AT32F413 Firmwary Library: Introduction

AT32F413 Firmwary Library 2.0.5
AT32F413 Peripherals Driver Library
Introduction

The AT32F413 Firmware Library is a firmware package which contains the device drivers for all of the peripherals for AT32F413.

This library provides a set of examples for each peripheral and some application such as the IAP and sLib utilities.

The mamual is structured as follows:

  • AT32F413_periph_driver : device drivers
  • AT32F413_periph_examples : examples for AT32F413
  • AT32F413_periph_template : AT32F413 project template for Keil and IAR IDE tools
  • AT32F413_board : AT-START-F413 board setting functions
  • AT32F413_middlewares_i2c_application_library : middlewares for I2C application
  • AT32F413_middlewares_usbd_class : middlewares for different USB device class
  • AT32F413_middlewares_usbd_drivers : middlewares for USB device core driver
  • UTILITIES_examples : some applications such as FreeRTOS, sLib and IAP.
Generated by doxygen 1.9.2


AT32F413 Firmwary Library: Modules

Modules
Here is a list of all modules:
[detail level 1234]
► CMSIS |
► AT32F413 |
Library_configuration_section |
Configuration_section_for_CMSIS |
Exported_types |
Exported_macro |
Peripheral_memory_map |
► AT32F413_system |
AT32F413_system_clock_stable_definition |
AT32F413_system_exported_variables |
AT32F413_system_exported_functions |
AT32F413_system_private_defines |
AT32F413_system_private_variables |
AT32F413_system_private_functions |
► AT32F413_periph_driver |
► ACC | ACC driver modules
ACC_exported_constants |
ACC_exported_types |
ACC_exported_functions |
ACC_private_functions |
► ADC | ADC driver modules
ADC_interrupts_definition | Adc interrupt
ADC_flags_definition | Adc flag
ADC_exported_types |
ADC_exported_functions |
ADC_private_functions |
► BPR | BPR driver modules
BPR_flags_definition | Bpr flag
BPR_exported_types |
BPR_exported_functions |
BPR_private_functions |
► CAN | CAN driver modules
CAN_timeout_count |
CAN_flags_definition | Can flag
CAN_interrupts_definition | Can interrupt
CAN_exported_types |
CAN_exported_functions |
CAN_private_functions |
► CRC | CRC driver modules
CRC_exported_types |
CRC_exported_functions |
CRC_private_functions |
► CRM | CRM driver modules
CRM_flags_definition | Crm flag
CRM_interrupts_definition | Crm interrupt
CRM_exported_types |
CRM_exported_functions |
CRM_private_functions |
► DEBUG | DEBUG driver modules
DEBUG_mode_definition |
DEBUG_exported_types |
DEBUG_exported_functions |
DEBUG_private_functions |
► DMA | DMA driver modules
DMA_interrupts_definition | Dma interrupt
DMA_flexible_channel |
DMA_flags_definition | Dma flag
DMA_exported_types |
DMA_exported_functions |
DMA_private_functions |
► EXINT | EXINT driver modules
EXINT_lines |
EXINT_exported_types |
EXINT_exported_functions |
EXINT_private_functions |
► FLASH | FLASH driver modules
FLASH_unlock_keys | Flash unlock keys
FLASH_spim_address | Flash spim address
FLASH_flags | Flash flag
FLASH_interrupts | Flash interrupts
FLASH_slib_mask | Flash slib mask
FLASH_user_system_data | Flash user system data
FLASH_timeout_definition | Flash timeout definition
FLASH_exported_types |
FLASH_exported_functions |
FLASH_private_functions |
► GPIO | GPIO driver modules
GPIO_pins_number_definition |
IOMUX_map_definition | Iomux map definitions
IOMUX_map2_definition | Iomux map2 definitions
IOMUX_map3_definition | Iomux map3 definitions
IOMUX_map4_definition | Iomux map4 definitions
IOMUX_map5_definition | Iomux map5 definitions
IOMUX_map6_definition | Iomux map6 definitions
IOMUX_map7_definition | Iomux map7 definitions
GPIO_exported_types |
GPIO_exported_functions |
GPIO_private_functions |
► I2C | I2C driver modules
I2C_sts1_flags_definition | I2c sts1 flag
I2C_sts2_flags_definition | I2c sts2 flag
I2C_interrupts_definition | I2c interrupt
I2C_exported_types |
I2C_exported_functions |
I2C_private_functions |
► MISC | MISC driver modules
MISC_vector_table_base_address |
MISC_exported_types |
MISC_exported_functions |
MISC_private_functions |
► PWC | PWC driver modules
PWC_flags_definition | Pwc flag
PWC_exported_types |
PWC_exported_functions |
PWC_private_functions |
► RTC | RTC driver modules
RTC_interrupts_definition | Rtc interrupt
RTC_flags_definition | Rtc flag
RTC_exported_types |
RTC_exported_functions |
RTC_private_functions |
► SDIO | SDIO driver modules
SDIO_interrupts_definition | Sdio interrupt
SDIO_flags_definition | Sdio flag
SDIO_exported_types |
SDIO_exported_functions |
SDIO_private_functions |
► SPI | SPI driver modules
SPI_I2S_flags_definition | Spi i2s flag
SPI_I2S_interrupts_definition | Spi i2s interrupt
SPI_exported_types |
SPI_exported_functions |
SPI_private_functions |
► TMR | TMR driver modules
TMR_flags_definition | Tmr flag
TMR_interrupt_select_type_definition | Tmr interrupt select type
TMR_exported_types |
TMR_exported_functions |
TMR_private_functions |
► USART | USART driver modules
USART_flags_definition | Usart flag
USART_interrupts_definition | Usart interrupt
USART_exported_types |
USART_exported_functions |
USART_private_functions |
► USB | USB driver modules
USB_interrupts_definition | Usb interrupt mask
USB_interrupt_flags_definition | Usb interrupt flag
USB_endpoint_register_bit_definition | Usb endpoint register bit define
USB_endpoint_tx_and_rx_status_definition | Usb endpoint tx and rx status
USB_device_endpoint_register_type_definition | Usb device endpoint register type define
USB_buffer_table_default_offset_address_definition | Usb buffer table default offset address
USB_packet_buffer_start_address_definition | Usb packet buffer start address
USB_exported_enum_types |
USB_macro_definition |
USB_exported_types |
USB_exported_functions |
USB_private_functions |
► WDT | WDT driver modules
WDT_flags_definition | Wdt flag
WDT_exported_types |
WDT_exported_functions |
WDT_private_functions |
► WWDT | WWDT driver modules
WWDT_enable_bit_definition | Wwdt enable bit
WWDT_exported_types |
WWDT_exported_functions |
WWDT_private_functions |
► AT32F413_middlewares_i2c_application_library |
I2C_library_event_check_flag |
I2C_library_transmission_mode |
I2C_library_status_code |
I2C_library_handler |
I2C_library_exported_functions |
► AT32F413_middlewares_usbd_class |
► USB_audio_class | Usb device class audio demo
USB_audio_class_private_functions |
USB_audio_class_definition |
USB_device_audio_config_definition |
► USB_audio_desc | Usb device audio descriptor
USB_audio_desc_private_functions |
USB_audio_desc_definition |
► USB_audio_hid_class | Usb device class audio hid demo
USB_device_audio_hid_config_definition |
USB_audio_hid_class_private_functions |
USB_audio_hid_class_definition |
► USB_audio_hid_desc | Usb device audio hid descriptor
USB_audio_hid_desc_private_functions |
USB_audio_hid_desc_definition |
► USB_cdc_class | Usb device class cdc demo
USB_cdc_class_private_functions |
USB_cdc_class_definition |
► USB_cdc_class_exported_types |
USB_msc_bot_scsi_definition |
USB_cdc_msc_class_exported_functions |
USB_cdc_class_exported_functions |
► USB_cdc_desc | Usb device cdc descriptor
USB_cdc_desc_private_functions |
USB_cdc_desc_definition |
► USB_cdc_keyboard_class | Usb device class composite cdc and keyboard
USB_cdc_keyboard_class_private_functions |
USB_cdc_keyboard_class_definition |
► USB_cdc_class_exported_types |
USB_msc_bot_scsi_definition |
USB_cdc_msc_class_exported_functions |
USB_cdc_keyboar_class_exported_functions |
► USB_cdc_keyboard_desc | Usb device cdc keyboard descriptor
USB_cdc_keyboard_desc_private_functions |
USB_cdc_keyboard_desc_definition |
► USB_cdc_msc_class | Usb device class cdc msc demo
USB_cdc_msc_class_private_functions |
USB_cdc_class_definition |
► USB_cdc_class_exported_types |
USB_msc_bot_scsi_definition |
USB_cdc_msc_class_exported_functions |
► USB_cdc_msc_desc | Usb device cdc msc descriptor
USB_cdc_msc_desc_private_functions |
USB_cdc_desc_definition |
► USB_msc_bot_scsi | Usb device class mass storage demo
USB_msc_bot_functions |
USB_msc_bot_scsi_definition |
► USB_custom_hid_class | Usb device custom hid demo
USB_custom_hid_class_private_functions |
USB_custom_hid_class_endpoint_definition |
USB_custom_hid_class_request_code_definition |
USB_custom_hid_class_exported_functions |
► USB_custom_hid_desc | Usb device custom_hid descriptor
USB_custom_hid_desc_private_functions |
USB_custom_hid_desc_definition |
► USB_hid_iap_class | Usb device class hid iap demo
USB_hid_iap_class_private_functions |
USB_hid_iap_class_definition |
► USB_hid_iap_desc | Usb device hid_iap descriptor
USB_hid_iap_desc_private_functions |
USB_hid_iap_desc_definition |
► USB_keyboard_class | Usb device keyboard demo
USB_keyboard_class_private_functions |
USB_keyboard_class_endpoint_definition |
USB_hid_class_exported_functions |
► USB_keyboard_desc | Usb device keyboard descriptor
USB_keyboard_desc_private_functions |
USB_keyboard_desc_definition |
► USB_mouse_class | Usb device mouse demo
USB_mouse_class_private_functions |
USB_mouse_class_endpoint_definition |
USB_mouse_class_request_code_definition |
USB_hid_class_exported_functions |
► USB_mouse_desc | Usb device mouse descriptor
USB_mouse_desc_private_functions |
USB_mouse_desc_definition |
► USB_msc_class | Usb device class msc demo
USB_msc_class_private_functions |
USB_msc_class_definition |
► USB_msc_desc | Usb device msc descriptor
USB_msc_desc_private_functions |
USB_msc_desc_definition |
► USB_printer_class | Usb device class printer demo
USB_printer_class_private_functions |
USB_printer_class_definition |
► USB_printer_desc | Usb device printer descriptor
USB_printer_desc_private_functions |
USB_printer_desc_definition |
► AT32F413_middlewares_usbd_drivers |
► USBD_drivers_core | Usb device drivers core
USBD_core_exported_types |
USBD_core_exported_functions |
USBD_core_private_functions |
► USBD_drivers_interrupt | Usb device interrupt
USBD_int_exported_functions |
USBD_int_private_functions |
► USBD_drivers_standard_request | Usb device standard_request
USBD_sdr_exported_functions |
USBD_sdr_private_functions |
► USB_standard |
USB_standard_define |
USB_standard_exported_types |
► AT32F413_board |
► BOARD | Onboard periph driver
BOARD_pins_definition |
BOARD_exported_functions |
► AT32F413_periph_examples |
ACC_calibration |
ADC_combine_mode_ordinary_simult |
ADC_current_vref_value_check |
ADC_exint_trigger_partitioned |
ADC_internal_temperature_sensor |
ADC_software_trigger_repeat |
ADC_tmr_trigger_automatic_preempted |
ADC_voltage_monitoring |
BPR_data |
BPR_tamper |
CAN_communication_mode |
CAN_filter |
CAN_loopback_mode |
CORTEX_m4_bit_band |
CORTEX_m4_cmsis_dsp |
► CORTEX_m4_fpu |
JULIA_fpu_functions |
CORTEX_m4_systick_interrupt |
CRC_calculation |
CRM_clock_failure_detection |
CRM_sysclk_switch |
DEBUG_tmr |
DMA_data_to_gpio_flexible |
DMA_flash_to_sram |
EXINT_config |
EXINT_software_trigger |
► FLASH_write_read |
FLASH_write_read_functions |
► FLASH_operate_spim |
FLASH_operate_spim_functions |
FLASH_run_in_spim |
GPIO_led_toggle |
GPIO_swjtag_remap |
I2C_communication_dma |
I2C_communication_int |
I2C_communication_poll |
I2C_eeprom |
I2S_halfduplex_dma |
I2S_halfduplex_interrupt |
I2S_spii2s_switch_halfduplex_polling |
PWC_deepsleep_rtc |
PWC_power_voltage_monitor |
PWC_sleep_tmr2 |
PWC_sleep_usart1 |
PWC_standby_rtc |
PWC_standby_wakeup_pin |
► RTC_calendar |
RTC_calendar_type |
RTC_calendar_exported_functions |
RTC_lick_calibration |
► SDIO_sd_mmc_card |
SDIO_sd_mmc_card_instance_definition |
SDIO_sd_mmc_card_exported_types |
SDIO_sd_mmc_card_command_index_definition |
SDIO_sd_mmc_card_paremeters_definition |
SDIO_sd_mmc_card_response_definition |
SDIO_sd_mmc_card_command_class_definition |
SDIO_sd_mmc_card_cmd8_definition |
SDIO_sd_mmc_card_mmc_extend_definition |
SDIO_sd_mmc_card_interrupt_flags_definition |
SDIO_sd_mmc_card_exported_functions |
► SDIO_sdio_fatfs |
SDIO_sdio_fatfs_instance_definition |
SDIO_sdio_fatfs_exported_types |
SDIO_sdio_fatfs_command_index_definition |
SDIO_sdio_fatfs_paremeters_definition |
SDIO_sdio_fatfs_response_definition |
SDIO_sdio_fatfs_command_class_definition |
SDIO_sdio_fatfs_cmd8_definition |
SDIO_sdio_fatfs_mmc_extend_definition |
SDIO_sdio_fatfs_interrupt_flags_definition |
SDIO_sdio_fatfs_exported_functions |
SPI_crc_transfer_polling |
SPI_fullduplex_polling |
SPI_halfduplex_interrupt |
SPI_halfduplex_transceiver_switch |
SPI_only_receive_mode_polling |
SPI_use_jtagpin_hardwarecs_dma |
► SPI_w25q_flash |
SPI_flash_cs_pin_definition |
SPI_flash_id_definition |
SPI_flash_operation_definition |
SPI_flash_exported_functions |
SRAM_extend_sram |
TMR_6_steps |
TMR_7_pwm_output |
TMR_cascade_synchro |
TMR_complementary_signals |
TMR_dma |
TMR_dma_burst |
TMR_encoder_tmr2 |
TMR_external_clock |
TMR_hall_xor_tmr2 |
TMR_hang_mode |
TMR_input_capture |
TMR_oc_high |
TMR_oc_low |
TMR_oc_toggle_tmr3 |
TMR_oc_toggle_tmr9 |
TMR_one_cycle |
TMR_parallel_synchro |
TMR_pwm_input |
TMR_pwm_input_dma |
TMR_pwm_output_simulate |
TMR_pwm_output_tmr10 |
TMR_pwm_output_tmr3 |
TMR_timer_base |
TMR_tmr1_synchro |
TMR_tmr2_32bit |
USART_half_duplex |
USART_hw_flow_control |
USART_idle_detection |
USART_interrupt |
USART_irda |
USART_polling |
USART_printf |
USART_receiver_mute |
F413_USART_rs485 |
USART_smartcard |
USART_synchronous |
USART_transfer_by_dma_interrupt |
USART_transfer_by_dma_polling |
► USB_device_audio |
USB_device_audio_codec_reg_definition |
USB_device_audio_codec_pin_definition |
USB_device_audio_codec_exported_functions |
► USB_device_audio_hid |
USB_device_audio_hid_codec_reg_definition |
USB_device_audio_hid_codec_pin_definition |
USB_device_audio_hid_codec_exported_functions |
USB_device_composite_vcp_keyboard |
USB_device_msc |
USB_device_composite_vcp_msc |
USB_device_custom_hid |
USB_device_keyboard |
USB_device_mouse |
USB_device_printer |
USB_device_vcp_loopback |
► USB_device_virtual_msc_iap |
USB_device_virtual_msc_iap_definition |
WDT_reset |
WDT_standby |
WWDT_reset |
_USB_device_hid_app_led3 |
_USB_device_hid_iap |
► AT32F413_periph_template |
Library_configuration |
System_clock_configuration |
LED_toggle |
► UTILITIES_examples |
FreeRTOS_demo |
► GEN_random_number_demo |
RTC_asseed_definition |
GEN_random_number_demo_exported_functions |
SLIB_project_l0 |
SLIB_project_l1 |
► USART_IAP_app_led3_toggle |
App_led3_definition |
App_led3_exported_functions |
► USART_IAP_app_led4_toggle |
App_led4_definition |
App_led4_exported_functions |
► USART_IAP_bootloader |
Bootloader_definition |
Bootloader_exported_functions |
Bootloader_exported_types |
► USB_IAP_app_led3_toggle |
App_led3_toggle_definition |
App_led3_toggle_exported_functions |
► USB_IAP_app_led4_toggle |
App_led4_toggle_definition |
App_led4_toggle_exported_functions |
► USB_IAP_bootloader |
Bootloader_definition |
Bootloader_exported_functions |


AT32F413 Firmwary Library: CMSIS

Modules
CMSIS

Modules

AT32F413
AT32F413_system

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: AT32F413

Modules
AT32F413
CMSIS

Modules

Library_configuration_section
Configuration_section_for_CMSIS
Exported_types
Exported_macro
Peripheral_memory_map

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: Library_configuration_section

Macros
Library_configuration_section
CMSIS » AT32F413

Macros

#define | __AT32F413_LIBRARY_VERSION_MAJOR (0x02)
at32f413 standard peripheral library version number More...
#define | __AT32F413_LIBRARY_VERSION_MIDDLE (0x00)
#define | __AT32F413_LIBRARY_VERSION_MINOR (0x05)
#define | __AT32F413_LIBRARY_VERSION_RC (0x00)
#define | __AT32F413_LIBRARY_VERSION

Detailed Description

Macro Definition Documentation

◆ __AT32F413_LIBRARY_VERSION

#define __AT32F413_LIBRARY_VERSION
Value:
((__AT32F413_LIBRARY_VERSION_MAJOR << 24) | \
(__AT32F413_LIBRARY_VERSION_MIDDLE << 16) | \
(__AT32F413_LIBRARY_VERSION_MINOR << 8) | \
(__AT32F413_LIBRARY_VERSION_RC))
__AT32F413_LIBRARY_VERSION_MIDDLE
#define __AT32F413_LIBRARY_VERSION_MIDDLE
Definition: at32f413.h:89
__AT32F413_LIBRARY_VERSION_RC
#define __AT32F413_LIBRARY_VERSION_RC
Definition: at32f413.h:91
__AT32F413_LIBRARY_VERSION_MAJOR
#define __AT32F413_LIBRARY_VERSION_MAJOR
at32f413 standard peripheral library version number
Definition: at32f413.h:88
__AT32F413_LIBRARY_VERSION_MINOR
#define __AT32F413_LIBRARY_VERSION_MINOR
Definition: at32f413.h:90

Definition at line 92 of file at32f413.h.

◆ __AT32F413_LIBRARY_VERSION_MAJOR

#define __AT32F413_LIBRARY_VERSION_MAJOR (0x02)

at32f413 standard peripheral library version number

tip: to avoid modifying this file each time you need to switch between these devices, you can define the device in your toolchain compiler preprocessor. [31:24] major version

Definition at line 88 of file at32f413.h.

◆ __AT32F413_LIBRARY_VERSION_MIDDLE

#define __AT32F413_LIBRARY_VERSION_MIDDLE (0x00)

[23:16] middle version

Definition at line 89 of file at32f413.h.

◆ __AT32F413_LIBRARY_VERSION_MINOR

#define __AT32F413_LIBRARY_VERSION_MINOR (0x05)

[15:8] minor version

Definition at line 90 of file at32f413.h.

◆ __AT32F413_LIBRARY_VERSION_RC

#define __AT32F413_LIBRARY_VERSION_RC (0x00)

[7:0] release candidate

Definition at line 91 of file at32f413.h.


AT32F413 Firmwary Library: Configuration_section_for_CMSIS

Macros | Typedefs | Enumerations
Configuration_section_for_CMSIS
CMSIS » AT32F413

Macros

#define | __CM4_REV 0x0001U
configuration of the cortex-m4 processor and core peripherals More...
#define | __MPU_PRESENT 1
#define | __NVIC_PRIO_BITS 4
#define | __Vendor_SysTickConfig 0
#define | __FPU_PRESENT 1U

Typedefs

typedef enum IRQn IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_section More...

Enumerations

enum IRQn {
Reset_IRQn = -15 , NonMaskableInt_IRQn = -14 , HardFault_IRQn = -13 , MemoryManagement_IRQn = -12 ,
BusFault_IRQn = -11 , UsageFault_IRQn = -10 , SVCall_IRQn = -5 , DebugMonitor_IRQn = -4 ,
PendSV_IRQn = -2 , SysTick_IRQn = -1 , WWDT_IRQn = 0 , PVM_IRQn = 1 ,
TAMPER_IRQn = 2 , RTC_IRQn = 3 , FLASH_IRQn = 4 , CRM_IRQn = 5 ,
EXINT0_IRQn = 6 , EXINT1_IRQn = 7 , EXINT2_IRQn = 8 , EXINT3_IRQn = 9 ,
EXINT4_IRQn = 10 , DMA1_Channel1_IRQn = 11 , DMA1_Channel2_IRQn = 12 , DMA1_Channel3_IRQn = 13 ,
DMA1_Channel4_IRQn = 14 , DMA1_Channel5_IRQn = 15 , DMA1_Channel6_IRQn = 16 , DMA1_Channel7_IRQn = 17 ,
ADC1_2_IRQn = 18 , USBFS_H_CAN1_TX_IRQn = 19 , USBFS_L_CAN1_RX0_IRQn = 20 , CAN1_RX1_IRQn = 21 ,
CAN1_SE_IRQn = 22 , EXINT9_5_IRQn = 23 , TMR1_BRK_TMR9_IRQn = 24 , TMR1_OVF_TMR10_IRQn = 25 ,
TMR1_TRG_HALL_TMR11_IRQn = 26 , TMR1_CH_IRQn = 27 , TMR2_GLOBAL_IRQn = 28 , TMR3_GLOBAL_IRQn = 29 ,
TMR4_GLOBAL_IRQn = 30 , I2C1_EVT_IRQn = 31 , I2C1_ERR_IRQn = 32 , I2C2_EVT_IRQn = 33 ,
I2C2_ERR_IRQn = 34 , SPI1_IRQn = 35 , SPI2_IRQn = 36 , USART1_IRQn = 37 ,
USART2_IRQn = 38 , USART3_IRQn = 39 , EXINT15_10_IRQn = 40 , RTCAlarm_IRQn = 41 ,
USBFSWakeUp_IRQn = 42 , TMR8_BRK_IRQn = 43 , TMR8_OVF_IRQn = 44 , TMR8_TRG_HALL_IRQn = 45 ,
TMR8_CH_IRQn = 46 , SDIO1_IRQn = 49 , TMR5_GLOBAL_IRQn = 50 , UART4_IRQn = 52 ,
UART5_IRQn = 53 , DMA2_Channel1_IRQn = 56 , DMA2_Channel2_IRQn = 57 , DMA2_Channel3_IRQn = 58 ,
DMA2_Channel4_5_IRQn = 59 , CAN2_TX_IRQn = 68 , CAN2_RX0_IRQn = 69 , CAN2_RX1_IRQn = 70 ,
CAN2_SE_IRQn = 71 , ACC_IRQn = 72 , USBFS_MAPH_IRQn = 73 , USBFS_MAPL_IRQn = 74 ,
DMA2_Channel6_7_IRQn = 75
}
at32f413 interrupt number definition, according to the selected device in Library_configuration_section More...

Detailed Description

Macro Definition Documentation

◆ __CM4_REV

#define __CM4_REV 0x0001U

configuration of the cortex-m4 processor and core peripherals

core revision r0p1

Definition at line 108 of file at32f413.h.

◆ __FPU_PRESENT

#define __FPU_PRESENT 1U

fpu present

Definition at line 112 of file at32f413.h.

◆ __MPU_PRESENT

#define __MPU_PRESENT 1

mpu present

Definition at line 109 of file at32f413.h.

◆ __NVIC_PRIO_BITS

#define __NVIC_PRIO_BITS 4

at32 uses 4 bits for the priority levels

Definition at line 110 of file at32f413.h.

◆ __Vendor_SysTickConfig

#define __Vendor_SysTickConfig 0

set to 1 if different systick config is used

Definition at line 111 of file at32f413.h.

Typedef Documentation

◆ IRQn_Type

typedef enum IRQn IRQn_Type

at32f413 interrupt number definition, according to the selected device in Library_configuration_section

Enumeration Type Documentation

◆ IRQn

enum IRQn

at32f413 interrupt number definition, according to the selected device in Library_configuration_section

Enumerator
Reset_IRQn | 1 reset vector, invoked on power up and warm reset
NonMaskableInt_IRQn | 2 non maskable interrupt
HardFault_IRQn | 3 hard fault, all classes of fault
MemoryManagement_IRQn | 4 cortex-m4 memory management interrupt
BusFault_IRQn | 5 cortex-m4 bus fault interrupt
UsageFault_IRQn | 6 cortex-m4 usage fault interrupt
SVCall_IRQn | 11 cortex-m4 sv call interrupt
DebugMonitor_IRQn | 12 cortex-m4 debug monitor interrupt
PendSV_IRQn | 14 cortex-m4 pend sv interrupt
SysTick_IRQn | 15 cortex-m4 system tick interrupt
WWDT_IRQn | window watchdog timer interrupt
PVM_IRQn | pvm through exint line detection interrupt
TAMPER_IRQn | tamper interrupt
RTC_IRQn | rtc global interrupt
FLASH_IRQn | flash global interrupt
CRM_IRQn | crm global interrupt
EXINT0_IRQn | external line0 interrupt
EXINT1_IRQn | external line1 interrupt
EXINT2_IRQn | external line2 interrupt
EXINT3_IRQn | external line3 interrupt
EXINT4_IRQn | external line4 interrupt
DMA1_Channel1_IRQn | dma1 channel 1 global interrupt
DMA1_Channel2_IRQn | dma1 channel 2 global interrupt
DMA1_Channel3_IRQn | dma1 channel 3 global interrupt
DMA1_Channel4_IRQn | dma1 channel 4 global interrupt
DMA1_Channel5_IRQn | dma1 channel 5 global interrupt
DMA1_Channel6_IRQn | dma1 channel 6 global interrupt
DMA1_Channel7_IRQn | dma1 channel 7 global interrupt
ADC1_2_IRQn | adc1 and adc2 global interrupt
USBFS_H_CAN1_TX_IRQn | usb device high priority or can1 tx interrupts
USBFS_L_CAN1_RX0_IRQn | usb device low priority or can1 rx0 interrupts
CAN1_RX1_IRQn | can1 rx1 interrupt
CAN1_SE_IRQn | can1 se interrupt
EXINT9_5_IRQn | external line[9:5] interrupts
TMR1_BRK_TMR9_IRQn | tmr1 brake interrupt
TMR1_OVF_TMR10_IRQn | tmr1 overflow interrupt
TMR1_TRG_HALL_TMR11_IRQn | tmr1 trigger and hall interrupt
TMR1_CH_IRQn | tmr1 channel interrupt
TMR2_GLOBAL_IRQn | tmr2 global interrupt
TMR3_GLOBAL_IRQn | tmr3 global interrupt
TMR4_GLOBAL_IRQn | tmr4 global interrupt
I2C1_EVT_IRQn | i2c1 event interrupt
I2C1_ERR_IRQn | i2c1 error interrupt
I2C2_EVT_IRQn | i2c2 event interrupt
I2C2_ERR_IRQn | i2c2 error interrupt
SPI1_IRQn | spi1 global interrupt
SPI2_IRQn | spi2 global interrupt
USART1_IRQn | usart1 global interrupt
USART2_IRQn | usart2 global interrupt
USART3_IRQn | usart3 global interrupt
EXINT15_10_IRQn | external line[15:10] interrupts
RTCAlarm_IRQn | rtc alarm through exint line interrupt
USBFSWakeUp_IRQn | usb device wakeup from suspend through exint line interrupt
TMR8_BRK_IRQn | tmr8 brake interrupt
TMR8_OVF_IRQn | tmr8 overflow interrupt
TMR8_TRG_HALL_IRQn | tmr8 trigger and hall interrupt
TMR8_CH_IRQn | tmr8 channel interrupt
SDIO1_IRQn | sdio1 global interrupt
TMR5_GLOBAL_IRQn | tmr5 global interrupt
UART4_IRQn | uart4 global interrupt
UART5_IRQn | uart5 global interrupt
DMA2_Channel1_IRQn | dma2 channel 1 global interrupt
DMA2_Channel2_IRQn | dma2 channel 2 global interrupt
DMA2_Channel3_IRQn | dma2 channel 3 global interrupt
DMA2_Channel4_5_IRQn | dma2 channel 4 and channel 5 global interrupt
CAN2_TX_IRQn | can2 tx interrupt
CAN2_RX0_IRQn | can2 rx0 interrupt
CAN2_RX1_IRQn | can2 rx1 interrupt
CAN2_SE_IRQn | can2 se interrupt
ACC_IRQn | acc interrupt
USBFS_MAPH_IRQn | usb map hp interrupt
USBFS_MAPL_IRQn | usb map lp interrupt
DMA2_Channel6_7_IRQn | dma2 channel 6 and channel 7 global interrupt

Definition at line 118 of file at32f413.h.


AT32F413 Firmwary Library: Exported_types

Typedefs | Enumerations
Exported_types
CMSIS » AT32F413

Typedefs

typedef int32_t | INT32
typedef int16_t | INT16
typedef int8_t | INT8
typedef uint32_t | UINT32
typedef uint16_t | UINT16
typedef uint8_t | UINT8
typedef int32_t | s32
typedef int16_t | s16
typedef int8_t | s8
typedef const int32_t | sc32
typedef const int16_t | sc16
typedef const int8_t | sc8
typedef __IO int32_t | vs32
typedef __IO int16_t | vs16
typedef __IO int8_t | vs8
typedef __I int32_t | vsc32
typedef __I int16_t | vsc16
typedef __I int8_t | vsc8
typedef uint32_t | u32
typedef uint16_t | u16
typedef uint8_t | u8
typedef const uint32_t | uc32
typedef const uint16_t | uc16
typedef const uint8_t | uc8
typedef __IO uint32_t | vu32
typedef __IO uint16_t | vu16
typedef __IO uint8_t | vu8
typedef __I uint32_t | vuc32
typedef __I uint16_t | vuc16
typedef __I uint8_t | vuc8

Enumerations

enum | flag_status { RESET = 0 , SET = !RESET }
flag status More...
enum | confirm_state { FALSE = 0 , TRUE = !FALSE }
confirm state More...
enum | error_status { ERROR = 0 , SUCCESS = !ERROR }
error status More...

Detailed Description

Typedef Documentation

◆ INT16

typedef int16_t INT16

Definition at line 213 of file at32f413.h.

◆ INT32

typedef int32_t INT32

Definition at line 212 of file at32f413.h.

◆ INT8

typedef int8_t INT8

Definition at line 214 of file at32f413.h.

◆ s16

typedef int16_t s16

Definition at line 220 of file at32f413.h.

◆ s32

typedef int32_t s32

Definition at line 219 of file at32f413.h.

◆ s8

typedef int8_t s8

Definition at line 221 of file at32f413.h.

◆ sc16

typedef const int16_t sc16

read only

Definition at line 224 of file at32f413.h.

◆ sc32

typedef const int32_t sc32

read only

Definition at line 223 of file at32f413.h.

◆ sc8

typedef const int8_t sc8

read only

Definition at line 225 of file at32f413.h.

◆ u16

typedef uint16_t u16

Definition at line 236 of file at32f413.h.

◆ u32

typedef uint32_t u32

Definition at line 235 of file at32f413.h.

◆ u8

typedef uint8_t u8

Definition at line 237 of file at32f413.h.

◆ uc16

typedef const uint16_t uc16

read only

Definition at line 240 of file at32f413.h.

◆ uc32

typedef const uint32_t uc32

read only

Definition at line 239 of file at32f413.h.

◆ uc8

typedef const uint8_t uc8

read only

Definition at line 241 of file at32f413.h.

◆ UINT16

typedef uint16_t UINT16

Definition at line 216 of file at32f413.h.

◆ UINT32

typedef uint32_t UINT32

Definition at line 215 of file at32f413.h.

◆ UINT8

typedef uint8_t UINT8

Definition at line 217 of file at32f413.h.

◆ vs16

typedef __IO int16_t vs16

Definition at line 228 of file at32f413.h.

◆ vs32

typedef __IO int32_t vs32

Definition at line 227 of file at32f413.h.

◆ vs8

typedef __IO int8_t vs8

Definition at line 229 of file at32f413.h.

◆ vsc16

typedef __I int16_t vsc16

read only

Definition at line 232 of file at32f413.h.

◆ vsc32

typedef __I int32_t vsc32

read only

Definition at line 231 of file at32f413.h.

◆ vsc8

typedef __I int8_t vsc8

read only

Definition at line 233 of file at32f413.h.

◆ vu16

typedef __IO uint16_t vu16

Definition at line 244 of file at32f413.h.

◆ vu32

typedef __IO uint32_t vu32

Definition at line 243 of file at32f413.h.

◆ vu8

typedef __IO uint8_t vu8

Definition at line 245 of file at32f413.h.

◆ vuc16

typedef __I uint16_t vuc16

read only

Definition at line 248 of file at32f413.h.

◆ vuc32

typedef __I uint32_t vuc32

read only

Definition at line 247 of file at32f413.h.

◆ vuc8

typedef __I uint8_t vuc8

read only

Definition at line 249 of file at32f413.h.

Enumeration Type Documentation

◆ confirm_state

enum confirm_state

confirm state

Enumerator
FALSE
TRUE

Definition at line 259 of file at32f413.h.

◆ error_status

enum error_status

error status

Enumerator
ERROR
SUCCESS

Definition at line 264 of file at32f413.h.

◆ flag_status

enum flag_status

flag status

Enumerator
RESET
SET

Definition at line 254 of file at32f413.h.


AT32F413 Firmwary Library: Exported_macro

Macros
Exported_macro
CMSIS » AT32F413

Macros

#define | REG8(addr) *(volatile uint8_t *)(addr)
#define | REG16(addr) *(volatile uint16_t *)(addr)
#define | REG32(addr) *(volatile uint32_t *)(addr)
#define | MAKE_VALUE(reg_offset, bit_num) (uint32_t)(((reg_offset) << 16) | (bit_num & 0x1F))
#define | PERIPH_REG(periph_base, value) REG32((periph_base + (value >> 16)))
#define | PERIPH_REG_BIT(value) (0x1U << (value & 0x1F))

Detailed Description

Macro Definition Documentation

◆ MAKE_VALUE

#define MAKE_VALUE | ( | reg_offset,
 |  | bit_num
 | ) | (uint32_t)(((reg_offset) << 16) | (bit_num & 0x1F))

Definition at line 278 of file at32f413.h.

◆ PERIPH_REG

#define PERIPH_REG | ( | periph_base,
 |  | value
 | ) | REG32((periph_base + (value >> 16)))

Definition at line 280 of file at32f413.h.

◆ PERIPH_REG_BIT

#define PERIPH_REG_BIT ( value ) (0x1U << (value & 0x1F))

Definition at line 281 of file at32f413.h.

◆ REG16

#define REG16 ( addr ) *(volatile uint16_t *)(addr)

Definition at line 275 of file at32f413.h.

◆ REG32

#define REG32 ( addr ) *(volatile uint32_t *)(addr)

Definition at line 276 of file at32f413.h.

◆ REG8

#define REG8 ( addr ) *(volatile uint8_t *)(addr)

Definition at line 274 of file at32f413.h.


AT32F413 Firmwary Library: Peripheral_memory_map

Macros
Peripheral_memory_map
CMSIS » AT32F413

Macros

#define | FLASH_BASE ((uint32_t)0x08000000)
#define | SPIM_FLASH_BASE ((uint32_t)0x08400000)
#define | USD_BASE ((uint32_t)0x1FFFF800)
#define | SRAM_BASE ((uint32_t)0x20000000)
#define | PERIPH_BASE ((uint32_t)0x40000000)
#define | XMC_REG_BASE ((uint32_t)0xA0000000)
#define | DEBUG_BASE ((uint32_t)0xE0042000)
#define | APB1PERIPH_BASE (PERIPH_BASE + 0x00000)
#define | APB2PERIPH_BASE (PERIPH_BASE + 0x10000)
#define | AHBPERIPH_BASE (PERIPH_BASE + 0x20000)
#define | TMR2_BASE (APB1PERIPH_BASE + 0x0000)
#define | TMR3_BASE (APB1PERIPH_BASE + 0x0400)
#define | TMR4_BASE (APB1PERIPH_BASE + 0x0800)
#define | TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
#define | RTC_BASE (APB1PERIPH_BASE + 0x2800)
#define | WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
#define | WDT_BASE (APB1PERIPH_BASE + 0x3000)
#define | SPI2_BASE (APB1PERIPH_BASE + 0x3800)
#define | USART2_BASE (APB1PERIPH_BASE + 0x4400)
#define | USART3_BASE (APB1PERIPH_BASE + 0x4800)
#define | UART4_BASE (APB1PERIPH_BASE + 0x4C00)
#define | UART5_BASE (APB1PERIPH_BASE + 0x5000)
#define | I2C1_BASE (APB1PERIPH_BASE + 0x5400)
#define | I2C2_BASE (APB1PERIPH_BASE + 0x5800)
#define | USBFS_BASE (APB1PERIPH_BASE + 0x5C00)
#define | CAN1_BASE (APB1PERIPH_BASE + 0x6400)
#define | CAN2_BASE (APB1PERIPH_BASE + 0x6800)
#define | BPR_BASE (APB1PERIPH_BASE + 0x6C00)
#define | PWC_BASE (APB1PERIPH_BASE + 0x7000)
#define | IOMUX_BASE (APB2PERIPH_BASE + 0x0000)
#define | EXINT_BASE (APB2PERIPH_BASE + 0x0400)
#define | GPIOA_BASE (APB2PERIPH_BASE + 0x0800)
#define | GPIOB_BASE (APB2PERIPH_BASE + 0x0C00)
#define | GPIOC_BASE (APB2PERIPH_BASE + 0x1000)
#define | GPIOD_BASE (APB2PERIPH_BASE + 0x1400)
#define | GPIOF_BASE (APB2PERIPH_BASE + 0x1C00)
#define | ADC1_BASE (APB2PERIPH_BASE + 0x2400)
#define | ADC2_BASE (APB2PERIPH_BASE + 0x2800)
#define | TMR1_BASE (APB2PERIPH_BASE + 0x2C00)
#define | SPI1_BASE (APB2PERIPH_BASE + 0x3000)
#define | TMR8_BASE (APB2PERIPH_BASE + 0x3400)
#define | USART1_BASE (APB2PERIPH_BASE + 0x3800)
#define | TMR9_BASE (APB2PERIPH_BASE + 0x4C00)
#define | TMR10_BASE (APB2PERIPH_BASE + 0x5000)
#define | TMR11_BASE (APB2PERIPH_BASE + 0x5400)
#define | ACC_BASE (APB2PERIPH_BASE + 0x5800)
#define | SDIO1_BASE (APB2PERIPH_BASE + 0x8000)
#define | DMA1_BASE (AHBPERIPH_BASE + 0x0000)
#define | DMA1_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0008)
#define | DMA1_CHANNEL2_BASE (AHBPERIPH_BASE + 0x001C)
#define | DMA1_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0030)
#define | DMA1_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0044)
#define | DMA1_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0058)
#define | DMA1_CHANNEL6_BASE (AHBPERIPH_BASE + 0x006C)
#define | DMA1_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0080)
#define | DMA2_BASE (AHBPERIPH_BASE + 0x0400)
#define | DMA2_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0408)
#define | DMA2_CHANNEL2_BASE (AHBPERIPH_BASE + 0x041C)
#define | DMA2_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0430)
#define | DMA2_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0444)
#define | DMA2_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0458)
#define | DMA2_CHANNEL6_BASE (AHBPERIPH_BASE + 0x046C)
#define | DMA2_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0480)
#define | CRM_BASE (AHBPERIPH_BASE + 0x1000)
#define | FLASH_REG_BASE (AHBPERIPH_BASE + 0x2000)
#define | CRC_BASE (AHBPERIPH_BASE + 0x3000)

Detailed Description

Macro Definition Documentation

◆ ACC_BASE

#define ACC_BASE (APB2PERIPH_BASE + 0x5800)

Definition at line 340 of file at32f413.h.

◆ ADC1_BASE

#define ADC1_BASE (APB2PERIPH_BASE + 0x2400)

Definition at line 331 of file at32f413.h.

◆ ADC2_BASE

#define ADC2_BASE (APB2PERIPH_BASE + 0x2800)

Definition at line 332 of file at32f413.h.

◆ AHBPERIPH_BASE

#define AHBPERIPH_BASE (PERIPH_BASE + 0x20000)

Definition at line 301 of file at32f413.h.

◆ APB1PERIPH_BASE

#define APB1PERIPH_BASE (PERIPH_BASE + 0x00000)

Definition at line 299 of file at32f413.h.

◆ APB2PERIPH_BASE

#define APB2PERIPH_BASE (PERIPH_BASE + 0x10000)

Definition at line 300 of file at32f413.h.

◆ BPR_BASE

#define BPR_BASE (APB1PERIPH_BASE + 0x6C00)

Definition at line 321 of file at32f413.h.

◆ CAN1_BASE

#define CAN1_BASE (APB1PERIPH_BASE + 0x6400)

Definition at line 319 of file at32f413.h.

◆ CAN2_BASE

#define CAN2_BASE (APB1PERIPH_BASE + 0x6800)

Definition at line 320 of file at32f413.h.

◆ CRC_BASE

#define CRC_BASE (AHBPERIPH_BASE + 0x3000)

Definition at line 361 of file at32f413.h.

◆ CRM_BASE

#define CRM_BASE (AHBPERIPH_BASE + 0x1000)

Definition at line 359 of file at32f413.h.

◆ DEBUG_BASE

#define DEBUG_BASE ((uint32_t)0xE0042000)

Definition at line 297 of file at32f413.h.

◆ DMA1_BASE

#define DMA1_BASE (AHBPERIPH_BASE + 0x0000)

Definition at line 343 of file at32f413.h.

◆ DMA1_CHANNEL1_BASE

#define DMA1_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0008)

Definition at line 344 of file at32f413.h.

◆ DMA1_CHANNEL2_BASE

#define DMA1_CHANNEL2_BASE (AHBPERIPH_BASE + 0x001C)

Definition at line 345 of file at32f413.h.

◆ DMA1_CHANNEL3_BASE

#define DMA1_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0030)

Definition at line 346 of file at32f413.h.

◆ DMA1_CHANNEL4_BASE

#define DMA1_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0044)

Definition at line 347 of file at32f413.h.

◆ DMA1_CHANNEL5_BASE

#define DMA1_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0058)

Definition at line 348 of file at32f413.h.

◆ DMA1_CHANNEL6_BASE

#define DMA1_CHANNEL6_BASE (AHBPERIPH_BASE + 0x006C)

Definition at line 349 of file at32f413.h.

◆ DMA1_CHANNEL7_BASE

#define DMA1_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0080)

Definition at line 350 of file at32f413.h.

◆ DMA2_BASE

#define DMA2_BASE (AHBPERIPH_BASE + 0x0400)

Definition at line 351 of file at32f413.h.

◆ DMA2_CHANNEL1_BASE

#define DMA2_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0408)

Definition at line 352 of file at32f413.h.

◆ DMA2_CHANNEL2_BASE

#define DMA2_CHANNEL2_BASE (AHBPERIPH_BASE + 0x041C)

Definition at line 353 of file at32f413.h.

◆ DMA2_CHANNEL3_BASE

#define DMA2_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0430)

Definition at line 354 of file at32f413.h.

◆ DMA2_CHANNEL4_BASE

#define DMA2_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0444)

Definition at line 355 of file at32f413.h.

◆ DMA2_CHANNEL5_BASE

#define DMA2_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0458)

Definition at line 356 of file at32f413.h.

◆ DMA2_CHANNEL6_BASE

#define DMA2_CHANNEL6_BASE (AHBPERIPH_BASE + 0x046C)

Definition at line 357 of file at32f413.h.

◆ DMA2_CHANNEL7_BASE

#define DMA2_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0480)

Definition at line 358 of file at32f413.h.

◆ EXINT_BASE

#define EXINT_BASE (APB2PERIPH_BASE + 0x0400)

Definition at line 325 of file at32f413.h.

◆ FLASH_BASE

#define FLASH_BASE ((uint32_t)0x08000000)

Definition at line 291 of file at32f413.h.

◆ FLASH_REG_BASE

#define FLASH_REG_BASE (AHBPERIPH_BASE + 0x2000)

Definition at line 360 of file at32f413.h.

◆ GPIOA_BASE

#define GPIOA_BASE (APB2PERIPH_BASE + 0x0800)

Definition at line 326 of file at32f413.h.

◆ GPIOB_BASE

#define GPIOB_BASE (APB2PERIPH_BASE + 0x0C00)

Definition at line 327 of file at32f413.h.

◆ GPIOC_BASE

#define GPIOC_BASE (APB2PERIPH_BASE + 0x1000)

Definition at line 328 of file at32f413.h.

◆ GPIOD_BASE

#define GPIOD_BASE (APB2PERIPH_BASE + 0x1400)

Definition at line 329 of file at32f413.h.

◆ GPIOF_BASE

#define GPIOF_BASE (APB2PERIPH_BASE + 0x1C00)

Definition at line 330 of file at32f413.h.

◆ I2C1_BASE

#define I2C1_BASE (APB1PERIPH_BASE + 0x5400)

Definition at line 316 of file at32f413.h.

◆ I2C2_BASE

#define I2C2_BASE (APB1PERIPH_BASE + 0x5800)

Definition at line 317 of file at32f413.h.

◆ IOMUX_BASE

#define IOMUX_BASE (APB2PERIPH_BASE + 0x0000)

Definition at line 324 of file at32f413.h.

◆ PERIPH_BASE

#define PERIPH_BASE ((uint32_t)0x40000000)

Definition at line 295 of file at32f413.h.

◆ PWC_BASE

#define PWC_BASE (APB1PERIPH_BASE + 0x7000)

Definition at line 322 of file at32f413.h.

◆ RTC_BASE

#define RTC_BASE (APB1PERIPH_BASE + 0x2800)

Definition at line 308 of file at32f413.h.

◆ SDIO1_BASE

#define SDIO1_BASE (APB2PERIPH_BASE + 0x8000)

Definition at line 341 of file at32f413.h.

◆ SPI1_BASE

#define SPI1_BASE (APB2PERIPH_BASE + 0x3000)

Definition at line 334 of file at32f413.h.

◆ SPI2_BASE

#define SPI2_BASE (APB1PERIPH_BASE + 0x3800)

Definition at line 311 of file at32f413.h.

◆ SPIM_FLASH_BASE

#define SPIM_FLASH_BASE ((uint32_t)0x08400000)

Definition at line 292 of file at32f413.h.

◆ SRAM_BASE

#define SRAM_BASE ((uint32_t)0x20000000)

Definition at line 294 of file at32f413.h.

◆ TMR10_BASE

#define TMR10_BASE (APB2PERIPH_BASE + 0x5000)

Definition at line 338 of file at32f413.h.

◆ TMR11_BASE

#define TMR11_BASE (APB2PERIPH_BASE + 0x5400)

Definition at line 339 of file at32f413.h.

◆ TMR1_BASE

#define TMR1_BASE (APB2PERIPH_BASE + 0x2C00)

Definition at line 333 of file at32f413.h.

◆ TMR2_BASE

#define TMR2_BASE (APB1PERIPH_BASE + 0x0000)

Definition at line 304 of file at32f413.h.

◆ TMR3_BASE

#define TMR3_BASE (APB1PERIPH_BASE + 0x0400)

Definition at line 305 of file at32f413.h.

◆ TMR4_BASE

#define TMR4_BASE (APB1PERIPH_BASE + 0x0800)

Definition at line 306 of file at32f413.h.

◆ TMR5_BASE

#define TMR5_BASE (APB1PERIPH_BASE + 0x0C00)

Definition at line 307 of file at32f413.h.

◆ TMR8_BASE

#define TMR8_BASE (APB2PERIPH_BASE + 0x3400)

Definition at line 335 of file at32f413.h.

◆ TMR9_BASE

#define TMR9_BASE (APB2PERIPH_BASE + 0x4C00)

Definition at line 337 of file at32f413.h.

◆ UART4_BASE

#define UART4_BASE (APB1PERIPH_BASE + 0x4C00)

Definition at line 314 of file at32f413.h.

◆ UART5_BASE

#define UART5_BASE (APB1PERIPH_BASE + 0x5000)

Definition at line 315 of file at32f413.h.

◆ USART1_BASE

#define USART1_BASE (APB2PERIPH_BASE + 0x3800)

Definition at line 336 of file at32f413.h.

◆ USART2_BASE

#define USART2_BASE (APB1PERIPH_BASE + 0x4400)

Definition at line 312 of file at32f413.h.

◆ USART3_BASE

#define USART3_BASE (APB1PERIPH_BASE + 0x4800)

Definition at line 313 of file at32f413.h.

◆ USBFS_BASE

#define USBFS_BASE (APB1PERIPH_BASE + 0x5C00)

Definition at line 318 of file at32f413.h.

◆ USD_BASE

#define USD_BASE ((uint32_t)0x1FFFF800)

Definition at line 293 of file at32f413.h.

◆ WDT_BASE

#define WDT_BASE (APB1PERIPH_BASE + 0x3000)

Definition at line 310 of file at32f413.h.

◆ WWDT_BASE

#define WWDT_BASE (APB1PERIPH_BASE + 0x2C00)

Definition at line 309 of file at32f413.h.

◆ XMC_REG_BASE

#define XMC_REG_BASE ((uint32_t)0xA0000000)

Definition at line 296 of file at32f413.h.


AT32F413 Firmwary Library: AT32F413_system

Modules
AT32F413_system
CMSIS

Modules

AT32F413_system_clock_stable_definition
AT32F413_system_exported_variables
AT32F413_system_exported_functions
AT32F413_system_private_defines
AT32F413_system_private_variables
AT32F413_system_private_functions

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: AT32F413_system_clock_stable_definition

Macros
AT32F413_system_clock_stable_definition
CMSIS » AT32F413_system

Macros

#define | HEXT_STABLE_DELAY (5000u)
#define | PLL_STABLE_DELAY (500u)

Detailed Description

Macro Definition Documentation

◆ HEXT_STABLE_DELAY

#define HEXT_STABLE_DELAY (5000u)

Definition at line 46 of file system_at32f413.h.

◆ PLL_STABLE_DELAY

#define PLL_STABLE_DELAY (500u)

Definition at line 47 of file system_at32f413.h.


AT32F413 Firmwary Library: AT32F413_system_exported_variables

Variables
AT32F413_system_exported_variables
CMSIS » AT32F413_system

Variables

unsigned int system_core_clock

Detailed Description

Variable Documentation

◆ system_core_clock

unsigned int system_core_clock
extern

system clock frequency (core clock)

value of the high speed internal clock in hz system clock frequency (core clock)

Definition at line 48 of file system_at32f413.c.

Referenced by delay_init(), DMA1_Channel2_IRQHandler(), main(), mclk_tmr1_init(), sd_init(), sd_power_on(), system_core_clock_update(), tmr1_config(), TMR3_GLOBAL_IRQHandler(), and usb_clock48m_select().


AT32F413 Firmwary Library: AT32F413_system_exported_functions

Functions
AT32F413_system_exported_functions
CMSIS » AT32F413_system

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Detailed Description

Function Documentation

◆ system_core_clock_update()

void system_core_clock_update ( void )

update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters.

Parameters
none
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 112 of file system_at32f413.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ SystemInit()

void SystemInit ( void )

setup the microcontroller system initialize the flash interface.

Note
this function should be used only after reset.
Parameters
none
Return values
none

< vector table base offset field. this value must be a multiple of 0x200.

Definition at line 64 of file system_at32f413.c.


AT32F413 Firmwary Library: AT32F413_system_private_defines

Macros
AT32F413_system_private_defines
CMSIS » AT32F413_system

Macros

#define VECT_TAB_OFFSET 0x0

Detailed Description

Macro Definition Documentation

◆ VECT_TAB_OFFSET

#define VECT_TAB_OFFSET 0x0

vector table base offset field. this value must be a multiple of 0x200.

Definition at line 40 of file system_at32f413.c.


AT32F413 Firmwary Library: AT32F413_system_private_variables

Variables
AT32F413_system_private_variables
CMSIS » AT32F413_system

Variables

unsigned int system_core_clock = ((uint32_t)8000000)

Detailed Description

Variable Documentation

◆ system_core_clock

unsigned int system_core_clock = ((uint32_t)8000000)

value of the high speed internal clock in hz system clock frequency (core clock)

Definition at line 48 of file system_at32f413.c.

Referenced by delay_init(), DMA1_Channel2_IRQHandler(), main(), mclk_tmr1_init(), sd_init(), sd_power_on(), system_core_clock_update(), tmr1_config(), TMR3_GLOBAL_IRQHandler(), and usb_clock48m_select().


AT32F413 Firmwary Library: AT32F413_system_private_functions

Functions
AT32F413_system_private_functions
CMSIS » AT32F413_system

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Detailed Description

Function Documentation

◆ system_core_clock_update()

void system_core_clock_update ( void )

update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters.

Parameters
none
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 112 of file system_at32f413.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ SystemInit()

void SystemInit ( void )

setup the microcontroller system initialize the flash interface.

Note
this function should be used only after reset.
Parameters
none
Return values
none

< vector table base offset field. this value must be a multiple of 0x200.

Definition at line 64 of file system_at32f413.c.


AT32F413 Firmwary Library: AT32F413_periph_driver

Modules
AT32F413_periph_driver

Modules

ACC
ACC driver modules.
ADC
ADC driver modules.
BPR
BPR driver modules.
CAN
CAN driver modules.
CRC
CRC driver modules.
CRM
CRM driver modules.
DEBUG
DEBUG driver modules.
DMA
DMA driver modules.
EXINT
EXINT driver modules.
FLASH
FLASH driver modules.
GPIO
GPIO driver modules.
I2C
I2C driver modules.
MISC
MISC driver modules.
PWC
PWC driver modules.
RTC
RTC driver modules.
SDIO
SDIO driver modules.
SPI
SPI driver modules.
TMR
TMR driver modules.
USART
USART driver modules.
USB
USB driver modules.
WDT
WDT driver modules.
WWDT
WWDT driver modules.

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: ACC

Modules | Macros
ACC
AT32F413_periph_driver

ACC driver modules. More...

Modules

ACC_exported_constants
ACC_exported_types
ACC_exported_functions
ACC_private_functions

Macros

#define ACC ((acc_type *) ACC_BASE)

Detailed Description

ACC driver modules.

Macro Definition Documentation

◆ ACC

#define ACC ((acc_type *) ACC_BASE)

Definition at line 166 of file at32f413_acc.h.


AT32F413 Firmwary Library: ACC_exported_constants

Macros
ACC_exported_constants
AT32F413_periph_driver » ACC

Macros

#define | ACC_CAL_HICKCAL ((uint16_t)0x0000)
#define | ACC_CAL_HICKTRIM ((uint16_t)0x0002)
#define | ACC_RSLOST_FLAG ((uint16_t)0x0002)
#define | ACC_CALRDY_FLAG ((uint16_t)0x0001)
#define | ACC_CALRDYIEN_INT ((uint16_t)0x0020)
#define | ACC_EIEN_INT ((uint16_t)0x0010)

Detailed Description

Macro Definition Documentation

◆ ACC_CAL_HICKCAL

#define ACC_CAL_HICKCAL ((uint16_t)0x0000)

acc hick calibration

Definition at line 52 of file at32f413_acc.h.

◆ ACC_CAL_HICKTRIM

#define ACC_CAL_HICKTRIM ((uint16_t)0x0002)

acc hick trim

Definition at line 53 of file at32f413_acc.h.

◆ ACC_CALRDY_FLAG

#define ACC_CALRDY_FLAG ((uint16_t)0x0001)

acc internal high-speed clock calibration ready error flag

Definition at line 56 of file at32f413_acc.h.

◆ ACC_CALRDYIEN_INT

#define ACC_CALRDYIEN_INT ((uint16_t)0x0020)

acc internal high-speed clock calibration ready interrupt enable

Definition at line 58 of file at32f413_acc.h.

◆ ACC_EIEN_INT

#define ACC_EIEN_INT ((uint16_t)0x0010)

acc reference signal lost interrupt enable

Definition at line 59 of file at32f413_acc.h.

◆ ACC_RSLOST_FLAG

#define ACC_RSLOST_FLAG ((uint16_t)0x0002)

acc reference signal lost error flag

Definition at line 55 of file at32f413_acc.h.


AT32F413 Firmwary Library: ACC_exported_types

Data Structures
ACC_exported_types
AT32F413_periph_driver » ACC

Data Structures

struct acc_type
type define acc register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: acc_type Struct Reference

Data Fields
acc_type Struct Reference
AT32F413_periph_driver » ACC » ACC_exported_types

type define acc register all More...

#include <at32f413_acc.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t calrdy: 1
__IO uint32_t rslost: 1
__IO uint32_t reserved1: 30
} sts_bit
};
acc sts register, offset:0x00 More...
union {
__IO uint32_t ctrl1
struct {
__IO uint32_t calon: 1
__IO uint32_t entrim: 1
__IO uint32_t reserved1: 2
__IO uint32_t eien: 1
__IO uint32_t calrdyien: 1
__IO uint32_t reserved2: 2
__IO uint32_t step: 4
__IO uint32_t reserved3: 20
} ctrl1_bit
};
acc ctrl1 register, offset:0x04 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t hickcal: 8
__IO uint32_t hicktrim: 6
__IO uint32_t reserved1: 18
} ctrl2_bit
};
acc ctrl2 register, offset:0x08 More...
union {
__IO uint32_t c1
struct {
__IO uint32_t c1: 16
__IO uint32_t reserved1: 16
} c1_bit
};
acc acc_c1 register, offset:0x0C More...
union {
__IO uint32_t c2
struct {
__IO uint32_t c2: 16
__IO uint32_t reserved1: 16
} c2_bit
};
acc acc_c2 register, offset:0x10 More...
union {
__IO uint32_t c3
struct {
__IO uint32_t c3: 16
__IO uint32_t reserved1: 16
} c3_bit
};
acc acc_c3 register, offset:0x14 More...

Detailed Description

type define acc register all

Definition at line 72 of file at32f413_acc.h.

Field Documentation

◆

union { ... } acc_type::@1

acc sts register, offset:0x00

◆

union { ... } acc_type::@11

acc acc_c3 register, offset:0x14

◆

union { ... } acc_type::@3

acc ctrl1 register, offset:0x04

◆

union { ... } acc_type::@5

acc ctrl2 register, offset:0x08

◆

union { ... } acc_type::@7

acc acc_c1 register, offset:0x0C

◆

union { ... } acc_type::@9

acc acc_c2 register, offset:0x10

◆ c1

__IO uint32_t acc_type::c1

Definition at line 127 of file at32f413_acc.h.

◆

struct { ... } acc_type::c1_bit

◆ c2

__IO uint32_t acc_type::c2

Definition at line 140 of file at32f413_acc.h.

◆

struct { ... } acc_type::c2_bit

◆ c3

__IO uint32_t acc_type::c3

Definition at line 153 of file at32f413_acc.h.

◆

struct { ... } acc_type::c3_bit

◆ calon

__IO uint32_t acc_type::calon

Definition at line 97 of file at32f413_acc.h.

◆ calrdy

__IO uint32_t acc_type::calrdy

Definition at line 83 of file at32f413_acc.h.

◆ calrdyien

__IO uint32_t acc_type::calrdyien

Definition at line 101 of file at32f413_acc.h.

◆ ctrl1

__IO uint32_t acc_type::ctrl1

Definition at line 94 of file at32f413_acc.h.

◆

struct { ... } acc_type::ctrl1_bit

◆ ctrl2

__IO uint32_t acc_type::ctrl2

Definition at line 113 of file at32f413_acc.h.

◆

struct { ... } acc_type::ctrl2_bit

◆ eien

__IO uint32_t acc_type::eien

Definition at line 100 of file at32f413_acc.h.

◆ entrim

__IO uint32_t acc_type::entrim

Definition at line 98 of file at32f413_acc.h.

◆ hickcal

__IO uint32_t acc_type::hickcal

Definition at line 116 of file at32f413_acc.h.

◆ hicktrim

__IO uint32_t acc_type::hicktrim

Definition at line 117 of file at32f413_acc.h.

◆ reserved1

__IO uint32_t acc_type::reserved1

Definition at line 85 of file at32f413_acc.h.

◆ reserved2

__IO uint32_t acc_type::reserved2

Definition at line 102 of file at32f413_acc.h.

◆ reserved3

__IO uint32_t acc_type::reserved3

Definition at line 104 of file at32f413_acc.h.

◆ rslost

__IO uint32_t acc_type::rslost

Definition at line 84 of file at32f413_acc.h.

◆ step

__IO uint32_t acc_type::step

Definition at line 103 of file at32f413_acc.h.

◆ sts

__IO uint32_t acc_type::sts

Definition at line 80 of file at32f413_acc.h.

◆

struct { ... } acc_type::sts_bit
The documentation for this struct was generated from the following file:
  • at32f413_acc.h


AT32F413 Firmwary Library: ACC_exported_functions

Functions
ACC_exported_functions
AT32F413_periph_driver » ACC

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

Function Documentation

◆ acc_calibration_mode_enable()

void acc_calibration_mode_enable | ( | uint16_t | acc_trim,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the acc calibration mode.

Parameters
acc_trim specifies the acc calibration type. this parameter can be one of the following values:
  • ACC_CAL_HICKCAL
  • ACC_CAL_HICKTRIM
new_state specifies the acc calibration to be enabled or disabled.(TRUE or FALSE)
Return values
none

< acc hick calibration

Definition at line 53 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_flag_clear()

void acc_flag_clear ( uint16_t acc_flag )

clear the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
none

Definition at line 201 of file at32f413_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_flag_get()

flag_status acc_flag_get ( uint16_t acc_flag )

check whether the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be one of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
flag_status (SET or RESET)

< acc internal high-speed clock calibration ready error flag

Definition at line 185 of file at32f413_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_hickcal_get()

uint8_t acc_hickcal_get ( void )

return the current acc hickcal value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 112 of file at32f413_acc.c.

◆ acc_hicktrim_get()

uint8_t acc_hicktrim_get ( void )

return the current acc hicktrim value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 102 of file at32f413_acc.c.

◆ acc_interrupt_enable()

void acc_interrupt_enable | ( | uint16_t | acc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified acc interrupts.

Parameters
acc_int specifies the acc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ACC_CALRDYIEN_INT
  • ACC_EIEN_INT
new_state (TRUE or FALSE)
Return values
none

< acc internal high-speed clock calibration ready interrupt enable

Definition at line 85 of file at32f413_acc.c.

Referenced by main().

◆ acc_read_c1()

uint16_t acc_read_c1 ( void )

return the current acc c1 value.

Parameters
none
Return values
16-bit c1 value.

Definition at line 152 of file at32f413_acc.c.

◆ acc_read_c2()

uint16_t acc_read_c2 ( void )

return the current acc c2 value.

Parameters
none
Return values
16-bit c2 value.

Definition at line 162 of file at32f413_acc.c.

◆ acc_read_c3()

uint16_t acc_read_c3 ( void )

return the current acc c3 value.

Parameters
none
Return values
16-bit c3 value.

Definition at line 172 of file at32f413_acc.c.

◆ acc_step_set()

void acc_step_set ( uint8_t step_value )

store calibration step data in acc's ctrl1 register.

Parameters
step_value value to be stored in the acc's ctrl1 register
Return values
none

Definition at line 71 of file at32f413_acc.c.

◆ acc_write_c1()

void acc_write_c1 ( uint16_t acc_c1_value )

wtire the value to acc c1 register.

Parameters
acc_c1_value
Return values
none.

Definition at line 122 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c2()

void acc_write_c2 ( uint16_t acc_c2_value )

wtire the value to acc c2 register.

Parameters
acc_c2_value
Return values
none.

Definition at line 132 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c3()

void acc_write_c3 ( uint16_t acc_c3_value )

wtire the value to acc c3 register.

Parameters
acc_c3_value
Return values
none.

Definition at line 142 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().


AT32F413 Firmwary Library: ACC_private_functions

Functions
ACC_private_functions
AT32F413_periph_driver » ACC

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

Function Documentation

◆ acc_calibration_mode_enable()

void acc_calibration_mode_enable | ( | uint16_t | acc_trim,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the acc calibration mode.

Parameters
acc_trim specifies the acc calibration type. this parameter can be one of the following values:
  • ACC_CAL_HICKCAL
  • ACC_CAL_HICKTRIM
new_state specifies the acc calibration to be enabled or disabled.(TRUE or FALSE)
Return values
none

< acc hick calibration

Definition at line 53 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_flag_clear()

void acc_flag_clear ( uint16_t acc_flag )

clear the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be any combination of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
none

Definition at line 201 of file at32f413_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_flag_get()

flag_status acc_flag_get ( uint16_t acc_flag )

check whether the specified acc flag is set or not.

Parameters
acc_flag specifies the flag to check. this parameter can be one of the following values:
  • ACC_RSLOST_FLAG
  • ACC_CALRDY_FLAG
Return values
flag_status (SET or RESET)

< acc internal high-speed clock calibration ready error flag

Definition at line 185 of file at32f413_acc.c.

Referenced by ACC_IRQHandler().

◆ acc_hickcal_get()

uint8_t acc_hickcal_get ( void )

return the current acc hickcal value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 112 of file at32f413_acc.c.

◆ acc_hicktrim_get()

uint8_t acc_hicktrim_get ( void )

return the current acc hicktrim value.

Parameters
none
Return values
8-bit hicktrim value.

Definition at line 102 of file at32f413_acc.c.

◆ acc_interrupt_enable()

void acc_interrupt_enable | ( | uint16_t | acc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified acc interrupts.

Parameters
acc_int specifies the acc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ACC_CALRDYIEN_INT
  • ACC_EIEN_INT
new_state (TRUE or FALSE)
Return values
none

< acc internal high-speed clock calibration ready interrupt enable

Definition at line 85 of file at32f413_acc.c.

Referenced by main().

◆ acc_read_c1()

uint16_t acc_read_c1 ( void )

return the current acc c1 value.

Parameters
none
Return values
16-bit c1 value.

Definition at line 152 of file at32f413_acc.c.

◆ acc_read_c2()

uint16_t acc_read_c2 ( void )

return the current acc c2 value.

Parameters
none
Return values
16-bit c2 value.

Definition at line 162 of file at32f413_acc.c.

◆ acc_read_c3()

uint16_t acc_read_c3 ( void )

return the current acc c3 value.

Parameters
none
Return values
16-bit c3 value.

Definition at line 172 of file at32f413_acc.c.

◆ acc_step_set()

void acc_step_set ( uint8_t step_value )

store calibration step data in acc's ctrl1 register.

Parameters
step_value value to be stored in the acc's ctrl1 register
Return values
none

Definition at line 71 of file at32f413_acc.c.

◆ acc_write_c1()

void acc_write_c1 ( uint16_t acc_c1_value )

wtire the value to acc c1 register.

Parameters
acc_c1_value
Return values
none.

Definition at line 122 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c2()

void acc_write_c2 ( uint16_t acc_c2_value )

wtire the value to acc c2 register.

Parameters
acc_c2_value
Return values
none.

Definition at line 132 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().

◆ acc_write_c3()

void acc_write_c3 ( uint16_t acc_c3_value )

wtire the value to acc c3 register.

Parameters
acc_c3_value
Return values
none.

Definition at line 142 of file at32f413_acc.c.

Referenced by main(), and usb_clock48m_select().


AT32F413 Firmwary Library: ADC

Modules | Macros
ADC
AT32F413_periph_driver

ADC driver modules. More...

Modules

ADC_interrupts_definition
adc interrupt
ADC_flags_definition
adc flag
ADC_exported_types
ADC_exported_functions
ADC_private_functions

Macros

#define | ADC1 ((adc_type *) ADC1_BASE)
#define | ADC2 ((adc_type *) ADC2_BASE)

Detailed Description

ADC driver modules.

Macro Definition Documentation

◆ ADC1

#define ADC1 ((adc_type *) ADC1_BASE)

Definition at line 559 of file at32f413_adc.h.

◆ ADC2

#define ADC2 ((adc_type *) ADC2_BASE)

Definition at line 560 of file at32f413_adc.h.


AT32F413 Firmwary Library: ADC_interrupts_definition

Macros
ADC_interrupts_definition
AT32F413_periph_driver » ADC

adc interrupt More...

Macros

#define | ADC_CCE_INT ((uint32_t)0x00000020)
#define | ADC_VMOR_INT ((uint32_t)0x00000040)
#define | ADC_PCCE_INT ((uint32_t)0x00000080)

Detailed Description

adc interrupt

Macro Definition Documentation

◆ ADC_CCE_INT

#define ADC_CCE_INT ((uint32_t)0x00000020)

channels conversion end interrupt

Definition at line 52 of file at32f413_adc.h.

◆ ADC_PCCE_INT

#define ADC_PCCE_INT ((uint32_t)0x00000080)

preempt channels conversion end interrupt

Definition at line 54 of file at32f413_adc.h.

◆ ADC_VMOR_INT

#define ADC_VMOR_INT ((uint32_t)0x00000040)

voltage monitoring out of range interrupt

Definition at line 53 of file at32f413_adc.h.


AT32F413 Firmwary Library: ADC_flags_definition

Macros
ADC_flags_definition
AT32F413_periph_driver » ADC

adc flag More...

Macros

#define | ADC_VMOR_FLAG ((uint8_t)0x01)
#define | ADC_CCE_FLAG ((uint8_t)0x02)
#define | ADC_PCCE_FLAG ((uint8_t)0x04)
#define | ADC_PCCS_FLAG ((uint8_t)0x08)
#define | ADC_OCCS_FLAG ((uint8_t)0x10)

Detailed Description

adc flag

Macro Definition Documentation

◆ ADC_CCE_FLAG

#define ADC_CCE_FLAG ((uint8_t)0x02)

channels conversion end flag

Definition at line 66 of file at32f413_adc.h.

◆ ADC_OCCS_FLAG

#define ADC_OCCS_FLAG ((uint8_t)0x10)

ordinary channel conversion start flag

Definition at line 69 of file at32f413_adc.h.

◆ ADC_PCCE_FLAG

#define ADC_PCCE_FLAG ((uint8_t)0x04)

preempt channels conversion end flag

Definition at line 67 of file at32f413_adc.h.

◆ ADC_PCCS_FLAG

#define ADC_PCCS_FLAG ((uint8_t)0x08)

preempt channel conversion start flag

Definition at line 68 of file at32f413_adc.h.

◆ ADC_VMOR_FLAG

#define ADC_VMOR_FLAG ((uint8_t)0x01)

voltage monitoring out of range flag

Definition at line 65 of file at32f413_adc.h.


AT32F413 Firmwary Library: ADC_exported_types

Data Structures | Enumerations
ADC_exported_types
AT32F413_periph_driver » ADC

Data Structures

struct | adc_base_config_type
adc base config type More...
struct | adc_type
type define adc register all More...

Enumerations

enum adc_combine_mode_type {
ADC_INDEPENDENT_MODE = 0x00 , ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE = 0x01 , ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE = 0x02 , ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE = 0x03 ,
ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE = 0x04 , ADC_PREEMPT_SMLT_ONLY_MODE = 0x05 , ADC_ORDINARY_SMLT_ONLY_MODE = 0x06 , ADC_ORDINARY_SHORTSHIFT_ONLY_MODE = 0x07 ,
ADC_ORDINARY_LONGSHIFT_ONLY_MODE = 0x08 , ADC_PREEMPT_INTERLTRIG_ONLY_MODE = 0x09
}
adc combine mode type(these options are reserved in adc2) More...
enum | adc_data_align_type { ADC_RIGHT_ALIGNMENT = 0x00 , ADC_LEFT_ALIGNMENT = 0x01 }
adc data align type More...
enum adc_channel_select_type {
ADC_CHANNEL_0 = 0x00 , ADC_CHANNEL_1 = 0x01 , ADC_CHANNEL_2 = 0x02 , ADC_CHANNEL_3 = 0x03 ,
ADC_CHANNEL_4 = 0x04 , ADC_CHANNEL_5 = 0x05 , ADC_CHANNEL_6 = 0x06 , ADC_CHANNEL_7 = 0x07 ,
ADC_CHANNEL_8 = 0x08 , ADC_CHANNEL_9 = 0x09 , ADC_CHANNEL_10 = 0x0A , ADC_CHANNEL_11 = 0x0B ,
ADC_CHANNEL_12 = 0x0C , ADC_CHANNEL_13 = 0x0D , ADC_CHANNEL_14 = 0x0E , ADC_CHANNEL_15 = 0x0F ,
ADC_CHANNEL_16 = 0x10 , ADC_CHANNEL_17 = 0x11
}
adc channel select type More...
enum adc_sampletime_select_type {
ADC_SAMPLETIME_1_5 = 0x00 , ADC_SAMPLETIME_7_5 = 0x01 , ADC_SAMPLETIME_13_5 = 0x02 , ADC_SAMPLETIME_28_5 = 0x03 ,
ADC_SAMPLETIME_41_5 = 0x04 , ADC_SAMPLETIME_55_5 = 0x05 , ADC_SAMPLETIME_71_5 = 0x06 , ADC_SAMPLETIME_239_5 = 0x07
}
adc sampletime select type More...
enum adc_ordinary_trig_select_type {
ADC12_ORDINARY_TRIG_TMR1CH1 = 0x00 , ADC12_ORDINARY_TRIG_TMR1CH2 = 0x01 , ADC12_ORDINARY_TRIG_TMR1CH3 = 0x02 , ADC12_ORDINARY_TRIG_TMR2CH2 = 0x03 ,
ADC12_ORDINARY_TRIG_TMR3TRGOUT = 0x04 , ADC12_ORDINARY_TRIG_TMR4CH4 = 0x05 , ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT = 0x06 , ADC12_ORDINARY_TRIG_SOFTWARE = 0x07 ,
ADC12_ORDINARY_TRIG_TMR1TRGOUT = 0x0D , ADC12_ORDINARY_TRIG_TMR8CH1 = 0x0E , ADC12_ORDINARY_TRIG_TMR8CH2 = 0x0F
}
adc ordinary group trigger event select type More...
enum adc_preempt_trig_select_type {
ADC12_PREEMPT_TRIG_TMR1TRGOUT = 0x00 , ADC12_PREEMPT_TRIG_TMR1CH4 = 0x01 , ADC12_PREEMPT_TRIG_TMR2TRGOUT = 0x02 , ADC12_PREEMPT_TRIG_TMR2CH1 = 0x03 ,
ADC12_PREEMPT_TRIG_TMR3CH4 = 0x04 , ADC12_PREEMPT_TRIG_TMR4TRGOUT = 0x05 , ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 = 0x06 , ADC12_PREEMPT_TRIG_SOFTWARE = 0x07 ,
ADC12_PREEMPT_TRIG_TMR1CH1 = 0x0D , ADC12_PREEMPT_TRIG_TMR8CH1 = 0x0E , ADC12_PREEMPT_TRIG_TMR8TRGOUT = 0x0F
}
adc preempt group trigger event select type More...
enum | adc_preempt_channel_type { ADC_PREEMPT_CHANNEL_1 = 0x00 , ADC_PREEMPT_CHANNEL_2 = 0x01 , ADC_PREEMPT_CHANNEL_3 = 0x02 , ADC_PREEMPT_CHANNEL_4 = 0x03 }
adc preempt channel type More...
enum adc_voltage_monitoring_type {
ADC_VMONITOR_SINGLE_ORDINARY = 0x00800200 , ADC_VMONITOR_SINGLE_PREEMPT = 0x00400200 , ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT = 0x00C00200 , ADC_VMONITOR_ALL_ORDINARY = 0x00800000 ,
ADC_VMONITOR_ALL_PREEMPT = 0x00400000 , ADC_VMONITOR_ALL_ORDINARY_PREEMPT = 0x00C00000 , ADC_VMONITOR_NONE = 0x00000000
}
adc voltage_monitoring type More...

Detailed Description

Enumeration Type Documentation

◆ adc_channel_select_type

enum adc_channel_select_type

adc channel select type

Enumerator
ADC_CHANNEL_0 | adc channel 0
ADC_CHANNEL_1 | adc channel 1
ADC_CHANNEL_2 | adc channel 2
ADC_CHANNEL_3 | adc channel 3
ADC_CHANNEL_4 | adc channel 4
ADC_CHANNEL_5 | adc channel 5
ADC_CHANNEL_6 | adc channel 6
ADC_CHANNEL_7 | adc channel 7
ADC_CHANNEL_8 | adc channel 8
ADC_CHANNEL_9 | adc channel 9
ADC_CHANNEL_10 | adc channel 10
ADC_CHANNEL_11 | adc channel 11
ADC_CHANNEL_12 | adc channel 12
ADC_CHANNEL_13 | adc channel 13
ADC_CHANNEL_14 | adc channel 14
ADC_CHANNEL_15 | adc channel 15
ADC_CHANNEL_16 | adc channel 16
ADC_CHANNEL_17 | adc channel 17

Definition at line 108 of file at32f413_adc.h.

◆ adc_combine_mode_type

enum adc_combine_mode_type

adc combine mode type(these options are reserved in adc2)

Enumerator
ADC_INDEPENDENT_MODE | independent mode
ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE | combined ordinary simultaneous + preempt simultaneous mode
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE | combined ordinary simultaneous + preempt interleaved trigger mode
ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE | combined ordinary short shifting + preempt simultaneous mode
ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE | combined ordinary long shifting + preempt simultaneous mode
ADC_PREEMPT_SMLT_ONLY_MODE | preempt simultaneous mode only
ADC_ORDINARY_SMLT_ONLY_MODE | ordinary simultaneous mode only
ADC_ORDINARY_SHORTSHIFT_ONLY_MODE | ordinary short shifting mode only
ADC_ORDINARY_LONGSHIFT_ONLY_MODE | slow interleaved mode only
ADC_PREEMPT_INTERLTRIG_ONLY_MODE | alternate trigger mode only

Definition at line 82 of file at32f413_adc.h.

◆ adc_data_align_type

enum adc_data_align_type

adc data align type

Enumerator
ADC_RIGHT_ALIGNMENT | data right alignment
ADC_LEFT_ALIGNMENT | data left alignment

Definition at line 99 of file at32f413_adc.h.

◆ adc_ordinary_trig_select_type

enum adc_ordinary_trig_select_type

adc ordinary group trigger event select type

Enumerator
ADC12_ORDINARY_TRIG_TMR1CH1 | timer1 ch1 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR1CH2 | timer1 ch2 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR1CH3 | timer1 ch3 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR2CH2 | timer2 ch2 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR3TRGOUT | timer3 trgout event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR4CH4 | timer4 ch4 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT | exint line11/timer8 trgout event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_SOFTWARE | software(OCSWTRG) control bit as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR1TRGOUT | timer1 trgout event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR8CH1 | timer8 ch1 event as trigger source of adc1/adc2 ordinary sequence
ADC12_ORDINARY_TRIG_TMR8CH2 | timer8 ch2 event as trigger source of adc1/adc2 ordinary sequence

Definition at line 148 of file at32f413_adc.h.

◆ adc_preempt_channel_type

enum adc_preempt_channel_type

adc preempt channel type

Enumerator
ADC_PREEMPT_CHANNEL_1 | adc preempt channel 1
ADC_PREEMPT_CHANNEL_2 | adc preempt channel 2
ADC_PREEMPT_CHANNEL_3 | adc preempt channel 3
ADC_PREEMPT_CHANNEL_4 | adc preempt channel 4

Definition at line 186 of file at32f413_adc.h.

◆ adc_preempt_trig_select_type

enum adc_preempt_trig_select_type

adc preempt group trigger event select type

Enumerator
ADC12_PREEMPT_TRIG_TMR1TRGOUT | timer1 trgout event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR1CH4 | timer1 ch4 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR2TRGOUT | timer2 trgout event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR2CH1 | timer2 ch1 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR3CH4 | timer3 ch4 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR4TRGOUT | timer4 trgout event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 | exint line15/timer8 ch4 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_SOFTWARE | software(PCSWTRG) control bit as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR1CH1 | timer1 ch1 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR8CH1 | timer8 ch1 event as trigger source of adc1/adc2 preempt sequence
ADC12_PREEMPT_TRIG_TMR8TRGOUT | timer8 trgout event as trigger source of adc1/adc2 preempt sequence

Definition at line 167 of file at32f413_adc.h.

◆ adc_sampletime_select_type

enum adc_sampletime_select_type

adc sampletime select type

Enumerator
ADC_SAMPLETIME_1_5 | adc sample time 1.5 cycle
ADC_SAMPLETIME_7_5 | adc sample time 7.5 cycle
ADC_SAMPLETIME_13_5 | adc sample time 13.5 cycle
ADC_SAMPLETIME_28_5 | adc sample time 28.5 cycle
ADC_SAMPLETIME_41_5 | adc sample time 41.5 cycle
ADC_SAMPLETIME_55_5 | adc sample time 55.5 cycle
ADC_SAMPLETIME_71_5 | adc sample time 71.5 cycle
ADC_SAMPLETIME_239_5 | adc sample time 239.5 cycle

Definition at line 133 of file at32f413_adc.h.

◆ adc_voltage_monitoring_type

enum adc_voltage_monitoring_type

adc voltage_monitoring type

Enumerator
ADC_VMONITOR_SINGLE_ORDINARY | voltage_monitoring on a single ordinary channel
ADC_VMONITOR_SINGLE_PREEMPT | voltage_monitoring on a single preempt channel
ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT | voltage_monitoring on a single ordinary or preempt channel
ADC_VMONITOR_ALL_ORDINARY | voltage_monitoring on all ordinary channel
ADC_VMONITOR_ALL_PREEMPT | voltage_monitoring on all preempt channel
ADC_VMONITOR_ALL_ORDINARY_PREEMPT | voltage_monitoring on all ordinary and preempt channel
ADC_VMONITOR_NONE | no channel guarded by the voltage_monitoring

Definition at line 197 of file at32f413_adc.h.


AT32F413 Firmwary Library: adc_base_config_type Struct Reference

Data Fields
adc_base_config_type Struct Reference
AT32F413_periph_driver » ADC » ADC_exported_types

adc base config type More...

#include <at32f413_adc.h>

Data Fields

confirm_state sequence_mode
confirm_state repeat_mode
adc_data_align_type data_align
uint8_t ordinary_channel_length

Detailed Description

adc base config type

Definition at line 211 of file at32f413_adc.h.

Field Documentation

◆ data_align

adc_data_align_type adc_base_config_type::data_align

adc data alignment

Definition at line 215 of file at32f413_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), and adc_config().

◆ ordinary_channel_length

uint8_t adc_base_config_type::ordinary_channel_length

adc ordinary channel sequence length

Definition at line 216 of file at32f413_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), and adc_config().

◆ repeat_mode

confirm_state adc_base_config_type::repeat_mode

adc repeat mode

Definition at line 214 of file at32f413_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), and adc_config().

◆ sequence_mode

confirm_state adc_base_config_type::sequence_mode

adc sequence mode

Definition at line 213 of file at32f413_adc.h.

Referenced by adc_base_config(), adc_base_default_para_init(), and adc_config().

The documentation for this struct was generated from the following file:
  • at32f413_adc.h


AT32F413 Firmwary Library: adc_type Struct Reference

Data Fields
adc_type Struct Reference
AT32F413_periph_driver » ADC » ADC_exported_types

type define adc register all More...

#include <at32f413_adc.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t vmor: 1
__IO uint32_t cce: 1
__IO uint32_t pcce: 1
__IO uint32_t pccs: 1
__IO uint32_t occs: 1
__IO uint32_t reserved1: 27
} sts_bit
};
adc sts register, offset:0x00 More...
union {
__IO uint32_t ctrl1
struct {
__IO uint32_t vmcsel: 5
__IO uint32_t cceien: 1
__IO uint32_t vmorien: 1
__IO uint32_t pcceien: 1
__IO uint32_t sqen: 1
__IO uint32_t vmsgen: 1
__IO uint32_t pcautoen: 1
__IO uint32_t ocpen: 1
__IO uint32_t pcpen: 1
__IO uint32_t ocpcnt: 3
__IO uint32_t mssel: 4
__IO uint32_t reserved1: 2
__IO uint32_t pcvmen: 1
__IO uint32_t ocvmen: 1
__IO uint32_t reserved2: 8
} ctrl1_bit
};
adc ctrl1 register, offset:0x04 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t adcen: 1
__IO uint32_t rpen: 1
__IO uint32_t adcal: 1
__IO uint32_t adcalinit: 1
__IO uint32_t reserved1: 4
__IO uint32_t ocdmaen: 1
__IO uint32_t reserved2: 2
__IO uint32_t dtalign: 1
__IO uint32_t pctesel_l: 3
__IO uint32_t pcten: 1
__IO uint32_t reserved3: 1
__IO uint32_t octesel_l: 3
__IO uint32_t octen: 1
__IO uint32_t pcswtrg: 1
__IO uint32_t ocswtrg: 1
__IO uint32_t itsrven: 1
__IO uint32_t pctesel_h: 1
__IO uint32_t octesel_h: 1
__IO uint32_t reserved4: 6
} ctrl2_bit
};
adc ctrl2 register, offset:0x08 More...
union {
__IO uint32_t spt1
struct {
__IO uint32_t cspt10: 3
__IO uint32_t cspt11: 3
__IO uint32_t cspt12: 3
__IO uint32_t cspt13: 3
__IO uint32_t cspt14: 3
__IO uint32_t cspt15: 3
__IO uint32_t cspt16: 3
__IO uint32_t cspt17: 3
__IO uint32_t reserved1: 8
} spt1_bit
};
adc spt1 register, offset:0x0C More...
union {
__IO uint32_t spt2
struct {
__IO uint32_t cspt0: 3
__IO uint32_t cspt1: 3
__IO uint32_t cspt2: 3
__IO uint32_t cspt3: 3
__IO uint32_t cspt4: 3
__IO uint32_t cspt5: 3
__IO uint32_t cspt6: 3
__IO uint32_t cspt7: 3
__IO uint32_t cspt8: 3
__IO uint32_t cspt9: 3
__IO uint32_t reserved1: 2
} spt2_bit
};
adc spt2 register, offset:0x10 More...
union {
__IO uint32_t pcdto1
struct {
__IO uint32_t pcdto1: 12
__IO uint32_t reserved1: 20
} pcdto1_bit
};
adc pcdto1 register, offset:0x14 More...
union {
__IO uint32_t pcdto2
struct {
__IO uint32_t pcdto2: 12
__IO uint32_t reserved1: 20
} pcdto2_bit
};
adc pcdto2 register, offset:0x18 More...
union {
__IO uint32_t pcdto3
struct {
__IO uint32_t pcdto3: 12
__IO uint32_t reserved1: 20
} pcdto3_bit
};
adc pcdto3 register, offset:0x1C More...
union {
__IO uint32_t pcdto4
struct {
__IO uint32_t pcdto4: 12
__IO uint32_t reserved1: 20
} pcdto4_bit
};
adc pcdto4 register, offset:0x20 More...
union {
__IO uint32_t vmhb
struct {
__IO uint32_t vmhb: 12
__IO uint32_t reserved1: 20
} vmhb_bit
};
adc vmhb register, offset:0x24 More...
union {
__IO uint32_t vmlb
struct {
__IO uint32_t vmlb: 12
__IO uint32_t reserved1: 20
} vmlb_bit
};
adc vmlb register, offset:0x28 More...
union {
__IO uint32_t osq1
struct {
__IO uint32_t osn13: 5
__IO uint32_t osn14: 5
__IO uint32_t osn15: 5
__IO uint32_t osn16: 5
__IO uint32_t oclen: 4
__IO uint32_t reserved1: 8
} osq1_bit
};
adc osq1 register, offset:0x2C More...
union {
__IO uint32_t osq2
struct {
__IO uint32_t osn7: 5
__IO uint32_t osn8: 5
__IO uint32_t osn9: 5
__IO uint32_t osn10: 5
__IO uint32_t osn11: 5
__IO uint32_t osn12: 5
__IO uint32_t reserved1: 2
} osq2_bit
};
adc osq2 register, offset:0x30 More...
union {
__IO uint32_t osq3
struct {
__IO uint32_t osn1: 5
__IO uint32_t osn2: 5
__IO uint32_t osn3: 5
__IO uint32_t osn4: 5
__IO uint32_t osn5: 5
__IO uint32_t osn6: 5
__IO uint32_t reserved1: 2
} osq3_bit
};
adc osq3 register, offset:0x34 More...
union {
__IO uint32_t psq
struct {
__IO uint32_t psn1: 5
__IO uint32_t psn2: 5
__IO uint32_t psn3: 5
__IO uint32_t psn4: 5
__IO uint32_t pclen: 2
__IO uint32_t reserved1: 10
} psq_bit
};
adc psq register, offset:0x38 More...
union {
__IO uint32_t pdt1
struct {
__IO uint32_t pdt1: 16
__IO uint32_t reserved1: 16
} pdt1_bit
};
adc pdt1 register, offset:0x3C More...
union {
__IO uint32_t pdt2
struct {
__IO uint32_t pdt2: 16
__IO uint32_t reserved1: 16
} pdt2_bit
};
adc pdt2 register, offset:0x40 More...
union {
__IO uint32_t pdt3
struct {
__IO uint32_t pdt3: 16
__IO uint32_t reserved1: 16
} pdt3_bit
};
adc pdt3 register, offset:0x44 More...
union {
__IO uint32_t pdt4
struct {
__IO uint32_t pdt4: 16
__IO uint32_t reserved1: 16
} pdt4_bit
};
adc pdt4 register, offset:0x48 More...
union {
__IO uint32_t odt
struct {
__IO uint32_t odt: 16
__IO uint32_t adc2odt: 16
} odt_bit
};
adc odt register, offset:0x4C More...

Detailed Description

type define adc register all

Definition at line 222 of file at32f413_adc.h.

Field Documentation

◆

union { ... } adc_type::@19

adc sts register, offset:0x00

◆

union { ... } adc_type::@21

adc ctrl1 register, offset:0x04

◆

union { ... } adc_type::@23

adc ctrl2 register, offset:0x08

◆

union { ... } adc_type::@25

adc spt1 register, offset:0x0C

◆

union { ... } adc_type::@27

adc spt2 register, offset:0x10

◆

union { ... } adc_type::@29

adc pcdto1 register, offset:0x14

◆

union { ... } adc_type::@31

adc pcdto2 register, offset:0x18

◆

union { ... } adc_type::@33

adc pcdto3 register, offset:0x1C

◆

union { ... } adc_type::@35

adc pcdto4 register, offset:0x20

◆

union { ... } adc_type::@37

adc vmhb register, offset:0x24

◆

union { ... } adc_type::@39

adc vmlb register, offset:0x28

◆

union { ... } adc_type::@41

adc osq1 register, offset:0x2C

◆

union { ... } adc_type::@43

adc osq2 register, offset:0x30

◆

union { ... } adc_type::@45

adc osq3 register, offset:0x34

◆

union { ... } adc_type::@47

adc psq register, offset:0x38

◆

union { ... } adc_type::@49

adc pdt1 register, offset:0x3C

◆

union { ... } adc_type::@51

adc pdt2 register, offset:0x40

◆

union { ... } adc_type::@53

adc pdt3 register, offset:0x44

◆

union { ... } adc_type::@55

adc pdt4 register, offset:0x48

◆

union { ... } adc_type::@57

adc odt register, offset:0x4C

◆ adc2odt

__IO uint32_t adc_type::adc2odt

Definition at line 549 of file at32f413_adc.h.

◆ adcal

__IO uint32_t adc_type::adcal

Definition at line 278 of file at32f413_adc.h.

Referenced by adc_calibration_start(), and adc_calibration_status_get().

◆ adcalinit

__IO uint32_t adc_type::adcalinit

Definition at line 279 of file at32f413_adc.h.

Referenced by adc_calibration_init(), and adc_calibration_init_status_get().

◆ adcen

__IO uint32_t adc_type::adcen

Definition at line 276 of file at32f413_adc.h.

Referenced by adc_enable().

◆ cce

__IO uint32_t adc_type::cce

Definition at line 234 of file at32f413_adc.h.

◆ cceien

__IO uint32_t adc_type::cceien

Definition at line 251 of file at32f413_adc.h.

◆ cspt0

__IO uint32_t adc_type::cspt0

Definition at line 326 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt1

__IO uint32_t adc_type::cspt1

Definition at line 327 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt10

__IO uint32_t adc_type::cspt10

Definition at line 306 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt11

__IO uint32_t adc_type::cspt11

Definition at line 307 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt12

__IO uint32_t adc_type::cspt12

Definition at line 308 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt13

__IO uint32_t adc_type::cspt13

Definition at line 309 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt14

__IO uint32_t adc_type::cspt14

Definition at line 310 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt15

__IO uint32_t adc_type::cspt15

Definition at line 311 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt16

__IO uint32_t adc_type::cspt16

Definition at line 312 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt17

__IO uint32_t adc_type::cspt17

Definition at line 313 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt2

__IO uint32_t adc_type::cspt2

Definition at line 328 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt3

__IO uint32_t adc_type::cspt3

Definition at line 329 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt4

__IO uint32_t adc_type::cspt4

Definition at line 330 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt5

__IO uint32_t adc_type::cspt5

Definition at line 331 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt6

__IO uint32_t adc_type::cspt6

Definition at line 332 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt7

__IO uint32_t adc_type::cspt7

Definition at line 333 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt8

__IO uint32_t adc_type::cspt8

Definition at line 334 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ cspt9

__IO uint32_t adc_type::cspt9

Definition at line 335 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ ctrl1

__IO uint32_t adc_type::ctrl1

Definition at line 247 of file at32f413_adc.h.

Referenced by adc_interrupt_enable(), and adc_voltage_monitor_enable().

◆

struct { ... } adc_type::ctrl1_bit

Referenced by adc_base_config(), adc_ordinary_part_count_set(), adc_ordinary_part_mode_enable(), adc_preempt_auto_mode_enable(), adc_preempt_part_mode_enable(), adc_voltage_monitor_enable(), and adc_voltage_monitor_single_channel_select().

◆ ctrl2

__IO uint32_t adc_type::ctrl2

Definition at line 273 of file at32f413_adc.h.

◆

struct { ... } adc_type::ctrl2_bit

Referenced by adc_base_config(), adc_calibration_init(), adc_calibration_init_status_get(), adc_calibration_start(), adc_calibration_status_get(), adc_dma_mode_enable(), adc_enable(), adc_ordinary_conversion_trigger_set(), adc_ordinary_software_trigger_enable(), adc_ordinary_software_trigger_status_get(), adc_preempt_conversion_trigger_set(), adc_preempt_software_trigger_enable(), and adc_preempt_software_trigger_status_get().

◆ dtalign

__IO uint32_t adc_type::dtalign

Definition at line 283 of file at32f413_adc.h.

Referenced by adc_base_config().

◆ itsrven

__IO uint32_t adc_type::itsrven

Definition at line 291 of file at32f413_adc.h.

◆ mssel

__IO uint32_t adc_type::mssel

Definition at line 260 of file at32f413_adc.h.

◆ occs

__IO uint32_t adc_type::occs

Definition at line 237 of file at32f413_adc.h.

◆ ocdmaen

__IO uint32_t adc_type::ocdmaen

Definition at line 281 of file at32f413_adc.h.

Referenced by adc_dma_mode_enable().

◆ oclen

__IO uint32_t adc_type::oclen

Definition at line 430 of file at32f413_adc.h.

Referenced by adc_base_config().

◆ ocpcnt

__IO uint32_t adc_type::ocpcnt

Definition at line 259 of file at32f413_adc.h.

Referenced by adc_ordinary_part_count_set().

◆ ocpen

__IO uint32_t adc_type::ocpen

Definition at line 257 of file at32f413_adc.h.

Referenced by adc_ordinary_part_mode_enable().

◆ ocswtrg

__IO uint32_t adc_type::ocswtrg

Definition at line 290 of file at32f413_adc.h.

Referenced by adc_ordinary_software_trigger_enable(), and adc_ordinary_software_trigger_status_get().

◆ octen

__IO uint32_t adc_type::octen

Definition at line 288 of file at32f413_adc.h.

Referenced by adc_ordinary_conversion_trigger_set().

◆ octesel_h

__IO uint32_t adc_type::octesel_h

Definition at line 293 of file at32f413_adc.h.

Referenced by adc_ordinary_conversion_trigger_set().

◆ octesel_l

__IO uint32_t adc_type::octesel_l

Definition at line 287 of file at32f413_adc.h.

Referenced by adc_ordinary_conversion_trigger_set().

◆ ocvmen

__IO uint32_t adc_type::ocvmen

Definition at line 263 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_enable().

◆ odt

__IO uint32_t adc_type::odt

Definition at line 545 of file at32f413_adc.h.

Referenced by adc_ordinary_conversion_data_get().

◆

struct { ... } adc_type::odt_bit

Referenced by adc_ordinary_conversion_data_get().

◆ osn1

__IO uint32_t adc_type::osn1

Definition at line 461 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn10

__IO uint32_t adc_type::osn10

Definition at line 446 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn11

__IO uint32_t adc_type::osn11

Definition at line 447 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn12

__IO uint32_t adc_type::osn12

Definition at line 448 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn13

__IO uint32_t adc_type::osn13

Definition at line 426 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn14

__IO uint32_t adc_type::osn14

Definition at line 427 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn15

__IO uint32_t adc_type::osn15

Definition at line 428 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn16

__IO uint32_t adc_type::osn16

Definition at line 429 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn2

__IO uint32_t adc_type::osn2

Definition at line 462 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn3

__IO uint32_t adc_type::osn3

Definition at line 463 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn4

__IO uint32_t adc_type::osn4

Definition at line 464 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn5

__IO uint32_t adc_type::osn5

Definition at line 465 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn6

__IO uint32_t adc_type::osn6

Definition at line 466 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn7

__IO uint32_t adc_type::osn7

Definition at line 443 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn8

__IO uint32_t adc_type::osn8

Definition at line 444 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osn9

__IO uint32_t adc_type::osn9

Definition at line 445 of file at32f413_adc.h.

Referenced by adc_ordinary_channel_set().

◆ osq1

__IO uint32_t adc_type::osq1

Definition at line 423 of file at32f413_adc.h.

◆

struct { ... } adc_type::osq1_bit

Referenced by adc_base_config(), and adc_ordinary_channel_set().

◆ osq2

__IO uint32_t adc_type::osq2

Definition at line 440 of file at32f413_adc.h.

◆

struct { ... } adc_type::osq2_bit

Referenced by adc_ordinary_channel_set().

◆ osq3

__IO uint32_t adc_type::osq3

Definition at line 458 of file at32f413_adc.h.

◆

struct { ... } adc_type::osq3_bit

Referenced by adc_ordinary_channel_set().

◆ pcautoen

__IO uint32_t adc_type::pcautoen

Definition at line 256 of file at32f413_adc.h.

Referenced by adc_preempt_auto_mode_enable().

◆ pcce

__IO uint32_t adc_type::pcce

Definition at line 235 of file at32f413_adc.h.

◆ pcceien

__IO uint32_t adc_type::pcceien

Definition at line 253 of file at32f413_adc.h.

◆ pccs

__IO uint32_t adc_type::pccs

Definition at line 236 of file at32f413_adc.h.

◆ pcdto1

__IO uint32_t adc_type::pcdto1

Definition at line 345 of file at32f413_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto1_bit

Referenced by adc_preempt_offset_value_set().

◆ pcdto2

__IO uint32_t adc_type::pcdto2

Definition at line 358 of file at32f413_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto2_bit

Referenced by adc_preempt_offset_value_set().

◆ pcdto3

__IO uint32_t adc_type::pcdto3

Definition at line 371 of file at32f413_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto3_bit

Referenced by adc_preempt_offset_value_set().

◆ pcdto4

__IO uint32_t adc_type::pcdto4

Definition at line 384 of file at32f413_adc.h.

Referenced by adc_preempt_offset_value_set().

◆

struct { ... } adc_type::pcdto4_bit

Referenced by adc_preempt_offset_value_set().

◆ pclen

__IO uint32_t adc_type::pclen

Definition at line 483 of file at32f413_adc.h.

Referenced by adc_preempt_channel_length_set(), and adc_preempt_channel_set().

◆ pcpen

__IO uint32_t adc_type::pcpen

Definition at line 258 of file at32f413_adc.h.

Referenced by adc_preempt_part_mode_enable().

◆ pcswtrg

__IO uint32_t adc_type::pcswtrg

Definition at line 289 of file at32f413_adc.h.

Referenced by adc_preempt_software_trigger_enable(), and adc_preempt_software_trigger_status_get().

◆ pcten

__IO uint32_t adc_type::pcten

Definition at line 285 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_trigger_set().

◆ pctesel_h

__IO uint32_t adc_type::pctesel_h

Definition at line 292 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_trigger_set().

◆ pctesel_l

__IO uint32_t adc_type::pctesel_l

Definition at line 284 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_trigger_set().

◆ pcvmen

__IO uint32_t adc_type::pcvmen

Definition at line 262 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_enable().

◆ pdt1

__IO uint32_t adc_type::pdt1

Definition at line 493 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt1_bit

Referenced by adc_preempt_conversion_data_get().

◆ pdt2

__IO uint32_t adc_type::pdt2

Definition at line 506 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt2_bit

Referenced by adc_preempt_conversion_data_get().

◆ pdt3

__IO uint32_t adc_type::pdt3

Definition at line 519 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt3_bit

Referenced by adc_preempt_conversion_data_get().

◆ pdt4

__IO uint32_t adc_type::pdt4

Definition at line 532 of file at32f413_adc.h.

Referenced by adc_preempt_conversion_data_get().

◆

struct { ... } adc_type::pdt4_bit

Referenced by adc_preempt_conversion_data_get().

◆ psn1

__IO uint32_t adc_type::psn1

Definition at line 479 of file at32f413_adc.h.

Referenced by adc_preempt_channel_set().

◆ psn2

__IO uint32_t adc_type::psn2

Definition at line 480 of file at32f413_adc.h.

Referenced by adc_preempt_channel_set().

◆ psn3

__IO uint32_t adc_type::psn3

Definition at line 481 of file at32f413_adc.h.

Referenced by adc_preempt_channel_set().

◆ psn4

__IO uint32_t adc_type::psn4

Definition at line 482 of file at32f413_adc.h.

Referenced by adc_preempt_channel_set().

◆ psq

__IO uint32_t adc_type::psq

Definition at line 476 of file at32f413_adc.h.

◆

struct { ... } adc_type::psq_bit

Referenced by adc_preempt_channel_length_set(), and adc_preempt_channel_set().

◆ reserved1

__IO uint32_t adc_type::reserved1

Definition at line 238 of file at32f413_adc.h.

◆ reserved2

__IO uint32_t adc_type::reserved2

Definition at line 264 of file at32f413_adc.h.

◆ reserved3

__IO uint32_t adc_type::reserved3

Definition at line 286 of file at32f413_adc.h.

◆ reserved4

__IO uint32_t adc_type::reserved4

Definition at line 294 of file at32f413_adc.h.

◆ rpen

__IO uint32_t adc_type::rpen

Definition at line 277 of file at32f413_adc.h.

Referenced by adc_base_config().

◆ spt1

__IO uint32_t adc_type::spt1

Definition at line 303 of file at32f413_adc.h.

◆

struct { ... } adc_type::spt1_bit

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ spt2

__IO uint32_t adc_type::spt2

Definition at line 323 of file at32f413_adc.h.

◆

struct { ... } adc_type::spt2_bit

Referenced by adc_ordinary_channel_set(), and adc_preempt_channel_set().

◆ sqen

__IO uint32_t adc_type::sqen

Definition at line 254 of file at32f413_adc.h.

Referenced by adc_base_config().

◆ sts

__IO uint32_t adc_type::sts

Definition at line 230 of file at32f413_adc.h.

Referenced by adc_flag_clear(), and adc_flag_get().

◆

struct { ... } adc_type::sts_bit

◆ vmcsel

__IO uint32_t adc_type::vmcsel

Definition at line 250 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_single_channel_select().

◆ vmhb

__IO uint32_t adc_type::vmhb

Definition at line 397 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_threshold_value_set().

◆

struct { ... } adc_type::vmhb_bit

Referenced by adc_voltage_monitor_threshold_value_set().

◆ vmlb

__IO uint32_t adc_type::vmlb

Definition at line 410 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_threshold_value_set().

◆

struct { ... } adc_type::vmlb_bit

Referenced by adc_voltage_monitor_threshold_value_set().

◆ vmor

__IO uint32_t adc_type::vmor

Definition at line 233 of file at32f413_adc.h.

◆ vmorien

__IO uint32_t adc_type::vmorien

Definition at line 252 of file at32f413_adc.h.

◆ vmsgen

__IO uint32_t adc_type::vmsgen

Definition at line 255 of file at32f413_adc.h.

Referenced by adc_voltage_monitor_enable().

The documentation for this struct was generated from the following file:
  • at32f413_adc.h


AT32F413 Firmwary Library: ADC_exported_functions

Functions
ADC_exported_functions
AT32F413_periph_driver » ADC

Functions

void | adc_reset (adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_combine_mode_select (adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_tempersensor_vintrv_enable (confirm_state new_state)
enable or disable the temperature sensor and vintrv channel. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2). More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...

Detailed Description

Function Documentation

◆ adc_base_config()

void adc_base_config | ( | adc_type * | adc_x,
 |  | adc_base_config_type * | adc_base_struct
 | ) |  |

initialize the adc peripheral according to the specified parameters.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0xf)
Return values
none

Definition at line 143 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_base_default_para_init()

void adc_base_default_para_init ( adc_base_config_type * adc_base_struct )

adc base default para init.

Parameters
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0xf)
Return values
none

Definition at line 117 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_init()

void adc_calibration_init ( adc_type * adc_x )

initialize calibration register of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 199 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_init_status_get()

flag_status adc_calibration_init_status_get ( adc_type * adc_x )

get calibration register's initialize status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of reset calibration register status(SET or RESET).

Definition at line 211 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_start()

void adc_calibration_start ( adc_type * adc_x )

start calibration process of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 230 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_status_get()

flag_status adc_calibration_status_get ( adc_type * adc_x )

get calibration status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of calibration status(SET or RESET).

Definition at line 242 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_combine_mode_select()

void adc_combine_mode_select ( adc_combine_mode_type combine_mode )

select combine mode of the specified adc peripheral.

Parameters
combine_mode select the adc combine mode. this parameter can be one of the following values:
  • ADC_INDEPENDENT_MODE
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE
  • ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE
  • ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE
  • ADC_PREEMPT_SMLT_ONLY_MODE
  • ADC_ORDINARY_SMLT_ONLY_MODE
  • ADC_ORDINARY_SHORTSHIFT_ONLY_MODE
  • ADC_ORDINARY_LONGSHIFT_ONLY_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_MODE note:these bits are reserved in adc2
Return values
none

Definition at line 97 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_combine_ordinary_conversion_data_get()

uint32_t adc_combine_ordinary_conversion_data_get ( void )

return the last conversion data for ordinary channel of combine adc(adc1 and adc2).

Return values
the last conversion data for ordinary channel.

Definition at line 835 of file at32f413_adc.c.

◆ adc_dma_mode_enable()

void adc_dma_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the adc dma transfer.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1. note:this bit is reserved in adc2
new_state | new state of the adc dma transfer. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 161 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_enable()

void adc_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of a/d converter. this parameter can be: TRUE or FALSE. note:after adc ready,user set adcen bit will cause ordinary conversion
Return values
none

Definition at line 75 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_flag_clear()

void adc_flag_clear | ( | adc_type * | adc_x,
 |  | uint32_t | adc_flag
 | ) |  |

clear flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_flag select the adc flag. this parameter can be any combination of the following values:
  • ADC_VMOR_FLAG
  • ADC_CCE_FLAG(also can clear by reading the adc_x->odt)
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG
  • ADC_OCCS_FLAG
Return values
none

Definition at line 919 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_flag_get()

flag_status adc_flag_get | ( | adc_type * | adc_x,
 |  | uint8_t | adc_flag
 | ) |  |

get flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_flag select the adc flag. this parameter can be one of the following values:
  • ADC_VMOR_FLAG
  • ADC_CCE_FLAG
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG(no interrupt associated)
  • ADC_OCCS_FLAG(no interrupt associated)
Return values
the new state of adc flag status(SET or RESET).

Definition at line 890 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_interrupt_enable()

void adc_interrupt_enable | ( | adc_type * | adc_x,
 |  | uint32_t | adc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc interrupts.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_int specifies the adc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ADC_VMOR_INT
  • ADC_CCE_INT
  • ADC_PCCE_INT
new_state | new state of the specified adc interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 180 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_channel_set()

void adc_ordinary_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
adc_sequence set rank in the ordinary group sequencer. this parameter must be:
  • between 1 to 16
adc_sampletime set the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_1_5
  • ADC_SAMPLETIME_7_5
  • ADC_SAMPLETIME_13_5
  • ADC_SAMPLETIME_28_5
  • ADC_SAMPLETIME_41_5
  • ADC_SAMPLETIME_55_5
  • ADC_SAMPLETIME_71_5
  • ADC_SAMPLETIME_239_5
Return values
none

Definition at line 343 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_conversion_data_get()

uint16_t adc_ordinary_conversion_data_get ( adc_type * adc_x )

return the last conversion data for ordinary channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the last conversion data for ordinary channel.

Definition at line 826 of file at32f413_adc.c.

◆ adc_ordinary_conversion_trigger_set()

void adc_ordinary_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_ordinary_trig_select_type | adc_ordinary_trig,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_ordinary_trig select the external trigger event. this parameter can be one of the following values: adc1 & adc2
  • ADC12_ORDINARY_TRIG_TMR1CH1 - ADC12_ORDINARY_TRIG_TMR1CH2 - ADC12_ORDINARY_TRIG_TMR1CH3 - ADC12_ORDINARY_TRIG_TMR2CH2
  • ADC12_ORDINARY_TRIG_TMR3TRGOUT - ADC12_ORDINARY_TRIG_TMR4CH4 - ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT - ADC12_ORDINARY_TRIG_SOFTWARE
  • ADC12_ORDINARY_TRIG_TMR1TRGOUT - ADC12_ORDINARY_TRIG_TMR8CH1 - ADC12_ORDINARY_TRIG_TMR8CH2
new_state | new state of ordinary channel's external trigger. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 599 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_count_set()

void adc_ordinary_part_count_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_count
 | ) |  |

set partitioned mode channel count of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel_count configure the adc partitioned mode channel count. this parameter can be:
  • (0x1~0x8)
Return values
none

Definition at line 693 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_mode_enable()

void adc_ordinary_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of ordinary channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 708 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_software_trigger_enable()

void adc_ordinary_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable ordinary software start conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of ordinary software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 762 of file at32f413_adc.c.

Referenced by main().

◆ adc_ordinary_software_trigger_status_get()

flag_status adc_ordinary_software_trigger_status_get ( adc_type * adc_x )

get ordinary software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of ordinary software start conversion status(SET or RESET).

Definition at line 774 of file at32f413_adc.c.

◆ adc_preempt_auto_mode_enable()

void adc_preempt_auto_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable automatic preempt group conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of automatic preempt group conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 736 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_length_set()

void adc_preempt_channel_length_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_lenght
 | ) |  |

set preempt channel lenghth of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel_lenght set the adc preempt channel lenghth. this parameter can be:
  • (0x1~0x4)
Return values
none

Definition at line 469 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_set()

void adc_preempt_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
adc_sequence set rank in the preempt group sequencer. this parameter must be:
  • between 1 to 4
adc_sampletime config the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_1_5
  • ADC_SAMPLETIME_7_5
  • ADC_SAMPLETIME_13_5
  • ADC_SAMPLETIME_28_5
  • ADC_SAMPLETIME_41_5
  • ADC_SAMPLETIME_55_5
  • ADC_SAMPLETIME_71_5
  • ADC_SAMPLETIME_239_5
Return values
none

Definition at line 501 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_conversion_data_get()

uint16_t adc_preempt_conversion_data_get | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel
 | ) |  |

return the conversion data for selection preempt channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPTED_CHANNEL_1
  • ADC_PREEMPTED_CHANNEL_2
  • ADC_PREEMPTED_CHANNEL_3
  • ADC_PREEMPTED_CHANNEL_4
Return values
the conversion data for selection preempt channel.

Definition at line 853 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_preempt_conversion_trigger_set()

void adc_preempt_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_preempt_trig_select_type | adc_preempt_trig,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_trig select the external trigger event. this parameter can be one of the following values: adc1 & adc2
  • ADC12_PREEMPT_TRIG_TMR1TRGOUT - ADC12_PREEMPT_TRIG_TMR1CH4 - ADC12_PREEMPT_TRIG_TMR2TRGOUT - ADC12_PREEMPT_TRIG_TMR2CH1
  • ADC12_PREEMPT_TRIG_TMR3CH4 - ADC12_PREEMPT_TRIG_TMR4TRGOUT - ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 - ADC12_PREEMPT_TRIG_SOFTWARE
  • ADC12_PREEMPT_TRIG_TMR1CH1 - ADC12_PREEMPT_TRIG_TMR8CH1 - ADC12_PREEMPT_TRIG_TMR8TRGOUT
new_state | new state of preempt channel's external trigger. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 630 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_offset_value_set()

void adc_preempt_offset_value_set | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel,
 |  | uint16_t | adc_offset_value
 | ) |  |

set preempt channel's conversion value offset of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPT_CHANNEL_1
  • ADC_PREEMPT_CHANNEL_2
  • ADC_PREEMPT_CHANNEL_3
  • ADC_PREEMPT_CHANNEL_4
adc_offset_value set the adc preempt channel's conversion value offset. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 662 of file at32f413_adc.c.

◆ adc_preempt_part_mode_enable()

void adc_preempt_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on preempt channel of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of preempt channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 722 of file at32f413_adc.c.

◆ adc_preempt_software_trigger_enable()

void adc_preempt_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable preempt software start conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of preempt software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 795 of file at32f413_adc.c.

◆ adc_preempt_software_trigger_status_get()

flag_status adc_preempt_software_trigger_status_get ( adc_type * adc_x )

get preempt software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of preempt software start conversion status(SET or RESET).

Definition at line 807 of file at32f413_adc.c.

◆ adc_reset()

void adc_reset ( adc_type * adc_x )

deinitialize the adc peripheral registers to their default reset values.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 51 of file at32f413_adc.c.

◆ adc_tempersensor_vintrv_enable()

void adc_tempersensor_vintrv_enable ( confirm_state new_state )

enable or disable the temperature sensor and vintrv channel.

Parameters
new_state new state of Internal temperature sensor and vintrv. this parameter can be: TRUE or FALSE. note:this bit is present only in adc1
Return values
none

Definition at line 748 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_enable()

void adc_voltage_monitor_enable | ( | adc_type * | adc_x,
 |  | adc_voltage_monitoring_type | adc_voltage_monitoring
 | ) |  |

enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_voltage_monitoring choose the adc_voltage_monitoring config. this parameter can be one of the following values:
  • ADC_VMONITOR_SINGLE_ORDINARY
  • ADC_VMONITOR_SINGLE_PREEMPT
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY
  • ADC_VMONITOR_ALL_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT
  • ADC_VMONITOR_NONE
Return values
none

Definition at line 270 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_single_channel_select()

void adc_voltage_monitor_single_channel_select | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel
 | ) |  |

select the voltage monitoring's channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
Return values
none

Definition at line 311 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_threshold_value_set()

void adc_voltage_monitor_threshold_value_set | ( | adc_type * | adc_x,
 |  | uint16_t | adc_high_threshold,
 |  | uint16_t | adc_low_threshold
 | ) |  |

set voltage monitoring's high and low thresholds value of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_high_threshold voltage monitoring's high thresholds value. this parameter can be:
  • (0x000~0xFFF)
adc_low_threshold voltage monitoring's low thresholds value. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 291 of file at32f413_adc.c.

Referenced by adc_config().


AT32F413 Firmwary Library: ADC_private_functions

Functions
ADC_private_functions
AT32F413_periph_driver » ADC

Functions

void | adc_reset (adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_combine_mode_select (adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_tempersensor_vintrv_enable (confirm_state new_state)
enable or disable the temperature sensor and vintrv channel. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2). More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...

Detailed Description

Function Documentation

◆ adc_base_config()

void adc_base_config | ( | adc_type * | adc_x,
 |  | adc_base_config_type * | adc_base_struct
 | ) |  |

initialize the adc peripheral according to the specified parameters.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0xf)
Return values
none

Definition at line 143 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_base_default_para_init()

void adc_base_default_para_init ( adc_base_config_type * adc_base_struct )

adc base default para init.

Parameters
sequence_mode | set the state of adc sequence mode. this parameter can be:TRUE or FALSE
repeat_mode | set the state of adc repeat conversion mode. this parameter can be:TRUE or FALSE
data_align set the state of adc data alignment. this parameter can be one of the following values:
  • ADC_RIGHT_ALIGNMENT
  • ADC_LEFT_ALIGNMENT
ordinary_channel_length configure the adc ordinary channel sequence length. this parameter can be:
  • (0x1~0xf)
Return values
none

Definition at line 117 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_init()

void adc_calibration_init ( adc_type * adc_x )

initialize calibration register of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 199 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_init_status_get()

flag_status adc_calibration_init_status_get ( adc_type * adc_x )

get calibration register's initialize status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of reset calibration register status(SET or RESET).

Definition at line 211 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_start()

void adc_calibration_start ( adc_type * adc_x )

start calibration process of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 230 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_calibration_status_get()

flag_status adc_calibration_status_get ( adc_type * adc_x )

get calibration status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of calibration status(SET or RESET).

Definition at line 242 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_combine_mode_select()

void adc_combine_mode_select ( adc_combine_mode_type combine_mode )

select combine mode of the specified adc peripheral.

Parameters
combine_mode select the adc combine mode. this parameter can be one of the following values:
  • ADC_INDEPENDENT_MODE
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE
  • ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE
  • ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE
  • ADC_PREEMPT_SMLT_ONLY_MODE
  • ADC_ORDINARY_SMLT_ONLY_MODE
  • ADC_ORDINARY_SHORTSHIFT_ONLY_MODE
  • ADC_ORDINARY_LONGSHIFT_ONLY_MODE
  • ADC_PREEMPT_INTERLTRIG_ONLY_MODE note:these bits are reserved in adc2
Return values
none

Definition at line 97 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_combine_ordinary_conversion_data_get()

uint32_t adc_combine_ordinary_conversion_data_get ( void )

return the last conversion data for ordinary channel of combine adc(adc1 and adc2).

Return values
the last conversion data for ordinary channel.

Definition at line 835 of file at32f413_adc.c.

◆ adc_dma_mode_enable()

void adc_dma_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the adc dma transfer.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1. note:this bit is reserved in adc2
new_state | new state of the adc dma transfer. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 161 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_enable()

void adc_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of a/d converter. this parameter can be: TRUE or FALSE. note:after adc ready,user set adcen bit will cause ordinary conversion
Return values
none

Definition at line 75 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_flag_clear()

void adc_flag_clear | ( | adc_type * | adc_x,
 |  | uint32_t | adc_flag
 | ) |  |

clear flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_flag select the adc flag. this parameter can be any combination of the following values:
  • ADC_VMOR_FLAG
  • ADC_CCE_FLAG(also can clear by reading the adc_x->odt)
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG
  • ADC_OCCS_FLAG
Return values
none

Definition at line 919 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_flag_get()

flag_status adc_flag_get | ( | adc_type * | adc_x,
 |  | uint8_t | adc_flag
 | ) |  |

get flag of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_flag select the adc flag. this parameter can be one of the following values:
  • ADC_VMOR_FLAG
  • ADC_CCE_FLAG
  • ADC_PCCE_FLAG
  • ADC_PCCS_FLAG(no interrupt associated)
  • ADC_OCCS_FLAG(no interrupt associated)
Return values
the new state of adc flag status(SET or RESET).

Definition at line 890 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_interrupt_enable()

void adc_interrupt_enable | ( | adc_type * | adc_x,
 |  | uint32_t | adc_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified adc interrupts.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_int specifies the adc interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • ADC_VMOR_INT
  • ADC_CCE_INT
  • ADC_PCCE_INT
new_state | new state of the specified adc interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 180 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_channel_set()

void adc_ordinary_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
adc_sequence set rank in the ordinary group sequencer. this parameter must be:
  • between 1 to 16
adc_sampletime set the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_1_5
  • ADC_SAMPLETIME_7_5
  • ADC_SAMPLETIME_13_5
  • ADC_SAMPLETIME_28_5
  • ADC_SAMPLETIME_41_5
  • ADC_SAMPLETIME_55_5
  • ADC_SAMPLETIME_71_5
  • ADC_SAMPLETIME_239_5
Return values
none

Definition at line 343 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_conversion_data_get()

uint16_t adc_ordinary_conversion_data_get ( adc_type * adc_x )

return the last conversion data for ordinary channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the last conversion data for ordinary channel.

Definition at line 826 of file at32f413_adc.c.

◆ adc_ordinary_conversion_trigger_set()

void adc_ordinary_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_ordinary_trig_select_type | adc_ordinary_trig,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_ordinary_trig select the external trigger event. this parameter can be one of the following values: adc1 & adc2
  • ADC12_ORDINARY_TRIG_TMR1CH1 - ADC12_ORDINARY_TRIG_TMR1CH2 - ADC12_ORDINARY_TRIG_TMR1CH3 - ADC12_ORDINARY_TRIG_TMR2CH2
  • ADC12_ORDINARY_TRIG_TMR3TRGOUT - ADC12_ORDINARY_TRIG_TMR4CH4 - ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT - ADC12_ORDINARY_TRIG_SOFTWARE
  • ADC12_ORDINARY_TRIG_TMR1TRGOUT - ADC12_ORDINARY_TRIG_TMR8CH1 - ADC12_ORDINARY_TRIG_TMR8CH2
new_state | new state of ordinary channel's external trigger. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 599 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_count_set()

void adc_ordinary_part_count_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_count
 | ) |  |

set partitioned mode channel count of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel_count configure the adc partitioned mode channel count. this parameter can be:
  • (0x1~0x8)
Return values
none

Definition at line 693 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_part_mode_enable()

void adc_ordinary_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of ordinary channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 708 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_ordinary_software_trigger_enable()

void adc_ordinary_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable ordinary software start conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of ordinary software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 762 of file at32f413_adc.c.

Referenced by main().

◆ adc_ordinary_software_trigger_status_get()

flag_status adc_ordinary_software_trigger_status_get ( adc_type * adc_x )

get ordinary software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of ordinary software start conversion status(SET or RESET).

Definition at line 774 of file at32f413_adc.c.

◆ adc_preempt_auto_mode_enable()

void adc_preempt_auto_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable automatic preempt group conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of automatic preempt group conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 736 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_length_set()

void adc_preempt_channel_length_set | ( | adc_type * | adc_x,
 |  | uint8_t | adc_channel_lenght
 | ) |  |

set preempt channel lenghth of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel_lenght set the adc preempt channel lenghth. this parameter can be:
  • (0x1~0x4)
Return values
none

Definition at line 469 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_channel_set()

void adc_preempt_channel_set | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel,
 |  | uint8_t | adc_sequence,
 |  | adc_sampletime_select_type | adc_sampletime
 | ) |  |

configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
adc_sequence set rank in the preempt group sequencer. this parameter must be:
  • between 1 to 4
adc_sampletime config the sampletime of adc channel. this parameter can be one of the following values:
  • ADC_SAMPLETIME_1_5
  • ADC_SAMPLETIME_7_5
  • ADC_SAMPLETIME_13_5
  • ADC_SAMPLETIME_28_5
  • ADC_SAMPLETIME_41_5
  • ADC_SAMPLETIME_55_5
  • ADC_SAMPLETIME_71_5
  • ADC_SAMPLETIME_239_5
Return values
none

Definition at line 501 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_conversion_data_get()

uint16_t adc_preempt_conversion_data_get | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel
 | ) |  |

return the conversion data for selection preempt channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPTED_CHANNEL_1
  • ADC_PREEMPTED_CHANNEL_2
  • ADC_PREEMPTED_CHANNEL_3
  • ADC_PREEMPTED_CHANNEL_4
Return values
the conversion data for selection preempt channel.

Definition at line 853 of file at32f413_adc.c.

Referenced by ADC1_2_IRQHandler().

◆ adc_preempt_conversion_trigger_set()

void adc_preempt_conversion_trigger_set | ( | adc_type * | adc_x,
 |  | adc_preempt_trig_select_type | adc_preempt_trig,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_trig select the external trigger event. this parameter can be one of the following values: adc1 & adc2
  • ADC12_PREEMPT_TRIG_TMR1TRGOUT - ADC12_PREEMPT_TRIG_TMR1CH4 - ADC12_PREEMPT_TRIG_TMR2TRGOUT - ADC12_PREEMPT_TRIG_TMR2CH1
  • ADC12_PREEMPT_TRIG_TMR3CH4 - ADC12_PREEMPT_TRIG_TMR4TRGOUT - ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 - ADC12_PREEMPT_TRIG_SOFTWARE
  • ADC12_PREEMPT_TRIG_TMR1CH1 - ADC12_PREEMPT_TRIG_TMR8CH1 - ADC12_PREEMPT_TRIG_TMR8TRGOUT
new_state | new state of preempt channel's external trigger. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 630 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_preempt_offset_value_set()

void adc_preempt_offset_value_set | ( | adc_type * | adc_x,
 |  | adc_preempt_channel_type | adc_preempt_channel,
 |  | uint16_t | adc_offset_value
 | ) |  |

set preempt channel's conversion value offset of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_preempt_channel select the preempt channel. this parameter can be one of the following values:
  • ADC_PREEMPT_CHANNEL_1
  • ADC_PREEMPT_CHANNEL_2
  • ADC_PREEMPT_CHANNEL_3
  • ADC_PREEMPT_CHANNEL_4
adc_offset_value set the adc preempt channel's conversion value offset. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 662 of file at32f413_adc.c.

◆ adc_preempt_part_mode_enable()

void adc_preempt_part_mode_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the partitioned mode on preempt channel of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of preempt channel's partitioned mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 722 of file at32f413_adc.c.

◆ adc_preempt_software_trigger_enable()

void adc_preempt_software_trigger_enable | ( | adc_type * | adc_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable preempt software start conversion of the specified adc peripheral.

Parameters
adc_x | select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
new_state | new state of preempt software start conversion. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 795 of file at32f413_adc.c.

◆ adc_preempt_software_trigger_status_get()

flag_status adc_preempt_software_trigger_status_get ( adc_type * adc_x )

get preempt software start conversion status of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
the new state of preempt software start conversion status(SET or RESET).

Definition at line 807 of file at32f413_adc.c.

◆ adc_reset()

void adc_reset ( adc_type * adc_x )

deinitialize the adc peripheral registers to their default reset values.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
Return values
none

Definition at line 51 of file at32f413_adc.c.

◆ adc_tempersensor_vintrv_enable()

void adc_tempersensor_vintrv_enable ( confirm_state new_state )

enable or disable the temperature sensor and vintrv channel.

Parameters
new_state new state of Internal temperature sensor and vintrv. this parameter can be: TRUE or FALSE. note:this bit is present only in adc1
Return values
none

Definition at line 748 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_enable()

void adc_voltage_monitor_enable | ( | adc_type * | adc_x,
 |  | adc_voltage_monitoring_type | adc_voltage_monitoring
 | ) |  |

enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_voltage_monitoring choose the adc_voltage_monitoring config. this parameter can be one of the following values:
  • ADC_VMONITOR_SINGLE_ORDINARY
  • ADC_VMONITOR_SINGLE_PREEMPT
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY
  • ADC_VMONITOR_ALL_PREEMPT
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT
  • ADC_VMONITOR_NONE
Return values
none

Definition at line 270 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_single_channel_select()

void adc_voltage_monitor_single_channel_select | ( | adc_type * | adc_x,
 |  | adc_channel_select_type | adc_channel
 | ) |  |

select the voltage monitoring's channel of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_channel select the channel. this parameter can be one of the following values:
  • ADC_CHANNEL_0 - ADC_CHANNEL_1 - ADC_CHANNEL_2 - ADC_CHANNEL_3
  • ADC_CHANNEL_4 - ADC_CHANNEL_5 - ADC_CHANNEL_6 - ADC_CHANNEL_7
  • ADC_CHANNEL_8 - ADC_CHANNEL_9 - ADC_CHANNEL_10 - ADC_CHANNEL_11
  • ADC_CHANNEL_12 - ADC_CHANNEL_13 - ADC_CHANNEL_14 - ADC_CHANNEL_15
  • ADC_CHANNEL_16 - ADC_CHANNEL_17
Return values
none

Definition at line 311 of file at32f413_adc.c.

Referenced by adc_config().

◆ adc_voltage_monitor_threshold_value_set()

void adc_voltage_monitor_threshold_value_set | ( | adc_type * | adc_x,
 |  | uint16_t | adc_high_threshold,
 |  | uint16_t | adc_low_threshold
 | ) |  |

set voltage monitoring's high and low thresholds value of the specified adc peripheral.

Parameters
adc_x select the adc peripheral. this parameter can be one of the following values: ADC1, ADC2.
adc_high_threshold voltage monitoring's high thresholds value. this parameter can be:
  • (0x000~0xFFF)
adc_low_threshold voltage monitoring's low thresholds value. this parameter can be:
  • (0x000~0xFFF)
Return values
none

Definition at line 291 of file at32f413_adc.c.

Referenced by adc_config().


AT32F413 Firmwary Library: BPR

Modules | Macros
BPR
AT32F413_periph_driver

BPR driver modules. More...

Modules

BPR_flags_definition
bpr flag
BPR_exported_types
BPR_exported_functions
BPR_private_functions

Macros

#define BPR ((bpr_type *) BPR_BASE)

Detailed Description

BPR driver modules.

Macro Definition Documentation

◆ BPR

#define BPR ((bpr_type *) BPR_BASE)

Definition at line 756 of file at32f413_bpr.h.


AT32F413 Firmwary Library: BPR_flags_definition

Macros
BPR_flags_definition
AT32F413_periph_driver » BPR

bpr flag More...

Macros

#define | BPR_TAMPER_INTERRUPT_FLAG ((uint32_t)0x00000001)
#define | BPR_TAMPER_EVENT_FLAG ((uint32_t)0x00000002)

Detailed Description

bpr flag

Macro Definition Documentation

◆ BPR_TAMPER_EVENT_FLAG

#define BPR_TAMPER_EVENT_FLAG ((uint32_t)0x00000002)

bpr tamper event flag

Definition at line 53 of file at32f413_bpr.h.

◆ BPR_TAMPER_INTERRUPT_FLAG

#define BPR_TAMPER_INTERRUPT_FLAG ((uint32_t)0x00000001)

bpr tamper interrupt flag

Definition at line 52 of file at32f413_bpr.h.


AT32F413 Firmwary Library: BPR_exported_types

Data Structures | Enumerations
BPR_exported_types
AT32F413_periph_driver » BPR

Data Structures

struct bpr_type
type define bpr register all More...

Enumerations

enum bpr_data_type {
BPR_DATA1 = 0x04 , BPR_DATA2 = 0x08 , BPR_DATA3 = 0x0C , BPR_DATA4 = 0x10 ,
BPR_DATA5 = 0x14 , BPR_DATA6 = 0x18 , BPR_DATA7 = 0x1C , BPR_DATA8 = 0x20 ,
BPR_DATA9 = 0x24 , BPR_DATA10 = 0x28 , BPR_DATA11 = 0x40 , BPR_DATA12 = 0x44 ,
BPR_DATA13 = 0x48 , BPR_DATA14 = 0x4C , BPR_DATA15 = 0x50 , BPR_DATA16 = 0x54 ,
BPR_DATA17 = 0x58 , BPR_DATA18 = 0x5C , BPR_DATA19 = 0x60 , BPR_DATA20 = 0x64 ,
BPR_DATA21 = 0x68 , BPR_DATA22 = 0x6C , BPR_DATA23 = 0x70 , BPR_DATA24 = 0x74 ,
BPR_DATA25 = 0x78 , BPR_DATA26 = 0x7C , BPR_DATA27 = 0x80 , BPR_DATA28 = 0x84 ,
BPR_DATA29 = 0x88 , BPR_DATA30 = 0x8C , BPR_DATA31 = 0x90 , BPR_DATA32 = 0x94 ,
BPR_DATA33 = 0x98 , BPR_DATA34 = 0x9C , BPR_DATA35 = 0xA0 , BPR_DATA36 = 0xA4 ,
BPR_DATA37 = 0xA8 , BPR_DATA38 = 0xAC , BPR_DATA39 = 0xB0 , BPR_DATA40 = 0xB4 ,
BPR_DATA41 = 0xB8 , BPR_DATA42 = 0xBC
}
battery powered register data type More...
enum bpr_rtc_output_type {
BPR_RTC_OUTPUT_NONE = 0x000 , BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE = 0x080 , BPR_RTC_OUTPUT_ALARM = 0x100 , BPR_RTC_OUTPUT_SECOND = 0x300 ,
BPR_RTC_OUTPUT_CLOCK_CAL_AFTER = 0x480 , BPR_RTC_OUTPUT_ALARM_TOGGLE = 0x900 , BPR_RTC_OUTPUT_SECOND_TOGGLE = 0xB00
}
bpr rtc output type More...
enum bpr_tamper_pin_active_level_type { BPR_TAMPER_PIN_ACTIVE_HIGH = 0x00 , BPR_TAMPER_PIN_ACTIVE_LOW = 0x01 }
tamper pin active level type More...

Detailed Description

Enumeration Type Documentation

◆ bpr_data_type

enum bpr_data_type

battery powered register data type

Enumerator
BPR_DATA1 | bpr data register 1
BPR_DATA2 | bpr data register 2
BPR_DATA3 | bpr data register 3
BPR_DATA4 | bpr data register 4
BPR_DATA5 | bpr data register 5
BPR_DATA6 | bpr data register 6
BPR_DATA7 | bpr data register 7
BPR_DATA8 | bpr data register 8
BPR_DATA9 | bpr data register 9
BPR_DATA10 | bpr data register 10
BPR_DATA11 | bpr data register 11
BPR_DATA12 | bpr data register 12
BPR_DATA13 | bpr data register 13
BPR_DATA14 | bpr data register 14
BPR_DATA15 | bpr data register 15
BPR_DATA16 | bpr data register 16
BPR_DATA17 | bpr data register 17
BPR_DATA18 | bpr data register 18
BPR_DATA19 | bpr data register 19
BPR_DATA20 | bpr data register 20
BPR_DATA21 | bpr data register 21
BPR_DATA22 | bpr data register 22
BPR_DATA23 | bpr data register 23
BPR_DATA24 | bpr data register 24
BPR_DATA25 | bpr data register 25
BPR_DATA26 | bpr data register 26
BPR_DATA27 | bpr data register 27
BPR_DATA28 | bpr data register 28
BPR_DATA29 | bpr data register 29
BPR_DATA30 | bpr data register 30
BPR_DATA31 | bpr data register 31
BPR_DATA32 | bpr data register 32
BPR_DATA33 | bpr data register 33
BPR_DATA34 | bpr data register 34
BPR_DATA35 | bpr data register 35
BPR_DATA36 | bpr data register 36
BPR_DATA37 | bpr data register 37
BPR_DATA38 | bpr data register 38
BPR_DATA39 | bpr data register 39
BPR_DATA40 | bpr data register 40
BPR_DATA41 | bpr data register 41
BPR_DATA42 | bpr data register 42

Definition at line 66 of file at32f413_bpr.h.

◆ bpr_rtc_output_type

enum bpr_rtc_output_type

bpr rtc output type

Enumerator
BPR_RTC_OUTPUT_NONE | output disable
BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE | output clock before calibration
BPR_RTC_OUTPUT_ALARM | output alarm event with pluse mode
BPR_RTC_OUTPUT_SECOND | output second event with pluse mode
BPR_RTC_OUTPUT_CLOCK_CAL_AFTER | output clock after calibration
BPR_RTC_OUTPUT_ALARM_TOGGLE | output alarm event with toggle mode
BPR_RTC_OUTPUT_SECOND_TOGGLE | output second event with toggle mode

Definition at line 115 of file at32f413_bpr.h.

◆ bpr_tamper_pin_active_level_type

enum bpr_tamper_pin_active_level_type

tamper pin active level type

Enumerator
BPR_TAMPER_PIN_ACTIVE_HIGH | tamper pin input active level is high
BPR_TAMPER_PIN_ACTIVE_LOW | tamper pin input active level is low

Definition at line 129 of file at32f413_bpr.h.


AT32F413 Firmwary Library: bpr_type Struct Reference

Data Fields
bpr_type Struct Reference
AT32F413_periph_driver » BPR » BPR_exported_types

type define bpr register all More...

#include <at32f413_bpr.h>

Data Fields

__IO uint32_t | reserved1
reserved, offset:0x00 More...
union {
__IO uint32_t dt1
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt1_bit
};
bpr dt1 register, offset:0x04 More...
union {
__IO uint32_t dt2
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt2_bit
};
bpr dt2 register, offset:0x08 More...
union {
__IO uint32_t dt3
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt3_bit
};
bpr dt3 register, offset:0x0C More...
union {
__IO uint32_t dt4
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt4_bit
};
bpr dt4 register, offset:0x10 More...
union {
__IO uint32_t dt5
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt5_bit
};
bpr dt5 register, offset:0x14 More...
union {
__IO uint32_t dt6
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt6_bit
};
bpr dt6 register, offset:0x18 More...
union {
__IO uint32_t dt7
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt7_bit
};
bpr dt7 register, offset:0x1C More...
union {
__IO uint32_t dt8
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt8_bit
};
bpr dt8 register, offset:0x20 More...
union {
__IO uint32_t dt9
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt9_bit
};
bpr dt9 register, offset:0x24 More...
union {
__IO uint32_t dt10
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt10_bit
};
bpr dt10 register, offset:0x28 More...
union {
__IO uint32_t rtccal
struct {
__IO uint32_t calval: 7
__IO uint32_t calout: 1
__IO uint32_t outen: 1
__IO uint32_t outsel: 1
__IO uint32_t ccos: 1
__IO uint32_t outm: 1
__IO uint32_t reserved1: 20
} rtccal_bit
};
bpr rtccal register, offset:0x2C More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t tpen: 1
__IO uint32_t tpp: 1
__IO uint32_t reserved1: 30
} ctrl_bit
};
bpr ctrl register, offset:0x30 More...
union {
__IO uint32_t ctrlsts
struct {
__IO uint32_t tpefclr: 1
__IO uint32_t tpifclr: 1
__IO uint32_t tpien: 1
__IO uint32_t reserved1: 5
__IO uint32_t tpef: 1
__IO uint32_t tpif: 1
__IO uint32_t reserved2: 22
} ctrlsts_bit
};
bpr ctrlsts register, offset:0x34 More...
__IO uint32_t | reserved3
reserved, offset:0x3C More...
union {
__IO uint32_t dt11
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt11_bit
};
bpr dt11 register, offset:0x40 More...
union {
__IO uint32_t dt12
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt12_bit
};
bpr dt12 register, offset:0x44 More...
union {
__IO uint32_t dt13
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt13_bit
};
bpr dt13 register, offset:0x48 More...
union {
__IO uint32_t dt14
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt14_bit
};
bpr dt14 register, offset:0x4C More...
union {
__IO uint32_t dt15
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt15_bit
};
bpr dt15 register, offset:0x50 More...
union {
__IO uint32_t dt16
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt16_bit
};
bpr dt16 register, offset:0x54 More...
union {
__IO uint32_t dt17
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt17_bit
};
bpr dt17 register, offset:0x58 More...
union {
__IO uint32_t dt18
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt18_bit
};
bpr dt18 register, offset:0x5C More...
union {
__IO uint32_t dt19
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt19_bit
};
bpr dt19 register, offset:0x60 More...
union {
__IO uint32_t dt20
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt20_bit
};
bpr dt20 register, offset:0x64 More...
union {
__IO uint32_t dt21
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt21_bit
};
bpr dt21 register, offset:0x68 More...
union {
__IO uint32_t dt22
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt22_bit
};
bpr dt22 register, offset:6C More...
union {
__IO uint32_t dt23
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt23_bit
};
bpr dt23 register, offset:0x70 More...
union {
__IO uint32_t dt24
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt24_bit
};
bpr dt24 register, offset:0x74 More...
union {
__IO uint32_t dt25
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt25_bit
};
bpr dt25 register, offset:0x78 More...
union {
__IO uint32_t dt26
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt26_bit
};
bpr dt26 register, offset:0x7C More...
union {
__IO uint32_t dt27
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt27_bit
};
bpr dt27 register, offset:0x80 More...
union {
__IO uint32_t dt28
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt28_bit
};
bpr dt28 register, offset:0x84 More...
union {
__IO uint32_t dt29
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt29_bit
};
bpr dt29 register, offset:0x88 More...
union {
__IO uint32_t dt30
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt30_bit
};
bpr dt30 register, offset:0x8C More...
union {
__IO uint32_t dt31
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt31_bit
};
bpr dt31 register, offset:0x90 More...
union {
__IO uint32_t dt32
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt32_bit
};
bpr dt32 register, offset:0x94 More...
union {
__IO uint32_t dt33
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt33_bit
};
bpr dt33 register, offset:0x98 More...
union {
__IO uint32_t dt34
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt34_bit
};
bpr dt34 register, offset:0x9C More...
union {
__IO uint32_t dt35
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt35_bit
};
bpr dt35 register, offset:0xA0 More...
union {
__IO uint32_t dt36
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt36_bit
};
bpr dt36 register, offset:0xA4 More...
union {
__IO uint32_t dt37
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt37_bit
};
bpr dt37 register, offset:0xA8 More...
union {
__IO uint32_t dt38
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt38_bit
};
bpr dt38 register, offset:0xAC More...
union {
__IO uint32_t dt39
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt39_bit
};
bpr dt39 register, offset:0xB0 More...
union {
__IO uint32_t dt40
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt40_bit
};
bpr dt40 register, offset:0xB4 More...
union {
__IO uint32_t dt41
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt41_bit
};
bpr dt41 register, offset:0xB8 More...
union {
__IO uint32_t dt42
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt42_bit
};
bpr dt42 register, offset:0xBC More...

Detailed Description

type define bpr register all

Definition at line 138 of file at32f413_bpr.h.

Field Documentation

◆

union { ... } bpr_type::@101

bpr ctrl register, offset:0x30

◆

union { ... } bpr_type::@103

bpr ctrlsts register, offset:0x34

◆

union { ... } bpr_type::@105

bpr dt11 register, offset:0x40

◆

union { ... } bpr_type::@107

bpr dt12 register, offset:0x44

◆

union { ... } bpr_type::@109

bpr dt13 register, offset:0x48

◆

union { ... } bpr_type::@111

bpr dt14 register, offset:0x4C

◆

union { ... } bpr_type::@113

bpr dt15 register, offset:0x50

◆

union { ... } bpr_type::@115

bpr dt16 register, offset:0x54

◆

union { ... } bpr_type::@117

bpr dt17 register, offset:0x58

◆

union { ... } bpr_type::@119

bpr dt18 register, offset:0x5C

◆

union { ... } bpr_type::@121

bpr dt19 register, offset:0x60

◆

union { ... } bpr_type::@123

bpr dt20 register, offset:0x64

◆

union { ... } bpr_type::@125

bpr dt21 register, offset:0x68

◆

union { ... } bpr_type::@127

bpr dt22 register, offset:6C

◆

union { ... } bpr_type::@129

bpr dt23 register, offset:0x70

◆

union { ... } bpr_type::@131

bpr dt24 register, offset:0x74

◆

union { ... } bpr_type::@133

bpr dt25 register, offset:0x78

◆

union { ... } bpr_type::@135

bpr dt26 register, offset:0x7C

◆

union { ... } bpr_type::@137

bpr dt27 register, offset:0x80

◆

union { ... } bpr_type::@139

bpr dt28 register, offset:0x84

◆

union { ... } bpr_type::@141

bpr dt29 register, offset:0x88

◆

union { ... } bpr_type::@143

bpr dt30 register, offset:0x8C

◆

union { ... } bpr_type::@145

bpr dt31 register, offset:0x90

◆

union { ... } bpr_type::@147

bpr dt32 register, offset:0x94

◆

union { ... } bpr_type::@149

bpr dt33 register, offset:0x98

◆

union { ... } bpr_type::@151

bpr dt34 register, offset:0x9C

◆

union { ... } bpr_type::@153

bpr dt35 register, offset:0xA0

◆

union { ... } bpr_type::@155

bpr dt36 register, offset:0xA4

◆

union { ... } bpr_type::@157

bpr dt37 register, offset:0xA8

◆

union { ... } bpr_type::@159

bpr dt38 register, offset:0xAC

◆

union { ... } bpr_type::@161

bpr dt39 register, offset:0xB0

◆

union { ... } bpr_type::@163

bpr dt40 register, offset:0xB4

◆

union { ... } bpr_type::@165

bpr dt41 register, offset:0xB8

◆

union { ... } bpr_type::@167

bpr dt42 register, offset:0xBC

◆

union { ... } bpr_type::@79

bpr dt1 register, offset:0x04

◆

union { ... } bpr_type::@81

bpr dt2 register, offset:0x08

◆

union { ... } bpr_type::@83

bpr dt3 register, offset:0x0C

◆

union { ... } bpr_type::@85

bpr dt4 register, offset:0x10

◆

union { ... } bpr_type::@87

bpr dt5 register, offset:0x14

◆

union { ... } bpr_type::@89

bpr dt6 register, offset:0x18

◆

union { ... } bpr_type::@91

bpr dt7 register, offset:0x1C

◆

union { ... } bpr_type::@93

bpr dt8 register, offset:0x20

◆

union { ... } bpr_type::@95

bpr dt9 register, offset:0x24

◆

union { ... } bpr_type::@97

bpr dt10 register, offset:0x28

◆

union { ... } bpr_type::@99

bpr rtccal register, offset:0x2C

◆ calout

__IO uint32_t bpr_type::calout

Definition at line 284 of file at32f413_bpr.h.

◆ calval

__IO uint32_t bpr_type::calval

Definition at line 283 of file at32f413_bpr.h.

◆ ccos

__IO uint32_t bpr_type::ccos

Definition at line 287 of file at32f413_bpr.h.

◆ ctrl

__IO uint32_t bpr_type::ctrl

Definition at line 298 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::ctrl_bit

◆ ctrlsts

__IO uint32_t bpr_type::ctrlsts

Definition at line 312 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::ctrlsts_bit

◆ dt

__IO uint32_t bpr_type::dt

Definition at line 153 of file at32f413_bpr.h.

◆ dt1

__IO uint32_t bpr_type::dt1

Definition at line 150 of file at32f413_bpr.h.

◆ dt10

__IO uint32_t bpr_type::dt10

Definition at line 267 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt10_bit

◆ dt11

__IO uint32_t bpr_type::dt11

Definition at line 340 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt11_bit

◆ dt12

__IO uint32_t bpr_type::dt12

Definition at line 353 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt12_bit

◆ dt13

__IO uint32_t bpr_type::dt13

Definition at line 366 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt13_bit

◆ dt14

__IO uint32_t bpr_type::dt14

Definition at line 379 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt14_bit

◆ dt15

__IO uint32_t bpr_type::dt15

Definition at line 392 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt15_bit

◆ dt16

__IO uint32_t bpr_type::dt16

Definition at line 405 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt16_bit

◆ dt17

__IO uint32_t bpr_type::dt17

Definition at line 418 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt17_bit

◆ dt18

__IO uint32_t bpr_type::dt18

Definition at line 431 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt18_bit

◆ dt19

__IO uint32_t bpr_type::dt19

Definition at line 444 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt19_bit

◆

struct { ... } bpr_type::dt1_bit

◆ dt2

__IO uint32_t bpr_type::dt2

Definition at line 163 of file at32f413_bpr.h.

◆ dt20

__IO uint32_t bpr_type::dt20

Definition at line 457 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt20_bit

◆ dt21

__IO uint32_t bpr_type::dt21

Definition at line 470 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt21_bit

◆ dt22

__IO uint32_t bpr_type::dt22

Definition at line 483 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt22_bit

◆ dt23

__IO uint32_t bpr_type::dt23

Definition at line 496 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt23_bit

◆ dt24

__IO uint32_t bpr_type::dt24

Definition at line 509 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt24_bit

◆ dt25

__IO uint32_t bpr_type::dt25

Definition at line 522 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt25_bit

◆ dt26

__IO uint32_t bpr_type::dt26

Definition at line 535 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt26_bit

◆ dt27

__IO uint32_t bpr_type::dt27

Definition at line 548 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt27_bit

◆ dt28

__IO uint32_t bpr_type::dt28

Definition at line 561 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt28_bit

◆ dt29

__IO uint32_t bpr_type::dt29

Definition at line 574 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt29_bit

◆

struct { ... } bpr_type::dt2_bit

◆ dt3

__IO uint32_t bpr_type::dt3

Definition at line 176 of file at32f413_bpr.h.

◆ dt30

__IO uint32_t bpr_type::dt30

Definition at line 587 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt30_bit

◆ dt31

__IO uint32_t bpr_type::dt31

Definition at line 600 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt31_bit

◆ dt32

__IO uint32_t bpr_type::dt32

Definition at line 613 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt32_bit

◆ dt33

__IO uint32_t bpr_type::dt33

Definition at line 626 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt33_bit

◆ dt34

__IO uint32_t bpr_type::dt34

Definition at line 639 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt34_bit

◆ dt35

__IO uint32_t bpr_type::dt35

Definition at line 652 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt35_bit

◆ dt36

__IO uint32_t bpr_type::dt36

Definition at line 665 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt36_bit

◆ dt37

__IO uint32_t bpr_type::dt37

Definition at line 678 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt37_bit

◆ dt38

__IO uint32_t bpr_type::dt38

Definition at line 691 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt38_bit

◆ dt39

__IO uint32_t bpr_type::dt39

Definition at line 704 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt39_bit

◆

struct { ... } bpr_type::dt3_bit

◆ dt4

__IO uint32_t bpr_type::dt4

Definition at line 189 of file at32f413_bpr.h.

◆ dt40

__IO uint32_t bpr_type::dt40

Definition at line 717 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt40_bit

◆ dt41

__IO uint32_t bpr_type::dt41

Definition at line 730 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt41_bit

◆ dt42

__IO uint32_t bpr_type::dt42

Definition at line 743 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt42_bit

◆

struct { ... } bpr_type::dt4_bit

◆ dt5

__IO uint32_t bpr_type::dt5

Definition at line 202 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt5_bit

◆ dt6

__IO uint32_t bpr_type::dt6

Definition at line 215 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt6_bit

◆ dt7

__IO uint32_t bpr_type::dt7

Definition at line 228 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt7_bit

◆ dt8

__IO uint32_t bpr_type::dt8

Definition at line 241 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt8_bit

◆ dt9

__IO uint32_t bpr_type::dt9

Definition at line 254 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::dt9_bit

◆ outen

__IO uint32_t bpr_type::outen

Definition at line 285 of file at32f413_bpr.h.

◆ outm

__IO uint32_t bpr_type::outm

Definition at line 288 of file at32f413_bpr.h.

◆ outsel

__IO uint32_t bpr_type::outsel

Definition at line 286 of file at32f413_bpr.h.

◆ reserved1

__IO uint32_t bpr_type::reserved1

reserved, offset:0x00

Definition at line 143 of file at32f413_bpr.h.

◆ reserved2

__IO uint32_t bpr_type::reserved2

reserved, offset:0x38

Definition at line 321 of file at32f413_bpr.h.

◆ reserved3

__IO uint32_t bpr_type::reserved3

reserved, offset:0x3C

Definition at line 333 of file at32f413_bpr.h.

◆ rtccal

__IO uint32_t bpr_type::rtccal

Definition at line 280 of file at32f413_bpr.h.

◆

struct { ... } bpr_type::rtccal_bit

◆ tpef

__IO uint32_t bpr_type::tpef

Definition at line 319 of file at32f413_bpr.h.

◆ tpefclr

__IO uint32_t bpr_type::tpefclr

Definition at line 315 of file at32f413_bpr.h.

◆ tpen

__IO uint32_t bpr_type::tpen

Definition at line 301 of file at32f413_bpr.h.

◆ tpien

__IO uint32_t bpr_type::tpien

Definition at line 317 of file at32f413_bpr.h.

◆ tpif

__IO uint32_t bpr_type::tpif

Definition at line 320 of file at32f413_bpr.h.

◆ tpifclr

__IO uint32_t bpr_type::tpifclr

Definition at line 316 of file at32f413_bpr.h.

◆ tpp

__IO uint32_t bpr_type::tpp

Definition at line 302 of file at32f413_bpr.h.

The documentation for this struct was generated from the following file:
  • at32f413_bpr.h


AT32F413 Firmwary Library: BPR_exported_functions

Functions
BPR_exported_functions
AT32F413_periph_driver » BPR

Functions

void | bpr_reset (void)
bpr reset by crm reset register More...
flag_status | bpr_flag_get (uint32_t flag)
bpr event flag get, for tamper event flag More...
void | bpr_flag_clear (uint32_t flag)
clear bpr tamper flag More...
void | bpr_interrupt_enable (confirm_state new_state)
enable or disable bpr tamper interrupt More...
uint16_t | bpr_data_read (bpr_data_type bpr_data)
read bpr bpr data More...
void | bpr_data_write (bpr_data_type bpr_data, uint16_t data_value)
write bpr data More...
void | bpr_rtc_output_select (bpr_rtc_output_type output_source)
select bpr rtc output More...
void | bpr_rtc_clock_calibration_value_set (uint8_t calibration_value)
set rtc clock calibration value More...
void | bpr_tamper_pin_enable (confirm_state new_state)
enable or disable bpr tamper pin More...
void | bpr_tamper_pin_active_level_set (bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level More...

Detailed Description

Function Documentation

◆ bpr_data_read()

uint16_t bpr_data_read ( bpr_data_type bpr_data )

read bpr bpr data

Parameters
bpr_data this parameter can be one of the following values:
  • BPR_DATA1
  • BPR_DATA2 ...
  • BPR_DATA41
  • BPR_DATA42
Return values
none

Definition at line 116 of file at32f413_bpr.c.

Referenced by bpr_reg_check(), bpr_reg_judge(), and rtc_init().

◆ bpr_data_write()

void bpr_data_write | ( | bpr_data_type | bpr_data,
 |  | uint16_t | data_value
 | ) |  |

write bpr data

Parameters
bpr_data this parameter can be one of the following values:
  • BPR_DATA1
  • BPR_DATA2 ...
  • BPR_DATA41
  • BPR_DATA42
data_value (0x0000~0xFFFF)
Return values
none

Definition at line 133 of file at32f413_bpr.c.

Referenced by bpr_reg_write(), and rtc_init().

◆ bpr_flag_clear()

void bpr_flag_clear ( uint32_t flag )

clear bpr tamper flag

Parameters
flag specifies the flag to clear. this parameter can be one of the following values:
  • BPR_TAMPER_INTERRUPT_FLAG: tamper interrupt flag
  • BPR_TAMPER_EVENT_FLAG: tamper event flag
Return values
none

< bpr tamper interrupt flag

Definition at line 83 of file at32f413_bpr.c.

Referenced by main(), and TAMPER_IRQHandler().

◆ bpr_flag_get()

flag_status bpr_flag_get ( uint32_t flag )

bpr event flag get, for tamper event flag

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • BPR_TAMPER_INTERRUPT_FLAG: tamper interrupt flag
  • BPR_TAMPER_EVENT_FLAG: tamper event flag
Return values
state of tamper event flag

< bpr tamper interrupt flag

Definition at line 63 of file at32f413_bpr.c.

Referenced by TAMPER_IRQHandler().

◆ bpr_interrupt_enable()

void bpr_interrupt_enable ( confirm_state new_state )

enable or disable bpr tamper interrupt

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 100 of file at32f413_bpr.c.

Referenced by main().

◆ bpr_reset()

void bpr_reset ( void )

bpr reset by crm reset register

Parameters
none
Return values
none

Definition at line 49 of file at32f413_bpr.c.

Referenced by main(), rtc_config(), rtc_configuration(), and rtc_init().

◆ bpr_rtc_clock_calibration_value_set()

void bpr_rtc_clock_calibration_value_set ( uint8_t calibration_value )

set rtc clock calibration value

Parameters
calibration_value (0x00~0x7f)
Return values
none

Definition at line 165 of file at32f413_bpr.c.

◆ bpr_rtc_output_select()

void bpr_rtc_output_select ( bpr_rtc_output_type output_source )

select bpr rtc output

Parameters
output_source this parameter can be one of the following values:
  • BPR_RTC_OUTPUT_NONE: output disable.
  • BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE: output clock before calibration.
  • BPR_RTC_OUTPUT_ALARM: output alarm event with pluse mode.
  • BPR_RTC_OUTPUT_SECOND: output second event with pluse mode.
  • BPR_RTC_OUTPUT_CLOCK_CAL_AFTER: output clock after calibration.
  • BPR_RTC_OUTPUT_ALARM_TOGGLE: output alarm event with toggle mode.
  • BPR_RTC_OUTPUT_SECOND_TOGGLE: output second event with toggle mode.
Return values
none

Definition at line 151 of file at32f413_bpr.c.

Referenced by rtc_configuration().

◆ bpr_tamper_pin_active_level_set()

void bpr_tamper_pin_active_level_set ( bpr_tamper_pin_active_level_type active_level )

set bpr tamper pin active level

Parameters
active_level this parameter can be one of the following values:
  • BPR_TAMPER_PIN_ACTIVE_HIGH: tamper pin input active level is high.
  • BPR_TAMPER_PIN_ACTIVE_LOW: tamper pin input active level is low.
Return values
none

Definition at line 189 of file at32f413_bpr.c.

Referenced by main().

◆ bpr_tamper_pin_enable()

void bpr_tamper_pin_enable ( confirm_state new_state )

enable or disable bpr tamper pin

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 176 of file at32f413_bpr.c.

Referenced by main(), rtc_configuration(), and TAMPER_IRQHandler().


AT32F413 Firmwary Library: BPR_private_functions

Functions
BPR_private_functions
AT32F413_periph_driver » BPR

Functions

void | bpr_reset (void)
bpr reset by crm reset register More...
flag_status | bpr_flag_get (uint32_t flag)
bpr event flag get, for tamper event flag More...
void | bpr_flag_clear (uint32_t flag)
clear bpr tamper flag More...
void | bpr_interrupt_enable (confirm_state new_state)
enable or disable bpr tamper interrupt More...
uint16_t | bpr_data_read (bpr_data_type bpr_data)
read bpr bpr data More...
void | bpr_data_write (bpr_data_type bpr_data, uint16_t data_value)
write bpr data More...
void | bpr_rtc_output_select (bpr_rtc_output_type output_source)
select bpr rtc output More...
void | bpr_rtc_clock_calibration_value_set (uint8_t calibration_value)
set rtc clock calibration value More...
void | bpr_tamper_pin_enable (confirm_state new_state)
enable or disable bpr tamper pin More...
void | bpr_tamper_pin_active_level_set (bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level More...

Detailed Description

Function Documentation

◆ bpr_data_read()

uint16_t bpr_data_read ( bpr_data_type bpr_data )

read bpr bpr data

Parameters
bpr_data this parameter can be one of the following values:
  • BPR_DATA1
  • BPR_DATA2 ...
  • BPR_DATA41
  • BPR_DATA42
Return values
none

Definition at line 116 of file at32f413_bpr.c.

Referenced by bpr_reg_check(), bpr_reg_judge(), and rtc_init().

◆ bpr_data_write()

void bpr_data_write | ( | bpr_data_type | bpr_data,
 |  | uint16_t | data_value
 | ) |  |

write bpr data

Parameters
bpr_data this parameter can be one of the following values:
  • BPR_DATA1
  • BPR_DATA2 ...
  • BPR_DATA41
  • BPR_DATA42
data_value (0x0000~0xFFFF)
Return values
none

Definition at line 133 of file at32f413_bpr.c.

Referenced by bpr_reg_write(), and rtc_init().

◆ bpr_flag_clear()

void bpr_flag_clear ( uint32_t flag )

clear bpr tamper flag

Parameters
flag specifies the flag to clear. this parameter can be one of the following values:
  • BPR_TAMPER_INTERRUPT_FLAG: tamper interrupt flag
  • BPR_TAMPER_EVENT_FLAG: tamper event flag
Return values
none

< bpr tamper interrupt flag

Definition at line 83 of file at32f413_bpr.c.

Referenced by main(), and TAMPER_IRQHandler().

◆ bpr_flag_get()

flag_status bpr_flag_get ( uint32_t flag )

bpr event flag get, for tamper event flag

Parameters
flag specifies the flag to check. this parameter can be one of the following values:
  • BPR_TAMPER_INTERRUPT_FLAG: tamper interrupt flag
  • BPR_TAMPER_EVENT_FLAG: tamper event flag
Return values
state of tamper event flag

< bpr tamper interrupt flag

Definition at line 63 of file at32f413_bpr.c.

Referenced by TAMPER_IRQHandler().

◆ bpr_interrupt_enable()

void bpr_interrupt_enable ( confirm_state new_state )

enable or disable bpr tamper interrupt

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 100 of file at32f413_bpr.c.

Referenced by main().

◆ bpr_reset()

void bpr_reset ( void )

bpr reset by crm reset register

Parameters
none
Return values
none

Definition at line 49 of file at32f413_bpr.c.

Referenced by main(), rtc_config(), rtc_configuration(), and rtc_init().

◆ bpr_rtc_clock_calibration_value_set()

void bpr_rtc_clock_calibration_value_set ( uint8_t calibration_value )

set rtc clock calibration value

Parameters
calibration_value (0x00~0x7f)
Return values
none

Definition at line 165 of file at32f413_bpr.c.

◆ bpr_rtc_output_select()

void bpr_rtc_output_select ( bpr_rtc_output_type output_source )

select bpr rtc output

Parameters
output_source this parameter can be one of the following values:
  • BPR_RTC_OUTPUT_NONE: output disable.
  • BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE: output clock before calibration.
  • BPR_RTC_OUTPUT_ALARM: output alarm event with pluse mode.
  • BPR_RTC_OUTPUT_SECOND: output second event with pluse mode.
  • BPR_RTC_OUTPUT_CLOCK_CAL_AFTER: output clock after calibration.
  • BPR_RTC_OUTPUT_ALARM_TOGGLE: output alarm event with toggle mode.
  • BPR_RTC_OUTPUT_SECOND_TOGGLE: output second event with toggle mode.
Return values
none

Definition at line 151 of file at32f413_bpr.c.

Referenced by rtc_configuration().

◆ bpr_tamper_pin_active_level_set()

void bpr_tamper_pin_active_level_set ( bpr_tamper_pin_active_level_type active_level )

set bpr tamper pin active level

Parameters
active_level this parameter can be one of the following values:
  • BPR_TAMPER_PIN_ACTIVE_HIGH: tamper pin input active level is high.
  • BPR_TAMPER_PIN_ACTIVE_LOW: tamper pin input active level is low.
Return values
none

Definition at line 189 of file at32f413_bpr.c.

Referenced by main().

◆ bpr_tamper_pin_enable()

void bpr_tamper_pin_enable ( confirm_state new_state )

enable or disable bpr tamper pin

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 176 of file at32f413_bpr.c.

Referenced by main(), rtc_configuration(), and TAMPER_IRQHandler().


AT32F413 Firmwary Library: CAN

Modules | Macros
CAN
AT32F413_periph_driver

CAN driver modules. More...

Modules

CAN_timeout_count
CAN_flags_definition
can flag
CAN_interrupts_definition
can interrupt
CAN_exported_types
CAN_exported_functions
CAN_private_functions

Macros

#define | CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)
can flag clear operation macro definition val More...
#define | CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)
#define | CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)
#define | CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)
#define | CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)
#define | CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)
#define | CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)
#define | CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)
#define | CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)
#define | CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)
#define | CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)
#define | CAN1 ((can_type *) CAN1_BASE)
#define | CAN2 ((can_type *) CAN2_BASE)

Detailed Description

CAN driver modules.

Macro Definition Documentation

◆ CAN1

#define CAN1 ((can_type *) CAN1_BASE)

Definition at line 938 of file at32f413_can.h.

◆ CAN2

#define CAN2 ((can_type *) CAN2_BASE)

Definition at line 939 of file at32f413_can.h.

◆ CAN_MSTS_EDZIF_VAL

#define CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)

edzif bit value, it clear by writing 1

Definition at line 115 of file at32f413_can.h.

◆ CAN_MSTS_EOIF_VAL

#define CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)

can flag clear operation macro definition val

eoif bit value, it clear by writing 1

Definition at line 113 of file at32f413_can.h.

◆ CAN_MSTS_QDZIF_VAL

#define CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)

qdzif bit value, it clear by writing 1

Definition at line 114 of file at32f413_can.h.

◆ CAN_RF0_RF0FF_VAL

#define CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)

rf0ff bit value, it clear by writing 1

Definition at line 122 of file at32f413_can.h.

◆ CAN_RF0_RF0OF_VAL

#define CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)

rf0of bit value, it clear by writing 1

Definition at line 123 of file at32f413_can.h.

◆ CAN_RF0_RF0R_VAL

#define CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)

rf0r bit value, it clear by writing 1

Definition at line 124 of file at32f413_can.h.

◆ CAN_RF1_RF1FF_VAL

#define CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)

rf1ff bit value, it clear by writing 1

Definition at line 125 of file at32f413_can.h.

◆ CAN_RF1_RF1OF_VAL

#define CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)

rf1of bit value, it clear by writing 1

Definition at line 126 of file at32f413_can.h.

◆ CAN_RF1_RF1R_VAL

#define CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)

rf1r bit value, it clear by writing 1

Definition at line 127 of file at32f413_can.h.

◆ CAN_TSTS_TM0CT_VAL

#define CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)

tm0ct bit value, it clear by writing 1

Definition at line 119 of file at32f413_can.h.

◆ CAN_TSTS_TM0TCF_VAL

#define CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)

tm0tcf bit value, it clear by writing 1

Definition at line 116 of file at32f413_can.h.

◆ CAN_TSTS_TM1CT_VAL

#define CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)

tm1ct bit value, it clear by writing 1

Definition at line 120 of file at32f413_can.h.

◆ CAN_TSTS_TM1TCF_VAL

#define CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)

tm1tcf bit value, it clear by writing 1

Definition at line 117 of file at32f413_can.h.

◆ CAN_TSTS_TM2CT_VAL

#define CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)

tm2ct bit value, it clear by writing 1

Definition at line 121 of file at32f413_can.h.

◆ CAN_TSTS_TM2TCF_VAL

#define CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)

tm2tcf bit value, it clear by writing 1

Definition at line 118 of file at32f413_can.h.


AT32F413 Firmwary Library: CAN_timeout_count

Macros
CAN_timeout_count
AT32F413_periph_driver » CAN

Macros

#define | FZC_TIMEOUT ((uint32_t)0x0000FFFF)
#define | DZC_TIMEOUT ((uint32_t)0x0000FFFF)

Detailed Description

Macro Definition Documentation

◆ DZC_TIMEOUT

#define DZC_TIMEOUT ((uint32_t)0x0000FFFF)

time out for dzc bit

Definition at line 53 of file at32f413_can.h.

◆ FZC_TIMEOUT

#define FZC_TIMEOUT ((uint32_t)0x0000FFFF)

time out for fzc bit

Definition at line 52 of file at32f413_can.h.


AT32F413 Firmwary Library: CAN_flags_definition

Macros
CAN_flags_definition
AT32F413_periph_driver » CAN

can flag More...

Macros

#define | CAN_EAF_FLAG ((uint32_t)0x01)
#define | CAN_EPF_FLAG ((uint32_t)0x02)
#define | CAN_BOF_FLAG ((uint32_t)0x03)
#define | CAN_ETR_FLAG ((uint32_t)0x04)
#define | CAN_EOIF_FLAG ((uint32_t)0x05)
#define | CAN_TM0TCF_FLAG ((uint32_t)0x06)
#define | CAN_TM1TCF_FLAG ((uint32_t)0x07)
#define | CAN_TM2TCF_FLAG ((uint32_t)0x08)
#define | CAN_RF0MN_FLAG ((uint32_t)0x09)
#define | CAN_RF0FF_FLAG ((uint32_t)0x0A)
#define | CAN_RF0OF_FLAG ((uint32_t)0x0B)
#define | CAN_RF1MN_FLAG ((uint32_t)0x0C)
#define | CAN_RF1FF_FLAG ((uint32_t)0x0D)
#define | CAN_RF1OF_FLAG ((uint32_t)0x0E)
#define | CAN_QDZIF_FLAG ((uint32_t)0x0F)
#define | CAN_EDZC_FLAG ((uint32_t)0x10)
#define | CAN_TMEF_FLAG ((uint32_t)0x11)

Detailed Description

can flag

Macro Definition Documentation

◆ CAN_BOF_FLAG

#define CAN_BOF_FLAG ((uint32_t)0x03)

bus-off flag

Definition at line 66 of file at32f413_can.h.

◆ CAN_EAF_FLAG

#define CAN_EAF_FLAG ((uint32_t)0x01)

error active flag

Definition at line 64 of file at32f413_can.h.

◆ CAN_EDZC_FLAG

#define CAN_EDZC_FLAG ((uint32_t)0x10)

enter doze mode confirm flag

Definition at line 79 of file at32f413_can.h.

◆ CAN_EOIF_FLAG

#define CAN_EOIF_FLAG ((uint32_t)0x05)

error occur interrupt flag

Definition at line 68 of file at32f413_can.h.

◆ CAN_EPF_FLAG

#define CAN_EPF_FLAG ((uint32_t)0x02)

error passive flag

Definition at line 65 of file at32f413_can.h.

◆ CAN_ETR_FLAG

#define CAN_ETR_FLAG ((uint32_t)0x04)

error type record flag

Definition at line 67 of file at32f413_can.h.

◆ CAN_QDZIF_FLAG

#define CAN_QDZIF_FLAG ((uint32_t)0x0F)

quit doze mode interrupt flag

Definition at line 78 of file at32f413_can.h.

◆ CAN_RF0FF_FLAG

#define CAN_RF0FF_FLAG ((uint32_t)0x0A)

receive fifo 0 full flag

Definition at line 73 of file at32f413_can.h.

◆ CAN_RF0MN_FLAG

#define CAN_RF0MN_FLAG ((uint32_t)0x09)

receive fifo 0 message num flag

Definition at line 72 of file at32f413_can.h.

◆ CAN_RF0OF_FLAG

#define CAN_RF0OF_FLAG ((uint32_t)0x0B)

receive fifo 0 overflow flag

Definition at line 74 of file at32f413_can.h.

◆ CAN_RF1FF_FLAG

#define CAN_RF1FF_FLAG ((uint32_t)0x0D)

receive fifo 1 full flag

Definition at line 76 of file at32f413_can.h.

◆ CAN_RF1MN_FLAG

#define CAN_RF1MN_FLAG ((uint32_t)0x0C)

receive fifo 1 message num flag

Definition at line 75 of file at32f413_can.h.

◆ CAN_RF1OF_FLAG

#define CAN_RF1OF_FLAG ((uint32_t)0x0E)

receive fifo 1 overflow flag

Definition at line 77 of file at32f413_can.h.

◆ CAN_TM0TCF_FLAG

#define CAN_TM0TCF_FLAG ((uint32_t)0x06)

transmit mailbox 0 transmission completed flag

Definition at line 69 of file at32f413_can.h.

◆ CAN_TM1TCF_FLAG

#define CAN_TM1TCF_FLAG ((uint32_t)0x07)

transmit mailbox 1 transmission completed flag

Definition at line 70 of file at32f413_can.h.

◆ CAN_TM2TCF_FLAG

#define CAN_TM2TCF_FLAG ((uint32_t)0x08)

transmit mailbox 2 transmission completed flag

Definition at line 71 of file at32f413_can.h.

◆ CAN_TMEF_FLAG

#define CAN_TMEF_FLAG ((uint32_t)0x11)

transmit mailbox empty flag

Definition at line 80 of file at32f413_can.h.


AT32F413 Firmwary Library: CAN_interrupts_definition

Macros
CAN_interrupts_definition
AT32F413_periph_driver » CAN

can interrupt More...

Macros

#define | CAN_TCIEN_INT ((uint32_t)0x00000001)
#define | CAN_RF0MIEN_INT ((uint32_t)0x00000002)
#define | CAN_RF0FIEN_INT ((uint32_t)0x00000004)
#define | CAN_RF0OIEN_INT ((uint32_t)0x00000008)
#define | CAN_RF1MIEN_INT ((uint32_t)0x00000010)
#define | CAN_RF1FIEN_INT ((uint32_t)0x00000020)
#define | CAN_RF1OIEN_INT ((uint32_t)0x00000040)
#define | CAN_EAIEN_INT ((uint32_t)0x00000100)
#define | CAN_EPIEN_INT ((uint32_t)0x00000200)
#define | CAN_BOIEN_INT ((uint32_t)0x00000400)
#define | CAN_ETRIEN_INT ((uint32_t)0x00000800)
#define | CAN_EOIEN_INT ((uint32_t)0x00008000)
#define | CAN_QDZIEN_INT ((uint32_t)0x00010000)
#define | CAN_EDZIEN_INT ((uint32_t)0x00020000)

Detailed Description

can interrupt

Macro Definition Documentation

◆ CAN_BOIEN_INT

#define CAN_BOIEN_INT ((uint32_t)0x00000400)

bus-off interrupt

Definition at line 100 of file at32f413_can.h.

◆ CAN_EAIEN_INT

#define CAN_EAIEN_INT ((uint32_t)0x00000100)

error active interrupt

Definition at line 98 of file at32f413_can.h.

◆ CAN_EDZIEN_INT

#define CAN_EDZIEN_INT ((uint32_t)0x00020000)

enter doze mode confirm interrupt

Definition at line 104 of file at32f413_can.h.

◆ CAN_EOIEN_INT

#define CAN_EOIEN_INT ((uint32_t)0x00008000)

error occur interrupt

Definition at line 102 of file at32f413_can.h.

◆ CAN_EPIEN_INT

#define CAN_EPIEN_INT ((uint32_t)0x00000200)

error passive interrupt

Definition at line 99 of file at32f413_can.h.

◆ CAN_ETRIEN_INT

#define CAN_ETRIEN_INT ((uint32_t)0x00000800)

error type record interrupt

Definition at line 101 of file at32f413_can.h.

◆ CAN_QDZIEN_INT

#define CAN_QDZIEN_INT ((uint32_t)0x00010000)

quit doze mode interrupt

Definition at line 103 of file at32f413_can.h.

◆ CAN_RF0FIEN_INT

#define CAN_RF0FIEN_INT ((uint32_t)0x00000004)

receive fifo 0 full interrupt

Definition at line 93 of file at32f413_can.h.

◆ CAN_RF0MIEN_INT

#define CAN_RF0MIEN_INT ((uint32_t)0x00000002)

receive fifo 0 message interrupt

Definition at line 92 of file at32f413_can.h.

◆ CAN_RF0OIEN_INT

#define CAN_RF0OIEN_INT ((uint32_t)0x00000008)

receive fifo 0 overflow interrupt

Definition at line 94 of file at32f413_can.h.

◆ CAN_RF1FIEN_INT

#define CAN_RF1FIEN_INT ((uint32_t)0x00000020)

receive fifo 1 full interrupt

Definition at line 96 of file at32f413_can.h.

◆ CAN_RF1MIEN_INT

#define CAN_RF1MIEN_INT ((uint32_t)0x00000010)

receive fifo 1 message interrupt

Definition at line 95 of file at32f413_can.h.

◆ CAN_RF1OIEN_INT

#define CAN_RF1OIEN_INT ((uint32_t)0x00000040)

receive fifo 1 overflow interrupt

Definition at line 97 of file at32f413_can.h.

◆ CAN_TCIEN_INT

#define CAN_TCIEN_INT ((uint32_t)0x00000001)

transmission complete interrupt

Definition at line 91 of file at32f413_can.h.


AT32F413 Firmwary Library: CAN_exported_types

Data Structures | Enumerations
CAN_exported_types
AT32F413_periph_driver » CAN

Data Structures

struct | can_base_type
can init structure definition More...
struct | can_baudrate_type
can baudrate structure definition More...
struct | can_filter_init_type
can filter init structure definition More...
struct | can_tx_message_type
can tx message structure definition More...
struct | can_rx_message_type
can rx message structure definition More...
struct | can_tx_mailbox_type
can controller area network tx mailbox More...
struct | can_fifo_mailbox_type
can controller area network fifo mailbox More...
struct | can_filter_register_type
can controller area network filter bit register More...
struct | can_type
type define can register all More...

Enumerations

enum | can_filter_fifo_type { CAN_FILTER_FIFO0 = 0x00 , CAN_FILTER_FIFO1 = 0x01 }
can filter fifo More...
enum | can_filter_mode_type { CAN_FILTER_MODE_ID_MASK = 0x00 , CAN_FILTER_MODE_ID_LIST = 0x01 }
can filter mode More...
enum | can_filter_bit_width_type { CAN_FILTER_16BIT = 0x00 , CAN_FILTER_32BIT = 0x01 }
can filter bit width select More...
enum | can_mode_type { CAN_MODE_COMMUNICATE = 0x00 , CAN_MODE_LOOPBACK = 0x01 , CAN_MODE_LISTENONLY = 0x02 , CAN_MODE_LISTENONLY_LOOPBACK = 0x03 }
can mode More...
enum | can_operating_mode_type { CAN_OPERATINGMODE_FREEZE = 0x00 , CAN_OPERATINGMODE_DOZE = 0x01 , CAN_OPERATINGMODE_COMMUNICATE = 0x02 }
can operating mode More...
enum | can_rsaw_type { CAN_RSAW_1TQ = 0x00 , CAN_RSAW_2TQ = 0x01 , CAN_RSAW_3TQ = 0x02 , CAN_RSAW_4TQ = 0x03 }
can resynchronization adjust width More...
enum can_bts1_type {
CAN_BTS1_1TQ = 0x00 , CAN_BTS1_2TQ = 0x01 , CAN_BTS1_3TQ = 0x02 , CAN_BTS1_4TQ = 0x03 ,
CAN_BTS1_5TQ = 0x04 , CAN_BTS1_6TQ = 0x05 , CAN_BTS1_7TQ = 0x06 , CAN_BTS1_8TQ = 0x07 ,
CAN_BTS1_9TQ = 0x08 , CAN_BTS1_10TQ = 0x09 , CAN_BTS1_11TQ = 0x0A , CAN_BTS1_12TQ = 0x0B ,
CAN_BTS1_13TQ = 0x0C , CAN_BTS1_14TQ = 0x0D , CAN_BTS1_15TQ = 0x0E , CAN_BTS1_16TQ = 0x0F
}
can bit time segment 1 More...
enum can_bts2_type {
CAN_BTS2_1TQ = 0x00 , CAN_BTS2_2TQ = 0x01 , CAN_BTS2_3TQ = 0x02 , CAN_BTS2_4TQ = 0x03 ,
CAN_BTS2_5TQ = 0x04 , CAN_BTS2_6TQ = 0x05 , CAN_BTS2_7TQ = 0x06 , CAN_BTS2_8TQ = 0x07
}
can bit time segment 2 More...
enum | can_identifier_type { CAN_ID_STANDARD = 0x00 , CAN_ID_EXTENDED = 0x01 }
can identifier type More...
enum | can_trans_frame_type { CAN_TFT_DATA = 0x00 , CAN_TFT_REMOTE = 0x01 }
can transmission frame type More...
enum | can_tx_mailbox_num_type { CAN_TX_MAILBOX0 = 0x00 , CAN_TX_MAILBOX1 = 0x01 , CAN_TX_MAILBOX2 = 0x02 }
can tx mailboxes More...
enum | can_rx_fifo_num_type { CAN_RX_FIFO0 = 0x00 , CAN_RX_FIFO1 = 0x01 }
can receive fifo More...
enum | can_transmit_status_type { CAN_TX_STATUS_FAILED = 0x00 , CAN_TX_STATUS_SUCCESSFUL = 0x01 , CAN_TX_STATUS_PENDING = 0x02 , CAN_TX_STATUS_NO_EMPTY = 0x04 }
can transmit status More...
enum | can_enter_doze_status_type { CAN_ENTER_DOZE_FAILED = 0x00 , CAN_ENTER_DOZE_SUCCESSFUL = 0x01 }
can enter doze mode status More...
enum | can_quit_doze_status_type { CAN_QUIT_DOZE_FAILED = 0x00 , CAN_QUIT_DOZE_SUCCESSFUL = 0x01 }
can quit doze mode status More...
enum | can_msg_discarding_rule_type { CAN_DISCARDING_FIRST_RECEIVED = 0x00 , CAN_DISCARDING_LAST_RECEIVED = 0x01 }
can message discarding rule select when overflow More...
enum | can_msg_sending_rule_type { CAN_SENDING_BY_ID = 0x00 , CAN_SENDING_BY_REQUEST = 0x01 }
can multiple message sending sequence rule More...
enum can_error_record_type {
CAN_ERRORRECORD_NOERR = 0x00 , CAN_ERRORRECORD_STUFFERR = 0x01 , CAN_ERRORRECORD_FORMERR = 0x02 , CAN_ERRORRECORD_ACKERR = 0x03 ,
CAN_ERRORRECORD_BITRECESSIVEERR = 0x04 , CAN_ERRORRECORD_BITDOMINANTERR = 0x05 , CAN_ERRORRECORD_CRCERR = 0x06 , CAN_ERRORRECORD_SOFTWARESETERR = 0x07
}
can error type record More...

Detailed Description

Enumeration Type Documentation

◆ can_bts1_type

enum can_bts1_type

can bit time segment 1

Enumerator
CAN_BTS1_1TQ | 1 time quantum
CAN_BTS1_2TQ | 2 time quantum
CAN_BTS1_3TQ | 3 time quantum
CAN_BTS1_4TQ | 4 time quantum
CAN_BTS1_5TQ | 5 time quantum
CAN_BTS1_6TQ | 6 time quantum
CAN_BTS1_7TQ | 7 time quantum
CAN_BTS1_8TQ | 8 time quantum
CAN_BTS1_9TQ | 9 time quantum
CAN_BTS1_10TQ | 10 time quantum
CAN_BTS1_11TQ | 11 time quantum
CAN_BTS1_12TQ | 12 time quantum
CAN_BTS1_13TQ | 13 time quantum
CAN_BTS1_14TQ | 14 time quantum
CAN_BTS1_15TQ | 15 time quantum
CAN_BTS1_16TQ | 16 time quantum

Definition at line 195 of file at32f413_can.h.

◆ can_bts2_type

enum can_bts2_type

can bit time segment 2

Enumerator
CAN_BTS2_1TQ | 1 time quantum
CAN_BTS2_2TQ | 2 time quantum
CAN_BTS2_3TQ | 3 time quantum
CAN_BTS2_4TQ | 4 time quantum
CAN_BTS2_5TQ | 5 time quantum
CAN_BTS2_6TQ | 6 time quantum
CAN_BTS2_7TQ | 7 time quantum
CAN_BTS2_8TQ | 8 time quantum

Definition at line 218 of file at32f413_can.h.

◆ can_enter_doze_status_type

enum can_enter_doze_status_type

can enter doze mode status

Enumerator
CAN_ENTER_DOZE_FAILED | can enter the doze mode failed
CAN_ENTER_DOZE_SUCCESSFUL | can enter the doze mode successful

Definition at line 281 of file at32f413_can.h.

◆ can_error_record_type

enum can_error_record_type

can error type record

Enumerator
CAN_ERRORRECORD_NOERR | no error
CAN_ERRORRECORD_STUFFERR | stuff error
CAN_ERRORRECORD_FORMERR | form error
CAN_ERRORRECORD_ACKERR | acknowledgment error
CAN_ERRORRECORD_BITRECESSIVEERR | bit recessive error
CAN_ERRORRECORD_BITDOMINANTERR | bit dominant error
CAN_ERRORRECORD_CRCERR | crc error
CAN_ERRORRECORD_SOFTWARESETERR | software set error

Definition at line 317 of file at32f413_can.h.

◆ can_filter_bit_width_type

enum can_filter_bit_width_type

can filter bit width select

Enumerator
CAN_FILTER_16BIT | two 16-bit filters
CAN_FILTER_32BIT | one 32-bit filter

Definition at line 154 of file at32f413_can.h.

◆ can_filter_fifo_type

enum can_filter_fifo_type

can filter fifo

Enumerator
CAN_FILTER_FIFO0 | filter fifo 0 assignment for filter x
CAN_FILTER_FIFO1 | filter fifo 1 assignment for filter x

Definition at line 136 of file at32f413_can.h.

◆ can_filter_mode_type

enum can_filter_mode_type

can filter mode

Enumerator
CAN_FILTER_MODE_ID_MASK | identifier mask mode
CAN_FILTER_MODE_ID_LIST | identifier list mode

Definition at line 145 of file at32f413_can.h.

◆ can_identifier_type

enum can_identifier_type

can identifier type

Enumerator
CAN_ID_STANDARD | standard Id
CAN_ID_EXTENDED | extended Id

Definition at line 233 of file at32f413_can.h.

◆ can_mode_type

enum can_mode_type

can mode

Enumerator
CAN_MODE_COMMUNICATE | communication mode
CAN_MODE_LOOPBACK | loopback mode
CAN_MODE_LISTENONLY | listen-only mode
CAN_MODE_LISTENONLY_LOOPBACK | loopback combined with listen-only mode

Definition at line 163 of file at32f413_can.h.

◆ can_msg_discarding_rule_type

enum can_msg_discarding_rule_type

can message discarding rule select when overflow

Enumerator
CAN_DISCARDING_FIRST_RECEIVED | can discarding the first received message
CAN_DISCARDING_LAST_RECEIVED | can discarding the last received message

Definition at line 299 of file at32f413_can.h.

◆ can_msg_sending_rule_type

enum can_msg_sending_rule_type

can multiple message sending sequence rule

Enumerator
CAN_SENDING_BY_ID | can sending the minimum id message first
CAN_SENDING_BY_REQUEST | can sending the first request message first

Definition at line 308 of file at32f413_can.h.

◆ can_operating_mode_type

enum can_operating_mode_type

can operating mode

Enumerator
CAN_OPERATINGMODE_FREEZE | freeze mode
CAN_OPERATINGMODE_DOZE | doze mode
CAN_OPERATINGMODE_COMMUNICATE | communication mode

Definition at line 174 of file at32f413_can.h.

◆ can_quit_doze_status_type

enum can_quit_doze_status_type

can quit doze mode status

Enumerator
CAN_QUIT_DOZE_FAILED | can quit doze mode failed
CAN_QUIT_DOZE_SUCCESSFUL | can quit doze mode successful

Definition at line 290 of file at32f413_can.h.

◆ can_rsaw_type

enum can_rsaw_type

can resynchronization adjust width

Enumerator
CAN_RSAW_1TQ | 1 time quantum
CAN_RSAW_2TQ | 2 time quantum
CAN_RSAW_3TQ | 3 time quantum
CAN_RSAW_4TQ | 4 time quantum

Definition at line 184 of file at32f413_can.h.

◆ can_rx_fifo_num_type

enum can_rx_fifo_num_type

can receive fifo

Enumerator
CAN_RX_FIFO0 | can fifo 0 used to receive
CAN_RX_FIFO1 | can fifo 1 used to receive

Definition at line 261 of file at32f413_can.h.

◆ can_trans_frame_type

enum can_trans_frame_type

can transmission frame type

Enumerator
CAN_TFT_DATA | data frame
CAN_TFT_REMOTE | remote frame

Definition at line 242 of file at32f413_can.h.

◆ can_transmit_status_type

enum can_transmit_status_type

can transmit status

Enumerator
CAN_TX_STATUS_FAILED | can transmission failed
CAN_TX_STATUS_SUCCESSFUL | can transmission successful
CAN_TX_STATUS_PENDING | can transmission pending
CAN_TX_STATUS_NO_EMPTY | can transmission no empty mailbox

Definition at line 270 of file at32f413_can.h.

◆ can_tx_mailbox_num_type

enum can_tx_mailbox_num_type

can tx mailboxes

Enumerator
CAN_TX_MAILBOX0 | can tx mailbox 0
CAN_TX_MAILBOX1 | can tx mailbox 1
CAN_TX_MAILBOX2 | can tx mailbox 2

Definition at line 251 of file at32f413_can.h.


AT32F413 Firmwary Library: can_base_type Struct Reference

Data Fields
can_base_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can init structure definition More...

#include <at32f413_can.h>

Data Fields

can_mode_type mode_selection
confirm_state ttc_enable
confirm_state aebo_enable
confirm_state aed_enable
confirm_state prsf_enable
can_msg_discarding_rule_type mdrsel_selection
can_msg_sending_rule_type mmssr_selection

Detailed Description

can init structure definition

Definition at line 332 of file at32f413_can.h.

Field Documentation

◆ aebo_enable

confirm_state can_base_type::aebo_enable

automatic exit bus-off enable

Definition at line 338 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ aed_enable

confirm_state can_base_type::aed_enable

automatic exit doze mode enable

Definition at line 340 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ mdrsel_selection

can_msg_discarding_rule_type can_base_type::mdrsel_selection

message discarding rule select when overflow

Definition at line 344 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ mmssr_selection

can_msg_sending_rule_type can_base_type::mmssr_selection

multiple message sending sequence rule

Definition at line 346 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ mode_selection

can_mode_type can_base_type::mode_selection

specifies the can mode.

Definition at line 334 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ prsf_enable

confirm_state can_base_type::prsf_enable

prohibit retransmission when sending fails enable

Definition at line 342 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

◆ ttc_enable

confirm_state can_base_type::ttc_enable

time triggered communication mode enable

Definition at line 336 of file at32f413_can.h.

Referenced by can_base_init(), can_configuration(), and can_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_baudrate_type Struct Reference

Data Fields
can_baudrate_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can baudrate structure definition More...

#include <at32f413_can.h>

Data Fields

uint16_t baudrate_div
can_rsaw_type rsaw_size
can_bts1_type bts1_size
can_bts2_type bts2_size

Detailed Description

can baudrate structure definition

Definition at line 353 of file at32f413_can.h.

Field Documentation

◆ baudrate_div

uint16_t can_baudrate_type::baudrate_div

baudrate division,this parameter can be 0x001~0x400.

Definition at line 355 of file at32f413_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

◆ bts1_size

can_bts1_type can_baudrate_type::bts1_size

bit time segment 1

Definition at line 359 of file at32f413_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

◆ bts2_size

can_bts2_type can_baudrate_type::bts2_size

bit time segment 2

Definition at line 361 of file at32f413_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

◆ rsaw_size

can_rsaw_type can_baudrate_type::rsaw_size

resynchronization adjust width

Definition at line 357 of file at32f413_can.h.

Referenced by can_baudrate_default_para_init(), can_baudrate_set(), and can_configuration().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_filter_init_type Struct Reference

Data Fields
can_filter_init_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can filter init structure definition More...

#include <at32f413_can.h>

Data Fields

confirm_state filter_activate_enable
can_filter_mode_type filter_mode
can_filter_fifo_type filter_fifo
uint8_t | filter_number
can_filter_bit_width_type filter_bit
uint16_t | filter_id_high
uint16_t | filter_id_low
uint16_t | filter_mask_high
uint16_t | filter_mask_low

Detailed Description

can filter init structure definition

Definition at line 368 of file at32f413_can.h.

Field Documentation

◆ filter_activate_enable

confirm_state can_filter_init_type::filter_activate_enable

enable or disable the filter activate.

Definition at line 370 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_bit

can_filter_bit_width_type can_filter_init_type::filter_bit

config the filter bit width 16bit or 32bit.

Definition at line 378 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_fifo

can_filter_fifo_type can_filter_init_type::filter_fifo

config the fifo which will be assigned to the filter.

Definition at line 374 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_id_high

uint16_t can_filter_init_type::filter_id_high

config the filter identification, for 32-bit configuration it's high 16 bits, for 16-bit configuration it's first.

Definition at line 380 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_id_low

uint16_t can_filter_init_type::filter_id_low

config the filter identification, for 32-bit configuration it's low 16 bits, for 16-bit configuration it's second.

Definition at line 383 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_mask_high

uint16_t can_filter_init_type::filter_mask_high

config the filter mask or identification, according to the filtering mode, for 32-bit configuration it's high 16 bits, for 16-bit configuration it's first.

Definition at line 386 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_mask_low

uint16_t can_filter_init_type::filter_mask_low

config the filter mask or identification, according to the filtering mode, for 32-bit configuration it's low 16 bits, for 16-bit configuration it's second.

Definition at line 389 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_mode

can_filter_mode_type can_filter_init_type::filter_mode

config the filter mode mask or list.

Definition at line 372 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

◆ filter_number

uint8_t can_filter_init_type::filter_number

config the filter number, parameter ranges from 0 to 13.

Definition at line 376 of file at32f413_can.h.

Referenced by can_configuration(), can_filter_default_para_init(), and can_filter_init().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_tx_message_type Struct Reference

Data Fields
can_tx_message_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can tx message structure definition More...

#include <at32f413_can.h>

Data Fields

uint32_t | standard_id
uint32_t | extended_id
can_identifier_type id_type
can_trans_frame_type frame_type
uint8_t | dlc
uint8_t | data [8]

Detailed Description

can tx message structure definition

Definition at line 396 of file at32f413_can.h.

Field Documentation

◆ data

uint8_t can_tx_message_type::data[8]

contains the transmit data. it ranges from 0 to 0xFF.

Definition at line 411 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ dlc

uint8_t can_tx_message_type::dlc

specifies frame data length that will be transmitted. this parameter can be a value between 0 to 8

Definition at line 408 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ extended_id

uint32_t can_tx_message_type::extended_id

specifies the 29 bits extended identifier. this parameter can be a value between 0 to 0x1FFFFFFF.

Definition at line 401 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ frame_type

can_trans_frame_type can_tx_message_type::frame_type

specifies frame type for the transmit message.

Definition at line 406 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ id_type

can_identifier_type can_tx_message_type::id_type

specifies identifier type for the transmit message.

Definition at line 404 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

◆ standard_id

uint32_t can_tx_message_type::standard_id

specifies the 11 bits standard identifier. this parameter can be a value between 0 to 0x7FF.

Definition at line 398 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_transmit_data().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_rx_message_type Struct Reference

Data Fields
can_rx_message_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can rx message structure definition More...

#include <at32f413_can.h>

Data Fields

uint32_t | standard_id
uint32_t | extended_id
can_identifier_type id_type
can_trans_frame_type frame_type
uint8_t | dlc
uint8_t | data [8]
uint8_t | filter_index

Detailed Description

can rx message structure definition

Definition at line 418 of file at32f413_can.h.

Field Documentation

◆ data

uint8_t can_rx_message_type::data[8]

contains the receive data. it ranges from 0 to 0xFF.

Definition at line 433 of file at32f413_can.h.

Referenced by can_message_receive().

◆ dlc

uint8_t can_rx_message_type::dlc

specifies the frame data length that will be received. this parameter can be a value between 0 to 8

Definition at line 430 of file at32f413_can.h.

Referenced by can_message_receive().

◆ extended_id

uint32_t can_rx_message_type::extended_id

specifies the 29 bits extended identifier. this parameter can be a value between 0 to 0x1FFFFFFF.

Definition at line 423 of file at32f413_can.h.

Referenced by can_message_receive(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ filter_index

uint8_t can_rx_message_type::filter_index

specifies the message stored in which filter this parameter can be a value between 0 to 0xFF

Definition at line 435 of file at32f413_can.h.

Referenced by can_message_receive().

◆ frame_type

can_trans_frame_type can_rx_message_type::frame_type

specifies frame type for the receive message.

Definition at line 428 of file at32f413_can.h.

Referenced by can_message_receive().

◆ id_type

can_identifier_type can_rx_message_type::id_type

specifies identifier type for the receive message.

Definition at line 426 of file at32f413_can.h.

Referenced by can_message_receive(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ standard_id

uint32_t can_rx_message_type::standard_id

specifies the 11 bits standard identifier this parameter can be a value between 0 to 0x7FF.

Definition at line 420 of file at32f413_can.h.

Referenced by can_message_receive(), and USBFS_L_CAN1_RX0_IRQHandler().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_tx_mailbox_type Struct Reference

Data Fields
can_tx_mailbox_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can controller area network tx mailbox More...

#include <at32f413_can.h>

Data Fields

union {
__IO uint32_t tmi
struct {
__IO uint32_t tmsr: 1
__IO uint32_t tmfrsel: 1
__IO uint32_t tmidsel: 1
__IO uint32_t tmeid: 18
__IO uint32_t tmsid: 11
} tmi_bit
};
can tmi register More...
union {
__IO uint32_t tmc
struct {
__IO uint32_t tmdtbl: 4
__IO uint32_t reserved1: 4
__IO uint32_t tmtsten: 1
__IO uint32_t reserved2: 7
__IO uint32_t tmts: 16
} tmc_bit
};
can tmc register More...
union {
__IO uint32_t tmdtl
struct {
__IO uint32_t tmdt0: 8
__IO uint32_t tmdt1: 8
__IO uint32_t tmdt2: 8
__IO uint32_t tmdt3: 8
} tmdtl_bit
};
can tmdtl register More...
union {
__IO uint32_t tmdth
struct {
__IO uint32_t tmdt4: 8
__IO uint32_t tmdt5: 8
__IO uint32_t tmdt6: 8
__IO uint32_t tmdt7: 8
} tmdth_bit
};
can tmdth register More...

Detailed Description

can controller area network tx mailbox

Definition at line 442 of file at32f413_can.h.

Field Documentation

◆

union { ... } can_tx_mailbox_type::@214

can tmi register

◆

union { ... } can_tx_mailbox_type::@216

can tmc register

◆

union { ... } can_tx_mailbox_type::@218

can tmdtl register

◆

union { ... } can_tx_mailbox_type::@220

can tmdth register

◆ reserved1

__IO uint32_t can_tx_mailbox_type::reserved1

Definition at line 469 of file at32f413_can.h.

◆ reserved2

__IO uint32_t can_tx_mailbox_type::reserved2

Definition at line 471 of file at32f413_can.h.

◆ tmc

__IO uint32_t can_tx_mailbox_type::tmc

Definition at line 465 of file at32f413_can.h.

◆

struct { ... } can_tx_mailbox_type::tmc_bit

Referenced by can_message_transmit(), and can_ttc_mode_enable().

◆ tmdt0

__IO uint32_t can_tx_mailbox_type::tmdt0

Definition at line 484 of file at32f413_can.h.

◆ tmdt1

__IO uint32_t can_tx_mailbox_type::tmdt1

Definition at line 485 of file at32f413_can.h.

◆ tmdt2

__IO uint32_t can_tx_mailbox_type::tmdt2

Definition at line 486 of file at32f413_can.h.

◆ tmdt3

__IO uint32_t can_tx_mailbox_type::tmdt3

Definition at line 487 of file at32f413_can.h.

◆ tmdt4

__IO uint32_t can_tx_mailbox_type::tmdt4

Definition at line 499 of file at32f413_can.h.

◆ tmdt5

__IO uint32_t can_tx_mailbox_type::tmdt5

Definition at line 500 of file at32f413_can.h.

◆ tmdt6

__IO uint32_t can_tx_mailbox_type::tmdt6

Definition at line 501 of file at32f413_can.h.

◆ tmdt7

__IO uint32_t can_tx_mailbox_type::tmdt7

Definition at line 502 of file at32f413_can.h.

◆ tmdtbl

__IO uint32_t can_tx_mailbox_type::tmdtbl

Definition at line 468 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmdth

__IO uint32_t can_tx_mailbox_type::tmdth

Definition at line 496 of file at32f413_can.h.

Referenced by can_message_transmit().

◆

struct { ... } can_tx_mailbox_type::tmdth_bit

◆ tmdtl

__IO uint32_t can_tx_mailbox_type::tmdtl

Definition at line 481 of file at32f413_can.h.

Referenced by can_message_transmit().

◆

struct { ... } can_tx_mailbox_type::tmdtl_bit

◆ tmeid

__IO uint32_t can_tx_mailbox_type::tmeid

Definition at line 455 of file at32f413_can.h.

◆ tmfrsel

__IO uint32_t can_tx_mailbox_type::tmfrsel

Definition at line 453 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmi

__IO uint32_t can_tx_mailbox_type::tmi

Definition at line 449 of file at32f413_can.h.

Referenced by can_message_transmit().

◆

struct { ... } can_tx_mailbox_type::tmi_bit

Referenced by can_message_transmit().

◆ tmidsel

__IO uint32_t can_tx_mailbox_type::tmidsel

Definition at line 454 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmsid

__IO uint32_t can_tx_mailbox_type::tmsid

Definition at line 456 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmsr

__IO uint32_t can_tx_mailbox_type::tmsr

Definition at line 452 of file at32f413_can.h.

Referenced by can_message_transmit().

◆ tmts

__IO uint32_t can_tx_mailbox_type::tmts

Definition at line 472 of file at32f413_can.h.

◆ tmtsten

__IO uint32_t can_tx_mailbox_type::tmtsten

Definition at line 470 of file at32f413_can.h.

Referenced by can_ttc_mode_enable().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_fifo_mailbox_type Struct Reference

Data Fields
can_fifo_mailbox_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can controller area network fifo mailbox More...

#include <at32f413_can.h>

Data Fields

union {
__IO uint32_t rfi
struct {
__IO uint32_t reserved1: 1
__IO uint32_t rffri: 1
__IO uint32_t rfidi: 1
__IO uint32_t rfeid: 18
__IO uint32_t rfsid: 11
} rfi_bit
};
can rfi register More...
union {
__IO uint32_t rfc
struct {
__IO uint32_t rfdtl: 4
__IO uint32_t reserved1: 4
__IO uint32_t rffmn: 8
__IO uint32_t rfts: 16
} rfc_bit
};
can rfc register More...
union {
__IO uint32_t rfdtl
struct {
__IO uint32_t rfdt0: 8
__IO uint32_t rfdt1: 8
__IO uint32_t rfdt2: 8
__IO uint32_t rfdt3: 8
} rfdtl_bit
};
can rfdtl register More...
union {
__IO uint32_t rfdth
struct {
__IO uint32_t rfdt4: 8
__IO uint32_t rfdt5: 8
__IO uint32_t rfdt6: 8
__IO uint32_t rfdt7: 8
} rfdth_bit
};
can rfdth register More...

Detailed Description

can controller area network fifo mailbox

Definition at line 510 of file at32f413_can.h.

Field Documentation

◆

union { ... } can_fifo_mailbox_type::@226

can rfi register

◆

union { ... } can_fifo_mailbox_type::@228

can rfc register

◆

union { ... } can_fifo_mailbox_type::@230

can rfdtl register

◆

union { ... } can_fifo_mailbox_type::@232

can rfdth register

◆ reserved1

__IO uint32_t can_fifo_mailbox_type::reserved1

Definition at line 520 of file at32f413_can.h.

◆ rfc

__IO uint32_t can_fifo_mailbox_type::rfc

Definition at line 533 of file at32f413_can.h.

◆

struct { ... } can_fifo_mailbox_type::rfc_bit

Referenced by can_message_receive().

◆ rfdt0

__IO uint32_t can_fifo_mailbox_type::rfdt0

Definition at line 551 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt1

__IO uint32_t can_fifo_mailbox_type::rfdt1

Definition at line 552 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt2

__IO uint32_t can_fifo_mailbox_type::rfdt2

Definition at line 553 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt3

__IO uint32_t can_fifo_mailbox_type::rfdt3

Definition at line 554 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt4

__IO uint32_t can_fifo_mailbox_type::rfdt4

Definition at line 566 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt5

__IO uint32_t can_fifo_mailbox_type::rfdt5

Definition at line 567 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt6

__IO uint32_t can_fifo_mailbox_type::rfdt6

Definition at line 568 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdt7

__IO uint32_t can_fifo_mailbox_type::rfdt7

Definition at line 569 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfdth

__IO uint32_t can_fifo_mailbox_type::rfdth

Definition at line 563 of file at32f413_can.h.

◆

struct { ... } can_fifo_mailbox_type::rfdth_bit

Referenced by can_message_receive().

◆ rfdtl

__IO uint32_t can_fifo_mailbox_type::rfdtl

Definition at line 536 of file at32f413_can.h.

Referenced by can_message_receive().

◆

struct { ... } can_fifo_mailbox_type::rfdtl_bit

Referenced by can_message_receive().

◆ rfeid

__IO uint32_t can_fifo_mailbox_type::rfeid

Definition at line 523 of file at32f413_can.h.

◆ rffmn

__IO uint32_t can_fifo_mailbox_type::rffmn

Definition at line 538 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rffri

__IO uint32_t can_fifo_mailbox_type::rffri

Definition at line 521 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfi

__IO uint32_t can_fifo_mailbox_type::rfi

Definition at line 517 of file at32f413_can.h.

Referenced by can_message_receive().

◆

struct { ... } can_fifo_mailbox_type::rfi_bit

Referenced by can_message_receive().

◆ rfidi

__IO uint32_t can_fifo_mailbox_type::rfidi

Definition at line 522 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfsid

__IO uint32_t can_fifo_mailbox_type::rfsid

Definition at line 524 of file at32f413_can.h.

Referenced by can_message_receive().

◆ rfts

__IO uint32_t can_fifo_mailbox_type::rfts

Definition at line 539 of file at32f413_can.h.

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_filter_register_type Struct Reference

Data Fields
can_filter_register_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

can controller area network filter bit register More...

#include <at32f413_can.h>

Data Fields

__IO uint32_t | ffdb1
__IO uint32_t | ffdb2

Detailed Description

can controller area network filter bit register

Definition at line 577 of file at32f413_can.h.

Field Documentation

◆ ffdb1

__IO uint32_t can_filter_register_type::ffdb1

Definition at line 579 of file at32f413_can.h.

Referenced by can_filter_init().

◆ ffdb2

__IO uint32_t can_filter_register_type::ffdb2

Definition at line 580 of file at32f413_can.h.

Referenced by can_filter_init().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: can_type Struct Reference

Data Fields
can_type Struct Reference
AT32F413_periph_driver » CAN » CAN_exported_types

type define can register all More...

#include <at32f413_can.h>

Data Fields

union {
__IO uint32_t mctrl
struct {
__IO uint32_t fzen: 1
__IO uint32_t dzen: 1
__IO uint32_t mmssr: 1
__IO uint32_t mdrsel: 1
__IO uint32_t prsfen: 1
__IO uint32_t aeden: 1
__IO uint32_t aeboen: 1
__IO uint32_t ttcen: 1
__IO uint32_t reserved1: 7
__IO uint32_t sprst: 1
__IO uint32_t ptd: 1
__IO uint32_t reserved2: 15
} mctrl_bit
};
can mctrl register, offset:0x00 More...
union {
__IO uint32_t msts
struct {
__IO uint32_t fzc: 1
__IO uint32_t dzc: 1
__IO uint32_t eoif: 1
__IO uint32_t qdzif: 1
__IO uint32_t edzif: 1
__IO uint32_t reserved1: 3
__IO uint32_t cuss: 1
__IO uint32_t curs: 1
__IO uint32_t lsamprx: 1
__IO uint32_t realrx: 1
__IO uint32_t reserved2: 20
} msts_bit
};
can msts register, offset:0x04 More...
union {
__IO uint32_t tsts
struct {
__IO uint32_t tm0tcf: 1
__IO uint32_t tm0tsf: 1
__IO uint32_t tm0alf: 1
__IO uint32_t tm0tef: 1
__IO uint32_t reserved1: 3
__IO uint32_t tm0ct: 1
__IO uint32_t tm1tcf: 1
__IO uint32_t tm1tsf: 1
__IO uint32_t tm1alf: 1
__IO uint32_t tm1tef: 1
__IO uint32_t reserved2: 3
__IO uint32_t tm1ct: 1
__IO uint32_t tm2tcf: 1
__IO uint32_t tm2tsf: 1
__IO uint32_t tm2alf: 1
__IO uint32_t tm2tef: 1
__IO uint32_t reserved3: 3
__IO uint32_t tm2ct: 1
__IO uint32_t tmnr: 2
__IO uint32_t tm0ef: 1
__IO uint32_t tm1ef: 1
__IO uint32_t tm2ef: 1
__IO uint32_t tm0lpf: 1
__IO uint32_t tm1lpf: 1
__IO uint32_t tm2lpf: 1
} tsts_bit
};
can tsts register, offset:0x08 More...
union {
__IO uint32_t rf0
struct {
__IO uint32_t rf0mn: 2
__IO uint32_t reserved1: 1
__IO uint32_t rf0ff: 1
__IO uint32_t rf0of: 1
__IO uint32_t rf0r: 1
__IO uint32_t reserved2: 26
} rf0_bit
};
can rf0 register, offset:0x0C More...
union {
__IO uint32_t rf1
struct {
__IO uint32_t rf1mn: 2
__IO uint32_t reserved1: 1
__IO uint32_t rf1ff: 1
__IO uint32_t rf1of: 1
__IO uint32_t rf1r: 1
__IO uint32_t reserved2: 26
} rf1_bit
};
can rf1 register, offset:0x10 More...
union {
__IO uint32_t inten
struct {
__IO uint32_t tcien: 1
__IO uint32_t rf0mien: 1
__IO uint32_t rf0fien: 1
__IO uint32_t rf0oien: 1
__IO uint32_t rf1mien: 1
__IO uint32_t rf1fien: 1
__IO uint32_t rf1oien: 1
__IO uint32_t reserved1: 1
__IO uint32_t eaien: 1
__IO uint32_t epien: 1
__IO uint32_t boien: 1
__IO uint32_t etrien: 1
__IO uint32_t reserved2: 3
__IO uint32_t eoien: 1
__IO uint32_t qdzien: 1
__IO uint32_t edzien: 1
__IO uint32_t reserved3: 14
} inten_bit
};
can inten register, offset:0x14 More...
union {
__IO uint32_t ests
struct {
__IO uint32_t eaf: 1
__IO uint32_t epf: 1
__IO uint32_t bof: 1
__IO uint32_t reserved1: 1
__IO uint32_t etr: 3
__IO uint32_t reserved2: 9
__IO uint32_t tec: 8
__IO uint32_t rec: 8
} ests_bit
};
can ests register, offset:0x18 More...
union {
__IO uint32_t btmg
struct {
__IO uint32_t brdiv: 12
__IO uint32_t reserved1: 4
__IO uint32_t bts1: 4
__IO uint32_t bts2: 3
__IO uint32_t reserved2: 1
__IO uint32_t rsaw: 2
__IO uint32_t reserved3: 4
__IO uint32_t lben: 1
__IO uint32_t loen: 1
} btmg_bit
};
can btmg register, offset:0x1C More...
can_tx_mailbox_type | tx_mailbox [3]
can controller area network tx mailbox register, offset:0x180~0x1AC More...
can_fifo_mailbox_type | fifo_mailbox [2]
can controller area network fifo mailbox register, offset:0x1B0~0x1CC More...
union {
__IO uint32_t fctrl
struct {
__IO uint32_t fcs: 1
__IO uint32_t reserved1: 31
} fctrl_bit
};
can fctrl register, offset:0x200 More...
union {
__IO uint32_t fmcfg
struct {
__IO uint32_t fmsel0: 1
__IO uint32_t fmsel1: 1
__IO uint32_t fmsel2: 1
__IO uint32_t fmsel3: 1
__IO uint32_t fmsel4: 1
__IO uint32_t fmsel5: 1
__IO uint32_t fmsel6: 1
__IO uint32_t fmsel7: 1
__IO uint32_t fmsel8: 1
__IO uint32_t fmsel9: 1
__IO uint32_t fmsel10: 1
__IO uint32_t fmsel11: 1
__IO uint32_t fmsel12: 1
__IO uint32_t fmsel13: 1
__IO uint32_t reserved1: 18
} fmcfg_bit
};
can fmcfg register, offset:0x204 More...
union {
__IO uint32_t fbwcfg
struct {
__IO uint32_t fbwsel0: 1
__IO uint32_t fbwsel1: 1
__IO uint32_t fbwsel2: 1
__IO uint32_t fbwsel3: 1
__IO uint32_t fbwsel4: 1
__IO uint32_t fbwsel5: 1
__IO uint32_t fbwsel6: 1
__IO uint32_t fbwsel7: 1
__IO uint32_t fbwsel8: 1
__IO uint32_t fbwsel9: 1
__IO uint32_t fbwsel10: 1
__IO uint32_t fbwsel11: 1
__IO uint32_t fbwsel12: 1
__IO uint32_t fbwsel13: 1
__IO uint32_t reserved1: 18
} fbwcfg_bit
};
can fbwcfg register, offset:0x20C More...
__IO uint32_t | reserved4
can reserved register, offset:0x210 More...
union {
__IO uint32_t frf
struct {
__IO uint32_t frfsel0: 1
__IO uint32_t frfsel1: 1
__IO uint32_t frfsel2: 1
__IO uint32_t frfsel3: 1
__IO uint32_t frfsel4: 1
__IO uint32_t frfsel5: 1
__IO uint32_t frfsel6: 1
__IO uint32_t frfsel7: 1
__IO uint32_t frfsel8: 1
__IO uint32_t frfsel9: 1
__IO uint32_t frfsel10: 1
__IO uint32_t frfsel11: 1
__IO uint32_t frfsel12: 1
__IO uint32_t frfsel13: 1
__IO uint32_t reserved1: 18
} frf_bit
};
can frf register, offset:0x214 More...
__IO uint32_t | reserved5
can reserved register, offset:0x218 More...
union {
__IO uint32_t facfg
struct {
__IO uint32_t faen0: 1
__IO uint32_t faen1: 1
__IO uint32_t faen2: 1
__IO uint32_t faen3: 1
__IO uint32_t faen4: 1
__IO uint32_t faen5: 1
__IO uint32_t faen6: 1
__IO uint32_t faen7: 1
__IO uint32_t faen8: 1
__IO uint32_t faen9: 1
__IO uint32_t faen10: 1
__IO uint32_t faen11: 1
__IO uint32_t faen12: 1
__IO uint32_t faen13: 1
__IO uint32_t reserved1: 18
} facfg_bit
};
can facfg register, offset:0x21C More...
__IO uint32_t | reserved6 [8]
can reserved register, offset:0x220~0x23C More...
can_filter_register_type | ffb [14]
can ffb register, offset:0x240~0x2AC More...

Detailed Description

type define can register all

Definition at line 586 of file at32f413_can.h.

Field Documentation

◆

union { ... } can_type::@238

can mctrl register, offset:0x00

◆

union { ... } can_type::@240

can msts register, offset:0x04

◆

union { ... } can_type::@242

can tsts register, offset:0x08

◆

union { ... } can_type::@244

can rf0 register, offset:0x0C

◆

union { ... } can_type::@246

can rf1 register, offset:0x10

◆

union { ... } can_type::@248

can inten register, offset:0x14

◆

union { ... } can_type::@250

can ests register, offset:0x18

◆

union { ... } can_type::@252

can btmg register, offset:0x1C

◆

union { ... } can_type::@254

can fctrl register, offset:0x200

◆

union { ... } can_type::@256

can fmcfg register, offset:0x204

◆

union { ... } can_type::@258

can fbwcfg register, offset:0x20C

◆

union { ... } can_type::@260

can frf register, offset:0x214

◆

union { ... } can_type::@262

can facfg register, offset:0x21C

◆ aeboen

__IO uint32_t can_type::aeboen

Definition at line 603 of file at32f413_can.h.

Referenced by can_base_init().

◆ aeden

__IO uint32_t can_type::aeden

Definition at line 602 of file at32f413_can.h.

Referenced by can_base_init().

◆ bof

__IO uint32_t can_type::bof

Definition at line 742 of file at32f413_can.h.

Referenced by can_flag_get().

◆ boien

__IO uint32_t can_type::boien

Definition at line 722 of file at32f413_can.h.

◆ brdiv

__IO uint32_t can_type::brdiv

Definition at line 759 of file at32f413_can.h.

Referenced by can_baudrate_set().

◆ btmg

__IO uint32_t can_type::btmg

Definition at line 756 of file at32f413_can.h.

◆

struct { ... } can_type::btmg_bit

Referenced by can_base_init(), and can_baudrate_set().

◆ bts1

__IO uint32_t can_type::bts1

Definition at line 761 of file at32f413_can.h.

Referenced by can_baudrate_set().

◆ bts2

__IO uint32_t can_type::bts2

Definition at line 762 of file at32f413_can.h.

Referenced by can_baudrate_set().

◆ curs

__IO uint32_t can_type::curs

Definition at line 627 of file at32f413_can.h.

◆ cuss

__IO uint32_t can_type::cuss

Definition at line 626 of file at32f413_can.h.

◆ dzc

__IO uint32_t can_type::dzc

Definition at line 621 of file at32f413_can.h.

Referenced by can_doze_mode_enter(), can_doze_mode_exit(), can_flag_get(), and can_operating_mode_set().

◆ dzen

__IO uint32_t can_type::dzen

Definition at line 598 of file at32f413_can.h.

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), can_doze_mode_exit(), and can_operating_mode_set().

◆ eaf

__IO uint32_t can_type::eaf

Definition at line 740 of file at32f413_can.h.

Referenced by can_flag_get().

◆ eaien

__IO uint32_t can_type::eaien

Definition at line 720 of file at32f413_can.h.

◆ edzien

__IO uint32_t can_type::edzien

Definition at line 727 of file at32f413_can.h.

◆ edzif

__IO uint32_t can_type::edzif

Definition at line 624 of file at32f413_can.h.

Referenced by can_flag_get().

◆ eoien

__IO uint32_t can_type::eoien

Definition at line 725 of file at32f413_can.h.

◆ eoif

__IO uint32_t can_type::eoif

Definition at line 622 of file at32f413_can.h.

Referenced by can_flag_get().

◆ epf

__IO uint32_t can_type::epf

Definition at line 741 of file at32f413_can.h.

Referenced by can_flag_get().

◆ epien

__IO uint32_t can_type::epien

Definition at line 721 of file at32f413_can.h.

◆ ests

__IO uint32_t can_type::ests

Definition at line 737 of file at32f413_can.h.

Referenced by can_flag_clear().

◆

struct { ... } can_type::ests_bit

Referenced by can_error_type_record_get(), can_flag_get(), can_receive_error_counter_get(), and can_transmit_error_counter_get().

◆ etr

__IO uint32_t can_type::etr

Definition at line 744 of file at32f413_can.h.

Referenced by can_error_type_record_get(), and can_flag_get().

◆ etrien

__IO uint32_t can_type::etrien

Definition at line 723 of file at32f413_can.h.

◆ facfg

__IO uint32_t can_type::facfg

Definition at line 902 of file at32f413_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::facfg_bit

◆ faen0

__IO uint32_t can_type::faen0

Definition at line 905 of file at32f413_can.h.

◆ faen1

__IO uint32_t can_type::faen1

Definition at line 906 of file at32f413_can.h.

◆ faen10

__IO uint32_t can_type::faen10

Definition at line 915 of file at32f413_can.h.

◆ faen11

__IO uint32_t can_type::faen11

Definition at line 916 of file at32f413_can.h.

◆ faen12

__IO uint32_t can_type::faen12

Definition at line 917 of file at32f413_can.h.

◆ faen13

__IO uint32_t can_type::faen13

Definition at line 918 of file at32f413_can.h.

◆ faen2

__IO uint32_t can_type::faen2

Definition at line 907 of file at32f413_can.h.

◆ faen3

__IO uint32_t can_type::faen3

Definition at line 908 of file at32f413_can.h.

◆ faen4

__IO uint32_t can_type::faen4

Definition at line 909 of file at32f413_can.h.

◆ faen5

__IO uint32_t can_type::faen5

Definition at line 910 of file at32f413_can.h.

◆ faen6

__IO uint32_t can_type::faen6

Definition at line 911 of file at32f413_can.h.

◆ faen7

__IO uint32_t can_type::faen7

Definition at line 912 of file at32f413_can.h.

◆ faen8

__IO uint32_t can_type::faen8

Definition at line 913 of file at32f413_can.h.

◆ faen9

__IO uint32_t can_type::faen9

Definition at line 914 of file at32f413_can.h.

◆ fbwcfg

__IO uint32_t can_type::fbwcfg

Definition at line 840 of file at32f413_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::fbwcfg_bit

◆ fbwsel0

__IO uint32_t can_type::fbwsel0

Definition at line 843 of file at32f413_can.h.

◆ fbwsel1

__IO uint32_t can_type::fbwsel1

Definition at line 844 of file at32f413_can.h.

◆ fbwsel10

__IO uint32_t can_type::fbwsel10

Definition at line 853 of file at32f413_can.h.

◆ fbwsel11

__IO uint32_t can_type::fbwsel11

Definition at line 854 of file at32f413_can.h.

◆ fbwsel12

__IO uint32_t can_type::fbwsel12

Definition at line 855 of file at32f413_can.h.

◆ fbwsel13

__IO uint32_t can_type::fbwsel13

Definition at line 856 of file at32f413_can.h.

◆ fbwsel2

__IO uint32_t can_type::fbwsel2

Definition at line 845 of file at32f413_can.h.

◆ fbwsel3

__IO uint32_t can_type::fbwsel3

Definition at line 846 of file at32f413_can.h.

◆ fbwsel4

__IO uint32_t can_type::fbwsel4

Definition at line 847 of file at32f413_can.h.

◆ fbwsel5

__IO uint32_t can_type::fbwsel5

Definition at line 848 of file at32f413_can.h.

◆ fbwsel6

__IO uint32_t can_type::fbwsel6

Definition at line 849 of file at32f413_can.h.

◆ fbwsel7

__IO uint32_t can_type::fbwsel7

Definition at line 850 of file at32f413_can.h.

◆ fbwsel8

__IO uint32_t can_type::fbwsel8

Definition at line 851 of file at32f413_can.h.

◆ fbwsel9

__IO uint32_t can_type::fbwsel9

Definition at line 852 of file at32f413_can.h.

◆ fcs

__IO uint32_t can_type::fcs

Definition at line 799 of file at32f413_can.h.

Referenced by can_filter_init().

◆ fctrl

__IO uint32_t can_type::fctrl

Definition at line 796 of file at32f413_can.h.

◆

struct { ... } can_type::fctrl_bit

Referenced by can_filter_init().

◆ ffb

can_filter_register_type can_type::ffb[14]

can ffb register, offset:0x240~0x2AC

Definition at line 931 of file at32f413_can.h.

Referenced by can_filter_init().

◆ fifo_mailbox

can_fifo_mailbox_type can_type::fifo_mailbox[2]

can controller area network fifo mailbox register, offset:0x1B0~0x1CC

Definition at line 784 of file at32f413_can.h.

Referenced by can_message_receive().

◆ fmcfg

__IO uint32_t can_type::fmcfg

Definition at line 809 of file at32f413_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::fmcfg_bit

◆ fmsel0

__IO uint32_t can_type::fmsel0

Definition at line 812 of file at32f413_can.h.

◆ fmsel1

__IO uint32_t can_type::fmsel1

Definition at line 813 of file at32f413_can.h.

◆ fmsel10

__IO uint32_t can_type::fmsel10

Definition at line 822 of file at32f413_can.h.

◆ fmsel11

__IO uint32_t can_type::fmsel11

Definition at line 823 of file at32f413_can.h.

◆ fmsel12

__IO uint32_t can_type::fmsel12

Definition at line 824 of file at32f413_can.h.

◆ fmsel13

__IO uint32_t can_type::fmsel13

Definition at line 825 of file at32f413_can.h.

◆ fmsel2

__IO uint32_t can_type::fmsel2

Definition at line 814 of file at32f413_can.h.

◆ fmsel3

__IO uint32_t can_type::fmsel3

Definition at line 815 of file at32f413_can.h.

◆ fmsel4

__IO uint32_t can_type::fmsel4

Definition at line 816 of file at32f413_can.h.

◆ fmsel5

__IO uint32_t can_type::fmsel5

Definition at line 817 of file at32f413_can.h.

◆ fmsel6

__IO uint32_t can_type::fmsel6

Definition at line 818 of file at32f413_can.h.

◆ fmsel7

__IO uint32_t can_type::fmsel7

Definition at line 819 of file at32f413_can.h.

◆ fmsel8

__IO uint32_t can_type::fmsel8

Definition at line 820 of file at32f413_can.h.

◆ fmsel9

__IO uint32_t can_type::fmsel9

Definition at line 821 of file at32f413_can.h.

◆ frf

__IO uint32_t can_type::frf

Definition at line 871 of file at32f413_can.h.

Referenced by can_filter_init().

◆

struct { ... } can_type::frf_bit

◆ frfsel0

__IO uint32_t can_type::frfsel0

Definition at line 874 of file at32f413_can.h.

◆ frfsel1

__IO uint32_t can_type::frfsel1

Definition at line 875 of file at32f413_can.h.

◆ frfsel10

__IO uint32_t can_type::frfsel10

Definition at line 884 of file at32f413_can.h.

◆ frfsel11

__IO uint32_t can_type::frfsel11

Definition at line 885 of file at32f413_can.h.

◆ frfsel12

__IO uint32_t can_type::frfsel12

Definition at line 886 of file at32f413_can.h.

◆ frfsel13

__IO uint32_t can_type::frfsel13

Definition at line 887 of file at32f413_can.h.

◆ frfsel2

__IO uint32_t can_type::frfsel2

Definition at line 876 of file at32f413_can.h.

◆ frfsel3

__IO uint32_t can_type::frfsel3

Definition at line 877 of file at32f413_can.h.

◆ frfsel4

__IO uint32_t can_type::frfsel4

Definition at line 878 of file at32f413_can.h.

◆ frfsel5

__IO uint32_t can_type::frfsel5

Definition at line 879 of file at32f413_can.h.

◆ frfsel6

__IO uint32_t can_type::frfsel6

Definition at line 880 of file at32f413_can.h.

◆ frfsel7

__IO uint32_t can_type::frfsel7

Definition at line 881 of file at32f413_can.h.

◆ frfsel8

__IO uint32_t can_type::frfsel8

Definition at line 882 of file at32f413_can.h.

◆ frfsel9

__IO uint32_t can_type::frfsel9

Definition at line 883 of file at32f413_can.h.

◆ fzc

__IO uint32_t can_type::fzc

Definition at line 620 of file at32f413_can.h.

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), and can_operating_mode_set().

◆ fzen

__IO uint32_t can_type::fzen

Definition at line 597 of file at32f413_can.h.

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), and can_operating_mode_set().

◆ inten

__IO uint32_t can_type::inten

Definition at line 709 of file at32f413_can.h.

Referenced by can_interrupt_enable().

◆

struct { ... } can_type::inten_bit

◆ lben

__IO uint32_t can_type::lben

Definition at line 766 of file at32f413_can.h.

Referenced by can_base_init().

◆ loen

__IO uint32_t can_type::loen

Definition at line 767 of file at32f413_can.h.

Referenced by can_base_init().

◆ lsamprx

__IO uint32_t can_type::lsamprx

Definition at line 628 of file at32f413_can.h.

◆ mctrl

__IO uint32_t can_type::mctrl

Definition at line 594 of file at32f413_can.h.

◆

struct { ... } can_type::mctrl_bit

Referenced by can_base_init(), can_baudrate_set(), can_debug_transmission_prohibit(), can_doze_mode_enter(), can_doze_mode_exit(), can_operating_mode_set(), and can_ttc_mode_enable().

◆ mdrsel

__IO uint32_t can_type::mdrsel

Definition at line 600 of file at32f413_can.h.

Referenced by can_base_init().

◆ mmssr

__IO uint32_t can_type::mmssr

Definition at line 599 of file at32f413_can.h.

Referenced by can_base_init().

◆ msts

__IO uint32_t can_type::msts

Definition at line 617 of file at32f413_can.h.

Referenced by can_flag_clear().

◆

struct { ... } can_type::msts_bit

Referenced by can_base_init(), can_baudrate_set(), can_doze_mode_enter(), can_doze_mode_exit(), can_flag_get(), and can_operating_mode_set().

◆ prsfen

__IO uint32_t can_type::prsfen

Definition at line 601 of file at32f413_can.h.

Referenced by can_base_init().

◆ ptd

__IO uint32_t can_type::ptd

Definition at line 607 of file at32f413_can.h.

Referenced by can_debug_transmission_prohibit().

◆ qdzien

__IO uint32_t can_type::qdzien

Definition at line 726 of file at32f413_can.h.

◆ qdzif

__IO uint32_t can_type::qdzif

Definition at line 623 of file at32f413_can.h.

Referenced by can_flag_get().

◆ realrx

__IO uint32_t can_type::realrx

Definition at line 629 of file at32f413_can.h.

◆ rec

__IO uint32_t can_type::rec

Definition at line 747 of file at32f413_can.h.

Referenced by can_receive_error_counter_get().

◆ reserved1

__IO uint32_t can_type::reserved1

can reserved register, offset:0x20~0x17C

Definition at line 605 of file at32f413_can.h.

◆ reserved2

__IO uint32_t can_type::reserved2

can reserved register, offset:0x1D0~0x1FC

Definition at line 608 of file at32f413_can.h.

◆ reserved3

__IO uint32_t can_type::reserved3

can reserved register, offset:0x208

Definition at line 658 of file at32f413_can.h.

◆ reserved4

__IO uint32_t can_type::reserved4

can reserved register, offset:0x210

Definition at line 864 of file at32f413_can.h.

◆ reserved5

__IO uint32_t can_type::reserved5

can reserved register, offset:0x218

Definition at line 895 of file at32f413_can.h.

◆ reserved6

__IO uint32_t can_type::reserved6[8]

can reserved register, offset:0x220~0x23C

Definition at line 926 of file at32f413_can.h.

◆ rf0

__IO uint32_t can_type::rf0

Definition at line 675 of file at32f413_can.h.

Referenced by can_flag_clear(), and can_receive_fifo_release().

◆

struct { ... } can_type::rf0_bit

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf0ff

__IO uint32_t can_type::rf0ff

Definition at line 680 of file at32f413_can.h.

Referenced by can_flag_get().

◆ rf0fien

__IO uint32_t can_type::rf0fien

Definition at line 714 of file at32f413_can.h.

◆ rf0mien

__IO uint32_t can_type::rf0mien

Definition at line 713 of file at32f413_can.h.

◆ rf0mn

__IO uint32_t can_type::rf0mn

Definition at line 678 of file at32f413_can.h.

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf0of

__IO uint32_t can_type::rf0of

Definition at line 681 of file at32f413_can.h.

Referenced by can_flag_get().

◆ rf0oien

__IO uint32_t can_type::rf0oien

Definition at line 715 of file at32f413_can.h.

◆ rf0r

__IO uint32_t can_type::rf0r

Definition at line 682 of file at32f413_can.h.

◆ rf1

__IO uint32_t can_type::rf1

Definition at line 692 of file at32f413_can.h.

Referenced by can_flag_clear(), and can_receive_fifo_release().

◆

struct { ... } can_type::rf1_bit

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf1ff

__IO uint32_t can_type::rf1ff

Definition at line 697 of file at32f413_can.h.

Referenced by can_flag_get().

◆ rf1fien

__IO uint32_t can_type::rf1fien

Definition at line 717 of file at32f413_can.h.

◆ rf1mien

__IO uint32_t can_type::rf1mien

Definition at line 716 of file at32f413_can.h.

◆ rf1mn

__IO uint32_t can_type::rf1mn

Definition at line 695 of file at32f413_can.h.

Referenced by can_flag_get(), and can_receive_message_pending_get().

◆ rf1of

__IO uint32_t can_type::rf1of

Definition at line 698 of file at32f413_can.h.

Referenced by can_flag_get().

◆ rf1oien

__IO uint32_t can_type::rf1oien

Definition at line 718 of file at32f413_can.h.

◆ rf1r

__IO uint32_t can_type::rf1r

Definition at line 699 of file at32f413_can.h.

◆ rsaw

__IO uint32_t can_type::rsaw

Definition at line 764 of file at32f413_can.h.

Referenced by can_baudrate_set().

◆ sprst

__IO uint32_t can_type::sprst

Definition at line 606 of file at32f413_can.h.

◆ tcien

__IO uint32_t can_type::tcien

Definition at line 712 of file at32f413_can.h.

◆ tec

__IO uint32_t can_type::tec

Definition at line 746 of file at32f413_can.h.

Referenced by can_transmit_error_counter_get().

◆ tm0alf

__IO uint32_t can_type::tm0alf

Definition at line 644 of file at32f413_can.h.

◆ tm0ct

__IO uint32_t can_type::tm0ct

Definition at line 647 of file at32f413_can.h.

◆ tm0ef

__IO uint32_t can_type::tm0ef

Definition at line 661 of file at32f413_can.h.

Referenced by can_flag_get(), and can_message_transmit().

◆ tm0lpf

__IO uint32_t can_type::tm0lpf

Definition at line 664 of file at32f413_can.h.

◆ tm0tcf

__IO uint32_t can_type::tm0tcf

Definition at line 642 of file at32f413_can.h.

Referenced by can_flag_get(), and can_transmit_status_get().

◆ tm0tef

__IO uint32_t can_type::tm0tef

Definition at line 645 of file at32f413_can.h.

◆ tm0tsf

__IO uint32_t can_type::tm0tsf

Definition at line 643 of file at32f413_can.h.

Referenced by can_transmit_status_get().

◆ tm1alf

__IO uint32_t can_type::tm1alf

Definition at line 650 of file at32f413_can.h.

◆ tm1ct

__IO uint32_t can_type::tm1ct

Definition at line 653 of file at32f413_can.h.

◆ tm1ef

__IO uint32_t can_type::tm1ef

Definition at line 662 of file at32f413_can.h.

Referenced by can_flag_get(), and can_message_transmit().

◆ tm1lpf

__IO uint32_t can_type::tm1lpf

Definition at line 665 of file at32f413_can.h.

◆ tm1tcf

__IO uint32_t can_type::tm1tcf

Definition at line 648 of file at32f413_can.h.

Referenced by can_flag_get(), and can_transmit_status_get().

◆ tm1tef

__IO uint32_t can_type::tm1tef

Definition at line 651 of file at32f413_can.h.

◆ tm1tsf

__IO uint32_t can_type::tm1tsf

Definition at line 649 of file at32f413_can.h.

Referenced by can_transmit_status_get().

◆ tm2alf

__IO uint32_t can_type::tm2alf

Definition at line 656 of file at32f413_can.h.

◆ tm2ct

__IO uint32_t can_type::tm2ct

Definition at line 659 of file at32f413_can.h.

◆ tm2ef

__IO uint32_t can_type::tm2ef

Definition at line 663 of file at32f413_can.h.

Referenced by can_flag_get(), and can_message_transmit().

◆ tm2lpf

__IO uint32_t can_type::tm2lpf

Definition at line 666 of file at32f413_can.h.

◆ tm2tcf

__IO uint32_t can_type::tm2tcf

Definition at line 654 of file at32f413_can.h.

Referenced by can_flag_get(), and can_transmit_status_get().

◆ tm2tef

__IO uint32_t can_type::tm2tef

Definition at line 657 of file at32f413_can.h.

◆ tm2tsf

__IO uint32_t can_type::tm2tsf

Definition at line 655 of file at32f413_can.h.

Referenced by can_transmit_status_get().

◆ tmnr

__IO uint32_t can_type::tmnr

Definition at line 660 of file at32f413_can.h.

◆ tsts

__IO uint32_t can_type::tsts

Definition at line 639 of file at32f413_can.h.

Referenced by can_flag_clear(), and can_transmit_cancel().

◆

struct { ... } can_type::tsts_bit

Referenced by can_flag_get(), can_message_transmit(), and can_transmit_status_get().

◆ ttcen

__IO uint32_t can_type::ttcen

Definition at line 604 of file at32f413_can.h.

Referenced by can_base_init(), and can_ttc_mode_enable().

◆ tx_mailbox

can_tx_mailbox_type can_type::tx_mailbox[3]

can controller area network tx mailbox register, offset:0x180~0x1AC

Definition at line 779 of file at32f413_can.h.

Referenced by can_message_transmit(), and can_ttc_mode_enable().

The documentation for this struct was generated from the following file:
  • at32f413_can.h


AT32F413 Firmwary Library: CAN_exported_functions

Functions
CAN_exported_functions
AT32F413_periph_driver » CAN

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

Function Documentation

◆ can_base_init()

error_status can_base_init | ( | can_type * | can_x,
 |  | can_base_type * | can_base_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_base_struct | pointer to a can_base_struct structure that contains the configuration information for the can peripheral.
Return values
the status of initialization this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 194 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_baudrate_default_para_init()

void can_baudrate_default_para_init ( can_baudrate_type * can_baudrate_struct )

fill each can_baudrate_struct member with its default value.

Parameters
can_baudrate_struct pointer to a can_baudrate_type structure which will be initialized.
Return values
none.

Definition at line 70 of file at32f413_can.c.

◆ can_baudrate_set()

error_status can_baudrate_set | ( | can_type * | can_x,
 |  | can_baudrate_type * | can_baudrate_struct
 | ) |  |

set the baudrate of the can peripheral

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_baudrate_struct | pointer to a can_baudrate_type structure which will be set.
Note
baudrate calculate method is: baudrate = fpclk/(baudrate_div *(3 + bts1_size + bts2_size))
Return values
the result of baudrate set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 99 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_debug_transmission_prohibit()

void can_debug_transmission_prohibit | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the debug transmission prohibit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
new_state | new state of debug transmission prohibit. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 395 of file at32f413_can.c.

◆ can_default_para_init()

void can_default_para_init ( can_base_type * can_base_struct )

fill each can_init_struct member with its default value.

Parameters
can_base_struct pointer to a can_base_type structure which will be initialized.
Return values
none.

Definition at line 157 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_doze_mode_enter()

can_enter_doze_status_type can_doze_mode_enter ( can_type * can_x )

enter the low power mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_ENTER_DOZE_SUCCESSFUL <it meaning enter the doze mode succeed>
  • CAN_ENTER_DOZE_FAILED <it meaning enter the doze mode failed>

< time out for fzc bit

Definition at line 801 of file at32f413_can.c.

◆ can_doze_mode_exit()

can_quit_doze_status_type can_doze_mode_exit ( can_type * can_x )

exit the doze mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_QUIT_DOZE_SUCCESSFUL <it meaning exit the doze mode succeed>
  • CAN_QUIT_DOZE_FAILED <it meaning exit the doze mode failed>

< time out for dzc bit

Definition at line 831 of file at32f413_can.c.

◆ can_error_type_record_get()

can_error_record_type can_error_type_record_get ( can_type * can_x )

return the error type record (etr) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of the error code the return can be one of the follow values:
  • CAN_ERRORRECORD_NOERR
  • CAN_ERRORRECORD_STUFFERR,
  • CAN_ERRORRECORD_FORMERR,
  • CAN_ERRORRECORD_ACKERR,
  • CAN_ERRORRECORD_BITRECESSIVEERR,
  • CAN_ERRORRECORD_BITDOMINANTERR,
  • CAN_ERRORRECORD_CRCERR,
  • CAN_ERRORRECORD_SOFTWARESETERR

Definition at line 863 of file at32f413_can.c.

◆ can_filter_default_para_init()

void can_filter_default_para_init ( can_filter_init_type * can_filter_init_struct )

fill each can_filter_init_struct member with its default value.

Parameters
can_filter_init_struct pointer to a can_filter_init_type structure which will be initialized.
Return values
none.

Definition at line 269 of file at32f413_can.c.

◆ can_filter_init()

void can_filter_init | ( | can_type * | can_x,
 |  | can_filter_init_type * | can_filter_init_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_filter_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_filter_init_struct | pointer to a can_filter_init_type structure that contains the configuration information.
Return values
none.

Definition at line 304 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_flag_clear()

void can_flag_clear | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

clear flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG
  • CAN_ETR_SOFTWARE_FLAG note:CAN_RF0MN_FLAG and CAN_RF1MN_FLAG can not clear by this function
Return values
none.

< error active flag

< error passive flag

< bus-off flag

< error occur interrupt flag

< eoif bit value, it clear by writing 1

< error type record flag

< eoif bit value, it clear by writing 1

< transmit mailbox 0 transmission completed flag

< tm0tcf bit value, it clear by writing 1

< transmit mailbox 1 transmission completed flag

< tm1tcf bit value, it clear by writing 1

< transmit mailbox 2 transmission completed flag

< tm2tcf bit value, it clear by writing 1

< receive fifo 0 full flag

< rf0ff bit value, it clear by writing 1

< receive fifo 0 overflow flag

< rf0of bit value, it clear by writing 1

< receive fifo 1 full flag

< rf1ff bit value, it clear by writing 1

< receive fifo 1 overflow flag

< rf1of bit value, it clear by writing 1

< quit doze mode interrupt flag

< qdzif bit value, it clear by writing 1

< enter doze mode confirm flag

< edzif bit value, it clear by writing 1

< transmit mailbox empty flag

< tm0tcf bit value, it clear by writing 1

< tm1tcf bit value, it clear by writing 1

< tm2tcf bit value, it clear by writing 1

Definition at line 1088 of file at32f413_can.c.

Referenced by CAN1_SE_IRQHandler().

◆ can_flag_get()

flag_status can_flag_get | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

get flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0MN_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1MN_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG note:the state of CAN_EDZC_FLAG need to check dzc and edzif bit note:the state of CAN_TMEF_FLAG need to check rqc0,rqc1 and rqc2 bit
Return values
status of can_flag, the returned value can be:SET or RESET.

< error active flag

< error passive flag

< bus-off flag

< error type record flag

< error occur interrupt flag

< transmit mailbox 0 transmission completed flag

< transmit mailbox 1 transmission completed flag

< transmit mailbox 2 transmission completed flag

< receive fifo 0 message num flag

< receive fifo 0 full flag

< receive fifo 0 overflow flag

< receive fifo 1 message num flag

< receive fifo 1 full flag

< receive fifo 1 overflow flag

< quit doze mode interrupt flag

< enter doze mode confirm flag

< transmit mailbox empty flag

Definition at line 964 of file at32f413_can.c.

Referenced by CAN1_SE_IRQHandler(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ can_interrupt_enable()

void can_interrupt_enable | ( | can_type * | can_x,
 |  | uint32_t | can_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the interrupt of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_int specifies the can interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • CAN_TCIEN_INT
  • CAN_RF0MIEN_INT
  • CAN_RF0FIEN_INT
  • CAN_RF0OIEN_INT
  • CAN_RF1MIEN_INT
  • CAN_RF1FIEN_INT
  • CAN_RF1OIEN_INT
  • CAN_EAIEN_INT
  • CAN_EPIEN_INT
  • CAN_BOIEN_INT
  • CAN_ETRIEN_INT
  • CAN_EOIEN_INT
  • CAN_QDZIEN_INT
  • CAN_EDZIEN_INT
new_state | new state of the can interrupts. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 924 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_message_receive()

void can_message_receive | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number,
 |  | can_rx_message_type * | rx_message_struct
 | ) |  |

receive message of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
rx_message_struct | pointer to a structure which store the receive message.
Return values
none.

Definition at line 619 of file at32f413_can.c.

Referenced by USBFS_L_CAN1_RX0_IRQHandler().

◆ can_message_transmit()

uint8_t can_message_transmit | ( | can_type * | can_x,
 |  | can_tx_message_type * | tx_message_struct
 | ) |  |

fill the transmission message and transmit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
tx_message_struct | pointer to a structure which contains the message to be trans.
Return values
the number of the mailbox that is used for transmission: this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
  • CAN_TX_STATUS_NO_EMPTY <meanings there is no empty mailbox, message cannot be filled>

Definition at line 440 of file at32f413_can.c.

Referenced by can_transmit_data().

◆ can_operating_mode_set()

error_status can_operating_mode_set | ( | can_type * | can_x,
 |  | can_operating_mode_type | can_operating_mode
 | ) |  |

set the operation mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_operating_mode can operating mode. this parameter can be one of the following values:
  • CAN_OPERATINGMODE_FREEZE
  • CAN_OPERATINGMODE_DOZE
  • CAN_OPERATINGMODE_COMMUNICATE
Return values
status of operation mode set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

Definition at line 723 of file at32f413_can.c.

◆ can_receive_error_counter_get()

uint8_t can_receive_error_counter_get ( can_type * can_x )

return the receive error counter (rec) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of receive error counter.

Definition at line 878 of file at32f413_can.c.

◆ can_receive_fifo_release()

void can_receive_fifo_release | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

release the specified fifo of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number fifo to be release. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
none.

< rf0r bit value, it clear by writing 1

< rf1r bit value, it clear by writing 1

Definition at line 666 of file at32f413_can.c.

Referenced by can_message_receive().

◆ can_receive_message_pending_get()

uint8_t can_receive_message_pending_get | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

return the number of pending messages of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
the number of message pending in the receive fifo.

Definition at line 692 of file at32f413_can.c.

◆ can_reset()

void can_reset ( can_type * can_x )

deinitialize the can peripheral registers to their default reset values.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
none.

Definition at line 51 of file at32f413_can.c.

◆ can_transmit_cancel()

void can_transmit_cancel | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

cancel a transmit request of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
mailbox mailbox number. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
none.

< tm0ct bit value, it clear by writing 1

< tm1ct bit value, it clear by writing 1

< tm2ct bit value, it clear by writing 1

Definition at line 589 of file at32f413_can.c.

◆ can_transmit_error_counter_get()

uint8_t can_transmit_error_counter_get ( can_type * can_x )

return the transmit error counter of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of transmit error counter.

Definition at line 892 of file at32f413_can.c.

◆ can_transmit_status_get()

can_transmit_status_type can_transmit_status_get | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

check the transmission state of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
transmit_mailbox the number of the mailbox that is used for transmission. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
can transmit status this parameter can be one of the following values:
  • CAN_TX_STATUS_SUCCESSFUL
  • CAN_TX_STATUS_FAILED
  • CAN_TX_STATUS_PENDING

Definition at line 514 of file at32f413_can.c.

Referenced by can_transmit_data().

◆ can_ttc_mode_enable()

void can_ttc_mode_enable | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable time trigger operation communication mode of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
new_state | : new state of time trigger operation communication mode. this parameter can be: TRUE or FALSE.
Note
note1: when enabled, transmit mailbox time stamp(tmts[15:0]) value is sent in the last two data bytes of the 8-byte message: tmts[7:0] in data byte 6 and tmts[15:8] in data byte 7
note2: tmdtbl must be programmed as 8 in order time stamp (2 bytes) to be sent over the can bus.
Return values
none

Definition at line 416 of file at32f413_can.c.


AT32F413 Firmwary Library: CAN_private_functions

Functions
CAN_private_functions
AT32F413_periph_driver » CAN

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

Function Documentation

◆ can_base_init()

error_status can_base_init | ( | can_type * | can_x,
 |  | can_base_type * | can_base_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_base_struct | pointer to a can_base_struct structure that contains the configuration information for the can peripheral.
Return values
the status of initialization this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 194 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_baudrate_default_para_init()

void can_baudrate_default_para_init ( can_baudrate_type * can_baudrate_struct )

fill each can_baudrate_struct member with its default value.

Parameters
can_baudrate_struct pointer to a can_baudrate_type structure which will be initialized.
Return values
none.

Definition at line 70 of file at32f413_can.c.

◆ can_baudrate_set()

error_status can_baudrate_set | ( | can_type * | can_x,
 |  | can_baudrate_type * | can_baudrate_struct
 | ) |  |

set the baudrate of the can peripheral

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_baudrate_struct | pointer to a can_baudrate_type structure which will be set.
Note
baudrate calculate method is: baudrate = fpclk/(baudrate_div *(3 + bts1_size + bts2_size))
Return values
the result of baudrate set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

< time out for fzc bit

Definition at line 99 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_debug_transmission_prohibit()

void can_debug_transmission_prohibit | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the debug transmission prohibit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
new_state | new state of debug transmission prohibit. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 395 of file at32f413_can.c.

◆ can_default_para_init()

void can_default_para_init ( can_base_type * can_base_struct )

fill each can_init_struct member with its default value.

Parameters
can_base_struct pointer to a can_base_type structure which will be initialized.
Return values
none.

Definition at line 157 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_doze_mode_enter()

can_enter_doze_status_type can_doze_mode_enter ( can_type * can_x )

enter the low power mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_ENTER_DOZE_SUCCESSFUL <it meaning enter the doze mode succeed>
  • CAN_ENTER_DOZE_FAILED <it meaning enter the doze mode failed>

< time out for fzc bit

Definition at line 801 of file at32f413_can.c.

◆ can_doze_mode_exit()

can_quit_doze_status_type can_doze_mode_exit ( can_type * can_x )

exit the doze mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
status of doze mode enter, the returned value can be:
  • CAN_QUIT_DOZE_SUCCESSFUL <it meaning exit the doze mode succeed>
  • CAN_QUIT_DOZE_FAILED <it meaning exit the doze mode failed>

< time out for dzc bit

Definition at line 831 of file at32f413_can.c.

◆ can_error_type_record_get()

can_error_record_type can_error_type_record_get ( can_type * can_x )

return the error type record (etr) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of the error code the return can be one of the follow values:
  • CAN_ERRORRECORD_NOERR
  • CAN_ERRORRECORD_STUFFERR,
  • CAN_ERRORRECORD_FORMERR,
  • CAN_ERRORRECORD_ACKERR,
  • CAN_ERRORRECORD_BITRECESSIVEERR,
  • CAN_ERRORRECORD_BITDOMINANTERR,
  • CAN_ERRORRECORD_CRCERR,
  • CAN_ERRORRECORD_SOFTWARESETERR

Definition at line 863 of file at32f413_can.c.

◆ can_filter_default_para_init()

void can_filter_default_para_init ( can_filter_init_type * can_filter_init_struct )

fill each can_filter_init_struct member with its default value.

Parameters
can_filter_init_struct pointer to a can_filter_init_type structure which will be initialized.
Return values
none.

Definition at line 269 of file at32f413_can.c.

◆ can_filter_init()

void can_filter_init | ( | can_type * | can_x,
 |  | can_filter_init_type * | can_filter_init_struct
 | ) |  |

initialize the can peripheral according to the specified parameters in the can_filter_init_struct.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_filter_init_struct | pointer to a can_filter_init_type structure that contains the configuration information.
Return values
none.

Definition at line 304 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_flag_clear()

void can_flag_clear | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

clear flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG
  • CAN_ETR_SOFTWARE_FLAG note:CAN_RF0MN_FLAG and CAN_RF1MN_FLAG can not clear by this function
Return values
none.

< error active flag

< error passive flag

< bus-off flag

< error occur interrupt flag

< eoif bit value, it clear by writing 1

< error type record flag

< eoif bit value, it clear by writing 1

< transmit mailbox 0 transmission completed flag

< tm0tcf bit value, it clear by writing 1

< transmit mailbox 1 transmission completed flag

< tm1tcf bit value, it clear by writing 1

< transmit mailbox 2 transmission completed flag

< tm2tcf bit value, it clear by writing 1

< receive fifo 0 full flag

< rf0ff bit value, it clear by writing 1

< receive fifo 0 overflow flag

< rf0of bit value, it clear by writing 1

< receive fifo 1 full flag

< rf1ff bit value, it clear by writing 1

< receive fifo 1 overflow flag

< rf1of bit value, it clear by writing 1

< quit doze mode interrupt flag

< qdzif bit value, it clear by writing 1

< enter doze mode confirm flag

< edzif bit value, it clear by writing 1

< transmit mailbox empty flag

< tm0tcf bit value, it clear by writing 1

< tm1tcf bit value, it clear by writing 1

< tm2tcf bit value, it clear by writing 1

Definition at line 1088 of file at32f413_can.c.

Referenced by CAN1_SE_IRQHandler().

◆ can_flag_get()

flag_status can_flag_get | ( | can_type * | can_x,
 |  | uint32_t | can_flag
 | ) |  |

get flag of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_flag select the flag. this parameter can be one of the following flags:
  • CAN_EAF_FLAG
  • CAN_EPF_FLAG
  • CAN_BOF_FLAG
  • CAN_ETR_FLAG
  • CAN_EOIF_FLAG
  • CAN_TM0TCF_FLAG
  • CAN_TM1TCF_FLAG
  • CAN_TM2TCF_FLAG
  • CAN_RF0MN_FLAG
  • CAN_RF0FF_FLAG
  • CAN_RF0OF_FLAG
  • CAN_RF1MN_FLAG
  • CAN_RF1FF_FLAG
  • CAN_RF1OF_FLAG
  • CAN_QDZIF_FLAG
  • CAN_EDZC_FLAG
  • CAN_TMEF_FLAG note:the state of CAN_EDZC_FLAG need to check dzc and edzif bit note:the state of CAN_TMEF_FLAG need to check rqc0,rqc1 and rqc2 bit
Return values
status of can_flag, the returned value can be:SET or RESET.

< error active flag

< error passive flag

< bus-off flag

< error type record flag

< error occur interrupt flag

< transmit mailbox 0 transmission completed flag

< transmit mailbox 1 transmission completed flag

< transmit mailbox 2 transmission completed flag

< receive fifo 0 message num flag

< receive fifo 0 full flag

< receive fifo 0 overflow flag

< receive fifo 1 message num flag

< receive fifo 1 full flag

< receive fifo 1 overflow flag

< quit doze mode interrupt flag

< enter doze mode confirm flag

< transmit mailbox empty flag

Definition at line 964 of file at32f413_can.c.

Referenced by CAN1_SE_IRQHandler(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ can_interrupt_enable()

void can_interrupt_enable | ( | can_type * | can_x,
 |  | uint32_t | can_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the interrupt of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_int specifies the can interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • CAN_TCIEN_INT
  • CAN_RF0MIEN_INT
  • CAN_RF0FIEN_INT
  • CAN_RF0OIEN_INT
  • CAN_RF1MIEN_INT
  • CAN_RF1FIEN_INT
  • CAN_RF1OIEN_INT
  • CAN_EAIEN_INT
  • CAN_EPIEN_INT
  • CAN_BOIEN_INT
  • CAN_ETRIEN_INT
  • CAN_EOIEN_INT
  • CAN_QDZIEN_INT
  • CAN_EDZIEN_INT
new_state | new state of the can interrupts. this parameter can be: TRUE or FALSE.
Return values
none.

Definition at line 924 of file at32f413_can.c.

Referenced by can_configuration().

◆ can_message_receive()

void can_message_receive | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number,
 |  | can_rx_message_type * | rx_message_struct
 | ) |  |

receive message of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
rx_message_struct | pointer to a structure which store the receive message.
Return values
none.

Definition at line 619 of file at32f413_can.c.

Referenced by USBFS_L_CAN1_RX0_IRQHandler().

◆ can_message_transmit()

uint8_t can_message_transmit | ( | can_type * | can_x,
 |  | can_tx_message_type * | tx_message_struct
 | ) |  |

fill the transmission message and transmit of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
tx_message_struct | pointer to a structure which contains the message to be trans.
Return values
the number of the mailbox that is used for transmission: this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
  • CAN_TX_STATUS_NO_EMPTY <meanings there is no empty mailbox, message cannot be filled>

Definition at line 440 of file at32f413_can.c.

Referenced by can_transmit_data().

◆ can_operating_mode_set()

error_status can_operating_mode_set | ( | can_type * | can_x,
 |  | can_operating_mode_type | can_operating_mode
 | ) |  |

set the operation mode of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
can_operating_mode can operating mode. this parameter can be one of the following values:
  • CAN_OPERATINGMODE_FREEZE
  • CAN_OPERATINGMODE_DOZE
  • CAN_OPERATINGMODE_COMMUNICATE
Return values
status of operation mode set this parameter can be one of the following values: SUCCESS or ERROR

< time out for fzc bit

Definition at line 723 of file at32f413_can.c.

◆ can_receive_error_counter_get()

uint8_t can_receive_error_counter_get ( can_type * can_x )

return the receive error counter (rec) of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of receive error counter.

Definition at line 878 of file at32f413_can.c.

◆ can_receive_fifo_release()

void can_receive_fifo_release | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

release the specified fifo of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number fifo to be release. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
none.

< rf0r bit value, it clear by writing 1

< rf1r bit value, it clear by writing 1

Definition at line 666 of file at32f413_can.c.

Referenced by can_message_receive().

◆ can_receive_message_pending_get()

uint8_t can_receive_message_pending_get | ( | can_type * | can_x,
 |  | can_rx_fifo_num_type | fifo_number
 | ) |  |

return the number of pending messages of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
fifo_number receive fifo number. this parameter can be one of the following values:
  • CAN_RX_FIFO0
  • CAN_RX_FIFO1
Return values
the number of message pending in the receive fifo.

Definition at line 692 of file at32f413_can.c.

◆ can_reset()

void can_reset ( can_type * can_x )

deinitialize the can peripheral registers to their default reset values.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
none.

Definition at line 51 of file at32f413_can.c.

◆ can_transmit_cancel()

void can_transmit_cancel | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

cancel a transmit request of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
mailbox mailbox number. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
none.

< tm0ct bit value, it clear by writing 1

< tm1ct bit value, it clear by writing 1

< tm2ct bit value, it clear by writing 1

Definition at line 589 of file at32f413_can.c.

◆ can_transmit_error_counter_get()

uint8_t can_transmit_error_counter_get ( can_type * can_x )

return the transmit error counter of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1,CAN2.
Return values
the value of transmit error counter.

Definition at line 892 of file at32f413_can.c.

◆ can_transmit_status_get()

can_transmit_status_type can_transmit_status_get | ( | can_type * | can_x,
 |  | can_tx_mailbox_num_type | transmit_mailbox
 | ) |  |

check the transmission state of the specified can peripheral.

Parameters
can_x select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
transmit_mailbox the number of the mailbox that is used for transmission. this parameter can be one of the following values:
  • CAN_TX_MAILBOX0
  • CAN_TX_MAILBOX1
  • CAN_TX_MAILBOX2
Return values
can transmit status this parameter can be one of the following values:
  • CAN_TX_STATUS_SUCCESSFUL
  • CAN_TX_STATUS_FAILED
  • CAN_TX_STATUS_PENDING

Definition at line 514 of file at32f413_can.c.

Referenced by can_transmit_data().

◆ can_ttc_mode_enable()

void can_ttc_mode_enable | ( | can_type * | can_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable time trigger operation communication mode of the specified can peripheral.

Parameters
can_x | select the can peripheral. this parameter can be one of the following values: CAN1 or CAN2.
new_state | : new state of time trigger operation communication mode. this parameter can be: TRUE or FALSE.
Note
note1: when enabled, transmit mailbox time stamp(tmts[15:0]) value is sent in the last two data bytes of the 8-byte message: tmts[7:0] in data byte 6 and tmts[15:8] in data byte 7
note2: tmdtbl must be programmed as 8 in order time stamp (2 bytes) to be sent over the can bus.
Return values
none

Definition at line 416 of file at32f413_can.c.


AT32F413 Firmwary Library: CRC

Modules | Macros
CRC
AT32F413_periph_driver

CRC driver modules. More...

Modules

CRC_exported_types
CRC_exported_functions
CRC_private_functions

Macros

#define CRC ((crc_type *) CRC_BASE)

Detailed Description

CRC driver modules.

Macro Definition Documentation

◆ CRC

#define CRC ((crc_type *) CRC_BASE)

Definition at line 140 of file at32f413_crc.h.


AT32F413 Firmwary Library: CRC_exported_types

Data Structures | Enumerations
CRC_exported_types
AT32F413_periph_driver » CRC

Data Structures

struct crc_type
type define crc register all More...

Enumerations

enum | crc_reverse_input_type { CRC_REVERSE_INPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_INPUT_BY_BYTE = 0x01 , CRC_REVERSE_INPUT_BY_HALFWORD = 0x02 , CRC_REVERSE_INPUT_BY_WORD = 0x03 }
crc reverse input data More...
enum | crc_reverse_output_type { CRC_REVERSE_OUTPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_OUTPUT_DATA = 0x01 }
crc reverse output data More...

Detailed Description

Enumeration Type Documentation

◆ crc_reverse_input_type

enum crc_reverse_input_type

crc reverse input data

Enumerator
CRC_REVERSE_INPUT_NO_AFFECTE | input data no reverse
CRC_REVERSE_INPUT_BY_BYTE | input data reverse by byte
CRC_REVERSE_INPUT_BY_HALFWORD | input data reverse by half word
CRC_REVERSE_INPUT_BY_WORD | input data reverse by word

Definition at line 54 of file at32f413_crc.h.

◆ crc_reverse_output_type

enum crc_reverse_output_type

crc reverse output data

Enumerator
CRC_REVERSE_OUTPUT_NO_AFFECTE | output data no reverse
CRC_REVERSE_OUTPUT_DATA | output data reverse by word

Definition at line 65 of file at32f413_crc.h.


AT32F413 Firmwary Library: crc_type Struct Reference

Data Fields
crc_type Struct Reference
AT32F413_periph_driver » CRC » CRC_exported_types

type define crc register all More...

#include <at32f413_crc.h>

Data Fields

union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 32
} dt_bit
};
crc dt register, offset:0x00 More...
union {
__IO uint32_t cdt
struct {
__IO uint32_t cdt: 8
__IO uint32_t reserved1: 24
} cdt_bit
};
crc cdt register, offset:0x04 More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t rst: 1
__IO uint32_t reserved1: 4
__IO uint32_t revid: 2
__IO uint32_t revod: 1
__IO uint32_t reserved2: 24
} ctrl_bit
};
crc ctrl register, offset:0x08 More...
union {
__IO uint32_t idt
struct {
__IO uint32_t idt: 32
} idt_bit
};
crc idt register, offset:0x10 More...

Detailed Description

type define crc register all

Definition at line 74 of file at32f413_crc.h.

Field Documentation

◆

union { ... } crc_type::@277

crc dt register, offset:0x00

◆

union { ... } crc_type::@279

crc cdt register, offset:0x04

◆

union { ... } crc_type::@281

crc ctrl register, offset:0x08

◆

union { ... } crc_type::@283

crc idt register, offset:0x10

◆ cdt

__IO uint32_t crc_type::cdt

Definition at line 93 of file at32f413_crc.h.

◆

struct { ... } crc_type::cdt_bit

◆ ctrl

__IO uint32_t crc_type::ctrl

Definition at line 106 of file at32f413_crc.h.

◆

struct { ... } crc_type::ctrl_bit

◆ dt

__IO uint32_t crc_type::dt

Definition at line 81 of file at32f413_crc.h.

◆

struct { ... } crc_type::dt_bit

◆ idt

__IO uint32_t crc_type::idt

Definition at line 127 of file at32f413_crc.h.

◆

struct { ... } crc_type::idt_bit

◆ reserved1

__IO uint32_t crc_type::reserved1

crm reserved1 register, offset:0x0C

Definition at line 97 of file at32f413_crc.h.

◆ reserved2

__IO uint32_t crc_type::reserved2

Definition at line 113 of file at32f413_crc.h.

◆ revid

__IO uint32_t crc_type::revid

Definition at line 111 of file at32f413_crc.h.

◆ revod

__IO uint32_t crc_type::revod

Definition at line 112 of file at32f413_crc.h.

◆ rst

__IO uint32_t crc_type::rst

Definition at line 109 of file at32f413_crc.h.

The documentation for this struct was generated from the following file:
  • at32f413_crc.h


AT32F413 Firmwary Library: CRC_exported_functions

Functions
CRC_exported_functions
AT32F413_periph_driver » CRC

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_date_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...

Detailed Description

Function Documentation

◆ crc_block_calculate()

uint32_t crc_block_calculate | ( | uint32_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

compute the 32-bit crc of a given buffer of data word(32-bit).

Parameters
pbuffer | pointer to the buffer containing the data to be computed
length | length of the buffer to be computed
Return values
32-bit crc

Definition at line 72 of file at32f413_crc.c.

Referenced by main().

◆ crc_common_data_set()

void crc_common_data_set ( uint8_t cdt_value )

store a 8-bit data in the common data register.

Parameters
cdt_value 8-bit value to be stored in the common data register
Return values
none

Definition at line 99 of file at32f413_crc.c.

◆ crc_common_date_get()

uint8_t crc_common_date_get ( void )

return the 8-bit data stored in the common data register

Parameters
none
Return values
8-bit value of the common data register

Definition at line 109 of file at32f413_crc.c.

◆ crc_data_get()

uint32_t crc_data_get ( void )

return the current crc value.

Parameters
none
Return values
32-bit crc

Definition at line 89 of file at32f413_crc.c.

Referenced by crc_cal().

◆ crc_data_reset()

void crc_data_reset ( void )

reset the crc data register.

Parameters
none
Return values
none

Definition at line 49 of file at32f413_crc.c.

Referenced by crc_cal(), flash_crc_check(), and main().

◆ crc_init_data_set()

void crc_init_data_set ( uint32_t value )

set the 32-bit initial data of crc

Parameters
value initial data
Return values
none

Definition at line 119 of file at32f413_crc.c.

◆ crc_one_word_calculate()

uint32_t crc_one_word_calculate ( uint32_t data )

compute the 32-bit crc of a given data word(32-bit).

Parameters
data data word(32-bit) to compute its crc
Return values
32-bit crc

Definition at line 60 of file at32f413_crc.c.

Referenced by crc_cal(), and flash_crc_check().

◆ crc_reverse_input_data_set()

void crc_reverse_input_data_set ( crc_reverse_input_type value )

control the reversal of the bit order in the input data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_INPUT_NO_AFFECTE
  • CRC_REVERSE_INPUT_BY_BYTE
  • CRC_REVERSE_INPUT_BY_HALFWORD
  • CRC_REVERSE_INPUT_BY_WORD
Return values
none.

Definition at line 134 of file at32f413_crc.c.

◆ crc_reverse_output_data_set()

void crc_reverse_output_data_set ( crc_reverse_output_type value )

control the reversal of the bit order in the output data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_OUTPUT_NO_AFFECTE
  • CRC_REVERSE_OUTPUT_DATA
Return values
none.

Definition at line 147 of file at32f413_crc.c.


AT32F413 Firmwary Library: CRC_private_functions

Functions
CRC_private_functions
AT32F413_periph_driver » CRC

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_date_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...

Detailed Description

Function Documentation

◆ crc_block_calculate()

uint32_t crc_block_calculate | ( | uint32_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

compute the 32-bit crc of a given buffer of data word(32-bit).

Parameters
pbuffer | pointer to the buffer containing the data to be computed
length | length of the buffer to be computed
Return values
32-bit crc

Definition at line 72 of file at32f413_crc.c.

Referenced by main().

◆ crc_common_data_set()

void crc_common_data_set ( uint8_t cdt_value )

store a 8-bit data in the common data register.

Parameters
cdt_value 8-bit value to be stored in the common data register
Return values
none

Definition at line 99 of file at32f413_crc.c.

◆ crc_common_date_get()

uint8_t crc_common_date_get ( void )

return the 8-bit data stored in the common data register

Parameters
none
Return values
8-bit value of the common data register

Definition at line 109 of file at32f413_crc.c.

◆ crc_data_get()

uint32_t crc_data_get ( void )

return the current crc value.

Parameters
none
Return values
32-bit crc

Definition at line 89 of file at32f413_crc.c.

Referenced by crc_cal().

◆ crc_data_reset()

void crc_data_reset ( void )

reset the crc data register.

Parameters
none
Return values
none

Definition at line 49 of file at32f413_crc.c.

Referenced by crc_cal(), flash_crc_check(), and main().

◆ crc_init_data_set()

void crc_init_data_set ( uint32_t value )

set the 32-bit initial data of crc

Parameters
value initial data
Return values
none

Definition at line 119 of file at32f413_crc.c.

◆ crc_one_word_calculate()

uint32_t crc_one_word_calculate ( uint32_t data )

compute the 32-bit crc of a given data word(32-bit).

Parameters
data data word(32-bit) to compute its crc
Return values
32-bit crc

Definition at line 60 of file at32f413_crc.c.

Referenced by crc_cal(), and flash_crc_check().

◆ crc_reverse_input_data_set()

void crc_reverse_input_data_set ( crc_reverse_input_type value )

control the reversal of the bit order in the input data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_INPUT_NO_AFFECTE
  • CRC_REVERSE_INPUT_BY_BYTE
  • CRC_REVERSE_INPUT_BY_HALFWORD
  • CRC_REVERSE_INPUT_BY_WORD
Return values
none.

Definition at line 134 of file at32f413_crc.c.

◆ crc_reverse_output_data_set()

void crc_reverse_output_data_set ( crc_reverse_output_type value )

control the reversal of the bit order in the output data

Parameters
value this parameter can be one of the following values:
  • CRC_REVERSE_OUTPUT_NO_AFFECTE
  • CRC_REVERSE_OUTPUT_DATA
Return values
none.

Definition at line 147 of file at32f413_crc.c.


AT32F413 Firmwary Library: CRM

Modules | Macros
CRM
AT32F413_periph_driver

CRM driver modules. More...

Modules

CRM_flags_definition
crm flag
CRM_interrupts_definition
crm interrupt
CRM_exported_types
CRM_exported_functions
CRM_private_functions

Macros

#define | CRM_REG(value) PERIPH_REG(CRM_BASE, value)
#define | CRM_REG_BIT(value) PERIPH_REG_BIT(value)
#define | CRM ((crm_type *) CRM_BASE)

Detailed Description

CRM driver modules.

Macro Definition Documentation

◆ CRM

#define CRM ((crm_type *) CRM_BASE)

Definition at line 844 of file at32f413_crm.h.

◆ CRM_REG

#define CRM_REG ( value ) PERIPH_REG(CRM_BASE, value)

Definition at line 47 of file at32f413_crm.h.

◆ CRM_REG_BIT

#define CRM_REG_BIT ( value ) PERIPH_REG_BIT(value)

Definition at line 48 of file at32f413_crm.h.


AT32F413 Firmwary Library: CRM_flags_definition

Macros
CRM_flags_definition
AT32F413_periph_driver » CRM

crm flag More...

Macros

#define | CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)
#define | CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)
#define | CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)
#define | CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x20, 1)
#define | CRM_LICK_STABLE_FLAG MAKE_VALUE(0x24, 1)
#define | CRM_ALL_RESET_FLAG MAKE_VALUE(0x24, 24)
#define | CRM_NRST_RESET_FLAG MAKE_VALUE(0x24, 26)
#define | CRM_POR_RESET_FLAG MAKE_VALUE(0x24, 27)
#define | CRM_SW_RESET_FLAG MAKE_VALUE(0x24, 28)
#define | CRM_WDT_RESET_FLAG MAKE_VALUE(0x24, 29)
#define | CRM_WWDT_RESET_FLAG MAKE_VALUE(0x24, 30)
#define | CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x24, 31)
#define | CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x08, 0)
#define | CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x08, 1)
#define | CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x08, 2)
#define | CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x08, 3)
#define | CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x08, 4)
#define | CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x08, 7)

Detailed Description

crm flag

Macro Definition Documentation

◆ CRM_ALL_RESET_FLAG

#define CRM_ALL_RESET_FLAG MAKE_VALUE(0x24, 24)

all reset flag

Definition at line 60 of file at32f413_crm.h.

◆ CRM_CLOCK_FAILURE_INT_FLAG

#define CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x08, 7)

clock failure interrupt ready flag

Definition at line 72 of file at32f413_crm.h.

◆ CRM_HEXT_READY_INT_FLAG

#define CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x08, 3)

high speed external crystal stable interrupt ready flag

Definition at line 70 of file at32f413_crm.h.

◆ CRM_HEXT_STABLE_FLAG

#define CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)

high speed external crystal stable flag

Definition at line 56 of file at32f413_crm.h.

◆ CRM_HICK_READY_INT_FLAG

#define CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x08, 2)

high speed internal clock stable interrupt ready flag

Definition at line 69 of file at32f413_crm.h.

◆ CRM_HICK_STABLE_FLAG

#define CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)

high speed internal clock stable flag

Definition at line 55 of file at32f413_crm.h.

◆ CRM_LEXT_READY_INT_FLAG

#define CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x08, 1)

low speed external crystal stable interrupt ready flag

Definition at line 68 of file at32f413_crm.h.

◆ CRM_LEXT_STABLE_FLAG

#define CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x20, 1)

low speed external crystal stable flag

Definition at line 58 of file at32f413_crm.h.

◆ CRM_LICK_READY_INT_FLAG

#define CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x08, 0)

low speed internal clock stable interrupt ready flag

Definition at line 67 of file at32f413_crm.h.

◆ CRM_LICK_STABLE_FLAG

#define CRM_LICK_STABLE_FLAG MAKE_VALUE(0x24, 1)

low speed internal clock stable flag

Definition at line 59 of file at32f413_crm.h.

◆ CRM_LOWPOWER_RESET_FLAG

#define CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x24, 31)

low-power reset flag

Definition at line 66 of file at32f413_crm.h.

◆ CRM_NRST_RESET_FLAG

#define CRM_NRST_RESET_FLAG MAKE_VALUE(0x24, 26)

nrst pin reset flag

Definition at line 61 of file at32f413_crm.h.

◆ CRM_PLL_READY_INT_FLAG

#define CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x08, 4)

phase locking loop stable interrupt ready flag

Definition at line 71 of file at32f413_crm.h.

◆ CRM_PLL_STABLE_FLAG

#define CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)

phase locking loop stable flag

Definition at line 57 of file at32f413_crm.h.

◆ CRM_POR_RESET_FLAG

#define CRM_POR_RESET_FLAG MAKE_VALUE(0x24, 27)

power on reset flag

Definition at line 62 of file at32f413_crm.h.

◆ CRM_SW_RESET_FLAG

#define CRM_SW_RESET_FLAG MAKE_VALUE(0x24, 28)

software reset flag

Definition at line 63 of file at32f413_crm.h.

◆ CRM_WDT_RESET_FLAG

#define CRM_WDT_RESET_FLAG MAKE_VALUE(0x24, 29)

watchdog timer reset flag

Definition at line 64 of file at32f413_crm.h.

◆ CRM_WWDT_RESET_FLAG

#define CRM_WWDT_RESET_FLAG MAKE_VALUE(0x24, 30)

window watchdog timer reset flag

Definition at line 65 of file at32f413_crm.h.


AT32F413 Firmwary Library: CRM_interrupts_definition

Macros
CRM_interrupts_definition
AT32F413_periph_driver » CRM

crm interrupt More...

Macros

#define | CRM_LICK_STABLE_INT ((uint32_t)0x00000100)
#define | CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)
#define | CRM_HICK_STABLE_INT ((uint32_t)0x00000400)
#define | CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)
#define | CRM_PLL_STABLE_INT ((uint32_t)0x00001000)
#define | CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)

Detailed Description

crm interrupt

Macro Definition Documentation

◆ CRM_CLOCK_FAILURE_INT

#define CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)

clock failure interrupt

Definition at line 88 of file at32f413_crm.h.

◆ CRM_HEXT_STABLE_INT

#define CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)

high speed external crystal stable interrupt

Definition at line 86 of file at32f413_crm.h.

◆ CRM_HICK_STABLE_INT

#define CRM_HICK_STABLE_INT ((uint32_t)0x00000400)

high speed internal clock stable interrupt

Definition at line 85 of file at32f413_crm.h.

◆ CRM_LEXT_STABLE_INT

#define CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)

low speed external crystal stable interrupt

Definition at line 84 of file at32f413_crm.h.

◆ CRM_LICK_STABLE_INT

#define CRM_LICK_STABLE_INT ((uint32_t)0x00000100)

low speed internal clock stable interrupt

Definition at line 83 of file at32f413_crm.h.

◆ CRM_PLL_STABLE_INT

#define CRM_PLL_STABLE_INT ((uint32_t)0x00001000)

phase locking loop stable interrupt

Definition at line 87 of file at32f413_crm.h.


AT32F413 Firmwary Library: CRM_exported_types

Data Structures | Enumerations
CRM_exported_types
AT32F413_periph_driver » CRM

Data Structures

struct | crm_clocks_freq_type
crm clocks freqency structure More...
struct | crm_type
type define crm register all More...

Enumerations

enum crm_periph_clock_type {
CRM_DMA1_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 0 & 0x1F)) , CRM_DMA2_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 1 & 0x1F)) , CRM_CRC_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 6 & 0x1F)) , CRM_SDIO1_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 10 & 0x1F)) ,
CRM_IOMUX_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 0 & 0x1F)) , CRM_GPIOA_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 2 & 0x1F)) , CRM_GPIOB_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 3 & 0x1F)) , CRM_GPIOC_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 4 & 0x1F)) ,
CRM_GPIOD_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 5 & 0x1F)) , CRM_GPIOF_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 7 & 0x1F)) , CRM_ADC1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 9 & 0x1F)) , CRM_ADC2_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 10 & 0x1F)) ,
CRM_TMR1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 11 & 0x1F)) , CRM_SPI1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 12 & 0x1F)) , CRM_TMR8_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 13 & 0x1F)) , CRM_USART1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 14 & 0x1F)) ,
CRM_TMR9_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 19 & 0x1F)) , CRM_TMR10_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 20 & 0x1F)) , CRM_TMR11_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 21 & 0x1F)) , CRM_ACC_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 22 & 0x1F)) ,
CRM_TMR2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 0 & 0x1F)) , CRM_TMR3_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 1 & 0x1F)) , CRM_TMR4_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 2 & 0x1F)) , CRM_TMR5_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 3 & 0x1F)) ,
CRM_WWDT_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 11 & 0x1F)) , CRM_SPI2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 14 & 0x1F)) , CRM_USART2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 17 & 0x1F)) , CRM_USART3_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 18 & 0x1F)) ,
CRM_UART4_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 19 & 0x1F)) , CRM_UART5_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 20 & 0x1F)) , CRM_I2C1_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 21 & 0x1F)) , CRM_I2C2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 22 & 0x1F)) ,
CRM_USB_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 23 & 0x1F)) , CRM_CAN1_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 25 & 0x1F)) , CRM_BPR_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 27 & 0x1F)) , CRM_PWC_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 28 & 0x1F)) ,
CRM_CAN2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 31 & 0x1F))
}
crm periph clock More...
enum crm_periph_reset_type {
CRM_IOMUX_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 0 & 0x1F)) , CRM_EXINT_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 1 & 0x1F)) , CRM_GPIOA_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 2 & 0x1F)) , CRM_GPIOB_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 3 & 0x1F)) ,
CRM_GPIOC_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 4 & 0x1F)) , CRM_GPIOD_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 5 & 0x1F)) , CRM_GPIOF_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 7 & 0x1F)) , CRM_ADC1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 9 & 0x1F)) ,
CRM_ADC2_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 10 & 0x1F)) , CRM_TMR1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 11 & 0x1F)) , CRM_SPI1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 12 & 0x1F)) , CRM_TMR8_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 13 & 0x1F)) ,
CRM_USART1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 14 & 0x1F)) , CRM_TMR9_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 19 & 0x1F)) , CRM_TMR10_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 20 & 0x1F)) , CRM_TMR11_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 21 & 0x1F)) ,
CRM_ACC_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 22 & 0x1F)) , CRM_TMR2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 0 & 0x1F)) , CRM_TMR3_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 1 & 0x1F)) , CRM_TMR4_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 2 & 0x1F)) ,
CRM_TMR5_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 3 & 0x1F)) , CRM_WWDT_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 11 & 0x1F)) , CRM_SPI2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 14 & 0x1F)) , CRM_USART2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 17 & 0x1F)) ,
CRM_USART3_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 18 & 0x1F)) , CRM_UART4_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 19 & 0x1F)) , CRM_UART5_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 20 & 0x1F)) , CRM_I2C1_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 21 & 0x1F)) ,
CRM_I2C2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 22 & 0x1F)) , CRM_USB_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 23 & 0x1F)) , CRM_CAN1_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 25 & 0x1F)) , CRM_BPR_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 27 & 0x1F)) ,
CRM_PWC_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 28 & 0x1F)) , CRM_CAN2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 31 & 0x1F))
}
crm periph reset More...
enum | crm_periph_clock_sleepmd_type { CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE = (uint32_t)((( 0x14 ) << 16) | ( 2 & 0x1F)) , CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE = (uint32_t)((( 0x14 ) << 16) | ( 4 & 0x1F)) }
crm periph clock in sleep mode More...
enum crm_pll_mult_type {
CRM_PLL_MULT_2 = 0 , CRM_PLL_MULT_3 = 1 , CRM_PLL_MULT_4 = 2 , CRM_PLL_MULT_5 = 3 ,
CRM_PLL_MULT_6 = 4 , CRM_PLL_MULT_7 = 5 , CRM_PLL_MULT_8 = 6 , CRM_PLL_MULT_9 = 7 ,
CRM_PLL_MULT_10 = 8 , CRM_PLL_MULT_11 = 9 , CRM_PLL_MULT_12 = 10 , CRM_PLL_MULT_13 = 11 ,
CRM_PLL_MULT_14 = 12 , CRM_PLL_MULT_15 = 13 , CRM_PLL_MULT_16 = 15 , CRM_PLL_MULT_17 = 16 ,
CRM_PLL_MULT_18 = 17 , CRM_PLL_MULT_19 = 18 , CRM_PLL_MULT_20 = 19 , CRM_PLL_MULT_21 = 20 ,
CRM_PLL_MULT_22 = 21 , CRM_PLL_MULT_23 = 22 , CRM_PLL_MULT_24 = 23 , CRM_PLL_MULT_25 = 24 ,
CRM_PLL_MULT_26 = 25 , CRM_PLL_MULT_27 = 26 , CRM_PLL_MULT_28 = 27 , CRM_PLL_MULT_29 = 28 ,
CRM_PLL_MULT_30 = 29 , CRM_PLL_MULT_31 = 30 , CRM_PLL_MULT_32 = 31 , CRM_PLL_MULT_33 = 32 ,
CRM_PLL_MULT_34 = 33 , CRM_PLL_MULT_35 = 34 , CRM_PLL_MULT_36 = 35 , CRM_PLL_MULT_37 = 36 ,
CRM_PLL_MULT_38 = 37 , CRM_PLL_MULT_39 = 38 , CRM_PLL_MULT_40 = 39 , CRM_PLL_MULT_41 = 40 ,
CRM_PLL_MULT_42 = 41 , CRM_PLL_MULT_43 = 42 , CRM_PLL_MULT_44 = 43 , CRM_PLL_MULT_45 = 44 ,
CRM_PLL_MULT_46 = 45 , CRM_PLL_MULT_47 = 46 , CRM_PLL_MULT_48 = 47 , CRM_PLL_MULT_49 = 48 ,
CRM_PLL_MULT_50 = 49 , CRM_PLL_MULT_51 = 50 , CRM_PLL_MULT_52 = 51 , CRM_PLL_MULT_53 = 52 ,
CRM_PLL_MULT_54 = 53 , CRM_PLL_MULT_55 = 54 , CRM_PLL_MULT_56 = 55 , CRM_PLL_MULT_57 = 56 ,
CRM_PLL_MULT_58 = 57 , CRM_PLL_MULT_59 = 58 , CRM_PLL_MULT_60 = 59 , CRM_PLL_MULT_61 = 60 ,
CRM_PLL_MULT_62 = 61 , CRM_PLL_MULT_63 = 62 , CRM_PLL_MULT_64 = 63
}
crm pll mult_x More...
enum | crm_pll_clock_source_type { CRM_PLL_SOURCE_HICK = 0x00 , CRM_PLL_SOURCE_HEXT = 0x01 , CRM_PLL_SOURCE_HEXT_DIV = 0x02 }
crm pll clock source More...
enum | crm_pll_output_range_type { CRM_PLL_OUTPUT_RANGE_LE72MHZ = 0x00 , CRM_PLL_OUTPUT_RANGE_GT72MHZ = 0x01 }
crm pll clock output range More...
enum crm_clock_source_type {
CRM_CLOCK_SOURCE_HICK = 0x00 , CRM_CLOCK_SOURCE_HEXT = 0x01 , CRM_CLOCK_SOURCE_PLL = 0x02 , CRM_CLOCK_SOURCE_LEXT = 0x03 ,
CRM_CLOCK_SOURCE_LICK = 0x04
}
crm clock source More...
enum crm_ahb_div_type {
CRM_AHB_DIV_1 = 0x00 , CRM_AHB_DIV_2 = 0x08 , CRM_AHB_DIV_4 = 0x09 , CRM_AHB_DIV_8 = 0x0A ,
CRM_AHB_DIV_16 = 0x0B , CRM_AHB_DIV_64 = 0x0C , CRM_AHB_DIV_128 = 0x0D , CRM_AHB_DIV_256 = 0x0E ,
CRM_AHB_DIV_512 = 0x0F
}
crm ahb division More...
enum crm_apb1_div_type {
CRM_APB1_DIV_1 = 0x00 , CRM_APB1_DIV_2 = 0x04 , CRM_APB1_DIV_4 = 0x05 , CRM_APB1_DIV_8 = 0x06 ,
CRM_APB1_DIV_16 = 0x07
}
crm apb1 division More...
enum crm_apb2_div_type {
CRM_APB2_DIV_1 = 0x00 , CRM_APB2_DIV_2 = 0x04 , CRM_APB2_DIV_4 = 0x05 , CRM_APB2_DIV_8 = 0x06 ,
CRM_APB2_DIV_16 = 0x07
}
crm apb2 division More...
enum crm_adc_div_type {
CRM_ADC_DIV_2 = 0x00 , CRM_ADC_DIV_4 = 0x01 , CRM_ADC_DIV_6 = 0x02 , CRM_ADC_DIV_8 = 0x03 ,
CRM_ADC_DIV_12 = 0x05 , CRM_ADC_DIV_16 = 0x07
}
crm adc division More...
enum crm_usb_div_type {
CRM_USB_DIV_1_5 = 0x00 , CRM_USB_DIV_1 = 0x01 , CRM_USB_DIV_2_5 = 0x02 , CRM_USB_DIV_2 = 0x03 ,
CRM_USB_DIV_3_5 = 0x04 , CRM_USB_DIV_3 = 0x05 , CRM_USB_DIV_4 = 0x06
}
crm usb division More...
enum | crm_rtc_clock_type { CRM_RTC_CLOCK_NOCLK = 0x00 , CRM_RTC_CLOCK_LEXT = 0x01 , CRM_RTC_CLOCK_LICK = 0x02 , CRM_RTC_CLOCK_HEXT_DIV = 0x03 }
crm rtc clock More...
enum | crm_hick_div_6_type { CRM_HICK48_DIV6 = 0x00 , CRM_HICK48_NODIV = 0x01 }
crm hick 48mhz division More...
enum | crm_sclk_type { CRM_SCLK_HICK = 0x00 , CRM_SCLK_HEXT = 0x01 , CRM_SCLK_PLL = 0x02 }
crm sclk select More...
enum crm_clkout_select_type {
CRM_CLKOUT_NOCLK = 0x00 , CRM_CLKOUT_LICK = 0x02 , CRM_CLKOUT_LEXT = 0x03 , CRM_CLKOUT_SCLK = 0x04 ,
CRM_CLKOUT_HICK = 0x05 , CRM_CLKOUT_HEXT = 0x06 , CRM_CLKOUT_PLL_DIV_2 = 0x07 , CRM_CLKOUT_PLL_DIV_4 = 0x0C ,
CRM_CLKOUT_USB = 0x0D , CRM_CLKOUT_ADC = 0x0E
}
crm clkout select More...
enum crm_clkout_div_type {
CRM_CLKOUT_DIV_1 = 0x00 , CRM_CLKOUT_DIV_2 = 0x08 , CRM_CLKOUT_DIV_4 = 0x09 , CRM_CLKOUT_DIV_8 = 0x0A ,
CRM_CLKOUT_DIV_16 = 0x0B , CRM_CLKOUT_DIV_64 = 0x0C , CRM_CLKOUT_DIV_128 = 0x0D , CRM_CLKOUT_DIV_256 = 0x0E ,
CRM_CLKOUT_DIV_512 = 0x0F
}
crm clkout division More...
enum | crm_auto_step_mode_type { CRM_AUTO_STEP_MODE_DISABLE = 0x00 , CRM_AUTO_STEP_MODE_ENABLE = 0x03 }
crm auto step mode More...
enum | crm_usb_int_map_type { CRM_USB_INT19_INT20 = 0x00 , CRM_USB_INT73_INT74 = 0x01 }
crm usbdev interrupt remap More...
enum | crm_usb_clock_source_type { CRM_USB_CLOCK_SOURCE_PLL = 0x00 , CRM_USB_CLOCK_SOURCE_HICK = 0x01 }
crm usb 48 mhz clock source select More...
enum | crm_hick_sclk_frequency_type { CRM_HICK_SCLK_8MHZ = 0x00 , CRM_HICK_SCLK_48MHZ = 0x01 }
crm hick as system clock frequency select More...

Detailed Description

Enumeration Type Documentation

◆ crm_adc_div_type

enum crm_adc_div_type

crm adc division

Enumerator
CRM_ADC_DIV_2 | apb2clk div2 to adcclk
CRM_ADC_DIV_4 | apb2clk div4 to adcclk
CRM_ADC_DIV_6 | apb2clk div6 to adcclk
CRM_ADC_DIV_8 | apb2clk div8 to adcclk
CRM_ADC_DIV_12 | apb2clk div12 to adcclk
CRM_ADC_DIV_16 | apb2clk div16 to adcclk

Definition at line 344 of file at32f413_crm.h.

◆ crm_ahb_div_type

enum crm_ahb_div_type

crm ahb division

Enumerator
CRM_AHB_DIV_1 | sclk div1 to ahbclk
CRM_AHB_DIV_2 | sclk div2 to ahbclk
CRM_AHB_DIV_4 | sclk div4 to ahbclk
CRM_AHB_DIV_8 | sclk div8 to ahbclk
CRM_AHB_DIV_16 | sclk div16 to ahbclk
CRM_AHB_DIV_64 | sclk div64 to ahbclk
CRM_AHB_DIV_128 | sclk div128 to ahbclk
CRM_AHB_DIV_256 | sclk div256 to ahbclk
CRM_AHB_DIV_512 | sclk div512 to ahbclk

Definition at line 304 of file at32f413_crm.h.

◆ crm_apb1_div_type

enum crm_apb1_div_type

crm apb1 division

Enumerator
CRM_APB1_DIV_1 | ahbclk div1 to apb1clk
CRM_APB1_DIV_2 | ahbclk div2 to apb1clk
CRM_APB1_DIV_4 | ahbclk div4 to apb1clk
CRM_APB1_DIV_8 | ahbclk div8 to apb1clk
CRM_APB1_DIV_16 | ahbclk div16 to apb1clk

Definition at line 320 of file at32f413_crm.h.

◆ crm_apb2_div_type

enum crm_apb2_div_type

crm apb2 division

Enumerator
CRM_APB2_DIV_1 | ahbclk div1 to apb2clk
CRM_APB2_DIV_2 | ahbclk div2 to apb2clk
CRM_APB2_DIV_4 | ahbclk div4 to apb2clk
CRM_APB2_DIV_8 | ahbclk div8 to apb2clk
CRM_APB2_DIV_16 | ahbclk div16 to apb2clk

Definition at line 332 of file at32f413_crm.h.

◆ crm_auto_step_mode_type

enum crm_auto_step_mode_type

crm auto step mode

Enumerator
CRM_AUTO_STEP_MODE_DISABLE | disable auto step mode
CRM_AUTO_STEP_MODE_ENABLE | enable auto step mode

Definition at line 434 of file at32f413_crm.h.

◆ crm_clkout_div_type

enum crm_clkout_div_type

crm clkout division

Enumerator
CRM_CLKOUT_DIV_1 | clkout div1
CRM_CLKOUT_DIV_2 | clkout div2
CRM_CLKOUT_DIV_4 | clkout div4
CRM_CLKOUT_DIV_8 | clkout div8
CRM_CLKOUT_DIV_16 | clkout div16
CRM_CLKOUT_DIV_64 | clkout div64
CRM_CLKOUT_DIV_128 | clkout div128
CRM_CLKOUT_DIV_256 | clkout div256
CRM_CLKOUT_DIV_512 | clkout div512

Definition at line 418 of file at32f413_crm.h.

◆ crm_clkout_select_type

enum crm_clkout_select_type

crm clkout select

Enumerator
CRM_CLKOUT_NOCLK | output no clock to clkout pin
CRM_CLKOUT_LICK | output low speed internal clock to clkout pin
CRM_CLKOUT_LEXT | output low speed external crystal to clkout pin
CRM_CLKOUT_SCLK | output system clock to clkout pin
CRM_CLKOUT_HICK | output high speed internal clock to clkout pin
CRM_CLKOUT_HEXT | output high speed external crystal to clkout pin
CRM_CLKOUT_PLL_DIV_2 | output phase locking loop clock div2 to clkout pin
CRM_CLKOUT_PLL_DIV_4 | output phase locking loop clock div4 to clkout pin
CRM_CLKOUT_USB | output usbclk to clkout pin
CRM_CLKOUT_ADC | output adcclk to clkout pin

Definition at line 401 of file at32f413_crm.h.

◆ crm_clock_source_type

enum crm_clock_source_type

crm clock source

Enumerator
CRM_CLOCK_SOURCE_HICK | high speed internal clock
CRM_CLOCK_SOURCE_HEXT | high speed external crystal
CRM_CLOCK_SOURCE_PLL | phase locking loop
CRM_CLOCK_SOURCE_LEXT | low speed external crystal
CRM_CLOCK_SOURCE_LICK | low speed internal clock

Definition at line 292 of file at32f413_crm.h.

◆ crm_hick_div_6_type

enum crm_hick_div_6_type

crm hick 48mhz division

Enumerator
CRM_HICK48_DIV6 | high speed internal clock (48 mhz) div6
CRM_HICK48_NODIV | high speed internal clock (48 mhz) no div

Definition at line 382 of file at32f413_crm.h.

◆ crm_hick_sclk_frequency_type

enum crm_hick_sclk_frequency_type

crm hick as system clock frequency select

Enumerator
CRM_HICK_SCLK_8MHZ | fixed 8 mhz when hick is selected as sclk
CRM_HICK_SCLK_48MHZ | 8 mhz or 48 mhz depend on hickdiv when hick is selected as sclk

Definition at line 461 of file at32f413_crm.h.

◆ crm_periph_clock_sleepmd_type

enum crm_periph_clock_sleepmd_type

crm periph clock in sleep mode

Enumerator
CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE | sram sleep mode periph clock
CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE | flash sleep mode periph clock

Definition at line 193 of file at32f413_crm.h.

◆ crm_periph_clock_type

enum crm_periph_clock_type

crm periph clock

Enumerator
CRM_DMA1_PERIPH_CLOCK | dma1 periph clock
CRM_DMA2_PERIPH_CLOCK | dma2 periph clock
CRM_CRC_PERIPH_CLOCK | crc periph clock
CRM_SDIO1_PERIPH_CLOCK | sdio1 periph clock
CRM_IOMUX_PERIPH_CLOCK | iomux periph clock
CRM_GPIOA_PERIPH_CLOCK | gpioa periph clock
CRM_GPIOB_PERIPH_CLOCK | gpiob periph clock
CRM_GPIOC_PERIPH_CLOCK | gpioc periph clock
CRM_GPIOD_PERIPH_CLOCK | gpiod periph clock
CRM_GPIOF_PERIPH_CLOCK | gpiof periph clock
CRM_ADC1_PERIPH_CLOCK | adc1 periph clock
CRM_ADC2_PERIPH_CLOCK | adc2 periph clock
CRM_TMR1_PERIPH_CLOCK | tmr1 periph clock
CRM_SPI1_PERIPH_CLOCK | spi1 periph clock
CRM_TMR8_PERIPH_CLOCK | tmr8 periph clock
CRM_USART1_PERIPH_CLOCK | usart1 periph clock
CRM_TMR9_PERIPH_CLOCK | tmr9 periph clock
CRM_TMR10_PERIPH_CLOCK | tmr10 periph clock
CRM_TMR11_PERIPH_CLOCK | tmr11 periph clock
CRM_ACC_PERIPH_CLOCK | acc periph clock
CRM_TMR2_PERIPH_CLOCK | tmr2 periph clock
CRM_TMR3_PERIPH_CLOCK | tmr3 periph clock
CRM_TMR4_PERIPH_CLOCK | tmr4 periph clock
CRM_TMR5_PERIPH_CLOCK | tmr5 periph clock
CRM_WWDT_PERIPH_CLOCK | wwdt periph clock
CRM_SPI2_PERIPH_CLOCK | spi2 periph clock
CRM_USART2_PERIPH_CLOCK | usart2 periph clock
CRM_USART3_PERIPH_CLOCK | usart3 periph clock
CRM_UART4_PERIPH_CLOCK | uart4 periph clock
CRM_UART5_PERIPH_CLOCK | uart5 periph clock
CRM_I2C1_PERIPH_CLOCK | i2c1 periph clock
CRM_I2C2_PERIPH_CLOCK | i2c2 periph clock
CRM_USB_PERIPH_CLOCK | usb periph clock
CRM_CAN1_PERIPH_CLOCK | can1 periph clock
CRM_BPR_PERIPH_CLOCK | bpr periph clock
CRM_PWC_PERIPH_CLOCK | pwc periph clock
CRM_CAN2_PERIPH_CLOCK | can2 periph clock

Definition at line 101 of file at32f413_crm.h.

◆ crm_periph_reset_type

enum crm_periph_reset_type

crm periph reset

Enumerator
CRM_IOMUX_PERIPH_RESET | iomux periph reset
CRM_EXINT_PERIPH_RESET | exint periph reset
CRM_GPIOA_PERIPH_RESET | gpioa periph reset
CRM_GPIOB_PERIPH_RESET | gpiob periph reset
CRM_GPIOC_PERIPH_RESET | gpioc periph reset
CRM_GPIOD_PERIPH_RESET | gpiod periph reset
CRM_GPIOF_PERIPH_RESET | gpiof periph reset
CRM_ADC1_PERIPH_RESET | adc1 periph reset
CRM_ADC2_PERIPH_RESET | adc2 periph reset
CRM_TMR1_PERIPH_RESET | tmr1 periph reset
CRM_SPI1_PERIPH_RESET | spi2 periph reset
CRM_TMR8_PERIPH_RESET | tmr8 periph reset
CRM_USART1_PERIPH_RESET | usart1 periph reset
CRM_TMR9_PERIPH_RESET | tmr9 periph reset
CRM_TMR10_PERIPH_RESET | tmr10 periph reset
CRM_TMR11_PERIPH_RESET | tmr11 periph reset
CRM_ACC_PERIPH_RESET | acc periph reset
CRM_TMR2_PERIPH_RESET | tmr2 periph reset
CRM_TMR3_PERIPH_RESET | tmr3 periph reset
CRM_TMR4_PERIPH_RESET | tmr4 periph reset
CRM_TMR5_PERIPH_RESET | tmr5 periph reset
CRM_WWDT_PERIPH_RESET | wwdt periph reset
CRM_SPI2_PERIPH_RESET | spi2 periph reset
CRM_USART2_PERIPH_RESET | usart2 periph reset
CRM_USART3_PERIPH_RESET | usart3 periph reset
CRM_UART4_PERIPH_RESET | uart4 periph reset
CRM_UART5_PERIPH_RESET | uart5 periph reset
CRM_I2C1_PERIPH_RESET | i2c1 periph reset
CRM_I2C2_PERIPH_RESET | i2c2 periph reset
CRM_USB_PERIPH_RESET | usb periph reset
CRM_CAN1_PERIPH_RESET | can1 periph reset
CRM_BPR_PERIPH_RESET | bpr periph reset
CRM_PWC_PERIPH_RESET | pwc periph reset
CRM_CAN2_PERIPH_RESET | can2 periph reset

Definition at line 149 of file at32f413_crm.h.

◆ crm_pll_clock_source_type

enum crm_pll_clock_source_type

crm pll clock source

Enumerator
CRM_PLL_SOURCE_HICK | high speed internal clock as pll reference clock source
CRM_PLL_SOURCE_HEXT | high speed external crystal as pll reference clock source
CRM_PLL_SOURCE_HEXT_DIV | high speed external crystal div as pll reference clock source

Definition at line 273 of file at32f413_crm.h.

◆ crm_pll_mult_type

enum crm_pll_mult_type

crm pll mult_x

Enumerator
CRM_PLL_MULT_2 | pll multiplication factor 2
CRM_PLL_MULT_3 | pll multiplication factor 3
CRM_PLL_MULT_4 | pll multiplication factor 4
CRM_PLL_MULT_5 | pll multiplication factor 5
CRM_PLL_MULT_6 | pll multiplication factor 6
CRM_PLL_MULT_7 | pll multiplication factor 7
CRM_PLL_MULT_8 | pll multiplication factor 8
CRM_PLL_MULT_9 | pll multiplication factor 9
CRM_PLL_MULT_10 | pll multiplication factor 10
CRM_PLL_MULT_11 | pll multiplication factor 11
CRM_PLL_MULT_12 | pll multiplication factor 12
CRM_PLL_MULT_13 | pll multiplication factor 13
CRM_PLL_MULT_14 | pll multiplication factor 14
CRM_PLL_MULT_15 | pll multiplication factor 15
CRM_PLL_MULT_16 | pll multiplication factor 16
CRM_PLL_MULT_17 | pll multiplication factor 17
CRM_PLL_MULT_18 | pll multiplication factor 18
CRM_PLL_MULT_19 | pll multiplication factor 19
CRM_PLL_MULT_20 | pll multiplication factor 20
CRM_PLL_MULT_21 | pll multiplication factor 21
CRM_PLL_MULT_22 | pll multiplication factor 22
CRM_PLL_MULT_23 | pll multiplication factor 23
CRM_PLL_MULT_24 | pll multiplication factor 24
CRM_PLL_MULT_25 | pll multiplication factor 25
CRM_PLL_MULT_26 | pll multiplication factor 26
CRM_PLL_MULT_27 | pll multiplication factor 27
CRM_PLL_MULT_28 | pll multiplication factor 28
CRM_PLL_MULT_29 | pll multiplication factor 29
CRM_PLL_MULT_30 | pll multiplication factor 30
CRM_PLL_MULT_31 | pll multiplication factor 31
CRM_PLL_MULT_32 | pll multiplication factor 32
CRM_PLL_MULT_33 | pll multiplication factor 33
CRM_PLL_MULT_34 | pll multiplication factor 34
CRM_PLL_MULT_35 | pll multiplication factor 35
CRM_PLL_MULT_36 | pll multiplication factor 36
CRM_PLL_MULT_37 | pll multiplication factor 37
CRM_PLL_MULT_38 | pll multiplication factor 38
CRM_PLL_MULT_39 | pll multiplication factor 39
CRM_PLL_MULT_40 | pll multiplication factor 40
CRM_PLL_MULT_41 | pll multiplication factor 41
CRM_PLL_MULT_42 | pll multiplication factor 42
CRM_PLL_MULT_43 | pll multiplication factor 43
CRM_PLL_MULT_44 | pll multiplication factor 44
CRM_PLL_MULT_45 | pll multiplication factor 45
CRM_PLL_MULT_46 | pll multiplication factor 46
CRM_PLL_MULT_47 | pll multiplication factor 47
CRM_PLL_MULT_48 | pll multiplication factor 48
CRM_PLL_MULT_49 | pll multiplication factor 49
CRM_PLL_MULT_50 | pll multiplication factor 50
CRM_PLL_MULT_51 | pll multiplication factor 51
CRM_PLL_MULT_52 | pll multiplication factor 52
CRM_PLL_MULT_53 | pll multiplication factor 53
CRM_PLL_MULT_54 | pll multiplication factor 54
CRM_PLL_MULT_55 | pll multiplication factor 55
CRM_PLL_MULT_56 | pll multiplication factor 56
CRM_PLL_MULT_57 | pll multiplication factor 57
CRM_PLL_MULT_58 | pll multiplication factor 58
CRM_PLL_MULT_59 | pll multiplication factor 59
CRM_PLL_MULT_60 | pll multiplication factor 60
CRM_PLL_MULT_61 | pll multiplication factor 61
CRM_PLL_MULT_62 | pll multiplication factor 62
CRM_PLL_MULT_63 | pll multiplication factor 63
CRM_PLL_MULT_64 | pll multiplication factor 64

Definition at line 203 of file at32f413_crm.h.

◆ crm_pll_output_range_type

enum crm_pll_output_range_type

crm pll clock output range

Enumerator
CRM_PLL_OUTPUT_RANGE_LE72MHZ | pll clock output range less than or equal to 72mhz
CRM_PLL_OUTPUT_RANGE_GT72MHZ | pll clock output range greater than 72mhz

Definition at line 283 of file at32f413_crm.h.

◆ crm_rtc_clock_type

enum crm_rtc_clock_type

crm rtc clock

Enumerator
CRM_RTC_CLOCK_NOCLK | no clock as rtc clock source
CRM_RTC_CLOCK_LEXT | low speed external crystal as rtc clock source
CRM_RTC_CLOCK_LICK | low speed internal clock as rtc clock source
CRM_RTC_CLOCK_HEXT_DIV | high speed external crystal div as rtc clock source

Definition at line 371 of file at32f413_crm.h.

◆ crm_sclk_type

enum crm_sclk_type

crm sclk select

Enumerator
CRM_SCLK_HICK | select high speed internal clock as sclk
CRM_SCLK_HEXT | select high speed external crystal as sclk
CRM_SCLK_PLL | select phase locking loop clock as sclk

Definition at line 391 of file at32f413_crm.h.

◆ crm_usb_clock_source_type

enum crm_usb_clock_source_type

crm usb 48 mhz clock source select

Enumerator
CRM_USB_CLOCK_SOURCE_PLL | select phase locking loop clock as usb clock source
CRM_USB_CLOCK_SOURCE_HICK | select high speed internal clock as usb clock source

Definition at line 452 of file at32f413_crm.h.

◆ crm_usb_div_type

enum crm_usb_div_type

crm usb division

Enumerator
CRM_USB_DIV_1_5 | pllclk div1.5 to usbclk
CRM_USB_DIV_1 | pllclk div1 to usbclk
CRM_USB_DIV_2_5 | pllclk div2.5 to usbclk
CRM_USB_DIV_2 | pllclk div2 to usbclk
CRM_USB_DIV_3_5 | pllclk div3.5 to usbclk
CRM_USB_DIV_3 | pllclk div3 to usbclk
CRM_USB_DIV_4 | pllclk div4 to usbclk

Definition at line 357 of file at32f413_crm.h.

◆ crm_usb_int_map_type

enum crm_usb_int_map_type

crm usbdev interrupt remap

Enumerator
CRM_USB_INT19_INT20 | usb high and low priority irq numer use 19 and 20
CRM_USB_INT73_INT74 | usb high and low priority irq numer use 73 and 74

Definition at line 443 of file at32f413_crm.h.


AT32F413 Firmwary Library: crm_clocks_freq_type Struct Reference

Data Fields
crm_clocks_freq_type Struct Reference
AT32F413_periph_driver » CRM » CRM_exported_types

crm clocks freqency structure More...

#include <at32f413_crm.h>

Data Fields

uint32_t | sclk_freq
uint32_t | ahb_freq
uint32_t | apb2_freq
uint32_t | apb1_freq
uint32_t | adc_freq

Detailed Description

crm clocks freqency structure

Definition at line 470 of file at32f413_crm.h.

Field Documentation

◆ adc_freq

uint32_t crm_clocks_freq_type::adc_freq

adc clock frequency

Definition at line 476 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get().

◆ ahb_freq

uint32_t crm_clocks_freq_type::ahb_freq

ahb bus clock frequency

Definition at line 473 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get(), main(), and tmr_init().

◆ apb1_freq

uint32_t crm_clocks_freq_type::apb1_freq

apb1 bus clock frequency

Definition at line 475 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get(), i2c_init(), main(), usart_configuration(), and usart_init().

◆ apb2_freq

uint32_t crm_clocks_freq_type::apb2_freq

apb2 bus clock frequency

Definition at line 474 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get(), and usart_init().

◆ sclk_freq

uint32_t crm_clocks_freq_type::sclk_freq

system clock frequency

Definition at line 472 of file at32f413_crm.h.

Referenced by crm_clocks_freq_get(), i2s_init(), main(), systick_configuration(), tmr1_config(), tmr2_config(), and TMR3_GLOBAL_IRQHandler().

The documentation for this struct was generated from the following file:
  • at32f413_crm.h


AT32F413 Firmwary Library: crm_type Struct Reference

Data Fields
crm_type Struct Reference
AT32F413_periph_driver » CRM » CRM_exported_types

type define crm register all More...

#include <at32f413_crm.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t hicken: 1
__IO uint32_t hickstbl: 1
__IO uint32_t hicktrim: 6
__IO uint32_t hickcal: 8
__IO uint32_t hexten: 1
__IO uint32_t hextstbl: 1
__IO uint32_t hextbyps: 1
__IO uint32_t cfden: 1
__IO uint32_t reserved1: 4
__IO uint32_t pllen: 1
__IO uint32_t pllstbl: 1
__IO uint32_t reserved2: 6
} ctrl_bit
};
crm ctrl register, offset:0x00 More...
union {
__IO uint32_t cfg
struct {
__IO uint32_t sclksel: 2
__IO uint32_t sclksts: 2
__IO uint32_t ahbdiv: 4
__IO uint32_t apb1div: 3
__IO uint32_t apb2div: 3
__IO uint32_t adcdiv_l: 2
__IO uint32_t pllrcs: 1
__IO uint32_t pllhextdiv: 1
__IO uint32_t pllmult_l: 4
__IO uint32_t usbdiv_l: 2
__IO uint32_t clkout_sel: 3
__IO uint32_t usbdiv_h: 1
__IO uint32_t adcdiv_h: 1
__IO uint32_t pllmult_h: 2
__IO uint32_t pllrange: 1
} cfg_bit
};
crm cfg register, offset:0x04 More...
union {
__IO uint32_t clkint
struct {
__IO uint32_t lickstblf: 1
__IO uint32_t lextstblf: 1
__IO uint32_t hickstblf: 1
__IO uint32_t hextstblf: 1
__IO uint32_t pllstblf: 1
__IO uint32_t reserved1: 2
__IO uint32_t cfdf: 1
__IO uint32_t lickstblien: 1
__IO uint32_t lextstblien: 1
__IO uint32_t hickstblien: 1
__IO uint32_t hextstblien: 1
__IO uint32_t pllstblien: 1
__IO uint32_t reserved2: 3
__IO uint32_t lickstblfc: 1
__IO uint32_t lextstblfc: 1
__IO uint32_t hickstblfc: 1
__IO uint32_t hextstblfc: 1
__IO uint32_t pllstblfc: 1
__IO uint32_t reserved3: 2
__IO uint32_t cfdfc: 1
__IO uint32_t reserved4: 8
} clkint_bit
};
crm clkint register, offset:0x08 More...
union {
__IO uint32_t apb2rst
struct {
__IO uint32_t iomuxrst: 1
__IO uint32_t exintrst: 1
__IO uint32_t gpioarst: 1
__IO uint32_t gpiobrst: 1
__IO uint32_t gpiocrst: 1
__IO uint32_t gpiodrst: 1
__IO uint32_t reserved1: 1
__IO uint32_t gpioerst: 1
__IO uint32_t reserved2: 1
__IO uint32_t adc1rst: 1
__IO uint32_t adc2rst: 1
__IO uint32_t tmr1rst: 1
__IO uint32_t spi1rst: 1
__IO uint32_t tmr8rst: 1
__IO uint32_t usart1rst: 1
__IO uint32_t reserved3: 4
__IO uint32_t tmr9rst: 1
__IO uint32_t tmr10rst: 1
__IO uint32_t tmr11rst: 1
__IO uint32_t accrst: 1
__IO uint32_t reserved4: 9
} apb2rst_bit
};
crm apb2rst register, offset:0x0C More...
union {
__IO uint32_t apb1rst
struct {
__IO uint32_t tmr2rst: 1
__IO uint32_t tmr3rst: 1
__IO uint32_t tmr4rst: 1
__IO uint32_t tmr5rst: 1
__IO uint32_t reserved1: 7
__IO uint32_t wwdtrst: 1
__IO uint32_t reserved2: 2
__IO uint32_t spi2rst: 1
__IO uint32_t reserved3: 2
__IO uint32_t usart2rst: 1
__IO uint32_t usart3rst: 1
__IO uint32_t uart4rst: 1
__IO uint32_t uart5rst: 1
__IO uint32_t i2c1rst: 1
__IO uint32_t i2c2rst: 1
__IO uint32_t usbrst: 1
__IO uint32_t reserved4: 1
__IO uint32_t can1rst: 1
__IO uint32_t reserved5: 1
__IO uint32_t bprrst: 1
__IO uint32_t pwcrst: 1
__IO uint32_t reserved6: 2
__IO uint32_t can2rst: 1
} apb1rst_bit
};
crm apb1rst register, offset:0x10 More...
union {
__IO uint32_t ahben
struct {
__IO uint32_t dma1en: 1
__IO uint32_t dma2en: 1
__IO uint32_t sramen: 1
__IO uint32_t reserved1: 1
__IO uint32_t flashen: 1
__IO uint32_t reserved2: 1
__IO uint32_t crcen: 1
__IO uint32_t reserved3: 3
__IO uint32_t sdio1en: 1
__IO uint32_t reserved5: 21
} ahben_bit
};
crm ahben register, offset:0x14 More...
union {
__IO uint32_t apb2en
struct {
__IO uint32_t iomuxen: 1
__IO uint32_t reserved1: 1
__IO uint32_t gpioaen: 1
__IO uint32_t gpioben: 1
__IO uint32_t gpiocen: 1
__IO uint32_t gpioden: 1
__IO uint32_t reserved2: 1
__IO uint32_t gpiofen: 1
__IO uint32_t reserved3: 1
__IO uint32_t adc1en: 1
__IO uint32_t adc2en: 1
__IO uint32_t tmr1en: 1
__IO uint32_t spi1en: 1
__IO uint32_t tmr8en: 1
__IO uint32_t usart1en: 1
__IO uint32_t reserved4: 4
__IO uint32_t tmr9en: 1
__IO uint32_t tmr10en: 1
__IO uint32_t tmr11en: 1
__IO uint32_t accen: 1
__IO uint32_t reserved5: 9
} apb2en_bit
};
crm apb2en register, offset:0x18 More...
union {
__IO uint32_t apb1en
struct {
__IO uint32_t tmr2en: 1
__IO uint32_t tmr3en: 1
__IO uint32_t tmr4en: 1
__IO uint32_t tmr5en: 1
__IO uint32_t reserved1: 7
__IO uint32_t wwdten: 1
__IO uint32_t reserved2: 2
__IO uint32_t spi2en: 1
__IO uint32_t reserved3: 2
__IO uint32_t usart2en: 1
__IO uint32_t usart3en: 1
__IO uint32_t uart4en: 1
__IO uint32_t uart5en: 1
__IO uint32_t i2c1en: 1
__IO uint32_t i2c2en: 1
__IO uint32_t usben: 1
__IO uint32_t reserved4: 1
__IO uint32_t can1en: 1
__IO uint32_t reserved5: 1
__IO uint32_t bpren: 1
__IO uint32_t pwcen: 1
__IO uint32_t reserved6: 2
__IO uint32_t can2en: 1
} apb1en_bit
};
crm apb1en register, offset:0x1C More...
union {
__IO uint32_t bpdc
struct {
__IO uint32_t lexten: 1
__IO uint32_t lextstbl: 1
__IO uint32_t lextbyps: 1
__IO uint32_t reserved1: 5
__IO uint32_t rtcsel: 2
__IO uint32_t reserved2: 5
__IO uint32_t rtcen: 1
__IO uint32_t bpdrst: 1
__IO uint32_t reserved3: 15
} bpdc_bit
};
crm bpdc register, offset:0x20 More...
union {
__IO uint32_t ctrlsts
struct {
__IO uint32_t licken: 1
__IO uint32_t lickstbl: 1
__IO uint32_t reserved1: 22
__IO uint32_t rstfc: 1
__IO uint32_t reserved2: 1
__IO uint32_t nrstf: 1
__IO uint32_t porrstf: 1
__IO uint32_t swrstf: 1
__IO uint32_t wdtrstf: 1
__IO uint32_t wwdtrstf: 1
__IO uint32_t lprstf: 1
} ctrlsts_bit
};
crm ctrlsts register, offset:0x24 More...
union {
__IO uint32_t misc1
struct {
__IO uint32_t hickcal_key: 8
__IO uint32_t reserved1: 8
__IO uint32_t clkout_sel: 1
__IO uint32_t reserved2: 7
__IO uint32_t usbbufs: 1
__IO uint32_t hickdiv: 1
__IO uint32_t reserved3: 2
__IO uint32_t clkoutdiv: 4
} misc1_bit
};
crm misc1 register, offset:0x30 More...
union {
__IO uint32_t misc2
struct {
__IO uint32_t reserved1: 16
__IO uint32_t clk_to_tmr: 1
__IO uint32_t reserved2: 15
} misc2_bit
};
crm misc2 register, offset:0x50 More...
union {
__IO uint32_t misc3
struct {
__IO uint32_t reserved1: 4
__IO uint32_t auto_step_en: 2
__IO uint32_t reserved2: 2
__IO uint32_t hick_to_usb: 1
__IO uint32_t hick_to_sclk: 1
__IO uint32_t reserved3: 22
} misc3_bit
};
crm misc3 register, offset:0x54 More...
union {
__IO uint32_t intmap
struct {
__IO uint32_t usbintmap: 1
__IO uint32_t reserved1: 31
} intmap_bit
};
crm intmap register, offset:0x5C More...

Detailed Description

type define crm register all

Definition at line 482 of file at32f413_crm.h.

Field Documentation

◆

union { ... } crm_type::@289

crm ctrl register, offset:0x00

◆

union { ... } crm_type::@291

crm cfg register, offset:0x04

◆

union { ... } crm_type::@293

crm clkint register, offset:0x08

◆

union { ... } crm_type::@295

crm apb2rst register, offset:0x0C

◆

union { ... } crm_type::@297

crm apb1rst register, offset:0x10

◆

union { ... } crm_type::@299

crm ahben register, offset:0x14

◆

union { ... } crm_type::@301

crm apb2en register, offset:0x18

◆

union { ... } crm_type::@303

crm apb1en register, offset:0x1C

◆

union { ... } crm_type::@305

crm bpdc register, offset:0x20

◆

union { ... } crm_type::@307

crm ctrlsts register, offset:0x24

◆

union { ... } crm_type::@309

crm misc1 register, offset:0x30

◆

union { ... } crm_type::@311

crm misc2 register, offset:0x50

◆

union { ... } crm_type::@313

crm misc3 register, offset:0x54

◆

union { ... } crm_type::@315

crm intmap register, offset:0x5C

◆ accen

__IO uint32_t crm_type::accen

Definition at line 679 of file at32f413_crm.h.

◆ accrst

__IO uint32_t crm_type::accrst

Definition at line 592 of file at32f413_crm.h.

◆ adc1en

__IO uint32_t crm_type::adc1en

Definition at line 669 of file at32f413_crm.h.

◆ adc1rst

__IO uint32_t crm_type::adc1rst

Definition at line 582 of file at32f413_crm.h.

◆ adc2en

__IO uint32_t crm_type::adc2en

Definition at line 670 of file at32f413_crm.h.

◆ adc2rst

__IO uint32_t crm_type::adc2rst

Definition at line 583 of file at32f413_crm.h.

◆ adcdiv_h

__IO uint32_t crm_type::adcdiv_h

Definition at line 527 of file at32f413_crm.h.

◆ adcdiv_l

__IO uint32_t crm_type::adcdiv_l

Definition at line 520 of file at32f413_crm.h.

◆ ahbdiv

__IO uint32_t crm_type::ahbdiv

Definition at line 517 of file at32f413_crm.h.

◆ ahben

__IO uint32_t crm_type::ahben

Definition at line 636 of file at32f413_crm.h.

◆

struct { ... } crm_type::ahben_bit

◆ apb1div

__IO uint32_t crm_type::apb1div

Definition at line 518 of file at32f413_crm.h.

◆ apb1en

__IO uint32_t crm_type::apb1en

Definition at line 689 of file at32f413_crm.h.

◆

struct { ... } crm_type::apb1en_bit

◆ apb1rst

__IO uint32_t crm_type::apb1rst

Definition at line 602 of file at32f413_crm.h.

◆

struct { ... } crm_type::apb1rst_bit

◆ apb2div

__IO uint32_t crm_type::apb2div

Definition at line 519 of file at32f413_crm.h.

◆ apb2en

__IO uint32_t crm_type::apb2en

Definition at line 657 of file at32f413_crm.h.

◆

struct { ... } crm_type::apb2en_bit

◆ apb2rst

__IO uint32_t crm_type::apb2rst

Definition at line 570 of file at32f413_crm.h.

◆

struct { ... } crm_type::apb2rst_bit

◆ auto_step_en

__IO uint32_t crm_type::auto_step_en

Definition at line 812 of file at32f413_crm.h.

◆ bpdc

__IO uint32_t crm_type::bpdc

Definition at line 723 of file at32f413_crm.h.

◆

struct { ... } crm_type::bpdc_bit

◆ bpdrst

__IO uint32_t crm_type::bpdrst

Definition at line 733 of file at32f413_crm.h.

◆ bpren

__IO uint32_t crm_type::bpren

Definition at line 711 of file at32f413_crm.h.

◆ bprrst

__IO uint32_t crm_type::bprrst

Definition at line 624 of file at32f413_crm.h.

◆ can1en

__IO uint32_t crm_type::can1en

Definition at line 709 of file at32f413_crm.h.

◆ can1rst

__IO uint32_t crm_type::can1rst

Definition at line 622 of file at32f413_crm.h.

◆ can2en

__IO uint32_t crm_type::can2en

Definition at line 714 of file at32f413_crm.h.

◆ can2rst

__IO uint32_t crm_type::can2rst

Definition at line 627 of file at32f413_crm.h.

◆ cfden

__IO uint32_t crm_type::cfden

Definition at line 499 of file at32f413_crm.h.

◆ cfdf

__IO uint32_t crm_type::cfdf

Definition at line 547 of file at32f413_crm.h.

◆ cfdfc

__IO uint32_t crm_type::cfdfc

Definition at line 560 of file at32f413_crm.h.

◆ cfg

__IO uint32_t crm_type::cfg

Definition at line 512 of file at32f413_crm.h.

◆

struct { ... } crm_type::cfg_bit

◆ clk_to_tmr

__IO uint32_t crm_type::clk_to_tmr

Definition at line 798 of file at32f413_crm.h.

◆ clkint

__IO uint32_t crm_type::clkint

Definition at line 538 of file at32f413_crm.h.

◆

struct { ... } crm_type::clkint_bit

◆ clkout_sel

__IO uint32_t crm_type::clkout_sel

Definition at line 525 of file at32f413_crm.h.

◆ clkoutdiv

__IO uint32_t crm_type::clkoutdiv

Definition at line 780 of file at32f413_crm.h.

◆ crcen

__IO uint32_t crm_type::crcen

Definition at line 645 of file at32f413_crm.h.

◆ ctrl

__IO uint32_t crm_type::ctrl

Definition at line 489 of file at32f413_crm.h.

◆

struct { ... } crm_type::ctrl_bit

◆ ctrlsts

__IO uint32_t crm_type::ctrlsts

Definition at line 743 of file at32f413_crm.h.

◆

struct { ... } crm_type::ctrlsts_bit

◆ dma1en

__IO uint32_t crm_type::dma1en

Definition at line 639 of file at32f413_crm.h.

◆ dma2en

__IO uint32_t crm_type::dma2en

Definition at line 640 of file at32f413_crm.h.

◆ exintrst

__IO uint32_t crm_type::exintrst

Definition at line 574 of file at32f413_crm.h.

◆ flashen

__IO uint32_t crm_type::flashen

Definition at line 643 of file at32f413_crm.h.

◆ gpioaen

__IO uint32_t crm_type::gpioaen

Definition at line 662 of file at32f413_crm.h.

◆ gpioarst

__IO uint32_t crm_type::gpioarst

Definition at line 575 of file at32f413_crm.h.

◆ gpioben

__IO uint32_t crm_type::gpioben

Definition at line 663 of file at32f413_crm.h.

◆ gpiobrst

__IO uint32_t crm_type::gpiobrst

Definition at line 576 of file at32f413_crm.h.

◆ gpiocen

__IO uint32_t crm_type::gpiocen

Definition at line 664 of file at32f413_crm.h.

◆ gpiocrst

__IO uint32_t crm_type::gpiocrst

Definition at line 577 of file at32f413_crm.h.

◆ gpioden

__IO uint32_t crm_type::gpioden

Definition at line 665 of file at32f413_crm.h.

◆ gpiodrst

__IO uint32_t crm_type::gpiodrst

Definition at line 578 of file at32f413_crm.h.

◆ gpioerst

__IO uint32_t crm_type::gpioerst

Definition at line 580 of file at32f413_crm.h.

◆ gpiofen

__IO uint32_t crm_type::gpiofen

Definition at line 667 of file at32f413_crm.h.

◆ hextbyps

__IO uint32_t crm_type::hextbyps

Definition at line 498 of file at32f413_crm.h.

◆ hexten

__IO uint32_t crm_type::hexten

Definition at line 496 of file at32f413_crm.h.

◆ hextstbl

__IO uint32_t crm_type::hextstbl

Definition at line 497 of file at32f413_crm.h.

◆ hextstblf

__IO uint32_t crm_type::hextstblf

Definition at line 544 of file at32f413_crm.h.

◆ hextstblfc

__IO uint32_t crm_type::hextstblfc

Definition at line 557 of file at32f413_crm.h.

◆ hextstblien

__IO uint32_t crm_type::hextstblien

Definition at line 551 of file at32f413_crm.h.

◆ hick_to_sclk

__IO uint32_t crm_type::hick_to_sclk

Definition at line 815 of file at32f413_crm.h.

◆ hick_to_usb

__IO uint32_t crm_type::hick_to_usb

Definition at line 814 of file at32f413_crm.h.

◆ hickcal

__IO uint32_t crm_type::hickcal

Definition at line 495 of file at32f413_crm.h.

◆ hickcal_key

__IO uint32_t crm_type::hickcal_key

Definition at line 773 of file at32f413_crm.h.

◆ hickdiv

__IO uint32_t crm_type::hickdiv

Definition at line 778 of file at32f413_crm.h.

◆ hicken

__IO uint32_t crm_type::hicken

Definition at line 492 of file at32f413_crm.h.

◆ hickstbl

__IO uint32_t crm_type::hickstbl

Definition at line 493 of file at32f413_crm.h.

◆ hickstblf

__IO uint32_t crm_type::hickstblf

Definition at line 543 of file at32f413_crm.h.

◆ hickstblfc

__IO uint32_t crm_type::hickstblfc

Definition at line 556 of file at32f413_crm.h.

◆ hickstblien

__IO uint32_t crm_type::hickstblien

Definition at line 550 of file at32f413_crm.h.

◆ hicktrim

__IO uint32_t crm_type::hicktrim

Definition at line 494 of file at32f413_crm.h.

◆ i2c1en

__IO uint32_t crm_type::i2c1en

Definition at line 705 of file at32f413_crm.h.

◆ i2c1rst

__IO uint32_t crm_type::i2c1rst

Definition at line 618 of file at32f413_crm.h.

◆ i2c2en

__IO uint32_t crm_type::i2c2en

Definition at line 706 of file at32f413_crm.h.

◆ i2c2rst

__IO uint32_t crm_type::i2c2rst

Definition at line 619 of file at32f413_crm.h.

◆ intmap

__IO uint32_t crm_type::intmap

Definition at line 830 of file at32f413_crm.h.

◆

struct { ... } crm_type::intmap_bit

◆ iomuxen

__IO uint32_t crm_type::iomuxen

Definition at line 660 of file at32f413_crm.h.

◆ iomuxrst

__IO uint32_t crm_type::iomuxrst

Definition at line 573 of file at32f413_crm.h.

◆ lextbyps

__IO uint32_t crm_type::lextbyps

Definition at line 728 of file at32f413_crm.h.

◆ lexten

__IO uint32_t crm_type::lexten

Definition at line 726 of file at32f413_crm.h.

◆ lextstbl

__IO uint32_t crm_type::lextstbl

Definition at line 727 of file at32f413_crm.h.

◆ lextstblf

__IO uint32_t crm_type::lextstblf

Definition at line 542 of file at32f413_crm.h.

◆ lextstblfc

__IO uint32_t crm_type::lextstblfc

Definition at line 555 of file at32f413_crm.h.

◆ lextstblien

__IO uint32_t crm_type::lextstblien

Definition at line 549 of file at32f413_crm.h.

◆ licken

__IO uint32_t crm_type::licken

Definition at line 746 of file at32f413_crm.h.

◆ lickstbl

__IO uint32_t crm_type::lickstbl

Definition at line 747 of file at32f413_crm.h.

◆ lickstblf

__IO uint32_t crm_type::lickstblf

Definition at line 541 of file at32f413_crm.h.

◆ lickstblfc

__IO uint32_t crm_type::lickstblfc

Definition at line 554 of file at32f413_crm.h.

◆ lickstblien

__IO uint32_t crm_type::lickstblien

Definition at line 548 of file at32f413_crm.h.

◆ lprstf

__IO uint32_t crm_type::lprstf

Definition at line 756 of file at32f413_crm.h.

◆ misc1

__IO uint32_t crm_type::misc1

Definition at line 770 of file at32f413_crm.h.

◆

struct { ... } crm_type::misc1_bit

◆ misc2

__IO uint32_t crm_type::misc2

Definition at line 794 of file at32f413_crm.h.

◆

struct { ... } crm_type::misc2_bit

◆ misc3

__IO uint32_t crm_type::misc3

Definition at line 808 of file at32f413_crm.h.

◆

struct { ... } crm_type::misc3_bit

◆ nrstf

__IO uint32_t crm_type::nrstf

Definition at line 751 of file at32f413_crm.h.

◆ pllen

__IO uint32_t crm_type::pllen

Definition at line 501 of file at32f413_crm.h.

◆ pllhextdiv

__IO uint32_t crm_type::pllhextdiv

Definition at line 522 of file at32f413_crm.h.

◆ pllmult_h

__IO uint32_t crm_type::pllmult_h

Definition at line 528 of file at32f413_crm.h.

◆ pllmult_l

__IO uint32_t crm_type::pllmult_l

Definition at line 523 of file at32f413_crm.h.

◆ pllrange

__IO uint32_t crm_type::pllrange

Definition at line 529 of file at32f413_crm.h.

◆ pllrcs

__IO uint32_t crm_type::pllrcs

Definition at line 521 of file at32f413_crm.h.

◆ pllstbl

__IO uint32_t crm_type::pllstbl

Definition at line 502 of file at32f413_crm.h.

◆ pllstblf

__IO uint32_t crm_type::pllstblf

Definition at line 545 of file at32f413_crm.h.

◆ pllstblfc

__IO uint32_t crm_type::pllstblfc

Definition at line 558 of file at32f413_crm.h.

◆ pllstblien

__IO uint32_t crm_type::pllstblien

Definition at line 552 of file at32f413_crm.h.

◆ porrstf

__IO uint32_t crm_type::porrstf

Definition at line 752 of file at32f413_crm.h.

◆ pwcen

__IO uint32_t crm_type::pwcen

Definition at line 712 of file at32f413_crm.h.

◆ pwcrst

__IO uint32_t crm_type::pwcrst

Definition at line 625 of file at32f413_crm.h.

◆ reserved1

__IO uint32_t crm_type::reserved1

crm reserved1 register, offset:0x28~0x2C

Definition at line 500 of file at32f413_crm.h.

◆ reserved2

__IO uint32_t crm_type::reserved2

crm reserved2 register, offset:0x4C~0x34

Definition at line 503 of file at32f413_crm.h.

◆ reserved3

__IO uint32_t crm_type::reserved3

crm reserved3 register, offset:0x58

Definition at line 559 of file at32f413_crm.h.

◆ reserved4

__IO uint32_t crm_type::reserved4

Definition at line 561 of file at32f413_crm.h.

◆ reserved5

__IO uint32_t crm_type::reserved5

Definition at line 623 of file at32f413_crm.h.

◆ reserved6

__IO uint32_t crm_type::reserved6

Definition at line 626 of file at32f413_crm.h.

◆ rstfc

__IO uint32_t crm_type::rstfc

Definition at line 749 of file at32f413_crm.h.

◆ rtcen

__IO uint32_t crm_type::rtcen

Definition at line 732 of file at32f413_crm.h.

◆ rtcsel

__IO uint32_t crm_type::rtcsel

Definition at line 730 of file at32f413_crm.h.

◆ sclksel

__IO uint32_t crm_type::sclksel

Definition at line 515 of file at32f413_crm.h.

◆ sclksts

__IO uint32_t crm_type::sclksts

Definition at line 516 of file at32f413_crm.h.

◆ sdio1en

__IO uint32_t crm_type::sdio1en

Definition at line 647 of file at32f413_crm.h.

◆ spi1en

__IO uint32_t crm_type::spi1en

Definition at line 672 of file at32f413_crm.h.

◆ spi1rst

__IO uint32_t crm_type::spi1rst

Definition at line 585 of file at32f413_crm.h.

◆ spi2en

__IO uint32_t crm_type::spi2en

Definition at line 699 of file at32f413_crm.h.

◆ spi2rst

__IO uint32_t crm_type::spi2rst

Definition at line 612 of file at32f413_crm.h.

◆ sramen

__IO uint32_t crm_type::sramen

Definition at line 641 of file at32f413_crm.h.

◆ swrstf

__IO uint32_t crm_type::swrstf

Definition at line 753 of file at32f413_crm.h.

◆ tmr10en

__IO uint32_t crm_type::tmr10en

Definition at line 677 of file at32f413_crm.h.

◆ tmr10rst

__IO uint32_t crm_type::tmr10rst

Definition at line 590 of file at32f413_crm.h.

◆ tmr11en

__IO uint32_t crm_type::tmr11en

Definition at line 678 of file at32f413_crm.h.

◆ tmr11rst

__IO uint32_t crm_type::tmr11rst

Definition at line 591 of file at32f413_crm.h.

◆ tmr1en

__IO uint32_t crm_type::tmr1en

Definition at line 671 of file at32f413_crm.h.

◆ tmr1rst

__IO uint32_t crm_type::tmr1rst

Definition at line 584 of file at32f413_crm.h.

◆ tmr2en

__IO uint32_t crm_type::tmr2en

Definition at line 692 of file at32f413_crm.h.

◆ tmr2rst

__IO uint32_t crm_type::tmr2rst

Definition at line 605 of file at32f413_crm.h.

◆ tmr3en

__IO uint32_t crm_type::tmr3en

Definition at line 693 of file at32f413_crm.h.

◆ tmr3rst

__IO uint32_t crm_type::tmr3rst

Definition at line 606 of file at32f413_crm.h.

◆ tmr4en

__IO uint32_t crm_type::tmr4en

Definition at line 694 of file at32f413_crm.h.

◆ tmr4rst

__IO uint32_t crm_type::tmr4rst

Definition at line 607 of file at32f413_crm.h.

◆ tmr5en

__IO uint32_t crm_type::tmr5en

Definition at line 695 of file at32f413_crm.h.

◆ tmr5rst

__IO uint32_t crm_type::tmr5rst

Definition at line 608 of file at32f413_crm.h.

◆ tmr8en

__IO uint32_t crm_type::tmr8en

Definition at line 673 of file at32f413_crm.h.

◆ tmr8rst

__IO uint32_t crm_type::tmr8rst

Definition at line 586 of file at32f413_crm.h.

◆ tmr9en

__IO uint32_t crm_type::tmr9en

Definition at line 676 of file at32f413_crm.h.

◆ tmr9rst

__IO uint32_t crm_type::tmr9rst

Definition at line 589 of file at32f413_crm.h.

◆ uart4en

__IO uint32_t crm_type::uart4en

Definition at line 703 of file at32f413_crm.h.

◆ uart4rst

__IO uint32_t crm_type::uart4rst

Definition at line 616 of file at32f413_crm.h.

◆ uart5en

__IO uint32_t crm_type::uart5en

Definition at line 704 of file at32f413_crm.h.

◆ uart5rst

__IO uint32_t crm_type::uart5rst

Definition at line 617 of file at32f413_crm.h.

◆ usart1en

__IO uint32_t crm_type::usart1en

Definition at line 674 of file at32f413_crm.h.

◆ usart1rst

__IO uint32_t crm_type::usart1rst

Definition at line 587 of file at32f413_crm.h.

◆ usart2en

__IO uint32_t crm_type::usart2en

Definition at line 701 of file at32f413_crm.h.

◆ usart2rst

__IO uint32_t crm_type::usart2rst

Definition at line 614 of file at32f413_crm.h.

◆ usart3en

__IO uint32_t crm_type::usart3en

Definition at line 702 of file at32f413_crm.h.

◆ usart3rst

__IO uint32_t crm_type::usart3rst

Definition at line 615 of file at32f413_crm.h.

◆ usbbufs

__IO uint32_t crm_type::usbbufs

Definition at line 777 of file at32f413_crm.h.

◆ usbdiv_h

__IO uint32_t crm_type::usbdiv_h

Definition at line 526 of file at32f413_crm.h.

◆ usbdiv_l

__IO uint32_t crm_type::usbdiv_l

Definition at line 524 of file at32f413_crm.h.

◆ usben

__IO uint32_t crm_type::usben

Definition at line 707 of file at32f413_crm.h.

◆ usbintmap

__IO uint32_t crm_type::usbintmap

Definition at line 833 of file at32f413_crm.h.

◆ usbrst

__IO uint32_t crm_type::usbrst

Definition at line 620 of file at32f413_crm.h.

◆ wdtrstf

__IO uint32_t crm_type::wdtrstf

Definition at line 754 of file at32f413_crm.h.

◆ wwdten

__IO uint32_t crm_type::wwdten

Definition at line 697 of file at32f413_crm.h.

◆ wwdtrst

__IO uint32_t crm_type::wwdtrst

Definition at line 610 of file at32f413_crm.h.

◆ wwdtrstf

__IO uint32_t crm_type::wwdtrstf

Definition at line 755 of file at32f413_crm.h.

The documentation for this struct was generated from the following file:
  • at32f413_crm.h


AT32F413 Firmwary Library: CRM_exported_functions

Functions
CRM_exported_functions
AT32F413_periph_driver » CRM

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_sleep_mode_clock_enable (crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_rtc_clock_select (crm_rtc_clock_type value)
select rtc clock More...
void | crm_rtc_clock_enable (confirm_state new_state)
enable or disable rtc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_adc_clock_div_set (crm_adc_div_type div_value)
set crm adc division More...
void | crm_usb_clock_div_set (crm_usb_div_type div_value)
set crm usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out_set (crm_clkout_select_type clkout)
set crm clkout More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_usb_interrupt_remapping_set (crm_usb_int_map_type int_remap)
usbdev interrupt remapping control More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_clkout_div_set (crm_clkout_div_type clkout_div)
set crm clkout division More...

Detailed Description

Function Documentation

◆ crm_adc_clock_div_set()

void crm_adc_clock_div_set ( crm_adc_div_type div_value )

set crm adc division

Parameters
value this parameter can be one of the following values:
  • CRM_ADC_DIV_2
  • CRM_ADC_DIV_4
  • CRM_ADC_DIV_6
  • CRM_ADC_DIV_8
  • CRM_ADC_DIV_12
  • CRM_ADC_DIV_16
Return values
none

Definition at line 455 of file at32f413_crm.c.

Referenced by adc_config().

◆ crm_ahb_div_set()

void crm_ahb_div_set ( crm_ahb_div_type value )

set crm ahb division

Parameters
value this parameter can be one of the following values:
  • CRM_AHB_DIV_1
  • CRM_AHB_DIV_2
  • CRM_AHB_DIV_4
  • CRM_AHB_DIV_8
  • CRM_AHB_DIV_16
  • CRM_AHB_DIV_64
  • CRM_AHB_DIV_128
  • CRM_AHB_DIV_256
  • CRM_AHB_DIV_512
Return values
none

Definition at line 406 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_apb1_div_set()

void crm_apb1_div_set ( crm_apb1_div_type value )

set crm apb1 division

Parameters
value this parameter can be one of the following values:
  • CRM_APB1_DIV_1
  • CRM_APB1_DIV_2
  • CRM_APB1_DIV_4
  • CRM_APB1_DIV_8
  • CRM_APB1_DIV_16
Return values
none

Definition at line 422 of file at32f413_crm.c.

Referenced by main(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_apb2_div_set()

void crm_apb2_div_set ( crm_apb2_div_type value )

set crm apb2 division

Parameters
value this parameter can be one of the following values:
  • CRM_APB2_DIV_1
  • CRM_APB2_DIV_2
  • CRM_APB2_DIV_4
  • CRM_APB2_DIV_8
  • CRM_APB2_DIV_16
Return values
none

Definition at line 438 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_auto_step_mode_enable()

void crm_auto_step_mode_enable ( confirm_state new_state )

auto step clock switch enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 714 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_battery_powered_domain_reset()

void crm_battery_powered_domain_reset ( confirm_state new_state )

battery powered domain software reset

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 495 of file at32f413_crm.c.

Referenced by bpr_reset().

◆ crm_clkout_div_set()

void crm_clkout_div_set ( crm_clkout_div_type clkout_div )

set crm clkout division

Parameters
clkout_div this parameter can be one of the following values:
  • CRM_CLKOUT_DIV_1
  • CRM_CLKOUT_DIV_2
  • CRM_CLKOUT_DIV_4
  • CRM_CLKOUT_DIV_8
  • CRM_CLKOUT_DIV_16
  • CRM_CLKOUT_DIV_64
  • CRM_CLKOUT_DIV_128
  • CRM_CLKOUT_DIV_256
  • CRM_CLKOUT_DIV_512
Return values
none

Definition at line 804 of file at32f413_crm.c.

Referenced by clkout_config().

◆ crm_clkout_to_tmr10_enable()

void crm_clkout_to_tmr10_enable ( confirm_state new_state )

enable or disable clkout direct to tmr10 channel 1

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 784 of file at32f413_crm.c.

◆ crm_clock_failure_detection_enable()

void crm_clock_failure_detection_enable ( confirm_state new_state )

enable or disable clock failure detection

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 485 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_clock_out_set()

void crm_clock_out_set ( crm_clkout_select_type clkout )

set crm clkout

Parameters
clkout this parameter can be one of the following values:
  • CRM_CLKOUT_NOCLK
  • CRM_CLKOUT_LICK
  • CRM_CLKOUT_LEXT
  • CRM_CLKOUT_SCLK
  • CRM_CLKOUT_HICK
  • CRM_CLKOUT_HEXT
  • CRM_CLKOUT_PLL_DIV_2
  • CRM_CLKOUT_PLL_DIV_4
  • CRM_CLKOUT_USB
  • CRM_CLKOUT_ADC
Return values
none

Definition at line 683 of file at32f413_crm.c.

Referenced by clkout_config().

◆ crm_clock_source_enable()

void crm_clock_source_enable | ( | crm_clock_source_type | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the crm clock source

Parameters
source this parameter can be one of the following values:
  • CRM_CLOCK_SOURCE_HICK
  • CRM_CLOCK_SOURCE_HEXT
  • CRM_CLOCK_SOURCE_PLL
  • CRM_CLOCK_SOURCE_LEXT
  • CRM_CLOCK_SOURCE_LICK
new_state (TRUE or FALSE)
Return values
none

Definition at line 285 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), rtc_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_clocks_freq_get()

void crm_clocks_freq_get ( crm_clocks_freq_type * clocks_struct )

get crm clocks freqency

Parameters
clocks
  • pointer to the crm_clocks_freq structure
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 576 of file at32f413_crm.c.

Referenced by i2c_init(), i2s_init(), main(), tmr1_config(), tmr2_config(), tmr_init(), usart_configuration(), and usart_init().

◆ crm_flag_clear()

void crm_flag_clear ( uint32_t flag )

clear the crm reset flags

Parameters
flag this parameter can be one of the following values: reset flag:
  • CRM_NRST_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG
  • CRM_ALL_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
none

< nrst pin reset flag

< power on reset flag

< software reset flag

< watchdog timer reset flag

< window watchdog timer reset flag

< low-power reset flag

< all reset flag

< low speed internal clock stable interrupt ready flag

< low speed external crystal stable interrupt ready flag

< high speed internal clock stable interrupt ready flag

< high speed external crystal stable interrupt ready flag

< phase locking loop stable interrupt ready flag

< clock failure interrupt ready flag

Definition at line 330 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_flag_get()

flag_status crm_flag_get ( uint32_t flag )

get crm flag status

Parameters
flag this parameter can be one of the following values:
  • CRM_HICK_STABLE_FLAG
  • CRM_HEXT_STABLE_FLAG
  • CRM_PLL_STABLE_FLAG
  • CRM_LEXT_STABLE_FLAG
  • CRM_LICK_STABLE_FLAG
  • CRM_NRST_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
flag_status (SET or RESET)

Definition at line 122 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), crm_hext_stable_wait(), main(), rtc_config(), rtc_configuration(), rtc_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_hext_bypass()

void crm_hext_bypass ( confirm_state new_state )

enable or disable crm high speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 93 of file at32f413_crm.c.

◆ crm_hext_stable_wait()

error_status crm_hext_stable_wait ( void )

wait for hext stable

Parameters
none
Return values
error_status (ERROR or SUCCESS)

< high speed external crystal stable flag

< time out for hext start up

< high speed external crystal stable flag

Definition at line 141 of file at32f413_crm.c.

Referenced by sclk_96m_hext_config(), system_clock_config(), and system_clock_recover().

◆ crm_hick_clock_calibration_set()

void crm_hick_clock_calibration_set ( uint8_t cali_value )

set the crm calibration value

Parameters
cali_value (0x00~0xFF)
Return values
none

Definition at line 178 of file at32f413_crm.c.

◆ crm_hick_clock_trimming_set()

void crm_hick_clock_trimming_set ( uint8_t trim_value )

set the hick trimming value

Parameters
trim_value (0x00~0x3F)
Return values
none

Definition at line 168 of file at32f413_crm.c.

◆ crm_hick_divider_select()

void crm_hick_divider_select ( crm_hick_div_6_type value )

config hick divider select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK48_DIV6
  • CRM_HICK48_NODIV
Return values
none

Definition at line 743 of file at32f413_crm.c.

Referenced by crm_hick_sclk_frequency_select().

◆ crm_hick_sclk_frequency_select()

void crm_hick_sclk_frequency_select ( crm_hick_sclk_frequency_type value )

hick as system clock frequency select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK_SCLK_8MHZ
  • CRM_HICK_SCLK_48MHZ
Return values
none

Definition at line 756 of file at32f413_crm.c.

Referenced by crm_usb_clock_source_select().

◆ crm_interrupt_enable()

void crm_interrupt_enable | ( | uint32_t | crm_int,
 |  | confirm_state | new_state
 | ) |  |

config crm interrupt

Parameters
int this parameter can be any combination of the following values:
  • CRM_LICK_STABLE_INT
  • CRM_LEXT_STABLE_INT
  • CRM_HICK_STABLE_INT
  • CRM_HEXT_STABLE_INT
  • CRM_PLL_STABLE_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 701 of file at32f413_crm.c.

◆ crm_lext_bypass()

void crm_lext_bypass ( confirm_state new_state )

enable or disable crm low speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 83 of file at32f413_crm.c.

◆ crm_periph_clock_enable()

void crm_periph_clock_enable | ( | crm_periph_clock_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock

Parameters
value this parameter can be one of the following values:
  • CRM_DMA1_PERIPH_CLOCK - CRM_DMA2_PERIPH_CLOCK - CRM_CRC_PERIPH_CLOCK - CRM_SDIO1_PERIPH_CLOCK
  • CRM_IOMUX_PERIPH_CLOCK - CRM_GPIOA_PERIPH_CLOCK - CRM_GPIOB_PERIPH_CLOCK - CRM_GPIOC_PERIPH_CLOCK
  • CRM_GPIOD_PERIPH_CLOCK - CRM_GPIOF_PERIPH_CLOCK - CRM_ADC1_PERIPH_CLOCK - CRM_ADC2_PERIPH_CLOCK
  • CRM_TMR1_PERIPH_CLOCK - CRM_SPI1_PERIPH_CLOCK - CRM_TMR8_PERIPH_CLOCK - CRM_USART1_PERIPH_CLOCK
  • CRM_TMR9_PERIPH_CLOCK - CRM_TMR10_PERIPH_CLOCK - CRM_TMR11_PERIPH_CLOCK - CRM_ACC_PERIPH_CLOCK
  • CRM_TMR3_PERIPH_CLOCK - CRM_TMR4_PERIPH_CLOCK - CRM_TMR5_PERIPH_CLOCK - CRM_WWDT_PERIPH_CLOCK
  • CRM_SPI2_PERIPH_CLOCK - CRM_USART2_PERIPH_CLOCK - CRM_USART3_PERIPH_CLOCK - CRM_UART4_PERIPH_CLOCK
  • CRM_UART5_PERIPH_CLOCK - CRM_I2C1_PERIPH_CLOCK - CRM_I2C2_PERIPH_CLOCK - CRM_USB_PERIPH_CLOCK
  • CRM_CAN1_PERIPH_CLOCK - CRM_BPR_PERIPH_CLOCK - CRM_PWC_PERIPH_CLOCK - CRM_CAN2_PERIPH_CLOCK
new_state (TRUE or FALSE)
Return values
none

Definition at line 206 of file at32f413_crm.c.

Referenced by adc_config(), app_load(), at32_button_init(), at32_led_init(), button_exint_init(), can_configuration(), can_gpio_config(), clkout_config(), codec_i2s_init(), crc_cal(), crm_configuration(), dma_config(), dma_configuration(), exint_config(), exint_line0_config(), exint_line4_config(), flash_crc_check(), gpio_config(), i2c_lowlevel_init(), i2s_config(), jump_to_app(), main(), mclk_tmr1_init(), rs485_config(), rtc_alarm_clock_set(), rtc_configuration(), rtc_init(), rtc_time_set(), sd_dma_config(), sd_init(), spi_config(), spiflash_init(), spim_init(), tmr1_config(), tmr2_config(), TMR3_GLOBAL_IRQHandler(), tmr_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_clock48m_select(), and usb_usart_config().

◆ crm_periph_reset()

void crm_periph_reset | ( | crm_periph_reset_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral reset

Parameters
value this parameter can be one of the following values:
  • CRM_IOMUX_PERIPH_RESET - CRM_EXINT_PERIPH_RESET - CRM_GPIOA_PERIPH_RESET - CRM_GPIOB_PERIPH_RESET
  • CRM_GPIOC_PERIPH_RESET - CRM_GPIOD_PERIPH_RESET - CRM_GPIOF_PERIPH_RESET - CRM_ADC1_PERIPH_RESET
  • CRM_ADC2_PERIPH_RESET - CRM_TMR1_PERIPH_RESET - CRM_SPI1_PERIPH_RESET - CRM_TMR8_PERIPH_RESET
  • CRM_USART1_PERIPH_RESET - CRM_TMR9_PERIPH_RESET - CRM_TMR10_PERIPH_RESET - CRM_TMR11_PERIPH_RESET
  • CRM_ACC_PERIPH_RESET - CRM_TMR2_PERIPH_RESET - CRM_TMR3_PERIPH_RESET - CRM_TMR4_PERIPH_RESET
  • CRM_TMR5_PERIPH_RESET - CRM_WWDT_PERIPH_RESET - CRM_SPI2_PERIPH_RESET - CRM_USART2_PERIPH_RESET
  • CRM_USART3_PERIPH_RESET - CRM_UART4_PERIPH_RESET - CRM_UART5_PERIPH_RESET - CRM_I2C1_PERIPH_RESET
  • CRM_I2C2_PERIPH_RESET - CRM_USB_PERIPH_RESET - CRM_CAN1_PERIPH_RESET - CRM_BPR_PERIPH_RESET
  • CRM_PWC_PERIPH_RESET - CRM_CAN2_PERIPH_RESET
new_state (TRUE or FALSE)
Return values
none

Definition at line 236 of file at32f413_crm.c.

Referenced by adc_reset(), can_reset(), gpio_iomux_reset(), gpio_reset(), i2c_reset(), jump_to_app(), pwc_reset(), spi_i2s_reset(), tmr_reset(), usart_reset(), and wwdt_reset().

◆ crm_periph_sleep_mode_clock_enable()

void crm_periph_sleep_mode_clock_enable | ( | crm_periph_clock_sleepmd_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock in sleep mode

Parameters
value this parameter can be one of the following values:
  • CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE
  • CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE
new_state (TRUE or FALSE)
Return values
none

Definition at line 259 of file at32f413_crm.c.

◆ crm_pll_config()

void crm_pll_config | ( | crm_pll_clock_source_type | clock_source,
 |  | crm_pll_mult_type | mult_value,
 |  | crm_pll_output_range_type | pll_range
 | ) |  |

config crm pll

Parameters
clock_source this parameter can be one of the following values:
  • CRM_PLL_SOURCE_HICK
  • CRM_PLL_SOURCE_HEXT
  • CRM_PLL_SOURCE_HEXT_DIV
mult_value (CRM_PLL_MULT_2~64)
pll_range this parameter can be one of the following values:
  • CRM_PLL_OUTPUT_RANGE_LE72MHZ
  • CRM_PLL_OUTPUT_RANGE_GT72MHZ
Return values
none

Definition at line 514 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_reset()

void crm_reset ( void )

reset the crm register

Parameters
none
Return values
none

Definition at line 49 of file at32f413_crm.c.

Referenced by app_update_handle(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_rtc_clock_enable()

void crm_rtc_clock_enable ( confirm_state new_state )

enable or disable rtc

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 386 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().

◆ crm_rtc_clock_select()

void crm_rtc_clock_select ( crm_rtc_clock_type value )

select rtc clock

Parameters
value this parameter can be one of the following values:
  • CRM_RTC_CLOCK_LEXT
  • CRM_RTC_CLOCK_LICK
  • CRM_RTC_CLOCK_HEXT_DIV
Return values
none

Definition at line 376 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().

◆ crm_sysclk_switch()

void crm_sysclk_switch ( crm_sclk_type value )

select system clock source

Parameters
value this parameter can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL
Return values
none

Definition at line 551 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_sysclk_switch_status_get()

crm_sclk_type crm_sysclk_switch_status_get ( void )

indicate which clock source is used as system clock

Parameters
none
Return values
crm_sclk this return can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL

Definition at line 565 of file at32f413_crm.c.

Referenced by crm_clocks_freq_get(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), system_clock_recover(), and system_core_clock_update().

◆ crm_usb_clock_div_set()

void crm_usb_clock_div_set ( crm_usb_div_type div_value )

set crm usb division

Parameters
value this parameter can be one of the following values:
  • CRM_USB_DIV_1_5
  • CRM_USB_DIV_1
  • CRM_USB_DIV_2_5
  • CRM_USB_DIV_2
  • CRM_USB_DIV_3_5
  • CRM_USB_DIV_3
  • CRM_USB_DIV_4
Return values
none

Definition at line 474 of file at32f413_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_clock_source_select()

void crm_usb_clock_source_select ( crm_usb_clock_source_type value )

usb 48 mhz clock source select

Parameters
value this parameter can be one of the following values:
  • CRM_USB_CLOCK_SOURCE_PLL
  • CRM_USB_CLOCK_SOURCE_HICK
Return values
none

Definition at line 770 of file at32f413_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_interrupt_remapping_set()

void crm_usb_interrupt_remapping_set ( crm_usb_int_map_type int_remap )

usbdev interrupt remapping control

Parameters
int_remap this parameter can be one of the following values:
  • CRM_USB_INT19_INT20
  • CRM_USB_INT73_INT74
Return values
none

Definition at line 730 of file at32f413_crm.c.


AT32F413 Firmwary Library: CRM_private_functions

Functions
CRM_private_functions
AT32F413_periph_driver » CRM

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_sleep_mode_clock_enable (crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_rtc_clock_select (crm_rtc_clock_type value)
select rtc clock More...
void | crm_rtc_clock_enable (confirm_state new_state)
enable or disable rtc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_adc_clock_div_set (crm_adc_div_type div_value)
set crm adc division More...
void | crm_usb_clock_div_set (crm_usb_div_type div_value)
set crm usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out_set (crm_clkout_select_type clkout)
set crm clkout More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_usb_interrupt_remapping_set (crm_usb_int_map_type int_remap)
usbdev interrupt remapping control More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_clkout_div_set (crm_clkout_div_type clkout_div)
set crm clkout division More...

Detailed Description

Function Documentation

◆ crm_adc_clock_div_set()

void crm_adc_clock_div_set ( crm_adc_div_type div_value )

set crm adc division

Parameters
value this parameter can be one of the following values:
  • CRM_ADC_DIV_2
  • CRM_ADC_DIV_4
  • CRM_ADC_DIV_6
  • CRM_ADC_DIV_8
  • CRM_ADC_DIV_12
  • CRM_ADC_DIV_16
Return values
none

Definition at line 455 of file at32f413_crm.c.

Referenced by adc_config().

◆ crm_ahb_div_set()

void crm_ahb_div_set ( crm_ahb_div_type value )

set crm ahb division

Parameters
value this parameter can be one of the following values:
  • CRM_AHB_DIV_1
  • CRM_AHB_DIV_2
  • CRM_AHB_DIV_4
  • CRM_AHB_DIV_8
  • CRM_AHB_DIV_16
  • CRM_AHB_DIV_64
  • CRM_AHB_DIV_128
  • CRM_AHB_DIV_256
  • CRM_AHB_DIV_512
Return values
none

Definition at line 406 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_apb1_div_set()

void crm_apb1_div_set ( crm_apb1_div_type value )

set crm apb1 division

Parameters
value this parameter can be one of the following values:
  • CRM_APB1_DIV_1
  • CRM_APB1_DIV_2
  • CRM_APB1_DIV_4
  • CRM_APB1_DIV_8
  • CRM_APB1_DIV_16
Return values
none

Definition at line 422 of file at32f413_crm.c.

Referenced by main(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_apb2_div_set()

void crm_apb2_div_set ( crm_apb2_div_type value )

set crm apb2 division

Parameters
value this parameter can be one of the following values:
  • CRM_APB2_DIV_1
  • CRM_APB2_DIV_2
  • CRM_APB2_DIV_4
  • CRM_APB2_DIV_8
  • CRM_APB2_DIV_16
Return values
none

Definition at line 438 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_auto_step_mode_enable()

void crm_auto_step_mode_enable ( confirm_state new_state )

auto step clock switch enable

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 714 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_battery_powered_domain_reset()

void crm_battery_powered_domain_reset ( confirm_state new_state )

battery powered domain software reset

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 495 of file at32f413_crm.c.

Referenced by bpr_reset().

◆ crm_clkout_div_set()

void crm_clkout_div_set ( crm_clkout_div_type clkout_div )

set crm clkout division

Parameters
clkout_div this parameter can be one of the following values:
  • CRM_CLKOUT_DIV_1
  • CRM_CLKOUT_DIV_2
  • CRM_CLKOUT_DIV_4
  • CRM_CLKOUT_DIV_8
  • CRM_CLKOUT_DIV_16
  • CRM_CLKOUT_DIV_64
  • CRM_CLKOUT_DIV_128
  • CRM_CLKOUT_DIV_256
  • CRM_CLKOUT_DIV_512
Return values
none

Definition at line 804 of file at32f413_crm.c.

Referenced by clkout_config().

◆ crm_clkout_to_tmr10_enable()

void crm_clkout_to_tmr10_enable ( confirm_state new_state )

enable or disable clkout direct to tmr10 channel 1

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 784 of file at32f413_crm.c.

◆ crm_clock_failure_detection_enable()

void crm_clock_failure_detection_enable ( confirm_state new_state )

enable or disable clock failure detection

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 485 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_clock_out_set()

void crm_clock_out_set ( crm_clkout_select_type clkout )

set crm clkout

Parameters
clkout this parameter can be one of the following values:
  • CRM_CLKOUT_NOCLK
  • CRM_CLKOUT_LICK
  • CRM_CLKOUT_LEXT
  • CRM_CLKOUT_SCLK
  • CRM_CLKOUT_HICK
  • CRM_CLKOUT_HEXT
  • CRM_CLKOUT_PLL_DIV_2
  • CRM_CLKOUT_PLL_DIV_4
  • CRM_CLKOUT_USB
  • CRM_CLKOUT_ADC
Return values
none

Definition at line 683 of file at32f413_crm.c.

Referenced by clkout_config().

◆ crm_clock_source_enable()

void crm_clock_source_enable | ( | crm_clock_source_type | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the crm clock source

Parameters
source this parameter can be one of the following values:
  • CRM_CLOCK_SOURCE_HICK
  • CRM_CLOCK_SOURCE_HEXT
  • CRM_CLOCK_SOURCE_PLL
  • CRM_CLOCK_SOURCE_LEXT
  • CRM_CLOCK_SOURCE_LICK
new_state (TRUE or FALSE)
Return values
none

Definition at line 285 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), rtc_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_clocks_freq_get()

void crm_clocks_freq_get ( crm_clocks_freq_type * clocks_struct )

get crm clocks freqency

Parameters
clocks
  • pointer to the crm_clocks_freq structure
Return values
none

< value of the high speed internal clock in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

< value of the high speed exernal crystal in hz

< value of the high speed exernal crystal in hz

< value of the high speed internal clock in hz

Definition at line 576 of file at32f413_crm.c.

Referenced by i2c_init(), i2s_init(), main(), tmr1_config(), tmr2_config(), tmr_init(), usart_configuration(), and usart_init().

◆ crm_flag_clear()

void crm_flag_clear ( uint32_t flag )

clear the crm reset flags

Parameters
flag this parameter can be one of the following values: reset flag:
  • CRM_NRST_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG
  • CRM_ALL_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
none

< nrst pin reset flag

< power on reset flag

< software reset flag

< watchdog timer reset flag

< window watchdog timer reset flag

< low-power reset flag

< all reset flag

< low speed internal clock stable interrupt ready flag

< low speed external crystal stable interrupt ready flag

< high speed internal clock stable interrupt ready flag

< high speed external crystal stable interrupt ready flag

< phase locking loop stable interrupt ready flag

< clock failure interrupt ready flag

Definition at line 330 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), and main().

◆ crm_flag_get()

flag_status crm_flag_get ( uint32_t flag )

get crm flag status

Parameters
flag this parameter can be one of the following values:
  • CRM_HICK_STABLE_FLAG
  • CRM_HEXT_STABLE_FLAG
  • CRM_PLL_STABLE_FLAG
  • CRM_LEXT_STABLE_FLAG
  • CRM_LICK_STABLE_FLAG
  • CRM_NRST_RESET_FLAG
  • CRM_POR_RESET_FLAG
  • CRM_SW_RESET_FLAG
  • CRM_WDT_RESET_FLAG
  • CRM_WWDT_RESET_FLAG
  • CRM_LOWPOWER_RESET_FLAG interrupt flag:
  • CRM_LICK_READY_INT_FLAG
  • CRM_LEXT_READY_INT_FLAG
  • CRM_HICK_READY_INT_FLAG
  • CRM_HEXT_READY_INT_FLAG
  • CRM_PLL_READY_INT_FLAG
  • CRM_CLOCK_FAILURE_INT_FLAG
Return values
flag_status (SET or RESET)

Definition at line 122 of file at32f413_crm.c.

Referenced by clock_failure_detection_handler(), crm_hext_stable_wait(), main(), rtc_config(), rtc_configuration(), rtc_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_hext_bypass()

void crm_hext_bypass ( confirm_state new_state )

enable or disable crm high speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 93 of file at32f413_crm.c.

◆ crm_hext_stable_wait()

error_status crm_hext_stable_wait ( void )

wait for hext stable

Parameters
none
Return values
error_status (ERROR or SUCCESS)

< high speed external crystal stable flag

< time out for hext start up

< high speed external crystal stable flag

Definition at line 141 of file at32f413_crm.c.

Referenced by sclk_96m_hext_config(), system_clock_config(), and system_clock_recover().

◆ crm_hick_clock_calibration_set()

void crm_hick_clock_calibration_set ( uint8_t cali_value )

set the crm calibration value

Parameters
cali_value (0x00~0xFF)
Return values
none

Definition at line 178 of file at32f413_crm.c.

◆ crm_hick_clock_trimming_set()

void crm_hick_clock_trimming_set ( uint8_t trim_value )

set the hick trimming value

Parameters
trim_value (0x00~0x3F)
Return values
none

Definition at line 168 of file at32f413_crm.c.

◆ crm_hick_divider_select()

void crm_hick_divider_select ( crm_hick_div_6_type value )

config hick divider select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK48_DIV6
  • CRM_HICK48_NODIV
Return values
none

Definition at line 743 of file at32f413_crm.c.

Referenced by crm_hick_sclk_frequency_select().

◆ crm_hick_sclk_frequency_select()

void crm_hick_sclk_frequency_select ( crm_hick_sclk_frequency_type value )

hick as system clock frequency select

Parameters
value this parameter can be one of the following values:
  • CRM_HICK_SCLK_8MHZ
  • CRM_HICK_SCLK_48MHZ
Return values
none

Definition at line 756 of file at32f413_crm.c.

Referenced by crm_usb_clock_source_select().

◆ crm_interrupt_enable()

void crm_interrupt_enable | ( | uint32_t | crm_int,
 |  | confirm_state | new_state
 | ) |  |

config crm interrupt

Parameters
int this parameter can be any combination of the following values:
  • CRM_LICK_STABLE_INT
  • CRM_LEXT_STABLE_INT
  • CRM_HICK_STABLE_INT
  • CRM_HEXT_STABLE_INT
  • CRM_PLL_STABLE_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 701 of file at32f413_crm.c.

◆ crm_lext_bypass()

void crm_lext_bypass ( confirm_state new_state )

enable or disable crm low speed external crystal bypass

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 83 of file at32f413_crm.c.

◆ crm_periph_clock_enable()

void crm_periph_clock_enable | ( | crm_periph_clock_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock

Parameters
value this parameter can be one of the following values:
  • CRM_DMA1_PERIPH_CLOCK - CRM_DMA2_PERIPH_CLOCK - CRM_CRC_PERIPH_CLOCK - CRM_SDIO1_PERIPH_CLOCK
  • CRM_IOMUX_PERIPH_CLOCK - CRM_GPIOA_PERIPH_CLOCK - CRM_GPIOB_PERIPH_CLOCK - CRM_GPIOC_PERIPH_CLOCK
  • CRM_GPIOD_PERIPH_CLOCK - CRM_GPIOF_PERIPH_CLOCK - CRM_ADC1_PERIPH_CLOCK - CRM_ADC2_PERIPH_CLOCK
  • CRM_TMR1_PERIPH_CLOCK - CRM_SPI1_PERIPH_CLOCK - CRM_TMR8_PERIPH_CLOCK - CRM_USART1_PERIPH_CLOCK
  • CRM_TMR9_PERIPH_CLOCK - CRM_TMR10_PERIPH_CLOCK - CRM_TMR11_PERIPH_CLOCK - CRM_ACC_PERIPH_CLOCK
  • CRM_TMR3_PERIPH_CLOCK - CRM_TMR4_PERIPH_CLOCK - CRM_TMR5_PERIPH_CLOCK - CRM_WWDT_PERIPH_CLOCK
  • CRM_SPI2_PERIPH_CLOCK - CRM_USART2_PERIPH_CLOCK - CRM_USART3_PERIPH_CLOCK - CRM_UART4_PERIPH_CLOCK
  • CRM_UART5_PERIPH_CLOCK - CRM_I2C1_PERIPH_CLOCK - CRM_I2C2_PERIPH_CLOCK - CRM_USB_PERIPH_CLOCK
  • CRM_CAN1_PERIPH_CLOCK - CRM_BPR_PERIPH_CLOCK - CRM_PWC_PERIPH_CLOCK - CRM_CAN2_PERIPH_CLOCK
new_state (TRUE or FALSE)
Return values
none

Definition at line 206 of file at32f413_crm.c.

Referenced by adc_config(), app_load(), at32_button_init(), at32_led_init(), button_exint_init(), can_configuration(), can_gpio_config(), clkout_config(), codec_i2s_init(), crc_cal(), crm_configuration(), dma_config(), dma_configuration(), exint_config(), exint_line0_config(), exint_line4_config(), flash_crc_check(), gpio_config(), i2c_lowlevel_init(), i2s_config(), jump_to_app(), main(), mclk_tmr1_init(), rs485_config(), rtc_alarm_clock_set(), rtc_configuration(), rtc_init(), rtc_time_set(), sd_dma_config(), sd_init(), spi_config(), spiflash_init(), spim_init(), tmr1_config(), tmr2_config(), TMR3_GLOBAL_IRQHandler(), tmr_init(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), usart_spi_configuration(), usb_clock48m_select(), and usb_usart_config().

◆ crm_periph_reset()

void crm_periph_reset | ( | crm_periph_reset_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral reset

Parameters
value this parameter can be one of the following values:
  • CRM_IOMUX_PERIPH_RESET - CRM_EXINT_PERIPH_RESET - CRM_GPIOA_PERIPH_RESET - CRM_GPIOB_PERIPH_RESET
  • CRM_GPIOC_PERIPH_RESET - CRM_GPIOD_PERIPH_RESET - CRM_GPIOF_PERIPH_RESET - CRM_ADC1_PERIPH_RESET
  • CRM_ADC2_PERIPH_RESET - CRM_TMR1_PERIPH_RESET - CRM_SPI1_PERIPH_RESET - CRM_TMR8_PERIPH_RESET
  • CRM_USART1_PERIPH_RESET - CRM_TMR9_PERIPH_RESET - CRM_TMR10_PERIPH_RESET - CRM_TMR11_PERIPH_RESET
  • CRM_ACC_PERIPH_RESET - CRM_TMR2_PERIPH_RESET - CRM_TMR3_PERIPH_RESET - CRM_TMR4_PERIPH_RESET
  • CRM_TMR5_PERIPH_RESET - CRM_WWDT_PERIPH_RESET - CRM_SPI2_PERIPH_RESET - CRM_USART2_PERIPH_RESET
  • CRM_USART3_PERIPH_RESET - CRM_UART4_PERIPH_RESET - CRM_UART5_PERIPH_RESET - CRM_I2C1_PERIPH_RESET
  • CRM_I2C2_PERIPH_RESET - CRM_USB_PERIPH_RESET - CRM_CAN1_PERIPH_RESET - CRM_BPR_PERIPH_RESET
  • CRM_PWC_PERIPH_RESET - CRM_CAN2_PERIPH_RESET
new_state (TRUE or FALSE)
Return values
none

Definition at line 236 of file at32f413_crm.c.

Referenced by adc_reset(), can_reset(), gpio_iomux_reset(), gpio_reset(), i2c_reset(), jump_to_app(), pwc_reset(), spi_i2s_reset(), tmr_reset(), usart_reset(), and wwdt_reset().

◆ crm_periph_sleep_mode_clock_enable()

void crm_periph_sleep_mode_clock_enable | ( | crm_periph_clock_sleepmd_type | value,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the peripheral clock in sleep mode

Parameters
value this parameter can be one of the following values:
  • CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE
  • CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE
new_state (TRUE or FALSE)
Return values
none

Definition at line 259 of file at32f413_crm.c.

◆ crm_pll_config()

void crm_pll_config | ( | crm_pll_clock_source_type | clock_source,
 |  | crm_pll_mult_type | mult_value,
 |  | crm_pll_output_range_type | pll_range
 | ) |  |

config crm pll

Parameters
clock_source this parameter can be one of the following values:
  • CRM_PLL_SOURCE_HICK
  • CRM_PLL_SOURCE_HEXT
  • CRM_PLL_SOURCE_HEXT_DIV
mult_value (CRM_PLL_MULT_2~64)
pll_range this parameter can be one of the following values:
  • CRM_PLL_OUTPUT_RANGE_LE72MHZ
  • CRM_PLL_OUTPUT_RANGE_GT72MHZ
Return values
none

Definition at line 514 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_reset()

void crm_reset ( void )

reset the crm register

Parameters
none
Return values
none

Definition at line 49 of file at32f413_crm.c.

Referenced by app_update_handle(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), and system_clock_config_for_acc().

◆ crm_rtc_clock_enable()

void crm_rtc_clock_enable ( confirm_state new_state )

enable or disable rtc

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 386 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().

◆ crm_rtc_clock_select()

void crm_rtc_clock_select ( crm_rtc_clock_type value )

select rtc clock

Parameters
value this parameter can be one of the following values:
  • CRM_RTC_CLOCK_LEXT
  • CRM_RTC_CLOCK_LICK
  • CRM_RTC_CLOCK_HEXT_DIV
Return values
none

Definition at line 376 of file at32f413_crm.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().

◆ crm_sysclk_switch()

void crm_sysclk_switch ( crm_sclk_type value )

select system clock source

Parameters
value this parameter can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL
Return values
none

Definition at line 551 of file at32f413_crm.c.

Referenced by sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), and system_clock_recover().

◆ crm_sysclk_switch_status_get()

crm_sclk_type crm_sysclk_switch_status_get ( void )

indicate which clock source is used as system clock

Parameters
none
Return values
crm_sclk this return can be one of the following values:
  • CRM_SCLK_HICK
  • CRM_SCLK_HEXT
  • CRM_SCLK_PLL

Definition at line 565 of file at32f413_crm.c.

Referenced by crm_clocks_freq_get(), sclk_192m_hick_config(), sclk_64m_hick_config(), sclk_96m_hext_config(), system_clock_config(), system_clock_config_for_acc(), system_clock_recover(), and system_core_clock_update().

◆ crm_usb_clock_div_set()

void crm_usb_clock_div_set ( crm_usb_div_type div_value )

set crm usb division

Parameters
value this parameter can be one of the following values:
  • CRM_USB_DIV_1_5
  • CRM_USB_DIV_1
  • CRM_USB_DIV_2_5
  • CRM_USB_DIV_2
  • CRM_USB_DIV_3_5
  • CRM_USB_DIV_3
  • CRM_USB_DIV_4
Return values
none

Definition at line 474 of file at32f413_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_clock_source_select()

void crm_usb_clock_source_select ( crm_usb_clock_source_type value )

usb 48 mhz clock source select

Parameters
value this parameter can be one of the following values:
  • CRM_USB_CLOCK_SOURCE_PLL
  • CRM_USB_CLOCK_SOURCE_HICK
Return values
none

Definition at line 770 of file at32f413_crm.c.

Referenced by usb_clock48m_select().

◆ crm_usb_interrupt_remapping_set()

void crm_usb_interrupt_remapping_set ( crm_usb_int_map_type int_remap )

usbdev interrupt remapping control

Parameters
int_remap this parameter can be one of the following values:
  • CRM_USB_INT19_INT20
  • CRM_USB_INT73_INT74
Return values
none

Definition at line 730 of file at32f413_crm.c.


AT32F413 Firmwary Library: DEBUG

Modules | Macros
DEBUG
AT32F413_periph_driver

DEBUG driver modules. More...

Modules

DEBUG_mode_definition
DEBUG_exported_types
DEBUG_exported_functions
DEBUG_private_functions

Macros

#define DEBUGMCU ((debug_type *) DEBUG_BASE)

Detailed Description

DEBUG driver modules.

Macro Definition Documentation

◆ DEBUGMCU

#define DEBUGMCU ((debug_type *) DEBUG_BASE)

Definition at line 136 of file at32f413_debug.h.


AT32F413 Firmwary Library: DEBUG_mode_definition

Macros
DEBUG_mode_definition
AT32F413_periph_driver » DEBUG

Macros

#define | DEBUG_SLEEP 0x00000001
#define | DEBUG_DEEPSLEEP 0x00000002
#define | DEBUG_STANDBY 0x00000004
#define | DEBUG_WDT_PAUSE 0x00000100
#define | DEBUG_WWDT_PAUSE 0x00000200
#define | DEBUG_TMR1_PAUSE 0x00000400
#define | DEBUG_TMR2_PAUSE 0x00000800
#define | DEBUG_TMR3_PAUSE 0x00001000
#define | DEBUG_TMR4_PAUSE 0x00002000
#define | DEBUG_CAN1_PAUSE 0x00004000
#define | DEBUG_I2C1_SMBUS_TIMEOUT 0x00008000
#define | DEBUG_I2C2_SMBUS_TIMEOUT 0x00010000
#define | DEBUG_TMR8_PAUSE 0x00020000
#define | DEBUG_TMR5_PAUSE 0x00040000
#define | DEBUG_CAN2_PAUSE 0x00200000
#define | DEBUG_TMR9_PAUSE 0x10000000
#define | DEBUG_TMR10_PAUSE 0x20000000
#define | DEBUG_TMR11_PAUSE 0x40000000

Detailed Description

Macro Definition Documentation

◆ DEBUG_CAN1_PAUSE

#define DEBUG_CAN1_PAUSE 0x00004000

debug can1 pause

Definition at line 60 of file at32f413_debug.h.

◆ DEBUG_CAN2_PAUSE

#define DEBUG_CAN2_PAUSE 0x00200000

debug can2 pause

Definition at line 65 of file at32f413_debug.h.

◆ DEBUG_DEEPSLEEP

#define DEBUG_DEEPSLEEP 0x00000002

debug deepsleep mode

Definition at line 52 of file at32f413_debug.h.

◆ DEBUG_I2C1_SMBUS_TIMEOUT

#define DEBUG_I2C1_SMBUS_TIMEOUT 0x00008000

debug i2c1 smbus timeout

Definition at line 61 of file at32f413_debug.h.

◆ DEBUG_I2C2_SMBUS_TIMEOUT

#define DEBUG_I2C2_SMBUS_TIMEOUT 0x00010000

debug i2c2 smbus timeout

Definition at line 62 of file at32f413_debug.h.

◆ DEBUG_SLEEP

#define DEBUG_SLEEP 0x00000001

debug sleep mode

Definition at line 51 of file at32f413_debug.h.

◆ DEBUG_STANDBY

#define DEBUG_STANDBY 0x00000004

debug standby mode

Definition at line 53 of file at32f413_debug.h.

◆ DEBUG_TMR10_PAUSE

#define DEBUG_TMR10_PAUSE 0x20000000

debug timer10 pause

Definition at line 67 of file at32f413_debug.h.

◆ DEBUG_TMR11_PAUSE

#define DEBUG_TMR11_PAUSE 0x40000000

debug timer11 pause

Definition at line 68 of file at32f413_debug.h.

◆ DEBUG_TMR1_PAUSE

#define DEBUG_TMR1_PAUSE 0x00000400

debug timer1 pause

Definition at line 56 of file at32f413_debug.h.

◆ DEBUG_TMR2_PAUSE

#define DEBUG_TMR2_PAUSE 0x00000800

debug timer2 pause

Definition at line 57 of file at32f413_debug.h.

◆ DEBUG_TMR3_PAUSE

#define DEBUG_TMR3_PAUSE 0x00001000

debug timer3 pause

Definition at line 58 of file at32f413_debug.h.

◆ DEBUG_TMR4_PAUSE

#define DEBUG_TMR4_PAUSE 0x00002000

debug timer4 pause

Definition at line 59 of file at32f413_debug.h.

◆ DEBUG_TMR5_PAUSE

#define DEBUG_TMR5_PAUSE 0x00040000

debug timer5 pause

Definition at line 64 of file at32f413_debug.h.

◆ DEBUG_TMR8_PAUSE

#define DEBUG_TMR8_PAUSE 0x00020000

debug timer8 pause

Definition at line 63 of file at32f413_debug.h.

◆ DEBUG_TMR9_PAUSE

#define DEBUG_TMR9_PAUSE 0x10000000

debug timer9 pause

Definition at line 66 of file at32f413_debug.h.

◆ DEBUG_WDT_PAUSE

#define DEBUG_WDT_PAUSE 0x00000100

debug watchdog timer pause

Definition at line 54 of file at32f413_debug.h.

◆ DEBUG_WWDT_PAUSE

#define DEBUG_WWDT_PAUSE 0x00000200

debug window watchdog timer pause

Definition at line 55 of file at32f413_debug.h.


AT32F413 Firmwary Library: DEBUG_exported_types

Data Structures
DEBUG_exported_types
AT32F413_periph_driver » DEBUG

Data Structures

struct debug_type
type define debug register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: debug_type Struct Reference

Data Fields
debug_type Struct Reference
AT32F413_periph_driver » DEBUG » DEBUG_exported_types

type define debug register all More...

#include <at32f413_debug.h>

Data Fields

union {
__IO uint32_t pid
struct {
__IO uint32_t pid: 32
} idcode_bit
};
debug idcode register, offset:0x00 More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t sleep_debug: 1
__IO uint32_t deepsleep_debug: 1
__IO uint32_t standby_debug: 1
__IO uint32_t reserved1: 2
__IO uint32_t trace_ioen: 1
__IO uint32_t trace_mode: 2
__IO uint32_t wdt_pause: 1
__IO uint32_t wwdt_pause: 1
__IO uint32_t tmr1_pause: 1
__IO uint32_t tmr2_pause: 1
__IO uint32_t tmr3_pause: 1
__IO uint32_t tmr4_pause: 1
__IO uint32_t can1_pause: 1
__IO uint32_t i2c1_smbus_timeout: 1
__IO uint32_t i2c2_smbus_timeout: 1
__IO uint32_t tmr8_pause: 1
__IO uint32_t tmr5_pause: 1
__IO uint32_t reserved2: 2
__IO uint32_t can2_pause: 1
__IO uint32_t reserved3: 6
__IO uint32_t tmr9_pause: 1
__IO uint32_t tmr10_pause: 1
__IO uint32_t tmr11_pause: 1
__IO uint32_t reserved4: 1
} ctrl_bit
};
debug ctrl register, offset:0x04 More...

Detailed Description

type define debug register all

Definition at line 81 of file at32f413_debug.h.

Field Documentation

◆

union { ... } debug_type::@331

debug idcode register, offset:0x00

◆

union { ... } debug_type::@333

debug ctrl register, offset:0x04

◆ can1_pause

__IO uint32_t debug_type::can1_pause

Definition at line 115 of file at32f413_debug.h.

◆ can2_pause

__IO uint32_t debug_type::can2_pause

Definition at line 121 of file at32f413_debug.h.

◆ ctrl

__IO uint32_t debug_type::ctrl

Definition at line 100 of file at32f413_debug.h.

◆

struct { ... } debug_type::ctrl_bit

◆ deepsleep_debug

__IO uint32_t debug_type::deepsleep_debug

Definition at line 104 of file at32f413_debug.h.

◆ i2c1_smbus_timeout

__IO uint32_t debug_type::i2c1_smbus_timeout

Definition at line 116 of file at32f413_debug.h.

◆ i2c2_smbus_timeout

__IO uint32_t debug_type::i2c2_smbus_timeout

Definition at line 117 of file at32f413_debug.h.

◆

struct { ... } debug_type::idcode_bit

◆ pid

__IO uint32_t debug_type::pid

Definition at line 88 of file at32f413_debug.h.

◆ reserved1

__IO uint32_t debug_type::reserved1

Definition at line 106 of file at32f413_debug.h.

◆ reserved2

__IO uint32_t debug_type::reserved2

Definition at line 120 of file at32f413_debug.h.

◆ reserved3

__IO uint32_t debug_type::reserved3

Definition at line 122 of file at32f413_debug.h.

◆ reserved4

__IO uint32_t debug_type::reserved4

Definition at line 126 of file at32f413_debug.h.

◆ sleep_debug

__IO uint32_t debug_type::sleep_debug

Definition at line 103 of file at32f413_debug.h.

◆ standby_debug

__IO uint32_t debug_type::standby_debug

Definition at line 105 of file at32f413_debug.h.

◆ tmr10_pause

__IO uint32_t debug_type::tmr10_pause

Definition at line 124 of file at32f413_debug.h.

◆ tmr11_pause

__IO uint32_t debug_type::tmr11_pause

Definition at line 125 of file at32f413_debug.h.

◆ tmr1_pause

__IO uint32_t debug_type::tmr1_pause

Definition at line 111 of file at32f413_debug.h.

◆ tmr2_pause

__IO uint32_t debug_type::tmr2_pause

Definition at line 112 of file at32f413_debug.h.

◆ tmr3_pause

__IO uint32_t debug_type::tmr3_pause

Definition at line 113 of file at32f413_debug.h.

◆ tmr4_pause

__IO uint32_t debug_type::tmr4_pause

Definition at line 114 of file at32f413_debug.h.

◆ tmr5_pause

__IO uint32_t debug_type::tmr5_pause

Definition at line 119 of file at32f413_debug.h.

◆ tmr8_pause

__IO uint32_t debug_type::tmr8_pause

Definition at line 118 of file at32f413_debug.h.

◆ tmr9_pause

__IO uint32_t debug_type::tmr9_pause

Definition at line 123 of file at32f413_debug.h.

◆ trace_ioen

__IO uint32_t debug_type::trace_ioen

Definition at line 107 of file at32f413_debug.h.

◆ trace_mode

__IO uint32_t debug_type::trace_mode

Definition at line 108 of file at32f413_debug.h.

◆ wdt_pause

__IO uint32_t debug_type::wdt_pause

Definition at line 109 of file at32f413_debug.h.

◆ wwdt_pause

__IO uint32_t debug_type::wwdt_pause

Definition at line 110 of file at32f413_debug.h.

The documentation for this struct was generated from the following file:
  • at32f413_debug.h


AT32F413 Firmwary Library: DEBUG_exported_functions

Functions
DEBUG_exported_functions
AT32F413_periph_driver » DEBUG

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_periph_mode_set (uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode More...

Detailed Description

Function Documentation

◆ debug_device_id_get()

uint32_t debug_device_id_get ( void )

get debug device id

Parameters
none
Return values
the debug device id

Definition at line 49 of file at32f413_debug.c.

◆ debug_periph_mode_set()

void debug_periph_mode_set | ( | uint32_t | periph_debug_mode,
 |  | confirm_state | new_state
 | ) |  |

set periph debug mode

Parameters
periph_debug_mode this parameter can be any combination of the following values:
  • DEBUG_SLEEP
  • DEBUG_DEEPSLEEP
  • DEBUG_STANDBY
  • DEBUG_WDT_PAUSE
  • DEBUG_WWDT_PAUSE
  • DEBUG_TMR1_PAUSE
  • DEBUG_TMR2_PAUSE
  • DEBUG_TMR3_PAUSE
  • DEBUG_TMR4_PAUSE
  • DEBUG_CAN1_PAUSE
  • DEBUG_I2C1_SMBUS_TIMEOUT
  • DEBUG_I2C2_SMBUS_TIMEOUT
  • DEBUG_TMR8_PAUSE
  • DEBUG_TMR5_PAUSE
  • DEBUG_CAN2_PAUSE
  • DEBUG_TMR9_PAUSE
  • DEBUG_TMR10_PAUSE
  • DEBUG_TMR11_PAUSE
new_state (TRUE or FALSE)
Return values
none

Definition at line 79 of file at32f413_debug.c.

Referenced by main().


AT32F413 Firmwary Library: DEBUG_private_functions

Functions
DEBUG_private_functions
AT32F413_periph_driver » DEBUG

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_periph_mode_set (uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode More...

Detailed Description

Function Documentation

◆ debug_device_id_get()

uint32_t debug_device_id_get ( void )

get debug device id

Parameters
none
Return values
the debug device id

Definition at line 49 of file at32f413_debug.c.

◆ debug_periph_mode_set()

void debug_periph_mode_set | ( | uint32_t | periph_debug_mode,
 |  | confirm_state | new_state
 | ) |  |

set periph debug mode

Parameters
periph_debug_mode this parameter can be any combination of the following values:
  • DEBUG_SLEEP
  • DEBUG_DEEPSLEEP
  • DEBUG_STANDBY
  • DEBUG_WDT_PAUSE
  • DEBUG_WWDT_PAUSE
  • DEBUG_TMR1_PAUSE
  • DEBUG_TMR2_PAUSE
  • DEBUG_TMR3_PAUSE
  • DEBUG_TMR4_PAUSE
  • DEBUG_CAN1_PAUSE
  • DEBUG_I2C1_SMBUS_TIMEOUT
  • DEBUG_I2C2_SMBUS_TIMEOUT
  • DEBUG_TMR8_PAUSE
  • DEBUG_TMR5_PAUSE
  • DEBUG_CAN2_PAUSE
  • DEBUG_TMR9_PAUSE
  • DEBUG_TMR10_PAUSE
  • DEBUG_TMR11_PAUSE
new_state (TRUE or FALSE)
Return values
none

Definition at line 79 of file at32f413_debug.c.

Referenced by main().


AT32F413 Firmwary Library: DMA

Modules | Macros
DMA
AT32F413_periph_driver

DMA driver modules. More...

Modules

DMA_interrupts_definition
dma interrupt
DMA_flexible_channel
DMA_flags_definition
dma flag
DMA_exported_types
DMA_exported_functions
DMA_private_functions

Macros

#define | DMA1 ((dma_type *) DMA1_BASE)
#define | DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)
#define | DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)
#define | DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)
#define | DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)
#define | DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)
#define | DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)
#define | DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)
#define | DMA2 ((dma_type *) DMA2_BASE)
#define | DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)
#define | DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)
#define | DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)
#define | DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)
#define | DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)
#define | DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)
#define | DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)

Detailed Description

DMA driver modules.

Macro Definition Documentation

◆ DMA1

#define DMA1 ((dma_type *) DMA1_BASE)

Definition at line 479 of file at32f413_dma.h.

◆ DMA1_CHANNEL1

#define DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)

Definition at line 480 of file at32f413_dma.h.

◆ DMA1_CHANNEL2

#define DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)

Definition at line 481 of file at32f413_dma.h.

◆ DMA1_CHANNEL3

#define DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)

Definition at line 482 of file at32f413_dma.h.

◆ DMA1_CHANNEL4

#define DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)

Definition at line 483 of file at32f413_dma.h.

◆ DMA1_CHANNEL5

#define DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)

Definition at line 484 of file at32f413_dma.h.

◆ DMA1_CHANNEL6

#define DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)

Definition at line 485 of file at32f413_dma.h.

◆ DMA1_CHANNEL7

#define DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)

Definition at line 486 of file at32f413_dma.h.

◆ DMA2

#define DMA2 ((dma_type *) DMA2_BASE)

Definition at line 488 of file at32f413_dma.h.

◆ DMA2_CHANNEL1

#define DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)

Definition at line 489 of file at32f413_dma.h.

◆ DMA2_CHANNEL2

#define DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)

Definition at line 490 of file at32f413_dma.h.

◆ DMA2_CHANNEL3

#define DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)

Definition at line 491 of file at32f413_dma.h.

◆ DMA2_CHANNEL4

#define DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)

Definition at line 492 of file at32f413_dma.h.

◆ DMA2_CHANNEL5

#define DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)

Definition at line 493 of file at32f413_dma.h.

◆ DMA2_CHANNEL6

#define DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)

Definition at line 494 of file at32f413_dma.h.

◆ DMA2_CHANNEL7

#define DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)

Definition at line 495 of file at32f413_dma.h.


AT32F413 Firmwary Library: DMA_interrupts_definition

Macros
DMA_interrupts_definition
AT32F413_periph_driver » DMA

dma interrupt More...

Macros

#define | DMA_FDT_INT ((uint32_t)0x00000002)
#define | DMA_HDT_INT ((uint32_t)0x00000004)
#define | DMA_DTERR_INT ((uint32_t)0x00000008)

Detailed Description

dma interrupt

Macro Definition Documentation

◆ DMA_DTERR_INT

#define DMA_DTERR_INT ((uint32_t)0x00000008)

dma errorr interrupt

Definition at line 54 of file at32f413_dma.h.

◆ DMA_FDT_INT

#define DMA_FDT_INT ((uint32_t)0x00000002)

dma full data transfer interrupt

Definition at line 52 of file at32f413_dma.h.

◆ DMA_HDT_INT

#define DMA_HDT_INT ((uint32_t)0x00000004)

dma half data transfer interrupt

Definition at line 53 of file at32f413_dma.h.


AT32F413 Firmwary Library: DMA_flexible_channel

Macros
DMA_flexible_channel
AT32F413_periph_driver » DMA

Macros

#define | FLEX_CHANNEL1 ((uint8_t)0x01)
#define | FLEX_CHANNEL2 ((uint8_t)0x02)
#define | FLEX_CHANNEL3 ((uint8_t)0x03)
#define | FLEX_CHANNEL4 ((uint8_t)0x04)
#define | FLEX_CHANNEL5 ((uint8_t)0x05)
#define | FLEX_CHANNEL6 ((uint8_t)0x06)
#define | FLEX_CHANNEL7 ((uint8_t)0x07)

Detailed Description

Macro Definition Documentation

◆ FLEX_CHANNEL1

#define FLEX_CHANNEL1 ((uint8_t)0x01)

dma flexible channel1

Definition at line 64 of file at32f413_dma.h.

◆ FLEX_CHANNEL2

#define FLEX_CHANNEL2 ((uint8_t)0x02)

dma flexible channel2

Definition at line 65 of file at32f413_dma.h.

◆ FLEX_CHANNEL3

#define FLEX_CHANNEL3 ((uint8_t)0x03)

dma flexible channel3

Definition at line 66 of file at32f413_dma.h.

◆ FLEX_CHANNEL4

#define FLEX_CHANNEL4 ((uint8_t)0x04)

dma flexible channel4

Definition at line 67 of file at32f413_dma.h.

◆ FLEX_CHANNEL5

#define FLEX_CHANNEL5 ((uint8_t)0x05)

dma flexible channel5

Definition at line 68 of file at32f413_dma.h.

◆ FLEX_CHANNEL6

#define FLEX_CHANNEL6 ((uint8_t)0x06)

dma flexible channel6

Definition at line 69 of file at32f413_dma.h.

◆ FLEX_CHANNEL7

#define FLEX_CHANNEL7 ((uint8_t)0x07)

dma flexible channel7

Definition at line 70 of file at32f413_dma.h.


AT32F413 Firmwary Library: DMA_flags_definition

Macros
DMA_flags_definition
AT32F413_periph_driver » DMA

dma flag More...

Macros

#define | DMA1_GL1_FLAG ((uint32_t)0x00000001)
#define | DMA1_FDT1_FLAG ((uint32_t)0x00000002)
#define | DMA1_HDT1_FLAG ((uint32_t)0x00000004)
#define | DMA1_DTERR1_FLAG ((uint32_t)0x00000008)
#define | DMA1_GL2_FLAG ((uint32_t)0x00000010)
#define | DMA1_FDT2_FLAG ((uint32_t)0x00000020)
#define | DMA1_HDT2_FLAG ((uint32_t)0x00000040)
#define | DMA1_DTERR2_FLAG ((uint32_t)0x00000080)
#define | DMA1_GL3_FLAG ((uint32_t)0x00000100)
#define | DMA1_FDT3_FLAG ((uint32_t)0x00000200)
#define | DMA1_HDT3_FLAG ((uint32_t)0x00000400)
#define | DMA1_DTERR3_FLAG ((uint32_t)0x00000800)
#define | DMA1_GL4_FLAG ((uint32_t)0x00001000)
#define | DMA1_FDT4_FLAG ((uint32_t)0x00002000)
#define | DMA1_HDT4_FLAG ((uint32_t)0x00004000)
#define | DMA1_DTERR4_FLAG ((uint32_t)0x00008000)
#define | DMA1_GL5_FLAG ((uint32_t)0x00010000)
#define | DMA1_FDT5_FLAG ((uint32_t)0x00020000)
#define | DMA1_HDT5_FLAG ((uint32_t)0x00040000)
#define | DMA1_DTERR5_FLAG ((uint32_t)0x00080000)
#define | DMA1_GL6_FLAG ((uint32_t)0x00100000)
#define | DMA1_FDT6_FLAG ((uint32_t)0x00200000)
#define | DMA1_HDT6_FLAG ((uint32_t)0x00400000)
#define | DMA1_DTERR6_FLAG ((uint32_t)0x00800000)
#define | DMA1_GL7_FLAG ((uint32_t)0x01000000)
#define | DMA1_FDT7_FLAG ((uint32_t)0x02000000)
#define | DMA1_HDT7_FLAG ((uint32_t)0x04000000)
#define | DMA1_DTERR7_FLAG ((uint32_t)0x08000000)
#define | DMA2_GL1_FLAG ((uint32_t)0x10000001)
#define | DMA2_FDT1_FLAG ((uint32_t)0x10000002)
#define | DMA2_HDT1_FLAG ((uint32_t)0x10000004)
#define | DMA2_DTERR1_FLAG ((uint32_t)0x10000008)
#define | DMA2_GL2_FLAG ((uint32_t)0x10000010)
#define | DMA2_FDT2_FLAG ((uint32_t)0x10000020)
#define | DMA2_HDT2_FLAG ((uint32_t)0x10000040)
#define | DMA2_DTERR2_FLAG ((uint32_t)0x10000080)
#define | DMA2_GL3_FLAG ((uint32_t)0x10000100)
#define | DMA2_FDT3_FLAG ((uint32_t)0x10000200)
#define | DMA2_HDT3_FLAG ((uint32_t)0x10000400)
#define | DMA2_DTERR3_FLAG ((uint32_t)0x10000800)
#define | DMA2_GL4_FLAG ((uint32_t)0x10001000)
#define | DMA2_FDT4_FLAG ((uint32_t)0x10002000)
#define | DMA2_HDT4_FLAG ((uint32_t)0x10004000)
#define | DMA2_DTERR4_FLAG ((uint32_t)0x10008000)
#define | DMA2_GL5_FLAG ((uint32_t)0x10010000)
#define | DMA2_FDT5_FLAG ((uint32_t)0x10020000)
#define | DMA2_HDT5_FLAG ((uint32_t)0x10040000)
#define | DMA2_DTERR5_FLAG ((uint32_t)0x10080000)
#define | DMA2_GL6_FLAG ((uint32_t)0x10100000)
#define | DMA2_FDT6_FLAG ((uint32_t)0x10200000)
#define | DMA2_HDT6_FLAG ((uint32_t)0x10400000)
#define | DMA2_DTERR6_FLAG ((uint32_t)0x10800000)
#define | DMA2_GL7_FLAG ((uint32_t)0x11000000)
#define | DMA2_FDT7_FLAG ((uint32_t)0x12000000)
#define | DMA2_HDT7_FLAG ((uint32_t)0x14000000)
#define | DMA2_DTERR7_FLAG ((uint32_t)0x18000000)

Detailed Description

dma flag

Macro Definition Documentation

◆ DMA1_DTERR1_FLAG

#define DMA1_DTERR1_FLAG ((uint32_t)0x00000008)

dma1 channel1 error flag

Definition at line 84 of file at32f413_dma.h.

◆ DMA1_DTERR2_FLAG

#define DMA1_DTERR2_FLAG ((uint32_t)0x00000080)

dma1 channel2 error flag

Definition at line 88 of file at32f413_dma.h.

◆ DMA1_DTERR3_FLAG

#define DMA1_DTERR3_FLAG ((uint32_t)0x00000800)

dma1 channel3 error flag

Definition at line 92 of file at32f413_dma.h.

◆ DMA1_DTERR4_FLAG

#define DMA1_DTERR4_FLAG ((uint32_t)0x00008000)

dma1 channel4 error flag

Definition at line 96 of file at32f413_dma.h.

◆ DMA1_DTERR5_FLAG

#define DMA1_DTERR5_FLAG ((uint32_t)0x00080000)

dma1 channel5 error flag

Definition at line 100 of file at32f413_dma.h.

◆ DMA1_DTERR6_FLAG

#define DMA1_DTERR6_FLAG ((uint32_t)0x00800000)

dma1 channel6 error flag

Definition at line 104 of file at32f413_dma.h.

◆ DMA1_DTERR7_FLAG

#define DMA1_DTERR7_FLAG ((uint32_t)0x08000000)

dma1 channel7 error flag

Definition at line 108 of file at32f413_dma.h.

◆ DMA1_FDT1_FLAG

#define DMA1_FDT1_FLAG ((uint32_t)0x00000002)

dma1 channel1 full data transfer flag

Definition at line 82 of file at32f413_dma.h.

◆ DMA1_FDT2_FLAG

#define DMA1_FDT2_FLAG ((uint32_t)0x00000020)

dma1 channel2 full data transfer flag

Definition at line 86 of file at32f413_dma.h.

◆ DMA1_FDT3_FLAG

#define DMA1_FDT3_FLAG ((uint32_t)0x00000200)

dma1 channel3 full data transfer flag

Definition at line 90 of file at32f413_dma.h.

◆ DMA1_FDT4_FLAG

#define DMA1_FDT4_FLAG ((uint32_t)0x00002000)

dma1 channel4 full data transfer flag

Definition at line 94 of file at32f413_dma.h.

◆ DMA1_FDT5_FLAG

#define DMA1_FDT5_FLAG ((uint32_t)0x00020000)

dma1 channel5 full data transfer flag

Definition at line 98 of file at32f413_dma.h.

◆ DMA1_FDT6_FLAG

#define DMA1_FDT6_FLAG ((uint32_t)0x00200000)

dma1 channel6 full data transfer flag

Definition at line 102 of file at32f413_dma.h.

◆ DMA1_FDT7_FLAG

#define DMA1_FDT7_FLAG ((uint32_t)0x02000000)

dma1 channel7 full data transfer flag

Definition at line 106 of file at32f413_dma.h.

◆ DMA1_GL1_FLAG

#define DMA1_GL1_FLAG ((uint32_t)0x00000001)

dma1 channel1 global flag

Definition at line 81 of file at32f413_dma.h.

◆ DMA1_GL2_FLAG

#define DMA1_GL2_FLAG ((uint32_t)0x00000010)

dma1 channel2 global flag

Definition at line 85 of file at32f413_dma.h.

◆ DMA1_GL3_FLAG

#define DMA1_GL3_FLAG ((uint32_t)0x00000100)

dma1 channel3 global flag

Definition at line 89 of file at32f413_dma.h.

◆ DMA1_GL4_FLAG

#define DMA1_GL4_FLAG ((uint32_t)0x00001000)

dma1 channel4 global flag

Definition at line 93 of file at32f413_dma.h.

◆ DMA1_GL5_FLAG

#define DMA1_GL5_FLAG ((uint32_t)0x00010000)

dma1 channel5 global flag

Definition at line 97 of file at32f413_dma.h.

◆ DMA1_GL6_FLAG

#define DMA1_GL6_FLAG ((uint32_t)0x00100000)

dma1 channel6 global flag

Definition at line 101 of file at32f413_dma.h.

◆ DMA1_GL7_FLAG

#define DMA1_GL7_FLAG ((uint32_t)0x01000000)

dma1 channel7 global flag

Definition at line 105 of file at32f413_dma.h.

◆ DMA1_HDT1_FLAG

#define DMA1_HDT1_FLAG ((uint32_t)0x00000004)

dma1 channel1 half data transfer flag

Definition at line 83 of file at32f413_dma.h.

◆ DMA1_HDT2_FLAG

#define DMA1_HDT2_FLAG ((uint32_t)0x00000040)

dma1 channel2 half data transfer flag

Definition at line 87 of file at32f413_dma.h.

◆ DMA1_HDT3_FLAG

#define DMA1_HDT3_FLAG ((uint32_t)0x00000400)

dma1 channel3 half data transfer flag

Definition at line 91 of file at32f413_dma.h.

◆ DMA1_HDT4_FLAG

#define DMA1_HDT4_FLAG ((uint32_t)0x00004000)

dma1 channel4 half data transfer flag

Definition at line 95 of file at32f413_dma.h.

◆ DMA1_HDT5_FLAG

#define DMA1_HDT5_FLAG ((uint32_t)0x00040000)

dma1 channel5 half data transfer flag

Definition at line 99 of file at32f413_dma.h.

◆ DMA1_HDT6_FLAG

#define DMA1_HDT6_FLAG ((uint32_t)0x00400000)

dma1 channel6 half data transfer flag

Definition at line 103 of file at32f413_dma.h.

◆ DMA1_HDT7_FLAG

#define DMA1_HDT7_FLAG ((uint32_t)0x04000000)

dma1 channel7 half data transfer flag

Definition at line 107 of file at32f413_dma.h.

◆ DMA2_DTERR1_FLAG

#define DMA2_DTERR1_FLAG ((uint32_t)0x10000008)

dma2 channel1 error flag

Definition at line 113 of file at32f413_dma.h.

◆ DMA2_DTERR2_FLAG

#define DMA2_DTERR2_FLAG ((uint32_t)0x10000080)

dma2 channel2 error flag

Definition at line 117 of file at32f413_dma.h.

◆ DMA2_DTERR3_FLAG

#define DMA2_DTERR3_FLAG ((uint32_t)0x10000800)

dma2 channel3 error flag

Definition at line 121 of file at32f413_dma.h.

◆ DMA2_DTERR4_FLAG

#define DMA2_DTERR4_FLAG ((uint32_t)0x10008000)

dma2 channel4 error flag

Definition at line 125 of file at32f413_dma.h.

◆ DMA2_DTERR5_FLAG

#define DMA2_DTERR5_FLAG ((uint32_t)0x10080000)

dma2 channel5 error flag

Definition at line 129 of file at32f413_dma.h.

◆ DMA2_DTERR6_FLAG

#define DMA2_DTERR6_FLAG ((uint32_t)0x10800000)

dma2 channel6 error flag

Definition at line 133 of file at32f413_dma.h.

◆ DMA2_DTERR7_FLAG

#define DMA2_DTERR7_FLAG ((uint32_t)0x18000000)

dma2 channel7 error flag

Definition at line 137 of file at32f413_dma.h.

◆ DMA2_FDT1_FLAG

#define DMA2_FDT1_FLAG ((uint32_t)0x10000002)

dma2 channel1 full data transfer flag

Definition at line 111 of file at32f413_dma.h.

◆ DMA2_FDT2_FLAG

#define DMA2_FDT2_FLAG ((uint32_t)0x10000020)

dma2 channel2 full data transfer flag

Definition at line 115 of file at32f413_dma.h.

◆ DMA2_FDT3_FLAG

#define DMA2_FDT3_FLAG ((uint32_t)0x10000200)

dma2 channel3 full data transfer flag

Definition at line 119 of file at32f413_dma.h.

◆ DMA2_FDT4_FLAG

#define DMA2_FDT4_FLAG ((uint32_t)0x10002000)

dma2 channel4 full data transfer flag

Definition at line 123 of file at32f413_dma.h.

◆ DMA2_FDT5_FLAG

#define DMA2_FDT5_FLAG ((uint32_t)0x10020000)

dma2 channel5 full data transfer flag

Definition at line 127 of file at32f413_dma.h.

◆ DMA2_FDT6_FLAG

#define DMA2_FDT6_FLAG ((uint32_t)0x10200000)

dma2 channel6 full data transfer flag

Definition at line 131 of file at32f413_dma.h.

◆ DMA2_FDT7_FLAG

#define DMA2_FDT7_FLAG ((uint32_t)0x12000000)

dma2 channel7 full data transfer flag

Definition at line 135 of file at32f413_dma.h.

◆ DMA2_GL1_FLAG

#define DMA2_GL1_FLAG ((uint32_t)0x10000001)

dma2 channel1 global flag

Definition at line 110 of file at32f413_dma.h.

◆ DMA2_GL2_FLAG

#define DMA2_GL2_FLAG ((uint32_t)0x10000010)

dma2 channel2 global flag

Definition at line 114 of file at32f413_dma.h.

◆ DMA2_GL3_FLAG

#define DMA2_GL3_FLAG ((uint32_t)0x10000100)

dma2 channel3 global flag

Definition at line 118 of file at32f413_dma.h.

◆ DMA2_GL4_FLAG

#define DMA2_GL4_FLAG ((uint32_t)0x10001000)

dma2 channel4 global flag

Definition at line 122 of file at32f413_dma.h.

◆ DMA2_GL5_FLAG

#define DMA2_GL5_FLAG ((uint32_t)0x10010000)

dma2 channel5 global flag

Definition at line 126 of file at32f413_dma.h.

◆ DMA2_GL6_FLAG

#define DMA2_GL6_FLAG ((uint32_t)0x10100000)

dma2 channel6 global flag

Definition at line 130 of file at32f413_dma.h.

◆ DMA2_GL7_FLAG

#define DMA2_GL7_FLAG ((uint32_t)0x11000000)

dma2 channel7 global flag

Definition at line 134 of file at32f413_dma.h.

◆ DMA2_HDT1_FLAG

#define DMA2_HDT1_FLAG ((uint32_t)0x10000004)

dma2 channel1 half data transfer flag

Definition at line 112 of file at32f413_dma.h.

◆ DMA2_HDT2_FLAG

#define DMA2_HDT2_FLAG ((uint32_t)0x10000040)

dma2 channel2 half data transfer flag

Definition at line 116 of file at32f413_dma.h.

◆ DMA2_HDT3_FLAG

#define DMA2_HDT3_FLAG ((uint32_t)0x10000400)

dma2 channel3 half data transfer flag

Definition at line 120 of file at32f413_dma.h.

◆ DMA2_HDT4_FLAG

#define DMA2_HDT4_FLAG ((uint32_t)0x10004000)

dma2 channel4 half data transfer flag

Definition at line 124 of file at32f413_dma.h.

◆ DMA2_HDT5_FLAG

#define DMA2_HDT5_FLAG ((uint32_t)0x10040000)

dma2 channel5 half data transfer flag

Definition at line 128 of file at32f413_dma.h.

◆ DMA2_HDT6_FLAG

#define DMA2_HDT6_FLAG ((uint32_t)0x10400000)

dma2 channel6 half data transfer flag

Definition at line 132 of file at32f413_dma.h.

◆ DMA2_HDT7_FLAG

#define DMA2_HDT7_FLAG ((uint32_t)0x14000000)

dma2 channel7 half data transfer flag

Definition at line 136 of file at32f413_dma.h.


AT32F413 Firmwary Library: DMA_exported_types

Data Structures | Enumerations
DMA_exported_types
AT32F413_periph_driver » DMA

Data Structures

struct | dma_init_type
dma init type More...
struct | dma_type
type define dma register More...
struct | dma_channel_type
type define dma channel register all More...

Enumerations

enum dma_flexible_request_type {
DMA_FLEXIBLE_ADC1 = 0x01 , DMA_FLEXIBLE_SPI1_RX = 0x09 , DMA_FLEXIBLE_SPI1_TX = 0x0A , DMA_FLEXIBLE_SPI2_RX = 0x0B ,
DMA_FLEXIBLE_SPI2_TX = 0x0C , DMA_FLEXIBLE_UART1_RX = 0x19 , DMA_FLEXIBLE_UART1_TX = 0x1A , DMA_FLEXIBLE_UART2_RX = 0x1B ,
DMA_FLEXIBLE_UART2_TX = 0x1C , DMA_FLEXIBLE_UART3_RX = 0x1D , DMA_FLEXIBLE_UART3_TX = 0x1E , DMA_FLEXIBLE_UART4_RX = 0x1F ,
DMA_FLEXIBLE_UART4_TX = 0x20 , DMA_FLEXIBLE_UART5_RX = 0x21 , DMA_FLEXIBLE_UART5_TX = 0x22 , DMA_FLEXIBLE_I2C1_RX = 0x29 ,
DMA_FLEXIBLE_I2C1_TX = 0x2A , DMA_FLEXIBLE_I2C2_RX = 0x2B , DMA_FLEXIBLE_I2C2_TX = 0x2C , DMA_FLEXIBLE_SDIO1 = 0x31 ,
DMA_FLEXIBLE_TMR1_TRIG = 0x35 , DMA_FLEXIBLE_TMR1_HALL = 0x36 , DMA_FLEXIBLE_TMR1_OVERFLOW = 0x37 , DMA_FLEXIBLE_TMR1_CH1 = 0x38 ,
DMA_FLEXIBLE_TMR1_CH2 = 0x39 , DMA_FLEXIBLE_TMR1_CH3 = 0x3A , DMA_FLEXIBLE_TMR1_CH4 = 0x3B , DMA_FLEXIBLE_TMR2_TRIG = 0x3D ,
DMA_FLEXIBLE_TMR2_OVERFLOW = 0x3F , DMA_FLEXIBLE_TMR2_CH1 = 0x40 , DMA_FLEXIBLE_TMR2_CH2 = 0x41 , DMA_FLEXIBLE_TMR2_CH3 = 0x42 ,
DMA_FLEXIBLE_TMR2_CH4 = 0x43 , DMA_FLEXIBLE_TMR3_TRIG = 0x45 , DMA_FLEXIBLE_TMR3_OVERFLOW = 0x47 , DMA_FLEXIBLE_TMR3_CH1 = 0x48 ,
DMA_FLEXIBLE_TMR3_CH2 = 0x49 , DMA_FLEXIBLE_TMR3_CH3 = 0x4A , DMA_FLEXIBLE_TMR3_CH4 = 0x4B , DMA_FLEXIBLE_TMR4_TRIG = 0x4D ,
DMA_FLEXIBLE_TMR4_OVERFLOW = 0x4F , DMA_FLEXIBLE_TMR4_CH1 = 0x50 , DMA_FLEXIBLE_TMR4_CH2 = 0x51 , DMA_FLEXIBLE_TMR4_CH3 = 0x52 ,
DMA_FLEXIBLE_TMR4_CH4 = 0x53 , DMA_FLEXIBLE_TMR5_TRIG = 0x55 , DMA_FLEXIBLE_TMR5_OVERFLOW = 0x57 , DMA_FLEXIBLE_TMR5_CH1 = 0x58 ,
DMA_FLEXIBLE_TMR5_CH2 = 0x59 , DMA_FLEXIBLE_TMR5_CH3 = 0x5A , DMA_FLEXIBLE_TMR5_CH4 = 0x5B , DMA_FLEXIBLE_TMR8_TRIG = 0x6D ,
DMA_FLEXIBLE_TMR8_HALL = 0x6E , DMA_FLEXIBLE_TMR8_OVERFLOW = 0x6F , DMA_FLEXIBLE_TMR8_CH1 = 0x70 , DMA_FLEXIBLE_TMR8_CH2 = 0x71 ,
DMA_FLEXIBLE_TMR8_CH3 = 0x72 , DMA_FLEXIBLE_TMR8_CH4 = 0x73
}
dma flexible request type More...
enum | dma_dir_type { DMA_DIR_PERIPHERAL_TO_MEMORY = 0x0000 , DMA_DIR_MEMORY_TO_PERIPHERAL = 0x0010 , DMA_DIR_MEMORY_TO_MEMORY = 0x4000 }
dma direction type More...
enum | dma_peripheral_inc_type { DMA_PERIPHERAL_INC_DISABLE = 0x00 , DMA_PERIPHERAL_INC_ENABLE = 0x01 }
dma peripheral incremented type More...
enum | dma_memory_inc_type { DMA_MEMORY_INC_DISABLE = 0x00 , DMA_MEMORY_INC_ENABLE = 0x01 }
dma memory incremented type More...
enum | dma_peripheral_data_size_type { DMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00 , DMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01 , DMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02 }
dma peripheral data size type More...
enum | dma_memory_data_size_type { DMA_MEMORY_DATA_WIDTH_BYTE = 0x00 , DMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01 , DMA_MEMORY_DATA_WIDTH_WORD = 0x02 }
dma memory data size type More...
enum | dma_priority_level_type { DMA_PRIORITY_LOW = 0x00 , DMA_PRIORITY_MEDIUM = 0x01 , DMA_PRIORITY_HIGH = 0x02 , DMA_PRIORITY_VERY_HIGH = 0x03 }
dma priority level type More...

Detailed Description

Enumeration Type Documentation

◆ dma_dir_type

enum dma_dir_type

dma direction type

Enumerator
DMA_DIR_PERIPHERAL_TO_MEMORY | dma data transfer direction:peripheral to memory
DMA_DIR_MEMORY_TO_PERIPHERAL | dma data transfer direction:memory to peripheral
DMA_DIR_MEMORY_TO_MEMORY | dma data transfer direction:memory to memory

Definition at line 215 of file at32f413_dma.h.

◆ dma_flexible_request_type

enum dma_flexible_request_type

dma flexible request type

Enumerator
DMA_FLEXIBLE_ADC1 | adc1 flexible request id
DMA_FLEXIBLE_SPI1_RX | spi1_rx flexible request id
DMA_FLEXIBLE_SPI1_TX | spi1_tx flexible request id
DMA_FLEXIBLE_SPI2_RX | spi2_rx flexible request id
DMA_FLEXIBLE_SPI2_TX | spi2_tx flexible request id
DMA_FLEXIBLE_UART1_RX | uart1_rx flexible request id
DMA_FLEXIBLE_UART1_TX | uart1_tx flexible request id
DMA_FLEXIBLE_UART2_RX | uart2_rx flexible request id
DMA_FLEXIBLE_UART2_TX | uart2_tx flexible request id
DMA_FLEXIBLE_UART3_RX | uart3_rx flexible request id
DMA_FLEXIBLE_UART3_TX | uart3_tx flexible request id
DMA_FLEXIBLE_UART4_RX | uart4_rx flexible request id
DMA_FLEXIBLE_UART4_TX | uart4_tx flexible request id
DMA_FLEXIBLE_UART5_RX | uart5_rx flexible request id
DMA_FLEXIBLE_UART5_TX | uart5_tx flexible request id
DMA_FLEXIBLE_I2C1_RX | i2c1_rx flexible request id
DMA_FLEXIBLE_I2C1_TX | i2c1_tx flexible request id
DMA_FLEXIBLE_I2C2_RX | i2c2_rx flexible request id
DMA_FLEXIBLE_I2C2_TX | i2c2_tx flexible request id
DMA_FLEXIBLE_SDIO1 | sdio1 flexible request id
DMA_FLEXIBLE_TMR1_TRIG | tmr1_trig flexible request id
DMA_FLEXIBLE_TMR1_HALL | tmr1_hall flexible request id
DMA_FLEXIBLE_TMR1_OVERFLOW | tmr1_overflow flexible request id
DMA_FLEXIBLE_TMR1_CH1 | tmr1_ch1 flexible request id
DMA_FLEXIBLE_TMR1_CH2 | tmr1_ch2 flexible request id
DMA_FLEXIBLE_TMR1_CH3 | tmr1_ch3 flexible request id
DMA_FLEXIBLE_TMR1_CH4 | tmr1_ch4 flexible request id
DMA_FLEXIBLE_TMR2_TRIG | tmr2_trig flexible request id
DMA_FLEXIBLE_TMR2_OVERFLOW | tmr2_overflow flexible request id
DMA_FLEXIBLE_TMR2_CH1 | tmr2_ch1 flexible request id
DMA_FLEXIBLE_TMR2_CH2 | tmr2_ch2 flexible request id
DMA_FLEXIBLE_TMR2_CH3 | tmr2_ch3 flexible request id
DMA_FLEXIBLE_TMR2_CH4 | tmr2_ch4 flexible request id
DMA_FLEXIBLE_TMR3_TRIG | tmr3_trig flexible request id
DMA_FLEXIBLE_TMR3_OVERFLOW | tmr3_overflow flexible request id
DMA_FLEXIBLE_TMR3_CH1 | tmr3_ch1 flexible request id
DMA_FLEXIBLE_TMR3_CH2 | tmr3_ch2 flexible request id
DMA_FLEXIBLE_TMR3_CH3 | tmr3_ch3 flexible request id
DMA_FLEXIBLE_TMR3_CH4 | tmr3_ch4 flexible request id
DMA_FLEXIBLE_TMR4_TRIG | tmr4_trig flexible request id
DMA_FLEXIBLE_TMR4_OVERFLOW | tmr4_overflow flexible request id
DMA_FLEXIBLE_TMR4_CH1 | tmr4_ch1 flexible request id
DMA_FLEXIBLE_TMR4_CH2 | tmr4_ch2 flexible request id
DMA_FLEXIBLE_TMR4_CH3 | tmr4_ch3 flexible request id
DMA_FLEXIBLE_TMR4_CH4 | tmr4_ch4 flexible request id
DMA_FLEXIBLE_TMR5_TRIG | tmr5_trig flexible request id
DMA_FLEXIBLE_TMR5_OVERFLOW | tmr5_overflow flexible request id
DMA_FLEXIBLE_TMR5_CH1 | tmr5_ch1 flexible request id
DMA_FLEXIBLE_TMR5_CH2 | tmr5_ch2 flexible request id
DMA_FLEXIBLE_TMR5_CH3 | tmr5_ch3 flexible request id
DMA_FLEXIBLE_TMR5_CH4 | tmr5_ch4 flexible request id
DMA_FLEXIBLE_TMR8_TRIG | tmr8_trig flexible request id
DMA_FLEXIBLE_TMR8_HALL | tmr8_hall flexible request id
DMA_FLEXIBLE_TMR8_OVERFLOW | tmr8_overflow flexible request id
DMA_FLEXIBLE_TMR8_CH1 | tmr8_ch1 flexible request id
DMA_FLEXIBLE_TMR8_CH2 | tmr8_ch2 flexible request id
DMA_FLEXIBLE_TMR8_CH3 | tmr8_ch3 flexible request id
DMA_FLEXIBLE_TMR8_CH4 | tmr8_ch4 flexible request id

Definition at line 150 of file at32f413_dma.h.

◆ dma_memory_data_size_type

enum dma_memory_data_size_type

dma memory data size type

Enumerator
DMA_MEMORY_DATA_WIDTH_BYTE | dma memory databus width 8bit
DMA_MEMORY_DATA_WIDTH_HALFWORD | dma memory databus width 16bit
DMA_MEMORY_DATA_WIDTH_WORD | dma memory databus width 32bit

Definition at line 253 of file at32f413_dma.h.

◆ dma_memory_inc_type

enum dma_memory_inc_type

dma memory incremented type

Enumerator
DMA_MEMORY_INC_DISABLE | dma memory increment mode disable
DMA_MEMORY_INC_ENABLE | dma memory increment mode enable

Definition at line 234 of file at32f413_dma.h.

◆ dma_peripheral_data_size_type

enum dma_peripheral_data_size_type

dma peripheral data size type

Enumerator
DMA_PERIPHERAL_DATA_WIDTH_BYTE | dma peripheral databus width 8bit
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD | dma peripheral databus width 16bit
DMA_PERIPHERAL_DATA_WIDTH_WORD | dma peripheral databus width 32bit

Definition at line 243 of file at32f413_dma.h.

◆ dma_peripheral_inc_type

enum dma_peripheral_inc_type

dma peripheral incremented type

Enumerator
DMA_PERIPHERAL_INC_DISABLE | dma peripheral increment mode disable
DMA_PERIPHERAL_INC_ENABLE | dma peripheral increment mode enable

Definition at line 225 of file at32f413_dma.h.

◆ dma_priority_level_type

enum dma_priority_level_type

dma priority level type

Enumerator
DMA_PRIORITY_LOW | dma channel priority: low
DMA_PRIORITY_MEDIUM | dma channel priority: mediue
DMA_PRIORITY_HIGH | dma channel priority: high
DMA_PRIORITY_VERY_HIGH | dma channel priority: very high

Definition at line 263 of file at32f413_dma.h.


AT32F413 Firmwary Library: dma_init_type Struct Reference

Data Fields
dma_init_type Struct Reference
AT32F413_periph_driver » DMA » DMA_exported_types

dma init type More...

#include <at32f413_dma.h>

Data Fields

uint32_t | peripheral_base_addr
uint32_t | memory_base_addr
dma_dir_type direction
uint16_t | buffer_size
confirm_state peripheral_inc_enable
confirm_state memory_inc_enable
dma_peripheral_data_size_type peripheral_data_width
dma_memory_data_size_type memory_data_width
confirm_state loop_mode_enable
dma_priority_level_type priority

Detailed Description

dma init type

Definition at line 274 of file at32f413_dma.h.

Field Documentation

◆ buffer_size

uint16_t dma_init_type::buffer_size

counter to transfer

Definition at line 279 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ direction

dma_dir_type dma_init_type::direction

dma transmit direction, peripheral as source or as destnation

Definition at line 278 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ loop_mode_enable

confirm_state dma_init_type::loop_mode_enable

when circular mode enable, buffer size will reload if count to 0

Definition at line 284 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ memory_base_addr

uint32_t dma_init_type::memory_base_addr

base addrress for memory

Definition at line 277 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ memory_data_width

dma_memory_data_size_type dma_init_type::memory_data_width

memory data width for transmit

Definition at line 283 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ memory_inc_enable

confirm_state dma_init_type::memory_inc_enable

memory address increment after one transmit

Definition at line 281 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ peripheral_base_addr

uint32_t dma_init_type::peripheral_base_addr

base addrress for peripheral

Definition at line 276 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ peripheral_data_width

dma_peripheral_data_size_type dma_init_type::peripheral_data_width

peripheral data width for transmit

Definition at line 282 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ peripheral_inc_enable

confirm_state dma_init_type::peripheral_inc_enable

periphera address increment after one transmit

Definition at line 280 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ priority

dma_priority_level_type dma_init_type::priority

dma priority can choose from very high, high, dedium or low

Definition at line 285 of file at32f413_dma.h.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

The documentation for this struct was generated from the following file:
  • at32f413_dma.h


AT32F413 Firmwary Library: dma_type Struct Reference

Data Fields
dma_type Struct Reference
AT32F413_periph_driver » DMA » DMA_exported_types

type define dma register More...

#include <at32f413_dma.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t gf1: 1
__IO uint32_t fdtf1: 1
__IO uint32_t hdtf1: 1
__IO uint32_t dterrf1: 1
__IO uint32_t gf2: 1
__IO uint32_t fdtf2: 1
__IO uint32_t hdtf2: 1
__IO uint32_t dterrf2: 1
__IO uint32_t gf3: 1
__IO uint32_t fdtf3: 1
__IO uint32_t hdtf3: 1
__IO uint32_t dterrf3: 1
__IO uint32_t gf4: 1
__IO uint32_t fdtf4: 1
__IO uint32_t hdtf4: 1
__IO uint32_t dterrf4: 1
__IO uint32_t gf5: 1
__IO uint32_t fdtf5: 1
__IO uint32_t hdtf5: 1
__IO uint32_t dterrf5: 1
__IO uint32_t gf6: 1
__IO uint32_t fdtf6: 1
__IO uint32_t hdtf6: 1
__IO uint32_t dterrf6: 1
__IO uint32_t gf7: 1
__IO uint32_t fdtf7: 1
__IO uint32_t hdtf7: 1
__IO uint32_t dterrf7: 1
__IO uint32_t reserved1: 4
} sts_bit
};
dma sts register, offset:0x00 More...
union {
__IO uint32_t clr
struct {
__IO uint32_t gfc1: 1
__IO uint32_t fdtfc1: 1
__IO uint32_t hdtfc1: 1
__IO uint32_t dterrfc1: 1
__IO uint32_t gfc2: 1
__IO uint32_t fdtfc2: 1
__IO uint32_t hdtfc2: 1
__IO uint32_t dterrfc2: 1
__IO uint32_t gfc3: 1
__IO uint32_t fdtfc3: 1
__IO uint32_t hdtfc3: 1
__IO uint32_t dterrfc3: 1
__IO uint32_t gfc4: 1
__IO uint32_t fdtfc4: 1
__IO uint32_t hdtfc4: 1
__IO uint32_t dterrfc4: 1
__IO uint32_t gfc5: 1
__IO uint32_t fdtfc5: 1
__IO uint32_t hdtfc5: 1
__IO uint32_t dterrfc5: 1
__IO uint32_t gfc6: 1
__IO uint32_t fdtfc6: 1
__IO uint32_t hdtfc6: 1
__IO uint32_t dterrfc6: 1
__IO uint32_t gfc7: 1
__IO uint32_t fdtfc7: 1
__IO uint32_t hdtfc7: 1
__IO uint32_t dterrfc7: 1
__IO uint32_t reserved1: 4
} clr_bit
};
dma clr register, offset:0x04 More...
union {
__IO uint32_t src_sel0
struct {
__IO uint32_t ch1_src: 8
__IO uint32_t ch2_src: 8
__IO uint32_t ch3_src: 8
__IO uint32_t ch4_src: 8
} src_sel0_bit
};
dma src_sel0 register, offset:0xA0 More...
union {
__IO uint32_t src_sel1
struct {
__IO uint32_t ch5_src: 8
__IO uint32_t ch6_src: 8
__IO uint32_t ch7_src: 8
__IO uint32_t dma_flex_en: 1
__IO uint32_t reserved1: 7
} src_sel1_bit
};
dma src_sel1 register, offset:0xA4 More...

Detailed Description

type define dma register

Definition at line 291 of file at32f413_dma.h.

Field Documentation

◆

union { ... } dma_type::@337

dma sts register, offset:0x00

◆

union { ... } dma_type::@339

dma clr register, offset:0x04

◆

union { ... } dma_type::@341

dma src_sel0 register, offset:0xA0

◆

union { ... } dma_type::@343

dma src_sel1 register, offset:0xA4

◆ ch1_src

__IO uint32_t dma_type::ch1_src

Definition at line 384 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch2_src

__IO uint32_t dma_type::ch2_src

Definition at line 385 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch3_src

__IO uint32_t dma_type::ch3_src

Definition at line 386 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch4_src

__IO uint32_t dma_type::ch4_src

Definition at line 387 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch5_src

__IO uint32_t dma_type::ch5_src

Definition at line 399 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch6_src

__IO uint32_t dma_type::ch6_src

Definition at line 400 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ ch7_src

__IO uint32_t dma_type::ch7_src

Definition at line 401 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ clr

__IO uint32_t dma_type::clr

Definition at line 338 of file at32f413_dma.h.

◆

struct { ... } dma_type::clr_bit

◆ dma_flex_en

__IO uint32_t dma_type::dma_flex_en

Definition at line 402 of file at32f413_dma.h.

Referenced by dma_flexible_config().

◆ dterrf1

__IO uint32_t dma_type::dterrf1

Definition at line 304 of file at32f413_dma.h.

◆ dterrf2

__IO uint32_t dma_type::dterrf2

Definition at line 308 of file at32f413_dma.h.

◆ dterrf3

__IO uint32_t dma_type::dterrf3

Definition at line 312 of file at32f413_dma.h.

◆ dterrf4

__IO uint32_t dma_type::dterrf4

Definition at line 316 of file at32f413_dma.h.

◆ dterrf5

__IO uint32_t dma_type::dterrf5

Definition at line 320 of file at32f413_dma.h.

◆ dterrf6

__IO uint32_t dma_type::dterrf6

Definition at line 324 of file at32f413_dma.h.

◆ dterrf7

__IO uint32_t dma_type::dterrf7

Definition at line 328 of file at32f413_dma.h.

◆ dterrfc1

__IO uint32_t dma_type::dterrfc1

Definition at line 344 of file at32f413_dma.h.

◆ dterrfc2

__IO uint32_t dma_type::dterrfc2

Definition at line 348 of file at32f413_dma.h.

◆ dterrfc3

__IO uint32_t dma_type::dterrfc3

Definition at line 352 of file at32f413_dma.h.

◆ dterrfc4

__IO uint32_t dma_type::dterrfc4

Definition at line 356 of file at32f413_dma.h.

◆ dterrfc5

__IO uint32_t dma_type::dterrfc5

Definition at line 360 of file at32f413_dma.h.

◆ dterrfc6

__IO uint32_t dma_type::dterrfc6

Definition at line 364 of file at32f413_dma.h.

◆ dterrfc7

__IO uint32_t dma_type::dterrfc7

Definition at line 368 of file at32f413_dma.h.

◆ fdtf1

__IO uint32_t dma_type::fdtf1

Definition at line 302 of file at32f413_dma.h.

◆ fdtf2

__IO uint32_t dma_type::fdtf2

Definition at line 306 of file at32f413_dma.h.

◆ fdtf3

__IO uint32_t dma_type::fdtf3

Definition at line 310 of file at32f413_dma.h.

◆ fdtf4

__IO uint32_t dma_type::fdtf4

Definition at line 314 of file at32f413_dma.h.

◆ fdtf5

__IO uint32_t dma_type::fdtf5

Definition at line 318 of file at32f413_dma.h.

◆ fdtf6

__IO uint32_t dma_type::fdtf6

Definition at line 322 of file at32f413_dma.h.

◆ fdtf7

__IO uint32_t dma_type::fdtf7

Definition at line 326 of file at32f413_dma.h.

◆ fdtfc1

__IO uint32_t dma_type::fdtfc1

Definition at line 342 of file at32f413_dma.h.

◆ fdtfc2

__IO uint32_t dma_type::fdtfc2

Definition at line 346 of file at32f413_dma.h.

◆ fdtfc3

__IO uint32_t dma_type::fdtfc3

Definition at line 350 of file at32f413_dma.h.

◆ fdtfc4

__IO uint32_t dma_type::fdtfc4

Definition at line 354 of file at32f413_dma.h.

◆ fdtfc5

__IO uint32_t dma_type::fdtfc5

Definition at line 358 of file at32f413_dma.h.

◆ fdtfc6

__IO uint32_t dma_type::fdtfc6

Definition at line 362 of file at32f413_dma.h.

◆ fdtfc7

__IO uint32_t dma_type::fdtfc7

Definition at line 366 of file at32f413_dma.h.

◆ gf1

__IO uint32_t dma_type::gf1

Definition at line 301 of file at32f413_dma.h.

◆ gf2

__IO uint32_t dma_type::gf2

Definition at line 305 of file at32f413_dma.h.

◆ gf3

__IO uint32_t dma_type::gf3

Definition at line 309 of file at32f413_dma.h.

◆ gf4

__IO uint32_t dma_type::gf4

Definition at line 313 of file at32f413_dma.h.

◆ gf5

__IO uint32_t dma_type::gf5

Definition at line 317 of file at32f413_dma.h.

◆ gf6

__IO uint32_t dma_type::gf6

Definition at line 321 of file at32f413_dma.h.

◆ gf7

__IO uint32_t dma_type::gf7

Definition at line 325 of file at32f413_dma.h.

◆ gfc1

__IO uint32_t dma_type::gfc1

Definition at line 341 of file at32f413_dma.h.

◆ gfc2

__IO uint32_t dma_type::gfc2

Definition at line 345 of file at32f413_dma.h.

◆ gfc3

__IO uint32_t dma_type::gfc3

Definition at line 349 of file at32f413_dma.h.

◆ gfc4

__IO uint32_t dma_type::gfc4

Definition at line 353 of file at32f413_dma.h.

◆ gfc5

__IO uint32_t dma_type::gfc5

Definition at line 357 of file at32f413_dma.h.

◆ gfc6

__IO uint32_t dma_type::gfc6

Definition at line 361 of file at32f413_dma.h.

◆ gfc7

__IO uint32_t dma_type::gfc7

Definition at line 365 of file at32f413_dma.h.

◆ hdtf1

__IO uint32_t dma_type::hdtf1

Definition at line 303 of file at32f413_dma.h.

◆ hdtf2

__IO uint32_t dma_type::hdtf2

Definition at line 307 of file at32f413_dma.h.

◆ hdtf3

__IO uint32_t dma_type::hdtf3

Definition at line 311 of file at32f413_dma.h.

◆ hdtf4

__IO uint32_t dma_type::hdtf4

Definition at line 315 of file at32f413_dma.h.

◆ hdtf5

__IO uint32_t dma_type::hdtf5

Definition at line 319 of file at32f413_dma.h.

◆ hdtf6

__IO uint32_t dma_type::hdtf6

Definition at line 323 of file at32f413_dma.h.

◆ hdtf7

__IO uint32_t dma_type::hdtf7

Definition at line 327 of file at32f413_dma.h.

◆ hdtfc1

__IO uint32_t dma_type::hdtfc1

Definition at line 343 of file at32f413_dma.h.

◆ hdtfc2

__IO uint32_t dma_type::hdtfc2

Definition at line 347 of file at32f413_dma.h.

◆ hdtfc3

__IO uint32_t dma_type::hdtfc3

Definition at line 351 of file at32f413_dma.h.

◆ hdtfc4

__IO uint32_t dma_type::hdtfc4

Definition at line 355 of file at32f413_dma.h.

◆ hdtfc5

__IO uint32_t dma_type::hdtfc5

Definition at line 359 of file at32f413_dma.h.

◆ hdtfc6

__IO uint32_t dma_type::hdtfc6

Definition at line 363 of file at32f413_dma.h.

◆ hdtfc7

__IO uint32_t dma_type::hdtfc7

Definition at line 367 of file at32f413_dma.h.

◆ reserved1

__IO uint32_t dma_type::reserved1

reserved, offset:0x08~0x9C

Definition at line 329 of file at32f413_dma.h.

◆ src_sel0

__IO uint32_t dma_type::src_sel0

Definition at line 381 of file at32f413_dma.h.

◆

struct { ... } dma_type::src_sel0_bit

Referenced by dma_flexible_config().

◆ src_sel1

__IO uint32_t dma_type::src_sel1

Definition at line 396 of file at32f413_dma.h.

◆

struct { ... } dma_type::src_sel1_bit

Referenced by dma_flexible_config().

◆ sts

__IO uint32_t dma_type::sts

Definition at line 298 of file at32f413_dma.h.

◆

struct { ... } dma_type::sts_bit
The documentation for this struct was generated from the following file:
  • at32f413_dma.h


AT32F413 Firmwary Library: dma_channel_type Struct Reference

Data Fields
dma_channel_type Struct Reference
AT32F413_periph_driver » DMA » DMA_exported_types

type define dma channel register all More...

#include <at32f413_dma.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t chen: 1
__IO uint32_t fdtien: 1
__IO uint32_t hdtien: 1
__IO uint32_t dterrien: 1
__IO uint32_t dtd: 1
__IO uint32_t lm: 1
__IO uint32_t pincm: 1
__IO uint32_t mincm: 1
__IO uint32_t pwidth: 2
__IO uint32_t mwidth: 2
__IO uint32_t chpl: 2
__IO uint32_t m2m: 1
__IO uint32_t reserved1: 17
} ctrl_bit
};
dma ctrl register, offset:0x08+20*(x-1) x=1...7 More...
union {
__IO uint32_t dtcnt
struct {
__IO uint32_t cnt: 16
__IO uint32_t reserved1: 16
} dtcnt_bit
};
dma dtcnt register, offset:0x0C+20*(x-1) x=1...7 More...
union {
__IO uint32_t paddr
struct {
__IO uint32_t paddr: 32
} paddr_bit
};
dma cpba register, offset:0x10+20*(x-1) x=1...7 More...
union {
__IO uint32_t maddr
struct {
__IO uint32_t maddr: 32
} maddr_bit
};
dma cmba register, offset:0x14+20*(x-1) x=1...7 More...

Detailed Description

type define dma channel register all

Definition at line 411 of file at32f413_dma.h.

Field Documentation

◆

union { ... } dma_channel_type::@349

dma ctrl register, offset:0x08+20*(x-1) x=1...7

◆

union { ... } dma_channel_type::@351

dma dtcnt register, offset:0x0C+20*(x-1) x=1...7

◆

union { ... } dma_channel_type::@353

dma cpba register, offset:0x10+20*(x-1) x=1...7

◆

union { ... } dma_channel_type::@355

dma cmba register, offset:0x14+20*(x-1) x=1...7

◆ chen

__IO uint32_t dma_channel_type::chen

Definition at line 421 of file at32f413_dma.h.

Referenced by dma_channel_enable(), and dma_reset().

◆ chpl

__IO uint32_t dma_channel_type::chpl

Definition at line 431 of file at32f413_dma.h.

Referenced by dma_init().

◆ cnt

__IO uint32_t dma_channel_type::cnt

Definition at line 445 of file at32f413_dma.h.

◆ ctrl

__IO uint32_t dma_channel_type::ctrl

Definition at line 418 of file at32f413_dma.h.

Referenced by dma_init(), dma_interrupt_enable(), and dma_reset().

◆

struct { ... } dma_channel_type::ctrl_bit

Referenced by dma_channel_enable(), dma_init(), and dma_reset().

◆ dtcnt

__IO uint32_t dma_channel_type::dtcnt

Definition at line 442 of file at32f413_dma.h.

Referenced by dma_data_number_get(), dma_data_number_set(), dma_init(), and dma_reset().

◆

struct { ... } dma_channel_type::dtcnt_bit

◆ dtd

__IO uint32_t dma_channel_type::dtd

Definition at line 425 of file at32f413_dma.h.

◆ dterrien

__IO uint32_t dma_channel_type::dterrien

Definition at line 424 of file at32f413_dma.h.

◆ fdtien

__IO uint32_t dma_channel_type::fdtien

Definition at line 422 of file at32f413_dma.h.

◆ hdtien

__IO uint32_t dma_channel_type::hdtien

Definition at line 423 of file at32f413_dma.h.

◆ lm

__IO uint32_t dma_channel_type::lm

Definition at line 426 of file at32f413_dma.h.

Referenced by dma_init().

◆ m2m

__IO uint32_t dma_channel_type::m2m

Definition at line 432 of file at32f413_dma.h.

◆ maddr

__IO uint32_t dma_channel_type::maddr

Definition at line 467 of file at32f413_dma.h.

Referenced by dma_init(), and dma_reset().

◆

struct { ... } dma_channel_type::maddr_bit

◆ mincm

__IO uint32_t dma_channel_type::mincm

Definition at line 428 of file at32f413_dma.h.

Referenced by dma_init().

◆ mwidth

__IO uint32_t dma_channel_type::mwidth

Definition at line 430 of file at32f413_dma.h.

Referenced by dma_init().

◆ paddr

__IO uint32_t dma_channel_type::paddr

Definition at line 455 of file at32f413_dma.h.

Referenced by dma_init(), and dma_reset().

◆

struct { ... } dma_channel_type::paddr_bit

◆ pincm

__IO uint32_t dma_channel_type::pincm

Definition at line 427 of file at32f413_dma.h.

Referenced by dma_init().

◆ pwidth

__IO uint32_t dma_channel_type::pwidth

Definition at line 429 of file at32f413_dma.h.

Referenced by dma_init().

◆ reserved1

__IO uint32_t dma_channel_type::reserved1

Definition at line 433 of file at32f413_dma.h.

The documentation for this struct was generated from the following file:
  • at32f413_dma.h


AT32F413 Firmwary Library: DMA_exported_functions

Functions
DMA_exported_functions
AT32F413_periph_driver » DMA

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset the dmax channely registers. More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely More...
void | dma_flexible_config (dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get number of data from dtcnt register More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt More...
flag_status | dma_flag_get (uint32_t dmax_flag)
get dma flag More...
void | dma_flag_clear (uint32_t dmax_flag)
clear dma flag More...

Detailed Description

Function Documentation

◆ dma_channel_enable()

void dma_channel_enable | ( | dma_channel_type * | dmax_channely,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma channely

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
new_state (TRUE or FALSE)
Return values
None

Definition at line 198 of file at32f413_dma.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), dma_config(), dma_configuration(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), and spi_bytes_write().

◆ dma_data_number_get()

uint16_t dma_data_number_get ( dma_channel_type * dmax_channely )

get number of data from dtcnt register

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
the number of data.

Definition at line 134 of file at32f413_dma.c.

◆ dma_data_number_set()

void dma_data_number_set | ( | dma_channel_type * | dmax_channely,
 |  | uint16_t | data_number
 | ) |  |

set the number of data to be transferred

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
data_number the number of data to be transferred(0x0000~0xFFFF) transfer.
Return values
none.

Definition at line 109 of file at32f413_dma.c.

◆ dma_default_para_init()

void dma_default_para_init ( dma_init_type * dma_init_struct )

dma init config with its default value.

Parameters
dma_init_struct : pointer to a dma_init_type structure which will be initialized.
Return values
none

Definition at line 362 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_flag_clear()

void dma_flag_clear ( uint32_t dmax_flag )

clear dma flag

Parameters
dmax_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
none

Definition at line 344 of file at32f413_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), main(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flag_get()

flag_status dma_flag_get ( uint32_t dmax_flag )

get dma flag

Parameters
dmax_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
state of dma flag

Definition at line 298 of file at32f413_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), main(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flexible_config()

void dma_flexible_config | ( | dma_type * | dma_x,
 |  | uint8_t | flex_channelx,
 |  | dma_flexible_request_type | flexible_request
 | ) |  |

initialize the dma_x flexible function according to the specified parameters.

Parameters
dma_x this parameter can be one of the following values:
  • DMA1
  • DMA2
flex_channelx this parameter can be one of the following values:
  • FLEX_CHANNEL1
  • FLEX_CHANNEL2
  • FLEX_CHANNEL3
  • FLEX_CHANNEL4
  • FLEX_CHANNEL5
  • FLEX_CHANNEL6
  • FLEX_CHANNEL7
flexible_request every peripheral have specified hardware_id. this parameter can be one of the following values:
  • DMA_FLEXIBLE_ADC1 - DMA_FLEXIBLE_SPI1_RX - DMA_FLEXIBLE_SPI1_TX - DMA_FLEXIBLE_SPI2_RX
  • DMA_FLEXIBLE_SPI2_TX - DMA_FLEXIBLE_UART1_RX - DMA_FLEXIBLE_UART1_TX - DMA_FLEXIBLE_UART2_RX
  • DMA_FLEXIBLE_UART2_TX - DMA_FLEXIBLE_UART3_RX - DMA_FLEXIBLE_UART3_TX - DMA_FLEXIBLE_UART4_RX
  • DMA_FLEXIBLE_UART4_TX - DMA_FLEXIBLE_UART5_RX - DMA_FLEXIBLE_UART5_TX - DMA_FLEXIBLE_I2C1_RX
  • DMA_FLEXIBLE_I2C1_TX - DMA_FLEXIBLE_I2C2_RX - DMA_FLEXIBLE_I2C2_TX - DMA_FLEXIBLE_SDIO1
  • DMA_FLEXIBLE_TMR1_TRIG - DMA_FLEXIBLE_TMR1_HALL - DMA_FLEXIBLE_TMR1_OVERFLOW- DMA_FLEXIBLE_TMR1_CH1
  • DMA_FLEXIBLE_TMR1_CH2 - DMA_FLEXIBLE_TMR1_CH3 - DMA_FLEXIBLE_TMR1_CH4 - DMA_FLEXIBLE_TMR2_TRIG
  • DMA_FLEXIBLE_TMR2_OVERFLOW- DMA_FLEXIBLE_TMR2_CH1 - DMA_FLEXIBLE_TMR2_CH2 - DMA_FLEXIBLE_TMR2_CH3
  • DMA_FLEXIBLE_TMR2_CH4 - DMA_FLEXIBLE_TMR3_TRIG - DMA_FLEXIBLE_TMR3_OVERFLOW- DMA_FLEXIBLE_TMR3_CH1
  • DMA_FLEXIBLE_TMR3_CH2 - DMA_FLEXIBLE_TMR3_CH3 - DMA_FLEXIBLE_TMR3_CH4 - DMA_FLEXIBLE_TMR4_TRIG
  • DMA_FLEXIBLE_TMR4_OVERFLOW- DMA_FLEXIBLE_TMR4_CH1 - DMA_FLEXIBLE_TMR4_CH2 - DMA_FLEXIBLE_TMR4_CH3
  • DMA_FLEXIBLE_TMR4_CH4 - DMA_FLEXIBLE_TMR5_TRIG - DMA_FLEXIBLE_TMR5_OVERFLOW- DMA_FLEXIBLE_TMR5_CH1
  • DMA_FLEXIBLE_TMR5_CH2 - DMA_FLEXIBLE_TMR5_CH3 - DMA_FLEXIBLE_TMR5_CH4 - DMA_FLEXIBLE_TMR8_TRIG
  • DMA_FLEXIBLE_TMR8_HALL - DMA_FLEXIBLE_TMR8_OVERFLOW- DMA_FLEXIBLE_TMR8_CH1 - DMA_FLEXIBLE_TMR8_CH2
  • DMA_FLEXIBLE_TMR8_CH3 - DMA_FLEXIBLE_TMR8_CH4
Return values
none

< dma flexible channel1

< dma flexible channel2

< dma flexible channel3

< dma flexible channel4

< dma flexible channel5

< dma flexible channel6

< dma flexible channel7

Definition at line 238 of file at32f413_dma.c.

Referenced by dma_configuration(), and main().

◆ dma_init()

void dma_init | ( | dma_channel_type * | dmax_channely,
 |  | dma_init_type * | dma_init_struct
 | ) |  |

dma init

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_initstruct : pointer to a dma_init_type structure.
Return values
none

Definition at line 397 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_interrupt_enable()

void dma_interrupt_enable | ( | dma_channel_type * | dmax_channely,
 |  | uint32_t | dma_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma interrupt

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_int this parameter can be any combination of the following values:
  • DMA_FDT_INT
  • DMA_HDT_INT
  • DMA_DTERR_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 165 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), and main().

◆ dma_reset()

void dma_reset ( dma_channel_type * dmax_channely )

reset the dmax channely registers.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
none

Definition at line 64 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().


AT32F413 Firmwary Library: DMA_private_functions

Functions
DMA_private_functions
AT32F413_periph_driver » DMA

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset the dmax channely registers. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get number of data from dtcnt register More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely More...
void | dma_flexible_config (dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters. More...
flag_status | dma_flag_get (uint32_t dmax_flag)
get dma flag More...
void | dma_flag_clear (uint32_t dmax_flag)
clear dma flag More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init More...

Detailed Description

Function Documentation

◆ dma_channel_enable()

void dma_channel_enable | ( | dma_channel_type * | dmax_channely,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma channely

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
new_state (TRUE or FALSE)
Return values
None

Definition at line 198 of file at32f413_dma.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), dma_config(), dma_configuration(), i2c_dma_config(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), and spi_bytes_write().

◆ dma_data_number_get()

uint16_t dma_data_number_get ( dma_channel_type * dmax_channely )

get number of data from dtcnt register

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
the number of data.

Definition at line 134 of file at32f413_dma.c.

◆ dma_data_number_set()

void dma_data_number_set | ( | dma_channel_type * | dmax_channely,
 |  | uint16_t | data_number
 | ) |  |

set the number of data to be transferred

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
data_number the number of data to be transferred(0x0000~0xFFFF) transfer.
Return values
none.

Definition at line 109 of file at32f413_dma.c.

◆ dma_default_para_init()

void dma_default_para_init ( dma_init_type * dma_init_struct )

dma init config with its default value.

Parameters
dma_init_struct : pointer to a dma_init_type structure which will be initialized.
Return values
none

Definition at line 362 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_flag_clear()

void dma_flag_clear ( uint32_t dmax_flag )

clear dma flag

Parameters
dmax_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
none

Definition at line 344 of file at32f413_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), main(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flag_get()

flag_status dma_flag_get ( uint32_t dmax_flag )

get dma flag

Parameters
dmax_flag this parameter can be one of the following values:
  • DMA1_GL1_FLAG - DMA1_FDT1_FLAG - DMA1_HDT1_FLAG - DMA1_DTERR1_FLAG
  • DMA1_GL2_FLAG - DMA1_FDT2_FLAG - DMA1_HDT2_FLAG - DMA1_DTERR2_FLAG
  • DMA1_GL3_FLAG - DMA1_FDT3_FLAG - DMA1_HDT3_FLAG - DMA1_DTERR3_FLAG
  • DMA1_GL4_FLAG - DMA1_FDT4_FLAG - DMA1_HDT4_FLAG - DMA1_DTERR4_FLAG
  • DMA1_GL5_FLAG - DMA1_FDT5_FLAG - DMA1_HDT5_FLAG - DMA1_DTERR5_FLAG
  • DMA1_GL6_FLAG - DMA1_FDT6_FLAG - DMA1_HDT6_FLAG - DMA1_DTERR6_FLAG
  • DMA1_GL7_FLAG - DMA1_FDT7_FLAG - DMA1_HDT7_FLAG - DMA1_DTERR7_FLAG
  • DMA2_GL1_FLAG - DMA2_FDT1_FLAG - DMA2_HDT1_FLAG - DMA2_DTERR1_FLAG
  • DMA2_GL2_FLAG - DMA2_FDT2_FLAG - DMA2_HDT2_FLAG - DMA2_DTERR2_FLAG
  • DMA2_GL3_FLAG - DMA2_FDT3_FLAG - DMA2_HDT3_FLAG - DMA2_DTERR3_FLAG
  • DMA2_GL4_FLAG - DMA2_FDT4_FLAG - DMA2_HDT4_FLAG - DMA2_DTERR4_FLAG
  • DMA2_GL5_FLAG - DMA2_FDT5_FLAG - DMA2_HDT5_FLAG - DMA2_DTERR5_FLAG
  • DMA2_GL6_FLAG - DMA2_FDT6_FLAG - DMA2_HDT6_FLAG - DMA2_DTERR6_FLAG
  • DMA2_GL7_FLAG - DMA2_FDT7_FLAG - DMA2_HDT7_FLAG - DMA2_DTERR7_FLAG
Return values
state of dma flag

Definition at line 298 of file at32f413_dma.c.

Referenced by DMA1_Channel1_IRQHandler(), DMA1_Channel2_IRQHandler(), DMA1_Channel3_IRQHandler(), DMA1_Channel4_IRQHandler(), DMA2_Channel1_IRQHandler(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), main(), spi_bytes_read(), and spi_bytes_write().

◆ dma_flexible_config()

void dma_flexible_config | ( | dma_type * | dma_x,
 |  | uint8_t | flex_channelx,
 |  | dma_flexible_request_type | flexible_request
 | ) |  |

initialize the dma_x flexible function according to the specified parameters.

Parameters
dma_x this parameter can be one of the following values:
  • DMA1
  • DMA2
flex_channelx this parameter can be one of the following values:
  • FLEX_CHANNEL1
  • FLEX_CHANNEL2
  • FLEX_CHANNEL3
  • FLEX_CHANNEL4
  • FLEX_CHANNEL5
  • FLEX_CHANNEL6
  • FLEX_CHANNEL7
flexible_request every peripheral have specified hardware_id. this parameter can be one of the following values:
  • DMA_FLEXIBLE_ADC1 - DMA_FLEXIBLE_SPI1_RX - DMA_FLEXIBLE_SPI1_TX - DMA_FLEXIBLE_SPI2_RX
  • DMA_FLEXIBLE_SPI2_TX - DMA_FLEXIBLE_UART1_RX - DMA_FLEXIBLE_UART1_TX - DMA_FLEXIBLE_UART2_RX
  • DMA_FLEXIBLE_UART2_TX - DMA_FLEXIBLE_UART3_RX - DMA_FLEXIBLE_UART3_TX - DMA_FLEXIBLE_UART4_RX
  • DMA_FLEXIBLE_UART4_TX - DMA_FLEXIBLE_UART5_RX - DMA_FLEXIBLE_UART5_TX - DMA_FLEXIBLE_I2C1_RX
  • DMA_FLEXIBLE_I2C1_TX - DMA_FLEXIBLE_I2C2_RX - DMA_FLEXIBLE_I2C2_TX - DMA_FLEXIBLE_SDIO1
  • DMA_FLEXIBLE_TMR1_TRIG - DMA_FLEXIBLE_TMR1_HALL - DMA_FLEXIBLE_TMR1_OVERFLOW- DMA_FLEXIBLE_TMR1_CH1
  • DMA_FLEXIBLE_TMR1_CH2 - DMA_FLEXIBLE_TMR1_CH3 - DMA_FLEXIBLE_TMR1_CH4 - DMA_FLEXIBLE_TMR2_TRIG
  • DMA_FLEXIBLE_TMR2_OVERFLOW- DMA_FLEXIBLE_TMR2_CH1 - DMA_FLEXIBLE_TMR2_CH2 - DMA_FLEXIBLE_TMR2_CH3
  • DMA_FLEXIBLE_TMR2_CH4 - DMA_FLEXIBLE_TMR3_TRIG - DMA_FLEXIBLE_TMR3_OVERFLOW- DMA_FLEXIBLE_TMR3_CH1
  • DMA_FLEXIBLE_TMR3_CH2 - DMA_FLEXIBLE_TMR3_CH3 - DMA_FLEXIBLE_TMR3_CH4 - DMA_FLEXIBLE_TMR4_TRIG
  • DMA_FLEXIBLE_TMR4_OVERFLOW- DMA_FLEXIBLE_TMR4_CH1 - DMA_FLEXIBLE_TMR4_CH2 - DMA_FLEXIBLE_TMR4_CH3
  • DMA_FLEXIBLE_TMR4_CH4 - DMA_FLEXIBLE_TMR5_TRIG - DMA_FLEXIBLE_TMR5_OVERFLOW- DMA_FLEXIBLE_TMR5_CH1
  • DMA_FLEXIBLE_TMR5_CH2 - DMA_FLEXIBLE_TMR5_CH3 - DMA_FLEXIBLE_TMR5_CH4 - DMA_FLEXIBLE_TMR8_TRIG
  • DMA_FLEXIBLE_TMR8_HALL - DMA_FLEXIBLE_TMR8_OVERFLOW- DMA_FLEXIBLE_TMR8_CH1 - DMA_FLEXIBLE_TMR8_CH2
  • DMA_FLEXIBLE_TMR8_CH3 - DMA_FLEXIBLE_TMR8_CH4
Return values
none

< dma flexible channel1

< dma flexible channel2

< dma flexible channel3

< dma flexible channel4

< dma flexible channel5

< dma flexible channel6

< dma flexible channel7

Definition at line 238 of file at32f413_dma.c.

Referenced by dma_configuration(), and main().

◆ dma_init()

void dma_init | ( | dma_channel_type * | dmax_channely,
 |  | dma_init_type * | dma_init_struct
 | ) |  |

dma init

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_initstruct : pointer to a dma_init_type structure.
Return values
none

Definition at line 397 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ dma_interrupt_enable()

void dma_interrupt_enable | ( | dma_channel_type * | dmax_channely,
 |  | uint32_t | dma_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma interrupt

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
dma_int this parameter can be any combination of the following values:
  • DMA_FDT_INT
  • DMA_HDT_INT
  • DMA_DTERR_INT
new_state (TRUE or FALSE)
Return values
none

Definition at line 165 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_dma_config(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), and main().

◆ dma_reset()

void dma_reset ( dma_channel_type * dmax_channely )

reset the dmax channely registers.

Parameters
dmax_channely this parameter can be one of the following values:
  • DMA1_CHANNEL1
  • DMA1_CHANNEL2
  • DMA1_CHANNEL3
  • DMA1_CHANNEL4
  • DMA1_CHANNEL5
  • DMA1_CHANNEL6
  • DMA1_CHANNEL7
  • DMA2_CHANNEL1
  • DMA2_CHANNEL2
  • DMA2_CHANNEL3
  • DMA2_CHANNEL4
  • DMA2_CHANNEL5
  • DMA2_CHANNEL6
  • DMA2_CHANNEL7
Return values
none

Definition at line 64 of file at32f413_dma.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), i2c_lowlevel_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().


AT32F413 Firmwary Library: EXINT

Modules | Macros
EXINT
AT32F413_periph_driver

EXINT driver modules. More...

Modules

EXINT_lines
EXINT_exported_types
EXINT_exported_functions
EXINT_private_functions

Macros

#define EXINT ((exint_type *) EXINT_BASE)

Detailed Description

EXINT driver modules.

Macro Definition Documentation

◆ EXINT

#define EXINT ((exint_type *) EXINT_BASE)

Definition at line 198 of file at32f413_exint.h.


AT32F413 Firmwary Library: EXINT_lines

Macros
EXINT_lines
AT32F413_periph_driver » EXINT

Macros

#define | EXINT_LINE_NONE ((uint32_t)0x000000)
#define | EXINT_LINE_0 ((uint32_t)0x000001)
#define | EXINT_LINE_1 ((uint32_t)0x000002)
#define | EXINT_LINE_2 ((uint32_t)0x000004)
#define | EXINT_LINE_3 ((uint32_t)0x000008)
#define | EXINT_LINE_4 ((uint32_t)0x000010)
#define | EXINT_LINE_5 ((uint32_t)0x000020)
#define | EXINT_LINE_6 ((uint32_t)0x000040)
#define | EXINT_LINE_7 ((uint32_t)0x000080)
#define | EXINT_LINE_8 ((uint32_t)0x000100)
#define | EXINT_LINE_9 ((uint32_t)0x000200)
#define | EXINT_LINE_10 ((uint32_t)0x000400)
#define | EXINT_LINE_11 ((uint32_t)0x000800)
#define | EXINT_LINE_12 ((uint32_t)0x001000)
#define | EXINT_LINE_13 ((uint32_t)0x002000)
#define | EXINT_LINE_14 ((uint32_t)0x004000)
#define | EXINT_LINE_15 ((uint32_t)0x008000)
#define | EXINT_LINE_16 ((uint32_t)0x010000)
#define | EXINT_LINE_17 ((uint32_t)0x020000)
#define | EXINT_LINE_18 ((uint32_t)0x040000)

Detailed Description

Macro Definition Documentation

◆ EXINT_LINE_0

#define EXINT_LINE_0 ((uint32_t)0x000001)

external interrupt line 0

Definition at line 52 of file at32f413_exint.h.

◆ EXINT_LINE_1

#define EXINT_LINE_1 ((uint32_t)0x000002)

external interrupt line 1

Definition at line 53 of file at32f413_exint.h.

◆ EXINT_LINE_10

#define EXINT_LINE_10 ((uint32_t)0x000400)

external interrupt line 10

Definition at line 62 of file at32f413_exint.h.

◆ EXINT_LINE_11

#define EXINT_LINE_11 ((uint32_t)0x000800)

external interrupt line 11

Definition at line 63 of file at32f413_exint.h.

◆ EXINT_LINE_12

#define EXINT_LINE_12 ((uint32_t)0x001000)

external interrupt line 12

Definition at line 64 of file at32f413_exint.h.

◆ EXINT_LINE_13

#define EXINT_LINE_13 ((uint32_t)0x002000)

external interrupt line 13

Definition at line 65 of file at32f413_exint.h.

◆ EXINT_LINE_14

#define EXINT_LINE_14 ((uint32_t)0x004000)

external interrupt line 14

Definition at line 66 of file at32f413_exint.h.

◆ EXINT_LINE_15

#define EXINT_LINE_15 ((uint32_t)0x008000)

external interrupt line 15

Definition at line 67 of file at32f413_exint.h.

◆ EXINT_LINE_16

#define EXINT_LINE_16 ((uint32_t)0x010000)

external interrupt line 16 connected to the pvm output

Definition at line 68 of file at32f413_exint.h.

◆ EXINT_LINE_17

#define EXINT_LINE_17 ((uint32_t)0x020000)

external interrupt line 17 connected to the rtc alarm event

Definition at line 69 of file at32f413_exint.h.

◆ EXINT_LINE_18

#define EXINT_LINE_18 ((uint32_t)0x040000)

external interrupt line 18 connected to the usb fs wakeup from suspend event

Definition at line 70 of file at32f413_exint.h.

◆ EXINT_LINE_2

#define EXINT_LINE_2 ((uint32_t)0x000004)

external interrupt line 2

Definition at line 54 of file at32f413_exint.h.

◆ EXINT_LINE_3

#define EXINT_LINE_3 ((uint32_t)0x000008)

external interrupt line 3

Definition at line 55 of file at32f413_exint.h.

◆ EXINT_LINE_4

#define EXINT_LINE_4 ((uint32_t)0x000010)

external interrupt line 4

Definition at line 56 of file at32f413_exint.h.

◆ EXINT_LINE_5

#define EXINT_LINE_5 ((uint32_t)0x000020)

external interrupt line 5

Definition at line 57 of file at32f413_exint.h.

◆ EXINT_LINE_6

#define EXINT_LINE_6 ((uint32_t)0x000040)

external interrupt line 6

Definition at line 58 of file at32f413_exint.h.

◆ EXINT_LINE_7

#define EXINT_LINE_7 ((uint32_t)0x000080)

external interrupt line 7

Definition at line 59 of file at32f413_exint.h.

◆ EXINT_LINE_8

#define EXINT_LINE_8 ((uint32_t)0x000100)

external interrupt line 8

Definition at line 60 of file at32f413_exint.h.

◆ EXINT_LINE_9

#define EXINT_LINE_9 ((uint32_t)0x000200)

external interrupt line 9

Definition at line 61 of file at32f413_exint.h.

◆ EXINT_LINE_NONE

#define EXINT_LINE_NONE ((uint32_t)0x000000)

Definition at line 51 of file at32f413_exint.h.


AT32F413 Firmwary Library: EXINT_exported_types

Data Structures | Enumerations
EXINT_exported_types
AT32F413_periph_driver » EXINT

Data Structures

struct | exint_init_type
exint init type More...
struct | exint_type
type define exint register all More...

Enumerations

enum | exint_line_mode_type { EXINT_LINE_INTERRUPUT = 0x00 , EXINT_LINE_EVENT = 0x01 }
exint line mode type More...
enum | exint_polarity_config_type { EXINT_TRIGGER_RISING_EDGE = 0x00 , EXINT_TRIGGER_FALLING_EDGE = 0x01 , EXINT_TRIGGER_BOTH_EDGE = 0x02 }
exint polarity configuration type More...

Detailed Description

Enumeration Type Documentation

◆ exint_line_mode_type

enum exint_line_mode_type

exint line mode type

Enumerator
EXINT_LINE_INTERRUPUT | external interrupt line interrupt mode
EXINT_LINE_EVENT | external interrupt line event mode

Definition at line 82 of file at32f413_exint.h.

◆ exint_polarity_config_type

enum exint_polarity_config_type

exint polarity configuration type

Enumerator
EXINT_TRIGGER_RISING_EDGE | external interrupt line rising trigger mode
EXINT_TRIGGER_FALLING_EDGE | external interrupt line falling trigger mode
EXINT_TRIGGER_BOTH_EDGE | external interrupt line both rising and falling trigger mode

Definition at line 91 of file at32f413_exint.h.


AT32F413 Firmwary Library: exint_init_type Struct Reference

Data Fields
exint_init_type Struct Reference
AT32F413_periph_driver » EXINT » EXINT_exported_types

exint init type More...

#include <at32f413_exint.h>

Data Fields

exint_line_mode_type line_mode
uint32_t line_select
exint_polarity_config_type line_polarity
confirm_state line_enable

Detailed Description

exint init type

Definition at line 101 of file at32f413_exint.h.

Field Documentation

◆ line_enable

confirm_state exint_init_type::line_enable

enable or disable exint

Definition at line 106 of file at32f413_exint.h.

Referenced by button_exint_init(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ line_mode

exint_line_mode_type exint_init_type::line_mode

choose mode event or interrupt mode

Definition at line 103 of file at32f413_exint.h.

Referenced by button_exint_init(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ line_polarity

exint_polarity_config_type exint_init_type::line_polarity

select the tregger polarity, with rising edge, falling edge or both edge

Definition at line 105 of file at32f413_exint.h.

Referenced by button_exint_init(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ line_select

uint32_t exint_init_type::line_select

select the exint line, availiable for single line or multiple lines

Definition at line 104 of file at32f413_exint.h.

Referenced by button_exint_init(), exint_config(), exint_default_para_init(), exint_init(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

The documentation for this struct was generated from the following file:
  • at32f413_exint.h


AT32F413 Firmwary Library: exint_type Struct Reference

Data Fields
exint_type Struct Reference
AT32F413_periph_driver » EXINT » EXINT_exported_types

type define exint register all More...

#include <at32f413_exint.h>

Data Fields

union {
__IO uint32_t inten
struct {
__IO uint32_t intenx: 23
__IO uint32_t reserved1: 9
} inten_bit
};
exint inten register, offset:0x00 More...
union {
__IO uint32_t evten
struct {
__IO uint32_t evtenx: 23
__IO uint32_t reserved1: 9
} evten_bit
};
exint evten register, offset:0x04 More...
union {
__IO uint32_t polcfg1
struct {
__IO uint32_t rpx: 23
__IO uint32_t reserved1: 9
} polcfg1_bit
};
exint polcfg1 register, offset:0x08 More...
union {
__IO uint32_t polcfg2
struct {
__IO uint32_t fpx: 23
__IO uint32_t reserved1: 9
} polcfg2_bit
};
exint polcfg2 register, offset:0x0C More...
union {
__IO uint32_t swtrg
struct {
__IO uint32_t swtx: 23
__IO uint32_t reserved1: 9
} swtrg_bit
};
exint swtrg register, offset:0x10 More...
union {
__IO uint32_t intsts
struct {
__IO uint32_t linex: 23
__IO uint32_t reserved1: 9
} intsts_bit
};
exint intsts register, offset:0x14 More...

Detailed Description

type define exint register all

Definition at line 112 of file at32f413_exint.h.

Field Documentation

◆

union { ... } exint_type::@361

exint inten register, offset:0x00

◆

union { ... } exint_type::@363

exint evten register, offset:0x04

◆

union { ... } exint_type::@365

exint polcfg1 register, offset:0x08

◆

union { ... } exint_type::@367

exint polcfg2 register, offset:0x0C

◆

union { ... } exint_type::@369

exint swtrg register, offset:0x10

◆

union { ... } exint_type::@371

exint intsts register, offset:0x14

◆ evten

__IO uint32_t exint_type::evten

Definition at line 133 of file at32f413_exint.h.

◆

struct { ... } exint_type::evten_bit

◆ evtenx

__IO uint32_t exint_type::evtenx

Definition at line 136 of file at32f413_exint.h.

◆ fpx

__IO uint32_t exint_type::fpx

Definition at line 162 of file at32f413_exint.h.

◆ inten

__IO uint32_t exint_type::inten

Definition at line 120 of file at32f413_exint.h.

◆

struct { ... } exint_type::inten_bit

◆ intenx

__IO uint32_t exint_type::intenx

Definition at line 123 of file at32f413_exint.h.

◆ intsts

__IO uint32_t exint_type::intsts

Definition at line 185 of file at32f413_exint.h.

◆

struct { ... } exint_type::intsts_bit

◆ linex

__IO uint32_t exint_type::linex

Definition at line 188 of file at32f413_exint.h.

◆ polcfg1

__IO uint32_t exint_type::polcfg1

Definition at line 146 of file at32f413_exint.h.

◆

struct { ... } exint_type::polcfg1_bit

◆ polcfg2

__IO uint32_t exint_type::polcfg2

Definition at line 159 of file at32f413_exint.h.

◆

struct { ... } exint_type::polcfg2_bit

◆ reserved1

__IO uint32_t exint_type::reserved1

Definition at line 124 of file at32f413_exint.h.

◆ rpx

__IO uint32_t exint_type::rpx

Definition at line 149 of file at32f413_exint.h.

◆ swtrg

__IO uint32_t exint_type::swtrg

Definition at line 172 of file at32f413_exint.h.

◆

struct { ... } exint_type::swtrg_bit

◆ swtx

__IO uint32_t exint_type::swtx

Definition at line 175 of file at32f413_exint.h.

The documentation for this struct was generated from the following file:
  • at32f413_exint.h


AT32F413 Firmwary Library: EXINT_exported_functions

Functions
EXINT_exported_functions
AT32F413_periph_driver » EXINT

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

Function Documentation

◆ exint_default_para_init()

void exint_default_para_init ( exint_init_type * exint_struct )

exint default para init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 64 of file at32f413_exint.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), exint_line4_config(), and usart_configuration().

◆ exint_event_enable()

void exint_event_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint event

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
new_state new state of exint event. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 212 of file at32f413_exint.c.

◆ exint_flag_clear()

void exint_flag_clear ( uint32_t exint_line )

clear exint flag

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
none

Definition at line 126 of file at32f413_exint.c.

Referenced by button_isr(), EXINT0_IRQHandler(), EXINT4_IRQHandler(), EXINT9_5_IRQHandler(), main(), PVM_IRQHandler(), RTCAlarm_IRQHandler(), and usart_configuration().

◆ exint_flag_get()

flag_status exint_flag_get ( uint32_t exint_line )

get exint flag

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
the new state of exint flag(SET or RESET).

Definition at line 142 of file at32f413_exint.c.

Referenced by EXINT0_IRQHandler(), EXINT4_IRQHandler(), main(), and PVM_IRQHandler().

◆ exint_init()

void exint_init ( exint_init_type * exint_struct )

exint init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 78 of file at32f413_exint.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ exint_interrupt_enable()

void exint_interrupt_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint interrupt

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
new_state new state of exint interrupt. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 187 of file at32f413_exint.c.

◆ exint_reset()

void exint_reset ( void )

exint reset

Parameters
none
Return values
none

Definition at line 49 of file at32f413_exint.c.

◆ exint_software_interrupt_event_generate()

void exint_software_interrupt_event_generate ( uint32_t exint_line )

generate exint software interrupt event

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
none

Definition at line 169 of file at32f413_exint.c.

Referenced by TMR1_OVF_TMR10_IRQHandler().


AT32F413 Firmwary Library: EXINT_private_functions

Functions
EXINT_private_functions
AT32F413_periph_driver » EXINT

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

Function Documentation

◆ exint_default_para_init()

void exint_default_para_init ( exint_init_type * exint_struct )

exint default para init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 64 of file at32f413_exint.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), exint_line4_config(), and usart_configuration().

◆ exint_event_enable()

void exint_event_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint event

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
new_state new state of exint event. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 212 of file at32f413_exint.c.

◆ exint_flag_clear()

void exint_flag_clear ( uint32_t exint_line )

clear exint flag

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
none

Definition at line 126 of file at32f413_exint.c.

Referenced by button_isr(), EXINT0_IRQHandler(), EXINT4_IRQHandler(), EXINT9_5_IRQHandler(), main(), PVM_IRQHandler(), RTCAlarm_IRQHandler(), and usart_configuration().

◆ exint_flag_get()

flag_status exint_flag_get ( uint32_t exint_line )

get exint flag

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
the new state of exint flag(SET or RESET).

Definition at line 142 of file at32f413_exint.c.

Referenced by EXINT0_IRQHandler(), EXINT4_IRQHandler(), main(), and PVM_IRQHandler().

◆ exint_init()

void exint_init ( exint_init_type * exint_struct )

exint init

Parameters
exint_struct
  • to the structure of exint_init_type
Return values
none

Definition at line 78 of file at32f413_exint.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), exint_line4_config(), pvm_exint_config(), rtc_config(), and usart_configuration().

◆ exint_interrupt_enable()

void exint_interrupt_enable | ( | uint32_t | exint_line,
 |  | confirm_state | new_state
 | ) |  |

enable or disable exint interrupt

Parameters
exint_line this parameter can be any combination of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
new_state new state of exint interrupt. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 187 of file at32f413_exint.c.

◆ exint_reset()

void exint_reset ( void )

exint reset

Parameters
none
Return values
none

Definition at line 49 of file at32f413_exint.c.

◆ exint_software_interrupt_event_generate()

void exint_software_interrupt_event_generate ( uint32_t exint_line )

generate exint software interrupt event

Parameters
exint_line this parameter can be one of the following values:
  • EXINT_LINE_0
  • EXINT_LINE_1 ...
  • EXINT_LINE_17
  • EXINT_LINE_18
Return values
none

Definition at line 169 of file at32f413_exint.c.

Referenced by TMR1_OVF_TMR10_IRQHandler().


AT32F413 Firmwary Library: FLASH

Modules | Macros
FLASH
AT32F413_periph_driver

FLASH driver modules. More...

Modules

FLASH_unlock_keys
flash unlock keys
FLASH_spim_address
flash spim address
FLASH_flags
flash flag
FLASH_interrupts
flash interrupts
FLASH_slib_mask
flash slib mask
FLASH_user_system_data
flash user system data
FLASH_timeout_definition
flash timeout definition
FLASH_exported_types
FLASH_exported_functions
FLASH_private_functions

Macros

#define | FLASH ((flash_type *) FLASH_REG_BASE)
#define | USD ((usd_type *) USD_BASE)

Detailed Description

FLASH driver modules.

Macro Definition Documentation

◆ FLASH

#define FLASH ((flash_type *) FLASH_REG_BASE)

Definition at line 564 of file at32f413_flash.h.

◆ USD

#define USD ((usd_type *) USD_BASE)

Definition at line 565 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_unlock_keys

Macros
FLASH_unlock_keys
AT32F413_periph_driver » FLASH

flash unlock keys More...

Macros

#define | FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)
#define | FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)
#define | FAP_RELIEVE_KEY ((uint16_t)0x00A5)
#define | SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)

Detailed Description

flash unlock keys

Macro Definition Documentation

◆ FAP_RELIEVE_KEY

#define FAP_RELIEVE_KEY ((uint16_t)0x00A5)

flash fap relieve key val

Definition at line 55 of file at32f413_flash.h.

◆ FLASH_UNLOCK_KEY1

#define FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)

flash operation unlock order key1

Definition at line 53 of file at32f413_flash.h.

◆ FLASH_UNLOCK_KEY2

#define FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)

flash operation unlock order key2

Definition at line 54 of file at32f413_flash.h.

◆ SLIB_UNLOCK_KEY

#define SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)

flash slib operation unlock order key

Definition at line 56 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_spim_address

Macros
FLASH_spim_address
AT32F413_periph_driver » FLASH

flash spim address More...

Macros

#define FLASH_SPIM_START_ADDR ((uint32_t)0x08400000)

Detailed Description

flash spim address

Macro Definition Documentation

◆ FLASH_SPIM_START_ADDR

#define FLASH_SPIM_START_ADDR ((uint32_t)0x08400000)

flash start address of spim

Definition at line 66 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_flags

Macros
FLASH_flags
AT32F413_periph_driver » FLASH

flash flag More...

Macros

#define | FLASH_OBF_FLAG ((uint32_t)0x00000001)
#define | FLASH_ODF_FLAG ((uint32_t)0x00000020)
#define | FLASH_PRGMERR_FLAG ((uint32_t)0x00000004)
#define | FLASH_EPPERR_FLAG ((uint32_t)0x00000010)
#define | FLASH_SPIM_OBF_FLAG ((uint32_t)0x20000001)
#define | FLASH_SPIM_ODF_FLAG ((uint32_t)0x20000020)
#define | FLASH_SPIM_PRGMERR_FLAG ((uint32_t)0x20000004)
#define | FLASH_SPIM_EPPERR_FLAG ((uint32_t)0x20000010)
#define | FLASH_USDERR_FLAG ((uint32_t)0x40000001)

Detailed Description

flash flag

Macro Definition Documentation

◆ FLASH_EPPERR_FLAG

#define FLASH_EPPERR_FLAG ((uint32_t)0x00000010)

flash bank1 erase/program protection error flag

Definition at line 80 of file at32f413_flash.h.

◆ FLASH_OBF_FLAG

#define FLASH_OBF_FLAG ((uint32_t)0x00000001)

flash bank1 operate busy flag

Definition at line 77 of file at32f413_flash.h.

◆ FLASH_ODF_FLAG

#define FLASH_ODF_FLAG ((uint32_t)0x00000020)

flash bank1 operate done flag

Definition at line 78 of file at32f413_flash.h.

◆ FLASH_PRGMERR_FLAG

#define FLASH_PRGMERR_FLAG ((uint32_t)0x00000004)

flash bank1 program error flag

Definition at line 79 of file at32f413_flash.h.

◆ FLASH_SPIM_EPPERR_FLAG

#define FLASH_SPIM_EPPERR_FLAG ((uint32_t)0x20000010)

flash spim erase/program protection error flag

Definition at line 84 of file at32f413_flash.h.

◆ FLASH_SPIM_OBF_FLAG

#define FLASH_SPIM_OBF_FLAG ((uint32_t)0x20000001)

flash spim operate busy flag

Definition at line 81 of file at32f413_flash.h.

◆ FLASH_SPIM_ODF_FLAG

#define FLASH_SPIM_ODF_FLAG ((uint32_t)0x20000020)

flash spim operate done flag

Definition at line 82 of file at32f413_flash.h.

◆ FLASH_SPIM_PRGMERR_FLAG

#define FLASH_SPIM_PRGMERR_FLAG ((uint32_t)0x20000004)

flash spim program error flag

Definition at line 83 of file at32f413_flash.h.

◆ FLASH_USDERR_FLAG

#define FLASH_USDERR_FLAG ((uint32_t)0x40000001)

flash user system data error flag

Definition at line 85 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_interrupts

Macros
FLASH_interrupts
AT32F413_periph_driver » FLASH

flash interrupts More...

Macros

#define | FLASH_ERR_INT ((uint32_t)0x00000001)
#define | FLASH_ODF_INT ((uint32_t)0x00000002)
#define | FLASH_SPIM_ERR_INT ((uint32_t)0x00000010)
#define | FLASH_SPIM_ODF_INT ((uint32_t)0x00000020)

Detailed Description

flash interrupts

Macro Definition Documentation

◆ FLASH_ERR_INT

#define FLASH_ERR_INT ((uint32_t)0x00000001)

flash bank1 error interrupt

Definition at line 96 of file at32f413_flash.h.

◆ FLASH_ODF_INT

#define FLASH_ODF_INT ((uint32_t)0x00000002)

flash bank1 operate done interrupt

Definition at line 97 of file at32f413_flash.h.

◆ FLASH_SPIM_ERR_INT

#define FLASH_SPIM_ERR_INT ((uint32_t)0x00000010)

flash spim error interrupt

Definition at line 98 of file at32f413_flash.h.

◆ FLASH_SPIM_ODF_INT

#define FLASH_SPIM_ODF_INT ((uint32_t)0x00000020)

flash spim operate done interrupt

Definition at line 99 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_slib_mask

Macros
FLASH_slib_mask
AT32F413_periph_driver » FLASH

flash slib mask More...

Macros

#define | FLASH_SLIB_START_SECTOR ((uint32_t)0x000007FF)
#define | FLASH_SLIB_DATA_START_SECTOR ((uint32_t)0x003FF800)
#define | FLASH_SLIB_END_SECTOR ((uint32_t)0xFFC00000)

Detailed Description

flash slib mask

Macro Definition Documentation

◆ FLASH_SLIB_DATA_START_SECTOR

#define FLASH_SLIB_DATA_START_SECTOR ((uint32_t)0x003FF800)

flash slib d-bus area start sector

Definition at line 111 of file at32f413_flash.h.

◆ FLASH_SLIB_END_SECTOR

#define FLASH_SLIB_END_SECTOR ((uint32_t)0xFFC00000)

flash slib end sector

Definition at line 112 of file at32f413_flash.h.

◆ FLASH_SLIB_START_SECTOR

#define FLASH_SLIB_START_SECTOR ((uint32_t)0x000007FF)

flash slib start sector

Definition at line 110 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_user_system_data

Macros
FLASH_user_system_data
AT32F413_periph_driver » FLASH

flash user system data More...

Macros

#define | USD_WDT_ATO_DISABLE ((uint16_t)0x0001)
#define | USD_WDT_ATO_ENABLE ((uint16_t)0x0000)
#define | USD_DEPSLP_NO_RST ((uint16_t)0x0002)
#define | USD_DEPSLP_RST ((uint16_t)0x0000)
#define | USD_STDBY_NO_RST ((uint16_t)0x0004)
#define | USD_STDBY_RST ((uint16_t)0x0000)

Detailed Description

flash user system data

Macro Definition Documentation

◆ USD_DEPSLP_NO_RST

#define USD_DEPSLP_NO_RST ((uint16_t)0x0002)

no reset generated when entering in deepsleep

Definition at line 126 of file at32f413_flash.h.

◆ USD_DEPSLP_RST

#define USD_DEPSLP_RST ((uint16_t)0x0000)

reset generated when entering in deepsleep

Definition at line 127 of file at32f413_flash.h.

◆ USD_STDBY_NO_RST

#define USD_STDBY_NO_RST ((uint16_t)0x0004)

no reset generated when entering in standby

Definition at line 129 of file at32f413_flash.h.

◆ USD_STDBY_RST

#define USD_STDBY_RST ((uint16_t)0x0000)

reset generated when entering in standby

Definition at line 130 of file at32f413_flash.h.

◆ USD_WDT_ATO_DISABLE

#define USD_WDT_ATO_DISABLE ((uint16_t)0x0001)

wdt auto start disabled

Definition at line 123 of file at32f413_flash.h.

◆ USD_WDT_ATO_ENABLE

#define USD_WDT_ATO_ENABLE ((uint16_t)0x0000)

wdt auto start enabled

Definition at line 124 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_timeout_definition

Macros
FLASH_timeout_definition
AT32F413_periph_driver » FLASH

flash timeout definition More...

Macros

#define | ERASE_TIMEOUT ((uint32_t)0x40000000)
#define | PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | SPIM_ERASE_TIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SPIM_PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | OPERATION_TIMEOUT ((uint32_t)0x10000000)

Detailed Description

flash timeout definition

Macro Definition Documentation

◆ ERASE_TIMEOUT

#define ERASE_TIMEOUT ((uint32_t)0x40000000)

internal flash erase operation timeout

Definition at line 141 of file at32f413_flash.h.

◆ OPERATION_TIMEOUT

#define OPERATION_TIMEOUT ((uint32_t)0x10000000)

flash common operation timeout

Definition at line 145 of file at32f413_flash.h.

◆ PROGRAMMING_TIMEOUT

#define PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)

internal flash program operation timeout

Definition at line 142 of file at32f413_flash.h.

◆ SPIM_ERASE_TIMEOUT

#define SPIM_ERASE_TIMEOUT ((uint32_t)0xFFFFFFFF)

spim erase operation timeout

Definition at line 143 of file at32f413_flash.h.

◆ SPIM_PROGRAMMING_TIMEOUT

#define SPIM_PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)

spim program operation timeout

Definition at line 144 of file at32f413_flash.h.


AT32F413 Firmwary Library: FLASH_exported_types

Data Structures | Enumerations
FLASH_exported_types
AT32F413_periph_driver » FLASH

Data Structures

struct | flash_type
type define flash register all More...
struct | usd_type
user system data More...

Enumerations

enum flash_status_type {
FLASH_OPERATE_BUSY = 0x00 , FLASH_PROGRAM_ERROR = 0x01 , FLASH_EPP_ERROR = 0x02 , FLASH_OPERATE_DONE = 0x03 ,
FLASH_OPERATE_TIMEOUT = 0x04
}
flash status type More...
enum flash_spim_model_type { FLASH_SPIM_MODEL1 = 0x01 , FLASH_SPIM_MODEL2 = 0x02 }
flash spim model type More...

Detailed Description

Enumeration Type Documentation

◆ flash_spim_model_type

enum flash_spim_model_type

flash spim model type

Enumerator
FLASH_SPIM_MODEL1 | spim model 1
FLASH_SPIM_MODEL2 | spim model 2

Definition at line 170 of file at32f413_flash.h.

◆ flash_status_type

enum flash_status_type

flash status type

Enumerator
FLASH_OPERATE_BUSY | flash status is operate busy
FLASH_PROGRAM_ERROR | flash status is program error
FLASH_EPP_ERROR | flash status is epp error
FLASH_OPERATE_DONE | flash status is operate done
FLASH_OPERATE_TIMEOUT | flash status is operate timeout

Definition at line 158 of file at32f413_flash.h.


AT32F413 Firmwary Library: flash_type Struct Reference

Data Fields
flash_type Struct Reference
AT32F413_periph_driver » FLASH » FLASH_exported_types

type define flash register all More...

#include <at32f413_flash.h>

Data Fields

union {
__IO uint32_t psr
struct {
__IO uint32_t reserved1: 32
} psr_bit
};
flash psr register, offset:0x00 More...
union {
__IO uint32_t unlock
struct {
__IO uint32_t ukval: 32
} unlock_bit
};
flash unlock register, offset:0x04 More...
union {
__IO uint32_t usd_unlock
struct {
__IO uint32_t usd_ukval: 32
} usd_unlock_bit
};
flash usd unlock register, offset:0x08 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t obf: 1
__IO uint32_t reserved1: 1
__IO uint32_t prgmerr: 1
__IO uint32_t reserved2: 1
__IO uint32_t epperr: 1
__IO uint32_t odf: 1
__IO uint32_t reserved3: 26
} sts_bit
};
flash sts register, offset:0x0C More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t fprgm: 1
__IO uint32_t secers: 1
__IO uint32_t bankers: 1
__IO uint32_t reserved1: 1
__IO uint32_t usdprgm: 1
__IO uint32_t usders: 1
__IO uint32_t erstr: 1
__IO uint32_t oplk: 1
__IO uint32_t reserved2: 1
__IO uint32_t usdulks: 1
__IO uint32_t errie: 1
__IO uint32_t reserved3: 1
__IO uint32_t odfie: 1
__IO uint32_t reserved4: 19
} ctrl_bit
};
flash ctrl register, offset:0x10 More...
union {
__IO uint32_t addr
struct {
__IO uint32_t fa: 32
} addr_bit
};
flash addr register, offset:0x14 More...
union {
__IO uint32_t usd
struct {
__IO uint32_t usderr: 1
__IO uint32_t fap: 1
__IO uint32_t wdt_ato_en: 1
__IO uint32_t depslp_rst: 1
__IO uint32_t stdby_rst: 1
__IO uint32_t reserved1: 5
__IO uint32_t user_d0: 8
__IO uint32_t user_d1: 8
__IO uint32_t reserved2: 6
} usd_bit
};
flash usd register, offset:0x1C More...
union {
__IO uint32_t epps
struct {
__IO uint32_t epps: 32
} epps_bit
};
flash epps register, offset:0x20 More...
union {
__IO uint32_t unlock3
struct {
__IO uint32_t ukval: 32
} unlock3_bit
};
flash unlock3 register, offset:0x84 More...
union {
__IO uint32_t select
struct {
__IO uint32_t select: 32
} select_bit
};
flash select register, offset:0x88 More...
union {
__IO uint32_t sts3
struct {
__IO uint32_t obf: 1
__IO uint32_t reserved1: 1
__IO uint32_t prgmerr: 1
__IO uint32_t reserved2: 1
__IO uint32_t epperr: 1
__IO uint32_t odf: 1
__IO uint32_t reserved3: 26
} sts3_bit
};
flash sts3 register, offset:0x8C More...
union {
__IO uint32_t ctrl3
struct {
__IO uint32_t fprgm: 1
__IO uint32_t secers: 1
__IO uint32_t chpers: 1
__IO uint32_t reserved1: 3
__IO uint32_t erstr: 1
__IO uint32_t oplk: 1
__IO uint32_t reserved2: 2
__IO uint32_t errie: 1
__IO uint32_t reserved3: 1
__IO uint32_t odfie: 1
__IO uint32_t reserved4: 19
} ctrl3_bit
};
flash ctrl3 register, offset:0x90 More...
union {
__IO uint32_t addr3
struct {
__IO uint32_t fa: 32
} addr3_bit
};
flash addr3 register, offset:0x94 More...
union {
__IO uint32_t da
struct {
__IO uint32_t fda: 32
} da_bit
};
flash da register, offset:0x98 More...
__IO uint32_t | reserved5 [12]
flash reserved5 register, offset:0xC8~0x9C More...
union {
__IO uint32_t slib_sts0
struct {
__IO uint32_t reserved1: 3
__IO uint32_t slib_enf: 1
__IO uint32_t reserved2: 28
} slib_sts0_bit
};
flash slib_sts0 register, offset:0xCC More...
union {
__IO uint32_t slib_sts1
struct {
__IO uint32_t slib_ss: 11
__IO uint32_t slib_dat_ss: 11
__IO uint32_t slib_es: 10
} slib_sts1_bit
};
flash slib_sts1 register, offset:0xD0 More...
union {
__IO uint32_t slib_pwd_clr
struct {
__IO uint32_t slib_pclr_val: 32
} slib_pwd_clr_bit
};
flash slib_pwd_clr register, offset:0xD4 More...
union {
__IO uint32_t slib_misc_sts
struct {
__IO uint32_t slib_pwd_err: 1
__IO uint32_t slib_pwd_ok: 1
__IO uint32_t slib_ulkf: 1
__IO uint32_t reserved1: 13
__IO uint32_t slib_rcnt: 9
__IO uint32_t reserved2: 7
} slib_misc_sts_bit
};
flash slib_misc_sts register, offset:0xD8 More...
union {
__IO uint32_t slib_set_pwd
struct {
__IO uint32_t slib_pset_val: 32
} slib_set_pwd_bit
};
flash slib_set_pwd register, offset:0xDC More...
union {
__IO uint32_t slib_set_range
struct {
__IO uint32_t slib_ss_set: 11
__IO uint32_t slib_dss_set: 11
__IO uint32_t slib_es_set: 10
} slib_set_range_bit
};
flash slib_set_range register, offset:0xE0 More...
__IO uint32_t | reserved6 [3]
flash reserved6 register, offset:0xEC~0xE4 More...
union {
__IO uint32_t slib_unlock
struct {
__IO uint32_t slib_ukval: 32
} slib_unlock_bit
};
flash slib_unlock register, offset:0xF0 More...
union {
__IO uint32_t crc_ctrl
struct {
__IO uint32_t crc_ss: 12
__IO uint32_t crc_sn: 12
__IO uint32_t reserved1: 7
__IO uint32_t crc_strt: 1
} crc_ctrl_bit
};
flash crc_ctrl register, offset:0xF4 More...
union {
__IO uint32_t crc_chkr
struct {
__IO uint32_t crc_chkr: 32
} crc_chkr_bit
};
flash crc_chkr register, offset:0xF8 More...

Detailed Description

type define flash register all

Definition at line 179 of file at32f413_flash.h.

Field Documentation

◆

union { ... } flash_type::@379

flash psr register, offset:0x00

◆

union { ... } flash_type::@381

flash unlock register, offset:0x04

◆

union { ... } flash_type::@383

flash usd unlock register, offset:0x08

◆

union { ... } flash_type::@385

flash sts register, offset:0x0C

◆

union { ... } flash_type::@387

flash ctrl register, offset:0x10

◆

union { ... } flash_type::@389

flash addr register, offset:0x14

◆

union { ... } flash_type::@391

flash usd register, offset:0x1C

◆

union { ... } flash_type::@393

flash epps register, offset:0x20

◆

union { ... } flash_type::@395

flash unlock3 register, offset:0x84

◆

union { ... } flash_type::@397

flash select register, offset:0x88

◆

union { ... } flash_type::@399

flash sts3 register, offset:0x8C

◆

union { ... } flash_type::@401

flash ctrl3 register, offset:0x90

◆

union { ... } flash_type::@403

flash addr3 register, offset:0x94

◆

union { ... } flash_type::@405

flash da register, offset:0x98

◆

union { ... } flash_type::@407

flash slib_sts0 register, offset:0xCC

◆

union { ... } flash_type::@409

flash slib_sts1 register, offset:0xD0

◆

union { ... } flash_type::@411

flash slib_pwd_clr register, offset:0xD4

◆

union { ... } flash_type::@413

flash slib_misc_sts register, offset:0xD8

◆

union { ... } flash_type::@415

flash slib_set_pwd register, offset:0xDC

◆

union { ... } flash_type::@417

flash slib_set_range register, offset:0xE0

◆

union { ... } flash_type::@419

flash slib_unlock register, offset:0xF0

◆

union { ... } flash_type::@421

flash crc_ctrl register, offset:0xF4

◆

union { ... } flash_type::@423

flash crc_chkr register, offset:0xF8

◆ addr

__IO uint32_t flash_type::addr

Definition at line 265 of file at32f413_flash.h.

◆ addr3

__IO uint32_t flash_type::addr3

Definition at line 383 of file at32f413_flash.h.

◆

struct { ... } flash_type::addr3_bit

◆

struct { ... } flash_type::addr_bit

◆ bankers

__IO uint32_t flash_type::bankers

Definition at line 245 of file at32f413_flash.h.

◆ chpers

__IO uint32_t flash_type::chpers

Definition at line 366 of file at32f413_flash.h.

◆ crc_chkr

__IO uint32_t flash_type::crc_chkr

Definition at line 527 of file at32f413_flash.h.

◆

struct { ... } flash_type::crc_chkr_bit

◆ crc_ctrl

__IO uint32_t flash_type::crc_ctrl

Definition at line 512 of file at32f413_flash.h.

◆

struct { ... } flash_type::crc_ctrl_bit

◆ crc_sn

__IO uint32_t flash_type::crc_sn

Definition at line 516 of file at32f413_flash.h.

◆ crc_ss

__IO uint32_t flash_type::crc_ss

Definition at line 515 of file at32f413_flash.h.

◆ crc_strt

__IO uint32_t flash_type::crc_strt

Definition at line 518 of file at32f413_flash.h.

◆ ctrl

__IO uint32_t flash_type::ctrl

Definition at line 240 of file at32f413_flash.h.

◆ ctrl3

__IO uint32_t flash_type::ctrl3

Definition at line 361 of file at32f413_flash.h.

◆

struct { ... } flash_type::ctrl3_bit

◆

struct { ... } flash_type::ctrl_bit

◆ da

__IO uint32_t flash_type::da

Definition at line 395 of file at32f413_flash.h.

◆

struct { ... } flash_type::da_bit

◆ depslp_rst

__IO uint32_t flash_type::depslp_rst

Definition at line 288 of file at32f413_flash.h.

◆ epperr

__IO uint32_t flash_type::epperr

Definition at line 229 of file at32f413_flash.h.

◆ epps

__IO uint32_t flash_type::epps

Definition at line 302 of file at32f413_flash.h.

◆

struct { ... } flash_type::epps_bit

◆ errie

__IO uint32_t flash_type::errie

Definition at line 253 of file at32f413_flash.h.

◆ erstr

__IO uint32_t flash_type::erstr

Definition at line 249 of file at32f413_flash.h.

◆ fa

__IO uint32_t flash_type::fa

Definition at line 268 of file at32f413_flash.h.

◆ fap

__IO uint32_t flash_type::fap

Definition at line 286 of file at32f413_flash.h.

◆ fda

__IO uint32_t flash_type::fda

Definition at line 398 of file at32f413_flash.h.

◆ fprgm

__IO uint32_t flash_type::fprgm

Definition at line 243 of file at32f413_flash.h.

◆ obf

__IO uint32_t flash_type::obf

Definition at line 225 of file at32f413_flash.h.

◆ odf

__IO uint32_t flash_type::odf

Definition at line 230 of file at32f413_flash.h.

◆ odfie

__IO uint32_t flash_type::odfie

Definition at line 255 of file at32f413_flash.h.

◆ oplk

__IO uint32_t flash_type::oplk

Definition at line 250 of file at32f413_flash.h.

◆ prgmerr

__IO uint32_t flash_type::prgmerr

Definition at line 227 of file at32f413_flash.h.

◆ psr

__IO uint32_t flash_type::psr

Definition at line 186 of file at32f413_flash.h.

◆

struct { ... } flash_type::psr_bit

◆ reserved1

__IO uint32_t flash_type::reserved1

flash reserved1 register, offset:0x18

Definition at line 189 of file at32f413_flash.h.

◆ reserved2

__IO uint32_t flash_type::reserved2

flash reserved2 register, offset:0x80~0x24

Definition at line 228 of file at32f413_flash.h.

◆ reserved3

__IO uint32_t flash_type::reserved3

Definition at line 231 of file at32f413_flash.h.

◆ reserved4

__IO uint32_t flash_type::reserved4

Definition at line 256 of file at32f413_flash.h.

◆ reserved5

__IO uint32_t flash_type::reserved5[12]

flash reserved5 register, offset:0xC8~0x9C

Definition at line 405 of file at32f413_flash.h.

◆ reserved6

__IO uint32_t flash_type::reserved6[3]

flash reserved6 register, offset:0xEC~0xE4

Definition at line 493 of file at32f413_flash.h.

◆ secers

__IO uint32_t flash_type::secers

Definition at line 244 of file at32f413_flash.h.

◆ select

__IO uint32_t flash_type::select

Definition at line 331 of file at32f413_flash.h.

◆

struct { ... } flash_type::select_bit

◆ slib_dat_ss

__IO uint32_t flash_type::slib_dat_ss

Definition at line 430 of file at32f413_flash.h.

◆ slib_dss_set

__IO uint32_t flash_type::slib_dss_set

Definition at line 485 of file at32f413_flash.h.

◆ slib_enf

__IO uint32_t flash_type::slib_enf

Definition at line 416 of file at32f413_flash.h.

◆ slib_es

__IO uint32_t flash_type::slib_es

Definition at line 431 of file at32f413_flash.h.

◆ slib_es_set

__IO uint32_t flash_type::slib_es_set

Definition at line 486 of file at32f413_flash.h.

◆ slib_misc_sts

__IO uint32_t flash_type::slib_misc_sts

Definition at line 452 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_misc_sts_bit

◆ slib_pclr_val

__IO uint32_t flash_type::slib_pclr_val

Definition at line 443 of file at32f413_flash.h.

◆ slib_pset_val

__IO uint32_t flash_type::slib_pset_val

Definition at line 472 of file at32f413_flash.h.

◆ slib_pwd_clr

__IO uint32_t flash_type::slib_pwd_clr

Definition at line 440 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_pwd_clr_bit

◆ slib_pwd_err

__IO uint32_t flash_type::slib_pwd_err

Definition at line 455 of file at32f413_flash.h.

◆ slib_pwd_ok

__IO uint32_t flash_type::slib_pwd_ok

Definition at line 456 of file at32f413_flash.h.

◆ slib_rcnt

__IO uint32_t flash_type::slib_rcnt

Definition at line 459 of file at32f413_flash.h.

◆ slib_set_pwd

__IO uint32_t flash_type::slib_set_pwd

Definition at line 469 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_set_pwd_bit

◆ slib_set_range

__IO uint32_t flash_type::slib_set_range

Definition at line 481 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_set_range_bit

◆ slib_ss

__IO uint32_t flash_type::slib_ss

Definition at line 429 of file at32f413_flash.h.

◆ slib_ss_set

__IO uint32_t flash_type::slib_ss_set

Definition at line 484 of file at32f413_flash.h.

◆ slib_sts0

__IO uint32_t flash_type::slib_sts0

Definition at line 412 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_sts0_bit

◆ slib_sts1

__IO uint32_t flash_type::slib_sts1

Definition at line 426 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_sts1_bit

◆ slib_ukval

__IO uint32_t flash_type::slib_ukval

Definition at line 503 of file at32f413_flash.h.

◆ slib_ulkf

__IO uint32_t flash_type::slib_ulkf

Definition at line 457 of file at32f413_flash.h.

◆ slib_unlock

__IO uint32_t flash_type::slib_unlock

Definition at line 500 of file at32f413_flash.h.

◆

struct { ... } flash_type::slib_unlock_bit

◆ stdby_rst

__IO uint32_t flash_type::stdby_rst

Definition at line 289 of file at32f413_flash.h.

◆ sts

__IO uint32_t flash_type::sts

Definition at line 222 of file at32f413_flash.h.

◆ sts3

__IO uint32_t flash_type::sts3

Definition at line 343 of file at32f413_flash.h.

◆

struct { ... } flash_type::sts3_bit

◆

struct { ... } flash_type::sts_bit

◆ ukval

__IO uint32_t flash_type::ukval

Definition at line 201 of file at32f413_flash.h.

◆ unlock

__IO uint32_t flash_type::unlock

Definition at line 198 of file at32f413_flash.h.

◆ unlock3

__IO uint32_t flash_type::unlock3

Definition at line 319 of file at32f413_flash.h.

◆

struct { ... } flash_type::unlock3_bit

◆

struct { ... } flash_type::unlock_bit

◆ usd

__IO uint32_t flash_type::usd

Definition at line 282 of file at32f413_flash.h.

◆

struct { ... } flash_type::usd_bit

◆ usd_ukval

__IO uint32_t flash_type::usd_ukval

Definition at line 213 of file at32f413_flash.h.

◆ usd_unlock

__IO uint32_t flash_type::usd_unlock

Definition at line 210 of file at32f413_flash.h.

◆

struct { ... } flash_type::usd_unlock_bit

◆ usderr

__IO uint32_t flash_type::usderr

Definition at line 285 of file at32f413_flash.h.

◆ usders

__IO uint32_t flash_type::usders

Definition at line 248 of file at32f413_flash.h.

◆ usdprgm

__IO uint32_t flash_type::usdprgm

Definition at line 247 of file at32f413_flash.h.

◆ usdulks

__IO uint32_t flash_type::usdulks

Definition at line 252 of file at32f413_flash.h.

◆ user_d0

__IO uint32_t flash_type::user_d0

Definition at line 291 of file at32f413_flash.h.

◆ user_d1

__IO uint32_t flash_type::user_d1

Definition at line 292 of file at32f413_flash.h.

◆ wdt_ato_en

__IO uint32_t flash_type::wdt_ato_en

Definition at line 287 of file at32f413_flash.h.

The documentation for this struct was generated from the following file:
  • at32f413_flash.h


AT32F413 Firmwary Library: usd_type Struct Reference

Data Fields
usd_type Struct Reference
AT32F413_periph_driver » FLASH » FLASH_exported_types

user system data More...

#include <at32f413_flash.h>

Data Fields

__IO uint16_t | fap
__IO uint16_t | ssb
__IO uint16_t | data0
__IO uint16_t | data1
__IO uint16_t | epp0
__IO uint16_t | epp1
__IO uint16_t | epp2
__IO uint16_t | epp3
__IO uint16_t | eopb0
__IO uint16_t | reserved
__IO uint16_t | data2
__IO uint16_t | data3
__IO uint16_t | data4
__IO uint16_t | data5
__IO uint16_t | data6
__IO uint16_t | data7
__IO uint16_t | ext_flash_key [8]

Detailed Description

user system data

Definition at line 539 of file at32f413_flash.h.

Field Documentation

◆ data0

__IO uint16_t usd_type::data0

Definition at line 543 of file at32f413_flash.h.

◆ data1

__IO uint16_t usd_type::data1

Definition at line 544 of file at32f413_flash.h.

◆ data2

__IO uint16_t usd_type::data2

Definition at line 551 of file at32f413_flash.h.

◆ data3

__IO uint16_t usd_type::data3

Definition at line 552 of file at32f413_flash.h.

◆ data4

__IO uint16_t usd_type::data4

Definition at line 553 of file at32f413_flash.h.

◆ data5

__IO uint16_t usd_type::data5

Definition at line 554 of file at32f413_flash.h.

◆ data6

__IO uint16_t usd_type::data6

Definition at line 555 of file at32f413_flash.h.

◆ data7

__IO uint16_t usd_type::data7

Definition at line 556 of file at32f413_flash.h.

◆ eopb0

__IO uint16_t usd_type::eopb0

Definition at line 549 of file at32f413_flash.h.

◆ epp0

__IO uint16_t usd_type::epp0

Definition at line 545 of file at32f413_flash.h.

◆ epp1

__IO uint16_t usd_type::epp1

Definition at line 546 of file at32f413_flash.h.

◆ epp2

__IO uint16_t usd_type::epp2

Definition at line 547 of file at32f413_flash.h.

◆ epp3

__IO uint16_t usd_type::epp3

Definition at line 548 of file at32f413_flash.h.

◆ ext_flash_key

__IO uint16_t usd_type::ext_flash_key[8]

Definition at line 557 of file at32f413_flash.h.

◆ fap

__IO uint16_t usd_type::fap

Definition at line 541 of file at32f413_flash.h.

◆ reserved

__IO uint16_t usd_type::reserved

Definition at line 550 of file at32f413_flash.h.

◆ ssb

__IO uint16_t usd_type::ssb

Definition at line 542 of file at32f413_flash.h.

The documentation for this struct was generated from the following file:
  • at32f413_flash.h


AT32F413 Firmwary Library: FLASH_exported_functions

Functions
FLASH_exported_functions
AT32F413_periph_driver » FLASH

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_spim_operation_status_get (void)
return the flash spim operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_spim_operation_wait_for (uint32_t time_out)
wait for flash spim operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_spim_unlock (void)
unlock the flash spim controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_spim_lock (void)
lock the flash spim controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_spim_all_erase (void)
erase flash spim sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
void | flash_spim_model_select (flash_spim_model_type mode)
select spim supports extended spi flash chip model. More...
void | flash_spim_encryption_range_set (uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_datstart_sector_get (void)
get the data start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...

Detailed Description

Function Documentation

◆ flash_byte_program()

flash_status_type flash_byte_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a byte at a specified address.

Note
this function cannot be used to program spim.
Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 533 of file at32f413_flash.c.

Referenced by flash_write_data(), and msc_disk_write().

◆ flash_crc_calibrate()

uint32_t flash_crc_calibrate | ( | uint32_t | start_sector,
 |  | uint32_t | sector_cnt
 | ) |  |

flash crc calibration in main block.

Parameters
start_sector crc calibration start sector number sector_cnt: crc calibration sector count
Return values
uint32 crc calibration result

< flash common operation timeout

Definition at line 935 of file at32f413_flash.c.

◆ flash_epp_set()

flash_status_type flash_epp_set ( uint32_t * sector_bits )

config erase/program protection for the desired sectors.

Parameters
sector_bits the pointer of the address of the sectors to be erase/program protected. general every bit is used to protect the 4KB bytes, and the last one bit is used to protect the rest.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 594 of file at32f413_flash.c.

◆ flash_epp_status_get()

void flash_epp_status_get ( uint32_t * sector_bits )

return the flash erase/program protection status.

Parameters
sector_bits pointer to get the epps register.
Return values
none

Definition at line 648 of file at32f413_flash.c.

◆ flash_fap_enable()

flash_status_type flash_fap_enable ( confirm_state new_state )

enable or disable the flash access protection.

Note
if the user has already programmed the other user system data before calling this function, must re-program them since this function erase all user system data.
Parameters
new_state new state of the flash access protection. this parameter can be: TRUE or FALSE.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash erase operation timeout

Definition at line 663 of file at32f413_flash.c.

◆ flash_fap_status_get()

flag_status flash_fap_status_get ( void )

check the flash access protection status.

Parameters
none
Return values
flash access protection status(SET or RESET)

Definition at line 707 of file at32f413_flash.c.

Referenced by flash_user_system_data_erase().

◆ flash_flag_clear()

void flash_flag_clear ( uint32_t flash_flag )

clear the flash flag.

Parameters
flash_flag specifies the flash flags to clear. this parameter can be any combination of the following values:
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_SPIM_ODF_FLAG
  • FLASH_SPIM_PRGMERR_FLAG
  • FLASH_SPIM_EPPERR_FLAG
Return values
none

Definition at line 98 of file at32f413_flash.c.

Referenced by FLASH_IRQHandler().

◆ flash_flag_get()

flag_status flash_flag_get ( uint32_t flash_flag )

check whether the specified flash flag is set or not.

Parameters
flash_flag specifies the flash flag to check. this parameter can be one of flash flag status:
  • FLASH_OBF_FLAG
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_SPIM_OBF_FLAG
  • FLASH_SPIM_ODF_FLAG
  • FLASH_SPIM_PRGMERR_FLAG
  • FLASH_SPIM_EPPERR_FLAG
  • FLASH_USDERR_FLAG
Return values
the new state of flash_flag (SET or RESET).

Definition at line 59 of file at32f413_flash.c.

Referenced by FLASH_IRQHandler(), and spim_init().

◆ flash_halfword_program()

flash_status_type flash_halfword_program | ( | uint32_t | address,
 |  | uint16_t | data
 | ) |  |

program a halfword at a specified address.

Parameters
address | specifies the address to be programmed, halfword alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< spim program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 485 of file at32f413_flash.c.

Referenced by flash_2kb_write(), and flash_write_nocheck().

◆ flash_internal_all_erase()

flash_status_type flash_internal_all_erase ( void )

erase flash all internal sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

< internal flash erase operation timeout

Definition at line 325 of file at32f413_flash.c.

◆ flash_interrupt_enable()

void flash_interrupt_enable | ( | uint32_t | flash_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified flash interrupts.

Parameters
flash_int specifies the flash interrupt sources to be enabled or disabled. this parameter can be any combination of the following values:
  • FLASH_ERR_INT
  • FLASH_ODF_INT
  • FLASH_SPIM_ERR_INT
  • FLASH_SPIM_ODF_INT
new_state new state of the specified flash interrupts. this parameter can be: TRUE or FALSE.
Return values
none

< flash bank1 error interrupt

< flash bank1 operate done interrupt

< flash spim error interrupt

< flash spim operate done interrupt

Definition at line 781 of file at32f413_flash.c.

Referenced by config_flash_interrupt().

◆ flash_lock()

void flash_lock ( void )

lock the flash controller.

Parameters
none
Return values
none

Definition at line 251 of file at32f413_flash.c.

Referenced by config_flash_interrupt(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), and msc_disk_write().

◆ flash_operation_status_get()

flash_status_type flash_operation_status_get ( void )

return the flash operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 122 of file at32f413_flash.c.

Referenced by flash_operation_wait_for().

◆ flash_operation_wait_for()

flash_status_type flash_operation_wait_for ( uint32_t time_out )

wait for flash operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 180 of file at32f413_flash.c.

Referenced by flash_byte_program(), flash_crc_calibrate(), flash_epp_set(), flash_fap_enable(), flash_halfword_program(), flash_internal_all_erase(), flash_sector_erase(), flash_slib_disable(), flash_slib_enable(), flash_ssb_set(), flash_user_system_data_erase(), flash_user_system_data_program(), and flash_word_program().

◆ flash_sector_erase()

flash_status_type flash_sector_erase ( uint32_t sector_address )

erase a specified flash sector.

Parameters
sector_address the sector address to be erased.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim erase operation timeout

< spim erase operation timeout

< internal flash erase operation timeout

< internal flash erase operation timeout

Definition at line 272 of file at32f413_flash.c.

Referenced by flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_erase_sector(), iap_init(), msc_disk_write(), slib_enable(), and spim_operate().

◆ flash_slib_datstart_sector_get()

uint16_t flash_slib_datstart_sector_get ( void )

get the data start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 914 of file at32f413_flash.c.

◆ flash_slib_disable()

error_status flash_slib_disable ( uint32_t pwd )

disable slib when slib enabled.

Parameters
pwd slib password
Return values
success or error

< internal flash erase operation timeout

Definition at line 859 of file at32f413_flash.c.

◆ flash_slib_enable()

flash_status_type flash_slib_enable | ( | uint32_t | pwd,
 |  | uint16_t | start_sector,
 |  | uint16_t | data_start_sector,
 |  | uint16_t | end_sector
 | ) |  |

enable security library function.

Parameters
pwd slib password start_sector: security library start sector data_start_sector: security library d-bus area start sector end_sector: security library end sector
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< flash slib operation unlock order key

< flash slib d-bus area start sector

< flash slib end sector

< flash slib start sector

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 824 of file at32f413_flash.c.

Referenced by slib_enable().

◆ flash_slib_end_sector_get()

uint16_t flash_slib_end_sector_get ( void )

get the end sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 924 of file at32f413_flash.c.

◆ flash_slib_remaining_count_get()

uint32_t flash_slib_remaining_count_get ( void )

get remaining count of slib(range: 256~0).

Parameters
none
Return values
uint32_t

Definition at line 881 of file at32f413_flash.c.

◆ flash_slib_start_sector_get()

uint16_t flash_slib_start_sector_get ( void )

get the start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 904 of file at32f413_flash.c.

◆ flash_slib_state_get()

flag_status flash_slib_state_get ( void )

get the slib state.

Parameters
none
Return values
SET or RESET

Definition at line 891 of file at32f413_flash.c.

Referenced by main().

◆ flash_spim_all_erase()

flash_status_type flash_spim_all_erase ( void )

erase flash spim sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< spim erase operation timeout

< spim erase operation timeout

Definition at line 353 of file at32f413_flash.c.

◆ flash_spim_encryption_range_set()

void flash_spim_encryption_range_set ( uint32_t decode_address )

set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption.

Parameters
decode_address the end address of encrypted data in spim
Return values
none

Definition at line 810 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_spim_lock()

void flash_spim_lock ( void )

lock the flash spim controller.

Parameters
none
Return values
none

Definition at line 261 of file at32f413_flash.c.

◆ flash_spim_model_select()

void flash_spim_model_select ( flash_spim_model_type mode )

select spim supports extended spi flash chip model.

Parameters
mode the extended spi flash model
Return values
none

Definition at line 798 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_spim_operation_status_get()

flash_status_type flash_spim_operation_status_get ( void )

return the flash spim operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 151 of file at32f413_flash.c.

Referenced by flash_spim_operation_wait_for().

◆ flash_spim_operation_wait_for()

flash_status_type flash_spim_operation_wait_for ( uint32_t time_out )

wait for flash spim operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 205 of file at32f413_flash.c.

Referenced by flash_halfword_program(), flash_sector_erase(), flash_spim_all_erase(), and flash_word_program().

◆ flash_spim_unlock()

void flash_spim_unlock ( void )

unlock the flash spim controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 240 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_ssb_set()

flash_status_type flash_ssb_set ( uint8_t usd_ssb )

program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst.

Parameters
usd_ssb the system setting byte
Note
this parameter usd_ssb must contain a combination of all the following 3 types of data type 1: wdt_ato_en, select the wdt auto start this data can be one of the following values:
  • USD_WDT_ATO_DISABLE: disable wdt auto start
  • USD_WDT_ATO_ENABLE: enable wdt auto start type 2: depslp_rst, reset event when entering deepsleep mode. this data can be one of the following values:
  • USD_DEPSLP_NO_RST: no reset generated when entering in deepsleep
  • USD_DEPSLP_RST: reset generated when entering in deepsleep type 3: stdby_rst, reset event when entering standby mode. this data can be one of the following values:
  • USD_STDBY_NO_RST: no reset generated when entering in standby
  • USD_STDBY_RST: reset generated when entering in standby
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 731 of file at32f413_flash.c.

◆ flash_ssb_status_get()

uint8_t flash_ssb_status_get ( void )

return the flash system setting byte status.

Parameters
none
Return values
values from flash_usd register: wdt_ato_en(bit0), depslp_rst(bit1) and stdby_rst(bit2).

Definition at line 763 of file at32f413_flash.c.

◆ flash_unlock()

void flash_unlock ( void )

unlock the flash controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 229 of file at32f413_flash.c.

Referenced by config_flash_interrupt(), extend_sram(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), msc_disk_write(), and slib_enable().

◆ flash_user_system_data_erase()

flash_status_type flash_user_system_data_erase ( void )

erase the flash user system data.

Note
this functions erases all user system data except the fap byte.
Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash fap relieve key val

< internal flash erase operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash program operation timeout

Definition at line 382 of file at32f413_flash.c.

Referenced by extend_sram().

◆ flash_user_system_data_program()

flash_status_type flash_user_system_data_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a halfword at a specified user system data address.

Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 560 of file at32f413_flash.c.

Referenced by extend_sram().

◆ flash_word_program()

flash_status_type flash_word_program | ( | uint32_t | address,
 |  | uint32_t | data
 | ) |  |

program a word at a specified address.

Parameters
address | specifies the address to be programmed, word alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< spim program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 438 of file at32f413_flash.c.

Referenced by flash_fat16_set_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_set_upgrade_flag(), slib_enable(), and spim_operate().


AT32F413 Firmwary Library: FLASH_private_functions

Functions
FLASH_private_functions
AT32F413_periph_driver » FLASH

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_spim_operation_status_get (void)
return the flash spim operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_spim_operation_wait_for (uint32_t time_out)
wait for flash spim operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_spim_unlock (void)
unlock the flash spim controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_spim_lock (void)
lock the flash spim controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_spim_all_erase (void)
erase flash spim sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
void | flash_spim_model_select (flash_spim_model_type mode)
select spim supports extended spi flash chip model. More...
void | flash_spim_encryption_range_set (uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_datstart_sector_get (void)
get the data start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...

Detailed Description

Function Documentation

◆ flash_byte_program()

flash_status_type flash_byte_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a byte at a specified address.

Note
this function cannot be used to program spim.
Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 533 of file at32f413_flash.c.

Referenced by flash_write_data(), and msc_disk_write().

◆ flash_crc_calibrate()

uint32_t flash_crc_calibrate | ( | uint32_t | start_sector,
 |  | uint32_t | sector_cnt
 | ) |  |

flash crc calibration in main block.

Parameters
start_sector crc calibration start sector number sector_cnt: crc calibration sector count
Return values
uint32 crc calibration result

< flash common operation timeout

Definition at line 935 of file at32f413_flash.c.

◆ flash_epp_set()

flash_status_type flash_epp_set ( uint32_t * sector_bits )

config erase/program protection for the desired sectors.

Parameters
sector_bits the pointer of the address of the sectors to be erase/program protected. general every bit is used to protect the 4KB bytes, and the last one bit is used to protect the rest.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 594 of file at32f413_flash.c.

◆ flash_epp_status_get()

void flash_epp_status_get ( uint32_t * sector_bits )

return the flash erase/program protection status.

Parameters
sector_bits pointer to get the epps register.
Return values
none

Definition at line 648 of file at32f413_flash.c.

◆ flash_fap_enable()

flash_status_type flash_fap_enable ( confirm_state new_state )

enable or disable the flash access protection.

Note
if the user has already programmed the other user system data before calling this function, must re-program them since this function erase all user system data.
Parameters
new_state new state of the flash access protection. this parameter can be: TRUE or FALSE.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash erase operation timeout

Definition at line 663 of file at32f413_flash.c.

◆ flash_fap_status_get()

flag_status flash_fap_status_get ( void )

check the flash access protection status.

Parameters
none
Return values
flash access protection status(SET or RESET)

Definition at line 707 of file at32f413_flash.c.

Referenced by flash_user_system_data_erase().

◆ flash_flag_clear()

void flash_flag_clear ( uint32_t flash_flag )

clear the flash flag.

Parameters
flash_flag specifies the flash flags to clear. this parameter can be any combination of the following values:
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_SPIM_ODF_FLAG
  • FLASH_SPIM_PRGMERR_FLAG
  • FLASH_SPIM_EPPERR_FLAG
Return values
none

Definition at line 98 of file at32f413_flash.c.

Referenced by FLASH_IRQHandler().

◆ flash_flag_get()

flag_status flash_flag_get ( uint32_t flash_flag )

check whether the specified flash flag is set or not.

Parameters
flash_flag specifies the flash flag to check. this parameter can be one of flash flag status:
  • FLASH_OBF_FLAG
  • FLASH_ODF_FLAG
  • FLASH_PRGMERR_FLAG
  • FLASH_EPPERR_FLAG
  • FLASH_SPIM_OBF_FLAG
  • FLASH_SPIM_ODF_FLAG
  • FLASH_SPIM_PRGMERR_FLAG
  • FLASH_SPIM_EPPERR_FLAG
  • FLASH_USDERR_FLAG
Return values
the new state of flash_flag (SET or RESET).

Definition at line 59 of file at32f413_flash.c.

Referenced by FLASH_IRQHandler(), and spim_init().

◆ flash_halfword_program()

flash_status_type flash_halfword_program | ( | uint32_t | address,
 |  | uint16_t | data
 | ) |  |

program a halfword at a specified address.

Parameters
address | specifies the address to be programmed, halfword alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< spim program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 485 of file at32f413_flash.c.

Referenced by flash_2kb_write(), and flash_write_nocheck().

◆ flash_internal_all_erase()

flash_status_type flash_internal_all_erase ( void )

erase flash all internal sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash erase operation timeout

< internal flash erase operation timeout

Definition at line 325 of file at32f413_flash.c.

◆ flash_interrupt_enable()

void flash_interrupt_enable | ( | uint32_t | flash_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified flash interrupts.

Parameters
flash_int specifies the flash interrupt sources to be enabled or disabled. this parameter can be any combination of the following values:
  • FLASH_ERR_INT
  • FLASH_ODF_INT
  • FLASH_SPIM_ERR_INT
  • FLASH_SPIM_ODF_INT
new_state new state of the specified flash interrupts. this parameter can be: TRUE or FALSE.
Return values
none

< flash bank1 error interrupt

< flash bank1 operate done interrupt

< flash spim error interrupt

< flash spim operate done interrupt

Definition at line 781 of file at32f413_flash.c.

Referenced by config_flash_interrupt().

◆ flash_lock()

void flash_lock ( void )

lock the flash controller.

Parameters
none
Return values
none

Definition at line 251 of file at32f413_flash.c.

Referenced by config_flash_interrupt(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), and msc_disk_write().

◆ flash_operation_status_get()

flash_status_type flash_operation_status_get ( void )

return the flash operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 122 of file at32f413_flash.c.

Referenced by flash_operation_wait_for().

◆ flash_operation_wait_for()

flash_status_type flash_operation_wait_for ( uint32_t time_out )

wait for flash operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 180 of file at32f413_flash.c.

Referenced by flash_byte_program(), flash_crc_calibrate(), flash_epp_set(), flash_fap_enable(), flash_halfword_program(), flash_internal_all_erase(), flash_sector_erase(), flash_slib_disable(), flash_slib_enable(), flash_ssb_set(), flash_user_system_data_erase(), flash_user_system_data_program(), and flash_word_program().

◆ flash_sector_erase()

flash_status_type flash_sector_erase ( uint32_t sector_address )

erase a specified flash sector.

Parameters
sector_address the sector address to be erased.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim erase operation timeout

< spim erase operation timeout

< internal flash erase operation timeout

< internal flash erase operation timeout

Definition at line 272 of file at32f413_flash.c.

Referenced by flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_erase_sector(), iap_init(), msc_disk_write(), slib_enable(), and spim_operate().

◆ flash_slib_datstart_sector_get()

uint16_t flash_slib_datstart_sector_get ( void )

get the data start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 914 of file at32f413_flash.c.

◆ flash_slib_disable()

error_status flash_slib_disable ( uint32_t pwd )

disable slib when slib enabled.

Parameters
pwd slib password
Return values
success or error

< internal flash erase operation timeout

Definition at line 859 of file at32f413_flash.c.

◆ flash_slib_enable()

flash_status_type flash_slib_enable | ( | uint32_t | pwd,
 |  | uint16_t | start_sector,
 |  | uint16_t | data_start_sector,
 |  | uint16_t | end_sector
 | ) |  |

enable security library function.

Parameters
pwd slib password start_sector: security library start sector data_start_sector: security library d-bus area start sector end_sector: security library end sector
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< flash slib operation unlock order key

< flash slib d-bus area start sector

< flash slib end sector

< flash slib start sector

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 824 of file at32f413_flash.c.

Referenced by slib_enable().

◆ flash_slib_end_sector_get()

uint16_t flash_slib_end_sector_get ( void )

get the end sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 924 of file at32f413_flash.c.

◆ flash_slib_remaining_count_get()

uint32_t flash_slib_remaining_count_get ( void )

get remaining count of slib(range: 256~0).

Parameters
none
Return values
uint32_t

Definition at line 881 of file at32f413_flash.c.

◆ flash_slib_start_sector_get()

uint16_t flash_slib_start_sector_get ( void )

get the start sector of slib.

Parameters
none
Return values
uint16_t

Definition at line 904 of file at32f413_flash.c.

◆ flash_slib_state_get()

flag_status flash_slib_state_get ( void )

get the slib state.

Parameters
none
Return values
SET or RESET

Definition at line 891 of file at32f413_flash.c.

Referenced by main().

◆ flash_spim_all_erase()

flash_status_type flash_spim_all_erase ( void )

erase flash spim sectors.

Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< spim erase operation timeout

< spim erase operation timeout

Definition at line 353 of file at32f413_flash.c.

◆ flash_spim_encryption_range_set()

void flash_spim_encryption_range_set ( uint32_t decode_address )

set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption.

Parameters
decode_address the end address of encrypted data in spim
Return values
none

Definition at line 810 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_spim_lock()

void flash_spim_lock ( void )

lock the flash spim controller.

Parameters
none
Return values
none

Definition at line 261 of file at32f413_flash.c.

◆ flash_spim_model_select()

void flash_spim_model_select ( flash_spim_model_type mode )

select spim supports extended spi flash chip model.

Parameters
mode the extended spi flash model
Return values
none

Definition at line 798 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_spim_operation_status_get()

flash_status_type flash_spim_operation_status_get ( void )

return the flash spim operation status.

Parameters
none
Return values
status the returned value can be: FLASH_OPERATE_BUSY, FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR or FLASH_OPERATE_DONE.

Definition at line 151 of file at32f413_flash.c.

Referenced by flash_spim_operation_wait_for().

◆ flash_spim_operation_wait_for()

flash_status_type flash_spim_operation_wait_for ( uint32_t time_out )

wait for flash spim operation complete or timeout.

Parameters
time_out flash operation timeout
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

Definition at line 205 of file at32f413_flash.c.

Referenced by flash_halfword_program(), flash_sector_erase(), flash_spim_all_erase(), and flash_word_program().

◆ flash_spim_unlock()

void flash_spim_unlock ( void )

unlock the flash spim controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 240 of file at32f413_flash.c.

Referenced by spim_init().

◆ flash_ssb_set()

flash_status_type flash_ssb_set ( uint8_t usd_ssb )

program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst.

Parameters
usd_ssb the system setting byte
Note
this parameter usd_ssb must contain a combination of all the following 3 types of data type 1: wdt_ato_en, select the wdt auto start this data can be one of the following values:
  • USD_WDT_ATO_DISABLE: disable wdt auto start
  • USD_WDT_ATO_ENABLE: enable wdt auto start type 2: depslp_rst, reset event when entering deepsleep mode. this data can be one of the following values:
  • USD_DEPSLP_NO_RST: no reset generated when entering in deepsleep
  • USD_DEPSLP_RST: reset generated when entering in deepsleep type 3: stdby_rst, reset event when entering standby mode. this data can be one of the following values:
  • USD_STDBY_NO_RST: no reset generated when entering in standby
  • USD_STDBY_RST: reset generated when entering in standby
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 731 of file at32f413_flash.c.

◆ flash_ssb_status_get()

uint8_t flash_ssb_status_get ( void )

return the flash system setting byte status.

Parameters
none
Return values
values from flash_usd register: wdt_ato_en(bit0), depslp_rst(bit1) and stdby_rst(bit2).

Definition at line 763 of file at32f413_flash.c.

◆ flash_unlock()

void flash_unlock ( void )

unlock the flash controller.

Parameters
none
Return values
none

< flash operation unlock order key1

< flash operation unlock order key2

Definition at line 229 of file at32f413_flash.c.

Referenced by config_flash_interrupt(), extend_sram(), flash_2kb_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_set_upgrade_flag(), flash_write(), flash_write_data(), iap_clear_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_erase_sector(), iap_init(), iap_set_upgrade_flag(), msc_disk_write(), and slib_enable().

◆ flash_user_system_data_erase()

flash_status_type flash_user_system_data_erase ( void )

erase the flash user system data.

Note
this functions erases all user system data except the fap byte.
Parameters
none
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash fap relieve key val

< internal flash erase operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash erase operation timeout

< flash fap relieve key val

< internal flash program operation timeout

Definition at line 382 of file at32f413_flash.c.

Referenced by extend_sram().

◆ flash_user_system_data_program()

flash_status_type flash_user_system_data_program | ( | uint32_t | address,
 |  | uint8_t | data
 | ) |  |

program a halfword at a specified user system data address.

Parameters
address | specifies the address to be programmed.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< internal flash program operation timeout

< flash operation unlock order key1

< flash operation unlock order key2

< internal flash program operation timeout

Definition at line 560 of file at32f413_flash.c.

Referenced by extend_sram().

◆ flash_word_program()

flash_status_type flash_word_program | ( | uint32_t | address,
 |  | uint32_t | data
 | ) |  |

program a word at a specified address.

Parameters
address | specifies the address to be programmed, word alignment is recommended.
data | specifies the data to be programmed.
Return values
status the returned value can be: FLASH_PROGRAM_ERROR, FLASH_EPP_ERROR, FLASH_OPERATE_DONE or FLASH_OPERATE_TIMEOUT.

< flash start address of spim

< spim program operation timeout

< spim program operation timeout

< internal flash program operation timeout

< internal flash program operation timeout

Definition at line 438 of file at32f413_flash.c.

Referenced by flash_fat16_set_upgrade_flag(), iap_command_handle(), iap_data_write(), iap_set_upgrade_flag(), slib_enable(), and spim_operate().


AT32F413 Firmwary Library: GPIO

Modules | Macros
GPIO
AT32F413_periph_driver

GPIO driver modules. More...

Modules

GPIO_pins_number_definition
IOMUX_map_definition
iomux map definitions
IOMUX_map2_definition
iomux map2 definitions
IOMUX_map3_definition
iomux map3 definitions
IOMUX_map4_definition
iomux map4 definitions
IOMUX_map5_definition
iomux map5 definitions
IOMUX_map6_definition
iomux map6 definitions
IOMUX_map7_definition
iomux map7 definitions
GPIO_exported_types
GPIO_exported_functions
GPIO_private_functions

Macros

#define | IOMUX_MAKE_VALUE(reg_offset, bit_addr, bit_num, bit_val) (uint32_t)(((reg_offset) << 24) | ((bit_addr) << 16) | ((bit_num) << 8) | (bit_val))
#define | GPIOA ((gpio_type *) GPIOA_BASE)
#define | GPIOB ((gpio_type *) GPIOB_BASE)
#define | GPIOC ((gpio_type *) GPIOC_BASE)
#define | GPIOD ((gpio_type *) GPIOD_BASE)
#define | GPIOF ((gpio_type *) GPIOF_BASE)
#define | IOMUX ((iomux_type *) IOMUX_BASE)

Detailed Description

GPIO driver modules.

Macro Definition Documentation

◆ GPIOA

#define GPIOA ((gpio_type *) GPIOA_BASE)

Definition at line 748 of file at32f413_gpio.h.

◆ GPIOB

#define GPIOB ((gpio_type *) GPIOB_BASE)

Definition at line 749 of file at32f413_gpio.h.

◆ GPIOC

#define GPIOC ((gpio_type *) GPIOC_BASE)

Definition at line 750 of file at32f413_gpio.h.

◆ GPIOD

#define GPIOD ((gpio_type *) GPIOD_BASE)

Definition at line 751 of file at32f413_gpio.h.

◆ GPIOF

#define GPIOF ((gpio_type *) GPIOF_BASE)

Definition at line 752 of file at32f413_gpio.h.

◆ IOMUX

#define IOMUX ((iomux_type *) IOMUX_BASE)

Definition at line 753 of file at32f413_gpio.h.

◆ IOMUX_MAKE_VALUE

#define IOMUX_MAKE_VALUE | ( | reg_offset,
 |  | bit_addr,
 |  | bit_num,
 |  | bit_val
 | ) | (uint32_t)(((reg_offset) << 24) | ((bit_addr) << 16) | ((bit_num) << 8) | (bit_val))

Definition at line 73 of file at32f413_gpio.h.


AT32F413 Firmwary Library: GPIO_pins_number_definition

Macros
GPIO_pins_number_definition
AT32F413_periph_driver » GPIO

Macros

#define | GPIO_PINS_0 0x0001
#define | GPIO_PINS_1 0x0002
#define | GPIO_PINS_2 0x0004
#define | GPIO_PINS_3 0x0008
#define | GPIO_PINS_4 0x0010
#define | GPIO_PINS_5 0x0020
#define | GPIO_PINS_6 0x0040
#define | GPIO_PINS_7 0x0080
#define | GPIO_PINS_8 0x0100
#define | GPIO_PINS_9 0x0200
#define | GPIO_PINS_10 0x0400
#define | GPIO_PINS_11 0x0800
#define | GPIO_PINS_12 0x1000
#define | GPIO_PINS_13 0x2000
#define | GPIO_PINS_14 0x4000
#define | GPIO_PINS_15 0x8000
#define | GPIO_PINS_ALL 0xFFFF

Detailed Description

Macro Definition Documentation

◆ GPIO_PINS_0

#define GPIO_PINS_0 0x0001

gpio pins number 0

Definition at line 51 of file at32f413_gpio.h.

◆ GPIO_PINS_1

#define GPIO_PINS_1 0x0002

gpio pins number 1

Definition at line 52 of file at32f413_gpio.h.

◆ GPIO_PINS_10

#define GPIO_PINS_10 0x0400

gpio pins number 10

Definition at line 61 of file at32f413_gpio.h.

◆ GPIO_PINS_11

#define GPIO_PINS_11 0x0800

gpio pins number 11

Definition at line 62 of file at32f413_gpio.h.

◆ GPIO_PINS_12

#define GPIO_PINS_12 0x1000

gpio pins number 12

Definition at line 63 of file at32f413_gpio.h.

◆ GPIO_PINS_13

#define GPIO_PINS_13 0x2000

gpio pins number 13

Definition at line 64 of file at32f413_gpio.h.

◆ GPIO_PINS_14

#define GPIO_PINS_14 0x4000

gpio pins number 14

Definition at line 65 of file at32f413_gpio.h.

◆ GPIO_PINS_15

#define GPIO_PINS_15 0x8000

gpio pins number 15

Definition at line 66 of file at32f413_gpio.h.

◆ GPIO_PINS_2

#define GPIO_PINS_2 0x0004

gpio pins number 2

Definition at line 53 of file at32f413_gpio.h.

◆ GPIO_PINS_3

#define GPIO_PINS_3 0x0008

gpio pins number 3

Definition at line 54 of file at32f413_gpio.h.

◆ GPIO_PINS_4

#define GPIO_PINS_4 0x0010

gpio pins number 4

Definition at line 55 of file at32f413_gpio.h.

◆ GPIO_PINS_5

#define GPIO_PINS_5 0x0020

gpio pins number 5

Definition at line 56 of file at32f413_gpio.h.

◆ GPIO_PINS_6

#define GPIO_PINS_6 0x0040

gpio pins number 6

Definition at line 57 of file at32f413_gpio.h.

◆ GPIO_PINS_7

#define GPIO_PINS_7 0x0080

gpio pins number 7

Definition at line 58 of file at32f413_gpio.h.

◆ GPIO_PINS_8

#define GPIO_PINS_8 0x0100

gpio pins number 8

Definition at line 59 of file at32f413_gpio.h.

◆ GPIO_PINS_9

#define GPIO_PINS_9 0x0200

gpio pins number 9

Definition at line 60 of file at32f413_gpio.h.

◆ GPIO_PINS_ALL

#define GPIO_PINS_ALL 0xFFFF

gpio all pins

Definition at line 67 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map_definition

Macros
IOMUX_map_definition
AT32F413_periph_driver » GPIO

iomux map definitions More...

Macros

#define | SPI1_MUX_01 SPI1_GMUX_0001
#define | I2C1_MUX I2C1_GMUX_0001
#define | USART1_MUX USART1_GMUX_0001
#define | USART3_MUX_01 USART3_GMUX_0001
#define | TMR1_MUX_01 TMR1_GMUX_0001
#define | TMR2_MUX_01 TMR2_GMUX_001
#define | TMR2_MUX_10 TMR2_GMUX_010
#define | TMR2_MUX_11 TMR2_GMUX_011
#define | TMR3_MUX_10 TMR3_GMUX_0010
#define | TMR3_MUX_11 TMR3_GMUX_0011
#define | CAN_MUX_10 CAN1_GMUX_0010
#define | PD01_MUX PD01_GMUX
#define | TMR5CH4_MUX TMR5CH4_GMUX
#define | ADC1_ETP_MUX ADC1_ETP_GMUX
#define | ADC1_ETO_MUX ADC1_ETO_GMUX
#define | ADC2_ETP_MUX ADC2_ETP_GMUX
#define | ADC2_ETO_MUX ADC2_ETO_GMUX
#define | SWJTAG_CONF_001 SWJTAG_GMUX_001
#define | SWJTAG_CONF_010 SWJTAG_GMUX_010
#define | SWJTAG_CONF_100 SWJTAG_GMUX_100

Detailed Description

iomux map definitions

Macro Definition Documentation

◆ ADC1_ETO_MUX

#define ADC1_ETO_MUX ADC1_ETO_GMUX

adc1 external trigger ordinary conversion muxing

Definition at line 95 of file at32f413_gpio.h.

◆ ADC1_ETP_MUX

#define ADC1_ETP_MUX ADC1_ETP_GMUX

adc1 external trigger preempted conversion muxing

Definition at line 94 of file at32f413_gpio.h.

◆ ADC2_ETO_MUX

#define ADC2_ETO_MUX ADC2_ETO_GMUX

adc2 external trigger ordinary conversion muxing

Definition at line 97 of file at32f413_gpio.h.

◆ ADC2_ETP_MUX

#define ADC2_ETP_MUX ADC2_ETP_GMUX

adc2 external trigger preempted conversion muxing

Definition at line 96 of file at32f413_gpio.h.

◆ CAN_MUX_10

#define CAN_MUX_10 CAN1_GMUX_0010

can_rx(pb8), can_tx(pb9)

Definition at line 91 of file at32f413_gpio.h.

◆ I2C1_MUX

#define I2C1_MUX I2C1_GMUX_0001

i2c1_scl(pb8), i2c1_sda(pb9)

Definition at line 82 of file at32f413_gpio.h.

◆ PD01_MUX

#define PD01_MUX PD01_GMUX

pd0/pd1 mapping on osc_in/osc_out

Definition at line 92 of file at32f413_gpio.h.

◆ SPI1_MUX_01

#define SPI1_MUX_01 SPI1_GMUX_0001

spi1_cs/i2s1_ws(pa15), spi1_sck/i2s1_ck(pb3), spi1_miso(pb4), spi1_mosi/i2s1_sd(pb5), i2s1_mck(pb0)

Definition at line 81 of file at32f413_gpio.h.

◆ SWJTAG_CONF_001

#define SWJTAG_CONF_001 SWJTAG_GMUX_001

full swj enabled (jtag-dp + sw-dp) but without jtrst

Definition at line 98 of file at32f413_gpio.h.

◆ SWJTAG_CONF_010

#define SWJTAG_CONF_010 SWJTAG_GMUX_010

jtag-dp disabled and sw-dp enabled

Definition at line 99 of file at32f413_gpio.h.

◆ SWJTAG_CONF_100

#define SWJTAG_CONF_100 SWJTAG_GMUX_100

full swj disabled (jtag-dp + sw-dp)

Definition at line 100 of file at32f413_gpio.h.

◆ TMR1_MUX_01

#define TMR1_MUX_01 TMR1_GMUX_0001

tmr1_ext(pa12), tmr1_ch1(pa8), tmr1_ch2(pa9), tmr1_ch3(pa10), tmr1_ch4(pa11), tmr1_brkin(pa6), tmr1_ch1c(pa7), tmr1_ch2c(pb0), tmr1_ch3c(pb1)

Definition at line 85 of file at32f413_gpio.h.

◆ TMR2_MUX_01

#define TMR2_MUX_01 TMR2_GMUX_001

tmr2_ch1_ext(pa15), tmr2_ch2(pb3), tmr2_ch3(pa2), tmr2_ch4(pa3)

Definition at line 86 of file at32f413_gpio.h.

◆ TMR2_MUX_10

#define TMR2_MUX_10 TMR2_GMUX_010

tmr2_ch1_ext(pa0), tmr2_ch2(pa1), tmr2_ch3(pb10), tmr2_ch4(pb11)

Definition at line 87 of file at32f413_gpio.h.

◆ TMR2_MUX_11

#define TMR2_MUX_11 TMR2_GMUX_011

tmr2_ch1_ext(pa15), tmr2_ch2(pb3), tmr2_ch3(pb10), tmr2_ch4(pb11)

Definition at line 88 of file at32f413_gpio.h.

◆ TMR3_MUX_10

#define TMR3_MUX_10 TMR3_GMUX_0010

tmr3_ch1(pb4), tmr3_ch2(pb5), tmr3_ch3(pb0), tmr3_ch4(pb1)

Definition at line 89 of file at32f413_gpio.h.

◆ TMR3_MUX_11

#define TMR3_MUX_11 TMR3_GMUX_0011

tmr3_ch1(pc6), tmr3_ch2(pc7), tmr3_ch3(pc8), tmr3_ch4(pc9)

Definition at line 90 of file at32f413_gpio.h.

◆ TMR5CH4_MUX

#define TMR5CH4_MUX TMR5CH4_GMUX

lick connected to tmr5_ch4 input capture for calibration

Definition at line 93 of file at32f413_gpio.h.

◆ USART1_MUX

#define USART1_MUX USART1_GMUX_0001

usart1_tx(pb6), usart1_rx(pb7)

Definition at line 83 of file at32f413_gpio.h.

◆ USART3_MUX_01

#define USART3_MUX_01 USART3_GMUX_0001

usart3_tx(pc10), usart3_rx(pc11), usart3_ck(pc12), usart3_cts(pb13), usart3_rts(pb14)

Definition at line 84 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map2_definition

Macros
IOMUX_map2_definition
AT32F413_periph_driver » GPIO

iomux map2 definitions More...

Macros

#define EXT_SPIM_EN_MUX EXT_SPIM_GMUX_1000

Detailed Description

iomux map2 definitions

Macro Definition Documentation

◆ EXT_SPIM_EN_MUX

#define EXT_SPIM_EN_MUX EXT_SPIM_GMUX_1000

enable external spi-flash interface

Definition at line 111 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map3_definition

Macros
IOMUX_map3_definition
AT32F413_periph_driver » GPIO

iomux map3 definitions More...

Macros

#define | TMR9_GMUX IOMUX_MAKE_VALUE(0x20, 0, 4, 0x02)
#define | TMR10_GMUX IOMUX_MAKE_VALUE(0x20, 4, 4, 0x02)
#define | TMR11_GMUX IOMUX_MAKE_VALUE(0x20, 8, 4, 0x02)

Detailed Description

iomux map3 definitions

Macro Definition Documentation

◆ TMR10_GMUX

#define TMR10_GMUX IOMUX_MAKE_VALUE(0x20, 4, 4, 0x02)

tmr10_ch1(pa6)

Definition at line 123 of file at32f413_gpio.h.

◆ TMR11_GMUX

#define TMR11_GMUX IOMUX_MAKE_VALUE(0x20, 8, 4, 0x02)

tmr11_ch1(pa7)

Definition at line 124 of file at32f413_gpio.h.

◆ TMR9_GMUX

#define TMR9_GMUX IOMUX_MAKE_VALUE(0x20, 0, 4, 0x02)

tmr9_ch1(pb14), tmr9_ch2(pb15)

Definition at line 122 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map4_definition

Macros
IOMUX_map4_definition
AT32F413_periph_driver » GPIO

iomux map4 definitions More...

Macros

#define | TMR1_GMUX_0001 IOMUX_MAKE_VALUE(0x24, 0, 4, 0x01)
#define | TMR2_GMUX_001 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x01)
#define | TMR2_GMUX_010 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x02)
#define | TMR2_GMUX_011 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x03)
#define | TMR2ITR1_GMUX IOMUX_MAKE_VALUE(0x24, 7, 1, 0x01)
#define | TMR3_GMUX_0010 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x02)
#define | TMR3_GMUX_0011 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x03)
#define | TMR5_GMUX_001 IOMUX_MAKE_VALUE(0x24, 16, 3, 0x01)
#define | TMR5CH4_GMUX IOMUX_MAKE_VALUE(0x24, 19, 1, 0x01)

Detailed Description

iomux map4 definitions

Macro Definition Documentation

◆ TMR1_GMUX_0001

#define TMR1_GMUX_0001 IOMUX_MAKE_VALUE(0x24, 0, 4, 0x01)

tmr1_ext(pa12), tmr1_ch1(pa8), tmr1_ch2(pa9), tmr1_ch3(pa10), tmr1_ch4(pa11), tmr1_brkin(pa6), tmr1_ch1c(pa7), tmr1_ch2c(pb0), tmr1_ch3c(pb1)

Definition at line 135 of file at32f413_gpio.h.

◆ TMR2_GMUX_001

#define TMR2_GMUX_001 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x01)

tmr2_ch1_ext(pa15), tmr2_ch2(pb3), tmr2_ch3(pa2), tmr2_ch4(pa3)

Definition at line 136 of file at32f413_gpio.h.

◆ TMR2_GMUX_010

#define TMR2_GMUX_010 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x02)

tmr2_ch1_ext(pa0), tmr2_ch2(pa1), tmr2_ch3(pb10), tmr2_ch4(pb11)

Definition at line 137 of file at32f413_gpio.h.

◆ TMR2_GMUX_011

#define TMR2_GMUX_011 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x03)

tmr2_ch1_ext(pa15), tmr2_ch2(pb3), tmr2_ch3(pb10), tmr2_ch4(pb11)

Definition at line 138 of file at32f413_gpio.h.

◆ TMR2ITR1_GMUX

#define TMR2ITR1_GMUX IOMUX_MAKE_VALUE(0x24, 7, 1, 0x01)

usbdev sof as input to tmr2_int.1

Definition at line 139 of file at32f413_gpio.h.

◆ TMR3_GMUX_0010

#define TMR3_GMUX_0010 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x02)

tmr3_ch1(pb4), tmr3_ch2(pb5), tmr3_ch3(pb0), tmr3_ch4(pb1)

Definition at line 140 of file at32f413_gpio.h.

◆ TMR3_GMUX_0011

#define TMR3_GMUX_0011 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x03)

tmr3_ch1(pc6), tmr3_ch2(pc7), tmr3_ch3(pc8), tmr3_ch4(pc9)

Definition at line 141 of file at32f413_gpio.h.

◆ TMR5_GMUX_001

#define TMR5_GMUX_001 IOMUX_MAKE_VALUE(0x24, 16, 3, 0x01)

tmr5_ch1(pf4), tmr5_ch2(pf5)

Definition at line 142 of file at32f413_gpio.h.

◆ TMR5CH4_GMUX

#define TMR5CH4_GMUX IOMUX_MAKE_VALUE(0x24, 19, 1, 0x01)

lick connected to tmr5_ch4 input capture for calibration

Definition at line 143 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map5_definition

Macros
IOMUX_map5_definition
AT32F413_periph_driver » GPIO

iomux map5 definitions More...

Macros

#define | I2C1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x01)
#define | I2C1_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x03)
#define | I2C2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | I2C2_GMUX_0010 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | I2C2_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | SPI1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 16, 4, 0x01)
#define | SPI2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 20, 4, 0x01)

Detailed Description

iomux map5 definitions

Macro Definition Documentation

◆ I2C1_GMUX_0001

#define I2C1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x01)

i2c1_scl(pb8), i2c1_sda(pb9)

Definition at line 154 of file at32f413_gpio.h.

◆ I2C1_GMUX_0011

#define I2C1_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x03)

i2c1_scl(pf6), i2c1_sda(pf7)

Definition at line 155 of file at32f413_gpio.h.

◆ I2C2_GMUX_0001

#define I2C2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)

i2c2_scl(pf6), i2c2_sda(pf7)

Definition at line 156 of file at32f413_gpio.h.

◆ I2C2_GMUX_0010

#define I2C2_GMUX_0010 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)

i2c2_scl(pa8), i2c2_sda(pc9)

Definition at line 157 of file at32f413_gpio.h.

◆ I2C2_GMUX_0011

#define I2C2_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)

i2c2_scl(pa8), i2c2_sda(pb4)

Definition at line 158 of file at32f413_gpio.h.

◆ SPI1_GMUX_0001

#define SPI1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 16, 4, 0x01)

spi1_cs/i2s1_ws(pa15), spi1_sck/i2s1_ck(pb3), spi1_miso(pb4), spi1_mosi/i2s1_sd(pb5), i2s1_mck(pb6)

Definition at line 159 of file at32f413_gpio.h.

◆ SPI2_GMUX_0001

#define SPI2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 20, 4, 0x01)

spi2_cs/i2s2_ws(pa15), spi2_sck/i2s2_ck(pb3), spi2_miso(pb4), spi2_mosi/i2s2_sd(pb5), i2s2_mck(pc7)

Definition at line 160 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map6_definition

Macros
IOMUX_map6_definition
AT32F413_periph_driver » GPIO

iomux map6 definitions More...

Macros

#define | CAN1_GMUX_0010 IOMUX_MAKE_VALUE(0x2C, 0, 4, 0x02)
#define | CAN2_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 4, 4, 0x01)
#define | SDIO1_GMUX_0100 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x04)
#define | SDIO1_GMUX_0101 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x05)
#define | SDIO1_GMUX_0110 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x06)
#define | SDIO1_GMUX_0111 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x07)
#define | USART1_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 16, 4, 0x01)
#define | USART3_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 24, 4, 0x01)
#define | UART4_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 28, 4, 0x01)

Detailed Description

iomux map6 definitions

Macro Definition Documentation

◆ CAN1_GMUX_0010

#define CAN1_GMUX_0010 IOMUX_MAKE_VALUE(0x2C, 0, 4, 0x02)

can_rx(pb8), can_tx(pb9)

Definition at line 171 of file at32f413_gpio.h.

◆ CAN2_GMUX_0001

#define CAN2_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 4, 4, 0x01)

can2_rx(pb5), can2_tx(pb6)

Definition at line 172 of file at32f413_gpio.h.

◆ SDIO1_GMUX_0100

#define SDIO1_GMUX_0100 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x04)

sdio1_ck(pc4), sdio1_cmd(pc5), sdio1_d0(pc0), sdio1_d1(pc1), sdio1_d2(pc2), sdio1_d3(pc3), sdio1_d4(pa4), sdio1_d5(pa5), sdio1_d6(pa6), sdio1_d7(pa7)

Definition at line 173 of file at32f413_gpio.h.

◆ SDIO1_GMUX_0101

#define SDIO1_GMUX_0101 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x05)

sdio1_ck(pc4), sdio1_cmd(pc5), sdio1_d0(pa4), sdio1_d1(pa5), sdio1_d2(pa6), sdio1_d3(pa7)

Definition at line 174 of file at32f413_gpio.h.

◆ SDIO1_GMUX_0110

#define SDIO1_GMUX_0110 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x06)

sdio1_ck(pa2), sdio1_cmd(pa3), sdio1_d0(pc0), sdio1_d1(pc1), sdio1_d2(pc2), sdio1_d3(pc3), sdio1_d4(pa4), sdio1_d5(pa5), sdio1_d6(pa6), sdio1_d7(pa7)

Definition at line 175 of file at32f413_gpio.h.

◆ SDIO1_GMUX_0111

#define SDIO1_GMUX_0111 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x07)

sdio1_ck(pa2), sdio1_cmd(pa3), sdio1_d0(pa4), sdio1_d1(pa5), sdio1_d2(pa6), sdio1_d3(pa7)

Definition at line 176 of file at32f413_gpio.h.

◆ UART4_GMUX_0001

#define UART4_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 28, 4, 0x01)

uart4_tx(pf4), uart4_rx(pf5)

Definition at line 179 of file at32f413_gpio.h.

◆ USART1_GMUX_0001

#define USART1_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 16, 4, 0x01)

usart1_tx(pb6), usart1_rx(pb7)

Definition at line 177 of file at32f413_gpio.h.

◆ USART3_GMUX_0001

#define USART3_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 24, 4, 0x01)

usart3_tx(pc10), usart3_rx(pc11), usart3_ck(pc12), usart3_cts(pb13), usart3_rts(pb14)

Definition at line 178 of file at32f413_gpio.h.


AT32F413 Firmwary Library: IOMUX_map7_definition

Macros
IOMUX_map7_definition
AT32F413_periph_driver » GPIO

iomux map7 definitions More...

Macros

#define | EXT_SPIM_GMUX_1000 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x08)
#define | EXT_SPIM_GMUX_1001 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x09)
#define | ADC1_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 4, 1, 0x01)
#define | ADC1_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 5, 1, 0x01)
#define | ADC2_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 8, 1, 0x01)
#define | ADC2_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 9, 1, 0x01)
#define | SWJTAG_GMUX_001 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x01)
#define | SWJTAG_GMUX_010 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x02)
#define | SWJTAG_GMUX_100 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x04)
#define | PD01_GMUX IOMUX_MAKE_VALUE(0x30, 20, 1, 0x01)

Detailed Description

iomux map7 definitions

Macro Definition Documentation

◆ ADC1_ETO_GMUX

#define ADC1_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 5, 1, 0x01)

adc1 external trigger ordinary conversion muxing

Definition at line 193 of file at32f413_gpio.h.

◆ ADC1_ETP_GMUX

#define ADC1_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 4, 1, 0x01)

adc1 external trigger preempted conversion muxing

Definition at line 192 of file at32f413_gpio.h.

◆ ADC2_ETO_GMUX

#define ADC2_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 9, 1, 0x01)

adc2 external trigger ordinary conversion muxing

Definition at line 195 of file at32f413_gpio.h.

◆ ADC2_ETP_GMUX

#define ADC2_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 8, 1, 0x01)

adc2 external trigger preempted conversion muxing

Definition at line 194 of file at32f413_gpio.h.

◆ EXT_SPIM_GMUX_1000

#define EXT_SPIM_GMUX_1000 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x08)

spim_sck(pb1), spim_cs(pa8), spim_io0(pa11), spim_io1(pa12), spim_io2(pb7), spim_sio3(pb6)

Definition at line 190 of file at32f413_gpio.h.

◆ EXT_SPIM_GMUX_1001

#define EXT_SPIM_GMUX_1001 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x09)

spim_sck(pb1), spim_cs(pa8), spim_io0(pb10), spim_io1(pb11), spim_io2(pb7), spim_sio3(pb6)

Definition at line 191 of file at32f413_gpio.h.

◆ PD01_GMUX

#define PD01_GMUX IOMUX_MAKE_VALUE(0x30, 20, 1, 0x01)

pd0/pd1 mapping on osc_in/osc_out

Definition at line 199 of file at32f413_gpio.h.

◆ SWJTAG_GMUX_001

#define SWJTAG_GMUX_001 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x01)

full swj enabled (jtag-dp + sw-dp) but without jtrst

Definition at line 196 of file at32f413_gpio.h.

◆ SWJTAG_GMUX_010

#define SWJTAG_GMUX_010 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x02)

jtag-dp disabled and sw-dp enabled

Definition at line 197 of file at32f413_gpio.h.

◆ SWJTAG_GMUX_100

#define SWJTAG_GMUX_100 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x04)

full swj disabled (jtag-dp + sw-dp)

Definition at line 198 of file at32f413_gpio.h.


AT32F413 Firmwary Library: GPIO_exported_types

Data Structures | Enumerations
GPIO_exported_types
AT32F413_periph_driver » GPIO

Data Structures

struct | gpio_init_type
gpio init type More...
struct | gpio_type
type define gpio register all More...
struct | iomux_type
type define iomux register all More...

Enumerations

enum | gpio_mode_type { GPIO_MODE_INPUT = 0x00 , GPIO_MODE_OUTPUT = 0x10 , GPIO_MODE_MUX = 0x08 , GPIO_MODE_ANALOG = 0x03 }
gpio mode select More...
enum | gpio_drive_type { GPIO_DRIVE_STRENGTH_STRONGER = 0x01 , GPIO_DRIVE_STRENGTH_MODERATE = 0x02 , GPIO_DRIVE_STRENGTH_MAXIMUM = 0x03 }
gpio output drive strength select More...
enum | gpio_output_type { GPIO_OUTPUT_PUSH_PULL = 0x00 , GPIO_OUTPUT_OPEN_DRAIN = 0x04 }
gpio output type More...
enum | gpio_pull_type { GPIO_PULL_NONE = 0x0004 , GPIO_PULL_UP = 0x0018 , GPIO_PULL_DOWN = 0x0028 }
gpio pull type More...
enum gpio_pins_source_type {
GPIO_PINS_SOURCE0 = 0x00 , GPIO_PINS_SOURCE1 = 0x01 , GPIO_PINS_SOURCE2 = 0x02 , GPIO_PINS_SOURCE3 = 0x03 ,
GPIO_PINS_SOURCE4 = 0x04 , GPIO_PINS_SOURCE5 = 0x05 , GPIO_PINS_SOURCE6 = 0x06 , GPIO_PINS_SOURCE7 = 0x07 ,
GPIO_PINS_SOURCE8 = 0x08 , GPIO_PINS_SOURCE9 = 0x09 , GPIO_PINS_SOURCE10 = 0x0A , GPIO_PINS_SOURCE11 = 0x0B ,
GPIO_PINS_SOURCE12 = 0x0C , GPIO_PINS_SOURCE13 = 0x0D , GPIO_PINS_SOURCE14 = 0x0E , GPIO_PINS_SOURCE15 = 0x0F
}
gpio pins source type More...
enum gpio_port_source_type {
GPIO_PORT_SOURCE_GPIOA = 0x00 , GPIO_PORT_SOURCE_GPIOB = 0x01 , GPIO_PORT_SOURCE_GPIOC = 0x02 , GPIO_PORT_SOURCE_GPIOD = 0x03 ,
GPIO_PORT_SOURCE_GPIOF = 0x05
}
gpio port source type More...

Detailed Description

Enumeration Type Documentation

◆ gpio_drive_type

enum gpio_drive_type

gpio output drive strength select

Enumerator
GPIO_DRIVE_STRENGTH_STRONGER | stronger sourcing/sinking strength
GPIO_DRIVE_STRENGTH_MODERATE | moderate sourcing/sinking strength
GPIO_DRIVE_STRENGTH_MAXIMUM | maximum sourcing/sinking strength

Definition at line 223 of file at32f413_gpio.h.

◆ gpio_mode_type

enum gpio_mode_type

gpio mode select

Enumerator
GPIO_MODE_INPUT | gpio input mode
GPIO_MODE_OUTPUT | gpio output mode
GPIO_MODE_MUX | gpio mux function mode
GPIO_MODE_ANALOG | gpio analog in/out mode

Definition at line 212 of file at32f413_gpio.h.

◆ gpio_output_type

enum gpio_output_type

gpio output type

Enumerator
GPIO_OUTPUT_PUSH_PULL | output push-pull
GPIO_OUTPUT_OPEN_DRAIN | output open-drain

Definition at line 233 of file at32f413_gpio.h.

◆ gpio_pins_source_type

enum gpio_pins_source_type

gpio pins source type

Enumerator
GPIO_PINS_SOURCE0 | gpio pins source number 0
GPIO_PINS_SOURCE1 | gpio pins source number 1
GPIO_PINS_SOURCE2 | gpio pins source number 2
GPIO_PINS_SOURCE3 | gpio pins source number 3
GPIO_PINS_SOURCE4 | gpio pins source number 4
GPIO_PINS_SOURCE5 | gpio pins source number 5
GPIO_PINS_SOURCE6 | gpio pins source number 6
GPIO_PINS_SOURCE7 | gpio pins source number 7
GPIO_PINS_SOURCE8 | gpio pins source number 8
GPIO_PINS_SOURCE9 | gpio pins source number 9
GPIO_PINS_SOURCE10 | gpio pins source number 10
GPIO_PINS_SOURCE11 | gpio pins source number 11
GPIO_PINS_SOURCE12 | gpio pins source number 12
GPIO_PINS_SOURCE13 | gpio pins source number 13
GPIO_PINS_SOURCE14 | gpio pins source number 14
GPIO_PINS_SOURCE15 | gpio pins source number 15

Definition at line 252 of file at32f413_gpio.h.

◆ gpio_port_source_type

enum gpio_port_source_type

gpio port source type

Enumerator
GPIO_PORT_SOURCE_GPIOA | gpio port source gpioa
GPIO_PORT_SOURCE_GPIOB | gpio port source gpiob
GPIO_PORT_SOURCE_GPIOC | gpio port source gpioc
GPIO_PORT_SOURCE_GPIOD | gpio port source gpiod
GPIO_PORT_SOURCE_GPIOF | gpio port source gpiof

Definition at line 275 of file at32f413_gpio.h.

◆ gpio_pull_type

enum gpio_pull_type

gpio pull type

Enumerator
GPIO_PULL_NONE | floating for input, no pull for output
GPIO_PULL_UP | pull-up
GPIO_PULL_DOWN | pull-down

Definition at line 242 of file at32f413_gpio.h.


AT32F413 Firmwary Library: gpio_init_type Struct Reference

Data Fields
gpio_init_type Struct Reference
AT32F413_periph_driver » GPIO » GPIO_exported_types

gpio init type More...

#include <at32f413_gpio.h>

Data Fields

uint32_t gpio_pins
gpio_output_type gpio_out_type
gpio_pull_type gpio_pull
gpio_mode_type gpio_mode
gpio_drive_type gpio_drive_strength

Detailed Description

gpio init type

Definition at line 287 of file at32f413_gpio.h.

Field Documentation

◆ gpio_drive_strength

gpio_drive_type gpio_init_type::gpio_drive_strength

drive strength selection

Definition at line 293 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_mode

gpio_mode_type gpio_init_type::gpio_mode

mode selection

Definition at line 292 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_out_type

gpio_output_type gpio_init_type::gpio_out_type

output type selection

Definition at line 290 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_pins

uint32_t gpio_init_type::gpio_pins

pins number selection

Definition at line 289 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_pull

gpio_pull_type gpio_init_type::gpio_pull

pull type selection

Definition at line 291 of file at32f413_gpio.h.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), gpio_default_para_init(), gpio_init(), i2c_lowlevel_init(), main(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

The documentation for this struct was generated from the following file:
  • at32f413_gpio.h


AT32F413 Firmwary Library: gpio_type Struct Reference

Data Fields
gpio_type Struct Reference
AT32F413_periph_driver » GPIO » GPIO_exported_types

type define gpio register all More...

#include <at32f413_gpio.h>

Data Fields

union {
__IO uint32_t cfglr
struct {
__IO uint32_t iomc0: 2
__IO uint32_t iofc0: 2
__IO uint32_t iomc1: 2
__IO uint32_t iofc1: 2
__IO uint32_t iomc2: 2
__IO uint32_t iofc2: 2
__IO uint32_t iomc3: 2
__IO uint32_t iofc3: 2
__IO uint32_t iomc4: 2
__IO uint32_t iofc4: 2
__IO uint32_t iomc5: 2
__IO uint32_t iofc5: 2
__IO uint32_t iomc6: 2
__IO uint32_t iofc6: 2
__IO uint32_t iomc7: 2
__IO uint32_t iofc7: 2
} cfglr_bit
};
gpio cfglr register, offset:0x00 More...
union {
__IO uint32_t cfghr
struct {
__IO uint32_t iomc8: 2
__IO uint32_t iofc8: 2
__IO uint32_t iomc9: 2
__IO uint32_t iofc9: 2
__IO uint32_t iomc10: 2
__IO uint32_t iofc10: 2
__IO uint32_t iomc11: 2
__IO uint32_t iofc11: 2
__IO uint32_t iomc12: 2
__IO uint32_t iofc12: 2
__IO uint32_t iomc13: 2
__IO uint32_t iofc13: 2
__IO uint32_t iomc14: 2
__IO uint32_t iofc14: 2
__IO uint32_t iomc15: 2
__IO uint32_t iofc15: 2
} cfghr_bit
};
gpio cfghr register, offset:0x04 More...
union {
__IO uint32_t idt
struct {
__IO uint32_t idt0: 1
__IO uint32_t idt1: 1
__IO uint32_t idt2: 1
__IO uint32_t idt3: 1
__IO uint32_t idt4: 1
__IO uint32_t idt5: 1
__IO uint32_t idt6: 1
__IO uint32_t idt7: 1
__IO uint32_t idt8: 1
__IO uint32_t idt9: 1
__IO uint32_t idt10: 1
__IO uint32_t idt11: 1
__IO uint32_t idt12: 1
__IO uint32_t idt13: 1
__IO uint32_t idt14: 1
__IO uint32_t idt15: 1
__IO uint32_t reserved1: 16
} idt_bit
};
gpio idt register, offset:0x08 More...
union {
__IO uint32_t odt
struct {
__IO uint32_t odt0: 1
__IO uint32_t odt1: 1
__IO uint32_t odt2: 1
__IO uint32_t odt3: 1
__IO uint32_t odt4: 1
__IO uint32_t odt5: 1
__IO uint32_t odt6: 1
__IO uint32_t odt7: 1
__IO uint32_t odt8: 1
__IO uint32_t odt9: 1
__IO uint32_t odt10: 1
__IO uint32_t odt11: 1
__IO uint32_t odt12: 1
__IO uint32_t odt13: 1
__IO uint32_t odt14: 1
__IO uint32_t odt15: 1
__IO uint32_t reserved1: 16
} odt_bit
};
gpio odt register, offset:0x0C More...
union {
__IO uint32_t scr
struct {
__IO uint32_t iosb0: 1
__IO uint32_t iosb1: 1
__IO uint32_t iosb2: 1
__IO uint32_t iosb3: 1
__IO uint32_t iosb4: 1
__IO uint32_t iosb5: 1
__IO uint32_t iosb6: 1
__IO uint32_t iosb7: 1
__IO uint32_t iosb8: 1
__IO uint32_t iosb9: 1
__IO uint32_t iosb10: 1
__IO uint32_t iosb11: 1
__IO uint32_t iosb12: 1
__IO uint32_t iosb13: 1
__IO uint32_t iosb14: 1
__IO uint32_t iosb15: 1
__IO uint32_t iocb0: 1
__IO uint32_t iocb1: 1
__IO uint32_t iocb2: 1
__IO uint32_t iocb3: 1
__IO uint32_t iocb4: 1
__IO uint32_t iocb5: 1
__IO uint32_t iocb6: 1
__IO uint32_t iocb7: 1
__IO uint32_t iocb8: 1
__IO uint32_t iocb9: 1
__IO uint32_t iocb10: 1
__IO uint32_t iocb11: 1
__IO uint32_t iocb12: 1
__IO uint32_t iocb13: 1
__IO uint32_t iocb14: 1
__IO uint32_t iocb15: 1
} scr_bit
};
gpio scr register, offset:0x10 More...
union {
__IO uint32_t clr
struct {
__IO uint32_t iocb0: 1
__IO uint32_t iocb1: 1
__IO uint32_t iocb2: 1
__IO uint32_t iocb3: 1
__IO uint32_t iocb4: 1
__IO uint32_t iocb5: 1
__IO uint32_t iocb6: 1
__IO uint32_t iocb7: 1
__IO uint32_t iocb8: 1
__IO uint32_t iocb9: 1
__IO uint32_t iocb10: 1
__IO uint32_t iocb11: 1
__IO uint32_t iocb12: 1
__IO uint32_t iocb13: 1
__IO uint32_t iocb14: 1
__IO uint32_t iocb15: 1
__IO uint32_t reserved1: 16
} clr_bit
};
gpio clr register, offset:0x14 More...
union {
__IO uint32_t wpr
struct {
__IO uint32_t wpen0: 1
__IO uint32_t wpen1: 1
__IO uint32_t wpen2: 1
__IO uint32_t wpen3: 1
__IO uint32_t wpen4: 1
__IO uint32_t wpen5: 1
__IO uint32_t wpen6: 1
__IO uint32_t wpen7: 1
__IO uint32_t wpen8: 1
__IO uint32_t wpen9: 1
__IO uint32_t wpen10: 1
__IO uint32_t wpen11: 1
__IO uint32_t wpen12: 1
__IO uint32_t wpen13: 1
__IO uint32_t wpen14: 1
__IO uint32_t wpen15: 1
__IO uint32_t wpseq: 1
__IO uint32_t reserved1: 15
} wpr_bit
};
gpio wpr register, offset:0x18 More...

Detailed Description

type define gpio register all

Definition at line 299 of file at32f413_gpio.h.

Field Documentation

◆

union { ... } gpio_type::@448

gpio cfglr register, offset:0x00

◆

union { ... } gpio_type::@450

gpio cfghr register, offset:0x04

◆

union { ... } gpio_type::@452

gpio idt register, offset:0x08

◆

union { ... } gpio_type::@454

gpio odt register, offset:0x0C

◆

union { ... } gpio_type::@456

gpio scr register, offset:0x10

◆

union { ... } gpio_type::@458

gpio clr register, offset:0x14

◆

union { ... } gpio_type::@460

gpio wpr register, offset:0x18

◆ cfghr

__IO uint32_t gpio_type::cfghr

Definition at line 333 of file at32f413_gpio.h.

Referenced by gpio_init().

◆

struct { ... } gpio_type::cfghr_bit

◆ cfglr

__IO uint32_t gpio_type::cfglr

Definition at line 306 of file at32f413_gpio.h.

Referenced by gpio_init().

◆

struct { ... } gpio_type::cfglr_bit

◆ clr

__IO uint32_t gpio_type::clr

Definition at line 459 of file at32f413_gpio.h.

Referenced by at32_led_on(), gpio_bits_reset(), gpio_bits_write(), and gpio_init().

◆

struct { ... } gpio_type::clr_bit

◆ idt

__IO uint32_t gpio_type::idt

Definition at line 360 of file at32f413_gpio.h.

Referenced by gpio_input_data_bit_read(), and gpio_input_data_read().

◆ idt0

__IO uint32_t gpio_type::idt0

Definition at line 363 of file at32f413_gpio.h.

◆ idt1

__IO uint32_t gpio_type::idt1

Definition at line 364 of file at32f413_gpio.h.

◆ idt10

__IO uint32_t gpio_type::idt10

Definition at line 373 of file at32f413_gpio.h.

◆ idt11

__IO uint32_t gpio_type::idt11

Definition at line 374 of file at32f413_gpio.h.

◆ idt12

__IO uint32_t gpio_type::idt12

Definition at line 375 of file at32f413_gpio.h.

◆ idt13

__IO uint32_t gpio_type::idt13

Definition at line 376 of file at32f413_gpio.h.

◆ idt14

__IO uint32_t gpio_type::idt14

Definition at line 377 of file at32f413_gpio.h.

◆ idt15

__IO uint32_t gpio_type::idt15

Definition at line 378 of file at32f413_gpio.h.

◆ idt2

__IO uint32_t gpio_type::idt2

Definition at line 365 of file at32f413_gpio.h.

◆ idt3

__IO uint32_t gpio_type::idt3

Definition at line 366 of file at32f413_gpio.h.

◆ idt4

__IO uint32_t gpio_type::idt4

Definition at line 367 of file at32f413_gpio.h.

◆ idt5

__IO uint32_t gpio_type::idt5

Definition at line 368 of file at32f413_gpio.h.

◆ idt6

__IO uint32_t gpio_type::idt6

Definition at line 369 of file at32f413_gpio.h.

◆ idt7

__IO uint32_t gpio_type::idt7

Definition at line 370 of file at32f413_gpio.h.

◆ idt8

__IO uint32_t gpio_type::idt8

Definition at line 371 of file at32f413_gpio.h.

◆ idt9

__IO uint32_t gpio_type::idt9

Definition at line 372 of file at32f413_gpio.h.

◆

struct { ... } gpio_type::idt_bit

◆ iocb0

__IO uint32_t gpio_type::iocb0

Definition at line 435 of file at32f413_gpio.h.

◆ iocb1

__IO uint32_t gpio_type::iocb1

Definition at line 436 of file at32f413_gpio.h.

◆ iocb10

__IO uint32_t gpio_type::iocb10

Definition at line 445 of file at32f413_gpio.h.

◆ iocb11

__IO uint32_t gpio_type::iocb11

Definition at line 446 of file at32f413_gpio.h.

◆ iocb12

__IO uint32_t gpio_type::iocb12

Definition at line 447 of file at32f413_gpio.h.

◆ iocb13

__IO uint32_t gpio_type::iocb13

Definition at line 448 of file at32f413_gpio.h.

◆ iocb14

__IO uint32_t gpio_type::iocb14

Definition at line 449 of file at32f413_gpio.h.

◆ iocb15

__IO uint32_t gpio_type::iocb15

Definition at line 450 of file at32f413_gpio.h.

◆ iocb2

__IO uint32_t gpio_type::iocb2

Definition at line 437 of file at32f413_gpio.h.

◆ iocb3

__IO uint32_t gpio_type::iocb3

Definition at line 438 of file at32f413_gpio.h.

◆ iocb4

__IO uint32_t gpio_type::iocb4

Definition at line 439 of file at32f413_gpio.h.

◆ iocb5

__IO uint32_t gpio_type::iocb5

Definition at line 440 of file at32f413_gpio.h.

◆ iocb6

__IO uint32_t gpio_type::iocb6

Definition at line 441 of file at32f413_gpio.h.

◆ iocb7

__IO uint32_t gpio_type::iocb7

Definition at line 442 of file at32f413_gpio.h.

◆ iocb8

__IO uint32_t gpio_type::iocb8

Definition at line 443 of file at32f413_gpio.h.

◆ iocb9

__IO uint32_t gpio_type::iocb9

Definition at line 444 of file at32f413_gpio.h.

◆ iofc0

__IO uint32_t gpio_type::iofc0

Definition at line 310 of file at32f413_gpio.h.

◆ iofc1

__IO uint32_t gpio_type::iofc1

Definition at line 312 of file at32f413_gpio.h.

◆ iofc10

__IO uint32_t gpio_type::iofc10

Definition at line 341 of file at32f413_gpio.h.

◆ iofc11

__IO uint32_t gpio_type::iofc11

Definition at line 343 of file at32f413_gpio.h.

◆ iofc12

__IO uint32_t gpio_type::iofc12

Definition at line 345 of file at32f413_gpio.h.

◆ iofc13

__IO uint32_t gpio_type::iofc13

Definition at line 347 of file at32f413_gpio.h.

◆ iofc14

__IO uint32_t gpio_type::iofc14

Definition at line 349 of file at32f413_gpio.h.

◆ iofc15

__IO uint32_t gpio_type::iofc15

Definition at line 351 of file at32f413_gpio.h.

◆ iofc2

__IO uint32_t gpio_type::iofc2

Definition at line 314 of file at32f413_gpio.h.

◆ iofc3

__IO uint32_t gpio_type::iofc3

Definition at line 316 of file at32f413_gpio.h.

◆ iofc4

__IO uint32_t gpio_type::iofc4

Definition at line 318 of file at32f413_gpio.h.

◆ iofc5

__IO uint32_t gpio_type::iofc5

Definition at line 320 of file at32f413_gpio.h.

◆ iofc6

__IO uint32_t gpio_type::iofc6

Definition at line 322 of file at32f413_gpio.h.

◆ iofc7

__IO uint32_t gpio_type::iofc7

Definition at line 324 of file at32f413_gpio.h.

◆ iofc8

__IO uint32_t gpio_type::iofc8

Definition at line 337 of file at32f413_gpio.h.

◆ iofc9

__IO uint32_t gpio_type::iofc9

Definition at line 339 of file at32f413_gpio.h.

◆ iomc0

__IO uint32_t gpio_type::iomc0

Definition at line 309 of file at32f413_gpio.h.

◆ iomc1

__IO uint32_t gpio_type::iomc1

Definition at line 311 of file at32f413_gpio.h.

◆ iomc10

__IO uint32_t gpio_type::iomc10

Definition at line 340 of file at32f413_gpio.h.

◆ iomc11

__IO uint32_t gpio_type::iomc11

Definition at line 342 of file at32f413_gpio.h.

◆ iomc12

__IO uint32_t gpio_type::iomc12

Definition at line 344 of file at32f413_gpio.h.

◆ iomc13

__IO uint32_t gpio_type::iomc13

Definition at line 346 of file at32f413_gpio.h.

◆ iomc14

__IO uint32_t gpio_type::iomc14

Definition at line 348 of file at32f413_gpio.h.

◆ iomc15

__IO uint32_t gpio_type::iomc15

Definition at line 350 of file at32f413_gpio.h.

◆ iomc2

__IO uint32_t gpio_type::iomc2

Definition at line 313 of file at32f413_gpio.h.

◆ iomc3

__IO uint32_t gpio_type::iomc3

Definition at line 315 of file at32f413_gpio.h.

◆ iomc4

__IO uint32_t gpio_type::iomc4

Definition at line 317 of file at32f413_gpio.h.

◆ iomc5

__IO uint32_t gpio_type::iomc5

Definition at line 319 of file at32f413_gpio.h.

◆ iomc6

__IO uint32_t gpio_type::iomc6

Definition at line 321 of file at32f413_gpio.h.

◆ iomc7

__IO uint32_t gpio_type::iomc7

Definition at line 323 of file at32f413_gpio.h.

◆ iomc8

__IO uint32_t gpio_type::iomc8

Definition at line 336 of file at32f413_gpio.h.

◆ iomc9

__IO uint32_t gpio_type::iomc9

Definition at line 338 of file at32f413_gpio.h.

◆ iosb0

__IO uint32_t gpio_type::iosb0

Definition at line 419 of file at32f413_gpio.h.

◆ iosb1

__IO uint32_t gpio_type::iosb1

Definition at line 420 of file at32f413_gpio.h.

◆ iosb10

__IO uint32_t gpio_type::iosb10

Definition at line 429 of file at32f413_gpio.h.

◆ iosb11

__IO uint32_t gpio_type::iosb11

Definition at line 430 of file at32f413_gpio.h.

◆ iosb12

__IO uint32_t gpio_type::iosb12

Definition at line 431 of file at32f413_gpio.h.

◆ iosb13

__IO uint32_t gpio_type::iosb13

Definition at line 432 of file at32f413_gpio.h.

◆ iosb14

__IO uint32_t gpio_type::iosb14

Definition at line 433 of file at32f413_gpio.h.

◆ iosb15

__IO uint32_t gpio_type::iosb15

Definition at line 434 of file at32f413_gpio.h.

◆ iosb2

__IO uint32_t gpio_type::iosb2

Definition at line 421 of file at32f413_gpio.h.

◆ iosb3

__IO uint32_t gpio_type::iosb3

Definition at line 422 of file at32f413_gpio.h.

◆ iosb4

__IO uint32_t gpio_type::iosb4

Definition at line 423 of file at32f413_gpio.h.

◆ iosb5

__IO uint32_t gpio_type::iosb5

Definition at line 424 of file at32f413_gpio.h.

◆ iosb6

__IO uint32_t gpio_type::iosb6

Definition at line 425 of file at32f413_gpio.h.

◆ iosb7

__IO uint32_t gpio_type::iosb7

Definition at line 426 of file at32f413_gpio.h.

◆ iosb8

__IO uint32_t gpio_type::iosb8

Definition at line 427 of file at32f413_gpio.h.

◆ iosb9

__IO uint32_t gpio_type::iosb9

Definition at line 428 of file at32f413_gpio.h.

◆ odt

__IO uint32_t gpio_type::odt

Definition at line 388 of file at32f413_gpio.h.

Referenced by at32_led_toggle(), gpio_output_data_bit_read(), gpio_output_data_read(), gpio_pins_toggle(), and gpio_port_wirte().

◆ odt0

__IO uint32_t gpio_type::odt0

Definition at line 391 of file at32f413_gpio.h.

◆ odt1

__IO uint32_t gpio_type::odt1

Definition at line 392 of file at32f413_gpio.h.

◆ odt10

__IO uint32_t gpio_type::odt10

Definition at line 401 of file at32f413_gpio.h.

◆ odt11

__IO uint32_t gpio_type::odt11

Definition at line 402 of file at32f413_gpio.h.

◆ odt12

__IO uint32_t gpio_type::odt12

Definition at line 403 of file at32f413_gpio.h.

◆ odt13

__IO uint32_t gpio_type::odt13

Definition at line 404 of file at32f413_gpio.h.

◆ odt14

__IO uint32_t gpio_type::odt14

Definition at line 405 of file at32f413_gpio.h.

◆ odt15

__IO uint32_t gpio_type::odt15

Definition at line 406 of file at32f413_gpio.h.

◆ odt2

__IO uint32_t gpio_type::odt2

Definition at line 393 of file at32f413_gpio.h.

◆ odt3

__IO uint32_t gpio_type::odt3

Definition at line 394 of file at32f413_gpio.h.

◆ odt4

__IO uint32_t gpio_type::odt4

Definition at line 395 of file at32f413_gpio.h.

◆ odt5

__IO uint32_t gpio_type::odt5

Definition at line 396 of file at32f413_gpio.h.

◆ odt6

__IO uint32_t gpio_type::odt6

Definition at line 397 of file at32f413_gpio.h.

◆ odt7

__IO uint32_t gpio_type::odt7

Definition at line 398 of file at32f413_gpio.h.

◆ odt8

__IO uint32_t gpio_type::odt8

Definition at line 399 of file at32f413_gpio.h.

◆ odt9

__IO uint32_t gpio_type::odt9

Definition at line 400 of file at32f413_gpio.h.

◆

struct { ... } gpio_type::odt_bit

◆ reserved1

__IO uint32_t gpio_type::reserved1

Definition at line 379 of file at32f413_gpio.h.

◆ scr

__IO uint32_t gpio_type::scr

Definition at line 416 of file at32f413_gpio.h.

Referenced by at32_led_off(), gpio_bits_set(), gpio_bits_write(), and gpio_init().

◆

struct { ... } gpio_type::scr_bit

◆ wpen0

__IO uint32_t gpio_type::wpen0

Definition at line 490 of file at32f413_gpio.h.

◆ wpen1

__IO uint32_t gpio_type::wpen1

Definition at line 491 of file at32f413_gpio.h.

◆ wpen10

__IO uint32_t gpio_type::wpen10

Definition at line 500 of file at32f413_gpio.h.

◆ wpen11

__IO uint32_t gpio_type::wpen11

Definition at line 501 of file at32f413_gpio.h.

◆ wpen12

__IO uint32_t gpio_type::wpen12

Definition at line 502 of file at32f413_gpio.h.

◆ wpen13

__IO uint32_t gpio_type::wpen13

Definition at line 503 of file at32f413_gpio.h.

◆ wpen14

__IO uint32_t gpio_type::wpen14

Definition at line 504 of file at32f413_gpio.h.

◆ wpen15

__IO uint32_t gpio_type::wpen15

Definition at line 505 of file at32f413_gpio.h.

◆ wpen2

__IO uint32_t gpio_type::wpen2

Definition at line 492 of file at32f413_gpio.h.

◆ wpen3

__IO uint32_t gpio_type::wpen3

Definition at line 493 of file at32f413_gpio.h.

◆ wpen4

__IO uint32_t gpio_type::wpen4

Definition at line 494 of file at32f413_gpio.h.

◆ wpen5

__IO uint32_t gpio_type::wpen5

Definition at line 495 of file at32f413_gpio.h.

◆ wpen6

__IO uint32_t gpio_type::wpen6

Definition at line 496 of file at32f413_gpio.h.

◆ wpen7

__IO uint32_t gpio_type::wpen7

Definition at line 497 of file at32f413_gpio.h.

◆ wpen8

__IO uint32_t gpio_type::wpen8

Definition at line 498 of file at32f413_gpio.h.

◆ wpen9

__IO uint32_t gpio_type::wpen9

Definition at line 499 of file at32f413_gpio.h.

◆ wpr

__IO uint32_t gpio_type::wpr

Definition at line 487 of file at32f413_gpio.h.

Referenced by gpio_pin_wp_config().

◆

struct { ... } gpio_type::wpr_bit

◆ wpseq

__IO uint32_t gpio_type::wpseq

Definition at line 506 of file at32f413_gpio.h.

The documentation for this struct was generated from the following file:
  • at32f413_gpio.h


AT32F413 Firmwary Library: iomux_type Struct Reference

Data Fields
iomux_type Struct Reference
AT32F413_periph_driver » GPIO » GPIO_exported_types

type define iomux register all More...

#include <at32f413_gpio.h>

Data Fields

union {
__IO uint32_t evtout
struct {
__IO uint32_t selpin: 4
__IO uint32_t selport: 3
__IO uint32_t evoen: 1
__IO uint32_t reserved1: 24
} evtout_bit
};
mux event control register, offset:0x00 More...
union {
__IO uint32_t remap
struct {
__IO uint32_t spi1_mux_l: 1
__IO uint32_t i2c1_mux: 1
__IO uint32_t usart1_mux: 1
__IO uint32_t reserved1: 1
__IO uint32_t usart3_mux: 2
__IO uint32_t tmr1_mux: 2
__IO uint32_t tmr2_mux: 2
__IO uint32_t tmr3_mux: 2
__IO uint32_t reserved2: 1
__IO uint32_t can_mux: 2
__IO uint32_t pd01_mux: 1
__IO uint32_t tmr5ch4_mux: 1
__IO uint32_t adc1_extrgpre_mux: 1
__IO uint32_t adc1_extrgord_mux: 1
__IO uint32_t adc2_extrgpre_mux: 1
__IO uint32_t adc2_extrgord_mux: 1
__IO uint32_t reserved3: 3
__IO uint32_t swjtag_conf: 3
__IO uint32_t reserved4: 4
__IO uint32_t spi1_mux_h: 1
} remap_bit
};
iomux remap register, offset:0x04 More...
union {
__IO uint32_t exintc1
struct {
__IO uint32_t exint0: 4
__IO uint32_t exint1: 4
__IO uint32_t exint2: 4
__IO uint32_t exint3: 4
__IO uint32_t reserved1: 16
} exintc1_bit
};
mux external interrupt configuration register 1, offset:0x08 More...
union {
__IO uint32_t exintc2
struct {
__IO uint32_t exint4: 4
__IO uint32_t exint5: 4
__IO uint32_t exint6: 4
__IO uint32_t exint7: 4
__IO uint32_t reserved1: 16
} exintc2_bit
};
mux external interrupt configuration register 2, offset:0x0c More...
union {
__IO uint32_t exintc3
struct {
__IO uint32_t exint8: 4
__IO uint32_t exint9: 4
__IO uint32_t exint10: 4
__IO uint32_t exint11: 4
__IO uint32_t reserved1: 16
} exintc3_bit
};
mux external interrupt configuration register 3, offset:0x10 More...
union {
__IO uint32_t exintc4
struct {
__IO uint32_t exint12: 4
__IO uint32_t exint13: 4
__IO uint32_t exint14: 4
__IO uint32_t exint15: 4
__IO uint32_t reserved1: 16
} exintc4_bit
};
mux external interrupt configuration register 4, offset:0x14 More...
union {
__IO uint32_t remap2
struct {
__IO uint32_t reserved1: 21
__IO uint32_t ext_spim_en_mux: 1
__IO uint32_t reserved2: 10
} remap2_bit
};
iomux remap register 2, offset:0x1C More...
union {
__IO uint32_t remap3
struct {
__IO uint32_t tmr9_gmux: 4
__IO uint32_t tmr10_gmux: 4
__IO uint32_t tmr11_gmux: 4
__IO uint32_t reserved1: 20
} remap3_bit
};
iomux remap register 3, offset:0x20 More...
union {
__IO uint32_t remap4
struct {
__IO uint32_t tmr1_gmux: 4
__IO uint32_t tmr2_gmux: 3
__IO uint32_t tmr2itr1_gmux: 1
__IO uint32_t tmr3_gmux: 4
__IO uint32_t reserved1: 4
__IO uint32_t tmr5_gmux: 3
__IO uint32_t tmr5ch4_gmux: 1
__IO uint32_t reserved2: 12
} remap4_bit
};
iomux remap register 4, offset:0x24 More...
union {
__IO uint32_t remap5
struct {
__IO uint32_t reserved1: 4
__IO uint32_t i2c1_gmux: 4
__IO uint32_t i2c2_gmux: 4
__IO uint32_t reserved2: 4
__IO uint32_t spi1_gmux: 4
__IO uint32_t spi2_gmux: 4
__IO uint32_t reserved3: 8
} remap5_bit
};
iomux remap register 5, offset:0x28 More...
union {
__IO uint32_t remap6
struct {
__IO uint32_t can1_gmux: 4
__IO uint32_t can2_gmux: 4
__IO uint32_t sdio1_gmux: 4
__IO uint32_t reserved1: 4
__IO uint32_t usart1_gmux: 4
__IO uint32_t reserved2: 4
__IO uint32_t usart3_gmux: 4
__IO uint32_t uart4_gmux: 4
} remap6_bit
};
iomux remap register 6, offset:0x2C More...
union {
__IO uint32_t remap7
struct {
__IO uint32_t ext_spim_gmux: 3
__IO uint32_t ext_spim_gen: 1
__IO uint32_t adc1_etp_gmux: 1
__IO uint32_t adc1_eto_gmux: 1
__IO uint32_t reserved1: 2
__IO uint32_t adc2_etp_gmux: 1
__IO uint32_t adc2_eto_gmux: 1
__IO uint32_t reserved2: 6
__IO uint32_t swjtag_gmux: 3
__IO uint32_t reserved3: 1
__IO uint32_t pd01_gmux: 1
__IO uint32_t reserved4: 11
} remap7_bit
};
iomux remap register 7, offset:0x30 More...

Detailed Description

type define iomux register all

Definition at line 516 of file at32f413_gpio.h.

Field Documentation

◆

union { ... } iomux_type::@469

mux event control register, offset:0x00

◆

union { ... } iomux_type::@471

iomux remap register, offset:0x04

◆

union { ... } iomux_type::@473

mux external interrupt configuration register 1, offset:0x08

◆

union { ... } iomux_type::@475

mux external interrupt configuration register 2, offset:0x0c

◆

union { ... } iomux_type::@477

mux external interrupt configuration register 3, offset:0x10

◆

union { ... } iomux_type::@479

mux external interrupt configuration register 4, offset:0x14

◆

union { ... } iomux_type::@481

iomux remap register 2, offset:0x1C

◆

union { ... } iomux_type::@483

iomux remap register 3, offset:0x20

◆

union { ... } iomux_type::@485

iomux remap register 4, offset:0x24

◆

union { ... } iomux_type::@487

iomux remap register 5, offset:0x28

◆

union { ... } iomux_type::@489

iomux remap register 6, offset:0x2C

◆

union { ... } iomux_type::@491

iomux remap register 7, offset:0x30

◆ adc1_eto_gmux

__IO uint32_t iomux_type::adc1_eto_gmux

Definition at line 729 of file at32f413_gpio.h.

◆ adc1_etp_gmux

__IO uint32_t iomux_type::adc1_etp_gmux

Definition at line 728 of file at32f413_gpio.h.

◆ adc1_extrgord_mux

__IO uint32_t iomux_type::adc1_extrgord_mux

Definition at line 554 of file at32f413_gpio.h.

◆ adc1_extrgpre_mux

__IO uint32_t iomux_type::adc1_extrgpre_mux

Definition at line 553 of file at32f413_gpio.h.

◆ adc2_eto_gmux

__IO uint32_t iomux_type::adc2_eto_gmux

Definition at line 732 of file at32f413_gpio.h.

◆ adc2_etp_gmux

__IO uint32_t iomux_type::adc2_etp_gmux

Definition at line 731 of file at32f413_gpio.h.

◆ adc2_extrgord_mux

__IO uint32_t iomux_type::adc2_extrgord_mux

Definition at line 556 of file at32f413_gpio.h.

◆ adc2_extrgpre_mux

__IO uint32_t iomux_type::adc2_extrgpre_mux

Definition at line 555 of file at32f413_gpio.h.

◆ can1_gmux

__IO uint32_t iomux_type::can1_gmux

Definition at line 707 of file at32f413_gpio.h.

◆ can2_gmux

__IO uint32_t iomux_type::can2_gmux

Definition at line 708 of file at32f413_gpio.h.

◆ can_mux

__IO uint32_t iomux_type::can_mux

Definition at line 550 of file at32f413_gpio.h.

◆ evoen

__IO uint32_t iomux_type::evoen

Definition at line 528 of file at32f413_gpio.h.

◆ evtout

__IO uint32_t iomux_type::evtout

Definition at line 523 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::evtout_bit

◆ exint0

__IO uint32_t iomux_type::exint0

Definition at line 572 of file at32f413_gpio.h.

◆ exint1

__IO uint32_t iomux_type::exint1

Definition at line 573 of file at32f413_gpio.h.

◆ exint10

__IO uint32_t iomux_type::exint10

Definition at line 606 of file at32f413_gpio.h.

◆ exint11

__IO uint32_t iomux_type::exint11

Definition at line 607 of file at32f413_gpio.h.

◆ exint12

__IO uint32_t iomux_type::exint12

Definition at line 620 of file at32f413_gpio.h.

◆ exint13

__IO uint32_t iomux_type::exint13

Definition at line 621 of file at32f413_gpio.h.

◆ exint14

__IO uint32_t iomux_type::exint14

Definition at line 622 of file at32f413_gpio.h.

◆ exint15

__IO uint32_t iomux_type::exint15

Definition at line 623 of file at32f413_gpio.h.

◆ exint2

__IO uint32_t iomux_type::exint2

Definition at line 574 of file at32f413_gpio.h.

◆ exint3

__IO uint32_t iomux_type::exint3

Definition at line 575 of file at32f413_gpio.h.

◆ exint4

__IO uint32_t iomux_type::exint4

Definition at line 588 of file at32f413_gpio.h.

◆ exint5

__IO uint32_t iomux_type::exint5

Definition at line 589 of file at32f413_gpio.h.

◆ exint6

__IO uint32_t iomux_type::exint6

Definition at line 590 of file at32f413_gpio.h.

◆ exint7

__IO uint32_t iomux_type::exint7

Definition at line 591 of file at32f413_gpio.h.

◆ exint8

__IO uint32_t iomux_type::exint8

Definition at line 604 of file at32f413_gpio.h.

◆ exint9

__IO uint32_t iomux_type::exint9

Definition at line 605 of file at32f413_gpio.h.

◆ exintc1

__IO uint32_t iomux_type::exintc1

Definition at line 569 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::exintc1_bit

◆ exintc2

__IO uint32_t iomux_type::exintc2

Definition at line 585 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::exintc2_bit

◆ exintc3

__IO uint32_t iomux_type::exintc3

Definition at line 601 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::exintc3_bit

◆ exintc4

__IO uint32_t iomux_type::exintc4

Definition at line 617 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::exintc4_bit

◆ ext_spim_en_mux

__IO uint32_t iomux_type::ext_spim_en_mux

Definition at line 642 of file at32f413_gpio.h.

◆ ext_spim_gen

__IO uint32_t iomux_type::ext_spim_gen

Definition at line 727 of file at32f413_gpio.h.

◆ ext_spim_gmux

__IO uint32_t iomux_type::ext_spim_gmux

Definition at line 726 of file at32f413_gpio.h.

◆ i2c1_gmux

__IO uint32_t iomux_type::i2c1_gmux

Definition at line 690 of file at32f413_gpio.h.

◆ i2c1_mux

__IO uint32_t iomux_type::i2c1_mux

Definition at line 542 of file at32f413_gpio.h.

◆ i2c2_gmux

__IO uint32_t iomux_type::i2c2_gmux

Definition at line 691 of file at32f413_gpio.h.

◆ pd01_gmux

__IO uint32_t iomux_type::pd01_gmux

Definition at line 736 of file at32f413_gpio.h.

◆ pd01_mux

__IO uint32_t iomux_type::pd01_mux

Definition at line 551 of file at32f413_gpio.h.

◆ remap

__IO uint32_t iomux_type::remap

Definition at line 538 of file at32f413_gpio.h.

◆ remap2

__IO uint32_t iomux_type::remap2

Definition at line 638 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap2_bit

◆ remap3

__IO uint32_t iomux_type::remap3

Definition at line 652 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap3_bit

◆ remap4

__IO uint32_t iomux_type::remap4

Definition at line 667 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap4_bit

◆ remap5

__IO uint32_t iomux_type::remap5

Definition at line 686 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap5_bit

◆ remap6

__IO uint32_t iomux_type::remap6

Definition at line 704 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap6_bit

◆ remap7

__IO uint32_t iomux_type::remap7

Definition at line 723 of file at32f413_gpio.h.

◆

struct { ... } iomux_type::remap7_bit

◆

struct { ... } iomux_type::remap_bit

◆ reserved1

__IO uint32_t iomux_type::reserved1

iomux reserved1 register, offset:0x18

Definition at line 529 of file at32f413_gpio.h.

◆ reserved2

__IO uint32_t iomux_type::reserved2

Definition at line 549 of file at32f413_gpio.h.

◆ reserved3

__IO uint32_t iomux_type::reserved3

Definition at line 557 of file at32f413_gpio.h.

◆ reserved4

__IO uint32_t iomux_type::reserved4

Definition at line 559 of file at32f413_gpio.h.

◆ sdio1_gmux

__IO uint32_t iomux_type::sdio1_gmux

Definition at line 709 of file at32f413_gpio.h.

◆ selpin

__IO uint32_t iomux_type::selpin

Definition at line 526 of file at32f413_gpio.h.

◆ selport

__IO uint32_t iomux_type::selport

Definition at line 527 of file at32f413_gpio.h.

◆ spi1_gmux

__IO uint32_t iomux_type::spi1_gmux

Definition at line 693 of file at32f413_gpio.h.

◆ spi1_mux_h

__IO uint32_t iomux_type::spi1_mux_h

Definition at line 560 of file at32f413_gpio.h.

◆ spi1_mux_l

__IO uint32_t iomux_type::spi1_mux_l

Definition at line 541 of file at32f413_gpio.h.

◆ spi2_gmux

__IO uint32_t iomux_type::spi2_gmux

Definition at line 694 of file at32f413_gpio.h.

◆ swjtag_conf

__IO uint32_t iomux_type::swjtag_conf

Definition at line 558 of file at32f413_gpio.h.

◆ swjtag_gmux

__IO uint32_t iomux_type::swjtag_gmux

Definition at line 734 of file at32f413_gpio.h.

◆ tmr10_gmux

__IO uint32_t iomux_type::tmr10_gmux

Definition at line 656 of file at32f413_gpio.h.

◆ tmr11_gmux

__IO uint32_t iomux_type::tmr11_gmux

Definition at line 657 of file at32f413_gpio.h.

◆ tmr1_gmux

__IO uint32_t iomux_type::tmr1_gmux

Definition at line 670 of file at32f413_gpio.h.

◆ tmr1_mux

__IO uint32_t iomux_type::tmr1_mux

Definition at line 546 of file at32f413_gpio.h.

◆ tmr2_gmux

__IO uint32_t iomux_type::tmr2_gmux

Definition at line 671 of file at32f413_gpio.h.

◆ tmr2_mux

__IO uint32_t iomux_type::tmr2_mux

Definition at line 547 of file at32f413_gpio.h.

◆ tmr2itr1_gmux

__IO uint32_t iomux_type::tmr2itr1_gmux

Definition at line 672 of file at32f413_gpio.h.

◆ tmr3_gmux

__IO uint32_t iomux_type::tmr3_gmux

Definition at line 673 of file at32f413_gpio.h.

◆ tmr3_mux

__IO uint32_t iomux_type::tmr3_mux

Definition at line 548 of file at32f413_gpio.h.

◆ tmr5_gmux

__IO uint32_t iomux_type::tmr5_gmux

Definition at line 675 of file at32f413_gpio.h.

◆ tmr5ch4_gmux

__IO uint32_t iomux_type::tmr5ch4_gmux

Definition at line 676 of file at32f413_gpio.h.

◆ tmr5ch4_mux

__IO uint32_t iomux_type::tmr5ch4_mux

Definition at line 552 of file at32f413_gpio.h.

◆ tmr9_gmux

__IO uint32_t iomux_type::tmr9_gmux

Definition at line 655 of file at32f413_gpio.h.

◆ uart4_gmux

__IO uint32_t iomux_type::uart4_gmux

Definition at line 714 of file at32f413_gpio.h.

◆ usart1_gmux

__IO uint32_t iomux_type::usart1_gmux

Definition at line 711 of file at32f413_gpio.h.

◆ usart1_mux

__IO uint32_t iomux_type::usart1_mux

Definition at line 543 of file at32f413_gpio.h.

◆ usart3_gmux

__IO uint32_t iomux_type::usart3_gmux

Definition at line 713 of file at32f413_gpio.h.

◆ usart3_mux

__IO uint32_t iomux_type::usart3_mux

Definition at line 545 of file at32f413_gpio.h.

The documentation for this struct was generated from the following file:
  • at32f413_gpio.h


AT32F413 Firmwary Library: GPIO_exported_functions

Functions
GPIO_exported_functions
AT32F413_periph_driver » GPIO

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_iomux_reset (void)
reset the mux functions (remap, event control and exint configuration) registers to their default values. More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_wirte (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_event_output_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output. More...
void | gpio_event_output_enable (confirm_state new_state)
enable or disable the event output. More...
void | gpio_pin_remap_config (uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration. More...
void | gpio_exint_line_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line. More...

Detailed Description

Function Documentation

◆ gpio_bits_reset()

void gpio_bits_reset | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

clear the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 341 of file at32f413_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), rs485_config(), rs485_send_data(), and TMR2_GLOBAL_IRQHandler().

◆ gpio_bits_set()

void gpio_bits_set | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

set the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 310 of file at32f413_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), rs485_send_data(), and usart_configuration().

◆ gpio_bits_write()

void gpio_bits_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins,
 |  | confirm_state | bit_state
 | ) |  |

set or clear the selected data port bit.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
bit_state | specifies the value to be written to the selected bit (TRUE or FALSE).
Return values
none

Definition at line 373 of file at32f413_gpio.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ gpio_default_para_init()

void gpio_default_para_init ( gpio_init_type * gpio_init_struct )

fill each gpio_init_type member with its default value.

Parameters
gpio_init_struct : pointer to a gpio_init_type structure which will be initialized.
Return values
none

< gpio all pins

Definition at line 168 of file at32f413_gpio.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), mclk_tmr1_init(), rs485_config(), spim_init(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), and usart_spi_configuration().

◆ gpio_event_output_config()

void gpio_event_output_config | ( | gpio_port_source_type | gpio_port_source,
 |  | gpio_pins_source_type | gpio_pin_source
 | ) |  |

select the gpio pin used as event output.

Parameters
gpio_port_source select the gpio port to be used as source for event output. this parameter can be one of the following values:
  • GPIO_PORT_SOURCE_GPIOA
  • GPIO_PORT_SOURCE_GPIOB
  • GPIO_PORT_SOURCE_GPIOC
  • GPIO_PORT_SOURCE_GPIOD
  • GPIO_PORT_SOURCE_GPIOF
gpio_pin_source specifies the pin for the event output. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
Return values
none

Definition at line 471 of file at32f413_gpio.c.

◆ gpio_event_output_enable()

void gpio_event_output_enable ( confirm_state new_state )

enable or disable the event output.

Parameters
confirm_state new state of the event output. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 490 of file at32f413_gpio.c.

◆ gpio_exint_line_config()

void gpio_exint_line_config | ( | gpio_port_source_type | gpio_port_source,
 |  | gpio_pins_source_type | gpio_pin_source
 | ) |  |

select the gpio pin used as exint line.

Parameters
gpio_port_source select the gpio port to be used as source for exint. this parameter can be one of the following values:
  • GPIO_PORT_SOURCE_GPIOA
  • GPIO_PORT_SOURCE_GPIOB
  • GPIO_PORT_SOURCE_GPIOC
  • GPIO_PORT_SOURCE_GPIOD
  • GPIO_PORT_SOURCE_GPIOF
gpio_pin_source specifies the pin for the event output. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
Return values
none

Definition at line 573 of file at32f413_gpio.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), and usart_configuration().

◆ gpio_init()

void gpio_init | ( | gpio_type * | gpio_x,
 |  | gpio_init_type * | gpio_init_struct
 | ) |  |

initialize the gpio peripheral.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
gpio_init_struct | pointer to gpio init structure.
Return values
none

Definition at line 100 of file at32f413_gpio.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_input_data_bit_read()

flag_status gpio_input_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified input port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 203 of file at32f413_gpio.c.

Referenced by at32_button_state(), button_isr(), and gpio_config().

◆ gpio_input_data_read()

uint16_t gpio_input_data_read ( gpio_type * gpio_x )

read the specified gpio input data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
gpio input data port value.

Definition at line 226 of file at32f413_gpio.c.

◆ gpio_iomux_reset()

void gpio_iomux_reset ( void )

reset the mux functions (remap, event control and exint configuration) registers to their default values.

Parameters
none
Return values
none

Definition at line 86 of file at32f413_gpio.c.

◆ gpio_output_data_bit_read()

flag_status gpio_output_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified output port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 256 of file at32f413_gpio.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ gpio_output_data_read()

uint16_t gpio_output_data_read ( gpio_type * gpio_x )

read the specified gpio ouput data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
gpio input data port value.

Definition at line 279 of file at32f413_gpio.c.

◆ gpio_pin_remap_config()

void gpio_pin_remap_config | ( | uint32_t | gpio_remap,
 |  | confirm_state | new_state
 | ) |  |

iomux remap and debug i/o configuration.

Parameters
gpio_remap select the pin to remap. this parameter can be one of the following values:
  • SPI1_MUX_01 - I2C1_MUX - USART1_MUX - USART3_MUX_01
  • TMR1_MUX_01 - TMR2_MUX_01 - TMR2_MUX_10 - TMR2_MUX_11
  • TMR3_MUX_10 - TMR3_MUX_11 - CAN_MUX_10 - PD01_MUX
  • TMR5CH4_MUX - ADC1_EXTRGPRE_MUX - ADC1_EXTRGORD_MUX - ADC2_EXTRGPRE_MUX
  • ADC2_EXTRGORD_MUX - SWJTAG_CONF_001 - SWJTAG_CONF_010 - SWJTAG_CONF_100
  • EXT_SPIM_EN_MUX - TMR9_GMUX - TMR10_GMUX - TMR11_GMUX
  • TMR1_GMUX_0001 - TMR2_GMUX_001 - TMR2_GMUX_010 - TMR2_GMUX_011
  • TMR2ITR1_GMUX - TMR3_GMUX_0010 - TMR3_GMUX_0011 - TMR5_GMUX_001
  • TMR5CH4_GMUX - I2C1_GMUX_0001 - I2C1_GMUX_0011 - I2C2_GMUX_0001
  • I2C2_GMUX_0010 - I2C2_GMUX_0011 - SPI1_GMUX_0001 - SPI2_GMUX_0001
  • CAN1_GMUX_0010 - CAN2_GMUX_0001 - SDIO1_GMUX_0100 - SDIO1_GMUX_0101
  • SDIO1_GMUX_0110 - SDIO1_GMUX_0111 - USART1_GMUX_0001 - USART3_GMUX_0001
  • UART4_GMUX_0001 - EXT_SPIM_GMUX_1000 - EXT_SPIM_GMUX_1001 - ADC1_ETP_GMUX
  • ADC1_ETO_GMUX - ADC2_ETP_GMUX - ADC2_ETO_GMUX - SWJTAG_GMUX_001
  • SWJTAG_GMUX_010 - SWJTAG_GMUX_100 - PD01_GMUX
new_state (TRUE or FALSE)
Return values
none

Definition at line 517 of file at32f413_gpio.c.

Referenced by can_gpio_config(), gpio_config(), i2c_lowlevel_init(), main(), and spim_init().

◆ gpio_pin_wp_config()

void gpio_pin_wp_config | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

write protect gpio pins configuration registers.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be any combination of the following:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 424 of file at32f413_gpio.c.

◆ gpio_port_wirte()

void gpio_port_wirte | ( | gpio_type * | gpio_x,
 |  | uint16_t | port_value
 | ) |  |

write data to the specified gpio data port.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
port_value | specifies the value to be written to the port output data register.
Return values
none

Definition at line 393 of file at32f413_gpio.c.

◆ gpio_reset()

void gpio_reset ( gpio_type * gpio_x )

reset the gpio register

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
none

Definition at line 51 of file at32f413_gpio.c.


AT32F413 Firmwary Library: GPIO_private_functions

Functions
GPIO_private_functions
AT32F413_periph_driver » GPIO

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_iomux_reset (void)
reset the mux functions (remap, event control and exint configuration) registers to their default values. More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_wirte (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_event_output_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output. More...
void | gpio_event_output_enable (confirm_state new_state)
enable or disable the event output. More...
void | gpio_pin_remap_config (uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration. More...
void | gpio_exint_line_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line. More...

Detailed Description

Function Documentation

◆ gpio_bits_reset()

void gpio_bits_reset | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

clear the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 341 of file at32f413_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), rs485_config(), rs485_send_data(), and TMR2_GLOBAL_IRQHandler().

◆ gpio_bits_set()

void gpio_bits_set | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

set the selected data port bits.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 310 of file at32f413_gpio.c.

Referenced by EXINT9_5_IRQHandler(), main(), rs485_send_data(), and usart_configuration().

◆ gpio_bits_write()

void gpio_bits_write | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins,
 |  | confirm_state | bit_state
 | ) |  |

set or clear the selected data port bit.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number parameter can be any combination of gpio_pin_x, gpio_pin_x as following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
bit_state | specifies the value to be written to the selected bit (TRUE or FALSE).
Return values
none

Definition at line 373 of file at32f413_gpio.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ gpio_default_para_init()

void gpio_default_para_init ( gpio_init_type * gpio_init_struct )

fill each gpio_init_type member with its default value.

Parameters
gpio_init_struct : pointer to a gpio_init_type structure which will be initialized.
Return values
none

< gpio all pins

Definition at line 168 of file at32f413_gpio.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), mclk_tmr1_init(), rs485_config(), spim_init(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), and usart_spi_configuration().

◆ gpio_event_output_config()

void gpio_event_output_config | ( | gpio_port_source_type | gpio_port_source,
 |  | gpio_pins_source_type | gpio_pin_source
 | ) |  |

select the gpio pin used as event output.

Parameters
gpio_port_source select the gpio port to be used as source for event output. this parameter can be one of the following values:
  • GPIO_PORT_SOURCE_GPIOA
  • GPIO_PORT_SOURCE_GPIOB
  • GPIO_PORT_SOURCE_GPIOC
  • GPIO_PORT_SOURCE_GPIOD
  • GPIO_PORT_SOURCE_GPIOF
gpio_pin_source specifies the pin for the event output. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
Return values
none

Definition at line 471 of file at32f413_gpio.c.

◆ gpio_event_output_enable()

void gpio_event_output_enable ( confirm_state new_state )

enable or disable the event output.

Parameters
confirm_state new state of the event output. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 490 of file at32f413_gpio.c.

◆ gpio_exint_line_config()

void gpio_exint_line_config | ( | gpio_port_source_type | gpio_port_source,
 |  | gpio_pins_source_type | gpio_pin_source
 | ) |  |

select the gpio pin used as exint line.

Parameters
gpio_port_source select the gpio port to be used as source for exint. this parameter can be one of the following values:
  • GPIO_PORT_SOURCE_GPIOA
  • GPIO_PORT_SOURCE_GPIOB
  • GPIO_PORT_SOURCE_GPIOC
  • GPIO_PORT_SOURCE_GPIOD
  • GPIO_PORT_SOURCE_GPIOF
gpio_pin_source specifies the pin for the event output. this parameter can be one of the following values:
  • GPIO_PINS_SOURCE0
  • GPIO_PINS_SOURCE1
  • GPIO_PINS_SOURCE2
  • GPIO_PINS_SOURCE3
  • GPIO_PINS_SOURCE4
  • GPIO_PINS_SOURCE5
  • GPIO_PINS_SOURCE6
  • GPIO_PINS_SOURCE7
  • GPIO_PINS_SOURCE8
  • GPIO_PINS_SOURCE9
  • GPIO_PINS_SOURCE10
  • GPIO_PINS_SOURCE11
  • GPIO_PINS_SOURCE12
  • GPIO_PINS_SOURCE13
  • GPIO_PINS_SOURCE14
  • GPIO_PINS_SOURCE15
Return values
none

Definition at line 573 of file at32f413_gpio.c.

Referenced by button_exint_init(), exint_config(), exint_line0_config(), and usart_configuration().

◆ gpio_init()

void gpio_init | ( | gpio_type * | gpio_x,
 |  | gpio_init_type * | gpio_init_struct
 | ) |  |

initialize the gpio peripheral.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
gpio_init_struct | pointer to gpio init structure.
Return values
none

Definition at line 100 of file at32f413_gpio.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), exint_config(), gpio_config(), gpio_configuration(), i2c_lowlevel_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spiflash_init(), spim_init(), swj_dp_config(), tmr1_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ gpio_input_data_bit_read()

flag_status gpio_input_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified input port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 203 of file at32f413_gpio.c.

Referenced by at32_button_state(), button_isr(), and gpio_config().

◆ gpio_input_data_read()

uint16_t gpio_input_data_read ( gpio_type * gpio_x )

read the specified gpio input data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
gpio input data port value.

Definition at line 226 of file at32f413_gpio.c.

◆ gpio_iomux_reset()

void gpio_iomux_reset ( void )

reset the mux functions (remap, event control and exint configuration) registers to their default values.

Parameters
none
Return values
none

Definition at line 86 of file at32f413_gpio.c.

◆ gpio_output_data_bit_read()

flag_status gpio_output_data_bit_read | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

read the specified output port pin.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be one of the following values:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
Return values
flag_status (SET or RESET)

Definition at line 256 of file at32f413_gpio.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ gpio_output_data_read()

uint16_t gpio_output_data_read ( gpio_type * gpio_x )

read the specified gpio ouput data port.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
gpio input data port value.

Definition at line 279 of file at32f413_gpio.c.

◆ gpio_pin_remap_config()

void gpio_pin_remap_config | ( | uint32_t | gpio_remap,
 |  | confirm_state | new_state
 | ) |  |

iomux remap and debug i/o configuration.

Parameters
gpio_remap select the pin to remap. this parameter can be one of the following values:
  • SPI1_MUX_01 - I2C1_MUX - USART1_MUX - USART3_MUX_01
  • TMR1_MUX_01 - TMR2_MUX_01 - TMR2_MUX_10 - TMR2_MUX_11
  • TMR3_MUX_10 - TMR3_MUX_11 - CAN_MUX_10 - PD01_MUX
  • TMR5CH4_MUX - ADC1_EXTRGPRE_MUX - ADC1_EXTRGORD_MUX - ADC2_EXTRGPRE_MUX
  • ADC2_EXTRGORD_MUX - SWJTAG_CONF_001 - SWJTAG_CONF_010 - SWJTAG_CONF_100
  • EXT_SPIM_EN_MUX - TMR9_GMUX - TMR10_GMUX - TMR11_GMUX
  • TMR1_GMUX_0001 - TMR2_GMUX_001 - TMR2_GMUX_010 - TMR2_GMUX_011
  • TMR2ITR1_GMUX - TMR3_GMUX_0010 - TMR3_GMUX_0011 - TMR5_GMUX_001
  • TMR5CH4_GMUX - I2C1_GMUX_0001 - I2C1_GMUX_0011 - I2C2_GMUX_0001
  • I2C2_GMUX_0010 - I2C2_GMUX_0011 - SPI1_GMUX_0001 - SPI2_GMUX_0001
  • CAN1_GMUX_0010 - CAN2_GMUX_0001 - SDIO1_GMUX_0100 - SDIO1_GMUX_0101
  • SDIO1_GMUX_0110 - SDIO1_GMUX_0111 - USART1_GMUX_0001 - USART3_GMUX_0001
  • UART4_GMUX_0001 - EXT_SPIM_GMUX_1000 - EXT_SPIM_GMUX_1001 - ADC1_ETP_GMUX
  • ADC1_ETO_GMUX - ADC2_ETP_GMUX - ADC2_ETO_GMUX - SWJTAG_GMUX_001
  • SWJTAG_GMUX_010 - SWJTAG_GMUX_100 - PD01_GMUX
new_state (TRUE or FALSE)
Return values
none

Definition at line 517 of file at32f413_gpio.c.

Referenced by can_gpio_config(), gpio_config(), i2c_lowlevel_init(), main(), and spim_init().

◆ gpio_pin_wp_config()

void gpio_pin_wp_config | ( | gpio_type * | gpio_x,
 |  | uint16_t | pins
 | ) |  |

write protect gpio pins configuration registers.

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
pins gpio pin number this parameter can be any combination of the following:
  • GPIO_PINS_0
  • GPIO_PINS_1
  • GPIO_PINS_2
  • GPIO_PINS_3
  • GPIO_PINS_4
  • GPIO_PINS_5
  • GPIO_PINS_6
  • GPIO_PINS_7
  • GPIO_PINS_8
  • GPIO_PINS_9
  • GPIO_PINS_10
  • GPIO_PINS_11
  • GPIO_PINS_12
  • GPIO_PINS_13
  • GPIO_PINS_14
  • GPIO_PINS_15
  • GPIO_PINS_ALL
Return values
none

Definition at line 424 of file at32f413_gpio.c.

◆ gpio_port_wirte()

void gpio_port_wirte | ( | gpio_type * | gpio_x,
 |  | uint16_t | port_value
 | ) |  |

write data to the specified gpio data port.

Parameters
gpio_x | to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
port_value | specifies the value to be written to the port output data register.
Return values
none

Definition at line 393 of file at32f413_gpio.c.

◆ gpio_reset()

void gpio_reset ( gpio_type * gpio_x )

reset the gpio register

Parameters
gpio_x to select the gpio peripheral. this parameter can be one of the following values: GPIOA, GPIOB, GPIOC, GPIOD, GPIOF.
Return values
none

Definition at line 51 of file at32f413_gpio.c.


AT32F413 Firmwary Library: I2C

Modules | Macros
I2C
AT32F413_periph_driver

I2C driver modules. More...

Modules

I2C_sts1_flags_definition
i2c sts1 flag
I2C_sts2_flags_definition
i2c sts2 flag
I2C_interrupts_definition
i2c interrupt
I2C_exported_types
I2C_exported_functions
I2C_private_functions

Macros

#define | I2C1 ((i2c_type *) I2C1_BASE)
#define | I2C2 ((i2c_type *) I2C2_BASE)

Detailed Description

I2C driver modules.

Macro Definition Documentation

◆ I2C1

#define I2C1 ((i2c_type *) I2C1_BASE)

Definition at line 347 of file at32f413_i2c.h.

◆ I2C2

#define I2C2 ((i2c_type *) I2C2_BASE)

Definition at line 348 of file at32f413_i2c.h.


AT32F413 Firmwary Library: I2C_sts1_flags_definition

Macros
I2C_sts1_flags_definition
AT32F413_periph_driver » I2C

i2c sts1 flag More...

Macros

#define | I2C_STARTF_FLAG ((uint32_t)0x00000001)
#define | I2C_ADDR7F_FLAG ((uint32_t)0x00000002)
#define | I2C_TDC_FLAG ((uint32_t)0x00000004)
#define | I2C_ADDRHF_FLAG ((uint32_t)0x00000008)
#define | I2C_STOPF_FLAG ((uint32_t)0x00000010)
#define | I2C_RDBF_FLAG ((uint32_t)0x00000040)
#define | I2C_TDBE_FLAG ((uint32_t)0x00000080)
#define | I2C_BUSERR_FLAG ((uint32_t)0x00000100)
#define | I2C_ARLOST_FLAG ((uint32_t)0x00000200)
#define | I2C_ACKFAIL_FLAG ((uint32_t)0x00000400)
#define | I2C_OUF_FLAG ((uint32_t)0x00000800)
#define | I2C_PECERR_FLAG ((uint32_t)0x00001000)
#define | I2C_TMOUT_FLAG ((uint32_t)0x00004000)
#define | I2C_ALERTF_FLAG ((uint32_t)0x00008000)

Detailed Description

i2c sts1 flag

Macro Definition Documentation

◆ I2C_ACKFAIL_FLAG

#define I2C_ACKFAIL_FLAG ((uint32_t)0x00000400)

i2c acknowledge failure flag

Definition at line 61 of file at32f413_i2c.h.

◆ I2C_ADDR7F_FLAG

#define I2C_ADDR7F_FLAG ((uint32_t)0x00000002)

i2c 0~7 bit address match flag

Definition at line 53 of file at32f413_i2c.h.

◆ I2C_ADDRHF_FLAG

#define I2C_ADDRHF_FLAG ((uint32_t)0x00000008)

i2c master 9~8 bit address header match flag

Definition at line 55 of file at32f413_i2c.h.

◆ I2C_ALERTF_FLAG

#define I2C_ALERTF_FLAG ((uint32_t)0x00008000)

i2c smbus alert flag

Definition at line 65 of file at32f413_i2c.h.

◆ I2C_ARLOST_FLAG

#define I2C_ARLOST_FLAG ((uint32_t)0x00000200)

i2c arbitration lost flag

Definition at line 60 of file at32f413_i2c.h.

◆ I2C_BUSERR_FLAG

#define I2C_BUSERR_FLAG ((uint32_t)0x00000100)

i2c bus error flag

Definition at line 59 of file at32f413_i2c.h.

◆ I2C_OUF_FLAG

#define I2C_OUF_FLAG ((uint32_t)0x00000800)

i2c overflow or underflow flag

Definition at line 62 of file at32f413_i2c.h.

◆ I2C_PECERR_FLAG

#define I2C_PECERR_FLAG ((uint32_t)0x00001000)

i2c pec receive error flag

Definition at line 63 of file at32f413_i2c.h.

◆ I2C_RDBF_FLAG

#define I2C_RDBF_FLAG ((uint32_t)0x00000040)

i2c receive data buffer full flag

Definition at line 57 of file at32f413_i2c.h.

◆ I2C_STARTF_FLAG

#define I2C_STARTF_FLAG ((uint32_t)0x00000001)

i2c start condition generation complete flag

Definition at line 52 of file at32f413_i2c.h.

◆ I2C_STOPF_FLAG

#define I2C_STOPF_FLAG ((uint32_t)0x00000010)

i2c stop condition generation complete flag

Definition at line 56 of file at32f413_i2c.h.

◆ I2C_TDBE_FLAG

#define I2C_TDBE_FLAG ((uint32_t)0x00000080)

i2c transmit data buffer empty flag

Definition at line 58 of file at32f413_i2c.h.

◆ I2C_TDC_FLAG

#define I2C_TDC_FLAG ((uint32_t)0x00000004)

i2c transmit data complete flag

Definition at line 54 of file at32f413_i2c.h.

◆ I2C_TMOUT_FLAG

#define I2C_TMOUT_FLAG ((uint32_t)0x00004000)

i2c smbus timeout flag

Definition at line 64 of file at32f413_i2c.h.


AT32F413 Firmwary Library: I2C_sts2_flags_definition

Macros
I2C_sts2_flags_definition
AT32F413_periph_driver » I2C

i2c sts2 flag More...

Macros

#define | I2C_TRMODE_FLAG ((uint32_t)0x10010000)
#define | I2C_BUSYF_FLAG ((uint32_t)0x10020000)
#define | I2C_DIRF_FLAG ((uint32_t)0x10040000)
#define | I2C_GCADDRF_FLAG ((uint32_t)0x10100000)
#define | I2C_DEVADDRF_FLAG ((uint32_t)0x10200000)
#define | I2C_HOSTADDRF_FLAG ((uint32_t)0x10400000)
#define | I2C_ADDR2_FLAG ((uint32_t)0x10800000)

Detailed Description

i2c sts2 flag

Macro Definition Documentation

◆ I2C_ADDR2_FLAG

#define I2C_ADDR2_FLAG ((uint32_t)0x10800000)

i2c own address 2 received flag

Definition at line 82 of file at32f413_i2c.h.

◆ I2C_BUSYF_FLAG

#define I2C_BUSYF_FLAG ((uint32_t)0x10020000)

i2c bus busy flag transmission mode

Definition at line 77 of file at32f413_i2c.h.

◆ I2C_DEVADDRF_FLAG

#define I2C_DEVADDRF_FLAG ((uint32_t)0x10200000)

i2c smbus device address received flag

Definition at line 80 of file at32f413_i2c.h.

◆ I2C_DIRF_FLAG

#define I2C_DIRF_FLAG ((uint32_t)0x10040000)

i2c transmission direction flag

Definition at line 78 of file at32f413_i2c.h.

◆ I2C_GCADDRF_FLAG

#define I2C_GCADDRF_FLAG ((uint32_t)0x10100000)

i2c general call address received flag

Definition at line 79 of file at32f413_i2c.h.

◆ I2C_HOSTADDRF_FLAG

#define I2C_HOSTADDRF_FLAG ((uint32_t)0x10400000)

i2c smbus host address received flag

Definition at line 81 of file at32f413_i2c.h.

◆ I2C_TRMODE_FLAG

#define I2C_TRMODE_FLAG ((uint32_t)0x10010000)

i2c transmission mode

Definition at line 76 of file at32f413_i2c.h.


AT32F413 Firmwary Library: I2C_interrupts_definition

Macros
I2C_interrupts_definition
AT32F413_periph_driver » I2C

i2c interrupt More...

Macros

#define | I2C_DATA_INT ((uint16_t)0x0400)
#define | I2C_EVT_INT ((uint16_t)0x0200)
#define | I2C_ERR_INT ((uint16_t)0x0100)

Detailed Description

i2c interrupt

Macro Definition Documentation

◆ I2C_DATA_INT

#define I2C_DATA_INT ((uint16_t)0x0400)

i2c data transmission interrupt

Definition at line 93 of file at32f413_i2c.h.

◆ I2C_ERR_INT

#define I2C_ERR_INT ((uint16_t)0x0100)

i2c error interrupt

Definition at line 95 of file at32f413_i2c.h.

◆ I2C_EVT_INT

#define I2C_EVT_INT ((uint16_t)0x0200)

i2c event interrupt

Definition at line 94 of file at32f413_i2c.h.


AT32F413 Firmwary Library: I2C_exported_types

Data Structures | Enumerations
I2C_exported_types
AT32F413_periph_driver » I2C

Data Structures

struct i2c_type
type define i2c register all More...

Enumerations

enum | i2c_master_ack_type { I2C_MASTER_ACK_CURRENT = 0x00 , I2C_MASTER_ACK_NEXT = 0x01 }
i2c master receiving mode acknowledge control More...
enum | i2c_pec_position_type { I2C_PEC_POSITION_CURRENT = 0x00 , I2C_PEC_POSITION_NEXT = 0x01 }
i2c pec position set More...
enum | i2c_smbus_alert_set_type { I2C_SMBUS_ALERT_HIGH = 0x00 , I2C_SMBUS_ALERT_LOW = 0x01 }
i2c smbus alert pin set More...
enum | i2c_smbus_mode_set_type { I2C_SMBUS_MODE_DEVICE = 0x00 , I2C_SMBUS_MODE_HOST = 0x01 }
i2c smbus mode set More...
enum | i2c_fsmode_duty_cycle_type { I2C_FSMODE_DUTY_2_1 = 0x00 , I2C_FSMODE_DUTY_16_9 = 0x01 }
i2c fast mode duty cycle More...
enum | i2c_address_mode_type { I2C_ADDRESS_MODE_7BIT = 0x00 , I2C_ADDRESS_MODE_10BIT = 0x01 }
i2c address mode More...
enum | i2c_direction_type { I2C_DIRECTION_TRANSMIT = 0x00 , I2C_DIRECTION_RECEIVE = 0x01 }
i2c address direction More...

Detailed Description

Enumeration Type Documentation

◆ i2c_address_mode_type

enum i2c_address_mode_type

i2c address mode

Enumerator
I2C_ADDRESS_MODE_7BIT | 7bit address mode
I2C_ADDRESS_MODE_10BIT | 10bit address mode

Definition at line 155 of file at32f413_i2c.h.

◆ i2c_direction_type

enum i2c_direction_type

i2c address direction

Enumerator
I2C_DIRECTION_TRANSMIT | transmit mode
I2C_DIRECTION_RECEIVE | receive mode

Definition at line 164 of file at32f413_i2c.h.

◆ i2c_fsmode_duty_cycle_type

enum i2c_fsmode_duty_cycle_type

i2c fast mode duty cycle

Enumerator
I2C_FSMODE_DUTY_2_1 | duty cycle is 2:1 in fast mode
I2C_FSMODE_DUTY_16_9 | duty cycle is 16:9 in fast mode

Definition at line 146 of file at32f413_i2c.h.

◆ i2c_master_ack_type

enum i2c_master_ack_type

i2c master receiving mode acknowledge control

Enumerator
I2C_MASTER_ACK_CURRENT | acken bit acts on the current byte
I2C_MASTER_ACK_NEXT | acken bit acts on the next byte

Definition at line 108 of file at32f413_i2c.h.

◆ i2c_pec_position_type

enum i2c_pec_position_type

i2c pec position set

Enumerator
I2C_PEC_POSITION_CURRENT | the current byte is pec
I2C_PEC_POSITION_NEXT | the next byte is pec

Definition at line 117 of file at32f413_i2c.h.

◆ i2c_smbus_alert_set_type

enum i2c_smbus_alert_set_type

i2c smbus alert pin set

Enumerator
I2C_SMBUS_ALERT_HIGH | smbus alert pin set high
I2C_SMBUS_ALERT_LOW | smbus alert pin set low

Definition at line 127 of file at32f413_i2c.h.

◆ i2c_smbus_mode_set_type

enum i2c_smbus_mode_set_type

i2c smbus mode set

Enumerator
I2C_SMBUS_MODE_DEVICE | smbus device mode
I2C_SMBUS_MODE_HOST | smbus host mode

Definition at line 136 of file at32f413_i2c.h.


AT32F413 Firmwary Library: i2c_type Struct Reference

Data Fields
i2c_type Struct Reference
AT32F413_periph_driver » I2C » I2C_exported_types

type define i2c register all More...

#include <at32f413_i2c.h>

Data Fields

union {
__IO uint32_t ctrl1
struct {
__IO uint32_t i2cen: 1
__IO uint32_t permode: 1
__IO uint32_t reserved1: 1
__IO uint32_t smbmode: 1
__IO uint32_t arpen: 1
__IO uint32_t pecen: 1
__IO uint32_t gcaen: 1
__IO uint32_t stretch: 1
__IO uint32_t genstart: 1
__IO uint32_t genstop: 1
__IO uint32_t acken: 1
__IO uint32_t mackctrl: 1
__IO uint32_t pecten: 1
__IO uint32_t smbalert: 1
__IO uint32_t reserved2: 1
__IO uint32_t reset: 1
__IO uint32_t reserved3: 16
} ctrl1_bit
};
i2c ctrl1 register, offset:0x00 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t clkfreq: 8
__IO uint32_t errien: 1
__IO uint32_t evtien: 1
__IO uint32_t dataien: 1
__IO uint32_t dmaen: 1
__IO uint32_t dmaend: 1
__IO uint32_t reserved1: 19
} ctrl2_bit
};
i2c ctrl2 register, offset:0x04 More...
union {
__IO uint32_t oaddr1
struct {
__IO uint32_t addr1: 10
__IO uint32_t reserved1: 5
__IO uint32_t addr1mode: 1
__IO uint32_t reserved2: 16
} oaddr1_bit
};
i2c oaddr1 register, offset:0x08 More...
union {
__IO uint32_t oaddr2
struct {
__IO uint32_t addr2en: 1
__IO uint32_t addr2: 7
__IO uint32_t reserved1: 24
} oaddr2_bit
};
i2c oaddr2 register, offset:0x0C More...
union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 8
__IO uint32_t reserved1: 24
} dt_bit
};
i2c dt register, offset:0x10 More...
union {
__IO uint32_t sts1
struct {
__IO uint32_t startf: 1
__IO uint32_t addr7f: 1
__IO uint32_t tdc: 1
__IO uint32_t addrhf: 1
__IO uint32_t stopf: 1
__IO uint32_t reserved1: 1
__IO uint32_t rdbf: 1
__IO uint32_t tdbe: 1
__IO uint32_t buserr: 1
__IO uint32_t arlost: 1
__IO uint32_t ackfail: 1
__IO uint32_t ouf: 1
__IO uint32_t pecerr: 1
__IO uint32_t reserved2: 1
__IO uint32_t tmout: 1
__IO uint32_t alertf: 1
__IO uint32_t reserved3: 16
} sts1_bit
};
i2c sts1 register, offset:0x14 More...
union {
__IO uint32_t sts2
struct {
__IO uint32_t trmode: 1
__IO uint32_t busyf: 1
__IO uint32_t dirf: 1
__IO uint32_t reserved1: 1
__IO uint32_t gcaddrf: 1
__IO uint32_t devaddrf: 1
__IO uint32_t hostaddrf: 1
__IO uint32_t addr2: 1
__IO uint32_t pecval: 8
__IO uint32_t reserved2: 16
} sts2_bit
};
i2c sts2 register, offset:0x18 More...
union {
__IO uint32_t clkctrl
struct {
__IO uint32_t speed: 12
__IO uint32_t reserved1: 2
__IO uint32_t dutymode: 1
__IO uint32_t speedmode: 1
__IO uint32_t reserved2: 16
} clkctrl_bit
};
i2c clkctrl register, offset:0x1C More...
union {
__IO uint32_t tmrise
struct {
__IO uint32_t risetime: 6
__IO uint32_t reserved1: 26
} tmrise_bit
};
i2c tmrise register, offset:0x20 More...

Detailed Description

type define i2c register all

Definition at line 173 of file at32f413_i2c.h.

Field Documentation

◆

union { ... } i2c_type::@505

i2c ctrl1 register, offset:0x00

◆

union { ... } i2c_type::@507

i2c ctrl2 register, offset:0x04

◆

union { ... } i2c_type::@509

i2c oaddr1 register, offset:0x08

◆

union { ... } i2c_type::@511

i2c oaddr2 register, offset:0x0C

◆

union { ... } i2c_type::@513

i2c dt register, offset:0x10

◆

union { ... } i2c_type::@515

i2c sts1 register, offset:0x14

◆

union { ... } i2c_type::@517

i2c sts2 register, offset:0x18

◆

union { ... } i2c_type::@519

i2c clkctrl register, offset:0x1C

◆

union { ... } i2c_type::@521

i2c tmrise register, offset:0x20

◆ acken

__IO uint32_t i2c_type::acken

Definition at line 193 of file at32f413_i2c.h.

Referenced by i2c_ack_enable().

◆ ackfail

__IO uint32_t i2c_type::ackfail

Definition at line 281 of file at32f413_i2c.h.

◆ addr1

__IO uint32_t i2c_type::addr1

Definition at line 229 of file at32f413_i2c.h.

Referenced by i2c_own_address1_set().

◆ addr1mode

__IO uint32_t i2c_type::addr1mode

Definition at line 231 of file at32f413_i2c.h.

Referenced by i2c_master_read_addr(), i2c_master_write_addr(), i2c_own_address1_set(), i2c_slave_transmit(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ addr2

__IO uint32_t i2c_type::addr2

Definition at line 245 of file at32f413_i2c.h.

Referenced by i2c_own_address2_set().

◆ addr2en

__IO uint32_t i2c_type::addr2en

Definition at line 244 of file at32f413_i2c.h.

Referenced by i2c_own_address2_enable().

◆ addr7f

__IO uint32_t i2c_type::addr7f

Definition at line 272 of file at32f413_i2c.h.

◆ addrhf

__IO uint32_t i2c_type::addrhf

Definition at line 274 of file at32f413_i2c.h.

◆ alertf

__IO uint32_t i2c_type::alertf

Definition at line 286 of file at32f413_i2c.h.

◆ arlost

__IO uint32_t i2c_type::arlost

Definition at line 280 of file at32f413_i2c.h.

◆ arpen

__IO uint32_t i2c_type::arpen

Definition at line 187 of file at32f413_i2c.h.

Referenced by i2c_arp_mode_enable().

◆ buserr

__IO uint32_t i2c_type::buserr

Definition at line 279 of file at32f413_i2c.h.

◆ busyf

__IO uint32_t i2c_type::busyf

Definition at line 300 of file at32f413_i2c.h.

◆ clkctrl

__IO uint32_t i2c_type::clkctrl

Definition at line 317 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::clkctrl_bit

Referenced by i2c_fast_mode_duty_set(), and i2c_init().

◆ clkfreq

__IO uint32_t i2c_type::clkfreq

Definition at line 211 of file at32f413_i2c.h.

Referenced by i2c_init().

◆ ctrl1

__IO uint32_t i2c_type::ctrl1

Definition at line 180 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::ctrl1_bit

Referenced by i2c_ack_enable(), i2c_arp_mode_enable(), i2c_clock_stretch_enable(), i2c_enable(), i2c_general_call_enable(), i2c_init(), i2c_master_receive_ack_set(), i2c_pec_calculate_enable(), i2c_pec_position_set(), i2c_pec_transmit_enable(), i2c_smbus_alert_set(), i2c_smbus_enable(), i2c_smbus_mode_set(), i2c_software_reset(), i2c_start_generate(), i2c_stop_flag_clear(), and i2c_stop_generate().

◆ ctrl2

__IO uint32_t i2c_type::ctrl2

Definition at line 208 of file at32f413_i2c.h.

Referenced by i2c_interrupt_enable().

◆

struct { ... } i2c_type::ctrl2_bit

Referenced by i2c_dma_enable(), i2c_dma_end_transfer_set(), and i2c_init().

◆ dataien

__IO uint32_t i2c_type::dataien

Definition at line 214 of file at32f413_i2c.h.

◆ devaddrf

__IO uint32_t i2c_type::devaddrf

Definition at line 304 of file at32f413_i2c.h.

◆ dirf

__IO uint32_t i2c_type::dirf

Definition at line 301 of file at32f413_i2c.h.

◆ dmaen

__IO uint32_t i2c_type::dmaen

Definition at line 215 of file at32f413_i2c.h.

Referenced by i2c_dma_enable().

◆ dmaend

__IO uint32_t i2c_type::dmaend

Definition at line 216 of file at32f413_i2c.h.

Referenced by i2c_dma_end_transfer_set().

◆ dt

__IO uint32_t i2c_type::dt

Definition at line 255 of file at32f413_i2c.h.

Referenced by i2c_7bit_address_send(), i2c_data_receive(), i2c_data_send(), and i2c_dma_config().

◆

struct { ... } i2c_type::dt_bit

◆ dutymode

__IO uint32_t i2c_type::dutymode

Definition at line 322 of file at32f413_i2c.h.

Referenced by i2c_fast_mode_duty_set(), and i2c_init().

◆ errien

__IO uint32_t i2c_type::errien

Definition at line 212 of file at32f413_i2c.h.

◆ evtien

__IO uint32_t i2c_type::evtien

Definition at line 213 of file at32f413_i2c.h.

◆ gcaddrf

__IO uint32_t i2c_type::gcaddrf

Definition at line 303 of file at32f413_i2c.h.

◆ gcaen

__IO uint32_t i2c_type::gcaen

Definition at line 189 of file at32f413_i2c.h.

Referenced by i2c_general_call_enable().

◆ genstart

__IO uint32_t i2c_type::genstart

Definition at line 191 of file at32f413_i2c.h.

Referenced by i2c_start_generate().

◆ genstop

__IO uint32_t i2c_type::genstop

Definition at line 192 of file at32f413_i2c.h.

Referenced by i2c_stop_generate().

◆ hostaddrf

__IO uint32_t i2c_type::hostaddrf

Definition at line 305 of file at32f413_i2c.h.

◆ i2cen

__IO uint32_t i2c_type::i2cen

Definition at line 183 of file at32f413_i2c.h.

Referenced by i2c_enable(), i2c_init(), and i2c_stop_flag_clear().

◆ mackctrl

__IO uint32_t i2c_type::mackctrl

Definition at line 194 of file at32f413_i2c.h.

Referenced by i2c_master_receive_ack_set(), and i2c_pec_position_set().

◆ oaddr1

__IO uint32_t i2c_type::oaddr1

Definition at line 226 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::oaddr1_bit

Referenced by i2c_master_read_addr(), i2c_master_write_addr(), i2c_own_address1_set(), i2c_slave_transmit(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ oaddr2

__IO uint32_t i2c_type::oaddr2

Definition at line 241 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::oaddr2_bit

Referenced by i2c_own_address2_enable(), and i2c_own_address2_set().

◆ ouf

__IO uint32_t i2c_type::ouf

Definition at line 282 of file at32f413_i2c.h.

◆ pecen

__IO uint32_t i2c_type::pecen

Definition at line 188 of file at32f413_i2c.h.

Referenced by i2c_pec_calculate_enable().

◆ pecerr

__IO uint32_t i2c_type::pecerr

Definition at line 283 of file at32f413_i2c.h.

◆ pecten

__IO uint32_t i2c_type::pecten

Definition at line 195 of file at32f413_i2c.h.

Referenced by i2c_pec_transmit_enable().

◆ pecval

__IO uint32_t i2c_type::pecval

Definition at line 307 of file at32f413_i2c.h.

Referenced by i2c_pec_value_get().

◆ permode

__IO uint32_t i2c_type::permode

Definition at line 184 of file at32f413_i2c.h.

Referenced by i2c_smbus_enable().

◆ rdbf

__IO uint32_t i2c_type::rdbf

Definition at line 277 of file at32f413_i2c.h.

◆ reserved1

__IO uint32_t i2c_type::reserved1

Definition at line 185 of file at32f413_i2c.h.

◆ reserved2

__IO uint32_t i2c_type::reserved2

Definition at line 197 of file at32f413_i2c.h.

◆ reserved3

__IO uint32_t i2c_type::reserved3

Definition at line 199 of file at32f413_i2c.h.

◆ reset

__IO uint32_t i2c_type::reset

Definition at line 198 of file at32f413_i2c.h.

Referenced by i2c_software_reset().

◆ risetime

__IO uint32_t i2c_type::risetime

Definition at line 336 of file at32f413_i2c.h.

Referenced by i2c_init().

◆ smbalert

__IO uint32_t i2c_type::smbalert

Definition at line 196 of file at32f413_i2c.h.

Referenced by i2c_smbus_alert_set().

◆ smbmode

__IO uint32_t i2c_type::smbmode

Definition at line 186 of file at32f413_i2c.h.

Referenced by i2c_smbus_mode_set().

◆ speed

__IO uint32_t i2c_type::speed

Definition at line 320 of file at32f413_i2c.h.

Referenced by i2c_init().

◆ speedmode

__IO uint32_t i2c_type::speedmode

Definition at line 323 of file at32f413_i2c.h.

Referenced by i2c_init().

◆ startf

__IO uint32_t i2c_type::startf

Definition at line 271 of file at32f413_i2c.h.

◆ stopf

__IO uint32_t i2c_type::stopf

Definition at line 275 of file at32f413_i2c.h.

◆ stretch

__IO uint32_t i2c_type::stretch

Definition at line 190 of file at32f413_i2c.h.

Referenced by i2c_clock_stretch_enable().

◆ sts1

__IO uint32_t i2c_type::sts1

Definition at line 268 of file at32f413_i2c.h.

Referenced by i2c_addr_flag_clear(), i2c_flag_clear(), i2c_flag_get(), and i2c_stop_flag_clear().

◆

struct { ... } i2c_type::sts1_bit

◆ sts2

__IO uint32_t i2c_type::sts2

Definition at line 296 of file at32f413_i2c.h.

Referenced by i2c_addr_flag_clear(), and i2c_flag_get().

◆

struct { ... } i2c_type::sts2_bit

Referenced by i2c_pec_value_get().

◆ tdbe

__IO uint32_t i2c_type::tdbe

Definition at line 278 of file at32f413_i2c.h.

◆ tdc

__IO uint32_t i2c_type::tdc

Definition at line 273 of file at32f413_i2c.h.

◆ tmout

__IO uint32_t i2c_type::tmout

Definition at line 285 of file at32f413_i2c.h.

◆ tmrise

__IO uint32_t i2c_type::tmrise

Definition at line 333 of file at32f413_i2c.h.

◆

struct { ... } i2c_type::tmrise_bit

Referenced by i2c_init().

◆ trmode

__IO uint32_t i2c_type::trmode

Definition at line 299 of file at32f413_i2c.h.

The documentation for this struct was generated from the following file:
  • at32f413_i2c.h


AT32F413 Firmwary Library: I2C_exported_functions

Functions
I2C_exported_functions
AT32F413_periph_driver » I2C

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_software_reset (i2c_type *i2c_x, confirm_state new_state)
software reset. More...
void | i2c_init (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address)
config own address2. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph More...
void | i2c_fast_mode_duty_set (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge. More...
void | i2c_master_receive_ack_set (i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control. More...
void | i2c_pec_position_set (i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call. More...
void | i2c_arp_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode. More...
void | i2c_smbus_mode_set (i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get pec value. More...
void | i2c_dma_end_transfer_set (i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one. More...
void | i2c_dma_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_7bit_address_send (i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

Function Documentation

◆ i2c_7bit_address_send()

void i2c_7bit_address_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | address,
 |  | i2c_direction_type | direction
 | ) |  |

transmit the slave address.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
address | specifies the slave address which will be transmitted
direction this parameter can be one of the following values:
  • I2C_DIRECTION_TRANSMIT: transmit mode.
  • I2C_DIRECTION_RECEIVE: receive mode.
Return values
none.

Definition at line 503 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), and i2c_master_write_addr().

◆ i2c_ack_enable()

void i2c_ack_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable acknowledge.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none.

Definition at line 283 of file at32f413_i2c.c.

Referenced by i2c_dma_tx_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ i2c_arp_mode_enable()

void i2c_arp_mode_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable arp mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 341 of file at32f413_i2c.c.

◆ i2c_clock_stretch_enable()

void i2c_clock_stretch_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock stretch.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 270 of file at32f413_i2c.c.

◆ i2c_data_receive()

uint8_t i2c_data_receive ( i2c_type * i2c_x )

receive a byte through the i2c periph.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
uint8_t received byte

Definition at line 535 of file at32f413_i2c.c.

Referenced by i2c_master_receive(), i2c_master_rx_isr_int(), i2c_memory_read(), i2c_slave_receive(), and i2c_slave_rx_isr_int().

◆ i2c_data_send()

void i2c_data_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | data
 | ) |  |

send a byte through the i2c periph.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
data | byte to be transmitted.
Return values
none

Definition at line 523 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), i2c_master_transmit(), i2c_master_tx_isr_int(), i2c_master_write_addr(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_transmit(), and i2c_slave_tx_isr_int().

◆ i2c_dma_enable()

void i2c_dma_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma requests.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 437 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive_dma(), i2c_master_transmit_dma(), i2c_memory_read_dma(), i2c_memory_write_dma(), i2c_slave_receive_dma(), and i2c_slave_transmit_dma().

◆ i2c_dma_end_transfer_set()

void i2c_dma_end_transfer_set | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable if the next dma transfer will be the last one.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 424 of file at32f413_i2c.c.

Referenced by i2c_master_receive_dma(), and i2c_memory_read_dma().

◆ i2c_enable()

void i2c_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2c periph

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 241 of file at32f413_i2c.c.

Referenced by i2c_config().

◆ i2c_fast_mode_duty_set()

void i2c_fast_mode_duty_set | ( | i2c_type * | i2c_x,
 |  | i2c_fsmode_duty_cycle_type | duty
 | ) |  |

config fast mode duty cycle

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
duty this parameter can be one of the following values:
  • I2C_FSMODE_DUTY_2_1: duty cycle 2:1
  • I2C_FSMODE_DUTY_16_9: duty cycle 16:9
Return values
none

Definition at line 257 of file at32f413_i2c.c.

◆ i2c_flag_clear()

void i2c_flag_clear | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

clear flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
flag this parameter can be any combination of the following values:
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
Return values
none

Definition at line 615 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_err_irq_handler(), i2c_slave_transmit(), i2c_slave_tx_isr_int(), and i2c_wait_flag().

◆ i2c_flag_get()

flag_status i2c_flag_get | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

get flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
flag this parameter can be one of the following values:
  • I2C_STARTF_FLAG: start condition generation complete flag.
  • I2C_ADDR7F_FLAG: 0~7 bit address match flag.
  • I2C_TDC_FLAG: transmit data complete flag.
  • I2C_ADDRHF_FLAG: master 9~8 bit address header match flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_RDBF_FLAG: receive data buffer full flag.
  • I2C_TDBE_FLAG: transmit data buffer empty flag.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_TRMODE_FLAG: transmission mode.
  • I2C_BUSYF_FLAG: bus busy flag transmission mode.
  • I2C_DIRF_FLAG: transmission direction flag.
  • I2C_GCADDRF_FLAG: general call address received flag.
  • I2C_DEVADDRF_FLAG: smbus device address received flag.
  • I2C_HOSTADDRF_FLAG: smbus host address received flag.
  • I2C_ADDR2_FLAG: own address 2 received flag.
Return values
flag_status (SET or RESET)

Definition at line 570 of file at32f413_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_rx_isr_int(), i2c_master_tx_isr_int(), i2c_slave_rx_isr_int(), i2c_slave_tx_isr_int(), and i2c_wait_flag().

◆ i2c_general_call_enable()

void i2c_general_call_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable general call.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 328 of file at32f413_i2c.c.

◆ i2c_init()

void i2c_init | ( | i2c_type * | i2c_x,
 |  | i2c_fsmode_duty_cycle_type | duty,
 |  | uint32_t | speed
 | ) |  |

init i2c speed and duty cycle.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
duty this parameter can be one of the following values:
  • I2C_FSMODE_DUTY_2_1: duty cycle 2:1
  • I2C_FSMODE_DUTY_16_9: duty cycle 16:9
speed | i2c scl clock speed, such as 100000
Return values
none

Definition at line 90 of file at32f413_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_interrupt_enable()

void i2c_interrupt_enable | ( | i2c_type * | i2c_x,
 |  | uint16_t | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable interrupt

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
source this parameter can be one of the following values:
  • I2C_DATA_INT: data interrupt.
  • I2C_EV_INT: event interrupt.
  • I2C_ERR_INT: error interrupt.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 455 of file at32f413_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_memory_read_int(), i2c_memory_write_int(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().

◆ i2c_master_receive_ack_set()

void i2c_master_receive_ack_set | ( | i2c_type * | i2c_x,
 |  | i2c_master_ack_type | pos
 | ) |  |

master receiving mode acknowledge control.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
pos this parameter can be one of the following values:
  • I2C_MASTER_ACK_CURRENT: acken bit acts on the current byte
  • I2C_MASTER_ACK_NEXT: acken bit acts on the next byte
Return values
none

Definition at line 299 of file at32f413_i2c.c.

Referenced by i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ i2c_own_address1_set()

void i2c_own_address1_set | ( | i2c_type * | i2c_x,
 |  | i2c_address_mode_type | mode,
 |  | uint16_t | address
 | ) |  |

config own address1.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
mode this parameter can be one of the following values:
  • I2C_ADDRESS_MODE_7BIT: 7bit address.
  • I2C_ADDRESS_MODE_10BIT: 10bit address.
address | own address1, such as 0xb0.
Return values
none

Definition at line 185 of file at32f413_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_own_address2_enable()

void i2c_own_address2_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable own address2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 215 of file at32f413_i2c.c.

◆ i2c_own_address2_set()

void i2c_own_address2_set | ( | i2c_type * | i2c_x,
 |  | uint8_t | address
 | ) |  |

config own address2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
address | specifies the 7bit i2c own address2, such as 0xa0.
Return values
none.

Definition at line 202 of file at32f413_i2c.c.

◆ i2c_pec_calculate_enable()

void i2c_pec_calculate_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec calcultetion.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 399 of file at32f413_i2c.c.

◆ i2c_pec_position_set()

void i2c_pec_position_set | ( | i2c_type * | i2c_x,
 |  | i2c_pec_position_type | pos
 | ) |  |

pec position set.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
pos this parameter can be one of the following values:
  • I2C_PEC_POSITION_CURRENT: the current byte is pec
  • I2C_PEC_POSITION_NEXT: the next byte is pec
Return values
none

Definition at line 315 of file at32f413_i2c.c.

◆ i2c_pec_transmit_enable()

void i2c_pec_transmit_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec transfer.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 386 of file at32f413_i2c.c.

◆ i2c_pec_value_get()

uint8_t i2c_pec_value_get ( i2c_type * i2c_x )

get pec value.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
uint8_t pec value.

Definition at line 411 of file at32f413_i2c.c.

◆ i2c_reset()

void i2c_reset ( i2c_type * i2c_x )

reset the i2c register

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none

Definition at line 51 of file at32f413_i2c.c.

Referenced by i2c_config().

◆ i2c_smbus_alert_set()

void i2c_smbus_alert_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_alert_set_type | level
 | ) |  |

drive the smbus alert pin high or low.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
level this parameter can be one of the following values:
  • I2C_SMBUS_ALERT_LOW: smbus alert pin set low.
  • I2C_SMBUS_ALERT_HIGH: smbus alert pin set high.
Return values
none

Definition at line 373 of file at32f413_i2c.c.

◆ i2c_smbus_enable()

void i2c_smbus_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the smbus mode

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 228 of file at32f413_i2c.c.

◆ i2c_smbus_mode_set()

void i2c_smbus_mode_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_mode_set_type | mode
 | ) |  |

config smbus host or device.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
level this parameter can be one of the following values:
  • I2C_SMBUS_MODE_DEVICE: smbus device.
  • I2C_SMBUS_MODE_HOST: smbus host.
Return values
none

Definition at line 357 of file at32f413_i2c.c.

◆ i2c_software_reset()

void i2c_software_reset | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

software reset.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 73 of file at32f413_i2c.c.

◆ i2c_start_generate()

void i2c_start_generate ( i2c_type * i2c_x )

generate start condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none.

Definition at line 474 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), and i2c_master_write_addr().

◆ i2c_stop_generate()

void i2c_stop_generate ( i2c_type * i2c_x )

generate stop condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none.

Definition at line 486 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), and i2c_wait_flag().


AT32F413 Firmwary Library: I2C_private_functions

Functions
I2C_private_functions
AT32F413_periph_driver » I2C

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_software_reset (i2c_type *i2c_x, confirm_state new_state)
software reset. More...
void | i2c_init (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address)
config own address2. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph More...
void | i2c_fast_mode_duty_set (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge. More...
void | i2c_master_receive_ack_set (i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control. More...
void | i2c_pec_position_set (i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call. More...
void | i2c_arp_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode. More...
void | i2c_smbus_mode_set (i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get pec value. More...
void | i2c_dma_end_transfer_set (i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one. More...
void | i2c_dma_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_7bit_address_send (i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

Function Documentation

◆ i2c_7bit_address_send()

void i2c_7bit_address_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | address,
 |  | i2c_direction_type | direction
 | ) |  |

transmit the slave address.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
address | specifies the slave address which will be transmitted
direction this parameter can be one of the following values:
  • I2C_DIRECTION_TRANSMIT: transmit mode.
  • I2C_DIRECTION_RECEIVE: receive mode.
Return values
none.

Definition at line 503 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), and i2c_master_write_addr().

◆ i2c_ack_enable()

void i2c_ack_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable acknowledge.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none.

Definition at line 283 of file at32f413_i2c.c.

Referenced by i2c_dma_tx_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ i2c_arp_mode_enable()

void i2c_arp_mode_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable arp mode.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 341 of file at32f413_i2c.c.

◆ i2c_clock_stretch_enable()

void i2c_clock_stretch_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock stretch.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 270 of file at32f413_i2c.c.

◆ i2c_data_receive()

uint8_t i2c_data_receive ( i2c_type * i2c_x )

receive a byte through the i2c periph.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
uint8_t received byte

Definition at line 535 of file at32f413_i2c.c.

Referenced by i2c_master_receive(), i2c_master_rx_isr_int(), i2c_memory_read(), i2c_slave_receive(), and i2c_slave_rx_isr_int().

◆ i2c_data_send()

void i2c_data_send | ( | i2c_type * | i2c_x,
 |  | uint8_t | data
 | ) |  |

send a byte through the i2c periph.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
data | byte to be transmitted.
Return values
none

Definition at line 523 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), i2c_master_transmit(), i2c_master_tx_isr_int(), i2c_master_write_addr(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_transmit(), and i2c_slave_tx_isr_int().

◆ i2c_dma_enable()

void i2c_dma_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma requests.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 437 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive_dma(), i2c_master_transmit_dma(), i2c_memory_read_dma(), i2c_memory_write_dma(), i2c_slave_receive_dma(), and i2c_slave_transmit_dma().

◆ i2c_dma_end_transfer_set()

void i2c_dma_end_transfer_set | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable if the next dma transfer will be the last one.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 424 of file at32f413_i2c.c.

Referenced by i2c_master_receive_dma(), and i2c_memory_read_dma().

◆ i2c_enable()

void i2c_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2c periph

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 241 of file at32f413_i2c.c.

Referenced by i2c_config().

◆ i2c_fast_mode_duty_set()

void i2c_fast_mode_duty_set | ( | i2c_type * | i2c_x,
 |  | i2c_fsmode_duty_cycle_type | duty
 | ) |  |

config fast mode duty cycle

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
duty this parameter can be one of the following values:
  • I2C_FSMODE_DUTY_2_1: duty cycle 2:1
  • I2C_FSMODE_DUTY_16_9: duty cycle 16:9
Return values
none

Definition at line 257 of file at32f413_i2c.c.

◆ i2c_flag_clear()

void i2c_flag_clear | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

clear flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
flag this parameter can be any combination of the following values:
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
Return values
none

Definition at line 615 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_err_irq_handler(), i2c_slave_transmit(), i2c_slave_tx_isr_int(), and i2c_wait_flag().

◆ i2c_flag_get()

flag_status i2c_flag_get | ( | i2c_type * | i2c_x,
 |  | uint32_t | flag
 | ) |  |

get flag status

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
flag this parameter can be one of the following values:
  • I2C_STARTF_FLAG: start condition generation complete flag.
  • I2C_ADDR7F_FLAG: 0~7 bit address match flag.
  • I2C_TDC_FLAG: transmit data complete flag.
  • I2C_ADDRHF_FLAG: master 9~8 bit address header match flag.
  • I2C_STOPF_FLAG: stop condition generation complete flag.
  • I2C_RDBF_FLAG: receive data buffer full flag.
  • I2C_TDBE_FLAG: transmit data buffer empty flag.
  • I2C_BUSERR_FLAG: bus error flag.
  • I2C_ARLOST_FLAG: arbitration lost flag.
  • I2C_ACKFAIL_FLAG: acknowledge failure flag.
  • I2C_OUF_FLAG: overflow or underflow flag.
  • I2C_PECERR_FLAG: pec receive error flag.
  • I2C_TMOUT_FLAG: smbus timeout flag.
  • I2C_ALERTF_FLAG: smbus alert flag.
  • I2C_TRMODE_FLAG: transmission mode.
  • I2C_BUSYF_FLAG: bus busy flag transmission mode.
  • I2C_DIRF_FLAG: transmission direction flag.
  • I2C_GCADDRF_FLAG: general call address received flag.
  • I2C_DEVADDRF_FLAG: smbus device address received flag.
  • I2C_HOSTADDRF_FLAG: smbus host address received flag.
  • I2C_ADDR2_FLAG: own address 2 received flag.
Return values
flag_status (SET or RESET)

Definition at line 570 of file at32f413_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_rx_isr_int(), i2c_master_tx_isr_int(), i2c_slave_rx_isr_int(), i2c_slave_tx_isr_int(), and i2c_wait_flag().

◆ i2c_general_call_enable()

void i2c_general_call_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable general call.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 328 of file at32f413_i2c.c.

◆ i2c_init()

void i2c_init | ( | i2c_type * | i2c_x,
 |  | i2c_fsmode_duty_cycle_type | duty,
 |  | uint32_t | speed
 | ) |  |

init i2c speed and duty cycle.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
duty this parameter can be one of the following values:
  • I2C_FSMODE_DUTY_2_1: duty cycle 2:1
  • I2C_FSMODE_DUTY_16_9: duty cycle 16:9
speed | i2c scl clock speed, such as 100000
Return values
none

Definition at line 90 of file at32f413_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_interrupt_enable()

void i2c_interrupt_enable | ( | i2c_type * | i2c_x,
 |  | uint16_t | source,
 |  | confirm_state | new_state
 | ) |  |

enable or disable interrupt

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
source this parameter can be one of the following values:
  • I2C_DATA_INT: data interrupt.
  • I2C_EV_INT: event interrupt.
  • I2C_ERR_INT: error interrupt.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 455 of file at32f413_i2c.c.

Referenced by i2c_err_irq_handler(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_memory_read_int(), i2c_memory_write_int(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().

◆ i2c_master_receive_ack_set()

void i2c_master_receive_ack_set | ( | i2c_type * | i2c_x,
 |  | i2c_master_ack_type | pos
 | ) |  |

master receiving mode acknowledge control.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
pos this parameter can be one of the following values:
  • I2C_MASTER_ACK_CURRENT: acken bit acts on the current byte
  • I2C_MASTER_ACK_NEXT: acken bit acts on the next byte
Return values
none

Definition at line 299 of file at32f413_i2c.c.

Referenced by i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ i2c_own_address1_set()

void i2c_own_address1_set | ( | i2c_type * | i2c_x,
 |  | i2c_address_mode_type | mode,
 |  | uint16_t | address
 | ) |  |

config own address1.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
mode this parameter can be one of the following values:
  • I2C_ADDRESS_MODE_7BIT: 7bit address.
  • I2C_ADDRESS_MODE_10BIT: 10bit address.
address | own address1, such as 0xb0.
Return values
none

Definition at line 185 of file at32f413_i2c.c.

Referenced by i2c_lowlevel_init().

◆ i2c_own_address2_enable()

void i2c_own_address2_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable own address2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 215 of file at32f413_i2c.c.

◆ i2c_own_address2_set()

void i2c_own_address2_set | ( | i2c_type * | i2c_x,
 |  | uint8_t | address
 | ) |  |

config own address2.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
address | specifies the 7bit i2c own address2, such as 0xa0.
Return values
none.

Definition at line 202 of file at32f413_i2c.c.

◆ i2c_pec_calculate_enable()

void i2c_pec_calculate_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec calcultetion.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 399 of file at32f413_i2c.c.

◆ i2c_pec_position_set()

void i2c_pec_position_set | ( | i2c_type * | i2c_x,
 |  | i2c_pec_position_type | pos
 | ) |  |

pec position set.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
pos this parameter can be one of the following values:
  • I2C_PEC_POSITION_CURRENT: the current byte is pec
  • I2C_PEC_POSITION_NEXT: the next byte is pec
Return values
none

Definition at line 315 of file at32f413_i2c.c.

◆ i2c_pec_transmit_enable()

void i2c_pec_transmit_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pec transfer.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 386 of file at32f413_i2c.c.

◆ i2c_pec_value_get()

uint8_t i2c_pec_value_get ( i2c_type * i2c_x )

get pec value.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
uint8_t pec value.

Definition at line 411 of file at32f413_i2c.c.

◆ i2c_reset()

void i2c_reset ( i2c_type * i2c_x )

reset the i2c register

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none

Definition at line 51 of file at32f413_i2c.c.

Referenced by i2c_config().

◆ i2c_smbus_alert_set()

void i2c_smbus_alert_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_alert_set_type | level
 | ) |  |

drive the smbus alert pin high or low.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
level this parameter can be one of the following values:
  • I2C_SMBUS_ALERT_LOW: smbus alert pin set low.
  • I2C_SMBUS_ALERT_HIGH: smbus alert pin set high.
Return values
none

Definition at line 373 of file at32f413_i2c.c.

◆ i2c_smbus_enable()

void i2c_smbus_enable | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the smbus mode

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 228 of file at32f413_i2c.c.

◆ i2c_smbus_mode_set()

void i2c_smbus_mode_set | ( | i2c_type * | i2c_x,
 |  | i2c_smbus_mode_set_type | mode
 | ) |  |

config smbus host or device.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
level this parameter can be one of the following values:
  • I2C_SMBUS_MODE_DEVICE: smbus device.
  • I2C_SMBUS_MODE_HOST: smbus host.
Return values
none

Definition at line 357 of file at32f413_i2c.c.

◆ i2c_software_reset()

void i2c_software_reset | ( | i2c_type * | i2c_x,
 |  | confirm_state | new_state
 | ) |  |

software reset.

Parameters
i2c_x | to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 73 of file at32f413_i2c.c.

◆ i2c_start_generate()

void i2c_start_generate ( i2c_type * i2c_x )

generate start condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none.

Definition at line 474 of file at32f413_i2c.c.

Referenced by i2c_master_read_addr(), and i2c_master_write_addr().

◆ i2c_stop_generate()

void i2c_stop_generate ( i2c_type * i2c_x )

generate stop condition.

Parameters
i2c_x to select the i2c peripheral. this parameter can be one of the following values: I2C1, I2C2.
Return values
none.

Definition at line 486 of file at32f413_i2c.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), and i2c_wait_flag().


AT32F413 Firmwary Library: MISC

Modules
MISC
AT32F413_periph_driver

MISC driver modules. More...

Modules

MISC_vector_table_base_address
MISC_exported_types
MISC_exported_functions
MISC_private_functions

Detailed Description

MISC driver modules.


AT32F413 Firmwary Library: MISC_vector_table_base_address

Macros
MISC_vector_table_base_address
AT32F413_periph_driver » MISC

Macros

#define | NVIC_VECTTAB_RAM ((uint32_t)0x20000000)
#define | NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)

Detailed Description

Macro Definition Documentation

◆ NVIC_VECTTAB_FLASH

#define NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)

nvic vector table based flash address

Definition at line 52 of file at32f413_misc.h.

◆ NVIC_VECTTAB_RAM

#define NVIC_VECTTAB_RAM ((uint32_t)0x20000000)

nvic vector table based ram address

Definition at line 51 of file at32f413_misc.h.


AT32F413 Firmwary Library: MISC_exported_types

Enumerations
MISC_exported_types
AT32F413_periph_driver » MISC

Enumerations

enum nvic_priority_group_type {
NVIC_PRIORITY_GROUP_0 = ((uint32_t)0x7) , NVIC_PRIORITY_GROUP_1 = ((uint32_t)0x6) , NVIC_PRIORITY_GROUP_2 = ((uint32_t)0x5) , NVIC_PRIORITY_GROUP_3 = ((uint32_t)0x4) ,
NVIC_PRIORITY_GROUP_4 = ((uint32_t)0x3)
}
nvic interrupt priority group More...
enum | nvic_lowpower_mode_type { NVIC_LP_SLEEPONEXIT = 0x02 , NVIC_LP_SLEEPDEEP = 0x04 , NVIC_LP_SEVONPEND = 0x10 }
nvic low power mode More...
enum | systick_clock_source_type { SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 = ((uint32_t)0x00000000) , SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV = ((uint32_t)0x00000004) }
systick clock source More...

Detailed Description

Enumeration Type Documentation

◆ nvic_lowpower_mode_type

enum nvic_lowpower_mode_type

nvic low power mode

Enumerator
NVIC_LP_SLEEPONEXIT | send event on pending
NVIC_LP_SLEEPDEEP | enable sleep-deep output signal when entering sleep mode
NVIC_LP_SEVONPEND | enable sleep-on-exit feature

Definition at line 77 of file at32f413_misc.h.

◆ nvic_priority_group_type

enum nvic_priority_group_type

nvic interrupt priority group

Enumerator
NVIC_PRIORITY_GROUP_0 | 0 bits for preemption priority, 4 bits for subpriority
NVIC_PRIORITY_GROUP_1 | 1 bits for preemption priority, 3 bits for subpriority
NVIC_PRIORITY_GROUP_2 | 2 bits for preemption priority, 2 bits for subpriority
NVIC_PRIORITY_GROUP_3 | 3 bits for preemption priority, 1 bits for subpriority
NVIC_PRIORITY_GROUP_4 | 4 bits for preemption priority, 0 bits for subpriority

Definition at line 65 of file at32f413_misc.h.

◆ systick_clock_source_type

enum systick_clock_source_type

systick clock source

Enumerator
SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 | systick clock source from core clock div8
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV | systick clock source from core clock

Definition at line 87 of file at32f413_misc.h.


AT32F413 Firmwary Library: MISC_exported_functions

Functions
MISC_exported_functions
AT32F413_periph_driver » MISC

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

Function Documentation

◆ nvic_irq_disable()

void nvic_irq_disable ( IRQn_Type irqn )

disable nvic irq number

Parameters
irqn (IRQn_Type number)
Return values
none

Definition at line 81 of file at32f413_misc.c.

Referenced by app_load(), and jump_to_app().

◆ nvic_irq_enable()

void nvic_irq_enable | ( | IRQn_Type | irqn,
 |  | uint32_t | preempt_priority,
 |  | uint32_t | sub_priority
 | ) |  |

enable nvic irq

Parameters
irqn | (IRQn_Type number)
preempt_priority | preemptive priority value (starting from 0)
sub_priority | subpriority value (starting from 0)
Return values
none

Definition at line 64 of file at32f413_misc.c.

Referenced by adc_config(), alarm_init(), button_exint_init(), can_configuration(), codec_i2s_init(), config_flash_interrupt(), dma_config(), dma_configuration(), exint_line0_config(), exint_line4_config(), i2c_lowlevel_init(), i2s_config(), main(), nvic_configuration(), rs485_config(), rtc_config(), spi_config(), tmr1_config(), tmr2_config(), tmr_init(), uart_init(), usart1_config(), usart_configuration(), and usb_usart_config().

◆ nvic_lowpower_mode_config()

void nvic_lowpower_mode_config | ( | nvic_lowpower_mode_type | lp_mode,
 |  | confirm_state | new_state
 | ) |  |

config nvic lowpower mode

Parameters
lp_mode this parameter can be one of the following values:
  • NVIC_LP_SEVONPEND
  • NVIC_LP_SLEEPDEEP
  • NVIC_LP_SLEEPONEXIT
new_state (new state of lp condition. ENABLE or DISABLE)
Return values
none

Definition at line 127 of file at32f413_misc.c.

◆ nvic_priority_group_config()

void nvic_priority_group_config ( nvic_priority_group_type priority_group )

config nvic priority group

Parameters
priority_group this parameter can be one of the following values:
  • NVIC_PRIORITY_GROUP_0
  • NVIC_PRIORITY_GROUP_1
  • NVIC_PRIORITY_GROUP_2
  • NVIC_PRIORITY_GROUP_3
  • NVIC_PRIORITY_GROUP_4
Return values
none

Definition at line 97 of file at32f413_misc.c.

Referenced by button_exint_init(), config_flash_interrupt(), exint_line0_config(), main(), nvic_configuration(), and usart_configuration().

◆ nvic_system_reset()

void nvic_system_reset ( void )

system reset

Parameters
none
Return values
none

Definition at line 52 of file at32f413_misc.c.

Referenced by app_loop(), extend_sram(), iap_command_handle(), and main().

◆ nvic_vector_table_set()

void nvic_vector_table_set | ( | uint32_t | base,
 |  | uint32_t | offset
 | ) |  |

set the vector table location and offset.

Parameters
base this parameter can be one of the following values:
  • NVIC_VECTTAB_RAM
  • NVIC_VECTTAB_FLASH
offset (vector table base offset field. this value must be a multiple of 0x200)
Return values
none

Definition at line 112 of file at32f413_misc.c.

Referenced by main().

◆ systick_clock_source_config()

void systick_clock_source_config ( systick_clock_source_type source )

config systick clock source

Parameters
source this parameter can be one of the following values:
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Return values
none

Definition at line 147 of file at32f413_misc.c.

Referenced by delay_init(), and main().


AT32F413 Firmwary Library: MISC_private_functions

Macros | Functions
MISC_private_functions
AT32F413_periph_driver » MISC

Macros

#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

Macro Definition Documentation

◆ AIRCR_VECTKEY_MASK

#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)

Definition at line 45 of file at32f413_misc.c.

Function Documentation

◆ nvic_irq_disable()

void nvic_irq_disable ( IRQn_Type irqn )

disable nvic irq number

Parameters
irqn (IRQn_Type number)
Return values
none

Definition at line 81 of file at32f413_misc.c.

Referenced by app_load(), and jump_to_app().

◆ nvic_irq_enable()

void nvic_irq_enable | ( | IRQn_Type | irqn,
 |  | uint32_t | preempt_priority,
 |  | uint32_t | sub_priority
 | ) |  |

enable nvic irq

Parameters
irqn | (IRQn_Type number)
preempt_priority | preemptive priority value (starting from 0)
sub_priority | subpriority value (starting from 0)
Return values
none

Definition at line 64 of file at32f413_misc.c.

Referenced by adc_config(), alarm_init(), button_exint_init(), can_configuration(), codec_i2s_init(), config_flash_interrupt(), dma_config(), dma_configuration(), exint_line0_config(), exint_line4_config(), i2c_lowlevel_init(), i2s_config(), main(), nvic_configuration(), rs485_config(), rtc_config(), spi_config(), tmr1_config(), tmr2_config(), tmr_init(), uart_init(), usart1_config(), usart_configuration(), and usb_usart_config().

◆ nvic_lowpower_mode_config()

void nvic_lowpower_mode_config | ( | nvic_lowpower_mode_type | lp_mode,
 |  | confirm_state | new_state
 | ) |  |

config nvic lowpower mode

Parameters
lp_mode this parameter can be one of the following values:
  • NVIC_LP_SEVONPEND
  • NVIC_LP_SLEEPDEEP
  • NVIC_LP_SLEEPONEXIT
new_state (new state of lp condition. ENABLE or DISABLE)
Return values
none

Definition at line 127 of file at32f413_misc.c.

◆ nvic_priority_group_config()

void nvic_priority_group_config ( nvic_priority_group_type priority_group )

config nvic priority group

Parameters
priority_group this parameter can be one of the following values:
  • NVIC_PRIORITY_GROUP_0
  • NVIC_PRIORITY_GROUP_1
  • NVIC_PRIORITY_GROUP_2
  • NVIC_PRIORITY_GROUP_3
  • NVIC_PRIORITY_GROUP_4
Return values
none

Definition at line 97 of file at32f413_misc.c.

Referenced by button_exint_init(), config_flash_interrupt(), exint_line0_config(), main(), nvic_configuration(), and usart_configuration().

◆ nvic_system_reset()

void nvic_system_reset ( void )

system reset

Parameters
none
Return values
none

Definition at line 52 of file at32f413_misc.c.

Referenced by app_loop(), extend_sram(), iap_command_handle(), and main().

◆ nvic_vector_table_set()

void nvic_vector_table_set | ( | uint32_t | base,
 |  | uint32_t | offset
 | ) |  |

set the vector table location and offset.

Parameters
base this parameter can be one of the following values:
  • NVIC_VECTTAB_RAM
  • NVIC_VECTTAB_FLASH
offset (vector table base offset field. this value must be a multiple of 0x200)
Return values
none

Definition at line 112 of file at32f413_misc.c.

Referenced by main().

◆ systick_clock_source_config()

void systick_clock_source_config ( systick_clock_source_type source )

config systick clock source

Parameters
source this parameter can be one of the following values:
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Return values
none

Definition at line 147 of file at32f413_misc.c.

Referenced by delay_init(), and main().


AT32F413 Firmwary Library: PWC

Modules | Macros
PWC
AT32F413_periph_driver

PWC driver modules. More...

Modules

PWC_flags_definition
pwc flag
PWC_exported_types
PWC_exported_functions
PWC_private_functions

Macros

#define | PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)
pwc wakeup pin num definition More...
#define | PWC ((pwc_type *) PWC_BASE)

Detailed Description

PWC driver modules.

Macro Definition Documentation

◆ PWC

#define PWC ((pwc_type *) PWC_BASE)

Definition at line 157 of file at32f413_pwc.h.

◆ PWC_WAKEUP_PIN_1

#define PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)

pwc wakeup pin num definition

standby wake-up pin1

Definition at line 63 of file at32f413_pwc.h.


AT32F413 Firmwary Library: PWC_flags_definition

Macros
PWC_flags_definition
AT32F413_periph_driver » PWC

pwc flag More...

Macros

#define | PWC_WAKEUP_FLAG ((uint32_t)0x00000001)
#define | PWC_STANDBY_FLAG ((uint32_t)0x00000002)
#define | PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)

Detailed Description

pwc flag

Macro Definition Documentation

◆ PWC_PVM_OUTPUT_FLAG

#define PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)

pvm output flag

Definition at line 54 of file at32f413_pwc.h.

◆ PWC_STANDBY_FLAG

#define PWC_STANDBY_FLAG ((uint32_t)0x00000002)

standby flag

Definition at line 53 of file at32f413_pwc.h.

◆ PWC_WAKEUP_FLAG

#define PWC_WAKEUP_FLAG ((uint32_t)0x00000001)

wakeup flag

Definition at line 52 of file at32f413_pwc.h.


AT32F413 Firmwary Library: PWC_exported_types

Data Structures | Enumerations
PWC_exported_types
AT32F413_periph_driver » PWC

Data Structures

struct pwc_type
type define pwc register all More...

Enumerations

enum pwc_pvm_voltage_type {
PWC_PVM_VOLTAGE_2V3 = 0x01 , PWC_PVM_VOLTAGE_2V4 = 0x02 , PWC_PVM_VOLTAGE_2V5 = 0x03 , PWC_PVM_VOLTAGE_2V6 = 0x04 ,
PWC_PVM_VOLTAGE_2V7 = 0x05 , PWC_PVM_VOLTAGE_2V8 = 0x06 , PWC_PVM_VOLTAGE_2V9 = 0x07
}
pwc pvm voltage type More...
enum | pwc_sleep_enter_type { PWC_SLEEP_ENTER_WFI = 0x00 , PWC_SLEEP_ENTER_WFE = 0x01 }
pwc sleep enter type More...
enum | pwc_deep_sleep_enter_type { PWC_DEEP_SLEEP_ENTER_WFI = 0x00 , PWC_DEEP_SLEEP_ENTER_WFE = 0x01 }
pwc deep sleep enter type More...
enum | pwc_regulator_type { PWC_REGULATOR_ON = 0x00 , PWC_REGULATOR_LOW_POWER = 0x01 }
pwc regulator type More...

Detailed Description

Enumeration Type Documentation

◆ pwc_deep_sleep_enter_type

enum pwc_deep_sleep_enter_type

pwc deep sleep enter type

Enumerator
PWC_DEEP_SLEEP_ENTER_WFI | use wfi enter deepsleep mode
PWC_DEEP_SLEEP_ENTER_WFE | use wfe enter deepsleep mode

Definition at line 95 of file at32f413_pwc.h.

◆ pwc_pvm_voltage_type

enum pwc_pvm_voltage_type

pwc pvm voltage type

Enumerator
PWC_PVM_VOLTAGE_2V3 | power voltage monitoring boundary 2.3v
PWC_PVM_VOLTAGE_2V4 | power voltage monitoring boundary 2.4v
PWC_PVM_VOLTAGE_2V5 | power voltage monitoring boundary 2.5v
PWC_PVM_VOLTAGE_2V6 | power voltage monitoring boundary 2.6v
PWC_PVM_VOLTAGE_2V7 | power voltage monitoring boundary 2.7v
PWC_PVM_VOLTAGE_2V8 | power voltage monitoring boundary 2.8v
PWC_PVM_VOLTAGE_2V9 | power voltage monitoring boundary 2.9v

Definition at line 72 of file at32f413_pwc.h.

◆ pwc_regulator_type

enum pwc_regulator_type

pwc regulator type

Enumerator
PWC_REGULATOR_ON | voltage regulator state on when deepsleep mode
PWC_REGULATOR_LOW_POWER | voltage regulator state low power when deepsleep mode

Definition at line 104 of file at32f413_pwc.h.

◆ pwc_sleep_enter_type

enum pwc_sleep_enter_type

pwc sleep enter type

Enumerator
PWC_SLEEP_ENTER_WFI | use wfi enter sleep mode
PWC_SLEEP_ENTER_WFE | use wfe enter sleep mode

Definition at line 86 of file at32f413_pwc.h.


AT32F413 Firmwary Library: pwc_type Struct Reference

Data Fields
pwc_type Struct Reference
AT32F413_periph_driver » PWC » PWC_exported_types

type define pwc register all More...

#include <at32f413_pwc.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t vrsel: 1
__IO uint32_t lpsel: 1
__IO uint32_t clswef: 1
__IO uint32_t clsef: 1
__IO uint32_t pvmen: 1
__IO uint32_t pvmsel: 3
__IO uint32_t bpwen: 1
__IO uint32_t reserved1: 23
} ctrl_bit
};
pwc ctrl register, offset:0x00 More...
union {
__IO uint32_t ctrlsts
struct {
__IO uint32_t swef: 1
__IO uint32_t sef: 1
__IO uint32_t pvmof: 1
__IO uint32_t reserved1: 5
__IO uint32_t swpen: 1
__IO uint32_t reserved2: 23
} ctrlsts_bit
};
pwc ctrlsts register, offset:0x04 More...

Detailed Description

type define pwc register all

Definition at line 113 of file at32f413_pwc.h.

Field Documentation

◆

union { ... } pwc_type::@532

pwc ctrl register, offset:0x00

◆

union { ... } pwc_type::@534

pwc ctrlsts register, offset:0x04

◆ bpwen

__IO uint32_t pwc_type::bpwen

Definition at line 129 of file at32f413_pwc.h.

◆ clsef

__IO uint32_t pwc_type::clsef

Definition at line 126 of file at32f413_pwc.h.

◆ clswef

__IO uint32_t pwc_type::clswef

Definition at line 125 of file at32f413_pwc.h.

◆ ctrl

__IO uint32_t pwc_type::ctrl

Definition at line 120 of file at32f413_pwc.h.

◆

struct { ... } pwc_type::ctrl_bit

◆ ctrlsts

__IO uint32_t pwc_type::ctrlsts

Definition at line 139 of file at32f413_pwc.h.

◆

struct { ... } pwc_type::ctrlsts_bit

◆ lpsel

__IO uint32_t pwc_type::lpsel

Definition at line 124 of file at32f413_pwc.h.

◆ pvmen

__IO uint32_t pwc_type::pvmen

Definition at line 127 of file at32f413_pwc.h.

◆ pvmof

__IO uint32_t pwc_type::pvmof

Definition at line 144 of file at32f413_pwc.h.

◆ pvmsel

__IO uint32_t pwc_type::pvmsel

Definition at line 128 of file at32f413_pwc.h.

◆ reserved1

__IO uint32_t pwc_type::reserved1

Definition at line 130 of file at32f413_pwc.h.

◆ reserved2

__IO uint32_t pwc_type::reserved2

Definition at line 147 of file at32f413_pwc.h.

◆ sef

__IO uint32_t pwc_type::sef

Definition at line 143 of file at32f413_pwc.h.

◆ swef

__IO uint32_t pwc_type::swef

Definition at line 142 of file at32f413_pwc.h.

◆ swpen

__IO uint32_t pwc_type::swpen

Definition at line 146 of file at32f413_pwc.h.

◆ vrsel

__IO uint32_t pwc_type::vrsel

Definition at line 123 of file at32f413_pwc.h.

The documentation for this struct was generated from the following file:
  • at32f413_pwc.h


AT32F413 Firmwary Library: PWC_exported_functions

Functions
PWC_exported_functions
AT32F413_periph_driver » PWC

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_voltage_regulate_set (pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

Function Documentation

◆ pwc_battery_powered_domain_access()

void pwc_battery_powered_domain_access ( confirm_state new_state )

enable or disable access to the battery powered domain.

Parameters
new_state new state of battery powered domain access. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 61 of file at32f413_pwc.c.

Referenced by main(), rtc_alarm_clock_set(), rtc_config(), rtc_configuration(), rtc_init(), and rtc_time_set().

◆ pwc_deep_sleep_mode_enter()

void pwc_deep_sleep_mode_enter ( pwc_deep_sleep_enter_type pwc_deep_sleep_enter )

enter pwc deep-sleep mode

Parameters
pwc_deep_sleep_enter choose the instruction to enter deep sleep mode. this parameter can be one of the following values:
  • PWC_DEEP_SLEEP_ENTER_WFI
  • PWC_DEEP_SLEEP_ENTER_WFE
Return values
none

Definition at line 189 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_flag_clear()

void pwc_flag_clear ( uint32_t pwc_flag )

clear flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be any combination of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • note:"PWC_PVM_OUTPUT_FLAG" cannot be choose!this bit is readonly bit,it means the voltage monitoring output state
Return values
none

< standby flag

< wakeup flag

Definition at line 127 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_flag_get()

flag_status pwc_flag_get ( uint32_t pwc_flag )

get flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be one of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • PWC_PVM_OUTPUT_FLAG
Return values
state of select flag(SET or RESET).

Definition at line 144 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_power_voltage_monitor_enable()

void pwc_power_voltage_monitor_enable ( confirm_state new_state )

enable or disable pwc power voltage monitor (pvm)

Parameters
new_state new state of pvm. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 90 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_pvm_level_select()

void pwc_pvm_level_select ( pwc_pvm_voltage_type pvm_voltage )

select the voltage threshold detected by the power voltage detector.

Parameters
pvm_voltage select pwc pvm voltage this parameter can be one of the following values:
  • PWC_PVM_VOLTAGE_2V3
  • PWC_PVM_VOLTAGE_2V4
  • PWC_PVM_VOLTAGE_2V5
  • PWC_PVM_VOLTAGE_2V6
  • PWC_PVM_VOLTAGE_2V7
  • PWC_PVM_VOLTAGE_2V8
  • PWC_PVM_VOLTAGE_2V9
Return values
none

Definition at line 79 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_reset()

void pwc_reset ( void )

deinitialize the pwc peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 49 of file at32f413_pwc.c.

◆ pwc_sleep_mode_enter()

void pwc_sleep_mode_enter ( pwc_sleep_enter_type pwc_sleep_enter )

enter pwc sleep mode

Parameters
sleep_mode_enter choose the instruction to enter sleep mode. this parameter can be one of the following values:
  • PWC_SLEEP_ENTER_WFI
  • PWC_SLEEP_ENTER_WFE
Return values
none

Definition at line 166 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_standby_mode_enter()

void pwc_standby_mode_enter ( void )

enter pwc standby mode

Parameters
none
Return values
none

Definition at line 223 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_voltage_regulate_set()

void pwc_voltage_regulate_set ( pwc_regulator_type pwc_regulator )

regulate low power consumption in the deep sleep mode

Parameters
pwc_regulator set the regulator state. this parameter can be one of the following values:
  • PWC_REGULATOR_ON
  • PWC_REGULATOR_LOW_POWER
Return values
none

Definition at line 213 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_wakeup_pin_enable()

void pwc_wakeup_pin_enable | ( | uint32_t | pin_num,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pwc standby wakeup pin

Parameters
pin_num choose the wakeup pin. this parameter can be be any combination of the following values:
  • PWC_WAKEUP_PIN_1
new_state new state of the standby wakeup pin. this parameter can be one of the following values:
  • TRUE <wakeup pin is used for wake up cpu from standby mode>
  • FALSE <wakeup pin is used for general purpose I/O>
Return values
none

Definition at line 106 of file at32f413_pwc.c.

Referenced by main().


AT32F413 Firmwary Library: PWC_private_functions

Functions
PWC_private_functions
AT32F413_periph_driver » PWC

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_voltage_regulate_set (pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

Function Documentation

◆ pwc_battery_powered_domain_access()

void pwc_battery_powered_domain_access ( confirm_state new_state )

enable or disable access to the battery powered domain.

Parameters
new_state new state of battery powered domain access. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 61 of file at32f413_pwc.c.

Referenced by main(), rtc_alarm_clock_set(), rtc_config(), rtc_configuration(), rtc_init(), and rtc_time_set().

◆ pwc_deep_sleep_mode_enter()

void pwc_deep_sleep_mode_enter ( pwc_deep_sleep_enter_type pwc_deep_sleep_enter )

enter pwc deep-sleep mode

Parameters
pwc_deep_sleep_enter choose the instruction to enter deep sleep mode. this parameter can be one of the following values:
  • PWC_DEEP_SLEEP_ENTER_WFI
  • PWC_DEEP_SLEEP_ENTER_WFE
Return values
none

Definition at line 189 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_flag_clear()

void pwc_flag_clear ( uint32_t pwc_flag )

clear flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be any combination of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • note:"PWC_PVM_OUTPUT_FLAG" cannot be choose!this bit is readonly bit,it means the voltage monitoring output state
Return values
none

< standby flag

< wakeup flag

Definition at line 127 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_flag_get()

flag_status pwc_flag_get ( uint32_t pwc_flag )

get flag of pwc

Parameters
pwc_flag select the pwc flag. this parameter can be one of the following values:
  • PWC_WAKEUP_FLAG
  • PWC_STANDBY_FLAG
  • PWC_PVM_OUTPUT_FLAG
Return values
state of select flag(SET or RESET).

Definition at line 144 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_power_voltage_monitor_enable()

void pwc_power_voltage_monitor_enable ( confirm_state new_state )

enable or disable pwc power voltage monitor (pvm)

Parameters
new_state new state of pvm. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 90 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_pvm_level_select()

void pwc_pvm_level_select ( pwc_pvm_voltage_type pvm_voltage )

select the voltage threshold detected by the power voltage detector.

Parameters
pvm_voltage select pwc pvm voltage this parameter can be one of the following values:
  • PWC_PVM_VOLTAGE_2V3
  • PWC_PVM_VOLTAGE_2V4
  • PWC_PVM_VOLTAGE_2V5
  • PWC_PVM_VOLTAGE_2V6
  • PWC_PVM_VOLTAGE_2V7
  • PWC_PVM_VOLTAGE_2V8
  • PWC_PVM_VOLTAGE_2V9
Return values
none

Definition at line 79 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_reset()

void pwc_reset ( void )

deinitialize the pwc peripheral registers to their default reset values.

Parameters
none
Return values
none

Definition at line 49 of file at32f413_pwc.c.

◆ pwc_sleep_mode_enter()

void pwc_sleep_mode_enter ( pwc_sleep_enter_type pwc_sleep_enter )

enter pwc sleep mode

Parameters
sleep_mode_enter choose the instruction to enter sleep mode. this parameter can be one of the following values:
  • PWC_SLEEP_ENTER_WFI
  • PWC_SLEEP_ENTER_WFE
Return values
none

Definition at line 166 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_standby_mode_enter()

void pwc_standby_mode_enter ( void )

enter pwc standby mode

Parameters
none
Return values
none

Definition at line 223 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_voltage_regulate_set()

void pwc_voltage_regulate_set ( pwc_regulator_type pwc_regulator )

regulate low power consumption in the deep sleep mode

Parameters
pwc_regulator set the regulator state. this parameter can be one of the following values:
  • PWC_REGULATOR_ON
  • PWC_REGULATOR_LOW_POWER
Return values
none

Definition at line 213 of file at32f413_pwc.c.

Referenced by main().

◆ pwc_wakeup_pin_enable()

void pwc_wakeup_pin_enable | ( | uint32_t | pin_num,
 |  | confirm_state | new_state
 | ) |  |

enable or disable pwc standby wakeup pin

Parameters
pin_num choose the wakeup pin. this parameter can be be any combination of the following values:
  • PWC_WAKEUP_PIN_1
new_state new state of the standby wakeup pin. this parameter can be one of the following values:
  • TRUE <wakeup pin is used for wake up cpu from standby mode>
  • FALSE <wakeup pin is used for general purpose I/O>
Return values
none

Definition at line 106 of file at32f413_pwc.c.

Referenced by main().


AT32F413 Firmwary Library: RTC

Modules | Macros
RTC
AT32F413_periph_driver

RTC driver modules. More...

Modules

RTC_interrupts_definition
rtc interrupt
RTC_flags_definition
rtc flag
RTC_exported_types
RTC_exported_functions
RTC_private_functions

Macros

#define RTC ((rtc_type *) RTC_BASE)

Detailed Description

RTC driver modules.

Macro Definition Documentation

◆ RTC

#define RTC ((rtc_type *) RTC_BASE)

Definition at line 228 of file at32f413_rtc.h.


AT32F413 Firmwary Library: RTC_interrupts_definition

Macros
RTC_interrupts_definition
AT32F413_periph_driver » RTC

rtc interrupt More...

Macros

#define | RTC_TS_INT ((uint16_t)0x0001)
#define | RTC_TA_INT ((uint16_t)0x0002)
#define | RTC_OVF_INT ((uint16_t)0x0004)

Detailed Description

rtc interrupt

Macro Definition Documentation

◆ RTC_OVF_INT

#define RTC_OVF_INT ((uint16_t)0x0004)

rtc overflow interrupt

Definition at line 54 of file at32f413_rtc.h.

◆ RTC_TA_INT

#define RTC_TA_INT ((uint16_t)0x0002)

rtc time alarm interrupt

Definition at line 53 of file at32f413_rtc.h.

◆ RTC_TS_INT

#define RTC_TS_INT ((uint16_t)0x0001)

rtc time second interrupt

Definition at line 52 of file at32f413_rtc.h.


AT32F413 Firmwary Library: RTC_flags_definition

Macros
RTC_flags_definition
AT32F413_periph_driver » RTC

rtc flag More...

Macros

#define | RTC_TS_FLAG ((uint16_t)0x0001)
#define | RTC_TA_FLAG ((uint16_t)0x0002)
#define | RTC_OVF_FLAG ((uint16_t)0x0004)
#define | RTC_UPDF_FLAG ((uint16_t)0x0008)
#define | RTC_CFGF_FLAG ((uint16_t)0x0020)

Detailed Description

rtc flag

Macro Definition Documentation

◆ RTC_CFGF_FLAG

#define RTC_CFGF_FLAG ((uint16_t)0x0020)

rtc configuration finish flag

Definition at line 69 of file at32f413_rtc.h.

◆ RTC_OVF_FLAG

#define RTC_OVF_FLAG ((uint16_t)0x0004)

rtc overflow flag

Definition at line 67 of file at32f413_rtc.h.

◆ RTC_TA_FLAG

#define RTC_TA_FLAG ((uint16_t)0x0002)

rtc time alarm flag

Definition at line 66 of file at32f413_rtc.h.

◆ RTC_TS_FLAG

#define RTC_TS_FLAG ((uint16_t)0x0001)

rtc time second flag

Definition at line 65 of file at32f413_rtc.h.

◆ RTC_UPDF_FLAG

#define RTC_UPDF_FLAG ((uint16_t)0x0008)

rtc update finish flag

Definition at line 68 of file at32f413_rtc.h.


AT32F413 Firmwary Library: RTC_exported_types

Data Structures
RTC_exported_types
AT32F413_periph_driver » RTC

Data Structures

struct rtc_type
type define rtc register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: rtc_type Struct Reference

Data Fields
rtc_type Struct Reference
AT32F413_periph_driver » RTC » RTC_exported_types

type define rtc register all More...

#include <at32f413_rtc.h>

Data Fields

union {
__IO uint32_t ctrlh
struct {
__IO uint32_t tsien: 1
__IO uint32_t taien: 1
__IO uint32_t ovfien: 1
__IO uint32_t reserved1: 29
} ctrlh_bit
};
rtc ctrlh register, offset:0x00 More...
union {
__IO uint32_t ctrll
struct {
__IO uint32_t tsf: 1
__IO uint32_t taf: 1
__IO uint32_t ovff: 1
__IO uint32_t updf: 1
__IO uint32_t cfgen: 1
__IO uint32_t cfgf: 1
__IO uint32_t reserved1: 26
} ctrll_bit
};
rtc ctrll register, offset:0x04 More...
union {
__IO uint32_t divh
struct {
__IO uint32_t div: 4
__IO uint32_t reserved1: 28
} divh_bit
};
rtc divh register, offset:0x08 More...
union {
__IO uint32_t divl
struct {
__IO uint32_t div: 16
__IO uint32_t reserved1: 16
} divl_bit
};
rtc divl register, offset:0x0C More...
union {
__IO uint32_t divcnth
struct {
__IO uint32_t divcnt: 4
__IO uint32_t reserved1: 28
} divcnth_bit
};
rtc divcnth register, offset:0x10 More...
union {
__IO uint32_t divcntl
struct {
__IO uint32_t divcnt: 16
__IO uint32_t reserved1: 16
} divcntl_bit
};
rtc divcntl register, offset:0x14 More...
union {
__IO uint32_t cnth
struct {
__IO uint32_t cnt: 16
__IO uint32_t reserved1: 16
} cnth_bit
};
rtc cnth register, offset:0x18 More...
union {
__IO uint32_t cntl
struct {
__IO uint32_t cnt: 16
__IO uint32_t reserved1: 16
} cntl_bit
};
rtc cntl register, offset:0x1C More...
union {
__IO uint32_t tah
struct {
__IO uint32_t ta: 16
__IO uint32_t reserved1: 16
} tah_bit
};
rtc tah register, offset:0x20 More...
union {
__IO uint32_t tal
struct {
__IO uint32_t ta: 16
__IO uint32_t reserved1: 16
} tal_bit
};
rtc tal register, offset:0x24 More...

Detailed Description

type define rtc register all

Definition at line 82 of file at32f413_rtc.h.

Field Documentation

◆

union { ... } rtc_type::@538

rtc ctrlh register, offset:0x00

◆

union { ... } rtc_type::@540

rtc ctrll register, offset:0x04

◆

union { ... } rtc_type::@542

rtc divh register, offset:0x08

◆

union { ... } rtc_type::@544

rtc divl register, offset:0x0C

◆

union { ... } rtc_type::@546

rtc divcnth register, offset:0x10

◆

union { ... } rtc_type::@548

rtc divcntl register, offset:0x14

◆

union { ... } rtc_type::@550

rtc cnth register, offset:0x18

◆

union { ... } rtc_type::@552

rtc cntl register, offset:0x1C

◆

union { ... } rtc_type::@554

rtc tah register, offset:0x20

◆

union { ... } rtc_type::@556

rtc tal register, offset:0x24

◆ cfgen

__IO uint32_t rtc_type::cfgen

Definition at line 112 of file at32f413_rtc.h.

◆ cfgf

__IO uint32_t rtc_type::cfgf

Definition at line 113 of file at32f413_rtc.h.

◆ cnt

__IO uint32_t rtc_type::cnt

Definition at line 178 of file at32f413_rtc.h.

◆ cnth

__IO uint32_t rtc_type::cnth

Definition at line 175 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::cnth_bit

◆ cntl

__IO uint32_t rtc_type::cntl

Definition at line 188 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::cntl_bit

◆ ctrlh

__IO uint32_t rtc_type::ctrlh

Definition at line 90 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::ctrlh_bit

◆ ctrll

__IO uint32_t rtc_type::ctrll

Definition at line 105 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::ctrll_bit

◆ div

__IO uint32_t rtc_type::div

Definition at line 126 of file at32f413_rtc.h.

◆ divcnt

__IO uint32_t rtc_type::divcnt

Definition at line 152 of file at32f413_rtc.h.

◆ divcnth

__IO uint32_t rtc_type::divcnth

Definition at line 149 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::divcnth_bit

◆ divcntl

__IO uint32_t rtc_type::divcntl

Definition at line 162 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::divcntl_bit

◆ divh

__IO uint32_t rtc_type::divh

Definition at line 123 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::divh_bit

◆ divl

__IO uint32_t rtc_type::divl

Definition at line 136 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::divl_bit

◆ ovff

__IO uint32_t rtc_type::ovff

Definition at line 110 of file at32f413_rtc.h.

◆ ovfien

__IO uint32_t rtc_type::ovfien

Definition at line 95 of file at32f413_rtc.h.

◆ reserved1

__IO uint32_t rtc_type::reserved1

Definition at line 96 of file at32f413_rtc.h.

◆ ta

__IO uint32_t rtc_type::ta

Definition at line 204 of file at32f413_rtc.h.

◆ taf

__IO uint32_t rtc_type::taf

Definition at line 109 of file at32f413_rtc.h.

◆ tah

__IO uint32_t rtc_type::tah

Definition at line 201 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::tah_bit

◆ taien

__IO uint32_t rtc_type::taien

Definition at line 94 of file at32f413_rtc.h.

◆ tal

__IO uint32_t rtc_type::tal

Definition at line 214 of file at32f413_rtc.h.

◆

struct { ... } rtc_type::tal_bit

◆ tsf

__IO uint32_t rtc_type::tsf

Definition at line 108 of file at32f413_rtc.h.

◆ tsien

__IO uint32_t rtc_type::tsien

Definition at line 93 of file at32f413_rtc.h.

◆ updf

__IO uint32_t rtc_type::updf

Definition at line 111 of file at32f413_rtc.h.

The documentation for this struct was generated from the following file:
  • at32f413_rtc.h


AT32F413 Firmwary Library: RTC_exported_functions

Functions
RTC_exported_functions
AT32F413_periph_driver » RTC

Functions

void | rtc_counter_set (uint32_t counter_value)
rtc counter set More...
uint32_t | rtc_counter_get (void)
rtc counter get More...
void | rtc_divider_set (uint32_t div_value)
rtc divider set More...
uint32_t | rtc_divider_get (void)
rtc divider get More...
void | rtc_alarm_set (uint32_t alarm_value)
rtc alarm value set More...
void | rtc_interrupt_enable (uint16_t source, confirm_state new_state)
rtc interrupt enable More...
flag_status | rtc_flag_get (uint16_t flag)
rtc flag get More...
void | rtc_flag_clear (uint16_t flag)
rtc flag clear More...
void | rtc_wait_config_finish (void)
rtc wait configuration finish More...
void | rtc_wait_update_finish (void)
rtc wait update finish More...

Detailed Description

Function Documentation

◆ rtc_alarm_set()

void rtc_alarm_set ( uint32_t alarm_value )

rtc alarm value set

Parameters
alarm_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 115 of file at32f413_rtc.c.

Referenced by main(), rtc_alarm_clock_set(), and rtc_alarm_config().

◆ rtc_counter_get()

uint32_t rtc_counter_get ( void )

rtc counter get

Parameters
none
Return values
rtc counter

Definition at line 67 of file at32f413_rtc.c.

Referenced by main(), randnum_test(), rtc_alarm_config(), RTC_IRQHandler(), and rtc_time_get().

◆ rtc_counter_set()

void rtc_counter_set ( uint32_t counter_value )

rtc counter set

Parameters
counter_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 49 of file at32f413_rtc.c.

Referenced by rtc_time_set().

◆ rtc_divider_get()

uint32_t rtc_divider_get ( void )

rtc divider get

Parameters
none
Return values
rtc counter

Definition at line 100 of file at32f413_rtc.c.

◆ rtc_divider_set()

void rtc_divider_set ( uint32_t div_value )

rtc divider set

Parameters
div_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 82 of file at32f413_rtc.c.

Referenced by main(), rtc_config(), rtc_configuration(), and rtc_init().

◆ rtc_flag_clear()

void rtc_flag_clear ( uint16_t flag )

rtc flag clear

Parameters
interrupt_flag this parameter can be any combination of the following values:
  • RTC_TS_FLAG: time second flag.
  • RTC_TA_FLAG: time alarm flag.
  • RTC_OVF_FLAG: overflow flag.
  • RTC_CFGF_FLAG: rtc configuration finish flag.
Return values
none

Definition at line 187 of file at32f413_rtc.c.

Referenced by alarm_init(), main(), rtc_alarm_config(), RTC_IRQHandler(), and RTCAlarm_IRQHandler().

◆ rtc_flag_get()

flag_status rtc_flag_get ( uint16_t flag )

rtc flag get

Parameters
flag this parameter can be one of the following values:
  • RTC_TS_FLAG: time second flag.
  • RTC_TA_FLAG: time alarm flag.
  • RTC_OVF_FLAG: overflow flag.
  • RTC_UPDF_FLAG: rtc update finish flag.
  • RTC_CFGF_FLAG: rtc configuration finish flag.
Return values
state of rtc flag

Definition at line 161 of file at32f413_rtc.c.

Referenced by main(), rtc_alarm_config(), RTC_IRQHandler(), and RTCAlarm_IRQHandler().

◆ rtc_interrupt_enable()

void rtc_interrupt_enable | ( | uint16_t | source,
 |  | confirm_state | new_state
 | ) |  |

rtc interrupt enable

Parameters
source this parameter can be any combination of the following values:
  • RTC_TS_INT: time second interrupt.
  • RTC_TA_INT: time alarm interrupt.
  • RTC_OVF_INT: overflow interrupt.
new_state (TRUE or FALSE)
Return values
none

Definition at line 138 of file at32f413_rtc.c.

Referenced by alarm_init(), rtc_config(), and rtc_configuration().

◆ rtc_wait_config_finish()

void rtc_wait_config_finish ( void )

rtc wait configuration finish

Parameters
none
Return values
none

Definition at line 197 of file at32f413_rtc.c.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_alarm_config(), rtc_config(), rtc_configuration(), rtc_init(), rtc_time_set(), and RTCAlarm_IRQHandler().

◆ rtc_wait_update_finish()

void rtc_wait_update_finish ( void )

rtc wait update finish

Parameters
none
Return values
none

Definition at line 207 of file at32f413_rtc.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().


AT32F413 Firmwary Library: RTC_private_functions

Functions
RTC_private_functions
AT32F413_periph_driver » RTC

Functions

void | rtc_counter_set (uint32_t counter_value)
rtc counter set More...
uint32_t | rtc_counter_get (void)
rtc counter get More...
void | rtc_divider_set (uint32_t div_value)
rtc divider set More...
uint32_t | rtc_divider_get (void)
rtc divider get More...
void | rtc_alarm_set (uint32_t alarm_value)
rtc alarm value set More...
void | rtc_interrupt_enable (uint16_t source, confirm_state new_state)
rtc interrupt enable More...
flag_status | rtc_flag_get (uint16_t flag)
rtc flag get More...
void | rtc_flag_clear (uint16_t flag)
rtc flag clear More...
void | rtc_wait_config_finish (void)
rtc wait configuration finish More...
void | rtc_wait_update_finish (void)
rtc wait update finish More...

Detailed Description

Function Documentation

◆ rtc_alarm_set()

void rtc_alarm_set ( uint32_t alarm_value )

rtc alarm value set

Parameters
alarm_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 115 of file at32f413_rtc.c.

Referenced by main(), rtc_alarm_clock_set(), and rtc_alarm_config().

◆ rtc_counter_get()

uint32_t rtc_counter_get ( void )

rtc counter get

Parameters
none
Return values
rtc counter

Definition at line 67 of file at32f413_rtc.c.

Referenced by main(), randnum_test(), rtc_alarm_config(), RTC_IRQHandler(), and rtc_time_get().

◆ rtc_counter_set()

void rtc_counter_set ( uint32_t counter_value )

rtc counter set

Parameters
counter_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 49 of file at32f413_rtc.c.

Referenced by rtc_time_set().

◆ rtc_divider_get()

uint32_t rtc_divider_get ( void )

rtc divider get

Parameters
none
Return values
rtc counter

Definition at line 100 of file at32f413_rtc.c.

◆ rtc_divider_set()

void rtc_divider_set ( uint32_t div_value )

rtc divider set

Parameters
div_value (0x0000_0000 ~ 0xFFFF_FFFF)
Return values
none

Definition at line 82 of file at32f413_rtc.c.

Referenced by main(), rtc_config(), rtc_configuration(), and rtc_init().

◆ rtc_flag_clear()

void rtc_flag_clear ( uint16_t flag )

rtc flag clear

Parameters
interrupt_flag this parameter can be any combination of the following values:
  • RTC_TS_FLAG: time second flag.
  • RTC_TA_FLAG: time alarm flag.
  • RTC_OVF_FLAG: overflow flag.
  • RTC_CFGF_FLAG: rtc configuration finish flag.
Return values
none

Definition at line 187 of file at32f413_rtc.c.

Referenced by alarm_init(), main(), rtc_alarm_config(), RTC_IRQHandler(), and RTCAlarm_IRQHandler().

◆ rtc_flag_get()

flag_status rtc_flag_get ( uint16_t flag )

rtc flag get

Parameters
flag this parameter can be one of the following values:
  • RTC_TS_FLAG: time second flag.
  • RTC_TA_FLAG: time alarm flag.
  • RTC_OVF_FLAG: overflow flag.
  • RTC_UPDF_FLAG: rtc update finish flag.
  • RTC_CFGF_FLAG: rtc configuration finish flag.
Return values
state of rtc flag

Definition at line 161 of file at32f413_rtc.c.

Referenced by main(), rtc_alarm_config(), RTC_IRQHandler(), and RTCAlarm_IRQHandler().

◆ rtc_interrupt_enable()

void rtc_interrupt_enable | ( | uint16_t | source,
 |  | confirm_state | new_state
 | ) |  |

rtc interrupt enable

Parameters
source this parameter can be any combination of the following values:
  • RTC_TS_INT: time second interrupt.
  • RTC_TA_INT: time alarm interrupt.
  • RTC_OVF_INT: overflow interrupt.
new_state (TRUE or FALSE)
Return values
none

Definition at line 138 of file at32f413_rtc.c.

Referenced by alarm_init(), rtc_config(), and rtc_configuration().

◆ rtc_wait_config_finish()

void rtc_wait_config_finish ( void )

rtc wait configuration finish

Parameters
none
Return values
none

Definition at line 197 of file at32f413_rtc.c.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_alarm_config(), rtc_config(), rtc_configuration(), rtc_init(), rtc_time_set(), and RTCAlarm_IRQHandler().

◆ rtc_wait_update_finish()

void rtc_wait_update_finish ( void )

rtc wait update finish

Parameters
none
Return values
none

Definition at line 207 of file at32f413_rtc.c.

Referenced by rtc_config(), rtc_configuration(), and rtc_init().


AT32F413 Firmwary Library: SDIO

Modules | Macros
SDIO
AT32F413_periph_driver

SDIO driver modules. More...

Modules

SDIO_interrupts_definition
sdio interrupt
SDIO_flags_definition
sdio flag
SDIO_exported_types
SDIO_exported_functions
SDIO_private_functions

Macros

#define SDIO1 ((sdio_type *) SDIO1_BASE)

Detailed Description

SDIO driver modules.

Macro Definition Documentation

◆ SDIO1

#define SDIO1 ((sdio_type *) SDIO1_BASE)

Definition at line 572 of file at32f413_sdio.h.


AT32F413 Firmwary Library: SDIO_interrupts_definition

Macros
SDIO_interrupts_definition
AT32F413_periph_driver » SDIO

sdio interrupt More...

Macros

#define | SDIO_CMDFAIL_INT ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_INT ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)
#define | SDIO_TXERRU_INT ((uint32_t)0x00000010)
#define | SDIO_RXERRO_INT ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_INT ((uint32_t)0x00000080)
#define | SDIO_DTCMP_INT ((uint32_t)0x00000100)
#define | SDIO_SBITERR_INT ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)
#define | SDIO_DOCMD_INT ((uint32_t)0x00000800)
#define | SDIO_DOTX_INT ((uint32_t)0x00001000)
#define | SDIO_DORX_INT ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_INT ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_INT ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_INT ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_INT ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_INT ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_INT ((uint32_t)0x00080000)
#define | SDIO_TXBUF_INT ((uint32_t)0x00100000)
#define | SDIO_RXBUF_INT ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_INT ((uint32_t)0x00400000)

Detailed Description

sdio interrupt

Macro Definition Documentation

◆ SDIO_CMDCMPL_INT

#define SDIO_CMDCMPL_INT ((uint32_t)0x00000080)

command sent interrupt

Definition at line 59 of file at32f413_sdio.h.

◆ SDIO_CMDFAIL_INT

#define SDIO_CMDFAIL_INT ((uint32_t)0x00000001)

command response received check failed interrupt

Definition at line 52 of file at32f413_sdio.h.

◆ SDIO_CMDRSPCMPL_INT

#define SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)

command response received interrupt

Definition at line 58 of file at32f413_sdio.h.

◆ SDIO_CMDTIMEOUT_INT

#define SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)

command response timerout interrupt

Definition at line 54 of file at32f413_sdio.h.

◆ SDIO_DOCMD_INT

#define SDIO_DOCMD_INT ((uint32_t)0x00000800)

command transfer in progress interrupt

Definition at line 63 of file at32f413_sdio.h.

◆ SDIO_DORX_INT

#define SDIO_DORX_INT ((uint32_t)0x00002000)

data receive in progress interrupt

Definition at line 65 of file at32f413_sdio.h.

◆ SDIO_DOTX_INT

#define SDIO_DOTX_INT ((uint32_t)0x00001000)

data transmit in progress interrupt

Definition at line 64 of file at32f413_sdio.h.

◆ SDIO_DTBLKCMPL_INT

#define SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)

data block sent/received interrupt

Definition at line 62 of file at32f413_sdio.h.

◆ SDIO_DTCMP_INT

#define SDIO_DTCMP_INT ((uint32_t)0x00000100)

data sent interrupt

Definition at line 60 of file at32f413_sdio.h.

◆ SDIO_DTFAIL_INT

#define SDIO_DTFAIL_INT ((uint32_t)0x00000002)

data block sent/received check failed interrupt

Definition at line 53 of file at32f413_sdio.h.

◆ SDIO_DTTIMEOUT_INT

#define SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)

data timeout interrupt

Definition at line 55 of file at32f413_sdio.h.

◆ SDIO_RXBUF_INT

#define SDIO_RXBUF_INT ((uint32_t)0x00200000)

data available in receive interrupt

Definition at line 73 of file at32f413_sdio.h.

◆ SDIO_RXBUFE_INT

#define SDIO_RXBUFE_INT ((uint32_t)0x00080000)

receive buf empty interrupt

Definition at line 71 of file at32f413_sdio.h.

◆ SDIO_RXBUFF_INT

#define SDIO_RXBUFF_INT ((uint32_t)0x00020000)

receive buf full interrupt

Definition at line 69 of file at32f413_sdio.h.

◆ SDIO_RXBUFH_INT

#define SDIO_RXBUFH_INT ((uint32_t)0x00008000)

receive buf half full interrupt

Definition at line 67 of file at32f413_sdio.h.

◆ SDIO_RXERRO_INT

#define SDIO_RXERRO_INT ((uint32_t)0x00000020)

received overrun error interrupt

Definition at line 57 of file at32f413_sdio.h.

◆ SDIO_SBITERR_INT

#define SDIO_SBITERR_INT ((uint32_t)0x00000200)

start bit not detected on data bus interrupt

Definition at line 61 of file at32f413_sdio.h.

◆ SDIO_SDIOIF_INT

#define SDIO_SDIOIF_INT ((uint32_t)0x00400000)

sdio interface received interrupt

Definition at line 74 of file at32f413_sdio.h.

◆ SDIO_TXBUF_INT

#define SDIO_TXBUF_INT ((uint32_t)0x00100000)

data available in transmit interrupt

Definition at line 72 of file at32f413_sdio.h.

◆ SDIO_TXBUFE_INT

#define SDIO_TXBUFE_INT ((uint32_t)0x00040000)

transmit buf empty interrupt

Definition at line 70 of file at32f413_sdio.h.

◆ SDIO_TXBUFF_INT

#define SDIO_TXBUFF_INT ((uint32_t)0x00010000)

transmit buf full interrupt

Definition at line 68 of file at32f413_sdio.h.

◆ SDIO_TXBUFH_INT

#define SDIO_TXBUFH_INT ((uint32_t)0x00004000)

transmit buf half empty interrupt

Definition at line 66 of file at32f413_sdio.h.

◆ SDIO_TXERRU_INT

#define SDIO_TXERRU_INT ((uint32_t)0x00000010)

transmit underrun error interrupt

Definition at line 56 of file at32f413_sdio.h.


AT32F413 Firmwary Library: SDIO_flags_definition

Macros
SDIO_flags_definition
AT32F413_periph_driver » SDIO

sdio flag More...

Macros

#define | SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)
#define | SDIO_TXERRU_FLAG ((uint32_t)0x00000010)
#define | SDIO_RXERRO_FLAG ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)
#define | SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)
#define | SDIO_SBITERR_FLAG ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)
#define | SDIO_DOCMD_FLAG ((uint32_t)0x00000800)
#define | SDIO_DOTX_FLAG ((uint32_t)0x00001000)
#define | SDIO_DORX_FLAG ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)
#define | SDIO_TXBUF_FLAG ((uint32_t)0x00100000)
#define | SDIO_RXBUF_FLAG ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)

Detailed Description

sdio flag

Macro Definition Documentation

◆ SDIO_CMDCMPL_FLAG

#define SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)

command sent flag

Definition at line 92 of file at32f413_sdio.h.

◆ SDIO_CMDFAIL_FLAG

#define SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)

command response received check failed flag

Definition at line 85 of file at32f413_sdio.h.

◆ SDIO_CMDRSPCMPL_FLAG

#define SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)

command response received flag

Definition at line 91 of file at32f413_sdio.h.

◆ SDIO_CMDTIMEOUT_FLAG

#define SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)

command response timerout flag

Definition at line 87 of file at32f413_sdio.h.

◆ SDIO_DOCMD_FLAG

#define SDIO_DOCMD_FLAG ((uint32_t)0x00000800)

command transfer in progress flag

Definition at line 96 of file at32f413_sdio.h.

◆ SDIO_DORX_FLAG

#define SDIO_DORX_FLAG ((uint32_t)0x00002000)

data receive in progress flag

Definition at line 98 of file at32f413_sdio.h.

◆ SDIO_DOTX_FLAG

#define SDIO_DOTX_FLAG ((uint32_t)0x00001000)

data transmit in progress flag

Definition at line 97 of file at32f413_sdio.h.

◆ SDIO_DTBLKCMPL_FLAG

#define SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)

data block sent/received flag

Definition at line 95 of file at32f413_sdio.h.

◆ SDIO_DTCMPL_FLAG

#define SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)

data sent flag

Definition at line 93 of file at32f413_sdio.h.

◆ SDIO_DTFAIL_FLAG

#define SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)

data block sent/received check failed flag

Definition at line 86 of file at32f413_sdio.h.

◆ SDIO_DTTIMEOUT_FLAG

#define SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)

data timeout flag

Definition at line 88 of file at32f413_sdio.h.

◆ SDIO_RXBUF_FLAG

#define SDIO_RXBUF_FLAG ((uint32_t)0x00200000)

data available in receive flag

Definition at line 106 of file at32f413_sdio.h.

◆ SDIO_RXBUFE_FLAG

#define SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)

receive buf empty flag

Definition at line 104 of file at32f413_sdio.h.

◆ SDIO_RXBUFF_FLAG

#define SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)

receive buf full flag

Definition at line 102 of file at32f413_sdio.h.

◆ SDIO_RXBUFH_FLAG

#define SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)

receive buf half full flag

Definition at line 100 of file at32f413_sdio.h.

◆ SDIO_RXERRO_FLAG

#define SDIO_RXERRO_FLAG ((uint32_t)0x00000020)

received overrun error flag

Definition at line 90 of file at32f413_sdio.h.

◆ SDIO_SBITERR_FLAG

#define SDIO_SBITERR_FLAG ((uint32_t)0x00000200)

start bit not detected on data bus flag

Definition at line 94 of file at32f413_sdio.h.

◆ SDIO_SDIOIF_FLAG

#define SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)

sdio interface received flag

Definition at line 107 of file at32f413_sdio.h.

◆ SDIO_TXBUF_FLAG

#define SDIO_TXBUF_FLAG ((uint32_t)0x00100000)

data available in transmit flag

Definition at line 105 of file at32f413_sdio.h.

◆ SDIO_TXBUFE_FLAG

#define SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)

transmit buf empty flag

Definition at line 103 of file at32f413_sdio.h.

◆ SDIO_TXBUFF_FLAG

#define SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)

transmit buf full flag

Definition at line 101 of file at32f413_sdio.h.

◆ SDIO_TXBUFH_FLAG

#define SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)

transmit buf half empty flag

Definition at line 99 of file at32f413_sdio.h.

◆ SDIO_TXERRU_FLAG

#define SDIO_TXERRU_FLAG ((uint32_t)0x00000010)

transmit underrun error flag

Definition at line 89 of file at32f413_sdio.h.


AT32F413 Firmwary Library: SDIO_exported_types

Data Structures | Enumerations
SDIO_exported_types
AT32F413_periph_driver » SDIO

Data Structures

struct | sdio_command_struct_type
sdio command structure More...
struct | sdio_data_struct_type
sdio data structure More...
struct | sdio_type
type define sdio register all More...

Enumerations

enum | sdio_power_state_type { SDIO_POWER_OFF = 0x00 , SDIO_POWER_ON = 0x03 }
sdio power state More...
enum | sdio_edge_phase_type { SDIO_CLOCK_EDGE_RISING = 0x00 , SDIO_CLOCK_EDGE_FALLING = 0x01 }
sdio edge phase More...
enum | sdio_bus_width_type { SDIO_BUS_WIDTH_D1 = 0x00 , SDIO_BUS_WIDTH_D4 = 0x01 , SDIO_BUS_WIDTH_D8 = 0x02 }
sdio bus width More...
enum | sdio_reponse_type { SDIO_RESPONSE_NO = 0x00 , SDIO_RESPONSE_SHORT = 0x01 , SDIO_RESPONSE_LONG = 0x03 }
sdio response type More...
enum | sdio_wait_type { SDIO_WAIT_FOR_NO = 0x00 , SDIO_WAIT_FOR_INT = 0x01 , SDIO_WAIT_FOR_PEND = 0x02 }
sdio wait type More...
enum | sdio_rsp_index_type { SDIO_RSP1_INDEX = 0x00 , SDIO_RSP2_INDEX = 0x01 , SDIO_RSP3_INDEX = 0x02 , SDIO_RSP4_INDEX = 0x03 }
sdio response register index More...
enum sdio_block_size_type {
SDIO_DATA_BLOCK_SIZE_1B = 0x00 , SDIO_DATA_BLOCK_SIZE_2B = 0x01 , SDIO_DATA_BLOCK_SIZE_4B = 0x02 , SDIO_DATA_BLOCK_SIZE_8B = 0x03 ,
SDIO_DATA_BLOCK_SIZE_16B = 0x04 , SDIO_DATA_BLOCK_SIZE_32B = 0x05 , SDIO_DATA_BLOCK_SIZE_64B = 0x06 , SDIO_DATA_BLOCK_SIZE_128B = 0x07 ,
SDIO_DATA_BLOCK_SIZE_256B = 0x08 , SDIO_DATA_BLOCK_SIZE_512B = 0x09 , SDIO_DATA_BLOCK_SIZE_1024B = 0x0A , SDIO_DATA_BLOCK_SIZE_2048B = 0x0B ,
SDIO_DATA_BLOCK_SIZE_4096B = 0x0C , SDIO_DATA_BLOCK_SIZE_8192B = 0x0D , SDIO_DATA_BLOCK_SIZE_16384B = 0x0E
}
sdio data block size More...
enum | sdio_transfer_mode_type { SDIO_DATA_BLOCK_TRANSFER = 0x00 , SDIO_DATA_STREAM_TRANSFER = 0x01 }
sdio data transfer mode More...
enum | sdio_transfer_direction_type { SDIO_DATA_TRANSFER_TO_CARD = 0x00 , SDIO_DATA_TRANSFER_TO_CONTROLLER = 0x01 }
sdio data transfer direction More...
enum | sdio_read_wait_mode_type { SDIO_READ_WAIT_CONTROLLED_BY_D2 = 0x00 , SDIO_READ_WAIT_CONTROLLED_BY_CK = 0x01 }
sdio read wait mode More...

Detailed Description

Enumeration Type Documentation

◆ sdio_block_size_type

enum sdio_block_size_type

sdio data block size

Enumerator
SDIO_DATA_BLOCK_SIZE_1B | data block size 1 byte
SDIO_DATA_BLOCK_SIZE_2B | data block size 2 bytes
SDIO_DATA_BLOCK_SIZE_4B | data block size 4 bytes
SDIO_DATA_BLOCK_SIZE_8B | data block size 8 bytes
SDIO_DATA_BLOCK_SIZE_16B | data block size 16 bytes
SDIO_DATA_BLOCK_SIZE_32B | data block size 32 bytes
SDIO_DATA_BLOCK_SIZE_64B | data block size 64 bytes
SDIO_DATA_BLOCK_SIZE_128B | data block size 128 bytes
SDIO_DATA_BLOCK_SIZE_256B | data block size 256 bytes
SDIO_DATA_BLOCK_SIZE_512B | data block size 512 bytes
SDIO_DATA_BLOCK_SIZE_1024B | data block size 1024 bytes
SDIO_DATA_BLOCK_SIZE_2048B | data block size 2048 bytes
SDIO_DATA_BLOCK_SIZE_4096B | data block size 4096 bytes
SDIO_DATA_BLOCK_SIZE_8192B | data block size 8192 bytes
SDIO_DATA_BLOCK_SIZE_16384B | data block size 16384 bytes

Definition at line 179 of file at32f413_sdio.h.

◆ sdio_bus_width_type

enum sdio_bus_width_type

sdio bus width

Enumerator
SDIO_BUS_WIDTH_D1 | sdio wide bus select 1-bit
SDIO_BUS_WIDTH_D4 | sdio wide bus select 4-bit
SDIO_BUS_WIDTH_D8 | sdio wide bus select 8-bit

Definition at line 138 of file at32f413_sdio.h.

◆ sdio_edge_phase_type

enum sdio_edge_phase_type

sdio edge phase

Enumerator
SDIO_CLOCK_EDGE_RISING | sdio bus clock generated on the rising edge of the master clock
SDIO_CLOCK_EDGE_FALLING | sdio bus clock generated on the falling edge of the master clock

Definition at line 129 of file at32f413_sdio.h.

◆ sdio_power_state_type

enum sdio_power_state_type

sdio power state

Enumerator
SDIO_POWER_OFF | power-off, clock to card is stopped
SDIO_POWER_ON | power-on, the card is clocked

Definition at line 120 of file at32f413_sdio.h.

◆ sdio_read_wait_mode_type

enum sdio_read_wait_mode_type

sdio read wait mode

Enumerator
SDIO_READ_WAIT_CONTROLLED_BY_D2 | the sdio read wait on data2 line
SDIO_READ_WAIT_CONTROLLED_BY_CK | the sdio read wait on clock line

Definition at line 219 of file at32f413_sdio.h.

◆ sdio_reponse_type

enum sdio_reponse_type

sdio response type

Enumerator
SDIO_RESPONSE_NO | no response
SDIO_RESPONSE_SHORT | short response
SDIO_RESPONSE_LONG | long response

Definition at line 148 of file at32f413_sdio.h.

◆ sdio_rsp_index_type

enum sdio_rsp_index_type

sdio response register index

Enumerator
SDIO_RSP1_INDEX | response index 1, corresponding to sdio_rsp register 1
SDIO_RSP2_INDEX | response index 2, corresponding to sdio_rsp register 2
SDIO_RSP3_INDEX | response index 3, corresponding to sdio_rsp register 3
SDIO_RSP4_INDEX | response index 4, corresponding to sdio_rsp register 4

Definition at line 168 of file at32f413_sdio.h.

◆ sdio_transfer_direction_type

enum sdio_transfer_direction_type

sdio data transfer direction

Enumerator
SDIO_DATA_TRANSFER_TO_CARD | the sdio controller write
SDIO_DATA_TRANSFER_TO_CONTROLLER | the sdio controller read

Definition at line 210 of file at32f413_sdio.h.

◆ sdio_transfer_mode_type

enum sdio_transfer_mode_type

sdio data transfer mode

Enumerator
SDIO_DATA_BLOCK_TRANSFER | the sdio block transfer mode
SDIO_DATA_STREAM_TRANSFER | the sdio stream transfer mode

Definition at line 201 of file at32f413_sdio.h.

◆ sdio_wait_type

enum sdio_wait_type

sdio wait type

Enumerator
SDIO_WAIT_FOR_NO | no wait
SDIO_WAIT_FOR_INT | wait interrupt request
SDIO_WAIT_FOR_PEND | wait end of transfer

Definition at line 158 of file at32f413_sdio.h.


AT32F413 Firmwary Library: sdio_command_struct_type Struct Reference

Data Fields
sdio_command_struct_type Struct Reference
AT32F413_periph_driver » SDIO » SDIO_exported_types

sdio command structure More...

#include <at32f413_sdio.h>

Data Fields

uint32_t | argument
uint8_t | cmd_index
sdio_reponse_type rsp_type
sdio_wait_type wait_type

Detailed Description

sdio command structure

Definition at line 228 of file at32f413_sdio.h.

Field Documentation

◆ argument

uint32_t sdio_command_struct_type::argument

the sdio command argument is sent to a card as part of command message

Definition at line 230 of file at32f413_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

◆ cmd_index

uint8_t sdio_command_struct_type::cmd_index

the sdio command index

Definition at line 231 of file at32f413_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

◆ rsp_type

sdio_reponse_type sdio_command_struct_type::rsp_type

the sdio response type

Definition at line 232 of file at32f413_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

◆ wait_type

sdio_wait_type sdio_command_struct_type::wait_type

the sdio wait for interrupt request is enabled or disable

Definition at line 233 of file at32f413_sdio.h.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), sdio_command_config(), and sdio_command_data_send().

The documentation for this struct was generated from the following file:
  • at32f413_sdio.h


AT32F413 Firmwary Library: sdio_data_struct_type Struct Reference

Data Fields
sdio_data_struct_type Struct Reference
AT32F413_periph_driver » SDIO » SDIO_exported_types

sdio data structure More...

#include <at32f413_sdio.h>

Data Fields

uint32_t | timeout
uint32_t | data_length
sdio_block_size_type block_size
sdio_transfer_mode_type transfer_mode
sdio_transfer_direction_type transfer_direction

Detailed Description

sdio data structure

Definition at line 239 of file at32f413_sdio.h.

Field Documentation

◆ block_size

sdio_block_size_type sdio_data_struct_type::block_size

the sdio data block size of block transfer mode

Definition at line 243 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_data_config().

◆ data_length

uint32_t sdio_data_struct_type::data_length

the sdio data length

Definition at line 242 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), sdio_command_data_send(), and sdio_data_config().

◆ timeout

uint32_t sdio_data_struct_type::timeout

the sdio data timeout period in car bus clock periods

Definition at line 241 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_data_config().

◆ transfer_direction

sdio_transfer_direction_type sdio_data_struct_type::transfer_direction

the sdio data transfer direction

Definition at line 245 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), sdio_command_data_send(), and sdio_data_config().

◆ transfer_mode

sdio_transfer_mode_type sdio_data_struct_type::transfer_mode

the sdio transfer mode, block or stream

Definition at line 244 of file at32f413_sdio.h.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_data_config().

The documentation for this struct was generated from the following file:
  • at32f413_sdio.h


AT32F413 Firmwary Library: sdio_type Struct Reference

Data Fields
sdio_type Struct Reference
AT32F413_periph_driver » SDIO » SDIO_exported_types

type define sdio register all More...

#include <at32f413_sdio.h>

Data Fields

union {
__IO uint32_t pwrctrl
struct {
__IO uint32_t ps: 2
__IO uint32_t reserved1: 30
} pwrctrl_bit
};
sdio pwrctrl register, offset:0x00 More...
union {
__IO uint32_t clkctrl
struct {
__IO uint32_t clkdiv_l: 8
__IO uint32_t clkoen: 1
__IO uint32_t pwrsven: 1
__IO uint32_t bypsen: 1
__IO uint32_t busws: 2
__IO uint32_t clkegs: 1
__IO uint32_t hfcen: 1
__IO uint32_t clkdiv_h: 2
__IO uint32_t reserved1: 15
} clkctrl_bit
};
sdio clkctrl register, offset:0x04 More...
union {
__IO uint32_t argu
struct {
__IO uint32_t argu: 32
} argu_bit
};
sdio argu register, offset:0x08 More...
union {
__IO uint32_t cmdctrl
struct {
__IO uint32_t cmdidx: 6
__IO uint32_t rspwt: 2
__IO uint32_t intwt: 1
__IO uint32_t pndwt: 1
__IO uint32_t ccsmen: 1
__IO uint32_t iosusp: 1
__IO uint32_t reserved1: 20
} cmdctrl_bit
};
sdio cmdctrl register, offset:0x0C More...
union {
__IO uint32_t rspcmd
struct {
__IO uint32_t rspcmd: 6
__IO uint32_t reserved1: 26
} rspcmd_bit
};
sdio rspcmd register, offset:0x10 More...
union {
__IO uint32_t rsp1
struct {
__IO uint32_t cardsts1: 32
} rsp1_bit
};
sdio rsp1 register, offset:0x14 More...
union {
__IO uint32_t rsp2
struct {
__IO uint32_t cardsts2: 32
} rsp2_bit
};
sdio rsp2 register, offset:0x18 More...
union {
__IO uint32_t rsp3
struct {
__IO uint32_t cardsts3: 32
} rsp3_bit
};
sdio rsp3 register, offset:0x1C More...
union {
__IO uint32_t rsp4
struct {
__IO uint32_t cardsts4: 32
} rsp4_bit
};
sdio rsp4 register, offset:0x20 More...
union {
__IO uint32_t dttmr
struct {
__IO uint32_t timeout: 32
} dttmr_bit
};
sdio dttmr register, offset:0x24 More...
union {
__IO uint32_t dtlen
struct {
__IO uint32_t dtlen: 25
__IO uint32_t reserved1: 7
} dtlen_bit
};
sdio dtlen register, offset:0x28 More...
union {
__IO uint32_t dtctrl
struct {
__IO uint32_t tfren: 1
__IO uint32_t tfrdir: 1
__IO uint32_t tfrmode: 1
__IO uint32_t dmaen: 1
__IO uint32_t blksize: 4
__IO uint32_t rdwtstart: 1
__IO uint32_t rdwtstop: 1
__IO uint32_t rdwtmode: 1
__IO uint32_t ioen: 1
__IO uint32_t reserved1: 20
} dtctrl_bit
};
sdio dtctrl register, offset:0x2C More...
union {
__IO uint32_t dtcnt
struct {
__IO uint32_t cnt: 25
__IO uint32_t reserved1: 7
} dtcnt_bit
};
sdio dtcnt register, offset:0x30 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t cmdfail: 1
__IO uint32_t dtfail: 1
__IO uint32_t cmdtimeout: 1
__IO uint32_t dttimeout: 1
__IO uint32_t txerru: 1
__IO uint32_t rxerro: 1
__IO uint32_t cmdrspcmpl: 1
__IO uint32_t cmdcmpl: 1
__IO uint32_t dtcmpl: 1
__IO uint32_t sbiterr: 1
__IO uint32_t dtblkcmpl: 1
__IO uint32_t docmd: 1
__IO uint32_t dotx: 1
__IO uint32_t dorx: 1
__IO uint32_t txbufh: 1
__IO uint32_t rxbufh: 1
__IO uint32_t txbuff: 1
__IO uint32_t rxbuff: 1
__IO uint32_t txbufe: 1
__IO uint32_t rxbufe: 1
__IO uint32_t txbuf: 1
__IO uint32_t rxbuf: 1
__IO uint32_t ioif: 1
__IO uint32_t reserved1: 9
} sts_bit
};
sdio sts register, offset:0x34 More...
union {
__IO uint32_t intclr
struct {
__IO uint32_t cmdfail: 1
__IO uint32_t dtfail: 1
__IO uint32_t cmdtimeout: 1
__IO uint32_t dttimeout: 1
__IO uint32_t txerru: 1
__IO uint32_t rxerro: 1
__IO uint32_t cmdrspcmpl: 1
__IO uint32_t cmdcmpl: 1
__IO uint32_t dtcmpl: 1
__IO uint32_t sbiterr: 1
__IO uint32_t dtblkcmpl: 1
__IO uint32_t reserved1: 11
__IO uint32_t ioif: 1
__IO uint32_t reserved2: 9
} intclr_bit
};
sdio intclr register, offset:0x38 More...
union {
__IO uint32_t inten
struct {
__IO uint32_t cmdfailien: 1
__IO uint32_t dtfailien: 1
__IO uint32_t cmdtimeoutien: 1
__IO uint32_t dttimeoutien: 1
__IO uint32_t txerruien: 1
__IO uint32_t rxerroien: 1
__IO uint32_t cmdrspcmplien: 1
__IO uint32_t cmdcmplien: 1
__IO uint32_t dtcmplien: 1
__IO uint32_t sbiterrien: 1
__IO uint32_t dtblkcmplien: 1
__IO uint32_t docmdien: 1
__IO uint32_t dotxien: 1
__IO uint32_t dorxien: 1
__IO uint32_t txbufhien: 1
__IO uint32_t rxbufhien: 1
__IO uint32_t txbuffien: 1
__IO uint32_t rxbuffien: 1
__IO uint32_t txbufeien: 1
__IO uint32_t rxbufeien: 1
__IO uint32_t txbufien: 1
__IO uint32_t rxbufien: 1
__IO uint32_t ioifien: 1
__IO uint32_t reserved1: 9
} inten_bit
};
sdio inten register, offset:0x3C More...
union {
__IO uint32_t bufcnt
struct {
__IO uint32_t cnt: 24
__IO uint32_t reserved1: 8
} bufcnt_bit
};
sdio bufcnt register, offset:0x48 More...
union {
__IO uint32_t buf
struct {
__IO uint32_t dt: 32
} buf_bit
};
sdio buf register, offset:0x80 More...

Detailed Description

type define sdio register all

Definition at line 251 of file at32f413_sdio.h.

Field Documentation

◆

union { ... } sdio_type::@568

sdio pwrctrl register, offset:0x00

◆

union { ... } sdio_type::@570

sdio clkctrl register, offset:0x04

◆

union { ... } sdio_type::@572

sdio argu register, offset:0x08

◆

union { ... } sdio_type::@574

sdio cmdctrl register, offset:0x0C

◆

union { ... } sdio_type::@576

sdio rspcmd register, offset:0x10

◆

union { ... } sdio_type::@578

sdio rsp1 register, offset:0x14

◆

union { ... } sdio_type::@580

sdio rsp2 register, offset:0x18

◆

union { ... } sdio_type::@582

sdio rsp3 register, offset:0x1C

◆

union { ... } sdio_type::@584

sdio rsp4 register, offset:0x20

◆

union { ... } sdio_type::@586

sdio dttmr register, offset:0x24

◆

union { ... } sdio_type::@588

sdio dtlen register, offset:0x28

◆

union { ... } sdio_type::@590

sdio dtctrl register, offset:0x2C

◆

union { ... } sdio_type::@592

sdio dtcnt register, offset:0x30

◆

union { ... } sdio_type::@594

sdio sts register, offset:0x34

◆

union { ... } sdio_type::@596

sdio intclr register, offset:0x38

◆

union { ... } sdio_type::@598

sdio inten register, offset:0x3C

◆

union { ... } sdio_type::@600

sdio bufcnt register, offset:0x48

◆

union { ... } sdio_type::@602

sdio buf register, offset:0x80

◆ argu

__IO uint32_t sdio_type::argu

Definition at line 291 of file at32f413_sdio.h.

Referenced by sdio_command_config(), and sdio_reset().

◆

struct { ... } sdio_type::argu_bit

◆ blksize

__IO uint32_t sdio_type::blksize

Definition at line 414 of file at32f413_sdio.h.

Referenced by sdio_data_config().

◆ buf

__IO uint32_t sdio_type::buf

Definition at line 559 of file at32f413_sdio.h.

Referenced by sdio_data_read(), and sdio_data_write().

◆

struct { ... } sdio_type::buf_bit

◆ bufcnt

__IO uint32_t sdio_type::bufcnt

Definition at line 541 of file at32f413_sdio.h.

Referenced by sdio_buffer_counter_get().

◆

struct { ... } sdio_type::bufcnt_bit

◆ busws

__IO uint32_t sdio_type::busws

Definition at line 278 of file at32f413_sdio.h.

Referenced by sdio_bus_width_config().

◆ bypsen

__IO uint32_t sdio_type::bypsen

Definition at line 277 of file at32f413_sdio.h.

Referenced by sdio_clock_bypass().

◆ cardsts1

__IO uint32_t sdio_type::cardsts1

Definition at line 337 of file at32f413_sdio.h.

◆ cardsts2

__IO uint32_t sdio_type::cardsts2

Definition at line 349 of file at32f413_sdio.h.

◆ cardsts3

__IO uint32_t sdio_type::cardsts3

Definition at line 361 of file at32f413_sdio.h.

◆ cardsts4

__IO uint32_t sdio_type::cardsts4

Definition at line 373 of file at32f413_sdio.h.

◆ ccsmen

__IO uint32_t sdio_type::ccsmen

Definition at line 310 of file at32f413_sdio.h.

Referenced by sdio_command_config(), and sdio_command_state_machine_enable().

◆ clkctrl

__IO uint32_t sdio_type::clkctrl

Definition at line 271 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::clkctrl_bit

Referenced by sdio_bus_width_config(), sdio_clock_bypass(), sdio_clock_config(), sdio_clock_enable(), sdio_flow_control_enable(), and sdio_power_saving_mode_enable().

◆ clkdiv_h

__IO uint32_t sdio_type::clkdiv_h

Definition at line 281 of file at32f413_sdio.h.

Referenced by sdio_clock_config().

◆ clkdiv_l

__IO uint32_t sdio_type::clkdiv_l

Definition at line 274 of file at32f413_sdio.h.

Referenced by sdio_clock_config().

◆ clkegs

__IO uint32_t sdio_type::clkegs

Definition at line 279 of file at32f413_sdio.h.

Referenced by sdio_clock_config().

◆ clkoen

__IO uint32_t sdio_type::clkoen

Definition at line 275 of file at32f413_sdio.h.

Referenced by sdio_clock_enable().

◆ cmdcmpl

__IO uint32_t sdio_type::cmdcmpl

Definition at line 451 of file at32f413_sdio.h.

◆ cmdcmplien

__IO uint32_t sdio_type::cmdcmplien

Definition at line 511 of file at32f413_sdio.h.

◆ cmdctrl

__IO uint32_t sdio_type::cmdctrl

Definition at line 303 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::cmdctrl_bit

Referenced by sdio_command_config(), sdio_command_state_machine_enable(), and sdio_io_suspend_command_set().

◆ cmdfail

__IO uint32_t sdio_type::cmdfail

Definition at line 444 of file at32f413_sdio.h.

◆ cmdfailien

__IO uint32_t sdio_type::cmdfailien

Definition at line 504 of file at32f413_sdio.h.

◆ cmdidx

__IO uint32_t sdio_type::cmdidx

Definition at line 306 of file at32f413_sdio.h.

Referenced by sdio_command_config().

◆ cmdrspcmpl

__IO uint32_t sdio_type::cmdrspcmpl

Definition at line 450 of file at32f413_sdio.h.

◆ cmdrspcmplien

__IO uint32_t sdio_type::cmdrspcmplien

Definition at line 510 of file at32f413_sdio.h.

◆ cmdtimeout

__IO uint32_t sdio_type::cmdtimeout

Definition at line 446 of file at32f413_sdio.h.

◆ cmdtimeoutien

__IO uint32_t sdio_type::cmdtimeoutien

Definition at line 506 of file at32f413_sdio.h.

◆ cnt

__IO uint32_t sdio_type::cnt

Definition at line 431 of file at32f413_sdio.h.

◆ dmaen

__IO uint32_t sdio_type::dmaen

Definition at line 413 of file at32f413_sdio.h.

Referenced by sdio_dma_enable().

◆ docmd

__IO uint32_t sdio_type::docmd

Definition at line 455 of file at32f413_sdio.h.

◆ docmdien

__IO uint32_t sdio_type::docmdien

Definition at line 515 of file at32f413_sdio.h.

◆ dorx

__IO uint32_t sdio_type::dorx

Definition at line 457 of file at32f413_sdio.h.

◆ dorxien

__IO uint32_t sdio_type::dorxien

Definition at line 517 of file at32f413_sdio.h.

◆ dotx

__IO uint32_t sdio_type::dotx

Definition at line 456 of file at32f413_sdio.h.

◆ dotxien

__IO uint32_t sdio_type::dotxien

Definition at line 516 of file at32f413_sdio.h.

◆ dt

__IO uint32_t sdio_type::dt

Definition at line 562 of file at32f413_sdio.h.

◆ dtblkcmpl

__IO uint32_t sdio_type::dtblkcmpl

Definition at line 454 of file at32f413_sdio.h.

◆ dtblkcmplien

__IO uint32_t sdio_type::dtblkcmplien

Definition at line 514 of file at32f413_sdio.h.

◆ dtcmpl

__IO uint32_t sdio_type::dtcmpl

Definition at line 452 of file at32f413_sdio.h.

◆ dtcmplien

__IO uint32_t sdio_type::dtcmplien

Definition at line 512 of file at32f413_sdio.h.

◆ dtcnt

__IO uint32_t sdio_type::dtcnt

Definition at line 428 of file at32f413_sdio.h.

Referenced by sdio_data_counter_get().

◆

struct { ... } sdio_type::dtcnt_bit

◆ dtctrl

__IO uint32_t sdio_type::dtctrl

Definition at line 407 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::dtctrl_bit

Referenced by sdio_data_config(), sdio_data_state_machine_enable(), sdio_dma_enable(), sdio_io_function_enable(), sdio_read_wait_mode_set(), sdio_read_wait_start(), and sdio_read_wait_stop().

◆ dtfail

__IO uint32_t sdio_type::dtfail

Definition at line 445 of file at32f413_sdio.h.

◆ dtfailien

__IO uint32_t sdio_type::dtfailien

Definition at line 505 of file at32f413_sdio.h.

◆ dtlen

__IO uint32_t sdio_type::dtlen

Definition at line 394 of file at32f413_sdio.h.

Referenced by sdio_data_config(), and sdio_reset().

◆

struct { ... } sdio_type::dtlen_bit

Referenced by sdio_data_config().

◆ dttimeout

__IO uint32_t sdio_type::dttimeout

Definition at line 447 of file at32f413_sdio.h.

◆ dttimeoutien

__IO uint32_t sdio_type::dttimeoutien

Definition at line 507 of file at32f413_sdio.h.

◆ dttmr

__IO uint32_t sdio_type::dttmr

Definition at line 382 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::dttmr_bit

Referenced by sdio_data_config().

◆ hfcen

__IO uint32_t sdio_type::hfcen

Definition at line 280 of file at32f413_sdio.h.

Referenced by sdio_flow_control_enable().

◆ intclr

__IO uint32_t sdio_type::intclr

Definition at line 476 of file at32f413_sdio.h.

Referenced by sdio_flag_clear(), and sdio_reset().

◆

struct { ... } sdio_type::intclr_bit

◆ inten

__IO uint32_t sdio_type::inten

Definition at line 501 of file at32f413_sdio.h.

Referenced by sdio_interrupt_enable(), and sdio_reset().

◆

struct { ... } sdio_type::inten_bit

◆ intwt

__IO uint32_t sdio_type::intwt

Definition at line 308 of file at32f413_sdio.h.

Referenced by sdio_command_config().

◆ ioen

__IO uint32_t sdio_type::ioen

Definition at line 418 of file at32f413_sdio.h.

Referenced by sdio_io_function_enable().

◆ ioif

__IO uint32_t sdio_type::ioif

Definition at line 466 of file at32f413_sdio.h.

◆ ioifien

__IO uint32_t sdio_type::ioifien

Definition at line 526 of file at32f413_sdio.h.

◆ iosusp

__IO uint32_t sdio_type::iosusp

Definition at line 311 of file at32f413_sdio.h.

Referenced by sdio_io_suspend_command_set().

◆ pndwt

__IO uint32_t sdio_type::pndwt

Definition at line 309 of file at32f413_sdio.h.

Referenced by sdio_command_config().

◆ ps

__IO uint32_t sdio_type::ps

Definition at line 261 of file at32f413_sdio.h.

Referenced by sdio_power_set(), and sdio_power_status_get().

◆ pwrctrl

__IO uint32_t sdio_type::pwrctrl

Definition at line 258 of file at32f413_sdio.h.

Referenced by sdio_reset().

◆

struct { ... } sdio_type::pwrctrl_bit

Referenced by sdio_power_set(), and sdio_power_status_get().

◆ pwrsven

__IO uint32_t sdio_type::pwrsven

Definition at line 276 of file at32f413_sdio.h.

Referenced by sdio_power_saving_mode_enable().

◆ rdwtmode

__IO uint32_t sdio_type::rdwtmode

Definition at line 417 of file at32f413_sdio.h.

Referenced by sdio_read_wait_mode_set().

◆ rdwtstart

__IO uint32_t sdio_type::rdwtstart

Definition at line 415 of file at32f413_sdio.h.

Referenced by sdio_read_wait_start().

◆ rdwtstop

__IO uint32_t sdio_type::rdwtstop

Definition at line 416 of file at32f413_sdio.h.

Referenced by sdio_read_wait_stop().

◆ reserved1

__IO uint32_t sdio_type::reserved1

sdio reserved1 register, offset:0x40~0x44

Definition at line 262 of file at32f413_sdio.h.

◆ reserved2

__IO uint32_t sdio_type::reserved2

sdio reserved2 register, offset:0x4C~0x7C

Definition at line 492 of file at32f413_sdio.h.

◆ rsp1

__IO uint32_t sdio_type::rsp1

Definition at line 334 of file at32f413_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp1_bit

◆ rsp2

__IO uint32_t sdio_type::rsp2

Definition at line 346 of file at32f413_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp2_bit

◆ rsp3

__IO uint32_t sdio_type::rsp3

Definition at line 358 of file at32f413_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp3_bit

◆ rsp4

__IO uint32_t sdio_type::rsp4

Definition at line 370 of file at32f413_sdio.h.

Referenced by sdio_response_get().

◆

struct { ... } sdio_type::rsp4_bit

◆ rspcmd

__IO uint32_t sdio_type::rspcmd

Definition at line 321 of file at32f413_sdio.h.

Referenced by sdio_command_response_get().

◆

struct { ... } sdio_type::rspcmd_bit

Referenced by sdio_command_response_get().

◆ rspwt

__IO uint32_t sdio_type::rspwt

Definition at line 307 of file at32f413_sdio.h.

Referenced by sdio_command_config().

◆ rxbuf

__IO uint32_t sdio_type::rxbuf

Definition at line 465 of file at32f413_sdio.h.

◆ rxbufe

__IO uint32_t sdio_type::rxbufe

Definition at line 463 of file at32f413_sdio.h.

◆ rxbufeien

__IO uint32_t sdio_type::rxbufeien

Definition at line 523 of file at32f413_sdio.h.

◆ rxbuff

__IO uint32_t sdio_type::rxbuff

Definition at line 461 of file at32f413_sdio.h.

◆ rxbuffien

__IO uint32_t sdio_type::rxbuffien

Definition at line 521 of file at32f413_sdio.h.

◆ rxbufh

__IO uint32_t sdio_type::rxbufh

Definition at line 459 of file at32f413_sdio.h.

◆ rxbufhien

__IO uint32_t sdio_type::rxbufhien

Definition at line 519 of file at32f413_sdio.h.

◆ rxbufien

__IO uint32_t sdio_type::rxbufien

Definition at line 525 of file at32f413_sdio.h.

◆ rxerro

__IO uint32_t sdio_type::rxerro

Definition at line 449 of file at32f413_sdio.h.

◆ rxerroien

__IO uint32_t sdio_type::rxerroien

Definition at line 509 of file at32f413_sdio.h.

◆ sbiterr

__IO uint32_t sdio_type::sbiterr

Definition at line 453 of file at32f413_sdio.h.

◆ sbiterrien

__IO uint32_t sdio_type::sbiterrien

Definition at line 513 of file at32f413_sdio.h.

◆ sts

__IO uint32_t sdio_type::sts

Definition at line 441 of file at32f413_sdio.h.

Referenced by sdio_flag_get().

◆

struct { ... } sdio_type::sts_bit

◆ tfrdir

__IO uint32_t sdio_type::tfrdir

Definition at line 411 of file at32f413_sdio.h.

Referenced by sdio_data_config().

◆ tfren

__IO uint32_t sdio_type::tfren

Definition at line 410 of file at32f413_sdio.h.

Referenced by sdio_data_config(), and sdio_data_state_machine_enable().

◆ tfrmode

__IO uint32_t sdio_type::tfrmode

Definition at line 412 of file at32f413_sdio.h.

Referenced by sdio_data_config().

◆ timeout

__IO uint32_t sdio_type::timeout

Definition at line 385 of file at32f413_sdio.h.

Referenced by sdio_data_config().

◆ txbuf

__IO uint32_t sdio_type::txbuf

Definition at line 464 of file at32f413_sdio.h.

◆ txbufe

__IO uint32_t sdio_type::txbufe

Definition at line 462 of file at32f413_sdio.h.

◆ txbufeien

__IO uint32_t sdio_type::txbufeien

Definition at line 522 of file at32f413_sdio.h.

◆ txbuff

__IO uint32_t sdio_type::txbuff

Definition at line 460 of file at32f413_sdio.h.

◆ txbuffien

__IO uint32_t sdio_type::txbuffien

Definition at line 520 of file at32f413_sdio.h.

◆ txbufh

__IO uint32_t sdio_type::txbufh

Definition at line 458 of file at32f413_sdio.h.

◆ txbufhien

__IO uint32_t sdio_type::txbufhien

Definition at line 518 of file at32f413_sdio.h.

◆ txbufien

__IO uint32_t sdio_type::txbufien

Definition at line 524 of file at32f413_sdio.h.

◆ txerru

__IO uint32_t sdio_type::txerru

Definition at line 448 of file at32f413_sdio.h.

◆ txerruien

__IO uint32_t sdio_type::txerruien

Definition at line 508 of file at32f413_sdio.h.

The documentation for this struct was generated from the following file:
  • at32f413_sdio.h


AT32F413 Firmwary Library: SDIO_exported_functions

Functions
SDIO_exported_functions
AT32F413_periph_driver » SDIO

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
flag_status | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

Function Documentation

◆ sdio_buffer_counter_get()

uint32_t sdio_buffer_counter_get ( sdio_type * sdio_x )

get the number of words left to be written to or read from fifo..

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t number of words

Definition at line 488 of file at32f413_sdio.c.

◆ sdio_bus_width_config()

void sdio_bus_width_config | ( | sdio_type * | sdio_x,
 |  | sdio_bus_width_type | width
 | ) |  |

config sdio bus width

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
width this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D1
  • SDIO_BUS_WIDTH_D4
  • SDIO_BUS_WIDTH_D8
Return values
none

Definition at line 139 of file at32f413_sdio.c.

Referenced by sd_power_on(), and sd_wide_bus_operation_config().

◆ sdio_clock_bypass()

void sdio_clock_bypass | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock divider bypss

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 152 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_config()

void sdio_clock_config | ( | sdio_type * | sdio_x,
 |  | uint16_t | clk_div,
 |  | sdio_edge_phase_type | clk_edg
 | ) |  |

config sdio clock

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
clk_div | sdio clock divide factor(frequency = sdio_clk / [clk_psc + 2]).
clk_edg this parameter can be one of the following values:
  • SDIO_CLOCK_EDGE_RISING
  • SDIO_CLOCK_EDGE_FALLING
Return values
none

Definition at line 115 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_enable()

void sdio_clock_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sdio_ck output.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 192 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_command_config()

void sdio_command_config | ( | sdio_type * | sdio_x,
 |  | sdio_command_struct_type * | command_struct
 | ) |  |

config sdio command.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
command_struct | : pointer to a sdio_command_struct_type structure that contains the configuration information for the sdio command.
Return values
none

Definition at line 340 of file at32f413_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_command_response_get()

uint8_t sdio_command_response_get ( sdio_type * sdio_x )

get command index of last command for which response received.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
uint8_t command index

Definition at line 376 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp4_error(), command_rsp5_error(), and command_rsp6_error().

◆ sdio_command_state_machine_enable()

void sdio_command_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable command path state machine(CPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 363 of file at32f413_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_data_config()

void sdio_data_config | ( | sdio_type * | sdio_x,
 |  | sdio_data_struct_type * | data_struct
 | ) |  |

config sdio data.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
data_struct | : pointer to a sdio_data_struct_type structure that contains the configuration information for the sdio data.
Return values
none

Definition at line 427 of file at32f413_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_counter_get()

uint32_t sdio_data_counter_get ( sdio_type * sdio_x )

get the number of remaining data bytes to be transferred.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t number of bytes

Definition at line 464 of file at32f413_sdio.c.

◆ sdio_data_read()

uint32_t sdio_data_read ( sdio_type * sdio_x )

read a word data from sdio fifo.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t data received

Definition at line 476 of file at32f413_sdio.c.

Referenced by scr_find(), and sdio_command_data_send().

◆ sdio_data_state_machine_enable()

void sdio_data_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable data path state machine(DPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 452 of file at32f413_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_write()

void sdio_data_write | ( | sdio_type * | sdio_x,
 |  | uint32_t | data
 | ) |  |

write one word data to fifo.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
data | data to be transferred.
Return values
none

Definition at line 501 of file at32f413_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_dma_enable()

void sdio_dma_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 205 of file at32f413_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_flag_clear()

void sdio_flag_clear | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

clear sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
int_opt this parameter can be any combination of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_SDIOIF_FLAG
Return values
none

Definition at line 326 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), command_rsp7_error(), mmc_stream_write(), scr_find(), sd_block_write(), sd_irq_service(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_flag_get()

flag_status sdio_flag_get | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

get sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
flag this parameter can be one of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_DOCMD_FLAG
  • SDIO_DOTX_FLAG
  • SDIO_DORX_FLAG
  • SDIO_TXBUFH_FLAG
  • SDIO_RXBUFH_FLAG
  • SDIO_TXBUFF_FLAG
  • SDIO_RXBUFF_FLAG
  • SDIO_TXBUFE_FLAG
  • SDIO_RXBUFE_FLAG
  • SDIO_TXBUF_FLAG
  • SDIO_RXBUF_FLAG
  • SDIO_SDIOIF_FLAG
Return values
flag_status (SET or RESET)

Definition at line 289 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), scr_find(), sd_irq_service(), and sdio_command_data_send().

◆ sdio_flow_control_enable()

void sdio_flow_control_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable hardware flow control.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 179 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_interrupt_enable()

void sdio_interrupt_enable | ( | sdio_type * | sdio_x,
 |  | uint32_t | int_opt,
 |  | confirm_state | new_state
 | ) |  |

config corresponding interrupt.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
int_opt this parameter can be one of the following values:
  • SDIO_CMDFAIL_INT
  • SDIO_DTFAIL_INT
  • SDIO_CMDTIMEOUT_INT
  • SDIO_DTTIMEOUT_INT
  • SDIO_TXERRU_INT
  • SDIO_RXERRO_INT
  • SDIO_CMDRSPCMPL_INT
  • SDIO_CMDCMPL_INT
  • SDIO_DTCMP_INT
  • SDIO_SBITERR_INT
  • SDIO_DTBLKCMPL_INT
  • SDIO_DOCMD_INT
  • SDIO_DOTX_INT
  • SDIO_DORX_INT
  • SDIO_TXBUFH_INT
  • SDIO_RXBUFH_INT
  • SDIO_TXBUFF_INT
  • SDIO_RXBUFF_INT
  • SDIO_TXBUFE_INT
  • SDIO_RXBUFE_INT
  • SDIO_TXBUF_INT
  • SDIO_RXBUF_INT
  • SDIO_SDIOIF_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 243 of file at32f413_sdio.c.

Referenced by sd_irq_service().

◆ sdio_io_function_enable()

void sdio_io_function_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the sd i/o function.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 556 of file at32f413_sdio.c.

◆ sdio_io_suspend_command_set()

void sdio_io_suspend_command_set | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sd i/o suspend command sending.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 569 of file at32f413_sdio.c.

◆ sdio_power_saving_mode_enable()

void sdio_power_saving_mode_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable power saving mode, config sdio_ck clock output when the bus is idle.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 166 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_power_set()

void sdio_power_set | ( | sdio_type * | sdio_x,
 |  | sdio_power_state_type | power_state
 | ) |  |

set the power status of the controller

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
power_state this parameter can be one of the following values:
  • SDIO_POWER_OFF
  • SDIO_POWER_ON
Return values
none

Definition at line 75 of file at32f413_sdio.c.

Referenced by sd_power_off(), and sd_power_on().

◆ sdio_power_status_get()

flag_status sdio_power_status_get ( sdio_type * sdio_x )

get power status.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
flag_status (SET or RESET)

Definition at line 87 of file at32f413_sdio.c.

Referenced by sd_card_init().

◆ sdio_read_wait_mode_set()

void sdio_read_wait_mode_set | ( | sdio_type * | sdio_x,
 |  | sdio_read_wait_mode_type | mode
 | ) |  |

set the read wait mode.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
mode this parameter can be one of the following values:
  • SDIO_READ_WAIT_CONTROLLED_BY_D2
  • SDIO_READ_WAIT_CONTROLLED_BY_CK
Return values
none

Definition at line 517 of file at32f413_sdio.c.

◆ sdio_read_wait_start()

void sdio_read_wait_start | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to start sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 530 of file at32f413_sdio.c.

◆ sdio_read_wait_stop()

void sdio_read_wait_stop | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to stop sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 543 of file at32f413_sdio.c.

◆ sdio_reset()

void sdio_reset ( sdio_type * sdio_x )

reset the sdio register

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
none

Definition at line 51 of file at32f413_sdio.c.

Referenced by sd_init().

◆ sdio_response_get()

uint32_t sdio_response_get | ( | sdio_type * | sdio_x,
 |  | sdio_rsp_index_type | reg_index
 | ) |  |

get response received from the card for the last command.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
reg_index this parameter can be one of the following values:
  • SDIO_RSP1_INDEX
  • SDIO_RSP2_INDEX
  • SDIO_RSP3_INDEX
  • SDIO_RSP4_INDEX
Return values
uint32_t response register value

Definition at line 394 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp5_error(), command_rsp6_error(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), and sd_status_send().


AT32F413 Firmwary Library: SDIO_private_functions

Functions
SDIO_private_functions
AT32F413_periph_driver » SDIO

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
flag_status | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

Function Documentation

◆ sdio_buffer_counter_get()

uint32_t sdio_buffer_counter_get ( sdio_type * sdio_x )

get the number of words left to be written to or read from fifo..

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t number of words

Definition at line 488 of file at32f413_sdio.c.

◆ sdio_bus_width_config()

void sdio_bus_width_config | ( | sdio_type * | sdio_x,
 |  | sdio_bus_width_type | width
 | ) |  |

config sdio bus width

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
width this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D1
  • SDIO_BUS_WIDTH_D4
  • SDIO_BUS_WIDTH_D8
Return values
none

Definition at line 139 of file at32f413_sdio.c.

Referenced by sd_power_on(), and sd_wide_bus_operation_config().

◆ sdio_clock_bypass()

void sdio_clock_bypass | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable clock divider bypss

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 152 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_config()

void sdio_clock_config | ( | sdio_type * | sdio_x,
 |  | uint16_t | clk_div,
 |  | sdio_edge_phase_type | clk_edg
 | ) |  |

config sdio clock

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
clk_div | sdio clock divide factor(frequency = sdio_clk / [clk_psc + 2]).
clk_edg this parameter can be one of the following values:
  • SDIO_CLOCK_EDGE_RISING
  • SDIO_CLOCK_EDGE_FALLING
Return values
none

Definition at line 115 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_clock_enable()

void sdio_clock_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sdio_ck output.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 192 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_command_config()

void sdio_command_config | ( | sdio_type * | sdio_x,
 |  | sdio_command_struct_type * | command_struct
 | ) |  |

config sdio command.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
command_struct | : pointer to a sdio_command_struct_type structure that contains the configuration information for the sdio command.
Return values
none

Definition at line 340 of file at32f413_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_command_response_get()

uint8_t sdio_command_response_get ( sdio_type * sdio_x )

get command index of last command for which response received.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
uint8_t command index

Definition at line 376 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp4_error(), command_rsp5_error(), and command_rsp6_error().

◆ sdio_command_state_machine_enable()

void sdio_command_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable command path state machine(CPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 363 of file at32f413_sdio.c.

Referenced by check_card_programming(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ sdio_data_config()

void sdio_data_config | ( | sdio_type * | sdio_x,
 |  | sdio_data_struct_type * | data_struct
 | ) |  |

config sdio data.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
data_struct | : pointer to a sdio_data_struct_type structure that contains the configuration information for the sdio data.
Return values
none

Definition at line 427 of file at32f413_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_counter_get()

uint32_t sdio_data_counter_get ( sdio_type * sdio_x )

get the number of remaining data bytes to be transferred.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t number of bytes

Definition at line 464 of file at32f413_sdio.c.

◆ sdio_data_read()

uint32_t sdio_data_read ( sdio_type * sdio_x )

read a word data from sdio fifo.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
uint32_t data received

Definition at line 476 of file at32f413_sdio.c.

Referenced by scr_find(), and sdio_command_data_send().

◆ sdio_data_state_machine_enable()

void sdio_data_state_machine_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable data path state machine(DPSM).

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 452 of file at32f413_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_data_write()

void sdio_data_write | ( | sdio_type * | sdio_x,
 |  | uint32_t | data
 | ) |  |

write one word data to fifo.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
data | data to be transferred.
Return values
none

Definition at line 501 of file at32f413_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_dma_enable()

void sdio_dma_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable dma.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 205 of file at32f413_sdio.c.

Referenced by sdio_command_data_send().

◆ sdio_flag_clear()

void sdio_flag_clear | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

clear sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
int_opt this parameter can be any combination of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_SDIOIF_FLAG
Return values
none

Definition at line 326 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), command_rsp7_error(), mmc_stream_write(), scr_find(), sd_block_write(), sd_irq_service(), sd_mult_blocks_write(), and sdio_command_data_send().

◆ sdio_flag_get()

flag_status sdio_flag_get | ( | sdio_type * | sdio_x,
 |  | uint32_t | flag
 | ) |  |

get sdio flag.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
flag this parameter can be one of the following values:
  • SDIO_CMDFAIL_FLAG
  • SDIO_DTFAIL_FLAG
  • SDIO_CMDTIMEOUT_FLAG
  • SDIO_DTTIMEOUT_FLAG
  • SDIO_TXERRU_FLAG
  • SDIO_RXERRO_FLAG
  • SDIO_CMDRSPCMPL_FLAG
  • SDIO_CMDCMPL_FLAG
  • SDIO_DTCMPL_FLAG
  • SDIO_SBITERR_FLAG
  • SDIO_DTBLKCMPL_FLAG
  • SDIO_DOCMD_FLAG
  • SDIO_DOTX_FLAG
  • SDIO_DORX_FLAG
  • SDIO_TXBUFH_FLAG
  • SDIO_RXBUFH_FLAG
  • SDIO_TXBUFF_FLAG
  • SDIO_RXBUFF_FLAG
  • SDIO_TXBUFE_FLAG
  • SDIO_RXBUFE_FLAG
  • SDIO_TXBUF_FLAG
  • SDIO_RXBUF_FLAG
  • SDIO_SDIOIF_FLAG
Return values
flag_status (SET or RESET)

Definition at line 289 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_error(), command_rsp1_error(), command_rsp2_error(), command_rsp3_error(), command_rsp4_error(), command_rsp5_error(), command_rsp6_error(), scr_find(), sd_irq_service(), and sdio_command_data_send().

◆ sdio_flow_control_enable()

void sdio_flow_control_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable hardware flow control.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 179 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_interrupt_enable()

void sdio_interrupt_enable | ( | sdio_type * | sdio_x,
 |  | uint32_t | int_opt,
 |  | confirm_state | new_state
 | ) |  |

config corresponding interrupt.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
int_opt this parameter can be one of the following values:
  • SDIO_CMDFAIL_INT
  • SDIO_DTFAIL_INT
  • SDIO_CMDTIMEOUT_INT
  • SDIO_DTTIMEOUT_INT
  • SDIO_TXERRU_INT
  • SDIO_RXERRO_INT
  • SDIO_CMDRSPCMPL_INT
  • SDIO_CMDCMPL_INT
  • SDIO_DTCMP_INT
  • SDIO_SBITERR_INT
  • SDIO_DTBLKCMPL_INT
  • SDIO_DOCMD_INT
  • SDIO_DOTX_INT
  • SDIO_DORX_INT
  • SDIO_TXBUFH_INT
  • SDIO_RXBUFH_INT
  • SDIO_TXBUFF_INT
  • SDIO_RXBUFF_INT
  • SDIO_TXBUFE_INT
  • SDIO_RXBUFE_INT
  • SDIO_TXBUF_INT
  • SDIO_RXBUF_INT
  • SDIO_SDIOIF_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 243 of file at32f413_sdio.c.

Referenced by sd_irq_service().

◆ sdio_io_function_enable()

void sdio_io_function_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the sd i/o function.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 556 of file at32f413_sdio.c.

◆ sdio_io_suspend_command_set()

void sdio_io_suspend_command_set | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable sd i/o suspend command sending.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 569 of file at32f413_sdio.c.

◆ sdio_power_saving_mode_enable()

void sdio_power_saving_mode_enable | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable power saving mode, config sdio_ck clock output when the bus is idle.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 166 of file at32f413_sdio.c.

Referenced by sd_power_on().

◆ sdio_power_set()

void sdio_power_set | ( | sdio_type * | sdio_x,
 |  | sdio_power_state_type | power_state
 | ) |  |

set the power status of the controller

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
power_state this parameter can be one of the following values:
  • SDIO_POWER_OFF
  • SDIO_POWER_ON
Return values
none

Definition at line 75 of file at32f413_sdio.c.

Referenced by sd_power_off(), and sd_power_on().

◆ sdio_power_status_get()

flag_status sdio_power_status_get ( sdio_type * sdio_x )

get power status.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
flag_status (SET or RESET)

Definition at line 87 of file at32f413_sdio.c.

Referenced by sd_card_init().

◆ sdio_read_wait_mode_set()

void sdio_read_wait_mode_set | ( | sdio_type * | sdio_x,
 |  | sdio_read_wait_mode_type | mode
 | ) |  |

set the read wait mode.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
mode this parameter can be one of the following values:
  • SDIO_READ_WAIT_CONTROLLED_BY_D2
  • SDIO_READ_WAIT_CONTROLLED_BY_CK
Return values
none

Definition at line 517 of file at32f413_sdio.c.

◆ sdio_read_wait_start()

void sdio_read_wait_start | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to start sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 530 of file at32f413_sdio.c.

◆ sdio_read_wait_stop()

void sdio_read_wait_stop | ( | sdio_type * | sdio_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable to stop sd i/o read wait operation.

Parameters
sdio_x | to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
new_state | (TRUE or FALSE)
Return values
none

Definition at line 543 of file at32f413_sdio.c.

◆ sdio_reset()

void sdio_reset ( sdio_type * sdio_x )

reset the sdio register

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
Return values
none

Definition at line 51 of file at32f413_sdio.c.

Referenced by sd_init().

◆ sdio_response_get()

uint32_t sdio_response_get | ( | sdio_type * | sdio_x,
 |  | sdio_rsp_index_type | reg_index
 | ) |  |

get response received from the card for the last command.

Parameters
sdio_x to select the sdio peripheral. this parameter can be one of the following values: SDIO1.
reg_index this parameter can be one of the following values:
  • SDIO_RSP1_INDEX
  • SDIO_RSP2_INDEX
  • SDIO_RSP3_INDEX
  • SDIO_RSP4_INDEX
Return values
uint32_t response register value

Definition at line 394 of file at32f413_sdio.c.

Referenced by check_card_programming(), command_rsp1_error(), command_rsp5_error(), command_rsp6_error(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), and sd_status_send().


AT32F413 Firmwary Library: SPI

Modules | Macros
SPI
AT32F413_periph_driver

SPI driver modules. More...

Modules

SPI_I2S_flags_definition
spi i2s flag
SPI_I2S_interrupts_definition
spi i2s interrupt
SPI_exported_types
SPI_exported_functions
SPI_private_functions

Macros

#define | SPI1 ((spi_type *) SPI1_BASE)
#define | SPI2 ((spi_type *) SPI2_BASE)

Detailed Description

SPI driver modules.

Macro Definition Documentation

◆ SPI1

#define SPI1 ((spi_type *) SPI1_BASE)

Definition at line 448 of file at32f413_spi.h.

◆ SPI2

#define SPI2 ((spi_type *) SPI2_BASE)

Definition at line 449 of file at32f413_spi.h.


AT32F413 Firmwary Library: SPI_I2S_flags_definition

Macros
SPI_I2S_flags_definition
AT32F413_periph_driver » SPI

spi i2s flag More...

Macros

#define | SPI_I2S_RDBF_FLAG 0x0001
#define | SPI_I2S_TDBE_FLAG 0x0002
#define | I2S_ACS_FLAG 0x0004
#define | I2S_TUERR_FLAG 0x0008
#define | SPI_CCERR_FLAG 0x0010
#define | SPI_MMERR_FLAG 0x0020
#define | SPI_I2S_ROERR_FLAG 0x0040
#define | SPI_I2S_BF_FLAG 0x0080

Detailed Description

spi i2s flag

Macro Definition Documentation

◆ I2S_ACS_FLAG

#define I2S_ACS_FLAG 0x0004

i2s audio channel state flag

Definition at line 55 of file at32f413_spi.h.

◆ I2S_TUERR_FLAG

#define I2S_TUERR_FLAG 0x0008

i2s transmitter underload error flag

Definition at line 56 of file at32f413_spi.h.

◆ SPI_CCERR_FLAG

#define SPI_CCERR_FLAG 0x0010

spi crc calculation error flag

Definition at line 57 of file at32f413_spi.h.

◆ SPI_I2S_BF_FLAG

#define SPI_I2S_BF_FLAG 0x0080

spi or i2s busy flag

Definition at line 60 of file at32f413_spi.h.

◆ SPI_I2S_RDBF_FLAG

#define SPI_I2S_RDBF_FLAG 0x0001

spi or i2s receive data buffer full flag

Definition at line 53 of file at32f413_spi.h.

◆ SPI_I2S_ROERR_FLAG

#define SPI_I2S_ROERR_FLAG 0x0040

spi or i2s receiver overflow error flag

Definition at line 59 of file at32f413_spi.h.

◆ SPI_I2S_TDBE_FLAG

#define SPI_I2S_TDBE_FLAG 0x0002

spi or i2s transmit data buffer empty flag

Definition at line 54 of file at32f413_spi.h.

◆ SPI_MMERR_FLAG

#define SPI_MMERR_FLAG 0x0020

spi master mode error flag

Definition at line 58 of file at32f413_spi.h.


AT32F413 Firmwary Library: SPI_I2S_interrupts_definition

Macros
SPI_I2S_interrupts_definition
AT32F413_periph_driver » SPI

spi i2s interrupt More...

Macros

#define | SPI_I2S_ERROR_INT 0x0020
#define | SPI_I2S_RDBF_INT 0x0040
#define | SPI_I2S_TDBE_INT 0x0080

Detailed Description

spi i2s interrupt

Macro Definition Documentation

◆ SPI_I2S_ERROR_INT

#define SPI_I2S_ERROR_INT 0x0020

error interrupt

Definition at line 72 of file at32f413_spi.h.

◆ SPI_I2S_RDBF_INT

#define SPI_I2S_RDBF_INT 0x0040

receive data buffer full interrupt

Definition at line 73 of file at32f413_spi.h.

◆ SPI_I2S_TDBE_INT

#define SPI_I2S_TDBE_INT 0x0080

transmit data buffer empty interrupt

Definition at line 74 of file at32f413_spi.h.


AT32F413 Firmwary Library: SPI_exported_types

Data Structures | Enumerations
SPI_exported_types
AT32F413_periph_driver » SPI

Data Structures

struct | spi_init_type
spi init type More...
struct | i2s_init_type
i2s init type More...
struct | spi_type
type define spi register all More...

Enumerations

enum | spi_frame_bit_num_type { SPI_FRAME_8BIT = 0x00 , SPI_FRAME_16BIT = 0x01 }
spi frame bit num type More...
enum | spi_master_slave_mode_type { SPI_MODE_SLAVE = 0x00 , SPI_MODE_MASTER = 0x01 }
spi master/slave mode type More...
enum | spi_clock_polarity_type { SPI_CLOCK_POLARITY_LOW = 0x00 , SPI_CLOCK_POLARITY_HIGH = 0x01 }
spi clock polarity (clkpol) type More...
enum | spi_clock_phase_type { SPI_CLOCK_PHASE_1EDGE = 0x00 , SPI_CLOCK_PHASE_2EDGE = 0x01 }
spi clock phase (clkpha) type More...
enum | spi_cs_mode_type { SPI_CS_HARDWARE_MODE = 0x00 , SPI_CS_SOFTWARE_MODE = 0x01 }
spi cs mode type More...
enum spi_mclk_freq_div_type {
SPI_MCLK_DIV_2 = 0x00 , SPI_MCLK_DIV_4 = 0x01 , SPI_MCLK_DIV_8 = 0x02 , SPI_MCLK_DIV_16 = 0x03 ,
SPI_MCLK_DIV_32 = 0x04 , SPI_MCLK_DIV_64 = 0x05 , SPI_MCLK_DIV_128 = 0x06 , SPI_MCLK_DIV_256 = 0x07 ,
SPI_MCLK_DIV_512 = 0x08 , SPI_MCLK_DIV_1024 = 0x09
}
spi master clock frequency division type More...
enum | spi_first_bit_type { SPI_FIRST_BIT_MSB = 0x00 , SPI_FIRST_BIT_LSB = 0x01 }
spi transmit first bit (lsb/msb) type More...
enum | spi_transmission_mode_type { SPI_TRANSMIT_FULL_DUPLEX = 0x00 , SPI_TRANSMIT_SIMPLEX_RX = 0x01 , SPI_TRANSMIT_HALF_DUPLEX_RX = 0x02 , SPI_TRANSMIT_HALF_DUPLEX_TX = 0x03 }
spi transmission mode type More...
enum | spi_crc_direction_type { SPI_CRC_RX = 0x0014 , SPI_CRC_TX = 0x0018 }
spi crc direction type More...
enum | spi_half_duplex_direction_type { SPI_HALF_DUPLEX_DIRECTION_RX = 0x00 , SPI_HALF_DUPLEX_DIRECTION_TX = 0x01 }
spi single line bidirectional direction type More...
enum | spi_software_cs_level_type { SPI_SWCS_INTERNAL_LEVEL_LOW = 0x00 , SPI_SWCS_INTERNAL_LEVEL_HIGHT = 0x01 }
spi software cs internal level type More...
enum i2s_audio_protocol_type {
I2S_AUDIO_PROTOCOL_PHILLIPS = 0x00 , I2S_AUDIO_PROTOCOL_MSB = 0x01 , I2S_AUDIO_PROTOCOL_LSB = 0x02 , I2S_AUDIO_PROTOCOL_PCM_SHORT = 0x03 ,
I2S_AUDIO_PROTOCOL_PCM_LONG = 0x04
}
i2s audio protocol type More...
enum i2s_audio_sampling_freq_type {
I2S_AUDIO_FREQUENCY_DEFAULT = 2 , I2S_AUDIO_FREQUENCY_8K = 8000 , I2S_AUDIO_FREQUENCY_11_025K = 11025 , I2S_AUDIO_FREQUENCY_16K = 16000 ,
I2S_AUDIO_FREQUENCY_22_05K = 22050 , I2S_AUDIO_FREQUENCY_32K = 32000 , I2S_AUDIO_FREQUENCY_44_1K = 44100 , I2S_AUDIO_FREQUENCY_48K = 48000 ,
I2S_AUDIO_FREQUENCY_96K = 96000 , I2S_AUDIO_FREQUENCY_192K = 192000
}
i2s audio frequency type More...
enum | i2s_data_channel_format_type { I2S_DATA_16BIT_CHANNEL_16BIT = 0x01 , I2S_DATA_16BIT_CHANNEL_32BIT = 0x02 , I2S_DATA_24BIT_CHANNEL_32BIT = 0x03 , I2S_DATA_32BIT_CHANNEL_32BIT = 0x04 }
i2s data bit num and channel bit num type More...
enum | i2s_operation_mode_type { I2S_MODE_SLAVE_TX = 0x00 , I2S_MODE_SLAVE_RX = 0x01 , I2S_MODE_MASTER_TX = 0x02 , I2S_MODE_MASTER_RX = 0x03 }
i2s operation mode type More...
enum | i2s_clock_polarity_type { I2S_CLOCK_POLARITY_LOW = 0x00 , I2S_CLOCK_POLARITY_HIGH = 0x01 }
i2s clock polarity type More...

Detailed Description

Enumeration Type Documentation

◆ i2s_audio_protocol_type

enum i2s_audio_protocol_type

i2s audio protocol type

Enumerator
I2S_AUDIO_PROTOCOL_PHILLIPS | i2s philip standard
I2S_AUDIO_PROTOCOL_MSB | msb-justified standard
I2S_AUDIO_PROTOCOL_LSB | lsb-justified standard
I2S_AUDIO_PROTOCOL_PCM_SHORT | pcm standard-short frame
I2S_AUDIO_PROTOCOL_PCM_LONG | pcm standard-long frame

Definition at line 196 of file at32f413_spi.h.

◆ i2s_audio_sampling_freq_type

enum i2s_audio_sampling_freq_type

i2s audio frequency type

Enumerator
I2S_AUDIO_FREQUENCY_DEFAULT | i2s audio sampling frequency default
I2S_AUDIO_FREQUENCY_8K | i2s audio sampling frequency 8k
I2S_AUDIO_FREQUENCY_11_025K | i2s audio sampling frequency 11.025k
I2S_AUDIO_FREQUENCY_16K | i2s audio sampling frequency 16k
I2S_AUDIO_FREQUENCY_22_05K | i2s audio sampling frequency 22.05k
I2S_AUDIO_FREQUENCY_32K | i2s audio sampling frequency 32k
I2S_AUDIO_FREQUENCY_44_1K | i2s audio sampling frequency 44.1k
I2S_AUDIO_FREQUENCY_48K | i2s audio sampling frequency 48k
I2S_AUDIO_FREQUENCY_96K | i2s audio sampling frequency 96k
I2S_AUDIO_FREQUENCY_192K | i2s audio sampling frequency 192k

Definition at line 208 of file at32f413_spi.h.

◆ i2s_clock_polarity_type

enum i2s_clock_polarity_type

i2s clock polarity type

Enumerator
I2S_CLOCK_POLARITY_LOW | i2s clock steady state is low level
I2S_CLOCK_POLARITY_HIGH | i2s clock steady state is high level

Definition at line 247 of file at32f413_spi.h.

◆ i2s_data_channel_format_type

enum i2s_data_channel_format_type

i2s data bit num and channel bit num type

Enumerator
I2S_DATA_16BIT_CHANNEL_16BIT | 16-bit data packed in 16-bit channel frame
I2S_DATA_16BIT_CHANNEL_32BIT | 16-bit data packed in 32-bit channel frame
I2S_DATA_24BIT_CHANNEL_32BIT | 24-bit data packed in 32-bit channel frame
I2S_DATA_32BIT_CHANNEL_32BIT | 32-bit data packed in 32-bit channel frame

Definition at line 225 of file at32f413_spi.h.

◆ i2s_operation_mode_type

enum i2s_operation_mode_type

i2s operation mode type

Enumerator
I2S_MODE_SLAVE_TX | slave transmission mode
I2S_MODE_SLAVE_RX | slave reception mode
I2S_MODE_MASTER_TX | master transmission mode
I2S_MODE_MASTER_RX | master reception mode

Definition at line 236 of file at32f413_spi.h.

◆ spi_clock_phase_type

enum spi_clock_phase_type

spi clock phase (clkpha) type

Enumerator
SPI_CLOCK_PHASE_1EDGE | data capture start from the first clock edge
SPI_CLOCK_PHASE_2EDGE | data capture start from the second clock edge

Definition at line 114 of file at32f413_spi.h.

◆ spi_clock_polarity_type

enum spi_clock_polarity_type

spi clock polarity (clkpol) type

Enumerator
SPI_CLOCK_POLARITY_LOW | sck keeps low at idle state
SPI_CLOCK_POLARITY_HIGH | sck keeps high at idle state

Definition at line 105 of file at32f413_spi.h.

◆ spi_crc_direction_type

enum spi_crc_direction_type

spi crc direction type

Enumerator
SPI_CRC_RX | crc direction is rx
SPI_CRC_TX | crc direction is tx

Definition at line 169 of file at32f413_spi.h.

◆ spi_cs_mode_type

enum spi_cs_mode_type

spi cs mode type

Enumerator
SPI_CS_HARDWARE_MODE | cs is hardware mode
SPI_CS_SOFTWARE_MODE | cs is software mode

Definition at line 123 of file at32f413_spi.h.

◆ spi_first_bit_type

enum spi_first_bit_type

spi transmit first bit (lsb/msb) type

Enumerator
SPI_FIRST_BIT_MSB | the frame format is msb first
SPI_FIRST_BIT_LSB | the frame format is lsb first

Definition at line 149 of file at32f413_spi.h.

◆ spi_frame_bit_num_type

enum spi_frame_bit_num_type

spi frame bit num type

Enumerator
SPI_FRAME_8BIT | 8-bit data frame format
SPI_FRAME_16BIT | 16-bit data frame format

Definition at line 87 of file at32f413_spi.h.

◆ spi_half_duplex_direction_type

enum spi_half_duplex_direction_type

spi single line bidirectional direction type

Enumerator
SPI_HALF_DUPLEX_DIRECTION_RX | single line bidirectional half duplex mode direction: receive(slbtd = 0)
SPI_HALF_DUPLEX_DIRECTION_TX | single line bidirectional half duplex mode direction: transmit(slbtd = 1)

Definition at line 178 of file at32f413_spi.h.

◆ spi_master_slave_mode_type

enum spi_master_slave_mode_type

spi master/slave mode type

Enumerator
SPI_MODE_SLAVE | select as slave mode
SPI_MODE_MASTER | select as master mode

Definition at line 96 of file at32f413_spi.h.

◆ spi_mclk_freq_div_type

enum spi_mclk_freq_div_type

spi master clock frequency division type

Enumerator
SPI_MCLK_DIV_2 | master clock frequency division 2
SPI_MCLK_DIV_4 | master clock frequency division 4
SPI_MCLK_DIV_8 | master clock frequency division 8
SPI_MCLK_DIV_16 | master clock frequency division 16
SPI_MCLK_DIV_32 | master clock frequency division 32
SPI_MCLK_DIV_64 | master clock frequency division 64
SPI_MCLK_DIV_128 | master clock frequency division 128
SPI_MCLK_DIV_256 | master clock frequency division 256
SPI_MCLK_DIV_512 | master clock frequency division 512
SPI_MCLK_DIV_1024 | master clock frequency division 1024

Definition at line 132 of file at32f413_spi.h.

◆ spi_software_cs_level_type

enum spi_software_cs_level_type

spi software cs internal level type

Enumerator
SPI_SWCS_INTERNAL_LEVEL_LOW | internal level low
SPI_SWCS_INTERNAL_LEVEL_HIGHT | internal level high

Definition at line 187 of file at32f413_spi.h.

◆ spi_transmission_mode_type

enum spi_transmission_mode_type

spi transmission mode type

Enumerator
SPI_TRANSMIT_FULL_DUPLEX | dual line unidirectional full-duplex mode(slben = 0 and ora = 0)
SPI_TRANSMIT_SIMPLEX_RX | dual line unidirectional simplex receive-only mode(slben = 0 and ora = 1)
SPI_TRANSMIT_HALF_DUPLEX_RX | single line bidirectional half duplex mode-receiving(slben = 1 and slbtd = 0)
SPI_TRANSMIT_HALF_DUPLEX_TX | single line bidirectional half duplex mode-transmitting(slben = 1 and slbtd = 1)

Definition at line 158 of file at32f413_spi.h.


AT32F413 Firmwary Library: spi_init_type Struct Reference

Data Fields
spi_init_type Struct Reference
AT32F413_periph_driver » SPI » SPI_exported_types

spi init type More...

#include <at32f413_spi.h>

Data Fields

spi_transmission_mode_type transmission_mode
spi_master_slave_mode_type master_slave_mode
spi_mclk_freq_div_type mclk_freq_division
spi_first_bit_type first_bit_transmission
spi_frame_bit_num_type frame_bit_num
spi_clock_polarity_type clock_polarity
spi_clock_phase_type clock_phase
spi_cs_mode_type cs_mode_selection

Detailed Description

spi init type

Definition at line 256 of file at32f413_spi.h.

Field Documentation

◆ clock_phase

spi_clock_phase_type spi_init_type::clock_phase

clock phase selection

Definition at line 264 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ clock_polarity

spi_clock_polarity_type spi_init_type::clock_polarity

clock polarity selection

Definition at line 263 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ cs_mode_selection

spi_cs_mode_type spi_init_type::cs_mode_selection

hardware or software cs mode selection

Definition at line 265 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ first_bit_transmission

spi_first_bit_type spi_init_type::first_bit_transmission

transmit lsb or msb selection

Definition at line 261 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ frame_bit_num

spi_frame_bit_num_type spi_init_type::frame_bit_num

frame bit num 8 or 16 bit selection

Definition at line 262 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ master_slave_mode

spi_master_slave_mode_type spi_init_type::master_slave_mode

master or slave mode selection

Definition at line 259 of file at32f413_spi.h.

Referenced by main(), spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ mclk_freq_division

spi_mclk_freq_div_type spi_init_type::mclk_freq_division

master clock frequency division selection

Definition at line 260 of file at32f413_spi.h.

Referenced by spi_config(), spi_default_para_init(), spi_init(), and spiflash_init().

◆ transmission_mode

spi_transmission_mode_type spi_init_type::transmission_mode

transmission mode selection

Definition at line 258 of file at32f413_spi.h.

Referenced by main(), spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

The documentation for this struct was generated from the following file:
  • at32f413_spi.h


AT32F413 Firmwary Library: i2s_init_type Struct Reference

Data Fields
i2s_init_type Struct Reference
AT32F413_periph_driver » SPI » SPI_exported_types

i2s init type More...

#include <at32f413_spi.h>

Data Fields

i2s_operation_mode_type operation_mode
i2s_audio_protocol_type audio_protocol
i2s_audio_sampling_freq_type audio_sampling_freq
i2s_data_channel_format_type data_channel_format
i2s_clock_polarity_type clock_polarity
confirm_state mclk_output_enable

Detailed Description

i2s init type

Definition at line 271 of file at32f413_spi.h.

Field Documentation

◆ audio_protocol

i2s_audio_protocol_type i2s_init_type::audio_protocol

audio protocol selection

Definition at line 274 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ audio_sampling_freq

i2s_audio_sampling_freq_type i2s_init_type::audio_sampling_freq

audio frequency selection

Definition at line 275 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ clock_polarity

i2s_clock_polarity_type i2s_init_type::clock_polarity

clock polarity selection

Definition at line 277 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ data_channel_format

i2s_data_channel_format_type i2s_init_type::data_channel_format

data bit num and channel bit num selection

Definition at line 276 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ mclk_output_enable

confirm_state i2s_init_type::mclk_output_enable

mclk_output selection

Definition at line 278 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

◆ operation_mode

i2s_operation_mode_type i2s_init_type::operation_mode

operation mode selection

Definition at line 273 of file at32f413_spi.h.

Referenced by codec_i2s_init(), i2s_config(), i2s_default_para_init(), and i2s_init().

The documentation for this struct was generated from the following file:
  • at32f413_spi.h


AT32F413 Firmwary Library: spi_type Struct Reference

Data Fields
spi_type Struct Reference
AT32F413_periph_driver » SPI » SPI_exported_types

type define spi register all More...

#include <at32f413_spi.h>

Data Fields

union {
__IO uint32_t ctrl1
struct {
__IO uint32_t clkpha: 1
__IO uint32_t clkpol: 1
__IO uint32_t msten: 1
__IO uint32_t mdiv_l: 3
__IO uint32_t spien: 1
__IO uint32_t ltf: 1
__IO uint32_t swcsil: 1
__IO uint32_t swcsen: 1
__IO uint32_t ora: 1
__IO uint32_t fbn: 1
__IO uint32_t ntc: 1
__IO uint32_t ccen: 1
__IO uint32_t slbtd: 1
__IO uint32_t slben: 1
__IO uint32_t reserved1: 16
} ctrl1_bit
};
spi ctrl1 register, offset:0x00 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t dmaren: 1
__IO uint32_t dmaten: 1
__IO uint32_t hwcsoe: 1
__IO uint32_t reserved1: 2
__IO uint32_t errie: 1
__IO uint32_t rdbfie: 1
__IO uint32_t tdbeie: 1
__IO uint32_t mdiv_h: 1
__IO uint32_t reserved2: 23
} ctrl2_bit
};
spi ctrl2 register, offset:0x04 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t rdbf: 1
__IO uint32_t tdbe: 1
__IO uint32_t acs: 1
__IO uint32_t tuerr: 1
__IO uint32_t ccerr: 1
__IO uint32_t mmerr: 1
__IO uint32_t roerr: 1
__IO uint32_t bf: 1
__IO uint32_t reserved1: 24
} sts_bit
};
spi sts register, offset:0x08 More...
union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 16
__IO uint32_t reserved1: 16
} dt_bit
};
spi dt register, offset:0x0C More...
union {
__IO uint32_t cpoly
struct {
__IO uint32_t cpoly: 16
__IO uint32_t reserved1: 16
} cpoly_bit
};
spi cpoly register, offset:0x10 More...
union {
__IO uint32_t rcrc
struct {
__IO uint32_t rcrc: 16
__IO uint32_t reserved1: 16
} rcrc_bit
};
spi rcrc register, offset:0x14 More...
union {
__IO uint32_t tcrc
struct {
__IO uint32_t tcrc: 16
__IO uint32_t reserved1: 16
} tcrc_bit
};
spi tcrc register, offset:0x18 More...
union {
__IO uint32_t i2sctrl
struct {
__IO uint32_t i2scbn: 1
__IO uint32_t i2sdbn: 2
__IO uint32_t i2sclkpol: 1
__IO uint32_t stdsel: 2
__IO uint32_t reserved1: 1
__IO uint32_t pcmfssel: 1
__IO uint32_t opersel: 2
__IO uint32_t i2sen: 1
__IO uint32_t i2smsel: 1
__IO uint32_t reserved2: 20
} i2sctrl_bit
};
spi i2sctrl register, offset:0x1C More...
union {
__IO uint32_t i2sclk
struct {
__IO uint32_t i2sdiv_l: 8
__IO uint32_t i2sodd: 1
__IO uint32_t i2smclkoe: 1
__IO uint32_t i2sdiv_h: 2
__IO uint32_t reserved1: 20
} i2sclk_bit
};
spi i2sclk register, offset:0x20 More...

Detailed Description

type define spi register all

Definition at line 284 of file at32f413_spi.h.

Field Documentation

◆

union { ... } spi_type::@622

spi ctrl1 register, offset:0x00

◆

union { ... } spi_type::@624

spi ctrl2 register, offset:0x04

◆

union { ... } spi_type::@626

spi sts register, offset:0x08

◆

union { ... } spi_type::@628

spi dt register, offset:0x0C

◆

union { ... } spi_type::@630

spi cpoly register, offset:0x10

◆

union { ... } spi_type::@632

spi rcrc register, offset:0x14

◆

union { ... } spi_type::@634

spi tcrc register, offset:0x18

◆

union { ... } spi_type::@636

spi i2sctrl register, offset:0x1C

◆

union { ... } spi_type::@638

spi i2sclk register, offset:0x20

◆ acs

__IO uint32_t spi_type::acs

Definition at line 343 of file at32f413_spi.h.

◆ bf

__IO uint32_t spi_type::bf

Definition at line 348 of file at32f413_spi.h.

◆ ccen

__IO uint32_t spi_type::ccen

Definition at line 306 of file at32f413_spi.h.

Referenced by spi_crc_enable().

◆ ccerr

__IO uint32_t spi_type::ccerr

Definition at line 345 of file at32f413_spi.h.

◆ clkpha

__IO uint32_t spi_type::clkpha

Definition at line 295 of file at32f413_spi.h.

Referenced by spi_init().

◆ clkpol

__IO uint32_t spi_type::clkpol

Definition at line 296 of file at32f413_spi.h.

Referenced by spi_init().

◆ cpoly

__IO uint32_t spi_type::cpoly

Definition at line 371 of file at32f413_spi.h.

Referenced by spi_crc_polynomial_get(), and spi_crc_polynomial_set().

◆

struct { ... } spi_type::cpoly_bit

Referenced by spi_crc_polynomial_get(), and spi_crc_polynomial_set().

◆ ctrl1

__IO uint32_t spi_type::ctrl1

Definition at line 292 of file at32f413_spi.h.

Referenced by spi_i2s_flag_clear().

◆

struct { ... } spi_type::ctrl1_bit

Referenced by spi_crc_enable(), spi_crc_next_transmit(), spi_enable(), spi_frame_bit_num_set(), spi_half_duplex_direction_set(), spi_init(), and spi_software_cs_internal_level_set().

◆ ctrl2

__IO uint32_t spi_type::ctrl2

Definition at line 318 of file at32f413_spi.h.

Referenced by spi_i2s_interrupt_enable().

◆

struct { ... } spi_type::ctrl2_bit

Referenced by spi_hardware_cs_output_enable(), spi_i2s_dma_receiver_enable(), spi_i2s_dma_transmitter_enable(), and spi_init().

◆ dmaren

__IO uint32_t spi_type::dmaren

Definition at line 321 of file at32f413_spi.h.

Referenced by spi_i2s_dma_receiver_enable().

◆ dmaten

__IO uint32_t spi_type::dmaten

Definition at line 322 of file at32f413_spi.h.

Referenced by spi_i2s_dma_transmitter_enable().

◆ dt

__IO uint32_t spi_type::dt

Definition at line 358 of file at32f413_spi.h.

Referenced by spi_i2s_data_receive(), spi_i2s_data_transmit(), and spi_i2s_flag_clear().

◆

struct { ... } spi_type::dt_bit

◆ errie

__IO uint32_t spi_type::errie

Definition at line 325 of file at32f413_spi.h.

◆ fbn

__IO uint32_t spi_type::fbn

Definition at line 304 of file at32f413_spi.h.

Referenced by spi_frame_bit_num_set(), and spi_init().

◆ hwcsoe

__IO uint32_t spi_type::hwcsoe

Definition at line 323 of file at32f413_spi.h.

Referenced by spi_hardware_cs_output_enable().

◆ i2scbn

__IO uint32_t spi_type::i2scbn

Definition at line 413 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sclk

__IO uint32_t spi_type::i2sclk

Definition at line 431 of file at32f413_spi.h.

◆

struct { ... } spi_type::i2sclk_bit

Referenced by i2s_init().

◆ i2sclkpol

__IO uint32_t spi_type::i2sclkpol

Definition at line 415 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sctrl

__IO uint32_t spi_type::i2sctrl

Definition at line 410 of file at32f413_spi.h.

◆

struct { ... } spi_type::i2sctrl_bit

Referenced by i2s_enable(), i2s_init(), and spi_init().

◆ i2sdbn

__IO uint32_t spi_type::i2sdbn

Definition at line 414 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sdiv_h

__IO uint32_t spi_type::i2sdiv_h

Definition at line 437 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sdiv_l

__IO uint32_t spi_type::i2sdiv_l

Definition at line 434 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2sen

__IO uint32_t spi_type::i2sen

Definition at line 420 of file at32f413_spi.h.

Referenced by i2s_enable().

◆ i2smclkoe

__IO uint32_t spi_type::i2smclkoe

Definition at line 436 of file at32f413_spi.h.

Referenced by i2s_init().

◆ i2smsel

__IO uint32_t spi_type::i2smsel

Definition at line 421 of file at32f413_spi.h.

Referenced by i2s_init(), and spi_init().

◆ i2sodd

__IO uint32_t spi_type::i2sodd

Definition at line 435 of file at32f413_spi.h.

Referenced by i2s_init().

◆ ltf

__IO uint32_t spi_type::ltf

Definition at line 300 of file at32f413_spi.h.

Referenced by spi_init().

◆ mdiv_h

__IO uint32_t spi_type::mdiv_h

Definition at line 328 of file at32f413_spi.h.

Referenced by spi_init().

◆ mdiv_l

__IO uint32_t spi_type::mdiv_l

Definition at line 298 of file at32f413_spi.h.

Referenced by spi_init().

◆ mmerr

__IO uint32_t spi_type::mmerr

Definition at line 346 of file at32f413_spi.h.

◆ msten

__IO uint32_t spi_type::msten

Definition at line 297 of file at32f413_spi.h.

Referenced by spi_init().

◆ ntc

__IO uint32_t spi_type::ntc

Definition at line 305 of file at32f413_spi.h.

Referenced by spi_crc_next_transmit().

◆ opersel

__IO uint32_t spi_type::opersel

Definition at line 419 of file at32f413_spi.h.

Referenced by i2s_init().

◆ ora

__IO uint32_t spi_type::ora

Definition at line 303 of file at32f413_spi.h.

Referenced by spi_init().

◆ pcmfssel

__IO uint32_t spi_type::pcmfssel

Definition at line 418 of file at32f413_spi.h.

Referenced by i2s_init().

◆ rcrc

__IO uint32_t spi_type::rcrc

Definition at line 384 of file at32f413_spi.h.

Referenced by spi_crc_value_get().

◆

struct { ... } spi_type::rcrc_bit

Referenced by spi_crc_value_get().

◆ rdbf

__IO uint32_t spi_type::rdbf

Definition at line 341 of file at32f413_spi.h.

◆ rdbfie

__IO uint32_t spi_type::rdbfie

Definition at line 326 of file at32f413_spi.h.

◆ reserved1

__IO uint32_t spi_type::reserved1

Definition at line 309 of file at32f413_spi.h.

◆ reserved2

__IO uint32_t spi_type::reserved2

Definition at line 329 of file at32f413_spi.h.

◆ roerr

__IO uint32_t spi_type::roerr

Definition at line 347 of file at32f413_spi.h.

◆ slben

__IO uint32_t spi_type::slben

Definition at line 308 of file at32f413_spi.h.

Referenced by spi_init().

◆ slbtd

__IO uint32_t spi_type::slbtd

Definition at line 307 of file at32f413_spi.h.

Referenced by spi_half_duplex_direction_set(), and spi_init().

◆ spien

__IO uint32_t spi_type::spien

Definition at line 299 of file at32f413_spi.h.

Referenced by spi_enable().

◆ stdsel

__IO uint32_t spi_type::stdsel

Definition at line 416 of file at32f413_spi.h.

Referenced by i2s_init().

◆ sts

__IO uint32_t spi_type::sts

Definition at line 338 of file at32f413_spi.h.

Referenced by spi_i2s_flag_clear(), and spi_i2s_flag_get().

◆

struct { ... } spi_type::sts_bit

◆ swcsen

__IO uint32_t spi_type::swcsen

Definition at line 302 of file at32f413_spi.h.

Referenced by spi_init().

◆ swcsil

__IO uint32_t spi_type::swcsil

Definition at line 301 of file at32f413_spi.h.

Referenced by spi_init(), and spi_software_cs_internal_level_set().

◆ tcrc

__IO uint32_t spi_type::tcrc

Definition at line 397 of file at32f413_spi.h.

Referenced by spi_crc_value_get().

◆

struct { ... } spi_type::tcrc_bit

Referenced by spi_crc_value_get().

◆ tdbe

__IO uint32_t spi_type::tdbe

Definition at line 342 of file at32f413_spi.h.

◆ tdbeie

__IO uint32_t spi_type::tdbeie

Definition at line 327 of file at32f413_spi.h.

◆ tuerr

__IO uint32_t spi_type::tuerr

Definition at line 344 of file at32f413_spi.h.

The documentation for this struct was generated from the following file:
  • at32f413_spi.h


AT32F413 Firmwary Library: SPI_exported_functions

Functions
SPI_exported_functions
AT32F413_periph_driver » SPI

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

Function Documentation

◆ i2s_default_para_init()

void i2s_default_para_init ( i2s_init_type * i2s_init_struct )

i2s init config with its default value.

Parameters
i2s_init_struct : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 298 of file at32f413_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ i2s_enable()

void i2s_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2s.

Parameters
spi_x | select the i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of i2s. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 445 of file at32f413_spi.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), i2s_config(), and main().

◆ i2s_init()

void i2s_init | ( | spi_type * | spi_x,
 |  | i2s_init_type * | i2s_init_struct
 | ) |  |

i2s init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
i2s_init_struct | : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 316 of file at32f413_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ spi_crc_enable()

void spi_crc_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware crc calculation for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of crc calculation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 191 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_crc_next_transmit()

void spi_crc_next_transmit ( spi_type * spi_x )

spi next transmit crc for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
none

Definition at line 152 of file at32f413_spi.c.

Referenced by main().

◆ spi_crc_polynomial_get()

uint16_t spi_crc_polynomial_get ( spi_type * spi_x )

return the crc polynomial register value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
the select crc polynomial register value

Definition at line 177 of file at32f413_spi.c.

◆ spi_crc_polynomial_set()

void spi_crc_polynomial_set | ( | spi_type * | spi_x,
 |  | uint16_t | crc_poly
 | ) |  |

set the crc polynomial value for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
crc_poly | crc polynomial value.
Return values
none

Definition at line 165 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_crc_value_get()

uint16_t spi_crc_value_get | ( | spi_type * | spi_x,
 |  | spi_crc_direction_type | crc_direction
 | ) |  |

return the transmit or the receive crc value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
crc_direction select transmit or receive crc value to be read
  • SPI_CRC_RX
  • SPI_CRC_TX
Return values
the select crc register value

Definition at line 206 of file at32f413_spi.c.

◆ spi_default_para_init()

void spi_default_para_init ( spi_init_type * spi_init_struct )

spi init config with its default value.

Parameters
spi_init_struct : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 71 of file at32f413_spi.c.

Referenced by spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_enable()

void spi_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable spi.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of spi. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 287 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_frame_bit_num_set()

void spi_frame_bit_num_set | ( | spi_type * | spi_x,
 |  | spi_frame_bit_num_type | bit_num
 | ) |  |

set the data frame bit num for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
bit_num set the data frame size
  • SPI_FRAME_8BIT
  • SPI_FRAME_16BIT
Return values
none

Definition at line 257 of file at32f413_spi.c.

◆ spi_half_duplex_direction_set()

void spi_half_duplex_direction_set | ( | spi_type * | spi_x,
 |  | spi_half_duplex_direction_type | direction
 | ) |  |

set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
direction data transfer direction this parameter can be one of the following values:
  • SPI_HALF_DUPLEX_DIRECTION_RX
  • SPI_HALF_DUPLEX_DIRECTION_TX
Return values
none

Definition at line 273 of file at32f413_spi.c.

◆ spi_hardware_cs_output_enable()

void spi_hardware_cs_output_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware cs output for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of spi master cs output. this parameter can be: TRUE or FALSE. note:the bit only use in spi master mode
Return values
none

Definition at line 224 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_i2s_data_receive()

uint16_t spi_i2s_data_receive ( spi_type * spi_x )

spi/i2s data receive

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
the received data value

Definition at line 526 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_data_transmit()

void spi_i2s_data_transmit | ( | spi_type * | spi_x,
 |  | uint16_t | tx_data
 | ) |  |

spi/i2s data transmit

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
tx_data the data to be transmit. this parameter can be:
  • (0x0000~0xFFFF)
Return values
none

Definition at line 514 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_dma_receiver_enable()

void spi_i2s_dma_receiver_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma receiver mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 499 of file at32f413_spi.c.

Referenced by codec_i2s_init(), i2s_config(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ spi_i2s_dma_transmitter_enable()

void spi_i2s_dma_transmitter_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma transmitter mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 485 of file at32f413_spi.c.

Referenced by codec_i2s_init(), main(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_flag_clear()

void spi_i2s_flag_clear | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

clear flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_CCERR_FLAG
  • SPI_I2S_RDBF_FLAG
  • I2S_TUERR_FLAG
  • SPI_MMERR_FLAG
  • SPI_I2S_ROERR_FLAG
Note
SPI_I2S_TDBE_FLAG this flag is cleared when the tx buffer already contain data to be transmit. I2S_ACS_FLAG this flag cann't cleared by software,the flag indicate the channel side(not use in pcm standard mode). SPI_I2S_BF_FLAG this flag cann't cleared by software, it's set and cleared by hardware.
Return values
none

< spi crc calculation error flag

< spi crc calculation error flag

< spi or i2s receive data buffer full flag

< i2s transmitter underload error flag

< spi master mode error flag

< spi or i2s receiver overflow error flag

Definition at line 580 of file at32f413_spi.c.

Referenced by main().

◆ spi_i2s_flag_get()

flag_status spi_i2s_flag_get | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

get flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_I2S_RDBF_FLAG
  • SPI_I2S_TDBE_FLAG
  • I2S_ACS_FLAG (this flag only use in i2s mode)
  • I2S_TUERR_FLAG (this flag only use in i2s mode)
  • SPI_CCERR_FLAG (this flag only use in spi mode)
  • SPI_MMERR_FLAG (this flag only use in spi mode)
  • SPI_I2S_ROERR_FLAG
  • SPI_I2S_BF_FLAG
Return values
the new state of spi/i2s flag

Definition at line 548 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_interrupt_enable()

void spi_i2s_interrupt_enable | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified spi/i2s interrupts.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_int specifies the spi/i2s interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • SPI_I2S_ERROR_INT
  • SPI_I2S_RDBF_INT
  • SPI_I2S_TDBE_INT
new_state | new state of the specified spi/i2s interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 464 of file at32f413_spi.c.

Referenced by i2s_config(), main(), SPI1_IRQHandler(), SPI2_IRQHandler(), and spi_config().

◆ spi_i2s_reset()

void spi_i2s_reset ( spi_type * spi_x )

spi reset by crm reset register

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
none

Definition at line 51 of file at32f413_spi.c.

Referenced by codec_i2s_init(), i2s_config(), and spi_config().

◆ spi_init()

void spi_init | ( | spi_type * | spi_x,
 |  | spi_init_type * | spi_init_struct
 | ) |  |

spi init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_init_struct | : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 91 of file at32f413_spi.c.

Referenced by main(), spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_software_cs_internal_level_set()

void spi_software_cs_internal_level_set | ( | spi_type * | spi_x,
 |  | spi_software_cs_level_type | level
 | ) |  |

set the software cs internal level for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
level set the state of spi cs level. this parameter can be one of the following values:
  • SPI_SWCS_INTERNAL_LEVEL_LOW
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT note:the bit only use when swcsen bit is set. note:when use this bit,io operation on the cs pin are invalid.
Return values
none

Definition at line 242 of file at32f413_spi.c.


AT32F413 Firmwary Library: SPI_private_functions

Functions
SPI_private_functions
AT32F413_periph_driver » SPI

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

Function Documentation

◆ i2s_default_para_init()

void i2s_default_para_init ( i2s_init_type * i2s_init_struct )

i2s init config with its default value.

Parameters
i2s_init_struct : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 298 of file at32f413_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ i2s_enable()

void i2s_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable i2s.

Parameters
spi_x | select the i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of i2s. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 445 of file at32f413_spi.c.

Referenced by codec_i2s_init(), codec_i2s_reset(), i2s_config(), and main().

◆ i2s_init()

void i2s_init | ( | spi_type * | spi_x,
 |  | i2s_init_type * | i2s_init_struct
 | ) |  |

i2s init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
i2s_init_struct | : pointer to a i2s_init_type structure which will be initialized.
Return values
none

Definition at line 316 of file at32f413_spi.c.

Referenced by codec_i2s_init(), and i2s_config().

◆ spi_crc_enable()

void spi_crc_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware crc calculation for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of crc calculation. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 191 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_crc_next_transmit()

void spi_crc_next_transmit ( spi_type * spi_x )

spi next transmit crc for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
none

Definition at line 152 of file at32f413_spi.c.

Referenced by main().

◆ spi_crc_polynomial_get()

uint16_t spi_crc_polynomial_get ( spi_type * spi_x )

return the crc polynomial register value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
the select crc polynomial register value

Definition at line 177 of file at32f413_spi.c.

◆ spi_crc_polynomial_set()

void spi_crc_polynomial_set | ( | spi_type * | spi_x,
 |  | uint16_t | crc_poly
 | ) |  |

set the crc polynomial value for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
crc_poly | crc polynomial value.
Return values
none

Definition at line 165 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_crc_value_get()

uint16_t spi_crc_value_get | ( | spi_type * | spi_x,
 |  | spi_crc_direction_type | crc_direction
 | ) |  |

return the transmit or the receive crc value for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
crc_direction select transmit or receive crc value to be read
  • SPI_CRC_RX
  • SPI_CRC_TX
Return values
the select crc register value

Definition at line 206 of file at32f413_spi.c.

◆ spi_default_para_init()

void spi_default_para_init ( spi_init_type * spi_init_struct )

spi init config with its default value.

Parameters
spi_init_struct : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 71 of file at32f413_spi.c.

Referenced by spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_enable()

void spi_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable spi.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of spi. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 287 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_frame_bit_num_set()

void spi_frame_bit_num_set | ( | spi_type * | spi_x,
 |  | spi_frame_bit_num_type | bit_num
 | ) |  |

set the data frame bit num for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
bit_num set the data frame size
  • SPI_FRAME_8BIT
  • SPI_FRAME_16BIT
Return values
none

Definition at line 257 of file at32f413_spi.c.

◆ spi_half_duplex_direction_set()

void spi_half_duplex_direction_set | ( | spi_type * | spi_x,
 |  | spi_half_duplex_direction_type | direction
 | ) |  |

set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
direction data transfer direction this parameter can be one of the following values:
  • SPI_HALF_DUPLEX_DIRECTION_RX
  • SPI_HALF_DUPLEX_DIRECTION_TX
Return values
none

Definition at line 273 of file at32f413_spi.c.

◆ spi_hardware_cs_output_enable()

void spi_hardware_cs_output_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the hardware cs output for the spi peripheral.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of spi master cs output. this parameter can be: TRUE or FALSE. note:the bit only use in spi master mode
Return values
none

Definition at line 224 of file at32f413_spi.c.

Referenced by spi_config().

◆ spi_i2s_data_receive()

uint16_t spi_i2s_data_receive ( spi_type * spi_x )

spi/i2s data receive

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
the received data value

Definition at line 526 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_data_transmit()

void spi_i2s_data_transmit | ( | spi_type * | spi_x,
 |  | uint16_t | tx_data
 | ) |  |

spi/i2s data transmit

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
tx_data the data to be transmit. this parameter can be:
  • (0x0000~0xFFFF)
Return values
none

Definition at line 514 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_dma_receiver_enable()

void spi_i2s_dma_receiver_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma receiver mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 499 of file at32f413_spi.c.

Referenced by codec_i2s_init(), i2s_config(), spi_byte_write(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ spi_i2s_dma_transmitter_enable()

void spi_i2s_dma_transmitter_enable | ( | spi_type * | spi_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the spi/i2s dma transmitter mode.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
new_state | new state of the dma request. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 485 of file at32f413_spi.c.

Referenced by codec_i2s_init(), main(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_flag_clear()

void spi_i2s_flag_clear | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

clear flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_CCERR_FLAG
  • SPI_I2S_RDBF_FLAG
  • I2S_TUERR_FLAG
  • SPI_MMERR_FLAG
  • SPI_I2S_ROERR_FLAG
Note
SPI_I2S_TDBE_FLAG this flag is cleared when the tx buffer already contain data to be transmit. I2S_ACS_FLAG this flag cann't cleared by software,the flag indicate the channel side(not use in pcm standard mode). SPI_I2S_BF_FLAG this flag cann't cleared by software, it's set and cleared by hardware.
Return values
none

< spi crc calculation error flag

< spi crc calculation error flag

< spi or i2s receive data buffer full flag

< i2s transmitter underload error flag

< spi master mode error flag

< spi or i2s receiver overflow error flag

Definition at line 580 of file at32f413_spi.c.

Referenced by main().

◆ spi_i2s_flag_get()

flag_status spi_i2s_flag_get | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_flag
 | ) |  |

get flag of the specified spi/i2s peripheral.

Parameters
spi_x select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_flag select the spi/i2s flag this parameter can be one of the following values:
  • SPI_I2S_RDBF_FLAG
  • SPI_I2S_TDBE_FLAG
  • I2S_ACS_FLAG (this flag only use in i2s mode)
  • I2S_TUERR_FLAG (this flag only use in i2s mode)
  • SPI_CCERR_FLAG (this flag only use in spi mode)
  • SPI_MMERR_FLAG (this flag only use in spi mode)
  • SPI_I2S_ROERR_FLAG
  • SPI_I2S_BF_FLAG
Return values
the new state of spi/i2s flag

Definition at line 548 of file at32f413_spi.c.

Referenced by main(), SPI1_IRQHandler(), SPI2_IRQHandler(), spi_byte_write(), spi_bytes_read(), and spi_bytes_write().

◆ spi_i2s_interrupt_enable()

void spi_i2s_interrupt_enable | ( | spi_type * | spi_x,
 |  | uint32_t | spi_i2s_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified spi/i2s interrupts.

Parameters
spi_x | select the spi/i2s peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_i2s_int specifies the spi/i2s interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • SPI_I2S_ERROR_INT
  • SPI_I2S_RDBF_INT
  • SPI_I2S_TDBE_INT
new_state | new state of the specified spi/i2s interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 464 of file at32f413_spi.c.

Referenced by i2s_config(), main(), SPI1_IRQHandler(), SPI2_IRQHandler(), and spi_config().

◆ spi_i2s_reset()

void spi_i2s_reset ( spi_type * spi_x )

spi reset by crm reset register

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
Return values
none

Definition at line 51 of file at32f413_spi.c.

Referenced by codec_i2s_init(), i2s_config(), and spi_config().

◆ spi_init()

void spi_init | ( | spi_type * | spi_x,
 |  | spi_init_type * | spi_init_struct
 | ) |  |

spi init config with its setting value.

Parameters
spi_x | select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
spi_init_struct | : pointer to a spi_init_type structure which will be initialized.
Return values
none

Definition at line 91 of file at32f413_spi.c.

Referenced by main(), spi_config(), spiflash_init(), and usart_spi_configuration().

◆ spi_software_cs_internal_level_set()

void spi_software_cs_internal_level_set | ( | spi_type * | spi_x,
 |  | spi_software_cs_level_type | level
 | ) |  |

set the software cs internal level for the spi peripheral.

Parameters
spi_x select the spi peripheral. this parameter can be one of the following values: SPI1, SPI2
level set the state of spi cs level. this parameter can be one of the following values:
  • SPI_SWCS_INTERNAL_LEVEL_LOW
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT note:the bit only use when swcsen bit is set. note:when use this bit,io operation on the cs pin are invalid.
Return values
none

Definition at line 242 of file at32f413_spi.c.


AT32F413 Firmwary Library: TMR

Modules | Macros
TMR
AT32F413_periph_driver

TMR driver modules. More...

Modules

TMR_flags_definition
tmr flag
TMR_interrupt_select_type_definition
tmr interrupt select type
TMR_exported_types
TMR_exported_functions
TMR_private_functions

Macros

#define | TMR1 ((tmr_type *) TMR1_BASE)
#define | TMR2 ((tmr_type *) TMR2_BASE)
#define | TMR3 ((tmr_type *) TMR3_BASE)
#define | TMR4 ((tmr_type *) TMR4_BASE)
#define | TMR5 ((tmr_type *) TMR5_BASE)
#define | TMR8 ((tmr_type *) TMR8_BASE)
#define | TMR9 ((tmr_type *) TMR9_BASE)
#define | TMR10 ((tmr_type *) TMR10_BASE)
#define | TMR11 ((tmr_type *) TMR11_BASE)

Detailed Description

TMR driver modules.

Macro Definition Documentation

◆ TMR1

#define TMR1 ((tmr_type *) TMR1_BASE)

Definition at line 832 of file at32f413_tmr.h.

◆ TMR10

#define TMR10 ((tmr_type *) TMR10_BASE)

Definition at line 839 of file at32f413_tmr.h.

◆ TMR11

#define TMR11 ((tmr_type *) TMR11_BASE)

Definition at line 840 of file at32f413_tmr.h.

◆ TMR2

#define TMR2 ((tmr_type *) TMR2_BASE)

Definition at line 833 of file at32f413_tmr.h.

◆ TMR3

#define TMR3 ((tmr_type *) TMR3_BASE)

Definition at line 834 of file at32f413_tmr.h.

◆ TMR4

#define TMR4 ((tmr_type *) TMR4_BASE)

Definition at line 835 of file at32f413_tmr.h.

◆ TMR5

#define TMR5 ((tmr_type *) TMR5_BASE)

Definition at line 836 of file at32f413_tmr.h.

◆ TMR8

#define TMR8 ((tmr_type *) TMR8_BASE)

Definition at line 837 of file at32f413_tmr.h.

◆ TMR9

#define TMR9 ((tmr_type *) TMR9_BASE)

Definition at line 838 of file at32f413_tmr.h.


AT32F413 Firmwary Library: TMR_flags_definition

Macros
TMR_flags_definition
AT32F413_periph_driver » TMR

tmr flag More...

Macros

#define | TMR_OVF_FLAG ((uint32_t)0x000001)
#define | TMR_C1_FLAG ((uint32_t)0x000002)
#define | TMR_C2_FLAG ((uint32_t)0x000004)
#define | TMR_C3_FLAG ((uint32_t)0x000008)
#define | TMR_C4_FLAG ((uint32_t)0x000010)
#define | TMR_HALL_FLAG ((uint32_t)0x000020)
#define | TMR_TRIGGER_FLAG ((uint32_t)0x000040)
#define | TMR_BRK_FLAG ((uint32_t)0x000080)
#define | TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)
#define | TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)
#define | TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)
#define | TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)

Detailed Description

tmr flag

Macro Definition Documentation

◆ TMR_BRK_FLAG

#define TMR_BRK_FLAG ((uint32_t)0x000080)

tmr flag brake

Definition at line 59 of file at32f413_tmr.h.

◆ TMR_C1_FLAG

#define TMR_C1_FLAG ((uint32_t)0x000002)

tmr flag channel 1

Definition at line 53 of file at32f413_tmr.h.

◆ TMR_C1_RECAPTURE_FLAG

#define TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)

tmr flag channel 1 recapture

Definition at line 60 of file at32f413_tmr.h.

◆ TMR_C2_FLAG

#define TMR_C2_FLAG ((uint32_t)0x000004)

tmr flag channel 2

Definition at line 54 of file at32f413_tmr.h.

◆ TMR_C2_RECAPTURE_FLAG

#define TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)

tmr flag channel 2 recapture

Definition at line 61 of file at32f413_tmr.h.

◆ TMR_C3_FLAG

#define TMR_C3_FLAG ((uint32_t)0x000008)

tmr flag channel 3

Definition at line 55 of file at32f413_tmr.h.

◆ TMR_C3_RECAPTURE_FLAG

#define TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)

tmr flag channel 3 recapture

Definition at line 62 of file at32f413_tmr.h.

◆ TMR_C4_FLAG

#define TMR_C4_FLAG ((uint32_t)0x000010)

tmr flag channel 4

Definition at line 56 of file at32f413_tmr.h.

◆ TMR_C4_RECAPTURE_FLAG

#define TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)

tmr flag channel 4 recapture

Definition at line 63 of file at32f413_tmr.h.

◆ TMR_HALL_FLAG

#define TMR_HALL_FLAG ((uint32_t)0x000020)

tmr flag hall

Definition at line 57 of file at32f413_tmr.h.

◆ TMR_OVF_FLAG

#define TMR_OVF_FLAG ((uint32_t)0x000001)

tmr flag overflow

Definition at line 52 of file at32f413_tmr.h.

◆ TMR_TRIGGER_FLAG

#define TMR_TRIGGER_FLAG ((uint32_t)0x000040)

tmr flag trigger

Definition at line 58 of file at32f413_tmr.h.


AT32F413 Firmwary Library: TMR_interrupt_select_type_definition

Macros
TMR_interrupt_select_type_definition
AT32F413_periph_driver » TMR

tmr interrupt select type More...

Macros

#define | TMR_OVF_INT ((uint32_t)0x000001)
#define | TMR_C1_INT ((uint32_t)0x000002)
#define | TMR_C2_INT ((uint32_t)0x000004)
#define | TMR_C3_INT ((uint32_t)0x000008)
#define | TMR_C4_INT ((uint32_t)0x000010)
#define | TMR_HALL_INT ((uint32_t)0x000020)
#define | TMR_TRIGGER_INT ((uint32_t)0x000040)
#define | TMR_BRK_INT ((uint32_t)0x000080)

Detailed Description

tmr interrupt select type

Macro Definition Documentation

◆ TMR_BRK_INT

#define TMR_BRK_INT ((uint32_t)0x000080)

tmr interrupt brake

Definition at line 81 of file at32f413_tmr.h.

◆ TMR_C1_INT

#define TMR_C1_INT ((uint32_t)0x000002)

tmr interrupt channel 1

Definition at line 75 of file at32f413_tmr.h.

◆ TMR_C2_INT

#define TMR_C2_INT ((uint32_t)0x000004)

tmr interrupt channel 2

Definition at line 76 of file at32f413_tmr.h.

◆ TMR_C3_INT

#define TMR_C3_INT ((uint32_t)0x000008)

tmr interrupt channel 3

Definition at line 77 of file at32f413_tmr.h.

◆ TMR_C4_INT

#define TMR_C4_INT ((uint32_t)0x000010)

tmr interrupt channel 4

Definition at line 78 of file at32f413_tmr.h.

◆ TMR_HALL_INT

#define TMR_HALL_INT ((uint32_t)0x000020)

tmr interrupt hall

Definition at line 79 of file at32f413_tmr.h.

◆ TMR_OVF_INT

#define TMR_OVF_INT ((uint32_t)0x000001)

tmr interrupt overflow

Definition at line 74 of file at32f413_tmr.h.

◆ TMR_TRIGGER_INT

#define TMR_TRIGGER_INT ((uint32_t)0x000040)

tmr interrupt trigger

Definition at line 80 of file at32f413_tmr.h.


AT32F413 Firmwary Library: TMR_exported_types

Data Structures | Enumerations
TMR_exported_types
AT32F413_periph_driver » TMR

Data Structures

struct | tmr_output_config_type
tmr output config type More...
struct | tmr_input_config_type
tmr input capture config type More...
struct | tmr_brkdt_config_type
tmr brkdt config type More...
struct | tmr_type
type define tmr register all More...

Enumerations

enum | tmr_clock_division_type { TMR_CLOCK_DIV1 = 0x00 , TMR_CLOCK_DIV2 = 0x01 , TMR_CLOCK_DIV4 = 0x02 }
tmr clock division type More...
enum tmr_count_mode_type {
TMR_COUNT_UP = 0x00 , TMR_COUNT_DOWN = 0x01 , TMR_COUNT_TWO_WAY_1 = 0x02 , TMR_COUNT_TWO_WAY_2 = 0x04 ,
TMR_COUNT_TWO_WAY_3 = 0x06
}
tmr counter mode type More...
enum tmr_primary_select_type {
TMR_PRIMARY_SEL_RESET = 0x00 , TMR_PRIMARY_SEL_ENABLE = 0x01 , TMR_PRIMARY_SEL_OVERFLOW = 0x02 , TMR_PRIMARY_SEL_COMPARE = 0x03 ,
TMR_PRIMARY_SEL_C1ORAW = 0x04 , TMR_PRIMARY_SEL_C2ORAW = 0x05 , TMR_PRIMARY_SEL_C3ORAW = 0x06 , TMR_PRIMARY_SEL_C4ORAW = 0x07
}
tmr primary mode select type More...
enum sub_tmr_input_sel_type {
TMR_SUB_INPUT_SEL_IS0 = 0x00 , TMR_SUB_INPUT_SEL_IS1 = 0x01 , TMR_SUB_INPUT_SEL_IS2 = 0x02 , TMR_SUB_INPUT_SEL_IS3 = 0x03 ,
TMR_SUB_INPUT_SEL_C1INC = 0x04 , TMR_SUB_INPUT_SEL_C1DF1 = 0x05 , TMR_SUB_INPUT_SEL_C2DF2 = 0x06 , TMR_SUB_INPUT_SEL_EXTIN = 0x07
}
tmr subordinate mode input select type More...
enum tmr_sub_mode_select_type {
TMR_SUB_MODE_DIABLE = 0x00 , TMR_SUB_ENCODER_MODE_A = 0x01 , TMR_SUB_ENCODER_MODE_B = 0x02 , TMR_SUB_ENCODER_MODE_C = 0x03 ,
TMR_SUB_RESET_MODE = 0x04 , TMR_SUB_HANG_MODE = 0x05 , TMR_SUB_TRIGGER_MODE = 0x06 , TMR_SUB_EXTERNAL_CLOCK_MODE_A = 0x07
}
tmr subordinate mode select type More...
enum | tmr_encoder_mode_type { TMR_ENCODER_MODE_A = TMR_SUB_ENCODER_MODE_A , TMR_ENCODER_MODE_B = TMR_SUB_ENCODER_MODE_B , TMR_ENCODER_MODE_C = TMR_SUB_ENCODER_MODE_C }
tmr encoder mode type More...
enum tmr_output_control_mode_type {
TMR_OUTPUT_CONTROL_OFF = 0x00 , TMR_OUTPUT_CONTROL_HIGH = 0x01 , TMR_OUTPUT_CONTROL_LOW = 0x02 , TMR_OUTPUT_CONTROL_SWITCH = 0x03 ,
TMR_OUTPUT_CONTROL_FORCE_LOW = 0x04 , TMR_OUTPUT_CONTROL_FORCE_HIGH = 0x05 , TMR_OUTPUT_CONTROL_PWM_MODE_A = 0x06 , TMR_OUTPUT_CONTROL_PWM_MODE_B = 0x07
}
tmr output control mode type More...
enum | tmr_force_output_type { TMR_FORCE_OUTPUT_HIGH = TMR_OUTPUT_CONTROL_FORCE_HIGH , TMR_FORCE_OUTPUT_LOW = TMR_OUTPUT_CONTROL_FORCE_LOW }
tmr force output type More...
enum | tmr_output_polarity_type { TMR_OUTPUT_ACTIVE_HIGH = 0x00 , TMR_OUTPUT_ACTIVE_LOW = 0x01 }
tmr output channel polarity type More...
enum | tmr_input_polarity_type { TMR_INPUT_RISING_EDGE = 0x00 , TMR_INPUT_FALLING_EDGE = 0x01 , TMR_INPUT_BOTH_EDGE = 0x03 }
tmr input channel polarity type More...
enum tmr_channel_select_type {
TMR_SELECT_CHANNEL_1 = 0x00 , TMR_SELECT_CHANNEL_1C = 0x01 , TMR_SELECT_CHANNEL_2 = 0x02 , TMR_SELECT_CHANNEL_2C = 0x03 ,
TMR_SELECT_CHANNEL_3 = 0x04 , TMR_SELECT_CHANNEL_3C = 0x05 , TMR_SELECT_CHANNEL_4 = 0x06
}
tmr channel select type More...
enum | tmr_channel1_input_connected_type { TMR_CHANEL1_CONNECTED_C1IRAW = 0x00 , TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR = 0x01 }
tmr channel1 input connected type More...
enum | tmr_input_direction_mapped_type { TMR_CC_CHANNEL_MAPPED_DIRECT = 0x01 , TMR_CC_CHANNEL_MAPPED_INDIRECT = 0x02 , TMR_CC_CHANNEL_MAPPED_STI = 0x03 }
tmr input channel mapped type channel direction More...
enum | tmr_channel_input_divider_type { TMR_CHANNEL_INPUT_DIV_1 = 0x00 , TMR_CHANNEL_INPUT_DIV_2 = 0x01 , TMR_CHANNEL_INPUT_DIV_4 = 0x02 , TMR_CHANNEL_INPUT_DIV_8 = 0x03 }
tmr input divider type More...
enum | tmr_dma_request_source_type { TMR_DMA_REQUEST_BY_CHANNEL = 0x00 , TMR_DMA_REQUEST_BY_OVERFLOW = 0x01 }
tmr dma request source select type More...
enum tmr_dma_request_type {
TMR_OVERFLOW_DMA_REQUEST = 0x00000100 , TMR_C1_DMA_REQUEST = 0x00000200 , TMR_C2_DMA_REQUEST = 0x00000400 , TMR_C3_DMA_REQUEST = 0x00000800 ,
TMR_C4_DMA_REQUEST = 0x00001000 , TMR_HALL_DMA_REQUEST = 0x00002000 , TMR_TRIGGER_DMA_REQUEST = 0x00004000
}
tmr dma request type More...
enum tmr_event_trigger_type {
TMR_OVERFLOW_SWTRIG = 0x00000001 , TMR_C1_SWTRIG = 0x00000002 , TMR_C2_SWTRIG = 0x00000004 , TMR_C3_SWTRIG = 0x00000008 ,
TMR_C4_SWTRIG = 0x00000010 , TMR_HALL_SWTRIG = 0x00000020 , TMR_TRIGGER_SWTRIG = 0x00000040 , TMR_BRK_SWTRIG = 0x00000080
}
tmr event triggered by software type More...
enum | tmr_polarity_active_type { TMR_POLARITY_ACTIVE_HIGH = 0x00 , TMR_POLARITY_ACTIVE_LOW = 0x01 , TMR_POLARITY_ACTIVE_BOTH = 0x02 }
tmr polarity active type More...
enum | tmr_external_signal_divider_type { TMR_ES_FREQUENCY_DIV_1 = 0x00 , TMR_ES_FREQUENCY_DIV_2 = 0x01 , TMR_ES_FREQUENCY_DIV_4 = 0x02 , TMR_ES_FREQUENCY_DIV_8 = 0x03 }
tmr external signal divider type More...
enum | tmr_external_signal_polarity_type { TMR_ES_POLARITY_NON_INVERTED = 0x00 , TMR_ES_POLARITY_INVERTED = 0x01 }
tmr external signal polarity type More...
enum tmr_dma_transfer_length_type {
TMR_DMA_TRANSFER_1BYTE = 0x00 , TMR_DMA_TRANSFER_2BYTES = 0x01 , TMR_DMA_TRANSFER_3BYTES = 0x02 , TMR_DMA_TRANSFER_4BYTES = 0x03 ,
TMR_DMA_TRANSFER_5BYTES = 0x04 , TMR_DMA_TRANSFER_6BYTES = 0x05 , TMR_DMA_TRANSFER_7BYTES = 0x06 , TMR_DMA_TRANSFER_8BYTES = 0x07 ,
TMR_DMA_TRANSFER_9BYTES = 0x08 , TMR_DMA_TRANSFER_10BYTES = 0x09 , TMR_DMA_TRANSFER_11BYTES = 0x0A , TMR_DMA_TRANSFER_12BYTES = 0x0B ,
TMR_DMA_TRANSFER_13BYTES = 0x0C , TMR_DMA_TRANSFER_14BYTES = 0x0D , TMR_DMA_TRANSFER_15BYTES = 0x0E , TMR_DMA_TRANSFER_16BYTES = 0x0F ,
TMR_DMA_TRANSFER_17BYTES = 0x10 , TMR_DMA_TRANSFER_18BYTES = 0x11
}
tmr dma transfer length type More...
enum tmr_dma_address_type {
TMR_CTRL1_ADDRESS = 0x0000 , TMR_CTRL2_ADDRESS = 0x0001 , TMR_STCTRL_ADDRESS = 0x0002 , TMR_IDEN_ADDRESS = 0x0003 ,
TMR_ISTS_ADDRESS = 0x0004 , TMR_SWEVT_ADDRESS = 0x0005 , TMR_CM1_ADDRESS = 0x0006 , TMR_CM2_ADDRESS = 0x0007 ,
TMR_CCTRL_ADDRESS = 0x0008 , TMR_CVAL_ADDRESS = 0x0009 , TMR_DIV_ADDRESS = 0x000A , TMR_PR_ADDRESS = 0x000B ,
TMR_RPR_ADDRESS = 0x000C , TMR_C1DT_ADDRESS = 0x000D , TMR_C2DT_ADDRESS = 0x000E , TMR_C3DT_ADDRESS = 0x000F ,
TMR_C4DT_ADDRESS = 0x0010 , TMR_BRK_ADDRESS = 0x0011 , TMR_DMACTRL_ADDRESS = 0x0012
}
tmr dma base address type More...
enum | tmr_brk_polarity_type { TMR_BRK_INPUT_ACTIVE_LOW = 0x00 , TMR_BRK_INPUT_ACTIVE_HIGH = 0x01 }
tmr brk polarity type More...
enum | tmr_wp_level_type { TMR_WP_OFF = 0x00 , TMR_WP_LEVEL_3 = 0x01 , TMR_WP_LEVEL_2 = 0x02 , TMR_WP_LEVEL_1 = 0x03 }
tmr write protect level type More...

Detailed Description

Enumeration Type Documentation

◆ sub_tmr_input_sel_type

enum sub_tmr_input_sel_type

tmr subordinate mode input select type

Enumerator
TMR_SUB_INPUT_SEL_IS0 | subordinate mode input select is0
TMR_SUB_INPUT_SEL_IS1 | subordinate mode input select is1
TMR_SUB_INPUT_SEL_IS2 | subordinate mode input select is2
TMR_SUB_INPUT_SEL_IS3 | subordinate mode input select is3
TMR_SUB_INPUT_SEL_C1INC | subordinate mode input select c1inc
TMR_SUB_INPUT_SEL_C1DF1 | subordinate mode input select c1df1
TMR_SUB_INPUT_SEL_C2DF2 | subordinate mode input select c2df2
TMR_SUB_INPUT_SEL_EXTIN | subordinate mode input select extin

Definition at line 131 of file at32f413_tmr.h.

◆ tmr_brk_polarity_type

enum tmr_brk_polarity_type

tmr brk polarity type

Enumerator
TMR_BRK_INPUT_ACTIVE_LOW | tmr brk input channel active low
TMR_BRK_INPUT_ACTIVE_HIGH | tmr brk input channel active high

Definition at line 377 of file at32f413_tmr.h.

◆ tmr_channel1_input_connected_type

enum tmr_channel1_input_connected_type

tmr channel1 input connected type

Enumerator
TMR_CHANEL1_CONNECTED_C1IRAW | channel1 pins is only connected to C1IRAW input
TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR | channel1/2/3 pins are connected to C1IRAW input after xored

Definition at line 228 of file at32f413_tmr.h.

◆ tmr_channel_input_divider_type

enum tmr_channel_input_divider_type

tmr input divider type

Enumerator
TMR_CHANNEL_INPUT_DIV_1 | tmr channel input divider 1
TMR_CHANNEL_INPUT_DIV_2 | tmr channel input divider 2
TMR_CHANNEL_INPUT_DIV_4 | tmr channel input divider 4
TMR_CHANNEL_INPUT_DIV_8 | tmr channel input divider 8

Definition at line 247 of file at32f413_tmr.h.

◆ tmr_channel_select_type

enum tmr_channel_select_type

tmr channel select type

Enumerator
TMR_SELECT_CHANNEL_1 | tmr channel select channel 1
TMR_SELECT_CHANNEL_1C | tmr channel select channel 1 complementary
TMR_SELECT_CHANNEL_2 | tmr channel select channel 2
TMR_SELECT_CHANNEL_2C | tmr channel select channel 2 complementary
TMR_SELECT_CHANNEL_3 | tmr channel select channel 3
TMR_SELECT_CHANNEL_3C | tmr channel select channel 3 complementary
TMR_SELECT_CHANNEL_4 | tmr channel select channel 4

Definition at line 214 of file at32f413_tmr.h.

◆ tmr_clock_division_type

enum tmr_clock_division_type

tmr clock division type

Enumerator
TMR_CLOCK_DIV1 | tmr clock division 1
TMR_CLOCK_DIV2 | tmr clock division 2
TMR_CLOCK_DIV4 | tmr clock division 4

Definition at line 94 of file at32f413_tmr.h.

◆ tmr_count_mode_type

enum tmr_count_mode_type

tmr counter mode type

Enumerator
TMR_COUNT_UP | tmr counter mode up
TMR_COUNT_DOWN | tmr counter mode down
TMR_COUNT_TWO_WAY_1 | tmr counter mode two way 1
TMR_COUNT_TWO_WAY_2 | tmr counter mode two way 2
TMR_COUNT_TWO_WAY_3 | tmr counter mode two way 3

Definition at line 104 of file at32f413_tmr.h.

◆ tmr_dma_address_type

enum tmr_dma_address_type

tmr dma base address type

Enumerator
TMR_CTRL1_ADDRESS | tmr dma base address ctrl1
TMR_CTRL2_ADDRESS | tmr dma base address ctrl2
TMR_STCTRL_ADDRESS | tmr dma base address stctrl
TMR_IDEN_ADDRESS | tmr dma base address iden
TMR_ISTS_ADDRESS | tmr dma base address ists
TMR_SWEVT_ADDRESS | tmr dma base address swevt
TMR_CM1_ADDRESS | tmr dma base address cm1
TMR_CM2_ADDRESS | tmr dma base address cm2
TMR_CCTRL_ADDRESS | tmr dma base address cctrl
TMR_CVAL_ADDRESS | tmr dma base address cval
TMR_DIV_ADDRESS | tmr dma base address div
TMR_PR_ADDRESS | tmr dma base address pr
TMR_RPR_ADDRESS | tmr dma base address rpr
TMR_C1DT_ADDRESS | tmr dma base address c1dt
TMR_C2DT_ADDRESS | tmr dma base address c2dt
TMR_C3DT_ADDRESS | tmr dma base address c3dt
TMR_C4DT_ADDRESS | tmr dma base address c4dt
TMR_BRK_ADDRESS | tmr dma base address brake
TMR_DMACTRL_ADDRESS | tmr dma base address dmactrl

Definition at line 351 of file at32f413_tmr.h.

◆ tmr_dma_request_source_type

enum tmr_dma_request_source_type

tmr dma request source select type

Enumerator
TMR_DMA_REQUEST_BY_CHANNEL | tmr dma request source select channel
TMR_DMA_REQUEST_BY_OVERFLOW | tmr dma request source select overflow

Definition at line 258 of file at32f413_tmr.h.

◆ tmr_dma_request_type

enum tmr_dma_request_type

tmr dma request type

Enumerator
TMR_OVERFLOW_DMA_REQUEST | tmr dma request select overflow
TMR_C1_DMA_REQUEST | tmr dma request select channel 1
TMR_C2_DMA_REQUEST | tmr dma request select channel 2
TMR_C3_DMA_REQUEST | tmr dma request select channel 3
TMR_C4_DMA_REQUEST | tmr dma request select channel 4
TMR_HALL_DMA_REQUEST | tmr dma request select hall
TMR_TRIGGER_DMA_REQUEST | tmr dma request select trigger

Definition at line 267 of file at32f413_tmr.h.

◆ tmr_dma_transfer_length_type

enum tmr_dma_transfer_length_type

tmr dma transfer length type

Enumerator
TMR_DMA_TRANSFER_1BYTE | tmr dma transfer length 1 byte
TMR_DMA_TRANSFER_2BYTES | tmr dma transfer length 2 bytes
TMR_DMA_TRANSFER_3BYTES | tmr dma transfer length 3 bytes
TMR_DMA_TRANSFER_4BYTES | tmr dma transfer length 4 bytes
TMR_DMA_TRANSFER_5BYTES | tmr dma transfer length 5 bytes
TMR_DMA_TRANSFER_6BYTES | tmr dma transfer length 6 bytes
TMR_DMA_TRANSFER_7BYTES | tmr dma transfer length 7 bytes
TMR_DMA_TRANSFER_8BYTES | tmr dma transfer length 8 bytes
TMR_DMA_TRANSFER_9BYTES | tmr dma transfer length 9 bytes
TMR_DMA_TRANSFER_10BYTES | tmr dma transfer length 10 bytes
TMR_DMA_TRANSFER_11BYTES | tmr dma transfer length 11 bytes
TMR_DMA_TRANSFER_12BYTES | tmr dma transfer length 12 bytes
TMR_DMA_TRANSFER_13BYTES | tmr dma transfer length 13 bytes
TMR_DMA_TRANSFER_14BYTES | tmr dma transfer length 14 bytes
TMR_DMA_TRANSFER_15BYTES | tmr dma transfer length 15 bytes
TMR_DMA_TRANSFER_16BYTES | tmr dma transfer length 16 bytes
TMR_DMA_TRANSFER_17BYTES | tmr dma transfer length 17 bytes
TMR_DMA_TRANSFER_18BYTES | tmr dma transfer length 18 bytes

Definition at line 326 of file at32f413_tmr.h.

◆ tmr_encoder_mode_type

enum tmr_encoder_mode_type

tmr encoder mode type

Enumerator
TMR_ENCODER_MODE_A | tmr encoder mode a
TMR_ENCODER_MODE_B | tmr encoder mode b
TMR_ENCODER_MODE_C | tmr encoder mode c

Definition at line 161 of file at32f413_tmr.h.

◆ tmr_event_trigger_type

enum tmr_event_trigger_type

tmr event triggered by software type

Enumerator
TMR_OVERFLOW_SWTRIG | tmr event triggered by software of overflow
TMR_C1_SWTRIG | tmr event triggered by software of channel 1
TMR_C2_SWTRIG | tmr event triggered by software of channel 2
TMR_C3_SWTRIG | tmr event triggered by software of channel 3
TMR_C4_SWTRIG | tmr event triggered by software of channel 4
TMR_HALL_SWTRIG | tmr event triggered by software of hall
TMR_TRIGGER_SWTRIG | tmr event triggered by software of trigger
TMR_BRK_SWTRIG | tmr event triggered by software of brake

Definition at line 281 of file at32f413_tmr.h.

◆ tmr_external_signal_divider_type

enum tmr_external_signal_divider_type

tmr external signal divider type

Enumerator
TMR_ES_FREQUENCY_DIV_1 | tmr external signal frequency divider 1
TMR_ES_FREQUENCY_DIV_2 | tmr external signal frequency divider 2
TMR_ES_FREQUENCY_DIV_4 | tmr external signal frequency divider 4
TMR_ES_FREQUENCY_DIV_8 | tmr external signal frequency divider 8

Definition at line 306 of file at32f413_tmr.h.

◆ tmr_external_signal_polarity_type

enum tmr_external_signal_polarity_type

tmr external signal polarity type

Enumerator
TMR_ES_POLARITY_NON_INVERTED | tmr external signal polarity non-inerted
TMR_ES_POLARITY_INVERTED | tmr external signal polarity inerted

Definition at line 317 of file at32f413_tmr.h.

◆ tmr_force_output_type

enum tmr_force_output_type

tmr force output type

Enumerator
TMR_FORCE_OUTPUT_HIGH | tmr force output high
TMR_FORCE_OUTPUT_LOW | tmr force output low

Definition at line 186 of file at32f413_tmr.h.

◆ tmr_input_direction_mapped_type

enum tmr_input_direction_mapped_type

tmr input channel mapped type channel direction

Enumerator
TMR_CC_CHANNEL_MAPPED_DIRECT | channel is configured as input, mapped direct
TMR_CC_CHANNEL_MAPPED_INDIRECT | channel is configured as input, mapped indirect
TMR_CC_CHANNEL_MAPPED_STI | channel is configured as input, mapped trc

Definition at line 237 of file at32f413_tmr.h.

◆ tmr_input_polarity_type

enum tmr_input_polarity_type

tmr input channel polarity type

Enumerator
TMR_INPUT_RISING_EDGE | tmr input channel polarity rising
TMR_INPUT_FALLING_EDGE | tmr input channel polarity falling
TMR_INPUT_BOTH_EDGE | tmr input channel polarity both edge

Definition at line 204 of file at32f413_tmr.h.

◆ tmr_output_control_mode_type

enum tmr_output_control_mode_type

tmr output control mode type

Enumerator
TMR_OUTPUT_CONTROL_OFF | tmr output control mode off
TMR_OUTPUT_CONTROL_HIGH | tmr output control mode high
TMR_OUTPUT_CONTROL_LOW | tmr output control mode low
TMR_OUTPUT_CONTROL_SWITCH | tmr output control mode switch
TMR_OUTPUT_CONTROL_FORCE_LOW | tmr output control mode force low
TMR_OUTPUT_CONTROL_FORCE_HIGH | tmr output control mode force high
TMR_OUTPUT_CONTROL_PWM_MODE_A | tmr output control mode pwm a
TMR_OUTPUT_CONTROL_PWM_MODE_B | tmr output control mode pwm b

Definition at line 171 of file at32f413_tmr.h.

◆ tmr_output_polarity_type

enum tmr_output_polarity_type

tmr output channel polarity type

Enumerator
TMR_OUTPUT_ACTIVE_HIGH | tmr output channel polarity high
TMR_OUTPUT_ACTIVE_LOW | tmr output channel polarity low

Definition at line 195 of file at32f413_tmr.h.

◆ tmr_polarity_active_type

enum tmr_polarity_active_type

tmr polarity active type

Enumerator
TMR_POLARITY_ACTIVE_HIGH | tmr polarity active high
TMR_POLARITY_ACTIVE_LOW | tmr polarity active low
TMR_POLARITY_ACTIVE_BOTH | tmr polarity active both high ande low

Definition at line 296 of file at32f413_tmr.h.

◆ tmr_primary_select_type

enum tmr_primary_select_type

tmr primary mode select type

Enumerator
TMR_PRIMARY_SEL_RESET | tmr primary mode select reset
TMR_PRIMARY_SEL_ENABLE | tmr primary mode select enable
TMR_PRIMARY_SEL_OVERFLOW | tmr primary mode select overflow
TMR_PRIMARY_SEL_COMPARE | tmr primary mode select compare
TMR_PRIMARY_SEL_C1ORAW | tmr primary mode select c1oraw
TMR_PRIMARY_SEL_C2ORAW | tmr primary mode select c2oraw
TMR_PRIMARY_SEL_C3ORAW | tmr primary mode select c3oraw
TMR_PRIMARY_SEL_C4ORAW | tmr primary mode select c4oraw

Definition at line 116 of file at32f413_tmr.h.

◆ tmr_sub_mode_select_type

enum tmr_sub_mode_select_type

tmr subordinate mode select type

Enumerator
TMR_SUB_MODE_DIABLE | subordinate mode disable
TMR_SUB_ENCODER_MODE_A | subordinate mode select encoder mode a
TMR_SUB_ENCODER_MODE_B | subordinate mode select encoder mode b
TMR_SUB_ENCODER_MODE_C | subordinate mode select encoder mode c
TMR_SUB_RESET_MODE | subordinate mode select reset
TMR_SUB_HANG_MODE | subordinate mode select hang
TMR_SUB_TRIGGER_MODE | subordinate mode select trigger
TMR_SUB_EXTERNAL_CLOCK_MODE_A | subordinate mode external clock mode a

Definition at line 146 of file at32f413_tmr.h.

◆ tmr_wp_level_type

enum tmr_wp_level_type

tmr write protect level type

Enumerator
TMR_WP_OFF | tmr write protect off
TMR_WP_LEVEL_3 | tmr write protect level 3
TMR_WP_LEVEL_2 | tmr write protect level 2
TMR_WP_LEVEL_1 | tmr write protect level 1

Definition at line 386 of file at32f413_tmr.h.


AT32F413 Firmwary Library: tmr_output_config_type Struct Reference

Data Fields
tmr_output_config_type Struct Reference
AT32F413_periph_driver » TMR » TMR_exported_types

tmr output config type More...

#include <at32f413_tmr.h>

Data Fields

tmr_output_control_mode_type oc_mode
confirm_state oc_idle_state
confirm_state occ_idle_state
tmr_output_polarity_type oc_polarity
tmr_output_polarity_type occ_polarity
confirm_state oc_output_state
confirm_state occ_output_state

Detailed Description

tmr output config type

Definition at line 397 of file at32f413_tmr.h.

Field Documentation

◆ oc_idle_state

confirm_state tmr_output_config_type::oc_idle_state

output channel idle state

Definition at line 400 of file at32f413_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ oc_mode

tmr_output_control_mode_type tmr_output_config_type::oc_mode

output channel mode

Definition at line 399 of file at32f413_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ oc_output_state

confirm_state tmr_output_config_type::oc_output_state

output channel enable

Definition at line 404 of file at32f413_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ oc_polarity

tmr_output_polarity_type tmr_output_config_type::oc_polarity

output channel polarity

Definition at line 402 of file at32f413_tmr.h.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ occ_idle_state

confirm_state tmr_output_config_type::occ_idle_state

output channel complementary idle state

Definition at line 401 of file at32f413_tmr.h.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ occ_output_state

confirm_state tmr_output_config_type::occ_output_state

output channel complementary enable

Definition at line 405 of file at32f413_tmr.h.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

◆ occ_polarity

tmr_output_polarity_type tmr_output_config_type::occ_polarity

output channel complementary polarity

Definition at line 403 of file at32f413_tmr.h.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f413_tmr.h


AT32F413 Firmwary Library: tmr_input_config_type Struct Reference

Data Fields
tmr_input_config_type Struct Reference
AT32F413_periph_driver » TMR » TMR_exported_types

tmr input capture config type More...

#include <at32f413_tmr.h>

Data Fields

tmr_channel_select_type input_channel_select
tmr_input_polarity_type input_polarity_select
tmr_input_direction_mapped_type input_mapped_select
uint8_t input_filter_value

Detailed Description

tmr input capture config type

Definition at line 411 of file at32f413_tmr.h.

Field Documentation

◆ input_channel_select

tmr_channel_select_type tmr_input_config_type::input_channel_select

tmr input channel select

Definition at line 413 of file at32f413_tmr.h.

Referenced by main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

◆ input_filter_value

uint8_t tmr_input_config_type::input_filter_value

tmr channel filter value

Definition at line 416 of file at32f413_tmr.h.

Referenced by main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

◆ input_mapped_select

tmr_input_direction_mapped_type tmr_input_config_type::input_mapped_select

tmr channel mapped direct or indirect

Definition at line 415 of file at32f413_tmr.h.

Referenced by main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

◆ input_polarity_select

tmr_input_polarity_type tmr_input_config_type::input_polarity_select

tmr input polarity select

Definition at line 414 of file at32f413_tmr.h.

Referenced by main(), tmr_input_channel_init(), tmr_input_default_para_init(), and tmr_pwm_input_config().

The documentation for this struct was generated from the following file:
  • at32f413_tmr.h


AT32F413 Firmwary Library: tmr_brkdt_config_type Struct Reference

Data Fields
tmr_brkdt_config_type Struct Reference
AT32F413_periph_driver » TMR » TMR_exported_types

tmr brkdt config type More...

#include <at32f413_tmr.h>

Data Fields

uint8_t deadtime
tmr_brk_polarity_type brk_polarity
tmr_wp_level_type wp_level
confirm_state auto_output_enable
confirm_state fcsoen_state
confirm_state fcsodis_state
confirm_state brk_enable

Detailed Description

tmr brkdt config type

Definition at line 422 of file at32f413_tmr.h.

Field Documentation

◆ auto_output_enable

confirm_state tmr_brkdt_config_type::auto_output_enable

automatic output enable

Definition at line 427 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ brk_enable

confirm_state tmr_brkdt_config_type::brk_enable

tmr brk enale

Definition at line 430 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ brk_polarity

tmr_brk_polarity_type tmr_brkdt_config_type::brk_polarity

tmr brake polarity

Definition at line 425 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ deadtime

uint8_t tmr_brkdt_config_type::deadtime

dead-time generator setup

Definition at line 424 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ fcsodis_state

confirm_state tmr_brkdt_config_type::fcsodis_state

frozen channel status when output disable

Definition at line 429 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ fcsoen_state

confirm_state tmr_brkdt_config_type::fcsoen_state

frozen channel status when output enable

Definition at line 428 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

◆ wp_level

tmr_wp_level_type tmr_brkdt_config_type::wp_level

write protect configuration

Definition at line 426 of file at32f413_tmr.h.

Referenced by main(), tmr_brkdt_config(), and tmr_brkdt_default_para_init().

The documentation for this struct was generated from the following file:
  • at32f413_tmr.h


AT32F413 Firmwary Library: tmr_type Struct Reference

Data Fields
tmr_type Struct Reference
AT32F413_periph_driver » TMR » TMR_exported_types

type define tmr register all More...

#include <at32f413_tmr.h>

Data Fields

union {
__IO uint32_t ctrl1
struct {
__IO uint32_t tmren: 1
__IO uint32_t ovfen: 1
__IO uint32_t ovfs: 1
__IO uint32_t ocmen: 1
__IO uint32_t cnt_dir: 3
__IO uint32_t prben: 1
__IO uint32_t clkdiv: 2
__IO uint32_t pmen: 1
__IO uint32_t reserved1: 21
} ctrl1_bit
};
tmr ctrl1 register, offset:0x00 More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t cbctrl: 1
__IO uint32_t reserved1: 1
__IO uint32_t ccfs: 1
__IO uint32_t drs: 1
__IO uint32_t ptos: 3
__IO uint32_t c1insel: 1
__IO uint32_t c1ios: 1
__IO uint32_t c1cios: 1
__IO uint32_t c2ios: 1
__IO uint32_t c2cios: 1
__IO uint32_t c3ios: 1
__IO uint32_t c3cios: 1
__IO uint32_t c4ios: 1
__IO uint32_t reserved2: 17
} ctrl2_bit
};
tmr ctrl2 register, offset:0x04 More...
union {
__IO uint32_t stctrl
struct {
__IO uint32_t smsel: 3
__IO uint32_t reserved1: 1
__IO uint32_t stis: 3
__IO uint32_t sts: 1
__IO uint32_t esf: 4
__IO uint32_t esdiv: 2
__IO uint32_t ecmben: 1
__IO uint32_t esp: 1
__IO uint32_t reserved2: 16
} stctrl_bit
};
tmr smc register, offset:0x08 More...
union {
__IO uint32_t iden
struct {
__IO uint32_t ovfien: 1
__IO uint32_t c1ien: 1
__IO uint32_t c2ien: 1
__IO uint32_t c3ien: 1
__IO uint32_t c4ien: 1
__IO uint32_t hallien: 1
__IO uint32_t tien: 1
__IO uint32_t brkie: 1
__IO uint32_t ovfden: 1
__IO uint32_t c1den: 1
__IO uint32_t c2den: 1
__IO uint32_t c3den: 1
__IO uint32_t c4den: 1
__IO uint32_t hallde: 1
__IO uint32_t tden: 1
__IO uint32_t reserved1: 17
} iden_bit
};
tmr die register, offset:0x0C More...
union {
__IO uint32_t ists
struct {
__IO uint32_t ovfif: 1
__IO uint32_t c1if: 1
__IO uint32_t c2if: 1
__IO uint32_t c3if: 1
__IO uint32_t c4if: 1
__IO uint32_t hallif: 1
__IO uint32_t trgif: 1
__IO uint32_t brkif: 1
__IO uint32_t reserved1: 1
__IO uint32_t c1rf: 1
__IO uint32_t c2rf: 1
__IO uint32_t c3rf: 1
__IO uint32_t c4rf: 1
__IO uint32_t reserved2: 19
} ists_bit
};
tmr ists register, offset:0x10 More...
union {
__IO uint32_t swevt
struct {
__IO uint32_t ovfswtr: 1
__IO uint32_t c1swtr: 1
__IO uint32_t c2swtr: 1
__IO uint32_t c3swtr: 1
__IO uint32_t c4swtr: 1
__IO uint32_t hallswtr: 1
__IO uint32_t trgswtr: 1
__IO uint32_t brkswtr: 1
__IO uint32_t reserved: 24
} swevt_bit
};
tmr eveg register, offset:0x14 More...
union {
__IO uint32_t cm1
struct {
__IO uint32_t c1c: 2
__IO uint32_t c1oien: 1
__IO uint32_t c1oben: 1
__IO uint32_t c1octrl: 3
__IO uint32_t c1osen: 1
__IO uint32_t c2c: 2
__IO uint32_t c2oien: 1
__IO uint32_t c2oben: 1
__IO uint32_t c2octrl: 3
__IO uint32_t c2osen: 1
__IO uint32_t reserved1: 16
} cm1_output_bit
channel mode More...
struct {
__IO uint32_t c1c: 2
__IO uint32_t c1idiv: 2
__IO uint32_t c1df: 4
__IO uint32_t c2c: 2
__IO uint32_t c2idiv: 2
__IO uint32_t c2df: 4
__IO uint32_t reserved1: 16
} cm1_input_bit
input capture mode More...
};
tmr ccm1 register, offset:0x18 More...
union {
__IO uint32_t cm2
struct {
__IO uint32_t c3c: 2
__IO uint32_t c3oien: 1
__IO uint32_t c3oben: 1
__IO uint32_t c3octrl: 3
__IO uint32_t c3osen: 1
__IO uint32_t c4c: 2
__IO uint32_t c4oien: 1
__IO uint32_t c4oben: 1
__IO uint32_t c4octrl: 3
__IO uint32_t c4osen: 1
__IO uint32_t reserved1: 16
} cm2_output_bit
channel mode More...
struct {
__IO uint32_t c3c: 2
__IO uint32_t c3idiv: 2
__IO uint32_t c3df: 4
__IO uint32_t c4c: 2
__IO uint32_t c4idiv: 2
__IO uint32_t c4df: 4
__IO uint32_t reserved1: 16
} cm2_input_bit
input capture mode More...
};
tmr ccm2 register, offset:0x1C More...
union {
uint32_t cctrl
struct {
__IO uint32_t c1en: 1
__IO uint32_t c1p: 1
__IO uint32_t c1cen: 1
__IO uint32_t c1cp: 1
__IO uint32_t c2en: 1
__IO uint32_t c2p: 1
__IO uint32_t c2cen: 1
__IO uint32_t c2cp: 1
__IO uint32_t c3en: 1
__IO uint32_t c3p: 1
__IO uint32_t c3cen: 1
__IO uint32_t c3cp: 1
__IO uint32_t c4en: 1
__IO uint32_t c4p: 1
__IO uint32_t reserved1: 18
} cctrl_bit
};
tmr cce register, offset:0x20 More...
union {
__IO uint32_t cval
struct {
__IO uint32_t cval: 32
} cval_bit
};
tmr cnt register, offset:0x24 More...
union {
__IO uint32_t div
struct {
__IO uint32_t div: 16
__IO uint32_t reserved1: 16
} div_bit
};
tmr div, offset:0x28 More...
union {
__IO uint32_t pr
struct {
__IO uint32_t pr: 32
} pr_bit
};
tmr pr register, offset:0x2C More...
union {
__IO uint32_t rpr
struct {
__IO uint32_t rpr: 8
__IO uint32_t reserved1: 24
} rpr_bit
};
tmr rpr register, offset:0x30 More...
union {
uint32_t c1dt
struct {
__IO uint32_t c1dt: 32
} c1dt_bit
};
tmr c1dt register, offset:0x34 More...
union {
uint32_t c2dt
struct {
__IO uint32_t c2dt: 32
} c2dt_bit
};
tmr c2dt register, offset:0x38 More...
union {
__IO uint32_t c3dt
struct {
__IO uint32_t c3dt: 32
} c3dt_bit
};
tmr c3dt register, offset:0x3C More...
union {
__IO uint32_t c4dt
struct {
__IO uint32_t c4dt: 32
} c4dt_bit
};
tmr c4dt register, offset:0x40 More...
union {
__IO uint32_t brk
struct {
__IO uint32_t dtc: 8
__IO uint32_t wpc: 2
__IO uint32_t fcsodis: 1
__IO uint32_t fcsoen: 1
__IO uint32_t brken: 1
__IO uint32_t brkv: 1
__IO uint32_t aoen: 1
__IO uint32_t oen: 1
__IO uint32_t reserved1: 16
} brk_bit
};
tmr brk register, offset:0x44 More...
union {
__IO uint32_t dmactrl
struct {
__IO uint32_t addr: 5
__IO uint32_t reserved1: 3
__IO uint32_t dtb: 5
__IO uint32_t reserved2: 19
} dmactrl_bit
};
tmr dmactrl register, offset:0x48 More...
union {
__IO uint32_t dmadt
struct {
__IO uint32_t dmadt: 16
__IO uint32_t reserved1: 16
} dmadt_bit
};
tmr dmadt register, offset:0x4C More...

Detailed Description

type define tmr register all

Definition at line 436 of file at32f413_tmr.h.

Field Documentation

◆

union { ... } tmr_type::@649

tmr ctrl1 register, offset:0x00

◆

union { ... } tmr_type::@651

tmr ctrl2 register, offset:0x04

◆

union { ... } tmr_type::@653

tmr smc register, offset:0x08

◆

union { ... } tmr_type::@655

tmr die register, offset:0x0C

◆

union { ... } tmr_type::@657

tmr ists register, offset:0x10

◆

union { ... } tmr_type::@659

tmr eveg register, offset:0x14

◆

union { ... } tmr_type::@661

tmr ccm1 register, offset:0x18

◆

union { ... } tmr_type::@663

tmr ccm2 register, offset:0x1C

◆

union { ... } tmr_type::@665

tmr cce register, offset:0x20

◆

union { ... } tmr_type::@667

tmr cnt register, offset:0x24

◆

union { ... } tmr_type::@669

tmr div, offset:0x28

◆

union { ... } tmr_type::@671

tmr pr register, offset:0x2C

◆

union { ... } tmr_type::@673

tmr rpr register, offset:0x30

◆

union { ... } tmr_type::@675

tmr c1dt register, offset:0x34

◆

union { ... } tmr_type::@677

tmr c2dt register, offset:0x38

◆

union { ... } tmr_type::@679

tmr c3dt register, offset:0x3C

◆

union { ... } tmr_type::@681

tmr c4dt register, offset:0x40

◆

union { ... } tmr_type::@683

tmr brk register, offset:0x44

◆

union { ... } tmr_type::@685

tmr dmactrl register, offset:0x48

◆

union { ... } tmr_type::@687

tmr dmadt register, offset:0x4C

◆ addr

__IO uint32_t tmr_type::addr

Definition at line 806 of file at32f413_tmr.h.

Referenced by tmr_dma_control_config().

◆ aoen

__IO uint32_t tmr_type::aoen

Definition at line 793 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ brk

__IO uint32_t tmr_type::brk

Definition at line 784 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::brk_bit

Referenced by tmr_brkdt_config(), and tmr_output_enable().

◆ brken

__IO uint32_t tmr_type::brken

Definition at line 791 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ brkie

__IO uint32_t tmr_type::brkie

Definition at line 518 of file at32f413_tmr.h.

◆ brkif

__IO uint32_t tmr_type::brkif

Definition at line 545 of file at32f413_tmr.h.

◆ brkswtr

__IO uint32_t tmr_type::brkswtr

Definition at line 570 of file at32f413_tmr.h.

◆ brkv

__IO uint32_t tmr_type::brkv

Definition at line 792 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ c1c

__IO uint32_t tmr_type::c1c

Definition at line 587 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1cen

__IO uint32_t tmr_type::c1cen

Definition at line 665 of file at32f413_tmr.h.

Referenced by tmr_channel_enable().

◆ c1cios

__IO uint32_t tmr_type::c1cios

Definition at line 473 of file at32f413_tmr.h.

◆ c1cp

__IO uint32_t tmr_type::c1cp

Definition at line 666 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c1den

__IO uint32_t tmr_type::c1den

Definition at line 520 of file at32f413_tmr.h.

◆ c1df

__IO uint32_t tmr_type::c1df

Definition at line 607 of file at32f413_tmr.h.

Referenced by tmr_input_channel_filter_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1dt [1/2]

uint32_t tmr_type::c1dt

Definition at line 736 of file at32f413_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆ c1dt [2/2]

__IO uint32_t tmr_type::c1dt

Definition at line 739 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::c1dt_bit

◆ c1en

__IO uint32_t tmr_type::c1en

Definition at line 663 of file at32f413_tmr.h.

Referenced by tmr_channel_enable(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1idiv

__IO uint32_t tmr_type::c1idiv

Definition at line 606 of file at32f413_tmr.h.

Referenced by tmr_input_channel_divider_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c1ien

__IO uint32_t tmr_type::c1ien

Definition at line 512 of file at32f413_tmr.h.

◆ c1if

__IO uint32_t tmr_type::c1if

Definition at line 539 of file at32f413_tmr.h.

◆ c1insel

__IO uint32_t tmr_type::c1insel

Definition at line 471 of file at32f413_tmr.h.

Referenced by tmr_channel1_input_select().

◆ c1ios

__IO uint32_t tmr_type::c1ios

Definition at line 472 of file at32f413_tmr.h.

◆ c1oben

__IO uint32_t tmr_type::c1oben

Definition at line 589 of file at32f413_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c1octrl

__IO uint32_t tmr_type::c1octrl

Definition at line 590 of file at32f413_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c1oien

__IO uint32_t tmr_type::c1oien

Definition at line 588 of file at32f413_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c1osen

__IO uint32_t tmr_type::c1osen

Definition at line 591 of file at32f413_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c1p

__IO uint32_t tmr_type::c1p

Definition at line 664 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), tmr_output_channel_polarity_set(), and tmr_pwm_input_config().

◆ c1rf

__IO uint32_t tmr_type::c1rf

Definition at line 547 of file at32f413_tmr.h.

◆ c1swtr

__IO uint32_t tmr_type::c1swtr

Definition at line 564 of file at32f413_tmr.h.

◆ c2c

__IO uint32_t tmr_type::c2c

Definition at line 592 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2cen

__IO uint32_t tmr_type::c2cen

Definition at line 669 of file at32f413_tmr.h.

Referenced by tmr_channel_enable().

◆ c2cios

__IO uint32_t tmr_type::c2cios

Definition at line 475 of file at32f413_tmr.h.

◆ c2cp

__IO uint32_t tmr_type::c2cp

Definition at line 670 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c2den

__IO uint32_t tmr_type::c2den

Definition at line 521 of file at32f413_tmr.h.

◆ c2df

__IO uint32_t tmr_type::c2df

Definition at line 610 of file at32f413_tmr.h.

Referenced by tmr_input_channel_filter_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2dt [1/2]

uint32_t tmr_type::c2dt

Definition at line 748 of file at32f413_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆ c2dt [2/2]

__IO uint32_t tmr_type::c2dt

Definition at line 751 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::c2dt_bit

◆ c2en

__IO uint32_t tmr_type::c2en

Definition at line 667 of file at32f413_tmr.h.

Referenced by tmr_channel_enable(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2idiv

__IO uint32_t tmr_type::c2idiv

Definition at line 609 of file at32f413_tmr.h.

Referenced by tmr_input_channel_divider_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆ c2ien

__IO uint32_t tmr_type::c2ien

Definition at line 513 of file at32f413_tmr.h.

◆ c2if

__IO uint32_t tmr_type::c2if

Definition at line 540 of file at32f413_tmr.h.

◆ c2ios

__IO uint32_t tmr_type::c2ios

Definition at line 474 of file at32f413_tmr.h.

◆ c2oben

__IO uint32_t tmr_type::c2oben

Definition at line 594 of file at32f413_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c2octrl

__IO uint32_t tmr_type::c2octrl

Definition at line 595 of file at32f413_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c2oien

__IO uint32_t tmr_type::c2oien

Definition at line 593 of file at32f413_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c2osen

__IO uint32_t tmr_type::c2osen

Definition at line 596 of file at32f413_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c2p

__IO uint32_t tmr_type::c2p

Definition at line 668 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_input_channel_init(), tmr_output_channel_polarity_set(), and tmr_pwm_input_config().

◆ c2rf

__IO uint32_t tmr_type::c2rf

Definition at line 548 of file at32f413_tmr.h.

◆ c2swtr

__IO uint32_t tmr_type::c2swtr

Definition at line 565 of file at32f413_tmr.h.

◆ c3c

__IO uint32_t tmr_type::c3c

Definition at line 627 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init().

◆ c3cen

__IO uint32_t tmr_type::c3cen

Definition at line 673 of file at32f413_tmr.h.

Referenced by tmr_channel_enable().

◆ c3cios

__IO uint32_t tmr_type::c3cios

Definition at line 477 of file at32f413_tmr.h.

◆ c3cp

__IO uint32_t tmr_type::c3cp

Definition at line 674 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c3den

__IO uint32_t tmr_type::c3den

Definition at line 522 of file at32f413_tmr.h.

◆ c3df

__IO uint32_t tmr_type::c3df

Definition at line 647 of file at32f413_tmr.h.

Referenced by tmr_input_channel_filter_set(), and tmr_input_channel_init().

◆ c3dt

__IO uint32_t tmr_type::c3dt

Definition at line 760 of file at32f413_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆

struct { ... } tmr_type::c3dt_bit

◆ c3en

__IO uint32_t tmr_type::c3en

Definition at line 671 of file at32f413_tmr.h.

Referenced by tmr_channel_enable(), and tmr_input_channel_init().

◆ c3idiv

__IO uint32_t tmr_type::c3idiv

Definition at line 646 of file at32f413_tmr.h.

Referenced by tmr_input_channel_divider_set(), and tmr_input_channel_init().

◆ c3ien

__IO uint32_t tmr_type::c3ien

Definition at line 514 of file at32f413_tmr.h.

◆ c3if

__IO uint32_t tmr_type::c3if

Definition at line 541 of file at32f413_tmr.h.

◆ c3ios

__IO uint32_t tmr_type::c3ios

Definition at line 476 of file at32f413_tmr.h.

◆ c3oben

__IO uint32_t tmr_type::c3oben

Definition at line 629 of file at32f413_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c3octrl

__IO uint32_t tmr_type::c3octrl

Definition at line 630 of file at32f413_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c3oien

__IO uint32_t tmr_type::c3oien

Definition at line 628 of file at32f413_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c3osen

__IO uint32_t tmr_type::c3osen

Definition at line 631 of file at32f413_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c3p

__IO uint32_t tmr_type::c3p

Definition at line 672 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c3rf

__IO uint32_t tmr_type::c3rf

Definition at line 549 of file at32f413_tmr.h.

◆ c3swtr

__IO uint32_t tmr_type::c3swtr

Definition at line 566 of file at32f413_tmr.h.

◆ c4c

__IO uint32_t tmr_type::c4c

Definition at line 632 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init().

◆ c4den

__IO uint32_t tmr_type::c4den

Definition at line 523 of file at32f413_tmr.h.

◆ c4df

__IO uint32_t tmr_type::c4df

Definition at line 650 of file at32f413_tmr.h.

Referenced by tmr_input_channel_filter_set(), and tmr_input_channel_init().

◆ c4dt

__IO uint32_t tmr_type::c4dt

Definition at line 772 of file at32f413_tmr.h.

Referenced by tmr_channel_value_get(), and tmr_channel_value_set().

◆

struct { ... } tmr_type::c4dt_bit

◆ c4en

__IO uint32_t tmr_type::c4en

Definition at line 675 of file at32f413_tmr.h.

Referenced by tmr_channel_enable(), and tmr_input_channel_init().

◆ c4idiv

__IO uint32_t tmr_type::c4idiv

Definition at line 649 of file at32f413_tmr.h.

Referenced by tmr_input_channel_divider_set(), and tmr_input_channel_init().

◆ c4ien

__IO uint32_t tmr_type::c4ien

Definition at line 515 of file at32f413_tmr.h.

◆ c4if

__IO uint32_t tmr_type::c4if

Definition at line 542 of file at32f413_tmr.h.

◆ c4ios

__IO uint32_t tmr_type::c4ios

Definition at line 478 of file at32f413_tmr.h.

◆ c4oben

__IO uint32_t tmr_type::c4oben

Definition at line 634 of file at32f413_tmr.h.

Referenced by tmr_output_channel_buffer_enable().

◆ c4octrl

__IO uint32_t tmr_type::c4octrl

Definition at line 635 of file at32f413_tmr.h.

Referenced by tmr_force_output_set(), tmr_output_channel_config(), and tmr_output_channel_mode_select().

◆ c4oien

__IO uint32_t tmr_type::c4oien

Definition at line 633 of file at32f413_tmr.h.

Referenced by tmr_output_channel_immediately_set().

◆ c4osen

__IO uint32_t tmr_type::c4osen

Definition at line 636 of file at32f413_tmr.h.

Referenced by tmr_output_channel_switch_set().

◆ c4p

__IO uint32_t tmr_type::c4p

Definition at line 676 of file at32f413_tmr.h.

Referenced by tmr_input_channel_init(), and tmr_output_channel_polarity_set().

◆ c4rf

__IO uint32_t tmr_type::c4rf

Definition at line 550 of file at32f413_tmr.h.

◆ c4swtr

__IO uint32_t tmr_type::c4swtr

Definition at line 567 of file at32f413_tmr.h.

◆ cbctrl

__IO uint32_t tmr_type::cbctrl

Definition at line 466 of file at32f413_tmr.h.

Referenced by tmr_channel_buffer_enable().

◆ ccfs

__IO uint32_t tmr_type::ccfs

Definition at line 468 of file at32f413_tmr.h.

Referenced by tmr_hall_select().

◆ cctrl

uint32_t tmr_type::cctrl

Definition at line 660 of file at32f413_tmr.h.

Referenced by tmr_output_channel_config().

◆

struct { ... } tmr_type::cctrl_bit

Referenced by tmr_channel_enable(), tmr_encoder_mode_config(), tmr_input_channel_init(), tmr_output_channel_polarity_set(), and tmr_pwm_input_config().

◆ clkdiv

__IO uint32_t tmr_type::clkdiv

Definition at line 452 of file at32f413_tmr.h.

Referenced by tmr_clock_source_div_set().

◆ cm1

__IO uint32_t tmr_type::cm1

Definition at line 580 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::cm1_input_bit

input capture mode

Referenced by tmr_encoder_mode_config(), tmr_input_channel_divider_set(), tmr_input_channel_filter_set(), tmr_input_channel_init(), and tmr_pwm_input_config().

◆

struct { ... } tmr_type::cm1_output_bit

channel mode

Referenced by tmr_force_output_set(), tmr_output_channel_buffer_enable(), tmr_output_channel_config(), tmr_output_channel_immediately_set(), tmr_output_channel_mode_select(), and tmr_output_channel_switch_set().

◆ cm2

__IO uint32_t tmr_type::cm2

Definition at line 620 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::cm2_input_bit

input capture mode

Referenced by tmr_input_channel_divider_set(), tmr_input_channel_filter_set(), and tmr_input_channel_init().

◆

struct { ... } tmr_type::cm2_output_bit

channel mode

Referenced by tmr_force_output_set(), tmr_output_channel_buffer_enable(), tmr_output_channel_config(), tmr_output_channel_immediately_set(), tmr_output_channel_mode_select(), and tmr_output_channel_switch_set().

◆ cnt_dir

__IO uint32_t tmr_type::cnt_dir

Definition at line 450 of file at32f413_tmr.h.

Referenced by tmr_cnt_dir_set().

◆ ctrl1

__IO uint32_t tmr_type::ctrl1

Definition at line 443 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::ctrl1_bit

Referenced by tmr_32_bit_function_enable(), tmr_clock_source_div_set(), tmr_cnt_dir_set(), tmr_counter_enable(), tmr_one_cycle_mode_enable(), tmr_overflow_event_disable(), tmr_overflow_request_source_set(), and tmr_period_buffer_enable().

◆ ctrl2

__IO uint32_t tmr_type::ctrl2

Definition at line 463 of file at32f413_tmr.h.

Referenced by tmr_output_channel_config().

◆

struct { ... } tmr_type::ctrl2_bit

Referenced by tmr_channel1_input_select(), tmr_channel_buffer_enable(), tmr_channel_dma_select(), tmr_hall_select(), and tmr_primary_mode_select().

◆ cval

__IO uint32_t tmr_type::cval

Definition at line 686 of file at32f413_tmr.h.

Referenced by tmr_counter_value_get(), and tmr_counter_value_set().

◆

struct { ... } tmr_type::cval_bit

◆ div

__IO uint32_t tmr_type::div

Definition at line 698 of file at32f413_tmr.h.

Referenced by tmr_base_init(), tmr_div_value_get(), and tmr_div_value_set().

◆

struct { ... } tmr_type::div_bit

◆ dmactrl

__IO uint32_t tmr_type::dmactrl

Definition at line 803 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::dmactrl_bit

Referenced by tmr_dma_control_config().

◆ dmadt

__IO uint32_t tmr_type::dmadt

Definition at line 818 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::dmadt_bit

◆ drs

__IO uint32_t tmr_type::drs

Definition at line 469 of file at32f413_tmr.h.

Referenced by tmr_channel_dma_select().

◆ dtb

__IO uint32_t tmr_type::dtb

Definition at line 808 of file at32f413_tmr.h.

Referenced by tmr_dma_control_config().

◆ dtc

__IO uint32_t tmr_type::dtc

Definition at line 787 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ ecmben

__IO uint32_t tmr_type::ecmben

Definition at line 497 of file at32f413_tmr.h.

Referenced by tmr_external_clock_mode2_config().

◆ esdiv

__IO uint32_t tmr_type::esdiv

Definition at line 496 of file at32f413_tmr.h.

Referenced by tmr_external_clock_config().

◆ esf

__IO uint32_t tmr_type::esf

Definition at line 495 of file at32f413_tmr.h.

Referenced by tmr_external_clock_config().

◆ esp

__IO uint32_t tmr_type::esp

Definition at line 498 of file at32f413_tmr.h.

Referenced by tmr_external_clock_config().

◆ fcsodis

__IO uint32_t tmr_type::fcsodis

Definition at line 789 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ fcsoen

__IO uint32_t tmr_type::fcsoen

Definition at line 790 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

◆ hallde

__IO uint32_t tmr_type::hallde

Definition at line 524 of file at32f413_tmr.h.

◆ hallien

__IO uint32_t tmr_type::hallien

Definition at line 516 of file at32f413_tmr.h.

◆ hallif

__IO uint32_t tmr_type::hallif

Definition at line 543 of file at32f413_tmr.h.

◆ hallswtr

__IO uint32_t tmr_type::hallswtr

Definition at line 568 of file at32f413_tmr.h.

◆ iden

__IO uint32_t tmr_type::iden

Definition at line 508 of file at32f413_tmr.h.

Referenced by tmr_dma_request_enable(), and tmr_interrupt_enable().

◆

struct { ... } tmr_type::iden_bit

◆ ists

__IO uint32_t tmr_type::ists

Definition at line 535 of file at32f413_tmr.h.

Referenced by tmr_flag_clear(), and tmr_flag_get().

◆

struct { ... } tmr_type::ists_bit

◆ ocmen

__IO uint32_t tmr_type::ocmen

Definition at line 449 of file at32f413_tmr.h.

Referenced by tmr_one_cycle_mode_enable().

◆ oen

__IO uint32_t tmr_type::oen

Definition at line 794 of file at32f413_tmr.h.

Referenced by tmr_output_enable().

◆ ovfden

__IO uint32_t tmr_type::ovfden

Definition at line 519 of file at32f413_tmr.h.

◆ ovfen

__IO uint32_t tmr_type::ovfen

Definition at line 447 of file at32f413_tmr.h.

Referenced by tmr_overflow_event_disable().

◆ ovfien

__IO uint32_t tmr_type::ovfien

Definition at line 511 of file at32f413_tmr.h.

◆ ovfif

__IO uint32_t tmr_type::ovfif

Definition at line 538 of file at32f413_tmr.h.

◆ ovfs

__IO uint32_t tmr_type::ovfs

Definition at line 448 of file at32f413_tmr.h.

Referenced by tmr_overflow_request_source_set().

◆ ovfswtr

__IO uint32_t tmr_type::ovfswtr

Definition at line 563 of file at32f413_tmr.h.

Referenced by tmr_base_init().

◆ pmen

__IO uint32_t tmr_type::pmen

Definition at line 453 of file at32f413_tmr.h.

Referenced by tmr_32_bit_function_enable().

◆ pr

__IO uint32_t tmr_type::pr

Definition at line 711 of file at32f413_tmr.h.

Referenced by tmr_base_init(), tmr_period_value_get(), and tmr_period_value_set().

◆

struct { ... } tmr_type::pr_bit

◆ prben

__IO uint32_t tmr_type::prben

Definition at line 451 of file at32f413_tmr.h.

Referenced by tmr_period_buffer_enable().

◆ ptos

__IO uint32_t tmr_type::ptos

Definition at line 470 of file at32f413_tmr.h.

Referenced by tmr_primary_mode_select().

◆ reserved

__IO uint32_t tmr_type::reserved

Definition at line 571 of file at32f413_tmr.h.

◆ reserved1

__IO uint32_t tmr_type::reserved1

Definition at line 454 of file at32f413_tmr.h.

◆ reserved2

__IO uint32_t tmr_type::reserved2

Definition at line 479 of file at32f413_tmr.h.

◆ rpr

__IO uint32_t tmr_type::rpr

Definition at line 723 of file at32f413_tmr.h.

Referenced by tmr_repetition_counter_set().

◆

struct { ... } tmr_type::rpr_bit

Referenced by tmr_repetition_counter_set().

◆ smsel

__IO uint32_t tmr_type::smsel

Definition at line 491 of file at32f413_tmr.h.

Referenced by tmr_encoder_mode_config(), tmr_external_clock_mode1_config(), tmr_internal_clock_set(), and tmr_sub_mode_select().

◆ stctrl

__IO uint32_t tmr_type::stctrl

Definition at line 488 of file at32f413_tmr.h.

◆

struct { ... } tmr_type::stctrl_bit

Referenced by tmr_encoder_mode_config(), tmr_external_clock_config(), tmr_external_clock_mode1_config(), tmr_external_clock_mode2_config(), tmr_internal_clock_set(), tmr_sub_mode_select(), tmr_sub_sync_mode_set(), and tmr_trigger_input_select().

◆ stis

__IO uint32_t tmr_type::stis

Definition at line 493 of file at32f413_tmr.h.

Referenced by tmr_external_clock_mode1_config(), and tmr_trigger_input_select().

◆ sts

__IO uint32_t tmr_type::sts

Definition at line 494 of file at32f413_tmr.h.

Referenced by tmr_sub_sync_mode_set().

◆ swevt

__IO uint32_t tmr_type::swevt

Definition at line 560 of file at32f413_tmr.h.

Referenced by tmr_event_sw_trigger().

◆

struct { ... } tmr_type::swevt_bit

Referenced by tmr_base_init().

◆ tden

__IO uint32_t tmr_type::tden

Definition at line 525 of file at32f413_tmr.h.

◆ tien

__IO uint32_t tmr_type::tien

Definition at line 517 of file at32f413_tmr.h.

◆ tmren

__IO uint32_t tmr_type::tmren

Definition at line 446 of file at32f413_tmr.h.

Referenced by tmr_counter_enable().

◆ trgif

__IO uint32_t tmr_type::trgif

Definition at line 544 of file at32f413_tmr.h.

◆ trgswtr

__IO uint32_t tmr_type::trgswtr

Definition at line 569 of file at32f413_tmr.h.

◆ wpc

__IO uint32_t tmr_type::wpc

Definition at line 788 of file at32f413_tmr.h.

Referenced by tmr_brkdt_config().

The documentation for this struct was generated from the following file:
  • at32f413_tmr.h


AT32F413 Firmwary Library: TMR_exported_functions

Functions
TMR_exported_functions
AT32F413_periph_driver » TMR

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ti1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time More...

Detailed Description

Function Documentation

◆ tmr_32_bit_function_enable()

void tmr_32_bit_function_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr 32 bit function(plus mode)

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR2, TMR5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 754 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_base_init()

void tmr_base_init | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr,
 |  | uint32_t | tmr_div
 | ) |  |

init tmr base

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_pr | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
tmr_div | (timer div value:0x0000~0xFFFF)
Return values
none

Definition at line 175 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_brkdt_config()

void tmr_brkdt_config | ( | tmr_type * | tmr_x,
 |  | tmr_brkdt_config_type * | brkdt_struct
 | ) |  |

config tmr break mode and dead-time

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 1715 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_brkdt_default_para_init()

void tmr_brkdt_default_para_init ( tmr_brkdt_config_type * tmr_brkdt_struct )

init tmr brkdt default para

Parameters
tmr_brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 153 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel1_input_select()

void tmr_channel1_input_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel1_input_connected_type | ti1_connect
 | ) |  |

select tmr channel1 input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
ti1_connect this parameter can be one of the following values:
  • TMR_CHANEL1_CONNECTED_C1IRAW
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Return values
none

Definition at line 1085 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel_buffer_enable()

void tmr_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable tmr channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1221 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel_dma_select()

void tmr_channel_dma_select | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_source_type | cc_dma_select
 | ) |  |

select tmr channel dma

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
cc_dma_select this parameter can be one of the following values:
  • TMR_DMA_REQUEST_BY_CHANNEL
  • TMR_DMA_REQUEST_BY_OVERFLOW
Return values
none

Definition at line 1195 of file at32f413_tmr.c.

◆ tmr_channel_enable()

void tmr_channel_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

tmr channel enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_3C
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 875 of file at32f413_tmr.c.

Referenced by main(), and TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_channel_value_get()

uint32_t tmr_channel_value_get | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel
 | ) |  |

get tmr channel value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
Return values
tmr channel value

Definition at line 547 of file at32f413_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_channel_value_set()

void tmr_channel_value_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint32_t | tmr_channel_value
 | ) |  |

set tmr channel value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
tmr_channel_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 502 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), TMR1_BRK_TMR9_IRQHandler(), tmr1_config(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_clock_source_div_set()

void tmr_clock_source_div_set | ( | tmr_type * | tmr_x,
 |  | tmr_clock_division_type | tmr_clock_div
 | ) |  |

set tmr clock source division

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_clock_div this parameter can be one of the following values:
  • TMR_CLOCK_DIV1
  • TMR_CLOCK_DIV2
  • TMR_CLOCK_DIV4
Return values
none

Definition at line 200 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), and tmr2_config().

◆ tmr_cnt_dir_set()

void tmr_cnt_dir_set | ( | tmr_type * | tmr_x,
 |  | tmr_count_mode_type | tmr_cnt_dir
 | ) |  |

set tmr counter count direction

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_cnt_dir this parameter can be one of the following values:
  • TMR_COUNT_UP
  • TMR_COUNT_DOWN
  • TMR_COUNT_TWO_WAY_1
  • TMR_COUNT_TWO_WAY_2
  • TMR_COUNT_TWO_WAY_3
Return values
none

Definition at line 221 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_counter_enable()

void tmr_counter_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr counter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 110 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr2_config(), TMR5_GLOBAL_IRQHandler(), and tmr_init().

◆ tmr_counter_value_get()

uint32_t tmr_counter_value_get ( tmr_type * tmr_x )

get tmr counter value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
tmr counter value

Definition at line 269 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_counter_value_set()

void tmr_counter_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_cnt_value
 | ) |  |

set tmr counter value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_cnt_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 255 of file at32f413_tmr.c.

◆ tmr_div_value_get()

uint32_t tmr_div_value_get ( tmr_type * tmr_x )

get tmr div value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
tmr div value

Definition at line 298 of file at32f413_tmr.c.

◆ tmr_div_value_set()

void tmr_div_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_div_value
 | ) |  |

set tmr div value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_div_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 284 of file at32f413_tmr.c.

◆ tmr_dma_control_config()

void tmr_dma_control_config | ( | tmr_type * | tmr_x,
 |  | tmr_dma_transfer_length_type | dma_length,
 |  | tmr_dma_address_type | dma_base_address
 | ) |  |

config tmr dma control

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
dma_length this parameter can be one of the following values:
  • TMR_DMA_TRANSFER_1BYTE
  • TMR_DMA_TRANSFER_2BYTES
  • TMR_DMA_TRANSFER_3BYTES ...
  • TMR_DMA_TRANSFER_17BYTES
  • TMR_DMA_TRANSFER_18BYTES
dma_base_address this parameter can be one of the following values:
  • TMR_CTRL1_ADDRESS
  • TMR_CTRL2_ADDRESS
  • TMR_STCTRL_ADDRESS
  • TMR_IDEN_ADDRESS
  • TMR_ISTS_ADDRESS
  • TMR_SWEVT_ADDRESS
  • TMR_CM1_ADDRESS
  • TMR_CM2_ADDRESS
  • TMR_CCTRL_ADDRESS
  • TMR_CVAL_ADDRESS
  • TMR_DIV_ADDRESS
  • TMR_PR_ADDRESS
  • TMR_RPR_ADDRESS
  • TMR_C1DT_ADDRESS
  • TMR_C2DT_ADDRESS
  • TMR_C3DT_ADDRESS
  • TMR_C4DT_ADDRESS
  • TMR_BRK_ADDRESS
  • TMR_DMACTRL_ADDRESS
Return values
none

Definition at line 1699 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_dma_request_enable()

void tmr_dma_request_enable | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_type | dma_request,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr dma request

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
dma_request this parameter can be one of the following values:
  • TMR_OVERFLOW_DMA_REQUEST
  • TMR_C1_DMA_REQUEST
  • TMR_C2_DMA_REQUEST
  • TMR_C3_DMA_REQUEST
  • TMR_C4_DMA_REQUEST
  • TMR_HALL_DMA_REQUEST
  • TMR_TRIGGER_DMA_REQUEST
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1279 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_encoder_mode_config()

void tmr_encoder_mode_config | ( | tmr_type * | tmr_x,
 |  | tmr_encoder_mode_type | encoder_mode,
 |  | tmr_input_polarity_type | ic1_polarity,
 |  | tmr_input_polarity_type | ic2_polarity
 | ) |  |

config tmr encoder mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
encoder_mode this parameter can be one of the following values:
  • TMR_ENCODER_MODE_A
  • TMR_ENCODER_MODE_B
  • TMR_ENCODER_MODE_C
ic1_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
ic2_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
Return values
none

Definition at line 1597 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_event_sw_trigger()

void tmr_event_sw_trigger | ( | tmr_type * | tmr_x,
 |  | tmr_event_trigger_type | tmr_event
 | ) |  |

generate tmr event

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_event this parameter can be one of the following values:
  • TMR_OVERFLOW_SWTRIG
  • TMR_C1_SWTRIG
  • TMR_C2_SWTRIG
  • TMR_C3_SWTRIG
  • TMR_C4_SWTRIG
  • TMR_HALL_SWTRIG
  • TMR_TRIGGER_SWTRIG
  • TMR_BRK_SWTRIG
Return values
none

Definition at line 1405 of file at32f413_tmr.c.

Referenced by SysTick_Handler().

◆ tmr_external_clock_config()

void tmr_external_clock_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1516 of file at32f413_tmr.c.

Referenced by tmr_external_clock_mode1_config(), and tmr_external_clock_mode2_config().

◆ tmr_external_clock_mode1_config()

void tmr_external_clock_mode1_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode1

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1542 of file at32f413_tmr.c.

◆ tmr_external_clock_mode2_config()

void tmr_external_clock_mode2_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode2

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1568 of file at32f413_tmr.c.

◆ tmr_flag_clear()

void tmr_flag_clear | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

clear tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_flag this parameter can be any combination of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
none

Definition at line 1382 of file at32f413_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR1_TRG_HALL_TMR11_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_flag_get()

flag_status tmr_flag_get | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

get tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_flag this parameter can be one of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
state of tmr flag

Definition at line 1344 of file at32f413_tmr.c.

Referenced by main(), TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), and TMR5_GLOBAL_IRQHandler().

◆ tmr_force_output_set()

void tmr_force_output_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_force_output_type | force_output
 | ) |  |

set tmr force output

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
force_output this parameter can be one of the following values:
  • TMR_FORCE_OUTPUT_HIGH
  • TMR_FORCE_OUTPUT_LOW
Return values
none

Definition at line 1633 of file at32f413_tmr.c.

◆ tmr_hall_select()

void tmr_hall_select | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr hall

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1208 of file at32f413_tmr.c.

◆ tmr_input_channel_divider_set()

void tmr_input_channel_divider_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

set tmr input channel divider

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 1110 of file at32f413_tmr.c.

◆ tmr_input_channel_filter_set()

void tmr_input_channel_filter_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint16_t | filter_value
 | ) |  |

set tmr input channel filter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
filter_value | (0x0~0xf)
Return values
none

Definition at line 931 of file at32f413_tmr.c.

◆ tmr_input_channel_init()

void tmr_input_channel_init | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

init tmr input channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 807 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_input_default_para_init()

void tmr_input_default_para_init ( tmr_input_config_type * tmr_input_struct )

init tmr input default para

Parameters
tmr_input_struct
  • to the structure of tmr_input_config_type
Return values
none

Definition at line 139 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_internal_clock_set()

void tmr_internal_clock_set ( tmr_type * tmr_x )

set tmr select internal clock

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
Return values
none

Definition at line 1430 of file at32f413_tmr.c.

◆ tmr_interrupt_enable()

void tmr_interrupt_enable | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_interrupt,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr interrupt

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_interrupt this parameter can be one of the following values:
  • TMR_OVF_INT
  • TMR_C1_INT
  • TMR_C2_INT
  • TMR_C3_INT
  • TMR_C4_INT
  • TMR_HALL_INT
  • TMR_TRIGGER_INT
  • TMR_BRK_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1310 of file at32f413_tmr.c.

Referenced by main(), tmr1_config(), tmr2_config(), TMR5_GLOBAL_IRQHandler(), and tmr_init().

◆ tmr_one_cycle_mode_enable()

void tmr_one_cycle_mode_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr one cycle mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
new_state | (TRUE or FALSE)
Return values
none

Definition at line 740 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_output_channel_buffer_enable()

void tmr_output_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

enable tmr output channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 609 of file at32f413_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_output_channel_config()

void tmr_output_channel_config | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_config_type * | tmr_output_struct
 | ) |  |

config tmr output channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 319 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_channel_immediately_set()

void tmr_output_channel_immediately_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel immediately

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 655 of file at32f413_tmr.c.

◆ tmr_output_channel_mode_select()

void tmr_output_channel_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_control_mode_type | oc_mode
 | ) |  |

select tmr output channel mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
oc_mode this parameter can be one of the following values:
  • TMR_OUTPUT_CONTROL_OFF
  • TMR_OUTPUT_CONTROL_HIGH
  • TMR_OUTPUT_CONTROL_LOW
  • TMR_OUTPUT_CONTROL_SWITCH
  • TMR_OUTPUT_CONTROL_FORCE_HIGH
  • TMR_OUTPUT_CONTROL_FORCE_LOW
  • TMR_OUTPUT_CONTROL_PWM_MODE_A
  • TMR_OUTPUT_CONTROL_PWM_MODE_B
Return values
none

Definition at line 425 of file at32f413_tmr.c.

Referenced by TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_output_channel_polarity_set()

void tmr_output_channel_polarity_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_polarity_active_type | oc_polarity
 | ) |  |

set tmr output channel polarity

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3C
oc_polarity this parameter can be one of the following values:
  • TMR_POLARITY_ACTIVE_HIGH
  • TMR_POLARITY_ACTIVE_LOW
Return values
none

Definition at line 1456 of file at32f413_tmr.c.

◆ tmr_output_channel_switch_set()

void tmr_output_channel_switch_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel switch

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 701 of file at32f413_tmr.c.

◆ tmr_output_default_para_init()

void tmr_output_default_para_init ( tmr_output_config_type * tmr_output_struct )

init tmr output default para

Parameters
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 122 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_enable()

void tmr_output_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

tmr output enable(oen),this function is important for advtm output enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1418 of file at32f413_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_overflow_event_disable()

void tmr_overflow_event_disable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr overflow event generation

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 786 of file at32f413_tmr.c.

◆ tmr_overflow_request_source_set()

void tmr_overflow_request_source_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr the overflow event sources

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 772 of file at32f413_tmr.c.

◆ tmr_period_buffer_enable()

void tmr_period_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable tmr period buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 588 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_period_value_get()

uint32_t tmr_period_value_get ( tmr_type * tmr_x )

get tmr period value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)

Definition at line 481 of file at32f413_tmr.c.

◆ tmr_period_value_set()

void tmr_period_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr_value
 | ) |  |

set tmr period value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_pr_value | timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 465 of file at32f413_tmr.c.

◆ tmr_primary_mode_select()

void tmr_primary_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_primary_select_type | primary_mode
 | ) |  |

select tmr primary mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
primary_mode this parameter can be one of the following values:
  • TMR_PRIMARY_SEL_RESET
  • TMR_PRIMARY_SEL_ENABLE
  • TMR_PRIMARY_SEL_OVERFLOW
  • TMR_PRIMARY_SEL_COMPARE
  • TMR_PRIMARY_SEL_C1ORAW
  • TMR_PRIMARY_SEL_C2ORAW
  • TMR_PRIMARY_SEL_C3ORAW
  • TMR_PRIMARY_SEL_C4ORAW
Return values
none

Definition at line 1157 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_pwm_input_config()

void tmr_pwm_input_config | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

config tmr pwm input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 977 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_repetition_counter_set()

void tmr_repetition_counter_set | ( | tmr_type * | tmr_x,
 |  | uint8_t | tmr_rpr_value
 | ) |  |

set the repetition counter register(rpr) value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
tmr_rpr_value | (0x00~0xFF)
Return values
none

Definition at line 235 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_reset()

void tmr_reset ( tmr_type * tmr_x )

tmr reset by crm reset register

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
none

Definition at line 52 of file at32f413_tmr.c.

◆ tmr_sub_mode_select()

void tmr_sub_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_sub_mode_select_type | sub_mode
 | ) |  |

select tmr subordinate mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
sub_mode this parameter can be one of the following values:
  • TMR_SUB_MODE_DIABLE
  • TMR_SUB_ENCODER_MODE_A
  • TMR_SUB_ENCODER_MODE_B
  • TMR_SUB_ENCODER_MODE_C
  • TMR_SUB_RESET_MODE
  • TMR_SUB_HANG_MODE
  • TMR_SUB_TRIGGER_MODE
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A
Return values
none

Definition at line 1179 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_sub_sync_mode_set()

void tmr_sub_sync_mode_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

set tmr subordinate synchronization mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1256 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_trigger_input_select()

void tmr_trigger_input_select | ( | tmr_type * | tmr_x,
 |  | sub_tmr_input_sel_type | trigger_select
 | ) |  |

select tmr sub-trigger

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
trigger_select this parameter can be one of the following values:
  • TMR_SUB_INPUT_SEL_IS0
  • TMR_SUB_INPUT_SEL_IS1
  • TMR_SUB_INPUT_SEL_IS2
  • TMR_SUB_INPUT_SEL_IS3
  • TMR_SUB_INPUT_SEL_C1INC
  • TMR_SUB_INPUT_SEL_C1DF1
  • TMR_SUB_INPUT_SEL_C2DF2
  • TMR_SUB_INPUT_SEL_EXTIN
Return values
none

Definition at line 1243 of file at32f413_tmr.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_private_functions

Functions
TMR_private_functions
AT32F413_periph_driver » TMR

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ti1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time More...

Detailed Description

Function Documentation

◆ tmr_32_bit_function_enable()

void tmr_32_bit_function_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr 32 bit function(plus mode)

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR2, TMR5
new_state | (TRUE or FALSE)
Return values
none

Definition at line 754 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_base_init()

void tmr_base_init | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr,
 |  | uint32_t | tmr_div
 | ) |  |

init tmr base

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_pr | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
tmr_div | (timer div value:0x0000~0xFFFF)
Return values
none

Definition at line 175 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_brkdt_config()

void tmr_brkdt_config | ( | tmr_type * | tmr_x,
 |  | tmr_brkdt_config_type * | brkdt_struct
 | ) |  |

config tmr break mode and dead-time

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 1715 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_brkdt_default_para_init()

void tmr_brkdt_default_para_init ( tmr_brkdt_config_type * tmr_brkdt_struct )

init tmr brkdt default para

Parameters
tmr_brkdt_struct
  • to the structure of tmr_brkdt_config_type
Return values
none

Definition at line 153 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel1_input_select()

void tmr_channel1_input_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel1_input_connected_type | ti1_connect
 | ) |  |

select tmr channel1 input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
ti1_connect this parameter can be one of the following values:
  • TMR_CHANEL1_CONNECTED_C1IRAW
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Return values
none

Definition at line 1085 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel_buffer_enable()

void tmr_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable tmr channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1221 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_channel_dma_select()

void tmr_channel_dma_select | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_source_type | cc_dma_select
 | ) |  |

select tmr channel dma

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
cc_dma_select this parameter can be one of the following values:
  • TMR_DMA_REQUEST_BY_CHANNEL
  • TMR_DMA_REQUEST_BY_OVERFLOW
Return values
none

Definition at line 1195 of file at32f413_tmr.c.

◆ tmr_channel_enable()

void tmr_channel_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

tmr channel enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_3C
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 875 of file at32f413_tmr.c.

Referenced by main(), and TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_channel_value_get()

uint32_t tmr_channel_value_get | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel
 | ) |  |

get tmr channel value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
Return values
tmr channel value

Definition at line 547 of file at32f413_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_channel_value_set()

void tmr_channel_value_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint32_t | tmr_channel_value
 | ) |  |

set tmr channel value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
tmr_channel_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 502 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), TMR1_BRK_TMR9_IRQHandler(), tmr1_config(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_clock_source_div_set()

void tmr_clock_source_div_set | ( | tmr_type * | tmr_x,
 |  | tmr_clock_division_type | tmr_clock_div
 | ) |  |

set tmr clock source division

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_clock_div this parameter can be one of the following values:
  • TMR_CLOCK_DIV1
  • TMR_CLOCK_DIV2
  • TMR_CLOCK_DIV4
Return values
none

Definition at line 200 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), and tmr2_config().

◆ tmr_cnt_dir_set()

void tmr_cnt_dir_set | ( | tmr_type * | tmr_x,
 |  | tmr_count_mode_type | tmr_cnt_dir
 | ) |  |

set tmr counter count direction

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_cnt_dir this parameter can be one of the following values:
  • TMR_COUNT_UP
  • TMR_COUNT_DOWN
  • TMR_COUNT_TWO_WAY_1
  • TMR_COUNT_TWO_WAY_2
  • TMR_COUNT_TWO_WAY_3
Return values
none

Definition at line 221 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr1_config(), tmr2_config(), and tmr_init().

◆ tmr_counter_enable()

void tmr_counter_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr counter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 110 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), tmr2_config(), TMR5_GLOBAL_IRQHandler(), and tmr_init().

◆ tmr_counter_value_get()

uint32_t tmr_counter_value_get ( tmr_type * tmr_x )

get tmr counter value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
tmr counter value

Definition at line 269 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_counter_value_set()

void tmr_counter_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_cnt_value
 | ) |  |

set tmr counter value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_cnt_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 255 of file at32f413_tmr.c.

◆ tmr_div_value_get()

uint32_t tmr_div_value_get ( tmr_type * tmr_x )

get tmr div value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
tmr div value

Definition at line 298 of file at32f413_tmr.c.

◆ tmr_div_value_set()

void tmr_div_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_div_value
 | ) |  |

set tmr div value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_div_value | (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 284 of file at32f413_tmr.c.

◆ tmr_dma_control_config()

void tmr_dma_control_config | ( | tmr_type * | tmr_x,
 |  | tmr_dma_transfer_length_type | dma_length,
 |  | tmr_dma_address_type | dma_base_address
 | ) |  |

config tmr dma control

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
dma_length this parameter can be one of the following values:
  • TMR_DMA_TRANSFER_1BYTE
  • TMR_DMA_TRANSFER_2BYTES
  • TMR_DMA_TRANSFER_3BYTES ...
  • TMR_DMA_TRANSFER_17BYTES
  • TMR_DMA_TRANSFER_18BYTES
dma_base_address this parameter can be one of the following values:
  • TMR_CTRL1_ADDRESS
  • TMR_CTRL2_ADDRESS
  • TMR_STCTRL_ADDRESS
  • TMR_IDEN_ADDRESS
  • TMR_ISTS_ADDRESS
  • TMR_SWEVT_ADDRESS
  • TMR_CM1_ADDRESS
  • TMR_CM2_ADDRESS
  • TMR_CCTRL_ADDRESS
  • TMR_CVAL_ADDRESS
  • TMR_DIV_ADDRESS
  • TMR_PR_ADDRESS
  • TMR_RPR_ADDRESS
  • TMR_C1DT_ADDRESS
  • TMR_C2DT_ADDRESS
  • TMR_C3DT_ADDRESS
  • TMR_C4DT_ADDRESS
  • TMR_BRK_ADDRESS
  • TMR_DMACTRL_ADDRESS
Return values
none

Definition at line 1699 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_dma_request_enable()

void tmr_dma_request_enable | ( | tmr_type * | tmr_x,
 |  | tmr_dma_request_type | dma_request,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr dma request

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
dma_request this parameter can be one of the following values:
  • TMR_OVERFLOW_DMA_REQUEST
  • TMR_C1_DMA_REQUEST
  • TMR_C2_DMA_REQUEST
  • TMR_C3_DMA_REQUEST
  • TMR_C4_DMA_REQUEST
  • TMR_HALL_DMA_REQUEST
  • TMR_TRIGGER_DMA_REQUEST
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1279 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_encoder_mode_config()

void tmr_encoder_mode_config | ( | tmr_type * | tmr_x,
 |  | tmr_encoder_mode_type | encoder_mode,
 |  | tmr_input_polarity_type | ic1_polarity,
 |  | tmr_input_polarity_type | ic2_polarity
 | ) |  |

config tmr encoder mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
encoder_mode this parameter can be one of the following values:
  • TMR_ENCODER_MODE_A
  • TMR_ENCODER_MODE_B
  • TMR_ENCODER_MODE_C
ic1_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
ic2_polarity this parameter can be one of the following values:
  • TMR_INPUT_RISING_EDGE
  • TMR_INPUT_FALLING_EDGE
  • TMR_INPUT_BOTH_EDGE
Return values
none

Definition at line 1597 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_event_sw_trigger()

void tmr_event_sw_trigger | ( | tmr_type * | tmr_x,
 |  | tmr_event_trigger_type | tmr_event
 | ) |  |

generate tmr event

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_event this parameter can be one of the following values:
  • TMR_OVERFLOW_SWTRIG
  • TMR_C1_SWTRIG
  • TMR_C2_SWTRIG
  • TMR_C3_SWTRIG
  • TMR_C4_SWTRIG
  • TMR_HALL_SWTRIG
  • TMR_TRIGGER_SWTRIG
  • TMR_BRK_SWTRIG
Return values
none

Definition at line 1405 of file at32f413_tmr.c.

Referenced by SysTick_Handler().

◆ tmr_external_clock_config()

void tmr_external_clock_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1516 of file at32f413_tmr.c.

Referenced by tmr_external_clock_mode1_config(), and tmr_external_clock_mode2_config().

◆ tmr_external_clock_mode1_config()

void tmr_external_clock_mode1_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode1

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1542 of file at32f413_tmr.c.

◆ tmr_external_clock_mode2_config()

void tmr_external_clock_mode2_config | ( | tmr_type * | tmr_x,
 |  | tmr_external_signal_divider_type | es_divide,
 |  | tmr_external_signal_polarity_type | es_polarity,
 |  | uint16_t | es_filter
 | ) |  |

config tmr external clock mode2

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
es_divide this parameter can be one of the following values:
  • TMR_ES_FREQUENCY_DIV_1
  • TMR_ES_FREQUENCY_DIV_2
  • TMR_ES_FREQUENCY_DIV_4
  • TMR_ES_FREQUENCY_DIV_8
es_polarity this parameter can be one of the following values:
  • TMR_ES_POLARITY_NON_INVERTED
  • TMR_ES_POLARITY_INVERTED
es_filter | (0x0~0xf)
Return values
none

Definition at line 1568 of file at32f413_tmr.c.

◆ tmr_flag_clear()

void tmr_flag_clear | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

clear tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_flag this parameter can be any combination of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
none

Definition at line 1382 of file at32f413_tmr.c.

Referenced by TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR1_TRG_HALL_TMR11_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_flag_get()

flag_status tmr_flag_get | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_flag
 | ) |  |

get tmr flag

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_flag this parameter can be one of the following values:
  • TMR_OVF_FLAG
  • TMR_C1_FLAG
  • TMR_C2_FLAG
  • TMR_C3_FLAG
  • TMR_C4_FLAG
  • TMR_HALL_FLAG
  • TMR_TRIGGER_FLAG
  • TMR_BRK_FLAG
  • TMR_C1_RECAPTURE_FLAG
  • TMR_C2_RECAPTURE_FLAG
  • TMR_C3_RECAPTURE_FLAG
  • TMR_C4_RECAPTURE_FLAG
Return values
state of tmr flag

Definition at line 1344 of file at32f413_tmr.c.

Referenced by main(), TMR1_BRK_TMR9_IRQHandler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), and TMR5_GLOBAL_IRQHandler().

◆ tmr_force_output_set()

void tmr_force_output_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_force_output_type | force_output
 | ) |  |

set tmr force output

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
force_output this parameter can be one of the following values:
  • TMR_FORCE_OUTPUT_HIGH
  • TMR_FORCE_OUTPUT_LOW
Return values
none

Definition at line 1633 of file at32f413_tmr.c.

◆ tmr_hall_select()

void tmr_hall_select | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr hall

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1208 of file at32f413_tmr.c.

◆ tmr_input_channel_divider_set()

void tmr_input_channel_divider_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

set tmr input channel divider

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 1110 of file at32f413_tmr.c.

◆ tmr_input_channel_filter_set()

void tmr_input_channel_filter_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | uint16_t | filter_value
 | ) |  |

set tmr input channel filter

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
filter_value | (0x0~0xf)
Return values
none

Definition at line 931 of file at32f413_tmr.c.

◆ tmr_input_channel_init()

void tmr_input_channel_init | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

init tmr input channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 807 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_input_default_para_init()

void tmr_input_default_para_init ( tmr_input_config_type * tmr_input_struct )

init tmr input default para

Parameters
tmr_input_struct
  • to the structure of tmr_input_config_type
Return values
none

Definition at line 139 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_internal_clock_set()

void tmr_internal_clock_set ( tmr_type * tmr_x )

set tmr select internal clock

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
Return values
none

Definition at line 1430 of file at32f413_tmr.c.

◆ tmr_interrupt_enable()

void tmr_interrupt_enable | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_interrupt,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr interrupt

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_interrupt this parameter can be one of the following values:
  • TMR_OVF_INT
  • TMR_C1_INT
  • TMR_C2_INT
  • TMR_C3_INT
  • TMR_C4_INT
  • TMR_HALL_INT
  • TMR_TRIGGER_INT
  • TMR_BRK_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1310 of file at32f413_tmr.c.

Referenced by main(), tmr1_config(), tmr2_config(), TMR5_GLOBAL_IRQHandler(), and tmr_init().

◆ tmr_one_cycle_mode_enable()

void tmr_one_cycle_mode_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr one cycle mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
new_state | (TRUE or FALSE)
Return values
none

Definition at line 740 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_output_channel_buffer_enable()

void tmr_output_channel_buffer_enable | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

enable tmr output channel buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 609 of file at32f413_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_output_channel_config()

void tmr_output_channel_config | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_config_type * | tmr_output_struct
 | ) |  |

config tmr output channel

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 319 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_channel_immediately_set()

void tmr_output_channel_immediately_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel immediately

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 655 of file at32f413_tmr.c.

◆ tmr_output_channel_mode_select()

void tmr_output_channel_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_output_control_mode_type | oc_mode
 | ) |  |

select tmr output channel mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
oc_mode this parameter can be one of the following values:
  • TMR_OUTPUT_CONTROL_OFF
  • TMR_OUTPUT_CONTROL_HIGH
  • TMR_OUTPUT_CONTROL_LOW
  • TMR_OUTPUT_CONTROL_SWITCH
  • TMR_OUTPUT_CONTROL_FORCE_HIGH
  • TMR_OUTPUT_CONTROL_FORCE_LOW
  • TMR_OUTPUT_CONTROL_PWM_MODE_A
  • TMR_OUTPUT_CONTROL_PWM_MODE_B
Return values
none

Definition at line 425 of file at32f413_tmr.c.

Referenced by TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_output_channel_polarity_set()

void tmr_output_channel_polarity_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | tmr_polarity_active_type | oc_polarity
 | ) |  |

set tmr output channel polarity

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
  • TMR_SELECT_CHANNEL_1C
  • TMR_SELECT_CHANNEL_2C
  • TMR_SELECT_CHANNEL_3C
oc_polarity this parameter can be one of the following values:
  • TMR_POLARITY_ACTIVE_HIGH
  • TMR_POLARITY_ACTIVE_LOW
Return values
none

Definition at line 1456 of file at32f413_tmr.c.

◆ tmr_output_channel_switch_set()

void tmr_output_channel_switch_set | ( | tmr_type * | tmr_x,
 |  | tmr_channel_select_type | tmr_channel,
 |  | confirm_state | new_state
 | ) |  |

set tmr output channel switch

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_channel this parameter can be one of the following values:
  • TMR_SELECT_CHANNEL_1
  • TMR_SELECT_CHANNEL_2
  • TMR_SELECT_CHANNEL_3
  • TMR_SELECT_CHANNEL_4
new_state | (TRUE or FALSE)
Return values
none

Definition at line 701 of file at32f413_tmr.c.

◆ tmr_output_default_para_init()

void tmr_output_default_para_init ( tmr_output_config_type * tmr_output_struct )

init tmr output default para

Parameters
tmr_output_struct
  • to the structure of tmr_output_config_type
Return values
none

Definition at line 122 of file at32f413_tmr.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().

◆ tmr_output_enable()

void tmr_output_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

tmr output enable(oen),this function is important for advtm output enable

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1418 of file at32f413_tmr.c.

Referenced by main(), and mclk_tmr1_init().

◆ tmr_overflow_event_disable()

void tmr_overflow_event_disable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable tmr overflow event generation

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 786 of file at32f413_tmr.c.

◆ tmr_overflow_request_source_set()

void tmr_overflow_request_source_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

select tmr the overflow event sources

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 772 of file at32f413_tmr.c.

◆ tmr_period_buffer_enable()

void tmr_period_buffer_enable | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

enable tmr period buffer

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
new_state | (TRUE or FALSE)
Return values
none

Definition at line 588 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_period_value_get()

uint32_t tmr_period_value_get ( tmr_type * tmr_x )

get tmr period value

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)

Definition at line 481 of file at32f413_tmr.c.

◆ tmr_period_value_set()

void tmr_period_value_set | ( | tmr_type * | tmr_x,
 |  | uint32_t | tmr_pr_value
 | ) |  |

set tmr period value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
tmr_pr_value | timer period register value of counter (for 16 bit tmr 0x0000~0xFFFF, for 32 bit tmr 0x0000_0000~0xFFFF_FFFF)
Return values
none

Definition at line 465 of file at32f413_tmr.c.

◆ tmr_primary_mode_select()

void tmr_primary_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_primary_select_type | primary_mode
 | ) |  |

select tmr primary mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8
primary_mode this parameter can be one of the following values:
  • TMR_PRIMARY_SEL_RESET
  • TMR_PRIMARY_SEL_ENABLE
  • TMR_PRIMARY_SEL_OVERFLOW
  • TMR_PRIMARY_SEL_COMPARE
  • TMR_PRIMARY_SEL_C1ORAW
  • TMR_PRIMARY_SEL_C2ORAW
  • TMR_PRIMARY_SEL_C3ORAW
  • TMR_PRIMARY_SEL_C4ORAW
Return values
none

Definition at line 1157 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_pwm_input_config()

void tmr_pwm_input_config | ( | tmr_type * | tmr_x,
 |  | tmr_input_config_type * | input_struct,
 |  | tmr_channel_input_divider_type | divider_factor
 | ) |  |

config tmr pwm input

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
input_struct
  • to the structure of tmr_input_config_type
divider_factor this parameter can be one of the following values:
  • TMR_CHANNEL_INPUT_DIV_1
  • TMR_CHANNEL_INPUT_DIV_2
  • TMR_CHANNEL_INPUT_DIV_4
  • TMR_CHANNEL_INPUT_DIV_8
Return values
none

Definition at line 977 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_repetition_counter_set()

void tmr_repetition_counter_set | ( | tmr_type * | tmr_x,
 |  | uint8_t | tmr_rpr_value
 | ) |  |

set the repetition counter register(rpr) value

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR8
tmr_rpr_value | (0x00~0xFF)
Return values
none

Definition at line 235 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_reset()

void tmr_reset ( tmr_type * tmr_x )

tmr reset by crm reset register

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9, TMR10, TMR11
Return values
none

Definition at line 52 of file at32f413_tmr.c.

◆ tmr_sub_mode_select()

void tmr_sub_mode_select | ( | tmr_type * | tmr_x,
 |  | tmr_sub_mode_select_type | sub_mode
 | ) |  |

select tmr subordinate mode

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
sub_mode this parameter can be one of the following values:
  • TMR_SUB_MODE_DIABLE
  • TMR_SUB_ENCODER_MODE_A
  • TMR_SUB_ENCODER_MODE_B
  • TMR_SUB_ENCODER_MODE_C
  • TMR_SUB_RESET_MODE
  • TMR_SUB_HANG_MODE
  • TMR_SUB_TRIGGER_MODE
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A
Return values
none

Definition at line 1179 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_sub_sync_mode_set()

void tmr_sub_sync_mode_set | ( | tmr_type * | tmr_x,
 |  | confirm_state | new_state
 | ) |  |

set tmr subordinate synchronization mode

Parameters
tmr_x | select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
new_state | (TRUE or FALSE)
Return values
none

Definition at line 1256 of file at32f413_tmr.c.

Referenced by main().

◆ tmr_trigger_input_select()

void tmr_trigger_input_select | ( | tmr_type * | tmr_x,
 |  | sub_tmr_input_sel_type | trigger_select
 | ) |  |

select tmr sub-trigger

Parameters
tmr_x select the tmr peripheral. this parameter can be one of the following values: TMR1, TMR2, TMR3, TMR4, TMR5, TMR8, TMR9
trigger_select this parameter can be one of the following values:
  • TMR_SUB_INPUT_SEL_IS0
  • TMR_SUB_INPUT_SEL_IS1
  • TMR_SUB_INPUT_SEL_IS2
  • TMR_SUB_INPUT_SEL_IS3
  • TMR_SUB_INPUT_SEL_C1INC
  • TMR_SUB_INPUT_SEL_C1DF1
  • TMR_SUB_INPUT_SEL_C2DF2
  • TMR_SUB_INPUT_SEL_EXTIN
Return values
none

Definition at line 1243 of file at32f413_tmr.c.

Referenced by main().


AT32F413 Firmwary Library: USART

Modules | Macros
USART
AT32F413_periph_driver

USART driver modules. More...

Modules

USART_flags_definition
usart flag
USART_interrupts_definition
usart interrupt
USART_exported_types
USART_exported_functions
USART_private_functions

Macros

#define | USART1 ((usart_type *) USART1_BASE)
#define | USART2 ((usart_type *) USART2_BASE)
#define | USART3 ((usart_type *) USART3_BASE)
#define | UART4 ((usart_type *) UART4_BASE)
#define | UART5 ((usart_type *) UART5_BASE)

Detailed Description

USART driver modules.

Macro Definition Documentation

◆ UART4

#define UART4 ((usart_type *) UART4_BASE)

Definition at line 322 of file at32f413_usart.h.

◆ UART5

#define UART5 ((usart_type *) UART5_BASE)

Definition at line 323 of file at32f413_usart.h.

◆ USART1

#define USART1 ((usart_type *) USART1_BASE)

Definition at line 319 of file at32f413_usart.h.

◆ USART2

#define USART2 ((usart_type *) USART2_BASE)

Definition at line 320 of file at32f413_usart.h.

◆ USART3

#define USART3 ((usart_type *) USART3_BASE)

Definition at line 321 of file at32f413_usart.h.


AT32F413 Firmwary Library: USART_flags_definition

Macros
USART_flags_definition
AT32F413_periph_driver » USART

usart flag More...

Macros

#define | USART_PERR_FLAG ((uint32_t)0x00000001)
#define | USART_FERR_FLAG ((uint32_t)0x00000002)
#define | USART_NERR_FLAG ((uint32_t)0x00000004)
#define | USART_ROERR_FLAG ((uint32_t)0x00000008)
#define | USART_IDLEF_FLAG ((uint32_t)0x00000010)
#define | USART_RDBF_FLAG ((uint32_t)0x00000020)
#define | USART_TDC_FLAG ((uint32_t)0x00000040)
#define | USART_TDBE_FLAG ((uint32_t)0x00000080)
#define | USART_BFF_FLAG ((uint32_t)0x00000100)
#define | USART_CTSCF_FLAG ((uint32_t)0x00000200)

Detailed Description

usart flag

Macro Definition Documentation

◆ USART_BFF_FLAG

#define USART_BFF_FLAG ((uint32_t)0x00000100)

usart break frame flag

Definition at line 60 of file at32f413_usart.h.

◆ USART_CTSCF_FLAG

#define USART_CTSCF_FLAG ((uint32_t)0x00000200)

usart cts change flag

Definition at line 61 of file at32f413_usart.h.

◆ USART_FERR_FLAG

#define USART_FERR_FLAG ((uint32_t)0x00000002)

usart framing error flag

Definition at line 53 of file at32f413_usart.h.

◆ USART_IDLEF_FLAG

#define USART_IDLEF_FLAG ((uint32_t)0x00000010)

usart idle flag

Definition at line 56 of file at32f413_usart.h.

◆ USART_NERR_FLAG

#define USART_NERR_FLAG ((uint32_t)0x00000004)

usart noise error flag

Definition at line 54 of file at32f413_usart.h.

◆ USART_PERR_FLAG

#define USART_PERR_FLAG ((uint32_t)0x00000001)

usart parity error flag

Definition at line 52 of file at32f413_usart.h.

◆ USART_RDBF_FLAG

#define USART_RDBF_FLAG ((uint32_t)0x00000020)

usart receive data buffer full flag

Definition at line 57 of file at32f413_usart.h.

◆ USART_ROERR_FLAG

#define USART_ROERR_FLAG ((uint32_t)0x00000008)

usart receiver overflow error flag

Definition at line 55 of file at32f413_usart.h.

◆ USART_TDBE_FLAG

#define USART_TDBE_FLAG ((uint32_t)0x00000080)

usart transmit data buffer empty flag

Definition at line 59 of file at32f413_usart.h.

◆ USART_TDC_FLAG

#define USART_TDC_FLAG ((uint32_t)0x00000040)

usart transmit data complete flag

Definition at line 58 of file at32f413_usart.h.


AT32F413 Firmwary Library: USART_interrupts_definition

Macros
USART_interrupts_definition
AT32F413_periph_driver » USART

usart interrupt More...

Macros

#define | USART_IDLE_INT MAKE_VALUE(0x0C,0x04)
#define | USART_RDBF_INT MAKE_VALUE(0x0C,0x05)
#define | USART_TDC_INT MAKE_VALUE(0x0C,0x06)
#define | USART_TDBE_INT MAKE_VALUE(0x0C,0x07)
#define | USART_PERR_INT MAKE_VALUE(0x0C,0x08)
#define | USART_BF_INT MAKE_VALUE(0x10,0x06)
#define | USART_ERR_INT MAKE_VALUE(0x14,0x00)
#define | USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)

Detailed Description

usart interrupt

Macro Definition Documentation

◆ USART_BF_INT

#define USART_BF_INT MAKE_VALUE(0x10,0x06)

usart break frame interrupt

Definition at line 77 of file at32f413_usart.h.

◆ USART_CTSCF_INT

#define USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)

usart cts change interrupt

Definition at line 79 of file at32f413_usart.h.

◆ USART_ERR_INT

#define USART_ERR_INT MAKE_VALUE(0x14,0x00)

usart error interrupt

Definition at line 78 of file at32f413_usart.h.

◆ USART_IDLE_INT

#define USART_IDLE_INT MAKE_VALUE(0x0C,0x04)

usart idle interrupt

Definition at line 72 of file at32f413_usart.h.

◆ USART_PERR_INT

#define USART_PERR_INT MAKE_VALUE(0x0C,0x08)

usart parity error interrupt

Definition at line 76 of file at32f413_usart.h.

◆ USART_RDBF_INT

#define USART_RDBF_INT MAKE_VALUE(0x0C,0x05)

usart receive data buffer full interrupt

Definition at line 73 of file at32f413_usart.h.

◆ USART_TDBE_INT

#define USART_TDBE_INT MAKE_VALUE(0x0C,0x07)

usart transmit data buffer empty interrupt

Definition at line 75 of file at32f413_usart.h.

◆ USART_TDC_INT

#define USART_TDC_INT MAKE_VALUE(0x0C,0x06)

usart transmit data complete interrupt

Definition at line 74 of file at32f413_usart.h.


AT32F413 Firmwary Library: USART_exported_types

Data Structures | Enumerations
USART_exported_types
AT32F413_periph_driver » USART

Data Structures

struct usart_type
type define usart register all More...

Enumerations

enum | usart_parity_selection_type { USART_PARITY_NONE = 0x00 , USART_PARITY_EVEN = 0x01 , USART_PARITY_ODD = 0x02 }
usart parity selection type More...
enum | usart_wakeup_mode_type { USART_WAKEUP_BY_IDLE_FRAME = 0x00 , USART_WAKEUP_BY_MATCHING_ID = 0x01 }
usart wakeup mode type More...
enum | usart_data_bit_num_type { USART_DATA_8BITS = 0x00 , USART_DATA_9BITS = 0x01 }
usart data bit num type More...
enum | usart_break_bit_num_type { USART_BREAK_10BITS = 0x00 , USART_BREAK_11BITS = 0x01 }
usart break frame bit num type More...
enum | usart_clock_phase_type { USART_CLOCK_PHASE_1EDGE = 0x00 , USART_CLOCK_PHASE_2EDGE = 0x01 }
usart phase of the clock type More...
enum | usart_clock_polarity_type { USART_CLOCK_POLARITY_LOW = 0x00 , USART_CLOCK_POLARITY_HIGH = 0x01 }
usart polarity of the clock type More...
enum | usart_lbcp_type { USART_CLOCK_LAST_BIT_NONE = 0x00 , USART_CLOCK_LAST_BIT_OUTPUT = 0x01 }
usart last bit clock pulse type More...
enum | usart_stop_bit_num_type { USART_STOP_1_BIT = 0x00 , USART_STOP_0_5_BIT = 0x01 , USART_STOP_2_BIT = 0x02 , USART_STOP_1_5_BIT = 0x03 }
usart stop bit num type More...
enum | usart_hardware_flow_control_type { USART_HARDWARE_FLOW_NONE = 0x00 , USART_HARDWARE_FLOW_RTS = 0x01 , USART_HARDWARE_FLOW_CTS = 0x02 , USART_HARDWARE_FLOW_RTS_CTS = 0x03 }
usart hardware flow control type More...

Detailed Description

Enumeration Type Documentation

◆ usart_break_bit_num_type

enum usart_break_bit_num_type

usart break frame bit num type

Enumerator
USART_BREAK_10BITS | usart lin mode berak frame detection 10 bits
USART_BREAK_11BITS | usart lin mode berak frame detection 11 bits

Definition at line 120 of file at32f413_usart.h.

◆ usart_clock_phase_type

enum usart_clock_phase_type

usart phase of the clock type

Enumerator
USART_CLOCK_PHASE_1EDGE | usart data capture is done on the clock leading edge
USART_CLOCK_PHASE_2EDGE | usart data capture is done on the clock trailing edge

Definition at line 129 of file at32f413_usart.h.

◆ usart_clock_polarity_type

enum usart_clock_polarity_type

usart polarity of the clock type

Enumerator
USART_CLOCK_POLARITY_LOW | usart clock stay low level outside transmission window
USART_CLOCK_POLARITY_HIGH | usart clock stay high level outside transmission window

Definition at line 138 of file at32f413_usart.h.

◆ usart_data_bit_num_type

enum usart_data_bit_num_type

usart data bit num type

Enumerator
USART_DATA_8BITS | usart data size is 8 bits
USART_DATA_9BITS | usart data size is 9 bits

Definition at line 111 of file at32f413_usart.h.

◆ usart_hardware_flow_control_type

enum usart_hardware_flow_control_type

usart hardware flow control type

Enumerator
USART_HARDWARE_FLOW_NONE | usart without hardware flow
USART_HARDWARE_FLOW_RTS | usart hardware flow only rts
USART_HARDWARE_FLOW_CTS | usart hardware flow only cts
USART_HARDWARE_FLOW_RTS_CTS | usart hardware flow both rts and cts

Definition at line 167 of file at32f413_usart.h.

◆ usart_lbcp_type

enum usart_lbcp_type

usart last bit clock pulse type

Enumerator
USART_CLOCK_LAST_BIT_NONE | usart clock pulse of the last data bit is not outputted
USART_CLOCK_LAST_BIT_OUTPUT | usart clock pulse of the last data bit is outputted

Definition at line 147 of file at32f413_usart.h.

◆ usart_parity_selection_type

enum usart_parity_selection_type

usart parity selection type

Enumerator
USART_PARITY_NONE | usart no parity
USART_PARITY_EVEN | usart even parity
USART_PARITY_ODD | usart odd parity

Definition at line 92 of file at32f413_usart.h.

◆ usart_stop_bit_num_type

enum usart_stop_bit_num_type

usart stop bit num type

Enumerator
USART_STOP_1_BIT | usart stop bits num is 1
USART_STOP_0_5_BIT | usart stop bits num is 0.5
USART_STOP_2_BIT | usart stop bits num is 2
USART_STOP_1_5_BIT | usart stop bits num is 1.5

Definition at line 156 of file at32f413_usart.h.

◆ usart_wakeup_mode_type

enum usart_wakeup_mode_type

usart wakeup mode type

Enumerator
USART_WAKEUP_BY_IDLE_FRAME | usart wakeup by idle frame
USART_WAKEUP_BY_MATCHING_ID | usart wakeup by matching id

Definition at line 102 of file at32f413_usart.h.


AT32F413 Firmwary Library: usart_type Struct Reference

Data Fields
usart_type Struct Reference
AT32F413_periph_driver » USART » USART_exported_types

type define usart register all More...

#include <at32f413_usart.h>

Data Fields

union {
__IO uint32_t sts
struct {
__IO uint32_t perr: 1
__IO uint32_t ferr: 1
__IO uint32_t nerr: 1
__IO uint32_t roerr: 1
__IO uint32_t idlef: 1
__IO uint32_t rdbf: 1
__IO uint32_t tdc: 1
__IO uint32_t tdbe: 1
__IO uint32_t bff: 1
__IO uint32_t ctscf: 1
__IO uint32_t reserved1: 22
} sts_bit
};
usart sts register, offset:0x00 More...
union {
__IO uint32_t dt
struct {
__IO uint32_t dt: 9
__IO uint32_t reserved1: 23
} dt_bit
};
usart dt register, offset:0x04 More...
union {
__IO uint32_t baudr
struct {
__IO uint32_t div: 16
__IO uint32_t reserved1: 16
} baudr_bit
};
usart baudr register, offset:0x08 More...
union {
__IO uint32_t ctrl1
struct {
__IO uint32_t sbf: 1
__IO uint32_t rm: 1
__IO uint32_t ren: 1
__IO uint32_t ten: 1
__IO uint32_t idleien: 1
__IO uint32_t rdbfien: 1
__IO uint32_t tdcien: 1
__IO uint32_t tdbeien: 1
__IO uint32_t perrien: 1
__IO uint32_t psel: 1
__IO uint32_t pen: 1
__IO uint32_t wum: 1
__IO uint32_t dbn: 1
__IO uint32_t uen: 1
__IO uint32_t reserved1: 18
} ctrl1_bit
};
usart ctrl1 register, offset:0x0C More...
union {
__IO uint32_t ctrl2
struct {
__IO uint32_t id: 4
__IO uint32_t reserved1: 1
__IO uint32_t bfbn: 1
__IO uint32_t bfien: 1
__IO uint32_t reserved2: 1
__IO uint32_t lbcp: 1
__IO uint32_t clkpha: 1
__IO uint32_t clkpol: 1
__IO uint32_t clken: 1
__IO uint32_t stopbn: 2
__IO uint32_t linen: 1
__IO uint32_t reserved3: 17
} ctrl2_bit
};
usart ctrl2 register, offset:0x10 More...
union {
__IO uint32_t ctrl3
struct {
__IO uint32_t errien: 1
__IO uint32_t irdaen: 1
__IO uint32_t irdalp: 1
__IO uint32_t slben: 1
__IO uint32_t scnacken: 1
__IO uint32_t scmen: 1
__IO uint32_t dmaren: 1
__IO uint32_t dmaten: 1
__IO uint32_t rtsen: 1
__IO uint32_t ctsen: 1
__IO uint32_t ctscfien: 1
__IO uint32_t reserved1: 21
} ctrl3_bit
};
usart ctrl3 register, offset:0x14 More...
union {
__IO uint32_t gdiv
struct {
__IO uint32_t isdiv: 8
__IO uint32_t scgt: 8
__IO uint32_t reserved1: 16
} gdiv_bit
};
usart gdiv register, offset:0x18 More...

Detailed Description

type define usart register all

Definition at line 178 of file at32f413_usart.h.

Field Documentation

◆

union { ... } usart_type::@711

usart sts register, offset:0x00

◆

union { ... } usart_type::@713

usart dt register, offset:0x04

◆

union { ... } usart_type::@715

usart baudr register, offset:0x08

◆

union { ... } usart_type::@717

usart ctrl1 register, offset:0x0C

◆

union { ... } usart_type::@719

usart ctrl2 register, offset:0x10

◆

union { ... } usart_type::@721

usart ctrl3 register, offset:0x14

◆

union { ... } usart_type::@723

usart gdiv register, offset:0x18

◆ baudr

__IO uint32_t usart_type::baudr

Definition at line 220 of file at32f413_usart.h.

◆

struct { ... } usart_type::baudr_bit

Referenced by usart_init().

◆ bfbn

__IO uint32_t usart_type::bfbn

Definition at line 264 of file at32f413_usart.h.

Referenced by usart_break_bit_num_set().

◆ bff

__IO uint32_t usart_type::bff

Definition at line 196 of file at32f413_usart.h.

◆ bfien

__IO uint32_t usart_type::bfien

Definition at line 265 of file at32f413_usart.h.

◆ clken

__IO uint32_t usart_type::clken

Definition at line 270 of file at32f413_usart.h.

Referenced by usart_clock_enable().

◆ clkpha

__IO uint32_t usart_type::clkpha

Definition at line 268 of file at32f413_usart.h.

Referenced by usart_clock_config().

◆ clkpol

__IO uint32_t usart_type::clkpol

Definition at line 269 of file at32f413_usart.h.

Referenced by usart_clock_config().

◆ ctrl1

__IO uint32_t usart_type::ctrl1

Definition at line 233 of file at32f413_usart.h.

◆

struct { ... } usart_type::ctrl1_bit

Referenced by usart_break_send(), usart_enable(), usart_init(), usart_parity_selection_config(), usart_receiver_enable(), usart_receiver_mute_enable(), usart_transmitter_enable(), and usart_wakeup_mode_set().

◆ ctrl2

__IO uint32_t usart_type::ctrl2

Definition at line 259 of file at32f413_usart.h.

◆

struct { ... } usart_type::ctrl2_bit

Referenced by usart_break_bit_num_set(), usart_clock_config(), usart_clock_enable(), usart_init(), usart_lin_mode_enable(), and usart_wakeup_id_set().

◆ ctrl3

__IO uint32_t usart_type::ctrl3

Definition at line 282 of file at32f413_usart.h.

◆

struct { ... } usart_type::ctrl3_bit

Referenced by usart_dma_receiver_enable(), usart_dma_transmitter_enable(), usart_hardware_flow_control_set(), usart_irda_low_power_enable(), usart_irda_mode_enable(), usart_single_line_halfduplex_select(), usart_smartcard_mode_enable(), and usart_smartcard_nack_set().

◆ ctscf

__IO uint32_t usart_type::ctscf

Definition at line 197 of file at32f413_usart.h.

◆ ctscfien

__IO uint32_t usart_type::ctscfien

Definition at line 295 of file at32f413_usart.h.

◆ ctsen

__IO uint32_t usart_type::ctsen

Definition at line 294 of file at32f413_usart.h.

Referenced by usart_hardware_flow_control_set().

◆ dbn

__IO uint32_t usart_type::dbn

Definition at line 248 of file at32f413_usart.h.

Referenced by usart_init().

◆ div

__IO uint32_t usart_type::div

Definition at line 223 of file at32f413_usart.h.

Referenced by usart_init().

◆ dmaren

__IO uint32_t usart_type::dmaren

Definition at line 291 of file at32f413_usart.h.

Referenced by usart_dma_receiver_enable().

◆ dmaten

__IO uint32_t usart_type::dmaten

Definition at line 292 of file at32f413_usart.h.

Referenced by usart_dma_transmitter_enable().

◆ dt

__IO uint32_t usart_type::dt

Definition at line 207 of file at32f413_usart.h.

Referenced by usart_data_receive(), and usart_data_transmit().

◆

struct { ... } usart_type::dt_bit

◆ errien

__IO uint32_t usart_type::errien

Definition at line 285 of file at32f413_usart.h.

◆ ferr

__IO uint32_t usart_type::ferr

Definition at line 189 of file at32f413_usart.h.

◆ gdiv

__IO uint32_t usart_type::gdiv

Definition at line 305 of file at32f413_usart.h.

◆

struct { ... } usart_type::gdiv_bit

Referenced by usart_irda_smartcard_division_set(), and usart_smartcard_guard_time_set().

◆ id

__IO uint32_t usart_type::id

Definition at line 262 of file at32f413_usart.h.

Referenced by usart_wakeup_id_set().

◆ idlef

__IO uint32_t usart_type::idlef

Definition at line 192 of file at32f413_usart.h.

◆ idleien

__IO uint32_t usart_type::idleien

Definition at line 240 of file at32f413_usart.h.

◆ irdaen

__IO uint32_t usart_type::irdaen

Definition at line 286 of file at32f413_usart.h.

Referenced by usart_irda_mode_enable().

◆ irdalp

__IO uint32_t usart_type::irdalp

Definition at line 287 of file at32f413_usart.h.

Referenced by usart_irda_low_power_enable().

◆ isdiv

__IO uint32_t usart_type::isdiv

Definition at line 308 of file at32f413_usart.h.

Referenced by usart_irda_smartcard_division_set().

◆ lbcp

__IO uint32_t usart_type::lbcp

Definition at line 267 of file at32f413_usart.h.

Referenced by usart_clock_config().

◆ linen

__IO uint32_t usart_type::linen

Definition at line 272 of file at32f413_usart.h.

Referenced by usart_lin_mode_enable().

◆ nerr

__IO uint32_t usart_type::nerr

Definition at line 190 of file at32f413_usart.h.

◆ pen

__IO uint32_t usart_type::pen

Definition at line 246 of file at32f413_usart.h.

Referenced by usart_parity_selection_config().

◆ perr

__IO uint32_t usart_type::perr

Definition at line 188 of file at32f413_usart.h.

◆ perrien

__IO uint32_t usart_type::perrien

Definition at line 244 of file at32f413_usart.h.

◆ psel

__IO uint32_t usart_type::psel

Definition at line 245 of file at32f413_usart.h.

Referenced by usart_parity_selection_config().

◆ rdbf

__IO uint32_t usart_type::rdbf

Definition at line 193 of file at32f413_usart.h.

◆ rdbfien

__IO uint32_t usart_type::rdbfien

Definition at line 241 of file at32f413_usart.h.

◆ ren

__IO uint32_t usart_type::ren

Definition at line 238 of file at32f413_usart.h.

Referenced by usart_receiver_enable().

◆ reserved1

__IO uint32_t usart_type::reserved1

Definition at line 198 of file at32f413_usart.h.

◆ reserved2

__IO uint32_t usart_type::reserved2

Definition at line 266 of file at32f413_usart.h.

◆ reserved3

__IO uint32_t usart_type::reserved3

Definition at line 273 of file at32f413_usart.h.

◆ rm

__IO uint32_t usart_type::rm

Definition at line 237 of file at32f413_usart.h.

Referenced by usart_receiver_mute_enable().

◆ roerr

__IO uint32_t usart_type::roerr

Definition at line 191 of file at32f413_usart.h.

◆ rtsen

__IO uint32_t usart_type::rtsen

Definition at line 293 of file at32f413_usart.h.

Referenced by usart_hardware_flow_control_set().

◆ sbf

__IO uint32_t usart_type::sbf

Definition at line 236 of file at32f413_usart.h.

Referenced by usart_break_send().

◆ scgt

__IO uint32_t usart_type::scgt

Definition at line 309 of file at32f413_usart.h.

Referenced by usart_smartcard_guard_time_set().

◆ scmen

__IO uint32_t usart_type::scmen

Definition at line 290 of file at32f413_usart.h.

Referenced by usart_smartcard_mode_enable().

◆ scnacken

__IO uint32_t usart_type::scnacken

Definition at line 289 of file at32f413_usart.h.

Referenced by usart_smartcard_nack_set().

◆ slben

__IO uint32_t usart_type::slben

Definition at line 288 of file at32f413_usart.h.

Referenced by usart_single_line_halfduplex_select().

◆ stopbn

__IO uint32_t usart_type::stopbn

Definition at line 271 of file at32f413_usart.h.

Referenced by usart_init().

◆ sts

__IO uint32_t usart_type::sts

Definition at line 185 of file at32f413_usart.h.

Referenced by usart_flag_clear(), and usart_flag_get().

◆

struct { ... } usart_type::sts_bit

◆ tdbe

__IO uint32_t usart_type::tdbe

Definition at line 195 of file at32f413_usart.h.

◆ tdbeien

__IO uint32_t usart_type::tdbeien

Definition at line 243 of file at32f413_usart.h.

◆ tdc

__IO uint32_t usart_type::tdc

Definition at line 194 of file at32f413_usart.h.

◆ tdcien

__IO uint32_t usart_type::tdcien

Definition at line 242 of file at32f413_usart.h.

◆ ten

__IO uint32_t usart_type::ten

Definition at line 239 of file at32f413_usart.h.

Referenced by usart_transmitter_enable().

◆ uen

__IO uint32_t usart_type::uen

Definition at line 249 of file at32f413_usart.h.

Referenced by usart_enable().

◆ wum

__IO uint32_t usart_type::wum

Definition at line 247 of file at32f413_usart.h.

Referenced by usart_wakeup_mode_set().

The documentation for this struct was generated from the following file:
  • at32f413_usart.h


AT32F413 Firmwary Library: USART_exported_functions

Functions
USART_exported_functions
AT32F413_periph_driver » USART

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...

Detailed Description

Function Documentation

◆ usart_break_bit_num_set()

void usart_break_bit_num_set | ( | usart_type * | usart_x,
 |  | usart_break_bit_num_type | break_bit
 | ) |  |

set the usart break frame bit num.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
break_bit specifies the break bit num. this parameter can be one of the following values:
  • USART_BREAK_10BITS
  • USART_BREAK_11BITS
Return values
none

Definition at line 347 of file at32f413_usart.c.

◆ usart_break_send()

void usart_break_send ( usart_type * usart_x )

transmit break characters.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
none

Definition at line 398 of file at32f413_usart.c.

◆ usart_clock_config()

void usart_clock_config | ( | usart_type * | usart_x,
 |  | usart_clock_polarity_type | clk_pol,
 |  | usart_clock_phase_type | clk_pha,
 |  | usart_lbcp_type | clk_lb
 | ) |  |

usart clock config.

Note
clock config are not available for UART4 and UART5.
Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
clk_pol polarity of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_POLARITY_LOW
  • USART_CLOCK_POLARITY_HIGH
clk_pha phase of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_PHASE_1EDGE
  • USART_CLOCK_PHASE_2EDGE
clk_lb whether the clock pulse of the last data bit transmitted (MSB) is outputted on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_LAST_BIT_NONE
  • USART_CLOCK_LAST_BIT_OUTPUT
Return values
none

Definition at line 217 of file at32f413_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_clock_enable()

void usart_clock_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart enable the ck pin.

Note
clock enable are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | TRUE or FALSE
Return values
none

Definition at line 233 of file at32f413_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_data_receive()

uint16_t usart_data_receive ( usart_type * usart_x )

return the most recent received data by the usart peripheral.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
the received data.

Definition at line 386 of file at32f413_usart.c.

Referenced by main(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart_data_transmit()

void usart_data_transmit | ( | usart_type * | usart_x,
 |  | uint16_t | data
 | ) |  |

transmit single data through the usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
data | the data to transmit.
Return values
none

Definition at line 374 of file at32f413_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_dma_receiver_enable()

void usart_dma_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma receiver interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 288 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_dma_transmitter_enable()

void usart_dma_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma transmitter interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 274 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_enable()

void usart_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart peripheral. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 166 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_flag_clear()

void usart_flag_clear | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

clear the usart's pending flags.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • USART_CTSCF_FLAG: (not available for UART4 and UART5).
  • USART_BFF_FLAG:
  • USART_TDC_FLAG:
  • USART_RDBF_FLAG:
Note
  • USART_PERR_FLAG, USART_FERR_FLAG, USART_NERR_FLAG, USART_ROERR_FLAG and USART_IDLEF_FLAG are cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a read operation to usart dt register (usart_data_receive()).
  • USART_RDBF_FLAG can be also cleared by a read to the usart dt register(usart_data_receive()).
  • USART_TDC_FLAG can be also cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a write operation to usart dt register (usart_data_transmit()).
  • USART_TDBE_FLAG is cleared only by a write to the usart dt register(usart_data_transmit()).
Return values
none

Definition at line 592 of file at32f413_usart.c.

Referenced by rs485_config().

◆ usart_flag_get()

flag_status usart_flag_get | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

check whether the specified usart flag is set or not.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
flag specifies the flag to check. this parameter can be one of the following values:
  • USART_CTSCF_FLAG: cts change flag (not available for UART4,UART5,USART6,UART7 and UART8)
  • USART_BFF_FLAG: break frame flag
  • USART_TDBE_FLAG: transmit data buffer empty flag
  • USART_TDC_FLAG: transmit data complete flag
  • USART_RDBF_FLAG: receive data buffer full flag
  • USART_IDLEF_FLAG: idle flag
  • USART_ROERR_FLAG: receiver overflow error flag
  • USART_NERR_FLAG: noise error flag
  • USART_FERR_FLAG: framing error flag
  • USART_PERR_FLAG: parity error flag
Return values
the new state of usart_flag (SET or RESET).

Definition at line 559 of file at32f413_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_hardware_flow_control_set()

void usart_hardware_flow_control_set | ( | usart_type * | usart_x,
 |  | usart_hardware_flow_control_type | flow_state
 | ) |  |

configure the usart's hardware flow control.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3
flow_state specifies the hardware flow control. this parameter can be one of the following values:
  • USART_HARDWARE_FLOW_NONE
  • USART_HARDWARE_FLOW_RTS,
  • USART_HARDWARE_FLOW_CTS,
  • USART_HARDWARE_FLOW_RTS_CTS
Return values
none

Definition at line 516 of file at32f413_usart.c.

Referenced by usart1_config(), and usart_configuration().

◆ usart_init()

void usart_init | ( | usart_type * | usart_x,
 |  | uint32_t | baud_rate,
 |  | usart_data_bit_num_type | data_bit,
 |  | usart_stop_bit_num_type | stop_bit
 | ) |  |

initialize the usart peripheral according to the specified parameters.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
baud_rate | configure the usart communication baud rate.
data_bit data bits transmitted or received in a frame this parameter can be one of the following values:
  • USART_DATA_8BITS
  • USART_DATA_9BITS.
stop_bit stop bits transmitted this parameter can be one of the following values:
  • USART_STOP_1_BIT
  • USART_STOP_0_5_BIT.
  • USART_STOP_2_BIT
  • USART_STOP_1_5_BIT.
Return values
none

Definition at line 99 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_interrupt_enable()

void usart_interrupt_enable | ( | usart_type * | usart_x,
 |  | uint32_t | usart_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart interrupts.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
usart_int specifies the USART interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • USART_IDLE_INT: idle interrupt
  • USART_RDBF_INT: rdbf interrupt
  • USART_TDC_INT: tdc interrupt
  • USART_TDBE_INT: tdbe interrupt
  • USART_PERR_INT: perr interrupt
  • USART_BF_INT: break frame interrupt
  • USART_ERR_INT: err interrupt
  • USART_CTSCF_INT: ctscf interrupt
new_state | new state of the specified usart interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 257 of file at32f413_usart.c.

Referenced by data_take(), main(), rs485_config(), SC_USART_IRQHandler(), uart_init(), usart1_config(), USART2_IRQHandler(), USART3_IRQHandler(), usart_configuration(), and usb_usart_config().

◆ usart_irda_low_power_enable()

void usart_irda_low_power_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

configure the usart's irda low power.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 498 of file at32f413_usart.c.

◆ usart_irda_mode_enable()

void usart_irda_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's irda interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 484 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_irda_smartcard_division_set()

void usart_irda_smartcard_division_set | ( | usart_type * | usart_x,
 |  | uint8_t | div_val
 | ) |  |

config the irda/smartcard division.

Note
the division are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
div_val | specifies the division.
Return values
none

Definition at line 426 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_lin_mode_enable()

void usart_lin_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart lin mode.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart lin mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 361 of file at32f413_usart.c.

◆ usart_parity_selection_config()

void usart_parity_selection_config | ( | usart_type * | usart_x,
 |  | usart_parity_selection_type | parity
 | ) |  |

usart parity selection config.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
parity select the none, odd or even parity. this parameter can be one of the following values:
  • USART_PARITY_NONE
  • USART_PARITY_EVEN.
  • USART_PARITY_ODD
Return values
none

Definition at line 138 of file at32f413_usart.c.

Referenced by usart1_config(), usart_configuration(), and usb_usart_config().

◆ usart_receiver_enable()

void usart_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart receiver enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | TRUE or FALSE.
Return values
none

Definition at line 192 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_receiver_mute_enable()

void usart_receiver_mute_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

config the usart in mute mode in multi-processor communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart mute mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 331 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_reset()

void usart_reset ( usart_type * usart_x )

deinitialize the usart peripheral registers to their default reset values.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
none

Definition at line 52 of file at32f413_usart.c.

◆ usart_single_line_halfduplex_select()

void usart_single_line_halfduplex_select | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart single line bidirectional half-duplex communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the single line half-duplex select. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 470 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_guard_time_set()

void usart_smartcard_guard_time_set | ( | usart_type * | usart_x,
 |  | uint8_t | guard_time_val
 | ) |  |

config the specified usart smartcard guard time.

Note
The guard time bits are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
guard_time_val | specifies the guard time (0x00~0xFF).
Return values
none

Definition at line 412 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_mode_enable()

void usart_smartcard_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart smart card mode.

Note
the smart card mode are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | new state of the smart card mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 441 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_nack_set()

void usart_smartcard_nack_set | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable nack transmission in smartcard mode.

Note
the smart card nack are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | new state of the nack transmission. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 456 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_transmitter_enable()

void usart_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart transmitter enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | TRUE or FALSE.
Return values
none

Definition at line 179 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_wakeup_id_set()

void usart_wakeup_id_set | ( | usart_type * | usart_x,
 |  | uint8_t | usart_id
 | ) |  |

set the wakeup id of the usart.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
usart_id | the matching id(0x0~0xF).
Return values
none

Definition at line 301 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_wakeup_mode_set()

void usart_wakeup_mode_set | ( | usart_type * | usart_x,
 |  | usart_wakeup_mode_type | wakeup_mode
 | ) |  |

select the usart wakeup method in multi-processor communication.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
wakeup_mode determines the way to wake up usart method. this parameter can be one of the following values:
  • USART_WAKEUP_BY_IDLE_FRAME
  • USART_WAKEUP_BY_MATCHING_ID
Return values
none

Definition at line 317 of file at32f413_usart.c.

Referenced by usart_configuration().


AT32F413 Firmwary Library: USART_private_functions

Functions
USART_private_functions
AT32F413_periph_driver » USART

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...

Detailed Description

Function Documentation

◆ usart_break_bit_num_set()

void usart_break_bit_num_set | ( | usart_type * | usart_x,
 |  | usart_break_bit_num_type | break_bit
 | ) |  |

set the usart break frame bit num.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
break_bit specifies the break bit num. this parameter can be one of the following values:
  • USART_BREAK_10BITS
  • USART_BREAK_11BITS
Return values
none

Definition at line 347 of file at32f413_usart.c.

◆ usart_break_send()

void usart_break_send ( usart_type * usart_x )

transmit break characters.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
none

Definition at line 398 of file at32f413_usart.c.

◆ usart_clock_config()

void usart_clock_config | ( | usart_type * | usart_x,
 |  | usart_clock_polarity_type | clk_pol,
 |  | usart_clock_phase_type | clk_pha,
 |  | usart_lbcp_type | clk_lb
 | ) |  |

usart clock config.

Note
clock config are not available for UART4 and UART5.
Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
clk_pol polarity of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_POLARITY_LOW
  • USART_CLOCK_POLARITY_HIGH
clk_pha phase of the clock output on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_PHASE_1EDGE
  • USART_CLOCK_PHASE_2EDGE
clk_lb whether the clock pulse of the last data bit transmitted (MSB) is outputted on the ck pin. this parameter can be one of the following values:
  • USART_CLOCK_LAST_BIT_NONE
  • USART_CLOCK_LAST_BIT_OUTPUT
Return values
none

Definition at line 217 of file at32f413_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_clock_enable()

void usart_clock_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart enable the ck pin.

Note
clock enable are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | TRUE or FALSE
Return values
none

Definition at line 233 of file at32f413_usart.c.

Referenced by usart_configuration(), and usart_spi_configuration().

◆ usart_data_receive()

uint16_t usart_data_receive ( usart_type * usart_x )

return the most recent received data by the usart peripheral.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
the received data.

Definition at line 386 of file at32f413_usart.c.

Referenced by main(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart_data_transmit()

void usart_data_transmit | ( | usart_type * | usart_x,
 |  | uint16_t | data
 | ) |  |

transmit single data through the usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
data | the data to transmit.
Return values
none

Definition at line 374 of file at32f413_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_dma_receiver_enable()

void usart_dma_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma receiver interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 288 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_dma_transmitter_enable()

void usart_dma_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's dma transmitter interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the dma request sources. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 274 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_enable()

void usart_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart peripheral.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart peripheral. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 166 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_flag_clear()

void usart_flag_clear | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

clear the usart's pending flags.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
flag specifies the flag to clear. this parameter can be any combination of the following values:
  • USART_CTSCF_FLAG: (not available for UART4 and UART5).
  • USART_BFF_FLAG:
  • USART_TDC_FLAG:
  • USART_RDBF_FLAG:
Note
  • USART_PERR_FLAG, USART_FERR_FLAG, USART_NERR_FLAG, USART_ROERR_FLAG and USART_IDLEF_FLAG are cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a read operation to usart dt register (usart_data_receive()).
  • USART_RDBF_FLAG can be also cleared by a read to the usart dt register(usart_data_receive()).
  • USART_TDC_FLAG can be also cleared by software sequence: a read operation to usart sts register (usart_flag_get()) followed by a write operation to usart dt register (usart_data_transmit()).
  • USART_TDBE_FLAG is cleared only by a write to the usart dt register(usart_data_transmit()).
Return values
none

Definition at line 592 of file at32f413_usart.c.

Referenced by rs485_config().

◆ usart_flag_get()

flag_status usart_flag_get | ( | usart_type * | usart_x,
 |  | uint32_t | flag
 | ) |  |

check whether the specified usart flag is set or not.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
flag specifies the flag to check. this parameter can be one of the following values:
  • USART_CTSCF_FLAG: cts change flag (not available for UART4,UART5,USART6,UART7 and UART8)
  • USART_BFF_FLAG: break frame flag
  • USART_TDBE_FLAG: transmit data buffer empty flag
  • USART_TDC_FLAG: transmit data complete flag
  • USART_RDBF_FLAG: receive data buffer full flag
  • USART_IDLEF_FLAG: idle flag
  • USART_ROERR_FLAG: receiver overflow error flag
  • USART_NERR_FLAG: noise error flag
  • USART_FERR_FLAG: framing error flag
  • USART_PERR_FLAG: parity error flag
Return values
the new state of usart_flag (SET or RESET).

Definition at line 559 of file at32f413_usart.c.

Referenced by back_err(), back_ok(), fputc(), main(), rs485_send_data(), SC_USART_IRQHandler(), USART1_IRQHandler(), USART2_IRQHandler(), USART3_IRQHandler(), and usart_send_data().

◆ usart_hardware_flow_control_set()

void usart_hardware_flow_control_set | ( | usart_type * | usart_x,
 |  | usart_hardware_flow_control_type | flow_state
 | ) |  |

configure the usart's hardware flow control.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3
flow_state specifies the hardware flow control. this parameter can be one of the following values:
  • USART_HARDWARE_FLOW_NONE
  • USART_HARDWARE_FLOW_RTS,
  • USART_HARDWARE_FLOW_CTS,
  • USART_HARDWARE_FLOW_RTS_CTS
Return values
none

Definition at line 516 of file at32f413_usart.c.

Referenced by usart1_config(), and usart_configuration().

◆ usart_init()

void usart_init | ( | usart_type * | usart_x,
 |  | uint32_t | baud_rate,
 |  | usart_data_bit_num_type | data_bit,
 |  | usart_stop_bit_num_type | stop_bit
 | ) |  |

initialize the usart peripheral according to the specified parameters.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
baud_rate | configure the usart communication baud rate.
data_bit data bits transmitted or received in a frame this parameter can be one of the following values:
  • USART_DATA_8BITS
  • USART_DATA_9BITS.
stop_bit stop bits transmitted this parameter can be one of the following values:
  • USART_STOP_1_BIT
  • USART_STOP_0_5_BIT.
  • USART_STOP_2_BIT
  • USART_STOP_1_5_BIT.
Return values
none

Definition at line 99 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_interrupt_enable()

void usart_interrupt_enable | ( | usart_type * | usart_x,
 |  | uint32_t | usart_int,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the specified usart interrupts.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
usart_int specifies the USART interrupt sources to be enabled or disabled. this parameter can be one of the following values:
  • USART_IDLE_INT: idle interrupt
  • USART_RDBF_INT: rdbf interrupt
  • USART_TDC_INT: tdc interrupt
  • USART_TDBE_INT: tdbe interrupt
  • USART_PERR_INT: perr interrupt
  • USART_BF_INT: break frame interrupt
  • USART_ERR_INT: err interrupt
  • USART_CTSCF_INT: ctscf interrupt
new_state | new state of the specified usart interrupts. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 257 of file at32f413_usart.c.

Referenced by data_take(), main(), rs485_config(), SC_USART_IRQHandler(), uart_init(), usart1_config(), USART2_IRQHandler(), USART3_IRQHandler(), usart_configuration(), and usb_usart_config().

◆ usart_irda_low_power_enable()

void usart_irda_low_power_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

configure the usart's irda low power.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 498 of file at32f413_usart.c.

◆ usart_irda_mode_enable()

void usart_irda_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart's irda interface.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the irda mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 484 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_irda_smartcard_division_set()

void usart_irda_smartcard_division_set | ( | usart_type * | usart_x,
 |  | uint8_t | div_val
 | ) |  |

config the irda/smartcard division.

Note
the division are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
div_val | specifies the division.
Return values
none

Definition at line 426 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_lin_mode_enable()

void usart_lin_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart lin mode.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart lin mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 361 of file at32f413_usart.c.

◆ usart_parity_selection_config()

void usart_parity_selection_config | ( | usart_type * | usart_x,
 |  | usart_parity_selection_type | parity
 | ) |  |

usart parity selection config.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
parity select the none, odd or even parity. this parameter can be one of the following values:
  • USART_PARITY_NONE
  • USART_PARITY_EVEN.
  • USART_PARITY_ODD
Return values
none

Definition at line 138 of file at32f413_usart.c.

Referenced by usart1_config(), usart_configuration(), and usb_usart_config().

◆ usart_receiver_enable()

void usart_receiver_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart receiver enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | TRUE or FALSE.
Return values
none

Definition at line 192 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_receiver_mute_enable()

void usart_receiver_mute_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

config the usart in mute mode in multi-processor communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the usart mute mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 331 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_reset()

void usart_reset ( usart_type * usart_x )

deinitialize the usart peripheral registers to their default reset values.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
Return values
none

Definition at line 52 of file at32f413_usart.c.

◆ usart_single_line_halfduplex_select()

void usart_single_line_halfduplex_select | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart single line bidirectional half-duplex communication.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | new state of the single line half-duplex select. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 470 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_guard_time_set()

void usart_smartcard_guard_time_set | ( | usart_type * | usart_x,
 |  | uint8_t | guard_time_val
 | ) |  |

config the specified usart smartcard guard time.

Note
The guard time bits are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
guard_time_val | specifies the guard time (0x00~0xFF).
Return values
none

Definition at line 412 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_mode_enable()

void usart_smartcard_mode_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable the usart smart card mode.

Note
the smart card mode are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | new state of the smart card mode. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 441 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_smartcard_nack_set()

void usart_smartcard_nack_set | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

enable or disable nack transmission in smartcard mode.

Note
the smart card nack are not available for UART4 and UART5.
Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2 or USART3.
new_state | new state of the nack transmission. this parameter can be: TRUE or FALSE.
Return values
none

Definition at line 456 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_transmitter_enable()

void usart_transmitter_enable | ( | usart_type * | usart_x,
 |  | confirm_state | new_state
 | ) |  |

usart transmitter enable.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
new_state | TRUE or FALSE.
Return values
none

Definition at line 179 of file at32f413_usart.c.

Referenced by rs485_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_spi_configuration(), and usb_usart_config().

◆ usart_wakeup_id_set()

void usart_wakeup_id_set | ( | usart_type * | usart_x,
 |  | uint8_t | usart_id
 | ) |  |

set the wakeup id of the usart.

Parameters
usart_x | select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
usart_id | the matching id(0x0~0xF).
Return values
none

Definition at line 301 of file at32f413_usart.c.

Referenced by usart_configuration().

◆ usart_wakeup_mode_set()

void usart_wakeup_mode_set | ( | usart_type * | usart_x,
 |  | usart_wakeup_mode_type | wakeup_mode
 | ) |  |

select the usart wakeup method in multi-processor communication.

Parameters
usart_x select the usart or the uart peripheral. this parameter can be one of the following values: USART1, USART2, USART3, UART4 or UART5.
wakeup_mode determines the way to wake up usart method. this parameter can be one of the following values:
  • USART_WAKEUP_BY_IDLE_FRAME
  • USART_WAKEUP_BY_MATCHING_ID
Return values
none

Definition at line 317 of file at32f413_usart.c.

Referenced by usart_configuration().


AT32F413 Firmwary Library: USB

Modules | Macros | Typedefs | Variables
USB
AT32F413_periph_driver

USB driver modules. More...

Modules

USB_interrupts_definition
usb interrupt mask
USB_interrupt_flags_definition
usb interrupt flag
USB_endpoint_register_bit_definition
usb endpoint register bit define
USB_endpoint_tx_and_rx_status_definition
usb endpoint tx and rx status
USB_device_endpoint_register_type_definition
usb device endpoint register type define
USB_buffer_table_default_offset_address_definition
usb buffer table default offset address
USB_packet_buffer_start_address_definition
usb packet buffer start address
USB_exported_enum_types
USB_macro_definition
USB_exported_types
USB_exported_functions
USB_private_functions

Macros

#define USB ((usbd_type *) USBFS_BASE)

Typedefs

typedef usbd_type usb_reg_type

Variables

uint32_t g_usb_packet_address

Detailed Description

USB driver modules.

Macro Definition Documentation

◆ USB

#define USB ((usbd_type *) USBFS_BASE)

Definition at line 666 of file at32f413_usb.h.

Typedef Documentation

◆ usb_reg_type

typedef usbd_type usb_reg_type

Definition at line 668 of file at32f413_usb.h.

Variable Documentation

◆ g_usb_packet_address

uint32_t g_usb_packet_address
extern

usb buffer address

Definition at line 49 of file at32f413_usb.c.

Referenced by usb_read_packet(), usb_usbbufs_enable(), and usb_write_packet().


AT32F413 Firmwary Library: USB_interrupts_definition

Macros
USB_interrupts_definition
AT32F413_periph_driver » USB

usb interrupt mask More...

Macros

#define | USB_LSOF_INT ((uint32_t)0x00000100)
#define | USB_SOF_INT ((uint32_t)0x00000200)
#define | USB_RST_INT ((uint32_t)0x00000400)
#define | USB_SP_INT ((uint32_t)0x00000800)
#define | USB_WK_INT ((uint32_t)0x00001000)
#define | USB_BE_INT ((uint32_t)0x00002000)
#define | USB_UCFOR_INT ((uint32_t)0x00004000)
#define | USB_TC_INT ((uint32_t)0x00008000)

Detailed Description

usb interrupt mask

Macro Definition Documentation

◆ USB_BE_INT

#define USB_BE_INT ((uint32_t)0x00002000)

usb bus error interrupt

Definition at line 59 of file at32f413_usb.h.

◆ USB_LSOF_INT

#define USB_LSOF_INT ((uint32_t)0x00000100)

usb lost sof interrupt

Definition at line 54 of file at32f413_usb.h.

◆ USB_RST_INT

#define USB_RST_INT ((uint32_t)0x00000400)

usb reset interrupt

Definition at line 56 of file at32f413_usb.h.

◆ USB_SOF_INT

#define USB_SOF_INT ((uint32_t)0x00000200)

usb sof interrupt

Definition at line 55 of file at32f413_usb.h.

◆ USB_SP_INT

#define USB_SP_INT ((uint32_t)0x00000800)

usb suspend interrupt

Definition at line 57 of file at32f413_usb.h.

◆ USB_TC_INT

#define USB_TC_INT ((uint32_t)0x00008000)

usb transmission completed interrupt

Definition at line 61 of file at32f413_usb.h.

◆ USB_UCFOR_INT

#define USB_UCFOR_INT ((uint32_t)0x00004000)

usb core fifo overrun interrupt

Definition at line 60 of file at32f413_usb.h.

◆ USB_WK_INT

#define USB_WK_INT ((uint32_t)0x00001000)

usb wakeup interrupt

Definition at line 58 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_interrupt_flags_definition

Macros
USB_interrupt_flags_definition
AT32F413_periph_driver » USB

usb interrupt flag More...

Macros

#define | USB_EPT_NUM_FLAG ((uint32_t)0x0000000F)
#define | USB_INOUT_FLAG ((uint32_t)0x00000010)
#define | USB_LSOF_FLAG ((uint32_t)0x00000100)
#define | USB_SOF_FLAG ((uint32_t)0x00000200)
#define | USB_RST_FLAG ((uint32_t)0x00000400)
#define | USB_SP_FLAG ((uint32_t)0x00000800)
#define | USB_WK_FLAG ((uint32_t)0x00001000)
#define | USB_BE_FLAG ((uint32_t)0x00002000)
#define | USB_UCFOR_FLAG ((uint32_t)0x00004000)
#define | USB_TC_FLAG ((uint32_t)0x00008000)

Detailed Description

usb interrupt flag

Macro Definition Documentation

◆ USB_BE_FLAG

#define USB_BE_FLAG ((uint32_t)0x00002000)

usb bus error flag

Definition at line 79 of file at32f413_usb.h.

◆ USB_EPT_NUM_FLAG

#define USB_EPT_NUM_FLAG ((uint32_t)0x0000000F)

usb endpoint number

Definition at line 72 of file at32f413_usb.h.

◆ USB_INOUT_FLAG

#define USB_INOUT_FLAG ((uint32_t)0x00000010)

usb in/out transcation flag

Definition at line 73 of file at32f413_usb.h.

◆ USB_LSOF_FLAG

#define USB_LSOF_FLAG ((uint32_t)0x00000100)

usb lost sof flag

Definition at line 74 of file at32f413_usb.h.

◆ USB_RST_FLAG

#define USB_RST_FLAG ((uint32_t)0x00000400)

usb reset flag

Definition at line 76 of file at32f413_usb.h.

◆ USB_SOF_FLAG

#define USB_SOF_FLAG ((uint32_t)0x00000200)

usb sof flag

Definition at line 75 of file at32f413_usb.h.

◆ USB_SP_FLAG

#define USB_SP_FLAG ((uint32_t)0x00000800)

usb suspend flag

Definition at line 77 of file at32f413_usb.h.

◆ USB_TC_FLAG

#define USB_TC_FLAG ((uint32_t)0x00008000)

usb transmission completed flag

Definition at line 81 of file at32f413_usb.h.

◆ USB_UCFOR_FLAG

#define USB_UCFOR_FLAG ((uint32_t)0x00004000)

usb core fifo overrun flag

Definition at line 80 of file at32f413_usb.h.

◆ USB_WK_FLAG

#define USB_WK_FLAG ((uint32_t)0x00001000)

usb wakeup flag

Definition at line 78 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_endpoint_register_bit_definition

Macros
USB_endpoint_register_bit_definition
AT32F413_periph_driver » USB

usb endpoint register bit define More...

Macros

#define | USB_EPTADDR ((uint32_t)0x0000000F)
#define | USB_TXSTS ((uint32_t)0x00000030)
#define | USB_TXDTS ((uint32_t)0x00000040)
#define | USB_TXTC ((uint32_t)0x00000080)
#define | USB_EXF ((uint32_t)0x00000100)
#define | USB_TRANS_TYPE ((uint32_t)0x00000600)
#define | USB_SETUPTC ((uint32_t)0x00000800)
#define | USB_RXSTS ((uint32_t)0x00003000)
#define | USB_RXDTS ((uint32_t)0x00004000)
#define | USB_RXTC ((uint32_t)0x00008000)
#define | USB_EPT_BIT_MASK (uint32_t)(USB_TXTC | USB_SETUPTC | USB_EPTADDR | USB_EXF | USB_RXTC | USB_TRANS_TYPE)
#define | USB_TX_MASK (USB_TXSTS | USB_EPT_BIT_MASK)
#define | USB_RX_MASK (USB_RXSTS | USB_EPT_BIT_MASK)

Detailed Description

usb endpoint register bit define

Macro Definition Documentation

◆ USB_EPT_BIT_MASK

#define USB_EPT_BIT_MASK (uint32_t)(USB_TXTC | USB_SETUPTC | USB_EPTADDR | USB_EXF | USB_RXTC | USB_TRANS_TYPE)

usb bit mask

Definition at line 103 of file at32f413_usb.h.

◆ USB_EPTADDR

#define USB_EPTADDR ((uint32_t)0x0000000F)

usb endpoint address

Definition at line 92 of file at32f413_usb.h.

◆ USB_EXF

#define USB_EXF ((uint32_t)0x00000100)

usb endpoint extend funtion

Definition at line 96 of file at32f413_usb.h.

◆ USB_RX_MASK

#define USB_RX_MASK (USB_RXSTS | USB_EPT_BIT_MASK)

usb rx mask

Definition at line 105 of file at32f413_usb.h.

◆ USB_RXDTS

#define USB_RXDTS ((uint32_t)0x00004000)

usb rx data toggle synchronization

Definition at line 100 of file at32f413_usb.h.

◆ USB_RXSTS

#define USB_RXSTS ((uint32_t)0x00003000)

usb rx status

Definition at line 99 of file at32f413_usb.h.

◆ USB_RXTC

#define USB_RXTC ((uint32_t)0x00008000)

usb rx transcation completed

Definition at line 101 of file at32f413_usb.h.

◆ USB_SETUPTC

#define USB_SETUPTC ((uint32_t)0x00000800)

usb setup transcation completed

Definition at line 98 of file at32f413_usb.h.

◆ USB_TRANS_TYPE

#define USB_TRANS_TYPE ((uint32_t)0x00000600)

usb transfer type

Definition at line 97 of file at32f413_usb.h.

◆ USB_TX_MASK

#define USB_TX_MASK (USB_TXSTS | USB_EPT_BIT_MASK)

usb tx mask

Definition at line 104 of file at32f413_usb.h.

◆ USB_TXDTS

#define USB_TXDTS ((uint32_t)0x00000040)

usb tx data toggle synchronization

Definition at line 94 of file at32f413_usb.h.

◆ USB_TXSTS

#define USB_TXSTS ((uint32_t)0x00000030)

usb tx status

Definition at line 93 of file at32f413_usb.h.

◆ USB_TXTC

#define USB_TXTC ((uint32_t)0x00000080)

usb tx transcation completed

Definition at line 95 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_endpoint_tx_and_rx_status_definition

Macros
USB_endpoint_tx_and_rx_status_definition
AT32F413_periph_driver » USB

usb endpoint tx and rx status More...

Macros

#define | USB_TX_DISABLE ((uint32_t)0x00000000)
#define | USB_TX_STALL ((uint32_t)0x00000010)
#define | USB_TX_NAK ((uint32_t)0x00000020)
#define | USB_TX_VALID ((uint32_t)0x00000030)
#define | USB_TXDTS0 ((uint32_t)0x00000010)
#define | USB_TXDTS1 ((uint32_t)0x00000020)
#define | USB_RX_DISABLE ((uint32_t)0x00000000)
#define | USB_RX_STALL ((uint32_t)0x00001000)
#define | USB_RX_NAK ((uint32_t)0x00002000)
#define | USB_RX_VALID ((uint32_t)0x00003000)
#define | USB_RXDTS0 ((uint32_t)0x00001000)
#define | USB_RXDTS1 ((uint32_t)0x00002000)

Detailed Description

usb endpoint tx and rx status

Macro Definition Documentation

◆ USB_RX_DISABLE

#define USB_RX_DISABLE ((uint32_t)0x00000000)

usb rx status disable

Definition at line 124 of file at32f413_usb.h.

◆ USB_RX_NAK

#define USB_RX_NAK ((uint32_t)0x00002000)

usb rx status nak

Definition at line 126 of file at32f413_usb.h.

◆ USB_RX_STALL

#define USB_RX_STALL ((uint32_t)0x00001000)

usb rx status stall

Definition at line 125 of file at32f413_usb.h.

◆ USB_RX_VALID

#define USB_RX_VALID ((uint32_t)0x00003000)

usb rx status valid

Definition at line 127 of file at32f413_usb.h.

◆ USB_RXDTS0

#define USB_RXDTS0 ((uint32_t)0x00001000)

usb rx data toggle bit 0

Definition at line 129 of file at32f413_usb.h.

◆ USB_RXDTS1

#define USB_RXDTS1 ((uint32_t)0x00002000)

usb rx data toggle bit 1

Definition at line 130 of file at32f413_usb.h.

◆ USB_TX_DISABLE

#define USB_TX_DISABLE ((uint32_t)0x00000000)

usb tx status disable

Definition at line 116 of file at32f413_usb.h.

◆ USB_TX_NAK

#define USB_TX_NAK ((uint32_t)0x00000020)

usb tx status nak

Definition at line 118 of file at32f413_usb.h.

◆ USB_TX_STALL

#define USB_TX_STALL ((uint32_t)0x00000010)

usb tx status stall

Definition at line 117 of file at32f413_usb.h.

◆ USB_TX_VALID

#define USB_TX_VALID ((uint32_t)0x00000030)

usb tx status valid

Definition at line 119 of file at32f413_usb.h.

◆ USB_TXDTS0

#define USB_TXDTS0 ((uint32_t)0x00000010)

usb tx data toggle bit 0

Definition at line 121 of file at32f413_usb.h.

◆ USB_TXDTS1

#define USB_TXDTS1 ((uint32_t)0x00000020)

usb tx data toggle bit 1

Definition at line 122 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_device_endpoint_register_type_definition

Macros
USB_device_endpoint_register_type_definition
AT32F413_periph_driver » USB

usb device endpoint register type define More...

Macros

#define | USB_EPT_CONTROL ((uint32_t)0x00000200)
#define | USB_EPT_BULK ((uint32_t)0x00000000)
#define | USB_EPT_INT ((uint32_t)0x00000600)
#define | USB_EPT_ISO ((uint32_t)0x00000400)

Detailed Description

usb device endpoint register type define

Macro Definition Documentation

◆ USB_EPT_BULK

#define USB_EPT_BULK ((uint32_t)0x00000000)

usb endpoint transfer type bulk

Definition at line 142 of file at32f413_usb.h.

◆ USB_EPT_CONTROL

#define USB_EPT_CONTROL ((uint32_t)0x00000200)

usb endpoint transfer type control

Definition at line 141 of file at32f413_usb.h.

◆ USB_EPT_INT

#define USB_EPT_INT ((uint32_t)0x00000600)

usb endpoint transfer type interrupt

Definition at line 143 of file at32f413_usb.h.

◆ USB_EPT_ISO

#define USB_EPT_ISO ((uint32_t)0x00000400)

usb endpoint transfer type iso

Definition at line 144 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_buffer_table_default_offset_address_definition

Macros
USB_buffer_table_default_offset_address_definition
AT32F413_periph_driver » USB

usb buffer table default offset address More...

Macros

#define USB_BUFFER_TABLE_ADDRESS 0x0000

Detailed Description

usb buffer table default offset address

Macro Definition Documentation

◆ USB_BUFFER_TABLE_ADDRESS

#define USB_BUFFER_TABLE_ADDRESS 0x0000

usb buffer table address

Definition at line 155 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_packet_buffer_start_address_definition

Macros
USB_packet_buffer_start_address_definition
AT32F413_periph_driver » USB

usb packet buffer start address More...

Macros

#define | USB_PACKET_BUFFER_ADDRESS 0x40006000
#define | USB_PACKET_BUFFER_ADDRESS_EX 0x40007800

Detailed Description

usb packet buffer start address

Macro Definition Documentation

◆ USB_PACKET_BUFFER_ADDRESS

#define USB_PACKET_BUFFER_ADDRESS 0x40006000

usb buffer address

Definition at line 166 of file at32f413_usb.h.

◆ USB_PACKET_BUFFER_ADDRESS_EX

#define USB_PACKET_BUFFER_ADDRESS_EX 0x40007800

usb buffer extend address

Definition at line 167 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_exported_enum_types

Enumerations
USB_exported_enum_types
AT32F413_periph_driver » USB

Enumerations

enum usb_ept_number_type {
USB_EPT0 = 0x00 , USB_EPT1 = 0x01 , USB_EPT2 = 0x02 , USB_EPT3 = 0x03 ,
USB_EPT4 = 0x04 , USB_EPT5 = 0x05 , USB_EPT6 = 0x06 , USB_EPT7 = 0x07
}
usb endpoint number define More...
enum | ept_trans_type { EPT_CONTROL_TYPE = 0x00 , EPT_BULK_TYPE = 0x01 , EPT_INT_TYPE = 0x02 , EPT_ISO_TYPE = 0x03 }
usb endpoint max num define More...
enum | ept_inout_type { EPT_IN = 0x00 , EPT_OUT = 0x01 }
endpoint endpoint direction define More...
enum | data_trans_dir { DATA_TRANS_OUT = 0x00 , DATA_TRANS_IN = 0x01 }
data transfer direction More...
enum | usb_clk48_s { USB_CLK_HICK , USB_CLK_HEXT }
usb clock select More...

Detailed Description

Enumeration Type Documentation

◆ data_trans_dir

enum data_trans_dir

data transfer direction

Enumerator
DATA_TRANS_OUT | usb data transfer direction out
DATA_TRANS_IN | usb data transfer direction in

Definition at line 221 of file at32f413_usb.h.

◆ ept_inout_type

enum ept_inout_type

endpoint endpoint direction define

Enumerator
EPT_IN | usb endpoint direction in
EPT_OUT | usb endpoint direction out

Definition at line 212 of file at32f413_usb.h.

◆ ept_trans_type

enum ept_trans_type

usb endpoint max num define

endpoint transfer type define

Enumerator
EPT_CONTROL_TYPE | usb transfer type control
EPT_BULK_TYPE | usb transfer type bulk
EPT_INT_TYPE | usb transfer type interrut
EPT_ISO_TYPE | usb transfer type iso

Definition at line 201 of file at32f413_usb.h.

◆ usb_clk48_s

enum usb_clk48_s

usb clock select

Enumerator
USB_CLK_HICK
USB_CLK_HEXT

Definition at line 230 of file at32f413_usb.h.

◆ usb_ept_number_type

enum usb_ept_number_type

usb endpoint number define

Enumerator
USB_EPT0 | usb endpoint 0
USB_EPT1 | usb endpoint 1
USB_EPT2 | usb endpoint 2
USB_EPT3 | usb endpoint 3
USB_EPT4 | usb endpoint 4
USB_EPT5 | usb endpoint 5
USB_EPT6 | usb endpoint 6
USB_EPT7 | usb endpoint 7

Definition at line 180 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_macro_definition

Macros
USB_macro_definition
AT32F413_periph_driver » USB

Macros

#define | USB_SET_TXSTS(ept_num, new_sts)
set usb endpoint tx status More...
#define | USB_SET_RXSTS(ept_num, new_sts)
set usb endpoint rx status More...
#define | GET_TX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 2) * 2 + g_usb_packet_address)
get usb endpoint tx/rx length address More...
#define | GET_RX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 6) * 2 + g_usb_packet_address)
#define | USB_GET_TX_LEN(eptn) ((uint16_t)(*GET_TX_LEN_ADDR(eptn)) & 0x3ff)
get usb endpoint tx/rx data length More...
#define | USB_GET_RX_LEN(eptn) ((uint16_t)(*GET_RX_LEN_ADDR(eptn)) & 0x3ff)
#define | USB_DBUF0_GET_LEN(eptn) USB_GET_TX_LEN(eptn)
double buffer mode get endpoint buf0/buf1 data length More...
#define | USB_DBUF1_GET_LEN(eptn) USB_GET_RX_LEN(eptn)
#define | BLK32(reg, len, blks)
set usb length of rx buffer More...
#define | BLK2(reg, len, blks)
#define | USB_SET_RXLEN_REG(reg, len)
#define | USB_SET_TXLEN(eptn, len) (*(GET_TX_LEN_ADDR(eptn)) = (len))
set endpoint tx/rx transfer length More...
#define | USB_SET_RXLEN(eptn, len)
#define | USB_OUT_EPT_DOUBLE_BUF0(eptn, len)
double buffer mode set endpoint rx buf0 length More...
#define | USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir)
double buffer mode set endpoint buf0 length More...
#define | USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir)
double buffer mode set endpoint buf1 length More...
#define | USB_SET_TX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8) * 2 + g_usb_packet_address) = address)
set usb endpoint tx/rx fifo address More...
#define | USB_SET_RX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8 + 4) * 2 + g_usb_packet_address) = address)
#define | USB_SET_DOUBLE_BUFF0_ADDRESS(eptn, address) (USB_SET_TX_ADDRESS(eptn, address))
set double buffer mode usb endpoint buf0/buf1 fifo address More...
#define | USB_SET_DOUBLE_BUFF1_ADDRESS(eptn, address) (USB_SET_RX_ADDRESS(eptn, address))
#define | USB_TOGGLE_TXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_TXDTS | USB_RXTC | USB_TXTC))
set usb tx/rx toggle More...
#define | USB_TOGGLE_RXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_RXDTS | USB_RXTC | USB_TXTC))
#define | USB_CLEAR_TXDTS(eptn)
clear usb tx/rx toggle More...
#define | USB_CLEAR_RXDTS(eptn)
#define | USB_SET_TRANS_TYPE(eptn, type) (USB->ept[eptn] = (USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_TRANS_TYPE)) | type)
set usb endpoint type More...
#define | USB_SET_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | ((USB->ept[eptn] | USB_EXF) & USB_EPT_BIT_MASK))
set/clear usb extend function More...
#define | USB_CLEAR_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | (USB->ept[eptn] & ((~USB_EXF) & USB_EPT_BIT_MASK)))
#define | USB_SET_EPT_ADDRESS(eptn, address) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_EPTADDR)) | address))
set usb device address More...
#define | USB_FREE_DB_USER_BUFFER(eptn, inout)
free buffer used by application More...
#define | USB_CLEAR_TXTC(eptn) (USB->ept[eptn] &= 0xFF7F & USB_EPT_BIT_MASK)
clear tx/rx transfer completed flag More...
#define | USB_CLEAR_RXTC(eptn) (USB->ept[eptn] &= 0x7FFF & USB_EPT_BIT_MASK)
#define | USB_SET_EPT_DOUBLE_BUFFER(eptn) USB_SET_EXF(eptn)
set/clear endpoint double buffer mode More...
#define | USB_CLEAR_EPT_DOUBLE_BUFFER(eptn) USB_CLEAR_EXF(eptn)

Detailed Description

Macro Definition Documentation

◆ BLK2

#define BLK2 | ( | reg,
 |  | len,
 |  | blks
 | ) |
Value:
{ \
blks = (len) >> 1; \
if(((len) & 0x1) == 0) \
blks ++; \
*reg = (uint16_t)((blks) << 10); \
}

Definition at line 310 of file at32f413_usb.h.

◆ BLK32

#define BLK32 | ( | reg,
 |  | len,
 |  | blks
 | ) |
Value:
{ \
blks = (len) >> 5; \
if(((len) & 0x1F) == 0) \
blks --; \
*reg = ((uint16_t)((blks) << 10) | 0x8000); \
}

set usb length of rx buffer

Parameters
reg | usb rx length register
len | rx max length
blks | number of blocks

Definition at line 303 of file at32f413_usb.h.

◆ GET_RX_LEN_ADDR

#define GET_RX_LEN_ADDR ( eptn ) (uint32_t *)((USB->buftbl + eptn * 8 + 6) * 2 + g_usb_packet_address)

Definition at line 279 of file at32f413_usb.h.

◆ GET_TX_LEN_ADDR

#define GET_TX_LEN_ADDR ( eptn ) (uint32_t *)((USB->buftbl + eptn * 8 + 2) * 2 + g_usb_packet_address)

get usb endpoint tx/rx length address

Parameters
eptn endpoint number
Return values
the length address of tx/rx

Definition at line 278 of file at32f413_usb.h.

◆ USB_CLEAR_EPT_DOUBLE_BUFFER

#define USB_CLEAR_EPT_DOUBLE_BUFFER ( eptn ) USB_CLEAR_EXF(eptn)

Definition at line 487 of file at32f413_usb.h.

◆ USB_CLEAR_EXF

#define USB_CLEAR_EXF ( eptn ) (USB->ept[eptn] = USB_TXTC | USB_RXTC | (USB->ept[eptn] & ((~USB_EXF) & USB_EPT_BIT_MASK)))

Definition at line 446 of file at32f413_usb.h.

◆ USB_CLEAR_RXDTS

#define USB_CLEAR_RXDTS ( eptn )
Value:
{ \
if(USB->ept_bit[eptn].rxdts != 0) \
USB_TOGGLE_RXDTS(eptn); \
}
USB
#define USB
Definition: at32f413_usb.h:666

Definition at line 423 of file at32f413_usb.h.

◆ USB_CLEAR_RXTC

#define USB_CLEAR_RXTC ( eptn ) (USB->ept[eptn] &= 0x7FFF & USB_EPT_BIT_MASK)

Definition at line 479 of file at32f413_usb.h.

◆ USB_CLEAR_TXDTS

#define USB_CLEAR_TXDTS ( eptn )
Value:
{ \
if(USB->ept_bit[eptn].txdts != 0) \
USB_TOGGLE_TXDTS(eptn); \
}

clear usb tx/rx toggle

Parameters
eptn endpoint number
Return values
none

Definition at line 419 of file at32f413_usb.h.

◆ USB_CLEAR_TXTC

#define USB_CLEAR_TXTC ( eptn ) (USB->ept[eptn] &= 0xFF7F & USB_EPT_BIT_MASK)

clear tx/rx transfer completed flag

Parameters
eptn endpoint number
Return values
none

Definition at line 478 of file at32f413_usb.h.

◆ USB_DBUF0_GET_LEN

#define USB_DBUF0_GET_LEN ( eptn ) USB_GET_TX_LEN(eptn)

double buffer mode get endpoint buf0/buf1 data length

Parameters
eptn endpoint number
Return values
the length of buf0/buf1

Definition at line 294 of file at32f413_usb.h.

◆ USB_DBUF1_GET_LEN

#define USB_DBUF1_GET_LEN ( eptn ) USB_GET_RX_LEN(eptn)

Definition at line 295 of file at32f413_usb.h.

◆ USB_FREE_DB_USER_BUFFER

#define USB_FREE_DB_USER_BUFFER | ( | eptn,
 |  | inout
 | ) |
Value:
{ \
if(inout == DATA_TRANS_IN) \
{ \
USB_TOGGLE_RXDTS(eptn); \
} \
else \
{ \
USB_TOGGLE_TXDTS(eptn); \
} \
}
DATA_TRANS_IN
@ DATA_TRANS_IN
Definition: at32f413_usb.h:224

free buffer used by application

Parameters
eptn | endpoint number
inout | transfer direction
Return values
none

Definition at line 462 of file at32f413_usb.h.

◆ USB_GET_RX_LEN

#define USB_GET_RX_LEN ( eptn ) ((uint16_t)(*GET_RX_LEN_ADDR(eptn)) & 0x3ff)

Definition at line 287 of file at32f413_usb.h.

◆ USB_GET_TX_LEN

#define USB_GET_TX_LEN ( eptn ) ((uint16_t)(*GET_TX_LEN_ADDR(eptn)) & 0x3ff)

get usb endpoint tx/rx data length

Parameters
eptn endpoint number
Return values
the length of tx/rx

Definition at line 286 of file at32f413_usb.h.

◆ USB_OUT_EPT_DOUBLE_BUF0

#define USB_OUT_EPT_DOUBLE_BUF0 | ( | eptn,
 |  | len
 | ) |
Value:
{ \
uint32_t *rx_reg = GET_TX_LEN_ADDR(eptn); \
USB_SET_RXLEN_REG(rx_reg, (len)); \
}
GET_TX_LEN_ADDR
#define GET_TX_LEN_ADDR(eptn)
get usb endpoint tx/rx length address
Definition: at32f413_usb.h:278

double buffer mode set endpoint rx buf0 length

Parameters
eptn | endpoint number
len | transfer length
Return values
none

Definition at line 347 of file at32f413_usb.h.

◆ USB_SET_DOUBLE_BUFF0_ADDRESS

#define USB_SET_DOUBLE_BUFF0_ADDRESS | ( | eptn,
 |  | address
 | ) | (USB_SET_TX_ADDRESS(eptn, address))

set double buffer mode usb endpoint buf0/buf1 fifo address

Parameters
eptn | endpoint number
address | offset of the fifo address
Return values
none

Definition at line 403 of file at32f413_usb.h.

◆ USB_SET_DOUBLE_BUFF1_ADDRESS

#define USB_SET_DOUBLE_BUFF1_ADDRESS | ( | eptn,
 |  | address
 | ) | (USB_SET_RX_ADDRESS(eptn, address))

Definition at line 404 of file at32f413_usb.h.

◆ USB_SET_EPT_ADDRESS

#define USB_SET_EPT_ADDRESS | ( | eptn,
 |  | address
 | ) | (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_EPTADDR)) | address))

set usb device address

Parameters
eptn | endpoint number
address | device address
Return values
none

Definition at line 454 of file at32f413_usb.h.

◆ USB_SET_EPT_DOUBLE_BUF0_LEN

#define USB_SET_EPT_DOUBLE_BUF0_LEN | ( | eptn,
 |  | len,
 |  | dir
 | ) |
Value:
{ \
if(dir == DATA_TRANS_OUT) \
{ \
USB_OUT_EPT_DOUBLE_BUF0(eptn, len); \
} \
else \
{ \
*(GET_TX_LEN_ADDR(eptn)) = (len); \
} \
}
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:223

double buffer mode set endpoint buf0 length

Parameters
eptn | endpoint number
len | transfer length
dir | transfer direction(in/out)
Return values
none

Definition at line 359 of file at32f413_usb.h.

◆ USB_SET_EPT_DOUBLE_BUF1_LEN

#define USB_SET_EPT_DOUBLE_BUF1_LEN | ( | eptn,
 |  | len,
 |  | dir
 | ) |
Value:
{ \
if(dir == DATA_TRANS_OUT) \
{ \
USB_SET_RXLEN(eptn, len); \
} \
else \
{ \
*(GET_RX_LEN_ADDR(eptn)) = (len); \
} \
}
GET_RX_LEN_ADDR
#define GET_RX_LEN_ADDR(eptn)
Definition: at32f413_usb.h:279

double buffer mode set endpoint buf1 length

Parameters
eptn | endpoint number
len | transfer length
dir | transfer direction(in/out)
Return values
none

Definition at line 377 of file at32f413_usb.h.

◆ USB_SET_EPT_DOUBLE_BUFFER

#define USB_SET_EPT_DOUBLE_BUFFER ( eptn ) USB_SET_EXF(eptn)

set/clear endpoint double buffer mode

Parameters
eptn endpoint number
Return values
none

Definition at line 486 of file at32f413_usb.h.

◆ USB_SET_EXF

#define USB_SET_EXF ( eptn ) (USB->ept[eptn] = USB_TXTC | USB_RXTC | ((USB->ept[eptn] | USB_EXF) & USB_EPT_BIT_MASK))

set/clear usb extend function

Parameters
eptn endpoint number
Return values
none

Definition at line 445 of file at32f413_usb.h.

◆ USB_SET_RX_ADDRESS

#define USB_SET_RX_ADDRESS | ( | eptn,
 |  | address
 | ) | (*(uint32_t *)((USB->buftbl + eptn * 8 + 4) * 2 + g_usb_packet_address) = address)

Definition at line 395 of file at32f413_usb.h.

◆ USB_SET_RXLEN

#define USB_SET_RXLEN | ( | eptn,
 |  | len
 | ) |
Value:
{ \
uint32_t *rx_reg = GET_RX_LEN_ADDR(eptn); \
USB_SET_RXLEN_REG(rx_reg, (len)); \
}

Definition at line 336 of file at32f413_usb.h.

◆ USB_SET_RXLEN_REG

#define USB_SET_RXLEN_REG | ( | reg,
 |  | len
 | ) |
Value:
{ \
uint16_t blks; \
if(len > 62) \
{ \
BLK32(reg, len, blks); \
} \
else \
{ \
BLK2(reg, len, blks); \
} \
}

Definition at line 317 of file at32f413_usb.h.

◆ USB_SET_RXSTS

#define USB_SET_RXSTS | ( | ept_num,
 |  | new_sts
 | ) |
Value:
{ \
register uint16_t epsts = (USB->ept[ept_num]) & USB_RX_MASK; \
if((new_sts & USB_RXDTS0) != 0) \
epsts ^= USB_RXDTS0; \
if((new_sts & USB_RXDTS1) != 0) \
epsts ^= USB_RXDTS1; \
USB->ept[ept_num] = epsts | USB_RXTC | USB_TXTC; \
}
USB_RXTC
#define USB_RXTC
Definition: at32f413_usb.h:101
USB_TXTC
#define USB_TXTC
Definition: at32f413_usb.h:95
USB_RX_MASK
#define USB_RX_MASK
Definition: at32f413_usb.h:105
USB_RXDTS0
#define USB_RXDTS0
Definition: at32f413_usb.h:129
USB_RXDTS1
#define USB_RXDTS1
Definition: at32f413_usb.h:130

set usb endpoint rx status

Parameters
ept_num | endpoint number
new_sts | the new rx status of this endpoint number
Return values
none

Definition at line 264 of file at32f413_usb.h.

◆ USB_SET_TRANS_TYPE

#define USB_SET_TRANS_TYPE | ( | eptn,
 |  | type
 | ) | (USB->ept[eptn] = (USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_TRANS_TYPE)) | type)

set usb endpoint type

set usb transfer type

Parameters
eptn | endpoint number
type | transfer type
Return values
none

Definition at line 438 of file at32f413_usb.h.

◆ USB_SET_TX_ADDRESS

#define USB_SET_TX_ADDRESS | ( | eptn,
 |  | address
 | ) | (*(uint32_t *)((USB->buftbl + eptn * 8) * 2 + g_usb_packet_address) = address)

set usb endpoint tx/rx fifo address

Parameters
eptn | endpoint number
address | offset of the fifo address
Return values
none

Definition at line 394 of file at32f413_usb.h.

◆ USB_SET_TXLEN

#define USB_SET_TXLEN | ( | eptn,
 |  | len
 | ) | (*(GET_TX_LEN_ADDR(eptn)) = (len))

set endpoint tx/rx transfer length

Parameters
eptn | endpoint number
len | transfer length
Return values
none

Definition at line 335 of file at32f413_usb.h.

◆ USB_SET_TXSTS

#define USB_SET_TXSTS | ( | ept_num,
 |  | new_sts
 | ) |
Value:
{ \
register uint16_t epsts = (USB->ept[ept_num]) & USB_TX_MASK; \
if((new_sts & USB_TXDTS0) != 0) \
epsts ^= USB_TXDTS0; \
if((new_sts & USB_TXDTS1) != 0) \
epsts ^= USB_TXDTS1; \
USB->ept[ept_num] = epsts | USB_RXTC | USB_TXTC; \
}
USB_TX_MASK
#define USB_TX_MASK
Definition: at32f413_usb.h:104
USB_TXDTS1
#define USB_TXDTS1
Definition: at32f413_usb.h:122
USB_TXDTS0
#define USB_TXDTS0
Definition: at32f413_usb.h:121

set usb endpoint tx status

Parameters
ept_num | endpoint number
new_sts | the new tx status of this endpoint number
Return values
none

Definition at line 249 of file at32f413_usb.h.

◆ USB_TOGGLE_RXDTS

#define USB_TOGGLE_RXDTS ( eptn ) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_RXDTS | USB_RXTC | USB_TXTC))

Definition at line 412 of file at32f413_usb.h.

◆ USB_TOGGLE_TXDTS

#define USB_TOGGLE_TXDTS ( eptn ) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_TXDTS | USB_RXTC | USB_TXTC))

set usb tx/rx toggle

Parameters
eptn endpoint number
Return values
none

Definition at line 411 of file at32f413_usb.h.


AT32F413 Firmwary Library: USB_exported_types

Data Structures
USB_exported_types
AT32F413_periph_driver » USB

Data Structures

struct | usb_ept_info
usb endpoint infomation structure definition More...
struct | usbd_type
type define usb register all More...

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: usb_ept_info Struct Reference

Data Fields
usb_ept_info Struct Reference
AT32F413_periph_driver » USB » USB_exported_types

usb endpoint infomation structure definition More...

#include <at32f413_usb.h>

Data Fields

uint8_t | eptn
uint8_t | ept_address
uint8_t | inout
uint8_t | trans_type
uint16_t | tx_addr
uint16_t | rx_addr
uint16_t | maxpacket
uint8_t | is_double_buffer
uint8_t | stall
uint16_t | status
uint16_t | total_len
uint16_t | trans_len
uint8_t * | trans_buf
uint16_t | last_len
uint16_t | rem0_len
uint16_t | ept0_slen

Detailed Description

usb endpoint infomation structure definition

Definition at line 500 of file at32f413_usb.h.

Field Documentation

◆ ept0_slen

uint16_t usb_ept_info::ept0_slen

endpoint 0 transfer sum length

Definition at line 521 of file at32f413_usb.h.

Referenced by usbd_core_in_handler(), usbd_ctrl_recv(), and usbd_ctrl_send().

◆ ept_address

uint8_t usb_ept_info::ept_address

endpoint address

Definition at line 503 of file at32f413_usb.h.

Referenced by usb_ept_open(), and usbd_ept_defaut_init().

◆ eptn

uint8_t usb_ept_info::eptn

endpoint register number (0~7)

Definition at line 502 of file at32f413_usb.h.

Referenced by usb_ept_close(), usb_ept_open(), usb_ept_stall(), usbd_clear_stall(), usbd_ept_defaut_init(), and usbd_set_stall().

◆ inout

uint8_t usb_ept_info::inout

endpoint dir DATA_TRANS_IN or DATA_TRANS_OUT

Definition at line 504 of file at32f413_usb.h.

Referenced by usb_ept_close(), usb_ept_open(), usb_ept_stall(), usbd_ept_buf_auto_define(), usbd_ept_buf_custom_define(), usbd_ept_defaut_init(), and usbd_ept_open().

◆ is_double_buffer

uint8_t usb_ept_info::is_double_buffer

endpoint double buffer flag

Definition at line 510 of file at32f413_usb.h.

Referenced by usb_ept_close(), usb_ept_open(), usbd_ept_buf_auto_define(), usbd_ept_buf_custom_define(), usbd_ept_dbuffer_enable(), usbd_ept_send(), and usbd_eptn_handler().

◆ last_len

uint16_t usb_ept_info::last_len

last transfer length

Definition at line 519 of file at32f413_usb.h.

Referenced by usbd_core_in_handler(), and usbd_ept_send().

◆ maxpacket

uint16_t usb_ept_info::maxpacket

endpoint max packet

Definition at line 509 of file at32f413_usb.h.

Referenced by usb_ept_open(), usbd_core_in_handler(), usbd_core_out_handler(), usbd_ept_buf_auto_define(), usbd_ept_defaut_init(), usbd_ept_open(), usbd_ept_recv(), and usbd_ept_send().

◆ rem0_len

uint16_t usb_ept_info::rem0_len

rem transfer length

Definition at line 520 of file at32f413_usb.h.

Referenced by usbd_core_in_handler(), usbd_core_out_handler(), usbd_ctrl_recv(), and usbd_ctrl_send().

◆ rx_addr

uint16_t usb_ept_info::rx_addr

endpoint rx buffer offset address

Definition at line 508 of file at32f413_usb.h.

Referenced by usb_ept_open(), usbd_ept_buf_auto_define(), usbd_ept_buf_custom_define(), usbd_ept_defaut_init(), usbd_ept_send(), and usbd_eptn_handler().

◆ stall

uint8_t usb_ept_info::stall

endpoint is stall state

Definition at line 511 of file at32f413_usb.h.

Referenced by usbd_clear_stall(), usbd_endpoint_request(), and usbd_set_stall().

◆ status

uint16_t usb_ept_info::status

endpoint status

Definition at line 512 of file at32f413_usb.h.

Referenced by usbd_endpoint_request().

◆ total_len

uint16_t usb_ept_info::total_len

endpoint transmission total length

Definition at line 515 of file at32f413_usb.h.

Referenced by usbd_ept_defaut_init(), usbd_ept_recv(), usbd_ept_send(), and usbd_eptn_handler().

◆ trans_buf

uint8_t* usb_ept_info::trans_buf

endpoint transmission buffer

Definition at line 517 of file at32f413_usb.h.

Referenced by usbd_core_in_handler(), usbd_core_out_handler(), usbd_ept_defaut_init(), usbd_ept_recv(), usbd_ept_send(), and usbd_eptn_handler().

◆ trans_len

uint16_t usb_ept_info::trans_len

endpoint transmission length

Definition at line 516 of file at32f413_usb.h.

Referenced by usbd_ept_recv(), usbd_ept_send(), usbd_eptn_handler(), and usbd_get_recv_len().

◆ trans_type

uint8_t usb_ept_info::trans_type

endpoint type: EPT_CONTROL_TYPE, EPT_BULK_TYPE, EPT_INT_TYPE, EPT_ISO_TYPE

Definition at line 505 of file at32f413_usb.h.

Referenced by usb_ept_open(), and usbd_ept_open().

◆ tx_addr

uint16_t usb_ept_info::tx_addr

endpoint tx buffer offset address

Definition at line 507 of file at32f413_usb.h.

Referenced by usb_ept_open(), usbd_ept_buf_auto_define(), usbd_ept_buf_custom_define(), usbd_ept_defaut_init(), usbd_ept_send(), and usbd_eptn_handler().

The documentation for this struct was generated from the following file:
  • at32f413_usb.h


AT32F413 Firmwary Library: usbd_type Struct Reference

Data Fields
usbd_type Struct Reference
AT32F413_periph_driver » USB » USB_exported_types

type define usb register all More...

#include <at32f413_usb.h>

Data Fields

union {
__IO uint32_t ept [8]
struct {
__IO uint32_t eptaddr: 4
__IO uint32_t txsts: 2
__IO uint32_t txdts: 1
__IO uint32_t txtc: 1
__IO uint32_t exf: 1
__IO uint32_t trans_type: 2
__IO uint32_t setuptc: 1
__IO uint32_t rxsts: 2
__IO uint32_t rxdts: 1
__IO uint32_t rxtc: 1
__IO uint32_t reserved1: 16
} ept_bit [8]
};
usb endpoint register, offset:0x00 More...
union {
__IO uint32_t ctrl
struct {
__IO uint32_t csrst: 1
__IO uint32_t disusb: 1
__IO uint32_t lpm: 1
__IO uint32_t ssp: 1
__IO uint32_t gresume: 1
__IO uint32_t reserved1: 3
__IO uint32_t lsofien: 1
__IO uint32_t sofien: 1
__IO uint32_t rstien: 1
__IO uint32_t spien: 1
__IO uint32_t wkien: 1
__IO uint32_t beien: 1
__IO uint32_t ucforien: 1
__IO uint32_t tcien: 1
__IO uint32_t reserved2: 16
} ctrl_bit
};
usb control register, offset:0x40 More...
union {
__IO uint32_t intsts
struct {
__IO uint32_t ept_num: 4
__IO uint32_t inout: 1
__IO uint32_t reserved1: 3
__IO uint32_t lsof: 1
__IO uint32_t sof: 1
__IO uint32_t rst: 1
__IO uint32_t sp: 1
__IO uint32_t wk: 1
__IO uint32_t be: 1
__IO uint32_t ucfor: 1
__IO uint32_t tc: 1
__IO uint32_t reserved2: 16
} intsts_bit
};
usb interrupt status register, offset:0x44 More...
union {
__IO uint32_t sofrnum
struct {
__IO uint32_t sofnum: 11
__IO uint32_t lsofnum: 2
__IO uint32_t clck: 1
__IO uint32_t dmsts: 1
__IO uint32_t dpsts: 1
__IO uint32_t reserved1: 16
} sofrnum_bit
};
usb frame number register, offset:0x48 More...
union {
__IO uint32_t devaddr
struct {
__IO uint32_t addr: 7
__IO uint32_t cen: 1
__IO uint32_t reserved1: 24
} devaddr_bit
};
usb device address register, offset:0x4c More...
union {
__IO uint32_t buftbl
struct {
__IO uint32_t reserved1: 3
__IO uint32_t btaddr: 13
__IO uint32_t reserved2: 16
} buftbl_bit
};
usb buffer address register, offset:0x50 More...
union {
__IO uint32_t cfg
struct {
__IO uint32_t sofouten: 1
__IO uint32_t reserved1: 31
} cfg_bit
};
usb cfg control register, offset:0x60 More...

Detailed Description

type define usb register all

Definition at line 527 of file at32f413_usb.h.

Field Documentation

◆

union { ... } usbd_type::@732

usb endpoint register, offset:0x00

◆

union { ... } usbd_type::@734

usb control register, offset:0x40

◆

union { ... } usbd_type::@736

usb interrupt status register, offset:0x44

◆

union { ... } usbd_type::@738

usb frame number register, offset:0x48

◆

union { ... } usbd_type::@740

usb device address register, offset:0x4c

◆

union { ... } usbd_type::@742

usb buffer address register, offset:0x50

◆

union { ... } usbd_type::@744

usb cfg control register, offset:0x60

◆ addr

__IO uint32_t usbd_type::addr

Definition at line 627 of file at32f413_usb.h.

Referenced by usb_set_address().

◆ be

__IO uint32_t usbd_type::be

Definition at line 595 of file at32f413_usb.h.

◆ beien

__IO uint32_t usbd_type::beien

Definition at line 572 of file at32f413_usb.h.

◆ btaddr

__IO uint32_t usbd_type::btaddr

Definition at line 642 of file at32f413_usb.h.

◆ buftbl

__IO uint32_t usbd_type::buftbl

Definition at line 638 of file at32f413_usb.h.

Referenced by usb_dev_init().

◆

struct { ... } usbd_type::buftbl_bit

◆ cen

__IO uint32_t usbd_type::cen

Definition at line 628 of file at32f413_usb.h.

Referenced by usb_set_address().

◆ cfg

__IO uint32_t usbd_type::cfg

Definition at line 652 of file at32f413_usb.h.

◆

struct { ... } usbd_type::cfg_bit

◆ clck

__IO uint32_t usbd_type::clck

Definition at line 612 of file at32f413_usb.h.

◆ csrst

__IO uint32_t usbd_type::csrst

Definition at line 561 of file at32f413_usb.h.

Referenced by usb_dev_init().

◆ ctrl

__IO uint32_t usbd_type::ctrl

Definition at line 558 of file at32f413_usb.h.

Referenced by usb_interrupt_enable(), and usbd_irq_handler().

◆

struct { ... } usbd_type::ctrl_bit

Referenced by usb_connect(), usb_dev_init(), usb_disconnect(), usb_enter_suspend(), usb_exit_suspend(), usb_remote_wkup_clear(), and usb_remote_wkup_set().

◆ devaddr

__IO uint32_t usbd_type::devaddr

Definition at line 624 of file at32f413_usb.h.

Referenced by usb_dev_init().

◆

struct { ... } usbd_type::devaddr_bit

Referenced by usb_set_address().

◆ disusb

__IO uint32_t usbd_type::disusb

Definition at line 562 of file at32f413_usb.h.

Referenced by usb_connect(), and usb_disconnect().

◆ dmsts

__IO uint32_t usbd_type::dmsts

Definition at line 613 of file at32f413_usb.h.

◆ dpsts

__IO uint32_t usbd_type::dpsts

Definition at line 614 of file at32f413_usb.h.

◆ ept

__IO uint32_t usbd_type::ept[8]

Definition at line 534 of file at32f413_usb.h.

Referenced by usbd_eptn_handler().

◆

struct { ... } usbd_type::ept_bit[8]

Referenced by usbd_ept_send().

◆ ept_num

__IO uint32_t usbd_type::ept_num

Definition at line 587 of file at32f413_usb.h.

◆ eptaddr

__IO uint32_t usbd_type::eptaddr

Definition at line 537 of file at32f413_usb.h.

◆ exf

__IO uint32_t usbd_type::exf

Definition at line 541 of file at32f413_usb.h.

◆ gresume

__IO uint32_t usbd_type::gresume

Definition at line 565 of file at32f413_usb.h.

Referenced by usb_remote_wkup_clear(), and usb_remote_wkup_set().

◆ inout

__IO uint32_t usbd_type::inout

Definition at line 588 of file at32f413_usb.h.

◆ intsts

__IO uint32_t usbd_type::intsts

Definition at line 584 of file at32f413_usb.h.

Referenced by usb_dev_init(), usb_flag_clear(), usb_flag_get(), usbd_ept_loop_handler(), and usbd_irq_handler().

◆

struct { ... } usbd_type::intsts_bit

◆ lpm

__IO uint32_t usbd_type::lpm

Definition at line 563 of file at32f413_usb.h.

Referenced by usb_enter_suspend(), and usb_exit_suspend().

◆ lsof

__IO uint32_t usbd_type::lsof

Definition at line 590 of file at32f413_usb.h.

◆ lsofien

__IO uint32_t usbd_type::lsofien

Definition at line 567 of file at32f413_usb.h.

◆ lsofnum

__IO uint32_t usbd_type::lsofnum

Definition at line 611 of file at32f413_usb.h.

◆ reserved1

__IO uint32_t usbd_type::reserved1

Definition at line 547 of file at32f413_usb.h.

◆ reserved2

__IO uint32_t usbd_type::reserved2

Definition at line 575 of file at32f413_usb.h.

◆ rst

__IO uint32_t usbd_type::rst

Definition at line 592 of file at32f413_usb.h.

◆ rstien

__IO uint32_t usbd_type::rstien

Definition at line 569 of file at32f413_usb.h.

◆ rxdts

__IO uint32_t usbd_type::rxdts

Definition at line 545 of file at32f413_usb.h.

◆ rxsts

__IO uint32_t usbd_type::rxsts

Definition at line 544 of file at32f413_usb.h.

◆ rxtc

__IO uint32_t usbd_type::rxtc

Definition at line 546 of file at32f413_usb.h.

◆ setuptc

__IO uint32_t usbd_type::setuptc

Definition at line 543 of file at32f413_usb.h.

◆ sof

__IO uint32_t usbd_type::sof

Definition at line 591 of file at32f413_usb.h.

◆ sofien

__IO uint32_t usbd_type::sofien

Definition at line 568 of file at32f413_usb.h.

◆ sofnum

__IO uint32_t usbd_type::sofnum

Definition at line 610 of file at32f413_usb.h.

◆ sofouten

__IO uint32_t usbd_type::sofouten

Definition at line 655 of file at32f413_usb.h.

◆ sofrnum

__IO uint32_t usbd_type::sofrnum

Definition at line 607 of file at32f413_usb.h.

◆

struct { ... } usbd_type::sofrnum_bit

◆ sp

__IO uint32_t usbd_type::sp

Definition at line 593 of file at32f413_usb.h.

◆ spien

__IO uint32_t usbd_type::spien

Definition at line 570 of file at32f413_usb.h.

◆ ssp

__IO uint32_t usbd_type::ssp

Definition at line 564 of file at32f413_usb.h.

Referenced by usb_enter_suspend(), and usb_exit_suspend().

◆ tc

__IO uint32_t usbd_type::tc

Definition at line 597 of file at32f413_usb.h.

◆ tcien

__IO uint32_t usbd_type::tcien

Definition at line 574 of file at32f413_usb.h.

◆ trans_type

__IO uint32_t usbd_type::trans_type

Definition at line 542 of file at32f413_usb.h.

◆ txdts

__IO uint32_t usbd_type::txdts

Definition at line 539 of file at32f413_usb.h.

Referenced by usbd_ept_send().

◆ txsts

__IO uint32_t usbd_type::txsts

Definition at line 538 of file at32f413_usb.h.

◆ txtc

__IO uint32_t usbd_type::txtc

Definition at line 540 of file at32f413_usb.h.

◆ ucfor

__IO uint32_t usbd_type::ucfor

Definition at line 596 of file at32f413_usb.h.

◆ ucforien

__IO uint32_t usbd_type::ucforien

Definition at line 573 of file at32f413_usb.h.

◆ wk

__IO uint32_t usbd_type::wk

Definition at line 594 of file at32f413_usb.h.

◆ wkien

__IO uint32_t usbd_type::wkien

Definition at line 571 of file at32f413_usb.h.

The documentation for this struct was generated from the following file:
  • at32f413_usb.h


AT32F413 Firmwary Library: USB_exported_functions

Functions
USB_exported_functions
AT32F413_periph_driver » USB

Functions

void | usb_dev_init (usbd_type *usbx)
initialize usb peripheral controller register More...
void | usb_connect (usbd_type *usbx)
connect usb device More...
void | usb_disconnect (usbd_type *usbx)
disconnect usb device More...
void | usb_usbbufs_enable (usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes. More...
void | usb_ept_open (usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_write_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_interrupt_enable (usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable More...
void | usb_set_address (usbd_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept_stall (usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_enter_suspend (usbd_type *usbx)
usb device enter suspend mode More...
void | usb_exit_suspend (usbd_type *usbx)
usb device exit suspend mode More...
void | usb_remote_wkup_set (usbd_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (usbd_type *usbx)
usb remote wakeup clear More...
uint16_t | usb_buffer_malloc (uint16_t maxpacket)
usb auto malloc endpoint buffer More...
void | usb_buffer_free (void)
free usb endpoint buffer More...
flag_status | usb_flag_get (usbd_type *usbx, uint16_t flag)
get flag of usb. More...
void | usb_flag_clear (usbd_type *usbx, uint16_t flag)
clear flag of usb. More...

Detailed Description

Function Documentation

◆ usb_buffer_free()

void usb_buffer_free ( void )

free usb endpoint buffer

Parameters
none
Return values
none

Definition at line 486 of file at32f413_usb.c.

Referenced by usbd_reset_handler().

◆ usb_buffer_malloc()

uint16_t usb_buffer_malloc ( uint16_t maxpacket )

usb auto malloc endpoint buffer

Parameters
mapacket endpoint support max packet size
Return values
none

Definition at line 474 of file at32f413_usb.c.

Referenced by usbd_ept_buf_auto_define().

◆ usb_connect()

void usb_connect ( usbd_type * usbx )

connect usb device

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 81 of file at32f413_usb.c.

Referenced by usbd_connect().

◆ usb_dev_init()

void usb_dev_init ( usbd_type * usbx )

initialize usb peripheral controller register

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

< usb buffer table address

< usb sof interrupt

< usb reset interrupt

< usb suspend interrupt

< usb wakeup interrupt

< usb transmission completed interrupt

Definition at line 58 of file at32f413_usb.c.

Referenced by usbd_core_init().

◆ usb_disconnect()

void usb_disconnect ( usbd_type * usbx )

disconnect usb device

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 93 of file at32f413_usb.c.

Referenced by usbd_disconnect().

◆ usb_enter_suspend()

void usb_enter_suspend ( usbd_type * usbx )

usb device enter suspend mode

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 429 of file at32f413_usb.c.

Referenced by usbd_enter_suspend().

◆ usb_ept_close()

void usb_ept_close | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

close usb endpoint

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 258 of file at32f413_usb.c.

Referenced by usbd_ept_close().

◆ usb_ept_open()

void usb_ept_open | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

open usb endpoint

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb endpoint address

< usb endpoint transfer type control

< usb endpoint transfer type bulk

< usb endpoint transfer type interrupt

< usb endpoint transfer type iso

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb transfer type

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status nak

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status nak

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb rx transcation completed

< usb endpoint extend funtion

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status nak

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status nak

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status valid

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status valid

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb rx transcation completed

< usb endpoint extend funtion

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status valid

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status valid

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 139 of file at32f413_usb.c.

Referenced by usbd_ept_open().

◆ usb_ept_stall()

void usb_ept_stall | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

set endpoint tx or rx status to stall

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status stall

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status stall

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status stall

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status stall

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 411 of file at32f413_usb.c.

◆ usb_exit_suspend()

void usb_exit_suspend ( usbd_type * usbx )

usb device exit suspend mode

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 441 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup(), and usbd_wakeup_handler().

◆ usb_flag_clear()

void usb_flag_clear | ( | usbd_type * | usbx,
 |  | uint16_t | flag
 | ) |  |

clear flag of usb.

Parameters
usbx select the usb peripheral
flag select the usb flag this parameter can be one of the following values:
  • USB_INOUT_FLAG
  • USB_LSOF_FLAG
  • USB_SOF_FLAG
  • USB_RST_FLAG
  • USB_SP_FLAG
  • USB_WK_FLAG
  • USB_BE_FLAG
  • USB_UCFOR_FLAG
  • USB_TC_FLAG
Return values
none

Definition at line 538 of file at32f413_usb.c.

Referenced by usbd_irq_handler().

◆ usb_flag_get()

flag_status usb_flag_get | ( | usbd_type * | usbx,
 |  | uint16_t | flag
 | ) |  |

get flag of usb.

Parameters
usbx select the usb peripheral
flag select the usb flag this parameter can be one of the following values:
  • USB_INOUT_FLAG
  • USB_LSOF_FLAG
  • USB_SOF_FLAG
  • USB_RST_FLAG
  • USB_SP_FLAG
  • USB_WK_FLAG
  • USB_BE_FLAG
  • USB_UCFOR_FLAG
  • USB_TC_FLAG
Return values
none

Definition at line 507 of file at32f413_usb.c.

◆ usb_interrupt_enable()

void usb_interrupt_enable | ( | usbd_type * | usbx,
 |  | uint16_t | interrupt,
 |  | confirm_state | new_state
 | ) |  |

usb interrupt enable

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
interrupt this parameter can be any combination of the following values:
  • USB_LSOF_INT
  • USB_SOF_INT
  • USB_RST_INT
  • USB_SP_INT
  • USB_WK_INT
  • USB_BE_INT
  • USB_UCFOR_INT
  • USB_TC_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 379 of file at32f413_usb.c.

Referenced by usb_dev_init().

◆ usb_read_packet()

void usb_read_packet | ( | uint8_t * | pusr_buf,
 |  | uint16_t | offset_addr,
 |  | uint16_t | nbytes
 | ) |  |

read data from usb buffer to user buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint rx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

Definition at line 343 of file at32f413_usb.c.

Referenced by usbd_eptn_handler().

◆ usb_remote_wkup_clear()

void usb_remote_wkup_clear ( usbd_type * usbx )

usb remote wakeup clear

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 464 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_remote_wkup_set()

void usb_remote_wkup_set ( usbd_type * usbx )

usb remote wakeup set

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 453 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_set_address()

void usb_set_address | ( | usbd_type * | usbx,
 |  | uint8_t | address
 | ) |  |

set the host assignment address

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
address | host assignment address
Return values
none

Definition at line 398 of file at32f413_usb.c.

Referenced by usbd_eptn_handler(), usbd_reset_handler(), and usbd_set_device_addr().

◆ usb_usbbufs_enable()

void usb_usbbufs_enable | ( | usbd_type * | usbx,
 |  | confirm_state | state
 | ) |  |

mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes.

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

< usb buffer extend address

< usb buffer address

Definition at line 116 of file at32f413_usb.c.

Referenced by usbd_core_init().

◆ usb_write_packet()

void usb_write_packet | ( | uint8_t * | pusr_buf,
 |  | uint16_t | offset_addr,
 |  | uint16_t | nbytes
 | ) |  |

write data from user memory to usb buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint tx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

Definition at line 316 of file at32f413_usb.c.

Referenced by usbd_ept_send().


AT32F413 Firmwary Library: USB_private_functions

Macros | Functions | Variables
USB_private_functions
AT32F413_periph_driver » USB

Macros

#define USB_ENDP_DESC_TABLE_OFFSET 0x40
usb packet buffer start address More...

Functions

void | usb_dev_init (usbd_type *usbx)
initialize usb peripheral controller register More...
void | usb_connect (usbd_type *usbx)
connect usb device More...
void | usb_disconnect (usbd_type *usbx)
disconnect usb device More...
void | usb_usbbufs_enable (usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes. More...
void | usb_ept_open (usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_write_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_interrupt_enable (usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable More...
void | usb_set_address (usbd_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept_stall (usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_enter_suspend (usbd_type *usbx)
usb device enter suspend mode More...
void | usb_exit_suspend (usbd_type *usbx)
usb device exit suspend mode More...
void | usb_remote_wkup_set (usbd_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (usbd_type *usbx)
usb remote wakeup clear More...
uint16_t | usb_buffer_malloc (uint16_t maxpacket)
usb auto malloc endpoint buffer More...
void | usb_buffer_free (void)
free usb endpoint buffer More...
flag_status | usb_flag_get (usbd_type *usbx, uint16_t flag)
get flag of usb. More...
void | usb_flag_clear (usbd_type *usbx, uint16_t flag)
clear flag of usb. More...

Variables

uint32_t | g_usb_packet_address = 0x40006000
static uint16_t | g_usb_offset_addr = 0x40

Detailed Description

Macro Definition Documentation

◆ USB_ENDP_DESC_TABLE_OFFSET

#define USB_ENDP_DESC_TABLE_OFFSET 0x40

usb packet buffer start address

Definition at line 48 of file at32f413_usb.c.

Function Documentation

◆ usb_buffer_free()

void usb_buffer_free ( void )

free usb endpoint buffer

Parameters
none
Return values
none

Definition at line 486 of file at32f413_usb.c.

Referenced by usbd_reset_handler().

◆ usb_buffer_malloc()

uint16_t usb_buffer_malloc ( uint16_t maxpacket )

usb auto malloc endpoint buffer

Parameters
mapacket endpoint support max packet size
Return values
none

Definition at line 474 of file at32f413_usb.c.

Referenced by usbd_ept_buf_auto_define().

◆ usb_connect()

void usb_connect ( usbd_type * usbx )

connect usb device

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 81 of file at32f413_usb.c.

Referenced by usbd_connect().

◆ usb_dev_init()

void usb_dev_init ( usbd_type * usbx )

initialize usb peripheral controller register

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

< usb buffer table address

< usb sof interrupt

< usb reset interrupt

< usb suspend interrupt

< usb wakeup interrupt

< usb transmission completed interrupt

Definition at line 58 of file at32f413_usb.c.

Referenced by usbd_core_init().

◆ usb_disconnect()

void usb_disconnect ( usbd_type * usbx )

disconnect usb device

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 93 of file at32f413_usb.c.

Referenced by usbd_disconnect().

◆ usb_enter_suspend()

void usb_enter_suspend ( usbd_type * usbx )

usb device enter suspend mode

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 429 of file at32f413_usb.c.

Referenced by usbd_enter_suspend().

◆ usb_ept_close()

void usb_ept_close | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

close usb endpoint

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 258 of file at32f413_usb.c.

Referenced by usbd_ept_close().

◆ usb_ept_open()

void usb_ept_open | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

open usb endpoint

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb endpoint address

< usb endpoint transfer type control

< usb endpoint transfer type bulk

< usb endpoint transfer type interrupt

< usb endpoint transfer type iso

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb transfer type

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status nak

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status nak

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb rx transcation completed

< usb endpoint extend funtion

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status disable

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status disable

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status nak

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status nak

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status valid

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status valid

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb rx transcation completed

< usb endpoint extend funtion

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx data toggle synchronization

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status valid

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status valid

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status disable

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status disable

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 139 of file at32f413_usb.c.

Referenced by usbd_ept_open().

◆ usb_ept_stall()

void usb_ept_stall | ( | usbd_type * | usbx,
 |  | usb_ept_info * | ept_info
 | ) |  |

set endpoint tx or rx status to stall

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
ept_info | endpoint information structure
Return values
none

< usb tx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb tx mask

< usb tx status stall

< usb tx data toggle bit 0

< usb tx data toggle bit 0

< usb tx status stall

< usb tx data toggle bit 1

< usb tx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

< usb rx status

< usb tx transcation completed

< usb setup transcation completed

< usb endpoint address

< usb endpoint extend funtion

< usb rx transcation completed

< usb transfer type

< usb bit mask

< usb rx mask

< usb rx status stall

< usb rx data toggle bit 0

< usb rx data toggle bit 0

< usb rx status stall

< usb rx data toggle bit 1

< usb rx data toggle bit 1

< usb rx transcation completed

< usb tx transcation completed

Definition at line 411 of file at32f413_usb.c.

◆ usb_exit_suspend()

void usb_exit_suspend ( usbd_type * usbx )

usb device exit suspend mode

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 441 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup(), and usbd_wakeup_handler().

◆ usb_flag_clear()

void usb_flag_clear | ( | usbd_type * | usbx,
 |  | uint16_t | flag
 | ) |  |

clear flag of usb.

Parameters
usbx select the usb peripheral
flag select the usb flag this parameter can be one of the following values:
  • USB_INOUT_FLAG
  • USB_LSOF_FLAG
  • USB_SOF_FLAG
  • USB_RST_FLAG
  • USB_SP_FLAG
  • USB_WK_FLAG
  • USB_BE_FLAG
  • USB_UCFOR_FLAG
  • USB_TC_FLAG
Return values
none

Definition at line 538 of file at32f413_usb.c.

Referenced by usbd_irq_handler().

◆ usb_flag_get()

flag_status usb_flag_get | ( | usbd_type * | usbx,
 |  | uint16_t | flag
 | ) |  |

get flag of usb.

Parameters
usbx select the usb peripheral
flag select the usb flag this parameter can be one of the following values:
  • USB_INOUT_FLAG
  • USB_LSOF_FLAG
  • USB_SOF_FLAG
  • USB_RST_FLAG
  • USB_SP_FLAG
  • USB_WK_FLAG
  • USB_BE_FLAG
  • USB_UCFOR_FLAG
  • USB_TC_FLAG
Return values
none

Definition at line 507 of file at32f413_usb.c.

◆ usb_interrupt_enable()

void usb_interrupt_enable | ( | usbd_type * | usbx,
 |  | uint16_t | interrupt,
 |  | confirm_state | new_state
 | ) |  |

usb interrupt enable

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
interrupt this parameter can be any combination of the following values:
  • USB_LSOF_INT
  • USB_SOF_INT
  • USB_RST_INT
  • USB_SP_INT
  • USB_WK_INT
  • USB_BE_INT
  • USB_UCFOR_INT
  • USB_TC_INT
new_state | (TRUE or FALSE)
Return values
none

Definition at line 379 of file at32f413_usb.c.

Referenced by usb_dev_init().

◆ usb_read_packet()

void usb_read_packet | ( | uint8_t * | pusr_buf,
 |  | uint16_t | offset_addr,
 |  | uint16_t | nbytes
 | ) |  |

read data from usb buffer to user buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint rx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

Definition at line 343 of file at32f413_usb.c.

Referenced by usbd_eptn_handler().

◆ usb_remote_wkup_clear()

void usb_remote_wkup_clear ( usbd_type * usbx )

usb remote wakeup clear

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 464 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_remote_wkup_set()

void usb_remote_wkup_set ( usbd_type * usbx )

usb remote wakeup set

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

Definition at line 453 of file at32f413_usb.c.

Referenced by usbd_remote_wakeup().

◆ usb_set_address()

void usb_set_address | ( | usbd_type * | usbx,
 |  | uint8_t | address
 | ) |  |

set the host assignment address

Parameters
usbx | to select the usb peripheral. parameter as following values: USB
address | host assignment address
Return values
none

Definition at line 398 of file at32f413_usb.c.

Referenced by usbd_eptn_handler(), usbd_reset_handler(), and usbd_set_device_addr().

◆ usb_usbbufs_enable()

void usb_usbbufs_enable | ( | usbd_type * | usbx,
 |  | confirm_state | state
 | ) |  |

mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes.

Parameters
usbx to select the usb peripheral. parameter as following values: USB
Return values
none

< usb buffer extend address

< usb buffer address

Definition at line 116 of file at32f413_usb.c.

Referenced by usbd_core_init().

◆ usb_write_packet()

void usb_write_packet | ( | uint8_t * | pusr_buf,
 |  | uint16_t | offset_addr,
 |  | uint16_t | nbytes
 | ) |  |

write data from user memory to usb buffer

Parameters
pusr_buf | point to user buffer
offset_addr | endpoint tx offset address
nbytes | number of bytes data write to usb buffer
Return values
none

Definition at line 316 of file at32f413_usb.c.

Referenced by usbd_ept_send().

Variable Documentation

◆ g_usb_offset_addr

uint16_t g_usb_offset_addr = 0x40
static

Definition at line 50 of file at32f413_usb.c.

Referenced by usb_buffer_free(), and usb_buffer_malloc().

◆ g_usb_packet_address

uint32_t g_usb_packet_address = 0x40006000

usb buffer address

Definition at line 49 of file at32f413_usb.c.

Referenced by usb_read_packet(), usb_usbbufs_enable(), and usb_write_packet().


AT32F413 Firmwary Library: WDT

Modules | Macros
WDT
AT32F413_periph_driver

WDT driver modules. More...

Modules

WDT_flags_definition
wdt flag
WDT_exported_types
WDT_exported_functions
WDT_private_functions

Macros

#define WDT ((wdt_type *) WDT_BASE)

Detailed Description

WDT driver modules.

Macro Definition Documentation

◆ WDT

#define WDT ((wdt_type *) WDT_BASE)

Definition at line 154 of file at32f413_wdt.h.


AT32F413 Firmwary Library: WDT_flags_definition

Macros
WDT_flags_definition
AT32F413_periph_driver » WDT

wdt flag More...

Macros

#define | WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)
#define | WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)

Detailed Description

wdt flag

Macro Definition Documentation

◆ WDT_DIVF_UPDATE_FLAG

#define WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)

wdt division value update complete flag

Definition at line 53 of file at32f413_wdt.h.

◆ WDT_RLDF_UPDATE_FLAG

#define WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)

wdt reload value update complete flag

Definition at line 54 of file at32f413_wdt.h.


AT32F413 Firmwary Library: WDT_exported_types

Data Structures | Enumerations
WDT_exported_types
AT32F413_periph_driver » WDT

Data Structures

struct wdt_type
type define wdt register all More...

Enumerations

enum wdt_division_type {
WDT_CLK_DIV_4 = 0x00 , WDT_CLK_DIV_8 = 0x01 , WDT_CLK_DIV_16 = 0x02 , WDT_CLK_DIV_32 = 0x03 ,
WDT_CLK_DIV_64 = 0x04 , WDT_CLK_DIV_128 = 0x05 , WDT_CLK_DIV_256 = 0x06
}
wdt division value type More...
enum wdt_cmd_value_type { WDT_CMD_LOCK = 0x0000 , WDT_CMD_UNLOCK = 0x5555 , WDT_CMD_ENABLE = 0xCCCC , WDT_CMD_RELOAD = 0xAAAA }
wdt cmd value type More...

Detailed Description

Enumeration Type Documentation

◆ wdt_cmd_value_type

enum wdt_cmd_value_type

wdt cmd value type

Enumerator
WDT_CMD_LOCK | disable write protection command
WDT_CMD_UNLOCK | enable write protection command
WDT_CMD_ENABLE | enable wdt command
WDT_CMD_RELOAD | reload command

Definition at line 81 of file at32f413_wdt.h.

◆ wdt_division_type

enum wdt_division_type

wdt division value type

Enumerator
WDT_CLK_DIV_4 | wdt clock divider value is 4
WDT_CLK_DIV_8 | wdt clock divider value is 8
WDT_CLK_DIV_16 | wdt clock divider value is 16
WDT_CLK_DIV_32 | wdt clock divider value is 32
WDT_CLK_DIV_64 | wdt clock divider value is 64
WDT_CLK_DIV_128 | wdt clock divider value is 128
WDT_CLK_DIV_256 | wdt clock divider value is 256

Definition at line 67 of file at32f413_wdt.h.


AT32F413 Firmwary Library: wdt_type Struct Reference

Data Fields
wdt_type Struct Reference
AT32F413_periph_driver » WDT » WDT_exported_types

type define wdt register all More...

#include <at32f413_wdt.h>

Data Fields

union {
__IO uint32_t cmd
struct {
__IO uint32_t cmd: 16
__IO uint32_t reserved1: 16
} cmd_bit
};
wdt cmd register, offset:0x00 More...
union {
__IO uint32_t div
struct {
__IO uint32_t div: 3
__IO uint32_t reserved1: 29
} div_bit
};
wdt div register, offset:0x04 More...
union {
__IO uint32_t rld
struct {
__IO uint32_t rld: 12
__IO uint32_t reserved1: 20
} rld_bit
};
wdt rld register, offset:0x08 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t divf: 1
__IO uint32_t rldf: 1
__IO uint32_t reserved1: 30
} sts_bit
};
wdt sts register, offset:0x0C More...

Detailed Description

type define wdt register all

Definition at line 92 of file at32f413_wdt.h.

Field Documentation

◆

union { ... } wdt_type::@753

wdt cmd register, offset:0x00

◆

union { ... } wdt_type::@755

wdt div register, offset:0x04

◆

union { ... } wdt_type::@757

wdt rld register, offset:0x08

◆

union { ... } wdt_type::@759

wdt sts register, offset:0x0C

◆ cmd

__IO uint32_t wdt_type::cmd

Definition at line 100 of file at32f413_wdt.h.

◆

struct { ... } wdt_type::cmd_bit

◆ div

__IO uint32_t wdt_type::div

Definition at line 113 of file at32f413_wdt.h.

◆

struct { ... } wdt_type::div_bit

◆ divf

__IO uint32_t wdt_type::divf

Definition at line 142 of file at32f413_wdt.h.

◆ reserved1

__IO uint32_t wdt_type::reserved1

Definition at line 104 of file at32f413_wdt.h.

◆ rld

__IO uint32_t wdt_type::rld

Definition at line 126 of file at32f413_wdt.h.

◆

struct { ... } wdt_type::rld_bit

◆ rldf

__IO uint32_t wdt_type::rldf

Definition at line 143 of file at32f413_wdt.h.

◆ sts

__IO uint32_t wdt_type::sts

Definition at line 139 of file at32f413_wdt.h.

◆

struct { ... } wdt_type::sts_bit
The documentation for this struct was generated from the following file:
  • at32f413_wdt.h


AT32F413 Firmwary Library: WDT_exported_functions

Functions
WDT_exported_functions
AT32F413_periph_driver » WDT

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...

Detailed Description

Function Documentation

◆ wdt_counter_reload()

void wdt_counter_reload ( void )

reload wdt counter

Parameters
none
Return values
none

Definition at line 59 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_divider_set()

void wdt_divider_set ( wdt_division_type division )

set wdt division divider

Parameters
division this parameter can be one of the following values:
  • WDT_CLK_DIV_4
  • WDT_CLK_DIV_8
  • WDT_CLK_DIV_16
  • WDT_CLK_DIV_32
  • WDT_CLK_DIV_64
  • WDT_CLK_DIV_128
  • WDT_CLK_DIV_256
Return values
none

Definition at line 87 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_enable()

void wdt_enable ( void )

wdt enable ,the reload value will be sent to the counter

Parameters
none
Return values
none

Definition at line 49 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_flag_get()

flag_status wdt_flag_get ( uint16_t wdt_flag )

get wdt flag

Parameters
wdt_flag this parameter can be one of the following values:
  • WDT_DIVF_UPDATE_FLAG: division value update complete flag.
  • WDT_RLDF_UPDATE_FLAG: reload value update complete flag.
Return values
state of wdt flag

Definition at line 117 of file at32f413_wdt.c.

◆ wdt_register_write_enable()

void wdt_register_write_enable ( confirm_state new_state )

enable or disable wdt cmd register write

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 97 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_reload_value_set()

void wdt_reload_value_set ( uint16_t reload_value )

set wdt counter reload value

Parameters
reload_value (0x0000~0x0FFF)
Return values
none

Definition at line 69 of file at32f413_wdt.c.

Referenced by main().


AT32F413 Firmwary Library: WDT_private_functions

Functions
WDT_private_functions
AT32F413_periph_driver » WDT

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...

Detailed Description

Function Documentation

◆ wdt_counter_reload()

void wdt_counter_reload ( void )

reload wdt counter

Parameters
none
Return values
none

Definition at line 59 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_divider_set()

void wdt_divider_set ( wdt_division_type division )

set wdt division divider

Parameters
division this parameter can be one of the following values:
  • WDT_CLK_DIV_4
  • WDT_CLK_DIV_8
  • WDT_CLK_DIV_16
  • WDT_CLK_DIV_32
  • WDT_CLK_DIV_64
  • WDT_CLK_DIV_128
  • WDT_CLK_DIV_256
Return values
none

Definition at line 87 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_enable()

void wdt_enable ( void )

wdt enable ,the reload value will be sent to the counter

Parameters
none
Return values
none

Definition at line 49 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_flag_get()

flag_status wdt_flag_get ( uint16_t wdt_flag )

get wdt flag

Parameters
wdt_flag this parameter can be one of the following values:
  • WDT_DIVF_UPDATE_FLAG: division value update complete flag.
  • WDT_RLDF_UPDATE_FLAG: reload value update complete flag.
Return values
state of wdt flag

Definition at line 117 of file at32f413_wdt.c.

◆ wdt_register_write_enable()

void wdt_register_write_enable ( confirm_state new_state )

enable or disable wdt cmd register write

Parameters
new_state (TRUE or FALSE)
Return values
none

Definition at line 97 of file at32f413_wdt.c.

Referenced by main().

◆ wdt_reload_value_set()

void wdt_reload_value_set ( uint16_t reload_value )

set wdt counter reload value

Parameters
reload_value (0x0000~0x0FFF)
Return values
none

Definition at line 69 of file at32f413_wdt.c.

Referenced by main().


AT32F413 Firmwary Library: WWDT

Modules | Macros
WWDT
AT32F413_periph_driver

WWDT driver modules. More...

Modules

WWDT_enable_bit_definition
wwdt enable bit
WWDT_exported_types
WWDT_exported_functions
WWDT_private_functions

Macros

#define WWDT ((wwdt_type *) WWDT_BASE)

Detailed Description

WWDT driver modules.

Macro Definition Documentation

◆ WWDT

#define WWDT ((wwdt_type *) WWDT_BASE)

Definition at line 127 of file at32f413_wwdt.h.


AT32F413 Firmwary Library: WWDT_enable_bit_definition

Macros
WWDT_enable_bit_definition
AT32F413_periph_driver » WWDT

wwdt enable bit More...

Macros

#define WWDT_EN_BIT ((uint32_t)0x00000080)

Detailed Description

wwdt enable bit

Macro Definition Documentation

◆ WWDT_EN_BIT

#define WWDT_EN_BIT ((uint32_t)0x00000080)

wwdt enable bit

Definition at line 52 of file at32f413_wwdt.h.


AT32F413 Firmwary Library: WWDT_exported_types

Data Structures | Enumerations
WWDT_exported_types
AT32F413_periph_driver » WWDT

Data Structures

struct wwdt_type
type define wwdt register all More...

Enumerations

enum wwdt_division_type { WWDT_PCLK1_DIV_4096 = 0x00 , WWDT_PCLK1_DIV_8192 = 0x01 , WWDT_PCLK1_DIV_16384 = 0x02 , WWDT_PCLK1_DIV_32768 = 0x03 }
wwdt division type More...

Detailed Description

Enumeration Type Documentation

◆ wwdt_division_type

enum wwdt_division_type

wwdt division type

Enumerator
WWDT_PCLK1_DIV_4096 | wwdt counter clock = (pclk1/4096)/1)
WWDT_PCLK1_DIV_8192 | wwdt counter clock = (pclk1/4096)/2)
WWDT_PCLK1_DIV_16384 | wwdt counter clock = (pclk1/4096)/4)
WWDT_PCLK1_DIV_32768 | wwdt counter clock = (pclk1/4096)/8)

Definition at line 65 of file at32f413_wwdt.h.


AT32F413 Firmwary Library: wwdt_type Struct Reference

Data Fields
wwdt_type Struct Reference
AT32F413_periph_driver » WWDT » WWDT_exported_types

type define wwdt register all More...

#include <at32f413_wwdt.h>

Data Fields

union {
__IO uint32_t ctrl
struct {
__IO uint32_t cnt: 7
__IO uint32_t wwdten: 1
__IO uint32_t reserved1: 24
} ctrl_bit
};
wwdt ctrl register, offset:0x00 More...
union {
__IO uint32_t cfg
struct {
__IO uint32_t win: 7
__IO uint32_t div: 2
__IO uint32_t rldien: 1
__IO uint32_t reserved1: 22
} cfg_bit
};
wwdt cfg register, offset:0x04 More...
union {
__IO uint32_t sts
struct {
__IO uint32_t rldf: 1
__IO uint32_t reserved1: 31
} sts_bit
};
wwdt cfg register, offset:0x08 More...

Detailed Description

type define wwdt register all

Definition at line 76 of file at32f413_wwdt.h.

Field Documentation

◆

union { ... } wwdt_type::@765

wwdt ctrl register, offset:0x00

◆

union { ... } wwdt_type::@767

wwdt cfg register, offset:0x04

◆

union { ... } wwdt_type::@769

wwdt cfg register, offset:0x08

◆ cfg

__IO uint32_t wwdt_type::cfg

Definition at line 98 of file at32f413_wwdt.h.

◆

struct { ... } wwdt_type::cfg_bit

◆ cnt

__IO uint32_t wwdt_type::cnt

Definition at line 87 of file at32f413_wwdt.h.

◆ ctrl

__IO uint32_t wwdt_type::ctrl

Definition at line 84 of file at32f413_wwdt.h.

◆

struct { ... } wwdt_type::ctrl_bit

◆ div

__IO uint32_t wwdt_type::div

Definition at line 102 of file at32f413_wwdt.h.

◆ reserved1

__IO uint32_t wwdt_type::reserved1

Definition at line 89 of file at32f413_wwdt.h.

◆ rldf

__IO uint32_t wwdt_type::rldf

Definition at line 116 of file at32f413_wwdt.h.

◆ rldien

__IO uint32_t wwdt_type::rldien

Definition at line 103 of file at32f413_wwdt.h.

◆ sts

__IO uint32_t wwdt_type::sts

Definition at line 113 of file at32f413_wwdt.h.

◆

struct { ... } wwdt_type::sts_bit

◆ win

__IO uint32_t wwdt_type::win

Definition at line 101 of file at32f413_wwdt.h.

◆ wwdten

__IO uint32_t wwdt_type::wwdten

Definition at line 88 of file at32f413_wwdt.h.

The documentation for this struct was generated from the following file:
  • at32f413_wwdt.h


AT32F413 Firmwary Library: WWDT_exported_functions

Functions
WWDT_exported_functions
AT32F413_periph_driver » WWDT

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

Function Documentation

◆ wwdt_counter_set()

void wwdt_counter_set ( uint8_t wwdt_cnt )

wwdt counter value set

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

Definition at line 114 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_divider_set()

void wwdt_divider_set ( wwdt_division_type division )

wwdt division set

Parameters
division this parameter can be one of the following values:
  • WWDT_PCLK1_DIV_4096 (wwdt counter clock = (pclk1/4096)/1)
  • WWDT_PCLK1_DIV_8192 (wwdt counter clock = (pclk1/4096)/2)
  • WWDT_PCLK1_DIV_16384 (wwdt counter clock = (pclk1/4096)/4)
  • WWDT_PCLK1_DIV_32768 (wwdt counter clock = (pclk1/4096)/8)
Return values
none

Definition at line 64 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_enable()

void wwdt_enable ( uint8_t wwdt_cnt )

wwdt enable and the counter value load

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

< wwdt enable bit

Definition at line 84 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_flag_clear()

void wwdt_flag_clear ( void )

wwdt reload counter interrupt flag clear

Parameters
none
Return values
none

Definition at line 74 of file at32f413_wwdt.c.

◆ wwdt_flag_get()

flag_status wwdt_flag_get ( void )

wwdt reload counter interrupt flag get

Parameters
none
Return values
state of reload counter interrupt flag

Definition at line 104 of file at32f413_wwdt.c.

◆ wwdt_interrupt_enable()

void wwdt_interrupt_enable ( void )

wwdt reload counter interrupt enable

Parameters
none
Return values
none

Definition at line 94 of file at32f413_wwdt.c.

◆ wwdt_reset()

void wwdt_reset ( void )

wwdt reset by crm reset register

Return values
none

Definition at line 48 of file at32f413_wwdt.c.

◆ wwdt_window_counter_set()

void wwdt_window_counter_set ( uint8_t window_cnt )

wwdt window counter value set

Parameters
window_cnt (0x40~0x7f)
Return values
none

Definition at line 124 of file at32f413_wwdt.c.

Referenced by main().


AT32F413 Firmwary Library: WWDT_private_functions

Functions
WWDT_private_functions
AT32F413_periph_driver » WWDT

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

Function Documentation

◆ wwdt_counter_set()

void wwdt_counter_set ( uint8_t wwdt_cnt )

wwdt counter value set

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

Definition at line 114 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_divider_set()

void wwdt_divider_set ( wwdt_division_type division )

wwdt division set

Parameters
division this parameter can be one of the following values:
  • WWDT_PCLK1_DIV_4096 (wwdt counter clock = (pclk1/4096)/1)
  • WWDT_PCLK1_DIV_8192 (wwdt counter clock = (pclk1/4096)/2)
  • WWDT_PCLK1_DIV_16384 (wwdt counter clock = (pclk1/4096)/4)
  • WWDT_PCLK1_DIV_32768 (wwdt counter clock = (pclk1/4096)/8)
Return values
none

Definition at line 64 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_enable()

void wwdt_enable ( uint8_t wwdt_cnt )

wwdt enable and the counter value load

Parameters
wwdt_cnt (0x40~0x7f)
Return values
none

< wwdt enable bit

Definition at line 84 of file at32f413_wwdt.c.

Referenced by main().

◆ wwdt_flag_clear()

void wwdt_flag_clear ( void )

wwdt reload counter interrupt flag clear

Parameters
none
Return values
none

Definition at line 74 of file at32f413_wwdt.c.

◆ wwdt_flag_get()

flag_status wwdt_flag_get ( void )

wwdt reload counter interrupt flag get

Parameters
none
Return values
state of reload counter interrupt flag

Definition at line 104 of file at32f413_wwdt.c.

◆ wwdt_interrupt_enable()

void wwdt_interrupt_enable ( void )

wwdt reload counter interrupt enable

Parameters
none
Return values
none

Definition at line 94 of file at32f413_wwdt.c.

◆ wwdt_reset()

void wwdt_reset ( void )

wwdt reset by crm reset register

Return values
none

Definition at line 48 of file at32f413_wwdt.c.

◆ wwdt_window_counter_set()

void wwdt_window_counter_set ( uint8_t window_cnt )

wwdt window counter value set

Parameters
window_cnt (0x40~0x7f)
Return values
none

Definition at line 124 of file at32f413_wwdt.c.

Referenced by main().


AT32F413 Firmwary Library: AT32F413_middlewares_i2c_application_library

Modules | Macros | Functions
AT32F413_middlewares_i2c_application_library

Modules

I2C_library_event_check_flag
I2C_library_transmission_mode
I2C_library_status_code
I2C_library_handler
I2C_library_exported_functions

Macros

#define | DMA_GET_TC_FLAG(DMA_CHANNEL)
get the dma transfer complete flag through the channel More...
#define | DMA_GET_HT_FLAG(DMA_CHANNEL)
get the dma half transfer flag through the channel More...
#define | DMA_GET_TERR_FLAG(DMA_CHANNEL)
get the dma transfer error flag through the channel More...
#define | I2C_START 0
i2c transmission status More...
#define | I2C_END 1

Functions

__WEAK void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
void | i2c_addr_flag_clear (i2c_handle_type *hi2c)
clear the addr flag. More...
void | i2c_stop_flag_clear (i2c_handle_type *hi2c)
clear the stop flag. More...
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, flag_status status, uint32_t event_check, uint32_t timeout)
wait for the flag. More...
void | i2c_dma_config (i2c_handle_type *hi2c, dma_channel_type *dma_channelx, uint8_t *pdata, uint16_t size)
dma transfer cofiguration. More...
i2c_status_type | i2c_master_write_addr (i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master transmits mode. More...
i2c_status_type | i2c_master_read_addr (i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master receive mode. More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_master_tx_isr_int (i2c_handle_type *hi2c)
master transfer mode interrupt procession function More...
void | i2c_master_rx_isr_int (i2c_handle_type *hi2c)
master receive mode interrupt procession function More...
void | i2c_slave_tx_isr_int (i2c_handle_type *hi2c)
slave transfer mode interrupt procession function More...
void | i2c_slave_rx_isr_int (i2c_handle_type *hi2c)
slave receive mode interrupt procession function More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
i2c error interrupt function. More...

Detailed Description

< define to prevent recursive inclusion ----------------------------------—

Macro Definition Documentation

◆ DMA_GET_HT_FLAG

#define DMA_GET_HT_FLAG ( DMA_CHANNEL )
Value:
(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_HDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_HDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_HDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_HDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_HDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_HDT6_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_HDT7_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_HDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_HDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_HDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_HDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_HDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_HDT6_FLAG : \
DMA2_HDT7_FLAG)
DMA1_HDT5_FLAG
#define DMA1_HDT5_FLAG
Definition: at32f413_dma.h:99
DMA2_HDT6_FLAG
#define DMA2_HDT6_FLAG
Definition: at32f413_dma.h:132
DMA1_HDT7_FLAG
#define DMA1_HDT7_FLAG
Definition: at32f413_dma.h:107
DMA2_HDT3_FLAG
#define DMA2_HDT3_FLAG
Definition: at32f413_dma.h:120
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f413_dma.h:95
DMA2_HDT5_FLAG
#define DMA2_HDT5_FLAG
Definition: at32f413_dma.h:128
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f413_dma.h:91
DMA2_HDT1_FLAG
#define DMA2_HDT1_FLAG
Definition: at32f413_dma.h:112
DMA2_HDT2_FLAG
#define DMA2_HDT2_FLAG
Definition: at32f413_dma.h:116
DMA1_HDT1_FLAG
#define DMA1_HDT1_FLAG
Definition: at32f413_dma.h:83
DMA2_HDT4_FLAG
#define DMA2_HDT4_FLAG
Definition: at32f413_dma.h:124
DMA2_HDT7_FLAG
#define DMA2_HDT7_FLAG
Definition: at32f413_dma.h:136
DMA1_HDT2_FLAG
#define DMA1_HDT2_FLAG
Definition: at32f413_dma.h:87
DMA1_HDT6_FLAG
#define DMA1_HDT6_FLAG
Definition: at32f413_dma.h:103
DMA2_CHANNEL5
#define DMA2_CHANNEL5
Definition: at32f413_dma.h:493
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:482
DMA1_CHANNEL5
#define DMA1_CHANNEL5
Definition: at32f413_dma.h:484
DMA2_CHANNEL2
#define DMA2_CHANNEL2
Definition: at32f413_dma.h:490
DMA2_CHANNEL3
#define DMA2_CHANNEL3
Definition: at32f413_dma.h:491
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:483
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
DMA2_CHANNEL6
#define DMA2_CHANNEL6
Definition: at32f413_dma.h:494
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:481
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f413_dma.h:492
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f413_dma.h:489
DMA1_CHANNEL6
#define DMA1_CHANNEL6
Definition: at32f413_dma.h:485
DMA1_CHANNEL7
#define DMA1_CHANNEL7
Definition: at32f413_dma.h:486

get the dma half transfer flag through the channel

Definition at line 56 of file i2c_application.c.

◆ DMA_GET_TC_FLAG

#define DMA_GET_TC_FLAG ( DMA_CHANNEL )
Value:
(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_FDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_FDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_FDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_FDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_FDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_FDT6_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_FDT7_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_FDT1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_FDT2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_FDT3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_FDT4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_FDT5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_FDT6_FLAG : \
DMA2_FDT7_FLAG)
DMA1_FDT7_FLAG
#define DMA1_FDT7_FLAG
Definition: at32f413_dma.h:106
DMA2_FDT7_FLAG
#define DMA2_FDT7_FLAG
Definition: at32f413_dma.h:135
DMA2_FDT4_FLAG
#define DMA2_FDT4_FLAG
Definition: at32f413_dma.h:123
DMA2_FDT6_FLAG
#define DMA2_FDT6_FLAG
Definition: at32f413_dma.h:131
DMA2_FDT2_FLAG
#define DMA2_FDT2_FLAG
Definition: at32f413_dma.h:115
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:94
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
DMA1_FDT6_FLAG
#define DMA1_FDT6_FLAG
Definition: at32f413_dma.h:102
DMA2_FDT5_FLAG
#define DMA2_FDT5_FLAG
Definition: at32f413_dma.h:127
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f413_dma.h:111
DMA2_FDT3_FLAG
#define DMA2_FDT3_FLAG
Definition: at32f413_dma.h:119
DMA1_FDT5_FLAG
#define DMA1_FDT5_FLAG
Definition: at32f413_dma.h:98
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f413_dma.h:86
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:90

get the dma transfer complete flag through the channel

Definition at line 37 of file i2c_application.c.

◆ DMA_GET_TERR_FLAG

#define DMA_GET_TERR_FLAG ( DMA_CHANNEL )
Value:
(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_DTERR1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_DTERR2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_DTERR3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_DTERR4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_DTERR5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_DTERR6_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_DTERR7_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_DTERR1_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_DTERR2_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_DTERR3_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_DTERR4_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_DTERR5_FLAG : \
((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_DTERR6_FLAG : \
DMA2_DTERR7_FLAG)
DMA1_DTERR7_FLAG
#define DMA1_DTERR7_FLAG
Definition: at32f413_dma.h:108
DMA1_DTERR3_FLAG
#define DMA1_DTERR3_FLAG
Definition: at32f413_dma.h:92
DMA2_DTERR4_FLAG
#define DMA2_DTERR4_FLAG
Definition: at32f413_dma.h:125
DMA2_DTERR7_FLAG
#define DMA2_DTERR7_FLAG
Definition: at32f413_dma.h:137
DMA1_DTERR1_FLAG
#define DMA1_DTERR1_FLAG
Definition: at32f413_dma.h:84
DMA1_DTERR4_FLAG
#define DMA1_DTERR4_FLAG
Definition: at32f413_dma.h:96
DMA2_DTERR6_FLAG
#define DMA2_DTERR6_FLAG
Definition: at32f413_dma.h:133
DMA1_DTERR6_FLAG
#define DMA1_DTERR6_FLAG
Definition: at32f413_dma.h:104
DMA1_DTERR5_FLAG
#define DMA1_DTERR5_FLAG
Definition: at32f413_dma.h:100
DMA1_DTERR2_FLAG
#define DMA1_DTERR2_FLAG
Definition: at32f413_dma.h:88
DMA2_DTERR3_FLAG
#define DMA2_DTERR3_FLAG
Definition: at32f413_dma.h:121
DMA2_DTERR5_FLAG
#define DMA2_DTERR5_FLAG
Definition: at32f413_dma.h:129
DMA2_DTERR1_FLAG
#define DMA2_DTERR1_FLAG
Definition: at32f413_dma.h:113
DMA2_DTERR2_FLAG
#define DMA2_DTERR2_FLAG
Definition: at32f413_dma.h:117

get the dma transfer error flag through the channel

Definition at line 75 of file i2c_application.c.

◆ I2C_END

#define I2C_END 1

Definition at line 95 of file i2c_application.c.

◆ I2C_START

#define I2C_START 0

i2c transmission status

Definition at line 94 of file i2c_application.c.

Function Documentation

◆ i2c_addr_flag_clear()

void i2c_addr_flag_clear ( i2c_handle_type * hi2c )

clear the addr flag.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 129 of file i2c_application.c.

Referenced by i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ i2c_config()

void i2c_config ( i2c_handle_type * hi2c )

i2c peripheral initialization.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 112 of file i2c_application.c.

Referenced by audio_codec_init(), and main().

◆ i2c_dma_config()

void i2c_dma_config | ( | i2c_handle_type * | hi2c,
 |  | dma_channel_type * | dma_channelx,
 |  | uint8_t * | pdata,
 |  | uint16_t | size
 | ) |  |

dma transfer cofiguration.

Parameters
hi2c | the handle points to the operation information.
dma_channelx | dma channel to be cofigured.
pdata | data buffer.
size | data size.
Return values
none.

< dma full data transfer interrupt

< dma full data transfer interrupt

Definition at line 247 of file i2c_application.c.

Referenced by i2c_master_receive_dma(), i2c_master_transmit_dma(), i2c_memory_read_dma(), i2c_memory_write_dma(), i2c_slave_receive_dma(), and i2c_slave_transmit_dma().

◆ i2c_dma_rx_irq_handler()

void i2c_dma_rx_irq_handler ( i2c_handle_type * hi2c )

dma reveive complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< dma full data transfer interrupt

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< i2c acknowledge failure flag

< i2c stop condition generation complete flag

< check flag none

Definition at line 2204 of file i2c_application.c.

Referenced by DMA1_Channel5_IRQHandler(), and DMA1_Channel7_IRQHandler().

◆ i2c_dma_tx_irq_handler()

void i2c_dma_tx_irq_handler ( i2c_handle_type * hi2c )

dma transmission complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< dma full data transfer interrupt

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< i2c transmit data complete flag

< check flag none

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

Definition at line 2155 of file i2c_application.c.

Referenced by DMA1_Channel4_IRQHandler(), and DMA1_Channel6_IRQHandler().

◆ i2c_err_irq_handler()

void i2c_err_irq_handler ( i2c_handle_type * hi2c )

i2c error interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c bus error flag

< i2c bus error flag

< i2c arbitration lost flag

< i2c arbitration lost flag

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c overflow or underflow flag

< i2c overflow or underflow flag

< i2c pec receive error flag

< i2c pec receive error flag

< i2c smbus timeout flag

< i2c smbus timeout flag

< i2c smbus alert flag

< i2c smbus alert flag

< i2c error interrupt

Definition at line 2253 of file i2c_application.c.

Referenced by I2C1_ERR_IRQHandler(), and I2C2_ERR_IRQHandler().

◆ i2c_evt_irq_handler()

void i2c_evt_irq_handler ( i2c_handle_type * hi2c )

interrupt procession function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 2129 of file i2c_application.c.

Referenced by I2C1_EVT_IRQHandler(), and I2C2_EVT_IRQHandler().

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

Definition at line 102 of file i2c_application.c.

Referenced by i2c_config().

◆ i2c_master_read_addr()

i2c_status_type i2c_master_read_addr | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint32_t | timeout
 | ) |  |

send address in master receive mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
timeout | maximum waiting time.
Return values
i2c status.

< i2c start condition generation complete flag

< check flag none

< i2c master 9~8 bit address header match flag

< check flag ackfail

< i2c 0~7 bit address match flag

< check flag ackfail

< i2c start condition generation complete flag

< check flag none

< i2c 0~7 bit address match flag

< check flag ackfail

Definition at line 329 of file i2c_application.c.

Referenced by i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_memory_read(), i2c_memory_read_dma(), and i2c_memory_read_int().

◆ i2c_master_receive()

i2c_status_type i2c_master_receive | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c receive data buffer full flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c receive data buffer full flag

< check flag none

Definition at line 555 of file i2c_application.c.

Referenced by main().

◆ i2c_master_receive_dma()

i2c_status_type i2c_master_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

Definition at line 1159 of file i2c_application.c.

Referenced by main().

◆ i2c_master_receive_int()

i2c_status_type i2c_master_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 908 of file i2c_application.c.

Referenced by main().

◆ i2c_master_rx_isr_int()

void i2c_master_rx_isr_int ( i2c_handle_type * hi2c )

master receive mode interrupt procession function

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c transmit data complete flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

< i2c receive data buffer full flag

< i2c data transmission interrupt

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1989 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_master_transmit()

i2c_status_type i2c_master_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data complete flag

< check flag ackfail

Definition at line 412 of file i2c_application.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_modify_freq(), and main().

◆ i2c_master_transmit_dma()

i2c_status_type i2c_master_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

Definition at line 1049 of file i2c_application.c.

Referenced by main().

◆ i2c_master_transmit_int()

i2c_status_type i2c_master_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 813 of file i2c_application.c.

Referenced by main().

◆ i2c_master_tx_isr_int()

void i2c_master_tx_isr_int ( i2c_handle_type * hi2c )

master transfer mode interrupt procession function

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c transmit data buffer empty flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1959 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_master_write_addr()

i2c_status_type i2c_master_write_addr | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint32_t | timeout
 | ) |  |

send address in master transmits mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
timeout | maximum waiting time.
Return values
i2c status.

< i2c start condition generation complete flag

< check flag none

< i2c master 9~8 bit address header match flag

< check flag ackfail

< i2c 0~7 bit address match flag

< check flag ackfail

Definition at line 276 of file i2c_application.c.

Referenced by i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), and i2c_memory_write_int().

◆ i2c_memory_read()

i2c_status_type i2c_memory_read | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c receive data buffer full flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c receive data buffer full flag

< check flag none

Definition at line 1391 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_dma()

i2c_status_type i2c_memory_read_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

Definition at line 1853 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_int()

i2c_status_type i2c_memory_read_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1667 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write()

i2c_status_type i2c_memory_write | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data complete flag

< check flag ackfail

Definition at line 1309 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_dma()

i2c_status_type i2c_memory_write_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

Definition at line 1777 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_int()

i2c_status_type i2c_memory_write_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1597 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive()

i2c_status_type i2c_slave_receive | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c receive data buffer full flag

< check flag stop

< i2c stop condition generation complete flag

< check flag ackfail

Definition at line 480 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_dma()

i2c_status_type i2c_slave_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

Definition at line 1102 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_int()

i2c_status_type i2c_slave_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 860 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_rx_isr_int()

void i2c_slave_rx_isr_int ( i2c_handle_type * hi2c )

slave receive mode interrupt procession function

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c receive data buffer full flag

< i2c stop condition generation complete flag

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 2096 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_slave_transmit()

i2c_status_type i2c_slave_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

Definition at line 726 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_dma()

i2c_status_type i2c_slave_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< check flag none

Definition at line 1235 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_int()

i2c_status_type i2c_slave_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 986 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_tx_isr_int()

void i2c_slave_tx_isr_int ( i2c_handle_type * hi2c )

slave transfer mode interrupt procession function

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c transmit data buffer empty flag

< i2c data transmission interrupt

< i2c event interrupt

< i2c error interrupt

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

Definition at line 2062 of file i2c_application.c.

Referenced by i2c_evt_irq_handler().

◆ i2c_stop_flag_clear()

void i2c_stop_flag_clear ( i2c_handle_type * hi2c )

clear the stop flag.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 143 of file i2c_application.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_slave_receive(), i2c_slave_rx_isr_int(), and i2c_wait_flag().

◆ i2c_wait_end()

i2c_status_type i2c_wait_end | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | timeout
 | ) |  |

wait for the transfer to end.

Parameters
hi2c | the handle points to the operation information.
timeout | maximum waiting time.
Return values
i2c status.

Definition at line 158 of file i2c_application.c.

Referenced by main().

◆ i2c_wait_flag()

i2c_status_type i2c_wait_flag | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | flag,
 |  | flag_status | status,
 |  | uint32_t | event_check,
 |  | uint32_t | timeout
 | ) |  |

wait for the flag.

Parameters
hi2c | the handle points to the operation information.
flag | flag to wait.
status | status to wait.
event_check flag to check while waiting for the flag. parameter as following values:
  • I2C_EVENT_CHECK_NONE
  • I2C_EVENT_CHECK_ACKFAIL
  • I2C_EVENT_CHECK_STOP
timeout | maximum waiting time.
Return values
i2c status.

< check flag ackfail

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< check flag stop

< i2c stop condition generation complete flag

Definition at line 192 of file i2c_application.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_write_addr(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().


AT32F413 Firmwary Library: I2C_library_event_check_flag

Macros
I2C_library_event_check_flag
AT32F413_middlewares_i2c_application_library

Macros

#define | I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)
#define | I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)
#define | I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)

Detailed Description

Macro Definition Documentation

◆ I2C_EVENT_CHECK_ACKFAIL

#define I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)

check flag ackfail

Definition at line 48 of file i2c_application.h.

◆ I2C_EVENT_CHECK_NONE

#define I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)

check flag none

Definition at line 47 of file i2c_application.h.

◆ I2C_EVENT_CHECK_STOP

#define I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)

check flag stop

Definition at line 49 of file i2c_application.h.


AT32F413 Firmwary Library: I2C_library_transmission_mode

Enumerations
I2C_library_transmission_mode
AT32F413_middlewares_i2c_application_library

Enumerations

enum i2c_mode_type {
I2C_INT_MA_TX = 0 , I2C_INT_MA_RX , I2C_INT_SLA_TX , I2C_INT_SLA_RX ,
I2C_DMA_MA_TX , I2C_DMA_MA_RX , I2C_DMA_SLA_TX , I2C_DMA_SLA_RX
}

Detailed Description

Enumeration Type Documentation

◆ i2c_mode_type

enum i2c_mode_type
Enumerator
I2C_INT_MA_TX
I2C_INT_MA_RX
I2C_INT_SLA_TX
I2C_INT_SLA_RX
I2C_DMA_MA_TX
I2C_DMA_MA_RX
I2C_DMA_SLA_TX
I2C_DMA_SLA_RX

Definition at line 59 of file i2c_application.h.


AT32F413 Firmwary Library: I2C_library_status_code

Enumerations
I2C_library_status_code
AT32F413_middlewares_i2c_application_library

Enumerations

enum i2c_status_type {
I2C_OK = 0 , I2C_ERR_STEP_1 , I2C_ERR_STEP_2 , I2C_ERR_STEP_3 ,
I2C_ERR_STEP_4 , I2C_ERR_STEP_5 , I2C_ERR_STEP_6 , I2C_ERR_STEP_7 ,
I2C_ERR_STEP_8 , I2C_ERR_STEP_9 , I2C_ERR_STEP_10 , I2C_ERR_STEP_11 ,
I2C_ERR_STEP_12 , I2C_ERR_START , I2C_ERR_ADDR10 , I2C_ERR_ADDR ,
I2C_ERR_STOP , I2C_ERR_ACKFAIL , I2C_ERR_TIMEOUT , I2C_ERR_INTERRUPT
}

Detailed Description

Enumeration Type Documentation

◆ i2c_status_type

enum i2c_status_type
Enumerator
I2C_OK | no error
I2C_ERR_STEP_1 | step 1 error
I2C_ERR_STEP_2 | step 2 error
I2C_ERR_STEP_3 | step 3 error
I2C_ERR_STEP_4 | step 4 error
I2C_ERR_STEP_5 | step 5 error
I2C_ERR_STEP_6 | step 6 error
I2C_ERR_STEP_7 | step 7 error
I2C_ERR_STEP_8 | step 8 error
I2C_ERR_STEP_9 | step 9 error
I2C_ERR_STEP_10 | step 10 error
I2C_ERR_STEP_11 | step 11 error
I2C_ERR_STEP_12 | step 12 error
I2C_ERR_START | start error
I2C_ERR_ADDR10 | addr10 error
I2C_ERR_ADDR | addr error
I2C_ERR_STOP | stop error
I2C_ERR_ACKFAIL | ackfail error
I2C_ERR_TIMEOUT | timeout error
I2C_ERR_INTERRUPT | interrupt error

Definition at line 80 of file i2c_application.h.


AT32F413 Firmwary Library: I2C_library_handler

Data Structures
I2C_library_handler
AT32F413_middlewares_i2c_application_library

Data Structures

struct i2c_handle_type

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: i2c_handle_type Struct Reference

Data Fields
i2c_handle_type Struct Reference
AT32F413_middlewares_i2c_application_library » I2C_library_handler

#include <i2c_application.h>

Data Fields

i2c_type * i2cx
uint8_t * | pbuff
__IO uint16_t | psize
__IO uint16_t | pcount
__IO uint32_t | mode
__IO uint32_t | timeout
__IO uint32_t | status
__IO i2c_status_type | error_code
dma_channel_type * dma_tx_channel
dma_channel_type * dma_rx_channel
dma_init_type dma_init_struct

Detailed Description

Definition at line 113 of file i2c_application.h.

Field Documentation

◆ dma_init_struct

dma_init_type i2c_handle_type::dma_init_struct

dma init parameters

Definition at line 125 of file i2c_application.h.

Referenced by i2c_dma_config(), and i2c_lowlevel_init().

◆ dma_rx_channel

dma_channel_type* i2c_handle_type::dma_rx_channel

dma receive channel

Definition at line 124 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_lowlevel_init(), i2c_master_receive_dma(), i2c_memory_read_dma(), and i2c_slave_receive_dma().

◆ dma_tx_channel

dma_channel_type* i2c_handle_type::dma_tx_channel

dma transmit channel

Definition at line 123 of file i2c_application.h.

Referenced by i2c_dma_config(), i2c_dma_tx_irq_handler(), i2c_lowlevel_init(), i2c_master_transmit_dma(), i2c_memory_write_dma(), and i2c_slave_transmit_dma().

◆ error_code

__IO i2c_status_type i2c_handle_type::error_code

i2c error code

Definition at line 122 of file i2c_application.h.

Referenced by i2c_err_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_write_addr(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_wait_end(), and i2c_wait_flag().

◆ i2cx

i2c_type* i2c_handle_type::i2cx

i2c registers base address

Definition at line 115 of file i2c_application.h.

Referenced by audio_codec_init(), i2c_addr_flag_clear(), i2c_config(), i2c_dma_config(), i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_err_irq_handler(), i2c_lowlevel_init(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_master_write_addr(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_slave_tx_isr_int(), i2c_stop_flag_clear(), i2c_wait_flag(), and main().

◆ mode

__IO uint32_t i2c_handle_type::mode

i2c communication mode

Definition at line 119 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_evt_irq_handler(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit_dma(), and i2c_slave_transmit_int().

◆ pbuff

uint8_t* i2c_handle_type::pbuff

pointer to i2c transfer buffer

Definition at line 116 of file i2c_application.h.

Referenced by i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().

◆ pcount

__IO uint16_t i2c_handle_type::pcount

i2c transfer counter

Definition at line 118 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().

◆ psize

__IO uint16_t i2c_handle_type::psize

i2c transfer size

Definition at line 117 of file i2c_application.h.

◆ status

__IO uint32_t i2c_handle_type::status

i2c communication status

Definition at line 121 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_rx_isr_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_tx_isr_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_rx_isr_int(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), i2c_slave_tx_isr_int(), and i2c_wait_end().

◆ timeout

__IO uint32_t i2c_handle_type::timeout

i2c wait time

Definition at line 120 of file i2c_application.h.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().

The documentation for this struct was generated from the following file:
  • i2c_application.h


AT32F413 Firmwary Library: I2C_library_exported_functions

Functions
I2C_library_exported_functions
AT32F413_middlewares_i2c_application_library

Functions

void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | i2c_reset_ctrl2_register (i2c_handle_type *hi2c)
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, flag_status status, uint32_t event_check, uint32_t timeout)
wait for the flag. More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
i2c error interrupt function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...

Detailed Description

Function Documentation

◆ i2c_config()

void i2c_config ( i2c_handle_type * hi2c )

i2c peripheral initialization.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 112 of file i2c_application.c.

Referenced by audio_codec_init(), and main().

◆ i2c_dma_rx_irq_handler()

void i2c_dma_rx_irq_handler ( i2c_handle_type * hi2c )

dma reveive complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< dma full data transfer interrupt

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< i2c acknowledge failure flag

< i2c stop condition generation complete flag

< check flag none

Definition at line 2204 of file i2c_application.c.

Referenced by DMA1_Channel5_IRQHandler(), and DMA1_Channel7_IRQHandler().

◆ i2c_dma_tx_irq_handler()

void i2c_dma_tx_irq_handler ( i2c_handle_type * hi2c )

dma transmission complete interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< dma full data transfer interrupt

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

< dma1 channel5 full data transfer flag

< dma1 channel6 full data transfer flag

< dma1 channel7 full data transfer flag

< dma2 channel1 full data transfer flag

< dma2 channel2 full data transfer flag

< dma2 channel3 full data transfer flag

< dma2 channel4 full data transfer flag

< dma2 channel5 full data transfer flag

< dma2 channel6 full data transfer flag

< dma2 channel7 full data transfer flag

< i2c transmit data complete flag

< check flag none

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

Definition at line 2155 of file i2c_application.c.

Referenced by DMA1_Channel4_IRQHandler(), and DMA1_Channel6_IRQHandler().

◆ i2c_err_irq_handler()

void i2c_err_irq_handler ( i2c_handle_type * hi2c )

i2c error interrupt function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

< i2c bus error flag

< i2c bus error flag

< i2c arbitration lost flag

< i2c arbitration lost flag

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< i2c overflow or underflow flag

< i2c overflow or underflow flag

< i2c pec receive error flag

< i2c pec receive error flag

< i2c smbus timeout flag

< i2c smbus timeout flag

< i2c smbus alert flag

< i2c smbus alert flag

< i2c error interrupt

Definition at line 2253 of file i2c_application.c.

Referenced by I2C1_ERR_IRQHandler(), and I2C2_ERR_IRQHandler().

◆ i2c_evt_irq_handler()

void i2c_evt_irq_handler ( i2c_handle_type * hi2c )

interrupt procession function.

Parameters
hi2c the handle points to the operation information.
Return values
none.

Definition at line 2129 of file i2c_application.c.

Referenced by I2C1_EVT_IRQHandler(), and I2C2_EVT_IRQHandler().

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

Definition at line 102 of file i2c_application.c.

Referenced by i2c_config().

◆ i2c_master_receive()

i2c_status_type i2c_master_receive | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c receive data buffer full flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c receive data buffer full flag

< check flag none

Definition at line 555 of file i2c_application.c.

Referenced by main().

◆ i2c_master_receive_dma()

i2c_status_type i2c_master_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

Definition at line 1159 of file i2c_application.c.

Referenced by main().

◆ i2c_master_receive_int()

i2c_status_type i2c_master_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 908 of file i2c_application.c.

Referenced by main().

◆ i2c_master_transmit()

i2c_status_type i2c_master_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data complete flag

< check flag ackfail

Definition at line 412 of file i2c_application.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_modify_freq(), and main().

◆ i2c_master_transmit_dma()

i2c_status_type i2c_master_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

Definition at line 1049 of file i2c_application.c.

Referenced by main().

◆ i2c_master_transmit_int()

i2c_status_type i2c_master_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the master transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | slave address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 813 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read()

i2c_status_type i2c_memory_read | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c receive data buffer full flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c transmit data complete flag

< check flag none

< i2c receive data buffer full flag

< check flag none

Definition at line 1391 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_dma()

i2c_status_type i2c_memory_read_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

Definition at line 1853 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_read_int()

i2c_status_type i2c_memory_read_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

read data from memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1667 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write()

i2c_status_type i2c_memory_write | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through polling mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data complete flag

< check flag ackfail

Definition at line 1309 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_dma()

i2c_status_type i2c_memory_write_dma | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through dma mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

Definition at line 1777 of file i2c_application.c.

Referenced by main().

◆ i2c_memory_write_int()

i2c_status_type i2c_memory_write_int | ( | i2c_handle_type * | hi2c,
 |  | uint16_t | address,
 |  | uint16_t | mem_address,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

write data to the memory device through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
address | memory device address.
mem_address | memory address.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 1597 of file i2c_application.c.

Referenced by main().

◆ i2c_reset_ctrl2_register()

void i2c_reset_ctrl2_register ( i2c_handle_type * hi2c )

◆ i2c_slave_receive()

i2c_status_type i2c_slave_receive | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c receive data buffer full flag

< check flag stop

< i2c stop condition generation complete flag

< check flag ackfail

Definition at line 480 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_dma()

i2c_status_type i2c_slave_receive_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

Definition at line 1102 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_receive_int()

i2c_status_type i2c_slave_receive_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave receive data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 860 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit()

i2c_status_type i2c_slave_transmit | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through polling mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c transmit data buffer empty flag

< check flag ackfail

< i2c acknowledge failure flag

< check flag none

< i2c acknowledge failure flag

Definition at line 726 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_dma()

i2c_status_type i2c_slave_transmit_dma | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through dma mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< check flag none

Definition at line 1235 of file i2c_application.c.

Referenced by main().

◆ i2c_slave_transmit_int()

i2c_status_type i2c_slave_transmit_int | ( | i2c_handle_type * | hi2c,
 |  | uint8_t * | pdata,
 |  | uint16_t | size,
 |  | uint32_t | timeout
 | ) |  |

the slave transmits data through interrupt mode.

Parameters
hi2c | the handle points to the operation information.
pdata | data buffer.
size | data size.
timeout | maximum waiting time.
Return values
i2c status.

< i2c bus busy flag transmission mode

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c 0~7 bit address match flag

< check flag none

< i2c event interrupt

< i2c data transmission interrupt

< i2c error interrupt

Definition at line 986 of file i2c_application.c.

Referenced by main().

◆ i2c_wait_end()

i2c_status_type i2c_wait_end | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | timeout
 | ) |  |

wait for the transfer to end.

Parameters
hi2c | the handle points to the operation information.
timeout | maximum waiting time.
Return values
i2c status.

Definition at line 158 of file i2c_application.c.

Referenced by main().

◆ i2c_wait_flag()

i2c_status_type i2c_wait_flag | ( | i2c_handle_type * | hi2c,
 |  | uint32_t | flag,
 |  | flag_status | status,
 |  | uint32_t | event_check,
 |  | uint32_t | timeout
 | ) |  |

wait for the flag.

Parameters
hi2c | the handle points to the operation information.
flag | flag to wait.
status | status to wait.
event_check flag to check while waiting for the flag. parameter as following values:
  • I2C_EVENT_CHECK_NONE
  • I2C_EVENT_CHECK_ACKFAIL
  • I2C_EVENT_CHECK_STOP
timeout | maximum waiting time.
Return values
i2c status.

< check flag ackfail

< i2c acknowledge failure flag

< i2c acknowledge failure flag

< check flag stop

< i2c stop condition generation complete flag

Definition at line 192 of file i2c_application.c.

Referenced by i2c_dma_rx_irq_handler(), i2c_dma_tx_irq_handler(), i2c_master_read_addr(), i2c_master_receive(), i2c_master_receive_dma(), i2c_master_receive_int(), i2c_master_transmit(), i2c_master_transmit_dma(), i2c_master_transmit_int(), i2c_master_write_addr(), i2c_memory_read(), i2c_memory_read_dma(), i2c_memory_read_int(), i2c_memory_write(), i2c_memory_write_dma(), i2c_memory_write_int(), i2c_slave_receive(), i2c_slave_receive_dma(), i2c_slave_receive_int(), i2c_slave_transmit(), i2c_slave_transmit_dma(), i2c_slave_transmit_int(), and i2c_slave_tx_isr_int().


AT32F413 Firmwary Library: AT32F413_middlewares_usbd_class

Modules | Variables
AT32F413_middlewares_usbd_class

Modules

USB_audio_class
usb device class audio demo
USB_audio_desc
usb device audio descriptor
USB_audio_hid_class
usb device class audio hid demo
USB_audio_hid_desc
usb device audio hid descriptor
USB_cdc_class
usb device class cdc demo
USB_cdc_desc
usb device cdc descriptor
USB_cdc_keyboard_class
usb device class composite cdc and keyboard
USB_cdc_keyboard_desc
usb device cdc keyboard descriptor
USB_cdc_msc_class
usb device class cdc msc demo
USB_cdc_msc_desc
usb device cdc msc descriptor
USB_msc_bot_scsi
usb device class mass storage demo
USB_custom_hid_class
usb device custom hid demo
USB_custom_hid_desc
usb device custom_hid descriptor
USB_hid_iap_class
usb device class hid iap demo
USB_hid_iap_desc
usb device hid_iap descriptor
USB_keyboard_class
usb device keyboard demo
USB_keyboard_desc
usb device keyboard descriptor
USB_mouse_class
usb device mouse demo
USB_mouse_desc
usb device mouse descriptor
USB_msc_class
usb device class msc demo
USB_msc_desc
usb device msc descriptor
USB_printer_class
usb device class printer demo
USB_printer_desc
usb device printer descriptor

Variables

uint8_t | cbd_typical_type::opcode
uint8_t | cbd_typical_type::lun
uint32_t | cbd_typical_type::address
uint8_t | cbd_typical_type::reserved1
uint32_t | cbd_typical_type::alloc_length
uint16_t | cbd_typical_type::reserved2
uint8_t | cbd_extended_type::opcode
uint8_t | cbd_extended_type::lun
uint32_t | cbd_extended_type::address
uint8_t | cbd_extended_type::reserved1
uint32_t | cbd_extended_type::alloc_length
uint16_t | cbd_extended_type::reserved2
uint32_t | cbw_type::dCBWSignature
uint32_t | cbw_type::dCBWTage
uint32_t | cbw_type::dCBWDataTransferLength
uint8_t | cbw_type::bmCBWFlags
uint8_t | cbw_type::bCBWLUN
uint8_t | cbw_type::bCBWCBLength
uint8_t | cbw_type::CBWCB [16]
uint32_t | csw_type::dCSWSignature
uint32_t | csw_type::dCSWTag
uint32_t | csw_type::dCSWDataResidue
uint32_t | csw_type::bCSWStatus
uint8_t | sense_type::err_code
uint8_t | sense_type::reserved1
uint8_t | sense_type::sense_key
uint32_t | sense_type::information
uint8_t | sense_type::as_length
uint32_t | sense_type::reserved2
uint8_t | sense_type::asc
uint8_t | sense_type::ascq
uint32_t | sense_type::reserved3
uint8_t | msc_type::msc_state
uint8_t | msc_type::bot_status
uint32_t | msc_type::max_lun
uint32_t | msc_type::blk_nbr [1]
uint32_t | msc_type::blk_size [1]
uint32_t | msc_type::blk_addr
uint32_t | msc_type::blk_len
uint32_t | msc_type::data_len
uint8_t | msc_type::data [4096]
uint32_t | msc_type::alt_setting
cbw_type msc_type::cbw_struct
csw_type msc_type::csw_struct
uint32_t | cdc_msc_struct_type::alt_setting
uint8_t | cdc_msc_struct_type::g_rx_buff [0x40]
uint8_t | cdc_msc_struct_type::g_cmd [0x08]
uint8_t | cdc_msc_struct_type::g_req
uint16_t | cdc_msc_struct_type::g_len
uint16_t | cdc_msc_struct_type::g_rxlen
__IO uint8_t | cdc_msc_struct_type::g_tx_completed
__IO uint8_t | cdc_msc_struct_type::g_rx_completed
linecoding_type cdc_msc_struct_type::linecoding
uint8_t | cdc_msc_struct_type::msc_state
uint8_t | cdc_msc_struct_type::bot_status
uint32_t | cdc_msc_struct_type::max_lun
uint32_t | cdc_msc_struct_type::blk_nbr [1]
uint32_t | cdc_msc_struct_type::blk_size [1]
uint32_t | cdc_msc_struct_type::blk_addr
uint32_t | cdc_msc_struct_type::blk_len
uint32_t | cdc_msc_struct_type::data_len
uint8_t | cdc_msc_struct_type::data [4096]
cbw_type cdc_msc_struct_type::cbw_struct
csw_type cdc_msc_struct_type::csw_struct

Detailed Description

Variable Documentation

◆ address [1/2]

uint32_t cbd_typical_type::address

Definition at line 166 of file cdc_msc_class.h.

◆ address [2/2]

uint32_t cbd_extended_type::address

Definition at line 179 of file cdc_msc_class.h.

◆ alloc_length [1/2]

uint32_t cbd_typical_type::alloc_length

Definition at line 168 of file cdc_msc_class.h.

◆ alloc_length [2/2]

uint32_t cbd_extended_type::alloc_length

Definition at line 181 of file cdc_msc_class.h.

◆ alt_setting [1/2]

uint32_t msc_type::alt_setting

Definition at line 242 of file cdc_msc_class.h.

Referenced by class_setup_handler().

◆ alt_setting [2/2]

uint32_t cdc_msc_struct_type::alt_setting

Definition at line 255 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler(), cdc_struct_init(), and msc_class_setup_handler().

◆ as_length

uint8_t sense_type::as_length

Definition at line 219 of file cdc_msc_class.h.

◆ asc

uint8_t sense_type::asc

Definition at line 221 of file cdc_msc_class.h.

◆ ascq

uint8_t sense_type::ascq

Definition at line 222 of file cdc_msc_class.h.

◆ bCBWCBLength

uint8_t cbw_type::bCBWCBLength

Definition at line 195 of file cdc_msc_class.h.

Referenced by bot_cbw_decode().

◆ bCBWLUN

uint8_t cbw_type::bCBWLUN

Definition at line 194 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), and bot_scsi_cmd_process().

◆ bCSWStatus

uint32_t csw_type::bCSWStatus

Definition at line 207 of file cdc_msc_class.h.

Referenced by bot_scsi_send_csw(), and bot_scsi_send_data().

◆ blk_addr [1/2]

uint32_t msc_type::blk_addr

Definition at line 236 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_addr [2/2]

uint32_t cdc_msc_struct_type::blk_addr

Definition at line 271 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_len [1/2]

uint32_t msc_type::blk_len

Definition at line 237 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_len [2/2]

uint32_t cdc_msc_struct_type::blk_len

Definition at line 272 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ blk_nbr [1/2]

uint32_t msc_type::blk_nbr

Definition at line 233 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_check_address(), and bot_scsi_format_capacity().

◆ blk_nbr [2/2]

uint32_t cdc_msc_struct_type::blk_nbr[1]

Definition at line 268 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_check_address(), and bot_scsi_format_capacity().

◆ blk_size [1/2]

uint32_t msc_type::blk_size

Definition at line 234 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_read10(), and bot_scsi_write10().

◆ blk_size [2/2]

uint32_t cdc_msc_struct_type::blk_size[1]

Definition at line 269 of file cdc_msc_class.h.

Referenced by bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_read10(), and bot_scsi_write10().

◆ bmCBWFlags

uint8_t cbw_type::bmCBWFlags

Definition at line 193 of file cdc_msc_class.h.

Referenced by bot_scsi_read10(), bot_scsi_stall(), and bot_scsi_write10().

◆ bot_status [1/2]

uint8_t msc_type::bot_status

Definition at line 230 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_init(), bot_scsi_reset(), and bot_scsi_stall().

◆ bot_status [2/2]

uint8_t cdc_msc_struct_type::bot_status

Definition at line 265 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_init(), bot_scsi_reset(), and bot_scsi_stall().

◆ cbw_struct [1/2]

cbw_type msc_type::cbw_struct

Definition at line 244 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_cmd_process(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ cbw_struct [2/2]

cbw_type cdc_msc_struct_type::cbw_struct

Definition at line 277 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_cmd_process(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ CBWCB

uint8_t cbw_type::CBWCB

Definition at line 196 of file cdc_msc_class.h.

Referenced by bot_scsi_cmd_process(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ csw_struct [1/2]

csw_type msc_type::csw_struct

Definition at line 245 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ csw_struct [2/2]

csw_type cdc_msc_struct_type::csw_struct

Definition at line 278 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ data [1/2]

uint8_t msc_type::data

Definition at line 240 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), and bot_scsi_write10().

◆ data [2/2]

uint8_t cdc_msc_struct_type::data[4096]

Definition at line 275 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), and bot_scsi_write10().

◆ data_len [1/2]

uint32_t msc_type::data_len

Definition at line 239 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_start_stop(), bot_scsi_test_unit(), and bot_scsi_verify().

◆ data_len [2/2]

uint32_t cdc_msc_struct_type::data_len

Definition at line 274 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_format_capacity(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_start_stop(), bot_scsi_test_unit(), and bot_scsi_verify().

◆ dCBWDataTransferLength

uint32_t cbw_type::dCBWDataTransferLength

Definition at line 192 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_inquiry(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_test_unit(), and bot_scsi_write10().

◆ dCBWSignature

uint32_t cbw_type::dCBWSignature

Definition at line 190 of file cdc_msc_class.h.

Referenced by bot_cbw_decode().

◆ dCBWTage

uint32_t cbw_type::dCBWTage

Definition at line 191 of file cdc_msc_class.h.

Referenced by bot_cbw_decode().

◆ dCSWDataResidue

uint32_t csw_type::dCSWDataResidue

Definition at line 206 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_send_data(), and bot_scsi_write10().

◆ dCSWSignature

uint32_t csw_type::dCSWSignature

Definition at line 204 of file cdc_msc_class.h.

Referenced by bot_scsi_init(), and bot_scsi_send_csw().

◆ dCSWTag

uint32_t csw_type::dCSWTag

Definition at line 205 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), and bot_scsi_init().

◆ err_code

uint8_t sense_type::err_code

Definition at line 215 of file cdc_msc_class.h.

◆ g_cmd

uint8_t cdc_msc_struct_type::g_cmd[0x08]

Definition at line 257 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_len

uint16_t cdc_msc_struct_type::g_len

Definition at line 259 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler().

◆ g_req

uint8_t cdc_msc_struct_type::g_req

Definition at line 258 of file cdc_msc_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_rx_buff

uint8_t cdc_msc_struct_type::g_rx_buff[0x40]

Definition at line 256 of file cdc_msc_class.h.

Referenced by class_init_handler(), and usb_vcp_get_rxdata().

◆ g_rx_completed

__IO uint8_t cdc_msc_struct_type::g_rx_completed

Definition at line 260 of file cdc_msc_class.h.

Referenced by cdc_struct_init(), class_out_handler(), and usb_vcp_get_rxdata().

◆ g_rxlen

uint16_t cdc_msc_struct_type::g_rxlen

Definition at line 259 of file cdc_msc_class.h.

Referenced by class_out_handler(), and usb_vcp_get_rxdata().

◆ g_tx_completed

__IO uint8_t cdc_msc_struct_type::g_tx_completed

Definition at line 260 of file cdc_msc_class.h.

Referenced by cdc_struct_init(), class_in_handler(), and usb_vcp_send_data().

◆ information

uint32_t sense_type::information

Definition at line 218 of file cdc_msc_class.h.

◆ linecoding

linecoding_type cdc_msc_struct_type::linecoding

Definition at line 261 of file cdc_msc_class.h.

Referenced by cdc_struct_init(), and usb_vcp_cmd_process().

◆ lun [1/2]

uint8_t cbd_typical_type::lun

Definition at line 165 of file cdc_msc_class.h.

◆ lun [2/2]

uint8_t cbd_extended_type::lun

Definition at line 178 of file cdc_msc_class.h.

◆ max_lun [1/2]

uint32_t msc_type::max_lun

Definition at line 231 of file cdc_msc_class.h.

Referenced by bot_scsi_init(), bot_scsi_reset(), and class_setup_handler().

◆ max_lun [2/2]

uint32_t cdc_msc_struct_type::max_lun

Definition at line 266 of file cdc_msc_class.h.

Referenced by bot_scsi_init(), bot_scsi_reset(), and msc_class_setup_handler().

◆ msc_state [1/2]

uint8_t msc_type::msc_state

Definition at line 229 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ msc_state [2/2]

uint8_t cdc_msc_struct_type::msc_state

Definition at line 264 of file cdc_msc_class.h.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_init(), bot_scsi_read10(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), and bot_scsi_write10().

◆ opcode [1/2]

uint8_t cbd_typical_type::opcode

Definition at line 164 of file cdc_msc_class.h.

◆ opcode [2/2]

uint8_t cbd_extended_type::opcode

Definition at line 177 of file cdc_msc_class.h.

◆ reserved1 [1/3]

uint8_t cbd_typical_type::reserved1

Definition at line 167 of file cdc_msc_class.h.

◆ reserved1 [2/3]

uint8_t cbd_extended_type::reserved1

Definition at line 180 of file cdc_msc_class.h.

◆ reserved1 [3/3]

uint8_t sense_type::reserved1

Definition at line 216 of file cdc_msc_class.h.

◆ reserved2 [1/3]

uint16_t cbd_typical_type::reserved2

Definition at line 169 of file cdc_msc_class.h.

◆ reserved2 [2/3]

uint16_t cbd_extended_type::reserved2

Definition at line 182 of file cdc_msc_class.h.

◆ reserved2 [3/3]

uint32_t sense_type::reserved2

Definition at line 220 of file cdc_msc_class.h.

◆ reserved3

uint32_t sense_type::reserved3

Definition at line 223 of file cdc_msc_class.h.

◆ sense_key

uint8_t sense_type::sense_key

Definition at line 217 of file cdc_msc_class.h.


AT32F413 Firmwary Library: USB_audio_class

Modules
USB_audio_class
AT32F413_middlewares_usbd_class

usb device class audio demo More...

Modules

USB_audio_class_private_functions
USB_audio_class_definition
USB_device_audio_config_definition

Detailed Description

usb device class audio demo


AT32F413 Firmwary Library: USB_audio_class_private_functions

Functions | Variables
USB_audio_class_private_functions
AT32F413_middlewares_usbd_class » USB_audio_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...

Variables

usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler audio_class_handler

Detailed Description

Function Documentation

◆ audio_get_interface()

static void audio_get_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio get interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 596 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_cur()

static void audio_req_get_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 414 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_max()

static void audio_req_get_max | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get max

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 515 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_min()

static void audio_req_get_min | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get min

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 493 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_get_res()

static void audio_req_get_res | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get res

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 537 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_req_set_cur()

static void audio_req_set_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request set cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 453 of file audio_class.c.

Referenced by class_setup_handler().

◆ audio_set_interface()

static void audio_set_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio set interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 559 of file audio_class.c.

Referenced by class_setup_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 118 of file audio_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 234 of file audio_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 220 of file audio_class.c.

◆ class_event_handler()

usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | usb device core handler type
event | usb device event
Return values
status of usb_sts_type

Definition at line 378 of file audio_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 305 of file audio_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 84 of file audio_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 336 of file audio_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 141 of file audio_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 363 of file audio_class.c.

Variable Documentation

◆ audio_class_handler

usbd_class_handler audio_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&audio_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_class.c:363
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_class.c:305
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_class.c:118
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_class.c:141
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_class.c:220
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_class.c:378
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_class.c:234
audio_struct
usb_audio_type audio_struct
Definition: audio_class.c:62
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_class.c:84
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_class.c:336

Definition at line 65 of file audio_class.c.

Referenced by main().

◆ audio_struct

usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}

Definition at line 62 of file audio_class.c.


AT32F413 Firmwary Library: USB_audio_class_definition

Data Structures | Macros | Variables
USB_audio_class_definition
AT32F413_middlewares_usbd_class » USB_audio_class

Data Structures

struct usb_audio_type
usb audio control struct More...

Macros

#define | USBD_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUDIO_FEEDBACK_EPT 0x83
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Variables

usbd_class_handler audio_class_handler

Detailed Description

Macro Definition Documentation

◆ AUDIO_DESCRIPTOR_SIZE

#define AUDIO_DESCRIPTOR_SIZE 0x09

Definition at line 84 of file audio_class.h.

◆ AUDIO_DESCRIPTOR_TYPE

#define AUDIO_DESCRIPTOR_TYPE 0x21

audio descriptor type

Definition at line 83 of file audio_class.h.

◆ AUDIO_FEEDBACK_MAXPACKET_SIZE

#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3

Definition at line 64 of file audio_class.h.

◆ AUDIO_FREQ_SET_CONTROL

#define AUDIO_FREQ_SET_CONTROL 0x03

Definition at line 78 of file audio_class.h.

◆ AUDIO_MIC_IN_MAXPACKET_SIZE

#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 62 of file audio_class.h.

◆ AUDIO_MUTE_CONTROL

#define AUDIO_MUTE_CONTROL 0x01

audio set cur type define

Definition at line 76 of file audio_class.h.

◆ AUDIO_REMAIN_SIZE

#define AUDIO_REMAIN_SIZE 40

endpoint support max size

Definition at line 61 of file audio_class.h.

◆ AUDIO_REQ_CONTROL_ENDPOINT

#define AUDIO_REQ_CONTROL_ENDPOINT 0x02

Definition at line 70 of file audio_class.h.

◆ AUDIO_REQ_CONTROL_INTERFACE

#define AUDIO_REQ_CONTROL_INTERFACE 0x01

request type define

Definition at line 69 of file audio_class.h.

◆ AUDIO_REQ_CONTROL_MASK

#define AUDIO_REQ_CONTROL_MASK 0x03

Definition at line 71 of file audio_class.h.

◆ AUDIO_SPK_OUT_MAXPACKET_SIZE

#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 63 of file audio_class.h.

◆ AUDIO_VOLUME_CONTROL

#define AUDIO_VOLUME_CONTROL 0x02

Definition at line 77 of file audio_class.h.

◆ FEEDBACK_REFRESH_TIME

#define FEEDBACK_REFRESH_TIME 0x8

Definition at line 65 of file audio_class.h.

◆ USBD_AUDIO_FEEDBACK_EPT

#define USBD_AUDIO_FEEDBACK_EPT 0x83

Definition at line 56 of file audio_class.h.

◆ USBD_AUDIO_MIC_IN_EPT

#define USBD_AUDIO_MIC_IN_EPT 0x81

endpoint define

Definition at line 54 of file audio_class.h.

◆ USBD_AUDIO_SPK_OUT_EPT

#define USBD_AUDIO_SPK_OUT_EPT 0x02

Definition at line 55 of file audio_class.h.

Variable Documentation

◆ audio_class_handler

usbd_class_handler audio_class_handler
extern

Definition at line 65 of file audio_class.c.

Referenced by main().


AT32F413 Firmwary Library: usb_audio_type Struct Reference

Data Fields
usb_audio_type Struct Reference
AT32F413_middlewares_usbd_class » USB_audio_class » USB_audio_class_definition

usb audio control struct More...

#include <audio_class.h>

Data Fields

uint8_t | enpd
uint8_t | interface
uint8_t | request_no
uint8_t | spk_mute
uint8_t | mic_mute
uint16_t | spk_volume
uint16_t | mic_volume
uint32_t | spk_freq
uint32_t | mic_freq
uint16_t | spk_volume_limits [3]
uint16_t | mic_volume_limits [3]
uint8_t | audio_cmd
uint32_t | audio_cmd_len
uint32_t | spk_alt_setting
uint32_t | mic_alt_setting
uint8_t | g_audio_cur [64]
uint8_t | audio_spk_data [(48 *2 *(16/8)+40)]
uint8_t | audio_mic_data [(48 *2 *(16/8)+40)]
uint8_t | audio_feed_back [0x3+1]

Detailed Description

usb audio control struct

Definition at line 89 of file audio_class.h.

Field Documentation

◆ audio_cmd

uint8_t usb_audio_type::audio_cmd

Definition at line 103 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ audio_cmd_len

uint32_t usb_audio_type::audio_cmd_len

Definition at line 104 of file audio_class.h.

Referenced by audio_req_set_cur().

◆ audio_feed_back

uint8_t usb_audio_type::audio_feed_back[0x3+1]

Definition at line 110 of file audio_class.h.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_mic_data

uint8_t usb_audio_type::audio_mic_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 109 of file audio_class.h.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_spk_data

uint8_t usb_audio_type::audio_spk_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 108 of file audio_class.h.

Referenced by audio_set_interface(), class_init_handler(), and class_out_handler().

◆ enpd

uint8_t usb_audio_type::enpd

Definition at line 91 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ g_audio_cur

uint8_t usb_audio_type::g_audio_cur[64]

Definition at line 107 of file audio_class.h.

Referenced by audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), and class_ept0_rx_handler().

◆ interface

uint8_t usb_audio_type::interface

Definition at line 92 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ mic_alt_setting

uint32_t usb_audio_type::mic_alt_setting

Definition at line 106 of file audio_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ mic_freq

uint32_t usb_audio_type::mic_freq

Definition at line 99 of file audio_class.h.

Referenced by class_ept0_rx_handler().

◆ mic_mute

uint8_t usb_audio_type::mic_mute

Definition at line 95 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume

uint16_t usb_audio_type::mic_volume

Definition at line 97 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume_limits

uint16_t usb_audio_type::mic_volume_limits[3]

Definition at line 101 of file audio_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

◆ request_no

uint8_t usb_audio_type::request_no

Definition at line 93 of file audio_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ spk_alt_setting

uint32_t usb_audio_type::spk_alt_setting

Definition at line 105 of file audio_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ spk_freq

uint32_t usb_audio_type::spk_freq

Definition at line 98 of file audio_class.h.

Referenced by class_ept0_rx_handler().

◆ spk_mute

uint8_t usb_audio_type::spk_mute

Definition at line 94 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume

uint16_t usb_audio_type::spk_volume

Definition at line 96 of file audio_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume_limits

uint16_t usb_audio_type::spk_volume_limits[3]

Definition at line 100 of file audio_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

The documentation for this struct was generated from the following file:
  • audio_class.h


AT32F413 Firmwary Library: USB_device_audio_config_definition

Macros
USB_device_audio_config_definition
AT32F413_middlewares_usbd_class » USB_audio_class

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 1
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

Macro Definition Documentation

◆ AUDIO_BITW_16

#define AUDIO_BITW_16 16

Definition at line 61 of file audio/audio_conf.h.

◆ AUDIO_DEFAULT_BITW

#define AUDIO_DEFAULT_BITW AUDIO_BITW_16

Definition at line 72 of file audio/audio_conf.h.

◆ AUDIO_DEFAULT_FREQ

#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K

Definition at line 71 of file audio/audio_conf.h.

◆ AUDIO_FREQ_16K

#define AUDIO_FREQ_16K 16000

Definition at line 59 of file audio/audio_conf.h.

◆ AUDIO_FREQ_48K

#define AUDIO_FREQ_48K 48000

Definition at line 60 of file audio/audio_conf.h.

◆ AUDIO_MIC_CHANEL_NUM

#define AUDIO_MIC_CHANEL_NUM 2

Definition at line 63 of file audio/audio_conf.h.

◆ AUDIO_MIC_DEFAULT_BITW

#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16

Definition at line 64 of file audio/audio_conf.h.

◆ AUDIO_SPK_CHANEL_NUM

#define AUDIO_SPK_CHANEL_NUM 2

Definition at line 66 of file audio/audio_conf.h.

◆ AUDIO_SPK_DEFAULT_BITW

#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16

Definition at line 67 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FEEDBACK

#define AUDIO_SUPPORT_FEEDBACK 1

Definition at line 49 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ

#define AUDIO_SUPPORT_FREQ
Value:
(AUDIO_SUPPORT_FREQ_16K + \
AUDIO_SUPPORT_FREQ_48K \
)
AUDIO_SUPPORT_FREQ_16K
#define AUDIO_SUPPORT_FREQ_16K
Definition: audio/audio_conf.h:51

Definition at line 55 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_16K

#define AUDIO_SUPPORT_FREQ_16K 1

Definition at line 51 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_48K

#define AUDIO_SUPPORT_FREQ_48K 1

Definition at line 52 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_MAX_FREQ

#define AUDIO_SUPPORT_MAX_FREQ 48

Definition at line 70 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_MIC

#define AUDIO_SUPPORT_MIC 1

Definition at line 48 of file audio/audio_conf.h.

◆ AUDIO_SUPPORT_SPK

#define AUDIO_SUPPORT_SPK 1

Definition at line 47 of file audio/audio_conf.h.


AT32F413 Firmwary Library: USB_audio_desc

Modules
USB_audio_desc
AT32F413_middlewares_usbd_class

usb device audio descriptor More...

Modules

USB_audio_desc_private_functions
USB_audio_desc_definition

Detailed Description

usb device audio descriptor


AT32F413 Firmwary Library: USB_audio_desc_private_functions

Functions | Variables
USB_audio_desc_private_functions
AT32F413_middlewares_usbd_class » USB_audio_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler audio_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 614 of file audio_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 536 of file audio_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 516 of file audio_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 602 of file audio_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 556 of file audio_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 567 of file audio_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 546 of file audio_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 579 of file audio_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 526 of file audio_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 591 of file audio_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 494 of file audio_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 468 of file audio_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 442 of file audio_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5730 ),
HBYTE( 0x5730 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
0x01
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 82 of file audio_desc.c.

◆ audio_desc_handler

usbd_desc_handler audio_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_desc.c:536
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_desc.c:516
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_desc.c:567
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_desc.c:526
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_desc.c:602
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_desc.c:546
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_desc.c:579
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_desc.c:614
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_desc.c:556
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_desc.c:591

device descriptor handler structure

Definition at line 62 of file audio_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
( 0x12 + ((0x08 + ( 1 + 1 ) ) + ( 1 + 1 ) * 0x1E) + + (0x31 + ( ( 1 + 1 ) ) * 3) + (0x31 + ( ( 1 + 1 ) ) * 3) + (9 * 1 ) ) ,
g_usbd_configuration
}

Definition at line 414 of file audio_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 407 of file audio_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 57 of file audio_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 421 of file audio_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 428 of file audio_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 434 of file audio_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_audio_desc_definition

Macros | Variables
USB_audio_desc_definition
AT32F413_middlewares_usbd_class » USB_audio_desc

Macros

#define | AUDIO_BCD_NUM 0x0100
#define | USBD_AUDIO_VENDOR_ID 0x2E3C
#define | USBD_AUDIO_PRODUCT_ID 0x5730
#define | USBD_AUDIO_SIZ_STRING_LANGID 4
#define | USBD_AUDIO_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x09
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUDIO_BINTERVAL_TIME 0x01
#define | USBD_AUDIO_CONFIG_DESC_SIZE
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler audio_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ AT32_AUDIO_FREQ_16K

#define AT32_AUDIO_FREQ_16K 16000

audio support freq

Definition at line 188 of file audio_desc.h.

◆ AT32_AUDIO_FREQ_48K

#define AT32_AUDIO_FREQ_48K 48000

Definition at line 189 of file audio_desc.h.

◆ AUDIO_AC_DESCRIPTOR_UNDEFINED

#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00

audio class-specific ac interface descriptor subtypes

Definition at line 90 of file audio_desc.h.

◆ AUDIO_AC_EXTENSION_UNIT

#define AUDIO_AC_EXTENSION_UNIT 0x08

Definition at line 98 of file audio_desc.h.

◆ AUDIO_AC_FEATURE_UNIT

#define AUDIO_AC_FEATURE_UNIT 0x06

Definition at line 96 of file audio_desc.h.

◆ AUDIO_AC_HEADER

#define AUDIO_AC_HEADER 0x01

Definition at line 91 of file audio_desc.h.

◆ AUDIO_AC_INPUT_TERMINAL

#define AUDIO_AC_INPUT_TERMINAL 0x02

Definition at line 92 of file audio_desc.h.

◆ AUDIO_AC_MIXER_UNIT

#define AUDIO_AC_MIXER_UNIT 0x04

Definition at line 94 of file audio_desc.h.

◆ AUDIO_AC_OUTPUT_TERMINAL

#define AUDIO_AC_OUTPUT_TERMINAL 0x03

Definition at line 93 of file audio_desc.h.

◆ AUDIO_AC_PROCESSING_UNIT

#define AUDIO_AC_PROCESSING_UNIT 0x07

Definition at line 97 of file audio_desc.h.

◆ AUDIO_AC_SELECTOR_UNIT

#define AUDIO_AC_SELECTOR_UNIT 0x05

Definition at line 95 of file audio_desc.h.

◆ AUDIO_AS_DESCRIPTOR_UNDEFINED

#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00

audio class-specific as interface descriptor subtypes

Definition at line 103 of file audio_desc.h.

◆ AUDIO_AS_FORMAT_SPECIFIC

#define AUDIO_AS_FORMAT_SPECIFIC 0x03

Definition at line 106 of file audio_desc.h.

◆ AUDIO_AS_FORMAT_TYPE

#define AUDIO_AS_FORMAT_TYPE 0x02

Definition at line 105 of file audio_desc.h.

◆ AUDIO_AS_GENERAL

#define AUDIO_AS_GENERAL 0x01

Definition at line 104 of file audio_desc.h.

◆ AUDIO_BCD_NUM

#define AUDIO_BCD_NUM 0x0100

Definition at line 51 of file audio_desc.h.

◆ AUDIO_BINTERVAL_TIME

#define AUDIO_BINTERVAL_TIME 0x01

Definition at line 205 of file audio_desc.h.

◆ AUDIO_CS_CONFIGURATION

#define AUDIO_CS_CONFIGURATION 0x22

Definition at line 78 of file audio_desc.h.

◆ AUDIO_CS_DEVICE

#define AUDIO_CS_DEVICE 0x21

Definition at line 79 of file audio_desc.h.

◆ AUDIO_CS_ENDPOINT

#define AUDIO_CS_ENDPOINT 0x25

Definition at line 76 of file audio_desc.h.

◆ AUDIO_CS_INTERFACE

#define AUDIO_CS_INTERFACE 0x24

audio class-specific descriptor types

Definition at line 75 of file audio_desc.h.

◆ AUDIO_CS_STRING

#define AUDIO_CS_STRING 0x23

Definition at line 77 of file audio_desc.h.

◆ AUDIO_CS_UNDEFINED

#define AUDIO_CS_UNDEFINED 0x20

Definition at line 80 of file audio_desc.h.

◆ AUDIO_FEATURE_UNIT_SIZE

#define AUDIO_FEATURE_UNIT_SIZE 0x09

Definition at line 163 of file audio_desc.h.

◆ AUDIO_FORMAT_TYPE_I

#define AUDIO_FORMAT_TYPE_I 0x01

audio format type 1

Definition at line 148 of file audio_desc.h.

◆ AUDIO_FU_BASS_CONTROL

#define AUDIO_FU_BASS_CONTROL 0x03

Definition at line 130 of file audio_desc.h.

◆ AUDIO_FU_CONTROL_UNDEFINED

#define AUDIO_FU_CONTROL_UNDEFINED 0x00

audio feature unit control selectors

Definition at line 127 of file audio_desc.h.

◆ AUDIO_FU_MID_CONTROL

#define AUDIO_FU_MID_CONTROL 0x04

Definition at line 131 of file audio_desc.h.

◆ AUDIO_FU_MUTE_CONTROL

#define AUDIO_FU_MUTE_CONTROL 0x01

Definition at line 128 of file audio_desc.h.

◆ AUDIO_FU_TREBLE_CONTROL

#define AUDIO_FU_TREBLE_CONTROL 0x05

Definition at line 132 of file audio_desc.h.

◆ AUDIO_FU_VOLUME_CONTROL

#define AUDIO_FU_VOLUME_CONTROL 0x02

Definition at line 129 of file audio_desc.h.

◆ AUDIO_INPUT_TERMINAL_MICROPHONE

#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201

Definition at line 141 of file audio_desc.h.

◆ AUDIO_INPUT_TERMINAL_SIZE

#define AUDIO_INPUT_TERMINAL_SIZE 0x0C

audio interface descriptor size define

Definition at line 161 of file audio_desc.h.

◆ AUDIO_INPUT_TERMINAL_UNDEFINED

#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200

Definition at line 140 of file audio_desc.h.

◆ AUDIO_INTERFACE_LEN

#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)

Definition at line 154 of file audio_desc.h.

◆ AUDIO_INTERFACE_NUM

#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)

audio interface config

Definition at line 153 of file audio_desc.h.

◆ AUDIO_MIC_BITW

#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)

Definition at line 196 of file audio_desc.h.

◆ AUDIO_MIC_CHR

#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM

Definition at line 195 of file audio_desc.h.

◆ AUDIO_MIC_FEATURE_UNIT_ID

#define AUDIO_MIC_FEATURE_UNIT_ID 0x02

Definition at line 169 of file audio_desc.h.

◆ AUDIO_MIC_FREQ_SIZE

#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio microphone freq and channel config

Definition at line 194 of file audio_desc.h.

◆ AUDIO_MIC_INPUT_TERMINAL_ID

#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01

audio terminal id define

Definition at line 168 of file audio_desc.h.

◆ AUDIO_MIC_INTERFACE

#define AUDIO_MIC_INTERFACE 0x01

Definition at line 155 of file audio_desc.h.

◆ AUDIO_MIC_INTERFACE_NUMBER

#define AUDIO_MIC_INTERFACE_NUMBER 0x01

audio interface number

Definition at line 178 of file audio_desc.h.

◆ AUDIO_MIC_OUTPUT_TERMINAL_ID

#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03

Definition at line 170 of file audio_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SIZE

#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09

Definition at line 162 of file audio_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SPEAKER

#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301

Definition at line 143 of file audio_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_UNDEFINED

#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300

Definition at line 142 of file audio_desc.h.

◆ AUDIO_PROTOCOL_UNDEFINED

#define AUDIO_PROTOCOL_UNDEFINED 0x00

audio interface protocol codes

Definition at line 85 of file audio_desc.h.

◆ AUDIO_REQ_GET_CUR

#define AUDIO_REQ_GET_CUR 0x81

Definition at line 113 of file audio_desc.h.

◆ AUDIO_REQ_GET_MAX

#define AUDIO_REQ_GET_MAX 0x83

Definition at line 117 of file audio_desc.h.

◆ AUDIO_REQ_GET_MEM

#define AUDIO_REQ_GET_MEM 0x85

Definition at line 121 of file audio_desc.h.

◆ AUDIO_REQ_GET_MIN

#define AUDIO_REQ_GET_MIN 0x82

Definition at line 115 of file audio_desc.h.

◆ AUDIO_REQ_GET_RES

#define AUDIO_REQ_GET_RES 0x84

Definition at line 119 of file audio_desc.h.

◆ AUDIO_REQ_GET_STAT

#define AUDIO_REQ_GET_STAT 0xFF

Definition at line 122 of file audio_desc.h.

◆ AUDIO_REQ_SET_CUR

#define AUDIO_REQ_SET_CUR 0x01

Definition at line 112 of file audio_desc.h.

◆ AUDIO_REQ_SET_MAX

#define AUDIO_REQ_SET_MAX 0x03

Definition at line 116 of file audio_desc.h.

◆ AUDIO_REQ_SET_MEM

#define AUDIO_REQ_SET_MEM 0x05

Definition at line 120 of file audio_desc.h.

◆ AUDIO_REQ_SET_MIN

#define AUDIO_REQ_SET_MIN 0x02

Definition at line 114 of file audio_desc.h.

◆ AUDIO_REQ_SET_RES

#define AUDIO_REQ_SET_RES 0x04

Definition at line 118 of file audio_desc.h.

◆ AUDIO_REQUEST_CODE_UNDEFINED

#define AUDIO_REQUEST_CODE_UNDEFINED 0x00

audio class-specific request codes

Definition at line 111 of file audio_desc.h.

◆ AUDIO_SPK_BITW

#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)

Definition at line 203 of file audio_desc.h.

◆ AUDIO_SPK_CHR

#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM

Definition at line 202 of file audio_desc.h.

◆ AUDIO_SPK_FEATURE_UNIT_ID

#define AUDIO_SPK_FEATURE_UNIT_ID 0x05

Definition at line 172 of file audio_desc.h.

◆ AUDIO_SPK_FREQ_SIZE

#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio speaker freq and channel config

Definition at line 201 of file audio_desc.h.

◆ AUDIO_SPK_INPUT_TERMINAL_ID

#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04

Definition at line 171 of file audio_desc.h.

◆ AUDIO_SPK_INTERFACE

#define AUDIO_SPK_INTERFACE 0x02

Definition at line 156 of file audio_desc.h.

◆ AUDIO_SPK_INTERFACE_NUMBER

#define AUDIO_SPK_INTERFACE_NUMBER 0x02

Definition at line 180 of file audio_desc.h.

◆ AUDIO_SPK_OUTPUT_TERMINAL_ID

#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06

Definition at line 173 of file audio_desc.h.

◆ AUDIO_SUBCLASS_AUDIOCONTROL

#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01

Definition at line 68 of file audio_desc.h.

◆ AUDIO_SUBCLASS_AUDIOSTREAMING

#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02

Definition at line 69 of file audio_desc.h.

◆ AUDIO_SUBCLASS_MIDISTREMING

#define AUDIO_SUBCLASS_MIDISTREMING 0x03

Definition at line 70 of file audio_desc.h.

◆ AUDIO_SUBCLASS_UNDEFINED

#define AUDIO_SUBCLASS_UNDEFINED 0x00

audio interface subclass codes

Definition at line 67 of file audio_desc.h.

◆ AUDIO_TERMINAL_TYPE_STREAMING

#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101

Definition at line 138 of file audio_desc.h.

◆ AUDIO_TERMINAL_TYPE_UNDEFINED

#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100

audio terminal type

Definition at line 137 of file audio_desc.h.

◆ AUDIO_TERMINAL_TYPE_VENDOR

#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF

Definition at line 139 of file audio_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 215 of file audio_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 216 of file audio_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 217 of file audio_desc.h.

◆ SAMPLE_FREQ

#define SAMPLE_FREQ ( frq ) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))

Definition at line 213 of file audio_desc.h.

◆ USBD_AUDIO_CONFIG_DESC_SIZE

#define USBD_AUDIO_CONFIG_DESC_SIZE
Value:
( 0x12 + AUDIO_INTERFACE_LEN + \
+ (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
+ (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
+ (9 * AUDIO_SUPPORT_FEEDBACK) \
)
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_desc.h:194
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_desc.h:201
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_desc.h:154
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49

Definition at line 208 of file audio_desc.h.

◆ USBD_AUDIO_DESC_CONFIGURATION_STRING

#define USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"

Definition at line 61 of file audio_desc.h.

◆ USBD_AUDIO_DESC_INTERFACE_STRING

#define USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"

Definition at line 62 of file audio_desc.h.

◆ USBD_AUDIO_DESC_MANUFACTURER_STRING

#define USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"

Definition at line 59 of file audio_desc.h.

◆ USBD_AUDIO_DESC_PRODUCT_STRING

#define USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"

Definition at line 60 of file audio_desc.h.

◆ USBD_AUDIO_PRODUCT_ID

#define USBD_AUDIO_PRODUCT_ID 0x5730

Definition at line 54 of file audio_desc.h.

◆ USBD_AUDIO_SIZ_STRING_LANGID

#define USBD_AUDIO_SIZ_STRING_LANGID 4

Definition at line 56 of file audio_desc.h.

◆ USBD_AUDIO_SIZ_STRING_SERIAL

#define USBD_AUDIO_SIZ_STRING_SERIAL 0x1A

Definition at line 57 of file audio_desc.h.

◆ USBD_AUDIO_VENDOR_ID

#define USBD_AUDIO_VENDOR_ID 0x2E3C

Definition at line 53 of file audio_desc.h.

Variable Documentation

◆ audio_desc_handler

usbd_desc_handler audio_desc_handler
extern

device descriptor handler structure

Definition at line 62 of file audio_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_audio_hid_class

Modules
USB_audio_hid_class
AT32F413_middlewares_usbd_class

usb device class audio hid demo More...

Modules

USB_device_audio_hid_config_definition
USB_audio_hid_class_private_functions
USB_audio_hid_class_definition

Detailed Description

usb device class audio hid demo


AT32F413 Firmwary Library: USB_device_audio_hid_config_definition

Macros
USB_device_audio_hid_config_definition
AT32F413_middlewares_usbd_class » USB_audio_hid_class

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 0
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

Macro Definition Documentation

◆ AUDIO_BITW_16

#define AUDIO_BITW_16 16

Definition at line 61 of file audio_hid/audio_conf.h.

◆ AUDIO_DEFAULT_BITW

#define AUDIO_DEFAULT_BITW AUDIO_BITW_16

Definition at line 72 of file audio_hid/audio_conf.h.

◆ AUDIO_DEFAULT_FREQ

#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K

Definition at line 71 of file audio_hid/audio_conf.h.

◆ AUDIO_FREQ_16K

#define AUDIO_FREQ_16K 16000

Definition at line 59 of file audio_hid/audio_conf.h.

◆ AUDIO_FREQ_48K

#define AUDIO_FREQ_48K 48000

Definition at line 60 of file audio_hid/audio_conf.h.

◆ AUDIO_MIC_CHANEL_NUM

#define AUDIO_MIC_CHANEL_NUM 2

Definition at line 63 of file audio_hid/audio_conf.h.

◆ AUDIO_MIC_DEFAULT_BITW

#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16

Definition at line 64 of file audio_hid/audio_conf.h.

◆ AUDIO_SPK_CHANEL_NUM

#define AUDIO_SPK_CHANEL_NUM 2

Definition at line 66 of file audio_hid/audio_conf.h.

◆ AUDIO_SPK_DEFAULT_BITW

#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16

Definition at line 67 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FEEDBACK

#define AUDIO_SUPPORT_FEEDBACK 1

Definition at line 49 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ

#define AUDIO_SUPPORT_FREQ
Value:
(AUDIO_SUPPORT_FREQ_16K + \
AUDIO_SUPPORT_FREQ_48K \
)
AUDIO_SUPPORT_FREQ_16K
#define AUDIO_SUPPORT_FREQ_16K
Definition: audio_hid/audio_conf.h:51

Definition at line 55 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_16K

#define AUDIO_SUPPORT_FREQ_16K 0

Definition at line 51 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_FREQ_48K

#define AUDIO_SUPPORT_FREQ_48K 1

Definition at line 52 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_MAX_FREQ

#define AUDIO_SUPPORT_MAX_FREQ 48

Definition at line 70 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_MIC

#define AUDIO_SUPPORT_MIC 1

Definition at line 48 of file audio_hid/audio_conf.h.

◆ AUDIO_SUPPORT_SPK

#define AUDIO_SUPPORT_SPK 1

Definition at line 47 of file audio_hid/audio_conf.h.


AT32F413 Firmwary Library: USB_audio_hid_class_private_functions

Functions | Variables
USB_audio_hid_class_private_functions
AT32F413_middlewares_usbd_class » USB_audio_hid_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device report function More...
usb_sts_type | class_audio_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | class_hid_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler audio_hid_class_handler

Detailed Description

Function Documentation

◆ audio_get_interface()

static void audio_get_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio get interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 748 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_hid_class_send_report()

usb_sts_type audio_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 770 of file audio_hid_class.c.

Referenced by main().

◆ audio_req_get_cur()

static void audio_req_get_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 566 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_get_max()

static void audio_req_get_max | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get max

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 667 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_get_min()

static void audio_req_get_min | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get min

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 645 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_get_res()

static void audio_req_get_res | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request get res

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 689 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_req_set_cur()

static void audio_req_set_cur | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio request set cur

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 605 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ audio_set_interface()

static void audio_set_interface | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb audio set interface

Parameters
udev | usb device core handler type
setup | setup class
Return values
none

Definition at line 711 of file audio_hid_class.c.

Referenced by class_audio_setup_handler().

◆ class_audio_setup_handler()

usb_sts_type class_audio_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 159 of file audio_hid_class.c.

Referenced by class_setup_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 128 of file audio_hid_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 359 of file audio_hid_class.c.

◆ class_ept0_tx_handler()

usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 345 of file audio_hid_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | usb device core handler type
event | usb device event
Return values
status of usb_sts_type

Definition at line 530 of file audio_hid_class.c.

◆ class_hid_setup_handler()

usb_sts_type class_hid_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 240 of file audio_hid_class.c.

Referenced by class_setup_handler().

◆ class_in_handler()

usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 445 of file audio_hid_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 83 of file audio_hid_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | usb device core handler type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 481 of file audio_hid_class.c.

◆ class_setup_handler()

usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | usb device core handler type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 314 of file audio_hid_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 515 of file audio_hid_class.c.

◆ usb_hid_buf_process()

static void usb_hid_buf_process | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |
static

usb device report function

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
none

Definition at line 789 of file audio_hid_class.c.

Referenced by class_ept0_rx_handler(), and class_out_handler().

Variable Documentation

◆ audio_hid_class_handler

usbd_class_handler audio_hid_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&audio_hid_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_hid_class.c:515
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_hid_class.c:128
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_hid_class.c:359
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_hid_class.c:530
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:314
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_hid_class.c:83
audio_hid_struct
usb_audio_hid_type audio_hid_struct
Definition: audio_hid_class.c:62
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_hid_class.c:345
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_hid_class.c:481
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_hid_class.c:445

Definition at line 64 of file audio_hid_class.c.

Referenced by main().

◆ audio_hid_struct

usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}

Definition at line 62 of file audio_hid_class.c.


AT32F413 Firmwary Library: USB_audio_hid_class_definition

Data Structures | Macros | Functions | Variables
USB_audio_hid_class_definition
AT32F413_middlewares_usbd_class » USB_audio_hid_class

Data Structures

struct usb_audio_hid_type
usb audio control struct More...

Macros

#define | USBD_AUHID_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83
#define | USBD_AUHID_HID_IN_EPT 0x84
usb custom hid use endpoint define More...
#define | USBD_AUHID_HID_OUT_EPT 0x05
#define | USBD_AUHID_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_AUHID_OUT_MAXPACKET_SIZE 0x40
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Functions

usb_sts_type audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler audio_hid_class_handler

Detailed Description

Macro Definition Documentation

◆ AUDIO_DESCRIPTOR_SIZE

#define AUDIO_DESCRIPTOR_SIZE 0x09

Definition at line 107 of file audio_hid_class.h.

◆ AUDIO_DESCRIPTOR_TYPE

#define AUDIO_DESCRIPTOR_TYPE 0x21

audio descriptor type

Definition at line 106 of file audio_hid_class.h.

◆ AUDIO_FEEDBACK_MAXPACKET_SIZE

#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3

Definition at line 76 of file audio_hid_class.h.

◆ AUDIO_FREQ_SET_CONTROL [1/2]

#define AUDIO_FREQ_SET_CONTROL 0x03

Definition at line 101 of file audio_hid_class.h.

◆ AUDIO_FREQ_SET_CONTROL [2/2]

#define AUDIO_FREQ_SET_CONTROL 0x03

Definition at line 101 of file audio_hid_class.h.

◆ AUDIO_MIC_IN_MAXPACKET_SIZE

#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 74 of file audio_hid_class.h.

◆ AUDIO_MUTE_CONTROL [1/2]

#define AUDIO_MUTE_CONTROL 0x01

audio set cur type define

audio descriptor type

audio set cur type define

Definition at line 99 of file audio_hid_class.h.

◆ AUDIO_MUTE_CONTROL [2/2]

#define AUDIO_MUTE_CONTROL 0x01

audio set cur type define

audio descriptor type

audio set cur type define

Definition at line 99 of file audio_hid_class.h.

◆ AUDIO_REMAIN_SIZE

#define AUDIO_REMAIN_SIZE 40

endpoint support max size

Definition at line 73 of file audio_hid_class.h.

◆ AUDIO_REQ_CONTROL_ENDPOINT

#define AUDIO_REQ_CONTROL_ENDPOINT 0x02

Definition at line 82 of file audio_hid_class.h.

◆ AUDIO_REQ_CONTROL_INTERFACE

#define AUDIO_REQ_CONTROL_INTERFACE 0x01

request type define

Definition at line 81 of file audio_hid_class.h.

◆ AUDIO_REQ_CONTROL_MASK

#define AUDIO_REQ_CONTROL_MASK 0x03

Definition at line 83 of file audio_hid_class.h.

◆ AUDIO_SPK_OUT_MAXPACKET_SIZE

#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)

Definition at line 75 of file audio_hid_class.h.

◆ AUDIO_VOLUME_CONTROL [1/2]

#define AUDIO_VOLUME_CONTROL 0x02

Definition at line 100 of file audio_hid_class.h.

◆ AUDIO_VOLUME_CONTROL [2/2]

#define AUDIO_VOLUME_CONTROL 0x02

Definition at line 100 of file audio_hid_class.h.

◆ FEEDBACK_REFRESH_TIME

#define FEEDBACK_REFRESH_TIME 0x8

Definition at line 77 of file audio_hid_class.h.

◆ USBD_AUHID_AUDIO_FEEDBACK_EPT

#define USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83

Definition at line 56 of file audio_hid_class.h.

◆ USBD_AUHID_AUDIO_MIC_IN_EPT

#define USBD_AUHID_AUDIO_MIC_IN_EPT 0x81

endpoint define

Definition at line 54 of file audio_hid_class.h.

◆ USBD_AUHID_AUDIO_SPK_OUT_EPT

#define USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02

Definition at line 55 of file audio_hid_class.h.

◆ USBD_AUHID_HID_IN_EPT

#define USBD_AUHID_HID_IN_EPT 0x84

usb custom hid use endpoint define

Definition at line 61 of file audio_hid_class.h.

◆ USBD_AUHID_HID_OUT_EPT

#define USBD_AUHID_HID_OUT_EPT 0x05

Definition at line 62 of file audio_hid_class.h.

◆ USBD_AUHID_IN_MAXPACKET_SIZE

#define USBD_AUHID_IN_MAXPACKET_SIZE 0x40

usb custom hid in and out max packet size define

Definition at line 67 of file audio_hid_class.h.

◆ USBD_AUHID_OUT_MAXPACKET_SIZE

#define USBD_AUHID_OUT_MAXPACKET_SIZE 0x40

Definition at line 68 of file audio_hid_class.h.

Function Documentation

◆ audio_hid_class_send_report()

usb_sts_type audio_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 770 of file audio_hid_class.c.

Referenced by main().

Variable Documentation

◆ audio_hid_class_handler

usbd_class_handler audio_hid_class_handler
extern

Definition at line 64 of file audio_hid_class.c.

Referenced by main().


AT32F413 Firmwary Library: usb_audio_hid_type Struct Reference

Data Fields
usb_audio_hid_type Struct Reference
AT32F413_middlewares_usbd_class » USB_audio_hid_class » USB_audio_hid_class_definition

usb audio control struct More...

#include <audio_hid_class.h>

Data Fields

uint8_t | enpd
uint8_t | interface
uint8_t | request_no
uint8_t | spk_mute
uint8_t | mic_mute
uint16_t | spk_volume
uint16_t | mic_volume
uint32_t | spk_freq
uint32_t | mic_freq
uint16_t | spk_volume_limits [3]
uint16_t | mic_volume_limits [3]
uint8_t | audio_cmd
uint32_t | audio_cmd_len
uint32_t | spk_alt_setting
uint32_t | mic_alt_setting
uint8_t | g_audio_cur [64]
uint8_t | audio_spk_data [(48 *2 *(16/8)+40)]
uint8_t | audio_mic_data [(48 *2 *(16/8)+40)]
uint8_t | audio_feed_back [0x3+1]
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_state
uint8_t | hid_set_report [64]
uint8_t | g_rxhid_buff [0x40]
uint8_t | g_txhid_buff [0x40]

Detailed Description

usb audio control struct

Definition at line 112 of file audio_hid_class.h.

Field Documentation

◆ alt_setting

uint32_t usb_audio_hid_type::alt_setting

Definition at line 139 of file audio_hid_class.h.

Referenced by class_hid_setup_handler().

◆ audio_cmd

uint8_t usb_audio_hid_type::audio_cmd

Definition at line 126 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ audio_cmd_len

uint32_t usb_audio_hid_type::audio_cmd_len

Definition at line 127 of file audio_hid_class.h.

Referenced by audio_req_set_cur().

◆ audio_feed_back

uint8_t usb_audio_hid_type::audio_feed_back[0x3+1]

Definition at line 133 of file audio_hid_class.h.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_mic_data

uint8_t usb_audio_hid_type::audio_mic_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 132 of file audio_hid_class.h.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_spk_data

uint8_t usb_audio_hid_type::audio_spk_data[(48 * 2 *( 16/8)+ 40)]

Definition at line 131 of file audio_hid_class.h.

Referenced by audio_set_interface(), class_init_handler(), and class_out_handler().

◆ enpd

uint8_t usb_audio_hid_type::enpd

Definition at line 114 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ g_audio_cur

uint8_t usb_audio_hid_type::g_audio_cur[64]

Definition at line 130 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), and class_ept0_rx_handler().

◆ g_rxhid_buff

uint8_t usb_audio_hid_type::g_rxhid_buff[0x40]

Definition at line 142 of file audio_hid_class.h.

Referenced by class_init_handler(), class_out_handler(), and usb_hid_buf_process().

◆ g_txhid_buff

uint8_t usb_audio_hid_type::g_txhid_buff[0x40]

Definition at line 143 of file audio_hid_class.h.

Referenced by usb_hid_buf_process().

◆ hid_protocol

uint32_t usb_audio_hid_type::hid_protocol

Definition at line 137 of file audio_hid_class.h.

Referenced by class_hid_setup_handler().

◆ hid_set_idle

uint32_t usb_audio_hid_type::hid_set_idle

Definition at line 138 of file audio_hid_class.h.

Referenced by class_hid_setup_handler().

◆ hid_set_report

uint8_t usb_audio_hid_type::hid_set_report[64]

Definition at line 141 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_hid_setup_handler().

◆ hid_state

uint8_t usb_audio_hid_type::hid_state

Definition at line 140 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_hid_setup_handler().

◆ interface

uint8_t usb_audio_hid_type::interface

Definition at line 115 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ mic_alt_setting

uint32_t usb_audio_hid_type::mic_alt_setting

Definition at line 129 of file audio_hid_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ mic_freq

uint32_t usb_audio_hid_type::mic_freq

Definition at line 122 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler().

◆ mic_mute

uint8_t usb_audio_hid_type::mic_mute

Definition at line 118 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume

uint16_t usb_audio_hid_type::mic_volume

Definition at line 120 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ mic_volume_limits

uint16_t usb_audio_hid_type::mic_volume_limits[3]

Definition at line 124 of file audio_hid_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

◆ request_no

uint8_t usb_audio_hid_type::request_no

Definition at line 116 of file audio_hid_class.h.

Referenced by audio_req_set_cur(), and class_ept0_rx_handler().

◆ spk_alt_setting

uint32_t usb_audio_hid_type::spk_alt_setting

Definition at line 128 of file audio_hid_class.h.

Referenced by audio_get_interface(), audio_set_interface(), and class_event_handler().

◆ spk_freq

uint32_t usb_audio_hid_type::spk_freq

Definition at line 121 of file audio_hid_class.h.

Referenced by class_ept0_rx_handler().

◆ spk_mute

uint8_t usb_audio_hid_type::spk_mute

Definition at line 117 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume

uint16_t usb_audio_hid_type::spk_volume

Definition at line 119 of file audio_hid_class.h.

Referenced by audio_req_get_cur(), and class_ept0_rx_handler().

◆ spk_volume_limits

uint16_t usb_audio_hid_type::spk_volume_limits[3]

Definition at line 123 of file audio_hid_class.h.

Referenced by audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), and class_ept0_rx_handler().

The documentation for this struct was generated from the following file:
  • audio_hid_class.h


AT32F413 Firmwary Library: USB_audio_hid_desc

Modules
USB_audio_hid_desc
AT32F413_middlewares_usbd_class

usb device audio hid descriptor More...

Modules

USB_audio_hid_desc_private_functions
USB_audio_hid_desc_definition

Detailed Description

usb device audio hid descriptor


AT32F413 Firmwary Library: USB_audio_hid_desc_private_functions

Functions | Variables
USB_audio_hid_desc_private_functions
AT32F413_middlewares_usbd_class » USB_audio_hid_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 769 of file audio_hid_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 691 of file audio_hid_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 671 of file audio_hid_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 757 of file audio_hid_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 711 of file audio_hid_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 722 of file audio_hid_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 701 of file audio_hid_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 734 of file audio_hid_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 681 of file audio_hid_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 746 of file audio_hid_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 649 of file audio_hid_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 623 of file audio_hid_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 597 of file audio_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5555 ),
HBYTE( 0x5555 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
0x01
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb hid report descriptor

usb configuration standard descriptor

Definition at line 84 of file audio_hid_desc.c.

◆ audio_hid_desc_handler

usbd_desc_handler audio_hid_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_hid_desc.c:691
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_hid_desc.c:671
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_hid_desc.c:722
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_hid_desc.c:681
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_hid_desc.c:757
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_hid_desc.c:701
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_hid_desc.c:734
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_hid_desc.c:769
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_hid_desc.c:711
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_hid_desc.c:746

device descriptor handler structure

Definition at line 64 of file audio_hid_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
( 0x12 + ((0x08 + ( 1 + 1 ) ) + ( 1 + 1 ) * 0x1E) + + (0x31 + ( ( 0 + 1 ) ) * 3) + (0x31 + ( ( 0 + 1 ) ) * 3) + (9 * 1 ) + 32 ) ,
g_usbd_configuration
}

Definition at line 569 of file audio_hid_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 562 of file audio_hid_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 59 of file audio_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 576 of file audio_hid_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 583 of file audio_hid_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 589 of file audio_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_audio_hid_desc_definition

Macros | Variables
USB_audio_hid_desc_definition
AT32F413_middlewares_usbd_class » USB_audio_hid_desc

Macros

#define | AUHID_BCD_NUM 0x0100
#define | USBD_AUHID_VENDOR_ID 0x2E3C
#define | USBD_AUHID_PRODUCT_ID 0x5555
#define | USBD_AUHID_SIZ_STRING_LANGID 4
#define | USBD_AUHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x09
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | HID_INTERFACE_NUMBER 0x03
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUHID_HID_BINTERVAL_TIME 0x01
#define | AUHID_HID_BCD_NUM 0x0110
usb bcd number define More...
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | USBD_AUHID_HID_SIZ_REPORT_DESC 126
#define | USBD_AUHID_HID_DESC_SIZE 32
#define | USBD_AUHID_CONFIG_DESC_SIZE

Variables

uint8_t | g_usbd_audio_hid_report [126]
usb hid report descriptor More...
uint8_t | g_audio_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ AT32_AUDIO_FREQ_16K

#define AT32_AUDIO_FREQ_16K 16000

audio support freq

Definition at line 188 of file audio_hid_desc.h.

◆ AT32_AUDIO_FREQ_48K

#define AT32_AUDIO_FREQ_48K 48000

Definition at line 189 of file audio_hid_desc.h.

◆ AUDIO_AC_DESCRIPTOR_UNDEFINED

#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00

audio class-specific ac interface descriptor subtypes

Definition at line 89 of file audio_hid_desc.h.

◆ AUDIO_AC_EXTENSION_UNIT

#define AUDIO_AC_EXTENSION_UNIT 0x08

Definition at line 97 of file audio_hid_desc.h.

◆ AUDIO_AC_FEATURE_UNIT

#define AUDIO_AC_FEATURE_UNIT 0x06

Definition at line 95 of file audio_hid_desc.h.

◆ AUDIO_AC_HEADER

#define AUDIO_AC_HEADER 0x01

Definition at line 90 of file audio_hid_desc.h.

◆ AUDIO_AC_INPUT_TERMINAL

#define AUDIO_AC_INPUT_TERMINAL 0x02

Definition at line 91 of file audio_hid_desc.h.

◆ AUDIO_AC_MIXER_UNIT

#define AUDIO_AC_MIXER_UNIT 0x04

Definition at line 93 of file audio_hid_desc.h.

◆ AUDIO_AC_OUTPUT_TERMINAL

#define AUDIO_AC_OUTPUT_TERMINAL 0x03

Definition at line 92 of file audio_hid_desc.h.

◆ AUDIO_AC_PROCESSING_UNIT

#define AUDIO_AC_PROCESSING_UNIT 0x07

Definition at line 96 of file audio_hid_desc.h.

◆ AUDIO_AC_SELECTOR_UNIT

#define AUDIO_AC_SELECTOR_UNIT 0x05

Definition at line 94 of file audio_hid_desc.h.

◆ AUDIO_AS_DESCRIPTOR_UNDEFINED

#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00

audio class-specific as interface descriptor subtypes

Definition at line 102 of file audio_hid_desc.h.

◆ AUDIO_AS_FORMAT_SPECIFIC

#define AUDIO_AS_FORMAT_SPECIFIC 0x03

Definition at line 105 of file audio_hid_desc.h.

◆ AUDIO_AS_FORMAT_TYPE

#define AUDIO_AS_FORMAT_TYPE 0x02

Definition at line 104 of file audio_hid_desc.h.

◆ AUDIO_AS_GENERAL

#define AUDIO_AS_GENERAL 0x01

Definition at line 103 of file audio_hid_desc.h.

◆ AUDIO_CS_CONFIGURATION

#define AUDIO_CS_CONFIGURATION 0x22

Definition at line 77 of file audio_hid_desc.h.

◆ AUDIO_CS_DEVICE

#define AUDIO_CS_DEVICE 0x21

Definition at line 78 of file audio_hid_desc.h.

◆ AUDIO_CS_ENDPOINT

#define AUDIO_CS_ENDPOINT 0x25

Definition at line 75 of file audio_hid_desc.h.

◆ AUDIO_CS_INTERFACE

#define AUDIO_CS_INTERFACE 0x24

audio class-specific descriptor types

Definition at line 74 of file audio_hid_desc.h.

◆ AUDIO_CS_STRING

#define AUDIO_CS_STRING 0x23

Definition at line 76 of file audio_hid_desc.h.

◆ AUDIO_CS_UNDEFINED

#define AUDIO_CS_UNDEFINED 0x20

Definition at line 79 of file audio_hid_desc.h.

◆ AUDIO_FEATURE_UNIT_SIZE

#define AUDIO_FEATURE_UNIT_SIZE 0x09

Definition at line 162 of file audio_hid_desc.h.

◆ AUDIO_FORMAT_TYPE_I

#define AUDIO_FORMAT_TYPE_I 0x01

audio format type 1

Definition at line 147 of file audio_hid_desc.h.

◆ AUDIO_FU_BASS_CONTROL

#define AUDIO_FU_BASS_CONTROL 0x03

Definition at line 129 of file audio_hid_desc.h.

◆ AUDIO_FU_CONTROL_UNDEFINED

#define AUDIO_FU_CONTROL_UNDEFINED 0x00

audio feature unit control selectors

Definition at line 126 of file audio_hid_desc.h.

◆ AUDIO_FU_MID_CONTROL

#define AUDIO_FU_MID_CONTROL 0x04

Definition at line 130 of file audio_hid_desc.h.

◆ AUDIO_FU_MUTE_CONTROL

#define AUDIO_FU_MUTE_CONTROL 0x01

Definition at line 127 of file audio_hid_desc.h.

◆ AUDIO_FU_TREBLE_CONTROL

#define AUDIO_FU_TREBLE_CONTROL 0x05

Definition at line 131 of file audio_hid_desc.h.

◆ AUDIO_FU_VOLUME_CONTROL

#define AUDIO_FU_VOLUME_CONTROL 0x02

Definition at line 128 of file audio_hid_desc.h.

◆ AUDIO_INPUT_TERMINAL_MICROPHONE

#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201

Definition at line 140 of file audio_hid_desc.h.

◆ AUDIO_INPUT_TERMINAL_SIZE

#define AUDIO_INPUT_TERMINAL_SIZE 0x0C

audio interface descriptor size define

Definition at line 160 of file audio_hid_desc.h.

◆ AUDIO_INPUT_TERMINAL_UNDEFINED

#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200

Definition at line 139 of file audio_hid_desc.h.

◆ AUDIO_INTERFACE_LEN

#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)

Definition at line 153 of file audio_hid_desc.h.

◆ AUDIO_INTERFACE_NUM

#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)

audio interface config

Definition at line 152 of file audio_hid_desc.h.

◆ AUDIO_MIC_BITW

#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)

Definition at line 196 of file audio_hid_desc.h.

◆ AUDIO_MIC_CHR

#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM

Definition at line 195 of file audio_hid_desc.h.

◆ AUDIO_MIC_FEATURE_UNIT_ID

#define AUDIO_MIC_FEATURE_UNIT_ID 0x02

Definition at line 168 of file audio_hid_desc.h.

◆ AUDIO_MIC_FREQ_SIZE

#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio microphone freq and channel config

Definition at line 194 of file audio_hid_desc.h.

◆ AUDIO_MIC_INPUT_TERMINAL_ID

#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01

audio terminal id define

Definition at line 167 of file audio_hid_desc.h.

◆ AUDIO_MIC_INTERFACE

#define AUDIO_MIC_INTERFACE 0x01

Definition at line 154 of file audio_hid_desc.h.

◆ AUDIO_MIC_INTERFACE_NUMBER

#define AUDIO_MIC_INTERFACE_NUMBER 0x01

audio interface number

Definition at line 177 of file audio_hid_desc.h.

◆ AUDIO_MIC_OUTPUT_TERMINAL_ID

#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03

Definition at line 169 of file audio_hid_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SIZE

#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09

Definition at line 161 of file audio_hid_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_SPEAKER

#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301

Definition at line 142 of file audio_hid_desc.h.

◆ AUDIO_OUTPUT_TERMINAL_UNDEFINED

#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300

Definition at line 141 of file audio_hid_desc.h.

◆ AUDIO_PROTOCOL_UNDEFINED

#define AUDIO_PROTOCOL_UNDEFINED 0x00

audio interface protocol codes

Definition at line 84 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_CUR

#define AUDIO_REQ_GET_CUR 0x81

Definition at line 112 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_MAX

#define AUDIO_REQ_GET_MAX 0x83

Definition at line 116 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_MEM

#define AUDIO_REQ_GET_MEM 0x85

Definition at line 120 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_MIN

#define AUDIO_REQ_GET_MIN 0x82

Definition at line 114 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_RES

#define AUDIO_REQ_GET_RES 0x84

Definition at line 118 of file audio_hid_desc.h.

◆ AUDIO_REQ_GET_STAT

#define AUDIO_REQ_GET_STAT 0xFF

Definition at line 121 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_CUR

#define AUDIO_REQ_SET_CUR 0x01

Definition at line 111 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_MAX

#define AUDIO_REQ_SET_MAX 0x03

Definition at line 115 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_MEM

#define AUDIO_REQ_SET_MEM 0x05

Definition at line 119 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_MIN

#define AUDIO_REQ_SET_MIN 0x02

Definition at line 113 of file audio_hid_desc.h.

◆ AUDIO_REQ_SET_RES

#define AUDIO_REQ_SET_RES 0x04

Definition at line 117 of file audio_hid_desc.h.

◆ AUDIO_REQUEST_CODE_UNDEFINED

#define AUDIO_REQUEST_CODE_UNDEFINED 0x00

audio class-specific request codes

Definition at line 110 of file audio_hid_desc.h.

◆ AUDIO_SPK_BITW

#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)

Definition at line 203 of file audio_hid_desc.h.

◆ AUDIO_SPK_CHR

#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM

Definition at line 202 of file audio_hid_desc.h.

◆ AUDIO_SPK_FEATURE_UNIT_ID

#define AUDIO_SPK_FEATURE_UNIT_ID 0x05

Definition at line 171 of file audio_hid_desc.h.

◆ AUDIO_SPK_FREQ_SIZE

#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)

audio speaker freq and channel config

Definition at line 201 of file audio_hid_desc.h.

◆ AUDIO_SPK_INPUT_TERMINAL_ID

#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04

Definition at line 170 of file audio_hid_desc.h.

◆ AUDIO_SPK_INTERFACE

#define AUDIO_SPK_INTERFACE 0x02

Definition at line 155 of file audio_hid_desc.h.

◆ AUDIO_SPK_INTERFACE_NUMBER

#define AUDIO_SPK_INTERFACE_NUMBER 0x02

Definition at line 179 of file audio_hid_desc.h.

◆ AUDIO_SPK_OUTPUT_TERMINAL_ID

#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06

Definition at line 172 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_AUDIOCONTROL

#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01

Definition at line 67 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_AUDIOSTREAMING

#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02

Definition at line 68 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_MIDISTREMING

#define AUDIO_SUBCLASS_MIDISTREMING 0x03

Definition at line 69 of file audio_hid_desc.h.

◆ AUDIO_SUBCLASS_UNDEFINED

#define AUDIO_SUBCLASS_UNDEFINED 0x00

audio interface subclass codes

Definition at line 66 of file audio_hid_desc.h.

◆ AUDIO_TERMINAL_TYPE_STREAMING

#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101

Definition at line 137 of file audio_hid_desc.h.

◆ AUDIO_TERMINAL_TYPE_UNDEFINED

#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100

audio terminal type

Definition at line 136 of file audio_hid_desc.h.

◆ AUDIO_TERMINAL_TYPE_VENDOR

#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF

Definition at line 138 of file audio_hid_desc.h.

◆ AUHID_BCD_NUM

#define AUHID_BCD_NUM 0x0100

Definition at line 51 of file audio_hid_desc.h.

◆ AUHID_HID_BCD_NUM

#define AUHID_HID_BCD_NUM 0x0110

usb bcd number define

Definition at line 210 of file audio_hid_desc.h.

◆ AUHID_HID_BINTERVAL_TIME

#define AUHID_HID_BINTERVAL_TIME 0x01

Definition at line 205 of file audio_hid_desc.h.

◆ HID_CLASS_DESC_HID

#define HID_CLASS_DESC_HID 0x21

usb hid class descriptor define

Definition at line 215 of file audio_hid_desc.h.

◆ HID_CLASS_DESC_PHYSICAL

#define HID_CLASS_DESC_PHYSICAL 0x23

Definition at line 217 of file audio_hid_desc.h.

◆ HID_CLASS_DESC_REPORT

#define HID_CLASS_DESC_REPORT 0x22

Definition at line 216 of file audio_hid_desc.h.

◆ HID_INTERFACE_NUMBER

#define HID_INTERFACE_NUMBER 0x03

Definition at line 183 of file audio_hid_desc.h.

◆ HID_REPORT_ID_1

#define HID_REPORT_ID_1 0x01

usb hid report id define

Definition at line 222 of file audio_hid_desc.h.

◆ HID_REPORT_ID_2

#define HID_REPORT_ID_2 0x02

Definition at line 223 of file audio_hid_desc.h.

◆ HID_REPORT_ID_3

#define HID_REPORT_ID_3 0x03

Definition at line 224 of file audio_hid_desc.h.

◆ HID_REPORT_ID_4

#define HID_REPORT_ID_4 0x04

Definition at line 225 of file audio_hid_desc.h.

◆ HID_REPORT_ID_5

#define HID_REPORT_ID_5 0x05

Definition at line 226 of file audio_hid_desc.h.

◆ HID_REPORT_ID_6

#define HID_REPORT_ID_6 0xF0

Definition at line 227 of file audio_hid_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 229 of file audio_hid_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 230 of file audio_hid_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 231 of file audio_hid_desc.h.

◆ SAMPLE_FREQ

#define SAMPLE_FREQ ( frq ) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))

Definition at line 234 of file audio_hid_desc.h.

◆ USBD_AUHID_CONFIG_DESC_SIZE

#define USBD_AUHID_CONFIG_DESC_SIZE
Value:
( 0x12 + AUDIO_INTERFACE_LEN + \
+ (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
+ (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
+ (9 * AUDIO_SUPPORT_FEEDBACK) \
+ USBD_AUHID_HID_DESC_SIZE)
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_hid_desc.h:194
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_hid_desc.h:201
USBD_AUHID_HID_DESC_SIZE
#define USBD_AUHID_HID_DESC_SIZE
Definition: audio_hid_desc.h:237
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_hid_desc.h:153
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49

Definition at line 238 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_CONFIGURATION_STRING

#define USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"

Definition at line 61 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_INTERFACE_STRING

#define USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"

Definition at line 62 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_MANUFACTURER_STRING

#define USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"

Definition at line 59 of file audio_hid_desc.h.

◆ USBD_AUHID_DESC_PRODUCT_STRING

#define USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"

Definition at line 60 of file audio_hid_desc.h.

◆ USBD_AUHID_HID_DESC_SIZE

#define USBD_AUHID_HID_DESC_SIZE 32

Definition at line 237 of file audio_hid_desc.h.

◆ USBD_AUHID_HID_SIZ_REPORT_DESC

#define USBD_AUHID_HID_SIZ_REPORT_DESC 126

Definition at line 236 of file audio_hid_desc.h.

◆ USBD_AUHID_PRODUCT_ID

#define USBD_AUHID_PRODUCT_ID 0x5555

Definition at line 54 of file audio_hid_desc.h.

◆ USBD_AUHID_SIZ_STRING_LANGID

#define USBD_AUHID_SIZ_STRING_LANGID 4

Definition at line 56 of file audio_hid_desc.h.

◆ USBD_AUHID_SIZ_STRING_SERIAL

#define USBD_AUHID_SIZ_STRING_SERIAL 0x1A

Definition at line 57 of file audio_hid_desc.h.

◆ USBD_AUHID_VENDOR_ID

#define USBD_AUHID_VENDOR_ID 0x2E3C

Definition at line 53 of file audio_hid_desc.h.

Variable Documentation

◆ audio_hid_desc_handler

usbd_desc_handler audio_hid_desc_handler
extern

device descriptor handler structure

Definition at line 64 of file audio_hid_desc.c.

Referenced by main().

◆ g_audio_hid_usb_desc

ALIGNED_HEAD uint8_t g_audio_hid_usb_desc
extern
Initial value:
=
{
0x09,
0x21 ,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
0x22 ,
LBYTE(sizeof(g_usbd_audio_hid_report)),
HBYTE(sizeof(g_usbd_audio_hid_report)),
}
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:423
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260

usb hid descriptor

Definition at line 521 of file audio_hid_desc.c.

Referenced by class_hid_setup_handler().

◆ g_usbd_audio_hid_report

ALIGNED_HEAD uint8_t g_usbd_audio_hid_report
extern

usb hid report descriptor

Definition at line 423 of file audio_hid_desc.c.

Referenced by class_hid_setup_handler().


AT32F413 Firmwary Library: USB_cdc_class

Modules
USB_cdc_class
AT32F413_middlewares_usbd_class

usb device class cdc demo More...

Modules

USB_cdc_class_private_functions
USB_cdc_class_definition
USB_cdc_class_exported_types
USB_cdc_class_exported_functions

Detailed Description

usb device class cdc demo


AT32F413 Firmwary Library: USB_cdc_class_private_functions

Functions | Variables
USB_cdc_class_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_struct_init (cdc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_struct_type cdc_struct
usbd_class_handler cdc_class_handler

Detailed Description

Function Documentation

◆ cdc_struct_init()

static usb_sts_type cdc_struct_init ( cdc_struct_type * pcdc )
static

usb device cdc init

Parameters
pcdc to the structure of cdc_struct
Return values
status of usb_sts_type

Definition at line 322 of file cdc_class.c.

Referenced by class_init_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 123 of file cdc_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 215 of file cdc_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 201 of file cdc_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 292 of file cdc_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 237 of file cdc_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 88 of file cdc_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 257 of file cdc_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 146 of file cdc_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 277 of file cdc_class.c.

◆ usb_usart_config()

void usb_usart_config ( linecoding_type linecoding )

this function handles usart2 and linecoding config.

Parameters
linecoding linecoding value
Return values
none

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

Definition at line 299 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by usb_vcp_cmd_process().

◆ usb_vcp_cmd_process()

static void usb_vcp_cmd_process | ( | void * | udev,
 |  | uint8_t | cmd,
 |  | uint8_t * | buff,
 |  | uint16_t | len
 | ) |  |
static

usb device class request function

Parameters
udev | to the structure of usbd_core_type
cmd | request number
buff | request buffer
len | buffer length
Return values
none

Definition at line 396 of file cdc_class.c.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 340 of file cdc_class.c.

Referenced by main().

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 370 of file cdc_class.c.

Referenced by main().

Variable Documentation

◆ cdc_class_handler

usbd_class_handler cdc_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&cdc_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_class.c:277
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_class.c:237
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_class.c:123
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_class.c:146
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_class.c:201
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_class.c:215
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_class.c:292
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_class.c:88
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_class.c:257
cdc_struct
cdc_struct_type cdc_struct
Definition: cdc_class.c:66

Definition at line 69 of file cdc_class.c.

Referenced by main().

◆ cdc_struct

cdc_struct_type cdc_struct

Definition at line 66 of file cdc_class.c.

◆ linecoding

linecoding_type linecoding
Initial value:
=
{
115200,
0,
0,
8
}

Definition at line 57 of file cdc_class.c.

Referenced by cdc_struct_init().


AT32F413 Firmwary Library: USB_cdc_class_definition

Macros
USB_cdc_class_definition
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class

Macros

#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x81
#define | USBD_CDC_BULK_OUT_EPT 0x01
#define | USBD_CDC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08
#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x83
#define | USBD_CDC_BULK_OUT_EPT 0x02
#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Detailed Description

Macro Definition Documentation

◆ USBD_CDC_BULK_IN_EPT [1/2]

#define USBD_CDC_BULK_IN_EPT 0x81

Definition at line 54 of file cdc_class.h.

◆ USBD_CDC_BULK_IN_EPT [2/2]

#define USBD_CDC_BULK_IN_EPT 0x83

Definition at line 54 of file cdc_msc_class.h.

◆ USBD_CDC_BULK_OUT_EPT [1/2]

#define USBD_CDC_BULK_OUT_EPT 0x01

Definition at line 55 of file cdc_class.h.

◆ USBD_CDC_BULK_OUT_EPT [2/2]

#define USBD_CDC_BULK_OUT_EPT 0x02

Definition at line 55 of file cdc_msc_class.h.

◆ USBD_CDC_CMD_MAXPACKET_SIZE [1/2]

#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Definition at line 62 of file cdc_class.h.

◆ USBD_CDC_CMD_MAXPACKET_SIZE [2/2]

#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Definition at line 66 of file cdc_msc_class.h.

◆ USBD_CDC_IN_MAXPACKET_SIZE

#define USBD_CDC_IN_MAXPACKET_SIZE 0x40

usb cdc in and out max packet size define

Definition at line 60 of file cdc_class.h.

◆ USBD_CDC_INT_EPT [1/2]

#define USBD_CDC_INT_EPT 0x82

usb cdc use endpoint define

Definition at line 53 of file cdc_class.h.

◆ USBD_CDC_INT_EPT [2/2]

#define USBD_CDC_INT_EPT 0x82

usb cdc use endpoint define

Definition at line 53 of file cdc_msc_class.h.

◆ USBD_CDC_MSC_IN_MAXPACKET_SIZE

#define USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40

usb cdc in and out max packet size define

Definition at line 63 of file cdc_msc_class.h.

◆ USBD_CDC_MSC_OUT_MAXPACKET_SIZE

#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40

Definition at line 65 of file cdc_msc_class.h.

◆ USBD_CDC_OUT_MAXPACKET_SIZE

#define USBD_CDC_OUT_MAXPACKET_SIZE 0x40

Definition at line 61 of file cdc_class.h.

◆ USBD_MSC_BULK_IN_EPT

#define USBD_MSC_BULK_IN_EPT 0x81

Definition at line 57 of file cdc_msc_class.h.

◆ USBD_MSC_BULK_OUT_EPT

#define USBD_MSC_BULK_OUT_EPT 0x01

Definition at line 58 of file cdc_msc_class.h.


AT32F413 Firmwary Library: USB_cdc_class_exported_types

Modules | Data Structures
USB_cdc_class_exported_types
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class

Modules

USB_msc_bot_scsi_definition
USB_cdc_msc_class_exported_functions

Data Structures

struct | cdc_struct_type
usb cdc class struct More...
struct | vcp_keyboard_type

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: USB_msc_bot_scsi_definition

Data Structures | Macros | Functions
USB_msc_bot_scsi_definition
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi

Data Structures

struct | cbd_typical_type
typical command block description More...
struct | cbd_extended_type
extended command block description More...
struct | cbw_type
command block wrapper More...
struct | csw_type
command block wrapper More...
struct | sense_type
request sense standard data More...
struct | msc_type
struct | cdc_msc_struct_type
usb cdc class struct More...

Macros

#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36
#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *pudev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *pudev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...

Detailed Description

Macro Definition Documentation

◆ ADDRESS_OUT_OF_RANGE [1/2]

#define ADDRESS_OUT_OF_RANGE 0x21

Definition at line 153 of file cdc_msc_class.h.

◆ ADDRESS_OUT_OF_RANGE [2/2]

#define ADDRESS_OUT_OF_RANGE 0x21

Definition at line 119 of file msc_bot_scsi.h.

◆ CBW_BMCBWFLAGS_DIR_IN [1/2]

#define CBW_BMCBWFLAGS_DIR_IN 0x80

Definition at line 112 of file cdc_msc_class.h.

◆ CBW_BMCBWFLAGS_DIR_IN [2/2]

#define CBW_BMCBWFLAGS_DIR_IN 0x80

Definition at line 78 of file msc_bot_scsi.h.

◆ CBW_BMCBWFLAGS_DIR_OUT [1/2]

#define CBW_BMCBWFLAGS_DIR_OUT 0x00

Definition at line 111 of file cdc_msc_class.h.

◆ CBW_BMCBWFLAGS_DIR_OUT [2/2]

#define CBW_BMCBWFLAGS_DIR_OUT 0x00

Definition at line 77 of file msc_bot_scsi.h.

◆ CBW_CMD_LENGTH [1/2]

#define CBW_CMD_LENGTH 31

Definition at line 109 of file cdc_msc_class.h.

◆ CBW_CMD_LENGTH [2/2]

#define CBW_CMD_LENGTH 31

Definition at line 75 of file msc_bot_scsi.h.

◆ CBW_DCBWSIGNATURE [1/2]

#define CBW_DCBWSIGNATURE 0x43425355

Definition at line 110 of file cdc_msc_class.h.

◆ CBW_DCBWSIGNATURE [2/2]

#define CBW_DCBWSIGNATURE 0x43425355

Definition at line 76 of file msc_bot_scsi.h.

◆ CSW_BCSWSTATUS_FAILED [1/2]

#define CSW_BCSWSTATUS_FAILED 0x01

Definition at line 117 of file cdc_msc_class.h.

◆ CSW_BCSWSTATUS_FAILED [2/2]

#define CSW_BCSWSTATUS_FAILED 0x01

Definition at line 83 of file msc_bot_scsi.h.

◆ CSW_BCSWSTATUS_PASS [1/2]

#define CSW_BCSWSTATUS_PASS 0x00

Definition at line 116 of file cdc_msc_class.h.

◆ CSW_BCSWSTATUS_PASS [2/2]

#define CSW_BCSWSTATUS_PASS 0x00

Definition at line 82 of file msc_bot_scsi.h.

◆ CSW_BCSWSTATUS_PHASE_ERR [1/2]

#define CSW_BCSWSTATUS_PHASE_ERR 0x02

Definition at line 118 of file cdc_msc_class.h.

◆ CSW_BCSWSTATUS_PHASE_ERR [2/2]

#define CSW_BCSWSTATUS_PHASE_ERR 0x02

Definition at line 84 of file msc_bot_scsi.h.

◆ CSW_CMD_LENGTH [1/2]

#define CSW_CMD_LENGTH 13

Definition at line 114 of file cdc_msc_class.h.

◆ CSW_CMD_LENGTH [2/2]

#define CSW_CMD_LENGTH 13

Definition at line 80 of file msc_bot_scsi.h.

◆ CSW_DCSWSIGNATURE [1/2]

#define CSW_DCSWSIGNATURE 0x53425355

Definition at line 115 of file cdc_msc_class.h.

◆ CSW_DCSWSIGNATURE [2/2]

#define CSW_DCSWSIGNATURE 0x53425355

Definition at line 81 of file msc_bot_scsi.h.

◆ GET_LINE_CODING [1/2]

#define GET_LINE_CODING 0x21

Definition at line 107 of file cdc_msc_class.h.

◆ GET_LINE_CODING [2/2]

#define GET_LINE_CODING 0x21

Definition at line 73 of file msc_bot_scsi.h.

◆ INVALID_COMMAND [1/2]

#define INVALID_COMMAND 0x20

Definition at line 149 of file cdc_msc_class.h.

◆ INVALID_COMMAND [2/2]

#define INVALID_COMMAND 0x20

Definition at line 115 of file msc_bot_scsi.h.

◆ INVALID_FIELD_IN_PARAMETER_LIST [1/2]

#define INVALID_FIELD_IN_PARAMETER_LIST 0x26

Definition at line 152 of file cdc_msc_class.h.

◆ INVALID_FIELD_IN_PARAMETER_LIST [2/2]

#define INVALID_FIELD_IN_PARAMETER_LIST 0x26

Definition at line 118 of file msc_bot_scsi.h.

◆ INVALID_FIELED_IN_COMMAND [1/2]

#define INVALID_FIELED_IN_COMMAND 0x24

Definition at line 150 of file cdc_msc_class.h.

◆ INVALID_FIELED_IN_COMMAND [2/2]

#define INVALID_FIELED_IN_COMMAND 0x24

Definition at line 116 of file msc_bot_scsi.h.

◆ MEDIUM_HAVE_CHANGED [1/2]

#define MEDIUM_HAVE_CHANGED 0x28

Definition at line 155 of file cdc_msc_class.h.

◆ MEDIUM_HAVE_CHANGED [2/2]

#define MEDIUM_HAVE_CHANGED 0x28

Definition at line 121 of file msc_bot_scsi.h.

◆ MEDIUM_NOT_PRESENT [1/2]

#define MEDIUM_NOT_PRESENT 0x3A

Definition at line 154 of file cdc_msc_class.h.

◆ MEDIUM_NOT_PRESENT [2/2]

#define MEDIUM_NOT_PRESENT 0x3A

Definition at line 120 of file msc_bot_scsi.h.

◆ MSC_BOT_STATE_ERROR [1/2]

#define MSC_BOT_STATE_ERROR 0x02

Definition at line 131 of file cdc_msc_class.h.

◆ MSC_BOT_STATE_ERROR [2/2]

#define MSC_BOT_STATE_ERROR 0x02

Definition at line 97 of file msc_bot_scsi.h.

◆ MSC_BOT_STATE_IDLE [1/2]

#define MSC_BOT_STATE_IDLE 0x00

Definition at line 129 of file cdc_msc_class.h.

◆ MSC_BOT_STATE_IDLE [2/2]

#define MSC_BOT_STATE_IDLE 0x00

Definition at line 95 of file msc_bot_scsi.h.

◆ MSC_BOT_STATE_RECOVERY [1/2]

#define MSC_BOT_STATE_RECOVERY 0x01

Definition at line 130 of file cdc_msc_class.h.

◆ MSC_BOT_STATE_RECOVERY [2/2]

#define MSC_BOT_STATE_RECOVERY 0x01

Definition at line 96 of file msc_bot_scsi.h.

◆ MSC_CMD_ALLOW_MEDIUM_REMOVAL [1/2]

#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E

Definition at line 91 of file cdc_msc_class.h.

◆ MSC_CMD_ALLOW_MEDIUM_REMOVAL [2/2]

#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E

Definition at line 57 of file msc_bot_scsi.h.

◆ MSC_CMD_FORMAT_UNIT [1/2]

#define MSC_CMD_FORMAT_UNIT 0x04

Definition at line 86 of file cdc_msc_class.h.

◆ MSC_CMD_FORMAT_UNIT [2/2]

#define MSC_CMD_FORMAT_UNIT 0x04

Definition at line 52 of file msc_bot_scsi.h.

◆ MSC_CMD_INQUIRY [1/2]

#define MSC_CMD_INQUIRY 0x12

Definition at line 87 of file cdc_msc_class.h.

◆ MSC_CMD_INQUIRY [2/2]

#define MSC_CMD_INQUIRY 0x12

Definition at line 53 of file msc_bot_scsi.h.

◆ MSC_CMD_MODE_SENSE10 [1/2]

#define MSC_CMD_MODE_SENSE10 0x5A

Definition at line 90 of file cdc_msc_class.h.

◆ MSC_CMD_MODE_SENSE10 [2/2]

#define MSC_CMD_MODE_SENSE10 0x5A

Definition at line 56 of file msc_bot_scsi.h.

◆ MSC_CMD_MODE_SENSE6 [1/2]

#define MSC_CMD_MODE_SENSE6 0x1A

Definition at line 89 of file cdc_msc_class.h.

◆ MSC_CMD_MODE_SENSE6 [2/2]

#define MSC_CMD_MODE_SENSE6 0x1A

Definition at line 55 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_10 [1/2]

#define MSC_CMD_READ_10 0x28

Definition at line 92 of file cdc_msc_class.h.

◆ MSC_CMD_READ_10 [2/2]

#define MSC_CMD_READ_10 0x28

Definition at line 58 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_12 [1/2]

#define MSC_CMD_READ_12 0xA8

Definition at line 93 of file cdc_msc_class.h.

◆ MSC_CMD_READ_12 [2/2]

#define MSC_CMD_READ_12 0xA8

Definition at line 59 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_CAPACITY [1/2]

#define MSC_CMD_READ_CAPACITY 0x25

Definition at line 94 of file cdc_msc_class.h.

◆ MSC_CMD_READ_CAPACITY [2/2]

#define MSC_CMD_READ_CAPACITY 0x25

Definition at line 60 of file msc_bot_scsi.h.

◆ MSC_CMD_READ_FORMAT_CAPACITY [1/2]

#define MSC_CMD_READ_FORMAT_CAPACITY 0x23

Definition at line 95 of file cdc_msc_class.h.

◆ MSC_CMD_READ_FORMAT_CAPACITY [2/2]

#define MSC_CMD_READ_FORMAT_CAPACITY 0x23

Definition at line 61 of file msc_bot_scsi.h.

◆ MSC_CMD_REQUEST_SENSE [1/2]

#define MSC_CMD_REQUEST_SENSE 0x03

Definition at line 96 of file cdc_msc_class.h.

◆ MSC_CMD_REQUEST_SENSE [2/2]

#define MSC_CMD_REQUEST_SENSE 0x03

Definition at line 62 of file msc_bot_scsi.h.

◆ MSC_CMD_START_STOP [1/2]

#define MSC_CMD_START_STOP 0x1B

Definition at line 88 of file cdc_msc_class.h.

◆ MSC_CMD_START_STOP [2/2]

#define MSC_CMD_START_STOP 0x1B

Definition at line 54 of file msc_bot_scsi.h.

◆ MSC_CMD_TEST_UNIT [1/2]

#define MSC_CMD_TEST_UNIT 0x00

Definition at line 97 of file cdc_msc_class.h.

◆ MSC_CMD_TEST_UNIT [2/2]

#define MSC_CMD_TEST_UNIT 0x00

Definition at line 63 of file msc_bot_scsi.h.

◆ MSC_CMD_VERIFY [1/2]

#define MSC_CMD_VERIFY 0x2F

Definition at line 98 of file cdc_msc_class.h.

◆ MSC_CMD_VERIFY [2/2]

#define MSC_CMD_VERIFY 0x2F

Definition at line 64 of file msc_bot_scsi.h.

◆ MSC_CMD_WRITE_10 [1/2]

#define MSC_CMD_WRITE_10 0x2A

Definition at line 99 of file cdc_msc_class.h.

◆ MSC_CMD_WRITE_10 [2/2]

#define MSC_CMD_WRITE_10 0x2A

Definition at line 65 of file msc_bot_scsi.h.

◆ MSC_CMD_WRITE_12 [1/2]

#define MSC_CMD_WRITE_12 0xAA

Definition at line 100 of file cdc_msc_class.h.

◆ MSC_CMD_WRITE_12 [2/2]

#define MSC_CMD_WRITE_12 0xAA

Definition at line 66 of file msc_bot_scsi.h.

◆ MSC_CMD_WRITE_VERIFY [1/2]

#define MSC_CMD_WRITE_VERIFY 0x2E

Definition at line 101 of file cdc_msc_class.h.

◆ MSC_CMD_WRITE_VERIFY [2/2]

#define MSC_CMD_WRITE_VERIFY 0x2E

Definition at line 67 of file msc_bot_scsi.h.

◆ MSC_MAX_DATA_BUF_LEN [1/2]

#define MSC_MAX_DATA_BUF_LEN 4096

Definition at line 84 of file cdc_msc_class.h.

◆ MSC_MAX_DATA_BUF_LEN [2/2]

#define MSC_MAX_DATA_BUF_LEN 4096

Definition at line 50 of file msc_bot_scsi.h.

◆ MSC_REQ_BO_RESET [1/2]

#define MSC_REQ_BO_RESET 0xFF

bulk only mass storage reset

Definition at line 104 of file cdc_msc_class.h.

◆ MSC_REQ_BO_RESET [2/2]

#define MSC_REQ_BO_RESET 0xFF

bulk only mass storage reset

Definition at line 70 of file msc_bot_scsi.h.

◆ MSC_REQ_GET_MAX_LUN [1/2]

#define MSC_REQ_GET_MAX_LUN 0xFE

get max lun

Definition at line 103 of file cdc_msc_class.h.

◆ MSC_REQ_GET_MAX_LUN [2/2]

#define MSC_REQ_GET_MAX_LUN 0xFE

get max lun

Definition at line 69 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_CMD [1/2]

#define MSC_STATE_MACHINE_CMD 0x00

Definition at line 120 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_CMD [2/2]

#define MSC_STATE_MACHINE_CMD 0x00

Definition at line 86 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_DATA_IN [1/2]

#define MSC_STATE_MACHINE_DATA_IN 0x01

Definition at line 121 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_DATA_IN [2/2]

#define MSC_STATE_MACHINE_DATA_IN 0x01

Definition at line 87 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_DATA_OUT [1/2]

#define MSC_STATE_MACHINE_DATA_OUT 0x02

Definition at line 122 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_DATA_OUT [2/2]

#define MSC_STATE_MACHINE_DATA_OUT 0x02

Definition at line 88 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_FAILED [1/2]

#define MSC_STATE_MACHINE_FAILED 0x06

Definition at line 126 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_FAILED [2/2]

#define MSC_STATE_MACHINE_FAILED 0x06

Definition at line 92 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_IDLE [1/2]

#define MSC_STATE_MACHINE_IDLE 0x07

Definition at line 127 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_IDLE [2/2]

#define MSC_STATE_MACHINE_IDLE 0x07

Definition at line 93 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_LAST_DATA [1/2]

#define MSC_STATE_MACHINE_LAST_DATA 0x04

Definition at line 124 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_LAST_DATA [2/2]

#define MSC_STATE_MACHINE_LAST_DATA 0x04

Definition at line 90 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_SEND_DATA [1/2]

#define MSC_STATE_MACHINE_SEND_DATA 0x03

Definition at line 123 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_SEND_DATA [2/2]

#define MSC_STATE_MACHINE_SEND_DATA 0x03

Definition at line 89 of file msc_bot_scsi.h.

◆ MSC_STATE_MACHINE_STATUS [1/2]

#define MSC_STATE_MACHINE_STATUS 0x05

Definition at line 125 of file cdc_msc_class.h.

◆ MSC_STATE_MACHINE_STATUS [2/2]

#define MSC_STATE_MACHINE_STATUS 0x05

Definition at line 91 of file msc_bot_scsi.h.

◆ MSC_SUPPORT_MAX_LUN [1/2]

#define MSC_SUPPORT_MAX_LUN 1

Definition at line 83 of file cdc_msc_class.h.

◆ MSC_SUPPORT_MAX_LUN [2/2]

#define MSC_SUPPORT_MAX_LUN 1

Definition at line 49 of file msc_bot_scsi.h.

◆ PARAMETER_LIST_LENGTH_ERROR [1/2]

#define PARAMETER_LIST_LENGTH_ERROR 0x1A

Definition at line 151 of file cdc_msc_class.h.

◆ PARAMETER_LIST_LENGTH_ERROR [2/2]

#define PARAMETER_LIST_LENGTH_ERROR 0x1A

Definition at line 117 of file msc_bot_scsi.h.

◆ REQ_SENSE_STANDARD_DATA_LEN [1/2]

#define REQ_SENSE_STANDARD_DATA_LEN 0x12

Definition at line 133 of file cdc_msc_class.h.

◆ REQ_SENSE_STANDARD_DATA_LEN [2/2]

#define REQ_SENSE_STANDARD_DATA_LEN 0x12

Definition at line 99 of file msc_bot_scsi.h.

◆ SCSI_INQUIRY_DATA_LENGTH [1/2]

#define SCSI_INQUIRY_DATA_LENGTH 36

Definition at line 157 of file cdc_msc_class.h.

◆ SCSI_INQUIRY_DATA_LENGTH [2/2]

#define SCSI_INQUIRY_DATA_LENGTH 36

Definition at line 123 of file msc_bot_scsi.h.

◆ SENSE_KEY_ABORTED_COMMAND [1/2]

#define SENSE_KEY_ABORTED_COMMAND 0x0B

Definition at line 144 of file cdc_msc_class.h.

◆ SENSE_KEY_ABORTED_COMMAND [2/2]

#define SENSE_KEY_ABORTED_COMMAND 0x0B

Definition at line 110 of file msc_bot_scsi.h.

◆ SENSE_KEY_BLANK_CHECK [1/2]

#define SENSE_KEY_BLANK_CHECK 0x08

Definition at line 142 of file cdc_msc_class.h.

◆ SENSE_KEY_BLANK_CHECK [2/2]

#define SENSE_KEY_BLANK_CHECK 0x08

Definition at line 108 of file msc_bot_scsi.h.

◆ SENSE_KEY_DATA_PROTECT [1/2]

#define SENSE_KEY_DATA_PROTECT 0x07

Definition at line 141 of file cdc_msc_class.h.

◆ SENSE_KEY_DATA_PROTECT [2/2]

#define SENSE_KEY_DATA_PROTECT 0x07

Definition at line 107 of file msc_bot_scsi.h.

◆ SENSE_KEY_HARDWARE_ERROR [1/2]

#define SENSE_KEY_HARDWARE_ERROR 0x04

Definition at line 138 of file cdc_msc_class.h.

◆ SENSE_KEY_HARDWARE_ERROR [2/2]

#define SENSE_KEY_HARDWARE_ERROR 0x04

Definition at line 104 of file msc_bot_scsi.h.

◆ SENSE_KEY_ILLEGAL_REQUEST [1/2]

#define SENSE_KEY_ILLEGAL_REQUEST 0x05

Definition at line 139 of file cdc_msc_class.h.

◆ SENSE_KEY_ILLEGAL_REQUEST [2/2]

#define SENSE_KEY_ILLEGAL_REQUEST 0x05

Definition at line 105 of file msc_bot_scsi.h.

◆ SENSE_KEY_MEDIUM_ERROR [1/2]

#define SENSE_KEY_MEDIUM_ERROR 0x03

Definition at line 137 of file cdc_msc_class.h.

◆ SENSE_KEY_MEDIUM_ERROR [2/2]

#define SENSE_KEY_MEDIUM_ERROR 0x03

Definition at line 103 of file msc_bot_scsi.h.

◆ SENSE_KEY_MISCOMPARE [1/2]

#define SENSE_KEY_MISCOMPARE 0x0E

Definition at line 146 of file cdc_msc_class.h.

◆ SENSE_KEY_MISCOMPARE [2/2]

#define SENSE_KEY_MISCOMPARE 0x0E

Definition at line 112 of file msc_bot_scsi.h.

◆ SENSE_KEY_NO_SENSE [1/2]

#define SENSE_KEY_NO_SENSE 0x00

Definition at line 134 of file cdc_msc_class.h.

◆ SENSE_KEY_NO_SENSE [2/2]

#define SENSE_KEY_NO_SENSE 0x00

Definition at line 100 of file msc_bot_scsi.h.

◆ SENSE_KEY_NOT_READY [1/2]

#define SENSE_KEY_NOT_READY 0x02

Definition at line 136 of file cdc_msc_class.h.

◆ SENSE_KEY_NOT_READY [2/2]

#define SENSE_KEY_NOT_READY 0x02

Definition at line 102 of file msc_bot_scsi.h.

◆ SENSE_KEY_RECOVERED_ERROR [1/2]

#define SENSE_KEY_RECOVERED_ERROR 0x01

Definition at line 135 of file cdc_msc_class.h.

◆ SENSE_KEY_RECOVERED_ERROR [2/2]

#define SENSE_KEY_RECOVERED_ERROR 0x01

Definition at line 101 of file msc_bot_scsi.h.

◆ SENSE_KEY_UNIT_ATTENTION [1/2]

#define SENSE_KEY_UNIT_ATTENTION 0x06

Definition at line 140 of file cdc_msc_class.h.

◆ SENSE_KEY_UNIT_ATTENTION [2/2]

#define SENSE_KEY_UNIT_ATTENTION 0x06

Definition at line 106 of file msc_bot_scsi.h.

◆ SENSE_KEY_VENDERO_SPECIFIC [1/2]

#define SENSE_KEY_VENDERO_SPECIFIC 0x09

Definition at line 143 of file cdc_msc_class.h.

◆ SENSE_KEY_VENDERO_SPECIFIC [2/2]

#define SENSE_KEY_VENDERO_SPECIFIC 0x09

Definition at line 109 of file msc_bot_scsi.h.

◆ SENSE_KEY_VOLUME_OVERFLOW [1/2]

#define SENSE_KEY_VOLUME_OVERFLOW 0x0D

Definition at line 145 of file cdc_msc_class.h.

◆ SENSE_KEY_VOLUME_OVERFLOW [2/2]

#define SENSE_KEY_VOLUME_OVERFLOW 0x0D

Definition at line 111 of file msc_bot_scsi.h.

◆ SET_LINE_CODING [1/2]

#define SET_LINE_CODING 0x20

Definition at line 106 of file cdc_msc_class.h.

◆ SET_LINE_CODING [2/2]

#define SET_LINE_CODING 0x20

Definition at line 72 of file msc_bot_scsi.h.

Function Documentation

◆ bot_cbw_decode()

void bot_cbw_decode ( void * udev )

bulk-only cbw decode

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 197 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_dataout_handler().

◆ bot_scsi_allow_medium_removal()

usb_sts_type bot_scsi_allow_medium_removal | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command meidum removal

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 424 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_capacity()

usb_sts_type bot_scsi_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 478 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_check_address()

usb_sts_type bot_scsi_check_address | ( | void * | udev,
 |  | uint8_t | lun,
 |  | uint32_t | blk_offset,
 |  | uint32_t | blk_count
 | ) |  |

check address

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type

Definition at line 304 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_clear_feature()

void bot_scsi_clear_feature | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

clear feature

Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type

Definition at line 730 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_cmd_process()

usb_sts_type bot_scsi_cmd_process ( void * udev )

bulk-only transport scsi command process

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type
Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 750 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), and bot_scsi_dataout_handler().

◆ bot_scsi_datain_handler()

void bot_scsi_datain_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data in handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 144 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_dataout_handler()

void bot_scsi_dataout_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data out handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 173 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_format_capacity()

usb_sts_type bot_scsi_format_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command format capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 505 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_init()

void bot_scsi_init ( void * udev )

initialize bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 104 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_inquiry()

usb_sts_type bot_scsi_inquiry | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command inquiry

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 369 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense10()

usb_sts_type bot_scsi_mode_sense10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 458 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense6()

usb_sts_type bot_scsi_mode_sense6 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense6

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 438 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_read10()

usb_sts_type bot_scsi_read10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command read10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 599 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_request_sense()

usb_sts_type bot_scsi_request_sense | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command request sense

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 540 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_reset()

void bot_scsi_reset ( void * udev )

reset bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 126 of file composite_cdc_msc/msc_bot_scsi.c.

◆ bot_scsi_send_csw()

void bot_scsi_send_csw | ( | void * | udev,
 |  | uint8_t | status
 | ) |  |

send command status

Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none
Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none

Definition at line 265 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), and bot_scsi_write10().

◆ bot_scsi_send_data()

void bot_scsi_send_data | ( | void * | udev,
 |  | uint8_t * | buffer,
 |  | uint32_t | len
 | ) |  |

send bot data

Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none
Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none

Definition at line 244 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_sense_code()

void bot_scsi_sense_code | ( | void * | udev,
 |  | uint8_t | sense_key,
 |  | uint8_t | asc
 | ) |  |

send scsi sense code

Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none
Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none

Definition at line 289 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_check_address(), bot_scsi_cmd_process(), bot_scsi_read10(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_stall()

void bot_scsi_stall ( void * udev )

bot endpoint stall

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 321 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_start_stop()

usb_sts_type bot_scsi_start_stop | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command start stop

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 410 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_test_unit()

usb_sts_type bot_scsi_test_unit | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command test unit

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 347 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_verify()

usb_sts_type bot_scsi_verify | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command verify

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 571 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_write10()

usb_sts_type bot_scsi_write10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command write10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 660 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().


AT32F413 Firmwary Library: cbd_typical_type Struct Reference

Data Fields
cbd_typical_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

typical command block description More...

#include <cdc_msc_class.h>

Data Fields

uint8_t | opcode
uint8_t | lun
uint32_t | address
uint8_t | reserved1
uint32_t | alloc_length
uint16_t | reserved2

Detailed Description

typical command block description

Definition at line 162 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: cbd_extended_type Struct Reference

Data Fields
cbd_extended_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

extended command block description More...

#include <cdc_msc_class.h>

Data Fields

uint8_t | opcode
uint8_t | lun
uint32_t | address
uint8_t | reserved1
uint32_t | alloc_length
uint16_t | reserved2

Detailed Description

extended command block description

Definition at line 175 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: cbw_type Struct Reference

Data Fields
cbw_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

command block wrapper More...

#include <cdc_msc_class.h>

Data Fields

uint32_t | dCBWSignature
uint32_t | dCBWTage
uint32_t | dCBWDataTransferLength
uint8_t | bmCBWFlags
uint8_t | bCBWLUN
uint8_t | bCBWCBLength
uint8_t | CBWCB [16]

Detailed Description

command block wrapper

Definition at line 188 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: csw_type Struct Reference

Data Fields
csw_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

command block wrapper More...

#include <cdc_msc_class.h>

Data Fields

uint32_t | dCSWSignature
uint32_t | dCSWTag
uint32_t | dCSWDataResidue
uint32_t | bCSWStatus

Detailed Description

command block wrapper

Definition at line 202 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: sense_type Struct Reference

Data Fields
sense_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

request sense standard data More...

#include <cdc_msc_class.h>

Data Fields

uint8_t | err_code
uint8_t | reserved1
uint8_t | sense_key
uint32_t | information
uint8_t | as_length
uint32_t | reserved2
uint8_t | asc
uint8_t | ascq
uint32_t | reserved3

Detailed Description

request sense standard data

Definition at line 213 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: msc_type Struct Reference

Data Fields
msc_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

#include <cdc_msc_class.h>

Data Fields

uint8_t | msc_state
uint8_t | bot_status
uint32_t | max_lun
uint32_t | blk_nbr [1]
uint32_t | blk_size [1]
uint32_t | blk_addr
uint32_t | blk_len
uint32_t | data_len
uint8_t | data [4096]
uint32_t | alt_setting
cbw_type cbw_struct
csw_type csw_struct

Detailed Description

Definition at line 227 of file cdc_msc_class.h.

The documentation for this struct was generated from the following files:
  • cdc_msc_class.h
  • msc_bot_scsi.h


AT32F413 Firmwary Library: cdc_msc_struct_type Struct Reference

Data Fields
cdc_msc_struct_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types | AT32F413_middlewares_usbd_class » USB_msc_bot_scsi » USB_msc_bot_scsi_definition

usb cdc class struct More...

#include <cdc_msc_class.h>

Data Fields

uint32_t | alt_setting
uint8_t | g_rx_buff [0x40]
uint8_t | g_cmd [0x08]
uint8_t | g_req
uint16_t | g_len
uint16_t | g_rxlen
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
linecoding_type linecoding
uint8_t | msc_state
uint8_t | bot_status
uint32_t | max_lun
uint32_t | blk_nbr [1]
uint32_t | blk_size [1]
uint32_t | blk_addr
uint32_t | blk_len
uint32_t | data_len
uint8_t | data [4096]
cbw_type cbw_struct
csw_type csw_struct

Detailed Description

usb cdc class struct

Definition at line 252 of file cdc_msc_class.h.

The documentation for this struct was generated from the following file:
  • cdc_msc_class.h


AT32F413 Firmwary Library: USB_cdc_msc_class_exported_functions

Functions | Variables
USB_cdc_msc_class_exported_functions
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler cdc_msc_class_handler

Detailed Description

Function Documentation

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len
Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 340 of file cdc_class.c.

Referenced by main().

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status
Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 370 of file cdc_class.c.

Referenced by main().

Variable Documentation

◆ cdc_msc_class_handler

usbd_class_handler cdc_msc_class_handler
extern

Definition at line 72 of file cdc_msc_class.c.

Referenced by main().


AT32F413 Firmwary Library: cdc_struct_type Struct Reference

Data Fields
cdc_struct_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types

usb cdc class struct More...

#include <cdc_class.h>

Data Fields

uint32_t | alt_setting
uint8_t | g_rx_buff [0x40]
uint8_t | g_cmd [0x08]
uint8_t | g_req
uint16_t | g_len
uint16_t | g_rxlen
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
linecoding_type linecoding

Detailed Description

usb cdc class struct

Definition at line 75 of file cdc_class.h.

Field Documentation

◆ alt_setting

uint32_t cdc_struct_type::alt_setting

Definition at line 77 of file cdc_class.h.

Referenced by cdc_struct_init(), and class_setup_handler().

◆ g_cmd

uint8_t cdc_struct_type::g_cmd[0x08]

Definition at line 79 of file cdc_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ g_len

uint16_t cdc_struct_type::g_len

Definition at line 81 of file cdc_class.h.

Referenced by class_setup_handler().

◆ g_req

uint8_t cdc_struct_type::g_req

Definition at line 80 of file cdc_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ g_rx_buff

uint8_t cdc_struct_type::g_rx_buff[0x40]

Definition at line 78 of file cdc_class.h.

Referenced by class_init_handler(), and usb_vcp_get_rxdata().

◆ g_rx_completed

__IO uint8_t cdc_struct_type::g_rx_completed

Definition at line 82 of file cdc_class.h.

Referenced by cdc_struct_init(), class_out_handler(), and usb_vcp_get_rxdata().

◆ g_rxlen

uint16_t cdc_struct_type::g_rxlen

Definition at line 81 of file cdc_class.h.

Referenced by class_out_handler(), and usb_vcp_get_rxdata().

◆ g_tx_completed

__IO uint8_t cdc_struct_type::g_tx_completed

Definition at line 82 of file cdc_class.h.

Referenced by cdc_struct_init(), class_in_handler(), and usb_vcp_send_data().

◆ linecoding

linecoding_type cdc_struct_type::linecoding

Definition at line 83 of file cdc_class.h.

Referenced by cdc_struct_init(), and usb_vcp_cmd_process().

The documentation for this struct was generated from the following file:
  • cdc_class.h


AT32F413 Firmwary Library: vcp_keyboard_type Struct Reference

Data Fields
vcp_keyboard_type Struct Reference
AT32F413_middlewares_usbd_class » USB_cdc_class | AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class | AT32F413_middlewares_usbd_class » USB_cdc_msc_class » USB_cdc_class_exported_types

#include <cdc_keyboard_class.h>

Data Fields

uint32_t | alt_setting
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint8_t | hid_set_report [64]
uint8_t | g_rx_buff [0x40]
uint8_t | g_cmd [0x08]
uint8_t | g_req
uint8_t | hid_state
uint16_t | g_len
uint16_t | g_rxlen
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
__IO uint8_t | g_keyboard_tx_completed
linecoding_type linecoding

Detailed Description

Definition at line 74 of file cdc_keyboard_class.h.

Field Documentation

◆ alt_setting

uint32_t vcp_keyboard_type::alt_setting

Definition at line 76 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler(), and keyboard_class_setup_handler().

◆ g_cmd

uint8_t vcp_keyboard_type::g_cmd[0x08]

Definition at line 82 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_keyboard_tx_completed

__IO uint8_t vcp_keyboard_type::g_keyboard_tx_completed

Definition at line 88 of file cdc_keyboard_class.h.

Referenced by class_in_handler(), class_init_handler(), and keyboard_send_string().

◆ g_len

uint16_t vcp_keyboard_type::g_len

Definition at line 85 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler().

◆ g_req

uint8_t vcp_keyboard_type::g_req

Definition at line 83 of file cdc_keyboard_class.h.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ g_rx_buff

uint8_t vcp_keyboard_type::g_rx_buff[0x40]

Definition at line 81 of file cdc_keyboard_class.h.

Referenced by class_init_handler(), and usb_vcpkybrd_vcp_get_rxdata().

◆ g_rx_completed

__IO uint8_t vcp_keyboard_type::g_rx_completed

Definition at line 87 of file cdc_keyboard_class.h.

Referenced by class_out_handler(), and usb_vcpkybrd_vcp_get_rxdata().

◆ g_rxlen

uint16_t vcp_keyboard_type::g_rxlen

Definition at line 85 of file cdc_keyboard_class.h.

Referenced by class_out_handler(), and usb_vcpkybrd_vcp_get_rxdata().

◆ g_tx_completed

__IO uint8_t vcp_keyboard_type::g_tx_completed

Definition at line 86 of file cdc_keyboard_class.h.

Referenced by class_in_handler(), class_init_handler(), and usb_vcpkybrd_vcp_send_data().

◆ hid_protocol

uint32_t vcp_keyboard_type::hid_protocol

Definition at line 77 of file cdc_keyboard_class.h.

Referenced by keyboard_class_setup_handler().

◆ hid_set_idle

uint32_t vcp_keyboard_type::hid_set_idle

Definition at line 78 of file cdc_keyboard_class.h.

Referenced by keyboard_class_setup_handler().

◆ hid_set_report

uint8_t vcp_keyboard_type::hid_set_report[64]

Definition at line 80 of file cdc_keyboard_class.h.

Referenced by keyboard_class_setup_handler().

◆ hid_state

uint8_t vcp_keyboard_type::hid_state

Definition at line 84 of file cdc_keyboard_class.h.

Referenced by class_ept0_rx_handler(), and keyboard_class_setup_handler().

◆ linecoding

linecoding_type vcp_keyboard_type::linecoding

Definition at line 90 of file cdc_keyboard_class.h.

Referenced by class_init_handler(), and usb_vcp_cmd_process().

The documentation for this struct was generated from the following file:
  • cdc_keyboard_class.h


AT32F413 Firmwary Library: USB_cdc_class_exported_functions

Functions | Variables
USB_cdc_class_exported_functions
AT32F413_middlewares_usbd_class » USB_cdc_class

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler cdc_class_handler

Detailed Description

Function Documentation

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len
Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 340 of file cdc_class.c.

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status
Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 370 of file cdc_class.c.

Variable Documentation

◆ cdc_class_handler

usbd_class_handler cdc_class_handler
extern

Definition at line 69 of file cdc_class.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_desc

Modules | Variables
USB_cdc_desc
AT32F413_middlewares_usbd_class

usb device cdc descriptor More...

Modules

USB_cdc_desc_private_functions
USB_cdc_desc_definition

Variables

usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...

Detailed Description

usb device cdc descriptor

Variable Documentation

◆ cdc_desc_handler

usbd_desc_handler cdc_desc_handler
extern

device descriptor handler structure

Definition at line 63 of file cdc_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_desc_private_functions

Functions | Variables
USB_cdc_desc_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 428 of file cdc_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 350 of file cdc_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 330 of file cdc_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 416 of file cdc_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 370 of file cdc_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 381 of file cdc_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 360 of file cdc_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 393 of file cdc_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 340 of file cdc_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 405 of file cdc_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 308 of file cdc_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 282 of file cdc_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 256 of file cdc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x02,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5740 ),
HBYTE( 0x5740 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 83 of file cdc_desc.c.

◆ cdc_desc_handler

usbd_desc_handler cdc_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_desc.c:350
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_desc.c:330
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_desc.c:381
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_desc.c:340
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_desc.c:416
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_desc.c:360
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_desc.c:393
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_desc.c:428
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_desc.c:370
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_desc.c:405

device descriptor handler structure

Definition at line 63 of file cdc_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
67 ,
g_usbd_configuration
}

Definition at line 228 of file cdc_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 221 of file cdc_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 58 of file cdc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 235 of file cdc_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 242 of file cdc_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 248 of file cdc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_cdc_desc_definition

Macros
USB_cdc_desc_definition
AT32F413_middlewares_usbd_class » USB_cdc_desc | AT32F413_middlewares_usbd_class » USB_cdc_msc_desc

Macros

#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_PRODUCT_ID 0x5740
#define | USBD_CDC_CONFIG_DESC_SIZE 67
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)
#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_MSC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_MSC_PRODUCT_ID 0x5760
#define | USBD_CDC_MSC_CONFIG_DESC_SIZE 106
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | VCPMSC_MSC_INTERFACE 0x00
usb interface define More...
#define | VCPMSC_CDC_INTERFACE 0x01
#define | VCPMSC_CDC_DATA_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ CDC_BCD_NUM [1/2]

#define CDC_BCD_NUM 0x0110

usb bcd number define

Definition at line 52 of file cdc_desc.h.

◆ CDC_BCD_NUM [2/2]

#define CDC_BCD_NUM 0x0110

usb bcd number define

Definition at line 52 of file cdc_msc_desc.h.

◆ CDC_HID_BINTERVAL_TIME [1/2]

#define CDC_HID_BINTERVAL_TIME 0xFF

usb endpoint interval define

Definition at line 78 of file cdc_desc.h.

◆ CDC_HID_BINTERVAL_TIME [2/2]

#define CDC_HID_BINTERVAL_TIME 0xFF

usb endpoint interval define

Definition at line 79 of file cdc_msc_desc.h.

◆ MCU_ID1 [1/2]

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 83 of file cdc_desc.h.

◆ MCU_ID1 [2/2]

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 92 of file cdc_msc_desc.h.

◆ MCU_ID2 [1/2]

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 84 of file cdc_desc.h.

◆ MCU_ID2 [2/2]

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 93 of file cdc_msc_desc.h.

◆ MCU_ID3 [1/2]

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 85 of file cdc_desc.h.

◆ MCU_ID3 [2/2]

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 94 of file cdc_msc_desc.h.

◆ USBD_CDC_CONFIG_DESC_SIZE

#define USBD_CDC_CONFIG_DESC_SIZE 67

usb descriptor size define

Definition at line 63 of file cdc_desc.h.

◆ USBD_CDC_DESC_CONFIGURATION_STRING [1/2]

#define USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"

Definition at line 72 of file cdc_desc.h.

◆ USBD_CDC_DESC_CONFIGURATION_STRING [2/2]

#define USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"

Definition at line 73 of file cdc_msc_desc.h.

◆ USBD_CDC_DESC_INTERFACE_STRING [1/2]

#define USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"

Definition at line 73 of file cdc_desc.h.

◆ USBD_CDC_DESC_INTERFACE_STRING [2/2]

#define USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"

Definition at line 74 of file cdc_msc_desc.h.

◆ USBD_CDC_DESC_MANUFACTURER_STRING [1/2]

#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 70 of file cdc_desc.h.

◆ USBD_CDC_DESC_MANUFACTURER_STRING [2/2]

#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 71 of file cdc_msc_desc.h.

◆ USBD_CDC_DESC_PRODUCT_STRING [1/2]

#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "

Definition at line 71 of file cdc_desc.h.

◆ USBD_CDC_DESC_PRODUCT_STRING [2/2]

#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "

Definition at line 72 of file cdc_msc_desc.h.

◆ USBD_CDC_MSC_CONFIG_DESC_SIZE

#define USBD_CDC_MSC_CONFIG_DESC_SIZE 106

usb descriptor size define

Definition at line 64 of file cdc_msc_desc.h.

◆ USBD_CDC_MSC_PRODUCT_ID

#define USBD_CDC_MSC_PRODUCT_ID 0x5760

Definition at line 58 of file cdc_msc_desc.h.

◆ USBD_CDC_MSC_VENDOR_ID

#define USBD_CDC_MSC_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 57 of file cdc_msc_desc.h.

◆ USBD_CDC_PRODUCT_ID

#define USBD_CDC_PRODUCT_ID 0x5740

Definition at line 58 of file cdc_desc.h.

◆ USBD_CDC_SIZ_STRING_LANGID [1/2]

#define USBD_CDC_SIZ_STRING_LANGID 4

Definition at line 64 of file cdc_desc.h.

◆ USBD_CDC_SIZ_STRING_LANGID [2/2]

#define USBD_CDC_SIZ_STRING_LANGID 4

Definition at line 65 of file cdc_msc_desc.h.

◆ USBD_CDC_SIZ_STRING_SERIAL [1/2]

#define USBD_CDC_SIZ_STRING_SERIAL 0x1A

Definition at line 65 of file cdc_desc.h.

◆ USBD_CDC_SIZ_STRING_SERIAL [2/2]

#define USBD_CDC_SIZ_STRING_SERIAL 0x1A

Definition at line 66 of file cdc_msc_desc.h.

◆ USBD_CDC_VENDOR_ID

#define USBD_CDC_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 57 of file cdc_desc.h.

◆ VCPMSC_CDC_DATA_INTERFACE

#define VCPMSC_CDC_DATA_INTERFACE 0x02

Definition at line 86 of file cdc_msc_desc.h.

◆ VCPMSC_CDC_INTERFACE

#define VCPMSC_CDC_INTERFACE 0x01

Definition at line 85 of file cdc_msc_desc.h.

◆ VCPMSC_MSC_INTERFACE

#define VCPMSC_MSC_INTERFACE 0x00

usb interface define

Definition at line 84 of file cdc_msc_desc.h.


AT32F413 Firmwary Library: USB_cdc_keyboard_class

Modules
USB_cdc_keyboard_class
AT32F413_middlewares_usbd_class

usb device class composite cdc and keyboard More...

Modules

USB_cdc_keyboard_class_private_functions
USB_cdc_keyboard_class_definition
USB_cdc_class_exported_types
USB_cdc_keyboar_class_exported_functions

Detailed Description

usb device class composite cdc and keyboard


AT32F413 Firmwary Library: USB_cdc_keyboard_class_private_functions

Macros | Functions | Variables
USB_cdc_keyboard_class_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | keyboard_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

vcp_keyboard_type vcp_keyboard_struct
static const unsigned char _asciimap [128]
linecoding_type linecoding_vcpkybrd
usbd_class_handler cdc_keyboard_class_handler

Detailed Description

Macro Definition Documentation

◆ SHIFT

#define SHIFT 0x80

Definition at line 59 of file cdc_keyboard_class.c.

Function Documentation

◆ cdc_class_setup_handler()

static usb_sts_type cdc_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 322 of file cdc_keyboard_class.c.

Referenced by class_setup_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 267 of file cdc_keyboard_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 466 of file cdc_keyboard_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 452 of file cdc_keyboard_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 556 of file cdc_keyboard_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 493 of file cdc_keyboard_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 224 of file cdc_keyboard_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 521 of file cdc_keyboard_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 293 of file cdc_keyboard_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 541 of file cdc_keyboard_class.c.

◆ keyboard_class_setup_handler()

static usb_sts_type keyboard_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 378 of file cdc_keyboard_class.c.

Referenced by class_setup_handler().

◆ usb_vcp_cmd_process()

static void usb_vcp_cmd_process | ( | void * | udev,
 |  | uint8_t | cmd,
 |  | uint8_t * | buff,
 |  | uint16_t | len
 | ) |  |
static

usb device class request function

Parameters
udev | to the structure of usbd_core_type
cmd | request number
buff | request buffer
len | buffer length
Return values
none

Definition at line 644 of file cdc_keyboard_class.c.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ usb_vcpkybrd_class_send_report()

usb_sts_type usb_vcpkybrd_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 679 of file cdc_keyboard_class.c.

Referenced by usb_vcpkybrd_keyboard_send_char().

◆ usb_vcpkybrd_keyboard_send_char()

void usb_vcpkybrd_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb keyoard send char

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 697 of file cdc_keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_vcpkybrd_vcp_get_rxdata()

uint16_t usb_vcpkybrd_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 587 of file cdc_keyboard_class.c.

Referenced by main().

◆ usb_vcpkybrd_vcp_send_data()

error_status usb_vcpkybrd_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 618 of file cdc_keyboard_class.c.

Referenced by main().

Variable Documentation

◆ _asciimap

const unsigned char _asciimap[128]
static

Definition at line 60 of file cdc_keyboard_class.c.

Referenced by usb_vcpkybrd_keyboard_send_char().

◆ cdc_keyboard_class_handler

usbd_class_handler cdc_keyboard_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&vcp_keyboard_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_keyboard_class.c:541
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_keyboard_class.c:493
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_keyboard_class.c:267
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:293
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_keyboard_class.c:452
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_keyboard_class.c:466
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_keyboard_class.c:556
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_keyboard_class.c:224
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_keyboard_class.c:521
vcp_keyboard_struct
vcp_keyboard_type vcp_keyboard_struct
Definition: cdc_keyboard_class.c:57

Definition at line 205 of file cdc_keyboard_class.c.

Referenced by main().

◆ linecoding_vcpkybrd

linecoding_type linecoding_vcpkybrd
Initial value:
=
{
115200,
0x00,
0x00,
0x08
}

Definition at line 193 of file cdc_keyboard_class.c.

Referenced by class_init_handler().

◆ vcp_keyboard_struct

vcp_keyboard_type vcp_keyboard_struct

Definition at line 57 of file cdc_keyboard_class.c.


AT32F413 Firmwary Library: USB_cdc_keyboard_class_definition

Macros
USB_cdc_keyboard_class_definition
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class

Macros

#define | USBD_VCPKYBRD_CDC_INT_EPT 0x82
usb use endpoint define More...
#define | USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81
#define | USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01
#define | USBD_VCPKYBRD_HID_IN_EPT 0x83
#define | USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40
usb in and out max packet size define More...
#define | USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40
#define | USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08

Detailed Description

Macro Definition Documentation

◆ USBD_VCPKYBRD_CDC_BULK_IN_EPT

#define USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81

Definition at line 54 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_CDC_BULK_OUT_EPT

#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01

Definition at line 55 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_CDC_INT_EPT

#define USBD_VCPKYBRD_CDC_INT_EPT 0x82

usb use endpoint define

Definition at line 53 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_CMD_MAXPACKET_SIZE

#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08

Definition at line 63 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_HID_IN_EPT

#define USBD_VCPKYBRD_HID_IN_EPT 0x83

Definition at line 56 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_IN_MAXPACKET_SIZE

#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40

usb in and out max packet size define

Definition at line 61 of file cdc_keyboard_class.h.

◆ USBD_VCPKYBRD_OUT_MAXPACKET_SIZE

#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40

Definition at line 62 of file cdc_keyboard_class.h.


AT32F413 Firmwary Library: USB_cdc_keyboar_class_exported_functions

Functions | Variables
USB_cdc_keyboar_class_exported_functions
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_class

Functions

uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

usbd_class_handler cdc_keyboard_class_handler

Detailed Description

Function Documentation

◆ usb_vcpkybrd_class_send_report()

usb_sts_type usb_vcpkybrd_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 679 of file cdc_keyboard_class.c.

Referenced by usb_vcpkybrd_keyboard_send_char().

◆ usb_vcpkybrd_keyboard_send_char()

void usb_vcpkybrd_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb keyoard send char

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 697 of file cdc_keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_vcpkybrd_vcp_get_rxdata()

uint16_t usb_vcpkybrd_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 587 of file cdc_keyboard_class.c.

Referenced by main().

◆ usb_vcpkybrd_vcp_send_data()

error_status usb_vcpkybrd_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 618 of file cdc_keyboard_class.c.

Referenced by main().

Variable Documentation

◆ cdc_keyboard_class_handler

usbd_class_handler cdc_keyboard_class_handler
extern

Definition at line 205 of file cdc_keyboard_class.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_keyboard_desc

Modules | Variables
USB_cdc_keyboard_desc
AT32F413_middlewares_usbd_class

usb device cdc keyboard descriptor More...

Modules

USB_cdc_keyboard_desc_private_functions
USB_cdc_keyboard_desc_definition

Variables

usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure More...

Detailed Description

usb device cdc keyboard descriptor

Variable Documentation

◆ cdc_keyboard_desc_handler

usbd_desc_handler cdc_keyboard_desc_handler
extern

device descriptor handler structure

Definition at line 62 of file cdc_keyboard_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_keyboard_desc_private_functions

Functions | Variables
USB_cdc_keyboard_desc_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_vcpkybrd_hid_usb_desc [9]
usb hid descriptor More...
uint8_t | g_usbd_vcpkybrd_hid_report [63]
usb hid keyboard report descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 533 of file cdc_keyboard_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 455 of file cdc_keyboard_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 435 of file cdc_keyboard_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 521 of file cdc_keyboard_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 475 of file cdc_keyboard_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 486 of file cdc_keyboard_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 465 of file cdc_keyboard_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 498 of file cdc_keyboard_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 445 of file cdc_keyboard_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 510 of file cdc_keyboard_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 413 of file cdc_keyboard_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 387 of file cdc_keyboard_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 361 of file cdc_keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0xEF,
0x02,
0x01,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5750 ),
HBYTE( 0x5750 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid keyboard report descriptor

usb hid descriptor

usb configuration standard descriptor

Definition at line 82 of file cdc_keyboard_desc.c.

◆ cdc_keyboard_desc_handler

usbd_desc_handler cdc_keyboard_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_keyboard_desc.c:455
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_keyboard_desc.c:435
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_keyboard_desc.c:486
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_keyboard_desc.c:445
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_keyboard_desc.c:521
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_keyboard_desc.c:465
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_keyboard_desc.c:498
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_keyboard_desc.c:533
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_keyboard_desc.c:475
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_keyboard_desc.c:510

device descriptor handler structure

Definition at line 62 of file cdc_keyboard_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
108 ,
g_usbd_configuration
}

Definition at line 333 of file cdc_keyboard_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 326 of file cdc_keyboard_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 57 of file cdc_keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ g_usbd_vcpkybrd_hid_report

ALIGNED_HEAD uint8_t g_usbd_vcpkybrd_hid_report
extern

usb hid keyboard report descriptor

Definition at line 263 of file cdc_keyboard_desc.c.

Referenced by keyboard_class_setup_handler().

◆ g_vcpkybrd_hid_usb_desc

ALIGNED_HEAD uint8_t g_vcpkybrd_hid_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
HBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:263

usb hid descriptor

Definition at line 244 of file cdc_keyboard_desc.c.

Referenced by keyboard_class_setup_handler().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 340 of file cdc_keyboard_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 347 of file cdc_keyboard_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 353 of file cdc_keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_cdc_keyboard_desc_definition

Macros
USB_cdc_keyboard_desc_definition
AT32F413_middlewares_usbd_class » USB_cdc_keyboard_desc

Macros

#define | VCPKYBRD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_VCPKYBRD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_VCPKYBRD_PRODUCT_ID 0x5750
#define | USBD_VCPKYBRD_CONFIG_DESC_SIZE 108
usb descriptor size define More...
#define | USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63
#define | USBD_VCPKYBRD_SIZ_STRING_LANGID 4
#define | USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A
#define | USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"
#define | USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"
#define | USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"
#define | VCPKYBRD_HID_BINTERVAL_TIME 0x0A
usb endpoint interval define More...
#define | VCPKYBRD_CDC_INTERFACE 0x00
usb interface define More...
#define | VCPKYBRD_CDC_DATA_INTERFACE 0x01
#define | VCPKYBRD_KEYBOARD_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 93 of file cdc_keyboard_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 94 of file cdc_keyboard_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 95 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_CONFIG_DESC_SIZE

#define USBD_VCPKYBRD_CONFIG_DESC_SIZE 108

usb descriptor size define

Definition at line 65 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_CONFIGURATION_STRING

#define USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"

Definition at line 75 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_INTERFACE_STRING

#define USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"

Definition at line 76 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_MANUFACTURER_STRING

#define USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 73 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_DESC_PRODUCT_STRING

#define USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"

Definition at line 74 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_HID_SIZ_REPORT_DESC

#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63

Definition at line 66 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_PRODUCT_ID

#define USBD_VCPKYBRD_PRODUCT_ID 0x5750

Definition at line 59 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_SIZ_STRING_LANGID

#define USBD_VCPKYBRD_SIZ_STRING_LANGID 4

Definition at line 67 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_SIZ_STRING_SERIAL

#define USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A

Definition at line 68 of file cdc_keyboard_desc.h.

◆ USBD_VCPKYBRD_VENDOR_ID

#define USBD_VCPKYBRD_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 58 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_BCD_NUM

#define VCPKYBRD_BCD_NUM 0x0110

usb bcd number define

Definition at line 53 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_CDC_DATA_INTERFACE

#define VCPKYBRD_CDC_DATA_INTERFACE 0x01

Definition at line 87 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_CDC_INTERFACE

#define VCPKYBRD_CDC_INTERFACE 0x00

usb interface define

Definition at line 86 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_HID_BINTERVAL_TIME

#define VCPKYBRD_HID_BINTERVAL_TIME 0x0A

usb endpoint interval define

Definition at line 81 of file cdc_keyboard_desc.h.

◆ VCPKYBRD_KEYBOARD_INTERFACE

#define VCPKYBRD_KEYBOARD_INTERFACE 0x02

Definition at line 88 of file cdc_keyboard_desc.h.


AT32F413 Firmwary Library: USB_cdc_msc_class

Modules
USB_cdc_msc_class
AT32F413_middlewares_usbd_class

usb device class cdc msc demo More...

Modules

USB_cdc_msc_class_private_functions
USB_cdc_class_definition
USB_cdc_class_exported_types

Detailed Description

usb device class cdc msc demo


AT32F413 Firmwary Library: USB_cdc_msc_class_private_functions

Functions | Variables
USB_cdc_msc_class_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_msc_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static usb_sts_type | cdc_struct_init (cdc_msc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | msc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_msc_struct_type cdc_msc_struct
usbd_class_handler cdc_msc_class_handler

Detailed Description

Function Documentation

◆ cdc_class_setup_handler()

static usb_sts_type cdc_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 193 of file cdc_msc_class.c.

Referenced by class_setup_handler().

◆ cdc_struct_init()

static usb_sts_type cdc_struct_init ( cdc_msc_struct_type * pcdc )
static

usb device cdc init

Parameters
pcdc to the structure of cdc_struct
Return values
status of usb_sts_type

Definition at line 455 of file cdc_msc_class.c.

Referenced by class_init_handler().

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 127 of file cdc_msc_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 331 of file cdc_msc_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 317 of file cdc_msc_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 425 of file cdc_msc_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 353 of file cdc_msc_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 90 of file cdc_msc_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 381 of file cdc_msc_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 156 of file cdc_msc_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 410 of file cdc_msc_class.c.

◆ msc_class_setup_handler()

static usb_sts_type msc_class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

< get max lun

< bulk only mass storage reset

Definition at line 249 of file cdc_msc_class.c.

Referenced by class_setup_handler().

◆ usb_usart_config()

void usb_usart_config ( linecoding_type linecoding )

this function handles usart2 and linecoding config.

Parameters
linecoding linecoding value
Return values
none

< usart receive data buffer full interrupt

Definition at line 299 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by usb_vcp_cmd_process().

◆ usb_vcp_cmd_process()

static void usb_vcp_cmd_process | ( | void * | udev,
 |  | uint8_t | cmd,
 |  | uint8_t * | buff,
 |  | uint16_t | len
 | ) |  |
static

usb device function

Parameters
udev | to the structure of usbd_core_type
cmd | request number
buff | request buffer
len | buffer length
Return values
none

Definition at line 528 of file cdc_msc_class.c.

Referenced by cdc_class_setup_handler(), and class_ept0_rx_handler().

◆ usb_vcp_get_rxdata()

uint16_t usb_vcp_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 473 of file cdc_msc_class.c.

◆ usb_vcp_send_data()

error_status usb_vcp_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 503 of file cdc_msc_class.c.

Variable Documentation

◆ cdc_msc_class_handler

usbd_class_handler cdc_msc_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&cdc_msc_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: cdc_msc_class.c:410
cdc_msc_struct
cdc_msc_struct_type cdc_msc_struct
Definition: cdc_msc_class.c:69
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: cdc_msc_class.c:353
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_msc_class.c:127
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:156
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: cdc_msc_class.c:317
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: cdc_msc_class.c:331
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: cdc_msc_class.c:425
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: cdc_msc_class.c:90
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: cdc_msc_class.c:381

Definition at line 72 of file cdc_msc_class.c.

Referenced by main().

◆ cdc_msc_struct

cdc_msc_struct_type cdc_msc_struct

Definition at line 69 of file cdc_msc_class.c.

Referenced by msc_class_setup_handler().

◆ linecoding

linecoding_type linecoding
Initial value:
=
{
115200,
0,
0,
8
}

Definition at line 60 of file cdc_msc_class.c.

Referenced by cdc_struct_init(), and usb_usart_config().


AT32F413 Firmwary Library: USB_cdc_msc_desc

Modules | Variables
USB_cdc_msc_desc
AT32F413_middlewares_usbd_class

usb device cdc msc descriptor More...

Modules

USB_cdc_msc_desc_private_functions
USB_cdc_desc_definition

Variables

usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...

Detailed Description

usb device cdc msc descriptor

Variable Documentation

◆ cdc_msc_desc_handler

usbd_desc_handler cdc_msc_desc_handler
extern

device descriptor handler structure

Definition at line 66 of file cdc_msc_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_cdc_msc_desc_private_functions

Macros | Functions | Variables
USB_cdc_msc_desc_private_functions
AT32F413_middlewares_usbd_class » USB_cdc_msc_desc

Macros

#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Macro Definition Documentation

◆ USB_INTERFACE_ASSOCIATION_TYPE

#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B

Definition at line 45 of file cdc_msc_desc.c.

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 481 of file cdc_msc_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 403 of file cdc_msc_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 383 of file cdc_msc_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 469 of file cdc_msc_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 423 of file cdc_msc_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 434 of file cdc_msc_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 413 of file cdc_msc_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 446 of file cdc_msc_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 393 of file cdc_msc_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 458 of file cdc_msc_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 361 of file cdc_msc_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 335 of file cdc_msc_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 309 of file cdc_msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0xEF,
0x02,
0x01,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5760 ),
HBYTE( 0x5760 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 86 of file cdc_msc_desc.c.

◆ cdc_msc_desc_handler

usbd_desc_handler cdc_msc_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_msc_desc.c:403
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_msc_desc.c:383
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_msc_desc.c:434
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_msc_desc.c:393
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_msc_desc.c:469
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_msc_desc.c:413
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_msc_desc.c:446
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_msc_desc.c:481
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_msc_desc.c:423
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_msc_desc.c:458

device descriptor handler structure

Definition at line 66 of file cdc_msc_desc.c.

Referenced by main().

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
106 ,
g_usbd_configuration
}

Definition at line 281 of file cdc_msc_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 274 of file cdc_msc_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 61 of file cdc_msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 288 of file cdc_msc_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 295 of file cdc_msc_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 301 of file cdc_msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_msc_bot_scsi

Modules
USB_msc_bot_scsi
AT32F413_middlewares_usbd_class

usb device class mass storage demo More...

Modules

USB_msc_bot_functions
USB_msc_bot_scsi_definition

Detailed Description

usb device class mass storage demo


AT32F413 Firmwary Library: USB_msc_bot_functions

Functions | Variables
USB_msc_bot_functions
AT32F413_middlewares_usbd_class » USB_msc_bot_scsi

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *udev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *udev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...

Variables

ALIGNED_HEAD uint8_t page00_inquiry_data[] | ALIGNED_TAIL
ALIGNED_HEAD uint8_t page00_inquiry_data[] | ALIGNED_TAIL

Detailed Description

Function Documentation

◆ bot_cbw_decode()

void bot_cbw_decode ( void * udev )

bulk-only cbw decode

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 197 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_dataout_handler().

◆ bot_scsi_allow_medium_removal()

usb_sts_type bot_scsi_allow_medium_removal | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command meidum removal

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 424 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_capacity()

usb_sts_type bot_scsi_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 478 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_check_address()

usb_sts_type bot_scsi_check_address | ( | void * | udev,
 |  | uint8_t | lun,
 |  | uint32_t | blk_offset,
 |  | uint32_t | blk_count
 | ) |  |

check address

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
blk_offset | blk offset address
blk_count | blk number
Return values
usb_sts_type

Definition at line 304 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_read10(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_clear_feature()

void bot_scsi_clear_feature | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

clear feature

Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
etp_num | endpoint number
Return values
status of usb_sts_type

Definition at line 730 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_setup_handler(), and msc_class_setup_handler().

◆ bot_scsi_cmd_process()

usb_sts_type bot_scsi_cmd_process ( void * udev )

bulk-only transport scsi command process

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type
Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 750 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_datain_handler(), and bot_scsi_dataout_handler().

◆ bot_scsi_datain_handler()

void bot_scsi_datain_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data in handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 144 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_in_handler().

◆ bot_scsi_dataout_handler()

void bot_scsi_dataout_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |

bulk-only transport data out handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none
Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 173 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_out_handler().

◆ bot_scsi_format_capacity()

usb_sts_type bot_scsi_format_capacity | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command format capacity

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 505 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_init()

void bot_scsi_init ( void * udev )

initialize bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 104 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_init_handler().

◆ bot_scsi_inquiry()

usb_sts_type bot_scsi_inquiry | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command inquiry

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 369 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense10()

usb_sts_type bot_scsi_mode_sense10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 458 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_mode_sense6()

usb_sts_type bot_scsi_mode_sense6 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command mode sense6

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 438 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_read10()

usb_sts_type bot_scsi_read10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command read10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 599 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_request_sense()

usb_sts_type bot_scsi_request_sense | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command request sense

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 540 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_reset()

void bot_scsi_reset ( void * udev )

reset bulk-only transport and scsi

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 126 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by class_setup_handler(), and msc_class_setup_handler().

◆ bot_scsi_send_csw()

void bot_scsi_send_csw | ( | void * | udev,
 |  | uint8_t | status
 | ) |  |

send command status

Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none
Parameters
udev | to the structure of usbd_core_type
status | csw status
Return values
none

Definition at line 265 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_clear_feature(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), and bot_scsi_write10().

◆ bot_scsi_send_data()

void bot_scsi_send_data | ( | void * | udev,
 |  | uint8_t * | buffer,
 |  | uint32_t | len
 | ) |  |

send bot data

Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none
Parameters
udev | to the structure of usbd_core_type
buffer | data buffer
len | data len
Return values
none

Definition at line 244 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_sense_code()

void bot_scsi_sense_code | ( | void * | udev,
 |  | uint8_t | sense_key,
 |  | uint8_t | asc
 | ) |  |

send scsi sense code

Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none
Parameters
udev | to the structure of usbd_core_type
sense_key | sense key
asc | asc
Return values
none

Definition at line 289 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode(), bot_scsi_check_address(), bot_scsi_cmd_process(), bot_scsi_read10(), bot_scsi_test_unit(), bot_scsi_verify(), and bot_scsi_write10().

◆ bot_scsi_stall()

void bot_scsi_stall ( void * udev )

bot endpoint stall

Parameters
udev to the structure of usbd_core_type
Return values
none
Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 321 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_cbw_decode().

◆ bot_scsi_start_stop()

usb_sts_type bot_scsi_start_stop | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command start stop

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 410 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_test_unit()

usb_sts_type bot_scsi_test_unit | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command test unit

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 347 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_verify()

usb_sts_type bot_scsi_verify | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command verify

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 571 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

◆ bot_scsi_write10()

usb_sts_type bot_scsi_write10 | ( | void * | udev,
 |  | uint8_t | lun
 | ) |  |

bulk-only transport scsi command write10

Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type
Parameters
udev | to the structure of usbd_core_type
lun | logical units number
Return values
status of usb_sts_type

Definition at line 660 of file composite_cdc_msc/msc_bot_scsi.c.

Referenced by bot_scsi_cmd_process().

Variable Documentation

◆ ALIGNED_TAIL [1/2]

ALIGNED_HEAD sense_type sense_data ALIGNED_TAIL
Initial value:
= {
0x00,
0x00,
0x00,
0x00,
0x00,
}

Definition at line 46 of file composite_cdc_msc/msc_bot_scsi.c.

◆ ALIGNED_TAIL [2/2]

ALIGNED_HEAD uint8_t mode_sense10_data [8] ALIGNED_TAIL
Initial value:
= {
0x00,
0x00,
0x00,
0x00,
0x00,
}

Definition at line 46 of file msc/msc_bot_scsi.c.


AT32F413 Firmwary Library: USB_custom_hid_class

Modules
USB_custom_hid_class
AT32F413_middlewares_usbd_class

usb device custom hid demo More...

Modules

USB_custom_hid_class_private_functions
USB_custom_hid_class_endpoint_definition
USB_custom_hid_class_request_code_definition
USB_custom_hid_class_exported_functions

Detailed Description

usb device custom hid demo


AT32F413 Firmwary Library: USB_custom_hid_class_private_functions

Functions | Variables
USB_custom_hid_class_private_functions
AT32F413_middlewares_usbd_class » USB_custom_hid_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device class report function More...
usb_sts_type | custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

custom_hid_type custom_hid_struct
usbd_class_handler custom_hid_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 104 of file custom_hid_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 212 of file custom_hid_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 198 of file custom_hid_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 290 of file custom_hid_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 235 of file custom_hid_class.c.

◆ class_init_handler()

usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 76 of file custom_hid_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 252 of file custom_hid_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 124 of file custom_hid_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 275 of file custom_hid_class.c.

◆ custom_hid_class_send_report()

usb_sts_type custom_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 322 of file custom_hid_class.c.

Referenced by main().

◆ usb_hid_buf_process()

static void usb_hid_buf_process | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |
static

usb device class report function

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
none

Definition at line 340 of file custom_hid_class.c.

Referenced by class_ept0_rx_handler(), and class_out_handler().

Variable Documentation

◆ custom_hid_class_handler

usbd_class_handler custom_hid_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&custom_hid_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: custom_hid_class.c:275
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: custom_hid_class.c:235
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: custom_hid_class.c:104
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: custom_hid_class.c:124
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: custom_hid_class.c:198
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: custom_hid_class.c:212
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: custom_hid_class.c:290
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: custom_hid_class.c:252
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: custom_hid_class.c:76
custom_hid_struct
custom_hid_type custom_hid_struct
Definition: custom_hid_class.c:54

Definition at line 57 of file custom_hid_class.c.

Referenced by main().

◆ custom_hid_struct

custom_hid_type custom_hid_struct

Definition at line 54 of file custom_hid_class.c.


AT32F413 Firmwary Library: USB_custom_hid_class_endpoint_definition

Macros
USB_custom_hid_class_endpoint_definition
AT32F413_middlewares_usbd_class » USB_custom_hid_class

Macros

#define | USBD_CUSTOM_HID_IN_EPT 0x81
usb custom hid use endpoint define More...
#define | USBD_CUSTOM_HID_OUT_EPT 0x01
#define | USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40

Detailed Description

Macro Definition Documentation

◆ USBD_CUSTOM_HID_IN_EPT

#define USBD_CUSTOM_HID_IN_EPT 0x81

usb custom hid use endpoint define

Definition at line 53 of file custom_hid_class.h.

◆ USBD_CUSTOM_HID_OUT_EPT

#define USBD_CUSTOM_HID_OUT_EPT 0x01

Definition at line 54 of file custom_hid_class.h.

◆ USBD_CUSTOM_IN_MAXPACKET_SIZE

#define USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40

usb custom hid in and out max packet size define

Definition at line 59 of file custom_hid_class.h.

◆ USBD_CUSTOM_OUT_MAXPACKET_SIZE

#define USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40

Definition at line 60 of file custom_hid_class.h.


AT32F413 Firmwary Library: USB_custom_hid_class_request_code_definition

Data Structures
USB_custom_hid_class_request_code_definition
AT32F413_middlewares_usbd_class » USB_custom_hid_class

Data Structures

struct custom_hid_type

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: custom_hid_type Struct Reference

Data Fields
custom_hid_type Struct Reference
AT32F413_middlewares_usbd_class » USB_custom_hid_class » USB_custom_hid_class_request_code_definition

#include <custom_hid_class.h>

Data Fields

uint8_t | g_rxhid_buff [0x40]
uint8_t | g_txhid_buff [0x40]
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_state
uint8_t | hid_set_report [64]

Detailed Description

Definition at line 70 of file custom_hid_class.h.

Field Documentation

◆ alt_setting

uint32_t custom_hid_type::alt_setting

Definition at line 77 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ g_rxhid_buff

uint8_t custom_hid_type::g_rxhid_buff[0x40]

Definition at line 72 of file custom_hid_class.h.

Referenced by class_init_handler(), class_out_handler(), and usb_hid_buf_process().

◆ g_txhid_buff

uint8_t custom_hid_type::g_txhid_buff[0x40]

Definition at line 73 of file custom_hid_class.h.

Referenced by usb_hid_buf_process().

◆ hid_protocol

uint32_t custom_hid_type::hid_protocol

Definition at line 75 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t custom_hid_type::hid_set_idle

Definition at line 76 of file custom_hid_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t custom_hid_type::hid_set_report[64]

Definition at line 79 of file custom_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ hid_state

uint8_t custom_hid_type::hid_state

Definition at line 78 of file custom_hid_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

The documentation for this struct was generated from the following file:
  • custom_hid_class.h


AT32F413 Firmwary Library: USB_custom_hid_class_exported_functions

Functions | Variables
USB_custom_hid_class_exported_functions
AT32F413_middlewares_usbd_class » USB_custom_hid_class

Functions

usb_sts_type custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler custom_hid_class_handler

Detailed Description

Function Documentation

◆ custom_hid_class_send_report()

usb_sts_type custom_hid_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 322 of file custom_hid_class.c.

Referenced by main().

Variable Documentation

◆ custom_hid_class_handler

usbd_class_handler custom_hid_class_handler
extern

Definition at line 57 of file custom_hid_class.c.

Referenced by main().


AT32F413 Firmwary Library: USB_custom_hid_desc

Modules | Variables
USB_custom_hid_desc
AT32F413_middlewares_usbd_class

usb device custom_hid descriptor More...

Modules

USB_custom_hid_desc_private_functions
USB_custom_hid_desc_definition

Variables

usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure More...

Detailed Description

usb device custom_hid descriptor

Variable Documentation

◆ custom_hid_desc_handler

usbd_desc_handler custom_hid_desc_handler
extern

custom hid device descriptor handler structure

Definition at line 62 of file custom_hid_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_custom_hid_desc_private_functions

Functions | Variables
USB_custom_hid_desc_private_functions
AT32F413_middlewares_usbd_class » USB_custom_hid_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_usbd_custom_hid_report [126]
usb hid report descriptor More...
uint8_t | g_custom_hid_usb_desc [9]
usb hid descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 513 of file custom_hid_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 435 of file custom_hid_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 415 of file custom_hid_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 501 of file custom_hid_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 455 of file custom_hid_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 466 of file custom_hid_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 445 of file custom_hid_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 478 of file custom_hid_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 425 of file custom_hid_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 490 of file custom_hid_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 393 of file custom_hid_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 367 of file custom_hid_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 341 of file custom_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5745 ),
HBYTE( 0x5745 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb hid report descriptor

usb configuration standard descriptor

Definition at line 82 of file custom_hid_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
41 ,
g_usbd_configuration
}

Definition at line 313 of file custom_hid_desc.c.

Referenced by get_device_configuration().

◆ custom_hid_desc_handler

usbd_desc_handler custom_hid_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: custom_hid_desc.c:435
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: custom_hid_desc.c:415
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: custom_hid_desc.c:466
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: custom_hid_desc.c:425
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: custom_hid_desc.c:501
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: custom_hid_desc.c:445
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: custom_hid_desc.c:478
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: custom_hid_desc.c:513
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: custom_hid_desc.c:455
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: custom_hid_desc.c:490

custom hid device descriptor handler structure

Definition at line 62 of file custom_hid_desc.c.

Referenced by main().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 306 of file custom_hid_desc.c.

Referenced by get_device_descriptor().

◆ g_custom_hid_usb_desc

ALIGNED_HEAD uint8_t g_custom_hid_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_custom_hid_report)),
HBYTE(sizeof(g_usbd_custom_hid_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:166

usb hid descriptor

Definition at line 264 of file custom_hid_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_custom_hid_report

ALIGNED_HEAD uint8_t g_usbd_custom_hid_report
extern

usb hid report descriptor

Definition at line 166 of file custom_hid_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 57 of file custom_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 320 of file custom_hid_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 327 of file custom_hid_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 333 of file custom_hid_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_custom_hid_desc_definition

Macros
USB_custom_hid_desc_definition
AT32F413_middlewares_usbd_class » USB_custom_hid_desc

Macros

#define | CUSHID_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CUSHID_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CUSHID_PRODUCT_ID 0x5745
#define | USBD_CUSHID_CONFIG_DESC_SIZE 41
usb descriptor size define More...
#define | USBD_CUSHID_SIZ_REPORT_DESC 126
#define | USBD_CUSHID_SIZ_STRING_LANGID 4
#define | USBD_CUSHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"
#define | USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"
#define | USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"
#define | CUSHID_BINTERVAL_TIME 0x0A
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ CUSHID_BCD_NUM

#define CUSHID_BCD_NUM 0x0110

usb bcd number define

Definition at line 54 of file custom_hid_desc.h.

◆ CUSHID_BINTERVAL_TIME

#define CUSHID_BINTERVAL_TIME 0x0A

Definition at line 78 of file custom_hid_desc.h.

◆ HID_REPORT_ID_1

#define HID_REPORT_ID_1 0x01

usb hid report id define

usb hid report id define

Definition at line 86 of file custom_hid_desc.h.

◆ HID_REPORT_ID_2

#define HID_REPORT_ID_2 0x02

Definition at line 87 of file custom_hid_desc.h.

◆ HID_REPORT_ID_3

#define HID_REPORT_ID_3 0x03

Definition at line 88 of file custom_hid_desc.h.

◆ HID_REPORT_ID_4

#define HID_REPORT_ID_4 0x04

Definition at line 89 of file custom_hid_desc.h.

◆ HID_REPORT_ID_5

#define HID_REPORT_ID_5 0x05

Definition at line 90 of file custom_hid_desc.h.

◆ HID_REPORT_ID_6

#define HID_REPORT_ID_6 0xF0

Definition at line 91 of file custom_hid_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 96 of file custom_hid_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 97 of file custom_hid_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 98 of file custom_hid_desc.h.

◆ USBD_CUSHID_CONFIG_DESC_SIZE

#define USBD_CUSHID_CONFIG_DESC_SIZE 41

usb descriptor size define

Definition at line 65 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_CONFIGURATION_STRING

#define USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"

Definition at line 75 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_INTERFACE_STRING

#define USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"

Definition at line 76 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_MANUFACTURER_STRING

#define USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 73 of file custom_hid_desc.h.

◆ USBD_CUSHID_DESC_PRODUCT_STRING

#define USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"

Definition at line 74 of file custom_hid_desc.h.

◆ USBD_CUSHID_PRODUCT_ID

#define USBD_CUSHID_PRODUCT_ID 0x5745

Definition at line 60 of file custom_hid_desc.h.

◆ USBD_CUSHID_SIZ_REPORT_DESC

#define USBD_CUSHID_SIZ_REPORT_DESC 126

Definition at line 66 of file custom_hid_desc.h.

◆ USBD_CUSHID_SIZ_STRING_LANGID

#define USBD_CUSHID_SIZ_STRING_LANGID 4

Definition at line 67 of file custom_hid_desc.h.

◆ USBD_CUSHID_SIZ_STRING_SERIAL

#define USBD_CUSHID_SIZ_STRING_SERIAL 0x1A

Definition at line 68 of file custom_hid_desc.h.

◆ USBD_CUSHID_VENDOR_ID

#define USBD_CUSHID_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 59 of file custom_hid_desc.h.


AT32F413 Firmwary Library: USB_hid_iap_class

Modules
USB_hid_iap_class
AT32F413_middlewares_usbd_class

usb device class hid iap demo More...

Modules

USB_hid_iap_class_private_functions
USB_hid_iap_class_definition

Detailed Description

usb device class hid iap demo


AT32F413 Firmwary Library: USB_hid_iap_class_private_functions

Functions | Variables
USB_hid_iap_class_private_functions
AT32F413_middlewares_usbd_class » USB_hid_iap_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

iap_info_type iap_info
usbd_class_handler hid_iap_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 98 of file hid_iap_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 206 of file hid_iap_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 192 of file hid_iap_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 284 of file hid_iap_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 228 of file hid_iap_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 76 of file hid_iap_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 246 of file hid_iap_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 118 of file hid_iap_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 269 of file hid_iap_class.c.

◆ usb_iap_class_send_report()

usb_sts_type usb_iap_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 316 of file hid_iap_class.c.

Referenced by usbd_hid_iap_process().

Variable Documentation

◆ hid_iap_class_handler

usbd_class_handler hid_iap_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&iap_info
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: hid_iap_class.c:269
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: hid_iap_class.c:228
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: hid_iap_class.c:98
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: hid_iap_class.c:118
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: hid_iap_class.c:192
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: hid_iap_class.c:206
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: hid_iap_class.c:284
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: hid_iap_class.c:76
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: hid_iap_class.c:246

Definition at line 57 of file hid_iap_class.c.

Referenced by main().

◆ iap_info

iap_info_type iap_info

Definition at line 54 of file hid_iap_class.c.

Referenced by app_loop(), iap_address(), iap_clear_upgrade_flag(), iap_crc(), iap_data_write(), iap_erase_sector(), iap_finish(), iap_get(), iap_get_upgrade_flag(), iap_idle(), iap_init(), iap_jump(), iap_loop(), iap_respond(), iap_set_upgrade_flag(), iap_start(), usbd_hid_iap_in_complete(), and usbd_hid_iap_process().


AT32F413 Firmwary Library: USB_hid_iap_class_definition

Data Structures | Macros | Enumerations | Functions | Variables
USB_hid_iap_class_definition
AT32F413_middlewares_usbd_class » USB_hid_iap_class

Data Structures

struct iap_info_type

Macros

#define | USBD_HIDIAP_IN_EPT 0x81
#define | USBD_HIDIAP_OUT_EPT 0x01
#define | USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40
#define | USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40
#define | FLASH_SIZE_REG() ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/
#define | KB_TO_B(kb) ((kb) << 10)
#define | SECTOR_SIZE_1K 0x400
#define | SECTOR_SIZE_2K 0x800
#define | SECTOR_SIZE_4K 0x1000
#define | IAP_CMD_IDLE 0x5AA0
iap command More...
#define | IAP_CMD_START 0x5AA1
#define | IAP_CMD_ADDR 0x5AA2
#define | IAP_CMD_DATA 0x5AA3
#define | IAP_CMD_FINISH 0x5AA4
#define | IAP_CMD_CRC 0x5AA5
#define | IAP_CMD_JMP 0x5AA6
#define | IAP_CMD_GET 0x5AA7
#define | HID_IAP_BUFFER_LEN 1024
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | CONVERT_ENDIAN(dwValue)
#define | IAP_ACK 0xFF00
#define | IAP_NACK 0x00FF

Enumerations

enum iap_result_type { IAP_SUCCESS , IAP_WAIT , IAP_FAILED }
enum iap_machine_state_type {
IAP_STS_IDLE , IAP_STS_START , IAP_STS_ADDR , IAP_STS_DATA ,
IAP_STS_FINISH , IAP_STS_CRC , IAP_STS_JMP_WAIT , IAP_STS_JMP
}

Functions

usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *report, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...

Variables

usbd_class_handler hid_iap_class_handler
iap_info_type iap_info

Detailed Description

Macro Definition Documentation

◆ CONVERT_ENDIAN

#define CONVERT_ENDIAN ( dwValue )
Value:
((dwValue >> 24) | ((dwValue >> 8) & 0xFF00) | \
((dwValue << 8) & 0xFF0000) | (dwValue << 24) )

Definition at line 79 of file hid_iap_class.h.

◆ FLASH_SIZE_REG

#define FLASH_SIZE_REG ( ) ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/

Definition at line 58 of file hid_iap_class.h.

◆ HID_IAP_BUFFER_LEN

#define HID_IAP_BUFFER_LEN 1024

Definition at line 77 of file hid_iap_class.h.

◆ IAP_ACK

#define IAP_ACK 0xFF00

Definition at line 82 of file hid_iap_class.h.

◆ IAP_CMD_ADDR

#define IAP_CMD_ADDR 0x5AA2

Definition at line 70 of file hid_iap_class.h.

◆ IAP_CMD_CRC

#define IAP_CMD_CRC 0x5AA5

Definition at line 73 of file hid_iap_class.h.

◆ IAP_CMD_DATA

#define IAP_CMD_DATA 0x5AA3

Definition at line 71 of file hid_iap_class.h.

◆ IAP_CMD_FINISH

#define IAP_CMD_FINISH 0x5AA4

Definition at line 72 of file hid_iap_class.h.

◆ IAP_CMD_GET

#define IAP_CMD_GET 0x5AA7

Definition at line 75 of file hid_iap_class.h.

◆ IAP_CMD_IDLE

#define IAP_CMD_IDLE 0x5AA0

iap command

Definition at line 68 of file hid_iap_class.h.

◆ IAP_CMD_JMP

#define IAP_CMD_JMP 0x5AA6

Definition at line 74 of file hid_iap_class.h.

◆ IAP_CMD_START

#define IAP_CMD_START 0x5AA1

Definition at line 69 of file hid_iap_class.h.

◆ IAP_NACK

#define IAP_NACK 0x00FF

Definition at line 83 of file hid_iap_class.h.

◆ IAP_UPGRADE_COMPLETE_FLAG

#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38

Definition at line 78 of file hid_iap_class.h.

◆ KB_TO_B

#define KB_TO_B ( kb ) ((kb) << 10)

Definition at line 59 of file hid_iap_class.h.

◆ SECTOR_SIZE_1K

#define SECTOR_SIZE_1K 0x400

Definition at line 61 of file hid_iap_class.h.

◆ SECTOR_SIZE_2K

#define SECTOR_SIZE_2K 0x800

Definition at line 62 of file hid_iap_class.h.

◆ SECTOR_SIZE_4K

#define SECTOR_SIZE_4K 0x1000

Definition at line 63 of file hid_iap_class.h.

◆ USBD_HIDIAP_IN_EPT

#define USBD_HIDIAP_IN_EPT 0x81

Definition at line 52 of file hid_iap_class.h.

◆ USBD_HIDIAP_IN_MAXPACKET_SIZE

#define USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40

Definition at line 55 of file hid_iap_class.h.

◆ USBD_HIDIAP_OUT_EPT

#define USBD_HIDIAP_OUT_EPT 0x01

Definition at line 53 of file hid_iap_class.h.

◆ USBD_HIDIAP_OUT_MAXPACKET_SIZE

#define USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40

Definition at line 56 of file hid_iap_class.h.

Enumeration Type Documentation

◆ iap_machine_state_type

enum iap_machine_state_type
Enumerator
IAP_STS_IDLE
IAP_STS_START
IAP_STS_ADDR
IAP_STS_DATA
IAP_STS_FINISH
IAP_STS_CRC
IAP_STS_JMP_WAIT
IAP_STS_JMP

Definition at line 92 of file hid_iap_class.h.

◆ iap_result_type

enum iap_result_type
Enumerator
IAP_SUCCESS
IAP_WAIT
IAP_FAILED

Definition at line 85 of file hid_iap_class.h.

Function Documentation

◆ usb_iap_class_send_report()

usb_sts_type usb_iap_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 316 of file hid_iap_class.c.

Referenced by usbd_hid_iap_process().

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 240 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by class_in_handler().

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 194 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by class_out_handler().

Variable Documentation

◆ hid_iap_class_handler

usbd_class_handler hid_iap_class_handler
extern

Definition at line 57 of file hid_iap_class.c.

Referenced by main().

◆ iap_info

iap_info_type iap_info
extern

Definition at line 54 of file hid_iap_class.c.

Referenced by app_loop(), iap_address(), iap_clear_upgrade_flag(), iap_crc(), iap_data_write(), iap_erase_sector(), iap_finish(), iap_get(), iap_get_upgrade_flag(), iap_idle(), iap_init(), iap_jump(), iap_loop(), iap_respond(), iap_set_upgrade_flag(), iap_start(), usbd_hid_iap_in_complete(), and usbd_hid_iap_process().


AT32F413 Firmwary Library: iap_info_type Struct Reference

Data Fields
iap_info_type Struct Reference
AT32F413_middlewares_usbd_class » USB_hid_iap_class » USB_hid_iap_class_definition

#include <hid_iap_class.h>

Data Fields

uint8_t | iap_fifo [1024]
uint8_t | iap_rx [0x40]
uint8_t | iap_tx [0x40]
uint32_t | fifo_length
uint32_t | tx_length
uint32_t | app_address
uint32_t | iap_address
uint32_t | flag_address
uint32_t | flash_start_address
uint32_t | flash_end_address
uint32_t | sector_size
uint32_t | flash_size
uint32_t | respond_flag
uint8_t | g_rxhid_buff [0x40]
uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint32_t | hid_state
uint8_t | hid_set_report [64]
iap_machine_state_type state

Detailed Description

Definition at line 104 of file hid_iap_class.h.

Field Documentation

◆ alt_setting

uint32_t iap_info_type::alt_setting

Definition at line 129 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ app_address

uint32_t iap_info_type::app_address

Definition at line 114 of file hid_iap_class.h.

Referenced by iap_get(), iap_init(), and iap_loop().

◆ fifo_length

uint32_t iap_info_type::fifo_length

Definition at line 111 of file hid_iap_class.h.

Referenced by iap_data_write(), and iap_init().

◆ flag_address

uint32_t iap_info_type::flag_address

Definition at line 116 of file hid_iap_class.h.

Referenced by iap_clear_upgrade_flag(), iap_get_upgrade_flag(), iap_init(), and iap_set_upgrade_flag().

◆ flash_end_address

uint32_t iap_info_type::flash_end_address

Definition at line 119 of file hid_iap_class.h.

Referenced by iap_address(), and iap_init().

◆ flash_size

uint32_t iap_info_type::flash_size

Definition at line 122 of file hid_iap_class.h.

Referenced by iap_init().

◆ flash_start_address

uint32_t iap_info_type::flash_start_address

Definition at line 118 of file hid_iap_class.h.

Referenced by iap_init().

◆ g_rxhid_buff

uint8_t iap_info_type::g_rxhid_buff[0x40]

Definition at line 126 of file hid_iap_class.h.

Referenced by class_init_handler(), and class_out_handler().

◆ hid_protocol

uint32_t iap_info_type::hid_protocol

Definition at line 127 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t iap_info_type::hid_set_idle

Definition at line 128 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t iap_info_type::hid_set_report[64]

Definition at line 131 of file hid_iap_class.h.

Referenced by class_setup_handler().

◆ hid_state

uint32_t iap_info_type::hid_state

Definition at line 130 of file hid_iap_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ iap_address

uint32_t iap_info_type::iap_address

Definition at line 115 of file hid_iap_class.h.

Referenced by iap_address(), iap_data_write(), and iap_init().

◆ iap_fifo

uint8_t iap_info_type::iap_fifo[1024]

Definition at line 107 of file hid_iap_class.h.

Referenced by iap_data_write().

◆ iap_rx

uint8_t iap_info_type::iap_rx[0x40]

Definition at line 108 of file hid_iap_class.h.

◆ iap_tx

uint8_t iap_info_type::iap_tx[0x40]

Definition at line 109 of file hid_iap_class.h.

Referenced by iap_address(), iap_crc(), iap_data_write(), iap_finish(), iap_get(), iap_idle(), iap_jump(), iap_start(), and usbd_hid_iap_process().

◆ respond_flag

uint32_t iap_info_type::respond_flag

Definition at line 124 of file hid_iap_class.h.

Referenced by iap_respond(), and usbd_hid_iap_process().

◆ sector_size

uint32_t iap_info_type::sector_size

Definition at line 121 of file hid_iap_class.h.

Referenced by iap_erase_sector(), and iap_init().

◆ state

iap_machine_state_type iap_info_type::state

Definition at line 133 of file hid_iap_class.h.

Referenced by app_loop(), iap_address(), iap_data_write(), iap_finish(), iap_idle(), iap_jump(), iap_loop(), iap_start(), and usbd_hid_iap_in_complete().

◆ tx_length

uint32_t iap_info_type::tx_length

Definition at line 112 of file hid_iap_class.h.

The documentation for this struct was generated from the following file:
  • hid_iap_class.h


AT32F413 Firmwary Library: USB_hid_iap_desc

Modules
USB_hid_iap_desc
AT32F413_middlewares_usbd_class

usb device hid_iap descriptor More...

Modules

USB_hid_iap_desc_private_functions
USB_hid_iap_desc_definition

Detailed Description

usb device hid_iap descriptor


AT32F413 Firmwary Library: USB_hid_iap_desc_private_functions

Functions | Variables
USB_hid_iap_desc_private_functions
AT32F413_middlewares_usbd_class » USB_hid_iap_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 449 of file hid_iap_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 371 of file hid_iap_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 351 of file hid_iap_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 437 of file hid_iap_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 391 of file hid_iap_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 402 of file hid_iap_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 381 of file hid_iap_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 414 of file hid_iap_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 361 of file hid_iap_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 426 of file hid_iap_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 329 of file hid_iap_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 303 of file hid_iap_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 277 of file hid_iap_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0xAF01 ),
HBYTE( 0xAF01 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb hid report descriptor

usb configuration standard descriptor

Definition at line 85 of file hid_iap_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
41 ,
g_usbd_configuration
}

Definition at line 249 of file hid_iap_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 242 of file hid_iap_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 60 of file hid_iap_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ hid_iap_desc_handler

usbd_desc_handler hid_iap_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: hid_iap_desc.c:371
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: hid_iap_desc.c:351
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: hid_iap_desc.c:402
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: hid_iap_desc.c:361
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: hid_iap_desc.c:437
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: hid_iap_desc.c:381
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: hid_iap_desc.c:414
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: hid_iap_desc.c:449
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: hid_iap_desc.c:391
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: hid_iap_desc.c:426

hid device descriptor handler structure

Definition at line 65 of file hid_iap_desc.c.

Referenced by main().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 256 of file hid_iap_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 263 of file hid_iap_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 269 of file hid_iap_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_hid_iap_desc_definition

Macros | Variables
USB_hid_iap_desc_definition
AT32F413_middlewares_usbd_class » USB_hid_iap_desc

Macros

#define | HIDIAP_BCD_NUM 0x0110
#define | USBD_HIDIAP_VENDOR_ID 0x2E3C
#define | USBD_HIDIAP_PRODUCT_ID 0xAF01
#define | USBD_HIDIAP_CONFIG_DESC_SIZE 41
#define | USBD_HIDIAP_SIZ_REPORT_DESC 32
#define | USBD_HIDIAP_SIZ_STRING_LANGID 4
#define | USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A
#define | USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"
#define | USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"
#define | USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"
#define | HIDIAP_BINTERVAL_TIME 0x01
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_hidiap_report [32]
usb hid report descriptor More...
uint8_t | g_hidiap_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ HIDIAP_BCD_NUM

#define HIDIAP_BCD_NUM 0x0110

Definition at line 51 of file hid_iap_desc.h.

◆ HIDIAP_BINTERVAL_TIME

#define HIDIAP_BINTERVAL_TIME 0x01

Definition at line 66 of file hid_iap_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 68 of file hid_iap_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 69 of file hid_iap_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 70 of file hid_iap_desc.h.

◆ USBD_HIDIAP_CONFIG_DESC_SIZE

#define USBD_HIDIAP_CONFIG_DESC_SIZE 41

Definition at line 56 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_CONFIGURATION_STRING

#define USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"

Definition at line 63 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_INTERFACE_STRING

#define USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"

Definition at line 64 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_MANUFACTURER_STRING

#define USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"

Definition at line 61 of file hid_iap_desc.h.

◆ USBD_HIDIAP_DESC_PRODUCT_STRING

#define USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"

Definition at line 62 of file hid_iap_desc.h.

◆ USBD_HIDIAP_PRODUCT_ID

#define USBD_HIDIAP_PRODUCT_ID 0xAF01

Definition at line 54 of file hid_iap_desc.h.

◆ USBD_HIDIAP_SIZ_REPORT_DESC

#define USBD_HIDIAP_SIZ_REPORT_DESC 32

Definition at line 57 of file hid_iap_desc.h.

◆ USBD_HIDIAP_SIZ_STRING_LANGID

#define USBD_HIDIAP_SIZ_STRING_LANGID 4

Definition at line 58 of file hid_iap_desc.h.

◆ USBD_HIDIAP_SIZ_STRING_SERIAL

#define USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A

Definition at line 59 of file hid_iap_desc.h.

◆ USBD_HIDIAP_VENDOR_ID

#define USBD_HIDIAP_VENDOR_ID 0x2E3C

Definition at line 53 of file hid_iap_desc.h.

Variable Documentation

◆ g_hidiap_usb_desc

ALIGNED_HEAD uint8_t g_hidiap_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_hidiap_report)),
HBYTE(sizeof(g_usbd_hidiap_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:169
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260

usb hid descriptor

Definition at line 200 of file hid_iap_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_hidiap_report

ALIGNED_HEAD uint8_t g_usbd_hidiap_report
extern
Initial value:
=
{
0x06, 0xFF, 0x00,
0x09, 0x01,
0xa1, 0x01,
0x15, 0x00,
0x25, 0xFF,
0x75, 0x08,
0x95, 0x40,
0x09, 0x01,
0x81, 0x02,
0x95, 0x40,
0x09, 0x01,
0x91, 0x02,
0x95, 0x01,
0x09, 0x01,
0xB1, 0x02,
0xC0
}

usb hid report descriptor

Definition at line 169 of file hid_iap_desc.c.

Referenced by class_setup_handler().

◆ hid_iap_desc_handler

usbd_desc_handler hid_iap_desc_handler
extern

hid device descriptor handler structure

Definition at line 65 of file hid_iap_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_keyboard_class

Modules | Data Structures
USB_keyboard_class
AT32F413_middlewares_usbd_class

usb device keyboard demo More...

Modules

USB_keyboard_class_private_functions
USB_keyboard_class_endpoint_definition
USB_hid_class_exported_functions

Data Structures

struct keyboard_type

Detailed Description

usb device keyboard demo


AT32F413 Firmwary Library: USB_keyboard_class_private_functions

Macros | Functions | Variables
USB_keyboard_class_private_functions
AT32F413_middlewares_usbd_class » USB_keyboard_class

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...

Variables

keyboard_type keyboard_struct
static const unsigned char _asciimap [128]
usbd_class_handler keyboard_class_handler

Detailed Description

Macro Definition Documentation

◆ SHIFT

#define SHIFT 0x80

Definition at line 54 of file keyboard_class.c.

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 231 of file keyboard_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 336 of file keyboard_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 322 of file keyboard_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 405 of file keyboard_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 358 of file keyboard_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 208 of file keyboard_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 378 of file keyboard_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 248 of file keyboard_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 390 of file keyboard_class.c.

◆ usb_hid_keyboard_send_char()

void usb_hid_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 457 of file keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_keyboard_class_send_report()

usb_sts_type usb_keyboard_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 439 of file keyboard_class.c.

Referenced by usb_hid_keyboard_send_char().

Variable Documentation

◆ _asciimap

const unsigned char _asciimap[128]
static

Definition at line 55 of file keyboard_class.c.

Referenced by usb_hid_keyboard_send_char().

◆ keyboard_class_handler

usbd_class_handler keyboard_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&keyboard_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: keyboard_class.c:390
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: keyboard_class.c:358
keyboard_struct
keyboard_type keyboard_struct
Definition: keyboard_class.c:53
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: keyboard_class.c:231
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: keyboard_class.c:248
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: keyboard_class.c:322
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: keyboard_class.c:336
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: keyboard_class.c:405
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: keyboard_class.c:208
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: keyboard_class.c:378

Definition at line 189 of file keyboard_class.c.

Referenced by main().

◆ keyboard_struct

keyboard_type keyboard_struct

Definition at line 53 of file keyboard_class.c.


AT32F413 Firmwary Library: USB_keyboard_class_endpoint_definition

Macros
USB_keyboard_class_endpoint_definition
AT32F413_middlewares_usbd_class » USB_keyboard_class

Macros

#define | USBD_KEYBOARD_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...
#define | USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40

Detailed Description

Macro Definition Documentation

◆ USBD_KEYBOARD_IN_EPT

#define USBD_KEYBOARD_IN_EPT 0x81

usb hid use endpoint define

Definition at line 53 of file keyboard_class.h.

◆ USBD_KEYBOARD_IN_MAXPACKET_SIZE

#define USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40

usb hid in and out max packet size define

Definition at line 58 of file keyboard_class.h.

◆ USBD_KEYBOARD_OUT_MAXPACKET_SIZE

#define USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40

Definition at line 59 of file keyboard_class.h.


AT32F413 Firmwary Library: USB_hid_class_exported_functions

Functions | Variables
USB_hid_class_exported_functions
AT32F413_middlewares_usbd_class » USB_keyboard_class | AT32F413_middlewares_usbd_class » USB_mouse_class

Functions

usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...
usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

usbd_class_handler keyboard_class_handler
usbd_class_handler mouse_class_handler

Detailed Description

Function Documentation

◆ usb_hid_keyboard_send_char()

void usb_hid_keyboard_send_char | ( | void * | udev,
 |  | uint8_t | ascii_code
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 457 of file keyboard_class.c.

Referenced by keyboard_send_string().

◆ usb_hid_mouse_send()

void usb_hid_mouse_send | ( | void * | udev,
 |  | uint8_t | op
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 319 of file mouse_class.c.

Referenced by main().

◆ usb_keyboard_class_send_report()

usb_sts_type usb_keyboard_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 439 of file keyboard_class.c.

Referenced by usb_hid_keyboard_send_char().

◆ usb_mouse_class_send_report()

usb_sts_type usb_mouse_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 302 of file mouse_class.c.

Referenced by usb_hid_mouse_send().

Variable Documentation

◆ keyboard_class_handler

usbd_class_handler keyboard_class_handler
extern

Definition at line 189 of file keyboard_class.c.

Referenced by main().

◆ mouse_class_handler

usbd_class_handler mouse_class_handler
extern

Definition at line 56 of file mouse_class.c.

Referenced by main().


AT32F413 Firmwary Library: keyboard_type Struct Reference

Data Fields
keyboard_type Struct Reference
AT32F413_middlewares_usbd_class » USB_keyboard_class

#include <keyboard_class.h>

Data Fields

uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_set_report [64]
uint8_t | keyboard_buf [8]
__IO uint8_t | hid_suspend_flag
__IO uint8_t | g_u8tx_completed
uint8_t | hid_state
uint8_t | temp

Detailed Description

Definition at line 66 of file keyboard_class.h.

Field Documentation

◆ alt_setting

uint32_t keyboard_type::alt_setting

Definition at line 70 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ g_u8tx_completed

__IO uint8_t keyboard_type::g_u8tx_completed

Definition at line 75 of file keyboard_class.h.

Referenced by class_in_handler(), class_init_handler(), and keyboard_send_string().

◆ hid_protocol

uint32_t keyboard_type::hid_protocol

Definition at line 68 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t keyboard_type::hid_set_idle

Definition at line 69 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t keyboard_type::hid_set_report[64]

Definition at line 71 of file keyboard_class.h.

Referenced by class_setup_handler().

◆ hid_state

uint8_t keyboard_type::hid_state

Definition at line 76 of file keyboard_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ hid_suspend_flag

__IO uint8_t keyboard_type::hid_suspend_flag

Definition at line 74 of file keyboard_class.h.

Referenced by class_event_handler().

◆ keyboard_buf

uint8_t keyboard_type::keyboard_buf[8]

Definition at line 72 of file keyboard_class.h.

Referenced by usb_hid_keyboard_send_char().

◆ temp

uint8_t keyboard_type::temp

Definition at line 77 of file keyboard_class.h.

Referenced by usb_hid_keyboard_send_char().

The documentation for this struct was generated from the following file:
  • keyboard_class.h


AT32F413 Firmwary Library: USB_keyboard_desc

Modules | Variables
USB_keyboard_desc
AT32F413_middlewares_usbd_class

usb device keyboard descriptor More...

Modules

USB_keyboard_desc_private_functions
USB_keyboard_desc_definition

Variables

usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure More...

Detailed Description

usb device keyboard descriptor

Variable Documentation

◆ keyboard_desc_handler

usbd_desc_handler keyboard_desc_handler
extern

keyboard device descriptor handler structure

Definition at line 63 of file keyboard_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_keyboard_desc_private_functions

Functions | Variables
USB_keyboard_desc_private_functions
AT32F413_middlewares_usbd_class » USB_keyboard_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_usbd_keyboard_report [63]
usb mouse report descriptor More...
uint8_t | g_keyboard_usb_desc [9]
usb hid descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 450 of file keyboard_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 372 of file keyboard_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 352 of file keyboard_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 438 of file keyboard_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 392 of file keyboard_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 403 of file keyboard_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 382 of file keyboard_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 415 of file keyboard_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 362 of file keyboard_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 427 of file keyboard_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 330 of file keyboard_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 304 of file keyboard_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 278 of file keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x6040 ),
HBYTE( 0x6040 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb mouse report descriptor

usb configuration standard descriptor

Definition at line 83 of file keyboard_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
34 ,
g_usbd_configuration
}

Definition at line 250 of file keyboard_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 243 of file keyboard_desc.c.

Referenced by get_device_descriptor().

◆ g_keyboard_usb_desc

ALIGNED_HEAD uint8_t g_keyboard_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_keyboard_report)),
HBYTE(sizeof(g_usbd_keyboard_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:159

usb hid descriptor

Definition at line 201 of file keyboard_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 58 of file keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ g_usbd_keyboard_report

ALIGNED_HEAD uint8_t g_usbd_keyboard_report
extern

usb mouse report descriptor

Definition at line 159 of file keyboard_desc.c.

Referenced by class_setup_handler().

◆ keyboard_desc_handler

usbd_desc_handler keyboard_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: keyboard_desc.c:372
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: keyboard_desc.c:352
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: keyboard_desc.c:403
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: keyboard_desc.c:362
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: keyboard_desc.c:438
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: keyboard_desc.c:382
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: keyboard_desc.c:415
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: keyboard_desc.c:450
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: keyboard_desc.c:392
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: keyboard_desc.c:427

keyboard device descriptor handler structure

Definition at line 63 of file keyboard_desc.c.

Referenced by main().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 257 of file keyboard_desc.c.

Referenced by get_device_lang_id().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 264 of file keyboard_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 270 of file keyboard_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_keyboard_desc_definition

Macros
USB_keyboard_desc_definition
AT32F413_middlewares_usbd_class » USB_keyboard_desc

Macros

#define | KEYBOARD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_KEYBOARD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_KEYBOARD_PRODUCT_ID 0x6040
#define | USBD_KEYBOARD_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_KEYBOARD_SIZ_REPORT_DESC 63
#define | USBD_KEYBOARD_SIZ_STRING_LANGID 4
#define | USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A
#define | USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"
#define | USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"
#define | USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"
#define | KEYBOARD_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ KEYBOARD_BCD_NUM

#define KEYBOARD_BCD_NUM 0x0110

usb bcd number define

Definition at line 53 of file keyboard_desc.h.

◆ KEYBOARD_BINTERVAL_TIME

#define KEYBOARD_BINTERVAL_TIME 0x0A

usb hid endpoint interval define

Definition at line 80 of file keyboard_desc.h.

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 85 of file keyboard_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 86 of file keyboard_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 87 of file keyboard_desc.h.

◆ USBD_KEYBOARD_CONFIG_DESC_SIZE

#define USBD_KEYBOARD_CONFIG_DESC_SIZE 34

usb descriptor size define

Definition at line 64 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_CONFIGURATION_STRING

#define USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"

Definition at line 74 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_INTERFACE_STRING

#define USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"

Definition at line 75 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_MANUFACTURER_STRING

#define USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 72 of file keyboard_desc.h.

◆ USBD_KEYBOARD_DESC_PRODUCT_STRING

#define USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"

Definition at line 73 of file keyboard_desc.h.

◆ USBD_KEYBOARD_PRODUCT_ID

#define USBD_KEYBOARD_PRODUCT_ID 0x6040

Definition at line 59 of file keyboard_desc.h.

◆ USBD_KEYBOARD_SIZ_REPORT_DESC

#define USBD_KEYBOARD_SIZ_REPORT_DESC 63

Definition at line 65 of file keyboard_desc.h.

◆ USBD_KEYBOARD_SIZ_STRING_LANGID

#define USBD_KEYBOARD_SIZ_STRING_LANGID 4

Definition at line 66 of file keyboard_desc.h.

◆ USBD_KEYBOARD_SIZ_STRING_SERIAL

#define USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A

Definition at line 67 of file keyboard_desc.h.

◆ USBD_KEYBOARD_VENDOR_ID

#define USBD_KEYBOARD_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 58 of file keyboard_desc.h.


AT32F413 Firmwary Library: USB_mouse_class

Modules
USB_mouse_class
AT32F413_middlewares_usbd_class

usb device mouse demo More...

Modules

USB_mouse_class_private_functions
USB_mouse_class_endpoint_definition
USB_mouse_class_request_code_definition
USB_hid_class_exported_functions

Detailed Description

usb device mouse demo


AT32F413 Firmwary Library: USB_mouse_class_private_functions

Functions | Variables
USB_mouse_class_private_functions
AT32F413_middlewares_usbd_class » USB_mouse_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

mouse_type mouse_struct
usbd_class_handler mouse_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 96 of file mouse_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device class endpoint 0 out status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 202 of file mouse_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device class endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 188 of file mouse_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device class event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 268 of file mouse_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 224 of file mouse_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 75 of file mouse_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device class endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 241 of file mouse_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 113 of file mouse_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device class sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 253 of file mouse_class.c.

◆ usb_hid_mouse_send()

void usb_hid_mouse_send | ( | void * | udev,
 |  | uint8_t | op
 | ) |  |

usb device class report function

Parameters
udev | to the structure of usbd_core_type
op | operation
Return values
none

Definition at line 319 of file mouse_class.c.

Referenced by main().

◆ usb_mouse_class_send_report()

usb_sts_type usb_mouse_class_send_report | ( | void * | udev,
 |  | uint8_t * | report,
 |  | uint16_t | len
 | ) |  |

usb device class send report

Parameters
udev | to the structure of usbd_core_type
report | report buffer
len | report length
Return values
status of usb_sts_type

Definition at line 302 of file mouse_class.c.

Referenced by usb_hid_mouse_send().

Variable Documentation

◆ mouse_class_handler

usbd_class_handler mouse_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&mouse_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: mouse_class.c:253
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: mouse_class.c:224
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: mouse_class.c:96
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: mouse_class.c:113
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: mouse_class.c:188
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: mouse_class.c:202
mouse_struct
mouse_type mouse_struct
Definition: mouse_class.c:53
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: mouse_class.c:268
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: mouse_class.c:75
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: mouse_class.c:241

Definition at line 56 of file mouse_class.c.

Referenced by main().

◆ mouse_struct

mouse_type mouse_struct

Definition at line 53 of file mouse_class.c.


AT32F413 Firmwary Library: USB_mouse_class_endpoint_definition

Macros
USB_mouse_class_endpoint_definition
AT32F413_middlewares_usbd_class » USB_mouse_class

Macros

#define | USBD_MOUSE_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_MOUSE_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...

Detailed Description

Macro Definition Documentation

◆ USBD_MOUSE_IN_EPT

#define USBD_MOUSE_IN_EPT 0x81

usb hid use endpoint define

Definition at line 53 of file mouse_class.h.

◆ USBD_MOUSE_IN_MAXPACKET_SIZE

#define USBD_MOUSE_IN_MAXPACKET_SIZE 0x40

usb hid in and out max packet size define

Definition at line 58 of file mouse_class.h.


AT32F413 Firmwary Library: USB_mouse_class_request_code_definition

Data Structures | Macros
USB_mouse_class_request_code_definition
AT32F413_middlewares_usbd_class » USB_mouse_class

Data Structures

struct mouse_type

Macros

#define | MOVE_STEP 20
usb hid mouse operation More...
#define | BUTTON_RELEASE 0
#define | LEFT_BUTTON 1
#define | RIGHT_BUTTON 2
#define | LEFT_MOVE 3
#define | RIGHT_MOVE 4
#define | UP_MOVE 5
#define | DOWN_MOVE 6

Detailed Description

Macro Definition Documentation

◆ BUTTON_RELEASE

#define BUTTON_RELEASE 0

Definition at line 74 of file mouse_class.h.

◆ DOWN_MOVE

#define DOWN_MOVE 6

Definition at line 80 of file mouse_class.h.

◆ LEFT_BUTTON

#define LEFT_BUTTON 1

Definition at line 75 of file mouse_class.h.

◆ LEFT_MOVE

#define LEFT_MOVE 3

Definition at line 77 of file mouse_class.h.

◆ MOVE_STEP

#define MOVE_STEP 20

usb hid mouse operation

Definition at line 72 of file mouse_class.h.

◆ RIGHT_BUTTON

#define RIGHT_BUTTON 2

Definition at line 76 of file mouse_class.h.

◆ RIGHT_MOVE

#define RIGHT_MOVE 4

Definition at line 78 of file mouse_class.h.

◆ UP_MOVE

#define UP_MOVE 5

Definition at line 79 of file mouse_class.h.


AT32F413 Firmwary Library: mouse_type Struct Reference

Data Fields
mouse_type Struct Reference
AT32F413_middlewares_usbd_class » USB_mouse_class » USB_mouse_class_request_code_definition

#include <mouse_class.h>

Data Fields

uint32_t | hid_protocol
uint32_t | hid_set_idle
uint32_t | alt_setting
uint8_t | hid_set_report [64]
uint8_t | mouse_buffer [4]
uint8_t | hid_state
__IO uint8_t | hid_suspend_flag

Detailed Description

Definition at line 82 of file mouse_class.h.

Field Documentation

◆ alt_setting

uint32_t mouse_type::alt_setting

Definition at line 86 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_protocol

uint32_t mouse_type::hid_protocol

Definition at line 84 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_set_idle

uint32_t mouse_type::hid_set_idle

Definition at line 85 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_set_report

uint8_t mouse_type::hid_set_report[64]

Definition at line 88 of file mouse_class.h.

Referenced by class_setup_handler().

◆ hid_state

uint8_t mouse_type::hid_state

Definition at line 90 of file mouse_class.h.

Referenced by class_ept0_rx_handler(), and class_setup_handler().

◆ hid_suspend_flag

__IO uint8_t mouse_type::hid_suspend_flag

Definition at line 91 of file mouse_class.h.

Referenced by class_event_handler().

◆ mouse_buffer

uint8_t mouse_type::mouse_buffer[4]

Definition at line 89 of file mouse_class.h.

Referenced by usb_hid_mouse_send().

The documentation for this struct was generated from the following file:
  • mouse_class.h


AT32F413 Firmwary Library: USB_mouse_desc

Modules | Variables
USB_mouse_desc
AT32F413_middlewares_usbd_class

usb device mouse descriptor More...

Modules

USB_mouse_desc_private_functions
USB_mouse_desc_definition

Variables

usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure More...

Detailed Description

usb device mouse descriptor

Variable Documentation

◆ mouse_desc_handler

usbd_desc_handler mouse_desc_handler
extern

mouse device descriptor handler structure

Definition at line 63 of file mouse_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_mouse_desc_private_functions

Functions | Variables
USB_mouse_desc_private_functions
AT32F413_middlewares_usbd_class » USB_mouse_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc
uint8_t | g_usbd_mouse_report [74]
usb mouse report descriptor More...
uint8_t | g_mouse_usb_desc [9]
usb hid descriptor More...

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 464 of file mouse_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 386 of file mouse_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 366 of file mouse_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 452 of file mouse_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 406 of file mouse_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 417 of file mouse_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 396 of file mouse_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 429 of file mouse_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 376 of file mouse_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 441 of file mouse_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 344 of file mouse_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 318 of file mouse_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 292 of file mouse_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5710 ),
HBYTE( 0x5710 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb hid descriptor

usb mouse report descriptor

usb configuration standard descriptor

Definition at line 83 of file mouse_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
34 ,
g_usbd_configuration
}

Definition at line 264 of file mouse_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 257 of file mouse_desc.c.

Referenced by get_device_descriptor().

◆ g_mouse_usb_desc

ALIGNED_HEAD uint8_t g_mouse_usb_desc
extern
Initial value:
=
{
0x09,
HID_CLASS_DESC_HID,
LBYTE( 0x0110 ),
HBYTE( 0x0110 ),
0x00,
0x01,
HID_CLASS_DESC_REPORT,
LBYTE(sizeof(g_usbd_mouse_report)),
HBYTE(sizeof(g_usbd_mouse_report)),
}
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:159

usb hid descriptor

Definition at line 215 of file mouse_desc.c.

Referenced by class_setup_handler().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 58 of file mouse_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ g_usbd_mouse_report

ALIGNED_HEAD uint8_t g_usbd_mouse_report
extern

usb mouse report descriptor

Definition at line 159 of file mouse_desc.c.

Referenced by class_setup_handler().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 271 of file mouse_desc.c.

Referenced by get_device_lang_id().

◆ mouse_desc_handler

usbd_desc_handler mouse_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: mouse_desc.c:386
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: mouse_desc.c:366
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: mouse_desc.c:417
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: mouse_desc.c:376
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: mouse_desc.c:452
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: mouse_desc.c:396
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: mouse_desc.c:429
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: mouse_desc.c:464
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: mouse_desc.c:406
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: mouse_desc.c:441

mouse device descriptor handler structure

Definition at line 63 of file mouse_desc.c.

Referenced by main().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 278 of file mouse_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 284 of file mouse_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_mouse_desc_definition

Macros
USB_mouse_desc_definition
AT32F413_middlewares_usbd_class » USB_mouse_desc

Macros

#define | MOUSE_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_MOUSE_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_MOUSE_PRODUCT_ID 0x5710
#define | USBD_MOUSE_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_MOUSE_SIZ_REPORT_DESC 74
#define | USBD_MOUSE_SIZ_STRING_LANGID 4
#define | USBD_MOUSE_SIZ_STRING_SERIAL 0x1A
#define | USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"
#define | USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"
#define | USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"
#define | MOUSE_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

usb mcu id address deine

Definition at line 85 of file mouse_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 86 of file mouse_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 87 of file mouse_desc.h.

◆ MOUSE_BCD_NUM

#define MOUSE_BCD_NUM 0x0110

usb bcd number define

Definition at line 53 of file mouse_desc.h.

◆ MOUSE_BINTERVAL_TIME

#define MOUSE_BINTERVAL_TIME 0x0A

usb hid endpoint interval define

Definition at line 80 of file mouse_desc.h.

◆ USBD_MOUSE_CONFIG_DESC_SIZE

#define USBD_MOUSE_CONFIG_DESC_SIZE 34

usb descriptor size define

Definition at line 64 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_CONFIGURATION_STRING

#define USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"

Definition at line 74 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_INTERFACE_STRING

#define USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"

Definition at line 75 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_MANUFACTURER_STRING

#define USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"

usb string define(vendor, product configuration, interface)

Definition at line 72 of file mouse_desc.h.

◆ USBD_MOUSE_DESC_PRODUCT_STRING

#define USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"

Definition at line 73 of file mouse_desc.h.

◆ USBD_MOUSE_PRODUCT_ID

#define USBD_MOUSE_PRODUCT_ID 0x5710

Definition at line 59 of file mouse_desc.h.

◆ USBD_MOUSE_SIZ_REPORT_DESC

#define USBD_MOUSE_SIZ_REPORT_DESC 74

Definition at line 65 of file mouse_desc.h.

◆ USBD_MOUSE_SIZ_STRING_LANGID

#define USBD_MOUSE_SIZ_STRING_LANGID 4

Definition at line 66 of file mouse_desc.h.

◆ USBD_MOUSE_SIZ_STRING_SERIAL

#define USBD_MOUSE_SIZ_STRING_SERIAL 0x1A

Definition at line 67 of file mouse_desc.h.

◆ USBD_MOUSE_VENDOR_ID

#define USBD_MOUSE_VENDOR_ID 0x2E3C

usb vendor id and product id define

Definition at line 58 of file mouse_desc.h.


AT32F413 Firmwary Library: USB_msc_class

Modules
USB_msc_class
AT32F413_middlewares_usbd_class

usb device class msc demo More...

Modules

USB_msc_class_private_functions
USB_msc_class_definition

Detailed Description

usb device class msc demo


AT32F413 Firmwary Library: USB_msc_class_private_functions

Functions | Variables
USB_msc_class_private_functions
AT32F413_middlewares_usbd_class » USB_msc_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...

Variables

msc_type msc_struct
usbd_class_handler msc_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 97 of file msc_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 199 of file msc_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 185 of file msc_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 255 of file msc_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 214 of file msc_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 76 of file msc_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 228 of file msc_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

< get max lun

< bulk only mass storage reset

Definition at line 117 of file msc_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 240 of file msc_class.c.

Variable Documentation

◆ msc_class_handler

usbd_class_handler msc_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&msc_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: msc_class.c:240
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: msc_class.c:214
msc_struct
msc_type msc_struct
Definition: msc_class.c:54
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: msc_class.c:97
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: msc_class.c:117
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: msc_class.c:185
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: msc_class.c:199
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: msc_class.c:255
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: msc_class.c:76
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: msc_class.c:228

Definition at line 57 of file msc_class.c.

Referenced by main().

◆ msc_struct

msc_type msc_struct

Definition at line 54 of file msc_class.c.


AT32F413 Firmwary Library: USB_msc_class_definition

Macros | Variables
USB_msc_class_definition
AT32F413_middlewares_usbd_class » USB_msc_class

Macros

#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_IN_MAXPACKET_SIZE 0x40
#define | USBD_OUT_MAXPACKET_SIZE 0x40

Variables

usbd_class_handler msc_class_handler

Detailed Description

Macro Definition Documentation

◆ USBD_IN_MAXPACKET_SIZE

#define USBD_IN_MAXPACKET_SIZE 0x40

Definition at line 52 of file msc_class.h.

◆ USBD_MSC_BULK_IN_EPT

#define USBD_MSC_BULK_IN_EPT 0x81

Definition at line 49 of file msc_class.h.

◆ USBD_MSC_BULK_OUT_EPT

#define USBD_MSC_BULK_OUT_EPT 0x01

Definition at line 50 of file msc_class.h.

◆ USBD_OUT_MAXPACKET_SIZE

#define USBD_OUT_MAXPACKET_SIZE 0x40

Definition at line 53 of file msc_class.h.

Variable Documentation

◆ msc_class_handler

usbd_class_handler msc_class_handler
extern

Definition at line 57 of file msc_class.c.

Referenced by main().


AT32F413 Firmwary Library: USB_msc_desc

Modules
USB_msc_desc
AT32F413_middlewares_usbd_class

usb device msc descriptor More...

Modules

USB_msc_desc_private_functions
USB_msc_desc_definition

Detailed Description

usb device msc descriptor


AT32F413 Firmwary Library: USB_msc_desc_private_functions

Functions | Variables
USB_msc_desc_private_functions
AT32F413_middlewares_usbd_class » USB_msc_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler msc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 387 of file msc_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 309 of file msc_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 289 of file msc_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 375 of file msc_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 329 of file msc_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 340 of file msc_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 319 of file msc_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 352 of file msc_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 299 of file msc_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 364 of file msc_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 267 of file msc_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 241 of file msc_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 215 of file msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x5720 ),
HBYTE( 0x5720 ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 84 of file msc_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
32 ,
g_usbd_configuration
}

Definition at line 187 of file msc_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 180 of file msc_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 59 of file msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 194 of file msc_desc.c.

Referenced by get_device_lang_id().

◆ msc_desc_handler

usbd_desc_handler msc_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: msc_desc.c:309
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: msc_desc.c:289
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: msc_desc.c:340
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: msc_desc.c:299
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: msc_desc.c:375
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: msc_desc.c:319
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: msc_desc.c:352
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: msc_desc.c:387
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: msc_desc.c:329
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: msc_desc.c:364

device descriptor handler structure

Definition at line 64 of file msc_desc.c.

Referenced by main().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 201 of file msc_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 207 of file msc_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_msc_desc_definition

Macros | Variables
USB_msc_desc_definition
AT32F413_middlewares_usbd_class » USB_msc_desc

Macros

#define | MSC_BCD_NUM 0x0110
#define | USBD_MSC_VENDOR_ID 0x2E3C
#define | USBD_MSC_PRODUCT_ID 0x5720
#define | USBD_MSC_CONFIG_DESC_SIZE 32
#define | USBD_MSC_SIZ_STRING_LANGID 4
#define | USBD_MSC_SIZ_STRING_SERIAL 0x1A
#define | USBD_MSC_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"
#define | USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"
#define | USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler msc_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 64 of file msc_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 65 of file msc_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 66 of file msc_desc.h.

◆ MSC_BCD_NUM

#define MSC_BCD_NUM 0x0110

Definition at line 50 of file msc_desc.h.

◆ USBD_MSC_CONFIG_DESC_SIZE

#define USBD_MSC_CONFIG_DESC_SIZE 32

Definition at line 55 of file msc_desc.h.

◆ USBD_MSC_DESC_CONFIGURATION_STRING

#define USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"

Definition at line 61 of file msc_desc.h.

◆ USBD_MSC_DESC_INTERFACE_STRING

#define USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"

Definition at line 62 of file msc_desc.h.

◆ USBD_MSC_DESC_MANUFACTURER_STRING

#define USBD_MSC_DESC_MANUFACTURER_STRING "Artery"

Definition at line 59 of file msc_desc.h.

◆ USBD_MSC_DESC_PRODUCT_STRING

#define USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"

Definition at line 60 of file msc_desc.h.

◆ USBD_MSC_PRODUCT_ID

#define USBD_MSC_PRODUCT_ID 0x5720

Definition at line 53 of file msc_desc.h.

◆ USBD_MSC_SIZ_STRING_LANGID

#define USBD_MSC_SIZ_STRING_LANGID 4

Definition at line 56 of file msc_desc.h.

◆ USBD_MSC_SIZ_STRING_SERIAL

#define USBD_MSC_SIZ_STRING_SERIAL 0x1A

Definition at line 57 of file msc_desc.h.

◆ USBD_MSC_VENDOR_ID

#define USBD_MSC_VENDOR_ID 0x2E3C

Definition at line 52 of file msc_desc.h.

Variable Documentation

◆ msc_desc_handler

usbd_desc_handler msc_desc_handler
extern

device descriptor handler structure

Definition at line 64 of file msc_desc.c.

Referenced by main().


AT32F413 Firmwary Library: USB_printer_class

Modules
USB_printer_class
AT32F413_middlewares_usbd_class

usb device class printer demo More...

Modules

USB_printer_class_private_functions
USB_printer_class_definition

Detailed Description

usb device class printer demo


AT32F413 Firmwary Library: USB_printer_class_private_functions

Functions | Variables
USB_printer_class_private_functions
AT32F413_middlewares_usbd_class » USB_printer_class

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

static ALIGNED_HEAD uint8_t printer_device_id[24] ALIGNED_TAIL
printer_type printer_struct
usbd_class_handler printer_class_handler

Detailed Description

Function Documentation

◆ class_clear_handler()

static usb_sts_type class_clear_handler ( void * udev )
static

clear endpoint or other state

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 109 of file printer_class.c.

◆ class_ept0_rx_handler()

static usb_sts_type class_ept0_rx_handler ( void * udev )
static

usb device endpoint 0 out status stage complete

Parameters
udev usb device core handler type
Return values
status of usb_sts_type

Definition at line 198 of file printer_class.c.

◆ class_ept0_tx_handler()

static usb_sts_type class_ept0_tx_handler ( void * udev )
static

usb device endpoint 0 in status stage complete

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 184 of file printer_class.c.

◆ class_event_handler()

static usb_sts_type class_event_handler | ( | void * | udev,
 |  | usbd_event_type | event
 | ) |  |
static

usb device event handler

Parameters
udev | to the structure of usbd_core_type
event | usb device event
Return values
status of usb_sts_type

Definition at line 267 of file printer_class.c.

◆ class_in_handler()

static usb_sts_type class_in_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device transmision complete handler

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 213 of file printer_class.c.

◆ class_init_handler()

static usb_sts_type class_init_handler ( void * udev )
static

initialize usb custom hid endpoint

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 83 of file printer_class.c.

◆ class_out_handler()

static usb_sts_type class_out_handler | ( | void * | udev,
 |  | uint8_t | ept_num
 | ) |  |
static

usb device endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
status of usb_sts_type

Definition at line 233 of file printer_class.c.

◆ class_setup_handler()

static usb_sts_type class_setup_handler | ( | void * | udev,
 |  | usb_setup_type * | setup
 | ) |  |
static

usb device class setup request handler

Parameters
udev | to the structure of usbd_core_type
setup | setup packet
Return values
status of usb_sts_type

Definition at line 129 of file printer_class.c.

◆ class_sof_handler()

static usb_sts_type class_sof_handler ( void * udev )
static

usb device sof handler

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 252 of file printer_class.c.

◆ usb_printer_get_rxdata()

uint16_t usb_printer_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 299 of file printer_class.c.

◆ usb_printer_send_data()

error_status usb_printer_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 329 of file printer_class.c.

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t printer_device_id [ 24 ] ALIGNED_TAIL
static
Initial value:
=
{
0x00, 0x16,
'M', 'F', 'G',':','A','r','t','e', 'r', 'y' ,' ',
'C','M', 'D', ':', 'E', 'S', 'C', 'P', 'O', 'S',' ',
}

Definition at line 53 of file printer_class.c.

◆ printer_class_handler

usbd_class_handler printer_class_handler
Initial value:
=
{
class_init_handler,
class_clear_handler,
class_setup_handler,
class_ept0_tx_handler,
class_ept0_rx_handler,
class_in_handler,
class_out_handler,
class_sof_handler,
class_event_handler,
&printer_struct
}
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: printer_class.c:252
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: printer_class.c:213
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: printer_class.c:109
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: printer_class.c:129
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: printer_class.c:184
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: printer_class.c:198
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: printer_class.c:267
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: printer_class.c:83
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: printer_class.c:233
printer_struct
printer_type printer_struct
Definition: printer_class.c:61

Definition at line 64 of file printer_class.c.

Referenced by main().

◆ printer_struct

printer_type printer_struct

Definition at line 61 of file printer_class.c.


AT32F413 Firmwary Library: USB_printer_class_definition

Data Structures | Macros | Enumerations | Functions | Variables
USB_printer_class_definition
AT32F413_middlewares_usbd_class » USB_printer_class

Data Structures

struct printer_type

Macros

#define | USBD_PRINTER_BULK_IN_EPT 0x81
#define | USBD_PRINTER_BULK_OUT_EPT 0x01
#define | USBD_PRINTER_IN_MAXPACKET_SIZE 0x40
#define | USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40
#define | PRINTER_DEVICE_ID_LEN 24

Enumerations

enum printer_req_type { PRINTER_REQ_GET_DEVICE_ID = 0x00 , PRINTER_REQ_GET_PORT_STATUS = 0x01 , PRINTER_REQ_GET_SOFT_RESET = 0x02 }

Functions

uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler printer_class_handler

Detailed Description

Macro Definition Documentation

◆ PRINTER_DEVICE_ID_LEN

#define PRINTER_DEVICE_ID_LEN 24

Definition at line 57 of file printer_class.h.

◆ USBD_PRINTER_BULK_IN_EPT

#define USBD_PRINTER_BULK_IN_EPT 0x81

Definition at line 50 of file printer_class.h.

◆ USBD_PRINTER_BULK_OUT_EPT

#define USBD_PRINTER_BULK_OUT_EPT 0x01

Definition at line 51 of file printer_class.h.

◆ USBD_PRINTER_IN_MAXPACKET_SIZE

#define USBD_PRINTER_IN_MAXPACKET_SIZE 0x40

Definition at line 54 of file printer_class.h.

◆ USBD_PRINTER_OUT_MAXPACKET_SIZE

#define USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40

Definition at line 55 of file printer_class.h.

Enumeration Type Documentation

◆ printer_req_type

enum printer_req_type
Enumerator
PRINTER_REQ_GET_DEVICE_ID
PRINTER_REQ_GET_PORT_STATUS
PRINTER_REQ_GET_SOFT_RESET

Definition at line 59 of file printer_class.h.

Function Documentation

◆ usb_printer_get_rxdata()

uint16_t usb_printer_get_rxdata | ( | void * | udev,
 |  | uint8_t * | recv_data
 | ) |  |

usb device class rx data process

Parameters
udev | to the structure of usbd_core_type
recv_data | receive buffer
Return values
receive data len

Definition at line 299 of file printer_class.c.

◆ usb_printer_send_data()

error_status usb_printer_send_data | ( | void * | udev,
 |  | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

usb device class send data

Parameters
udev | to the structure of usbd_core_type
send_data | send data buffer
len | send length
Return values
error status

Definition at line 329 of file printer_class.c.

Variable Documentation

◆ printer_class_handler

usbd_class_handler printer_class_handler
extern

Definition at line 64 of file printer_class.c.

Referenced by main().


AT32F413 Firmwary Library: printer_type Struct Reference

Data Fields
printer_type Struct Reference
AT32F413_middlewares_usbd_class » USB_printer_class » USB_printer_class_definition

#include <printer_class.h>

Data Fields

uint32_t | alt_setting
uint32_t | g_printer_port_status
uint8_t | g_rx_buff [0x40]
uint8_t | g_printer_data [0x40]
__IO uint8_t | g_tx_completed
__IO uint8_t | g_rx_completed
uint32_t | g_rxlen

Detailed Description

Definition at line 67 of file printer_class.h.

Field Documentation

◆ alt_setting

uint32_t printer_type::alt_setting

Definition at line 69 of file printer_class.h.

Referenced by class_setup_handler().

◆ g_printer_data

uint8_t printer_type::g_printer_data[0x40]

Definition at line 72 of file printer_class.h.

Referenced by class_setup_handler().

◆ g_printer_port_status

uint32_t printer_type::g_printer_port_status

Definition at line 70 of file printer_class.h.

Referenced by class_init_handler(), and class_setup_handler().

◆ g_rx_buff

uint8_t printer_type::g_rx_buff[0x40]

Definition at line 71 of file printer_class.h.

Referenced by class_init_handler(), and usb_printer_get_rxdata().

◆ g_rx_completed

__IO uint8_t printer_type::g_rx_completed

Definition at line 74 of file printer_class.h.

Referenced by class_out_handler(), and usb_printer_get_rxdata().

◆ g_rxlen

uint32_t printer_type::g_rxlen

Definition at line 75 of file printer_class.h.

Referenced by class_out_handler(), and usb_printer_get_rxdata().

◆ g_tx_completed

__IO uint8_t printer_type::g_tx_completed

Definition at line 73 of file printer_class.h.

Referenced by class_in_handler(), class_init_handler(), and usb_printer_send_data().

The documentation for this struct was generated from the following file:
  • printer_class.h


AT32F413 Firmwary Library: USB_printer_desc

Modules
USB_printer_desc
AT32F413_middlewares_usbd_class

usb device printer descriptor More...

Modules

USB_printer_desc_private_functions
USB_printer_desc_definition

Detailed Description

usb device printer descriptor


AT32F413 Firmwary Library: USB_printer_desc_private_functions

Functions | Variables
USB_printer_desc_private_functions
AT32F413_middlewares_usbd_class » USB_printer_desc

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler printer_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

Function Documentation

◆ get_device_config_string()

static usbd_desc_t * get_device_config_string ( void )
static

get device config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 387 of file printer_desc.c.

◆ get_device_configuration()

static usbd_desc_t * get_device_configuration ( void )
static

get config descriptor

Parameters
none
Return values
usbd_desc

Definition at line 309 of file printer_desc.c.

◆ get_device_descriptor()

static usbd_desc_t * get_device_descriptor ( void )
static

get device descriptor

Parameters
none
Return values
usbd_desc

Definition at line 289 of file printer_desc.c.

◆ get_device_interface_string()

static usbd_desc_t * get_device_interface_string ( void )
static

get interface descriptor

Parameters
none
Return values
usbd_desc

Definition at line 375 of file printer_desc.c.

◆ get_device_lang_id()

static usbd_desc_t * get_device_lang_id ( void )
static

get lang id descriptor

Parameters
none
Return values
usbd_desc

Definition at line 329 of file printer_desc.c.

◆ get_device_manufacturer_string()

static usbd_desc_t * get_device_manufacturer_string ( void )
static

get manufacturer descriptor

Parameters
none
Return values
usbd_desc

Definition at line 340 of file printer_desc.c.

◆ get_device_other_speed()

static usbd_desc_t * get_device_other_speed ( void )
static

get other speed descriptor

Parameters
none
Return values
usbd_desc

Definition at line 319 of file printer_desc.c.

◆ get_device_product_string()

static usbd_desc_t * get_device_product_string ( void )
static

get product descriptor

Parameters
none
Return values
usbd_desc

Definition at line 352 of file printer_desc.c.

◆ get_device_qualifier()

static usbd_desc_t * get_device_qualifier ( void )
static

get device qualifier

Parameters
none
Return values
usbd_desc

Definition at line 299 of file printer_desc.c.

◆ get_device_serial_string()

static usbd_desc_t * get_device_serial_string ( void )
static

get serial descriptor

Parameters
none
Return values
usbd_desc

Definition at line 364 of file printer_desc.c.

◆ get_serial_num()

static void get_serial_num ( void )
static

usb get serial number

Parameters
none
Return values
none

Definition at line 267 of file printer_desc.c.

Referenced by get_device_serial_string().

◆ usbd_int_to_unicode()

static void usbd_int_to_unicode | ( | uint32_t | value,
 |  | uint8_t * | pbuf,
 |  | uint8_t | len
 | ) |  |
static

usb int convert to unicode

Parameters
value | int value
pbus | unicode buffer
len | length
Return values
none

Definition at line 241 of file printer_desc.c.

Referenced by get_serial_num().

◆ usbd_unicode_convert()

static uint16_t usbd_unicode_convert | ( | uint8_t * | string,
 |  | uint8_t * | unicode_buf
 | ) |  |
static

standard usb unicode convert

Parameters
string | source string
unicode_buf | unicode buffer
Return values
length

Definition at line 215 of file printer_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

Variable Documentation

◆ ALIGNED_TAIL

ALIGNED_HEAD uint8_t g_string_serial [ 0x1A ] ALIGNED_TAIL
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
USB_DESCIPTOR_TYPE_DEVICE,
0x00,
0x02,
0x00,
0x00,
0x00,
USB_MAX_EP0_SIZE,
LBYTE( 0x2E3C ),
HBYTE( 0x2E3C ),
LBYTE( 0x57FF ),
HBYTE( 0x57FF ),
0x00,
0x02,
USB_MFC_STRING,
USB_PRODUCT_STRING,
USB_SERIAL_STRING,
1
}
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92

usb device standard descriptor

usb string serial

usb string lang id

usb configuration standard descriptor

Definition at line 84 of file printer_desc.c.

◆ config_descriptor

usbd_desc_t config_descriptor
static
Initial value:
=
{
32 ,
g_usbd_configuration
}

Definition at line 187 of file printer_desc.c.

Referenced by get_device_configuration().

◆ device_descriptor

usbd_desc_t device_descriptor
static
Initial value:
=
{
USB_DEVICE_DESC_LEN,
g_usbd_descriptor
}

Definition at line 180 of file printer_desc.c.

Referenced by get_device_descriptor().

◆ g_usbd_desc_buffer

uint8_t g_usbd_desc_buffer[256]
static

Definition at line 59 of file printer_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().

◆ langid_descriptor

usbd_desc_t langid_descriptor
static
Initial value:
=
{
4 ,
g_string_lang_id
}

Definition at line 194 of file printer_desc.c.

Referenced by get_device_lang_id().

◆ printer_desc_handler

usbd_desc_handler printer_desc_handler
Initial value:
=
{
get_device_descriptor,
get_device_qualifier,
get_device_configuration,
get_device_other_speed,
get_device_lang_id,
get_device_manufacturer_string,
get_device_product_string,
get_device_serial_string,
get_device_interface_string,
get_device_config_string,
}
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: printer_desc.c:309
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: printer_desc.c:289
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: printer_desc.c:340
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: printer_desc.c:299
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: printer_desc.c:375
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: printer_desc.c:319
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: printer_desc.c:352
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: printer_desc.c:387
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: printer_desc.c:329
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: printer_desc.c:364

device descriptor handler structure

Definition at line 64 of file printer_desc.c.

Referenced by main().

◆ serial_descriptor

usbd_desc_t serial_descriptor
static
Initial value:
=
{
0x1A ,
g_string_serial
}

Definition at line 201 of file printer_desc.c.

Referenced by get_device_serial_string().

◆ vp_desc

usbd_desc_t vp_desc
static

Definition at line 207 of file printer_desc.c.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), and get_device_product_string().


AT32F413 Firmwary Library: USB_printer_desc_definition

Macros | Variables
USB_printer_desc_definition
AT32F413_middlewares_usbd_class » USB_printer_desc

Macros

#define | PRINTER_BCD_NUM 0x0110
#define | USBD_PRINTER_VENDOR_ID 0x2E3C
#define | USBD_PRINTER_PRODUCT_ID 0x57FF
#define | USBD_PRINTER_CONFIG_DESC_SIZE 32
#define | USBD_PRINTER_SIZ_STRING_LANGID 4
#define | USBD_PRINTER_SIZ_STRING_SERIAL 0x1A
#define | USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"
#define | USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"
#define | USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"
#define | PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01
#define | PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02
#define | PRINTER_PROTOCOL_1284_4 0x03
#define | PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler printer_desc_handler
device descriptor handler structure More...

Detailed Description

Macro Definition Documentation

◆ MCU_ID1

#define MCU_ID1 (0x1FFFF7E8)

Definition at line 70 of file printer_desc.h.

◆ MCU_ID2

#define MCU_ID2 (0x1FFFF7EC)

Definition at line 71 of file printer_desc.h.

◆ MCU_ID3

#define MCU_ID3 (0x1FFFF7F0)

Definition at line 72 of file printer_desc.h.

◆ PRINTER_BCD_NUM

#define PRINTER_BCD_NUM 0x0110

Definition at line 50 of file printer_desc.h.

◆ PRINTER_PROTOCOL_1284_4

#define PRINTER_PROTOCOL_1284_4 0x03

Definition at line 66 of file printer_desc.h.

◆ PRINTER_PROTOCOL_BI_DIRECTIONAL

#define PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02

Definition at line 65 of file printer_desc.h.

◆ PRINTER_PROTOCOL_UNIDIRECTIONAL

#define PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01

Definition at line 64 of file printer_desc.h.

◆ PRINTER_PROTOCOL_VENDOR_SPECIFIC

#define PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF

Definition at line 67 of file printer_desc.h.

◆ USBD_PRINTER_CONFIG_DESC_SIZE

#define USBD_PRINTER_CONFIG_DESC_SIZE 32

Definition at line 55 of file printer_desc.h.

◆ USBD_PRINTER_DESC_CONFIGURATION_STRING

#define USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"

Definition at line 61 of file printer_desc.h.

◆ USBD_PRINTER_DESC_INTERFACE_STRING

#define USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"

Definition at line 62 of file printer_desc.h.

◆ USBD_PRINTER_DESC_MANUFACTURER_STRING

#define USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"

Definition at line 59 of file printer_desc.h.

◆ USBD_PRINTER_DESC_PRODUCT_STRING

#define USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"

Definition at line 60 of file printer_desc.h.

◆ USBD_PRINTER_PRODUCT_ID

#define USBD_PRINTER_PRODUCT_ID 0x57FF

Definition at line 53 of file printer_desc.h.

◆ USBD_PRINTER_SIZ_STRING_LANGID

#define USBD_PRINTER_SIZ_STRING_LANGID 4

Definition at line 56 of file printer_desc.h.

◆ USBD_PRINTER_SIZ_STRING_SERIAL

#define USBD_PRINTER_SIZ_STRING_SERIAL 0x1A

Definition at line 57 of file printer_desc.h.

◆ USBD_PRINTER_VENDOR_ID

#define USBD_PRINTER_VENDOR_ID 0x2E3C

Definition at line 52 of file printer_desc.h.

Variable Documentation

◆ printer_desc_handler

usbd_desc_handler printer_desc_handler
extern

device descriptor handler structure

Definition at line 64 of file printer_desc.c.

Referenced by main().


AT32F413 Firmwary Library: AT32F413_middlewares_usbd_drivers

Modules
AT32F413_middlewares_usbd_drivers

Modules

USBD_drivers_core
usb device drivers core
USBD_drivers_interrupt
usb device interrupt
USBD_drivers_standard_request
usb device standard_request
USB_standard

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: USBD_drivers_core

Modules
USBD_drivers_core
AT32F413_middlewares_usbd_drivers

usb device drivers core More...

Modules

USBD_core_exported_types
USBD_core_exported_functions
USBD_core_private_functions

Detailed Description

usb device drivers core


AT32F413 Firmwary Library: USBD_core_exported_types

Data Structures | Enumerations
USBD_core_exported_types
AT32F413_middlewares_usbd_drivers » USBD_drivers_core

Data Structures

struct | usbd_desc_t
usb device descriptor struct More...
struct | usbd_desc_handler
usb device descriptor handler More...
struct | usbd_class_handler
usb device class handler More...
struct | usbd_core_type
usb device core struct type More...

Enumerations

enum usbd_event_type {
USBD_NOP_EVENT , USBD_RESET_EVENT , USBD_SUSPEND_EVENT , USBD_WAKEUP_EVENT ,
USBD_ERR_EVENT
}
usb device event More...

Detailed Description

Enumeration Type Documentation

◆ usbd_event_type

enum usbd_event_type

usb device event

Enumerator
USBD_NOP_EVENT | usb device event nop
USBD_RESET_EVENT | usb device event reset
USBD_SUSPEND_EVENT | usb device event suspend
USBD_WAKEUP_EVENT | usb device event wakeup
USBD_ERR_EVENT | usb device event error

Definition at line 54 of file usbd_core.h.


AT32F413 Firmwary Library: usbd_desc_t Struct Reference

Data Fields
usbd_desc_t Struct Reference
AT32F413_middlewares_usbd_drivers » USBD_drivers_core » USBD_core_exported_types

usb device descriptor struct More...

#include <usbd_core.h>

Data Fields

uint16_t | length
uint8_t * | descriptor

Detailed Description

usb device descriptor struct

Definition at line 66 of file usbd_core.h.

Field Documentation

◆ descriptor

uint8_t* usbd_desc_t::descriptor

descriptor string

Definition at line 69 of file usbd_core.h.

Referenced by class_audio_setup_handler(), class_setup_handler(), get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), get_device_product_string(), and usbd_get_descriptor().

◆ length

uint16_t usbd_desc_t::length

descriptor length

Definition at line 68 of file usbd_core.h.

Referenced by get_device_config_string(), get_device_interface_string(), get_device_manufacturer_string(), get_device_product_string(), and usbd_get_descriptor().

The documentation for this struct was generated from the following file:
  • usbd_core.h


AT32F413 Firmwary Library: usbd_desc_handler Struct Reference

Data Fields
usbd_desc_handler Struct Reference
AT32F413_middlewares_usbd_drivers » USBD_drivers_core » USBD_core_exported_types

usb device descriptor handler More...

#include <usbd_core.h>

Data Fields

usbd_desc_t *(* | get_device_descriptor )(void)
usbd_desc_t *(* | get_device_qualifier )(void)
usbd_desc_t *(* | get_device_configuration )(void)
usbd_desc_t *(* | get_device_other_speed )(void)
usbd_desc_t *(* | get_device_lang_id )(void)
usbd_desc_t *(* | get_device_manufacturer_string )(void)
usbd_desc_t *(* | get_device_product_string )(void)
usbd_desc_t *(* | get_device_serial_string )(void)
usbd_desc_t *(* | get_device_interface_string )(void)
usbd_desc_t *(* | get_device_config_string )(void)

Detailed Description

usb device descriptor handler

Definition at line 75 of file usbd_core.h.

Field Documentation

◆ get_device_config_string

usbd_desc_t *(* usbd_desc_handler::get_device_config_string) (void)

get device device config callback

Definition at line 86 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_configuration

usbd_desc_t *(* usbd_desc_handler::get_device_configuration) (void)

get device configuration callback

Definition at line 79 of file usbd_core.h.

Referenced by class_audio_setup_handler(), class_setup_handler(), and usbd_get_descriptor().

◆ get_device_descriptor

usbd_desc_t *(* usbd_desc_handler::get_device_descriptor) (void)

get device descriptor callback

Definition at line 77 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_interface_string

usbd_desc_t *(* usbd_desc_handler::get_device_interface_string) (void)

get device interface string callback

Definition at line 85 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_lang_id

usbd_desc_t *(* usbd_desc_handler::get_device_lang_id) (void)

get device lang id callback

Definition at line 81 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_manufacturer_string

usbd_desc_t *(* usbd_desc_handler::get_device_manufacturer_string) (void)

get device manufacturer callback

Definition at line 82 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_other_speed

usbd_desc_t *(* usbd_desc_handler::get_device_other_speed) (void)

get device other speed callback

Definition at line 80 of file usbd_core.h.

◆ get_device_product_string

usbd_desc_t *(* usbd_desc_handler::get_device_product_string) (void)

get device product callback

Definition at line 83 of file usbd_core.h.

Referenced by usbd_get_descriptor().

◆ get_device_qualifier

usbd_desc_t *(* usbd_desc_handler::get_device_qualifier) (void)

get device qualifier callback

Definition at line 78 of file usbd_core.h.

◆ get_device_serial_string

usbd_desc_t *(* usbd_desc_handler::get_device_serial_string) (void)

get device serial callback

Definition at line 84 of file usbd_core.h.

Referenced by usbd_get_descriptor().

The documentation for this struct was generated from the following file:
  • usbd_core.h


AT32F413 Firmwary Library: usbd_class_handler Struct Reference

Data Fields
usbd_class_handler Struct Reference
AT32F413_middlewares_usbd_drivers » USBD_drivers_core » USBD_core_exported_types

usb device class handler More...

#include <usbd_core.h>

Data Fields

usb_sts_type(* | init_handler )(void *udev)
usb_sts_type(* | clear_handler )(void *udev)
usb_sts_type(* | setup_handler )(void *udev, usb_setup_type *setup)
usb_sts_type(* | ept0_tx_handler )(void *udev)
usb_sts_type(* | ept0_rx_handler )(void *udev)
usb_sts_type(* | in_handler )(void *udev, uint8_t ept_num)
usb_sts_type(* | out_handler )(void *udev, uint8_t ept_num)
usb_sts_type(* | sof_handler )(void *udev)
usb_sts_type(* | event_handler )(void *udev, usbd_event_type event)
void * | pdata

Detailed Description

usb device class handler

Definition at line 92 of file usbd_core.h.

Field Documentation

◆ clear_handler

usb_sts_type(* usbd_class_handler::clear_handler) (void *udev)

usb class clear handler

Definition at line 95 of file usbd_core.h.

Referenced by usbd_set_configuration().

◆ ept0_rx_handler

usb_sts_type(* usbd_class_handler::ept0_rx_handler) (void *udev)

usb class endpoint 0 rx complete handler

Definition at line 98 of file usbd_core.h.

Referenced by usbd_core_out_handler().

◆ ept0_tx_handler

usb_sts_type(* usbd_class_handler::ept0_tx_handler) (void *udev)

usb class endpoint 0 tx complete handler

Definition at line 97 of file usbd_core.h.

Referenced by usbd_core_in_handler().

◆ event_handler

usb_sts_type(* usbd_class_handler::event_handler) (void *udev, usbd_event_type event)

usb class event handler

Definition at line 102 of file usbd_core.h.

Referenced by usbd_reset_handler(), usbd_suspend_handler(), and usbd_wakeup_handler().

◆ in_handler

usb_sts_type(* usbd_class_handler::in_handler) (void *udev, uint8_t ept_num)

usb class in transfer complete handler

Definition at line 99 of file usbd_core.h.

Referenced by usbd_core_in_handler().

◆ init_handler

usb_sts_type(* usbd_class_handler::init_handler) (void *udev)

usb class init handler

Definition at line 94 of file usbd_core.h.

Referenced by usbd_set_configuration().

◆ out_handler

usb_sts_type(* usbd_class_handler::out_handler) (void *udev, uint8_t ept_num)

usb class out transfer complete handler

Definition at line 100 of file usbd_core.h.

Referenced by usbd_core_out_handler().

◆ pdata

void* usbd_class_handler::pdata

usb class data pointer

Definition at line 103 of file usbd_core.h.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), audio_set_interface(), bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_check_address(), bot_scsi_clear_feature(), bot_scsi_cmd_process(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_format_capacity(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_start_stop(), bot_scsi_test_unit(), bot_scsi_verify(), bot_scsi_write10(), cdc_class_setup_handler(), class_ept0_rx_handler(), class_event_handler(), class_hid_setup_handler(), class_in_handler(), class_init_handler(), class_out_handler(), class_setup_handler(), keyboard_class_setup_handler(), keyboard_send_string(), main(), msc_class_setup_handler(), usb_hid_buf_process(), usb_hid_keyboard_send_char(), usb_hid_mouse_send(), usb_printer_get_rxdata(), usb_printer_send_data(), usb_vcp_cmd_process(), usb_vcp_get_rxdata(), usb_vcp_send_data(), usb_vcpkybrd_vcp_get_rxdata(), and usb_vcpkybrd_vcp_send_data().

◆ setup_handler

usb_sts_type(* usbd_class_handler::setup_handler) (void *udev, usb_setup_type *setup)

usb class setup handler

Definition at line 96 of file usbd_core.h.

Referenced by usbd_clear_feature(), usbd_device_request(), usbd_endpoint_request(), usbd_get_descriptor(), usbd_interface_request(), and usbd_set_feature().

◆ sof_handler

usb_sts_type(* usbd_class_handler::sof_handler) (void *udev)

usb class sof handler

Definition at line 101 of file usbd_core.h.

Referenced by usbd_sof_handler().

The documentation for this struct was generated from the following file:
  • usbd_core.h


AT32F413 Firmwary Library: usbd_core_type Struct Reference

Data Fields
usbd_core_type Struct Reference
AT32F413_middlewares_usbd_drivers » USBD_drivers_core » USBD_core_exported_types

usb device core struct type More...

#include <usbd_core.h>

Data Fields

usb_reg_type * usb_reg
usbd_class_handler * class_handler
usbd_desc_handler * desc_handler
usb_ept_info | ept_in [USB_EPT_MAX_NUM]
usb_ept_info | ept_out [USB_EPT_MAX_NUM]
usb_setup_type setup
uint8_t | setup_buffer [12]
uint8_t | ept0_sts
uint8_t | speed
uint16_t | ept0_wlength
usbd_conn_state conn_state
usbd_conn_state old_conn_state
uint8_t | device_addr
uint8_t | remote_wakup
uint8_t | default_config
uint8_t | dev_config
uint16_t | config_status

Detailed Description

usb device core struct type

Definition at line 109 of file usbd_core.h.

Field Documentation

◆ class_handler

usbd_class_handler* usbd_core_type::class_handler

usb device class handler pointer

Definition at line 113 of file usbd_core.h.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), audio_set_interface(), bot_cbw_decode(), bot_scsi_allow_medium_removal(), bot_scsi_capacity(), bot_scsi_check_address(), bot_scsi_clear_feature(), bot_scsi_cmd_process(), bot_scsi_datain_handler(), bot_scsi_dataout_handler(), bot_scsi_format_capacity(), bot_scsi_init(), bot_scsi_inquiry(), bot_scsi_mode_sense10(), bot_scsi_mode_sense6(), bot_scsi_read10(), bot_scsi_request_sense(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_send_data(), bot_scsi_stall(), bot_scsi_start_stop(), bot_scsi_test_unit(), bot_scsi_verify(), bot_scsi_write10(), cdc_class_setup_handler(), class_ept0_rx_handler(), class_event_handler(), class_hid_setup_handler(), class_in_handler(), class_init_handler(), class_out_handler(), class_setup_handler(), keyboard_class_setup_handler(), keyboard_send_string(), main(), msc_class_setup_handler(), usb_hid_buf_process(), usb_hid_keyboard_send_char(), usb_hid_mouse_send(), usb_printer_get_rxdata(), usb_printer_send_data(), usb_vcp_cmd_process(), usb_vcp_get_rxdata(), usb_vcp_send_data(), usb_vcpkybrd_vcp_get_rxdata(), usb_vcpkybrd_vcp_send_data(), usbd_clear_feature(), usbd_core_in_handler(), usbd_core_init(), usbd_core_out_handler(), usbd_device_request(), usbd_endpoint_request(), usbd_get_descriptor(), usbd_interface_request(), usbd_reset_handler(), usbd_set_configuration(), usbd_set_feature(), usbd_sof_handler(), usbd_suspend_handler(), and usbd_wakeup_handler().

◆ config_status

uint16_t usbd_core_type::config_status

usb configure status

Definition at line 133 of file usbd_core.h.

Referenced by usbd_clear_feature(), and usbd_get_status().

◆ conn_state

usbd_conn_state usbd_core_type::conn_state

usb current connect state

Definition at line 126 of file usbd_core.h.

Referenced by usbd_clear_feature(), usbd_connect_state_get(), usbd_core_in_handler(), usbd_core_init(), usbd_core_out_handler(), usbd_endpoint_request(), usbd_eptn_handler(), usbd_get_configuration(), usbd_get_status(), usbd_interface_request(), usbd_remote_wakeup(), usbd_reset_handler(), usbd_set_address(), usbd_set_configuration(), usbd_suspend_handler(), and usbd_wakeup_handler().

◆ default_config

uint8_t usbd_core_type::default_config

usb default config state

Definition at line 131 of file usbd_core.h.

Referenced by usbd_get_configuration().

◆ desc_handler

usbd_desc_handler* usbd_core_type::desc_handler

usb device descriptor handler pointer

Definition at line 114 of file usbd_core.h.

Referenced by class_audio_setup_handler(), class_setup_handler(), usbd_core_init(), and usbd_get_descriptor().

◆ dev_config

uint8_t usbd_core_type::dev_config

usb device config state

Definition at line 132 of file usbd_core.h.

Referenced by usbd_get_configuration(), and usbd_set_configuration().

◆ device_addr

uint8_t usbd_core_type::device_addr

device address

Definition at line 129 of file usbd_core.h.

Referenced by usbd_eptn_handler(), and usbd_set_address().

◆ ept0_sts

uint8_t usbd_core_type::ept0_sts

usb control endpoint 0 state

Definition at line 122 of file usbd_core.h.

Referenced by usbd_core_in_handler(), usbd_core_out_handler(), usbd_core_setup_handler(), usbd_ctrl_recv(), usbd_ctrl_recv_status(), usbd_ctrl_send(), and usbd_ctrl_send_status().

◆ ept0_wlength

uint16_t usbd_core_type::ept0_wlength

usb endpoint 0 transfer length

Definition at line 124 of file usbd_core.h.

Referenced by usbd_core_in_handler(), and usbd_core_setup_handler().

◆ ept_in

usb_ept_info usbd_core_type::ept_in[USB_EPT_MAX_NUM]

usb in endpoint infomation struct

Definition at line 116 of file usbd_core.h.

Referenced by usbd_clear_stall(), usbd_core_in_handler(), usbd_ctrl_send(), usbd_endpoint_request(), usbd_ept_buf_custom_define(), usbd_ept_close(), usbd_ept_dbuffer_enable(), usbd_ept_defaut_init(), usbd_ept_open(), usbd_ept_send(), usbd_eptn_handler(), and usbd_set_stall().

◆ ept_out

usb_ept_info usbd_core_type::ept_out[USB_EPT_MAX_NUM]

usb out endpoint infomation struct

Definition at line 117 of file usbd_core.h.

Referenced by usbd_clear_stall(), usbd_core_out_handler(), usbd_ctrl_recv(), usbd_endpoint_request(), usbd_ept_buf_custom_define(), usbd_ept_close(), usbd_ept_dbuffer_enable(), usbd_ept_defaut_init(), usbd_ept_open(), usbd_ept_recv(), usbd_eptn_handler(), usbd_get_recv_len(), and usbd_set_stall().

◆ old_conn_state

usbd_conn_state usbd_core_type::old_conn_state

usb save the previous connect state

Definition at line 127 of file usbd_core.h.

Referenced by usbd_remote_wakeup(), usbd_suspend_handler(), and usbd_wakeup_handler().

◆ remote_wakup

uint8_t usbd_core_type::remote_wakup

remote wakeup state

Definition at line 130 of file usbd_core.h.

Referenced by main(), usbd_clear_feature(), usbd_get_status(), and usbd_set_feature().

◆ setup

usb_setup_type usbd_core_type::setup

usb setup type struct

Definition at line 119 of file usbd_core.h.

Referenced by class_ept0_rx_handler(), usbd_clear_feature(), usbd_core_setup_handler(), usbd_device_request(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_set_feature().

◆ setup_buffer

uint8_t usbd_core_type::setup_buffer[12]

usb setup request buffer

Definition at line 120 of file usbd_core.h.

Referenced by usbd_core_setup_handler(), and usbd_eptn_handler().

◆ speed

uint8_t usbd_core_type::speed

usb speed

Definition at line 123 of file usbd_core.h.

◆ usb_reg

usb_reg_type* usbd_core_type::usb_reg

usb register pointer

Definition at line 111 of file usbd_core.h.

Referenced by usbd_connect(), usbd_core_init(), usbd_disconnect(), usbd_enter_suspend(), usbd_ept_close(), usbd_ept_loop_handler(), usbd_ept_open(), usbd_ept_send(), usbd_eptn_handler(), usbd_irq_handler(), usbd_remote_wakeup(), usbd_reset_handler(), usbd_set_device_addr(), and usbd_wakeup_handler().

The documentation for this struct was generated from the following file:
  • usbd_core.h


AT32F413 Firmwary Library: USBD_core_exported_functions

Functions
USBD_core_exported_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_core

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_num)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_num)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall. More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_ept_dbuffer_enable (usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer. More...
void | usbd_ept_buf_auto_define (usb_ept_info *ept_info)
usb auto define endpoint buffer More...
void | usbd_ept_buf_custom_define (usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer More...
void | usbd_ept_defaut_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core More...

Detailed Description

Function Documentation

◆ usbd_clear_stall()

void usbd_clear_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

clear endpoint stall

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 236 of file usbd_core.c.

Referenced by usbd_endpoint_request().

◆ usbd_connect()

void usbd_connect ( usbd_core_type * udev )

usb device connect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 561 of file usbd_core.c.

Referenced by main(), and usb_reset().

◆ usbd_connect_state_get()

usbd_conn_state usbd_connect_state_get ( usbd_core_type * udev )

get usb connect state

Parameters
udev to the structure of usbd_core_type
Return values
usb connect state

Definition at line 592 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), custom_hid_class_send_report(), main(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), and usb_vcpkybrd_class_send_report().

◆ usbd_core_in_handler()

void usbd_core_in_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core in transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 48 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_core_init()

void usbd_core_init | ( | usbd_core_type * | udev,
 |  | usb_reg_type * | usb_reg,
 |  | usbd_class_handler * | class_handler,
 |  | usbd_desc_handler * | desc_handler,
 |  | uint8_t | core_id
 | ) |  |

initializes the usb core

Parameters
udev | to the structure of usbd_core_type
usb_reg | usb register pointer (USB)
class_handler | usb class handler
desc_handler | device config handler
core_id | usb core id number
Return values
none

Definition at line 672 of file usbd_core.c.

Referenced by main().

◆ usbd_core_out_handler()

void usbd_core_out_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core out transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 100 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_core_setup_handler()

void usbd_core_setup_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_num
 | ) |  |

usb core setup transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 140 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_ctrl_recv()

void usbd_ctrl_recv | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | recv data buffer
len | recv data length
Return values
none

Definition at line 195 of file usbd_core.c.

Referenced by audio_req_set_cur(), cdc_class_setup_handler(), class_hid_setup_handler(), class_setup_handler(), and keyboard_class_setup_handler().

◆ usbd_ctrl_recv_status()

void usbd_ctrl_recv_status ( usbd_core_type * udev )

usb control endpoint send out status

Parameters
udev usb device core handler type
Return values
none

Definition at line 223 of file usbd_core.c.

Referenced by usbd_core_in_handler().

◆ usbd_ctrl_send()

void usbd_ctrl_send | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 176 of file usbd_core.c.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), and usbd_get_status().

◆ usbd_ctrl_send_status()

void usbd_ctrl_send_status ( usbd_core_type * udev )

usb control endpoint send in status

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 211 of file usbd_core.c.

Referenced by class_audio_setup_handler(), class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_core_out_handler(), usbd_endpoint_request(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_set_feature().

◆ usbd_ctrl_unsupport()

void usbd_ctrl_unsupport ( usbd_core_type * udev )

un-support device request

Parameters
udev usb device core handler type
Return values
none

Definition at line 286 of file usbd_core.c.

Referenced by cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_device_request(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), usbd_get_status(), usbd_interface_request(), usbd_set_address(), and usbd_set_configuration().

◆ usbd_disconnect()

void usbd_disconnect ( usbd_core_type * udev )

usb device disconnect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 571 of file usbd_core.c.

Referenced by usb_reset().

◆ usbd_enter_suspend()

void usbd_enter_suspend ( usbd_core_type * udev )

usb device enter suspend mode

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 622 of file usbd_core.c.

Referenced by usbd_suspend_handler().

◆ usbd_ept_buf_auto_define()

void usbd_ept_buf_auto_define ( usb_ept_info * ept_info )

usb auto define endpoint buffer

Parameters
usb_ept_info endpoint information
Return values
none

Definition at line 427 of file usbd_core.c.

Referenced by usbd_ept_open().

◆ usbd_ept_buf_custom_define()

void usbd_ept_buf_custom_define | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint32_t | addr
 | ) |  |

usb custom define endpoint buffer

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
addr | usb fifo offset address
Return values
none

Definition at line 461 of file usbd_core.c.

Referenced by class_init_handler(), and usbd_reset_handler().

◆ usbd_ept_close()

void usbd_ept_close | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb close endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 538 of file usbd_core.c.

Referenced by class_clear_handler(), class_setup_handler(), and msc_class_setup_handler().

◆ usbd_ept_dbuffer_enable()

void usbd_ept_dbuffer_enable | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

enable endpoint double buffer.

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 406 of file usbd_core.c.

Referenced by class_init_handler().

◆ usbd_ept_defaut_init()

void usbd_ept_defaut_init ( usbd_core_type * udev )

usb endpoint structure initialization

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 632 of file usbd_core.c.

Referenced by usbd_core_init(), and usbd_reset_handler().

◆ usbd_ept_open()

void usbd_ept_open | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t | ept_type,
 |  | uint16_t | maxpacket
 | ) |  |

usb open endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
ept_type | endpoint type
maxpacket | endpoint support max buffer size
Return values
none

Definition at line 503 of file usbd_core.c.

Referenced by class_init_handler(), class_setup_handler(), msc_class_setup_handler(), and usbd_reset_handler().

◆ usbd_ept_recv()

void usbd_ept_recv | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | receive data buffer
len | receive data length
Return values
none

Definition at line 361 of file usbd_core.c.

Referenced by audio_set_interface(), bot_scsi_init(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_stall(), bot_scsi_write10(), class_init_handler(), class_out_handler(), usb_printer_get_rxdata(), usb_vcp_get_rxdata(), usb_vcpkybrd_vcp_get_rxdata(), usbd_core_in_handler(), usbd_core_out_handler(), usbd_ctrl_recv(), usbd_ctrl_recv_status(), and usbd_eptn_handler().

◆ usbd_ept_send()

void usbd_ept_send | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 301 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), audio_set_interface(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), class_in_handler(), custom_hid_class_send_report(), usb_hid_buf_process(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), usb_printer_send_data(), usb_vcp_send_data(), usb_vcpkybrd_class_send_report(), usb_vcpkybrd_vcp_send_data(), usbd_core_in_handler(), usbd_ctrl_send(), usbd_ctrl_send_status(), and usbd_eptn_handler().

◆ usbd_get_recv_len()

uint32_t usbd_get_recv_len | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb endpoint get receive data length

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 394 of file usbd_core.c.

Referenced by bot_cbw_decode(), class_ept0_rx_handler(), and class_out_handler().

◆ usbd_remote_wakeup()

void usbd_remote_wakeup ( usbd_core_type * udev )

usb device remote wakeup

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 602 of file usbd_core.c.

Referenced by main().

◆ usbd_set_device_addr()

void usbd_set_device_addr | ( | usbd_core_type * | udev,
 |  | uint8_t | address
 | ) |  |

usb device set device address.

Parameters
udev | to the structure of usbd_core_type
address | host assignment address
Return values
none

Definition at line 582 of file usbd_core.c.

◆ usbd_set_stall()

void usbd_set_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb set endpoint to stall.

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 261 of file usbd_core.c.

Referenced by bot_scsi_clear_feature(), bot_scsi_stall(), usbd_ctrl_unsupport(), and usbd_endpoint_request().


AT32F413 Firmwary Library: USBD_core_private_functions

Functions
USBD_core_private_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_core

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall. More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint receive data More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length More...
void | usbd_ept_dbuffer_enable (usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer. More...
void | usbd_ept_buf_auto_define (usb_ept_info *ept_info)
usb auto define endpoint buffer More...
void | usbd_ept_buf_custom_define (usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_ept_defaut_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *class_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core More...

Detailed Description

Function Documentation

◆ usbd_clear_stall()

void usbd_clear_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

clear endpoint stall

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 236 of file usbd_core.c.

Referenced by usbd_endpoint_request().

◆ usbd_connect()

void usbd_connect ( usbd_core_type * udev )

usb device connect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 561 of file usbd_core.c.

Referenced by main(), and usb_reset().

◆ usbd_connect_state_get()

usbd_conn_state usbd_connect_state_get ( usbd_core_type * udev )

get usb connect state

Parameters
udev to the structure of usbd_core_type
Return values
usb connect state

Definition at line 592 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), custom_hid_class_send_report(), main(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), and usb_vcpkybrd_class_send_report().

◆ usbd_core_in_handler()

void usbd_core_in_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core in transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 48 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_core_init()

void usbd_core_init | ( | usbd_core_type * | udev,
 |  | usb_reg_type * | usb_reg,
 |  | usbd_class_handler * | class_handler,
 |  | usbd_desc_handler * | desc_handler,
 |  | uint8_t | core_id
 | ) |  |

initializes the usb core

Parameters
udev | to the structure of usbd_core_type
usb_reg | usb register pointer (USB)
class_handler | usb class handler
desc_handler | device config handler
core_id | usb core id number
Return values
none

Definition at line 672 of file usbd_core.c.

Referenced by main().

◆ usbd_core_out_handler()

void usbd_core_out_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb core out transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 100 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_core_setup_handler()

void usbd_core_setup_handler | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_num
 | ) |  |

usb core setup transfer complete handler

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 140 of file usbd_core.c.

Referenced by usbd_eptn_handler().

◆ usbd_ctrl_recv()

void usbd_ctrl_recv | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | recv data buffer
len | recv data length
Return values
none

Definition at line 195 of file usbd_core.c.

Referenced by audio_req_set_cur(), cdc_class_setup_handler(), class_hid_setup_handler(), class_setup_handler(), and keyboard_class_setup_handler().

◆ usbd_ctrl_recv_status()

void usbd_ctrl_recv_status ( usbd_core_type * udev )

usb control endpoint send out status

Parameters
udev usb device core handler type
Return values
none

Definition at line 223 of file usbd_core.c.

Referenced by usbd_core_in_handler().

◆ usbd_ctrl_send()

void usbd_ctrl_send | ( | usbd_core_type * | udev,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb control endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 176 of file usbd_core.c.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), and usbd_get_status().

◆ usbd_ctrl_send_status()

void usbd_ctrl_send_status ( usbd_core_type * udev )

usb control endpoint send in status

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 211 of file usbd_core.c.

Referenced by class_audio_setup_handler(), class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_core_out_handler(), usbd_endpoint_request(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_set_feature().

◆ usbd_ctrl_unsupport()

void usbd_ctrl_unsupport ( usbd_core_type * udev )

un-support device request

Parameters
udev usb device core handler type
Return values
none

Definition at line 286 of file usbd_core.c.

Referenced by cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_device_request(), usbd_endpoint_request(), usbd_get_configuration(), usbd_get_descriptor(), usbd_get_status(), usbd_interface_request(), usbd_set_address(), and usbd_set_configuration().

◆ usbd_disconnect()

void usbd_disconnect ( usbd_core_type * udev )

usb device disconnect to host

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 571 of file usbd_core.c.

Referenced by usb_reset().

◆ usbd_enter_suspend()

void usbd_enter_suspend ( usbd_core_type * udev )

usb device enter suspend mode

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 622 of file usbd_core.c.

Referenced by usbd_suspend_handler().

◆ usbd_ept_buf_auto_define()

void usbd_ept_buf_auto_define ( usb_ept_info * ept_info )

usb auto define endpoint buffer

Parameters
usb_ept_info endpoint information
Return values
none

Definition at line 427 of file usbd_core.c.

Referenced by usbd_ept_open().

◆ usbd_ept_buf_custom_define()

void usbd_ept_buf_custom_define | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint32_t | addr
 | ) |  |

usb custom define endpoint buffer

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
addr | usb fifo offset address
Return values
none

Definition at line 461 of file usbd_core.c.

Referenced by class_init_handler(), and usbd_reset_handler().

◆ usbd_ept_close()

void usbd_ept_close | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb close endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 538 of file usbd_core.c.

Referenced by class_clear_handler(), class_setup_handler(), and msc_class_setup_handler().

◆ usbd_ept_dbuffer_enable()

void usbd_ept_dbuffer_enable | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

enable endpoint double buffer.

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 406 of file usbd_core.c.

Referenced by class_init_handler().

◆ usbd_ept_defaut_init()

void usbd_ept_defaut_init ( usbd_core_type * udev )

usb endpoint structure initialization

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 632 of file usbd_core.c.

Referenced by usbd_core_init(), and usbd_reset_handler().

◆ usbd_ept_open()

void usbd_ept_open | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t | ept_type,
 |  | uint16_t | maxpacket
 | ) |  |

usb open endpoint

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
ept_type | endpoint type
maxpacket | endpoint support max buffer size
Return values
none

Definition at line 503 of file usbd_core.c.

Referenced by class_init_handler(), class_setup_handler(), msc_class_setup_handler(), and usbd_reset_handler().

◆ usbd_ept_recv()

void usbd_ept_recv | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb endpoint receive data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | receive data buffer
len | receive data length
Return values
none

Definition at line 361 of file usbd_core.c.

Referenced by audio_set_interface(), bot_scsi_init(), bot_scsi_reset(), bot_scsi_send_csw(), bot_scsi_stall(), bot_scsi_write10(), class_init_handler(), class_out_handler(), usb_printer_get_rxdata(), usb_vcp_get_rxdata(), usb_vcpkybrd_vcp_get_rxdata(), usbd_core_in_handler(), usbd_core_out_handler(), usbd_ctrl_recv(), usbd_ctrl_recv_status(), and usbd_eptn_handler().

◆ usbd_ept_send()

void usbd_ept_send | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr,
 |  | uint8_t * | buffer,
 |  | uint16_t | len
 | ) |  |

usb endpoint send data

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
buffer | send data buffer
len | send data length
Return values
none

Definition at line 301 of file usbd_core.c.

Referenced by audio_hid_class_send_report(), audio_set_interface(), bot_scsi_read10(), bot_scsi_send_csw(), bot_scsi_send_data(), class_in_handler(), custom_hid_class_send_report(), usb_hid_buf_process(), usb_iap_class_send_report(), usb_keyboard_class_send_report(), usb_mouse_class_send_report(), usb_printer_send_data(), usb_vcp_send_data(), usb_vcpkybrd_class_send_report(), usb_vcpkybrd_vcp_send_data(), usbd_core_in_handler(), usbd_ctrl_send(), usbd_ctrl_send_status(), and usbd_eptn_handler().

◆ usbd_get_recv_len()

uint32_t usbd_get_recv_len | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb endpoint get receive data length

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 394 of file usbd_core.c.

Referenced by bot_cbw_decode(), class_ept0_rx_handler(), and class_out_handler().

◆ usbd_remote_wakeup()

void usbd_remote_wakeup ( usbd_core_type * udev )

usb device remote wakeup

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 602 of file usbd_core.c.

Referenced by main().

◆ usbd_set_device_addr()

void usbd_set_device_addr | ( | usbd_core_type * | udev,
 |  | uint8_t | address
 | ) |  |

usb device set device address.

Parameters
udev | to the structure of usbd_core_type
address | host assignment address
Return values
none

Definition at line 582 of file usbd_core.c.

◆ usbd_set_stall()

void usbd_set_stall | ( | usbd_core_type * | udev,
 |  | uint8_t | ept_addr
 | ) |  |

usb set endpoint to stall.

Parameters
udev | to the structure of usbd_core_type
ept_addr | endpoint number
Return values
none

Definition at line 261 of file usbd_core.c.

Referenced by bot_scsi_clear_feature(), bot_scsi_stall(), usbd_ctrl_unsupport(), and usbd_endpoint_request().


AT32F413 Firmwary Library: USBD_drivers_interrupt

Modules
USBD_drivers_interrupt
AT32F413_middlewares_usbd_drivers

usb device interrupt More...

Modules

USBD_int_exported_functions
USBD_int_private_functions

Detailed Description

usb device interrupt


AT32F413 Firmwary Library: USBD_int_exported_functions

Functions
USBD_int_exported_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_interrupt

Functions

void | usbd_irq_handler (usbd_core_type *udev)
usb device interrput request handler. More...
void | usbd_ept_loop_handler (usbd_core_type *udev)
usb device endpoint loop handler. More...
void | usbd_eptn_handler (usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler. More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...

Detailed Description

Function Documentation

◆ usbd_ept_loop_handler()

void usbd_ept_loop_handler ( usbd_core_type * udev )

usb device endpoint loop handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 224 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_eptn_handler()

void usbd_eptn_handler | ( | usbd_core_type * | udev,
 |  | usb_ept_number_type | ept_num
 | ) |  |

usb device endpoint request handler.

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 111 of file usbd_int.c.

Referenced by usbd_ept_loop_handler().

◆ usbd_irq_handler()

void usbd_irq_handler ( usbd_core_type * udev )

usb device interrput request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 46 of file usbd_int.c.

Referenced by USBFS_L_CAN1_RX0_IRQHandler().

◆ usbd_reset_handler()

void usbd_reset_handler ( usbd_core_type * udev )

usb device reset interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 244 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_sof_handler()

void usbd_sof_handler ( usbd_core_type * udev )

usb device sof interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 277 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_suspend_handler()

void usbd_suspend_handler ( usbd_core_type * udev )

usb device suspend interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 289 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_wakeup_handler()

void usbd_wakeup_handler ( usbd_core_type * udev )

usb device wakup interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 310 of file usbd_int.c.

Referenced by usbd_irq_handler().


AT32F413 Firmwary Library: USBD_int_private_functions

Functions
USBD_int_private_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_interrupt

Functions

void | usbd_irq_handler (usbd_core_type *udev)
usb device interrput request handler. More...
void | usbd_eptn_handler (usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler. More...
void | usbd_ept_loop_handler (usbd_core_type *udev)
usb device endpoint loop handler. More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...

Detailed Description

Function Documentation

◆ usbd_ept_loop_handler()

void usbd_ept_loop_handler ( usbd_core_type * udev )

usb device endpoint loop handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 224 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_eptn_handler()

void usbd_eptn_handler | ( | usbd_core_type * | udev,
 |  | usb_ept_number_type | ept_num
 | ) |  |

usb device endpoint request handler.

Parameters
udev | to the structure of usbd_core_type
ept_num | endpoint number
Return values
none

Definition at line 111 of file usbd_int.c.

Referenced by usbd_ept_loop_handler().

◆ usbd_irq_handler()

void usbd_irq_handler ( usbd_core_type * udev )

usb device interrput request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 46 of file usbd_int.c.

Referenced by USBFS_L_CAN1_RX0_IRQHandler().

◆ usbd_reset_handler()

void usbd_reset_handler ( usbd_core_type * udev )

usb device reset interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 244 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_sof_handler()

void usbd_sof_handler ( usbd_core_type * udev )

usb device sof interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 277 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_suspend_handler()

void usbd_suspend_handler ( usbd_core_type * udev )

usb device suspend interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 289 of file usbd_int.c.

Referenced by usbd_irq_handler().

◆ usbd_wakeup_handler()

void usbd_wakeup_handler ( usbd_core_type * udev )

usb device wakup interrupt request handler.

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 310 of file usbd_int.c.

Referenced by usbd_irq_handler().


AT32F413 Firmwary Library: USBD_drivers_standard_request

Modules
USBD_drivers_standard_request
AT32F413_middlewares_usbd_drivers

usb device standard_request More...

Modules

USBD_sdr_exported_functions
USBD_sdr_private_functions

Detailed Description

usb device standard_request


AT32F413 Firmwary Library: USBD_sdr_exported_functions

Functions
USBD_sdr_exported_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_standard_request

Functions

void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

Function Documentation

◆ usbd_device_request()

usb_sts_type usbd_device_request ( usbd_core_type * udev )

standard usb device requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 350 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_endpoint_request()

usb_sts_type usbd_endpoint_request ( usbd_core_type * udev )

standard usb endpoint requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 419 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_interface_request()

usb_sts_type usbd_interface_request ( usbd_core_type * udev )

standard usb interface requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 394 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_setup_request_parse()

void usbd_setup_request_parse | ( | usb_setup_type * | setup,
 |  | uint8_t * | buf
 | ) |  |

usb parse standard setup request

Parameters
setup | setup structure
buf | setup buffer
Return values
none

Definition at line 55 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().


AT32F413 Firmwary Library: USBD_sdr_private_functions

Functions
USBD_sdr_private_functions
AT32F413_middlewares_usbd_drivers » USBD_drivers_standard_request

Functions

static usb_sts_type | usbd_get_descriptor (usbd_core_type *udev)
get usb standard device description request More...
static usb_sts_type | usbd_set_address (usbd_core_type *udev)
this request sets the device address More...
static usb_sts_type | usbd_get_status (usbd_core_type *udev)
get usb status request More...
static usb_sts_type | usbd_clear_feature (usbd_core_type *udev)
clear usb feature request More...
static usb_sts_type | usbd_set_feature (usbd_core_type *udev)
set usb feature request More...
static usb_sts_type | usbd_get_configuration (usbd_core_type *udev)
get usb configuration request More...
static usb_sts_type | usbd_set_configuration (usbd_core_type *udev)
sets the usb device configuration request More...
void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

Function Documentation

◆ usbd_clear_feature()

static usb_sts_type usbd_clear_feature ( usbd_core_type * udev )
static

clear usb feature request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 210 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_device_request()

usb_sts_type usbd_device_request ( usbd_core_type * udev )

standard usb device requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 350 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_endpoint_request()

usb_sts_type usbd_endpoint_request ( usbd_core_type * udev )

standard usb endpoint requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 419 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_get_configuration()

static usb_sts_type usbd_get_configuration ( usbd_core_type * udev )
static

get usb configuration request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 256 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_get_descriptor()

static usb_sts_type usbd_get_descriptor ( usbd_core_type * udev )
static

get usb standard device description request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 69 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_get_status()

static usb_sts_type usbd_get_status ( usbd_core_type * udev )
static

get usb status request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 185 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_interface_request()

usb_sts_type usbd_interface_request ( usbd_core_type * udev )

standard usb interface requests

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 394 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().

◆ usbd_set_address()

static usb_sts_type usbd_set_address ( usbd_core_type * udev )
static

this request sets the device address

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 139 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_set_configuration()

static usb_sts_type usbd_set_configuration ( usbd_core_type * udev )
static

sets the usb device configuration request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 288 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_set_feature()

static usb_sts_type usbd_set_feature ( usbd_core_type * udev )
static

set usb feature request

Parameters
udev to the structure of usbd_core_type
Return values
status of usb_sts_type

Definition at line 238 of file usbd_sdr.c.

Referenced by usbd_device_request().

◆ usbd_setup_request_parse()

void usbd_setup_request_parse | ( | usb_setup_type * | setup,
 |  | uint8_t * | buf
 | ) |  |

usb parse standard setup request

Parameters
setup | setup structure
buf | setup buffer
Return values
none

Definition at line 55 of file usbd_sdr.c.

Referenced by usbd_core_setup_handler().


AT32F413 Firmwary Library: USB_standard

Modules
USB_standard
AT32F413_middlewares_usbd_drivers

Modules

USB_standard_define
USB_standard_exported_types

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: USB_standard_define

Data Structures | Macros | Enumerations
USB_standard_define
AT32F413_middlewares_usbd_drivers » USB_standard

Data Structures

struct linecoding_type
usb cdc class set line coding struct More...

Macros

#define | USB_REQ_RECIPIENT_DEVICE 0x00
usb request recipient More...
#define | USB_REQ_RECIPIENT_INTERFACE 0x01
#define | USB_REQ_RECIPIENT_ENDPOINT 0x02
#define | USB_REQ_RECIPIENT_OTHER 0x03
#define | USB_REQ_RECIPIENT_MASK 0x1F
#define | USB_REQ_TYPE_STANDARD 0x00
usb request type More...
#define | USB_REQ_TYPE_CLASS 0x20
#define | USB_REQ_TYPE_VENDOR 0x40
#define | USB_REQ_TYPE_RESERVED 0x60
#define | USB_REQ_DIR_HTD 0x00
usb request data transfer direction More...
#define | USB_REQ_DIR_DTH 0x80
#define | USB_STD_REQ_GET_STATUS 0
usb standard device requests codes More...
#define | USB_STD_REQ_CLEAR_FEATURE 1
#define | USB_STD_REQ_SET_FEATURE 3
#define | USB_STD_REQ_SET_ADDRESS 5
#define | USB_STD_REQ_GET_DESCRIPTOR 6
#define | USB_STD_REQ_SET_DESCRIPTOR 7
#define | USB_STD_REQ_GET_CONFIGURATION 8
#define | USB_STD_REQ_SET_CONFIGURATION 9
#define | USB_STD_REQ_GET_INTERFACE 10
#define | USB_STD_REQ_SET_INTERFACE 11
#define | USB_STD_REQ_SYNCH_FRAME 12
#define | USB_DESCIPTOR_TYPE_DEVICE 1
usb standard device type More...
#define | USB_DESCIPTOR_TYPE_CONFIGURATION 2
#define | USB_DESCIPTOR_TYPE_STRING 3
#define | USB_DESCIPTOR_TYPE_INTERFACE 4
#define | USB_DESCIPTOR_TYPE_ENDPOINT 5
#define | USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6
#define | USB_DESCIPTOR_TYPE_OTHER_SPEED 7
#define | USB_DESCIPTOR_TYPE_INTERFACE_POWER 8
#define | USB_LANGID_STRING 0
usb standard string type More...
#define | USB_MFC_STRING 1
#define | USB_PRODUCT_STRING 2
#define | USB_SERIAL_STRING 3
#define | USB_CONFIG_STRING 4
#define | USB_INTERFACE_STRING 5
#define | USB_CONF_REMOTE_WAKEUP 2
usb configuration attributes More...
#define | USB_CONF_SELF_POWERED 1
#define | USB_FEATURE_EPT_HALT 0
usb standard feature selectors More...
#define | USB_FEATURE_REMOTE_WAKEUP 1
#define | USB_FEATURE_TEST_MODE 2
#define | USB_EPT0_IDLE 0
endpoint 0 state More...
#define | USB_EPT0_SETUP 1
#define | USB_EPT0_DATA_IN 2
#define | USB_EPT0_DATA_OUT 3
#define | USB_EPT0_STATUS_IN 4
#define | USB_EPT0_STATUS_OUT 5
#define | USB_EPT0_STALL 6
#define | USB_DEVICE_QUALIFIER_DESC_LEN 0x0A
usb descriptor length More...
#define | USB_DEVICE_DESC_LEN 0x12
#define | USB_DEVICE_CFG_DESC_LEN 0x09
#define | USB_DEVICE_IF_DESC_LEN 0x09
#define | USB_DEVICE_EPT_LEN 0x07
#define | USB_DEVICE_OTG_DESC_LEN 0x03
#define | USB_DEVICE_LANGID_STR_DESC_LEN 0x04
#define | USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09
#define | USB_CLASS_CODE_AUDIO 0x01
usb class code More...
#define | USB_CLASS_CODE_CDC 0x02
#define | USB_CLASS_CODE_HID 0x03
#define | USB_CLASS_CODE_PRINTER 0x07
#define | USB_CLASS_CODE_MSC 0x08
#define | USB_CLASS_CODE_HUB 0x09
#define | USB_CLASS_CODE_CDCDATA 0x0A
#define | USB_CLASS_CODE_CCID 0x0B
#define | USB_CLASS_CODE_VIDEO 0x0E
#define | USB_CLASS_CODE_VENDOR 0xFF
#define | USB_EPT_DESC_CONTROL 0x00
usb endpoint type More...
#define | USB_EPT_DESC_ISO 0x01
#define | USB_EPT_DESC_BULK 0x02
#define | USB_EPT_DESC_INTERRUPT 0x03
#define | USB_EPT_DESC_NSYNC 0x00
#define | USB_ETP_DESC_ASYNC 0x04
#define | USB_ETP_DESC_ADAPTIVE 0x08
#define | USB_ETP_DESC_SYNC 0x0C
#define | USB_EPT_DESC_DATA_EPT 0x00
#define | USB_EPT_DESC_FD_EPT 0x10
#define | USB_EPT_DESC_FDDATA_EPT 0x20
#define | USBD_CDC_CS_INTERFACE 0x24
usb cdc class descriptor define More...
#define | USBD_CDC_CS_ENDPOINT 0x25
#define | USBD_CDC_SUBTYPE_HEADER 0x00
usb cdc class sub-type define More...
#define | USBD_CDC_SUBTYPE_CMF 0x01
#define | USBD_CDC_SUBTYPE_ACM 0x02
#define | USBD_CDC_SUBTYPE_UFD 0x06
#define | SET_LINE_CODING 0x20
usb cdc class request code define More...
#define | GET_LINE_CODING 0x21
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REQ_SET_PROTOCOL 0x0B
usb hid class request code define More...
#define | HID_REQ_GET_PROTOCOL 0x03
#define | HID_REQ_SET_IDLE 0x0A
#define | HID_REQ_GET_IDLE 0x02
#define | HID_REQ_SET_REPORT 0x09
#define | HID_REQ_GET_REPORT 0x01
#define | HID_DESCRIPTOR_TYPE 0x21
#define | HID_REPORT_DESC 0x22
#define | USB_MAX_EP0_SIZE 64
endpoint 0 max size More...
#define | SWAPBYTE(addr)
usb swap address More...
#define | MIN(a, b) (uint16_t)(((a) < (b)) ? (a) : (b))
min and max define More...
#define | MAX(a, b) (uint16_t)(((a) > (b)) ? (a) : (b))
#define | LBYTE(x) ((uint8_t)(x & 0x00FF))
low byte and high byte define More...
#define | HBYTE(x) ((uint8_t)((x & 0xFF00) >>8))

Enumerations

enum usbd_conn_state { USB_CONN_STATE_DEFAULT =1 , USB_CONN_STATE_ADDRESSED , USB_CONN_STATE_CONFIGURED , USB_CONN_STATE_SUSPENDED }
usb device connect state More...

Detailed Description

Macro Definition Documentation

◆ GET_LINE_CODING

#define GET_LINE_CODING 0x21

Definition at line 207 of file usb_std.h.

◆ HBYTE

#define HBYTE ( x ) ((uint8_t)((x & 0xFF00) >>8))

high byte define

Definition at line 261 of file usb_std.h.

◆ HID_CLASS_DESC_HID

#define HID_CLASS_DESC_HID 0x21

usb hid class descriptor define

Definition at line 223 of file usb_std.h.

◆ HID_CLASS_DESC_PHYSICAL

#define HID_CLASS_DESC_PHYSICAL 0x23

Definition at line 225 of file usb_std.h.

◆ HID_CLASS_DESC_REPORT

#define HID_CLASS_DESC_REPORT 0x22

Definition at line 224 of file usb_std.h.

◆ HID_DESCRIPTOR_TYPE

#define HID_DESCRIPTOR_TYPE 0x21

Definition at line 236 of file usb_std.h.

◆ HID_REPORT_DESC

#define HID_REPORT_DESC 0x22

Definition at line 237 of file usb_std.h.

◆ HID_REQ_GET_IDLE

#define HID_REQ_GET_IDLE 0x02

Definition at line 233 of file usb_std.h.

◆ HID_REQ_GET_PROTOCOL

#define HID_REQ_GET_PROTOCOL 0x03

Definition at line 231 of file usb_std.h.

◆ HID_REQ_GET_REPORT

#define HID_REQ_GET_REPORT 0x01

Definition at line 235 of file usb_std.h.

◆ HID_REQ_SET_IDLE

#define HID_REQ_SET_IDLE 0x0A

Definition at line 232 of file usb_std.h.

◆ HID_REQ_SET_PROTOCOL

#define HID_REQ_SET_PROTOCOL 0x0B

usb hid class request code define

Definition at line 230 of file usb_std.h.

◆ HID_REQ_SET_REPORT

#define HID_REQ_SET_REPORT 0x09

Definition at line 234 of file usb_std.h.

◆ LBYTE

#define LBYTE ( x ) ((uint8_t)(x & 0x00FF))

low byte and high byte define

low byte define

Definition at line 260 of file usb_std.h.

◆ MAX

#define MAX | ( | a,
 |  | b
 | ) | (uint16_t)(((a) > (b)) ? (a) : (b))

max define

Definition at line 255 of file usb_std.h.

◆ MIN

#define MIN | ( | a,
 |  | b
 | ) | (uint16_t)(((a) < (b)) ? (a) : (b))

min and max define

min define

Definition at line 254 of file usb_std.h.

◆ SET_LINE_CODING

#define SET_LINE_CODING 0x20

usb cdc class request code define

Definition at line 206 of file usb_std.h.

◆ SWAPBYTE

#define SWAPBYTE ( addr )
Value:
(uint16_t)(((uint16_t)(*((uint8_t *)(addr)))) + \
(((uint16_t)(*(((uint8_t *)(addr)) + 1))) << 8))

usb swap address

swap address

Definition at line 249 of file usb_std.h.

◆ USB_CLASS_CODE_AUDIO

#define USB_CLASS_CODE_AUDIO 0x01

usb class code

usb class code audio

Definition at line 161 of file usb_std.h.

◆ USB_CLASS_CODE_CCID

#define USB_CLASS_CODE_CCID 0x0B

usb class code ccid

Definition at line 168 of file usb_std.h.

◆ USB_CLASS_CODE_CDC

#define USB_CLASS_CODE_CDC 0x02

usb class code cdc

Definition at line 162 of file usb_std.h.

◆ USB_CLASS_CODE_CDCDATA

#define USB_CLASS_CODE_CDCDATA 0x0A

usb class code cdc data

Definition at line 167 of file usb_std.h.

◆ USB_CLASS_CODE_HID

#define USB_CLASS_CODE_HID 0x03

usb class code hid

Definition at line 163 of file usb_std.h.

◆ USB_CLASS_CODE_HUB

#define USB_CLASS_CODE_HUB 0x09

usb class code hub

Definition at line 166 of file usb_std.h.

◆ USB_CLASS_CODE_MSC

#define USB_CLASS_CODE_MSC 0x08

usb class code msc

Definition at line 165 of file usb_std.h.

◆ USB_CLASS_CODE_PRINTER

#define USB_CLASS_CODE_PRINTER 0x07

usb class code printer

Definition at line 164 of file usb_std.h.

◆ USB_CLASS_CODE_VENDOR

#define USB_CLASS_CODE_VENDOR 0xFF

usb class code vendor

Definition at line 170 of file usb_std.h.

◆ USB_CLASS_CODE_VIDEO

#define USB_CLASS_CODE_VIDEO 0x0E

usb class code video

Definition at line 169 of file usb_std.h.

◆ USB_CONF_REMOTE_WAKEUP

#define USB_CONF_REMOTE_WAKEUP 2

usb configuration attributes

usb configuration attributes remote wakeup

Definition at line 114 of file usb_std.h.

◆ USB_CONF_SELF_POWERED

#define USB_CONF_SELF_POWERED 1

usb configuration attributes self powered

Definition at line 115 of file usb_std.h.

◆ USB_CONFIG_STRING

#define USB_CONFIG_STRING 4

usb standard string type config

Definition at line 108 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_CONFIGURATION

#define USB_DESCIPTOR_TYPE_CONFIGURATION 2

usb standard device type configuration

Definition at line 93 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_DEVICE

#define USB_DESCIPTOR_TYPE_DEVICE 1

usb standard device type

usb standard device type device

Definition at line 92 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER

#define USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6

usb standard device type qualifier

Definition at line 97 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_ENDPOINT

#define USB_DESCIPTOR_TYPE_ENDPOINT 5

usb standard device type endpoint

Definition at line 96 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_INTERFACE

#define USB_DESCIPTOR_TYPE_INTERFACE 4

usb standard device type interface

Definition at line 95 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_INTERFACE_POWER

#define USB_DESCIPTOR_TYPE_INTERFACE_POWER 8

usb standard device type interface power

Definition at line 99 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_OTHER_SPEED

#define USB_DESCIPTOR_TYPE_OTHER_SPEED 7

usb standard device type other speed

Definition at line 98 of file usb_std.h.

◆ USB_DESCIPTOR_TYPE_STRING

#define USB_DESCIPTOR_TYPE_STRING 3

usb standard device type string

Definition at line 94 of file usb_std.h.

◆ USB_DEVICE_CFG_DESC_LEN

#define USB_DEVICE_CFG_DESC_LEN 0x09

usb configuration descriptor length

Definition at line 151 of file usb_std.h.

◆ USB_DEVICE_DESC_LEN

#define USB_DEVICE_DESC_LEN 0x12

usb device descriptor length

Definition at line 150 of file usb_std.h.

◆ USB_DEVICE_EPT_LEN

#define USB_DEVICE_EPT_LEN 0x07

usb endpoint descriptor length

Definition at line 153 of file usb_std.h.

◆ USB_DEVICE_IF_DESC_LEN

#define USB_DEVICE_IF_DESC_LEN 0x09

usb interface descriptor length

Definition at line 152 of file usb_std.h.

◆ USB_DEVICE_LANGID_STR_DESC_LEN

#define USB_DEVICE_LANGID_STR_DESC_LEN 0x04

usb lang id string descriptor length

Definition at line 155 of file usb_std.h.

◆ USB_DEVICE_OTG_DESC_LEN

#define USB_DEVICE_OTG_DESC_LEN 0x03

usb otg descriptor length

Definition at line 154 of file usb_std.h.

◆ USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN

#define USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09

usb other speed descriptor length

Definition at line 156 of file usb_std.h.

◆ USB_DEVICE_QUALIFIER_DESC_LEN

#define USB_DEVICE_QUALIFIER_DESC_LEN 0x0A

usb descriptor length

usb qualifier descriptor length

Definition at line 149 of file usb_std.h.

◆ USB_EPT0_DATA_IN

#define USB_EPT0_DATA_IN 2

usb endpoint state data in

Definition at line 140 of file usb_std.h.

◆ USB_EPT0_DATA_OUT

#define USB_EPT0_DATA_OUT 3

usb endpoint state data out

Definition at line 141 of file usb_std.h.

◆ USB_EPT0_IDLE

#define USB_EPT0_IDLE 0

endpoint 0 state

usb endpoint state idle

Definition at line 138 of file usb_std.h.

◆ USB_EPT0_SETUP

#define USB_EPT0_SETUP 1

usb endpoint state setup

Definition at line 139 of file usb_std.h.

◆ USB_EPT0_STALL

#define USB_EPT0_STALL 6

usb endpoint state stall

Definition at line 144 of file usb_std.h.

◆ USB_EPT0_STATUS_IN

#define USB_EPT0_STATUS_IN 4

usb endpoint state status in

Definition at line 142 of file usb_std.h.

◆ USB_EPT0_STATUS_OUT

#define USB_EPT0_STATUS_OUT 5

usb endpoint state status out

Definition at line 143 of file usb_std.h.

◆ USB_EPT_DESC_BULK

#define USB_EPT_DESC_BULK 0x02

usb endpoint description type bulk

Definition at line 177 of file usb_std.h.

◆ USB_EPT_DESC_CONTROL

#define USB_EPT_DESC_CONTROL 0x00

usb endpoint type

usb endpoint description type control

Definition at line 175 of file usb_std.h.

◆ USB_EPT_DESC_DATA_EPT

#define USB_EPT_DESC_DATA_EPT 0x00

usb endpoint description data

Definition at line 185 of file usb_std.h.

◆ USB_EPT_DESC_FD_EPT

#define USB_EPT_DESC_FD_EPT 0x10

usb endpoint description fd

Definition at line 186 of file usb_std.h.

◆ USB_EPT_DESC_FDDATA_EPT

#define USB_EPT_DESC_FDDATA_EPT 0x20

usb endpoint description fddata

Definition at line 187 of file usb_std.h.

◆ USB_EPT_DESC_INTERRUPT

#define USB_EPT_DESC_INTERRUPT 0x03

usb endpoint description type interrupt

Definition at line 178 of file usb_std.h.

◆ USB_EPT_DESC_ISO

#define USB_EPT_DESC_ISO 0x01

usb endpoint description type iso

Definition at line 176 of file usb_std.h.

◆ USB_EPT_DESC_NSYNC

#define USB_EPT_DESC_NSYNC 0x00

usb endpoint description nsync

Definition at line 180 of file usb_std.h.

◆ USB_ETP_DESC_ADAPTIVE

#define USB_ETP_DESC_ADAPTIVE 0x08

usb endpoint description adaptive

Definition at line 182 of file usb_std.h.

◆ USB_ETP_DESC_ASYNC

#define USB_ETP_DESC_ASYNC 0x04

usb endpoint description async

Definition at line 181 of file usb_std.h.

◆ USB_ETP_DESC_SYNC

#define USB_ETP_DESC_SYNC 0x0C

usb endpoint description sync

Definition at line 183 of file usb_std.h.

◆ USB_FEATURE_EPT_HALT

#define USB_FEATURE_EPT_HALT 0

usb standard feature selectors

usb standard feature selectors endpoint halt

Definition at line 120 of file usb_std.h.

◆ USB_FEATURE_REMOTE_WAKEUP

#define USB_FEATURE_REMOTE_WAKEUP 1

usb standard feature selectors remote wakeup

Definition at line 121 of file usb_std.h.

◆ USB_FEATURE_TEST_MODE

#define USB_FEATURE_TEST_MODE 2

usb standard feature selectors test mode

Definition at line 122 of file usb_std.h.

◆ USB_INTERFACE_STRING

#define USB_INTERFACE_STRING 5

usb standard string type interface

Definition at line 109 of file usb_std.h.

◆ USB_LANGID_STRING

#define USB_LANGID_STRING 0

usb standard string type

usb standard string type lang id

Definition at line 104 of file usb_std.h.

◆ USB_MAX_EP0_SIZE

#define USB_MAX_EP0_SIZE 64

endpoint 0 max size

usb endpoint 0 max size

Definition at line 242 of file usb_std.h.

◆ USB_MFC_STRING

#define USB_MFC_STRING 1

usb standard string type mfc

Definition at line 105 of file usb_std.h.

◆ USB_PRODUCT_STRING

#define USB_PRODUCT_STRING 2

usb standard string type product

Definition at line 106 of file usb_std.h.

◆ USB_REQ_DIR_DTH

#define USB_REQ_DIR_DTH 0x80

usb request data transfer direction device to host

Definition at line 72 of file usb_std.h.

◆ USB_REQ_DIR_HTD

#define USB_REQ_DIR_HTD 0x00

usb request data transfer direction

usb request data transfer direction host to device

Definition at line 71 of file usb_std.h.

◆ USB_REQ_RECIPIENT_DEVICE

#define USB_REQ_RECIPIENT_DEVICE 0x00

usb request recipient

usb request recipient device

Definition at line 54 of file usb_std.h.

◆ USB_REQ_RECIPIENT_ENDPOINT

#define USB_REQ_RECIPIENT_ENDPOINT 0x02

usb request recipient endpoint

Definition at line 56 of file usb_std.h.

◆ USB_REQ_RECIPIENT_INTERFACE

#define USB_REQ_RECIPIENT_INTERFACE 0x01

usb request recipient interface

Definition at line 55 of file usb_std.h.

◆ USB_REQ_RECIPIENT_MASK

#define USB_REQ_RECIPIENT_MASK 0x1F

usb request recipient mask

Definition at line 58 of file usb_std.h.

◆ USB_REQ_RECIPIENT_OTHER

#define USB_REQ_RECIPIENT_OTHER 0x03

usb request recipient other

Definition at line 57 of file usb_std.h.

◆ USB_REQ_TYPE_CLASS

#define USB_REQ_TYPE_CLASS 0x20

usb request type class

Definition at line 64 of file usb_std.h.

◆ USB_REQ_TYPE_RESERVED

#define USB_REQ_TYPE_RESERVED 0x60

usb request type reserved

Definition at line 66 of file usb_std.h.

◆ USB_REQ_TYPE_STANDARD

#define USB_REQ_TYPE_STANDARD 0x00

usb request type

usb request type standard

Definition at line 63 of file usb_std.h.

◆ USB_REQ_TYPE_VENDOR

#define USB_REQ_TYPE_VENDOR 0x40

usb request type vendor

Definition at line 65 of file usb_std.h.

◆ USB_SERIAL_STRING

#define USB_SERIAL_STRING 3

usb standard string type serial

Definition at line 107 of file usb_std.h.

◆ USB_STD_REQ_CLEAR_FEATURE

#define USB_STD_REQ_CLEAR_FEATURE 1

usb request code clear feature

Definition at line 78 of file usb_std.h.

◆ USB_STD_REQ_GET_CONFIGURATION

#define USB_STD_REQ_GET_CONFIGURATION 8

usb request code get configuration

Definition at line 83 of file usb_std.h.

◆ USB_STD_REQ_GET_DESCRIPTOR

#define USB_STD_REQ_GET_DESCRIPTOR 6

usb request code get descriptor

Definition at line 81 of file usb_std.h.

◆ USB_STD_REQ_GET_INTERFACE

#define USB_STD_REQ_GET_INTERFACE 10

usb request code get interface

Definition at line 85 of file usb_std.h.

◆ USB_STD_REQ_GET_STATUS

#define USB_STD_REQ_GET_STATUS 0

usb standard device requests codes

usb request code status

Definition at line 77 of file usb_std.h.

◆ USB_STD_REQ_SET_ADDRESS

#define USB_STD_REQ_SET_ADDRESS 5

usb request code address

Definition at line 80 of file usb_std.h.

◆ USB_STD_REQ_SET_CONFIGURATION

#define USB_STD_REQ_SET_CONFIGURATION 9

usb request code set configuration

Definition at line 84 of file usb_std.h.

◆ USB_STD_REQ_SET_DESCRIPTOR

#define USB_STD_REQ_SET_DESCRIPTOR 7

usb request code set descriptor

Definition at line 82 of file usb_std.h.

◆ USB_STD_REQ_SET_FEATURE

#define USB_STD_REQ_SET_FEATURE 3

usb request code feature

Definition at line 79 of file usb_std.h.

◆ USB_STD_REQ_SET_INTERFACE

#define USB_STD_REQ_SET_INTERFACE 11

usb request code set interface

Definition at line 86 of file usb_std.h.

◆ USB_STD_REQ_SYNCH_FRAME

#define USB_STD_REQ_SYNCH_FRAME 12

usb request code synch frame

Definition at line 87 of file usb_std.h.

◆ USBD_CDC_CS_ENDPOINT

#define USBD_CDC_CS_ENDPOINT 0x25

Definition at line 193 of file usb_std.h.

◆ USBD_CDC_CS_INTERFACE

#define USBD_CDC_CS_INTERFACE 0x24

usb cdc class descriptor define

Definition at line 192 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_ACM

#define USBD_CDC_SUBTYPE_ACM 0x02

Definition at line 200 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_CMF

#define USBD_CDC_SUBTYPE_CMF 0x01

Definition at line 199 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_HEADER

#define USBD_CDC_SUBTYPE_HEADER 0x00

usb cdc class sub-type define

Definition at line 198 of file usb_std.h.

◆ USBD_CDC_SUBTYPE_UFD

#define USBD_CDC_SUBTYPE_UFD 0x06

Definition at line 201 of file usb_std.h.

Enumeration Type Documentation

◆ usbd_conn_state

enum usbd_conn_state

usb device connect state

Enumerator
USB_CONN_STATE_DEFAULT | usb device connect state default
USB_CONN_STATE_ADDRESSED | usb device connect state address
USB_CONN_STATE_CONFIGURED | usb device connect state configured
USB_CONN_STATE_SUSPENDED | usb device connect state suspend

Definition at line 127 of file usb_std.h.


AT32F413 Firmwary Library: linecoding_type Struct Reference

Data Fields
linecoding_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_define

usb cdc class set line coding struct More...

#include <usb_std.h>

Data Fields

uint32_t | bitrate
uint8_t | format
uint8_t | parity
uint8_t | data

Detailed Description

usb cdc class set line coding struct

Definition at line 212 of file usb_std.h.

Field Documentation

◆ bitrate

uint32_t linecoding_type::bitrate

Definition at line 214 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

◆ data

uint8_t linecoding_type::data

Definition at line 217 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

◆ format

uint8_t linecoding_type::format

Definition at line 215 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

◆ parity

uint8_t linecoding_type::parity

Definition at line 216 of file usb_std.h.

Referenced by cdc_struct_init(), class_init_handler(), usb_usart_config(), and usb_vcp_cmd_process().

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: USB_standard_exported_types

Data Structures | Enumerations
USB_standard_exported_types
AT32F413_middlewares_usbd_drivers » USB_standard

Data Structures

struct | usb_setup_type
format of usb setup data More...
struct | usb_device_desc_type
format of standard device descriptor More...
struct | usb_configuration_desc_type
format of standard configuration descriptor More...
struct | usb_interface_desc_type
format of standard interface descriptor More...
struct | usb_endpoint_desc_type
format of standard endpoint descriptor More...
struct | usb_header_desc_type
format of header More...

Enumerations

enum usb_sts_type {
USB_OK , USB_FAIL , USB_WAIT , USB_NOT_SUPPORT ,
USB_ERROR
}
usb return status More...

Detailed Description

Enumeration Type Documentation

◆ usb_sts_type

enum usb_sts_type

usb return status

Enumerator
USB_OK | usb status ok
USB_FAIL | usb status fail
USB_WAIT | usb status wait
USB_NOT_SUPPORT | usb status not support
USB_ERROR | usb status error

Definition at line 274 of file usb_std.h.


AT32F413 Firmwary Library: usb_setup_type Struct Reference

Data Fields
usb_setup_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of usb setup data More...

#include <usb_std.h>

Data Fields

uint8_t | bmRequestType
uint8_t | bRequest
uint16_t | wValue
uint16_t | wIndex
uint16_t | wLength

Detailed Description

format of usb setup data

Definition at line 286 of file usb_std.h.

Field Documentation

◆ bmRequestType

uint8_t usb_setup_type::bmRequestType

characteristics of request

Definition at line 288 of file usb_std.h.

Referenced by audio_req_set_cur(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_core_setup_handler(), usbd_device_request(), usbd_endpoint_request(), and usbd_setup_request_parse().

◆ bRequest

uint8_t usb_setup_type::bRequest

specific request

Definition at line 289 of file usb_std.h.

Referenced by cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_device_request(), usbd_endpoint_request(), and usbd_setup_request_parse().

◆ wIndex

uint16_t usb_setup_type::wIndex

word-sized field that varies according to request typically used to pass an index or offset

Definition at line 291 of file usb_std.h.

Referenced by audio_get_interface(), audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), audio_set_interface(), class_setup_handler(), msc_class_setup_handler(), usbd_endpoint_request(), usbd_set_address(), usbd_set_configuration(), and usbd_setup_request_parse().

◆ wLength

uint16_t usb_setup_type::wLength

number of bytes to transfer if there is a data stage

Definition at line 293 of file usb_std.h.

Referenced by audio_req_get_cur(), audio_req_get_max(), audio_req_get_min(), audio_req_get_res(), audio_req_set_cur(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), usbd_core_setup_handler(), usbd_get_configuration(), usbd_get_descriptor(), usbd_interface_request(), usbd_set_address(), usbd_set_configuration(), and usbd_setup_request_parse().

◆ wValue

uint16_t usb_setup_type::wValue

word-sized field that varies according to request

Definition at line 290 of file usb_std.h.

Referenced by audio_req_get_cur(), audio_req_set_cur(), audio_set_interface(), cdc_class_setup_handler(), class_audio_setup_handler(), class_hid_setup_handler(), class_setup_handler(), keyboard_class_setup_handler(), msc_class_setup_handler(), usbd_clear_feature(), usbd_endpoint_request(), usbd_get_descriptor(), usbd_set_address(), usbd_set_configuration(), usbd_set_feature(), and usbd_setup_request_parse().

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_device_desc_type Struct Reference

Data Fields
usb_device_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of standard device descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint16_t | bcdUSB
uint8_t | bDeviceClass
uint8_t | bDeviceSubClass
uint8_t | bDeviceProtocol
uint8_t | bMaxPacketSize0
uint16_t | idVendor
uint16_t | idProduct
uint16_t | bcdDevice
uint8_t | iManufacturer
uint8_t | iProduct
uint8_t | iSerialNumber
uint8_t | bNumConfigurations

Detailed Description

format of standard device descriptor

Definition at line 299 of file usb_std.h.

Field Documentation

◆ bcdDevice

uint16_t usb_device_desc_type::bcdDevice

device release number in binary-coded decimal

Definition at line 310 of file usb_std.h.

◆ bcdUSB

uint16_t usb_device_desc_type::bcdUSB

usb specification release number

Definition at line 303 of file usb_std.h.

◆ bDescriptorType

uint8_t usb_device_desc_type::bDescriptorType

device descriptor type

Definition at line 302 of file usb_std.h.

◆ bDeviceClass

uint8_t usb_device_desc_type::bDeviceClass

class code (assigned by the usb-if)

Definition at line 304 of file usb_std.h.

◆ bDeviceProtocol

uint8_t usb_device_desc_type::bDeviceProtocol

protocol code ((assigned by the usb-if))

Definition at line 306 of file usb_std.h.

◆ bDeviceSubClass

uint8_t usb_device_desc_type::bDeviceSubClass

subclass code (assigned by the usb-if)

Definition at line 305 of file usb_std.h.

◆ bLength

uint8_t usb_device_desc_type::bLength

size of this descriptor in bytes

Definition at line 301 of file usb_std.h.

◆ bMaxPacketSize0

uint8_t usb_device_desc_type::bMaxPacketSize0

maximum packet size for endpoint zero

Definition at line 307 of file usb_std.h.

◆ bNumConfigurations

uint8_t usb_device_desc_type::bNumConfigurations

number of possible configurations

Definition at line 314 of file usb_std.h.

◆ idProduct

uint16_t usb_device_desc_type::idProduct

product id ((assigned by the usb-if))

Definition at line 309 of file usb_std.h.

◆ idVendor

uint16_t usb_device_desc_type::idVendor

verndor id ((assigned by the usb-if))

Definition at line 308 of file usb_std.h.

◆ iManufacturer

uint8_t usb_device_desc_type::iManufacturer

index of string descriptor describing manufacturer

Definition at line 311 of file usb_std.h.

◆ iProduct

uint8_t usb_device_desc_type::iProduct

index of string descriptor describing product

Definition at line 312 of file usb_std.h.

◆ iSerialNumber

uint8_t usb_device_desc_type::iSerialNumber

index of string descriptor describing serial number

Definition at line 313 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_configuration_desc_type Struct Reference

Data Fields
usb_configuration_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of standard configuration descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint16_t | wTotalLength
uint8_t | bNumInterfaces
uint8_t | bConfigurationValue
uint8_t | iConfiguration
uint8_t | bmAttributes
uint8_t | bMaxPower

Detailed Description

format of standard configuration descriptor

Definition at line 320 of file usb_std.h.

Field Documentation

◆ bConfigurationValue

uint8_t usb_configuration_desc_type::bConfigurationValue

value to use as an argument to the SetConfiguration() request

Definition at line 326 of file usb_std.h.

◆ bDescriptorType

uint8_t usb_configuration_desc_type::bDescriptorType

configuration descriptor type

Definition at line 323 of file usb_std.h.

◆ bLength

uint8_t usb_configuration_desc_type::bLength

size of this descriptor in bytes

Definition at line 322 of file usb_std.h.

◆ bmAttributes

uint8_t usb_configuration_desc_type::bmAttributes

configuration characteristics D7 reserved D6 self-powered D5 remote wakeup D4~D0 reserved

Definition at line 328 of file usb_std.h.

◆ bMaxPower

uint8_t usb_configuration_desc_type::bMaxPower

maximum power consumption of the usb device from the bus

Definition at line 333 of file usb_std.h.

◆ bNumInterfaces

uint8_t usb_configuration_desc_type::bNumInterfaces

number of interfaces supported by this configuration

Definition at line 325 of file usb_std.h.

◆ iConfiguration

uint8_t usb_configuration_desc_type::iConfiguration

index of string descriptor describing this configuration

Definition at line 327 of file usb_std.h.

◆ wTotalLength

uint16_t usb_configuration_desc_type::wTotalLength

total length of data returned for this configuration

Definition at line 324 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_interface_desc_type Struct Reference

Data Fields
usb_interface_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of standard interface descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint8_t | bInterfaceNumber
uint8_t | bAlternateSetting
uint8_t | bNumEndpoints
uint8_t | bInterfaceClass
uint8_t | bInterfaceSubClass
uint8_t | bInterfaceProtocol
uint8_t | iInterface

Detailed Description

format of standard interface descriptor

Definition at line 341 of file usb_std.h.

Field Documentation

◆ bAlternateSetting

uint8_t usb_interface_desc_type::bAlternateSetting

value used to select this alternate setting for the interface

Definition at line 346 of file usb_std.h.

◆ bDescriptorType

uint8_t usb_interface_desc_type::bDescriptorType

interface descriptor type

Definition at line 344 of file usb_std.h.

◆ bInterfaceClass

uint8_t usb_interface_desc_type::bInterfaceClass

class code (assigned by the usb-if)

Definition at line 348 of file usb_std.h.

◆ bInterfaceNumber

uint8_t usb_interface_desc_type::bInterfaceNumber

number of this interface

Definition at line 345 of file usb_std.h.

◆ bInterfaceProtocol

uint8_t usb_interface_desc_type::bInterfaceProtocol

protocol code (assigned by the usb-if)

Definition at line 350 of file usb_std.h.

◆ bInterfaceSubClass

uint8_t usb_interface_desc_type::bInterfaceSubClass

subclass code (assigned by the usb-if)

Definition at line 349 of file usb_std.h.

◆ bLength

uint8_t usb_interface_desc_type::bLength

size of this descriptor in bytes

Definition at line 343 of file usb_std.h.

◆ bNumEndpoints

uint8_t usb_interface_desc_type::bNumEndpoints

number of endpoints used by this interface

Definition at line 347 of file usb_std.h.

◆ iInterface

uint8_t usb_interface_desc_type::iInterface

index of string descriptor describing this interface

Definition at line 351 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_endpoint_desc_type Struct Reference

Data Fields
usb_endpoint_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of standard endpoint descriptor More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType
uint8_t | bEndpointAddress
uint8_t | bmAttributes
uint16_t | wMaxPacketSize
uint8_t | bInterval

Detailed Description

format of standard endpoint descriptor

Definition at line 357 of file usb_std.h.

Field Documentation

◆ bDescriptorType

uint8_t usb_endpoint_desc_type::bDescriptorType

endpoint descriptor type

Definition at line 360 of file usb_std.h.

◆ bEndpointAddress

uint8_t usb_endpoint_desc_type::bEndpointAddress

the address of the endpoint on the usb device described by this descriptor

Definition at line 361 of file usb_std.h.

◆ bInterval

uint8_t usb_endpoint_desc_type::bInterval

interval for polling endpoint for data transfers

Definition at line 364 of file usb_std.h.

◆ bLength

uint8_t usb_endpoint_desc_type::bLength

size of this descriptor in bytes

Definition at line 359 of file usb_std.h.

◆ bmAttributes

uint8_t usb_endpoint_desc_type::bmAttributes

describes the endpoints attributes when it is configured using bConfiguration value

Definition at line 362 of file usb_std.h.

◆ wMaxPacketSize

uint16_t usb_endpoint_desc_type::wMaxPacketSize

maximum packet size this endpoint

Definition at line 363 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: usb_header_desc_type Struct Reference

Data Fields
usb_header_desc_type Struct Reference
AT32F413_middlewares_usbd_drivers » USB_standard » USB_standard_exported_types

format of header More...

#include <usb_std.h>

Data Fields

uint8_t | bLength
uint8_t | bDescriptorType

Detailed Description

format of header

Definition at line 370 of file usb_std.h.

Field Documentation

◆ bDescriptorType

uint8_t usb_header_desc_type::bDescriptorType

descriptor type

Definition at line 373 of file usb_std.h.

◆ bLength

uint8_t usb_header_desc_type::bLength

size of this descriptor in bytes

Definition at line 372 of file usb_std.h.

The documentation for this struct was generated from the following file:
  • usb_std.h


AT32F413 Firmwary Library: AT32F413_board

Modules
AT32F413_board

Modules

BOARD
onboard periph driver

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: BOARD

Modules | Macros | Functions | Variables
BOARD
AT32F413_board

onboard periph driver More...

Modules

BOARD_pins_definition
BOARD_exported_functions

Macros

#define | STEP_DELAY_MS 50
#define | PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)

Functions

int | fputc (int ch, FILE *f)
retargets the c library printf function to the usart. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...
void | at32_board_init ()
board initialize interface init led and button More...
void | at32_button_init (void)
configure button gpio More...
uint8_t | at32_button_state (void)
returns the selected button state More...
button_type at32_button_press ()
returns which button have press down More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | delay_init ()
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...

Variables

gpio_type * | led_gpio_port [3] = {LED2_GPIO, LED3_GPIO, LED4_GPIO}
uint16_t | led_gpio_pin [3] = {LED2_PIN, LED3_PIN, LED4_PIN}
crm_periph_clock_type | led_gpio_crm_clk [3] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK}
static __IO uint32_t | fac_us
static __IO uint32_t | fac_ms

Detailed Description

onboard periph driver

Macro Definition Documentation

◆ PUTCHAR_PROTOTYPE

#define PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)

Definition at line 87 of file at32f413_board.c.

◆ STEP_DELAY_MS

#define STEP_DELAY_MS 50

Definition at line 40 of file at32f413_board.c.

Function Documentation

◆ at32_board_init()

void at32_board_init ( void )

board initialize interface init led and button

Parameters
none
Return values
none

Definition at line 136 of file at32f413_board.c.

Referenced by main().

◆ at32_button_init()

void at32_button_init ( void )

configure button gpio

Parameters
button specifies the button to be configured.
Return values
none

< gpio pins number 0

Definition at line 158 of file at32f413_board.c.

Referenced by at32_board_init().

◆ at32_button_press()

button_type at32_button_press ( void )

returns which button have press down

Parameters
none
Return values
the button have press down

Definition at line 192 of file at32f413_board.c.

Referenced by main().

◆ at32_button_state()

uint8_t at32_button_state ( void )

returns the selected button state

Parameters
none
Return values
the button gpio pin value

< gpio pins number 0

Definition at line 182 of file at32f413_board.c.

Referenced by at32_button_press().

◆ at32_led_init()

void at32_led_init ( led_type led )

configure led gpio

Parameters
led specifies the led to be configured.
Return values
none

Definition at line 216 of file at32f413_board.c.

Referenced by at32_board_init(), and main().

◆ at32_led_off()

void at32_led_off ( led_type led )

turns selected led off.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 261 of file at32f413_board.c.

Referenced by at32_board_init(), main(), sd_test_error(), TAMPER_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_on()

void at32_led_on ( led_type led )

turns selected led on.

Parameters
led specifies the led to be set on. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 244 of file at32f413_board.c.

Referenced by DMA2_Channel1_IRQHandler(), main(), sd_test_error(), TAMPER_IRQHandler(), USART2_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_toggle()

void at32_led_toggle ( led_type led )

turns selected led toggle.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 278 of file at32f413_board.c.

Referenced by ACC_IRQHandler(), ADC1_2_IRQHandler(), error_handler(), EXINT0_IRQHandler(), EXINT4_IRQHandler(), led2_task_function(), led3_task_function(), main(), PVM_IRQHandler(), result_error(), RTC_IRQHandler(), RTCAlarm_IRQHandler(), spim_operate(), spim_run(), systick_handler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), USART1_IRQHandler(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ delay_init()

void delay_init ( void )

initialize delay function

Parameters
none
Return values
none

Definition at line 291 of file at32f413_board.c.

Referenced by at32_board_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ delay_ms()

void delay_ms ( uint16_t nms )

inserts a delay time.

Parameters
nms specifies the delay time length, in milliseconds.
Return values
none

Definition at line 324 of file at32f413_board.c.

Referenced by at32_button_press(), button_isr(), delay_sec(), error_handler(), flash_fat16_loop_status(), FLASH_IRQHandler(), iap_loop(), main(), randnum_test(), sd_power_on(), sd_test_error(), spim_operate(), spim_run(), usb_delay_ms(), and usb_reset().

◆ delay_sec()

void delay_sec ( uint16_t sec )

inserts a delay time.

Parameters
sec specifies the delay time, in seconds.
Return values
none

Definition at line 356 of file at32f413_board.c.

Referenced by main(), and result_error().

◆ delay_us()

void delay_us ( uint32_t nus )

inserts a delay time.

Parameters
nus specifies the delay time length, in microsecond.
Return values
none

Definition at line 304 of file at32f413_board.c.

Referenced by main(), and usb_delay_us().

◆ fputc()

int fputc | ( | int | ch,
 |  | FILE * | f
 | ) |  |

retargets the c library printf function to the usart.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

Definition at line 95 of file at32f413_board.c.

◆ uart_print_init()

void uart_print_init ( uint32_t baudrate )

initialize uart

Parameters
baudrate uart baudrate
Return values
none

< gpio pins number 9

Definition at line 107 of file at32f413_board.c.

Referenced by main().

Variable Documentation

◆ fac_ms

__IO uint32_t fac_ms
static

Definition at line 49 of file at32f413_board.c.

Referenced by delay_init(), and delay_ms().

◆ fac_us

__IO uint32_t fac_us
static

Definition at line 48 of file at32f413_board.c.

Referenced by delay_init(), and delay_us().

◆ led_gpio_crm_clk

crm_periph_clock_type led_gpio_crm_clk[3] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK}

Definition at line 45 of file at32f413_board.c.

Referenced by at32_led_init().

◆ led_gpio_pin

uint16_t led_gpio_pin[3] = {LED2_PIN, LED3_PIN, LED4_PIN}

Definition at line 44 of file at32f413_board.c.

Referenced by at32_led_init(), at32_led_off(), at32_led_on(), and at32_led_toggle().

◆ led_gpio_port

gpio_type* led_gpio_port[3] = {LED2_GPIO, LED3_GPIO, LED4_GPIO}

Definition at line 43 of file at32f413_board.c.

Referenced by at32_led_init(), at32_led_off(), at32_led_on(), and at32_led_toggle().


AT32F413 Firmwary Library: BOARD_pins_definition

Macros | Enumerations
BOARD_pins_definition
AT32F413_board » BOARD

Macros

#define | LED_NUM 3
#define | PRINT_UART USART1
#define | PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK
#define | PRINT_UART_TX_PIN GPIO_PINS_9
#define | PRINT_UART_TX_GPIO GPIOA
#define | PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | USER_BUTTON_PIN GPIO_PINS_0
#define | USER_BUTTON_PORT GPIOA
#define | USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Enumerations

enum | led_type { LED2 = 0 , LED3 = 1 , LED4 = 2 }
enum | button_type { USER_BUTTON = 0 , NO_BUTTON = 1 }

Detailed Description

Macro Definition Documentation

◆ LED_NUM

#define LED_NUM 3

Definition at line 68 of file at32f413_board.h.

◆ PRINT_UART

#define PRINT_UART USART1

Definition at line 85 of file at32f413_board.h.

◆ PRINT_UART_CRM_CLK

#define PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK

Definition at line 86 of file at32f413_board.h.

◆ PRINT_UART_TX_GPIO

#define PRINT_UART_TX_GPIO GPIOA

Definition at line 88 of file at32f413_board.h.

◆ PRINT_UART_TX_GPIO_CRM_CLK

#define PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 89 of file at32f413_board.h.

◆ PRINT_UART_TX_PIN

#define PRINT_UART_TX_PIN GPIO_PINS_9

Definition at line 87 of file at32f413_board.h.

◆ USER_BUTTON_CRM_CLK

#define USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 100 of file at32f413_board.h.

◆ USER_BUTTON_PIN

#define USER_BUTTON_PIN GPIO_PINS_0

Definition at line 98 of file at32f413_board.h.

◆ USER_BUTTON_PORT

#define USER_BUTTON_PORT GPIOA

Definition at line 99 of file at32f413_board.h.

Enumeration Type Documentation

◆ button_type

enum button_type
Enumerator
USER_BUTTON
NO_BUTTON

Definition at line 92 of file at32f413_board.h.

◆ led_type

enum led_type

this header include define support list:

  1. at-start-f413 v1.x board if define AT_START_F413_V1, the header file support at-start-f413 v1.x board
Enumerator
LED2
LED3
LED4

Definition at line 61 of file at32f413_board.h.


AT32F413 Firmwary Library: BOARD_exported_functions

Functions
BOARD_exported_functions
AT32F413_board » BOARD

Functions

void | at32_board_init (void)
board initialize interface init led and button More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | at32_button_init (void)
configure button gpio More...
button_type | at32_button_press (void)
returns which button have press down More...
uint8_t | at32_button_state (void)
returns the selected button state More...
void | delay_init (void)
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...

Detailed Description

Function Documentation

◆ at32_board_init()

void at32_board_init ( void )

board initialize interface init led and button

Parameters
none
Return values
none

Definition at line 136 of file at32f413_board.c.

Referenced by main().

◆ at32_button_init()

void at32_button_init ( void )

configure button gpio

Parameters
button specifies the button to be configured.
Return values
none

< gpio pins number 0

Definition at line 158 of file at32f413_board.c.

Referenced by at32_board_init().

◆ at32_button_press()

button_type at32_button_press ( void )

returns which button have press down

Parameters
none
Return values
the button have press down

Definition at line 192 of file at32f413_board.c.

Referenced by main().

◆ at32_button_state()

uint8_t at32_button_state ( void )

returns the selected button state

Parameters
none
Return values
the button gpio pin value

< gpio pins number 0

Definition at line 182 of file at32f413_board.c.

Referenced by at32_button_press().

◆ at32_led_init()

void at32_led_init ( led_type led )

configure led gpio

Parameters
led specifies the led to be configured.
Return values
none

Definition at line 216 of file at32f413_board.c.

Referenced by at32_board_init(), and main().

◆ at32_led_off()

void at32_led_off ( led_type led )

turns selected led off.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 261 of file at32f413_board.c.

Referenced by at32_board_init(), main(), sd_test_error(), TAMPER_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_on()

void at32_led_on ( led_type led )

turns selected led on.

Parameters
led specifies the led to be set on. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 244 of file at32f413_board.c.

Referenced by DMA2_Channel1_IRQHandler(), main(), sd_test_error(), TAMPER_IRQHandler(), USART2_IRQHandler(), and usb_hid_buf_process().

◆ at32_led_toggle()

void at32_led_toggle ( led_type led )

turns selected led toggle.

Parameters
led specifies the led to be set off. this parameter can be one of following parameters:
  • LED2
  • LED3
  • LED4
Return values
none

Definition at line 278 of file at32f413_board.c.

Referenced by ACC_IRQHandler(), ADC1_2_IRQHandler(), error_handler(), EXINT0_IRQHandler(), EXINT4_IRQHandler(), led2_task_function(), led3_task_function(), main(), PVM_IRQHandler(), result_error(), RTC_IRQHandler(), RTCAlarm_IRQHandler(), spim_operate(), spim_run(), systick_handler(), TMR1_OVF_TMR10_IRQHandler(), TMR2_GLOBAL_IRQHandler(), TMR3_GLOBAL_IRQHandler(), USART1_IRQHandler(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ delay_init()

void delay_init ( void )

initialize delay function

Parameters
none
Return values
none

Definition at line 291 of file at32f413_board.c.

Referenced by at32_board_init(), sclk_192m_hick_config(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ delay_ms()

void delay_ms ( uint16_t nms )

inserts a delay time.

Parameters
nms specifies the delay time length, in milliseconds.
Return values
none

Definition at line 324 of file at32f413_board.c.

Referenced by at32_button_press(), button_isr(), delay_sec(), error_handler(), flash_fat16_loop_status(), FLASH_IRQHandler(), iap_loop(), main(), randnum_test(), sd_power_on(), sd_test_error(), spim_operate(), spim_run(), usb_delay_ms(), and usb_reset().

◆ delay_sec()

void delay_sec ( uint16_t sec )

inserts a delay time.

Parameters
sec specifies the delay time, in seconds.
Return values
none

Definition at line 356 of file at32f413_board.c.

Referenced by main(), and result_error().

◆ delay_us()

void delay_us ( uint32_t nus )

inserts a delay time.

Parameters
nus specifies the delay time length, in microsecond.
Return values
none

Definition at line 304 of file at32f413_board.c.

Referenced by main(), and usb_delay_us().

◆ uart_print_init()

void uart_print_init ( uint32_t baudrate )

initialize uart

Parameters
baudrate uart baudrate
Return values
none

< gpio pins number 9

Definition at line 107 of file at32f413_board.c.

Referenced by main().


AT32F413 Firmwary Library: AT32F413_periph_examples

Modules
AT32F413_periph_examples

Modules

ACC_calibration
ADC_combine_mode_ordinary_simult
ADC_current_vref_value_check
ADC_exint_trigger_partitioned
ADC_internal_temperature_sensor
ADC_software_trigger_repeat
ADC_tmr_trigger_automatic_preempted
ADC_voltage_monitoring
BPR_data
BPR_tamper
CAN_communication_mode
CAN_filter
CAN_loopback_mode
CORTEX_m4_bit_band
CORTEX_m4_cmsis_dsp
CORTEX_m4_fpu
CORTEX_m4_systick_interrupt
CRC_calculation
CRM_clock_failure_detection
CRM_sysclk_switch
DEBUG_tmr
DMA_data_to_gpio_flexible
DMA_flash_to_sram
EXINT_config
EXINT_software_trigger
FLASH_write_read
FLASH_operate_spim
FLASH_run_in_spim
GPIO_led_toggle
GPIO_swjtag_remap
I2C_communication_dma
I2C_communication_int
I2C_communication_poll
I2C_eeprom
I2S_halfduplex_dma
I2S_halfduplex_interrupt
I2S_spii2s_switch_halfduplex_polling
PWC_deepsleep_rtc
PWC_power_voltage_monitor
PWC_sleep_tmr2
PWC_sleep_usart1
PWC_standby_rtc
PWC_standby_wakeup_pin
RTC_calendar
RTC_lick_calibration
SDIO_sd_mmc_card
SDIO_sdio_fatfs
SPI_crc_transfer_polling
SPI_fullduplex_polling
SPI_halfduplex_interrupt
SPI_halfduplex_transceiver_switch
SPI_only_receive_mode_polling
SPI_use_jtagpin_hardwarecs_dma
SPI_w25q_flash
SRAM_extend_sram
TMR_6_steps
TMR_7_pwm_output
TMR_cascade_synchro
TMR_complementary_signals
TMR_dma
TMR_dma_burst
TMR_encoder_tmr2
TMR_external_clock
TMR_hall_xor_tmr2
TMR_hang_mode
TMR_input_capture
TMR_oc_high
TMR_oc_low
TMR_oc_toggle_tmr3
TMR_oc_toggle_tmr9
TMR_one_cycle
TMR_parallel_synchro
TMR_pwm_input
TMR_pwm_input_dma
TMR_pwm_output_simulate
TMR_pwm_output_tmr10
TMR_pwm_output_tmr3
TMR_timer_base
TMR_tmr1_synchro
TMR_tmr2_32bit
USART_half_duplex
USART_hw_flow_control
USART_idle_detection
USART_interrupt
USART_irda
USART_polling
USART_printf
USART_receiver_mute
F413_USART_rs485
USART_smartcard
USART_synchronous
USART_transfer_by_dma_interrupt
USART_transfer_by_dma_polling
USB_device_audio
USB_device_audio_hid
USB_device_composite_vcp_keyboard
USB_device_msc
USB_device_composite_vcp_msc
USB_device_custom_hid
USB_device_keyboard
USB_device_mouse
USB_device_printer
USB_device_vcp_loopback
USB_device_virtual_msc_iap
WDT_reset
WDT_standby
WWDT_reset
_USB_device_hid_app_led3
_USB_device_hid_iap

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: ACC_calibration

Macros | Functions | Variables
ACC_calibration
AT32F413_periph_examples

Macros

#define | EPT0_TX_ADDR 0x40
usb endpoint max num define More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00
#define | SCLK_FROM_HICK
#define | ACC_TRIM

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | system_clock_config_for_acc (void)
system clock config for acc More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
usbfs_l_can1_rx0 interrupt handler More...
void | ACC_IRQHandler (void)
acc interrupt handler More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
uint32_t | acc_c2_value = 0

Detailed Description

Macro Definition Documentation

◆ ACC_TRIM

#define ACC_TRIM

Definition at line 53 of file project/at_start_f413/examples/acc/calibration/src/main.c.

◆ EPT0_RX_ADDR

#define EPT0_RX_ADDR 0x80

Definition at line 75 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT0_TX_ADDR

#define EPT0_TX_ADDR 0x40

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer

user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size

Definition at line 74 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT1_RX_ADDR

#define EPT1_RX_ADDR 0x100

Definition at line 78 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT1_TX_ADDR

#define EPT1_TX_ADDR 0xC0

Definition at line 77 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT2_RX_ADDR

#define EPT2_RX_ADDR 0x180

Definition at line 81 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT2_TX_ADDR

#define EPT2_TX_ADDR 0x140

Definition at line 80 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT3_RX_ADDR

#define EPT3_RX_ADDR 0x00

Definition at line 84 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT3_TX_ADDR

#define EPT3_TX_ADDR 0x00

Definition at line 83 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT4_RX_ADDR

#define EPT4_RX_ADDR 0x00

Definition at line 87 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT4_TX_ADDR

#define EPT4_TX_ADDR 0x00

Definition at line 86 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT5_RX_ADDR

#define EPT5_RX_ADDR 0x00

Definition at line 90 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT5_TX_ADDR

#define EPT5_TX_ADDR 0x00

Definition at line 89 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT6_RX_ADDR

#define EPT6_RX_ADDR 0x00

Definition at line 93 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT6_TX_ADDR

#define EPT6_TX_ADDR 0x00

Definition at line 92 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT7_RX_ADDR

#define EPT7_RX_ADDR 0x00

Definition at line 96 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ EPT7_TX_ADDR

#define EPT7_TX_ADDR 0x00

Definition at line 95 of file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.

◆ SCLK_FROM_HICK

#define SCLK_FROM_HICK

Definition at line 49 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Function Documentation

◆ ACC_IRQHandler()

void ACC_IRQHandler ( void )

acc interrupt handler

Parameters
none
Return values
none

< acc internal high-speed clock calibration ready error flag

< acc internal high-speed clock calibration ready error flag

< acc reference signal lost error flag

< acc reference signal lost error flag

Definition at line 133 of file project/at_start_f413/examples/acc/calibration/src/main.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< acc internal high-speed clock calibration ready interrupt enable

< acc reference signal lost interrupt enable

< acc hick trim

Definition at line 268 of file project/at_start_f413/examples/acc/calibration/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ system_clock_config_for_acc()

void system_clock_config_for_acc ( void )

system clock config for acc

Parameters
none
Return values
none

< high speed internal clock stable flag

< phase locking loop stable flag

Definition at line 156 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 66 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by main().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

usbfs_l_can1_rx0 interrupt handler

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Variable Documentation

◆ acc_c2_value

uint32_t acc_c2_value = 0

Definition at line 58 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by acc_write_c2(), and main().

◆ usb_buffer

uint8_t usb_buffer[256]

Definition at line 45 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 44 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: ADC_combine_mode_ordinary_simult

Functions | Variables
ADC_combine_mode_ordinary_simult
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adc1_ordinary_valuetab [5][3]
__IO uint32_t | dma1_trans_complete_flag = 0

Detailed Description

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

Definition at line 100 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 144 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 72 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 51 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 144 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint32_t adc1_ordinary_valuetab[5][3]

Definition at line 39 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by dma_config(), and main().

◆ dma1_trans_complete_flag

__IO uint32_t dma1_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.

Referenced by DMA1_Channel1_IRQHandler(), and main().


AT32F413 Firmwary Library: ADC_current_vref_value_check

Functions | Variables
ADC_current_vref_value_check
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t adc1_ordinary_value = 0

Detailed Description

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

Definition at line 74 of file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 105 of file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_value

__IO uint16_t adc1_ordinary_value = 0

Definition at line 38 of file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.

Referenced by dma_config(), and main().


AT32F413 Firmwary Library: ADC_exint_trigger_partitioned

Functions | Variables
ADC_exint_trigger_partitioned
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | exint_config (void)
exint configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [3][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_trigger_count = 0

Detailed Description

Function Documentation

◆ ADC1_2_IRQHandler()

void ADC1_2_IRQHandler ( void )

this function handles adc1_2 handler.

Parameters
none
Return values
none

< preempt channels conversion end flag

< preempt channels conversion end flag

Definition at line 159 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< preempt channels conversion end interrupt

Definition at line 143 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 145 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 115 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ exint_config()

static void exint_config ( void )
static

exint configuration.

Parameters
none
Return values
none

< gpio pins number 11

< gpio pins number 15

< external interrupt line 11

< external interrupt line 15

Definition at line 75 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 54 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 185 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint16_t adc1_ordinary_valuetab[3][3] = {0}

Definition at line 39 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_preempt_valuetab

__IO uint16_t adc1_preempt_valuetab[3][3] = {0}

Definition at line 40 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ dma_trans_complete_flag

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 41 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by main().

◆ preempt_trigger_count

__IO uint16_t preempt_trigger_count = 0

Definition at line 42 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.

Referenced by ADC1_2_IRQHandler(), and main().


AT32F413 Firmwary Library: ADC_internal_temperature_sensor

Macros | Functions | Variables
ADC_internal_temperature_sensor
AT32F413_periph_examples

Macros

#define | ADC_VREF (3.3)
#define | ADC_TEMP_BASE (1.26)
#define | ADC_TEMP_SLOPE (-0.00423)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t adc1_ordinary_value = 0

Detailed Description

Macro Definition Documentation

◆ ADC_TEMP_BASE

#define ADC_TEMP_BASE (1.26)

Definition at line 40 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

◆ ADC_TEMP_SLOPE

#define ADC_TEMP_SLOPE (-0.00423)

Definition at line 41 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

◆ ADC_VREF

#define ADC_VREF (3.3)

Definition at line 39 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 110 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_value

__IO uint16_t adc1_ordinary_value = 0

Definition at line 43 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.

Referenced by dma_config(), and main().


AT32F413 Firmwary Library: ADC_software_trigger_repeat

Functions | Variables
ADC_software_trigger_repeat
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0

Detailed Description

Function Documentation

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 143 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 66 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 50 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint16_t adc1_ordinary_valuetab[10][3] = {0}

Definition at line 38 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

Referenced by dma_config(), and main().

◆ dma_trans_complete_flag

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 39 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: ADC_tmr_trigger_automatic_preempted

Functions | Variables
ADC_tmr_trigger_automatic_preempted
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0

Detailed Description

Function Documentation

◆ ADC1_2_IRQHandler()

void ADC1_2_IRQHandler ( void )

this function handles adc1_2 handler.

Parameters
none
Return values
none

< preempt channels conversion end flag

< preempt channels conversion end flag

Definition at line 160 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< preempt channels conversion end interrupt

Definition at line 141 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1_channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 146 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 74 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 53 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 185 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 102 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint16_t adc1_ordinary_valuetab[5][3] = {0}

Definition at line 38 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by dma_config(), and main().

◆ adc1_preempt_valuetab

__IO uint16_t adc1_preempt_valuetab[5][3] = {0}

Definition at line 39 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by ADC1_2_IRQHandler(), and main().

◆ dma_trans_complete_flag

__IO uint16_t dma_trans_complete_flag = 0

Definition at line 40 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by DMA1_Channel1_IRQHandler(), and main().

◆ preempt_conversion_count

__IO uint16_t preempt_conversion_count = 0

Definition at line 41 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.

Referenced by ADC1_2_IRQHandler(), and main().


AT32F413 Firmwary Library: ADC_voltage_monitoring

Functions | Variables
ADC_voltage_monitoring
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | vmor_flag_index = 0

Detailed Description

Function Documentation

◆ ADC1_2_IRQHandler()

void ADC1_2_IRQHandler ( void )

this function handles adc1_2 handler.

Parameters
none
Return values
none

< voltage monitoring out of range flag

< voltage monitoring out of range flag

Definition at line 145 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ adc_config()

static void adc_config ( void )
static

adc configuration.

Parameters
none
Return values
none

< voltage monitoring out of range interrupt

Definition at line 92 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ dma_config()

static void dma_config ( void )
static

dma configuration.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 6

Definition at line 50 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.

Variable Documentation

◆ adc1_ordinary_valuetab

__IO uint16_t adc1_ordinary_valuetab[3] = {0}

Definition at line 38 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by dma_config(), and main().

◆ vmor_flag_index

__IO uint16_t vmor_flag_index = 0

Definition at line 39 of file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.

Referenced by ADC1_2_IRQHandler(), and main().


AT32F413 Firmwary Library: BPR_data

Macros | Functions | Variables
BPR_data
AT32F413_periph_examples

Macros

#define BPR_DR_NUMBER 42

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
int | main (void)
main function. More...

Variables

bpr_data_type bpr_addr_tab [42]

Detailed Description

Macro Definition Documentation

◆ BPR_DR_NUMBER

#define BPR_DR_NUMBER 42

Definition at line 38 of file project/at_start_f413/examples/bpr/bpr_data/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< bpr tamper event flag

Definition at line 100 of file project/at_start_f413/examples/bpr/bpr_data/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 45 of file app_led3_toggle/src/usart.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.

Variable Documentation

◆ bpr_addr_tab

bpr_data_type bpr_addr_tab[42]
Initial value:
=
{
BPR_DATA1, BPR_DATA2, BPR_DATA3, BPR_DATA4, BPR_DATA5,
BPR_DATA6, BPR_DATA7, BPR_DATA8, BPR_DATA9, BPR_DATA10,
BPR_DATA11, BPR_DATA12, BPR_DATA13, BPR_DATA14, BPR_DATA15,
BPR_DATA16, BPR_DATA17, BPR_DATA18, BPR_DATA19, BPR_DATA20,
BPR_DATA21, BPR_DATA22, BPR_DATA23, BPR_DATA24, BPR_DATA25,
BPR_DATA26, BPR_DATA27, BPR_DATA28, BPR_DATA29, BPR_DATA30,
BPR_DATA31, BPR_DATA32, BPR_DATA33, BPR_DATA34, BPR_DATA35,
BPR_DATA36, BPR_DATA37, BPR_DATA38, BPR_DATA39, BPR_DATA40,
BPR_DATA41, BPR_DATA42
}
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:93
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:95
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:98
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:75
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:92
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:106
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:74
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:79
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:96
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:86
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:68
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:103
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:76
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:77
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:94
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:87
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:105
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:104
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:108
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:80
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:71
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:99
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:83
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:78
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:91
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:90
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:72
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:85
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:84
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:109
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:88
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:100
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:107
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:97
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:69
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:81
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:82
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:70
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:89
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:101
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:102
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:73

Definition at line 40 of file project/at_start_f413/examples/bpr/bpr_data/src/main.c.

Referenced by bpr_reg_check(), and bpr_reg_write().


AT32F413 Firmwary Library: BPR_tamper

Macros | Functions | Variables
BPR_tamper
AT32F413_periph_examples

Macros

#define BPR_DR_NUMBER 42

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMPER_IRQHandler (void)
this function handles tamper interrupt request. More...
void | bpr_reg_write (void)
write data to bpr dt registers. More...
uint8_t | bpr_reg_check (void)
checks if the bpr dt registers values are correct or not. More...
uint32_t | bpr_reg_judge (void)
checks if the bpr dt registers are reset or not. More...
int | main (void)
main function. More...

Variables

bpr_data_type bpr_addr_tab [42]

Detailed Description

Macro Definition Documentation

◆ BPR_DR_NUMBER

#define BPR_DR_NUMBER 42

Definition at line 38 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Function Documentation

◆ bpr_reg_check()

uint8_t bpr_reg_check ( void )

checks if the bpr dt registers values are correct or not.

Parameters
none.
Return values
- TRUE: all bpr dt registers values are correct
  • FALSE: number of the bpr register which value is not correct

Definition at line 80 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Referenced by main().

◆ bpr_reg_judge()

uint32_t bpr_reg_judge ( void )

checks if the bpr dt registers are reset or not.

Parameters
none
Return values
- 0: all bpr dt registers are reset
  • value different from 0: number of the first bpr register not reset

Definition at line 103 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Referenced by TAMPER_IRQHandler().

◆ bpr_reg_write()

void bpr_reg_write ( void )

write data to bpr dt registers.

Parameters
none.
Return values
none

Definition at line 62 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< bpr tamper event flag

Definition at line 123 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ TAMPER_IRQHandler()

void TAMPER_IRQHandler ( void )

this function handles tamper interrupt request.

Parameters
none
Return values
none

< bpr tamper interrupt flag

< bpr tamper interrupt flag

< bpr tamper event flag

Definition at line 143 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.

Variable Documentation

◆ bpr_addr_tab

bpr_data_type bpr_addr_tab[42]
Initial value:
=
{
BPR_DATA1, BPR_DATA2, BPR_DATA3, BPR_DATA4, BPR_DATA5,
BPR_DATA6, BPR_DATA7, BPR_DATA8, BPR_DATA9, BPR_DATA10,
BPR_DATA11, BPR_DATA12, BPR_DATA13, BPR_DATA14, BPR_DATA15,
BPR_DATA16, BPR_DATA17, BPR_DATA18, BPR_DATA19, BPR_DATA20,
BPR_DATA21, BPR_DATA22, BPR_DATA23, BPR_DATA24, BPR_DATA25,
BPR_DATA26, BPR_DATA27, BPR_DATA28, BPR_DATA29, BPR_DATA30,
BPR_DATA31, BPR_DATA32, BPR_DATA33, BPR_DATA34, BPR_DATA35,
BPR_DATA36, BPR_DATA37, BPR_DATA38, BPR_DATA39, BPR_DATA40,
BPR_DATA41, BPR_DATA42
}
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:93
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:95
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:98
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:75
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:92
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:106
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:74
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:79
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:96
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:86
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:68
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:103
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:76
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:77
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:94
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:87
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:105
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:104
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:108
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:80
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:71
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:99
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:83
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:78
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:91
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:90
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:72
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:85
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:84
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:109
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:88
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:100
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:107
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:97
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:69
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:81
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:82
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:70
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:89
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:101
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:102
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:73

Definition at line 40 of file project/at_start_f413/examples/bpr/tamper/src/main.c.

Referenced by bpr_reg_check(), bpr_reg_judge(), and bpr_reg_write().


AT32F413 Firmwary Library: CAN_communication_mode

Functions
CAN_communication_mode
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ CAN1_SE_IRQHandler()

void CAN1_SE_IRQHandler ( void )

can1 interrupt function se

Parameters
none
Return values
none

< error type record flag

< error type record flag

Definition at line 168 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

◆ can_configuration()

static void can_configuration ( void )
static

can configiguration.

Parameters
none
Return values
none

< receive fifo 0 message interrupt

< error type record interrupt

< error occur interrupt

Definition at line 72 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

Referenced by main().

◆ can_gpio_config()

static void can_gpio_config ( void )
static

can gpio config

Parameters
none
Return values
none

< can_rx(pb8), can_tx(pb9)

< gpio pins number 9

< gpio pins number 8

Definition at line 43 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

Referenced by main().

◆ can_transmit_data()

static void can_transmit_data ( void )
static

can transmit data

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 189 of file project/at_start_f413/examples/can/communication_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

can1 interrupt function rx0

Parameters
none
Return values
none

< receive fifo 0 message num flag

Definition at line 150 of file project/at_start_f413/examples/can/communication_mode/src/main.c.


AT32F413 Firmwary Library: CAN_filter

Macros | Functions | Variables
CAN_filter
AT32F413_periph_examples

Macros

#define | FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
#define | FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
#define | FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
#define | FILTER_STD_ID1 ((uint16_t)0x04F6)
#define | FILTER_STD_ID2 ((uint16_t)0x04F7)
#define | FILTER_STD_ID3 ((uint16_t)0x04F8)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Variables

uint8_t test_result = 0

Detailed Description

Macro Definition Documentation

◆ FILTER_EXT_ID1

#define FILTER_EXT_ID1 ((uint32_t)0x18F5F100)

Definition at line 39 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_EXT_ID2

#define FILTER_EXT_ID2 ((uint32_t)0x18F5F200)

Definition at line 40 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_EXT_ID3

#define FILTER_EXT_ID3 ((uint32_t)0x18F5F300)

Definition at line 41 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_STD_ID1

#define FILTER_STD_ID1 ((uint16_t)0x04F6)

Definition at line 44 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_STD_ID2

#define FILTER_STD_ID2 ((uint16_t)0x04F7)

Definition at line 45 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ FILTER_STD_ID3

#define FILTER_STD_ID3 ((uint16_t)0x04F8)

Definition at line 46 of file project/at_start_f413/examples/can/filter/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ CAN1_SE_IRQHandler()

void CAN1_SE_IRQHandler ( void )

can1 interrupt function se

Parameters
none
Return values
none

< error type record flag

< error type record flag

Definition at line 290 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ can_configuration()

static void can_configuration ( void )
static

can configiguration.

Parameters
none
Return values
none

< receive fifo 0 message interrupt

< error type record interrupt

< error occur interrupt

Definition at line 85 of file project/at_start_f413/examples/can/filter/src/main.c.

Referenced by main().

◆ can_gpio_config()

static void can_gpio_config ( void )
static

can gpio config

Parameters
none
Return values
none

< can_rx(pb8), can_tx(pb9)

< gpio pins number 9

< gpio pins number 8

Definition at line 54 of file project/at_start_f413/examples/can/filter/src/main.c.

Referenced by main().

◆ can_transmit_data()

static void can_transmit_data ( void )
static

can transmit data

Parameters
none
Return values
none

Definition at line 149 of file project/at_start_f413/examples/can/filter/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 311 of file project/at_start_f413/examples/can/filter/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/can/filter/src/at32f413_int.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

can1 interrupt function rx0

Parameters
none
Return values
none

< receive fifo 0 message num flag

Definition at line 262 of file project/at_start_f413/examples/can/filter/src/main.c.

Variable Documentation

◆ test_result

uint8_t test_result = 0

Definition at line 48 of file project/at_start_f413/examples/can/filter/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: CAN_loopback_mode

Functions
CAN_loopback_mode
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ CAN1_SE_IRQHandler()

void CAN1_SE_IRQHandler ( void )

can1 interrupt function se

Parameters
none
Return values
none

< error type record flag

< error type record flag

Definition at line 166 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

◆ can_configuration()

static void can_configuration ( void )
static

can configiguration.

Parameters
none
Return values
none

< receive fifo 0 message interrupt

< error type record interrupt

< error occur interrupt

Definition at line 72 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

Referenced by main().

◆ can_gpio_config()

static void can_gpio_config ( void )
static

can gpio config

Parameters
none
Return values
none

< can_rx(pb8), can_tx(pb9)

< gpio pins number 9

< gpio pins number 8

Definition at line 43 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

Referenced by main().

◆ can_transmit_data()

static void can_transmit_data ( void )
static

can transmit data

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 187 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

can1 interrupt function rx0

Parameters
none
Return values
none

< receive fifo 0 message num flag

Definition at line 150 of file project/at_start_f413/examples/can/loopback_mode/src/main.c.


AT32F413 Firmwary Library: CORTEX_m4_bit_band

Macros | Functions | Variables
CORTEX_m4_bit_band
AT32F413_periph_examples

Macros

#define | RAM_BASE 0x20000000
#define | RAM_BITBAND_BASE 0x22000000
#define | VARIABLES_RESET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | VARIABLES_SET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
#define | VARIABLES_GET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
#define | PERIPHERAL_BASE 0x40000000
#define | PERIPHERAL_BITBAND_BASE 0x42000000
#define | PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | PERIPHERAL_SET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | result_error (void)
led4 flick for error. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | variables
__IO uint32_t | variables_addr = 0
__IO uint32_t | variables_bit_val = 0

Detailed Description

Macro Definition Documentation

◆ PERIPHERAL_BASE

#define PERIPHERAL_BASE 0x40000000

Definition at line 53 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_BITBAND_BASE

#define PERIPHERAL_BITBAND_BASE 0x42000000

Definition at line 54 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_RESET_BIT

#define PERIPHERAL_RESET_BIT | ( | peripheral_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)

Definition at line 56 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ PERIPHERAL_SET_BIT

#define PERIPHERAL_SET_BIT | ( | peripheral_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Definition at line 59 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ RAM_BASE

#define RAM_BASE 0x20000000

Definition at line 40 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ RAM_BITBAND_BASE

#define RAM_BITBAND_BASE 0x22000000

Definition at line 41 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_GET_BIT

#define VARIABLES_GET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))

Definition at line 49 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_RESET_BIT

#define VARIABLES_RESET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)

Definition at line 43 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ VARIABLES_SET_BIT

#define VARIABLES_SET_BIT | ( | variables_addr,
 |  | bit_number
 | ) | (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)

Definition at line 46 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ result_error()

void result_error ( void )

led4 flick for error.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.

Variable Documentation

◆ variables

__IO uint32_t variables

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

Referenced by main().

◆ variables_addr

__IO uint32_t variables_addr = 0

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.

Referenced by main().

◆ variables_bit_val

__IO uint32_t variables_bit_val = 0

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.


AT32F413 Firmwary Library: CORTEX_m4_cmsis_dsp

Macros | Functions | Variables
CORTEX_m4_cmsis_dsp
AT32F413_periph_examples

Macros

#define | USE_STATIC_INIT
#define | TEST_LENGTH_SAMPLES (20*4)
#define | NUMSTUDENTS 20
#define | NUMSUBJECTS 4

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int32_t | main ()
main function. More...

Variables

const float32_t | testMarks_f32 [(20 *4)]
const float32_t | testUnity_f32 [4]
static float32_t | testOutput [(20 *4)]
uint32_t | numStudents = 20
uint32_t | numSubjects = 4
float32_t | max_marks
float32_t | min_marks
float32_t | mean
float32_t | std
float32_t | var
uint32_t | student_num

Detailed Description

Macro Definition Documentation

◆ NUMSTUDENTS

#define NUMSTUDENTS 20

Definition at line 83 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ NUMSUBJECTS

#define NUMSUBJECTS 4

Definition at line 84 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ TEST_LENGTH_SAMPLES

#define TEST_LENGTH_SAMPLES (20*4)

Definition at line 43 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ USE_STATIC_INIT

#define USE_STATIC_INIT

Definition at line 39 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ main()

int32_t main ( void )

main function.

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.

Variable Documentation

◆ max_marks

float32_t max_marks

Definition at line 90 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ mean

float32_t mean

Definition at line 90 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ min_marks

float32_t min_marks

Definition at line 90 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ numStudents

uint32_t numStudents = 20

Definition at line 88 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ numSubjects

uint32_t numSubjects = 4

Definition at line 89 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ std

float32_t std

Definition at line 90 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ student_num

uint32_t student_num

Definition at line 91 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ testMarks_f32

const float32_t testMarks_f32[(20 *4)]
Initial value:
=
{
42.000000, 37.000000, 81.000000, 28.000000,
83.000000, 72.000000, 36.000000, 38.000000,
32.000000, 51.000000, 63.000000, 64.000000,
97.000000, 82.000000, 95.000000, 90.000000,
66.000000, 51.000000, 54.000000, 42.000000,
67.000000, 56.000000, 45.000000, 57.000000,
67.000000, 69.000000, 35.000000, 52.000000,
29.000000, 81.000000, 58.000000, 47.000000,
38.000000, 76.000000, 100.000000, 29.000000,
33.000000, 47.000000, 29.000000, 50.000000,
34.000000, 41.000000, 61.000000, 46.000000,
52.000000, 50.000000, 48.000000, 36.000000,
47.000000, 55.000000, 44.000000, 40.000000,
100.000000, 94.000000, 84.000000, 37.000000,
32.000000, 71.000000, 47.000000, 77.000000,
31.000000, 50.000000, 49.000000, 35.000000,
63.000000, 67.000000, 40.000000, 31.000000,
29.000000, 68.000000, 61.000000, 38.000000,
31.000000, 28.000000, 28.000000, 76.000000,
55.000000, 33.000000, 29.000000, 39.000000
}

Definition at line 46 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ testOutput

float32_t testOutput[(20 *4)]
static

Definition at line 79 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ testUnity_f32

const float32_t testUnity_f32[4]
Initial value:
=
{
1.000, 1.000, 1.000, 1.000
}

Definition at line 72 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().

◆ var

float32_t var

Definition at line 90 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: CORTEX_m4_fpu

Modules | Macros | Functions | Variables
CORTEX_m4_fpu
AT32F413_periph_examples

Modules

JULIA_fpu_functions

Macros

#define | ITERATION 200
#define | REAL_CONSTANT (0.285f)
#define | IMG_CONSTANT (0.01f)
#define | SCREEN_X_SIZE ((uint16_t)160)
#define | SCREEN_Y_SIZE ((uint16_t)120)
#define | ZOOM ((uint16_t)100)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...
int | main (void)
main function. More...

Variables

uint8_t buffer [((uint16_t) 160) *((uint16_t) 120)]

Detailed Description

Macro Definition Documentation

◆ IMG_CONSTANT

#define IMG_CONSTANT (0.01f)

Definition at line 47 of file julia_fpu.h.

◆ ITERATION

#define ITERATION 200

Definition at line 45 of file julia_fpu.h.

◆ REAL_CONSTANT

#define REAL_CONSTANT (0.285f)

Definition at line 46 of file julia_fpu.h.

◆ SCREEN_X_SIZE

#define SCREEN_X_SIZE ((uint16_t)160)

Definition at line 39 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

◆ SCREEN_Y_SIZE

#define SCREEN_Y_SIZE ((uint16_t)120)

Definition at line 40 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

◆ ZOOM

#define ZOOM ((uint16_t)100)

Definition at line 41 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ generate_julia_fpu()

void generate_julia_fpu | ( | uint16_t | size_x,
 |  | uint16_t | size_y,
 |  | uint16_t | offset_x,
 |  | uint16_t | offset_y,
 |  | uint16_t | zoom,
 |  | uint8_t * | buffer
 | ) |  |

julia calculation test with fpu option enable or disable

Parameters
size_x | width in pixel
size_y | height in pixel
offset_x | x offset for starting point
offset_y | y offset for starting point
zoom | iteration zoom ratio
buffer | pointer to output buffer where values are stored
Return values
none

Definition at line 48 of file julia_fpu.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.

Variable Documentation

◆ buffer

uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]

Definition at line 43 of file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.

Referenced by audio_codec_mic_get_data(), bot_scsi_send_data(), generate_julia_fpu(), main(), memset16_buffer(), usbd_ctrl_recv(), usbd_ctrl_send(), usbd_ept_recv(), and usbd_ept_send().


AT32F413 Firmwary Library: JULIA_fpu_functions

Functions
JULIA_fpu_functions
AT32F413_periph_examples » CORTEX_m4_fpu

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

Function Documentation

◆ generate_julia_fpu()

void generate_julia_fpu | ( | uint16_t | size_x,
 |  | uint16_t | size_y,
 |  | uint16_t | offset_x,
 |  | uint16_t | offset_y,
 |  | uint16_t | zoom,
 |  | uint8_t * | buffer
 | ) |  |

julia calculation test with fpu option enable or disable

Parameters
size_x | width in pixel
size_y | height in pixel
offset_x | x offset for starting point
offset_y | y offset for starting point
zoom | iteration zoom ratio
buffer | pointer to output buffer where values are stored
Return values
none

Definition at line 48 of file julia_fpu.c.

Referenced by main().


AT32F413 Firmwary Library: CORTEX_m4_systick_interrupt

Macros | Functions
CORTEX_m4_systick_interrupt
AT32F413_periph_examples

Macros

#define | MS_TICK (system_core_clock / 1000U)
#define | DELAY 200 /* 200 ms ticks */

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | systick_handler (void)
systick interrupt handler. More...
int | main (void)
main function. More...

Detailed Description

Macro Definition Documentation

◆ DELAY

#define DELAY 200 /* 200 ms ticks */

Definition at line 39 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.

◆ MS_TICK

#define MS_TICK (system_core_clock / 1000U)

Definition at line 38 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.

◆ systick_handler()

void systick_handler ( void )

systick interrupt handler.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.

Referenced by SysTick_Handler().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: CRC_calculation

Macros | Functions | Variables
CRC_calculation
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 120

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

static const uint32_t | data_buffer [120]
__IO uint32_t | crc_value = 0

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 120

Definition at line 38 of file project/at_start_f413/examples/crc/calculation/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f413/examples/crc/calculation/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.

Variable Documentation

◆ crc_value

__IO uint32_t crc_value = 0

Definition at line 64 of file project/at_start_f413/examples/crc/calculation/src/main.c.

Referenced by iap_crc(), and main().

◆ data_buffer

const uint32_t data_buffer[120]
static
Initial value:
=
{
0xc33dd31c, 0xe37ff35e, 0x129022f3, 0x32d24235, 0x52146277, 0x7256b5ea,
0x4a755a54, 0x6a377a16, 0x0af11ad0, 0x2ab33a92, 0xed0fdd6c, 0xcd4dbdaa,
0xbb3bab1a, 0x6ca67c87, 0x5cc52c22, 0x3c030c60, 0x1c41edae, 0xfd8fcdec,
0xad8b9de8, 0x8dc97c26, 0x5c644c45, 0x3ca22c83, 0x1ce00cc1, 0xef1fff3e,
0x95a88589, 0xf56ee54f, 0xd52cc50d, 0x34e224c3, 0x04817466, 0x64475424,
0x78066827, 0x18c008e1, 0x28a3cb7d, 0xdb5ceb3f, 0xfb1e8bf9, 0x9bd8abbb,
0xdf7caf9b, 0xbfba8fd9, 0x9ff86e17, 0x7e364e55, 0x2e933eb2, 0x0ed11ef0,
0xa35ad3bd, 0xc39cf3ff, 0xe3de2462, 0x34430420, 0x64e674c7, 0x44a45485,
0xad2abd0b, 0x8d689d49, 0x7e976eb6, 0x5ed54ef4, 0x2e321e51, 0x0e70ff9f,
0xefbedfdd, 0xcffcbf1b, 0x9f598f78, 0x918881a9, 0xb1caa1eb, 0xd10cc12d,
0xe16f1080, 0x00a130c2, 0x20e35004, 0x40257046, 0x83b99398, 0xa3fbb3da,
0x00001021, 0x20423063, 0x408450a5, 0x60c670e7, 0x9129a14a, 0xb16bc18c,
0x569546b4, 0xb75ba77a, 0x97198738, 0xf7dfe7fe, 0xc7bc48c4, 0x58e56886,
0x4405a7db, 0xb7fa8799, 0xe75ff77e, 0xc71dd73c, 0x26d336f2, 0x069116b0,
0x76764615, 0x5634d94c, 0xc96df90e, 0xe92f99c8, 0xb98aa9ab, 0x58444865,
0x78a70840, 0x18612802, 0xc9ccd9ed, 0xe98ef9af, 0x89489969, 0xa90ab92b,
0xd1ade1ce, 0xf1ef1231, 0x32732252, 0x52b54294, 0x72f762d6, 0x93398318,
0xa56ab54b, 0x85289509, 0xf5cfc5ac, 0xd58d3653, 0x26721611, 0x063076d7,
0x8d689d49, 0xf7dfe7fe, 0xe98ef9af, 0x063076d7, 0x93398318, 0xb98aa9ab,
0x4ad47ab7, 0x6a961a71, 0x0a503a33, 0x2a12dbfd, 0xfbbfeb9e, 0x9b798b58
}

Definition at line 40 of file project/at_start_f413/examples/crc/calculation/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: CRM_clock_failure_detection

Functions
CRM_clock_failure_detection
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | clkout_config (void)
clkout configuration. More...
static void | sclk_192m_hick_config (void)
config sclk 192 mhz with hick clock source. More...
void | clock_failure_detection_handler (void)
clock failure detection handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ clkout_config()

static void clkout_config ( void )
static

clkout configuration.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 47 of file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.

Referenced by main(), and sclk_192m_hick_config().

◆ clock_failure_detection_handler()

void clock_failure_detection_handler ( void )

clock failure detection handler.

Parameters
none
Return values
none

< clock failure interrupt ready flag

< clock failure interrupt ready flag

Definition at line 76 of file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.

Referenced by NMI_Handler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 171 of file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ sclk_192m_hick_config()

static void sclk_192m_hick_config ( void )
static

config sclk 192 mhz with hick clock source.

Note
the system clock is configured as follow:
  • system clock = hick / 2 * pll_mult
  • system clock source = pll (hick)
  • hick = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< high speed internal clock stable flag

< phase locking loop stable flag

Definition at line 110 of file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.

Referenced by clock_failure_detection_handler().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.


AT32F413 Firmwary Library: CRM_sysclk_switch

Functions
CRM_sysclk_switch
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | clkout_config (void)
clkout configuration. More...
static void | sclk_64m_hick_config (void)
config sclk 64 mhz with hick clock source. More...
static void | sclk_96m_hext_config (void)
config sclk 96 mhz with hext clock source. More...
static void | switch_system_clock (void)
sclk switch function. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ clkout_config()

static void clkout_config ( void )
static

clkout configuration.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 48 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

Referenced by main(), sclk_64m_hick_config(), and sclk_96m_hext_config().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 242 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ sclk_64m_hick_config()

static void sclk_64m_hick_config ( void )
static

config sclk 64 mhz with hick clock source.

Note
the system clock is configured as follow:
  • system clock = hick / 2 * pll_mult
  • system clock source = pll (hick)
  • hick = 8000000
  • sclk = 64000000
  • ahbdiv = 1
  • ahbclk = 64000000
  • apb2div = 2
  • apb2clk = 32000000
  • apb1div = 2
  • apb1clk = 32000000
  • pll_mult = 16
  • pll_range = LE72MHZ (less equal 72 mhz)
Parameters
none
Return values
none

< high speed internal clock stable flag

< phase locking loop stable flag

Definition at line 107 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

Referenced by switch_system_clock().

◆ sclk_96m_hext_config()

static void sclk_96m_hext_config ( void )
static

config sclk 96 mhz with hext clock source.

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hick = 8000000
  • sclk = 96000000
  • ahbdiv = 1
  • ahbclk = 96000000
  • apb2div = 2
  • apb2clk = 48000000
  • apb1div = 2
  • apb1clk = 48000000
  • pll_mult = 24
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 181 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

Referenced by switch_system_clock().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ switch_system_clock()

static void switch_system_clock ( void )
static

sclk switch function.

Parameters
none
Return values
none

Definition at line 77 of file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.


AT32F413 Firmwary Library: DEBUG_tmr

Functions | Variables
DEBUG_tmr
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles tmr1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | counter = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< debug timer1 pause

< tmr interrupt overflow

Definition at line 62 of file project/at_start_f413/examples/debug/tmr1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

this function handles tmr1 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 47 of file project/at_start_f413/examples/debug/tmr1/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.

Variable Documentation

◆ counter

uint16_t counter = 0

Definition at line 40 of file project/at_start_f413/examples/debug/tmr1/src/main.c.

Referenced by can_receive_error_counter_get(), can_transmit_error_counter_get(), and main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/debug/tmr1/src/main.c.

Referenced by main(), tmr1_config(), tmr2_config(), and tmr_init().


AT32F413 Firmwary Library: DMA_data_to_gpio_flexible

Macros | Functions | Variables
DMA_data_to_gpio_flexible
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA2_Channel1_IRQHandler (void)
this function handles DMA2 channel1 handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type | dma_init_struct = {0}
uint16_t | src_buffer [16]

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 16

Definition at line 41 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ DMA2_Channel1_IRQHandler()

void DMA2_Channel1_IRQHandler ( void )

this function handles DMA2 channel1 handler.

Parameters
none
Return values
none

< dma2 channel1 full data transfer flag

< dma2 channel1 full data transfer flag

Definition at line 50 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< jtag-dp disabled and sw-dp enabled

< jtag-dp disabled and sw-dp enabled

< gpio all pins

< dma full data transfer interrupt

< dma flexible channel1

Definition at line 67 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.

Variable Documentation

◆ dma_init_struct

dma_init_type dma_init_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

Referenced by codec_i2s_init(), dma_config(), dma_configuration(), dma_default_para_init(), dma_init(), i2s_config(), main(), sd_dma_config(), spi_bytes_read(), spi_bytes_write(), and spi_config().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

Referenced by at32_button_init(), at32_led_init(), can_gpio_config(), clkout_config(), codec_i2s_init(), gpio_configuration(), gpio_default_para_init(), gpio_init(), main(), mclk_tmr1_init(), rs485_config(), sd_init(), spim_init(), swj_dp_config(), uart_init(), uart_print_init(), usart1_config(), usart_configuration(), usart_gpio_config(), and usart_spi_configuration().

◆ src_buffer

uint16_t src_buffer[16]
Initial value:
= {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
0x0009, 0x000A, 0x000B, 0x000C, 0x000D, 0x000E, 0x000F, 0x0010}

Definition at line 42 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: DMA_flash_to_sram

Macros | Functions | Variables
DMA_flash_to_sram
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
error_status | buffer_compare (const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
gpio_init_type | gpio_init_struct = {0}
dma_init_type | dma_init_struct = {0}
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 39 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | const uint32_t * | pbuffer,
 |  | uint32_t * | pbuffer1,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer,pbuffer1 | buffers to be compared.
buffer_length | buffer's length
Return values
SUCCESS pbuffer identical to pbuffer1 ERROR: pbuffer differs from pbuffer1

Definition at line 78 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1 channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 62 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 99 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.

Variable Documentation

◆ data_counter_end

__IO uint32_t data_counter_end = 0x01

Definition at line 52 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by DMA1_Channel1_IRQHandler(), and main().

◆ dma_init_struct

dma_init_type dma_init_struct = {0}

Definition at line 51 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ dst_buffer

uint32_t dst_buffer[32]

Definition at line 49 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 50 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

◆ src_const_buffer

const uint32_t src_const_buffer[32]
Initial value:
= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80}

Definition at line 41 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().

◆ transfer_status

error_status transfer_status = ERROR

Definition at line 53 of file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: EXINT_config

Functions
EXINT_config
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | exint_line0_config (void)
exint line0 config. configure pa0 in interrupt mode More...
int | main (void)
main function. More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

< external interrupt line 0

< external interrupt line 0

Definition at line 96 of file project/at_start_f413/examples/exint/exint_config/src/main.c.

◆ exint_line0_config()

void exint_line0_config ( void )

exint line0 config. configure pa0 in interrupt mode

Parameters
None
Return values
None

< external interrupt line 0

Definition at line 71 of file project/at_start_f413/examples/exint/exint_config/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f413/examples/exint/exint_config/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.


AT32F413 Firmwary Library: EXINT_software_trigger

Functions
EXINT_software_trigger
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | exint_line4_config (void)
exint line4 config. configure pa0 in interrupt mode More...
static void | tmr1_config (void)
tmr1 configuration. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
tmr1 interrupt handler More...
void | EXINT4_IRQHandler (void)
exint4 interrupt handler More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ EXINT4_IRQHandler()

void EXINT4_IRQHandler ( void )

exint4 interrupt handler

Parameters
none
Return values
none

< external interrupt line 4

< external interrupt line 4

Definition at line 106 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

◆ exint_line4_config()

void exint_line4_config ( void )

exint line4 config. configure pa0 in interrupt mode

Parameters
None
Return values
None

< external interrupt line 4

Definition at line 48 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.

◆ tmr1_config()

static void tmr1_config ( void )
static

tmr1 configuration.

Parameters
none
Return values
none

< tmr interrupt overflow

Definition at line 69 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

Referenced by main().

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

tmr1 interrupt handler

Parameters
none
Return values
none

< tmr flag overflow

< external interrupt line 4

< tmr flag overflow

Definition at line 91 of file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.


AT32F413 Firmwary Library: FLASH_write_read

Modules | Macros | Functions | Variables
FLASH_write_read
AT32F413_periph_examples

Modules

FLASH_write_read_functions

Macros

#define | SECTOR_SIZE 2048 /* this parameter depends on the specific model of the chip */
#define | TEST_BUFEER_SIZE 3000
#define | TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 16)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
void | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
void | flash_write (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode with checking More...
int | main (void)
main function. More...

Variables

uint16_t | flash_buf [2048/2]
uint16_t | buffer_write [3000]
uint16_t | buffer_read [3000]

Detailed Description

Macro Definition Documentation

◆ SECTOR_SIZE

#define SECTOR_SIZE 2048 /* this parameter depends on the specific model of the chip */

Definition at line 38 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

◆ TEST_BUFEER_SIZE

#define TEST_BUFEER_SIZE 3000

Definition at line 39 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

◆ TEST_FLASH_ADDRESS_START

#define TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 16)

Definition at line 40 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ flash_read()

void flash_read | ( | uint32_t | read_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_read
 | ) |  |

read data using halfword mode

Parameters
read_addr | the address of reading
p_buffer | the buffer of reading data
num_read | the number of reading data
Return values
none

Definition at line 49 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write(), and main().

◆ flash_write()

void flash_write | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode with checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
none

Definition at line 83 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by main().

◆ flash_write_nocheck()

void flash_write_nocheck | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode without checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
none

Definition at line 66 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.

Variable Documentation

◆ buffer_read

uint16_t buffer_read[3000]

Definition at line 43 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

Referenced by main().

◆ buffer_write

uint16_t buffer_write[3000]

Definition at line 42 of file project/at_start_f413/examples/flash/flash_write_read/src/main.c.

Referenced by main().

◆ flash_buf

uint16_t flash_buf[2048/2]

Definition at line 40 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().


AT32F413 Firmwary Library: FLASH_write_read_functions

Functions
FLASH_write_read_functions
AT32F413_periph_examples » FLASH_write_read

Functions

void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
void | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
void | flash_write (uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking More...

Detailed Description

Function Documentation

◆ flash_read()

void flash_read | ( | uint32_t | read_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_read
 | ) |  |

read data using halfword mode

Parameters
read_addr | the address of reading
p_buffer | the buffer of reading data
num_read | the number of reading data
Return values
none

Definition at line 49 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write(), and main().

◆ flash_write()

void flash_write | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode with checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
none

Definition at line 83 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by main().

◆ flash_write_nocheck()

void flash_write_nocheck | ( | uint32_t | write_addr,
 |  | uint16_t * | p_buffer,
 |  | uint16_t | num_write
 | ) |  |

write data using halfword mode without checking

Parameters
write_addr | the address of writing
p_buffer | the buffer of writing data
num_write | the number of writing data
Return values
none

Definition at line 66 of file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.

Referenced by flash_write().


AT32F413 Firmwary Library: FLASH_operate_spim

Modules | Macros | Functions | Variables
FLASH_operate_spim
AT32F413_periph_examples

Modules

FLASH_operate_spim_functions

Macros

#define | SPIM_SECTOR_SIZE 4096
#define | SPIM_TEST_ADDR 0x08400000

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | spim_init (void)
init the spim flash More...
void | sector_read (uint32_t address, uint32_t sector_size, uint8_t *buf)
read one sector from a specified address in spim flash More...
void | spim_operate (void)
operate spim flash More...

Variables

uint8_t | write_buffer [4096]
uint8_t | read_buffer [4096]

Detailed Description

Macro Definition Documentation

◆ SPIM_SECTOR_SIZE

#define SPIM_SECTOR_SIZE 4096

Definition at line 43 of file operate_spim.h.

◆ SPIM_TEST_ADDR

#define SPIM_TEST_ADDR 0x08400000

Definition at line 44 of file operate_spim.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/flash/operate_spim/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ sector_read()

void sector_read | ( | uint32_t | address,
 |  | uint32_t | sector_size,
 |  | uint8_t * | buf
 | ) |  |

read one sector from a specified address in spim flash

Parameters
address | specifies the sector starting address
sector_size | sector size in bytes
buf | the content read from spim flash
Return values
none

Definition at line 93 of file operate_spim.c.

Referenced by spim_operate().

◆ spim_init()

void spim_init ( void )

init the spim flash

Parameters
none
Return values
none

Definition at line 49 of file operate_spim.c.

Referenced by spim_operate().

◆ spim_operate()

void spim_operate ( void )

operate spim flash

Parameters
none
Return values
none

Definition at line 109 of file operate_spim.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.

Variable Documentation

◆ read_buffer

uint8_t read_buffer[4096]

Definition at line 42 of file operate_spim.c.

Referenced by spim_operate().

◆ write_buffer

uint8_t write_buffer[4096]

Definition at line 41 of file operate_spim.c.

Referenced by spim_operate().


AT32F413 Firmwary Library: FLASH_operate_spim_functions

Functions
FLASH_operate_spim_functions
AT32F413_periph_examples » FLASH_operate_spim

Functions

void spim_operate (void)
operate spim flash More...

Detailed Description

Function Documentation

◆ spim_operate()

void spim_operate ( void )

operate spim flash

Parameters
none
Return values
none

Definition at line 109 of file operate_spim.c.

Referenced by main().


AT32F413 Firmwary Library: FLASH_run_in_spim

Functions
FLASH_run_in_spim
AT32F413_periph_examples

Functions

void | spim_run (void)
check the led toggle in spim More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | spim_init (void)
init the spim flash More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 87 of file project/at_start_f413/examples/flash/run_in_spim/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ spim_init()

void spim_init ( void )

init the spim flash

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 1

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

< spim_sck(pb1), spim_cs(pa8), spim_io0(pb10), spim_io1(pb11), spim_io2(pb7), spim_sio3(pb6)

< flash spim operate busy flag

Definition at line 45 of file project/at_start_f413/examples/flash/run_in_spim/src/main.c.

Referenced by main().

◆ spim_run()

void spim_run ( void )

check the led toggle in spim

Parameters
none
Return values
none

Definition at line 45 of file run_in_spim.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.


AT32F413 Firmwary Library: GPIO_led_toggle

Functions
GPIO_led_toggle
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/gpio/led_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: GPIO_swjtag_remap

Functions
GPIO_swjtag_remap
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | swj_dp_config (void)
configure the gpio of swj-dp. More...
void | gpio_pins_toggle (gpio_type *gpio_x, uint16_t gpio_pin)
toggles the specified gpio pin More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ gpio_pins_toggle()

void gpio_pins_toggle | ( | gpio_type * | gpio_x,
 |  | uint16_t | gpio_pin
 | ) |  |

toggles the specified gpio pin

Parameters
gpiox | where x can be (a..g depending on device used) to select the gpio peripheral
gpio_pin | specifies the pins to be toggled.
Return values
none

Definition at line 70 of file project/at_start_f413/examples/gpio/swjtag_remap/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< full swj disabled (jtag-dp + sw-dp)

< full swj disabled (jtag-dp + sw-dp)

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 3

< gpio pins number 4

Definition at line 80 of file project/at_start_f413/examples/gpio/swjtag_remap/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ swj_dp_config()

void swj_dp_config ( void )

configure the gpio of swj-dp.

Parameters
none
Return values
none

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 3

< gpio pins number 4

Definition at line 47 of file project/at_start_f413/examples/gpio/swjtag_remap/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.


AT32F413 Firmwary Library: I2C_communication_dma

Macros | Functions | Variables
I2C_communication_dma
AT32F413_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL6
#define | I2Cx_DMA_TX_IRQn DMA1_Channel6_IRQn
#define | I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL7
#define | I2Cx_DMA_RX_IRQn DMA1_Channel7_IRQn
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel7_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel6_IRQHandler (void)
this function handles dma interrupt request. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | error_handler (uint32_t error_code)
error handler program More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 8

Definition at line 65 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 39 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0xA0

Definition at line 42 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 45 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_CLK

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_CHANNEL

#define I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL7

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_RX_IRQn

#define I2Cx_DMA_RX_IRQn DMA1_Channel7_IRQn

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_CHANNEL

#define I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL6

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_DMA_TX_IRQn

#define I2Cx_DMA_TX_IRQn DMA1_Channel6_IRQn

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_ERR_IRQn

#define I2Cx_ERR_IRQn I2C1_ERR_IRQn

Definition at line 63 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_EVT_IRQn

#define I2Cx_EVT_IRQn I2C1_EVT_IRQn

Definition at line 62 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 44 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 48 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_6

Definition at line 47 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 52 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_7

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 41 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ MASTER_BOARD

#define MASTER_BOARD

Definition at line 66 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ DMA1_Channel6_IRQHandler()

void DMA1_Channel6_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 158 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ DMA1_Channel7_IRQHandler()

void DMA1_Channel7_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 148 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 81 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

Definition at line 117 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 180 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 139 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 99 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

Variable Documentation

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 71 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ rx_buf

uint8_t rx_buf[8] = {0}

Definition at line 69 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Referenced by main().

◆ tx_buf

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 68 of file project/at_start_f413/examples/i2c/communication_dma/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2C_communication_int

Macros | Functions | Variables
I2C_communication_int
AT32F413_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | error_handler (uint32_t error_code)
error handler program More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 8

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 39 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0xA0

Definition at line 42 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 45 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_ERR_IRQn

#define I2Cx_ERR_IRQn I2C1_ERR_IRQn

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_EVT_IRQn

#define I2Cx_EVT_IRQn I2C1_EVT_IRQn

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 44 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 48 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_6

Definition at line 47 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 52 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_7

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 41 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ MASTER_BOARD

#define MASTER_BOARD

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 91 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 75 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ I2C1_ERR_IRQHandler()

void I2C1_ERR_IRQHandler ( void )

this function handles i2c error interrupt request.

Parameters
none
Return values
none

Definition at line 156 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ I2C1_EVT_IRQHandler()

void I2C1_EVT_IRQHandler ( void )

this function handles i2c event interrupt request.

Parameters
none
Return values
none

Definition at line 146 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

Definition at line 111 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 151 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 128 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 110 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 137 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 97 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

Variable Documentation

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 64 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ rx_buf

uint8_t rx_buf[8] = {0}

Definition at line 62 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().

◆ tx_buf

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 61 of file project/at_start_f413/examples/i2c/communication_int/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2C_communication_poll

Macros | Functions | Variables
I2C_communication_poll
AT32F413_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 8

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 39 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0xA0

Definition at line 42 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 45 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 44 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 48 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_6

Definition at line 47 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 52 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_7

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 41 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ MASTER_BOARD

#define MASTER_BOARD

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 88 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 72 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

Definition at line 108 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 144 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.

Variable Documentation

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 61 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ rx_buf

uint8_t rx_buf[8] = {0}

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().

◆ tx_buf

uint8_t tx_buf[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_poll/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2C_eeprom

Macros | Functions | Variables
I2C_eeprom
AT32F413_periph_examples

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C2
#define | I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_10
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_11
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL4
#define | I2Cx_DMA_TX_IRQn DMA1_Channel4_IRQn
#define | I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL5
#define | I2Cx_DMA_RX_IRQn DMA1_Channel5_IRQn
#define | I2Cx_EVT_IRQn I2C2_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C2_ERR_IRQn
#define | BUF_SIZE 8

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel5_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C2_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C2_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...
void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf1 [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | tx_buf2 [8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}
uint8_t | tx_buf3 [8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}
uint8_t | rx_buf1 [8] = {0}
uint8_t | rx_buf2 [8] = {0}
uint8_t | rx_buf3 [8] = {0}
i2c_handle_type hi2cx

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 8

Definition at line 65 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 39 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0xA0

Definition at line 42 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C2_PERIPH_CLOCK

Definition at line 45 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_CLK

#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK

Definition at line 55 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_CHANNEL

#define I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL5

Definition at line 59 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_RX_IRQn

#define I2Cx_DMA_RX_IRQn DMA1_Channel5_IRQn

Definition at line 60 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_CHANNEL

#define I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL4

Definition at line 56 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_DMA_TX_IRQn

#define I2Cx_DMA_TX_IRQn DMA1_Channel4_IRQn

Definition at line 57 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_ERR_IRQn

#define I2Cx_ERR_IRQn I2C2_ERR_IRQn

Definition at line 63 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_EVT_IRQn

#define I2Cx_EVT_IRQn I2C2_EVT_IRQn

Definition at line 62 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C2

Definition at line 44 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 49 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 48 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_10

Definition at line 47 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 53 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 52 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_11

Definition at line 51 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 41 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Function Documentation

◆ buffer_compare()

uint32_t buffer_compare | ( | uint8_t * | buffer1,
 |  | uint8_t * | buffer2,
 |  | uint32_t | len
 | ) |  |

compare whether the valus of buffer 1 and buffer 2 are equal.

Parameters
buffer1 buffer 1 address. buffer2: buffer 2 address.
Return values
0 equal. 1: unequal.

Definition at line 101 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 158 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ DMA1_Channel5_IRQHandler()

void DMA1_Channel5_IRQHandler ( void )

this function handles dma interrupt request.

Parameters
none
Return values
none

Definition at line 148 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ error_handler()

void error_handler ( uint32_t error_code )

error handler program

Parameters
i2c_status
Return values
none

Definition at line 85 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2C2_ERR_IRQHandler()

void I2C2_ERR_IRQHandler ( void )

this function handles i2c error interrupt request.

Parameters
none
Return values
none

Definition at line 178 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2C2_EVT_IRQHandler()

void I2C2_EVT_IRQHandler ( void )

this function handles i2c event interrupt request.

Parameters
none
Return values
none

Definition at line 168 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 11

Definition at line 121 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 188 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 139 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 99 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

Variable Documentation

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 74 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ rx_buf1

uint8_t rx_buf1[8] = {0}

Definition at line 70 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ rx_buf2

uint8_t rx_buf2[8] = {0}

Definition at line 71 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ rx_buf3

uint8_t rx_buf3[8] = {0}

Definition at line 72 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ tx_buf1

uint8_t tx_buf1[8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}

Definition at line 67 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ tx_buf2

uint8_t tx_buf2[8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}

Definition at line 68 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().

◆ tx_buf3

uint8_t tx_buf3[8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}

Definition at line 69 of file project/at_start_f413/examples/i2c/eeprom/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2S_halfduplex_dma

Functions | Variables
I2S_halfduplex_dma
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
volatile error_status | transfer_status = ERROR

Detailed Description

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare function.

Parameters
none
Return values
the result of compare

Definition at line 58 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 7

< gpio pins number 0

< gpio pins number 12

< gpio pins number 13

< gpio pins number 15

Definition at line 130 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ i2s_config()

static void i2s_config ( void )
static

i2s configuration.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel4 full data transfer flag

Definition at line 186 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.

Variable Documentation

◆ i2s1_buffer_tx

uint16_t i2s1_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 40 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by i2s_config(), and main().

◆ i2s2_buffer_rx

uint16_t i2s2_buffer_rx[32]

Definition at line 46 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by i2s_config(), and main().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 47 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2S_halfduplex_interrupt

Functions | Variables
I2S_halfduplex_interrupt
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
error_status | buffer_compare_24bits (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare_24bits function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare function.

Parameters
none
Return values
the result of compare

Definition at line 59 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ buffer_compare_24bits()

error_status buffer_compare_24bits | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare_24bits function.

Parameters
none
Return values
the result of compare

Definition at line 79 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 7

< gpio pins number 0

< gpio pins number 12

< gpio pins number 13

< gpio pins number 15

Definition at line 136 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ i2s_config()

static void i2s_config | ( | i2s_data_channel_format_type | format,
 |  | i2s_audio_sampling_freq_type | freq
 | ) |  |
static

i2s configuration.

Parameters
none
Return values
none

< receive data buffer full interrupt

< transmit data buffer empty interrupt

Definition at line 102 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 192 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ SPI1_IRQHandler()

void SPI1_IRQHandler ( void )

This function handles the spi1 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

Definition at line 159 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ SPI2_IRQHandler()

void SPI2_IRQHandler ( void )

This function handles the spi2 interrupt request.

Parameters
None
Return values
None

< spi or i2s receive data buffer full flag

Definition at line 146 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

Variable Documentation

◆ i2s1_buffer_tx

uint16_t i2s1_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40}

Definition at line 39 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ i2s2_buffer_rx

uint16_t i2s2_buffer_rx[32]

Definition at line 45 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ rx_index

__IO uint32_t rx_index = 0

Definition at line 46 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 47 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 47 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ tx_index

__IO uint32_t tx_index = 0

Definition at line 46 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: I2S_spii2s_switch_halfduplex_polling

Functions | Variables
I2S_spii2s_switch_halfduplex_polling
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
static void | i2s_config (i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | spi1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR

Detailed Description

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer_compare function.

Parameters
none
Return values
the result of compare

Definition at line 68 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 4

< gpio pins number 5

< gpio pins number 7

< gpio pins number 0

< gpio pins number 12

< gpio pins number 13

< gpio pins number 15

Definition at line 147 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ i2s_config()

static void i2s_config | ( | i2s_operation_mode_type | i2s1_mode,
 |  | i2s_operation_mode_type | i2s2_mode
 | ) |  |
static

i2s configuration.

Parameters
none
Return values
none

Definition at line 88 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

Definition at line 203 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.

Variable Documentation

◆ i2s1_buffer_tx

uint16_t i2s1_buffer_tx[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
0x3D3E, 0x3F40
}

Definition at line 39 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main(), and SPI1_IRQHandler().

◆ i2s2_buffer_rx

uint16_t i2s2_buffer_rx[32]

Definition at line 53 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main(), and SPI2_IRQHandler().

◆ rx_index

__IO uint32_t rx_index = 0

Definition at line 55 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ spi1_buffer_tx

uint16_t spi1_buffer_tx[32]
Initial value:
= {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C,
0x5D5E, 0x5F60, 0x6162, 0x6364, 0x6566, 0x6768,
0x696A, 0x6B6C, 0x6D6E, 0x6F70, 0x7172, 0x7374,
0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C,
0x8D8E, 0x8F90
}

Definition at line 46 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ spi2_buffer_rx

uint16_t spi2_buffer_rx[32]

Definition at line 54 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 56 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 56 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status3

volatile error_status transfer_status3 = ERROR

Definition at line 56 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().

◆ tx_index

__IO uint32_t tx_index = 0

Definition at line 55 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: PWC_deepsleep_rtc

Functions
PWC_deepsleep_rtc
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTCAlarm_IRQHandler (void)
this function handles the rtc alarm through exint line interrupt request. More...
void | rtc_config (void)
rtc configuration. More...
void | system_clock_recover (void)
systemclock recover. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< rtc time second flag

< rtc time second flag

Definition at line 127 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ rtc_config()

void rtc_config ( void )

rtc configuration.

Parameters
none
Return values
none

< external interrupt line 17 connected to the rtc alarm event

< low speed internal clock stable flag

< rtc time alarm interrupt

Definition at line 45 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

Referenced by main().

◆ RTCAlarm_IRQHandler()

void RTCAlarm_IRQHandler ( void )

this function handles the rtc alarm through exint line interrupt request.

Parameters
none
Return values
none

< rtc time alarm flag

< external interrupt line 17 connected to the rtc alarm event

< rtc time alarm flag

Definition at line 143 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

systemclock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 98 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.


AT32F413 Firmwary Library: PWC_power_voltage_monitor

Functions
PWC_power_voltage_monitor
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | PVM_IRQHandler (void)
this function handles the power voltage monitoring output interrupt request. More...
void | pvm_exint_config (void)
power voltage monitor exint configuration. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< external interrupt line 16 connected to the pvm output

< external interrupt line 16 connected to the pvm output

Definition at line 62 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ pvm_exint_config()

void pvm_exint_config ( void )

power voltage monitor exint configuration.

Parameters
none
Return values
none

< external interrupt line 16 connected to the pvm output

Definition at line 45 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c.

Referenced by main().

◆ PVM_IRQHandler()

void PVM_IRQHandler ( void )

this function handles the power voltage monitoring output interrupt request.

Parameters
none
Return values
none

< external interrupt line 16 connected to the pvm output

< external interrupt line 16 connected to the pvm output

Definition at line 143 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.


AT32F413 Firmwary Library: PWC_sleep_tmr2

Functions
PWC_sleep_tmr2
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles the timer interrupt request. More...
void | tmr2_config (void)
tmr2 configuration. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 80 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 67 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 106 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ tmr2_config()

void tmr2_config ( void )

tmr2 configuration.

Parameters
none
Return values
none

< tmr interrupt overflow

Definition at line 45 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c.

Referenced by main().

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles the timer interrupt request.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 142 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 93 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.


AT32F413 Firmwary Library: PWC_sleep_usart1

Functions | Variables
PWC_sleep_usart1
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART1_IRQHandler (void)
this function handles the usatt interrupt request. More...
void | usart1_config (uint32_t baudrate)
usart1 configuration. More...
int | main (void)
main function. More...

Variables

uint16_t usart1_index = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 82 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 56 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f413/examples/pwc/sleep_usart1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 69 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 47 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 126 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 135 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 95 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

◆ usart1_config()

void usart1_config ( uint32_t baudrate )

usart1 configuration.

Parameters
none
Return values
none

< gpio pins number 9

< gpio pins number 10

< usart receive data buffer full interrupt

Definition at line 43 of file project/at_start_f413/examples/pwc/sleep_usart1/src/main.c.

Referenced by main().

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

this function handles the usatt interrupt request.

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 144 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

Variable Documentation

◆ usart1_index

uint16_t usart1_index = 0

Definition at line 41 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.

Referenced by USART1_IRQHandler().


AT32F413 Firmwary Library: PWC_standby_rtc

Functions
PWC_standby_rtc
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | rtc_config (void)
rtc configuration. More...
void | rtc_alarm_config (uint8_t alarm_time)
rtc alarm set. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< standby flag

< standby flag

< wakeup flag

< wakeup flag

Definition at line 101 of file project/at_start_f413/examples/pwc/standby_rtc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ rtc_alarm_config()

void rtc_alarm_config ( uint8_t alarm_time )

rtc alarm set.

Parameters
none
Return values
none

< rtc time second flag

< rtc time second flag

Definition at line 81 of file project/at_start_f413/examples/pwc/standby_rtc/src/main.c.

Referenced by main().

◆ rtc_config()

void rtc_config ( void )

rtc configuration.

Parameters
none
Return values
none

< low speed internal clock stable flag

Definition at line 46 of file project/at_start_f413/examples/pwc/standby_rtc/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.


AT32F413 Firmwary Library: PWC_standby_wakeup_pin

Functions
PWC_standby_wakeup_pin
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< standby flag

< standby flag

< wakeup flag

< wakeup flag

< standby wake-up pin1

Definition at line 44 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.


AT32F413 Firmwary Library: RTC_calendar

Modules | Functions | Variables
RTC_calendar
AT32F413_periph_examples

Modules

RTC_calendar_type
RTC_calendar_exported_functions

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTC_IRQHandler (void)
this function handles rtc handler. More...
void | alarm_init (void)
init alarm. More...
int | main (void)
main function. More...
uint8_t | rtc_init (calendar_type *calendar)
rtc peripheral initialization. More...
uint8_t | is_leap_year (uint16_t year)
judeg the leap year or common year. More...
uint8_t | rtc_time_set (calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_alarm_clock_set (calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_week_get (uint16_t year, uint8_t month, uint8_t day)
get current week by input leap year\mouth\day. More...
void | rtc_time_get (void)
get current time. More...

Variables

calendar_type calendar
char const | weekday_table [7][10] = { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"}
calendar_type calendar
const uint8_t | table_week [12] = {0, 3, 3, 6, 1, 4, 6, 2, 5, 0, 3, 5}
const uint8_t | mon_table [12] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}

Detailed Description

Function Documentation

◆ alarm_init()

void alarm_init ( void )

init alarm.

Parameters
none
Return values
none

< rtc time alarm flag

< rtc time alarm interrupt

Definition at line 46 of file project/at_start_f413/examples/rtc/calendar/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ is_leap_year()

uint8_t is_leap_year ( uint16_t year )

judeg the leap year or common year.

  • month 1 2 3 4 5 6 7 8 9 10 11 12
  • leap year 31 29 31 30 31 30 31 31 30 31 30 31
  • common year 31 28 31 30 31 30 31 31 30 31 30 31
    Parameters
    year
    Return values
    1 leap year 2: common year

Definition at line 117 of file rtc.c.

Referenced by rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< rtc time second flag

< rtc time second flag

Definition at line 82 of file project/at_start_f413/examples/rtc/calendar/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ rtc_alarm_clock_set()

uint8_t rtc_alarm_clock_set ( calendar_type * calendar )

set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099

Parameters
calendar
Return values
0 set alarm right. 1: set alarm failed.

Definition at line 217 of file rtc.c.

Referenced by alarm_init().

◆ rtc_init()

uint8_t rtc_init ( calendar_type * calendar )

rtc peripheral initialization.

Parameters
calendar
Return values
0 rtc already init 1: rtc init

Definition at line 51 of file rtc.c.

Referenced by main().

◆ RTC_IRQHandler()

void RTC_IRQHandler ( void )

this function handles rtc handler.

Parameters
none
Return values
none

< rtc time alarm flag

< rtc time alarm flag

Definition at line 142 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ rtc_time_get()

void rtc_time_get ( void )

get current time.

Parameters
none.
Return values
none.

Definition at line 309 of file rtc.c.

Referenced by main().

◆ rtc_time_set()

uint8_t rtc_time_set ( calendar_type * calendar )

set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099

Parameters
calendar
Return values
0 set time right. 1: set time failed.

Definition at line 151 of file rtc.c.

Referenced by rtc_init().

◆ rtc_week_get()

uint8_t rtc_week_get | ( | uint16_t | year,
 |  | uint8_t | month,
 |  | uint8_t | day
 | ) |  |

get current week by input leap year\mouth\day.

Parameters
year | : year
mon | : month
day | : day
Return values
week number.

Definition at line 279 of file rtc.c.

Referenced by rtc_time_get().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.

Variable Documentation

◆ calendar [1/2]

calendar_type calendar
extern

Definition at line 37 of file rtc.c.

Referenced by main(), rtc_alarm_clock_set(), rtc_init(), rtc_time_get(), and rtc_time_set().

◆ calendar [2/2]

calendar_type calendar

Definition at line 37 of file rtc.c.

Referenced by main(), rtc_alarm_clock_set(), rtc_init(), rtc_time_get(), and rtc_time_set().

◆ mon_table

const uint8_t mon_table[12] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}

Definition at line 43 of file rtc.c.

Referenced by rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ table_week

const uint8_t table_week[12] = {0, 3, 3, 6, 1, 4, 6, 2, 5, 0, 3, 5}

Definition at line 40 of file rtc.c.

Referenced by rtc_week_get().

◆ weekday_table

char const weekday_table[7][10] = { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"}

Definition at line 39 of file project/at_start_f413/examples/rtc/calendar/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: RTC_calendar_type

Data Structures
RTC_calendar_type
AT32F413_periph_examples » RTC_calendar

Data Structures

struct calendar_type

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: calendar_type Struct Reference

Data Fields
calendar_type Struct Reference
AT32F413_periph_examples » RTC_calendar » RTC_calendar_type

#include <rtc.h>

Data Fields

__IO uint16_t | year
__IO uint8_t | month
__IO uint8_t | date
__IO uint8_t | hour
__IO uint8_t | min
__IO uint8_t | sec
__IO uint8_t | week

Detailed Description

Definition at line 48 of file rtc.h.

Field Documentation

◆ date

__IO uint8_t calendar_type::date

specifies the date of calendar.

Definition at line 52 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ hour

__IO uint8_t calendar_type::hour

specifies the hours of calendar.

Definition at line 53 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ min

__IO uint8_t calendar_type::min

specifies the minutes of calendar.

Definition at line 54 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ month

__IO uint8_t calendar_type::month

specifies the months of calendar.

Definition at line 51 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ sec

__IO uint8_t calendar_type::sec

specifies the second of calendar.

Definition at line 55 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

◆ week

__IO uint8_t calendar_type::week

specifies the weeks of calendar.

Definition at line 56 of file rtc.h.

Referenced by main(), and rtc_time_get().

◆ year

__IO uint16_t calendar_type::year

specifies the years of calendar.

Definition at line 50 of file rtc.h.

Referenced by alarm_init(), main(), rtc_alarm_clock_set(), rtc_time_get(), and rtc_time_set().

The documentation for this struct was generated from the following file:
  • rtc.h


AT32F413 Firmwary Library: RTC_calendar_exported_functions

Functions
RTC_calendar_exported_functions
AT32F413_periph_examples » RTC_calendar

Functions

uint8_t | rtc_init (calendar_type *calendar)
rtc peripheral initialization. More...
uint8_t | rtc_time_set (calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_alarm_clock_set (calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
void | rtc_time_get (void)
get current time. More...

Detailed Description

Function Documentation

◆ rtc_alarm_clock_set()

uint8_t rtc_alarm_clock_set ( calendar_type * calendar )

set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099

Parameters
calendar
Return values
0 set alarm right. 1: set alarm failed.

Definition at line 217 of file rtc.c.

Referenced by alarm_init().

◆ rtc_init()

uint8_t rtc_init ( calendar_type * calendar )

rtc peripheral initialization.

Parameters
calendar
Return values
0 rtc already init 1: rtc init

Definition at line 51 of file rtc.c.

Referenced by main().

◆ rtc_time_get()

void rtc_time_get ( void )

get current time.

Parameters
none.
Return values
none.

Definition at line 309 of file rtc.c.

Referenced by main().

◆ rtc_time_set()

uint8_t rtc_time_set ( calendar_type * calendar )

set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099

Parameters
calendar
Return values
0 set time right. 1: set time failed.

Definition at line 151 of file rtc.c.

Referenced by rtc_init().


AT32F413 Firmwary Library: RTC_lick_calibration

Functions | Variables
RTC_lick_calibration
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTC_IRQHandler (void)
this function handles rtc global interrupt request. More...
void | TMR5_GLOBAL_IRQHandler (void)
this function handles tmr5 global interrupt request. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
void | rtc_configuration (void)
configures the rtc. More...
uint32_t | incrementvar_operationcomplete (void)
increments operationcomplete variable and return its value before increment operation. More...
uint32_t | getvar_operationcomplete (void)
returns operationcomplete value. More...
void | setvar_periodvalue (uint32_t value)
sets the periodvalue variable with input parameter. More...
int | main (void)
main function. More...

Variables

uint16_t | tmpCC4 [2] = {0, 0}
crm_clocks_freq_type crm_clocks
__IO uint32_t | periodvalue = 0
__IO uint32_t | lickfreq = 0
__IO uint32_t | operationcomplete = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ getvar_operationcomplete()

uint32_t getvar_operationcomplete ( void )

returns operationcomplete value.

Parameters
none
Return values
operationcomplete value

Definition at line 130 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ incrementvar_operationcomplete()

uint32_t incrementvar_operationcomplete ( void )

increments operationcomplete variable and return its value before increment operation.

Parameters
none
Return values
operationcomplete value before increment

Definition at line 118 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< lick connected to tmr5_ch4 input capture for calibration

< lick connected to tmr5_ch4 input capture for calibration

< tmr flag channel 4

< tmr interrupt channel 4

Definition at line 150 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ nvic_configuration()

static void nvic_configuration ( void )

configures the nested vectored interrupt controller.

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ rtc_configuration()

void rtc_configuration ( void )

configures the rtc.

Parameters
none
Return values
none

< low speed internal clock stable flag

< rtc time second interrupt

Definition at line 65 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ RTC_IRQHandler()

void RTC_IRQHandler ( void )

this function handles rtc global interrupt request.

Parameters
none
Return values
none

< rtc time second flag

< rtc time second flag

Definition at line 151 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ setvar_periodvalue()

void setvar_periodvalue ( uint32_t value )

sets the periodvalue variable with input parameter.

Parameters
value value of periodvalue to be set.
Return values
none

Definition at line 140 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by TMR5_GLOBAL_IRQHandler().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 142 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ TMR5_GLOBAL_IRQHandler()

void TMR5_GLOBAL_IRQHandler ( void )

this function handles tmr5 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 4

< tmr flag channel 4

< tmr interrupt channel 4

Definition at line 170 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks

crm_clocks_freq_type crm_clocks

Definition at line 38 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ lickfreq

__IO uint32_t lickfreq = 0

Definition at line 40 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ operationcomplete

__IO uint32_t operationcomplete = 0

Definition at line 41 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by getvar_operationcomplete(), incrementvar_operationcomplete(), and main().

◆ periodvalue

__IO uint32_t periodvalue = 0

Definition at line 39 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main(), and setvar_periodvalue().

◆ tmpCC4

uint16_t tmpCC4[2] = {0, 0}

Definition at line 47 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.

Referenced by TMR5_GLOBAL_IRQHandler().


AT32F413 Firmwary Library: SDIO_sd_mmc_card

Modules | Macros | Functions | Variables
SDIO_sd_mmc_card
AT32F413_periph_examples

Modules

SDIO_sd_mmc_card_instance_definition
SDIO_sd_mmc_card_exported_types
SDIO_sd_mmc_card_command_index_definition
SDIO_sd_mmc_card_paremeters_definition
SDIO_sd_mmc_card_response_definition
SDIO_sd_mmc_card_command_class_definition
SDIO_sd_mmc_card_cmd8_definition
SDIO_sd_mmc_card_mmc_extend_definition
SDIO_sd_mmc_card_interrupt_flags_definition
SDIO_sd_mmc_card_exported_functions

Macros

#define | BLOCK_SIZE (512)
#define | BLOCKS_NUMBER (8)
#define | MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
#define | STREAM_BUFFER_SIZE (1024)

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static error_status | sd_single_block_test (void)
sd card single block read/write test. More...
static error_status | sd_multiple_blocks_test (void)
sd card multiple blocks read/write test. More...
static void | sd_test_error (void)
LED2 on off every 300ms for sd test failed. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static error_status | mmc_stream_test (void)
mmc card data stream read/write test. More...
void | show_card_info (void)
show sd/mmc card info. More...
int | main (void)
main function. More...

Variables

sd_card_info_struct_type sd_card_info
sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info
static uint8_t | sblock_tbuffer [(512)]
static uint8_t | sblock_rbuffer [(512)]
static uint8_t | mblock_tbuffer [((512) *(8))]
static uint8_t | mblock_rbuffer [((512) *(8))]
static uint8_t | stream_tbuffer [(1024)]
static uint8_t | stream_rbuffer [(1024)]

Detailed Description

Macro Definition Documentation

◆ BLOCK_SIZE

#define BLOCK_SIZE (512)

Definition at line 41 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

◆ BLOCKS_NUMBER

#define BLOCKS_NUMBER (8)

Definition at line 42 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

◆ MULTI_BUFFER_SIZE

#define MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)

Definition at line 43 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

◆ STREAM_BUFFER_SIZE

#define STREAM_BUFFER_SIZE (1024)

Definition at line 44 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 273 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1646 of file sd_mmc_card/src/at32_sdio.c.

◆ mmc_stream_test()

static error_status mmc_stream_test ( void )
static

mmc card data stream read/write test.

Parameters
none
Return values
ERROR fail. SUCCESS: success.

Definition at line 157 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1693 of file sd_mmc_card/src/at32_sdio.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ nvic_configuration()

static void nvic_configuration ( void )
static

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 238 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1181 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1360 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1023 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 525 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 410 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 800 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 779 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2699 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 72 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1782 of file sd_mmc_card/src/at32_sdio.c.

Referenced by SDIO1_IRQHandler(), and SDIO2_IRQHandler().

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1270 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1482 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_multiple_blocks_test()

static error_status sd_multiple_blocks_test ( void )
static

sd card multiple blocks read/write test.

Parameters
none
Return values
ERROR fail. SUCCESS: success.

Definition at line 109 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 396 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 196 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_single_block_test()

static error_status sd_single_block_test ( void )
static

sd card single block read/write test.

Parameters
none
Return values
ERROR fail. SUCCESS: success.

Definition at line 62 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2482 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2445 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_switch(), sd_block_write(), sd_mult_blocks_write(), and sd_state_get().

◆ sd_test_error()

static void sd_test_error ( void )
static

LED2 on off every 300ms for sd test failed.

Parameters
none
Return values
none

Definition at line 225 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 736 of file sd_mmc_card/src/at32_sdio.c.

◆ SDIO1_IRQHandler()

void SDIO1_IRQHandler ( void )

sdio1 isr.

Parameters
none.
Return values
none.

Definition at line 1762 of file sd_mmc_card/src/at32_sdio.c.

◆ SDIO2_IRQHandler()

void SDIO2_IRQHandler ( void )

sdio2 isr.

Parameters
none.
Return values
none.

Definition at line 1772 of file sd_mmc_card/src/at32_sdio.c.

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 181 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_command_data_send()

sd_error_status_type sdio_command_data_send | ( | sdio_command_struct_type * | sdio_cmd_init_t,
 |  | sdio_data_struct_type * | sdio_data_init_t,
 |  | uint32_t * | buf
 | ) |  |

read data from or write data to sd card.

Parameters
sdio_cmd_init_struct | pointer to sdio_command_struct_type structure.
sdio_data_init_struct | pointer to sdio_data_struct_type structure.
buf | pointer to data buffer read or write.
Return values
sd_error_status_type sd card error code.

Definition at line 823 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ show_card_info()

void show_card_info ( void )

show sd/mmc card info.

Parameters
none
Return values
none

Definition at line 249 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.

Variable Documentation

◆ card_type

sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static

Definition at line 42 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_card_info_get(), sd_card_init(), sd_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_wide_bus_operation_config(), and speed_change().

◆ cid_table

uint32_t cid_table[4]
static

Definition at line 43 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ csd_table

uint32_t csd_table[4]
static

Definition at line 43 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ device_mode

sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE
static

Definition at line 44 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_device_mode_set(), and sdio_command_data_send().

◆ mblock_rbuffer

uint8_t mblock_rbuffer[((512) *(8))]
static

Definition at line 47 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_multiple_blocks_test().

◆ mblock_tbuffer

uint8_t mblock_tbuffer[((512) *(8))]
static

Definition at line 47 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_multiple_blocks_test().

◆ rca

uint32_t rca = 0
static

Definition at line 43 of file sd_mmc_card/src/at32_sdio.c.

Referenced by check_card_programming(), sd_card_info_get(), sd_card_init(), sd_mult_blocks_write(), and sd_status_send().

◆ sblock_rbuffer

uint8_t sblock_rbuffer[(512)]
static

Definition at line 46 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_single_block_test().

◆ sblock_tbuffer

uint8_t sblock_tbuffer[(512)]
static

Definition at line 46 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by sd_single_block_test().

◆ sd_card_info [1/2]

sd_card_info_struct_type sd_card_info
extern

Definition at line 48 of file sd_mmc_card/src/at32_sdio.c.

Referenced by disk_ioctl(), main(), and show_card_info().

◆ sd_card_info [2/2]

sd_card_info_struct_type sd_card_info

Definition at line 48 of file sd_mmc_card/src/at32_sdio.c.

Referenced by scr_find(), sd_bus_wide_enable(), sd_init(), and speed_change().

◆ sdio_command_init_struct

sdio_command_struct_type sdio_command_init_struct

Definition at line 39 of file sd_mmc_card/src/at32_sdio.c.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), and sd_switch().

◆ sdio_data_init_struct

sdio_data_struct_type sdio_data_init_struct

Definition at line 40 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ stop_flag

uint8_t stop_flag = 0
static

Definition at line 45 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_command_data_send().

◆ stream_rbuffer

uint8_t stream_rbuffer[(1024)]
static

Definition at line 48 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by mmc_stream_test().

◆ stream_tbuffer

uint8_t stream_tbuffer[(1024)]
static

Definition at line 48 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.

Referenced by mmc_stream_test().

◆ transfer_end

volatile uint8_t transfer_end = 0

Definition at line 47 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ transfer_error

volatile sd_error_status_type transfer_error = SD_OK

Definition at line 46 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().


AT32F413 Firmwary Library: SDIO_sd_mmc_card_instance_definition

Macros
SDIO_sd_mmc_card_instance_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define SDIOx SDIO1

Detailed Description

Macro Definition Documentation

◆ SDIOx

#define SDIOx SDIO1

Definition at line 51 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_exported_types

Data Structures | Enumerations
SDIO_sd_mmc_card_exported_types
AT32F413_periph_examples » SDIO_sd_mmc_card

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Enumerations

enum sd_data_transfer_mode_type { SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 }
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Detailed Description

Enumeration Type Documentation

◆ sd_card_state_type

enum sd_card_state_type

sd card status

Enumerator
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR

Definition at line 186 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_data_transfer_mode_type

enum sd_data_transfer_mode_type

sdio data transfer mode

Enumerator
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE

Definition at line 64 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_error_status_type

enum sd_error_status_type

sdio error defines

Enumerator
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass

Definition at line 73 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_memory_card_type

enum sd_memory_card_type

supported sd memory cards

Enumerator
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD

Definition at line 202 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: sd_csd_struct_type Struct Reference

Data Fields
sd_csd_struct_type Struct Reference
AT32F413_periph_examples » SDIO_sd_mmc_card » SDIO_sd_mmc_card_exported_types | AT32F413_periph_examples » SDIO_sdio_fatfs » SDIO_sdio_fatfs_exported_types

#include <at32_sdio.h>

Data Fields

uint8_t | csd_struct
uint8_t | spec_version
uint8_t | reserved1
uint8_t | taac
uint8_t | nsac
uint8_t | max_bus_clk_freq
uint16_t | card_cmd_classes
uint8_t | max_read_blk_length
uint8_t | part_blk_read
uint8_t | write_blk_misalign
uint8_t | read_blk_misalign
uint8_t | dsr_implemented
uint8_t | reserved2
uint32_t | device_size
uint8_t | max_read_current_vdd_min
uint8_t | max_read_current_vdd_max
uint8_t | max_write_current_vdd_min
uint8_t | max_write_current_vdd_max
uint8_t | device_size_mult
uint8_t | erase_group_size
uint8_t | erase_group_size_mult
uint8_t | write_protect_group_size
uint8_t | write_protect_group_enable
uint8_t | manufacturer_default_ecc
uint8_t | write_speed_factor
uint8_t | max_write_blk_length
uint8_t | part_blk_write
uint8_t | reserved3
uint8_t | content_protect_app
uint8_t | file_format_group
uint8_t | copy_flag
uint8_t | permanent_write_protect
uint8_t | temp_write_protect
uint8_t | file_formart
uint8_t | ecc_code
uint8_t | csd_crc
uint8_t | reserved4

Detailed Description

card specific data: csd register

Definition at line 125 of file sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ card_cmd_classes

uint16_t sd_csd_struct_type::card_cmd_classes

card command classes

Definition at line 133 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ content_protect_app

uint8_t sd_csd_struct_type::content_protect_app

content protection application

Definition at line 155 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ copy_flag

uint8_t sd_csd_struct_type::copy_flag

copy flag (otp)

Definition at line 157 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ csd_crc

uint8_t sd_csd_struct_type::csd_crc

csd crc

Definition at line 162 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ csd_struct

uint8_t sd_csd_struct_type::csd_struct

csd structure

Definition at line 127 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ device_size

uint32_t sd_csd_struct_type::device_size

device size

Definition at line 140 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and show_card_info().

◆ device_size_mult

uint8_t sd_csd_struct_type::device_size_mult

device size multiplier

Definition at line 145 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ dsr_implemented

uint8_t sd_csd_struct_type::dsr_implemented

dsr implemented

Definition at line 138 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ ecc_code

uint8_t sd_csd_struct_type::ecc_code

ecc code

Definition at line 161 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ erase_group_size

uint8_t sd_csd_struct_type::erase_group_size

erase group size

Definition at line 146 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ erase_group_size_mult

uint8_t sd_csd_struct_type::erase_group_size_mult

erase group size multiplier

Definition at line 147 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ file_formart

uint8_t sd_csd_struct_type::file_formart

file format

Definition at line 160 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ file_format_group

uint8_t sd_csd_struct_type::file_format_group

file format group

Definition at line 156 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ manufacturer_default_ecc

uint8_t sd_csd_struct_type::manufacturer_default_ecc

manufacturer default ecc

Definition at line 150 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_bus_clk_freq

uint8_t sd_csd_struct_type::max_bus_clk_freq

max. bus clock frequency

Definition at line 132 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_read_blk_length

uint8_t sd_csd_struct_type::max_read_blk_length

max. read data block length

Definition at line 134 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_read_current_vdd_max

uint8_t sd_csd_struct_type::max_read_current_vdd_max

max. read current @ vdd max

Definition at line 142 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_read_current_vdd_min

uint8_t sd_csd_struct_type::max_read_current_vdd_min

max. read current @ vdd min

Definition at line 141 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_write_blk_length

uint8_t sd_csd_struct_type::max_write_blk_length

max. write data block length

Definition at line 152 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_write_current_vdd_max

uint8_t sd_csd_struct_type::max_write_current_vdd_max

max. write current @ vdd max

Definition at line 144 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ max_write_current_vdd_min

uint8_t sd_csd_struct_type::max_write_current_vdd_min

max. write current @ vdd min

Definition at line 143 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ nsac

uint8_t sd_csd_struct_type::nsac

data read access-time 2 in clk cycles

Definition at line 131 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ part_blk_read

uint8_t sd_csd_struct_type::part_blk_read

partial blocks for read allowed

Definition at line 135 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ part_blk_write

uint8_t sd_csd_struct_type::part_blk_write

partial blocks for write allowed

Definition at line 153 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ permanent_write_protect

uint8_t sd_csd_struct_type::permanent_write_protect

permanent write protection

Definition at line 158 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ read_blk_misalign

uint8_t sd_csd_struct_type::read_blk_misalign

read block misalignment

Definition at line 137 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved1

uint8_t sd_csd_struct_type::reserved1

reserved

Definition at line 129 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved2

uint8_t sd_csd_struct_type::reserved2

reserved

Definition at line 139 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved3

uint8_t sd_csd_struct_type::reserved3

reserded

Definition at line 154 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved4

uint8_t sd_csd_struct_type::reserved4

always

Definition at line 163 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ spec_version

uint8_t sd_csd_struct_type::spec_version

system specification version

Definition at line 128 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and sd_init().

◆ taac

uint8_t sd_csd_struct_type::taac

data read access-time 1

Definition at line 130 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ temp_write_protect

uint8_t sd_csd_struct_type::temp_write_protect

temporary write protection

Definition at line 159 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_blk_misalign

uint8_t sd_csd_struct_type::write_blk_misalign

write block misalignment

Definition at line 136 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_protect_group_enable

uint8_t sd_csd_struct_type::write_protect_group_enable

write protect group enable

Definition at line 149 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_protect_group_size

uint8_t sd_csd_struct_type::write_protect_group_size

write protect group size

Definition at line 148 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ write_speed_factor

uint8_t sd_csd_struct_type::write_speed_factor

write speed factor

Definition at line 151 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

The documentation for this struct was generated from the following files:
  • sd_mmc_card/inc/at32_sdio.h
  • sdio_fatfs/inc/at32_sdio.h


AT32F413 Firmwary Library: sd_cid_struct_type Struct Reference

Data Fields
sd_cid_struct_type Struct Reference
AT32F413_periph_examples » SDIO_sd_mmc_card » SDIO_sd_mmc_card_exported_types | AT32F413_periph_examples » SDIO_sdio_fatfs » SDIO_sdio_fatfs_exported_types

#include <at32_sdio.h>

Data Fields

uint8_t | manufacturer_id
uint16_t | oem_app_id
uint32_t | product_name1
uint8_t | product_name2
uint8_t | product_reversion
uint32_t | product_sn
uint8_t | reserved1
uint16_t | manufact_date
uint8_t | cid_crc
uint8_t | reserved2

Detailed Description

card identification data: cid register

Definition at line 169 of file sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ cid_crc

uint8_t sd_cid_struct_type::cid_crc

cid crc

Definition at line 179 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ manufact_date

uint16_t sd_cid_struct_type::manufact_date

manufacturing date

Definition at line 178 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ manufacturer_id

uint8_t sd_cid_struct_type::manufacturer_id

manufacturer id

Definition at line 171 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and show_card_info().

◆ oem_app_id

uint16_t sd_cid_struct_type::oem_app_id

oem/application id

Definition at line 172 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_name1

uint32_t sd_cid_struct_type::product_name1

product name part1

Definition at line 173 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_name2

uint8_t sd_cid_struct_type::product_name2

product name part2

Definition at line 174 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_reversion

uint8_t sd_cid_struct_type::product_reversion

product revision

Definition at line 175 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ product_sn

uint32_t sd_cid_struct_type::product_sn

product serial number

Definition at line 176 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved1

uint8_t sd_cid_struct_type::reserved1

reserved1

Definition at line 177 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

◆ reserved2

uint8_t sd_cid_struct_type::reserved2

always 1

Definition at line 180 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get().

The documentation for this struct was generated from the following files:
  • sd_mmc_card/inc/at32_sdio.h
  • sdio_fatfs/inc/at32_sdio.h


AT32F413 Firmwary Library: sd_scr_struct_type Struct Reference

Data Fields
sd_scr_struct_type Struct Reference
AT32F413_periph_examples » SDIO_sd_mmc_card » SDIO_sd_mmc_card_exported_types | AT32F413_periph_examples » SDIO_sdio_fatfs » SDIO_sdio_fatfs_exported_types

#include <at32_sdio.h>

Data Fields

uint32_t | sd_spec:4
uint32_t | scr_structure:4
uint32_t | sd_bus_width:4
uint32_t | sd_security:3
uint32_t | data_stat_after_erase:1
uint32_t | reserved1:7
uint32_t | sd_spec3:1
uint32_t | cmd20_support:1
uint32_t | cmd23_support:1
uint32_t | reserverd2:6
uint32_t | reserverd3

Detailed Description

sd card scr information

Definition at line 218 of file sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ cmd20_support

uint32_t sd_scr_struct_type::cmd20_support

Definition at line 227 of file sd_mmc_card/inc/at32_sdio.h.

◆ cmd23_support

uint32_t sd_scr_struct_type::cmd23_support

Definition at line 228 of file sd_mmc_card/inc/at32_sdio.h.

◆ data_stat_after_erase

uint32_t sd_scr_struct_type::data_stat_after_erase

Definition at line 224 of file sd_mmc_card/inc/at32_sdio.h.

◆ reserved1

uint32_t sd_scr_struct_type::reserved1

Definition at line 225 of file sd_mmc_card/inc/at32_sdio.h.

◆ reserverd2

uint32_t sd_scr_struct_type::reserverd2

Definition at line 229 of file sd_mmc_card/inc/at32_sdio.h.

◆ reserverd3

uint32_t sd_scr_struct_type::reserverd3

Definition at line 230 of file sd_mmc_card/inc/at32_sdio.h.

◆ scr_structure

uint32_t sd_scr_struct_type::scr_structure

Definition at line 221 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_bus_width

uint32_t sd_scr_struct_type::sd_bus_width

Definition at line 222 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_bus_wide_enable().

◆ sd_security

uint32_t sd_scr_struct_type::sd_security

Definition at line 223 of file sd_mmc_card/inc/at32_sdio.h.

◆ sd_spec

uint32_t sd_scr_struct_type::sd_spec

Definition at line 220 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by speed_change().

◆ sd_spec3

uint32_t sd_scr_struct_type::sd_spec3

Definition at line 226 of file sd_mmc_card/inc/at32_sdio.h.

The documentation for this struct was generated from the following files:
  • sd_mmc_card/inc/at32_sdio.h
  • sdio_fatfs/inc/at32_sdio.h


AT32F413 Firmwary Library: sd_card_info_struct_type Struct Reference

Data Fields
sd_card_info_struct_type Struct Reference
AT32F413_periph_examples » SDIO_sd_mmc_card » SDIO_sd_mmc_card_exported_types | AT32F413_periph_examples » SDIO_sdio_fatfs » SDIO_sdio_fatfs_exported_types

#include <at32_sdio.h>

Data Fields

sd_csd_struct_type sd_csd_reg
sd_cid_struct_type sd_cid_reg
sd_scr_struct_type sd_scr_reg
long long | card_capacity
uint32_t | card_blk_size
uint16_t | rca
uint8_t | card_type

Detailed Description

sd card information

Definition at line 236 of file sd_mmc_card/inc/at32_sdio.h.

Field Documentation

◆ card_blk_size

uint32_t sd_card_info_struct_type::card_blk_size

Definition at line 242 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by disk_ioctl(), sd_card_info_get(), and show_card_info().

◆ card_capacity

long long sd_card_info_struct_type::card_capacity

Definition at line 241 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by disk_ioctl(), sd_card_info_get(), and show_card_info().

◆ card_type

uint8_t sd_card_info_struct_type::card_type

Definition at line 244 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by main(), sd_card_info_get(), sd_init(), and show_card_info().

◆ rca

uint16_t sd_card_info_struct_type::rca

Definition at line 243 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by scr_find(), sd_bus_wide_enable(), sd_card_info_get(), sd_init(), and show_card_info().

◆ sd_cid_reg

sd_cid_struct_type sd_card_info_struct_type::sd_cid_reg

Definition at line 239 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), and show_card_info().

◆ sd_csd_reg

sd_csd_struct_type sd_card_info_struct_type::sd_csd_reg

Definition at line 238 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by sd_card_info_get(), sd_init(), and show_card_info().

◆ sd_scr_reg

sd_scr_struct_type sd_card_info_struct_type::sd_scr_reg

Definition at line 240 of file sd_mmc_card/inc/at32_sdio.h.

Referenced by scr_find(), sd_bus_wide_enable(), and speed_change().

The documentation for this struct was generated from the following files:
  • sd_mmc_card/inc/at32_sdio.h
  • sdio_fatfs/inc/at32_sdio.h


AT32F413 Firmwary Library: SDIO_sdio_fatfs_exported_types

Data Structures | Enumerations
SDIO_sdio_fatfs_exported_types
AT32F413_periph_examples » SDIO_sdio_fatfs

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Enumerations

enum sd_data_transfer_mode_type { SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 }
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Detailed Description

Enumeration Type Documentation

◆ sd_card_state_type

enum sd_card_state_type

sd card status

Enumerator
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR
SD_CARD_READY
SD_CARD_IDENTIFICATION
SD_CARD_STANDBY
SD_CARD_TRANSFER
SD_CARD_SENDING
SD_CARD_RECEIVING
SD_CARD_PROGRAMMING
SD_CARD_DISCONNECTED
SD_CARD_ERROR

Definition at line 186 of file sdio_fatfs/inc/at32_sdio.h.

◆ sd_data_transfer_mode_type

enum sd_data_transfer_mode_type

sdio data transfer mode

Enumerator
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE
SD_TRANSFER_POLLING_MODE
SD_TRANSFER_DMA_MODE

Definition at line 64 of file sdio_fatfs/inc/at32_sdio.h.

◆ sd_error_status_type

enum sd_error_status_type

sdio error defines

Enumerator
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass
SD_CMD_FAIL | command response received (but crc check error)
SD_DATA_FAIL | data bock sent/received (crc check error)
SD_CMD_RSP_TIMEOUT | command response timeout
SD_DATA_TIMEOUT | data time out
SD_TX_UNDERRUN | transmit fifo under-run
SD_RX_OVERRUN | receive fifo over-run
SD_START_BIT_ERR | start bit not detected on all data signals in wide bus mode
SD_CMD_OUT_OF_RANGE | cmd's argument was out of range.
SD_ADDR_MISALIGNED | misaligned address
SD_BLK_LEN_ERR | transferred block length is not allowed for the card or the number of transferred bytes does not match the block length
SD_ERASE_SEQ_ERR | an error in the sequence of erase command occurs.
SD_INVALID_ERASE_PARAM | an invalid selection for erase groups
SD_WR_PROTECT_VIOLATION | attempt to program a write protect block
SD_LOCK_UNLOCK_ERROR | sequence or password error has been detected in unlock command or if there was an attempt to access a locked card
SD_CMD_CRC_ERROR | crc check of the previous command error
SD_ILLEGAL_CMD | command is not legal for the card state
SD_CARD_ECC_ERROR | card internal ecc was applied but error to correct the data
SD_CARD_CONTROLLER_ERR | internal card controller error
SD_GENERAL_UNKNOWN_ERROR | general or unknown error
SD_STREAM_RD_UNDERRUN | the card could not sustain data transfer in stream read operation.
SD_STREAM_WR_OVERRUN | the card could not sustain data programming in stream mode
SD_CID_CSD_OVERWRITE | cid/csd overwrite error
SD_WP_ERASE_SKIP | only partial address space was erased
SD_CARD_ECC_DISABLED | command has been executed without using internal ecc
SD_ERASE_RESET | erase sequence was cleared before executing because an out of erase sequence command was received
SD_AKE_SEQ_ERROR | error in sequence of authentication.
SD_INVALID_VOLTRANGE | invalid voltage range
SD_ADDR_OUT_OF_RANGE | address out of range
SD_SWITCH_ERROR | switch error
SD_SDIO_DISABLED | sdio disabled
SD_SDIO_FUNC_BUSY | function busy
SD_SDIO_FUNC_ERROR | function error
SD_SDIO_UNKNOWN_FUNC | unknown function
SD_INTERNAL_ERROR | internal error
SD_NOT_CONFIGURED | sdio doesn't configuration
SD_REQ_PENDING | request pending
SD_REQ_NOT_APPLICABLE | request isn't applicable
SD_INVALID_PARAMETER | invalid parameter
SD_UNSUPPORTED_FEATURE | unsupported feature
SD_UNSUPPORTED_HW | unsupported hardware
SD_ERROR | error
SD_OK | pass

Definition at line 73 of file sdio_fatfs/inc/at32_sdio.h.

◆ sd_memory_card_type

enum sd_memory_card_type

supported sd memory cards

Enumerator
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD
SDIO_STD_CAPACITY_SD_CARD_V1_1
SDIO_STD_CAPACITY_SD_CARD_V2_0
SDIO_HIGH_CAPACITY_SD_CARD
SDIO_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_CARD
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
SDIO_HIGH_CAPACITY_MMC_CARD
SDIO_SDIO_CARD

Definition at line 202 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_command_index_definition

Macros
SDIO_sd_mmc_card_command_index_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Detailed Description

Macro Definition Documentation

◆ SD_CMD_ALL_SEND_CID

#define SD_CMD_ALL_SEND_CID ((uint8_t)2)

Definition at line 260 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_APP_CMD

#define SD_CMD_APP_CMD ((uint8_t)55)

Definition at line 295 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_APP_SD_SET_BUSWIDTH

#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)

following commands are sd card specific commands. should be sent before sending these commands.

Definition at line 303 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_CLR_WRITE_PROT

#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)

Definition at line 285 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE

#define SD_CMD_ERASE ((uint8_t)38)

Definition at line 291 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_END

#define SD_CMD_ERASE_GRP_END ((uint8_t)36)

Definition at line 290 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_START

#define SD_CMD_ERASE_GRP_START ((uint8_t)35)

Definition at line 289 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_FAST_IO

#define SD_CMD_FAST_IO ((uint8_t)39)

Definition at line 292 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GEN_CMD

#define SD_CMD_GEN_CMD ((uint8_t)56)

Definition at line 296 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_IDLE_STATE

#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)

sdio commands index

Definition at line 258 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_INACTIVE_STATE

#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)

Definition at line 273 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_GO_IRQ_STATE

#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)

Definition at line 293 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_READ

#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)

Definition at line 272 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_WRITE

#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)

Definition at line 277 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_SEND_EXT_CSD

#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)

Definition at line 266 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_HS_SWITCH

#define SD_CMD_HS_SWITCH ((uint8_t)6)

Definition at line 264 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_LOCK_UNLOCK

#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)

Definition at line 294 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_NO_CMD

#define SD_CMD_NO_CMD ((uint8_t)64)

Definition at line 297 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_PROG_CID

#define SD_CMD_PROG_CID ((uint8_t)26)

Definition at line 282 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_PROG_CSD

#define SD_CMD_PROG_CSD ((uint8_t)27)

Definition at line 283 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_DAT_UNTIL_STOP

#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)

Definition at line 269 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_MULT_BLOCK

#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)

Definition at line 276 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_READ_SINGLE_BLOCK

#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)

Definition at line 275 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_CHANGE_SECURE_AREA

#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)

Definition at line 325 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RES1

#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)

Definition at line 321 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RN2

#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)

Definition at line 319 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MID

#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)

Definition at line 317 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MKB

#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)

following commands are sd card specific security commands. sdio_app_cmd should be sent before sending these commands.

Definition at line 316 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_OP_COND

#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)

Definition at line 306 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_ERASE

#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)

Definition at line 324 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK

#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)

Definition at line 322 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MKB

#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Definition at line 326 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK

#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)

Definition at line 323 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS

#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)

Definition at line 305 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_SCR

#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)

Definition at line 308 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RES2

#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)

Definition at line 320 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RN1

#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)

Definition at line 318 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CLR_CARD_DETECT

#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)

Definition at line 307 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_STAUS

#define SD_CMD_SD_APP_STAUS ((uint8_t)13)

Definition at line 304 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_END

#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)

Definition at line 288 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_START

#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)

Definition at line 287 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_DIRECT

#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)

Definition at line 309 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_EXTENDED

#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)

Definition at line 310 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SDIO_SEN_OP_COND

#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)

Definition at line 263 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEL_DESEL_CARD

#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)

Definition at line 265 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_CID

#define SD_CMD_SEND_CID ((uint8_t)10)

Definition at line 268 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_CSD

#define SD_CMD_SEND_CSD ((uint8_t)9)

Definition at line 267 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_OP_COND

#define SD_CMD_SEND_OP_COND ((uint8_t)1)

Definition at line 259 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_STATUS

#define SD_CMD_SEND_STATUS ((uint8_t)13)

Definition at line 271 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SEND_WRITE_PROT

#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)

Definition at line 286 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCK_COUNT

#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)

Definition at line 279 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCKLEN

#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)

Definition at line 274 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_DSR

#define SD_CMD_SET_DSR ((uint8_t)4)

Definition at line 262 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_REL_ADDR

#define SD_CMD_SET_REL_ADDR ((uint8_t)3)

Definition at line 261 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_SET_WRITE_PROT

#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)

Definition at line 284 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_STOP_TRANSMISSION

#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)

Definition at line 270 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_DAT_UNTIL_STOP

#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)

Definition at line 278 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_MULT_BLOCK

#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)

Definition at line 281 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CMD_WRITE_SINGLE_BLOCK

#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)

Definition at line 280 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_paremeters_definition

Macros
SDIO_sd_mmc_card_paremeters_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)

Detailed Description

Macro Definition Documentation

◆ NULL

#define NULL 0

sdio paremeters

Definition at line 339 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_CMD0TIMEOUT

#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)

Definition at line 341 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_DATATIMEOUT

#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 342 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_FIFO_Address

#define SDIO_FIFO_Address ((uint32_t)0x40018080)

Definition at line 343 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_STATIC_FLAGS

#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)

Definition at line 340 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_response_definition

Macros
SDIO_sd_mmc_card_response_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ MMC_SWITCH_ERROR

#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)

Definition at line 374 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_0TO7BITS

#define SD_0TO7BITS ((uint32_t)0x000000FF)

Definition at line 404 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_16TO23BITS

#define SD_16TO23BITS ((uint32_t)0x00FF0000)

Definition at line 406 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_24TO31BITS

#define SD_24TO31BITS ((uint32_t)0xFF000000)

Definition at line 407 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_8TO15BITS

#define SD_8TO15BITS ((uint32_t)0x0000FF00)

Definition at line 405 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_ALLZERO

#define SD_ALLZERO ((uint32_t)0x00000000)

Definition at line 397 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_LOCKED

#define SD_CARD_LOCKED ((uint32_t)0x02000000)

Definition at line 400 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_PROGRAMMING

#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)

Definition at line 401 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CARD_RECEIVING

#define SD_CARD_RECEIVING ((uint32_t)0x00000006)

Definition at line 402 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CHECK_PATTERN

#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)

Definition at line 394 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_DATATIMEOUT

#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 403 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_HALFFIFO

#define SD_HALFFIFO ((uint32_t)0x00000008)

Definition at line 409 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_HALFFIFOBYTES

#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Definition at line 410 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_HIGH_CAPACITY

#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)

Definition at line 392 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_MAX_DATA_LENGTH

#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)

Definition at line 408 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_MAX_VOLT_TRIAL

#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)

Definition at line 396 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ADDR_MISALIGNED

#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)

Definition at line 357 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ADDR_OUT_OF_RANGE

#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)

mask for errors card status r1 (ocr register)

Definition at line 356 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_AKE_SEQ_ERROR

#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)

Definition at line 375 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_BLK_LEN_ERR

#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)

Definition at line 358 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_CONTROLLER_ERR

#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)

Definition at line 366 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_DISABLED

#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)

Definition at line 372 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_ERROR

#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)

Definition at line 365 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CID_CSD_OVERWRIETE

#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)

Definition at line 370 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_CMD_CRC_ERROR

#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)

Definition at line 363 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERASE_RESET

#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)

Definition at line 373 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERASE_SEQ_ERR

#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)

Definition at line 359 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ERRORBITS

#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)

Definition at line 376 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_GENERAL_UNKNOWN_ERROR

#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)

Definition at line 367 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_ILLEGAL_CMD

#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)

Definition at line 364 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_INVALID_ERASE_PARAM

#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)

Definition at line 360 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_LOCK_UNLOCK_ERROR

#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)

Definition at line 362 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_STREAM_RD_UNDERRUN

#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)

Definition at line 368 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_STREAM_WR_OVERRUN

#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)

Definition at line 369 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_WP_ERASE_SKIP

#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)

Definition at line 371 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_OCR_WR_PROTECT_VIOLATION

#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)

Definition at line 361 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_ERROR

#define SD_R5_ERROR ((uint32_t)0x00000800)

Definition at line 383 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_FUNCTION_NUMBER

#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)

Definition at line 382 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R5_OUT_OF_RANGE

#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)

masks for r5 response

Definition at line 381 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_CMD_CRC_ERROR

#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)

Definition at line 390 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_GENERAL_UNKNOWN_ERROR

#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)

masks for r6 response

Definition at line 388 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_R6_ILLEGAL_CMD

#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)

Definition at line 389 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_SINGLE_BUS_SUPPORT

#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)

Definition at line 399 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_STD_CAPACITY

#define SD_STD_CAPACITY ((uint32_t)0x00000000)

Definition at line 393 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_MMC

#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)

Definition at line 395 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_SD

#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)

Definition at line 391 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_WIDE_BUS_SUPPORT

#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)

Definition at line 398 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_command_class_definition

Macros
SDIO_sd_mmc_card_command_class_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ SD_CCCC_ERASE

#define SD_CCCC_ERASE ((uint32_t)0x00000020)

Definition at line 425 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_LOCK_UNLOCK

#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)

command class supported

Definition at line 423 of file sd_mmc_card/inc/at32_sdio.h.

◆ SD_CCCC_WRITE_PROT

#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)

Definition at line 424 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_cmd8_definition

Macros
SDIO_sd_mmc_card_cmd8_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

Detailed Description

Macro Definition Documentation

◆ SDIO_SEND_IF_COND

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

cmd8

Definition at line 438 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_mmc_extend_definition

Macros
SDIO_sd_mmc_card_mmc_extend_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185

Detailed Description

Macro Definition Documentation

◆ EXT_CSD_BUS_WIDTH

#define EXT_CSD_BUS_WIDTH 183

mmc ext_csd offset

Definition at line 463 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Clear_byte

#define EXT_CSD_Clear_byte 0x2

Definition at line 453 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_CPSECURE

#define EXT_CSD_CMD_SET_CPSECURE (1<<2)

Definition at line 458 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_NORMAL

#define EXT_CSD_CMD_SET_NORMAL (1<<0)

Definition at line 456 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_SECURE

#define EXT_CSD_CMD_SET_SECURE (1<<1)

Definition at line 457 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Command_set

#define EXT_CSD_Command_set 0x0

mmc ext_csd operation

Definition at line 451 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_HS_TIMING

#define EXT_CSD_HS_TIMING 185

Definition at line 464 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Set_bit

#define EXT_CSD_Set_bit 0x1

Definition at line 452 of file sd_mmc_card/inc/at32_sdio.h.

◆ EXT_CSD_Write_byte

#define EXT_CSD_Write_byte 0x3

Definition at line 454 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_interrupt_flags_definition

Macros
SDIO_sd_mmc_card_interrupt_flags_definition
AT32F413_periph_examples » SDIO_sd_mmc_card

Macros

#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Detailed Description

Macro Definition Documentation

◆ SDIO_INTR_STS_READ_MASK

#define SDIO_INTR_STS_READ_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f413_sdio.h:86
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f413_sdio.h:90
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f413_sdio.h:88
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f413_sdio.h:94

Definition at line 476 of file sd_mmc_card/inc/at32_sdio.h.

◆ SDIO_INTR_STS_WRITE_MASK

#define SDIO_INTR_STS_WRITE_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f413_sdio.h:89

Definition at line 474 of file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sd_mmc_card_exported_functions

Functions
SDIO_sd_mmc_card_exported_functions
AT32F413_periph_examples » SDIO_sd_mmc_card

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Detailed Description

Function Documentation

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1646 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1693 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1181 of file sd_mmc_card/src/at32_sdio.c.

Referenced by __align(), and sd_single_block_test().

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1360 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_single_block_test(), and sd_write_disk().

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1023 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 525 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 410 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 800 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 779 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2699 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 72 of file sd_mmc_card/src/at32_sdio.c.

Referenced by disk_initialize(), and main().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1782 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1270 of file sd_mmc_card/src/at32_sdio.c.

Referenced by __align(), and sd_multiple_blocks_test().

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1482 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_multiple_blocks_test(), and sd_write_disk().

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 396 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 196 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2482 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2445 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 736 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_stream_test(), sd_multiple_blocks_test(), and sd_single_block_test().

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 181 of file sd_mmc_card/src/at32_sdio.c.


AT32F413 Firmwary Library: SDIO_sdio_fatfs

Modules | Functions | Variables
SDIO_sdio_fatfs
AT32F413_periph_examples

Modules

SDIO_sdio_fatfs_instance_definition
SDIO_sdio_fatfs_exported_types
SDIO_sdio_fatfs_command_index_definition
SDIO_sdio_fatfs_paremeters_definition
SDIO_sdio_fatfs_response_definition
SDIO_sdio_fatfs_command_class_definition
SDIO_sdio_fatfs_cmd8_definition
SDIO_sdio_fatfs_mmc_extend_definition
SDIO_sdio_fatfs_interrupt_flags_definition
SDIO_sdio_fatfs_exported_functions

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
static void | sd_test_error (void)
led2 on off every 300ms for sd test failed. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static error_status | fatfs_test (void)
fatfs file read/write test. More...
int | main (void)
main function. More...

Variables

sd_card_info_struct_type sd_card_info
sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info
FATFS | fs
FIL | file
BYTE | work [FF_MAX_SS]

Detailed Description

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 57 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ check_card_programming()

sd_error_status_type check_card_programming ( uint8_t * p_status )

checks if the sd card is in programming state.

Parameters
p_status pointer to the variable that will contain the sd card state.
Return values
sd_error_status_type sd card error code.

Definition at line 2398 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_write(), sd_block_write(), sd_blocks_erase(), and sd_mult_blocks_write().

◆ command_error()

sd_error_status_type command_error ( void )

checks for error conditions for cmd0.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1873 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_power_on().

◆ command_rsp1_error()

sd_error_status_type command_rsp1_error ( uint8_t cmd )

checks for error conditions for R1 response.

Parameters
cmd the sent command index.
Return values
sd_error_status_type sd card error code.

Definition at line 1937 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), sd_switch(), and sdio_command_data_send().

◆ command_rsp2_error()

sd_error_status_type command_rsp2_error ( void )

checks for error conditions for R2 (cid or csd) response.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 2010 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_init().

◆ command_rsp3_error()

sd_error_status_type command_rsp3_error ( void )

checks for error conditions for R3 (ocr) response.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1980 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_power_on().

◆ command_rsp4_error()

sd_error_status_type command_rsp4_error ( uint8_t cmd )

checks for error conditions for r4 response.

Parameters
cmd the sent command index.
Return values
sd_error_status_type sd card error code.

Definition at line 2050 of file sdio_fatfs/src/at32_sdio.c.

◆ command_rsp5_error()

sd_error_status_type command_rsp5_error ( uint8_t cmd )

checks for error conditions for r5 response.

Parameters
cmd the sent command index.
Return values
sd_error_status_type sd card error code.

Definition at line 2093 of file sdio_fatfs/src/at32_sdio.c.

◆ command_rsp6_error()

sd_error_status_type command_rsp6_error | ( | uint8_t | cmd,
 |  | uint16_t * | prca
 | ) |  |

checks for error conditions for r6 (rca) response.

Parameters
cmd | the sent command index.
prca | pointer to the variable that will contain the sd card relative address rca.
Return values
sd_error_status_type sd card error code.

Definition at line 2156 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_init().

◆ command_rsp7_error()

sd_error_status_type command_rsp7_error ( void )

checks for error conditions for R7 response.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1900 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_power_on().

◆ convert_from_bytes_to_power_of_two()

uint8_t convert_from_bytes_to_power_of_two ( uint16_t number_of_bytes )

converts the number of bytes in power of two and returns the power.

Parameters
number_of_bytes number of bytes.
Return values
none

Definition at line 2685 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ fatfs_test()

static error_status fatfs_test ( void )
static

fatfs file read/write test.

Parameters
none
Return values
ERROR fail. SUCCESS: success.

Definition at line 101 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 205 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1653 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1700 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_test().

◆ mmc_switch()

sd_error_status_type mmc_switch | ( | uint8_t | set,
 |  | uint8_t | index,
 |  | uint8_t | value
 | ) |  |

switch mmc card speed to high speed

Parameters
set | new state of the sdio wide bus mode.
index | offset.
value | expect speed.
Return values
sd_error_status_type sd card error code.

Definition at line 2291 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_wide_bus_operation_config(), and speed_change().

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ nvic_configuration()

static void nvic_configuration ( void )
static

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ scr_find()

sd_error_status_type scr_find ( void )

find the sd card scr register value.

Return values
sd_error_status_type sd card error code.

Definition at line 2507 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1188 of file sdio_fatfs/src/at32_sdio.c.

Referenced by __align(), and sd_single_block_test().

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1367 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_single_block_test(), and sd_write_disk().

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1030 of file sdio_fatfs/src/at32_sdio.c.

◆ sd_bus_wide_enable()

sd_error_status_type sd_bus_wide_enable ( confirm_state new_state )

enable or disable the sdio wide bus mode.

Parameters
new_state new state of the sdio wide bus mode. (true or false)
Return values
sd_error_status_type sd card error code.

Definition at line 2222 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_wide_bus_operation_config().

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 532 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 417 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 807 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 786 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2706 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 73 of file sdio_fatfs/src/at32_sdio.c.

Referenced by disk_initialize(), main(), and sdio_command_data_send().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1789 of file sdio_fatfs/src/at32_sdio.c.

Referenced by SDIO1_IRQHandler(), and SDIO2_IRQHandler().

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1277 of file sdio_fatfs/src/at32_sdio.c.

Referenced by __align(), and sd_multiple_blocks_test().

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1489 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_multiple_blocks_test(), and sd_write_disk().

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 403 of file sdio_fatfs/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 203 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2489 of file sdio_fatfs/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2452 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_switch(), sd_block_write(), sd_mult_blocks_write(), and sd_state_get().

◆ sd_switch()

sd_error_status_type sd_switch | ( | uint32_t | mode,
 |  | uint32_t | group,
 |  | uint8_t | value,
 |  | uint8_t * | rsp
 | ) |  |

switch sd card speed to high speed

Parameters
mode | polling mode or dma mode
group | selected group
value | wanted speed
rsp | switch status
Return values
sd_error_status_type sd card error code.

Definition at line 2342 of file sdio_fatfs/src/at32_sdio.c.

Referenced by speed_change().

◆ sd_test_error()

static void sd_test_error ( void )
static

led2 on off every 300ms for sd test failed.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by main().

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 743 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_test(), sd_init(), sd_multiple_blocks_test(), and sd_single_block_test().

◆ SDIO1_IRQHandler()

void SDIO1_IRQHandler ( void )

sdio1 isr.

Parameters
none.
Return values
none.

Definition at line 1769 of file sdio_fatfs/src/at32_sdio.c.

◆ SDIO2_IRQHandler()

void SDIO2_IRQHandler ( void )

sdio2 isr.

Parameters
none.
Return values
none.

Definition at line 1779 of file sdio_fatfs/src/at32_sdio.c.

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 188 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_command_data_send()

sd_error_status_type sdio_command_data_send | ( | sdio_command_struct_type * | sdio_cmd_init_t,
 |  | sdio_data_struct_type * | sdio_data_init_t,
 |  | uint32_t * | buf
 | ) |  |

read data from or write data to sd card.

Parameters
sdio_cmd_init_struct | pointer to sdio_command_struct_type structure.
sdio_data_init_struct | pointer to sdio_data_struct_type structure.
buf | pointer to data buffer read or write.
Return values
sd_error_status_type sd card error code.

Definition at line 830 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ speed_change()

sd_error_status_type speed_change ( uint8_t speed )

set bus speed

Parameters
speed 0,normal speed; 1,high speed.
Return values
sd_error_status_type sd card error code.

Definition at line 2621 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_init().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.

Variable Documentation

◆ card_type

sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static

Definition at line 43 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_card_info_get(), sd_card_init(), sd_init(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_wide_bus_operation_config(), and speed_change().

◆ cid_table

uint32_t cid_table[4]
static

Definition at line 44 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ csd_table

uint32_t csd_table[4]
static

Definition at line 44 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_card_info_get(), and sd_card_init().

◆ device_mode

sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE
static

Definition at line 45 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_device_mode_set(), and sdio_command_data_send().

◆ file

FIL file

Definition at line 43 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ fs

FATFS fs

Definition at line 42 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().

◆ rca

uint32_t rca = 0
static

Definition at line 44 of file sdio_fatfs/src/at32_sdio.c.

Referenced by check_card_programming(), sd_card_info_get(), sd_card_init(), sd_mult_blocks_write(), and sd_status_send().

◆ sd_card_info [1/2]

sd_card_info_struct_type sd_card_info
extern

Definition at line 48 of file sd_mmc_card/src/at32_sdio.c.

Referenced by scr_find(), sd_bus_wide_enable(), sd_init(), and speed_change().

◆ sd_card_info [2/2]

sd_card_info_struct_type sd_card_info

Definition at line 49 of file sdio_fatfs/src/at32_sdio.c.

Referenced by disk_ioctl(), main(), scr_find(), sd_bus_wide_enable(), sd_init(), show_card_info(), and speed_change().

◆ sdio_command_init_struct

sdio_command_struct_type sdio_command_init_struct

Definition at line 40 of file sdio_fatfs/src/at32_sdio.c.

Referenced by check_card_programming(), mmc_stream_read(), mmc_stream_write(), mmc_switch(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_bus_wide_enable(), sd_card_init(), sd_deselect_select(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_power_on(), sd_status_send(), and sd_switch().

◆ sdio_data_init_struct

sdio_data_struct_type sdio_data_init_struct

Definition at line 41 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), scr_find(), sd_block_read(), sd_block_write(), sd_blocks_erase(), sd_mult_blocks_read(), sd_mult_blocks_write(), and sd_switch().

◆ stop_flag

uint8_t stop_flag = 0
static

Definition at line 46 of file sdio_fatfs/src/at32_sdio.c.

Referenced by mmc_stream_read(), mmc_stream_write(), sd_block_read(), sd_block_write(), sd_irq_service(), sd_mult_blocks_read(), sd_mult_blocks_write(), sd_switch(), and sdio_command_data_send().

◆ transfer_end

volatile uint8_t transfer_end = 0

Definition at line 48 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ transfer_error

volatile sd_error_status_type transfer_error = SD_OK

Definition at line 47 of file sdio_fatfs/src/at32_sdio.c.

Referenced by sd_irq_service(), and sdio_command_data_send().

◆ work

BYTE work[FF_MAX_SS]

Definition at line 44 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.

Referenced by fatfs_test().


AT32F413 Firmwary Library: SDIO_sdio_fatfs_instance_definition

Macros
SDIO_sdio_fatfs_instance_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define SDIOx SDIO1

Detailed Description

Macro Definition Documentation

◆ SDIOx

#define SDIOx SDIO1

Definition at line 51 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_command_index_definition

Macros
SDIO_sdio_fatfs_command_index_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Detailed Description

Macro Definition Documentation

◆ SD_CMD_ALL_SEND_CID

#define SD_CMD_ALL_SEND_CID ((uint8_t)2)

Definition at line 260 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_APP_CMD

#define SD_CMD_APP_CMD ((uint8_t)55)

Definition at line 295 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_APP_SD_SET_BUSWIDTH

#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)

following commands are sd card specific commands. should be sent before sending these commands.

Definition at line 303 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_CLR_WRITE_PROT

#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)

Definition at line 285 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE

#define SD_CMD_ERASE ((uint8_t)38)

Definition at line 291 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_END

#define SD_CMD_ERASE_GRP_END ((uint8_t)36)

Definition at line 290 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_ERASE_GRP_START

#define SD_CMD_ERASE_GRP_START ((uint8_t)35)

Definition at line 289 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_FAST_IO

#define SD_CMD_FAST_IO ((uint8_t)39)

Definition at line 292 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GEN_CMD

#define SD_CMD_GEN_CMD ((uint8_t)56)

Definition at line 296 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_IDLE_STATE

#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)

sdio commands index

Definition at line 258 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_INACTIVE_STATE

#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)

Definition at line 273 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_GO_IRQ_STATE

#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)

Definition at line 293 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_READ

#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)

Definition at line 272 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_BUSTEST_WRITE

#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)

Definition at line 277 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_SEND_EXT_CSD

#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)

Definition at line 266 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_HS_SWITCH

#define SD_CMD_HS_SWITCH ((uint8_t)6)

Definition at line 264 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_LOCK_UNLOCK

#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)

Definition at line 294 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_NO_CMD

#define SD_CMD_NO_CMD ((uint8_t)64)

Definition at line 297 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_PROG_CID

#define SD_CMD_PROG_CID ((uint8_t)26)

Definition at line 282 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_PROG_CSD

#define SD_CMD_PROG_CSD ((uint8_t)27)

Definition at line 283 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_DAT_UNTIL_STOP

#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)

Definition at line 269 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_MULT_BLOCK

#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)

Definition at line 276 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_READ_SINGLE_BLOCK

#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)

Definition at line 275 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_CHANGE_SECURE_AREA

#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)

Definition at line 325 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RES1

#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)

Definition at line 321 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_CER_RN2

#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)

Definition at line 319 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MID

#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)

Definition at line 317 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_GET_MKB

#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)

following commands are sd card specific security commands. sdio_app_cmd should be sent before sending these commands.

Definition at line 316 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_OP_COND

#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)

Definition at line 306 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_ERASE

#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)

Definition at line 324 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK

#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)

Definition at line 322 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MKB

#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)

Definition at line 326 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK

#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)

Definition at line 323 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS

#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)

Definition at line 305 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SEND_SCR

#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)

Definition at line 308 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RES2

#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)

Definition at line 320 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CER_RN1

#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)

Definition at line 318 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_SET_CLR_CARD_DETECT

#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)

Definition at line 307 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_APP_STAUS

#define SD_CMD_SD_APP_STAUS ((uint8_t)13)

Definition at line 304 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_END

#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)

Definition at line 288 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SD_ERASE_GRP_START

#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)

Definition at line 287 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_DIRECT

#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)

Definition at line 309 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_RW_EXTENDED

#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)

Definition at line 310 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SDIO_SEN_OP_COND

#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)

Definition at line 263 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEL_DESEL_CARD

#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)

Definition at line 265 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_CID

#define SD_CMD_SEND_CID ((uint8_t)10)

Definition at line 268 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_CSD

#define SD_CMD_SEND_CSD ((uint8_t)9)

Definition at line 267 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_OP_COND

#define SD_CMD_SEND_OP_COND ((uint8_t)1)

Definition at line 259 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_STATUS

#define SD_CMD_SEND_STATUS ((uint8_t)13)

Definition at line 271 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SEND_WRITE_PROT

#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)

Definition at line 286 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCK_COUNT

#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)

Definition at line 279 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_BLOCKLEN

#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)

Definition at line 274 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_DSR

#define SD_CMD_SET_DSR ((uint8_t)4)

Definition at line 262 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_REL_ADDR

#define SD_CMD_SET_REL_ADDR ((uint8_t)3)

Definition at line 261 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_SET_WRITE_PROT

#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)

Definition at line 284 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_STOP_TRANSMISSION

#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)

Definition at line 270 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_DAT_UNTIL_STOP

#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)

Definition at line 278 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_MULT_BLOCK

#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)

Definition at line 281 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CMD_WRITE_SINGLE_BLOCK

#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)

Definition at line 280 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_paremeters_definition

Macros
SDIO_sdio_fatfs_paremeters_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)

Detailed Description

Macro Definition Documentation

◆ NULL

#define NULL 0

sdio paremeters

Definition at line 339 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_CMD0TIMEOUT

#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)

Definition at line 341 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_DATATIMEOUT

#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 342 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_FIFO_Address

#define SDIO_FIFO_Address ((uint32_t)0x40018080)

Definition at line 343 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_STATIC_FLAGS

#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)

Definition at line 340 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_response_definition

Macros
SDIO_sdio_fatfs_response_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ MMC_SWITCH_ERROR

#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)

Definition at line 374 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_0TO7BITS

#define SD_0TO7BITS ((uint32_t)0x000000FF)

Definition at line 404 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_16TO23BITS

#define SD_16TO23BITS ((uint32_t)0x00FF0000)

Definition at line 406 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_24TO31BITS

#define SD_24TO31BITS ((uint32_t)0xFF000000)

Definition at line 407 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_8TO15BITS

#define SD_8TO15BITS ((uint32_t)0x0000FF00)

Definition at line 405 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_ALLZERO

#define SD_ALLZERO ((uint32_t)0x00000000)

Definition at line 397 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_LOCKED

#define SD_CARD_LOCKED ((uint32_t)0x02000000)

Definition at line 400 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_PROGRAMMING

#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)

Definition at line 401 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CARD_RECEIVING

#define SD_CARD_RECEIVING ((uint32_t)0x00000006)

Definition at line 402 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CHECK_PATTERN

#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)

Definition at line 394 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_DATATIMEOUT

#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)

Definition at line 403 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_HALFFIFO

#define SD_HALFFIFO ((uint32_t)0x00000008)

Definition at line 409 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_HALFFIFOBYTES

#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)

Definition at line 410 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_HIGH_CAPACITY

#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)

Definition at line 392 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_MAX_DATA_LENGTH

#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)

Definition at line 408 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_MAX_VOLT_TRIAL

#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)

Definition at line 396 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ADDR_MISALIGNED

#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)

Definition at line 357 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ADDR_OUT_OF_RANGE

#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)

mask for errors card status r1 (ocr register)

Definition at line 356 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_AKE_SEQ_ERROR

#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)

Definition at line 375 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_BLK_LEN_ERR

#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)

Definition at line 358 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_CONTROLLER_ERR

#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)

Definition at line 366 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_DISABLED

#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)

Definition at line 372 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CARD_ECC_ERROR

#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)

Definition at line 365 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CID_CSD_OVERWRIETE

#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)

Definition at line 370 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_CMD_CRC_ERROR

#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)

Definition at line 363 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERASE_RESET

#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)

Definition at line 373 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERASE_SEQ_ERR

#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)

Definition at line 359 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ERRORBITS

#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)

Definition at line 376 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_GENERAL_UNKNOWN_ERROR

#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)

Definition at line 367 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_ILLEGAL_CMD

#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)

Definition at line 364 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_INVALID_ERASE_PARAM

#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)

Definition at line 360 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_LOCK_UNLOCK_ERROR

#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)

Definition at line 362 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_STREAM_RD_UNDERRUN

#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)

Definition at line 368 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_STREAM_WR_OVERRUN

#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)

Definition at line 369 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_WP_ERASE_SKIP

#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)

Definition at line 371 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_OCR_WR_PROTECT_VIOLATION

#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)

Definition at line 361 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_ERROR

#define SD_R5_ERROR ((uint32_t)0x00000800)

Definition at line 383 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_FUNCTION_NUMBER

#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)

Definition at line 382 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R5_OUT_OF_RANGE

#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)

masks for r5 response

Definition at line 381 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_CMD_CRC_ERROR

#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)

Definition at line 390 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_GENERAL_UNKNOWN_ERROR

#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)

masks for r6 response

Definition at line 388 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_R6_ILLEGAL_CMD

#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)

Definition at line 389 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_SINGLE_BUS_SUPPORT

#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)

Definition at line 399 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_STD_CAPACITY

#define SD_STD_CAPACITY ((uint32_t)0x00000000)

Definition at line 393 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_MMC

#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)

Definition at line 395 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_VOLTAGE_WINDOW_SD

#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)

Definition at line 391 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_WIDE_BUS_SUPPORT

#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)

Definition at line 398 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_command_class_definition

Macros
SDIO_sdio_fatfs_command_class_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)

Detailed Description

Macro Definition Documentation

◆ SD_CCCC_ERASE

#define SD_CCCC_ERASE ((uint32_t)0x00000020)

Definition at line 425 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CCCC_LOCK_UNLOCK

#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)

command class supported

Definition at line 423 of file sdio_fatfs/inc/at32_sdio.h.

◆ SD_CCCC_WRITE_PROT

#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)

Definition at line 424 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_cmd8_definition

Macros
SDIO_sdio_fatfs_cmd8_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

Detailed Description

Macro Definition Documentation

◆ SDIO_SEND_IF_COND

#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)

cmd8

Definition at line 438 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_mmc_extend_definition

Macros
SDIO_sdio_fatfs_mmc_extend_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185

Detailed Description

Macro Definition Documentation

◆ EXT_CSD_BUS_WIDTH

#define EXT_CSD_BUS_WIDTH 183

mmc ext_csd offset

Definition at line 463 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Clear_byte

#define EXT_CSD_Clear_byte 0x2

Definition at line 453 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_CPSECURE

#define EXT_CSD_CMD_SET_CPSECURE (1<<2)

Definition at line 458 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_NORMAL

#define EXT_CSD_CMD_SET_NORMAL (1<<0)

Definition at line 456 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_CMD_SET_SECURE

#define EXT_CSD_CMD_SET_SECURE (1<<1)

Definition at line 457 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Command_set

#define EXT_CSD_Command_set 0x0

mmc ext_csd operation

Definition at line 451 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_HS_TIMING

#define EXT_CSD_HS_TIMING 185

Definition at line 464 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Set_bit

#define EXT_CSD_Set_bit 0x1

Definition at line 452 of file sdio_fatfs/inc/at32_sdio.h.

◆ EXT_CSD_Write_byte

#define EXT_CSD_Write_byte 0x3

Definition at line 454 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_interrupt_flags_definition

Macros
SDIO_sdio_fatfs_interrupt_flags_definition
AT32F413_periph_examples » SDIO_sdio_fatfs

Macros

#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Detailed Description

Macro Definition Documentation

◆ SDIO_INTR_STS_READ_MASK

#define SDIO_INTR_STS_READ_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f413_sdio.h:86
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f413_sdio.h:90
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f413_sdio.h:88
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f413_sdio.h:94

Definition at line 476 of file sdio_fatfs/inc/at32_sdio.h.

◆ SDIO_INTR_STS_WRITE_MASK

#define SDIO_INTR_STS_WRITE_MASK
Value:
(SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f413_sdio.h:89

Definition at line 474 of file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: SDIO_sdio_fatfs_exported_functions

Functions
SDIO_sdio_fatfs_exported_functions
AT32F413_periph_examples » SDIO_sdio_fatfs

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Detailed Description

Function Documentation

◆ mmc_stream_read()

sd_error_status_type mmc_stream_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

read mmc card data stream.

Parameters
buf | buffer of saving data from mmc card
addr | start address of data from mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1646 of file sd_mmc_card/src/at32_sdio.c.

◆ mmc_stream_write()

sd_error_status_type mmc_stream_write | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint32_t | len
 | ) |  |

write mmc card data stream.

Parameters
buf | data that writing to mmc card
addr | start address mmc card
len | data size
Return values
sd_error_status_type sd card error code.

Definition at line 1693 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_block_read()

sd_error_status_type sd_block_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1181 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_block_write()

sd_error_status_type sd_block_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size
 | ) |  |

allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
Return values
sd_error_status_type sd card error code.

Definition at line 1360 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_blocks_erase()

sd_error_status_type sd_blocks_erase | ( | long long | addr,
 |  | uint32_t | nblks
 | ) |  |

erase continuous data block

Parameters
addr | starting address
nblks | amount of erasing data block
Return values
sd_error_status_type sd card error code.

Definition at line 1023 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_card_info_get()

sd_error_status_type sd_card_info_get ( sd_card_info_struct_type * card_info )

returns information about specific card.

Parameters
card_info pointer to a sd_card_info_struct_type structure that contains all sd card information.
Return values
sd_error_status_type sd card error code.

Definition at line 525 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_card_init()

sd_error_status_type sd_card_init ( void )

intialises all cards or single card as the case may be card(s) come into standby state.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 410 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_deselect_select()

sd_error_status_type sd_deselect_select ( uint32_t addr )

selects od deselects the corresponding card.

Parameters
addr address of the card to be selected.
Return values
sd_error_status_type sd card error code.

Definition at line 800 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_device_mode_set()

sd_error_status_type sd_device_mode_set ( uint32_t mode )

set sdio work mode.

Parameters
mode parameter as following values:
  • SD_TRANSFER_POLLING_MODE: dma mode.
  • SD_TRANSFER_POLLING_MODE: polling mode.
Return values
sd_error_status_type sd card error code.

Definition at line 779 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_dma_config()

void sd_dma_config | ( | uint32_t * | mbuf,
 |  | uint32_t | buf_size,
 |  | dma_dir_type | dir
 | ) |  |

set dma configuation for sdio

Parameters
mbuf | buffer address
buf_size | transmission data size
dir | dma direction, it is DMA_DIR_MEMORY_TO_PERIPHERAL(writing data) or DMA_DIR_PERIPHERAL_TO_MEMORY(read data)
Return values
none

Definition at line 2699 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_init()

sd_error_status_type sd_init ( void )

initializes the sd card and put it into standby state (ready for data transfer).

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 72 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sdio_command_data_send().

◆ sd_irq_service()

sd_error_status_type sd_irq_service ( void )

allows to process all the interrupts that are high.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 1782 of file sd_mmc_card/src/at32_sdio.c.

Referenced by SDIO1_IRQHandler(), and SDIO2_IRQHandler().

◆ sd_mult_blocks_read()

sd_error_status_type sd_mult_blocks_read | ( | uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode.

Parameters
buf | pointer to the buffer that will contain the received data.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be read.
Return values
sd_error_status_type sd card error code.

Definition at line 1270 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_mult_blocks_write()

sd_error_status_type sd_mult_blocks_write | ( | const uint8_t * | buf,
 |  | long long | addr,
 |  | uint16_t | blk_size,
 |  | uint32_t | nblks
 | ) |  |

allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only.

Parameters
buf | pointer to the buffer that contain the data to be transferred.
addr | address from where data are to be read.
blk_size | the sd card data block size. the block size should be 512.
nblks | number of blocks to be written.
Return values
sd_error_status_type sd card error code.

Definition at line 1482 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_power_off()

sd_error_status_type sd_power_off ( void )

turns the sdio output signals off.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 396 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_power_on()

sd_error_status_type sd_power_on ( void )

enquires cards about their operating voltage and configures clock controls.

Parameters
none
Return values
sd_error_status_type sd card error code.

Definition at line 196 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sd_state_get()

sd_card_state_type sd_state_get ( void )

returns information about sd card.

Parameters
none.
Return values
sd_card_state_type sd card state code.

Definition at line 2482 of file sd_mmc_card/src/at32_sdio.c.

◆ sd_status_send()

sd_error_status_type sd_status_send ( uint32_t * p_card_status )

read current card status.

Parameters
p_card_status card status.
Return values
sd_error_status_type sd card error code.

Definition at line 2445 of file sd_mmc_card/src/at32_sdio.c.

Referenced by mmc_switch(), sd_block_write(), sd_mult_blocks_write(), and sd_state_get().

◆ sd_wide_bus_operation_config()

sd_error_status_type sd_wide_bus_operation_config ( sdio_bus_width_type mode )

enable wide bus opeartion for the requeseted card if supported by card.

Parameters
mode specifies the sd card wide bus mode. this parameter can be one of the following values:
  • SDIO_BUS_WIDTH_D8: 8-bit data transfer (only for mmc)
  • SDIO_BUS_WIDTH_D4: 4-bit data transfer
  • SDIO_BUS_WIDTH_D1: 1-bit data transfer
Return values
sd_error_status_type sd card error code.

Definition at line 736 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().

◆ sdio_clock_set()

void sdio_clock_set ( uint32_t clk_div )

set sdio clock devision factor.

Parameters
clkdiv sdio_ck = ahbclk / (clkdiv+2)
Return values
none

Definition at line 181 of file sd_mmc_card/src/at32_sdio.c.

Referenced by sd_init().


AT32F413 Firmwary Library: SPI_crc_transfer_polling

Macros | Functions | Variables
SPI_crc_transfer_polling
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | spi1_tx_buffer [32]
uint16_t | spi2_tx_buffer [32]
uint16_t | spi1_rx_buffer [32]
uint16_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
__IO uint16_t | crc1_value = 0
__IO uint16_t | crc2_value = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 39 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint16_t * | pbuffer1,
 |  | uint16_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 64 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

Definition at line 115 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi crc calculation error flag

< spi crc calculation error flag

< spi crc calculation error flag

< spi crc calculation error flag

Definition at line 169 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.

Variable Documentation

◆ crc1_value

__IO uint16_t crc1_value = 0

Definition at line 51 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ crc2_value

__IO uint16_t crc2_value = 0

Definition at line 51 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ rx_index

uint32_t rx_index = 0

Definition at line 50 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi1_rx_buffer

uint16_t spi1_rx_buffer[32]

Definition at line 49 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi1_tx_buffer

uint16_t spi1_tx_buffer[32]
Initial value:
= {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C, 0x0D0E, 0x0F10,
0x1112, 0x1314, 0x1516, 0x1718, 0x191A, 0x1B1C, 0x1D1E, 0x1F20,
0x2122, 0x2324, 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C, 0x3D3E, 0x3F40}

Definition at line 41 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint16_t spi2_rx_buffer[32]

Definition at line 49 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ spi2_tx_buffer

uint16_t spi2_tx_buffer[32]
Initial value:
= {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C, 0x5D5E, 0x5F60,
0x6162, 0x6364, 0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C, 0x8D8E, 0x8F90}

Definition at line 45 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 52 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 52 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().

◆ tx_index

uint32_t tx_index = 0

Definition at line 50 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SPI_fullduplex_polling

Macros | Functions | Variables
SPI_fullduplex_polling
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (uint16_t spi1_mode, uint16_t spi2_mode)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_tx_buffer [32]
uint8_t | spi1_rx_buffer [32]
uint8_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR
volatile error_status | transfer_status4 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 39 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | bufferlength
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 65 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config | ( | uint16_t | spi1_mode,
 |  | uint16_t | spi2_mode
 | ) |  |
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 6

< gpio pins number 7

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

Definition at line 112 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

Definition at line 204 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.

Variable Documentation

◆ rx_index

uint32_t rx_index = 0

Definition at line 51 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi1_rx_buffer

uint8_t spi1_rx_buffer[32]

Definition at line 50 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 42 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 50 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi2_tx_buffer

uint8_t spi2_tx_buffer[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 46 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ spi_init_struct

spi_init_type spi_init_struct

Definition at line 41 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main(), spi_config(), spi_default_para_init(), spi_init(), spiflash_init(), and usart_spi_configuration().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 52 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 52 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status3

volatile error_status transfer_status3 = ERROR

Definition at line 53 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ transfer_status4

volatile error_status transfer_status4 = ERROR

Definition at line 53 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().

◆ tx_index

uint32_t tx_index = 0

Definition at line 51 of file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SPI_halfduplex_interrupt

Macros | Functions | Variables
SPI_halfduplex_interrupt
AT32F413_periph_examples

Macros

#define | BUFFERSIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

◆ BUFFERSIZE

#define BUFFERSIZE 32

Definition at line 44 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 60 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 7

< gpio pins number 13

< gpio pins number 14

< gpio pins number 13

Definition at line 113 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 60 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 154 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 51 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 130 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ SPI1_IRQHandler()

void SPI1_IRQHandler ( void )

This function handles the spi1 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

Definition at line 148 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ SPI2_IRQHandler()

void SPI2_IRQHandler ( void )

This function handles the spi2 interrupt request.

Parameters
None
Return values
None

< spi or i2s receive data buffer full flag

Definition at line 165 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

< transmit data buffer empty interrupt

< receive data buffer full interrupt

Definition at line 80 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 112 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 139 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 99 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.

Variable Documentation

◆ rx_index

volatile uint32_t rx_index = 0

Definition at line 47 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 42 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 46 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ spi_init_struct

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by spi_config().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 48 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.

Referenced by main().

◆ tx_index

volatile uint32_t tx_index = 0

Definition at line 47 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.


AT32F413 Firmwary Library: SPI_halfduplex_transceiver_switch

Macros | Functions | Variables
SPI_halfduplex_transceiver_switch
AT32F413_periph_examples

Macros

#define | BUFFERSIZE 32
#define | BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_tx_buffer [32]
uint8_t | spi1_rx_buffer [32]
uint8_t | spi2_rx_buffer [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ BUFFERSIZE

#define BUFFERSIZE 32

Definition at line 46 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 64 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 88 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 7

< gpio pins number 13

< gpio pins number 14

< gpio pins number 13

Definition at line 117 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 62 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< transmit data buffer empty interrupt

< receive data buffer full interrupt

< receive data buffer full interrupt

< transmit data buffer empty interrupt

Definition at line 158 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 75 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ SPI1_IRQHandler()

void SPI1_IRQHandler ( void )

This function handles the spi1 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s receive data buffer full flag

< spi or i2s receive data buffer full flag

Definition at line 150 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ SPI2_IRQHandler()

void SPI2_IRQHandler ( void )

This function handles the spi2 interrupt request.

Parameters
None
Return values
None

< spi or i2s transmit data buffer empty flag

< transmit data buffer empty interrupt

< spi or i2s receive data buffer full flag

Definition at line 183 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

< transmit data buffer empty interrupt

< receive data buffer full interrupt

Definition at line 84 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 141 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 101 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.

Variable Documentation

◆ rx_index

volatile uint32_t rx_index = 0

Definition at line 51 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi1_rx_buffer

uint8_t spi1_rx_buffer[32]

Definition at line 50 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main(), and SPI1_IRQHandler().

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 42 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 50 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi2_tx_buffer

uint8_t spi2_tx_buffer[32]
Initial value:
= {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70}

Definition at line 46 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ spi_init_struct

spi_init_type spi_init_struct

Definition at line 41 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main(), and spi_config().

◆ transfer_status1

volatile error_status transfer_status1 = ERROR

Definition at line 52 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ transfer_status2

volatile error_status transfer_status2 = ERROR

Definition at line 52 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().

◆ tx_index

volatile uint32_t tx_index = 0

Definition at line 51 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SPI_only_receive_mode_polling

Macros | Functions | Variables
SPI_only_receive_mode_polling
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 59 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< gpio pins number 5

< gpio pins number 7

< gpio pins number 13

< gpio pins number 15

< gpio pins number 13

Definition at line 107 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< spi or i2s receive data buffer full flag

Definition at line 148 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.

Variable Documentation

◆ rx_index

uint32_t rx_index = 0

Definition at line 46 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main(), SPI1_IRQHandler(), and SPI2_IRQHandler().

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 41 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 45 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ spi_init_struct

spi_init_type spi_init_struct

Definition at line 40 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by spi_config().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 47 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().

◆ tx_index

uint32_t tx_index = 0

Definition at line 46 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SPI_use_jtagpin_hardwarecs_dma

Macros | Functions | Variables
SPI_use_jtagpin_hardwarecs_dma
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
__IO uint8_t | tx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 32

Definition at line 38 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 58 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ gpio_config()

static void gpio_config ( void )
static

gpio configuration.

Parameters
none
Return values
none

< jtag-dp disabled and sw-dp enabled

< spi1_cs/i2s1_ws(pa15), spi1_sck/i2s1_ck(pb3), spi1_miso(pb4), spi1_mosi/i2s1_sd(pb5), i2s1_mck(pb6)

< spi1_cs/i2s1_ws(pa15), spi1_sck/i2s1_ck(pb3), spi1_miso(pb4), spi1_mosi/i2s1_sd(pb5), i2s1_mck(pb0)

< gpio pins number 3

< gpio pins number 4

< gpio pins number 5

< gpio pins number 15

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

Definition at line 126 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< spi or i2s transmit data buffer empty flag

< dma1 channel4 full data transfer flag

Definition at line 191 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ spi_config()

static void spi_config ( void )
static

spi configuration.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.

Variable Documentation

◆ spi1_tx_buffer

uint8_t spi1_tx_buffer[32]
Initial value:
= {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20}

Definition at line 40 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), and SPI1_IRQHandler().

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[32]

Definition at line 44 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), and spi_config().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 46 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main().

◆ tx_index

__IO uint8_t tx_index = 0

Definition at line 45 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.

Referenced by main(), SPI1_IRQHandler(), and SPI2_IRQHandler().


AT32F413 Firmwary Library: SPI_w25q_flash

Modules | Macros | Functions | Variables
SPI_w25q_flash
AT32F413_periph_examples

Modules

SPI_flash_cs_pin_definition
SPI_flash_id_definition
SPI_flash_operation_definition
SPI_flash_exported_functions

Macros

#define | SPI_TRANS_DMA
#define | FLASH_TEST_ADDR 0x1000
#define | BUF_SIZE 0x256

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | tx_data_fill (void)
transfer data fill. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...
void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Variables

uint8_t | tx_buffer [0x256]
uint8_t | rx_buffer [0x256]
volatile error_status | transfer_status = ERROR
uint8_t | spiflash_sector_buf [SPIF_SECTOR_SIZE]

Detailed Description

Macro Definition Documentation

◆ BUF_SIZE

#define BUF_SIZE 0x256

Definition at line 40 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

◆ FLASH_TEST_ADDR

#define FLASH_TEST_ADDR 0x1000

Definition at line 39 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

◆ SPI_TRANS_DMA

#define SPI_TRANS_DMA

Definition at line 46 of file spi_flash.h.

Function Documentation

◆ buffer_compare()

error_status buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

buffer compare function.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
the result of compare

Definition at line 69 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ spi_byte_read()

uint8_t spi_byte_read ( void )

read a byte to flash

Parameters
none
Return values
flash return data

Definition at line 504 of file spi_flash.c.

Referenced by spiflash_read_id(), and spiflash_read_sr1().

◆ spi_byte_write()

uint8_t spi_byte_write ( uint8_t data )

write a byte to flash

Parameters
data data to write
Return values
flash return data

Definition at line 487 of file spi_flash.c.

Referenced by spi_byte_read(), spiflash_page_write(), spiflash_read(), spiflash_read_id(), spiflash_read_sr1(), spiflash_sector_erase(), and spiflash_write_enable().

◆ spi_bytes_read()

void spi_bytes_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

read data continuously

Parameters
pbuffer | buffer to save data
length | buffer length
Return values
none

Definition at line 368 of file spi_flash.c.

Referenced by spiflash_read().

◆ spi_bytes_write()

void spi_bytes_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

write data continuously

Parameters
pbuffer | the pointer for data buffer
length | buffer length
Return values
none

Definition at line 303 of file spi_flash.c.

Referenced by spiflash_page_write().

◆ spiflash_init()

void spiflash_init ( void )

spi configuration.

Parameters
none
Return values
none

Definition at line 44 of file spi_flash.c.

Referenced by main().

◆ spiflash_page_write()

void spiflash_page_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write a page data

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 272 of file spi_flash.c.

Referenced by spiflash_write_nocheck().

◆ spiflash_read()

void spiflash_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | read_addr,
 |  | uint32_t | length
 | ) |  |

read data from flash

Parameters
pbuffer | the pointer for data buffer
read_addr | the address where the data is read
length | buffer length
Return values
none

Definition at line 187 of file spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_read_id()

uint16_t spiflash_read_id ( void )

read device id

Parameters
none
Return values
device id

Definition at line 468 of file spi_flash.c.

Referenced by main().

◆ spiflash_read_sr1()

uint8_t spiflash_read_sr1 ( void )

read sr1 register

Parameters
none
Return values
none

Definition at line 441 of file spi_flash.c.

Referenced by spiflash_wait_busy().

◆ spiflash_sector_erase()

void spiflash_sector_erase ( uint32_t erase_addr )

erase a sector data

Parameters
erase_addr sector address to erase
Return values
none

Definition at line 203 of file spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_wait_busy()

void spiflash_wait_busy ( void )

wait program done

Parameters
none
Return values
none

Definition at line 431 of file spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write()

void spiflash_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data to flash

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 99 of file spi_flash.c.

Referenced by main().

◆ spiflash_write_enable()

void spiflash_write_enable ( void )

enable write operation

Parameters
none
Return values
none

Definition at line 456 of file spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write_nocheck()

void spiflash_write_nocheck | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data without check

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 224 of file spi_flash.c.

Referenced by spiflash_write().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

◆ tx_data_fill()

void tx_data_fill ( void )

transfer data fill.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.

Variable Documentation

◆ rx_buffer

uint8_t rx_buffer[0x256]

Definition at line 43 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ spiflash_sector_buf

uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE]

Definition at line 37 of file spi_flash.c.

Referenced by spiflash_write().

◆ transfer_status

volatile error_status transfer_status = ERROR

Definition at line 44 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main().

◆ tx_buffer

uint8_t tx_buffer[0x256]

Definition at line 42 of file project/at_start_f413/examples/spi/w25q_flash/src/main.c.

Referenced by main(), and tx_data_fill().


AT32F413 Firmwary Library: SPI_flash_cs_pin_definition

Macros
SPI_flash_cs_pin_definition
AT32F413_periph_examples » SPI_w25q_flash

Macros

#define | FLASH_CS_HIGH() gpio_bits_set(GPIOB, GPIO_PINS_12)
#define | FLASH_CS_LOW() gpio_bits_reset(GPIOB, GPIO_PINS_12)

Detailed Description

Macro Definition Documentation

◆ FLASH_CS_HIGH

#define FLASH_CS_HIGH ( ) gpio_bits_set(GPIOB, GPIO_PINS_12)

Definition at line 52 of file spi_flash.h.

◆ FLASH_CS_LOW

#define FLASH_CS_LOW ( ) gpio_bits_reset(GPIOB, GPIO_PINS_12)

Definition at line 53 of file spi_flash.h.


AT32F413 Firmwary Library: SPI_flash_id_definition

Macros
SPI_flash_id_definition
AT32F413_periph_examples » SPI_w25q_flash

Macros

#define | W25Q80 0xEF13
#define | W25Q16 0xEF14
#define | W25Q32 0xEF15
#define | W25Q64 0xEF16
#define | W25Q128 0xEF17

Detailed Description

Macro Definition Documentation

◆ W25Q128

#define W25Q128 0xEF17

Definition at line 71 of file spi_flash.h.

◆ W25Q16

#define W25Q16 0xEF14

Definition at line 67 of file spi_flash.h.

◆ W25Q32

#define W25Q32 0xEF15

Definition at line 68 of file spi_flash.h.

◆ W25Q64

#define W25Q64 0xEF16

Definition at line 69 of file spi_flash.h.

◆ W25Q80

#define W25Q80 0xEF13

Definition at line 66 of file spi_flash.h.


AT32F413 Firmwary Library: SPI_flash_operation_definition

Macros
SPI_flash_operation_definition
AT32F413_periph_examples » SPI_w25q_flash

Macros

#define | SPIF_CHIP_SIZE 0x1000000
#define | SPIF_SECTOR_SIZE 4096
#define | SPIF_PAGE_SIZE 256
#define | SPIF_WRITEENABLE 0x06
#define | SPIF_WRITEDISABLE 0x04
#define | SPIF_READSTATUSREG1 0x05
#define | SPIF_WRITESTATUSREG1 0x01
#define | SPIF_READSTATUSREG2 0x35
#define | SPIF_WRITESTATUSREG2 0x31
#define | SPIF_READSTATUSREG3 0x15
#define | SPIF_WRITESTATUSREG3 0x11
#define | SPIF_READDATA 0x03
#define | SPIF_FASTREADDATA 0x0B
#define | SPIF_FASTREADDUAL 0x3B
#define | SPIF_PAGEPROGRAM 0x02
#define | SPIF_BLOCKERASE 0xD8
#define | SPIF_SECTORERASE 0x20
#define | SPIF_CHIPERASE 0xC7
#define | SPIF_POWERDOWN 0xB9
#define | SPIF_RELEASEPOWERDOWN 0xAB
#define | SPIF_DEVICEID 0xAB
#define | SPIF_MANUFACTDEVICEID 0x90
#define | SPIF_JEDECDEVICEID 0x9F
#define | FLASH_SPI_DUMMY_BYTE 0xA5

Detailed Description

Macro Definition Documentation

◆ FLASH_SPI_DUMMY_BYTE

#define FLASH_SPI_DUMMY_BYTE 0xA5

Definition at line 109 of file spi_flash.h.

◆ SPIF_BLOCKERASE

#define SPIF_BLOCKERASE 0xD8

Definition at line 101 of file spi_flash.h.

◆ SPIF_CHIP_SIZE

#define SPIF_CHIP_SIZE 0x1000000

Definition at line 81 of file spi_flash.h.

◆ SPIF_CHIPERASE

#define SPIF_CHIPERASE 0xC7

Definition at line 103 of file spi_flash.h.

◆ SPIF_DEVICEID

#define SPIF_DEVICEID 0xAB

Definition at line 106 of file spi_flash.h.

◆ SPIF_FASTREADDATA

#define SPIF_FASTREADDATA 0x0B

Definition at line 97 of file spi_flash.h.

◆ SPIF_FASTREADDUAL

#define SPIF_FASTREADDUAL 0x3B

Definition at line 98 of file spi_flash.h.

◆ SPIF_JEDECDEVICEID

#define SPIF_JEDECDEVICEID 0x9F

Definition at line 108 of file spi_flash.h.

◆ SPIF_MANUFACTDEVICEID

#define SPIF_MANUFACTDEVICEID 0x90

Definition at line 107 of file spi_flash.h.

◆ SPIF_PAGE_SIZE

#define SPIF_PAGE_SIZE 256

Definition at line 83 of file spi_flash.h.

◆ SPIF_PAGEPROGRAM

#define SPIF_PAGEPROGRAM 0x02

Definition at line 99 of file spi_flash.h.

◆ SPIF_POWERDOWN

#define SPIF_POWERDOWN 0xB9

Definition at line 104 of file spi_flash.h.

◆ SPIF_READDATA

#define SPIF_READDATA 0x03

Definition at line 96 of file spi_flash.h.

◆ SPIF_READSTATUSREG1

#define SPIF_READSTATUSREG1 0x05

Definition at line 88 of file spi_flash.h.

◆ SPIF_READSTATUSREG2

#define SPIF_READSTATUSREG2 0x35

Definition at line 91 of file spi_flash.h.

◆ SPIF_READSTATUSREG3

#define SPIF_READSTATUSREG3 0x15

Definition at line 94 of file spi_flash.h.

◆ SPIF_RELEASEPOWERDOWN

#define SPIF_RELEASEPOWERDOWN 0xAB

Definition at line 105 of file spi_flash.h.

◆ SPIF_SECTOR_SIZE

#define SPIF_SECTOR_SIZE 4096

Definition at line 82 of file spi_flash.h.

◆ SPIF_SECTORERASE

#define SPIF_SECTORERASE 0x20

Definition at line 102 of file spi_flash.h.

◆ SPIF_WRITEDISABLE

#define SPIF_WRITEDISABLE 0x04

Definition at line 86 of file spi_flash.h.

◆ SPIF_WRITEENABLE

#define SPIF_WRITEENABLE 0x06

Definition at line 85 of file spi_flash.h.

◆ SPIF_WRITESTATUSREG1

#define SPIF_WRITESTATUSREG1 0x01

Definition at line 89 of file spi_flash.h.

◆ SPIF_WRITESTATUSREG2

#define SPIF_WRITESTATUSREG2 0x31

Definition at line 92 of file spi_flash.h.

◆ SPIF_WRITESTATUSREG3

#define SPIF_WRITESTATUSREG3 0x11

Definition at line 95 of file spi_flash.h.


AT32F413 Firmwary Library: SPI_flash_exported_functions

Functions
SPI_flash_exported_functions
AT32F413_periph_examples » SPI_w25q_flash

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Detailed Description

Function Documentation

◆ spi_byte_read()

uint8_t spi_byte_read ( void )

read a byte to flash

Parameters
none
Return values
flash return data

Definition at line 504 of file spi_flash.c.

Referenced by spiflash_read_id(), and spiflash_read_sr1().

◆ spi_byte_write()

uint8_t spi_byte_write ( uint8_t data )

write a byte to flash

Parameters
data data to write
Return values
flash return data

Definition at line 487 of file spi_flash.c.

Referenced by spi_byte_read(), spiflash_page_write(), spiflash_read(), spiflash_read_id(), spiflash_read_sr1(), spiflash_sector_erase(), and spiflash_write_enable().

◆ spi_bytes_read()

void spi_bytes_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

read data continuously

Parameters
pbuffer | buffer to save data
length | buffer length
Return values
none

Definition at line 368 of file spi_flash.c.

Referenced by spiflash_read().

◆ spi_bytes_write()

void spi_bytes_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | length
 | ) |  |

write data continuously

Parameters
pbuffer | the pointer for data buffer
length | buffer length
Return values
none

Definition at line 303 of file spi_flash.c.

Referenced by spiflash_page_write().

◆ spiflash_init()

void spiflash_init ( void )

spi configuration.

Parameters
none
Return values
none

Definition at line 44 of file spi_flash.c.

Referenced by main().

◆ spiflash_page_write()

void spiflash_page_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write a page data

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 272 of file spi_flash.c.

Referenced by spiflash_write_nocheck().

◆ spiflash_read()

void spiflash_read | ( | uint8_t * | pbuffer,
 |  | uint32_t | read_addr,
 |  | uint32_t | length
 | ) |  |

read data from flash

Parameters
pbuffer | the pointer for data buffer
read_addr | the address where the data is read
length | buffer length
Return values
none

Definition at line 187 of file spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_read_id()

uint16_t spiflash_read_id ( void )

read device id

Parameters
none
Return values
device id

Definition at line 468 of file spi_flash.c.

Referenced by main().

◆ spiflash_read_sr1()

uint8_t spiflash_read_sr1 ( void )

read sr1 register

Parameters
none
Return values
none

Definition at line 441 of file spi_flash.c.

Referenced by spiflash_wait_busy().

◆ spiflash_sector_erase()

void spiflash_sector_erase ( uint32_t erase_addr )

erase a sector data

Parameters
erase_addr sector address to erase
Return values
none

Definition at line 203 of file spi_flash.c.

Referenced by main(), and spiflash_write().

◆ spiflash_wait_busy()

void spiflash_wait_busy ( void )

wait program done

Parameters
none
Return values
none

Definition at line 431 of file spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write()

void spiflash_write | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data to flash

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 99 of file spi_flash.c.

Referenced by main().

◆ spiflash_write_enable()

void spiflash_write_enable ( void )

enable write operation

Parameters
none
Return values
none

Definition at line 456 of file spi_flash.c.

Referenced by spiflash_page_write(), and spiflash_sector_erase().

◆ spiflash_write_nocheck()

void spiflash_write_nocheck | ( | uint8_t * | pbuffer,
 |  | uint32_t | write_addr,
 |  | uint32_t | length
 | ) |  |

write data without check

Parameters
pbuffer | the pointer for data buffer
write_addr | the address where the data is written
length | buffer length
Return values
none

Definition at line 224 of file spi_flash.c.

Referenced by spiflash_write().


AT32F413 Firmwary Library: SRAM_extend_sram

Functions
SRAM_extend_sram
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | extend_sram (void)
to extend sram size More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ extend_sram()

void extend_sram ( void )

to extend sram size

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/sram/extend_sram/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 75 of file project/at_start_f413/examples/sram/extend_sram/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.


AT32F413 Firmwary Library: TMR_6_steps

Functions | Variables
TMR_6_steps
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | systick_configuration (void)
configures the systick. More...
int | main (void)
main function. More...
void | TMR1_TRG_HALL_TMR11_IRQHandler (void)
this function handles tmr1 trigger and hall interrupts requests. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint32_t | step = 1

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

< tmr interrupt hall

Definition at line 53 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ systick_configuration()

void systick_configuration ( void )

configures the systick.

Parameters
none
Return values
none

Definition at line 185 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

◆ TMR1_TRG_HALL_TMR11_IRQHandler()

void TMR1_TRG_HALL_TMR11_IRQHandler ( void )

this function handles tmr1 trigger and hall interrupts requests.

Parameters
none
Return values
none

< tmr flag hall

Definition at line 202 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 41 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main(), and systick_configuration().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ step

__IO uint32_t step = 1

Definition at line 43 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by TMR1_TRG_HALL_TMR11_IRQHandler().

◆ tmr_brkdt_config_struct

tmr_brkdt_config_type tmr_brkdt_config_struct = {0}

Definition at line 40 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f413/examples/tmr/6_steps/src/main.c.

Referenced by main(), tmr_output_channel_config(), and tmr_output_default_para_init().


AT32F413 Firmwary Library: TMR_7_pwm_output

Functions | Variables
TMR_7_pwm_output
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | channel1_pulse = 0
uint16_t | channel2_pulse = 0
uint16_t | channel3_pulse = 0
uint16_t | channel4_pulse = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 11

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

Definition at line 50 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.

Variable Documentation

◆ channel1_pulse

uint16_t channel1_pulse = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel2_pulse

uint16_t channel2_pulse = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel3_pulse

uint16_t channel3_pulse = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ channel4_pulse

uint16_t channel4_pulse = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ timer_period

uint16_t timer_period = 0

Definition at line 42 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_cascade_synchro

Functions | Variables
TMR_cascade_synchro
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 0

< gpio pins number 6

Definition at line 46 of file project/at_start_f413/examples/tmr/cascade_synchro/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.

Variable Documentation

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/cascade_synchro/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f413/examples/tmr/cascade_synchro/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_complementary_signals

Functions | Variables
TMR_complementary_signals
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
uint16_t | timer_period = 0
uint16_t | channel1_pulse = 0
uint16_t | channel2_pulse = 0
uint16_t | channel3_pulse = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

< gpio pins number 10

< gpio pins number 13

< gpio pins number 14

< gpio pins number 15

< gpio pins number 12

Definition at line 51 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.

Variable Documentation

◆ channel1_pulse

uint16_t channel1_pulse = 0

Definition at line 44 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ channel2_pulse

uint16_t channel2_pulse = 0

Definition at line 44 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ channel3_pulse

uint16_t channel3_pulse = 0

Definition at line 44 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 40 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ timer_period

uint16_t timer_period = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ tmr_brkdt_config_struct

tmr_brkdt_config_type tmr_brkdt_config_struct = {0}

Definition at line 41 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_dma

Functions | Variables
TMR_dma
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type | dma_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | src_buffer [3] = {0, 0, 0}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 10

< gpio pins number 15

Definition at line 51 of file project/at_start_f413/examples/tmr/dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 41 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ dma_init_struct

dma_init_type dma_init_struct = {0}

Definition at line 40 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ src_buffer

uint16_t src_buffer[3] = {0, 0, 0}

Definition at line 44 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ timer_period

uint16_t timer_period = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f413/examples/tmr/dma/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_dma_burst

Functions | Variables
TMR_dma_burst
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type | dma_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | src_buffer [3] = {0x0FFF, 0x0000, 0x0555}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 51 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 41 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ dma_init_struct

dma_init_type dma_init_struct = {0}

Definition at line 40 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ src_buffer

uint16_t src_buffer[3] = {0x0FFF, 0x0000, 0x0555}

Definition at line 44 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().

◆ timer_period

uint16_t timer_period = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 39 of file project/at_start_f413/examples/tmr/dma_burst/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_encoder_tmr2

Functions | Variables
TMR_encoder_tmr2
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | delay (uint32_t time)
delay function More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint32_t | counter

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ delay()

void delay ( uint32_t time )

delay function

Parameters
time number of time to delay
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

< gpio pins number 2

< gpio pins number 3

Definition at line 49 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.

Variable Documentation

◆ counter

uint32_t counter

Definition at line 42 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_external_clock

Functions | Variables
TMR_external_clock
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 7

Definition at line 48 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ tmr_input_config_struct

tmr_input_config_type tmr_input_config_struct

Definition at line 41 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 40 of file project/at_start_f413/examples/tmr/external_clock/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_hall_xor_tmr2

Functions | Variables
TMR_hall_xor_tmr2
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles TMR2 trigger exception. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< tmr interrupt trigger

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

< gpio pins number 3

< gpio pins number 6

< gpio pins number 7

Definition at line 48 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles TMR2 trigger exception.

Parameters
none
Return values
none

< tmr flag trigger

< gpio pins number 8

< tmr flag trigger

Definition at line 139 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

Referenced by main().

◆ tmr_input_config_struct

tmr_input_config_type tmr_input_config_struct

Definition at line 41 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 40 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.


AT32F413 Firmwary Library: TMR_hang_mode

Functions | Variables
TMR_hang_mode
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 8

< gpio pins number 9

Definition at line 48 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ tmr_input_config_struct

tmr_input_config_type tmr_input_config_struct

Definition at line 41 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

Referenced by main().

◆ tmr_output_struct

tmr_output_config_type tmr_output_struct

Definition at line 40 of file project/at_start_f413/examples/tmr/hang_mode/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_input_capture

Functions | Variables
TMR_input_capture
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 trigger exception. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_input_config_type tmr_input_config_struct
__IO uint32_t | tmr3freq = 0
__IO uint32_t | sys_counter = 0
__IO uint16_t | capturenumber = 0
__IO uint16_t | ch3readvalue1 = 0
__IO uint16_t | ch3readvalue2 = 0
__IO uint32_t | capture = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< gpio pins number 7

< tmr interrupt channel 2

Definition at line 91 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

this function handles tmr3 trigger exception.

Parameters
none
Return values
none

< tmr flag channel 2

< tmr flag channel 2

Definition at line 53 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 45 of file app_led3_toggle/src/usart.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.

Variable Documentation

◆ capture

__IO uint32_t capture = 0

Definition at line 46 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ capturenumber

__IO uint16_t capturenumber = 0

Definition at line 44 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ch3readvalue1

__IO uint16_t ch3readvalue1 = 0

Definition at line 45 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ch3readvalue2

__IO uint16_t ch3readvalue2 = 0

Definition at line 45 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by main(), and TMR3_GLOBAL_IRQHandler().

◆ gpio_init_struct

gpio_init_type gpio_init_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by main().

◆ sys_counter

__IO uint32_t sys_counter = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

◆ tmr3freq

__IO uint32_t tmr3freq = 0

Definition at line 42 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by main(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_input_config_struct

tmr_input_config_type tmr_input_config_struct

Definition at line 40 of file project/at_start_f413/examples/tmr/input_capture/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_oc_high

Functions | Variables
TMR_oc_high
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ch1_val = 1000
uint16_t | ch2_val = 500
uint16_t | ch3_val = 250
uint16_t | ch4_val = 125
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 74 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles tmr2 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

Definition at line 140 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint16_t ch1_val = 1000

Definition at line 40 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ch2_val

uint16_t ch2_val = 500

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ch3_val

uint16_t ch3_val = 250

Definition at line 42 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ ch4_val

uint16_t ch4_val = 125

Definition at line 43 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 39 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 44 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by crm_adc_clock_div_set(), crm_clocks_freq_get(), crm_usb_clock_div_set(), main(), rtc_divider_set(), and system_core_clock_update().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/oc_high/src/main.c.

Referenced by main(), mclk_tmr1_init(), and tmr1_config().


AT32F413 Firmwary Library: TMR_oc_low

Functions | Variables
TMR_oc_low
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...
void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 1000
uint16_t | ch2_val = 500
uint16_t | ch3_val = 250
uint16_t | ch4_val = 125
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the gpioc pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 52 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

this function handles tmr2 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

Definition at line 140 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint16_t ch1_val = 1000

Definition at line 39 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ch2_val

uint16_t ch2_val = 500

Definition at line 40 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ch3_val

uint16_t ch3_val = 250

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ ch4_val

uint16_t ch4_val = 125

Definition at line 42 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/oc_low/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_oc_toggle_tmr3

Functions | Variables
TMR_oc_toggle_tmr3
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
int | main (void)
main function. More...

Variables

uint32_t | capture = 0
tmr_output_config_type tmr_oc_init_structure
__IO uint16_t | ch1_val = 32768
__IO uint16_t | ch2_val = 16384
__IO uint16_t | ch3_val = 8192
__IO uint16_t | ch4_val = 4096
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 54 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 59 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

Definition at line 93 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ nvic_configuration()

void nvic_configuration ( void )

configures the nested vectored interrupt controller.

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 138 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

this function handles tmr3 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< tmr flag channel 2

< tmr flag channel 2

< tmr flag channel 3

< tmr flag channel 3

< tmr flag channel 4

< tmr flag channel 4

Definition at line 147 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

Variable Documentation

◆ capture

uint32_t capture = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ ch1_val

__IO uint16_t ch1_val = 32768

Definition at line 39 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ch2_val

__IO uint16_t ch2_val = 16384

Definition at line 40 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ch3_val

__IO uint16_t ch3_val = 8192

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ ch4_val

__IO uint16_t ch4_val = 4096

Definition at line 42 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_oc_toggle_tmr9

Functions | Variables
TMR_oc_toggle_tmr9
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR1_BRK_TMR9_IRQHandler (void)
this function handles TMR9 global interrupt request. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr9 pins. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
int | main (void)
main function. More...

Variables

uint16_t | capture = 0
tmr_output_config_type tmr_oc_init_structure
__IO uint16_t | ch1_val = 32768
__IO uint16_t | ch2_val = 16384
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr9 pins.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

Definition at line 52 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

Definition at line 86 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ nvic_configuration()

void nvic_configuration ( void )

configures the nested vectored interrupt controller.

configures sdio1 irq channel.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.

Referenced by main().

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ TMR1_BRK_TMR9_IRQHandler()

void TMR1_BRK_TMR9_IRQHandler ( void )

this function handles TMR9 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 1

< tmr flag channel 1

< tmr flag channel 2

< tmr flag channel 2

Definition at line 145 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

Variable Documentation

◆ capture

uint16_t capture = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.

Referenced by TMR1_BRK_TMR9_IRQHandler().

◆ ch1_val

__IO uint16_t ch1_val = 32768

Definition at line 39 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ ch2_val

__IO uint16_t ch2_val = 16384

Definition at line 40 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_one_cycle

Functions | Variables
TMR_one_cycle
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
tmr_input_config_type tmr_ic_init_structure
uint16_t div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 75 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 7

< gpio pins number 6

Definition at line 50 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.

Variable Documentation

◆ div_value

uint16_t div_value = 0

Definition at line 40 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ tmr_ic_init_structure

tmr_input_config_type tmr_ic_init_structure

Definition at line 39 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/one_cycle/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_parallel_synchro

Functions | Variables
TMR_parallel_synchro
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 71 of file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 0

< gpio pins number 6

Definition at line 48 of file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 90 of file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.

Variable Documentation

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_input

Functions | Variables
TMR_pwm_input
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | ic2value = 0
tmr_input_config_type tmr_ic_init_structure
__IO uint16_t | duty_cycle = 0
__IO uint32_t | frequency = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 7

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 2

Definition at line 84 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

this function handles tmr3 global interrupt request.

Parameters
none
Return values
none

< tmr flag channel 2

Definition at line 145 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

Variable Documentation

◆ duty_cycle

__IO uint16_t duty_cycle = 0

Definition at line 40 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ frequency

__IO uint32_t frequency = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().

◆ ic2value

__IO uint16_t ic2value = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ tmr_ic_init_structure

tmr_input_config_type tmr_ic_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/pwm_input/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_input_dma

Macros | Functions | Variables
TMR_pwm_input_dma
AT32F413_periph_examples

Macros

#define | TMR1_C1DT_ADDRESS 0x40012C34
#define | TMR1_C2DT_ADDRESS 0x40012C38
#define | SAMPLING_NUM 1000

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
void | DMA1_Channel2_IRQHandler (void)
int | main (void)
main function. More...

Variables

tmr_input_config_type tmr_ic_init_structure
dma_init_type dma_init_structure
__IO uint16_t | buffer_ch1 [1000]
__IO uint16_t | buffer_ch2 [1000]
__IO uint32_t | frequency = 0
__IO float | duty_cycle = 0
uint32_t | freq_result
float | duty_result

Detailed Description

Macro Definition Documentation

◆ SAMPLING_NUM

#define SAMPLING_NUM 1000

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

◆ TMR1_C1DT_ADDRESS

#define TMR1_C1DT_ADDRESS 0x40012C34

Definition at line 39 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

◆ TMR1_C2DT_ADDRESS

#define TMR1_C2DT_ADDRESS 0x40012C38

Definition at line 40 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 103 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ DMA1_Channel2_IRQHandler()

void DMA1_Channel2_IRQHandler ( void )

< dma1 channel2 full data transfer flag

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 84 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma full data transfer interrupt

Definition at line 120 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.

Variable Documentation

◆ buffer_ch1

__IO uint16_t buffer_ch1[1000]

Definition at line 47 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ buffer_ch2

__IO uint16_t buffer_ch2[1000]

Definition at line 48 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ dma_init_structure

dma_init_type dma_init_structure

Definition at line 45 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().

◆ duty_cycle

__IO float duty_cycle = 0

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ duty_result

float duty_result

Definition at line 54 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler().

◆ freq_result

uint32_t freq_result

Definition at line 53 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler().

◆ frequency

__IO uint32_t frequency = 0

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_ic_init_structure

tmr_input_config_type tmr_ic_init_structure

Definition at line 44 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_output_simulate

Functions | Variables
TMR_pwm_output_simulate
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

uint16_t | capture = 0
tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 40961
uint16_t | ch2_val = 27309
uint16_t | ch3_val = 13654
uint16_t | ch4_val = 6826
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 85 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 120 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 8

< gpio pins number 9

Definition at line 54 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt channel 1

< tmr interrupt channel 2

< tmr interrupt channel 3

< tmr interrupt channel 4

Definition at line 87 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 50 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 129 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 111 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 138 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ TMR2_GLOBAL_IRQHandler()

void TMR2_GLOBAL_IRQHandler ( void )

< tmr flag channel 1

< tmr flag channel 1

< gpio pins number 6

< gpio pins number 6

< tmr flag channel 2

< tmr flag channel 2

< gpio pins number 7

< gpio pins number 7

< tmr flag channel 3

< tmr flag channel 3

< gpio pins number 8

< gpio pins number 8

< tmr flag channel 4

< gpio pins number 9

< gpio pins number 9

Definition at line 142 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

Variable Documentation

◆ capture

uint16_t capture = 0

Definition at line 43 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.

Referenced by TMR2_GLOBAL_IRQHandler().

◆ ch1_val

uint16_t ch1_val = 40961

Definition at line 40 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ch2_val

uint16_t ch2_val = 27309

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ch3_val

uint16_t ch3_val = 13654

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ ch4_val

uint16_t ch4_val = 6826

Definition at line 43 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 44 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_output_tmr10

Functions | Variables
TMR_pwm_output_tmr10
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 250
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 8

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 84 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint16_t ch1_val = 250

Definition at line 40 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_pwm_output_tmr3

Functions | Variables
TMR_pwm_output_tmr3
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 333
uint16_t | ch2_val = 249
uint16_t | ch3_val = 166
uint16_t | ch4_val = 83
uint16_t | div_value = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr3 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 0

< gpio pins number 1

Definition at line 54 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint16_t ch1_val = 333

Definition at line 40 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ch2_val

uint16_t ch2_val = 249

Definition at line 41 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ch3_val

uint16_t ch3_val = 166

Definition at line 42 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ ch4_val

uint16_t ch4_val = 83

Definition at line 43 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ div_value

uint16_t div_value = 0

Definition at line 44 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_timer_base

Functions | Variables
TMR_timer_base
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | clkout_config (void)
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles timer1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ clkout_config()

void clkout_config ( void )

< gpio pins number 8

Definition at line 40 of file project/at_start_f413/examples/tmr/timer_base/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< tmr interrupt overflow

Definition at line 85 of file project/at_start_f413/examples/tmr/timer_base/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

◆ TMR1_OVF_TMR10_IRQHandler()

void TMR1_OVF_TMR10_IRQHandler ( void )

this function handles timer1 overflow handler.

Parameters
none
Return values
none

< tmr flag overflow

< tmr flag overflow

Definition at line 70 of file project/at_start_f413/examples/tmr/timer_base/src/main.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.

Variable Documentation

◆ crm_clocks_freq_struct

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Definition at line 38 of file project/at_start_f413/examples/tmr/timer_base/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_tmr1_synchro

Functions | Variables
TMR_tmr1_synchro
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 8

< gpio pins number 6

Definition at line 48 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 87 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.

Variable Documentation

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: TMR_tmr2_32bit

Functions | Variables
TMR_tmr2_32bit
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint32_t | ch1_val = 0x7FFFF
uint32_t | ch2_val = 0x3FFFF
uint32_t | ch3_val = 0x1FFFF
uint32_t | ch4_val = 0xFFFF

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ crm_configuration()

void crm_configuration ( void )

configures the different peripheral clocks.

Parameters
none
Return values
none

Definition at line 72 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ gpio_configuration()

void gpio_configuration ( void )

configure the tmr1 pins.

Parameters
none
Return values
none

< gpio pins number 0

< gpio pins number 1

< gpio pins number 2

< gpio pins number 3

Definition at line 53 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 86 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.

Variable Documentation

◆ ch1_val

uint32_t ch1_val = 0x7FFFF

Definition at line 40 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main(), TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ ch2_val

uint32_t ch2_val = 0x3FFFF

Definition at line 41 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main(), TMR1_BRK_TMR9_IRQHandler(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ ch3_val

uint32_t ch3_val = 0x1FFFF

Definition at line 42 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ ch4_val

uint32_t ch4_val = 0xFFFF

Definition at line 43 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main(), TMR2_GLOBAL_IRQHandler(), and TMR3_GLOBAL_IRQHandler().

◆ tmr_oc_init_structure

tmr_output_config_type tmr_oc_init_structure

Definition at line 38 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_half_duplex

Macros | Functions | Variables
USART_half_duplex
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart half-duplex transfer: usart2 -> usart3"
uint8_t | usart3_tx_buffer [] = "usart half-duplex transfer: usart3 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | data_count

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 101 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 120 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

Definition at line 53 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

Variable Documentation

◆ data_count

uint8_t data_count

Definition at line 46 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart half-duplex transfer: usart2 -> usart3"

Definition at line 42 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart half-duplex transfer: usart3 -> usart2"

Definition at line 43 of file project/at_start_f413/examples/usart/half_duplex/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_hw_flow_control

Macros | Functions | Variables
USART_hw_flow_control
AT32F413_periph_examples

Macros

#define BUFFER_SIZE 16

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | rx_buffer [16]
uint8_t | data_count

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 16

Definition at line 38 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart transmit data buffer empty flag

Definition at line 87 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 1

< gpio pins number 3

< gpio pins number 0

Definition at line 48 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

Referenced by main().

Variable Documentation

◆ data_count

uint8_t data_count

Definition at line 41 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

Referenced by main().

◆ rx_buffer

uint8_t rx_buffer[16]

Definition at line 40 of file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_idle_detection

Functions
USART_idle_detection
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 86 of file project/at_start_f413/examples/usart/idle_detection/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

this function handles usart2 handler.

Parameters
none
Return values
none

< usart idle flag

Definition at line 141 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< usart idle interrupt

Definition at line 43 of file project/at_start_f413/examples/usart/idle_detection/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_interrupt

Macros | Functions | Variables
USART_interrupt
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_counter = 0x00
volatile uint8_t | usart3_tx_counter = 0x00
volatile uint8_t | usart2_rx_counter = 0x00
volatile uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 129 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 89 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 124 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 63 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 148 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 76 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 54 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 133 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 115 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 142 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 102 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

this function handles usart2 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full interrupt

< usart transmit data buffer empty flag

< usart transmit data buffer empty interrupt

Definition at line 151 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ USART3_IRQHandler()

void USART3_IRQHandler ( void )

this function handles usart3 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

< usart receive data buffer full interrupt

< usart transmit data buffer empty flag

< usart transmit data buffer empty interrupt

Definition at line 183 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

< gpio pins number 3

< gpio pins number 11

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

< usart transmit data buffer empty interrupt

< usart transmit data buffer empty interrupt

Definition at line 58 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_rx_counter

volatile uint8_t usart2_rx_counter = 0x00

Definition at line 48 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 42 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 50 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart2_tx_counter

volatile uint8_t usart2_tx_counter = 0x00

Definition at line 46 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_rx_counter

volatile uint8_t usart3_rx_counter = 0x00

Definition at line 49 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 43 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_buffer_size

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f413/examples/usart/interrupt/src/main.c.

Referenced by main().

◆ usart3_tx_counter

volatile uint8_t usart3_tx_counter = 0x00

Definition at line 47 of file project/at_start_f413/examples/usart/interrupt/src/main.c.


AT32F413 Firmwary Library: USART_irda

Functions
USART_irda
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/usart/irda/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

Definition at line 43 of file project/at_start_f413/examples/usart/irda/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_polling

Macros | Functions | Variables
USART_polling
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f413/examples/usart/polling/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f413/examples/usart/polling/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f413/examples/usart/polling/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 118 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart receive data buffer full flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 137 of file project/at_start_f413/examples/usart/polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

< gpio pins number 3

< gpio pins number 11

Definition at line 58 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_rx_counter

uint8_t usart2_rx_counter = 0x00

Definition at line 48 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"

Definition at line 42 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 50 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart2_tx_counter

uint8_t usart2_tx_counter = 0x00

Definition at line 46 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_rx_counter

uint8_t usart3_rx_counter = 0x00

Definition at line 49 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main(), and USART3_IRQHandler().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"

Definition at line 43 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main().

◆ usart3_tx_buffer_size

uint8_t usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart3_tx_counter

uint8_t usart3_tx_counter = 0x00

Definition at line 47 of file project/at_start_f413/examples/usart/polling/src/main.c.

Referenced by main(), and USART3_IRQHandler().


AT32F413 Firmwary Library: USART_printf

Functions | Variables
USART_printf
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Variables

__IO uint32_t time_cnt = 0

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 45 of file project/at_start_f413/examples/usart/printf/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.

Variable Documentation

◆ time_cnt

__IO uint32_t time_cnt = 0

Definition at line 38 of file project/at_start_f413/examples/usart/printf/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_receiver_mute

Macros | Functions | Variables
USART_receiver_mute
AT32F413_periph_examples

Macros

#define | BUFFER_SIZE 7
#define | MATCH_ID_VAL 0x81
#define | ERROR_ID_VAL 0x82
#define | DATA1_VAL 0x7F
#define | DATA2_VAL 0x7A
#define | DATA3_VAL 0x7B
#define | DATA4_VAL 0x7C

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...
void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }
uint8_t | usart3_rx_buffer [7]
uint8_t | tx_counter = 0
uint8_t | rx_counter = 0

Detailed Description

Macro Definition Documentation

◆ BUFFER_SIZE

#define BUFFER_SIZE 7

Definition at line 38 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ DATA1_VAL

#define DATA1_VAL 0x7F

Definition at line 41 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ DATA2_VAL

#define DATA2_VAL 0x7A

Definition at line 42 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ DATA3_VAL

#define DATA3_VAL 0x7B

Definition at line 43 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ DATA4_VAL

#define DATA4_VAL 0x7C

Definition at line 44 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ ERROR_ID_VAL

#define ERROR_ID_VAL 0x82

Definition at line 40 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ MATCH_ID_VAL

#define MATCH_ID_VAL 0x81

Definition at line 39 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< usart transmit data complete flag

Definition at line 110 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ USART3_IRQHandler()

void USART3_IRQHandler ( void )

this function handles usart3 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 143 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 11

< usart receive data buffer full interrupt

Definition at line 56 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by main().

Variable Documentation

◆ rx_counter

uint8_t rx_counter = 0

Definition at line 49 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by USART3_IRQHandler().

◆ tx_counter

uint8_t tx_counter = 0

Definition at line 48 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }

Definition at line 46 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by main().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[7]

Definition at line 47 of file project/at_start_f413/examples/usart/receiver_mute/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: F413_USART_rs485

Macros | Functions | Variables
F413_USART_rs485
AT32F413_periph_examples

Macros

#define | RS485_BAUDRATE 9600
#define | RS485_BUFFER_SIZE 128

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
static void | rs485_config (void)
rs485 configiguration. More...
static void | rs485_send_data (u8 *buf, u8 cnt)
rs485 send data More...
int | main (void)
main function. More...
void | USART2_IRQHandler (void)
usart2 interrupt handler More...

Variables

uint8_t | rs485_buffer_rx [128]
uint8_t | rs485_buffer_rx_cnt = 0

Detailed Description

Macro Definition Documentation

◆ RS485_BAUDRATE

#define RS485_BAUDRATE 9600

Definition at line 38 of file project/at_start_f413/examples/usart/rs485/src/main.c.

◆ RS485_BUFFER_SIZE

#define RS485_BUFFER_SIZE 128

Definition at line 39 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart idle flag

< usart receive data buffer full interrupt

< usart receive data buffer full interrupt

Definition at line 114 of file project/at_start_f413/examples/usart/rs485/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ rs485_config()

static void rs485_config ( void )
static

rs485 configiguration.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

< gpio pins number 1

< gpio pins number 1

< usart receive data buffer full flag

< usart receive data buffer full interrupt

Definition at line 49 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Referenced by main().

◆ rs485_send_data()

static void rs485_send_data | ( | u8 * | buf,
 |  | u8 | cnt
 | ) |  |
static

rs485 send data

Parameters
buf | pointer to the buffer that contain the data to be transferred.
cnt | size of buffer in bytes.
Return values
none

< gpio pins number 1

< usart transmit data buffer empty flag

< usart transmit data complete flag

< gpio pins number 1

Definition at line 98 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

usart2 interrupt handler

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 145 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Variable Documentation

◆ rs485_buffer_rx

uint8_t rs485_buffer_rx[128]

Definition at line 41 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Referenced by main(), and USART2_IRQHandler().

◆ rs485_buffer_rx_cnt

uint8_t rs485_buffer_rx_cnt = 0

Definition at line 42 of file project/at_start_f413/examples/usart/rs485/src/main.c.

Referenced by main(), and USART2_IRQHandler().


AT32F413 Firmwary Library: USART_smartcard

Data Structures | Macros | Functions | Variables
USART_smartcard
AT32F413_periph_examples

Data Structures

struct sc_atr_type

Macros

#define | T0_PROTOCOL 0x00 /* t0 protocol */
#define | SETUP_LENGTH 20
#define | HIST_LENGTH 20
#define | SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
#define | SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
#define | SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EXINT9_5_IRQHandler (void)
this function handles external lines 9 to 5 interrupt request. More...
void | SC_USART_IRQHandler (void)
this function handles sc_usart global interrupt request. More...
void | usart_configuration (void)
config usart More...
uint8_t | sc_response_decode (__IO uint8_t *card)
decode the card atr response. More...
int | main (void)
main function. More...

Variables

sc_atr_type sc_a2r_struct
uint32_t | sc_baud_rate = 0
uint32_t | sc_clock_freq = 0
uint32_t | counter = 0
error_status atr_decode_status = ERROR
uint32_t | card_inserted = 0
uint32_t | card_protocol = 1
uint8_t | dst_buffer [50]

Detailed Description

Macro Definition Documentation

◆ HIST_LENGTH

#define HIST_LENGTH 20

Definition at line 41 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ SC_F_DIV_D

#define SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */

Definition at line 45 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ SC_RECEIVE_TIMEOUT

#define SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */

Definition at line 42 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ SC_USART_DIV_VAL

#define SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */

Definition at line 44 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ SETUP_LENGTH

#define SETUP_LENGTH 20

Definition at line 40 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ T0_PROTOCOL

#define T0_PROTOCOL 0x00 /* t0 protocol */

Definition at line 39 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 81 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 116 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ EXINT9_5_IRQHandler()

void EXINT9_5_IRQHandler ( void )

this function handles external lines 9 to 5 interrupt request.

Parameters
none
Return values
none

Definition at line 143 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 55 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 279 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 68 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 46 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 125 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ sc_response_decode()

uint8_t sc_response_decode ( __IO uint8_t * card )

decode the card atr response.

Parameters
card pointer to the buffer containing the card atr.
Return values
card protocol

Definition at line 203 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ SC_USART_IRQHandler()

void SC_USART_IRQHandler ( void )

this function handles sc_usart global interrupt request.

Parameters
none
Return values
none

< usart parity error flag

< usart receive data buffer full interrupt

< usart receive data buffer full flag

< usart receive data buffer full interrupt

Definition at line 166 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 107 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 134 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 94 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< usart parity error interrupt

Definition at line 75 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

Variable Documentation

◆ atr_decode_status

error_status atr_decode_status = ERROR

Definition at line 62 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ card_inserted

uint32_t card_inserted = 0

Definition at line 63 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by EXINT9_5_IRQHandler(), and main().

◆ card_protocol

uint32_t card_protocol = 1

Definition at line 63 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ counter

uint32_t counter = 0

Definition at line 61 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ dst_buffer

uint8_t dst_buffer[50]
Initial value:
= {
1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
1, 1, 1, 1, 1, 1, 1, 1, 1, 1
}

Definition at line 64 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by main().

◆ sc_a2r_struct

sc_atr_type sc_a2r_struct

Definition at line 58 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ sc_baud_rate

uint32_t sc_baud_rate = 0

Definition at line 59 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by usart_configuration().

◆ sc_clock_freq

uint32_t sc_clock_freq = 0

Definition at line 60 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by usart_configuration().


AT32F413 Firmwary Library: sc_atr_type Struct Reference

Data Fields
sc_atr_type Struct Reference
AT32F413_periph_examples » USART_smartcard

Data Fields

uint8_t | ts
uint8_t | t0
uint8_t | t [20]
uint8_t | h [20]
uint8_t | tlength
uint8_t | hlength

Detailed Description

Definition at line 48 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Field Documentation

◆ h

uint8_t sc_atr_type::h[20]

Definition at line 53 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ hlength

uint8_t sc_atr_type::hlength

Definition at line 55 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ t

uint8_t sc_atr_type::t[20]

Definition at line 52 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ t0

uint8_t sc_atr_type::t0

Definition at line 51 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ tlength

uint8_t sc_atr_type::tlength

Definition at line 54 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

◆ ts

uint8_t sc_atr_type::ts

Definition at line 50 of file project/at_start_f413/examples/usart/smartcard/src/main.c.

Referenced by sc_response_decode().

The documentation for this struct was generated from the following file:
  • project/at_start_f413/examples/usart/smartcard/src/main.c


AT32F413 Firmwary Library: USART_synchronous

Macros | Functions | Variables
USART_synchronous
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | SPI2_TX_BUFFER_SIZE (COUNTOF(spi2_tx_buffer) - 1)
#define | DYMMY_BYTE 0x00

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_spi_configuration (void)
config usart and spi More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart synchronous example: usart2 -> spi2"
uint8_t | spi2_tx_buffer [] = "usart synchronous example: spi2 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(spi2_tx_buffer)/sizeof(*(spi2_tx_buffer))) - 1)]
uint8_t | spi2_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | spi2_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | spi2_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | spi2_tx_buffer_size = ((sizeof( spi2_tx_buffer ) / sizeof(*( spi2_tx_buffer ))) - 1)

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

◆ DYMMY_BYTE

#define DYMMY_BYTE 0x00

Definition at line 41 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

◆ SPI2_TX_BUFFER_SIZE

#define SPI2_TX_BUFFER_SIZE (COUNTOF(spi2_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 134 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< usart transmit data buffer empty flag

< spi or i2s receive data buffer full flag

< usart receive data buffer full flag

< spi or i2s transmit data buffer empty flag

< usart transmit data buffer empty flag

< usart receive data buffer full flag

Definition at line 153 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.

◆ usart_spi_configuration()

void usart_spi_configuration ( void )

config usart and spi

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 4

< gpio pins number 3

< gpio pins number 15

< gpio pins number 13

< gpio pins number 14

Definition at line 59 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

Variable Documentation

◆ spi2_rx_buffer

uint8_t spi2_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 46 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), and SPI2_IRQHandler().

◆ spi2_rx_counter

uint8_t spi2_rx_counter = 0x00

Definition at line 50 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ spi2_tx_buffer

uint8_t spi2_tx_buffer[] = "usart synchronous example: spi2 -> usart2"

Definition at line 44 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), and SPI2_IRQHandler().

◆ spi2_tx_buffer_size

uint8_t spi2_tx_buffer_size = ((sizeof( spi2_tx_buffer ) / sizeof(*( spi2_tx_buffer ))) - 1)

Definition at line 52 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ spi2_tx_counter

uint8_t spi2_tx_counter = 0x00

Definition at line 48 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(spi2_tx_buffer)/sizeof(*(spi2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_rx_counter

uint8_t usart2_rx_counter = 0x00

Definition at line 49 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), and USART2_IRQHandler().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart synchronous example: usart2 -> spi2"

Definition at line 43 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main().

◆ usart2_tx_buffer_size

uint8_t usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)

Definition at line 51 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), USART2_IRQHandler(), and USART3_IRQHandler().

◆ usart2_tx_counter

uint8_t usart2_tx_counter = 0x00

Definition at line 47 of file project/at_start_f413/examples/usart/synchronous/src/main.c.

Referenced by main(), and USART2_IRQHandler().


AT32F413 Firmwary Library: USART_transfer_by_dma_interrupt

Macros | Functions | Variables
USART_transfer_by_dma_interrupt
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma1 channel2 handler. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 handler. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 handler. More...
void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_dma_status = 0
volatile uint8_t | usart2_rx_dma_status = 0
volatile uint8_t | usart3_tx_dma_status = 0
volatile uint8_t | usart3_rx_dma_status = 0

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 231 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 83 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DMA1_Channel1_IRQHandler()

void DMA1_Channel1_IRQHandler ( void )

this function handles dma1 channel1 handler.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel1 full data transfer flag

Definition at line 145 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DMA1_Channel2_IRQHandler()

void DMA1_Channel2_IRQHandler ( void )

this function handles dma1 channel2 handler.

Parameters
none
Return values
none

< dma1 channel2 full data transfer flag

< dma1 channel2 full data transfer flag

Definition at line 160 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DMA1_Channel3_IRQHandler()

void DMA1_Channel3_IRQHandler ( void )

this function handles dma1 channel3 handler.

Parameters
none
Return values
none

< dma1 channel3 full data transfer flag

< dma1 channel3 full data transfer flag

Definition at line 175 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma1 channel4 handler.

Parameters
none
Return values
none

< dma1 channel4 full data transfer flag

< dma1 channel4 full data transfer flag

Definition at line 190 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ dma_configuration()

void dma_configuration ( void )

config dma for usart2 and usart3

Parameters
none
Return values
none

< dma full data transfer interrupt

< dma flexible channel1

< dma full data transfer interrupt

< dma flexible channel2

< dma full data transfer interrupt

< dma flexible channel3

< dma full data transfer interrupt

< dma flexible channel4

Definition at line 115 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 57 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 250 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 70 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 48 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 127 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 109 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 136 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 96 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

< gpio pins number 3

< gpio pins number 11

Definition at line 56 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_rx_dma_status

volatile uint8_t usart2_rx_dma_status = 0

Definition at line 47 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel2_IRQHandler(), and main().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"

Definition at line 42 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart2_tx_dma_status

volatile uint8_t usart2_tx_dma_status = 0

Definition at line 46 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel1_IRQHandler(), and main().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart3_rx_dma_status

volatile uint8_t usart3_rx_dma_status = 0

Definition at line 49 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel4_IRQHandler(), and main().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"

Definition at line 43 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by dma_configuration(), and main().

◆ usart3_tx_dma_status

volatile uint8_t usart3_tx_dma_status = 0

Definition at line 48 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.

Referenced by DMA1_Channel3_IRQHandler(), and main().


AT32F413 Firmwary Library: USART_transfer_by_dma_polling

Macros | Functions | Variables
USART_transfer_by_dma_polling
AT32F413_periph_examples

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Detailed Description

Macro Definition Documentation

◆ COUNTOF

#define COUNTOF ( a ) (sizeof(a) / sizeof(*(a)))

Definition at line 38 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

◆ USART2_TX_BUFFER_SIZE

#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)

Definition at line 39 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

◆ USART3_TX_BUFFER_SIZE

#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Definition at line 40 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Function Documentation

◆ buffer_compare()

uint8_t buffer_compare | ( | uint8_t * | pbuffer1,
 |  | uint8_t * | pbuffer2,
 |  | uint16_t | buffer_length
 | ) |  |

compares two buffers.

Parameters
pbuffer1,pbuffer2 | buffers to be compared.
buffer_length | buffer's length
Return values
1 pbuffer1 identical to pbuffer2 0: pbuffer1 differs from pbuffer2

Definition at line 203 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ dma_configuration()

void dma_configuration ( void )

config dma for usart2 and usart3

Parameters
none
Return values
none

< dma flexible channel1

< dma flexible channel2

< dma flexible channel3

< dma flexible channel4

Definition at line 111 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< dma1 channel1 full data transfer flag

< dma1 channel2 full data transfer flag

< dma1 channel3 full data transfer flag

< dma1 channel4 full data transfer flag

Definition at line 222 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.

◆ usart_configuration()

void usart_configuration ( void )

config usart

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 10

< gpio pins number 3

< gpio pins number 11

Definition at line 52 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by main().

Variable Documentation

◆ usart2_rx_buffer

uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]

Definition at line 44 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), main(), and USART2_IRQHandler().

◆ usart2_tx_buffer

uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"

Definition at line 42 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), main(), and USART2_IRQHandler().

◆ usart3_rx_buffer

uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Definition at line 45 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), main(), and USART3_IRQHandler().

◆ usart3_tx_buffer

uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"

Definition at line 43 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.

Referenced by dma_configuration(), main(), and USART3_IRQHandler().


AT32F413 Firmwary Library: USB_device_audio

Modules | Macros | Functions | Variables
USB_device_audio
AT32F413_periph_examples

Modules

USB_device_audio_codec_reg_definition
USB_device_audio_codec_pin_definition
USB_device_audio_codec_exported_functions

Macros

#define | USB_BUFFER_SIZE_EX
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer More...
#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]
usbd_core_type usb_core_dev

Detailed Description

Macro Definition Documentation

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 41 of file audio/src/audio_codec.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0x00

Definition at line 44 of file audio/src/audio_codec.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 47 of file audio/src/audio_codec.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 46 of file audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 51 of file audio/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 50 of file audio/src/audio_codec.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_8

Definition at line 49 of file audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 55 of file audio/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 54 of file audio/src/audio_codec.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_9

Definition at line 53 of file audio/src/audio_codec.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 100000

Definition at line 43 of file audio/src/audio_codec.c.

◆ USB_BUFFER_SIZE_EX

#define USB_BUFFER_SIZE_EX

usb endpoint max num define

usb buffer extend to 768-1280 bytes usb enable extend buffer

Definition at line 57 of file project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

auto malloc usb endpoint buffer

usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h.

◆ WM8988_REG_BITW16

#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)

wm8988 bit width

Definition at line 66 of file audio/src/audio_codec.c.

◆ WM8988_REG_FREQ16K

#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)

Definition at line 61 of file audio/src/audio_codec.c.

◆ WM8988_REG_FREQ48K

#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)

wm8988 freq

Definition at line 60 of file audio/src/audio_codec.c.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 794 of file audio/src/audio_codec.c.

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 853 of file audio/src/audio_codec.c.

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 169 of file audio/src/audio_codec.c.

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 282 of file audio/src/audio_codec.c.

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 342 of file audio/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 121 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 184 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 206 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 137 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 195 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 217 of file audio/src/audio_codec.c.

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 154 of file audio/src/audio_codec.c.

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 228 of file audio/src/audio_codec.c.

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

codec speaker write fifo

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 244 of file audio/src/audio_codec.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ DMA1_Channel3_IRQHandler()

void DMA1_Channel3_IRQHandler ( void )

this function handles dma1 channel3 interrupt.

Parameters
none
Return values
none

Definition at line 649 of file audio/src/audio_codec.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma1 channel4 interrupt.

Parameters
none
Return values
none

Definition at line 724 of file audio/src/audio_codec.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

Definition at line 399 of file audio/src/audio_codec.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 50 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 169 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 180 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 159 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

Variable Documentation

◆ audio_codec

audio_codec_type audio_codec

Definition at line 106 of file audio/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_mic_get_data(), audio_codec_set_mic_freq(), audio_codec_set_mic_mute(), audio_codec_set_mic_volume(), audio_codec_set_spk_freq(), audio_codec_set_spk_mute(), audio_codec_set_spk_volume(), audio_codec_spk_feedback(), audio_codec_spk_fifo_write(), DMA1_Channel3_IRQHandler(), and DMA1_Channel4_IRQHandler().

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 104 of file audio/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), and audio_codec_modify_freq().

◆ mic_dma_buffer

uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 108 of file audio/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ reg_addr_data

uint16_t reg_addr_data[]

wm8988 register default value

Definition at line 71 of file audio/src/audio_codec.c.

Referenced by audio_codec_init().

◆ spk_dma_buffer

uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 107 of file audio/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 43 of file project/at_start_f413/examples/usb_device/audio/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_audio_codec_reg_definition

Macros
USB_device_audio_codec_reg_definition
AT32F413_periph_examples » USB_device_audio

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36

Detailed Description

Macro Definition Documentation

◆ WM8988_I2C_ADDR_CSB_HIGH

#define WM8988_I2C_ADDR_CSB_HIGH 0x36

Definition at line 94 of file audio/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_LOW

#define WM8988_I2C_ADDR_CSB_LOW 0x34

Definition at line 93 of file audio/inc/audio_codec.h.

◆ WM8988_R0_LEFT_INPUT_VOLUME

#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/

Definition at line 50 of file audio/inc/audio_codec.h.

◆ WM8988_R10_LEFT_DAC_VOLUME

#define WM8988_R10_LEFT_DAC_VOLUME 0x0A

Definition at line 60 of file audio/inc/audio_codec.h.

◆ WM8988_R11_RIGHT_DAC_VOLUME

#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B

Definition at line 61 of file audio/inc/audio_codec.h.

◆ WM8988_R12_BASS_CONTROL

#define WM8988_R12_BASS_CONTROL 0x0C

Definition at line 62 of file audio/inc/audio_codec.h.

◆ WM8988_R13_TREBLE_CONTROL

#define WM8988_R13_TREBLE_CONTROL 0x0D

Definition at line 63 of file audio/inc/audio_codec.h.

◆ WM8988_R14_

#define WM8988_R14_

Definition at line 64 of file audio/inc/audio_codec.h.

◆ WM8988_R15_RESET

#define WM8988_R15_RESET 0x0F

Definition at line 65 of file audio/inc/audio_codec.h.

◆ WM8988_R16_3D_CONTROL

#define WM8988_R16_3D_CONTROL 0x10

Definition at line 66 of file audio/inc/audio_codec.h.

◆ WM8988_R17_ALC1

#define WM8988_R17_ALC1 0x11

Definition at line 67 of file audio/inc/audio_codec.h.

◆ WM8988_R18_ALC2

#define WM8988_R18_ALC2 0x12

Definition at line 68 of file audio/inc/audio_codec.h.

◆ WM8988_R19_ALC3

#define WM8988_R19_ALC3 0x13

Definition at line 69 of file audio/inc/audio_codec.h.

◆ WM8988_R1_RIGHT_INPUT_VOLUME

#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/

Definition at line 51 of file audio/inc/audio_codec.h.

◆ WM8988_R20_NOISE_GATE

#define WM8988_R20_NOISE_GATE 0x14

Definition at line 70 of file audio/inc/audio_codec.h.

◆ WM8988_R21_LEFT_ADC_VOLUME

#define WM8988_R21_LEFT_ADC_VOLUME 0x15

Definition at line 71 of file audio/inc/audio_codec.h.

◆ WM8988_R22_RIGHT_ADC_VOLUME

#define WM8988_R22_RIGHT_ADC_VOLUME 0x16

Definition at line 72 of file audio/inc/audio_codec.h.

◆ WM8988_R23_ADDITIONAL_1_CONTROL

#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17

Definition at line 73 of file audio/inc/audio_codec.h.

◆ WM8988_R24_ADDITIONAL_2_CONTROL

#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18

Definition at line 74 of file audio/inc/audio_codec.h.

◆ WM8988_R25_PWR_1_MGMT

#define WM8988_R25_PWR_1_MGMT 0x19

Definition at line 75 of file audio/inc/audio_codec.h.

◆ WM8988_R26_PWR_2_MGMT

#define WM8988_R26_PWR_2_MGMT 0x1A

Definition at line 76 of file audio/inc/audio_codec.h.

◆ WM8988_R27_ADDITIONAL_3_CONTROL

#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B

Definition at line 77 of file audio/inc/audio_codec.h.

◆ WM8988_R2_LOUT1_VOLUME

#define WM8988_R2_LOUT1_VOLUME 0x02

Definition at line 52 of file audio/inc/audio_codec.h.

◆ WM8988_R31_ADC_INPUT_MODE

#define WM8988_R31_ADC_INPUT_MODE 0x1F

Definition at line 79 of file audio/inc/audio_codec.h.

◆ WM8988_R32_ADC_L_SIGNAL_PATH

#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20

Definition at line 80 of file audio/inc/audio_codec.h.

◆ WM8988_R33_ADC_R_SIGNAL_PATH

#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21

Definition at line 81 of file audio/inc/audio_codec.h.

◆ WM8988_R34_LEFT_OUT_MIX_1

#define WM8988_R34_LEFT_OUT_MIX_1 0x22

Definition at line 82 of file audio/inc/audio_codec.h.

◆ WM8988_R35_LEFT_OUT_MIX_2

#define WM8988_R35_LEFT_OUT_MIX_2 0x23

Definition at line 83 of file audio/inc/audio_codec.h.

◆ WM8988_R36_RIGHT_OUT_MIX_1

#define WM8988_R36_RIGHT_OUT_MIX_1 0x24

Definition at line 84 of file audio/inc/audio_codec.h.

◆ WM8988_R37_RIGHT_OUT_MIX_2

#define WM8988_R37_RIGHT_OUT_MIX_2 0x25

Definition at line 85 of file audio/inc/audio_codec.h.

◆ WM8988_R38_RESERVED

#define WM8988_R38_RESERVED

Definition at line 86 of file audio/inc/audio_codec.h.

◆ WM8988_R39_RESERVED

#define WM8988_R39_RESERVED

Definition at line 87 of file audio/inc/audio_codec.h.

◆ WM8988_R3_ROUT1_VOLUME

#define WM8988_R3_ROUT1_VOLUME 0x03

Definition at line 53 of file audio/inc/audio_codec.h.

◆ WM8988_R40_LOUT2_VOLUME

#define WM8988_R40_LOUT2_VOLUME 0x28

Definition at line 88 of file audio/inc/audio_codec.h.

◆ WM8988_R41_ROUT2_VOLUME

#define WM8988_R41_ROUT2_VOLUME 0x29

Definition at line 89 of file audio/inc/audio_codec.h.

◆ WM8988_R42_RESERVED

#define WM8988_R42_RESERVED

Definition at line 90 of file audio/inc/audio_codec.h.

◆ WM8988_R43_LOW_POWER_PALYBACK

#define WM8988_R43_LOW_POWER_PALYBACK 0x43

Definition at line 91 of file audio/inc/audio_codec.h.

◆ WM8988_R4_RESERVED

#define WM8988_R4_RESERVED 0x04

Definition at line 54 of file audio/inc/audio_codec.h.

◆ WM8988_R5_ADC_DAC_CONTROL

#define WM8988_R5_ADC_DAC_CONTROL 0x05

Definition at line 55 of file audio/inc/audio_codec.h.

◆ WM8988_R6_RESERVED

#define WM8988_R6_RESERVED 0x06

Definition at line 56 of file audio/inc/audio_codec.h.

◆ WM8988_R7_AUDIO_INTERFACE

#define WM8988_R7_AUDIO_INTERFACE 0x07

Definition at line 57 of file audio/inc/audio_codec.h.

◆ WM8988_R8_SAMPLE_RATE

#define WM8988_R8_SAMPLE_RATE 0x08

Definition at line 58 of file audio/inc/audio_codec.h.

◆ WM8988_R9_RESERVED

#define WM8988_R9_RESERVED 0x09

Definition at line 59 of file audio/inc/audio_codec.h.


AT32F413 Firmwary Library: USB_device_audio_codec_pin_definition

Macros
USB_device_audio_codec_pin_definition
AT32F413_periph_examples » USB_device_audio

Macros

#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_12
#define | I2S2_CK_PIN GPIO_PINS_13
#define | I2S2_SD_PIN GPIO_PINS_15
#define | I2S2_GPIO GPIOB
#define | I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)

Detailed Description

Macro Definition Documentation

◆ I2S1_CK_PIN

#define I2S1_CK_PIN GPIO_PINS_5

Definition at line 104 of file audio/inc/audio_codec.h.

◆ I2S1_DT_ADDRESS

#define I2S1_DT_ADDRESS (&(SPI1->dt))

Definition at line 108 of file audio/inc/audio_codec.h.

◆ I2S1_GPIO

#define I2S1_GPIO GPIOA

Definition at line 106 of file audio/inc/audio_codec.h.

◆ I2S1_GPIO_CRM_CLK

#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 107 of file audio/inc/audio_codec.h.

◆ I2S1_SD_PIN

#define I2S1_SD_PIN GPIO_PINS_7

Definition at line 105 of file audio/inc/audio_codec.h.

◆ I2S1_WS_PIN

#define I2S1_WS_PIN GPIO_PINS_4

Definition at line 103 of file audio/inc/audio_codec.h.

◆ I2S2_CK_PIN

#define I2S2_CK_PIN GPIO_PINS_13

Definition at line 112 of file audio/inc/audio_codec.h.

◆ I2S2_DT_ADDRESS

#define I2S2_DT_ADDRESS (&(SPI2->dt))

Definition at line 116 of file audio/inc/audio_codec.h.

◆ I2S2_GPIO

#define I2S2_GPIO GPIOB

Definition at line 114 of file audio/inc/audio_codec.h.

◆ I2S2_GPIO_CRM_CLK

#define I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 115 of file audio/inc/audio_codec.h.

◆ I2S2_SD_PIN

#define I2S2_SD_PIN GPIO_PINS_15

Definition at line 113 of file audio/inc/audio_codec.h.

◆ I2S2_WS_PIN

#define I2S2_WS_PIN GPIO_PINS_12

Definition at line 111 of file audio/inc/audio_codec.h.

◆ SPK_TX_FIFO_SIZE

#define SPK_TX_FIFO_SIZE (1024 * 4)

Definition at line 118 of file audio/inc/audio_codec.h.


AT32F413 Firmwary Library: USB_device_audio_codec_exported_functions

Data Structures | Macros | Functions
USB_device_audio_codec_exported_functions
AT32F413_periph_examples » USB_device_audio

Data Structures

struct audio_codec_type

Macros

#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

Macro Definition Documentation

◆ DMA_BUFFER_SIZE

#define DMA_BUFFER_SIZE 288

Definition at line 129 of file audio/inc/audio_codec.h.

◆ MIC_BUFFER_SIZE

#define MIC_BUFFER_SIZE 1024

Definition at line 127 of file audio/inc/audio_codec.h.

◆ SPK_BUFFER_SIZE

#define SPK_BUFFER_SIZE 4096

Definition at line 128 of file audio/inc/audio_codec.h.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 794 of file audio/src/audio_codec.c.

Referenced by main().

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 853 of file audio/src/audio_codec.c.

Referenced by main().

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 169 of file audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 282 of file audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 342 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 121 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 184 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 206 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 137 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 195 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 217 of file audio/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 154 of file audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 228 of file audio/src/audio_codec.c.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

audio codec interface

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 244 of file audio/src/audio_codec.c.

Referenced by class_out_handler().


AT32F413 Firmwary Library: audio_codec_type Struct Reference

Data Fields
audio_codec_type Struct Reference
AT32F413_periph_examples » USB_device_audio » USB_device_audio_codec_exported_functions | AT32F413_periph_examples » USB_device_audio_hid » USB_device_audio_hid_codec_exported_functions

#include <audio_codec.h>

Data Fields

uint32_t | audio_freq
uint32_t | audio_bitw
uint16_t | spk_buffer [4096]
uint16_t * | spk_roff
uint16_t * | spk_woff
uint16_t * | spk_rend
uint32_t | spk_freq
uint32_t | spk_wtotal
uint32_t | spk_rtotal
uint16_t | spk_threshold
uint16_t | spk_calc
uint8_t | spk_stage
uint16_t | mic_buffer [1024]
uint16_t * | mic_roff
uint16_t * | mic_woff
uint16_t * | mic_wend
uint32_t | mic_wtotal
uint32_t | mic_rtotal
uint32_t | mic_delta
uint16_t | mic_calc
uint16_t | mic_adj_count
uint8_t | mic_adj_stage
uint8_t | mic_stage
uint8_t | mic_mute
uint8_t | spk_mute
uint16_t | mic_volume
uint16_t | spk_volume
uint32_t | spk_tx_size
uint32_t | mic_rx_size
uint32_t | spk_enable
uint32_t | mic_enable

Detailed Description

Definition at line 131 of file audio/inc/audio_codec.h.

Field Documentation

◆ audio_bitw

uint32_t audio_codec_type::audio_bitw

Definition at line 134 of file audio/inc/audio_codec.h.

Referenced by audio_codec_init(), and codec_i2s_init().

◆ audio_freq

uint32_t audio_codec_type::audio_freq

Definition at line 133 of file audio/inc/audio_codec.h.

Referenced by audio_codec_init(), audio_codec_set_mic_freq(), audio_codec_set_spk_freq(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ mic_adj_count

uint16_t audio_codec_type::mic_adj_count

Definition at line 156 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_adj_stage

uint8_t audio_codec_type::mic_adj_stage

Definition at line 157 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_buffer

uint16_t audio_codec_type::mic_buffer

Definition at line 148 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_calc

uint16_t audio_codec_type::mic_calc

Definition at line 155 of file audio/inc/audio_codec.h.

Referenced by DMA1_Channel4_IRQHandler().

◆ mic_delta

uint32_t audio_codec_type::mic_delta

Definition at line 154 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_enable

uint32_t audio_codec_type::mic_enable

Definition at line 170 of file audio/inc/audio_codec.h.

◆ mic_mute

uint8_t audio_codec_type::mic_mute

Definition at line 160 of file audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_mic_mute().

◆ mic_roff

uint16_t * audio_codec_type::mic_roff

Definition at line 149 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_rtotal

uint32_t audio_codec_type::mic_rtotal

Definition at line 153 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_rx_size

uint32_t audio_codec_type::mic_rx_size

Definition at line 167 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_stage

uint8_t audio_codec_type::mic_stage

Definition at line 158 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ mic_volume

uint16_t audio_codec_type::mic_volume

Definition at line 163 of file audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_mic_volume().

◆ mic_wend

uint16_t * audio_codec_type::mic_wend

Definition at line 151 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_woff

uint16_t * audio_codec_type::mic_woff

Definition at line 150 of file audio/inc/audio_codec.h.

Referenced by codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ mic_wtotal

uint32_t audio_codec_type::mic_wtotal

Definition at line 152 of file audio/inc/audio_codec.h.

Referenced by audio_codec_mic_get_data(), and DMA1_Channel4_IRQHandler().

◆ spk_buffer

uint16_t audio_codec_type::spk_buffer

Definition at line 136 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_calc

uint16_t audio_codec_type::spk_calc

Definition at line 144 of file audio/inc/audio_codec.h.

Referenced by DMA1_Channel3_IRQHandler().

◆ spk_enable

uint32_t audio_codec_type::spk_enable

Definition at line 169 of file audio/inc/audio_codec.h.

◆ spk_freq

uint32_t audio_codec_type::spk_freq

Definition at line 140 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_feedback(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_mute

uint8_t audio_codec_type::spk_mute

Definition at line 161 of file audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_spk_mute().

◆ spk_rend

uint16_t * audio_codec_type::spk_rend

Definition at line 139 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_roff

uint16_t * audio_codec_type::spk_roff

Definition at line 137 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_rtotal

uint32_t audio_codec_type::spk_rtotal

Definition at line 142 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

◆ spk_stage

uint8_t audio_codec_type::spk_stage

Definition at line 145 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

◆ spk_threshold

uint16_t audio_codec_type::spk_threshold

Definition at line 143 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

◆ spk_tx_size

uint32_t audio_codec_type::spk_tx_size

Definition at line 166 of file audio/inc/audio_codec.h.

Referenced by codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_volume

uint16_t audio_codec_type::spk_volume

Definition at line 164 of file audio/inc/audio_codec.h.

Referenced by audio_codec_loop(), and audio_codec_set_spk_volume().

◆ spk_woff

uint16_t * audio_codec_type::spk_woff

Definition at line 138 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ spk_wtotal

uint32_t audio_codec_type::spk_wtotal

Definition at line 141 of file audio/inc/audio_codec.h.

Referenced by audio_codec_spk_fifo_write(), and DMA1_Channel3_IRQHandler().

The documentation for this struct was generated from the following files:
  • audio/inc/audio_codec.h
  • composite_audio_hid/inc/audio_codec.h


AT32F413 Firmwary Library: USB_device_audio_hid

Modules | Macros | Functions | Variables
USB_device_audio_hid
AT32F413_periph_examples

Modules

USB_device_audio_hid_codec_reg_definition
USB_device_audio_hid_codec_pin_definition
USB_device_audio_hid_codec_exported_functions

Macros

#define | USB_BUFFER_SIZE_EX
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer More...
#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 200000
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]
usbd_core_type usb_core_dev
uint8_t | report_buf [USBD_AUHID_IN_MAXPACKET_SIZE]

Detailed Description

Macro Definition Documentation

◆ I2C_TIMEOUT

#define I2C_TIMEOUT 0xFFFFFFFF

Definition at line 41 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_ADDRESS

#define I2Cx_ADDRESS 0x00

Definition at line 44 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_CLK

#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK

Definition at line 47 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_PORT

#define I2Cx_PORT I2C1

Definition at line 46 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_CLK

#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 51 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_GPIO_PORT

#define I2Cx_SCL_GPIO_PORT GPIOB

Definition at line 50 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SCL_PIN

#define I2Cx_SCL_PIN GPIO_PINS_8

Definition at line 49 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_CLK

#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 55 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_GPIO_PORT

#define I2Cx_SDA_GPIO_PORT GPIOB

Definition at line 54 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SDA_PIN

#define I2Cx_SDA_PIN GPIO_PINS_9

Definition at line 53 of file composite_audio_hid/src/audio_codec.c.

◆ I2Cx_SPEED

#define I2Cx_SPEED 200000

Definition at line 43 of file composite_audio_hid/src/audio_codec.c.

◆ USB_BUFFER_SIZE_EX

#define USB_BUFFER_SIZE_EX

usb endpoint max num define

usb buffer extend to 768-1280 bytes usb enable extend buffer

Definition at line 57 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

auto malloc usb endpoint buffer

usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h.

◆ WM8988_REG_BITW16

#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)

wm8988 bit width

Definition at line 66 of file composite_audio_hid/src/audio_codec.c.

◆ WM8988_REG_FREQ16K

#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)

Definition at line 61 of file composite_audio_hid/src/audio_codec.c.

◆ WM8988_REG_FREQ48K

#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)

wm8988 freq

Definition at line 60 of file composite_audio_hid/src/audio_codec.c.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 796 of file composite_audio_hid/src/audio_codec.c.

Referenced by main().

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 855 of file composite_audio_hid/src/audio_codec.c.

Referenced by main().

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 169 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 282 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 342 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 121 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 184 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 206 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 137 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 195 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 217 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_ept0_rx_handler().

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 154 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_event_handler().

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 228 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_set_interface(), and class_in_handler().

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

codec speaker write fifo

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 244 of file composite_audio_hid/src/audio_codec.c.

Referenced by class_out_handler().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ codec_i2s_init()

void codec_i2s_init ( audio_codec_type * param )

audio codec i2s init

Parameters
freq | audio sampling freq
bitw_format | bit width
Return values
error status

Definition at line 493 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ codec_i2s_reset()

void codec_i2s_reset ( void )

audio codec i2s reset

Parameters
none
Return values
none

Definition at line 479 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ copy_buff()

void copy_buff | ( | uint16_t * | dest,
 |  | uint16_t * | src,
 |  | uint32_t | len
 | ) |  |

copy buffer

Parameters
dest | dest data buffer
src | src data buffer
len | data length
Return values
none

Definition at line 385 of file composite_audio_hid/src/audio_codec.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ DMA1_Channel3_IRQHandler()

void DMA1_Channel3_IRQHandler ( void )

this function handles dma1 channel3 interrupt.

Parameters
none
Return values
none

Definition at line 651 of file composite_audio_hid/src/audio_codec.c.

◆ DMA1_Channel4_IRQHandler()

void DMA1_Channel4_IRQHandler ( void )

this function handles dma1 channel4 interrupt.

Parameters
none
Return values
none

Definition at line 726 of file composite_audio_hid/src/audio_codec.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ i2c_lowlevel_init()

void i2c_lowlevel_init ( i2c_handle_type * hi2c )

initializes peripherals used by the i2c.

Parameters
none
Return values
none

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 6

< gpio pins number 7

< gpio pins number 10

< gpio pins number 11

Definition at line 399 of file composite_audio_hid/src/audio_codec.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 121 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

◆ mclk_tmr1_init()

void mclk_tmr1_init ( void )

mclk clock conifg

Parameters
none
Return values
none

Definition at line 437 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init().

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ memset16_buffer()

void memset16_buffer | ( | uint16_t * | buffer,
 |  | uint32_t | set,
 |  | uint32_t | len
 | ) |  |

buffer memset

Parameters
buffer | buffer
set | memset data
len | data length
Return values
none

Definition at line 369 of file composite_audio_hid/src/audio_codec.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 53 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 178 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 189 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 168 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

Variable Documentation

◆ audio_codec

audio_codec_type audio_codec

Definition at line 106 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_mic_get_data(), audio_codec_set_mic_freq(), audio_codec_set_mic_mute(), audio_codec_set_mic_volume(), audio_codec_set_spk_freq(), audio_codec_set_spk_mute(), audio_codec_set_spk_volume(), audio_codec_spk_feedback(), audio_codec_spk_fifo_write(), DMA1_Channel3_IRQHandler(), and DMA1_Channel4_IRQHandler().

◆ hi2cx

i2c_handle_type hi2cx

Definition at line 104 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init(), audio_codec_loop(), audio_codec_modify_freq(), DMA1_Channel4_IRQHandler(), DMA1_Channel5_IRQHandler(), DMA1_Channel6_IRQHandler(), DMA1_Channel7_IRQHandler(), I2C1_ERR_IRQHandler(), I2C1_EVT_IRQHandler(), I2C2_ERR_IRQHandler(), and I2C2_EVT_IRQHandler().

◆ mic_dma_buffer

uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 108 of file composite_audio_hid/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel4_IRQHandler().

◆ reg_addr_data

uint16_t reg_addr_data[]

wm8988 register default value

Definition at line 71 of file composite_audio_hid/src/audio_codec.c.

Referenced by audio_codec_init().

◆ report_buf

uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE]

Definition at line 46 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main().

◆ spk_dma_buffer

uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]

Definition at line 107 of file composite_audio_hid/src/audio_codec.c.

Referenced by codec_i2s_init(), and DMA1_Channel3_IRQHandler().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 44 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_audio_hid_codec_reg_definition

Macros
USB_device_audio_hid_codec_reg_definition
AT32F413_periph_examples » USB_device_audio_hid

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36

Detailed Description

Macro Definition Documentation

◆ WM8988_I2C_ADDR_CSB_HIGH

#define WM8988_I2C_ADDR_CSB_HIGH 0x36

Definition at line 94 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_I2C_ADDR_CSB_LOW

#define WM8988_I2C_ADDR_CSB_LOW 0x34

Definition at line 93 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R0_LEFT_INPUT_VOLUME

#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/

Definition at line 50 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R10_LEFT_DAC_VOLUME

#define WM8988_R10_LEFT_DAC_VOLUME 0x0A

Definition at line 60 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R11_RIGHT_DAC_VOLUME

#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B

Definition at line 61 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R12_BASS_CONTROL

#define WM8988_R12_BASS_CONTROL 0x0C

Definition at line 62 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R13_TREBLE_CONTROL

#define WM8988_R13_TREBLE_CONTROL 0x0D

Definition at line 63 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R14_

#define WM8988_R14_

Definition at line 64 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R15_RESET

#define WM8988_R15_RESET 0x0F

Definition at line 65 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R16_3D_CONTROL

#define WM8988_R16_3D_CONTROL 0x10

Definition at line 66 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R17_ALC1

#define WM8988_R17_ALC1 0x11

Definition at line 67 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R18_ALC2

#define WM8988_R18_ALC2 0x12

Definition at line 68 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R19_ALC3

#define WM8988_R19_ALC3 0x13

Definition at line 69 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R1_RIGHT_INPUT_VOLUME

#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/

Definition at line 51 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R20_NOISE_GATE

#define WM8988_R20_NOISE_GATE 0x14

Definition at line 70 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R21_LEFT_ADC_VOLUME

#define WM8988_R21_LEFT_ADC_VOLUME 0x15

Definition at line 71 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R22_RIGHT_ADC_VOLUME

#define WM8988_R22_RIGHT_ADC_VOLUME 0x16

Definition at line 72 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R23_ADDITIONAL_1_CONTROL

#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17

Definition at line 73 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R24_ADDITIONAL_2_CONTROL

#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18

Definition at line 74 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R25_PWR_1_MGMT

#define WM8988_R25_PWR_1_MGMT 0x19

Definition at line 75 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R26_PWR_2_MGMT

#define WM8988_R26_PWR_2_MGMT 0x1A

Definition at line 76 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R27_ADDITIONAL_3_CONTROL

#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B

Definition at line 77 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R2_LOUT1_VOLUME

#define WM8988_R2_LOUT1_VOLUME 0x02

Definition at line 52 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R31_ADC_INPUT_MODE

#define WM8988_R31_ADC_INPUT_MODE 0x1F

Definition at line 79 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R32_ADC_L_SIGNAL_PATH

#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20

Definition at line 80 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R33_ADC_R_SIGNAL_PATH

#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21

Definition at line 81 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R34_LEFT_OUT_MIX_1

#define WM8988_R34_LEFT_OUT_MIX_1 0x22

Definition at line 82 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R35_LEFT_OUT_MIX_2

#define WM8988_R35_LEFT_OUT_MIX_2 0x23

Definition at line 83 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R36_RIGHT_OUT_MIX_1

#define WM8988_R36_RIGHT_OUT_MIX_1 0x24

Definition at line 84 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R37_RIGHT_OUT_MIX_2

#define WM8988_R37_RIGHT_OUT_MIX_2 0x25

Definition at line 85 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R38_RESERVED

#define WM8988_R38_RESERVED

Definition at line 86 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R39_RESERVED

#define WM8988_R39_RESERVED

Definition at line 87 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R3_ROUT1_VOLUME

#define WM8988_R3_ROUT1_VOLUME 0x03

Definition at line 53 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R40_LOUT2_VOLUME

#define WM8988_R40_LOUT2_VOLUME 0x28

Definition at line 88 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R41_ROUT2_VOLUME

#define WM8988_R41_ROUT2_VOLUME 0x29

Definition at line 89 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R42_RESERVED

#define WM8988_R42_RESERVED

Definition at line 90 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R43_LOW_POWER_PALYBACK

#define WM8988_R43_LOW_POWER_PALYBACK 0x43

Definition at line 91 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R4_RESERVED

#define WM8988_R4_RESERVED 0x04

Definition at line 54 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R5_ADC_DAC_CONTROL

#define WM8988_R5_ADC_DAC_CONTROL 0x05

Definition at line 55 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R6_RESERVED

#define WM8988_R6_RESERVED 0x06

Definition at line 56 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R7_AUDIO_INTERFACE

#define WM8988_R7_AUDIO_INTERFACE 0x07

Definition at line 57 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R8_SAMPLE_RATE

#define WM8988_R8_SAMPLE_RATE 0x08

Definition at line 58 of file composite_audio_hid/inc/audio_codec.h.

◆ WM8988_R9_RESERVED

#define WM8988_R9_RESERVED 0x09

Definition at line 59 of file composite_audio_hid/inc/audio_codec.h.


AT32F413 Firmwary Library: USB_device_audio_hid_codec_pin_definition

Macros
USB_device_audio_hid_codec_pin_definition
AT32F413_periph_examples » USB_device_audio_hid

Macros

#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_12
#define | I2S2_CK_PIN GPIO_PINS_13
#define | I2S2_SD_PIN GPIO_PINS_15
#define | I2S2_GPIO GPIOB
#define | I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)

Detailed Description

Macro Definition Documentation

◆ I2S1_CK_PIN

#define I2S1_CK_PIN GPIO_PINS_5

Definition at line 104 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_DT_ADDRESS

#define I2S1_DT_ADDRESS (&(SPI1->dt))

Definition at line 109 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_GPIO

#define I2S1_GPIO GPIOA

Definition at line 107 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_GPIO_CRM_CLK

#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 108 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_SD_PIN

#define I2S1_SD_PIN GPIO_PINS_7

Definition at line 105 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S1_WS_PIN

#define I2S1_WS_PIN GPIO_PINS_4

Definition at line 103 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_CK_PIN

#define I2S2_CK_PIN GPIO_PINS_13

Definition at line 113 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_DT_ADDRESS

#define I2S2_DT_ADDRESS (&(SPI2->dt))

Definition at line 119 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_GPIO

#define I2S2_GPIO GPIOB

Definition at line 117 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_GPIO_CRM_CLK

#define I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK

Definition at line 118 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_SD_PIN

#define I2S2_SD_PIN GPIO_PINS_15

Definition at line 114 of file composite_audio_hid/inc/audio_codec.h.

◆ I2S2_WS_PIN

#define I2S2_WS_PIN GPIO_PINS_12

Definition at line 112 of file composite_audio_hid/inc/audio_codec.h.

◆ SPK_TX_FIFO_SIZE

#define SPK_TX_FIFO_SIZE (1024 * 4)

Definition at line 121 of file composite_audio_hid/inc/audio_codec.h.


AT32F413 Firmwary Library: USB_device_audio_hid_codec_exported_functions

Data Structures | Macros | Functions
USB_device_audio_hid_codec_exported_functions
AT32F413_periph_examples » USB_device_audio_hid

Data Structures

struct audio_codec_type

Macros

#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

Macro Definition Documentation

◆ DMA_BUFFER_SIZE

#define DMA_BUFFER_SIZE 288

Definition at line 132 of file composite_audio_hid/inc/audio_codec.h.

◆ MIC_BUFFER_SIZE

#define MIC_BUFFER_SIZE 1024

Definition at line 130 of file composite_audio_hid/inc/audio_codec.h.

◆ SPK_BUFFER_SIZE

#define SPK_BUFFER_SIZE 4096

Definition at line 131 of file composite_audio_hid/inc/audio_codec.h.

Function Documentation

◆ audio_codec_init()

error_status audio_codec_init ( void )

audio codec init

Parameters
none
Return values
error status

Definition at line 794 of file audio/src/audio_codec.c.

◆ audio_codec_loop()

error_status audio_codec_loop ( void )

audio codec loop

Parameters
none
Return values
none

Definition at line 853 of file audio/src/audio_codec.c.

◆ audio_codec_mic_alt_setting()

void audio_codec_mic_alt_setting ( uint32_t alt_seting )

audio codec microphone alt setting config

Parameters
none
Return values
none

Definition at line 169 of file audio/src/audio_codec.c.

◆ audio_codec_mic_get_data()

uint32_t audio_codec_mic_get_data ( uint8_t * buffer )

codec microphone get data

Parameters
data data buffer
Return values
data len

Definition at line 282 of file audio/src/audio_codec.c.

◆ audio_codec_modify_freq()

void audio_codec_modify_freq ( uint32_t freq )

audio codec modify freq

Parameters
freq freq (wm8988 microphone and speaker must as same freq)
Return values
none

Definition at line 342 of file audio/src/audio_codec.c.

Referenced by audio_codec_set_mic_freq(), and audio_codec_set_spk_freq().

◆ audio_codec_set_mic_freq()

void audio_codec_set_mic_freq ( uint32_t freq )

audio codec set microphone freq

Parameters
freq freq (wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 121 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_mute()

void audio_codec_set_mic_mute ( uint8_t mute )

audio codec set microphone mute

Parameters
mute mute state
Return values
none

Definition at line 184 of file audio/src/audio_codec.c.

◆ audio_codec_set_mic_volume()

void audio_codec_set_mic_volume ( uint16_t volume )

audio codec set microphone volume

Parameters
volume the new volume
Return values
none

Definition at line 206 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_freq()

void audio_codec_set_spk_freq ( uint32_t freq )

audio codec set speaker freq

Parameters
freq freq(wm8988 microphone and speaker must same freq)
Return values
none

Definition at line 137 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_mute()

void audio_codec_set_spk_mute ( uint8_t mute )

audio codec set speaker mute

Parameters
mute mute state
Return values
none

Definition at line 195 of file audio/src/audio_codec.c.

◆ audio_codec_set_spk_volume()

void audio_codec_set_spk_volume ( uint16_t volume )

audio codec set speaker volume

Parameters
volume the new volume
Return values
none

Definition at line 217 of file audio/src/audio_codec.c.

◆ audio_codec_spk_alt_setting()

void audio_codec_spk_alt_setting ( uint32_t alt_seting )

audio codec speaker alt setting config

Parameters
none
Return values
none

Definition at line 154 of file audio/src/audio_codec.c.

◆ audio_codec_spk_feedback()

uint8_t audio_codec_spk_feedback ( uint8_t * feedback )

codec speaker feedback

Parameters
feedback data buffer
Return values
feedback len

Definition at line 228 of file audio/src/audio_codec.c.

◆ audio_codec_spk_fifo_write()

void audio_codec_spk_fifo_write | ( | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

audio codec interface

audio codec interface

Parameters
data | data buffer
len | data length
Return values
none

Definition at line 244 of file audio/src/audio_codec.c.


AT32F413 Firmwary Library: USB_device_composite_vcp_keyboard

Macros | Functions | Variables
USB_device_composite_vcp_keyboard
AT32F413_periph_examples

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER [1/2]

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER [2/2]

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 155 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 51 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 235 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 246 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 225 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

Variable Documentation

◆ usb_buffer

uint8_t usb_buffer[256]

Definition at line 43 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.

Referenced by keyboard_send_string(), main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_msc

Macros | Functions | Variables
USB_device_msc
AT32F413_periph_examples

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096
#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096
#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
usbd_core_type usb_core_dev
uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

Macro Definition Documentation

◆ INTERNAL_FLASH_LUN [1/2]

#define INTERNAL_FLASH_LUN 0

Definition at line 45 of file composite_vcp_msc/inc/msc_diskio.h.

◆ INTERNAL_FLASH_LUN [2/2]

#define INTERNAL_FLASH_LUN 0

Definition at line 45 of file msc/inc/msc_diskio.h.

◆ SD_LUN [1/2]

#define SD_LUN 2

Definition at line 47 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SD_LUN [2/2]

#define SD_LUN 2

Definition at line 47 of file msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_1K [1/2]

#define SECTOR_SIZE_1K 1024

Definition at line 51 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_1K [2/2]

#define SECTOR_SIZE_1K 1024

Definition at line 51 of file msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_2K [1/2]

#define SECTOR_SIZE_2K 2048

Definition at line 52 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_2K [2/2]

#define SECTOR_SIZE_2K 2048

Definition at line 52 of file msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_4K [1/2]

#define SECTOR_SIZE_4K 4096

Definition at line 53 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SECTOR_SIZE_4K [2/2]

#define SECTOR_SIZE_4K 4096

Definition at line 53 of file msc/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [1/2]

#define SPI_FLASH_LUN 1

Definition at line 46 of file composite_vcp_msc/inc/msc_diskio.h.

◆ SPI_FLASH_LUN [2/2]

#define SPI_FLASH_LUN 1

Definition at line 46 of file msc/inc/msc_diskio.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h.

◆ USB_FLASH_ADDR_OFFSET [1/2]

#define USB_FLASH_ADDR_OFFSET 0x08005000

Definition at line 49 of file composite_vcp_msc/inc/msc_diskio.h.

◆ USB_FLASH_ADDR_OFFSET [2/2]

#define USB_FLASH_ADDR_OFFSET 0x08005000

Definition at line 49 of file msc/inc/msc_diskio.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 119 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 51 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 163 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 174 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 153 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

Variable Documentation

◆ msc_flash_size [1/2]

uint32_t msc_flash_size

Definition at line 37 of file composite_vcp_msc/src/msc_diskio.c.

Referenced by msc_disk_capacity().

◆ msc_flash_size [2/2]

uint32_t msc_flash_size

Definition at line 37 of file msc/src/msc_diskio.c.

◆ scsi_inquiry [1/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
}
}
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157

Definition at line 38 of file composite_vcp_msc/src/msc_diskio.c.

Referenced by get_inquiry().

◆ scsi_inquiry [2/2]

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
}
}

Definition at line 38 of file msc/src/msc_diskio.c.

◆ sector_size [1/2]

uint32_t sector_size = 2048

Definition at line 36 of file composite_vcp_msc/src/msc_diskio.c.

Referenced by msc_disk_capacity(), and sector_read().

◆ sector_size [2/2]

uint32_t sector_size = 2048

Definition at line 36 of file msc/src/msc_diskio.c.

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 43 of file project/at_start_f413/examples/usb_device/msc/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_composite_vcp_msc

Functions | Variables
USB_device_composite_vcp_msc
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 50 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 193 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 204 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 183 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

Variable Documentation

◆ usb_buffer

uint8_t usb_buffer[256]

Definition at line 43 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_custom_hid

Macros | Functions | Variables
USB_device_custom_hid
AT32F413_periph_examples

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

usbd_core_type usb_core_dev
uint8_t report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 50 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 170 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 181 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 160 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

Variable Documentation

◆ report_buf

uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]

Definition at line 43 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_keyboard

Macros | Functions | Variables
USB_device_keyboard
AT32F413_periph_examples

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | keyboard_send_string (void *udev, uint8_t *string, uint8_t len)
keyboard send string More...
void | system_clock_recover (void)
systemclock recover. More...
void | usb_low_power_wakeup_config (void)
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

usbd_core_type usb_core_dev
__IO uint8_t hid_suspend_flag

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 103 of file project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ keyboard_send_string()

void keyboard_send_string | ( | void * | udev,
 |  | uint8_t * | string,
 |  | uint8_t | len
 | ) |  |

keyboard send string

Parameters
string | send string
len | send string length
Return values
none

Definition at line 55 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 157 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

systemclock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 98 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 89 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 337 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 348 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 327 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

Variable Documentation

◆ hid_suspend_flag

__IO uint8_t hid_suspend_flag
extern

Referenced by main().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/usb_device/keyboard/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_mouse

Macros | Functions | Variables
USB_device_mouse
AT32F413_periph_examples

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | system_clock_recover (void)
systemclock recover. More...
void | button_exint_init (void)
configure button exint More...
void | usb_low_power_wakeup_config (void)
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

usbd_core_type usb_core_dev
__IO uint8_t | press_mouse = 0
__IO uint8_t | hid_suspend_flag
uint8_t | report_buf [USBD_MOUSE_IN_MAXPACKET_SIZE]

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h.

◆ USB_LOW_POWER_WAKUP

#define USB_LOW_POWER_WAKUP

usb low power wakeup handler enable

Definition at line 103 of file project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

Definition at line 52 of file project/at_start_f413/templates/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ system_clock_recover()

void system_clock_recover ( void )

systemclock recover.

Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 98 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.

Referenced by main().

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 54 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 313 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 324 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

◆ usb_low_power_wakeup_config()

void usb_low_power_wakeup_config ( void )

Referenced by main().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 302 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

Variable Documentation

◆ hid_suspend_flag

__IO uint8_t hid_suspend_flag
extern

Referenced by main().

◆ press_mouse

__IO uint8_t press_mouse = 0

Definition at line 43 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

Referenced by main().

◆ report_buf

uint8_t report_buf[USBD_MOUSE_IN_MAXPACKET_SIZE]

Definition at line 45 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/usb_device/mouse/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_printer

Macros | Functions | Variables
USB_device_printer
AT32F413_periph_examples

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 117 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 49 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 161 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 172 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 151 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

Variable Documentation

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/usb_device/printer/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_vcp_loopback

Macros | Functions | Variables
USB_device_vcp_loopback
AT32F413_periph_examples

Macros

#define | EPT0_TX_ADDR 0x40
usb endpoint max num define More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00
#define | USB_VIRTUAL_COMPORT
usb endpoint max num define More...
#define | EPT0_TX_ADDR 0x40
user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00
#define | usart_buffer_size 2048

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
void | usart_gpio_config (void)
this function handles usart2 gpio config. More...
void | usart_send_data (uint8_t *send_data, uint16_t len)
this function handles usart2 send data. More...
uint16_t | usart_receive_data (void)
this function handles usart2 receive data. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...

Variables

usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
linecoding_type linecoding
uint8_t | usart_rx_buffer [2048]
uint16_t | hw_usart_rx_index = 0
uint16_t | hw_usart_read_index = 0
uint16_t | usart_rx_data_len = 0
uint16_t | ov_cnt = 0

Detailed Description

Macro Definition Documentation

◆ EPT0_RX_ADDR [1/2]

#define EPT0_RX_ADDR 0x80

usb endpoint 0 rx buffer address offset

Definition at line 75 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT0_RX_ADDR [2/2]

#define EPT0_RX_ADDR 0x80

usb endpoint 0 rx buffer address offset

Definition at line 79 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT0_TX_ADDR [1/2]

#define EPT0_TX_ADDR 0x40

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer

user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size usb endpoint 0 tx buffer address offset

Definition at line 74 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT0_TX_ADDR [2/2]

#define EPT0_TX_ADDR 0x40

user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size

usb endpoint 0 tx buffer address offset

Definition at line 78 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT1_RX_ADDR [1/2]

#define EPT1_RX_ADDR 0x100

usb endpoint 1 rx buffer address offset

Definition at line 78 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT1_RX_ADDR [2/2]

#define EPT1_RX_ADDR 0x100

usb endpoint 1 rx buffer address offset

Definition at line 82 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT1_TX_ADDR [1/2]

#define EPT1_TX_ADDR 0xC0

usb endpoint 1 tx buffer address offset

Definition at line 77 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT1_TX_ADDR [2/2]

#define EPT1_TX_ADDR 0xC0

usb endpoint 1 tx buffer address offset

Definition at line 81 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT2_RX_ADDR [1/2]

#define EPT2_RX_ADDR 0x180

usb endpoint 2 rx buffer address offset

Definition at line 81 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT2_RX_ADDR [2/2]

#define EPT2_RX_ADDR 0x180

usb endpoint 2 rx buffer address offset

Definition at line 85 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT2_TX_ADDR [1/2]

#define EPT2_TX_ADDR 0x140

usb endpoint 2 tx buffer address offset

Definition at line 80 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT2_TX_ADDR [2/2]

#define EPT2_TX_ADDR 0x140

usb endpoint 2 tx buffer address offset

Definition at line 84 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT3_RX_ADDR [1/2]

#define EPT3_RX_ADDR 0x00

usb endpoint 3 rx buffer address offset

Definition at line 84 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT3_RX_ADDR [2/2]

#define EPT3_RX_ADDR 0x00

usb endpoint 3 rx buffer address offset

Definition at line 88 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT3_TX_ADDR [1/2]

#define EPT3_TX_ADDR 0x00

usb endpoint 3 tx buffer address offset

Definition at line 83 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT3_TX_ADDR [2/2]

#define EPT3_TX_ADDR 0x00

usb endpoint 3 tx buffer address offset

Definition at line 87 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT4_RX_ADDR [1/2]

#define EPT4_RX_ADDR 0x00

usb endpoint 4 rx buffer address offset

Definition at line 87 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT4_RX_ADDR [2/2]

#define EPT4_RX_ADDR 0x00

usb endpoint 4 rx buffer address offset

Definition at line 91 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT4_TX_ADDR [1/2]

#define EPT4_TX_ADDR 0x00

usb endpoint 4 tx buffer address offset

Definition at line 86 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT4_TX_ADDR [2/2]

#define EPT4_TX_ADDR 0x00

usb endpoint 4 tx buffer address offset

Definition at line 90 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT5_RX_ADDR [1/2]

#define EPT5_RX_ADDR 0x00

usb endpoint 5 rx buffer address offset

Definition at line 90 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT5_RX_ADDR [2/2]

#define EPT5_RX_ADDR 0x00

usb endpoint 5 rx buffer address offset

Definition at line 94 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT5_TX_ADDR [1/2]

#define EPT5_TX_ADDR 0x00

usb endpoint 5 tx buffer address offset

Definition at line 89 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT5_TX_ADDR [2/2]

#define EPT5_TX_ADDR 0x00

usb endpoint 5 tx buffer address offset

Definition at line 93 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT6_RX_ADDR [1/2]

#define EPT6_RX_ADDR 0x00

usb endpoint 6 rx buffer address offset

Definition at line 93 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT6_RX_ADDR [2/2]

#define EPT6_RX_ADDR 0x00

usb endpoint 6 rx buffer address offset

Definition at line 97 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT6_TX_ADDR [1/2]

#define EPT6_TX_ADDR 0x00

usb endpoint 6 tx buffer address offset

Definition at line 92 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT6_TX_ADDR [2/2]

#define EPT6_TX_ADDR 0x00

usb endpoint 6 tx buffer address offset

Definition at line 96 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT7_RX_ADDR [1/2]

#define EPT7_RX_ADDR 0x00

usb endpoint 7 rx buffer address offset

Definition at line 96 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT7_RX_ADDR [2/2]

#define EPT7_RX_ADDR 0x00

usb endpoint 7 rx buffer address offset

Definition at line 100 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ EPT7_TX_ADDR [1/2]

#define EPT7_TX_ADDR 0x00

usb endpoint 7 tx buffer address offset

Definition at line 95 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.

◆ EPT7_TX_ADDR [2/2]

#define EPT7_TX_ADDR 0x00

usb endpoint 7 tx buffer address offset

Definition at line 99 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

◆ usart_buffer_size

#define usart_buffer_size 2048

Definition at line 49 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ USB_VIRTUAL_COMPORT

#define USB_VIRTUAL_COMPORT

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer

usb virtual comport

Definition at line 68 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 118 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.

◆ USART2_IRQHandler()

void USART2_IRQHandler ( void )

this function handles usart2 handler.

Parameters
none
Return values
none

< usart receive data buffer full flag

Definition at line 284 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usart_gpio_config()

void usart_gpio_config ( void )

this function handles usart2 gpio config.

Parameters
none
Return values
none

< gpio pins number 2

< gpio pins number 3

Definition at line 380 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usart_receive_data()

uint16_t usart_receive_data ( void )

this function handles usart2 receive data.

Parameters
none
Return values
the data len

Definition at line 258 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usart_send_data()

void usart_send_data | ( | uint8_t * | send_data,
 |  | uint16_t | len
 | ) |  |

this function handles usart2 send data.

Parameters
send_data | pointer to data
len | data len
Return values
none

< usart transmit data buffer empty flag

Definition at line 239 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

< acc hick trim

Definition at line 50 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 195 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 206 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

◆ usb_usart_config()

void usb_usart_config ( linecoding_type linecoding )

this function handles usart2 and linecoding config.

Parameters
linecoding linecoding value
Return values
none

< usart receive data buffer full interrupt

Definition at line 299 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by usb_vcp_cmd_process().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 185 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

Variable Documentation

◆ hw_usart_read_index

uint16_t hw_usart_read_index = 0

Definition at line 52 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by usart_receive_data().

◆ hw_usart_rx_index

uint16_t hw_usart_rx_index = 0

Definition at line 51 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by USART2_IRQHandler(), and usart_receive_data().

◆ linecoding

linecoding_type linecoding
extern

Definition at line 57 of file cdc_class.c.

Referenced by cdc_struct_init(), and usb_usart_config().

◆ ov_cnt

uint16_t ov_cnt = 0

Definition at line 54 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usart_rx_buffer

uint8_t usart_rx_buffer[2048]

Definition at line 50 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

Referenced by USART2_IRQHandler().

◆ usart_rx_data_len

uint16_t usart_rx_data_len = 0

Definition at line 53 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usb_buffer [1/2]

uint8_t usb_buffer[256]

Definition at line 43 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main().

◆ usb_buffer [2/2]

uint8_t usb_buffer[256]

Definition at line 43 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.

◆ usb_core_dev [1/2]

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().

◆ usb_core_dev [2/2]

usbd_core_type usb_core_dev

Definition at line 42 of file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.


AT32F413 Firmwary Library: USB_device_virtual_msc_iap

Modules | Macros | Functions | Variables
USB_device_virtual_msc_iap
AT32F413_periph_examples

Modules

USB_device_virtual_msc_iap_definition

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08004000
#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | FAT16_SECTOR_SIZE 62

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
uint32_t | flash_fat16_boot_dir_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write More...
uint32_t | flash_fat16_sector_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector More...
uint32_t | fat16_memory_copy (uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function More...
uint32_t | fat16_memory_memset (uint8_t *dst, uint32_t set, uint32_t len)
memset function More...
uint32_t | flash_write_data (uint32_t address, uint8_t *data, uint32_t len)
write data to flash More...
uint32_t | flash_read_data (uint32_t address, uint8_t *data, uint32_t len)
read data from flash More...
uint32_t | fat16_memory_cmp (uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function More...
uint32_t | flash_crc_check (uint32_t address, uint8_t *data, uint32_t len)
crc check More...
void | flash_fat16_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | flash_fat16_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint32_t | flash_fat16_addr_offset (uint8_t *file_name)
get offset address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | jump_to_app (uint32_t address)
jump to app More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | usb_reset ()
usb re-connect More...
void | flash_fat16_loop_status (void)
loop status More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...

Variables

static uint8_t | fat16_sector [62]
const uint8_t | fat16_root_dir_sector [FAT16_DIR_SIZE]
const uint8_t | fat16_table_sector0 [FAT16_TABLE_SIZE]
uint8_t | fat16_file_name [FAT16_FILENAME_SIZE]
fat_dir_type g_file_attr
flash_iap_type flash_iap
uint32_t | file_write_nr = 0
uint8_t | file_match = 0
usbd_core_type usb_core_dev
void(* | pftarget )(void)
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
iapfun jump_to_app
jump to app More...

Detailed Description

Macro Definition Documentation

◆ FAT16_SECTOR_SIZE

#define FAT16_SECTOR_SIZE 62

Definition at line 36 of file flash_fat16.c.

◆ INTERNAL_FLASH_LUN

#define INTERNAL_FLASH_LUN 0

Definition at line 45 of file virtual_msc_iap/inc/msc_diskio.h.

◆ SD_LUN

#define SD_LUN 2

Definition at line 47 of file virtual_msc_iap/inc/msc_diskio.h.

◆ SPI_FLASH_LUN

#define SPI_FLASH_LUN 1

Definition at line 46 of file virtual_msc_iap/inc/msc_diskio.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.

◆ USB_FLASH_ADDR_OFFSET

#define USB_FLASH_ADDR_OFFSET 0x08004000

Definition at line 49 of file virtual_msc_iap/inc/msc_diskio.h.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ fat16_memory_cmp()

uint32_t fat16_memory_cmp | ( | uint8_t * | dst,
 |  | uint8_t * | src,
 |  | uint32_t | len
 | ) |  |

memory compare function

Parameters
dst | dest buffer pointer
src | src buffer pointer
len | compare length
Return values
compare result

Definition at line 229 of file flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ fat16_memory_copy()

uint32_t fat16_memory_copy | ( | uint8_t * | dst,
 |  | const uint8_t * | src,
 |  | uint32_t | len
 | ) |  |

memory copy function

Parameters
dst | dest buffer pointer
src | src buffer pointer
len | copy length
Return values
nubmer of data copy

Definition at line 195 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_read().

◆ fat16_memory_memset()

uint32_t fat16_memory_memset | ( | uint8_t * | dst,
 |  | uint32_t | set,
 |  | uint32_t | len
 | ) |  |

memset function

Parameters
dst | dest buffer pointer
set | set value
len | set length
Return values
nubmer of data set

Definition at line 212 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_read().

◆ flash_crc_check()

uint32_t flash_crc_check | ( | uint32_t | address,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

crc check

Parameters
address | flash address
data | pointer to array to store data
len | data length
Return values
crc result

Definition at line 592 of file flash_fat16.c.

Referenced by flash_write_data().

◆ flash_fat16_addr_offset()

uint32_t flash_fat16_addr_offset ( uint8_t * file_name )

get offset address

Parameters
file_name file name
Return values
offset address

Definition at line 439 of file flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ flash_fat16_boot_dir_write()

uint32_t flash_fat16_boot_dir_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

boot dir write

Parameters
fat_lbk | logical block address
data | pointer to array to store data
len | data length
Return values
nubmer of data

Definition at line 381 of file flash_fat16.c.

Referenced by flash_fat16_write().

◆ flash_fat16_clear_upgrade_flag()

void flash_fat16_clear_upgrade_flag ( void )

clear iap upgrade flag

Parameters
none
Return values
none

Definition at line 245 of file flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ flash_fat16_get_upgrade_flag()

uint8_t flash_fat16_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the iap flag

Definition at line 270 of file flash_fat16.c.

Referenced by main().

◆ flash_fat16_init()

void flash_fat16_init ( void )

flash fat16 iap init

Parameters
none
Return values
none

Definition at line 711 of file flash_fat16.c.

Referenced by main().

◆ flash_fat16_loop_status()

void flash_fat16_loop_status ( void )

loop status

Parameters
none
Return values
none

Definition at line 179 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ flash_fat16_read()

uint32_t flash_fat16_read | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

read a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 290 of file flash_fat16.c.

Referenced by msc_disk_read().

◆ flash_fat16_sector_write()

uint32_t flash_fat16_sector_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write sector

Parameters
fat_lbk | logical block address
data | pointer to array to store data
len | data length
Return values
nubmer of data

Definition at line 488 of file flash_fat16.c.

Referenced by flash_fat16_write().

◆ flash_fat16_set_name()

uint32_t flash_fat16_set_name | ( | const uint8_t * | file_name,
 |  | uint8_t | len
 | ) |  |

set file name

Parameters
file_name | file name
len | filename length
Return values
filename length

Definition at line 359 of file flash_fat16.c.

Referenced by flash_fat16_loop_status().

◆ flash_fat16_set_upgrade_flag()

void flash_fat16_set_upgrade_flag ( void )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 257 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ flash_fat16_write()

uint32_t flash_fat16_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 331 of file flash_fat16.c.

Referenced by msc_disk_write().

◆ flash_read_data()

uint32_t flash_read_data | ( | uint32_t | address,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

read data from flash

Parameters
address | flash address
data | pointer to array to store data
len | data length
Return values
read length

Definition at line 643 of file flash_fat16.c.

◆ flash_write_data()

uint32_t flash_write_data | ( | uint32_t | address,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write data to flash

Parameters
address | flash address
data | pointer to array to store data
len | data length
Return values
write status

Definition at line 662 of file flash_fat16.c.

Referenced by flash_fat16_sector_write().

◆ get_inquiry()

uint8_t * get_inquiry ( uint8_t lun )

get disk inquiry

Parameters
lun logical units number
Return values
inquiry string

Definition at line 59 of file virtual_msc_iap/src/msc_diskio.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ jump_to_app()

void jump_to_app ( uint32_t address )

jump to app

Parameters
none
Return values
none

Definition at line 234 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by flash_fat16_loop_status(), and main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ msc_disk_capacity()

usb_sts_type msc_disk_capacity | ( | uint8_t | lun,
 |  | uint32_t * | blk_nbr,
 |  | uint32_t * | blk_size
 | ) |  |

disk capacity

Parameters
lun | logical units number
blk_nbr | pointer to number of block
blk_size | pointer to block size
Return values
status of usb_sts_type

Definition at line 117 of file virtual_msc_iap/src/msc_diskio.c.

◆ msc_disk_read()

usb_sts_type msc_disk_read | ( | uint8_t | lun,
 |  | uint32_t | addr,
 |  | uint8_t * | read_buf,
 |  | uint32_t | len
 | ) |  |

disk read

Parameters
lun | logical units number
addr | logical address
read_buf | pointer to read buffer
len | read length
Return values
status of usb_sts_type

Definition at line 75 of file virtual_msc_iap/src/msc_diskio.c.

◆ msc_disk_write()

usb_sts_type msc_disk_write | ( | uint8_t | lun,
 |  | uint32_t | addr,
 |  | uint8_t * | buf,
 |  | uint32_t | len
 | ) |  |

disk write

Parameters
lun | logical units number
addr | logical address
buf | pointer to write buffer
len | write length
Return values
status of usb_sts_type

Definition at line 97 of file virtual_msc_iap/src/msc_diskio.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 55 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 267 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 278 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

◆ usb_reset()

void usb_reset ( )

usb re-connect

Parameters
none
Return values
none

Definition at line 166 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by flash_fat16_loop_status().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 257 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Variable Documentation

◆ fat16_file_name

uint8_t fat16_file_name[FAT16_FILENAME_SIZE]
Initial value:
=
{
'R',
'e',
'a',
'd',
'y',
' ',
' ',
' ',
'T',
'X',
'T'
}

Definition at line 157 of file flash_fat16.c.

Referenced by flash_fat16_read(), and flash_fat16_set_name().

◆ fat16_root_dir_sector

const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]

Definition at line 108 of file flash_fat16.c.

Referenced by flash_fat16_read().

◆ fat16_sector

uint8_t fat16_sector[62]
static

Definition at line 37 of file flash_fat16.c.

Referenced by flash_fat16_read().

◆ fat16_table_sector0

const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE]
Initial value:
=
{
0xF8,
0xFF,
0xFF,
0xFF
}

Definition at line 149 of file flash_fat16.c.

Referenced by flash_fat16_read().

◆ file_match

uint8_t file_match = 0

Definition at line 175 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ file_write_nr

uint32_t file_write_nr = 0

Definition at line 174 of file flash_fat16.c.

◆ flash_iap

flash_iap_type flash_iap

Definition at line 173 of file flash_fat16.c.

Referenced by flash_fat16_addr_offset(), flash_fat16_boot_dir_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_loop_status(), flash_fat16_sector_write(), flash_fat16_set_upgrade_flag(), flash_write_data(), and main().

◆ g_file_attr

fat_dir_type g_file_attr

Definition at line 172 of file flash_fat16.c.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ jump_to_app

void jump_to_app

jump to app

Parameters
none
Return values
none

Definition at line 46 of file bootloader/src/iap.c.

Referenced by app_load(), and main().

◆ pftarget

void(* pftarget) (void) ( void )

Definition at line 45 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by jump_to_app().

◆ scsi_inquiry

uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Initial value:
=
{
{
0x00,
0x80,
0x00,
0x01,
SCSI_INQUIRY_DATA_LENGTH - 5,
0x00, 0x00, 0x00,
'A', 'T', '3', '2', ' ', ' ', ' ', ' ',
'M', 's', 'c', ' ', 'i', 'a', 'p', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ',
'2', '.', '0', '0'
},
}
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157

Definition at line 38 of file virtual_msc_iap/src/msc_diskio.c.

Referenced by get_inquiry().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 43 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main(), usb_reset(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: USB_device_virtual_msc_iap_definition

Data Structures | Macros | Enumerations | Functions | Variables
USB_device_virtual_msc_iap_definition
AT32F413_periph_examples » USB_device_virtual_msc_iap

Data Structures

struct | fat_dir_type
struct | flash_iap_type

Macros

#define | FAT16_SECTOR_SIZE 62
#define | FAT16_TABLE_SIZE 4
#define | FAT16_BYTE_PER_SIZE 2048
#define | FAT16_FILENAME_SIZE 11
#define | FAT16_DIR_SIZE 47
#define | FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
#define | FLASH_FAT16_1_ADDR 0x3000
#define | FLASH_FAT16_2_ADDR 0x3800
#define | FLASH_FAT16_ROOT_ADDR 0x4000
#define | FLASH_FAT16_FILE_START_ADDR 0x8800
#define | FLASH_APP_START_ADDR 0x08005000
#define | FLASH_SECTOR_1K_SIZE 0x400
#define | FLASH_SECTOR_2K_SIZE 0x800
#define | FLASH_SECTOR_4K_SIZE 0x1000
#define | FLASH_SECTOR_1K_ALLGNED 0x3FF
#define | FLASH_SECTOR_2K_ALLGNED 0x7FF
#define | FLASH_SECTOR_4K_ALLGNED 0xFFF
#define | FILE_SUFFIX1_LEN 3
#define | FILE_SUFFIX2_LEN 3
#define | FILE_SUFFIX1_NAME "BIN"
#define | FILE_SUFFIX2_NAME "bin"
#define | INVAILD_OFFSET_ADDR 0xFFFFFFFF
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | IAP_SUCCESS 0
#define | IAP_FAILED 1

Enumerations

enum upgrade_status_type {
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP
}

Functions

uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | flash_fat16_loop_status (void)
loop status More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...

Variables

flash_iap_type flash_iap

Detailed Description

Macro Definition Documentation

◆ FAT16_BYTE_PER_SIZE

#define FAT16_BYTE_PER_SIZE 2048

Definition at line 50 of file flash_fat16.h.

◆ FAT16_DIR_SIZE

#define FAT16_DIR_SIZE 47

Definition at line 52 of file flash_fat16.h.

◆ FAT16_FILENAME_SIZE

#define FAT16_FILENAME_SIZE 11

Definition at line 51 of file flash_fat16.h.

◆ FAT16_SECTOR_SIZE

#define FAT16_SECTOR_SIZE 62

Definition at line 48 of file flash_fat16.h.

◆ FAT16_TABLE_SIZE

#define FAT16_TABLE_SIZE 4

Definition at line 49 of file flash_fat16.h.

◆ FILE_SUFFIX1_LEN

#define FILE_SUFFIX1_LEN 3

Definition at line 70 of file flash_fat16.h.

◆ FILE_SUFFIX1_NAME

#define FILE_SUFFIX1_NAME "BIN"

Definition at line 72 of file flash_fat16.h.

◆ FILE_SUFFIX2_LEN

#define FILE_SUFFIX2_LEN 3

Definition at line 71 of file flash_fat16.h.

◆ FILE_SUFFIX2_NAME

#define FILE_SUFFIX2_NAME "bin"

Definition at line 73 of file flash_fat16.h.

◆ FLASH_APP_START_ADDR

#define FLASH_APP_START_ADDR 0x08005000

Definition at line 60 of file flash_fat16.h.

◆ FLASH_FAT16_1_ADDR

#define FLASH_FAT16_1_ADDR 0x3000

Definition at line 55 of file flash_fat16.h.

◆ FLASH_FAT16_2_ADDR

#define FLASH_FAT16_2_ADDR 0x3800

Definition at line 56 of file flash_fat16.h.

◆ FLASH_FAT16_BOOT_SECTOR_ADDR

#define FLASH_FAT16_BOOT_SECTOR_ADDR 0x00

Definition at line 54 of file flash_fat16.h.

◆ FLASH_FAT16_FILE_START_ADDR

#define FLASH_FAT16_FILE_START_ADDR 0x8800

Definition at line 58 of file flash_fat16.h.

◆ FLASH_FAT16_ROOT_ADDR

#define FLASH_FAT16_ROOT_ADDR 0x4000

Definition at line 57 of file flash_fat16.h.

◆ FLASH_SECTOR_1K_ALLGNED

#define FLASH_SECTOR_1K_ALLGNED 0x3FF

Definition at line 66 of file flash_fat16.h.

◆ FLASH_SECTOR_1K_SIZE

#define FLASH_SECTOR_1K_SIZE 0x400

Definition at line 62 of file flash_fat16.h.

◆ FLASH_SECTOR_2K_ALLGNED

#define FLASH_SECTOR_2K_ALLGNED 0x7FF

Definition at line 67 of file flash_fat16.h.

◆ FLASH_SECTOR_2K_SIZE

#define FLASH_SECTOR_2K_SIZE 0x800

Definition at line 63 of file flash_fat16.h.

◆ FLASH_SECTOR_4K_ALLGNED

#define FLASH_SECTOR_4K_ALLGNED 0xFFF

Definition at line 68 of file flash_fat16.h.

◆ FLASH_SECTOR_4K_SIZE

#define FLASH_SECTOR_4K_SIZE 0x1000

Definition at line 64 of file flash_fat16.h.

◆ IAP_FAILED

#define IAP_FAILED 1

Definition at line 78 of file flash_fat16.h.

◆ IAP_SUCCESS

#define IAP_SUCCESS 0

Definition at line 77 of file flash_fat16.h.

◆ IAP_UPGRADE_COMPLETE_FLAG

#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38

Definition at line 76 of file flash_fat16.h.

◆ INVAILD_OFFSET_ADDR

#define INVAILD_OFFSET_ADDR 0xFFFFFFFF

Definition at line 75 of file flash_fat16.h.

Enumeration Type Documentation

◆ upgrade_status_type

enum upgrade_status_type
Enumerator
UPGRADE_READY
UPGRAGE_ONGOING
UPGRADE_SUCCESS
UPGRADE_FAILED
UPGRADE_LARGE
UPGRADE_UNKNOWN
UPGRADE_DONE
UPGRADE_JUMP

Definition at line 80 of file flash_fat16.h.

Function Documentation

◆ flash_fat16_get_upgrade_flag()

uint8_t flash_fat16_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the iap flag

Definition at line 270 of file flash_fat16.c.

Referenced by main().

◆ flash_fat16_init()

void flash_fat16_init ( void )

flash fat16 iap init

Parameters
none
Return values
none

Definition at line 711 of file flash_fat16.c.

Referenced by main().

◆ flash_fat16_loop_status()

void flash_fat16_loop_status ( void )

loop status

Parameters
none
Return values
none

Definition at line 179 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by main().

◆ flash_fat16_read()

uint32_t flash_fat16_read | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

read a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 290 of file flash_fat16.c.

Referenced by msc_disk_read().

◆ flash_fat16_set_name()

uint32_t flash_fat16_set_name | ( | const uint8_t * | file_name,
 |  | uint8_t | len
 | ) |  |

set file name

Parameters
file_name | file name
len | filename length
Return values
filename length

Definition at line 359 of file flash_fat16.c.

Referenced by flash_fat16_loop_status().

◆ flash_fat16_write()

uint32_t flash_fat16_write | ( | uint32_t | fat_lbk,
 |  | uint8_t * | data,
 |  | uint32_t | len
 | ) |  |

write a logical block address

Parameters
fat_lbk | logical block address to read
data | pointer to array to store data read
len | data length
Return values
read length

Definition at line 331 of file flash_fat16.c.

Referenced by msc_disk_write().

Variable Documentation

◆ flash_iap

flash_iap_type flash_iap
extern

Definition at line 173 of file flash_fat16.c.

Referenced by flash_fat16_addr_offset(), flash_fat16_boot_dir_write(), flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_loop_status(), flash_fat16_sector_write(), flash_fat16_set_upgrade_flag(), flash_write_data(), and main().


AT32F413 Firmwary Library: fat_dir_type Struct Reference

Data Fields
fat_dir_type Struct Reference
AT32F413_periph_examples » USB_device_virtual_msc_iap » USB_device_virtual_msc_iap_definition

#include <flash_fat16.h>

Data Fields

uint8_t | file_name [11]
uint8_t | attr
uint8_t | res
uint8_t | create_time_tenth
uint16_t | create_time
uint16_t | create_data
uint16_t | last_access_data
uint16_t | clus_high
uint16_t | write_time
uint16_t | write_data
uint16_t | clus_low
uint32_t | file_size

Detailed Description

Definition at line 92 of file flash_fat16.h.

Field Documentation

◆ attr

uint8_t fat_dir_type::attr

Definition at line 95 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write().

◆ clus_high

uint16_t fat_dir_type::clus_high

Definition at line 101 of file flash_fat16.h.

◆ clus_low

uint16_t fat_dir_type::clus_low

Definition at line 104 of file flash_fat16.h.

◆ create_data

uint16_t fat_dir_type::create_data

Definition at line 99 of file flash_fat16.h.

◆ create_time

uint16_t fat_dir_type::create_time

Definition at line 98 of file flash_fat16.h.

◆ create_time_tenth

uint8_t fat_dir_type::create_time_tenth

Definition at line 97 of file flash_fat16.h.

◆ file_name

uint8_t fat_dir_type::file_name[11]

Definition at line 94 of file flash_fat16.h.

Referenced by flash_fat16_sector_write().

◆ file_size

uint32_t fat_dir_type::file_size

Definition at line 105 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ last_access_data

uint16_t fat_dir_type::last_access_data

Definition at line 100 of file flash_fat16.h.

◆ res

uint8_t fat_dir_type::res

Definition at line 96 of file flash_fat16.h.

◆ write_data

uint16_t fat_dir_type::write_data

Definition at line 103 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write().

◆ write_time

uint16_t fat_dir_type::write_time

Definition at line 102 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write().

The documentation for this struct was generated from the following file:
  • flash_fat16.h


AT32F413 Firmwary Library: flash_iap_type Struct Reference

Data Fields
flash_iap_type Struct Reference
AT32F413_periph_examples » USB_device_virtual_msc_iap » USB_device_virtual_msc_iap_definition

#include <flash_fat16.h>

Data Fields

uint32_t | flash_base_addr
uint32_t | flash_app_addr
uint32_t | flash_size
uint32_t | flash_app_size
uint32_t | sector_size
uint32_t | sector_mask
uint32_t | firmware_length
uint32_t | write_crc
uint32_t | read_crc
uint32_t | write_addr
uint32_t | file_write_nr
upgrade_status_type msc_up_status

Detailed Description

Definition at line 108 of file flash_fat16.h.

Field Documentation

◆ file_write_nr

uint32_t flash_iap_type::file_write_nr

Definition at line 121 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write(), and flash_fat16_sector_write().

◆ firmware_length

uint32_t flash_iap_type::firmware_length

Definition at line 116 of file flash_fat16.h.

◆ flash_app_addr

uint32_t flash_iap_type::flash_app_addr

Definition at line 111 of file flash_fat16.h.

Referenced by flash_fat16_addr_offset(), flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_set_upgrade_flag(), and main().

◆ flash_app_size

uint32_t flash_iap_type::flash_app_size

Definition at line 113 of file flash_fat16.h.

Referenced by flash_fat16_init(), and flash_fat16_sector_write().

◆ flash_base_addr

uint32_t flash_iap_type::flash_base_addr

Definition at line 110 of file flash_fat16.h.

Referenced by flash_fat16_addr_offset(), flash_fat16_init(), flash_fat16_sector_write(), and flash_write_data().

◆ flash_size

uint32_t flash_iap_type::flash_size

Definition at line 112 of file flash_fat16.h.

Referenced by flash_fat16_addr_offset(), flash_fat16_init(), and flash_write_data().

◆ msc_up_status

upgrade_status_type flash_iap_type::msc_up_status

Definition at line 122 of file flash_fat16.h.

Referenced by flash_fat16_boot_dir_write(), flash_fat16_loop_status(), and flash_fat16_sector_write().

◆ read_crc

uint32_t flash_iap_type::read_crc

Definition at line 118 of file flash_fat16.h.

◆ sector_mask

uint32_t flash_iap_type::sector_mask

Definition at line 115 of file flash_fat16.h.

Referenced by flash_fat16_init(), and flash_write_data().

◆ sector_size

uint32_t flash_iap_type::sector_size

Definition at line 114 of file flash_fat16.h.

Referenced by flash_fat16_clear_upgrade_flag(), flash_fat16_get_upgrade_flag(), flash_fat16_init(), flash_fat16_set_upgrade_flag(), and flash_write_data().

◆ write_addr

uint32_t flash_iap_type::write_addr

Definition at line 120 of file flash_fat16.h.

Referenced by flash_fat16_init(), flash_fat16_loop_status(), and flash_fat16_sector_write().

◆ write_crc

uint32_t flash_iap_type::write_crc

Definition at line 117 of file flash_fat16.h.

The documentation for this struct was generated from the following file:
  • flash_fat16.h


AT32F413 Firmwary Library: WDT_reset

Functions
WDT_reset
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< watchdog timer reset flag

< watchdog timer reset flag

Definition at line 44 of file project/at_start_f413/examples/wdt/wdt_reset/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.


AT32F413 Firmwary Library: WDT_standby

Functions
WDT_standby
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< watchdog timer reset flag

< watchdog timer reset flag

Definition at line 44 of file project/at_start_f413/examples/wdt/wdt_standby/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.


AT32F413 Firmwary Library: WWDT_reset

Functions
WWDT_reset
AT32F413_periph_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< window watchdog timer reset flag

< window watchdog timer reset flag

Definition at line 43 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.


AT32F413 Firmwary Library: _USB_device_hid_app_led3

Macros | Functions
_USB_device_hid_app_led3
AT32F413_periph_examples

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER [1/2]

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.

◆ USB_EPT_AUTO_MALLOC_BUFFER [2/2]

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.

Function Documentation

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 247 of file project/at_start_f413/examples/acc/calibration/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 258 of file project/at_start_f413/examples/acc/calibration/src/main.c.


AT32F413 Firmwary Library: _USB_device_hid_iap

Macros | Functions
_USB_device_hid_iap
AT32F413_periph_examples

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

Macro Definition Documentation

◆ USB_EPT_AUTO_MALLOC_BUFFER

#define USB_EPT_AUTO_MALLOC_BUFFER

usb endpoint max num define

usb buffer extend to 768-1280 bytes

auto malloc usb endpoint buffer usb auto malloc endpoint tx and rx buffer

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.

Function Documentation

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 247 of file project/at_start_f413/examples/acc/calibration/src/main.c.

Referenced by usbd_remote_wakeup().

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 258 of file project/at_start_f413/examples/acc/calibration/src/main.c.


AT32F413 Firmwary Library: AT32F413_periph_template

Modules
AT32F413_periph_template

Modules

Library_configuration
System_clock_configuration
LED_toggle

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: Library_configuration

Macros
Library_configuration
AT32F413_periph_template

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 84 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 78 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 81 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 77 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 60 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 53 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 61 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 85 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 82 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 83 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 80 of file project/at_start_f413/templates/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 79 of file project/at_start_f413/templates/inc/at32f413_conf.h.


AT32F413 Firmwary Library: System_clock_configuration

Functions
System_clock_configuration
AT32F413_periph_template

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 56 of file project/at_start_f413/templates/src/at32f413_clock.c.


AT32F413 Firmwary Library: LED_toggle

Macros | Functions | Variables
LED_toggle
AT32F413_periph_template

Macros

#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...

Variables

uint8_t g_speed = 1

Detailed Description

Macro Definition Documentation

◆ DELAY

#define DELAY 100

Definition at line 38 of file project/at_start_f413/templates/src/main.c.

◆ FAST

#define FAST 1

Definition at line 39 of file project/at_start_f413/templates/src/main.c.

◆ SLOW

#define SLOW 4

Definition at line 40 of file project/at_start_f413/templates/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ button_exint_init()

void button_exint_init ( void )

configure button exint

Parameters
none
Return values
none

< external interrupt line 0

Definition at line 52 of file project/at_start_f413/templates/src/main.c.

Referenced by main().

◆ button_isr()

void button_isr ( void )

button handler function

Parameters
none
Return values
none

< external interrupt line 0

Definition at line 75 of file project/at_start_f413/templates/src/main.c.

Referenced by EXINT0_IRQHandler().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ EXINT0_IRQHandler()

void EXINT0_IRQHandler ( void )

exint0 interrupt handler

Parameters
none
Return values
none

Definition at line 98 of file project/at_start_f413/templates/src/main.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 108 of file project/at_start_f413/templates/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file project/at_start_f413/templates/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file project/at_start_f413/templates/src/at32f413_int.c.

Variable Documentation

◆ g_speed

uint8_t g_speed = 1

Definition at line 42 of file project/at_start_f413/templates/src/main.c.

Referenced by button_isr(), and main().


AT32F413 Firmwary Library: UTILITIES_examples

Modules
UTILITIES_examples

Modules

FreeRTOS_demo
GEN_random_number_demo
SLIB_project_l0
SLIB_project_l1
USART_IAP_app_led3_toggle
USART_IAP_app_led4_toggle
USART_IAP_bootloader
USB_IAP_app_led3_toggle
USB_IAP_app_led4_toggle
USB_IAP_bootloader

Detailed Description

Generated by doxygen 1.9.2


AT32F413 Firmwary Library: FreeRTOS_demo

Functions | Variables
FreeRTOS_demo
UTILITIES_examples

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | DebugMon_Handler (void)
this function handles svcall exception. More...
void | led2_task_function (void *pvParameters)
void | led3_task_function (void *pvParameters)
int | main (void)
main function. More...

Variables

TaskHandle_t | led2_handler
TaskHandle_t | led3_handler

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles svcall exception.

this function handles debug monitor exception.

Parameters
none
Return values
none

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ led2_task_function()

void led2_task_function ( void * pvParameters )

Definition at line 105 of file utilities/at32f413_freertos_demo/src/main.c.

Referenced by main().

◆ led3_task_function()

void led3_task_function ( void * pvParameters )

Definition at line 115 of file utilities/at32f413_freertos_demo/src/main.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f413_freertos_demo/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f413_freertos_demo/src/at32f413_int.c.

Variable Documentation

◆ led2_handler

TaskHandle_t led2_handler

Definition at line 39 of file utilities/at32f413_freertos_demo/src/main.c.

Referenced by main().

◆ led3_handler

TaskHandle_t led3_handler

Definition at line 40 of file utilities/at32f413_freertos_demo/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: GEN_random_number_demo

Modules | Macros | Functions
GEN_random_number_demo
UTILITIES_examples

Modules

RTC_asseed_definition
GEN_random_number_demo_exported_functions

Macros

#define DEVICE_ID_ADDR1 0x1FFFF7E8

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
int | main (void)
main function. More...
int | get_uid_for_seed (void)
get uid value as seed More...
void | randnum_test (void)
enable rtc as seed More...

Detailed Description

Macro Definition Documentation

◆ DEVICE_ID_ADDR1

#define DEVICE_ID_ADDR1 0x1FFFF7E8

Definition at line 41 of file random.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ get_uid_for_seed()

int get_uid_for_seed ( void )

get uid value as seed

Parameters
none
Return values
uid_one_word

Definition at line 48 of file random.c.

Referenced by randnum_test().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 45 of file utilities/at32f413_gen_random_number_demo/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ randnum_test()

void randnum_test ( void )

enable rtc as seed

Parameters
none
Return values
none

random number test

Parameters
none
Return values
none

Definition at line 122 of file random.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.


AT32F413 Firmwary Library: RTC_asseed_definition

Macros
RTC_asseed_definition
UTILITIES_examples » GEN_random_number_demo

Macros

#define ENABLE_RTC_ASSEED (1)

Detailed Description

Macro Definition Documentation

◆ ENABLE_RTC_ASSEED

#define ENABLE_RTC_ASSEED (1)

Definition at line 49 of file random.h.


AT32F413 Firmwary Library: GEN_random_number_demo_exported_functions

Functions
GEN_random_number_demo_exported_functions
UTILITIES_examples » GEN_random_number_demo

Functions

void randnum_test (void)
enable rtc as seed More...

Detailed Description

Function Documentation

◆ randnum_test()

void randnum_test ( void )

enable rtc as seed

Parameters
none
Return values
none

random number test

Parameters
none
Return values
none

Definition at line 122 of file random.c.

Referenced by main().


AT32F413 Firmwary Library: SLIB_project_l0

Macros | Functions | Variables
SLIB_project_l0
UTILITIES_examples

Macros

#define | USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */
#define | FLASH_START_ADDR 0x08000000
#define | TEST_SLIB_PSW 0x55665566
#define | SLIB_START_ADDR 0x08001000
#define | SLIB_DATA_ADDR 0x08002000
#define | SLIB_END_ADDR 0x08002800
#define | FLASH_SECTOR_SIZE 0x800
#define | SECTOR_NUM(dwAddr) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)
#define | SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */
#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...
flash_status_type | slib_enable (void)
config slib enable and program slib area. More...
int | main (void)
main function. More...

Variables

uint32_t | dw_start_sector
uint32_t | dw_data_start_sector
uint32_t | dw_end_sector
uint32_t | temp_buf [512]
static float32_t | testOutput [320]

Detailed Description

Macro Definition Documentation

◆ FLASH_SECTOR_SIZE

#define FLASH_SECTOR_SIZE 0x800

Definition at line 52 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ FLASH_START_ADDR

#define FLASH_START_ADDR 0x08000000

Definition at line 47 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SECTOR_NUM

#define SECTOR_NUM ( dwAddr ) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)

Definition at line 53 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SECTOR_WORD_CNT

#define SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */

Definition at line 54 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SLIB_DATA_ADDR

#define SLIB_DATA_ADDR 0x08002000

Definition at line 50 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SLIB_END_ADDR

#define SLIB_END_ADDR 0x08002800

Definition at line 51 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SLIB_START_ADDR

#define SLIB_START_ADDR 0x08001000

Definition at line 49 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ SNR_THRESHOLD_F32

#define SNR_THRESHOLD_F32 140.0f

Definition at line 56 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ TEST_LENGTH_SAMPLES

#define TEST_LENGTH_SAMPLES 320

Definition at line 57 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ TEST_SLIB_PSW

#define TEST_SLIB_PSW 0x55665566

Definition at line 48 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ USE_SLIB_FUNCTION

#define USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */

Definition at line 44 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ FLASH_IRQHandler()

void FLASH_IRQHandler ( void )

flash handler.

Parameters
none
Return values
none

< flash bank1 erase/program protection error flag

< flash bank1 erase/program protection error flag

Definition at line 141 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 129 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ slib_enable()

flash_status_type slib_enable ( void )

config slib enable and program slib area.

Parameters
none
Return values
flash status

Definition at line 93 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by main().

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.

Variable Documentation

◆ dw_data_start_sector

uint32_t dw_data_start_sector

Definition at line 60 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ dw_end_sector

uint32_t dw_end_sector

Definition at line 60 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ dw_start_sector

uint32_t dw_start_sector

Definition at line 60 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ temp_buf

uint32_t temp_buf[512]

Definition at line 61 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by slib_enable().

◆ testOutput

float32_t testOutput[320]
static

Definition at line 64 of file utilities/at32f413_slib_demo/project_l0/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: SLIB_project_l1

Macros | Functions | Variables
SLIB_project_l1
UTILITIES_examples

Macros

#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...
void | config_flash_interrupt (void)
config flash error interrupt. More...
int | main (void)
main function. More...

Variables

static float32_t testOutput [320]

Detailed Description

Macro Definition Documentation

◆ SNR_THRESHOLD_F32

#define SNR_THRESHOLD_F32 140.0f

Definition at line 44 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

◆ TEST_LENGTH_SAMPLES

#define TEST_LENGTH_SAMPLES 320

Definition at line 45 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 79 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ config_flash_interrupt()

void config_flash_interrupt ( void )

config flash error interrupt.

Parameters
none
Return values
flash status

< flash bank1 error interrupt

Definition at line 56 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

Referenced by main().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 114 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ FLASH_IRQHandler()

void FLASH_IRQHandler ( void )

flash handler.

Parameters
none
Return values
none

< flash bank1 erase/program protection error flag

< flash bank1 erase/program protection error flag

Definition at line 141 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 53 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 72 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 66 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 44 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 123 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 105 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 132 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 92 of file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.

Variable Documentation

◆ testOutput

float32_t testOutput[320]
static

Definition at line 47 of file utilities/at32f413_slib_demo/project_l1/src/main.c.

Referenced by main().


AT32F413 Firmwary Library: USART_IAP_app_led3_toggle

Modules | Functions | Variables
USART_IAP_app_led3_toggle
UTILITIES_examples

Modules

App_led3_definition
App_led3_exported_functions

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 120 of file app_led3_toggle/src/usart.c.

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 107 of file app_led3_toggle/src/usart.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 44 of file app_led3_toggle/src/iap.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

Definition at line 61 of file app_led3_toggle/src/iap.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 46 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 72 of file app_led3_toggle/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file app_led3_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 45 of file app_led3_toggle/src/usart.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

usart1 interrupt handler.

Parameters
none
Return values
none

Definition at line 87 of file app_led3_toggle/src/usart.c.

Variable Documentation

◆ iap_flag

uint8_t iap_flag = IAP_REV_FLAG_NO

Definition at line 38 of file app_led3_toggle/src/usart.c.

Referenced by USART1_IRQHandler().


AT32F413 Firmwary Library: App_led3_definition

Macros
App_led3_definition
UTILITIES_examples » USART_IAP_app_led3_toggle

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38
#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Detailed Description

Macro Definition Documentation

◆ APP_START_ADDR

#define APP_START_ADDR 0x08004000

Definition at line 49 of file app_led3_toggle/inc/iap.h.

◆ IAP_REV_FLAG_5A

#define IAP_REV_FLAG_5A 1

Definition at line 51 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_DONE

#define IAP_REV_FLAG_DONE 2

Definition at line 52 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_ERROR

#define IAP_REV_FLAG_ERROR 3

Definition at line 53 of file app_led3_toggle/inc/usart.h.

◆ IAP_REV_FLAG_NO

#define IAP_REV_FLAG_NO 0

Definition at line 50 of file app_led3_toggle/inc/usart.h.

◆ IAP_UPGRADE_FLAG

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 56 of file app_led3_toggle/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)

Definition at line 52 of file app_led3_toggle/inc/iap.h.


AT32F413 Firmwary Library: App_led3_exported_functions

Functions
App_led3_exported_functions
UTILITIES_examples » USART_IAP_app_led3_toggle

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
void | tmr_init (void)
init tmr. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 120 of file app_led3_toggle/src/usart.c.

Referenced by TMR3_GLOBAL_IRQHandler().

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 107 of file app_led3_toggle/src/usart.c.

Referenced by main().

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 44 of file app_led3_toggle/src/iap.c.

Referenced by main().

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file app_led3_toggle/src/iap.c.

Referenced by main().

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file app_led3_toggle/src/tmr.c.

Referenced by main().

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 45 of file app_led3_toggle/src/usart.c.


AT32F413 Firmwary Library: USART_IAP_app_led4_toggle

Modules | Functions | Variables
USART_IAP_app_led4_toggle
UTILITIES_examples

Modules

App_led4_definition
App_led4_exported_functions

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 120 of file app_led4_toggle/src/usart.c.

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 107 of file app_led4_toggle/src/usart.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 44 of file app_led4_toggle/src/iap.c.

Referenced by main().

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

Definition at line 61 of file app_led4_toggle/src/iap.c.

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 46 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 72 of file app_led4_toggle/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file app_led4_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 45 of file app_led4_toggle/src/usart.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

usart1 interrupt handler.

Parameters
none
Return values
none

Definition at line 87 of file app_led4_toggle/src/usart.c.

Variable Documentation

◆ iap_flag

uint8_t iap_flag = IAP_REV_FLAG_NO

Definition at line 38 of file app_led4_toggle/src/usart.c.

Referenced by iap_command_handle(), and USART1_IRQHandler().


AT32F413 Firmwary Library: App_led4_definition

Macros
App_led4_definition
UTILITIES_examples » USART_IAP_app_led4_toggle

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38
#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Detailed Description

Macro Definition Documentation

◆ APP_START_ADDR

#define APP_START_ADDR 0x08004000

Definition at line 49 of file app_led4_toggle/inc/iap.h.

◆ IAP_REV_FLAG_5A

#define IAP_REV_FLAG_5A 1

Definition at line 51 of file app_led4_toggle/inc/usart.h.

◆ IAP_REV_FLAG_DONE

#define IAP_REV_FLAG_DONE 2

Definition at line 52 of file app_led4_toggle/inc/usart.h.

◆ IAP_REV_FLAG_ERROR

#define IAP_REV_FLAG_ERROR 3

Definition at line 53 of file app_led4_toggle/inc/usart.h.

◆ IAP_REV_FLAG_NO

#define IAP_REV_FLAG_NO 0

Definition at line 50 of file app_led4_toggle/inc/usart.h.

◆ IAP_UPGRADE_FLAG

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 56 of file app_led4_toggle/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)

Definition at line 52 of file app_led4_toggle/inc/iap.h.


AT32F413 Firmwary Library: App_led4_exported_functions

Functions
App_led4_exported_functions
UTILITIES_examples » USART_IAP_app_led4_toggle

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...
void | tmr_init (void)
init tmr. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Detailed Description

Function Documentation

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 120 of file app_led3_toggle/src/usart.c.

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 107 of file app_led3_toggle/src/usart.c.

◆ iap_command_handle()

void iap_command_handle ( void )

iap command handle handle.

Parameters
none
Return values
none

Definition at line 44 of file app_led3_toggle/src/iap.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file app_led3_toggle/src/iap.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file app_led3_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 45 of file app_led3_toggle/src/usart.c.


AT32F413 Firmwary Library: USART_IAP_bootloader

Modules | Functions | Variables
USART_IAP_bootloader
UTILITIES_examples

Modules

Bootloader_definition
Bootloader_exported_functions
Bootloader_exported_types

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...
void | app_load (uint32_t app_addr)
app load. More...
uint8_t | data_take (void)
take data from usart buf. More...
void | command_handle (void)
command analysis handle. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...
void | app_update_handle (void)
app update flow handle. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...
int | main (void)
main function. More...
void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...

Variables

cmd_data_group_type cmd_data_group_type_struct
cmd_data_step_type cmd_data_step
cmd_ctr_step_type cmd_ctr_step
update_status_type update_status
usart_group_type usart_group_struct
cmd_data_step_type cmd_data_step = CMD_DATA_IDLE
cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE
cmd_data_group_type cmd_data_group_struct
update_status_type update_status = UPDATE_PRE
static uint8_t | cmd_addr_cnt = 0
static uint32_t | cmd_data_cnt = 0
uint8_t | time_ira_cnt =0
uint8_t | get_data_from_usart_flag = 0
usart_group_type usart_group_struct

Detailed Description

Function Documentation

◆ app_load()

void app_load ( uint32_t app_addr )

app load.

Parameters
app_addr app code starting address
Return values
none

Definition at line 60 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and main().

◆ app_update_handle()

void app_update_handle ( void )

app update flow handle.

Parameters
none
Return values
none

Definition at line 262 of file bootloader/src/iap.c.

Referenced by iap_upgrade_app_handle().

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 241 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and TMR3_GLOBAL_IRQHandler().

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 228 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ command_handle()

void command_handle ( void )

command analysis handle.

Parameters
none
Return values
none

Definition at line 106 of file bootloader/src/iap.c.

Referenced by iap_upgrade_app_handle().

◆ data_take()

uint8_t data_take ( void )

take data from usart buf.

Parameters
app_addr app code starting address
Return values
val took data

Definition at line 89 of file bootloader/src/iap.c.

Referenced by command_handle().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ flash_2kb_write()

void flash_2kb_write | ( | uint32_t | write_addr,
 |  | uint8_t * | pbuffer
 | ) |  |

flash erase/program operation.

Note
follow 2kb operation of ont time
Parameters
none
Return values
none

Definition at line 45 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by app_update_handle().

◆ flash_upgrade_flag_read()

flag_status flash_upgrade_flag_read ( void )

check flash upgrade flag.

Parameters
none
Return values
none

Definition at line 66 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by main().

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ iap_upgrade_app_handle()

void iap_upgrade_app_handle ( void )

iap upgrade app handle.

Parameters
none
Return values
none

Definition at line 344 of file bootloader/src/iap.c.

Referenced by main().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 47 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ TMR3_GLOBAL_IRQHandler()

void TMR3_GLOBAL_IRQHandler ( void )

tmr3 global interrupt handler.

Parameters
none
Return values
none

Definition at line 75 of file bootloader/src/tmr.c.

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 47 of file bootloader/src/tmr.c.

Referenced by main().

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 45 of file bootloader/src/usart.c.

Referenced by main().

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ USART1_IRQHandler()

void USART1_IRQHandler ( void )

usart1 interrupt handler.

Parameters
none
Return values
none

Definition at line 87 of file bootloader/src/usart.c.

Variable Documentation

◆ cmd_addr_cnt

uint8_t cmd_addr_cnt = 0
static

Definition at line 44 of file bootloader/src/iap.c.

Referenced by back_err(), and command_handle().

◆ cmd_ctr_step [1/2]

cmd_ctr_step_type cmd_ctr_step
extern

Definition at line 41 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ cmd_ctr_step [2/2]

cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE

Definition at line 41 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ cmd_data_cnt

uint32_t cmd_data_cnt = 0
static

Definition at line 45 of file bootloader/src/iap.c.

Referenced by back_err(), and command_handle().

◆ cmd_data_group_struct

cmd_data_group_type cmd_data_group_struct

Definition at line 42 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and command_handle().

◆ cmd_data_group_type_struct

cmd_data_group_type cmd_data_group_type_struct
extern

◆ cmd_data_step [1/2]

cmd_data_step_type cmd_data_step
extern

Definition at line 40 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ cmd_data_step [2/2]

cmd_data_step_type cmd_data_step = CMD_DATA_IDLE

Definition at line 40 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ get_data_from_usart_flag

uint8_t get_data_from_usart_flag = 0

Definition at line 40 of file bootloader/src/tmr.c.

Referenced by app_update_handle(), back_err(), and TMR3_GLOBAL_IRQHandler().

◆ time_ira_cnt

uint8_t time_ira_cnt =0

Definition at line 39 of file bootloader/src/tmr.c.

Referenced by back_err(), TMR3_GLOBAL_IRQHandler(), and USART1_IRQHandler().

◆ update_status [1/2]

update_status_type update_status
extern

Definition at line 43 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ update_status [2/2]

update_status_type update_status = UPDATE_PRE

Definition at line 43 of file bootloader/src/iap.c.

Referenced by app_update_handle(), back_err(), and command_handle().

◆ usart_group_struct [1/2]

usart_group_type usart_group_struct
extern

Definition at line 38 of file bootloader/src/usart.c.

Referenced by command_handle(), data_take(), and USART1_IRQHandler().

◆ usart_group_struct [2/2]

usart_group_type usart_group_struct

Definition at line 38 of file bootloader/src/usart.c.

Referenced by command_handle(), data_take(), and USART1_IRQHandler().


AT32F413 Firmwary Library: Bootloader_definition

Macros
Bootloader_definition
UTILITIES_examples » USART_IAP_bootloader | UTILITIES_examples » USB_IAP_bootloader

Macros

#define | FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */
#define | SRAM_SIZE 224 /* sram size, unit:kbyte */
#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38
#define | USART_REC_LEN 1024
#define | FLASH_APP_ADDRESS 0x08004000

Detailed Description

Macro Definition Documentation

◆ APP_START_ADDR

#define APP_START_ADDR 0x08004000

Definition at line 49 of file bootloader/inc/iap.h.

◆ FLASH_APP_ADDRESS

#define FLASH_APP_ADDRESS 0x08004000

Definition at line 49 of file bootloader/inc/hid_iap_user.h.

◆ FLASH_SIZE

#define FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */

Definition at line 48 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h.

◆ IAP_UPGRADE_FLAG

#define IAP_UPGRADE_FLAG 0x41544B38

Definition at line 56 of file bootloader/inc/iap.h.

◆ IAP_UPGRADE_FLAG_ADDR

#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)

Definition at line 52 of file bootloader/inc/iap.h.

◆ SRAM_SIZE

#define SRAM_SIZE 224 /* sram size, unit:kbyte */

Definition at line 49 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h.

◆ USART_REC_LEN

#define USART_REC_LEN 1024

Definition at line 48 of file bootloader/inc/usart.h.


AT32F413 Firmwary Library: Bootloader_exported_functions

Functions
Bootloader_exported_functions
UTILITIES_examples » USART_IAP_bootloader | UTILITIES_examples » USB_IAP_bootloader

Functions

void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...
void | command_handle (void)
command analysis handle. More...
void | back_err (void)
command response error. More...
void | back_ok (void)
command response ok. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...
void | app_load (uint32_t appxaddr)
app load. More...
void | tmr_init (void)
init tmr. More...
void | uart_init (uint32_t baudrate)
init usart. More...
void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_loop (void)
iap loop More...
void | jump_to_app (uint32_t address)
jump to app More...

Detailed Description

Function Documentation

◆ app_load()

void app_load ( uint32_t app_addr )

app load.

Parameters
app_addr app code starting address
Return values
none

Definition at line 60 of file bootloader/src/iap.c.

Referenced by app_update_handle(), and main().

◆ back_err()

void back_err ( void )

command response error.

Parameters
none
Return values
none

Definition at line 120 of file app_led3_toggle/src/usart.c.

Referenced by app_update_handle().

◆ back_ok()

void back_ok ( void )

command response ok.

Parameters
none
Return values
none

Definition at line 107 of file app_led3_toggle/src/usart.c.

Referenced by app_update_handle().

◆ command_handle()

void command_handle ( void )

command analysis handle.

Parameters
none
Return values
none

Definition at line 106 of file bootloader/src/iap.c.

Referenced by iap_upgrade_app_handle().

◆ flash_2kb_write()

void flash_2kb_write | ( | uint32_t | write_addr,
 |  | uint8_t * | pbuffer
 | ) |  |

flash erase/program operation.

Note
follow 2kb operation of ont time
Parameters
none
Return values
none

Definition at line 45 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by app_update_handle().

◆ flash_upgrade_flag_read()

flag_status flash_upgrade_flag_read ( void )

check flash upgrade flag.

Parameters
none
Return values
none

Definition at line 66 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.

Referenced by main().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 79 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file app_led3_toggle/src/iap.c.

Referenced by iap_idle(), and iap_start().

◆ iap_loop()

void iap_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 473 of file bootloader/src/hid_iap_user.c.

Referenced by main().

◆ iap_upgrade_app_handle()

void iap_upgrade_app_handle ( void )

iap upgrade app handle.

Parameters
none
Return values
none

Definition at line 344 of file bootloader/src/iap.c.

Referenced by main().

◆ jump_to_app()

void jump_to_app ( uint32_t address )

jump to app

Parameters
none
Return values
none

Definition at line 234 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.

Referenced by flash_fat16_loop_status(), iap_loop(), and main().

◆ tmr_init()

void tmr_init ( void )

init tmr.

Parameters
none
Return values
none

Definition at line 44 of file app_led3_toggle/src/tmr.c.

◆ uart_init()

void uart_init ( uint32_t baudrate )

init usart.

Parameters
none
Return values
none

Definition at line 45 of file app_led3_toggle/src/usart.c.


AT32F413 Firmwary Library: Bootloader_exported_types

Data Structures | Typedefs | Enumerations
Bootloader_exported_types
UTILITIES_examples » USART_IAP_bootloader

Data Structures

struct | cmd_data_group_type
cmd data group type More...
struct | usart_group_type
usart group type More...

Typedefs

typedef void(* iapfun) (void)

Enumerations

enum cmd_data_step_type {
CMD_DATA_IDLE , CMD_DATA_ADDR , CMD_DATA_BUF , CMD_DATA_CHACK ,
CMD_DATA_DONE , CMD_DATA_ERR
}
cmd data step type More...
enum cmd_ctr_step_type {
CMD_CTR_IDLE , CMD_CTR_INIT , CMD_CTR_DONE , CMD_CTR_ERR ,
CMD_CTR_APP
}
cmd ctr step type More...
enum update_status_type { UPDATE_PRE , UPDATE_CLEAR_FLAG , UPDATE_ING , UPDATE_DONE }
update status type More...

Detailed Description

Typedef Documentation

◆ iapfun

typedef void(* iapfun) (void)

Definition at line 113 of file bootloader/inc/iap.h.

Enumeration Type Documentation

◆ cmd_ctr_step_type

enum cmd_ctr_step_type

cmd ctr step type

Enumerator
CMD_CTR_IDLE
CMD_CTR_INIT
CMD_CTR_DONE
CMD_CTR_ERR
CMD_CTR_APP

Definition at line 93 of file bootloader/inc/iap.h.

◆ cmd_data_step_type

enum cmd_data_step_type

cmd data step type

Enumerator
CMD_DATA_IDLE
CMD_DATA_ADDR
CMD_DATA_BUF
CMD_DATA_CHACK
CMD_DATA_DONE
CMD_DATA_ERR

Definition at line 80 of file bootloader/inc/iap.h.

◆ update_status_type

enum update_status_type

update status type

Enumerator
UPDATE_PRE
UPDATE_CLEAR_FLAG
UPDATE_ING
UPDATE_DONE

Definition at line 105 of file bootloader/inc/iap.h.


AT32F413 Firmwary Library: cmd_data_group_type Struct Reference

Data Fields
cmd_data_group_type Struct Reference
UTILITIES_examples » USART_IAP_bootloader » Bootloader_exported_types

cmd data group type More...

#include <iap.h>

Data Fields

uint8_t | cmd_head
uint8_t | cmd_addr [4]
uint8_t | cmd_buf [0x800]
uint8_t | cmd_check

Detailed Description

cmd data group type

Definition at line 69 of file bootloader/inc/iap.h.

Field Documentation

◆ cmd_addr

uint8_t cmd_data_group_type::cmd_addr[4]

Definition at line 72 of file bootloader/inc/iap.h.

Referenced by app_update_handle(), and command_handle().

◆ cmd_buf

uint8_t cmd_data_group_type::cmd_buf[0x800]

Definition at line 73 of file bootloader/inc/iap.h.

Referenced by app_update_handle(), and command_handle().

◆ cmd_check

uint8_t cmd_data_group_type::cmd_check

Definition at line 74 of file bootloader/inc/iap.h.

◆ cmd_head

uint8_t cmd_data_group_type::cmd_head

Definition at line 71 of file bootloader/inc/iap.h.

The documentation for this struct was generated from the following file:
  • bootloader/inc/iap.h


AT32F413 Firmwary Library: usart_group_type Struct Reference

Data Fields
usart_group_type Struct Reference
UTILITIES_examples » USART_IAP_bootloader » Bootloader_exported_types

usart group type More...

#include <usart.h>

Data Fields

uint16_t | buf [1024]
uint16_t | head
uint16_t | tail
uint16_t | count

Detailed Description

usart group type

Definition at line 61 of file bootloader/inc/usart.h.

Field Documentation

◆ buf

uint16_t usart_group_type::buf[1024]

Definition at line 63 of file bootloader/inc/usart.h.

Referenced by data_take(), and USART1_IRQHandler().

◆ count

uint16_t usart_group_type::count

Definition at line 66 of file bootloader/inc/usart.h.

Referenced by command_handle(), data_take(), and USART1_IRQHandler().

◆ head

uint16_t usart_group_type::head

Definition at line 64 of file bootloader/inc/usart.h.

Referenced by USART1_IRQHandler().

◆ tail

uint16_t usart_group_type::tail

Definition at line 65 of file bootloader/inc/usart.h.

Referenced by data_take(), and USART1_IRQHandler().

The documentation for this struct was generated from the following file:
  • bootloader/inc/usart.h


AT32F413 Firmwary Library: USB_IAP_app_led3_toggle

Modules | Functions | Variables
USB_IAP_app_led3_toggle
UTILITIES_examples

Modules

App_led3_toggle_definition
App_led3_toggle_exported_functions

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_finish (void)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

void(* pftarget )(void)
usbd_core_type usb_core_dev

Detailed Description

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 253 of file app_led3_toggle/src/hid_iap_user.c.

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ iap_finish()

void iap_finish ( void )

Definition at line 315 of file bootloader/src/hid_iap_user.c.

◆ iap_get()

void iap_get ( )

Definition at line 159 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 79 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_init()

void iap_init ( void )

iap init

iap init.

Parameters
none
Return values
none

Definition at line 97 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by iap_idle(), and iap_start().

◆ iap_jump()

void iap_jump ( void )

Definition at line 148 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_respond()

void iap_respond | ( | uint8_t * | res_buf,
 |  | uint16_t | iap_cmd,
 |  | uint16_t | result
 | ) |  |

Definition at line 177 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by iap_get(), iap_idle(), iap_jump(), and iap_start().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 151 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 52 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 130 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 141 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 240 of file app_led3_toggle/src/hid_iap_user.c.

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 194 of file app_led3_toggle/src/hid_iap_user.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 120 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

Variable Documentation

◆ pftarget

void(* pftarget) (void) ( void )

Definition at line 39 of file app_led3_toggle/src/hid_iap_user.c.

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 43 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: App_led3_toggle_definition

Macros
App_led3_toggle_definition
UTILITIES_examples » USB_IAP_app_led3_toggle

Macros

#define FLASH_APP_ADDRESS 0x08004000

Detailed Description

Macro Definition Documentation

◆ FLASH_APP_ADDRESS

#define FLASH_APP_ADDRESS 0x08004000

Definition at line 49 of file app_led3_toggle/inc/hid_iap_user.h.


AT32F413 Firmwary Library: App_led3_toggle_exported_functions

Functions
App_led3_toggle_exported_functions
UTILITIES_examples » USB_IAP_app_led3_toggle

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...

Detailed Description

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 253 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by main().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 79 of file app_led3_toggle/src/hid_iap_user.c.

Referenced by main().

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file app_led3_toggle/src/iap.c.


AT32F413 Firmwary Library: USB_IAP_app_led4_toggle

Modules | Functions | Variables
USB_IAP_app_led4_toggle
UTILITIES_examples

Modules

App_led4_toggle_definition
App_led4_toggle_exported_functions

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
void | iap_finish (void)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

void(* pftarget )(void)
usbd_core_type usb_core_dev

Detailed Description

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 253 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by main().

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ crc_cal()

uint32_t crc_cal | ( | uint32_t | addr,
 |  | uint16_t | nk
 | ) |  |

crc cal

Parameters
addr | start address
nk | nk byte
Return values
crc value

Definition at line 155 of file bootloader/src/hid_iap_user.c.

Referenced by iap_crc().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ iap_clear_upgrade_flag()

void iap_clear_upgrade_flag ( void )

clear iap upgrade flag

Parameters
none
Return values
none

Definition at line 55 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by app_loop().

◆ iap_finish()

void iap_finish ( void )

Definition at line 315 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get()

void iap_get ( )

Definition at line 159 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 79 of file app_led4_toggle/src/hid_iap_user.c.

◆ iap_idle()

void iap_idle ( void )

iap idle function

Parameters
none
Return values
none

Definition at line 124 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_init()

void iap_init ( void )

iap init

iap init.

Parameters
none
Return values
none

Definition at line 97 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by iap_idle(), and iap_start().

◆ iap_jump()

void iap_jump ( void )

Definition at line 148 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_respond()

void iap_respond | ( | uint8_t * | res_buf,
 |  | uint16_t | iap_cmd,
 |  | uint16_t | result
 | ) |  |

Definition at line 177 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by iap_get(), iap_idle(), iap_jump(), and iap_start().

◆ iap_set_upgrade_flag()

void iap_set_upgrade_flag ( void )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 67 of file app_led4_toggle/src/hid_iap_user.c.

◆ iap_start()

void iap_start ( void )

iap start function

Parameters
none
Return values
none

Definition at line 136 of file app_led4_toggle/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

< nvic vector table based flash address

Definition at line 151 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 52 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 130 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 141 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 240 of file app_led4_toggle/src/hid_iap_user.c.

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 194 of file app_led4_toggle/src/hid_iap_user.c.

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 120 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

Variable Documentation

◆ pftarget

void(* pftarget) (void) ( void )

Definition at line 39 of file app_led4_toggle/src/hid_iap_user.c.

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 43 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: App_led4_toggle_definition

Macros
App_led4_toggle_definition
UTILITIES_examples » USB_IAP_app_led4_toggle

Macros

#define FLASH_APP_ADDRESS 0x08004000

Detailed Description

Macro Definition Documentation

◆ FLASH_APP_ADDRESS

#define FLASH_APP_ADDRESS 0x08004000

Definition at line 49 of file app_led4_toggle/inc/hid_iap_user.h.


AT32F413 Firmwary Library: App_led4_toggle_exported_functions

Functions
App_led4_toggle_exported_functions
UTILITIES_examples » USB_IAP_app_led4_toggle

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...

Detailed Description

Function Documentation

◆ app_loop()

void app_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 253 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 79 of file app_led3_toggle/src/hid_iap_user.c.

◆ iap_init()

void iap_init ( void )

iap init.

Parameters
none
Return values
none

iap init.

Parameters
none
Return values
none

Definition at line 61 of file app_led3_toggle/src/iap.c.


AT32F413 Firmwary Library: USB_IAP_bootloader

Modules | Functions | Variables
USB_IAP_bootloader
UTILITIES_examples

Modules

Bootloader_definition
Bootloader_exported_functions

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
iap_result_type | iap_address (uint8_t *pdata, uint32_t len)
iap parse address More...
void | iap_finish (void)
iap_result_type | iap_data_write (uint8_t *pdata, uint32_t len)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
void | jump_to_app (uint32_t address)
jump to app More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_erase_sector (uint32_t address)
set iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_crc (uint8_t *pdata, uint32_t len)
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | iap_loop (void)
iap loop More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

void(* pftarget )(void)
usbd_core_type usb_core_dev

Detailed Description

Function Documentation

◆ BusFault_Handler()

void BusFault_Handler ( void )

this function handles bus fault exception.

Parameters
none
Return values
none

Definition at line 78 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ crc_cal()

uint32_t crc_cal | ( | uint32_t | addr,
 |  | uint16_t | nk
 | ) |  |

crc cal

Parameters
addr | start address
nk | nk byte
Return values
crc value

Definition at line 155 of file bootloader/src/hid_iap_user.c.

Referenced by iap_crc().

◆ DebugMon_Handler()

void DebugMon_Handler ( void )

this function handles debug monitor exception.

Parameters
none
Return values
none

Definition at line 113 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ HardFault_Handler()

void HardFault_Handler ( void )

this function handles hard fault exception.

Parameters
none
Return values
none

Definition at line 52 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ iap_address()

iap_result_type iap_address | ( | uint8_t * | pdata,
 |  | uint32_t | len
 | ) |  |

iap parse address

Parameters
pdata | data buffer pointer.
len | data length
Return values
the result of the address parse

Definition at line 229 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_clear_upgrade_flag()

void iap_clear_upgrade_flag ( void )

clear iap upgrade flag

Parameters
none
Return values
none

Definition at line 82 of file bootloader/src/hid_iap_user.c.

Referenced by iap_address().

◆ iap_crc()

void iap_crc | ( | uint8_t * | pdata,
 |  | uint32_t | len
 | ) |  |

Definition at line 328 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_data_write()

iap_result_type iap_data_write | ( | uint8_t * | pdata,
 |  | uint32_t | len
 | ) |  |

Definition at line 270 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_erase_sector()

void iap_erase_sector ( uint32_t address )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 124 of file bootloader/src/hid_iap_user.c.

Referenced by iap_address().

◆ iap_finish()

void iap_finish ( void )

Definition at line 315 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get()

void iap_get ( )

Definition at line 367 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_get_upgrade_flag()

iap_result_type iap_get_upgrade_flag ( void )

get iap upgrade complete flag

Parameters
none
Return values
the status of the iap flag

Definition at line 106 of file bootloader/src/hid_iap_user.c.

Referenced by main().

◆ iap_idle()

void iap_idle ( void )

iap idle function

Parameters
none
Return values
none

Definition at line 204 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_init()

void iap_init ( void )

iap init

iap init.

Parameters
none
Return values
none

Definition at line 177 of file bootloader/src/hid_iap_user.c.

Referenced by iap_idle(), iap_start(), and main().

◆ iap_jump()

void iap_jump ( void )

Definition at line 356 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ iap_loop()

void iap_loop ( void )

iap loop

Parameters
none
Return values
none

Definition at line 473 of file bootloader/src/hid_iap_user.c.

Referenced by main().

◆ iap_respond()

void iap_respond | ( | uint8_t * | res_buf,
 |  | uint16_t | iap_cmd,
 |  | uint16_t | result
 | ) |  |

Definition at line 385 of file bootloader/src/hid_iap_user.c.

Referenced by iap_address(), iap_crc(), iap_data_write(), iap_finish(), iap_get(), iap_idle(), iap_jump(), and iap_start().

◆ iap_set_upgrade_flag()

void iap_set_upgrade_flag ( void )

set iap upgrade complete flag

Parameters
none
Return values
none

Definition at line 94 of file bootloader/src/hid_iap_user.c.

Referenced by iap_finish().

◆ iap_start()

void iap_start ( void )

iap start function

Parameters
none
Return values
none

Definition at line 216 of file bootloader/src/hid_iap_user.c.

Referenced by usbd_hid_iap_process().

◆ jump_to_app()

void jump_to_app ( uint32_t address )

jump to app

Parameters
none
Return values
none

Definition at line 57 of file bootloader/src/hid_iap_user.c.

Referenced by iap_loop().

◆ main()

int main ( void )

main function.

Parameters
none
Return values
none

Definition at line 152 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

◆ MemManage_Handler()

void MemManage_Handler ( void )

this function handles memory manage exception.

Parameters
none
Return values
none

Definition at line 65 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ NMI_Handler()

void NMI_Handler ( void )

this function handles nmi exception.

Parameters
none
Return values
none

Definition at line 43 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ PendSV_Handler()

void PendSV_Handler ( void )

this function handles pendsv_handler exception.

Parameters
none
Return values
none

Definition at line 122 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ SVC_Handler()

void SVC_Handler ( void )

this function handles svcall exception.

Parameters
none
Return values
none

Definition at line 104 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ SysTick_Handler()

void SysTick_Handler ( void )

this function handles systick handler.

Parameters
none
Return values
none

Definition at line 131 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ UsageFault_Handler()

void UsageFault_Handler ( void )

this function handles usage fault exception.

Parameters
none
Return values
none

Definition at line 91 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.

◆ usb_clock48m_select()

void usb_clock48m_select ( usb_clk48_s clk_s )

usb 48M clock select

Parameters
clk_s:USB_CLK_HICK,USB_CLK_HEXT
Return values
none

< acc hick trim

Definition at line 52 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

Referenced by main().

◆ usb_delay_ms()

void usb_delay_ms ( uint32_t ms )

usb delay millisecond function.

Parameters
ms number of millisecond delay
Return values
none

Definition at line 131 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

◆ usb_delay_us()

void usb_delay_us ( uint32_t us )

usb delay microsecond function.

Parameters
us number of microsecond delay
Return values
none

Definition at line 142 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

◆ usbd_hid_iap_in_complete()

void usbd_hid_iap_in_complete ( void * udev )

usb device in transfer complete function

Parameters
udev to the structure of usbd_core_type
Return values
none

Definition at line 460 of file bootloader/src/hid_iap_user.c.

Referenced by class_in_handler().

◆ usbd_hid_iap_process()

iap_result_type usbd_hid_iap_process | ( | void * | udev,
 |  | uint8_t * | pdata,
 |  | uint16_t | len
 | ) |  |

usb device iap function

Parameters
udev | to the structure of usbd_core_type
pdata | data buffer point
len | data length
Return values
iap_result_type

Definition at line 402 of file bootloader/src/hid_iap_user.c.

Referenced by class_out_handler().

◆ USBFS_L_CAN1_RX0_IRQHandler()

void USBFS_L_CAN1_RX0_IRQHandler ( void )

this function handles usb interrupt.

Parameters
none
Return values
none

Definition at line 121 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

Variable Documentation

◆ pftarget

void(* pftarget) (void) ( void )

Definition at line 39 of file bootloader/src/hid_iap_user.c.

Referenced by jump_to_app().

◆ usb_core_dev

usbd_core_type usb_core_dev

Definition at line 43 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.

Referenced by main(), and USBFS_L_CAN1_RX0_IRQHandler().


AT32F413 Firmwary Library: Data Structures

Data Structures
Here are the data structures with brief descriptions:
C acc_type | Type define acc register all
C adc_base_config_type | Adc base config type
C adc_type | Type define adc register all
C audio_codec_type |
C bpr_type | Type define bpr register all
C calendar_type |
C can_base_type | Can init structure definition
C can_baudrate_type | Can baudrate structure definition
C can_fifo_mailbox_type | Can controller area network fifo mailbox
C can_filter_init_type | Can filter init structure definition
C can_filter_register_type | Can controller area network filter bit register
C can_rx_message_type | Can rx message structure definition
C can_tx_mailbox_type | Can controller area network tx mailbox
C can_tx_message_type | Can tx message structure definition
C can_type | Type define can register all
C cbd_extended_type | Extended command block description
C cbd_typical_type | Typical command block description
C cbw_type | Command block wrapper
C cdc_msc_struct_type | Usb cdc class struct
C cdc_struct_type | Usb cdc class struct
C cmd_data_group_type | Cmd data group type
C crc_type | Type define crc register all
C crm_clocks_freq_type | Crm clocks freqency structure
C crm_type | Type define crm register all
C csw_type | Command block wrapper
C custom_hid_type |
C debug_type | Type define debug register all
C dma_channel_type | Type define dma channel register all
C dma_init_type | Dma init type
C dma_type | Type define dma register
C exint_init_type | Exint init type
C exint_type | Type define exint register all
C fat_dir_type |
C flash_iap_type |
C flash_type | Type define flash register all
C gpio_init_type | Gpio init type
C gpio_type | Type define gpio register all
C i2c_handle_type |
C i2c_type | Type define i2c register all
C i2s_init_type | I2s init type
C iap_info_type |
C iomux_type | Type define iomux register all
C keyboard_type |
C linecoding_type | Usb cdc class set line coding struct
C mouse_type |
C msc_type |
C printer_type |
C pwc_type | Type define pwc register all
C rtc_type | Type define rtc register all
C sc_atr_type |
C sd_card_info_struct_type |
C sd_cid_struct_type |
C sd_csd_struct_type |
C sd_scr_struct_type |
C sdio_command_struct_type | Sdio command structure
C sdio_data_struct_type | Sdio data structure
C sdio_type | Type define sdio register all
C sense_type | Request sense standard data
C spi_init_type | Spi init type
C spi_type | Type define spi register all
C tmr_brkdt_config_type | Tmr brkdt config type
C tmr_input_config_type | Tmr input capture config type
C tmr_output_config_type | Tmr output config type
C tmr_type | Type define tmr register all
C usart_group_type | Usart group type
C usart_type | Type define usart register all
C usb_audio_hid_type | Usb audio control struct
C usb_audio_type | Usb audio control struct
C usb_configuration_desc_type | Format of standard configuration descriptor
C usb_device_desc_type | Format of standard device descriptor
C usb_endpoint_desc_type | Format of standard endpoint descriptor
C usb_ept_info | Usb endpoint infomation structure definition
C usb_header_desc_type | Format of header
C usb_interface_desc_type | Format of standard interface descriptor
C usb_setup_type | Format of usb setup data
C usbd_class_handler | Usb device class handler
C usbd_core_type | Usb device core struct type
C usbd_desc_handler | Usb device descriptor handler
C usbd_desc_t | Usb device descriptor struct
C usbd_type | Type define usb register all
C usd_type | User system data
C vcp_keyboard_type |
C wdt_type | Type define wdt register all
C wwdt_type | Type define wwdt register all


AT32F413 Firmwary Library: Data Structure Index

Data Structure Index
A | B | C | D | E | F | G | I | K | L | M | P | R | S | T | U | V | W
A
acc_type
adc_base_config_type
adc_type
audio_codec_type
B
bpr_type
C
calendar_type
can_base_type
can_baudrate_type
can_fifo_mailbox_type
can_filter_init_type
can_filter_register_type
can_rx_message_type
can_tx_mailbox_type
can_tx_message_type
can_type
cbd_extended_type
cbd_typical_type
cbw_type
cdc_msc_struct_type
cdc_struct_type
cmd_data_group_type
crc_type
crm_clocks_freq_type
crm_type
csw_type
custom_hid_type
D
debug_type
dma_channel_type
dma_init_type
dma_type
E
exint_init_type
exint_type
F
fat_dir_type
flash_iap_type
flash_type
G
gpio_init_type
gpio_type
I
i2c_handle_type
i2c_type
i2s_init_type
iap_info_type
iomux_type
K
keyboard_type
L
linecoding_type
M
mouse_type
msc_type
P
printer_type
pwc_type
R
rtc_type
S
sc_atr_type
sd_card_info_struct_type
sd_cid_struct_type
sd_csd_struct_type
sd_scr_struct_type
sdio_command_struct_type
sdio_data_struct_type
sdio_type
sense_type
spi_init_type
spi_type
T
tmr_brkdt_config_type
tmr_input_config_type
tmr_output_config_type
tmr_type
U
usart_group_type
usart_type
usb_audio_hid_type
usb_audio_type
usb_configuration_desc_type
usb_device_desc_type
usb_endpoint_desc_type
usb_ept_info
usb_header_desc_type
usb_interface_desc_type
usb_setup_type
usbd_class_handler
usbd_core_type
usbd_desc_handler
usbd_desc_t
usbd_type
usd_type
V
vcp_keyboard_type
W
wdt_type
wwdt_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • accen : crm_type
  • accrst : crm_type
  • acken : i2c_type
  • ackfail : i2c_type
  • acs : spi_type
  • adc1_eto_gmux : iomux_type
  • adc1_etp_gmux : iomux_type
  • adc1_extrgord_mux : iomux_type
  • adc1_extrgpre_mux : iomux_type
  • adc1en : crm_type
  • adc1rst : crm_type
  • adc2_eto_gmux : iomux_type
  • adc2_etp_gmux : iomux_type
  • adc2_extrgord_mux : iomux_type
  • adc2_extrgpre_mux : iomux_type
  • adc2en : crm_type
  • adc2odt : adc_type
  • adc2rst : crm_type
  • adc_freq : crm_clocks_freq_type
  • adcal : adc_type
  • adcalinit : adc_type
  • adcdiv_h : crm_type
  • adcdiv_l : crm_type
  • adcen : adc_type
  • addr : flash_type, tmr_type, usbd_type
  • addr1 : i2c_type
  • addr1mode : i2c_type
  • addr2 : i2c_type
  • addr2en : i2c_type
  • addr3 : flash_type
  • addr3_bit : flash_type
  • addr7f : i2c_type
  • addr_bit : flash_type
  • address : cbd_extended_type, cbd_typical_type
  • addrhf : i2c_type
  • aebo_enable : can_base_type
  • aeboen : can_type
  • aed_enable : can_base_type
  • aeden : can_type
  • ahb_freq : crm_clocks_freq_type
  • ahbdiv : crm_type
  • ahben : crm_type
  • ahben_bit : crm_type
  • alertf : i2c_type
  • alloc_length : cbd_extended_type, cbd_typical_type
  • alt_setting : cdc_msc_struct_type, cdc_struct_type, custom_hid_type, iap_info_type, keyboard_type, mouse_type, msc_type, printer_type, usb_audio_hid_type, vcp_keyboard_type
  • aoen : tmr_type
  • apb1_freq : crm_clocks_freq_type
  • apb1div : crm_type
  • apb1en : crm_type
  • apb1en_bit : crm_type
  • apb1rst : crm_type
  • apb1rst_bit : crm_type
  • apb2_freq : crm_clocks_freq_type
  • apb2div : crm_type
  • apb2en : crm_type
  • apb2en_bit : crm_type
  • apb2rst : crm_type
  • apb2rst_bit : crm_type
  • app_address : iap_info_type
  • argu : sdio_type
  • argu_bit : sdio_type
  • argument : sdio_command_struct_type
  • arlost : i2c_type
  • arpen : i2c_type
  • as_length : sense_type
  • asc : sense_type
  • ascq : sense_type
  • attr : fat_dir_type
  • audio_bitw : audio_codec_type
  • audio_cmd : usb_audio_hid_type, usb_audio_type
  • audio_cmd_len : usb_audio_hid_type, usb_audio_type
  • audio_feed_back : usb_audio_hid_type, usb_audio_type
  • audio_freq : audio_codec_type
  • audio_mic_data : usb_audio_hid_type, usb_audio_type
  • audio_protocol : i2s_init_type
  • audio_sampling_freq : i2s_init_type
  • audio_spk_data : usb_audio_hid_type, usb_audio_type
  • auto_output_enable : tmr_brkdt_config_type
  • auto_step_en : crm_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • bAlternateSetting : usb_interface_desc_type
  • bankers : flash_type
  • baudr : usart_type
  • baudr_bit : usart_type
  • baudrate_div : can_baudrate_type
  • bCBWCBLength : cbw_type
  • bCBWLUN : cbw_type
  • bcdDevice : usb_device_desc_type
  • bcdUSB : usb_device_desc_type
  • bConfigurationValue : usb_configuration_desc_type
  • bCSWStatus : csw_type
  • bDescriptorType : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_interface_desc_type
  • bDeviceClass : usb_device_desc_type
  • bDeviceProtocol : usb_device_desc_type
  • bDeviceSubClass : usb_device_desc_type
  • be : usbd_type
  • beien : usbd_type
  • bEndpointAddress : usb_endpoint_desc_type
  • bf : spi_type
  • bfbn : usart_type
  • bff : usart_type
  • bfien : usart_type
  • bInterfaceClass : usb_interface_desc_type
  • bInterfaceNumber : usb_interface_desc_type
  • bInterfaceProtocol : usb_interface_desc_type
  • bInterfaceSubClass : usb_interface_desc_type
  • bInterval : usb_endpoint_desc_type
  • bitrate : linecoding_type
  • bLength : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_interface_desc_type
  • blk_addr : cdc_msc_struct_type, msc_type
  • blk_len : cdc_msc_struct_type, msc_type
  • blk_nbr : cdc_msc_struct_type, msc_type
  • blk_size : cdc_msc_struct_type, msc_type
  • blksize : sdio_type
  • block_size : sdio_data_struct_type
  • bmAttributes : usb_configuration_desc_type, usb_endpoint_desc_type
  • bMaxPacketSize0 : usb_device_desc_type
  • bMaxPower : usb_configuration_desc_type
  • bmCBWFlags : cbw_type
  • bmRequestType : usb_setup_type
  • bNumConfigurations : usb_device_desc_type
  • bNumEndpoints : usb_interface_desc_type
  • bNumInterfaces : usb_configuration_desc_type
  • bof : can_type
  • boien : can_type
  • bot_status : cdc_msc_struct_type, msc_type
  • bpdc : crm_type
  • bpdc_bit : crm_type
  • bpdrst : crm_type
  • bpren : crm_type
  • bprrst : crm_type
  • bpwen : pwc_type
  • brdiv : can_type
  • bRequest : usb_setup_type
  • brk : tmr_type
  • brk_bit : tmr_type
  • brk_enable : tmr_brkdt_config_type
  • brk_polarity : tmr_brkdt_config_type
  • brken : tmr_type
  • brkie : tmr_type
  • brkif : tmr_type
  • brkswtr : tmr_type
  • brkv : tmr_type
  • btaddr : usbd_type
  • btmg : can_type
  • btmg_bit : can_type
  • bts1 : can_type
  • bts1_size : can_baudrate_type
  • bts2 : can_type
  • bts2_size : can_baudrate_type
  • buf : sdio_type, usart_group_type
  • buf_bit : sdio_type
  • bufcnt : sdio_type
  • bufcnt_bit : sdio_type
  • buffer_size : dma_init_type
  • buftbl : usbd_type
  • buftbl_bit : usbd_type
  • buserr : i2c_type
  • busws : sdio_type
  • busyf : i2c_type
  • bypsen : sdio_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • c1 : acc_type
  • c1_bit : acc_type
  • c1c : tmr_type
  • c1cen : tmr_type
  • c1cios : tmr_type
  • c1cp : tmr_type
  • c1den : tmr_type
  • c1df : tmr_type
  • c1dt : tmr_type
  • c1dt_bit : tmr_type
  • c1en : tmr_type
  • c1idiv : tmr_type
  • c1ien : tmr_type
  • c1if : tmr_type
  • c1insel : tmr_type
  • c1ios : tmr_type
  • c1oben : tmr_type
  • c1octrl : tmr_type
  • c1oien : tmr_type
  • c1osen : tmr_type
  • c1p : tmr_type
  • c1rf : tmr_type
  • c1swtr : tmr_type
  • c2 : acc_type
  • c2_bit : acc_type
  • c2c : tmr_type
  • c2cen : tmr_type
  • c2cios : tmr_type
  • c2cp : tmr_type
  • c2den : tmr_type
  • c2df : tmr_type
  • c2dt : tmr_type
  • c2dt_bit : tmr_type
  • c2en : tmr_type
  • c2idiv : tmr_type
  • c2ien : tmr_type
  • c2if : tmr_type
  • c2ios : tmr_type
  • c2oben : tmr_type
  • c2octrl : tmr_type
  • c2oien : tmr_type
  • c2osen : tmr_type
  • c2p : tmr_type
  • c2rf : tmr_type
  • c2swtr : tmr_type
  • c3 : acc_type
  • c3_bit : acc_type
  • c3c : tmr_type
  • c3cen : tmr_type
  • c3cios : tmr_type
  • c3cp : tmr_type
  • c3den : tmr_type
  • c3df : tmr_type
  • c3dt : tmr_type
  • c3dt_bit : tmr_type
  • c3en : tmr_type
  • c3idiv : tmr_type
  • c3ien : tmr_type
  • c3if : tmr_type
  • c3ios : tmr_type
  • c3oben : tmr_type
  • c3octrl : tmr_type
  • c3oien : tmr_type
  • c3osen : tmr_type
  • c3p : tmr_type
  • c3rf : tmr_type
  • c3swtr : tmr_type
  • c4c : tmr_type
  • c4den : tmr_type
  • c4df : tmr_type
  • c4dt : tmr_type
  • c4dt_bit : tmr_type
  • c4en : tmr_type
  • c4idiv : tmr_type
  • c4ien : tmr_type
  • c4if : tmr_type
  • c4ios : tmr_type
  • c4oben : tmr_type
  • c4octrl : tmr_type
  • c4oien : tmr_type
  • c4osen : tmr_type
  • c4p : tmr_type
  • c4rf : tmr_type
  • c4swtr : tmr_type
  • calon : acc_type
  • calout : bpr_type
  • calrdy : acc_type
  • calrdyien : acc_type
  • calval : bpr_type
  • can1_gmux : iomux_type
  • can1_pause : debug_type
  • can1en : crm_type
  • can1rst : crm_type
  • can2_gmux : iomux_type
  • can2_pause : debug_type
  • can2en : crm_type
  • can2rst : crm_type
  • can_mux : iomux_type
  • card_blk_size : sd_card_info_struct_type
  • card_capacity : sd_card_info_struct_type
  • card_cmd_classes : sd_csd_struct_type
  • card_type : sd_card_info_struct_type
  • cardsts1 : sdio_type
  • cardsts2 : sdio_type
  • cardsts3 : sdio_type
  • cardsts4 : sdio_type
  • cbctrl : tmr_type
  • cbw_struct : cdc_msc_struct_type, msc_type
  • CBWCB : cbw_type
  • cce : adc_type
  • cceien : adc_type
  • ccen : spi_type
  • ccerr : spi_type
  • ccfs : tmr_type
  • ccos : bpr_type
  • ccsmen : sdio_type
  • cctrl : tmr_type
  • cctrl_bit : tmr_type
  • cdt : crc_type
  • cdt_bit : crc_type
  • cen : usbd_type
  • cfden : crm_type
  • cfdf : crm_type
  • cfdfc : crm_type
  • cfg : crm_type, usbd_type, wwdt_type
  • cfg_bit : crm_type, usbd_type, wwdt_type
  • cfgen : rtc_type
  • cfgf : rtc_type
  • cfghr : gpio_type
  • cfghr_bit : gpio_type
  • cfglr : gpio_type
  • cfglr_bit : gpio_type
  • ch1_src : dma_type
  • ch2_src : dma_type
  • ch3_src : dma_type
  • ch4_src : dma_type
  • ch5_src : dma_type
  • ch6_src : dma_type
  • ch7_src : dma_type
  • chen : dma_channel_type
  • chpers : flash_type
  • chpl : dma_channel_type
  • cid_crc : sd_cid_struct_type
  • class_handler : usbd_core_type
  • clck : usbd_type
  • clear_handler : usbd_class_handler
  • clk_to_tmr : crm_type
  • clkctrl : i2c_type, sdio_type
  • clkctrl_bit : i2c_type, sdio_type
  • clkdiv : tmr_type
  • clkdiv_h : sdio_type
  • clkdiv_l : sdio_type
  • clkegs : sdio_type
  • clken : usart_type
  • clkfreq : i2c_type
  • clkint : crm_type
  • clkint_bit : crm_type
  • clkoen : sdio_type
  • clkout_sel : crm_type
  • clkoutdiv : crm_type
  • clkpha : spi_type, usart_type
  • clkpol : spi_type, usart_type
  • clock_phase : spi_init_type
  • clock_polarity : i2s_init_type, spi_init_type
  • clr : dma_type, gpio_type
  • clr_bit : dma_type, gpio_type
  • clsef : pwc_type
  • clswef : pwc_type
  • clus_high : fat_dir_type
  • clus_low : fat_dir_type
  • cm1 : tmr_type
  • cm1_input_bit : tmr_type
  • cm1_output_bit : tmr_type
  • cm2 : tmr_type
  • cm2_input_bit : tmr_type
  • cm2_output_bit : tmr_type
  • cmd : wdt_type
  • cmd20_support : sd_scr_struct_type
  • cmd23_support : sd_scr_struct_type
  • cmd_addr : cmd_data_group_type
  • cmd_bit : wdt_type
  • cmd_buf : cmd_data_group_type
  • cmd_check : cmd_data_group_type
  • cmd_head : cmd_data_group_type
  • cmd_index : sdio_command_struct_type
  • cmdcmpl : sdio_type
  • cmdcmplien : sdio_type
  • cmdctrl : sdio_type
  • cmdctrl_bit : sdio_type
  • cmdfail : sdio_type
  • cmdfailien : sdio_type
  • cmdidx : sdio_type
  • cmdrspcmpl : sdio_type
  • cmdrspcmplien : sdio_type
  • cmdtimeout : sdio_type
  • cmdtimeoutien : sdio_type
  • cnt : dma_channel_type, rtc_type, sdio_type, wwdt_type
  • cnt_dir : tmr_type
  • cnth : rtc_type
  • cnth_bit : rtc_type
  • cntl : rtc_type
  • cntl_bit : rtc_type
  • config_status : usbd_core_type
  • conn_state : usbd_core_type
  • content_protect_app : sd_csd_struct_type
  • copy_flag : sd_csd_struct_type
  • count : usart_group_type
  • cpoly : spi_type
  • cpoly_bit : spi_type
  • crc_chkr : flash_type
  • crc_chkr_bit : flash_type
  • crc_ctrl : flash_type
  • crc_ctrl_bit : flash_type
  • crc_sn : flash_type
  • crc_ss : flash_type
  • crc_strt : flash_type
  • crcen : crm_type
  • create_data : fat_dir_type
  • create_time : fat_dir_type
  • create_time_tenth : fat_dir_type
  • cs_mode_selection : spi_init_type
  • csd_crc : sd_csd_struct_type
  • csd_struct : sd_csd_struct_type
  • cspt0 : adc_type
  • cspt1 : adc_type
  • cspt10 : adc_type
  • cspt11 : adc_type
  • cspt12 : adc_type
  • cspt13 : adc_type
  • cspt14 : adc_type
  • cspt15 : adc_type
  • cspt16 : adc_type
  • cspt17 : adc_type
  • cspt2 : adc_type
  • cspt3 : adc_type
  • cspt4 : adc_type
  • cspt5 : adc_type
  • cspt6 : adc_type
  • cspt7 : adc_type
  • cspt8 : adc_type
  • cspt9 : adc_type
  • csrst : usbd_type
  • csw_struct : cdc_msc_struct_type, msc_type
  • ctrl : bpr_type, crc_type, crm_type, debug_type, dma_channel_type, flash_type, pwc_type, usbd_type, wwdt_type
  • ctrl1 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl1_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl3 : flash_type, usart_type
  • ctrl3_bit : flash_type, usart_type
  • ctrl_bit : bpr_type, crc_type, crm_type, debug_type, dma_channel_type, flash_type, pwc_type, usbd_type, wwdt_type
  • ctrlh : rtc_type
  • ctrlh_bit : rtc_type
  • ctrll : rtc_type
  • ctrll_bit : rtc_type
  • ctrlsts : bpr_type, crm_type, pwc_type
  • ctrlsts_bit : bpr_type, crm_type, pwc_type
  • ctscf : usart_type
  • ctscfien : usart_type
  • ctsen : usart_type
  • curs : can_type
  • cuss : can_type
  • cval : tmr_type
  • cval_bit : tmr_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • da : flash_type
  • da_bit : flash_type
  • data : can_rx_message_type, can_tx_message_type, cdc_msc_struct_type, linecoding_type, msc_type
  • data0 : usd_type
  • data1 : usd_type
  • data2 : usd_type
  • data3 : usd_type
  • data4 : usd_type
  • data5 : usd_type
  • data6 : usd_type
  • data7 : usd_type
  • data_align : adc_base_config_type
  • data_channel_format : i2s_init_type
  • data_len : cdc_msc_struct_type, msc_type
  • data_length : sdio_data_struct_type
  • data_stat_after_erase : sd_scr_struct_type
  • dataien : i2c_type
  • date : calendar_type
  • dbn : usart_type
  • dCBWDataTransferLength : cbw_type
  • dCBWSignature : cbw_type
  • dCBWTage : cbw_type
  • dCSWDataResidue : csw_type
  • dCSWSignature : csw_type
  • dCSWTag : csw_type
  • deadtime : tmr_brkdt_config_type
  • deepsleep_debug : debug_type
  • default_config : usbd_core_type
  • depslp_rst : flash_type
  • desc_handler : usbd_core_type
  • descriptor : usbd_desc_t
  • dev_config : usbd_core_type
  • devaddr : usbd_type
  • devaddr_bit : usbd_type
  • devaddrf : i2c_type
  • device_addr : usbd_core_type
  • device_size : sd_csd_struct_type
  • device_size_mult : sd_csd_struct_type
  • direction : dma_init_type
  • dirf : i2c_type
  • disusb : usbd_type
  • div : rtc_type, tmr_type, usart_type, wdt_type, wwdt_type
  • div_bit : tmr_type, wdt_type
  • divcnt : rtc_type
  • divcnth : rtc_type
  • divcnth_bit : rtc_type
  • divcntl : rtc_type
  • divcntl_bit : rtc_type
  • divf : wdt_type
  • divh : rtc_type
  • divh_bit : rtc_type
  • divl : rtc_type
  • divl_bit : rtc_type
  • dlc : can_rx_message_type, can_tx_message_type
  • dma1en : crm_type
  • dma2en : crm_type
  • dma_flex_en : dma_type
  • dma_init_struct : i2c_handle_type
  • dma_rx_channel : i2c_handle_type
  • dma_tx_channel : i2c_handle_type
  • dmactrl : tmr_type
  • dmactrl_bit : tmr_type
  • dmadt : tmr_type
  • dmadt_bit : tmr_type
  • dmaen : i2c_type, sdio_type
  • dmaend : i2c_type
  • dmaren : spi_type, usart_type
  • dmaten : spi_type, usart_type
  • dmsts : usbd_type
  • docmd : sdio_type
  • docmdien : sdio_type
  • dorx : sdio_type
  • dorxien : sdio_type
  • dotx : sdio_type
  • dotxien : sdio_type
  • dpsts : usbd_type
  • drs : tmr_type
  • dsr_implemented : sd_csd_struct_type
  • dt : bpr_type, crc_type, i2c_type, sdio_type, spi_type, usart_type
  • dt1 : bpr_type
  • dt10 : bpr_type
  • dt10_bit : bpr_type
  • dt11 : bpr_type
  • dt11_bit : bpr_type
  • dt12 : bpr_type
  • dt12_bit : bpr_type
  • dt13 : bpr_type
  • dt13_bit : bpr_type
  • dt14 : bpr_type
  • dt14_bit : bpr_type
  • dt15 : bpr_type
  • dt15_bit : bpr_type
  • dt16 : bpr_type
  • dt16_bit : bpr_type
  • dt17 : bpr_type
  • dt17_bit : bpr_type
  • dt18 : bpr_type
  • dt18_bit : bpr_type
  • dt19 : bpr_type
  • dt19_bit : bpr_type
  • dt1_bit : bpr_type
  • dt2 : bpr_type
  • dt20 : bpr_type
  • dt20_bit : bpr_type
  • dt21 : bpr_type
  • dt21_bit : bpr_type
  • dt22 : bpr_type
  • dt22_bit : bpr_type
  • dt23 : bpr_type
  • dt23_bit : bpr_type
  • dt24 : bpr_type
  • dt24_bit : bpr_type
  • dt25 : bpr_type
  • dt25_bit : bpr_type
  • dt26 : bpr_type
  • dt26_bit : bpr_type
  • dt27 : bpr_type
  • dt27_bit : bpr_type
  • dt28 : bpr_type
  • dt28_bit : bpr_type
  • dt29 : bpr_type
  • dt29_bit : bpr_type
  • dt2_bit : bpr_type
  • dt3 : bpr_type
  • dt30 : bpr_type
  • dt30_bit : bpr_type
  • dt31 : bpr_type
  • dt31_bit : bpr_type
  • dt32 : bpr_type
  • dt32_bit : bpr_type
  • dt33 : bpr_type
  • dt33_bit : bpr_type
  • dt34 : bpr_type
  • dt34_bit : bpr_type
  • dt35 : bpr_type
  • dt35_bit : bpr_type
  • dt36 : bpr_type
  • dt36_bit : bpr_type
  • dt37 : bpr_type
  • dt37_bit : bpr_type
  • dt38 : bpr_type
  • dt38_bit : bpr_type
  • dt39 : bpr_type
  • dt39_bit : bpr_type
  • dt3_bit : bpr_type
  • dt4 : bpr_type
  • dt40 : bpr_type
  • dt40_bit : bpr_type
  • dt41 : bpr_type
  • dt41_bit : bpr_type
  • dt42 : bpr_type
  • dt42_bit : bpr_type
  • dt4_bit : bpr_type
  • dt5 : bpr_type
  • dt5_bit : bpr_type
  • dt6 : bpr_type
  • dt6_bit : bpr_type
  • dt7 : bpr_type
  • dt7_bit : bpr_type
  • dt8 : bpr_type
  • dt8_bit : bpr_type
  • dt9 : bpr_type
  • dt9_bit : bpr_type
  • dt_bit : crc_type, i2c_type, spi_type, usart_type
  • dtalign : adc_type
  • dtb : tmr_type
  • dtblkcmpl : sdio_type
  • dtblkcmplien : sdio_type
  • dtc : tmr_type
  • dtcmpl : sdio_type
  • dtcmplien : sdio_type
  • dtcnt : dma_channel_type, sdio_type
  • dtcnt_bit : dma_channel_type, sdio_type
  • dtctrl : sdio_type
  • dtctrl_bit : sdio_type
  • dtd : dma_channel_type
  • dterrf1 : dma_type
  • dterrf2 : dma_type
  • dterrf3 : dma_type
  • dterrf4 : dma_type
  • dterrf5 : dma_type
  • dterrf6 : dma_type
  • dterrf7 : dma_type
  • dterrfc1 : dma_type
  • dterrfc2 : dma_type
  • dterrfc3 : dma_type
  • dterrfc4 : dma_type
  • dterrfc5 : dma_type
  • dterrfc6 : dma_type
  • dterrfc7 : dma_type
  • dterrien : dma_channel_type
  • dtfail : sdio_type
  • dtfailien : sdio_type
  • dtlen : sdio_type
  • dtlen_bit : sdio_type
  • dttimeout : sdio_type
  • dttimeoutien : sdio_type
  • dttmr : sdio_type
  • dttmr_bit : sdio_type
  • dutymode : i2c_type
  • dzc : can_type
  • dzen : can_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • eaf : can_type
  • eaien : can_type
  • ecc_code : sd_csd_struct_type
  • ecmben : tmr_type
  • edzien : can_type
  • edzif : can_type
  • eien : acc_type
  • enpd : usb_audio_hid_type, usb_audio_type
  • entrim : acc_type
  • eoien : can_type
  • eoif : can_type
  • eopb0 : usd_type
  • epf : can_type
  • epien : can_type
  • epp0 : usd_type
  • epp1 : usd_type
  • epp2 : usd_type
  • epp3 : usd_type
  • epperr : flash_type
  • epps : flash_type
  • epps_bit : flash_type
  • ept : usbd_type
  • ept0_rx_handler : usbd_class_handler
  • ept0_slen : usb_ept_info
  • ept0_sts : usbd_core_type
  • ept0_tx_handler : usbd_class_handler
  • ept0_wlength : usbd_core_type
  • ept_address : usb_ept_info
  • ept_bit : usbd_type
  • ept_in : usbd_core_type
  • ept_num : usbd_type
  • ept_out : usbd_core_type
  • eptaddr : usbd_type
  • eptn : usb_ept_info
  • erase_group_size : sd_csd_struct_type
  • erase_group_size_mult : sd_csd_struct_type
  • err_code : sense_type
  • errie : flash_type, spi_type
  • errien : i2c_type, usart_type
  • error_code : i2c_handle_type
  • erstr : flash_type
  • esdiv : tmr_type
  • esf : tmr_type
  • esp : tmr_type
  • ests : can_type
  • ests_bit : can_type
  • etr : can_type
  • etrien : can_type
  • event_handler : usbd_class_handler
  • evoen : iomux_type
  • evten : exint_type
  • evten_bit : exint_type
  • evtenx : exint_type
  • evtien : i2c_type
  • evtout : iomux_type
  • evtout_bit : iomux_type
  • exf : usbd_type
  • exint0 : iomux_type
  • exint1 : iomux_type
  • exint10 : iomux_type
  • exint11 : iomux_type
  • exint12 : iomux_type
  • exint13 : iomux_type
  • exint14 : iomux_type
  • exint15 : iomux_type
  • exint2 : iomux_type
  • exint3 : iomux_type
  • exint4 : iomux_type
  • exint5 : iomux_type
  • exint6 : iomux_type
  • exint7 : iomux_type
  • exint8 : iomux_type
  • exint9 : iomux_type
  • exintc1 : iomux_type
  • exintc1_bit : iomux_type
  • exintc2 : iomux_type
  • exintc2_bit : iomux_type
  • exintc3 : iomux_type
  • exintc3_bit : iomux_type
  • exintc4 : iomux_type
  • exintc4_bit : iomux_type
  • exintrst : crm_type
  • ext_flash_key : usd_type
  • ext_spim_en_mux : iomux_type
  • ext_spim_gen : iomux_type
  • ext_spim_gmux : iomux_type
  • extended_id : can_rx_message_type, can_tx_message_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • fa : flash_type
  • facfg : can_type
  • facfg_bit : can_type
  • faen0 : can_type
  • faen1 : can_type
  • faen10 : can_type
  • faen11 : can_type
  • faen12 : can_type
  • faen13 : can_type
  • faen2 : can_type
  • faen3 : can_type
  • faen4 : can_type
  • faen5 : can_type
  • faen6 : can_type
  • faen7 : can_type
  • faen8 : can_type
  • faen9 : can_type
  • fap : flash_type, usd_type
  • fbn : spi_type
  • fbwcfg : can_type
  • fbwcfg_bit : can_type
  • fbwsel0 : can_type
  • fbwsel1 : can_type
  • fbwsel10 : can_type
  • fbwsel11 : can_type
  • fbwsel12 : can_type
  • fbwsel13 : can_type
  • fbwsel2 : can_type
  • fbwsel3 : can_type
  • fbwsel4 : can_type
  • fbwsel5 : can_type
  • fbwsel6 : can_type
  • fbwsel7 : can_type
  • fbwsel8 : can_type
  • fbwsel9 : can_type
  • fcs : can_type
  • fcsodis : tmr_type
  • fcsodis_state : tmr_brkdt_config_type
  • fcsoen : tmr_type
  • fcsoen_state : tmr_brkdt_config_type
  • fctrl : can_type
  • fctrl_bit : can_type
  • fda : flash_type
  • fdtf1 : dma_type
  • fdtf2 : dma_type
  • fdtf3 : dma_type
  • fdtf4 : dma_type
  • fdtf5 : dma_type
  • fdtf6 : dma_type
  • fdtf7 : dma_type
  • fdtfc1 : dma_type
  • fdtfc2 : dma_type
  • fdtfc3 : dma_type
  • fdtfc4 : dma_type
  • fdtfc5 : dma_type
  • fdtfc6 : dma_type
  • fdtfc7 : dma_type
  • fdtien : dma_channel_type
  • ferr : usart_type
  • ffb : can_type
  • ffdb1 : can_filter_register_type
  • ffdb2 : can_filter_register_type
  • fifo_length : iap_info_type
  • fifo_mailbox : can_type
  • file_formart : sd_csd_struct_type
  • file_format_group : sd_csd_struct_type
  • file_name : fat_dir_type
  • file_size : fat_dir_type
  • file_write_nr : flash_iap_type
  • filter_activate_enable : can_filter_init_type
  • filter_bit : can_filter_init_type
  • filter_fifo : can_filter_init_type
  • filter_id_high : can_filter_init_type
  • filter_id_low : can_filter_init_type
  • filter_index : can_rx_message_type
  • filter_mask_high : can_filter_init_type
  • filter_mask_low : can_filter_init_type
  • filter_mode : can_filter_init_type
  • filter_number : can_filter_init_type
  • firmware_length : flash_iap_type
  • first_bit_transmission : spi_init_type
  • flag_address : iap_info_type
  • flash_app_addr : flash_iap_type
  • flash_app_size : flash_iap_type
  • flash_base_addr : flash_iap_type
  • flash_end_address : iap_info_type
  • flash_size : flash_iap_type, iap_info_type
  • flash_start_address : iap_info_type
  • flashen : crm_type
  • fmcfg : can_type
  • fmcfg_bit : can_type
  • fmsel0 : can_type
  • fmsel1 : can_type
  • fmsel10 : can_type
  • fmsel11 : can_type
  • fmsel12 : can_type
  • fmsel13 : can_type
  • fmsel2 : can_type
  • fmsel3 : can_type
  • fmsel4 : can_type
  • fmsel5 : can_type
  • fmsel6 : can_type
  • fmsel7 : can_type
  • fmsel8 : can_type
  • fmsel9 : can_type
  • format : linecoding_type
  • fprgm : flash_type
  • fpx : exint_type
  • frame_bit_num : spi_init_type
  • frame_type : can_rx_message_type, can_tx_message_type
  • frf : can_type
  • frf_bit : can_type
  • frfsel0 : can_type
  • frfsel1 : can_type
  • frfsel10 : can_type
  • frfsel11 : can_type
  • frfsel12 : can_type
  • frfsel13 : can_type
  • frfsel2 : can_type
  • frfsel3 : can_type
  • frfsel4 : can_type
  • frfsel5 : can_type
  • frfsel6 : can_type
  • frfsel7 : can_type
  • frfsel8 : can_type
  • frfsel9 : can_type
  • fzc : can_type
  • fzen : can_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • g_audio_cur : usb_audio_hid_type, usb_audio_type
  • g_cmd : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_keyboard_tx_completed : vcp_keyboard_type
  • g_len : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_printer_data : printer_type
  • g_printer_port_status : printer_type
  • g_req : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_rx_buff : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rxhid_buff : custom_hid_type, iap_info_type, usb_audio_hid_type
  • g_rxlen : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_tx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_txhid_buff : custom_hid_type, usb_audio_hid_type
  • g_u8tx_completed : keyboard_type
  • gcaddrf : i2c_type
  • gcaen : i2c_type
  • gdiv : usart_type
  • gdiv_bit : usart_type
  • genstart : i2c_type
  • genstop : i2c_type
  • get_device_config_string : usbd_desc_handler
  • get_device_configuration : usbd_desc_handler
  • get_device_descriptor : usbd_desc_handler
  • get_device_interface_string : usbd_desc_handler
  • get_device_lang_id : usbd_desc_handler
  • get_device_manufacturer_string : usbd_desc_handler
  • get_device_other_speed : usbd_desc_handler
  • get_device_product_string : usbd_desc_handler
  • get_device_qualifier : usbd_desc_handler
  • get_device_serial_string : usbd_desc_handler
  • gf1 : dma_type
  • gf2 : dma_type
  • gf3 : dma_type
  • gf4 : dma_type
  • gf5 : dma_type
  • gf6 : dma_type
  • gf7 : dma_type
  • gfc1 : dma_type
  • gfc2 : dma_type
  • gfc3 : dma_type
  • gfc4 : dma_type
  • gfc5 : dma_type
  • gfc6 : dma_type
  • gfc7 : dma_type
  • gpio_drive_strength : gpio_init_type
  • gpio_mode : gpio_init_type
  • gpio_out_type : gpio_init_type
  • gpio_pins : gpio_init_type
  • gpio_pull : gpio_init_type
  • gpioaen : crm_type
  • gpioarst : crm_type
  • gpioben : crm_type
  • gpiobrst : crm_type
  • gpiocen : crm_type
  • gpiocrst : crm_type
  • gpioden : crm_type
  • gpiodrst : crm_type
  • gpioerst : crm_type
  • gpiofen : crm_type
  • gresume : usbd_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • h : sc_atr_type
  • hallde : tmr_type
  • hallien : tmr_type
  • hallif : tmr_type
  • hallswtr : tmr_type
  • hdtf1 : dma_type
  • hdtf2 : dma_type
  • hdtf3 : dma_type
  • hdtf4 : dma_type
  • hdtf5 : dma_type
  • hdtf6 : dma_type
  • hdtf7 : dma_type
  • hdtfc1 : dma_type
  • hdtfc2 : dma_type
  • hdtfc3 : dma_type
  • hdtfc4 : dma_type
  • hdtfc5 : dma_type
  • hdtfc6 : dma_type
  • hdtfc7 : dma_type
  • hdtien : dma_channel_type
  • head : usart_group_type
  • hextbyps : crm_type
  • hexten : crm_type
  • hextstbl : crm_type
  • hextstblf : crm_type
  • hextstblfc : crm_type
  • hextstblien : crm_type
  • hfcen : sdio_type
  • hick_to_sclk : crm_type
  • hick_to_usb : crm_type
  • hickcal : acc_type, crm_type
  • hickcal_key : crm_type
  • hickdiv : crm_type
  • hicken : crm_type
  • hickstbl : crm_type
  • hickstblf : crm_type
  • hickstblfc : crm_type
  • hickstblien : crm_type
  • hicktrim : acc_type, crm_type
  • hid_protocol : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_idle : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_report : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_state : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_suspend_flag : keyboard_type, mouse_type
  • hlength : sc_atr_type
  • hostaddrf : i2c_type
  • hour : calendar_type
  • hwcsoe : spi_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • i2c1_gmux : iomux_type
  • i2c1_mux : iomux_type
  • i2c1_smbus_timeout : debug_type
  • i2c1en : crm_type
  • i2c1rst : crm_type
  • i2c2_gmux : iomux_type
  • i2c2_smbus_timeout : debug_type
  • i2c2en : crm_type
  • i2c2rst : crm_type
  • i2cen : i2c_type
  • i2cx : i2c_handle_type
  • i2scbn : spi_type
  • i2sclk : spi_type
  • i2sclk_bit : spi_type
  • i2sclkpol : spi_type
  • i2sctrl : spi_type
  • i2sctrl_bit : spi_type
  • i2sdbn : spi_type
  • i2sdiv_h : spi_type
  • i2sdiv_l : spi_type
  • i2sen : spi_type
  • i2smclkoe : spi_type
  • i2smsel : spi_type
  • i2sodd : spi_type
  • iap_address : iap_info_type
  • iap_fifo : iap_info_type
  • iap_rx : iap_info_type
  • iap_tx : iap_info_type
  • iConfiguration : usb_configuration_desc_type
  • id : usart_type
  • id_type : can_rx_message_type, can_tx_message_type
  • idcode_bit : debug_type
  • iden : tmr_type
  • iden_bit : tmr_type
  • idlef : usart_type
  • idleien : usart_type
  • idProduct : usb_device_desc_type
  • idt : crc_type, gpio_type
  • idt0 : gpio_type
  • idt1 : gpio_type
  • idt10 : gpio_type
  • idt11 : gpio_type
  • idt12 : gpio_type
  • idt13 : gpio_type
  • idt14 : gpio_type
  • idt15 : gpio_type
  • idt2 : gpio_type
  • idt3 : gpio_type
  • idt4 : gpio_type
  • idt5 : gpio_type
  • idt6 : gpio_type
  • idt7 : gpio_type
  • idt8 : gpio_type
  • idt9 : gpio_type
  • idt_bit : crc_type, gpio_type
  • idVendor : usb_device_desc_type
  • iInterface : usb_interface_desc_type
  • iManufacturer : usb_device_desc_type
  • in_handler : usbd_class_handler
  • information : sense_type
  • init_handler : usbd_class_handler
  • inout : usb_ept_info, usbd_type
  • input_channel_select : tmr_input_config_type
  • input_filter_value : tmr_input_config_type
  • input_mapped_select : tmr_input_config_type
  • input_polarity_select : tmr_input_config_type
  • intclr : sdio_type
  • intclr_bit : sdio_type
  • inten : can_type, exint_type, sdio_type
  • inten_bit : can_type, exint_type, sdio_type
  • intenx : exint_type
  • interface : usb_audio_hid_type, usb_audio_type
  • intmap : crm_type
  • intmap_bit : crm_type
  • intsts : exint_type, usbd_type
  • intsts_bit : exint_type, usbd_type
  • intwt : sdio_type
  • iocb0 : gpio_type
  • iocb1 : gpio_type
  • iocb10 : gpio_type
  • iocb11 : gpio_type
  • iocb12 : gpio_type
  • iocb13 : gpio_type
  • iocb14 : gpio_type
  • iocb15 : gpio_type
  • iocb2 : gpio_type
  • iocb3 : gpio_type
  • iocb4 : gpio_type
  • iocb5 : gpio_type
  • iocb6 : gpio_type
  • iocb7 : gpio_type
  • iocb8 : gpio_type
  • iocb9 : gpio_type
  • ioen : sdio_type
  • iofc0 : gpio_type
  • iofc1 : gpio_type
  • iofc10 : gpio_type
  • iofc11 : gpio_type
  • iofc12 : gpio_type
  • iofc13 : gpio_type
  • iofc14 : gpio_type
  • iofc15 : gpio_type
  • iofc2 : gpio_type
  • iofc3 : gpio_type
  • iofc4 : gpio_type
  • iofc5 : gpio_type
  • iofc6 : gpio_type
  • iofc7 : gpio_type
  • iofc8 : gpio_type
  • iofc9 : gpio_type
  • ioif : sdio_type
  • ioifien : sdio_type
  • iomc0 : gpio_type
  • iomc1 : gpio_type
  • iomc10 : gpio_type
  • iomc11 : gpio_type
  • iomc12 : gpio_type
  • iomc13 : gpio_type
  • iomc14 : gpio_type
  • iomc15 : gpio_type
  • iomc2 : gpio_type
  • iomc3 : gpio_type
  • iomc4 : gpio_type
  • iomc5 : gpio_type
  • iomc6 : gpio_type
  • iomc7 : gpio_type
  • iomc8 : gpio_type
  • iomc9 : gpio_type
  • iomuxen : crm_type
  • iomuxrst : crm_type
  • iosb0 : gpio_type
  • iosb1 : gpio_type
  • iosb10 : gpio_type
  • iosb11 : gpio_type
  • iosb12 : gpio_type
  • iosb13 : gpio_type
  • iosb14 : gpio_type
  • iosb15 : gpio_type
  • iosb2 : gpio_type
  • iosb3 : gpio_type
  • iosb4 : gpio_type
  • iosb5 : gpio_type
  • iosb6 : gpio_type
  • iosb7 : gpio_type
  • iosb8 : gpio_type
  • iosb9 : gpio_type
  • iosusp : sdio_type
  • iProduct : usb_device_desc_type
  • irdaen : usart_type
  • irdalp : usart_type
  • is_double_buffer : usb_ept_info
  • isdiv : usart_type
  • iSerialNumber : usb_device_desc_type
  • ists : tmr_type
  • ists_bit : tmr_type
  • itsrven : adc_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- k -

  • keyboard_buf : keyboard_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • last_access_data : fat_dir_type
  • last_len : usb_ept_info
  • lbcp : usart_type
  • lben : can_type
  • length : usbd_desc_t
  • lextbyps : crm_type
  • lexten : crm_type
  • lextstbl : crm_type
  • lextstblf : crm_type
  • lextstblfc : crm_type
  • lextstblien : crm_type
  • licken : crm_type
  • lickstbl : crm_type
  • lickstblf : crm_type
  • lickstblfc : crm_type
  • lickstblien : crm_type
  • line_enable : exint_init_type
  • line_mode : exint_init_type
  • line_polarity : exint_init_type
  • line_select : exint_init_type
  • linecoding : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • linen : usart_type
  • linex : exint_type
  • lm : dma_channel_type
  • loen : can_type
  • loop_mode_enable : dma_init_type
  • lpm : usbd_type
  • lprstf : crm_type
  • lpsel : pwc_type
  • lsamprx : can_type
  • lsof : usbd_type
  • lsofien : usbd_type
  • lsofnum : usbd_type
  • ltf : spi_type
  • lun : cbd_extended_type, cbd_typical_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • m2m : dma_channel_type
  • mackctrl : i2c_type
  • maddr : dma_channel_type
  • maddr_bit : dma_channel_type
  • manufact_date : sd_cid_struct_type
  • manufacturer_default_ecc : sd_csd_struct_type
  • manufacturer_id : sd_cid_struct_type
  • master_slave_mode : spi_init_type
  • max_bus_clk_freq : sd_csd_struct_type
  • max_lun : cdc_msc_struct_type, msc_type
  • max_read_blk_length : sd_csd_struct_type
  • max_read_current_vdd_max : sd_csd_struct_type
  • max_read_current_vdd_min : sd_csd_struct_type
  • max_write_blk_length : sd_csd_struct_type
  • max_write_current_vdd_max : sd_csd_struct_type
  • max_write_current_vdd_min : sd_csd_struct_type
  • maxpacket : usb_ept_info
  • mclk_freq_division : spi_init_type
  • mclk_output_enable : i2s_init_type
  • mctrl : can_type
  • mctrl_bit : can_type
  • mdiv_h : spi_type
  • mdiv_l : spi_type
  • mdrsel : can_type
  • mdrsel_selection : can_base_type
  • memory_base_addr : dma_init_type
  • memory_data_width : dma_init_type
  • memory_inc_enable : dma_init_type
  • mic_adj_count : audio_codec_type
  • mic_adj_stage : audio_codec_type
  • mic_alt_setting : usb_audio_hid_type, usb_audio_type
  • mic_buffer : audio_codec_type
  • mic_calc : audio_codec_type
  • mic_delta : audio_codec_type
  • mic_enable : audio_codec_type
  • mic_freq : usb_audio_hid_type, usb_audio_type
  • mic_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_roff : audio_codec_type
  • mic_rtotal : audio_codec_type
  • mic_rx_size : audio_codec_type
  • mic_stage : audio_codec_type
  • mic_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_volume_limits : usb_audio_hid_type, usb_audio_type
  • mic_wend : audio_codec_type
  • mic_woff : audio_codec_type
  • mic_wtotal : audio_codec_type
  • min : calendar_type
  • mincm : dma_channel_type
  • misc1 : crm_type
  • misc1_bit : crm_type
  • misc2 : crm_type
  • misc2_bit : crm_type
  • misc3 : crm_type
  • misc3_bit : crm_type
  • mmerr : spi_type
  • mmssr : can_type
  • mmssr_selection : can_base_type
  • mode : i2c_handle_type
  • mode_selection : can_base_type
  • month : calendar_type
  • mouse_buffer : mouse_type
  • msc_state : cdc_msc_struct_type, msc_type
  • msc_up_status : flash_iap_type
  • mssel : adc_type
  • msten : spi_type
  • msts : can_type
  • msts_bit : can_type
  • mwidth : dma_channel_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • nerr : usart_type
  • nrstf : crm_type
  • nsac : sd_csd_struct_type
  • ntc : spi_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • oaddr1 : i2c_type
  • oaddr1_bit : i2c_type
  • oaddr2 : i2c_type
  • oaddr2_bit : i2c_type
  • obf : flash_type
  • oc_idle_state : tmr_output_config_type
  • oc_mode : tmr_output_config_type
  • oc_output_state : tmr_output_config_type
  • oc_polarity : tmr_output_config_type
  • occ_idle_state : tmr_output_config_type
  • occ_output_state : tmr_output_config_type
  • occ_polarity : tmr_output_config_type
  • occs : adc_type
  • ocdmaen : adc_type
  • oclen : adc_type
  • ocmen : tmr_type
  • ocpcnt : adc_type
  • ocpen : adc_type
  • ocswtrg : adc_type
  • octen : adc_type
  • octesel_h : adc_type
  • octesel_l : adc_type
  • ocvmen : adc_type
  • odf : flash_type
  • odfie : flash_type
  • odt : adc_type, gpio_type
  • odt0 : gpio_type
  • odt1 : gpio_type
  • odt10 : gpio_type
  • odt11 : gpio_type
  • odt12 : gpio_type
  • odt13 : gpio_type
  • odt14 : gpio_type
  • odt15 : gpio_type
  • odt2 : gpio_type
  • odt3 : gpio_type
  • odt4 : gpio_type
  • odt5 : gpio_type
  • odt6 : gpio_type
  • odt7 : gpio_type
  • odt8 : gpio_type
  • odt9 : gpio_type
  • odt_bit : adc_type, gpio_type
  • oem_app_id : sd_cid_struct_type
  • oen : tmr_type
  • old_conn_state : usbd_core_type
  • opcode : cbd_extended_type, cbd_typical_type
  • operation_mode : i2s_init_type
  • opersel : spi_type
  • oplk : flash_type
  • ora : spi_type
  • ordinary_channel_length : adc_base_config_type
  • osn1 : adc_type
  • osn10 : adc_type
  • osn11 : adc_type
  • osn12 : adc_type
  • osn13 : adc_type
  • osn14 : adc_type
  • osn15 : adc_type
  • osn16 : adc_type
  • osn2 : adc_type
  • osn3 : adc_type
  • osn4 : adc_type
  • osn5 : adc_type
  • osn6 : adc_type
  • osn7 : adc_type
  • osn8 : adc_type
  • osn9 : adc_type
  • osq1 : adc_type
  • osq1_bit : adc_type
  • osq2 : adc_type
  • osq2_bit : adc_type
  • osq3 : adc_type
  • osq3_bit : adc_type
  • ouf : i2c_type
  • out_handler : usbd_class_handler
  • outen : bpr_type
  • outm : bpr_type
  • outsel : bpr_type
  • ovfden : tmr_type
  • ovfen : tmr_type
  • ovff : rtc_type
  • ovfien : rtc_type, tmr_type
  • ovfif : tmr_type
  • ovfs : tmr_type
  • ovfswtr : tmr_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • paddr : dma_channel_type
  • paddr_bit : dma_channel_type
  • parity : linecoding_type
  • part_blk_read : sd_csd_struct_type
  • part_blk_write : sd_csd_struct_type
  • pbuff : i2c_handle_type
  • pcautoen : adc_type
  • pcce : adc_type
  • pcceien : adc_type
  • pccs : adc_type
  • pcdto1 : adc_type
  • pcdto1_bit : adc_type
  • pcdto2 : adc_type
  • pcdto2_bit : adc_type
  • pcdto3 : adc_type
  • pcdto3_bit : adc_type
  • pcdto4 : adc_type
  • pcdto4_bit : adc_type
  • pclen : adc_type
  • pcmfssel : spi_type
  • pcount : i2c_handle_type
  • pcpen : adc_type
  • pcswtrg : adc_type
  • pcten : adc_type
  • pctesel_h : adc_type
  • pctesel_l : adc_type
  • pcvmen : adc_type
  • pd01_gmux : iomux_type
  • pd01_mux : iomux_type
  • pdata : usbd_class_handler
  • pdt1 : adc_type
  • pdt1_bit : adc_type
  • pdt2 : adc_type
  • pdt2_bit : adc_type
  • pdt3 : adc_type
  • pdt3_bit : adc_type
  • pdt4 : adc_type
  • pdt4_bit : adc_type
  • pecen : i2c_type
  • pecerr : i2c_type
  • pecten : i2c_type
  • pecval : i2c_type
  • pen : usart_type
  • peripheral_base_addr : dma_init_type
  • peripheral_data_width : dma_init_type
  • peripheral_inc_enable : dma_init_type
  • permanent_write_protect : sd_csd_struct_type
  • permode : i2c_type
  • perr : usart_type
  • perrien : usart_type
  • pid : debug_type
  • pincm : dma_channel_type
  • pllen : crm_type
  • pllhextdiv : crm_type
  • pllmult_h : crm_type
  • pllmult_l : crm_type
  • pllrange : crm_type
  • pllrcs : crm_type
  • pllstbl : crm_type
  • pllstblf : crm_type
  • pllstblfc : crm_type
  • pllstblien : crm_type
  • pmen : tmr_type
  • pndwt : sdio_type
  • polcfg1 : exint_type
  • polcfg1_bit : exint_type
  • polcfg2 : exint_type
  • polcfg2_bit : exint_type
  • porrstf : crm_type
  • pr : tmr_type
  • pr_bit : tmr_type
  • prben : tmr_type
  • prgmerr : flash_type
  • priority : dma_init_type
  • product_name1 : sd_cid_struct_type
  • product_name2 : sd_cid_struct_type
  • product_reversion : sd_cid_struct_type
  • product_sn : sd_cid_struct_type
  • prsf_enable : can_base_type
  • prsfen : can_type
  • ps : sdio_type
  • psel : usart_type
  • psize : i2c_handle_type
  • psn1 : adc_type
  • psn2 : adc_type
  • psn3 : adc_type
  • psn4 : adc_type
  • psq : adc_type
  • psq_bit : adc_type
  • psr : flash_type
  • psr_bit : flash_type
  • ptd : can_type
  • ptos : tmr_type
  • pvmen : pwc_type
  • pvmof : pwc_type
  • pvmsel : pwc_type
  • pwcen : crm_type
  • pwcrst : crm_type
  • pwidth : dma_channel_type
  • pwrctrl : sdio_type
  • pwrctrl_bit : sdio_type
  • pwrsven : sdio_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- q -

  • qdzien : can_type
  • qdzif : can_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • rca : sd_card_info_struct_type
  • rcrc : spi_type
  • rcrc_bit : spi_type
  • rdbf : i2c_type, spi_type, usart_type
  • rdbfie : spi_type
  • rdbfien : usart_type
  • rdwtmode : sdio_type
  • rdwtstart : sdio_type
  • rdwtstop : sdio_type
  • read_blk_misalign : sd_csd_struct_type
  • read_crc : flash_iap_type
  • realrx : can_type
  • rec : can_type
  • rem0_len : usb_ept_info
  • remap : iomux_type
  • remap2 : iomux_type
  • remap2_bit : iomux_type
  • remap3 : iomux_type
  • remap3_bit : iomux_type
  • remap4 : iomux_type
  • remap4_bit : iomux_type
  • remap5 : iomux_type
  • remap5_bit : iomux_type
  • remap6 : iomux_type
  • remap6_bit : iomux_type
  • remap7 : iomux_type
  • remap7_bit : iomux_type
  • remap_bit : iomux_type
  • remote_wakup : usbd_core_type
  • ren : usart_type
  • repeat_mode : adc_base_config_type
  • request_no : usb_audio_hid_type, usb_audio_type
  • res : fat_dir_type
  • reserved : tmr_type, usd_type
  • reserved1 : acc_type, adc_type, bpr_type, can_fifo_mailbox_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, debug_type, dma_channel_type, dma_type, exint_type, flash_type, gpio_type, i2c_type, iomux_type, pwc_type, rtc_type, sd_cid_struct_type, sd_csd_struct_type, sd_scr_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usbd_type, wdt_type, wwdt_type
  • reserved2 : acc_type, adc_type, bpr_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, debug_type, flash_type, i2c_type, iomux_type, pwc_type, sd_cid_struct_type, sd_csd_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usbd_type
  • reserved3 : acc_type, adc_type, bpr_type, can_type, crm_type, debug_type, flash_type, i2c_type, iomux_type, sd_csd_struct_type, sense_type, usart_type
  • reserved4 : adc_type, can_type, crm_type, debug_type, flash_type, iomux_type, sd_csd_struct_type
  • reserved5 : can_type, crm_type, flash_type
  • reserved6 : can_type, crm_type, flash_type
  • reserverd2 : sd_scr_struct_type
  • reserverd3 : sd_scr_struct_type
  • reset : i2c_type
  • respond_flag : iap_info_type
  • revid : crc_type
  • revod : crc_type
  • rf0 : can_type
  • rf0_bit : can_type
  • rf0ff : can_type
  • rf0fien : can_type
  • rf0mien : can_type
  • rf0mn : can_type
  • rf0of : can_type
  • rf0oien : can_type
  • rf0r : can_type
  • rf1 : can_type
  • rf1_bit : can_type
  • rf1ff : can_type
  • rf1fien : can_type
  • rf1mien : can_type
  • rf1mn : can_type
  • rf1of : can_type
  • rf1oien : can_type
  • rf1r : can_type
  • rfc : can_fifo_mailbox_type
  • rfc_bit : can_fifo_mailbox_type
  • rfdt0 : can_fifo_mailbox_type
  • rfdt1 : can_fifo_mailbox_type
  • rfdt2 : can_fifo_mailbox_type
  • rfdt3 : can_fifo_mailbox_type
  • rfdt4 : can_fifo_mailbox_type
  • rfdt5 : can_fifo_mailbox_type
  • rfdt6 : can_fifo_mailbox_type
  • rfdt7 : can_fifo_mailbox_type
  • rfdth : can_fifo_mailbox_type
  • rfdth_bit : can_fifo_mailbox_type
  • rfdtl : can_fifo_mailbox_type
  • rfdtl_bit : can_fifo_mailbox_type
  • rfeid : can_fifo_mailbox_type
  • rffmn : can_fifo_mailbox_type
  • rffri : can_fifo_mailbox_type
  • rfi : can_fifo_mailbox_type
  • rfi_bit : can_fifo_mailbox_type
  • rfidi : can_fifo_mailbox_type
  • rfsid : can_fifo_mailbox_type
  • rfts : can_fifo_mailbox_type
  • risetime : i2c_type
  • rld : wdt_type
  • rld_bit : wdt_type
  • rldf : wdt_type, wwdt_type
  • rldien : wwdt_type
  • rm : usart_type
  • roerr : spi_type, usart_type
  • rpen : adc_type
  • rpr : tmr_type
  • rpr_bit : tmr_type
  • rpx : exint_type
  • rsaw : can_type
  • rsaw_size : can_baudrate_type
  • rslost : acc_type
  • rsp1 : sdio_type
  • rsp1_bit : sdio_type
  • rsp2 : sdio_type
  • rsp2_bit : sdio_type
  • rsp3 : sdio_type
  • rsp3_bit : sdio_type
  • rsp4 : sdio_type
  • rsp4_bit : sdio_type
  • rsp_type : sdio_command_struct_type
  • rspcmd : sdio_type
  • rspcmd_bit : sdio_type
  • rspwt : sdio_type
  • rst : crc_type, usbd_type
  • rstfc : crm_type
  • rstien : usbd_type
  • rtccal : bpr_type
  • rtccal_bit : bpr_type
  • rtcen : crm_type
  • rtcsel : crm_type
  • rtsen : usart_type
  • rx_addr : usb_ept_info
  • rxbuf : sdio_type
  • rxbufe : sdio_type
  • rxbufeien : sdio_type
  • rxbuff : sdio_type
  • rxbuffien : sdio_type
  • rxbufh : sdio_type
  • rxbufhien : sdio_type
  • rxbufien : sdio_type
  • rxdts : usbd_type
  • rxerro : sdio_type
  • rxerroien : sdio_type
  • rxsts : usbd_type
  • rxtc : usbd_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • sbf : usart_type
  • sbiterr : sdio_type
  • sbiterrien : sdio_type
  • scgt : usart_type
  • sclk_freq : crm_clocks_freq_type
  • sclksel : crm_type
  • sclksts : crm_type
  • scmen : usart_type
  • scnacken : usart_type
  • scr : gpio_type
  • scr_bit : gpio_type
  • scr_structure : sd_scr_struct_type
  • sd_bus_width : sd_scr_struct_type
  • sd_cid_reg : sd_card_info_struct_type
  • sd_csd_reg : sd_card_info_struct_type
  • sd_scr_reg : sd_card_info_struct_type
  • sd_security : sd_scr_struct_type
  • sd_spec : sd_scr_struct_type
  • sd_spec3 : sd_scr_struct_type
  • sdio1_gmux : iomux_type
  • sdio1en : crm_type
  • sec : calendar_type
  • secers : flash_type
  • sector_mask : flash_iap_type
  • sector_size : flash_iap_type, iap_info_type
  • sef : pwc_type
  • select : flash_type
  • select_bit : flash_type
  • selpin : iomux_type
  • selport : iomux_type
  • sense_key : sense_type
  • sequence_mode : adc_base_config_type
  • setup : usbd_core_type
  • setup_buffer : usbd_core_type
  • setup_handler : usbd_class_handler
  • setuptc : usbd_type
  • slben : spi_type, usart_type
  • slbtd : spi_type
  • sleep_debug : debug_type
  • slib_dat_ss : flash_type
  • slib_dss_set : flash_type
  • slib_enf : flash_type
  • slib_es : flash_type
  • slib_es_set : flash_type
  • slib_misc_sts : flash_type
  • slib_misc_sts_bit : flash_type
  • slib_pclr_val : flash_type
  • slib_pset_val : flash_type
  • slib_pwd_clr : flash_type
  • slib_pwd_clr_bit : flash_type
  • slib_pwd_err : flash_type
  • slib_pwd_ok : flash_type
  • slib_rcnt : flash_type
  • slib_set_pwd : flash_type
  • slib_set_pwd_bit : flash_type
  • slib_set_range : flash_type
  • slib_set_range_bit : flash_type
  • slib_ss : flash_type
  • slib_ss_set : flash_type
  • slib_sts0 : flash_type
  • slib_sts0_bit : flash_type
  • slib_sts1 : flash_type
  • slib_sts1_bit : flash_type
  • slib_ukval : flash_type
  • slib_ulkf : flash_type
  • slib_unlock : flash_type
  • slib_unlock_bit : flash_type
  • smbalert : i2c_type
  • smbmode : i2c_type
  • smsel : tmr_type
  • sof : usbd_type
  • sof_handler : usbd_class_handler
  • sofien : usbd_type
  • sofnum : usbd_type
  • sofouten : usbd_type
  • sofrnum : usbd_type
  • sofrnum_bit : usbd_type
  • sp : usbd_type
  • spec_version : sd_csd_struct_type
  • speed : i2c_type, usbd_core_type
  • speedmode : i2c_type
  • spi1_gmux : iomux_type
  • spi1_mux_h : iomux_type
  • spi1_mux_l : iomux_type
  • spi1en : crm_type
  • spi1rst : crm_type
  • spi2_gmux : iomux_type
  • spi2en : crm_type
  • spi2rst : crm_type
  • spien : spi_type, usbd_type
  • spk_alt_setting : usb_audio_hid_type, usb_audio_type
  • spk_buffer : audio_codec_type
  • spk_calc : audio_codec_type
  • spk_enable : audio_codec_type
  • spk_freq : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_rend : audio_codec_type
  • spk_roff : audio_codec_type
  • spk_rtotal : audio_codec_type
  • spk_stage : audio_codec_type
  • spk_threshold : audio_codec_type
  • spk_tx_size : audio_codec_type
  • spk_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_volume_limits : usb_audio_hid_type, usb_audio_type
  • spk_woff : audio_codec_type
  • spk_wtotal : audio_codec_type
  • sprst : can_type
  • spt1 : adc_type
  • spt1_bit : adc_type
  • spt2 : adc_type
  • spt2_bit : adc_type
  • sqen : adc_type
  • sramen : crm_type
  • src_sel0 : dma_type
  • src_sel0_bit : dma_type
  • src_sel1 : dma_type
  • src_sel1_bit : dma_type
  • ssb : usd_type
  • ssp : usbd_type
  • stall : usb_ept_info
  • standard_id : can_rx_message_type, can_tx_message_type
  • standby_debug : debug_type
  • startf : i2c_type
  • state : iap_info_type
  • status : i2c_handle_type, usb_ept_info
  • stctrl : tmr_type
  • stctrl_bit : tmr_type
  • stdby_rst : flash_type
  • stdsel : spi_type
  • step : acc_type
  • stis : tmr_type
  • stopbn : usart_type
  • stopf : i2c_type
  • stretch : i2c_type
  • sts : acc_type, adc_type, dma_type, flash_type, sdio_type, spi_type, tmr_type, usart_type, wdt_type, wwdt_type
  • sts1 : i2c_type
  • sts1_bit : i2c_type
  • sts2 : i2c_type
  • sts2_bit : i2c_type
  • sts3 : flash_type
  • sts3_bit : flash_type
  • sts_bit : acc_type, adc_type, dma_type, flash_type, sdio_type, spi_type, usart_type, wdt_type, wwdt_type
  • swcsen : spi_type
  • swcsil : spi_type
  • swef : pwc_type
  • swevt : tmr_type
  • swevt_bit : tmr_type
  • swjtag_conf : iomux_type
  • swjtag_gmux : iomux_type
  • swpen : pwc_type
  • swrstf : crm_type
  • swtrg : exint_type
  • swtrg_bit : exint_type
  • swtx : exint_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • t : sc_atr_type
  • t0 : sc_atr_type
  • ta : rtc_type
  • taac : sd_csd_struct_type
  • taf : rtc_type
  • tah : rtc_type
  • tah_bit : rtc_type
  • taien : rtc_type
  • tail : usart_group_type
  • tal : rtc_type
  • tal_bit : rtc_type
  • tc : usbd_type
  • tcien : can_type, usbd_type
  • tcrc : spi_type
  • tcrc_bit : spi_type
  • tdbe : i2c_type, spi_type, usart_type
  • tdbeie : spi_type
  • tdbeien : usart_type
  • tdc : i2c_type, usart_type
  • tdcien : usart_type
  • tden : tmr_type
  • tec : can_type
  • temp : keyboard_type
  • temp_write_protect : sd_csd_struct_type
  • ten : usart_type
  • tfrdir : sdio_type
  • tfren : sdio_type
  • tfrmode : sdio_type
  • tien : tmr_type
  • timeout : i2c_handle_type, sdio_data_struct_type, sdio_type
  • tlength : sc_atr_type
  • tm0alf : can_type
  • tm0ct : can_type
  • tm0ef : can_type
  • tm0lpf : can_type
  • tm0tcf : can_type
  • tm0tef : can_type
  • tm0tsf : can_type
  • tm1alf : can_type
  • tm1ct : can_type
  • tm1ef : can_type
  • tm1lpf : can_type
  • tm1tcf : can_type
  • tm1tef : can_type
  • tm1tsf : can_type
  • tm2alf : can_type
  • tm2ct : can_type
  • tm2ef : can_type
  • tm2lpf : can_type
  • tm2tcf : can_type
  • tm2tef : can_type
  • tm2tsf : can_type
  • tmc : can_tx_mailbox_type
  • tmc_bit : can_tx_mailbox_type
  • tmdt0 : can_tx_mailbox_type
  • tmdt1 : can_tx_mailbox_type
  • tmdt2 : can_tx_mailbox_type
  • tmdt3 : can_tx_mailbox_type
  • tmdt4 : can_tx_mailbox_type
  • tmdt5 : can_tx_mailbox_type
  • tmdt6 : can_tx_mailbox_type
  • tmdt7 : can_tx_mailbox_type
  • tmdtbl : can_tx_mailbox_type
  • tmdth : can_tx_mailbox_type
  • tmdth_bit : can_tx_mailbox_type
  • tmdtl : can_tx_mailbox_type
  • tmdtl_bit : can_tx_mailbox_type
  • tmeid : can_tx_mailbox_type
  • tmfrsel : can_tx_mailbox_type
  • tmi : can_tx_mailbox_type
  • tmi_bit : can_tx_mailbox_type
  • tmidsel : can_tx_mailbox_type
  • tmnr : can_type
  • tmout : i2c_type
  • tmr10_gmux : iomux_type
  • tmr10_pause : debug_type
  • tmr10en : crm_type
  • tmr10rst : crm_type
  • tmr11_gmux : iomux_type
  • tmr11_pause : debug_type
  • tmr11en : crm_type
  • tmr11rst : crm_type
  • tmr1_gmux : iomux_type
  • tmr1_mux : iomux_type
  • tmr1_pause : debug_type
  • tmr1en : crm_type
  • tmr1rst : crm_type
  • tmr2_gmux : iomux_type
  • tmr2_mux : iomux_type
  • tmr2_pause : debug_type
  • tmr2en : crm_type
  • tmr2itr1_gmux : iomux_type
  • tmr2rst : crm_type
  • tmr3_gmux : iomux_type
  • tmr3_mux : iomux_type
  • tmr3_pause : debug_type
  • tmr3en : crm_type
  • tmr3rst : crm_type
  • tmr4_pause : debug_type
  • tmr4en : crm_type
  • tmr4rst : crm_type
  • tmr5_gmux : iomux_type
  • tmr5_pause : debug_type
  • tmr5ch4_gmux : iomux_type
  • tmr5ch4_mux : iomux_type
  • tmr5en : crm_type
  • tmr5rst : crm_type
  • tmr8_pause : debug_type
  • tmr8en : crm_type
  • tmr8rst : crm_type
  • tmr9_gmux : iomux_type
  • tmr9_pause : debug_type
  • tmr9en : crm_type
  • tmr9rst : crm_type
  • tmren : tmr_type
  • tmrise : i2c_type
  • tmrise_bit : i2c_type
  • tmsid : can_tx_mailbox_type
  • tmsr : can_tx_mailbox_type
  • tmts : can_tx_mailbox_type
  • tmtsten : can_tx_mailbox_type
  • total_len : usb_ept_info
  • tpef : bpr_type
  • tpefclr : bpr_type
  • tpen : bpr_type
  • tpien : bpr_type
  • tpif : bpr_type
  • tpifclr : bpr_type
  • tpp : bpr_type
  • trace_ioen : debug_type
  • trace_mode : debug_type
  • trans_buf : usb_ept_info
  • trans_len : usb_ept_info
  • trans_type : usb_ept_info, usbd_type
  • transfer_direction : sdio_data_struct_type
  • transfer_mode : sdio_data_struct_type
  • transmission_mode : spi_init_type
  • trgif : tmr_type
  • trgswtr : tmr_type
  • trmode : i2c_type
  • ts : sc_atr_type
  • tsf : rtc_type
  • tsien : rtc_type
  • tsts : can_type
  • tsts_bit : can_type
  • ttc_enable : can_base_type
  • ttcen : can_type
  • tuerr : spi_type
  • tx_addr : usb_ept_info
  • tx_length : iap_info_type
  • tx_mailbox : can_type
  • txbuf : sdio_type
  • txbufe : sdio_type
  • txbufeien : sdio_type
  • txbuff : sdio_type
  • txbuffien : sdio_type
  • txbufh : sdio_type
  • txbufhien : sdio_type
  • txbufien : sdio_type
  • txdts : usbd_type
  • txerru : sdio_type
  • txerruien : sdio_type
  • txsts : usbd_type
  • txtc : usbd_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • uart4_gmux : iomux_type
  • uart4en : crm_type
  • uart4rst : crm_type
  • uart5en : crm_type
  • uart5rst : crm_type
  • ucfor : usbd_type
  • ucforien : usbd_type
  • uen : usart_type
  • ukval : flash_type
  • unlock : flash_type
  • unlock3 : flash_type
  • unlock3_bit : flash_type
  • unlock_bit : flash_type
  • updf : rtc_type
  • usart1_gmux : iomux_type
  • usart1_mux : iomux_type
  • usart1en : crm_type
  • usart1rst : crm_type
  • usart2en : crm_type
  • usart2rst : crm_type
  • usart3_gmux : iomux_type
  • usart3_mux : iomux_type
  • usart3en : crm_type
  • usart3rst : crm_type
  • usb_reg : usbd_core_type
  • usbbufs : crm_type
  • usbdiv_h : crm_type
  • usbdiv_l : crm_type
  • usben : crm_type
  • usbintmap : crm_type
  • usbrst : crm_type
  • usd : flash_type
  • usd_bit : flash_type
  • usd_ukval : flash_type
  • usd_unlock : flash_type
  • usd_unlock_bit : flash_type
  • usderr : flash_type
  • usders : flash_type
  • usdprgm : flash_type
  • usdulks : flash_type
  • user_d0 : flash_type
  • user_d1 : flash_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • vmcsel : adc_type
  • vmhb : adc_type
  • vmhb_bit : adc_type
  • vmlb : adc_type
  • vmlb_bit : adc_type
  • vmor : adc_type
  • vmorien : adc_type
  • vmsgen : adc_type
  • vrsel : pwc_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • wait_type : sdio_command_struct_type
  • wdt_ato_en : flash_type
  • wdt_pause : debug_type
  • wdtrstf : crm_type
  • week : calendar_type
  • win : wwdt_type
  • wIndex : usb_setup_type
  • wk : usbd_type
  • wkien : usbd_type
  • wLength : usb_setup_type
  • wMaxPacketSize : usb_endpoint_desc_type
  • wp_level : tmr_brkdt_config_type
  • wpc : tmr_type
  • wpen0 : gpio_type
  • wpen1 : gpio_type
  • wpen10 : gpio_type
  • wpen11 : gpio_type
  • wpen12 : gpio_type
  • wpen13 : gpio_type
  • wpen14 : gpio_type
  • wpen15 : gpio_type
  • wpen2 : gpio_type
  • wpen3 : gpio_type
  • wpen4 : gpio_type
  • wpen5 : gpio_type
  • wpen6 : gpio_type
  • wpen7 : gpio_type
  • wpen8 : gpio_type
  • wpen9 : gpio_type
  • wpr : gpio_type
  • wpr_bit : gpio_type
  • wpseq : gpio_type
  • write_addr : flash_iap_type
  • write_blk_misalign : sd_csd_struct_type
  • write_crc : flash_iap_type
  • write_data : fat_dir_type
  • write_protect_group_enable : sd_csd_struct_type
  • write_protect_group_size : sd_csd_struct_type
  • write_speed_factor : sd_csd_struct_type
  • write_time : fat_dir_type
  • wTotalLength : usb_configuration_desc_type
  • wum : usart_type
  • wValue : usb_setup_type
  • wwdt_pause : debug_type
  • wwdten : crm_type, wwdt_type
  • wwdtrst : crm_type
  • wwdtrstf : crm_type


AT32F413 Firmwary Library: Data Fields

Here is a list of all struct and union fields with links to the structures/unions they belong to:

- y -

  • year : calendar_type


AT32F413 Firmwary Library: Data Fields - Variables

- a -

  • accen : crm_type
  • accrst : crm_type
  • acken : i2c_type
  • ackfail : i2c_type
  • acs : spi_type
  • adc1_eto_gmux : iomux_type
  • adc1_etp_gmux : iomux_type
  • adc1_extrgord_mux : iomux_type
  • adc1_extrgpre_mux : iomux_type
  • adc1en : crm_type
  • adc1rst : crm_type
  • adc2_eto_gmux : iomux_type
  • adc2_etp_gmux : iomux_type
  • adc2_extrgord_mux : iomux_type
  • adc2_extrgpre_mux : iomux_type
  • adc2en : crm_type
  • adc2odt : adc_type
  • adc2rst : crm_type
  • adc_freq : crm_clocks_freq_type
  • adcal : adc_type
  • adcalinit : adc_type
  • adcdiv_h : crm_type
  • adcdiv_l : crm_type
  • adcen : adc_type
  • addr : flash_type, tmr_type, usbd_type
  • addr1 : i2c_type
  • addr1mode : i2c_type
  • addr2 : i2c_type
  • addr2en : i2c_type
  • addr3 : flash_type
  • addr3_bit : flash_type
  • addr7f : i2c_type
  • addr_bit : flash_type
  • address : cbd_extended_type, cbd_typical_type
  • addrhf : i2c_type
  • aebo_enable : can_base_type
  • aeboen : can_type
  • aed_enable : can_base_type
  • aeden : can_type
  • ahb_freq : crm_clocks_freq_type
  • ahbdiv : crm_type
  • ahben : crm_type
  • ahben_bit : crm_type
  • alertf : i2c_type
  • alloc_length : cbd_extended_type, cbd_typical_type
  • alt_setting : cdc_msc_struct_type, cdc_struct_type, custom_hid_type, iap_info_type, keyboard_type, mouse_type, msc_type, printer_type, usb_audio_hid_type, vcp_keyboard_type
  • aoen : tmr_type
  • apb1_freq : crm_clocks_freq_type
  • apb1div : crm_type
  • apb1en : crm_type
  • apb1en_bit : crm_type
  • apb1rst : crm_type
  • apb1rst_bit : crm_type
  • apb2_freq : crm_clocks_freq_type
  • apb2div : crm_type
  • apb2en : crm_type
  • apb2en_bit : crm_type
  • apb2rst : crm_type
  • apb2rst_bit : crm_type
  • app_address : iap_info_type
  • argu : sdio_type
  • argu_bit : sdio_type
  • argument : sdio_command_struct_type
  • arlost : i2c_type
  • arpen : i2c_type
  • as_length : sense_type
  • asc : sense_type
  • ascq : sense_type
  • attr : fat_dir_type
  • audio_bitw : audio_codec_type
  • audio_cmd : usb_audio_hid_type, usb_audio_type
  • audio_cmd_len : usb_audio_hid_type, usb_audio_type
  • audio_feed_back : usb_audio_hid_type, usb_audio_type
  • audio_freq : audio_codec_type
  • audio_mic_data : usb_audio_hid_type, usb_audio_type
  • audio_protocol : i2s_init_type
  • audio_sampling_freq : i2s_init_type
  • audio_spk_data : usb_audio_hid_type, usb_audio_type
  • auto_output_enable : tmr_brkdt_config_type
  • auto_step_en : crm_type


AT32F413 Firmwary Library: Data Fields - Variables

- b -

  • bAlternateSetting : usb_interface_desc_type
  • bankers : flash_type
  • baudr : usart_type
  • baudr_bit : usart_type
  • baudrate_div : can_baudrate_type
  • bCBWCBLength : cbw_type
  • bCBWLUN : cbw_type
  • bcdDevice : usb_device_desc_type
  • bcdUSB : usb_device_desc_type
  • bConfigurationValue : usb_configuration_desc_type
  • bCSWStatus : csw_type
  • bDescriptorType : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_interface_desc_type
  • bDeviceClass : usb_device_desc_type
  • bDeviceProtocol : usb_device_desc_type
  • bDeviceSubClass : usb_device_desc_type
  • be : usbd_type
  • beien : usbd_type
  • bEndpointAddress : usb_endpoint_desc_type
  • bf : spi_type
  • bfbn : usart_type
  • bff : usart_type
  • bfien : usart_type
  • bInterfaceClass : usb_interface_desc_type
  • bInterfaceNumber : usb_interface_desc_type
  • bInterfaceProtocol : usb_interface_desc_type
  • bInterfaceSubClass : usb_interface_desc_type
  • bInterval : usb_endpoint_desc_type
  • bitrate : linecoding_type
  • bLength : usb_configuration_desc_type, usb_device_desc_type, usb_endpoint_desc_type, usb_header_desc_type, usb_interface_desc_type
  • blk_addr : cdc_msc_struct_type, msc_type
  • blk_len : cdc_msc_struct_type, msc_type
  • blk_nbr : cdc_msc_struct_type, msc_type
  • blk_size : cdc_msc_struct_type, msc_type
  • blksize : sdio_type
  • block_size : sdio_data_struct_type
  • bmAttributes : usb_configuration_desc_type, usb_endpoint_desc_type
  • bMaxPacketSize0 : usb_device_desc_type
  • bMaxPower : usb_configuration_desc_type
  • bmCBWFlags : cbw_type
  • bmRequestType : usb_setup_type
  • bNumConfigurations : usb_device_desc_type
  • bNumEndpoints : usb_interface_desc_type
  • bNumInterfaces : usb_configuration_desc_type
  • bof : can_type
  • boien : can_type
  • bot_status : cdc_msc_struct_type, msc_type
  • bpdc : crm_type
  • bpdc_bit : crm_type
  • bpdrst : crm_type
  • bpren : crm_type
  • bprrst : crm_type
  • bpwen : pwc_type
  • brdiv : can_type
  • bRequest : usb_setup_type
  • brk : tmr_type
  • brk_bit : tmr_type
  • brk_enable : tmr_brkdt_config_type
  • brk_polarity : tmr_brkdt_config_type
  • brken : tmr_type
  • brkie : tmr_type
  • brkif : tmr_type
  • brkswtr : tmr_type
  • brkv : tmr_type
  • btaddr : usbd_type
  • btmg : can_type
  • btmg_bit : can_type
  • bts1 : can_type
  • bts1_size : can_baudrate_type
  • bts2 : can_type
  • bts2_size : can_baudrate_type
  • buf : sdio_type, usart_group_type
  • buf_bit : sdio_type
  • bufcnt : sdio_type
  • bufcnt_bit : sdio_type
  • buffer_size : dma_init_type
  • buftbl : usbd_type
  • buftbl_bit : usbd_type
  • buserr : i2c_type
  • busws : sdio_type
  • busyf : i2c_type
  • bypsen : sdio_type


AT32F413 Firmwary Library: Data Fields - Variables

- c -

  • c1 : acc_type
  • c1_bit : acc_type
  • c1c : tmr_type
  • c1cen : tmr_type
  • c1cios : tmr_type
  • c1cp : tmr_type
  • c1den : tmr_type
  • c1df : tmr_type
  • c1dt : tmr_type
  • c1dt_bit : tmr_type
  • c1en : tmr_type
  • c1idiv : tmr_type
  • c1ien : tmr_type
  • c1if : tmr_type
  • c1insel : tmr_type
  • c1ios : tmr_type
  • c1oben : tmr_type
  • c1octrl : tmr_type
  • c1oien : tmr_type
  • c1osen : tmr_type
  • c1p : tmr_type
  • c1rf : tmr_type
  • c1swtr : tmr_type
  • c2 : acc_type
  • c2_bit : acc_type
  • c2c : tmr_type
  • c2cen : tmr_type
  • c2cios : tmr_type
  • c2cp : tmr_type
  • c2den : tmr_type
  • c2df : tmr_type
  • c2dt : tmr_type
  • c2dt_bit : tmr_type
  • c2en : tmr_type
  • c2idiv : tmr_type
  • c2ien : tmr_type
  • c2if : tmr_type
  • c2ios : tmr_type
  • c2oben : tmr_type
  • c2octrl : tmr_type
  • c2oien : tmr_type
  • c2osen : tmr_type
  • c2p : tmr_type
  • c2rf : tmr_type
  • c2swtr : tmr_type
  • c3 : acc_type
  • c3_bit : acc_type
  • c3c : tmr_type
  • c3cen : tmr_type
  • c3cios : tmr_type
  • c3cp : tmr_type
  • c3den : tmr_type
  • c3df : tmr_type
  • c3dt : tmr_type
  • c3dt_bit : tmr_type
  • c3en : tmr_type
  • c3idiv : tmr_type
  • c3ien : tmr_type
  • c3if : tmr_type
  • c3ios : tmr_type
  • c3oben : tmr_type
  • c3octrl : tmr_type
  • c3oien : tmr_type
  • c3osen : tmr_type
  • c3p : tmr_type
  • c3rf : tmr_type
  • c3swtr : tmr_type
  • c4c : tmr_type
  • c4den : tmr_type
  • c4df : tmr_type
  • c4dt : tmr_type
  • c4dt_bit : tmr_type
  • c4en : tmr_type
  • c4idiv : tmr_type
  • c4ien : tmr_type
  • c4if : tmr_type
  • c4ios : tmr_type
  • c4oben : tmr_type
  • c4octrl : tmr_type
  • c4oien : tmr_type
  • c4osen : tmr_type
  • c4p : tmr_type
  • c4rf : tmr_type
  • c4swtr : tmr_type
  • calon : acc_type
  • calout : bpr_type
  • calrdy : acc_type
  • calrdyien : acc_type
  • calval : bpr_type
  • can1_gmux : iomux_type
  • can1_pause : debug_type
  • can1en : crm_type
  • can1rst : crm_type
  • can2_gmux : iomux_type
  • can2_pause : debug_type
  • can2en : crm_type
  • can2rst : crm_type
  • can_mux : iomux_type
  • card_blk_size : sd_card_info_struct_type
  • card_capacity : sd_card_info_struct_type
  • card_cmd_classes : sd_csd_struct_type
  • card_type : sd_card_info_struct_type
  • cardsts1 : sdio_type
  • cardsts2 : sdio_type
  • cardsts3 : sdio_type
  • cardsts4 : sdio_type
  • cbctrl : tmr_type
  • cbw_struct : cdc_msc_struct_type, msc_type
  • CBWCB : cbw_type
  • cce : adc_type
  • cceien : adc_type
  • ccen : spi_type
  • ccerr : spi_type
  • ccfs : tmr_type
  • ccos : bpr_type
  • ccsmen : sdio_type
  • cctrl : tmr_type
  • cctrl_bit : tmr_type
  • cdt : crc_type
  • cdt_bit : crc_type
  • cen : usbd_type
  • cfden : crm_type
  • cfdf : crm_type
  • cfdfc : crm_type
  • cfg : crm_type, usbd_type, wwdt_type
  • cfg_bit : crm_type, usbd_type, wwdt_type
  • cfgen : rtc_type
  • cfgf : rtc_type
  • cfghr : gpio_type
  • cfghr_bit : gpio_type
  • cfglr : gpio_type
  • cfglr_bit : gpio_type
  • ch1_src : dma_type
  • ch2_src : dma_type
  • ch3_src : dma_type
  • ch4_src : dma_type
  • ch5_src : dma_type
  • ch6_src : dma_type
  • ch7_src : dma_type
  • chen : dma_channel_type
  • chpers : flash_type
  • chpl : dma_channel_type
  • cid_crc : sd_cid_struct_type
  • class_handler : usbd_core_type
  • clck : usbd_type
  • clear_handler : usbd_class_handler
  • clk_to_tmr : crm_type
  • clkctrl : i2c_type, sdio_type
  • clkctrl_bit : i2c_type, sdio_type
  • clkdiv : tmr_type
  • clkdiv_h : sdio_type
  • clkdiv_l : sdio_type
  • clkegs : sdio_type
  • clken : usart_type
  • clkfreq : i2c_type
  • clkint : crm_type
  • clkint_bit : crm_type
  • clkoen : sdio_type
  • clkout_sel : crm_type
  • clkoutdiv : crm_type
  • clkpha : spi_type, usart_type
  • clkpol : spi_type, usart_type
  • clock_phase : spi_init_type
  • clock_polarity : i2s_init_type, spi_init_type
  • clr : dma_type, gpio_type
  • clr_bit : dma_type, gpio_type
  • clsef : pwc_type
  • clswef : pwc_type
  • clus_high : fat_dir_type
  • clus_low : fat_dir_type
  • cm1 : tmr_type
  • cm1_input_bit : tmr_type
  • cm1_output_bit : tmr_type
  • cm2 : tmr_type
  • cm2_input_bit : tmr_type
  • cm2_output_bit : tmr_type
  • cmd : wdt_type
  • cmd20_support : sd_scr_struct_type
  • cmd23_support : sd_scr_struct_type
  • cmd_addr : cmd_data_group_type
  • cmd_bit : wdt_type
  • cmd_buf : cmd_data_group_type
  • cmd_check : cmd_data_group_type
  • cmd_head : cmd_data_group_type
  • cmd_index : sdio_command_struct_type
  • cmdcmpl : sdio_type
  • cmdcmplien : sdio_type
  • cmdctrl : sdio_type
  • cmdctrl_bit : sdio_type
  • cmdfail : sdio_type
  • cmdfailien : sdio_type
  • cmdidx : sdio_type
  • cmdrspcmpl : sdio_type
  • cmdrspcmplien : sdio_type
  • cmdtimeout : sdio_type
  • cmdtimeoutien : sdio_type
  • cnt : dma_channel_type, rtc_type, sdio_type, wwdt_type
  • cnt_dir : tmr_type
  • cnth : rtc_type
  • cnth_bit : rtc_type
  • cntl : rtc_type
  • cntl_bit : rtc_type
  • config_status : usbd_core_type
  • conn_state : usbd_core_type
  • content_protect_app : sd_csd_struct_type
  • copy_flag : sd_csd_struct_type
  • count : usart_group_type
  • cpoly : spi_type
  • cpoly_bit : spi_type
  • crc_chkr : flash_type
  • crc_chkr_bit : flash_type
  • crc_ctrl : flash_type
  • crc_ctrl_bit : flash_type
  • crc_sn : flash_type
  • crc_ss : flash_type
  • crc_strt : flash_type
  • crcen : crm_type
  • create_data : fat_dir_type
  • create_time : fat_dir_type
  • create_time_tenth : fat_dir_type
  • cs_mode_selection : spi_init_type
  • csd_crc : sd_csd_struct_type
  • csd_struct : sd_csd_struct_type
  • cspt0 : adc_type
  • cspt1 : adc_type
  • cspt10 : adc_type
  • cspt11 : adc_type
  • cspt12 : adc_type
  • cspt13 : adc_type
  • cspt14 : adc_type
  • cspt15 : adc_type
  • cspt16 : adc_type
  • cspt17 : adc_type
  • cspt2 : adc_type
  • cspt3 : adc_type
  • cspt4 : adc_type
  • cspt5 : adc_type
  • cspt6 : adc_type
  • cspt7 : adc_type
  • cspt8 : adc_type
  • cspt9 : adc_type
  • csrst : usbd_type
  • csw_struct : cdc_msc_struct_type, msc_type
  • ctrl : bpr_type, crc_type, crm_type, debug_type, dma_channel_type, flash_type, pwc_type, usbd_type, wwdt_type
  • ctrl1 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl1_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2 : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl2_bit : acc_type, adc_type, i2c_type, spi_type, tmr_type, usart_type
  • ctrl3 : flash_type, usart_type
  • ctrl3_bit : flash_type, usart_type
  • ctrl_bit : bpr_type, crc_type, crm_type, debug_type, dma_channel_type, flash_type, pwc_type, usbd_type, wwdt_type
  • ctrlh : rtc_type
  • ctrlh_bit : rtc_type
  • ctrll : rtc_type
  • ctrll_bit : rtc_type
  • ctrlsts : bpr_type, crm_type, pwc_type
  • ctrlsts_bit : bpr_type, crm_type, pwc_type
  • ctscf : usart_type
  • ctscfien : usart_type
  • ctsen : usart_type
  • curs : can_type
  • cuss : can_type
  • cval : tmr_type
  • cval_bit : tmr_type


AT32F413 Firmwary Library: Data Fields - Variables

- d -

  • da : flash_type
  • da_bit : flash_type
  • data : can_rx_message_type, can_tx_message_type, cdc_msc_struct_type, linecoding_type, msc_type
  • data0 : usd_type
  • data1 : usd_type
  • data2 : usd_type
  • data3 : usd_type
  • data4 : usd_type
  • data5 : usd_type
  • data6 : usd_type
  • data7 : usd_type
  • data_align : adc_base_config_type
  • data_channel_format : i2s_init_type
  • data_len : cdc_msc_struct_type, msc_type
  • data_length : sdio_data_struct_type
  • data_stat_after_erase : sd_scr_struct_type
  • dataien : i2c_type
  • date : calendar_type
  • dbn : usart_type
  • dCBWDataTransferLength : cbw_type
  • dCBWSignature : cbw_type
  • dCBWTage : cbw_type
  • dCSWDataResidue : csw_type
  • dCSWSignature : csw_type
  • dCSWTag : csw_type
  • deadtime : tmr_brkdt_config_type
  • deepsleep_debug : debug_type
  • default_config : usbd_core_type
  • depslp_rst : flash_type
  • desc_handler : usbd_core_type
  • descriptor : usbd_desc_t
  • dev_config : usbd_core_type
  • devaddr : usbd_type
  • devaddr_bit : usbd_type
  • devaddrf : i2c_type
  • device_addr : usbd_core_type
  • device_size : sd_csd_struct_type
  • device_size_mult : sd_csd_struct_type
  • direction : dma_init_type
  • dirf : i2c_type
  • disusb : usbd_type
  • div : rtc_type, tmr_type, usart_type, wdt_type, wwdt_type
  • div_bit : tmr_type, wdt_type
  • divcnt : rtc_type
  • divcnth : rtc_type
  • divcnth_bit : rtc_type
  • divcntl : rtc_type
  • divcntl_bit : rtc_type
  • divf : wdt_type
  • divh : rtc_type
  • divh_bit : rtc_type
  • divl : rtc_type
  • divl_bit : rtc_type
  • dlc : can_rx_message_type, can_tx_message_type
  • dma1en : crm_type
  • dma2en : crm_type
  • dma_flex_en : dma_type
  • dma_init_struct : i2c_handle_type
  • dma_rx_channel : i2c_handle_type
  • dma_tx_channel : i2c_handle_type
  • dmactrl : tmr_type
  • dmactrl_bit : tmr_type
  • dmadt : tmr_type
  • dmadt_bit : tmr_type
  • dmaen : i2c_type, sdio_type
  • dmaend : i2c_type
  • dmaren : spi_type, usart_type
  • dmaten : spi_type, usart_type
  • dmsts : usbd_type
  • docmd : sdio_type
  • docmdien : sdio_type
  • dorx : sdio_type
  • dorxien : sdio_type
  • dotx : sdio_type
  • dotxien : sdio_type
  • dpsts : usbd_type
  • drs : tmr_type
  • dsr_implemented : sd_csd_struct_type
  • dt : bpr_type, crc_type, i2c_type, sdio_type, spi_type, usart_type
  • dt1 : bpr_type
  • dt10 : bpr_type
  • dt10_bit : bpr_type
  • dt11 : bpr_type
  • dt11_bit : bpr_type
  • dt12 : bpr_type
  • dt12_bit : bpr_type
  • dt13 : bpr_type
  • dt13_bit : bpr_type
  • dt14 : bpr_type
  • dt14_bit : bpr_type
  • dt15 : bpr_type
  • dt15_bit : bpr_type
  • dt16 : bpr_type
  • dt16_bit : bpr_type
  • dt17 : bpr_type
  • dt17_bit : bpr_type
  • dt18 : bpr_type
  • dt18_bit : bpr_type
  • dt19 : bpr_type
  • dt19_bit : bpr_type
  • dt1_bit : bpr_type
  • dt2 : bpr_type
  • dt20 : bpr_type
  • dt20_bit : bpr_type
  • dt21 : bpr_type
  • dt21_bit : bpr_type
  • dt22 : bpr_type
  • dt22_bit : bpr_type
  • dt23 : bpr_type
  • dt23_bit : bpr_type
  • dt24 : bpr_type
  • dt24_bit : bpr_type
  • dt25 : bpr_type
  • dt25_bit : bpr_type
  • dt26 : bpr_type
  • dt26_bit : bpr_type
  • dt27 : bpr_type
  • dt27_bit : bpr_type
  • dt28 : bpr_type
  • dt28_bit : bpr_type
  • dt29 : bpr_type
  • dt29_bit : bpr_type
  • dt2_bit : bpr_type
  • dt3 : bpr_type
  • dt30 : bpr_type
  • dt30_bit : bpr_type
  • dt31 : bpr_type
  • dt31_bit : bpr_type
  • dt32 : bpr_type
  • dt32_bit : bpr_type
  • dt33 : bpr_type
  • dt33_bit : bpr_type
  • dt34 : bpr_type
  • dt34_bit : bpr_type
  • dt35 : bpr_type
  • dt35_bit : bpr_type
  • dt36 : bpr_type
  • dt36_bit : bpr_type
  • dt37 : bpr_type
  • dt37_bit : bpr_type
  • dt38 : bpr_type
  • dt38_bit : bpr_type
  • dt39 : bpr_type
  • dt39_bit : bpr_type
  • dt3_bit : bpr_type
  • dt4 : bpr_type
  • dt40 : bpr_type
  • dt40_bit : bpr_type
  • dt41 : bpr_type
  • dt41_bit : bpr_type
  • dt42 : bpr_type
  • dt42_bit : bpr_type
  • dt4_bit : bpr_type
  • dt5 : bpr_type
  • dt5_bit : bpr_type
  • dt6 : bpr_type
  • dt6_bit : bpr_type
  • dt7 : bpr_type
  • dt7_bit : bpr_type
  • dt8 : bpr_type
  • dt8_bit : bpr_type
  • dt9 : bpr_type
  • dt9_bit : bpr_type
  • dt_bit : crc_type, i2c_type, spi_type, usart_type
  • dtalign : adc_type
  • dtb : tmr_type
  • dtblkcmpl : sdio_type
  • dtblkcmplien : sdio_type
  • dtc : tmr_type
  • dtcmpl : sdio_type
  • dtcmplien : sdio_type
  • dtcnt : dma_channel_type, sdio_type
  • dtcnt_bit : dma_channel_type, sdio_type
  • dtctrl : sdio_type
  • dtctrl_bit : sdio_type
  • dtd : dma_channel_type
  • dterrf1 : dma_type
  • dterrf2 : dma_type
  • dterrf3 : dma_type
  • dterrf4 : dma_type
  • dterrf5 : dma_type
  • dterrf6 : dma_type
  • dterrf7 : dma_type
  • dterrfc1 : dma_type
  • dterrfc2 : dma_type
  • dterrfc3 : dma_type
  • dterrfc4 : dma_type
  • dterrfc5 : dma_type
  • dterrfc6 : dma_type
  • dterrfc7 : dma_type
  • dterrien : dma_channel_type
  • dtfail : sdio_type
  • dtfailien : sdio_type
  • dtlen : sdio_type
  • dtlen_bit : sdio_type
  • dttimeout : sdio_type
  • dttimeoutien : sdio_type
  • dttmr : sdio_type
  • dttmr_bit : sdio_type
  • dutymode : i2c_type
  • dzc : can_type
  • dzen : can_type


AT32F413 Firmwary Library: Data Fields - Variables

- e -

  • eaf : can_type
  • eaien : can_type
  • ecc_code : sd_csd_struct_type
  • ecmben : tmr_type
  • edzien : can_type
  • edzif : can_type
  • eien : acc_type
  • enpd : usb_audio_hid_type, usb_audio_type
  • entrim : acc_type
  • eoien : can_type
  • eoif : can_type
  • eopb0 : usd_type
  • epf : can_type
  • epien : can_type
  • epp0 : usd_type
  • epp1 : usd_type
  • epp2 : usd_type
  • epp3 : usd_type
  • epperr : flash_type
  • epps : flash_type
  • epps_bit : flash_type
  • ept : usbd_type
  • ept0_rx_handler : usbd_class_handler
  • ept0_slen : usb_ept_info
  • ept0_sts : usbd_core_type
  • ept0_tx_handler : usbd_class_handler
  • ept0_wlength : usbd_core_type
  • ept_address : usb_ept_info
  • ept_bit : usbd_type
  • ept_in : usbd_core_type
  • ept_num : usbd_type
  • ept_out : usbd_core_type
  • eptaddr : usbd_type
  • eptn : usb_ept_info
  • erase_group_size : sd_csd_struct_type
  • erase_group_size_mult : sd_csd_struct_type
  • err_code : sense_type
  • errie : flash_type, spi_type
  • errien : i2c_type, usart_type
  • error_code : i2c_handle_type
  • erstr : flash_type
  • esdiv : tmr_type
  • esf : tmr_type
  • esp : tmr_type
  • ests : can_type
  • ests_bit : can_type
  • etr : can_type
  • etrien : can_type
  • event_handler : usbd_class_handler
  • evoen : iomux_type
  • evten : exint_type
  • evten_bit : exint_type
  • evtenx : exint_type
  • evtien : i2c_type
  • evtout : iomux_type
  • evtout_bit : iomux_type
  • exf : usbd_type
  • exint0 : iomux_type
  • exint1 : iomux_type
  • exint10 : iomux_type
  • exint11 : iomux_type
  • exint12 : iomux_type
  • exint13 : iomux_type
  • exint14 : iomux_type
  • exint15 : iomux_type
  • exint2 : iomux_type
  • exint3 : iomux_type
  • exint4 : iomux_type
  • exint5 : iomux_type
  • exint6 : iomux_type
  • exint7 : iomux_type
  • exint8 : iomux_type
  • exint9 : iomux_type
  • exintc1 : iomux_type
  • exintc1_bit : iomux_type
  • exintc2 : iomux_type
  • exintc2_bit : iomux_type
  • exintc3 : iomux_type
  • exintc3_bit : iomux_type
  • exintc4 : iomux_type
  • exintc4_bit : iomux_type
  • exintrst : crm_type
  • ext_flash_key : usd_type
  • ext_spim_en_mux : iomux_type
  • ext_spim_gen : iomux_type
  • ext_spim_gmux : iomux_type
  • extended_id : can_rx_message_type, can_tx_message_type


AT32F413 Firmwary Library: Data Fields - Variables

- f -

  • fa : flash_type
  • facfg : can_type
  • facfg_bit : can_type
  • faen0 : can_type
  • faen1 : can_type
  • faen10 : can_type
  • faen11 : can_type
  • faen12 : can_type
  • faen13 : can_type
  • faen2 : can_type
  • faen3 : can_type
  • faen4 : can_type
  • faen5 : can_type
  • faen6 : can_type
  • faen7 : can_type
  • faen8 : can_type
  • faen9 : can_type
  • fap : flash_type, usd_type
  • fbn : spi_type
  • fbwcfg : can_type
  • fbwcfg_bit : can_type
  • fbwsel0 : can_type
  • fbwsel1 : can_type
  • fbwsel10 : can_type
  • fbwsel11 : can_type
  • fbwsel12 : can_type
  • fbwsel13 : can_type
  • fbwsel2 : can_type
  • fbwsel3 : can_type
  • fbwsel4 : can_type
  • fbwsel5 : can_type
  • fbwsel6 : can_type
  • fbwsel7 : can_type
  • fbwsel8 : can_type
  • fbwsel9 : can_type
  • fcs : can_type
  • fcsodis : tmr_type
  • fcsodis_state : tmr_brkdt_config_type
  • fcsoen : tmr_type
  • fcsoen_state : tmr_brkdt_config_type
  • fctrl : can_type
  • fctrl_bit : can_type
  • fda : flash_type
  • fdtf1 : dma_type
  • fdtf2 : dma_type
  • fdtf3 : dma_type
  • fdtf4 : dma_type
  • fdtf5 : dma_type
  • fdtf6 : dma_type
  • fdtf7 : dma_type
  • fdtfc1 : dma_type
  • fdtfc2 : dma_type
  • fdtfc3 : dma_type
  • fdtfc4 : dma_type
  • fdtfc5 : dma_type
  • fdtfc6 : dma_type
  • fdtfc7 : dma_type
  • fdtien : dma_channel_type
  • ferr : usart_type
  • ffb : can_type
  • ffdb1 : can_filter_register_type
  • ffdb2 : can_filter_register_type
  • fifo_length : iap_info_type
  • fifo_mailbox : can_type
  • file_formart : sd_csd_struct_type
  • file_format_group : sd_csd_struct_type
  • file_name : fat_dir_type
  • file_size : fat_dir_type
  • file_write_nr : flash_iap_type
  • filter_activate_enable : can_filter_init_type
  • filter_bit : can_filter_init_type
  • filter_fifo : can_filter_init_type
  • filter_id_high : can_filter_init_type
  • filter_id_low : can_filter_init_type
  • filter_index : can_rx_message_type
  • filter_mask_high : can_filter_init_type
  • filter_mask_low : can_filter_init_type
  • filter_mode : can_filter_init_type
  • filter_number : can_filter_init_type
  • firmware_length : flash_iap_type
  • first_bit_transmission : spi_init_type
  • flag_address : iap_info_type
  • flash_app_addr : flash_iap_type
  • flash_app_size : flash_iap_type
  • flash_base_addr : flash_iap_type
  • flash_end_address : iap_info_type
  • flash_size : flash_iap_type, iap_info_type
  • flash_start_address : iap_info_type
  • flashen : crm_type
  • fmcfg : can_type
  • fmcfg_bit : can_type
  • fmsel0 : can_type
  • fmsel1 : can_type
  • fmsel10 : can_type
  • fmsel11 : can_type
  • fmsel12 : can_type
  • fmsel13 : can_type
  • fmsel2 : can_type
  • fmsel3 : can_type
  • fmsel4 : can_type
  • fmsel5 : can_type
  • fmsel6 : can_type
  • fmsel7 : can_type
  • fmsel8 : can_type
  • fmsel9 : can_type
  • format : linecoding_type
  • fprgm : flash_type
  • fpx : exint_type
  • frame_bit_num : spi_init_type
  • frame_type : can_rx_message_type, can_tx_message_type
  • frf : can_type
  • frf_bit : can_type
  • frfsel0 : can_type
  • frfsel1 : can_type
  • frfsel10 : can_type
  • frfsel11 : can_type
  • frfsel12 : can_type
  • frfsel13 : can_type
  • frfsel2 : can_type
  • frfsel3 : can_type
  • frfsel4 : can_type
  • frfsel5 : can_type
  • frfsel6 : can_type
  • frfsel7 : can_type
  • frfsel8 : can_type
  • frfsel9 : can_type
  • fzc : can_type
  • fzen : can_type


AT32F413 Firmwary Library: Data Fields - Variables

- g -

  • g_audio_cur : usb_audio_hid_type, usb_audio_type
  • g_cmd : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_keyboard_tx_completed : vcp_keyboard_type
  • g_len : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_printer_data : printer_type
  • g_printer_port_status : printer_type
  • g_req : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • g_rx_buff : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_rxhid_buff : custom_hid_type, iap_info_type, usb_audio_hid_type
  • g_rxlen : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_tx_completed : cdc_msc_struct_type, cdc_struct_type, printer_type, vcp_keyboard_type
  • g_txhid_buff : custom_hid_type, usb_audio_hid_type
  • g_u8tx_completed : keyboard_type
  • gcaddrf : i2c_type
  • gcaen : i2c_type
  • gdiv : usart_type
  • gdiv_bit : usart_type
  • genstart : i2c_type
  • genstop : i2c_type
  • get_device_config_string : usbd_desc_handler
  • get_device_configuration : usbd_desc_handler
  • get_device_descriptor : usbd_desc_handler
  • get_device_interface_string : usbd_desc_handler
  • get_device_lang_id : usbd_desc_handler
  • get_device_manufacturer_string : usbd_desc_handler
  • get_device_other_speed : usbd_desc_handler
  • get_device_product_string : usbd_desc_handler
  • get_device_qualifier : usbd_desc_handler
  • get_device_serial_string : usbd_desc_handler
  • gf1 : dma_type
  • gf2 : dma_type
  • gf3 : dma_type
  • gf4 : dma_type
  • gf5 : dma_type
  • gf6 : dma_type
  • gf7 : dma_type
  • gfc1 : dma_type
  • gfc2 : dma_type
  • gfc3 : dma_type
  • gfc4 : dma_type
  • gfc5 : dma_type
  • gfc6 : dma_type
  • gfc7 : dma_type
  • gpio_drive_strength : gpio_init_type
  • gpio_mode : gpio_init_type
  • gpio_out_type : gpio_init_type
  • gpio_pins : gpio_init_type
  • gpio_pull : gpio_init_type
  • gpioaen : crm_type
  • gpioarst : crm_type
  • gpioben : crm_type
  • gpiobrst : crm_type
  • gpiocen : crm_type
  • gpiocrst : crm_type
  • gpioden : crm_type
  • gpiodrst : crm_type
  • gpioerst : crm_type
  • gpiofen : crm_type
  • gresume : usbd_type


AT32F413 Firmwary Library: Data Fields - Variables

- h -

  • h : sc_atr_type
  • hallde : tmr_type
  • hallien : tmr_type
  • hallif : tmr_type
  • hallswtr : tmr_type
  • hdtf1 : dma_type
  • hdtf2 : dma_type
  • hdtf3 : dma_type
  • hdtf4 : dma_type
  • hdtf5 : dma_type
  • hdtf6 : dma_type
  • hdtf7 : dma_type
  • hdtfc1 : dma_type
  • hdtfc2 : dma_type
  • hdtfc3 : dma_type
  • hdtfc4 : dma_type
  • hdtfc5 : dma_type
  • hdtfc6 : dma_type
  • hdtfc7 : dma_type
  • hdtien : dma_channel_type
  • head : usart_group_type
  • hextbyps : crm_type
  • hexten : crm_type
  • hextstbl : crm_type
  • hextstblf : crm_type
  • hextstblfc : crm_type
  • hextstblien : crm_type
  • hfcen : sdio_type
  • hick_to_sclk : crm_type
  • hick_to_usb : crm_type
  • hickcal : acc_type, crm_type
  • hickcal_key : crm_type
  • hickdiv : crm_type
  • hicken : crm_type
  • hickstbl : crm_type
  • hickstblf : crm_type
  • hickstblfc : crm_type
  • hickstblien : crm_type
  • hicktrim : acc_type, crm_type
  • hid_protocol : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_idle : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_set_report : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_state : custom_hid_type, iap_info_type, keyboard_type, mouse_type, usb_audio_hid_type, vcp_keyboard_type
  • hid_suspend_flag : keyboard_type, mouse_type
  • hlength : sc_atr_type
  • hostaddrf : i2c_type
  • hour : calendar_type
  • hwcsoe : spi_type


AT32F413 Firmwary Library: Data Fields - Variables

- i -

  • i2c1_gmux : iomux_type
  • i2c1_mux : iomux_type
  • i2c1_smbus_timeout : debug_type
  • i2c1en : crm_type
  • i2c1rst : crm_type
  • i2c2_gmux : iomux_type
  • i2c2_smbus_timeout : debug_type
  • i2c2en : crm_type
  • i2c2rst : crm_type
  • i2cen : i2c_type
  • i2cx : i2c_handle_type
  • i2scbn : spi_type
  • i2sclk : spi_type
  • i2sclk_bit : spi_type
  • i2sclkpol : spi_type
  • i2sctrl : spi_type
  • i2sctrl_bit : spi_type
  • i2sdbn : spi_type
  • i2sdiv_h : spi_type
  • i2sdiv_l : spi_type
  • i2sen : spi_type
  • i2smclkoe : spi_type
  • i2smsel : spi_type
  • i2sodd : spi_type
  • iap_address : iap_info_type
  • iap_fifo : iap_info_type
  • iap_rx : iap_info_type
  • iap_tx : iap_info_type
  • iConfiguration : usb_configuration_desc_type
  • id : usart_type
  • id_type : can_rx_message_type, can_tx_message_type
  • idcode_bit : debug_type
  • iden : tmr_type
  • iden_bit : tmr_type
  • idlef : usart_type
  • idleien : usart_type
  • idProduct : usb_device_desc_type
  • idt : crc_type, gpio_type
  • idt0 : gpio_type
  • idt1 : gpio_type
  • idt10 : gpio_type
  • idt11 : gpio_type
  • idt12 : gpio_type
  • idt13 : gpio_type
  • idt14 : gpio_type
  • idt15 : gpio_type
  • idt2 : gpio_type
  • idt3 : gpio_type
  • idt4 : gpio_type
  • idt5 : gpio_type
  • idt6 : gpio_type
  • idt7 : gpio_type
  • idt8 : gpio_type
  • idt9 : gpio_type
  • idt_bit : crc_type, gpio_type
  • idVendor : usb_device_desc_type
  • iInterface : usb_interface_desc_type
  • iManufacturer : usb_device_desc_type
  • in_handler : usbd_class_handler
  • information : sense_type
  • init_handler : usbd_class_handler
  • inout : usb_ept_info, usbd_type
  • input_channel_select : tmr_input_config_type
  • input_filter_value : tmr_input_config_type
  • input_mapped_select : tmr_input_config_type
  • input_polarity_select : tmr_input_config_type
  • intclr : sdio_type
  • intclr_bit : sdio_type
  • inten : can_type, exint_type, sdio_type
  • inten_bit : can_type, exint_type, sdio_type
  • intenx : exint_type
  • interface : usb_audio_hid_type, usb_audio_type
  • intmap : crm_type
  • intmap_bit : crm_type
  • intsts : exint_type, usbd_type
  • intsts_bit : exint_type, usbd_type
  • intwt : sdio_type
  • iocb0 : gpio_type
  • iocb1 : gpio_type
  • iocb10 : gpio_type
  • iocb11 : gpio_type
  • iocb12 : gpio_type
  • iocb13 : gpio_type
  • iocb14 : gpio_type
  • iocb15 : gpio_type
  • iocb2 : gpio_type
  • iocb3 : gpio_type
  • iocb4 : gpio_type
  • iocb5 : gpio_type
  • iocb6 : gpio_type
  • iocb7 : gpio_type
  • iocb8 : gpio_type
  • iocb9 : gpio_type
  • ioen : sdio_type
  • iofc0 : gpio_type
  • iofc1 : gpio_type
  • iofc10 : gpio_type
  • iofc11 : gpio_type
  • iofc12 : gpio_type
  • iofc13 : gpio_type
  • iofc14 : gpio_type
  • iofc15 : gpio_type
  • iofc2 : gpio_type
  • iofc3 : gpio_type
  • iofc4 : gpio_type
  • iofc5 : gpio_type
  • iofc6 : gpio_type
  • iofc7 : gpio_type
  • iofc8 : gpio_type
  • iofc9 : gpio_type
  • ioif : sdio_type
  • ioifien : sdio_type
  • iomc0 : gpio_type
  • iomc1 : gpio_type
  • iomc10 : gpio_type
  • iomc11 : gpio_type
  • iomc12 : gpio_type
  • iomc13 : gpio_type
  • iomc14 : gpio_type
  • iomc15 : gpio_type
  • iomc2 : gpio_type
  • iomc3 : gpio_type
  • iomc4 : gpio_type
  • iomc5 : gpio_type
  • iomc6 : gpio_type
  • iomc7 : gpio_type
  • iomc8 : gpio_type
  • iomc9 : gpio_type
  • iomuxen : crm_type
  • iomuxrst : crm_type
  • iosb0 : gpio_type
  • iosb1 : gpio_type
  • iosb10 : gpio_type
  • iosb11 : gpio_type
  • iosb12 : gpio_type
  • iosb13 : gpio_type
  • iosb14 : gpio_type
  • iosb15 : gpio_type
  • iosb2 : gpio_type
  • iosb3 : gpio_type
  • iosb4 : gpio_type
  • iosb5 : gpio_type
  • iosb6 : gpio_type
  • iosb7 : gpio_type
  • iosb8 : gpio_type
  • iosb9 : gpio_type
  • iosusp : sdio_type
  • iProduct : usb_device_desc_type
  • irdaen : usart_type
  • irdalp : usart_type
  • is_double_buffer : usb_ept_info
  • isdiv : usart_type
  • iSerialNumber : usb_device_desc_type
  • ists : tmr_type
  • ists_bit : tmr_type
  • itsrven : adc_type


AT32F413 Firmwary Library: Data Fields - Variables

- k -

  • keyboard_buf : keyboard_type


AT32F413 Firmwary Library: Data Fields - Variables

- l -

  • last_access_data : fat_dir_type
  • last_len : usb_ept_info
  • lbcp : usart_type
  • lben : can_type
  • length : usbd_desc_t
  • lextbyps : crm_type
  • lexten : crm_type
  • lextstbl : crm_type
  • lextstblf : crm_type
  • lextstblfc : crm_type
  • lextstblien : crm_type
  • licken : crm_type
  • lickstbl : crm_type
  • lickstblf : crm_type
  • lickstblfc : crm_type
  • lickstblien : crm_type
  • line_enable : exint_init_type
  • line_mode : exint_init_type
  • line_polarity : exint_init_type
  • line_select : exint_init_type
  • linecoding : cdc_msc_struct_type, cdc_struct_type, vcp_keyboard_type
  • linen : usart_type
  • linex : exint_type
  • lm : dma_channel_type
  • loen : can_type
  • loop_mode_enable : dma_init_type
  • lpm : usbd_type
  • lprstf : crm_type
  • lpsel : pwc_type
  • lsamprx : can_type
  • lsof : usbd_type
  • lsofien : usbd_type
  • lsofnum : usbd_type
  • ltf : spi_type
  • lun : cbd_extended_type, cbd_typical_type


AT32F413 Firmwary Library: Data Fields - Variables

- m -

  • m2m : dma_channel_type
  • mackctrl : i2c_type
  • maddr : dma_channel_type
  • maddr_bit : dma_channel_type
  • manufact_date : sd_cid_struct_type
  • manufacturer_default_ecc : sd_csd_struct_type
  • manufacturer_id : sd_cid_struct_type
  • master_slave_mode : spi_init_type
  • max_bus_clk_freq : sd_csd_struct_type
  • max_lun : cdc_msc_struct_type, msc_type
  • max_read_blk_length : sd_csd_struct_type
  • max_read_current_vdd_max : sd_csd_struct_type
  • max_read_current_vdd_min : sd_csd_struct_type
  • max_write_blk_length : sd_csd_struct_type
  • max_write_current_vdd_max : sd_csd_struct_type
  • max_write_current_vdd_min : sd_csd_struct_type
  • maxpacket : usb_ept_info
  • mclk_freq_division : spi_init_type
  • mclk_output_enable : i2s_init_type
  • mctrl : can_type
  • mctrl_bit : can_type
  • mdiv_h : spi_type
  • mdiv_l : spi_type
  • mdrsel : can_type
  • mdrsel_selection : can_base_type
  • memory_base_addr : dma_init_type
  • memory_data_width : dma_init_type
  • memory_inc_enable : dma_init_type
  • mic_adj_count : audio_codec_type
  • mic_adj_stage : audio_codec_type
  • mic_alt_setting : usb_audio_hid_type, usb_audio_type
  • mic_buffer : audio_codec_type
  • mic_calc : audio_codec_type
  • mic_delta : audio_codec_type
  • mic_enable : audio_codec_type
  • mic_freq : usb_audio_hid_type, usb_audio_type
  • mic_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_roff : audio_codec_type
  • mic_rtotal : audio_codec_type
  • mic_rx_size : audio_codec_type
  • mic_stage : audio_codec_type
  • mic_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • mic_volume_limits : usb_audio_hid_type, usb_audio_type
  • mic_wend : audio_codec_type
  • mic_woff : audio_codec_type
  • mic_wtotal : audio_codec_type
  • min : calendar_type
  • mincm : dma_channel_type
  • misc1 : crm_type
  • misc1_bit : crm_type
  • misc2 : crm_type
  • misc2_bit : crm_type
  • misc3 : crm_type
  • misc3_bit : crm_type
  • mmerr : spi_type
  • mmssr : can_type
  • mmssr_selection : can_base_type
  • mode : i2c_handle_type
  • mode_selection : can_base_type
  • month : calendar_type
  • mouse_buffer : mouse_type
  • msc_state : cdc_msc_struct_type, msc_type
  • msc_up_status : flash_iap_type
  • mssel : adc_type
  • msten : spi_type
  • msts : can_type
  • msts_bit : can_type
  • mwidth : dma_channel_type


AT32F413 Firmwary Library: Data Fields - Variables

- n -

  • nerr : usart_type
  • nrstf : crm_type
  • nsac : sd_csd_struct_type
  • ntc : spi_type


AT32F413 Firmwary Library: Data Fields - Variables

- o -

  • oaddr1 : i2c_type
  • oaddr1_bit : i2c_type
  • oaddr2 : i2c_type
  • oaddr2_bit : i2c_type
  • obf : flash_type
  • oc_idle_state : tmr_output_config_type
  • oc_mode : tmr_output_config_type
  • oc_output_state : tmr_output_config_type
  • oc_polarity : tmr_output_config_type
  • occ_idle_state : tmr_output_config_type
  • occ_output_state : tmr_output_config_type
  • occ_polarity : tmr_output_config_type
  • occs : adc_type
  • ocdmaen : adc_type
  • oclen : adc_type
  • ocmen : tmr_type
  • ocpcnt : adc_type
  • ocpen : adc_type
  • ocswtrg : adc_type
  • octen : adc_type
  • octesel_h : adc_type
  • octesel_l : adc_type
  • ocvmen : adc_type
  • odf : flash_type
  • odfie : flash_type
  • odt : adc_type, gpio_type
  • odt0 : gpio_type
  • odt1 : gpio_type
  • odt10 : gpio_type
  • odt11 : gpio_type
  • odt12 : gpio_type
  • odt13 : gpio_type
  • odt14 : gpio_type
  • odt15 : gpio_type
  • odt2 : gpio_type
  • odt3 : gpio_type
  • odt4 : gpio_type
  • odt5 : gpio_type
  • odt6 : gpio_type
  • odt7 : gpio_type
  • odt8 : gpio_type
  • odt9 : gpio_type
  • odt_bit : adc_type, gpio_type
  • oem_app_id : sd_cid_struct_type
  • oen : tmr_type
  • old_conn_state : usbd_core_type
  • opcode : cbd_extended_type, cbd_typical_type
  • operation_mode : i2s_init_type
  • opersel : spi_type
  • oplk : flash_type
  • ora : spi_type
  • ordinary_channel_length : adc_base_config_type
  • osn1 : adc_type
  • osn10 : adc_type
  • osn11 : adc_type
  • osn12 : adc_type
  • osn13 : adc_type
  • osn14 : adc_type
  • osn15 : adc_type
  • osn16 : adc_type
  • osn2 : adc_type
  • osn3 : adc_type
  • osn4 : adc_type
  • osn5 : adc_type
  • osn6 : adc_type
  • osn7 : adc_type
  • osn8 : adc_type
  • osn9 : adc_type
  • osq1 : adc_type
  • osq1_bit : adc_type
  • osq2 : adc_type
  • osq2_bit : adc_type
  • osq3 : adc_type
  • osq3_bit : adc_type
  • ouf : i2c_type
  • out_handler : usbd_class_handler
  • outen : bpr_type
  • outm : bpr_type
  • outsel : bpr_type
  • ovfden : tmr_type
  • ovfen : tmr_type
  • ovff : rtc_type
  • ovfien : rtc_type, tmr_type
  • ovfif : tmr_type
  • ovfs : tmr_type
  • ovfswtr : tmr_type


AT32F413 Firmwary Library: Data Fields - Variables

- p -

  • paddr : dma_channel_type
  • paddr_bit : dma_channel_type
  • parity : linecoding_type
  • part_blk_read : sd_csd_struct_type
  • part_blk_write : sd_csd_struct_type
  • pbuff : i2c_handle_type
  • pcautoen : adc_type
  • pcce : adc_type
  • pcceien : adc_type
  • pccs : adc_type
  • pcdto1 : adc_type
  • pcdto1_bit : adc_type
  • pcdto2 : adc_type
  • pcdto2_bit : adc_type
  • pcdto3 : adc_type
  • pcdto3_bit : adc_type
  • pcdto4 : adc_type
  • pcdto4_bit : adc_type
  • pclen : adc_type
  • pcmfssel : spi_type
  • pcount : i2c_handle_type
  • pcpen : adc_type
  • pcswtrg : adc_type
  • pcten : adc_type
  • pctesel_h : adc_type
  • pctesel_l : adc_type
  • pcvmen : adc_type
  • pd01_gmux : iomux_type
  • pd01_mux : iomux_type
  • pdata : usbd_class_handler
  • pdt1 : adc_type
  • pdt1_bit : adc_type
  • pdt2 : adc_type
  • pdt2_bit : adc_type
  • pdt3 : adc_type
  • pdt3_bit : adc_type
  • pdt4 : adc_type
  • pdt4_bit : adc_type
  • pecen : i2c_type
  • pecerr : i2c_type
  • pecten : i2c_type
  • pecval : i2c_type
  • pen : usart_type
  • peripheral_base_addr : dma_init_type
  • peripheral_data_width : dma_init_type
  • peripheral_inc_enable : dma_init_type
  • permanent_write_protect : sd_csd_struct_type
  • permode : i2c_type
  • perr : usart_type
  • perrien : usart_type
  • pid : debug_type
  • pincm : dma_channel_type
  • pllen : crm_type
  • pllhextdiv : crm_type
  • pllmult_h : crm_type
  • pllmult_l : crm_type
  • pllrange : crm_type
  • pllrcs : crm_type
  • pllstbl : crm_type
  • pllstblf : crm_type
  • pllstblfc : crm_type
  • pllstblien : crm_type
  • pmen : tmr_type
  • pndwt : sdio_type
  • polcfg1 : exint_type
  • polcfg1_bit : exint_type
  • polcfg2 : exint_type
  • polcfg2_bit : exint_type
  • porrstf : crm_type
  • pr : tmr_type
  • pr_bit : tmr_type
  • prben : tmr_type
  • prgmerr : flash_type
  • priority : dma_init_type
  • product_name1 : sd_cid_struct_type
  • product_name2 : sd_cid_struct_type
  • product_reversion : sd_cid_struct_type
  • product_sn : sd_cid_struct_type
  • prsf_enable : can_base_type
  • prsfen : can_type
  • ps : sdio_type
  • psel : usart_type
  • psize : i2c_handle_type
  • psn1 : adc_type
  • psn2 : adc_type
  • psn3 : adc_type
  • psn4 : adc_type
  • psq : adc_type
  • psq_bit : adc_type
  • psr : flash_type
  • psr_bit : flash_type
  • ptd : can_type
  • ptos : tmr_type
  • pvmen : pwc_type
  • pvmof : pwc_type
  • pvmsel : pwc_type
  • pwcen : crm_type
  • pwcrst : crm_type
  • pwidth : dma_channel_type
  • pwrctrl : sdio_type
  • pwrctrl_bit : sdio_type
  • pwrsven : sdio_type


AT32F413 Firmwary Library: Data Fields - Variables

- q -

  • qdzien : can_type
  • qdzif : can_type


AT32F413 Firmwary Library: Data Fields - Variables

- r -

  • rca : sd_card_info_struct_type
  • rcrc : spi_type
  • rcrc_bit : spi_type
  • rdbf : i2c_type, spi_type, usart_type
  • rdbfie : spi_type
  • rdbfien : usart_type
  • rdwtmode : sdio_type
  • rdwtstart : sdio_type
  • rdwtstop : sdio_type
  • read_blk_misalign : sd_csd_struct_type
  • read_crc : flash_iap_type
  • realrx : can_type
  • rec : can_type
  • rem0_len : usb_ept_info
  • remap : iomux_type
  • remap2 : iomux_type
  • remap2_bit : iomux_type
  • remap3 : iomux_type
  • remap3_bit : iomux_type
  • remap4 : iomux_type
  • remap4_bit : iomux_type
  • remap5 : iomux_type
  • remap5_bit : iomux_type
  • remap6 : iomux_type
  • remap6_bit : iomux_type
  • remap7 : iomux_type
  • remap7_bit : iomux_type
  • remap_bit : iomux_type
  • remote_wakup : usbd_core_type
  • ren : usart_type
  • repeat_mode : adc_base_config_type
  • request_no : usb_audio_hid_type, usb_audio_type
  • res : fat_dir_type
  • reserved : tmr_type, usd_type
  • reserved1 : acc_type, adc_type, bpr_type, can_fifo_mailbox_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, debug_type, dma_channel_type, dma_type, exint_type, flash_type, gpio_type, i2c_type, iomux_type, pwc_type, rtc_type, sd_cid_struct_type, sd_csd_struct_type, sd_scr_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usbd_type, wdt_type, wwdt_type
  • reserved2 : acc_type, adc_type, bpr_type, can_tx_mailbox_type, can_type, cbd_extended_type, cbd_typical_type, crc_type, crm_type, debug_type, flash_type, i2c_type, iomux_type, pwc_type, sd_cid_struct_type, sd_csd_struct_type, sdio_type, sense_type, spi_type, tmr_type, usart_type, usbd_type
  • reserved3 : acc_type, adc_type, bpr_type, can_type, crm_type, debug_type, flash_type, i2c_type, iomux_type, sd_csd_struct_type, sense_type, usart_type
  • reserved4 : adc_type, can_type, crm_type, debug_type, flash_type, iomux_type, sd_csd_struct_type
  • reserved5 : can_type, crm_type, flash_type
  • reserved6 : can_type, crm_type, flash_type
  • reserverd2 : sd_scr_struct_type
  • reserverd3 : sd_scr_struct_type
  • reset : i2c_type
  • respond_flag : iap_info_type
  • revid : crc_type
  • revod : crc_type
  • rf0 : can_type
  • rf0_bit : can_type
  • rf0ff : can_type
  • rf0fien : can_type
  • rf0mien : can_type
  • rf0mn : can_type
  • rf0of : can_type
  • rf0oien : can_type
  • rf0r : can_type
  • rf1 : can_type
  • rf1_bit : can_type
  • rf1ff : can_type
  • rf1fien : can_type
  • rf1mien : can_type
  • rf1mn : can_type
  • rf1of : can_type
  • rf1oien : can_type
  • rf1r : can_type
  • rfc : can_fifo_mailbox_type
  • rfc_bit : can_fifo_mailbox_type
  • rfdt0 : can_fifo_mailbox_type
  • rfdt1 : can_fifo_mailbox_type
  • rfdt2 : can_fifo_mailbox_type
  • rfdt3 : can_fifo_mailbox_type
  • rfdt4 : can_fifo_mailbox_type
  • rfdt5 : can_fifo_mailbox_type
  • rfdt6 : can_fifo_mailbox_type
  • rfdt7 : can_fifo_mailbox_type
  • rfdth : can_fifo_mailbox_type
  • rfdth_bit : can_fifo_mailbox_type
  • rfdtl : can_fifo_mailbox_type
  • rfdtl_bit : can_fifo_mailbox_type
  • rfeid : can_fifo_mailbox_type
  • rffmn : can_fifo_mailbox_type
  • rffri : can_fifo_mailbox_type
  • rfi : can_fifo_mailbox_type
  • rfi_bit : can_fifo_mailbox_type
  • rfidi : can_fifo_mailbox_type
  • rfsid : can_fifo_mailbox_type
  • rfts : can_fifo_mailbox_type
  • risetime : i2c_type
  • rld : wdt_type
  • rld_bit : wdt_type
  • rldf : wdt_type, wwdt_type
  • rldien : wwdt_type
  • rm : usart_type
  • roerr : spi_type, usart_type
  • rpen : adc_type
  • rpr : tmr_type
  • rpr_bit : tmr_type
  • rpx : exint_type
  • rsaw : can_type
  • rsaw_size : can_baudrate_type
  • rslost : acc_type
  • rsp1 : sdio_type
  • rsp1_bit : sdio_type
  • rsp2 : sdio_type
  • rsp2_bit : sdio_type
  • rsp3 : sdio_type
  • rsp3_bit : sdio_type
  • rsp4 : sdio_type
  • rsp4_bit : sdio_type
  • rsp_type : sdio_command_struct_type
  • rspcmd : sdio_type
  • rspcmd_bit : sdio_type
  • rspwt : sdio_type
  • rst : crc_type, usbd_type
  • rstfc : crm_type
  • rstien : usbd_type
  • rtccal : bpr_type
  • rtccal_bit : bpr_type
  • rtcen : crm_type
  • rtcsel : crm_type
  • rtsen : usart_type
  • rx_addr : usb_ept_info
  • rxbuf : sdio_type
  • rxbufe : sdio_type
  • rxbufeien : sdio_type
  • rxbuff : sdio_type
  • rxbuffien : sdio_type
  • rxbufh : sdio_type
  • rxbufhien : sdio_type
  • rxbufien : sdio_type
  • rxdts : usbd_type
  • rxerro : sdio_type
  • rxerroien : sdio_type
  • rxsts : usbd_type
  • rxtc : usbd_type


AT32F413 Firmwary Library: Data Fields - Variables

- s -

  • sbf : usart_type
  • sbiterr : sdio_type
  • sbiterrien : sdio_type
  • scgt : usart_type
  • sclk_freq : crm_clocks_freq_type
  • sclksel : crm_type
  • sclksts : crm_type
  • scmen : usart_type
  • scnacken : usart_type
  • scr : gpio_type
  • scr_bit : gpio_type
  • scr_structure : sd_scr_struct_type
  • sd_bus_width : sd_scr_struct_type
  • sd_cid_reg : sd_card_info_struct_type
  • sd_csd_reg : sd_card_info_struct_type
  • sd_scr_reg : sd_card_info_struct_type
  • sd_security : sd_scr_struct_type
  • sd_spec : sd_scr_struct_type
  • sd_spec3 : sd_scr_struct_type
  • sdio1_gmux : iomux_type
  • sdio1en : crm_type
  • sec : calendar_type
  • secers : flash_type
  • sector_mask : flash_iap_type
  • sector_size : flash_iap_type, iap_info_type
  • sef : pwc_type
  • select : flash_type
  • select_bit : flash_type
  • selpin : iomux_type
  • selport : iomux_type
  • sense_key : sense_type
  • sequence_mode : adc_base_config_type
  • setup : usbd_core_type
  • setup_buffer : usbd_core_type
  • setup_handler : usbd_class_handler
  • setuptc : usbd_type
  • slben : spi_type, usart_type
  • slbtd : spi_type
  • sleep_debug : debug_type
  • slib_dat_ss : flash_type
  • slib_dss_set : flash_type
  • slib_enf : flash_type
  • slib_es : flash_type
  • slib_es_set : flash_type
  • slib_misc_sts : flash_type
  • slib_misc_sts_bit : flash_type
  • slib_pclr_val : flash_type
  • slib_pset_val : flash_type
  • slib_pwd_clr : flash_type
  • slib_pwd_clr_bit : flash_type
  • slib_pwd_err : flash_type
  • slib_pwd_ok : flash_type
  • slib_rcnt : flash_type
  • slib_set_pwd : flash_type
  • slib_set_pwd_bit : flash_type
  • slib_set_range : flash_type
  • slib_set_range_bit : flash_type
  • slib_ss : flash_type
  • slib_ss_set : flash_type
  • slib_sts0 : flash_type
  • slib_sts0_bit : flash_type
  • slib_sts1 : flash_type
  • slib_sts1_bit : flash_type
  • slib_ukval : flash_type
  • slib_ulkf : flash_type
  • slib_unlock : flash_type
  • slib_unlock_bit : flash_type
  • smbalert : i2c_type
  • smbmode : i2c_type
  • smsel : tmr_type
  • sof : usbd_type
  • sof_handler : usbd_class_handler
  • sofien : usbd_type
  • sofnum : usbd_type
  • sofouten : usbd_type
  • sofrnum : usbd_type
  • sofrnum_bit : usbd_type
  • sp : usbd_type
  • spec_version : sd_csd_struct_type
  • speed : i2c_type, usbd_core_type
  • speedmode : i2c_type
  • spi1_gmux : iomux_type
  • spi1_mux_h : iomux_type
  • spi1_mux_l : iomux_type
  • spi1en : crm_type
  • spi1rst : crm_type
  • spi2_gmux : iomux_type
  • spi2en : crm_type
  • spi2rst : crm_type
  • spien : spi_type, usbd_type
  • spk_alt_setting : usb_audio_hid_type, usb_audio_type
  • spk_buffer : audio_codec_type
  • spk_calc : audio_codec_type
  • spk_enable : audio_codec_type
  • spk_freq : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_mute : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_rend : audio_codec_type
  • spk_roff : audio_codec_type
  • spk_rtotal : audio_codec_type
  • spk_stage : audio_codec_type
  • spk_threshold : audio_codec_type
  • spk_tx_size : audio_codec_type
  • spk_volume : audio_codec_type, usb_audio_hid_type, usb_audio_type
  • spk_volume_limits : usb_audio_hid_type, usb_audio_type
  • spk_woff : audio_codec_type
  • spk_wtotal : audio_codec_type
  • sprst : can_type
  • spt1 : adc_type
  • spt1_bit : adc_type
  • spt2 : adc_type
  • spt2_bit : adc_type
  • sqen : adc_type
  • sramen : crm_type
  • src_sel0 : dma_type
  • src_sel0_bit : dma_type
  • src_sel1 : dma_type
  • src_sel1_bit : dma_type
  • ssb : usd_type
  • ssp : usbd_type
  • stall : usb_ept_info
  • standard_id : can_rx_message_type, can_tx_message_type
  • standby_debug : debug_type
  • startf : i2c_type
  • state : iap_info_type
  • status : i2c_handle_type, usb_ept_info
  • stctrl : tmr_type
  • stctrl_bit : tmr_type
  • stdby_rst : flash_type
  • stdsel : spi_type
  • step : acc_type
  • stis : tmr_type
  • stopbn : usart_type
  • stopf : i2c_type
  • stretch : i2c_type
  • sts : acc_type, adc_type, dma_type, flash_type, sdio_type, spi_type, tmr_type, usart_type, wdt_type, wwdt_type
  • sts1 : i2c_type
  • sts1_bit : i2c_type
  • sts2 : i2c_type
  • sts2_bit : i2c_type
  • sts3 : flash_type
  • sts3_bit : flash_type
  • sts_bit : acc_type, adc_type, dma_type, flash_type, sdio_type, spi_type, usart_type, wdt_type, wwdt_type
  • swcsen : spi_type
  • swcsil : spi_type
  • swef : pwc_type
  • swevt : tmr_type
  • swevt_bit : tmr_type
  • swjtag_conf : iomux_type
  • swjtag_gmux : iomux_type
  • swpen : pwc_type
  • swrstf : crm_type
  • swtrg : exint_type
  • swtrg_bit : exint_type
  • swtx : exint_type


AT32F413 Firmwary Library: Data Fields - Variables

- t -

  • t : sc_atr_type
  • t0 : sc_atr_type
  • ta : rtc_type
  • taac : sd_csd_struct_type
  • taf : rtc_type
  • tah : rtc_type
  • tah_bit : rtc_type
  • taien : rtc_type
  • tail : usart_group_type
  • tal : rtc_type
  • tal_bit : rtc_type
  • tc : usbd_type
  • tcien : can_type, usbd_type
  • tcrc : spi_type
  • tcrc_bit : spi_type
  • tdbe : i2c_type, spi_type, usart_type
  • tdbeie : spi_type
  • tdbeien : usart_type
  • tdc : i2c_type, usart_type
  • tdcien : usart_type
  • tden : tmr_type
  • tec : can_type
  • temp : keyboard_type
  • temp_write_protect : sd_csd_struct_type
  • ten : usart_type
  • tfrdir : sdio_type
  • tfren : sdio_type
  • tfrmode : sdio_type
  • tien : tmr_type
  • timeout : i2c_handle_type, sdio_data_struct_type, sdio_type
  • tlength : sc_atr_type
  • tm0alf : can_type
  • tm0ct : can_type
  • tm0ef : can_type
  • tm0lpf : can_type
  • tm0tcf : can_type
  • tm0tef : can_type
  • tm0tsf : can_type
  • tm1alf : can_type
  • tm1ct : can_type
  • tm1ef : can_type
  • tm1lpf : can_type
  • tm1tcf : can_type
  • tm1tef : can_type
  • tm1tsf : can_type
  • tm2alf : can_type
  • tm2ct : can_type
  • tm2ef : can_type
  • tm2lpf : can_type
  • tm2tcf : can_type
  • tm2tef : can_type
  • tm2tsf : can_type
  • tmc : can_tx_mailbox_type
  • tmc_bit : can_tx_mailbox_type
  • tmdt0 : can_tx_mailbox_type
  • tmdt1 : can_tx_mailbox_type
  • tmdt2 : can_tx_mailbox_type
  • tmdt3 : can_tx_mailbox_type
  • tmdt4 : can_tx_mailbox_type
  • tmdt5 : can_tx_mailbox_type
  • tmdt6 : can_tx_mailbox_type
  • tmdt7 : can_tx_mailbox_type
  • tmdtbl : can_tx_mailbox_type
  • tmdth : can_tx_mailbox_type
  • tmdth_bit : can_tx_mailbox_type
  • tmdtl : can_tx_mailbox_type
  • tmdtl_bit : can_tx_mailbox_type
  • tmeid : can_tx_mailbox_type
  • tmfrsel : can_tx_mailbox_type
  • tmi : can_tx_mailbox_type
  • tmi_bit : can_tx_mailbox_type
  • tmidsel : can_tx_mailbox_type
  • tmnr : can_type
  • tmout : i2c_type
  • tmr10_gmux : iomux_type
  • tmr10_pause : debug_type
  • tmr10en : crm_type
  • tmr10rst : crm_type
  • tmr11_gmux : iomux_type
  • tmr11_pause : debug_type
  • tmr11en : crm_type
  • tmr11rst : crm_type
  • tmr1_gmux : iomux_type
  • tmr1_mux : iomux_type
  • tmr1_pause : debug_type
  • tmr1en : crm_type
  • tmr1rst : crm_type
  • tmr2_gmux : iomux_type
  • tmr2_mux : iomux_type
  • tmr2_pause : debug_type
  • tmr2en : crm_type
  • tmr2itr1_gmux : iomux_type
  • tmr2rst : crm_type
  • tmr3_gmux : iomux_type
  • tmr3_mux : iomux_type
  • tmr3_pause : debug_type
  • tmr3en : crm_type
  • tmr3rst : crm_type
  • tmr4_pause : debug_type
  • tmr4en : crm_type
  • tmr4rst : crm_type
  • tmr5_gmux : iomux_type
  • tmr5_pause : debug_type
  • tmr5ch4_gmux : iomux_type
  • tmr5ch4_mux : iomux_type
  • tmr5en : crm_type
  • tmr5rst : crm_type
  • tmr8_pause : debug_type
  • tmr8en : crm_type
  • tmr8rst : crm_type
  • tmr9_gmux : iomux_type
  • tmr9_pause : debug_type
  • tmr9en : crm_type
  • tmr9rst : crm_type
  • tmren : tmr_type
  • tmrise : i2c_type
  • tmrise_bit : i2c_type
  • tmsid : can_tx_mailbox_type
  • tmsr : can_tx_mailbox_type
  • tmts : can_tx_mailbox_type
  • tmtsten : can_tx_mailbox_type
  • total_len : usb_ept_info
  • tpef : bpr_type
  • tpefclr : bpr_type
  • tpen : bpr_type
  • tpien : bpr_type
  • tpif : bpr_type
  • tpifclr : bpr_type
  • tpp : bpr_type
  • trace_ioen : debug_type
  • trace_mode : debug_type
  • trans_buf : usb_ept_info
  • trans_len : usb_ept_info
  • trans_type : usb_ept_info, usbd_type
  • transfer_direction : sdio_data_struct_type
  • transfer_mode : sdio_data_struct_type
  • transmission_mode : spi_init_type
  • trgif : tmr_type
  • trgswtr : tmr_type
  • trmode : i2c_type
  • ts : sc_atr_type
  • tsf : rtc_type
  • tsien : rtc_type
  • tsts : can_type
  • tsts_bit : can_type
  • ttc_enable : can_base_type
  • ttcen : can_type
  • tuerr : spi_type
  • tx_addr : usb_ept_info
  • tx_length : iap_info_type
  • tx_mailbox : can_type
  • txbuf : sdio_type
  • txbufe : sdio_type
  • txbufeien : sdio_type
  • txbuff : sdio_type
  • txbuffien : sdio_type
  • txbufh : sdio_type
  • txbufhien : sdio_type
  • txbufien : sdio_type
  • txdts : usbd_type
  • txerru : sdio_type
  • txerruien : sdio_type
  • txsts : usbd_type
  • txtc : usbd_type


AT32F413 Firmwary Library: Data Fields - Variables

- u -

  • uart4_gmux : iomux_type
  • uart4en : crm_type
  • uart4rst : crm_type
  • uart5en : crm_type
  • uart5rst : crm_type
  • ucfor : usbd_type
  • ucforien : usbd_type
  • uen : usart_type
  • ukval : flash_type
  • unlock : flash_type
  • unlock3 : flash_type
  • unlock3_bit : flash_type
  • unlock_bit : flash_type
  • updf : rtc_type
  • usart1_gmux : iomux_type
  • usart1_mux : iomux_type
  • usart1en : crm_type
  • usart1rst : crm_type
  • usart2en : crm_type
  • usart2rst : crm_type
  • usart3_gmux : iomux_type
  • usart3_mux : iomux_type
  • usart3en : crm_type
  • usart3rst : crm_type
  • usb_reg : usbd_core_type
  • usbbufs : crm_type
  • usbdiv_h : crm_type
  • usbdiv_l : crm_type
  • usben : crm_type
  • usbintmap : crm_type
  • usbrst : crm_type
  • usd : flash_type
  • usd_bit : flash_type
  • usd_ukval : flash_type
  • usd_unlock : flash_type
  • usd_unlock_bit : flash_type
  • usderr : flash_type
  • usders : flash_type
  • usdprgm : flash_type
  • usdulks : flash_type
  • user_d0 : flash_type
  • user_d1 : flash_type


AT32F413 Firmwary Library: Data Fields - Variables

- v -

  • vmcsel : adc_type
  • vmhb : adc_type
  • vmhb_bit : adc_type
  • vmlb : adc_type
  • vmlb_bit : adc_type
  • vmor : adc_type
  • vmorien : adc_type
  • vmsgen : adc_type
  • vrsel : pwc_type


AT32F413 Firmwary Library: Data Fields - Variables

- w -

  • wait_type : sdio_command_struct_type
  • wdt_ato_en : flash_type
  • wdt_pause : debug_type
  • wdtrstf : crm_type
  • week : calendar_type
  • win : wwdt_type
  • wIndex : usb_setup_type
  • wk : usbd_type
  • wkien : usbd_type
  • wLength : usb_setup_type
  • wMaxPacketSize : usb_endpoint_desc_type
  • wp_level : tmr_brkdt_config_type
  • wpc : tmr_type
  • wpen0 : gpio_type
  • wpen1 : gpio_type
  • wpen10 : gpio_type
  • wpen11 : gpio_type
  • wpen12 : gpio_type
  • wpen13 : gpio_type
  • wpen14 : gpio_type
  • wpen15 : gpio_type
  • wpen2 : gpio_type
  • wpen3 : gpio_type
  • wpen4 : gpio_type
  • wpen5 : gpio_type
  • wpen6 : gpio_type
  • wpen7 : gpio_type
  • wpen8 : gpio_type
  • wpen9 : gpio_type
  • wpr : gpio_type
  • wpr_bit : gpio_type
  • wpseq : gpio_type
  • write_addr : flash_iap_type
  • write_blk_misalign : sd_csd_struct_type
  • write_crc : flash_iap_type
  • write_data : fat_dir_type
  • write_protect_group_enable : sd_csd_struct_type
  • write_protect_group_size : sd_csd_struct_type
  • write_speed_factor : sd_csd_struct_type
  • write_time : fat_dir_type
  • wTotalLength : usb_configuration_desc_type
  • wum : usart_type
  • wValue : usb_setup_type
  • wwdt_pause : debug_type
  • wwdten : crm_type, wwdt_type
  • wwdtrst : crm_type
  • wwdtrstf : crm_type


AT32F413 Firmwary Library: Data Fields - Variables

- y -

  • year : calendar_type


AT32F413 Firmwary Library: File List

File List
Here is a list of all files with brief descriptions:
at32f413.h | At32f413 header file
system_at32f413.c | All the functions for cmsis cortex-m4 system source file
system_at32f413.h | Cmsis cortex-m4 system header file
at32f413_acc.h | At32f413 acc header file
at32f413_adc.h | At32f413 adc header file
at32f413_bpr.h | At32f413 bpr header file
at32f413_can.h | At32f413 can header file
at32f413_crc.h | At32f413 crc header file
at32f413_crm.h | At32f413 crm header file
at32f413_debug.h | At32f413 debug header file
at32f413_def.h | At32f413 macros header file
at32f413_dma.h | At32f413 dma header file
at32f413_exint.h | At32f413 exint header file
at32f413_flash.h | At32f413 flash header file
at32f413_gpio.h | At32f413 gpio header file
at32f413_i2c.h | At32f413 i2c header file
at32f413_misc.h | At32f413 misc header file
at32f413_pwc.h | At32f413 pwc header file
at32f413_rtc.h | At32f413 rtc header file
at32f413_sdio.h | At32f413 sdio header file
at32f413_spi.h | At32f413 spi header file
at32f413_tmr.h | At32f413 tmr header file
at32f413_usart.h | At32f413 usart header file
at32f413_usb.h | At32f413 usb header file
at32f413_wdt.h | At32f413 wdt header file
at32f413_wwdt.h | At32f413 wwdt header file
at32f413_acc.c | All the functions for the acc firmware library
at32f413_adc.c | All the functions for the adc firmware library
at32f413_bpr.c | All the functions for the bpr firmware library
at32f413_can.c | All the functions for the can firmware library
at32f413_crc.c | All the functions for the crc firmware library
at32f413_crm.c | All the functions for the crm firmware library
at32f413_debug.c | All the functions for the debug firmware library
at32f413_dma.c | All the functions for the dma firmware library
at32f413_exint.c | All the functions for the exint firmware library
at32f413_flash.c | All the functions for the flash firmware library
at32f413_gpio.c | All the functions for the gpio firmware library
at32f413_i2c.c | All the functions for the i2c firmware library
at32f413_misc.c | All the functions for the misc firmware library
at32f413_pwc.c | All the functions for the pwc firmware library
at32f413_rtc.c | All the functions for the rtc firmware library
at32f413_sdio.c | All the functions for the sdio firmware library
at32f413_spi.c | All the functions for the spi firmware library
at32f413_tmr.c | All the functions for the tmr firmware library
at32f413_usart.c | All the functions for the usart firmware library
at32f413_usb.c | Functions for the usb firmware library
at32f413_wdt.c | All the functions for the wdt firmware library
at32f413_wwdt.c | All the functions for the wwdt firmware library
main_page.h |
i2c_application.c | Driver library of the i2c peripheral
i2c_application.h | I2c application libray header file
audio_class.c | Usb audio class type
audio_class.h | Usb audio class file
audio/audio_conf.h | Usb audio config
audio_hid/audio_conf.h | Usb audio config
audio_desc.c | Usb audio device descriptor
audio_desc.h | Usb audio descriptor header file
audio_hid_class.c |
audio_hid_class.h |
audio_hid_desc.c |
audio_hid_desc.h |
cdc_class.c | Usb cdc class type
cdc_class.h | Usb cdc class file
cdc_desc.c | Usb cdc device descriptor
cdc_desc.h | Usb cdc descriptor header file
cdc_keyboard_class.c | Usb cdc and keyboard class type
cdc_keyboard_class.h | Usb cdc and keyboard class file
cdc_keyboard_desc.c | Usb cdc and keyboard device descriptor
cdc_keyboard_desc.h | Usb cdc and keyboard descriptor header file
cdc_msc_class.c | Usb cdc class type
cdc_msc_class.h | Usb cdc class file
cdc_msc_desc.c | Usb cdc device descriptor
cdc_msc_desc.h | Usb cdc descriptor header file
composite_cdc_msc/msc_bot_scsi.c | Usb mass storage bulk-only transport and scsi command
msc/msc_bot_scsi.c | Usb mass storage bulk-only transport and scsi command
custom_hid_class.c | Usb custom hid class type
custom_hid_class.h | Usb custom hid header file
custom_hid_desc.c | Usb hid device descriptor
custom_hid_desc.h | Usb custom hid descriptor header file
hid_iap_class.c | Usb hid iap class type
hid_iap_class.h | Usb hid iap header file
hid_iap_desc.c | Usb hid device descriptor
hid_iap_desc.h | Usb hid descriptor header file
keyboard_class.c | Usb hid keyboard class type
keyboard_class.h | Usb hid keyboard header file
keyboard_desc.c | Usb hid keyboard device descriptor
keyboard_desc.h | Usb keyboard descriptor header file
mouse_class.c | Usb hid mouse class type
mouse_class.h | Usb hid mouse header file
mouse_desc.c | Usb hid mouse device descriptor
mouse_desc.h | Usb mouse descriptor header file
msc_bot_scsi.h | Usb mass storage bulk-only transport and scsi command header file
msc_class.c | Usb msc class type
msc_class.h | Usb msc class file
msc_desc.c | Usb msc device descriptor
msc_desc.h | Usb msc descriptor header file
printer_class.c | Usb printer class type
printer_class.h | Usb printer class file
printer_desc.c | Usb printer device descriptor
printer_desc.h | Usb printer descriptor header file
usb_std.h | Usb standard header file
usbd_core.h | Usb device core header file
usbd_int.h |
usbd_sdr.h | Usb standard request header file
usbd_core.c | Usb driver
usbd_int.c | Usb interrupt request
usbd_sdr.c | Usb standard device request
at32f413_board.c | Set of firmware functions to manage leds and push-button. initialize delay function
at32f413_board.h | Header file for at-start board. set of firmware functions to manage leds and push-button. initialize delay function
project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/can/filter/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/templates/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_freertos_demo/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h | Header file of clock program
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h | Header file of clock program
project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/can/filter/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/templates/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_freertos_demo/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h | At32f413 config header file
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h | At32f413 config header file
project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/can/filter/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/irda/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/printf/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/templates/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_freertos_demo/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h | Header file of main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h | Header file of main interrupt service routines
project/at_start_f413/examples/acc/calibration/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h | Usb config header file
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h | Usb config header file
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h | Usb config header file
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h | Usb config header file
project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/can/filter/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/irda/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/printf/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c | System clock config program
project/at_start_f413/templates/src/at32f413_clock.c | System clock config program
utilities/at32f413_freertos_demo/src/at32f413_clock.c | System clock config program
utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c | System clock config program
utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c | System clock config program
utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c | System clock config program
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c | System clock config program
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c | System clock config program
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c | System clock config program
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c | System clock config program
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c | System clock config program
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c | System clock config program
project/at_start_f413/examples/acc/calibration/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/can/filter/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/crc/calculation/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/irda/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/printf/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/rs485/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/templates/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_freertos_demo/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_gen_random_number_demo/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c | Main interrupt service routines
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c | Main interrupt service routines
project/at_start_f413/examples/acc/calibration/src/main.c | Main program
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c | Main program
project/at_start_f413/examples/adc/current_vref_value_check/src/main.c | Main program
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c | Main program
project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c | Main program
project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c | Main program
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c | Main program
project/at_start_f413/examples/adc/voltage_monitoring/src/main.c | Main program
project/at_start_f413/examples/bpr/bpr_data/src/main.c | Main program
project/at_start_f413/examples/bpr/tamper/src/main.c | Main program
project/at_start_f413/examples/can/communication_mode/src/main.c | Main program
project/at_start_f413/examples/can/filter/src/main.c | Main program
project/at_start_f413/examples/can/loopback_mode/src/main.c | Main program
project/at_start_f413/examples/cortex_m4/bit_band/src/main.c | Main program
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c | Main program
project/at_start_f413/examples/cortex_m4/fpu/src/main.c | Main program
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c | Main program
project/at_start_f413/examples/crc/calculation/src/main.c | Main program
project/at_start_f413/examples/crm/clock_failure_detection/src/main.c | Main program
project/at_start_f413/examples/crm/sysclk_switch/src/main.c | Main program
project/at_start_f413/examples/debug/tmr1/src/main.c | Main program
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c | Main program
project/at_start_f413/examples/dma/flash_to_sram/src/main.c | Main program
project/at_start_f413/examples/exint/exint_config/src/main.c | Main program
project/at_start_f413/examples/exint/exint_software_trigger/src/main.c | Main program
project/at_start_f413/examples/flash/flash_write_read/src/main.c | Main program
project/at_start_f413/examples/flash/operate_spim/src/main.c | Main program
project/at_start_f413/examples/flash/run_in_spim/src/main.c | Main program
project/at_start_f413/examples/gpio/led_toggle/src/main.c | Main program
project/at_start_f413/examples/gpio/swjtag_remap/src/main.c | Main program
project/at_start_f413/examples/i2c/communication_dma/src/main.c | Main program
project/at_start_f413/examples/i2c/communication_int/src/main.c | Main program
project/at_start_f413/examples/i2c/communication_poll/src/main.c | Main program
project/at_start_f413/examples/i2c/eeprom/src/main.c | Main program
project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c | Main program
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c | Main program
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c | Main program
project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c | Main program
project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c | Main program
project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c | Main program
project/at_start_f413/examples/pwc/sleep_usart1/src/main.c | Main program
project/at_start_f413/examples/pwc/standby_rtc/src/main.c | Main program
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c | Main program
project/at_start_f413/examples/rtc/calendar/src/main.c | Main program
project/at_start_f413/examples/rtc/lick_calibration/src/main.c | Main program
project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c | Main program
project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c | Main program
project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c | Main program
project/at_start_f413/examples/spi/fullduplex_polling/src/main.c | Main program
project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c | Main program
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c | Main program
project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c | Main program
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c | Main program
project/at_start_f413/examples/spi/w25q_flash/src/main.c | Main program
project/at_start_f413/examples/sram/extend_sram/src/main.c | Main program
project/at_start_f413/examples/tmr/6_steps/src/main.c | Main program
project/at_start_f413/examples/tmr/7_pwm_output/src/main.c | Main program
project/at_start_f413/examples/tmr/cascade_synchro/src/main.c | Main program
project/at_start_f413/examples/tmr/complementary_signals/src/main.c | Main program
project/at_start_f413/examples/tmr/dma/src/main.c | Main program
project/at_start_f413/examples/tmr/dma_burst/src/main.c | Main program
project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c | Main program
project/at_start_f413/examples/tmr/external_clock/src/main.c | Main program
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c | Main program
project/at_start_f413/examples/tmr/hang_mode/src/main.c | Main program
project/at_start_f413/examples/tmr/input_capture/src/main.c | Main program
project/at_start_f413/examples/tmr/oc_high/src/main.c | Main program
project/at_start_f413/examples/tmr/oc_low/src/main.c | Main program
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c | Main program
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c | Main program
project/at_start_f413/examples/tmr/one_cycle/src/main.c | Main program
project/at_start_f413/examples/tmr/parallel_synchro/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_input/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c | Main program
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c | Main program
project/at_start_f413/examples/tmr/timer_base/src/main.c | Main program
project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c | Main program
project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c | Main program
project/at_start_f413/examples/usart/half_duplex/src/main.c | Main program
project/at_start_f413/examples/usart/hw_flow_control/src/main.c | Main program
project/at_start_f413/examples/usart/idle_detection/src/main.c | Main program
project/at_start_f413/examples/usart/interrupt/src/main.c | Main program
project/at_start_f413/examples/usart/irda/src/main.c | Main program
project/at_start_f413/examples/usart/polling/src/main.c | Main program
project/at_start_f413/examples/usart/printf/src/main.c | Main program
project/at_start_f413/examples/usart/receiver_mute/src/main.c | Main program
project/at_start_f413/examples/usart/rs485/src/main.c | Main program
project/at_start_f413/examples/usart/smartcard/src/main.c | Main program
project/at_start_f413/examples/usart/synchronous/src/main.c | Main program
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c | Main program
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c | Main program
project/at_start_f413/examples/usb_device/audio/src/main.c | Main program
project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c | Main program
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c | Main program
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c | Main program
project/at_start_f413/examples/usb_device/custom_hid/src/main.c | Main program
project/at_start_f413/examples/usb_device/keyboard/src/main.c | Main program
project/at_start_f413/examples/usb_device/mouse/src/main.c | Main program
project/at_start_f413/examples/usb_device/msc/src/main.c | Main program
project/at_start_f413/examples/usb_device/printer/src/main.c | Main program
project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c | Main program
project/at_start_f413/examples/usb_device/virtual_comport/src/main.c | Main program
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c | Main program
project/at_start_f413/examples/wdt/wdt_reset/src/main.c | Main program
project/at_start_f413/examples/wdt/wdt_standby/src/main.c | Main program
project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c | Main program
project/at_start_f413/templates/src/main.c | Main program
utilities/at32f413_freertos_demo/src/main.c | Main program
utilities/at32f413_gen_random_number_demo/src/main.c | Main program
utilities/at32f413_slib_demo/project_l0/src/main.c | Main program
utilities/at32f413_slib_demo/project_l1/src/main.c | Main program
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c | Main program
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c | Main program
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c | Main program
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c | Main program
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c | Main program
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c | Main program
julia_fpu.h | Julia_fpu header file
julia_fpu.c | Julia_fpu source file
project/at_start_f413/examples/flash/flash_write_read/inc/flash.h | Flash header file
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h | Flash header file
project/at_start_f413/examples/flash/flash_write_read/src/flash.c | Flash program
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c | Flash program
operate_spim.h | Operate_spim header file
operate_spim.c | Operate spim program
run_in_spim.h | Run_in_spim header file
run_in_spim.c | Run in spim program
rtc.h | This file provides template for calendar api
rtc.c | This file provides template for calendar api
sd_mmc_card/inc/at32_sdio.h | This file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library
sdio_fatfs/inc/at32_sdio.h | This file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library
ffconf.h |
sd_mmc_card/src/at32_sdio.c | This file provides a set of functions needed to manage the sdio/mmc card memory
sdio_fatfs/src/at32_sdio.c | This file provides a set of functions needed to manage the sdio/mmc card memory
diskio.c |
spi_flash.h | Header file of spi_flash
spi_flash.c | Spi_flash source code
smartcard_config.h | Header file of clock program
audio/inc/audio_codec.h | Audio codec header file
composite_audio_hid/inc/audio_codec.h | Audio codec header file
audio/src/audio_codec.c | Audio codec function
composite_audio_hid/src/audio_codec.c | Audio codec function
composite_vcp_msc/inc/msc_diskio.h | Usb mass storage disk interface header file
msc/inc/msc_diskio.h | Usb mass storage disk interface header file
virtual_msc_iap/inc/msc_diskio.h | Usb mass storage disk interface header file
composite_vcp_msc/src/msc_diskio.c | Usb mass storage disk function
msc/src/msc_diskio.c | Usb mass storage disk function
virtual_msc_iap/src/msc_diskio.c | Usb mass storage disk function
flash_fat16.h | Fat16 file system header file
flash_fat16.c | Fat16 file system
FreeRTOSConfig.h |
random.h | At32f413 random header file
random.c | Set of firmware functions to random function
project_l0/inc/fir_filter.h |
project_l1/inc/fir_filter.h |
project_l0/inc/math_helper.h |
project_l1/inc/math_helper.h |
project_l0/src/arm_fir_data.c |
project_l1/src/arm_fir_data.c |
arm_fir_init_f32.c |
fir_coefficient.c |
fir_filter.c |
project_l0/src/math_helper.c |
project_l1/src/math_helper.c |
app_led3_toggle/inc/iap.h | Iap header file
app_led4_toggle/inc/iap.h | Iap header file
bootloader/inc/iap.h | Iap header file
app_led3_toggle/inc/tmr.h | Tmr header file
app_led4_toggle/inc/tmr.h | Tmr header file
bootloader/inc/tmr.h | Tmr header file
app_led3_toggle/inc/usart.h | Usart header file
app_led4_toggle/inc/usart.h | Usart header file
bootloader/inc/usart.h | Usart header file
app_led3_toggle/src/iap.c | Iap program
app_led4_toggle/src/iap.c | Iap program
bootloader/src/iap.c | Iap program
app_led3_toggle/src/tmr.c | Tmr program
app_led4_toggle/src/tmr.c | Tmr program
bootloader/src/tmr.c | Tmr program
app_led3_toggle/src/usart.c | Usart program
app_led4_toggle/src/usart.c | Usart program
bootloader/src/usart.c | Usart program
app_led3_toggle/inc/hid_iap_user.h | Usb config header file
app_led4_toggle/inc/hid_iap_user.h | Usb config header file
bootloader/inc/hid_iap_user.h | Usb config header file
app_led3_toggle/src/hid_iap_user.c | Usb hid iap user file
app_led4_toggle/src/hid_iap_user.c | Usb hid iap user file
bootloader/src/hid_iap_user.c | Usb hid iap user file


AT32F413 Firmwary Library: at32f413.h File Reference

  • AT32F413_Firmware_Library_V2.0.5
  • libraries
  • cmsis
  • cm4
  • device_support
Macros | Typedefs | Enumerations
at32f413.h File Reference

at32f413 header file More...

#include "core_cm4.h"
#include "system_at32f413.h"
#include <stdint.h>
#include "at32f413_def.h"
#include "at32f413_conf.h"

Go to the source code of this file.

Macros

#define | __AT32F413_LIBRARY_VERSION_MAJOR (0x02)
at32f413 standard peripheral library version number More...
#define | __AT32F413_LIBRARY_VERSION_MIDDLE (0x00)
#define | __AT32F413_LIBRARY_VERSION_MINOR (0x05)
#define | __AT32F413_LIBRARY_VERSION_RC (0x00)
#define | __AT32F413_LIBRARY_VERSION
#define | __CM4_REV 0x0001U
configuration of the cortex-m4 processor and core peripherals More...
#define | __MPU_PRESENT 1
#define | __NVIC_PRIO_BITS 4
#define | __Vendor_SysTickConfig 0
#define | __FPU_PRESENT 1U
#define | REG8(addr) *(volatile uint8_t *)(addr)
#define | REG16(addr) *(volatile uint16_t *)(addr)
#define | REG32(addr) *(volatile uint32_t *)(addr)
#define | MAKE_VALUE(reg_offset, bit_num) (uint32_t)(((reg_offset) << 16) | (bit_num & 0x1F))
#define | PERIPH_REG(periph_base, value) REG32((periph_base + (value >> 16)))
#define | PERIPH_REG_BIT(value) (0x1U << (value & 0x1F))
#define | FLASH_BASE ((uint32_t)0x08000000)
#define | SPIM_FLASH_BASE ((uint32_t)0x08400000)
#define | USD_BASE ((uint32_t)0x1FFFF800)
#define | SRAM_BASE ((uint32_t)0x20000000)
#define | PERIPH_BASE ((uint32_t)0x40000000)
#define | XMC_REG_BASE ((uint32_t)0xA0000000)
#define | DEBUG_BASE ((uint32_t)0xE0042000)
#define | APB1PERIPH_BASE (PERIPH_BASE + 0x00000)
#define | APB2PERIPH_BASE (PERIPH_BASE + 0x10000)
#define | AHBPERIPH_BASE (PERIPH_BASE + 0x20000)
#define | TMR2_BASE (APB1PERIPH_BASE + 0x0000)
#define | TMR3_BASE (APB1PERIPH_BASE + 0x0400)
#define | TMR4_BASE (APB1PERIPH_BASE + 0x0800)
#define | TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
#define | RTC_BASE (APB1PERIPH_BASE + 0x2800)
#define | WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
#define | WDT_BASE (APB1PERIPH_BASE + 0x3000)
#define | SPI2_BASE (APB1PERIPH_BASE + 0x3800)
#define | USART2_BASE (APB1PERIPH_BASE + 0x4400)
#define | USART3_BASE (APB1PERIPH_BASE + 0x4800)
#define | UART4_BASE (APB1PERIPH_BASE + 0x4C00)
#define | UART5_BASE (APB1PERIPH_BASE + 0x5000)
#define | I2C1_BASE (APB1PERIPH_BASE + 0x5400)
#define | I2C2_BASE (APB1PERIPH_BASE + 0x5800)
#define | USBFS_BASE (APB1PERIPH_BASE + 0x5C00)
#define | CAN1_BASE (APB1PERIPH_BASE + 0x6400)
#define | CAN2_BASE (APB1PERIPH_BASE + 0x6800)
#define | BPR_BASE (APB1PERIPH_BASE + 0x6C00)
#define | PWC_BASE (APB1PERIPH_BASE + 0x7000)
#define | IOMUX_BASE (APB2PERIPH_BASE + 0x0000)
#define | EXINT_BASE (APB2PERIPH_BASE + 0x0400)
#define | GPIOA_BASE (APB2PERIPH_BASE + 0x0800)
#define | GPIOB_BASE (APB2PERIPH_BASE + 0x0C00)
#define | GPIOC_BASE (APB2PERIPH_BASE + 0x1000)
#define | GPIOD_BASE (APB2PERIPH_BASE + 0x1400)
#define | GPIOF_BASE (APB2PERIPH_BASE + 0x1C00)
#define | ADC1_BASE (APB2PERIPH_BASE + 0x2400)
#define | ADC2_BASE (APB2PERIPH_BASE + 0x2800)
#define | TMR1_BASE (APB2PERIPH_BASE + 0x2C00)
#define | SPI1_BASE (APB2PERIPH_BASE + 0x3000)
#define | TMR8_BASE (APB2PERIPH_BASE + 0x3400)
#define | USART1_BASE (APB2PERIPH_BASE + 0x3800)
#define | TMR9_BASE (APB2PERIPH_BASE + 0x4C00)
#define | TMR10_BASE (APB2PERIPH_BASE + 0x5000)
#define | TMR11_BASE (APB2PERIPH_BASE + 0x5400)
#define | ACC_BASE (APB2PERIPH_BASE + 0x5800)
#define | SDIO1_BASE (APB2PERIPH_BASE + 0x8000)
#define | DMA1_BASE (AHBPERIPH_BASE + 0x0000)
#define | DMA1_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0008)
#define | DMA1_CHANNEL2_BASE (AHBPERIPH_BASE + 0x001C)
#define | DMA1_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0030)
#define | DMA1_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0044)
#define | DMA1_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0058)
#define | DMA1_CHANNEL6_BASE (AHBPERIPH_BASE + 0x006C)
#define | DMA1_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0080)
#define | DMA2_BASE (AHBPERIPH_BASE + 0x0400)
#define | DMA2_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0408)
#define | DMA2_CHANNEL2_BASE (AHBPERIPH_BASE + 0x041C)
#define | DMA2_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0430)
#define | DMA2_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0444)
#define | DMA2_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0458)
#define | DMA2_CHANNEL6_BASE (AHBPERIPH_BASE + 0x046C)
#define | DMA2_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0480)
#define | CRM_BASE (AHBPERIPH_BASE + 0x1000)
#define | FLASH_REG_BASE (AHBPERIPH_BASE + 0x2000)
#define | CRC_BASE (AHBPERIPH_BASE + 0x3000)

Typedefs

typedef enum IRQn | IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_section More...
typedef int32_t | INT32
typedef int16_t | INT16
typedef int8_t | INT8
typedef uint32_t | UINT32
typedef uint16_t | UINT16
typedef uint8_t | UINT8
typedef int32_t | s32
typedef int16_t | s16
typedef int8_t | s8
typedef const int32_t | sc32
typedef const int16_t | sc16
typedef const int8_t | sc8
typedef __IO int32_t | vs32
typedef __IO int16_t | vs16
typedef __IO int8_t | vs8
typedef __I int32_t | vsc32
typedef __I int16_t | vsc16
typedef __I int8_t | vsc8
typedef uint32_t | u32
typedef uint16_t | u16
typedef uint8_t | u8
typedef const uint32_t | uc32
typedef const uint16_t | uc16
typedef const uint8_t | uc8
typedef __IO uint32_t | vu32
typedef __IO uint16_t | vu16
typedef __IO uint8_t | vu8
typedef __I uint32_t | vuc32
typedef __I uint16_t | vuc16
typedef __I uint8_t | vuc8

Enumerations

enum IRQn {
Reset_IRQn = -15 , NonMaskableInt_IRQn = -14 , HardFault_IRQn = -13 , MemoryManagement_IRQn = -12 ,
BusFault_IRQn = -11 , UsageFault_IRQn = -10 , SVCall_IRQn = -5 , DebugMonitor_IRQn = -4 ,
PendSV_IRQn = -2 , SysTick_IRQn = -1 , WWDT_IRQn = 0 , PVM_IRQn = 1 ,
TAMPER_IRQn = 2 , RTC_IRQn = 3 , FLASH_IRQn = 4 , CRM_IRQn = 5 ,
EXINT0_IRQn = 6 , EXINT1_IRQn = 7 , EXINT2_IRQn = 8 , EXINT3_IRQn = 9 ,
EXINT4_IRQn = 10 , DMA1_Channel1_IRQn = 11 , DMA1_Channel2_IRQn = 12 , DMA1_Channel3_IRQn = 13 ,
DMA1_Channel4_IRQn = 14 , DMA1_Channel5_IRQn = 15 , DMA1_Channel6_IRQn = 16 , DMA1_Channel7_IRQn = 17 ,
ADC1_2_IRQn = 18 , USBFS_H_CAN1_TX_IRQn = 19 , USBFS_L_CAN1_RX0_IRQn = 20 , CAN1_RX1_IRQn = 21 ,
CAN1_SE_IRQn = 22 , EXINT9_5_IRQn = 23 , TMR1_BRK_TMR9_IRQn = 24 , TMR1_OVF_TMR10_IRQn = 25 ,
TMR1_TRG_HALL_TMR11_IRQn = 26 , TMR1_CH_IRQn = 27 , TMR2_GLOBAL_IRQn = 28 , TMR3_GLOBAL_IRQn = 29 ,
TMR4_GLOBAL_IRQn = 30 , I2C1_EVT_IRQn = 31 , I2C1_ERR_IRQn = 32 , I2C2_EVT_IRQn = 33 ,
I2C2_ERR_IRQn = 34 , SPI1_IRQn = 35 , SPI2_IRQn = 36 , USART1_IRQn = 37 ,
USART2_IRQn = 38 , USART3_IRQn = 39 , EXINT15_10_IRQn = 40 , RTCAlarm_IRQn = 41 ,
USBFSWakeUp_IRQn = 42 , TMR8_BRK_IRQn = 43 , TMR8_OVF_IRQn = 44 , TMR8_TRG_HALL_IRQn = 45 ,
TMR8_CH_IRQn = 46 , SDIO1_IRQn = 49 , TMR5_GLOBAL_IRQn = 50 , UART4_IRQn = 52 ,
UART5_IRQn = 53 , DMA2_Channel1_IRQn = 56 , DMA2_Channel2_IRQn = 57 , DMA2_Channel3_IRQn = 58 ,
DMA2_Channel4_5_IRQn = 59 , CAN2_TX_IRQn = 68 , CAN2_RX0_IRQn = 69 , CAN2_RX1_IRQn = 70 ,
CAN2_SE_IRQn = 71 , ACC_IRQn = 72 , USBFS_MAPH_IRQn = 73 , USBFS_MAPL_IRQn = 74 ,
DMA2_Channel6_7_IRQn = 75
}
at32f413 interrupt number definition, according to the selected device in Library_configuration_section More...
enum | flag_status { RESET = 0 , SET = !RESET }
flag status More...
enum | confirm_state { FALSE = 0 , TRUE = !FALSE }
confirm state More...
enum | error_status { ERROR = 0 , SUCCESS = !ERROR }
error status More...

Detailed Description

at32f413 header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413.h.


AT32F413 Firmwary Library: system_at32f413.c File Reference

  • libraries
  • cmsis
  • cm4
  • device_support
Macros | Functions | Variables
system_at32f413.c File Reference

contains all the functions for cmsis cortex-m4 system source file More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define VECT_TAB_OFFSET 0x0

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Variables

unsigned int system_core_clock = ((uint32_t)8000000)

Detailed Description

contains all the functions for cmsis cortex-m4 system source file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file system_at32f413.c.


AT32F413 Firmwary Library: system_at32f413.h File Reference

  • libraries
  • cmsis
  • cm4
  • device_support
Macros | Functions | Variables
system_at32f413.h File Reference

cmsis cortex-m4 system header file. More...

Go to the source code of this file.

Macros

#define | HEXT_STABLE_DELAY (5000u)
#define | PLL_STABLE_DELAY (500u)

Functions

void | SystemInit (void)
setup the microcontroller system initialize the flash interface. More...
void | system_core_clock_update (void)
update system_core_clock variable according to clock register values. the system_core_clock variable contains the core clock (hclk), it can be used by the user application to setup the systick timer or configure other parameters. More...

Variables

unsigned int system_core_clock

Detailed Description

cmsis cortex-m4 system header file.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file system_at32f413.h.


AT32F413 Firmwary Library: at32f413_acc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Functions
at32f413_acc.h File Reference

at32f413 acc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct acc_type
type define acc register all More...

Macros

#define | ACC_CAL_HICKCAL ((uint16_t)0x0000)
#define | ACC_CAL_HICKTRIM ((uint16_t)0x0002)
#define | ACC_RSLOST_FLAG ((uint16_t)0x0002)
#define | ACC_CALRDY_FLAG ((uint16_t)0x0001)
#define | ACC_CALRDYIEN_INT ((uint16_t)0x0020)
#define | ACC_EIEN_INT ((uint16_t)0x0010)
#define | ACC ((acc_type *) ACC_BASE)

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

at32f413 acc header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_acc.h.


AT32F413 Firmwary Library: at32f413_adc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_adc.h File Reference

at32f413 adc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | adc_base_config_type
adc base config type More...
struct | adc_type
type define adc register all More...

Macros

#define | ADC_CCE_INT ((uint32_t)0x00000020)
#define | ADC_VMOR_INT ((uint32_t)0x00000040)
#define | ADC_PCCE_INT ((uint32_t)0x00000080)
#define | ADC_VMOR_FLAG ((uint8_t)0x01)
#define | ADC_CCE_FLAG ((uint8_t)0x02)
#define | ADC_PCCE_FLAG ((uint8_t)0x04)
#define | ADC_PCCS_FLAG ((uint8_t)0x08)
#define | ADC_OCCS_FLAG ((uint8_t)0x10)
#define | ADC1 ((adc_type *) ADC1_BASE)
#define | ADC2 ((adc_type *) ADC2_BASE)

Enumerations

enum adc_combine_mode_type {
ADC_INDEPENDENT_MODE = 0x00 , ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE = 0x01 , ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE = 0x02 , ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE = 0x03 ,
ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE = 0x04 , ADC_PREEMPT_SMLT_ONLY_MODE = 0x05 , ADC_ORDINARY_SMLT_ONLY_MODE = 0x06 , ADC_ORDINARY_SHORTSHIFT_ONLY_MODE = 0x07 ,
ADC_ORDINARY_LONGSHIFT_ONLY_MODE = 0x08 , ADC_PREEMPT_INTERLTRIG_ONLY_MODE = 0x09
}
adc combine mode type(these options are reserved in adc2) More...
enum | adc_data_align_type { ADC_RIGHT_ALIGNMENT = 0x00 , ADC_LEFT_ALIGNMENT = 0x01 }
adc data align type More...
enum adc_channel_select_type {
ADC_CHANNEL_0 = 0x00 , ADC_CHANNEL_1 = 0x01 , ADC_CHANNEL_2 = 0x02 , ADC_CHANNEL_3 = 0x03 ,
ADC_CHANNEL_4 = 0x04 , ADC_CHANNEL_5 = 0x05 , ADC_CHANNEL_6 = 0x06 , ADC_CHANNEL_7 = 0x07 ,
ADC_CHANNEL_8 = 0x08 , ADC_CHANNEL_9 = 0x09 , ADC_CHANNEL_10 = 0x0A , ADC_CHANNEL_11 = 0x0B ,
ADC_CHANNEL_12 = 0x0C , ADC_CHANNEL_13 = 0x0D , ADC_CHANNEL_14 = 0x0E , ADC_CHANNEL_15 = 0x0F ,
ADC_CHANNEL_16 = 0x10 , ADC_CHANNEL_17 = 0x11
}
adc channel select type More...
enum adc_sampletime_select_type {
ADC_SAMPLETIME_1_5 = 0x00 , ADC_SAMPLETIME_7_5 = 0x01 , ADC_SAMPLETIME_13_5 = 0x02 , ADC_SAMPLETIME_28_5 = 0x03 ,
ADC_SAMPLETIME_41_5 = 0x04 , ADC_SAMPLETIME_55_5 = 0x05 , ADC_SAMPLETIME_71_5 = 0x06 , ADC_SAMPLETIME_239_5 = 0x07
}
adc sampletime select type More...
enum adc_ordinary_trig_select_type {
ADC12_ORDINARY_TRIG_TMR1CH1 = 0x00 , ADC12_ORDINARY_TRIG_TMR1CH2 = 0x01 , ADC12_ORDINARY_TRIG_TMR1CH3 = 0x02 , ADC12_ORDINARY_TRIG_TMR2CH2 = 0x03 ,
ADC12_ORDINARY_TRIG_TMR3TRGOUT = 0x04 , ADC12_ORDINARY_TRIG_TMR4CH4 = 0x05 , ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT = 0x06 , ADC12_ORDINARY_TRIG_SOFTWARE = 0x07 ,
ADC12_ORDINARY_TRIG_TMR1TRGOUT = 0x0D , ADC12_ORDINARY_TRIG_TMR8CH1 = 0x0E , ADC12_ORDINARY_TRIG_TMR8CH2 = 0x0F
}
adc ordinary group trigger event select type More...
enum adc_preempt_trig_select_type {
ADC12_PREEMPT_TRIG_TMR1TRGOUT = 0x00 , ADC12_PREEMPT_TRIG_TMR1CH4 = 0x01 , ADC12_PREEMPT_TRIG_TMR2TRGOUT = 0x02 , ADC12_PREEMPT_TRIG_TMR2CH1 = 0x03 ,
ADC12_PREEMPT_TRIG_TMR3CH4 = 0x04 , ADC12_PREEMPT_TRIG_TMR4TRGOUT = 0x05 , ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 = 0x06 , ADC12_PREEMPT_TRIG_SOFTWARE = 0x07 ,
ADC12_PREEMPT_TRIG_TMR1CH1 = 0x0D , ADC12_PREEMPT_TRIG_TMR8CH1 = 0x0E , ADC12_PREEMPT_TRIG_TMR8TRGOUT = 0x0F
}
adc preempt group trigger event select type More...
enum | adc_preempt_channel_type { ADC_PREEMPT_CHANNEL_1 = 0x00 , ADC_PREEMPT_CHANNEL_2 = 0x01 , ADC_PREEMPT_CHANNEL_3 = 0x02 , ADC_PREEMPT_CHANNEL_4 = 0x03 }
adc preempt channel type More...
enum adc_voltage_monitoring_type {
ADC_VMONITOR_SINGLE_ORDINARY = 0x00800200 , ADC_VMONITOR_SINGLE_PREEMPT = 0x00400200 , ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT = 0x00C00200 , ADC_VMONITOR_ALL_ORDINARY = 0x00800000 ,
ADC_VMONITOR_ALL_PREEMPT = 0x00400000 , ADC_VMONITOR_ALL_ORDINARY_PREEMPT = 0x00C00000 , ADC_VMONITOR_NONE = 0x00000000
}
adc voltage_monitoring type More...

Functions

void | adc_reset (adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_combine_mode_select (adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_tempersensor_vintrv_enable (confirm_state new_state)
enable or disable the temperature sensor and vintrv channel. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2). More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...

Detailed Description

at32f413 adc header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_adc.h.


AT32F413 Firmwary Library: at32f413_bpr.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_bpr.h File Reference

at32f413 bpr header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct bpr_type
type define bpr register all More...

Macros

#define | BPR_TAMPER_INTERRUPT_FLAG ((uint32_t)0x00000001)
#define | BPR_TAMPER_EVENT_FLAG ((uint32_t)0x00000002)
#define | BPR ((bpr_type *) BPR_BASE)

Enumerations

enum bpr_data_type {
BPR_DATA1 = 0x04 , BPR_DATA2 = 0x08 , BPR_DATA3 = 0x0C , BPR_DATA4 = 0x10 ,
BPR_DATA5 = 0x14 , BPR_DATA6 = 0x18 , BPR_DATA7 = 0x1C , BPR_DATA8 = 0x20 ,
BPR_DATA9 = 0x24 , BPR_DATA10 = 0x28 , BPR_DATA11 = 0x40 , BPR_DATA12 = 0x44 ,
BPR_DATA13 = 0x48 , BPR_DATA14 = 0x4C , BPR_DATA15 = 0x50 , BPR_DATA16 = 0x54 ,
BPR_DATA17 = 0x58 , BPR_DATA18 = 0x5C , BPR_DATA19 = 0x60 , BPR_DATA20 = 0x64 ,
BPR_DATA21 = 0x68 , BPR_DATA22 = 0x6C , BPR_DATA23 = 0x70 , BPR_DATA24 = 0x74 ,
BPR_DATA25 = 0x78 , BPR_DATA26 = 0x7C , BPR_DATA27 = 0x80 , BPR_DATA28 = 0x84 ,
BPR_DATA29 = 0x88 , BPR_DATA30 = 0x8C , BPR_DATA31 = 0x90 , BPR_DATA32 = 0x94 ,
BPR_DATA33 = 0x98 , BPR_DATA34 = 0x9C , BPR_DATA35 = 0xA0 , BPR_DATA36 = 0xA4 ,
BPR_DATA37 = 0xA8 , BPR_DATA38 = 0xAC , BPR_DATA39 = 0xB0 , BPR_DATA40 = 0xB4 ,
BPR_DATA41 = 0xB8 , BPR_DATA42 = 0xBC
}
battery powered register data type More...
enum bpr_rtc_output_type {
BPR_RTC_OUTPUT_NONE = 0x000 , BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE = 0x080 , BPR_RTC_OUTPUT_ALARM = 0x100 , BPR_RTC_OUTPUT_SECOND = 0x300 ,
BPR_RTC_OUTPUT_CLOCK_CAL_AFTER = 0x480 , BPR_RTC_OUTPUT_ALARM_TOGGLE = 0x900 , BPR_RTC_OUTPUT_SECOND_TOGGLE = 0xB00
}
bpr rtc output type More...
enum bpr_tamper_pin_active_level_type { BPR_TAMPER_PIN_ACTIVE_HIGH = 0x00 , BPR_TAMPER_PIN_ACTIVE_LOW = 0x01 }
tamper pin active level type More...

Functions

void | bpr_reset (void)
bpr reset by crm reset register More...
flag_status | bpr_flag_get (uint32_t flag)
bpr event flag get, for tamper event flag More...
void | bpr_flag_clear (uint32_t flag)
clear bpr tamper flag More...
void | bpr_interrupt_enable (confirm_state new_state)
enable or disable bpr tamper interrupt More...
uint16_t | bpr_data_read (bpr_data_type bpr_data)
read bpr bpr data More...
void | bpr_data_write (bpr_data_type bpr_data, uint16_t data_value)
write bpr data More...
void | bpr_rtc_output_select (bpr_rtc_output_type output_source)
select bpr rtc output More...
void | bpr_rtc_clock_calibration_value_set (uint8_t calibration_value)
set rtc clock calibration value More...
void | bpr_tamper_pin_enable (confirm_state new_state)
enable or disable bpr tamper pin More...
void | bpr_tamper_pin_active_level_set (bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level More...

Detailed Description

at32f413 bpr header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_bpr.h.


AT32F413 Firmwary Library: at32f413_can.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_can.h File Reference

at32f413 can header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | can_base_type
can init structure definition More...
struct | can_baudrate_type
can baudrate structure definition More...
struct | can_filter_init_type
can filter init structure definition More...
struct | can_tx_message_type
can tx message structure definition More...
struct | can_rx_message_type
can rx message structure definition More...
struct | can_tx_mailbox_type
can controller area network tx mailbox More...
struct | can_fifo_mailbox_type
can controller area network fifo mailbox More...
struct | can_filter_register_type
can controller area network filter bit register More...
struct | can_type
type define can register all More...

Macros

#define | FZC_TIMEOUT ((uint32_t)0x0000FFFF)
#define | DZC_TIMEOUT ((uint32_t)0x0000FFFF)
#define | CAN_EAF_FLAG ((uint32_t)0x01)
#define | CAN_EPF_FLAG ((uint32_t)0x02)
#define | CAN_BOF_FLAG ((uint32_t)0x03)
#define | CAN_ETR_FLAG ((uint32_t)0x04)
#define | CAN_EOIF_FLAG ((uint32_t)0x05)
#define | CAN_TM0TCF_FLAG ((uint32_t)0x06)
#define | CAN_TM1TCF_FLAG ((uint32_t)0x07)
#define | CAN_TM2TCF_FLAG ((uint32_t)0x08)
#define | CAN_RF0MN_FLAG ((uint32_t)0x09)
#define | CAN_RF0FF_FLAG ((uint32_t)0x0A)
#define | CAN_RF0OF_FLAG ((uint32_t)0x0B)
#define | CAN_RF1MN_FLAG ((uint32_t)0x0C)
#define | CAN_RF1FF_FLAG ((uint32_t)0x0D)
#define | CAN_RF1OF_FLAG ((uint32_t)0x0E)
#define | CAN_QDZIF_FLAG ((uint32_t)0x0F)
#define | CAN_EDZC_FLAG ((uint32_t)0x10)
#define | CAN_TMEF_FLAG ((uint32_t)0x11)
#define | CAN_TCIEN_INT ((uint32_t)0x00000001)
#define | CAN_RF0MIEN_INT ((uint32_t)0x00000002)
#define | CAN_RF0FIEN_INT ((uint32_t)0x00000004)
#define | CAN_RF0OIEN_INT ((uint32_t)0x00000008)
#define | CAN_RF1MIEN_INT ((uint32_t)0x00000010)
#define | CAN_RF1FIEN_INT ((uint32_t)0x00000020)
#define | CAN_RF1OIEN_INT ((uint32_t)0x00000040)
#define | CAN_EAIEN_INT ((uint32_t)0x00000100)
#define | CAN_EPIEN_INT ((uint32_t)0x00000200)
#define | CAN_BOIEN_INT ((uint32_t)0x00000400)
#define | CAN_ETRIEN_INT ((uint32_t)0x00000800)
#define | CAN_EOIEN_INT ((uint32_t)0x00008000)
#define | CAN_QDZIEN_INT ((uint32_t)0x00010000)
#define | CAN_EDZIEN_INT ((uint32_t)0x00020000)
#define | CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)
can flag clear operation macro definition val More...
#define | CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)
#define | CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)
#define | CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)
#define | CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)
#define | CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)
#define | CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)
#define | CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)
#define | CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)
#define | CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)
#define | CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)
#define | CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)
#define | CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)
#define | CAN1 ((can_type *) CAN1_BASE)
#define | CAN2 ((can_type *) CAN2_BASE)

Enumerations

enum | can_filter_fifo_type { CAN_FILTER_FIFO0 = 0x00 , CAN_FILTER_FIFO1 = 0x01 }
can filter fifo More...
enum | can_filter_mode_type { CAN_FILTER_MODE_ID_MASK = 0x00 , CAN_FILTER_MODE_ID_LIST = 0x01 }
can filter mode More...
enum | can_filter_bit_width_type { CAN_FILTER_16BIT = 0x00 , CAN_FILTER_32BIT = 0x01 }
can filter bit width select More...
enum | can_mode_type { CAN_MODE_COMMUNICATE = 0x00 , CAN_MODE_LOOPBACK = 0x01 , CAN_MODE_LISTENONLY = 0x02 , CAN_MODE_LISTENONLY_LOOPBACK = 0x03 }
can mode More...
enum | can_operating_mode_type { CAN_OPERATINGMODE_FREEZE = 0x00 , CAN_OPERATINGMODE_DOZE = 0x01 , CAN_OPERATINGMODE_COMMUNICATE = 0x02 }
can operating mode More...
enum | can_rsaw_type { CAN_RSAW_1TQ = 0x00 , CAN_RSAW_2TQ = 0x01 , CAN_RSAW_3TQ = 0x02 , CAN_RSAW_4TQ = 0x03 }
can resynchronization adjust width More...
enum can_bts1_type {
CAN_BTS1_1TQ = 0x00 , CAN_BTS1_2TQ = 0x01 , CAN_BTS1_3TQ = 0x02 , CAN_BTS1_4TQ = 0x03 ,
CAN_BTS1_5TQ = 0x04 , CAN_BTS1_6TQ = 0x05 , CAN_BTS1_7TQ = 0x06 , CAN_BTS1_8TQ = 0x07 ,
CAN_BTS1_9TQ = 0x08 , CAN_BTS1_10TQ = 0x09 , CAN_BTS1_11TQ = 0x0A , CAN_BTS1_12TQ = 0x0B ,
CAN_BTS1_13TQ = 0x0C , CAN_BTS1_14TQ = 0x0D , CAN_BTS1_15TQ = 0x0E , CAN_BTS1_16TQ = 0x0F
}
can bit time segment 1 More...
enum can_bts2_type {
CAN_BTS2_1TQ = 0x00 , CAN_BTS2_2TQ = 0x01 , CAN_BTS2_3TQ = 0x02 , CAN_BTS2_4TQ = 0x03 ,
CAN_BTS2_5TQ = 0x04 , CAN_BTS2_6TQ = 0x05 , CAN_BTS2_7TQ = 0x06 , CAN_BTS2_8TQ = 0x07
}
can bit time segment 2 More...
enum | can_identifier_type { CAN_ID_STANDARD = 0x00 , CAN_ID_EXTENDED = 0x01 }
can identifier type More...
enum | can_trans_frame_type { CAN_TFT_DATA = 0x00 , CAN_TFT_REMOTE = 0x01 }
can transmission frame type More...
enum | can_tx_mailbox_num_type { CAN_TX_MAILBOX0 = 0x00 , CAN_TX_MAILBOX1 = 0x01 , CAN_TX_MAILBOX2 = 0x02 }
can tx mailboxes More...
enum | can_rx_fifo_num_type { CAN_RX_FIFO0 = 0x00 , CAN_RX_FIFO1 = 0x01 }
can receive fifo More...
enum | can_transmit_status_type { CAN_TX_STATUS_FAILED = 0x00 , CAN_TX_STATUS_SUCCESSFUL = 0x01 , CAN_TX_STATUS_PENDING = 0x02 , CAN_TX_STATUS_NO_EMPTY = 0x04 }
can transmit status More...
enum | can_enter_doze_status_type { CAN_ENTER_DOZE_FAILED = 0x00 , CAN_ENTER_DOZE_SUCCESSFUL = 0x01 }
can enter doze mode status More...
enum | can_quit_doze_status_type { CAN_QUIT_DOZE_FAILED = 0x00 , CAN_QUIT_DOZE_SUCCESSFUL = 0x01 }
can quit doze mode status More...
enum | can_msg_discarding_rule_type { CAN_DISCARDING_FIRST_RECEIVED = 0x00 , CAN_DISCARDING_LAST_RECEIVED = 0x01 }
can message discarding rule select when overflow More...
enum | can_msg_sending_rule_type { CAN_SENDING_BY_ID = 0x00 , CAN_SENDING_BY_REQUEST = 0x01 }
can multiple message sending sequence rule More...
enum can_error_record_type {
CAN_ERRORRECORD_NOERR = 0x00 , CAN_ERRORRECORD_STUFFERR = 0x01 , CAN_ERRORRECORD_FORMERR = 0x02 , CAN_ERRORRECORD_ACKERR = 0x03 ,
CAN_ERRORRECORD_BITRECESSIVEERR = 0x04 , CAN_ERRORRECORD_BITDOMINANTERR = 0x05 , CAN_ERRORRECORD_CRCERR = 0x06 , CAN_ERRORRECORD_SOFTWARESETERR = 0x07
}
can error type record More...

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

at32f413 can header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_can.h.


AT32F413 Firmwary Library: at32f413_crc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_crc.h File Reference

at32f413 crc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct crc_type
type define crc register all More...

Macros

#define CRC ((crc_type *) CRC_BASE)

Enumerations

enum | crc_reverse_input_type { CRC_REVERSE_INPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_INPUT_BY_BYTE = 0x01 , CRC_REVERSE_INPUT_BY_HALFWORD = 0x02 , CRC_REVERSE_INPUT_BY_WORD = 0x03 }
crc reverse input data More...
enum | crc_reverse_output_type { CRC_REVERSE_OUTPUT_NO_AFFECTE = 0x00 , CRC_REVERSE_OUTPUT_DATA = 0x01 }
crc reverse output data More...

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_date_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...

Detailed Description

at32f413 crc header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_crc.h.


AT32F413 Firmwary Library: at32f413_crm.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_crm.h File Reference

at32f413 crm header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | crm_clocks_freq_type
crm clocks freqency structure More...
struct | crm_type
type define crm register all More...

Macros

#define | CRM_REG(value) PERIPH_REG(CRM_BASE, value)
#define | CRM_REG_BIT(value) PERIPH_REG_BIT(value)
#define | CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)
#define | CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)
#define | CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)
#define | CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x20, 1)
#define | CRM_LICK_STABLE_FLAG MAKE_VALUE(0x24, 1)
#define | CRM_ALL_RESET_FLAG MAKE_VALUE(0x24, 24)
#define | CRM_NRST_RESET_FLAG MAKE_VALUE(0x24, 26)
#define | CRM_POR_RESET_FLAG MAKE_VALUE(0x24, 27)
#define | CRM_SW_RESET_FLAG MAKE_VALUE(0x24, 28)
#define | CRM_WDT_RESET_FLAG MAKE_VALUE(0x24, 29)
#define | CRM_WWDT_RESET_FLAG MAKE_VALUE(0x24, 30)
#define | CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x24, 31)
#define | CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x08, 0)
#define | CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x08, 1)
#define | CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x08, 2)
#define | CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x08, 3)
#define | CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x08, 4)
#define | CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x08, 7)
#define | CRM_LICK_STABLE_INT ((uint32_t)0x00000100)
#define | CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)
#define | CRM_HICK_STABLE_INT ((uint32_t)0x00000400)
#define | CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)
#define | CRM_PLL_STABLE_INT ((uint32_t)0x00001000)
#define | CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)
#define | CRM ((crm_type *) CRM_BASE)

Enumerations

enum crm_periph_clock_type {
CRM_DMA1_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 0 & 0x1F)) , CRM_DMA2_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 1 & 0x1F)) , CRM_CRC_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 6 & 0x1F)) , CRM_SDIO1_PERIPH_CLOCK = (uint32_t)((( 0x14 ) << 16) | ( 10 & 0x1F)) ,
CRM_IOMUX_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 0 & 0x1F)) , CRM_GPIOA_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 2 & 0x1F)) , CRM_GPIOB_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 3 & 0x1F)) , CRM_GPIOC_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 4 & 0x1F)) ,
CRM_GPIOD_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 5 & 0x1F)) , CRM_GPIOF_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 7 & 0x1F)) , CRM_ADC1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 9 & 0x1F)) , CRM_ADC2_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 10 & 0x1F)) ,
CRM_TMR1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 11 & 0x1F)) , CRM_SPI1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 12 & 0x1F)) , CRM_TMR8_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 13 & 0x1F)) , CRM_USART1_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 14 & 0x1F)) ,
CRM_TMR9_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 19 & 0x1F)) , CRM_TMR10_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 20 & 0x1F)) , CRM_TMR11_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 21 & 0x1F)) , CRM_ACC_PERIPH_CLOCK = (uint32_t)((( 0x18 ) << 16) | ( 22 & 0x1F)) ,
CRM_TMR2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 0 & 0x1F)) , CRM_TMR3_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 1 & 0x1F)) , CRM_TMR4_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 2 & 0x1F)) , CRM_TMR5_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 3 & 0x1F)) ,
CRM_WWDT_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 11 & 0x1F)) , CRM_SPI2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 14 & 0x1F)) , CRM_USART2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 17 & 0x1F)) , CRM_USART3_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 18 & 0x1F)) ,
CRM_UART4_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 19 & 0x1F)) , CRM_UART5_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 20 & 0x1F)) , CRM_I2C1_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 21 & 0x1F)) , CRM_I2C2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 22 & 0x1F)) ,
CRM_USB_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 23 & 0x1F)) , CRM_CAN1_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 25 & 0x1F)) , CRM_BPR_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 27 & 0x1F)) , CRM_PWC_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 28 & 0x1F)) ,
CRM_CAN2_PERIPH_CLOCK = (uint32_t)((( 0x1C ) << 16) | ( 31 & 0x1F))
}
crm periph clock More...
enum crm_periph_reset_type {
CRM_IOMUX_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 0 & 0x1F)) , CRM_EXINT_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 1 & 0x1F)) , CRM_GPIOA_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 2 & 0x1F)) , CRM_GPIOB_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 3 & 0x1F)) ,
CRM_GPIOC_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 4 & 0x1F)) , CRM_GPIOD_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 5 & 0x1F)) , CRM_GPIOF_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 7 & 0x1F)) , CRM_ADC1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 9 & 0x1F)) ,
CRM_ADC2_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 10 & 0x1F)) , CRM_TMR1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 11 & 0x1F)) , CRM_SPI1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 12 & 0x1F)) , CRM_TMR8_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 13 & 0x1F)) ,
CRM_USART1_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 14 & 0x1F)) , CRM_TMR9_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 19 & 0x1F)) , CRM_TMR10_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 20 & 0x1F)) , CRM_TMR11_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 21 & 0x1F)) ,
CRM_ACC_PERIPH_RESET = (uint32_t)((( 0x0C ) << 16) | ( 22 & 0x1F)) , CRM_TMR2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 0 & 0x1F)) , CRM_TMR3_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 1 & 0x1F)) , CRM_TMR4_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 2 & 0x1F)) ,
CRM_TMR5_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 3 & 0x1F)) , CRM_WWDT_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 11 & 0x1F)) , CRM_SPI2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 14 & 0x1F)) , CRM_USART2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 17 & 0x1F)) ,
CRM_USART3_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 18 & 0x1F)) , CRM_UART4_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 19 & 0x1F)) , CRM_UART5_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 20 & 0x1F)) , CRM_I2C1_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 21 & 0x1F)) ,
CRM_I2C2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 22 & 0x1F)) , CRM_USB_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 23 & 0x1F)) , CRM_CAN1_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 25 & 0x1F)) , CRM_BPR_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 27 & 0x1F)) ,
CRM_PWC_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 28 & 0x1F)) , CRM_CAN2_PERIPH_RESET = (uint32_t)((( 0x10 ) << 16) | ( 31 & 0x1F))
}
crm periph reset More...
enum | crm_periph_clock_sleepmd_type { CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE = (uint32_t)((( 0x14 ) << 16) | ( 2 & 0x1F)) , CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE = (uint32_t)((( 0x14 ) << 16) | ( 4 & 0x1F)) }
crm periph clock in sleep mode More...
enum crm_pll_mult_type {
CRM_PLL_MULT_2 = 0 , CRM_PLL_MULT_3 = 1 , CRM_PLL_MULT_4 = 2 , CRM_PLL_MULT_5 = 3 ,
CRM_PLL_MULT_6 = 4 , CRM_PLL_MULT_7 = 5 , CRM_PLL_MULT_8 = 6 , CRM_PLL_MULT_9 = 7 ,
CRM_PLL_MULT_10 = 8 , CRM_PLL_MULT_11 = 9 , CRM_PLL_MULT_12 = 10 , CRM_PLL_MULT_13 = 11 ,
CRM_PLL_MULT_14 = 12 , CRM_PLL_MULT_15 = 13 , CRM_PLL_MULT_16 = 15 , CRM_PLL_MULT_17 = 16 ,
CRM_PLL_MULT_18 = 17 , CRM_PLL_MULT_19 = 18 , CRM_PLL_MULT_20 = 19 , CRM_PLL_MULT_21 = 20 ,
CRM_PLL_MULT_22 = 21 , CRM_PLL_MULT_23 = 22 , CRM_PLL_MULT_24 = 23 , CRM_PLL_MULT_25 = 24 ,
CRM_PLL_MULT_26 = 25 , CRM_PLL_MULT_27 = 26 , CRM_PLL_MULT_28 = 27 , CRM_PLL_MULT_29 = 28 ,
CRM_PLL_MULT_30 = 29 , CRM_PLL_MULT_31 = 30 , CRM_PLL_MULT_32 = 31 , CRM_PLL_MULT_33 = 32 ,
CRM_PLL_MULT_34 = 33 , CRM_PLL_MULT_35 = 34 , CRM_PLL_MULT_36 = 35 , CRM_PLL_MULT_37 = 36 ,
CRM_PLL_MULT_38 = 37 , CRM_PLL_MULT_39 = 38 , CRM_PLL_MULT_40 = 39 , CRM_PLL_MULT_41 = 40 ,
CRM_PLL_MULT_42 = 41 , CRM_PLL_MULT_43 = 42 , CRM_PLL_MULT_44 = 43 , CRM_PLL_MULT_45 = 44 ,
CRM_PLL_MULT_46 = 45 , CRM_PLL_MULT_47 = 46 , CRM_PLL_MULT_48 = 47 , CRM_PLL_MULT_49 = 48 ,
CRM_PLL_MULT_50 = 49 , CRM_PLL_MULT_51 = 50 , CRM_PLL_MULT_52 = 51 , CRM_PLL_MULT_53 = 52 ,
CRM_PLL_MULT_54 = 53 , CRM_PLL_MULT_55 = 54 , CRM_PLL_MULT_56 = 55 , CRM_PLL_MULT_57 = 56 ,
CRM_PLL_MULT_58 = 57 , CRM_PLL_MULT_59 = 58 , CRM_PLL_MULT_60 = 59 , CRM_PLL_MULT_61 = 60 ,
CRM_PLL_MULT_62 = 61 , CRM_PLL_MULT_63 = 62 , CRM_PLL_MULT_64 = 63
}
crm pll mult_x More...
enum | crm_pll_clock_source_type { CRM_PLL_SOURCE_HICK = 0x00 , CRM_PLL_SOURCE_HEXT = 0x01 , CRM_PLL_SOURCE_HEXT_DIV = 0x02 }
crm pll clock source More...
enum | crm_pll_output_range_type { CRM_PLL_OUTPUT_RANGE_LE72MHZ = 0x00 , CRM_PLL_OUTPUT_RANGE_GT72MHZ = 0x01 }
crm pll clock output range More...
enum crm_clock_source_type {
CRM_CLOCK_SOURCE_HICK = 0x00 , CRM_CLOCK_SOURCE_HEXT = 0x01 , CRM_CLOCK_SOURCE_PLL = 0x02 , CRM_CLOCK_SOURCE_LEXT = 0x03 ,
CRM_CLOCK_SOURCE_LICK = 0x04
}
crm clock source More...
enum crm_ahb_div_type {
CRM_AHB_DIV_1 = 0x00 , CRM_AHB_DIV_2 = 0x08 , CRM_AHB_DIV_4 = 0x09 , CRM_AHB_DIV_8 = 0x0A ,
CRM_AHB_DIV_16 = 0x0B , CRM_AHB_DIV_64 = 0x0C , CRM_AHB_DIV_128 = 0x0D , CRM_AHB_DIV_256 = 0x0E ,
CRM_AHB_DIV_512 = 0x0F
}
crm ahb division More...
enum crm_apb1_div_type {
CRM_APB1_DIV_1 = 0x00 , CRM_APB1_DIV_2 = 0x04 , CRM_APB1_DIV_4 = 0x05 , CRM_APB1_DIV_8 = 0x06 ,
CRM_APB1_DIV_16 = 0x07
}
crm apb1 division More...
enum crm_apb2_div_type {
CRM_APB2_DIV_1 = 0x00 , CRM_APB2_DIV_2 = 0x04 , CRM_APB2_DIV_4 = 0x05 , CRM_APB2_DIV_8 = 0x06 ,
CRM_APB2_DIV_16 = 0x07
}
crm apb2 division More...
enum crm_adc_div_type {
CRM_ADC_DIV_2 = 0x00 , CRM_ADC_DIV_4 = 0x01 , CRM_ADC_DIV_6 = 0x02 , CRM_ADC_DIV_8 = 0x03 ,
CRM_ADC_DIV_12 = 0x05 , CRM_ADC_DIV_16 = 0x07
}
crm adc division More...
enum crm_usb_div_type {
CRM_USB_DIV_1_5 = 0x00 , CRM_USB_DIV_1 = 0x01 , CRM_USB_DIV_2_5 = 0x02 , CRM_USB_DIV_2 = 0x03 ,
CRM_USB_DIV_3_5 = 0x04 , CRM_USB_DIV_3 = 0x05 , CRM_USB_DIV_4 = 0x06
}
crm usb division More...
enum | crm_rtc_clock_type { CRM_RTC_CLOCK_NOCLK = 0x00 , CRM_RTC_CLOCK_LEXT = 0x01 , CRM_RTC_CLOCK_LICK = 0x02 , CRM_RTC_CLOCK_HEXT_DIV = 0x03 }
crm rtc clock More...
enum | crm_hick_div_6_type { CRM_HICK48_DIV6 = 0x00 , CRM_HICK48_NODIV = 0x01 }
crm hick 48mhz division More...
enum | crm_sclk_type { CRM_SCLK_HICK = 0x00 , CRM_SCLK_HEXT = 0x01 , CRM_SCLK_PLL = 0x02 }
crm sclk select More...
enum crm_clkout_select_type {
CRM_CLKOUT_NOCLK = 0x00 , CRM_CLKOUT_LICK = 0x02 , CRM_CLKOUT_LEXT = 0x03 , CRM_CLKOUT_SCLK = 0x04 ,
CRM_CLKOUT_HICK = 0x05 , CRM_CLKOUT_HEXT = 0x06 , CRM_CLKOUT_PLL_DIV_2 = 0x07 , CRM_CLKOUT_PLL_DIV_4 = 0x0C ,
CRM_CLKOUT_USB = 0x0D , CRM_CLKOUT_ADC = 0x0E
}
crm clkout select More...
enum crm_clkout_div_type {
CRM_CLKOUT_DIV_1 = 0x00 , CRM_CLKOUT_DIV_2 = 0x08 , CRM_CLKOUT_DIV_4 = 0x09 , CRM_CLKOUT_DIV_8 = 0x0A ,
CRM_CLKOUT_DIV_16 = 0x0B , CRM_CLKOUT_DIV_64 = 0x0C , CRM_CLKOUT_DIV_128 = 0x0D , CRM_CLKOUT_DIV_256 = 0x0E ,
CRM_CLKOUT_DIV_512 = 0x0F
}
crm clkout division More...
enum | crm_auto_step_mode_type { CRM_AUTO_STEP_MODE_DISABLE = 0x00 , CRM_AUTO_STEP_MODE_ENABLE = 0x03 }
crm auto step mode More...
enum | crm_usb_int_map_type { CRM_USB_INT19_INT20 = 0x00 , CRM_USB_INT73_INT74 = 0x01 }
crm usbdev interrupt remap More...
enum | crm_usb_clock_source_type { CRM_USB_CLOCK_SOURCE_PLL = 0x00 , CRM_USB_CLOCK_SOURCE_HICK = 0x01 }
crm usb 48 mhz clock source select More...
enum | crm_hick_sclk_frequency_type { CRM_HICK_SCLK_8MHZ = 0x00 , CRM_HICK_SCLK_48MHZ = 0x01 }
crm hick as system clock frequency select More...

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_sleep_mode_clock_enable (crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_rtc_clock_select (crm_rtc_clock_type value)
select rtc clock More...
void | crm_rtc_clock_enable (confirm_state new_state)
enable or disable rtc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_adc_clock_div_set (crm_adc_div_type div_value)
set crm adc division More...
void | crm_usb_clock_div_set (crm_usb_div_type div_value)
set crm usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out_set (crm_clkout_select_type clkout)
set crm clkout More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_usb_interrupt_remapping_set (crm_usb_int_map_type int_remap)
usbdev interrupt remapping control More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_clkout_div_set (crm_clkout_div_type clkout_div)
set crm clkout division More...

Detailed Description

at32f413 crm header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_crm.h.


AT32F413 Firmwary Library: at32f413_debug.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Functions
at32f413_debug.h File Reference

at32f413 debug header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct debug_type
type define debug register all More...

Macros

#define | DEBUG_SLEEP 0x00000001
#define | DEBUG_DEEPSLEEP 0x00000002
#define | DEBUG_STANDBY 0x00000004
#define | DEBUG_WDT_PAUSE 0x00000100
#define | DEBUG_WWDT_PAUSE 0x00000200
#define | DEBUG_TMR1_PAUSE 0x00000400
#define | DEBUG_TMR2_PAUSE 0x00000800
#define | DEBUG_TMR3_PAUSE 0x00001000
#define | DEBUG_TMR4_PAUSE 0x00002000
#define | DEBUG_CAN1_PAUSE 0x00004000
#define | DEBUG_I2C1_SMBUS_TIMEOUT 0x00008000
#define | DEBUG_I2C2_SMBUS_TIMEOUT 0x00010000
#define | DEBUG_TMR8_PAUSE 0x00020000
#define | DEBUG_TMR5_PAUSE 0x00040000
#define | DEBUG_CAN2_PAUSE 0x00200000
#define | DEBUG_TMR9_PAUSE 0x10000000
#define | DEBUG_TMR10_PAUSE 0x20000000
#define | DEBUG_TMR11_PAUSE 0x40000000
#define | DEBUGMCU ((debug_type *) DEBUG_BASE)

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_periph_mode_set (uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode More...

Detailed Description

at32f413 debug header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_debug.h.


AT32F413 Firmwary Library: at32f413_def.h File Reference

  • libraries
  • drivers
  • inc
at32f413_def.h File Reference

at32f413 macros header file More...

Go to the source code of this file.

Detailed Description

at32f413 macros header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_def.h.


AT32F413 Firmwary Library: at32f413_dma.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_dma.h File Reference

at32f413 dma header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | dma_init_type
dma init type More...
struct | dma_type
type define dma register More...
struct | dma_channel_type
type define dma channel register all More...

Macros

#define | DMA_FDT_INT ((uint32_t)0x00000002)
#define | DMA_HDT_INT ((uint32_t)0x00000004)
#define | DMA_DTERR_INT ((uint32_t)0x00000008)
#define | FLEX_CHANNEL1 ((uint8_t)0x01)
#define | FLEX_CHANNEL2 ((uint8_t)0x02)
#define | FLEX_CHANNEL3 ((uint8_t)0x03)
#define | FLEX_CHANNEL4 ((uint8_t)0x04)
#define | FLEX_CHANNEL5 ((uint8_t)0x05)
#define | FLEX_CHANNEL6 ((uint8_t)0x06)
#define | FLEX_CHANNEL7 ((uint8_t)0x07)
#define | DMA1_GL1_FLAG ((uint32_t)0x00000001)
#define | DMA1_FDT1_FLAG ((uint32_t)0x00000002)
#define | DMA1_HDT1_FLAG ((uint32_t)0x00000004)
#define | DMA1_DTERR1_FLAG ((uint32_t)0x00000008)
#define | DMA1_GL2_FLAG ((uint32_t)0x00000010)
#define | DMA1_FDT2_FLAG ((uint32_t)0x00000020)
#define | DMA1_HDT2_FLAG ((uint32_t)0x00000040)
#define | DMA1_DTERR2_FLAG ((uint32_t)0x00000080)
#define | DMA1_GL3_FLAG ((uint32_t)0x00000100)
#define | DMA1_FDT3_FLAG ((uint32_t)0x00000200)
#define | DMA1_HDT3_FLAG ((uint32_t)0x00000400)
#define | DMA1_DTERR3_FLAG ((uint32_t)0x00000800)
#define | DMA1_GL4_FLAG ((uint32_t)0x00001000)
#define | DMA1_FDT4_FLAG ((uint32_t)0x00002000)
#define | DMA1_HDT4_FLAG ((uint32_t)0x00004000)
#define | DMA1_DTERR4_FLAG ((uint32_t)0x00008000)
#define | DMA1_GL5_FLAG ((uint32_t)0x00010000)
#define | DMA1_FDT5_FLAG ((uint32_t)0x00020000)
#define | DMA1_HDT5_FLAG ((uint32_t)0x00040000)
#define | DMA1_DTERR5_FLAG ((uint32_t)0x00080000)
#define | DMA1_GL6_FLAG ((uint32_t)0x00100000)
#define | DMA1_FDT6_FLAG ((uint32_t)0x00200000)
#define | DMA1_HDT6_FLAG ((uint32_t)0x00400000)
#define | DMA1_DTERR6_FLAG ((uint32_t)0x00800000)
#define | DMA1_GL7_FLAG ((uint32_t)0x01000000)
#define | DMA1_FDT7_FLAG ((uint32_t)0x02000000)
#define | DMA1_HDT7_FLAG ((uint32_t)0x04000000)
#define | DMA1_DTERR7_FLAG ((uint32_t)0x08000000)
#define | DMA2_GL1_FLAG ((uint32_t)0x10000001)
#define | DMA2_FDT1_FLAG ((uint32_t)0x10000002)
#define | DMA2_HDT1_FLAG ((uint32_t)0x10000004)
#define | DMA2_DTERR1_FLAG ((uint32_t)0x10000008)
#define | DMA2_GL2_FLAG ((uint32_t)0x10000010)
#define | DMA2_FDT2_FLAG ((uint32_t)0x10000020)
#define | DMA2_HDT2_FLAG ((uint32_t)0x10000040)
#define | DMA2_DTERR2_FLAG ((uint32_t)0x10000080)
#define | DMA2_GL3_FLAG ((uint32_t)0x10000100)
#define | DMA2_FDT3_FLAG ((uint32_t)0x10000200)
#define | DMA2_HDT3_FLAG ((uint32_t)0x10000400)
#define | DMA2_DTERR3_FLAG ((uint32_t)0x10000800)
#define | DMA2_GL4_FLAG ((uint32_t)0x10001000)
#define | DMA2_FDT4_FLAG ((uint32_t)0x10002000)
#define | DMA2_HDT4_FLAG ((uint32_t)0x10004000)
#define | DMA2_DTERR4_FLAG ((uint32_t)0x10008000)
#define | DMA2_GL5_FLAG ((uint32_t)0x10010000)
#define | DMA2_FDT5_FLAG ((uint32_t)0x10020000)
#define | DMA2_HDT5_FLAG ((uint32_t)0x10040000)
#define | DMA2_DTERR5_FLAG ((uint32_t)0x10080000)
#define | DMA2_GL6_FLAG ((uint32_t)0x10100000)
#define | DMA2_FDT6_FLAG ((uint32_t)0x10200000)
#define | DMA2_HDT6_FLAG ((uint32_t)0x10400000)
#define | DMA2_DTERR6_FLAG ((uint32_t)0x10800000)
#define | DMA2_GL7_FLAG ((uint32_t)0x11000000)
#define | DMA2_FDT7_FLAG ((uint32_t)0x12000000)
#define | DMA2_HDT7_FLAG ((uint32_t)0x14000000)
#define | DMA2_DTERR7_FLAG ((uint32_t)0x18000000)
#define | DMA1 ((dma_type *) DMA1_BASE)
#define | DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)
#define | DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)
#define | DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)
#define | DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)
#define | DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)
#define | DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)
#define | DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)
#define | DMA2 ((dma_type *) DMA2_BASE)
#define | DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)
#define | DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)
#define | DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)
#define | DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)
#define | DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)
#define | DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)
#define | DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)

Enumerations

enum dma_flexible_request_type {
DMA_FLEXIBLE_ADC1 = 0x01 , DMA_FLEXIBLE_SPI1_RX = 0x09 , DMA_FLEXIBLE_SPI1_TX = 0x0A , DMA_FLEXIBLE_SPI2_RX = 0x0B ,
DMA_FLEXIBLE_SPI2_TX = 0x0C , DMA_FLEXIBLE_UART1_RX = 0x19 , DMA_FLEXIBLE_UART1_TX = 0x1A , DMA_FLEXIBLE_UART2_RX = 0x1B ,
DMA_FLEXIBLE_UART2_TX = 0x1C , DMA_FLEXIBLE_UART3_RX = 0x1D , DMA_FLEXIBLE_UART3_TX = 0x1E , DMA_FLEXIBLE_UART4_RX = 0x1F ,
DMA_FLEXIBLE_UART4_TX = 0x20 , DMA_FLEXIBLE_UART5_RX = 0x21 , DMA_FLEXIBLE_UART5_TX = 0x22 , DMA_FLEXIBLE_I2C1_RX = 0x29 ,
DMA_FLEXIBLE_I2C1_TX = 0x2A , DMA_FLEXIBLE_I2C2_RX = 0x2B , DMA_FLEXIBLE_I2C2_TX = 0x2C , DMA_FLEXIBLE_SDIO1 = 0x31 ,
DMA_FLEXIBLE_TMR1_TRIG = 0x35 , DMA_FLEXIBLE_TMR1_HALL = 0x36 , DMA_FLEXIBLE_TMR1_OVERFLOW = 0x37 , DMA_FLEXIBLE_TMR1_CH1 = 0x38 ,
DMA_FLEXIBLE_TMR1_CH2 = 0x39 , DMA_FLEXIBLE_TMR1_CH3 = 0x3A , DMA_FLEXIBLE_TMR1_CH4 = 0x3B , DMA_FLEXIBLE_TMR2_TRIG = 0x3D ,
DMA_FLEXIBLE_TMR2_OVERFLOW = 0x3F , DMA_FLEXIBLE_TMR2_CH1 = 0x40 , DMA_FLEXIBLE_TMR2_CH2 = 0x41 , DMA_FLEXIBLE_TMR2_CH3 = 0x42 ,
DMA_FLEXIBLE_TMR2_CH4 = 0x43 , DMA_FLEXIBLE_TMR3_TRIG = 0x45 , DMA_FLEXIBLE_TMR3_OVERFLOW = 0x47 , DMA_FLEXIBLE_TMR3_CH1 = 0x48 ,
DMA_FLEXIBLE_TMR3_CH2 = 0x49 , DMA_FLEXIBLE_TMR3_CH3 = 0x4A , DMA_FLEXIBLE_TMR3_CH4 = 0x4B , DMA_FLEXIBLE_TMR4_TRIG = 0x4D ,
DMA_FLEXIBLE_TMR4_OVERFLOW = 0x4F , DMA_FLEXIBLE_TMR4_CH1 = 0x50 , DMA_FLEXIBLE_TMR4_CH2 = 0x51 , DMA_FLEXIBLE_TMR4_CH3 = 0x52 ,
DMA_FLEXIBLE_TMR4_CH4 = 0x53 , DMA_FLEXIBLE_TMR5_TRIG = 0x55 , DMA_FLEXIBLE_TMR5_OVERFLOW = 0x57 , DMA_FLEXIBLE_TMR5_CH1 = 0x58 ,
DMA_FLEXIBLE_TMR5_CH2 = 0x59 , DMA_FLEXIBLE_TMR5_CH3 = 0x5A , DMA_FLEXIBLE_TMR5_CH4 = 0x5B , DMA_FLEXIBLE_TMR8_TRIG = 0x6D ,
DMA_FLEXIBLE_TMR8_HALL = 0x6E , DMA_FLEXIBLE_TMR8_OVERFLOW = 0x6F , DMA_FLEXIBLE_TMR8_CH1 = 0x70 , DMA_FLEXIBLE_TMR8_CH2 = 0x71 ,
DMA_FLEXIBLE_TMR8_CH3 = 0x72 , DMA_FLEXIBLE_TMR8_CH4 = 0x73
}
dma flexible request type More...
enum | dma_dir_type { DMA_DIR_PERIPHERAL_TO_MEMORY = 0x0000 , DMA_DIR_MEMORY_TO_PERIPHERAL = 0x0010 , DMA_DIR_MEMORY_TO_MEMORY = 0x4000 }
dma direction type More...
enum | dma_peripheral_inc_type { DMA_PERIPHERAL_INC_DISABLE = 0x00 , DMA_PERIPHERAL_INC_ENABLE = 0x01 }
dma peripheral incremented type More...
enum | dma_memory_inc_type { DMA_MEMORY_INC_DISABLE = 0x00 , DMA_MEMORY_INC_ENABLE = 0x01 }
dma memory incremented type More...
enum | dma_peripheral_data_size_type { DMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00 , DMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01 , DMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02 }
dma peripheral data size type More...
enum | dma_memory_data_size_type { DMA_MEMORY_DATA_WIDTH_BYTE = 0x00 , DMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01 , DMA_MEMORY_DATA_WIDTH_WORD = 0x02 }
dma memory data size type More...
enum | dma_priority_level_type { DMA_PRIORITY_LOW = 0x00 , DMA_PRIORITY_MEDIUM = 0x01 , DMA_PRIORITY_HIGH = 0x02 , DMA_PRIORITY_VERY_HIGH = 0x03 }
dma priority level type More...

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset the dmax channely registers. More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely More...
void | dma_flexible_config (dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get number of data from dtcnt register More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt More...
flag_status | dma_flag_get (uint32_t dmax_flag)
get dma flag More...
void | dma_flag_clear (uint32_t dmax_flag)
clear dma flag More...

Detailed Description

at32f413 dma header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_dma.h.


AT32F413 Firmwary Library: at32f413_exint.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_exint.h File Reference

at32f413 exint header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | exint_init_type
exint init type More...
struct | exint_type
type define exint register all More...

Macros

#define | EXINT_LINE_NONE ((uint32_t)0x000000)
#define | EXINT_LINE_0 ((uint32_t)0x000001)
#define | EXINT_LINE_1 ((uint32_t)0x000002)
#define | EXINT_LINE_2 ((uint32_t)0x000004)
#define | EXINT_LINE_3 ((uint32_t)0x000008)
#define | EXINT_LINE_4 ((uint32_t)0x000010)
#define | EXINT_LINE_5 ((uint32_t)0x000020)
#define | EXINT_LINE_6 ((uint32_t)0x000040)
#define | EXINT_LINE_7 ((uint32_t)0x000080)
#define | EXINT_LINE_8 ((uint32_t)0x000100)
#define | EXINT_LINE_9 ((uint32_t)0x000200)
#define | EXINT_LINE_10 ((uint32_t)0x000400)
#define | EXINT_LINE_11 ((uint32_t)0x000800)
#define | EXINT_LINE_12 ((uint32_t)0x001000)
#define | EXINT_LINE_13 ((uint32_t)0x002000)
#define | EXINT_LINE_14 ((uint32_t)0x004000)
#define | EXINT_LINE_15 ((uint32_t)0x008000)
#define | EXINT_LINE_16 ((uint32_t)0x010000)
#define | EXINT_LINE_17 ((uint32_t)0x020000)
#define | EXINT_LINE_18 ((uint32_t)0x040000)
#define | EXINT ((exint_type *) EXINT_BASE)

Enumerations

enum | exint_line_mode_type { EXINT_LINE_INTERRUPUT = 0x00 , EXINT_LINE_EVENT = 0x01 }
exint line mode type More...
enum | exint_polarity_config_type { EXINT_TRIGGER_RISING_EDGE = 0x00 , EXINT_TRIGGER_FALLING_EDGE = 0x01 , EXINT_TRIGGER_BOTH_EDGE = 0x02 }
exint polarity configuration type More...

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

at32f413 exint header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_exint.h.


AT32F413 Firmwary Library: at32f413_flash.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_flash.h File Reference

at32f413 flash header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | flash_type
type define flash register all More...
struct | usd_type
user system data More...

Macros

#define | FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)
#define | FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)
#define | FAP_RELIEVE_KEY ((uint16_t)0x00A5)
#define | SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)
#define | FLASH_SPIM_START_ADDR ((uint32_t)0x08400000)
#define | FLASH_OBF_FLAG ((uint32_t)0x00000001)
#define | FLASH_ODF_FLAG ((uint32_t)0x00000020)
#define | FLASH_PRGMERR_FLAG ((uint32_t)0x00000004)
#define | FLASH_EPPERR_FLAG ((uint32_t)0x00000010)
#define | FLASH_SPIM_OBF_FLAG ((uint32_t)0x20000001)
#define | FLASH_SPIM_ODF_FLAG ((uint32_t)0x20000020)
#define | FLASH_SPIM_PRGMERR_FLAG ((uint32_t)0x20000004)
#define | FLASH_SPIM_EPPERR_FLAG ((uint32_t)0x20000010)
#define | FLASH_USDERR_FLAG ((uint32_t)0x40000001)
#define | FLASH_ERR_INT ((uint32_t)0x00000001)
#define | FLASH_ODF_INT ((uint32_t)0x00000002)
#define | FLASH_SPIM_ERR_INT ((uint32_t)0x00000010)
#define | FLASH_SPIM_ODF_INT ((uint32_t)0x00000020)
#define | FLASH_SLIB_START_SECTOR ((uint32_t)0x000007FF)
#define | FLASH_SLIB_DATA_START_SECTOR ((uint32_t)0x003FF800)
#define | FLASH_SLIB_END_SECTOR ((uint32_t)0xFFC00000)
#define | USD_WDT_ATO_DISABLE ((uint16_t)0x0001)
#define | USD_WDT_ATO_ENABLE ((uint16_t)0x0000)
#define | USD_DEPSLP_NO_RST ((uint16_t)0x0002)
#define | USD_DEPSLP_RST ((uint16_t)0x0000)
#define | USD_STDBY_NO_RST ((uint16_t)0x0004)
#define | USD_STDBY_RST ((uint16_t)0x0000)
#define | ERASE_TIMEOUT ((uint32_t)0x40000000)
#define | PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | SPIM_ERASE_TIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SPIM_PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
#define | OPERATION_TIMEOUT ((uint32_t)0x10000000)
#define | FLASH ((flash_type *) FLASH_REG_BASE)
#define | USD ((usd_type *) USD_BASE)

Enumerations

enum flash_status_type {
FLASH_OPERATE_BUSY = 0x00 , FLASH_PROGRAM_ERROR = 0x01 , FLASH_EPP_ERROR = 0x02 , FLASH_OPERATE_DONE = 0x03 ,
FLASH_OPERATE_TIMEOUT = 0x04
}
flash status type More...
enum flash_spim_model_type { FLASH_SPIM_MODEL1 = 0x01 , FLASH_SPIM_MODEL2 = 0x02 }
flash spim model type More...

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_spim_operation_status_get (void)
return the flash spim operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_spim_operation_wait_for (uint32_t time_out)
wait for flash spim operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_spim_unlock (void)
unlock the flash spim controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_spim_lock (void)
lock the flash spim controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_spim_all_erase (void)
erase flash spim sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
void | flash_spim_model_select (flash_spim_model_type mode)
select spim supports extended spi flash chip model. More...
void | flash_spim_encryption_range_set (uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_datstart_sector_get (void)
get the data start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...

Detailed Description

at32f413 flash header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_flash.h.


AT32F413 Firmwary Library: at32f413_gpio.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_gpio.h File Reference

at32f413 gpio header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | gpio_init_type
gpio init type More...
struct | gpio_type
type define gpio register all More...
struct | iomux_type
type define iomux register all More...

Macros

#define | GPIO_PINS_0 0x0001
#define | GPIO_PINS_1 0x0002
#define | GPIO_PINS_2 0x0004
#define | GPIO_PINS_3 0x0008
#define | GPIO_PINS_4 0x0010
#define | GPIO_PINS_5 0x0020
#define | GPIO_PINS_6 0x0040
#define | GPIO_PINS_7 0x0080
#define | GPIO_PINS_8 0x0100
#define | GPIO_PINS_9 0x0200
#define | GPIO_PINS_10 0x0400
#define | GPIO_PINS_11 0x0800
#define | GPIO_PINS_12 0x1000
#define | GPIO_PINS_13 0x2000
#define | GPIO_PINS_14 0x4000
#define | GPIO_PINS_15 0x8000
#define | GPIO_PINS_ALL 0xFFFF
#define | IOMUX_MAKE_VALUE(reg_offset, bit_addr, bit_num, bit_val) (uint32_t)(((reg_offset) << 24) | ((bit_addr) << 16) | ((bit_num) << 8) | (bit_val))
#define | SPI1_MUX_01 SPI1_GMUX_0001
#define | I2C1_MUX I2C1_GMUX_0001
#define | USART1_MUX USART1_GMUX_0001
#define | USART3_MUX_01 USART3_GMUX_0001
#define | TMR1_MUX_01 TMR1_GMUX_0001
#define | TMR2_MUX_01 TMR2_GMUX_001
#define | TMR2_MUX_10 TMR2_GMUX_010
#define | TMR2_MUX_11 TMR2_GMUX_011
#define | TMR3_MUX_10 TMR3_GMUX_0010
#define | TMR3_MUX_11 TMR3_GMUX_0011
#define | CAN_MUX_10 CAN1_GMUX_0010
#define | PD01_MUX PD01_GMUX
#define | TMR5CH4_MUX TMR5CH4_GMUX
#define | ADC1_ETP_MUX ADC1_ETP_GMUX
#define | ADC1_ETO_MUX ADC1_ETO_GMUX
#define | ADC2_ETP_MUX ADC2_ETP_GMUX
#define | ADC2_ETO_MUX ADC2_ETO_GMUX
#define | SWJTAG_CONF_001 SWJTAG_GMUX_001
#define | SWJTAG_CONF_010 SWJTAG_GMUX_010
#define | SWJTAG_CONF_100 SWJTAG_GMUX_100
#define | EXT_SPIM_EN_MUX EXT_SPIM_GMUX_1000
#define | TMR9_GMUX IOMUX_MAKE_VALUE(0x20, 0, 4, 0x02)
#define | TMR10_GMUX IOMUX_MAKE_VALUE(0x20, 4, 4, 0x02)
#define | TMR11_GMUX IOMUX_MAKE_VALUE(0x20, 8, 4, 0x02)
#define | TMR1_GMUX_0001 IOMUX_MAKE_VALUE(0x24, 0, 4, 0x01)
#define | TMR2_GMUX_001 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x01)
#define | TMR2_GMUX_010 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x02)
#define | TMR2_GMUX_011 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x03)
#define | TMR2ITR1_GMUX IOMUX_MAKE_VALUE(0x24, 7, 1, 0x01)
#define | TMR3_GMUX_0010 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x02)
#define | TMR3_GMUX_0011 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x03)
#define | TMR5_GMUX_001 IOMUX_MAKE_VALUE(0x24, 16, 3, 0x01)
#define | TMR5CH4_GMUX IOMUX_MAKE_VALUE(0x24, 19, 1, 0x01)
#define | I2C1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x01)
#define | I2C1_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x03)
#define | I2C2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | I2C2_GMUX_0010 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | I2C2_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
#define | SPI1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 16, 4, 0x01)
#define | SPI2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 20, 4, 0x01)
#define | CAN1_GMUX_0010 IOMUX_MAKE_VALUE(0x2C, 0, 4, 0x02)
#define | CAN2_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 4, 4, 0x01)
#define | SDIO1_GMUX_0100 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x04)
#define | SDIO1_GMUX_0101 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x05)
#define | SDIO1_GMUX_0110 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x06)
#define | SDIO1_GMUX_0111 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x07)
#define | USART1_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 16, 4, 0x01)
#define | USART3_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 24, 4, 0x01)
#define | UART4_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 28, 4, 0x01)
#define | EXT_SPIM_GMUX_1000 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x08)
#define | EXT_SPIM_GMUX_1001 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x09)
#define | ADC1_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 4, 1, 0x01)
#define | ADC1_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 5, 1, 0x01)
#define | ADC2_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 8, 1, 0x01)
#define | ADC2_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 9, 1, 0x01)
#define | SWJTAG_GMUX_001 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x01)
#define | SWJTAG_GMUX_010 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x02)
#define | SWJTAG_GMUX_100 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x04)
#define | PD01_GMUX IOMUX_MAKE_VALUE(0x30, 20, 1, 0x01)
#define | GPIOA ((gpio_type *) GPIOA_BASE)
#define | GPIOB ((gpio_type *) GPIOB_BASE)
#define | GPIOC ((gpio_type *) GPIOC_BASE)
#define | GPIOD ((gpio_type *) GPIOD_BASE)
#define | GPIOF ((gpio_type *) GPIOF_BASE)
#define | IOMUX ((iomux_type *) IOMUX_BASE)

Enumerations

enum | gpio_mode_type { GPIO_MODE_INPUT = 0x00 , GPIO_MODE_OUTPUT = 0x10 , GPIO_MODE_MUX = 0x08 , GPIO_MODE_ANALOG = 0x03 }
gpio mode select More...
enum | gpio_drive_type { GPIO_DRIVE_STRENGTH_STRONGER = 0x01 , GPIO_DRIVE_STRENGTH_MODERATE = 0x02 , GPIO_DRIVE_STRENGTH_MAXIMUM = 0x03 }
gpio output drive strength select More...
enum | gpio_output_type { GPIO_OUTPUT_PUSH_PULL = 0x00 , GPIO_OUTPUT_OPEN_DRAIN = 0x04 }
gpio output type More...
enum | gpio_pull_type { GPIO_PULL_NONE = 0x0004 , GPIO_PULL_UP = 0x0018 , GPIO_PULL_DOWN = 0x0028 }
gpio pull type More...
enum gpio_pins_source_type {
GPIO_PINS_SOURCE0 = 0x00 , GPIO_PINS_SOURCE1 = 0x01 , GPIO_PINS_SOURCE2 = 0x02 , GPIO_PINS_SOURCE3 = 0x03 ,
GPIO_PINS_SOURCE4 = 0x04 , GPIO_PINS_SOURCE5 = 0x05 , GPIO_PINS_SOURCE6 = 0x06 , GPIO_PINS_SOURCE7 = 0x07 ,
GPIO_PINS_SOURCE8 = 0x08 , GPIO_PINS_SOURCE9 = 0x09 , GPIO_PINS_SOURCE10 = 0x0A , GPIO_PINS_SOURCE11 = 0x0B ,
GPIO_PINS_SOURCE12 = 0x0C , GPIO_PINS_SOURCE13 = 0x0D , GPIO_PINS_SOURCE14 = 0x0E , GPIO_PINS_SOURCE15 = 0x0F
}
gpio pins source type More...
enum gpio_port_source_type {
GPIO_PORT_SOURCE_GPIOA = 0x00 , GPIO_PORT_SOURCE_GPIOB = 0x01 , GPIO_PORT_SOURCE_GPIOC = 0x02 , GPIO_PORT_SOURCE_GPIOD = 0x03 ,
GPIO_PORT_SOURCE_GPIOF = 0x05
}
gpio port source type More...

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_iomux_reset (void)
reset the mux functions (remap, event control and exint configuration) registers to their default values. More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_wirte (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_event_output_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output. More...
void | gpio_event_output_enable (confirm_state new_state)
enable or disable the event output. More...
void | gpio_pin_remap_config (uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration. More...
void | gpio_exint_line_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line. More...

Detailed Description

at32f413 gpio header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_gpio.h.


AT32F413 Firmwary Library: at32f413_i2c.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_i2c.h File Reference

at32f413 i2c header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct i2c_type
type define i2c register all More...

Macros

#define | I2C_STARTF_FLAG ((uint32_t)0x00000001)
#define | I2C_ADDR7F_FLAG ((uint32_t)0x00000002)
#define | I2C_TDC_FLAG ((uint32_t)0x00000004)
#define | I2C_ADDRHF_FLAG ((uint32_t)0x00000008)
#define | I2C_STOPF_FLAG ((uint32_t)0x00000010)
#define | I2C_RDBF_FLAG ((uint32_t)0x00000040)
#define | I2C_TDBE_FLAG ((uint32_t)0x00000080)
#define | I2C_BUSERR_FLAG ((uint32_t)0x00000100)
#define | I2C_ARLOST_FLAG ((uint32_t)0x00000200)
#define | I2C_ACKFAIL_FLAG ((uint32_t)0x00000400)
#define | I2C_OUF_FLAG ((uint32_t)0x00000800)
#define | I2C_PECERR_FLAG ((uint32_t)0x00001000)
#define | I2C_TMOUT_FLAG ((uint32_t)0x00004000)
#define | I2C_ALERTF_FLAG ((uint32_t)0x00008000)
#define | I2C_TRMODE_FLAG ((uint32_t)0x10010000)
#define | I2C_BUSYF_FLAG ((uint32_t)0x10020000)
#define | I2C_DIRF_FLAG ((uint32_t)0x10040000)
#define | I2C_GCADDRF_FLAG ((uint32_t)0x10100000)
#define | I2C_DEVADDRF_FLAG ((uint32_t)0x10200000)
#define | I2C_HOSTADDRF_FLAG ((uint32_t)0x10400000)
#define | I2C_ADDR2_FLAG ((uint32_t)0x10800000)
#define | I2C_DATA_INT ((uint16_t)0x0400)
#define | I2C_EVT_INT ((uint16_t)0x0200)
#define | I2C_ERR_INT ((uint16_t)0x0100)
#define | I2C1 ((i2c_type *) I2C1_BASE)
#define | I2C2 ((i2c_type *) I2C2_BASE)

Enumerations

enum | i2c_master_ack_type { I2C_MASTER_ACK_CURRENT = 0x00 , I2C_MASTER_ACK_NEXT = 0x01 }
i2c master receiving mode acknowledge control More...
enum | i2c_pec_position_type { I2C_PEC_POSITION_CURRENT = 0x00 , I2C_PEC_POSITION_NEXT = 0x01 }
i2c pec position set More...
enum | i2c_smbus_alert_set_type { I2C_SMBUS_ALERT_HIGH = 0x00 , I2C_SMBUS_ALERT_LOW = 0x01 }
i2c smbus alert pin set More...
enum | i2c_smbus_mode_set_type { I2C_SMBUS_MODE_DEVICE = 0x00 , I2C_SMBUS_MODE_HOST = 0x01 }
i2c smbus mode set More...
enum | i2c_fsmode_duty_cycle_type { I2C_FSMODE_DUTY_2_1 = 0x00 , I2C_FSMODE_DUTY_16_9 = 0x01 }
i2c fast mode duty cycle More...
enum | i2c_address_mode_type { I2C_ADDRESS_MODE_7BIT = 0x00 , I2C_ADDRESS_MODE_10BIT = 0x01 }
i2c address mode More...
enum | i2c_direction_type { I2C_DIRECTION_TRANSMIT = 0x00 , I2C_DIRECTION_RECEIVE = 0x01 }
i2c address direction More...

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_software_reset (i2c_type *i2c_x, confirm_state new_state)
software reset. More...
void | i2c_init (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address)
config own address2. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph More...
void | i2c_fast_mode_duty_set (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge. More...
void | i2c_master_receive_ack_set (i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control. More...
void | i2c_pec_position_set (i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call. More...
void | i2c_arp_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode. More...
void | i2c_smbus_mode_set (i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get pec value. More...
void | i2c_dma_end_transfer_set (i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one. More...
void | i2c_dma_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_7bit_address_send (i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

at32f413 i2c header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_i2c.h.


AT32F413 Firmwary Library: at32f413_misc.h File Reference

  • libraries
  • drivers
  • inc
Macros | Enumerations | Functions
at32f413_misc.h File Reference

at32f413 misc header file More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define | NVIC_VECTTAB_RAM ((uint32_t)0x20000000)
#define | NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)

Enumerations

enum nvic_priority_group_type {
NVIC_PRIORITY_GROUP_0 = ((uint32_t)0x7) , NVIC_PRIORITY_GROUP_1 = ((uint32_t)0x6) , NVIC_PRIORITY_GROUP_2 = ((uint32_t)0x5) , NVIC_PRIORITY_GROUP_3 = ((uint32_t)0x4) ,
NVIC_PRIORITY_GROUP_4 = ((uint32_t)0x3)
}
nvic interrupt priority group More...
enum | nvic_lowpower_mode_type { NVIC_LP_SLEEPONEXIT = 0x02 , NVIC_LP_SLEEPDEEP = 0x04 , NVIC_LP_SEVONPEND = 0x10 }
nvic low power mode More...
enum | systick_clock_source_type { SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 = ((uint32_t)0x00000000) , SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV = ((uint32_t)0x00000004) }
systick clock source More...

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

at32f413 misc header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_misc.h.


AT32F413 Firmwary Library: at32f413_pwc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_pwc.h File Reference

at32f413 pwc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct pwc_type
type define pwc register all More...

Macros

#define | PWC_WAKEUP_FLAG ((uint32_t)0x00000001)
#define | PWC_STANDBY_FLAG ((uint32_t)0x00000002)
#define | PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)
#define | PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)
pwc wakeup pin num definition More...
#define | PWC ((pwc_type *) PWC_BASE)

Enumerations

enum pwc_pvm_voltage_type {
PWC_PVM_VOLTAGE_2V3 = 0x01 , PWC_PVM_VOLTAGE_2V4 = 0x02 , PWC_PVM_VOLTAGE_2V5 = 0x03 , PWC_PVM_VOLTAGE_2V6 = 0x04 ,
PWC_PVM_VOLTAGE_2V7 = 0x05 , PWC_PVM_VOLTAGE_2V8 = 0x06 , PWC_PVM_VOLTAGE_2V9 = 0x07
}
pwc pvm voltage type More...
enum | pwc_sleep_enter_type { PWC_SLEEP_ENTER_WFI = 0x00 , PWC_SLEEP_ENTER_WFE = 0x01 }
pwc sleep enter type More...
enum | pwc_deep_sleep_enter_type { PWC_DEEP_SLEEP_ENTER_WFI = 0x00 , PWC_DEEP_SLEEP_ENTER_WFE = 0x01 }
pwc deep sleep enter type More...
enum | pwc_regulator_type { PWC_REGULATOR_ON = 0x00 , PWC_REGULATOR_LOW_POWER = 0x01 }
pwc regulator type More...

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_voltage_regulate_set (pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

at32f413 pwc header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_pwc.h.


AT32F413 Firmwary Library: at32f413_rtc.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Functions
at32f413_rtc.h File Reference

at32f413 rtc header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct rtc_type
type define rtc register all More...

Macros

#define | RTC_TS_INT ((uint16_t)0x0001)
#define | RTC_TA_INT ((uint16_t)0x0002)
#define | RTC_OVF_INT ((uint16_t)0x0004)
#define | RTC_TS_FLAG ((uint16_t)0x0001)
#define | RTC_TA_FLAG ((uint16_t)0x0002)
#define | RTC_OVF_FLAG ((uint16_t)0x0004)
#define | RTC_UPDF_FLAG ((uint16_t)0x0008)
#define | RTC_CFGF_FLAG ((uint16_t)0x0020)
#define | RTC ((rtc_type *) RTC_BASE)

Functions

void | rtc_counter_set (uint32_t counter_value)
rtc counter set More...
uint32_t | rtc_counter_get (void)
rtc counter get More...
void | rtc_divider_set (uint32_t div_value)
rtc divider set More...
uint32_t | rtc_divider_get (void)
rtc divider get More...
void | rtc_alarm_set (uint32_t alarm_value)
rtc alarm value set More...
void | rtc_interrupt_enable (uint16_t source, confirm_state new_state)
rtc interrupt enable More...
flag_status | rtc_flag_get (uint16_t flag)
rtc flag get More...
void | rtc_flag_clear (uint16_t flag)
rtc flag clear More...
void | rtc_wait_config_finish (void)
rtc wait configuration finish More...
void | rtc_wait_update_finish (void)
rtc wait update finish More...

Detailed Description

at32f413 rtc header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_rtc.h.


AT32F413 Firmwary Library: at32f413_sdio.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_sdio.h File Reference

at32f413 sdio header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | sdio_command_struct_type
sdio command structure More...
struct | sdio_data_struct_type
sdio data structure More...
struct | sdio_type
type define sdio register all More...

Macros

#define | SDIO_CMDFAIL_INT ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_INT ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)
#define | SDIO_TXERRU_INT ((uint32_t)0x00000010)
#define | SDIO_RXERRO_INT ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_INT ((uint32_t)0x00000080)
#define | SDIO_DTCMP_INT ((uint32_t)0x00000100)
#define | SDIO_SBITERR_INT ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)
#define | SDIO_DOCMD_INT ((uint32_t)0x00000800)
#define | SDIO_DOTX_INT ((uint32_t)0x00001000)
#define | SDIO_DORX_INT ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_INT ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_INT ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_INT ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_INT ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_INT ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_INT ((uint32_t)0x00080000)
#define | SDIO_TXBUF_INT ((uint32_t)0x00100000)
#define | SDIO_RXBUF_INT ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_INT ((uint32_t)0x00400000)
#define | SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)
#define | SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)
#define | SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)
#define | SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)
#define | SDIO_TXERRU_FLAG ((uint32_t)0x00000010)
#define | SDIO_RXERRO_FLAG ((uint32_t)0x00000020)
#define | SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)
#define | SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)
#define | SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)
#define | SDIO_SBITERR_FLAG ((uint32_t)0x00000200)
#define | SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)
#define | SDIO_DOCMD_FLAG ((uint32_t)0x00000800)
#define | SDIO_DOTX_FLAG ((uint32_t)0x00001000)
#define | SDIO_DORX_FLAG ((uint32_t)0x00002000)
#define | SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)
#define | SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)
#define | SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)
#define | SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)
#define | SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)
#define | SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)
#define | SDIO_TXBUF_FLAG ((uint32_t)0x00100000)
#define | SDIO_RXBUF_FLAG ((uint32_t)0x00200000)
#define | SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)
#define | SDIO1 ((sdio_type *) SDIO1_BASE)

Enumerations

enum | sdio_power_state_type { SDIO_POWER_OFF = 0x00 , SDIO_POWER_ON = 0x03 }
sdio power state More...
enum | sdio_edge_phase_type { SDIO_CLOCK_EDGE_RISING = 0x00 , SDIO_CLOCK_EDGE_FALLING = 0x01 }
sdio edge phase More...
enum | sdio_bus_width_type { SDIO_BUS_WIDTH_D1 = 0x00 , SDIO_BUS_WIDTH_D4 = 0x01 , SDIO_BUS_WIDTH_D8 = 0x02 }
sdio bus width More...
enum | sdio_reponse_type { SDIO_RESPONSE_NO = 0x00 , SDIO_RESPONSE_SHORT = 0x01 , SDIO_RESPONSE_LONG = 0x03 }
sdio response type More...
enum | sdio_wait_type { SDIO_WAIT_FOR_NO = 0x00 , SDIO_WAIT_FOR_INT = 0x01 , SDIO_WAIT_FOR_PEND = 0x02 }
sdio wait type More...
enum | sdio_rsp_index_type { SDIO_RSP1_INDEX = 0x00 , SDIO_RSP2_INDEX = 0x01 , SDIO_RSP3_INDEX = 0x02 , SDIO_RSP4_INDEX = 0x03 }
sdio response register index More...
enum sdio_block_size_type {
SDIO_DATA_BLOCK_SIZE_1B = 0x00 , SDIO_DATA_BLOCK_SIZE_2B = 0x01 , SDIO_DATA_BLOCK_SIZE_4B = 0x02 , SDIO_DATA_BLOCK_SIZE_8B = 0x03 ,
SDIO_DATA_BLOCK_SIZE_16B = 0x04 , SDIO_DATA_BLOCK_SIZE_32B = 0x05 , SDIO_DATA_BLOCK_SIZE_64B = 0x06 , SDIO_DATA_BLOCK_SIZE_128B = 0x07 ,
SDIO_DATA_BLOCK_SIZE_256B = 0x08 , SDIO_DATA_BLOCK_SIZE_512B = 0x09 , SDIO_DATA_BLOCK_SIZE_1024B = 0x0A , SDIO_DATA_BLOCK_SIZE_2048B = 0x0B ,
SDIO_DATA_BLOCK_SIZE_4096B = 0x0C , SDIO_DATA_BLOCK_SIZE_8192B = 0x0D , SDIO_DATA_BLOCK_SIZE_16384B = 0x0E
}
sdio data block size More...
enum | sdio_transfer_mode_type { SDIO_DATA_BLOCK_TRANSFER = 0x00 , SDIO_DATA_STREAM_TRANSFER = 0x01 }
sdio data transfer mode More...
enum | sdio_transfer_direction_type { SDIO_DATA_TRANSFER_TO_CARD = 0x00 , SDIO_DATA_TRANSFER_TO_CONTROLLER = 0x01 }
sdio data transfer direction More...
enum | sdio_read_wait_mode_type { SDIO_READ_WAIT_CONTROLLED_BY_D2 = 0x00 , SDIO_READ_WAIT_CONTROLLED_BY_CK = 0x01 }
sdio read wait mode More...

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
flag_status | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

at32f413 sdio header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_sdio.h.


AT32F413 Firmwary Library: at32f413_spi.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_spi.h File Reference

at32f413 spi header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | spi_init_type
spi init type More...
struct | i2s_init_type
i2s init type More...
struct | spi_type
type define spi register all More...

Macros

#define | SPI_I2S_RDBF_FLAG 0x0001
#define | SPI_I2S_TDBE_FLAG 0x0002
#define | I2S_ACS_FLAG 0x0004
#define | I2S_TUERR_FLAG 0x0008
#define | SPI_CCERR_FLAG 0x0010
#define | SPI_MMERR_FLAG 0x0020
#define | SPI_I2S_ROERR_FLAG 0x0040
#define | SPI_I2S_BF_FLAG 0x0080
#define | SPI_I2S_ERROR_INT 0x0020
#define | SPI_I2S_RDBF_INT 0x0040
#define | SPI_I2S_TDBE_INT 0x0080
#define | SPI1 ((spi_type *) SPI1_BASE)
#define | SPI2 ((spi_type *) SPI2_BASE)

Enumerations

enum | spi_frame_bit_num_type { SPI_FRAME_8BIT = 0x00 , SPI_FRAME_16BIT = 0x01 }
spi frame bit num type More...
enum | spi_master_slave_mode_type { SPI_MODE_SLAVE = 0x00 , SPI_MODE_MASTER = 0x01 }
spi master/slave mode type More...
enum | spi_clock_polarity_type { SPI_CLOCK_POLARITY_LOW = 0x00 , SPI_CLOCK_POLARITY_HIGH = 0x01 }
spi clock polarity (clkpol) type More...
enum | spi_clock_phase_type { SPI_CLOCK_PHASE_1EDGE = 0x00 , SPI_CLOCK_PHASE_2EDGE = 0x01 }
spi clock phase (clkpha) type More...
enum | spi_cs_mode_type { SPI_CS_HARDWARE_MODE = 0x00 , SPI_CS_SOFTWARE_MODE = 0x01 }
spi cs mode type More...
enum spi_mclk_freq_div_type {
SPI_MCLK_DIV_2 = 0x00 , SPI_MCLK_DIV_4 = 0x01 , SPI_MCLK_DIV_8 = 0x02 , SPI_MCLK_DIV_16 = 0x03 ,
SPI_MCLK_DIV_32 = 0x04 , SPI_MCLK_DIV_64 = 0x05 , SPI_MCLK_DIV_128 = 0x06 , SPI_MCLK_DIV_256 = 0x07 ,
SPI_MCLK_DIV_512 = 0x08 , SPI_MCLK_DIV_1024 = 0x09
}
spi master clock frequency division type More...
enum | spi_first_bit_type { SPI_FIRST_BIT_MSB = 0x00 , SPI_FIRST_BIT_LSB = 0x01 }
spi transmit first bit (lsb/msb) type More...
enum | spi_transmission_mode_type { SPI_TRANSMIT_FULL_DUPLEX = 0x00 , SPI_TRANSMIT_SIMPLEX_RX = 0x01 , SPI_TRANSMIT_HALF_DUPLEX_RX = 0x02 , SPI_TRANSMIT_HALF_DUPLEX_TX = 0x03 }
spi transmission mode type More...
enum | spi_crc_direction_type { SPI_CRC_RX = 0x0014 , SPI_CRC_TX = 0x0018 }
spi crc direction type More...
enum | spi_half_duplex_direction_type { SPI_HALF_DUPLEX_DIRECTION_RX = 0x00 , SPI_HALF_DUPLEX_DIRECTION_TX = 0x01 }
spi single line bidirectional direction type More...
enum | spi_software_cs_level_type { SPI_SWCS_INTERNAL_LEVEL_LOW = 0x00 , SPI_SWCS_INTERNAL_LEVEL_HIGHT = 0x01 }
spi software cs internal level type More...
enum i2s_audio_protocol_type {
I2S_AUDIO_PROTOCOL_PHILLIPS = 0x00 , I2S_AUDIO_PROTOCOL_MSB = 0x01 , I2S_AUDIO_PROTOCOL_LSB = 0x02 , I2S_AUDIO_PROTOCOL_PCM_SHORT = 0x03 ,
I2S_AUDIO_PROTOCOL_PCM_LONG = 0x04
}
i2s audio protocol type More...
enum i2s_audio_sampling_freq_type {
I2S_AUDIO_FREQUENCY_DEFAULT = 2 , I2S_AUDIO_FREQUENCY_8K = 8000 , I2S_AUDIO_FREQUENCY_11_025K = 11025 , I2S_AUDIO_FREQUENCY_16K = 16000 ,
I2S_AUDIO_FREQUENCY_22_05K = 22050 , I2S_AUDIO_FREQUENCY_32K = 32000 , I2S_AUDIO_FREQUENCY_44_1K = 44100 , I2S_AUDIO_FREQUENCY_48K = 48000 ,
I2S_AUDIO_FREQUENCY_96K = 96000 , I2S_AUDIO_FREQUENCY_192K = 192000
}
i2s audio frequency type More...
enum | i2s_data_channel_format_type { I2S_DATA_16BIT_CHANNEL_16BIT = 0x01 , I2S_DATA_16BIT_CHANNEL_32BIT = 0x02 , I2S_DATA_24BIT_CHANNEL_32BIT = 0x03 , I2S_DATA_32BIT_CHANNEL_32BIT = 0x04 }
i2s data bit num and channel bit num type More...
enum | i2s_operation_mode_type { I2S_MODE_SLAVE_TX = 0x00 , I2S_MODE_SLAVE_RX = 0x01 , I2S_MODE_MASTER_TX = 0x02 , I2S_MODE_MASTER_RX = 0x03 }
i2s operation mode type More...
enum | i2s_clock_polarity_type { I2S_CLOCK_POLARITY_LOW = 0x00 , I2S_CLOCK_POLARITY_HIGH = 0x01 }
i2s clock polarity type More...

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

at32f413 spi header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_spi.h.


AT32F413 Firmwary Library: at32f413_tmr.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_tmr.h File Reference

at32f413 tmr header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | tmr_output_config_type
tmr output config type More...
struct | tmr_input_config_type
tmr input capture config type More...
struct | tmr_brkdt_config_type
tmr brkdt config type More...
struct | tmr_type
type define tmr register all More...

Macros

#define | TMR_OVF_FLAG ((uint32_t)0x000001)
#define | TMR_C1_FLAG ((uint32_t)0x000002)
#define | TMR_C2_FLAG ((uint32_t)0x000004)
#define | TMR_C3_FLAG ((uint32_t)0x000008)
#define | TMR_C4_FLAG ((uint32_t)0x000010)
#define | TMR_HALL_FLAG ((uint32_t)0x000020)
#define | TMR_TRIGGER_FLAG ((uint32_t)0x000040)
#define | TMR_BRK_FLAG ((uint32_t)0x000080)
#define | TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)
#define | TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)
#define | TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)
#define | TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)
#define | TMR_OVF_INT ((uint32_t)0x000001)
#define | TMR_C1_INT ((uint32_t)0x000002)
#define | TMR_C2_INT ((uint32_t)0x000004)
#define | TMR_C3_INT ((uint32_t)0x000008)
#define | TMR_C4_INT ((uint32_t)0x000010)
#define | TMR_HALL_INT ((uint32_t)0x000020)
#define | TMR_TRIGGER_INT ((uint32_t)0x000040)
#define | TMR_BRK_INT ((uint32_t)0x000080)
#define | TMR1 ((tmr_type *) TMR1_BASE)
#define | TMR2 ((tmr_type *) TMR2_BASE)
#define | TMR3 ((tmr_type *) TMR3_BASE)
#define | TMR4 ((tmr_type *) TMR4_BASE)
#define | TMR5 ((tmr_type *) TMR5_BASE)
#define | TMR8 ((tmr_type *) TMR8_BASE)
#define | TMR9 ((tmr_type *) TMR9_BASE)
#define | TMR10 ((tmr_type *) TMR10_BASE)
#define | TMR11 ((tmr_type *) TMR11_BASE)

Enumerations

enum | tmr_clock_division_type { TMR_CLOCK_DIV1 = 0x00 , TMR_CLOCK_DIV2 = 0x01 , TMR_CLOCK_DIV4 = 0x02 }
tmr clock division type More...
enum tmr_count_mode_type {
TMR_COUNT_UP = 0x00 , TMR_COUNT_DOWN = 0x01 , TMR_COUNT_TWO_WAY_1 = 0x02 , TMR_COUNT_TWO_WAY_2 = 0x04 ,
TMR_COUNT_TWO_WAY_3 = 0x06
}
tmr counter mode type More...
enum tmr_primary_select_type {
TMR_PRIMARY_SEL_RESET = 0x00 , TMR_PRIMARY_SEL_ENABLE = 0x01 , TMR_PRIMARY_SEL_OVERFLOW = 0x02 , TMR_PRIMARY_SEL_COMPARE = 0x03 ,
TMR_PRIMARY_SEL_C1ORAW = 0x04 , TMR_PRIMARY_SEL_C2ORAW = 0x05 , TMR_PRIMARY_SEL_C3ORAW = 0x06 , TMR_PRIMARY_SEL_C4ORAW = 0x07
}
tmr primary mode select type More...
enum sub_tmr_input_sel_type {
TMR_SUB_INPUT_SEL_IS0 = 0x00 , TMR_SUB_INPUT_SEL_IS1 = 0x01 , TMR_SUB_INPUT_SEL_IS2 = 0x02 , TMR_SUB_INPUT_SEL_IS3 = 0x03 ,
TMR_SUB_INPUT_SEL_C1INC = 0x04 , TMR_SUB_INPUT_SEL_C1DF1 = 0x05 , TMR_SUB_INPUT_SEL_C2DF2 = 0x06 , TMR_SUB_INPUT_SEL_EXTIN = 0x07
}
tmr subordinate mode input select type More...
enum tmr_sub_mode_select_type {
TMR_SUB_MODE_DIABLE = 0x00 , TMR_SUB_ENCODER_MODE_A = 0x01 , TMR_SUB_ENCODER_MODE_B = 0x02 , TMR_SUB_ENCODER_MODE_C = 0x03 ,
TMR_SUB_RESET_MODE = 0x04 , TMR_SUB_HANG_MODE = 0x05 , TMR_SUB_TRIGGER_MODE = 0x06 , TMR_SUB_EXTERNAL_CLOCK_MODE_A = 0x07
}
tmr subordinate mode select type More...
enum | tmr_encoder_mode_type { TMR_ENCODER_MODE_A = TMR_SUB_ENCODER_MODE_A , TMR_ENCODER_MODE_B = TMR_SUB_ENCODER_MODE_B , TMR_ENCODER_MODE_C = TMR_SUB_ENCODER_MODE_C }
tmr encoder mode type More...
enum tmr_output_control_mode_type {
TMR_OUTPUT_CONTROL_OFF = 0x00 , TMR_OUTPUT_CONTROL_HIGH = 0x01 , TMR_OUTPUT_CONTROL_LOW = 0x02 , TMR_OUTPUT_CONTROL_SWITCH = 0x03 ,
TMR_OUTPUT_CONTROL_FORCE_LOW = 0x04 , TMR_OUTPUT_CONTROL_FORCE_HIGH = 0x05 , TMR_OUTPUT_CONTROL_PWM_MODE_A = 0x06 , TMR_OUTPUT_CONTROL_PWM_MODE_B = 0x07
}
tmr output control mode type More...
enum | tmr_force_output_type { TMR_FORCE_OUTPUT_HIGH = TMR_OUTPUT_CONTROL_FORCE_HIGH , TMR_FORCE_OUTPUT_LOW = TMR_OUTPUT_CONTROL_FORCE_LOW }
tmr force output type More...
enum | tmr_output_polarity_type { TMR_OUTPUT_ACTIVE_HIGH = 0x00 , TMR_OUTPUT_ACTIVE_LOW = 0x01 }
tmr output channel polarity type More...
enum | tmr_input_polarity_type { TMR_INPUT_RISING_EDGE = 0x00 , TMR_INPUT_FALLING_EDGE = 0x01 , TMR_INPUT_BOTH_EDGE = 0x03 }
tmr input channel polarity type More...
enum tmr_channel_select_type {
TMR_SELECT_CHANNEL_1 = 0x00 , TMR_SELECT_CHANNEL_1C = 0x01 , TMR_SELECT_CHANNEL_2 = 0x02 , TMR_SELECT_CHANNEL_2C = 0x03 ,
TMR_SELECT_CHANNEL_3 = 0x04 , TMR_SELECT_CHANNEL_3C = 0x05 , TMR_SELECT_CHANNEL_4 = 0x06
}
tmr channel select type More...
enum | tmr_channel1_input_connected_type { TMR_CHANEL1_CONNECTED_C1IRAW = 0x00 , TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR = 0x01 }
tmr channel1 input connected type More...
enum | tmr_input_direction_mapped_type { TMR_CC_CHANNEL_MAPPED_DIRECT = 0x01 , TMR_CC_CHANNEL_MAPPED_INDIRECT = 0x02 , TMR_CC_CHANNEL_MAPPED_STI = 0x03 }
tmr input channel mapped type channel direction More...
enum | tmr_channel_input_divider_type { TMR_CHANNEL_INPUT_DIV_1 = 0x00 , TMR_CHANNEL_INPUT_DIV_2 = 0x01 , TMR_CHANNEL_INPUT_DIV_4 = 0x02 , TMR_CHANNEL_INPUT_DIV_8 = 0x03 }
tmr input divider type More...
enum | tmr_dma_request_source_type { TMR_DMA_REQUEST_BY_CHANNEL = 0x00 , TMR_DMA_REQUEST_BY_OVERFLOW = 0x01 }
tmr dma request source select type More...
enum tmr_dma_request_type {
TMR_OVERFLOW_DMA_REQUEST = 0x00000100 , TMR_C1_DMA_REQUEST = 0x00000200 , TMR_C2_DMA_REQUEST = 0x00000400 , TMR_C3_DMA_REQUEST = 0x00000800 ,
TMR_C4_DMA_REQUEST = 0x00001000 , TMR_HALL_DMA_REQUEST = 0x00002000 , TMR_TRIGGER_DMA_REQUEST = 0x00004000
}
tmr dma request type More...
enum tmr_event_trigger_type {
TMR_OVERFLOW_SWTRIG = 0x00000001 , TMR_C1_SWTRIG = 0x00000002 , TMR_C2_SWTRIG = 0x00000004 , TMR_C3_SWTRIG = 0x00000008 ,
TMR_C4_SWTRIG = 0x00000010 , TMR_HALL_SWTRIG = 0x00000020 , TMR_TRIGGER_SWTRIG = 0x00000040 , TMR_BRK_SWTRIG = 0x00000080
}
tmr event triggered by software type More...
enum | tmr_polarity_active_type { TMR_POLARITY_ACTIVE_HIGH = 0x00 , TMR_POLARITY_ACTIVE_LOW = 0x01 , TMR_POLARITY_ACTIVE_BOTH = 0x02 }
tmr polarity active type More...
enum | tmr_external_signal_divider_type { TMR_ES_FREQUENCY_DIV_1 = 0x00 , TMR_ES_FREQUENCY_DIV_2 = 0x01 , TMR_ES_FREQUENCY_DIV_4 = 0x02 , TMR_ES_FREQUENCY_DIV_8 = 0x03 }
tmr external signal divider type More...
enum | tmr_external_signal_polarity_type { TMR_ES_POLARITY_NON_INVERTED = 0x00 , TMR_ES_POLARITY_INVERTED = 0x01 }
tmr external signal polarity type More...
enum tmr_dma_transfer_length_type {
TMR_DMA_TRANSFER_1BYTE = 0x00 , TMR_DMA_TRANSFER_2BYTES = 0x01 , TMR_DMA_TRANSFER_3BYTES = 0x02 , TMR_DMA_TRANSFER_4BYTES = 0x03 ,
TMR_DMA_TRANSFER_5BYTES = 0x04 , TMR_DMA_TRANSFER_6BYTES = 0x05 , TMR_DMA_TRANSFER_7BYTES = 0x06 , TMR_DMA_TRANSFER_8BYTES = 0x07 ,
TMR_DMA_TRANSFER_9BYTES = 0x08 , TMR_DMA_TRANSFER_10BYTES = 0x09 , TMR_DMA_TRANSFER_11BYTES = 0x0A , TMR_DMA_TRANSFER_12BYTES = 0x0B ,
TMR_DMA_TRANSFER_13BYTES = 0x0C , TMR_DMA_TRANSFER_14BYTES = 0x0D , TMR_DMA_TRANSFER_15BYTES = 0x0E , TMR_DMA_TRANSFER_16BYTES = 0x0F ,
TMR_DMA_TRANSFER_17BYTES = 0x10 , TMR_DMA_TRANSFER_18BYTES = 0x11
}
tmr dma transfer length type More...
enum tmr_dma_address_type {
TMR_CTRL1_ADDRESS = 0x0000 , TMR_CTRL2_ADDRESS = 0x0001 , TMR_STCTRL_ADDRESS = 0x0002 , TMR_IDEN_ADDRESS = 0x0003 ,
TMR_ISTS_ADDRESS = 0x0004 , TMR_SWEVT_ADDRESS = 0x0005 , TMR_CM1_ADDRESS = 0x0006 , TMR_CM2_ADDRESS = 0x0007 ,
TMR_CCTRL_ADDRESS = 0x0008 , TMR_CVAL_ADDRESS = 0x0009 , TMR_DIV_ADDRESS = 0x000A , TMR_PR_ADDRESS = 0x000B ,
TMR_RPR_ADDRESS = 0x000C , TMR_C1DT_ADDRESS = 0x000D , TMR_C2DT_ADDRESS = 0x000E , TMR_C3DT_ADDRESS = 0x000F ,
TMR_C4DT_ADDRESS = 0x0010 , TMR_BRK_ADDRESS = 0x0011 , TMR_DMACTRL_ADDRESS = 0x0012
}
tmr dma base address type More...
enum | tmr_brk_polarity_type { TMR_BRK_INPUT_ACTIVE_LOW = 0x00 , TMR_BRK_INPUT_ACTIVE_HIGH = 0x01 }
tmr brk polarity type More...
enum | tmr_wp_level_type { TMR_WP_OFF = 0x00 , TMR_WP_LEVEL_3 = 0x01 , TMR_WP_LEVEL_2 = 0x02 , TMR_WP_LEVEL_1 = 0x03 }
tmr write protect level type More...

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ti1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time More...

Detailed Description

at32f413 tmr header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_tmr.h.


AT32F413 Firmwary Library: at32f413_usart.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_usart.h File Reference

at32f413 usart header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct usart_type
type define usart register all More...

Macros

#define | USART_PERR_FLAG ((uint32_t)0x00000001)
#define | USART_FERR_FLAG ((uint32_t)0x00000002)
#define | USART_NERR_FLAG ((uint32_t)0x00000004)
#define | USART_ROERR_FLAG ((uint32_t)0x00000008)
#define | USART_IDLEF_FLAG ((uint32_t)0x00000010)
#define | USART_RDBF_FLAG ((uint32_t)0x00000020)
#define | USART_TDC_FLAG ((uint32_t)0x00000040)
#define | USART_TDBE_FLAG ((uint32_t)0x00000080)
#define | USART_BFF_FLAG ((uint32_t)0x00000100)
#define | USART_CTSCF_FLAG ((uint32_t)0x00000200)
#define | USART_IDLE_INT MAKE_VALUE(0x0C,0x04)
#define | USART_RDBF_INT MAKE_VALUE(0x0C,0x05)
#define | USART_TDC_INT MAKE_VALUE(0x0C,0x06)
#define | USART_TDBE_INT MAKE_VALUE(0x0C,0x07)
#define | USART_PERR_INT MAKE_VALUE(0x0C,0x08)
#define | USART_BF_INT MAKE_VALUE(0x10,0x06)
#define | USART_ERR_INT MAKE_VALUE(0x14,0x00)
#define | USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)
#define | USART1 ((usart_type *) USART1_BASE)
#define | USART2 ((usart_type *) USART2_BASE)
#define | USART3 ((usart_type *) USART3_BASE)
#define | UART4 ((usart_type *) UART4_BASE)
#define | UART5 ((usart_type *) UART5_BASE)

Enumerations

enum | usart_parity_selection_type { USART_PARITY_NONE = 0x00 , USART_PARITY_EVEN = 0x01 , USART_PARITY_ODD = 0x02 }
usart parity selection type More...
enum | usart_wakeup_mode_type { USART_WAKEUP_BY_IDLE_FRAME = 0x00 , USART_WAKEUP_BY_MATCHING_ID = 0x01 }
usart wakeup mode type More...
enum | usart_data_bit_num_type { USART_DATA_8BITS = 0x00 , USART_DATA_9BITS = 0x01 }
usart data bit num type More...
enum | usart_break_bit_num_type { USART_BREAK_10BITS = 0x00 , USART_BREAK_11BITS = 0x01 }
usart break frame bit num type More...
enum | usart_clock_phase_type { USART_CLOCK_PHASE_1EDGE = 0x00 , USART_CLOCK_PHASE_2EDGE = 0x01 }
usart phase of the clock type More...
enum | usart_clock_polarity_type { USART_CLOCK_POLARITY_LOW = 0x00 , USART_CLOCK_POLARITY_HIGH = 0x01 }
usart polarity of the clock type More...
enum | usart_lbcp_type { USART_CLOCK_LAST_BIT_NONE = 0x00 , USART_CLOCK_LAST_BIT_OUTPUT = 0x01 }
usart last bit clock pulse type More...
enum | usart_stop_bit_num_type { USART_STOP_1_BIT = 0x00 , USART_STOP_0_5_BIT = 0x01 , USART_STOP_2_BIT = 0x02 , USART_STOP_1_5_BIT = 0x03 }
usart stop bit num type More...
enum | usart_hardware_flow_control_type { USART_HARDWARE_FLOW_NONE = 0x00 , USART_HARDWARE_FLOW_RTS = 0x01 , USART_HARDWARE_FLOW_CTS = 0x02 , USART_HARDWARE_FLOW_RTS_CTS = 0x03 }
usart hardware flow control type More...

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...

Detailed Description

at32f413 usart header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_usart.h.


AT32F413 Firmwary Library: at32f413_usb.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Typedefs | Enumerations | Functions | Variables
at32f413_usb.h File Reference

at32f413 usb header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | usb_ept_info
usb endpoint infomation structure definition More...
struct | usbd_type
type define usb register all More...

Macros

#define | USB_LSOF_INT ((uint32_t)0x00000100)
#define | USB_SOF_INT ((uint32_t)0x00000200)
#define | USB_RST_INT ((uint32_t)0x00000400)
#define | USB_SP_INT ((uint32_t)0x00000800)
#define | USB_WK_INT ((uint32_t)0x00001000)
#define | USB_BE_INT ((uint32_t)0x00002000)
#define | USB_UCFOR_INT ((uint32_t)0x00004000)
#define | USB_TC_INT ((uint32_t)0x00008000)
#define | USB_EPT_NUM_FLAG ((uint32_t)0x0000000F)
#define | USB_INOUT_FLAG ((uint32_t)0x00000010)
#define | USB_LSOF_FLAG ((uint32_t)0x00000100)
#define | USB_SOF_FLAG ((uint32_t)0x00000200)
#define | USB_RST_FLAG ((uint32_t)0x00000400)
#define | USB_SP_FLAG ((uint32_t)0x00000800)
#define | USB_WK_FLAG ((uint32_t)0x00001000)
#define | USB_BE_FLAG ((uint32_t)0x00002000)
#define | USB_UCFOR_FLAG ((uint32_t)0x00004000)
#define | USB_TC_FLAG ((uint32_t)0x00008000)
#define | USB_EPTADDR ((uint32_t)0x0000000F)
#define | USB_TXSTS ((uint32_t)0x00000030)
#define | USB_TXDTS ((uint32_t)0x00000040)
#define | USB_TXTC ((uint32_t)0x00000080)
#define | USB_EXF ((uint32_t)0x00000100)
#define | USB_TRANS_TYPE ((uint32_t)0x00000600)
#define | USB_SETUPTC ((uint32_t)0x00000800)
#define | USB_RXSTS ((uint32_t)0x00003000)
#define | USB_RXDTS ((uint32_t)0x00004000)
#define | USB_RXTC ((uint32_t)0x00008000)
#define | USB_EPT_BIT_MASK (uint32_t)(USB_TXTC | USB_SETUPTC | USB_EPTADDR | USB_EXF | USB_RXTC | USB_TRANS_TYPE)
#define | USB_TX_MASK (USB_TXSTS | USB_EPT_BIT_MASK)
#define | USB_RX_MASK (USB_RXSTS | USB_EPT_BIT_MASK)
#define | USB_TX_DISABLE ((uint32_t)0x00000000)
#define | USB_TX_STALL ((uint32_t)0x00000010)
#define | USB_TX_NAK ((uint32_t)0x00000020)
#define | USB_TX_VALID ((uint32_t)0x00000030)
#define | USB_TXDTS0 ((uint32_t)0x00000010)
#define | USB_TXDTS1 ((uint32_t)0x00000020)
#define | USB_RX_DISABLE ((uint32_t)0x00000000)
#define | USB_RX_STALL ((uint32_t)0x00001000)
#define | USB_RX_NAK ((uint32_t)0x00002000)
#define | USB_RX_VALID ((uint32_t)0x00003000)
#define | USB_RXDTS0 ((uint32_t)0x00001000)
#define | USB_RXDTS1 ((uint32_t)0x00002000)
#define | USB_EPT_CONTROL ((uint32_t)0x00000200)
#define | USB_EPT_BULK ((uint32_t)0x00000000)
#define | USB_EPT_INT ((uint32_t)0x00000600)
#define | USB_EPT_ISO ((uint32_t)0x00000400)
#define | USB_BUFFER_TABLE_ADDRESS 0x0000
#define | USB_PACKET_BUFFER_ADDRESS 0x40006000
#define | USB_PACKET_BUFFER_ADDRESS_EX 0x40007800
#define | USB_SET_TXSTS(ept_num, new_sts)
set usb endpoint tx status More...
#define | USB_SET_RXSTS(ept_num, new_sts)
set usb endpoint rx status More...
#define | GET_TX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 2) * 2 + g_usb_packet_address)
get usb endpoint tx/rx length address More...
#define | GET_RX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 6) * 2 + g_usb_packet_address)
#define | USB_GET_TX_LEN(eptn) ((uint16_t)(*GET_TX_LEN_ADDR(eptn)) & 0x3ff)
get usb endpoint tx/rx data length More...
#define | USB_GET_RX_LEN(eptn) ((uint16_t)(*GET_RX_LEN_ADDR(eptn)) & 0x3ff)
#define | USB_DBUF0_GET_LEN(eptn) USB_GET_TX_LEN(eptn)
double buffer mode get endpoint buf0/buf1 data length More...
#define | USB_DBUF1_GET_LEN(eptn) USB_GET_RX_LEN(eptn)
#define | BLK32(reg, len, blks)
set usb length of rx buffer More...
#define | BLK2(reg, len, blks)
#define | USB_SET_RXLEN_REG(reg, len)
#define | USB_SET_TXLEN(eptn, len) (*(GET_TX_LEN_ADDR(eptn)) = (len))
set endpoint tx/rx transfer length More...
#define | USB_SET_RXLEN(eptn, len)
#define | USB_OUT_EPT_DOUBLE_BUF0(eptn, len)
double buffer mode set endpoint rx buf0 length More...
#define | USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir)
double buffer mode set endpoint buf0 length More...
#define | USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir)
double buffer mode set endpoint buf1 length More...
#define | USB_SET_TX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8) * 2 + g_usb_packet_address) = address)
set usb endpoint tx/rx fifo address More...
#define | USB_SET_RX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8 + 4) * 2 + g_usb_packet_address) = address)
#define | USB_SET_DOUBLE_BUFF0_ADDRESS(eptn, address) (USB_SET_TX_ADDRESS(eptn, address))
set double buffer mode usb endpoint buf0/buf1 fifo address More...
#define | USB_SET_DOUBLE_BUFF1_ADDRESS(eptn, address) (USB_SET_RX_ADDRESS(eptn, address))
#define | USB_TOGGLE_TXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_TXDTS | USB_RXTC | USB_TXTC))
set usb tx/rx toggle More...
#define | USB_TOGGLE_RXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_RXDTS | USB_RXTC | USB_TXTC))
#define | USB_CLEAR_TXDTS(eptn)
clear usb tx/rx toggle More...
#define | USB_CLEAR_RXDTS(eptn)
#define | USB_SET_TRANS_TYPE(eptn, type) (USB->ept[eptn] = (USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_TRANS_TYPE)) | type)
set usb endpoint type More...
#define | USB_SET_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | ((USB->ept[eptn] | USB_EXF) & USB_EPT_BIT_MASK))
set/clear usb extend function More...
#define | USB_CLEAR_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | (USB->ept[eptn] & ((~USB_EXF) & USB_EPT_BIT_MASK)))
#define | USB_SET_EPT_ADDRESS(eptn, address) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_EPTADDR)) | address))
set usb device address More...
#define | USB_FREE_DB_USER_BUFFER(eptn, inout)
free buffer used by application More...
#define | USB_CLEAR_TXTC(eptn) (USB->ept[eptn] &= 0xFF7F & USB_EPT_BIT_MASK)
clear tx/rx transfer completed flag More...
#define | USB_CLEAR_RXTC(eptn) (USB->ept[eptn] &= 0x7FFF & USB_EPT_BIT_MASK)
#define | USB_SET_EPT_DOUBLE_BUFFER(eptn) USB_SET_EXF(eptn)
set/clear endpoint double buffer mode More...
#define | USB_CLEAR_EPT_DOUBLE_BUFFER(eptn) USB_CLEAR_EXF(eptn)
#define | USB ((usbd_type *) USBFS_BASE)

Typedefs

typedef usbd_type usb_reg_type

Enumerations

enum usb_ept_number_type {
USB_EPT0 = 0x00 , USB_EPT1 = 0x01 , USB_EPT2 = 0x02 , USB_EPT3 = 0x03 ,
USB_EPT4 = 0x04 , USB_EPT5 = 0x05 , USB_EPT6 = 0x06 , USB_EPT7 = 0x07
}
usb endpoint number define More...
enum | ept_trans_type { EPT_CONTROL_TYPE = 0x00 , EPT_BULK_TYPE = 0x01 , EPT_INT_TYPE = 0x02 , EPT_ISO_TYPE = 0x03 }
usb endpoint max num define More...
enum | ept_inout_type { EPT_IN = 0x00 , EPT_OUT = 0x01 }
endpoint endpoint direction define More...
enum | data_trans_dir { DATA_TRANS_OUT = 0x00 , DATA_TRANS_IN = 0x01 }
data transfer direction More...
enum | usb_clk48_s { USB_CLK_HICK , USB_CLK_HEXT }
usb clock select More...

Functions

void | usb_dev_init (usbd_type *usbx)
initialize usb peripheral controller register More...
void | usb_connect (usbd_type *usbx)
connect usb device More...
void | usb_disconnect (usbd_type *usbx)
disconnect usb device More...
void | usb_usbbufs_enable (usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes. More...
void | usb_ept_open (usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_write_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_interrupt_enable (usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable More...
void | usb_set_address (usbd_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept_stall (usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_enter_suspend (usbd_type *usbx)
usb device enter suspend mode More...
void | usb_exit_suspend (usbd_type *usbx)
usb device exit suspend mode More...
void | usb_remote_wkup_set (usbd_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (usbd_type *usbx)
usb remote wakeup clear More...
uint16_t | usb_buffer_malloc (uint16_t maxpacket)
usb auto malloc endpoint buffer More...
void | usb_buffer_free (void)
free usb endpoint buffer More...
flag_status | usb_flag_get (usbd_type *usbx, uint16_t flag)
get flag of usb. More...
void | usb_flag_clear (usbd_type *usbx, uint16_t flag)
clear flag of usb. More...

Variables

uint32_t g_usb_packet_address

Detailed Description

at32f413 usb header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_usb.h.


AT32F413 Firmwary Library: at32f413_wdt.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_wdt.h File Reference

at32f413 wdt header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct wdt_type
type define wdt register all More...

Macros

#define | WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)
#define | WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)
#define | WDT ((wdt_type *) WDT_BASE)

Enumerations

enum wdt_division_type {
WDT_CLK_DIV_4 = 0x00 , WDT_CLK_DIV_8 = 0x01 , WDT_CLK_DIV_16 = 0x02 , WDT_CLK_DIV_32 = 0x03 ,
WDT_CLK_DIV_64 = 0x04 , WDT_CLK_DIV_128 = 0x05 , WDT_CLK_DIV_256 = 0x06
}
wdt division value type More...
enum wdt_cmd_value_type { WDT_CMD_LOCK = 0x0000 , WDT_CMD_UNLOCK = 0x5555 , WDT_CMD_ENABLE = 0xCCCC , WDT_CMD_RELOAD = 0xAAAA }
wdt cmd value type More...

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...

Detailed Description

at32f413 wdt header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_wdt.h.


AT32F413 Firmwary Library: at32f413_wwdt.h File Reference

  • libraries
  • drivers
  • inc
Data Structures | Macros | Enumerations | Functions
at32f413_wwdt.h File Reference

at32f413 wwdt header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct wwdt_type
type define wwdt register all More...

Macros

#define | WWDT_EN_BIT ((uint32_t)0x00000080)
#define | WWDT ((wwdt_type *) WWDT_BASE)

Enumerations

enum wwdt_division_type { WWDT_PCLK1_DIV_4096 = 0x00 , WWDT_PCLK1_DIV_8192 = 0x01 , WWDT_PCLK1_DIV_16384 = 0x02 , WWDT_PCLK1_DIV_32768 = 0x03 }
wwdt division type More...

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

at32f413 wwdt header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_wwdt.h.


AT32F413 Firmwary Library: at32f413_acc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_acc.c File Reference

contains all the functions for the acc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | acc_calibration_mode_enable (uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode. More...
void | acc_step_set (uint8_t step_value)
store calibration step data in acc's ctrl1 register. More...
void | acc_interrupt_enable (uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts. More...
uint8_t | acc_hicktrim_get (void)
return the current acc hicktrim value. More...
uint8_t | acc_hickcal_get (void)
return the current acc hickcal value. More...
void | acc_write_c1 (uint16_t acc_c1_value)
wtire the value to acc c1 register. More...
void | acc_write_c2 (uint16_t acc_c2_value)
wtire the value to acc c2 register. More...
void | acc_write_c3 (uint16_t acc_c3_value)
wtire the value to acc c3 register. More...
uint16_t | acc_read_c1 (void)
return the current acc c1 value. More...
uint16_t | acc_read_c2 (void)
return the current acc c2 value. More...
uint16_t | acc_read_c3 (void)
return the current acc c3 value. More...
flag_status | acc_flag_get (uint16_t acc_flag)
check whether the specified acc flag is set or not. More...
void | acc_flag_clear (uint16_t acc_flag)
clear the specified acc flag is set or not. More...

Detailed Description

contains all the functions for the acc firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_acc.c.


AT32F413 Firmwary Library: at32f413_adc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_adc.c File Reference

contains all the functions for the adc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | adc_reset (adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values. More...
void | adc_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral. More...
void | adc_combine_mode_select (adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral. More...
void | adc_base_default_para_init (adc_base_config_type *adc_base_struct)
adc base default para init. More...
void | adc_base_config (adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters. More...
void | adc_dma_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer. More...
void | adc_interrupt_enable (adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts. More...
void | adc_calibration_init (adc_type *adc_x)
initialize calibration register of the specified adc peripheral. More...
flag_status | adc_calibration_init_status_get (adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral. More...
void | adc_calibration_start (adc_type *adc_x)
start calibration process of the specified adc peripheral. More...
flag_status | adc_calibration_status_get (adc_type *adc_x)
get calibration status of the specified adc peripheral. More...
void | adc_voltage_monitor_enable (adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified adc peripheral. More...
void | adc_voltage_monitor_threshold_value_set (adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral. More...
void | adc_voltage_monitor_single_channel_select (adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral. More...
void | adc_ordinary_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_preempt_channel_length_set (adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral. More...
void | adc_preempt_channel_set (adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc peripheral. More...
void | adc_ordinary_conversion_trigger_set (adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_conversion_trigger_set (adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specified adc peripheral. More...
void | adc_preempt_offset_value_set (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral. More...
void | adc_ordinary_part_count_set (adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral. More...
void | adc_ordinary_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral. More...
void | adc_preempt_part_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral. More...
void | adc_preempt_auto_mode_enable (adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral. More...
void | adc_tempersensor_vintrv_enable (confirm_state new_state)
enable or disable the temperature sensor and vintrv channel. More...
void | adc_ordinary_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral. More...
flag_status | adc_ordinary_software_trigger_status_get (adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral. More...
void | adc_preempt_software_trigger_enable (adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral. More...
flag_status | adc_preempt_software_trigger_status_get (adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral. More...
uint16_t | adc_ordinary_conversion_data_get (adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral. More...
uint32_t | adc_combine_ordinary_conversion_data_get (void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2). More...
uint16_t | adc_preempt_conversion_data_get (adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral. More...
flag_status | adc_flag_get (adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral. More...
void | adc_flag_clear (adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral. More...

Detailed Description

contains all the functions for the adc firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_adc.c.


AT32F413 Firmwary Library: at32f413_bpr.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_bpr.c File Reference

contains all the functions for the bpr firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | bpr_reset (void)
bpr reset by crm reset register More...
flag_status | bpr_flag_get (uint32_t flag)
bpr event flag get, for tamper event flag More...
void | bpr_flag_clear (uint32_t flag)
clear bpr tamper flag More...
void | bpr_interrupt_enable (confirm_state new_state)
enable or disable bpr tamper interrupt More...
uint16_t | bpr_data_read (bpr_data_type bpr_data)
read bpr bpr data More...
void | bpr_data_write (bpr_data_type bpr_data, uint16_t data_value)
write bpr data More...
void | bpr_rtc_output_select (bpr_rtc_output_type output_source)
select bpr rtc output More...
void | bpr_rtc_clock_calibration_value_set (uint8_t calibration_value)
set rtc clock calibration value More...
void | bpr_tamper_pin_enable (confirm_state new_state)
enable or disable bpr tamper pin More...
void | bpr_tamper_pin_active_level_set (bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level More...

Detailed Description

contains all the functions for the bpr firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_bpr.c.


AT32F413 Firmwary Library: at32f413_can.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_can.c File Reference

contains all the functions for the can firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | can_reset (can_type *can_x)
deinitialize the can peripheral registers to their default reset values. More...
void | can_baudrate_default_para_init (can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value. More...
error_status | can_baudrate_set (can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral More...
void | can_default_para_init (can_base_type *can_base_struct)
fill each can_init_struct member with its default value. More...
error_status | can_base_init (can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct. More...
void | can_filter_default_para_init (can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value. More...
void | can_filter_init (can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct. More...
void | can_debug_transmission_prohibit (can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral. More...
void | can_ttc_mode_enable (can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral. More...
uint8_t | can_message_transmit (can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral. More...
can_transmit_status_type | can_transmit_status_get (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral. More...
void | can_transmit_cancel (can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral. More...
void | can_message_receive (can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral. More...
void | can_receive_fifo_release (can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral. More...
uint8_t | can_receive_message_pending_get (can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral. More...
error_status | can_operating_mode_set (can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral. More...
can_enter_doze_status_type | can_doze_mode_enter (can_type *can_x)
enter the low power mode of the specified can peripheral. More...
can_quit_doze_status_type | can_doze_mode_exit (can_type *can_x)
exit the doze mode of the specified can peripheral. More...
can_error_record_type | can_error_type_record_get (can_type *can_x)
return the error type record (etr) of the specified can peripheral. More...
uint8_t | can_receive_error_counter_get (can_type *can_x)
return the receive error counter (rec) of the specified can peripheral. More...
uint8_t | can_transmit_error_counter_get (can_type *can_x)
return the transmit error counter of the specified can peripheral. More...
void | can_interrupt_enable (can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral. More...
flag_status | can_flag_get (can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral. More...
void | can_flag_clear (can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral. More...

Detailed Description

contains all the functions for the can firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_can.c.


AT32F413 Firmwary Library: at32f413_crc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_crc.c File Reference

contains all the functions for the crc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | crc_data_reset (void)
reset the crc data register. More...
uint32_t | crc_one_word_calculate (uint32_t data)
compute the 32-bit crc of a given data word(32-bit). More...
uint32_t | crc_block_calculate (uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit). More...
uint32_t | crc_data_get (void)
return the current crc value. More...
void | crc_common_data_set (uint8_t cdt_value)
store a 8-bit data in the common data register. More...
uint8_t | crc_common_date_get (void)
return the 8-bit data stored in the common data register More...
void | crc_init_data_set (uint32_t value)
set the 32-bit initial data of crc More...
void | crc_reverse_input_data_set (crc_reverse_input_type value)
control the reversal of the bit order in the input data More...
void | crc_reverse_output_data_set (crc_reverse_output_type value)
control the reversal of the bit order in the output data More...

Detailed Description

contains all the functions for the crc firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_crc.c.


AT32F413 Firmwary Library: at32f413_crm.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_crm.c File Reference

contains all the functions for the crm firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | crm_reset (void)
reset the crm register More...
void | crm_lext_bypass (confirm_state new_state)
enable or disable crm low speed external crystal bypass More...
void | crm_hext_bypass (confirm_state new_state)
enable or disable crm high speed external crystal bypass More...
flag_status | crm_flag_get (uint32_t flag)
get crm flag status More...
error_status | crm_hext_stable_wait (void)
wait for hext stable More...
void | crm_hick_clock_trimming_set (uint8_t trim_value)
set the hick trimming value More...
void | crm_hick_clock_calibration_set (uint8_t cali_value)
set the crm calibration value More...
void | crm_periph_clock_enable (crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock More...
void | crm_periph_reset (crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset More...
void | crm_periph_sleep_mode_clock_enable (crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode More...
void | crm_clock_source_enable (crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source More...
void | crm_flag_clear (uint32_t flag)
clear the crm reset flags More...
void | crm_rtc_clock_select (crm_rtc_clock_type value)
select rtc clock More...
void | crm_rtc_clock_enable (confirm_state new_state)
enable or disable rtc More...
void | crm_ahb_div_set (crm_ahb_div_type value)
set crm ahb division More...
void | crm_apb1_div_set (crm_apb1_div_type value)
set crm apb1 division More...
void | crm_apb2_div_set (crm_apb2_div_type value)
set crm apb2 division More...
void | crm_adc_clock_div_set (crm_adc_div_type div_value)
set crm adc division More...
void | crm_usb_clock_div_set (crm_usb_div_type div_value)
set crm usb division More...
void | crm_clock_failure_detection_enable (confirm_state new_state)
enable or disable clock failure detection More...
void | crm_battery_powered_domain_reset (confirm_state new_state)
battery powered domain software reset More...
void | crm_pll_config (crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll More...
void | crm_sysclk_switch (crm_sclk_type value)
select system clock source More...
crm_sclk_type | crm_sysclk_switch_status_get (void)
indicate which clock source is used as system clock More...
void | crm_clocks_freq_get (crm_clocks_freq_type *clocks_struct)
get crm clocks freqency More...
void | crm_clock_out_set (crm_clkout_select_type clkout)
set crm clkout More...
void | crm_interrupt_enable (uint32_t crm_int, confirm_state new_state)
config crm interrupt More...
void | crm_auto_step_mode_enable (confirm_state new_state)
auto step clock switch enable More...
void | crm_usb_interrupt_remapping_set (crm_usb_int_map_type int_remap)
usbdev interrupt remapping control More...
void | crm_hick_divider_select (crm_hick_div_6_type value)
config hick divider select More...
void | crm_hick_sclk_frequency_select (crm_hick_sclk_frequency_type value)
hick as system clock frequency select More...
void | crm_usb_clock_source_select (crm_usb_clock_source_type value)
usb 48 mhz clock source select More...
void | crm_clkout_to_tmr10_enable (confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1 More...
void | crm_clkout_div_set (crm_clkout_div_type clkout_div)
set crm clkout division More...

Detailed Description

contains all the functions for the crm firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_crm.c.


AT32F413 Firmwary Library: at32f413_debug.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_debug.c File Reference

contains all the functions for the debug firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

uint32_t | debug_device_id_get (void)
get debug device id More...
void | debug_periph_mode_set (uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode More...

Detailed Description

contains all the functions for the debug firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_debug.c.


AT32F413 Firmwary Library: at32f413_dma.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_dma.c File Reference

contains all the functions for the dma firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | dma_reset (dma_channel_type *dmax_channely)
reset the dmax channely registers. More...
void | dma_data_number_set (dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred More...
uint16_t | dma_data_number_get (dma_channel_type *dmax_channely)
get number of data from dtcnt register More...
void | dma_interrupt_enable (dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt More...
void | dma_channel_enable (dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely More...
void | dma_flexible_config (dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters. More...
flag_status | dma_flag_get (uint32_t dmax_flag)
get dma flag More...
void | dma_flag_clear (uint32_t dmax_flag)
clear dma flag More...
void | dma_default_para_init (dma_init_type *dma_init_struct)
dma init config with its default value. More...
void | dma_init (dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init More...

Detailed Description

contains all the functions for the dma firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_dma.c.


AT32F413 Firmwary Library: at32f413_exint.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_exint.c File Reference

contains all the functions for the exint firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | exint_reset (void)
exint reset More...
void | exint_default_para_init (exint_init_type *exint_struct)
exint default para init More...
void | exint_init (exint_init_type *exint_struct)
exint init More...
void | exint_flag_clear (uint32_t exint_line)
clear exint flag More...
flag_status | exint_flag_get (uint32_t exint_line)
get exint flag More...
void | exint_software_interrupt_event_generate (uint32_t exint_line)
generate exint software interrupt event More...
void | exint_interrupt_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt More...
void | exint_event_enable (uint32_t exint_line, confirm_state new_state)
enable or disable exint event More...

Detailed Description

contains all the functions for the exint firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_exint.c.


AT32F413 Firmwary Library: at32f413_flash.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_flash.c File Reference

contains all the functions for the flash firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

flag_status | flash_flag_get (uint32_t flash_flag)
check whether the specified flash flag is set or not. More...
void | flash_flag_clear (uint32_t flash_flag)
clear the flash flag. More...
flash_status_type | flash_operation_status_get (void)
return the flash operation status. More...
flash_status_type | flash_spim_operation_status_get (void)
return the flash spim operation status. More...
flash_status_type | flash_operation_wait_for (uint32_t time_out)
wait for flash operation complete or timeout. More...
flash_status_type | flash_spim_operation_wait_for (uint32_t time_out)
wait for flash spim operation complete or timeout. More...
void | flash_unlock (void)
unlock the flash controller. More...
void | flash_spim_unlock (void)
unlock the flash spim controller. More...
void | flash_lock (void)
lock the flash controller. More...
void | flash_spim_lock (void)
lock the flash spim controller. More...
flash_status_type | flash_sector_erase (uint32_t sector_address)
erase a specified flash sector. More...
flash_status_type | flash_internal_all_erase (void)
erase flash all internal sectors. More...
flash_status_type | flash_spim_all_erase (void)
erase flash spim sectors. More...
flash_status_type | flash_user_system_data_erase (void)
erase the flash user system data. More...
flash_status_type | flash_word_program (uint32_t address, uint32_t data)
program a word at a specified address. More...
flash_status_type | flash_halfword_program (uint32_t address, uint16_t data)
program a halfword at a specified address. More...
flash_status_type | flash_byte_program (uint32_t address, uint8_t data)
program a byte at a specified address. More...
flash_status_type | flash_user_system_data_program (uint32_t address, uint8_t data)
program a halfword at a specified user system data address. More...
flash_status_type | flash_epp_set (uint32_t *sector_bits)
config erase/program protection for the desired sectors. More...
void | flash_epp_status_get (uint32_t *sector_bits)
return the flash erase/program protection status. More...
flash_status_type | flash_fap_enable (confirm_state new_state)
enable or disable the flash access protection. More...
flag_status | flash_fap_status_get (void)
check the flash access protection status. More...
flash_status_type | flash_ssb_set (uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst. More...
uint8_t | flash_ssb_status_get (void)
return the flash system setting byte status. More...
void | flash_interrupt_enable (uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts. More...
void | flash_spim_model_select (flash_spim_model_type mode)
select spim supports extended spi flash chip model. More...
void | flash_spim_encryption_range_set (uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value, the writing data will be directly written to spim without encryption. More...
flash_status_type | flash_slib_enable (uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function. More...
error_status | flash_slib_disable (uint32_t pwd)
disable slib when slib enabled. More...
uint32_t | flash_slib_remaining_count_get (void)
get remaining count of slib(range: 256~0). More...
flag_status | flash_slib_state_get (void)
get the slib state. More...
uint16_t | flash_slib_start_sector_get (void)
get the start sector of slib. More...
uint16_t | flash_slib_datstart_sector_get (void)
get the data start sector of slib. More...
uint16_t | flash_slib_end_sector_get (void)
get the end sector of slib. More...
uint32_t | flash_crc_calibrate (uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block. More...

Detailed Description

contains all the functions for the flash firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_flash.c.


AT32F413 Firmwary Library: at32f413_gpio.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_gpio.c File Reference

contains all the functions for the gpio firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | gpio_reset (gpio_type *gpio_x)
reset the gpio register More...
void | gpio_iomux_reset (void)
reset the mux functions (remap, event control and exint configuration) registers to their default values. More...
void | gpio_init (gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral. More...
void | gpio_default_para_init (gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value. More...
flag_status | gpio_input_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified input port pin. More...
uint16_t | gpio_input_data_read (gpio_type *gpio_x)
read the specified gpio input data port. More...
flag_status | gpio_output_data_bit_read (gpio_type *gpio_x, uint16_t pins)
read the specified output port pin. More...
uint16_t | gpio_output_data_read (gpio_type *gpio_x)
read the specified gpio ouput data port. More...
void | gpio_bits_set (gpio_type *gpio_x, uint16_t pins)
set the selected data port bits. More...
void | gpio_bits_reset (gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits. More...
void | gpio_bits_write (gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit. More...
void | gpio_port_wirte (gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port. More...
void | gpio_pin_wp_config (gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers. More...
void | gpio_event_output_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output. More...
void | gpio_event_output_enable (confirm_state new_state)
enable or disable the event output. More...
void | gpio_pin_remap_config (uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration. More...
void | gpio_exint_line_config (gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line. More...

Detailed Description

contains all the functions for the gpio firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_gpio.c.


AT32F413 Firmwary Library: at32f413_i2c.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_i2c.c File Reference

contains all the functions for the i2c firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | i2c_reset (i2c_type *i2c_x)
reset the i2c register More...
void | i2c_software_reset (i2c_type *i2c_x, confirm_state new_state)
software reset. More...
void | i2c_init (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle. More...
void | i2c_own_address1_set (i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1. More...
void | i2c_own_address2_set (i2c_type *i2c_x, uint8_t address)
config own address2. More...
void | i2c_own_address2_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2. More...
void | i2c_smbus_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode More...
void | i2c_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph More...
void | i2c_fast_mode_duty_set (i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle More...
void | i2c_clock_stretch_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch. More...
void | i2c_ack_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge. More...
void | i2c_master_receive_ack_set (i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control. More...
void | i2c_pec_position_set (i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set. More...
void | i2c_general_call_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable general call. More...
void | i2c_arp_mode_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode. More...
void | i2c_smbus_mode_set (i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device. More...
void | i2c_smbus_alert_set (i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low. More...
void | i2c_pec_transmit_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer. More...
void | i2c_pec_calculate_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion. More...
uint8_t | i2c_pec_value_get (i2c_type *i2c_x)
get pec value. More...
void | i2c_dma_end_transfer_set (i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one. More...
void | i2c_dma_enable (i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests. More...
void | i2c_interrupt_enable (i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt More...
void | i2c_start_generate (i2c_type *i2c_x)
generate start condition. More...
void | i2c_stop_generate (i2c_type *i2c_x)
generate stop condition. More...
void | i2c_7bit_address_send (i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address. More...
void | i2c_data_send (i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph. More...
uint8_t | i2c_data_receive (i2c_type *i2c_x)
receive a byte through the i2c periph. More...
flag_status | i2c_flag_get (i2c_type *i2c_x, uint32_t flag)
get flag status More...
void | i2c_flag_clear (i2c_type *i2c_x, uint32_t flag)
clear flag status More...

Detailed Description

contains all the functions for the i2c firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_i2c.c.


AT32F413 Firmwary Library: at32f413_misc.c File Reference

  • libraries
  • drivers
  • src
Macros | Functions
at32f413_misc.c File Reference

contains all the functions for the misc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Macros

#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)

Functions

void | nvic_system_reset (void)
system reset More...
void | nvic_irq_enable (IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq More...
void | nvic_irq_disable (IRQn_Type irqn)
disable nvic irq number More...
void | nvic_priority_group_config (nvic_priority_group_type priority_group)
config nvic priority group More...
void | nvic_vector_table_set (uint32_t base, uint32_t offset)
set the vector table location and offset. More...
void | nvic_lowpower_mode_config (nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode More...
void | systick_clock_source_config (systick_clock_source_type source)
config systick clock source More...

Detailed Description

contains all the functions for the misc firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_misc.c.


AT32F413 Firmwary Library: at32f413_pwc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_pwc.c File Reference

contains all the functions for the pwc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | pwc_reset (void)
deinitialize the pwc peripheral registers to their default reset values. More...
void | pwc_battery_powered_domain_access (confirm_state new_state)
enable or disable access to the battery powered domain. More...
void | pwc_pvm_level_select (pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector. More...
void | pwc_power_voltage_monitor_enable (confirm_state new_state)
enable or disable pwc power voltage monitor (pvm) More...
void | pwc_wakeup_pin_enable (uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin More...
void | pwc_flag_clear (uint32_t pwc_flag)
clear flag of pwc More...
flag_status | pwc_flag_get (uint32_t pwc_flag)
get flag of pwc More...
void | pwc_sleep_mode_enter (pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode More...
void | pwc_deep_sleep_mode_enter (pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode More...
void | pwc_voltage_regulate_set (pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode More...
void | pwc_standby_mode_enter (void)
enter pwc standby mode More...

Detailed Description

contains all the functions for the pwc firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_pwc.c.


AT32F413 Firmwary Library: at32f413_rtc.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_rtc.c File Reference

contains all the functions for the rtc firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | rtc_counter_set (uint32_t counter_value)
rtc counter set More...
uint32_t | rtc_counter_get (void)
rtc counter get More...
void | rtc_divider_set (uint32_t div_value)
rtc divider set More...
uint32_t | rtc_divider_get (void)
rtc divider get More...
void | rtc_alarm_set (uint32_t alarm_value)
rtc alarm value set More...
void | rtc_interrupt_enable (uint16_t source, confirm_state new_state)
rtc interrupt enable More...
flag_status | rtc_flag_get (uint16_t flag)
rtc flag get More...
void | rtc_flag_clear (uint16_t flag)
rtc flag clear More...
void | rtc_wait_config_finish (void)
rtc wait configuration finish More...
void | rtc_wait_update_finish (void)
rtc wait update finish More...

Detailed Description

contains all the functions for the rtc firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_rtc.c.


AT32F413 Firmwary Library: at32f413_sdio.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_sdio.c File Reference

contains all the functions for the sdio firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | sdio_reset (sdio_type *sdio_x)
reset the sdio register More...
void | sdio_power_set (sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller More...
flag_status | sdio_power_status_get (sdio_type *sdio_x)
get power status. More...
void | sdio_clock_config (sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock More...
void | sdio_bus_width_config (sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width More...
void | sdio_clock_bypass (sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss More...
void | sdio_power_saving_mode_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle. More...
void | sdio_flow_control_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control. More...
void | sdio_clock_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output. More...
void | sdio_dma_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable dma. More...
void | sdio_interrupt_enable (sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt. More...
flag_status | sdio_flag_get (sdio_type *sdio_x, uint32_t flag)
get sdio flag. More...
void | sdio_flag_clear (sdio_type *sdio_x, uint32_t flag)
clear sdio flag. More...
void | sdio_command_config (sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command. More...
void | sdio_command_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM). More...
uint8_t | sdio_command_response_get (sdio_type *sdio_x)
get command index of last command for which response received. More...
uint32_t | sdio_response_get (sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command. More...
void | sdio_data_config (sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data. More...
void | sdio_data_state_machine_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM). More...
uint32_t | sdio_data_counter_get (sdio_type *sdio_x)
get the number of remaining data bytes to be transferred. More...
uint32_t | sdio_data_read (sdio_type *sdio_x)
read a word data from sdio fifo. More...
uint32_t | sdio_buffer_counter_get (sdio_type *sdio_x)
get the number of words left to be written to or read from fifo.. More...
void | sdio_data_write (sdio_type *sdio_x, uint32_t data)
write one word data to fifo. More...
void | sdio_read_wait_mode_set (sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode. More...
void | sdio_read_wait_start (sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation. More...
void | sdio_read_wait_stop (sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation. More...
void | sdio_io_function_enable (sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function. More...
void | sdio_io_suspend_command_set (sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending. More...

Detailed Description

contains all the functions for the sdio firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_sdio.c.


AT32F413 Firmwary Library: at32f413_spi.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_spi.c File Reference

contains all the functions for the spi firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | spi_i2s_reset (spi_type *spi_x)
spi reset by crm reset register More...
void | spi_default_para_init (spi_init_type *spi_init_struct)
spi init config with its default value. More...
void | spi_init (spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value. More...
void | spi_crc_next_transmit (spi_type *spi_x)
spi next transmit crc for the spi peripheral. More...
void | spi_crc_polynomial_set (spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral. More...
uint16_t | spi_crc_polynomial_get (spi_type *spi_x)
return the crc polynomial register value for the spi peripheral. More...
void | spi_crc_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral. More...
uint16_t | spi_crc_value_get (spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral. More...
void | spi_hardware_cs_output_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral. More...
void | spi_software_cs_internal_level_set (spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral. More...
void | spi_frame_bit_num_set (spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral. More...
void | spi_half_duplex_direction_set (spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi peripheral. More...
void | spi_enable (spi_type *spi_x, confirm_state new_state)
enable or disable spi. More...
void | i2s_default_para_init (i2s_init_type *i2s_init_struct)
i2s init config with its default value. More...
void | i2s_init (spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value. More...
void | i2s_enable (spi_type *spi_x, confirm_state new_state)
enable or disable i2s. More...
void | spi_i2s_interrupt_enable (spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts. More...
void | spi_i2s_dma_transmitter_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode. More...
void | spi_i2s_dma_receiver_enable (spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode. More...
void | spi_i2s_data_transmit (spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit More...
uint16_t | spi_i2s_data_receive (spi_type *spi_x)
spi/i2s data receive More...
flag_status | spi_i2s_flag_get (spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral. More...
void | spi_i2s_flag_clear (spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral. More...

Detailed Description

contains all the functions for the spi firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_spi.c.


AT32F413 Firmwary Library: at32f413_tmr.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_tmr.c File Reference

contains all the functions for the tmr firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | tmr_reset (tmr_type *tmr_x)
tmr reset by crm reset register More...
void | tmr_counter_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter More...
void | tmr_output_default_para_init (tmr_output_config_type *tmr_output_struct)
init tmr output default para More...
void | tmr_input_default_para_init (tmr_input_config_type *tmr_input_struct)
init tmr input default para More...
void | tmr_brkdt_default_para_init (tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para More...
void | tmr_base_init (tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base More...
void | tmr_clock_source_div_set (tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division More...
void | tmr_cnt_dir_set (tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction More...
void | tmr_repetition_counter_set (tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value More...
void | tmr_counter_value_set (tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value More...
uint32_t | tmr_counter_value_get (tmr_type *tmr_x)
get tmr counter value More...
void | tmr_div_value_set (tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value More...
uint32_t | tmr_div_value_get (tmr_type *tmr_x)
get tmr div value More...
void | tmr_output_channel_config (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel More...
void | tmr_output_channel_mode_select (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode More...
void | tmr_period_value_set (tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value More...
uint32_t | tmr_period_value_get (tmr_type *tmr_x)
get tmr period value More...
void | tmr_channel_value_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value More...
uint32_t | tmr_channel_value_get (tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value More...
void | tmr_period_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer More...
void | tmr_output_channel_buffer_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer More...
void | tmr_output_channel_immediately_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately More...
void | tmr_output_channel_switch_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch More...
void | tmr_one_cycle_mode_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode More...
void | tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode) More...
void | tmr_overflow_request_source_set (tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources More...
void | tmr_overflow_event_disable (tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation More...
void | tmr_input_channel_init (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel More...
void | tmr_channel_enable (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable More...
void | tmr_input_channel_filter_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter More...
void | tmr_pwm_input_config (tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input More...
void | tmr_channel1_input_select (tmr_type *tmr_x, tmr_channel1_input_connected_type ti1_connect)
select tmr channel1 input More...
void | tmr_input_channel_divider_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider More...
void | tmr_primary_mode_select (tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode More...
void | tmr_sub_mode_select (tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode More...
void | tmr_channel_dma_select (tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma More...
void | tmr_hall_select (tmr_type *tmr_x, confirm_state new_state)
select tmr hall More...
void | tmr_channel_buffer_enable (tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer More...
void | tmr_trigger_input_select (tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger More...
void | tmr_sub_sync_mode_set (tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode More...
void | tmr_dma_request_enable (tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request More...
void | tmr_interrupt_enable (tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt More...
flag_status | tmr_flag_get (tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag More...
void | tmr_flag_clear (tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag More...
void | tmr_event_sw_trigger (tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event More...
void | tmr_output_enable (tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable More...
void | tmr_internal_clock_set (tmr_type *tmr_x)
set tmr select internal clock More...
void | tmr_output_channel_polarity_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity More...
void | tmr_external_clock_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock More...
void | tmr_external_clock_mode1_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1 More...
void | tmr_external_clock_mode2_config (tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2 More...
void | tmr_encoder_mode_config (tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode More...
void | tmr_force_output_set (tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output More...
void | tmr_dma_control_config (tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control More...
void | tmr_brkdt_config (tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time More...

Detailed Description

contains all the functions for the tmr firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_tmr.c.


AT32F413 Firmwary Library: at32f413_usart.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_usart.c File Reference

contains all the functions for the usart firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | usart_reset (usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values. More...
void | usart_init (usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters. More...
void | usart_parity_selection_config (usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config. More...
void | usart_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral. More...
void | usart_transmitter_enable (usart_type *usart_x, confirm_state new_state)
usart transmitter enable. More...
void | usart_receiver_enable (usart_type *usart_x, confirm_state new_state)
usart receiver enable. More...
void | usart_clock_config (usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config. More...
void | usart_clock_enable (usart_type *usart_x, confirm_state new_state)
usart enable the ck pin. More...
void | usart_interrupt_enable (usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts. More...
void | usart_dma_transmitter_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface. More...
void | usart_dma_receiver_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface. More...
void | usart_wakeup_id_set (usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart. More...
void | usart_wakeup_mode_set (usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication. More...
void | usart_receiver_mute_enable (usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication. More...
void | usart_break_bit_num_set (usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num. More...
void | usart_lin_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode. More...
void | usart_data_transmit (usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral. More...
uint16_t | usart_data_receive (usart_type *usart_x)
return the most recent received data by the usart peripheral. More...
void | usart_break_send (usart_type *usart_x)
transmit break characters. More...
void | usart_smartcard_guard_time_set (usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time. More...
void | usart_irda_smartcard_division_set (usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division. More...
void | usart_smartcard_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode. More...
void | usart_smartcard_nack_set (usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode. More...
void | usart_single_line_halfduplex_select (usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication. More...
void | usart_irda_mode_enable (usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface. More...
void | usart_irda_low_power_enable (usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power. More...
void | usart_hardware_flow_control_set (usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control. More...
flag_status | usart_flag_get (usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not. More...
void | usart_flag_clear (usart_type *usart_x, uint32_t flag)
clear the usart's pending flags. More...

Detailed Description

contains all the functions for the usart firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_usart.c.


AT32F413 Firmwary Library: at32f413_usb.c File Reference

  • libraries
  • drivers
  • src
Macros | Functions | Variables
at32f413_usb.c File Reference

contains the functions for the usb firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Macros

#define USB_ENDP_DESC_TABLE_OFFSET 0x40
usb packet buffer start address More...

Functions

void | usb_dev_init (usbd_type *usbx)
initialize usb peripheral controller register More...
void | usb_connect (usbd_type *usbx)
connect usb device More...
void | usb_disconnect (usbd_type *usbx)
disconnect usb device More...
void | usb_usbbufs_enable (usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area, and are select by the usbbufs in the crm misc1 register. when usbbufs is 0,sram size is 512 bytes, packet buffer start address is 0x40006000.when usbbufs is 1, sram size is fixed to 768~1280 bytes, and the packet buffer start address is fixed to 0x40007800,packet buffer size decided by whether can1 and can2 are enabled;when both can1 and can2 are disabled, usb packet buffer can be set to the maximum of 1280 bytes; when either can1 or can2 is enabled, usb packet buffer can be set to the maximum of 1024 bytes; when both CAN1 and CAN2 are enabled, usb packet buffer can be set to the maximum of 768 bytes. More...
void | usb_ept_open (usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint More...
void | usb_ept_close (usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint More...
void | usb_write_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer More...
void | usb_read_packet (uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer More...
void | usb_interrupt_enable (usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable More...
void | usb_set_address (usbd_type *usbx, uint8_t address)
set the host assignment address More...
void | usb_ept_stall (usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall More...
void | usb_enter_suspend (usbd_type *usbx)
usb device enter suspend mode More...
void | usb_exit_suspend (usbd_type *usbx)
usb device exit suspend mode More...
void | usb_remote_wkup_set (usbd_type *usbx)
usb remote wakeup set More...
void | usb_remote_wkup_clear (usbd_type *usbx)
usb remote wakeup clear More...
uint16_t | usb_buffer_malloc (uint16_t maxpacket)
usb auto malloc endpoint buffer More...
void | usb_buffer_free (void)
free usb endpoint buffer More...
flag_status | usb_flag_get (usbd_type *usbx, uint16_t flag)
get flag of usb. More...
void | usb_flag_clear (usbd_type *usbx, uint16_t flag)
clear flag of usb. More...

Variables

uint32_t | g_usb_packet_address = 0x40006000
static uint16_t | g_usb_offset_addr = 0x40

Detailed Description

contains the functions for the usb firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_usb.c.


AT32F413 Firmwary Library: at32f413_wdt.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_wdt.c File Reference

contains all the functions for the wdt firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | wdt_enable (void)
wdt enable ,the reload value will be sent to the counter More...
void | wdt_counter_reload (void)
reload wdt counter More...
void | wdt_reload_value_set (uint16_t reload_value)
set wdt counter reload value More...
void | wdt_divider_set (wdt_division_type division)
set wdt division divider More...
void | wdt_register_write_enable (confirm_state new_state)
enable or disable wdt cmd register write More...
flag_status | wdt_flag_get (uint16_t wdt_flag)
get wdt flag More...

Detailed Description

contains all the functions for the wdt firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_wdt.c.


AT32F413 Firmwary Library: at32f413_wwdt.c File Reference

  • libraries
  • drivers
  • src
Functions
at32f413_wwdt.c File Reference

contains all the functions for the wwdt firmware library More...

#include "at32f413_conf.h"

Go to the source code of this file.

Functions

void | wwdt_reset (void)
wwdt reset by crm reset register More...
void | wwdt_divider_set (wwdt_division_type division)
wwdt division set More...
void | wwdt_flag_clear (void)
wwdt reload counter interrupt flag clear More...
void | wwdt_enable (uint8_t wwdt_cnt)
wwdt enable and the counter value load More...
void | wwdt_interrupt_enable (void)
wwdt reload counter interrupt enable More...
flag_status | wwdt_flag_get (void)
wwdt reload counter interrupt flag get More...
void | wwdt_counter_set (uint8_t wwdt_cnt)
wwdt counter value set More...
void | wwdt_window_counter_set (uint8_t window_cnt)
wwdt window counter value set More...

Detailed Description

contains all the functions for the wwdt firmware library

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_wwdt.c.


AT32F413 Firmwary Library: main_page.h File Reference

  • main_page
main_page.h File Reference

Go to the source code of this file.


AT32F413 Firmwary Library: i2c_application.c File Reference

  • middlewares
  • i2c_application_library
Macros | Functions
i2c_application.c File Reference

the driver library of the i2c peripheral More...

#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | DMA_GET_TC_FLAG(DMA_CHANNEL)
get the dma transfer complete flag through the channel More...
#define | DMA_GET_HT_FLAG(DMA_CHANNEL)
get the dma half transfer flag through the channel More...
#define | DMA_GET_TERR_FLAG(DMA_CHANNEL)
get the dma transfer error flag through the channel More...
#define | I2C_START 0
i2c transmission status More...
#define | I2C_END 1

Functions

__WEAK void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
void | i2c_addr_flag_clear (i2c_handle_type *hi2c)
clear the addr flag. More...
void | i2c_stop_flag_clear (i2c_handle_type *hi2c)
clear the stop flag. More...
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, flag_status status, uint32_t event_check, uint32_t timeout)
wait for the flag. More...
void | i2c_dma_config (i2c_handle_type *hi2c, dma_channel_type *dma_channelx, uint8_t *pdata, uint16_t size)
dma transfer cofiguration. More...
i2c_status_type | i2c_master_write_addr (i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master transmits mode. More...
i2c_status_type | i2c_master_read_addr (i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master receive mode. More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_master_tx_isr_int (i2c_handle_type *hi2c)
master transfer mode interrupt procession function More...
void | i2c_master_rx_isr_int (i2c_handle_type *hi2c)
master receive mode interrupt procession function More...
void | i2c_slave_tx_isr_int (i2c_handle_type *hi2c)
slave transfer mode interrupt procession function More...
void | i2c_slave_rx_isr_int (i2c_handle_type *hi2c)
slave receive mode interrupt procession function More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
i2c error interrupt function. More...

Detailed Description

the driver library of the i2c peripheral

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file i2c_application.c.


AT32F413 Firmwary Library: i2c_application.h File Reference

  • middlewares
  • i2c_application_library
Data Structures | Macros | Enumerations | Functions
i2c_application.h File Reference

i2c application libray header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct i2c_handle_type

Macros

#define | I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)
#define | I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)
#define | I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)

Enumerations

enum i2c_mode_type {
I2C_INT_MA_TX = 0 , I2C_INT_MA_RX , I2C_INT_SLA_TX , I2C_INT_SLA_RX ,
I2C_DMA_MA_TX , I2C_DMA_MA_RX , I2C_DMA_SLA_TX , I2C_DMA_SLA_RX
}
enum i2c_status_type {
I2C_OK = 0 , I2C_ERR_STEP_1 , I2C_ERR_STEP_2 , I2C_ERR_STEP_3 ,
I2C_ERR_STEP_4 , I2C_ERR_STEP_5 , I2C_ERR_STEP_6 , I2C_ERR_STEP_7 ,
I2C_ERR_STEP_8 , I2C_ERR_STEP_9 , I2C_ERR_STEP_10 , I2C_ERR_STEP_11 ,
I2C_ERR_STEP_12 , I2C_ERR_START , I2C_ERR_ADDR10 , I2C_ERR_ADDR ,
I2C_ERR_STOP , I2C_ERR_ACKFAIL , I2C_ERR_TIMEOUT , I2C_ERR_INTERRUPT
}

Functions

void | i2c_config (i2c_handle_type *hi2c)
i2c peripheral initialization. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | i2c_reset_ctrl2_register (i2c_handle_type *hi2c)
i2c_status_type | i2c_wait_end (i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end. More...
i2c_status_type | i2c_wait_flag (i2c_handle_type *hi2c, uint32_t flag, flag_status status, uint32_t event_check, uint32_t timeout)
wait for the flag. More...
i2c_status_type | i2c_master_transmit (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode. More...
i2c_status_type | i2c_master_receive (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode. More...
i2c_status_type | i2c_slave_transmit (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode. More...
i2c_status_type | i2c_slave_receive (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode. More...
i2c_status_type | i2c_master_transmit_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode. More...
i2c_status_type | i2c_master_receive_int (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode. More...
i2c_status_type | i2c_slave_transmit_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode. More...
i2c_status_type | i2c_slave_receive_int (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode. More...
i2c_status_type | i2c_master_transmit_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode. More...
i2c_status_type | i2c_master_receive_dma (i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode. More...
i2c_status_type | i2c_slave_transmit_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode. More...
i2c_status_type | i2c_slave_receive_dma (i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode. More...
i2c_status_type | i2c_memory_write (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode. More...
i2c_status_type | i2c_memory_write_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode. More...
i2c_status_type | i2c_memory_write_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode. More...
i2c_status_type | i2c_memory_read (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
i2c_status_type | i2c_memory_read_int (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode. More...
i2c_status_type | i2c_memory_read_dma (i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode. More...
void | i2c_evt_irq_handler (i2c_handle_type *hi2c)
interrupt procession function. More...
void | i2c_err_irq_handler (i2c_handle_type *hi2c)
i2c error interrupt function. More...
void | i2c_dma_tx_irq_handler (i2c_handle_type *hi2c)
dma transmission complete interrupt function. More...
void | i2c_dma_rx_irq_handler (i2c_handle_type *hi2c)
dma reveive complete interrupt function. More...

Detailed Description

i2c application libray header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file i2c_application.h.


AT32F413 Firmwary Library: audio_class.c File Reference

  • middlewares
  • usbd_class
  • audio
Functions | Variables
audio_class.c File Reference

usb audio class type More...

#include "usbd_core.h"
#include "audio_class.h"
#include "audio_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...

Variables

usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler audio_class_handler

Detailed Description

usb audio class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_class.c.


AT32F413 Firmwary Library: audio_class.h File Reference

  • middlewares
  • usbd_class
  • audio
Data Structures | Macros | Variables
audio_class.h File Reference

usb audio class file More...

#include "usb_std.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Data Structures

struct usb_audio_type
usb audio control struct More...

Macros

#define | USBD_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUDIO_FEEDBACK_EPT 0x83
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Variables

usbd_class_handler audio_class_handler

Detailed Description

usb audio class file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_class.h.


AT32F413 Firmwary Library: audio_conf.h File Reference

  • middlewares
  • usbd_class
  • audio
Macros
audio/audio_conf.h File Reference

usb audio config More...

Go to the source code of this file.

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 1
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

usb audio config

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio/audio_conf.h.


AT32F413 Firmwary Library: audio_conf.h File Reference

  • middlewares
  • usbd_class
  • audio_hid
Macros
audio_hid/audio_conf.h File Reference

usb audio config More...

Go to the source code of this file.

Macros

#define | AUDIO_SUPPORT_SPK 1
#define | AUDIO_SUPPORT_MIC 1
#define | AUDIO_SUPPORT_FEEDBACK 1
#define | AUDIO_SUPPORT_FREQ_16K 0
#define | AUDIO_SUPPORT_FREQ_48K 1
#define | AUDIO_SUPPORT_FREQ
#define | AUDIO_FREQ_16K 16000
#define | AUDIO_FREQ_48K 48000
#define | AUDIO_BITW_16 16
#define | AUDIO_MIC_CHANEL_NUM 2
#define | AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SPK_CHANEL_NUM 2
#define | AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
#define | AUDIO_SUPPORT_MAX_FREQ 48
#define | AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
#define | AUDIO_DEFAULT_BITW AUDIO_BITW_16

Detailed Description

usb audio config

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_hid/audio_conf.h.


AT32F413 Firmwary Library: audio_desc.c File Reference

  • middlewares
  • usbd_class
  • audio
Functions | Variables
audio_desc.c File Reference

usb audio device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "audio_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler audio_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb audio device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_desc.c.


AT32F413 Firmwary Library: audio_desc.h File Reference

  • middlewares
  • usbd_class
  • audio
Macros | Variables
audio_desc.h File Reference

usb audio descriptor header file More...

#include "audio_class.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Macros

#define | AUDIO_BCD_NUM 0x0100
#define | USBD_AUDIO_VENDOR_ID 0x2E3C
#define | USBD_AUDIO_PRODUCT_ID 0x5730
#define | USBD_AUDIO_SIZ_STRING_LANGID 4
#define | USBD_AUDIO_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x09
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUDIO_BINTERVAL_TIME 0x01
#define | USBD_AUDIO_CONFIG_DESC_SIZE
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler audio_desc_handler
device descriptor handler structure More...

Detailed Description

usb audio descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio_desc.h.


AT32F413 Firmwary Library: audio_hid_class.c File Reference

  • middlewares
  • usbd_class
  • audio_hid
Functions | Variables
audio_hid_class.c File Reference
#include "usbd_core.h"
#include "audio_hid_class.h"
#include "audio_hid_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static void | audio_req_get_cur (void *udev, usb_setup_type *setup)
usb audio request get cur More...
static void | audio_req_set_cur (void *udev, usb_setup_type *setup)
usb audio request set cur More...
static void | audio_req_get_min (void *udev, usb_setup_type *setup)
usb audio request get min More...
static void | audio_req_get_max (void *udev, usb_setup_type *setup)
usb audio request get max More...
static void | audio_req_get_res (void *udev, usb_setup_type *setup)
usb audio request get res More...
static void | audio_get_interface (void *udev, usb_setup_type *setup)
usb audio get interface More...
static void | audio_set_interface (void *udev, usb_setup_type *setup)
usb audio set interface More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device report function More...
usb_sts_type | class_audio_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | class_hid_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
usb_sts_type | audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0}
usbd_class_handler audio_hid_class_handler


AT32F413 Firmwary Library: audio_hid_class.h File Reference

  • middlewares
  • usbd_class
  • audio_hid
Data Structures | Macros | Functions | Variables
audio_hid_class.h File Reference
#include "usb_std.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Data Structures

struct usb_audio_hid_type
usb audio control struct More...

Macros

#define | USBD_AUHID_AUDIO_MIC_IN_EPT 0x81
endpoint define More...
#define | USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02
#define | USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83
#define | USBD_AUHID_HID_IN_EPT 0x84
usb custom hid use endpoint define More...
#define | USBD_AUHID_HID_OUT_EPT 0x05
#define | USBD_AUHID_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_AUHID_OUT_MAXPACKET_SIZE 0x40
#define | AUDIO_REMAIN_SIZE 40
endpoint support max size More...
#define | AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
#define | AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
#define | FEEDBACK_REFRESH_TIME 0x8
#define | AUDIO_REQ_CONTROL_INTERFACE 0x01
request type define More...
#define | AUDIO_REQ_CONTROL_ENDPOINT 0x02
#define | AUDIO_REQ_CONTROL_MASK 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_MUTE_CONTROL 0x01
audio set cur type define More...
#define | AUDIO_VOLUME_CONTROL 0x02
#define | AUDIO_FREQ_SET_CONTROL 0x03
#define | AUDIO_DESCRIPTOR_TYPE 0x21
audio descriptor type More...
#define | AUDIO_DESCRIPTOR_SIZE 0x09

Functions

usb_sts_type audio_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler audio_hid_class_handler


AT32F413 Firmwary Library: audio_hid_desc.c File Reference

  • middlewares
  • usbd_class
  • audio_hid
Functions | Variables
audio_hid_desc.c File Reference
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "audio_hid_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc


AT32F413 Firmwary Library: audio_hid_desc.h File Reference

  • middlewares
  • usbd_class
  • audio_hid
Macros | Variables
audio_hid_desc.h File Reference
#include "audio_hid_class.h"
#include "usbd_core.h"
#include "audio_conf.h"

Go to the source code of this file.

Macros

#define | AUHID_BCD_NUM 0x0100
#define | USBD_AUHID_VENDOR_ID 0x2E3C
#define | USBD_AUHID_PRODUCT_ID 0x5555
#define | USBD_AUHID_SIZ_STRING_LANGID 4
#define | USBD_AUHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"
#define | USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"
#define | USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"
#define | AUDIO_SUBCLASS_UNDEFINED 0x00
audio interface subclass codes More...
#define | AUDIO_SUBCLASS_AUDIOCONTROL 0x01
#define | AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
#define | AUDIO_SUBCLASS_MIDISTREMING 0x03
#define | AUDIO_CS_INTERFACE 0x24
audio class-specific descriptor types More...
#define | AUDIO_CS_ENDPOINT 0x25
#define | AUDIO_CS_STRING 0x23
#define | AUDIO_CS_CONFIGURATION 0x22
#define | AUDIO_CS_DEVICE 0x21
#define | AUDIO_CS_UNDEFINED 0x20
#define | AUDIO_PROTOCOL_UNDEFINED 0x00
audio interface protocol codes More...
#define | AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
audio class-specific ac interface descriptor subtypes More...
#define | AUDIO_AC_HEADER 0x01
#define | AUDIO_AC_INPUT_TERMINAL 0x02
#define | AUDIO_AC_OUTPUT_TERMINAL 0x03
#define | AUDIO_AC_MIXER_UNIT 0x04
#define | AUDIO_AC_SELECTOR_UNIT 0x05
#define | AUDIO_AC_FEATURE_UNIT 0x06
#define | AUDIO_AC_PROCESSING_UNIT 0x07
#define | AUDIO_AC_EXTENSION_UNIT 0x08
#define | AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
audio class-specific as interface descriptor subtypes More...
#define | AUDIO_AS_GENERAL 0x01
#define | AUDIO_AS_FORMAT_TYPE 0x02
#define | AUDIO_AS_FORMAT_SPECIFIC 0x03
#define | AUDIO_REQUEST_CODE_UNDEFINED 0x00
audio class-specific request codes More...
#define | AUDIO_REQ_SET_CUR 0x01
#define | AUDIO_REQ_GET_CUR 0x81
#define | AUDIO_REQ_SET_MIN 0x02
#define | AUDIO_REQ_GET_MIN 0x82
#define | AUDIO_REQ_SET_MAX 0x03
#define | AUDIO_REQ_GET_MAX 0x83
#define | AUDIO_REQ_SET_RES 0x04
#define | AUDIO_REQ_GET_RES 0x84
#define | AUDIO_REQ_SET_MEM 0x05
#define | AUDIO_REQ_GET_MEM 0x85
#define | AUDIO_REQ_GET_STAT 0xFF
#define | AUDIO_FU_CONTROL_UNDEFINED 0x00
audio feature unit control selectors More...
#define | AUDIO_FU_MUTE_CONTROL 0x01
#define | AUDIO_FU_VOLUME_CONTROL 0x02
#define | AUDIO_FU_BASS_CONTROL 0x03
#define | AUDIO_FU_MID_CONTROL 0x04
#define | AUDIO_FU_TREBLE_CONTROL 0x05
#define | AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
audio terminal type More...
#define | AUDIO_TERMINAL_TYPE_STREAMING 0x0101
#define | AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
#define | AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
#define | AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
#define | AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
#define | AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
#define | AUDIO_FORMAT_TYPE_I 0x01
audio format type 1 More...
#define | AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
audio interface config More...
#define | AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
#define | AUDIO_MIC_INTERFACE 0x01
#define | AUDIO_SPK_INTERFACE 0x02
#define | AUDIO_INPUT_TERMINAL_SIZE 0x0C
audio interface descriptor size define More...
#define | AUDIO_OUTPUT_TERMINAL_SIZE 0x09
#define | AUDIO_FEATURE_UNIT_SIZE 0x09
#define | AUDIO_MIC_INPUT_TERMINAL_ID 0x01
audio terminal id define More...
#define | AUDIO_MIC_FEATURE_UNIT_ID 0x02
#define | AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
#define | AUDIO_SPK_INPUT_TERMINAL_ID 0x04
#define | AUDIO_SPK_FEATURE_UNIT_ID 0x05
#define | AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
#define | AUDIO_MIC_INTERFACE_NUMBER 0x01
audio interface number More...
#define | AUDIO_SPK_INTERFACE_NUMBER 0x02
#define | HID_INTERFACE_NUMBER 0x03
#define | AT32_AUDIO_FREQ_16K 16000
audio support freq More...
#define | AT32_AUDIO_FREQ_48K 48000
#define | AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio microphone freq and channel config More...
#define | AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
#define | AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
#define | AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
audio speaker freq and channel config More...
#define | AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
#define | AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
#define | AUHID_HID_BINTERVAL_TIME 0x01
#define | AUHID_HID_BCD_NUM 0x0110
usb bcd number define More...
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)
#define | SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
#define | USBD_AUHID_HID_SIZ_REPORT_DESC 126
#define | USBD_AUHID_HID_DESC_SIZE 32
#define | USBD_AUHID_CONFIG_DESC_SIZE

Variables

uint8_t | g_usbd_audio_hid_report [126]
usb hid report descriptor More...
uint8_t | g_audio_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure More...


AT32F413 Firmwary Library: cdc_class.c File Reference

  • middlewares
  • usbd_class
  • cdc
Functions | Variables
cdc_class.c File Reference

usb cdc class type More...

#include "usbd_core.h"
#include "cdc_class.h"
#include "cdc_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_struct_init (cdc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_struct_type cdc_struct
usbd_class_handler cdc_class_handler

Detailed Description

usb cdc class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_class.c.


AT32F413 Firmwary Library: cdc_class.h File Reference

  • middlewares
  • usbd_class
  • cdc
Data Structures | Macros | Functions | Variables
cdc_class.h File Reference

usb cdc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct cdc_struct_type
usb cdc class struct More...

Macros

#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x81
#define | USBD_CDC_BULK_OUT_EPT 0x01
#define | USBD_CDC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler cdc_class_handler

Detailed Description

usb cdc class file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_class.h.


AT32F413 Firmwary Library: cdc_desc.c File Reference

  • middlewares
  • usbd_class
  • cdc
Functions | Variables
cdc_desc.c File Reference

usb cdc device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "cdc_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb cdc device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_desc.c.


AT32F413 Firmwary Library: cdc_desc.h File Reference

  • middlewares
  • usbd_class
  • cdc
Macros | Variables
cdc_desc.h File Reference

usb cdc descriptor header file More...

#include "cdc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_PRODUCT_ID 0x5740
#define | USBD_CDC_CONFIG_DESC_SIZE 67
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler cdc_desc_handler
device descriptor handler structure More...

Detailed Description

usb cdc descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_desc.h.


AT32F413 Firmwary Library: cdc_keyboard_class.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Macros | Functions | Variables
cdc_keyboard_class.c File Reference

usb cdc and keyboard class type More...

#include "usbd_core.h"
#include "cdc_keyboard_class.h"
#include "cdc_keyboard_desc.h"

Go to the source code of this file.

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | keyboard_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function More...
uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

vcp_keyboard_type vcp_keyboard_struct
static const unsigned char _asciimap [128]
linecoding_type linecoding_vcpkybrd
usbd_class_handler cdc_keyboard_class_handler

Detailed Description

usb cdc and keyboard class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_class.c.


AT32F413 Firmwary Library: cdc_keyboard_class.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Data Structures | Macros | Functions | Variables
cdc_keyboard_class.h File Reference

usb cdc and keyboard class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct vcp_keyboard_type

Macros

#define | USBD_VCPKYBRD_CDC_INT_EPT 0x82
usb use endpoint define More...
#define | USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81
#define | USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01
#define | USBD_VCPKYBRD_HID_IN_EPT 0x83
#define | USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40
usb in and out max packet size define More...
#define | USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40
#define | USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08

Functions

uint16_t | usb_vcpkybrd_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcpkybrd_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
usb_sts_type | usb_vcpkybrd_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_vcpkybrd_keyboard_send_char (void *udev, uint8_t ascii_code)
usb keyoard send char More...

Variables

usbd_class_handler cdc_keyboard_class_handler

Detailed Description

usb cdc and keyboard class file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_class.h.


AT32F413 Firmwary Library: cdc_keyboard_desc.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Functions | Variables
cdc_keyboard_desc.c File Reference

usb cdc and keyboard device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "cdc_keyboard_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb cdc and keyboard device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_desc.c.


AT32F413 Firmwary Library: cdc_keyboard_desc.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
Macros | Variables
cdc_keyboard_desc.h File Reference

usb cdc and keyboard descriptor header file More...

#include "cdc_keyboard_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | VCPKYBRD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_VCPKYBRD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_VCPKYBRD_PRODUCT_ID 0x5750
#define | USBD_VCPKYBRD_CONFIG_DESC_SIZE 108
usb descriptor size define More...
#define | USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63
#define | USBD_VCPKYBRD_SIZ_STRING_LANGID 4
#define | USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A
#define | USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"
#define | USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"
#define | USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"
#define | VCPKYBRD_HID_BINTERVAL_TIME 0x0A
usb endpoint interval define More...
#define | VCPKYBRD_CDC_INTERFACE 0x00
usb interface define More...
#define | VCPKYBRD_CDC_DATA_INTERFACE 0x01
#define | VCPKYBRD_KEYBOARD_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_vcpkybrd_hid_report [63]
usb hid keyboard report descriptor More...
uint8_t | g_vcpkybrd_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure More...

Detailed Description

usb cdc and keyboard descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_keyboard_desc.h.


AT32F413 Firmwary Library: cdc_msc_class.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Functions | Variables
cdc_msc_class.c File Reference

usb cdc class type More...

#include "usbd_core.h"
#include "cdc_msc_class.h"
#include "cdc_msc_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
static usb_sts_type | cdc_struct_init (cdc_msc_struct_type *pcdc)
usb device cdc init More...
void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
static void | usb_vcp_cmd_process (void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function More...
static usb_sts_type | cdc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | msc_class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

linecoding_type linecoding
cdc_msc_struct_type cdc_msc_struct
usbd_class_handler cdc_msc_class_handler

Detailed Description

usb cdc class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_class.c.


AT32F413 Firmwary Library: cdc_msc_class.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Data Structures | Macros | Functions | Variables
cdc_msc_class.h File Reference

usb cdc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct | cbd_typical_type
typical command block description More...
struct | cbd_extended_type
extended command block description More...
struct | cbw_type
command block wrapper More...
struct | csw_type
command block wrapper More...
struct | sense_type
request sense standard data More...
struct | msc_type
struct | cdc_msc_struct_type
usb cdc class struct More...

Macros

#define | USBD_CDC_INT_EPT 0x82
usb cdc use endpoint define More...
#define | USBD_CDC_BULK_IN_EPT 0x83
#define | USBD_CDC_BULK_OUT_EPT 0x02
#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40
usb cdc in and out max packet size define More...
#define | USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40
#define | USBD_CDC_CMD_MAXPACKET_SIZE 0x08
#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36

Functions

uint16_t | usb_vcp_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_vcp_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...
void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *pudev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *pudev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...

Variables

usbd_class_handler cdc_msc_class_handler

Detailed Description

usb cdc class file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_class.h.


AT32F413 Firmwary Library: cdc_msc_desc.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Macros | Functions | Variables
cdc_msc_desc.c File Reference

usb cdc device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "cdc_msc_desc.h"

Go to the source code of this file.

Macros

#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb cdc device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_desc.c.


AT32F413 Firmwary Library: cdc_msc_desc.h File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Macros | Variables
cdc_msc_desc.h File Reference

usb cdc descriptor header file More...

#include "cdc_msc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | CDC_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CDC_MSC_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CDC_MSC_PRODUCT_ID 0x5760
#define | USBD_CDC_MSC_CONFIG_DESC_SIZE 106
usb descriptor size define More...
#define | USBD_CDC_SIZ_STRING_LANGID 4
#define | USBD_CDC_SIZ_STRING_SERIAL 0x1A
#define | USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "
#define | USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"
#define | USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"
#define | CDC_HID_BINTERVAL_TIME 0xFF
usb endpoint interval define More...
#define | VCPMSC_MSC_INTERFACE 0x00
usb interface define More...
#define | VCPMSC_CDC_INTERFACE 0x01
#define | VCPMSC_CDC_DATA_INTERFACE 0x02
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure More...

Detailed Description

usb cdc descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file cdc_msc_desc.h.


AT32F413 Firmwary Library: msc_bot_scsi.c File Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
Functions | Variables
composite_cdc_msc/msc_bot_scsi.c File Reference

usb mass storage bulk-only transport and scsi command More...

#include "cdc_msc_class.h"
#include "msc_diskio.h"

Go to the source code of this file.

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *udev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *udev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...

Variables

ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL

Detailed Description

usb mass storage bulk-only transport and scsi command

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_cdc_msc/msc_bot_scsi.c.


AT32F413 Firmwary Library: msc_bot_scsi.c File Reference

  • middlewares
  • usbd_class
  • msc
Functions | Variables
msc/msc_bot_scsi.c File Reference

usb mass storage bulk-only transport and scsi command More...

#include "msc_bot_scsi.h"
#include "msc_diskio.h"

Go to the source code of this file.

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *udev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *udev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...

Variables

ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL

Detailed Description

usb mass storage bulk-only transport and scsi command

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc/msc_bot_scsi.c.


AT32F413 Firmwary Library: custom_hid_class.c File Reference

  • middlewares
  • usbd_class
  • custom_hid
Functions | Variables
custom_hid_class.c File Reference

usb custom hid class type More...

#include "usbd_core.h"
#include "custom_hid_class.h"
#include "custom_hid_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
static void | usb_hid_buf_process (void *udev, uint8_t *report, uint16_t len)
usb device class report function More...
usb_sts_type | custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

custom_hid_type custom_hid_struct
usbd_class_handler custom_hid_class_handler

Detailed Description

usb custom hid class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_class.c.


AT32F413 Firmwary Library: custom_hid_class.h File Reference

  • middlewares
  • usbd_class
  • custom_hid
Data Structures | Macros | Functions | Variables
custom_hid_class.h File Reference

usb custom hid header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct custom_hid_type

Macros

#define | USBD_CUSTOM_HID_IN_EPT 0x81
usb custom hid use endpoint define More...
#define | USBD_CUSTOM_HID_OUT_EPT 0x01
#define | USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40
usb custom hid in and out max packet size define More...
#define | USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40

Functions

usb_sts_type custom_hid_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

usbd_class_handler custom_hid_class_handler

Detailed Description

usb custom hid header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_class.h.


AT32F413 Firmwary Library: custom_hid_desc.c File Reference

  • middlewares
  • usbd_class
  • custom_hid
Functions | Variables
custom_hid_desc.c File Reference

usb hid device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "custom_hid_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_desc.c.


AT32F413 Firmwary Library: custom_hid_desc.h File Reference

  • middlewares
  • usbd_class
  • custom_hid
Macros | Variables
custom_hid_desc.h File Reference

usb custom hid descriptor header file More...

#include "custom_hid_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | CUSHID_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_CUSHID_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_CUSHID_PRODUCT_ID 0x5745
#define | USBD_CUSHID_CONFIG_DESC_SIZE 41
usb descriptor size define More...
#define | USBD_CUSHID_SIZ_REPORT_DESC 126
#define | USBD_CUSHID_SIZ_STRING_LANGID 4
#define | USBD_CUSHID_SIZ_STRING_SERIAL 0x1A
#define | USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"
#define | USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"
#define | USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"
#define | CUSHID_BINTERVAL_TIME 0x0A
#define | HID_REPORT_ID_1 0x01
usb hid report id define More...
#define | HID_REPORT_ID_2 0x02
#define | HID_REPORT_ID_3 0x03
#define | HID_REPORT_ID_4 0x04
#define | HID_REPORT_ID_5 0x05
#define | HID_REPORT_ID_6 0xF0
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_custom_hid_report [126]
usb hid report descriptor More...
uint8_t | g_custom_hid_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure More...

Detailed Description

usb custom hid descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file custom_hid_desc.h.


AT32F413 Firmwary Library: hid_iap_class.c File Reference

  • middlewares
  • usbd_class
  • hid_iap
Functions | Variables
hid_iap_class.c File Reference

usb hid iap class type More...

#include "usbd_core.h"
#include "hid_iap_class.h"
#include "hid_iap_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...

Variables

iap_info_type iap_info
usbd_class_handler hid_iap_class_handler

Detailed Description

usb hid iap class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_class.c.


AT32F413 Firmwary Library: hid_iap_class.h File Reference

  • middlewares
  • usbd_class
  • hid_iap
Data Structures | Macros | Enumerations | Functions | Variables
hid_iap_class.h File Reference

usb hid iap header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct iap_info_type

Macros

#define | USBD_HIDIAP_IN_EPT 0x81
#define | USBD_HIDIAP_OUT_EPT 0x01
#define | USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40
#define | USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40
#define | FLASH_SIZE_REG() ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/
#define | KB_TO_B(kb) ((kb) << 10)
#define | SECTOR_SIZE_1K 0x400
#define | SECTOR_SIZE_2K 0x800
#define | SECTOR_SIZE_4K 0x1000
#define | IAP_CMD_IDLE 0x5AA0
iap command More...
#define | IAP_CMD_START 0x5AA1
#define | IAP_CMD_ADDR 0x5AA2
#define | IAP_CMD_DATA 0x5AA3
#define | IAP_CMD_FINISH 0x5AA4
#define | IAP_CMD_CRC 0x5AA5
#define | IAP_CMD_JMP 0x5AA6
#define | IAP_CMD_GET 0x5AA7
#define | HID_IAP_BUFFER_LEN 1024
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | CONVERT_ENDIAN(dwValue)
#define | IAP_ACK 0xFF00
#define | IAP_NACK 0x00FF

Enumerations

enum iap_result_type { IAP_SUCCESS , IAP_WAIT , IAP_FAILED }
enum iap_machine_state_type {
IAP_STS_IDLE , IAP_STS_START , IAP_STS_ADDR , IAP_STS_DATA ,
IAP_STS_FINISH , IAP_STS_CRC , IAP_STS_JMP_WAIT , IAP_STS_JMP
}

Functions

usb_sts_type | usb_iap_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *report, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...

Variables

usbd_class_handler hid_iap_class_handler
iap_info_type iap_info

Detailed Description

usb hid iap header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_class.h.


AT32F413 Firmwary Library: hid_iap_desc.c File Reference

  • middlewares
  • usbd_class
  • hid_iap
Functions | Variables
hid_iap_desc.c File Reference

usb hid device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "hid_iap_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_desc.c.


AT32F413 Firmwary Library: hid_iap_desc.h File Reference

  • middlewares
  • usbd_class
  • hid_iap
Macros | Variables
hid_iap_desc.h File Reference

usb hid descriptor header file More...

#include "hid_iap_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | HIDIAP_BCD_NUM 0x0110
#define | USBD_HIDIAP_VENDOR_ID 0x2E3C
#define | USBD_HIDIAP_PRODUCT_ID 0xAF01
#define | USBD_HIDIAP_CONFIG_DESC_SIZE 41
#define | USBD_HIDIAP_SIZ_REPORT_DESC 32
#define | USBD_HIDIAP_SIZ_STRING_LANGID 4
#define | USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A
#define | USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"
#define | USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"
#define | USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"
#define | HIDIAP_BINTERVAL_TIME 0x01
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_hidiap_report [32]
usb hid report descriptor More...
uint8_t | g_hidiap_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure More...

Detailed Description

usb hid descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file hid_iap_desc.h.


AT32F413 Firmwary Library: keyboard_class.c File Reference

  • middlewares
  • usbd_class
  • keyboard
Macros | Functions | Variables
keyboard_class.c File Reference

usb hid keyboard class type More...

#include "usbd_core.h"
#include "keyboard_class.h"
#include "keyboard_desc.h"

Go to the source code of this file.

Macros

#define SHIFT 0x80

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...

Variables

keyboard_type keyboard_struct
static const unsigned char _asciimap [128]
usbd_class_handler keyboard_class_handler

Detailed Description

usb hid keyboard class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_class.c.


AT32F413 Firmwary Library: keyboard_class.h File Reference

  • middlewares
  • usbd_class
  • keyboard
Data Structures | Macros | Functions | Variables
keyboard_class.h File Reference

usb hid keyboard header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct keyboard_type

Macros

#define | USBD_KEYBOARD_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...
#define | USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40

Functions

usb_sts_type | usb_keyboard_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_keyboard_send_char (void *udev, uint8_t ascii_code)
usb device class report function More...

Variables

usbd_class_handler keyboard_class_handler

Detailed Description

usb hid keyboard header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_class.h.


AT32F413 Firmwary Library: keyboard_desc.c File Reference

  • middlewares
  • usbd_class
  • keyboard
Functions | Variables
keyboard_desc.c File Reference

usb hid keyboard device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "keyboard_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid keyboard device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_desc.c.


AT32F413 Firmwary Library: keyboard_desc.h File Reference

  • middlewares
  • usbd_class
  • keyboard
Macros | Variables
keyboard_desc.h File Reference

usb keyboard descriptor header file More...

#include "keyboard_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | KEYBOARD_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_KEYBOARD_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_KEYBOARD_PRODUCT_ID 0x6040
#define | USBD_KEYBOARD_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_KEYBOARD_SIZ_REPORT_DESC 63
#define | USBD_KEYBOARD_SIZ_STRING_LANGID 4
#define | USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A
#define | USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"
#define | USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"
#define | USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"
#define | KEYBOARD_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_keyboard_report [63]
usb mouse report descriptor More...
uint8_t | g_keyboard_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure More...

Detailed Description

usb keyboard descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file keyboard_desc.h.


AT32F413 Firmwary Library: mouse_class.c File Reference

  • middlewares
  • usbd_class
  • mouse
Functions | Variables
mouse_class.c File Reference

usb hid mouse class type More...

#include "usbd_core.h"
#include "mouse_class.h"
#include "mouse_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device class endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device class endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device class transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device class endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device class sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device class event handler More...
usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

mouse_type mouse_struct
usbd_class_handler mouse_class_handler

Detailed Description

usb hid mouse class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_class.c.


AT32F413 Firmwary Library: mouse_class.h File Reference

  • middlewares
  • usbd_class
  • mouse
Data Structures | Macros | Functions | Variables
mouse_class.h File Reference

usb hid mouse header file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct mouse_type

Macros

#define | USBD_MOUSE_IN_EPT 0x81
usb hid use endpoint define More...
#define | USBD_MOUSE_IN_MAXPACKET_SIZE 0x40
usb hid in and out max packet size define More...
#define | MOVE_STEP 20
usb hid mouse operation More...
#define | BUTTON_RELEASE 0
#define | LEFT_BUTTON 1
#define | RIGHT_BUTTON 2
#define | LEFT_MOVE 3
#define | RIGHT_MOVE 4
#define | UP_MOVE 5
#define | DOWN_MOVE 6

Functions

usb_sts_type | usb_mouse_class_send_report (void *udev, uint8_t *report, uint16_t len)
usb device class send report More...
void | usb_hid_mouse_send (void *udev, uint8_t op)
usb device class report function More...

Variables

usbd_class_handler mouse_class_handler

Detailed Description

usb hid mouse header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_class.h.


AT32F413 Firmwary Library: mouse_desc.c File Reference

  • middlewares
  • usbd_class
  • mouse
Functions | Variables
mouse_desc.c File Reference

usb hid mouse device descriptor More...

#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "mouse_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb hid mouse device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_desc.c.


AT32F413 Firmwary Library: mouse_desc.h File Reference

  • middlewares
  • usbd_class
  • mouse
Macros | Variables
mouse_desc.h File Reference

usb mouse descriptor header file More...

#include "mouse_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | MOUSE_BCD_NUM 0x0110
usb bcd number define More...
#define | USBD_MOUSE_VENDOR_ID 0x2E3C
usb vendor id and product id define More...
#define | USBD_MOUSE_PRODUCT_ID 0x5710
#define | USBD_MOUSE_CONFIG_DESC_SIZE 34
usb descriptor size define More...
#define | USBD_MOUSE_SIZ_REPORT_DESC 74
#define | USBD_MOUSE_SIZ_STRING_LANGID 4
#define | USBD_MOUSE_SIZ_STRING_SERIAL 0x1A
#define | USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"
usb string define(vendor, product configuration, interface) More...
#define | USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"
#define | USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"
#define | USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"
#define | MOUSE_BINTERVAL_TIME 0x0A
usb hid endpoint interval define More...
#define | MCU_ID1 (0x1FFFF7E8)
usb mcu id address deine More...
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

uint8_t | g_usbd_mouse_report [74]
usb mouse report descriptor More...
uint8_t | g_mouse_usb_desc [9]
usb hid descriptor More...
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure More...

Detailed Description

usb mouse descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file mouse_desc.h.


AT32F413 Firmwary Library: msc_bot_scsi.h File Reference

  • middlewares
  • usbd_class
  • msc
Data Structures | Macros | Functions
msc_bot_scsi.h File Reference

usb mass storage bulk-only transport and scsi command header file More...

#include "msc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct | cbd_typical_type
typical command block description More...
struct | cbd_extended_type
extended command block description More...
struct | cbw_type
command block wrapper More...
struct | csw_type
command block wrapper More...
struct | sense_type
request sense standard data More...
struct | msc_type

Macros

#define | MSC_SUPPORT_MAX_LUN 1
#define | MSC_MAX_DATA_BUF_LEN 4096
#define | MSC_CMD_FORMAT_UNIT 0x04
#define | MSC_CMD_INQUIRY 0x12
#define | MSC_CMD_START_STOP 0x1B
#define | MSC_CMD_MODE_SENSE6 0x1A
#define | MSC_CMD_MODE_SENSE10 0x5A
#define | MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
#define | MSC_CMD_READ_10 0x28
#define | MSC_CMD_READ_12 0xA8
#define | MSC_CMD_READ_CAPACITY 0x25
#define | MSC_CMD_READ_FORMAT_CAPACITY 0x23
#define | MSC_CMD_REQUEST_SENSE 0x03
#define | MSC_CMD_TEST_UNIT 0x00
#define | MSC_CMD_VERIFY 0x2F
#define | MSC_CMD_WRITE_10 0x2A
#define | MSC_CMD_WRITE_12 0xAA
#define | MSC_CMD_WRITE_VERIFY 0x2E
#define | MSC_REQ_GET_MAX_LUN 0xFE
#define | MSC_REQ_BO_RESET 0xFF
#define | SET_LINE_CODING 0x20
#define | GET_LINE_CODING 0x21
#define | CBW_CMD_LENGTH 31
#define | CBW_DCBWSIGNATURE 0x43425355
#define | CBW_BMCBWFLAGS_DIR_OUT 0x00
#define | CBW_BMCBWFLAGS_DIR_IN 0x80
#define | CSW_CMD_LENGTH 13
#define | CSW_DCSWSIGNATURE 0x53425355
#define | CSW_BCSWSTATUS_PASS 0x00
#define | CSW_BCSWSTATUS_FAILED 0x01
#define | CSW_BCSWSTATUS_PHASE_ERR 0x02
#define | MSC_STATE_MACHINE_CMD 0x00
#define | MSC_STATE_MACHINE_DATA_IN 0x01
#define | MSC_STATE_MACHINE_DATA_OUT 0x02
#define | MSC_STATE_MACHINE_SEND_DATA 0x03
#define | MSC_STATE_MACHINE_LAST_DATA 0x04
#define | MSC_STATE_MACHINE_STATUS 0x05
#define | MSC_STATE_MACHINE_FAILED 0x06
#define | MSC_STATE_MACHINE_IDLE 0x07
#define | MSC_BOT_STATE_IDLE 0x00
#define | MSC_BOT_STATE_RECOVERY 0x01
#define | MSC_BOT_STATE_ERROR 0x02
#define | REQ_SENSE_STANDARD_DATA_LEN 0x12
#define | SENSE_KEY_NO_SENSE 0x00
#define | SENSE_KEY_RECOVERED_ERROR 0x01
#define | SENSE_KEY_NOT_READY 0x02
#define | SENSE_KEY_MEDIUM_ERROR 0x03
#define | SENSE_KEY_HARDWARE_ERROR 0x04
#define | SENSE_KEY_ILLEGAL_REQUEST 0x05
#define | SENSE_KEY_UNIT_ATTENTION 0x06
#define | SENSE_KEY_DATA_PROTECT 0x07
#define | SENSE_KEY_BLANK_CHECK 0x08
#define | SENSE_KEY_VENDERO_SPECIFIC 0x09
#define | SENSE_KEY_ABORTED_COMMAND 0x0B
#define | SENSE_KEY_VOLUME_OVERFLOW 0x0D
#define | SENSE_KEY_MISCOMPARE 0x0E
#define | INVALID_COMMAND 0x20
#define | INVALID_FIELED_IN_COMMAND 0x24
#define | PARAMETER_LIST_LENGTH_ERROR 0x1A
#define | INVALID_FIELD_IN_PARAMETER_LIST 0x26
#define | ADDRESS_OUT_OF_RANGE 0x21
#define | MEDIUM_NOT_PRESENT 0x3A
#define | MEDIUM_HAVE_CHANGED 0x28
#define | SCSI_INQUIRY_DATA_LENGTH 36

Functions

void | bot_scsi_init (void *udev)
initialize bulk-only transport and scsi More...
void | bot_scsi_reset (void *udev)
reset bulk-only transport and scsi More...
void | bot_scsi_datain_handler (void *pudev, uint8_t ept_num)
bulk-only transport data in handler More...
void | bot_scsi_dataout_handler (void *pudev, uint8_t ept_num)
bulk-only transport data out handler More...
void | bot_cbw_decode (void *udev)
bulk-only cbw decode More...
void | bot_scsi_send_data (void *udev, uint8_t *buffer, uint32_t len)
send bot data More...
void | bot_scsi_send_csw (void *udev, uint8_t status)
send command status More...
void | bot_scsi_sense_code (void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code More...
usb_sts_type | bot_scsi_check_address (void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address More...
void | bot_scsi_stall (void *udev)
bot endpoint stall More...
usb_sts_type | bot_scsi_cmd_process (void *udev)
bulk-only transport scsi command process More...
usb_sts_type | bot_scsi_test_unit (void *udev, uint8_t lun)
bulk-only transport scsi command test unit More...
usb_sts_type | bot_scsi_inquiry (void *udev, uint8_t lun)
bulk-only transport scsi command inquiry More...
usb_sts_type | bot_scsi_start_stop (void *udev, uint8_t lun)
bulk-only transport scsi command start stop More...
usb_sts_type | bot_scsi_allow_medium_removal (void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal More...
usb_sts_type | bot_scsi_mode_sense6 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6 More...
usb_sts_type | bot_scsi_mode_sense10 (void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10 More...
usb_sts_type | bot_scsi_read10 (void *udev, uint8_t lun)
bulk-only transport scsi command read10 More...
usb_sts_type | bot_scsi_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command capacity More...
usb_sts_type | bot_scsi_format_capacity (void *udev, uint8_t lun)
bulk-only transport scsi command format capacity More...
usb_sts_type | bot_scsi_request_sense (void *udev, uint8_t lun)
bulk-only transport scsi command request sense More...
usb_sts_type | bot_scsi_verify (void *udev, uint8_t lun)
bulk-only transport scsi command verify More...
usb_sts_type | bot_scsi_write10 (void *udev, uint8_t lun)
bulk-only transport scsi command write10 More...
void | bot_scsi_clear_feature (void *udev, uint8_t ept_num)
clear feature More...

Detailed Description

usb mass storage bulk-only transport and scsi command header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_bot_scsi.h.


AT32F413 Firmwary Library: msc_class.c File Reference

  • middlewares
  • usbd_class
  • msc
Functions | Variables
msc_class.c File Reference

usb msc class type More...

#include "usbd_core.h"
#include "msc_class.h"
#include "msc_desc.h"
#include "msc_bot_scsi.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...

Variables

msc_type msc_struct
usbd_class_handler msc_class_handler

Detailed Description

usb msc class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_class.c.


AT32F413 Firmwary Library: msc_class.h File Reference

  • middlewares
  • usbd_class
  • msc
Macros | Variables
msc_class.h File Reference

usb msc class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | USBD_MSC_BULK_IN_EPT 0x81
#define | USBD_MSC_BULK_OUT_EPT 0x01
#define | USBD_IN_MAXPACKET_SIZE 0x40
#define | USBD_OUT_MAXPACKET_SIZE 0x40

Variables

usbd_class_handler msc_class_handler

Detailed Description

usb msc class file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_class.h.


AT32F413 Firmwary Library: msc_desc.c File Reference

  • middlewares
  • usbd_class
  • msc
Functions | Variables
msc_desc.c File Reference

usb msc device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "msc_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler msc_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb msc device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_desc.c.


AT32F413 Firmwary Library: msc_desc.h File Reference

  • middlewares
  • usbd_class
  • msc
Macros | Variables
msc_desc.h File Reference

usb msc descriptor header file More...

#include "msc_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | MSC_BCD_NUM 0x0110
#define | USBD_MSC_VENDOR_ID 0x2E3C
#define | USBD_MSC_PRODUCT_ID 0x5720
#define | USBD_MSC_CONFIG_DESC_SIZE 32
#define | USBD_MSC_SIZ_STRING_LANGID 4
#define | USBD_MSC_SIZ_STRING_SERIAL 0x1A
#define | USBD_MSC_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"
#define | USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"
#define | USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler msc_desc_handler
device descriptor handler structure More...

Detailed Description

usb msc descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc_desc.h.


AT32F413 Firmwary Library: printer_class.c File Reference

  • middlewares
  • usbd_class
  • printer
Functions | Variables
printer_class.c File Reference

usb printer class type More...

#include "usbd_core.h"
#include "printer_class.h"
#include "printer_desc.h"

Go to the source code of this file.

Functions

static usb_sts_type | class_init_handler (void *udev)
initialize usb custom hid endpoint More...
static usb_sts_type | class_clear_handler (void *udev)
clear endpoint or other state More...
static usb_sts_type | class_setup_handler (void *udev, usb_setup_type *setup)
usb device class setup request handler More...
static usb_sts_type | class_ept0_tx_handler (void *udev)
usb device endpoint 0 in status stage complete More...
static usb_sts_type | class_ept0_rx_handler (void *udev)
usb device endpoint 0 out status stage complete More...
static usb_sts_type | class_in_handler (void *udev, uint8_t ept_num)
usb device transmision complete handler More...
static usb_sts_type | class_out_handler (void *udev, uint8_t ept_num)
usb device endpoint receive data More...
static usb_sts_type | class_sof_handler (void *udev)
usb device sof handler More...
static usb_sts_type | class_event_handler (void *udev, usbd_event_type event)
usb device event handler More...
uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

static ALIGNED_HEAD uint8_t printer_device_id[24] ALIGNED_TAIL
printer_type printer_struct
usbd_class_handler printer_class_handler

Detailed Description

usb printer class type

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_class.c.


AT32F413 Firmwary Library: printer_class.h File Reference

  • middlewares
  • usbd_class
  • printer
Data Structures | Macros | Enumerations | Functions | Variables
printer_class.h File Reference

usb printer class file More...

#include "usb_std.h"
#include "usbd_core.h"

Go to the source code of this file.

Data Structures

struct printer_type

Macros

#define | USBD_PRINTER_BULK_IN_EPT 0x81
#define | USBD_PRINTER_BULK_OUT_EPT 0x01
#define | USBD_PRINTER_IN_MAXPACKET_SIZE 0x40
#define | USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40
#define | PRINTER_DEVICE_ID_LEN 24

Enumerations

enum printer_req_type { PRINTER_REQ_GET_DEVICE_ID = 0x00 , PRINTER_REQ_GET_PORT_STATUS = 0x01 , PRINTER_REQ_GET_SOFT_RESET = 0x02 }

Functions

uint16_t | usb_printer_get_rxdata (void *udev, uint8_t *recv_data)
usb device class rx data process More...
error_status | usb_printer_send_data (void *udev, uint8_t *send_data, uint16_t len)
usb device class send data More...

Variables

usbd_class_handler printer_class_handler

Detailed Description

usb printer class file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_class.h.


AT32F413 Firmwary Library: printer_desc.c File Reference

  • middlewares
  • usbd_class
  • printer
Functions | Variables
printer_desc.c File Reference

usb printer device descriptor More...

#include "stdio.h"
#include "usb_std.h"
#include "usbd_sdr.h"
#include "usbd_core.h"
#include "printer_desc.h"

Go to the source code of this file.

Functions

static usbd_desc_t * | get_device_descriptor (void)
get device descriptor More...
static usbd_desc_t * | get_device_qualifier (void)
get device qualifier More...
static usbd_desc_t * | get_device_configuration (void)
get config descriptor More...
static usbd_desc_t * | get_device_other_speed (void)
get other speed descriptor More...
static usbd_desc_t * | get_device_lang_id (void)
get lang id descriptor More...
static usbd_desc_t * | get_device_manufacturer_string (void)
get manufacturer descriptor More...
static usbd_desc_t * | get_device_product_string (void)
get product descriptor More...
static usbd_desc_t * | get_device_serial_string (void)
get serial descriptor More...
static usbd_desc_t * | get_device_interface_string (void)
get interface descriptor More...
static usbd_desc_t * | get_device_config_string (void)
get device config descriptor More...
static uint16_t | usbd_unicode_convert (uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert More...
static void | usbd_int_to_unicode (uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode More...
static void | get_serial_num (void)
usb get serial number More...

Variables

static uint8_t | g_usbd_desc_buffer [256]
usbd_desc_handler printer_desc_handler
device descriptor handler structure More...
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] | ALIGNED_TAIL
usb device standard descriptor More...
static usbd_desc_t | device_descriptor
static usbd_desc_t | config_descriptor
static usbd_desc_t | langid_descriptor
static usbd_desc_t | serial_descriptor
static usbd_desc_t | vp_desc

Detailed Description

usb printer device descriptor

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_desc.c.


AT32F413 Firmwary Library: printer_desc.h File Reference

  • middlewares
  • usbd_class
  • printer
Macros | Variables
printer_desc.h File Reference

usb printer descriptor header file More...

#include "printer_class.h"
#include "usbd_core.h"

Go to the source code of this file.

Macros

#define | PRINTER_BCD_NUM 0x0110
#define | USBD_PRINTER_VENDOR_ID 0x2E3C
#define | USBD_PRINTER_PRODUCT_ID 0x57FF
#define | USBD_PRINTER_CONFIG_DESC_SIZE 32
#define | USBD_PRINTER_SIZ_STRING_LANGID 4
#define | USBD_PRINTER_SIZ_STRING_SERIAL 0x1A
#define | USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"
#define | USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"
#define | USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"
#define | USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"
#define | PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01
#define | PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02
#define | PRINTER_PROTOCOL_1284_4 0x03
#define | PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF
#define | MCU_ID1 (0x1FFFF7E8)
#define | MCU_ID2 (0x1FFFF7EC)
#define | MCU_ID3 (0x1FFFF7F0)

Variables

usbd_desc_handler printer_desc_handler
device descriptor handler structure More...

Detailed Description

usb printer descriptor header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file printer_desc.h.


AT32F413 Firmwary Library: usb_std.h File Reference

  • middlewares
  • usbd_drivers
  • inc
Data Structures | Macros | Enumerations
usb_std.h File Reference

usb standard header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | linecoding_type
usb cdc class set line coding struct More...
struct | usb_setup_type
format of usb setup data More...
struct | usb_device_desc_type
format of standard device descriptor More...
struct | usb_configuration_desc_type
format of standard configuration descriptor More...
struct | usb_interface_desc_type
format of standard interface descriptor More...
struct | usb_endpoint_desc_type
format of standard endpoint descriptor More...
struct | usb_header_desc_type
format of header More...

Macros

#define | USB_REQ_RECIPIENT_DEVICE 0x00
usb request recipient More...
#define | USB_REQ_RECIPIENT_INTERFACE 0x01
#define | USB_REQ_RECIPIENT_ENDPOINT 0x02
#define | USB_REQ_RECIPIENT_OTHER 0x03
#define | USB_REQ_RECIPIENT_MASK 0x1F
#define | USB_REQ_TYPE_STANDARD 0x00
usb request type More...
#define | USB_REQ_TYPE_CLASS 0x20
#define | USB_REQ_TYPE_VENDOR 0x40
#define | USB_REQ_TYPE_RESERVED 0x60
#define | USB_REQ_DIR_HTD 0x00
usb request data transfer direction More...
#define | USB_REQ_DIR_DTH 0x80
#define | USB_STD_REQ_GET_STATUS 0
usb standard device requests codes More...
#define | USB_STD_REQ_CLEAR_FEATURE 1
#define | USB_STD_REQ_SET_FEATURE 3
#define | USB_STD_REQ_SET_ADDRESS 5
#define | USB_STD_REQ_GET_DESCRIPTOR 6
#define | USB_STD_REQ_SET_DESCRIPTOR 7
#define | USB_STD_REQ_GET_CONFIGURATION 8
#define | USB_STD_REQ_SET_CONFIGURATION 9
#define | USB_STD_REQ_GET_INTERFACE 10
#define | USB_STD_REQ_SET_INTERFACE 11
#define | USB_STD_REQ_SYNCH_FRAME 12
#define | USB_DESCIPTOR_TYPE_DEVICE 1
usb standard device type More...
#define | USB_DESCIPTOR_TYPE_CONFIGURATION 2
#define | USB_DESCIPTOR_TYPE_STRING 3
#define | USB_DESCIPTOR_TYPE_INTERFACE 4
#define | USB_DESCIPTOR_TYPE_ENDPOINT 5
#define | USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6
#define | USB_DESCIPTOR_TYPE_OTHER_SPEED 7
#define | USB_DESCIPTOR_TYPE_INTERFACE_POWER 8
#define | USB_LANGID_STRING 0
usb standard string type More...
#define | USB_MFC_STRING 1
#define | USB_PRODUCT_STRING 2
#define | USB_SERIAL_STRING 3
#define | USB_CONFIG_STRING 4
#define | USB_INTERFACE_STRING 5
#define | USB_CONF_REMOTE_WAKEUP 2
usb configuration attributes More...
#define | USB_CONF_SELF_POWERED 1
#define | USB_FEATURE_EPT_HALT 0
usb standard feature selectors More...
#define | USB_FEATURE_REMOTE_WAKEUP 1
#define | USB_FEATURE_TEST_MODE 2
#define | USB_EPT0_IDLE 0
endpoint 0 state More...
#define | USB_EPT0_SETUP 1
#define | USB_EPT0_DATA_IN 2
#define | USB_EPT0_DATA_OUT 3
#define | USB_EPT0_STATUS_IN 4
#define | USB_EPT0_STATUS_OUT 5
#define | USB_EPT0_STALL 6
#define | USB_DEVICE_QUALIFIER_DESC_LEN 0x0A
usb descriptor length More...
#define | USB_DEVICE_DESC_LEN 0x12
#define | USB_DEVICE_CFG_DESC_LEN 0x09
#define | USB_DEVICE_IF_DESC_LEN 0x09
#define | USB_DEVICE_EPT_LEN 0x07
#define | USB_DEVICE_OTG_DESC_LEN 0x03
#define | USB_DEVICE_LANGID_STR_DESC_LEN 0x04
#define | USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09
#define | USB_CLASS_CODE_AUDIO 0x01
usb class code More...
#define | USB_CLASS_CODE_CDC 0x02
#define | USB_CLASS_CODE_HID 0x03
#define | USB_CLASS_CODE_PRINTER 0x07
#define | USB_CLASS_CODE_MSC 0x08
#define | USB_CLASS_CODE_HUB 0x09
#define | USB_CLASS_CODE_CDCDATA 0x0A
#define | USB_CLASS_CODE_CCID 0x0B
#define | USB_CLASS_CODE_VIDEO 0x0E
#define | USB_CLASS_CODE_VENDOR 0xFF
#define | USB_EPT_DESC_CONTROL 0x00
usb endpoint type More...
#define | USB_EPT_DESC_ISO 0x01
#define | USB_EPT_DESC_BULK 0x02
#define | USB_EPT_DESC_INTERRUPT 0x03
#define | USB_EPT_DESC_NSYNC 0x00
#define | USB_ETP_DESC_ASYNC 0x04
#define | USB_ETP_DESC_ADAPTIVE 0x08
#define | USB_ETP_DESC_SYNC 0x0C
#define | USB_EPT_DESC_DATA_EPT 0x00
#define | USB_EPT_DESC_FD_EPT 0x10
#define | USB_EPT_DESC_FDDATA_EPT 0x20
#define | USBD_CDC_CS_INTERFACE 0x24
usb cdc class descriptor define More...
#define | USBD_CDC_CS_ENDPOINT 0x25
#define | USBD_CDC_SUBTYPE_HEADER 0x00
usb cdc class sub-type define More...
#define | USBD_CDC_SUBTYPE_CMF 0x01
#define | USBD_CDC_SUBTYPE_ACM 0x02
#define | USBD_CDC_SUBTYPE_UFD 0x06
#define | SET_LINE_CODING 0x20
usb cdc class request code define More...
#define | GET_LINE_CODING 0x21
#define | HID_CLASS_DESC_HID 0x21
usb hid class descriptor define More...
#define | HID_CLASS_DESC_REPORT 0x22
#define | HID_CLASS_DESC_PHYSICAL 0x23
#define | HID_REQ_SET_PROTOCOL 0x0B
usb hid class request code define More...
#define | HID_REQ_GET_PROTOCOL 0x03
#define | HID_REQ_SET_IDLE 0x0A
#define | HID_REQ_GET_IDLE 0x02
#define | HID_REQ_SET_REPORT 0x09
#define | HID_REQ_GET_REPORT 0x01
#define | HID_DESCRIPTOR_TYPE 0x21
#define | HID_REPORT_DESC 0x22
#define | USB_MAX_EP0_SIZE 64
endpoint 0 max size More...
#define | SWAPBYTE(addr)
usb swap address More...
#define | MIN(a, b) (uint16_t)(((a) < (b)) ? (a) : (b))
min and max define More...
#define | MAX(a, b) (uint16_t)(((a) > (b)) ? (a) : (b))
#define | LBYTE(x) ((uint8_t)(x & 0x00FF))
low byte and high byte define More...
#define | HBYTE(x) ((uint8_t)((x & 0xFF00) >>8))

Enumerations

enum usbd_conn_state { USB_CONN_STATE_DEFAULT =1 , USB_CONN_STATE_ADDRESSED , USB_CONN_STATE_CONFIGURED , USB_CONN_STATE_SUSPENDED }
usb device connect state More...
enum usb_sts_type {
USB_OK , USB_FAIL , USB_WAIT , USB_NOT_SUPPORT ,
USB_ERROR
}
usb return status More...

Detailed Description

usb standard header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usb_std.h.


AT32F413 Firmwary Library: usbd_core.h File Reference

  • middlewares
  • usbd_drivers
  • inc
Data Structures | Enumerations | Functions
usbd_core.h File Reference

usb device core header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Data Structures

struct | usbd_desc_t
usb device descriptor struct More...
struct | usbd_desc_handler
usb device descriptor handler More...
struct | usbd_class_handler
usb device class handler More...
struct | usbd_core_type
usb device core struct type More...

Enumerations

enum usbd_event_type {
USBD_NOP_EVENT , USBD_RESET_EVENT , USBD_SUSPEND_EVENT , USBD_WAKEUP_EVENT ,
USBD_ERR_EVENT
}
usb device event More...

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_num)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_num)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall. More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_ept_dbuffer_enable (usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer. More...
void | usbd_ept_buf_auto_define (usb_ept_info *ept_info)
usb auto define endpoint buffer More...
void | usbd_ept_buf_custom_define (usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer More...
void | usbd_ept_defaut_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core More...

Detailed Description

usb device core header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_core.h.


AT32F413 Firmwary Library: usbd_int.h File Reference

  • middlewares
  • usbd_drivers
  • inc
Functions
usbd_int.h File Reference
#include "usbd_core.h"

Go to the source code of this file.

Functions

void | usbd_irq_handler (usbd_core_type *udev)
usb device interrput request handler. More...
void | usbd_ept_loop_handler (usbd_core_type *udev)
usb device endpoint loop handler. More...
void | usbd_eptn_handler (usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler. More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...


AT32F413 Firmwary Library: usbd_sdr.h File Reference

  • middlewares
  • usbd_drivers
  • inc
Functions
usbd_sdr.h File Reference

usb standard request header file More...

#include "usbd_core.h"

Go to the source code of this file.

Functions

void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

usb standard request header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_sdr.h.


AT32F413 Firmwary Library: usbd_core.c File Reference

  • middlewares
  • usbd_drivers
  • src
Functions
usbd_core.c File Reference

usb driver More...

#include "usbd_core.h"
#include "usbd_sdr.h"

Go to the source code of this file.

Functions

void | usbd_core_in_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core in transfer complete handler More...
void | usbd_core_out_handler (usbd_core_type *udev, uint8_t ept_addr)
usb core out transfer complete handler More...
void | usbd_core_setup_handler (usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler More...
void | usbd_ctrl_send (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data More...
void | usbd_ctrl_recv (usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data More...
void | usbd_ctrl_send_status (usbd_core_type *udev)
usb control endpoint send in status More...
void | usbd_ctrl_recv_status (usbd_core_type *udev)
usb control endpoint send out status More...
void | usbd_clear_stall (usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall More...
void | usbd_set_stall (usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall. More...
void | usbd_ctrl_unsupport (usbd_core_type *udev)
un-support device request More...
void | usbd_ept_send (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint send data More...
void | usbd_ept_recv (usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint receive data More...
uint32_t | usbd_get_recv_len (usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length More...
void | usbd_ept_dbuffer_enable (usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer. More...
void | usbd_ept_buf_auto_define (usb_ept_info *ept_info)
usb auto define endpoint buffer More...
void | usbd_ept_buf_custom_define (usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer More...
void | usbd_ept_open (usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint More...
void | usbd_ept_close (usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint More...
void | usbd_connect (usbd_core_type *udev)
usb device connect to host More...
void | usbd_disconnect (usbd_core_type *udev)
usb device disconnect to host More...
void | usbd_set_device_addr (usbd_core_type *udev, uint8_t address)
usb device set device address. More...
usbd_conn_state | usbd_connect_state_get (usbd_core_type *udev)
get usb connect state More...
void | usbd_remote_wakeup (usbd_core_type *udev)
usb device remote wakeup More...
void | usbd_enter_suspend (usbd_core_type *udev)
usb device enter suspend mode More...
void | usbd_ept_defaut_init (usbd_core_type *udev)
usb endpoint structure initialization More...
void | usbd_core_init (usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *class_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core More...

Detailed Description

usb driver

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_core.c.


AT32F413 Firmwary Library: usbd_int.c File Reference

  • middlewares
  • usbd_drivers
  • src
Functions
usbd_int.c File Reference

usb interrupt request More...

#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usbd_irq_handler (usbd_core_type *udev)
usb device interrput request handler. More...
void | usbd_eptn_handler (usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler. More...
void | usbd_ept_loop_handler (usbd_core_type *udev)
usb device endpoint loop handler. More...
void | usbd_reset_handler (usbd_core_type *udev)
usb device reset interrupt request handler. More...
void | usbd_sof_handler (usbd_core_type *udev)
usb device sof interrupt request handler. More...
void | usbd_suspend_handler (usbd_core_type *udev)
usb device suspend interrupt request handler. More...
void | usbd_wakeup_handler (usbd_core_type *udev)
usb device wakup interrupt request handler. More...

Detailed Description

usb interrupt request

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_int.c.


AT32F413 Firmwary Library: usbd_sdr.c File Reference

  • middlewares
  • usbd_drivers
  • src
Functions
usbd_sdr.c File Reference

usb standard device request More...

#include "usbd_sdr.h"

Go to the source code of this file.

Functions

static usb_sts_type | usbd_get_descriptor (usbd_core_type *udev)
get usb standard device description request More...
static usb_sts_type | usbd_set_address (usbd_core_type *udev)
this request sets the device address More...
static usb_sts_type | usbd_get_status (usbd_core_type *udev)
get usb status request More...
static usb_sts_type | usbd_clear_feature (usbd_core_type *udev)
clear usb feature request More...
static usb_sts_type | usbd_set_feature (usbd_core_type *udev)
set usb feature request More...
static usb_sts_type | usbd_get_configuration (usbd_core_type *udev)
get usb configuration request More...
static usb_sts_type | usbd_set_configuration (usbd_core_type *udev)
sets the usb device configuration request More...
void | usbd_setup_request_parse (usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request More...
usb_sts_type | usbd_device_request (usbd_core_type *udev)
standard usb device requests More...
usb_sts_type | usbd_interface_request (usbd_core_type *udev)
standard usb interface requests More...
usb_sts_type | usbd_endpoint_request (usbd_core_type *udev)
standard usb endpoint requests More...

Detailed Description

usb standard device request

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file usbd_sdr.c.


AT32F413 Firmwary Library: at32f413_board.c File Reference

  • project
  • at32f413_board
Macros | Functions | Variables
at32f413_board.c File Reference

set of firmware functions to manage leds and push-button. initialize delay function. More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | STEP_DELAY_MS 50
#define | PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)

Functions

int | fputc (int ch, FILE *f)
retargets the c library printf function to the usart. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...
void | at32_board_init ()
board initialize interface init led and button More...
void | at32_button_init (void)
configure button gpio More...
uint8_t | at32_button_state (void)
returns the selected button state More...
button_type at32_button_press ()
returns which button have press down More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | delay_init ()
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...

Variables

gpio_type * | led_gpio_port [3] = {LED2_GPIO, LED3_GPIO, LED4_GPIO}
uint16_t | led_gpio_pin [3] = {LED2_PIN, LED3_PIN, LED4_PIN}
crm_periph_clock_type | led_gpio_crm_clk [3] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK}
static __IO uint32_t | fac_us
static __IO uint32_t | fac_ms

Detailed Description

set of firmware functions to manage leds and push-button. initialize delay function.

Version
v2.0.5
Date
2022-05-20
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_board.c.


AT32F413 Firmwary Library: at32f413_board.h File Reference

  • at32f413_board
Macros | Enumerations | Functions
at32f413_board.h File Reference

header file for at-start board. set of firmware functions to manage leds and push-button. initialize delay function. More...

#include "stdio.h"
#include "at32f413.h"

Go to the source code of this file.

Macros

#define | LED_NUM 3
#define | PRINT_UART USART1
#define | PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK
#define | PRINT_UART_TX_PIN GPIO_PINS_9
#define | PRINT_UART_TX_GPIO GPIOA
#define | PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | USER_BUTTON_PIN GPIO_PINS_0
#define | USER_BUTTON_PORT GPIOA
#define | USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK

Enumerations

enum | led_type { LED2 = 0 , LED3 = 1 , LED4 = 2 }
enum | button_type { USER_BUTTON = 0 , NO_BUTTON = 1 }

Functions

void | at32_board_init (void)
board initialize interface init led and button More...
void | at32_led_init (led_type led)
configure led gpio More...
void | at32_led_on (led_type led)
turns selected led on. More...
void | at32_led_off (led_type led)
turns selected led off. More...
void | at32_led_toggle (led_type led)
turns selected led toggle. More...
void | at32_button_init (void)
configure button gpio More...
button_type | at32_button_press (void)
returns which button have press down More...
uint8_t | at32_button_state (void)
returns the selected button state More...
void | delay_init (void)
initialize delay function More...
void | delay_us (uint32_t nus)
inserts a delay time. More...
void | delay_ms (uint16_t nms)
inserts a delay time. More...
void | delay_sec (uint16_t sec)
inserts a delay time. More...
void | uart_print_init (uint32_t baudrate)
initialize uart More...

Detailed Description

header file for at-start board. set of firmware functions to manage leds and push-button. initialize delay function.

Version
v2.0.5
Date
2022-05-20
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file at32f413_board.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • at_start_f413
  • examples
  • acc
  • calibration
  • inc
Functions
project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • combine_mode_ordinary_simult
  • inc
Functions
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • current_vref_value_check
  • inc
Functions
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • exint_trigger_partitioned
  • inc
Functions
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • internal_temperature_sensor
  • inc
Functions
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • software_trigger_repeat
  • inc
Functions
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • inc
Functions
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • adc
  • voltage_monitoring
  • inc
Functions
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • bpr
  • bpr_data
  • inc
Functions
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • bpr
  • tamper
  • inc
Functions
project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • can
  • communication_mode
  • inc
Functions
project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • can
  • filter
  • inc
Functions
project/at_start_f413/examples/can/filter/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • can
  • loopback_mode
  • inc
Functions
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • cortex_m4
  • bit_band
  • inc
Functions
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • cortex_m4
  • cmsis_dsp
  • inc
Functions
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • cortex_m4
  • fpu
  • inc
Functions
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • cortex_m4
  • systick_interrupt
  • inc
Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • crc
  • calculation
  • inc
Functions
project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • crm
  • clock_failure_detection
  • inc
Functions
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • crm
  • sysclk_switch
  • inc
Functions
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • debug
  • tmr1
  • inc
Functions
project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • dma
  • data_to_gpio_flexible
  • inc
Functions
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • dma
  • flash_to_sram
  • inc
Functions
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • exint
  • exint_config
  • inc
Functions
project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • exint
  • exint_software_trigger
  • inc
Functions
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • flash
  • operate_spim
  • inc
Functions
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • flash
  • run_in_spim
  • inc
Functions
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • gpio
  • led_toggle
  • inc
Functions
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • gpio
  • swjtag_remap
  • inc
Functions
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2c
  • communication_dma
  • inc
Functions
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2c
  • communication_int
  • inc
Functions
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2c
  • communication_poll
  • inc
Functions
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2c
  • eeprom
  • inc
Functions
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2s
  • halfduplex_dma
  • inc
Functions
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2s
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Functions
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • deepsleep_rtc
  • inc
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • power_voltage_monitor
  • inc
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • sleep_tmr2
  • inc
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • sleep_usart1
  • inc
Functions
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • standby_rtc
  • inc
Functions
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • pwc
  • standby_wakeup_pin
  • inc
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • rtc
  • calendar
  • inc
Functions
project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • rtc
  • lick_calibration
  • inc
Functions
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • sdio
  • sd_mmc_card
  • inc
Functions
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Functions
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • crc_transfer_polling
  • inc
Functions
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • fullduplex_polling
  • inc
Functions
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • halfduplex_transceiver_switch
  • inc
Functions
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • only_receive_mode_polling
  • inc
Functions
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Functions
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • spi
  • w25q_flash
  • inc
Functions
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • sram
  • extend_sram
  • inc
Functions
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • 6_steps
  • inc
Functions
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • 7_pwm_output
  • inc
Functions
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • cascade_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • complementary_signals
  • inc
Functions
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • dma
  • inc
Functions
project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • dma_burst
  • inc
Functions
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • encoder_tmr2
  • inc
Functions
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • external_clock
  • inc
Functions
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • hall_xor_tmr2
  • inc
Functions
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • hang_mode
  • inc
Functions
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • input_capture
  • inc
Functions
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • oc_high
  • inc
Functions
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • oc_low
  • inc
Functions
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • oc_toggle_tmr3
  • inc
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • oc_toggle_tmr9
  • inc
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • one_cycle
  • inc
Functions
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • parallel_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_input
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_input_dma
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_output_simulate
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_output_tmr10
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • pwm_output_tmr3
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • timer_base
  • inc
Functions
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • tmr1_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • tmr
  • tmr2_32bit
  • inc
Functions
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • half_duplex
  • inc
Functions
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • hw_flow_control
  • inc
Functions
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • idle_detection
  • inc
Functions
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • interrupt
  • inc
Functions
project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • irda
  • inc
Functions
project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • polling
  • inc
Functions
project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • printf
  • inc
Functions
project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • receiver_mute
  • inc
Functions
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • rs485
  • inc
Functions
project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • smartcard
  • inc
Functions
project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • synchronous
  • inc
Functions
project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • transfer_by_dma_interrupt
  • inc
Functions
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usart
  • transfer_by_dma_polling
  • inc
Functions
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • audio
  • inc
Functions
project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • custom_hid
  • inc
Functions
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • keyboard
  • inc
Functions
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • mouse
  • inc
Functions
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • msc
  • inc
Functions
project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • printer
  • inc
Functions
project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • vcp_loopback
  • inc
Functions
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • virtual_comport
  • inc
Functions
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • wdt
  • wdt_reset
  • inc
Functions
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • wdt
  • wdt_standby
  • inc
Functions
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • wwdt
  • wwdt_reset
  • inc
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • templates
  • inc
Functions
project/at_start_f413/templates/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_freertos_demo
  • inc
Functions
utilities/at32f413_freertos_demo/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
Functions
utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Functions
utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Functions
utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_clock.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h File Reference

header file of clock program More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • acc
  • calibration
  • inc
Macros
project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • combine_mode_ordinary_simult
  • inc
Macros
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • current_vref_value_check
  • inc
Macros
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • exint_trigger_partitioned
  • inc
Macros
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • internal_temperature_sensor
  • inc
Macros
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • software_trigger_repeat
  • inc
Macros
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • inc
Macros
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • adc
  • voltage_monitoring
  • inc
Macros
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • bpr
  • bpr_data
  • inc
Macros
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • bpr
  • tamper
  • inc
Macros
project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • can
  • communication_mode
  • inc
Macros
project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • can
  • filter
  • inc
Macros
project/at_start_f413/examples/can/filter/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/can/filter/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • can
  • loopback_mode
  • inc
Macros
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • cortex_m4
  • bit_band
  • inc
Macros
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • cortex_m4
  • cmsis_dsp
  • inc
Macros
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • cortex_m4
  • fpu
  • inc
Macros
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • cortex_m4
  • systick_interrupt
  • inc
Macros
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • crc
  • calculation
  • inc
Macros
project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • crm
  • clock_failure_detection
  • inc
Macros
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • crm
  • sysclk_switch
  • inc
Macros
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • debug
  • tmr1
  • inc
Macros
project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • dma
  • data_to_gpio_flexible
  • inc
Macros
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • dma
  • flash_to_sram
  • inc
Macros
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • exint
  • exint_config
  • inc
Macros
project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • exint
  • exint_software_trigger
  • inc
Macros
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • flash
  • flash_write_read
  • inc
Macros
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • flash
  • operate_spim
  • inc
Macros
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • flash
  • run_in_spim
  • inc
Macros
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • gpio
  • led_toggle
  • inc
Macros
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • gpio
  • swjtag_remap
  • inc
Macros
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2c
  • communication_dma
  • inc
Macros
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2c
  • communication_int
  • inc
Macros
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2c
  • communication_poll
  • inc
Macros
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2c
  • eeprom
  • inc
Macros
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2s
  • halfduplex_dma
  • inc
Macros
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2s
  • halfduplex_interrupt
  • inc
Macros
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Macros
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • deepsleep_rtc
  • inc
Macros
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • power_voltage_monitor
  • inc
Macros
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • sleep_tmr2
  • inc
Macros
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • sleep_usart1
  • inc
Macros
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • standby_rtc
  • inc
Macros
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • pwc
  • standby_wakeup_pin
  • inc
Macros
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • rtc
  • calendar
  • inc
Macros
project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • rtc
  • lick_calibration
  • inc
Macros
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • sdio
  • sd_mmc_card
  • inc
Macros
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Macros
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • crc_transfer_polling
  • inc
Macros
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • fullduplex_polling
  • inc
Macros
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • halfduplex_interrupt
  • inc
Macros
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • halfduplex_transceiver_switch
  • inc
Macros
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • only_receive_mode_polling
  • inc
Macros
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Macros
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • spi
  • w25q_flash
  • inc
Macros
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • sram
  • extend_sram
  • inc
Macros
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • 6_steps
  • inc
Macros
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • 7_pwm_output
  • inc
Macros
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • cascade_synchro
  • inc
Macros
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • complementary_signals
  • inc
Macros
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • dma
  • inc
Macros
project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • dma_burst
  • inc
Macros
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • encoder_tmr2
  • inc
Macros
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • external_clock
  • inc
Macros
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • hall_xor_tmr2
  • inc
Macros
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • hang_mode
  • inc
Macros
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • input_capture
  • inc
Macros
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • oc_high
  • inc
Macros
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • oc_low
  • inc
Macros
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • oc_toggle_tmr3
  • inc
Macros
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • oc_toggle_tmr9
  • inc
Macros
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • one_cycle
  • inc
Macros
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • parallel_synchro
  • inc
Macros
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_input
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_input_dma
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_output_simulate
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_output_tmr10
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • pwm_output_tmr3
  • inc
Macros
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • timer_base
  • inc
Macros
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • tmr1_synchro
  • inc
Macros
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • tmr
  • tmr2_32bit
  • inc
Macros
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • half_duplex
  • inc
Macros
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • hw_flow_control
  • inc
Macros
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • idle_detection
  • inc
Macros
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • interrupt
  • inc
Macros
project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • irda
  • inc
Macros
project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • polling
  • inc
Macros
project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • printf
  • inc
Macros
project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • receiver_mute
  • inc
Macros
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • rs485
  • inc
Macros
project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • smartcard
  • inc
Macros
project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • synchronous
  • inc
Macros
project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • transfer_by_dma_interrupt
  • inc
Macros
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usart
  • transfer_by_dma_polling
  • inc
Macros
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • audio
  • inc
Macros
project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Macros
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
Macros
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Macros
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • custom_hid
  • inc
Macros
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • keyboard
  • inc
Macros
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • mouse
  • inc
Macros
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • msc
  • inc
Macros
project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • printer
  • inc
Macros
project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • vcp_loopback
  • inc
Macros
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • virtual_comport
  • inc
Macros
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Macros
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • wdt
  • wdt_reset
  • inc
Macros
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • wdt
  • wdt_standby
  • inc
Macros
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • wwdt
  • wwdt_reset
  • inc
Macros
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • templates
  • inc
Macros
project/at_start_f413/templates/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_freertos_demo
  • inc
Macros
utilities/at32f413_freertos_demo/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_freertos_demo/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
Macros
utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Macros
utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Macros
utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Macros
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Macros
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h File Reference

at32f413 config header file More...

#include "at32f413_crm.h"
#include "at32f413_tmr.h"
#include "at32f413_rtc.h"
#include "at32f413_bpr.h"
#include "at32f413_gpio.h"
#include "at32f413_i2c.h"
#include "at32f413_usart.h"
#include "at32f413_pwc.h"
#include "at32f413_can.h"
#include "at32f413_adc.h"
#include "at32f413_spi.h"
#include "at32f413_dma.h"
#include "at32f413_debug.h"
#include "at32f413_flash.h"
#include "at32f413_crc.h"
#include "at32f413_wwdt.h"
#include "at32f413_wdt.h"
#include "at32f413_exint.h"
#include "at32f413_sdio.h"
#include "at32f413_acc.h"
#include "at32f413_misc.h"
#include "at32f413_usb.h"

Go to the source code of this file.

Macros

#define | HEXT_VALUE ((uint32_t)8000000)
in the following line adjust the value of high speed exernal crystal (hext) used in your application More...
#define | HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
in the following line adjust the high speed exernal crystal (hext) startup timeout value More...
#define | HICK_VALUE ((uint32_t)8000000)
#define | CRM_MODULE_ENABLED
#define | TMR_MODULE_ENABLED
#define | RTC_MODULE_ENABLED
#define | BPR_MODULE_ENABLED
#define | GPIO_MODULE_ENABLED
#define | I2C_MODULE_ENABLED
#define | USART_MODULE_ENABLED
#define | PWC_MODULE_ENABLED
#define | CAN_MODULE_ENABLED
#define | ADC_MODULE_ENABLED
#define | SPI_MODULE_ENABLED
#define | DMA_MODULE_ENABLED
#define | DEBUG_MODULE_ENABLED
#define | FLASH_MODULE_ENABLED
#define | CRC_MODULE_ENABLED
#define | WWDT_MODULE_ENABLED
#define | WDT_MODULE_ENABLED
#define | EXINT_MODULE_ENABLED
#define | SDIO_MODULE_ENABLED
#define | USB_MODULE_ENABLED
#define | ACC_MODULE_ENABLED
#define | MISC_MODULE_ENABLED

Detailed Description

at32f413 config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

Macro Definition Documentation

◆ ACC_MODULE_ENABLED

#define ACC_MODULE_ENABLED

Definition at line 75 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ ADC_MODULE_ENABLED

#define ADC_MODULE_ENABLED

Definition at line 64 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ BPR_MODULE_ENABLED

#define BPR_MODULE_ENABLED

Definition at line 58 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CAN_MODULE_ENABLED

#define CAN_MODULE_ENABLED

Definition at line 63 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CRC_MODULE_ENABLED

#define CRC_MODULE_ENABLED

Definition at line 69 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ CRM_MODULE_ENABLED

#define CRM_MODULE_ENABLED

Definition at line 55 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ DEBUG_MODULE_ENABLED

#define DEBUG_MODULE_ENABLED

Definition at line 67 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ DMA_MODULE_ENABLED

#define DMA_MODULE_ENABLED

Definition at line 66 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ EXINT_MODULE_ENABLED

#define EXINT_MODULE_ENABLED

Definition at line 72 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ FLASH_MODULE_ENABLED

#define FLASH_MODULE_ENABLED

Definition at line 68 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ GPIO_MODULE_ENABLED

#define GPIO_MODULE_ENABLED

Definition at line 59 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HEXT_STARTUP_TIMEOUT

#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)

in the following line adjust the high speed exernal crystal (hext) startup timeout value

time out for hext start up

Definition at line 51 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HEXT_VALUE

#define HEXT_VALUE ((uint32_t)8000000)

in the following line adjust the value of high speed exernal crystal (hext) used in your application

tip: to avoid modifying this file each time you need to use different hext, you can define the hext value in your toolchain compiler preprocessor. value of the high speed exernal crystal in hz

Definition at line 44 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ HICK_VALUE

#define HICK_VALUE ((uint32_t)8000000)

value of the high speed internal clock in hz

Definition at line 52 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ I2C_MODULE_ENABLED

#define I2C_MODULE_ENABLED

Definition at line 60 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ MISC_MODULE_ENABLED

#define MISC_MODULE_ENABLED

Definition at line 76 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ PWC_MODULE_ENABLED

#define PWC_MODULE_ENABLED

Definition at line 62 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ RTC_MODULE_ENABLED

#define RTC_MODULE_ENABLED

Definition at line 57 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ SDIO_MODULE_ENABLED

#define SDIO_MODULE_ENABLED

Definition at line 73 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ SPI_MODULE_ENABLED

#define SPI_MODULE_ENABLED

Definition at line 65 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ TMR_MODULE_ENABLED

#define TMR_MODULE_ENABLED

Definition at line 56 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ USART_MODULE_ENABLED

#define USART_MODULE_ENABLED

Definition at line 61 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ USB_MODULE_ENABLED

#define USB_MODULE_ENABLED

Definition at line 74 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ WDT_MODULE_ENABLED

#define WDT_MODULE_ENABLED

Definition at line 71 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.

◆ WWDT_MODULE_ENABLED

#define WWDT_MODULE_ENABLED

Definition at line 70 of file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • acc
  • calibration
  • inc
Functions
project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • combine_mode_ordinary_simult
  • inc
Functions
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • current_vref_value_check
  • inc
Functions
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • exint_trigger_partitioned
  • inc
Functions
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • internal_temperature_sensor
  • inc
Functions
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • software_trigger_repeat
  • inc
Functions
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • inc
Functions
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • adc
  • voltage_monitoring
  • inc
Functions
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • bpr
  • bpr_data
  • inc
Functions
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • bpr
  • tamper
  • inc
Functions
project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • can
  • communication_mode
  • inc
Functions
project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • can
  • filter
  • inc
Functions
project/at_start_f413/examples/can/filter/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • can
  • loopback_mode
  • inc
Functions
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • cortex_m4
  • bit_band
  • inc
Functions
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • cortex_m4
  • cmsis_dsp
  • inc
Functions
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • cortex_m4
  • fpu
  • inc
Functions
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • cortex_m4
  • systick_interrupt
  • inc
Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • crc
  • calculation
  • inc
Functions
project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • crm
  • clock_failure_detection
  • inc
Functions
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • crm
  • sysclk_switch
  • inc
Functions
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • debug
  • tmr1
  • inc
Functions
project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • dma
  • data_to_gpio_flexible
  • inc
Functions
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • dma
  • flash_to_sram
  • inc
Functions
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • exint
  • exint_config
  • inc
Functions
project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • exint
  • exint_software_trigger
  • inc
Functions
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • flash
  • operate_spim
  • inc
Functions
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • flash
  • run_in_spim
  • inc
Functions
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • gpio
  • led_toggle
  • inc
Functions
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • gpio
  • swjtag_remap
  • inc
Functions
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2c
  • communication_dma
  • inc
Functions
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2c
  • communication_int
  • inc
Functions
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2c
  • communication_poll
  • inc
Functions
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2c
  • eeprom
  • inc
Functions
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2s
  • halfduplex_dma
  • inc
Functions
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2s
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
Functions
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • deepsleep_rtc
  • inc
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • power_voltage_monitor
  • inc
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • sleep_tmr2
  • inc
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • sleep_usart1
  • inc
Functions
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • standby_rtc
  • inc
Functions
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • pwc
  • standby_wakeup_pin
  • inc
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • rtc
  • calendar
  • inc
Functions
project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • rtc
  • lick_calibration
  • inc
Functions
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • sdio
  • sd_mmc_card
  • inc
Functions
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Functions
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • crc_transfer_polling
  • inc
Functions
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • fullduplex_polling
  • inc
Functions
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • halfduplex_interrupt
  • inc
Functions
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • halfduplex_transceiver_switch
  • inc
Functions
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • only_receive_mode_polling
  • inc
Functions
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
Functions
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • spi
  • w25q_flash
  • inc
Functions
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • sram
  • extend_sram
  • inc
Functions
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • 6_steps
  • inc
Functions
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • 7_pwm_output
  • inc
Functions
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • cascade_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • complementary_signals
  • inc
Functions
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • dma
  • inc
Functions
project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • dma_burst
  • inc
Functions
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • encoder_tmr2
  • inc
Functions
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • external_clock
  • inc
Functions
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • hall_xor_tmr2
  • inc
Functions
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • hang_mode
  • inc
Functions
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • input_capture
  • inc
Functions
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • oc_high
  • inc
Functions
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • oc_low
  • inc
Functions
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • oc_toggle_tmr3
  • inc
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • oc_toggle_tmr9
  • inc
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • one_cycle
  • inc
Functions
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • parallel_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_input
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_input_dma
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_output_simulate
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_output_tmr10
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • pwm_output_tmr3
  • inc
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • timer_base
  • inc
Functions
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • tmr1_synchro
  • inc
Functions
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • tmr
  • tmr2_32bit
  • inc
Functions
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • half_duplex
  • inc
Functions
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • hw_flow_control
  • inc
Functions
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • idle_detection
  • inc
Functions
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • interrupt
  • inc
Functions
project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • irda
  • inc
Functions
project/at_start_f413/examples/usart/irda/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • polling
  • inc
Functions
project/at_start_f413/examples/usart/polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • printf
  • inc
Functions
project/at_start_f413/examples/usart/printf/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • receiver_mute
  • inc
Functions
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • rs485
  • inc
Functions
project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • smartcard
  • inc
Functions
project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • synchronous
  • inc
Functions
project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • transfer_by_dma_interrupt
  • inc
Functions
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usart
  • transfer_by_dma_polling
  • inc
Functions
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • audio
  • inc
Functions
project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • custom_hid
  • inc
Functions
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • keyboard
  • inc
Functions
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • mouse
  • inc
Functions
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • msc
  • inc
Functions
project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • printer
  • inc
Functions
project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • vcp_loopback
  • inc
Functions
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • virtual_comport
  • inc
Functions
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • wdt
  • wdt_reset
  • inc
Functions
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • wdt
  • wdt_standby
  • inc
Functions
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • wwdt
  • wwdt_reset
  • inc
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • templates
  • inc
Functions
project/at_start_f413/templates/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_freertos_demo
  • inc
Functions
utilities/at32f413_freertos_demo/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
Functions
utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Functions
utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Functions
utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h.


AT32F413 Firmwary Library: at32f413_int.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h File Reference

header file of main interrupt service routines. More...

#include "at32f413.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

header file of main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • acc
  • calibration
  • inc
Macros | Functions
project/at_start_f413/examples/acc/calibration/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | EPT0_TX_ADDR 0x40
usb endpoint max num define More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • audio
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_BUFFER_SIZE_EX
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_BUFFER_SIZE_EX
usb endpoint max num define More...
#define | USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • custom_hid
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • keyboard
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • mouse
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...
#define | USB_LOW_POWER_WAKUP
usb low power wakeup handler enable More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • msc
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • printer
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • vcp_loopback
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | EPT0_TX_ADDR 0x40
usb endpoint max num define More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • virtual_comport
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | USB_VIRTUAL_COMPORT
usb endpoint max num define More...
#define | EPT0_TX_ADDR 0x40
user custom endpoint buffer EPTn_TX_ADDR, EPTn_RX_ADDR must less than usb buffer size More...
#define | EPT0_RX_ADDR 0x80
#define | EPT1_TX_ADDR 0xC0
#define | EPT1_RX_ADDR 0x100
#define | EPT2_TX_ADDR 0x140
#define | EPT2_RX_ADDR 0x180
#define | EPT3_TX_ADDR 0x00
#define | EPT3_RX_ADDR 0x00
#define | EPT4_TX_ADDR 0x00
#define | EPT4_RX_ADDR 0x00
#define | EPT5_TX_ADDR 0x00
#define | EPT5_RX_ADDR 0x00
#define | EPT6_TX_ADDR 0x00
#define | EPT6_RX_ADDR 0x00
#define | EPT7_TX_ADDR 0x00
#define | EPT7_RX_ADDR 0x00

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Macros | Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h.


AT32F413 Firmwary Library: usb_conf.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Macros | Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h File Reference

usb config header file More...

#include "at32f413.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define USB_EPT_AUTO_MALLOC_BUFFER
usb endpoint max num define More...

Functions

void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • acc
  • calibration
  • src
Functions
project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • combine_mode_ordinary_simult
  • src
Functions
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • current_vref_value_check
  • src
Functions
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • exint_trigger_partitioned
  • src
Functions
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • internal_temperature_sensor
  • src
Functions
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • software_trigger_repeat
  • src
Functions
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • src
Functions
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • adc
  • voltage_monitoring
  • src
Functions
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • bpr
  • bpr_data
  • src
Functions
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • bpr
  • tamper
  • src
Functions
project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • can
  • communication_mode
  • src
Functions
project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • can
  • filter
  • src
Functions
project/at_start_f413/examples/can/filter/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/can/filter/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • can
  • loopback_mode
  • src
Functions
project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • cortex_m4
  • bit_band
  • src
Functions
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • cortex_m4
  • cmsis_dsp
  • src
Functions
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • cortex_m4
  • fpu
  • src
Functions
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • cortex_m4
  • systick_interrupt
  • src
Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • crc
  • calculation
  • src
Functions
project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • crm
  • clock_failure_detection
  • src
Functions
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • crm
  • sysclk_switch
  • src
Functions
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • debug
  • tmr1
  • src
Functions
project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • dma
  • data_to_gpio_flexible
  • src
Functions
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • dma
  • flash_to_sram
  • src
Functions
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • exint
  • exint_config
  • src
Functions
project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • exint
  • exint_software_trigger
  • src
Functions
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • flash
  • flash_write_read
  • src
Functions
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • flash
  • operate_spim
  • src
Functions
project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • flash
  • run_in_spim
  • src
Functions
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • gpio
  • led_toggle
  • src
Functions
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • gpio
  • swjtag_remap
  • src
Functions
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2c
  • communication_dma
  • src
Functions
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2c
  • communication_int
  • src
Functions
project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2c
  • communication_poll
  • src
Functions
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2c
  • eeprom
  • src
Functions
project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2s
  • halfduplex_dma
  • src
Functions
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2s
  • halfduplex_interrupt
  • src
Functions
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
Functions
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • deepsleep_rtc
  • src
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • power_voltage_monitor
  • src
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • sleep_tmr2
  • src
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • sleep_usart1
  • src
Functions
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • standby_rtc
  • src
Functions
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • pwc
  • standby_wakeup_pin
  • src
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • rtc
  • calendar
  • src
Functions
project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • rtc
  • lick_calibration
  • src
Functions
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • sdio
  • sd_mmc_card
  • src
Functions
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • sdio
  • sdio_fatfs
  • src
Functions
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • crc_transfer_polling
  • src
Functions
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • fullduplex_polling
  • src
Functions
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • halfduplex_interrupt
  • src
Functions
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • halfduplex_transceiver_switch
  • src
Functions
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • only_receive_mode_polling
  • src
Functions
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
Functions
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • spi
  • w25q_flash
  • src
Functions
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • sram
  • extend_sram
  • src
Functions
project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • 6_steps
  • src
Functions
project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • 7_pwm_output
  • src
Functions
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • cascade_synchro
  • src
Functions
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • complementary_signals
  • src
Functions
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • dma
  • src
Functions
project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • dma_burst
  • src
Functions
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • encoder_tmr2
  • src
Functions
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • external_clock
  • src
Functions
project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • hall_xor_tmr2
  • src
Functions
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • hang_mode
  • src
Functions
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • input_capture
  • src
Functions
project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • oc_high
  • src
Functions
project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • oc_low
  • src
Functions
project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • oc_toggle_tmr3
  • src
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • oc_toggle_tmr9
  • src
Functions
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • one_cycle
  • src
Functions
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • parallel_synchro
  • src
Functions
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_input
  • src
Functions
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_input_dma
  • src
Functions
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_output_simulate
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_output_tmr10
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • pwm_output_tmr3
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • timer_base
  • src
Functions
project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • tmr1_synchro
  • src
Functions
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • tmr
  • tmr2_32bit
  • src
Functions
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • half_duplex
  • src
Functions
project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • hw_flow_control
  • src
Functions
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • idle_detection
  • src
Functions
project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • interrupt
  • src
Functions
project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • irda
  • src
Functions
project/at_start_f413/examples/usart/irda/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/irda/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • polling
  • src
Functions
project/at_start_f413/examples/usart/polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • printf
  • src
Functions
project/at_start_f413/examples/usart/printf/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/printf/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • receiver_mute
  • src
Functions
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • rs485
  • src
Functions
project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • smartcard
  • src
Functions
project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • synchronous
  • src
Functions
project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • transfer_by_dma_interrupt
  • src
Functions
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usart
  • transfer_by_dma_polling
  • src
Functions
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • audio
  • src
Functions
project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • composite_audio_hid
  • src
Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • composite_vcp_keyboard
  • src
Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • composite_vcp_msc
  • src
Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • custom_hid
  • src
Functions
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • keyboard
  • src
Functions
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • mouse
  • src
Functions
project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • msc
  • src
Functions
project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • printer
  • src
Functions
project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • vcp_loopback
  • src
Functions
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • virtual_comport
  • src
Functions
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • wdt
  • wdt_reset
  • src
Functions
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • wdt
  • wdt_standby
  • src
Functions
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • wwdt
  • wwdt_reset
  • src
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c.

Function Documentation

◆ system_clock_config()

void system_clock_config ( void )

system clock config program

Note
the system clock is configured as follow:
  • system clock = hext / 2 * pll_mult
  • system clock source = pll (hext)
  • hext = 8000000
  • sclk = 192000000
  • ahbdiv = 1
  • ahbclk = 192000000
  • apb2div = 2
  • apb2clk = 96000000
  • apb1div = 2
  • apb1clk = 96000000
  • pll_mult = 48
  • pll_range = GT72MHZ (greater than 72 mhz)
Parameters
none
Return values
none

< phase locking loop stable flag

Definition at line 48 of file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • templates
  • src
Functions
project/at_start_f413/templates/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_freertos_demo
  • src
Functions
utilities/at32f413_freertos_demo/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
Functions
utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Functions
utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Functions
utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_clock.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c File Reference

system clock config program More...

#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void system_clock_config (void)
system clock config program More...

Detailed Description

system clock config program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • acc
  • calibration
  • src
Functions
project/at_start_f413/examples/acc/calibration/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • combine_mode_ordinary_simult
  • src
Functions | Variables
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...

Variables

__IO uint32_t | adc1_ordinary_valuetab [5][3]
__IO uint32_t | dma1_trans_complete_flag

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • current_vref_value_check
  • src
Functions
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • exint_trigger_partitioned
  • src
Functions | Variables
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...

Variables

__IO uint16_t | adc1_preempt_valuetab [3][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_trigger_count

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • internal_temperature_sensor
  • src
Functions
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • software_trigger_repeat
  • src
Functions | Variables
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...

Variables

__IO uint16_t dma_trans_complete_flag

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • src
Functions | Variables
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1_channel1 handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3]
__IO uint16_t | adc1_preempt_valuetab [5][3]
__IO uint16_t | dma_trans_complete_flag
__IO uint16_t | preempt_conversion_count

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • adc
  • voltage_monitoring
  • src
Functions | Variables
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | ADC1_2_IRQHandler (void)
this function handles adc1_2 handler. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3]
__IO uint16_t | vmor_flag_index

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • bpr
  • bpr_data
  • src
Functions
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • bpr
  • tamper
  • src
Functions
project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

uint32_t | bpr_reg_judge (void)
checks if the bpr dt registers are reset or not. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TAMPER_IRQHandler (void)
this function handles tamper interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • can
  • communication_mode
  • src
Functions
project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • can
  • filter
  • src
Functions
project/at_start_f413/examples/can/filter/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • can
  • loopback_mode
  • src
Functions
project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • cortex_m4
  • bit_band
  • src
Functions
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • cortex_m4
  • cmsis_dsp
  • src
Functions
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • cortex_m4
  • fpu
  • src
Functions
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • cortex_m4
  • systick_interrupt
  • src
Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | systick_handler (void)
systick interrupt handler. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • crc
  • calculation
  • src
Functions
project/at_start_f413/examples/crc/calculation/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • crm
  • clock_failure_detection
  • src
Functions
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | clock_failure_detection_handler (void)
clock failure detection handler. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • crm
  • sysclk_switch
  • src
Functions
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • debug
  • tmr1
  • src
Functions
project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • dma
  • data_to_gpio_flexible
  • src
Functions
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • dma
  • flash_to_sram
  • src
Functions
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • exint
  • exint_config
  • src
Functions
project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • exint
  • exint_software_trigger
  • src
Functions
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • flash
  • flash_write_read
  • src
Functions
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • flash
  • operate_spim
  • src
Functions
project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • flash
  • run_in_spim
  • src
Functions
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • gpio
  • led_toggle
  • src
Functions
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • gpio
  • swjtag_remap
  • src
Functions
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2c
  • communication_dma
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel6_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel7_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel7_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel6_IRQHandler (void)
this function handles dma interrupt request. More...

Variables

i2c_handle_type hi2cx

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

Macro Definition Documentation

◆ I2Cx_DMA_RX_IRQHandler

#define I2Cx_DMA_RX_IRQHandler DMA1_Channel7_IRQHandler

Definition at line 34 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ I2Cx_DMA_TX_IRQHandler

#define I2Cx_DMA_TX_IRQHandler DMA1_Channel6_IRQHandler

Definition at line 33 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ I2Cx_ERR_IRQHandler

#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Definition at line 36 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.

◆ I2Cx_EVT_IRQHandler

#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler

Definition at line 35 of file project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2c
  • communication_int
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | I2C1_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C1_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...

Variables

i2c_handle_type hi2cx

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

Macro Definition Documentation

◆ I2Cx_ERR_IRQHandler

#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler

Definition at line 34 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.

◆ I2Cx_EVT_IRQHandler

#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler

Definition at line 33 of file project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2c
  • communication_poll
  • src
Functions
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2c
  • eeprom
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2Cx_DMA_TX_IRQHandler DMA1_Channel4_IRQHandler
#define | I2Cx_DMA_RX_IRQHandler DMA1_Channel5_IRQHandler
#define | I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler
#define | I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel5_IRQHandler (void)
this function handles dma interrupt request. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma interrupt request. More...
void | I2C2_EVT_IRQHandler (void)
this function handles i2c event interrupt request. More...
void | I2C2_ERR_IRQHandler (void)
this function handles i2c error interrupt request. More...

Variables

i2c_handle_type hi2cx

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

Macro Definition Documentation

◆ I2Cx_DMA_RX_IRQHandler

#define I2Cx_DMA_RX_IRQHandler DMA1_Channel5_IRQHandler

Definition at line 34 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2Cx_DMA_TX_IRQHandler

#define I2Cx_DMA_TX_IRQHandler DMA1_Channel4_IRQHandler

Definition at line 33 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2Cx_ERR_IRQHandler

#define I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler

Definition at line 36 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.

◆ I2Cx_EVT_IRQHandler

#define I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler

Definition at line 35 of file project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2s
  • halfduplex_dma
  • src
Functions
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2s
  • halfduplex_interrupt
  • src
Functions | Variables
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...

Variables

uint16_t | i2s1_buffer_tx []
uint16_t | i2s2_buffer_rx []
__IO uint32_t | tx_index
__IO uint32_t | rx_index

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

Variable Documentation

◆ rx_index

__IO uint32_t rx_index

Definition at line 33 of file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c.

Referenced by SPI2_IRQHandler().


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
Functions
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • deepsleep_rtc
  • src
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTCAlarm_IRQHandler (void)
this function handles the rtc alarm through exint line interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • power_voltage_monitor
  • src
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | PVM_IRQHandler (void)
this function handles the power voltage monitoring output interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • sleep_tmr2
  • src
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles the timer interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • sleep_usart1
  • src
Functions | Variables
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART1_IRQHandler (void)
this function handles the usatt interrupt request. More...

Variables

uint16_t usart1_index = 0

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • standby_rtc
  • src
Functions
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • pwc
  • standby_wakeup_pin
  • src
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • rtc
  • calendar
  • src
Functions
project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTC_IRQHandler (void)
this function handles rtc handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • rtc
  • lick_calibration
  • src
Functions | Variables
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"
#include "stdio.h"

Go to the source code of this file.

Functions

uint32_t | incrementvar_operationcomplete (void)
increments operationcomplete variable and return its value before increment operation. More...
uint32_t | getvar_operationcomplete (void)
returns operationcomplete value. More...
void | setvar_periodvalue (uint32_t Value)
sets the periodvalue variable with input parameter. More...
void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | RTC_IRQHandler (void)
this function handles rtc global interrupt request. More...
void | TMR5_GLOBAL_IRQHandler (void)
this function handles tmr5 global interrupt request. More...

Variables

__IO uint32_t | periodvalue
__IO uint32_t | operationcomplete
uint16_t | tmpCC4 [2] = {0, 0}

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • sdio
  • sd_mmc_card
  • src
Functions
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • sdio
  • sdio_fatfs
  • src
Functions
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • crc_transfer_polling
  • src
Functions
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • fullduplex_polling
  • src
Functions
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • halfduplex_interrupt
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define BUFFERSIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...

Variables

uint8_t | spi1_tx_buffer []
uint8_t | spi2_rx_buffer []
uint32_t | tx_index
uint32_t | rx_index

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • halfduplex_transceiver_switch
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define BUFFERSIZE 32

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | SPI1_IRQHandler (void)
This function handles the spi1 interrupt request. More...
void | SPI2_IRQHandler (void)
This function handles the spi2 interrupt request. More...

Variables

uint8_t | spi1_tx_buffer []
uint8_t | spi2_tx_buffer []
uint8_t | spi1_rx_buffer []
uint8_t | spi2_rx_buffer []
uint32_t | tx_index
uint32_t | rx_index

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • only_receive_mode_polling
  • src
Functions
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
Functions
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • spi
  • w25q_flash
  • src
Functions
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • sram
  • extend_sram
  • src
Functions
project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • 6_steps
  • src
Functions
project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • 7_pwm_output
  • src
Functions
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • cascade_synchro
  • src
Functions
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • complementary_signals
  • src
Functions
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • dma
  • src
Functions
project/at_start_f413/examples/tmr/dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • dma_burst
  • src
Functions
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • encoder_tmr2
  • src
Functions
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • external_clock
  • src
Functions
project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • hall_xor_tmr2
  • src
Functions
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • hang_mode
  • src
Functions
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • input_capture
  • src
Functions
project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • oc_high
  • src
Functions
project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • oc_low
  • src
Functions
project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles tmr2 global interrupt request. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • oc_toggle_tmr3
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...

Variables

__IO uint16_t | ch1_val
__IO uint16_t | ch2_val
__IO uint16_t | ch3_val
__IO uint16_t | ch4_val
uint32_t | capture = 0

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • oc_toggle_tmr9
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR1_BRK_TMR9_IRQHandler (void)
this function handles TMR9 global interrupt request. More...

Variables

__IO uint16_t | ch1_val
__IO uint16_t | ch2_val
uint16_t | capture = 0

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • one_cycle
  • src
Functions
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • parallel_synchro
  • src
Functions
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_input
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 global interrupt request. More...

Variables

uint16_t | duty_cycle
uint32_t | frequency
__IO uint16_t | ic2value = 0

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_input_dma
  • src
Functions
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_output_simulate
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | TMR2_GLOBAL_IRQHandler (void)

Variables

__IO uint16_t | ch1_val
__IO uint16_t | ch2_val
__IO uint16_t | ch3_val
__IO uint16_t | ch4_val
uint16_t | capture = 0

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_output_tmr10
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • pwm_output_tmr3
  • src
Functions
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • timer_base
  • src
Functions
project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • tmr1_synchro
  • src
Functions
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • tmr
  • tmr2_32bit
  • src
Functions
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • half_duplex
  • src
Functions
project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • hw_flow_control
  • src
Functions
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • idle_detection
  • src
Functions
project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • interrupt
  • src
Functions | Variables
project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...

Variables

uint8_t | usart2_tx_buffer []
uint8_t | usart3_tx_buffer []
uint8_t | usart2_rx_buffer []
uint8_t | usart3_rx_buffer []
uint8_t | usart2_tx_counter
uint8_t | usart3_tx_counter
uint8_t | usart2_rx_counter
uint8_t | usart3_rx_counter
uint8_t | usart2_tx_buffer_size
uint8_t | usart3_tx_buffer_size

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • irda
  • src
Functions
project/at_start_f413/examples/usart/irda/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • polling
  • src
Functions
project/at_start_f413/examples/usart/polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • printf
  • src
Functions
project/at_start_f413/examples/usart/printf/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • receiver_mute
  • src
Functions | Variables
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | USART3_IRQHandler (void)
this function handles usart3 handler. More...

Variables

uint8_t | usart3_rx_buffer []
uint8_t | rx_counter

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • rs485
  • src
Functions
project/at_start_f413/examples/usart/rs485/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • smartcard
  • src
Functions | Variables
project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "smartcard_config.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | EXINT9_5_IRQHandler (void)
this function handles external lines 9 to 5 interrupt request. More...
void | SC_USART_IRQHandler (void)
this function handles sc_usart global interrupt request. More...

Variables

uint32_t card_inserted

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • synchronous
  • src
Functions
project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • transfer_by_dma_interrupt
  • src
Functions | Variables
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
void | DMA1_Channel2_IRQHandler (void)
this function handles dma1 channel2 handler. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 handler. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 handler. More...

Variables

uint8_t | usart2_tx_dma_status
uint8_t | usart2_rx_dma_status
uint8_t | usart3_tx_dma_status
uint8_t | usart3_rx_dma_status

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usart
  • transfer_by_dma_polling
  • src
Functions
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • audio
  • src
Functions
project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • composite_audio_hid
  • src
Functions
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • composite_vcp_keyboard
  • src
Functions
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • composite_vcp_msc
  • src
Functions
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • custom_hid
  • src
Functions
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • keyboard
  • src
Functions
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • mouse
  • src
Functions
project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • msc
  • src
Functions
project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • printer
  • src
Functions
project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • vcp_loopback
  • src
Functions
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • virtual_comport
  • src
Functions
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Functions
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • wdt
  • wdt_reset
  • src
Functions
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • wdt
  • wdt_standby
  • src
Functions
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • wwdt
  • wwdt_reset
  • src
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • templates
  • src
Functions
project/at_start_f413/templates/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_freertos_demo
  • src
Functions
utilities/at32f413_freertos_demo/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | DebugMon_Handler (void)
this function handles svcall exception. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
Functions
utilities/at32f413_gen_random_number_demo/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Functions
utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Functions
utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...
void | FLASH_IRQHandler (void)
flash handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c.


AT32F413 Firmwary Library: at32f413_int.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c File Reference

main interrupt service routines. More...

#include "at32f413_int.h"

Go to the source code of this file.

Functions

void | NMI_Handler (void)
this function handles nmi exception. More...
void | HardFault_Handler (void)
this function handles hard fault exception. More...
void | MemManage_Handler (void)
this function handles memory manage exception. More...
void | BusFault_Handler (void)
this function handles bus fault exception. More...
void | UsageFault_Handler (void)
this function handles usage fault exception. More...
void | SVC_Handler (void)
this function handles svcall exception. More...
void | DebugMon_Handler (void)
this function handles debug monitor exception. More...
void | PendSV_Handler (void)
this function handles pendsv_handler exception. More...
void | SysTick_Handler (void)
this function handles systick handler. More...

Detailed Description

main interrupt service routines.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c.


AT32F413 Firmwary Library: main.c File Reference

  • acc
  • calibration
  • src
Macros | Functions | Variables
project/at_start_f413/examples/acc/calibration/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_class.h"
#include "cdc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Macros

#define | SCLK_FROM_HICK
#define | ACC_TRIM

Functions

void | system_clock_config_for_acc (void)
system clock config for acc More...
void | clkout_config (void)
clkout configuration More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
usbfs_l_can1_rx0 interrupt handler More...
void | ACC_IRQHandler (void)
acc interrupt handler More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
uint32_t | acc_c2_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/acc/calibration/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • combine_mode_ordinary_simult
  • src
Functions | Variables
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | adc1_ordinary_valuetab [5][3]
__IO uint32_t | dma1_trans_complete_flag = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • current_vref_value_check
  • src
Functions | Variables
project/at_start_f413/examples/adc/current_vref_value_check/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t adc1_ordinary_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/current_vref_value_check/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • exint_trigger_partitioned
  • src
Functions | Variables
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | exint_config (void)
exint configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [3][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_trigger_count = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • internal_temperature_sensor
  • src
Macros | Functions | Variables
project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | ADC_VREF (3.3)
#define | ADC_TEMP_BASE (1.26)
#define | ADC_TEMP_SLOPE (-0.00423)

Functions

static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t adc1_ordinary_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • software_trigger_repeat
  • src
Functions | Variables
project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [10][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • tmr_trigger_automatic_preempted
  • src
Functions | Variables
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | tmr1_config (void)
tmr1 configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [5][3] = {0}
__IO uint16_t | adc1_preempt_valuetab [5][3] = {0}
__IO uint16_t | dma_trans_complete_flag = 0
__IO uint16_t | preempt_conversion_count = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • adc
  • voltage_monitoring
  • src
Functions | Variables
project/at_start_f413/examples/adc/voltage_monitoring/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | dma_config (void)
dma configuration. More...
static void | adc_config (void)
adc configuration. More...
int | main (void)
main function. More...

Variables

__IO uint16_t | adc1_ordinary_valuetab [3] = {0}
__IO uint16_t | vmor_flag_index = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/adc/voltage_monitoring/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • bpr
  • bpr_data
  • src
Macros | Functions | Variables
project/at_start_f413/examples/bpr/bpr_data/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BPR_DR_NUMBER 42

Functions

void | bpr_reg_write (void)
write data to bpr dt register. More...
uint8_t | bpr_reg_check (void)
checks if the bpr dt register values are correct or not. More...
void | uart_init (uint32_t baudrate)
init usart. More...
int | main (void)
main function. More...

Variables

bpr_data_type bpr_addr_tab [42]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/bpr_data/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • bpr
  • tamper
  • src
Macros | Functions | Variables
project/at_start_f413/examples/bpr/tamper/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BPR_DR_NUMBER 42

Functions

void | bpr_reg_write (void)
write data to bpr dt registers. More...
uint8_t | bpr_reg_check (void)
checks if the bpr dt registers values are correct or not. More...
uint32_t | bpr_reg_judge (void)
checks if the bpr dt registers are reset or not. More...
int | main (void)
main function. More...

Variables

bpr_data_type bpr_addr_tab [42]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/bpr/tamper/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • can
  • communication_mode
  • src
Functions
project/at_start_f413/examples/can/communication_mode/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/communication_mode/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • can
  • filter
  • src
Macros | Functions | Variables
project/at_start_f413/examples/can/filter/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
#define | FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
#define | FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
#define | FILTER_STD_ID1 ((uint16_t)0x04F6)
#define | FILTER_STD_ID2 ((uint16_t)0x04F7)
#define | FILTER_STD_ID3 ((uint16_t)0x04F8)

Functions

static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Variables

uint8_t test_result = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/filter/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • can
  • loopback_mode
  • src
Functions
project/at_start_f413/examples/can/loopback_mode/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | can_gpio_config (void)
can gpio config More...
static void | can_configuration (void)
can configiguration. More...
static void | can_transmit_data (void)
can transmit data More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
can1 interrupt function rx0 More...
void | CAN1_SE_IRQHandler (void)
can1 interrupt function se More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/can/loopback_mode/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • cortex_m4
  • bit_band
  • src
Macros | Functions | Variables
project/at_start_f413/examples/cortex_m4/bit_band/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | RAM_BASE 0x20000000
#define | RAM_BITBAND_BASE 0x22000000
#define | VARIABLES_RESET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | VARIABLES_SET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
#define | VARIABLES_GET_BIT(variables_addr, bit_number) (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
#define | PERIPHERAL_BASE 0x40000000
#define | PERIPHERAL_BITBAND_BASE 0x42000000
#define | PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
#define | PERIPHERAL_SET_BIT(peripheral_addr, bit_number) (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)

Functions

void | result_error (void)
led4 flick for error. More...
int | main (void)
main function. More...

Variables

__IO uint32_t | variables
__IO uint32_t | variables_addr = 0
__IO uint32_t | variables_bit_val = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/bit_band/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • cortex_m4
  • cmsis_dsp
  • src
Macros | Functions | Variables
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "arm_math.h"

Go to the source code of this file.

Macros

#define | USE_STATIC_INIT
#define | TEST_LENGTH_SAMPLES (20*4)
#define | NUMSTUDENTS 20
#define | NUMSUBJECTS 4

Functions

int32_t main ()
main function. More...

Variables

const float32_t | testMarks_f32 [(20 *4)]
const float32_t | testUnity_f32 [4]
static float32_t | testOutput [(20 *4)]
uint32_t | numStudents = 20
uint32_t | numSubjects = 4
float32_t | max_marks
float32_t | min_marks
float32_t | mean
float32_t | std
float32_t | var
uint32_t | student_num

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • cortex_m4
  • fpu
  • src
Macros | Functions | Variables
project/at_start_f413/examples/cortex_m4/fpu/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "julia_fpu.h"

Go to the source code of this file.

Macros

#define | SCREEN_X_SIZE ((uint16_t)160)
#define | SCREEN_Y_SIZE ((uint16_t)120)
#define | ZOOM ((uint16_t)100)

Functions

int main (void)
main function. More...

Variables

uint8_t buffer [((uint16_t) 160) *((uint16_t) 120)]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/fpu/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • cortex_m4
  • systick_interrupt
  • src
Macros | Functions
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | MS_TICK (system_core_clock / 1000U)
#define | DELAY 200 /* 200 ms ticks */

Functions

void | systick_handler (void)
systick interrupt handler. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • crc
  • calculation
  • src
Macros | Functions | Variables
project/at_start_f413/examples/crc/calculation/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 120

Functions

int main (void)
main function. More...

Variables

static const uint32_t | data_buffer [120]
__IO uint32_t | crc_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crc/calculation/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • crm
  • clock_failure_detection
  • src
Functions
project/at_start_f413/examples/crm/clock_failure_detection/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | clkout_config (void)
clkout configuration. More...
static void | sclk_192m_hick_config (void)
config sclk 192 mhz with hick clock source. More...
void | clock_failure_detection_handler (void)
clock failure detection handler. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/clock_failure_detection/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • crm
  • sysclk_switch
  • src
Functions
project/at_start_f413/examples/crm/sysclk_switch/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

static void | clkout_config (void)
clkout configuration. More...
static void | sclk_64m_hick_config (void)
config sclk 64 mhz with hick clock source. More...
static void | sclk_96m_hext_config (void)
config sclk 96 mhz with hext clock source. More...
static void | switch_system_clock (void)
sclk switch function. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/crm/sysclk_switch/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • debug
  • tmr1
  • src
Functions | Variables
project/at_start_f413/examples/debug/tmr1/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles tmr1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | counter = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/debug/tmr1/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • dma
  • data_to_gpio_flexible
  • src
Macros | Functions | Variables
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

void | DMA2_Channel1_IRQHandler (void)
this function handles DMA2 channel1 handler. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
dma_init_type | dma_init_struct = {0}
uint16_t | src_buffer [16]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • dma
  • flash_to_sram
  • src
Macros | Functions | Variables
project/at_start_f413/examples/dma/flash_to_sram/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

error_status | buffer_compare (const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers. More...
void | DMA1_Channel1_IRQHandler (void)
this function handles dma1 channel1 handler. More...
int | main (void)
main function. More...

Variables

const uint32_t | src_const_buffer [32]
uint32_t | dst_buffer [32]
gpio_init_type | gpio_init_struct = {0}
dma_init_type | dma_init_struct = {0}
__IO uint32_t | data_counter_end = 0x01
error_status transfer_status = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/dma/flash_to_sram/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • exint
  • exint_config
  • src
Functions
project/at_start_f413/examples/exint/exint_config/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | exint_line0_config (void)
exint line0 config. configure pa0 in interrupt mode More...
int | main (void)
main function. More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_config/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • exint
  • exint_software_trigger
  • src
Functions
project/at_start_f413/examples/exint/exint_software_trigger/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | exint_line4_config (void)
exint line4 config. configure pa0 in interrupt mode More...
static void | tmr1_config (void)
tmr1 configuration. More...
void | TMR1_OVF_TMR10_IRQHandler (void)
tmr1 interrupt handler More...
void | EXINT4_IRQHandler (void)
exint4 interrupt handler More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/exint/exint_software_trigger/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • flash
  • flash_write_read
  • src
Macros | Functions | Variables
project/at_start_f413/examples/flash/flash_write_read/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "flash.h"

Go to the source code of this file.

Macros

#define | TEST_BUFEER_SIZE 3000
#define | TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 16)

Functions

error_status | buffer_compare (uint16_t *p_buffer1, uint16_t *p_buffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint16_t | buffer_write [3000]
uint16_t | buffer_read [3000]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • flash
  • operate_spim
  • src
Functions
project/at_start_f413/examples/flash/operate_spim/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "operate_spim.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/operate_spim/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • flash
  • run_in_spim
  • src
Functions
project/at_start_f413/examples/flash/run_in_spim/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "run_in_spim.h"

Go to the source code of this file.

Functions

void | spim_init (void)
init the spim flash More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/run_in_spim/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • gpio
  • led_toggle
  • src
Functions
project/at_start_f413/examples/gpio/led_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/led_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • gpio
  • swjtag_remap
  • src
Functions
project/at_start_f413/examples/gpio/swjtag_remap/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | swj_dp_config (void)
configure the gpio of swj-dp. More...
void | gpio_pins_toggle (gpio_type *gpio_x, uint16_t gpio_pin)
toggles the specified gpio pin More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/gpio/swjtag_remap/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2c
  • communication_dma
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL6
#define | I2Cx_DMA_TX_IRQn DMA1_Channel6_IRQn
#define | I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL7
#define | I2Cx_DMA_RX_IRQn DMA1_Channel7_IRQn
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | error_handler (uint32_t error_code)
error handler program More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2c
  • communication_int
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_int/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_EVT_IRQn I2C1_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C1_ERR_IRQn
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | error_handler (uint32_t error_code)
error handler program More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_int/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2c
  • communication_poll
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/communication_poll/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_6
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_7
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | BUF_SIZE 8
#define | MASTER_BOARD

Functions

void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | rx_buf [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/communication_poll/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2c
  • eeprom
  • src
Macros | Functions | Variables
project/at_start_f413/examples/i2c/eeprom/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "i2c_application.h"

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0xA0
#define | I2Cx_PORT I2C2
#define | I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_10
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_11
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
#define | I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL4
#define | I2Cx_DMA_TX_IRQn DMA1_Channel4_IRQn
#define | I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL5
#define | I2Cx_DMA_RX_IRQn DMA1_Channel5_IRQn
#define | I2Cx_EVT_IRQn I2C2_EVT_IRQn
#define | I2Cx_ERR_IRQn I2C2_ERR_IRQn
#define | BUF_SIZE 8

Functions

void | error_handler (uint32_t error_code)
error handler program More...
uint32_t | buffer_compare (uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal. More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buf1 [8] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08}
uint8_t | tx_buf2 [8] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80}
uint8_t | tx_buf3 [8] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88}
uint8_t | rx_buf1 [8] = {0}
uint8_t | rx_buf2 [8] = {0}
uint8_t | rx_buf3 [8] = {0}
i2c_handle_type hi2cx

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2c/eeprom/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2s
  • halfduplex_dma
  • src
Functions | Variables
project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (void)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
volatile error_status | transfer_status = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2s
  • halfduplex_interrupt
  • src
Functions | Variables
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | i2s_config (i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
error_status | buffer_compare_24bits (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare_24bits function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
Functions | Variables
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
static void | i2s_config (i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode)
i2s configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | i2s1_buffer_tx [32]
uint16_t | spi1_buffer_tx [32]
uint16_t | i2s2_buffer_rx [32]
uint16_t | spi2_buffer_rx [32]
__IO uint32_t | tx_index = 0
__IO uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • deepsleep_rtc
  • src
Functions
project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

void | rtc_config (void)
rtc configuration. More...
void | system_clock_recover (void)
systemclock recover. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • power_voltage_monitor
  • src
Functions
project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | pvm_exint_config (void)
power voltage monitor exint configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • sleep_tmr2
  • src
Functions
project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | tmr2_config (void)
tmr2 configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • sleep_usart1
  • src
Functions
project/at_start_f413/examples/pwc/sleep_usart1/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | usart1_config (uint32_t baudrate)
usart1 configuration. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/sleep_usart1/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • standby_rtc
  • src
Functions
project/at_start_f413/examples/pwc/standby_rtc/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

void | rtc_config (void)
rtc configuration. More...
void | rtc_alarm_config (uint8_t alarm_time)
rtc alarm set. More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_rtc/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • pwc
  • standby_wakeup_pin
  • src
Functions
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • rtc
  • calendar
  • src
Functions | Variables
project/at_start_f413/examples/rtc/calendar/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "rtc.h"

Go to the source code of this file.

Functions

void | alarm_init (void)
init alarm. More...
int | main (void)
main function. More...

Variables

char const weekday_table [7][10] = { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"}

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/calendar/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • rtc
  • lick_calibration
  • src
Functions | Variables
project/at_start_f413/examples/rtc/lick_calibration/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
void | rtc_configuration (void)
configures the rtc. More...
uint32_t | incrementvar_operationcomplete (void)
increments operationcomplete variable and return its value before increment operation. More...
uint32_t | getvar_operationcomplete (void)
returns operationcomplete value. More...
void | setvar_periodvalue (uint32_t value)
sets the periodvalue variable with input parameter. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type crm_clocks
__IO uint32_t | periodvalue = 0
__IO uint32_t | lickfreq = 0
__IO uint32_t | operationcomplete = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/rtc/lick_calibration/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • sdio
  • sd_mmc_card
  • src
Macros | Functions | Variables
project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c File Reference

main program More...

#include <stdbool.h>
#include <string.h>
#include "at32_sdio.h"
#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | BLOCK_SIZE (512)
#define | BLOCKS_NUMBER (8)
#define | MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
#define | STREAM_BUFFER_SIZE (1024)

Functions

static error_status | sd_single_block_test (void)
sd card single block read/write test. More...
static error_status | sd_multiple_blocks_test (void)
sd card multiple blocks read/write test. More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
static void | sd_test_error (void)
LED2 on off every 300ms for sd test failed. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static error_status | mmc_stream_test (void)
mmc card data stream read/write test. More...
void | show_card_info (void)
show sd/mmc card info. More...
int | main (void)
main function. More...

Variables

static uint8_t | sblock_tbuffer [(512)]
static uint8_t | sblock_rbuffer [(512)]
static uint8_t | mblock_tbuffer [((512) *(8))]
static uint8_t | mblock_rbuffer [((512) *(8))]
static uint8_t | stream_tbuffer [(1024)]
static uint8_t | stream_rbuffer [(1024)]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • sdio
  • sdio_fatfs
  • src
Functions | Variables
project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c File Reference

main program More...

#include <stdbool.h>
#include <string.h>
#include "at32_sdio.h"
#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "ff.h"

Go to the source code of this file.

Functions

uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
static void | sd_test_error (void)
led2 on off every 300ms for sd test failed. More...
static void | nvic_configuration (void)
configures sdio1 irq channel. More...
static error_status | fatfs_test (void)
fatfs file read/write test. More...
int | main (void)
main function. More...

Variables

FATFS | fs
FIL | file
BYTE | work [FF_MAX_SS]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • crc_transfer_polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint16_t | spi1_tx_buffer [32]
uint16_t | spi2_tx_buffer [32]
uint16_t | spi1_rx_buffer [32]
uint16_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
__IO uint16_t | crc1_value = 0
__IO uint16_t | crc2_value = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • fullduplex_polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/fullduplex_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (uint16_t spi1_mode, uint16_t spi2_mode)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_tx_buffer [32]
uint8_t | spi1_rx_buffer [32]
uint8_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR
volatile error_status | transfer_status3 = ERROR
volatile error_status | transfer_status4 = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/fullduplex_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • halfduplex_interrupt
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • halfduplex_transceiver_switch
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_tx_buffer [32]
uint8_t | spi1_rx_buffer [32]
uint8_t | spi2_rx_buffer [32]
volatile uint32_t | tx_index = 0
volatile uint32_t | rx_index = 0
volatile error_status | transfer_status1 = ERROR
volatile error_status | transfer_status2 = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • only_receive_mode_polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

spi_init_type spi_init_struct
uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
uint32_t | tx_index = 0
uint32_t | rx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 32

Functions

static void | gpio_config (void)
gpio configuration. More...
static void | spi_config (void)
spi configuration. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint8_t | spi1_tx_buffer [32]
uint8_t | spi2_rx_buffer [32]
__IO uint8_t | tx_index = 0
volatile error_status | transfer_status = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • spi
  • w25q_flash
  • src
Macros | Functions | Variables
project/at_start_f413/examples/spi/w25q_flash/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "spi_flash.h"

Go to the source code of this file.

Macros

#define | FLASH_TEST_ADDR 0x1000
#define | BUF_SIZE 0x256

Functions

void | tx_data_fill (void)
transfer data fill. More...
error_status | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function. More...
int | main (void)
main function. More...

Variables

uint8_t | tx_buffer [0x256]
uint8_t | rx_buffer [0x256]
volatile error_status | transfer_status = ERROR

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/spi/w25q_flash/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • sram
  • extend_sram
  • src
Functions
project/at_start_f413/examples/sram/extend_sram/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | extend_sram (void)
to extend sram size More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/sram/extend_sram/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • 6_steps
  • src
Functions | Variables
project/at_start_f413/examples/tmr/6_steps/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | systick_configuration (void)
configures the systick. More...
int | main (void)
main function. More...
void | TMR1_TRG_HALL_TMR11_IRQHandler (void)
this function handles tmr1 trigger and hall interrupts requests. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
__IO uint32_t | step = 1

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/6_steps/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • 7_pwm_output
  • src
Functions | Variables
project/at_start_f413/examples/tmr/7_pwm_output/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | channel1_pulse = 0
uint16_t | channel2_pulse = 0
uint16_t | channel3_pulse = 0
uint16_t | channel4_pulse = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/7_pwm_output/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • cascade_synchro
  • src
Functions | Variables
project/at_start_f413/examples/tmr/cascade_synchro/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/cascade_synchro/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • complementary_signals
  • src
Functions | Variables
project/at_start_f413/examples/tmr/complementary_signals/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_brkdt_config_type | tmr_brkdt_config_struct = {0}
uint16_t | timer_period = 0
uint16_t | channel1_pulse = 0
uint16_t | channel2_pulse = 0
uint16_t | channel3_pulse = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/complementary_signals/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • dma
  • src
Functions | Variables
project/at_start_f413/examples/tmr/dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type | dma_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | src_buffer [3] = {0, 0, 0}

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • dma_burst
  • src
Functions | Variables
project/at_start_f413/examples/tmr/dma_burst/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
tmr_output_config_type tmr_output_struct
dma_init_type | dma_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | timer_period = 0
uint16_t | src_buffer [3] = {0x0FFF, 0x0000, 0x0555}

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/dma_burst/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • encoder_tmr2
  • src
Functions | Variables
project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | delay (uint32_t time)
delay function More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint32_t | counter

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • external_clock
  • src
Functions | Variables
project/at_start_f413/examples/tmr/external_clock/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/external_clock/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • hall_xor_tmr2
  • src
Functions | Variables
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int | main (void)
main function. More...
void | TMR2_GLOBAL_IRQHandler (void)
this function handles TMR2 trigger exception. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • hang_mode
  • src
Functions | Variables
project/at_start_f413/examples/tmr/hang_mode/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_output_config_type tmr_output_struct
tmr_input_config_type tmr_input_config_struct

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/hang_mode/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • input_capture
  • src
Functions | Variables
project/at_start_f413/examples/tmr/input_capture/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | TMR3_GLOBAL_IRQHandler (void)
this function handles tmr3 trigger exception. More...
int | main (void)
main function. More...

Variables

gpio_init_type | gpio_init_struct = {0}
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
tmr_input_config_type tmr_input_config_struct
__IO uint32_t | tmr3freq = 0
__IO uint32_t | sys_counter = 0
__IO uint16_t | capturenumber = 0
__IO uint16_t | ch3readvalue1 = 0
__IO uint16_t | ch3readvalue2 = 0
__IO uint32_t | capture = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/input_capture/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • oc_high
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_high/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
crm_clocks_freq_type | crm_clocks_freq_struct = {0}
uint16_t | ch1_val = 1000
uint16_t | ch2_val = 500
uint16_t | ch3_val = 250
uint16_t | ch4_val = 125
uint16_t | div_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_high/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • oc_low
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_low/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | gpio_configuration (void)
configure the gpioc pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 1000
uint16_t | ch2_val = 500
uint16_t | ch3_val = 250
uint16_t | ch4_val = 125
uint16_t | div_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_low/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • oc_toggle_tmr3
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
__IO uint16_t | ch1_val = 32768
__IO uint16_t | ch2_val = 16384
__IO uint16_t | ch3_val = 8192
__IO uint16_t | ch4_val = 4096
uint16_t | div_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • oc_toggle_tmr9
  • src
Functions | Variables
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr9 pins. More...
void | nvic_configuration (void)
configures the nested vectored interrupt controller. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
__IO uint16_t | ch1_val = 32768
__IO uint16_t | ch2_val = 16384
uint16_t | div_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • one_cycle
  • src
Functions | Variables
project/at_start_f413/examples/tmr/one_cycle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
tmr_input_config_type tmr_ic_init_structure
uint16_t div_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/one_cycle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • parallel_synchro
  • src
Functions | Variables
project/at_start_f413/examples/tmr/parallel_synchro/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/parallel_synchro/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_input
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_input/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_input_config_type tmr_ic_init_structure
__IO uint16_t | duty_cycle = 0
__IO uint32_t | frequency = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_input_dma
  • src
Macros | Functions | Variables
project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "stdio.h"

Go to the source code of this file.

Macros

#define | TMR1_C1DT_ADDRESS 0x40012C34
#define | TMR1_C2DT_ADDRESS 0x40012C38
#define | SAMPLING_NUM 1000

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
void | DMA1_Channel2_IRQHandler (void)
int | main (void)
main function. More...

Variables

tmr_input_config_type tmr_ic_init_structure
dma_init_type dma_init_structure
__IO uint16_t | buffer_ch1 [1000]
__IO uint16_t | buffer_ch2 [1000]
__IO uint32_t | frequency = 0
__IO float | duty_cycle = 0
uint32_t | freq_result
float | duty_result

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_output_simulate
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 40961
uint16_t | ch2_val = 27309
uint16_t | ch3_val = 13654
uint16_t | ch4_val = 6826
uint16_t | div_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_output_tmr10
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 250
uint16_t | div_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • pwm_output_tmr3
  • src
Functions | Variables
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr3 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint16_t | ch1_val = 333
uint16_t | ch2_val = 249
uint16_t | ch3_val = 166
uint16_t | ch4_val = 83
uint16_t | div_value = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • timer_base
  • src
Functions | Variables
project/at_start_f413/examples/tmr/timer_base/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | clkout_config (void)
void | TMR1_OVF_TMR10_IRQHandler (void)
this function handles timer1 overflow handler. More...
int | main (void)
main function. More...

Variables

crm_clocks_freq_type crm_clocks_freq_struct = {0}

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/timer_base/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • tmr1_synchro
  • src
Functions | Variables
project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • tmr
  • tmr2_32bit
  • src
Functions | Variables
project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | crm_configuration (void)
configures the different peripheral clocks. More...
void | gpio_configuration (void)
configure the tmr1 pins. More...
int | main (void)
main function. More...

Variables

tmr_output_config_type tmr_oc_init_structure
uint32_t | ch1_val = 0x7FFFF
uint32_t | ch2_val = 0x3FFFF
uint32_t | ch3_val = 0x1FFFF
uint32_t | ch4_val = 0xFFFF

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • half_duplex
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/half_duplex/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart half-duplex transfer: usart2 -> usart3"
uint8_t | usart3_tx_buffer [] = "usart half-duplex transfer: usart3 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | data_count

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/half_duplex/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • hw_flow_control
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/hw_flow_control/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define BUFFER_SIZE 16

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | rx_buffer [16]
uint8_t | data_count

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/hw_flow_control/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • idle_detection
  • src
Functions
project/at_start_f413/examples/usart/idle_detection/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/idle_detection/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • interrupt
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_counter = 0x00
volatile uint8_t | usart3_tx_counter = 0x00
volatile uint8_t | usart2_rx_counter = 0x00
volatile uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • irda
  • src
Functions
project/at_start_f413/examples/usart/irda/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/irda/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by interrupt: usart2 -> usart3 using interrupt"
uint8_t | usart3_tx_buffer [] = "usart transfer by interrupt: usart3 -> usart2 using interrupt"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | usart3_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | usart3_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | usart3_tx_buffer_size = ((sizeof( usart3_tx_buffer ) / sizeof(*( usart3_tx_buffer ))) - 1)

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • printf
  • src
Functions | Variables
project/at_start_f413/examples/usart/printf/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Variables

__IO uint32_t time_cnt = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/printf/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • receiver_mute
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/receiver_mute/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | BUFFER_SIZE 7
#define | MATCH_ID_VAL 0x81
#define | ERROR_ID_VAL 0x82
#define | DATA1_VAL 0x7F
#define | DATA2_VAL 0x7A
#define | DATA3_VAL 0x7B
#define | DATA4_VAL 0x7C

Functions

void | usart_configuration (void)
config usart More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [7] = { 0x7F , 0x81 , 0x7A , 0x82 , 0x7B , 0x81 , 0x7C }
uint8_t | usart3_rx_buffer [7]
uint8_t | tx_counter = 0
uint8_t | rx_counter = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/receiver_mute/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • rs485
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/rs485/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | RS485_BAUDRATE 9600
#define | RS485_BUFFER_SIZE 128

Functions

static void | rs485_config (void)
rs485 configiguration. More...
static void | rs485_send_data (u8 *buf, u8 cnt)
rs485 send data More...
int | main (void)
main function. More...
void | USART2_IRQHandler (void)
usart2 interrupt handler More...

Variables

uint8_t | rs485_buffer_rx [128]
uint8_t | rs485_buffer_rx_cnt = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/rs485/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • smartcard
  • src
Data Structures | Macros | Functions | Variables
project/at_start_f413/examples/usart/smartcard/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "smartcard_config.h"

Go to the source code of this file.

Data Structures

struct sc_atr_type

Macros

#define | T0_PROTOCOL 0x00 /* t0 protocol */
#define | SETUP_LENGTH 20
#define | HIST_LENGTH 20
#define | SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
#define | SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
#define | SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */

Functions

void | usart_configuration (void)
config usart More...
uint8_t | sc_response_decode (__IO uint8_t *card)
decode the card atr response. More...
int | main (void)
main function. More...

Variables

sc_atr_type sc_a2r_struct
uint32_t | sc_baud_rate = 0
uint32_t | sc_clock_freq = 0
uint32_t | counter = 0
error_status atr_decode_status = ERROR
uint32_t | card_inserted = 0
uint32_t | card_protocol = 1
uint8_t | dst_buffer [50]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/smartcard/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • synchronous
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/synchronous/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | SPI2_TX_BUFFER_SIZE (COUNTOF(spi2_tx_buffer) - 1)
#define | DYMMY_BYTE 0x00

Functions

void | usart_spi_configuration (void)
config usart and spi More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart synchronous example: usart2 -> spi2"
uint8_t | spi2_tx_buffer [] = "usart synchronous example: spi2 -> usart2"
uint8_t | usart2_rx_buffer [((sizeof(spi2_tx_buffer)/sizeof(*(spi2_tx_buffer))) - 1)]
uint8_t | spi2_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
uint8_t | usart2_tx_counter = 0x00
uint8_t | spi2_tx_counter = 0x00
uint8_t | usart2_rx_counter = 0x00
uint8_t | spi2_rx_counter = 0x00
uint8_t | usart2_tx_buffer_size = ((sizeof( usart2_tx_buffer ) / sizeof(*( usart2_tx_buffer ))) - 1)
uint8_t | spi2_tx_buffer_size = ((sizeof( spi2_tx_buffer ) / sizeof(*( spi2_tx_buffer ))) - 1)

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/synchronous/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • transfer_by_dma_interrupt
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
volatile uint8_t | usart2_tx_dma_status = 0
volatile uint8_t | usart2_rx_dma_status = 0
volatile uint8_t | usart3_tx_dma_status = 0
volatile uint8_t | usart3_rx_dma_status = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usart
  • transfer_by_dma_polling
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | COUNTOF(a) (sizeof(a) / sizeof(*(a)))
#define | USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
#define | USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)

Functions

void | usart_configuration (void)
config usart More...
void | dma_configuration (void)
config dma for usart2 and usart3 More...
uint8_t | buffer_compare (uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers. More...
int | main (void)
main function. More...

Variables

uint8_t | usart2_tx_buffer [] = "usart transfer by dma interrupt: usart2 -> usart3 using dma"
uint8_t | usart3_tx_buffer [] = "usart transfer by dma interrupt: usart3 -> usart2 using dma"
uint8_t | usart2_rx_buffer [((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
uint8_t | usart3_rx_buffer [((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • audio
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/audio/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "audio_class.h"
#include "audio_desc.h"
#include "usbd_int.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/audio/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • composite_audio_hid
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "usbd_int.h"
#include "audio_hid_class.h"
#include "audio_hid_desc.h"
#include "audio_codec.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t report_buf [USBD_AUHID_IN_MAXPACKET_SIZE]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • composite_vcp_keyboard
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_keyboard_class.h"
#include "cdc_keyboard_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | keyboard_send_string (void *udev, uint8_t *string, uint8_t len)
keyboard send string More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • composite_vcp_msc
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_msc_class.h"
#include "cdc_msc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • custom_hid
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/custom_hid/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "custom_hid_class.h"
#include "custom_hid_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t report_buf [USBD_CUSTOM_IN_MAXPACKET_SIZE]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/custom_hid/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • keyboard
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/keyboard/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "keyboard_class.h"
#include "keyboard_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | keyboard_send_string (void *udev, uint8_t *string, uint8_t len)
keyboard send string More...
void | system_clock_recover (void)
systemclock recover. More...
void | button_exint_init (void)
configure button exint More...
void | usb_low_power_wakeup_config (void)
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
__IO uint8_t hid_suspend_flag

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/keyboard/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • mouse
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/mouse/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "mouse_class.h"
#include "mouse_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | system_clock_recover (void)
systemclock recover. More...
void | button_exint_init (void)
configure button exint More...
void | usb_low_power_wakeup_config (void)
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
__IO uint8_t | press_mouse = 0
__IO uint8_t | hid_suspend_flag
uint8_t | report_buf [USBD_MOUSE_IN_MAXPACKET_SIZE]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/mouse/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • msc
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/msc/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "msc_class.h"
#include "msc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/msc/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • printer
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/printer/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "printer_class.h"
#include "printer_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/printer/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • vcp_loopback
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_class.h"
#include "cdc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t usb_buffer [256]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • virtual_comport
  • src
Macros | Functions | Variables
project/at_start_f413/examples/usb_device/virtual_comport/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "cdc_class.h"
#include "cdc_desc.h"
#include "usbd_int.h"

Go to the source code of this file.

Macros

#define usart_buffer_size 2048

Functions

void | usb_usart_config (linecoding_type linecoding)
this function handles usart2 and linecoding config. More...
void | usart_gpio_config (void)
this function handles usart2 gpio config. More...
void | usart_send_data (uint8_t *send_data, uint16_t len)
this function handles usart2 send data. More...
uint16_t | usart_receive_data (void)
this function handles usart2 receive data. More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | USART2_IRQHandler (void)
this function handles usart2 handler. More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
uint8_t | usb_buffer [256]
linecoding_type linecoding
uint8_t | usart_rx_buffer [2048]
uint16_t | hw_usart_rx_index = 0
uint16_t | hw_usart_read_index = 0
uint16_t | usart_rx_data_len = 0
uint16_t | ov_cnt = 0

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_comport/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Functions | Variables
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "msc_class.h"
#include "msc_desc.h"
#include "usbd_int.h"
#include "flash_fat16.h"

Go to the source code of this file.

Functions

void | jump_to_app (uint32_t address)
jump to app More...
void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
int | main (void)
main function. More...
void | usb_reset ()
usb re-connect More...
void | flash_fat16_loop_status (void)
loop status More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...

Variables

usbd_core_type usb_core_dev
void(* pftarget )(void)

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • wdt
  • wdt_reset
  • src
Functions
project/at_start_f413/examples/wdt/wdt_reset/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_reset/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • wdt
  • wdt_standby
  • src
Functions
project/at_start_f413/examples/wdt/wdt_standby/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wdt/wdt_standby/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • wwdt
  • wwdt_reset
  • src
Functions
project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • templates
  • src
Macros | Functions | Variables
project/at_start_f413/templates/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"

Go to the source code of this file.

Macros

#define | DELAY 100
#define | FAST 1
#define | SLOW 4

Functions

void | button_exint_init (void)
configure button exint More...
void | button_isr (void)
button handler function More...
void | EXINT0_IRQHandler (void)
exint0 interrupt handler More...
int | main (void)
main function. More...

Variables

uint8_t g_speed = 1

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/templates/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_freertos_demo
  • src
Functions | Variables
utilities/at32f413_freertos_demo/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "FreeRTOS.h"
#include "task.h"

Go to the source code of this file.

Functions

void | led2_task_function (void *pvParameters)
void | led3_task_function (void *pvParameters)
int | main (void)
main function. More...

Variables

TaskHandle_t | led2_handler
TaskHandle_t | led3_handler

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_freertos_demo/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
Functions
utilities/at32f413_gen_random_number_demo/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "stdio.h"
#include "random.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_gen_random_number_demo/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Macros | Functions | Variables
utilities/at32f413_slib_demo/project_l0/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>
#include "math_helper.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define | USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */
#define | FLASH_START_ADDR 0x08000000
#define | TEST_SLIB_PSW 0x55665566
#define | SLIB_START_ADDR 0x08001000
#define | SLIB_DATA_ADDR 0x08002000
#define | SLIB_END_ADDR 0x08002800
#define | FLASH_SECTOR_SIZE 0x800
#define | SECTOR_NUM(dwAddr) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)
#define | SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */
#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

flash_status_type | slib_enable (void)
config slib enable and program slib area. More...
void | config_flash_interrupt (void)
config flash error interrupt. More...
int | main (void)
main function. More...

Variables

float32_t | testInput_f32_1kHz_15kHz []
float32_t | refOutput []
uint32_t | dw_start_sector
uint32_t | dw_data_start_sector
uint32_t | dw_end_sector
uint32_t | temp_buf [512]
static float32_t | testOutput [320]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l0/src/main.c.

Variable Documentation

◆ refOutput

float32_t refOutput[]
extern

Definition at line 96 of file project_l0/src/arm_fir_data.c.

Referenced by main().

◆ testInput_f32_1kHz_15kHz

float32_t testInput_f32_1kHz_15kHz[]
extern

Definition at line 48 of file project_l0/src/arm_fir_data.c.

Referenced by main().


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Macros | Functions | Variables
utilities/at32f413_slib_demo/project_l1/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include <stdio.h>
#include "math_helper.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define | SNR_THRESHOLD_F32 140.0f
#define | TEST_LENGTH_SAMPLES 320

Functions

void | config_flash_interrupt (void)
config flash error interrupt. More...
int | main (void)
main function. More...

Variables

float32_t | testInput_f32_1kHz_15kHz []
float32_t | refOutput []
static float32_t | testOutput [320]

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_slib_demo/project_l1/src/main.c.

Variable Documentation

◆ refOutput

float32_t refOutput[]
extern

Definition at line 96 of file project_l0/src/arm_fir_data.c.

Referenced by main().

◆ testInput_f32_1kHz_15kHz

float32_t testInput_f32_1kHz_15kHz[]
extern

Definition at line 48 of file project_l0/src/arm_fir_data.c.

Referenced by main().


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "tmr.h"
#include "usart.h"
#include "iap.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "tmr.h"
#include "usart.h"
#include "iap.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "tmr.h"
#include "usart.h"
#include "flash.h"
#include "iap.h"

Go to the source code of this file.

Functions

int main (void)
main function. More...

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions | Variables
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "hid_iap_class.h"
#include "hid_iap_desc.h"
#include "hid_iap_user.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions | Variables
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "hid_iap_class.h"
#include "hid_iap_desc.h"
#include "hid_iap_user.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c.


AT32F413 Firmwary Library: main.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c File Reference

main program More...

#include "at32f413_board.h"
#include "at32f413_clock.h"
#include "usbd_core.h"
#include "hid_iap_class.h"
#include "hid_iap_desc.h"
#include "hid_iap_user.h"
#include "usbd_int.h"

Go to the source code of this file.

Functions

void | usb_clock48m_select (usb_clk48_s clk_s)
usb 48M clock select More...
void | USBFS_L_CAN1_RX0_IRQHandler (void)
this function handles usb interrupt. More...
void | usb_delay_ms (uint32_t ms)
usb delay millisecond function. More...
void | usb_delay_us (uint32_t us)
usb delay microsecond function. More...
int | main (void)
main function. More...

Variables

usbd_core_type usb_core_dev

Detailed Description

main program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c.


AT32F413 Firmwary Library: julia_fpu.h File Reference

  • cortex_m4
  • fpu
  • inc
Macros | Functions
julia_fpu.h File Reference

julia_fpu header file More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define | ITERATION 200
#define | REAL_CONSTANT (0.285f)
#define | IMG_CONSTANT (0.01f)

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

julia_fpu header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file julia_fpu.h.


AT32F413 Firmwary Library: julia_fpu.c File Reference

  • cortex_m4
  • fpu
  • src
Functions
julia_fpu.c File Reference

julia_fpu source file More...

#include "julia_fpu.h"

Go to the source code of this file.

Functions

void generate_julia_fpu (uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable More...

Detailed Description

julia_fpu source file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file julia_fpu.c.


AT32F413 Firmwary Library: flash.h File Reference

  • flash
  • flash_write_read
  • inc
Functions
project/at_start_f413/examples/flash/flash_write_read/inc/flash.h File Reference

flash header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Functions

void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
void | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
void | flash_write (uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking More...

Detailed Description

flash header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/inc/flash.h.


AT32F413 Firmwary Library: flash.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Macros | Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h File Reference

flash header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */
#define | SRAM_SIZE 224 /* sram size, unit:kbyte */

Functions

void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...

Detailed Description

flash header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h.


AT32F413 Firmwary Library: flash.c File Reference

  • flash
  • flash_write_read
  • src
Macros | Functions | Variables
project/at_start_f413/examples/flash/flash_write_read/src/flash.c File Reference

flash program More...

#include "at32f413_board.h"
#include "flash.h"

Go to the source code of this file.

Macros

#define SECTOR_SIZE 2048 /* this parameter depends on the specific model of the chip */

Functions

void | flash_read (uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode More...
void | flash_write_nocheck (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking More...
void | flash_write (uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode with checking More...

Variables

uint16_t flash_buf [2048/2]

Detailed Description

flash program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file project/at_start_f413/examples/flash/flash_write_read/src/flash.c.


AT32F413 Firmwary Library: flash.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c File Reference

flash program More...

#include "flash.h"
#include "usart.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | flash_2kb_write (uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation. More...
flag_status | flash_upgrade_flag_read (void)
check flash upgrade flag. More...

Detailed Description

flash program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c.


AT32F413 Firmwary Library: operate_spim.h File Reference

  • flash
  • operate_spim
  • inc
Macros | Functions
operate_spim.h File Reference

operate_spim header file More...

Go to the source code of this file.

Macros

#define | SPIM_SECTOR_SIZE 4096
#define | SPIM_TEST_ADDR 0x08400000

Functions

void spim_operate (void)
operate spim flash More...

Detailed Description

operate_spim header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file operate_spim.h.


AT32F413 Firmwary Library: operate_spim.c File Reference

  • flash
  • operate_spim
  • src
Functions | Variables
operate_spim.c File Reference

operate spim program More...

#include "at32f413_board.h"
#include "operate_spim.h"
#include <string.h>

Go to the source code of this file.

Functions

void | spim_init (void)
init the spim flash More...
void | sector_read (uint32_t address, uint32_t sector_size, uint8_t *buf)
read one sector from a specified address in spim flash More...
void | spim_operate (void)
operate spim flash More...

Variables

uint8_t | write_buffer [4096]
uint8_t | read_buffer [4096]

Detailed Description

operate spim program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file operate_spim.c.


AT32F413 Firmwary Library: run_in_spim.h File Reference

  • flash
  • run_in_spim
  • inc
Functions
run_in_spim.h File Reference

run_in_spim header file More...

Go to the source code of this file.

Functions

void spim_run (void)
check the led toggle in spim More...

Detailed Description

run_in_spim header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file run_in_spim.h.


AT32F413 Firmwary Library: run_in_spim.c File Reference

  • flash
  • run_in_spim
  • src
Functions
run_in_spim.c File Reference

run in spim program More...

#include "at32f413_board.h"
#include "run_in_spim.h"

Go to the source code of this file.

Functions

void spim_run (void)
check the led toggle in spim More...

Detailed Description

run in spim program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file run_in_spim.c.


AT32F413 Firmwary Library: rtc.h File Reference

  • rtc
  • calendar
  • inc
Data Structures | Functions | Variables
rtc.h File Reference

this file provides template for calendar api. More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct calendar_type

Functions

uint8_t | rtc_init (calendar_type *calendar)
rtc peripheral initialization. More...
uint8_t | rtc_time_set (calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_alarm_clock_set (calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
void | rtc_time_get (void)
get current time. More...

Variables

calendar_type calendar

Detailed Description

this file provides template for calendar api.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file rtc.h.


AT32F413 Firmwary Library: rtc.c File Reference

  • rtc
  • calendar
  • src
Functions | Variables
rtc.c File Reference

this file provides template for calendar api. More...

#include "rtc.h"

Go to the source code of this file.

Functions

uint8_t | rtc_init (calendar_type *calendar)
rtc peripheral initialization. More...
uint8_t | is_leap_year (uint16_t year)
judeg the leap year or common year. More...
uint8_t | rtc_time_set (calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_alarm_clock_set (calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099 More...
uint8_t | rtc_week_get (uint16_t year, uint8_t month, uint8_t day)
get current week by input leap year\mouth\day. More...
void | rtc_time_get (void)
get current time. More...

Variables

calendar_type calendar
const uint8_t | table_week [12] = {0, 3, 3, 6, 1, 4, 6, 2, 5, 0, 3, 5}
const uint8_t | mon_table [12] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}

Detailed Description

this file provides template for calendar api.

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file rtc.c.


AT32F413 Firmwary Library: at32_sdio.h File Reference

  • sdio
  • sd_mmc_card
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
sd_mmc_card/inc/at32_sdio.h File Reference

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library. More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Macros

#define | SDIOx SDIO1
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Enumerations

enum sd_data_transfer_mode_type { SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 }
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sd_card_info_struct_type sd_card_info

Detailed Description

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.

Version
v2.0.5
Date
2022-05-20
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file sd_mmc_card/inc/at32_sdio.h.


AT32F413 Firmwary Library: at32_sdio.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
sdio_fatfs/inc/at32_sdio.h File Reference

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library. More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct | sd_csd_struct_type
struct | sd_cid_struct_type
struct | sd_scr_struct_type
struct | sd_card_info_struct_type

Macros

#define | SDIOx SDIO1
#define | SD_CMD_GO_IDLE_STATE ((uint8_t)0)
#define | SD_CMD_SEND_OP_COND ((uint8_t)1)
#define | SD_CMD_ALL_SEND_CID ((uint8_t)2)
#define | SD_CMD_SET_REL_ADDR ((uint8_t)3)
#define | SD_CMD_SET_DSR ((uint8_t)4)
#define | SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
#define | SD_CMD_HS_SWITCH ((uint8_t)6)
#define | SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
#define | SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
#define | SD_CMD_SEND_CSD ((uint8_t)9)
#define | SD_CMD_SEND_CID ((uint8_t)10)
#define | SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
#define | SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
#define | SD_CMD_SEND_STATUS ((uint8_t)13)
#define | SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
#define | SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
#define | SD_CMD_SET_BLOCKLEN ((uint8_t)16)
#define | SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
#define | SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
#define | SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
#define | SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
#define | SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
#define | SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
#define | SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
#define | SD_CMD_PROG_CID ((uint8_t)26)
#define | SD_CMD_PROG_CSD ((uint8_t)27)
#define | SD_CMD_SET_WRITE_PROT ((uint8_t)28)
#define | SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
#define | SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
#define | SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
#define | SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
#define | SD_CMD_ERASE_GRP_START ((uint8_t)35)
#define | SD_CMD_ERASE_GRP_END ((uint8_t)36)
#define | SD_CMD_ERASE ((uint8_t)38)
#define | SD_CMD_FAST_IO ((uint8_t)39)
#define | SD_CMD_GO_IRQ_STATE ((uint8_t)40)
#define | SD_CMD_LOCK_UNLOCK ((uint8_t)42)
#define | SD_CMD_APP_CMD ((uint8_t)55)
#define | SD_CMD_GEN_CMD ((uint8_t)56)
#define | SD_CMD_NO_CMD ((uint8_t)64)
#define | SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
#define | SD_CMD_SD_APP_STAUS ((uint8_t)13)
#define | SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
#define | SD_CMD_SD_APP_OP_COND ((uint8_t)41)
#define | SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
#define | SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
#define | SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
#define | SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
#define | SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
#define | SD_CMD_SD_APP_GET_MID ((uint8_t)44)
#define | SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
#define | SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
#define | SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
#define | SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
#define | SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
#define | SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
#define | SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
#define | SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
#define | SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
#define | NULL 0
#define | SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
#define | SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
#define | SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SDIO_FIFO_Address ((uint32_t)0x40018080)
#define | SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
#define | SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
#define | SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
#define | SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
#define | SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
#define | SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
#define | SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
#define | SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
#define | SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
#define | SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
#define | SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
#define | SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
#define | SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
#define | SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
#define | SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
#define | SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
#define | SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
#define | SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
#define | MMC_SWITCH_ERROR ((uint32_t)0x00000080)
#define | SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
#define | SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
#define | SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
#define | SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
#define | SD_R5_ERROR ((uint32_t)0x00000800)
#define | SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
#define | SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
#define | SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
#define | SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
#define | SD_HIGH_CAPACITY ((uint32_t)0x40000000)
#define | SD_STD_CAPACITY ((uint32_t)0x00000000)
#define | SD_CHECK_PATTERN ((uint32_t)0x000001AA)
#define | SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
#define | SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
#define | SD_ALLZERO ((uint32_t)0x00000000)
#define | SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
#define | SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
#define | SD_CARD_LOCKED ((uint32_t)0x02000000)
#define | SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
#define | SD_CARD_RECEIVING ((uint32_t)0x00000006)
#define | SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
#define | SD_0TO7BITS ((uint32_t)0x000000FF)
#define | SD_8TO15BITS ((uint32_t)0x0000FF00)
#define | SD_16TO23BITS ((uint32_t)0x00FF0000)
#define | SD_24TO31BITS ((uint32_t)0xFF000000)
#define | SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
#define | SD_HALFFIFO ((uint32_t)0x00000008)
#define | SD_HALFFIFOBYTES ((uint32_t)0x00000020)
#define | SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
#define | SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
#define | SD_CCCC_ERASE ((uint32_t)0x00000020)
#define | SDIO_SEND_IF_COND ((uint32_t)0x00000008)
#define | EXT_CSD_Command_set 0x0
#define | EXT_CSD_Set_bit 0x1
#define | EXT_CSD_Clear_byte 0x2
#define | EXT_CSD_Write_byte 0x3
#define | EXT_CSD_CMD_SET_NORMAL (1<<0)
#define | EXT_CSD_CMD_SET_SECURE (1<<1)
#define | EXT_CSD_CMD_SET_CPSECURE (1<<2)
#define | EXT_CSD_BUS_WIDTH 183
#define | EXT_CSD_HS_TIMING 185
#define | SDIO_INTR_STS_WRITE_MASK
#define | SDIO_INTR_STS_READ_MASK

Enumerations

enum sd_data_transfer_mode_type { SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 , SD_TRANSFER_POLLING_MODE = 0 , SD_TRANSFER_DMA_MODE = 1 }
enum sd_error_status_type {
SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 , SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 ,
SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 , SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 ,
SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 , SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 ,
SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 , SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 ,
SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 , SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 ,
SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 , SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 ,
SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 , SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 ,
SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 , SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 ,
SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR , SD_NOT_CONFIGURED , SD_REQ_PENDING ,
SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER , SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW ,
SD_ERROR , SD_OK = 0 , SD_CMD_FAIL = 1 , SD_DATA_FAIL = 2 ,
SD_CMD_RSP_TIMEOUT = 3 , SD_DATA_TIMEOUT = 4 , SD_TX_UNDERRUN = 5 , SD_RX_OVERRUN = 6 ,
SD_START_BIT_ERR = 7 , SD_CMD_OUT_OF_RANGE = 8 , SD_ADDR_MISALIGNED = 9 , SD_BLK_LEN_ERR = 10 ,
SD_ERASE_SEQ_ERR = 11 , SD_INVALID_ERASE_PARAM = 12 , SD_WR_PROTECT_VIOLATION = 13 , SD_LOCK_UNLOCK_ERROR = 14 ,
SD_CMD_CRC_ERROR = 15 , SD_ILLEGAL_CMD = 16 , SD_CARD_ECC_ERROR = 17 , SD_CARD_CONTROLLER_ERR = 18 ,
SD_GENERAL_UNKNOWN_ERROR = 19 , SD_STREAM_RD_UNDERRUN = 20 , SD_STREAM_WR_OVERRUN = 21 , SD_CID_CSD_OVERWRITE = 22 ,
SD_WP_ERASE_SKIP = 23 , SD_CARD_ECC_DISABLED = 24 , SD_ERASE_RESET = 25 , SD_AKE_SEQ_ERROR = 26 ,
SD_INVALID_VOLTRANGE = 27 , SD_ADDR_OUT_OF_RANGE = 28 , SD_SWITCH_ERROR = 29 , SD_SDIO_DISABLED = 30 ,
SD_SDIO_FUNC_BUSY = 31 , SD_SDIO_FUNC_ERROR = 32 , SD_SDIO_UNKNOWN_FUNC = 33 , SD_INTERNAL_ERROR ,
SD_NOT_CONFIGURED , SD_REQ_PENDING , SD_REQ_NOT_APPLICABLE , SD_INVALID_PARAMETER ,
SD_UNSUPPORTED_FEATURE , SD_UNSUPPORTED_HW , SD_ERROR , SD_OK = 0
}
enum sd_card_state_type {
SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) , SD_CARD_TRANSFER = ((uint32_t)0x00000004) ,
SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) , SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) ,
SD_CARD_ERROR = ((uint32_t)0x000000FF) , SD_CARD_READY = ((uint32_t)0x00000001) , SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002) , SD_CARD_STANDBY = ((uint32_t)0x00000003) ,
SD_CARD_TRANSFER = ((uint32_t)0x00000004) , SD_CARD_SENDING = ((uint32_t)0x00000005) , SD_CARD_RECEIVING = ((uint32_t)0x00000006) , SD_CARD_PROGRAMMING = ((uint32_t)0x00000007) ,
SD_CARD_DISCONNECTED = ((uint32_t)0x00000008) , SD_CARD_ERROR = ((uint32_t)0x000000FF)
}
enum sd_memory_card_type {
SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 , SDIO_MULTIMEDIA_CARD = 3 ,
SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 , SDIO_HIGH_CAPACITY_MMC_CARD = 7 ,
SDIO_SDIO_CARD = 8 , SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0 , SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1 , SDIO_HIGH_CAPACITY_SD_CARD = 2 ,
SDIO_MULTIMEDIA_CARD = 3 , SDIO_SECURE_DIGITAL_IO_CARD = 4 , SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5 , SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6 ,
SDIO_HIGH_CAPACITY_MMC_CARD = 7 , SDIO_SDIO_CARD = 8
}

Functions

sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clkdiv)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sd_card_info_struct_type sd_card_info

Detailed Description

this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.

Version
v2.0.5
Date
2022-05-20
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file sdio_fatfs/inc/at32_sdio.h.


AT32F413 Firmwary Library: ffconf.h File Reference

  • sdio
  • sdio_fatfs
  • inc
Macros
ffconf.h File Reference

Go to the source code of this file.

Macros

#define | FFCONF_DEF 86631 /* Revision ID */
#define | FF_FS_READONLY 0
#define | FF_FS_MINIMIZE 0
#define | FF_USE_FIND 0
#define | FF_USE_MKFS 1
#define | FF_USE_FASTSEEK 1
#define | FF_USE_EXPAND 0
#define | FF_USE_CHMOD 0
#define | FF_USE_LABEL 0
#define | FF_USE_FORWARD 0
#define | FF_USE_STRFUNC 0
#define | FF_PRINT_LLI 0
#define | FF_PRINT_FLOAT 0
#define | FF_STRF_ENCODE 0
#define | FF_CODE_PAGE 932
#define | FF_USE_LFN 0
#define | FF_MAX_LFN 255
#define | FF_LFN_UNICODE 0
#define | FF_LFN_BUF 255
#define | FF_SFN_BUF 12
#define | FF_FS_RPATH 0
#define | FF_VOLUMES 3
#define | FF_STR_VOLUME_ID 0
#define | FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
#define | FF_MULTI_PARTITION 0
#define | FF_MIN_SS 512
#define | FF_MAX_SS 512
#define | FF_LBA64 0
#define | FF_MIN_GPT 0x10000000
#define | FF_USE_TRIM 0
#define | FF_FS_TINY 0
#define | FF_FS_EXFAT 0
#define | FF_FS_NORTC 1
#define | FF_NORTC_MON 1
#define | FF_NORTC_MDAY 1
#define | FF_NORTC_YEAR 2020
#define | FF_FS_NOFSINFO 0
#define | FF_FS_LOCK 0
#define | FF_FS_REENTRANT 0
#define | FF_FS_TIMEOUT 1000
#define | FF_SYNC_t HANDLE

Macro Definition Documentation

◆ FF_CODE_PAGE

#define FF_CODE_PAGE 932

Definition at line 87 of file ffconf.h.

◆ FF_FS_EXFAT

#define FF_FS_EXFAT 0

Definition at line 234 of file ffconf.h.

◆ FF_FS_LOCK

#define FF_FS_LOCK 0

Definition at line 266 of file ffconf.h.

◆ FF_FS_MINIMIZE

#define FF_FS_MINIMIZE 0

Definition at line 18 of file ffconf.h.

◆ FF_FS_NOFSINFO

#define FF_FS_NOFSINFO 0

Definition at line 254 of file ffconf.h.

◆ FF_FS_NORTC

#define FF_FS_NORTC 1

Definition at line 240 of file ffconf.h.

◆ FF_FS_READONLY

#define FF_FS_READONLY 0

Definition at line 11 of file ffconf.h.

◆ FF_FS_REENTRANT

#define FF_FS_REENTRANT 0

Definition at line 279 of file ffconf.h.

◆ FF_FS_RPATH

#define FF_FS_RPATH 0

Definition at line 156 of file ffconf.h.

◆ FF_FS_TIMEOUT

#define FF_FS_TIMEOUT 1000

Definition at line 280 of file ffconf.h.

◆ FF_FS_TINY

#define FF_FS_TINY 0

Definition at line 227 of file ffconf.h.

◆ FF_LBA64

#define FF_LBA64 0

Definition at line 206 of file ffconf.h.

◆ FF_LFN_BUF

#define FF_LFN_BUF 255

Definition at line 148 of file ffconf.h.

◆ FF_LFN_UNICODE

#define FF_LFN_UNICODE 0

Definition at line 136 of file ffconf.h.

◆ FF_MAX_LFN

#define FF_MAX_LFN 255

Definition at line 117 of file ffconf.h.

◆ FF_MAX_SS

#define FF_MAX_SS 512

Definition at line 197 of file ffconf.h.

◆ FF_MIN_GPT

#define FF_MIN_GPT 0x10000000

Definition at line 211 of file ffconf.h.

◆ FF_MIN_SS

#define FF_MIN_SS 512

Definition at line 196 of file ffconf.h.

◆ FF_MULTI_PARTITION

#define FF_MULTI_PARTITION 0

Definition at line 187 of file ffconf.h.

◆ FF_NORTC_MDAY

#define FF_NORTC_MDAY 1

Definition at line 242 of file ffconf.h.

◆ FF_NORTC_MON

#define FF_NORTC_MON 1

Definition at line 241 of file ffconf.h.

◆ FF_NORTC_YEAR

#define FF_NORTC_YEAR 2020

Definition at line 243 of file ffconf.h.

◆ FF_PRINT_FLOAT

#define FF_PRINT_FLOAT 0

Definition at line 61 of file ffconf.h.

◆ FF_PRINT_LLI

#define FF_PRINT_LLI 0

Definition at line 60 of file ffconf.h.

◆ FF_SFN_BUF

#define FF_SFN_BUF 12

Definition at line 149 of file ffconf.h.

◆ FF_STR_VOLUME_ID

#define FF_STR_VOLUME_ID 0

Definition at line 173 of file ffconf.h.

◆ FF_STRF_ENCODE

#define FF_STRF_ENCODE 0

Definition at line 62 of file ffconf.h.

◆ FF_SYNC_t

#define FF_SYNC_t HANDLE

Definition at line 281 of file ffconf.h.

◆ FF_USE_CHMOD

#define FF_USE_CHMOD 0

Definition at line 45 of file ffconf.h.

◆ FF_USE_EXPAND

#define FF_USE_EXPAND 0

Definition at line 41 of file ffconf.h.

◆ FF_USE_FASTSEEK

#define FF_USE_FASTSEEK 1

Definition at line 37 of file ffconf.h.

◆ FF_USE_FIND

#define FF_USE_FIND 0

Definition at line 28 of file ffconf.h.

◆ FF_USE_FORWARD

#define FF_USE_FORWARD 0

Definition at line 55 of file ffconf.h.

◆ FF_USE_LABEL

#define FF_USE_LABEL 0

Definition at line 50 of file ffconf.h.

◆ FF_USE_LFN

#define FF_USE_LFN 0

Definition at line 116 of file ffconf.h.

◆ FF_USE_MKFS

#define FF_USE_MKFS 1

Definition at line 33 of file ffconf.h.

◆ FF_USE_STRFUNC

#define FF_USE_STRFUNC 0

Definition at line 59 of file ffconf.h.

◆ FF_USE_TRIM

#define FF_USE_TRIM 0

Definition at line 216 of file ffconf.h.

◆ FF_VOLUME_STRS

#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"

Definition at line 174 of file ffconf.h.

◆ FF_VOLUMES

#define FF_VOLUMES 3

Definition at line 169 of file ffconf.h.

◆ FFCONF_DEF

#define FFCONF_DEF 86631 /* Revision ID */

Definition at line 5 of file ffconf.h.


AT32F413 Firmwary Library: at32_sdio.c File Reference

  • sdio
  • sd_mmc_card
  • src
Functions | Variables
sd_mmc_card/src/at32_sdio.c File Reference

this file provides a set of functions needed to manage the sdio/mmc card memory. More...

#include "at32_sdio.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info

Detailed Description

this file provides a set of functions needed to manage the sdio/mmc card memory.

Version
v2.0.5
Date
2022-05-20
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file sd_mmc_card/src/at32_sdio.c.


AT32F413 Firmwary Library: at32_sdio.c File Reference

  • sdio
  • sdio_fatfs
  • src
Functions | Variables
sdio_fatfs/src/at32_sdio.c File Reference

this file provides a set of functions needed to manage the sdio/mmc card memory. More...

#include <string.h>
#include "at32_sdio.h"
#include "at32f413_board.h"

Go to the source code of this file.

Functions

sd_error_status_type | command_error (void)
checks for error conditions for cmd0. More...
sd_error_status_type | command_rsp1_error (uint8_t cmd)
checks for error conditions for R1 response. More...
sd_error_status_type | command_rsp2_error (void)
checks for error conditions for R2 (cid or csd) response. More...
sd_error_status_type | command_rsp3_error (void)
checks for error conditions for R3 (ocr) response. More...
sd_error_status_type | command_rsp4_error (uint8_t cmd)
checks for error conditions for r4 response. More...
sd_error_status_type | command_rsp5_error (uint8_t cmd)
checks for error conditions for r5 response. More...
sd_error_status_type | command_rsp6_error (uint8_t cmd, uint16_t *prca)
checks for error conditions for r6 (rca) response. More...
sd_error_status_type | command_rsp7_error (void)
checks for error conditions for R7 response. More...
sd_error_status_type | sd_bus_wide_enable (confirm_state new_state)
enable or disable the sdio wide bus mode. More...
sd_error_status_type | mmc_switch (uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed More...
sd_error_status_type | sd_switch (uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed More...
sd_error_status_type | check_card_programming (uint8_t *p_status)
checks if the sd card is in programming state. More...
sd_error_status_type | speed_change (uint8_t speed)
set bus speed More...
sd_error_status_type | scr_find (void)
find the sd card scr register value. More...
uint8_t | convert_from_bytes_to_power_of_two (uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power. More...
sd_error_status_type | sd_init (void)
initializes the sd card and put it into standby state (ready for data transfer). More...
void | sdio_clock_set (uint32_t clk_div)
set sdio clock devision factor. More...
sd_error_status_type | sd_power_on (void)
enquires cards about their operating voltage and configures clock controls. More...
sd_error_status_type | sd_power_off (void)
turns the sdio output signals off. More...
sd_error_status_type | sd_card_init (void)
intialises all cards or single card as the case may be card(s) come into standby state. More...
sd_error_status_type | sd_card_info_get (sd_card_info_struct_type *card_info)
returns information about specific card. More...
sd_error_status_type | sd_wide_bus_operation_config (sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card. More...
sd_error_status_type | sd_device_mode_set (uint32_t mode)
set sdio work mode. More...
sd_error_status_type | sd_deselect_select (uint32_t addr)
selects od deselects the corresponding card. More...
sd_error_status_type | sdio_command_data_send (sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card. More...
sd_error_status_type | sd_blocks_erase (long long addr, uint32_t nblks)
erase continuous data block More...
sd_error_status_type | sd_block_read (uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_read (uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_block_write (const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be managed by dma mode or polling mode. More...
sd_error_status_type | sd_mult_blocks_write (const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed by dma mode only. More...
sd_error_status_type | mmc_stream_read (uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream. More...
sd_error_status_type | mmc_stream_write (uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream. More...
void | SDIO1_IRQHandler (void)
sdio1 isr. More...
void | SDIO2_IRQHandler (void)
sdio2 isr. More...
sd_error_status_type | sd_irq_service (void)
allows to process all the interrupts that are high. More...
sd_error_status_type | sd_status_send (uint32_t *p_card_status)
read current card status. More...
sd_card_state_type | sd_state_get (void)
returns information about sd card. More...
void | sd_dma_config (uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio More...

Variables

sdio_command_struct_type sdio_command_init_struct
sdio_data_struct_type sdio_data_init_struct
static sd_memory_card_type | card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1
static uint32_t | csd_table [4]
static uint32_t | cid_table [4]
static uint32_t | rca = 0
static sd_data_transfer_mode_type | device_mode = SD_TRANSFER_POLLING_MODE
static uint8_t | stop_flag = 0
volatile sd_error_status_type | transfer_error = SD_OK
volatile uint8_t | transfer_end = 0
sd_card_info_struct_type sd_card_info

Detailed Description

this file provides a set of functions needed to manage the sdio/mmc card memory.

Version
v2.0.5
Date
2022-05-20
        Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file sdio_fatfs/src/at32_sdio.c.


AT32F413 Firmwary Library: diskio.c File Reference

  • sdio
  • sdio_fatfs
  • src
Macros | Functions
diskio.c File Reference
#include "ff.h"
#include "diskio.h"
#include <string.h>
#include "at32_sdio.h"

Go to the source code of this file.

Macros

#define | DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
#define | DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
#define | DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Functions

__align (4)
sd_error_status_type | sd_write_disk (const uint8_t *buf, uint32_t sector, uint8_t cnt)
write sd card sector More...
DSTATUS | disk_status (BYTE pdrv)
DSTATUS | disk_initialize (BYTE pdrv)
DRESULT | disk_read (BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_write (BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
DRESULT | disk_ioctl (BYTE pdrv, BYTE cmd, void *buff)

Macro Definition Documentation

◆ DEV_MMC

#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */

Definition at line 19 of file diskio.c.

◆ DEV_RAM

#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */

Definition at line 18 of file diskio.c.

◆ DEV_USB

#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */

Definition at line 20 of file diskio.c.

Function Documentation

◆ __align()

__align ( 4 )

Definition at line 22 of file diskio.c.

◆ disk_initialize()

DSTATUS disk_initialize ( BYTE pdrv )

Definition at line 141 of file diskio.c.

◆ disk_ioctl()

DRESULT disk_ioctl | ( | BYTE | pdrv,
 |  | BYTE | cmd,
 |  | void * | buff
 | ) |  |

Definition at line 245 of file diskio.c.

◆ disk_read()

DRESULT disk_read | ( | BYTE | pdrv,
 |  | BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 172 of file diskio.c.

◆ disk_status()

DSTATUS disk_status ( BYTE pdrv )

Definition at line 110 of file diskio.c.

◆ disk_write()

DRESULT disk_write | ( | BYTE | pdrv,
 |  | const BYTE * | buff,
 |  | LBA_t | sector,
 |  | UINT | count
 | ) |  |

Definition at line 209 of file diskio.c.

◆ sd_write_disk()

sd_error_status_type sd_write_disk | ( | const uint8_t * | buf,
 |  | uint32_t | sector,
 |  | uint8_t | cnt
 | ) |  |

write sd card sector

Parameters
buf | write data buf
sector | sector address
cnt | sector count
Return values
sd_error_status_type sd card error code.

Definition at line 74 of file diskio.c.

Referenced by disk_write().


AT32F413 Firmwary Library: spi_flash.h File Reference

  • spi
  • w25q_flash
  • inc
Macros | Functions
spi_flash.h File Reference

header file of spi_flash More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define | SPI_TRANS_DMA
#define | FLASH_CS_HIGH() gpio_bits_set(GPIOB, GPIO_PINS_12)
#define | FLASH_CS_LOW() gpio_bits_reset(GPIOB, GPIO_PINS_12)
#define | W25Q80 0xEF13
#define | W25Q16 0xEF14
#define | W25Q32 0xEF15
#define | W25Q64 0xEF16
#define | W25Q128 0xEF17
#define | SPIF_CHIP_SIZE 0x1000000
#define | SPIF_SECTOR_SIZE 4096
#define | SPIF_PAGE_SIZE 256
#define | SPIF_WRITEENABLE 0x06
#define | SPIF_WRITEDISABLE 0x04
#define | SPIF_READSTATUSREG1 0x05
#define | SPIF_WRITESTATUSREG1 0x01
#define | SPIF_READSTATUSREG2 0x35
#define | SPIF_WRITESTATUSREG2 0x31
#define | SPIF_READSTATUSREG3 0x15
#define | SPIF_WRITESTATUSREG3 0x11
#define | SPIF_READDATA 0x03
#define | SPIF_FASTREADDATA 0x0B
#define | SPIF_FASTREADDUAL 0x3B
#define | SPIF_PAGEPROGRAM 0x02
#define | SPIF_BLOCKERASE 0xD8
#define | SPIF_SECTORERASE 0x20
#define | SPIF_CHIPERASE 0xC7
#define | SPIF_POWERDOWN 0xB9
#define | SPIF_RELEASEPOWERDOWN 0xAB
#define | SPIF_DEVICEID 0xAB
#define | SPIF_MANUFACTDEVICEID 0x90
#define | SPIF_JEDECDEVICEID 0x9F
#define | FLASH_SPI_DUMMY_BYTE 0xA5

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Detailed Description

header file of spi_flash

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file spi_flash.h.


AT32F413 Firmwary Library: spi_flash.c File Reference

  • spi
  • w25q_flash
  • src
Functions | Variables
spi_flash.c File Reference

spi_flash source code More...

#include "spi_flash.h"

Go to the source code of this file.

Functions

void | spiflash_init (void)
spi configuration. More...
void | spiflash_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash More...
void | spiflash_read (uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash More...
void | spiflash_sector_erase (uint32_t erase_addr)
erase a sector data More...
void | spiflash_write_nocheck (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check More...
void | spiflash_page_write (uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data More...
void | spi_bytes_write (uint8_t *pbuffer, uint32_t length)
write data continuously More...
void | spi_bytes_read (uint8_t *pbuffer, uint32_t length)
read data continuously More...
void | spiflash_wait_busy (void)
wait program done More...
uint8_t | spiflash_read_sr1 (void)
read sr1 register More...
void | spiflash_write_enable (void)
enable write operation More...
uint16_t | spiflash_read_id (void)
read device id More...
uint8_t | spi_byte_write (uint8_t data)
write a byte to flash More...
uint8_t | spi_byte_read (void)
read a byte to flash More...

Variables

uint8_t spiflash_sector_buf [SPIF_SECTOR_SIZE]

Detailed Description

spi_flash source code

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file spi_flash.c.


AT32F413 Firmwary Library: smartcard_config.h File Reference

  • usart
  • smartcard
  • inc
Macros
smartcard_config.h File Reference

header file of clock program More...

Go to the source code of this file.

Macros

#define | SC_USART USART2
#define | SC_USART_CLK CRM_USART2_PERIPH_CLOCK
#define | SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_USART_TX_PIN GPIO_PINS_2
#define | SC_USART_TX_PORT GPIOA
#define | SC_USART_CLK_PIN GPIO_PINS_4
#define | SC_USART_CLK_PORT GPIOA
#define | SC_USART_IRQn USART2_IRQn
#define | SC_USART_IRQHandler USART2_IRQHandler
#define | SC_3_5V_PIN GPIO_PINS_5
#define | SC_RESET_PIN GPIO_PINS_6
#define | SC_CMDVCC_PIN GPIO_PINS_7
#define | SC_OFF_PIN GPIO_PINS_8
#define | SC_3_5V_PORT GPIOA
#define | SC_RESET_PORT GPIOA
#define | SC_CMDVCC_PORT GPIOA
#define | SC_OFF_PORT GPIOA
#define | SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK
#define | SC_OFF_EXINT EXINT_LINE_8
#define | SC_OFF_PORTSOURCE GPIO_PORT_SOURCE_GPIOA
#define | SC_OFF_PINSOURCE GPIO_PINS_SOURCE8
#define | SC_OFF_EXINT_IRQ EXINT9_5_IRQn

Detailed Description

header file of clock program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file smartcard_config.h.

Macro Definition Documentation

◆ SC_3_5V_CLK

#define SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 55 of file smartcard_config.h.

◆ SC_3_5V_PIN

#define SC_3_5V_PIN GPIO_PINS_5

Definition at line 47 of file smartcard_config.h.

◆ SC_3_5V_PORT

#define SC_3_5V_PORT GPIOA

Definition at line 51 of file smartcard_config.h.

◆ SC_CMDVCC_CLK

#define SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 57 of file smartcard_config.h.

◆ SC_CMDVCC_PIN

#define SC_CMDVCC_PIN GPIO_PINS_7

Definition at line 49 of file smartcard_config.h.

◆ SC_CMDVCC_PORT

#define SC_CMDVCC_PORT GPIOA

Definition at line 53 of file smartcard_config.h.

◆ SC_OFF_CLK

#define SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 58 of file smartcard_config.h.

◆ SC_OFF_EXINT

#define SC_OFF_EXINT EXINT_LINE_8

Definition at line 59 of file smartcard_config.h.

◆ SC_OFF_EXINT_IRQ

#define SC_OFF_EXINT_IRQ EXINT9_5_IRQn

Definition at line 62 of file smartcard_config.h.

◆ SC_OFF_PIN

#define SC_OFF_PIN GPIO_PINS_8

Definition at line 50 of file smartcard_config.h.

◆ SC_OFF_PINSOURCE

#define SC_OFF_PINSOURCE GPIO_PINS_SOURCE8

Definition at line 61 of file smartcard_config.h.

◆ SC_OFF_PORT

#define SC_OFF_PORT GPIOA

Definition at line 54 of file smartcard_config.h.

◆ SC_OFF_PORTSOURCE

#define SC_OFF_PORTSOURCE GPIO_PORT_SOURCE_GPIOA

Definition at line 60 of file smartcard_config.h.

◆ SC_RESET_CLK

#define SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 56 of file smartcard_config.h.

◆ SC_RESET_PIN

#define SC_RESET_PIN GPIO_PINS_6

Definition at line 48 of file smartcard_config.h.

◆ SC_RESET_PORT

#define SC_RESET_PORT GPIOA

Definition at line 52 of file smartcard_config.h.

◆ SC_USART

#define SC_USART USART2

Definition at line 36 of file smartcard_config.h.

◆ SC_USART_CLK

#define SC_USART_CLK CRM_USART2_PERIPH_CLOCK

Definition at line 37 of file smartcard_config.h.

◆ SC_USART_CLK_PIN

#define SC_USART_CLK_PIN GPIO_PINS_4

Definition at line 41 of file smartcard_config.h.

◆ SC_USART_CLK_PORT

#define SC_USART_CLK_PORT GPIOA

Definition at line 42 of file smartcard_config.h.

◆ SC_USART_GPIO_CLK

#define SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK

Definition at line 38 of file smartcard_config.h.

◆ SC_USART_IRQHandler

#define SC_USART_IRQHandler ( void ) USART2_IRQHandler

Definition at line 44 of file smartcard_config.h.

◆ SC_USART_IRQn

#define SC_USART_IRQn USART2_IRQn

Definition at line 43 of file smartcard_config.h.

◆ SC_USART_TX_PIN

#define SC_USART_TX_PIN GPIO_PINS_2

Definition at line 39 of file smartcard_config.h.

◆ SC_USART_TX_PORT

#define SC_USART_TX_PORT GPIOA

Definition at line 40 of file smartcard_config.h.


AT32F413 Firmwary Library: audio_codec.h File Reference

  • usb_device
  • audio
  • inc
Data Structures | Macros | Functions
audio/inc/audio_codec.h File Reference

audio codec header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct audio_codec_type

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_12
#define | I2S2_CK_PIN GPIO_PINS_13
#define | I2S2_SD_PIN GPIO_PINS_15
#define | I2S2_GPIO GPIOB
#define | I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

audio codec header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio/inc/audio_codec.h.


AT32F413 Firmwary Library: audio_codec.h File Reference

  • usb_device
  • composite_audio_hid
  • inc
Data Structures | Macros | Functions
composite_audio_hid/inc/audio_codec.h File Reference

audio codec header file More...

#include "at32f413.h"

Go to the source code of this file.

Data Structures

struct audio_codec_type

Macros

#define | WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
#define | WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
#define | WM8988_R2_LOUT1_VOLUME 0x02
#define | WM8988_R3_ROUT1_VOLUME 0x03
#define | WM8988_R4_RESERVED 0x04
#define | WM8988_R5_ADC_DAC_CONTROL 0x05
#define | WM8988_R6_RESERVED 0x06
#define | WM8988_R7_AUDIO_INTERFACE 0x07
#define | WM8988_R8_SAMPLE_RATE 0x08
#define | WM8988_R9_RESERVED 0x09
#define | WM8988_R10_LEFT_DAC_VOLUME 0x0A
#define | WM8988_R11_RIGHT_DAC_VOLUME 0x0B
#define | WM8988_R12_BASS_CONTROL 0x0C
#define | WM8988_R13_TREBLE_CONTROL 0x0D
#define | WM8988_R14_
#define | WM8988_R15_RESET 0x0F
#define | WM8988_R16_3D_CONTROL 0x10
#define | WM8988_R17_ALC1 0x11
#define | WM8988_R18_ALC2 0x12
#define | WM8988_R19_ALC3 0x13
#define | WM8988_R20_NOISE_GATE 0x14
#define | WM8988_R21_LEFT_ADC_VOLUME 0x15
#define | WM8988_R22_RIGHT_ADC_VOLUME 0x16
#define | WM8988_R23_ADDITIONAL_1_CONTROL 0x17
#define | WM8988_R24_ADDITIONAL_2_CONTROL 0x18
#define | WM8988_R25_PWR_1_MGMT 0x19
#define | WM8988_R26_PWR_2_MGMT 0x1A
#define | WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
#define | WM8988_R31_ADC_INPUT_MODE 0x1F
#define | WM8988_R32_ADC_L_SIGNAL_PATH 0x20
#define | WM8988_R33_ADC_R_SIGNAL_PATH 0x21
#define | WM8988_R34_LEFT_OUT_MIX_1 0x22
#define | WM8988_R35_LEFT_OUT_MIX_2 0x23
#define | WM8988_R36_RIGHT_OUT_MIX_1 0x24
#define | WM8988_R37_RIGHT_OUT_MIX_2 0x25
#define | WM8988_R38_RESERVED
#define | WM8988_R39_RESERVED
#define | WM8988_R40_LOUT2_VOLUME 0x28
#define | WM8988_R41_ROUT2_VOLUME 0x29
#define | WM8988_R42_RESERVED
#define | WM8988_R43_LOW_POWER_PALYBACK 0x43
#define | WM8988_I2C_ADDR_CSB_LOW 0x34
#define | WM8988_I2C_ADDR_CSB_HIGH 0x36
#define | I2S1_WS_PIN GPIO_PINS_4
#define | I2S1_CK_PIN GPIO_PINS_5
#define | I2S1_SD_PIN GPIO_PINS_7
#define | I2S1_GPIO GPIOA
#define | I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
#define | I2S1_DT_ADDRESS (&(SPI1->dt))
#define | I2S2_WS_PIN GPIO_PINS_12
#define | I2S2_CK_PIN GPIO_PINS_13
#define | I2S2_SD_PIN GPIO_PINS_15
#define | I2S2_GPIO GPIOB
#define | I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2S2_DT_ADDRESS (&(SPI2->dt))
#define | SPK_TX_FIFO_SIZE (1024 * 4)
#define | MIC_BUFFER_SIZE 1024
#define | SPK_BUFFER_SIZE 4096
#define | DMA_BUFFER_SIZE 288

Functions

error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
audio codec interface More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...

Detailed Description

audio codec header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_audio_hid/inc/audio_codec.h.


AT32F413 Firmwary Library: audio_codec.c File Reference

  • usb_device
  • audio
  • src
Macros | Functions | Variables
audio/src/audio_codec.c File Reference

audio codec function More...

#include "audio_codec.h"
#include "i2c_application.h"
#include "audio_conf.h"
#include <string.h>

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 100000
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]

Detailed Description

audio codec function

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file audio/src/audio_codec.c.


AT32F413 Firmwary Library: audio_codec.c File Reference

  • usb_device
  • composite_audio_hid
  • src
Macros | Functions | Variables
composite_audio_hid/src/audio_codec.c File Reference

audio codec function More...

#include "audio_codec.h"
#include "i2c_application.h"
#include "audio_conf.h"
#include <string.h>

Go to the source code of this file.

Macros

#define | I2C_TIMEOUT 0xFFFFFFFF
#define | I2Cx_SPEED 200000
#define | I2Cx_ADDRESS 0x00
#define | I2Cx_PORT I2C1
#define | I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
#define | I2Cx_SCL_PIN GPIO_PINS_8
#define | I2Cx_SCL_GPIO_PORT GPIOB
#define | I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | I2Cx_SDA_PIN GPIO_PINS_9
#define | I2Cx_SDA_GPIO_PORT GPIOB
#define | I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
#define | WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
wm8988 freq More...
#define | WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
#define | WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
wm8988 bit width More...

Functions

void | memset16_buffer (uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset More...
void | codec_i2s_reset (void)
audio codec i2s reset More...
void | codec_i2s_init (audio_codec_type *param)
audio codec i2s init More...
void | mclk_tmr1_init (void)
mclk clock conifg More...
void | copy_buff (uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer More...
void | audio_codec_set_mic_freq (uint32_t freq)
audio codec set microphone freq More...
void | audio_codec_set_spk_freq (uint32_t freq)
audio codec set speaker freq More...
void | audio_codec_spk_alt_setting (uint32_t alt_seting)
audio codec speaker alt setting config More...
void | audio_codec_mic_alt_setting (uint32_t alt_seting)
audio codec microphone alt setting config More...
void | audio_codec_set_mic_mute (uint8_t mute)
audio codec set microphone mute More...
void | audio_codec_set_spk_mute (uint8_t mute)
audio codec set speaker mute More...
void | audio_codec_set_mic_volume (uint16_t volume)
audio codec set microphone volume More...
void | audio_codec_set_spk_volume (uint16_t volume)
audio codec set speaker volume More...
uint8_t | audio_codec_spk_feedback (uint8_t *feedback)
codec speaker feedback More...
void | audio_codec_spk_fifo_write (uint8_t *data, uint32_t len)
codec speaker write fifo More...
uint32_t | audio_codec_mic_get_data (uint8_t *buffer)
codec microphone get data More...
void | audio_codec_modify_freq (uint32_t freq)
audio codec modify freq More...
void | i2c_lowlevel_init (i2c_handle_type *hi2c)
initializes peripherals used by the i2c. More...
void | DMA1_Channel3_IRQHandler (void)
this function handles dma1 channel3 interrupt. More...
void | DMA1_Channel4_IRQHandler (void)
this function handles dma1 channel4 interrupt. More...
error_status | audio_codec_init (void)
audio codec init More...
error_status | audio_codec_loop (void)
audio codec loop More...

Variables

uint16_t | reg_addr_data []
wm8988 register default value More...
i2c_handle_type hi2cx
audio_codec_type audio_codec
uint16_t | spk_dma_buffer [DMA_BUFFER_SIZE]
uint16_t | mic_dma_buffer [DMA_BUFFER_SIZE]

Detailed Description

audio codec function

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_audio_hid/src/audio_codec.c.


AT32F413 Firmwary Library: msc_diskio.h File Reference

  • usb_device
  • composite_vcp_msc
  • inc
Macros | Functions
composite_vcp_msc/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_vcp_msc/inc/msc_diskio.h.


AT32F413 Firmwary Library: msc_diskio.h File Reference

  • usb_device
  • msc
  • inc
Macros | Functions
msc/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08005000
#define | SECTOR_SIZE_1K 1024
#define | SECTOR_SIZE_2K 2048
#define | SECTOR_SIZE_4K 4096

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc/inc/msc_diskio.h.


AT32F413 Firmwary Library: msc_diskio.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Macros | Functions
virtual_msc_iap/inc/msc_diskio.h File Reference

usb mass storage disk interface header file More...

#include "usb_conf.h"
#include "usb_std.h"

Go to the source code of this file.

Macros

#define | INTERNAL_FLASH_LUN 0
#define | SPI_FLASH_LUN 1
#define | SD_LUN 2
#define | USB_FLASH_ADDR_OFFSET 0x08004000

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Detailed Description

usb mass storage disk interface header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file virtual_msc_iap/inc/msc_diskio.h.


AT32F413 Firmwary Library: msc_diskio.c File Reference

  • usb_device
  • composite_vcp_msc
  • src
Functions | Variables
composite_vcp_msc/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "cdc_msc_class.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file composite_vcp_msc/src/msc_diskio.c.


AT32F413 Firmwary Library: msc_diskio.c File Reference

  • usb_device
  • msc
  • src
Functions | Variables
msc/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "msc_bot_scsi.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint32_t | sector_size = 2048
uint32_t | msc_flash_size
uint8_t | scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file msc/src/msc_diskio.c.


AT32F413 Firmwary Library: msc_diskio.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Functions | Variables
virtual_msc_iap/src/msc_diskio.c File Reference

usb mass storage disk function More...

#include "msc_diskio.h"
#include "msc_bot_scsi.h"
#include "flash_fat16.h"

Go to the source code of this file.

Functions

uint8_t * | get_inquiry (uint8_t lun)
get disk inquiry More...
usb_sts_type | msc_disk_read (uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read More...
usb_sts_type | msc_disk_write (uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write More...
usb_sts_type | msc_disk_capacity (uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity More...

Variables

uint8_t scsi_inquiry [MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]

Detailed Description

usb mass storage disk function

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file virtual_msc_iap/src/msc_diskio.c.


AT32F413 Firmwary Library: flash_fat16.h File Reference

  • usb_device
  • virtual_msc_iap
  • inc
Data Structures | Macros | Enumerations | Functions | Variables
flash_fat16.h File Reference

fat16 file system header file More...

#include "usb_conf.h"

Go to the source code of this file.

Data Structures

struct | fat_dir_type
struct | flash_iap_type

Macros

#define | FAT16_SECTOR_SIZE 62
#define | FAT16_TABLE_SIZE 4
#define | FAT16_BYTE_PER_SIZE 2048
#define | FAT16_FILENAME_SIZE 11
#define | FAT16_DIR_SIZE 47
#define | FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
#define | FLASH_FAT16_1_ADDR 0x3000
#define | FLASH_FAT16_2_ADDR 0x3800
#define | FLASH_FAT16_ROOT_ADDR 0x4000
#define | FLASH_FAT16_FILE_START_ADDR 0x8800
#define | FLASH_APP_START_ADDR 0x08005000
#define | FLASH_SECTOR_1K_SIZE 0x400
#define | FLASH_SECTOR_2K_SIZE 0x800
#define | FLASH_SECTOR_4K_SIZE 0x1000
#define | FLASH_SECTOR_1K_ALLGNED 0x3FF
#define | FLASH_SECTOR_2K_ALLGNED 0x7FF
#define | FLASH_SECTOR_4K_ALLGNED 0xFFF
#define | FILE_SUFFIX1_LEN 3
#define | FILE_SUFFIX2_LEN 3
#define | FILE_SUFFIX1_NAME "BIN"
#define | FILE_SUFFIX2_NAME "bin"
#define | INVAILD_OFFSET_ADDR 0xFFFFFFFF
#define | IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
#define | IAP_SUCCESS 0
#define | IAP_FAILED 1

Enumerations

enum upgrade_status_type {
UPGRADE_READY = 0 , UPGRAGE_ONGOING , UPGRADE_SUCCESS , UPGRADE_FAILED ,
UPGRADE_LARGE , UPGRADE_UNKNOWN , UPGRADE_DONE , UPGRADE_JUMP
}

Functions

uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
void | flash_fat16_init (void)
flash fat16 iap init More...
void | flash_fat16_loop_status (void)
loop status More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...

Variables

flash_iap_type flash_iap

Detailed Description

fat16 file system header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file flash_fat16.h.


AT32F413 Firmwary Library: flash_fat16.c File Reference

  • usb_device
  • virtual_msc_iap
  • src
Macros | Functions | Variables
flash_fat16.c File Reference

fat16 file system More...

#include "flash_fat16.h"
#include "usb_conf.h"

Go to the source code of this file.

Macros

#define FAT16_SECTOR_SIZE 62

Functions

uint32_t | flash_fat16_boot_dir_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write More...
uint32_t | flash_fat16_sector_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector More...
uint32_t | fat16_memory_copy (uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function More...
uint32_t | fat16_memory_memset (uint8_t *dst, uint32_t set, uint32_t len)
memset function More...
uint32_t | flash_write_data (uint32_t address, uint8_t *data, uint32_t len)
write data to flash More...
uint32_t | flash_read_data (uint32_t address, uint8_t *data, uint32_t len)
read data from flash More...
uint32_t | fat16_memory_cmp (uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function More...
uint32_t | flash_crc_check (uint32_t address, uint8_t *data, uint32_t len)
crc check More...
void | flash_fat16_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | flash_fat16_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint8_t | flash_fat16_get_upgrade_flag (void)
get iap upgrade complete flag More...
uint32_t | flash_fat16_read (uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address More...
uint32_t | flash_fat16_write (uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address More...
uint32_t | flash_fat16_set_name (const uint8_t *file_name, uint8_t len)
set file name More...
uint32_t | flash_fat16_addr_offset (uint8_t *file_name)
get offset address More...
void | flash_fat16_init (void)
flash fat16 iap init More...

Variables

static uint8_t | fat16_sector [62]
const uint8_t | fat16_root_dir_sector [FAT16_DIR_SIZE]
const uint8_t | fat16_table_sector0 [FAT16_TABLE_SIZE]
uint8_t | fat16_file_name [FAT16_FILENAME_SIZE]
fat_dir_type g_file_attr
flash_iap_type flash_iap
uint32_t | file_write_nr = 0
uint8_t | file_match = 0

Detailed Description

fat16 file system

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file flash_fat16.c.


AT32F413 Firmwary Library: FreeRTOSConfig.h File Reference

  • utilities
  • at32f413_freertos_demo
  • inc
Macros
FreeRTOSConfig.h File Reference

Go to the source code of this file.

Macros

#define | configUSE_PREEMPTION 1
#define | configUSE_IDLE_HOOK 0
#define | configUSE_TICK_HOOK 0
#define | configCPU_CLOCK_HZ ( ( unsigned long ) systemcoreclock )
#define | configTICK_RATE_HZ ( ( TickType_t ) 1000 )
#define | configMAX_PRIORITIES ( 5 )
#define | configMINIMAL_STACK_SIZE ( ( unsigned short ) 128 )
#define | configSUPPORT_DYNAMIC_ALLOCATION 1
#define | configTOTAL_HEAP_SIZE ( ( size_t ) ( 8 * 1024 ) )
#define | configMAX_TASK_NAME_LEN ( 16 )
#define | configUSE_16_BIT_TICKS 0
#define | configIDLE_SHOULD_YIELD 1
#define | configUSE_CO_ROUTINES 0
#define | configMAX_CO_ROUTINE_PRIORITIES ( 2 )
#define | INCLUDE_vTaskPrioritySet 1
#define | INCLUDE_uxTaskPriorityGet 1
#define | INCLUDE_vTaskDelete 1
#define | INCLUDE_vTaskCleanUpResources 0
#define | INCLUDE_vTaskSuspend 1
#define | INCLUDE_vTaskDelayUntil 1
#define | INCLUDE_vTaskDelay 1
#define | INCLUDE_xTaskGetCurrentTaskHandle 1
#define | configPRIO_BITS 4 /* 15 priority levels */
#define | configLIBRARY_LOWEST_INTERRUPT_PRIORITY 0x0f
#define | configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY 0x01
#define | configKERNEL_INTERRUPT_PRIORITY ( configLIBRARY_LOWEST_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
#define | configMAX_SYSCALL_INTERRUPT_PRIORITY ( configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
#define | configASSERT(x) if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }
#define | vPortSVCHandler SVC_Handler
#define | xPortPendSVHandler PendSV_Handler
#define | xPortSysTickHandler SysTick_Handler

Macro Definition Documentation

◆ configASSERT

#define configASSERT ( x ) if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }

Definition at line 168 of file FreeRTOSConfig.h.

◆ configCPU_CLOCK_HZ

#define configCPU_CLOCK_HZ ( ( unsigned long ) systemcoreclock )

Definition at line 115 of file FreeRTOSConfig.h.

◆ configIDLE_SHOULD_YIELD

#define configIDLE_SHOULD_YIELD 1

Definition at line 123 of file FreeRTOSConfig.h.

◆ configKERNEL_INTERRUPT_PRIORITY

#define configKERNEL_INTERRUPT_PRIORITY ( configLIBRARY_LOWEST_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )

Definition at line 161 of file FreeRTOSConfig.h.

◆ configLIBRARY_LOWEST_INTERRUPT_PRIORITY

#define configLIBRARY_LOWEST_INTERRUPT_PRIORITY 0x0f

Definition at line 151 of file FreeRTOSConfig.h.

◆ configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY

#define configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY 0x01

Definition at line 157 of file FreeRTOSConfig.h.

◆ configMAX_CO_ROUTINE_PRIORITIES

#define configMAX_CO_ROUTINE_PRIORITIES ( 2 )

Definition at line 128 of file FreeRTOSConfig.h.

◆ configMAX_PRIORITIES

#define configMAX_PRIORITIES ( 5 )

Definition at line 117 of file FreeRTOSConfig.h.

◆ configMAX_SYSCALL_INTERRUPT_PRIORITY

#define configMAX_SYSCALL_INTERRUPT_PRIORITY ( configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )

Definition at line 164 of file FreeRTOSConfig.h.

◆ configMAX_TASK_NAME_LEN

#define configMAX_TASK_NAME_LEN ( 16 )

Definition at line 121 of file FreeRTOSConfig.h.

◆ configMINIMAL_STACK_SIZE

#define configMINIMAL_STACK_SIZE ( ( unsigned short ) 128 )

Definition at line 118 of file FreeRTOSConfig.h.

◆ configPRIO_BITS

#define configPRIO_BITS 4 /* 15 priority levels */

Definition at line 146 of file FreeRTOSConfig.h.

◆ configSUPPORT_DYNAMIC_ALLOCATION

#define configSUPPORT_DYNAMIC_ALLOCATION 1

Definition at line 119 of file FreeRTOSConfig.h.

◆ configTICK_RATE_HZ

#define configTICK_RATE_HZ ( ( TickType_t ) 1000 )

Definition at line 116 of file FreeRTOSConfig.h.

◆ configTOTAL_HEAP_SIZE

#define configTOTAL_HEAP_SIZE ( ( size_t ) ( 8 * 1024 ) )

Definition at line 120 of file FreeRTOSConfig.h.

◆ configUSE_16_BIT_TICKS

#define configUSE_16_BIT_TICKS 0

Definition at line 122 of file FreeRTOSConfig.h.

◆ configUSE_CO_ROUTINES

#define configUSE_CO_ROUTINES 0

Definition at line 127 of file FreeRTOSConfig.h.

◆ configUSE_IDLE_HOOK

#define configUSE_IDLE_HOOK 0

Definition at line 113 of file FreeRTOSConfig.h.

◆ configUSE_PREEMPTION

#define configUSE_PREEMPTION 1

Definition at line 112 of file FreeRTOSConfig.h.

◆ configUSE_TICK_HOOK

#define configUSE_TICK_HOOK 0

Definition at line 114 of file FreeRTOSConfig.h.

◆ INCLUDE_uxTaskPriorityGet

#define INCLUDE_uxTaskPriorityGet 1

Definition at line 134 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskCleanUpResources

#define INCLUDE_vTaskCleanUpResources 0

Definition at line 136 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskDelay

#define INCLUDE_vTaskDelay 1

Definition at line 139 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskDelayUntil

#define INCLUDE_vTaskDelayUntil 1

Definition at line 138 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskDelete

#define INCLUDE_vTaskDelete 1

Definition at line 135 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskPrioritySet

#define INCLUDE_vTaskPrioritySet 1

Definition at line 133 of file FreeRTOSConfig.h.

◆ INCLUDE_vTaskSuspend

#define INCLUDE_vTaskSuspend 1

Definition at line 137 of file FreeRTOSConfig.h.

◆ INCLUDE_xTaskGetCurrentTaskHandle

#define INCLUDE_xTaskGetCurrentTaskHandle 1

Definition at line 140 of file FreeRTOSConfig.h.

◆ vPortSVCHandler

#define vPortSVCHandler SVC_Handler

Definition at line 172 of file FreeRTOSConfig.h.

◆ xPortPendSVHandler

#define xPortPendSVHandler PendSV_Handler

Definition at line 173 of file FreeRTOSConfig.h.

◆ xPortSysTickHandler

#define xPortSysTickHandler SysTick_Handler

Definition at line 174 of file FreeRTOSConfig.h.


AT32F413 Firmwary Library: random.h File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
Macros | Functions
random.h File Reference

at32f413 random header file More...

#include "at32f413.h"

Go to the source code of this file.

Macros

#define ENABLE_RTC_ASSEED (1)

Functions

void randnum_test (void)
enable rtc as seed More...

Detailed Description

at32f413 random header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file random.h.


AT32F413 Firmwary Library: random.c File Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
Macros | Functions
random.c File Reference

set of firmware functions to random function More...

#include "at32f413_board.h"
#include "random.h"
#include "stdio.h"
#include <stdlib.h>

Go to the source code of this file.

Macros

#define DEVICE_ID_ADDR1 0x1FFFF7E8

Functions

int | get_uid_for_seed (void)
get uid value as seed More...
void | randnum_test (void)
enable rtc as seed More...

Detailed Description

set of firmware functions to random function

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file random.c.


AT32F413 Firmwary Library: fir_filter.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Functions
project_l0/inc/fir_filter.h File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

void | arm_fir_init_f32 (arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter. More...
void | arm_fir_f32 (const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
void | FIR_lowpass_filter (float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)

Function Documentation

◆ arm_fir_f32()

void arm_fir_f32 | ( | const arm_fir_instance_f32 * | S,
 |  | const float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | blockSize
 | ) |  |

Referenced by FIR_lowpass_filter().

◆ arm_fir_init_f32()

void arm_fir_init_f32 | ( | arm_fir_instance_f32 * | S,
 |  | uint16_t | numTaps,
 |  | const float32_t * | pCoeffs,
 |  | float32_t * | pState,
 |  | uint32_t | blockSize
 | ) |  |

Initialization function for the floating-point FIR filter.

File : Step1-ST_Customer_level_n/Inc/fir_filter.h Version: V1.3.0 Date : 2021-03-18 Brief : This file contains the headers of FIR filter IP-Code.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. may be used to endorse or promote products derived from this software without specific prior written permission.

AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Parameters
[in,out] | S | points to an instance of the floating-point FIR filter structure
[in] | numTaps | number of filter coefficients in the filter
[in] | pCoeffs | points to the filter coefficients buffer
[in] | pState | points to the state buffer
[in] | blockSize | number of samples processed per call
Returns
none
Details
pCoeffs points to the array of filter coefficients stored in time reversed order:
    {b[numTaps-1], b[numTaps-2], b[N-2], ..., b[1], b[0]}
pState points to the array of state variables. pState is of length numTaps+blockSize-1 samples, where blockSize is the number of input samples processed by each call to arm_fir_f32().
Initialization of Helium version
For Helium version the array of coefficients must be a multiple of 16 even if less then 16 coefficients are used. The additional coefficients must be set to 0. It does not mean that all the coefficients will be used in the filter (numTaps is still set to its right value in the init function.) It just means that the implementation may require to read more coefficients due to the vectorization and to avoid having to manage too many different cases in the code.

Definition at line 59 of file arm_fir_init_f32.c.

Referenced by FIR_lowpass_filter().

◆ FIR_lowpass_filter()

void FIR_lowpass_filter | ( | float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | testlengthsamples
 | ) |  |

Definition at line 76 of file fir_filter.c.

Referenced by main().


AT32F413 Firmwary Library: fir_filter.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Functions
project_l1/inc/fir_filter.h File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

void | arm_fir_init_f32 (arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter. More...
void | arm_fir_f32 (const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
void | FIR_lowpass_filter (float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)

Function Documentation

◆ arm_fir_f32()

void arm_fir_f32 | ( | const arm_fir_instance_f32 * | S,
 |  | const float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | blockSize
 | ) |  |

◆ arm_fir_init_f32()

void arm_fir_init_f32 | ( | arm_fir_instance_f32 * | S,
 |  | uint16_t | numTaps,
 |  | const float32_t * | pCoeffs,
 |  | float32_t * | pState,
 |  | uint32_t | blockSize
 | ) |  |

Initialization function for the floating-point FIR filter.

File : Step1-ST_Customer_level_n/Inc/fir_filter.h Version: V1.3.0 Date : 2021-03-18 Brief : This file contains the headers of FIR filter IP-Code.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. may be used to endorse or promote products derived from this software without specific prior written permission.

AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Parameters
[in,out] | S | points to an instance of the floating-point FIR filter structure
[in] | numTaps | number of filter coefficients in the filter
[in] | pCoeffs | points to the filter coefficients buffer
[in] | pState | points to the state buffer
[in] | blockSize | number of samples processed per call
Returns
none
Details
pCoeffs points to the array of filter coefficients stored in time reversed order:
    {b[numTaps-1], b[numTaps-2], b[N-2], ..., b[1], b[0]}
pState points to the array of state variables. pState is of length numTaps+blockSize-1 samples, where blockSize is the number of input samples processed by each call to arm_fir_f32().
Initialization of Helium version
For Helium version the array of coefficients must be a multiple of 16 even if less then 16 coefficients are used. The additional coefficients must be set to 0. It does not mean that all the coefficients will be used in the filter (numTaps is still set to its right value in the init function.) It just means that the implementation may require to read more coefficients due to the vectorization and to avoid having to manage too many different cases in the code.

Definition at line 59 of file arm_fir_init_f32.c.

◆ FIR_lowpass_filter()

void FIR_lowpass_filter | ( | float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | testlengthsamples
 | ) |  |

Definition at line 76 of file fir_filter.c.


AT32F413 Firmwary Library: math_helper.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
Functions
project_l0/inc/math_helper.h File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

float | arm_snr_f32 (float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR. More...
void | arm_float_to_q12_20 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format. More...
void | arm_provide_guard_bits_q15 (q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_provide_guard_bits_q31 (q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14. More...
void | arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format. More...
void | arm_float_to_q30 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_clip_f32 (float *pIn, uint32_t numSamples)
Clip the float values to +/- 1. More...
uint32_t | arm_calc_guard_bits (uint32_t num_adds)
Caluclates number of guard bits. More...
void | arm_apply_guard_bits (float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer. More...
uint32_t | arm_compare_fixed_q15 (q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_compare_fixed_q31 (q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_calc_2pow (uint32_t guard_bits)
Calculates pow(2, numShifts) More...

Function Documentation

◆ arm_apply_guard_bits()

void arm_apply_guard_bits | ( | float32_t * | pIn,
 |  | uint32_t | numSamples,
 |  | uint32_t | guard_bits
 | ) |  |

Apply guard bits to buffer.

Parameters
[in,out] | pIn | pointer to input buffer
[in] | numSamples | number of samples in the input buffer
[in] | guard_bits | guard bits
Returns
none

Definition at line 293 of file project_l0/src/math_helper.c.

◆ arm_calc_2pow()

uint32_t arm_calc_2pow ( uint32_t numShifts )

Calculates pow(2, numShifts)

Parameters
[in] numShifts number of shifts
Returns
pow(2, numShifts)

Definition at line 310 of file project_l0/src/math_helper.c.

◆ arm_calc_guard_bits()

uint32_t arm_calc_guard_bits ( uint32_t num_adds )

Caluclates number of guard bits.

Parameters
[in] num_adds number of additions
Returns
guard bits The function Caluclates the number of guard bits depending on the numtaps

Definition at line 267 of file project_l0/src/math_helper.c.

◆ arm_clip_f32()

void arm_clip_f32 | ( | float * | pIn,
 |  | uint32_t | numSamples
 | ) |  |

Clip the float values to +/- 1.

Parameters
[in,out] | pIn | input buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 445 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q15()

uint32_t arm_compare_fixed_q15 | ( | q15_t * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 165 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q31()

uint32_t arm_compare_fixed_q31 | ( | q31_t * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 193 of file project_l0/src/math_helper.c.

◆ arm_float_to_q12_20()

void arm_float_to_q12_20 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed in q12.20 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to outputbuffer
[in] | numSamples | number of samples in the input buffer
Returns
none The function converts floating point values to fixed point(q12.20) values

Definition at line 139 of file project_l0/src/math_helper.c.

◆ arm_float_to_q14()

void arm_float_to_q14 | ( | float * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q14.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 334 of file project_l0/src/math_helper.c.

◆ arm_float_to_q28()

void arm_float_to_q28 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q28 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 419 of file project_l0/src/math_helper.c.

◆ arm_float_to_q29()

void arm_float_to_q29 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 391 of file project_l0/src/math_helper.c.

◆ arm_float_to_q30()

void arm_float_to_q30 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 364 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q15()

void arm_provide_guard_bits_q15 | ( | q15_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 119 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q31()

void arm_provide_guard_bits_q31 | ( | q31_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 223 of file project_l0/src/math_helper.c.

◆ arm_snr_f32()

float arm_snr_f32 | ( | float * | pRef,
 |  | float * | pTest,
 |  | uint32_t | buffSize
 | ) |  |

Caluclation of SNR.

Parameters
[in] | pRef | Pointer to the reference buffer
[in] | pTest | Pointer to the test buffer
[in] | buffSize | total number of samples
Returns
SNR The function Caluclates signal to noise ratio for the reference output and test output

Definition at line 61 of file project_l0/src/math_helper.c.

Referenced by main().


AT32F413 Firmwary Library: math_helper.h File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
Functions
project_l1/inc/math_helper.h File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

float | arm_snr_f32 (float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR. More...
void | arm_float_to_q12_20 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format. More...
void | arm_provide_guard_bits_q15 (q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_provide_guard_bits_q31 (q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14. More...
void | arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format. More...
void | arm_float_to_q30 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_clip_f32 (float *pIn, uint32_t numSamples)
Clip the float values to +/- 1. More...
uint32_t | arm_calc_guard_bits (uint32_t num_adds)
Caluclates number of guard bits. More...
void | arm_apply_guard_bits (float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer. More...
uint32_t | arm_compare_fixed_q15 (q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_compare_fixed_q31 (q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_calc_2pow (uint32_t guard_bits)
Calculates pow(2, numShifts) More...

Function Documentation

◆ arm_apply_guard_bits()

void arm_apply_guard_bits | ( | float32_t * | pIn,
 |  | uint32_t | numSamples,
 |  | uint32_t | guard_bits
 | ) |  |

Apply guard bits to buffer.

Parameters
[in,out] | pIn | pointer to input buffer
[in] | numSamples | number of samples in the input buffer
[in] | guard_bits | guard bits
Returns
none

Definition at line 293 of file project_l0/src/math_helper.c.

◆ arm_calc_2pow()

uint32_t arm_calc_2pow ( uint32_t numShifts )

Calculates pow(2, numShifts)

Parameters
[in] numShifts number of shifts
Returns
pow(2, numShifts)

Definition at line 310 of file project_l0/src/math_helper.c.

Referenced by arm_apply_guard_bits().

◆ arm_calc_guard_bits()

uint32_t arm_calc_guard_bits ( uint32_t num_adds )

Caluclates number of guard bits.

Parameters
[in] num_adds number of additions
Returns
guard bits The function Caluclates the number of guard bits depending on the numtaps

Definition at line 267 of file project_l0/src/math_helper.c.

◆ arm_clip_f32()

void arm_clip_f32 | ( | float * | pIn,
 |  | uint32_t | numSamples
 | ) |  |

Clip the float values to +/- 1.

Parameters
[in,out] | pIn | input buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 445 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q15()

uint32_t arm_compare_fixed_q15 | ( | q15_t * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 165 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q31()

uint32_t arm_compare_fixed_q31 | ( | q31_t * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 193 of file project_l0/src/math_helper.c.

◆ arm_float_to_q12_20()

void arm_float_to_q12_20 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed in q12.20 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to outputbuffer
[in] | numSamples | number of samples in the input buffer
Returns
none The function converts floating point values to fixed point(q12.20) values

Definition at line 139 of file project_l0/src/math_helper.c.

◆ arm_float_to_q14()

void arm_float_to_q14 | ( | float * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q14.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 334 of file project_l0/src/math_helper.c.

◆ arm_float_to_q28()

void arm_float_to_q28 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q28 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 419 of file project_l0/src/math_helper.c.

◆ arm_float_to_q29()

void arm_float_to_q29 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 391 of file project_l0/src/math_helper.c.

◆ arm_float_to_q30()

void arm_float_to_q30 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 364 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q15()

void arm_provide_guard_bits_q15 | ( | q15_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 119 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q31()

void arm_provide_guard_bits_q31 | ( | q31_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 223 of file project_l0/src/math_helper.c.

◆ arm_snr_f32()

float arm_snr_f32 | ( | float * | pRef,
 |  | float * | pTest,
 |  | uint32_t | buffSize
 | ) |  |

Caluclation of SNR.

Parameters
[in] | pRef | Pointer to the reference buffer
[in] | pTest | Pointer to the test buffer
[in] | buffSize | total number of samples
Returns
SNR The function Caluclates signal to noise ratio for the reference output and test output

Definition at line 61 of file project_l0/src/math_helper.c.


AT32F413 Firmwary Library: arm_fir_data.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Variables
project_l0/src/arm_fir_data.c File Reference
#include "at32f413.h"
#include "arm_math.h"

Go to the source code of this file.

Variables

float32_t | testInput_f32_1kHz_15kHz [320]
float32_t | refOutput [320]

Variable Documentation

◆ refOutput

float32_t refOutput[320]

Definition at line 96 of file project_l0/src/arm_fir_data.c.

◆ testInput_f32_1kHz_15kHz

float32_t testInput_f32_1kHz_15kHz[320]

Definition at line 48 of file project_l0/src/arm_fir_data.c.


AT32F413 Firmwary Library: arm_fir_data.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Variables
project_l1/src/arm_fir_data.c File Reference
#include "at32f413.h"
#include "arm_math.h"

Go to the source code of this file.

Variables

float32_t | testInput_f32_1kHz_15kHz [320]
float32_t | refOutput [320]

Variable Documentation

◆ refOutput

float32_t refOutput[320]

Definition at line 96 of file project_l1/src/arm_fir_data.c.

Referenced by main().

◆ testInput_f32_1kHz_15kHz

float32_t testInput_f32_1kHz_15kHz[320]

Definition at line 48 of file project_l1/src/arm_fir_data.c.

Referenced by main().


AT32F413 Firmwary Library: arm_fir_init_f32.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Functions
arm_fir_init_f32.c File Reference
#include "arm_math.h"

Go to the source code of this file.

Functions

void * | my_memset (void *s, int c, size_t n)
void | arm_fir_init_f32 (arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter. More...

Function Documentation

◆ arm_fir_init_f32()

void arm_fir_init_f32 | ( | arm_fir_instance_f32 * | S,
 |  | uint16_t | numTaps,
 |  | const float32_t * | pCoeffs,
 |  | float32_t * | pState,
 |  | uint32_t | blockSize
 | ) |  |

Initialization function for the floating-point FIR filter.

Parameters
[in,out] | S | points to an instance of the floating-point FIR filter structure
[in] | numTaps | number of filter coefficients in the filter
[in] | pCoeffs | points to the filter coefficients buffer
[in] | pState | points to the state buffer
[in] | blockSize | number of samples processed per call
Returns
none
Details
pCoeffs points to the array of filter coefficients stored in time reversed order:
    {b[numTaps-1], b[numTaps-2], b[N-2], ..., b[1], b[0]}
pState points to the array of state variables. pState is of length numTaps+blockSize-1 samples, where blockSize is the number of input samples processed by each call to arm_fir_f32().
Initialization of Helium version
For Helium version the array of coefficients must be a multiple of 16 even if less then 16 coefficients are used. The additional coefficients must be set to 0. It does not mean that all the coefficients will be used in the filter (numTaps is still set to its right value in the init function.) It just means that the implementation may require to read more coefficients due to the vectorization and to avoid having to manage too many different cases in the code.

Definition at line 59 of file arm_fir_init_f32.c.

Referenced by FIR_lowpass_filter().

◆ my_memset()

void * my_memset | ( | void * | s,
 |  | int | c,
 |  | size_t | n
 | ) |  |

Definition at line 79 of file arm_fir_init_f32.c.

Referenced by arm_fir_init_f32().


AT32F413 Firmwary Library: fir_coefficient.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Macros | Variables
fir_coefficient.c File Reference
#include "at32f413.h"
#include "arm_math.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define NUM_TAPS 29

Variables

const float32_t firCoeffs32 [29]

Macro Definition Documentation

◆ NUM_TAPS

#define NUM_TAPS 29

Definition at line 51 of file fir_coefficient.c.

Variable Documentation

◆ firCoeffs32

const float32_t firCoeffs32[29]
Initial value:
= {
-0.0018225230f, -0.0015879294f, +0.0000000000f, +0.0036977508f, +0.0080754303f, +0.0085302217f, -0.0000000000f, -0.0173976984f,
-0.0341458607f, -0.0333591565f, +0.0000000000f, +0.0676308395f, +0.1522061835f, +0.2229246956f, +0.2504960933f, +0.2229246956f,
+0.1522061835f, +0.0676308395f, +0.0000000000f, -0.0333591565f, -0.0341458607f, -0.0173976984f, -0.0000000000f, +0.0085302217f,
+0.0080754303f, +0.0036977508f, +0.0000000000f, -0.0015879294f, -0.0018225230f
}

Definition at line 62 of file fir_coefficient.c.

Referenced by FIR_lowpass_filter().


AT32F413 Firmwary Library: fir_filter.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Macros | Functions | Variables
fir_filter.c File Reference
#include "at32f413.h"
#include "arm_math.h"
#include "fir_filter.h"

Go to the source code of this file.

Macros

#define | BLOCK_SIZE 32
#define | NUM_TAPS 29

Functions

void FIR_lowpass_filter (float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)

Variables

const float32_t | firCoeffs32 []
static float32_t | firStateF32 [32+29 - 1]

Macro Definition Documentation

◆ BLOCK_SIZE

#define BLOCK_SIZE 32

Definition at line 53 of file fir_filter.c.

◆ NUM_TAPS

#define NUM_TAPS 29

Definition at line 54 of file fir_filter.c.

Function Documentation

◆ FIR_lowpass_filter()

void FIR_lowpass_filter | ( | float32_t * | pSrc,
 |  | float32_t * | pDst,
 |  | uint32_t | testlengthsamples
 | ) |  |

Definition at line 76 of file fir_filter.c.

Referenced by main().

Variable Documentation

◆ firCoeffs32

const float32_t firCoeffs32[]
extern

Definition at line 62 of file fir_coefficient.c.

Referenced by FIR_lowpass_filter().

◆ firStateF32

float32_t firStateF32[32+ 29 - 1]
static

Definition at line 66 of file fir_filter.c.

Referenced by FIR_lowpass_filter().


AT32F413 Firmwary Library: math_helper.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
Functions
project_l0/src/math_helper.c File Reference
#include <math.h>
#include "math_helper.h"

Go to the source code of this file.

Functions

float | arm_snr_f32 (float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR. More...
void | arm_provide_guard_bits_q15 (q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_float_to_q12_20 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format. More...
uint32_t | arm_compare_fixed_q15 (q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_compare_fixed_q31 (q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
void | arm_provide_guard_bits_q31 (q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_provide_guard_bits_q7 (q7_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
uint32_t | arm_calc_guard_bits (uint32_t num_adds)
Caluclates number of guard bits. More...
void | arm_apply_guard_bits (float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer. More...
uint32_t | arm_calc_2pow (uint32_t numShifts)
Calculates pow(2, numShifts) More...
void | arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14. More...
void | arm_float_to_q30 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format. More...
void | arm_clip_f32 (float *pIn, uint32_t numSamples)
Clip the float values to +/- 1. More...

Function Documentation

◆ arm_apply_guard_bits()

void arm_apply_guard_bits | ( | float32_t * | pIn,
 |  | uint32_t | numSamples,
 |  | uint32_t | guard_bits
 | ) |  |

Apply guard bits to buffer.

Parameters
[in,out] | pIn | pointer to input buffer
[in] | numSamples | number of samples in the input buffer
[in] | guard_bits | guard bits
Returns
none

Definition at line 293 of file project_l0/src/math_helper.c.

◆ arm_calc_2pow()

uint32_t arm_calc_2pow ( uint32_t numShifts )

Calculates pow(2, numShifts)

Parameters
[in] numShifts number of shifts
Returns
pow(2, numShifts)

Definition at line 310 of file project_l0/src/math_helper.c.

Referenced by arm_apply_guard_bits().

◆ arm_calc_guard_bits()

uint32_t arm_calc_guard_bits ( uint32_t num_adds )

Caluclates number of guard bits.

Parameters
[in] num_adds number of additions
Returns
guard bits The function Caluclates the number of guard bits depending on the numtaps

Definition at line 267 of file project_l0/src/math_helper.c.

◆ arm_clip_f32()

void arm_clip_f32 | ( | float * | pIn,
 |  | uint32_t | numSamples
 | ) |  |

Clip the float values to +/- 1.

Parameters
[in,out] | pIn | input buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 445 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q15()

uint32_t arm_compare_fixed_q15 | ( | q15_t * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 165 of file project_l0/src/math_helper.c.

◆ arm_compare_fixed_q31()

uint32_t arm_compare_fixed_q31 | ( | q31_t * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 193 of file project_l0/src/math_helper.c.

◆ arm_float_to_q12_20()

void arm_float_to_q12_20 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed in q12.20 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to outputbuffer
[in] | numSamples | number of samples in the input buffer
Returns
none The function converts floating point values to fixed point(q12.20) values

Definition at line 139 of file project_l0/src/math_helper.c.

◆ arm_float_to_q14()

void arm_float_to_q14 | ( | float * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q14.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 334 of file project_l0/src/math_helper.c.

◆ arm_float_to_q28()

void arm_float_to_q28 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q28 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 419 of file project_l0/src/math_helper.c.

◆ arm_float_to_q29()

void arm_float_to_q29 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 391 of file project_l0/src/math_helper.c.

◆ arm_float_to_q30()

void arm_float_to_q30 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 364 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q15()

void arm_provide_guard_bits_q15 | ( | q15_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 119 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q31()

void arm_provide_guard_bits_q31 | ( | q31_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 223 of file project_l0/src/math_helper.c.

◆ arm_provide_guard_bits_q7()

void arm_provide_guard_bits_q7 | ( | q7_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 245 of file project_l0/src/math_helper.c.

◆ arm_snr_f32()

float arm_snr_f32 | ( | float * | pRef,
 |  | float * | pTest,
 |  | uint32_t | buffSize
 | ) |  |

Caluclation of SNR.

Parameters
[in] | pRef | Pointer to the reference buffer
[in] | pTest | Pointer to the test buffer
[in] | buffSize | total number of samples
Returns
SNR The function Caluclates signal to noise ratio for the reference output and test output

Definition at line 61 of file project_l0/src/math_helper.c.


AT32F413 Firmwary Library: math_helper.c File Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
Functions
project_l1/src/math_helper.c File Reference
#include <math.h>
#include "math_helper.h"

Go to the source code of this file.

Functions

float | arm_snr_f32 (float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR. More...
void | arm_provide_guard_bits_q15 (q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_float_to_q12_20 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format. More...
uint32_t | arm_compare_fixed_q15 (q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
uint32_t | arm_compare_fixed_q31 (q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output. More...
void | arm_provide_guard_bits_q31 (q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
void | arm_provide_guard_bits_q7 (q7_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer. More...
uint32_t | arm_calc_guard_bits (uint32_t num_adds)
Caluclates number of guard bits. More...
void | arm_apply_guard_bits (float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer. More...
uint32_t | arm_calc_2pow (uint32_t numShifts)
Calculates pow(2, numShifts) More...
void | arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14. More...
void | arm_float_to_q30 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format. More...
void | arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format. More...
void | arm_clip_f32 (float *pIn, uint32_t numSamples)
Clip the float values to +/- 1. More...

Function Documentation

◆ arm_apply_guard_bits()

void arm_apply_guard_bits | ( | float32_t * | pIn,
 |  | uint32_t | numSamples,
 |  | uint32_t | guard_bits
 | ) |  |

Apply guard bits to buffer.

Parameters
[in,out] | pIn | pointer to input buffer
[in] | numSamples | number of samples in the input buffer
[in] | guard_bits | guard bits
Returns
none

Definition at line 293 of file project_l1/src/math_helper.c.

◆ arm_calc_2pow()

uint32_t arm_calc_2pow ( uint32_t numShifts )

Calculates pow(2, numShifts)

Parameters
[in] numShifts number of shifts
Returns
pow(2, numShifts)

Definition at line 310 of file project_l1/src/math_helper.c.

Referenced by arm_apply_guard_bits().

◆ arm_calc_guard_bits()

uint32_t arm_calc_guard_bits ( uint32_t num_adds )

Caluclates number of guard bits.

Parameters
[in] num_adds number of additions
Returns
guard bits The function Caluclates the number of guard bits depending on the numtaps

Definition at line 267 of file project_l1/src/math_helper.c.

◆ arm_clip_f32()

void arm_clip_f32 | ( | float * | pIn,
 |  | uint32_t | numSamples
 | ) |  |

Clip the float values to +/- 1.

Parameters
[in,out] | pIn | input buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 445 of file project_l1/src/math_helper.c.

◆ arm_compare_fixed_q15()

uint32_t arm_compare_fixed_q15 | ( | q15_t * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 165 of file project_l1/src/math_helper.c.

◆ arm_compare_fixed_q31()

uint32_t arm_compare_fixed_q31 | ( | q31_t * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Compare MATLAB Reference Output and ARM Test output.

Parameters
[in] | pIn | Pointer to Ref buffer
[in] | pOut | Pointer to Test buffer
[in] | numSamples | number of samples in the buffer
Returns
maximum difference

Definition at line 193 of file project_l1/src/math_helper.c.

◆ arm_float_to_q12_20()

void arm_float_to_q12_20 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed in q12.20 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to outputbuffer
[in] | numSamples | number of samples in the input buffer
Returns
none The function converts floating point values to fixed point(q12.20) values

Definition at line 139 of file project_l1/src/math_helper.c.

◆ arm_float_to_q14()

void arm_float_to_q14 | ( | float * | pIn,
 |  | q15_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q14.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 334 of file project_l1/src/math_helper.c.

◆ arm_float_to_q28()

void arm_float_to_q28 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q28 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 419 of file project_l1/src/math_helper.c.

◆ arm_float_to_q29()

void arm_float_to_q29 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 391 of file project_l1/src/math_helper.c.

◆ arm_float_to_q30()

void arm_float_to_q30 | ( | float * | pIn,
 |  | q31_t * | pOut,
 |  | uint32_t | numSamples
 | ) |  |

Converts float to fixed q30 format.

Parameters
[in] | pIn | pointer to input buffer
[out] | pOut | pointer to output buffer
[in] | numSamples | number of samples in the buffer
Returns
none The function converts floating point values to fixed point values

Definition at line 364 of file project_l1/src/math_helper.c.

◆ arm_provide_guard_bits_q15()

void arm_provide_guard_bits_q15 | ( | q15_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 119 of file project_l1/src/math_helper.c.

◆ arm_provide_guard_bits_q31()

void arm_provide_guard_bits_q31 | ( | q31_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 223 of file project_l1/src/math_helper.c.

◆ arm_provide_guard_bits_q7()

void arm_provide_guard_bits_q7 | ( | q7_t * | input_buf,
 |  | uint32_t | blockSize,
 |  | uint32_t | guard_bits
 | ) |  |

Provide guard bits for Input buffer.

Parameters
[in,out] | input_buf | Pointer to input buffer
[in] | blockSize | block Size
[in] | guard_bits | guard bits
Returns
none The function Provides the guard bits for the buffer to avoid overflow

Definition at line 245 of file project_l1/src/math_helper.c.

◆ arm_snr_f32()

float arm_snr_f32 | ( | float * | pRef,
 |  | float * | pTest,
 |  | uint32_t | buffSize
 | ) |  |

Caluclation of SNR.

Parameters
[in] | pRef | Pointer to the reference buffer
[in] | pTest | Pointer to the test buffer
[in] | buffSize | total number of samples
Returns
SNR The function Caluclates signal to noise ratio for the reference output and test output

Definition at line 61 of file project_l1/src/math_helper.c.

Referenced by main().


AT32F413 Firmwary Library: iap.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions
app_led3_toggle/inc/iap.h File Reference

iap header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/iap.h.


AT32F413 Firmwary Library: iap.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions
app_led4_toggle/inc/iap.h File Reference

iap header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/iap.h.


AT32F413 Firmwary Library: iap.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Data Structures | Macros | Typedefs | Enumerations | Functions | Variables
bootloader/inc/iap.h File Reference

iap header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Data Structures

struct cmd_data_group_type
cmd data group type More...

Macros

#define | APP_START_ADDR 0x08004000
#define | IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
#define | IAP_UPGRADE_FLAG 0x41544B38

Typedefs

typedef void(* iapfun) (void)

Enumerations

enum cmd_data_step_type {
CMD_DATA_IDLE , CMD_DATA_ADDR , CMD_DATA_BUF , CMD_DATA_CHACK ,
CMD_DATA_DONE , CMD_DATA_ERR
}
cmd data step type More...
enum cmd_ctr_step_type {
CMD_CTR_IDLE , CMD_CTR_INIT , CMD_CTR_DONE , CMD_CTR_ERR ,
CMD_CTR_APP
}
cmd ctr step type More...
enum update_status_type { UPDATE_PRE , UPDATE_CLEAR_FLAG , UPDATE_ING , UPDATE_DONE }
update status type More...

Functions

void | command_handle (void)
command analysis handle. More...
void | back_err (void)
command response error. More...
void | back_ok (void)
command response ok. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...
void | app_load (uint32_t appxaddr)
app load. More...

Variables

cmd_data_group_type cmd_data_group_type_struct
cmd_data_step_type cmd_data_step
cmd_ctr_step_type cmd_ctr_step
update_status_type update_status

Detailed Description

iap header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/iap.h.


AT32F413 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Functions
app_led3_toggle/inc/tmr.h File Reference

tmr header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Detailed Description

tmr header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/tmr.h.


AT32F413 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Functions
app_led4_toggle/inc/tmr.h File Reference

tmr header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Detailed Description

tmr header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/tmr.h.


AT32F413 Firmwary Library: tmr.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Functions | Variables
bootloader/inc/tmr.h File Reference

tmr header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Functions

void tmr_init (void)
init tmr. More...

Variables

uint8_t | time_ira_cnt
uint8_t | get_data_from_usart_flag

Detailed Description

tmr header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/tmr.h.


AT32F413 Firmwary Library: usart.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions | Variables
app_led3_toggle/inc/usart.h File Reference

usart header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag

Detailed Description

usart header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/usart.h.


AT32F413 Firmwary Library: usart.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions | Variables
app_led4_toggle/inc/usart.h File Reference

usart header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Macros

#define | IAP_REV_FLAG_NO 0
#define | IAP_REV_FLAG_5A 1
#define | IAP_REV_FLAG_DONE 2
#define | IAP_REV_FLAG_ERROR 3

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag

Detailed Description

usart header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/usart.h.


AT32F413 Firmwary Library: usart.h File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
Data Structures | Macros | Functions | Variables
bootloader/inc/usart.h File Reference

usart header file More...

#include "at32f413_board.h"

Go to the source code of this file.

Data Structures

struct usart_group_type
usart group type More...

Macros

#define USART_REC_LEN 1024

Functions

void uart_init (uint32_t baudrate)
init usart. More...

Variables

usart_group_type usart_group_struct

Detailed Description

usart header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/usart.h.


AT32F413 Firmwary Library: iap.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
app_led3_toggle/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/iap.c.


AT32F413 Firmwary Library: iap.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
app_led4_toggle/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | iap_command_handle (void)
iap command handle handle. More...
void | iap_init (void)
iap init. More...

Detailed Description

iap program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/iap.c.


AT32F413 Firmwary Library: iap.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/iap.c File Reference

iap program More...

#include "iap.h"
#include "usart.h"
#include "flash.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | app_load (uint32_t app_addr)
app load. More...
uint8_t | data_take (void)
take data from usart buf. More...
void | command_handle (void)
command analysis handle. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...
void | app_update_handle (void)
app update flow handle. More...
void | iap_upgrade_app_handle (void)
iap upgrade app handle. More...

Variables

cmd_data_step_type cmd_data_step = CMD_DATA_IDLE
cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE
cmd_data_group_type cmd_data_group_struct
update_status_type update_status = UPDATE_PRE
static uint8_t | cmd_addr_cnt = 0
static uint32_t | cmd_data_cnt = 0
iapfun jump_to_app
jump to app More...

Detailed Description

iap program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/iap.c.


AT32F413 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions
app_led3_toggle/src/tmr.c File Reference

tmr program More...

#include "at32f413_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Detailed Description

tmr program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/tmr.c.


AT32F413 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions
app_led4_toggle/src/tmr.c File Reference

tmr program More...

#include "at32f413_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Detailed Description

tmr program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/tmr.c.


AT32F413 Firmwary Library: tmr.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/tmr.c File Reference

tmr program More...

#include "at32f413_board.h"
#include "tmr.h"
#include "iap.h"

Go to the source code of this file.

Functions

void | tmr_init (void)
init tmr. More...
void | TMR3_GLOBAL_IRQHandler (void)
tmr3 global interrupt handler. More...

Variables

uint8_t | time_ira_cnt =0
uint8_t | get_data_from_usart_flag = 0

Detailed Description

tmr program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/tmr.c.


AT32F413 Firmwary Library: usart.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions | Variables
app_led3_toggle/src/usart.c File Reference

usart program More...

#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

usart program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/usart.c.


AT32F413 Firmwary Library: usart.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions | Variables
app_led4_toggle/src/usart.c File Reference

usart program More...

#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...
void | back_ok (void)
command response ok. More...
void | back_err (void)
command response error. More...

Variables

uint8_t iap_flag = IAP_REV_FLAG_NO

Detailed Description

usart program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/usart.c.


AT32F413 Firmwary Library: usart.c File Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/usart.c File Reference

usart program More...

#include "usart.h"
#include "tmr.h"

Go to the source code of this file.

Functions

void | uart_init (uint32_t baudrate)
init usart. More...
void | USART1_IRQHandler (void)
usart1 interrupt handler. More...

Variables

usart_group_type usart_group_struct

Detailed Description

usart program

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/usart.c.


AT32F413 Firmwary Library: hid_iap_user.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
Macros | Functions
app_led3_toggle/inc/hid_iap_user.h File Reference

usb config header file More...

#include "hid_iap_class.h"

Go to the source code of this file.

Macros

#define FLASH_APP_ADDRESS 0x08004000

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/inc/hid_iap_user.h.


AT32F413 Firmwary Library: hid_iap_user.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
Macros | Functions
app_led4_toggle/inc/hid_iap_user.h File Reference

usb config header file More...

#include "hid_iap_class.h"

Go to the source code of this file.

Macros

#define FLASH_APP_ADDRESS 0x08004000

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | app_loop (void)
iap loop More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/inc/hid_iap_user.h.


AT32F413 Firmwary Library: hid_iap_user.h File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
Macros | Functions
bootloader/inc/hid_iap_user.h File Reference

usb config header file More...

#include "hid_iap_class.h"

Go to the source code of this file.

Macros

#define FLASH_APP_ADDRESS 0x08004000

Functions

void | iap_init (void)
iap init. More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_loop (void)
iap loop More...
void | jump_to_app (uint32_t address)
jump to app More...

Detailed Description

usb config header file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/inc/hid_iap_user.h.


AT32F413 Firmwary Library: hid_iap_user.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
Functions | Variables
app_led3_toggle/src/hid_iap_user.c File Reference

usb hid iap user file More...

#include "hid_iap_user.h"
#include "hid_iap_class.h"
#include "string.h"

Go to the source code of this file.

Functions

void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
void | iap_finish (void)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...

Variables

void(* pftarget )(void)

Detailed Description

usb hid iap user file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led3_toggle/src/hid_iap_user.c.


AT32F413 Firmwary Library: hid_iap_user.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
Functions | Variables
app_led4_toggle/src/hid_iap_user.c File Reference

usb hid iap user file More...

#include "hid_iap_user.h"
#include "hid_iap_class.h"
#include "string.h"

Go to the source code of this file.

Functions

void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
void | iap_finish (void)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | app_loop (void)
iap loop More...

Variables

void(* pftarget )(void)

Detailed Description

usb hid iap user file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file app_led4_toggle/src/hid_iap_user.c.


AT32F413 Firmwary Library: hid_iap_user.c File Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
Functions | Variables
bootloader/src/hid_iap_user.c File Reference

usb hid iap user file More...

#include "hid_iap_user.h"
#include "hid_iap_class.h"
#include "string.h"

Go to the source code of this file.

Functions

void | iap_clear_upgrade_flag (void)
clear iap upgrade flag More...
void | iap_set_upgrade_flag (void)
set iap upgrade complete flag More...
uint32_t | crc_cal (uint32_t addr, uint16_t nk)
crc cal More...
void | iap_idle (void)
iap idle function More...
void | iap_start (void)
iap start function More...
iap_result_type | iap_address (uint8_t *pdata, uint32_t len)
iap parse address More...
void | iap_finish (void)
iap_result_type | iap_data_write (uint8_t *pdata, uint32_t len)
void | iap_jump (void)
void | iap_respond (uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
void | jump_to_app (uint32_t address)
jump to app More...
iap_result_type | iap_get_upgrade_flag (void)
get iap upgrade complete flag More...
void | iap_erase_sector (uint32_t address)
set iap upgrade complete flag More...
void | iap_init (void)
iap init More...
void | iap_crc (uint8_t *pdata, uint32_t len)
void | iap_get ()
iap_result_type | usbd_hid_iap_process (void *udev, uint8_t *pdata, uint16_t len)
usb device iap function More...
void | usbd_hid_iap_in_complete (void *udev)
usb device in transfer complete function More...
void | iap_loop (void)
iap loop More...

Variables

void(* pftarget )(void)

Detailed Description

usb hid iap user file

Version
v2.0.5
Date
2022-05-20
                  Copyright notice & Disclaimer
The software Board Support Package (BSP) that is made available to download from Artery official website is the copyrighted work of Artery. Artery authorizes customers to use, copy, and distribute the BSP software and its related documentation for the purpose of design and development in conjunction with Artery microcontrollers. Use of the software is governed by this copyright notice and the following disclaimer.

THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES, GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS, TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

Definition in file bootloader/src/hid_iap_user.c.


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • __align() : diskio.c
  • __AT32F413_LIBRARY_VERSION : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MAJOR : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MIDDLE : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MINOR : at32f413.h
  • __AT32F413_LIBRARY_VERSION_RC : at32f413.h
  • __CM4_REV : at32f413.h
  • __FPU_PRESENT : at32f413.h
  • __MPU_PRESENT : at32f413.h
  • __NVIC_PRIO_BITS : at32f413.h
  • __Vendor_SysTickConfig : at32f413.h
  • _asciimap : cdc_keyboard_class.c, keyboard_class.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • ACC : at32f413_acc.h
  • ACC_BASE : at32f413.h
  • acc_c2_value : project/at_start_f413/examples/acc/calibration/src/main.c
  • ACC_CAL_HICKCAL : at32f413_acc.h
  • ACC_CAL_HICKTRIM : at32f413_acc.h
  • acc_calibration_mode_enable() : at32f413_acc.h, at32f413_acc.c
  • ACC_CALRDY_FLAG : at32f413_acc.h
  • ACC_CALRDYIEN_INT : at32f413_acc.h
  • ACC_EIEN_INT : at32f413_acc.h
  • acc_flag_clear() : at32f413_acc.h, at32f413_acc.c
  • acc_flag_get() : at32f413_acc.h, at32f413_acc.c
  • acc_hickcal_get() : at32f413_acc.h, at32f413_acc.c
  • acc_hicktrim_get() : at32f413_acc.h, at32f413_acc.c
  • acc_interrupt_enable() : at32f413_acc.h, at32f413_acc.c
  • ACC_IRQHandler() : project/at_start_f413/examples/acc/calibration/src/main.c
  • ACC_IRQn : at32f413.h
  • ACC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • acc_read_c1() : at32f413_acc.h, at32f413_acc.c
  • acc_read_c2() : at32f413_acc.h, at32f413_acc.c
  • acc_read_c3() : at32f413_acc.h, at32f413_acc.c
  • ACC_RSLOST_FLAG : at32f413_acc.h
  • acc_step_set() : at32f413_acc.h, at32f413_acc.c
  • ACC_TRIM : project/at_start_f413/examples/acc/calibration/src/main.c
  • acc_write_c1() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c2() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c3() : at32f413_acc.h, at32f413_acc.c
  • ADC1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_SOFTWARE : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH2 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH3 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR2CH2 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR3TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR4CH4 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR8CH1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR8CH2 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_SOFTWARE : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR2CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR2TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR3CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR4TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR8CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR8TRGOUT : at32f413_adc.h
  • ADC1_2_IRQHandler() : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c
  • ADC1_2_IRQn : at32f413.h
  • ADC1_BASE : at32f413.h
  • ADC1_ETO_GMUX : at32f413_gpio.h
  • ADC1_ETO_MUX : at32f413_gpio.h
  • ADC1_ETP_GMUX : at32f413_gpio.h
  • ADC1_ETP_MUX : at32f413_gpio.h
  • adc1_ordinary_value : project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • adc1_ordinary_valuetab : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • adc1_preempt_valuetab : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • ADC2 : at32f413_adc.h
  • ADC2_BASE : at32f413.h
  • ADC2_ETO_GMUX : at32f413_gpio.h
  • ADC2_ETO_MUX : at32f413_gpio.h
  • ADC2_ETP_GMUX : at32f413_gpio.h
  • ADC2_ETP_MUX : at32f413_gpio.h
  • adc_base_config() : at32f413_adc.h, at32f413_adc.c
  • adc_base_default_para_init() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_init() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_init_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_start() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_status_get() : at32f413_adc.h, at32f413_adc.c
  • ADC_CCE_FLAG : at32f413_adc.h
  • ADC_CCE_INT : at32f413_adc.h
  • ADC_CHANNEL_0 : at32f413_adc.h
  • ADC_CHANNEL_1 : at32f413_adc.h
  • ADC_CHANNEL_10 : at32f413_adc.h
  • ADC_CHANNEL_11 : at32f413_adc.h
  • ADC_CHANNEL_12 : at32f413_adc.h
  • ADC_CHANNEL_13 : at32f413_adc.h
  • ADC_CHANNEL_14 : at32f413_adc.h
  • ADC_CHANNEL_15 : at32f413_adc.h
  • ADC_CHANNEL_16 : at32f413_adc.h
  • ADC_CHANNEL_17 : at32f413_adc.h
  • ADC_CHANNEL_2 : at32f413_adc.h
  • ADC_CHANNEL_3 : at32f413_adc.h
  • ADC_CHANNEL_4 : at32f413_adc.h
  • ADC_CHANNEL_5 : at32f413_adc.h
  • ADC_CHANNEL_6 : at32f413_adc.h
  • ADC_CHANNEL_7 : at32f413_adc.h
  • ADC_CHANNEL_8 : at32f413_adc.h
  • ADC_CHANNEL_9 : at32f413_adc.h
  • adc_channel_select_type : at32f413_adc.h
  • adc_combine_mode_select() : at32f413_adc.h, at32f413_adc.c
  • adc_combine_mode_type : at32f413_adc.h
  • adc_combine_ordinary_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • adc_data_align_type : at32f413_adc.h
  • adc_dma_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_flag_clear() : at32f413_adc.h, at32f413_adc.c
  • adc_flag_get() : at32f413_adc.h, at32f413_adc.c
  • ADC_INDEPENDENT_MODE : at32f413_adc.h
  • adc_interrupt_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_LEFT_ALIGNMENT : at32f413_adc.h
  • ADC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • ADC_OCCS_FLAG : at32f413_adc.h
  • adc_ordinary_channel_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_conversion_trigger_set() : at32f413_adc.h, at32f413_adc.c
  • ADC_ORDINARY_LONGSHIFT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • adc_ordinary_part_count_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_part_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_ORDINARY_SHORTSHIFT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • adc_ordinary_software_trigger_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_software_trigger_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_trig_select_type : at32f413_adc.h
  • ADC_PCCE_FLAG : at32f413_adc.h
  • ADC_PCCE_INT : at32f413_adc.h
  • ADC_PCCS_FLAG : at32f413_adc.h
  • adc_preempt_auto_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_PREEMPT_CHANNEL_1 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_2 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_3 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_4 : at32f413_adc.h
  • adc_preempt_channel_length_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_channel_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_channel_type : at32f413_adc.h
  • adc_preempt_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_conversion_trigger_set() : at32f413_adc.h, at32f413_adc.c
  • ADC_PREEMPT_INTERLTRIG_ONLY_MODE : at32f413_adc.h
  • adc_preempt_offset_value_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_part_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_PREEMPT_SMLT_ONLY_MODE : at32f413_adc.h
  • adc_preempt_software_trigger_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_software_trigger_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_trig_select_type : at32f413_adc.h
  • adc_reset() : at32f413_adc.h, at32f413_adc.c
  • ADC_RIGHT_ALIGNMENT : at32f413_adc.h
  • ADC_SAMPLETIME_13_5 : at32f413_adc.h
  • ADC_SAMPLETIME_1_5 : at32f413_adc.h
  • ADC_SAMPLETIME_239_5 : at32f413_adc.h
  • ADC_SAMPLETIME_28_5 : at32f413_adc.h
  • ADC_SAMPLETIME_41_5 : at32f413_adc.h
  • ADC_SAMPLETIME_55_5 : at32f413_adc.h
  • ADC_SAMPLETIME_71_5 : at32f413_adc.h
  • ADC_SAMPLETIME_7_5 : at32f413_adc.h
  • adc_sampletime_select_type : at32f413_adc.h
  • ADC_TEMP_BASE : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_TEMP_SLOPE : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • adc_tempersensor_vintrv_enable() : at32f413_adc.h, at32f413_adc.c
  • ADC_VMONITOR_ALL_ORDINARY : at32f413_adc.h
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_ALL_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_NONE : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_PREEMPT : at32f413_adc.h
  • ADC_VMOR_FLAG : at32f413_adc.h
  • ADC_VMOR_INT : at32f413_adc.h
  • adc_voltage_monitor_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_single_channel_select() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_threshold_value_set() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitoring_type : at32f413_adc.h
  • ADC_VREF : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADDRESS_OUT_OF_RANGE : cdc_msc_class.h, msc_bot_scsi.h
  • AHBPERIPH_BASE : at32f413.h
  • AIRCR_VECTKEY_MASK : at32f413_misc.c
  • alarm_init() : project/at_start_f413/examples/rtc/calendar/src/main.c
  • ALIGNED_TAIL : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, composite_cdc_msc/msc_bot_scsi.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc/msc_bot_scsi.c, msc_desc.c, printer_class.c, printer_desc.c
  • APB1PERIPH_BASE : at32f413.h
  • APB2PERIPH_BASE : at32f413.h
  • app_load() : bootloader/inc/iap.h, bootloader/src/iap.c
  • app_loop() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c
  • APP_START_ADDR : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • app_update_handle() : bootloader/src/iap.c
  • arm_apply_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_2pow() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_clip_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_fir_f32() : project_l0/inc/fir_filter.h, project_l1/inc/fir_filter.h
  • arm_fir_init_f32() : project_l0/inc/fir_filter.h, arm_fir_init_f32.c, project_l1/inc/fir_filter.h
  • arm_float_to_q12_20() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q14() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q28() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q29() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q30() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q7() : project_l0/src/math_helper.c, project_l1/src/math_helper.c
  • arm_snr_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • AT32_AUDIO_FREQ_16K : audio_desc.h, audio_hid_desc.h
  • AT32_AUDIO_FREQ_48K : audio_desc.h, audio_hid_desc.h
  • at32_board_init() : at32f413_board.c, at32f413_board.h
  • at32_button_init() : at32f413_board.c, at32f413_board.h
  • at32_button_press() : at32f413_board.c, at32f413_board.h
  • at32_button_state() : at32f413_board.c, at32f413_board.h
  • at32_led_init() : at32f413_board.c, at32f413_board.h
  • at32_led_off() : at32f413_board.c, at32f413_board.h
  • at32_led_on() : at32f413_board.c, at32f413_board.h
  • at32_led_toggle() : at32f413_board.c, at32f413_board.h
  • atr_decode_status : project/at_start_f413/examples/usart/smartcard/src/main.c
  • AUDIO_AC_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_EXTENSION_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_FEATURE_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_HEADER : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_INPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_MIXER_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_OUTPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_PROCESSING_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_SELECTOR_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_SPECIFIC : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_TYPE : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_GENERAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_BCD_NUM : audio_desc.h
  • AUDIO_BINTERVAL_TIME : audio_desc.h
  • AUDIO_BITW_16 : audio/audio_conf.h, audio_hid/audio_conf.h
  • audio_class_handler : audio_class.c, audio_class.h
  • audio_codec : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • audio_codec_init() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_loop() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_alt_setting() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_get_data() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_modify_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_mute() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_volume() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_mute() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_volume() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_alt_setting() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_feedback() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_fifo_write() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • AUDIO_CS_CONFIGURATION : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_DEVICE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_ENDPOINT : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_STRING : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_DEFAULT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • audio_desc_handler : audio_desc.c, audio_desc.h
  • AUDIO_DESCRIPTOR_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_DESCRIPTOR_TYPE : audio_class.h, audio_hid_class.h
  • AUDIO_FEATURE_UNIT_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_FEEDBACK_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_FORMAT_TYPE_I : audio_desc.h, audio_hid_desc.h
  • AUDIO_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_SET_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_FU_BASS_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_CONTROL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MID_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MUTE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_TREBLE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_VOLUME_CONTROL : audio_desc.h, audio_hid_desc.h
  • audio_get_interface() : audio_class.c, audio_hid_class.c
  • audio_hid_class_handler : audio_hid_class.c, audio_hid_class.h
  • audio_hid_class_send_report() : audio_hid_class.c, audio_hid_class.h
  • audio_hid_desc_handler : audio_hid_desc.c, audio_hid_desc.h
  • audio_hid_struct : audio_hid_class.c
  • AUDIO_INPUT_TERMINAL_MICROPHONE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_LEN : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_NUM : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_IN_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_MIC_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MUTE_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_OUTPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_SPEAKER : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_PROTOCOL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_REMAIN_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_ENDPOINT : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_INTERFACE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_MASK : audio_class.h, audio_hid_class.h
  • audio_req_get_cur() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_CUR : audio_desc.h, audio_hid_desc.h
  • audio_req_get_max() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MEM : audio_desc.h, audio_hid_desc.h
  • audio_req_get_min() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_RES : audio_desc.h, audio_hid_desc.h
  • audio_req_get_res() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_GET_STAT : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_CUR : audio_desc.h, audio_hid_desc.h
  • audio_req_set_cur() : audio_class.c, audio_hid_class.c
  • AUDIO_REQ_SET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_RES : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQUEST_CODE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • audio_set_interface() : audio_class.c, audio_hid_class.c
  • AUDIO_SPK_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_OUT_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_SPK_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • audio_struct : audio_class.c
  • AUDIO_SUBCLASS_AUDIOCONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_AUDIOSTREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_MIDISTREMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUPPORT_FEEDBACK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MAX_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MIC : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_SPK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_TERMINAL_TYPE_STREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_VENDOR : audio_desc.h, audio_hid_desc.h
  • AUDIO_VOLUME_CONTROL : audio_class.h, audio_hid_class.h
  • AUHID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BINTERVAL_TIME : audio_hid_desc.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- b -

  • back_err() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/iap.h, bootloader/src/iap.c
  • back_ok() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/iap.h, bootloader/src/iap.c
  • BLK2 : at32f413_usb.h
  • BLK32 : at32f413_usb.h
  • BLOCK_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, fir_filter.c
  • BLOCKS_NUMBER : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • bot_cbw_decode() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_allow_medium_removal() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_check_address() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_clear_feature() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_cmd_process() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_datain_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_dataout_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_format_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_init() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_inquiry() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense6() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_read10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_request_sense() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_reset() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_csw() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_data() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_sense_code() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_stall() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_start_stop() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_test_unit() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_verify() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_write10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • BPR : at32f413_bpr.h
  • bpr_addr_tab : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • BPR_BASE : at32f413.h
  • BPR_DATA1 : at32f413_bpr.h
  • BPR_DATA10 : at32f413_bpr.h
  • BPR_DATA11 : at32f413_bpr.h
  • BPR_DATA12 : at32f413_bpr.h
  • BPR_DATA13 : at32f413_bpr.h
  • BPR_DATA14 : at32f413_bpr.h
  • BPR_DATA15 : at32f413_bpr.h
  • BPR_DATA16 : at32f413_bpr.h
  • BPR_DATA17 : at32f413_bpr.h
  • BPR_DATA18 : at32f413_bpr.h
  • BPR_DATA19 : at32f413_bpr.h
  • BPR_DATA2 : at32f413_bpr.h
  • BPR_DATA20 : at32f413_bpr.h
  • BPR_DATA21 : at32f413_bpr.h
  • BPR_DATA22 : at32f413_bpr.h
  • BPR_DATA23 : at32f413_bpr.h
  • BPR_DATA24 : at32f413_bpr.h
  • BPR_DATA25 : at32f413_bpr.h
  • BPR_DATA26 : at32f413_bpr.h
  • BPR_DATA27 : at32f413_bpr.h
  • BPR_DATA28 : at32f413_bpr.h
  • BPR_DATA29 : at32f413_bpr.h
  • BPR_DATA3 : at32f413_bpr.h
  • BPR_DATA30 : at32f413_bpr.h
  • BPR_DATA31 : at32f413_bpr.h
  • BPR_DATA32 : at32f413_bpr.h
  • BPR_DATA33 : at32f413_bpr.h
  • BPR_DATA34 : at32f413_bpr.h
  • BPR_DATA35 : at32f413_bpr.h
  • BPR_DATA36 : at32f413_bpr.h
  • BPR_DATA37 : at32f413_bpr.h
  • BPR_DATA38 : at32f413_bpr.h
  • BPR_DATA39 : at32f413_bpr.h
  • BPR_DATA4 : at32f413_bpr.h
  • BPR_DATA40 : at32f413_bpr.h
  • BPR_DATA41 : at32f413_bpr.h
  • BPR_DATA42 : at32f413_bpr.h
  • BPR_DATA5 : at32f413_bpr.h
  • BPR_DATA6 : at32f413_bpr.h
  • BPR_DATA7 : at32f413_bpr.h
  • BPR_DATA8 : at32f413_bpr.h
  • BPR_DATA9 : at32f413_bpr.h
  • bpr_data_read() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_data_type : at32f413_bpr.h
  • bpr_data_write() : at32f413_bpr.h, at32f413_bpr.c
  • BPR_DR_NUMBER : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_flag_clear() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_flag_get() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_interrupt_enable() : at32f413_bpr.h, at32f413_bpr.c
  • BPR_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • bpr_reg_check() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reg_judge() : project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reg_write() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reset() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_rtc_clock_calibration_value_set() : at32f413_bpr.h, at32f413_bpr.c
  • BPR_RTC_OUTPUT_ALARM : at32f413_bpr.h
  • BPR_RTC_OUTPUT_ALARM_TOGGLE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_CLOCK_CAL_AFTER : at32f413_bpr.h
  • BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_NONE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_SECOND : at32f413_bpr.h
  • BPR_RTC_OUTPUT_SECOND_TOGGLE : at32f413_bpr.h
  • bpr_rtc_output_select() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_rtc_output_type : at32f413_bpr.h
  • BPR_TAMPER_EVENT_FLAG : at32f413_bpr.h
  • BPR_TAMPER_INTERRUPT_FLAG : at32f413_bpr.h
  • BPR_TAMPER_PIN_ACTIVE_HIGH : at32f413_bpr.h
  • bpr_tamper_pin_active_level_set() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_tamper_pin_active_level_type : at32f413_bpr.h
  • BPR_TAMPER_PIN_ACTIVE_LOW : at32f413_bpr.h
  • bpr_tamper_pin_enable() : at32f413_bpr.h, at32f413_bpr.c
  • BUF_SIZE : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • buffer : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • buffer_ch1 : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • buffer_ch2 : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • buffer_compare() : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/flash/flash_write_read/src/main.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • buffer_compare_24bits() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c
  • buffer_read : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • BUFFER_SIZE : project/at_start_f413/examples/crc/calculation/src/main.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • buffer_write : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • BUFFERSIZE : project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • BusFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • BusFault_IRQn : at32f413.h
  • button_exint_init() : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/templates/src/main.c
  • button_isr() : project/at_start_f413/templates/src/main.c
  • BUTTON_RELEASE : mouse_class.h
  • button_type : at32f413_board.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • calendar : rtc.h, rtc.c
  • CAN1 : at32f413_can.h
  • CAN1_BASE : at32f413.h
  • CAN1_GMUX_0010 : at32f413_gpio.h
  • CAN1_RX1_IRQn : at32f413.h
  • CAN1_SE_IRQHandler() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • CAN1_SE_IRQn : at32f413.h
  • CAN2 : at32f413_can.h
  • CAN2_BASE : at32f413.h
  • CAN2_GMUX_0001 : at32f413_gpio.h
  • CAN2_RX0_IRQn : at32f413.h
  • CAN2_RX1_IRQn : at32f413.h
  • CAN2_SE_IRQn : at32f413.h
  • CAN2_TX_IRQn : at32f413.h
  • can_base_init() : at32f413_can.h, at32f413_can.c
  • can_baudrate_default_para_init() : at32f413_can.h, at32f413_can.c
  • can_baudrate_set() : at32f413_can.h, at32f413_can.c
  • CAN_BOF_FLAG : at32f413_can.h
  • CAN_BOIEN_INT : at32f413_can.h
  • CAN_BTS1_10TQ : at32f413_can.h
  • CAN_BTS1_11TQ : at32f413_can.h
  • CAN_BTS1_12TQ : at32f413_can.h
  • CAN_BTS1_13TQ : at32f413_can.h
  • CAN_BTS1_14TQ : at32f413_can.h
  • CAN_BTS1_15TQ : at32f413_can.h
  • CAN_BTS1_16TQ : at32f413_can.h
  • CAN_BTS1_1TQ : at32f413_can.h
  • CAN_BTS1_2TQ : at32f413_can.h
  • CAN_BTS1_3TQ : at32f413_can.h
  • CAN_BTS1_4TQ : at32f413_can.h
  • CAN_BTS1_5TQ : at32f413_can.h
  • CAN_BTS1_6TQ : at32f413_can.h
  • CAN_BTS1_7TQ : at32f413_can.h
  • CAN_BTS1_8TQ : at32f413_can.h
  • CAN_BTS1_9TQ : at32f413_can.h
  • can_bts1_type : at32f413_can.h
  • CAN_BTS2_1TQ : at32f413_can.h
  • CAN_BTS2_2TQ : at32f413_can.h
  • CAN_BTS2_3TQ : at32f413_can.h
  • CAN_BTS2_4TQ : at32f413_can.h
  • CAN_BTS2_5TQ : at32f413_can.h
  • CAN_BTS2_6TQ : at32f413_can.h
  • CAN_BTS2_7TQ : at32f413_can.h
  • CAN_BTS2_8TQ : at32f413_can.h
  • can_bts2_type : at32f413_can.h
  • can_configuration() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_debug_transmission_prohibit() : at32f413_can.h, at32f413_can.c
  • can_default_para_init() : at32f413_can.h, at32f413_can.c
  • CAN_DISCARDING_FIRST_RECEIVED : at32f413_can.h
  • CAN_DISCARDING_LAST_RECEIVED : at32f413_can.h
  • can_doze_mode_enter() : at32f413_can.h, at32f413_can.c
  • can_doze_mode_exit() : at32f413_can.h, at32f413_can.c
  • CAN_EAF_FLAG : at32f413_can.h
  • CAN_EAIEN_INT : at32f413_can.h
  • CAN_EDZC_FLAG : at32f413_can.h
  • CAN_EDZIEN_INT : at32f413_can.h
  • CAN_ENTER_DOZE_FAILED : at32f413_can.h
  • can_enter_doze_status_type : at32f413_can.h
  • CAN_ENTER_DOZE_SUCCESSFUL : at32f413_can.h
  • CAN_EOIEN_INT : at32f413_can.h
  • CAN_EOIF_FLAG : at32f413_can.h
  • CAN_EPF_FLAG : at32f413_can.h
  • CAN_EPIEN_INT : at32f413_can.h
  • can_error_record_type : at32f413_can.h
  • can_error_type_record_get() : at32f413_can.h, at32f413_can.c
  • CAN_ERRORRECORD_ACKERR : at32f413_can.h
  • CAN_ERRORRECORD_BITDOMINANTERR : at32f413_can.h
  • CAN_ERRORRECORD_BITRECESSIVEERR : at32f413_can.h
  • CAN_ERRORRECORD_CRCERR : at32f413_can.h
  • CAN_ERRORRECORD_FORMERR : at32f413_can.h
  • CAN_ERRORRECORD_NOERR : at32f413_can.h
  • CAN_ERRORRECORD_SOFTWARESETERR : at32f413_can.h
  • CAN_ERRORRECORD_STUFFERR : at32f413_can.h
  • CAN_ETR_FLAG : at32f413_can.h
  • CAN_ETRIEN_INT : at32f413_can.h
  • CAN_FILTER_16BIT : at32f413_can.h
  • CAN_FILTER_32BIT : at32f413_can.h
  • can_filter_bit_width_type : at32f413_can.h
  • can_filter_default_para_init() : at32f413_can.h, at32f413_can.c
  • CAN_FILTER_FIFO0 : at32f413_can.h
  • CAN_FILTER_FIFO1 : at32f413_can.h
  • can_filter_fifo_type : at32f413_can.h
  • can_filter_init() : at32f413_can.h, at32f413_can.c
  • CAN_FILTER_MODE_ID_LIST : at32f413_can.h
  • CAN_FILTER_MODE_ID_MASK : at32f413_can.h
  • can_filter_mode_type : at32f413_can.h
  • can_flag_clear() : at32f413_can.h, at32f413_can.c
  • can_flag_get() : at32f413_can.h, at32f413_can.c
  • can_gpio_config() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • CAN_ID_EXTENDED : at32f413_can.h
  • CAN_ID_STANDARD : at32f413_can.h
  • can_identifier_type : at32f413_can.h
  • can_interrupt_enable() : at32f413_can.h, at32f413_can.c
  • can_message_receive() : at32f413_can.h, at32f413_can.c
  • can_message_transmit() : at32f413_can.h, at32f413_can.c
  • CAN_MODE_COMMUNICATE : at32f413_can.h
  • CAN_MODE_LISTENONLY : at32f413_can.h
  • CAN_MODE_LISTENONLY_LOOPBACK : at32f413_can.h
  • CAN_MODE_LOOPBACK : at32f413_can.h
  • can_mode_type : at32f413_can.h
  • CAN_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • can_msg_discarding_rule_type : at32f413_can.h
  • can_msg_sending_rule_type : at32f413_can.h
  • CAN_MSTS_EDZIF_VAL : at32f413_can.h
  • CAN_MSTS_EOIF_VAL : at32f413_can.h
  • CAN_MSTS_QDZIF_VAL : at32f413_can.h
  • CAN_MUX_10 : at32f413_gpio.h
  • can_operating_mode_set() : at32f413_can.h, at32f413_can.c
  • can_operating_mode_type : at32f413_can.h
  • CAN_OPERATINGMODE_COMMUNICATE : at32f413_can.h
  • CAN_OPERATINGMODE_DOZE : at32f413_can.h
  • CAN_OPERATINGMODE_FREEZE : at32f413_can.h
  • CAN_QDZIEN_INT : at32f413_can.h
  • CAN_QDZIF_FLAG : at32f413_can.h
  • CAN_QUIT_DOZE_FAILED : at32f413_can.h
  • can_quit_doze_status_type : at32f413_can.h
  • CAN_QUIT_DOZE_SUCCESSFUL : at32f413_can.h
  • can_receive_error_counter_get() : at32f413_can.h, at32f413_can.c
  • can_receive_fifo_release() : at32f413_can.h, at32f413_can.c
  • can_receive_message_pending_get() : at32f413_can.h, at32f413_can.c
  • can_reset() : at32f413_can.h, at32f413_can.c
  • CAN_RF0_RF0FF_VAL : at32f413_can.h
  • CAN_RF0_RF0OF_VAL : at32f413_can.h
  • CAN_RF0_RF0R_VAL : at32f413_can.h
  • CAN_RF0FF_FLAG : at32f413_can.h
  • CAN_RF0FIEN_INT : at32f413_can.h
  • CAN_RF0MIEN_INT : at32f413_can.h
  • CAN_RF0MN_FLAG : at32f413_can.h
  • CAN_RF0OF_FLAG : at32f413_can.h
  • CAN_RF0OIEN_INT : at32f413_can.h
  • CAN_RF1_RF1FF_VAL : at32f413_can.h
  • CAN_RF1_RF1OF_VAL : at32f413_can.h
  • CAN_RF1_RF1R_VAL : at32f413_can.h
  • CAN_RF1FF_FLAG : at32f413_can.h
  • CAN_RF1FIEN_INT : at32f413_can.h
  • CAN_RF1MIEN_INT : at32f413_can.h
  • CAN_RF1MN_FLAG : at32f413_can.h
  • CAN_RF1OF_FLAG : at32f413_can.h
  • CAN_RF1OIEN_INT : at32f413_can.h
  • CAN_RSAW_1TQ : at32f413_can.h
  • CAN_RSAW_2TQ : at32f413_can.h
  • CAN_RSAW_3TQ : at32f413_can.h
  • CAN_RSAW_4TQ : at32f413_can.h
  • can_rsaw_type : at32f413_can.h
  • CAN_RX_FIFO0 : at32f413_can.h
  • CAN_RX_FIFO1 : at32f413_can.h
  • can_rx_fifo_num_type : at32f413_can.h
  • CAN_SENDING_BY_ID : at32f413_can.h
  • CAN_SENDING_BY_REQUEST : at32f413_can.h
  • CAN_TCIEN_INT : at32f413_can.h
  • CAN_TFT_DATA : at32f413_can.h
  • CAN_TFT_REMOTE : at32f413_can.h
  • CAN_TM0TCF_FLAG : at32f413_can.h
  • CAN_TM1TCF_FLAG : at32f413_can.h
  • CAN_TM2TCF_FLAG : at32f413_can.h
  • CAN_TMEF_FLAG : at32f413_can.h
  • can_trans_frame_type : at32f413_can.h
  • can_transmit_cancel() : at32f413_can.h, at32f413_can.c
  • can_transmit_data() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_transmit_error_counter_get() : at32f413_can.h, at32f413_can.c
  • can_transmit_status_get() : at32f413_can.h, at32f413_can.c
  • can_transmit_status_type : at32f413_can.h
  • CAN_TSTS_TM0CT_VAL : at32f413_can.h
  • CAN_TSTS_TM0TCF_VAL : at32f413_can.h
  • CAN_TSTS_TM1CT_VAL : at32f413_can.h
  • CAN_TSTS_TM1TCF_VAL : at32f413_can.h
  • CAN_TSTS_TM2CT_VAL : at32f413_can.h
  • CAN_TSTS_TM2TCF_VAL : at32f413_can.h
  • can_ttc_mode_enable() : at32f413_can.h, at32f413_can.c
  • CAN_TX_MAILBOX0 : at32f413_can.h
  • CAN_TX_MAILBOX1 : at32f413_can.h
  • CAN_TX_MAILBOX2 : at32f413_can.h
  • can_tx_mailbox_num_type : at32f413_can.h
  • CAN_TX_STATUS_FAILED : at32f413_can.h
  • CAN_TX_STATUS_NO_EMPTY : at32f413_can.h
  • CAN_TX_STATUS_PENDING : at32f413_can.h
  • CAN_TX_STATUS_SUCCESSFUL : at32f413_can.h
  • capture : project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
  • capturenumber : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • card_inserted : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • card_protocol : project/at_start_f413/examples/usart/smartcard/src/main.c
  • card_type : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • CBW_BMCBWFLAGS_DIR_IN : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_BMCBWFLAGS_DIR_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_DCBWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CDC_BCD_NUM : cdc_desc.h, cdc_msc_desc.h
  • cdc_class_handler : cdc_class.c, cdc_class.h
  • cdc_class_setup_handler() : cdc_keyboard_class.c, cdc_msc_class.c
  • cdc_desc_handler : cdc_desc.c, cdc_desc.h
  • CDC_HID_BINTERVAL_TIME : cdc_desc.h, cdc_msc_desc.h
  • cdc_keyboard_class_handler : cdc_keyboard_class.c, cdc_keyboard_class.h
  • cdc_keyboard_desc_handler : cdc_keyboard_desc.c, cdc_keyboard_desc.h
  • cdc_msc_class_handler : cdc_msc_class.c, cdc_msc_class.h
  • cdc_msc_desc_handler : cdc_msc_desc.c, cdc_msc_desc.h
  • cdc_msc_struct : cdc_msc_class.c
  • cdc_struct : cdc_class.c
  • cdc_struct_init() : cdc_class.c, cdc_msc_class.c
  • ch1_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch2_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch3_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch3readvalue1 : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • ch3readvalue2 : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • ch4_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • channel1_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel2_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel3_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel4_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c
  • check_card_programming() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • cid_table : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • class_audio_setup_handler() : audio_hid_class.c
  • class_clear_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_rx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_tx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_event_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_hid_setup_handler() : audio_hid_class.c
  • class_in_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_init_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_out_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_setup_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_sof_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • clkout_config() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c, project/at_start_f413/examples/crm/sysclk_switch/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • clock_failure_detection_handler() : project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
  • cmd_addr_cnt : bootloader/src/iap.c
  • CMD_CTR_APP : bootloader/inc/iap.h
  • CMD_CTR_DONE : bootloader/inc/iap.h
  • CMD_CTR_ERR : bootloader/inc/iap.h
  • CMD_CTR_IDLE : bootloader/inc/iap.h
  • CMD_CTR_INIT : bootloader/inc/iap.h
  • cmd_ctr_step : bootloader/inc/iap.h, bootloader/src/iap.c
  • cmd_ctr_step_type : bootloader/inc/iap.h
  • CMD_DATA_ADDR : bootloader/inc/iap.h
  • CMD_DATA_BUF : bootloader/inc/iap.h
  • CMD_DATA_CHACK : bootloader/inc/iap.h
  • cmd_data_cnt : bootloader/src/iap.c
  • CMD_DATA_DONE : bootloader/inc/iap.h
  • CMD_DATA_ERR : bootloader/inc/iap.h
  • cmd_data_group_struct : bootloader/src/iap.c
  • cmd_data_group_type_struct : bootloader/inc/iap.h
  • CMD_DATA_IDLE : bootloader/inc/iap.h
  • cmd_data_step : bootloader/inc/iap.h, bootloader/src/iap.c
  • cmd_data_step_type : bootloader/inc/iap.h
  • codec_i2s_init() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • codec_i2s_reset() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • command_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_handle() : bootloader/inc/iap.h, bootloader/src/iap.c
  • command_rsp1_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp2_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp3_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp4_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp5_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp6_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp7_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • config_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • config_flash_interrupt() : utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • configASSERT : FreeRTOSConfig.h
  • configCPU_CLOCK_HZ : FreeRTOSConfig.h
  • configIDLE_SHOULD_YIELD : FreeRTOSConfig.h
  • configKERNEL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_LOWEST_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_CO_ROUTINE_PRIORITIES : FreeRTOSConfig.h
  • configMAX_PRIORITIES : FreeRTOSConfig.h
  • configMAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_TASK_NAME_LEN : FreeRTOSConfig.h
  • configMINIMAL_STACK_SIZE : FreeRTOSConfig.h
  • configPRIO_BITS : FreeRTOSConfig.h
  • configSUPPORT_DYNAMIC_ALLOCATION : FreeRTOSConfig.h
  • configTICK_RATE_HZ : FreeRTOSConfig.h
  • configTOTAL_HEAP_SIZE : FreeRTOSConfig.h
  • configUSE_16_BIT_TICKS : FreeRTOSConfig.h
  • configUSE_CO_ROUTINES : FreeRTOSConfig.h
  • configUSE_IDLE_HOOK : FreeRTOSConfig.h
  • configUSE_PREEMPTION : FreeRTOSConfig.h
  • configUSE_TICK_HOOK : FreeRTOSConfig.h
  • confirm_state : at32f413.h
  • CONVERT_ENDIAN : hid_iap_class.h
  • convert_from_bytes_to_power_of_two() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • copy_buff() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • counter : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • COUNTOF : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • CRC : at32f413_crc.h
  • crc1_value : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
  • crc2_value : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
  • CRC_BASE : at32f413.h
  • crc_block_calculate() : at32f413_crc.h, at32f413_crc.c
  • crc_cal() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • crc_common_data_set() : at32f413_crc.h, at32f413_crc.c
  • crc_common_date_get() : at32f413_crc.h, at32f413_crc.c
  • crc_data_get() : at32f413_crc.h, at32f413_crc.c
  • crc_data_reset() : at32f413_crc.h, at32f413_crc.c
  • crc_init_data_set() : at32f413_crc.h, at32f413_crc.c
  • CRC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • crc_one_word_calculate() : at32f413_crc.h, at32f413_crc.c
  • CRC_REVERSE_INPUT_BY_BYTE : at32f413_crc.h
  • CRC_REVERSE_INPUT_BY_HALFWORD : at32f413_crc.h
  • CRC_REVERSE_INPUT_BY_WORD : at32f413_crc.h
  • crc_reverse_input_data_set() : at32f413_crc.h, at32f413_crc.c
  • CRC_REVERSE_INPUT_NO_AFFECTE : at32f413_crc.h
  • crc_reverse_input_type : at32f413_crc.h
  • CRC_REVERSE_OUTPUT_DATA : at32f413_crc.h
  • crc_reverse_output_data_set() : at32f413_crc.h, at32f413_crc.c
  • CRC_REVERSE_OUTPUT_NO_AFFECTE : at32f413_crc.h
  • crc_reverse_output_type : at32f413_crc.h
  • crc_value : project/at_start_f413/examples/crc/calculation/src/main.c
  • CRM : at32f413_crm.h
  • CRM_ACC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ACC_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ADC1_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ADC2_PERIPH_RESET : at32f413_crm.h
  • crm_adc_clock_div_set() : at32f413_crm.h, at32f413_crm.c
  • CRM_ADC_DIV_12 : at32f413_crm.h
  • CRM_ADC_DIV_16 : at32f413_crm.h
  • CRM_ADC_DIV_2 : at32f413_crm.h
  • CRM_ADC_DIV_4 : at32f413_crm.h
  • CRM_ADC_DIV_6 : at32f413_crm.h
  • CRM_ADC_DIV_8 : at32f413_crm.h
  • crm_adc_div_type : at32f413_crm.h
  • CRM_AHB_DIV_1 : at32f413_crm.h
  • CRM_AHB_DIV_128 : at32f413_crm.h
  • CRM_AHB_DIV_16 : at32f413_crm.h
  • CRM_AHB_DIV_2 : at32f413_crm.h
  • CRM_AHB_DIV_256 : at32f413_crm.h
  • CRM_AHB_DIV_4 : at32f413_crm.h
  • CRM_AHB_DIV_512 : at32f413_crm.h
  • CRM_AHB_DIV_64 : at32f413_crm.h
  • CRM_AHB_DIV_8 : at32f413_crm.h
  • crm_ahb_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_ahb_div_type : at32f413_crm.h
  • CRM_ALL_RESET_FLAG : at32f413_crm.h
  • CRM_APB1_DIV_1 : at32f413_crm.h
  • CRM_APB1_DIV_16 : at32f413_crm.h
  • CRM_APB1_DIV_2 : at32f413_crm.h
  • CRM_APB1_DIV_4 : at32f413_crm.h
  • CRM_APB1_DIV_8 : at32f413_crm.h
  • crm_apb1_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_apb1_div_type : at32f413_crm.h
  • CRM_APB2_DIV_1 : at32f413_crm.h
  • CRM_APB2_DIV_16 : at32f413_crm.h
  • CRM_APB2_DIV_2 : at32f413_crm.h
  • CRM_APB2_DIV_4 : at32f413_crm.h
  • CRM_APB2_DIV_8 : at32f413_crm.h
  • crm_apb2_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_apb2_div_type : at32f413_crm.h
  • CRM_AUTO_STEP_MODE_DISABLE : at32f413_crm.h
  • crm_auto_step_mode_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_AUTO_STEP_MODE_ENABLE : at32f413_crm.h
  • crm_auto_step_mode_type : at32f413_crm.h
  • CRM_BASE : at32f413.h
  • crm_battery_powered_domain_reset() : at32f413_crm.h, at32f413_crm.c
  • CRM_BPR_PERIPH_CLOCK : at32f413_crm.h
  • CRM_BPR_PERIPH_RESET : at32f413_crm.h
  • CRM_CAN1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_CAN1_PERIPH_RESET : at32f413_crm.h
  • CRM_CAN2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_CAN2_PERIPH_RESET : at32f413_crm.h
  • CRM_CLKOUT_ADC : at32f413_crm.h
  • CRM_CLKOUT_DIV_1 : at32f413_crm.h
  • CRM_CLKOUT_DIV_128 : at32f413_crm.h
  • CRM_CLKOUT_DIV_16 : at32f413_crm.h
  • CRM_CLKOUT_DIV_2 : at32f413_crm.h
  • CRM_CLKOUT_DIV_256 : at32f413_crm.h
  • CRM_CLKOUT_DIV_4 : at32f413_crm.h
  • CRM_CLKOUT_DIV_512 : at32f413_crm.h
  • CRM_CLKOUT_DIV_64 : at32f413_crm.h
  • CRM_CLKOUT_DIV_8 : at32f413_crm.h
  • crm_clkout_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_clkout_div_type : at32f413_crm.h
  • CRM_CLKOUT_HEXT : at32f413_crm.h
  • CRM_CLKOUT_HICK : at32f413_crm.h
  • CRM_CLKOUT_LEXT : at32f413_crm.h
  • CRM_CLKOUT_LICK : at32f413_crm.h
  • CRM_CLKOUT_NOCLK : at32f413_crm.h
  • CRM_CLKOUT_PLL_DIV_2 : at32f413_crm.h
  • CRM_CLKOUT_PLL_DIV_4 : at32f413_crm.h
  • CRM_CLKOUT_SCLK : at32f413_crm.h
  • crm_clkout_select_type : at32f413_crm.h
  • crm_clkout_to_tmr10_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_CLKOUT_USB : at32f413_crm.h
  • crm_clock_failure_detection_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_CLOCK_FAILURE_INT : at32f413_crm.h
  • CRM_CLOCK_FAILURE_INT_FLAG : at32f413_crm.h
  • crm_clock_out_set() : at32f413_crm.h, at32f413_crm.c
  • crm_clock_source_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_CLOCK_SOURCE_HEXT : at32f413_crm.h
  • CRM_CLOCK_SOURCE_HICK : at32f413_crm.h
  • CRM_CLOCK_SOURCE_LEXT : at32f413_crm.h
  • CRM_CLOCK_SOURCE_LICK : at32f413_crm.h
  • CRM_CLOCK_SOURCE_PLL : at32f413_crm.h
  • crm_clock_source_type : at32f413_crm.h
  • crm_clocks : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • crm_clocks_freq_get() : at32f413_crm.h, at32f413_crm.c
  • crm_clocks_freq_struct : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • crm_configuration() : project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • CRM_CRC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_DMA1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_DMA2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_EXINT_PERIPH_RESET : at32f413_crm.h
  • crm_flag_clear() : at32f413_crm.h, at32f413_crm.c
  • crm_flag_get() : at32f413_crm.h, at32f413_crm.c
  • CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE : at32f413_crm.h
  • CRM_GPIOA_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOA_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOB_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOB_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOC_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOD_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOD_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOF_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOF_PERIPH_RESET : at32f413_crm.h
  • crm_hext_bypass() : at32f413_crm.h, at32f413_crm.c
  • CRM_HEXT_READY_INT_FLAG : at32f413_crm.h
  • CRM_HEXT_STABLE_FLAG : at32f413_crm.h
  • CRM_HEXT_STABLE_INT : at32f413_crm.h
  • crm_hext_stable_wait() : at32f413_crm.h, at32f413_crm.c
  • CRM_HICK48_DIV6 : at32f413_crm.h
  • CRM_HICK48_NODIV : at32f413_crm.h
  • crm_hick_clock_calibration_set() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_clock_trimming_set() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_div_6_type : at32f413_crm.h
  • crm_hick_divider_select() : at32f413_crm.h, at32f413_crm.c
  • CRM_HICK_READY_INT_FLAG : at32f413_crm.h
  • CRM_HICK_SCLK_48MHZ : at32f413_crm.h
  • CRM_HICK_SCLK_8MHZ : at32f413_crm.h
  • crm_hick_sclk_frequency_select() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_sclk_frequency_type : at32f413_crm.h
  • CRM_HICK_STABLE_FLAG : at32f413_crm.h
  • CRM_HICK_STABLE_INT : at32f413_crm.h
  • CRM_I2C1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_I2C1_PERIPH_RESET : at32f413_crm.h
  • CRM_I2C2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_I2C2_PERIPH_RESET : at32f413_crm.h
  • crm_interrupt_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_IOMUX_PERIPH_CLOCK : at32f413_crm.h
  • CRM_IOMUX_PERIPH_RESET : at32f413_crm.h
  • CRM_IRQn : at32f413.h
  • crm_lext_bypass() : at32f413_crm.h, at32f413_crm.c
  • CRM_LEXT_READY_INT_FLAG : at32f413_crm.h
  • CRM_LEXT_STABLE_FLAG : at32f413_crm.h
  • CRM_LEXT_STABLE_INT : at32f413_crm.h
  • CRM_LICK_READY_INT_FLAG : at32f413_crm.h
  • CRM_LICK_STABLE_FLAG : at32f413_crm.h
  • CRM_LICK_STABLE_INT : at32f413_crm.h
  • CRM_LOWPOWER_RESET_FLAG : at32f413_crm.h
  • CRM_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • CRM_NRST_RESET_FLAG : at32f413_crm.h
  • crm_periph_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_clock_sleepmd_type : at32f413_crm.h
  • crm_periph_clock_type : at32f413_crm.h
  • crm_periph_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_reset_type : at32f413_crm.h
  • crm_periph_sleep_mode_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_pll_clock_source_type : at32f413_crm.h
  • crm_pll_config() : at32f413_crm.h, at32f413_crm.c
  • CRM_PLL_MULT_10 : at32f413_crm.h
  • CRM_PLL_MULT_11 : at32f413_crm.h
  • CRM_PLL_MULT_12 : at32f413_crm.h
  • CRM_PLL_MULT_13 : at32f413_crm.h
  • CRM_PLL_MULT_14 : at32f413_crm.h
  • CRM_PLL_MULT_15 : at32f413_crm.h
  • CRM_PLL_MULT_16 : at32f413_crm.h
  • CRM_PLL_MULT_17 : at32f413_crm.h
  • CRM_PLL_MULT_18 : at32f413_crm.h
  • CRM_PLL_MULT_19 : at32f413_crm.h
  • CRM_PLL_MULT_2 : at32f413_crm.h
  • CRM_PLL_MULT_20 : at32f413_crm.h
  • CRM_PLL_MULT_21 : at32f413_crm.h
  • CRM_PLL_MULT_22 : at32f413_crm.h
  • CRM_PLL_MULT_23 : at32f413_crm.h
  • CRM_PLL_MULT_24 : at32f413_crm.h
  • CRM_PLL_MULT_25 : at32f413_crm.h
  • CRM_PLL_MULT_26 : at32f413_crm.h
  • CRM_PLL_MULT_27 : at32f413_crm.h
  • CRM_PLL_MULT_28 : at32f413_crm.h
  • CRM_PLL_MULT_29 : at32f413_crm.h
  • CRM_PLL_MULT_3 : at32f413_crm.h
  • CRM_PLL_MULT_30 : at32f413_crm.h
  • CRM_PLL_MULT_31 : at32f413_crm.h
  • CRM_PLL_MULT_32 : at32f413_crm.h
  • CRM_PLL_MULT_33 : at32f413_crm.h
  • CRM_PLL_MULT_34 : at32f413_crm.h
  • CRM_PLL_MULT_35 : at32f413_crm.h
  • CRM_PLL_MULT_36 : at32f413_crm.h
  • CRM_PLL_MULT_37 : at32f413_crm.h
  • CRM_PLL_MULT_38 : at32f413_crm.h
  • CRM_PLL_MULT_39 : at32f413_crm.h
  • CRM_PLL_MULT_4 : at32f413_crm.h
  • CRM_PLL_MULT_40 : at32f413_crm.h
  • CRM_PLL_MULT_41 : at32f413_crm.h
  • CRM_PLL_MULT_42 : at32f413_crm.h
  • CRM_PLL_MULT_43 : at32f413_crm.h
  • CRM_PLL_MULT_44 : at32f413_crm.h
  • CRM_PLL_MULT_45 : at32f413_crm.h
  • CRM_PLL_MULT_46 : at32f413_crm.h
  • CRM_PLL_MULT_47 : at32f413_crm.h
  • CRM_PLL_MULT_48 : at32f413_crm.h
  • CRM_PLL_MULT_49 : at32f413_crm.h
  • CRM_PLL_MULT_5 : at32f413_crm.h
  • CRM_PLL_MULT_50 : at32f413_crm.h
  • CRM_PLL_MULT_51 : at32f413_crm.h
  • CRM_PLL_MULT_52 : at32f413_crm.h
  • CRM_PLL_MULT_53 : at32f413_crm.h
  • CRM_PLL_MULT_54 : at32f413_crm.h
  • CRM_PLL_MULT_55 : at32f413_crm.h
  • CRM_PLL_MULT_56 : at32f413_crm.h
  • CRM_PLL_MULT_57 : at32f413_crm.h
  • CRM_PLL_MULT_58 : at32f413_crm.h
  • CRM_PLL_MULT_59 : at32f413_crm.h
  • CRM_PLL_MULT_6 : at32f413_crm.h
  • CRM_PLL_MULT_60 : at32f413_crm.h
  • CRM_PLL_MULT_61 : at32f413_crm.h
  • CRM_PLL_MULT_62 : at32f413_crm.h
  • CRM_PLL_MULT_63 : at32f413_crm.h
  • CRM_PLL_MULT_64 : at32f413_crm.h
  • CRM_PLL_MULT_7 : at32f413_crm.h
  • CRM_PLL_MULT_8 : at32f413_crm.h
  • CRM_PLL_MULT_9 : at32f413_crm.h
  • crm_pll_mult_type : at32f413_crm.h
  • CRM_PLL_OUTPUT_RANGE_GT72MHZ : at32f413_crm.h
  • CRM_PLL_OUTPUT_RANGE_LE72MHZ : at32f413_crm.h
  • crm_pll_output_range_type : at32f413_crm.h
  • CRM_PLL_READY_INT_FLAG : at32f413_crm.h
  • CRM_PLL_SOURCE_HEXT : at32f413_crm.h
  • CRM_PLL_SOURCE_HEXT_DIV : at32f413_crm.h
  • CRM_PLL_SOURCE_HICK : at32f413_crm.h
  • CRM_PLL_STABLE_FLAG : at32f413_crm.h
  • CRM_PLL_STABLE_INT : at32f413_crm.h
  • CRM_POR_RESET_FLAG : at32f413_crm.h
  • CRM_PWC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_PWC_PERIPH_RESET : at32f413_crm.h
  • CRM_REG : at32f413_crm.h
  • CRM_REG_BIT : at32f413_crm.h
  • crm_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_rtc_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • CRM_RTC_CLOCK_HEXT_DIV : at32f413_crm.h
  • CRM_RTC_CLOCK_LEXT : at32f413_crm.h
  • CRM_RTC_CLOCK_LICK : at32f413_crm.h
  • CRM_RTC_CLOCK_NOCLK : at32f413_crm.h
  • crm_rtc_clock_select() : at32f413_crm.h, at32f413_crm.c
  • crm_rtc_clock_type : at32f413_crm.h
  • CRM_SCLK_HEXT : at32f413_crm.h
  • CRM_SCLK_HICK : at32f413_crm.h
  • CRM_SCLK_PLL : at32f413_crm.h
  • crm_sclk_type : at32f413_crm.h
  • CRM_SDIO1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI1_PERIPH_RESET : at32f413_crm.h
  • CRM_SPI2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI2_PERIPH_RESET : at32f413_crm.h
  • CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE : at32f413_crm.h
  • CRM_SW_RESET_FLAG : at32f413_crm.h
  • crm_sysclk_switch() : at32f413_crm.h, at32f413_crm.c
  • crm_sysclk_switch_status_get() : at32f413_crm.h, at32f413_crm.c
  • CRM_TMR10_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR10_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR11_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR11_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR1_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR2_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR3_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR3_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR4_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR4_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR5_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR5_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR8_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR8_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR9_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR9_PERIPH_RESET : at32f413_crm.h
  • CRM_UART4_PERIPH_CLOCK : at32f413_crm.h
  • CRM_UART4_PERIPH_RESET : at32f413_crm.h
  • CRM_UART5_PERIPH_CLOCK : at32f413_crm.h
  • CRM_UART5_PERIPH_RESET : at32f413_crm.h
  • CRM_USART1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART1_PERIPH_RESET : at32f413_crm.h
  • CRM_USART2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART2_PERIPH_RESET : at32f413_crm.h
  • CRM_USART3_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART3_PERIPH_RESET : at32f413_crm.h
  • crm_usb_clock_div_set() : at32f413_crm.h, at32f413_crm.c
  • CRM_USB_CLOCK_SOURCE_HICK : at32f413_crm.h
  • CRM_USB_CLOCK_SOURCE_PLL : at32f413_crm.h
  • crm_usb_clock_source_select() : at32f413_crm.h, at32f413_crm.c
  • crm_usb_clock_source_type : at32f413_crm.h
  • CRM_USB_DIV_1 : at32f413_crm.h
  • CRM_USB_DIV_1_5 : at32f413_crm.h
  • CRM_USB_DIV_2 : at32f413_crm.h
  • CRM_USB_DIV_2_5 : at32f413_crm.h
  • CRM_USB_DIV_3 : at32f413_crm.h
  • CRM_USB_DIV_3_5 : at32f413_crm.h
  • CRM_USB_DIV_4 : at32f413_crm.h
  • crm_usb_div_type : at32f413_crm.h
  • CRM_USB_INT19_INT20 : at32f413_crm.h
  • CRM_USB_INT73_INT74 : at32f413_crm.h
  • crm_usb_int_map_type : at32f413_crm.h
  • crm_usb_interrupt_remapping_set() : at32f413_crm.h, at32f413_crm.c
  • CRM_USB_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USB_PERIPH_RESET : at32f413_crm.h
  • CRM_WDT_RESET_FLAG : at32f413_crm.h
  • CRM_WWDT_PERIPH_CLOCK : at32f413_crm.h
  • CRM_WWDT_PERIPH_RESET : at32f413_crm.h
  • CRM_WWDT_RESET_FLAG : at32f413_crm.h
  • csd_table : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • CSW_BCSWSTATUS_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PASS : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PHASE_ERR : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_DCSWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CUSHID_BCD_NUM : custom_hid_desc.h
  • CUSHID_BINTERVAL_TIME : custom_hid_desc.h
  • custom_hid_class_handler : custom_hid_class.c, custom_hid_class.h
  • custom_hid_class_send_report() : custom_hid_class.c, custom_hid_class.h
  • custom_hid_desc_handler : custom_hid_desc.c, custom_hid_desc.h
  • custom_hid_struct : custom_hid_class.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- d -

  • DATA1_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA2_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA3_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA4_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • data_buffer : project/at_start_f413/examples/crc/calculation/src/main.c
  • data_count : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c
  • data_counter_end : project/at_start_f413/examples/dma/flash_to_sram/src/main.c
  • data_take() : bootloader/src/iap.c
  • data_trans_dir : at32f413_usb.h
  • DATA_TRANS_IN : at32f413_usb.h
  • DATA_TRANS_OUT : at32f413_usb.h
  • DEBUG_BASE : at32f413.h
  • DEBUG_CAN1_PAUSE : at32f413_debug.h
  • DEBUG_CAN2_PAUSE : at32f413_debug.h
  • DEBUG_DEEPSLEEP : at32f413_debug.h
  • debug_device_id_get() : at32f413_debug.h, at32f413_debug.c
  • DEBUG_I2C1_SMBUS_TIMEOUT : at32f413_debug.h
  • DEBUG_I2C2_SMBUS_TIMEOUT : at32f413_debug.h
  • DEBUG_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • debug_periph_mode_set() : at32f413_debug.h, at32f413_debug.c
  • DEBUG_SLEEP : at32f413_debug.h
  • DEBUG_STANDBY : at32f413_debug.h
  • DEBUG_TMR10_PAUSE : at32f413_debug.h
  • DEBUG_TMR11_PAUSE : at32f413_debug.h
  • DEBUG_TMR1_PAUSE : at32f413_debug.h
  • DEBUG_TMR2_PAUSE : at32f413_debug.h
  • DEBUG_TMR3_PAUSE : at32f413_debug.h
  • DEBUG_TMR4_PAUSE : at32f413_debug.h
  • DEBUG_TMR5_PAUSE : at32f413_debug.h
  • DEBUG_TMR8_PAUSE : at32f413_debug.h
  • DEBUG_TMR9_PAUSE : at32f413_debug.h
  • DEBUG_WDT_PAUSE : at32f413_debug.h
  • DEBUG_WWDT_PAUSE : at32f413_debug.h
  • DEBUGMCU : at32f413_debug.h
  • DebugMon_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • DebugMonitor_IRQn : at32f413.h
  • DELAY : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f413/templates/src/main.c
  • delay() : project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c
  • delay_init() : at32f413_board.c, at32f413_board.h
  • delay_ms() : at32f413_board.c, at32f413_board.h
  • delay_sec() : at32f413_board.c, at32f413_board.h
  • delay_us() : at32f413_board.c, at32f413_board.h
  • DEV_MMC : diskio.c
  • DEV_RAM : diskio.c
  • DEV_USB : diskio.c
  • device_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • DEVICE_ID_ADDR1 : random.c
  • device_mode : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • disk_initialize() : diskio.c
  • disk_ioctl() : diskio.c
  • disk_read() : diskio.c
  • disk_status() : diskio.c
  • disk_write() : diskio.c
  • div_value : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c
  • DMA1 : at32f413_dma.h
  • DMA1_BASE : at32f413.h
  • DMA1_CHANNEL1 : at32f413_dma.h
  • DMA1_CHANNEL1_BASE : at32f413.h
  • DMA1_Channel1_IRQHandler() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
  • DMA1_Channel1_IRQn : at32f413.h
  • DMA1_CHANNEL2 : at32f413_dma.h
  • DMA1_CHANNEL2_BASE : at32f413.h
  • DMA1_Channel2_IRQHandler() : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
  • DMA1_Channel2_IRQn : at32f413.h
  • DMA1_CHANNEL3 : at32f413_dma.h
  • DMA1_CHANNEL3_BASE : at32f413.h
  • DMA1_Channel3_IRQHandler() : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • DMA1_Channel3_IRQn : at32f413.h
  • DMA1_CHANNEL4 : at32f413_dma.h
  • DMA1_CHANNEL4_BASE : at32f413.h
  • DMA1_Channel4_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • DMA1_Channel4_IRQn : at32f413.h
  • DMA1_CHANNEL5 : at32f413_dma.h
  • DMA1_CHANNEL5_BASE : at32f413.h
  • DMA1_Channel5_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • DMA1_Channel5_IRQn : at32f413.h
  • DMA1_CHANNEL6 : at32f413_dma.h
  • DMA1_CHANNEL6_BASE : at32f413.h
  • DMA1_Channel6_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
  • DMA1_Channel6_IRQn : at32f413.h
  • DMA1_CHANNEL7 : at32f413_dma.h
  • DMA1_CHANNEL7_BASE : at32f413.h
  • DMA1_Channel7_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
  • DMA1_Channel7_IRQn : at32f413.h
  • DMA1_DTERR1_FLAG : at32f413_dma.h
  • DMA1_DTERR2_FLAG : at32f413_dma.h
  • DMA1_DTERR3_FLAG : at32f413_dma.h
  • DMA1_DTERR4_FLAG : at32f413_dma.h
  • DMA1_DTERR5_FLAG : at32f413_dma.h
  • DMA1_DTERR6_FLAG : at32f413_dma.h
  • DMA1_DTERR7_FLAG : at32f413_dma.h
  • DMA1_FDT1_FLAG : at32f413_dma.h
  • DMA1_FDT2_FLAG : at32f413_dma.h
  • DMA1_FDT3_FLAG : at32f413_dma.h
  • DMA1_FDT4_FLAG : at32f413_dma.h
  • DMA1_FDT5_FLAG : at32f413_dma.h
  • DMA1_FDT6_FLAG : at32f413_dma.h
  • DMA1_FDT7_FLAG : at32f413_dma.h
  • DMA1_GL1_FLAG : at32f413_dma.h
  • DMA1_GL2_FLAG : at32f413_dma.h
  • DMA1_GL3_FLAG : at32f413_dma.h
  • DMA1_GL4_FLAG : at32f413_dma.h
  • DMA1_GL5_FLAG : at32f413_dma.h
  • DMA1_GL6_FLAG : at32f413_dma.h
  • DMA1_GL7_FLAG : at32f413_dma.h
  • DMA1_HDT1_FLAG : at32f413_dma.h
  • DMA1_HDT2_FLAG : at32f413_dma.h
  • DMA1_HDT3_FLAG : at32f413_dma.h
  • DMA1_HDT4_FLAG : at32f413_dma.h
  • DMA1_HDT5_FLAG : at32f413_dma.h
  • DMA1_HDT6_FLAG : at32f413_dma.h
  • DMA1_HDT7_FLAG : at32f413_dma.h
  • dma1_trans_complete_flag : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c
  • DMA2 : at32f413_dma.h
  • DMA2_BASE : at32f413.h
  • DMA2_CHANNEL1 : at32f413_dma.h
  • DMA2_CHANNEL1_BASE : at32f413.h
  • DMA2_Channel1_IRQHandler() : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c
  • DMA2_Channel1_IRQn : at32f413.h
  • DMA2_CHANNEL2 : at32f413_dma.h
  • DMA2_CHANNEL2_BASE : at32f413.h
  • DMA2_Channel2_IRQn : at32f413.h
  • DMA2_CHANNEL3 : at32f413_dma.h
  • DMA2_CHANNEL3_BASE : at32f413.h
  • DMA2_Channel3_IRQn : at32f413.h
  • DMA2_CHANNEL4 : at32f413_dma.h
  • DMA2_Channel4_5_IRQn : at32f413.h
  • DMA2_CHANNEL4_BASE : at32f413.h
  • DMA2_CHANNEL5 : at32f413_dma.h
  • DMA2_CHANNEL5_BASE : at32f413.h
  • DMA2_CHANNEL6 : at32f413_dma.h
  • DMA2_Channel6_7_IRQn : at32f413.h
  • DMA2_CHANNEL6_BASE : at32f413.h
  • DMA2_CHANNEL7 : at32f413_dma.h
  • DMA2_CHANNEL7_BASE : at32f413.h
  • DMA2_DTERR1_FLAG : at32f413_dma.h
  • DMA2_DTERR2_FLAG : at32f413_dma.h
  • DMA2_DTERR3_FLAG : at32f413_dma.h
  • DMA2_DTERR4_FLAG : at32f413_dma.h
  • DMA2_DTERR5_FLAG : at32f413_dma.h
  • DMA2_DTERR6_FLAG : at32f413_dma.h
  • DMA2_DTERR7_FLAG : at32f413_dma.h
  • DMA2_FDT1_FLAG : at32f413_dma.h
  • DMA2_FDT2_FLAG : at32f413_dma.h
  • DMA2_FDT3_FLAG : at32f413_dma.h
  • DMA2_FDT4_FLAG : at32f413_dma.h
  • DMA2_FDT5_FLAG : at32f413_dma.h
  • DMA2_FDT6_FLAG : at32f413_dma.h
  • DMA2_FDT7_FLAG : at32f413_dma.h
  • DMA2_GL1_FLAG : at32f413_dma.h
  • DMA2_GL2_FLAG : at32f413_dma.h
  • DMA2_GL3_FLAG : at32f413_dma.h
  • DMA2_GL4_FLAG : at32f413_dma.h
  • DMA2_GL5_FLAG : at32f413_dma.h
  • DMA2_GL6_FLAG : at32f413_dma.h
  • DMA2_GL7_FLAG : at32f413_dma.h
  • DMA2_HDT1_FLAG : at32f413_dma.h
  • DMA2_HDT2_FLAG : at32f413_dma.h
  • DMA2_HDT3_FLAG : at32f413_dma.h
  • DMA2_HDT4_FLAG : at32f413_dma.h
  • DMA2_HDT5_FLAG : at32f413_dma.h
  • DMA2_HDT6_FLAG : at32f413_dma.h
  • DMA2_HDT7_FLAG : at32f413_dma.h
  • DMA_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • dma_channel_enable() : at32f413_dma.h, at32f413_dma.c
  • dma_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • dma_configuration() : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • dma_data_number_get() : at32f413_dma.h, at32f413_dma.c
  • dma_data_number_set() : at32f413_dma.h, at32f413_dma.c
  • dma_default_para_init() : at32f413_dma.h, at32f413_dma.c
  • DMA_DIR_MEMORY_TO_MEMORY : at32f413_dma.h
  • DMA_DIR_MEMORY_TO_PERIPHERAL : at32f413_dma.h
  • DMA_DIR_PERIPHERAL_TO_MEMORY : at32f413_dma.h
  • dma_dir_type : at32f413_dma.h
  • DMA_DTERR_INT : at32f413_dma.h
  • DMA_FDT_INT : at32f413_dma.h
  • dma_flag_clear() : at32f413_dma.h, at32f413_dma.c
  • dma_flag_get() : at32f413_dma.h, at32f413_dma.c
  • DMA_FLEXIBLE_ADC1 : at32f413_dma.h
  • dma_flexible_config() : at32f413_dma.h, at32f413_dma.c
  • DMA_FLEXIBLE_I2C1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C2_TX : at32f413_dma.h
  • dma_flexible_request_type : at32f413_dma.h
  • DMA_FLEXIBLE_SDIO1 : at32f413_dma.h
  • DMA_FLEXIBLE_SPI1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_HALL : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_HALL : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_UART1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART3_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART3_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART4_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART4_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART5_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART5_TX : at32f413_dma.h
  • DMA_GET_HT_FLAG : i2c_application.c
  • DMA_GET_TC_FLAG : i2c_application.c
  • DMA_GET_TERR_FLAG : i2c_application.c
  • DMA_HDT_INT : at32f413_dma.h
  • dma_init() : at32f413_dma.h, at32f413_dma.c
  • dma_init_struct : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • dma_init_structure : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • dma_interrupt_enable() : at32f413_dma.h, at32f413_dma.c
  • dma_memory_data_size_type : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_BYTE : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_HALFWORD : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_WORD : at32f413_dma.h
  • DMA_MEMORY_INC_DISABLE : at32f413_dma.h
  • DMA_MEMORY_INC_ENABLE : at32f413_dma.h
  • dma_memory_inc_type : at32f413_dma.h
  • DMA_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • dma_peripheral_data_size_type : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_BYTE : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_HALFWORD : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_WORD : at32f413_dma.h
  • DMA_PERIPHERAL_INC_DISABLE : at32f413_dma.h
  • DMA_PERIPHERAL_INC_ENABLE : at32f413_dma.h
  • dma_peripheral_inc_type : at32f413_dma.h
  • DMA_PRIORITY_HIGH : at32f413_dma.h
  • dma_priority_level_type : at32f413_dma.h
  • DMA_PRIORITY_LOW : at32f413_dma.h
  • DMA_PRIORITY_MEDIUM : at32f413_dma.h
  • DMA_PRIORITY_VERY_HIGH : at32f413_dma.h
  • dma_reset() : at32f413_dma.h, at32f413_dma.c
  • dma_trans_complete_flag : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • DOWN_MOVE : mouse_class.h
  • dst_buffer : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • duty_cycle : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • duty_result : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • dw_data_start_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • dw_end_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • dw_start_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • DYMMY_BYTE : project/at_start_f413/examples/usart/synchronous/src/main.c
  • DZC_TIMEOUT : at32f413_can.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • ENABLE_RTC_ASSEED : random.h
  • EPT0_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT0_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT1_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT1_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT2_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT2_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT3_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT3_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT4_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT4_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT5_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT5_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT6_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT6_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT7_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT7_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT_BULK_TYPE : at32f413_usb.h
  • EPT_CONTROL_TYPE : at32f413_usb.h
  • EPT_IN : at32f413_usb.h
  • ept_inout_type : at32f413_usb.h
  • EPT_INT_TYPE : at32f413_usb.h
  • EPT_ISO_TYPE : at32f413_usb.h
  • EPT_OUT : at32f413_usb.h
  • ept_trans_type : at32f413_usb.h
  • ERASE_TIMEOUT : at32f413_flash.h
  • ERROR : at32f413.h
  • error_handler() : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • ERROR_ID_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • error_status : at32f413.h
  • EXINT : at32f413_exint.h
  • EXINT0_IRQHandler() : project/at_start_f413/examples/exint/exint_config/src/main.c, project/at_start_f413/templates/src/main.c
  • EXINT0_IRQn : at32f413.h
  • EXINT15_10_IRQn : at32f413.h
  • EXINT1_IRQn : at32f413.h
  • EXINT2_IRQn : at32f413.h
  • EXINT3_IRQn : at32f413.h
  • EXINT4_IRQHandler() : project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • EXINT4_IRQn : at32f413.h
  • EXINT9_5_IRQHandler() : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
  • EXINT9_5_IRQn : at32f413.h
  • EXINT_BASE : at32f413.h
  • exint_config() : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
  • exint_default_para_init() : at32f413_exint.h, at32f413_exint.c
  • exint_event_enable() : at32f413_exint.h, at32f413_exint.c
  • exint_flag_clear() : at32f413_exint.h, at32f413_exint.c
  • exint_flag_get() : at32f413_exint.h, at32f413_exint.c
  • exint_init() : at32f413_exint.h, at32f413_exint.c
  • exint_interrupt_enable() : at32f413_exint.h, at32f413_exint.c
  • exint_line0_config() : project/at_start_f413/examples/exint/exint_config/src/main.c
  • exint_line4_config() : project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • EXINT_LINE_0 : at32f413_exint.h
  • EXINT_LINE_1 : at32f413_exint.h
  • EXINT_LINE_10 : at32f413_exint.h
  • EXINT_LINE_11 : at32f413_exint.h
  • EXINT_LINE_12 : at32f413_exint.h
  • EXINT_LINE_13 : at32f413_exint.h
  • EXINT_LINE_14 : at32f413_exint.h
  • EXINT_LINE_15 : at32f413_exint.h
  • EXINT_LINE_16 : at32f413_exint.h
  • EXINT_LINE_17 : at32f413_exint.h
  • EXINT_LINE_18 : at32f413_exint.h
  • EXINT_LINE_2 : at32f413_exint.h
  • EXINT_LINE_3 : at32f413_exint.h
  • EXINT_LINE_4 : at32f413_exint.h
  • EXINT_LINE_5 : at32f413_exint.h
  • EXINT_LINE_6 : at32f413_exint.h
  • EXINT_LINE_7 : at32f413_exint.h
  • EXINT_LINE_8 : at32f413_exint.h
  • EXINT_LINE_9 : at32f413_exint.h
  • EXINT_LINE_EVENT : at32f413_exint.h
  • EXINT_LINE_INTERRUPUT : at32f413_exint.h
  • exint_line_mode_type : at32f413_exint.h
  • EXINT_LINE_NONE : at32f413_exint.h
  • EXINT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • exint_polarity_config_type : at32f413_exint.h
  • exint_reset() : at32f413_exint.h, at32f413_exint.c
  • exint_software_interrupt_event_generate() : at32f413_exint.h, at32f413_exint.c
  • EXINT_TRIGGER_BOTH_EDGE : at32f413_exint.h
  • EXINT_TRIGGER_FALLING_EDGE : at32f413_exint.h
  • EXINT_TRIGGER_RISING_EDGE : at32f413_exint.h
  • EXT_CSD_BUS_WIDTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Clear_byte : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_CPSECURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_NORMAL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_SECURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Command_set : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_HS_TIMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Set_bit : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Write_byte : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_SPIM_EN_MUX : at32f413_gpio.h
  • EXT_SPIM_GMUX_1000 : at32f413_gpio.h
  • EXT_SPIM_GMUX_1001 : at32f413_gpio.h
  • extend_sram() : project/at_start_f413/examples/sram/extend_sram/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- f -

  • fac_ms : at32f413_board.c
  • fac_us : at32f413_board.c
  • FALSE : at32f413.h
  • FAP_RELIEVE_KEY : at32f413_flash.h
  • FAST : project/at_start_f413/templates/src/main.c
  • FAT16_BYTE_PER_SIZE : flash_fat16.h
  • FAT16_DIR_SIZE : flash_fat16.h
  • fat16_file_name : flash_fat16.c
  • FAT16_FILENAME_SIZE : flash_fat16.h
  • fat16_memory_cmp() : flash_fat16.c
  • fat16_memory_copy() : flash_fat16.c
  • fat16_memory_memset() : flash_fat16.c
  • fat16_root_dir_sector : flash_fat16.c
  • fat16_sector : flash_fat16.c
  • FAT16_SECTOR_SIZE : flash_fat16.h, flash_fat16.c
  • fat16_table_sector0 : flash_fat16.c
  • FAT16_TABLE_SIZE : flash_fat16.h
  • fatfs_test() : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • FEEDBACK_REFRESH_TIME : audio_class.h, audio_hid_class.h
  • FF_CODE_PAGE : ffconf.h
  • FF_FS_EXFAT : ffconf.h
  • FF_FS_LOCK : ffconf.h
  • FF_FS_MINIMIZE : ffconf.h
  • FF_FS_NOFSINFO : ffconf.h
  • FF_FS_NORTC : ffconf.h
  • FF_FS_READONLY : ffconf.h
  • FF_FS_REENTRANT : ffconf.h
  • FF_FS_RPATH : ffconf.h
  • FF_FS_TIMEOUT : ffconf.h
  • FF_FS_TINY : ffconf.h
  • FF_LBA64 : ffconf.h
  • FF_LFN_BUF : ffconf.h
  • FF_LFN_UNICODE : ffconf.h
  • FF_MAX_LFN : ffconf.h
  • FF_MAX_SS : ffconf.h
  • FF_MIN_GPT : ffconf.h
  • FF_MIN_SS : ffconf.h
  • FF_MULTI_PARTITION : ffconf.h
  • FF_NORTC_MDAY : ffconf.h
  • FF_NORTC_MON : ffconf.h
  • FF_NORTC_YEAR : ffconf.h
  • FF_PRINT_FLOAT : ffconf.h
  • FF_PRINT_LLI : ffconf.h
  • FF_SFN_BUF : ffconf.h
  • FF_STR_VOLUME_ID : ffconf.h
  • FF_STRF_ENCODE : ffconf.h
  • FF_SYNC_t : ffconf.h
  • FF_USE_CHMOD : ffconf.h
  • FF_USE_EXPAND : ffconf.h
  • FF_USE_FASTSEEK : ffconf.h
  • FF_USE_FIND : ffconf.h
  • FF_USE_FORWARD : ffconf.h
  • FF_USE_LABEL : ffconf.h
  • FF_USE_LFN : ffconf.h
  • FF_USE_MKFS : ffconf.h
  • FF_USE_STRFUNC : ffconf.h
  • FF_USE_TRIM : ffconf.h
  • FF_VOLUME_STRS : ffconf.h
  • FF_VOLUMES : ffconf.h
  • FFCONF_DEF : ffconf.h
  • file : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • file_match : flash_fat16.c
  • FILE_SUFFIX1_LEN : flash_fat16.h
  • FILE_SUFFIX1_NAME : flash_fat16.h
  • FILE_SUFFIX2_LEN : flash_fat16.h
  • FILE_SUFFIX2_NAME : flash_fat16.h
  • file_write_nr : flash_fat16.c
  • FILTER_EXT_ID1 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_EXT_ID2 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_EXT_ID3 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID1 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID2 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID3 : project/at_start_f413/examples/can/filter/src/main.c
  • FIR_lowpass_filter() : project_l0/inc/fir_filter.h, fir_filter.c, project_l1/inc/fir_filter.h
  • firCoeffs32 : fir_coefficient.c, fir_filter.c
  • firStateF32 : fir_filter.c
  • flag_status : at32f413.h
  • FLASH : at32f413_flash.h
  • flash_2kb_write() : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
  • FLASH_APP_ADDRESS : app_led3_toggle/inc/hid_iap_user.h, app_led4_toggle/inc/hid_iap_user.h, bootloader/inc/hid_iap_user.h
  • FLASH_APP_START_ADDR : flash_fat16.h
  • FLASH_BASE : at32f413.h
  • flash_buf : project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_byte_program() : at32f413_flash.h, at32f413_flash.c
  • flash_crc_calibrate() : at32f413_flash.h, at32f413_flash.c
  • flash_crc_check() : flash_fat16.c
  • FLASH_CS_HIGH : spi_flash.h
  • FLASH_CS_LOW : spi_flash.h
  • FLASH_EPP_ERROR : at32f413_flash.h
  • flash_epp_set() : at32f413_flash.h, at32f413_flash.c
  • flash_epp_status_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_EPPERR_FLAG : at32f413_flash.h
  • FLASH_ERR_INT : at32f413_flash.h
  • flash_fap_enable() : at32f413_flash.h, at32f413_flash.c
  • flash_fap_status_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_FAT16_1_ADDR : flash_fat16.h
  • FLASH_FAT16_2_ADDR : flash_fat16.h
  • flash_fat16_addr_offset() : flash_fat16.c
  • flash_fat16_boot_dir_write() : flash_fat16.c
  • FLASH_FAT16_BOOT_SECTOR_ADDR : flash_fat16.h
  • flash_fat16_clear_upgrade_flag() : flash_fat16.c
  • FLASH_FAT16_FILE_START_ADDR : flash_fat16.h
  • flash_fat16_get_upgrade_flag() : flash_fat16.h, flash_fat16.c
  • flash_fat16_init() : flash_fat16.h, flash_fat16.c
  • flash_fat16_loop_status() : flash_fat16.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
  • flash_fat16_read() : flash_fat16.h, flash_fat16.c
  • FLASH_FAT16_ROOT_ADDR : flash_fat16.h
  • flash_fat16_sector_write() : flash_fat16.c
  • flash_fat16_set_name() : flash_fat16.h, flash_fat16.c
  • flash_fat16_set_upgrade_flag() : flash_fat16.c
  • flash_fat16_write() : flash_fat16.h, flash_fat16.c
  • flash_flag_clear() : at32f413_flash.h, at32f413_flash.c
  • flash_flag_get() : at32f413_flash.h, at32f413_flash.c
  • flash_halfword_program() : at32f413_flash.h, at32f413_flash.c
  • flash_iap : flash_fat16.h, flash_fat16.c
  • flash_internal_all_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_interrupt_enable() : at32f413_flash.h, at32f413_flash.c
  • FLASH_IRQHandler() : utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c
  • FLASH_IRQn : at32f413.h
  • flash_lock() : at32f413_flash.h, at32f413_flash.c
  • FLASH_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • FLASH_OBF_FLAG : at32f413_flash.h
  • FLASH_ODF_FLAG : at32f413_flash.h
  • FLASH_ODF_INT : at32f413_flash.h
  • FLASH_OPERATE_BUSY : at32f413_flash.h
  • FLASH_OPERATE_DONE : at32f413_flash.h
  • FLASH_OPERATE_TIMEOUT : at32f413_flash.h
  • flash_operation_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_operation_wait_for() : at32f413_flash.h, at32f413_flash.c
  • FLASH_PRGMERR_FLAG : at32f413_flash.h
  • FLASH_PROGRAM_ERROR : at32f413_flash.h
  • flash_read() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_read_data() : flash_fat16.c
  • FLASH_REG_BASE : at32f413.h
  • FLASH_SECTOR_1K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_1K_SIZE : flash_fat16.h
  • FLASH_SECTOR_2K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_2K_SIZE : flash_fat16.h
  • FLASH_SECTOR_4K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_4K_SIZE : flash_fat16.h
  • flash_sector_erase() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SECTOR_SIZE : utilities/at32f413_slib_demo/project_l0/src/main.c
  • FLASH_SIZE : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
  • FLASH_SIZE_REG : hid_iap_class.h
  • FLASH_SLIB_DATA_START_SECTOR : at32f413_flash.h
  • flash_slib_datstart_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_disable() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_enable() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SLIB_END_SECTOR : at32f413_flash.h
  • flash_slib_end_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_remaining_count_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SLIB_START_SECTOR : at32f413_flash.h
  • flash_slib_start_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_state_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SPI_DUMMY_BYTE : spi_flash.h
  • flash_spim_all_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_encryption_range_set() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SPIM_EPPERR_FLAG : at32f413_flash.h
  • FLASH_SPIM_ERR_INT : at32f413_flash.h
  • flash_spim_lock() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SPIM_MODEL1 : at32f413_flash.h
  • FLASH_SPIM_MODEL2 : at32f413_flash.h
  • flash_spim_model_select() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_model_type : at32f413_flash.h
  • FLASH_SPIM_OBF_FLAG : at32f413_flash.h
  • FLASH_SPIM_ODF_FLAG : at32f413_flash.h
  • FLASH_SPIM_ODF_INT : at32f413_flash.h
  • flash_spim_operation_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_operation_wait_for() : at32f413_flash.h, at32f413_flash.c
  • FLASH_SPIM_PRGMERR_FLAG : at32f413_flash.h
  • FLASH_SPIM_START_ADDR : at32f413_flash.h
  • flash_spim_unlock() : at32f413_flash.h, at32f413_flash.c
  • flash_ssb_set() : at32f413_flash.h, at32f413_flash.c
  • flash_ssb_status_get() : at32f413_flash.h, at32f413_flash.c
  • FLASH_START_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • flash_status_type : at32f413_flash.h
  • FLASH_TEST_ADDR : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • flash_unlock() : at32f413_flash.h, at32f413_flash.c
  • FLASH_UNLOCK_KEY1 : at32f413_flash.h
  • FLASH_UNLOCK_KEY2 : at32f413_flash.h
  • flash_upgrade_flag_read() : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
  • FLASH_USDERR_FLAG : at32f413_flash.h
  • flash_user_system_data_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_user_system_data_program() : at32f413_flash.h, at32f413_flash.c
  • flash_word_program() : at32f413_flash.h, at32f413_flash.c
  • flash_write() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_write_data() : flash_fat16.c
  • flash_write_nocheck() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • FLEX_CHANNEL1 : at32f413_dma.h
  • FLEX_CHANNEL2 : at32f413_dma.h
  • FLEX_CHANNEL3 : at32f413_dma.h
  • FLEX_CHANNEL4 : at32f413_dma.h
  • FLEX_CHANNEL5 : at32f413_dma.h
  • FLEX_CHANNEL6 : at32f413_dma.h
  • FLEX_CHANNEL7 : at32f413_dma.h
  • fputc() : at32f413_board.c
  • freq_result : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • frequency : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • fs : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • FZC_TIMEOUT : at32f413_can.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- g -

  • g_audio_hid_usb_desc : audio_hid_desc.h
  • g_custom_hid_usb_desc : custom_hid_desc.h
  • g_file_attr : flash_fat16.c
  • g_hidiap_usb_desc : hid_iap_desc.h
  • g_keyboard_usb_desc : keyboard_desc.h
  • g_mouse_usb_desc : mouse_desc.h
  • g_speed : project/at_start_f413/templates/src/main.c
  • g_usb_offset_addr : at32f413_usb.c
  • g_usb_packet_address : at32f413_usb.h, at32f413_usb.c
  • g_usbd_audio_hid_report : audio_hid_desc.h
  • g_usbd_custom_hid_report : custom_hid_desc.h
  • g_usbd_desc_buffer : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • g_usbd_hidiap_report : hid_iap_desc.h
  • g_usbd_keyboard_report : keyboard_desc.h
  • g_usbd_mouse_report : mouse_desc.h
  • g_usbd_vcpkybrd_hid_report : cdc_keyboard_desc.h
  • g_vcpkybrd_hid_usb_desc : cdc_keyboard_desc.h
  • generate_julia_fpu() : julia_fpu.h, julia_fpu.c
  • get_data_from_usart_flag : bootloader/inc/tmr.h, bootloader/src/tmr.c
  • get_device_config_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_configuration() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_descriptor() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_interface_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_lang_id() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_manufacturer_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_other_speed() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_product_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_qualifier() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_serial_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_inquiry() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • GET_LINE_CODING : cdc_msc_class.h, msc_bot_scsi.h, usb_std.h
  • GET_RX_LEN_ADDR : at32f413_usb.h
  • get_serial_num() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • GET_TX_LEN_ADDR : at32f413_usb.h
  • get_uid_for_seed() : random.c
  • getvar_operationcomplete() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • gpio_bits_reset() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_bits_set() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_bits_write() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • gpio_configuration() : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • gpio_default_para_init() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_DRIVE_STRENGTH_MAXIMUM : at32f413_gpio.h
  • GPIO_DRIVE_STRENGTH_MODERATE : at32f413_gpio.h
  • GPIO_DRIVE_STRENGTH_STRONGER : at32f413_gpio.h
  • gpio_drive_type : at32f413_gpio.h
  • gpio_event_output_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_event_output_enable() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_exint_line_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_init() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_init_struct : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c
  • gpio_input_data_bit_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_input_data_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_iomux_reset() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_MODE_ANALOG : at32f413_gpio.h
  • GPIO_MODE_INPUT : at32f413_gpio.h
  • GPIO_MODE_MUX : at32f413_gpio.h
  • GPIO_MODE_OUTPUT : at32f413_gpio.h
  • gpio_mode_type : at32f413_gpio.h
  • GPIO_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • gpio_output_data_bit_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_output_data_read() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_OUTPUT_OPEN_DRAIN : at32f413_gpio.h
  • GPIO_OUTPUT_PUSH_PULL : at32f413_gpio.h
  • gpio_output_type : at32f413_gpio.h
  • gpio_pin_remap_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_pin_wp_config() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_PINS_0 : at32f413_gpio.h
  • GPIO_PINS_1 : at32f413_gpio.h
  • GPIO_PINS_10 : at32f413_gpio.h
  • GPIO_PINS_11 : at32f413_gpio.h
  • GPIO_PINS_12 : at32f413_gpio.h
  • GPIO_PINS_13 : at32f413_gpio.h
  • GPIO_PINS_14 : at32f413_gpio.h
  • GPIO_PINS_15 : at32f413_gpio.h
  • GPIO_PINS_2 : at32f413_gpio.h
  • GPIO_PINS_3 : at32f413_gpio.h
  • GPIO_PINS_4 : at32f413_gpio.h
  • GPIO_PINS_5 : at32f413_gpio.h
  • GPIO_PINS_6 : at32f413_gpio.h
  • GPIO_PINS_7 : at32f413_gpio.h
  • GPIO_PINS_8 : at32f413_gpio.h
  • GPIO_PINS_9 : at32f413_gpio.h
  • GPIO_PINS_ALL : at32f413_gpio.h
  • GPIO_PINS_SOURCE0 : at32f413_gpio.h
  • GPIO_PINS_SOURCE1 : at32f413_gpio.h
  • GPIO_PINS_SOURCE10 : at32f413_gpio.h
  • GPIO_PINS_SOURCE11 : at32f413_gpio.h
  • GPIO_PINS_SOURCE12 : at32f413_gpio.h
  • GPIO_PINS_SOURCE13 : at32f413_gpio.h
  • GPIO_PINS_SOURCE14 : at32f413_gpio.h
  • GPIO_PINS_SOURCE15 : at32f413_gpio.h
  • GPIO_PINS_SOURCE2 : at32f413_gpio.h
  • GPIO_PINS_SOURCE3 : at32f413_gpio.h
  • GPIO_PINS_SOURCE4 : at32f413_gpio.h
  • GPIO_PINS_SOURCE5 : at32f413_gpio.h
  • GPIO_PINS_SOURCE6 : at32f413_gpio.h
  • GPIO_PINS_SOURCE7 : at32f413_gpio.h
  • GPIO_PINS_SOURCE8 : at32f413_gpio.h
  • GPIO_PINS_SOURCE9 : at32f413_gpio.h
  • gpio_pins_source_type : at32f413_gpio.h
  • gpio_pins_toggle() : project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
  • GPIO_PORT_SOURCE_GPIOA : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOB : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOC : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOD : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOF : at32f413_gpio.h
  • gpio_port_source_type : at32f413_gpio.h
  • gpio_port_wirte() : at32f413_gpio.h, at32f413_gpio.c
  • GPIO_PULL_DOWN : at32f413_gpio.h
  • GPIO_PULL_NONE : at32f413_gpio.h
  • gpio_pull_type : at32f413_gpio.h
  • GPIO_PULL_UP : at32f413_gpio.h
  • gpio_reset() : at32f413_gpio.h, at32f413_gpio.c
  • GPIOA : at32f413_gpio.h
  • GPIOA_BASE : at32f413.h
  • GPIOB : at32f413_gpio.h
  • GPIOB_BASE : at32f413.h
  • GPIOC : at32f413_gpio.h
  • GPIOC_BASE : at32f413.h
  • GPIOD : at32f413_gpio.h
  • GPIOD_BASE : at32f413.h
  • GPIOF : at32f413_gpio.h
  • GPIOF_BASE : at32f413.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- h -

  • HardFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • HardFault_IRQn : at32f413.h
  • HBYTE : usb_std.h
  • HEXT_STABLE_DELAY : system_at32f413.h
  • HEXT_STARTUP_TIMEOUT : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HEXT_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • hi2cx : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • HICK_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HID_CLASS_DESC_HID : audio_hid_desc.h, usb_std.h
  • HID_CLASS_DESC_PHYSICAL : audio_hid_desc.h, usb_std.h
  • HID_CLASS_DESC_REPORT : audio_hid_desc.h, usb_std.h
  • HID_DESCRIPTOR_TYPE : usb_std.h
  • HID_IAP_BUFFER_LEN : hid_iap_class.h
  • hid_iap_class_handler : hid_iap_class.c, hid_iap_class.h
  • hid_iap_desc_handler : hid_iap_desc.c, hid_iap_desc.h
  • HID_INTERFACE_NUMBER : audio_hid_desc.h
  • HID_REPORT_DESC : usb_std.h
  • HID_REPORT_ID_1 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_2 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_3 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_4 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_5 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_6 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REQ_GET_IDLE : usb_std.h
  • HID_REQ_GET_PROTOCOL : usb_std.h
  • HID_REQ_GET_REPORT : usb_std.h
  • HID_REQ_SET_IDLE : usb_std.h
  • HID_REQ_SET_PROTOCOL : usb_std.h
  • HID_REQ_SET_REPORT : usb_std.h
  • hid_suspend_flag : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • HIDIAP_BCD_NUM : hid_iap_desc.h
  • HIDIAP_BINTERVAL_TIME : hid_iap_desc.h
  • HIST_LENGTH : project/at_start_f413/examples/usart/smartcard/src/main.c
  • hw_usart_read_index : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • hw_usart_rx_index : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • I2C1 : at32f413_i2c.h
  • I2C1_BASE : at32f413.h
  • I2C1_ERR_IRQHandler() : project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
  • I2C1_ERR_IRQn : at32f413.h
  • I2C1_EVT_IRQHandler() : project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
  • I2C1_EVT_IRQn : at32f413.h
  • I2C1_GMUX_0001 : at32f413_gpio.h
  • I2C1_GMUX_0011 : at32f413_gpio.h
  • I2C1_MUX : at32f413_gpio.h
  • I2C2 : at32f413_i2c.h
  • I2C2_BASE : at32f413.h
  • I2C2_ERR_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2C2_ERR_IRQn : at32f413.h
  • I2C2_EVT_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2C2_EVT_IRQn : at32f413.h
  • I2C2_GMUX_0001 : at32f413_gpio.h
  • I2C2_GMUX_0010 : at32f413_gpio.h
  • I2C2_GMUX_0011 : at32f413_gpio.h
  • i2c_7bit_address_send() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_ack_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_ACKFAIL_FLAG : at32f413_i2c.h
  • I2C_ADDR2_FLAG : at32f413_i2c.h
  • I2C_ADDR7F_FLAG : at32f413_i2c.h
  • i2c_addr_flag_clear() : i2c_application.c
  • I2C_ADDRESS_MODE_10BIT : at32f413_i2c.h
  • I2C_ADDRESS_MODE_7BIT : at32f413_i2c.h
  • i2c_address_mode_type : at32f413_i2c.h
  • I2C_ADDRHF_FLAG : at32f413_i2c.h
  • I2C_ALERTF_FLAG : at32f413_i2c.h
  • I2C_ARLOST_FLAG : at32f413_i2c.h
  • i2c_arp_mode_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_BUSERR_FLAG : at32f413_i2c.h
  • I2C_BUSYF_FLAG : at32f413_i2c.h
  • i2c_clock_stretch_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_config() : i2c_application.c, i2c_application.h
  • I2C_DATA_INT : at32f413_i2c.h
  • i2c_data_receive() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_data_send() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_DEVADDRF_FLAG : at32f413_i2c.h
  • I2C_DIRECTION_RECEIVE : at32f413_i2c.h
  • I2C_DIRECTION_TRANSMIT : at32f413_i2c.h
  • i2c_direction_type : at32f413_i2c.h
  • I2C_DIRF_FLAG : at32f413_i2c.h
  • i2c_dma_config() : i2c_application.c
  • i2c_dma_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_dma_end_transfer_set() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_DMA_MA_RX : i2c_application.h
  • I2C_DMA_MA_TX : i2c_application.h
  • i2c_dma_rx_irq_handler() : i2c_application.c, i2c_application.h
  • I2C_DMA_SLA_RX : i2c_application.h
  • I2C_DMA_SLA_TX : i2c_application.h
  • i2c_dma_tx_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_END : i2c_application.c
  • I2C_ERR_ACKFAIL : i2c_application.h
  • I2C_ERR_ADDR : i2c_application.h
  • I2C_ERR_ADDR10 : i2c_application.h
  • I2C_ERR_INT : at32f413_i2c.h
  • I2C_ERR_INTERRUPT : i2c_application.h
  • i2c_err_irq_handler() : i2c_application.c, i2c_application.h
  • I2C_ERR_START : i2c_application.h
  • I2C_ERR_STEP_1 : i2c_application.h
  • I2C_ERR_STEP_10 : i2c_application.h
  • I2C_ERR_STEP_11 : i2c_application.h
  • I2C_ERR_STEP_12 : i2c_application.h
  • I2C_ERR_STEP_2 : i2c_application.h
  • I2C_ERR_STEP_3 : i2c_application.h
  • I2C_ERR_STEP_4 : i2c_application.h
  • I2C_ERR_STEP_5 : i2c_application.h
  • I2C_ERR_STEP_6 : i2c_application.h
  • I2C_ERR_STEP_7 : i2c_application.h
  • I2C_ERR_STEP_8 : i2c_application.h
  • I2C_ERR_STEP_9 : i2c_application.h
  • I2C_ERR_STOP : i2c_application.h
  • I2C_ERR_TIMEOUT : i2c_application.h
  • I2C_EVENT_CHECK_ACKFAIL : i2c_application.h
  • I2C_EVENT_CHECK_NONE : i2c_application.h
  • I2C_EVENT_CHECK_STOP : i2c_application.h
  • I2C_EVT_INT : at32f413_i2c.h
  • i2c_evt_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_fast_mode_duty_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_flag_clear() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_flag_get() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_FSMODE_DUTY_16_9 : at32f413_i2c.h
  • I2C_FSMODE_DUTY_2_1 : at32f413_i2c.h
  • i2c_fsmode_duty_cycle_type : at32f413_i2c.h
  • I2C_GCADDRF_FLAG : at32f413_i2c.h
  • i2c_general_call_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_HOSTADDRF_FLAG : at32f413_i2c.h
  • i2c_init() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_INT_MA_RX : i2c_application.h
  • I2C_INT_MA_TX : i2c_application.h
  • I2C_INT_SLA_RX : i2c_application.h
  • I2C_INT_SLA_TX : i2c_application.h
  • i2c_interrupt_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_lowlevel_init() : i2c_application.c, i2c_application.h, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2C_MASTER_ACK_CURRENT : at32f413_i2c.h
  • I2C_MASTER_ACK_NEXT : at32f413_i2c.h
  • i2c_master_ack_type : at32f413_i2c.h
  • i2c_master_read_addr() : i2c_application.c
  • i2c_master_receive() : i2c_application.c, i2c_application.h
  • i2c_master_receive_ack_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_master_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_master_receive_int() : i2c_application.c, i2c_application.h
  • i2c_master_rx_isr_int() : i2c_application.c
  • i2c_master_transmit() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_master_tx_isr_int() : i2c_application.c
  • i2c_master_write_addr() : i2c_application.c
  • i2c_memory_read() : i2c_application.c, i2c_application.h
  • i2c_memory_read_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_read_int() : i2c_application.c, i2c_application.h
  • i2c_memory_write() : i2c_application.c, i2c_application.h
  • i2c_memory_write_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_write_int() : i2c_application.c, i2c_application.h
  • i2c_mode_type : i2c_application.h
  • I2C_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • I2C_OK : i2c_application.h
  • I2C_OUF_FLAG : at32f413_i2c.h
  • i2c_own_address1_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_own_address2_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_own_address2_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_calculate_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_PEC_POSITION_CURRENT : at32f413_i2c.h
  • I2C_PEC_POSITION_NEXT : at32f413_i2c.h
  • i2c_pec_position_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_position_type : at32f413_i2c.h
  • i2c_pec_transmit_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_value_get() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_PECERR_FLAG : at32f413_i2c.h
  • I2C_RDBF_FLAG : at32f413_i2c.h
  • i2c_reset() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_reset_ctrl2_register() : i2c_application.h
  • i2c_slave_receive() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_int() : i2c_application.c, i2c_application.h
  • i2c_slave_rx_isr_int() : i2c_application.c
  • i2c_slave_transmit() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_slave_tx_isr_int() : i2c_application.c
  • I2C_SMBUS_ALERT_HIGH : at32f413_i2c.h
  • I2C_SMBUS_ALERT_LOW : at32f413_i2c.h
  • i2c_smbus_alert_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_smbus_alert_set_type : at32f413_i2c.h
  • i2c_smbus_enable() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_SMBUS_MODE_DEVICE : at32f413_i2c.h
  • I2C_SMBUS_MODE_HOST : at32f413_i2c.h
  • i2c_smbus_mode_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_smbus_mode_set_type : at32f413_i2c.h
  • i2c_software_reset() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_START : i2c_application.c
  • i2c_start_generate() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_STARTF_FLAG : at32f413_i2c.h
  • i2c_status_type : i2c_application.h
  • i2c_stop_flag_clear() : i2c_application.c
  • i2c_stop_generate() : at32f413_i2c.h, at32f413_i2c.c
  • I2C_STOPF_FLAG : at32f413_i2c.h
  • I2C_TDBE_FLAG : at32f413_i2c.h
  • I2C_TDC_FLAG : at32f413_i2c.h
  • I2C_TIMEOUT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2C_TMOUT_FLAG : at32f413_i2c.h
  • I2C_TRMODE_FLAG : at32f413_i2c.h
  • i2c_wait_end() : i2c_application.c, i2c_application.h
  • i2c_wait_flag() : i2c_application.c, i2c_application.h
  • I2Cx_ADDRESS : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_DMA_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_CHANNEL : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_DMA_RX_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_CHANNEL : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_DMA_TX_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_ERR_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_ERR_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_EVT_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_EVT_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_PIN : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_PIN : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SPEED : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • i2s1_buffer_tx : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • I2S1_CK_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_DT_ADDRESS : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO_CRM_CLK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • i2s2_buffer_rx : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • I2S2_CK_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_DT_ADDRESS : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO_CRM_CLK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S_ACS_FLAG : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_11_025K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_16K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_192K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_22_05K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_32K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_44_1K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_48K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_8K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_96K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_DEFAULT : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_LSB : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_MSB : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_LONG : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_SHORT : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PHILLIPS : at32f413_spi.h
  • i2s_audio_protocol_type : at32f413_spi.h
  • i2s_audio_sampling_freq_type : at32f413_spi.h
  • I2S_CLOCK_POLARITY_HIGH : at32f413_spi.h
  • I2S_CLOCK_POLARITY_LOW : at32f413_spi.h
  • i2s_clock_polarity_type : at32f413_spi.h
  • i2s_config() : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • I2S_DATA_16BIT_CHANNEL_16BIT : at32f413_spi.h
  • I2S_DATA_16BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_DATA_24BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_DATA_32BIT_CHANNEL_32BIT : at32f413_spi.h
  • i2s_data_channel_format_type : at32f413_spi.h
  • i2s_default_para_init() : at32f413_spi.h, at32f413_spi.c
  • i2s_enable() : at32f413_spi.h, at32f413_spi.c
  • i2s_init() : at32f413_spi.h, at32f413_spi.c
  • I2S_MODE_MASTER_RX : at32f413_spi.h
  • I2S_MODE_MASTER_TX : at32f413_spi.h
  • I2S_MODE_SLAVE_RX : at32f413_spi.h
  • I2S_MODE_SLAVE_TX : at32f413_spi.h
  • i2s_operation_mode_type : at32f413_spi.h
  • I2S_TUERR_FLAG : at32f413_spi.h
  • IAP_ACK : hid_iap_class.h
  • iap_address() : bootloader/src/hid_iap_user.c
  • iap_clear_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • IAP_CMD_ADDR : hid_iap_class.h
  • IAP_CMD_CRC : hid_iap_class.h
  • IAP_CMD_DATA : hid_iap_class.h
  • IAP_CMD_FINISH : hid_iap_class.h
  • IAP_CMD_GET : hid_iap_class.h
  • IAP_CMD_IDLE : hid_iap_class.h
  • IAP_CMD_JMP : hid_iap_class.h
  • IAP_CMD_START : hid_iap_class.h
  • iap_command_handle() : app_led3_toggle/inc/iap.h, app_led3_toggle/src/iap.c, app_led4_toggle/inc/iap.h, app_led4_toggle/src/iap.c
  • iap_crc() : bootloader/src/hid_iap_user.c
  • iap_data_write() : bootloader/src/hid_iap_user.c
  • iap_erase_sector() : bootloader/src/hid_iap_user.c
  • IAP_FAILED : flash_fat16.h, hid_iap_class.h
  • iap_finish() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_flag : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c
  • iap_get() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_get_upgrade_flag() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_idle() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_info : hid_iap_class.c, hid_iap_class.h
  • iap_init() : app_led3_toggle/inc/iap.h, app_led3_toggle/src/iap.c, app_led4_toggle/inc/iap.h, app_led4_toggle/src/iap.c, app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_jump() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_loop() : bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_machine_state_type : hid_iap_class.h
  • IAP_NACK : hid_iap_class.h
  • iap_respond() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_result_type : hid_iap_class.h
  • IAP_REV_FLAG_5A : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_DONE : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_ERROR : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_NO : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • iap_set_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_start() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • IAP_STS_ADDR : hid_iap_class.h
  • IAP_STS_CRC : hid_iap_class.h
  • IAP_STS_DATA : hid_iap_class.h
  • IAP_STS_FINISH : hid_iap_class.h
  • IAP_STS_IDLE : hid_iap_class.h
  • IAP_STS_JMP : hid_iap_class.h
  • IAP_STS_JMP_WAIT : hid_iap_class.h
  • IAP_STS_START : hid_iap_class.h
  • IAP_SUCCESS : flash_fat16.h, hid_iap_class.h
  • iap_upgrade_app_handle() : bootloader/inc/iap.h, bootloader/src/iap.c
  • IAP_UPGRADE_COMPLETE_FLAG : hid_iap_class.h, flash_fat16.h
  • IAP_UPGRADE_FLAG : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • IAP_UPGRADE_FLAG_ADDR : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • IAP_WAIT : hid_iap_class.h
  • iapfun : bootloader/inc/iap.h
  • ic2value : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c
  • IMG_CONSTANT : julia_fpu.h
  • INCLUDE_uxTaskPriorityGet : FreeRTOSConfig.h
  • INCLUDE_vTaskCleanUpResources : FreeRTOSConfig.h
  • INCLUDE_vTaskDelay : FreeRTOSConfig.h
  • INCLUDE_vTaskDelayUntil : FreeRTOSConfig.h
  • INCLUDE_vTaskDelete : FreeRTOSConfig.h
  • INCLUDE_vTaskPrioritySet : FreeRTOSConfig.h
  • INCLUDE_vTaskSuspend : FreeRTOSConfig.h
  • INCLUDE_xTaskGetCurrentTaskHandle : FreeRTOSConfig.h
  • incrementvar_operationcomplete() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • INT16 : at32f413.h
  • INT32 : at32f413.h
  • INT8 : at32f413.h
  • INTERNAL_FLASH_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • INVAILD_OFFSET_ADDR : flash_fat16.h
  • INVALID_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELD_IN_PARAMETER_LIST : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELED_IN_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • IOMUX : at32f413_gpio.h
  • IOMUX_BASE : at32f413.h
  • IOMUX_MAKE_VALUE : at32f413_gpio.h
  • IRQn : at32f413.h
  • IRQn_Type : at32f413.h
  • is_leap_year() : rtc.c
  • ITERATION : julia_fpu.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- j -

  • jump_to_app : bootloader/src/iap.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- k -

  • KB_TO_B : hid_iap_class.h
  • KEYBOARD_BCD_NUM : keyboard_desc.h
  • KEYBOARD_BINTERVAL_TIME : keyboard_desc.h
  • keyboard_class_handler : keyboard_class.c, keyboard_class.h
  • keyboard_class_setup_handler() : cdc_keyboard_class.c
  • keyboard_desc_handler : keyboard_desc.c, keyboard_desc.h
  • keyboard_send_string() : project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c
  • keyboard_struct : keyboard_class.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • langid_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • LBYTE : usb_std.h
  • LED2 : at32f413_board.h
  • led2_handler : utilities/at32f413_freertos_demo/src/main.c
  • led2_task_function() : utilities/at32f413_freertos_demo/src/main.c
  • LED3 : at32f413_board.h
  • led3_handler : utilities/at32f413_freertos_demo/src/main.c
  • led3_task_function() : utilities/at32f413_freertos_demo/src/main.c
  • LED4 : at32f413_board.h
  • led_gpio_crm_clk : at32f413_board.c
  • led_gpio_pin : at32f413_board.c
  • led_gpio_port : at32f413_board.c
  • LED_NUM : at32f413_board.h
  • led_type : at32f413_board.h
  • LEFT_BUTTON : mouse_class.h
  • LEFT_MOVE : mouse_class.h
  • lickfreq : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • linecoding : cdc_class.c, cdc_msc_class.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • linecoding_vcpkybrd : cdc_keyboard_class.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • main() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c, project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c, project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c, project/at_start_f413/examples/cortex_m4/bit_band/src/main.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f413/examples/cortex_m4/fpu/src/main.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f413/examples/crc/calculation/src/main.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c, project/at_start_f413/examples/crm/sysclk_switch/src/main.c, project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/exint/exint_config/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c, project/at_start_f413/examples/flash/flash_write_read/src/main.c, project/at_start_f413/examples/flash/operate_spim/src/main.c, project/at_start_f413/examples/flash/run_in_spim/src/main.c, project/at_start_f413/examples/gpio/led_toggle/src/main.c, project/at_start_f413/examples/gpio/swjtag_remap/src/main.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c, project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c, project/at_start_f413/examples/pwc/sleep_usart1/src/main.c, project/at_start_f413/examples/pwc/standby_rtc/src/main.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c, project/at_start_f413/examples/rtc/calendar/src/main.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/sram/extend_sram/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/idle_detection/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/irda/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/printf/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/rs485/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f413/examples/wdt/wdt_reset/src/main.c, project/at_start_f413/examples/wdt/wdt_standby/src/main.c, project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c, project/at_start_f413/templates/src/main.c, utilities/at32f413_freertos_demo/src/main.c, utilities/at32f413_gen_random_number_demo/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • MAKE_VALUE : at32f413.h
  • MASTER_BOARD : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • MATCH_ID_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • MAX : usb_std.h
  • max_marks : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • mblock_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mblock_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mclk_tmr1_init() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • MCU_ID1 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID2 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID3 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • mean : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • MEDIUM_HAVE_CHANGED : cdc_msc_class.h, msc_bot_scsi.h
  • MEDIUM_NOT_PRESENT : cdc_msc_class.h, msc_bot_scsi.h
  • MemManage_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • MemoryManagement_IRQn : at32f413.h
  • memset16_buffer() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • MIC_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • mic_dma_buffer : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • MIN : usb_std.h
  • min_marks : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • MISC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • mmc_stream_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • mmc_stream_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mmc_stream_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • mmc_switch() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • MMC_SWITCH_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • mon_table : rtc.c
  • MOUSE_BCD_NUM : mouse_desc.h
  • MOUSE_BINTERVAL_TIME : mouse_desc.h
  • mouse_class_handler : mouse_class.c, mouse_class.h
  • mouse_desc_handler : mouse_desc.c, mouse_desc.h
  • mouse_struct : mouse_class.c
  • MOVE_STEP : mouse_class.h
  • MS_TICK : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c
  • MSC_BCD_NUM : msc_desc.h
  • MSC_BOT_STATE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_RECOVERY : cdc_msc_class.h, msc_bot_scsi.h
  • msc_class_handler : msc_class.c, msc_class.h
  • msc_class_setup_handler() : cdc_msc_class.c
  • MSC_CMD_ALLOW_MEDIUM_REMOVAL : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_FORMAT_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_INQUIRY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE6 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_FORMAT_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_REQUEST_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_START_STOP : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_TEST_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • msc_desc_handler : msc_desc.c, msc_desc.h
  • msc_disk_capacity() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_read() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_write() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_flash_size : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c
  • MSC_MAX_DATA_BUF_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_BO_RESET : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_GET_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_CMD : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_IN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_LAST_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_SEND_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_STATUS : cdc_msc_class.h, msc_bot_scsi.h
  • msc_struct : msc_class.c
  • MSC_SUPPORT_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MULTI_BUFFER_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • my_memset() : arm_fir_init_f32.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- n -

  • NMI_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • NO_BUTTON : at32f413_board.h
  • NonMaskableInt_IRQn : at32f413.h
  • NULL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • NUM_TAPS : fir_coefficient.c, fir_filter.c
  • NUMSTUDENTS : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • numStudents : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • NUMSUBJECTS : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • numSubjects : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • nvic_configuration() : project/at_start_f413/examples/rtc/lick_calibration/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c
  • nvic_irq_disable() : at32f413_misc.h, at32f413_misc.c
  • nvic_irq_enable() : at32f413_misc.h, at32f413_misc.c
  • nvic_lowpower_mode_config() : at32f413_misc.h, at32f413_misc.c
  • nvic_lowpower_mode_type : at32f413_misc.h
  • NVIC_LP_SEVONPEND : at32f413_misc.h
  • NVIC_LP_SLEEPDEEP : at32f413_misc.h
  • NVIC_LP_SLEEPONEXIT : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_0 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_1 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_2 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_3 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_4 : at32f413_misc.h
  • nvic_priority_group_config() : at32f413_misc.h, at32f413_misc.c
  • nvic_priority_group_type : at32f413_misc.h
  • nvic_system_reset() : at32f413_misc.h, at32f413_misc.c
  • nvic_vector_table_set() : at32f413_misc.h, at32f413_misc.c
  • NVIC_VECTTAB_FLASH : at32f413_misc.h
  • NVIC_VECTTAB_RAM : at32f413_misc.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- o -

  • OPERATION_TIMEOUT : at32f413_flash.h
  • operationcomplete : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • ov_cnt : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • PARAMETER_LIST_LENGTH_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • PD01_GMUX : at32f413_gpio.h
  • PD01_MUX : at32f413_gpio.h
  • PendSV_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • PendSV_IRQn : at32f413.h
  • periodvalue : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • PERIPH_BASE : at32f413.h
  • PERIPH_REG : at32f413.h
  • PERIPH_REG_BIT : at32f413.h
  • PERIPHERAL_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_BITBAND_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_RESET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_SET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • pftarget : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • PLL_STABLE_DELAY : system_at32f413.h
  • preempt_conversion_count : project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • preempt_trigger_count : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
  • press_mouse : project/at_start_f413/examples/usb_device/mouse/src/main.c
  • PRINT_UART : at32f413_board.h
  • PRINT_UART_CRM_CLK : at32f413_board.h
  • PRINT_UART_TX_GPIO : at32f413_board.h
  • PRINT_UART_TX_GPIO_CRM_CLK : at32f413_board.h
  • PRINT_UART_TX_PIN : at32f413_board.h
  • PRINTER_BCD_NUM : printer_desc.h
  • printer_class_handler : printer_class.c, printer_class.h
  • printer_desc_handler : printer_desc.c, printer_desc.h
  • PRINTER_DEVICE_ID_LEN : printer_class.h
  • PRINTER_PROTOCOL_1284_4 : printer_desc.h
  • PRINTER_PROTOCOL_BI_DIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_UNIDIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_VENDOR_SPECIFIC : printer_desc.h
  • PRINTER_REQ_GET_DEVICE_ID : printer_class.h
  • PRINTER_REQ_GET_PORT_STATUS : printer_class.h
  • PRINTER_REQ_GET_SOFT_RESET : printer_class.h
  • printer_req_type : printer_class.h
  • printer_struct : printer_class.c
  • PROGRAMMING_TIMEOUT : at32f413_flash.h
  • PUTCHAR_PROTOTYPE : at32f413_board.c
  • pvm_exint_config() : project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c
  • PVM_IRQHandler() : project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c
  • PVM_IRQn : at32f413.h
  • PWC : at32f413_pwc.h
  • PWC_BASE : at32f413.h
  • pwc_battery_powered_domain_access() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_deep_sleep_enter_type : at32f413_pwc.h
  • PWC_DEEP_SLEEP_ENTER_WFE : at32f413_pwc.h
  • PWC_DEEP_SLEEP_ENTER_WFI : at32f413_pwc.h
  • pwc_deep_sleep_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_flag_clear() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_flag_get() : at32f413_pwc.h, at32f413_pwc.c
  • PWC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • pwc_power_voltage_monitor_enable() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_pvm_level_select() : at32f413_pwc.h, at32f413_pwc.c
  • PWC_PVM_OUTPUT_FLAG : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V3 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V4 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V5 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V6 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V7 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V8 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V9 : at32f413_pwc.h
  • pwc_pvm_voltage_type : at32f413_pwc.h
  • PWC_REGULATOR_LOW_POWER : at32f413_pwc.h
  • PWC_REGULATOR_ON : at32f413_pwc.h
  • pwc_regulator_type : at32f413_pwc.h
  • pwc_reset() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_sleep_enter_type : at32f413_pwc.h
  • PWC_SLEEP_ENTER_WFE : at32f413_pwc.h
  • PWC_SLEEP_ENTER_WFI : at32f413_pwc.h
  • pwc_sleep_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • PWC_STANDBY_FLAG : at32f413_pwc.h
  • pwc_standby_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_voltage_regulate_set() : at32f413_pwc.h, at32f413_pwc.c
  • PWC_WAKEUP_FLAG : at32f413_pwc.h
  • PWC_WAKEUP_PIN_1 : at32f413_pwc.h
  • pwc_wakeup_pin_enable() : at32f413_pwc.h, at32f413_pwc.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- r -

  • RAM_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • RAM_BITBAND_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • randnum_test() : random.h, random.c
  • rca : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • read_buffer : operate_spim.c
  • REAL_CONSTANT : julia_fpu.h
  • refOutput : project_l0/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • REG16 : at32f413.h
  • REG32 : at32f413.h
  • REG8 : at32f413.h
  • reg_addr_data : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • report_buf : project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • REQ_SENSE_STANDARD_DATA_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • RESET : at32f413.h
  • Reset_IRQn : at32f413.h
  • result_error() : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • RIGHT_BUTTON : mouse_class.h
  • RIGHT_MOVE : mouse_class.h
  • RS485_BAUDRATE : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_buffer_rx : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_buffer_rx_cnt : project/at_start_f413/examples/usart/rs485/src/main.c
  • RS485_BUFFER_SIZE : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_config() : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_send_data() : project/at_start_f413/examples/usart/rs485/src/main.c
  • RTC : at32f413_rtc.h
  • rtc_alarm_clock_set() : rtc.h, rtc.c
  • rtc_alarm_config() : project/at_start_f413/examples/pwc/standby_rtc/src/main.c
  • rtc_alarm_set() : at32f413_rtc.h, at32f413_rtc.c
  • RTC_BASE : at32f413.h
  • RTC_CFGF_FLAG : at32f413_rtc.h
  • rtc_config() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/pwc/standby_rtc/src/main.c
  • rtc_configuration() : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • rtc_counter_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_counter_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_divider_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_divider_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_flag_clear() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_flag_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_init() : rtc.h, rtc.c
  • rtc_interrupt_enable() : at32f413_rtc.h, at32f413_rtc.c
  • RTC_IRQHandler() : project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • RTC_IRQn : at32f413.h
  • RTC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • RTC_OVF_FLAG : at32f413_rtc.h
  • RTC_OVF_INT : at32f413_rtc.h
  • RTC_TA_FLAG : at32f413_rtc.h
  • RTC_TA_INT : at32f413_rtc.h
  • rtc_time_get() : rtc.h, rtc.c
  • rtc_time_set() : rtc.h, rtc.c
  • RTC_TS_FLAG : at32f413_rtc.h
  • RTC_TS_INT : at32f413_rtc.h
  • RTC_UPDF_FLAG : at32f413_rtc.h
  • rtc_wait_config_finish() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_wait_update_finish() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_week_get() : rtc.c
  • RTCAlarm_IRQHandler() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c
  • RTCAlarm_IRQn : at32f413.h
  • rx_buf : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • rx_buf1 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buf2 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buf3 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buffer : project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c
  • rx_counter : project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • rx_index : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • s16 : at32f413.h
  • s32 : at32f413.h
  • s8 : at32f413.h
  • SAMPLE_FREQ : audio_desc.h, audio_hid_desc.h
  • SAMPLING_NUM : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • sblock_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sblock_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sc16 : at32f413.h
  • sc32 : at32f413.h
  • sc8 : at32f413.h
  • SC_3_5V_CLK : smartcard_config.h
  • SC_3_5V_PIN : smartcard_config.h
  • SC_3_5V_PORT : smartcard_config.h
  • sc_a2r_struct : project/at_start_f413/examples/usart/smartcard/src/main.c
  • sc_baud_rate : project/at_start_f413/examples/usart/smartcard/src/main.c
  • sc_clock_freq : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_CMDVCC_CLK : smartcard_config.h
  • SC_CMDVCC_PIN : smartcard_config.h
  • SC_CMDVCC_PORT : smartcard_config.h
  • SC_F_DIV_D : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_OFF_CLK : smartcard_config.h
  • SC_OFF_EXINT : smartcard_config.h
  • SC_OFF_EXINT_IRQ : smartcard_config.h
  • SC_OFF_PIN : smartcard_config.h
  • SC_OFF_PINSOURCE : smartcard_config.h
  • SC_OFF_PORT : smartcard_config.h
  • SC_OFF_PORTSOURCE : smartcard_config.h
  • SC_RECEIVE_TIMEOUT : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_RESET_CLK : smartcard_config.h
  • SC_RESET_PIN : smartcard_config.h
  • SC_RESET_PORT : smartcard_config.h
  • sc_response_decode() : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_USART : smartcard_config.h
  • SC_USART_CLK : smartcard_config.h
  • SC_USART_CLK_PIN : smartcard_config.h
  • SC_USART_CLK_PORT : smartcard_config.h
  • SC_USART_DIV_VAL : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_USART_GPIO_CLK : smartcard_config.h
  • SC_USART_IRQHandler : smartcard_config.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
  • SC_USART_IRQn : smartcard_config.h
  • SC_USART_TX_PIN : smartcard_config.h
  • SC_USART_TX_PORT : smartcard_config.h
  • sclk_192m_hick_config() : project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
  • sclk_64m_hick_config() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • sclk_96m_hext_config() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • SCLK_FROM_HICK : project/at_start_f413/examples/acc/calibration/src/main.c
  • scr_find() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SCREEN_X_SIZE : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • SCREEN_Y_SIZE : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • scsi_inquiry : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c, virtual_msc_iap/src/msc_diskio.c
  • SCSI_INQUIRY_DATA_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • SD_0TO7BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_16TO23BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_24TO31BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_8TO15BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ADDR_MISALIGNED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ADDR_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_AKE_SEQ_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ALLZERO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_BLK_LEN_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_block_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_block_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_blocks_erase() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_bus_wide_enable() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SD_CARD_CONTROLLER_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_DISCONNECTED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_IDENTIFICATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_card_info : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_card_info_get() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_card_init() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_CARD_LOCKED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_PROGRAMMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h, sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_READY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_RECEIVING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h, sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_SENDING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_STANDBY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_card_state_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_TRANSFER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_LOCK_UNLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CHECK_PATTERN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CID_CSD_OVERWRITE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ALL_SEND_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_SD_SET_BUSWIDTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CLR_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_END : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_START : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAIL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAST_IO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GEN_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IDLE_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_INACTIVE_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IRQ_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_READ : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_WRITE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SEND_EXT_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SWITCH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_LOCK_UNLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_NO_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_DAT_UNTIL_STOP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_MULT_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_SINGLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_RSP_TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_CHANGE_SECURE_AREA : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RES1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RN2 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MKB : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MKB : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_SCR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RES2 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RN1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CLR_CARD_DETECT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_STAUS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_END : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_START : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_DIRECT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_EXTENDED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_SEN_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEL_DESEL_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_STATUS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCK_COUNT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCKLEN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_DSR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_REL_ADDR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_STOP_TRANSMISSION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_DAT_UNTIL_STOP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_MULT_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_SINGLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_FAIL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_data_transfer_mode_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATATIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_deselect_select() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_device_mode_set() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_dma_config() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_ERASE_RESET : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERASE_SEQ_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_error_status_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFOBYTES : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HIGH_CAPACITY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_init() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_INTERNAL_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_ERASE_PARAM : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_PARAMETER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_VOLTRANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_irq_service() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_LOCK_UNLOCK_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • SD_MAX_DATA_LENGTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_MAX_VOLT_TRIAL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_memory_card_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_mult_blocks_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_mult_blocks_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_multiple_blocks_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • SD_NOT_CONFIGURED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_MISALIGNED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_AKE_SEQ_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_BLK_LEN_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_CONTROLLER_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CID_CSD_OVERWRIETE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_RESET : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_SEQ_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERRORBITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_INVALID_ERASE_PARAM : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_LOCK_UNLOCK_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_RD_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_WR_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WP_ERASE_SKIP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WR_PROTECT_VIOLATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_power_off() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_power_on() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_R5_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_FUNCTION_NUMBER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_NOT_APPLICABLE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_PENDING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_RX_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_BUSY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_UNKNOWN_FUNC : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_single_block_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • SD_SINGLE_BUS_SUPPORT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_START_BIT_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_state_get() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_status_send() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_STD_CAPACITY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_RD_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_WR_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_switch() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SD_SWITCH_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_test_error() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • SD_TRANSFER_DMA_MODE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TRANSFER_POLLING_MODE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TX_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_FEATURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_HW : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_MMC : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_SD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_wide_bus_operation_config() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SD_WIDE_BUS_SUPPORT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WP_ERASE_SKIP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WR_PROTECT_VIOLATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_write_disk() : diskio.c
  • SDIO1 : at32f413_sdio.h
  • SDIO1_BASE : at32f413.h
  • SDIO1_GMUX_0100 : at32f413_gpio.h
  • SDIO1_GMUX_0101 : at32f413_gpio.h
  • SDIO1_GMUX_0110 : at32f413_gpio.h
  • SDIO1_GMUX_0111 : at32f413_gpio.h
  • SDIO1_IRQHandler() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SDIO1_IRQn : at32f413.h
  • SDIO2_IRQHandler() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_block_size_type : at32f413_sdio.h
  • sdio_buffer_counter_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_bus_width_config() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_BUS_WIDTH_D1 : at32f413_sdio.h
  • SDIO_BUS_WIDTH_D4 : at32f413_sdio.h
  • SDIO_BUS_WIDTH_D8 : at32f413_sdio.h
  • sdio_bus_width_type : at32f413_sdio.h
  • sdio_clock_bypass() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_config() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_CLOCK_EDGE_FALLING : at32f413_sdio.h
  • SDIO_CLOCK_EDGE_RISING : at32f413_sdio.h
  • sdio_clock_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_set() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • SDIO_CMD0TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_CMDCMPL_FLAG : at32f413_sdio.h
  • SDIO_CMDCMPL_INT : at32f413_sdio.h
  • SDIO_CMDFAIL_FLAG : at32f413_sdio.h
  • SDIO_CMDFAIL_INT : at32f413_sdio.h
  • SDIO_CMDRSPCMPL_FLAG : at32f413_sdio.h
  • SDIO_CMDRSPCMPL_INT : at32f413_sdio.h
  • SDIO_CMDTIMEOUT_FLAG : at32f413_sdio.h
  • SDIO_CMDTIMEOUT_INT : at32f413_sdio.h
  • sdio_command_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_command_data_send() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_command_init_struct : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_command_response_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_command_state_machine_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_DATA_BLOCK_SIZE_1024B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_128B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16384B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_1B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2048B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_256B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_32B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4096B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_512B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_64B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8192B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_TRANSFER : at32f413_sdio.h
  • sdio_data_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_counter_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_init_struct : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_data_read() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_state_machine_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_DATA_STREAM_TRANSFER : at32f413_sdio.h
  • SDIO_DATA_TRANSFER_TO_CARD : at32f413_sdio.h
  • SDIO_DATA_TRANSFER_TO_CONTROLLER : at32f413_sdio.h
  • sdio_data_write() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_DATATIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_dma_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_DOCMD_FLAG : at32f413_sdio.h
  • SDIO_DOCMD_INT : at32f413_sdio.h
  • SDIO_DORX_FLAG : at32f413_sdio.h
  • SDIO_DORX_INT : at32f413_sdio.h
  • SDIO_DOTX_FLAG : at32f413_sdio.h
  • SDIO_DOTX_INT : at32f413_sdio.h
  • SDIO_DTBLKCMPL_FLAG : at32f413_sdio.h
  • SDIO_DTBLKCMPL_INT : at32f413_sdio.h
  • SDIO_DTCMP_INT : at32f413_sdio.h
  • SDIO_DTCMPL_FLAG : at32f413_sdio.h
  • SDIO_DTFAIL_FLAG : at32f413_sdio.h
  • SDIO_DTFAIL_INT : at32f413_sdio.h
  • SDIO_DTTIMEOUT_FLAG : at32f413_sdio.h
  • SDIO_DTTIMEOUT_INT : at32f413_sdio.h
  • sdio_edge_phase_type : at32f413_sdio.h
  • SDIO_FIFO_Address : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_flag_clear() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flag_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flow_control_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_HIGH_CAPACITY_MMC_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_CAPACITY_SD_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_SPEED_MULTIMEDIA_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_interrupt_enable() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_INTR_STS_READ_MASK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_INTR_STS_WRITE_MASK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_io_function_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_io_suspend_command_set() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • SDIO_MULTIMEDIA_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_POWER_OFF : at32f413_sdio.h
  • SDIO_POWER_ON : at32f413_sdio.h
  • sdio_power_saving_mode_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_state_type : at32f413_sdio.h
  • sdio_power_status_get() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_READ_WAIT_CONTROLLED_BY_CK : at32f413_sdio.h
  • SDIO_READ_WAIT_CONTROLLED_BY_D2 : at32f413_sdio.h
  • sdio_read_wait_mode_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_mode_type : at32f413_sdio.h
  • sdio_read_wait_start() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_stop() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_reponse_type : at32f413_sdio.h
  • sdio_reset() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_response_get() : at32f413_sdio.h, at32f413_sdio.c
  • SDIO_RESPONSE_LONG : at32f413_sdio.h
  • SDIO_RESPONSE_NO : at32f413_sdio.h
  • SDIO_RESPONSE_SHORT : at32f413_sdio.h
  • SDIO_RSP1_INDEX : at32f413_sdio.h
  • SDIO_RSP2_INDEX : at32f413_sdio.h
  • SDIO_RSP3_INDEX : at32f413_sdio.h
  • SDIO_RSP4_INDEX : at32f413_sdio.h
  • sdio_rsp_index_type : at32f413_sdio.h
  • SDIO_RXBUF_FLAG : at32f413_sdio.h
  • SDIO_RXBUF_INT : at32f413_sdio.h
  • SDIO_RXBUFE_FLAG : at32f413_sdio.h
  • SDIO_RXBUFE_INT : at32f413_sdio.h
  • SDIO_RXBUFF_FLAG : at32f413_sdio.h
  • SDIO_RXBUFF_INT : at32f413_sdio.h
  • SDIO_RXBUFH_FLAG : at32f413_sdio.h
  • SDIO_RXBUFH_INT : at32f413_sdio.h
  • SDIO_RXERRO_FLAG : at32f413_sdio.h
  • SDIO_RXERRO_INT : at32f413_sdio.h
  • SDIO_SBITERR_FLAG : at32f413_sdio.h
  • SDIO_SBITERR_INT : at32f413_sdio.h
  • SDIO_SDIO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SDIOIF_FLAG : at32f413_sdio.h
  • SDIO_SDIOIF_INT : at32f413_sdio.h
  • SDIO_SECURE_DIGITAL_IO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SECURE_DIGITAL_IO_COMBO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SEND_IF_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STATIC_FLAGS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V1_1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V2_0 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_transfer_direction_type : at32f413_sdio.h
  • sdio_transfer_mode_type : at32f413_sdio.h
  • SDIO_TXBUF_FLAG : at32f413_sdio.h
  • SDIO_TXBUF_INT : at32f413_sdio.h
  • SDIO_TXBUFE_FLAG : at32f413_sdio.h
  • SDIO_TXBUFE_INT : at32f413_sdio.h
  • SDIO_TXBUFF_FLAG : at32f413_sdio.h
  • SDIO_TXBUFF_INT : at32f413_sdio.h
  • SDIO_TXBUFH_FLAG : at32f413_sdio.h
  • SDIO_TXBUFH_INT : at32f413_sdio.h
  • SDIO_TXERRU_FLAG : at32f413_sdio.h
  • SDIO_TXERRU_INT : at32f413_sdio.h
  • SDIO_WAIT_FOR_INT : at32f413_sdio.h
  • SDIO_WAIT_FOR_NO : at32f413_sdio.h
  • SDIO_WAIT_FOR_PEND : at32f413_sdio.h
  • sdio_wait_type : at32f413_sdio.h
  • SDIOx : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SECTOR_NUM : utilities/at32f413_slib_demo/project_l0/src/main.c
  • sector_read() : operate_spim.c
  • SECTOR_SIZE : project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • sector_size : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c
  • SECTOR_SIZE_1K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_SIZE_2K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_SIZE_4K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_WORD_CNT : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SENSE_KEY_ABORTED_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_BLANK_CHECK : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_DATA_PROTECT : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_HARDWARE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_ILLEGAL_REQUEST : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MEDIUM_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MISCOMPARE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NO_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NOT_READY : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_RECOVERED_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_UNIT_ATTENTION : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VENDERO_SPECIFIC : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VOLUME_OVERFLOW : cdc_msc_class.h, msc_bot_scsi.h
  • serial_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • SET : at32f413.h
  • SET_LINE_CODING : cdc_msc_class.h, msc_bot_scsi.h, usb_std.h
  • SETUP_LENGTH : project/at_start_f413/examples/usart/smartcard/src/main.c
  • setvar_periodvalue() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • SHIFT : cdc_keyboard_class.c, keyboard_class.c
  • show_card_info() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • SLIB_DATA_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • slib_enable() : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_END_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_START_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_UNLOCK_KEY : at32f413_flash.h
  • SLOW : project/at_start_f413/templates/src/main.c
  • SNR_THRESHOLD_F32 : utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • speed_change() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SPI1 : at32f413_spi.h
  • SPI1_BASE : at32f413.h
  • spi1_buffer_tx : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • SPI1_GMUX_0001 : at32f413_gpio.h
  • SPI1_IRQHandler() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • SPI1_IRQn : at32f413.h
  • SPI1_MUX_01 : at32f413_gpio.h
  • spi1_rx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • spi1_tx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • SPI2 : at32f413_spi.h
  • SPI2_BASE : at32f413.h
  • spi2_buffer_rx : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • SPI2_GMUX_0001 : at32f413_gpio.h
  • SPI2_IRQHandler() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • SPI2_IRQn : at32f413.h
  • spi2_rx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_rx_counter : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_buffer_size : project/at_start_f413/examples/usart/synchronous/src/main.c
  • SPI2_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_counter : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi_byte_read() : spi_flash.h, spi_flash.c
  • spi_byte_write() : spi_flash.h, spi_flash.c
  • spi_bytes_read() : spi_flash.h, spi_flash.c
  • spi_bytes_write() : spi_flash.h, spi_flash.c
  • SPI_CCERR_FLAG : at32f413_spi.h
  • SPI_CLOCK_PHASE_1EDGE : at32f413_spi.h
  • SPI_CLOCK_PHASE_2EDGE : at32f413_spi.h
  • spi_clock_phase_type : at32f413_spi.h
  • SPI_CLOCK_POLARITY_HIGH : at32f413_spi.h
  • SPI_CLOCK_POLARITY_LOW : at32f413_spi.h
  • spi_clock_polarity_type : at32f413_spi.h
  • spi_config() : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi_crc_direction_type : at32f413_spi.h
  • spi_crc_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_next_transmit() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_polynomial_get() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_polynomial_set() : at32f413_spi.h, at32f413_spi.c
  • SPI_CRC_RX : at32f413_spi.h
  • SPI_CRC_TX : at32f413_spi.h
  • spi_crc_value_get() : at32f413_spi.h, at32f413_spi.c
  • SPI_CS_HARDWARE_MODE : at32f413_spi.h
  • spi_cs_mode_type : at32f413_spi.h
  • SPI_CS_SOFTWARE_MODE : at32f413_spi.h
  • spi_default_para_init() : at32f413_spi.h, at32f413_spi.c
  • spi_enable() : at32f413_spi.h, at32f413_spi.c
  • SPI_FIRST_BIT_LSB : at32f413_spi.h
  • SPI_FIRST_BIT_MSB : at32f413_spi.h
  • spi_first_bit_type : at32f413_spi.h
  • SPI_FLASH_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • SPI_FRAME_16BIT : at32f413_spi.h
  • SPI_FRAME_8BIT : at32f413_spi.h
  • spi_frame_bit_num_set() : at32f413_spi.h, at32f413_spi.c
  • spi_frame_bit_num_type : at32f413_spi.h
  • SPI_HALF_DUPLEX_DIRECTION_RX : at32f413_spi.h
  • spi_half_duplex_direction_set() : at32f413_spi.h, at32f413_spi.c
  • SPI_HALF_DUPLEX_DIRECTION_TX : at32f413_spi.h
  • spi_half_duplex_direction_type : at32f413_spi.h
  • spi_hardware_cs_output_enable() : at32f413_spi.h, at32f413_spi.c
  • SPI_I2S_BF_FLAG : at32f413_spi.h
  • spi_i2s_data_receive() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_data_transmit() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_dma_receiver_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_dma_transmitter_enable() : at32f413_spi.h, at32f413_spi.c
  • SPI_I2S_ERROR_INT : at32f413_spi.h
  • spi_i2s_flag_clear() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_flag_get() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_interrupt_enable() : at32f413_spi.h, at32f413_spi.c
  • SPI_I2S_RDBF_FLAG : at32f413_spi.h
  • SPI_I2S_RDBF_INT : at32f413_spi.h
  • spi_i2s_reset() : at32f413_spi.h, at32f413_spi.c
  • SPI_I2S_ROERR_FLAG : at32f413_spi.h
  • SPI_I2S_TDBE_FLAG : at32f413_spi.h
  • SPI_I2S_TDBE_INT : at32f413_spi.h
  • spi_init() : at32f413_spi.h, at32f413_spi.c
  • spi_init_struct : project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c
  • spi_master_slave_mode_type : at32f413_spi.h
  • SPI_MCLK_DIV_1024 : at32f413_spi.h
  • SPI_MCLK_DIV_128 : at32f413_spi.h
  • SPI_MCLK_DIV_16 : at32f413_spi.h
  • SPI_MCLK_DIV_2 : at32f413_spi.h
  • SPI_MCLK_DIV_256 : at32f413_spi.h
  • SPI_MCLK_DIV_32 : at32f413_spi.h
  • SPI_MCLK_DIV_4 : at32f413_spi.h
  • SPI_MCLK_DIV_512 : at32f413_spi.h
  • SPI_MCLK_DIV_64 : at32f413_spi.h
  • SPI_MCLK_DIV_8 : at32f413_spi.h
  • spi_mclk_freq_div_type : at32f413_spi.h
  • SPI_MMERR_FLAG : at32f413_spi.h
  • SPI_MODE_MASTER : at32f413_spi.h
  • SPI_MODE_SLAVE : at32f413_spi.h
  • SPI_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • spi_software_cs_internal_level_set() : at32f413_spi.h, at32f413_spi.c
  • spi_software_cs_level_type : at32f413_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT : at32f413_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_LOW : at32f413_spi.h
  • SPI_TRANS_DMA : spi_flash.h
  • spi_transmission_mode_type : at32f413_spi.h
  • SPI_TRANSMIT_FULL_DUPLEX : at32f413_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_RX : at32f413_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_TX : at32f413_spi.h
  • SPI_TRANSMIT_SIMPLEX_RX : at32f413_spi.h
  • SPIF_BLOCKERASE : spi_flash.h
  • SPIF_CHIP_SIZE : spi_flash.h
  • SPIF_CHIPERASE : spi_flash.h
  • SPIF_DEVICEID : spi_flash.h
  • SPIF_FASTREADDATA : spi_flash.h
  • SPIF_FASTREADDUAL : spi_flash.h
  • SPIF_JEDECDEVICEID : spi_flash.h
  • SPIF_MANUFACTDEVICEID : spi_flash.h
  • SPIF_PAGE_SIZE : spi_flash.h
  • SPIF_PAGEPROGRAM : spi_flash.h
  • SPIF_POWERDOWN : spi_flash.h
  • SPIF_READDATA : spi_flash.h
  • SPIF_READSTATUSREG1 : spi_flash.h
  • SPIF_READSTATUSREG2 : spi_flash.h
  • SPIF_READSTATUSREG3 : spi_flash.h
  • SPIF_RELEASEPOWERDOWN : spi_flash.h
  • SPIF_SECTOR_SIZE : spi_flash.h
  • SPIF_SECTORERASE : spi_flash.h
  • SPIF_WRITEDISABLE : spi_flash.h
  • SPIF_WRITEENABLE : spi_flash.h
  • SPIF_WRITESTATUSREG1 : spi_flash.h
  • SPIF_WRITESTATUSREG2 : spi_flash.h
  • SPIF_WRITESTATUSREG3 : spi_flash.h
  • spiflash_init() : spi_flash.h, spi_flash.c
  • spiflash_page_write() : spi_flash.h, spi_flash.c
  • spiflash_read() : spi_flash.h, spi_flash.c
  • spiflash_read_id() : spi_flash.h, spi_flash.c
  • spiflash_read_sr1() : spi_flash.h, spi_flash.c
  • spiflash_sector_buf : spi_flash.c
  • spiflash_sector_erase() : spi_flash.h, spi_flash.c
  • spiflash_wait_busy() : spi_flash.h, spi_flash.c
  • spiflash_write() : spi_flash.h, spi_flash.c
  • spiflash_write_enable() : spi_flash.h, spi_flash.c
  • spiflash_write_nocheck() : spi_flash.h, spi_flash.c
  • SPIM_ERASE_TIMEOUT : at32f413_flash.h
  • SPIM_FLASH_BASE : at32f413.h
  • spim_init() : operate_spim.c, project/at_start_f413/examples/flash/run_in_spim/src/main.c
  • spim_operate() : operate_spim.h, operate_spim.c
  • SPIM_PROGRAMMING_TIMEOUT : at32f413_flash.h
  • spim_run() : run_in_spim.h
  • SPIM_SECTOR_SIZE : operate_spim.h
  • SPIM_TEST_ADDR : operate_spim.h
  • SPK_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • spk_dma_buffer : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • SPK_TX_FIFO_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • SRAM_BASE : at32f413.h
  • SRAM_SIZE : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
  • src_buffer : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • src_const_buffer : project/at_start_f413/examples/dma/flash_to_sram/src/main.c
  • std : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • step : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • STEP_DELAY_MS : at32f413_board.c
  • stop_flag : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • STREAM_BUFFER_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • stream_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • stream_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • student_num : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • sub_tmr_input_sel_type : at32f413_tmr.h
  • SUCCESS : at32f413.h
  • SVC_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • SVCall_IRQn : at32f413.h
  • SWAPBYTE : usb_std.h
  • switch_system_clock() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • swj_dp_config() : project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
  • SWJTAG_CONF_001 : at32f413_gpio.h
  • SWJTAG_CONF_010 : at32f413_gpio.h
  • SWJTAG_CONF_100 : at32f413_gpio.h
  • SWJTAG_GMUX_001 : at32f413_gpio.h
  • SWJTAG_GMUX_010 : at32f413_gpio.h
  • SWJTAG_GMUX_100 : at32f413_gpio.h
  • sys_counter : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • system_clock_config() : project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h, project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c, project/at_start_f413/examples/can/filter/inc/at32f413_clock.h, project/at_start_f413/examples/can/filter/src/at32f413_clock.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h, project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c, project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h, project/at_start_f413/examples/usart/irda/src/at32f413_clock.c, project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h, project/at_start_f413/examples/usart/polling/src/at32f413_clock.c, project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h, project/at_start_f413/examples/usart/printf/src/at32f413_clock.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h, project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c, project/at_start_f413/templates/inc/at32f413_clock.h, project/at_start_f413/templates/src/at32f413_clock.c, utilities/at32f413_freertos_demo/inc/at32f413_clock.h, utilities/at32f413_freertos_demo/src/at32f413_clock.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h, utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c
  • system_clock_config_for_acc() : project/at_start_f413/examples/acc/calibration/src/main.c
  • system_clock_recover() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • system_core_clock : system_at32f413.c, system_at32f413.h
  • system_core_clock_update() : system_at32f413.c, system_at32f413.h
  • SystemInit() : system_at32f413.c, system_at32f413.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 : at32f413_misc.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV : at32f413_misc.h
  • systick_clock_source_config() : at32f413_misc.h, at32f413_misc.c
  • systick_clock_source_type : at32f413_misc.h
  • systick_configuration() : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • systick_handler() : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c
  • SysTick_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • SysTick_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • T0_PROTOCOL : project/at_start_f413/examples/usart/smartcard/src/main.c
  • table_week : rtc.c
  • TAMPER_IRQHandler() : project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c
  • TAMPER_IRQn : at32f413.h
  • temp_buf : utilities/at32f413_slib_demo/project_l0/src/main.c
  • TEST_BUFEER_SIZE : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • TEST_FLASH_ADDRESS_START : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • TEST_LENGTH_SAMPLES : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • test_result : project/at_start_f413/examples/can/filter/src/main.c
  • TEST_SLIB_PSW : utilities/at32f413_slib_demo/project_l0/src/main.c
  • testInput_f32_1kHz_15kHz : project_l0/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • testMarks_f32 : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • testOutput : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • testUnity_f32 : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • time_cnt : project/at_start_f413/examples/usart/printf/src/main.c
  • time_ira_cnt : bootloader/inc/tmr.h, bootloader/src/tmr.c
  • timer_period : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • tmpCC4 : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • TMR1 : at32f413_tmr.h
  • TMR10 : at32f413_tmr.h
  • TMR10_BASE : at32f413.h
  • TMR10_GMUX : at32f413_gpio.h
  • TMR11 : at32f413_tmr.h
  • TMR11_BASE : at32f413.h
  • TMR11_GMUX : at32f413_gpio.h
  • TMR1_BASE : at32f413.h
  • TMR1_BRK_TMR9_IRQHandler() : project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c
  • TMR1_BRK_TMR9_IRQn : at32f413.h
  • TMR1_C1DT_ADDRESS : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR1_C2DT_ADDRESS : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR1_CH_IRQn : at32f413.h
  • tmr1_config() : project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • TMR1_GMUX_0001 : at32f413_gpio.h
  • TMR1_MUX_01 : at32f413_gpio.h
  • TMR1_OVF_TMR10_IRQHandler() : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • TMR1_OVF_TMR10_IRQn : at32f413.h
  • TMR1_TRG_HALL_TMR11_IRQHandler() : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • TMR1_TRG_HALL_TMR11_IRQn : at32f413.h
  • TMR2 : at32f413_tmr.h
  • TMR2_BASE : at32f413.h
  • tmr2_config() : project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c
  • TMR2_GLOBAL_IRQHandler() : project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
  • TMR2_GLOBAL_IRQn : at32f413.h
  • TMR2_GMUX_001 : at32f413_gpio.h
  • TMR2_GMUX_010 : at32f413_gpio.h
  • TMR2_GMUX_011 : at32f413_gpio.h
  • TMR2_MUX_01 : at32f413_gpio.h
  • TMR2_MUX_10 : at32f413_gpio.h
  • TMR2_MUX_11 : at32f413_gpio.h
  • TMR2ITR1_GMUX : at32f413_gpio.h
  • TMR3 : at32f413_tmr.h
  • TMR3_BASE : at32f413.h
  • TMR3_GLOBAL_IRQHandler() : project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, app_led3_toggle/src/tmr.c, app_led4_toggle/src/tmr.c, bootloader/src/tmr.c
  • TMR3_GLOBAL_IRQn : at32f413.h
  • TMR3_GMUX_0010 : at32f413_gpio.h
  • TMR3_GMUX_0011 : at32f413_gpio.h
  • TMR3_MUX_10 : at32f413_gpio.h
  • TMR3_MUX_11 : at32f413_gpio.h
  • tmr3freq : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • TMR4 : at32f413_tmr.h
  • TMR4_BASE : at32f413.h
  • TMR4_GLOBAL_IRQn : at32f413.h
  • TMR5 : at32f413_tmr.h
  • TMR5_BASE : at32f413.h
  • TMR5_GLOBAL_IRQHandler() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • TMR5_GLOBAL_IRQn : at32f413.h
  • TMR5_GMUX_001 : at32f413_gpio.h
  • TMR5CH4_GMUX : at32f413_gpio.h
  • TMR5CH4_MUX : at32f413_gpio.h
  • TMR8 : at32f413_tmr.h
  • TMR8_BASE : at32f413.h
  • TMR8_BRK_IRQn : at32f413.h
  • TMR8_CH_IRQn : at32f413.h
  • TMR8_OVF_IRQn : at32f413.h
  • TMR8_TRG_HALL_IRQn : at32f413.h
  • TMR9 : at32f413_tmr.h
  • TMR9_BASE : at32f413.h
  • TMR9_GMUX : at32f413_gpio.h
  • tmr_32_bit_function_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_base_init() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_BRK_ADDRESS : at32f413_tmr.h
  • TMR_BRK_FLAG : at32f413_tmr.h
  • TMR_BRK_INPUT_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_BRK_INPUT_ACTIVE_LOW : at32f413_tmr.h
  • TMR_BRK_INT : at32f413_tmr.h
  • tmr_brk_polarity_type : at32f413_tmr.h
  • TMR_BRK_SWTRIG : at32f413_tmr.h
  • tmr_brkdt_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_brkdt_config_struct : project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • tmr_brkdt_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_C1_DMA_REQUEST : at32f413_tmr.h
  • TMR_C1_FLAG : at32f413_tmr.h
  • TMR_C1_INT : at32f413_tmr.h
  • TMR_C1_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C1_SWTRIG : at32f413_tmr.h
  • TMR_C1DT_ADDRESS : at32f413_tmr.h
  • TMR_C2_DMA_REQUEST : at32f413_tmr.h
  • TMR_C2_FLAG : at32f413_tmr.h
  • TMR_C2_INT : at32f413_tmr.h
  • TMR_C2_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C2_SWTRIG : at32f413_tmr.h
  • TMR_C2DT_ADDRESS : at32f413_tmr.h
  • TMR_C3_DMA_REQUEST : at32f413_tmr.h
  • TMR_C3_FLAG : at32f413_tmr.h
  • TMR_C3_INT : at32f413_tmr.h
  • TMR_C3_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C3_SWTRIG : at32f413_tmr.h
  • TMR_C3DT_ADDRESS : at32f413_tmr.h
  • TMR_C4_DMA_REQUEST : at32f413_tmr.h
  • TMR_C4_FLAG : at32f413_tmr.h
  • TMR_C4_INT : at32f413_tmr.h
  • TMR_C4_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C4_SWTRIG : at32f413_tmr.h
  • TMR_C4DT_ADDRESS : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_DIRECT : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_INDIRECT : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_STI : at32f413_tmr.h
  • TMR_CCTRL_ADDRESS : at32f413_tmr.h
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR : at32f413_tmr.h
  • TMR_CHANEL1_CONNECTED_C1IRAW : at32f413_tmr.h
  • tmr_channel1_input_connected_type : at32f413_tmr.h
  • tmr_channel1_input_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_dma_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_enable() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_CHANNEL_INPUT_DIV_1 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_2 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_4 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_8 : at32f413_tmr.h
  • tmr_channel_input_divider_type : at32f413_tmr.h
  • tmr_channel_select_type : at32f413_tmr.h
  • tmr_channel_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_CLOCK_DIV1 : at32f413_tmr.h
  • TMR_CLOCK_DIV2 : at32f413_tmr.h
  • TMR_CLOCK_DIV4 : at32f413_tmr.h
  • tmr_clock_division_type : at32f413_tmr.h
  • tmr_clock_source_div_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_CM1_ADDRESS : at32f413_tmr.h
  • TMR_CM2_ADDRESS : at32f413_tmr.h
  • tmr_cnt_dir_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_COUNT_DOWN : at32f413_tmr.h
  • tmr_count_mode_type : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_1 : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_2 : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_3 : at32f413_tmr.h
  • TMR_COUNT_UP : at32f413_tmr.h
  • tmr_counter_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_CTRL1_ADDRESS : at32f413_tmr.h
  • TMR_CTRL2_ADDRESS : at32f413_tmr.h
  • TMR_CVAL_ADDRESS : at32f413_tmr.h
  • TMR_DIV_ADDRESS : at32f413_tmr.h
  • tmr_div_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_div_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_dma_address_type : at32f413_tmr.h
  • tmr_dma_control_config() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_DMA_REQUEST_BY_CHANNEL : at32f413_tmr.h
  • TMR_DMA_REQUEST_BY_OVERFLOW : at32f413_tmr.h
  • tmr_dma_request_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_dma_request_source_type : at32f413_tmr.h
  • tmr_dma_request_type : at32f413_tmr.h
  • TMR_DMA_TRANSFER_10BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_11BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_12BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_13BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_14BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_15BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_16BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_17BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_18BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_1BYTE : at32f413_tmr.h
  • TMR_DMA_TRANSFER_2BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_3BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_4BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_5BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_6BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_7BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_8BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_9BYTES : at32f413_tmr.h
  • tmr_dma_transfer_length_type : at32f413_tmr.h
  • TMR_DMACTRL_ADDRESS : at32f413_tmr.h
  • TMR_ENCODER_MODE_A : at32f413_tmr.h
  • TMR_ENCODER_MODE_B : at32f413_tmr.h
  • TMR_ENCODER_MODE_C : at32f413_tmr.h
  • tmr_encoder_mode_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_encoder_mode_type : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_1 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_2 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_4 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_8 : at32f413_tmr.h
  • TMR_ES_POLARITY_INVERTED : at32f413_tmr.h
  • TMR_ES_POLARITY_NON_INVERTED : at32f413_tmr.h
  • tmr_event_sw_trigger() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_event_trigger_type : at32f413_tmr.h
  • tmr_external_clock_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_mode1_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_mode2_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_signal_divider_type : at32f413_tmr.h
  • tmr_external_signal_polarity_type : at32f413_tmr.h
  • tmr_flag_clear() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_flag_get() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_FORCE_OUTPUT_HIGH : at32f413_tmr.h
  • TMR_FORCE_OUTPUT_LOW : at32f413_tmr.h
  • tmr_force_output_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_force_output_type : at32f413_tmr.h
  • TMR_HALL_DMA_REQUEST : at32f413_tmr.h
  • TMR_HALL_FLAG : at32f413_tmr.h
  • TMR_HALL_INT : at32f413_tmr.h
  • tmr_hall_select() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_HALL_SWTRIG : at32f413_tmr.h
  • tmr_ic_init_structure : project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR_IDEN_ADDRESS : at32f413_tmr.h
  • tmr_init() : app_led3_toggle/inc/tmr.h, app_led3_toggle/src/tmr.c, app_led4_toggle/inc/tmr.h, app_led4_toggle/src/tmr.c, bootloader/inc/tmr.h, bootloader/src/tmr.c
  • TMR_INPUT_BOTH_EDGE : at32f413_tmr.h
  • tmr_input_channel_divider_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_channel_filter_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_channel_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_config_struct : project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c
  • tmr_input_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_direction_mapped_type : at32f413_tmr.h
  • TMR_INPUT_FALLING_EDGE : at32f413_tmr.h
  • tmr_input_polarity_type : at32f413_tmr.h
  • TMR_INPUT_RISING_EDGE : at32f413_tmr.h
  • tmr_internal_clock_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_interrupt_enable() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_ISTS_ADDRESS : at32f413_tmr.h
  • TMR_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • tmr_oc_init_structure : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • tmr_one_cycle_mode_enable() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_OUTPUT_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_ACTIVE_LOW : at32f413_tmr.h
  • tmr_output_channel_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_immediately_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_polarity_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_switch_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_OUTPUT_CONTROL_FORCE_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_FORCE_LOW : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_LOW : at32f413_tmr.h
  • tmr_output_control_mode_type : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_OFF : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_A : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_B : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_SWITCH : at32f413_tmr.h
  • tmr_output_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_polarity_type : at32f413_tmr.h
  • tmr_output_struct : project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c
  • TMR_OVERFLOW_DMA_REQUEST : at32f413_tmr.h
  • tmr_overflow_event_disable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_overflow_request_source_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_OVERFLOW_SWTRIG : at32f413_tmr.h
  • TMR_OVF_FLAG : at32f413_tmr.h
  • TMR_OVF_INT : at32f413_tmr.h
  • tmr_period_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_POLARITY_ACTIVE_BOTH : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_LOW : at32f413_tmr.h
  • tmr_polarity_active_type : at32f413_tmr.h
  • TMR_PR_ADDRESS : at32f413_tmr.h
  • tmr_primary_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_PRIMARY_SEL_C1ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C2ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C3ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C4ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_COMPARE : at32f413_tmr.h
  • TMR_PRIMARY_SEL_ENABLE : at32f413_tmr.h
  • TMR_PRIMARY_SEL_OVERFLOW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_RESET : at32f413_tmr.h
  • tmr_primary_select_type : at32f413_tmr.h
  • tmr_pwm_input_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_repetition_counter_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_reset() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_RPR_ADDRESS : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_1 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_1C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_2 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_2C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_3 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_3C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_4 : at32f413_tmr.h
  • TMR_STCTRL_ADDRESS : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_A : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_B : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_C : at32f413_tmr.h
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A : at32f413_tmr.h
  • TMR_SUB_HANG_MODE : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C1DF1 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C1INC : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C2DF2 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_EXTIN : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS0 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS1 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS2 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS3 : at32f413_tmr.h
  • TMR_SUB_MODE_DIABLE : at32f413_tmr.h
  • tmr_sub_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_sub_mode_select_type : at32f413_tmr.h
  • TMR_SUB_RESET_MODE : at32f413_tmr.h
  • tmr_sub_sync_mode_set() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_SUB_TRIGGER_MODE : at32f413_tmr.h
  • TMR_SWEVT_ADDRESS : at32f413_tmr.h
  • TMR_TRIGGER_DMA_REQUEST : at32f413_tmr.h
  • TMR_TRIGGER_FLAG : at32f413_tmr.h
  • tmr_trigger_input_select() : at32f413_tmr.h, at32f413_tmr.c
  • TMR_TRIGGER_INT : at32f413_tmr.h
  • TMR_TRIGGER_SWTRIG : at32f413_tmr.h
  • TMR_WP_LEVEL_1 : at32f413_tmr.h
  • TMR_WP_LEVEL_2 : at32f413_tmr.h
  • TMR_WP_LEVEL_3 : at32f413_tmr.h
  • tmr_wp_level_type : at32f413_tmr.h
  • TMR_WP_OFF : at32f413_tmr.h
  • transfer_end : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • transfer_error : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • transfer_status : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • transfer_status1 : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • transfer_status2 : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • transfer_status3 : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
  • transfer_status4 : project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
  • TRUE : at32f413.h
  • tx_buf : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • tx_buf1 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buf2 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buf3 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buffer : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • tx_counter : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • tx_data_fill() : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • tx_index : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- u -

  • u16 : at32f413.h
  • u32 : at32f413.h
  • u8 : at32f413.h
  • UART4 : at32f413_usart.h
  • UART4_BASE : at32f413.h
  • UART4_GMUX_0001 : at32f413_gpio.h
  • UART4_IRQn : at32f413.h
  • UART5 : at32f413_usart.h
  • UART5_BASE : at32f413.h
  • UART5_IRQn : at32f413.h
  • uart_init() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/usart.h, bootloader/src/usart.c
  • uart_print_init() : at32f413_board.c, at32f413_board.h
  • uc16 : at32f413.h
  • uc32 : at32f413.h
  • uc8 : at32f413.h
  • UINT16 : at32f413.h
  • UINT32 : at32f413.h
  • UINT8 : at32f413.h
  • UP_MOVE : mouse_class.h
  • UPDATE_CLEAR_FLAG : bootloader/inc/iap.h
  • UPDATE_DONE : bootloader/inc/iap.h
  • UPDATE_ING : bootloader/inc/iap.h
  • UPDATE_PRE : bootloader/inc/iap.h
  • update_status : bootloader/inc/iap.h, bootloader/src/iap.c
  • update_status_type : bootloader/inc/iap.h
  • UPGRADE_DONE : flash_fat16.h
  • UPGRADE_FAILED : flash_fat16.h
  • UPGRADE_JUMP : flash_fat16.h
  • UPGRADE_LARGE : flash_fat16.h
  • UPGRADE_READY : flash_fat16.h
  • upgrade_status_type : flash_fat16.h
  • UPGRADE_SUCCESS : flash_fat16.h
  • UPGRADE_UNKNOWN : flash_fat16.h
  • UPGRAGE_ONGOING : flash_fat16.h
  • UsageFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • UsageFault_IRQn : at32f413.h
  • USART1 : at32f413_usart.h
  • USART1_BASE : at32f413.h
  • usart1_config() : project/at_start_f413/examples/pwc/sleep_usart1/src/main.c
  • USART1_GMUX_0001 : at32f413_gpio.h
  • usart1_index : project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c
  • USART1_IRQHandler() : project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, bootloader/src/usart.c
  • USART1_IRQn : at32f413.h
  • USART1_MUX : at32f413_gpio.h
  • USART2 : at32f413_usart.h
  • USART2_BASE : at32f413.h
  • USART2_IRQHandler() : project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • USART2_IRQn : at32f413.h
  • usart2_rx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart2_rx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_rx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart2_tx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart2_tx_buffer_size : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • USART2_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart2_tx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_tx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • USART3 : at32f413_usart.h
  • USART3_BASE : at32f413.h
  • USART3_GMUX_0001 : at32f413_gpio.h
  • USART3_IRQHandler() : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c
  • USART3_IRQn : at32f413.h
  • USART3_MUX_01 : at32f413_gpio.h
  • usart3_rx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart3_rx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_rx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart3_tx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart3_tx_buffer_size : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • USART3_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart3_tx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_tx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • USART_BF_INT : at32f413_usart.h
  • USART_BFF_FLAG : at32f413_usart.h
  • USART_BREAK_10BITS : at32f413_usart.h
  • USART_BREAK_11BITS : at32f413_usart.h
  • usart_break_bit_num_set() : at32f413_usart.h, at32f413_usart.c
  • usart_break_bit_num_type : at32f413_usart.h
  • usart_break_send() : at32f413_usart.h, at32f413_usart.c
  • usart_buffer_size : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_clock_config() : at32f413_usart.h, at32f413_usart.c
  • usart_clock_enable() : at32f413_usart.h, at32f413_usart.c
  • USART_CLOCK_LAST_BIT_NONE : at32f413_usart.h
  • USART_CLOCK_LAST_BIT_OUTPUT : at32f413_usart.h
  • USART_CLOCK_PHASE_1EDGE : at32f413_usart.h
  • USART_CLOCK_PHASE_2EDGE : at32f413_usart.h
  • usart_clock_phase_type : at32f413_usart.h
  • USART_CLOCK_POLARITY_HIGH : at32f413_usart.h
  • USART_CLOCK_POLARITY_LOW : at32f413_usart.h
  • usart_clock_polarity_type : at32f413_usart.h
  • usart_configuration() : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/idle_detection/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/irda/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • USART_CTSCF_FLAG : at32f413_usart.h
  • USART_CTSCF_INT : at32f413_usart.h
  • USART_DATA_8BITS : at32f413_usart.h
  • USART_DATA_9BITS : at32f413_usart.h
  • usart_data_bit_num_type : at32f413_usart.h
  • usart_data_receive() : at32f413_usart.h, at32f413_usart.c
  • usart_data_transmit() : at32f413_usart.h, at32f413_usart.c
  • usart_dma_receiver_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_dma_transmitter_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_enable() : at32f413_usart.h, at32f413_usart.c
  • USART_ERR_INT : at32f413_usart.h
  • USART_FERR_FLAG : at32f413_usart.h
  • usart_flag_clear() : at32f413_usart.h, at32f413_usart.c
  • usart_flag_get() : at32f413_usart.h, at32f413_usart.c
  • usart_gpio_config() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_group_struct : bootloader/inc/usart.h, bootloader/src/usart.c
  • usart_hardware_flow_control_set() : at32f413_usart.h, at32f413_usart.c
  • usart_hardware_flow_control_type : at32f413_usart.h
  • USART_HARDWARE_FLOW_CTS : at32f413_usart.h
  • USART_HARDWARE_FLOW_NONE : at32f413_usart.h
  • USART_HARDWARE_FLOW_RTS : at32f413_usart.h
  • USART_HARDWARE_FLOW_RTS_CTS : at32f413_usart.h
  • USART_IDLE_INT : at32f413_usart.h
  • USART_IDLEF_FLAG : at32f413_usart.h
  • usart_init() : at32f413_usart.h, at32f413_usart.c
  • usart_interrupt_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_low_power_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_smartcard_division_set() : at32f413_usart.h, at32f413_usart.c
  • usart_lbcp_type : at32f413_usart.h
  • usart_lin_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • USART_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • USART_NERR_FLAG : at32f413_usart.h
  • USART_PARITY_EVEN : at32f413_usart.h
  • USART_PARITY_NONE : at32f413_usart.h
  • USART_PARITY_ODD : at32f413_usart.h
  • usart_parity_selection_config() : at32f413_usart.h, at32f413_usart.c
  • usart_parity_selection_type : at32f413_usart.h
  • USART_PERR_FLAG : at32f413_usart.h
  • USART_PERR_INT : at32f413_usart.h
  • USART_RDBF_FLAG : at32f413_usart.h
  • USART_RDBF_INT : at32f413_usart.h
  • USART_REC_LEN : bootloader/inc/usart.h
  • usart_receive_data() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_receiver_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_receiver_mute_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_reset() : at32f413_usart.h, at32f413_usart.c
  • USART_ROERR_FLAG : at32f413_usart.h
  • usart_rx_buffer : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_rx_data_len : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_send_data() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_single_line_halfduplex_select() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_guard_time_set() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_nack_set() : at32f413_usart.h, at32f413_usart.c
  • usart_spi_configuration() : project/at_start_f413/examples/usart/synchronous/src/main.c
  • USART_STOP_0_5_BIT : at32f413_usart.h
  • USART_STOP_1_5_BIT : at32f413_usart.h
  • USART_STOP_1_BIT : at32f413_usart.h
  • USART_STOP_2_BIT : at32f413_usart.h
  • usart_stop_bit_num_type : at32f413_usart.h
  • USART_TDBE_FLAG : at32f413_usart.h
  • USART_TDBE_INT : at32f413_usart.h
  • USART_TDC_FLAG : at32f413_usart.h
  • USART_TDC_INT : at32f413_usart.h
  • usart_transmitter_enable() : at32f413_usart.h, at32f413_usart.c
  • USART_WAKEUP_BY_IDLE_FRAME : at32f413_usart.h
  • USART_WAKEUP_BY_MATCHING_ID : at32f413_usart.h
  • usart_wakeup_id_set() : at32f413_usart.h, at32f413_usart.c
  • usart_wakeup_mode_set() : at32f413_usart.h, at32f413_usart.c
  • usart_wakeup_mode_type : at32f413_usart.h
  • USB : at32f413_usb.h
  • USB_BE_FLAG : at32f413_usb.h
  • USB_BE_INT : at32f413_usb.h
  • usb_buffer : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_buffer_free() : at32f413_usb.h, at32f413_usb.c
  • usb_buffer_malloc() : at32f413_usb.h, at32f413_usb.c
  • USB_BUFFER_SIZE_EX : project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h
  • USB_BUFFER_TABLE_ADDRESS : at32f413_usb.h
  • USB_CLASS_CODE_AUDIO : usb_std.h
  • USB_CLASS_CODE_CCID : usb_std.h
  • USB_CLASS_CODE_CDC : usb_std.h
  • USB_CLASS_CODE_CDCDATA : usb_std.h
  • USB_CLASS_CODE_HID : usb_std.h
  • USB_CLASS_CODE_HUB : usb_std.h
  • USB_CLASS_CODE_MSC : usb_std.h
  • USB_CLASS_CODE_PRINTER : usb_std.h
  • USB_CLASS_CODE_VENDOR : usb_std.h
  • USB_CLASS_CODE_VIDEO : usb_std.h
  • USB_CLEAR_EPT_DOUBLE_BUFFER : at32f413_usb.h
  • USB_CLEAR_EXF : at32f413_usb.h
  • USB_CLEAR_RXDTS : at32f413_usb.h
  • USB_CLEAR_RXTC : at32f413_usb.h
  • USB_CLEAR_TXDTS : at32f413_usb.h
  • USB_CLEAR_TXTC : at32f413_usb.h
  • usb_clk48_s : at32f413_usb.h
  • USB_CLK_HEXT : at32f413_usb.h
  • USB_CLK_HICK : at32f413_usb.h
  • usb_clock48m_select() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • USB_CONF_REMOTE_WAKEUP : usb_std.h
  • USB_CONF_SELF_POWERED : usb_std.h
  • USB_CONFIG_STRING : usb_std.h
  • USB_CONN_STATE_ADDRESSED : usb_std.h
  • USB_CONN_STATE_CONFIGURED : usb_std.h
  • USB_CONN_STATE_DEFAULT : usb_std.h
  • USB_CONN_STATE_SUSPENDED : usb_std.h
  • usb_connect() : at32f413_usb.h, at32f413_usb.c
  • usb_core_dev : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • USB_DBUF0_GET_LEN : at32f413_usb.h
  • USB_DBUF1_GET_LEN : at32f413_usb.h
  • usb_delay_ms() : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_delay_us() : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • USB_DESCIPTOR_TYPE_CONFIGURATION : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER : usb_std.h
  • USB_DESCIPTOR_TYPE_ENDPOINT : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE_POWER : usb_std.h
  • USB_DESCIPTOR_TYPE_OTHER_SPEED : usb_std.h
  • USB_DESCIPTOR_TYPE_STRING : usb_std.h
  • usb_dev_init() : at32f413_usb.h, at32f413_usb.c
  • USB_DEVICE_CFG_DESC_LEN : usb_std.h
  • USB_DEVICE_DESC_LEN : usb_std.h
  • USB_DEVICE_EPT_LEN : usb_std.h
  • USB_DEVICE_IF_DESC_LEN : usb_std.h
  • USB_DEVICE_LANGID_STR_DESC_LEN : usb_std.h
  • USB_DEVICE_OTG_DESC_LEN : usb_std.h
  • USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN : usb_std.h
  • USB_DEVICE_QUALIFIER_DESC_LEN : usb_std.h
  • usb_disconnect() : at32f413_usb.h, at32f413_usb.c
  • USB_ENDP_DESC_TABLE_OFFSET : at32f413_usb.c
  • usb_enter_suspend() : at32f413_usb.h, at32f413_usb.c
  • USB_EPT0 : at32f413_usb.h
  • USB_EPT0_DATA_IN : usb_std.h
  • USB_EPT0_DATA_OUT : usb_std.h
  • USB_EPT0_IDLE : usb_std.h
  • USB_EPT0_SETUP : usb_std.h
  • USB_EPT0_STALL : usb_std.h
  • USB_EPT0_STATUS_IN : usb_std.h
  • USB_EPT0_STATUS_OUT : usb_std.h
  • USB_EPT1 : at32f413_usb.h
  • USB_EPT2 : at32f413_usb.h
  • USB_EPT3 : at32f413_usb.h
  • USB_EPT4 : at32f413_usb.h
  • USB_EPT5 : at32f413_usb.h
  • USB_EPT6 : at32f413_usb.h
  • USB_EPT7 : at32f413_usb.h
  • USB_EPT_AUTO_MALLOC_BUFFER : project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USB_EPT_BIT_MASK : at32f413_usb.h
  • USB_EPT_BULK : at32f413_usb.h
  • usb_ept_close() : at32f413_usb.h, at32f413_usb.c
  • USB_EPT_CONTROL : at32f413_usb.h
  • USB_EPT_DESC_BULK : usb_std.h
  • USB_EPT_DESC_CONTROL : usb_std.h
  • USB_EPT_DESC_DATA_EPT : usb_std.h
  • USB_EPT_DESC_FD_EPT : usb_std.h
  • USB_EPT_DESC_FDDATA_EPT : usb_std.h
  • USB_EPT_DESC_INTERRUPT : usb_std.h
  • USB_EPT_DESC_ISO : usb_std.h
  • USB_EPT_DESC_NSYNC : usb_std.h
  • USB_EPT_INT : at32f413_usb.h
  • USB_EPT_ISO : at32f413_usb.h
  • USB_EPT_NUM_FLAG : at32f413_usb.h
  • usb_ept_number_type : at32f413_usb.h
  • usb_ept_open() : at32f413_usb.h, at32f413_usb.c
  • usb_ept_stall() : at32f413_usb.h, at32f413_usb.c
  • USB_EPTADDR : at32f413_usb.h
  • USB_ERROR : usb_std.h
  • USB_ETP_DESC_ADAPTIVE : usb_std.h
  • USB_ETP_DESC_ASYNC : usb_std.h
  • USB_ETP_DESC_SYNC : usb_std.h
  • USB_EXF : at32f413_usb.h
  • usb_exit_suspend() : at32f413_usb.h, at32f413_usb.c
  • USB_FAIL : usb_std.h
  • USB_FEATURE_EPT_HALT : usb_std.h
  • USB_FEATURE_REMOTE_WAKEUP : usb_std.h
  • USB_FEATURE_TEST_MODE : usb_std.h
  • usb_flag_clear() : at32f413_usb.h, at32f413_usb.c
  • usb_flag_get() : at32f413_usb.h, at32f413_usb.c
  • USB_FLASH_ADDR_OFFSET : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • USB_FREE_DB_USER_BUFFER : at32f413_usb.h
  • USB_GET_RX_LEN : at32f413_usb.h
  • USB_GET_TX_LEN : at32f413_usb.h
  • usb_hid_buf_process() : audio_hid_class.c, custom_hid_class.c
  • usb_hid_keyboard_send_char() : keyboard_class.c, keyboard_class.h
  • usb_hid_mouse_send() : mouse_class.c, mouse_class.h
  • usb_iap_class_send_report() : hid_iap_class.c, hid_iap_class.h
  • USB_INOUT_FLAG : at32f413_usb.h
  • USB_INTERFACE_ASSOCIATION_TYPE : cdc_msc_desc.c
  • USB_INTERFACE_STRING : usb_std.h
  • usb_interrupt_enable() : at32f413_usb.h, at32f413_usb.c
  • usb_keyboard_class_send_report() : keyboard_class.c, keyboard_class.h
  • USB_LANGID_STRING : usb_std.h
  • usb_low_power_wakeup_config() : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • USB_LOW_POWER_WAKUP : project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h
  • USB_LSOF_FLAG : at32f413_usb.h
  • USB_LSOF_INT : at32f413_usb.h
  • USB_MAX_EP0_SIZE : usb_std.h
  • USB_MFC_STRING : usb_std.h
  • USB_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • usb_mouse_class_send_report() : mouse_class.c, mouse_class.h
  • USB_NOT_SUPPORT : usb_std.h
  • USB_OK : usb_std.h
  • USB_OUT_EPT_DOUBLE_BUF0 : at32f413_usb.h
  • USB_PACKET_BUFFER_ADDRESS : at32f413_usb.h
  • USB_PACKET_BUFFER_ADDRESS_EX : at32f413_usb.h
  • usb_printer_get_rxdata() : printer_class.c, printer_class.h
  • usb_printer_send_data() : printer_class.c, printer_class.h
  • USB_PRODUCT_STRING : usb_std.h
  • usb_read_packet() : at32f413_usb.h, at32f413_usb.c
  • usb_reg_type : at32f413_usb.h
  • usb_remote_wkup_clear() : at32f413_usb.h, at32f413_usb.c
  • usb_remote_wkup_set() : at32f413_usb.h, at32f413_usb.c
  • USB_REQ_DIR_DTH : usb_std.h
  • USB_REQ_DIR_HTD : usb_std.h
  • USB_REQ_RECIPIENT_DEVICE : usb_std.h
  • USB_REQ_RECIPIENT_ENDPOINT : usb_std.h
  • USB_REQ_RECIPIENT_INTERFACE : usb_std.h
  • USB_REQ_RECIPIENT_MASK : usb_std.h
  • USB_REQ_RECIPIENT_OTHER : usb_std.h
  • USB_REQ_TYPE_CLASS : usb_std.h
  • USB_REQ_TYPE_RESERVED : usb_std.h
  • USB_REQ_TYPE_STANDARD : usb_std.h
  • USB_REQ_TYPE_VENDOR : usb_std.h
  • usb_reset() : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
  • USB_RST_FLAG : at32f413_usb.h
  • USB_RST_INT : at32f413_usb.h
  • USB_RX_DISABLE : at32f413_usb.h
  • USB_RX_MASK : at32f413_usb.h
  • USB_RX_NAK : at32f413_usb.h
  • USB_RX_STALL : at32f413_usb.h
  • USB_RX_VALID : at32f413_usb.h
  • USB_RXDTS : at32f413_usb.h
  • USB_RXDTS0 : at32f413_usb.h
  • USB_RXDTS1 : at32f413_usb.h
  • USB_RXSTS : at32f413_usb.h
  • USB_RXTC : at32f413_usb.h
  • USB_SERIAL_STRING : usb_std.h
  • usb_set_address() : at32f413_usb.h, at32f413_usb.c
  • USB_SET_DOUBLE_BUFF0_ADDRESS : at32f413_usb.h
  • USB_SET_DOUBLE_BUFF1_ADDRESS : at32f413_usb.h
  • USB_SET_EPT_ADDRESS : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUF0_LEN : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUF1_LEN : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUFFER : at32f413_usb.h
  • USB_SET_EXF : at32f413_usb.h
  • USB_SET_RX_ADDRESS : at32f413_usb.h
  • USB_SET_RXLEN : at32f413_usb.h
  • USB_SET_RXLEN_REG : at32f413_usb.h
  • USB_SET_RXSTS : at32f413_usb.h
  • USB_SET_TRANS_TYPE : at32f413_usb.h
  • USB_SET_TX_ADDRESS : at32f413_usb.h
  • USB_SET_TXLEN : at32f413_usb.h
  • USB_SET_TXSTS : at32f413_usb.h
  • USB_SETUPTC : at32f413_usb.h
  • USB_SOF_FLAG : at32f413_usb.h
  • USB_SOF_INT : at32f413_usb.h
  • USB_SP_FLAG : at32f413_usb.h
  • USB_SP_INT : at32f413_usb.h
  • USB_STD_REQ_CLEAR_FEATURE : usb_std.h
  • USB_STD_REQ_GET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_GET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_GET_INTERFACE : usb_std.h
  • USB_STD_REQ_GET_STATUS : usb_std.h
  • USB_STD_REQ_SET_ADDRESS : usb_std.h
  • USB_STD_REQ_SET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_SET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_SET_FEATURE : usb_std.h
  • USB_STD_REQ_SET_INTERFACE : usb_std.h
  • USB_STD_REQ_SYNCH_FRAME : usb_std.h
  • usb_sts_type : usb_std.h
  • USB_TC_FLAG : at32f413_usb.h
  • USB_TC_INT : at32f413_usb.h
  • USB_TOGGLE_RXDTS : at32f413_usb.h
  • USB_TOGGLE_TXDTS : at32f413_usb.h
  • USB_TRANS_TYPE : at32f413_usb.h
  • USB_TX_DISABLE : at32f413_usb.h
  • USB_TX_MASK : at32f413_usb.h
  • USB_TX_NAK : at32f413_usb.h
  • USB_TX_STALL : at32f413_usb.h
  • USB_TX_VALID : at32f413_usb.h
  • USB_TXDTS : at32f413_usb.h
  • USB_TXDTS0 : at32f413_usb.h
  • USB_TXDTS1 : at32f413_usb.h
  • USB_TXSTS : at32f413_usb.h
  • USB_TXTC : at32f413_usb.h
  • USB_UCFOR_FLAG : at32f413_usb.h
  • USB_UCFOR_INT : at32f413_usb.h
  • usb_usart_config() : cdc_class.c, cdc_msc_class.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_usbbufs_enable() : at32f413_usb.h, at32f413_usb.c
  • usb_vcp_cmd_process() : cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c
  • usb_vcp_get_rxdata() : cdc_class.c, cdc_class.h, cdc_msc_class.c, cdc_msc_class.h
  • usb_vcp_send_data() : cdc_class.c, cdc_class.h, cdc_msc_class.c, cdc_msc_class.h
  • usb_vcpkybrd_class_send_report() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_keyboard_send_char() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_get_rxdata() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_send_data() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • USB_VIRTUAL_COMPORT : project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • USB_WAIT : usb_std.h
  • USB_WK_FLAG : at32f413_usb.h
  • USB_WK_INT : at32f413_usb.h
  • usb_write_packet() : at32f413_usb.h, at32f413_usb.c
  • USBD_AUDIO_CONFIG_DESC_SIZE : audio_desc.h
  • USBD_AUDIO_DESC_CONFIGURATION_STRING : audio_desc.h
  • USBD_AUDIO_DESC_INTERFACE_STRING : audio_desc.h
  • USBD_AUDIO_DESC_MANUFACTURER_STRING : audio_desc.h
  • USBD_AUDIO_DESC_PRODUCT_STRING : audio_desc.h
  • USBD_AUDIO_FEEDBACK_EPT : audio_class.h
  • USBD_AUDIO_MIC_IN_EPT : audio_class.h
  • USBD_AUDIO_PRODUCT_ID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_LANGID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_SERIAL : audio_desc.h
  • USBD_AUDIO_SPK_OUT_EPT : audio_class.h
  • USBD_AUDIO_VENDOR_ID : audio_desc.h
  • USBD_AUHID_AUDIO_FEEDBACK_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_MIC_IN_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_SPK_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_CONFIG_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_DESC_CONFIGURATION_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_INTERFACE_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_MANUFACTURER_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_PRODUCT_STRING : audio_hid_desc.h
  • USBD_AUHID_HID_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_HID_IN_EPT : audio_hid_class.h
  • USBD_AUHID_HID_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_HID_SIZ_REPORT_DESC : audio_hid_desc.h
  • USBD_AUHID_IN_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_OUT_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_PRODUCT_ID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_LANGID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_SERIAL : audio_hid_desc.h
  • USBD_AUHID_VENDOR_ID : audio_hid_desc.h
  • USBD_CDC_BULK_IN_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_BULK_OUT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CMD_MAXPACKET_SIZE : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CONFIG_DESC_SIZE : cdc_desc.h
  • USBD_CDC_CS_ENDPOINT : usb_std.h
  • USBD_CDC_CS_INTERFACE : usb_std.h
  • USBD_CDC_DESC_CONFIGURATION_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_INTERFACE_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_MANUFACTURER_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_PRODUCT_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_IN_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_INT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_MSC_CONFIG_DESC_SIZE : cdc_msc_desc.h
  • USBD_CDC_MSC_IN_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_OUT_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_PRODUCT_ID : cdc_msc_desc.h
  • USBD_CDC_MSC_VENDOR_ID : cdc_msc_desc.h
  • USBD_CDC_OUT_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_PRODUCT_ID : cdc_desc.h
  • USBD_CDC_SIZ_STRING_LANGID : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SIZ_STRING_SERIAL : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SUBTYPE_ACM : usb_std.h
  • USBD_CDC_SUBTYPE_CMF : usb_std.h
  • USBD_CDC_SUBTYPE_HEADER : usb_std.h
  • USBD_CDC_SUBTYPE_UFD : usb_std.h
  • USBD_CDC_VENDOR_ID : cdc_desc.h
  • usbd_clear_feature() : usbd_sdr.c
  • usbd_clear_stall() : usbd_core.h, usbd_core.c
  • usbd_conn_state : usb_std.h
  • usbd_connect() : usbd_core.h, usbd_core.c
  • usbd_connect_state_get() : usbd_core.h, usbd_core.c
  • usbd_core_in_handler() : usbd_core.h, usbd_core.c
  • usbd_core_init() : usbd_core.h, usbd_core.c
  • usbd_core_out_handler() : usbd_core.h, usbd_core.c
  • usbd_core_setup_handler() : usbd_core.h, usbd_core.c
  • usbd_ctrl_recv() : usbd_core.h, usbd_core.c
  • usbd_ctrl_recv_status() : usbd_core.h, usbd_core.c
  • usbd_ctrl_send() : usbd_core.h, usbd_core.c
  • usbd_ctrl_send_status() : usbd_core.h, usbd_core.c
  • usbd_ctrl_unsupport() : usbd_core.h, usbd_core.c
  • USBD_CUSHID_CONFIG_DESC_SIZE : custom_hid_desc.h
  • USBD_CUSHID_DESC_CONFIGURATION_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_INTERFACE_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_MANUFACTURER_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_PRODUCT_STRING : custom_hid_desc.h
  • USBD_CUSHID_PRODUCT_ID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_REPORT_DESC : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_LANGID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_SERIAL : custom_hid_desc.h
  • USBD_CUSHID_VENDOR_ID : custom_hid_desc.h
  • USBD_CUSTOM_HID_IN_EPT : custom_hid_class.h
  • USBD_CUSTOM_HID_OUT_EPT : custom_hid_class.h
  • USBD_CUSTOM_IN_MAXPACKET_SIZE : custom_hid_class.h
  • USBD_CUSTOM_OUT_MAXPACKET_SIZE : custom_hid_class.h
  • usbd_device_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_disconnect() : usbd_core.h, usbd_core.c
  • usbd_endpoint_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_enter_suspend() : usbd_core.h, usbd_core.c
  • usbd_ept_buf_auto_define() : usbd_core.h, usbd_core.c
  • usbd_ept_buf_custom_define() : usbd_core.h, usbd_core.c
  • usbd_ept_close() : usbd_core.h, usbd_core.c
  • usbd_ept_dbuffer_enable() : usbd_core.h, usbd_core.c
  • usbd_ept_defaut_init() : usbd_core.h, usbd_core.c
  • usbd_ept_loop_handler() : usbd_int.h, usbd_int.c
  • usbd_ept_open() : usbd_core.h, usbd_core.c
  • usbd_ept_recv() : usbd_core.h, usbd_core.c
  • usbd_ept_send() : usbd_core.h, usbd_core.c
  • usbd_eptn_handler() : usbd_int.h, usbd_int.c
  • USBD_ERR_EVENT : usbd_core.h
  • usbd_event_type : usbd_core.h
  • usbd_get_configuration() : usbd_sdr.c
  • usbd_get_descriptor() : usbd_sdr.c
  • usbd_get_recv_len() : usbd_core.h, usbd_core.c
  • usbd_get_status() : usbd_sdr.c
  • usbd_hid_iap_in_complete() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • usbd_hid_iap_process() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • USBD_HIDIAP_CONFIG_DESC_SIZE : hid_iap_desc.h
  • USBD_HIDIAP_DESC_CONFIGURATION_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_INTERFACE_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_MANUFACTURER_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_PRODUCT_STRING : hid_iap_desc.h
  • USBD_HIDIAP_IN_EPT : hid_iap_class.h
  • USBD_HIDIAP_IN_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_OUT_EPT : hid_iap_class.h
  • USBD_HIDIAP_OUT_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_PRODUCT_ID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_REPORT_DESC : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_LANGID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_SERIAL : hid_iap_desc.h
  • USBD_HIDIAP_VENDOR_ID : hid_iap_desc.h
  • USBD_IN_MAXPACKET_SIZE : msc_class.h
  • usbd_int_to_unicode() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • usbd_interface_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_irq_handler() : usbd_int.h, usbd_int.c
  • USBD_KEYBOARD_CONFIG_DESC_SIZE : keyboard_desc.h
  • USBD_KEYBOARD_DESC_CONFIGURATION_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_INTERFACE_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_MANUFACTURER_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_PRODUCT_STRING : keyboard_desc.h
  • USBD_KEYBOARD_IN_EPT : keyboard_class.h
  • USBD_KEYBOARD_IN_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_OUT_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_PRODUCT_ID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_REPORT_DESC : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_LANGID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_SERIAL : keyboard_desc.h
  • USBD_KEYBOARD_VENDOR_ID : keyboard_desc.h
  • USBD_MOUSE_CONFIG_DESC_SIZE : mouse_desc.h
  • USBD_MOUSE_DESC_CONFIGURATION_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_INTERFACE_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_MANUFACTURER_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_PRODUCT_STRING : mouse_desc.h
  • USBD_MOUSE_IN_EPT : mouse_class.h
  • USBD_MOUSE_IN_MAXPACKET_SIZE : mouse_class.h
  • USBD_MOUSE_PRODUCT_ID : mouse_desc.h
  • USBD_MOUSE_SIZ_REPORT_DESC : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_LANGID : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_SERIAL : mouse_desc.h
  • USBD_MOUSE_VENDOR_ID : mouse_desc.h
  • USBD_MSC_BULK_IN_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_BULK_OUT_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_CONFIG_DESC_SIZE : msc_desc.h
  • USBD_MSC_DESC_CONFIGURATION_STRING : msc_desc.h
  • USBD_MSC_DESC_INTERFACE_STRING : msc_desc.h
  • USBD_MSC_DESC_MANUFACTURER_STRING : msc_desc.h
  • USBD_MSC_DESC_PRODUCT_STRING : msc_desc.h
  • USBD_MSC_PRODUCT_ID : msc_desc.h
  • USBD_MSC_SIZ_STRING_LANGID : msc_desc.h
  • USBD_MSC_SIZ_STRING_SERIAL : msc_desc.h
  • USBD_MSC_VENDOR_ID : msc_desc.h
  • USBD_NOP_EVENT : usbd_core.h
  • USBD_OUT_MAXPACKET_SIZE : msc_class.h
  • USBD_PRINTER_BULK_IN_EPT : printer_class.h
  • USBD_PRINTER_BULK_OUT_EPT : printer_class.h
  • USBD_PRINTER_CONFIG_DESC_SIZE : printer_desc.h
  • USBD_PRINTER_DESC_CONFIGURATION_STRING : printer_desc.h
  • USBD_PRINTER_DESC_INTERFACE_STRING : printer_desc.h
  • USBD_PRINTER_DESC_MANUFACTURER_STRING : printer_desc.h
  • USBD_PRINTER_DESC_PRODUCT_STRING : printer_desc.h
  • USBD_PRINTER_IN_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_OUT_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_PRODUCT_ID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_LANGID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_SERIAL : printer_desc.h
  • USBD_PRINTER_VENDOR_ID : printer_desc.h
  • usbd_remote_wakeup() : usbd_core.h, usbd_core.c
  • USBD_RESET_EVENT : usbd_core.h
  • usbd_reset_handler() : usbd_int.h, usbd_int.c
  • usbd_set_address() : usbd_sdr.c
  • usbd_set_configuration() : usbd_sdr.c
  • usbd_set_device_addr() : usbd_core.h, usbd_core.c
  • usbd_set_feature() : usbd_sdr.c
  • usbd_set_stall() : usbd_core.h, usbd_core.c
  • usbd_setup_request_parse() : usbd_sdr.h, usbd_sdr.c
  • usbd_sof_handler() : usbd_int.h, usbd_int.c
  • USBD_SUSPEND_EVENT : usbd_core.h
  • usbd_suspend_handler() : usbd_int.h, usbd_int.c
  • usbd_unicode_convert() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • USBD_VCPKYBRD_CDC_BULK_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_BULK_OUT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_INT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CMD_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CONFIG_DESC_SIZE : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_CONFIGURATION_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_INTERFACE_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_MANUFACTURER_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_PRODUCT_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_HID_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_HID_SIZ_REPORT_DESC : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_IN_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_OUT_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_PRODUCT_ID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_LANGID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_SERIAL : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_VENDOR_ID : cdc_keyboard_desc.h
  • USBD_WAKEUP_EVENT : usbd_core.h
  • usbd_wakeup_handler() : usbd_int.h, usbd_int.c
  • USBFS_BASE : at32f413.h
  • USBFS_H_CAN1_TX_IRQn : at32f413.h
  • USBFS_L_CAN1_RX0_IRQHandler() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • USBFS_L_CAN1_RX0_IRQn : at32f413.h
  • USBFS_MAPH_IRQn : at32f413.h
  • USBFS_MAPL_IRQn : at32f413.h
  • USBFSWakeUp_IRQn : at32f413.h
  • USD : at32f413_flash.h
  • USD_BASE : at32f413.h
  • USD_DEPSLP_NO_RST : at32f413_flash.h
  • USD_DEPSLP_RST : at32f413_flash.h
  • USD_STDBY_NO_RST : at32f413_flash.h
  • USD_STDBY_RST : at32f413_flash.h
  • USD_WDT_ATO_DISABLE : at32f413_flash.h
  • USD_WDT_ATO_ENABLE : at32f413_flash.h
  • USE_SLIB_FUNCTION : utilities/at32f413_slib_demo/project_l0/src/main.c
  • USE_STATIC_INIT : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • USER_BUTTON : at32f413_board.h
  • USER_BUTTON_CRM_CLK : at32f413_board.h
  • USER_BUTTON_PIN : at32f413_board.h
  • USER_BUTTON_PORT : at32f413_board.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • var : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • variables : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • variables_addr : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • variables_bit_val : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_GET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_RESET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_SET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • vcp_keyboard_struct : cdc_keyboard_class.c
  • VCPKYBRD_BCD_NUM : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_DATA_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_HID_BINTERVAL_TIME : cdc_keyboard_desc.h
  • VCPKYBRD_KEYBOARD_INTERFACE : cdc_keyboard_desc.h
  • VCPMSC_CDC_DATA_INTERFACE : cdc_msc_desc.h
  • VCPMSC_CDC_INTERFACE : cdc_msc_desc.h
  • VCPMSC_MSC_INTERFACE : cdc_msc_desc.h
  • VECT_TAB_OFFSET : system_at32f413.c
  • vmor_flag_index : project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • vp_desc : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • vPortSVCHandler : FreeRTOSConfig.h
  • vs16 : at32f413.h
  • vs32 : at32f413.h
  • vs8 : at32f413.h
  • vsc16 : at32f413.h
  • vsc32 : at32f413.h
  • vsc8 : at32f413.h
  • vu16 : at32f413.h
  • vu32 : at32f413.h
  • vu8 : at32f413.h
  • vuc16 : at32f413.h
  • vuc32 : at32f413.h
  • vuc8 : at32f413.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- w -

  • W25Q128 : spi_flash.h
  • W25Q16 : spi_flash.h
  • W25Q32 : spi_flash.h
  • W25Q64 : spi_flash.h
  • W25Q80 : spi_flash.h
  • WDT : at32f413_wdt.h
  • WDT_BASE : at32f413.h
  • WDT_CLK_DIV_128 : at32f413_wdt.h
  • WDT_CLK_DIV_16 : at32f413_wdt.h
  • WDT_CLK_DIV_256 : at32f413_wdt.h
  • WDT_CLK_DIV_32 : at32f413_wdt.h
  • WDT_CLK_DIV_4 : at32f413_wdt.h
  • WDT_CLK_DIV_64 : at32f413_wdt.h
  • WDT_CLK_DIV_8 : at32f413_wdt.h
  • WDT_CMD_ENABLE : at32f413_wdt.h
  • WDT_CMD_LOCK : at32f413_wdt.h
  • WDT_CMD_RELOAD : at32f413_wdt.h
  • WDT_CMD_UNLOCK : at32f413_wdt.h
  • wdt_cmd_value_type : at32f413_wdt.h
  • wdt_counter_reload() : at32f413_wdt.h, at32f413_wdt.c
  • WDT_DIVF_UPDATE_FLAG : at32f413_wdt.h
  • wdt_divider_set() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_division_type : at32f413_wdt.h
  • wdt_enable() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_flag_get() : at32f413_wdt.h, at32f413_wdt.c
  • WDT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • wdt_register_write_enable() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_reload_value_set() : at32f413_wdt.h, at32f413_wdt.c
  • WDT_RLDF_UPDATE_FLAG : at32f413_wdt.h
  • weekday_table : project/at_start_f413/examples/rtc/calendar/src/main.c
  • WM8988_I2C_ADDR_CSB_HIGH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_I2C_ADDR_CSB_LOW : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R0_LEFT_INPUT_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R10_LEFT_DAC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R11_RIGHT_DAC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R12_BASS_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R13_TREBLE_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R14_ : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R15_RESET : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R16_3D_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R17_ALC1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R18_ALC2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R19_ALC3 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R1_RIGHT_INPUT_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R20_NOISE_GATE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R21_LEFT_ADC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R22_RIGHT_ADC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R23_ADDITIONAL_1_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R24_ADDITIONAL_2_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R25_PWR_1_MGMT : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R26_PWR_2_MGMT : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R27_ADDITIONAL_3_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R2_LOUT1_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R31_ADC_INPUT_MODE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R32_ADC_L_SIGNAL_PATH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R33_ADC_R_SIGNAL_PATH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R34_LEFT_OUT_MIX_1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R35_LEFT_OUT_MIX_2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R36_RIGHT_OUT_MIX_1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R37_RIGHT_OUT_MIX_2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R38_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R39_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R3_ROUT1_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R40_LOUT2_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R41_ROUT2_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R42_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R43_LOW_POWER_PALYBACK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R4_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R5_ADC_DAC_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R6_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R7_AUDIO_INTERFACE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R8_SAMPLE_RATE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R9_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_REG_BITW16 : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ16K : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ48K : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • work : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • write_buffer : operate_spim.c
  • WWDT : at32f413_wwdt.h
  • WWDT_BASE : at32f413.h
  • wwdt_counter_set() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_divider_set() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_division_type : at32f413_wwdt.h
  • WWDT_EN_BIT : at32f413_wwdt.h
  • wwdt_enable() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_flag_clear() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_flag_get() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_interrupt_enable() : at32f413_wwdt.h, at32f413_wwdt.c
  • WWDT_IRQn : at32f413.h
  • WWDT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • WWDT_PCLK1_DIV_16384 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_32768 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_4096 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_8192 : at32f413_wwdt.h
  • wwdt_reset() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_window_counter_set() : at32f413_wwdt.h, at32f413_wwdt.c


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- x -

  • XMC_REG_BASE : at32f413.h
  • xPortPendSVHandler : FreeRTOSConfig.h
  • xPortSysTickHandler : FreeRTOSConfig.h


AT32F413 Firmwary Library: Globals

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- z -

  • ZOOM : project/at_start_f413/examples/cortex_m4/fpu/src/main.c


AT32F413 Firmwary Library: Globals

- _ -

  • __align() : diskio.c


AT32F413 Firmwary Library: Globals

- a -

  • acc_calibration_mode_enable() : at32f413_acc.h, at32f413_acc.c
  • acc_flag_clear() : at32f413_acc.h, at32f413_acc.c
  • acc_flag_get() : at32f413_acc.h, at32f413_acc.c
  • acc_hickcal_get() : at32f413_acc.h, at32f413_acc.c
  • acc_hicktrim_get() : at32f413_acc.h, at32f413_acc.c
  • acc_interrupt_enable() : at32f413_acc.h, at32f413_acc.c
  • ACC_IRQHandler() : project/at_start_f413/examples/acc/calibration/src/main.c
  • acc_read_c1() : at32f413_acc.h, at32f413_acc.c
  • acc_read_c2() : at32f413_acc.h, at32f413_acc.c
  • acc_read_c3() : at32f413_acc.h, at32f413_acc.c
  • acc_step_set() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c1() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c2() : at32f413_acc.h, at32f413_acc.c
  • acc_write_c3() : at32f413_acc.h, at32f413_acc.c
  • ADC1_2_IRQHandler() : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c
  • adc_base_config() : at32f413_adc.h, at32f413_adc.c
  • adc_base_default_para_init() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_init() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_init_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_start() : at32f413_adc.h, at32f413_adc.c
  • adc_calibration_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_combine_mode_select() : at32f413_adc.h, at32f413_adc.c
  • adc_combine_ordinary_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • adc_dma_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_flag_clear() : at32f413_adc.h, at32f413_adc.c
  • adc_flag_get() : at32f413_adc.h, at32f413_adc.c
  • adc_interrupt_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_channel_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_conversion_trigger_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_part_count_set() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_part_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_software_trigger_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_ordinary_software_trigger_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_auto_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_channel_length_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_channel_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_conversion_data_get() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_conversion_trigger_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_offset_value_set() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_part_mode_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_software_trigger_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_preempt_software_trigger_status_get() : at32f413_adc.h, at32f413_adc.c
  • adc_reset() : at32f413_adc.h, at32f413_adc.c
  • adc_tempersensor_vintrv_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_enable() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_single_channel_select() : at32f413_adc.h, at32f413_adc.c
  • adc_voltage_monitor_threshold_value_set() : at32f413_adc.h, at32f413_adc.c
  • alarm_init() : project/at_start_f413/examples/rtc/calendar/src/main.c
  • app_load() : bootloader/inc/iap.h, bootloader/src/iap.c
  • app_loop() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c
  • app_update_handle() : bootloader/src/iap.c
  • arm_apply_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_2pow() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_calc_guard_bits() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_clip_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_compare_fixed_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_fir_f32() : project_l0/inc/fir_filter.h, project_l1/inc/fir_filter.h
  • arm_fir_init_f32() : project_l0/inc/fir_filter.h, arm_fir_init_f32.c, project_l1/inc/fir_filter.h
  • arm_float_to_q12_20() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q14() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q28() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q29() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_float_to_q30() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q15() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q31() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • arm_provide_guard_bits_q7() : project_l0/src/math_helper.c, project_l1/src/math_helper.c
  • arm_snr_f32() : project_l0/inc/math_helper.h, project_l0/src/math_helper.c, project_l1/inc/math_helper.h, project_l1/src/math_helper.c
  • at32_board_init() : at32f413_board.c, at32f413_board.h
  • at32_button_init() : at32f413_board.c, at32f413_board.h
  • at32_button_press() : at32f413_board.c, at32f413_board.h
  • at32_button_state() : at32f413_board.c, at32f413_board.h
  • at32_led_init() : at32f413_board.c, at32f413_board.h
  • at32_led_off() : at32f413_board.c, at32f413_board.h
  • at32_led_on() : at32f413_board.c, at32f413_board.h
  • at32_led_toggle() : at32f413_board.c, at32f413_board.h
  • audio_codec_init() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_loop() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_alt_setting() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_mic_get_data() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_modify_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_mute() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_mic_volume() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_freq() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_mute() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_set_spk_volume() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_alt_setting() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_feedback() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_codec_spk_fifo_write() : audio/inc/audio_codec.h, audio/src/audio_codec.c, composite_audio_hid/inc/audio_codec.h, composite_audio_hid/src/audio_codec.c
  • audio_get_interface() : audio_class.c, audio_hid_class.c
  • audio_hid_class_send_report() : audio_hid_class.c, audio_hid_class.h
  • audio_req_get_cur() : audio_class.c, audio_hid_class.c
  • audio_req_get_max() : audio_class.c, audio_hid_class.c
  • audio_req_get_min() : audio_class.c, audio_hid_class.c
  • audio_req_get_res() : audio_class.c, audio_hid_class.c
  • audio_req_set_cur() : audio_class.c, audio_hid_class.c
  • audio_set_interface() : audio_class.c, audio_hid_class.c


AT32F413 Firmwary Library: Globals

- b -

  • back_err() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/iap.h, bootloader/src/iap.c
  • back_ok() : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/iap.h, bootloader/src/iap.c
  • bot_cbw_decode() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_allow_medium_removal() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_check_address() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_clear_feature() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_cmd_process() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_datain_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_dataout_handler() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_format_capacity() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_init() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_inquiry() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_mode_sense6() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_read10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_request_sense() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_reset() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_csw() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_send_data() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_sense_code() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_stall() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_start_stop() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_test_unit() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_verify() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bot_scsi_write10() : cdc_msc_class.h, composite_cdc_msc/msc_bot_scsi.c, msc_bot_scsi.h
  • bpr_data_read() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_data_write() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_flag_clear() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_flag_get() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_interrupt_enable() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_reg_check() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reg_judge() : project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reg_write() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • bpr_reset() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_rtc_clock_calibration_value_set() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_rtc_output_select() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_tamper_pin_active_level_set() : at32f413_bpr.h, at32f413_bpr.c
  • bpr_tamper_pin_enable() : at32f413_bpr.h, at32f413_bpr.c
  • buffer_compare() : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/flash/flash_write_read/src/main.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • buffer_compare_24bits() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c
  • BusFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • button_exint_init() : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/templates/src/main.c
  • button_isr() : project/at_start_f413/templates/src/main.c


AT32F413 Firmwary Library: Globals

- c -

  • CAN1_SE_IRQHandler() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_base_init() : at32f413_can.h, at32f413_can.c
  • can_baudrate_default_para_init() : at32f413_can.h, at32f413_can.c
  • can_baudrate_set() : at32f413_can.h, at32f413_can.c
  • can_configuration() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_debug_transmission_prohibit() : at32f413_can.h, at32f413_can.c
  • can_default_para_init() : at32f413_can.h, at32f413_can.c
  • can_doze_mode_enter() : at32f413_can.h, at32f413_can.c
  • can_doze_mode_exit() : at32f413_can.h, at32f413_can.c
  • can_error_type_record_get() : at32f413_can.h, at32f413_can.c
  • can_filter_default_para_init() : at32f413_can.h, at32f413_can.c
  • can_filter_init() : at32f413_can.h, at32f413_can.c
  • can_flag_clear() : at32f413_can.h, at32f413_can.c
  • can_flag_get() : at32f413_can.h, at32f413_can.c
  • can_gpio_config() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_interrupt_enable() : at32f413_can.h, at32f413_can.c
  • can_message_receive() : at32f413_can.h, at32f413_can.c
  • can_message_transmit() : at32f413_can.h, at32f413_can.c
  • can_operating_mode_set() : at32f413_can.h, at32f413_can.c
  • can_receive_error_counter_get() : at32f413_can.h, at32f413_can.c
  • can_receive_fifo_release() : at32f413_can.h, at32f413_can.c
  • can_receive_message_pending_get() : at32f413_can.h, at32f413_can.c
  • can_reset() : at32f413_can.h, at32f413_can.c
  • can_transmit_cancel() : at32f413_can.h, at32f413_can.c
  • can_transmit_data() : project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c
  • can_transmit_error_counter_get() : at32f413_can.h, at32f413_can.c
  • can_transmit_status_get() : at32f413_can.h, at32f413_can.c
  • can_ttc_mode_enable() : at32f413_can.h, at32f413_can.c
  • cdc_class_setup_handler() : cdc_keyboard_class.c, cdc_msc_class.c
  • cdc_struct_init() : cdc_class.c, cdc_msc_class.c
  • check_card_programming() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • class_audio_setup_handler() : audio_hid_class.c
  • class_clear_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_rx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_ept0_tx_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_event_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_hid_setup_handler() : audio_hid_class.c
  • class_in_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_init_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_out_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_setup_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • class_sof_handler() : audio_class.c, audio_hid_class.c, cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c, custom_hid_class.c, hid_iap_class.c, keyboard_class.c, mouse_class.c, msc_class.c, printer_class.c
  • clkout_config() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c, project/at_start_f413/examples/crm/sysclk_switch/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • clock_failure_detection_handler() : project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
  • codec_i2s_init() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • codec_i2s_reset() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • command_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_handle() : bootloader/inc/iap.h, bootloader/src/iap.c
  • command_rsp1_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp2_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp3_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp4_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp5_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp6_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • command_rsp7_error() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • config_flash_interrupt() : utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • convert_from_bytes_to_power_of_two() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • copy_buff() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • crc_block_calculate() : at32f413_crc.h, at32f413_crc.c
  • crc_cal() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • crc_common_data_set() : at32f413_crc.h, at32f413_crc.c
  • crc_common_date_get() : at32f413_crc.h, at32f413_crc.c
  • crc_data_get() : at32f413_crc.h, at32f413_crc.c
  • crc_data_reset() : at32f413_crc.h, at32f413_crc.c
  • crc_init_data_set() : at32f413_crc.h, at32f413_crc.c
  • crc_one_word_calculate() : at32f413_crc.h, at32f413_crc.c
  • crc_reverse_input_data_set() : at32f413_crc.h, at32f413_crc.c
  • crc_reverse_output_data_set() : at32f413_crc.h, at32f413_crc.c
  • crm_adc_clock_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_ahb_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_apb1_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_apb2_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_auto_step_mode_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_battery_powered_domain_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_clkout_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_clkout_to_tmr10_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_clock_failure_detection_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_clock_out_set() : at32f413_crm.h, at32f413_crm.c
  • crm_clock_source_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_clocks_freq_get() : at32f413_crm.h, at32f413_crm.c
  • crm_configuration() : project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • crm_flag_clear() : at32f413_crm.h, at32f413_crm.c
  • crm_flag_get() : at32f413_crm.h, at32f413_crm.c
  • crm_hext_bypass() : at32f413_crm.h, at32f413_crm.c
  • crm_hext_stable_wait() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_clock_calibration_set() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_clock_trimming_set() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_divider_select() : at32f413_crm.h, at32f413_crm.c
  • crm_hick_sclk_frequency_select() : at32f413_crm.h, at32f413_crm.c
  • crm_interrupt_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_lext_bypass() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_periph_sleep_mode_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_pll_config() : at32f413_crm.h, at32f413_crm.c
  • crm_reset() : at32f413_crm.h, at32f413_crm.c
  • crm_rtc_clock_enable() : at32f413_crm.h, at32f413_crm.c
  • crm_rtc_clock_select() : at32f413_crm.h, at32f413_crm.c
  • crm_sysclk_switch() : at32f413_crm.h, at32f413_crm.c
  • crm_sysclk_switch_status_get() : at32f413_crm.h, at32f413_crm.c
  • crm_usb_clock_div_set() : at32f413_crm.h, at32f413_crm.c
  • crm_usb_clock_source_select() : at32f413_crm.h, at32f413_crm.c
  • crm_usb_interrupt_remapping_set() : at32f413_crm.h, at32f413_crm.c
  • custom_hid_class_send_report() : custom_hid_class.c, custom_hid_class.h


AT32F413 Firmwary Library: Globals

- d -

  • data_take() : bootloader/src/iap.c
  • debug_device_id_get() : at32f413_debug.h, at32f413_debug.c
  • debug_periph_mode_set() : at32f413_debug.h, at32f413_debug.c
  • DebugMon_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • delay() : project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c
  • delay_init() : at32f413_board.c, at32f413_board.h
  • delay_ms() : at32f413_board.c, at32f413_board.h
  • delay_sec() : at32f413_board.c, at32f413_board.h
  • delay_us() : at32f413_board.c, at32f413_board.h
  • disk_initialize() : diskio.c
  • disk_ioctl() : diskio.c
  • disk_read() : diskio.c
  • disk_status() : diskio.c
  • disk_write() : diskio.c
  • DMA1_Channel1_IRQHandler() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
  • DMA1_Channel2_IRQHandler() : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
  • DMA1_Channel3_IRQHandler() : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • DMA1_Channel4_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • DMA1_Channel5_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • DMA1_Channel6_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
  • DMA1_Channel7_IRQHandler() : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
  • DMA2_Channel1_IRQHandler() : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c
  • dma_channel_enable() : at32f413_dma.h, at32f413_dma.c
  • dma_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • dma_configuration() : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • dma_data_number_get() : at32f413_dma.h, at32f413_dma.c
  • dma_data_number_set() : at32f413_dma.h, at32f413_dma.c
  • dma_default_para_init() : at32f413_dma.h, at32f413_dma.c
  • dma_flag_clear() : at32f413_dma.h, at32f413_dma.c
  • dma_flag_get() : at32f413_dma.h, at32f413_dma.c
  • dma_flexible_config() : at32f413_dma.h, at32f413_dma.c
  • dma_init() : at32f413_dma.h, at32f413_dma.c
  • dma_interrupt_enable() : at32f413_dma.h, at32f413_dma.c
  • dma_reset() : at32f413_dma.h, at32f413_dma.c


AT32F413 Firmwary Library: Globals

- e -

  • error_handler() : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • EXINT0_IRQHandler() : project/at_start_f413/examples/exint/exint_config/src/main.c, project/at_start_f413/templates/src/main.c
  • EXINT4_IRQHandler() : project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • EXINT9_5_IRQHandler() : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
  • exint_config() : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
  • exint_default_para_init() : at32f413_exint.h, at32f413_exint.c
  • exint_event_enable() : at32f413_exint.h, at32f413_exint.c
  • exint_flag_clear() : at32f413_exint.h, at32f413_exint.c
  • exint_flag_get() : at32f413_exint.h, at32f413_exint.c
  • exint_init() : at32f413_exint.h, at32f413_exint.c
  • exint_interrupt_enable() : at32f413_exint.h, at32f413_exint.c
  • exint_line0_config() : project/at_start_f413/examples/exint/exint_config/src/main.c
  • exint_line4_config() : project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • exint_reset() : at32f413_exint.h, at32f413_exint.c
  • exint_software_interrupt_event_generate() : at32f413_exint.h, at32f413_exint.c
  • extend_sram() : project/at_start_f413/examples/sram/extend_sram/src/main.c


AT32F413 Firmwary Library: Globals

- f -

  • fat16_memory_cmp() : flash_fat16.c
  • fat16_memory_copy() : flash_fat16.c
  • fat16_memory_memset() : flash_fat16.c
  • fatfs_test() : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • FIR_lowpass_filter() : project_l0/inc/fir_filter.h, fir_filter.c, project_l1/inc/fir_filter.h
  • flash_2kb_write() : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
  • flash_byte_program() : at32f413_flash.h, at32f413_flash.c
  • flash_crc_calibrate() : at32f413_flash.h, at32f413_flash.c
  • flash_crc_check() : flash_fat16.c
  • flash_epp_set() : at32f413_flash.h, at32f413_flash.c
  • flash_epp_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_fap_enable() : at32f413_flash.h, at32f413_flash.c
  • flash_fap_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_fat16_addr_offset() : flash_fat16.c
  • flash_fat16_boot_dir_write() : flash_fat16.c
  • flash_fat16_clear_upgrade_flag() : flash_fat16.c
  • flash_fat16_get_upgrade_flag() : flash_fat16.h, flash_fat16.c
  • flash_fat16_init() : flash_fat16.h, flash_fat16.c
  • flash_fat16_loop_status() : flash_fat16.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
  • flash_fat16_read() : flash_fat16.h, flash_fat16.c
  • flash_fat16_sector_write() : flash_fat16.c
  • flash_fat16_set_name() : flash_fat16.h, flash_fat16.c
  • flash_fat16_set_upgrade_flag() : flash_fat16.c
  • flash_fat16_write() : flash_fat16.h, flash_fat16.c
  • flash_flag_clear() : at32f413_flash.h, at32f413_flash.c
  • flash_flag_get() : at32f413_flash.h, at32f413_flash.c
  • flash_halfword_program() : at32f413_flash.h, at32f413_flash.c
  • flash_internal_all_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_interrupt_enable() : at32f413_flash.h, at32f413_flash.c
  • FLASH_IRQHandler() : utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c
  • flash_lock() : at32f413_flash.h, at32f413_flash.c
  • flash_operation_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_operation_wait_for() : at32f413_flash.h, at32f413_flash.c
  • flash_read() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_read_data() : flash_fat16.c
  • flash_sector_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_datstart_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_disable() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_enable() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_end_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_remaining_count_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_start_sector_get() : at32f413_flash.h, at32f413_flash.c
  • flash_slib_state_get() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_all_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_encryption_range_set() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_lock() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_model_select() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_operation_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_operation_wait_for() : at32f413_flash.h, at32f413_flash.c
  • flash_spim_unlock() : at32f413_flash.h, at32f413_flash.c
  • flash_ssb_set() : at32f413_flash.h, at32f413_flash.c
  • flash_ssb_status_get() : at32f413_flash.h, at32f413_flash.c
  • flash_unlock() : at32f413_flash.h, at32f413_flash.c
  • flash_upgrade_flag_read() : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
  • flash_user_system_data_erase() : at32f413_flash.h, at32f413_flash.c
  • flash_user_system_data_program() : at32f413_flash.h, at32f413_flash.c
  • flash_word_program() : at32f413_flash.h, at32f413_flash.c
  • flash_write() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_write_data() : flash_fat16.c
  • flash_write_nocheck() : project/at_start_f413/examples/flash/flash_write_read/inc/flash.h, project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • fputc() : at32f413_board.c


AT32F413 Firmwary Library: Globals

- g -

  • generate_julia_fpu() : julia_fpu.h, julia_fpu.c
  • get_device_config_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_configuration() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_descriptor() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_interface_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_lang_id() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_manufacturer_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_other_speed() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_product_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_qualifier() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_device_serial_string() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_inquiry() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • get_serial_num() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • get_uid_for_seed() : random.c
  • getvar_operationcomplete() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • gpio_bits_reset() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_bits_set() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_bits_write() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_config() : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • gpio_configuration() : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • gpio_default_para_init() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_event_output_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_event_output_enable() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_exint_line_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_init() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_input_data_bit_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_input_data_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_iomux_reset() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_output_data_bit_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_output_data_read() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_pin_remap_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_pin_wp_config() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_pins_toggle() : project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
  • gpio_port_wirte() : at32f413_gpio.h, at32f413_gpio.c
  • gpio_reset() : at32f413_gpio.h, at32f413_gpio.c


AT32F413 Firmwary Library: Globals

- h -

  • HardFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c


AT32F413 Firmwary Library: Globals

- i -

  • I2C1_ERR_IRQHandler() : project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
  • I2C1_EVT_IRQHandler() : project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
  • I2C2_ERR_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2C2_EVT_IRQHandler() : project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • i2c_7bit_address_send() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_ack_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_addr_flag_clear() : i2c_application.c
  • i2c_arp_mode_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_clock_stretch_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_config() : i2c_application.c, i2c_application.h
  • i2c_data_receive() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_data_send() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_dma_config() : i2c_application.c
  • i2c_dma_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_dma_end_transfer_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_dma_rx_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_dma_tx_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_err_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_evt_irq_handler() : i2c_application.c, i2c_application.h
  • i2c_fast_mode_duty_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_flag_clear() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_flag_get() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_general_call_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_init() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_interrupt_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_lowlevel_init() : i2c_application.c, i2c_application.h, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • i2c_master_read_addr() : i2c_application.c
  • i2c_master_receive() : i2c_application.c, i2c_application.h
  • i2c_master_receive_ack_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_master_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_master_receive_int() : i2c_application.c, i2c_application.h
  • i2c_master_rx_isr_int() : i2c_application.c
  • i2c_master_transmit() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_master_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_master_tx_isr_int() : i2c_application.c
  • i2c_master_write_addr() : i2c_application.c
  • i2c_memory_read() : i2c_application.c, i2c_application.h
  • i2c_memory_read_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_read_int() : i2c_application.c, i2c_application.h
  • i2c_memory_write() : i2c_application.c, i2c_application.h
  • i2c_memory_write_dma() : i2c_application.c, i2c_application.h
  • i2c_memory_write_int() : i2c_application.c, i2c_application.h
  • i2c_own_address1_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_own_address2_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_own_address2_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_calculate_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_position_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_transmit_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_pec_value_get() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_reset() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_reset_ctrl2_register() : i2c_application.h
  • i2c_slave_receive() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_receive_int() : i2c_application.c, i2c_application.h
  • i2c_slave_rx_isr_int() : i2c_application.c
  • i2c_slave_transmit() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_dma() : i2c_application.c, i2c_application.h
  • i2c_slave_transmit_int() : i2c_application.c, i2c_application.h
  • i2c_slave_tx_isr_int() : i2c_application.c
  • i2c_smbus_alert_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_smbus_enable() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_smbus_mode_set() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_software_reset() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_start_generate() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_stop_flag_clear() : i2c_application.c
  • i2c_stop_generate() : at32f413_i2c.h, at32f413_i2c.c
  • i2c_wait_end() : i2c_application.c, i2c_application.h
  • i2c_wait_flag() : i2c_application.c, i2c_application.h
  • i2s_config() : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • i2s_default_para_init() : at32f413_spi.h, at32f413_spi.c
  • i2s_enable() : at32f413_spi.h, at32f413_spi.c
  • i2s_init() : at32f413_spi.h, at32f413_spi.c
  • iap_address() : bootloader/src/hid_iap_user.c
  • iap_clear_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_command_handle() : app_led3_toggle/inc/iap.h, app_led3_toggle/src/iap.c, app_led4_toggle/inc/iap.h, app_led4_toggle/src/iap.c
  • iap_crc() : bootloader/src/hid_iap_user.c
  • iap_data_write() : bootloader/src/hid_iap_user.c
  • iap_erase_sector() : bootloader/src/hid_iap_user.c
  • iap_finish() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_get() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_get_upgrade_flag() : app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_idle() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_init() : app_led3_toggle/inc/iap.h, app_led3_toggle/src/iap.c, app_led4_toggle/inc/iap.h, app_led4_toggle/src/iap.c, app_led3_toggle/inc/hid_iap_user.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/inc/hid_iap_user.h, app_led4_toggle/src/hid_iap_user.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_jump() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_loop() : bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c
  • iap_respond() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_set_upgrade_flag() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_start() : app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • iap_upgrade_app_handle() : bootloader/inc/iap.h, bootloader/src/iap.c
  • incrementvar_operationcomplete() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • is_leap_year() : rtc.c


AT32F413 Firmwary Library: Globals

- j -

  • jump_to_app() : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, bootloader/inc/hid_iap_user.h, bootloader/src/hid_iap_user.c


AT32F413 Firmwary Library: Globals

- k -

  • keyboard_class_setup_handler() : cdc_keyboard_class.c
  • keyboard_send_string() : project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c


AT32F413 Firmwary Library: Globals

- l -

  • led2_task_function() : utilities/at32f413_freertos_demo/src/main.c
  • led3_task_function() : utilities/at32f413_freertos_demo/src/main.c


AT32F413 Firmwary Library: Globals

- m -

  • main() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c, project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c, project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c, project/at_start_f413/examples/cortex_m4/bit_band/src/main.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, project/at_start_f413/examples/cortex_m4/fpu/src/main.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f413/examples/crc/calculation/src/main.c, project/at_start_f413/examples/crm/clock_failure_detection/src/main.c, project/at_start_f413/examples/crm/sysclk_switch/src/main.c, project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/exint/exint_config/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c, project/at_start_f413/examples/flash/flash_write_read/src/main.c, project/at_start_f413/examples/flash/operate_spim/src/main.c, project/at_start_f413/examples/flash/run_in_spim/src/main.c, project/at_start_f413/examples/gpio/led_toggle/src/main.c, project/at_start_f413/examples/gpio/swjtag_remap/src/main.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c, project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c, project/at_start_f413/examples/pwc/sleep_usart1/src/main.c, project/at_start_f413/examples/pwc/standby_rtc/src/main.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c, project/at_start_f413/examples/rtc/calendar/src/main.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/sram/extend_sram/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c, project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/idle_detection/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/irda/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/printf/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/rs485/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, project/at_start_f413/examples/wdt/wdt_reset/src/main.c, project/at_start_f413/examples/wdt/wdt_standby/src/main.c, project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c, project/at_start_f413/templates/src/main.c, utilities/at32f413_freertos_demo/src/main.c, utilities/at32f413_gen_random_number_demo/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • mclk_tmr1_init() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • MemManage_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • memset16_buffer() : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • mmc_stream_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • mmc_stream_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mmc_stream_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • mmc_switch() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • msc_class_setup_handler() : cdc_msc_class.c
  • msc_disk_capacity() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_read() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • msc_disk_write() : composite_vcp_msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • my_memset() : arm_fir_init_f32.c


AT32F413 Firmwary Library: Globals

- n -

  • NMI_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • nvic_configuration() : project/at_start_f413/examples/rtc/lick_calibration/src/main.c, project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c
  • nvic_irq_disable() : at32f413_misc.h, at32f413_misc.c
  • nvic_irq_enable() : at32f413_misc.h, at32f413_misc.c
  • nvic_lowpower_mode_config() : at32f413_misc.h, at32f413_misc.c
  • nvic_priority_group_config() : at32f413_misc.h, at32f413_misc.c
  • nvic_system_reset() : at32f413_misc.h, at32f413_misc.c
  • nvic_vector_table_set() : at32f413_misc.h, at32f413_misc.c


AT32F413 Firmwary Library: Globals

- p -

  • PendSV_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • pvm_exint_config() : project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c
  • PVM_IRQHandler() : project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c
  • pwc_battery_powered_domain_access() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_deep_sleep_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_flag_clear() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_flag_get() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_power_voltage_monitor_enable() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_pvm_level_select() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_reset() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_sleep_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_standby_mode_enter() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_voltage_regulate_set() : at32f413_pwc.h, at32f413_pwc.c
  • pwc_wakeup_pin_enable() : at32f413_pwc.h, at32f413_pwc.c


AT32F413 Firmwary Library: Globals

- r -

  • randnum_test() : random.h, random.c
  • result_error() : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • rs485_config() : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_send_data() : project/at_start_f413/examples/usart/rs485/src/main.c
  • rtc_alarm_clock_set() : rtc.h, rtc.c
  • rtc_alarm_config() : project/at_start_f413/examples/pwc/standby_rtc/src/main.c
  • rtc_alarm_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_config() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/pwc/standby_rtc/src/main.c
  • rtc_configuration() : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • rtc_counter_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_counter_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_divider_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_divider_set() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_flag_clear() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_flag_get() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_init() : rtc.h, rtc.c
  • rtc_interrupt_enable() : at32f413_rtc.h, at32f413_rtc.c
  • RTC_IRQHandler() : project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • rtc_time_get() : rtc.h, rtc.c
  • rtc_time_set() : rtc.h, rtc.c
  • rtc_wait_config_finish() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_wait_update_finish() : at32f413_rtc.h, at32f413_rtc.c
  • rtc_week_get() : rtc.c
  • RTCAlarm_IRQHandler() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c


AT32F413 Firmwary Library: Globals

- s -

  • sc_response_decode() : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_USART_IRQHandler() : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
  • sclk_192m_hick_config() : project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
  • sclk_64m_hick_config() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • sclk_96m_hext_config() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • scr_find() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sd_block_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_block_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_blocks_erase() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_bus_wide_enable() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sd_card_info_get() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_card_init() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_deselect_select() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_device_mode_set() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_dma_config() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_init() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_irq_service() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_mult_blocks_read() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_mult_blocks_write() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_multiple_blocks_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sd_power_off() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_power_on() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_single_block_test() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sd_state_get() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_status_send() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_switch() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sd_test_error() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • sd_wide_bus_operation_config() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sd_write_disk() : diskio.c
  • SDIO1_IRQHandler() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SDIO2_IRQHandler() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_buffer_counter_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_bus_width_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_bypass() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_clock_set() : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sdio_command_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_command_data_send() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_command_response_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_command_state_machine_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_config() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_counter_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_read() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_state_machine_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_data_write() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_dma_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flag_clear() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flag_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_flow_control_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_interrupt_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_io_function_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_io_suspend_command_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_saving_mode_enable() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_power_status_get() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_mode_set() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_start() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_read_wait_stop() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_reset() : at32f413_sdio.h, at32f413_sdio.c
  • sdio_response_get() : at32f413_sdio.h, at32f413_sdio.c
  • sector_read() : operate_spim.c
  • setvar_periodvalue() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • show_card_info() : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • slib_enable() : utilities/at32f413_slib_demo/project_l0/src/main.c
  • speed_change() : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • SPI1_IRQHandler() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • SPI2_IRQHandler() : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • spi_byte_read() : spi_flash.h, spi_flash.c
  • spi_byte_write() : spi_flash.h, spi_flash.c
  • spi_bytes_read() : spi_flash.h, spi_flash.c
  • spi_bytes_write() : spi_flash.h, spi_flash.c
  • spi_config() : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi_crc_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_next_transmit() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_polynomial_get() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_polynomial_set() : at32f413_spi.h, at32f413_spi.c
  • spi_crc_value_get() : at32f413_spi.h, at32f413_spi.c
  • spi_default_para_init() : at32f413_spi.h, at32f413_spi.c
  • spi_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_frame_bit_num_set() : at32f413_spi.h, at32f413_spi.c
  • spi_half_duplex_direction_set() : at32f413_spi.h, at32f413_spi.c
  • spi_hardware_cs_output_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_data_receive() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_data_transmit() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_dma_receiver_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_dma_transmitter_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_flag_clear() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_flag_get() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_interrupt_enable() : at32f413_spi.h, at32f413_spi.c
  • spi_i2s_reset() : at32f413_spi.h, at32f413_spi.c
  • spi_init() : at32f413_spi.h, at32f413_spi.c
  • spi_software_cs_internal_level_set() : at32f413_spi.h, at32f413_spi.c
  • spiflash_init() : spi_flash.h, spi_flash.c
  • spiflash_page_write() : spi_flash.h, spi_flash.c
  • spiflash_read() : spi_flash.h, spi_flash.c
  • spiflash_read_id() : spi_flash.h, spi_flash.c
  • spiflash_read_sr1() : spi_flash.h, spi_flash.c
  • spiflash_sector_erase() : spi_flash.h, spi_flash.c
  • spiflash_wait_busy() : spi_flash.h, spi_flash.c
  • spiflash_write() : spi_flash.h, spi_flash.c
  • spiflash_write_enable() : spi_flash.h, spi_flash.c
  • spiflash_write_nocheck() : spi_flash.h, spi_flash.c
  • spim_init() : operate_spim.c, project/at_start_f413/examples/flash/run_in_spim/src/main.c
  • spim_operate() : operate_spim.h, operate_spim.c
  • spim_run() : run_in_spim.h
  • SVC_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • switch_system_clock() : project/at_start_f413/examples/crm/sysclk_switch/src/main.c
  • swj_dp_config() : project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
  • system_clock_config() : project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h, project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c, project/at_start_f413/examples/can/filter/inc/at32f413_clock.h, project/at_start_f413/examples/can/filter/src/at32f413_clock.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h, project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c, project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h, project/at_start_f413/examples/usart/irda/src/at32f413_clock.c, project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h, project/at_start_f413/examples/usart/polling/src/at32f413_clock.c, project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h, project/at_start_f413/examples/usart/printf/src/at32f413_clock.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h, project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c, project/at_start_f413/templates/inc/at32f413_clock.h, project/at_start_f413/templates/src/at32f413_clock.c, utilities/at32f413_freertos_demo/inc/at32f413_clock.h, utilities/at32f413_freertos_demo/src/at32f413_clock.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h, utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c
  • system_clock_config_for_acc() : project/at_start_f413/examples/acc/calibration/src/main.c
  • system_clock_recover() : project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • system_core_clock_update() : system_at32f413.c, system_at32f413.h
  • SystemInit() : system_at32f413.c, system_at32f413.h
  • systick_clock_source_config() : at32f413_misc.h, at32f413_misc.c
  • systick_configuration() : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • systick_handler() : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c
  • SysTick_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c


AT32F413 Firmwary Library: Globals

- t -

  • TAMPER_IRQHandler() : project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c
  • TMR1_BRK_TMR9_IRQHandler() : project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c
  • tmr1_config() : project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
  • TMR1_OVF_TMR10_IRQHandler() : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/exint/exint_software_trigger/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • TMR1_TRG_HALL_TMR11_IRQHandler() : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • tmr2_config() : project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c
  • TMR2_GLOBAL_IRQHandler() : project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
  • TMR3_GLOBAL_IRQHandler() : project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, app_led3_toggle/src/tmr.c, app_led4_toggle/src/tmr.c, bootloader/src/tmr.c
  • TMR5_GLOBAL_IRQHandler() : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • tmr_32_bit_function_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_base_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_brkdt_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_brkdt_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel1_input_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_dma_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_channel_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_clock_source_div_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_cnt_dir_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_counter_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_div_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_div_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_dma_control_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_dma_request_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_encoder_mode_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_event_sw_trigger() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_mode1_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_external_clock_mode2_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_flag_clear() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_flag_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_force_output_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_hall_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_init() : app_led3_toggle/inc/tmr.h, app_led3_toggle/src/tmr.c, app_led4_toggle/inc/tmr.h, app_led4_toggle/src/tmr.c, bootloader/inc/tmr.h, bootloader/src/tmr.c
  • tmr_input_channel_divider_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_channel_filter_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_channel_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_input_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_internal_clock_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_interrupt_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_one_cycle_mode_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_immediately_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_polarity_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_channel_switch_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_default_para_init() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_output_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_overflow_event_disable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_overflow_request_source_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_buffer_enable() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_value_get() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_period_value_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_primary_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_pwm_input_config() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_repetition_counter_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_reset() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_sub_mode_select() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_sub_sync_mode_set() : at32f413_tmr.h, at32f413_tmr.c
  • tmr_trigger_input_select() : at32f413_tmr.h, at32f413_tmr.c
  • tx_data_fill() : project/at_start_f413/examples/spi/w25q_flash/src/main.c


AT32F413 Firmwary Library: Globals

- u -

  • uart_init() : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c, bootloader/inc/usart.h, bootloader/src/usart.c
  • uart_print_init() : at32f413_board.c, at32f413_board.h
  • UsageFault_Handler() : project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h, project/at_start_f413/examples/acc/calibration/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h, project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h, project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h, project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c, project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h, project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c, project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c, project/at_start_f413/examples/can/filter/inc/at32f413_int.h, project/at_start_f413/examples/can/filter/src/at32f413_int.c, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h, project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c, project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h, project/at_start_f413/examples/crc/calculation/src/at32f413_int.c, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h, project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h, project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c, project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h, project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h, project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h, project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h, project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h, project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h, project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h, project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h, project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h, project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h, project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c, project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h, project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h, project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h, project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h, project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h, project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h, project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h, project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h, project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h, project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h, project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h, project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h, project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h, project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h, project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h, project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h, project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h, project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h, project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h, project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/irda/inc/at32f413_int.h, project/at_start_f413/examples/usart/irda/src/at32f413_int.c, project/at_start_f413/examples/usart/polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/polling/src/at32f413_int.c, project/at_start_f413/examples/usart/printf/inc/at32f413_int.h, project/at_start_f413/examples/usart/printf/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h, project/at_start_f413/examples/usart/rs485/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h, project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h, project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c, project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c, project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c, project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h, project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h, project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c, project/at_start_f413/templates/inc/at32f413_int.h, project/at_start_f413/templates/src/at32f413_int.c, utilities/at32f413_freertos_demo/inc/at32f413_int.h, utilities/at32f413_freertos_demo/src/at32f413_int.c, utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h, utilities/at32f413_gen_random_number_demo/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c, utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h, utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
  • usart1_config() : project/at_start_f413/examples/pwc/sleep_usart1/src/main.c
  • USART1_IRQHandler() : project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c, app_led3_toggle/src/usart.c, app_led4_toggle/src/usart.c, bootloader/src/usart.c
  • USART2_IRQHandler() : project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/rs485/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • USART3_IRQHandler() : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c
  • usart_break_bit_num_set() : at32f413_usart.h, at32f413_usart.c
  • usart_break_send() : at32f413_usart.h, at32f413_usart.c
  • usart_clock_config() : at32f413_usart.h, at32f413_usart.c
  • usart_clock_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_configuration() : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/idle_detection/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/irda/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart_data_receive() : at32f413_usart.h, at32f413_usart.c
  • usart_data_transmit() : at32f413_usart.h, at32f413_usart.c
  • usart_dma_receiver_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_dma_transmitter_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_flag_clear() : at32f413_usart.h, at32f413_usart.c
  • usart_flag_get() : at32f413_usart.h, at32f413_usart.c
  • usart_gpio_config() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_hardware_flow_control_set() : at32f413_usart.h, at32f413_usart.c
  • usart_init() : at32f413_usart.h, at32f413_usart.c
  • usart_interrupt_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_low_power_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_irda_smartcard_division_set() : at32f413_usart.h, at32f413_usart.c
  • usart_lin_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_parity_selection_config() : at32f413_usart.h, at32f413_usart.c
  • usart_receive_data() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_receiver_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_receiver_mute_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_reset() : at32f413_usart.h, at32f413_usart.c
  • usart_send_data() : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_single_line_halfduplex_select() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_guard_time_set() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_mode_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_smartcard_nack_set() : at32f413_usart.h, at32f413_usart.c
  • usart_spi_configuration() : project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart_transmitter_enable() : at32f413_usart.h, at32f413_usart.c
  • usart_wakeup_id_set() : at32f413_usart.h, at32f413_usart.c
  • usart_wakeup_mode_set() : at32f413_usart.h, at32f413_usart.c
  • usb_buffer_free() : at32f413_usb.h, at32f413_usb.c
  • usb_buffer_malloc() : at32f413_usb.h, at32f413_usb.c
  • usb_clock48m_select() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_connect() : at32f413_usb.h, at32f413_usb.c
  • usb_delay_ms() : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_delay_us() : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
  • usb_dev_init() : at32f413_usb.h, at32f413_usb.c
  • usb_disconnect() : at32f413_usb.h, at32f413_usb.c
  • usb_enter_suspend() : at32f413_usb.h, at32f413_usb.c
  • usb_ept_close() : at32f413_usb.h, at32f413_usb.c
  • usb_ept_open() : at32f413_usb.h, at32f413_usb.c
  • usb_ept_stall() : at32f413_usb.h, at32f413_usb.c
  • usb_exit_suspend() : at32f413_usb.h, at32f413_usb.c
  • usb_flag_clear() : at32f413_usb.h, at32f413_usb.c
  • usb_flag_get() : at32f413_usb.h, at32f413_usb.c
  • usb_hid_buf_process() : audio_hid_class.c, custom_hid_class.c
  • usb_hid_keyboard_send_char() : keyboard_class.c, keyboard_class.h
  • usb_hid_mouse_send() : mouse_class.c, mouse_class.h
  • usb_iap_class_send_report() : hid_iap_class.c, hid_iap_class.h
  • usb_interrupt_enable() : at32f413_usb.h, at32f413_usb.c
  • usb_keyboard_class_send_report() : keyboard_class.c, keyboard_class.h
  • usb_low_power_wakeup_config() : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • usb_mouse_class_send_report() : mouse_class.c, mouse_class.h
  • usb_printer_get_rxdata() : printer_class.c, printer_class.h
  • usb_printer_send_data() : printer_class.c, printer_class.h
  • usb_read_packet() : at32f413_usb.h, at32f413_usb.c
  • usb_remote_wkup_clear() : at32f413_usb.h, at32f413_usb.c
  • usb_remote_wkup_set() : at32f413_usb.h, at32f413_usb.c
  • usb_reset() : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
  • usb_set_address() : at32f413_usb.h, at32f413_usb.c
  • usb_usart_config() : cdc_class.c, cdc_msc_class.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_usbbufs_enable() : at32f413_usb.h, at32f413_usb.c
  • usb_vcp_cmd_process() : cdc_class.c, cdc_keyboard_class.c, cdc_msc_class.c
  • usb_vcp_get_rxdata() : cdc_class.c, cdc_class.h, cdc_msc_class.c, cdc_msc_class.h
  • usb_vcp_send_data() : cdc_class.c, cdc_class.h, cdc_msc_class.c, cdc_msc_class.h
  • usb_vcpkybrd_class_send_report() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_keyboard_send_char() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_get_rxdata() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_vcpkybrd_vcp_send_data() : cdc_keyboard_class.c, cdc_keyboard_class.h
  • usb_write_packet() : at32f413_usb.h, at32f413_usb.c
  • usbd_clear_feature() : usbd_sdr.c
  • usbd_clear_stall() : usbd_core.h, usbd_core.c
  • usbd_connect() : usbd_core.h, usbd_core.c
  • usbd_connect_state_get() : usbd_core.h, usbd_core.c
  • usbd_core_in_handler() : usbd_core.h, usbd_core.c
  • usbd_core_init() : usbd_core.h, usbd_core.c
  • usbd_core_out_handler() : usbd_core.h, usbd_core.c
  • usbd_core_setup_handler() : usbd_core.h, usbd_core.c
  • usbd_ctrl_recv() : usbd_core.h, usbd_core.c
  • usbd_ctrl_recv_status() : usbd_core.h, usbd_core.c
  • usbd_ctrl_send() : usbd_core.h, usbd_core.c
  • usbd_ctrl_send_status() : usbd_core.h, usbd_core.c
  • usbd_ctrl_unsupport() : usbd_core.h, usbd_core.c
  • usbd_device_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_disconnect() : usbd_core.h, usbd_core.c
  • usbd_endpoint_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_enter_suspend() : usbd_core.h, usbd_core.c
  • usbd_ept_buf_auto_define() : usbd_core.h, usbd_core.c
  • usbd_ept_buf_custom_define() : usbd_core.h, usbd_core.c
  • usbd_ept_close() : usbd_core.h, usbd_core.c
  • usbd_ept_dbuffer_enable() : usbd_core.h, usbd_core.c
  • usbd_ept_defaut_init() : usbd_core.h, usbd_core.c
  • usbd_ept_loop_handler() : usbd_int.h, usbd_int.c
  • usbd_ept_open() : usbd_core.h, usbd_core.c
  • usbd_ept_recv() : usbd_core.h, usbd_core.c
  • usbd_ept_send() : usbd_core.h, usbd_core.c
  • usbd_eptn_handler() : usbd_int.h, usbd_int.c
  • usbd_get_configuration() : usbd_sdr.c
  • usbd_get_descriptor() : usbd_sdr.c
  • usbd_get_recv_len() : usbd_core.h, usbd_core.c
  • usbd_get_status() : usbd_sdr.c
  • usbd_hid_iap_in_complete() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • usbd_hid_iap_process() : hid_iap_class.h, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • usbd_int_to_unicode() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • usbd_interface_request() : usbd_sdr.h, usbd_sdr.c
  • usbd_irq_handler() : usbd_int.h, usbd_int.c
  • usbd_remote_wakeup() : usbd_core.h, usbd_core.c
  • usbd_reset_handler() : usbd_int.h, usbd_int.c
  • usbd_set_address() : usbd_sdr.c
  • usbd_set_configuration() : usbd_sdr.c
  • usbd_set_device_addr() : usbd_core.h, usbd_core.c
  • usbd_set_feature() : usbd_sdr.c
  • usbd_set_stall() : usbd_core.h, usbd_core.c
  • usbd_setup_request_parse() : usbd_sdr.h, usbd_sdr.c
  • usbd_sof_handler() : usbd_int.h, usbd_int.c
  • usbd_suspend_handler() : usbd_int.h, usbd_int.c
  • usbd_unicode_convert() : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • usbd_wakeup_handler() : usbd_int.h, usbd_int.c
  • USBFS_L_CAN1_RX0_IRQHandler() : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/can/communication_mode/src/main.c, project/at_start_f413/examples/can/filter/src/main.c, project/at_start_f413/examples/can/loopback_mode/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c


AT32F413 Firmwary Library: Globals

- w -

  • wdt_counter_reload() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_divider_set() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_enable() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_flag_get() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_register_write_enable() : at32f413_wdt.h, at32f413_wdt.c
  • wdt_reload_value_set() : at32f413_wdt.h, at32f413_wdt.c
  • wwdt_counter_set() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_divider_set() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_enable() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_flag_clear() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_flag_get() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_interrupt_enable() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_reset() : at32f413_wwdt.h, at32f413_wwdt.c
  • wwdt_window_counter_set() : at32f413_wwdt.h, at32f413_wwdt.c


AT32F413 Firmwary Library: Globals

- _ -

  • _asciimap : cdc_keyboard_class.c, keyboard_class.c


AT32F413 Firmwary Library: Globals

- a -

  • acc_c2_value : project/at_start_f413/examples/acc/calibration/src/main.c
  • adc1_ordinary_value : project/at_start_f413/examples/adc/current_vref_value_check/src/main.c, project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • adc1_ordinary_valuetab : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c, project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • adc1_preempt_valuetab : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • ALIGNED_TAIL : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, composite_cdc_msc/msc_bot_scsi.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc/msc_bot_scsi.c, msc_desc.c, printer_class.c, printer_desc.c
  • atr_decode_status : project/at_start_f413/examples/usart/smartcard/src/main.c
  • audio_class_handler : audio_class.c, audio_class.h
  • audio_codec : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • audio_desc_handler : audio_desc.c, audio_desc.h
  • audio_hid_class_handler : audio_hid_class.c, audio_hid_class.h
  • audio_hid_desc_handler : audio_hid_desc.c, audio_hid_desc.h
  • audio_hid_struct : audio_hid_class.c
  • audio_struct : audio_class.c


AT32F413 Firmwary Library: Globals

- b -

  • bpr_addr_tab : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • buffer : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • buffer_ch1 : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • buffer_ch2 : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • buffer_read : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • buffer_write : project/at_start_f413/examples/flash/flash_write_read/src/main.c


AT32F413 Firmwary Library: Globals

- c -

  • calendar : rtc.h, rtc.c
  • capture : project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
  • capturenumber : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • card_inserted : project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • card_protocol : project/at_start_f413/examples/usart/smartcard/src/main.c
  • card_type : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • cdc_class_handler : cdc_class.c, cdc_class.h
  • cdc_desc_handler : cdc_desc.c, cdc_desc.h
  • cdc_keyboard_class_handler : cdc_keyboard_class.c, cdc_keyboard_class.h
  • cdc_keyboard_desc_handler : cdc_keyboard_desc.c, cdc_keyboard_desc.h
  • cdc_msc_class_handler : cdc_msc_class.c, cdc_msc_class.h
  • cdc_msc_desc_handler : cdc_msc_desc.c, cdc_msc_desc.h
  • cdc_msc_struct : cdc_msc_class.c
  • cdc_struct : cdc_class.c
  • ch1_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch2_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch3_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • ch3readvalue1 : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • ch3readvalue2 : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • ch4_val : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • channel1_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel2_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel3_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • channel4_pulse : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c
  • cid_table : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • cmd_addr_cnt : bootloader/src/iap.c
  • cmd_ctr_step : bootloader/inc/iap.h, bootloader/src/iap.c
  • cmd_data_cnt : bootloader/src/iap.c
  • cmd_data_group_struct : bootloader/src/iap.c
  • cmd_data_group_type_struct : bootloader/inc/iap.h
  • cmd_data_step : bootloader/inc/iap.h, bootloader/src/iap.c
  • config_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • counter : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • crc1_value : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
  • crc2_value : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
  • crc_value : project/at_start_f413/examples/crc/calculation/src/main.c
  • crm_clocks : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • crm_clocks_freq_struct : project/at_start_f413/examples/debug/tmr1/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c, project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/timer_base/src/main.c
  • csd_table : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • custom_hid_class_handler : custom_hid_class.c, custom_hid_class.h
  • custom_hid_desc_handler : custom_hid_desc.c, custom_hid_desc.h
  • custom_hid_struct : custom_hid_class.c


AT32F413 Firmwary Library: Globals

- d -

  • data_buffer : project/at_start_f413/examples/crc/calculation/src/main.c
  • data_count : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c
  • data_counter_end : project/at_start_f413/examples/dma/flash_to_sram/src/main.c
  • device_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • device_mode : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • div_value : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c
  • dma1_trans_complete_flag : project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c
  • dma_init_struct : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • dma_init_structure : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • dma_trans_complete_flag : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c, project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • dst_buffer : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/usart/smartcard/src/main.c
  • duty_cycle : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • duty_result : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • dw_data_start_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • dw_end_sector : utilities/at32f413_slib_demo/project_l0/src/main.c
  • dw_start_sector : utilities/at32f413_slib_demo/project_l0/src/main.c


AT32F413 Firmwary Library: Globals

- f -

  • fac_ms : at32f413_board.c
  • fac_us : at32f413_board.c
  • fat16_file_name : flash_fat16.c
  • fat16_root_dir_sector : flash_fat16.c
  • fat16_sector : flash_fat16.c
  • fat16_table_sector0 : flash_fat16.c
  • file : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • file_match : flash_fat16.c
  • file_write_nr : flash_fat16.c
  • firCoeffs32 : fir_coefficient.c, fir_filter.c
  • firStateF32 : fir_filter.c
  • flash_buf : project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • flash_iap : flash_fat16.h, flash_fat16.c
  • freq_result : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • frequency : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • fs : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c


AT32F413 Firmwary Library: Globals

- g -

  • g_audio_hid_usb_desc : audio_hid_desc.h
  • g_custom_hid_usb_desc : custom_hid_desc.h
  • g_file_attr : flash_fat16.c
  • g_hidiap_usb_desc : hid_iap_desc.h
  • g_keyboard_usb_desc : keyboard_desc.h
  • g_mouse_usb_desc : mouse_desc.h
  • g_speed : project/at_start_f413/templates/src/main.c
  • g_usb_offset_addr : at32f413_usb.c
  • g_usb_packet_address : at32f413_usb.h, at32f413_usb.c
  • g_usbd_audio_hid_report : audio_hid_desc.h
  • g_usbd_custom_hid_report : custom_hid_desc.h
  • g_usbd_desc_buffer : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • g_usbd_hidiap_report : hid_iap_desc.h
  • g_usbd_keyboard_report : keyboard_desc.h
  • g_usbd_mouse_report : mouse_desc.h
  • g_usbd_vcpkybrd_hid_report : cdc_keyboard_desc.h
  • g_vcpkybrd_hid_usb_desc : cdc_keyboard_desc.h
  • get_data_from_usart_flag : bootloader/inc/tmr.h, bootloader/src/tmr.c
  • gpio_init_struct : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c


AT32F413 Firmwary Library: Globals

- h -

  • hi2cx : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • hid_iap_class_handler : hid_iap_class.c, hid_iap_class.h
  • hid_iap_desc_handler : hid_iap_desc.c, hid_iap_desc.h
  • hid_suspend_flag : project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • hw_usart_read_index : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • hw_usart_rx_index : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c


AT32F413 Firmwary Library: Globals

- i -

  • i2s1_buffer_tx : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • i2s2_buffer_rx : project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • iap_flag : app_led3_toggle/inc/usart.h, app_led3_toggle/src/usart.c, app_led4_toggle/inc/usart.h, app_led4_toggle/src/usart.c
  • iap_info : hid_iap_class.c, hid_iap_class.h
  • ic2value : project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c


AT32F413 Firmwary Library: Globals

- j -

  • jump_to_app : bootloader/src/iap.c


AT32F413 Firmwary Library: Globals

- k -

  • keyboard_class_handler : keyboard_class.c, keyboard_class.h
  • keyboard_desc_handler : keyboard_desc.c, keyboard_desc.h
  • keyboard_struct : keyboard_class.c


AT32F413 Firmwary Library: Globals

- l -

  • langid_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • led2_handler : utilities/at32f413_freertos_demo/src/main.c
  • led3_handler : utilities/at32f413_freertos_demo/src/main.c
  • led_gpio_crm_clk : at32f413_board.c
  • led_gpio_pin : at32f413_board.c
  • led_gpio_port : at32f413_board.c
  • lickfreq : project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • linecoding : cdc_class.c, cdc_msc_class.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • linecoding_vcpkybrd : cdc_keyboard_class.c


AT32F413 Firmwary Library: Globals

- m -

  • max_marks : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • mblock_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mblock_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • mean : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • mic_dma_buffer : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • min_marks : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • mon_table : rtc.c
  • mouse_class_handler : mouse_class.c, mouse_class.h
  • mouse_desc_handler : mouse_desc.c, mouse_desc.h
  • mouse_struct : mouse_class.c
  • msc_class_handler : msc_class.c, msc_class.h
  • msc_desc_handler : msc_desc.c, msc_desc.h
  • msc_flash_size : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c
  • msc_struct : msc_class.c


AT32F413 Firmwary Library: Globals

- n -

  • numStudents : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • numSubjects : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c


AT32F413 Firmwary Library: Globals

- o -

  • operationcomplete : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • ov_cnt : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c


AT32F413 Firmwary Library: Globals

- p -

  • periodvalue : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c, project/at_start_f413/examples/rtc/lick_calibration/src/main.c
  • pftarget : project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, app_led3_toggle/src/hid_iap_user.c, app_led4_toggle/src/hid_iap_user.c, bootloader/src/hid_iap_user.c
  • preempt_conversion_count : project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
  • preempt_trigger_count : project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c, project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
  • press_mouse : project/at_start_f413/examples/usb_device/mouse/src/main.c
  • printer_class_handler : printer_class.c, printer_class.h
  • printer_desc_handler : printer_desc.c, printer_desc.h
  • printer_struct : printer_class.c


AT32F413 Firmwary Library: Globals

- r -

  • rca : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • read_buffer : operate_spim.c
  • refOutput : project_l0/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • reg_addr_data : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • report_buf : project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c
  • rs485_buffer_rx : project/at_start_f413/examples/usart/rs485/src/main.c
  • rs485_buffer_rx_cnt : project/at_start_f413/examples/usart/rs485/src/main.c
  • rx_buf : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • rx_buf1 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buf2 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buf3 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • rx_buffer : project/at_start_f413/examples/spi/w25q_flash/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c
  • rx_counter : project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • rx_index : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c


AT32F413 Firmwary Library: Globals

- s -

  • sblock_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sblock_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • sc_a2r_struct : project/at_start_f413/examples/usart/smartcard/src/main.c
  • sc_baud_rate : project/at_start_f413/examples/usart/smartcard/src/main.c
  • sc_clock_freq : project/at_start_f413/examples/usart/smartcard/src/main.c
  • scsi_inquiry : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c, virtual_msc_iap/src/msc_diskio.c
  • sd_card_info : sd_mmc_card/inc/at32_sdio.h, sd_mmc_card/src/at32_sdio.c, sdio_fatfs/inc/at32_sdio.h, sdio_fatfs/src/at32_sdio.c
  • sdio_command_init_struct : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sdio_data_init_struct : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • sector_size : composite_vcp_msc/src/msc_diskio.c, msc/src/msc_diskio.c
  • serial_descriptor : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c
  • spi1_buffer_tx : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • spi1_rx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • spi1_tx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
  • spi2_buffer_rx : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
  • spi2_rx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_rx_counter : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_buffer : project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_buffer_size : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi2_tx_counter : project/at_start_f413/examples/usart/synchronous/src/main.c
  • spi_init_struct : project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c
  • spiflash_sector_buf : spi_flash.c
  • spk_dma_buffer : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • src_buffer : project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • src_const_buffer : project/at_start_f413/examples/dma/flash_to_sram/src/main.c
  • std : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • step : project/at_start_f413/examples/tmr/6_steps/src/main.c
  • stop_flag : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • stream_rbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • stream_tbuffer : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • student_num : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • sys_counter : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • system_core_clock : system_at32f413.c, system_at32f413.h


AT32F413 Firmwary Library: Globals

- t -

  • table_week : rtc.c
  • temp_buf : utilities/at32f413_slib_demo/project_l0/src/main.c
  • test_result : project/at_start_f413/examples/can/filter/src/main.c
  • testInput_f32_1kHz_15kHz : project_l0/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l0/src/main.c, project_l1/src/arm_fir_data.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • testMarks_f32 : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • testOutput : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • testUnity_f32 : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • time_cnt : project/at_start_f413/examples/usart/printf/src/main.c
  • time_ira_cnt : bootloader/inc/tmr.h, bootloader/src/tmr.c
  • timer_period : project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c
  • tmpCC4 : project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
  • tmr3freq : project/at_start_f413/examples/tmr/input_capture/src/main.c
  • tmr_brkdt_config_struct : project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c
  • tmr_ic_init_structure : project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/pwm_input/src/main.c, project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • tmr_input_config_struct : project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c, project/at_start_f413/examples/tmr/input_capture/src/main.c
  • tmr_oc_init_structure : project/at_start_f413/examples/tmr/oc_high/src/main.c, project/at_start_f413/examples/tmr/oc_low/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c, project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c, project/at_start_f413/examples/tmr/one_cycle/src/main.c, project/at_start_f413/examples/tmr/parallel_synchro/src/main.c, project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c, project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c, project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c, project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
  • tmr_output_struct : project/at_start_f413/examples/tmr/6_steps/src/main.c, project/at_start_f413/examples/tmr/7_pwm_output/src/main.c, project/at_start_f413/examples/tmr/cascade_synchro/src/main.c, project/at_start_f413/examples/tmr/complementary_signals/src/main.c, project/at_start_f413/examples/tmr/dma/src/main.c, project/at_start_f413/examples/tmr/dma_burst/src/main.c, project/at_start_f413/examples/tmr/external_clock/src/main.c, project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c, project/at_start_f413/examples/tmr/hang_mode/src/main.c
  • transfer_end : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • transfer_error : sd_mmc_card/src/at32_sdio.c, sdio_fatfs/src/at32_sdio.c
  • transfer_status : project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • transfer_status1 : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • transfer_status2 : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
  • transfer_status3 : project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
  • transfer_status4 : project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
  • tx_buf : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • tx_buf1 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buf2 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buf3 : project/at_start_f413/examples/i2c/eeprom/src/main.c
  • tx_buffer : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • tx_counter : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • tx_index : project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c


AT32F413 Firmwary Library: Globals

- u -

  • update_status : bootloader/inc/iap.h, bootloader/src/iap.c
  • usart1_index : project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c
  • usart2_rx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart2_rx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_rx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart2_tx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart2_tx_buffer_size : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_tx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c
  • usart2_tx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart3_rx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart3_rx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_rx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart3_tx_buffer : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • usart3_tx_buffer_size : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_tx_counter : project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c
  • usart3_tx_dma_status : project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
  • usart_group_struct : bootloader/inc/usart.h, bootloader/src/usart.c
  • usart_rx_buffer : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usart_rx_data_len : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_buffer : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • usb_core_dev : project/at_start_f413/examples/acc/calibration/src/main.c, project/at_start_f413/examples/usb_device/audio/src/main.c, project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c, project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c, project/at_start_f413/examples/usb_device/custom_hid/src/main.c, project/at_start_f413/examples/usb_device/keyboard/src/main.c, project/at_start_f413/examples/usb_device/mouse/src/main.c, project/at_start_f413/examples/usb_device/msc/src/main.c, project/at_start_f413/examples/usb_device/printer/src/main.c, project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c, project/at_start_f413/examples/usb_device/virtual_comport/src/main.c, project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c, utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c


AT32F413 Firmwary Library: Globals

- v -

  • var : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • variables : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • variables_addr : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • variables_bit_val : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • vcp_keyboard_struct : cdc_keyboard_class.c
  • vmor_flag_index : project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c, project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
  • vp_desc : audio_desc.c, audio_hid_desc.c, cdc_desc.c, cdc_keyboard_desc.c, cdc_msc_desc.c, custom_hid_desc.c, hid_iap_desc.c, keyboard_desc.c, mouse_desc.c, msc_desc.c, printer_desc.c


AT32F413 Firmwary Library: Globals

- w -

  • weekday_table : project/at_start_f413/examples/rtc/calendar/src/main.c
  • work : project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
  • write_buffer : operate_spim.c


AT32F413 Firmwary Library: Globals

- i -

  • iapfun : bootloader/inc/iap.h
  • INT16 : at32f413.h
  • INT32 : at32f413.h
  • INT8 : at32f413.h
  • IRQn_Type : at32f413.h

- s -

  • s16 : at32f413.h
  • s32 : at32f413.h
  • s8 : at32f413.h
  • sc16 : at32f413.h
  • sc32 : at32f413.h
  • sc8 : at32f413.h

- u -

  • u16 : at32f413.h
  • u32 : at32f413.h
  • u8 : at32f413.h
  • uc16 : at32f413.h
  • uc32 : at32f413.h
  • uc8 : at32f413.h
  • UINT16 : at32f413.h
  • UINT32 : at32f413.h
  • UINT8 : at32f413.h
  • usb_reg_type : at32f413_usb.h

- v -

  • vs16 : at32f413.h
  • vs32 : at32f413.h
  • vs8 : at32f413.h
  • vsc16 : at32f413.h
  • vsc32 : at32f413.h
  • vsc8 : at32f413.h
  • vu16 : at32f413.h
  • vu32 : at32f413.h
  • vu8 : at32f413.h
  • vuc16 : at32f413.h
  • vuc32 : at32f413.h
  • vuc8 : at32f413.h


AT32F413 Firmwary Library: Globals

- a -

  • adc_channel_select_type : at32f413_adc.h
  • adc_combine_mode_type : at32f413_adc.h
  • adc_data_align_type : at32f413_adc.h
  • adc_ordinary_trig_select_type : at32f413_adc.h
  • adc_preempt_channel_type : at32f413_adc.h
  • adc_preempt_trig_select_type : at32f413_adc.h
  • adc_sampletime_select_type : at32f413_adc.h
  • adc_voltage_monitoring_type : at32f413_adc.h

- b -

  • bpr_data_type : at32f413_bpr.h
  • bpr_rtc_output_type : at32f413_bpr.h
  • bpr_tamper_pin_active_level_type : at32f413_bpr.h
  • button_type : at32f413_board.h

- c -

  • can_bts1_type : at32f413_can.h
  • can_bts2_type : at32f413_can.h
  • can_enter_doze_status_type : at32f413_can.h
  • can_error_record_type : at32f413_can.h
  • can_filter_bit_width_type : at32f413_can.h
  • can_filter_fifo_type : at32f413_can.h
  • can_filter_mode_type : at32f413_can.h
  • can_identifier_type : at32f413_can.h
  • can_mode_type : at32f413_can.h
  • can_msg_discarding_rule_type : at32f413_can.h
  • can_msg_sending_rule_type : at32f413_can.h
  • can_operating_mode_type : at32f413_can.h
  • can_quit_doze_status_type : at32f413_can.h
  • can_rsaw_type : at32f413_can.h
  • can_rx_fifo_num_type : at32f413_can.h
  • can_trans_frame_type : at32f413_can.h
  • can_transmit_status_type : at32f413_can.h
  • can_tx_mailbox_num_type : at32f413_can.h
  • cmd_ctr_step_type : bootloader/inc/iap.h
  • cmd_data_step_type : bootloader/inc/iap.h
  • confirm_state : at32f413.h
  • crc_reverse_input_type : at32f413_crc.h
  • crc_reverse_output_type : at32f413_crc.h
  • crm_adc_div_type : at32f413_crm.h
  • crm_ahb_div_type : at32f413_crm.h
  • crm_apb1_div_type : at32f413_crm.h
  • crm_apb2_div_type : at32f413_crm.h
  • crm_auto_step_mode_type : at32f413_crm.h
  • crm_clkout_div_type : at32f413_crm.h
  • crm_clkout_select_type : at32f413_crm.h
  • crm_clock_source_type : at32f413_crm.h
  • crm_hick_div_6_type : at32f413_crm.h
  • crm_hick_sclk_frequency_type : at32f413_crm.h
  • crm_periph_clock_sleepmd_type : at32f413_crm.h
  • crm_periph_clock_type : at32f413_crm.h
  • crm_periph_reset_type : at32f413_crm.h
  • crm_pll_clock_source_type : at32f413_crm.h
  • crm_pll_mult_type : at32f413_crm.h
  • crm_pll_output_range_type : at32f413_crm.h
  • crm_rtc_clock_type : at32f413_crm.h
  • crm_sclk_type : at32f413_crm.h
  • crm_usb_clock_source_type : at32f413_crm.h
  • crm_usb_div_type : at32f413_crm.h
  • crm_usb_int_map_type : at32f413_crm.h

- d -

  • data_trans_dir : at32f413_usb.h
  • dma_dir_type : at32f413_dma.h
  • dma_flexible_request_type : at32f413_dma.h
  • dma_memory_data_size_type : at32f413_dma.h
  • dma_memory_inc_type : at32f413_dma.h
  • dma_peripheral_data_size_type : at32f413_dma.h
  • dma_peripheral_inc_type : at32f413_dma.h
  • dma_priority_level_type : at32f413_dma.h

- e -

  • ept_inout_type : at32f413_usb.h
  • ept_trans_type : at32f413_usb.h
  • error_status : at32f413.h
  • exint_line_mode_type : at32f413_exint.h
  • exint_polarity_config_type : at32f413_exint.h

- f -

  • flag_status : at32f413.h
  • flash_spim_model_type : at32f413_flash.h
  • flash_status_type : at32f413_flash.h

- g -

  • gpio_drive_type : at32f413_gpio.h
  • gpio_mode_type : at32f413_gpio.h
  • gpio_output_type : at32f413_gpio.h
  • gpio_pins_source_type : at32f413_gpio.h
  • gpio_port_source_type : at32f413_gpio.h
  • gpio_pull_type : at32f413_gpio.h

- i -

  • i2c_address_mode_type : at32f413_i2c.h
  • i2c_direction_type : at32f413_i2c.h
  • i2c_fsmode_duty_cycle_type : at32f413_i2c.h
  • i2c_master_ack_type : at32f413_i2c.h
  • i2c_mode_type : i2c_application.h
  • i2c_pec_position_type : at32f413_i2c.h
  • i2c_smbus_alert_set_type : at32f413_i2c.h
  • i2c_smbus_mode_set_type : at32f413_i2c.h
  • i2c_status_type : i2c_application.h
  • i2s_audio_protocol_type : at32f413_spi.h
  • i2s_audio_sampling_freq_type : at32f413_spi.h
  • i2s_clock_polarity_type : at32f413_spi.h
  • i2s_data_channel_format_type : at32f413_spi.h
  • i2s_operation_mode_type : at32f413_spi.h
  • iap_machine_state_type : hid_iap_class.h
  • iap_result_type : hid_iap_class.h
  • IRQn : at32f413.h

- l -

  • led_type : at32f413_board.h

- n -

  • nvic_lowpower_mode_type : at32f413_misc.h
  • nvic_priority_group_type : at32f413_misc.h

- p -

  • printer_req_type : printer_class.h
  • pwc_deep_sleep_enter_type : at32f413_pwc.h
  • pwc_pvm_voltage_type : at32f413_pwc.h
  • pwc_regulator_type : at32f413_pwc.h
  • pwc_sleep_enter_type : at32f413_pwc.h

- s -

  • sd_card_state_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_data_transfer_mode_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_error_status_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sd_memory_card_type : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • sdio_block_size_type : at32f413_sdio.h
  • sdio_bus_width_type : at32f413_sdio.h
  • sdio_edge_phase_type : at32f413_sdio.h
  • sdio_power_state_type : at32f413_sdio.h
  • sdio_read_wait_mode_type : at32f413_sdio.h
  • sdio_reponse_type : at32f413_sdio.h
  • sdio_rsp_index_type : at32f413_sdio.h
  • sdio_transfer_direction_type : at32f413_sdio.h
  • sdio_transfer_mode_type : at32f413_sdio.h
  • sdio_wait_type : at32f413_sdio.h
  • spi_clock_phase_type : at32f413_spi.h
  • spi_clock_polarity_type : at32f413_spi.h
  • spi_crc_direction_type : at32f413_spi.h
  • spi_cs_mode_type : at32f413_spi.h
  • spi_first_bit_type : at32f413_spi.h
  • spi_frame_bit_num_type : at32f413_spi.h
  • spi_half_duplex_direction_type : at32f413_spi.h
  • spi_master_slave_mode_type : at32f413_spi.h
  • spi_mclk_freq_div_type : at32f413_spi.h
  • spi_software_cs_level_type : at32f413_spi.h
  • spi_transmission_mode_type : at32f413_spi.h
  • sub_tmr_input_sel_type : at32f413_tmr.h
  • systick_clock_source_type : at32f413_misc.h

- t -

  • tmr_brk_polarity_type : at32f413_tmr.h
  • tmr_channel1_input_connected_type : at32f413_tmr.h
  • tmr_channel_input_divider_type : at32f413_tmr.h
  • tmr_channel_select_type : at32f413_tmr.h
  • tmr_clock_division_type : at32f413_tmr.h
  • tmr_count_mode_type : at32f413_tmr.h
  • tmr_dma_address_type : at32f413_tmr.h
  • tmr_dma_request_source_type : at32f413_tmr.h
  • tmr_dma_request_type : at32f413_tmr.h
  • tmr_dma_transfer_length_type : at32f413_tmr.h
  • tmr_encoder_mode_type : at32f413_tmr.h
  • tmr_event_trigger_type : at32f413_tmr.h
  • tmr_external_signal_divider_type : at32f413_tmr.h
  • tmr_external_signal_polarity_type : at32f413_tmr.h
  • tmr_force_output_type : at32f413_tmr.h
  • tmr_input_direction_mapped_type : at32f413_tmr.h
  • tmr_input_polarity_type : at32f413_tmr.h
  • tmr_output_control_mode_type : at32f413_tmr.h
  • tmr_output_polarity_type : at32f413_tmr.h
  • tmr_polarity_active_type : at32f413_tmr.h
  • tmr_primary_select_type : at32f413_tmr.h
  • tmr_sub_mode_select_type : at32f413_tmr.h
  • tmr_wp_level_type : at32f413_tmr.h

- u -

  • update_status_type : bootloader/inc/iap.h
  • upgrade_status_type : flash_fat16.h
  • usart_break_bit_num_type : at32f413_usart.h
  • usart_clock_phase_type : at32f413_usart.h
  • usart_clock_polarity_type : at32f413_usart.h
  • usart_data_bit_num_type : at32f413_usart.h
  • usart_hardware_flow_control_type : at32f413_usart.h
  • usart_lbcp_type : at32f413_usart.h
  • usart_parity_selection_type : at32f413_usart.h
  • usart_stop_bit_num_type : at32f413_usart.h
  • usart_wakeup_mode_type : at32f413_usart.h
  • usb_clk48_s : at32f413_usb.h
  • usb_ept_number_type : at32f413_usb.h
  • usb_sts_type : usb_std.h
  • usbd_conn_state : usb_std.h
  • usbd_event_type : usbd_core.h

- w -

  • wdt_cmd_value_type : at32f413_wdt.h
  • wdt_division_type : at32f413_wdt.h
  • wwdt_division_type : at32f413_wwdt.h


AT32F413 Firmwary Library: Globals

- a -

  • ACC_IRQn : at32f413.h
  • ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_SOFTWARE : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH2 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1CH3 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR1TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR2CH2 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR3TRGOUT : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR4CH4 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR8CH1 : at32f413_adc.h
  • ADC12_ORDINARY_TRIG_TMR8CH2 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_SOFTWARE : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR1TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR2CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR2TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR3CH4 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR4TRGOUT : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR8CH1 : at32f413_adc.h
  • ADC12_PREEMPT_TRIG_TMR8TRGOUT : at32f413_adc.h
  • ADC1_2_IRQn : at32f413.h
  • ADC_CHANNEL_0 : at32f413_adc.h
  • ADC_CHANNEL_1 : at32f413_adc.h
  • ADC_CHANNEL_10 : at32f413_adc.h
  • ADC_CHANNEL_11 : at32f413_adc.h
  • ADC_CHANNEL_12 : at32f413_adc.h
  • ADC_CHANNEL_13 : at32f413_adc.h
  • ADC_CHANNEL_14 : at32f413_adc.h
  • ADC_CHANNEL_15 : at32f413_adc.h
  • ADC_CHANNEL_16 : at32f413_adc.h
  • ADC_CHANNEL_17 : at32f413_adc.h
  • ADC_CHANNEL_2 : at32f413_adc.h
  • ADC_CHANNEL_3 : at32f413_adc.h
  • ADC_CHANNEL_4 : at32f413_adc.h
  • ADC_CHANNEL_5 : at32f413_adc.h
  • ADC_CHANNEL_6 : at32f413_adc.h
  • ADC_CHANNEL_7 : at32f413_adc.h
  • ADC_CHANNEL_8 : at32f413_adc.h
  • ADC_CHANNEL_9 : at32f413_adc.h
  • ADC_INDEPENDENT_MODE : at32f413_adc.h
  • ADC_LEFT_ALIGNMENT : at32f413_adc.h
  • ADC_ORDINARY_LONGSHIFT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • ADC_ORDINARY_SHORTSHIFT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_ONLY_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE : at32f413_adc.h
  • ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_1 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_2 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_3 : at32f413_adc.h
  • ADC_PREEMPT_CHANNEL_4 : at32f413_adc.h
  • ADC_PREEMPT_INTERLTRIG_ONLY_MODE : at32f413_adc.h
  • ADC_PREEMPT_SMLT_ONLY_MODE : at32f413_adc.h
  • ADC_RIGHT_ALIGNMENT : at32f413_adc.h
  • ADC_SAMPLETIME_13_5 : at32f413_adc.h
  • ADC_SAMPLETIME_1_5 : at32f413_adc.h
  • ADC_SAMPLETIME_239_5 : at32f413_adc.h
  • ADC_SAMPLETIME_28_5 : at32f413_adc.h
  • ADC_SAMPLETIME_41_5 : at32f413_adc.h
  • ADC_SAMPLETIME_55_5 : at32f413_adc.h
  • ADC_SAMPLETIME_71_5 : at32f413_adc.h
  • ADC_SAMPLETIME_7_5 : at32f413_adc.h
  • ADC_VMONITOR_ALL_ORDINARY : at32f413_adc.h
  • ADC_VMONITOR_ALL_ORDINARY_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_ALL_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_NONE : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT : at32f413_adc.h
  • ADC_VMONITOR_SINGLE_PREEMPT : at32f413_adc.h


AT32F413 Firmwary Library: Globals

- b -

  • BPR_DATA1 : at32f413_bpr.h
  • BPR_DATA10 : at32f413_bpr.h
  • BPR_DATA11 : at32f413_bpr.h
  • BPR_DATA12 : at32f413_bpr.h
  • BPR_DATA13 : at32f413_bpr.h
  • BPR_DATA14 : at32f413_bpr.h
  • BPR_DATA15 : at32f413_bpr.h
  • BPR_DATA16 : at32f413_bpr.h
  • BPR_DATA17 : at32f413_bpr.h
  • BPR_DATA18 : at32f413_bpr.h
  • BPR_DATA19 : at32f413_bpr.h
  • BPR_DATA2 : at32f413_bpr.h
  • BPR_DATA20 : at32f413_bpr.h
  • BPR_DATA21 : at32f413_bpr.h
  • BPR_DATA22 : at32f413_bpr.h
  • BPR_DATA23 : at32f413_bpr.h
  • BPR_DATA24 : at32f413_bpr.h
  • BPR_DATA25 : at32f413_bpr.h
  • BPR_DATA26 : at32f413_bpr.h
  • BPR_DATA27 : at32f413_bpr.h
  • BPR_DATA28 : at32f413_bpr.h
  • BPR_DATA29 : at32f413_bpr.h
  • BPR_DATA3 : at32f413_bpr.h
  • BPR_DATA30 : at32f413_bpr.h
  • BPR_DATA31 : at32f413_bpr.h
  • BPR_DATA32 : at32f413_bpr.h
  • BPR_DATA33 : at32f413_bpr.h
  • BPR_DATA34 : at32f413_bpr.h
  • BPR_DATA35 : at32f413_bpr.h
  • BPR_DATA36 : at32f413_bpr.h
  • BPR_DATA37 : at32f413_bpr.h
  • BPR_DATA38 : at32f413_bpr.h
  • BPR_DATA39 : at32f413_bpr.h
  • BPR_DATA4 : at32f413_bpr.h
  • BPR_DATA40 : at32f413_bpr.h
  • BPR_DATA41 : at32f413_bpr.h
  • BPR_DATA42 : at32f413_bpr.h
  • BPR_DATA5 : at32f413_bpr.h
  • BPR_DATA6 : at32f413_bpr.h
  • BPR_DATA7 : at32f413_bpr.h
  • BPR_DATA8 : at32f413_bpr.h
  • BPR_DATA9 : at32f413_bpr.h
  • BPR_RTC_OUTPUT_ALARM : at32f413_bpr.h
  • BPR_RTC_OUTPUT_ALARM_TOGGLE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_CLOCK_CAL_AFTER : at32f413_bpr.h
  • BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_NONE : at32f413_bpr.h
  • BPR_RTC_OUTPUT_SECOND : at32f413_bpr.h
  • BPR_RTC_OUTPUT_SECOND_TOGGLE : at32f413_bpr.h
  • BPR_TAMPER_PIN_ACTIVE_HIGH : at32f413_bpr.h
  • BPR_TAMPER_PIN_ACTIVE_LOW : at32f413_bpr.h
  • BusFault_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- c -

  • CAN1_RX1_IRQn : at32f413.h
  • CAN1_SE_IRQn : at32f413.h
  • CAN2_RX0_IRQn : at32f413.h
  • CAN2_RX1_IRQn : at32f413.h
  • CAN2_SE_IRQn : at32f413.h
  • CAN2_TX_IRQn : at32f413.h
  • CAN_BTS1_10TQ : at32f413_can.h
  • CAN_BTS1_11TQ : at32f413_can.h
  • CAN_BTS1_12TQ : at32f413_can.h
  • CAN_BTS1_13TQ : at32f413_can.h
  • CAN_BTS1_14TQ : at32f413_can.h
  • CAN_BTS1_15TQ : at32f413_can.h
  • CAN_BTS1_16TQ : at32f413_can.h
  • CAN_BTS1_1TQ : at32f413_can.h
  • CAN_BTS1_2TQ : at32f413_can.h
  • CAN_BTS1_3TQ : at32f413_can.h
  • CAN_BTS1_4TQ : at32f413_can.h
  • CAN_BTS1_5TQ : at32f413_can.h
  • CAN_BTS1_6TQ : at32f413_can.h
  • CAN_BTS1_7TQ : at32f413_can.h
  • CAN_BTS1_8TQ : at32f413_can.h
  • CAN_BTS1_9TQ : at32f413_can.h
  • CAN_BTS2_1TQ : at32f413_can.h
  • CAN_BTS2_2TQ : at32f413_can.h
  • CAN_BTS2_3TQ : at32f413_can.h
  • CAN_BTS2_4TQ : at32f413_can.h
  • CAN_BTS2_5TQ : at32f413_can.h
  • CAN_BTS2_6TQ : at32f413_can.h
  • CAN_BTS2_7TQ : at32f413_can.h
  • CAN_BTS2_8TQ : at32f413_can.h
  • CAN_DISCARDING_FIRST_RECEIVED : at32f413_can.h
  • CAN_DISCARDING_LAST_RECEIVED : at32f413_can.h
  • CAN_ENTER_DOZE_FAILED : at32f413_can.h
  • CAN_ENTER_DOZE_SUCCESSFUL : at32f413_can.h
  • CAN_ERRORRECORD_ACKERR : at32f413_can.h
  • CAN_ERRORRECORD_BITDOMINANTERR : at32f413_can.h
  • CAN_ERRORRECORD_BITRECESSIVEERR : at32f413_can.h
  • CAN_ERRORRECORD_CRCERR : at32f413_can.h
  • CAN_ERRORRECORD_FORMERR : at32f413_can.h
  • CAN_ERRORRECORD_NOERR : at32f413_can.h
  • CAN_ERRORRECORD_SOFTWARESETERR : at32f413_can.h
  • CAN_ERRORRECORD_STUFFERR : at32f413_can.h
  • CAN_FILTER_16BIT : at32f413_can.h
  • CAN_FILTER_32BIT : at32f413_can.h
  • CAN_FILTER_FIFO0 : at32f413_can.h
  • CAN_FILTER_FIFO1 : at32f413_can.h
  • CAN_FILTER_MODE_ID_LIST : at32f413_can.h
  • CAN_FILTER_MODE_ID_MASK : at32f413_can.h
  • CAN_ID_EXTENDED : at32f413_can.h
  • CAN_ID_STANDARD : at32f413_can.h
  • CAN_MODE_COMMUNICATE : at32f413_can.h
  • CAN_MODE_LISTENONLY : at32f413_can.h
  • CAN_MODE_LISTENONLY_LOOPBACK : at32f413_can.h
  • CAN_MODE_LOOPBACK : at32f413_can.h
  • CAN_OPERATINGMODE_COMMUNICATE : at32f413_can.h
  • CAN_OPERATINGMODE_DOZE : at32f413_can.h
  • CAN_OPERATINGMODE_FREEZE : at32f413_can.h
  • CAN_QUIT_DOZE_FAILED : at32f413_can.h
  • CAN_QUIT_DOZE_SUCCESSFUL : at32f413_can.h
  • CAN_RSAW_1TQ : at32f413_can.h
  • CAN_RSAW_2TQ : at32f413_can.h
  • CAN_RSAW_3TQ : at32f413_can.h
  • CAN_RSAW_4TQ : at32f413_can.h
  • CAN_RX_FIFO0 : at32f413_can.h
  • CAN_RX_FIFO1 : at32f413_can.h
  • CAN_SENDING_BY_ID : at32f413_can.h
  • CAN_SENDING_BY_REQUEST : at32f413_can.h
  • CAN_TFT_DATA : at32f413_can.h
  • CAN_TFT_REMOTE : at32f413_can.h
  • CAN_TX_MAILBOX0 : at32f413_can.h
  • CAN_TX_MAILBOX1 : at32f413_can.h
  • CAN_TX_MAILBOX2 : at32f413_can.h
  • CAN_TX_STATUS_FAILED : at32f413_can.h
  • CAN_TX_STATUS_NO_EMPTY : at32f413_can.h
  • CAN_TX_STATUS_PENDING : at32f413_can.h
  • CAN_TX_STATUS_SUCCESSFUL : at32f413_can.h
  • CMD_CTR_APP : bootloader/inc/iap.h
  • CMD_CTR_DONE : bootloader/inc/iap.h
  • CMD_CTR_ERR : bootloader/inc/iap.h
  • CMD_CTR_IDLE : bootloader/inc/iap.h
  • CMD_CTR_INIT : bootloader/inc/iap.h
  • CMD_DATA_ADDR : bootloader/inc/iap.h
  • CMD_DATA_BUF : bootloader/inc/iap.h
  • CMD_DATA_CHACK : bootloader/inc/iap.h
  • CMD_DATA_DONE : bootloader/inc/iap.h
  • CMD_DATA_ERR : bootloader/inc/iap.h
  • CMD_DATA_IDLE : bootloader/inc/iap.h
  • CRC_REVERSE_INPUT_BY_BYTE : at32f413_crc.h
  • CRC_REVERSE_INPUT_BY_HALFWORD : at32f413_crc.h
  • CRC_REVERSE_INPUT_BY_WORD : at32f413_crc.h
  • CRC_REVERSE_INPUT_NO_AFFECTE : at32f413_crc.h
  • CRC_REVERSE_OUTPUT_DATA : at32f413_crc.h
  • CRC_REVERSE_OUTPUT_NO_AFFECTE : at32f413_crc.h
  • CRM_ACC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ACC_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ADC1_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_ADC2_PERIPH_RESET : at32f413_crm.h
  • CRM_ADC_DIV_12 : at32f413_crm.h
  • CRM_ADC_DIV_16 : at32f413_crm.h
  • CRM_ADC_DIV_2 : at32f413_crm.h
  • CRM_ADC_DIV_4 : at32f413_crm.h
  • CRM_ADC_DIV_6 : at32f413_crm.h
  • CRM_ADC_DIV_8 : at32f413_crm.h
  • CRM_AHB_DIV_1 : at32f413_crm.h
  • CRM_AHB_DIV_128 : at32f413_crm.h
  • CRM_AHB_DIV_16 : at32f413_crm.h
  • CRM_AHB_DIV_2 : at32f413_crm.h
  • CRM_AHB_DIV_256 : at32f413_crm.h
  • CRM_AHB_DIV_4 : at32f413_crm.h
  • CRM_AHB_DIV_512 : at32f413_crm.h
  • CRM_AHB_DIV_64 : at32f413_crm.h
  • CRM_AHB_DIV_8 : at32f413_crm.h
  • CRM_APB1_DIV_1 : at32f413_crm.h
  • CRM_APB1_DIV_16 : at32f413_crm.h
  • CRM_APB1_DIV_2 : at32f413_crm.h
  • CRM_APB1_DIV_4 : at32f413_crm.h
  • CRM_APB1_DIV_8 : at32f413_crm.h
  • CRM_APB2_DIV_1 : at32f413_crm.h
  • CRM_APB2_DIV_16 : at32f413_crm.h
  • CRM_APB2_DIV_2 : at32f413_crm.h
  • CRM_APB2_DIV_4 : at32f413_crm.h
  • CRM_APB2_DIV_8 : at32f413_crm.h
  • CRM_AUTO_STEP_MODE_DISABLE : at32f413_crm.h
  • CRM_AUTO_STEP_MODE_ENABLE : at32f413_crm.h
  • CRM_BPR_PERIPH_CLOCK : at32f413_crm.h
  • CRM_BPR_PERIPH_RESET : at32f413_crm.h
  • CRM_CAN1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_CAN1_PERIPH_RESET : at32f413_crm.h
  • CRM_CAN2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_CAN2_PERIPH_RESET : at32f413_crm.h
  • CRM_CLKOUT_ADC : at32f413_crm.h
  • CRM_CLKOUT_DIV_1 : at32f413_crm.h
  • CRM_CLKOUT_DIV_128 : at32f413_crm.h
  • CRM_CLKOUT_DIV_16 : at32f413_crm.h
  • CRM_CLKOUT_DIV_2 : at32f413_crm.h
  • CRM_CLKOUT_DIV_256 : at32f413_crm.h
  • CRM_CLKOUT_DIV_4 : at32f413_crm.h
  • CRM_CLKOUT_DIV_512 : at32f413_crm.h
  • CRM_CLKOUT_DIV_64 : at32f413_crm.h
  • CRM_CLKOUT_DIV_8 : at32f413_crm.h
  • CRM_CLKOUT_HEXT : at32f413_crm.h
  • CRM_CLKOUT_HICK : at32f413_crm.h
  • CRM_CLKOUT_LEXT : at32f413_crm.h
  • CRM_CLKOUT_LICK : at32f413_crm.h
  • CRM_CLKOUT_NOCLK : at32f413_crm.h
  • CRM_CLKOUT_PLL_DIV_2 : at32f413_crm.h
  • CRM_CLKOUT_PLL_DIV_4 : at32f413_crm.h
  • CRM_CLKOUT_SCLK : at32f413_crm.h
  • CRM_CLKOUT_USB : at32f413_crm.h
  • CRM_CLOCK_SOURCE_HEXT : at32f413_crm.h
  • CRM_CLOCK_SOURCE_HICK : at32f413_crm.h
  • CRM_CLOCK_SOURCE_LEXT : at32f413_crm.h
  • CRM_CLOCK_SOURCE_LICK : at32f413_crm.h
  • CRM_CLOCK_SOURCE_PLL : at32f413_crm.h
  • CRM_CRC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_DMA1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_DMA2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_EXINT_PERIPH_RESET : at32f413_crm.h
  • CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE : at32f413_crm.h
  • CRM_GPIOA_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOA_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOB_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOB_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOC_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOD_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOD_PERIPH_RESET : at32f413_crm.h
  • CRM_GPIOF_PERIPH_CLOCK : at32f413_crm.h
  • CRM_GPIOF_PERIPH_RESET : at32f413_crm.h
  • CRM_HICK48_DIV6 : at32f413_crm.h
  • CRM_HICK48_NODIV : at32f413_crm.h
  • CRM_HICK_SCLK_48MHZ : at32f413_crm.h
  • CRM_HICK_SCLK_8MHZ : at32f413_crm.h
  • CRM_I2C1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_I2C1_PERIPH_RESET : at32f413_crm.h
  • CRM_I2C2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_I2C2_PERIPH_RESET : at32f413_crm.h
  • CRM_IOMUX_PERIPH_CLOCK : at32f413_crm.h
  • CRM_IOMUX_PERIPH_RESET : at32f413_crm.h
  • CRM_IRQn : at32f413.h
  • CRM_PLL_MULT_10 : at32f413_crm.h
  • CRM_PLL_MULT_11 : at32f413_crm.h
  • CRM_PLL_MULT_12 : at32f413_crm.h
  • CRM_PLL_MULT_13 : at32f413_crm.h
  • CRM_PLL_MULT_14 : at32f413_crm.h
  • CRM_PLL_MULT_15 : at32f413_crm.h
  • CRM_PLL_MULT_16 : at32f413_crm.h
  • CRM_PLL_MULT_17 : at32f413_crm.h
  • CRM_PLL_MULT_18 : at32f413_crm.h
  • CRM_PLL_MULT_19 : at32f413_crm.h
  • CRM_PLL_MULT_2 : at32f413_crm.h
  • CRM_PLL_MULT_20 : at32f413_crm.h
  • CRM_PLL_MULT_21 : at32f413_crm.h
  • CRM_PLL_MULT_22 : at32f413_crm.h
  • CRM_PLL_MULT_23 : at32f413_crm.h
  • CRM_PLL_MULT_24 : at32f413_crm.h
  • CRM_PLL_MULT_25 : at32f413_crm.h
  • CRM_PLL_MULT_26 : at32f413_crm.h
  • CRM_PLL_MULT_27 : at32f413_crm.h
  • CRM_PLL_MULT_28 : at32f413_crm.h
  • CRM_PLL_MULT_29 : at32f413_crm.h
  • CRM_PLL_MULT_3 : at32f413_crm.h
  • CRM_PLL_MULT_30 : at32f413_crm.h
  • CRM_PLL_MULT_31 : at32f413_crm.h
  • CRM_PLL_MULT_32 : at32f413_crm.h
  • CRM_PLL_MULT_33 : at32f413_crm.h
  • CRM_PLL_MULT_34 : at32f413_crm.h
  • CRM_PLL_MULT_35 : at32f413_crm.h
  • CRM_PLL_MULT_36 : at32f413_crm.h
  • CRM_PLL_MULT_37 : at32f413_crm.h
  • CRM_PLL_MULT_38 : at32f413_crm.h
  • CRM_PLL_MULT_39 : at32f413_crm.h
  • CRM_PLL_MULT_4 : at32f413_crm.h
  • CRM_PLL_MULT_40 : at32f413_crm.h
  • CRM_PLL_MULT_41 : at32f413_crm.h
  • CRM_PLL_MULT_42 : at32f413_crm.h
  • CRM_PLL_MULT_43 : at32f413_crm.h
  • CRM_PLL_MULT_44 : at32f413_crm.h
  • CRM_PLL_MULT_45 : at32f413_crm.h
  • CRM_PLL_MULT_46 : at32f413_crm.h
  • CRM_PLL_MULT_47 : at32f413_crm.h
  • CRM_PLL_MULT_48 : at32f413_crm.h
  • CRM_PLL_MULT_49 : at32f413_crm.h
  • CRM_PLL_MULT_5 : at32f413_crm.h
  • CRM_PLL_MULT_50 : at32f413_crm.h
  • CRM_PLL_MULT_51 : at32f413_crm.h
  • CRM_PLL_MULT_52 : at32f413_crm.h
  • CRM_PLL_MULT_53 : at32f413_crm.h
  • CRM_PLL_MULT_54 : at32f413_crm.h
  • CRM_PLL_MULT_55 : at32f413_crm.h
  • CRM_PLL_MULT_56 : at32f413_crm.h
  • CRM_PLL_MULT_57 : at32f413_crm.h
  • CRM_PLL_MULT_58 : at32f413_crm.h
  • CRM_PLL_MULT_59 : at32f413_crm.h
  • CRM_PLL_MULT_6 : at32f413_crm.h
  • CRM_PLL_MULT_60 : at32f413_crm.h
  • CRM_PLL_MULT_61 : at32f413_crm.h
  • CRM_PLL_MULT_62 : at32f413_crm.h
  • CRM_PLL_MULT_63 : at32f413_crm.h
  • CRM_PLL_MULT_64 : at32f413_crm.h
  • CRM_PLL_MULT_7 : at32f413_crm.h
  • CRM_PLL_MULT_8 : at32f413_crm.h
  • CRM_PLL_MULT_9 : at32f413_crm.h
  • CRM_PLL_OUTPUT_RANGE_GT72MHZ : at32f413_crm.h
  • CRM_PLL_OUTPUT_RANGE_LE72MHZ : at32f413_crm.h
  • CRM_PLL_SOURCE_HEXT : at32f413_crm.h
  • CRM_PLL_SOURCE_HEXT_DIV : at32f413_crm.h
  • CRM_PLL_SOURCE_HICK : at32f413_crm.h
  • CRM_PWC_PERIPH_CLOCK : at32f413_crm.h
  • CRM_PWC_PERIPH_RESET : at32f413_crm.h
  • CRM_RTC_CLOCK_HEXT_DIV : at32f413_crm.h
  • CRM_RTC_CLOCK_LEXT : at32f413_crm.h
  • CRM_RTC_CLOCK_LICK : at32f413_crm.h
  • CRM_RTC_CLOCK_NOCLK : at32f413_crm.h
  • CRM_SCLK_HEXT : at32f413_crm.h
  • CRM_SCLK_HICK : at32f413_crm.h
  • CRM_SCLK_PLL : at32f413_crm.h
  • CRM_SDIO1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI1_PERIPH_RESET : at32f413_crm.h
  • CRM_SPI2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_SPI2_PERIPH_RESET : at32f413_crm.h
  • CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE : at32f413_crm.h
  • CRM_TMR10_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR10_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR11_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR11_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR1_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR2_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR3_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR3_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR4_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR4_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR5_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR5_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR8_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR8_PERIPH_RESET : at32f413_crm.h
  • CRM_TMR9_PERIPH_CLOCK : at32f413_crm.h
  • CRM_TMR9_PERIPH_RESET : at32f413_crm.h
  • CRM_UART4_PERIPH_CLOCK : at32f413_crm.h
  • CRM_UART4_PERIPH_RESET : at32f413_crm.h
  • CRM_UART5_PERIPH_CLOCK : at32f413_crm.h
  • CRM_UART5_PERIPH_RESET : at32f413_crm.h
  • CRM_USART1_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART1_PERIPH_RESET : at32f413_crm.h
  • CRM_USART2_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART2_PERIPH_RESET : at32f413_crm.h
  • CRM_USART3_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USART3_PERIPH_RESET : at32f413_crm.h
  • CRM_USB_CLOCK_SOURCE_HICK : at32f413_crm.h
  • CRM_USB_CLOCK_SOURCE_PLL : at32f413_crm.h
  • CRM_USB_DIV_1 : at32f413_crm.h
  • CRM_USB_DIV_1_5 : at32f413_crm.h
  • CRM_USB_DIV_2 : at32f413_crm.h
  • CRM_USB_DIV_2_5 : at32f413_crm.h
  • CRM_USB_DIV_3 : at32f413_crm.h
  • CRM_USB_DIV_3_5 : at32f413_crm.h
  • CRM_USB_DIV_4 : at32f413_crm.h
  • CRM_USB_INT19_INT20 : at32f413_crm.h
  • CRM_USB_INT73_INT74 : at32f413_crm.h
  • CRM_USB_PERIPH_CLOCK : at32f413_crm.h
  • CRM_USB_PERIPH_RESET : at32f413_crm.h
  • CRM_WWDT_PERIPH_CLOCK : at32f413_crm.h
  • CRM_WWDT_PERIPH_RESET : at32f413_crm.h


AT32F413 Firmwary Library: Globals

- d -

  • DATA_TRANS_IN : at32f413_usb.h
  • DATA_TRANS_OUT : at32f413_usb.h
  • DebugMonitor_IRQn : at32f413.h
  • DMA1_Channel1_IRQn : at32f413.h
  • DMA1_Channel2_IRQn : at32f413.h
  • DMA1_Channel3_IRQn : at32f413.h
  • DMA1_Channel4_IRQn : at32f413.h
  • DMA1_Channel5_IRQn : at32f413.h
  • DMA1_Channel6_IRQn : at32f413.h
  • DMA1_Channel7_IRQn : at32f413.h
  • DMA2_Channel1_IRQn : at32f413.h
  • DMA2_Channel2_IRQn : at32f413.h
  • DMA2_Channel3_IRQn : at32f413.h
  • DMA2_Channel4_5_IRQn : at32f413.h
  • DMA2_Channel6_7_IRQn : at32f413.h
  • DMA_DIR_MEMORY_TO_MEMORY : at32f413_dma.h
  • DMA_DIR_MEMORY_TO_PERIPHERAL : at32f413_dma.h
  • DMA_DIR_PERIPHERAL_TO_MEMORY : at32f413_dma.h
  • DMA_FLEXIBLE_ADC1 : at32f413_dma.h
  • DMA_FLEXIBLE_I2C1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_I2C2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_SDIO1 : at32f413_dma.h
  • DMA_FLEXIBLE_SPI1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_SPI2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_HALL : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR1_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR2_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR3_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR4_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR5_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH1 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH2 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH3 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_CH4 : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_HALL : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_OVERFLOW : at32f413_dma.h
  • DMA_FLEXIBLE_TMR8_TRIG : at32f413_dma.h
  • DMA_FLEXIBLE_UART1_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART1_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART2_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART2_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART3_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART3_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART4_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART4_TX : at32f413_dma.h
  • DMA_FLEXIBLE_UART5_RX : at32f413_dma.h
  • DMA_FLEXIBLE_UART5_TX : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_BYTE : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_HALFWORD : at32f413_dma.h
  • DMA_MEMORY_DATA_WIDTH_WORD : at32f413_dma.h
  • DMA_MEMORY_INC_DISABLE : at32f413_dma.h
  • DMA_MEMORY_INC_ENABLE : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_BYTE : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_HALFWORD : at32f413_dma.h
  • DMA_PERIPHERAL_DATA_WIDTH_WORD : at32f413_dma.h
  • DMA_PERIPHERAL_INC_DISABLE : at32f413_dma.h
  • DMA_PERIPHERAL_INC_ENABLE : at32f413_dma.h
  • DMA_PRIORITY_HIGH : at32f413_dma.h
  • DMA_PRIORITY_LOW : at32f413_dma.h
  • DMA_PRIORITY_MEDIUM : at32f413_dma.h
  • DMA_PRIORITY_VERY_HIGH : at32f413_dma.h


AT32F413 Firmwary Library: Globals

- e -

  • EPT_BULK_TYPE : at32f413_usb.h
  • EPT_CONTROL_TYPE : at32f413_usb.h
  • EPT_IN : at32f413_usb.h
  • EPT_INT_TYPE : at32f413_usb.h
  • EPT_ISO_TYPE : at32f413_usb.h
  • EPT_OUT : at32f413_usb.h
  • ERROR : at32f413.h
  • EXINT0_IRQn : at32f413.h
  • EXINT15_10_IRQn : at32f413.h
  • EXINT1_IRQn : at32f413.h
  • EXINT2_IRQn : at32f413.h
  • EXINT3_IRQn : at32f413.h
  • EXINT4_IRQn : at32f413.h
  • EXINT9_5_IRQn : at32f413.h
  • EXINT_LINE_EVENT : at32f413_exint.h
  • EXINT_LINE_INTERRUPUT : at32f413_exint.h
  • EXINT_TRIGGER_BOTH_EDGE : at32f413_exint.h
  • EXINT_TRIGGER_FALLING_EDGE : at32f413_exint.h
  • EXINT_TRIGGER_RISING_EDGE : at32f413_exint.h


AT32F413 Firmwary Library: Globals

- f -

  • FALSE : at32f413.h
  • FLASH_EPP_ERROR : at32f413_flash.h
  • FLASH_IRQn : at32f413.h
  • FLASH_OPERATE_BUSY : at32f413_flash.h
  • FLASH_OPERATE_DONE : at32f413_flash.h
  • FLASH_OPERATE_TIMEOUT : at32f413_flash.h
  • FLASH_PROGRAM_ERROR : at32f413_flash.h
  • FLASH_SPIM_MODEL1 : at32f413_flash.h
  • FLASH_SPIM_MODEL2 : at32f413_flash.h


AT32F413 Firmwary Library: Globals

- g -

  • GPIO_DRIVE_STRENGTH_MAXIMUM : at32f413_gpio.h
  • GPIO_DRIVE_STRENGTH_MODERATE : at32f413_gpio.h
  • GPIO_DRIVE_STRENGTH_STRONGER : at32f413_gpio.h
  • GPIO_MODE_ANALOG : at32f413_gpio.h
  • GPIO_MODE_INPUT : at32f413_gpio.h
  • GPIO_MODE_MUX : at32f413_gpio.h
  • GPIO_MODE_OUTPUT : at32f413_gpio.h
  • GPIO_OUTPUT_OPEN_DRAIN : at32f413_gpio.h
  • GPIO_OUTPUT_PUSH_PULL : at32f413_gpio.h
  • GPIO_PINS_SOURCE0 : at32f413_gpio.h
  • GPIO_PINS_SOURCE1 : at32f413_gpio.h
  • GPIO_PINS_SOURCE10 : at32f413_gpio.h
  • GPIO_PINS_SOURCE11 : at32f413_gpio.h
  • GPIO_PINS_SOURCE12 : at32f413_gpio.h
  • GPIO_PINS_SOURCE13 : at32f413_gpio.h
  • GPIO_PINS_SOURCE14 : at32f413_gpio.h
  • GPIO_PINS_SOURCE15 : at32f413_gpio.h
  • GPIO_PINS_SOURCE2 : at32f413_gpio.h
  • GPIO_PINS_SOURCE3 : at32f413_gpio.h
  • GPIO_PINS_SOURCE4 : at32f413_gpio.h
  • GPIO_PINS_SOURCE5 : at32f413_gpio.h
  • GPIO_PINS_SOURCE6 : at32f413_gpio.h
  • GPIO_PINS_SOURCE7 : at32f413_gpio.h
  • GPIO_PINS_SOURCE8 : at32f413_gpio.h
  • GPIO_PINS_SOURCE9 : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOA : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOB : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOC : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOD : at32f413_gpio.h
  • GPIO_PORT_SOURCE_GPIOF : at32f413_gpio.h
  • GPIO_PULL_DOWN : at32f413_gpio.h
  • GPIO_PULL_NONE : at32f413_gpio.h
  • GPIO_PULL_UP : at32f413_gpio.h


AT32F413 Firmwary Library: Globals

- h -

  • HardFault_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- i -

  • I2C1_ERR_IRQn : at32f413.h
  • I2C1_EVT_IRQn : at32f413.h
  • I2C2_ERR_IRQn : at32f413.h
  • I2C2_EVT_IRQn : at32f413.h
  • I2C_ADDRESS_MODE_10BIT : at32f413_i2c.h
  • I2C_ADDRESS_MODE_7BIT : at32f413_i2c.h
  • I2C_DIRECTION_RECEIVE : at32f413_i2c.h
  • I2C_DIRECTION_TRANSMIT : at32f413_i2c.h
  • I2C_DMA_MA_RX : i2c_application.h
  • I2C_DMA_MA_TX : i2c_application.h
  • I2C_DMA_SLA_RX : i2c_application.h
  • I2C_DMA_SLA_TX : i2c_application.h
  • I2C_ERR_ACKFAIL : i2c_application.h
  • I2C_ERR_ADDR : i2c_application.h
  • I2C_ERR_ADDR10 : i2c_application.h
  • I2C_ERR_INTERRUPT : i2c_application.h
  • I2C_ERR_START : i2c_application.h
  • I2C_ERR_STEP_1 : i2c_application.h
  • I2C_ERR_STEP_10 : i2c_application.h
  • I2C_ERR_STEP_11 : i2c_application.h
  • I2C_ERR_STEP_12 : i2c_application.h
  • I2C_ERR_STEP_2 : i2c_application.h
  • I2C_ERR_STEP_3 : i2c_application.h
  • I2C_ERR_STEP_4 : i2c_application.h
  • I2C_ERR_STEP_5 : i2c_application.h
  • I2C_ERR_STEP_6 : i2c_application.h
  • I2C_ERR_STEP_7 : i2c_application.h
  • I2C_ERR_STEP_8 : i2c_application.h
  • I2C_ERR_STEP_9 : i2c_application.h
  • I2C_ERR_STOP : i2c_application.h
  • I2C_ERR_TIMEOUT : i2c_application.h
  • I2C_FSMODE_DUTY_16_9 : at32f413_i2c.h
  • I2C_FSMODE_DUTY_2_1 : at32f413_i2c.h
  • I2C_INT_MA_RX : i2c_application.h
  • I2C_INT_MA_TX : i2c_application.h
  • I2C_INT_SLA_RX : i2c_application.h
  • I2C_INT_SLA_TX : i2c_application.h
  • I2C_MASTER_ACK_CURRENT : at32f413_i2c.h
  • I2C_MASTER_ACK_NEXT : at32f413_i2c.h
  • I2C_OK : i2c_application.h
  • I2C_PEC_POSITION_CURRENT : at32f413_i2c.h
  • I2C_PEC_POSITION_NEXT : at32f413_i2c.h
  • I2C_SMBUS_ALERT_HIGH : at32f413_i2c.h
  • I2C_SMBUS_ALERT_LOW : at32f413_i2c.h
  • I2C_SMBUS_MODE_DEVICE : at32f413_i2c.h
  • I2C_SMBUS_MODE_HOST : at32f413_i2c.h
  • I2S_AUDIO_FREQUENCY_11_025K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_16K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_192K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_22_05K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_32K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_44_1K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_48K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_8K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_96K : at32f413_spi.h
  • I2S_AUDIO_FREQUENCY_DEFAULT : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_LSB : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_MSB : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_LONG : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PCM_SHORT : at32f413_spi.h
  • I2S_AUDIO_PROTOCOL_PHILLIPS : at32f413_spi.h
  • I2S_CLOCK_POLARITY_HIGH : at32f413_spi.h
  • I2S_CLOCK_POLARITY_LOW : at32f413_spi.h
  • I2S_DATA_16BIT_CHANNEL_16BIT : at32f413_spi.h
  • I2S_DATA_16BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_DATA_24BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_DATA_32BIT_CHANNEL_32BIT : at32f413_spi.h
  • I2S_MODE_MASTER_RX : at32f413_spi.h
  • I2S_MODE_MASTER_TX : at32f413_spi.h
  • I2S_MODE_SLAVE_RX : at32f413_spi.h
  • I2S_MODE_SLAVE_TX : at32f413_spi.h
  • IAP_FAILED : hid_iap_class.h
  • IAP_STS_ADDR : hid_iap_class.h
  • IAP_STS_CRC : hid_iap_class.h
  • IAP_STS_DATA : hid_iap_class.h
  • IAP_STS_FINISH : hid_iap_class.h
  • IAP_STS_IDLE : hid_iap_class.h
  • IAP_STS_JMP : hid_iap_class.h
  • IAP_STS_JMP_WAIT : hid_iap_class.h
  • IAP_STS_START : hid_iap_class.h
  • IAP_SUCCESS : hid_iap_class.h
  • IAP_WAIT : hid_iap_class.h


AT32F413 Firmwary Library: Globals

- l -

  • LED2 : at32f413_board.h
  • LED3 : at32f413_board.h
  • LED4 : at32f413_board.h


AT32F413 Firmwary Library: Globals

- m -

  • MemoryManagement_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- n -

  • NO_BUTTON : at32f413_board.h
  • NonMaskableInt_IRQn : at32f413.h
  • NVIC_LP_SEVONPEND : at32f413_misc.h
  • NVIC_LP_SLEEPDEEP : at32f413_misc.h
  • NVIC_LP_SLEEPONEXIT : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_0 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_1 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_2 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_3 : at32f413_misc.h
  • NVIC_PRIORITY_GROUP_4 : at32f413_misc.h


AT32F413 Firmwary Library: Globals

- p -

  • PendSV_IRQn : at32f413.h
  • PRINTER_REQ_GET_DEVICE_ID : printer_class.h
  • PRINTER_REQ_GET_PORT_STATUS : printer_class.h
  • PRINTER_REQ_GET_SOFT_RESET : printer_class.h
  • PVM_IRQn : at32f413.h
  • PWC_DEEP_SLEEP_ENTER_WFE : at32f413_pwc.h
  • PWC_DEEP_SLEEP_ENTER_WFI : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V3 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V4 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V5 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V6 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V7 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V8 : at32f413_pwc.h
  • PWC_PVM_VOLTAGE_2V9 : at32f413_pwc.h
  • PWC_REGULATOR_LOW_POWER : at32f413_pwc.h
  • PWC_REGULATOR_ON : at32f413_pwc.h
  • PWC_SLEEP_ENTER_WFE : at32f413_pwc.h
  • PWC_SLEEP_ENTER_WFI : at32f413_pwc.h


AT32F413 Firmwary Library: Globals

- r -

  • RESET : at32f413.h
  • Reset_IRQn : at32f413.h
  • RTC_IRQn : at32f413.h
  • RTCAlarm_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- s -

  • SD_ADDR_MISALIGNED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ADDR_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_AKE_SEQ_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_BLK_LEN_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_CONTROLLER_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_DISCONNECTED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ECC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_IDENTIFICATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_PROGRAMMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_READY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_RECEIVING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_SENDING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_STANDBY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_TRANSFER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CID_CSD_OVERWRITE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAIL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_RSP_TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_FAIL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATA_TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERASE_RESET : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERASE_SEQ_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INTERNAL_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_ERASE_PARAM : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_PARAMETER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_INVALID_VOLTRANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_LOCK_UNLOCK_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_NOT_CONFIGURED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_NOT_APPLICABLE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_REQ_PENDING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_RX_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_BUSY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_FUNC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SDIO_UNKNOWN_FUNC : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_START_BIT_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_RD_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STREAM_WR_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SWITCH_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TRANSFER_DMA_MODE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TRANSFER_POLLING_MODE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_TX_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_FEATURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_UNSUPPORTED_HW : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WP_ERASE_SKIP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WR_PROTECT_VIOLATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO1_IRQn : at32f413.h
  • SDIO_BUS_WIDTH_D1 : at32f413_sdio.h
  • SDIO_BUS_WIDTH_D4 : at32f413_sdio.h
  • SDIO_BUS_WIDTH_D8 : at32f413_sdio.h
  • SDIO_CLOCK_EDGE_FALLING : at32f413_sdio.h
  • SDIO_CLOCK_EDGE_RISING : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_1024B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_128B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16384B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_16B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_1B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2048B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_256B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_2B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_32B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4096B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_4B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_512B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_64B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8192B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_SIZE_8B : at32f413_sdio.h
  • SDIO_DATA_BLOCK_TRANSFER : at32f413_sdio.h
  • SDIO_DATA_STREAM_TRANSFER : at32f413_sdio.h
  • SDIO_DATA_TRANSFER_TO_CARD : at32f413_sdio.h
  • SDIO_DATA_TRANSFER_TO_CONTROLLER : at32f413_sdio.h
  • SDIO_HIGH_CAPACITY_MMC_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_CAPACITY_SD_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_HIGH_SPEED_MULTIMEDIA_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_MULTIMEDIA_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_POWER_OFF : at32f413_sdio.h
  • SDIO_POWER_ON : at32f413_sdio.h
  • SDIO_READ_WAIT_CONTROLLED_BY_CK : at32f413_sdio.h
  • SDIO_READ_WAIT_CONTROLLED_BY_D2 : at32f413_sdio.h
  • SDIO_RESPONSE_LONG : at32f413_sdio.h
  • SDIO_RESPONSE_NO : at32f413_sdio.h
  • SDIO_RESPONSE_SHORT : at32f413_sdio.h
  • SDIO_RSP1_INDEX : at32f413_sdio.h
  • SDIO_RSP2_INDEX : at32f413_sdio.h
  • SDIO_RSP3_INDEX : at32f413_sdio.h
  • SDIO_RSP4_INDEX : at32f413_sdio.h
  • SDIO_SDIO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SECURE_DIGITAL_IO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_SECURE_DIGITAL_IO_COMBO_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V1_1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STD_CAPACITY_SD_CARD_V2_0 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_WAIT_FOR_INT : at32f413_sdio.h
  • SDIO_WAIT_FOR_NO : at32f413_sdio.h
  • SDIO_WAIT_FOR_PEND : at32f413_sdio.h
  • SET : at32f413.h
  • SPI1_IRQn : at32f413.h
  • SPI2_IRQn : at32f413.h
  • SPI_CLOCK_PHASE_1EDGE : at32f413_spi.h
  • SPI_CLOCK_PHASE_2EDGE : at32f413_spi.h
  • SPI_CLOCK_POLARITY_HIGH : at32f413_spi.h
  • SPI_CLOCK_POLARITY_LOW : at32f413_spi.h
  • SPI_CRC_RX : at32f413_spi.h
  • SPI_CRC_TX : at32f413_spi.h
  • SPI_CS_HARDWARE_MODE : at32f413_spi.h
  • SPI_CS_SOFTWARE_MODE : at32f413_spi.h
  • SPI_FIRST_BIT_LSB : at32f413_spi.h
  • SPI_FIRST_BIT_MSB : at32f413_spi.h
  • SPI_FRAME_16BIT : at32f413_spi.h
  • SPI_FRAME_8BIT : at32f413_spi.h
  • SPI_HALF_DUPLEX_DIRECTION_RX : at32f413_spi.h
  • SPI_HALF_DUPLEX_DIRECTION_TX : at32f413_spi.h
  • SPI_MCLK_DIV_1024 : at32f413_spi.h
  • SPI_MCLK_DIV_128 : at32f413_spi.h
  • SPI_MCLK_DIV_16 : at32f413_spi.h
  • SPI_MCLK_DIV_2 : at32f413_spi.h
  • SPI_MCLK_DIV_256 : at32f413_spi.h
  • SPI_MCLK_DIV_32 : at32f413_spi.h
  • SPI_MCLK_DIV_4 : at32f413_spi.h
  • SPI_MCLK_DIV_512 : at32f413_spi.h
  • SPI_MCLK_DIV_64 : at32f413_spi.h
  • SPI_MCLK_DIV_8 : at32f413_spi.h
  • SPI_MODE_MASTER : at32f413_spi.h
  • SPI_MODE_SLAVE : at32f413_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_HIGHT : at32f413_spi.h
  • SPI_SWCS_INTERNAL_LEVEL_LOW : at32f413_spi.h
  • SPI_TRANSMIT_FULL_DUPLEX : at32f413_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_RX : at32f413_spi.h
  • SPI_TRANSMIT_HALF_DUPLEX_TX : at32f413_spi.h
  • SPI_TRANSMIT_SIMPLEX_RX : at32f413_spi.h
  • SUCCESS : at32f413.h
  • SVCall_IRQn : at32f413.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 : at32f413_misc.h
  • SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV : at32f413_misc.h
  • SysTick_IRQn : at32f413.h


AT32F413 Firmwary Library: Globals

- t -

  • TAMPER_IRQn : at32f413.h
  • TMR1_BRK_TMR9_IRQn : at32f413.h
  • TMR1_CH_IRQn : at32f413.h
  • TMR1_OVF_TMR10_IRQn : at32f413.h
  • TMR1_TRG_HALL_TMR11_IRQn : at32f413.h
  • TMR2_GLOBAL_IRQn : at32f413.h
  • TMR3_GLOBAL_IRQn : at32f413.h
  • TMR4_GLOBAL_IRQn : at32f413.h
  • TMR5_GLOBAL_IRQn : at32f413.h
  • TMR8_BRK_IRQn : at32f413.h
  • TMR8_CH_IRQn : at32f413.h
  • TMR8_OVF_IRQn : at32f413.h
  • TMR8_TRG_HALL_IRQn : at32f413.h
  • TMR_BRK_ADDRESS : at32f413_tmr.h
  • TMR_BRK_INPUT_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_BRK_INPUT_ACTIVE_LOW : at32f413_tmr.h
  • TMR_BRK_SWTRIG : at32f413_tmr.h
  • TMR_C1_DMA_REQUEST : at32f413_tmr.h
  • TMR_C1_SWTRIG : at32f413_tmr.h
  • TMR_C1DT_ADDRESS : at32f413_tmr.h
  • TMR_C2_DMA_REQUEST : at32f413_tmr.h
  • TMR_C2_SWTRIG : at32f413_tmr.h
  • TMR_C2DT_ADDRESS : at32f413_tmr.h
  • TMR_C3_DMA_REQUEST : at32f413_tmr.h
  • TMR_C3_SWTRIG : at32f413_tmr.h
  • TMR_C3DT_ADDRESS : at32f413_tmr.h
  • TMR_C4_DMA_REQUEST : at32f413_tmr.h
  • TMR_C4_SWTRIG : at32f413_tmr.h
  • TMR_C4DT_ADDRESS : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_DIRECT : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_INDIRECT : at32f413_tmr.h
  • TMR_CC_CHANNEL_MAPPED_STI : at32f413_tmr.h
  • TMR_CCTRL_ADDRESS : at32f413_tmr.h
  • TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR : at32f413_tmr.h
  • TMR_CHANEL1_CONNECTED_C1IRAW : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_1 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_2 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_4 : at32f413_tmr.h
  • TMR_CHANNEL_INPUT_DIV_8 : at32f413_tmr.h
  • TMR_CLOCK_DIV1 : at32f413_tmr.h
  • TMR_CLOCK_DIV2 : at32f413_tmr.h
  • TMR_CLOCK_DIV4 : at32f413_tmr.h
  • TMR_CM1_ADDRESS : at32f413_tmr.h
  • TMR_CM2_ADDRESS : at32f413_tmr.h
  • TMR_COUNT_DOWN : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_1 : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_2 : at32f413_tmr.h
  • TMR_COUNT_TWO_WAY_3 : at32f413_tmr.h
  • TMR_COUNT_UP : at32f413_tmr.h
  • TMR_CTRL1_ADDRESS : at32f413_tmr.h
  • TMR_CTRL2_ADDRESS : at32f413_tmr.h
  • TMR_CVAL_ADDRESS : at32f413_tmr.h
  • TMR_DIV_ADDRESS : at32f413_tmr.h
  • TMR_DMA_REQUEST_BY_CHANNEL : at32f413_tmr.h
  • TMR_DMA_REQUEST_BY_OVERFLOW : at32f413_tmr.h
  • TMR_DMA_TRANSFER_10BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_11BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_12BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_13BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_14BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_15BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_16BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_17BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_18BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_1BYTE : at32f413_tmr.h
  • TMR_DMA_TRANSFER_2BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_3BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_4BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_5BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_6BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_7BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_8BYTES : at32f413_tmr.h
  • TMR_DMA_TRANSFER_9BYTES : at32f413_tmr.h
  • TMR_DMACTRL_ADDRESS : at32f413_tmr.h
  • TMR_ENCODER_MODE_A : at32f413_tmr.h
  • TMR_ENCODER_MODE_B : at32f413_tmr.h
  • TMR_ENCODER_MODE_C : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_1 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_2 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_4 : at32f413_tmr.h
  • TMR_ES_FREQUENCY_DIV_8 : at32f413_tmr.h
  • TMR_ES_POLARITY_INVERTED : at32f413_tmr.h
  • TMR_ES_POLARITY_NON_INVERTED : at32f413_tmr.h
  • TMR_FORCE_OUTPUT_HIGH : at32f413_tmr.h
  • TMR_FORCE_OUTPUT_LOW : at32f413_tmr.h
  • TMR_HALL_DMA_REQUEST : at32f413_tmr.h
  • TMR_HALL_SWTRIG : at32f413_tmr.h
  • TMR_IDEN_ADDRESS : at32f413_tmr.h
  • TMR_INPUT_BOTH_EDGE : at32f413_tmr.h
  • TMR_INPUT_FALLING_EDGE : at32f413_tmr.h
  • TMR_INPUT_RISING_EDGE : at32f413_tmr.h
  • TMR_ISTS_ADDRESS : at32f413_tmr.h
  • TMR_OUTPUT_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_ACTIVE_LOW : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_FORCE_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_FORCE_LOW : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_HIGH : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_LOW : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_OFF : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_A : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_PWM_MODE_B : at32f413_tmr.h
  • TMR_OUTPUT_CONTROL_SWITCH : at32f413_tmr.h
  • TMR_OVERFLOW_DMA_REQUEST : at32f413_tmr.h
  • TMR_OVERFLOW_SWTRIG : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_BOTH : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_HIGH : at32f413_tmr.h
  • TMR_POLARITY_ACTIVE_LOW : at32f413_tmr.h
  • TMR_PR_ADDRESS : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C1ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C2ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C3ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_C4ORAW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_COMPARE : at32f413_tmr.h
  • TMR_PRIMARY_SEL_ENABLE : at32f413_tmr.h
  • TMR_PRIMARY_SEL_OVERFLOW : at32f413_tmr.h
  • TMR_PRIMARY_SEL_RESET : at32f413_tmr.h
  • TMR_RPR_ADDRESS : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_1 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_1C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_2 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_2C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_3 : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_3C : at32f413_tmr.h
  • TMR_SELECT_CHANNEL_4 : at32f413_tmr.h
  • TMR_STCTRL_ADDRESS : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_A : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_B : at32f413_tmr.h
  • TMR_SUB_ENCODER_MODE_C : at32f413_tmr.h
  • TMR_SUB_EXTERNAL_CLOCK_MODE_A : at32f413_tmr.h
  • TMR_SUB_HANG_MODE : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C1DF1 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C1INC : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_C2DF2 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_EXTIN : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS0 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS1 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS2 : at32f413_tmr.h
  • TMR_SUB_INPUT_SEL_IS3 : at32f413_tmr.h
  • TMR_SUB_MODE_DIABLE : at32f413_tmr.h
  • TMR_SUB_RESET_MODE : at32f413_tmr.h
  • TMR_SUB_TRIGGER_MODE : at32f413_tmr.h
  • TMR_SWEVT_ADDRESS : at32f413_tmr.h
  • TMR_TRIGGER_DMA_REQUEST : at32f413_tmr.h
  • TMR_TRIGGER_SWTRIG : at32f413_tmr.h
  • TMR_WP_LEVEL_1 : at32f413_tmr.h
  • TMR_WP_LEVEL_2 : at32f413_tmr.h
  • TMR_WP_LEVEL_3 : at32f413_tmr.h
  • TMR_WP_OFF : at32f413_tmr.h
  • TRUE : at32f413.h


AT32F413 Firmwary Library: Globals

- u -

  • UART4_IRQn : at32f413.h
  • UART5_IRQn : at32f413.h
  • UPDATE_CLEAR_FLAG : bootloader/inc/iap.h
  • UPDATE_DONE : bootloader/inc/iap.h
  • UPDATE_ING : bootloader/inc/iap.h
  • UPDATE_PRE : bootloader/inc/iap.h
  • UPGRADE_DONE : flash_fat16.h
  • UPGRADE_FAILED : flash_fat16.h
  • UPGRADE_JUMP : flash_fat16.h
  • UPGRADE_LARGE : flash_fat16.h
  • UPGRADE_READY : flash_fat16.h
  • UPGRADE_SUCCESS : flash_fat16.h
  • UPGRADE_UNKNOWN : flash_fat16.h
  • UPGRAGE_ONGOING : flash_fat16.h
  • UsageFault_IRQn : at32f413.h
  • USART1_IRQn : at32f413.h
  • USART2_IRQn : at32f413.h
  • USART3_IRQn : at32f413.h
  • USART_BREAK_10BITS : at32f413_usart.h
  • USART_BREAK_11BITS : at32f413_usart.h
  • USART_CLOCK_LAST_BIT_NONE : at32f413_usart.h
  • USART_CLOCK_LAST_BIT_OUTPUT : at32f413_usart.h
  • USART_CLOCK_PHASE_1EDGE : at32f413_usart.h
  • USART_CLOCK_PHASE_2EDGE : at32f413_usart.h
  • USART_CLOCK_POLARITY_HIGH : at32f413_usart.h
  • USART_CLOCK_POLARITY_LOW : at32f413_usart.h
  • USART_DATA_8BITS : at32f413_usart.h
  • USART_DATA_9BITS : at32f413_usart.h
  • USART_HARDWARE_FLOW_CTS : at32f413_usart.h
  • USART_HARDWARE_FLOW_NONE : at32f413_usart.h
  • USART_HARDWARE_FLOW_RTS : at32f413_usart.h
  • USART_HARDWARE_FLOW_RTS_CTS : at32f413_usart.h
  • USART_PARITY_EVEN : at32f413_usart.h
  • USART_PARITY_NONE : at32f413_usart.h
  • USART_PARITY_ODD : at32f413_usart.h
  • USART_STOP_0_5_BIT : at32f413_usart.h
  • USART_STOP_1_5_BIT : at32f413_usart.h
  • USART_STOP_1_BIT : at32f413_usart.h
  • USART_STOP_2_BIT : at32f413_usart.h
  • USART_WAKEUP_BY_IDLE_FRAME : at32f413_usart.h
  • USART_WAKEUP_BY_MATCHING_ID : at32f413_usart.h
  • USB_CLK_HEXT : at32f413_usb.h
  • USB_CLK_HICK : at32f413_usb.h
  • USB_CONN_STATE_ADDRESSED : usb_std.h
  • USB_CONN_STATE_CONFIGURED : usb_std.h
  • USB_CONN_STATE_DEFAULT : usb_std.h
  • USB_CONN_STATE_SUSPENDED : usb_std.h
  • USB_EPT0 : at32f413_usb.h
  • USB_EPT1 : at32f413_usb.h
  • USB_EPT2 : at32f413_usb.h
  • USB_EPT3 : at32f413_usb.h
  • USB_EPT4 : at32f413_usb.h
  • USB_EPT5 : at32f413_usb.h
  • USB_EPT6 : at32f413_usb.h
  • USB_EPT7 : at32f413_usb.h
  • USB_ERROR : usb_std.h
  • USB_FAIL : usb_std.h
  • USB_NOT_SUPPORT : usb_std.h
  • USB_OK : usb_std.h
  • USB_WAIT : usb_std.h
  • USBD_ERR_EVENT : usbd_core.h
  • USBD_NOP_EVENT : usbd_core.h
  • USBD_RESET_EVENT : usbd_core.h
  • USBD_SUSPEND_EVENT : usbd_core.h
  • USBD_WAKEUP_EVENT : usbd_core.h
  • USBFS_H_CAN1_TX_IRQn : at32f413.h
  • USBFS_L_CAN1_RX0_IRQn : at32f413.h
  • USBFS_MAPH_IRQn : at32f413.h
  • USBFS_MAPL_IRQn : at32f413.h
  • USBFSWakeUp_IRQn : at32f413.h
  • USER_BUTTON : at32f413_board.h


AT32F413 Firmwary Library: Globals

- w -

  • WDT_CLK_DIV_128 : at32f413_wdt.h
  • WDT_CLK_DIV_16 : at32f413_wdt.h
  • WDT_CLK_DIV_256 : at32f413_wdt.h
  • WDT_CLK_DIV_32 : at32f413_wdt.h
  • WDT_CLK_DIV_4 : at32f413_wdt.h
  • WDT_CLK_DIV_64 : at32f413_wdt.h
  • WDT_CLK_DIV_8 : at32f413_wdt.h
  • WDT_CMD_ENABLE : at32f413_wdt.h
  • WDT_CMD_LOCK : at32f413_wdt.h
  • WDT_CMD_RELOAD : at32f413_wdt.h
  • WDT_CMD_UNLOCK : at32f413_wdt.h
  • WWDT_IRQn : at32f413.h
  • WWDT_PCLK1_DIV_16384 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_32768 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_4096 : at32f413_wwdt.h
  • WWDT_PCLK1_DIV_8192 : at32f413_wwdt.h


AT32F413 Firmwary Library: Globals

- _ -

  • __AT32F413_LIBRARY_VERSION : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MAJOR : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MIDDLE : at32f413.h
  • __AT32F413_LIBRARY_VERSION_MINOR : at32f413.h
  • __AT32F413_LIBRARY_VERSION_RC : at32f413.h
  • __CM4_REV : at32f413.h
  • __FPU_PRESENT : at32f413.h
  • __MPU_PRESENT : at32f413.h
  • __NVIC_PRIO_BITS : at32f413.h
  • __Vendor_SysTickConfig : at32f413.h


AT32F413 Firmwary Library: Globals

- a -

  • ACC : at32f413_acc.h
  • ACC_BASE : at32f413.h
  • ACC_CAL_HICKCAL : at32f413_acc.h
  • ACC_CAL_HICKTRIM : at32f413_acc.h
  • ACC_CALRDY_FLAG : at32f413_acc.h
  • ACC_CALRDYIEN_INT : at32f413_acc.h
  • ACC_EIEN_INT : at32f413_acc.h
  • ACC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • ACC_RSLOST_FLAG : at32f413_acc.h
  • ACC_TRIM : project/at_start_f413/examples/acc/calibration/src/main.c
  • ADC1 : at32f413_adc.h
  • ADC1_BASE : at32f413.h
  • ADC1_ETO_GMUX : at32f413_gpio.h
  • ADC1_ETO_MUX : at32f413_gpio.h
  • ADC1_ETP_GMUX : at32f413_gpio.h
  • ADC1_ETP_MUX : at32f413_gpio.h
  • ADC2 : at32f413_adc.h
  • ADC2_BASE : at32f413.h
  • ADC2_ETO_GMUX : at32f413_gpio.h
  • ADC2_ETO_MUX : at32f413_gpio.h
  • ADC2_ETP_GMUX : at32f413_gpio.h
  • ADC2_ETP_MUX : at32f413_gpio.h
  • ADC_CCE_FLAG : at32f413_adc.h
  • ADC_CCE_INT : at32f413_adc.h
  • ADC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • ADC_OCCS_FLAG : at32f413_adc.h
  • ADC_PCCE_FLAG : at32f413_adc.h
  • ADC_PCCE_INT : at32f413_adc.h
  • ADC_PCCS_FLAG : at32f413_adc.h
  • ADC_TEMP_BASE : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_TEMP_SLOPE : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADC_VMOR_FLAG : at32f413_adc.h
  • ADC_VMOR_INT : at32f413_adc.h
  • ADC_VREF : project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
  • ADDRESS_OUT_OF_RANGE : cdc_msc_class.h, msc_bot_scsi.h
  • AHBPERIPH_BASE : at32f413.h
  • AIRCR_VECTKEY_MASK : at32f413_misc.c
  • APB1PERIPH_BASE : at32f413.h
  • APB2PERIPH_BASE : at32f413.h
  • APP_START_ADDR : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • AT32_AUDIO_FREQ_16K : audio_desc.h, audio_hid_desc.h
  • AT32_AUDIO_FREQ_48K : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_EXTENSION_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_FEATURE_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_HEADER : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_INPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_MIXER_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_OUTPUT_TERMINAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_PROCESSING_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AC_SELECTOR_UNIT : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_DESCRIPTOR_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_SPECIFIC : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_FORMAT_TYPE : audio_desc.h, audio_hid_desc.h
  • AUDIO_AS_GENERAL : audio_desc.h, audio_hid_desc.h
  • AUDIO_BCD_NUM : audio_desc.h
  • AUDIO_BINTERVAL_TIME : audio_desc.h
  • AUDIO_BITW_16 : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_CS_CONFIGURATION : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_DEVICE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_ENDPOINT : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_STRING : audio_desc.h, audio_hid_desc.h
  • AUDIO_CS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_DEFAULT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_DESCRIPTOR_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_DESCRIPTOR_TYPE : audio_class.h, audio_hid_class.h
  • AUDIO_FEATURE_UNIT_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_FEEDBACK_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_FORMAT_TYPE_I : audio_desc.h, audio_hid_desc.h
  • AUDIO_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_FREQ_SET_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_FU_BASS_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_CONTROL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MID_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_MUTE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_TREBLE_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_FU_VOLUME_CONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_MICROPHONE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_INPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_LEN : audio_desc.h, audio_hid_desc.h
  • AUDIO_INTERFACE_NUM : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_MIC_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_IN_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_MIC_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_MIC_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_MUTE_CONTROL : audio_class.h, audio_hid_class.h
  • AUDIO_OUTPUT_TERMINAL_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_SPEAKER : audio_desc.h, audio_hid_desc.h
  • AUDIO_OUTPUT_TERMINAL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_PROTOCOL_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_REMAIN_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_ENDPOINT : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_INTERFACE : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_CONTROL_MASK : audio_class.h, audio_hid_class.h
  • AUDIO_REQ_GET_CUR : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_RES : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_GET_STAT : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_CUR : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MAX : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MEM : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_MIN : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQ_SET_RES : audio_desc.h, audio_hid_desc.h
  • AUDIO_REQUEST_CODE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_BITW : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_CHANEL_NUM : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_CHR : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_DEFAULT_BITW : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SPK_FEATURE_UNIT_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_FREQ_SIZE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_INTERFACE_NUMBER : audio_desc.h, audio_hid_desc.h
  • AUDIO_SPK_OUT_MAXPACKET_SIZE : audio_class.h, audio_hid_class.h
  • AUDIO_SPK_OUTPUT_TERMINAL_ID : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_AUDIOCONTROL : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_AUDIOSTREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_MIDISTREMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUBCLASS_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_SUPPORT_FEEDBACK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_16K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_FREQ_48K : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MAX_FREQ : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_MIC : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_SUPPORT_SPK : audio/audio_conf.h, audio_hid/audio_conf.h
  • AUDIO_TERMINAL_TYPE_STREAMING : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_UNDEFINED : audio_desc.h, audio_hid_desc.h
  • AUDIO_TERMINAL_TYPE_VENDOR : audio_desc.h, audio_hid_desc.h
  • AUDIO_VOLUME_CONTROL : audio_class.h, audio_hid_class.h
  • AUHID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BCD_NUM : audio_hid_desc.h
  • AUHID_HID_BINTERVAL_TIME : audio_hid_desc.h


AT32F413 Firmwary Library: Globals

- b -

  • BLK2 : at32f413_usb.h
  • BLK32 : at32f413_usb.h
  • BLOCK_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c, fir_filter.c
  • BLOCKS_NUMBER : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • BPR : at32f413_bpr.h
  • BPR_BASE : at32f413.h
  • BPR_DR_NUMBER : project/at_start_f413/examples/bpr/bpr_data/src/main.c, project/at_start_f413/examples/bpr/tamper/src/main.c
  • BPR_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • BPR_TAMPER_EVENT_FLAG : at32f413_bpr.h
  • BPR_TAMPER_INTERRUPT_FLAG : at32f413_bpr.h
  • BUF_SIZE : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • BUFFER_SIZE : project/at_start_f413/examples/crc/calculation/src/main.c, project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c, project/at_start_f413/examples/dma/flash_to_sram/src/main.c, project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c, project/at_start_f413/examples/spi/fullduplex_polling/src/main.c, project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c, project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c, project/at_start_f413/examples/usart/hw_flow_control/src/main.c, project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • BUFFERSIZE : project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
  • BUTTON_RELEASE : mouse_class.h


AT32F413 Firmwary Library: Globals

- c -

  • CAN1 : at32f413_can.h
  • CAN1_BASE : at32f413.h
  • CAN1_GMUX_0010 : at32f413_gpio.h
  • CAN2 : at32f413_can.h
  • CAN2_BASE : at32f413.h
  • CAN2_GMUX_0001 : at32f413_gpio.h
  • CAN_BOF_FLAG : at32f413_can.h
  • CAN_BOIEN_INT : at32f413_can.h
  • CAN_EAF_FLAG : at32f413_can.h
  • CAN_EAIEN_INT : at32f413_can.h
  • CAN_EDZC_FLAG : at32f413_can.h
  • CAN_EDZIEN_INT : at32f413_can.h
  • CAN_EOIEN_INT : at32f413_can.h
  • CAN_EOIF_FLAG : at32f413_can.h
  • CAN_EPF_FLAG : at32f413_can.h
  • CAN_EPIEN_INT : at32f413_can.h
  • CAN_ETR_FLAG : at32f413_can.h
  • CAN_ETRIEN_INT : at32f413_can.h
  • CAN_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • CAN_MSTS_EDZIF_VAL : at32f413_can.h
  • CAN_MSTS_EOIF_VAL : at32f413_can.h
  • CAN_MSTS_QDZIF_VAL : at32f413_can.h
  • CAN_MUX_10 : at32f413_gpio.h
  • CAN_QDZIEN_INT : at32f413_can.h
  • CAN_QDZIF_FLAG : at32f413_can.h
  • CAN_RF0_RF0FF_VAL : at32f413_can.h
  • CAN_RF0_RF0OF_VAL : at32f413_can.h
  • CAN_RF0_RF0R_VAL : at32f413_can.h
  • CAN_RF0FF_FLAG : at32f413_can.h
  • CAN_RF0FIEN_INT : at32f413_can.h
  • CAN_RF0MIEN_INT : at32f413_can.h
  • CAN_RF0MN_FLAG : at32f413_can.h
  • CAN_RF0OF_FLAG : at32f413_can.h
  • CAN_RF0OIEN_INT : at32f413_can.h
  • CAN_RF1_RF1FF_VAL : at32f413_can.h
  • CAN_RF1_RF1OF_VAL : at32f413_can.h
  • CAN_RF1_RF1R_VAL : at32f413_can.h
  • CAN_RF1FF_FLAG : at32f413_can.h
  • CAN_RF1FIEN_INT : at32f413_can.h
  • CAN_RF1MIEN_INT : at32f413_can.h
  • CAN_RF1MN_FLAG : at32f413_can.h
  • CAN_RF1OF_FLAG : at32f413_can.h
  • CAN_RF1OIEN_INT : at32f413_can.h
  • CAN_TCIEN_INT : at32f413_can.h
  • CAN_TM0TCF_FLAG : at32f413_can.h
  • CAN_TM1TCF_FLAG : at32f413_can.h
  • CAN_TM2TCF_FLAG : at32f413_can.h
  • CAN_TMEF_FLAG : at32f413_can.h
  • CAN_TSTS_TM0CT_VAL : at32f413_can.h
  • CAN_TSTS_TM0TCF_VAL : at32f413_can.h
  • CAN_TSTS_TM1CT_VAL : at32f413_can.h
  • CAN_TSTS_TM1TCF_VAL : at32f413_can.h
  • CAN_TSTS_TM2CT_VAL : at32f413_can.h
  • CAN_TSTS_TM2TCF_VAL : at32f413_can.h
  • CBW_BMCBWFLAGS_DIR_IN : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_BMCBWFLAGS_DIR_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CBW_DCBWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CDC_BCD_NUM : cdc_desc.h, cdc_msc_desc.h
  • CDC_HID_BINTERVAL_TIME : cdc_desc.h, cdc_msc_desc.h
  • configASSERT : FreeRTOSConfig.h
  • configCPU_CLOCK_HZ : FreeRTOSConfig.h
  • configIDLE_SHOULD_YIELD : FreeRTOSConfig.h
  • configKERNEL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_LOWEST_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_CO_ROUTINE_PRIORITIES : FreeRTOSConfig.h
  • configMAX_PRIORITIES : FreeRTOSConfig.h
  • configMAX_SYSCALL_INTERRUPT_PRIORITY : FreeRTOSConfig.h
  • configMAX_TASK_NAME_LEN : FreeRTOSConfig.h
  • configMINIMAL_STACK_SIZE : FreeRTOSConfig.h
  • configPRIO_BITS : FreeRTOSConfig.h
  • configSUPPORT_DYNAMIC_ALLOCATION : FreeRTOSConfig.h
  • configTICK_RATE_HZ : FreeRTOSConfig.h
  • configTOTAL_HEAP_SIZE : FreeRTOSConfig.h
  • configUSE_16_BIT_TICKS : FreeRTOSConfig.h
  • configUSE_CO_ROUTINES : FreeRTOSConfig.h
  • configUSE_IDLE_HOOK : FreeRTOSConfig.h
  • configUSE_PREEMPTION : FreeRTOSConfig.h
  • configUSE_TICK_HOOK : FreeRTOSConfig.h
  • CONVERT_ENDIAN : hid_iap_class.h
  • COUNTOF : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • CRC : at32f413_crc.h
  • CRC_BASE : at32f413.h
  • CRC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • CRM : at32f413_crm.h
  • CRM_ALL_RESET_FLAG : at32f413_crm.h
  • CRM_BASE : at32f413.h
  • CRM_CLOCK_FAILURE_INT : at32f413_crm.h
  • CRM_CLOCK_FAILURE_INT_FLAG : at32f413_crm.h
  • CRM_HEXT_READY_INT_FLAG : at32f413_crm.h
  • CRM_HEXT_STABLE_FLAG : at32f413_crm.h
  • CRM_HEXT_STABLE_INT : at32f413_crm.h
  • CRM_HICK_READY_INT_FLAG : at32f413_crm.h
  • CRM_HICK_STABLE_FLAG : at32f413_crm.h
  • CRM_HICK_STABLE_INT : at32f413_crm.h
  • CRM_LEXT_READY_INT_FLAG : at32f413_crm.h
  • CRM_LEXT_STABLE_FLAG : at32f413_crm.h
  • CRM_LEXT_STABLE_INT : at32f413_crm.h
  • CRM_LICK_READY_INT_FLAG : at32f413_crm.h
  • CRM_LICK_STABLE_FLAG : at32f413_crm.h
  • CRM_LICK_STABLE_INT : at32f413_crm.h
  • CRM_LOWPOWER_RESET_FLAG : at32f413_crm.h
  • CRM_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • CRM_NRST_RESET_FLAG : at32f413_crm.h
  • CRM_PLL_READY_INT_FLAG : at32f413_crm.h
  • CRM_PLL_STABLE_FLAG : at32f413_crm.h
  • CRM_PLL_STABLE_INT : at32f413_crm.h
  • CRM_POR_RESET_FLAG : at32f413_crm.h
  • CRM_REG : at32f413_crm.h
  • CRM_REG_BIT : at32f413_crm.h
  • CRM_SW_RESET_FLAG : at32f413_crm.h
  • CRM_WDT_RESET_FLAG : at32f413_crm.h
  • CRM_WWDT_RESET_FLAG : at32f413_crm.h
  • CSW_BCSWSTATUS_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PASS : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_BCSWSTATUS_PHASE_ERR : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_CMD_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • CSW_DCSWSIGNATURE : cdc_msc_class.h, msc_bot_scsi.h
  • CUSHID_BCD_NUM : custom_hid_desc.h
  • CUSHID_BINTERVAL_TIME : custom_hid_desc.h


AT32F413 Firmwary Library: Globals

- d -

  • DATA1_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA2_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA3_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DATA4_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • DEBUG_BASE : at32f413.h
  • DEBUG_CAN1_PAUSE : at32f413_debug.h
  • DEBUG_CAN2_PAUSE : at32f413_debug.h
  • DEBUG_DEEPSLEEP : at32f413_debug.h
  • DEBUG_I2C1_SMBUS_TIMEOUT : at32f413_debug.h
  • DEBUG_I2C2_SMBUS_TIMEOUT : at32f413_debug.h
  • DEBUG_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • DEBUG_SLEEP : at32f413_debug.h
  • DEBUG_STANDBY : at32f413_debug.h
  • DEBUG_TMR10_PAUSE : at32f413_debug.h
  • DEBUG_TMR11_PAUSE : at32f413_debug.h
  • DEBUG_TMR1_PAUSE : at32f413_debug.h
  • DEBUG_TMR2_PAUSE : at32f413_debug.h
  • DEBUG_TMR3_PAUSE : at32f413_debug.h
  • DEBUG_TMR4_PAUSE : at32f413_debug.h
  • DEBUG_TMR5_PAUSE : at32f413_debug.h
  • DEBUG_TMR8_PAUSE : at32f413_debug.h
  • DEBUG_TMR9_PAUSE : at32f413_debug.h
  • DEBUG_WDT_PAUSE : at32f413_debug.h
  • DEBUG_WWDT_PAUSE : at32f413_debug.h
  • DEBUGMCU : at32f413_debug.h
  • DELAY : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c, project/at_start_f413/templates/src/main.c
  • DEV_MMC : diskio.c
  • DEV_RAM : diskio.c
  • DEV_USB : diskio.c
  • DEVICE_ID_ADDR1 : random.c
  • DMA1 : at32f413_dma.h
  • DMA1_BASE : at32f413.h
  • DMA1_CHANNEL1 : at32f413_dma.h
  • DMA1_CHANNEL1_BASE : at32f413.h
  • DMA1_CHANNEL2 : at32f413_dma.h
  • DMA1_CHANNEL2_BASE : at32f413.h
  • DMA1_CHANNEL3 : at32f413_dma.h
  • DMA1_CHANNEL3_BASE : at32f413.h
  • DMA1_CHANNEL4 : at32f413_dma.h
  • DMA1_CHANNEL4_BASE : at32f413.h
  • DMA1_CHANNEL5 : at32f413_dma.h
  • DMA1_CHANNEL5_BASE : at32f413.h
  • DMA1_CHANNEL6 : at32f413_dma.h
  • DMA1_CHANNEL6_BASE : at32f413.h
  • DMA1_CHANNEL7 : at32f413_dma.h
  • DMA1_CHANNEL7_BASE : at32f413.h
  • DMA1_DTERR1_FLAG : at32f413_dma.h
  • DMA1_DTERR2_FLAG : at32f413_dma.h
  • DMA1_DTERR3_FLAG : at32f413_dma.h
  • DMA1_DTERR4_FLAG : at32f413_dma.h
  • DMA1_DTERR5_FLAG : at32f413_dma.h
  • DMA1_DTERR6_FLAG : at32f413_dma.h
  • DMA1_DTERR7_FLAG : at32f413_dma.h
  • DMA1_FDT1_FLAG : at32f413_dma.h
  • DMA1_FDT2_FLAG : at32f413_dma.h
  • DMA1_FDT3_FLAG : at32f413_dma.h
  • DMA1_FDT4_FLAG : at32f413_dma.h
  • DMA1_FDT5_FLAG : at32f413_dma.h
  • DMA1_FDT6_FLAG : at32f413_dma.h
  • DMA1_FDT7_FLAG : at32f413_dma.h
  • DMA1_GL1_FLAG : at32f413_dma.h
  • DMA1_GL2_FLAG : at32f413_dma.h
  • DMA1_GL3_FLAG : at32f413_dma.h
  • DMA1_GL4_FLAG : at32f413_dma.h
  • DMA1_GL5_FLAG : at32f413_dma.h
  • DMA1_GL6_FLAG : at32f413_dma.h
  • DMA1_GL7_FLAG : at32f413_dma.h
  • DMA1_HDT1_FLAG : at32f413_dma.h
  • DMA1_HDT2_FLAG : at32f413_dma.h
  • DMA1_HDT3_FLAG : at32f413_dma.h
  • DMA1_HDT4_FLAG : at32f413_dma.h
  • DMA1_HDT5_FLAG : at32f413_dma.h
  • DMA1_HDT6_FLAG : at32f413_dma.h
  • DMA1_HDT7_FLAG : at32f413_dma.h
  • DMA2 : at32f413_dma.h
  • DMA2_BASE : at32f413.h
  • DMA2_CHANNEL1 : at32f413_dma.h
  • DMA2_CHANNEL1_BASE : at32f413.h
  • DMA2_CHANNEL2 : at32f413_dma.h
  • DMA2_CHANNEL2_BASE : at32f413.h
  • DMA2_CHANNEL3 : at32f413_dma.h
  • DMA2_CHANNEL3_BASE : at32f413.h
  • DMA2_CHANNEL4 : at32f413_dma.h
  • DMA2_CHANNEL4_BASE : at32f413.h
  • DMA2_CHANNEL5 : at32f413_dma.h
  • DMA2_CHANNEL5_BASE : at32f413.h
  • DMA2_CHANNEL6 : at32f413_dma.h
  • DMA2_CHANNEL6_BASE : at32f413.h
  • DMA2_CHANNEL7 : at32f413_dma.h
  • DMA2_CHANNEL7_BASE : at32f413.h
  • DMA2_DTERR1_FLAG : at32f413_dma.h
  • DMA2_DTERR2_FLAG : at32f413_dma.h
  • DMA2_DTERR3_FLAG : at32f413_dma.h
  • DMA2_DTERR4_FLAG : at32f413_dma.h
  • DMA2_DTERR5_FLAG : at32f413_dma.h
  • DMA2_DTERR6_FLAG : at32f413_dma.h
  • DMA2_DTERR7_FLAG : at32f413_dma.h
  • DMA2_FDT1_FLAG : at32f413_dma.h
  • DMA2_FDT2_FLAG : at32f413_dma.h
  • DMA2_FDT3_FLAG : at32f413_dma.h
  • DMA2_FDT4_FLAG : at32f413_dma.h
  • DMA2_FDT5_FLAG : at32f413_dma.h
  • DMA2_FDT6_FLAG : at32f413_dma.h
  • DMA2_FDT7_FLAG : at32f413_dma.h
  • DMA2_GL1_FLAG : at32f413_dma.h
  • DMA2_GL2_FLAG : at32f413_dma.h
  • DMA2_GL3_FLAG : at32f413_dma.h
  • DMA2_GL4_FLAG : at32f413_dma.h
  • DMA2_GL5_FLAG : at32f413_dma.h
  • DMA2_GL6_FLAG : at32f413_dma.h
  • DMA2_GL7_FLAG : at32f413_dma.h
  • DMA2_HDT1_FLAG : at32f413_dma.h
  • DMA2_HDT2_FLAG : at32f413_dma.h
  • DMA2_HDT3_FLAG : at32f413_dma.h
  • DMA2_HDT4_FLAG : at32f413_dma.h
  • DMA2_HDT5_FLAG : at32f413_dma.h
  • DMA2_HDT6_FLAG : at32f413_dma.h
  • DMA2_HDT7_FLAG : at32f413_dma.h
  • DMA_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • DMA_DTERR_INT : at32f413_dma.h
  • DMA_FDT_INT : at32f413_dma.h
  • DMA_GET_HT_FLAG : i2c_application.c
  • DMA_GET_TC_FLAG : i2c_application.c
  • DMA_GET_TERR_FLAG : i2c_application.c
  • DMA_HDT_INT : at32f413_dma.h
  • DMA_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • DOWN_MOVE : mouse_class.h
  • DYMMY_BYTE : project/at_start_f413/examples/usart/synchronous/src/main.c
  • DZC_TIMEOUT : at32f413_can.h


AT32F413 Firmwary Library: Globals

- e -

  • ENABLE_RTC_ASSEED : random.h
  • EPT0_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT0_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT1_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT1_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT2_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT2_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT3_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT3_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT4_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT4_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT5_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT5_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT6_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT6_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT7_RX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • EPT7_TX_ADDR : project/at_start_f413/examples/acc/calibration/inc/usb_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • ERASE_TIMEOUT : at32f413_flash.h
  • ERROR_ID_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • EXINT : at32f413_exint.h
  • EXINT_BASE : at32f413.h
  • EXINT_LINE_0 : at32f413_exint.h
  • EXINT_LINE_1 : at32f413_exint.h
  • EXINT_LINE_10 : at32f413_exint.h
  • EXINT_LINE_11 : at32f413_exint.h
  • EXINT_LINE_12 : at32f413_exint.h
  • EXINT_LINE_13 : at32f413_exint.h
  • EXINT_LINE_14 : at32f413_exint.h
  • EXINT_LINE_15 : at32f413_exint.h
  • EXINT_LINE_16 : at32f413_exint.h
  • EXINT_LINE_17 : at32f413_exint.h
  • EXINT_LINE_18 : at32f413_exint.h
  • EXINT_LINE_2 : at32f413_exint.h
  • EXINT_LINE_3 : at32f413_exint.h
  • EXINT_LINE_4 : at32f413_exint.h
  • EXINT_LINE_5 : at32f413_exint.h
  • EXINT_LINE_6 : at32f413_exint.h
  • EXINT_LINE_7 : at32f413_exint.h
  • EXINT_LINE_8 : at32f413_exint.h
  • EXINT_LINE_9 : at32f413_exint.h
  • EXINT_LINE_NONE : at32f413_exint.h
  • EXINT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • EXT_CSD_BUS_WIDTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Clear_byte : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_CPSECURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_NORMAL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_CMD_SET_SECURE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Command_set : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_HS_TIMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Set_bit : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_CSD_Write_byte : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • EXT_SPIM_EN_MUX : at32f413_gpio.h
  • EXT_SPIM_GMUX_1000 : at32f413_gpio.h
  • EXT_SPIM_GMUX_1001 : at32f413_gpio.h


AT32F413 Firmwary Library: Globals

- f -

  • FAP_RELIEVE_KEY : at32f413_flash.h
  • FAST : project/at_start_f413/templates/src/main.c
  • FAT16_BYTE_PER_SIZE : flash_fat16.h
  • FAT16_DIR_SIZE : flash_fat16.h
  • FAT16_FILENAME_SIZE : flash_fat16.h
  • FAT16_SECTOR_SIZE : flash_fat16.h, flash_fat16.c
  • FAT16_TABLE_SIZE : flash_fat16.h
  • FEEDBACK_REFRESH_TIME : audio_class.h, audio_hid_class.h
  • FF_CODE_PAGE : ffconf.h
  • FF_FS_EXFAT : ffconf.h
  • FF_FS_LOCK : ffconf.h
  • FF_FS_MINIMIZE : ffconf.h
  • FF_FS_NOFSINFO : ffconf.h
  • FF_FS_NORTC : ffconf.h
  • FF_FS_READONLY : ffconf.h
  • FF_FS_REENTRANT : ffconf.h
  • FF_FS_RPATH : ffconf.h
  • FF_FS_TIMEOUT : ffconf.h
  • FF_FS_TINY : ffconf.h
  • FF_LBA64 : ffconf.h
  • FF_LFN_BUF : ffconf.h
  • FF_LFN_UNICODE : ffconf.h
  • FF_MAX_LFN : ffconf.h
  • FF_MAX_SS : ffconf.h
  • FF_MIN_GPT : ffconf.h
  • FF_MIN_SS : ffconf.h
  • FF_MULTI_PARTITION : ffconf.h
  • FF_NORTC_MDAY : ffconf.h
  • FF_NORTC_MON : ffconf.h
  • FF_NORTC_YEAR : ffconf.h
  • FF_PRINT_FLOAT : ffconf.h
  • FF_PRINT_LLI : ffconf.h
  • FF_SFN_BUF : ffconf.h
  • FF_STR_VOLUME_ID : ffconf.h
  • FF_STRF_ENCODE : ffconf.h
  • FF_SYNC_t : ffconf.h
  • FF_USE_CHMOD : ffconf.h
  • FF_USE_EXPAND : ffconf.h
  • FF_USE_FASTSEEK : ffconf.h
  • FF_USE_FIND : ffconf.h
  • FF_USE_FORWARD : ffconf.h
  • FF_USE_LABEL : ffconf.h
  • FF_USE_LFN : ffconf.h
  • FF_USE_MKFS : ffconf.h
  • FF_USE_STRFUNC : ffconf.h
  • FF_USE_TRIM : ffconf.h
  • FF_VOLUME_STRS : ffconf.h
  • FF_VOLUMES : ffconf.h
  • FFCONF_DEF : ffconf.h
  • FILE_SUFFIX1_LEN : flash_fat16.h
  • FILE_SUFFIX1_NAME : flash_fat16.h
  • FILE_SUFFIX2_LEN : flash_fat16.h
  • FILE_SUFFIX2_NAME : flash_fat16.h
  • FILTER_EXT_ID1 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_EXT_ID2 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_EXT_ID3 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID1 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID2 : project/at_start_f413/examples/can/filter/src/main.c
  • FILTER_STD_ID3 : project/at_start_f413/examples/can/filter/src/main.c
  • FLASH : at32f413_flash.h
  • FLASH_APP_ADDRESS : app_led3_toggle/inc/hid_iap_user.h, app_led4_toggle/inc/hid_iap_user.h, bootloader/inc/hid_iap_user.h
  • FLASH_APP_START_ADDR : flash_fat16.h
  • FLASH_BASE : at32f413.h
  • FLASH_CS_HIGH : spi_flash.h
  • FLASH_CS_LOW : spi_flash.h
  • FLASH_EPPERR_FLAG : at32f413_flash.h
  • FLASH_ERR_INT : at32f413_flash.h
  • FLASH_FAT16_1_ADDR : flash_fat16.h
  • FLASH_FAT16_2_ADDR : flash_fat16.h
  • FLASH_FAT16_BOOT_SECTOR_ADDR : flash_fat16.h
  • FLASH_FAT16_FILE_START_ADDR : flash_fat16.h
  • FLASH_FAT16_ROOT_ADDR : flash_fat16.h
  • FLASH_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • FLASH_OBF_FLAG : at32f413_flash.h
  • FLASH_ODF_FLAG : at32f413_flash.h
  • FLASH_ODF_INT : at32f413_flash.h
  • FLASH_PRGMERR_FLAG : at32f413_flash.h
  • FLASH_REG_BASE : at32f413.h
  • FLASH_SECTOR_1K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_1K_SIZE : flash_fat16.h
  • FLASH_SECTOR_2K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_2K_SIZE : flash_fat16.h
  • FLASH_SECTOR_4K_ALLGNED : flash_fat16.h
  • FLASH_SECTOR_4K_SIZE : flash_fat16.h
  • FLASH_SECTOR_SIZE : utilities/at32f413_slib_demo/project_l0/src/main.c
  • FLASH_SIZE : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
  • FLASH_SIZE_REG : hid_iap_class.h
  • FLASH_SLIB_DATA_START_SECTOR : at32f413_flash.h
  • FLASH_SLIB_END_SECTOR : at32f413_flash.h
  • FLASH_SLIB_START_SECTOR : at32f413_flash.h
  • FLASH_SPI_DUMMY_BYTE : spi_flash.h
  • FLASH_SPIM_EPPERR_FLAG : at32f413_flash.h
  • FLASH_SPIM_ERR_INT : at32f413_flash.h
  • FLASH_SPIM_OBF_FLAG : at32f413_flash.h
  • FLASH_SPIM_ODF_FLAG : at32f413_flash.h
  • FLASH_SPIM_ODF_INT : at32f413_flash.h
  • FLASH_SPIM_PRGMERR_FLAG : at32f413_flash.h
  • FLASH_SPIM_START_ADDR : at32f413_flash.h
  • FLASH_START_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • FLASH_TEST_ADDR : project/at_start_f413/examples/spi/w25q_flash/src/main.c
  • FLASH_UNLOCK_KEY1 : at32f413_flash.h
  • FLASH_UNLOCK_KEY2 : at32f413_flash.h
  • FLASH_USDERR_FLAG : at32f413_flash.h
  • FLEX_CHANNEL1 : at32f413_dma.h
  • FLEX_CHANNEL2 : at32f413_dma.h
  • FLEX_CHANNEL3 : at32f413_dma.h
  • FLEX_CHANNEL4 : at32f413_dma.h
  • FLEX_CHANNEL5 : at32f413_dma.h
  • FLEX_CHANNEL6 : at32f413_dma.h
  • FLEX_CHANNEL7 : at32f413_dma.h
  • FZC_TIMEOUT : at32f413_can.h


AT32F413 Firmwary Library: Globals

- g -

  • GET_LINE_CODING : cdc_msc_class.h, msc_bot_scsi.h, usb_std.h
  • GET_RX_LEN_ADDR : at32f413_usb.h
  • GET_TX_LEN_ADDR : at32f413_usb.h
  • GPIO_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • GPIO_PINS_0 : at32f413_gpio.h
  • GPIO_PINS_1 : at32f413_gpio.h
  • GPIO_PINS_10 : at32f413_gpio.h
  • GPIO_PINS_11 : at32f413_gpio.h
  • GPIO_PINS_12 : at32f413_gpio.h
  • GPIO_PINS_13 : at32f413_gpio.h
  • GPIO_PINS_14 : at32f413_gpio.h
  • GPIO_PINS_15 : at32f413_gpio.h
  • GPIO_PINS_2 : at32f413_gpio.h
  • GPIO_PINS_3 : at32f413_gpio.h
  • GPIO_PINS_4 : at32f413_gpio.h
  • GPIO_PINS_5 : at32f413_gpio.h
  • GPIO_PINS_6 : at32f413_gpio.h
  • GPIO_PINS_7 : at32f413_gpio.h
  • GPIO_PINS_8 : at32f413_gpio.h
  • GPIO_PINS_9 : at32f413_gpio.h
  • GPIO_PINS_ALL : at32f413_gpio.h
  • GPIOA : at32f413_gpio.h
  • GPIOA_BASE : at32f413.h
  • GPIOB : at32f413_gpio.h
  • GPIOB_BASE : at32f413.h
  • GPIOC : at32f413_gpio.h
  • GPIOC_BASE : at32f413.h
  • GPIOD : at32f413_gpio.h
  • GPIOD_BASE : at32f413.h
  • GPIOF : at32f413_gpio.h
  • GPIOF_BASE : at32f413.h


AT32F413 Firmwary Library: Globals

- h -

  • HBYTE : usb_std.h
  • HEXT_STABLE_DELAY : system_at32f413.h
  • HEXT_STARTUP_TIMEOUT : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HEXT_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HICK_VALUE : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • HID_CLASS_DESC_HID : audio_hid_desc.h, usb_std.h
  • HID_CLASS_DESC_PHYSICAL : audio_hid_desc.h, usb_std.h
  • HID_CLASS_DESC_REPORT : audio_hid_desc.h, usb_std.h
  • HID_DESCRIPTOR_TYPE : usb_std.h
  • HID_IAP_BUFFER_LEN : hid_iap_class.h
  • HID_INTERFACE_NUMBER : audio_hid_desc.h
  • HID_REPORT_DESC : usb_std.h
  • HID_REPORT_ID_1 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_2 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_3 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_4 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_5 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REPORT_ID_6 : audio_hid_desc.h, custom_hid_desc.h
  • HID_REQ_GET_IDLE : usb_std.h
  • HID_REQ_GET_PROTOCOL : usb_std.h
  • HID_REQ_GET_REPORT : usb_std.h
  • HID_REQ_SET_IDLE : usb_std.h
  • HID_REQ_SET_PROTOCOL : usb_std.h
  • HID_REQ_SET_REPORT : usb_std.h
  • HIDIAP_BCD_NUM : hid_iap_desc.h
  • HIDIAP_BINTERVAL_TIME : hid_iap_desc.h
  • HIST_LENGTH : project/at_start_f413/examples/usart/smartcard/src/main.c


AT32F413 Firmwary Library: Globals

- i -

  • I2C1 : at32f413_i2c.h
  • I2C1_BASE : at32f413.h
  • I2C1_GMUX_0001 : at32f413_gpio.h
  • I2C1_GMUX_0011 : at32f413_gpio.h
  • I2C1_MUX : at32f413_gpio.h
  • I2C2 : at32f413_i2c.h
  • I2C2_BASE : at32f413.h
  • I2C2_GMUX_0001 : at32f413_gpio.h
  • I2C2_GMUX_0010 : at32f413_gpio.h
  • I2C2_GMUX_0011 : at32f413_gpio.h
  • I2C_ACKFAIL_FLAG : at32f413_i2c.h
  • I2C_ADDR2_FLAG : at32f413_i2c.h
  • I2C_ADDR7F_FLAG : at32f413_i2c.h
  • I2C_ADDRHF_FLAG : at32f413_i2c.h
  • I2C_ALERTF_FLAG : at32f413_i2c.h
  • I2C_ARLOST_FLAG : at32f413_i2c.h
  • I2C_BUSERR_FLAG : at32f413_i2c.h
  • I2C_BUSYF_FLAG : at32f413_i2c.h
  • I2C_DATA_INT : at32f413_i2c.h
  • I2C_DEVADDRF_FLAG : at32f413_i2c.h
  • I2C_DIRF_FLAG : at32f413_i2c.h
  • I2C_END : i2c_application.c
  • I2C_ERR_INT : at32f413_i2c.h
  • I2C_EVENT_CHECK_ACKFAIL : i2c_application.h
  • I2C_EVENT_CHECK_NONE : i2c_application.h
  • I2C_EVENT_CHECK_STOP : i2c_application.h
  • I2C_EVT_INT : at32f413_i2c.h
  • I2C_GCADDRF_FLAG : at32f413_i2c.h
  • I2C_HOSTADDRF_FLAG : at32f413_i2c.h
  • I2C_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • I2C_OUF_FLAG : at32f413_i2c.h
  • I2C_PECERR_FLAG : at32f413_i2c.h
  • I2C_RDBF_FLAG : at32f413_i2c.h
  • I2C_START : i2c_application.c
  • I2C_STARTF_FLAG : at32f413_i2c.h
  • I2C_STOPF_FLAG : at32f413_i2c.h
  • I2C_TDBE_FLAG : at32f413_i2c.h
  • I2C_TDC_FLAG : at32f413_i2c.h
  • I2C_TIMEOUT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2C_TMOUT_FLAG : at32f413_i2c.h
  • I2C_TRMODE_FLAG : at32f413_i2c.h
  • I2Cx_ADDRESS : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_DMA_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_CHANNEL : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_RX_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_DMA_RX_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_CHANNEL : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_DMA_TX_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_DMA_TX_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_ERR_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_ERR_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_EVT_IRQHandler : project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c, project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c, project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
  • I2Cx_EVT_IRQn : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c
  • I2Cx_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_GPIO_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SCL_PIN : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_CLK : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_GPIO_PORT : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SDA_PIN : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2Cx_SPEED : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c, project/at_start_f413/examples/i2c/eeprom/src/main.c, audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • I2S1_CK_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_DT_ADDRESS : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_GPIO_CRM_CLK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_SD_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S1_WS_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_CK_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_DT_ADDRESS : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_GPIO_CRM_CLK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_SD_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S2_WS_PIN : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • I2S_ACS_FLAG : at32f413_spi.h
  • I2S_TUERR_FLAG : at32f413_spi.h
  • IAP_ACK : hid_iap_class.h
  • IAP_CMD_ADDR : hid_iap_class.h
  • IAP_CMD_CRC : hid_iap_class.h
  • IAP_CMD_DATA : hid_iap_class.h
  • IAP_CMD_FINISH : hid_iap_class.h
  • IAP_CMD_GET : hid_iap_class.h
  • IAP_CMD_IDLE : hid_iap_class.h
  • IAP_CMD_JMP : hid_iap_class.h
  • IAP_CMD_START : hid_iap_class.h
  • IAP_FAILED : flash_fat16.h
  • IAP_NACK : hid_iap_class.h
  • IAP_REV_FLAG_5A : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_DONE : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_ERROR : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_REV_FLAG_NO : app_led3_toggle/inc/usart.h, app_led4_toggle/inc/usart.h
  • IAP_SUCCESS : flash_fat16.h
  • IAP_UPGRADE_COMPLETE_FLAG : hid_iap_class.h, flash_fat16.h
  • IAP_UPGRADE_FLAG : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • IAP_UPGRADE_FLAG_ADDR : app_led3_toggle/inc/iap.h, app_led4_toggle/inc/iap.h, bootloader/inc/iap.h
  • IMG_CONSTANT : julia_fpu.h
  • INCLUDE_uxTaskPriorityGet : FreeRTOSConfig.h
  • INCLUDE_vTaskCleanUpResources : FreeRTOSConfig.h
  • INCLUDE_vTaskDelay : FreeRTOSConfig.h
  • INCLUDE_vTaskDelayUntil : FreeRTOSConfig.h
  • INCLUDE_vTaskDelete : FreeRTOSConfig.h
  • INCLUDE_vTaskPrioritySet : FreeRTOSConfig.h
  • INCLUDE_vTaskSuspend : FreeRTOSConfig.h
  • INCLUDE_xTaskGetCurrentTaskHandle : FreeRTOSConfig.h
  • INTERNAL_FLASH_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • INVAILD_OFFSET_ADDR : flash_fat16.h
  • INVALID_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELD_IN_PARAMETER_LIST : cdc_msc_class.h, msc_bot_scsi.h
  • INVALID_FIELED_IN_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • IOMUX : at32f413_gpio.h
  • IOMUX_BASE : at32f413.h
  • IOMUX_MAKE_VALUE : at32f413_gpio.h
  • ITERATION : julia_fpu.h


AT32F413 Firmwary Library: Globals

- k -

  • KB_TO_B : hid_iap_class.h
  • KEYBOARD_BCD_NUM : keyboard_desc.h
  • KEYBOARD_BINTERVAL_TIME : keyboard_desc.h


AT32F413 Firmwary Library: Globals

- l -

  • LBYTE : usb_std.h
  • LED_NUM : at32f413_board.h
  • LEFT_BUTTON : mouse_class.h
  • LEFT_MOVE : mouse_class.h


AT32F413 Firmwary Library: Globals

- m -

  • MAKE_VALUE : at32f413.h
  • MASTER_BOARD : project/at_start_f413/examples/i2c/communication_dma/src/main.c, project/at_start_f413/examples/i2c/communication_int/src/main.c, project/at_start_f413/examples/i2c/communication_poll/src/main.c
  • MATCH_ID_VAL : project/at_start_f413/examples/usart/receiver_mute/src/main.c
  • MAX : usb_std.h
  • MCU_ID1 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID2 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MCU_ID3 : audio_desc.h, audio_hid_desc.h, cdc_desc.h, cdc_keyboard_desc.h, cdc_msc_desc.h, custom_hid_desc.h, hid_iap_desc.h, keyboard_desc.h, mouse_desc.h, msc_desc.h, printer_desc.h
  • MEDIUM_HAVE_CHANGED : cdc_msc_class.h, msc_bot_scsi.h
  • MEDIUM_NOT_PRESENT : cdc_msc_class.h, msc_bot_scsi.h
  • MIC_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • MIN : usb_std.h
  • MISC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • MMC_SWITCH_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • MOUSE_BCD_NUM : mouse_desc.h
  • MOUSE_BINTERVAL_TIME : mouse_desc.h
  • MOVE_STEP : mouse_class.h
  • MS_TICK : project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c
  • MSC_BCD_NUM : msc_desc.h
  • MSC_BOT_STATE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_BOT_STATE_RECOVERY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_ALLOW_MEDIUM_REMOVAL : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_FORMAT_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_INQUIRY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_MODE_SENSE6 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_READ_FORMAT_CAPACITY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_REQUEST_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_START_STOP : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_TEST_UNIT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_10 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_12 : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_CMD_WRITE_VERIFY : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_MAX_DATA_BUF_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_BO_RESET : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_REQ_GET_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_CMD : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_IN : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_DATA_OUT : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_FAILED : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_IDLE : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_LAST_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_SEND_DATA : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_STATE_MACHINE_STATUS : cdc_msc_class.h, msc_bot_scsi.h
  • MSC_SUPPORT_MAX_LUN : cdc_msc_class.h, msc_bot_scsi.h
  • MULTI_BUFFER_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c


AT32F413 Firmwary Library: Globals

- n -

  • NULL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • NUM_TAPS : fir_coefficient.c, fir_filter.c
  • NUMSTUDENTS : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • NUMSUBJECTS : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • NVIC_VECTTAB_FLASH : at32f413_misc.h
  • NVIC_VECTTAB_RAM : at32f413_misc.h


AT32F413 Firmwary Library: Globals

- o -

  • OPERATION_TIMEOUT : at32f413_flash.h


AT32F413 Firmwary Library: Globals

- p -

  • PARAMETER_LIST_LENGTH_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • PD01_GMUX : at32f413_gpio.h
  • PD01_MUX : at32f413_gpio.h
  • PERIPH_BASE : at32f413.h
  • PERIPH_REG : at32f413.h
  • PERIPH_REG_BIT : at32f413.h
  • PERIPHERAL_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_BITBAND_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_RESET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PERIPHERAL_SET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • PLL_STABLE_DELAY : system_at32f413.h
  • PRINT_UART : at32f413_board.h
  • PRINT_UART_CRM_CLK : at32f413_board.h
  • PRINT_UART_TX_GPIO : at32f413_board.h
  • PRINT_UART_TX_GPIO_CRM_CLK : at32f413_board.h
  • PRINT_UART_TX_PIN : at32f413_board.h
  • PRINTER_BCD_NUM : printer_desc.h
  • PRINTER_DEVICE_ID_LEN : printer_class.h
  • PRINTER_PROTOCOL_1284_4 : printer_desc.h
  • PRINTER_PROTOCOL_BI_DIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_UNIDIRECTIONAL : printer_desc.h
  • PRINTER_PROTOCOL_VENDOR_SPECIFIC : printer_desc.h
  • PROGRAMMING_TIMEOUT : at32f413_flash.h
  • PUTCHAR_PROTOTYPE : at32f413_board.c
  • PWC : at32f413_pwc.h
  • PWC_BASE : at32f413.h
  • PWC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • PWC_PVM_OUTPUT_FLAG : at32f413_pwc.h
  • PWC_STANDBY_FLAG : at32f413_pwc.h
  • PWC_WAKEUP_FLAG : at32f413_pwc.h
  • PWC_WAKEUP_PIN_1 : at32f413_pwc.h


AT32F413 Firmwary Library: Globals

- r -

  • RAM_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • RAM_BITBAND_BASE : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • REAL_CONSTANT : julia_fpu.h
  • REG16 : at32f413.h
  • REG32 : at32f413.h
  • REG8 : at32f413.h
  • REQ_SENSE_STANDARD_DATA_LEN : cdc_msc_class.h, msc_bot_scsi.h
  • RIGHT_BUTTON : mouse_class.h
  • RIGHT_MOVE : mouse_class.h
  • RS485_BAUDRATE : project/at_start_f413/examples/usart/rs485/src/main.c
  • RS485_BUFFER_SIZE : project/at_start_f413/examples/usart/rs485/src/main.c
  • RTC : at32f413_rtc.h
  • RTC_BASE : at32f413.h
  • RTC_CFGF_FLAG : at32f413_rtc.h
  • RTC_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • RTC_OVF_FLAG : at32f413_rtc.h
  • RTC_OVF_INT : at32f413_rtc.h
  • RTC_TA_FLAG : at32f413_rtc.h
  • RTC_TA_INT : at32f413_rtc.h
  • RTC_TS_FLAG : at32f413_rtc.h
  • RTC_TS_INT : at32f413_rtc.h
  • RTC_UPDF_FLAG : at32f413_rtc.h


AT32F413 Firmwary Library: Globals

- s -

  • SAMPLE_FREQ : audio_desc.h, audio_hid_desc.h
  • SAMPLING_NUM : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • SC_3_5V_CLK : smartcard_config.h
  • SC_3_5V_PIN : smartcard_config.h
  • SC_3_5V_PORT : smartcard_config.h
  • SC_CMDVCC_CLK : smartcard_config.h
  • SC_CMDVCC_PIN : smartcard_config.h
  • SC_CMDVCC_PORT : smartcard_config.h
  • SC_F_DIV_D : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_OFF_CLK : smartcard_config.h
  • SC_OFF_EXINT : smartcard_config.h
  • SC_OFF_EXINT_IRQ : smartcard_config.h
  • SC_OFF_PIN : smartcard_config.h
  • SC_OFF_PINSOURCE : smartcard_config.h
  • SC_OFF_PORT : smartcard_config.h
  • SC_OFF_PORTSOURCE : smartcard_config.h
  • SC_RECEIVE_TIMEOUT : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_RESET_CLK : smartcard_config.h
  • SC_RESET_PIN : smartcard_config.h
  • SC_RESET_PORT : smartcard_config.h
  • SC_USART : smartcard_config.h
  • SC_USART_CLK : smartcard_config.h
  • SC_USART_CLK_PIN : smartcard_config.h
  • SC_USART_CLK_PORT : smartcard_config.h
  • SC_USART_DIV_VAL : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SC_USART_GPIO_CLK : smartcard_config.h
  • SC_USART_IRQHandler : smartcard_config.h
  • SC_USART_IRQn : smartcard_config.h
  • SC_USART_TX_PIN : smartcard_config.h
  • SC_USART_TX_PORT : smartcard_config.h
  • SCLK_FROM_HICK : project/at_start_f413/examples/acc/calibration/src/main.c
  • SCREEN_X_SIZE : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • SCREEN_Y_SIZE : project/at_start_f413/examples/cortex_m4/fpu/src/main.c
  • SCSI_INQUIRY_DATA_LENGTH : cdc_msc_class.h, msc_bot_scsi.h
  • SD_0TO7BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_16TO23BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_24TO31BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_8TO15BITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_ALLZERO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_LOCKED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_PROGRAMMING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CARD_RECEIVING : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_LOCK_UNLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CCCC_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CHECK_PATTERN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ALL_SEND_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_APP_SD_SET_BUSWIDTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_CLR_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_END : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_ERASE_GRP_START : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_FAST_IO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GEN_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IDLE_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_INACTIVE_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_GO_IRQ_STATE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_READ : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_BUSTEST_WRITE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SEND_EXT_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_HS_SWITCH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_LOCK_UNLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_NO_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_PROG_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_DAT_UNTIL_STOP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_MULT_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_READ_SINGLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_CHANGE_SECURE_AREA : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RES1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_CER_RN2 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_GET_MKB : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_ERASE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MKB : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SEND_SCR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RES2 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CER_RN1 : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_SET_CLR_CARD_DETECT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_APP_STAUS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_END : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SD_ERASE_GRP_START : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_DIRECT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_RW_EXTENDED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SDIO_SEN_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEL_DESEL_CARD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CID : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_CSD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_OP_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_STATUS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SEND_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCK_COUNT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_BLOCKLEN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_DSR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_REL_ADDR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_SET_WRITE_PROT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_STOP_TRANSMISSION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_DAT_UNTIL_STOP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_MULT_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_CMD_WRITE_SINGLE_BLOCK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_DATATIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFO : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HALFFIFOBYTES : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_HIGH_CAPACITY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • SD_MAX_DATA_LENGTH : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_MAX_VOLT_TRIAL : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_MISALIGNED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ADDR_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_AKE_SEQ_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_BLK_LEN_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_CONTROLLER_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_DISABLED : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CARD_ECC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CID_CSD_OVERWRIETE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_RESET : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERASE_SEQ_ERR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ERRORBITS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_INVALID_ERASE_PARAM : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_LOCK_UNLOCK_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_RD_UNDERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_STREAM_WR_OVERRUN : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WP_ERASE_SKIP : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_OCR_WR_PROTECT_VIOLATION : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_FUNCTION_NUMBER : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R5_OUT_OF_RANGE : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_CMD_CRC_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_GENERAL_UNKNOWN_ERROR : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_R6_ILLEGAL_CMD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_SINGLE_BUS_SUPPORT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_STD_CAPACITY : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_MMC : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_VOLTAGE_WINDOW_SD : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SD_WIDE_BUS_SUPPORT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO1 : at32f413_sdio.h
  • SDIO1_BASE : at32f413.h
  • SDIO1_GMUX_0100 : at32f413_gpio.h
  • SDIO1_GMUX_0101 : at32f413_gpio.h
  • SDIO1_GMUX_0110 : at32f413_gpio.h
  • SDIO1_GMUX_0111 : at32f413_gpio.h
  • SDIO_CMD0TIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_CMDCMPL_FLAG : at32f413_sdio.h
  • SDIO_CMDCMPL_INT : at32f413_sdio.h
  • SDIO_CMDFAIL_FLAG : at32f413_sdio.h
  • SDIO_CMDFAIL_INT : at32f413_sdio.h
  • SDIO_CMDRSPCMPL_FLAG : at32f413_sdio.h
  • SDIO_CMDRSPCMPL_INT : at32f413_sdio.h
  • SDIO_CMDTIMEOUT_FLAG : at32f413_sdio.h
  • SDIO_CMDTIMEOUT_INT : at32f413_sdio.h
  • SDIO_DATATIMEOUT : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_DOCMD_FLAG : at32f413_sdio.h
  • SDIO_DOCMD_INT : at32f413_sdio.h
  • SDIO_DORX_FLAG : at32f413_sdio.h
  • SDIO_DORX_INT : at32f413_sdio.h
  • SDIO_DOTX_FLAG : at32f413_sdio.h
  • SDIO_DOTX_INT : at32f413_sdio.h
  • SDIO_DTBLKCMPL_FLAG : at32f413_sdio.h
  • SDIO_DTBLKCMPL_INT : at32f413_sdio.h
  • SDIO_DTCMP_INT : at32f413_sdio.h
  • SDIO_DTCMPL_FLAG : at32f413_sdio.h
  • SDIO_DTFAIL_FLAG : at32f413_sdio.h
  • SDIO_DTFAIL_INT : at32f413_sdio.h
  • SDIO_DTTIMEOUT_FLAG : at32f413_sdio.h
  • SDIO_DTTIMEOUT_INT : at32f413_sdio.h
  • SDIO_FIFO_Address : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_INTR_STS_READ_MASK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_INTR_STS_WRITE_MASK : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • SDIO_RXBUF_FLAG : at32f413_sdio.h
  • SDIO_RXBUF_INT : at32f413_sdio.h
  • SDIO_RXBUFE_FLAG : at32f413_sdio.h
  • SDIO_RXBUFE_INT : at32f413_sdio.h
  • SDIO_RXBUFF_FLAG : at32f413_sdio.h
  • SDIO_RXBUFF_INT : at32f413_sdio.h
  • SDIO_RXBUFH_FLAG : at32f413_sdio.h
  • SDIO_RXBUFH_INT : at32f413_sdio.h
  • SDIO_RXERRO_FLAG : at32f413_sdio.h
  • SDIO_RXERRO_INT : at32f413_sdio.h
  • SDIO_SBITERR_FLAG : at32f413_sdio.h
  • SDIO_SBITERR_INT : at32f413_sdio.h
  • SDIO_SDIOIF_FLAG : at32f413_sdio.h
  • SDIO_SDIOIF_INT : at32f413_sdio.h
  • SDIO_SEND_IF_COND : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_STATIC_FLAGS : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SDIO_TXBUF_FLAG : at32f413_sdio.h
  • SDIO_TXBUF_INT : at32f413_sdio.h
  • SDIO_TXBUFE_FLAG : at32f413_sdio.h
  • SDIO_TXBUFE_INT : at32f413_sdio.h
  • SDIO_TXBUFF_FLAG : at32f413_sdio.h
  • SDIO_TXBUFF_INT : at32f413_sdio.h
  • SDIO_TXBUFH_FLAG : at32f413_sdio.h
  • SDIO_TXBUFH_INT : at32f413_sdio.h
  • SDIO_TXERRU_FLAG : at32f413_sdio.h
  • SDIO_TXERRU_INT : at32f413_sdio.h
  • SDIOx : sd_mmc_card/inc/at32_sdio.h, sdio_fatfs/inc/at32_sdio.h
  • SECTOR_NUM : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SECTOR_SIZE : project/at_start_f413/examples/flash/flash_write_read/src/flash.c
  • SECTOR_SIZE_1K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_SIZE_2K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_SIZE_4K : hid_iap_class.h, composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h
  • SECTOR_WORD_CNT : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SENSE_KEY_ABORTED_COMMAND : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_BLANK_CHECK : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_DATA_PROTECT : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_HARDWARE_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_ILLEGAL_REQUEST : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MEDIUM_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_MISCOMPARE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NO_SENSE : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_NOT_READY : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_RECOVERED_ERROR : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_UNIT_ATTENTION : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VENDERO_SPECIFIC : cdc_msc_class.h, msc_bot_scsi.h
  • SENSE_KEY_VOLUME_OVERFLOW : cdc_msc_class.h, msc_bot_scsi.h
  • SET_LINE_CODING : cdc_msc_class.h, msc_bot_scsi.h, usb_std.h
  • SETUP_LENGTH : project/at_start_f413/examples/usart/smartcard/src/main.c
  • SHIFT : cdc_keyboard_class.c, keyboard_class.c
  • SLIB_DATA_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_END_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_START_ADDR : utilities/at32f413_slib_demo/project_l0/src/main.c
  • SLIB_UNLOCK_KEY : at32f413_flash.h
  • SLOW : project/at_start_f413/templates/src/main.c
  • SNR_THRESHOLD_F32 : utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • SPI1 : at32f413_spi.h
  • SPI1_BASE : at32f413.h
  • SPI1_GMUX_0001 : at32f413_gpio.h
  • SPI1_MUX_01 : at32f413_gpio.h
  • SPI2 : at32f413_spi.h
  • SPI2_BASE : at32f413.h
  • SPI2_GMUX_0001 : at32f413_gpio.h
  • SPI2_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/synchronous/src/main.c
  • SPI_CCERR_FLAG : at32f413_spi.h
  • SPI_FLASH_LUN : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • SPI_I2S_BF_FLAG : at32f413_spi.h
  • SPI_I2S_ERROR_INT : at32f413_spi.h
  • SPI_I2S_RDBF_FLAG : at32f413_spi.h
  • SPI_I2S_RDBF_INT : at32f413_spi.h
  • SPI_I2S_ROERR_FLAG : at32f413_spi.h
  • SPI_I2S_TDBE_FLAG : at32f413_spi.h
  • SPI_I2S_TDBE_INT : at32f413_spi.h
  • SPI_MMERR_FLAG : at32f413_spi.h
  • SPI_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • SPI_TRANS_DMA : spi_flash.h
  • SPIF_BLOCKERASE : spi_flash.h
  • SPIF_CHIP_SIZE : spi_flash.h
  • SPIF_CHIPERASE : spi_flash.h
  • SPIF_DEVICEID : spi_flash.h
  • SPIF_FASTREADDATA : spi_flash.h
  • SPIF_FASTREADDUAL : spi_flash.h
  • SPIF_JEDECDEVICEID : spi_flash.h
  • SPIF_MANUFACTDEVICEID : spi_flash.h
  • SPIF_PAGE_SIZE : spi_flash.h
  • SPIF_PAGEPROGRAM : spi_flash.h
  • SPIF_POWERDOWN : spi_flash.h
  • SPIF_READDATA : spi_flash.h
  • SPIF_READSTATUSREG1 : spi_flash.h
  • SPIF_READSTATUSREG2 : spi_flash.h
  • SPIF_READSTATUSREG3 : spi_flash.h
  • SPIF_RELEASEPOWERDOWN : spi_flash.h
  • SPIF_SECTOR_SIZE : spi_flash.h
  • SPIF_SECTORERASE : spi_flash.h
  • SPIF_WRITEDISABLE : spi_flash.h
  • SPIF_WRITEENABLE : spi_flash.h
  • SPIF_WRITESTATUSREG1 : spi_flash.h
  • SPIF_WRITESTATUSREG2 : spi_flash.h
  • SPIF_WRITESTATUSREG3 : spi_flash.h
  • SPIM_ERASE_TIMEOUT : at32f413_flash.h
  • SPIM_FLASH_BASE : at32f413.h
  • SPIM_PROGRAMMING_TIMEOUT : at32f413_flash.h
  • SPIM_SECTOR_SIZE : operate_spim.h
  • SPIM_TEST_ADDR : operate_spim.h
  • SPK_BUFFER_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • SPK_TX_FIFO_SIZE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • SRAM_BASE : at32f413.h
  • SRAM_SIZE : utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
  • STEP_DELAY_MS : at32f413_board.c
  • STREAM_BUFFER_SIZE : project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
  • SWAPBYTE : usb_std.h
  • SWJTAG_CONF_001 : at32f413_gpio.h
  • SWJTAG_CONF_010 : at32f413_gpio.h
  • SWJTAG_CONF_100 : at32f413_gpio.h
  • SWJTAG_GMUX_001 : at32f413_gpio.h
  • SWJTAG_GMUX_010 : at32f413_gpio.h
  • SWJTAG_GMUX_100 : at32f413_gpio.h


AT32F413 Firmwary Library: Globals

- t -

  • T0_PROTOCOL : project/at_start_f413/examples/usart/smartcard/src/main.c
  • TEST_BUFEER_SIZE : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • TEST_FLASH_ADDRESS_START : project/at_start_f413/examples/flash/flash_write_read/src/main.c
  • TEST_LENGTH_SAMPLES : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c, utilities/at32f413_slib_demo/project_l0/src/main.c, utilities/at32f413_slib_demo/project_l1/src/main.c
  • TEST_SLIB_PSW : utilities/at32f413_slib_demo/project_l0/src/main.c
  • TMR1 : at32f413_tmr.h
  • TMR10 : at32f413_tmr.h
  • TMR10_BASE : at32f413.h
  • TMR10_GMUX : at32f413_gpio.h
  • TMR11 : at32f413_tmr.h
  • TMR11_BASE : at32f413.h
  • TMR11_GMUX : at32f413_gpio.h
  • TMR1_BASE : at32f413.h
  • TMR1_C1DT_ADDRESS : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR1_C2DT_ADDRESS : project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
  • TMR1_GMUX_0001 : at32f413_gpio.h
  • TMR1_MUX_01 : at32f413_gpio.h
  • TMR2 : at32f413_tmr.h
  • TMR2_BASE : at32f413.h
  • TMR2_GMUX_001 : at32f413_gpio.h
  • TMR2_GMUX_010 : at32f413_gpio.h
  • TMR2_GMUX_011 : at32f413_gpio.h
  • TMR2_MUX_01 : at32f413_gpio.h
  • TMR2_MUX_10 : at32f413_gpio.h
  • TMR2_MUX_11 : at32f413_gpio.h
  • TMR2ITR1_GMUX : at32f413_gpio.h
  • TMR3 : at32f413_tmr.h
  • TMR3_BASE : at32f413.h
  • TMR3_GMUX_0010 : at32f413_gpio.h
  • TMR3_GMUX_0011 : at32f413_gpio.h
  • TMR3_MUX_10 : at32f413_gpio.h
  • TMR3_MUX_11 : at32f413_gpio.h
  • TMR4 : at32f413_tmr.h
  • TMR4_BASE : at32f413.h
  • TMR5 : at32f413_tmr.h
  • TMR5_BASE : at32f413.h
  • TMR5_GMUX_001 : at32f413_gpio.h
  • TMR5CH4_GMUX : at32f413_gpio.h
  • TMR5CH4_MUX : at32f413_gpio.h
  • TMR8 : at32f413_tmr.h
  • TMR8_BASE : at32f413.h
  • TMR9 : at32f413_tmr.h
  • TMR9_BASE : at32f413.h
  • TMR9_GMUX : at32f413_gpio.h
  • TMR_BRK_FLAG : at32f413_tmr.h
  • TMR_BRK_INT : at32f413_tmr.h
  • TMR_C1_FLAG : at32f413_tmr.h
  • TMR_C1_INT : at32f413_tmr.h
  • TMR_C1_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C2_FLAG : at32f413_tmr.h
  • TMR_C2_INT : at32f413_tmr.h
  • TMR_C2_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C3_FLAG : at32f413_tmr.h
  • TMR_C3_INT : at32f413_tmr.h
  • TMR_C3_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_C4_FLAG : at32f413_tmr.h
  • TMR_C4_INT : at32f413_tmr.h
  • TMR_C4_RECAPTURE_FLAG : at32f413_tmr.h
  • TMR_HALL_FLAG : at32f413_tmr.h
  • TMR_HALL_INT : at32f413_tmr.h
  • TMR_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • TMR_OVF_FLAG : at32f413_tmr.h
  • TMR_OVF_INT : at32f413_tmr.h
  • TMR_TRIGGER_FLAG : at32f413_tmr.h
  • TMR_TRIGGER_INT : at32f413_tmr.h


AT32F413 Firmwary Library: Globals

- u -

  • UART4 : at32f413_usart.h
  • UART4_BASE : at32f413.h
  • UART4_GMUX_0001 : at32f413_gpio.h
  • UART5 : at32f413_usart.h
  • UART5_BASE : at32f413.h
  • UP_MOVE : mouse_class.h
  • USART1 : at32f413_usart.h
  • USART1_BASE : at32f413.h
  • USART1_GMUX_0001 : at32f413_gpio.h
  • USART1_MUX : at32f413_gpio.h
  • USART2 : at32f413_usart.h
  • USART2_BASE : at32f413.h
  • USART2_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/synchronous/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • USART3 : at32f413_usart.h
  • USART3_BASE : at32f413.h
  • USART3_GMUX_0001 : at32f413_gpio.h
  • USART3_MUX_01 : at32f413_gpio.h
  • USART3_TX_BUFFER_SIZE : project/at_start_f413/examples/usart/half_duplex/src/main.c, project/at_start_f413/examples/usart/interrupt/src/main.c, project/at_start_f413/examples/usart/polling/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c, project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
  • USART_BF_INT : at32f413_usart.h
  • USART_BFF_FLAG : at32f413_usart.h
  • usart_buffer_size : project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
  • USART_CTSCF_FLAG : at32f413_usart.h
  • USART_CTSCF_INT : at32f413_usart.h
  • USART_ERR_INT : at32f413_usart.h
  • USART_FERR_FLAG : at32f413_usart.h
  • USART_IDLE_INT : at32f413_usart.h
  • USART_IDLEF_FLAG : at32f413_usart.h
  • USART_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • USART_NERR_FLAG : at32f413_usart.h
  • USART_PERR_FLAG : at32f413_usart.h
  • USART_PERR_INT : at32f413_usart.h
  • USART_RDBF_FLAG : at32f413_usart.h
  • USART_RDBF_INT : at32f413_usart.h
  • USART_REC_LEN : bootloader/inc/usart.h
  • USART_ROERR_FLAG : at32f413_usart.h
  • USART_TDBE_FLAG : at32f413_usart.h
  • USART_TDBE_INT : at32f413_usart.h
  • USART_TDC_FLAG : at32f413_usart.h
  • USART_TDC_INT : at32f413_usart.h
  • USB : at32f413_usb.h
  • USB_BE_FLAG : at32f413_usb.h
  • USB_BE_INT : at32f413_usb.h
  • USB_BUFFER_SIZE_EX : project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h
  • USB_BUFFER_TABLE_ADDRESS : at32f413_usb.h
  • USB_CLASS_CODE_AUDIO : usb_std.h
  • USB_CLASS_CODE_CCID : usb_std.h
  • USB_CLASS_CODE_CDC : usb_std.h
  • USB_CLASS_CODE_CDCDATA : usb_std.h
  • USB_CLASS_CODE_HID : usb_std.h
  • USB_CLASS_CODE_HUB : usb_std.h
  • USB_CLASS_CODE_MSC : usb_std.h
  • USB_CLASS_CODE_PRINTER : usb_std.h
  • USB_CLASS_CODE_VENDOR : usb_std.h
  • USB_CLASS_CODE_VIDEO : usb_std.h
  • USB_CLEAR_EPT_DOUBLE_BUFFER : at32f413_usb.h
  • USB_CLEAR_EXF : at32f413_usb.h
  • USB_CLEAR_RXDTS : at32f413_usb.h
  • USB_CLEAR_RXTC : at32f413_usb.h
  • USB_CLEAR_TXDTS : at32f413_usb.h
  • USB_CLEAR_TXTC : at32f413_usb.h
  • USB_CONF_REMOTE_WAKEUP : usb_std.h
  • USB_CONF_SELF_POWERED : usb_std.h
  • USB_CONFIG_STRING : usb_std.h
  • USB_DBUF0_GET_LEN : at32f413_usb.h
  • USB_DBUF1_GET_LEN : at32f413_usb.h
  • USB_DESCIPTOR_TYPE_CONFIGURATION : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE : usb_std.h
  • USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER : usb_std.h
  • USB_DESCIPTOR_TYPE_ENDPOINT : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE : usb_std.h
  • USB_DESCIPTOR_TYPE_INTERFACE_POWER : usb_std.h
  • USB_DESCIPTOR_TYPE_OTHER_SPEED : usb_std.h
  • USB_DESCIPTOR_TYPE_STRING : usb_std.h
  • USB_DEVICE_CFG_DESC_LEN : usb_std.h
  • USB_DEVICE_DESC_LEN : usb_std.h
  • USB_DEVICE_EPT_LEN : usb_std.h
  • USB_DEVICE_IF_DESC_LEN : usb_std.h
  • USB_DEVICE_LANGID_STR_DESC_LEN : usb_std.h
  • USB_DEVICE_OTG_DESC_LEN : usb_std.h
  • USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN : usb_std.h
  • USB_DEVICE_QUALIFIER_DESC_LEN : usb_std.h
  • USB_ENDP_DESC_TABLE_OFFSET : at32f413_usb.c
  • USB_EPT0_DATA_IN : usb_std.h
  • USB_EPT0_DATA_OUT : usb_std.h
  • USB_EPT0_IDLE : usb_std.h
  • USB_EPT0_SETUP : usb_std.h
  • USB_EPT0_STALL : usb_std.h
  • USB_EPT0_STATUS_IN : usb_std.h
  • USB_EPT0_STATUS_OUT : usb_std.h
  • USB_EPT_AUTO_MALLOC_BUFFER : project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h, project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h, project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
  • USB_EPT_BIT_MASK : at32f413_usb.h
  • USB_EPT_BULK : at32f413_usb.h
  • USB_EPT_CONTROL : at32f413_usb.h
  • USB_EPT_DESC_BULK : usb_std.h
  • USB_EPT_DESC_CONTROL : usb_std.h
  • USB_EPT_DESC_DATA_EPT : usb_std.h
  • USB_EPT_DESC_FD_EPT : usb_std.h
  • USB_EPT_DESC_FDDATA_EPT : usb_std.h
  • USB_EPT_DESC_INTERRUPT : usb_std.h
  • USB_EPT_DESC_ISO : usb_std.h
  • USB_EPT_DESC_NSYNC : usb_std.h
  • USB_EPT_INT : at32f413_usb.h
  • USB_EPT_ISO : at32f413_usb.h
  • USB_EPT_NUM_FLAG : at32f413_usb.h
  • USB_EPTADDR : at32f413_usb.h
  • USB_ETP_DESC_ADAPTIVE : usb_std.h
  • USB_ETP_DESC_ASYNC : usb_std.h
  • USB_ETP_DESC_SYNC : usb_std.h
  • USB_EXF : at32f413_usb.h
  • USB_FEATURE_EPT_HALT : usb_std.h
  • USB_FEATURE_REMOTE_WAKEUP : usb_std.h
  • USB_FEATURE_TEST_MODE : usb_std.h
  • USB_FLASH_ADDR_OFFSET : composite_vcp_msc/inc/msc_diskio.h, msc/inc/msc_diskio.h, virtual_msc_iap/inc/msc_diskio.h
  • USB_FREE_DB_USER_BUFFER : at32f413_usb.h
  • USB_GET_RX_LEN : at32f413_usb.h
  • USB_GET_TX_LEN : at32f413_usb.h
  • USB_INOUT_FLAG : at32f413_usb.h
  • USB_INTERFACE_ASSOCIATION_TYPE : cdc_msc_desc.c
  • USB_INTERFACE_STRING : usb_std.h
  • USB_LANGID_STRING : usb_std.h
  • USB_LOW_POWER_WAKUP : project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h
  • USB_LSOF_FLAG : at32f413_usb.h
  • USB_LSOF_INT : at32f413_usb.h
  • USB_MAX_EP0_SIZE : usb_std.h
  • USB_MFC_STRING : usb_std.h
  • USB_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • USB_OUT_EPT_DOUBLE_BUF0 : at32f413_usb.h
  • USB_PACKET_BUFFER_ADDRESS : at32f413_usb.h
  • USB_PACKET_BUFFER_ADDRESS_EX : at32f413_usb.h
  • USB_PRODUCT_STRING : usb_std.h
  • USB_REQ_DIR_DTH : usb_std.h
  • USB_REQ_DIR_HTD : usb_std.h
  • USB_REQ_RECIPIENT_DEVICE : usb_std.h
  • USB_REQ_RECIPIENT_ENDPOINT : usb_std.h
  • USB_REQ_RECIPIENT_INTERFACE : usb_std.h
  • USB_REQ_RECIPIENT_MASK : usb_std.h
  • USB_REQ_RECIPIENT_OTHER : usb_std.h
  • USB_REQ_TYPE_CLASS : usb_std.h
  • USB_REQ_TYPE_RESERVED : usb_std.h
  • USB_REQ_TYPE_STANDARD : usb_std.h
  • USB_REQ_TYPE_VENDOR : usb_std.h
  • USB_RST_FLAG : at32f413_usb.h
  • USB_RST_INT : at32f413_usb.h
  • USB_RX_DISABLE : at32f413_usb.h
  • USB_RX_MASK : at32f413_usb.h
  • USB_RX_NAK : at32f413_usb.h
  • USB_RX_STALL : at32f413_usb.h
  • USB_RX_VALID : at32f413_usb.h
  • USB_RXDTS : at32f413_usb.h
  • USB_RXDTS0 : at32f413_usb.h
  • USB_RXDTS1 : at32f413_usb.h
  • USB_RXSTS : at32f413_usb.h
  • USB_RXTC : at32f413_usb.h
  • USB_SERIAL_STRING : usb_std.h
  • USB_SET_DOUBLE_BUFF0_ADDRESS : at32f413_usb.h
  • USB_SET_DOUBLE_BUFF1_ADDRESS : at32f413_usb.h
  • USB_SET_EPT_ADDRESS : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUF0_LEN : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUF1_LEN : at32f413_usb.h
  • USB_SET_EPT_DOUBLE_BUFFER : at32f413_usb.h
  • USB_SET_EXF : at32f413_usb.h
  • USB_SET_RX_ADDRESS : at32f413_usb.h
  • USB_SET_RXLEN : at32f413_usb.h
  • USB_SET_RXLEN_REG : at32f413_usb.h
  • USB_SET_RXSTS : at32f413_usb.h
  • USB_SET_TRANS_TYPE : at32f413_usb.h
  • USB_SET_TX_ADDRESS : at32f413_usb.h
  • USB_SET_TXLEN : at32f413_usb.h
  • USB_SET_TXSTS : at32f413_usb.h
  • USB_SETUPTC : at32f413_usb.h
  • USB_SOF_FLAG : at32f413_usb.h
  • USB_SOF_INT : at32f413_usb.h
  • USB_SP_FLAG : at32f413_usb.h
  • USB_SP_INT : at32f413_usb.h
  • USB_STD_REQ_CLEAR_FEATURE : usb_std.h
  • USB_STD_REQ_GET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_GET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_GET_INTERFACE : usb_std.h
  • USB_STD_REQ_GET_STATUS : usb_std.h
  • USB_STD_REQ_SET_ADDRESS : usb_std.h
  • USB_STD_REQ_SET_CONFIGURATION : usb_std.h
  • USB_STD_REQ_SET_DESCRIPTOR : usb_std.h
  • USB_STD_REQ_SET_FEATURE : usb_std.h
  • USB_STD_REQ_SET_INTERFACE : usb_std.h
  • USB_STD_REQ_SYNCH_FRAME : usb_std.h
  • USB_TC_FLAG : at32f413_usb.h
  • USB_TC_INT : at32f413_usb.h
  • USB_TOGGLE_RXDTS : at32f413_usb.h
  • USB_TOGGLE_TXDTS : at32f413_usb.h
  • USB_TRANS_TYPE : at32f413_usb.h
  • USB_TX_DISABLE : at32f413_usb.h
  • USB_TX_MASK : at32f413_usb.h
  • USB_TX_NAK : at32f413_usb.h
  • USB_TX_STALL : at32f413_usb.h
  • USB_TX_VALID : at32f413_usb.h
  • USB_TXDTS : at32f413_usb.h
  • USB_TXDTS0 : at32f413_usb.h
  • USB_TXDTS1 : at32f413_usb.h
  • USB_TXSTS : at32f413_usb.h
  • USB_TXTC : at32f413_usb.h
  • USB_UCFOR_FLAG : at32f413_usb.h
  • USB_UCFOR_INT : at32f413_usb.h
  • USB_VIRTUAL_COMPORT : project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
  • USB_WK_FLAG : at32f413_usb.h
  • USB_WK_INT : at32f413_usb.h
  • USBD_AUDIO_CONFIG_DESC_SIZE : audio_desc.h
  • USBD_AUDIO_DESC_CONFIGURATION_STRING : audio_desc.h
  • USBD_AUDIO_DESC_INTERFACE_STRING : audio_desc.h
  • USBD_AUDIO_DESC_MANUFACTURER_STRING : audio_desc.h
  • USBD_AUDIO_DESC_PRODUCT_STRING : audio_desc.h
  • USBD_AUDIO_FEEDBACK_EPT : audio_class.h
  • USBD_AUDIO_MIC_IN_EPT : audio_class.h
  • USBD_AUDIO_PRODUCT_ID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_LANGID : audio_desc.h
  • USBD_AUDIO_SIZ_STRING_SERIAL : audio_desc.h
  • USBD_AUDIO_SPK_OUT_EPT : audio_class.h
  • USBD_AUDIO_VENDOR_ID : audio_desc.h
  • USBD_AUHID_AUDIO_FEEDBACK_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_MIC_IN_EPT : audio_hid_class.h
  • USBD_AUHID_AUDIO_SPK_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_CONFIG_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_DESC_CONFIGURATION_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_INTERFACE_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_MANUFACTURER_STRING : audio_hid_desc.h
  • USBD_AUHID_DESC_PRODUCT_STRING : audio_hid_desc.h
  • USBD_AUHID_HID_DESC_SIZE : audio_hid_desc.h
  • USBD_AUHID_HID_IN_EPT : audio_hid_class.h
  • USBD_AUHID_HID_OUT_EPT : audio_hid_class.h
  • USBD_AUHID_HID_SIZ_REPORT_DESC : audio_hid_desc.h
  • USBD_AUHID_IN_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_OUT_MAXPACKET_SIZE : audio_hid_class.h
  • USBD_AUHID_PRODUCT_ID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_LANGID : audio_hid_desc.h
  • USBD_AUHID_SIZ_STRING_SERIAL : audio_hid_desc.h
  • USBD_AUHID_VENDOR_ID : audio_hid_desc.h
  • USBD_CDC_BULK_IN_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_BULK_OUT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CMD_MAXPACKET_SIZE : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_CONFIG_DESC_SIZE : cdc_desc.h
  • USBD_CDC_CS_ENDPOINT : usb_std.h
  • USBD_CDC_CS_INTERFACE : usb_std.h
  • USBD_CDC_DESC_CONFIGURATION_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_INTERFACE_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_MANUFACTURER_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_DESC_PRODUCT_STRING : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_IN_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_INT_EPT : cdc_class.h, cdc_msc_class.h
  • USBD_CDC_MSC_CONFIG_DESC_SIZE : cdc_msc_desc.h
  • USBD_CDC_MSC_IN_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_OUT_MAXPACKET_SIZE : cdc_msc_class.h
  • USBD_CDC_MSC_PRODUCT_ID : cdc_msc_desc.h
  • USBD_CDC_MSC_VENDOR_ID : cdc_msc_desc.h
  • USBD_CDC_OUT_MAXPACKET_SIZE : cdc_class.h
  • USBD_CDC_PRODUCT_ID : cdc_desc.h
  • USBD_CDC_SIZ_STRING_LANGID : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SIZ_STRING_SERIAL : cdc_desc.h, cdc_msc_desc.h
  • USBD_CDC_SUBTYPE_ACM : usb_std.h
  • USBD_CDC_SUBTYPE_CMF : usb_std.h
  • USBD_CDC_SUBTYPE_HEADER : usb_std.h
  • USBD_CDC_SUBTYPE_UFD : usb_std.h
  • USBD_CDC_VENDOR_ID : cdc_desc.h
  • USBD_CUSHID_CONFIG_DESC_SIZE : custom_hid_desc.h
  • USBD_CUSHID_DESC_CONFIGURATION_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_INTERFACE_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_MANUFACTURER_STRING : custom_hid_desc.h
  • USBD_CUSHID_DESC_PRODUCT_STRING : custom_hid_desc.h
  • USBD_CUSHID_PRODUCT_ID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_REPORT_DESC : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_LANGID : custom_hid_desc.h
  • USBD_CUSHID_SIZ_STRING_SERIAL : custom_hid_desc.h
  • USBD_CUSHID_VENDOR_ID : custom_hid_desc.h
  • USBD_CUSTOM_HID_IN_EPT : custom_hid_class.h
  • USBD_CUSTOM_HID_OUT_EPT : custom_hid_class.h
  • USBD_CUSTOM_IN_MAXPACKET_SIZE : custom_hid_class.h
  • USBD_CUSTOM_OUT_MAXPACKET_SIZE : custom_hid_class.h
  • USBD_HIDIAP_CONFIG_DESC_SIZE : hid_iap_desc.h
  • USBD_HIDIAP_DESC_CONFIGURATION_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_INTERFACE_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_MANUFACTURER_STRING : hid_iap_desc.h
  • USBD_HIDIAP_DESC_PRODUCT_STRING : hid_iap_desc.h
  • USBD_HIDIAP_IN_EPT : hid_iap_class.h
  • USBD_HIDIAP_IN_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_OUT_EPT : hid_iap_class.h
  • USBD_HIDIAP_OUT_MAXPACKET_SIZE : hid_iap_class.h
  • USBD_HIDIAP_PRODUCT_ID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_REPORT_DESC : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_LANGID : hid_iap_desc.h
  • USBD_HIDIAP_SIZ_STRING_SERIAL : hid_iap_desc.h
  • USBD_HIDIAP_VENDOR_ID : hid_iap_desc.h
  • USBD_IN_MAXPACKET_SIZE : msc_class.h
  • USBD_KEYBOARD_CONFIG_DESC_SIZE : keyboard_desc.h
  • USBD_KEYBOARD_DESC_CONFIGURATION_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_INTERFACE_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_MANUFACTURER_STRING : keyboard_desc.h
  • USBD_KEYBOARD_DESC_PRODUCT_STRING : keyboard_desc.h
  • USBD_KEYBOARD_IN_EPT : keyboard_class.h
  • USBD_KEYBOARD_IN_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_OUT_MAXPACKET_SIZE : keyboard_class.h
  • USBD_KEYBOARD_PRODUCT_ID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_REPORT_DESC : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_LANGID : keyboard_desc.h
  • USBD_KEYBOARD_SIZ_STRING_SERIAL : keyboard_desc.h
  • USBD_KEYBOARD_VENDOR_ID : keyboard_desc.h
  • USBD_MOUSE_CONFIG_DESC_SIZE : mouse_desc.h
  • USBD_MOUSE_DESC_CONFIGURATION_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_INTERFACE_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_MANUFACTURER_STRING : mouse_desc.h
  • USBD_MOUSE_DESC_PRODUCT_STRING : mouse_desc.h
  • USBD_MOUSE_IN_EPT : mouse_class.h
  • USBD_MOUSE_IN_MAXPACKET_SIZE : mouse_class.h
  • USBD_MOUSE_PRODUCT_ID : mouse_desc.h
  • USBD_MOUSE_SIZ_REPORT_DESC : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_LANGID : mouse_desc.h
  • USBD_MOUSE_SIZ_STRING_SERIAL : mouse_desc.h
  • USBD_MOUSE_VENDOR_ID : mouse_desc.h
  • USBD_MSC_BULK_IN_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_BULK_OUT_EPT : cdc_msc_class.h, msc_class.h
  • USBD_MSC_CONFIG_DESC_SIZE : msc_desc.h
  • USBD_MSC_DESC_CONFIGURATION_STRING : msc_desc.h
  • USBD_MSC_DESC_INTERFACE_STRING : msc_desc.h
  • USBD_MSC_DESC_MANUFACTURER_STRING : msc_desc.h
  • USBD_MSC_DESC_PRODUCT_STRING : msc_desc.h
  • USBD_MSC_PRODUCT_ID : msc_desc.h
  • USBD_MSC_SIZ_STRING_LANGID : msc_desc.h
  • USBD_MSC_SIZ_STRING_SERIAL : msc_desc.h
  • USBD_MSC_VENDOR_ID : msc_desc.h
  • USBD_OUT_MAXPACKET_SIZE : msc_class.h
  • USBD_PRINTER_BULK_IN_EPT : printer_class.h
  • USBD_PRINTER_BULK_OUT_EPT : printer_class.h
  • USBD_PRINTER_CONFIG_DESC_SIZE : printer_desc.h
  • USBD_PRINTER_DESC_CONFIGURATION_STRING : printer_desc.h
  • USBD_PRINTER_DESC_INTERFACE_STRING : printer_desc.h
  • USBD_PRINTER_DESC_MANUFACTURER_STRING : printer_desc.h
  • USBD_PRINTER_DESC_PRODUCT_STRING : printer_desc.h
  • USBD_PRINTER_IN_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_OUT_MAXPACKET_SIZE : printer_class.h
  • USBD_PRINTER_PRODUCT_ID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_LANGID : printer_desc.h
  • USBD_PRINTER_SIZ_STRING_SERIAL : printer_desc.h
  • USBD_PRINTER_VENDOR_ID : printer_desc.h
  • USBD_VCPKYBRD_CDC_BULK_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_BULK_OUT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CDC_INT_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CMD_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_CONFIG_DESC_SIZE : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_CONFIGURATION_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_INTERFACE_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_MANUFACTURER_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_DESC_PRODUCT_STRING : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_HID_IN_EPT : cdc_keyboard_class.h
  • USBD_VCPKYBRD_HID_SIZ_REPORT_DESC : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_IN_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_OUT_MAXPACKET_SIZE : cdc_keyboard_class.h
  • USBD_VCPKYBRD_PRODUCT_ID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_LANGID : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_SIZ_STRING_SERIAL : cdc_keyboard_desc.h
  • USBD_VCPKYBRD_VENDOR_ID : cdc_keyboard_desc.h
  • USBFS_BASE : at32f413.h
  • USD : at32f413_flash.h
  • USD_BASE : at32f413.h
  • USD_DEPSLP_NO_RST : at32f413_flash.h
  • USD_DEPSLP_RST : at32f413_flash.h
  • USD_STDBY_NO_RST : at32f413_flash.h
  • USD_STDBY_RST : at32f413_flash.h
  • USD_WDT_ATO_DISABLE : at32f413_flash.h
  • USD_WDT_ATO_ENABLE : at32f413_flash.h
  • USE_SLIB_FUNCTION : utilities/at32f413_slib_demo/project_l0/src/main.c
  • USE_STATIC_INIT : project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
  • USER_BUTTON_CRM_CLK : at32f413_board.h
  • USER_BUTTON_PIN : at32f413_board.h
  • USER_BUTTON_PORT : at32f413_board.h


AT32F413 Firmwary Library: Globals

- v -

  • VARIABLES_GET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_RESET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VARIABLES_SET_BIT : project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
  • VCPKYBRD_BCD_NUM : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_DATA_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_CDC_INTERFACE : cdc_keyboard_desc.h
  • VCPKYBRD_HID_BINTERVAL_TIME : cdc_keyboard_desc.h
  • VCPKYBRD_KEYBOARD_INTERFACE : cdc_keyboard_desc.h
  • VCPMSC_CDC_DATA_INTERFACE : cdc_msc_desc.h
  • VCPMSC_CDC_INTERFACE : cdc_msc_desc.h
  • VCPMSC_MSC_INTERFACE : cdc_msc_desc.h
  • VECT_TAB_OFFSET : system_at32f413.c
  • vPortSVCHandler : FreeRTOSConfig.h


AT32F413 Firmwary Library: Globals

- w -

  • W25Q128 : spi_flash.h
  • W25Q16 : spi_flash.h
  • W25Q32 : spi_flash.h
  • W25Q64 : spi_flash.h
  • W25Q80 : spi_flash.h
  • WDT : at32f413_wdt.h
  • WDT_BASE : at32f413.h
  • WDT_DIVF_UPDATE_FLAG : at32f413_wdt.h
  • WDT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
  • WDT_RLDF_UPDATE_FLAG : at32f413_wdt.h
  • WM8988_I2C_ADDR_CSB_HIGH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_I2C_ADDR_CSB_LOW : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R0_LEFT_INPUT_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R10_LEFT_DAC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R11_RIGHT_DAC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R12_BASS_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R13_TREBLE_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R14_ : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R15_RESET : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R16_3D_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R17_ALC1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R18_ALC2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R19_ALC3 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R1_RIGHT_INPUT_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R20_NOISE_GATE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R21_LEFT_ADC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R22_RIGHT_ADC_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R23_ADDITIONAL_1_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R24_ADDITIONAL_2_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R25_PWR_1_MGMT : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R26_PWR_2_MGMT : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R27_ADDITIONAL_3_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R2_LOUT1_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R31_ADC_INPUT_MODE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R32_ADC_L_SIGNAL_PATH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R33_ADC_R_SIGNAL_PATH : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R34_LEFT_OUT_MIX_1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R35_LEFT_OUT_MIX_2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R36_RIGHT_OUT_MIX_1 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R37_RIGHT_OUT_MIX_2 : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R38_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R39_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R3_ROUT1_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R40_LOUT2_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R41_ROUT2_VOLUME : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R42_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R43_LOW_POWER_PALYBACK : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R4_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R5_ADC_DAC_CONTROL : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R6_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R7_AUDIO_INTERFACE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R8_SAMPLE_RATE : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_R9_RESERVED : audio/inc/audio_codec.h, composite_audio_hid/inc/audio_codec.h
  • WM8988_REG_BITW16 : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ16K : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WM8988_REG_FREQ48K : audio/src/audio_codec.c, composite_audio_hid/src/audio_codec.c
  • WWDT : at32f413_wwdt.h
  • WWDT_BASE : at32f413.h
  • WWDT_EN_BIT : at32f413_wwdt.h
  • WWDT_MODULE_ENABLED : project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h, project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h, project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h, project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h, project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h, project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h, project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h, project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h, project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h, project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h, project/at_start_f413/examples/can/filter/inc/at32f413_conf.h, project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h, project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h, project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h, project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h, project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h, project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h, project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h, project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h, project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h, project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h, project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h, project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h, project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h, project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h, project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h, project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h, project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h, project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h, project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h, project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h, project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h, project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h, project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h, project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h, project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h, project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h, project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h, project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h, project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h, project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h, project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h, project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h, project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h, project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h, project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h, project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h, project/at_start_f413/templates/inc/at32f413_conf.h, utilities/at32f413_freertos_demo/inc/at32f413_conf.h, utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h, utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h, utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h


AT32F413 Firmwary Library: Globals

- x -

  • XMC_REG_BASE : at32f413.h
  • xPortPendSVHandler : FreeRTOSConfig.h
  • xPortSysTickHandler : FreeRTOSConfig.h


AT32F413 Firmwary Library: Globals

- z -

  • ZOOM : project/at_start_f413/examples/cortex_m4/fpu/src/main.c


AT32F413 Firmwary Library: FreeRTOSConfig.h Source File

  • utilities
  • at32f413_freertos_demo
  • inc
FreeRTOSConfig.h
Go to the documentation of this file.
1/*
2 FreeRTOS V8.2.3 - Copyright (C) 2015 Real Time Engineers Ltd.
3 All rights reserved
4
5 VISIT http://www.FreeRTOS.org TO ENSURE YOU ARE USING THE LATEST VERSION.
6
7 This file is part of the FreeRTOS distribution.
8
9 FreeRTOS is free software; you can redistribute it and/or modify it under
10 the terms of the GNU General Public License (version 2) as published by the
11 Free Software Foundation >>>> AND MODIFIED BY <<<< the FreeRTOS exception.
12
13 ***************************************************************************
14 >>! NOTE: The modification to the GPL is included to allow you to !<<
15 >>! distribute a combined work that includes FreeRTOS without being !<<
16 >>! obliged to provide the source code for proprietary components !<<
17 >>! outside of the FreeRTOS kernel. !<<
18 ***************************************************************************
19
20 FreeRTOS is distributed in the hope that it will be useful, but WITHOUT ANY
21 WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
22 FOR A PARTICULAR PURPOSE. Full license text is available on the following
23 link: http://www.freertos.org/a00114.html
24
25 ***************************************************************************
26 * *
27 * FreeRTOS provides completely free yet professionally developed, *
28 * robust, strictly quality controlled, supported, and cross *
29 * platform software that is more than just the market leader, it *
30 * is the industry's de facto standard. *
31 * *
32 * Help yourself get started quickly while simultaneously helping *
33 * to support the FreeRTOS project by purchasing a FreeRTOS *
34 * tutorial book, reference manual, or both: *
35 * http://www.FreeRTOS.org/Documentation *
36 * *
37 ***************************************************************************
38
39 http://www.FreeRTOS.org/FAQHelp.html - Having a problem? Start by reading
40 the FAQ page "My application does not run, what could be wrong?". Have you
41 defined configASSERT()?
42
43 http://www.FreeRTOS.org/support - In return for receiving this top quality
44 embedded software for free we request you assist our global community by
45 participating in the support forum.
46
47 http://www.FreeRTOS.org/training - Investing in training allows your team to
48 be as productive as possible as early as possible. Now you can receive
49 FreeRTOS training directly from Richard Barry, CEO of Real Time Engineers
50 Ltd, and the world's leading authority on the world's leading RTOS.
51
52 http://www.FreeRTOS.org/plus - A selection of FreeRTOS ecosystem products,
53 including FreeRTOS+Trace - an indispensable productivity tool, a DOS
54 compatible FAT file system, and our tiny thread aware UDP/IP stack.
55
56 http://www.FreeRTOS.org/labs - Where new FreeRTOS products go to incubate.
57 Come and try FreeRTOS+TCP, our new open source TCP/IP stack for FreeRTOS.
58
59 http://www.OpenRTOS.com - Real Time Engineers ltd. license FreeRTOS to High
60 Integrity Systems ltd. to sell under the OpenRTOS brand. Low cost OpenRTOS
61 licenses offer ticketed support, indemnification and commercial middleware.
62
63 http://www.SafeRTOS.com - High Integrity Systems also provide a safety
64 engineered and independently SIL3 certified version for use in safety and
65 mission critical applications that require provable dependability.
66
67 1 tab == 4 spaces!
68 * Copyright notice & Disclaimer
69 *
70 * The software Board Support Package (BSP) that is made available to
71 * download from Artery official website is the copyrighted work of Artery.
72 * Artery authorizes customers to use, copy, and distribute the BSP
73 * software and its related documentation for the purpose of design and
74 * development in conjunction with Artery microcontrollers. Use of the
75 * software is governed by this copyright notice and the following disclaimer.
76 *
77 * THIS SOFTWARE IS PROVIDED ON "AS IS" BASIS WITHOUT WARRANTIES,
78 * GUARANTEES OR REPRESENTATIONS OF ANY KIND. ARTERY EXPRESSLY DISCLAIMS,
79 * TO THE FULLEST EXTENT PERMITTED BY LAW, ALL EXPRESS, IMPLIED OR
80 * STATUTORY OR OTHER WARRANTIES, GUARANTEES OR REPRESENTATIONS,
81 * INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
82 * FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.
83 *
84 **************************************************************************
85*/
86
87#ifndef FREERTOS_CONFIG_H
88#define FREERTOS_CONFIG_H
89
90#ifdef __cplusplus
91 extern "C" {
92#endif
93
94#if defined(__ICCARM__) || defined(__CC_ARM) || defined(__GNUC__)
95 #include <stdint.h>
96 static uint32_t systemcoreclock = 192000000;
97#endif
98
99
100
101/*-----------------------------------------------------------
102 * Application specific definitions.
103 *
104 * These definitions should be adjusted for your particular hardware and
105 * application requirements.
106 *
107 * THESE PARAMETERS ARE DESCRIBED WITHIN THE 'CONFIGURATION' SECTION OF THE
108 * FreeRTOS API DOCUMENTATION AVAILABLE ON THE FreeRTOS.org WEB SITE.
109 *
110 * See http://www.freertos.org/a00110.html.
111 *----------------------------------------------------------*/
112#define configUSE_PREEMPTION 1
113#define configUSE_IDLE_HOOK 0
114#define configUSE_TICK_HOOK 0
115#define configCPU_CLOCK_HZ ( ( unsigned long ) systemcoreclock )
116#define configTICK_RATE_HZ ( ( TickType_t ) 1000 )
117#define configMAX_PRIORITIES ( 5 )
118#define configMINIMAL_STACK_SIZE ( ( unsigned short ) 128 )
119#define configSUPPORT_DYNAMIC_ALLOCATION 1
120#define configTOTAL_HEAP_SIZE ( ( size_t ) ( 8 * 1024 ) )
121#define configMAX_TASK_NAME_LEN ( 16 )
122#define configUSE_16_BIT_TICKS 0
123#define configIDLE_SHOULD_YIELD 1
124
125
126/* Co-routine definitions. */
127#define configUSE_CO_ROUTINES 0
128#define configMAX_CO_ROUTINE_PRIORITIES ( 2 )
129
130/* Set the following definitions to 1 to include the API function, or zero
131to exclude the API function. */
132
133#define INCLUDE_vTaskPrioritySet 1
134#define INCLUDE_uxTaskPriorityGet 1
135#define INCLUDE_vTaskDelete 1
136#define INCLUDE_vTaskCleanUpResources 0
137#define INCLUDE_vTaskSuspend 1
138#define INCLUDE_vTaskDelayUntil 1
139#define INCLUDE_vTaskDelay 1
140#define INCLUDE_xTaskGetCurrentTaskHandle 1
141/* Cortex-M specific definitions. */
142#ifdef __NVIC_PRIO_BITS
143 /* __BVIC_PRIO_BITS will be specified when CMSIS is being used. */
144 #define configPRIO_BITS __NVIC_PRIO_BITS
145#else
146 #define configPRIO_BITS 4 /* 15 priority levels */
147#endif
148
149/* The lowest interrupt priority that can be used in a call to a "set priority"
150function. */
151#define configLIBRARY_LOWEST_INTERRUPT_PRIORITY 0x0f
152
153/* The highest interrupt priority that can be used by any interrupt service
154routine that makes calls to interrupt safe FreeRTOS API functions. DO NOT CALL
155INTERRUPT SAFE FREERTOS API FUNCTIONS FROM ANY INTERRUPT THAT HAS A HIGHER
156PRIORITY THAN THIS! (higher priorities are lower numeric values. */
157#define configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY 0x01
158
159/* Interrupt priorities used by the kernel port layer itself. These are generic
160to all Cortex-M ports, and do not rely on any particular library functions. */
161#define configKERNEL_INTERRUPT_PRIORITY ( configLIBRARY_LOWEST_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
162/* !!!! configMAX_SYSCALL_INTERRUPT_PRIORITY must not be set to zero !!!!
163See http://www.FreeRTOS.org/RTOS-Cortex-M3-M4.html. */
164#define configMAX_SYSCALL_INTERRUPT_PRIORITY ( configLIBRARY_MAX_SYSCALL_INTERRUPT_PRIORITY << (8 - configPRIO_BITS) )
165
166/* Normal assert() semantics without relying on the provision of an assert.h
167header file. */
168#define configASSERT( x ) if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }
169
170/* Definitions that map the FreeRTOS port interrupt handlers to their CMSIS
171standard names. */
172#define vPortSVCHandler SVC_Handler
173#define xPortPendSVHandler PendSV_Handler
174#define xPortSysTickHandler SysTick_Handler
175
176#ifdef __cplusplus
177 }
178#endif
179
180#endif /* FREERTOS_CONFIG_H */
181


AT32F413 Firmwary Library: hid_iap_user.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/hid_iap_user.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_USER_H
29#define __HID_IAP_USER_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "hid_iap_class.h"
36
49#define FLASH_APP_ADDRESS 0x08004000
50
59void iap_init(void);
60 iap_result_type iap_get_upgrade_flag(void);
61void app_loop(void);
62
75#ifdef __cplusplus
76}
77#endif
78
79#endif
80
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:79
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:253
hid_iap_class.h
usb hid iap header file


AT32F413 Firmwary Library: iap.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/iap.h
Go to the documentation of this file.
1
27#ifndef __IAP_H__
28#define __IAP_H__
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
48/* app starting address */
49#define APP_START_ADDR 0x08004000
50
51/* the previous sector of app starting address is iap upgrade flag */
52#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
53
54/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
55indicates that an app upgrade will follow, see iap application note for more details */
56#define IAP_UPGRADE_FLAG 0x41544B38
57
66void iap_command_handle(void);
67void iap_init(void);
68
81#ifdef __cplusplus
82}
83#endif
84
85#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:44


AT32F413 Firmwary Library: tmr.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/tmr.h
Go to the documentation of this file.
1
27#ifndef __TMR_H
28#define __TMR_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
48void tmr_init(void);
49
62#ifdef __cplusplus
63}
64#endif
65
66#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:44


AT32F413 Firmwary Library: usart.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
app_led3_toggle/inc/usart.h
Go to the documentation of this file.
1
27#ifndef __USART_H
28#define __USART_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
36extern uint8_t iap_flag;
37
50#define IAP_REV_FLAG_NO 0
51#define IAP_REV_FLAG_5A 1
52#define IAP_REV_FLAG_DONE 2
53#define IAP_REV_FLAG_ERROR 3
54
63void uart_init(uint32_t baudrate);
64void back_ok(void);
65void back_err(void);
66
79#ifdef __cplusplus
80}
81#endif
82
83#endif
84
85
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:120
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:107


AT32F413 Firmwary Library: hid_iap_user.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/hid_iap_user.c
Go to the documentation of this file.
1
27#include "hid_iap_user.h"
28#include "hid_iap_class.h"
29#include "string.h"
30
39void (*pftarget)(void);
40void iap_clear_upgrade_flag(void);
41void iap_set_upgrade_flag(void);
42uint32_t crc_cal(uint32_t addr, uint16_t nk);
43
44void iap_idle(void);
45void iap_start(void);
46void iap_finish(void);
47void iap_jump(void);
48void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result);
49
55void iap_clear_upgrade_flag(void)
56{
57 flash_unlock();
58 flash_sector_erase(iap_info.flag_address);
59 flash_lock();
60}
61
67void iap_set_upgrade_flag(void)
68{
69 flash_unlock();
70 flash_word_program(iap_info.flag_address, IAP_UPGRADE_COMPLETE_FLAG);
71 flash_lock();
72}
73
79 iap_result_type iap_get_upgrade_flag(void)
80{
81 uint32_t flag_address = iap_info.flag_address;
82 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
83 {
84 return IAP_SUCCESS;
85 }
86 else
87 {
88 return IAP_FAILED;
89 }
90}
91
97void iap_init(void)
98{
99 iap_info.flash_size = KB_TO_B(FLASH_SIZE_REG());
100 if(iap_info.flash_size < KB_TO_B(256))
101 {
102 iap_info.sector_size = SECTOR_SIZE_1K;
103 }
104 else
105 {
106 iap_info.sector_size = SECTOR_SIZE_2K;
107 }
108
109 iap_info.flash_start_address = FLASH_BASE;
110 iap_info.flash_end_address = iap_info.flash_start_address + iap_info.flash_size;
111
112 iap_info.app_address = FLASH_APP_ADDRESS;
113 iap_info.flag_address = iap_info.app_address - iap_info.sector_size;
114
115 iap_info.fifo_length = 0;
116 iap_info.iap_address = 0;
117}
118
124void iap_idle(void)
125{
126 iap_info.state = IAP_STS_JMP_WAIT;
127 iap_init();
128 iap_respond(iap_info.iap_tx, IAP_CMD_IDLE, IAP_ACK);
129}
130
136void iap_start(void)
137{
138 iap_info.state = IAP_STS_START;
139 iap_init();
140 iap_respond(iap_info.iap_tx, IAP_CMD_START, IAP_ACK);
141}
142
143/*
144 * @brief iap jump
145 * @param none
146 * @retval none
147 */
148void iap_jump()
149{
150 iap_info.state = IAP_STS_JMP_WAIT;
151 iap_respond(iap_info.iap_tx, IAP_CMD_JMP, IAP_ACK);
152}
153
154/*
155 * @brief iap get
156 * @param none
157 * @retval none
158 */
159void iap_get()
160{
161 iap_respond(iap_info.iap_tx, IAP_CMD_GET, IAP_ACK);
162 iap_info.iap_tx[4] = (uint8_t)((iap_info.app_address >> 24) & 0xFF);
163 iap_info.iap_tx[5] = (uint8_t)((iap_info.app_address >> 16) & 0xFF);
164 iap_info.iap_tx[6] = (uint8_t)((iap_info.app_address >> 8) & 0xFF);
165 iap_info.iap_tx[7] = (uint8_t)((iap_info.app_address) & 0xFF);
166}
167
168
169
170/*
171 * @brief iap respond
172 * @param res_buf: data buffer pointer.
173 * @param iap_cmd: iap command
174 * @param result: iap result
175 * @retval the result of the address parse
176 */
177void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
178{
179 res_buf[0] = (uint8_t)((iap_cmd >> 8) & 0xFF);
180 res_buf[1] = (uint8_t)((iap_cmd) & 0xFF);
181 res_buf[2] = (uint8_t)((result >> 8) & 0xFF);
182 res_buf[3] = (uint8_t)((result) & 0xFF);
183
184 iap_info.respond_flag = 1;
185}
186
194 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
195{
196 iap_result_type status = IAP_SUCCESS;
197 uint16_t iap_cmd;
198
199 if(len < 2)
200 {
201 return IAP_FAILED;
202 }
203
204 iap_info.respond_flag = 0;
205
206 iap_cmd = (pdata[0] << 8) | pdata[1];
207
208 switch(iap_cmd)
209 {
210 case IAP_CMD_IDLE:
211 iap_idle();
212 break;
213 case IAP_CMD_START:
214 iap_start();
215 break;
216 case IAP_CMD_JMP:
217 iap_jump();
218 break;
219 case IAP_CMD_GET:
220 iap_get();
221 break;
222 default:
223 status = IAP_FAILED;
224 break;
225 }
226
227 if(iap_info.respond_flag)
228 {
229 usb_iap_class_send_report(udev, iap_info.iap_tx, 64);
230 }
231
232 return status;
233}
234
240void usbd_hid_iap_in_complete(void *udev)
241{
242 if(iap_info.state == IAP_STS_JMP_WAIT)
243 {
244 iap_info.state = IAP_STS_JMP;
245 }
246}
247
253void app_loop(void)
254{
255 if(iap_info.state == IAP_STS_JMP)
256 {
257 iap_clear_upgrade_flag();
258 nvic_system_reset();
259 }
260}
261
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:52
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:291
iap_set_upgrade_flag
void iap_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:67
iap_idle
void iap_idle(void)
iap idle function
Definition: app_led3_toggle/src/hid_iap_user.c:124
iap_respond
void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
Definition: app_led3_toggle/src/hid_iap_user.c:177
iap_init
void iap_init(void)
iap init
Definition: app_led3_toggle/src/hid_iap_user.c:97
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
usb device iap function
Definition: app_led3_toggle/src/hid_iap_user.c:194
crc_cal
uint32_t crc_cal(uint32_t addr, uint16_t nk)
crc cal
Definition: bootloader/src/hid_iap_user.c:155
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:79
iap_finish
void iap_finish(void)
Definition: bootloader/src/hid_iap_user.c:315
iap_start
void iap_start(void)
iap start function
Definition: app_led3_toggle/src/hid_iap_user.c:136
pftarget
void(* pftarget)(void)
Definition: app_led3_toggle/src/hid_iap_user.c:39
iap_clear_upgrade_flag
void iap_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: app_led3_toggle/src/hid_iap_user.c:55
iap_get
void iap_get()
Definition: app_led3_toggle/src/hid_iap_user.c:159
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:253
iap_jump
void iap_jump(void)
Definition: app_led3_toggle/src/hid_iap_user.c:148
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led3_toggle/src/hid_iap_user.c:240
IAP_CMD_IDLE
#define IAP_CMD_IDLE
iap command
Definition: hid_iap_class.h:68
IAP_CMD_GET
#define IAP_CMD_GET
Definition: hid_iap_class.h:75
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
IAP_ACK
#define IAP_ACK
Definition: hid_iap_class.h:82
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:78
FLASH_SIZE_REG
#define FLASH_SIZE_REG()
Definition: hid_iap_class.h:58
IAP_CMD_START
#define IAP_CMD_START
Definition: hid_iap_class.h:69
IAP_CMD_JMP
#define IAP_CMD_JMP
Definition: hid_iap_class.h:74
KB_TO_B
#define KB_TO_B(kb)
Definition: hid_iap_class.h:59
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:95
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:101
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:100
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:49
hid_iap_class.h
usb hid iap header file
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:124
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:116
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:121
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:115
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:118
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:119
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:111
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:122
iap_info_type::iap_tx
uint8_t iap_tx[0x40]
Definition: hid_iap_class.h:109
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:114
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:133


AT32F413 Firmwary Library: iap.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/iap.c
Go to the documentation of this file.
1
27#include "iap.h"
28#include "usart.h"
29#include "tmr.h"
30
44void iap_command_handle(void)
45{
46 if(iap_flag==IAP_REV_FLAG_DONE)
47 {
48 flash_unlock();
49 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
50 flash_word_program(IAP_UPGRADE_FLAG_ADDR, IAP_UPGRADE_FLAG);
51 flash_lock();
52 nvic_system_reset();
53 }
54}
55
61void iap_init(void)
62{
63 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
64 {
65 flash_unlock();
66 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
67 flash_lock();
68 }
69}
70
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:52
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:44
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: app_led3_toggle/inc/iap.h:52
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:52
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: app_led3_toggle/inc/iap.h:56


AT32F413 Firmwary Library: tmr.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/tmr.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "tmr.h"
29#include "iap.h"
30
44void tmr_init(void)
45{
46 crm_clocks_freq_type crm_clocks_freq_struct = {0};
47
48 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
49
50 /* enable the tmr3 global interrupt */
51 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
52
53 /* get system clock */
54 crm_clocks_freq_get(&crm_clocks_freq_struct);
55
56 /* time base configuration */
57 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
58 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
59
60 /* overflow interrupt enable */
61 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
62
63 /* enable tmr */
64 tmr_counter_enable(TMR3, TRUE);
65}
66
72void TMR3_GLOBAL_IRQHandler(void)
73{
74 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
75 {
76 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
77 at32_led_toggle(LED3);
78 }
79}
80
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:64
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:163
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:74
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: app_led3_toggle/src/tmr.c:72
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:44
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:473


AT32F413 Firmwary Library: usart.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
app_led3_toggle/src/usart.c
Go to the documentation of this file.
1
27#include "usart.h"
28#include "tmr.h"
29
38uint8_t iap_flag = IAP_REV_FLAG_NO;
39
45void uart_init(uint32_t baudrate)
46{
47 gpio_init_type gpio_init_struct;
48 /* enable the usart and it's io clock */
49 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
50 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
51
52 /* set default parameter */
53 gpio_default_para_init(&gpio_init_struct);
54
55 /* configure the usart1_tx pa9 */
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
58 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
59 gpio_init_struct.gpio_pins = GPIO_PINS_9;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init(GPIOA, &gpio_init_struct);
62
63 /* configure the usart1_rx pa10 */
64 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
65 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
66 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
67 gpio_init_struct.gpio_pins = GPIO_PINS_10;
68 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
69 gpio_init(GPIOA, &gpio_init_struct);
70
71 /*configure usart nvic interrupt */
72 nvic_irq_enable(USART1_IRQn, 0, 0);
73
74 /*configure usart param*/
75 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
76 usart_transmitter_enable(USART1, TRUE);
77 usart_receiver_enable(USART1, TRUE);
78 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
79 usart_enable(USART1, TRUE);
80}
81
87void USART1_IRQHandler(void)
88{
89 uint16_t reval;
90 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
91 {
92 reval = usart_data_receive(USART1);
93 if((reval == 0x5A) && (iap_flag == IAP_REV_FLAG_NO))
94 iap_flag = IAP_REV_FLAG_5A;
95 else if((reval == 0xA5) && (iap_flag == IAP_REV_FLAG_5A))
96 iap_flag = IAP_REV_FLAG_DONE;
97 else
98 iap_flag = IAP_REV_FLAG_NO;
99 }
100}
101
107void back_ok(void)
108{
109 usart_data_transmit(USART1, 0xCC);
110 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
111 usart_data_transmit(USART1, 0xDD);
112 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
113}
114
120void back_err(void)
121{
122 usart_data_transmit(USART1, 0xEE);
123 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
124 usart_data_transmit(USART1, 0xFF);
125 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
126}
127
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:120
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:171
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
USART1_IRQHandler
void USART1_IRQHandler(void)
usart1 interrupt handler.
Definition: app_led3_toggle/src/usart.c:87
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:120
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:107
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:58
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART1
#define USART1
Definition: at32f413_usart.h:319
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:52
IAP_REV_FLAG_NO
#define IAP_REV_FLAG_NO
Definition: app_led3_toggle/inc/usart.h:50
IAP_REV_FLAG_5A
#define IAP_REV_FLAG_5A
Definition: app_led3_toggle/inc/usart.h:51
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289


AT32F413 Firmwary Library: hid_iap_user.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/hid_iap_user.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_USER_H
29#define __HID_IAP_USER_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "hid_iap_class.h"
36
49#define FLASH_APP_ADDRESS 0x08004000
50
59void iap_init(void);
60 iap_result_type iap_get_upgrade_flag(void);
61void app_loop(void);
62
75#ifdef __cplusplus
76}
77#endif
78
79#endif
80
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:79
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:253
hid_iap_class.h
usb hid iap header file


AT32F413 Firmwary Library: iap.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/iap.h
Go to the documentation of this file.
1
27#ifndef __IAP_H__
28#define __IAP_H__
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
48/* app starting address */
49#define APP_START_ADDR 0x08004000
50
51/* the previous sector of app starting address is iap upgrade flag */
52#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
53
54/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
55indicates that an app upgrade will follow, see iap application note for more details */
56#define IAP_UPGRADE_FLAG 0x41544B38
57
66void iap_command_handle(void);
67void iap_init(void);
68
81#ifdef __cplusplus
82}
83#endif
84
85#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:44


AT32F413 Firmwary Library: tmr.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/tmr.h
Go to the documentation of this file.
1
27#ifndef __TMR_H
28#define __TMR_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
48void tmr_init(void);
49
62#ifdef __cplusplus
63}
64#endif
65
66#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:44


AT32F413 Firmwary Library: usart.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
app_led4_toggle/inc/usart.h
Go to the documentation of this file.
1
27#ifndef __USART_H
28#define __USART_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
36extern uint8_t iap_flag;
37
50#define IAP_REV_FLAG_NO 0
51#define IAP_REV_FLAG_5A 1
52#define IAP_REV_FLAG_DONE 2
53#define IAP_REV_FLAG_ERROR 3
54
63void uart_init(uint32_t baudrate);
64void back_ok(void);
65void back_err(void);
66
79#ifdef __cplusplus
80}
81#endif
82
83#endif
84
85
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:120
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:107


AT32F413 Firmwary Library: hid_iap_user.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/hid_iap_user.c
Go to the documentation of this file.
1
27#include "hid_iap_user.h"
28#include "hid_iap_class.h"
29#include "string.h"
30
39void (*pftarget)(void);
40void iap_clear_upgrade_flag(void);
41void iap_set_upgrade_flag(void);
42uint32_t crc_cal(uint32_t addr, uint16_t nk);
43
44void iap_idle(void);
45void iap_start(void);
46void iap_finish(void);
47void iap_jump(void);
48void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result);
49
55void iap_clear_upgrade_flag(void)
56{
57 flash_unlock();
58 flash_sector_erase(iap_info.flag_address);
59 flash_lock();
60}
61
67void iap_set_upgrade_flag(void)
68{
69 flash_unlock();
70 flash_word_program(iap_info.flag_address, IAP_UPGRADE_COMPLETE_FLAG);
71 flash_lock();
72}
73
79 iap_result_type iap_get_upgrade_flag(void)
80{
81 uint32_t flag_address = iap_info.flag_address;
82 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
83 {
84 return IAP_SUCCESS;
85 }
86 else
87 {
88 return IAP_FAILED;
89 }
90}
91
97void iap_init(void)
98{
99 iap_info.flash_size = KB_TO_B(FLASH_SIZE_REG());
100 if(iap_info.flash_size < KB_TO_B(256))
101 {
102 iap_info.sector_size = SECTOR_SIZE_1K;
103 }
104 else
105 {
106 iap_info.sector_size = SECTOR_SIZE_2K;
107 }
108
109 iap_info.flash_start_address = FLASH_BASE;
110 iap_info.flash_end_address = iap_info.flash_start_address + iap_info.flash_size;
111
112 iap_info.app_address = FLASH_APP_ADDRESS;
113 iap_info.flag_address = iap_info.app_address - iap_info.sector_size;
114
115 iap_info.fifo_length = 0;
116 iap_info.iap_address = 0;
117}
118
124void iap_idle(void)
125{
126 iap_info.state = IAP_STS_JMP_WAIT;
127 iap_init();
128 iap_respond(iap_info.iap_tx, IAP_CMD_IDLE, IAP_ACK);
129}
130
136void iap_start(void)
137{
138 iap_info.state = IAP_STS_START;
139 iap_init();
140 iap_respond(iap_info.iap_tx, IAP_CMD_START, IAP_ACK);
141}
142
143/*
144 * @brief iap jump
145 * @param none
146 * @retval none
147 */
148void iap_jump()
149{
150 iap_info.state = IAP_STS_JMP_WAIT;
151 iap_respond(iap_info.iap_tx, IAP_CMD_JMP, IAP_ACK);
152}
153
154/*
155 * @brief iap get
156 * @param none
157 * @retval none
158 */
159void iap_get()
160{
161 iap_respond(iap_info.iap_tx, IAP_CMD_GET, IAP_ACK);
162 iap_info.iap_tx[4] = (uint8_t)((iap_info.app_address >> 24) & 0xFF);
163 iap_info.iap_tx[5] = (uint8_t)((iap_info.app_address >> 16) & 0xFF);
164 iap_info.iap_tx[6] = (uint8_t)((iap_info.app_address >> 8) & 0xFF);
165 iap_info.iap_tx[7] = (uint8_t)((iap_info.app_address) & 0xFF);
166}
167
168
169
170/*
171 * @brief iap respond
172 * @param res_buf: data buffer pointer.
173 * @param iap_cmd: iap command
174 * @param result: iap result
175 * @retval the result of the address parse
176 */
177void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
178{
179 res_buf[0] = (uint8_t)((iap_cmd >> 8) & 0xFF);
180 res_buf[1] = (uint8_t)((iap_cmd) & 0xFF);
181 res_buf[2] = (uint8_t)((result >> 8) & 0xFF);
182 res_buf[3] = (uint8_t)((result) & 0xFF);
183
184 iap_info.respond_flag = 1;
185}
186
194 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
195{
196 iap_result_type status = IAP_SUCCESS;
197 uint16_t iap_cmd;
198
199 if(len < 2)
200 {
201 return IAP_FAILED;
202 }
203
204 iap_info.respond_flag = 0;
205
206 iap_cmd = (pdata[0] << 8) | pdata[1];
207
208 switch(iap_cmd)
209 {
210 case IAP_CMD_IDLE:
211 iap_idle();
212 break;
213 case IAP_CMD_START:
214 iap_start();
215 break;
216 case IAP_CMD_JMP:
217 iap_jump();
218 break;
219 case IAP_CMD_GET:
220 iap_get();
221 break;
222 default:
223 status = IAP_FAILED;
224 break;
225 }
226
227 if(iap_info.respond_flag)
228 {
229 usb_iap_class_send_report(udev, iap_info.iap_tx, 64);
230 }
231
232 return status;
233}
234
240void usbd_hid_iap_in_complete(void *udev)
241{
242 if(iap_info.state == IAP_STS_JMP_WAIT)
243 {
244 iap_info.state = IAP_STS_JMP;
245 }
246}
247
253void app_loop(void)
254{
255 if(iap_info.state == IAP_STS_JMP)
256 {
257 iap_clear_upgrade_flag();
258 nvic_system_reset();
259 }
260}
261
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:52
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:291
iap_set_upgrade_flag
void iap_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: app_led4_toggle/src/hid_iap_user.c:67
iap_idle
void iap_idle(void)
iap idle function
Definition: app_led4_toggle/src/hid_iap_user.c:124
iap_respond
void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
Definition: app_led4_toggle/src/hid_iap_user.c:177
iap_init
void iap_init(void)
iap init
Definition: app_led4_toggle/src/hid_iap_user.c:97
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
usb device iap function
Definition: app_led4_toggle/src/hid_iap_user.c:194
crc_cal
uint32_t crc_cal(uint32_t addr, uint16_t nk)
crc cal
Definition: bootloader/src/hid_iap_user.c:155
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led4_toggle/src/hid_iap_user.c:79
iap_finish
void iap_finish(void)
Definition: bootloader/src/hid_iap_user.c:315
iap_start
void iap_start(void)
iap start function
Definition: app_led4_toggle/src/hid_iap_user.c:136
pftarget
void(* pftarget)(void)
Definition: app_led4_toggle/src/hid_iap_user.c:39
iap_clear_upgrade_flag
void iap_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: app_led4_toggle/src/hid_iap_user.c:55
iap_get
void iap_get()
Definition: app_led4_toggle/src/hid_iap_user.c:159
app_loop
void app_loop(void)
iap loop
Definition: app_led4_toggle/src/hid_iap_user.c:253
iap_jump
void iap_jump(void)
Definition: app_led4_toggle/src/hid_iap_user.c:148
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led4_toggle/src/hid_iap_user.c:240
IAP_CMD_IDLE
#define IAP_CMD_IDLE
iap command
Definition: hid_iap_class.h:68
IAP_CMD_GET
#define IAP_CMD_GET
Definition: hid_iap_class.h:75
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
IAP_ACK
#define IAP_ACK
Definition: hid_iap_class.h:82
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:78
FLASH_SIZE_REG
#define FLASH_SIZE_REG()
Definition: hid_iap_class.h:58
IAP_CMD_START
#define IAP_CMD_START
Definition: hid_iap_class.h:69
IAP_CMD_JMP
#define IAP_CMD_JMP
Definition: hid_iap_class.h:74
KB_TO_B
#define KB_TO_B(kb)
Definition: hid_iap_class.h:59
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:95
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:101
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:100
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:49
hid_iap_class.h
usb hid iap header file
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:124
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:116
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:121
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:115
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:118
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:119
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:111
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:122
iap_info_type::iap_tx
uint8_t iap_tx[0x40]
Definition: hid_iap_class.h:109
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:114
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:133


AT32F413 Firmwary Library: iap.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/iap.c
Go to the documentation of this file.
1
27#include "iap.h"
28#include "usart.h"
29#include "tmr.h"
30
44void iap_command_handle(void)
45{
46 if(iap_flag==IAP_REV_FLAG_DONE)
47 {
48 flash_unlock();
49 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
50 flash_word_program(IAP_UPGRADE_FLAG_ADDR, IAP_UPGRADE_FLAG);
51 flash_lock();
52 nvic_system_reset();
53 }
54}
55
61void iap_init(void)
62{
63 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
64 {
65 flash_unlock();
66 flash_sector_erase(IAP_UPGRADE_FLAG_ADDR);
67 flash_lock();
68 }
69}
70
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:52
iap_flag
uint8_t iap_flag
Definition: app_led3_toggle/src/usart.c:38
iap_init
void iap_init(void)
iap init.
Definition: app_led4_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led4_toggle/src/iap.c:44
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: app_led3_toggle/inc/iap.h:52
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:52
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: app_led3_toggle/inc/iap.h:56


AT32F413 Firmwary Library: tmr.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/tmr.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "tmr.h"
29#include "iap.h"
30
44void tmr_init(void)
45{
46 crm_clocks_freq_type crm_clocks_freq_struct = {0};
47
48 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
49
50 /* enable the tmr3 global interrupt */
51 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
52
53 /* get system clock */
54 crm_clocks_freq_get(&crm_clocks_freq_struct);
55
56 /* time base configuration */
57 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
58 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
59
60 /* overflow interrupt enable */
61 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
62
63 /* enable tmr */
64 tmr_counter_enable(TMR3, TRUE);
65}
66
72void TMR3_GLOBAL_IRQHandler(void)
73{
74 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
75 {
76 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
77 at32_led_toggle(LED4);
78 }
79}
80
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:39
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:163
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:74
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: app_led4_toggle/src/tmr.c:72
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led4_toggle/src/tmr.c:44
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:473


AT32F413 Firmwary Library: usart.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
app_led4_toggle/src/usart.c
Go to the documentation of this file.
1
27#include "usart.h"
28#include "tmr.h"
29
38uint8_t iap_flag = IAP_REV_FLAG_NO;
39
45void uart_init(uint32_t baudrate)
46{
47 gpio_init_type gpio_init_struct;
48 /* enable the usart and it's io clock */
49 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
50 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
51
52 /* set default parameter */
53 gpio_default_para_init(&gpio_init_struct);
54
55 /* configure the usart1_tx pa9 */
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
58 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
59 gpio_init_struct.gpio_pins = GPIO_PINS_9;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init(GPIOA, &gpio_init_struct);
62
63 /* configure the usart1_rx pa10 */
64 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
65 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
66 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
67 gpio_init_struct.gpio_pins = GPIO_PINS_10;
68 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
69 gpio_init(GPIOA, &gpio_init_struct);
70
71 /*configure usart nvic interrupt */
72 nvic_irq_enable(USART1_IRQn, 0, 0);
73
74 /*configure usart param*/
75 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
76 usart_transmitter_enable(USART1, TRUE);
77 usart_receiver_enable(USART1, TRUE);
78 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
79 usart_enable(USART1, TRUE);
80}
81
87void USART1_IRQHandler(void)
88{
89 uint16_t reval;
90 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
91 {
92 reval = usart_data_receive(USART1);
93 if((reval == 0x5A) && (iap_flag == IAP_REV_FLAG_NO))
94 iap_flag = IAP_REV_FLAG_5A;
95 else if((reval == 0xA5) && (iap_flag == IAP_REV_FLAG_5A))
96 iap_flag = IAP_REV_FLAG_DONE;
97 else
98 iap_flag = IAP_REV_FLAG_NO;
99 }
100}
101
107void back_ok(void)
108{
109 usart_data_transmit(USART1, 0xCC);
110 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
111 usart_data_transmit(USART1, 0xDD);
112 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
113}
114
120void back_err(void)
121{
122 usart_data_transmit(USART1, 0xEE);
123 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
124 usart_data_transmit(USART1, 0xFF);
125 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
126}
127
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:120
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:171
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
USART1_IRQHandler
void USART1_IRQHandler(void)
usart1 interrupt handler.
Definition: app_led4_toggle/src/usart.c:87
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led4_toggle/src/usart.c:45
iap_flag
uint8_t iap_flag
Definition: app_led4_toggle/src/usart.c:38
back_err
void back_err(void)
command response error.
Definition: app_led4_toggle/src/usart.c:120
back_ok
void back_ok(void)
command response ok.
Definition: app_led4_toggle/src/usart.c:107
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:58
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART1
#define USART1
Definition: at32f413_usart.h:319
IAP_REV_FLAG_DONE
#define IAP_REV_FLAG_DONE
Definition: app_led3_toggle/inc/usart.h:52
IAP_REV_FLAG_NO
#define IAP_REV_FLAG_NO
Definition: app_led3_toggle/inc/usart.h:50
IAP_REV_FLAG_5A
#define IAP_REV_FLAG_5A
Definition: app_led3_toggle/inc/usart.h:51
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289


AT32F413 Firmwary Library: arm_fir_init_f32.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
arm_fir_init_f32.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2 * Project: CMSIS DSP Library
3 * Title: arm_fir_init_f32.c
4 * Description: Floating-point FIR filter initialization function
5 *
6 * $Date: 18. March 2019
7 * $Revision: V1.6.0
8 *
9 * Target Processor: Cortex-M cores
10 * -------------------------------------------------------------------- */
11/*
12 * Copyright (C) 2010-2019 ARM Limited or its affiliates. All rights reserved.
13 *
14 * SPDX-License-Identifier: Apache-2.0
15 *
16 * Licensed under the Apache License, Version 2.0 (the License); you may
17 * not use this file except in compliance with the License.
18 * You may obtain a copy of the License at
19 *
20 * www.apache.org/licenses/LICENSE-2.0
21 *
22 * Unless required by applicable law or agreed to in writing, software
23 * distributed under the License is distributed on an AS IS BASIS, WITHOUT
24 * WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
25 * See the License for the specific language governing permissions and
26 * limitations under the License.
27 */
28
29#include "arm_math.h"
30
31void* my_memset(void *s, int c, size_t n);
32
59void arm_fir_init_f32(
60 arm_fir_instance_f32 * S,
61 uint16_t numTaps,
62 const float32_t * pCoeffs,
63 float32_t * pState,
64 uint32_t blockSize)
65{
66 /* Assign filter taps */
67 S->numTaps = numTaps;
68
69 /* Assign coefficient pointer */
70 S->pCoeffs = pCoeffs;
71
72 /* Clear state buffer. The size is always (blockSize + numTaps - 1) */
73 my_memset(pState, 0, (numTaps + (blockSize - 1u)) * sizeof(float32_t));
74
75 /* Assign state pointer */
76 S->pState = pState;
77}
78
79void* my_memset(void *s, int c, size_t n)
80{
81 while (n>0)
82 *( (char*)s + n-- -1 ) = (char)c;
83
84 return (s);
85}
my_memset
void * my_memset(void *s, int c, size_t n)
Definition: arm_fir_init_f32.c:79
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59


AT32F413 Firmwary Library: at32f413.h Source File

  • libraries
  • cmsis
  • cm4
  • device_support
at32f413.h
Go to the documentation of this file.
1
27#ifndef __AT32F413_H
28#define __AT32F413_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#if defined (__CC_ARM)
35 #pragma anon_unions
36#endif
37
55#if !defined (AT32F413KBU7_4) && !defined (AT32F413KCU7_4) && !defined (AT32F413CBU7) && \
56 !defined (AT32F413CCU7) && !defined (AT32F413C8T7) && !defined (AT32F413CBT7) && \
57 !defined (AT32F413CCT7) && !defined (AT32F413RBT7) && !defined (AT32F413RCT7) && \
58 !defined (AT32FEBKC8T7) && !defined (AT32F413TBU7)
59
60 #error "Please select first the target device used in your application (in at32f413.h file)"
61#endif
62
63#if defined (AT32F413KBU7_4) || defined (AT32F413KCU7_4) || defined (AT32F413CBU7) || \
64 defined (AT32F413CCU7) || defined (AT32F413C8T7) || defined (AT32F413CBT7) || \
65 defined (AT32F413CCT7) || defined (AT32F413RBT7) || defined (AT32F413RCT7) || \
66 defined (AT32FEBKC8T7) || defined (AT32F413TBU7)
67
68 #define AT32F413xx
69#endif
70
71#ifndef USE_STDPERIPH_DRIVER
77 #ifdef _RTE_
78 #include "RTE_Components.h"
79 #ifdef RTE_DEVICE_STDPERIPH_FRAMEWORK
80 #define USE_STDPERIPH_DRIVER
81 #endif
82 #endif
83#endif
84
88#define __AT32F413_LIBRARY_VERSION_MAJOR (0x02)
89#define __AT32F413_LIBRARY_VERSION_MIDDLE (0x00)
90#define __AT32F413_LIBRARY_VERSION_MINOR (0x05)
91#define __AT32F413_LIBRARY_VERSION_RC (0x00)
92#define __AT32F413_LIBRARY_VERSION ((__AT32F413_LIBRARY_VERSION_MAJOR << 24) | \
93 (__AT32F413_LIBRARY_VERSION_MIDDLE << 16) | \
94 (__AT32F413_LIBRARY_VERSION_MINOR << 8) | \
95 (__AT32F413_LIBRARY_VERSION_RC))
96
108#define __CM4_REV 0x0001U
109#define __MPU_PRESENT 1
110#define __NVIC_PRIO_BITS 4
111#define __Vendor_SysTickConfig 0
112#define __FPU_PRESENT 1U
118typedef enum IRQn
119{
120 /****** cortex-m4 processor exceptions numbers ***************************************************/
121 Reset_IRQn = -15,
122 NonMaskableInt_IRQn = -14,
123 HardFault_IRQn = -13,
124 MemoryManagement_IRQn = -12,
125 BusFault_IRQn = -11,
126 UsageFault_IRQn = -10,
127 SVCall_IRQn = -5,
128 DebugMonitor_IRQn = -4,
129 PendSV_IRQn = -2,
130 SysTick_IRQn = -1,
132 /****** at32 specific interrupt numbers *********************************************************/
133 WWDT_IRQn = 0,
134 PVM_IRQn = 1,
135 TAMPER_IRQn = 2,
136 RTC_IRQn = 3,
137 FLASH_IRQn = 4,
138 CRM_IRQn = 5,
139 EXINT0_IRQn = 6,
140 EXINT1_IRQn = 7,
141 EXINT2_IRQn = 8,
142 EXINT3_IRQn = 9,
143 EXINT4_IRQn = 10,
144 DMA1_Channel1_IRQn = 11,
145 DMA1_Channel2_IRQn = 12,
146 DMA1_Channel3_IRQn = 13,
147 DMA1_Channel4_IRQn = 14,
148 DMA1_Channel5_IRQn = 15,
149 DMA1_Channel6_IRQn = 16,
150 DMA1_Channel7_IRQn = 17,
152 ADC1_2_IRQn = 18,
153 USBFS_H_CAN1_TX_IRQn = 19,
154 USBFS_L_CAN1_RX0_IRQn = 20,
155 CAN1_RX1_IRQn = 21,
156 CAN1_SE_IRQn = 22,
157 EXINT9_5_IRQn = 23,
158 TMR1_BRK_TMR9_IRQn = 24,
159 TMR1_OVF_TMR10_IRQn = 25,
160 TMR1_TRG_HALL_TMR11_IRQn = 26,
161 TMR1_CH_IRQn = 27,
162 TMR2_GLOBAL_IRQn = 28,
163 TMR3_GLOBAL_IRQn = 29,
164 TMR4_GLOBAL_IRQn = 30,
165 I2C1_EVT_IRQn = 31,
166 I2C1_ERR_IRQn = 32,
167 I2C2_EVT_IRQn = 33,
168 I2C2_ERR_IRQn = 34,
169 SPI1_IRQn = 35,
170 SPI2_IRQn = 36,
171 USART1_IRQn = 37,
172 USART2_IRQn = 38,
173 USART3_IRQn = 39,
174 EXINT15_10_IRQn = 40,
175 RTCAlarm_IRQn = 41,
176 USBFSWakeUp_IRQn = 42,
177 TMR8_BRK_IRQn = 43,
178 TMR8_OVF_IRQn = 44,
179 TMR8_TRG_HALL_IRQn = 45,
180 TMR8_CH_IRQn = 46,
181 SDIO1_IRQn = 49,
182 TMR5_GLOBAL_IRQn = 50,
183 UART4_IRQn = 52,
184 UART5_IRQn = 53,
185 DMA2_Channel1_IRQn = 56,
186 DMA2_Channel2_IRQn = 57,
187 DMA2_Channel3_IRQn = 58,
188 DMA2_Channel4_5_IRQn = 59,
189 CAN2_TX_IRQn = 68,
190 CAN2_RX0_IRQn = 69,
191 CAN2_RX1_IRQn = 70,
192 CAN2_SE_IRQn = 71,
193 ACC_IRQn = 72,
194 USBFS_MAPH_IRQn = 73,
195 USBFS_MAPL_IRQn = 74,
196 DMA2_Channel6_7_IRQn = 75,
198} IRQn_Type;
199
204#include "core_cm4.h"
205#include "system_at32f413.h"
206#include <stdint.h>
207
212typedef int32_t INT32;
213typedef int16_t INT16;
214typedef int8_t INT8;
215typedef uint32_t UINT32;
216typedef uint16_t UINT16;
217typedef uint8_t UINT8;
218
219typedef int32_t s32;
220typedef int16_t s16;
221typedef int8_t s8;
222
223typedef const int32_t sc32;
224typedef const int16_t sc16;
225typedef const int8_t sc8;
227typedef __IO int32_t vs32;
228typedef __IO int16_t vs16;
229typedef __IO int8_t vs8;
230
231typedef __I int32_t vsc32;
232typedef __I int16_t vsc16;
233typedef __I int8_t vsc8;
235typedef uint32_t u32;
236typedef uint16_t u16;
237typedef uint8_t u8;
238
239typedef const uint32_t uc32;
240typedef const uint16_t uc16;
241typedef const uint8_t uc8;
243typedef __IO uint32_t vu32;
244typedef __IO uint16_t vu16;
245typedef __IO uint8_t vu8;
246
247typedef __I uint32_t vuc32;
248typedef __I uint16_t vuc16;
249typedef __I uint8_t vuc8;
254typedef enum {RESET = 0, SET = !RESET} flag_status;
255
259typedef enum {FALSE = 0, TRUE = !FALSE} confirm_state;
260
264typedef enum {ERROR = 0, SUCCESS = !ERROR} error_status;
265
274#define REG8(addr) *(volatile uint8_t *)(addr)
275#define REG16(addr) *(volatile uint16_t *)(addr)
276#define REG32(addr) *(volatile uint32_t *)(addr)
277
278#define MAKE_VALUE(reg_offset, bit_num) (uint32_t)(((reg_offset) << 16) | (bit_num & 0x1F))
279
280#define PERIPH_REG(periph_base, value) REG32((periph_base + (value >> 16)))
281#define PERIPH_REG_BIT(value) (0x1U << (value & 0x1F))
282
291#define FLASH_BASE ((uint32_t)0x08000000)
292#define SPIM_FLASH_BASE ((uint32_t)0x08400000)
293#define USD_BASE ((uint32_t)0x1FFFF800)
294#define SRAM_BASE ((uint32_t)0x20000000)
295#define PERIPH_BASE ((uint32_t)0x40000000)
296#define XMC_REG_BASE ((uint32_t)0xA0000000)
297#define DEBUG_BASE ((uint32_t)0xE0042000)
298
299#define APB1PERIPH_BASE (PERIPH_BASE + 0x00000)
300#define APB2PERIPH_BASE (PERIPH_BASE + 0x10000)
301#define AHBPERIPH_BASE (PERIPH_BASE + 0x20000)
302
303/* apb1 bus base address */
304#define TMR2_BASE (APB1PERIPH_BASE + 0x0000)
305#define TMR3_BASE (APB1PERIPH_BASE + 0x0400)
306#define TMR4_BASE (APB1PERIPH_BASE + 0x0800)
307#define TMR5_BASE (APB1PERIPH_BASE + 0x0C00)
308#define RTC_BASE (APB1PERIPH_BASE + 0x2800)
309#define WWDT_BASE (APB1PERIPH_BASE + 0x2C00)
310#define WDT_BASE (APB1PERIPH_BASE + 0x3000)
311#define SPI2_BASE (APB1PERIPH_BASE + 0x3800)
312#define USART2_BASE (APB1PERIPH_BASE + 0x4400)
313#define USART3_BASE (APB1PERIPH_BASE + 0x4800)
314#define UART4_BASE (APB1PERIPH_BASE + 0x4C00)
315#define UART5_BASE (APB1PERIPH_BASE + 0x5000)
316#define I2C1_BASE (APB1PERIPH_BASE + 0x5400)
317#define I2C2_BASE (APB1PERIPH_BASE + 0x5800)
318#define USBFS_BASE (APB1PERIPH_BASE + 0x5C00)
319#define CAN1_BASE (APB1PERIPH_BASE + 0x6400)
320#define CAN2_BASE (APB1PERIPH_BASE + 0x6800)
321#define BPR_BASE (APB1PERIPH_BASE + 0x6C00)
322#define PWC_BASE (APB1PERIPH_BASE + 0x7000)
323/* apb2 bus base address */
324#define IOMUX_BASE (APB2PERIPH_BASE + 0x0000)
325#define EXINT_BASE (APB2PERIPH_BASE + 0x0400)
326#define GPIOA_BASE (APB2PERIPH_BASE + 0x0800)
327#define GPIOB_BASE (APB2PERIPH_BASE + 0x0C00)
328#define GPIOC_BASE (APB2PERIPH_BASE + 0x1000)
329#define GPIOD_BASE (APB2PERIPH_BASE + 0x1400)
330#define GPIOF_BASE (APB2PERIPH_BASE + 0x1C00)
331#define ADC1_BASE (APB2PERIPH_BASE + 0x2400)
332#define ADC2_BASE (APB2PERIPH_BASE + 0x2800)
333#define TMR1_BASE (APB2PERIPH_BASE + 0x2C00)
334#define SPI1_BASE (APB2PERIPH_BASE + 0x3000)
335#define TMR8_BASE (APB2PERIPH_BASE + 0x3400)
336#define USART1_BASE (APB2PERIPH_BASE + 0x3800)
337#define TMR9_BASE (APB2PERIPH_BASE + 0x4C00)
338#define TMR10_BASE (APB2PERIPH_BASE + 0x5000)
339#define TMR11_BASE (APB2PERIPH_BASE + 0x5400)
340#define ACC_BASE (APB2PERIPH_BASE + 0x5800)
341#define SDIO1_BASE (APB2PERIPH_BASE + 0x8000)
342/* ahb bus base address */
343#define DMA1_BASE (AHBPERIPH_BASE + 0x0000)
344#define DMA1_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0008)
345#define DMA1_CHANNEL2_BASE (AHBPERIPH_BASE + 0x001C)
346#define DMA1_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0030)
347#define DMA1_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0044)
348#define DMA1_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0058)
349#define DMA1_CHANNEL6_BASE (AHBPERIPH_BASE + 0x006C)
350#define DMA1_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0080)
351#define DMA2_BASE (AHBPERIPH_BASE + 0x0400)
352#define DMA2_CHANNEL1_BASE (AHBPERIPH_BASE + 0x0408)
353#define DMA2_CHANNEL2_BASE (AHBPERIPH_BASE + 0x041C)
354#define DMA2_CHANNEL3_BASE (AHBPERIPH_BASE + 0x0430)
355#define DMA2_CHANNEL4_BASE (AHBPERIPH_BASE + 0x0444)
356#define DMA2_CHANNEL5_BASE (AHBPERIPH_BASE + 0x0458)
357#define DMA2_CHANNEL6_BASE (AHBPERIPH_BASE + 0x046C)
358#define DMA2_CHANNEL7_BASE (AHBPERIPH_BASE + 0x0480)
359#define CRM_BASE (AHBPERIPH_BASE + 0x1000)
360#define FLASH_REG_BASE (AHBPERIPH_BASE + 0x2000)
361#define CRC_BASE (AHBPERIPH_BASE + 0x3000)
362
375#include "at32f413_def.h"
376#include "at32f413_conf.h"
377
378#ifdef __cplusplus
379}
380#endif
381
382#endif
at32f413_def.h
at32f413 macros header file
IRQn_Type
enum IRQn IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_secti...
IRQn
IRQn
at32f413 interrupt number definition, according to the selected device in Library_configuration_secti...
Definition: at32f413.h:119
PendSV_IRQn
@ PendSV_IRQn
Definition: at32f413.h:129
TMR1_BRK_TMR9_IRQn
@ TMR1_BRK_TMR9_IRQn
Definition: at32f413.h:158
ADC1_2_IRQn
@ ADC1_2_IRQn
Definition: at32f413.h:152
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f413.h:145
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f413.h:159
TAMPER_IRQn
@ TAMPER_IRQn
Definition: at32f413.h:135
TMR8_CH_IRQn
@ TMR8_CH_IRQn
Definition: at32f413.h:180
MemoryManagement_IRQn
@ MemoryManagement_IRQn
Definition: at32f413.h:124
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:144
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f413.h:146
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:172
DMA2_Channel6_7_IRQn
@ DMA2_Channel6_7_IRQn
Definition: at32f413.h:196
CAN2_SE_IRQn
@ CAN2_SE_IRQn
Definition: at32f413.h:192
TMR8_TRG_HALL_IRQn
@ TMR8_TRG_HALL_IRQn
Definition: at32f413.h:179
I2C1_ERR_IRQn
@ I2C1_ERR_IRQn
Definition: at32f413.h:166
SVCall_IRQn
@ SVCall_IRQn
Definition: at32f413.h:127
I2C1_EVT_IRQn
@ I2C1_EVT_IRQn
Definition: at32f413.h:165
SPI2_IRQn
@ SPI2_IRQn
Definition: at32f413.h:170
Reset_IRQn
@ Reset_IRQn
Definition: at32f413.h:121
RTCAlarm_IRQn
@ RTCAlarm_IRQn
Definition: at32f413.h:175
DMA1_Channel7_IRQn
@ DMA1_Channel7_IRQn
Definition: at32f413.h:150
UsageFault_IRQn
@ UsageFault_IRQn
Definition: at32f413.h:126
SysTick_IRQn
@ SysTick_IRQn
Definition: at32f413.h:130
EXINT9_5_IRQn
@ EXINT9_5_IRQn
Definition: at32f413.h:157
EXINT1_IRQn
@ EXINT1_IRQn
Definition: at32f413.h:140
CAN2_RX0_IRQn
@ CAN2_RX0_IRQn
Definition: at32f413.h:190
BusFault_IRQn
@ BusFault_IRQn
Definition: at32f413.h:125
WWDT_IRQn
@ WWDT_IRQn
Definition: at32f413.h:133
TMR4_GLOBAL_IRQn
@ TMR4_GLOBAL_IRQn
Definition: at32f413.h:164
USBFS_MAPL_IRQn
@ USBFS_MAPL_IRQn
Definition: at32f413.h:195
USBFSWakeUp_IRQn
@ USBFSWakeUp_IRQn
Definition: at32f413.h:176
DebugMonitor_IRQn
@ DebugMonitor_IRQn
Definition: at32f413.h:128
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:139
FLASH_IRQn
@ FLASH_IRQn
Definition: at32f413.h:137
CRM_IRQn
@ CRM_IRQn
Definition: at32f413.h:138
PVM_IRQn
@ PVM_IRQn
Definition: at32f413.h:134
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:163
SDIO1_IRQn
@ SDIO1_IRQn
Definition: at32f413.h:181
TMR5_GLOBAL_IRQn
@ TMR5_GLOBAL_IRQn
Definition: at32f413.h:182
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
EXINT3_IRQn
@ EXINT3_IRQn
Definition: at32f413.h:142
DMA1_Channel6_IRQn
@ DMA1_Channel6_IRQn
Definition: at32f413.h:149
SPI1_IRQn
@ SPI1_IRQn
Definition: at32f413.h:169
HardFault_IRQn
@ HardFault_IRQn
Definition: at32f413.h:123
CAN2_RX1_IRQn
@ CAN2_RX1_IRQn
Definition: at32f413.h:191
USBFS_H_CAN1_TX_IRQn
@ USBFS_H_CAN1_TX_IRQn
Definition: at32f413.h:153
EXINT15_10_IRQn
@ EXINT15_10_IRQn
Definition: at32f413.h:174
DMA2_Channel1_IRQn
@ DMA2_Channel1_IRQn
Definition: at32f413.h:185
DMA1_Channel5_IRQn
@ DMA1_Channel5_IRQn
Definition: at32f413.h:148
UART5_IRQn
@ UART5_IRQn
Definition: at32f413.h:184
DMA2_Channel2_IRQn
@ DMA2_Channel2_IRQn
Definition: at32f413.h:186
TMR1_TRG_HALL_TMR11_IRQn
@ TMR1_TRG_HALL_TMR11_IRQn
Definition: at32f413.h:160
TMR1_CH_IRQn
@ TMR1_CH_IRQn
Definition: at32f413.h:161
USBFS_MAPH_IRQn
@ USBFS_MAPH_IRQn
Definition: at32f413.h:194
EXINT4_IRQn
@ EXINT4_IRQn
Definition: at32f413.h:143
I2C2_ERR_IRQn
@ I2C2_ERR_IRQn
Definition: at32f413.h:168
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:171
TMR8_BRK_IRQn
@ TMR8_BRK_IRQn
Definition: at32f413.h:177
DMA2_Channel3_IRQn
@ DMA2_Channel3_IRQn
Definition: at32f413.h:187
RTC_IRQn
@ RTC_IRQn
Definition: at32f413.h:136
DMA2_Channel4_5_IRQn
@ DMA2_Channel4_5_IRQn
Definition: at32f413.h:188
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f413.h:156
NonMaskableInt_IRQn
@ NonMaskableInt_IRQn
Definition: at32f413.h:122
UART4_IRQn
@ UART4_IRQn
Definition: at32f413.h:183
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f413.h:147
EXINT2_IRQn
@ EXINT2_IRQn
Definition: at32f413.h:141
TMR8_OVF_IRQn
@ TMR8_OVF_IRQn
Definition: at32f413.h:178
I2C2_EVT_IRQn
@ I2C2_EVT_IRQn
Definition: at32f413.h:167
ACC_IRQn
@ ACC_IRQn
Definition: at32f413.h:193
CAN2_TX_IRQn
@ CAN2_TX_IRQn
Definition: at32f413.h:189
CAN1_RX1_IRQn
@ CAN1_RX1_IRQn
Definition: at32f413.h:155
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:162
USART3_IRQn
@ USART3_IRQn
Definition: at32f413.h:173
vu32
__IO uint32_t vu32
Definition: at32f413.h:243
INT8
int8_t INT8
Definition: at32f413.h:214
vs16
__IO int16_t vs16
Definition: at32f413.h:228
error_status
error_status
error status
Definition: at32f413.h:264
INT32
int32_t INT32
Definition: at32f413.h:212
vuc32
__I uint32_t vuc32
Definition: at32f413.h:247
sc8
const int8_t sc8
Definition: at32f413.h:225
vsc16
__I int16_t vsc16
Definition: at32f413.h:232
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
vsc8
__I int8_t vsc8
Definition: at32f413.h:233
vs32
__IO int32_t vs32
Definition: at32f413.h:227
vu8
__IO uint8_t vu8
Definition: at32f413.h:245
uc32
const uint32_t uc32
Definition: at32f413.h:239
sc16
const int16_t sc16
Definition: at32f413.h:224
vuc16
__I uint16_t vuc16
Definition: at32f413.h:248
flag_status
flag_status
flag status
Definition: at32f413.h:254
u8
uint8_t u8
Definition: at32f413.h:237
vu16
__IO uint16_t vu16
Definition: at32f413.h:244
s8
int8_t s8
Definition: at32f413.h:221
vs8
__IO int8_t vs8
Definition: at32f413.h:229
s16
int16_t s16
Definition: at32f413.h:220
vuc8
__I uint8_t vuc8
Definition: at32f413.h:249
uc16
const uint16_t uc16
Definition: at32f413.h:240
uc8
const uint8_t uc8
Definition: at32f413.h:241
INT16
int16_t INT16
Definition: at32f413.h:213
UINT16
uint16_t UINT16
Definition: at32f413.h:216
u16
uint16_t u16
Definition: at32f413.h:236
sc32
const int32_t sc32
Definition: at32f413.h:223
UINT32
uint32_t UINT32
Definition: at32f413.h:215
s32
int32_t s32
Definition: at32f413.h:219
vsc32
__I int32_t vsc32
Definition: at32f413.h:231
UINT8
uint8_t UINT8
Definition: at32f413.h:217
u32
uint32_t u32
Definition: at32f413.h:235
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
system_at32f413.h
cmsis cortex-m4 system header file.
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_acc.c Source File

  • libraries
  • drivers
  • src
at32f413_acc.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef ACC_MODULE_ENABLED
39
53void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
54{
55 if(acc_trim == ACC_CAL_HICKCAL)
56 {
57 ACC->ctrl1_bit.entrim = FALSE;
58 }
59 else
60 {
61 ACC->ctrl1_bit.entrim = TRUE;
62 }
63 ACC->ctrl1_bit.calon = new_state;
64}
65
71void acc_step_set(uint8_t step_value)
72{
73 ACC->ctrl1_bit.step = step_value;
74}
75
85void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
86{
87 if(acc_int == ACC_CALRDYIEN_INT)
88 {
89 ACC->ctrl1_bit.calrdyien = new_state;
90 }
91 else
92 {
93 ACC->ctrl1_bit.eien = new_state;
94 }
95}
96
102uint8_t acc_hicktrim_get(void)
103{
104 return ((uint8_t)(ACC->ctrl2_bit.hicktrim));
105}
106
112uint8_t acc_hickcal_get(void)
113{
114 return ((uint8_t)(ACC->ctrl2_bit.hickcal));
115}
116
122void acc_write_c1(uint16_t acc_c1_value)
123{
124 ACC->c1 = acc_c1_value;
125}
126
132void acc_write_c2(uint16_t acc_c2_value)
133{
134 ACC->c2 = acc_c2_value;
135}
136
142void acc_write_c3(uint16_t acc_c3_value)
143{
144 ACC->c3 = acc_c3_value;
145}
146
152uint16_t acc_read_c1(void)
153{
154 return ((uint16_t)(ACC->c1));
155}
156
162uint16_t acc_read_c2(void)
163{
164 return ((uint16_t)(ACC->c2));
165}
166
172uint16_t acc_read_c3(void)
173{
174 return ((uint16_t)(ACC->c3));
175}
176
185 flag_status acc_flag_get(uint16_t acc_flag)
186{
187 if(acc_flag == ACC_CALRDY_FLAG)
188 return (flag_status)(ACC->sts_bit.calrdy);
189 else
190 return (flag_status)(ACC->sts_bit.rslost);
191}
192
201void acc_flag_clear(uint16_t acc_flag)
202{
203 ACC->sts = ~acc_flag;
204}
205
210#endif
211
acc_c2_value
uint32_t acc_c2_value
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:58
ACC_CAL_HICKCAL
#define ACC_CAL_HICKCAL
Definition: at32f413_acc.h:52
ACC_CALRDYIEN_INT
#define ACC_CALRDYIEN_INT
Definition: at32f413_acc.h:58
ACC_CALRDY_FLAG
#define ACC_CALRDY_FLAG
Definition: at32f413_acc.h:56
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_step_set
void acc_step_set(uint8_t step_value)
store calibration step data in acc's ctrl1 register.
Definition: at32f413_acc.c:71
acc_read_c2
uint16_t acc_read_c2(void)
return the current acc c2 value.
Definition: at32f413_acc.c:162
acc_hickcal_get
uint8_t acc_hickcal_get(void)
return the current acc hickcal value.
Definition: at32f413_acc.c:112
acc_interrupt_enable
void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts.
Definition: at32f413_acc.c:85
acc_read_c3
uint16_t acc_read_c3(void)
return the current acc c3 value.
Definition: at32f413_acc.c:172
acc_read_c1
uint16_t acc_read_c1(void)
return the current acc c1 value.
Definition: at32f413_acc.c:152
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_flag_get
flag_status acc_flag_get(uint16_t acc_flag)
check whether the specified acc flag is set or not.
Definition: at32f413_acc.c:185
acc_flag_clear
void acc_flag_clear(uint16_t acc_flag)
clear the specified acc flag is set or not.
Definition: at32f413_acc.c:201
acc_hicktrim_get
uint8_t acc_hicktrim_get(void)
return the current acc hicktrim value.
Definition: at32f413_acc.c:102
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
ACC
#define ACC
Definition: at32f413_acc.h:166
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_acc.h Source File

  • libraries
  • drivers
  • inc
at32f413_acc.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_ACC_H
29#define __AT32F413_ACC_H
30
31
32#ifdef __cplusplus
33extern "C" {
34#endif
35
36
37/* Includes ------------------------------------------------------------------*/
38#include "at32f413.h"
39
52#define ACC_CAL_HICKCAL ((uint16_t)0x0000)
53#define ACC_CAL_HICKTRIM ((uint16_t)0x0002)
55#define ACC_RSLOST_FLAG ((uint16_t)0x0002)
56#define ACC_CALRDY_FLAG ((uint16_t)0x0001)
58#define ACC_CALRDYIEN_INT ((uint16_t)0x0020)
59#define ACC_EIEN_INT ((uint16_t)0x0010)
72typedef struct
73{
74
78 union
79 {
80 __IO uint32_t sts;
81 struct
82 {
83 __IO uint32_t calrdy : 1; /* [0] */
84 __IO uint32_t rslost : 1; /* [1] */
85 __IO uint32_t reserved1 : 30;/* [31:2] */
86 } sts_bit;
87 };
88
92 union
93 {
94 __IO uint32_t ctrl1;
95 struct
96 {
97 __IO uint32_t calon : 1; /* [0] */
98 __IO uint32_t entrim : 1; /* [1] */
99 __IO uint32_t reserved1 : 2; /* [3:2] */
100 __IO uint32_t eien : 1; /* [4] */
101 __IO uint32_t calrdyien : 1; /* [5] */
102 __IO uint32_t reserved2 : 2; /* [7:6] */
103 __IO uint32_t step : 4; /* [11:8] */
104 __IO uint32_t reserved3 : 20;/* [31:12] */
105 } ctrl1_bit;
106 };
107
111 union
112 {
113 __IO uint32_t ctrl2;
114 struct
115 {
116 __IO uint32_t hickcal : 8; /* [7:0] */
117 __IO uint32_t hicktrim : 6; /* [13:8] */
118 __IO uint32_t reserved1 : 18;/* [31:14] */
119 } ctrl2_bit;
120 };
121
125 union
126 {
127 __IO uint32_t c1;
128 struct
129 {
130 __IO uint32_t c1 : 16;/* [15:0] */
131 __IO uint32_t reserved1 : 16;/* [31:16] */
132 } c1_bit;
133 };
134
138 union
139 {
140 __IO uint32_t c2;
141 struct
142 {
143 __IO uint32_t c2 : 16;/* [15:0] */
144 __IO uint32_t reserved1 : 16;/* [31:16] */
145 } c2_bit;
146 };
147
151 union
152 {
153 __IO uint32_t c3;
154 struct
155 {
156 __IO uint32_t c3 : 16;/* [15:0] */
157 __IO uint32_t reserved1 : 16;/* [31:16] */
158 } c3_bit;
159 };
160} acc_type;
161
166#define ACC ((acc_type *) ACC_BASE)
167
172void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state);
173void acc_step_set(uint8_t step_value);
174void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state);
175uint8_t acc_hicktrim_get(void);
176uint8_t acc_hickcal_get(void);
177void acc_write_c1(uint16_t acc_c1_value);
178void acc_write_c2(uint16_t acc_c2_value);
179void acc_write_c3(uint16_t acc_c3_value);
180uint16_t acc_read_c1(void);
181uint16_t acc_read_c2(void);
182uint16_t acc_read_c3(void);
183 flag_status acc_flag_get(uint16_t acc_flag);
184void acc_flag_clear(uint16_t acc_flag);
185
198#ifdef __cplusplus
199}
200#endif
201
202#endif
at32f413.h
at32f413 header file
acc_c2_value
uint32_t acc_c2_value
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:58
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_step_set
void acc_step_set(uint8_t step_value)
store calibration step data in acc's ctrl1 register.
Definition: at32f413_acc.c:71
acc_read_c2
uint16_t acc_read_c2(void)
return the current acc c2 value.
Definition: at32f413_acc.c:162
acc_hickcal_get
uint8_t acc_hickcal_get(void)
return the current acc hickcal value.
Definition: at32f413_acc.c:112
acc_interrupt_enable
void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts.
Definition: at32f413_acc.c:85
acc_read_c3
uint16_t acc_read_c3(void)
return the current acc c3 value.
Definition: at32f413_acc.c:172
acc_read_c1
uint16_t acc_read_c1(void)
return the current acc c1 value.
Definition: at32f413_acc.c:152
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_flag_get
flag_status acc_flag_get(uint16_t acc_flag)
check whether the specified acc flag is set or not.
Definition: at32f413_acc.c:185
acc_flag_clear
void acc_flag_clear(uint16_t acc_flag)
clear the specified acc flag is set or not.
Definition: at32f413_acc.c:201
acc_hicktrim_get
uint8_t acc_hicktrim_get(void)
return the current acc hicktrim value.
Definition: at32f413_acc.c:102
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
acc_type
type define acc register all
Definition: at32f413_acc.h:73
acc_type::entrim
__IO uint32_t entrim
Definition: at32f413_acc.h:98
acc_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_acc.h:94
acc_type::hicktrim
__IO uint32_t hicktrim
Definition: at32f413_acc.h:117
acc_type::c2
__IO uint32_t c2
Definition: at32f413_acc.h:140
acc_type::rslost
__IO uint32_t rslost
Definition: at32f413_acc.h:84
acc_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_acc.h:102
acc_type::c3
__IO uint32_t c3
Definition: at32f413_acc.h:153
acc_type::calrdyien
__IO uint32_t calrdyien
Definition: at32f413_acc.h:101
acc_type::calon
__IO uint32_t calon
Definition: at32f413_acc.h:97
acc_type::eien
__IO uint32_t eien
Definition: at32f413_acc.h:100
acc_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_acc.h:85
acc_type::sts
__IO uint32_t sts
Definition: at32f413_acc.h:80
acc_type::hickcal
__IO uint32_t hickcal
Definition: at32f413_acc.h:116
acc_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_acc.h:113
acc_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_acc.h:104
acc_type::c1
__IO uint32_t c1
Definition: at32f413_acc.h:127
acc_type::calrdy
__IO uint32_t calrdy
Definition: at32f413_acc.h:83
acc_type::step
__IO uint32_t step
Definition: at32f413_acc.h:103


AT32F413 Firmwary Library: at32f413_adc.c Source File

  • libraries
  • drivers
  • src
at32f413_adc.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef ADC_MODULE_ENABLED
39
51void adc_reset(adc_type *adc_x)
52{
53 if(adc_x == ADC1)
54 {
55 crm_periph_reset(CRM_ADC1_PERIPH_RESET, TRUE);
56 crm_periph_reset(CRM_ADC1_PERIPH_RESET, FALSE);
57 }
58 else if(adc_x == ADC2)
59 {
60 crm_periph_reset(CRM_ADC2_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_ADC2_PERIPH_RESET, FALSE);
62 }
63}
64
75void adc_enable(adc_type *adc_x, confirm_state new_state)
76{
77 adc_x->ctrl2_bit.adcen = new_state;
78}
79
97void adc_combine_mode_select(adc_combine_mode_type combine_mode)
98{
99 ADC1->ctrl1_bit.mssel = combine_mode;
100}
101
117void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
118{
119 adc_base_struct->sequence_mode = FALSE;
120 adc_base_struct->repeat_mode = FALSE;
121 adc_base_struct->data_align = ADC_RIGHT_ALIGNMENT;
122 adc_base_struct->ordinary_channel_length = 1;
123}
124
143void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
144{
145 adc_x->ctrl1_bit.sqen = adc_base_struct->sequence_mode;
146 adc_x->ctrl2_bit.rpen = adc_base_struct->repeat_mode;
147 adc_x->ctrl2_bit.dtalign = adc_base_struct->data_align;
148 adc_x->osq1_bit.oclen = adc_base_struct->ordinary_channel_length - 1;
149}
150
161void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
162{
163 adc_x->ctrl2_bit.ocdmaen = new_state;
164}
165
180void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
181{
182 if(new_state == TRUE)
183 {
184 adc_x->ctrl1 |= adc_int;
185 }
186 else if(new_state == FALSE)
187 {
188 adc_x->ctrl1 &= ~adc_int;
189 }
190}
191
199void adc_calibration_init(adc_type *adc_x)
200{
201 adc_x->ctrl2_bit.adcalinit = TRUE;
202}
203
211 flag_status adc_calibration_init_status_get(adc_type *adc_x)
212{
213 if(adc_x->ctrl2_bit.adcalinit)
214 {
215 return SET;
216 }
217 else
218 {
219 return RESET;
220 }
221}
222
230void adc_calibration_start(adc_type *adc_x)
231{
232 adc_x->ctrl2_bit.adcal = TRUE;
233}
234
242 flag_status adc_calibration_status_get(adc_type *adc_x)
243{
244 if(adc_x->ctrl2_bit.adcal)
245 {
246 return SET;
247 }
248 else
249 {
250 return RESET;
251 }
252}
253
270void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
271{
272 adc_x->ctrl1_bit.ocvmen = FALSE;
273 adc_x->ctrl1_bit.pcvmen = FALSE;
274 adc_x->ctrl1_bit.vmsgen = FALSE;
275 adc_x->ctrl1 |= adc_voltage_monitoring;
276}
277
291void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
292{
293 adc_x->vmhb_bit.vmhb = adc_high_threshold;
294 adc_x->vmlb_bit.vmlb = adc_low_threshold;
295}
296
311void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
312{
313 adc_x->ctrl1_bit.vmcsel = adc_channel;
314}
315
343void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
344{
345 switch(adc_channel)
346 {
347 case ADC_CHANNEL_0:
348 adc_x->spt2_bit.cspt0 = adc_sampletime;
349 break;
350 case ADC_CHANNEL_1:
351 adc_x->spt2_bit.cspt1 = adc_sampletime;
352 break;
353 case ADC_CHANNEL_2:
354 adc_x->spt2_bit.cspt2 = adc_sampletime;
355 break;
356 case ADC_CHANNEL_3:
357 adc_x->spt2_bit.cspt3 = adc_sampletime;
358 break;
359 case ADC_CHANNEL_4:
360 adc_x->spt2_bit.cspt4 = adc_sampletime;
361 break;
362 case ADC_CHANNEL_5:
363 adc_x->spt2_bit.cspt5 = adc_sampletime;
364 break;
365 case ADC_CHANNEL_6:
366 adc_x->spt2_bit.cspt6 = adc_sampletime;
367 break;
368 case ADC_CHANNEL_7:
369 adc_x->spt2_bit.cspt7 = adc_sampletime;
370 break;
371 case ADC_CHANNEL_8:
372 adc_x->spt2_bit.cspt8 = adc_sampletime;
373 break;
374 case ADC_CHANNEL_9:
375 adc_x->spt2_bit.cspt9 = adc_sampletime;
376 break;
377 case ADC_CHANNEL_10:
378 adc_x->spt1_bit.cspt10 = adc_sampletime;
379 break;
380 case ADC_CHANNEL_11:
381 adc_x->spt1_bit.cspt11 = adc_sampletime;
382 break;
383 case ADC_CHANNEL_12:
384 adc_x->spt1_bit.cspt12 = adc_sampletime;
385 break;
386 case ADC_CHANNEL_13:
387 adc_x->spt1_bit.cspt13 = adc_sampletime;
388 break;
389 case ADC_CHANNEL_14:
390 adc_x->spt1_bit.cspt14 = adc_sampletime;
391 break;
392 case ADC_CHANNEL_15:
393 adc_x->spt1_bit.cspt15 = adc_sampletime;
394 break;
395 case ADC_CHANNEL_16:
396 adc_x->spt1_bit.cspt16 = adc_sampletime;
397 break;
398 case ADC_CHANNEL_17:
399 adc_x->spt1_bit.cspt17 = adc_sampletime;
400 break;
401 default:
402 break;
403 }
404 switch(adc_sequence)
405 {
406 case 1:
407 adc_x->osq3_bit.osn1 = adc_channel;
408 break;
409 case 2:
410 adc_x->osq3_bit.osn2 = adc_channel;
411 break;
412 case 3:
413 adc_x->osq3_bit.osn3 = adc_channel;
414 break;
415 case 4:
416 adc_x->osq3_bit.osn4 = adc_channel;
417 break;
418 case 5:
419 adc_x->osq3_bit.osn5 = adc_channel;
420 break;
421 case 6:
422 adc_x->osq3_bit.osn6 = adc_channel;
423 break;
424 case 7:
425 adc_x->osq2_bit.osn7 = adc_channel;
426 break;
427 case 8:
428 adc_x->osq2_bit.osn8 = adc_channel;
429 break;
430 case 9:
431 adc_x->osq2_bit.osn9 = adc_channel;
432 break;
433 case 10:
434 adc_x->osq2_bit.osn10 = adc_channel;
435 break;
436 case 11:
437 adc_x->osq2_bit.osn11 = adc_channel;
438 break;
439 case 12:
440 adc_x->osq2_bit.osn12 = adc_channel;
441 break;
442 case 13:
443 adc_x->osq1_bit.osn13 = adc_channel;
444 break;
445 case 14:
446 adc_x->osq1_bit.osn14 = adc_channel;
447 break;
448 case 15:
449 adc_x->osq1_bit.osn15 = adc_channel;
450 break;
451 case 16:
452 adc_x->osq1_bit.osn16 = adc_channel;
453 break;
454 default:
455 break;
456 }
457}
458
469void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
470{
471 adc_x->psq_bit.pclen = adc_channel_lenght - 1;
472}
473
501void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
502{
503 uint16_t sequence_index=0;
504 switch(adc_channel)
505 {
506 case ADC_CHANNEL_0:
507 adc_x->spt2_bit.cspt0 = adc_sampletime;
508 break;
509 case ADC_CHANNEL_1:
510 adc_x->spt2_bit.cspt1 = adc_sampletime;
511 break;
512 case ADC_CHANNEL_2:
513 adc_x->spt2_bit.cspt2 = adc_sampletime;
514 break;
515 case ADC_CHANNEL_3:
516 adc_x->spt2_bit.cspt3 = adc_sampletime;
517 break;
518 case ADC_CHANNEL_4:
519 adc_x->spt2_bit.cspt4 = adc_sampletime;
520 break;
521 case ADC_CHANNEL_5:
522 adc_x->spt2_bit.cspt5 = adc_sampletime;
523 break;
524 case ADC_CHANNEL_6:
525 adc_x->spt2_bit.cspt6 = adc_sampletime;
526 break;
527 case ADC_CHANNEL_7:
528 adc_x->spt2_bit.cspt7 = adc_sampletime;
529 break;
530 case ADC_CHANNEL_8:
531 adc_x->spt2_bit.cspt8 = adc_sampletime;
532 break;
533 case ADC_CHANNEL_9:
534 adc_x->spt2_bit.cspt9 = adc_sampletime;
535 break;
536 case ADC_CHANNEL_10:
537 adc_x->spt1_bit.cspt10 = adc_sampletime;
538 break;
539 case ADC_CHANNEL_11:
540 adc_x->spt1_bit.cspt11 = adc_sampletime;
541 break;
542 case ADC_CHANNEL_12:
543 adc_x->spt1_bit.cspt12 = adc_sampletime;
544 break;
545 case ADC_CHANNEL_13:
546 adc_x->spt1_bit.cspt13 = adc_sampletime;
547 break;
548 case ADC_CHANNEL_14:
549 adc_x->spt1_bit.cspt14 = adc_sampletime;
550 break;
551 case ADC_CHANNEL_15:
552 adc_x->spt1_bit.cspt15 = adc_sampletime;
553 break;
554 case ADC_CHANNEL_16:
555 adc_x->spt1_bit.cspt16 = adc_sampletime;
556 break;
557 case ADC_CHANNEL_17:
558 adc_x->spt1_bit.cspt17 = adc_sampletime;
559 break;
560 default:
561 break;
562 }
563 sequence_index = adc_sequence + 3 - adc_x->psq_bit.pclen;
564 switch(sequence_index)
565 {
566 case 1:
567 adc_x->psq_bit.psn1 = adc_channel;
568 break;
569 case 2:
570 adc_x->psq_bit.psn2 = adc_channel;
571 break;
572 case 3:
573 adc_x->psq_bit.psn3 = adc_channel;
574 break;
575 case 4:
576 adc_x->psq_bit.psn4 = adc_channel;
577 break;
578 default:
579 break;
580 }
581}
582
599void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
600{
601 if(adc_ordinary_trig > 7)
602 {
603 adc_x->ctrl2_bit.octesel_h = 1;
604 adc_x->ctrl2_bit.octesel_l = adc_ordinary_trig & 0x7;
605 }
606 else
607 {
608 adc_x->ctrl2_bit.octesel_h = 0;
609 adc_x->ctrl2_bit.octesel_l = adc_ordinary_trig & 0x7;
610 }
611 adc_x->ctrl2_bit.octen = new_state;
612}
613
630void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
631{
632 if(adc_preempt_trig > 7)
633 {
634 adc_x->ctrl2_bit.pctesel_h = 1;
635 adc_x->ctrl2_bit.pctesel_l = adc_preempt_trig & 0x7;
636 }
637 else
638 {
639 adc_x->ctrl2_bit.pctesel_h = 0;
640 adc_x->ctrl2_bit.pctesel_l = adc_preempt_trig & 0x7;
641 }
642 adc_x->ctrl2_bit.pcten = new_state;
643}
644
645
662void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
663{
664 switch(adc_preempt_channel)
665 {
666 case ADC_PREEMPT_CHANNEL_1:
667 adc_x->pcdto1_bit.pcdto1 = adc_offset_value;
668 break;
669 case ADC_PREEMPT_CHANNEL_2:
670 adc_x->pcdto2_bit.pcdto2 = adc_offset_value;
671 break;
672 case ADC_PREEMPT_CHANNEL_3:
673 adc_x->pcdto3_bit.pcdto3 = adc_offset_value;
674 break;
675 case ADC_PREEMPT_CHANNEL_4:
676 adc_x->pcdto4_bit.pcdto4 = adc_offset_value;
677 break;
678 default:
679 break;
680 }
681}
682
693void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
694{
695
696 adc_x->ctrl1_bit.ocpcnt = adc_channel_count - 1;
697}
698
708void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
709{
710 adc_x->ctrl1_bit.ocpen = new_state;
711}
712
722void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state)
723{
724 adc_x->ctrl1_bit.pcpen = new_state;
725}
726
736void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
737{
738 adc_x->ctrl1_bit.pcautoen = new_state;
739}
740
748void adc_tempersensor_vintrv_enable(confirm_state new_state)
749{
750 ADC1->ctrl2_bit.itsrven = new_state;
751}
752
762void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
763{
764 adc_x->ctrl2_bit.ocswtrg = new_state;
765}
766
774 flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x)
775{
776 if(adc_x->ctrl2_bit.ocswtrg)
777 {
778 return SET;
779 }
780 else
781 {
782 return RESET;
783 }
784}
785
795void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
796{
797 adc_x->ctrl2_bit.pcswtrg = new_state;
798}
799
807 flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x)
808{
809 if(adc_x->ctrl2_bit.pcswtrg)
810 {
811 return SET;
812 }
813 else
814 {
815 return RESET;
816 }
817}
818
826uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
827{
828 return (uint16_t)(adc_x->odt_bit.odt);
829}
830
835uint32_t adc_combine_ordinary_conversion_data_get(void)
836{
837 return (uint32_t)(ADC1->odt);
838}
839
853uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
854{
855 uint16_t preempt_conv_data_index = 0;
856 switch(adc_preempt_channel)
857 {
858 case ADC_PREEMPT_CHANNEL_1:
859 preempt_conv_data_index = (uint16_t)(adc_x->pdt1_bit.pdt1);
860 break;
861 case ADC_PREEMPT_CHANNEL_2:
862 preempt_conv_data_index = (uint16_t)(adc_x->pdt2_bit.pdt2);
863 break;
864 case ADC_PREEMPT_CHANNEL_3:
865 preempt_conv_data_index = (uint16_t)(adc_x->pdt3_bit.pdt3);
866 break;
867 case ADC_PREEMPT_CHANNEL_4:
868 preempt_conv_data_index = (uint16_t)(adc_x->pdt4_bit.pdt4);
869 break;
870 default:
871 break;
872 }
873 return preempt_conv_data_index;
874}
875
890 flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
891{
892 flag_status status = RESET;
893
894 if((adc_x->sts & adc_flag) == RESET)
895 {
896 status = RESET;
897 }
898 else
899 {
900 status = SET;
901 }
902 return status;
903}
904
919void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
920{
921 adc_x->sts = ~adc_flag;
922}
923
928#endif
929
adc_voltage_monitoring_type
adc_voltage_monitoring_type
adc voltage_monitoring type
Definition: at32f413_adc.h:198
adc_channel_select_type
adc_channel_select_type
adc channel select type
Definition: at32f413_adc.h:109
adc_sampletime_select_type
adc_sampletime_select_type
adc sampletime select type
Definition: at32f413_adc.h:134
adc_preempt_trig_select_type
adc_preempt_trig_select_type
adc preempt group trigger event select type
Definition: at32f413_adc.h:168
adc_combine_mode_type
adc_combine_mode_type
adc combine mode type(these options are reserved in adc2)
Definition: at32f413_adc.h:83
adc_ordinary_trig_select_type
adc_ordinary_trig_select_type
adc ordinary group trigger event select type
Definition: at32f413_adc.h:149
adc_preempt_channel_type
adc_preempt_channel_type
adc preempt channel type
Definition: at32f413_adc.h:187
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:101
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f413_adc.h:119
ADC_CHANNEL_1
@ ADC_CHANNEL_1
Definition: at32f413_adc.h:111
ADC_CHANNEL_17
@ ADC_CHANNEL_17
Definition: at32f413_adc.h:127
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f413_adc.h:118
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:114
ADC_CHANNEL_12
@ ADC_CHANNEL_12
Definition: at32f413_adc.h:122
ADC_CHANNEL_16
@ ADC_CHANNEL_16
Definition: at32f413_adc.h:126
ADC_CHANNEL_0
@ ADC_CHANNEL_0
Definition: at32f413_adc.h:110
ADC_CHANNEL_3
@ ADC_CHANNEL_3
Definition: at32f413_adc.h:113
ADC_CHANNEL_14
@ ADC_CHANNEL_14
Definition: at32f413_adc.h:124
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f413_adc.h:120
ADC_CHANNEL_13
@ ADC_CHANNEL_13
Definition: at32f413_adc.h:123
ADC_CHANNEL_2
@ ADC_CHANNEL_2
Definition: at32f413_adc.h:112
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:116
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f413_adc.h:117
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:115
ADC_CHANNEL_11
@ ADC_CHANNEL_11
Definition: at32f413_adc.h:121
ADC_CHANNEL_15
@ ADC_CHANNEL_15
Definition: at32f413_adc.h:125
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f413_adc.h:190
ADC_PREEMPT_CHANNEL_4
@ ADC_PREEMPT_CHANNEL_4
Definition: at32f413_adc.h:191
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f413_adc.h:189
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f413_adc.h:188
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:762
adc_voltage_monitor_enable
void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified ...
Definition: at32f413_adc.c:270
adc_voltage_monitor_single_channel_select
void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral.
Definition: at32f413_adc.c:311
adc_ordinary_conversion_data_get
uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:826
adc_preempt_offset_value_set
void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral.
Definition: at32f413_adc.c:662
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:143
adc_ordinary_software_trigger_status_get
flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral.
Definition: at32f413_adc.c:774
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f413_adc.c:736
adc_tempersensor_vintrv_enable
void adc_tempersensor_vintrv_enable(confirm_state new_state)
enable or disable the temperature sensor and vintrv channel.
Definition: at32f413_adc.c:748
adc_preempt_software_trigger_status_get
flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral.
Definition: at32f413_adc.c:807
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:75
adc_ordinary_part_count_set
void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral.
Definition: at32f413_adc.c:693
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:853
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:919
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:180
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:117
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:230
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:242
adc_voltage_monitor_threshold_value_set
void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral.
Definition: at32f413_adc.c:291
adc_preempt_part_mode_enable
void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:722
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:599
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f413_adc.c:630
adc_combine_ordinary_conversion_data_get
uint32_t adc_combine_ordinary_conversion_data_get(void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2).
Definition: at32f413_adc.c:835
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:890
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:199
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f413_adc.c:501
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:211
adc_ordinary_part_mode_enable
void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:708
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:161
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:97
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f413_adc.c:469
adc_reset
void adc_reset(adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values.
Definition: at32f413_adc.c:51
adc_preempt_software_trigger_enable
void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:795
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:343
ADC1
#define ADC1
Definition: at32f413_adc.h:559
ADC2
#define ADC2
Definition: at32f413_adc.h:560
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
CRM_ADC2_PERIPH_RESET
@ CRM_ADC2_PERIPH_RESET
Definition: at32f413_crm.h:160
CRM_ADC1_PERIPH_RESET
@ CRM_ADC1_PERIPH_RESET
Definition: at32f413_crm.h:159
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:212
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:215
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:214
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:213
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:216
adc_type
type define adc register all
Definition: at32f413_adc.h:223
adc_type::cspt1
__IO uint32_t cspt1
Definition: at32f413_adc.h:327
adc_type::dtalign
__IO uint32_t dtalign
Definition: at32f413_adc.h:283
adc_type::ocdmaen
__IO uint32_t ocdmaen
Definition: at32f413_adc.h:281
adc_type::ocswtrg
__IO uint32_t ocswtrg
Definition: at32f413_adc.h:290
adc_type::osn14
__IO uint32_t osn14
Definition: at32f413_adc.h:427
adc_type::rpen
__IO uint32_t rpen
Definition: at32f413_adc.h:277
adc_type::sqen
__IO uint32_t sqen
Definition: at32f413_adc.h:254
adc_type::pctesel_h
__IO uint32_t pctesel_h
Definition: at32f413_adc.h:292
adc_type::pdt4
__IO uint32_t pdt4
Definition: at32f413_adc.h:532
adc_type::cspt15
__IO uint32_t cspt15
Definition: at32f413_adc.h:311
adc_type::pclen
__IO uint32_t pclen
Definition: at32f413_adc.h:483
adc_type::vmcsel
__IO uint32_t vmcsel
Definition: at32f413_adc.h:250
adc_type::cspt7
__IO uint32_t cspt7
Definition: at32f413_adc.h:333
adc_type::odt
__IO uint32_t odt
Definition: at32f413_adc.h:545
adc_type::pcvmen
__IO uint32_t pcvmen
Definition: at32f413_adc.h:262
adc_type::osn1
__IO uint32_t osn1
Definition: at32f413_adc.h:461
adc_type::osq2_bit
struct adc_type::@42::@70 osq2_bit
adc_type::pcdto1_bit
struct adc_type::@28::@63 pcdto1_bit
adc_type::pcdto4
__IO uint32_t pcdto4
Definition: at32f413_adc.h:384
adc_type::pdt1
__IO uint32_t pdt1
Definition: at32f413_adc.h:493
adc_type::pcdto2
__IO uint32_t pcdto2
Definition: at32f413_adc.h:358
adc_type::cspt6
__IO uint32_t cspt6
Definition: at32f413_adc.h:332
adc_type::osn6
__IO uint32_t osn6
Definition: at32f413_adc.h:466
adc_type::osn8
__IO uint32_t osn8
Definition: at32f413_adc.h:444
adc_type::pcpen
__IO uint32_t pcpen
Definition: at32f413_adc.h:258
adc_type::osn16
__IO uint32_t osn16
Definition: at32f413_adc.h:429
adc_type::cspt13
__IO uint32_t cspt13
Definition: at32f413_adc.h:309
adc_type::vmsgen
__IO uint32_t vmsgen
Definition: at32f413_adc.h:255
adc_type::osn3
__IO uint32_t osn3
Definition: at32f413_adc.h:463
adc_type::octen
__IO uint32_t octen
Definition: at32f413_adc.h:288
adc_type::pdt2_bit
struct adc_type::@50::@74 pdt2_bit
adc_type::pcdto4_bit
struct adc_type::@34::@66 pcdto4_bit
adc_type::ocvmen
__IO uint32_t ocvmen
Definition: at32f413_adc.h:263
adc_type::oclen
__IO uint32_t oclen
Definition: at32f413_adc.h:430
adc_type::pcdto1
__IO uint32_t pcdto1
Definition: at32f413_adc.h:345
adc_type::osn9
__IO uint32_t osn9
Definition: at32f413_adc.h:445
adc_type::cspt5
__IO uint32_t cspt5
Definition: at32f413_adc.h:331
adc_type::psn4
__IO uint32_t psn4
Definition: at32f413_adc.h:482
adc_type::psq_bit
struct adc_type::@46::@72 psq_bit
adc_type::cspt12
__IO uint32_t cspt12
Definition: at32f413_adc.h:308
adc_type::adcal
__IO uint32_t adcal
Definition: at32f413_adc.h:278
adc_type::cspt14
__IO uint32_t cspt14
Definition: at32f413_adc.h:310
adc_type::octesel_l
__IO uint32_t octesel_l
Definition: at32f413_adc.h:287
adc_type::spt2_bit
struct adc_type::@26::@62 spt2_bit
adc_type::pctesel_l
__IO uint32_t pctesel_l
Definition: at32f413_adc.h:284
adc_type::odt_bit
struct adc_type::@56::@77 odt_bit
adc_type::ctrl1_bit
struct adc_type::@20::@59 ctrl1_bit
adc_type::osq1_bit
struct adc_type::@40::@69 osq1_bit
adc_type::spt1_bit
struct adc_type::@24::@61 spt1_bit
adc_type::octesel_h
__IO uint32_t octesel_h
Definition: at32f413_adc.h:293
adc_type::psn3
__IO uint32_t psn3
Definition: at32f413_adc.h:481
adc_type::osn4
__IO uint32_t osn4
Definition: at32f413_adc.h:464
adc_type::adcen
__IO uint32_t adcen
Definition: at32f413_adc.h:276
adc_type::vmhb
__IO uint32_t vmhb
Definition: at32f413_adc.h:397
adc_type::ocpen
__IO uint32_t ocpen
Definition: at32f413_adc.h:257
adc_type::cspt9
__IO uint32_t cspt9
Definition: at32f413_adc.h:335
adc_type::pdt1_bit
struct adc_type::@48::@73 pdt1_bit
adc_type::adcalinit
__IO uint32_t adcalinit
Definition: at32f413_adc.h:279
adc_type::pdt3
__IO uint32_t pdt3
Definition: at32f413_adc.h:519
adc_type::ctrl2_bit
struct adc_type::@22::@60 ctrl2_bit
adc_type::psn1
__IO uint32_t psn1
Definition: at32f413_adc.h:479
adc_type::cspt10
__IO uint32_t cspt10
Definition: at32f413_adc.h:306
adc_type::osn10
__IO uint32_t osn10
Definition: at32f413_adc.h:446
adc_type::pdt3_bit
struct adc_type::@52::@75 pdt3_bit
adc_type::osn12
__IO uint32_t osn12
Definition: at32f413_adc.h:448
adc_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_adc.h:247
adc_type::sts
__IO uint32_t sts
Definition: at32f413_adc.h:230
adc_type::pcdto2_bit
struct adc_type::@30::@64 pcdto2_bit
adc_type::cspt0
__IO uint32_t cspt0
Definition: at32f413_adc.h:326
adc_type::cspt16
__IO uint32_t cspt16
Definition: at32f413_adc.h:312
adc_type::psn2
__IO uint32_t psn2
Definition: at32f413_adc.h:480
adc_type::osn2
__IO uint32_t osn2
Definition: at32f413_adc.h:462
adc_type::osn15
__IO uint32_t osn15
Definition: at32f413_adc.h:428
adc_type::osn11
__IO uint32_t osn11
Definition: at32f413_adc.h:447
adc_type::vmlb
__IO uint32_t vmlb
Definition: at32f413_adc.h:410
adc_type::osn5
__IO uint32_t osn5
Definition: at32f413_adc.h:465
adc_type::pcdto3_bit
struct adc_type::@32::@65 pcdto3_bit
adc_type::pdt2
__IO uint32_t pdt2
Definition: at32f413_adc.h:506
adc_type::cspt4
__IO uint32_t cspt4
Definition: at32f413_adc.h:330
adc_type::ocpcnt
__IO uint32_t ocpcnt
Definition: at32f413_adc.h:259
adc_type::pdt4_bit
struct adc_type::@54::@76 pdt4_bit
adc_type::vmhb_bit
struct adc_type::@36::@67 vmhb_bit
adc_type::vmlb_bit
struct adc_type::@38::@68 vmlb_bit
adc_type::pcautoen
__IO uint32_t pcautoen
Definition: at32f413_adc.h:256
adc_type::cspt2
__IO uint32_t cspt2
Definition: at32f413_adc.h:328
adc_type::cspt17
__IO uint32_t cspt17
Definition: at32f413_adc.h:313
adc_type::cspt11
__IO uint32_t cspt11
Definition: at32f413_adc.h:307
adc_type::pcdto3
__IO uint32_t pcdto3
Definition: at32f413_adc.h:371
adc_type::cspt8
__IO uint32_t cspt8
Definition: at32f413_adc.h:334
adc_type::osn7
__IO uint32_t osn7
Definition: at32f413_adc.h:443
adc_type::pcten
__IO uint32_t pcten
Definition: at32f413_adc.h:285
adc_type::pcswtrg
__IO uint32_t pcswtrg
Definition: at32f413_adc.h:289
adc_type::osq3_bit
struct adc_type::@44::@71 osq3_bit
adc_type::osn13
__IO uint32_t osn13
Definition: at32f413_adc.h:426
adc_type::cspt3
__IO uint32_t cspt3
Definition: at32f413_adc.h:329
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_adc.h Source File

  • libraries
  • drivers
  • inc
at32f413_adc.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_ADC_H
29#define __AT32F413_ADC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define ADC_CCE_INT ((uint32_t)0x00000020)
53#define ADC_VMOR_INT ((uint32_t)0x00000040)
54#define ADC_PCCE_INT ((uint32_t)0x00000080)
65#define ADC_VMOR_FLAG ((uint8_t)0x01)
66#define ADC_CCE_FLAG ((uint8_t)0x02)
67#define ADC_PCCE_FLAG ((uint8_t)0x04)
68#define ADC_PCCS_FLAG ((uint8_t)0x08)
69#define ADC_OCCS_FLAG ((uint8_t)0x10)
82typedef enum
83{
84 ADC_INDEPENDENT_MODE = 0x00,
85 ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE = 0x01,
86 ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE = 0x02,
87 ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE = 0x03,
88 ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE = 0x04,
89 ADC_PREEMPT_SMLT_ONLY_MODE = 0x05,
90 ADC_ORDINARY_SMLT_ONLY_MODE = 0x06,
91 ADC_ORDINARY_SHORTSHIFT_ONLY_MODE = 0x07,
92 ADC_ORDINARY_LONGSHIFT_ONLY_MODE = 0x08,
93 ADC_PREEMPT_INTERLTRIG_ONLY_MODE = 0x09
94} adc_combine_mode_type;
95
99typedef enum
100{
101 ADC_RIGHT_ALIGNMENT = 0x00,
102 ADC_LEFT_ALIGNMENT = 0x01
103} adc_data_align_type;
104
108typedef enum
109{
110 ADC_CHANNEL_0 = 0x00,
111 ADC_CHANNEL_1 = 0x01,
112 ADC_CHANNEL_2 = 0x02,
113 ADC_CHANNEL_3 = 0x03,
114 ADC_CHANNEL_4 = 0x04,
115 ADC_CHANNEL_5 = 0x05,
116 ADC_CHANNEL_6 = 0x06,
117 ADC_CHANNEL_7 = 0x07,
118 ADC_CHANNEL_8 = 0x08,
119 ADC_CHANNEL_9 = 0x09,
120 ADC_CHANNEL_10 = 0x0A,
121 ADC_CHANNEL_11 = 0x0B,
122 ADC_CHANNEL_12 = 0x0C,
123 ADC_CHANNEL_13 = 0x0D,
124 ADC_CHANNEL_14 = 0x0E,
125 ADC_CHANNEL_15 = 0x0F,
126 ADC_CHANNEL_16 = 0x10,
127 ADC_CHANNEL_17 = 0x11
128} adc_channel_select_type;
129
133typedef enum
134{
135 ADC_SAMPLETIME_1_5 = 0x00,
136 ADC_SAMPLETIME_7_5 = 0x01,
137 ADC_SAMPLETIME_13_5 = 0x02,
138 ADC_SAMPLETIME_28_5 = 0x03,
139 ADC_SAMPLETIME_41_5 = 0x04,
140 ADC_SAMPLETIME_55_5 = 0x05,
141 ADC_SAMPLETIME_71_5 = 0x06,
142 ADC_SAMPLETIME_239_5 = 0x07
143} adc_sampletime_select_type;
144
148typedef enum
149{
150 /*adc1 and adc2 ordinary trigger event*/
151 ADC12_ORDINARY_TRIG_TMR1CH1 = 0x00,
152 ADC12_ORDINARY_TRIG_TMR1CH2 = 0x01,
153 ADC12_ORDINARY_TRIG_TMR1CH3 = 0x02,
154 ADC12_ORDINARY_TRIG_TMR2CH2 = 0x03,
155 ADC12_ORDINARY_TRIG_TMR3TRGOUT = 0x04,
156 ADC12_ORDINARY_TRIG_TMR4CH4 = 0x05,
157 ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT = 0x06,
158 ADC12_ORDINARY_TRIG_SOFTWARE = 0x07,
159 ADC12_ORDINARY_TRIG_TMR1TRGOUT = 0x0D,
160 ADC12_ORDINARY_TRIG_TMR8CH1 = 0x0E,
161 ADC12_ORDINARY_TRIG_TMR8CH2 = 0x0F,
162} adc_ordinary_trig_select_type;
163
167typedef enum
168{
169 /*adc1 and adc2 preempt trigger event*/
170 ADC12_PREEMPT_TRIG_TMR1TRGOUT = 0x00,
171 ADC12_PREEMPT_TRIG_TMR1CH4 = 0x01,
172 ADC12_PREEMPT_TRIG_TMR2TRGOUT = 0x02,
173 ADC12_PREEMPT_TRIG_TMR2CH1 = 0x03,
174 ADC12_PREEMPT_TRIG_TMR3CH4 = 0x04,
175 ADC12_PREEMPT_TRIG_TMR4TRGOUT = 0x05,
176 ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4 = 0x06,
177 ADC12_PREEMPT_TRIG_SOFTWARE = 0x07,
178 ADC12_PREEMPT_TRIG_TMR1CH1 = 0x0D,
179 ADC12_PREEMPT_TRIG_TMR8CH1 = 0x0E,
180 ADC12_PREEMPT_TRIG_TMR8TRGOUT = 0x0F,
181} adc_preempt_trig_select_type;
182
186typedef enum
187{
188 ADC_PREEMPT_CHANNEL_1 = 0x00,
189 ADC_PREEMPT_CHANNEL_2 = 0x01,
190 ADC_PREEMPT_CHANNEL_3 = 0x02,
191 ADC_PREEMPT_CHANNEL_4 = 0x03
192} adc_preempt_channel_type;
193
197typedef enum
198{
199 ADC_VMONITOR_SINGLE_ORDINARY = 0x00800200,
200 ADC_VMONITOR_SINGLE_PREEMPT = 0x00400200,
201 ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT = 0x00C00200,
202 ADC_VMONITOR_ALL_ORDINARY = 0x00800000,
203 ADC_VMONITOR_ALL_PREEMPT = 0x00400000,
204 ADC_VMONITOR_ALL_ORDINARY_PREEMPT = 0x00C00000,
205 ADC_VMONITOR_NONE = 0x00000000
206} adc_voltage_monitoring_type;
207
211typedef struct
212{
213 confirm_state sequence_mode;
214 confirm_state repeat_mode;
215 adc_data_align_type data_align;
216 uint8_t ordinary_channel_length;
217} adc_base_config_type;
218
222typedef struct
223{
224
228 union
229 {
230 __IO uint32_t sts;
231 struct
232 {
233 __IO uint32_t vmor : 1; /* [0] */
234 __IO uint32_t cce : 1; /* [1] */
235 __IO uint32_t pcce : 1; /* [2] */
236 __IO uint32_t pccs : 1; /* [3] */
237 __IO uint32_t occs : 1; /* [4] */
238 __IO uint32_t reserved1 : 27;/* [31:5] */
239 } sts_bit;
240 };
241
245 union
246 {
247 __IO uint32_t ctrl1;
248 struct
249 {
250 __IO uint32_t vmcsel : 5; /* [4:0] */
251 __IO uint32_t cceien : 1; /* [5] */
252 __IO uint32_t vmorien : 1; /* [6] */
253 __IO uint32_t pcceien : 1; /* [7] */
254 __IO uint32_t sqen : 1; /* [8] */
255 __IO uint32_t vmsgen : 1; /* [9] */
256 __IO uint32_t pcautoen : 1; /* [10] */
257 __IO uint32_t ocpen : 1; /* [11] */
258 __IO uint32_t pcpen : 1; /* [12] */
259 __IO uint32_t ocpcnt : 3; /* [15:13] */
260 __IO uint32_t mssel : 4; /* [19:16] */
261 __IO uint32_t reserved1 : 2; /* [21:20] */
262 __IO uint32_t pcvmen : 1; /* [22] */
263 __IO uint32_t ocvmen : 1; /* [23] */
264 __IO uint32_t reserved2 : 8; /* [31:24] */
265 } ctrl1_bit;
266 };
267
271 union
272 {
273 __IO uint32_t ctrl2;
274 struct
275 {
276 __IO uint32_t adcen : 1; /* [0] */
277 __IO uint32_t rpen : 1; /* [1] */
278 __IO uint32_t adcal : 1; /* [2] */
279 __IO uint32_t adcalinit : 1; /* [3] */
280 __IO uint32_t reserved1 : 4; /* [7:4] */
281 __IO uint32_t ocdmaen : 1; /* [8] */
282 __IO uint32_t reserved2 : 2; /* [10:9] */
283 __IO uint32_t dtalign : 1; /* [11] */
284 __IO uint32_t pctesel_l : 3; /* [14:12] */
285 __IO uint32_t pcten : 1; /* [15] */
286 __IO uint32_t reserved3 : 1; /* [16] */
287 __IO uint32_t octesel_l : 3; /* [19:17] */
288 __IO uint32_t octen : 1; /* [20] */
289 __IO uint32_t pcswtrg : 1; /* [21] */
290 __IO uint32_t ocswtrg : 1; /* [22] */
291 __IO uint32_t itsrven : 1; /* [23] */
292 __IO uint32_t pctesel_h : 1; /* [24] */
293 __IO uint32_t octesel_h : 1; /* [25] */
294 __IO uint32_t reserved4 : 6; /* [31:26] */
295 } ctrl2_bit;
296 };
297
301 union
302 {
303 __IO uint32_t spt1;
304 struct
305 {
306 __IO uint32_t cspt10 : 3; /* [2:0] */
307 __IO uint32_t cspt11 : 3; /* [5:3] */
308 __IO uint32_t cspt12 : 3; /* [8:6] */
309 __IO uint32_t cspt13 : 3; /* [11:9] */
310 __IO uint32_t cspt14 : 3; /* [14:12] */
311 __IO uint32_t cspt15 : 3; /* [17:15] */
312 __IO uint32_t cspt16 : 3; /* [20:18] */
313 __IO uint32_t cspt17 : 3; /* [23:21] */
314 __IO uint32_t reserved1 : 8;/* [31:24] */
315 } spt1_bit;
316 };
317
321 union
322 {
323 __IO uint32_t spt2;
324 struct
325 {
326 __IO uint32_t cspt0 : 3;/* [2:0] */
327 __IO uint32_t cspt1 : 3;/* [5:3] */
328 __IO uint32_t cspt2 : 3;/* [8:6] */
329 __IO uint32_t cspt3 : 3;/* [11:9] */
330 __IO uint32_t cspt4 : 3;/* [14:12] */
331 __IO uint32_t cspt5 : 3;/* [17:15] */
332 __IO uint32_t cspt6 : 3;/* [20:18] */
333 __IO uint32_t cspt7 : 3;/* [23:21] */
334 __IO uint32_t cspt8 : 3;/* [26:24] */
335 __IO uint32_t cspt9 : 3;/* [29:27] */
336 __IO uint32_t reserved1 : 2;/* [31:30] */
337 } spt2_bit;
338 };
339
343 union
344 {
345 __IO uint32_t pcdto1;
346 struct
347 {
348 __IO uint32_t pcdto1 : 12; /* [11:0] */
349 __IO uint32_t reserved1 : 20; /* [31:12] */
350 } pcdto1_bit;
351 };
352
356 union
357 {
358 __IO uint32_t pcdto2;
359 struct
360 {
361 __IO uint32_t pcdto2 : 12; /* [11:0] */
362 __IO uint32_t reserved1 : 20; /* [31:12] */
363 } pcdto2_bit;
364 };
365
369 union
370 {
371 __IO uint32_t pcdto3;
372 struct
373 {
374 __IO uint32_t pcdto3 : 12; /* [11:0] */
375 __IO uint32_t reserved1 : 20; /* [31:12] */
376 } pcdto3_bit;
377 };
378
382 union
383 {
384 __IO uint32_t pcdto4;
385 struct
386 {
387 __IO uint32_t pcdto4 : 12; /* [11:0] */
388 __IO uint32_t reserved1 : 20; /* [31:12] */
389 } pcdto4_bit;
390 };
391
395 union
396 {
397 __IO uint32_t vmhb;
398 struct
399 {
400 __IO uint32_t vmhb : 12; /* [11:0] */
401 __IO uint32_t reserved1 : 20; /* [31:12] */
402 } vmhb_bit;
403 };
404
408 union
409 {
410 __IO uint32_t vmlb;
411 struct
412 {
413 __IO uint32_t vmlb : 12; /* [11:0] */
414 __IO uint32_t reserved1 : 20; /* [31:12] */
415 } vmlb_bit;
416 };
417
421 union
422 {
423 __IO uint32_t osq1;
424 struct
425 {
426 __IO uint32_t osn13 : 5; /* [4:0] */
427 __IO uint32_t osn14 : 5; /* [9:5] */
428 __IO uint32_t osn15 : 5; /* [14:10] */
429 __IO uint32_t osn16 : 5; /* [19:15] */
430 __IO uint32_t oclen : 4; /* [23:20] */
431 __IO uint32_t reserved1 : 8; /* [31:24] */
432 } osq1_bit;
433 };
434
438 union
439 {
440 __IO uint32_t osq2;
441 struct
442 {
443 __IO uint32_t osn7 : 5; /* [4:0] */
444 __IO uint32_t osn8 : 5; /* [9:5] */
445 __IO uint32_t osn9 : 5; /* [14:10] */
446 __IO uint32_t osn10 : 5; /* [19:15] */
447 __IO uint32_t osn11 : 5; /* [24:20] */
448 __IO uint32_t osn12 : 5; /* [29:25] */
449 __IO uint32_t reserved1 : 2; /* [31:30] */
450 } osq2_bit;
451 };
452
456 union
457 {
458 __IO uint32_t osq3;
459 struct
460 {
461 __IO uint32_t osn1 : 5; /* [4:0] */
462 __IO uint32_t osn2 : 5; /* [9:5] */
463 __IO uint32_t osn3 : 5; /* [14:10] */
464 __IO uint32_t osn4 : 5; /* [19:15] */
465 __IO uint32_t osn5 : 5; /* [24:20] */
466 __IO uint32_t osn6 : 5; /* [29:25] */
467 __IO uint32_t reserved1 : 2; /* [31:30] */
468 } osq3_bit;
469 };
470
474 union
475 {
476 __IO uint32_t psq;
477 struct
478 {
479 __IO uint32_t psn1 : 5; /* [4:0] */
480 __IO uint32_t psn2 : 5; /* [9:5] */
481 __IO uint32_t psn3 : 5; /* [14:10] */
482 __IO uint32_t psn4 : 5; /* [19:15] */
483 __IO uint32_t pclen : 2; /* [21:20] */
484 __IO uint32_t reserved1 : 10;/* [31:22] */
485 } psq_bit;
486 };
487
491 union
492 {
493 __IO uint32_t pdt1;
494 struct
495 {
496 __IO uint32_t pdt1 : 16; /* [15:0] */
497 __IO uint32_t reserved1 : 16; /* [31:16] */
498 } pdt1_bit;
499 };
500
504 union
505 {
506 __IO uint32_t pdt2;
507 struct
508 {
509 __IO uint32_t pdt2 : 16; /* [15:0] */
510 __IO uint32_t reserved1 : 16; /* [31:16] */
511 } pdt2_bit;
512 };
513
517 union
518 {
519 __IO uint32_t pdt3;
520 struct
521 {
522 __IO uint32_t pdt3 : 16; /* [15:0] */
523 __IO uint32_t reserved1 : 16; /* [31:16] */
524 } pdt3_bit;
525 };
526
530 union
531 {
532 __IO uint32_t pdt4;
533 struct
534 {
535 __IO uint32_t pdt4 : 16; /* [15:0] */
536 __IO uint32_t reserved1 : 16; /* [31:16] */
537 } pdt4_bit;
538 };
539
543 union
544 {
545 __IO uint32_t odt;
546 struct
547 {
548 __IO uint32_t odt : 16; /* [15:0] */
549 __IO uint32_t adc2odt : 16; /* [31:16] */
550 } odt_bit;
551 };
552
553} adc_type;
554
559#define ADC1 ((adc_type *) ADC1_BASE)
560#define ADC2 ((adc_type *) ADC2_BASE)
561
566void adc_reset(adc_type *adc_x);
567void adc_enable(adc_type *adc_x, confirm_state new_state);
568void adc_combine_mode_select(adc_combine_mode_type combine_mode);
569void adc_base_default_para_init(adc_base_config_type *adc_base_struct);
570void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct);
571void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state);
572void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state);
573void adc_calibration_init(adc_type *adc_x);
574 flag_status adc_calibration_init_status_get(adc_type *adc_x);
575void adc_calibration_start(adc_type *adc_x);
576 flag_status adc_calibration_status_get(adc_type *adc_x);
577void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring);
578void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold);
579void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel);
580void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime);
581void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght);
582void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime);
583void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state);
584void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state);
585void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value);
586void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count);
587void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state);
588void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state);
589void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state);
590void adc_tempersensor_vintrv_enable(confirm_state new_state);
591void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state);
592 flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x);
593void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state);
594 flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x);
595uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x);
596uint32_t adc_combine_ordinary_conversion_data_get(void);
597uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel);
598 flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag);
599void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag);
600
613#ifdef __cplusplus
614}
615#endif
616
617#endif
at32f413.h
at32f413 header file
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:762
adc_voltage_monitor_enable
void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified ...
Definition: at32f413_adc.c:270
adc_voltage_monitor_single_channel_select
void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral.
Definition: at32f413_adc.c:311
adc_ordinary_conversion_data_get
uint16_t adc_ordinary_conversion_data_get(adc_type *adc_x)
return the last conversion data for ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:826
adc_preempt_offset_value_set
void adc_preempt_offset_value_set(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel, uint16_t adc_offset_value)
set preempt channel's conversion value offset of the specified adc peripheral.
Definition: at32f413_adc.c:662
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:143
adc_ordinary_software_trigger_status_get
flag_status adc_ordinary_software_trigger_status_get(adc_type *adc_x)
get ordinary software start conversion status of the specified adc peripheral.
Definition: at32f413_adc.c:774
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f413_adc.c:736
adc_tempersensor_vintrv_enable
void adc_tempersensor_vintrv_enable(confirm_state new_state)
enable or disable the temperature sensor and vintrv channel.
Definition: at32f413_adc.c:748
adc_preempt_software_trigger_status_get
flag_status adc_preempt_software_trigger_status_get(adc_type *adc_x)
get preempt software start conversion status of the specified adc peripheral.
Definition: at32f413_adc.c:807
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:75
adc_ordinary_part_count_set
void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral.
Definition: at32f413_adc.c:693
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:853
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:919
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:180
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:117
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:230
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:242
adc_voltage_monitor_threshold_value_set
void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral.
Definition: at32f413_adc.c:291
adc_preempt_part_mode_enable
void adc_preempt_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:722
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:599
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f413_adc.c:630
adc_combine_ordinary_conversion_data_get
uint32_t adc_combine_ordinary_conversion_data_get(void)
return the last conversion data for ordinary channel of combine adc(adc1 and adc2).
Definition: at32f413_adc.c:835
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:890
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:199
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f413_adc.c:501
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:211
adc_ordinary_part_mode_enable
void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:708
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:161
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:97
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f413_adc.c:469
adc_reset
void adc_reset(adc_type *adc_x)
deinitialize the adc peripheral registers to their default reset values.
Definition: at32f413_adc.c:51
adc_preempt_software_trigger_enable
void adc_preempt_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable preempt software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:795
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:343
adc_voltage_monitoring_type
adc_voltage_monitoring_type
adc voltage_monitoring type
Definition: at32f413_adc.h:198
adc_data_align_type
adc_data_align_type
adc data align type
Definition: at32f413_adc.h:100
adc_channel_select_type
adc_channel_select_type
adc channel select type
Definition: at32f413_adc.h:109
adc_sampletime_select_type
adc_sampletime_select_type
adc sampletime select type
Definition: at32f413_adc.h:134
adc_preempt_trig_select_type
adc_preempt_trig_select_type
adc preempt group trigger event select type
Definition: at32f413_adc.h:168
adc_combine_mode_type
adc_combine_mode_type
adc combine mode type(these options are reserved in adc2)
Definition: at32f413_adc.h:83
adc_ordinary_trig_select_type
adc_ordinary_trig_select_type
adc ordinary group trigger event select type
Definition: at32f413_adc.h:149
adc_preempt_channel_type
adc_preempt_channel_type
adc preempt channel type
Definition: at32f413_adc.h:187
ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
@ ADC_VMONITOR_SINGLE_ORDINARY_PREEMPT
Definition: at32f413_adc.h:201
ADC_VMONITOR_SINGLE_ORDINARY
@ ADC_VMONITOR_SINGLE_ORDINARY
Definition: at32f413_adc.h:199
ADC_VMONITOR_ALL_ORDINARY
@ ADC_VMONITOR_ALL_ORDINARY
Definition: at32f413_adc.h:202
ADC_VMONITOR_ALL_PREEMPT
@ ADC_VMONITOR_ALL_PREEMPT
Definition: at32f413_adc.h:203
ADC_VMONITOR_ALL_ORDINARY_PREEMPT
@ ADC_VMONITOR_ALL_ORDINARY_PREEMPT
Definition: at32f413_adc.h:204
ADC_VMONITOR_NONE
@ ADC_VMONITOR_NONE
Definition: at32f413_adc.h:205
ADC_VMONITOR_SINGLE_PREEMPT
@ ADC_VMONITOR_SINGLE_PREEMPT
Definition: at32f413_adc.h:200
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:101
ADC_LEFT_ALIGNMENT
@ ADC_LEFT_ALIGNMENT
Definition: at32f413_adc.h:102
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f413_adc.h:119
ADC_CHANNEL_1
@ ADC_CHANNEL_1
Definition: at32f413_adc.h:111
ADC_CHANNEL_17
@ ADC_CHANNEL_17
Definition: at32f413_adc.h:127
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f413_adc.h:118
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:114
ADC_CHANNEL_12
@ ADC_CHANNEL_12
Definition: at32f413_adc.h:122
ADC_CHANNEL_16
@ ADC_CHANNEL_16
Definition: at32f413_adc.h:126
ADC_CHANNEL_0
@ ADC_CHANNEL_0
Definition: at32f413_adc.h:110
ADC_CHANNEL_3
@ ADC_CHANNEL_3
Definition: at32f413_adc.h:113
ADC_CHANNEL_14
@ ADC_CHANNEL_14
Definition: at32f413_adc.h:124
ADC_CHANNEL_10
@ ADC_CHANNEL_10
Definition: at32f413_adc.h:120
ADC_CHANNEL_13
@ ADC_CHANNEL_13
Definition: at32f413_adc.h:123
ADC_CHANNEL_2
@ ADC_CHANNEL_2
Definition: at32f413_adc.h:112
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:116
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f413_adc.h:117
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:115
ADC_CHANNEL_11
@ ADC_CHANNEL_11
Definition: at32f413_adc.h:121
ADC_CHANNEL_15
@ ADC_CHANNEL_15
Definition: at32f413_adc.h:125
ADC_SAMPLETIME_41_5
@ ADC_SAMPLETIME_41_5
Definition: at32f413_adc.h:139
ADC_SAMPLETIME_55_5
@ ADC_SAMPLETIME_55_5
Definition: at32f413_adc.h:140
ADC_SAMPLETIME_71_5
@ ADC_SAMPLETIME_71_5
Definition: at32f413_adc.h:141
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:142
ADC_SAMPLETIME_1_5
@ ADC_SAMPLETIME_1_5
Definition: at32f413_adc.h:135
ADC_SAMPLETIME_28_5
@ ADC_SAMPLETIME_28_5
Definition: at32f413_adc.h:138
ADC_SAMPLETIME_13_5
@ ADC_SAMPLETIME_13_5
Definition: at32f413_adc.h:137
ADC_SAMPLETIME_7_5
@ ADC_SAMPLETIME_7_5
Definition: at32f413_adc.h:136
ADC12_PREEMPT_TRIG_TMR8CH1
@ ADC12_PREEMPT_TRIG_TMR8CH1
Definition: at32f413_adc.h:179
ADC12_PREEMPT_TRIG_TMR4TRGOUT
@ ADC12_PREEMPT_TRIG_TMR4TRGOUT
Definition: at32f413_adc.h:175
ADC12_PREEMPT_TRIG_TMR2TRGOUT
@ ADC12_PREEMPT_TRIG_TMR2TRGOUT
Definition: at32f413_adc.h:172
ADC12_PREEMPT_TRIG_TMR1CH1
@ ADC12_PREEMPT_TRIG_TMR1CH1
Definition: at32f413_adc.h:178
ADC12_PREEMPT_TRIG_TMR1CH4
@ ADC12_PREEMPT_TRIG_TMR1CH4
Definition: at32f413_adc.h:171
ADC12_PREEMPT_TRIG_TMR1TRGOUT
@ ADC12_PREEMPT_TRIG_TMR1TRGOUT
Definition: at32f413_adc.h:170
ADC12_PREEMPT_TRIG_TMR3CH4
@ ADC12_PREEMPT_TRIG_TMR3CH4
Definition: at32f413_adc.h:174
ADC12_PREEMPT_TRIG_SOFTWARE
@ ADC12_PREEMPT_TRIG_SOFTWARE
Definition: at32f413_adc.h:177
ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4
@ ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4
Definition: at32f413_adc.h:176
ADC12_PREEMPT_TRIG_TMR8TRGOUT
@ ADC12_PREEMPT_TRIG_TMR8TRGOUT
Definition: at32f413_adc.h:180
ADC12_PREEMPT_TRIG_TMR2CH1
@ ADC12_PREEMPT_TRIG_TMR2CH1
Definition: at32f413_adc.h:173
ADC_PREEMPT_SMLT_ONLY_MODE
@ ADC_PREEMPT_SMLT_ONLY_MODE
Definition: at32f413_adc.h:89
ADC_PREEMPT_INTERLTRIG_ONLY_MODE
@ ADC_PREEMPT_INTERLTRIG_ONLY_MODE
Definition: at32f413_adc.h:93
ADC_ORDINARY_LONGSHIFT_ONLY_MODE
@ ADC_ORDINARY_LONGSHIFT_ONLY_MODE
Definition: at32f413_adc.h:92
ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE
@ ADC_ORDINARY_SHORTSHIFT_PREEMPT_SMLT_MODE
Definition: at32f413_adc.h:87
ADC_ORDINARY_SMLT_ONLY_MODE
@ ADC_ORDINARY_SMLT_ONLY_MODE
Definition: at32f413_adc.h:90
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:84
ADC_ORDINARY_SHORTSHIFT_ONLY_MODE
@ ADC_ORDINARY_SHORTSHIFT_ONLY_MODE
Definition: at32f413_adc.h:91
ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE
@ ADC_ORDINARY_SMLT_PREEMPT_INTERLTRIG_MODE
Definition: at32f413_adc.h:86
ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE
@ ADC_ORDINARY_LONGSHIFT_PREEMPT_SMLT_MODE
Definition: at32f413_adc.h:88
ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE
@ ADC_ORDINARY_SMLT_PREEMPT_SMLT_MODE
Definition: at32f413_adc.h:85
ADC12_ORDINARY_TRIG_TMR2CH2
@ ADC12_ORDINARY_TRIG_TMR2CH2
Definition: at32f413_adc.h:154
ADC12_ORDINARY_TRIG_TMR1TRGOUT
@ ADC12_ORDINARY_TRIG_TMR1TRGOUT
Definition: at32f413_adc.h:159
ADC12_ORDINARY_TRIG_TMR1CH2
@ ADC12_ORDINARY_TRIG_TMR1CH2
Definition: at32f413_adc.h:152
ADC12_ORDINARY_TRIG_TMR1CH1
@ ADC12_ORDINARY_TRIG_TMR1CH1
Definition: at32f413_adc.h:151
ADC12_ORDINARY_TRIG_TMR8CH2
@ ADC12_ORDINARY_TRIG_TMR8CH2
Definition: at32f413_adc.h:161
ADC12_ORDINARY_TRIG_TMR4CH4
@ ADC12_ORDINARY_TRIG_TMR4CH4
Definition: at32f413_adc.h:156
ADC12_ORDINARY_TRIG_TMR1CH3
@ ADC12_ORDINARY_TRIG_TMR1CH3
Definition: at32f413_adc.h:153
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:158
ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT
@ ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT
Definition: at32f413_adc.h:157
ADC12_ORDINARY_TRIG_TMR3TRGOUT
@ ADC12_ORDINARY_TRIG_TMR3TRGOUT
Definition: at32f413_adc.h:155
ADC12_ORDINARY_TRIG_TMR8CH1
@ ADC12_ORDINARY_TRIG_TMR8CH1
Definition: at32f413_adc.h:160
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f413_adc.h:190
ADC_PREEMPT_CHANNEL_4
@ ADC_PREEMPT_CHANNEL_4
Definition: at32f413_adc.h:191
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f413_adc.h:189
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f413_adc.h:188
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:212
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:215
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:214
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:213
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:216
adc_type
type define adc register all
Definition: at32f413_adc.h:223
adc_type::cspt1
__IO uint32_t cspt1
Definition: at32f413_adc.h:327
adc_type::pcce
__IO uint32_t pcce
Definition: at32f413_adc.h:235
adc_type::adc2odt
__IO uint32_t adc2odt
Definition: at32f413_adc.h:549
adc_type::dtalign
__IO uint32_t dtalign
Definition: at32f413_adc.h:283
adc_type::osq2
__IO uint32_t osq2
Definition: at32f413_adc.h:440
adc_type::ocdmaen
__IO uint32_t ocdmaen
Definition: at32f413_adc.h:281
adc_type::ocswtrg
__IO uint32_t ocswtrg
Definition: at32f413_adc.h:290
adc_type::osn14
__IO uint32_t osn14
Definition: at32f413_adc.h:427
adc_type::rpen
__IO uint32_t rpen
Definition: at32f413_adc.h:277
adc_type::sqen
__IO uint32_t sqen
Definition: at32f413_adc.h:254
adc_type::pctesel_h
__IO uint32_t pctesel_h
Definition: at32f413_adc.h:292
adc_type::pdt4
__IO uint32_t pdt4
Definition: at32f413_adc.h:532
adc_type::cspt15
__IO uint32_t cspt15
Definition: at32f413_adc.h:311
adc_type::pclen
__IO uint32_t pclen
Definition: at32f413_adc.h:483
adc_type::vmcsel
__IO uint32_t vmcsel
Definition: at32f413_adc.h:250
adc_type::cspt7
__IO uint32_t cspt7
Definition: at32f413_adc.h:333
adc_type::odt
__IO uint32_t odt
Definition: at32f413_adc.h:545
adc_type::pcvmen
__IO uint32_t pcvmen
Definition: at32f413_adc.h:262
adc_type::osn1
__IO uint32_t osn1
Definition: at32f413_adc.h:461
adc_type::pcdto4
__IO uint32_t pcdto4
Definition: at32f413_adc.h:384
adc_type::pdt1
__IO uint32_t pdt1
Definition: at32f413_adc.h:493
adc_type::pcdto2
__IO uint32_t pcdto2
Definition: at32f413_adc.h:358
adc_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_adc.h:286
adc_type::cspt6
__IO uint32_t cspt6
Definition: at32f413_adc.h:332
adc_type::osn6
__IO uint32_t osn6
Definition: at32f413_adc.h:466
adc_type::osn8
__IO uint32_t osn8
Definition: at32f413_adc.h:444
adc_type::pcpen
__IO uint32_t pcpen
Definition: at32f413_adc.h:258
adc_type::osn16
__IO uint32_t osn16
Definition: at32f413_adc.h:429
adc_type::cspt13
__IO uint32_t cspt13
Definition: at32f413_adc.h:309
adc_type::vmsgen
__IO uint32_t vmsgen
Definition: at32f413_adc.h:255
adc_type::psq
__IO uint32_t psq
Definition: at32f413_adc.h:476
adc_type::osn3
__IO uint32_t osn3
Definition: at32f413_adc.h:463
adc_type::pcceien
__IO uint32_t pcceien
Definition: at32f413_adc.h:253
adc_type::octen
__IO uint32_t octen
Definition: at32f413_adc.h:288
adc_type::vmorien
__IO uint32_t vmorien
Definition: at32f413_adc.h:252
adc_type::ocvmen
__IO uint32_t ocvmen
Definition: at32f413_adc.h:263
adc_type::oclen
__IO uint32_t oclen
Definition: at32f413_adc.h:430
adc_type::pcdto1
__IO uint32_t pcdto1
Definition: at32f413_adc.h:345
adc_type::mssel
__IO uint32_t mssel
Definition: at32f413_adc.h:260
adc_type::occs
__IO uint32_t occs
Definition: at32f413_adc.h:237
adc_type::osn9
__IO uint32_t osn9
Definition: at32f413_adc.h:445
adc_type::cspt5
__IO uint32_t cspt5
Definition: at32f413_adc.h:331
adc_type::spt1
__IO uint32_t spt1
Definition: at32f413_adc.h:303
adc_type::psn4
__IO uint32_t psn4
Definition: at32f413_adc.h:482
adc_type::cspt12
__IO uint32_t cspt12
Definition: at32f413_adc.h:308
adc_type::adcal
__IO uint32_t adcal
Definition: at32f413_adc.h:278
adc_type::cspt14
__IO uint32_t cspt14
Definition: at32f413_adc.h:310
adc_type::octesel_l
__IO uint32_t octesel_l
Definition: at32f413_adc.h:287
adc_type::cceien
__IO uint32_t cceien
Definition: at32f413_adc.h:251
adc_type::pctesel_l
__IO uint32_t pctesel_l
Definition: at32f413_adc.h:284
adc_type::octesel_h
__IO uint32_t octesel_h
Definition: at32f413_adc.h:293
adc_type::psn3
__IO uint32_t psn3
Definition: at32f413_adc.h:481
adc_type::itsrven
__IO uint32_t itsrven
Definition: at32f413_adc.h:291
adc_type::spt2
__IO uint32_t spt2
Definition: at32f413_adc.h:323
adc_type::osn4
__IO uint32_t osn4
Definition: at32f413_adc.h:464
adc_type::adcen
__IO uint32_t adcen
Definition: at32f413_adc.h:276
adc_type::vmhb
__IO uint32_t vmhb
Definition: at32f413_adc.h:397
adc_type::ocpen
__IO uint32_t ocpen
Definition: at32f413_adc.h:257
adc_type::cspt9
__IO uint32_t cspt9
Definition: at32f413_adc.h:335
adc_type::adcalinit
__IO uint32_t adcalinit
Definition: at32f413_adc.h:279
adc_type::pdt3
__IO uint32_t pdt3
Definition: at32f413_adc.h:519
adc_type::psn1
__IO uint32_t psn1
Definition: at32f413_adc.h:479
adc_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_adc.h:294
adc_type::cspt10
__IO uint32_t cspt10
Definition: at32f413_adc.h:306
adc_type::osn10
__IO uint32_t osn10
Definition: at32f413_adc.h:446
adc_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_adc.h:264
adc_type::osn12
__IO uint32_t osn12
Definition: at32f413_adc.h:448
adc_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_adc.h:247
adc_type::sts
__IO uint32_t sts
Definition: at32f413_adc.h:230
adc_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_adc.h:273
adc_type::cspt0
__IO uint32_t cspt0
Definition: at32f413_adc.h:326
adc_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_adc.h:238
adc_type::cce
__IO uint32_t cce
Definition: at32f413_adc.h:234
adc_type::osq1
__IO uint32_t osq1
Definition: at32f413_adc.h:423
adc_type::cspt16
__IO uint32_t cspt16
Definition: at32f413_adc.h:312
adc_type::psn2
__IO uint32_t psn2
Definition: at32f413_adc.h:480
adc_type::osn2
__IO uint32_t osn2
Definition: at32f413_adc.h:462
adc_type::vmor
__IO uint32_t vmor
Definition: at32f413_adc.h:233
adc_type::osn15
__IO uint32_t osn15
Definition: at32f413_adc.h:428
adc_type::osn11
__IO uint32_t osn11
Definition: at32f413_adc.h:447
adc_type::vmlb
__IO uint32_t vmlb
Definition: at32f413_adc.h:410
adc_type::osn5
__IO uint32_t osn5
Definition: at32f413_adc.h:465
adc_type::pdt2
__IO uint32_t pdt2
Definition: at32f413_adc.h:506
adc_type::cspt4
__IO uint32_t cspt4
Definition: at32f413_adc.h:330
adc_type::ocpcnt
__IO uint32_t ocpcnt
Definition: at32f413_adc.h:259
adc_type::osq3
__IO uint32_t osq3
Definition: at32f413_adc.h:458
adc_type::pcautoen
__IO uint32_t pcautoen
Definition: at32f413_adc.h:256
adc_type::cspt2
__IO uint32_t cspt2
Definition: at32f413_adc.h:328
adc_type::cspt17
__IO uint32_t cspt17
Definition: at32f413_adc.h:313
adc_type::cspt11
__IO uint32_t cspt11
Definition: at32f413_adc.h:307
adc_type::pcdto3
__IO uint32_t pcdto3
Definition: at32f413_adc.h:371
adc_type::cspt8
__IO uint32_t cspt8
Definition: at32f413_adc.h:334
adc_type::osn7
__IO uint32_t osn7
Definition: at32f413_adc.h:443
adc_type::pcten
__IO uint32_t pcten
Definition: at32f413_adc.h:285
adc_type::pcswtrg
__IO uint32_t pcswtrg
Definition: at32f413_adc.h:289
adc_type::osn13
__IO uint32_t osn13
Definition: at32f413_adc.h:426
adc_type::cspt3
__IO uint32_t cspt3
Definition: at32f413_adc.h:329
adc_type::pccs
__IO uint32_t pccs
Definition: at32f413_adc.h:236


AT32F413 Firmwary Library: at32f413_board.c Source File

  • at32f413_board
at32f413_board.c
Go to the documentation of this file.
1
28#include "at32f413_board.h"
29
39/* delay macros */
40#define STEP_DELAY_MS 50
41
42/* at-start led resouce array */
43 gpio_type *led_gpio_port[LED_NUM] = {LED2_GPIO, LED3_GPIO, LED4_GPIO};
44uint16_t led_gpio_pin[LED_NUM] = {LED2_PIN, LED3_PIN, LED4_PIN};
45 crm_periph_clock_type led_gpio_crm_clk[LED_NUM] = {LED2_GPIO_CRM_CLK, LED3_GPIO_CRM_CLK, LED4_GPIO_CRM_CLK};
46
47/* delay variable */
48static __IO uint32_t fac_us;
49static __IO uint32_t fac_ms;
50
51/* support printf function, usemicrolib is unnecessary */
52#if (__ARMCC_VERSION > 6000000)
53 __asm (".global __use_no_semihosting\n\t");
54 void _sys_exit(int x)
55 {
56 x = x;
57 }
58 /* __use_no_semihosting was requested, but _ttywrch was */
59 void _ttywrch(int ch)
60 {
61 ch = ch;
62 }
63 FILE __stdout;
64#else
65 #ifdef __CC_ARM
66 #pragma import(__use_no_semihosting)
67 struct __FILE
68 {
69 int handle;
70 };
71 FILE __stdout;
72 void _sys_exit(int x)
73 {
74 x = x;
75 }
76 /* __use_no_semihosting was requested, but _ttywrch was */
77 void _ttywrch(int ch)
78 {
79 ch = ch;
80 }
81 #endif
82#endif
83
84#if defined (__GNUC__) && !defined (__clang__)
85 #define PUTCHAR_PROTOTYPE int __io_putchar(int ch)
86#else
87 #define PUTCHAR_PROTOTYPE int fputc(int ch, FILE *f)
88#endif
89
95 PUTCHAR_PROTOTYPE
96{
97 while(usart_flag_get(PRINT_UART, USART_TDBE_FLAG) == RESET);
98 usart_data_transmit(PRINT_UART, ch);
99 return ch;
100}
101
107void uart_print_init(uint32_t baudrate)
108{
109 gpio_init_type gpio_init_struct;
110
111 /* enable the uart and gpio clock */
112 crm_periph_clock_enable(PRINT_UART_CRM_CLK, TRUE);
113 crm_periph_clock_enable(PRINT_UART_TX_GPIO_CRM_CLK, TRUE);
114
115 gpio_default_para_init(&gpio_init_struct);
116
117 /* configure the uart tx pin */
118 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
119 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
120 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
121 gpio_init_struct.gpio_pins = PRINT_UART_TX_PIN;
122 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
123 gpio_init(PRINT_UART_TX_GPIO, &gpio_init_struct);
124
125 /* configure uart param */
126 usart_init(PRINT_UART, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
127 usart_transmitter_enable(PRINT_UART, TRUE);
128 usart_enable(PRINT_UART, TRUE);
129}
130
136void at32_board_init()
137{
138 /* initialize delay function */
139 delay_init();
140
141 /* configure led in at_start_board */
142 at32_led_init(LED2);
143 at32_led_init(LED3);
144 at32_led_init(LED4);
145 at32_led_off(LED2);
146 at32_led_off(LED3);
147 at32_led_off(LED4);
148
149 /* configure button in at_start board */
150 at32_button_init();
151}
152
158void at32_button_init(void)
159{
160 gpio_init_type gpio_init_struct;
161
162 /* enable the button clock */
163 crm_periph_clock_enable(USER_BUTTON_CRM_CLK, TRUE);
164
165 /* set default parameter */
166 gpio_default_para_init(&gpio_init_struct);
167
168 /* configure button pin as input with pull-up/pull-down */
169 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
170 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
171 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
172 gpio_init_struct.gpio_pins = USER_BUTTON_PIN;
173 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
174 gpio_init(USER_BUTTON_PORT, &gpio_init_struct);
175}
176
182uint8_t at32_button_state(void)
183{
184 return gpio_input_data_bit_read(USER_BUTTON_PORT, USER_BUTTON_PIN);
185}
186
192 button_type at32_button_press()
193{
194 static uint8_t pressed = 1;
195 /* get button state in at_start board */
196 if((pressed == 1) && (at32_button_state() != RESET))
197 {
198 /* debounce */
199 pressed = 0;
200 delay_ms(10);
201 if(at32_button_state() != RESET)
202 return USER_BUTTON;
203 }
204 else if(at32_button_state() == RESET)
205 {
206 pressed = 1;
207 }
208 return NO_BUTTON;
209}
210
216void at32_led_init(led_type led)
217{
218 gpio_init_type gpio_init_struct;
219
220 /* enable the led clock */
221 crm_periph_clock_enable(led_gpio_crm_clk[led], TRUE);
222
223 /* set default parameter */
224 gpio_default_para_init(&gpio_init_struct);
225
226 /* configure the led gpio */
227 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
228 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
229 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
230 gpio_init_struct.gpio_pins = led_gpio_pin[led];
231 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
232 gpio_init(led_gpio_port[led], &gpio_init_struct);
233}
234
244void at32_led_on(led_type led)
245{
246 if(led > (LED_NUM - 1))
247 return;
248 if(led_gpio_pin[led])
249 led_gpio_port[led]->clr = led_gpio_pin[led];
250}
251
261void at32_led_off(led_type led)
262{
263 if(led > (LED_NUM - 1))
264 return;
265 if(led_gpio_pin[led])
266 led_gpio_port[led]->scr = led_gpio_pin[led];
267}
268
278void at32_led_toggle(led_type led)
279{
280 if(led > (LED_NUM - 1))
281 return;
282 if(led_gpio_pin[led])
283 led_gpio_port[led]->odt ^= led_gpio_pin[led];
284}
285
291void delay_init()
292{
293 /* configure systick */
294 systick_clock_source_config(SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV);
295 fac_us = system_core_clock / (1000000U);
296 fac_ms = fac_us * (1000U);
297}
298
304void delay_us(uint32_t nus)
305{
306 uint32_t temp = 0;
307 SysTick->LOAD = (uint32_t)(nus * fac_us);
308 SysTick->VAL = 0x00;
309 SysTick->CTRL |= SysTick_CTRL_ENABLE_Msk ;
310 do
311 {
312 temp = SysTick->CTRL;
313 }while((temp & 0x01) && !(temp & (1 << 16)));
314
315 SysTick->CTRL &= ~SysTick_CTRL_ENABLE_Msk;
316 SysTick->VAL = 0x00;
317}
318
324void delay_ms(uint16_t nms)
325{
326 uint32_t temp = 0;
327 while(nms)
328 {
329 if(nms > STEP_DELAY_MS)
330 {
331 SysTick->LOAD = (uint32_t)(STEP_DELAY_MS * fac_ms);
332 nms -= STEP_DELAY_MS;
333 }
334 else
335 {
336 SysTick->LOAD = (uint32_t)(nms * fac_ms);
337 nms = 0;
338 }
339 SysTick->VAL = 0x00;
340 SysTick->CTRL |= SysTick_CTRL_ENABLE_Msk;
341 do
342 {
343 temp = SysTick->CTRL;
344 }while((temp & 0x01) && !(temp & (1 << 16)));
345
346 SysTick->CTRL &= ~SysTick_CTRL_ENABLE_Msk;
347 SysTick->VAL = 0x00;
348 }
349}
350
356void delay_sec(uint16_t sec)
357{
358 uint16_t index;
359 for(index = 0; index < sec; index++)
360 {
361 delay_ms(500);
362 delay_ms(500);
363 }
364}
365
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
USER_BUTTON_PORT
#define USER_BUTTON_PORT
Definition: at32f413_board.h:99
PRINT_UART_CRM_CLK
#define PRINT_UART_CRM_CLK
Definition: at32f413_board.h:86
USER_BUTTON_PIN
#define USER_BUTTON_PIN
Definition: at32f413_board.h:98
PRINT_UART_TX_PIN
#define PRINT_UART_TX_PIN
Definition: at32f413_board.h:87
LED_NUM
#define LED_NUM
Definition: at32f413_board.h:68
led_type
led_type
Definition: at32f413_board.h:62
PRINT_UART
#define PRINT_UART
Definition: at32f413_board.h:85
PRINT_UART_TX_GPIO
#define PRINT_UART_TX_GPIO
Definition: at32f413_board.h:88
USER_BUTTON_CRM_CLK
#define USER_BUTTON_CRM_CLK
Definition: at32f413_board.h:100
PRINT_UART_TX_GPIO_CRM_CLK
#define PRINT_UART_TX_GPIO_CRM_CLK
Definition: at32f413_board.h:89
button_type
button_type
Definition: at32f413_board.h:93
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:95
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
led_gpio_port
gpio_type * led_gpio_port[3]
Definition: at32f413_board.c:43
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
fac_ms
static __IO uint32_t fac_ms
Definition: at32f413_board.c:49
led_gpio_pin
uint16_t led_gpio_pin[3]
Definition: at32f413_board.c:44
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f413_board.c:216
delay_init
void delay_init()
initialize delay function
Definition: at32f413_board.c:291
at32_button_state
uint8_t at32_button_state(void)
returns the selected button state
Definition: at32f413_board.c:182
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
STEP_DELAY_MS
#define STEP_DELAY_MS
Definition: at32f413_board.c:40
led_gpio_crm_clk
crm_periph_clock_type led_gpio_crm_clk[3]
Definition: at32f413_board.c:45
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
PUTCHAR_PROTOTYPE
#define PUTCHAR_PROTOTYPE
Definition: at32f413_board.c:87
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
at32_button_init
void at32_button_init(void)
configure button gpio
Definition: at32f413_board.c:158
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
fac_us
static __IO uint32_t fac_us
Definition: at32f413_board.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_periph_clock_type
crm_periph_clock_type
crm periph clock
Definition: at32f413_crm.h:102
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:203
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f413_misc.c:147
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f413_misc.h:90
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
gpio_type
type define gpio register all
Definition: at32f413_gpio.h:300
gpio_type::scr
__IO uint32_t scr
Definition: at32f413_gpio.h:416
gpio_type::odt
__IO uint32_t odt
Definition: at32f413_gpio.h:388
gpio_type::clr
__IO uint32_t clr
Definition: at32f413_gpio.h:459


AT32F413 Firmwary Library: at32f413_board.h Source File

  • at32f413_board
at32f413_board.h
Go to the documentation of this file.
1
28#ifndef __AT32F413_BOARD_H
29#define __AT32F413_BOARD_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "stdio.h"
36#include "at32f413.h"
37
56#if !defined (AT_START_F413_V1)
57#error "please select first the board at-start device used in your application (in at32f413_board.h file)"
58#endif
59
60/******************** define led ********************/
61typedef enum
62{
63 LED2 = 0,
64 LED3 = 1,
65 LED4 = 2
66} led_type;
67
68#define LED_NUM 3
69
70#if defined (AT_START_F413_V1)
71#define LED2_PIN GPIO_PINS_2
72#define LED2_GPIO GPIOC
73#define LED2_GPIO_CRM_CLK CRM_GPIOC_PERIPH_CLOCK
74
75#define LED3_PIN GPIO_PINS_3
76#define LED3_GPIO GPIOC
77#define LED3_GPIO_CRM_CLK CRM_GPIOC_PERIPH_CLOCK
78
79#define LED4_PIN GPIO_PINS_5
80#define LED4_GPIO GPIOC
81#define LED4_GPIO_CRM_CLK CRM_GPIOC_PERIPH_CLOCK
82#endif
83
84/**************** define print uart ******************/
85#define PRINT_UART USART1
86#define PRINT_UART_CRM_CLK CRM_USART1_PERIPH_CLOCK
87#define PRINT_UART_TX_PIN GPIO_PINS_9
88#define PRINT_UART_TX_GPIO GPIOA
89#define PRINT_UART_TX_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
90
91/******************* define button *******************/
92typedef enum
93{
94 USER_BUTTON = 0,
95 NO_BUTTON = 1
96} button_type;
97
98#define USER_BUTTON_PIN GPIO_PINS_0
99#define USER_BUTTON_PORT GPIOA
100#define USER_BUTTON_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
101
110/******************** functions ********************/
111void at32_board_init(void);
112
113/* led operation function */
114void at32_led_init(led_type led);
115void at32_led_on(led_type led);
116void at32_led_off(led_type led);
117void at32_led_toggle(led_type led);
118
119/* button operation function */
120void at32_button_init(void);
121 button_type at32_button_press(void);
122uint8_t at32_button_state(void);
123
124/* delay function */
125void delay_init(void);
126void delay_us(uint32_t nus);
127void delay_ms(uint16_t nms);
128void delay_sec(uint16_t sec);
129
130/* printf uart init function */
131void uart_print_init(uint32_t baudrate);
132
145#ifdef __cplusplus
146}
147#endif
148
149#endif
150
at32f413.h
at32f413 header file
at32_board_init
void at32_board_init(void)
board initialize interface init led and button
Definition: at32f413_board.c:136
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f413_board.c:216
at32_button_state
uint8_t at32_button_state(void)
returns the selected button state
Definition: at32f413_board.c:182
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_button_press
button_type at32_button_press(void)
returns which button have press down
Definition: at32f413_board.c:192
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
at32_button_init
void at32_button_init(void)
configure button gpio
Definition: at32f413_board.c:158
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
delay_init
void delay_init(void)
initialize delay function
Definition: at32f413_board.c:291
led_type
led_type
Definition: at32f413_board.h:62
button_type
button_type
Definition: at32f413_board.h:93
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:95
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94


AT32F413 Firmwary Library: at32f413_bpr.c Source File

  • libraries
  • drivers
  • src
at32f413_bpr.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef BPR_MODULE_ENABLED
39
49void bpr_reset(void)
50{
51 crm_battery_powered_domain_reset(TRUE);
52 crm_battery_powered_domain_reset(FALSE);
53}
54
63 flag_status bpr_flag_get(uint32_t flag)
64{
65 if(flag == BPR_TAMPER_INTERRUPT_FLAG)
66 {
67 return (flag_status)(BPR->ctrlsts_bit.tpif);
68 }
69 else
70 {
71 return (flag_status)(BPR->ctrlsts_bit.tpef);
72 }
73}
74
83void bpr_flag_clear(uint32_t flag)
84{
85 if(flag == BPR_TAMPER_INTERRUPT_FLAG)
86 {
87 BPR->ctrlsts_bit.tpifclr = TRUE;
88 }
89 else
90 {
91 BPR->ctrlsts_bit.tpefclr = TRUE;
92 }
93}
94
100void bpr_interrupt_enable(confirm_state new_state)
101{
102 BPR->ctrlsts_bit.tpien = new_state;
103}
104
116uint16_t bpr_data_read(bpr_data_type bpr_data)
117{
118 return (*(__IO uint16_t *)(BPR_BASE + bpr_data));
119}
120
133void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
134{
135 (*(__IO uint32_t *)(BPR_BASE + bpr_data)) = data_value;
136}
137
151void bpr_rtc_output_select(bpr_rtc_output_type output_source)
152{
153 /* clear cco,asoe,asos,ccos,togen bits */
154 BPR->rtccal &= (uint32_t)~0x0F80;
155
156 /* set output_source value */
157 BPR->rtccal |= output_source;
158}
159
165void bpr_rtc_clock_calibration_value_set(uint8_t calibration_value)
166{
167 /* set rtc clock calibration value */
168 BPR->rtccal_bit.calval= calibration_value;
169}
170
176void bpr_tamper_pin_enable(confirm_state new_state)
177{
178 BPR->ctrl_bit.tpen = new_state;
179}
180
189void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level)
190{
191 BPR->ctrl_bit.tpp = active_level;
192}
193
198#endif
199
bpr_data_type
bpr_data_type
battery powered register data type
Definition: at32f413_bpr.h:67
bpr_tamper_pin_active_level_type
bpr_tamper_pin_active_level_type
tamper pin active level type
Definition: at32f413_bpr.h:130
bpr_rtc_output_type
bpr_rtc_output_type
bpr rtc output type
Definition: at32f413_bpr.h:116
BPR_TAMPER_INTERRUPT_FLAG
#define BPR_TAMPER_INTERRUPT_FLAG
Definition: at32f413_bpr.h:52
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:49
bpr_rtc_clock_calibration_value_set
void bpr_rtc_clock_calibration_value_set(uint8_t calibration_value)
set rtc clock calibration value
Definition: at32f413_bpr.c:165
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:176
bpr_interrupt_enable
void bpr_interrupt_enable(confirm_state new_state)
enable or disable bpr tamper interrupt
Definition: at32f413_bpr.c:100
bpr_rtc_output_select
void bpr_rtc_output_select(bpr_rtc_output_type output_source)
select bpr rtc output
Definition: at32f413_bpr.c:151
bpr_tamper_pin_active_level_set
void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level
Definition: at32f413_bpr.c:189
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:116
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:83
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:133
bpr_flag_get
flag_status bpr_flag_get(uint32_t flag)
bpr event flag get, for tamper event flag
Definition: at32f413_bpr.c:63
BPR
#define BPR
Definition: at32f413_bpr.h:756
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f413_crm.c:495
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
BPR_BASE
#define BPR_BASE
Definition: at32f413.h:321
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_bpr.h Source File

  • libraries
  • drivers
  • inc
at32f413_bpr.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_BPR_H
29#define __AT32F413_BPR_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define BPR_TAMPER_INTERRUPT_FLAG ((uint32_t)0x00000001)
53#define BPR_TAMPER_EVENT_FLAG ((uint32_t)0x00000002)
66typedef enum
67{
68 BPR_DATA1 = 0x04,
69 BPR_DATA2 = 0x08,
70 BPR_DATA3 = 0x0C,
71 BPR_DATA4 = 0x10,
72 BPR_DATA5 = 0x14,
73 BPR_DATA6 = 0x18,
74 BPR_DATA7 = 0x1C,
75 BPR_DATA8 = 0x20,
76 BPR_DATA9 = 0x24,
77 BPR_DATA10 = 0x28,
78 BPR_DATA11 = 0x40,
79 BPR_DATA12 = 0x44,
80 BPR_DATA13 = 0x48,
81 BPR_DATA14 = 0x4C,
82 BPR_DATA15 = 0x50,
83 BPR_DATA16 = 0x54,
84 BPR_DATA17 = 0x58,
85 BPR_DATA18 = 0x5C,
86 BPR_DATA19 = 0x60,
87 BPR_DATA20 = 0x64,
88 BPR_DATA21 = 0x68,
89 BPR_DATA22 = 0x6C,
90 BPR_DATA23 = 0x70,
91 BPR_DATA24 = 0x74,
92 BPR_DATA25 = 0x78,
93 BPR_DATA26 = 0x7C,
94 BPR_DATA27 = 0x80,
95 BPR_DATA28 = 0x84,
96 BPR_DATA29 = 0x88,
97 BPR_DATA30 = 0x8C,
98 BPR_DATA31 = 0x90,
99 BPR_DATA32 = 0x94,
100 BPR_DATA33 = 0x98,
101 BPR_DATA34 = 0x9C,
102 BPR_DATA35 = 0xA0,
103 BPR_DATA36 = 0xA4,
104 BPR_DATA37 = 0xA8,
105 BPR_DATA38 = 0xAC,
106 BPR_DATA39 = 0xB0,
107 BPR_DATA40 = 0xB4,
108 BPR_DATA41 = 0xB8,
109 BPR_DATA42 = 0xBC
110} bpr_data_type;
111
115typedef enum
116{
117 BPR_RTC_OUTPUT_NONE = 0x000,
118 BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE = 0x080,
119 BPR_RTC_OUTPUT_ALARM = 0x100,
120 BPR_RTC_OUTPUT_SECOND = 0x300,
121 BPR_RTC_OUTPUT_CLOCK_CAL_AFTER = 0x480,
122 BPR_RTC_OUTPUT_ALARM_TOGGLE = 0x900,
123 BPR_RTC_OUTPUT_SECOND_TOGGLE = 0xB00
124} bpr_rtc_output_type;
125
129typedef enum
130{
131 BPR_TAMPER_PIN_ACTIVE_HIGH = 0x00,
132 BPR_TAMPER_PIN_ACTIVE_LOW = 0x01
133} bpr_tamper_pin_active_level_type;
134
138typedef struct
139{
143 __IO uint32_t reserved1;
144
148 union
149 {
150 __IO uint32_t dt1;
151 struct
152 {
153 __IO uint32_t dt : 16;/* [15:0] */
154 __IO uint32_t reserved1 : 16;/* [31:15] */
155 } dt1_bit;
156 };
157
161 union
162 {
163 __IO uint32_t dt2;
164 struct
165 {
166 __IO uint32_t dt : 16;/* [15:0] */
167 __IO uint32_t reserved1 : 16;/* [31:15] */
168 } dt2_bit;
169 };
170
174 union
175 {
176 __IO uint32_t dt3;
177 struct
178 {
179 __IO uint32_t dt : 16;/* [15:0] */
180 __IO uint32_t reserved1 : 16;/* [31:15] */
181 } dt3_bit;
182 };
183
187 union
188 {
189 __IO uint32_t dt4;
190 struct
191 {
192 __IO uint32_t dt : 16;/* [15:0] */
193 __IO uint32_t reserved1 : 16;/* [31:15] */
194 } dt4_bit;
195 };
196
200 union
201 {
202 __IO uint32_t dt5;
203 struct
204 {
205 __IO uint32_t dt : 16;/* [15:0] */
206 __IO uint32_t reserved1 : 16;/* [31:15] */
207 } dt5_bit;
208 };
209
213 union
214 {
215 __IO uint32_t dt6;
216 struct
217 {
218 __IO uint32_t dt : 16;/* [15:0] */
219 __IO uint32_t reserved1 : 16;/* [31:15] */
220 } dt6_bit;
221 };
222
226 union
227 {
228 __IO uint32_t dt7;
229 struct
230 {
231 __IO uint32_t dt : 16;/* [15:0] */
232 __IO uint32_t reserved1 : 16;/* [31:15] */
233 } dt7_bit;
234 };
235
239 union
240 {
241 __IO uint32_t dt8;
242 struct
243 {
244 __IO uint32_t dt : 16;/* [15:0] */
245 __IO uint32_t reserved1 : 16;/* [31:15] */
246 } dt8_bit;
247 };
248
252 union
253 {
254 __IO uint32_t dt9;
255 struct
256 {
257 __IO uint32_t dt : 16;/* [15:0] */
258 __IO uint32_t reserved1 : 16;/* [31:15] */
259 } dt9_bit;
260 };
261
265 union
266 {
267 __IO uint32_t dt10;
268 struct
269 {
270 __IO uint32_t dt : 16;/* [15:0] */
271 __IO uint32_t reserved1 : 16;/* [31:15] */
272 } dt10_bit;
273 };
274
278 union
279 {
280 __IO uint32_t rtccal;
281 struct
282 {
283 __IO uint32_t calval : 7; /* [6:0] */
284 __IO uint32_t calout : 1; /* [7] */
285 __IO uint32_t outen : 1; /* [8] */
286 __IO uint32_t outsel : 1; /* [9] */
287 __IO uint32_t ccos : 1; /* [10] */
288 __IO uint32_t outm : 1; /* [11] */
289 __IO uint32_t reserved1 : 20;/* [31:12] */
290 } rtccal_bit;
291 };
292
296 union
297 {
298 __IO uint32_t ctrl;
299 struct
300 {
301 __IO uint32_t tpen : 1; /* [0] */
302 __IO uint32_t tpp : 1; /* [1] */
303 __IO uint32_t reserved1 : 30;/* [31:2] */
304 } ctrl_bit;
305 };
306
310 union
311 {
312 __IO uint32_t ctrlsts;
313 struct
314 {
315 __IO uint32_t tpefclr : 1;/* [0] */
316 __IO uint32_t tpifclr : 1;/* [1] */
317 __IO uint32_t tpien : 1;/* [2] */
318 __IO uint32_t reserved1 : 5;/* [7:3] */
319 __IO uint32_t tpef : 1;/* [8] */
320 __IO uint32_t tpif : 1;/* [9] */
321 __IO uint32_t reserved2 : 22;/* [31:10] */
322 } ctrlsts_bit;
323 };
324
328 __IO uint32_t reserved2;
329
333 __IO uint32_t reserved3;
334
338 union
339 {
340 __IO uint32_t dt11;
341 struct
342 {
343 __IO uint32_t dt : 16;/* [15:0] */
344 __IO uint32_t reserved1 : 16;/* [31:15] */
345 } dt11_bit;
346 };
347
351 union
352 {
353 __IO uint32_t dt12;
354 struct
355 {
356 __IO uint32_t dt : 16;/* [15:0] */
357 __IO uint32_t reserved1 : 16;/* [31:15] */
358 } dt12_bit;
359 };
360
364 union
365 {
366 __IO uint32_t dt13;
367 struct
368 {
369 __IO uint32_t dt : 16;/* [15:0] */
370 __IO uint32_t reserved1 : 16;/* [31:15] */
371 } dt13_bit;
372 };
373
377 union
378 {
379 __IO uint32_t dt14;
380 struct
381 {
382 __IO uint32_t dt : 16;/* [15:0] */
383 __IO uint32_t reserved1 : 16;/* [31:15] */
384 } dt14_bit;
385 };
386
390 union
391 {
392 __IO uint32_t dt15;
393 struct
394 {
395 __IO uint32_t dt : 16;/* [15:0] */
396 __IO uint32_t reserved1 : 16;/* [31:15] */
397 } dt15_bit;
398 };
399
403 union
404 {
405 __IO uint32_t dt16;
406 struct
407 {
408 __IO uint32_t dt : 16;/* [15:0] */
409 __IO uint32_t reserved1 : 16;/* [31:15] */
410 } dt16_bit;
411 };
412
416 union
417 {
418 __IO uint32_t dt17;
419 struct
420 {
421 __IO uint32_t dt : 16;/* [15:0] */
422 __IO uint32_t reserved1 : 16;/* [31:15] */
423 } dt17_bit;
424 };
425
429 union
430 {
431 __IO uint32_t dt18;
432 struct
433 {
434 __IO uint32_t dt : 16;/* [15:0] */
435 __IO uint32_t reserved1 : 16;/* [31:15] */
436 } dt18_bit;
437 };
438
442 union
443 {
444 __IO uint32_t dt19;
445 struct
446 {
447 __IO uint32_t dt : 16;/* [15:0] */
448 __IO uint32_t reserved1 : 16;/* [31:15] */
449 } dt19_bit;
450 };
451
455 union
456 {
457 __IO uint32_t dt20;
458 struct
459 {
460 __IO uint32_t dt : 16;/* [15:0] */
461 __IO uint32_t reserved1 : 16;/* [31:15] */
462 } dt20_bit;
463 };
464
468 union
469 {
470 __IO uint32_t dt21;
471 struct
472 {
473 __IO uint32_t dt : 16;/* [15:0] */
474 __IO uint32_t reserved1 : 16;/* [31:15] */
475 } dt21_bit;
476 };
477
481 union
482 {
483 __IO uint32_t dt22;
484 struct
485 {
486 __IO uint32_t dt : 16;/* [15:0] */
487 __IO uint32_t reserved1 : 16;/* [31:15] */
488 } dt22_bit;
489 };
490
494 union
495 {
496 __IO uint32_t dt23;
497 struct
498 {
499 __IO uint32_t dt : 16;/* [15:0] */
500 __IO uint32_t reserved1 : 16;/* [31:15] */
501 } dt23_bit;
502 };
503
507 union
508 {
509 __IO uint32_t dt24;
510 struct
511 {
512 __IO uint32_t dt : 16;/* [15:0] */
513 __IO uint32_t reserved1 : 16;/* [31:15] */
514 } dt24_bit;
515 };
516
520 union
521 {
522 __IO uint32_t dt25;
523 struct
524 {
525 __IO uint32_t dt : 16;/* [15:0] */
526 __IO uint32_t reserved1 : 16;/* [31:15] */
527 } dt25_bit;
528 };
529
533 union
534 {
535 __IO uint32_t dt26;
536 struct
537 {
538 __IO uint32_t dt : 16;/* [15:0] */
539 __IO uint32_t reserved1 : 16;/* [31:15] */
540 } dt26_bit;
541 };
542
546 union
547 {
548 __IO uint32_t dt27;
549 struct
550 {
551 __IO uint32_t dt : 16;/* [15:0] */
552 __IO uint32_t reserved1 : 16;/* [31:15] */
553 } dt27_bit;
554 };
555
559 union
560 {
561 __IO uint32_t dt28;
562 struct
563 {
564 __IO uint32_t dt : 16;/* [15:0] */
565 __IO uint32_t reserved1 : 16;/* [31:15] */
566 } dt28_bit;
567 };
568
572 union
573 {
574 __IO uint32_t dt29;
575 struct
576 {
577 __IO uint32_t dt : 16;/* [15:0] */
578 __IO uint32_t reserved1 : 16;/* [31:15] */
579 } dt29_bit;
580 };
581
585 union
586 {
587 __IO uint32_t dt30;
588 struct
589 {
590 __IO uint32_t dt : 16;/* [15:0] */
591 __IO uint32_t reserved1 : 16;/* [31:15] */
592 } dt30_bit;
593 };
594
598 union
599 {
600 __IO uint32_t dt31;
601 struct
602 {
603 __IO uint32_t dt : 16;/* [15:0] */
604 __IO uint32_t reserved1 : 16;/* [31:15] */
605 } dt31_bit;
606 };
607
611 union
612 {
613 __IO uint32_t dt32;
614 struct
615 {
616 __IO uint32_t dt : 16;/* [15:0] */
617 __IO uint32_t reserved1 : 16;/* [31:15] */
618 } dt32_bit;
619 };
620
624 union
625 {
626 __IO uint32_t dt33;
627 struct
628 {
629 __IO uint32_t dt : 16;/* [15:0] */
630 __IO uint32_t reserved1 : 16;/* [31:15] */
631 } dt33_bit;
632 };
633
637 union
638 {
639 __IO uint32_t dt34;
640 struct
641 {
642 __IO uint32_t dt : 16;/* [15:0] */
643 __IO uint32_t reserved1 : 16;/* [31:15] */
644 } dt34_bit;
645 };
646
650 union
651 {
652 __IO uint32_t dt35;
653 struct
654 {
655 __IO uint32_t dt : 16;/* [15:0] */
656 __IO uint32_t reserved1 : 16;/* [31:15] */
657 } dt35_bit;
658 };
659
663 union
664 {
665 __IO uint32_t dt36;
666 struct
667 {
668 __IO uint32_t dt : 16;/* [15:0] */
669 __IO uint32_t reserved1 : 16;/* [31:15] */
670 } dt36_bit;
671 };
672
676 union
677 {
678 __IO uint32_t dt37;
679 struct
680 {
681 __IO uint32_t dt : 16;/* [15:0] */
682 __IO uint32_t reserved1 : 16;/* [31:15] */
683 } dt37_bit;
684 };
685
689 union
690 {
691 __IO uint32_t dt38;
692 struct
693 {
694 __IO uint32_t dt : 16;/* [15:0] */
695 __IO uint32_t reserved1 : 16;/* [31:15] */
696 } dt38_bit;
697 };
698
702 union
703 {
704 __IO uint32_t dt39;
705 struct
706 {
707 __IO uint32_t dt : 16;/* [15:0] */
708 __IO uint32_t reserved1 : 16;/* [31:15] */
709 } dt39_bit;
710 };
711
715 union
716 {
717 __IO uint32_t dt40;
718 struct
719 {
720 __IO uint32_t dt : 16;/* [15:0] */
721 __IO uint32_t reserved1 : 16;/* [31:15] */
722 } dt40_bit;
723 };
724
728 union
729 {
730 __IO uint32_t dt41;
731 struct
732 {
733 __IO uint32_t dt : 16;/* [15:0] */
734 __IO uint32_t reserved1 : 16;/* [31:15] */
735 } dt41_bit;
736 };
737
741 union
742 {
743 __IO uint32_t dt42;
744 struct
745 {
746 __IO uint32_t dt : 16;/* [15:0] */
747 __IO uint32_t reserved1 : 16;/* [31:15] */
748 } dt42_bit;
749 };
750} bpr_type;
751
756#define BPR ((bpr_type *) BPR_BASE)
757
762void bpr_reset(void);
763 flag_status bpr_flag_get(uint32_t flag);
764void bpr_flag_clear(uint32_t flag);
765void bpr_interrupt_enable(confirm_state new_state);
766uint16_t bpr_data_read(bpr_data_type bpr_data);
767void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value);
768void bpr_rtc_output_select(bpr_rtc_output_type output_source);
769void bpr_rtc_clock_calibration_value_set(uint8_t calibration_value);
770void bpr_tamper_pin_enable(confirm_state new_state);
771void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level);
772
785#ifdef __cplusplus
786}
787#endif
788
789#endif
at32f413.h
at32f413 header file
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:49
bpr_rtc_clock_calibration_value_set
void bpr_rtc_clock_calibration_value_set(uint8_t calibration_value)
set rtc clock calibration value
Definition: at32f413_bpr.c:165
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:176
bpr_interrupt_enable
void bpr_interrupt_enable(confirm_state new_state)
enable or disable bpr tamper interrupt
Definition: at32f413_bpr.c:100
bpr_rtc_output_select
void bpr_rtc_output_select(bpr_rtc_output_type output_source)
select bpr rtc output
Definition: at32f413_bpr.c:151
bpr_tamper_pin_active_level_set
void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level
Definition: at32f413_bpr.c:189
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:116
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:83
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:133
bpr_flag_get
flag_status bpr_flag_get(uint32_t flag)
bpr event flag get, for tamper event flag
Definition: at32f413_bpr.c:63
bpr_data_type
bpr_data_type
battery powered register data type
Definition: at32f413_bpr.h:67
bpr_tamper_pin_active_level_type
bpr_tamper_pin_active_level_type
tamper pin active level type
Definition: at32f413_bpr.h:130
bpr_rtc_output_type
bpr_rtc_output_type
bpr rtc output type
Definition: at32f413_bpr.h:116
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:93
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:95
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:98
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:75
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:92
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:106
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:74
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:79
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:96
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:86
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:68
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:103
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:76
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:77
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:94
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:87
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:105
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:104
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:108
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:80
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:71
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:99
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:83
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:78
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:91
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:90
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:72
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:85
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:84
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:109
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:88
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:100
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:107
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:97
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:69
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:81
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:82
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:70
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:89
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:101
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:102
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:73
BPR_TAMPER_PIN_ACTIVE_LOW
@ BPR_TAMPER_PIN_ACTIVE_LOW
Definition: at32f413_bpr.h:132
BPR_TAMPER_PIN_ACTIVE_HIGH
@ BPR_TAMPER_PIN_ACTIVE_HIGH
Definition: at32f413_bpr.h:131
BPR_RTC_OUTPUT_NONE
@ BPR_RTC_OUTPUT_NONE
Definition: at32f413_bpr.h:117
BPR_RTC_OUTPUT_ALARM
@ BPR_RTC_OUTPUT_ALARM
Definition: at32f413_bpr.h:119
BPR_RTC_OUTPUT_CLOCK_CAL_AFTER
@ BPR_RTC_OUTPUT_CLOCK_CAL_AFTER
Definition: at32f413_bpr.h:121
BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE
@ BPR_RTC_OUTPUT_CLOCK_CAL_BEFORE
Definition: at32f413_bpr.h:118
BPR_RTC_OUTPUT_SECOND
@ BPR_RTC_OUTPUT_SECOND
Definition: at32f413_bpr.h:120
BPR_RTC_OUTPUT_SECOND_TOGGLE
@ BPR_RTC_OUTPUT_SECOND_TOGGLE
Definition: at32f413_bpr.h:123
BPR_RTC_OUTPUT_ALARM_TOGGLE
@ BPR_RTC_OUTPUT_ALARM_TOGGLE
Definition: at32f413_bpr.h:122
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
bpr_type
type define bpr register all
Definition: at32f413_bpr.h:139
bpr_type::dt14
__IO uint32_t dt14
Definition: at32f413_bpr.h:379
bpr_type::dt32
__IO uint32_t dt32
Definition: at32f413_bpr.h:613
bpr_type::dt22
__IO uint32_t dt22
Definition: at32f413_bpr.h:483
bpr_type::reserved2
__IO uint32_t reserved2
reserved, offset:0x38
Definition: at32f413_bpr.h:321
bpr_type::dt17
__IO uint32_t dt17
Definition: at32f413_bpr.h:418
bpr_type::dt24
__IO uint32_t dt24
Definition: at32f413_bpr.h:509
bpr_type::outen
__IO uint32_t outen
Definition: at32f413_bpr.h:285
bpr_type::ccos
__IO uint32_t ccos
Definition: at32f413_bpr.h:287
bpr_type::dt11
__IO uint32_t dt11
Definition: at32f413_bpr.h:340
bpr_type::dt35
__IO uint32_t dt35
Definition: at32f413_bpr.h:652
bpr_type::dt30
__IO uint32_t dt30
Definition: at32f413_bpr.h:587
bpr_type::tpp
__IO uint32_t tpp
Definition: at32f413_bpr.h:302
bpr_type::dt19
__IO uint32_t dt19
Definition: at32f413_bpr.h:444
bpr_type::tpif
__IO uint32_t tpif
Definition: at32f413_bpr.h:320
bpr_type::dt38
__IO uint32_t dt38
Definition: at32f413_bpr.h:691
bpr_type::tpifclr
__IO uint32_t tpifclr
Definition: at32f413_bpr.h:316
bpr_type::dt8
__IO uint32_t dt8
Definition: at32f413_bpr.h:241
bpr_type::tpien
__IO uint32_t tpien
Definition: at32f413_bpr.h:317
bpr_type::dt25
__IO uint32_t dt25
Definition: at32f413_bpr.h:522
bpr_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_bpr.h:298
bpr_type::dt16
__IO uint32_t dt16
Definition: at32f413_bpr.h:405
bpr_type::dt31
__IO uint32_t dt31
Definition: at32f413_bpr.h:600
bpr_type::dt
__IO uint32_t dt
Definition: at32f413_bpr.h:153
bpr_type::dt37
__IO uint32_t dt37
Definition: at32f413_bpr.h:678
bpr_type::dt39
__IO uint32_t dt39
Definition: at32f413_bpr.h:704
bpr_type::dt34
__IO uint32_t dt34
Definition: at32f413_bpr.h:639
bpr_type::dt20
__IO uint32_t dt20
Definition: at32f413_bpr.h:457
bpr_type::dt1
__IO uint32_t dt1
Definition: at32f413_bpr.h:150
bpr_type::reserved3
__IO uint32_t reserved3
reserved, offset:0x3C
Definition: at32f413_bpr.h:333
bpr_type::tpefclr
__IO uint32_t tpefclr
Definition: at32f413_bpr.h:315
bpr_type::calout
__IO uint32_t calout
Definition: at32f413_bpr.h:284
bpr_type::calval
__IO uint32_t calval
Definition: at32f413_bpr.h:283
bpr_type::dt7
__IO uint32_t dt7
Definition: at32f413_bpr.h:228
bpr_type::dt3
__IO uint32_t dt3
Definition: at32f413_bpr.h:176
bpr_type::dt29
__IO uint32_t dt29
Definition: at32f413_bpr.h:574
bpr_type::dt6
__IO uint32_t dt6
Definition: at32f413_bpr.h:215
bpr_type::dt33
__IO uint32_t dt33
Definition: at32f413_bpr.h:626
bpr_type::dt18
__IO uint32_t dt18
Definition: at32f413_bpr.h:431
bpr_type::dt4
__IO uint32_t dt4
Definition: at32f413_bpr.h:189
bpr_type::dt13
__IO uint32_t dt13
Definition: at32f413_bpr.h:366
bpr_type::tpef
__IO uint32_t tpef
Definition: at32f413_bpr.h:319
bpr_type::dt42
__IO uint32_t dt42
Definition: at32f413_bpr.h:743
bpr_type::dt36
__IO uint32_t dt36
Definition: at32f413_bpr.h:665
bpr_type::ctrlsts
__IO uint32_t ctrlsts
Definition: at32f413_bpr.h:312
bpr_type::dt12
__IO uint32_t dt12
Definition: at32f413_bpr.h:353
bpr_type::dt28
__IO uint32_t dt28
Definition: at32f413_bpr.h:561
bpr_type::dt9
__IO uint32_t dt9
Definition: at32f413_bpr.h:254
bpr_type::outsel
__IO uint32_t outsel
Definition: at32f413_bpr.h:286
bpr_type::dt15
__IO uint32_t dt15
Definition: at32f413_bpr.h:392
bpr_type::dt21
__IO uint32_t dt21
Definition: at32f413_bpr.h:470
bpr_type::dt26
__IO uint32_t dt26
Definition: at32f413_bpr.h:535
bpr_type::dt10
__IO uint32_t dt10
Definition: at32f413_bpr.h:267
bpr_type::dt2
__IO uint32_t dt2
Definition: at32f413_bpr.h:163
bpr_type::outm
__IO uint32_t outm
Definition: at32f413_bpr.h:288
bpr_type::dt40
__IO uint32_t dt40
Definition: at32f413_bpr.h:717
bpr_type::reserved1
__IO uint32_t reserved1
reserved, offset:0x00
Definition: at32f413_bpr.h:143
bpr_type::dt5
__IO uint32_t dt5
Definition: at32f413_bpr.h:202
bpr_type::tpen
__IO uint32_t tpen
Definition: at32f413_bpr.h:301
bpr_type::dt27
__IO uint32_t dt27
Definition: at32f413_bpr.h:548
bpr_type::rtccal
__IO uint32_t rtccal
Definition: at32f413_bpr.h:280
bpr_type::dt23
__IO uint32_t dt23
Definition: at32f413_bpr.h:496
bpr_type::dt41
__IO uint32_t dt41
Definition: at32f413_bpr.h:730


AT32F413 Firmwary Library: at32f413_can.c Source File

  • libraries
  • drivers
  • src
at32f413_can.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef CAN_MODULE_ENABLED
39
51void can_reset(can_type* can_x)
52{
53 if(can_x == CAN1)
54 {
55 crm_periph_reset(CRM_CAN1_PERIPH_RESET, TRUE);
56 crm_periph_reset(CRM_CAN1_PERIPH_RESET, FALSE);
57 }
58 else if(can_x == CAN2)
59 {
60 crm_periph_reset(CRM_CAN2_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_CAN2_PERIPH_RESET, FALSE);
62 }
63}
64
70void can_baudrate_default_para_init(can_baudrate_type* can_baudrate_struct)
71{
72 /* reset can baudrate structure parameters values */
73
74 /* baud rate division */
75 can_baudrate_struct->baudrate_div = 1;
76
77 /* resynchronization adjust width */
78 can_baudrate_struct->rsaw_size = CAN_RSAW_2TQ;
79
80 /* bit time segment 1 */
81 can_baudrate_struct->bts1_size = CAN_BTS1_4TQ;
82
83 /* bit time segment 2 */
84 can_baudrate_struct->bts2_size = CAN_BTS2_3TQ;
85}
86
99 error_status can_baudrate_set(can_type* can_x, can_baudrate_type* can_baudrate_struct)
100{
101 error_status status_index = ERROR;
102 uint32_t wait_ack_index = 0x00000000;
103 /* exit from doze mode */
104 can_x->mctrl_bit.dzen = FALSE;
105
106 /* request freeze mode */
107 can_x->mctrl_bit.fzen = TRUE;
108
109 /* wait the acknowledge */
110 while((!can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
111 {
112 wait_ack_index++;
113 }
114
115 /* check acknowledge */
116 if(can_x->msts_bit.fzc)
117 {
118 can_x->btmg_bit.brdiv = can_baudrate_struct->baudrate_div - 1;
119 can_x->btmg_bit.rsaw = can_baudrate_struct->rsaw_size;
120 can_x->btmg_bit.bts1 = can_baudrate_struct->bts1_size;
121 can_x->btmg_bit.bts2 = can_baudrate_struct->bts2_size;
122
123 /* request leave freeze mode */
124 can_x->mctrl_bit.fzen = FALSE;
125
126 /* wait the acknowledge */
127 wait_ack_index = 0;
128 while((can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
129 {
130 wait_ack_index++;
131 }
132
133 /* check acknowledged */
134 if(can_x->msts_bit.fzc)
135 {
136 status_index = ERROR;
137 }
138 else
139 {
140 status_index = SUCCESS ;
141 }
142 }
143 else
144 {
145 status_index = ERROR;
146 }
147
148 /* return the status of baudrate set */
149 return status_index;
150}
151
157void can_default_para_init(can_base_type* can_base_struct)
158{
159 /* reset can init structure parameters values */
160
161 /* initialize the time triggered communication mode */
162 can_base_struct->ttc_enable = FALSE;
163
164 /* initialize the automatic exit bus-off management */
165 can_base_struct->aebo_enable = FALSE;
166
167 /* initialize the automatic exit doze mode */
168 can_base_struct->aed_enable = FALSE;
169
170 /* initialize the prohibit retransmission when sending fails */
171 can_base_struct->prsf_enable = FALSE;
172
173 /* initialize the message discarding rule select when overflow */
174 can_base_struct->mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
175
176 /* initialize the multiple message sending sequence rule */
177 can_base_struct->mmssr_selection = CAN_SENDING_BY_ID;
178
179 /* initialize the can_mode */
180 can_base_struct->mode_selection = CAN_MODE_COMMUNICATE;
181}
182
194 error_status can_base_init(can_type* can_x, can_base_type* can_base_struct)
195{
196 error_status init_status_index = ERROR;
197 uint32_t wait_ack_index = 0x00000000;
198 /* exit from doze mode */
199 can_x->mctrl_bit.dzen = FALSE;
200
201 /* request freeze mode */
202 can_x->mctrl_bit.fzen = TRUE;
203
204 /* wait the acknowledge */
205 while((!can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
206 {
207 wait_ack_index++;
208 }
209
210 /* check acknowledge */
211 if(can_x->msts_bit.fzc)
212 {
213 /* set the time triggered communication mode */
214 can_x->mctrl_bit.ttcen = can_base_struct->ttc_enable;
215
216 /* set the automatic exit bus-off management */
217 can_x->mctrl_bit.aeboen = can_base_struct->aebo_enable;
218
219 /* set the automatic automatic exit doze mode */
220 can_x->mctrl_bit.aeden = can_base_struct->aed_enable;
221
222 /* set the prohibit retransmission when sending fails */
223 can_x->mctrl_bit.prsfen = can_base_struct->prsf_enable;
224
225 /* set the message discarding rule select when overflow */
226 can_x->mctrl_bit.mdrsel = can_base_struct->mdrsel_selection;
227
228 /* set the multiple message sending sequence rule */
229 can_x->mctrl_bit.mmssr = can_base_struct->mmssr_selection;
230
231 /* set the test mode */
232 can_x->btmg_bit.lben = can_base_struct->mode_selection & 0x01;
233 can_x->btmg_bit.loen = (can_base_struct->mode_selection >> 1) & 0x01;
234
235 /* request leave freeze mode */
236 can_x->mctrl_bit.fzen = FALSE;
237
238 /* wait the acknowledge */
239 wait_ack_index = 0;
240 while((can_x->msts_bit.fzc) && (wait_ack_index != FZC_TIMEOUT))
241 {
242 wait_ack_index++;
243 }
244
245 /* check acknowledged */
246 if(can_x->msts_bit.fzc)
247 {
248 init_status_index = ERROR;
249 }
250 else
251 {
252 init_status_index = SUCCESS ;
253 }
254 }
255 else
256 {
257 init_status_index = ERROR;
258 }
259
260 /* return the status of initialization */
261 return init_status_index;
262}
263
269void can_filter_default_para_init(can_filter_init_type* can_filter_init_struct)
270{
271 /* reset can filter init structure parameters values */
272
273 /* initialize the filter activate state */
274 can_filter_init_struct->filter_activate_enable = FALSE;
275
276 /* filter mode */
277 can_filter_init_struct->filter_mode = CAN_FILTER_MODE_ID_MASK;
278
279 /* filter relation fifo select */
280 can_filter_init_struct->filter_fifo = CAN_FILTER_FIFO0;
281
282 /* filter number select */
283 can_filter_init_struct->filter_number = 0;
284
285 /* initialize the filter bit width */
286 can_filter_init_struct->filter_bit = CAN_FILTER_16BIT;
287
288 /* initialize the filters filter data bit */
289 can_filter_init_struct->filter_id_high = 0;
290 can_filter_init_struct->filter_id_low = 0;
291 can_filter_init_struct->filter_mask_high = 0;
292 can_filter_init_struct->filter_mask_low = 0;
293}
294
304void can_filter_init(can_type* can_x, can_filter_init_type* can_filter_init_struct)
305{
306 uint32_t filter_number_bit_pos = 0;
307 filter_number_bit_pos = ((uint32_t)1) << can_filter_init_struct->filter_number;
308 /* set the filter turn into configuration condition */
309 can_x->fctrl_bit.fcs = TRUE;
310
311 /* filter activate disable */
312 can_x->facfg &= ~(uint32_t)filter_number_bit_pos;
313
314 /* filter bit width */
315 switch(can_filter_init_struct->filter_bit)
316 {
317 case CAN_FILTER_16BIT:
318 can_x->fbwcfg &= ~(uint32_t)filter_number_bit_pos;
319 /* first 16-bit identifier and first 16-bit mask or first 16-bit identifier and second 16-bit identifier */
320 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_low) << 16);
321 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_low);
322
323 /* second 16-bit identifier and second 16-bit mask or third 16-bit identifier and fourth 16-bit identifier */
324 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_high) << 16);
325 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_high);
326
327 break;
328 case CAN_FILTER_32BIT:
329 can_x->fbwcfg |= filter_number_bit_pos;
330 /* 32-bit identifier or first 32-bit identifier */
331 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_high) << 16);
332 can_x->ffb[can_filter_init_struct->filter_number].ffdb1 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_id_low);
333
334 /* 32-bit mask or second 32-bit identifier */
335 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 = ((0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_high) << 16);
336 can_x->ffb[can_filter_init_struct->filter_number].ffdb2 |= (0x0000FFFF & (uint32_t)can_filter_init_struct->filter_mask_low);
337
338 break;
339 default:
340 break;
341 }
342
343 /* filter mode */
344 switch(can_filter_init_struct->filter_mode)
345 {
346 case CAN_FILTER_MODE_ID_MASK:
347 can_x->fmcfg &= ~(uint32_t)filter_number_bit_pos;
348 break;
349 case CAN_FILTER_MODE_ID_LIST:
350 can_x->fmcfg |= (uint32_t)filter_number_bit_pos;
351 break;
352 default:
353 break;
354 }
355
356 /* filter relation fifo select */
357 switch(can_filter_init_struct->filter_fifo)
358 {
359 case CAN_FILTER_FIFO0:
360 can_x->frf &= ~(uint32_t)filter_number_bit_pos;
361 break;
362 case CAN_FILTER_FIFO1:
363 can_x->frf |= (uint32_t)filter_number_bit_pos;
364 break;
365 default:
366 break;
367 }
368
369 /* filter activate enable */
370 switch(can_filter_init_struct->filter_activate_enable)
371 {
372 case TRUE:
373 can_x->facfg |= (uint32_t)filter_number_bit_pos;
374 break;
375 case FALSE:
376 can_x->facfg &= ~(uint32_t)filter_number_bit_pos;
377 break;
378 default:
379 break;
380 }
381
382 /* set the filter turn into working condition */
383 can_x->fctrl_bit.fcs = FALSE;
384}
385
395void can_debug_transmission_prohibit(can_type* can_x, confirm_state new_state)
396{
397 can_x->mctrl_bit.ptd = new_state;
398}
399
416void can_ttc_mode_enable(can_type* can_x, confirm_state new_state)
417{
418 /* config the ttc mode new_state */
419 can_x->mctrl_bit.ttcen = new_state;
420
421 /* config tmtsten bits new_state */
422 can_x->tx_mailbox[0].tmc_bit.tmtsten = new_state;
423 can_x->tx_mailbox[1].tmc_bit.tmtsten = new_state;
424 can_x->tx_mailbox[2].tmc_bit.tmtsten = new_state;
425}
426
440uint8_t can_message_transmit(can_type* can_x, can_tx_message_type* tx_message_struct)
441{
442 uint8_t transmit_mailbox = CAN_TX_STATUS_NO_EMPTY;
443
444 /* select one empty transmit mailbox */
445 if(can_x->tsts_bit.tm0ef)
446 {
447 transmit_mailbox = CAN_TX_MAILBOX0;
448 }
449 else if(can_x->tsts_bit.tm1ef)
450 {
451 transmit_mailbox = CAN_TX_MAILBOX1;
452 }
453 else if(can_x->tsts_bit.tm2ef)
454 {
455 transmit_mailbox = CAN_TX_MAILBOX2;
456 }
457 else
458 {
459 transmit_mailbox = CAN_TX_STATUS_NO_EMPTY;
460 }
461
462 if(transmit_mailbox != CAN_TX_STATUS_NO_EMPTY)
463 {
464 /* set up the id */
465 can_x->tx_mailbox[transmit_mailbox].tmi &= 0x00000001;
466 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmidsel = tx_message_struct->id_type;
467 switch(tx_message_struct->id_type)
468 {
469 case CAN_ID_STANDARD:
470 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmsid = tx_message_struct->standard_id;
471 break;
472 case CAN_ID_EXTENDED:
473 can_x->tx_mailbox[transmit_mailbox].tmi |= (tx_message_struct->extended_id << 3);
474 break;
475 default:
476 break;
477 }
478 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmfrsel = tx_message_struct->frame_type;
479 /* set up the dlc */
480 can_x->tx_mailbox[transmit_mailbox].tmc_bit.tmdtbl = (tx_message_struct->dlc & ((uint8_t)0x0F));
481
482 /* set up the data field */
483 can_x->tx_mailbox[transmit_mailbox].tmdtl = (((uint32_t)tx_message_struct->data[3] << 24) |
484 ((uint32_t)tx_message_struct->data[2] << 16) |
485 ((uint32_t)tx_message_struct->data[1] << 8) |
486 ((uint32_t)tx_message_struct->data[0]));
487 can_x->tx_mailbox[transmit_mailbox].tmdth = (((uint32_t)tx_message_struct->data[7] << 24) |
488 ((uint32_t)tx_message_struct->data[6] << 16) |
489 ((uint32_t)tx_message_struct->data[5] << 8) |
490 ((uint32_t)tx_message_struct->data[4]));
491
492 /* request transmission */
493 can_x->tx_mailbox[transmit_mailbox].tmi_bit.tmsr = TRUE;
494 }
495 return transmit_mailbox;
496}
497
514 can_transmit_status_type can_transmit_status_get(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox)
515{
516 can_transmit_status_type state_index = CAN_TX_STATUS_FAILED;
517 switch(transmit_mailbox)
518 {
519 case CAN_TX_MAILBOX0:
520 if(can_x->tsts_bit.tm0tcf != RESET)
521 {
522 if(can_x->tsts_bit.tm0tsf != RESET)
523 {
524 state_index = CAN_TX_STATUS_SUCCESSFUL;
525 }
526 else
527 {
528 state_index = CAN_TX_STATUS_FAILED;
529 }
530 }
531 else
532 {
533 state_index = CAN_TX_STATUS_PENDING;
534 }
535 break;
536 case CAN_TX_MAILBOX1:
537 if(can_x->tsts_bit.tm1tcf != RESET)
538 {
539 if(can_x->tsts_bit.tm1tsf != RESET)
540 {
541 state_index = CAN_TX_STATUS_SUCCESSFUL;
542 }
543 else
544 {
545 state_index = CAN_TX_STATUS_FAILED;
546 }
547 }
548 else
549 {
550 state_index = CAN_TX_STATUS_PENDING;
551 }
552 break;
553 case CAN_TX_MAILBOX2:
554 if(can_x->tsts_bit.tm2tcf != RESET)
555 {
556 if(can_x->tsts_bit.tm2tsf != RESET)
557 {
558 state_index = CAN_TX_STATUS_SUCCESSFUL;
559 }
560 else
561 {
562 state_index = CAN_TX_STATUS_FAILED;
563 }
564 }
565 else
566 {
567 state_index = CAN_TX_STATUS_PENDING;
568 }
569 break;
570 default:
571 state_index = CAN_TX_STATUS_FAILED;
572 break;
573 }
574 return state_index;
575}
576
589void can_transmit_cancel(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox)
590{
591 switch (transmit_mailbox)
592 {
593 case CAN_TX_MAILBOX0:
594 can_x->tsts = CAN_TSTS_TM0CT_VAL;
595 break;
596 case CAN_TX_MAILBOX1:
597 can_x->tsts = CAN_TSTS_TM1CT_VAL;
598 break;
599 case CAN_TX_MAILBOX2:
600 can_x->tsts = CAN_TSTS_TM2CT_VAL;
601 break;
602 default:
603 break;
604 }
605}
606
619void can_message_receive(can_type* can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type* rx_message_struct)
620{
621 /* get the id type */
622 rx_message_struct->id_type = (can_identifier_type)can_x->fifo_mailbox[fifo_number].rfi_bit.rfidi;
623 switch (rx_message_struct->id_type)
624 {
625 case CAN_ID_STANDARD:
626 rx_message_struct->standard_id = can_x->fifo_mailbox[fifo_number].rfi_bit.rfsid;
627 break;
628 case CAN_ID_EXTENDED:
629 rx_message_struct->extended_id = 0x1FFFFFFF & (can_x->fifo_mailbox[fifo_number].rfi >> 3);
630 break;
631 default:
632 break;
633 }
634 rx_message_struct->frame_type = (can_trans_frame_type)can_x->fifo_mailbox[fifo_number].rfi_bit.rffri;
635 /* get the dlc */
636 rx_message_struct->dlc = can_x->fifo_mailbox[fifo_number].rfc_bit.rfdtl;
637
638 /* get the filter match number */
639 rx_message_struct->filter_index = can_x->fifo_mailbox[fifo_number].rfc_bit.rffmn;
640
641 /* get the data field */
642 rx_message_struct->data[0] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt0;
643 rx_message_struct->data[1] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt1;
644 rx_message_struct->data[2] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt2;
645 rx_message_struct->data[3] = can_x->fifo_mailbox[fifo_number].rfdtl_bit.rfdt3;
646 rx_message_struct->data[4] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt4;
647 rx_message_struct->data[5] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt5;
648 rx_message_struct->data[6] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt6;
649 rx_message_struct->data[7] = can_x->fifo_mailbox[fifo_number].rfdth_bit.rfdt7;
650
651 /* release the fifo */
652 can_receive_fifo_release(can_x, fifo_number);
653}
654
666void can_receive_fifo_release(can_type* can_x, can_rx_fifo_num_type fifo_number)
667{
668 switch (fifo_number)
669 {
670 case CAN_RX_FIFO0:
671 can_x->rf0 = CAN_RF0_RF0R_VAL;
672 break;
673 case CAN_RX_FIFO1:
674 can_x->rf1 = CAN_RF1_RF1R_VAL;
675 break;
676 default:
677 break;
678 }
679}
680
692uint8_t can_receive_message_pending_get(can_type* can_x, can_rx_fifo_num_type fifo_number)
693{
694 uint8_t message_pending = 0;
695 switch (fifo_number)
696 {
697 case CAN_RX_FIFO0:
698 message_pending = can_x->rf0_bit.rf0mn;
699 break;
700 case CAN_RX_FIFO1:
701 message_pending = can_x->rf1_bit.rf1mn;
702 break;
703 default:
704 break;
705 }
706 return message_pending;
707}
708
723 error_status can_operating_mode_set(can_type* can_x, can_operating_mode_type can_operating_mode)
724{
725 error_status status = ERROR;
726 uint32_t time_out_index = FZC_TIMEOUT;
727
728 if (can_operating_mode == CAN_OPERATINGMODE_FREEZE)
729 {
730 /* request enter freeze mode */
731 can_x->mctrl_bit.dzen = FALSE;
732 can_x->mctrl_bit.fzen = TRUE;
733
734 while(((can_x->msts_bit.dzc) || (!can_x->msts_bit.fzc)) && (time_out_index != 0))
735 {
736 time_out_index--;
737 }
738 if((can_x->msts_bit.dzc) || (!can_x->msts_bit.fzc))
739 {
740 status = ERROR;
741 }
742 else
743 {
744 status = SUCCESS;
745 }
746 }
747 else if(can_operating_mode == CAN_OPERATINGMODE_DOZE)
748 {
749 /* request enter doze mode */
750 can_x->mctrl_bit.dzen = TRUE;
751 can_x->mctrl_bit.fzen = FALSE;
752
753 while(((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc)) && (time_out_index != 0))
754 {
755 time_out_index--;
756 }
757 if((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc))
758 {
759 status = ERROR;
760 }
761 else
762 {
763 status = SUCCESS;
764 }
765 }
766 else if(can_operating_mode == CAN_OPERATINGMODE_COMMUNICATE)
767 {
768 /* request enter normal mode */
769 can_x->mctrl_bit.dzen = FALSE;
770 can_x->mctrl_bit.fzen = FALSE;
771
772 while(((can_x->msts_bit.dzc) || (can_x->msts_bit.fzc)) && (time_out_index != 0))
773 {
774 time_out_index--;
775 }
776 if((can_x->msts_bit.dzc) || (can_x->msts_bit.fzc))
777 {
778 status = ERROR;
779 }
780 else
781 {
782 status = SUCCESS;
783 }
784 }
785 else
786 {
787 status = ERROR;
788 }
789 return status;
790}
791
801 can_enter_doze_status_type can_doze_mode_enter(can_type* can_x)
802{
803 can_enter_doze_status_type status = CAN_ENTER_DOZE_FAILED;
804 uint32_t time_out_index = FZC_TIMEOUT;
805 can_x->mctrl_bit.fzen = FALSE;
806 can_x->mctrl_bit.dzen = TRUE;
807 while(((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc)) && (time_out_index != 0))
808 {
809 time_out_index--;
810 }
811 if((!can_x->msts_bit.dzc) || (can_x->msts_bit.fzc))
812 {
813 status = CAN_ENTER_DOZE_FAILED;
814 }
815 else
816 {
817 status = CAN_ENTER_DOZE_SUCCESSFUL;
818 }
819 return status;
820}
821
831 can_quit_doze_status_type can_doze_mode_exit(can_type* can_x)
832{
833 can_quit_doze_status_type status = CAN_QUIT_DOZE_FAILED;
834 uint32_t time_out_index = DZC_TIMEOUT;
835 can_x->mctrl_bit.dzen = FALSE;
836 while((can_x->msts_bit.dzc) && (time_out_index != 0))
837 {
838 time_out_index--;
839 }
840 if(!can_x->msts_bit.dzc)
841 {
842 status = CAN_QUIT_DOZE_SUCCESSFUL;
843 }
844 return status;
845}
846
863 can_error_record_type can_error_type_record_get(can_type* can_x)
864{
865 can_error_record_type error_code = CAN_ERRORRECORD_NOERR;
866
867 error_code = (can_error_record_type)can_x->ests_bit.etr;
868 return error_code;
869}
870
878uint8_t can_receive_error_counter_get(can_type* can_x)
879{
880 uint8_t counter = 0;
881 counter = can_x->ests_bit.rec;
882 return counter;
883}
884
892uint8_t can_transmit_error_counter_get(can_type* can_x)
893{
894 uint8_t counter = 0;
895 counter = can_x->ests_bit.tec;
896 return counter;
897}
898
924void can_interrupt_enable(can_type* can_x, uint32_t can_int, confirm_state new_state)
925{
926 if (new_state != FALSE)
927 {
928 can_x->inten |= can_int;
929 }
930 else
931 {
932 can_x->inten &= ~can_int;
933 }
934}
935
964 flag_status can_flag_get(can_type* can_x, uint32_t can_flag)
965{
966 flag_status bit_status = RESET;
967 switch(can_flag)
968 {
969 case CAN_EAF_FLAG:
970 bit_status = (flag_status)can_x->ests_bit.eaf;
971 break;
972 case CAN_EPF_FLAG:
973 bit_status = (flag_status)can_x->ests_bit.epf;
974 break;
975 case CAN_BOF_FLAG:
976 bit_status = (flag_status)can_x->ests_bit.bof;
977 break;
978 case CAN_ETR_FLAG:
979 if(can_x->ests_bit.etr != 0)
980 {
981 bit_status = SET;
982 }
983 else
984 {
985 bit_status = RESET;
986 }
987 break;
988 case CAN_EOIF_FLAG:
989 bit_status = (flag_status)can_x->msts_bit.eoif;
990 break;
991 case CAN_TM0TCF_FLAG:
992 bit_status = (flag_status)can_x->tsts_bit.tm0tcf;
993 break;
994 case CAN_TM1TCF_FLAG:
995 bit_status = (flag_status)can_x->tsts_bit.tm1tcf;
996 break;
997 case CAN_TM2TCF_FLAG:
998 bit_status = (flag_status)can_x->tsts_bit.tm2tcf;
999 break;
1000 case CAN_RF0MN_FLAG:
1001 if(can_x->rf0_bit.rf0mn != 0)
1002 {
1003 bit_status = SET;
1004 }
1005 else
1006 {
1007 bit_status = RESET;
1008 }
1009 break;
1010 case CAN_RF0FF_FLAG:
1011 bit_status = (flag_status)can_x->rf0_bit.rf0ff;
1012 break;
1013 case CAN_RF0OF_FLAG:
1014 bit_status = (flag_status)can_x->rf0_bit.rf0of;
1015 break;
1016 case CAN_RF1MN_FLAG:
1017 if(can_x->rf1_bit.rf1mn != 0)
1018 {
1019 bit_status = SET;
1020 }
1021 else
1022 {
1023 bit_status = RESET;
1024 }
1025 break;
1026 case CAN_RF1FF_FLAG:
1027 bit_status = (flag_status)can_x->rf1_bit.rf1ff;
1028 break;
1029 case CAN_RF1OF_FLAG:
1030 bit_status = (flag_status)can_x->rf1_bit.rf1of;
1031 break;
1032 case CAN_QDZIF_FLAG:
1033 bit_status = (flag_status)can_x->msts_bit.qdzif;
1034 break;
1035 case CAN_EDZC_FLAG:
1036 if((can_x->msts_bit.dzc != RESET) ||(can_x->msts_bit.edzif != RESET))
1037 {
1038 bit_status = SET;
1039 }
1040 else
1041 {
1042 bit_status = RESET;
1043 }
1044 break;
1045 case CAN_TMEF_FLAG:
1046 if((can_x->tsts_bit.tm0ef != RESET) || (can_x->tsts_bit.tm1ef != RESET) || (can_x->tsts_bit.tm2ef != RESET))
1047 {
1048 bit_status = SET;
1049 }
1050 else
1051 {
1052 bit_status = RESET;
1053 }
1054 break;
1055 default:
1056 bit_status = RESET;
1057 break;
1058 }
1059 return bit_status;
1060}
1061
1088void can_flag_clear(can_type* can_x, uint32_t can_flag)
1089{
1090 switch(can_flag)
1091 {
1092 case CAN_EAF_FLAG:
1093 case CAN_EPF_FLAG:
1094 case CAN_BOF_FLAG:
1095 case CAN_EOIF_FLAG:
1096 can_x->msts = CAN_MSTS_EOIF_VAL;
1097 break;
1098 case CAN_ETR_FLAG:
1099 can_x->msts = CAN_MSTS_EOIF_VAL;
1100 can_x->ests = 0;
1101 break;
1102 case CAN_TM0TCF_FLAG:
1103 can_x->tsts = CAN_TSTS_TM0TCF_VAL;
1104 break;
1105 case CAN_TM1TCF_FLAG:
1106 can_x->tsts = CAN_TSTS_TM1TCF_VAL;
1107 break;
1108 case CAN_TM2TCF_FLAG:
1109 can_x->tsts = CAN_TSTS_TM2TCF_VAL;
1110 break;
1111 case CAN_RF0FF_FLAG:
1112 can_x->rf0 = CAN_RF0_RF0FF_VAL;
1113 break;
1114 case CAN_RF0OF_FLAG:
1115 can_x->rf0 = CAN_RF0_RF0OF_VAL;
1116 break;
1117 case CAN_RF1FF_FLAG:
1118 can_x->rf1 = CAN_RF1_RF1FF_VAL;
1119 break;
1120 case CAN_RF1OF_FLAG:
1121 can_x->rf1 = CAN_RF1_RF1OF_VAL;
1122 break;
1123 case CAN_QDZIF_FLAG:
1124 can_x->msts = CAN_MSTS_QDZIF_VAL;
1125 break;
1126 case CAN_EDZC_FLAG:
1127 can_x->msts = CAN_MSTS_EDZIF_VAL;
1128 break;
1129 case CAN_TMEF_FLAG:
1130 can_x->tsts = CAN_TSTS_TM0TCF_VAL | CAN_TSTS_TM1TCF_VAL | CAN_TSTS_TM2TCF_VAL;
1131 break;
1132 default:
1133 break;
1134 }
1135}
1136
1141#endif
1142
counter
uint16_t counter
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:40
can_transmit_status_type
can_transmit_status_type
can transmit status
Definition: at32f413_can.h:271
can_quit_doze_status_type
can_quit_doze_status_type
can quit doze mode status
Definition: at32f413_can.h:291
can_trans_frame_type
can_trans_frame_type
can transmission frame type
Definition: at32f413_can.h:243
can_error_record_type
can_error_record_type
can error type record
Definition: at32f413_can.h:318
can_operating_mode_type
can_operating_mode_type
can operating mode
Definition: at32f413_can.h:175
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:252
can_enter_doze_status_type
can_enter_doze_status_type
can enter doze mode status
Definition: at32f413_can.h:282
can_rx_fifo_num_type
can_rx_fifo_num_type
can receive fifo
Definition: at32f413_can.h:262
can_identifier_type
can_identifier_type
can identifier type
Definition: at32f413_can.h:234
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:138
CAN_FILTER_FIFO1
@ CAN_FILTER_FIFO1
Definition: at32f413_can.h:139
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:273
CAN_TX_STATUS_PENDING
@ CAN_TX_STATUS_PENDING
Definition: at32f413_can.h:274
CAN_TX_STATUS_NO_EMPTY
@ CAN_TX_STATUS_NO_EMPTY
Definition: at32f413_can.h:275
CAN_TX_STATUS_FAILED
@ CAN_TX_STATUS_FAILED
Definition: at32f413_can.h:272
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:301
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:222
CAN_QUIT_DOZE_FAILED
@ CAN_QUIT_DOZE_FAILED
Definition: at32f413_can.h:292
CAN_QUIT_DOZE_SUCCESSFUL
@ CAN_QUIT_DOZE_SUCCESSFUL
Definition: at32f413_can.h:293
CAN_BTS1_4TQ
@ CAN_BTS1_4TQ
Definition: at32f413_can.h:200
CAN_ERRORRECORD_NOERR
@ CAN_ERRORRECORD_NOERR
Definition: at32f413_can.h:319
CAN_FILTER_MODE_ID_LIST
@ CAN_FILTER_MODE_ID_LIST
Definition: at32f413_can.h:148
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f413_can.h:147
CAN_OPERATINGMODE_FREEZE
@ CAN_OPERATINGMODE_FREEZE
Definition: at32f413_can.h:176
CAN_OPERATINGMODE_COMMUNICATE
@ CAN_OPERATINGMODE_COMMUNICATE
Definition: at32f413_can.h:178
CAN_OPERATINGMODE_DOZE
@ CAN_OPERATINGMODE_DOZE
Definition: at32f413_can.h:177
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:310
CAN_TX_MAILBOX2
@ CAN_TX_MAILBOX2
Definition: at32f413_can.h:255
CAN_TX_MAILBOX0
@ CAN_TX_MAILBOX0
Definition: at32f413_can.h:253
CAN_TX_MAILBOX1
@ CAN_TX_MAILBOX1
Definition: at32f413_can.h:254
CAN_FILTER_16BIT
@ CAN_FILTER_16BIT
Definition: at32f413_can.h:156
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:157
CAN_ENTER_DOZE_FAILED
@ CAN_ENTER_DOZE_FAILED
Definition: at32f413_can.h:283
CAN_ENTER_DOZE_SUCCESSFUL
@ CAN_ENTER_DOZE_SUCCESSFUL
Definition: at32f413_can.h:284
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:263
CAN_RX_FIFO1
@ CAN_RX_FIFO1
Definition: at32f413_can.h:264
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:235
CAN_ID_EXTENDED
@ CAN_ID_EXTENDED
Definition: at32f413_can.h:236
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f413_can.h:165
CAN_RSAW_2TQ
@ CAN_RSAW_2TQ
Definition: at32f413_can.h:187
CAN_EDZC_FLAG
#define CAN_EDZC_FLAG
Definition: at32f413_can.h:79
CAN_TM1TCF_FLAG
#define CAN_TM1TCF_FLAG
Definition: at32f413_can.h:70
CAN_QDZIF_FLAG
#define CAN_QDZIF_FLAG
Definition: at32f413_can.h:78
CAN_TM0TCF_FLAG
#define CAN_TM0TCF_FLAG
Definition: at32f413_can.h:69
CAN_RF1FF_FLAG
#define CAN_RF1FF_FLAG
Definition: at32f413_can.h:76
CAN_RF0FF_FLAG
#define CAN_RF0FF_FLAG
Definition: at32f413_can.h:73
CAN_RF1MN_FLAG
#define CAN_RF1MN_FLAG
Definition: at32f413_can.h:75
CAN_EPF_FLAG
#define CAN_EPF_FLAG
Definition: at32f413_can.h:65
CAN_RF1OF_FLAG
#define CAN_RF1OF_FLAG
Definition: at32f413_can.h:77
CAN_EAF_FLAG
#define CAN_EAF_FLAG
Definition: at32f413_can.h:64
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f413_can.h:72
CAN_TM2TCF_FLAG
#define CAN_TM2TCF_FLAG
Definition: at32f413_can.h:71
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f413_can.h:67
CAN_RF0OF_FLAG
#define CAN_RF0OF_FLAG
Definition: at32f413_can.h:74
CAN_EOIF_FLAG
#define CAN_EOIF_FLAG
Definition: at32f413_can.h:68
CAN_TMEF_FLAG
#define CAN_TMEF_FLAG
Definition: at32f413_can.h:80
CAN_BOF_FLAG
#define CAN_BOF_FLAG
Definition: at32f413_can.h:66
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:194
can_reset
void can_reset(can_type *can_x)
deinitialize the can peripheral registers to their default reset values.
Definition: at32f413_can.c:51
can_transmit_error_counter_get
uint8_t can_transmit_error_counter_get(can_type *can_x)
return the transmit error counter of the specified can peripheral.
Definition: at32f413_can.c:892
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:514
can_ttc_mode_enable
void can_ttc_mode_enable(can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral.
Definition: at32f413_can.c:416
can_filter_default_para_init
void can_filter_default_para_init(can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value.
Definition: at32f413_can.c:269
can_receive_fifo_release
void can_receive_fifo_release(can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral.
Definition: at32f413_can.c:666
can_receive_error_counter_get
uint8_t can_receive_error_counter_get(can_type *can_x)
return the receive error counter (rec) of the specified can peripheral.
Definition: at32f413_can.c:878
can_operating_mode_set
error_status can_operating_mode_set(can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral.
Definition: at32f413_can.c:723
can_baudrate_default_para_init
void can_baudrate_default_para_init(can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value.
Definition: at32f413_can.c:70
can_transmit_cancel
void can_transmit_cancel(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral.
Definition: at32f413_can.c:589
can_receive_message_pending_get
uint8_t can_receive_message_pending_get(can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral.
Definition: at32f413_can.c:692
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1088
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:99
can_debug_transmission_prohibit
void can_debug_transmission_prohibit(can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral.
Definition: at32f413_can.c:395
can_error_type_record_get
can_error_record_type can_error_type_record_get(can_type *can_x)
return the error type record (etr) of the specified can peripheral.
Definition: at32f413_can.c:863
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:157
can_doze_mode_exit
can_quit_doze_status_type can_doze_mode_exit(can_type *can_x)
exit the doze mode of the specified can peripheral.
Definition: at32f413_can.c:831
can_doze_mode_enter
can_enter_doze_status_type can_doze_mode_enter(can_type *can_x)
enter the low power mode of the specified can peripheral.
Definition: at32f413_can.c:801
DZC_TIMEOUT
#define DZC_TIMEOUT
Definition: at32f413_can.h:53
FZC_TIMEOUT
#define FZC_TIMEOUT
Definition: at32f413_can.h:52
CAN_RF1_RF1FF_VAL
#define CAN_RF1_RF1FF_VAL
Definition: at32f413_can.h:125
CAN_RF0_RF0FF_VAL
#define CAN_RF0_RF0FF_VAL
Definition: at32f413_can.h:122
CAN_TSTS_TM0TCF_VAL
#define CAN_TSTS_TM0TCF_VAL
Definition: at32f413_can.h:116
CAN_TSTS_TM2CT_VAL
#define CAN_TSTS_TM2CT_VAL
Definition: at32f413_can.h:121
CAN_RF1_RF1R_VAL
#define CAN_RF1_RF1R_VAL
Definition: at32f413_can.h:127
CAN1
#define CAN1
Definition: at32f413_can.h:938
CAN_MSTS_EOIF_VAL
#define CAN_MSTS_EOIF_VAL
can flag clear operation macro definition val
Definition: at32f413_can.h:113
CAN_MSTS_QDZIF_VAL
#define CAN_MSTS_QDZIF_VAL
Definition: at32f413_can.h:114
CAN_TSTS_TM2TCF_VAL
#define CAN_TSTS_TM2TCF_VAL
Definition: at32f413_can.h:118
CAN_RF0_RF0OF_VAL
#define CAN_RF0_RF0OF_VAL
Definition: at32f413_can.h:123
CAN_RF0_RF0R_VAL
#define CAN_RF0_RF0R_VAL
Definition: at32f413_can.h:124
CAN_RF1_RF1OF_VAL
#define CAN_RF1_RF1OF_VAL
Definition: at32f413_can.h:126
CAN_TSTS_TM1TCF_VAL
#define CAN_TSTS_TM1TCF_VAL
Definition: at32f413_can.h:117
CAN2
#define CAN2
Definition: at32f413_can.h:939
CAN_TSTS_TM0CT_VAL
#define CAN_TSTS_TM0CT_VAL
Definition: at32f413_can.h:119
CAN_TSTS_TM1CT_VAL
#define CAN_TSTS_TM1CT_VAL
Definition: at32f413_can.h:120
CAN_MSTS_EDZIF_VAL
#define CAN_MSTS_EDZIF_VAL
Definition: at32f413_can.h:115
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
CRM_CAN1_PERIPH_RESET
@ CRM_CAN1_PERIPH_RESET
Definition: at32f413_crm.h:183
CRM_CAN2_PERIPH_RESET
@ CRM_CAN2_PERIPH_RESET
Definition: at32f413_crm.h:186
error_status
error_status
error status
Definition: at32f413.h:264
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
can_base_type
can init structure definition
Definition: at32f413_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:359
can_fifo_mailbox_type::rfdt4
__IO uint32_t rfdt4
Definition: at32f413_can.h:566
can_fifo_mailbox_type::rfi
__IO uint32_t rfi
Definition: at32f413_can.h:517
can_fifo_mailbox_type::rfdt0
__IO uint32_t rfdt0
Definition: at32f413_can.h:551
can_fifo_mailbox_type::rfsid
__IO uint32_t rfsid
Definition: at32f413_can.h:524
can_fifo_mailbox_type::rfdt2
__IO uint32_t rfdt2
Definition: at32f413_can.h:553
can_fifo_mailbox_type::rfdtl
__IO uint32_t rfdtl
Definition: at32f413_can.h:536
can_fifo_mailbox_type::rfidi
__IO uint32_t rfidi
Definition: at32f413_can.h:522
can_fifo_mailbox_type::rfdt1
__IO uint32_t rfdt1
Definition: at32f413_can.h:552
can_fifo_mailbox_type::rfc_bit
struct can_fifo_mailbox_type::@227::@234 rfc_bit
can_fifo_mailbox_type::rfdt6
__IO uint32_t rfdt6
Definition: at32f413_can.h:568
can_fifo_mailbox_type::rffri
__IO uint32_t rffri
Definition: at32f413_can.h:521
can_fifo_mailbox_type::rfdtl_bit
struct can_fifo_mailbox_type::@229::@235 rfdtl_bit
can_fifo_mailbox_type::rfdt3
__IO uint32_t rfdt3
Definition: at32f413_can.h:554
can_fifo_mailbox_type::rfi_bit
struct can_fifo_mailbox_type::@225::@233 rfi_bit
can_fifo_mailbox_type::rfdt5
__IO uint32_t rfdt5
Definition: at32f413_can.h:567
can_fifo_mailbox_type::rfdt7
__IO uint32_t rfdt7
Definition: at32f413_can.h:569
can_fifo_mailbox_type::rffmn
__IO uint32_t rffmn
Definition: at32f413_can.h:538
can_fifo_mailbox_type::rfdth_bit
struct can_fifo_mailbox_type::@231::@236 rfdth_bit
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:383
can_filter_register_type::ffdb1
__IO uint32_t ffdb1
Definition: at32f413_can.h:579
can_filter_register_type::ffdb2
__IO uint32_t ffdb2
Definition: at32f413_can.h:580
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:420
can_rx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:426
can_rx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:428
can_rx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:433
can_rx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:430
can_rx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:423
can_rx_message_type::filter_index
uint8_t filter_index
Definition: at32f413_can.h:435
can_tx_mailbox_type::tmtsten
__IO uint32_t tmtsten
Definition: at32f413_can.h:470
can_tx_mailbox_type::tmi
__IO uint32_t tmi
Definition: at32f413_can.h:449
can_tx_mailbox_type::tmsr
__IO uint32_t tmsr
Definition: at32f413_can.h:452
can_tx_mailbox_type::tmdtl
__IO uint32_t tmdtl
Definition: at32f413_can.h:481
can_tx_mailbox_type::tmdtbl
__IO uint32_t tmdtbl
Definition: at32f413_can.h:468
can_tx_mailbox_type::tmfrsel
__IO uint32_t tmfrsel
Definition: at32f413_can.h:453
can_tx_mailbox_type::tmsid
__IO uint32_t tmsid
Definition: at32f413_can.h:456
can_tx_mailbox_type::tmi_bit
struct can_tx_mailbox_type::@213::@221 tmi_bit
can_tx_mailbox_type::tmc_bit
struct can_tx_mailbox_type::@215::@222 tmc_bit
can_tx_mailbox_type::tmdth
__IO uint32_t tmdth
Definition: at32f413_can.h:496
can_tx_mailbox_type::tmidsel
__IO uint32_t tmidsel
Definition: at32f413_can.h:454
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:406
can_tx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:411
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:398
can_type
type define can register all
Definition: at32f413_can.h:587
can_type::rf0of
__IO uint32_t rf0of
Definition: at32f413_can.h:681
can_type::tm2ef
__IO uint32_t tm2ef
Definition: at32f413_can.h:663
can_type::eaf
__IO uint32_t eaf
Definition: at32f413_can.h:740
can_type::rf1
__IO uint32_t rf1
Definition: at32f413_can.h:692
can_type::tm0tsf
__IO uint32_t tm0tsf
Definition: at32f413_can.h:643
can_type::aeden
__IO uint32_t aeden
Definition: at32f413_can.h:602
can_type::dzc
__IO uint32_t dzc
Definition: at32f413_can.h:621
can_type::mctrl_bit
struct can_type::@237::@263 mctrl_bit
can_type::tm0tcf
__IO uint32_t tm0tcf
Definition: at32f413_can.h:642
can_type::fctrl_bit
struct can_type::@253::@271 fctrl_bit
can_type::edzif
__IO uint32_t edzif
Definition: at32f413_can.h:624
can_type::mdrsel
__IO uint32_t mdrsel
Definition: at32f413_can.h:600
can_type::rf1ff
__IO uint32_t rf1ff
Definition: at32f413_can.h:697
can_type::bof
__IO uint32_t bof
Definition: at32f413_can.h:742
can_type::tec
__IO uint32_t tec
Definition: at32f413_can.h:746
can_type::ttcen
__IO uint32_t ttcen
Definition: at32f413_can.h:604
can_type::tx_mailbox
can_tx_mailbox_type tx_mailbox[3]
can controller area network tx mailbox register, offset:0x180~0x1AC
Definition: at32f413_can.h:779
can_type::tm1tcf
__IO uint32_t tm1tcf
Definition: at32f413_can.h:648
can_type::lben
__IO uint32_t lben
Definition: at32f413_can.h:766
can_type::ptd
__IO uint32_t ptd
Definition: at32f413_can.h:607
can_type::fzc
__IO uint32_t fzc
Definition: at32f413_can.h:620
can_type::ffb
can_filter_register_type ffb[14]
can ffb register, offset:0x240~0x2AC
Definition: at32f413_can.h:931
can_type::tm0ef
__IO uint32_t tm0ef
Definition: at32f413_can.h:661
can_type::bts2
__IO uint32_t bts2
Definition: at32f413_can.h:762
can_type::loen
__IO uint32_t loen
Definition: at32f413_can.h:767
can_type::ests
__IO uint32_t ests
Definition: at32f413_can.h:737
can_type::ests_bit
struct can_type::@249::@269 ests_bit
can_type::rf0_bit
struct can_type::@243::@266 rf0_bit
can_type::frf
__IO uint32_t frf
Definition: at32f413_can.h:871
can_type::rsaw
__IO uint32_t rsaw
Definition: at32f413_can.h:764
can_type::rf0
__IO uint32_t rf0
Definition: at32f413_can.h:675
can_type::tsts_bit
struct can_type::@241::@265 tsts_bit
can_type::rf1mn
__IO uint32_t rf1mn
Definition: at32f413_can.h:695
can_type::prsfen
__IO uint32_t prsfen
Definition: at32f413_can.h:601
can_type::btmg_bit
struct can_type::@251::@270 btmg_bit
can_type::facfg
__IO uint32_t facfg
Definition: at32f413_can.h:902
can_type::tm1ef
__IO uint32_t tm1ef
Definition: at32f413_can.h:662
can_type::aeboen
__IO uint32_t aeboen
Definition: at32f413_can.h:603
can_type::eoif
__IO uint32_t eoif
Definition: at32f413_can.h:622
can_type::tm2tcf
__IO uint32_t tm2tcf
Definition: at32f413_can.h:654
can_type::rf1_bit
struct can_type::@245::@267 rf1_bit
can_type::brdiv
__IO uint32_t brdiv
Definition: at32f413_can.h:759
can_type::epf
__IO uint32_t epf
Definition: at32f413_can.h:741
can_type::dzen
__IO uint32_t dzen
Definition: at32f413_can.h:598
can_type::etr
__IO uint32_t etr
Definition: at32f413_can.h:744
can_type::fifo_mailbox
can_fifo_mailbox_type fifo_mailbox[2]
can controller area network fifo mailbox register, offset:0x1B0~0x1CC
Definition: at32f413_can.h:784
can_type::tsts
__IO uint32_t tsts
Definition: at32f413_can.h:639
can_type::fbwcfg
__IO uint32_t fbwcfg
Definition: at32f413_can.h:840
can_type::qdzif
__IO uint32_t qdzif
Definition: at32f413_can.h:623
can_type::msts_bit
struct can_type::@239::@264 msts_bit
can_type::rf0mn
__IO uint32_t rf0mn
Definition: at32f413_can.h:678
can_type::rf0ff
__IO uint32_t rf0ff
Definition: at32f413_can.h:680
can_type::fcs
__IO uint32_t fcs
Definition: at32f413_can.h:799
can_type::msts
__IO uint32_t msts
Definition: at32f413_can.h:617
can_type::rec
__IO uint32_t rec
Definition: at32f413_can.h:747
can_type::bts1
__IO uint32_t bts1
Definition: at32f413_can.h:761
can_type::tm2tsf
__IO uint32_t tm2tsf
Definition: at32f413_can.h:655
can_type::rf1of
__IO uint32_t rf1of
Definition: at32f413_can.h:698
can_type::fzen
__IO uint32_t fzen
Definition: at32f413_can.h:597
can_type::mmssr
__IO uint32_t mmssr
Definition: at32f413_can.h:599
can_type::inten
__IO uint32_t inten
Definition: at32f413_can.h:709
can_type::fmcfg
__IO uint32_t fmcfg
Definition: at32f413_can.h:809
can_type::tm1tsf
__IO uint32_t tm1tsf
Definition: at32f413_can.h:649
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_can.h Source File

  • libraries
  • drivers
  • inc
at32f413_can.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CAN_H
29#define __AT32F413_CAN_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define FZC_TIMEOUT ((uint32_t)0x0000FFFF)
53#define DZC_TIMEOUT ((uint32_t)0x0000FFFF)
64#define CAN_EAF_FLAG ((uint32_t)0x01)
65#define CAN_EPF_FLAG ((uint32_t)0x02)
66#define CAN_BOF_FLAG ((uint32_t)0x03)
67#define CAN_ETR_FLAG ((uint32_t)0x04)
68#define CAN_EOIF_FLAG ((uint32_t)0x05)
69#define CAN_TM0TCF_FLAG ((uint32_t)0x06)
70#define CAN_TM1TCF_FLAG ((uint32_t)0x07)
71#define CAN_TM2TCF_FLAG ((uint32_t)0x08)
72#define CAN_RF0MN_FLAG ((uint32_t)0x09)
73#define CAN_RF0FF_FLAG ((uint32_t)0x0A)
74#define CAN_RF0OF_FLAG ((uint32_t)0x0B)
75#define CAN_RF1MN_FLAG ((uint32_t)0x0C)
76#define CAN_RF1FF_FLAG ((uint32_t)0x0D)
77#define CAN_RF1OF_FLAG ((uint32_t)0x0E)
78#define CAN_QDZIF_FLAG ((uint32_t)0x0F)
79#define CAN_EDZC_FLAG ((uint32_t)0x10)
80#define CAN_TMEF_FLAG ((uint32_t)0x11)
91#define CAN_TCIEN_INT ((uint32_t)0x00000001)
92#define CAN_RF0MIEN_INT ((uint32_t)0x00000002)
93#define CAN_RF0FIEN_INT ((uint32_t)0x00000004)
94#define CAN_RF0OIEN_INT ((uint32_t)0x00000008)
95#define CAN_RF1MIEN_INT ((uint32_t)0x00000010)
96#define CAN_RF1FIEN_INT ((uint32_t)0x00000020)
97#define CAN_RF1OIEN_INT ((uint32_t)0x00000040)
98#define CAN_EAIEN_INT ((uint32_t)0x00000100)
99#define CAN_EPIEN_INT ((uint32_t)0x00000200)
100#define CAN_BOIEN_INT ((uint32_t)0x00000400)
101#define CAN_ETRIEN_INT ((uint32_t)0x00000800)
102#define CAN_EOIEN_INT ((uint32_t)0x00008000)
103#define CAN_QDZIEN_INT ((uint32_t)0x00010000)
104#define CAN_EDZIEN_INT ((uint32_t)0x00020000)
113#define CAN_MSTS_EOIF_VAL ((uint32_t)0x00000004)
114#define CAN_MSTS_QDZIF_VAL ((uint32_t)0x00000008)
115#define CAN_MSTS_EDZIF_VAL ((uint32_t)0x00000010)
116#define CAN_TSTS_TM0TCF_VAL ((uint32_t)0x00000001)
117#define CAN_TSTS_TM1TCF_VAL ((uint32_t)0x00000100)
118#define CAN_TSTS_TM2TCF_VAL ((uint32_t)0x00010000)
119#define CAN_TSTS_TM0CT_VAL ((uint32_t)0x00000080)
120#define CAN_TSTS_TM1CT_VAL ((uint32_t)0x00008000)
121#define CAN_TSTS_TM2CT_VAL ((uint32_t)0x00800000)
122#define CAN_RF0_RF0FF_VAL ((uint32_t)0x00000008)
123#define CAN_RF0_RF0OF_VAL ((uint32_t)0x00000010)
124#define CAN_RF0_RF0R_VAL ((uint32_t)0x00000020)
125#define CAN_RF1_RF1FF_VAL ((uint32_t)0x00000008)
126#define CAN_RF1_RF1OF_VAL ((uint32_t)0x00000010)
127#define CAN_RF1_RF1R_VAL ((uint32_t)0x00000020)
136typedef enum
137{
138 CAN_FILTER_FIFO0 = 0x00,
139 CAN_FILTER_FIFO1 = 0x01
140} can_filter_fifo_type;
141
145typedef enum
146{
147 CAN_FILTER_MODE_ID_MASK = 0x00,
148 CAN_FILTER_MODE_ID_LIST = 0x01
149} can_filter_mode_type;
150
154typedef enum
155{
156 CAN_FILTER_16BIT = 0x00,
157 CAN_FILTER_32BIT = 0x01
158} can_filter_bit_width_type;
159
163typedef enum
164{
165 CAN_MODE_COMMUNICATE = 0x00,
166 CAN_MODE_LOOPBACK = 0x01,
167 CAN_MODE_LISTENONLY = 0x02,
168 CAN_MODE_LISTENONLY_LOOPBACK = 0x03
169} can_mode_type;
170
174typedef enum
175{
176 CAN_OPERATINGMODE_FREEZE = 0x00,
177 CAN_OPERATINGMODE_DOZE = 0x01,
178 CAN_OPERATINGMODE_COMMUNICATE = 0x02
179} can_operating_mode_type;
180
184typedef enum
185{
186 CAN_RSAW_1TQ = 0x00,
187 CAN_RSAW_2TQ = 0x01,
188 CAN_RSAW_3TQ = 0x02,
189 CAN_RSAW_4TQ = 0x03
190} can_rsaw_type;
191
195typedef enum
196{
197 CAN_BTS1_1TQ = 0x00,
198 CAN_BTS1_2TQ = 0x01,
199 CAN_BTS1_3TQ = 0x02,
200 CAN_BTS1_4TQ = 0x03,
201 CAN_BTS1_5TQ = 0x04,
202 CAN_BTS1_6TQ = 0x05,
203 CAN_BTS1_7TQ = 0x06,
204 CAN_BTS1_8TQ = 0x07,
205 CAN_BTS1_9TQ = 0x08,
206 CAN_BTS1_10TQ = 0x09,
207 CAN_BTS1_11TQ = 0x0A,
208 CAN_BTS1_12TQ = 0x0B,
209 CAN_BTS1_13TQ = 0x0C,
210 CAN_BTS1_14TQ = 0x0D,
211 CAN_BTS1_15TQ = 0x0E,
212 CAN_BTS1_16TQ = 0x0F
213} can_bts1_type;
214
218typedef enum
219{
220 CAN_BTS2_1TQ = 0x00,
221 CAN_BTS2_2TQ = 0x01,
222 CAN_BTS2_3TQ = 0x02,
223 CAN_BTS2_4TQ = 0x03,
224 CAN_BTS2_5TQ = 0x04,
225 CAN_BTS2_6TQ = 0x05,
226 CAN_BTS2_7TQ = 0x06,
227 CAN_BTS2_8TQ = 0x07
228} can_bts2_type;
229
233typedef enum
234{
235 CAN_ID_STANDARD = 0x00,
236 CAN_ID_EXTENDED = 0x01
237} can_identifier_type;
238
242typedef enum
243{
244 CAN_TFT_DATA = 0x00,
245 CAN_TFT_REMOTE = 0x01
246} can_trans_frame_type;
247
251typedef enum
252{
253 CAN_TX_MAILBOX0 = 0x00,
254 CAN_TX_MAILBOX1 = 0x01,
255 CAN_TX_MAILBOX2 = 0x02
256} can_tx_mailbox_num_type;
257
261typedef enum
262{
263 CAN_RX_FIFO0 = 0x00,
264 CAN_RX_FIFO1 = 0x01
265} can_rx_fifo_num_type;
266
270typedef enum
271{
272 CAN_TX_STATUS_FAILED = 0x00,
273 CAN_TX_STATUS_SUCCESSFUL = 0x01,
274 CAN_TX_STATUS_PENDING = 0x02,
275 CAN_TX_STATUS_NO_EMPTY = 0x04
276} can_transmit_status_type;
277
281typedef enum
282{
283 CAN_ENTER_DOZE_FAILED = 0x00,
284 CAN_ENTER_DOZE_SUCCESSFUL = 0x01
285} can_enter_doze_status_type;
286
290typedef enum
291{
292 CAN_QUIT_DOZE_FAILED = 0x00,
293 CAN_QUIT_DOZE_SUCCESSFUL = 0x01
294} can_quit_doze_status_type;
295
299typedef enum
300{
301 CAN_DISCARDING_FIRST_RECEIVED = 0x00,
302 CAN_DISCARDING_LAST_RECEIVED = 0x01
303} can_msg_discarding_rule_type;
304
308typedef enum
309{
310 CAN_SENDING_BY_ID = 0x00,
311 CAN_SENDING_BY_REQUEST = 0x01
312} can_msg_sending_rule_type;
313
317typedef enum
318{
319 CAN_ERRORRECORD_NOERR = 0x00,
320 CAN_ERRORRECORD_STUFFERR = 0x01,
321 CAN_ERRORRECORD_FORMERR = 0x02,
322 CAN_ERRORRECORD_ACKERR = 0x03,
323 CAN_ERRORRECORD_BITRECESSIVEERR = 0x04,
324 CAN_ERRORRECORD_BITDOMINANTERR = 0x05,
325 CAN_ERRORRECORD_CRCERR = 0x06,
326 CAN_ERRORRECORD_SOFTWARESETERR = 0x07
327} can_error_record_type;
328
332typedef struct
333{
334 can_mode_type mode_selection;
336 confirm_state ttc_enable;
338 confirm_state aebo_enable;
340 confirm_state aed_enable;
342 confirm_state prsf_enable;
344 can_msg_discarding_rule_type mdrsel_selection;
346 can_msg_sending_rule_type mmssr_selection;
348} can_base_type;
349
353typedef struct
354{
355 uint16_t baudrate_div;
357 can_rsaw_type rsaw_size;
359 can_bts1_type bts1_size;
361 can_bts2_type bts2_size;
363} can_baudrate_type;
364
368typedef struct
369{
370 confirm_state filter_activate_enable;
372 can_filter_mode_type filter_mode;
374 can_filter_fifo_type filter_fifo;
376 uint8_t filter_number;
378 can_filter_bit_width_type filter_bit;
380 uint16_t filter_id_high;
383 uint16_t filter_id_low;
386 uint16_t filter_mask_high;
389 uint16_t filter_mask_low;
391} can_filter_init_type;
392
396typedef struct
397{
398 uint32_t standard_id;
401 uint32_t extended_id;
404 can_identifier_type id_type;
406 can_trans_frame_type frame_type;
408 uint8_t dlc;
411 uint8_t data[8];
413} can_tx_message_type;
414
418typedef struct
419{
420 uint32_t standard_id;
423 uint32_t extended_id;
426 can_identifier_type id_type;
428 can_trans_frame_type frame_type;
430 uint8_t dlc;
433 uint8_t data[8];
435 uint8_t filter_index;
437} can_rx_message_type;
438
442typedef struct
443{
447 union
448 {
449 __IO uint32_t tmi;
450 struct
451 {
452 __IO uint32_t tmsr : 1; /* [0] */
453 __IO uint32_t tmfrsel : 1; /* [1] */
454 __IO uint32_t tmidsel : 1; /* [2] */
455 __IO uint32_t tmeid : 18;/* [20:3] */
456 __IO uint32_t tmsid : 11;/* [31:21] */
457 } tmi_bit;
458 };
459
463 union
464 {
465 __IO uint32_t tmc;
466 struct
467 {
468 __IO uint32_t tmdtbl : 4; /* [3:0] */
469 __IO uint32_t reserved1 : 4; /* [7:4] */
470 __IO uint32_t tmtsten : 1; /* [8] */
471 __IO uint32_t reserved2 : 7; /* [15:9] */
472 __IO uint32_t tmts : 16;/* [31:16] */
473 } tmc_bit;
474 };
475
479 union
480 {
481 __IO uint32_t tmdtl;
482 struct
483 {
484 __IO uint32_t tmdt0 : 8; /* [7:0] */
485 __IO uint32_t tmdt1 : 8; /* [15:8] */
486 __IO uint32_t tmdt2 : 8; /* [23:16] */
487 __IO uint32_t tmdt3 : 8; /* [31:24] */
488 } tmdtl_bit;
489 };
490
494 union
495 {
496 __IO uint32_t tmdth;
497 struct
498 {
499 __IO uint32_t tmdt4 : 8; /* [7:0] */
500 __IO uint32_t tmdt5 : 8; /* [15:8] */
501 __IO uint32_t tmdt6 : 8; /* [23:16] */
502 __IO uint32_t tmdt7 : 8; /* [31:24] */
503 } tmdth_bit;
504 };
505} can_tx_mailbox_type;
506
510typedef struct
511{
515 union
516 {
517 __IO uint32_t rfi;
518 struct
519 {
520 __IO uint32_t reserved1 : 1; /* [0] */
521 __IO uint32_t rffri : 1; /* [1] */
522 __IO uint32_t rfidi : 1; /* [2] */
523 __IO uint32_t rfeid : 18;/* [20:3] */
524 __IO uint32_t rfsid : 11;/* [31:21] */
525 } rfi_bit;
526 };
527
531 union
532 {
533 __IO uint32_t rfc;
534 struct
535 {
536 __IO uint32_t rfdtl : 4; /* [3:0] */
537 __IO uint32_t reserved1 : 4; /* [7:4] */
538 __IO uint32_t rffmn : 8; /* [15:8] */
539 __IO uint32_t rfts : 16;/* [31:16] */
540 } rfc_bit;
541 };
542
546 union
547 {
548 __IO uint32_t rfdtl;
549 struct
550 {
551 __IO uint32_t rfdt0 : 8; /* [7:0] */
552 __IO uint32_t rfdt1 : 8; /* [15:8] */
553 __IO uint32_t rfdt2 : 8; /* [23:16] */
554 __IO uint32_t rfdt3 : 8; /* [31:24] */
555 } rfdtl_bit;
556 };
557
561 union
562 {
563 __IO uint32_t rfdth;
564 struct
565 {
566 __IO uint32_t rfdt4 : 8; /* [7:0] */
567 __IO uint32_t rfdt5 : 8; /* [15:8] */
568 __IO uint32_t rfdt6 : 8; /* [23:16] */
569 __IO uint32_t rfdt7 : 8; /* [31:24] */
570 } rfdth_bit;
571 };
572} can_fifo_mailbox_type;
573
577typedef struct
578{
579 __IO uint32_t ffdb1;
580 __IO uint32_t ffdb2;
581} can_filter_register_type;
582
586typedef struct
587{
588
592 union
593 {
594 __IO uint32_t mctrl;
595 struct
596 {
597 __IO uint32_t fzen : 1; /* [0] */
598 __IO uint32_t dzen : 1; /* [1] */
599 __IO uint32_t mmssr : 1; /* [2] */
600 __IO uint32_t mdrsel : 1; /* [3] */
601 __IO uint32_t prsfen : 1; /* [4] */
602 __IO uint32_t aeden : 1; /* [5] */
603 __IO uint32_t aeboen : 1; /* [6] */
604 __IO uint32_t ttcen : 1; /* [7] */
605 __IO uint32_t reserved1 : 7; /* [14:8] */
606 __IO uint32_t sprst : 1; /* [15] */
607 __IO uint32_t ptd : 1; /* [16] */
608 __IO uint32_t reserved2 : 15;/*[31:17] */
609 } mctrl_bit;
610 };
611
615 union
616 {
617 __IO uint32_t msts;
618 struct
619 {
620 __IO uint32_t fzc : 1; /* [0] */
621 __IO uint32_t dzc : 1; /* [1] */
622 __IO uint32_t eoif : 1; /* [2] */
623 __IO uint32_t qdzif : 1; /* [3] */
624 __IO uint32_t edzif : 1; /* [4] */
625 __IO uint32_t reserved1 : 3; /* [7:5] */
626 __IO uint32_t cuss : 1; /* [8] */
627 __IO uint32_t curs : 1; /* [9] */
628 __IO uint32_t lsamprx : 1; /* [10] */
629 __IO uint32_t realrx : 1; /* [11] */
630 __IO uint32_t reserved2 : 20;/*[31:12] */
631 } msts_bit;
632 };
633
637 union
638 {
639 __IO uint32_t tsts;
640 struct
641 {
642 __IO uint32_t tm0tcf : 1; /* [0] */
643 __IO uint32_t tm0tsf : 1; /* [1] */
644 __IO uint32_t tm0alf : 1; /* [2] */
645 __IO uint32_t tm0tef : 1; /* [3] */
646 __IO uint32_t reserved1 : 3; /* [6:4] */
647 __IO uint32_t tm0ct : 1; /* [7] */
648 __IO uint32_t tm1tcf : 1; /* [8] */
649 __IO uint32_t tm1tsf : 1; /* [9] */
650 __IO uint32_t tm1alf : 1; /* [10] */
651 __IO uint32_t tm1tef : 1; /* [11] */
652 __IO uint32_t reserved2 : 3; /* [14:12] */
653 __IO uint32_t tm1ct : 1; /* [15] */
654 __IO uint32_t tm2tcf : 1; /* [16] */
655 __IO uint32_t tm2tsf : 1; /* [17] */
656 __IO uint32_t tm2alf : 1; /* [18] */
657 __IO uint32_t tm2tef : 1; /* [19] */
658 __IO uint32_t reserved3 : 3; /* [22:20] */
659 __IO uint32_t tm2ct : 1; /* [23] */
660 __IO uint32_t tmnr : 2; /* [25:24] */
661 __IO uint32_t tm0ef : 1; /* [26] */
662 __IO uint32_t tm1ef : 1; /* [27] */
663 __IO uint32_t tm2ef : 1; /* [28] */
664 __IO uint32_t tm0lpf : 1; /* [29] */
665 __IO uint32_t tm1lpf : 1; /* [30] */
666 __IO uint32_t tm2lpf : 1; /* [31] */
667 } tsts_bit;
668 };
669
673 union
674 {
675 __IO uint32_t rf0;
676 struct
677 {
678 __IO uint32_t rf0mn : 2; /* [1:0] */
679 __IO uint32_t reserved1 : 1; /* [2] */
680 __IO uint32_t rf0ff : 1; /* [3] */
681 __IO uint32_t rf0of : 1; /* [4] */
682 __IO uint32_t rf0r : 1; /* [5] */
683 __IO uint32_t reserved2 : 26;/* [31:6] */
684 } rf0_bit;
685 };
686
690 union
691 {
692 __IO uint32_t rf1;
693 struct
694 {
695 __IO uint32_t rf1mn : 2; /* [1:0] */
696 __IO uint32_t reserved1 : 1; /* [2] */
697 __IO uint32_t rf1ff : 1; /* [3] */
698 __IO uint32_t rf1of : 1; /* [4] */
699 __IO uint32_t rf1r : 1; /* [5] */
700 __IO uint32_t reserved2 : 26;/* [31:6] */
701 } rf1_bit;
702 };
703
707 union
708 {
709 __IO uint32_t inten;
710 struct
711 {
712 __IO uint32_t tcien : 1; /* [0] */
713 __IO uint32_t rf0mien : 1; /* [1] */
714 __IO uint32_t rf0fien : 1; /* [2] */
715 __IO uint32_t rf0oien : 1; /* [3] */
716 __IO uint32_t rf1mien : 1; /* [4] */
717 __IO uint32_t rf1fien : 1; /* [5] */
718 __IO uint32_t rf1oien : 1; /* [6] */
719 __IO uint32_t reserved1 : 1; /* [7] */
720 __IO uint32_t eaien : 1; /* [8] */
721 __IO uint32_t epien : 1; /* [9] */
722 __IO uint32_t boien : 1; /* [10] */
723 __IO uint32_t etrien : 1; /* [11] */
724 __IO uint32_t reserved2 : 3; /* [14:12] */
725 __IO uint32_t eoien : 1; /* [15] */
726 __IO uint32_t qdzien : 1; /* [16] */
727 __IO uint32_t edzien : 1; /* [17] */
728 __IO uint32_t reserved3 : 14;/* [31:18] */
729 } inten_bit;
730 };
731
735 union
736 {
737 __IO uint32_t ests;
738 struct
739 {
740 __IO uint32_t eaf : 1; /* [0] */
741 __IO uint32_t epf : 1; /* [1] */
742 __IO uint32_t bof : 1; /* [2] */
743 __IO uint32_t reserved1 : 1; /* [3] */
744 __IO uint32_t etr : 3; /* [6:4] */
745 __IO uint32_t reserved2 : 9; /* [15:7] */
746 __IO uint32_t tec : 8; /* [23:16] */
747 __IO uint32_t rec : 8; /* [31:24] */
748 } ests_bit;
749 };
750
754 union
755 {
756 __IO uint32_t btmg;
757 struct
758 {
759 __IO uint32_t brdiv : 12;/* [11:0] */
760 __IO uint32_t reserved1 : 4; /* [15:12] */
761 __IO uint32_t bts1 : 4; /* [19:16] */
762 __IO uint32_t bts2 : 3; /* [22:20] */
763 __IO uint32_t reserved2 : 1; /* [23] */
764 __IO uint32_t rsaw : 2; /* [25:24] */
765 __IO uint32_t reserved3 : 4; /* [29:26] */
766 __IO uint32_t lben : 1; /* [30] */
767 __IO uint32_t loen : 1; /* [31] */
768 } btmg_bit;
769 };
770
774 __IO uint32_t reserved1[88];
775
779 can_tx_mailbox_type tx_mailbox[3];
780
784 can_fifo_mailbox_type fifo_mailbox[2];
785
789 __IO uint32_t reserved2[12];
790
794 union
795 {
796 __IO uint32_t fctrl;
797 struct
798 {
799 __IO uint32_t fcs : 1; /* [0] */
800 __IO uint32_t reserved1 : 31;/* [31:1] */
801 } fctrl_bit;
802 };
803
807 union
808 {
809 __IO uint32_t fmcfg;
810 struct
811 {
812 __IO uint32_t fmsel0 : 1; /* [0] */
813 __IO uint32_t fmsel1 : 1; /* [1] */
814 __IO uint32_t fmsel2 : 1; /* [2] */
815 __IO uint32_t fmsel3 : 1; /* [3] */
816 __IO uint32_t fmsel4 : 1; /* [4] */
817 __IO uint32_t fmsel5 : 1; /* [5] */
818 __IO uint32_t fmsel6 : 1; /* [6] */
819 __IO uint32_t fmsel7 : 1; /* [7] */
820 __IO uint32_t fmsel8 : 1; /* [8] */
821 __IO uint32_t fmsel9 : 1; /* [9] */
822 __IO uint32_t fmsel10 : 1; /* [10] */
823 __IO uint32_t fmsel11 : 1; /* [11] */
824 __IO uint32_t fmsel12 : 1; /* [12] */
825 __IO uint32_t fmsel13 : 1; /* [13] */
826 __IO uint32_t reserved1 : 18;/* [31:14] */
827 } fmcfg_bit;
828 };
829
833 __IO uint32_t reserved3;
834
838 union
839 {
840 __IO uint32_t fbwcfg;
841 struct
842 {
843 __IO uint32_t fbwsel0 : 1; /* [0] */
844 __IO uint32_t fbwsel1 : 1; /* [1] */
845 __IO uint32_t fbwsel2 : 1; /* [2] */
846 __IO uint32_t fbwsel3 : 1; /* [3] */
847 __IO uint32_t fbwsel4 : 1; /* [4] */
848 __IO uint32_t fbwsel5 : 1; /* [5] */
849 __IO uint32_t fbwsel6 : 1; /* [6] */
850 __IO uint32_t fbwsel7 : 1; /* [7] */
851 __IO uint32_t fbwsel8 : 1; /* [8] */
852 __IO uint32_t fbwsel9 : 1; /* [9] */
853 __IO uint32_t fbwsel10 : 1; /* [10] */
854 __IO uint32_t fbwsel11 : 1; /* [11] */
855 __IO uint32_t fbwsel12 : 1; /* [12] */
856 __IO uint32_t fbwsel13 : 1; /* [13] */
857 __IO uint32_t reserved1 : 18;/* [31:14] */
858 } fbwcfg_bit;
859 };
860
864 __IO uint32_t reserved4;
865
869 union
870 {
871 __IO uint32_t frf;
872 struct
873 {
874 __IO uint32_t frfsel0 : 1; /* [0] */
875 __IO uint32_t frfsel1 : 1; /* [1] */
876 __IO uint32_t frfsel2 : 1; /* [2] */
877 __IO uint32_t frfsel3 : 1; /* [3] */
878 __IO uint32_t frfsel4 : 1; /* [4] */
879 __IO uint32_t frfsel5 : 1; /* [5] */
880 __IO uint32_t frfsel6 : 1; /* [6] */
881 __IO uint32_t frfsel7 : 1; /* [7] */
882 __IO uint32_t frfsel8 : 1; /* [8] */
883 __IO uint32_t frfsel9 : 1; /* [9] */
884 __IO uint32_t frfsel10 : 1; /* [10] */
885 __IO uint32_t frfsel11 : 1; /* [11] */
886 __IO uint32_t frfsel12 : 1; /* [12] */
887 __IO uint32_t frfsel13 : 1; /* [13] */
888 __IO uint32_t reserved1 : 18;/* [31:14] */
889 } frf_bit;
890 };
891
895 __IO uint32_t reserved5;
896
900 union
901 {
902 __IO uint32_t facfg;
903 struct
904 {
905 __IO uint32_t faen0 : 1; /* [0] */
906 __IO uint32_t faen1 : 1; /* [1] */
907 __IO uint32_t faen2 : 1; /* [2] */
908 __IO uint32_t faen3 : 1; /* [3] */
909 __IO uint32_t faen4 : 1; /* [4] */
910 __IO uint32_t faen5 : 1; /* [5] */
911 __IO uint32_t faen6 : 1; /* [6] */
912 __IO uint32_t faen7 : 1; /* [7] */
913 __IO uint32_t faen8 : 1; /* [8] */
914 __IO uint32_t faen9 : 1; /* [9] */
915 __IO uint32_t faen10 : 1; /* [10] */
916 __IO uint32_t faen11 : 1; /* [11] */
917 __IO uint32_t faen12 : 1; /* [12] */
918 __IO uint32_t faen13 : 1; /* [13] */
919 __IO uint32_t reserved1 : 18;/* [31:14] */
920 } facfg_bit;
921 };
922
926 __IO uint32_t reserved6[8];
927
931 can_filter_register_type ffb[14];
932} can_type;
933
938#define CAN1 ((can_type *) CAN1_BASE)
939#define CAN2 ((can_type *) CAN2_BASE)
940
945void can_reset(can_type* can_x);
946void can_baudrate_default_para_init(can_baudrate_type* can_baudrate_struct);
947 error_status can_baudrate_set(can_type* can_x, can_baudrate_type* can_baudrate_struct);
948void can_default_para_init(can_base_type* can_base_struct);
949 error_status can_base_init(can_type* can_x, can_base_type* can_base_struct);
950void can_filter_default_para_init(can_filter_init_type* can_filter_init_struct);
951void can_filter_init(can_type* can_x, can_filter_init_type* can_filter_init_struct);
952void can_debug_transmission_prohibit(can_type* can_x, confirm_state new_state);
953void can_ttc_mode_enable(can_type* can_x, confirm_state new_state);
954uint8_t can_message_transmit(can_type* can_x, can_tx_message_type* tx_message_struct);
955 can_transmit_status_type can_transmit_status_get(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox);
956void can_transmit_cancel(can_type* can_x, can_tx_mailbox_num_type transmit_mailbox);
957void can_message_receive(can_type* can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type* rx_message_struct);
958void can_receive_fifo_release(can_type* can_x, can_rx_fifo_num_type fifo_number);
959uint8_t can_receive_message_pending_get(can_type* can_x, can_rx_fifo_num_type fifo_number);
960 error_status can_operating_mode_set(can_type* can_x, can_operating_mode_type can_operating_mode);
961 can_enter_doze_status_type can_doze_mode_enter(can_type* can_x);
962 can_quit_doze_status_type can_doze_mode_exit(can_type* can_x);
963 can_error_record_type can_error_type_record_get(can_type* can_x);
964uint8_t can_receive_error_counter_get(can_type* can_x);
965uint8_t can_transmit_error_counter_get(can_type* can_x);
966void can_interrupt_enable(can_type* can_x, uint32_t can_int, confirm_state new_state);
967 flag_status can_flag_get(can_type* can_x, uint32_t can_flag);
968void can_flag_clear(can_type* can_x, uint32_t can_flag);
969
982#ifdef __cplusplus
983}
984#endif
985
986#endif
at32f413.h
at32f413 header file
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:194
can_reset
void can_reset(can_type *can_x)
deinitialize the can peripheral registers to their default reset values.
Definition: at32f413_can.c:51
can_transmit_error_counter_get
uint8_t can_transmit_error_counter_get(can_type *can_x)
return the transmit error counter of the specified can peripheral.
Definition: at32f413_can.c:892
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:514
can_ttc_mode_enable
void can_ttc_mode_enable(can_type *can_x, confirm_state new_state)
enable or disable time trigger operation communication mode of the specified can peripheral.
Definition: at32f413_can.c:416
can_filter_default_para_init
void can_filter_default_para_init(can_filter_init_type *can_filter_init_struct)
fill each can_filter_init_struct member with its default value.
Definition: at32f413_can.c:269
can_receive_fifo_release
void can_receive_fifo_release(can_type *can_x, can_rx_fifo_num_type fifo_number)
release the specified fifo of the specified can peripheral.
Definition: at32f413_can.c:666
can_receive_error_counter_get
uint8_t can_receive_error_counter_get(can_type *can_x)
return the receive error counter (rec) of the specified can peripheral.
Definition: at32f413_can.c:878
can_operating_mode_set
error_status can_operating_mode_set(can_type *can_x, can_operating_mode_type can_operating_mode)
set the operation mode of the specified can peripheral.
Definition: at32f413_can.c:723
can_baudrate_default_para_init
void can_baudrate_default_para_init(can_baudrate_type *can_baudrate_struct)
fill each can_baudrate_struct member with its default value.
Definition: at32f413_can.c:70
can_transmit_cancel
void can_transmit_cancel(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
cancel a transmit request of the specified can peripheral.
Definition: at32f413_can.c:589
can_receive_message_pending_get
uint8_t can_receive_message_pending_get(can_type *can_x, can_rx_fifo_num_type fifo_number)
return the number of pending messages of the specified can peripheral.
Definition: at32f413_can.c:692
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1088
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:99
can_debug_transmission_prohibit
void can_debug_transmission_prohibit(can_type *can_x, confirm_state new_state)
enable or disable the debug transmission prohibit of the specified can peripheral.
Definition: at32f413_can.c:395
can_error_type_record_get
can_error_record_type can_error_type_record_get(can_type *can_x)
return the error type record (etr) of the specified can peripheral.
Definition: at32f413_can.c:863
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:157
can_doze_mode_exit
can_quit_doze_status_type can_doze_mode_exit(can_type *can_x)
exit the doze mode of the specified can peripheral.
Definition: at32f413_can.c:831
can_doze_mode_enter
can_enter_doze_status_type can_doze_mode_enter(can_type *can_x)
enter the low power mode of the specified can peripheral.
Definition: at32f413_can.c:801
can_filter_fifo_type
can_filter_fifo_type
can filter fifo
Definition: at32f413_can.h:137
can_transmit_status_type
can_transmit_status_type
can transmit status
Definition: at32f413_can.h:271
can_msg_discarding_rule_type
can_msg_discarding_rule_type
can message discarding rule select when overflow
Definition: at32f413_can.h:300
can_bts2_type
can_bts2_type
can bit time segment 2
Definition: at32f413_can.h:219
can_quit_doze_status_type
can_quit_doze_status_type
can quit doze mode status
Definition: at32f413_can.h:291
can_trans_frame_type
can_trans_frame_type
can transmission frame type
Definition: at32f413_can.h:243
can_bts1_type
can_bts1_type
can bit time segment 1
Definition: at32f413_can.h:196
can_error_record_type
can_error_record_type
can error type record
Definition: at32f413_can.h:318
can_filter_mode_type
can_filter_mode_type
can filter mode
Definition: at32f413_can.h:146
can_operating_mode_type
can_operating_mode_type
can operating mode
Definition: at32f413_can.h:175
can_msg_sending_rule_type
can_msg_sending_rule_type
can multiple message sending sequence rule
Definition: at32f413_can.h:309
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:252
can_filter_bit_width_type
can_filter_bit_width_type
can filter bit width select
Definition: at32f413_can.h:155
can_enter_doze_status_type
can_enter_doze_status_type
can enter doze mode status
Definition: at32f413_can.h:282
can_rx_fifo_num_type
can_rx_fifo_num_type
can receive fifo
Definition: at32f413_can.h:262
can_identifier_type
can_identifier_type
can identifier type
Definition: at32f413_can.h:234
can_mode_type
can_mode_type
can mode
Definition: at32f413_can.h:164
can_rsaw_type
can_rsaw_type
can resynchronization adjust width
Definition: at32f413_can.h:185
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:138
CAN_FILTER_FIFO1
@ CAN_FILTER_FIFO1
Definition: at32f413_can.h:139
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:273
CAN_TX_STATUS_PENDING
@ CAN_TX_STATUS_PENDING
Definition: at32f413_can.h:274
CAN_TX_STATUS_NO_EMPTY
@ CAN_TX_STATUS_NO_EMPTY
Definition: at32f413_can.h:275
CAN_TX_STATUS_FAILED
@ CAN_TX_STATUS_FAILED
Definition: at32f413_can.h:272
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:301
CAN_DISCARDING_LAST_RECEIVED
@ CAN_DISCARDING_LAST_RECEIVED
Definition: at32f413_can.h:302
CAN_BTS2_4TQ
@ CAN_BTS2_4TQ
Definition: at32f413_can.h:223
CAN_BTS2_2TQ
@ CAN_BTS2_2TQ
Definition: at32f413_can.h:221
CAN_BTS2_5TQ
@ CAN_BTS2_5TQ
Definition: at32f413_can.h:224
CAN_BTS2_6TQ
@ CAN_BTS2_6TQ
Definition: at32f413_can.h:225
CAN_BTS2_7TQ
@ CAN_BTS2_7TQ
Definition: at32f413_can.h:226
CAN_BTS2_8TQ
@ CAN_BTS2_8TQ
Definition: at32f413_can.h:227
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:222
CAN_BTS2_1TQ
@ CAN_BTS2_1TQ
Definition: at32f413_can.h:220
CAN_QUIT_DOZE_FAILED
@ CAN_QUIT_DOZE_FAILED
Definition: at32f413_can.h:292
CAN_QUIT_DOZE_SUCCESSFUL
@ CAN_QUIT_DOZE_SUCCESSFUL
Definition: at32f413_can.h:293
CAN_TFT_REMOTE
@ CAN_TFT_REMOTE
Definition: at32f413_can.h:245
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f413_can.h:244
CAN_BTS1_7TQ
@ CAN_BTS1_7TQ
Definition: at32f413_can.h:203
CAN_BTS1_1TQ
@ CAN_BTS1_1TQ
Definition: at32f413_can.h:197
CAN_BTS1_14TQ
@ CAN_BTS1_14TQ
Definition: at32f413_can.h:210
CAN_BTS1_4TQ
@ CAN_BTS1_4TQ
Definition: at32f413_can.h:200
CAN_BTS1_15TQ
@ CAN_BTS1_15TQ
Definition: at32f413_can.h:211
CAN_BTS1_11TQ
@ CAN_BTS1_11TQ
Definition: at32f413_can.h:207
CAN_BTS1_10TQ
@ CAN_BTS1_10TQ
Definition: at32f413_can.h:206
CAN_BTS1_16TQ
@ CAN_BTS1_16TQ
Definition: at32f413_can.h:212
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f413_can.h:204
CAN_BTS1_3TQ
@ CAN_BTS1_3TQ
Definition: at32f413_can.h:199
CAN_BTS1_12TQ
@ CAN_BTS1_12TQ
Definition: at32f413_can.h:208
CAN_BTS1_9TQ
@ CAN_BTS1_9TQ
Definition: at32f413_can.h:205
CAN_BTS1_5TQ
@ CAN_BTS1_5TQ
Definition: at32f413_can.h:201
CAN_BTS1_6TQ
@ CAN_BTS1_6TQ
Definition: at32f413_can.h:202
CAN_BTS1_2TQ
@ CAN_BTS1_2TQ
Definition: at32f413_can.h:198
CAN_BTS1_13TQ
@ CAN_BTS1_13TQ
Definition: at32f413_can.h:209
CAN_ERRORRECORD_CRCERR
@ CAN_ERRORRECORD_CRCERR
Definition: at32f413_can.h:325
CAN_ERRORRECORD_FORMERR
@ CAN_ERRORRECORD_FORMERR
Definition: at32f413_can.h:321
CAN_ERRORRECORD_BITDOMINANTERR
@ CAN_ERRORRECORD_BITDOMINANTERR
Definition: at32f413_can.h:324
CAN_ERRORRECORD_BITRECESSIVEERR
@ CAN_ERRORRECORD_BITRECESSIVEERR
Definition: at32f413_can.h:323
CAN_ERRORRECORD_NOERR
@ CAN_ERRORRECORD_NOERR
Definition: at32f413_can.h:319
CAN_ERRORRECORD_STUFFERR
@ CAN_ERRORRECORD_STUFFERR
Definition: at32f413_can.h:320
CAN_ERRORRECORD_SOFTWARESETERR
@ CAN_ERRORRECORD_SOFTWARESETERR
Definition: at32f413_can.h:326
CAN_ERRORRECORD_ACKERR
@ CAN_ERRORRECORD_ACKERR
Definition: at32f413_can.h:322
CAN_FILTER_MODE_ID_LIST
@ CAN_FILTER_MODE_ID_LIST
Definition: at32f413_can.h:148
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f413_can.h:147
CAN_OPERATINGMODE_FREEZE
@ CAN_OPERATINGMODE_FREEZE
Definition: at32f413_can.h:176
CAN_OPERATINGMODE_COMMUNICATE
@ CAN_OPERATINGMODE_COMMUNICATE
Definition: at32f413_can.h:178
CAN_OPERATINGMODE_DOZE
@ CAN_OPERATINGMODE_DOZE
Definition: at32f413_can.h:177
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:310
CAN_SENDING_BY_REQUEST
@ CAN_SENDING_BY_REQUEST
Definition: at32f413_can.h:311
CAN_TX_MAILBOX2
@ CAN_TX_MAILBOX2
Definition: at32f413_can.h:255
CAN_TX_MAILBOX0
@ CAN_TX_MAILBOX0
Definition: at32f413_can.h:253
CAN_TX_MAILBOX1
@ CAN_TX_MAILBOX1
Definition: at32f413_can.h:254
CAN_FILTER_16BIT
@ CAN_FILTER_16BIT
Definition: at32f413_can.h:156
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:157
CAN_ENTER_DOZE_FAILED
@ CAN_ENTER_DOZE_FAILED
Definition: at32f413_can.h:283
CAN_ENTER_DOZE_SUCCESSFUL
@ CAN_ENTER_DOZE_SUCCESSFUL
Definition: at32f413_can.h:284
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:263
CAN_RX_FIFO1
@ CAN_RX_FIFO1
Definition: at32f413_can.h:264
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:235
CAN_ID_EXTENDED
@ CAN_ID_EXTENDED
Definition: at32f413_can.h:236
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f413_can.h:165
CAN_MODE_LISTENONLY
@ CAN_MODE_LISTENONLY
Definition: at32f413_can.h:167
CAN_MODE_LISTENONLY_LOOPBACK
@ CAN_MODE_LISTENONLY_LOOPBACK
Definition: at32f413_can.h:168
CAN_MODE_LOOPBACK
@ CAN_MODE_LOOPBACK
Definition: at32f413_can.h:166
CAN_RSAW_1TQ
@ CAN_RSAW_1TQ
Definition: at32f413_can.h:186
CAN_RSAW_4TQ
@ CAN_RSAW_4TQ
Definition: at32f413_can.h:189
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f413_can.h:188
CAN_RSAW_2TQ
@ CAN_RSAW_2TQ
Definition: at32f413_can.h:187
error_status
error_status
error status
Definition: at32f413.h:264
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
can_base_type
can init structure definition
Definition: at32f413_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:359
can_fifo_mailbox_type
can controller area network fifo mailbox
Definition: at32f413_can.h:511
can_fifo_mailbox_type::rfdt4
__IO uint32_t rfdt4
Definition: at32f413_can.h:566
can_fifo_mailbox_type::rfi
__IO uint32_t rfi
Definition: at32f413_can.h:517
can_fifo_mailbox_type::rfdt0
__IO uint32_t rfdt0
Definition: at32f413_can.h:551
can_fifo_mailbox_type::rfsid
__IO uint32_t rfsid
Definition: at32f413_can.h:524
can_fifo_mailbox_type::rfdt2
__IO uint32_t rfdt2
Definition: at32f413_can.h:553
can_fifo_mailbox_type::rfdth
__IO uint32_t rfdth
Definition: at32f413_can.h:563
can_fifo_mailbox_type::rfdtl
__IO uint32_t rfdtl
Definition: at32f413_can.h:536
can_fifo_mailbox_type::rfidi
__IO uint32_t rfidi
Definition: at32f413_can.h:522
can_fifo_mailbox_type::rfdt1
__IO uint32_t rfdt1
Definition: at32f413_can.h:552
can_fifo_mailbox_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_can.h:520
can_fifo_mailbox_type::rfdt6
__IO uint32_t rfdt6
Definition: at32f413_can.h:568
can_fifo_mailbox_type::rffri
__IO uint32_t rffri
Definition: at32f413_can.h:521
can_fifo_mailbox_type::rfc
__IO uint32_t rfc
Definition: at32f413_can.h:533
can_fifo_mailbox_type::rfdt3
__IO uint32_t rfdt3
Definition: at32f413_can.h:554
can_fifo_mailbox_type::rfdt5
__IO uint32_t rfdt5
Definition: at32f413_can.h:567
can_fifo_mailbox_type::rfdt7
__IO uint32_t rfdt7
Definition: at32f413_can.h:569
can_fifo_mailbox_type::rfts
__IO uint32_t rfts
Definition: at32f413_can.h:539
can_fifo_mailbox_type::rffmn
__IO uint32_t rffmn
Definition: at32f413_can.h:538
can_fifo_mailbox_type::rfeid
__IO uint32_t rfeid
Definition: at32f413_can.h:523
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:383
can_filter_register_type
can controller area network filter bit register
Definition: at32f413_can.h:578
can_filter_register_type::ffdb1
__IO uint32_t ffdb1
Definition: at32f413_can.h:579
can_filter_register_type::ffdb2
__IO uint32_t ffdb2
Definition: at32f413_can.h:580
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:420
can_rx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:426
can_rx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:428
can_rx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:430
can_rx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:423
can_rx_message_type::filter_index
uint8_t filter_index
Definition: at32f413_can.h:435
can_tx_mailbox_type
can controller area network tx mailbox
Definition: at32f413_can.h:443
can_tx_mailbox_type::tmdt5
__IO uint32_t tmdt5
Definition: at32f413_can.h:500
can_tx_mailbox_type::tmtsten
__IO uint32_t tmtsten
Definition: at32f413_can.h:470
can_tx_mailbox_type::tmi
__IO uint32_t tmi
Definition: at32f413_can.h:449
can_tx_mailbox_type::tmc
__IO uint32_t tmc
Definition: at32f413_can.h:465
can_tx_mailbox_type::tmts
__IO uint32_t tmts
Definition: at32f413_can.h:472
can_tx_mailbox_type::tmdt0
__IO uint32_t tmdt0
Definition: at32f413_can.h:484
can_tx_mailbox_type::tmsr
__IO uint32_t tmsr
Definition: at32f413_can.h:452
can_tx_mailbox_type::tmdtl
__IO uint32_t tmdtl
Definition: at32f413_can.h:481
can_tx_mailbox_type::tmdt2
__IO uint32_t tmdt2
Definition: at32f413_can.h:486
can_tx_mailbox_type::tmdtbl
__IO uint32_t tmdtbl
Definition: at32f413_can.h:468
can_tx_mailbox_type::tmdt3
__IO uint32_t tmdt3
Definition: at32f413_can.h:487
can_tx_mailbox_type::tmdt1
__IO uint32_t tmdt1
Definition: at32f413_can.h:485
can_tx_mailbox_type::tmdt4
__IO uint32_t tmdt4
Definition: at32f413_can.h:499
can_tx_mailbox_type::tmfrsel
__IO uint32_t tmfrsel
Definition: at32f413_can.h:453
can_tx_mailbox_type::tmsid
__IO uint32_t tmsid
Definition: at32f413_can.h:456
can_tx_mailbox_type::tmdt6
__IO uint32_t tmdt6
Definition: at32f413_can.h:501
can_tx_mailbox_type::tmdth
__IO uint32_t tmdth
Definition: at32f413_can.h:496
can_tx_mailbox_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_can.h:469
can_tx_mailbox_type::tmidsel
__IO uint32_t tmidsel
Definition: at32f413_can.h:454
can_tx_mailbox_type::tmdt7
__IO uint32_t tmdt7
Definition: at32f413_can.h:502
can_tx_mailbox_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_can.h:471
can_tx_mailbox_type::tmeid
__IO uint32_t tmeid
Definition: at32f413_can.h:455
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:406
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:398
can_type
type define can register all
Definition: at32f413_can.h:587
can_type::tmnr
__IO uint32_t tmnr
Definition: at32f413_can.h:660
can_type::fbwsel10
__IO uint32_t fbwsel10
Definition: at32f413_can.h:853
can_type::rf0of
__IO uint32_t rf0of
Definition: at32f413_can.h:681
can_type::tm1alf
__IO uint32_t tm1alf
Definition: at32f413_can.h:650
can_type::tm2lpf
__IO uint32_t tm2lpf
Definition: at32f413_can.h:666
can_type::fmsel13
__IO uint32_t fmsel13
Definition: at32f413_can.h:825
can_type::tm2ef
__IO uint32_t tm2ef
Definition: at32f413_can.h:663
can_type::tm2ct
__IO uint32_t tm2ct
Definition: at32f413_can.h:659
can_type::frfsel1
__IO uint32_t frfsel1
Definition: at32f413_can.h:875
can_type::frfsel12
__IO uint32_t frfsel12
Definition: at32f413_can.h:886
can_type::fmsel4
__IO uint32_t fmsel4
Definition: at32f413_can.h:816
can_type::etrien
__IO uint32_t etrien
Definition: at32f413_can.h:723
can_type::tm1tef
__IO uint32_t tm1tef
Definition: at32f413_can.h:651
can_type::fbwsel8
__IO uint32_t fbwsel8
Definition: at32f413_can.h:851
can_type::boien
__IO uint32_t boien
Definition: at32f413_can.h:722
can_type::eoien
__IO uint32_t eoien
Definition: at32f413_can.h:725
can_type::fctrl
__IO uint32_t fctrl
Definition: at32f413_can.h:796
can_type::frfsel4
__IO uint32_t frfsel4
Definition: at32f413_can.h:878
can_type::tm0ct
__IO uint32_t tm0ct
Definition: at32f413_can.h:647
can_type::eaf
__IO uint32_t eaf
Definition: at32f413_can.h:740
can_type::rf1
__IO uint32_t rf1
Definition: at32f413_can.h:692
can_type::tm0tsf
__IO uint32_t tm0tsf
Definition: at32f413_can.h:643
can_type::tm0lpf
__IO uint32_t tm0lpf
Definition: at32f413_can.h:664
can_type::frfsel2
__IO uint32_t frfsel2
Definition: at32f413_can.h:876
can_type::aeden
__IO uint32_t aeden
Definition: at32f413_can.h:602
can_type::dzc
__IO uint32_t dzc
Definition: at32f413_can.h:621
can_type::fmsel0
__IO uint32_t fmsel0
Definition: at32f413_can.h:812
can_type::faen4
__IO uint32_t faen4
Definition: at32f413_can.h:909
can_type::tm0tcf
__IO uint32_t tm0tcf
Definition: at32f413_can.h:642
can_type::fmsel12
__IO uint32_t fmsel12
Definition: at32f413_can.h:824
can_type::eaien
__IO uint32_t eaien
Definition: at32f413_can.h:720
can_type::fbwsel4
__IO uint32_t fbwsel4
Definition: at32f413_can.h:847
can_type::fbwsel9
__IO uint32_t fbwsel9
Definition: at32f413_can.h:852
can_type::reserved5
__IO uint32_t reserved5
can reserved register, offset:0x218
Definition: at32f413_can.h:895
can_type::edzif
__IO uint32_t edzif
Definition: at32f413_can.h:624
can_type::frfsel11
__IO uint32_t frfsel11
Definition: at32f413_can.h:885
can_type::fmsel9
__IO uint32_t fmsel9
Definition: at32f413_can.h:821
can_type::frfsel10
__IO uint32_t frfsel10
Definition: at32f413_can.h:884
can_type::mctrl
__IO uint32_t mctrl
Definition: at32f413_can.h:594
can_type::frfsel13
__IO uint32_t frfsel13
Definition: at32f413_can.h:887
can_type::faen7
__IO uint32_t faen7
Definition: at32f413_can.h:912
can_type::faen6
__IO uint32_t faen6
Definition: at32f413_can.h:911
can_type::mdrsel
__IO uint32_t mdrsel
Definition: at32f413_can.h:600
can_type::faen8
__IO uint32_t faen8
Definition: at32f413_can.h:913
can_type::rf0fien
__IO uint32_t rf0fien
Definition: at32f413_can.h:714
can_type::rf1ff
__IO uint32_t rf1ff
Definition: at32f413_can.h:697
can_type::cuss
__IO uint32_t cuss
Definition: at32f413_can.h:626
can_type::bof
__IO uint32_t bof
Definition: at32f413_can.h:742
can_type::faen10
__IO uint32_t faen10
Definition: at32f413_can.h:915
can_type::tec
__IO uint32_t tec
Definition: at32f413_can.h:746
can_type::btmg
__IO uint32_t btmg
Definition: at32f413_can.h:756
can_type::fbwsel0
__IO uint32_t fbwsel0
Definition: at32f413_can.h:843
can_type::sprst
__IO uint32_t sprst
Definition: at32f413_can.h:606
can_type::ttcen
__IO uint32_t ttcen
Definition: at32f413_can.h:604
can_type::tm1tcf
__IO uint32_t tm1tcf
Definition: at32f413_can.h:648
can_type::lben
__IO uint32_t lben
Definition: at32f413_can.h:766
can_type::ptd
__IO uint32_t ptd
Definition: at32f413_can.h:607
can_type::fzc
__IO uint32_t fzc
Definition: at32f413_can.h:620
can_type::epien
__IO uint32_t epien
Definition: at32f413_can.h:721
can_type::fbwsel11
__IO uint32_t fbwsel11
Definition: at32f413_can.h:854
can_type::faen3
__IO uint32_t faen3
Definition: at32f413_can.h:908
can_type::rf1oien
__IO uint32_t rf1oien
Definition: at32f413_can.h:718
can_type::rf0oien
__IO uint32_t rf0oien
Definition: at32f413_can.h:715
can_type::tm0ef
__IO uint32_t tm0ef
Definition: at32f413_can.h:661
can_type::fbwsel1
__IO uint32_t fbwsel1
Definition: at32f413_can.h:844
can_type::frfsel8
__IO uint32_t frfsel8
Definition: at32f413_can.h:882
can_type::fbwsel6
__IO uint32_t fbwsel6
Definition: at32f413_can.h:849
can_type::bts2
__IO uint32_t bts2
Definition: at32f413_can.h:762
can_type::loen
__IO uint32_t loen
Definition: at32f413_can.h:767
can_type::fbwsel7
__IO uint32_t fbwsel7
Definition: at32f413_can.h:850
can_type::fmsel3
__IO uint32_t fmsel3
Definition: at32f413_can.h:815
can_type::ests
__IO uint32_t ests
Definition: at32f413_can.h:737
can_type::frfsel9
__IO uint32_t frfsel9
Definition: at32f413_can.h:883
can_type::frf
__IO uint32_t frf
Definition: at32f413_can.h:871
can_type::reserved4
__IO uint32_t reserved4
can reserved register, offset:0x210
Definition: at32f413_can.h:864
can_type::qdzien
__IO uint32_t qdzien
Definition: at32f413_can.h:726
can_type::fbwsel13
__IO uint32_t fbwsel13
Definition: at32f413_can.h:856
can_type::reserved3
__IO uint32_t reserved3
can reserved register, offset:0x208
Definition: at32f413_can.h:658
can_type::rsaw
__IO uint32_t rsaw
Definition: at32f413_can.h:764
can_type::rf0r
__IO uint32_t rf0r
Definition: at32f413_can.h:682
can_type::rf0
__IO uint32_t rf0
Definition: at32f413_can.h:675
can_type::rf1mien
__IO uint32_t rf1mien
Definition: at32f413_can.h:716
can_type::fmsel1
__IO uint32_t fmsel1
Definition: at32f413_can.h:813
can_type::frfsel6
__IO uint32_t frfsel6
Definition: at32f413_can.h:880
can_type::tm1ct
__IO uint32_t tm1ct
Definition: at32f413_can.h:653
can_type::rf0mien
__IO uint32_t rf0mien
Definition: at32f413_can.h:713
can_type::rf1mn
__IO uint32_t rf1mn
Definition: at32f413_can.h:695
can_type::edzien
__IO uint32_t edzien
Definition: at32f413_can.h:727
can_type::reserved1
__IO uint32_t reserved1
can reserved register, offset:0x20~0x17C
Definition: at32f413_can.h:605
can_type::prsfen
__IO uint32_t prsfen
Definition: at32f413_can.h:601
can_type::facfg
__IO uint32_t facfg
Definition: at32f413_can.h:902
can_type::fmsel11
__IO uint32_t fmsel11
Definition: at32f413_can.h:823
can_type::tm1ef
__IO uint32_t tm1ef
Definition: at32f413_can.h:662
can_type::realrx
__IO uint32_t realrx
Definition: at32f413_can.h:629
can_type::aeboen
__IO uint32_t aeboen
Definition: at32f413_can.h:603
can_type::eoif
__IO uint32_t eoif
Definition: at32f413_can.h:622
can_type::tm2tcf
__IO uint32_t tm2tcf
Definition: at32f413_can.h:654
can_type::faen11
__IO uint32_t faen11
Definition: at32f413_can.h:916
can_type::faen1
__IO uint32_t faen1
Definition: at32f413_can.h:906
can_type::brdiv
__IO uint32_t brdiv
Definition: at32f413_can.h:759
can_type::fmsel2
__IO uint32_t fmsel2
Definition: at32f413_can.h:814
can_type::fbwsel3
__IO uint32_t fbwsel3
Definition: at32f413_can.h:846
can_type::frfsel7
__IO uint32_t frfsel7
Definition: at32f413_can.h:881
can_type::epf
__IO uint32_t epf
Definition: at32f413_can.h:741
can_type::faen0
__IO uint32_t faen0
Definition: at32f413_can.h:905
can_type::dzen
__IO uint32_t dzen
Definition: at32f413_can.h:598
can_type::tm2alf
__IO uint32_t tm2alf
Definition: at32f413_can.h:656
can_type::faen2
__IO uint32_t faen2
Definition: at32f413_can.h:907
can_type::fmsel10
__IO uint32_t fmsel10
Definition: at32f413_can.h:822
can_type::etr
__IO uint32_t etr
Definition: at32f413_can.h:744
can_type::tsts
__IO uint32_t tsts
Definition: at32f413_can.h:639
can_type::fbwsel5
__IO uint32_t fbwsel5
Definition: at32f413_can.h:848
can_type::fbwcfg
__IO uint32_t fbwcfg
Definition: at32f413_can.h:840
can_type::qdzif
__IO uint32_t qdzif
Definition: at32f413_can.h:623
can_type::tcien
__IO uint32_t tcien
Definition: at32f413_can.h:712
can_type::fbwsel2
__IO uint32_t fbwsel2
Definition: at32f413_can.h:845
can_type::fmsel8
__IO uint32_t fmsel8
Definition: at32f413_can.h:820
can_type::rf0mn
__IO uint32_t rf0mn
Definition: at32f413_can.h:678
can_type::fmsel5
__IO uint32_t fmsel5
Definition: at32f413_can.h:817
can_type::rf0ff
__IO uint32_t rf0ff
Definition: at32f413_can.h:680
can_type::frfsel0
__IO uint32_t frfsel0
Definition: at32f413_can.h:874
can_type::reserved2
__IO uint32_t reserved2
can reserved register, offset:0x1D0~0x1FC
Definition: at32f413_can.h:608
can_type::fcs
__IO uint32_t fcs
Definition: at32f413_can.h:799
can_type::msts
__IO uint32_t msts
Definition: at32f413_can.h:617
can_type::lsamprx
__IO uint32_t lsamprx
Definition: at32f413_can.h:628
can_type::faen13
__IO uint32_t faen13
Definition: at32f413_can.h:918
can_type::tm0alf
__IO uint32_t tm0alf
Definition: at32f413_can.h:644
can_type::rec
__IO uint32_t rec
Definition: at32f413_can.h:747
can_type::bts1
__IO uint32_t bts1
Definition: at32f413_can.h:761
can_type::fmsel7
__IO uint32_t fmsel7
Definition: at32f413_can.h:819
can_type::rf1r
__IO uint32_t rf1r
Definition: at32f413_can.h:699
can_type::tm1lpf
__IO uint32_t tm1lpf
Definition: at32f413_can.h:665
can_type::tm2tsf
__IO uint32_t tm2tsf
Definition: at32f413_can.h:655
can_type::frfsel5
__IO uint32_t frfsel5
Definition: at32f413_can.h:879
can_type::faen9
__IO uint32_t faen9
Definition: at32f413_can.h:914
can_type::fmsel6
__IO uint32_t fmsel6
Definition: at32f413_can.h:818
can_type::rf1fien
__IO uint32_t rf1fien
Definition: at32f413_can.h:717
can_type::faen5
__IO uint32_t faen5
Definition: at32f413_can.h:910
can_type::rf1of
__IO uint32_t rf1of
Definition: at32f413_can.h:698
can_type::fbwsel12
__IO uint32_t fbwsel12
Definition: at32f413_can.h:855
can_type::tm0tef
__IO uint32_t tm0tef
Definition: at32f413_can.h:645
can_type::fzen
__IO uint32_t fzen
Definition: at32f413_can.h:597
can_type::mmssr
__IO uint32_t mmssr
Definition: at32f413_can.h:599
can_type::faen12
__IO uint32_t faen12
Definition: at32f413_can.h:917
can_type::frfsel3
__IO uint32_t frfsel3
Definition: at32f413_can.h:877
can_type::tm2tef
__IO uint32_t tm2tef
Definition: at32f413_can.h:657
can_type::inten
__IO uint32_t inten
Definition: at32f413_can.h:709
can_type::fmcfg
__IO uint32_t fmcfg
Definition: at32f413_can.h:809
can_type::tm1tsf
__IO uint32_t tm1tsf
Definition: at32f413_can.h:649
can_type::curs
__IO uint32_t curs
Definition: at32f413_can.h:627


AT32F413 Firmwary Library: at32f413_crc.c Source File

  • libraries
  • drivers
  • src
at32f413_crc.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef CRC_MODULE_ENABLED
39
49void crc_data_reset(void)
50{
51 /* reset crc generator */
52 CRC->ctrl_bit.rst = 0x1;
53}
54
60uint32_t crc_one_word_calculate(uint32_t data)
61{
62 CRC->dt = data;
63 return (CRC->dt);
64}
65
72uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
73{
74 uint32_t index = 0;
75
76 for(index = 0; index < length; index++)
77 {
78 CRC->dt = pbuffer[index];
79 }
80
81 return (CRC->dt);
82}
83
89uint32_t crc_data_get(void)
90{
91 return (CRC->dt);
92}
93
99void crc_common_data_set(uint8_t cdt_value)
100{
101 CRC->cdt_bit.cdt = cdt_value;
102}
103
109uint8_t crc_common_date_get(void)
110{
111 return (CRC->cdt_bit.cdt);
112}
113
119void crc_init_data_set(uint32_t value)
120{
121 CRC->idt = value;
122}
123
134void crc_reverse_input_data_set(crc_reverse_input_type value)
135{
136 CRC->ctrl_bit.revid = value;
137}
138
147void crc_reverse_output_data_set(crc_reverse_output_type value)
148{
149 CRC->ctrl_bit.revod = value;
150}
151
156#endif
157
crc_reverse_output_type
crc_reverse_output_type
crc reverse output data
Definition: at32f413_crc.h:66
crc_reverse_input_type
crc_reverse_input_type
crc reverse input data
Definition: at32f413_crc.h:55
crc_reverse_input_data_set
void crc_reverse_input_data_set(crc_reverse_input_type value)
control the reversal of the bit order in the input data
Definition: at32f413_crc.c:134
crc_block_calculate
uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit).
Definition: at32f413_crc.c:72
crc_init_data_set
void crc_init_data_set(uint32_t value)
set the 32-bit initial data of crc
Definition: at32f413_crc.c:119
crc_common_data_set
void crc_common_data_set(uint8_t cdt_value)
store a 8-bit data in the common data register.
Definition: at32f413_crc.c:99
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:49
crc_common_date_get
uint8_t crc_common_date_get(void)
return the 8-bit data stored in the common data register
Definition: at32f413_crc.c:109
crc_data_get
uint32_t crc_data_get(void)
return the current crc value.
Definition: at32f413_crc.c:89
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f413_crc.c:60
crc_reverse_output_data_set
void crc_reverse_output_data_set(crc_reverse_output_type value)
control the reversal of the bit order in the output data
Definition: at32f413_crc.c:147
CRC
#define CRC
Definition: at32f413_crc.h:140
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_crc.h Source File

  • libraries
  • drivers
  • inc
at32f413_crc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CRC_H
29#define __AT32F413_CRC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
54typedef enum
55{
56 CRC_REVERSE_INPUT_NO_AFFECTE = 0x00,
57 CRC_REVERSE_INPUT_BY_BYTE = 0x01,
58 CRC_REVERSE_INPUT_BY_HALFWORD = 0x02,
59 CRC_REVERSE_INPUT_BY_WORD = 0x03
60} crc_reverse_input_type;
61
65typedef enum
66{
67 CRC_REVERSE_OUTPUT_NO_AFFECTE = 0x00,
68 CRC_REVERSE_OUTPUT_DATA = 0x01
69} crc_reverse_output_type;
70
74typedef struct
75{
79 union
80 {
81 __IO uint32_t dt;
82 struct
83 {
84 __IO uint32_t dt : 32; /* [31:0] */
85 } dt_bit;
86 };
87
91 union
92 {
93 __IO uint32_t cdt;
94 struct
95 {
96 __IO uint32_t cdt : 8 ; /* [7:0] */
97 __IO uint32_t reserved1 : 24 ;/* [31:8] */
98 } cdt_bit;
99 };
100
104 union
105 {
106 __IO uint32_t ctrl;
107 struct
108 {
109 __IO uint32_t rst : 1 ; /* [0] */
110 __IO uint32_t reserved1 : 4 ; /* [4:1] */
111 __IO uint32_t revid : 2 ; /* [6:5] */
112 __IO uint32_t revod : 1 ; /* [7] */
113 __IO uint32_t reserved2 : 24 ;/* [31:8] */
114 } ctrl_bit;
115 };
116
120 __IO uint32_t reserved1;
121
125 union
126 {
127 __IO uint32_t idt;
128 struct
129 {
130 __IO uint32_t idt : 32; /* [31:0] */
131 } idt_bit;
132 };
133
134} crc_type;
135
140#define CRC ((crc_type *) CRC_BASE)
141
146void crc_data_reset(void);
147uint32_t crc_one_word_calculate(uint32_t data);
148uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length);
149uint32_t crc_data_get(void);
150void crc_common_data_set(uint8_t cdt_value);
151uint8_t crc_common_date_get(void);
152void crc_init_data_set(uint32_t value);
153void crc_reverse_input_data_set(crc_reverse_input_type value);
154void crc_reverse_output_data_set(crc_reverse_output_type value);
155
168#ifdef __cplusplus
169}
170#endif
171
172#endif
at32f413.h
at32f413 header file
crc_reverse_input_data_set
void crc_reverse_input_data_set(crc_reverse_input_type value)
control the reversal of the bit order in the input data
Definition: at32f413_crc.c:134
crc_block_calculate
uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit).
Definition: at32f413_crc.c:72
crc_init_data_set
void crc_init_data_set(uint32_t value)
set the 32-bit initial data of crc
Definition: at32f413_crc.c:119
crc_common_data_set
void crc_common_data_set(uint8_t cdt_value)
store a 8-bit data in the common data register.
Definition: at32f413_crc.c:99
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:49
crc_common_date_get
uint8_t crc_common_date_get(void)
return the 8-bit data stored in the common data register
Definition: at32f413_crc.c:109
crc_data_get
uint32_t crc_data_get(void)
return the current crc value.
Definition: at32f413_crc.c:89
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f413_crc.c:60
crc_reverse_output_data_set
void crc_reverse_output_data_set(crc_reverse_output_type value)
control the reversal of the bit order in the output data
Definition: at32f413_crc.c:147
crc_reverse_output_type
crc_reverse_output_type
crc reverse output data
Definition: at32f413_crc.h:66
crc_reverse_input_type
crc_reverse_input_type
crc reverse input data
Definition: at32f413_crc.h:55
CRC_REVERSE_OUTPUT_DATA
@ CRC_REVERSE_OUTPUT_DATA
Definition: at32f413_crc.h:68
CRC_REVERSE_OUTPUT_NO_AFFECTE
@ CRC_REVERSE_OUTPUT_NO_AFFECTE
Definition: at32f413_crc.h:67
CRC_REVERSE_INPUT_BY_HALFWORD
@ CRC_REVERSE_INPUT_BY_HALFWORD
Definition: at32f413_crc.h:58
CRC_REVERSE_INPUT_BY_WORD
@ CRC_REVERSE_INPUT_BY_WORD
Definition: at32f413_crc.h:59
CRC_REVERSE_INPUT_BY_BYTE
@ CRC_REVERSE_INPUT_BY_BYTE
Definition: at32f413_crc.h:57
CRC_REVERSE_INPUT_NO_AFFECTE
@ CRC_REVERSE_INPUT_NO_AFFECTE
Definition: at32f413_crc.h:56
crc_type
type define crc register all
Definition: at32f413_crc.h:75
crc_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_crc.h:106
crc_type::cdt
__IO uint32_t cdt
Definition: at32f413_crc.h:93
crc_type::dt
__IO uint32_t dt
Definition: at32f413_crc.h:81
crc_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_crc.h:113
crc_type::rst
__IO uint32_t rst
Definition: at32f413_crc.h:109
crc_type::revod
__IO uint32_t revod
Definition: at32f413_crc.h:112
crc_type::idt
__IO uint32_t idt
Definition: at32f413_crc.h:127
crc_type::reserved1
__IO uint32_t reserved1
crm reserved1 register, offset:0x0C
Definition: at32f413_crc.h:97
crc_type::revid
__IO uint32_t revid
Definition: at32f413_crc.h:111


AT32F413 Firmwary Library: at32f413_crm.c Source File

  • libraries
  • drivers
  • src
at32f413_crm.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef CRM_MODULE_ENABLED
39
49void crm_reset(void)
50{
51 /* reset the crm clock configuration to the default reset state(for debug purpose) */
52 /* set hicken bit */
53 CRM->ctrl_bit.hicken = TRUE;
54
55 /* wait hick stable */
56 while(CRM->ctrl_bit.hickstbl != SET);
57
58 /* hick used as system clock */
59 CRM->cfg_bit.sclksel = CRM_SCLK_HICK;
60
61 /* wait sclk switch status */
62 while(CRM->cfg_bit.sclksts != CRM_SCLK_HICK);
63
64 /* reset hexten, hextbyps, cfden and pllen bits */
65 CRM->ctrl &= ~(0x010D0000U);
66
67 /* reset cfg register, include sclk switch, ahbdiv, apb1div, apb2div, adcdiv,
68 clkout pllrcs, pllhextdiv, pllmult, usbdiv and pllrange bits */
69 CRM->cfg = 0;
70
71 /* reset clkout[3], usbbufs, hickdiv, clkoutdiv */
72 CRM->misc1 = 0;
73
74 /* disable all interrupts enable and clear pending bits */
75 CRM->clkint = 0x009F0000;
76}
77
83void crm_lext_bypass(confirm_state new_state)
84{
85 CRM->bpdc_bit.lextbyps = new_state;
86}
87
93void crm_hext_bypass(confirm_state new_state)
94{
95 CRM->ctrl_bit.hextbyps = new_state;
96}
97
122 flag_status crm_flag_get(uint32_t flag)
123{
124 flag_status status = RESET;
125 if((CRM_REG(flag) & CRM_REG_BIT(flag)) != CRM_REG_BIT(flag))
126 {
127 status = RESET;
128 }
129 else
130 {
131 status = SET;
132 }
133 return status;
134}
135
141 error_status crm_hext_stable_wait(void)
142{
143 uint32_t stable_cnt = 0;
144 error_status status = ERROR;
145
146 while((crm_flag_get(CRM_HEXT_STABLE_FLAG) != SET) && (stable_cnt < HEXT_STARTUP_TIMEOUT))
147 {
148 stable_cnt ++;
149 }
150
151 if(crm_flag_get(CRM_HEXT_STABLE_FLAG) != SET)
152 {
153 status = ERROR;
154 }
155 else
156 {
157 status = SUCCESS;
158 }
159
160 return status;
161}
162
168void crm_hick_clock_trimming_set(uint8_t trim_value)
169{
170 CRM->ctrl_bit.hicktrim = trim_value;
171}
172
178void crm_hick_clock_calibration_set(uint8_t cali_value)
179{
180 /* enable write hick calibration */
181 CRM->misc1_bit.hickcal_key = 0x5A;
182
183 /* write hick calibration value */
184 CRM->ctrl_bit.hickcal = cali_value;
185
186 /* disable write hick calibration */
187 CRM->misc1_bit.hickcal_key = 0x0;
188}
189
206void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
207{
208 /* enable periph clock */
209 if(TRUE == new_state)
210 {
211 CRM_REG(value) |= CRM_REG_BIT(value);
212 }
213 /* disable periph clock */
214 else
215 {
216 CRM_REG(value) &= ~(CRM_REG_BIT(value));
217 }
218}
219
236void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
237{
238 /* enable periph reset */
239 if(new_state == TRUE)
240 {
241 CRM_REG(value) |= (CRM_REG_BIT(value));
242 }
243 /* disable periph reset */
244 else
245 {
246 CRM_REG(value) &= ~(CRM_REG_BIT(value));
247 }
248}
249
259void crm_periph_sleep_mode_clock_enable(crm_periph_clock_sleepmd_type value, confirm_state new_state)
260{
261 /* enable periph clock in sleep mode */
262 if(new_state == TRUE)
263 {
264 CRM_REG(value) |= (CRM_REG_BIT(value));
265 }
266 /* disable perph clock in sleep mode */
267 else
268 {
269 CRM_REG(value) &= ~(CRM_REG_BIT(value));
270 }
271}
272
285void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
286{
287 switch(source)
288 {
289 case CRM_CLOCK_SOURCE_HICK:
290 CRM->ctrl_bit.hicken = new_state;
291 break;
292 case CRM_CLOCK_SOURCE_HEXT:
293 CRM->ctrl_bit.hexten = new_state;
294 break;
295 case CRM_CLOCK_SOURCE_PLL:
296 CRM->ctrl_bit.pllen = new_state;
297 break;
298 case CRM_CLOCK_SOURCE_LEXT:
299 CRM->bpdc_bit.lexten = new_state;
300 break;
301 case CRM_CLOCK_SOURCE_LICK:
302 CRM->ctrlsts_bit.licken = new_state;
303 break;
304 default:
305 break;
306 }
307}
308
330void crm_flag_clear(uint32_t flag)
331{
332 switch(flag)
333 {
334 case CRM_NRST_RESET_FLAG:
335 case CRM_POR_RESET_FLAG:
336 case CRM_SW_RESET_FLAG:
337 case CRM_WDT_RESET_FLAG:
338 case CRM_WWDT_RESET_FLAG:
339 case CRM_LOWPOWER_RESET_FLAG:
340 case CRM_ALL_RESET_FLAG:
341 CRM->ctrlsts_bit.rstfc = TRUE;
342 while(CRM->ctrlsts_bit.rstfc == TRUE);
343 break;
344 case CRM_LICK_READY_INT_FLAG:
345 CRM->clkint_bit.lickstblfc = TRUE;
346 break;
347 case CRM_LEXT_READY_INT_FLAG:
348 CRM->clkint_bit.lextstblfc = TRUE;
349 break;
350 case CRM_HICK_READY_INT_FLAG:
351 CRM->clkint_bit.hickstblfc = TRUE;
352 break;
353 case CRM_HEXT_READY_INT_FLAG:
354 CRM->clkint_bit.hextstblfc = TRUE;
355 break;
356 case CRM_PLL_READY_INT_FLAG:
357 CRM->clkint_bit.pllstblfc = TRUE;
358 break;
359 case CRM_CLOCK_FAILURE_INT_FLAG:
360 CRM->clkint_bit.cfdfc = TRUE;
361 break;
362 default:
363 break;
364 }
365}
366
376void crm_rtc_clock_select(crm_rtc_clock_type value)
377{
378 CRM->bpdc_bit.rtcsel = value;
379}
380
386void crm_rtc_clock_enable(confirm_state new_state)
387{
388 CRM->bpdc_bit.rtcen = new_state;
389}
390
406void crm_ahb_div_set(crm_ahb_div_type value)
407{
408 CRM->cfg_bit.ahbdiv = value;
409}
410
422void crm_apb1_div_set(crm_apb1_div_type value)
423{
424 CRM->cfg_bit.apb1div = value;
425}
426
438void crm_apb2_div_set(crm_apb2_div_type value)
439{
440 CRM->cfg_bit.apb2div = value;
441}
442
455void crm_adc_clock_div_set(crm_adc_div_type div_value)
456{
457 CRM->cfg_bit.adcdiv_l = div_value & 0x03;
458 CRM->cfg_bit.adcdiv_h = (div_value >> 2) & 0x01;
459}
460
474void crm_usb_clock_div_set(crm_usb_div_type div_value)
475{
476 CRM->cfg_bit.usbdiv_l = div_value & 0x03;
477 CRM->cfg_bit.usbdiv_h = (div_value >> 2) & 0x01;
478}
479
485void crm_clock_failure_detection_enable(confirm_state new_state)
486{
487 CRM->ctrl_bit.cfden = new_state;
488}
489
495void crm_battery_powered_domain_reset(confirm_state new_state)
496{
497 CRM->bpdc_bit.bpdrst = new_state;
498}
499
514void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
515{
516 /* config pll clock source */
517 if(clock_source == CRM_PLL_SOURCE_HICK)
518 {
519 CRM->cfg_bit.pllrcs = FALSE;
520 }
521 else
522 {
523 CRM->cfg_bit.pllrcs = TRUE;
524 if(CRM_PLL_SOURCE_HEXT == clock_source)
525 {
526 CRM->cfg_bit.pllhextdiv = FALSE;
527 }
528 else
529 {
530 CRM->cfg_bit.pllhextdiv = TRUE;
531 }
532 }
533
534 /* config pll multiplication factor */
535 CRM->cfg_bit.pllmult_l = (mult_value & 0x0F);
536 CRM->cfg_bit.pllmult_h = ((mult_value & 0x30) >> 4);
537
538 /* config pll output range */
539 CRM->cfg_bit.pllrange = pll_range;
540}
541
551void crm_sysclk_switch(crm_sclk_type value)
552{
553 CRM->cfg_bit.sclksel = value;
554}
555
565 crm_sclk_type crm_sysclk_switch_status_get(void)
566{
567 return (crm_sclk_type)CRM->cfg_bit.sclksts;
568}
569
576void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
577{
578 uint32_t pll_mult = 0, pll_mult_h = 0, pll_clock_source = 0, temp = 0, div_value = 0;
579 crm_sclk_type sclk_source;
580
581 static const uint8_t sclk_ahb_div_table[16] = {0, 0, 0, 0, 0, 0, 0, 0, 1, 2, 3, 4, 6, 7, 8, 9};
582 static const uint8_t ahb_apb1_div_table[8] = {0, 0, 0, 0, 1, 2, 3, 4};
583 static const uint8_t ahb_apb2_div_table[8] = {0, 0, 0, 0, 1, 2, 3, 4};
584 static const uint8_t adc_div_table[8] = {2, 4, 6, 8, 2, 12, 8, 16};
585
586 /* get sclk source */
587 sclk_source = crm_sysclk_switch_status_get();
588
589 switch(sclk_source)
590 {
591 case CRM_SCLK_HICK:
592 if(((CRM->misc3_bit.hick_to_sclk) != RESET) && ((CRM->misc1_bit.hickdiv) != RESET))
593 clocks_struct->sclk_freq = HICK_VALUE * 6;
594 else
595 clocks_struct->sclk_freq = HICK_VALUE;
596 break;
597 case CRM_SCLK_HEXT:
598 clocks_struct->sclk_freq = HEXT_VALUE;
599 break;
600 case CRM_SCLK_PLL:
601 pll_clock_source = CRM->cfg_bit.pllrcs;
602 /* get multiplication factor */
603 pll_mult = CRM->cfg_bit.pllmult_l;
604 pll_mult_h = CRM->cfg_bit.pllmult_h;
605
606 /* process high bits */
607 if((pll_mult_h != 0U) || (pll_mult == 15U))
608 {
609 pll_mult += ((16U * pll_mult_h) + 1U);
610 }
611 else
612 {
613 pll_mult += 2U;
614 }
615
616 if (pll_clock_source == 0x00)
617 {
618 /* hick divided by 2 selected as pll clock entry */
619 clocks_struct->sclk_freq = (HICK_VALUE >> 1) * pll_mult;
620 }
621 else
622 {
623 /* hext selected as pll clock entry */
624 if (CRM->cfg_bit.pllhextdiv != RESET)
625 {
626 /* hext clock divided by 2 */
627 clocks_struct->sclk_freq = (HEXT_VALUE / 2) * pll_mult;
628 }
629 else
630 {
631 clocks_struct->sclk_freq = HEXT_VALUE * pll_mult;
632 }
633 }
634 break;
635 default:
636 clocks_struct->sclk_freq = HICK_VALUE;
637 break;
638 }
639
640 /* compute sclk, ahbclk, abp1clk apb2clk and adcclk frequencies */
641 /* get ahb division */
642 temp = CRM->cfg_bit.ahbdiv;
643 div_value = sclk_ahb_div_table[temp];
644 /* ahbclk frequency */
645 clocks_struct->ahb_freq = clocks_struct->sclk_freq >> div_value;
646
647 /* get apb1 division */
648 temp = CRM->cfg_bit.apb1div;
649 div_value = ahb_apb1_div_table[temp];
650 /* apb1clk frequency */
651 clocks_struct->apb1_freq = clocks_struct->ahb_freq >> div_value;
652
653 /* get apb2 division */
654 temp = CRM->cfg_bit.apb2div;
655 div_value = ahb_apb2_div_table[temp];
656 /* apb2clk frequency */
657 clocks_struct->apb2_freq = clocks_struct->ahb_freq >> div_value;
658
659 /* get adc division */
660 temp = CRM->cfg_bit.adcdiv_h;
661 temp = ((temp << 2) | (CRM->cfg_bit.adcdiv_l));
662 div_value = adc_div_table[temp];
663 /* adcclk clock frequency */
664 clocks_struct->adc_freq = clocks_struct->apb2_freq / div_value;
665}
666
683void crm_clock_out_set(crm_clkout_select_type clkout)
684{
685 CRM->cfg_bit.clkout_sel = clkout & 0x7;
686 CRM->misc1_bit.clkout_sel = (clkout >> 3) & 0x1;
687}
688
701void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state)
702{
703 if(new_state == TRUE)
704 CRM->clkint |= crm_int;
705 else
706 CRM->clkint &= ~crm_int;
707}
708
714void crm_auto_step_mode_enable(confirm_state new_state)
715{
716 if(new_state == TRUE)
717 CRM->misc3_bit.auto_step_en = CRM_AUTO_STEP_MODE_ENABLE;
718 else
719 CRM->misc3_bit.auto_step_en = CRM_AUTO_STEP_MODE_DISABLE;
720}
721
730void crm_usb_interrupt_remapping_set(crm_usb_int_map_type int_remap)
731{
732 CRM->intmap_bit.usbintmap = int_remap;
733}
734
743void crm_hick_divider_select(crm_hick_div_6_type value)
744{
745 CRM->misc1_bit.hickdiv = value;
746}
747
756void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value)
757{
758 crm_hick_divider_select(CRM_HICK48_NODIV);
759 CRM->misc3_bit.hick_to_sclk = value;
760}
761
770void crm_usb_clock_source_select(crm_usb_clock_source_type value)
771{
772 if(value == CRM_USB_CLOCK_SOURCE_HICK)
773 {
774 crm_hick_sclk_frequency_select(CRM_HICK_SCLK_48MHZ);
775 }
776 CRM->misc3_bit.hick_to_usb = value;
777}
778
784void crm_clkout_to_tmr10_enable(confirm_state new_state)
785{
786 CRM->misc2_bit.clk_to_tmr = new_state;
787}
788
804void crm_clkout_div_set(crm_clkout_div_type clkout_div)
805{
806 CRM->misc1_bit.clkoutdiv = clkout_div;
807}
808
813#endif
814
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:44
crm_periph_clock_type
crm_periph_clock_type
crm periph clock
Definition: at32f413_crm.h:102
crm_hick_sclk_frequency_type
crm_hick_sclk_frequency_type
crm hick as system clock frequency select
Definition: at32f413_crm.h:462
crm_apb1_div_type
crm_apb1_div_type
crm apb1 division
Definition: at32f413_crm.h:321
crm_clock_source_type
crm_clock_source_type
crm clock source
Definition: at32f413_crm.h:293
crm_usb_div_type
crm_usb_div_type
crm usb division
Definition: at32f413_crm.h:358
crm_clkout_div_type
crm_clkout_div_type
crm clkout division
Definition: at32f413_crm.h:419
crm_usb_clock_source_type
crm_usb_clock_source_type
crm usb 48 mhz clock source select
Definition: at32f413_crm.h:453
crm_periph_clock_sleepmd_type
crm_periph_clock_sleepmd_type
crm periph clock in sleep mode
Definition: at32f413_crm.h:194
crm_pll_clock_source_type
crm_pll_clock_source_type
crm pll clock source
Definition: at32f413_crm.h:274
crm_pll_mult_type
crm_pll_mult_type
crm pll mult_x
Definition: at32f413_crm.h:204
crm_ahb_div_type
crm_ahb_div_type
crm ahb division
Definition: at32f413_crm.h:305
crm_rtc_clock_type
crm_rtc_clock_type
crm rtc clock
Definition: at32f413_crm.h:372
crm_adc_div_type
crm_adc_div_type
crm adc division
Definition: at32f413_crm.h:345
crm_usb_int_map_type
crm_usb_int_map_type
crm usbdev interrupt remap
Definition: at32f413_crm.h:444
crm_clkout_select_type
crm_clkout_select_type
crm clkout select
Definition: at32f413_crm.h:402
crm_sclk_type
crm_sclk_type
crm sclk select
Definition: at32f413_crm.h:392
crm_periph_reset_type
crm_periph_reset_type
crm periph reset
Definition: at32f413_crm.h:150
crm_apb2_div_type
crm_apb2_div_type
crm apb2 division
Definition: at32f413_crm.h:333
crm_pll_output_range_type
crm_pll_output_range_type
crm pll clock output range
Definition: at32f413_crm.h:284
crm_hick_div_6_type
crm_hick_div_6_type
crm hick 48mhz division
Definition: at32f413_crm.h:383
CRM_HICK_SCLK_48MHZ
@ CRM_HICK_SCLK_48MHZ
Definition: at32f413_crm.h:464
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f413_crm.h:297
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:298
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f413_crm.h:276
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:275
CRM_AUTO_STEP_MODE_ENABLE
@ CRM_AUTO_STEP_MODE_ENABLE
Definition: at32f413_crm.h:437
CRM_AUTO_STEP_MODE_DISABLE
@ CRM_AUTO_STEP_MODE_DISABLE
Definition: at32f413_crm.h:436
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f413_crm.h:393
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_SCLK_HEXT
@ CRM_SCLK_HEXT
Definition: at32f413_crm.h:394
CRM_HICK48_NODIV
@ CRM_HICK48_NODIV
Definition: at32f413_crm.h:385
CRM_PLL_READY_INT_FLAG
#define CRM_PLL_READY_INT_FLAG
Definition: at32f413_crm.h:71
CRM_HEXT_READY_INT_FLAG
#define CRM_HEXT_READY_INT_FLAG
Definition: at32f413_crm.h:70
CRM_LOWPOWER_RESET_FLAG
#define CRM_LOWPOWER_RESET_FLAG
Definition: at32f413_crm.h:66
CRM_CLOCK_FAILURE_INT_FLAG
#define CRM_CLOCK_FAILURE_INT_FLAG
Definition: at32f413_crm.h:72
CRM_HICK_READY_INT_FLAG
#define CRM_HICK_READY_INT_FLAG
Definition: at32f413_crm.h:69
CRM_LEXT_READY_INT_FLAG
#define CRM_LEXT_READY_INT_FLAG
Definition: at32f413_crm.h:68
CRM_POR_RESET_FLAG
#define CRM_POR_RESET_FLAG
Definition: at32f413_crm.h:62
CRM_HEXT_STABLE_FLAG
#define CRM_HEXT_STABLE_FLAG
Definition: at32f413_crm.h:56
CRM_SW_RESET_FLAG
#define CRM_SW_RESET_FLAG
Definition: at32f413_crm.h:63
CRM_NRST_RESET_FLAG
#define CRM_NRST_RESET_FLAG
Definition: at32f413_crm.h:61
CRM_WWDT_RESET_FLAG
#define CRM_WWDT_RESET_FLAG
Definition: at32f413_crm.h:65
CRM_LICK_READY_INT_FLAG
#define CRM_LICK_READY_INT_FLAG
Definition: at32f413_crm.h:67
CRM_ALL_RESET_FLAG
#define CRM_ALL_RESET_FLAG
Definition: at32f413_crm.h:60
CRM_WDT_RESET_FLAG
#define CRM_WDT_RESET_FLAG
Definition: at32f413_crm.h:64
crm_periph_sleep_mode_clock_enable
void crm_periph_sleep_mode_clock_enable(crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode
Definition: at32f413_crm.c:259
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hick_clock_calibration_set
void crm_hick_clock_calibration_set(uint8_t cali_value)
set the crm calibration value
Definition: at32f413_crm.c:178
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:804
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:376
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:386
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_interrupt_enable
void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state)
config crm interrupt
Definition: at32f413_crm.c:701
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:330
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_lext_bypass
void crm_lext_bypass(confirm_state new_state)
enable or disable crm low speed external crystal bypass
Definition: at32f413_crm.c:83
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_hick_sclk_frequency_select
void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value)
hick as system clock frequency select
Definition: at32f413_crm.c:756
crm_hick_divider_select
void crm_hick_divider_select(crm_hick_div_6_type value)
config hick divider select
Definition: at32f413_crm.c:743
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:683
crm_clock_failure_detection_enable
void crm_clock_failure_detection_enable(confirm_state new_state)
enable or disable clock failure detection
Definition: at32f413_crm.c:485
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_clkout_to_tmr10_enable
void crm_clkout_to_tmr10_enable(confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1
Definition: at32f413_crm.c:784
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_usb_interrupt_remapping_set
void crm_usb_interrupt_remapping_set(crm_usb_int_map_type int_remap)
usbdev interrupt remapping control
Definition: at32f413_crm.c:730
crm_hick_clock_trimming_set
void crm_hick_clock_trimming_set(uint8_t trim_value)
set the hick trimming value
Definition: at32f413_crm.c:168
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f413_crm.c:495
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
crm_hext_bypass
void crm_hext_bypass(confirm_state new_state)
enable or disable crm high speed external crystal bypass
Definition: at32f413_crm.c:93
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_REG_BIT
#define CRM_REG_BIT(value)
Definition: at32f413_crm.h:48
CRM
#define CRM
Definition: at32f413_crm.h:844
CRM_REG
#define CRM_REG(value)
Definition: at32f413_crm.h:47
error_status
error_status
error status
Definition: at32f413.h:264
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
HEXT_VALUE
#define HEXT_VALUE
in the following line adjust the value of high speed exernal crystal (hext) used in your application
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:44
HICK_VALUE
#define HICK_VALUE
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:52
HEXT_STARTUP_TIMEOUT
#define HEXT_STARTUP_TIMEOUT
in the following line adjust the high speed exernal crystal (hext) startup timeout value
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:51
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::adc_freq
uint32_t adc_freq
Definition: at32f413_crm.h:476
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:475
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f413_crm.h:474
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:473
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_crm.h Source File

  • libraries
  • drivers
  • inc
at32f413_crm.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CRM_H
29#define __AT32F413_CRM_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
47#define CRM_REG(value) PERIPH_REG(CRM_BASE, value)
48#define CRM_REG_BIT(value) PERIPH_REG_BIT(value)
49
55#define CRM_HICK_STABLE_FLAG MAKE_VALUE(0x00, 1)
56#define CRM_HEXT_STABLE_FLAG MAKE_VALUE(0x00, 17)
57#define CRM_PLL_STABLE_FLAG MAKE_VALUE(0x00, 25)
58#define CRM_LEXT_STABLE_FLAG MAKE_VALUE(0x20, 1)
59#define CRM_LICK_STABLE_FLAG MAKE_VALUE(0x24, 1)
60#define CRM_ALL_RESET_FLAG MAKE_VALUE(0x24, 24)
61#define CRM_NRST_RESET_FLAG MAKE_VALUE(0x24, 26)
62#define CRM_POR_RESET_FLAG MAKE_VALUE(0x24, 27)
63#define CRM_SW_RESET_FLAG MAKE_VALUE(0x24, 28)
64#define CRM_WDT_RESET_FLAG MAKE_VALUE(0x24, 29)
65#define CRM_WWDT_RESET_FLAG MAKE_VALUE(0x24, 30)
66#define CRM_LOWPOWER_RESET_FLAG MAKE_VALUE(0x24, 31)
67#define CRM_LICK_READY_INT_FLAG MAKE_VALUE(0x08, 0)
68#define CRM_LEXT_READY_INT_FLAG MAKE_VALUE(0x08, 1)
69#define CRM_HICK_READY_INT_FLAG MAKE_VALUE(0x08, 2)
70#define CRM_HEXT_READY_INT_FLAG MAKE_VALUE(0x08, 3)
71#define CRM_PLL_READY_INT_FLAG MAKE_VALUE(0x08, 4)
72#define CRM_CLOCK_FAILURE_INT_FLAG MAKE_VALUE(0x08, 7)
83#define CRM_LICK_STABLE_INT ((uint32_t)0x00000100)
84#define CRM_LEXT_STABLE_INT ((uint32_t)0x00000200)
85#define CRM_HICK_STABLE_INT ((uint32_t)0x00000400)
86#define CRM_HEXT_STABLE_INT ((uint32_t)0x00000800)
87#define CRM_PLL_STABLE_INT ((uint32_t)0x00001000)
88#define CRM_CLOCK_FAILURE_INT ((uint32_t)0x00800000)
101typedef enum
102{
103 /* ahb periph */
104 CRM_DMA1_PERIPH_CLOCK = MAKE_VALUE(0x14, 0),
105 CRM_DMA2_PERIPH_CLOCK = MAKE_VALUE(0x14, 1),
106 CRM_CRC_PERIPH_CLOCK = MAKE_VALUE(0x14, 6),
107 CRM_SDIO1_PERIPH_CLOCK = MAKE_VALUE(0x14, 10),
108 /* apb2 periph */
109 CRM_IOMUX_PERIPH_CLOCK = MAKE_VALUE(0x18, 0),
110 CRM_GPIOA_PERIPH_CLOCK = MAKE_VALUE(0x18, 2),
111 CRM_GPIOB_PERIPH_CLOCK = MAKE_VALUE(0x18, 3),
112 CRM_GPIOC_PERIPH_CLOCK = MAKE_VALUE(0x18, 4),
113 CRM_GPIOD_PERIPH_CLOCK = MAKE_VALUE(0x18, 5),
114 CRM_GPIOF_PERIPH_CLOCK = MAKE_VALUE(0x18, 7),
115 CRM_ADC1_PERIPH_CLOCK = MAKE_VALUE(0x18, 9),
116 CRM_ADC2_PERIPH_CLOCK = MAKE_VALUE(0x18, 10),
117 CRM_TMR1_PERIPH_CLOCK = MAKE_VALUE(0x18, 11),
118 CRM_SPI1_PERIPH_CLOCK = MAKE_VALUE(0x18, 12),
119 CRM_TMR8_PERIPH_CLOCK = MAKE_VALUE(0x18, 13),
120 CRM_USART1_PERIPH_CLOCK = MAKE_VALUE(0x18, 14),
121 CRM_TMR9_PERIPH_CLOCK = MAKE_VALUE(0x18, 19),
122 CRM_TMR10_PERIPH_CLOCK = MAKE_VALUE(0x18, 20),
123 CRM_TMR11_PERIPH_CLOCK = MAKE_VALUE(0x18, 21),
124 CRM_ACC_PERIPH_CLOCK = MAKE_VALUE(0x18, 22),
125 /* apb1 periph */
126 CRM_TMR2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 0),
127 CRM_TMR3_PERIPH_CLOCK = MAKE_VALUE(0x1C, 1),
128 CRM_TMR4_PERIPH_CLOCK = MAKE_VALUE(0x1C, 2),
129 CRM_TMR5_PERIPH_CLOCK = MAKE_VALUE(0x1C, 3),
130 CRM_WWDT_PERIPH_CLOCK = MAKE_VALUE(0x1C, 11),
131 CRM_SPI2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 14),
132 CRM_USART2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 17),
133 CRM_USART3_PERIPH_CLOCK = MAKE_VALUE(0x1C, 18),
134 CRM_UART4_PERIPH_CLOCK = MAKE_VALUE(0x1C, 19),
135 CRM_UART5_PERIPH_CLOCK = MAKE_VALUE(0x1C, 20),
136 CRM_I2C1_PERIPH_CLOCK = MAKE_VALUE(0x1C, 21),
137 CRM_I2C2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 22),
138 CRM_USB_PERIPH_CLOCK = MAKE_VALUE(0x1C, 23),
139 CRM_CAN1_PERIPH_CLOCK = MAKE_VALUE(0x1C, 25),
140 CRM_BPR_PERIPH_CLOCK = MAKE_VALUE(0x1C, 27),
141 CRM_PWC_PERIPH_CLOCK = MAKE_VALUE(0x1C, 28),
142 CRM_CAN2_PERIPH_CLOCK = MAKE_VALUE(0x1C, 31),
144} crm_periph_clock_type;
145
149typedef enum
150{
151 /* apb2 periph */
152 CRM_IOMUX_PERIPH_RESET = MAKE_VALUE(0x0C, 0),
153 CRM_EXINT_PERIPH_RESET = MAKE_VALUE(0x0C, 1),
154 CRM_GPIOA_PERIPH_RESET = MAKE_VALUE(0x0C, 2),
155 CRM_GPIOB_PERIPH_RESET = MAKE_VALUE(0x0C, 3),
156 CRM_GPIOC_PERIPH_RESET = MAKE_VALUE(0x0C, 4),
157 CRM_GPIOD_PERIPH_RESET = MAKE_VALUE(0x0C, 5),
158 CRM_GPIOF_PERIPH_RESET = MAKE_VALUE(0x0C, 7),
159 CRM_ADC1_PERIPH_RESET = MAKE_VALUE(0x0C, 9),
160 CRM_ADC2_PERIPH_RESET = MAKE_VALUE(0x0C, 10),
161 CRM_TMR1_PERIPH_RESET = MAKE_VALUE(0x0C, 11),
162 CRM_SPI1_PERIPH_RESET = MAKE_VALUE(0x0C, 12),
163 CRM_TMR8_PERIPH_RESET = MAKE_VALUE(0x0C, 13),
164 CRM_USART1_PERIPH_RESET = MAKE_VALUE(0x0C, 14),
165 CRM_TMR9_PERIPH_RESET = MAKE_VALUE(0x0C, 19),
166 CRM_TMR10_PERIPH_RESET = MAKE_VALUE(0x0C, 20),
167 CRM_TMR11_PERIPH_RESET = MAKE_VALUE(0x0C, 21),
168 CRM_ACC_PERIPH_RESET = MAKE_VALUE(0x0C, 22),
169 /* apb1 periph */
170 CRM_TMR2_PERIPH_RESET = MAKE_VALUE(0x10, 0),
171 CRM_TMR3_PERIPH_RESET = MAKE_VALUE(0x10, 1),
172 CRM_TMR4_PERIPH_RESET = MAKE_VALUE(0x10, 2),
173 CRM_TMR5_PERIPH_RESET = MAKE_VALUE(0x10, 3),
174 CRM_WWDT_PERIPH_RESET = MAKE_VALUE(0x10, 11),
175 CRM_SPI2_PERIPH_RESET = MAKE_VALUE(0x10, 14),
176 CRM_USART2_PERIPH_RESET = MAKE_VALUE(0x10, 17),
177 CRM_USART3_PERIPH_RESET = MAKE_VALUE(0x10, 18),
178 CRM_UART4_PERIPH_RESET = MAKE_VALUE(0x10, 19),
179 CRM_UART5_PERIPH_RESET = MAKE_VALUE(0x10, 20),
180 CRM_I2C1_PERIPH_RESET = MAKE_VALUE(0x10, 21),
181 CRM_I2C2_PERIPH_RESET = MAKE_VALUE(0x10, 22),
182 CRM_USB_PERIPH_RESET = MAKE_VALUE(0x10, 23),
183 CRM_CAN1_PERIPH_RESET = MAKE_VALUE(0x10, 25),
184 CRM_BPR_PERIPH_RESET = MAKE_VALUE(0x10, 27),
185 CRM_PWC_PERIPH_RESET = MAKE_VALUE(0x10, 28),
186 CRM_CAN2_PERIPH_RESET = MAKE_VALUE(0x10, 31),
188} crm_periph_reset_type;
189
193typedef enum
194{
195 /* ahb periph */
196 CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE = MAKE_VALUE(0x14, 2),
197 CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE = MAKE_VALUE(0x14, 4)
198} crm_periph_clock_sleepmd_type;
199
203typedef enum
204{
205 CRM_PLL_MULT_2 = 0,
206 CRM_PLL_MULT_3 = 1,
207 CRM_PLL_MULT_4 = 2,
208 CRM_PLL_MULT_5 = 3,
209 CRM_PLL_MULT_6 = 4,
210 CRM_PLL_MULT_7 = 5,
211 CRM_PLL_MULT_8 = 6,
212 CRM_PLL_MULT_9 = 7,
213 CRM_PLL_MULT_10 = 8,
214 CRM_PLL_MULT_11 = 9,
215 CRM_PLL_MULT_12 = 10,
216 CRM_PLL_MULT_13 = 11,
217 CRM_PLL_MULT_14 = 12,
218 CRM_PLL_MULT_15 = 13,
219 CRM_PLL_MULT_16 = 15,
220 CRM_PLL_MULT_17 = 16,
221 CRM_PLL_MULT_18 = 17,
222 CRM_PLL_MULT_19 = 18,
223 CRM_PLL_MULT_20 = 19,
224 CRM_PLL_MULT_21 = 20,
225 CRM_PLL_MULT_22 = 21,
226 CRM_PLL_MULT_23 = 22,
227 CRM_PLL_MULT_24 = 23,
228 CRM_PLL_MULT_25 = 24,
229 CRM_PLL_MULT_26 = 25,
230 CRM_PLL_MULT_27 = 26,
231 CRM_PLL_MULT_28 = 27,
232 CRM_PLL_MULT_29 = 28,
233 CRM_PLL_MULT_30 = 29,
234 CRM_PLL_MULT_31 = 30,
235 CRM_PLL_MULT_32 = 31,
236 CRM_PLL_MULT_33 = 32,
237 CRM_PLL_MULT_34 = 33,
238 CRM_PLL_MULT_35 = 34,
239 CRM_PLL_MULT_36 = 35,
240 CRM_PLL_MULT_37 = 36,
241 CRM_PLL_MULT_38 = 37,
242 CRM_PLL_MULT_39 = 38,
243 CRM_PLL_MULT_40 = 39,
244 CRM_PLL_MULT_41 = 40,
245 CRM_PLL_MULT_42 = 41,
246 CRM_PLL_MULT_43 = 42,
247 CRM_PLL_MULT_44 = 43,
248 CRM_PLL_MULT_45 = 44,
249 CRM_PLL_MULT_46 = 45,
250 CRM_PLL_MULT_47 = 46,
251 CRM_PLL_MULT_48 = 47,
252 CRM_PLL_MULT_49 = 48,
253 CRM_PLL_MULT_50 = 49,
254 CRM_PLL_MULT_51 = 50,
255 CRM_PLL_MULT_52 = 51,
256 CRM_PLL_MULT_53 = 52,
257 CRM_PLL_MULT_54 = 53,
258 CRM_PLL_MULT_55 = 54,
259 CRM_PLL_MULT_56 = 55,
260 CRM_PLL_MULT_57 = 56,
261 CRM_PLL_MULT_58 = 57,
262 CRM_PLL_MULT_59 = 58,
263 CRM_PLL_MULT_60 = 59,
264 CRM_PLL_MULT_61 = 60,
265 CRM_PLL_MULT_62 = 61,
266 CRM_PLL_MULT_63 = 62,
267 CRM_PLL_MULT_64 = 63
268} crm_pll_mult_type;
269
273typedef enum
274{
275 CRM_PLL_SOURCE_HICK = 0x00,
276 CRM_PLL_SOURCE_HEXT = 0x01,
277 CRM_PLL_SOURCE_HEXT_DIV = 0x02
278} crm_pll_clock_source_type;
279
283typedef enum
284{
285 CRM_PLL_OUTPUT_RANGE_LE72MHZ = 0x00,
286 CRM_PLL_OUTPUT_RANGE_GT72MHZ = 0x01
287} crm_pll_output_range_type;
288
292typedef enum
293{
294 CRM_CLOCK_SOURCE_HICK = 0x00,
295 CRM_CLOCK_SOURCE_HEXT = 0x01,
296 CRM_CLOCK_SOURCE_PLL = 0x02,
297 CRM_CLOCK_SOURCE_LEXT = 0x03,
298 CRM_CLOCK_SOURCE_LICK = 0x04
299} crm_clock_source_type;
300
304typedef enum
305{
306 CRM_AHB_DIV_1 = 0x00,
307 CRM_AHB_DIV_2 = 0x08,
308 CRM_AHB_DIV_4 = 0x09,
309 CRM_AHB_DIV_8 = 0x0A,
310 CRM_AHB_DIV_16 = 0x0B,
311 CRM_AHB_DIV_64 = 0x0C,
312 CRM_AHB_DIV_128 = 0x0D,
313 CRM_AHB_DIV_256 = 0x0E,
314 CRM_AHB_DIV_512 = 0x0F
315} crm_ahb_div_type;
316
320typedef enum
321{
322 CRM_APB1_DIV_1 = 0x00,
323 CRM_APB1_DIV_2 = 0x04,
324 CRM_APB1_DIV_4 = 0x05,
325 CRM_APB1_DIV_8 = 0x06,
326 CRM_APB1_DIV_16 = 0x07
327} crm_apb1_div_type;
328
332typedef enum
333{
334 CRM_APB2_DIV_1 = 0x00,
335 CRM_APB2_DIV_2 = 0x04,
336 CRM_APB2_DIV_4 = 0x05,
337 CRM_APB2_DIV_8 = 0x06,
338 CRM_APB2_DIV_16 = 0x07
339} crm_apb2_div_type;
340
344typedef enum
345{
346 CRM_ADC_DIV_2 = 0x00,
347 CRM_ADC_DIV_4 = 0x01,
348 CRM_ADC_DIV_6 = 0x02,
349 CRM_ADC_DIV_8 = 0x03,
350 CRM_ADC_DIV_12 = 0x05,
351 CRM_ADC_DIV_16 = 0x07
352} crm_adc_div_type;
353
357typedef enum
358{
359 CRM_USB_DIV_1_5 = 0x00,
360 CRM_USB_DIV_1 = 0x01,
361 CRM_USB_DIV_2_5 = 0x02,
362 CRM_USB_DIV_2 = 0x03,
363 CRM_USB_DIV_3_5 = 0x04,
364 CRM_USB_DIV_3 = 0x05,
365 CRM_USB_DIV_4 = 0x06
366} crm_usb_div_type;
367
371typedef enum
372{
373 CRM_RTC_CLOCK_NOCLK = 0x00,
374 CRM_RTC_CLOCK_LEXT = 0x01,
375 CRM_RTC_CLOCK_LICK = 0x02,
376 CRM_RTC_CLOCK_HEXT_DIV = 0x03
377} crm_rtc_clock_type;
378
382typedef enum
383{
384 CRM_HICK48_DIV6 = 0x00,
385 CRM_HICK48_NODIV = 0x01
386} crm_hick_div_6_type;
387
391typedef enum
392{
393 CRM_SCLK_HICK = 0x00,
394 CRM_SCLK_HEXT = 0x01,
395 CRM_SCLK_PLL = 0x02
396} crm_sclk_type;
397
401typedef enum
402{
403 CRM_CLKOUT_NOCLK = 0x00,
404 CRM_CLKOUT_LICK = 0x02,
405 CRM_CLKOUT_LEXT = 0x03,
406 CRM_CLKOUT_SCLK = 0x04,
407 CRM_CLKOUT_HICK = 0x05,
408 CRM_CLKOUT_HEXT = 0x06,
409 CRM_CLKOUT_PLL_DIV_2 = 0x07,
410 CRM_CLKOUT_PLL_DIV_4 = 0x0C,
411 CRM_CLKOUT_USB = 0x0D,
412 CRM_CLKOUT_ADC = 0x0E
413} crm_clkout_select_type;
414
418typedef enum
419{
420 CRM_CLKOUT_DIV_1 = 0x00,
421 CRM_CLKOUT_DIV_2 = 0x08,
422 CRM_CLKOUT_DIV_4 = 0x09,
423 CRM_CLKOUT_DIV_8 = 0x0A,
424 CRM_CLKOUT_DIV_16 = 0x0B,
425 CRM_CLKOUT_DIV_64 = 0x0C,
426 CRM_CLKOUT_DIV_128 = 0x0D,
427 CRM_CLKOUT_DIV_256 = 0x0E,
428 CRM_CLKOUT_DIV_512 = 0x0F
429} crm_clkout_div_type;
430
434typedef enum
435{
436 CRM_AUTO_STEP_MODE_DISABLE = 0x00,
437 CRM_AUTO_STEP_MODE_ENABLE = 0x03
438} crm_auto_step_mode_type;
439
443typedef enum
444{
445 CRM_USB_INT19_INT20 = 0x00,
446 CRM_USB_INT73_INT74 = 0x01
447} crm_usb_int_map_type;
448
452typedef enum
453{
454 CRM_USB_CLOCK_SOURCE_PLL = 0x00,
455 CRM_USB_CLOCK_SOURCE_HICK = 0x01
456} crm_usb_clock_source_type;
457
461typedef enum
462{
463 CRM_HICK_SCLK_8MHZ = 0x00,
464 CRM_HICK_SCLK_48MHZ = 0x01
465} crm_hick_sclk_frequency_type;
466
470typedef struct
471{
472 uint32_t sclk_freq;
473 uint32_t ahb_freq;
474 uint32_t apb2_freq;
475 uint32_t apb1_freq;
476 uint32_t adc_freq;
477} crm_clocks_freq_type;
478
482typedef struct
483{
487 union
488 {
489 __IO uint32_t ctrl;
490 struct
491 {
492 __IO uint32_t hicken : 1; /* [0] */
493 __IO uint32_t hickstbl : 1; /* [1] */
494 __IO uint32_t hicktrim : 6; /* [7:2] */
495 __IO uint32_t hickcal : 8; /* [15:8] */
496 __IO uint32_t hexten : 1; /* [16] */
497 __IO uint32_t hextstbl : 1; /* [17] */
498 __IO uint32_t hextbyps : 1; /* [18] */
499 __IO uint32_t cfden : 1; /* [19] */
500 __IO uint32_t reserved1 : 4; /* [23:20] */
501 __IO uint32_t pllen : 1; /* [24] */
502 __IO uint32_t pllstbl : 1; /* [25] */
503 __IO uint32_t reserved2 : 6; /* [31:26] */
504 } ctrl_bit;
505 };
506
510 union
511 {
512 __IO uint32_t cfg;
513 struct
514 {
515 __IO uint32_t sclksel : 2; /* [1:0] */
516 __IO uint32_t sclksts : 2; /* [3:2] */
517 __IO uint32_t ahbdiv : 4; /* [7:4] */
518 __IO uint32_t apb1div : 3; /* [10:8] */
519 __IO uint32_t apb2div : 3; /* [13:11] */
520 __IO uint32_t adcdiv_l : 2; /* [15:14] */
521 __IO uint32_t pllrcs : 1; /* [16] */
522 __IO uint32_t pllhextdiv : 1; /* [17] */
523 __IO uint32_t pllmult_l : 4; /* [21:18] */
524 __IO uint32_t usbdiv_l : 2; /* [23:22] */
525 __IO uint32_t clkout_sel : 3; /* [26:24] */
526 __IO uint32_t usbdiv_h : 1; /* [27] */
527 __IO uint32_t adcdiv_h : 1; /* [28] */
528 __IO uint32_t pllmult_h : 2; /* [30:29] */
529 __IO uint32_t pllrange : 1; /* [31] */
530 } cfg_bit;
531 };
532
536 union
537 {
538 __IO uint32_t clkint;
539 struct
540 {
541 __IO uint32_t lickstblf : 1; /* [0] */
542 __IO uint32_t lextstblf : 1; /* [1] */
543 __IO uint32_t hickstblf : 1; /* [2] */
544 __IO uint32_t hextstblf : 1; /* [3] */
545 __IO uint32_t pllstblf : 1; /* [4] */
546 __IO uint32_t reserved1 : 2; /* [6:5] */
547 __IO uint32_t cfdf : 1; /* [7] */
548 __IO uint32_t lickstblien : 1; /* [8] */
549 __IO uint32_t lextstblien : 1; /* [9] */
550 __IO uint32_t hickstblien : 1; /* [10] */
551 __IO uint32_t hextstblien : 1; /* [11] */
552 __IO uint32_t pllstblien : 1; /* [12] */
553 __IO uint32_t reserved2 : 3; /* [15:13] */
554 __IO uint32_t lickstblfc : 1; /* [16] */
555 __IO uint32_t lextstblfc : 1; /* [17] */
556 __IO uint32_t hickstblfc : 1; /* [18] */
557 __IO uint32_t hextstblfc : 1; /* [19] */
558 __IO uint32_t pllstblfc : 1; /* [20] */
559 __IO uint32_t reserved3 : 2; /* [22:21] */
560 __IO uint32_t cfdfc : 1; /* [23] */
561 __IO uint32_t reserved4 : 8; /* [31:24] */
562 } clkint_bit;
563 };
564
568 union
569 {
570 __IO uint32_t apb2rst;
571 struct
572 {
573 __IO uint32_t iomuxrst : 1; /* [0] */
574 __IO uint32_t exintrst : 1; /* [1] */
575 __IO uint32_t gpioarst : 1; /* [2] */
576 __IO uint32_t gpiobrst : 1; /* [3] */
577 __IO uint32_t gpiocrst : 1; /* [4] */
578 __IO uint32_t gpiodrst : 1; /* [5] */
579 __IO uint32_t reserved1 : 1; /* [6] */
580 __IO uint32_t gpioerst : 1; /* [7] */
581 __IO uint32_t reserved2 : 1; /* [8] */
582 __IO uint32_t adc1rst : 1; /* [9] */
583 __IO uint32_t adc2rst : 1; /* [10] */
584 __IO uint32_t tmr1rst : 1; /* [11] */
585 __IO uint32_t spi1rst : 1; /* [12] */
586 __IO uint32_t tmr8rst : 1; /* [13] */
587 __IO uint32_t usart1rst : 1; /* [14] */
588 __IO uint32_t reserved3 : 4; /* [18:15] */
589 __IO uint32_t tmr9rst : 1; /* [19] */
590 __IO uint32_t tmr10rst : 1; /* [20] */
591 __IO uint32_t tmr11rst : 1; /* [21] */
592 __IO uint32_t accrst : 1; /* [22] */
593 __IO uint32_t reserved4 : 9; /* [31:23] */
594 } apb2rst_bit;
595 };
596
600 union
601 {
602 __IO uint32_t apb1rst;
603 struct
604 {
605 __IO uint32_t tmr2rst : 1; /* [0] */
606 __IO uint32_t tmr3rst : 1; /* [1] */
607 __IO uint32_t tmr4rst : 1; /* [2] */
608 __IO uint32_t tmr5rst : 1; /* [3] */
609 __IO uint32_t reserved1 : 7; /* [10:4] */
610 __IO uint32_t wwdtrst : 1; /* [11] */
611 __IO uint32_t reserved2 : 2; /* [13:12] */
612 __IO uint32_t spi2rst : 1; /* [14] */
613 __IO uint32_t reserved3 : 2; /* [16:15] */
614 __IO uint32_t usart2rst : 1; /* [17] */
615 __IO uint32_t usart3rst : 1; /* [18] */
616 __IO uint32_t uart4rst : 1; /* [19] */
617 __IO uint32_t uart5rst : 1; /* [20] */
618 __IO uint32_t i2c1rst : 1; /* [21] */
619 __IO uint32_t i2c2rst : 1; /* [22] */
620 __IO uint32_t usbrst : 1; /* [23] */
621 __IO uint32_t reserved4 : 1; /* [24] */
622 __IO uint32_t can1rst : 1; /* [25] */
623 __IO uint32_t reserved5 : 1; /* [26] */
624 __IO uint32_t bprrst : 1; /* [27] */
625 __IO uint32_t pwcrst : 1; /* [28] */
626 __IO uint32_t reserved6 : 2; /* [31:30] */
627 __IO uint32_t can2rst : 1; /* [31] */
628 } apb1rst_bit;
629 };
630
634 union
635 {
636 __IO uint32_t ahben;
637 struct
638 {
639 __IO uint32_t dma1en : 1; /* [0] */
640 __IO uint32_t dma2en : 1; /* [1] */
641 __IO uint32_t sramen : 1; /* [2] */
642 __IO uint32_t reserved1 : 1; /* [3] */
643 __IO uint32_t flashen : 1; /* [4] */
644 __IO uint32_t reserved2 : 1; /* [5] */
645 __IO uint32_t crcen : 1; /* [6] */
646 __IO uint32_t reserved3 : 3; /* [9:7] */
647 __IO uint32_t sdio1en : 1; /* [10] */
648 __IO uint32_t reserved5 : 21;/* [31:11] */
649 } ahben_bit;
650 };
651
655 union
656 {
657 __IO uint32_t apb2en;
658 struct
659 {
660 __IO uint32_t iomuxen : 1; /* [0] */
661 __IO uint32_t reserved1 : 1; /* [1] */
662 __IO uint32_t gpioaen : 1; /* [2] */
663 __IO uint32_t gpioben : 1; /* [3] */
664 __IO uint32_t gpiocen : 1; /* [4] */
665 __IO uint32_t gpioden : 1; /* [5] */
666 __IO uint32_t reserved2 : 1; /* [6] */
667 __IO uint32_t gpiofen : 1; /* [7] */
668 __IO uint32_t reserved3 : 1; /* [8] */
669 __IO uint32_t adc1en : 1; /* [9] */
670 __IO uint32_t adc2en : 1; /* [10] */
671 __IO uint32_t tmr1en : 1; /* [11] */
672 __IO uint32_t spi1en : 1; /* [12] */
673 __IO uint32_t tmr8en : 1; /* [13] */
674 __IO uint32_t usart1en : 1; /* [14] */
675 __IO uint32_t reserved4 : 4; /* [18:15] */
676 __IO uint32_t tmr9en : 1; /* [19] */
677 __IO uint32_t tmr10en : 1; /* [20] */
678 __IO uint32_t tmr11en : 1; /* [21] */
679 __IO uint32_t accen : 1; /* [22] */
680 __IO uint32_t reserved5 : 9; /* [31:23] */
681 } apb2en_bit;
682 };
683
687 union
688 {
689 __IO uint32_t apb1en;
690 struct
691 {
692 __IO uint32_t tmr2en : 1; /* [0] */
693 __IO uint32_t tmr3en : 1; /* [1] */
694 __IO uint32_t tmr4en : 1; /* [2] */
695 __IO uint32_t tmr5en : 1; /* [3] */
696 __IO uint32_t reserved1 : 7; /* [10:4] */
697 __IO uint32_t wwdten : 1; /* [11] */
698 __IO uint32_t reserved2 : 2; /* [13:12] */
699 __IO uint32_t spi2en : 1; /* [14] */
700 __IO uint32_t reserved3 : 2; /* [16:15] */
701 __IO uint32_t usart2en : 1; /* [17] */
702 __IO uint32_t usart3en : 1; /* [18] */
703 __IO uint32_t uart4en : 1; /* [19] */
704 __IO uint32_t uart5en : 1; /* [20] */
705 __IO uint32_t i2c1en : 1; /* [21] */
706 __IO uint32_t i2c2en : 1; /* [22] */
707 __IO uint32_t usben : 1; /* [23] */
708 __IO uint32_t reserved4 : 1; /* [24] */
709 __IO uint32_t can1en : 1; /* [25] */
710 __IO uint32_t reserved5 : 1; /* [26] */
711 __IO uint32_t bpren : 1; /* [27] */
712 __IO uint32_t pwcen : 1; /* [28] */
713 __IO uint32_t reserved6 : 2; /* [30:29] */
714 __IO uint32_t can2en : 1; /* [31] */
715 } apb1en_bit;
716 };
717
721 union
722 {
723 __IO uint32_t bpdc;
724 struct
725 {
726 __IO uint32_t lexten : 1; /* [0] */
727 __IO uint32_t lextstbl : 1; /* [1] */
728 __IO uint32_t lextbyps : 1; /* [2] */
729 __IO uint32_t reserved1 : 5; /* [7:3] */
730 __IO uint32_t rtcsel : 2; /* [9:8] */
731 __IO uint32_t reserved2 : 5; /* [14:10] */
732 __IO uint32_t rtcen : 1; /* [15] */
733 __IO uint32_t bpdrst : 1; /* [16] */
734 __IO uint32_t reserved3 : 15;/* [31:17] */
735 } bpdc_bit;
736 };
737
741 union
742 {
743 __IO uint32_t ctrlsts;
744 struct
745 {
746 __IO uint32_t licken : 1; /* [0] */
747 __IO uint32_t lickstbl : 1; /* [1] */
748 __IO uint32_t reserved1 : 22;/* [23:2] */
749 __IO uint32_t rstfc : 1; /* [24] */
750 __IO uint32_t reserved2 : 1; /* [25] */
751 __IO uint32_t nrstf : 1; /* [26] */
752 __IO uint32_t porrstf : 1; /* [27] */
753 __IO uint32_t swrstf : 1; /* [28] */
754 __IO uint32_t wdtrstf : 1; /* [29] */
755 __IO uint32_t wwdtrstf : 1; /* [30] */
756 __IO uint32_t lprstf : 1; /* [31] */
757 } ctrlsts_bit;
758 };
759
763 __IO uint32_t reserved1[2];
764
768 union
769 {
770 __IO uint32_t misc1;
771 struct
772 {
773 __IO uint32_t hickcal_key : 8; /* [7:0] */
774 __IO uint32_t reserved1 : 8; /* [15:8] */
775 __IO uint32_t clkout_sel : 1; /* [16] */
776 __IO uint32_t reserved2 : 7; /* [23:17] */
777 __IO uint32_t usbbufs : 1; /* [24] */
778 __IO uint32_t hickdiv : 1; /* [25] */
779 __IO uint32_t reserved3 : 2; /* [27:26] */
780 __IO uint32_t clkoutdiv : 4; /* [31:28] */
781 } misc1_bit;
782 };
783
787 __IO uint32_t reserved2[7];
788
792 union
793 {
794 __IO uint32_t misc2;
795 struct
796 {
797 __IO uint32_t reserved1 : 16;/* [15:0] */
798 __IO uint32_t clk_to_tmr : 1; /* [16] */
799 __IO uint32_t reserved2 : 15;/* [31:17] */
800 } misc2_bit;
801 };
802
806 union
807 {
808 __IO uint32_t misc3;
809 struct
810 {
811 __IO uint32_t reserved1 : 4; /* [3:0] */
812 __IO uint32_t auto_step_en : 2; /* [5:4] */
813 __IO uint32_t reserved2 : 2; /* [7:6] */
814 __IO uint32_t hick_to_usb : 1; /* [8] */
815 __IO uint32_t hick_to_sclk : 1; /* [9] */
816 __IO uint32_t reserved3 : 22;/* [31:10] */
817 } misc3_bit;
818 };
819
823 __IO uint32_t reserved3;
824
828 union
829 {
830 __IO uint32_t intmap;
831 struct
832 {
833 __IO uint32_t usbintmap : 1; /* [0] */
834 __IO uint32_t reserved1 : 31;/* [31:1] */
835 } intmap_bit;
836 };
837
838} crm_type;
839
844#define CRM ((crm_type *) CRM_BASE)
845
850void crm_reset(void);
851void crm_lext_bypass(confirm_state new_state);
852void crm_hext_bypass(confirm_state new_state);
853 flag_status crm_flag_get(uint32_t flag);
854 error_status crm_hext_stable_wait(void);
855void crm_hick_clock_trimming_set(uint8_t trim_value);
856void crm_hick_clock_calibration_set(uint8_t cali_value);
857void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state);
858void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state);
859void crm_periph_sleep_mode_clock_enable(crm_periph_clock_sleepmd_type value, confirm_state new_state);
860void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state);
861void crm_flag_clear(uint32_t flag);
862void crm_rtc_clock_select(crm_rtc_clock_type value);
863void crm_rtc_clock_enable(confirm_state new_state);
864void crm_ahb_div_set(crm_ahb_div_type value);
865void crm_apb1_div_set(crm_apb1_div_type value);
866void crm_apb2_div_set(crm_apb2_div_type value);
867void crm_adc_clock_div_set(crm_adc_div_type div_value);
868void crm_usb_clock_div_set(crm_usb_div_type div_value);
869void crm_clock_failure_detection_enable(confirm_state new_state);
870void crm_battery_powered_domain_reset(confirm_state new_state);
871void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range);
872void crm_sysclk_switch(crm_sclk_type value);
873 crm_sclk_type crm_sysclk_switch_status_get(void);
874void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct);
875void crm_clock_out_set(crm_clkout_select_type clkout);
876void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state);
877void crm_auto_step_mode_enable(confirm_state new_state);
878void crm_usb_interrupt_remapping_set(crm_usb_int_map_type int_remap);
879void crm_hick_divider_select(crm_hick_div_6_type value);
880void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value);
881void crm_usb_clock_source_select(crm_usb_clock_source_type value);
882void crm_clkout_to_tmr10_enable(confirm_state new_state);
883void crm_clkout_div_set(crm_clkout_div_type clkout_div);
884
897#ifdef __cplusplus
898}
899#endif
900
901#endif
at32f413.h
at32f413 header file
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:44
crm_periph_sleep_mode_clock_enable
void crm_periph_sleep_mode_clock_enable(crm_periph_clock_sleepmd_type value, confirm_state new_state)
enable or disable the peripheral clock in sleep mode
Definition: at32f413_crm.c:259
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hick_clock_calibration_set
void crm_hick_clock_calibration_set(uint8_t cali_value)
set the crm calibration value
Definition: at32f413_crm.c:178
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:804
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:376
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:386
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_interrupt_enable
void crm_interrupt_enable(uint32_t crm_int, confirm_state new_state)
config crm interrupt
Definition: at32f413_crm.c:701
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:330
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_lext_bypass
void crm_lext_bypass(confirm_state new_state)
enable or disable crm low speed external crystal bypass
Definition: at32f413_crm.c:83
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_hick_sclk_frequency_select
void crm_hick_sclk_frequency_select(crm_hick_sclk_frequency_type value)
hick as system clock frequency select
Definition: at32f413_crm.c:756
crm_hick_divider_select
void crm_hick_divider_select(crm_hick_div_6_type value)
config hick divider select
Definition: at32f413_crm.c:743
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:683
crm_clock_failure_detection_enable
void crm_clock_failure_detection_enable(confirm_state new_state)
enable or disable clock failure detection
Definition: at32f413_crm.c:485
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_clkout_to_tmr10_enable
void crm_clkout_to_tmr10_enable(confirm_state new_state)
enable or disable clkout direct to tmr10 channel 1
Definition: at32f413_crm.c:784
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_usb_interrupt_remapping_set
void crm_usb_interrupt_remapping_set(crm_usb_int_map_type int_remap)
usbdev interrupt remapping control
Definition: at32f413_crm.c:730
crm_hick_clock_trimming_set
void crm_hick_clock_trimming_set(uint8_t trim_value)
set the hick trimming value
Definition: at32f413_crm.c:168
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
crm_battery_powered_domain_reset
void crm_battery_powered_domain_reset(confirm_state new_state)
battery powered domain software reset
Definition: at32f413_crm.c:495
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
crm_hext_bypass
void crm_hext_bypass(confirm_state new_state)
enable or disable crm high speed external crystal bypass
Definition: at32f413_crm.c:93
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
crm_periph_clock_type
crm_periph_clock_type
crm periph clock
Definition: at32f413_crm.h:102
crm_hick_sclk_frequency_type
crm_hick_sclk_frequency_type
crm hick as system clock frequency select
Definition: at32f413_crm.h:462
crm_apb1_div_type
crm_apb1_div_type
crm apb1 division
Definition: at32f413_crm.h:321
crm_clock_source_type
crm_clock_source_type
crm clock source
Definition: at32f413_crm.h:293
crm_usb_div_type
crm_usb_div_type
crm usb division
Definition: at32f413_crm.h:358
crm_clkout_div_type
crm_clkout_div_type
crm clkout division
Definition: at32f413_crm.h:419
crm_usb_clock_source_type
crm_usb_clock_source_type
crm usb 48 mhz clock source select
Definition: at32f413_crm.h:453
crm_periph_clock_sleepmd_type
crm_periph_clock_sleepmd_type
crm periph clock in sleep mode
Definition: at32f413_crm.h:194
crm_pll_clock_source_type
crm_pll_clock_source_type
crm pll clock source
Definition: at32f413_crm.h:274
crm_pll_mult_type
crm_pll_mult_type
crm pll mult_x
Definition: at32f413_crm.h:204
crm_ahb_div_type
crm_ahb_div_type
crm ahb division
Definition: at32f413_crm.h:305
crm_rtc_clock_type
crm_rtc_clock_type
crm rtc clock
Definition: at32f413_crm.h:372
crm_adc_div_type
crm_adc_div_type
crm adc division
Definition: at32f413_crm.h:345
crm_usb_int_map_type
crm_usb_int_map_type
crm usbdev interrupt remap
Definition: at32f413_crm.h:444
crm_clkout_select_type
crm_clkout_select_type
crm clkout select
Definition: at32f413_crm.h:402
crm_auto_step_mode_type
crm_auto_step_mode_type
crm auto step mode
Definition: at32f413_crm.h:435
crm_sclk_type
crm_sclk_type
crm sclk select
Definition: at32f413_crm.h:392
crm_periph_reset_type
crm_periph_reset_type
crm periph reset
Definition: at32f413_crm.h:150
crm_apb2_div_type
crm_apb2_div_type
crm apb2 division
Definition: at32f413_crm.h:333
crm_pll_output_range_type
crm_pll_output_range_type
crm pll clock output range
Definition: at32f413_crm.h:284
crm_hick_div_6_type
crm_hick_div_6_type
crm hick 48mhz division
Definition: at32f413_crm.h:383
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_TMR10_PERIPH_CLOCK
@ CRM_TMR10_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:112
CRM_GPIOF_PERIPH_CLOCK
@ CRM_GPIOF_PERIPH_CLOCK
Definition: at32f413_crm.h:114
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_UART5_PERIPH_CLOCK
@ CRM_UART5_PERIPH_CLOCK
Definition: at32f413_crm.h:135
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:140
CRM_TMR9_PERIPH_CLOCK
@ CRM_TMR9_PERIPH_CLOCK
Definition: at32f413_crm.h:121
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:133
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_I2C1_PERIPH_CLOCK
@ CRM_I2C1_PERIPH_CLOCK
Definition: at32f413_crm.h:136
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:128
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f413_crm.h:106
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_TMR8_PERIPH_CLOCK
@ CRM_TMR8_PERIPH_CLOCK
Definition: at32f413_crm.h:119
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:120
CRM_UART4_PERIPH_CLOCK
@ CRM_UART4_PERIPH_CLOCK
Definition: at32f413_crm.h:134
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_CAN2_PERIPH_CLOCK
@ CRM_CAN2_PERIPH_CLOCK
Definition: at32f413_crm.h:142
CRM_I2C2_PERIPH_CLOCK
@ CRM_I2C2_PERIPH_CLOCK
Definition: at32f413_crm.h:137
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f413_crm.h:105
CRM_TMR5_PERIPH_CLOCK
@ CRM_TMR5_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
CRM_TMR11_PERIPH_CLOCK
@ CRM_TMR11_PERIPH_CLOCK
Definition: at32f413_crm.h:123
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
CRM_WWDT_PERIPH_CLOCK
@ CRM_WWDT_PERIPH_CLOCK
Definition: at32f413_crm.h:130
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_HICK_SCLK_48MHZ
@ CRM_HICK_SCLK_48MHZ
Definition: at32f413_crm.h:464
CRM_HICK_SCLK_8MHZ
@ CRM_HICK_SCLK_8MHZ
Definition: at32f413_crm.h:463
CRM_APB1_DIV_8
@ CRM_APB1_DIV_8
Definition: at32f413_crm.h:325
CRM_APB1_DIV_4
@ CRM_APB1_DIV_4
Definition: at32f413_crm.h:324
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_APB1_DIV_16
@ CRM_APB1_DIV_16
Definition: at32f413_crm.h:326
CRM_APB1_DIV_1
@ CRM_APB1_DIV_1
Definition: at32f413_crm.h:322
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f413_crm.h:297
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:298
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_CLKOUT_DIV_2
@ CRM_CLKOUT_DIV_2
Definition: at32f413_crm.h:421
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:420
CRM_CLKOUT_DIV_128
@ CRM_CLKOUT_DIV_128
Definition: at32f413_crm.h:426
CRM_CLKOUT_DIV_64
@ CRM_CLKOUT_DIV_64
Definition: at32f413_crm.h:425
CRM_CLKOUT_DIV_8
@ CRM_CLKOUT_DIV_8
Definition: at32f413_crm.h:423
CRM_CLKOUT_DIV_16
@ CRM_CLKOUT_DIV_16
Definition: at32f413_crm.h:424
CRM_CLKOUT_DIV_256
@ CRM_CLKOUT_DIV_256
Definition: at32f413_crm.h:427
CRM_CLKOUT_DIV_4
@ CRM_CLKOUT_DIV_4
Definition: at32f413_crm.h:422
CRM_CLKOUT_DIV_512
@ CRM_CLKOUT_DIV_512
Definition: at32f413_crm.h:428
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
CRM_USB_CLOCK_SOURCE_PLL
@ CRM_USB_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:454
CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE
@ CRM_FLASH_PERIPH_CLOCK_SLEEP_MODE
Definition: at32f413_crm.h:197
CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE
@ CRM_SRAM_PERIPH_CLOCK_SLEEP_MODE
Definition: at32f413_crm.h:196
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_SOURCE_HEXT
@ CRM_PLL_SOURCE_HEXT
Definition: at32f413_crm.h:276
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:275
CRM_PLL_MULT_17
@ CRM_PLL_MULT_17
Definition: at32f413_crm.h:220
CRM_PLL_MULT_24
@ CRM_PLL_MULT_24
Definition: at32f413_crm.h:227
CRM_PLL_MULT_53
@ CRM_PLL_MULT_53
Definition: at32f413_crm.h:256
CRM_PLL_MULT_61
@ CRM_PLL_MULT_61
Definition: at32f413_crm.h:264
CRM_PLL_MULT_27
@ CRM_PLL_MULT_27
Definition: at32f413_crm.h:230
CRM_PLL_MULT_50
@ CRM_PLL_MULT_50
Definition: at32f413_crm.h:253
CRM_PLL_MULT_41
@ CRM_PLL_MULT_41
Definition: at32f413_crm.h:244
CRM_PLL_MULT_56
@ CRM_PLL_MULT_56
Definition: at32f413_crm.h:259
CRM_PLL_MULT_11
@ CRM_PLL_MULT_11
Definition: at32f413_crm.h:214
CRM_PLL_MULT_37
@ CRM_PLL_MULT_37
Definition: at32f413_crm.h:240
CRM_PLL_MULT_63
@ CRM_PLL_MULT_63
Definition: at32f413_crm.h:266
CRM_PLL_MULT_18
@ CRM_PLL_MULT_18
Definition: at32f413_crm.h:221
CRM_PLL_MULT_9
@ CRM_PLL_MULT_9
Definition: at32f413_crm.h:212
CRM_PLL_MULT_4
@ CRM_PLL_MULT_4
Definition: at32f413_crm.h:207
CRM_PLL_MULT_35
@ CRM_PLL_MULT_35
Definition: at32f413_crm.h:238
CRM_PLL_MULT_14
@ CRM_PLL_MULT_14
Definition: at32f413_crm.h:217
CRM_PLL_MULT_28
@ CRM_PLL_MULT_28
Definition: at32f413_crm.h:231
CRM_PLL_MULT_62
@ CRM_PLL_MULT_62
Definition: at32f413_crm.h:265
CRM_PLL_MULT_20
@ CRM_PLL_MULT_20
Definition: at32f413_crm.h:223
CRM_PLL_MULT_47
@ CRM_PLL_MULT_47
Definition: at32f413_crm.h:250
CRM_PLL_MULT_32
@ CRM_PLL_MULT_32
Definition: at32f413_crm.h:235
CRM_PLL_MULT_58
@ CRM_PLL_MULT_58
Definition: at32f413_crm.h:261
CRM_PLL_MULT_10
@ CRM_PLL_MULT_10
Definition: at32f413_crm.h:213
CRM_PLL_MULT_44
@ CRM_PLL_MULT_44
Definition: at32f413_crm.h:247
CRM_PLL_MULT_5
@ CRM_PLL_MULT_5
Definition: at32f413_crm.h:208
CRM_PLL_MULT_34
@ CRM_PLL_MULT_34
Definition: at32f413_crm.h:237
CRM_PLL_MULT_15
@ CRM_PLL_MULT_15
Definition: at32f413_crm.h:218
CRM_PLL_MULT_39
@ CRM_PLL_MULT_39
Definition: at32f413_crm.h:242
CRM_PLL_MULT_13
@ CRM_PLL_MULT_13
Definition: at32f413_crm.h:216
CRM_PLL_MULT_45
@ CRM_PLL_MULT_45
Definition: at32f413_crm.h:248
CRM_PLL_MULT_12
@ CRM_PLL_MULT_12
Definition: at32f413_crm.h:215
CRM_PLL_MULT_33
@ CRM_PLL_MULT_33
Definition: at32f413_crm.h:236
CRM_PLL_MULT_64
@ CRM_PLL_MULT_64
Definition: at32f413_crm.h:267
CRM_PLL_MULT_31
@ CRM_PLL_MULT_31
Definition: at32f413_crm.h:234
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_PLL_MULT_19
@ CRM_PLL_MULT_19
Definition: at32f413_crm.h:222
CRM_PLL_MULT_29
@ CRM_PLL_MULT_29
Definition: at32f413_crm.h:232
CRM_PLL_MULT_49
@ CRM_PLL_MULT_49
Definition: at32f413_crm.h:252
CRM_PLL_MULT_3
@ CRM_PLL_MULT_3
Definition: at32f413_crm.h:206
CRM_PLL_MULT_36
@ CRM_PLL_MULT_36
Definition: at32f413_crm.h:239
CRM_PLL_MULT_21
@ CRM_PLL_MULT_21
Definition: at32f413_crm.h:224
CRM_PLL_MULT_40
@ CRM_PLL_MULT_40
Definition: at32f413_crm.h:243
CRM_PLL_MULT_46
@ CRM_PLL_MULT_46
Definition: at32f413_crm.h:249
CRM_PLL_MULT_59
@ CRM_PLL_MULT_59
Definition: at32f413_crm.h:262
CRM_PLL_MULT_2
@ CRM_PLL_MULT_2
Definition: at32f413_crm.h:205
CRM_PLL_MULT_54
@ CRM_PLL_MULT_54
Definition: at32f413_crm.h:257
CRM_PLL_MULT_7
@ CRM_PLL_MULT_7
Definition: at32f413_crm.h:210
CRM_PLL_MULT_25
@ CRM_PLL_MULT_25
Definition: at32f413_crm.h:228
CRM_PLL_MULT_22
@ CRM_PLL_MULT_22
Definition: at32f413_crm.h:225
CRM_PLL_MULT_51
@ CRM_PLL_MULT_51
Definition: at32f413_crm.h:254
CRM_PLL_MULT_57
@ CRM_PLL_MULT_57
Definition: at32f413_crm.h:260
CRM_PLL_MULT_43
@ CRM_PLL_MULT_43
Definition: at32f413_crm.h:246
CRM_PLL_MULT_55
@ CRM_PLL_MULT_55
Definition: at32f413_crm.h:258
CRM_PLL_MULT_42
@ CRM_PLL_MULT_42
Definition: at32f413_crm.h:245
CRM_PLL_MULT_23
@ CRM_PLL_MULT_23
Definition: at32f413_crm.h:226
CRM_PLL_MULT_38
@ CRM_PLL_MULT_38
Definition: at32f413_crm.h:241
CRM_PLL_MULT_16
@ CRM_PLL_MULT_16
Definition: at32f413_crm.h:219
CRM_PLL_MULT_30
@ CRM_PLL_MULT_30
Definition: at32f413_crm.h:233
CRM_PLL_MULT_52
@ CRM_PLL_MULT_52
Definition: at32f413_crm.h:255
CRM_PLL_MULT_6
@ CRM_PLL_MULT_6
Definition: at32f413_crm.h:209
CRM_PLL_MULT_26
@ CRM_PLL_MULT_26
Definition: at32f413_crm.h:229
CRM_PLL_MULT_8
@ CRM_PLL_MULT_8
Definition: at32f413_crm.h:211
CRM_PLL_MULT_60
@ CRM_PLL_MULT_60
Definition: at32f413_crm.h:263
CRM_AHB_DIV_4
@ CRM_AHB_DIV_4
Definition: at32f413_crm.h:308
CRM_AHB_DIV_16
@ CRM_AHB_DIV_16
Definition: at32f413_crm.h:310
CRM_AHB_DIV_64
@ CRM_AHB_DIV_64
Definition: at32f413_crm.h:311
CRM_AHB_DIV_8
@ CRM_AHB_DIV_8
Definition: at32f413_crm.h:309
CRM_AHB_DIV_512
@ CRM_AHB_DIV_512
Definition: at32f413_crm.h:314
CRM_AHB_DIV_128
@ CRM_AHB_DIV_128
Definition: at32f413_crm.h:312
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_AHB_DIV_256
@ CRM_AHB_DIV_256
Definition: at32f413_crm.h:313
CRM_AHB_DIV_2
@ CRM_AHB_DIV_2
Definition: at32f413_crm.h:307
CRM_RTC_CLOCK_HEXT_DIV
@ CRM_RTC_CLOCK_HEXT_DIV
Definition: at32f413_crm.h:376
CRM_RTC_CLOCK_LICK
@ CRM_RTC_CLOCK_LICK
Definition: at32f413_crm.h:375
CRM_RTC_CLOCK_LEXT
@ CRM_RTC_CLOCK_LEXT
Definition: at32f413_crm.h:374
CRM_RTC_CLOCK_NOCLK
@ CRM_RTC_CLOCK_NOCLK
Definition: at32f413_crm.h:373
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:348
CRM_ADC_DIV_16
@ CRM_ADC_DIV_16
Definition: at32f413_crm.h:351
CRM_ADC_DIV_4
@ CRM_ADC_DIV_4
Definition: at32f413_crm.h:347
CRM_ADC_DIV_12
@ CRM_ADC_DIV_12
Definition: at32f413_crm.h:350
CRM_ADC_DIV_2
@ CRM_ADC_DIV_2
Definition: at32f413_crm.h:346
CRM_ADC_DIV_8
@ CRM_ADC_DIV_8
Definition: at32f413_crm.h:349
CRM_USB_INT73_INT74
@ CRM_USB_INT73_INT74
Definition: at32f413_crm.h:446
CRM_USB_INT19_INT20
@ CRM_USB_INT19_INT20
Definition: at32f413_crm.h:445
CRM_CLKOUT_NOCLK
@ CRM_CLKOUT_NOCLK
Definition: at32f413_crm.h:403
CRM_CLKOUT_HICK
@ CRM_CLKOUT_HICK
Definition: at32f413_crm.h:407
CRM_CLKOUT_USB
@ CRM_CLKOUT_USB
Definition: at32f413_crm.h:411
CRM_CLKOUT_LICK
@ CRM_CLKOUT_LICK
Definition: at32f413_crm.h:404
CRM_CLKOUT_PLL_DIV_2
@ CRM_CLKOUT_PLL_DIV_2
Definition: at32f413_crm.h:409
CRM_CLKOUT_ADC
@ CRM_CLKOUT_ADC
Definition: at32f413_crm.h:412
CRM_CLKOUT_LEXT
@ CRM_CLKOUT_LEXT
Definition: at32f413_crm.h:405
CRM_CLKOUT_SCLK
@ CRM_CLKOUT_SCLK
Definition: at32f413_crm.h:406
CRM_CLKOUT_PLL_DIV_4
@ CRM_CLKOUT_PLL_DIV_4
Definition: at32f413_crm.h:410
CRM_CLKOUT_HEXT
@ CRM_CLKOUT_HEXT
Definition: at32f413_crm.h:408
CRM_AUTO_STEP_MODE_ENABLE
@ CRM_AUTO_STEP_MODE_ENABLE
Definition: at32f413_crm.h:437
CRM_AUTO_STEP_MODE_DISABLE
@ CRM_AUTO_STEP_MODE_DISABLE
Definition: at32f413_crm.h:436
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f413_crm.h:393
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_SCLK_HEXT
@ CRM_SCLK_HEXT
Definition: at32f413_crm.h:394
CRM_TMR2_PERIPH_RESET
@ CRM_TMR2_PERIPH_RESET
Definition: at32f413_crm.h:170
CRM_TMR4_PERIPH_RESET
@ CRM_TMR4_PERIPH_RESET
Definition: at32f413_crm.h:172
CRM_SPI1_PERIPH_RESET
@ CRM_SPI1_PERIPH_RESET
Definition: at32f413_crm.h:162
CRM_TMR10_PERIPH_RESET
@ CRM_TMR10_PERIPH_RESET
Definition: at32f413_crm.h:166
CRM_I2C2_PERIPH_RESET
@ CRM_I2C2_PERIPH_RESET
Definition: at32f413_crm.h:181
CRM_UART4_PERIPH_RESET
@ CRM_UART4_PERIPH_RESET
Definition: at32f413_crm.h:178
CRM_BPR_PERIPH_RESET
@ CRM_BPR_PERIPH_RESET
Definition: at32f413_crm.h:184
CRM_ADC2_PERIPH_RESET
@ CRM_ADC2_PERIPH_RESET
Definition: at32f413_crm.h:160
CRM_USART1_PERIPH_RESET
@ CRM_USART1_PERIPH_RESET
Definition: at32f413_crm.h:164
CRM_IOMUX_PERIPH_RESET
@ CRM_IOMUX_PERIPH_RESET
Definition: at32f413_crm.h:152
CRM_CAN1_PERIPH_RESET
@ CRM_CAN1_PERIPH_RESET
Definition: at32f413_crm.h:183
CRM_TMR5_PERIPH_RESET
@ CRM_TMR5_PERIPH_RESET
Definition: at32f413_crm.h:173
CRM_TMR9_PERIPH_RESET
@ CRM_TMR9_PERIPH_RESET
Definition: at32f413_crm.h:165
CRM_GPIOF_PERIPH_RESET
@ CRM_GPIOF_PERIPH_RESET
Definition: at32f413_crm.h:158
CRM_TMR1_PERIPH_RESET
@ CRM_TMR1_PERIPH_RESET
Definition: at32f413_crm.h:161
CRM_GPIOD_PERIPH_RESET
@ CRM_GPIOD_PERIPH_RESET
Definition: at32f413_crm.h:157
CRM_USART2_PERIPH_RESET
@ CRM_USART2_PERIPH_RESET
Definition: at32f413_crm.h:176
CRM_GPIOC_PERIPH_RESET
@ CRM_GPIOC_PERIPH_RESET
Definition: at32f413_crm.h:156
CRM_CAN2_PERIPH_RESET
@ CRM_CAN2_PERIPH_RESET
Definition: at32f413_crm.h:186
CRM_ACC_PERIPH_RESET
@ CRM_ACC_PERIPH_RESET
Definition: at32f413_crm.h:168
CRM_TMR8_PERIPH_RESET
@ CRM_TMR8_PERIPH_RESET
Definition: at32f413_crm.h:163
CRM_WWDT_PERIPH_RESET
@ CRM_WWDT_PERIPH_RESET
Definition: at32f413_crm.h:174
CRM_UART5_PERIPH_RESET
@ CRM_UART5_PERIPH_RESET
Definition: at32f413_crm.h:179
CRM_ADC1_PERIPH_RESET
@ CRM_ADC1_PERIPH_RESET
Definition: at32f413_crm.h:159
CRM_EXINT_PERIPH_RESET
@ CRM_EXINT_PERIPH_RESET
Definition: at32f413_crm.h:153
CRM_TMR3_PERIPH_RESET
@ CRM_TMR3_PERIPH_RESET
Definition: at32f413_crm.h:171
CRM_USB_PERIPH_RESET
@ CRM_USB_PERIPH_RESET
Definition: at32f413_crm.h:182
CRM_SPI2_PERIPH_RESET
@ CRM_SPI2_PERIPH_RESET
Definition: at32f413_crm.h:175
CRM_PWC_PERIPH_RESET
@ CRM_PWC_PERIPH_RESET
Definition: at32f413_crm.h:185
CRM_GPIOA_PERIPH_RESET
@ CRM_GPIOA_PERIPH_RESET
Definition: at32f413_crm.h:154
CRM_TMR11_PERIPH_RESET
@ CRM_TMR11_PERIPH_RESET
Definition: at32f413_crm.h:167
CRM_USART3_PERIPH_RESET
@ CRM_USART3_PERIPH_RESET
Definition: at32f413_crm.h:177
CRM_GPIOB_PERIPH_RESET
@ CRM_GPIOB_PERIPH_RESET
Definition: at32f413_crm.h:155
CRM_I2C1_PERIPH_RESET
@ CRM_I2C1_PERIPH_RESET
Definition: at32f413_crm.h:180
CRM_APB2_DIV_4
@ CRM_APB2_DIV_4
Definition: at32f413_crm.h:336
CRM_APB2_DIV_1
@ CRM_APB2_DIV_1
Definition: at32f413_crm.h:334
CRM_APB2_DIV_16
@ CRM_APB2_DIV_16
Definition: at32f413_crm.h:338
CRM_APB2_DIV_8
@ CRM_APB2_DIV_8
Definition: at32f413_crm.h:337
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_LE72MHZ
@ CRM_PLL_OUTPUT_RANGE_LE72MHZ
Definition: at32f413_crm.h:285
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_HICK48_NODIV
@ CRM_HICK48_NODIV
Definition: at32f413_crm.h:385
CRM_HICK48_DIV6
@ CRM_HICK48_DIV6
Definition: at32f413_crm.h:384
MAKE_VALUE
#define MAKE_VALUE(reg_offset, bit_num)
Definition: at32f413.h:278
error_status
error_status
error status
Definition: at32f413.h:264
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::adc_freq
uint32_t adc_freq
Definition: at32f413_crm.h:476
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:475
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f413_crm.h:474
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:473
crm_type
type define crm register all
Definition: at32f413_crm.h:483
crm_type::misc1
__IO uint32_t misc1
Definition: at32f413_crm.h:770
crm_type::lickstblien
__IO uint32_t lickstblien
Definition: at32f413_crm.h:548
crm_type::uart4en
__IO uint32_t uart4en
Definition: at32f413_crm.h:703
crm_type::auto_step_en
__IO uint32_t auto_step_en
Definition: at32f413_crm.h:812
crm_type::usart1en
__IO uint32_t usart1en
Definition: at32f413_crm.h:674
crm_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_crm.h:489
crm_type::adc2en
__IO uint32_t adc2en
Definition: at32f413_crm.h:670
crm_type::apb2en
__IO uint32_t apb2en
Definition: at32f413_crm.h:657
crm_type::apb1rst
__IO uint32_t apb1rst
Definition: at32f413_crm.h:602
crm_type::uart4rst
__IO uint32_t uart4rst
Definition: at32f413_crm.h:616
crm_type::misc2
__IO uint32_t misc2
Definition: at32f413_crm.h:794
crm_type::tmr11rst
__IO uint32_t tmr11rst
Definition: at32f413_crm.h:591
crm_type::accen
__IO uint32_t accen
Definition: at32f413_crm.h:679
crm_type::i2c2rst
__IO uint32_t i2c2rst
Definition: at32f413_crm.h:619
crm_type::apb2rst
__IO uint32_t apb2rst
Definition: at32f413_crm.h:570
crm_type::adc1rst
__IO uint32_t adc1rst
Definition: at32f413_crm.h:582
crm_type::adcdiv_h
__IO uint32_t adcdiv_h
Definition: at32f413_crm.h:527
crm_type::cfdf
__IO uint32_t cfdf
Definition: at32f413_crm.h:547
crm_type::gpioerst
__IO uint32_t gpioerst
Definition: at32f413_crm.h:580
crm_type::pllmult_l
__IO uint32_t pllmult_l
Definition: at32f413_crm.h:523
crm_type::reserved5
__IO uint32_t reserved5
Definition: at32f413_crm.h:623
crm_type::tmr3en
__IO uint32_t tmr3en
Definition: at32f413_crm.h:693
crm_type::usart2rst
__IO uint32_t usart2rst
Definition: at32f413_crm.h:614
crm_type::tmr3rst
__IO uint32_t tmr3rst
Definition: at32f413_crm.h:606
crm_type::hexten
__IO uint32_t hexten
Definition: at32f413_crm.h:496
crm_type::gpiocrst
__IO uint32_t gpiocrst
Definition: at32f413_crm.h:577
crm_type::bpdc
__IO uint32_t bpdc
Definition: at32f413_crm.h:723
crm_type::dma1en
__IO uint32_t dma1en
Definition: at32f413_crm.h:639
crm_type::tmr4en
__IO uint32_t tmr4en
Definition: at32f413_crm.h:694
crm_type::usbrst
__IO uint32_t usbrst
Definition: at32f413_crm.h:620
crm_type::tmr1en
__IO uint32_t tmr1en
Definition: at32f413_crm.h:671
crm_type::hickcal_key
__IO uint32_t hickcal_key
Definition: at32f413_crm.h:773
crm_type::pllstblfc
__IO uint32_t pllstblfc
Definition: at32f413_crm.h:558
crm_type::clk_to_tmr
__IO uint32_t clk_to_tmr
Definition: at32f413_crm.h:798
crm_type::rtcsel
__IO uint32_t rtcsel
Definition: at32f413_crm.h:730
crm_type::uart5en
__IO uint32_t uart5en
Definition: at32f413_crm.h:704
crm_type::hick_to_usb
__IO uint32_t hick_to_usb
Definition: at32f413_crm.h:814
crm_type::pllhextdiv
__IO uint32_t pllhextdiv
Definition: at32f413_crm.h:522
crm_type::lprstf
__IO uint32_t lprstf
Definition: at32f413_crm.h:756
crm_type::uart5rst
__IO uint32_t uart5rst
Definition: at32f413_crm.h:617
crm_type::hickcal
__IO uint32_t hickcal
Definition: at32f413_crm.h:495
crm_type::sclksel
__IO uint32_t sclksel
Definition: at32f413_crm.h:515
crm_type::gpioben
__IO uint32_t gpioben
Definition: at32f413_crm.h:663
crm_type::tmr11en
__IO uint32_t tmr11en
Definition: at32f413_crm.h:678
crm_type::gpioden
__IO uint32_t gpioden
Definition: at32f413_crm.h:665
crm_type::lextstblfc
__IO uint32_t lextstblfc
Definition: at32f413_crm.h:555
crm_type::reserved1
__IO uint32_t reserved1
crm reserved1 register, offset:0x28~0x2C
Definition: at32f413_crm.h:500
crm_type::usbbufs
__IO uint32_t usbbufs
Definition: at32f413_crm.h:777
crm_type::tmr8en
__IO uint32_t tmr8en
Definition: at32f413_crm.h:673
crm_type::gpiofen
__IO uint32_t gpiofen
Definition: at32f413_crm.h:667
crm_type::hextbyps
__IO uint32_t hextbyps
Definition: at32f413_crm.h:498
crm_type::wdtrstf
__IO uint32_t wdtrstf
Definition: at32f413_crm.h:754
crm_type::bpdrst
__IO uint32_t bpdrst
Definition: at32f413_crm.h:733
crm_type::tmr10en
__IO uint32_t tmr10en
Definition: at32f413_crm.h:677
crm_type::usart2en
__IO uint32_t usart2en
Definition: at32f413_crm.h:701
crm_type::lickstbl
__IO uint32_t lickstbl
Definition: at32f413_crm.h:747
crm_type::tmr9rst
__IO uint32_t tmr9rst
Definition: at32f413_crm.h:589
crm_type::tmr8rst
__IO uint32_t tmr8rst
Definition: at32f413_crm.h:586
crm_type::nrstf
__IO uint32_t nrstf
Definition: at32f413_crm.h:751
crm_type::sramen
__IO uint32_t sramen
Definition: at32f413_crm.h:641
crm_type::usbintmap
__IO uint32_t usbintmap
Definition: at32f413_crm.h:833
crm_type::lickstblfc
__IO uint32_t lickstblfc
Definition: at32f413_crm.h:554
crm_type::swrstf
__IO uint32_t swrstf
Definition: at32f413_crm.h:753
crm_type::cfdfc
__IO uint32_t cfdfc
Definition: at32f413_crm.h:560
crm_type::can2rst
__IO uint32_t can2rst
Definition: at32f413_crm.h:627
crm_type::gpioarst
__IO uint32_t gpioarst
Definition: at32f413_crm.h:575
crm_type::apb1en
__IO uint32_t apb1en
Definition: at32f413_crm.h:689
crm_type::tmr10rst
__IO uint32_t tmr10rst
Definition: at32f413_crm.h:590
crm_type::rstfc
__IO uint32_t rstfc
Definition: at32f413_crm.h:749
crm_type::tmr1rst
__IO uint32_t tmr1rst
Definition: at32f413_crm.h:584
crm_type::tmr5en
__IO uint32_t tmr5en
Definition: at32f413_crm.h:695
crm_type::hextstbl
__IO uint32_t hextstbl
Definition: at32f413_crm.h:497
crm_type::usart1rst
__IO uint32_t usart1rst
Definition: at32f413_crm.h:587
crm_type::gpioaen
__IO uint32_t gpioaen
Definition: at32f413_crm.h:662
crm_type::misc3
__IO uint32_t misc3
Definition: at32f413_crm.h:808
crm_type::spi2rst
__IO uint32_t spi2rst
Definition: at32f413_crm.h:612
crm_type::spi1rst
__IO uint32_t spi1rst
Definition: at32f413_crm.h:585
crm_type::cfg
__IO uint32_t cfg
Definition: at32f413_crm.h:512
crm_type::i2c1rst
__IO uint32_t i2c1rst
Definition: at32f413_crm.h:618
crm_type::licken
__IO uint32_t licken
Definition: at32f413_crm.h:746
crm_type::pllrcs
__IO uint32_t pllrcs
Definition: at32f413_crm.h:521
crm_type::tmr9en
__IO uint32_t tmr9en
Definition: at32f413_crm.h:676
crm_type::hickstblfc
__IO uint32_t hickstblfc
Definition: at32f413_crm.h:556
crm_type::hickstblien
__IO uint32_t hickstblien
Definition: at32f413_crm.h:550
crm_type::pllstblf
__IO uint32_t pllstblf
Definition: at32f413_crm.h:545
crm_type::hicktrim
__IO uint32_t hicktrim
Definition: at32f413_crm.h:494
crm_type::sdio1en
__IO uint32_t sdio1en
Definition: at32f413_crm.h:647
crm_type::ahben
__IO uint32_t ahben
Definition: at32f413_crm.h:636
crm_type::pllmult_h
__IO uint32_t pllmult_h
Definition: at32f413_crm.h:528
crm_type::wwdten
__IO uint32_t wwdten
Definition: at32f413_crm.h:697
crm_type::flashen
__IO uint32_t flashen
Definition: at32f413_crm.h:643
crm_type::reserved6
__IO uint32_t reserved6
Definition: at32f413_crm.h:626
crm_type::usart3rst
__IO uint32_t usart3rst
Definition: at32f413_crm.h:615
crm_type::gpiocen
__IO uint32_t gpiocen
Definition: at32f413_crm.h:664
crm_type::iomuxen
__IO uint32_t iomuxen
Definition: at32f413_crm.h:660
crm_type::usben
__IO uint32_t usben
Definition: at32f413_crm.h:707
crm_type::usbdiv_h
__IO uint32_t usbdiv_h
Definition: at32f413_crm.h:526
crm_type::lextstblf
__IO uint32_t lextstblf
Definition: at32f413_crm.h:542
crm_type::clkoutdiv
__IO uint32_t clkoutdiv
Definition: at32f413_crm.h:780
crm_type::rtcen
__IO uint32_t rtcen
Definition: at32f413_crm.h:732
crm_type::pwcrst
__IO uint32_t pwcrst
Definition: at32f413_crm.h:625
crm_type::apb2div
__IO uint32_t apb2div
Definition: at32f413_crm.h:519
crm_type::wwdtrst
__IO uint32_t wwdtrst
Definition: at32f413_crm.h:610
crm_type::usart3en
__IO uint32_t usart3en
Definition: at32f413_crm.h:702
crm_type::tmr2rst
__IO uint32_t tmr2rst
Definition: at32f413_crm.h:605
crm_type::adc1en
__IO uint32_t adc1en
Definition: at32f413_crm.h:669
crm_type::pllstbl
__IO uint32_t pllstbl
Definition: at32f413_crm.h:502
crm_type::pllstblien
__IO uint32_t pllstblien
Definition: at32f413_crm.h:552
crm_type::can1rst
__IO uint32_t can1rst
Definition: at32f413_crm.h:622
crm_type::can1en
__IO uint32_t can1en
Definition: at32f413_crm.h:709
crm_type::adc2rst
__IO uint32_t adc2rst
Definition: at32f413_crm.h:583
crm_type::exintrst
__IO uint32_t exintrst
Definition: at32f413_crm.h:574
crm_type::lextbyps
__IO uint32_t lextbyps
Definition: at32f413_crm.h:728
crm_type::lextstbl
__IO uint32_t lextstbl
Definition: at32f413_crm.h:727
crm_type::usbdiv_l
__IO uint32_t usbdiv_l
Definition: at32f413_crm.h:524
crm_type::reserved3
__IO uint32_t reserved3
crm reserved3 register, offset:0x58
Definition: at32f413_crm.h:559
crm_type::crcen
__IO uint32_t crcen
Definition: at32f413_crm.h:645
crm_type::tmr2en
__IO uint32_t tmr2en
Definition: at32f413_crm.h:692
crm_type::hick_to_sclk
__IO uint32_t hick_to_sclk
Definition: at32f413_crm.h:815
crm_type::sclksts
__IO uint32_t sclksts
Definition: at32f413_crm.h:516
crm_type::i2c1en
__IO uint32_t i2c1en
Definition: at32f413_crm.h:705
crm_type::hextstblien
__IO uint32_t hextstblien
Definition: at32f413_crm.h:551
crm_type::gpiodrst
__IO uint32_t gpiodrst
Definition: at32f413_crm.h:578
crm_type::ctrlsts
__IO uint32_t ctrlsts
Definition: at32f413_crm.h:743
crm_type::bpren
__IO uint32_t bpren
Definition: at32f413_crm.h:711
crm_type::reserved2
__IO uint32_t reserved2
crm reserved2 register, offset:0x4C~0x34
Definition: at32f413_crm.h:503
crm_type::intmap
__IO uint32_t intmap
Definition: at32f413_crm.h:830
crm_type::hickdiv
__IO uint32_t hickdiv
Definition: at32f413_crm.h:778
crm_type::accrst
__IO uint32_t accrst
Definition: at32f413_crm.h:592
crm_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_crm.h:561
crm_type::wwdtrstf
__IO uint32_t wwdtrstf
Definition: at32f413_crm.h:755
crm_type::porrstf
__IO uint32_t porrstf
Definition: at32f413_crm.h:752
crm_type::pllrange
__IO uint32_t pllrange
Definition: at32f413_crm.h:529
crm_type::hextstblfc
__IO uint32_t hextstblfc
Definition: at32f413_crm.h:557
crm_type::tmr4rst
__IO uint32_t tmr4rst
Definition: at32f413_crm.h:607
crm_type::bprrst
__IO uint32_t bprrst
Definition: at32f413_crm.h:624
crm_type::iomuxrst
__IO uint32_t iomuxrst
Definition: at32f413_crm.h:573
crm_type::cfden
__IO uint32_t cfden
Definition: at32f413_crm.h:499
crm_type::adcdiv_l
__IO uint32_t adcdiv_l
Definition: at32f413_crm.h:520
crm_type::apb1div
__IO uint32_t apb1div
Definition: at32f413_crm.h:518
crm_type::pwcen
__IO uint32_t pwcen
Definition: at32f413_crm.h:712
crm_type::lextstblien
__IO uint32_t lextstblien
Definition: at32f413_crm.h:549
crm_type::lickstblf
__IO uint32_t lickstblf
Definition: at32f413_crm.h:541
crm_type::clkout_sel
__IO uint32_t clkout_sel
Definition: at32f413_crm.h:525
crm_type::hicken
__IO uint32_t hicken
Definition: at32f413_crm.h:492
crm_type::lexten
__IO uint32_t lexten
Definition: at32f413_crm.h:726
crm_type::hickstbl
__IO uint32_t hickstbl
Definition: at32f413_crm.h:493
crm_type::i2c2en
__IO uint32_t i2c2en
Definition: at32f413_crm.h:706
crm_type::spi1en
__IO uint32_t spi1en
Definition: at32f413_crm.h:672
crm_type::dma2en
__IO uint32_t dma2en
Definition: at32f413_crm.h:640
crm_type::hextstblf
__IO uint32_t hextstblf
Definition: at32f413_crm.h:544
crm_type::spi2en
__IO uint32_t spi2en
Definition: at32f413_crm.h:699
crm_type::gpiobrst
__IO uint32_t gpiobrst
Definition: at32f413_crm.h:576
crm_type::pllen
__IO uint32_t pllen
Definition: at32f413_crm.h:501
crm_type::tmr5rst
__IO uint32_t tmr5rst
Definition: at32f413_crm.h:608
crm_type::can2en
__IO uint32_t can2en
Definition: at32f413_crm.h:714
crm_type::hickstblf
__IO uint32_t hickstblf
Definition: at32f413_crm.h:543
crm_type::clkint
__IO uint32_t clkint
Definition: at32f413_crm.h:538
crm_type::ahbdiv
__IO uint32_t ahbdiv
Definition: at32f413_crm.h:517


AT32F413 Firmwary Library: at32f413_debug.c Source File

  • libraries
  • drivers
  • src
at32f413_debug.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef DEBUG_MODULE_ENABLED
39
49uint32_t debug_device_id_get(void)
50{
51 return DEBUGMCU->pid;
52}
53
79void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state)
80{
81
82 if(new_state != FALSE)
83 {
84 DEBUGMCU->ctrl |= periph_debug_mode;
85 }
86 else
87 {
88 DEBUGMCU->ctrl &= ~periph_debug_mode;
89 }
90}
91
96#endif
97
debug_periph_mode_set
void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode
Definition: at32f413_debug.c:79
debug_device_id_get
uint32_t debug_device_id_get(void)
get debug device id
Definition: at32f413_debug.c:49
DEBUGMCU
#define DEBUGMCU
Definition: at32f413_debug.h:136
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
FALSE
@ FALSE
Definition: at32f413.h:259
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_debug.h Source File

  • libraries
  • drivers
  • inc
at32f413_debug.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_DEBUG_H
29#define __AT32F413_DEBUG_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
51#define DEBUG_SLEEP 0x00000001
52#define DEBUG_DEEPSLEEP 0x00000002
53#define DEBUG_STANDBY 0x00000004
54#define DEBUG_WDT_PAUSE 0x00000100
55#define DEBUG_WWDT_PAUSE 0x00000200
56#define DEBUG_TMR1_PAUSE 0x00000400
57#define DEBUG_TMR2_PAUSE 0x00000800
58#define DEBUG_TMR3_PAUSE 0x00001000
59#define DEBUG_TMR4_PAUSE 0x00002000
60#define DEBUG_CAN1_PAUSE 0x00004000
61#define DEBUG_I2C1_SMBUS_TIMEOUT 0x00008000
62#define DEBUG_I2C2_SMBUS_TIMEOUT 0x00010000
63#define DEBUG_TMR8_PAUSE 0x00020000
64#define DEBUG_TMR5_PAUSE 0x00040000
65#define DEBUG_CAN2_PAUSE 0x00200000
66#define DEBUG_TMR9_PAUSE 0x10000000
67#define DEBUG_TMR10_PAUSE 0x20000000
68#define DEBUG_TMR11_PAUSE 0x40000000
81typedef struct
82{
86 union
87 {
88 __IO uint32_t pid;
89 struct
90 {
91 __IO uint32_t pid : 32;/* [31:0] */
92 } idcode_bit;
93 };
94
98 union
99 {
100 __IO uint32_t ctrl;
101 struct
102 {
103 __IO uint32_t sleep_debug : 1;/* [0] */
104 __IO uint32_t deepsleep_debug : 1;/* [1] */
105 __IO uint32_t standby_debug : 1;/* [2] */
106 __IO uint32_t reserved1 : 2;/* [4:3] */
107 __IO uint32_t trace_ioen : 1;/* [5] */
108 __IO uint32_t trace_mode : 2;/* [7:6] */
109 __IO uint32_t wdt_pause : 1;/* [8] */
110 __IO uint32_t wwdt_pause : 1;/* [9] */
111 __IO uint32_t tmr1_pause : 1;/* [10] */
112 __IO uint32_t tmr2_pause : 1;/* [11] */
113 __IO uint32_t tmr3_pause : 1;/* [12] */
114 __IO uint32_t tmr4_pause : 1;/* [13] */
115 __IO uint32_t can1_pause : 1;/* [14] */
116 __IO uint32_t i2c1_smbus_timeout : 1;/* [15] */
117 __IO uint32_t i2c2_smbus_timeout : 1;/* [16] */
118 __IO uint32_t tmr8_pause : 1;/* [17] */
119 __IO uint32_t tmr5_pause : 1;/* [18] */
120 __IO uint32_t reserved2 : 2;/* [20:19] */
121 __IO uint32_t can2_pause : 1;/* [21] */
122 __IO uint32_t reserved3 : 6;/* [27:22] */
123 __IO uint32_t tmr9_pause : 1;/* [28] */
124 __IO uint32_t tmr10_pause : 1;/* [29] */
125 __IO uint32_t tmr11_pause : 1;/* [30] */
126 __IO uint32_t reserved4 : 1;/* [31] */
127 } ctrl_bit;
128 };
129
130} debug_type;
131
136#define DEBUGMCU ((debug_type *) DEBUG_BASE)
137
142uint32_t debug_device_id_get(void);
143void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state);
144
157#ifdef __cplusplus
158}
159#endif
160
161#endif
at32f413.h
at32f413 header file
debug_periph_mode_set
void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode
Definition: at32f413_debug.c:79
debug_device_id_get
uint32_t debug_device_id_get(void)
get debug device id
Definition: at32f413_debug.c:49
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
debug_type
type define debug register all
Definition: at32f413_debug.h:82
debug_type::can2_pause
__IO uint32_t can2_pause
Definition: at32f413_debug.h:121
debug_type::tmr11_pause
__IO uint32_t tmr11_pause
Definition: at32f413_debug.h:125
debug_type::i2c2_smbus_timeout
__IO uint32_t i2c2_smbus_timeout
Definition: at32f413_debug.h:117
debug_type::pid
__IO uint32_t pid
Definition: at32f413_debug.h:88
debug_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_debug.h:120
debug_type::sleep_debug
__IO uint32_t sleep_debug
Definition: at32f413_debug.h:103
debug_type::tmr8_pause
__IO uint32_t tmr8_pause
Definition: at32f413_debug.h:118
debug_type::trace_ioen
__IO uint32_t trace_ioen
Definition: at32f413_debug.h:107
debug_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_debug.h:100
debug_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_debug.h:122
debug_type::tmr9_pause
__IO uint32_t tmr9_pause
Definition: at32f413_debug.h:123
debug_type::tmr2_pause
__IO uint32_t tmr2_pause
Definition: at32f413_debug.h:112
debug_type::wdt_pause
__IO uint32_t wdt_pause
Definition: at32f413_debug.h:109
debug_type::deepsleep_debug
__IO uint32_t deepsleep_debug
Definition: at32f413_debug.h:104
debug_type::tmr1_pause
__IO uint32_t tmr1_pause
Definition: at32f413_debug.h:111
debug_type::i2c1_smbus_timeout
__IO uint32_t i2c1_smbus_timeout
Definition: at32f413_debug.h:116
debug_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_debug.h:126
debug_type::trace_mode
__IO uint32_t trace_mode
Definition: at32f413_debug.h:108
debug_type::standby_debug
__IO uint32_t standby_debug
Definition: at32f413_debug.h:105
debug_type::tmr10_pause
__IO uint32_t tmr10_pause
Definition: at32f413_debug.h:124
debug_type::wwdt_pause
__IO uint32_t wwdt_pause
Definition: at32f413_debug.h:110
debug_type::can1_pause
__IO uint32_t can1_pause
Definition: at32f413_debug.h:115
debug_type::tmr4_pause
__IO uint32_t tmr4_pause
Definition: at32f413_debug.h:114
debug_type::tmr5_pause
__IO uint32_t tmr5_pause
Definition: at32f413_debug.h:119
debug_type::tmr3_pause
__IO uint32_t tmr3_pause
Definition: at32f413_debug.h:113
debug_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_debug.h:106


AT32F413 Firmwary Library: at32f413_def.h Source File

  • libraries
  • drivers
  • inc
at32f413_def.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_DEF_H
29#define __AT32F413_DEF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* gnu compiler */
36#if defined (__GNUC__)
37 #ifndef ALIGNED_HEAD
38 #define ALIGNED_HEAD
39 #endif
40 #ifndef ALIGNED_TAIL
41 #define ALIGNED_TAIL __attribute__ ((aligned (4)))
42 #endif
43#endif
44
45/* arm compiler */
46#if defined (__CC_ARM)
47 #ifndef ALIGNED_HEAD
48 #define ALIGNED_HEAD __align(4)
49 #endif
50 #ifndef ALIGNED_TAIL
51 #define ALIGNED_TAIL
52 #endif
53#endif
54
55/* iar compiler */
56#if defined (__ICCARM__)
57 #ifndef ALIGNED_HEAD
58 #define ALIGNED_HEAD
59 #endif
60 #ifndef ALIGNED_TAIL
61 #define ALIGNED_TAIL
62 #endif
63#endif
64
65#ifdef __cplusplus
66}
67#endif
68
69#endif


AT32F413 Firmwary Library: at32f413_dma.c Source File

  • libraries
  • drivers
  • src
at32f413_dma.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef DMA_MODULE_ENABLED
39
64void dma_reset(dma_channel_type* dmax_channely)
65{
66 uint32_t temp = 0;
67 dmax_channely->ctrl_bit.chen = FALSE;
68 dmax_channely->ctrl = 0;
69 dmax_channely->dtcnt = 0;
70 dmax_channely->paddr = 0;
71 dmax_channely->maddr = 0;
72
73 temp = (uint32_t)dmax_channely;
74
75 if((temp & 0x4ff) < 0x408)
76 {
77 /* dma1 channel */
78 DMA1->clr |= (uint32_t)(0x0f << ((((temp & 0xff) - 0x08) / 0x14) * 4));
79 }
80 else if((temp & 0x4ff) < 0x488)
81 {
82 /* dma2 channel */
83 DMA2->clr |= (uint32_t)(0x0f << ((((temp & 0xff) - 0x08) / 0x14) * 4));
84 }
85}
86
109void dma_data_number_set(dma_channel_type* dmax_channely, uint16_t data_number)
110{
111 dmax_channely->dtcnt = data_number;
112}
113
134uint16_t dma_data_number_get(dma_channel_type* dmax_channely)
135{
136 return (uint16_t)dmax_channely->dtcnt;
137}
138
165void dma_interrupt_enable(dma_channel_type* dmax_channely, uint32_t dma_int, confirm_state new_state)
166{
167 if (new_state != FALSE)
168 {
169 dmax_channely->ctrl |= dma_int;
170 }
171 else
172 {
173 dmax_channely->ctrl &= ~dma_int;
174 }
175}
176
198void dma_channel_enable(dma_channel_type* dmax_channely, confirm_state new_state)
199{
200 dmax_channely->ctrl_bit.chen = new_state;
201}
202
238void dma_flexible_config(dma_type* dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
239{
240 if(dma_x->src_sel1_bit.dma_flex_en == RESET)
241 {
242 dma_x->src_sel1_bit.dma_flex_en = TRUE;
243 }
244
245 if(flex_channelx == FLEX_CHANNEL1)
246 {
247 dma_x->src_sel0_bit.ch1_src = flexible_request;
248 }
249 else if(flex_channelx == FLEX_CHANNEL2)
250 {
251 dma_x->src_sel0_bit.ch2_src = flexible_request;
252 }
253 else if(flex_channelx == FLEX_CHANNEL3)
254 {
255 dma_x->src_sel0_bit.ch3_src = flexible_request;
256 }
257 else if(flex_channelx == FLEX_CHANNEL4)
258 {
259 dma_x->src_sel0_bit.ch4_src = flexible_request;
260 }
261 else if(flex_channelx == FLEX_CHANNEL5)
262 {
263 dma_x->src_sel1_bit.ch5_src = flexible_request;
264 }
265 else if(flex_channelx == FLEX_CHANNEL6)
266 {
267 dma_x->src_sel1_bit.ch6_src = flexible_request;
268 }
269 else
270 {
271 if(flex_channelx == FLEX_CHANNEL7)
272 {
273 dma_x->src_sel1_bit.ch7_src = flexible_request;
274 }
275 }
276}
277
298 flag_status dma_flag_get(uint32_t dmax_flag)
299{
300 flag_status status = RESET;
301 uint32_t temp = 0;
302
303 if(dmax_flag > 0x10000000)
304 {
305 temp = DMA2->sts;
306 }
307 else
308 {
309 temp = DMA1->sts;
310 }
311
312 if ((temp & dmax_flag) != (uint16_t)RESET)
313 {
314 status = SET;
315 }
316 else
317 {
318 status = RESET;
319 }
320
321 return status;
322}
323
344void dma_flag_clear(uint32_t dmax_flag)
345{
346 if(dmax_flag > ((uint32_t)0x10000000))
347 {
348 DMA2->clr = (uint32_t)(dmax_flag & 0x0FFFFFFF);
349 }
350 else
351 {
352 DMA1->clr = dmax_flag;
353 }
354}
355
362void dma_default_para_init(dma_init_type* dma_init_struct)
363{
364 dma_init_struct->peripheral_base_addr = 0x0;
365 dma_init_struct->memory_base_addr = 0x0;
366 dma_init_struct->direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
367 dma_init_struct->buffer_size = 0x0;
368 dma_init_struct->peripheral_inc_enable = FALSE;
369 dma_init_struct->memory_inc_enable = FALSE;
370 dma_init_struct->peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
371 dma_init_struct->memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
372 dma_init_struct->loop_mode_enable = FALSE;
373 dma_init_struct->priority = DMA_PRIORITY_LOW;
374}
375
397void dma_init(dma_channel_type* dmax_channely, dma_init_type* dma_init_struct)
398{
399 /* clear ctrl register dtd bit and m2m bit */
400 dmax_channely->ctrl &= 0xbfef;
401 dmax_channely->ctrl |= dma_init_struct->direction;
402
403 dmax_channely->ctrl_bit.chpl = dma_init_struct->priority;
404 dmax_channely->ctrl_bit.mwidth = dma_init_struct->memory_data_width;
405 dmax_channely->ctrl_bit.pwidth = dma_init_struct->peripheral_data_width;
406 dmax_channely->ctrl_bit.mincm = dma_init_struct->memory_inc_enable;
407 dmax_channely->ctrl_bit.pincm = dma_init_struct->peripheral_inc_enable;
408 dmax_channely->ctrl_bit.lm = dma_init_struct->loop_mode_enable;
409 dmax_channely->dtcnt = dma_init_struct->buffer_size;
410 dmax_channely->paddr = dma_init_struct->peripheral_base_addr;
411 dmax_channely->maddr = dma_init_struct->memory_base_addr;
412}
413
418#endif
419
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
dma_flexible_request_type
dma_flexible_request_type
dma flexible request type
Definition: at32f413_dma.h:151
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:245
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:255
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f413_dma.h:265
FLEX_CHANNEL5
#define FLEX_CHANNEL5
Definition: at32f413_dma.h:68
FLEX_CHANNEL7
#define FLEX_CHANNEL7
Definition: at32f413_dma.h:70
FLEX_CHANNEL3
#define FLEX_CHANNEL3
Definition: at32f413_dma.h:66
FLEX_CHANNEL1
#define FLEX_CHANNEL1
Definition: at32f413_dma.h:64
FLEX_CHANNEL6
#define FLEX_CHANNEL6
Definition: at32f413_dma.h:69
FLEX_CHANNEL4
#define FLEX_CHANNEL4
Definition: at32f413_dma.h:67
FLEX_CHANNEL2
#define FLEX_CHANNEL2
Definition: at32f413_dma.h:65
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:238
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_data_number_get
uint16_t dma_data_number_get(dma_channel_type *dmax_channely)
get number of data from dtcnt register
Definition: at32f413_dma.c:134
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
dma_data_number_set
void dma_data_number_set(dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred
Definition: at32f413_dma.c:109
DMA2
#define DMA2
Definition: at32f413_dma.h:488
DMA1
#define DMA1
Definition: at32f413_dma.h:479
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
dma_channel_type
type define dma channel register all
Definition: at32f413_dma.h:412
dma_channel_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f413_dma.h:442
dma_channel_type::pwidth
__IO uint32_t pwidth
Definition: at32f413_dma.h:429
dma_channel_type::paddr
__IO uint32_t paddr
Definition: at32f413_dma.h:455
dma_channel_type::mincm
__IO uint32_t mincm
Definition: at32f413_dma.h:428
dma_channel_type::chen
__IO uint32_t chen
Definition: at32f413_dma.h:421
dma_channel_type::ctrl_bit
struct dma_channel_type::@348::@356 ctrl_bit
dma_channel_type::lm
__IO uint32_t lm
Definition: at32f413_dma.h:426
dma_channel_type::mwidth
__IO uint32_t mwidth
Definition: at32f413_dma.h:430
dma_channel_type::maddr
__IO uint32_t maddr
Definition: at32f413_dma.h:467
dma_channel_type::pincm
__IO uint32_t pincm
Definition: at32f413_dma.h:427
dma_channel_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_dma.h:418
dma_channel_type::chpl
__IO uint32_t chpl
Definition: at32f413_dma.h:431
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
dma_type
type define dma register
Definition: at32f413_dma.h:292
dma_type::ch2_src
__IO uint32_t ch2_src
Definition: at32f413_dma.h:385
dma_type::ch3_src
__IO uint32_t ch3_src
Definition: at32f413_dma.h:386
dma_type::src_sel1_bit
struct dma_type::@342::@347 src_sel1_bit
dma_type::dma_flex_en
__IO uint32_t dma_flex_en
Definition: at32f413_dma.h:402
dma_type::ch5_src
__IO uint32_t ch5_src
Definition: at32f413_dma.h:399
dma_type::ch1_src
__IO uint32_t ch1_src
Definition: at32f413_dma.h:384
dma_type::ch7_src
__IO uint32_t ch7_src
Definition: at32f413_dma.h:401
dma_type::ch4_src
__IO uint32_t ch4_src
Definition: at32f413_dma.h:387
dma_type::src_sel0_bit
struct dma_type::@340::@346 src_sel0_bit
dma_type::ch6_src
__IO uint32_t ch6_src
Definition: at32f413_dma.h:400
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_dma.h Source File

  • libraries
  • drivers
  • inc
at32f413_dma.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_DMA_H
29#define __AT32F413_DMA_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define DMA_FDT_INT ((uint32_t)0x00000002)
53#define DMA_HDT_INT ((uint32_t)0x00000004)
54#define DMA_DTERR_INT ((uint32_t)0x00000008)
64#define FLEX_CHANNEL1 ((uint8_t)0x01)
65#define FLEX_CHANNEL2 ((uint8_t)0x02)
66#define FLEX_CHANNEL3 ((uint8_t)0x03)
67#define FLEX_CHANNEL4 ((uint8_t)0x04)
68#define FLEX_CHANNEL5 ((uint8_t)0x05)
69#define FLEX_CHANNEL6 ((uint8_t)0x06)
70#define FLEX_CHANNEL7 ((uint8_t)0x07)
81#define DMA1_GL1_FLAG ((uint32_t)0x00000001)
82#define DMA1_FDT1_FLAG ((uint32_t)0x00000002)
83#define DMA1_HDT1_FLAG ((uint32_t)0x00000004)
84#define DMA1_DTERR1_FLAG ((uint32_t)0x00000008)
85#define DMA1_GL2_FLAG ((uint32_t)0x00000010)
86#define DMA1_FDT2_FLAG ((uint32_t)0x00000020)
87#define DMA1_HDT2_FLAG ((uint32_t)0x00000040)
88#define DMA1_DTERR2_FLAG ((uint32_t)0x00000080)
89#define DMA1_GL3_FLAG ((uint32_t)0x00000100)
90#define DMA1_FDT3_FLAG ((uint32_t)0x00000200)
91#define DMA1_HDT3_FLAG ((uint32_t)0x00000400)
92#define DMA1_DTERR3_FLAG ((uint32_t)0x00000800)
93#define DMA1_GL4_FLAG ((uint32_t)0x00001000)
94#define DMA1_FDT4_FLAG ((uint32_t)0x00002000)
95#define DMA1_HDT4_FLAG ((uint32_t)0x00004000)
96#define DMA1_DTERR4_FLAG ((uint32_t)0x00008000)
97#define DMA1_GL5_FLAG ((uint32_t)0x00010000)
98#define DMA1_FDT5_FLAG ((uint32_t)0x00020000)
99#define DMA1_HDT5_FLAG ((uint32_t)0x00040000)
100#define DMA1_DTERR5_FLAG ((uint32_t)0x00080000)
101#define DMA1_GL6_FLAG ((uint32_t)0x00100000)
102#define DMA1_FDT6_FLAG ((uint32_t)0x00200000)
103#define DMA1_HDT6_FLAG ((uint32_t)0x00400000)
104#define DMA1_DTERR6_FLAG ((uint32_t)0x00800000)
105#define DMA1_GL7_FLAG ((uint32_t)0x01000000)
106#define DMA1_FDT7_FLAG ((uint32_t)0x02000000)
107#define DMA1_HDT7_FLAG ((uint32_t)0x04000000)
108#define DMA1_DTERR7_FLAG ((uint32_t)0x08000000)
110#define DMA2_GL1_FLAG ((uint32_t)0x10000001)
111#define DMA2_FDT1_FLAG ((uint32_t)0x10000002)
112#define DMA2_HDT1_FLAG ((uint32_t)0x10000004)
113#define DMA2_DTERR1_FLAG ((uint32_t)0x10000008)
114#define DMA2_GL2_FLAG ((uint32_t)0x10000010)
115#define DMA2_FDT2_FLAG ((uint32_t)0x10000020)
116#define DMA2_HDT2_FLAG ((uint32_t)0x10000040)
117#define DMA2_DTERR2_FLAG ((uint32_t)0x10000080)
118#define DMA2_GL3_FLAG ((uint32_t)0x10000100)
119#define DMA2_FDT3_FLAG ((uint32_t)0x10000200)
120#define DMA2_HDT3_FLAG ((uint32_t)0x10000400)
121#define DMA2_DTERR3_FLAG ((uint32_t)0x10000800)
122#define DMA2_GL4_FLAG ((uint32_t)0x10001000)
123#define DMA2_FDT4_FLAG ((uint32_t)0x10002000)
124#define DMA2_HDT4_FLAG ((uint32_t)0x10004000)
125#define DMA2_DTERR4_FLAG ((uint32_t)0x10008000)
126#define DMA2_GL5_FLAG ((uint32_t)0x10010000)
127#define DMA2_FDT5_FLAG ((uint32_t)0x10020000)
128#define DMA2_HDT5_FLAG ((uint32_t)0x10040000)
129#define DMA2_DTERR5_FLAG ((uint32_t)0x10080000)
130#define DMA2_GL6_FLAG ((uint32_t)0x10100000)
131#define DMA2_FDT6_FLAG ((uint32_t)0x10200000)
132#define DMA2_HDT6_FLAG ((uint32_t)0x10400000)
133#define DMA2_DTERR6_FLAG ((uint32_t)0x10800000)
134#define DMA2_GL7_FLAG ((uint32_t)0x11000000)
135#define DMA2_FDT7_FLAG ((uint32_t)0x12000000)
136#define DMA2_HDT7_FLAG ((uint32_t)0x14000000)
137#define DMA2_DTERR7_FLAG ((uint32_t)0x18000000)
150typedef enum
151{
152 DMA_FLEXIBLE_ADC1 = 0x01,
153 DMA_FLEXIBLE_SPI1_RX = 0x09,
154 DMA_FLEXIBLE_SPI1_TX = 0x0A,
155 DMA_FLEXIBLE_SPI2_RX = 0x0B,
156 DMA_FLEXIBLE_SPI2_TX = 0x0C,
157 DMA_FLEXIBLE_UART1_RX = 0x19,
158 DMA_FLEXIBLE_UART1_TX = 0x1A,
159 DMA_FLEXIBLE_UART2_RX = 0x1B,
160 DMA_FLEXIBLE_UART2_TX = 0x1C,
161 DMA_FLEXIBLE_UART3_RX = 0x1D,
162 DMA_FLEXIBLE_UART3_TX = 0x1E,
163 DMA_FLEXIBLE_UART4_RX = 0x1F,
164 DMA_FLEXIBLE_UART4_TX = 0x20,
165 DMA_FLEXIBLE_UART5_RX = 0x21,
166 DMA_FLEXIBLE_UART5_TX = 0x22,
167 DMA_FLEXIBLE_I2C1_RX = 0x29,
168 DMA_FLEXIBLE_I2C1_TX = 0x2A,
169 DMA_FLEXIBLE_I2C2_RX = 0x2B,
170 DMA_FLEXIBLE_I2C2_TX = 0x2C,
171 DMA_FLEXIBLE_SDIO1 = 0x31,
172 DMA_FLEXIBLE_TMR1_TRIG = 0x35,
173 DMA_FLEXIBLE_TMR1_HALL = 0x36,
174 DMA_FLEXIBLE_TMR1_OVERFLOW = 0x37,
175 DMA_FLEXIBLE_TMR1_CH1 = 0x38,
176 DMA_FLEXIBLE_TMR1_CH2 = 0x39,
177 DMA_FLEXIBLE_TMR1_CH3 = 0x3A,
178 DMA_FLEXIBLE_TMR1_CH4 = 0x3B,
179 DMA_FLEXIBLE_TMR2_TRIG = 0x3D,
180 DMA_FLEXIBLE_TMR2_OVERFLOW = 0x3F,
181 DMA_FLEXIBLE_TMR2_CH1 = 0x40,
182 DMA_FLEXIBLE_TMR2_CH2 = 0x41,
183 DMA_FLEXIBLE_TMR2_CH3 = 0x42,
184 DMA_FLEXIBLE_TMR2_CH4 = 0x43,
185 DMA_FLEXIBLE_TMR3_TRIG = 0x45,
186 DMA_FLEXIBLE_TMR3_OVERFLOW = 0x47,
187 DMA_FLEXIBLE_TMR3_CH1 = 0x48,
188 DMA_FLEXIBLE_TMR3_CH2 = 0x49,
189 DMA_FLEXIBLE_TMR3_CH3 = 0x4A,
190 DMA_FLEXIBLE_TMR3_CH4 = 0x4B,
191 DMA_FLEXIBLE_TMR4_TRIG = 0x4D,
192 DMA_FLEXIBLE_TMR4_OVERFLOW = 0x4F,
193 DMA_FLEXIBLE_TMR4_CH1 = 0x50,
194 DMA_FLEXIBLE_TMR4_CH2 = 0x51,
195 DMA_FLEXIBLE_TMR4_CH3 = 0x52,
196 DMA_FLEXIBLE_TMR4_CH4 = 0x53,
197 DMA_FLEXIBLE_TMR5_TRIG = 0x55,
198 DMA_FLEXIBLE_TMR5_OVERFLOW = 0x57,
199 DMA_FLEXIBLE_TMR5_CH1 = 0x58,
200 DMA_FLEXIBLE_TMR5_CH2 = 0x59,
201 DMA_FLEXIBLE_TMR5_CH3 = 0x5A,
202 DMA_FLEXIBLE_TMR5_CH4 = 0x5B,
203 DMA_FLEXIBLE_TMR8_TRIG = 0x6D,
204 DMA_FLEXIBLE_TMR8_HALL = 0x6E,
205 DMA_FLEXIBLE_TMR8_OVERFLOW = 0x6F,
206 DMA_FLEXIBLE_TMR8_CH1 = 0x70,
207 DMA_FLEXIBLE_TMR8_CH2 = 0x71,
208 DMA_FLEXIBLE_TMR8_CH3 = 0x72,
209 DMA_FLEXIBLE_TMR8_CH4 = 0x73,
210} dma_flexible_request_type;
211
215typedef enum
216{
217 DMA_DIR_PERIPHERAL_TO_MEMORY = 0x0000,
218 DMA_DIR_MEMORY_TO_PERIPHERAL = 0x0010,
219 DMA_DIR_MEMORY_TO_MEMORY = 0x4000
220} dma_dir_type;
221
225typedef enum
226{
227 DMA_PERIPHERAL_INC_DISABLE = 0x00,
228 DMA_PERIPHERAL_INC_ENABLE = 0x01
229} dma_peripheral_inc_type;
230
234typedef enum
235{
236 DMA_MEMORY_INC_DISABLE = 0x00,
237 DMA_MEMORY_INC_ENABLE = 0x01
238} dma_memory_inc_type;
239
243typedef enum
244{
245 DMA_PERIPHERAL_DATA_WIDTH_BYTE = 0x00,
246 DMA_PERIPHERAL_DATA_WIDTH_HALFWORD = 0x01,
247 DMA_PERIPHERAL_DATA_WIDTH_WORD = 0x02
248} dma_peripheral_data_size_type;
249
253typedef enum
254{
255 DMA_MEMORY_DATA_WIDTH_BYTE = 0x00,
256 DMA_MEMORY_DATA_WIDTH_HALFWORD = 0x01,
257 DMA_MEMORY_DATA_WIDTH_WORD = 0x02
258} dma_memory_data_size_type;
259
263typedef enum
264{
265 DMA_PRIORITY_LOW = 0x00,
266 DMA_PRIORITY_MEDIUM = 0x01,
267 DMA_PRIORITY_HIGH = 0x02,
268 DMA_PRIORITY_VERY_HIGH = 0x03
269} dma_priority_level_type;
270
274typedef struct
275{
276 uint32_t peripheral_base_addr;
277 uint32_t memory_base_addr;
278 dma_dir_type direction;
279 uint16_t buffer_size;
280 confirm_state peripheral_inc_enable;
281 confirm_state memory_inc_enable;
282 dma_peripheral_data_size_type peripheral_data_width;
283 dma_memory_data_size_type memory_data_width;
284 confirm_state loop_mode_enable;
285 dma_priority_level_type priority;
286} dma_init_type;
287
291typedef struct
292{
296 union
297 {
298 __IO uint32_t sts;
299 struct
300 {
301 __IO uint32_t gf1 : 1; /* [0] */
302 __IO uint32_t fdtf1 : 1; /* [1] */
303 __IO uint32_t hdtf1 : 1; /* [2] */
304 __IO uint32_t dterrf1 : 1; /* [3] */
305 __IO uint32_t gf2 : 1; /* [4] */
306 __IO uint32_t fdtf2 : 1; /* [5] */
307 __IO uint32_t hdtf2 : 1; /* [6] */
308 __IO uint32_t dterrf2 : 1; /* [7] */
309 __IO uint32_t gf3 : 1; /* [8] */
310 __IO uint32_t fdtf3 : 1; /* [9] */
311 __IO uint32_t hdtf3 : 1; /* [10] */
312 __IO uint32_t dterrf3 : 1; /* [11] */
313 __IO uint32_t gf4 : 1; /* [12] */
314 __IO uint32_t fdtf4 : 1; /* [13] */
315 __IO uint32_t hdtf4 : 1; /* [14] */
316 __IO uint32_t dterrf4 : 1; /* [15] */
317 __IO uint32_t gf5 : 1; /* [16] */
318 __IO uint32_t fdtf5 : 1; /* [17] */
319 __IO uint32_t hdtf5 : 1; /* [18] */
320 __IO uint32_t dterrf5 : 1; /* [19] */
321 __IO uint32_t gf6 : 1; /* [20] */
322 __IO uint32_t fdtf6 : 1; /* [21] */
323 __IO uint32_t hdtf6 : 1; /* [22] */
324 __IO uint32_t dterrf6 : 1; /* [23] */
325 __IO uint32_t gf7 : 1; /* [24] */
326 __IO uint32_t fdtf7 : 1; /* [25] */
327 __IO uint32_t hdtf7 : 1; /* [26] */
328 __IO uint32_t dterrf7 : 1; /* [27] */
329 __IO uint32_t reserved1 : 4; /* [31:28] */
330 } sts_bit;
331 };
332
336 union
337 {
338 __IO uint32_t clr;
339 struct
340 {
341 __IO uint32_t gfc1 : 1; /* [0] */
342 __IO uint32_t fdtfc1 : 1; /* [1] */
343 __IO uint32_t hdtfc1 : 1; /* [2] */
344 __IO uint32_t dterrfc1 : 1; /* [3] */
345 __IO uint32_t gfc2 : 1; /* [4] */
346 __IO uint32_t fdtfc2 : 1; /* [5] */
347 __IO uint32_t hdtfc2 : 1; /* [6] */
348 __IO uint32_t dterrfc2 : 1; /* [7] */
349 __IO uint32_t gfc3 : 1; /* [8] */
350 __IO uint32_t fdtfc3 : 1; /* [9] */
351 __IO uint32_t hdtfc3 : 1; /* [10] */
352 __IO uint32_t dterrfc3 : 1; /* [11] */
353 __IO uint32_t gfc4 : 1; /* [12] */
354 __IO uint32_t fdtfc4 : 1; /* [13] */
355 __IO uint32_t hdtfc4 : 1; /* [14] */
356 __IO uint32_t dterrfc4 : 1; /* [15] */
357 __IO uint32_t gfc5 : 1; /* [16] */
358 __IO uint32_t fdtfc5 : 1; /* [17] */
359 __IO uint32_t hdtfc5 : 1; /* [18] */
360 __IO uint32_t dterrfc5 : 1; /* [19] */
361 __IO uint32_t gfc6 : 1; /* [20] */
362 __IO uint32_t fdtfc6 : 1; /* [21] */
363 __IO uint32_t hdtfc6 : 1; /* [22] */
364 __IO uint32_t dterrfc6 : 1; /* [23] */
365 __IO uint32_t gfc7 : 1; /* [24] */
366 __IO uint32_t fdtfc7 : 1; /* [25] */
367 __IO uint32_t hdtfc7 : 1; /* [26] */
368 __IO uint32_t dterrfc7 : 1; /* [27] */
369 __IO uint32_t reserved1 : 4; /* [31:28] */
370 } clr_bit;
371 };
375 __IO uint32_t reserved1[38];
379 union
380 {
381 __IO uint32_t src_sel0;
382 struct
383 {
384 __IO uint32_t ch1_src : 8; /* [7:0] */
385 __IO uint32_t ch2_src : 8; /* [15:8] */
386 __IO uint32_t ch3_src : 8; /* [23:16] */
387 __IO uint32_t ch4_src : 8; /* [31:24] */
388 } src_sel0_bit;
389 };
390
394 union
395 {
396 __IO uint32_t src_sel1;
397 struct
398 {
399 __IO uint32_t ch5_src : 8; /* [7:0] */
400 __IO uint32_t ch6_src : 8; /* [15:8] */
401 __IO uint32_t ch7_src : 8; /* [23:16] */
402 __IO uint32_t dma_flex_en : 1; /* [24] */
403 __IO uint32_t reserved1 : 7; /* [31:25] */
404 } src_sel1_bit;
405 };
406} dma_type;
407
411typedef struct
412{
416 union
417 {
418 __IO uint32_t ctrl;
419 struct
420 {
421 __IO uint32_t chen : 1; /* [0] */
422 __IO uint32_t fdtien : 1; /* [1] */
423 __IO uint32_t hdtien : 1; /* [2] */
424 __IO uint32_t dterrien : 1; /* [3] */
425 __IO uint32_t dtd : 1; /* [4] */
426 __IO uint32_t lm : 1; /* [5] */
427 __IO uint32_t pincm : 1; /* [6] */
428 __IO uint32_t mincm : 1; /* [7] */
429 __IO uint32_t pwidth : 2; /* [9:8] */
430 __IO uint32_t mwidth : 2; /* [11:10] */
431 __IO uint32_t chpl : 2; /* [13:12] */
432 __IO uint32_t m2m : 1; /* [14] */
433 __IO uint32_t reserved1 : 17;/* [31:15] */
434 } ctrl_bit;
435 };
436
440 union
441 {
442 __IO uint32_t dtcnt;
443 struct
444 {
445 __IO uint32_t cnt : 16;/* [15:0] */
446 __IO uint32_t reserved1 : 16;/* [31:16] */
447 } dtcnt_bit;
448 };
449
453 union
454 {
455 __IO uint32_t paddr;
456 struct
457 {
458 __IO uint32_t paddr : 32;/* [31:0] */
459 } paddr_bit;
460 };
461
465 union
466 {
467 __IO uint32_t maddr;
468 struct
469 {
470 __IO uint32_t maddr : 32;/* [31:0] */
471 } maddr_bit;
472 };
473} dma_channel_type;
474
479#define DMA1 ((dma_type *) DMA1_BASE)
480#define DMA1_CHANNEL1 ((dma_channel_type *) DMA1_CHANNEL1_BASE)
481#define DMA1_CHANNEL2 ((dma_channel_type *) DMA1_CHANNEL2_BASE)
482#define DMA1_CHANNEL3 ((dma_channel_type *) DMA1_CHANNEL3_BASE)
483#define DMA1_CHANNEL4 ((dma_channel_type *) DMA1_CHANNEL4_BASE)
484#define DMA1_CHANNEL5 ((dma_channel_type *) DMA1_CHANNEL5_BASE)
485#define DMA1_CHANNEL6 ((dma_channel_type *) DMA1_CHANNEL6_BASE)
486#define DMA1_CHANNEL7 ((dma_channel_type *) DMA1_CHANNEL7_BASE)
487
488#define DMA2 ((dma_type *) DMA2_BASE)
489#define DMA2_CHANNEL1 ((dma_channel_type *) DMA2_CHANNEL1_BASE)
490#define DMA2_CHANNEL2 ((dma_channel_type *) DMA2_CHANNEL2_BASE)
491#define DMA2_CHANNEL3 ((dma_channel_type *) DMA2_CHANNEL3_BASE)
492#define DMA2_CHANNEL4 ((dma_channel_type *) DMA2_CHANNEL4_BASE)
493#define DMA2_CHANNEL5 ((dma_channel_type *) DMA2_CHANNEL5_BASE)
494#define DMA2_CHANNEL6 ((dma_channel_type *) DMA2_CHANNEL6_BASE)
495#define DMA2_CHANNEL7 ((dma_channel_type *) DMA2_CHANNEL7_BASE)
496
501void dma_reset(dma_channel_type* dmax_channely);
502void dma_default_para_init(dma_init_type* dma_init_struct);
503void dma_init(dma_channel_type* dmax_channely, dma_init_type* dma_init_struct);
504void dma_channel_enable(dma_channel_type* dmax_channely, confirm_state new_state);
505void dma_flexible_config(dma_type* dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request);
506void dma_data_number_set(dma_channel_type* dmax_channely, uint16_t data_number);
507uint16_t dma_data_number_get(dma_channel_type* dmax_channely);
508void dma_interrupt_enable(dma_channel_type* dmax_channely, uint32_t dma_int, confirm_state new_state);
509 flag_status dma_flag_get(uint32_t dmax_flag);
510void dma_flag_clear(uint32_t dmax_flag);
511
512
525#ifdef __cplusplus
526}
527#endif
528
529#endif
at32f413.h
at32f413 header file
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:238
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_data_number_get
uint16_t dma_data_number_get(dma_channel_type *dmax_channely)
get number of data from dtcnt register
Definition: at32f413_dma.c:134
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
dma_data_number_set
void dma_data_number_set(dma_channel_type *dmax_channely, uint16_t data_number)
set the number of data to be transferred
Definition: at32f413_dma.c:109
dma_peripheral_inc_type
dma_peripheral_inc_type
dma peripheral incremented type
Definition: at32f413_dma.h:226
dma_peripheral_data_size_type
dma_peripheral_data_size_type
dma peripheral data size type
Definition: at32f413_dma.h:244
dma_flexible_request_type
dma_flexible_request_type
dma flexible request type
Definition: at32f413_dma.h:151
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:216
dma_memory_data_size_type
dma_memory_data_size_type
dma memory data size type
Definition: at32f413_dma.h:254
dma_priority_level_type
dma_priority_level_type
dma priority level type
Definition: at32f413_dma.h:264
dma_memory_inc_type
dma_memory_inc_type
dma memory incremented type
Definition: at32f413_dma.h:235
DMA_PERIPHERAL_INC_DISABLE
@ DMA_PERIPHERAL_INC_DISABLE
Definition: at32f413_dma.h:227
DMA_PERIPHERAL_INC_ENABLE
@ DMA_PERIPHERAL_INC_ENABLE
Definition: at32f413_dma.h:228
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:247
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:245
DMA_FLEXIBLE_TMR4_OVERFLOW
@ DMA_FLEXIBLE_TMR4_OVERFLOW
Definition: at32f413_dma.h:192
DMA_FLEXIBLE_TMR8_CH4
@ DMA_FLEXIBLE_TMR8_CH4
Definition: at32f413_dma.h:209
DMA_FLEXIBLE_TMR4_CH4
@ DMA_FLEXIBLE_TMR4_CH4
Definition: at32f413_dma.h:196
DMA_FLEXIBLE_SDIO1
@ DMA_FLEXIBLE_SDIO1
Definition: at32f413_dma.h:171
DMA_FLEXIBLE_UART5_RX
@ DMA_FLEXIBLE_UART5_RX
Definition: at32f413_dma.h:165
DMA_FLEXIBLE_UART3_TX
@ DMA_FLEXIBLE_UART3_TX
Definition: at32f413_dma.h:162
DMA_FLEXIBLE_TMR4_CH2
@ DMA_FLEXIBLE_TMR4_CH2
Definition: at32f413_dma.h:194
DMA_FLEXIBLE_I2C2_TX
@ DMA_FLEXIBLE_I2C2_TX
Definition: at32f413_dma.h:170
DMA_FLEXIBLE_TMR8_HALL
@ DMA_FLEXIBLE_TMR8_HALL
Definition: at32f413_dma.h:204
DMA_FLEXIBLE_TMR4_CH3
@ DMA_FLEXIBLE_TMR4_CH3
Definition: at32f413_dma.h:195
DMA_FLEXIBLE_TMR5_CH3
@ DMA_FLEXIBLE_TMR5_CH3
Definition: at32f413_dma.h:201
DMA_FLEXIBLE_TMR2_OVERFLOW
@ DMA_FLEXIBLE_TMR2_OVERFLOW
Definition: at32f413_dma.h:180
DMA_FLEXIBLE_UART2_RX
@ DMA_FLEXIBLE_UART2_RX
Definition: at32f413_dma.h:159
DMA_FLEXIBLE_TMR4_TRIG
@ DMA_FLEXIBLE_TMR4_TRIG
Definition: at32f413_dma.h:191
DMA_FLEXIBLE_TMR1_HALL
@ DMA_FLEXIBLE_TMR1_HALL
Definition: at32f413_dma.h:173
DMA_FLEXIBLE_TMR3_OVERFLOW
@ DMA_FLEXIBLE_TMR3_OVERFLOW
Definition: at32f413_dma.h:186
DMA_FLEXIBLE_TMR3_CH2
@ DMA_FLEXIBLE_TMR3_CH2
Definition: at32f413_dma.h:188
DMA_FLEXIBLE_TMR8_TRIG
@ DMA_FLEXIBLE_TMR8_TRIG
Definition: at32f413_dma.h:203
DMA_FLEXIBLE_SPI2_RX
@ DMA_FLEXIBLE_SPI2_RX
Definition: at32f413_dma.h:155
DMA_FLEXIBLE_UART1_TX
@ DMA_FLEXIBLE_UART1_TX
Definition: at32f413_dma.h:158
DMA_FLEXIBLE_TMR2_TRIG
@ DMA_FLEXIBLE_TMR2_TRIG
Definition: at32f413_dma.h:179
DMA_FLEXIBLE_TMR8_CH2
@ DMA_FLEXIBLE_TMR8_CH2
Definition: at32f413_dma.h:207
DMA_FLEXIBLE_TMR3_CH1
@ DMA_FLEXIBLE_TMR3_CH1
Definition: at32f413_dma.h:187
DMA_FLEXIBLE_TMR2_CH2
@ DMA_FLEXIBLE_TMR2_CH2
Definition: at32f413_dma.h:182
DMA_FLEXIBLE_TMR3_CH4
@ DMA_FLEXIBLE_TMR3_CH4
Definition: at32f413_dma.h:190
DMA_FLEXIBLE_TMR5_CH1
@ DMA_FLEXIBLE_TMR5_CH1
Definition: at32f413_dma.h:199
DMA_FLEXIBLE_TMR2_CH1
@ DMA_FLEXIBLE_TMR2_CH1
Definition: at32f413_dma.h:181
DMA_FLEXIBLE_TMR8_CH1
@ DMA_FLEXIBLE_TMR8_CH1
Definition: at32f413_dma.h:206
DMA_FLEXIBLE_TMR1_CH4
@ DMA_FLEXIBLE_TMR1_CH4
Definition: at32f413_dma.h:178
DMA_FLEXIBLE_I2C1_RX
@ DMA_FLEXIBLE_I2C1_RX
Definition: at32f413_dma.h:167
DMA_FLEXIBLE_TMR2_CH4
@ DMA_FLEXIBLE_TMR2_CH4
Definition: at32f413_dma.h:184
DMA_FLEXIBLE_TMR5_CH4
@ DMA_FLEXIBLE_TMR5_CH4
Definition: at32f413_dma.h:202
DMA_FLEXIBLE_TMR1_CH1
@ DMA_FLEXIBLE_TMR1_CH1
Definition: at32f413_dma.h:175
DMA_FLEXIBLE_ADC1
@ DMA_FLEXIBLE_ADC1
Definition: at32f413_dma.h:152
DMA_FLEXIBLE_UART2_TX
@ DMA_FLEXIBLE_UART2_TX
Definition: at32f413_dma.h:160
DMA_FLEXIBLE_UART4_TX
@ DMA_FLEXIBLE_UART4_TX
Definition: at32f413_dma.h:164
DMA_FLEXIBLE_TMR4_CH1
@ DMA_FLEXIBLE_TMR4_CH1
Definition: at32f413_dma.h:193
DMA_FLEXIBLE_TMR1_TRIG
@ DMA_FLEXIBLE_TMR1_TRIG
Definition: at32f413_dma.h:172
DMA_FLEXIBLE_UART1_RX
@ DMA_FLEXIBLE_UART1_RX
Definition: at32f413_dma.h:157
DMA_FLEXIBLE_SPI1_RX
@ DMA_FLEXIBLE_SPI1_RX
Definition: at32f413_dma.h:153
DMA_FLEXIBLE_UART3_RX
@ DMA_FLEXIBLE_UART3_RX
Definition: at32f413_dma.h:161
DMA_FLEXIBLE_TMR1_CH2
@ DMA_FLEXIBLE_TMR1_CH2
Definition: at32f413_dma.h:176
DMA_FLEXIBLE_TMR5_OVERFLOW
@ DMA_FLEXIBLE_TMR5_OVERFLOW
Definition: at32f413_dma.h:198
DMA_FLEXIBLE_TMR5_TRIG
@ DMA_FLEXIBLE_TMR5_TRIG
Definition: at32f413_dma.h:197
DMA_FLEXIBLE_UART4_RX
@ DMA_FLEXIBLE_UART4_RX
Definition: at32f413_dma.h:163
DMA_FLEXIBLE_TMR3_TRIG
@ DMA_FLEXIBLE_TMR3_TRIG
Definition: at32f413_dma.h:185
DMA_FLEXIBLE_I2C2_RX
@ DMA_FLEXIBLE_I2C2_RX
Definition: at32f413_dma.h:169
DMA_FLEXIBLE_TMR2_CH3
@ DMA_FLEXIBLE_TMR2_CH3
Definition: at32f413_dma.h:183
DMA_FLEXIBLE_I2C1_TX
@ DMA_FLEXIBLE_I2C1_TX
Definition: at32f413_dma.h:168
DMA_FLEXIBLE_TMR8_OVERFLOW
@ DMA_FLEXIBLE_TMR8_OVERFLOW
Definition: at32f413_dma.h:205
DMA_FLEXIBLE_SPI1_TX
@ DMA_FLEXIBLE_SPI1_TX
Definition: at32f413_dma.h:154
DMA_FLEXIBLE_TMR5_CH2
@ DMA_FLEXIBLE_TMR5_CH2
Definition: at32f413_dma.h:200
DMA_FLEXIBLE_SPI2_TX
@ DMA_FLEXIBLE_SPI2_TX
Definition: at32f413_dma.h:156
DMA_FLEXIBLE_TMR8_CH3
@ DMA_FLEXIBLE_TMR8_CH3
Definition: at32f413_dma.h:208
DMA_FLEXIBLE_TMR1_OVERFLOW
@ DMA_FLEXIBLE_TMR1_OVERFLOW
Definition: at32f413_dma.h:174
DMA_FLEXIBLE_TMR1_CH3
@ DMA_FLEXIBLE_TMR1_CH3
Definition: at32f413_dma.h:177
DMA_FLEXIBLE_TMR3_CH3
@ DMA_FLEXIBLE_TMR3_CH3
Definition: at32f413_dma.h:189
DMA_FLEXIBLE_UART5_TX
@ DMA_FLEXIBLE_UART5_TX
Definition: at32f413_dma.h:166
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_MEMORY_TO_MEMORY
@ DMA_DIR_MEMORY_TO_MEMORY
Definition: at32f413_dma.h:219
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:257
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:255
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:266
DMA_PRIORITY_VERY_HIGH
@ DMA_PRIORITY_VERY_HIGH
Definition: at32f413_dma.h:268
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f413_dma.h:265
DMA_MEMORY_INC_ENABLE
@ DMA_MEMORY_INC_ENABLE
Definition: at32f413_dma.h:237
DMA_MEMORY_INC_DISABLE
@ DMA_MEMORY_INC_DISABLE
Definition: at32f413_dma.h:236
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
dma_channel_type
type define dma channel register all
Definition: at32f413_dma.h:412
dma_channel_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f413_dma.h:442
dma_channel_type::cnt
__IO uint32_t cnt
Definition: at32f413_dma.h:445
dma_channel_type::pwidth
__IO uint32_t pwidth
Definition: at32f413_dma.h:429
dma_channel_type::paddr
__IO uint32_t paddr
Definition: at32f413_dma.h:455
dma_channel_type::mincm
__IO uint32_t mincm
Definition: at32f413_dma.h:428
dma_channel_type::dterrien
__IO uint32_t dterrien
Definition: at32f413_dma.h:424
dma_channel_type::chen
__IO uint32_t chen
Definition: at32f413_dma.h:421
dma_channel_type::lm
__IO uint32_t lm
Definition: at32f413_dma.h:426
dma_channel_type::mwidth
__IO uint32_t mwidth
Definition: at32f413_dma.h:430
dma_channel_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_dma.h:433
dma_channel_type::dtd
__IO uint32_t dtd
Definition: at32f413_dma.h:425
dma_channel_type::maddr
__IO uint32_t maddr
Definition: at32f413_dma.h:467
dma_channel_type::hdtien
__IO uint32_t hdtien
Definition: at32f413_dma.h:423
dma_channel_type::m2m
__IO uint32_t m2m
Definition: at32f413_dma.h:432
dma_channel_type::pincm
__IO uint32_t pincm
Definition: at32f413_dma.h:427
dma_channel_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_dma.h:418
dma_channel_type::fdtien
__IO uint32_t fdtien
Definition: at32f413_dma.h:422
dma_channel_type::chpl
__IO uint32_t chpl
Definition: at32f413_dma.h:431
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
dma_type
type define dma register
Definition: at32f413_dma.h:292
dma_type::gfc3
__IO uint32_t gfc3
Definition: at32f413_dma.h:349
dma_type::dterrfc1
__IO uint32_t dterrfc1
Definition: at32f413_dma.h:344
dma_type::ch2_src
__IO uint32_t ch2_src
Definition: at32f413_dma.h:385
dma_type::gfc2
__IO uint32_t gfc2
Definition: at32f413_dma.h:345
dma_type::src_sel1
__IO uint32_t src_sel1
Definition: at32f413_dma.h:396
dma_type::ch3_src
__IO uint32_t ch3_src
Definition: at32f413_dma.h:386
dma_type::hdtfc3
__IO uint32_t hdtfc3
Definition: at32f413_dma.h:351
dma_type::fdtfc2
__IO uint32_t fdtfc2
Definition: at32f413_dma.h:346
dma_type::hdtf7
__IO uint32_t hdtf7
Definition: at32f413_dma.h:327
dma_type::gfc1
__IO uint32_t gfc1
Definition: at32f413_dma.h:341
dma_type::gf4
__IO uint32_t gf4
Definition: at32f413_dma.h:313
dma_type::hdtf2
__IO uint32_t hdtf2
Definition: at32f413_dma.h:307
dma_type::hdtf3
__IO uint32_t hdtf3
Definition: at32f413_dma.h:311
dma_type::dma_flex_en
__IO uint32_t dma_flex_en
Definition: at32f413_dma.h:402
dma_type::fdtf7
__IO uint32_t fdtf7
Definition: at32f413_dma.h:326
dma_type::reserved1
__IO uint32_t reserved1
reserved, offset:0x08~0x9C
Definition: at32f413_dma.h:329
dma_type::dterrfc2
__IO uint32_t dterrfc2
Definition: at32f413_dma.h:348
dma_type::dterrf4
__IO uint32_t dterrf4
Definition: at32f413_dma.h:316
dma_type::gf7
__IO uint32_t gf7
Definition: at32f413_dma.h:325
dma_type::fdtfc4
__IO uint32_t fdtfc4
Definition: at32f413_dma.h:354
dma_type::src_sel0
__IO uint32_t src_sel0
Definition: at32f413_dma.h:381
dma_type::gf2
__IO uint32_t gf2
Definition: at32f413_dma.h:305
dma_type::hdtfc6
__IO uint32_t hdtfc6
Definition: at32f413_dma.h:363
dma_type::dterrf5
__IO uint32_t dterrf5
Definition: at32f413_dma.h:320
dma_type::hdtf5
__IO uint32_t hdtf5
Definition: at32f413_dma.h:319
dma_type::fdtfc5
__IO uint32_t fdtfc5
Definition: at32f413_dma.h:358
dma_type::fdtfc1
__IO uint32_t fdtfc1
Definition: at32f413_dma.h:342
dma_type::hdtf4
__IO uint32_t hdtf4
Definition: at32f413_dma.h:315
dma_type::ch5_src
__IO uint32_t ch5_src
Definition: at32f413_dma.h:399
dma_type::fdtf1
__IO uint32_t fdtf1
Definition: at32f413_dma.h:302
dma_type::gfc6
__IO uint32_t gfc6
Definition: at32f413_dma.h:361
dma_type::dterrf6
__IO uint32_t dterrf6
Definition: at32f413_dma.h:324
dma_type::fdtf4
__IO uint32_t fdtf4
Definition: at32f413_dma.h:314
dma_type::dterrf2
__IO uint32_t dterrf2
Definition: at32f413_dma.h:308
dma_type::gfc4
__IO uint32_t gfc4
Definition: at32f413_dma.h:353
dma_type::dterrfc3
__IO uint32_t dterrfc3
Definition: at32f413_dma.h:352
dma_type::dterrf1
__IO uint32_t dterrf1
Definition: at32f413_dma.h:304
dma_type::hdtfc1
__IO uint32_t hdtfc1
Definition: at32f413_dma.h:343
dma_type::sts
__IO uint32_t sts
Definition: at32f413_dma.h:298
dma_type::dterrf3
__IO uint32_t dterrf3
Definition: at32f413_dma.h:312
dma_type::fdtf5
__IO uint32_t fdtf5
Definition: at32f413_dma.h:318
dma_type::clr
__IO uint32_t clr
Definition: at32f413_dma.h:338
dma_type::fdtfc7
__IO uint32_t fdtfc7
Definition: at32f413_dma.h:366
dma_type::fdtf2
__IO uint32_t fdtf2
Definition: at32f413_dma.h:306
dma_type::gf1
__IO uint32_t gf1
Definition: at32f413_dma.h:301
dma_type::fdtf3
__IO uint32_t fdtf3
Definition: at32f413_dma.h:310
dma_type::hdtfc5
__IO uint32_t hdtfc5
Definition: at32f413_dma.h:359
dma_type::gf3
__IO uint32_t gf3
Definition: at32f413_dma.h:309
dma_type::dterrfc6
__IO uint32_t dterrfc6
Definition: at32f413_dma.h:364
dma_type::fdtfc3
__IO uint32_t fdtfc3
Definition: at32f413_dma.h:350
dma_type::hdtfc2
__IO uint32_t hdtfc2
Definition: at32f413_dma.h:347
dma_type::fdtfc6
__IO uint32_t fdtfc6
Definition: at32f413_dma.h:362
dma_type::ch1_src
__IO uint32_t ch1_src
Definition: at32f413_dma.h:384
dma_type::dterrfc7
__IO uint32_t dterrfc7
Definition: at32f413_dma.h:368
dma_type::gf6
__IO uint32_t gf6
Definition: at32f413_dma.h:321
dma_type::fdtf6
__IO uint32_t fdtf6
Definition: at32f413_dma.h:322
dma_type::gfc5
__IO uint32_t gfc5
Definition: at32f413_dma.h:357
dma_type::hdtfc7
__IO uint32_t hdtfc7
Definition: at32f413_dma.h:367
dma_type::dterrfc5
__IO uint32_t dterrfc5
Definition: at32f413_dma.h:360
dma_type::gfc7
__IO uint32_t gfc7
Definition: at32f413_dma.h:365
dma_type::hdtf1
__IO uint32_t hdtf1
Definition: at32f413_dma.h:303
dma_type::ch7_src
__IO uint32_t ch7_src
Definition: at32f413_dma.h:401
dma_type::ch4_src
__IO uint32_t ch4_src
Definition: at32f413_dma.h:387
dma_type::dterrf7
__IO uint32_t dterrf7
Definition: at32f413_dma.h:328
dma_type::dterrfc4
__IO uint32_t dterrfc4
Definition: at32f413_dma.h:356
dma_type::gf5
__IO uint32_t gf5
Definition: at32f413_dma.h:317
dma_type::hdtfc4
__IO uint32_t hdtfc4
Definition: at32f413_dma.h:355
dma_type::ch6_src
__IO uint32_t ch6_src
Definition: at32f413_dma.h:400
dma_type::hdtf6
__IO uint32_t hdtf6
Definition: at32f413_dma.h:323


AT32F413 Firmwary Library: at32f413_exint.c Source File

  • libraries
  • drivers
  • src
at32f413_exint.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef EXINT_MODULE_ENABLED
39
49void exint_reset(void)
50{
51 EXINT->inten = 0x00000000;
52 EXINT->polcfg1 = 0x00000000;
53 EXINT->polcfg2 = 0x00000000;
54 EXINT->evten = 0x00000000;
55 EXINT->intsts = 0x0007FFFF;
56}
57
64void exint_default_para_init(exint_init_type *exint_struct)
65{
66 exint_struct->line_enable = FALSE;
67 exint_struct->line_select = EXINT_LINE_NONE;
68 exint_struct->line_polarity = EXINT_TRIGGER_FALLING_EDGE;
69 exint_struct->line_mode = EXINT_LINE_EVENT;
70}
71
78void exint_init(exint_init_type *exint_struct)
79{
80 uint32_t line_index = 0;
81 line_index = exint_struct->line_select;
82
83 EXINT->inten &= ~line_index;
84 EXINT->evten &= ~line_index;
85
86 if(exint_struct->line_enable != FALSE)
87 {
88 if(exint_struct->line_mode == EXINT_LINE_INTERRUPUT)
89 {
90 EXINT->inten |= line_index;
91 }
92 else
93 {
94 EXINT->evten |= line_index;
95 }
96
97 EXINT->polcfg1 &= ~line_index;
98 EXINT->polcfg2 &= ~line_index;
99 if(exint_struct->line_polarity == EXINT_TRIGGER_RISING_EDGE)
100 {
101 EXINT->polcfg1 |= line_index;
102 }
103 else if(exint_struct->line_polarity == EXINT_TRIGGER_FALLING_EDGE)
104 {
105 EXINT->polcfg2 |= line_index;
106 }
107 else
108 {
109 EXINT->polcfg1 |= line_index;
110 EXINT->polcfg2 |= line_index;
111 }
112 }
113}
114
126void exint_flag_clear(uint32_t exint_line)
127{
128 EXINT->intsts = exint_line;
129}
130
142 flag_status exint_flag_get(uint32_t exint_line)
143{
144 flag_status status = RESET;
145 uint32_t exint_flag =0;
146 exint_flag = EXINT->intsts & exint_line;
147 if((exint_flag != (uint16_t)RESET))
148 {
149 status = SET;
150 }
151 else
152 {
153 status = RESET;
154 }
155 return status;
156}
157
169void exint_software_interrupt_event_generate(uint32_t exint_line)
170{
171 EXINT->swtrg |= exint_line;
172}
173
187void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state)
188{
189 if(new_state == TRUE)
190 {
191 EXINT->inten |= exint_line;
192 }
193 else
194 {
195 EXINT->inten &= ~exint_line;
196 }
197}
198
212void exint_event_enable(uint32_t exint_line, confirm_state new_state)
213{
214 if(new_state == TRUE)
215 {
216 EXINT->evten |= exint_line;
217 }
218 else
219 {
220 EXINT->evten &= ~exint_line;
221 }
222}
223
228#endif
229
EXINT_LINE_EVENT
@ EXINT_LINE_EVENT
Definition: at32f413_exint.h:85
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:93
EXINT_TRIGGER_FALLING_EDGE
@ EXINT_TRIGGER_FALLING_EDGE
Definition: at32f413_exint.h:94
EXINT_LINE_NONE
#define EXINT_LINE_NONE
Definition: at32f413_exint.h:51
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:142
exint_interrupt_enable
void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt
Definition: at32f413_exint.c:187
exint_event_enable
void exint_event_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint event
Definition: at32f413_exint.c:212
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:64
exint_reset
void exint_reset(void)
exint reset
Definition: at32f413_exint.c:49
exint_software_interrupt_event_generate
void exint_software_interrupt_event_generate(uint32_t exint_line)
generate exint software interrupt event
Definition: at32f413_exint.c:169
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT
#define EXINT
Definition: at32f413_exint.h:198
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_exint.h Source File

  • libraries
  • drivers
  • inc
at32f413_exint.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_EXINT_H
29#define __AT32F413_EXINT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
51#define EXINT_LINE_NONE ((uint32_t)0x000000)
52#define EXINT_LINE_0 ((uint32_t)0x000001)
53#define EXINT_LINE_1 ((uint32_t)0x000002)
54#define EXINT_LINE_2 ((uint32_t)0x000004)
55#define EXINT_LINE_3 ((uint32_t)0x000008)
56#define EXINT_LINE_4 ((uint32_t)0x000010)
57#define EXINT_LINE_5 ((uint32_t)0x000020)
58#define EXINT_LINE_6 ((uint32_t)0x000040)
59#define EXINT_LINE_7 ((uint32_t)0x000080)
60#define EXINT_LINE_8 ((uint32_t)0x000100)
61#define EXINT_LINE_9 ((uint32_t)0x000200)
62#define EXINT_LINE_10 ((uint32_t)0x000400)
63#define EXINT_LINE_11 ((uint32_t)0x000800)
64#define EXINT_LINE_12 ((uint32_t)0x001000)
65#define EXINT_LINE_13 ((uint32_t)0x002000)
66#define EXINT_LINE_14 ((uint32_t)0x004000)
67#define EXINT_LINE_15 ((uint32_t)0x008000)
68#define EXINT_LINE_16 ((uint32_t)0x010000)
69#define EXINT_LINE_17 ((uint32_t)0x020000)
70#define EXINT_LINE_18 ((uint32_t)0x040000)
82typedef enum
83{
84 EXINT_LINE_INTERRUPUT = 0x00,
85 EXINT_LINE_EVENT = 0x01
86} exint_line_mode_type;
87
91typedef enum
92{
93 EXINT_TRIGGER_RISING_EDGE = 0x00,
94 EXINT_TRIGGER_FALLING_EDGE = 0x01,
95 EXINT_TRIGGER_BOTH_EDGE = 0x02
96} exint_polarity_config_type;
97
101typedef struct
102{
103 exint_line_mode_type line_mode;
104 uint32_t line_select;
105 exint_polarity_config_type line_polarity;
106 confirm_state line_enable;
107} exint_init_type;
108
112typedef struct
113{
114
118 union
119 {
120 __IO uint32_t inten;
121 struct
122 {
123 __IO uint32_t intenx : 23;/* [22:0] */
124 __IO uint32_t reserved1 : 9;/* [31:23] */
125 } inten_bit;
126 };
127
131 union
132 {
133 __IO uint32_t evten;
134 struct
135 {
136 __IO uint32_t evtenx : 23;/* [22:0] */
137 __IO uint32_t reserved1 : 9;/* [31:23] */
138 } evten_bit;
139 };
140
144 union
145 {
146 __IO uint32_t polcfg1;
147 struct
148 {
149 __IO uint32_t rpx : 23;/* [22:0] */
150 __IO uint32_t reserved1 : 9;/* [31:23] */
151 } polcfg1_bit;
152 };
153
157 union
158 {
159 __IO uint32_t polcfg2;
160 struct
161 {
162 __IO uint32_t fpx : 23;/* [22:0] */
163 __IO uint32_t reserved1 : 9;/* [31:23] */
164 } polcfg2_bit;
165 };
166
170 union
171 {
172 __IO uint32_t swtrg;
173 struct
174 {
175 __IO uint32_t swtx : 23;/* [22:0] */
176 __IO uint32_t reserved1 : 9;/* [31:23] */
177 } swtrg_bit;
178 };
179
183 union
184 {
185 __IO uint32_t intsts;
186 struct
187 {
188 __IO uint32_t linex : 23;/* [22:0] */
189 __IO uint32_t reserved1 : 9;/* [31:23] */
190 } intsts_bit;
191 };
192} exint_type;
193
198#define EXINT ((exint_type *) EXINT_BASE)
199
204void exint_reset(void);
205void exint_default_para_init(exint_init_type *exint_struct);
206void exint_init(exint_init_type *exint_struct);
207void exint_flag_clear(uint32_t exint_line);
208 flag_status exint_flag_get(uint32_t exint_line);
209void exint_software_interrupt_event_generate(uint32_t exint_line);
210void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state);
211void exint_event_enable(uint32_t exint_line, confirm_state new_state);
212
225#ifdef __cplusplus
226}
227#endif
228
229#endif
at32f413.h
at32f413 header file
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:142
exint_interrupt_enable
void exint_interrupt_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint interrupt
Definition: at32f413_exint.c:187
exint_event_enable
void exint_event_enable(uint32_t exint_line, confirm_state new_state)
enable or disable exint event
Definition: at32f413_exint.c:212
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:64
exint_reset
void exint_reset(void)
exint reset
Definition: at32f413_exint.c:49
exint_software_interrupt_event_generate
void exint_software_interrupt_event_generate(uint32_t exint_line)
generate exint software interrupt event
Definition: at32f413_exint.c:169
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
exint_line_mode_type
exint_line_mode_type
exint line mode type
Definition: at32f413_exint.h:83
exint_polarity_config_type
exint_polarity_config_type
exint polarity configuration type
Definition: at32f413_exint.h:92
EXINT_LINE_EVENT
@ EXINT_LINE_EVENT
Definition: at32f413_exint.h:85
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:93
EXINT_TRIGGER_FALLING_EDGE
@ EXINT_TRIGGER_FALLING_EDGE
Definition: at32f413_exint.h:94
EXINT_TRIGGER_BOTH_EDGE
@ EXINT_TRIGGER_BOTH_EDGE
Definition: at32f413_exint.h:95
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
exint_type
type define exint register all
Definition: at32f413_exint.h:113
exint_type::polcfg1
__IO uint32_t polcfg1
Definition: at32f413_exint.h:146
exint_type::intsts
__IO uint32_t intsts
Definition: at32f413_exint.h:185
exint_type::polcfg2
__IO uint32_t polcfg2
Definition: at32f413_exint.h:159
exint_type::fpx
__IO uint32_t fpx
Definition: at32f413_exint.h:162
exint_type::intenx
__IO uint32_t intenx
Definition: at32f413_exint.h:123
exint_type::rpx
__IO uint32_t rpx
Definition: at32f413_exint.h:149
exint_type::evtenx
__IO uint32_t evtenx
Definition: at32f413_exint.h:136
exint_type::linex
__IO uint32_t linex
Definition: at32f413_exint.h:188
exint_type::inten
__IO uint32_t inten
Definition: at32f413_exint.h:120
exint_type::evten
__IO uint32_t evten
Definition: at32f413_exint.h:133
exint_type::swtx
__IO uint32_t swtx
Definition: at32f413_exint.h:175
exint_type::swtrg
__IO uint32_t swtrg
Definition: at32f413_exint.h:172
exint_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_exint.h:124


AT32F413 Firmwary Library: at32f413_flash.c Source File

  • libraries
  • drivers
  • src
at32f413_flash.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef FLASH_MODULE_ENABLED
39
59 flag_status flash_flag_get(uint32_t flash_flag)
60{
61 flag_status status = RESET;
62 uint32_t flag_position;
63 flag_position = flash_flag & 0x70000000;
64 flash_flag &= 0x8FFFFFFF;
65 switch(flag_position)
66 {
67 case 0x00000000:
68 if(FLASH->sts & flash_flag)
69 status = SET;
70 break;
71 case 0x20000000:
72 if(FLASH->sts3 & flash_flag)
73 status = SET;
74 break;
75 case 0x40000000:
76 if(FLASH->usd & flash_flag)
77 status = SET;
78 break;
79 default:
80 break;
81 }
82 /* return the new state of flash_flag (SET or RESET) */
83 return status;
84}
85
98void flash_flag_clear(uint32_t flash_flag)
99{
100 uint32_t flag_position;
101 flag_position = flash_flag & 0x70000000;
102 flash_flag &= 0x8FFFFFFF;
103 switch(flag_position)
104 {
105 case 0x00000000:
106 FLASH->sts = flash_flag;
107 break;
108 case 0x20000000:
109 FLASH->sts3 = flash_flag;
110 break;
111 default:
112 break;
113 }
114}
115
122 flash_status_type flash_operation_status_get(void)
123{
124 flash_status_type flash_status = FLASH_OPERATE_DONE;
125 if(FLASH->sts_bit.obf != RESET)
126 {
127 flash_status = FLASH_OPERATE_BUSY;
128 }
129 else if(FLASH->sts_bit.prgmerr != RESET)
130 {
131 flash_status = FLASH_PROGRAM_ERROR;
132 }
133 else if(FLASH->sts_bit.epperr != RESET)
134 {
135 flash_status = FLASH_EPP_ERROR;
136 }
137 else
138 {
139 flash_status = FLASH_OPERATE_DONE;
140 }
141 /* return the flash status */
142 return flash_status;
143}
144
151 flash_status_type flash_spim_operation_status_get(void)
152{
153 flash_status_type flash_status = FLASH_OPERATE_DONE;
154 if(FLASH->sts3_bit.obf != RESET)
155 {
156 flash_status = FLASH_OPERATE_BUSY;
157 }
158 else if(FLASH->sts3_bit.prgmerr != RESET)
159 {
160 flash_status = FLASH_PROGRAM_ERROR;
161 }
162 else if(FLASH->sts3_bit.epperr != RESET)
163 {
164 flash_status = FLASH_EPP_ERROR;
165 }
166 else
167 {
168 flash_status = FLASH_OPERATE_DONE;
169 }
170 /* return the flash status */
171 return flash_status;
172}
173
180 flash_status_type flash_operation_wait_for(uint32_t time_out)
181{
182 flash_status_type status = FLASH_OPERATE_DONE;
183 /* check for the flash status */
184 status = flash_operation_status_get();
185
186 while((status == FLASH_OPERATE_BUSY) && (time_out != 0x00))
187 {
188 status = flash_operation_status_get();
189 time_out--;
190 }
191 if(time_out == 0x00)
192 {
193 status = FLASH_OPERATE_TIMEOUT;
194 }
195 /* return the status */
196 return status;
197}
198
205 flash_status_type flash_spim_operation_wait_for(uint32_t time_out)
206{
207 flash_status_type status = FLASH_OPERATE_DONE;
208 /* check for the flash status */
209 status = flash_spim_operation_status_get();
210
211 while((status == FLASH_OPERATE_BUSY) && (time_out != 0x00))
212 {
213 status = flash_spim_operation_status_get();
214 time_out--;
215 }
216 if(time_out == 0x00)
217 {
218 status = FLASH_OPERATE_TIMEOUT;
219 }
220 /* return the operation status */
221 return status;
222}
223
229void flash_unlock(void)
230{
231 FLASH->unlock = FLASH_UNLOCK_KEY1;
232 FLASH->unlock = FLASH_UNLOCK_KEY2;
233}
234
240void flash_spim_unlock(void)
241{
242 FLASH->unlock3 = FLASH_UNLOCK_KEY1;
243 FLASH->unlock3 = FLASH_UNLOCK_KEY2;
244}
245
251void flash_lock(void)
252{
253 FLASH->ctrl_bit.oplk = TRUE;
254}
255
261void flash_spim_lock(void)
262{
263 FLASH->ctrl3_bit.oplk = TRUE;
264}
265
272 flash_status_type flash_sector_erase(uint32_t sector_address)
273{
274 flash_status_type status = FLASH_OPERATE_DONE;
275 /* spim : external flash */
276 if(sector_address >= FLASH_SPIM_START_ADDR)
277 {
278 /* wait for last operation to be completed */
279 status = flash_spim_operation_wait_for(SPIM_ERASE_TIMEOUT);
280
281 if(status == FLASH_OPERATE_DONE)
282 {
283 /* if the previous operation is completed, continue to erase the sector */
284 FLASH->ctrl3_bit.secers = TRUE;
285 FLASH->addr3 = sector_address;
286 FLASH->ctrl3_bit.erstr = TRUE;
287
288 /* wait for operation to be completed */
289 status = flash_spim_operation_wait_for(SPIM_ERASE_TIMEOUT);
290
291 /* disable the secers bit */
292 FLASH->ctrl3_bit.secers = FALSE;
293 }
294 return status;
295 }
296 else
297 {
298 /* wait for last operation to be completed */
299 status = flash_operation_wait_for(ERASE_TIMEOUT);
300
301 if(status == FLASH_OPERATE_DONE)
302 {
303 /* if the previous operation is completed, continue to erase the sector */
304 FLASH->ctrl_bit.secers = TRUE;
305 FLASH->addr = sector_address;
306 FLASH->ctrl_bit.erstr = TRUE;
307
308 /* wait for operation to be completed */
309 status = flash_operation_wait_for(ERASE_TIMEOUT);
310
311 /* disable the secers bit */
312 FLASH->ctrl_bit.secers = FALSE;
313 }
314 }
315 /* return the erase status */
316 return status;
317}
318
325 flash_status_type flash_internal_all_erase(void)
326{
327 flash_status_type status = FLASH_OPERATE_DONE;
328 /* wait for last operation to be completed */
329 status = flash_operation_wait_for(ERASE_TIMEOUT);
330
331 if(status == FLASH_OPERATE_DONE)
332 {
333 /* if the previous operation is completed, continue to erase bank1 */
334 FLASH->ctrl_bit.bankers = TRUE;
335 FLASH->ctrl_bit.erstr = TRUE;
336
337 /* wait for operation to be completed */
338 status = flash_operation_wait_for(ERASE_TIMEOUT);
339
340 /* disable the bankers bit */
341 FLASH->ctrl_bit.bankers = FALSE;
342 }
343 /* return the erase status */
344 return status;
345}
346
353 flash_status_type flash_spim_all_erase(void)
354{
355 flash_status_type status = FLASH_OPERATE_DONE;
356 /* wait for last operation to be completed */
357 status = flash_spim_operation_wait_for(SPIM_ERASE_TIMEOUT);
358
359 if(status == FLASH_OPERATE_DONE)
360 {
361 /* if the previous operation is completed, continue to erase spim */
362 FLASH->ctrl3_bit.chpers = TRUE;
363 FLASH->ctrl3_bit.erstr = TRUE;
364
365 /* wait for operation to be completed */
366 status = flash_spim_operation_wait_for(SPIM_ERASE_TIMEOUT);
367
368 /* disable the chpers bit */
369 FLASH->ctrl3_bit.chpers = FALSE;
370 }
371 /* return the erase status */
372 return status;
373}
374
382 flash_status_type flash_user_system_data_erase(void)
383{
384 flash_status_type status = FLASH_OPERATE_DONE;
385 uint16_t fap_val = FAP_RELIEVE_KEY;
386 /* get the flash access protection status */
387 if(flash_fap_status_get() != RESET)
388 {
389 fap_val = 0x0000;
390 }
391
392 /* wait for last operation to be completed */
393 status = flash_operation_wait_for(ERASE_TIMEOUT);
394
395 if(status == FLASH_OPERATE_DONE)
396 {
397 /* unlock the user system data */
398 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
399 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
400 while(FLASH->ctrl_bit.usdulks==RESET);
401
402 /* erase the user system data */
403 FLASH->ctrl_bit.usders = TRUE;
404 FLASH->ctrl_bit.erstr = TRUE;
405
406 /* wait for operation to be completed */
407 status = flash_operation_wait_for(ERASE_TIMEOUT);
408
409 /* disable the usders bit */
410 FLASH->ctrl_bit.usders = FALSE;
411
412 if((status == FLASH_OPERATE_DONE) && (fap_val == FAP_RELIEVE_KEY))
413 {
414 /* enable the user system data programming operation */
415 FLASH->ctrl_bit.usdprgm = TRUE;
416
417 /* restore the last flash access protection value */
418 USD->fap = (uint16_t)fap_val;
419
420 /* wait for operation to be completed */
421 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
422
423 /*disable the usdprgm bit */
424 FLASH->ctrl_bit.usdprgm = FALSE;
425 }
426 }
427 /* return the erase status */
428 return status;
429}
430
438 flash_status_type flash_word_program(uint32_t address, uint32_t data)
439{
440 flash_status_type status = FLASH_OPERATE_DONE;
441 /* spim : external flash */
442 if(address >= FLASH_SPIM_START_ADDR)
443 {
444 /* wait for last operation to be completed */
445 status = flash_spim_operation_wait_for(SPIM_PROGRAMMING_TIMEOUT);
446
447 if(status == FLASH_OPERATE_DONE)
448 {
449 FLASH->ctrl3_bit.fprgm = TRUE;
450 *(__IO uint32_t*)address = data;
451 /* wait for operation to be completed */
452 status = flash_spim_operation_wait_for(SPIM_PROGRAMMING_TIMEOUT);
453
454 /* disable the fprgm bit */
455 FLASH->ctrl3_bit.fprgm = FALSE;
456 }
457 }
458 else
459 {
460 /* wait for last operation to be completed */
461 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
462
463 if(status == FLASH_OPERATE_DONE)
464 {
465 FLASH->ctrl_bit.fprgm = TRUE;
466 *(__IO uint32_t*)address = data;
467 /* wait for operation to be completed */
468 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
469
470 /* disable the fprgm bit */
471 FLASH->ctrl_bit.fprgm = FALSE;
472 }
473 }
474 /* return the program status */
475 return status;
476}
477
485 flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
486{
487 flash_status_type status = FLASH_OPERATE_DONE;
488 /* spim : external flash */
489 if(address >= FLASH_SPIM_START_ADDR)
490 {
491 /* wait for last operation to be completed */
492 status = flash_spim_operation_wait_for(SPIM_PROGRAMMING_TIMEOUT);
493
494 if(status == FLASH_OPERATE_DONE)
495 {
496 FLASH->ctrl3_bit.fprgm = TRUE;
497 *(__IO uint16_t*)address = data;
498 /* wait for operation to be completed */
499 status = flash_spim_operation_wait_for(SPIM_PROGRAMMING_TIMEOUT);
500
501 /* disable the fprgm bit */
502 FLASH->ctrl3_bit.fprgm = FALSE;
503 }
504 }
505 else
506 {
507 /* wait for last operation to be completed */
508 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
509
510 if(status == FLASH_OPERATE_DONE)
511 {
512 FLASH->ctrl_bit.fprgm = TRUE;
513 *(__IO uint16_t*)address = data;
514 /* wait for operation to be completed */
515 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
516
517 /* disable the fprgm bit */
518 FLASH->ctrl_bit.fprgm = FALSE;
519 }
520 }
521 /* return the program status */
522 return status;
523}
524
533 flash_status_type flash_byte_program(uint32_t address, uint8_t data)
534{
535 flash_status_type status = FLASH_OPERATE_DONE;
536 /* wait for last operation to be completed */
537 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
538
539 if(status == FLASH_OPERATE_DONE)
540 {
541 FLASH->ctrl_bit.fprgm = TRUE;
542 *(__IO uint8_t*)address = data;
543 /* wait for operation to be completed */
544 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
545
546 /* disable the fprgm bit */
547 FLASH->ctrl_bit.fprgm = FALSE;
548 }
549 /* return the program status */
550 return status;
551}
552
560 flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
561{
562 flash_status_type status = FLASH_OPERATE_DONE;
563 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
564 if(status == FLASH_OPERATE_DONE)
565 {
566 /* unlock the user system data */
567 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
568 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
569 while(FLASH->ctrl_bit.usdulks==RESET);
570
571 /* enable the user system data programming operation */
572 FLASH->ctrl_bit.usdprgm = TRUE;
573 *(__IO uint16_t*)address = data;
574
575 /* wait for operation to be completed */
576 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
577
578 /* disable the usdprgm bit */
579 FLASH->ctrl_bit.usdprgm = FALSE;
580 }
581 /* return the user system data program status */
582 return status;
583}
584
594 flash_status_type flash_epp_set(uint32_t *sector_bits)
595{
596 uint16_t epp_data[4] = {0xFFFF,0xFFFF,0xFFFF,0xFFFF};
597 flash_status_type status = FLASH_OPERATE_DONE;
598 sector_bits[0] = (uint32_t)(~sector_bits[0]);
599 epp_data[0] = (uint16_t)((sector_bits[0] >> 0) & 0xFF);
600 epp_data[1] = (uint16_t)((sector_bits[0] >> 8) & 0xFF);
601 epp_data[2] = (uint16_t)((sector_bits[0] >> 16) & 0xFF);
602 epp_data[3] = (uint16_t)((sector_bits[0] >> 24) & 0xFF);
603 /* wait for last operation to be completed */
604 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
605
606 if(status == FLASH_OPERATE_DONE)
607 {
608 /* unlock the user system data */
609 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
610 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
611 while(FLASH->ctrl_bit.usdulks==RESET);
612
613 FLASH->ctrl_bit.usdprgm = TRUE;
614 USD->epp0 = epp_data[0];
615 /* wait for operation to be completed */
616 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
617
618 if(status == FLASH_OPERATE_DONE)
619 {
620 USD->epp1 = epp_data[1];
621 /* wait for operation to be completed */
622 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
623 }
624 if(status == FLASH_OPERATE_DONE)
625 {
626 USD->epp2 = epp_data[2];
627 /* wait for operation to be completed */
628 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
629 }
630 if(status == FLASH_OPERATE_DONE)
631 {
632 USD->epp3 = epp_data[3];
633 /* wait for operation to be completed */
634 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
635 }
636 /* disable the usdprgm bit */
637 FLASH->ctrl_bit.usdprgm = FALSE;
638 }
639 /* return the erase/program protection operation status */
640 return status;
641}
642
648void flash_epp_status_get(uint32_t *sector_bits)
649{
650 /* return the flash erase/program protection register value */
651 sector_bits[0] = (uint32_t)(FLASH->epps);
652}
653
663 flash_status_type flash_fap_enable(confirm_state new_state)
664{
665 flash_status_type status = FLASH_OPERATE_DONE;
666 status = flash_operation_wait_for(ERASE_TIMEOUT);
667 if(status == FLASH_OPERATE_DONE)
668 {
669 /* unlock the user system data */
670 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
671 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
672 while(FLASH->ctrl_bit.usdulks==RESET);
673
674 FLASH->ctrl_bit.usders = TRUE;
675 FLASH->ctrl_bit.erstr = TRUE;
676 /* wait for operation to be completed */
677 status = flash_operation_wait_for(ERASE_TIMEOUT);
678
679 /* disable the usders bit */
680 FLASH->ctrl_bit.usders = FALSE;
681
682 if(status == FLASH_OPERATE_DONE)
683 {
684 if(new_state == FALSE)
685 {
686 /* enable the user system data programming operation */
687 FLASH->ctrl_bit.usdprgm = TRUE;
688 USD->fap = FAP_RELIEVE_KEY;
689
690 /* Wait for operation to be completed */
691 status = flash_operation_wait_for(ERASE_TIMEOUT);
692
693 /* disable the usdprgm bit */
694 FLASH->ctrl_bit.usdprgm = FALSE;
695 }
696 }
697 }
698 /* return the flash access protection operation status */
699 return status;
700}
701
707 flag_status flash_fap_status_get(void)
708{
709 return (flag_status)FLASH->usd_bit.fap;
710}
711
731 flash_status_type flash_ssb_set(uint8_t usd_ssb)
732{
733 flash_status_type status = FLASH_OPERATE_DONE;
734 /* wait for last operation to be completed */
735 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
736
737 if(status == FLASH_OPERATE_DONE)
738 {
739 /* unlock the user system data */
740 FLASH->usd_unlock = FLASH_UNLOCK_KEY1;
741 FLASH->usd_unlock = FLASH_UNLOCK_KEY2;
742 while(FLASH->ctrl_bit.usdulks==RESET);
743
744 /* enable the user system data programming operation */
745 FLASH->ctrl_bit.usdprgm = TRUE;
746
747 USD->ssb = usd_ssb;
748 /* wait for operation to be completed */
749 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
750
751 /* disable the usdprgm bit */
752 FLASH->ctrl_bit.usdprgm = FALSE;
753 }
754 /* return the user system data program status */
755 return status;
756}
757
763uint8_t flash_ssb_status_get(void)
764{
765 /* return the system setting byte status */
766 return (uint8_t)(FLASH->usd >> 2);
767}
768
781void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
782{
783 if(flash_int & FLASH_ERR_INT)
784 FLASH->ctrl_bit.errie = new_state;
785 if(flash_int & FLASH_ODF_INT)
786 FLASH->ctrl_bit.odfie = new_state;
787 if(flash_int & FLASH_SPIM_ERR_INT)
788 FLASH->ctrl3_bit.errie = new_state;
789 if(flash_int & FLASH_SPIM_ODF_INT)
790 FLASH->ctrl3_bit.odfie = new_state;
791}
792
798void flash_spim_model_select(flash_spim_model_type mode)
799{
800 FLASH->select = mode;
801}
802
810void flash_spim_encryption_range_set(uint32_t decode_address)
811{
812 FLASH->da = decode_address;
813}
814
824 flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
825{
826 uint32_t slib_range;
827 flash_status_type status = FLASH_OPERATE_DONE;
828 /* wait for last operation to be completed */
829 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
830
831 /*check range param limits*/
832 if((start_sector>=data_start_sector) || ((data_start_sector > end_sector) && \
833 (data_start_sector != 0x7FF)) || (start_sector > end_sector))
834 return FLASH_PROGRAM_ERROR;
835
836 if(status == FLASH_OPERATE_DONE)
837 {
838 /* unlock slib cfg register */
839 FLASH->slib_unlock = SLIB_UNLOCK_KEY;
840 while(FLASH->slib_misc_sts_bit.slib_ulkf==RESET);
841
842 slib_range = ((uint32_t)(data_start_sector << 11) & FLASH_SLIB_DATA_START_SECTOR) | \
843 ((uint32_t)(end_sector << 22) & FLASH_SLIB_END_SECTOR) | \
844 (start_sector & FLASH_SLIB_START_SECTOR);
845 /* configure slib, set pwd and range */
846 FLASH->slib_set_pwd = pwd;
847 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
848 FLASH->slib_set_range = slib_range;
849 status = flash_operation_wait_for(PROGRAMMING_TIMEOUT);
850 }
851 return status;
852}
853
859 error_status flash_slib_disable(uint32_t pwd)
860{
861 flash_status_type status = FLASH_OPERATE_DONE;
862 /* write password to disable slib */
863 FLASH->slib_pwd_clr = pwd;
864
865 status = flash_operation_wait_for(ERASE_TIMEOUT);
866 if(status == FLASH_OPERATE_DONE)
867 {
868 if(FLASH->slib_misc_sts_bit.slib_pwd_ok)
869 return SUCCESS;
870 else
871 return ERROR;
872 }
873 return ERROR;
874}
875
881uint32_t flash_slib_remaining_count_get(void)
882{
883 return (uint32_t)FLASH->slib_misc_sts_bit.slib_rcnt;
884}
885
891 flag_status flash_slib_state_get(void)
892{
893 if(FLASH->slib_sts0_bit.slib_enf)
894 return SET;
895 else
896 return RESET;
897}
898
904uint16_t flash_slib_start_sector_get(void)
905{
906 return (uint16_t)FLASH->slib_sts1_bit.slib_ss;
907}
908
914uint16_t flash_slib_datstart_sector_get(void)
915{
916 return (uint16_t)FLASH->slib_sts1_bit.slib_dat_ss;
917}
918
924uint16_t flash_slib_end_sector_get(void)
925{
926 return (uint16_t)FLASH->slib_sts1_bit.slib_es;
927}
928
935uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt)
936{
937 FLASH->crc_ctrl_bit.crc_ss = start_sector;
938 FLASH->crc_ctrl_bit.crc_sn = sector_cnt;
939 FLASH->crc_ctrl_bit.crc_strt = TRUE;
940 flash_operation_wait_for(OPERATION_TIMEOUT);
941 return FLASH->crc_chkr;
942}
943
948#endif
949
error_status
error_status
error status
Definition: at32f413.h:264
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
flash_spim_model_type
flash_spim_model_type
flash spim model type
Definition: at32f413_flash.h:171
flash_status_type
flash_status_type
flash status type
Definition: at32f413_flash.h:159
FLASH_OPERATE_BUSY
@ FLASH_OPERATE_BUSY
Definition: at32f413_flash.h:160
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f413_flash.h:163
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f413_flash.h:164
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f413_flash.h:161
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f413_flash.h:162
FLASH_ERR_INT
#define FLASH_ERR_INT
Definition: at32f413_flash.h:96
FLASH_SPIM_ERR_INT
#define FLASH_SPIM_ERR_INT
Definition: at32f413_flash.h:98
FLASH_SPIM_ODF_INT
#define FLASH_SPIM_ODF_INT
Definition: at32f413_flash.h:99
FLASH_ODF_INT
#define FLASH_ODF_INT
Definition: at32f413_flash.h:97
flash_slib_state_get
flag_status flash_slib_state_get(void)
get the slib state.
Definition: at32f413_flash.c:891
flash_slib_enable
flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function.
Definition: at32f413_flash.c:824
flash_fap_status_get
flag_status flash_fap_status_get(void)
check the flash access protection status.
Definition: at32f413_flash.c:707
flash_slib_remaining_count_get
uint32_t flash_slib_remaining_count_get(void)
get remaining count of slib(range: 256~0).
Definition: at32f413_flash.c:881
flash_slib_disable
error_status flash_slib_disable(uint32_t pwd)
disable slib when slib enabled.
Definition: at32f413_flash.c:859
flash_slib_datstart_sector_get
uint16_t flash_slib_datstart_sector_get(void)
get the data start sector of slib.
Definition: at32f413_flash.c:914
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f413_flash.c:485
flash_user_system_data_program
flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
program a halfword at a specified user system data address.
Definition: at32f413_flash.c:560
flash_spim_lock
void flash_spim_lock(void)
lock the flash spim controller.
Definition: at32f413_flash.c:261
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:533
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_spim_unlock
void flash_spim_unlock(void)
unlock the flash spim controller.
Definition: at32f413_flash.c:240
flash_operation_status_get
flash_status_type flash_operation_status_get(void)
return the flash operation status.
Definition: at32f413_flash.c:122
flash_epp_set
flash_status_type flash_epp_set(uint32_t *sector_bits)
config erase/program protection for the desired sectors.
Definition: at32f413_flash.c:594
flash_spim_model_select
void flash_spim_model_select(flash_spim_model_type mode)
select spim supports extended spi flash chip model.
Definition: at32f413_flash.c:798
flash_ssb_set
flash_status_type flash_ssb_set(uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst.
Definition: at32f413_flash.c:731
flash_crc_calibrate
uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block.
Definition: at32f413_flash.c:935
flash_spim_operation_wait_for
flash_status_type flash_spim_operation_wait_for(uint32_t time_out)
wait for flash spim operation complete or timeout.
Definition: at32f413_flash.c:205
flash_slib_start_sector_get
uint16_t flash_slib_start_sector_get(void)
get the start sector of slib.
Definition: at32f413_flash.c:904
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f413_flash.c:781
flash_fap_enable
flash_status_type flash_fap_enable(confirm_state new_state)
enable or disable the flash access protection.
Definition: at32f413_flash.c:663
flash_slib_end_sector_get
uint16_t flash_slib_end_sector_get(void)
get the end sector of slib.
Definition: at32f413_flash.c:924
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
flash_spim_encryption_range_set
void flash_spim_encryption_range_set(uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value,...
Definition: at32f413_flash.c:810
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:59
flash_spim_operation_status_get
flash_status_type flash_spim_operation_status_get(void)
return the flash spim operation status.
Definition: at32f413_flash.c:151
flash_user_system_data_erase
flash_status_type flash_user_system_data_erase(void)
erase the flash user system data.
Definition: at32f413_flash.c:382
flash_internal_all_erase
flash_status_type flash_internal_all_erase(void)
erase flash all internal sectors.
Definition: at32f413_flash.c:325
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f413_flash.c:180
flash_ssb_status_get
uint8_t flash_ssb_status_get(void)
return the flash system setting byte status.
Definition: at32f413_flash.c:763
flash_epp_status_get
void flash_epp_status_get(uint32_t *sector_bits)
return the flash erase/program protection status.
Definition: at32f413_flash.c:648
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:98
flash_spim_all_erase
flash_status_type flash_spim_all_erase(void)
erase flash spim sectors.
Definition: at32f413_flash.c:353
FLASH_SLIB_END_SECTOR
#define FLASH_SLIB_END_SECTOR
Definition: at32f413_flash.h:112
FLASH_SLIB_DATA_START_SECTOR
#define FLASH_SLIB_DATA_START_SECTOR
Definition: at32f413_flash.h:111
FLASH_SLIB_START_SECTOR
#define FLASH_SLIB_START_SECTOR
Definition: at32f413_flash.h:110
FLASH_SPIM_START_ADDR
#define FLASH_SPIM_START_ADDR
Definition: at32f413_flash.h:66
PROGRAMMING_TIMEOUT
#define PROGRAMMING_TIMEOUT
Definition: at32f413_flash.h:142
SPIM_ERASE_TIMEOUT
#define SPIM_ERASE_TIMEOUT
Definition: at32f413_flash.h:143
OPERATION_TIMEOUT
#define OPERATION_TIMEOUT
Definition: at32f413_flash.h:145
ERASE_TIMEOUT
#define ERASE_TIMEOUT
Definition: at32f413_flash.h:141
SPIM_PROGRAMMING_TIMEOUT
#define SPIM_PROGRAMMING_TIMEOUT
Definition: at32f413_flash.h:144
FAP_RELIEVE_KEY
#define FAP_RELIEVE_KEY
Definition: at32f413_flash.h:55
FLASH_UNLOCK_KEY2
#define FLASH_UNLOCK_KEY2
Definition: at32f413_flash.h:54
FLASH_UNLOCK_KEY1
#define FLASH_UNLOCK_KEY1
Definition: at32f413_flash.h:53
SLIB_UNLOCK_KEY
#define SLIB_UNLOCK_KEY
Definition: at32f413_flash.h:56
USD
#define USD
Definition: at32f413_flash.h:565
FLASH
#define FLASH
Definition: at32f413_flash.h:564
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_flash.h Source File

  • libraries
  • drivers
  • inc
at32f413_flash.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_FLASH_H
29#define __AT32F413_FLASH_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
39
53#define FLASH_UNLOCK_KEY1 ((uint32_t)0x45670123)
54#define FLASH_UNLOCK_KEY2 ((uint32_t)0xCDEF89AB)
55#define FAP_RELIEVE_KEY ((uint16_t)0x00A5)
56#define SLIB_UNLOCK_KEY ((uint32_t)0xA35F6D24)
66#define FLASH_SPIM_START_ADDR ((uint32_t)0x08400000)
77#define FLASH_OBF_FLAG ((uint32_t)0x00000001)
78#define FLASH_ODF_FLAG ((uint32_t)0x00000020)
79#define FLASH_PRGMERR_FLAG ((uint32_t)0x00000004)
80#define FLASH_EPPERR_FLAG ((uint32_t)0x00000010)
81#define FLASH_SPIM_OBF_FLAG ((uint32_t)0x20000001)
82#define FLASH_SPIM_ODF_FLAG ((uint32_t)0x20000020)
83#define FLASH_SPIM_PRGMERR_FLAG ((uint32_t)0x20000004)
84#define FLASH_SPIM_EPPERR_FLAG ((uint32_t)0x20000010)
85#define FLASH_USDERR_FLAG ((uint32_t)0x40000001)
96#define FLASH_ERR_INT ((uint32_t)0x00000001)
97#define FLASH_ODF_INT ((uint32_t)0x00000002)
98#define FLASH_SPIM_ERR_INT ((uint32_t)0x00000010)
99#define FLASH_SPIM_ODF_INT ((uint32_t)0x00000020)
110#define FLASH_SLIB_START_SECTOR ((uint32_t)0x000007FF)
111#define FLASH_SLIB_DATA_START_SECTOR ((uint32_t)0x003FF800)
112#define FLASH_SLIB_END_SECTOR ((uint32_t)0xFFC00000)
123#define USD_WDT_ATO_DISABLE ((uint16_t)0x0001)
124#define USD_WDT_ATO_ENABLE ((uint16_t)0x0000)
126#define USD_DEPSLP_NO_RST ((uint16_t)0x0002)
127#define USD_DEPSLP_RST ((uint16_t)0x0000)
129#define USD_STDBY_NO_RST ((uint16_t)0x0004)
130#define USD_STDBY_RST ((uint16_t)0x0000)
141#define ERASE_TIMEOUT ((uint32_t)0x40000000)
142#define PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
143#define SPIM_ERASE_TIMEOUT ((uint32_t)0xFFFFFFFF)
144#define SPIM_PROGRAMMING_TIMEOUT ((uint32_t)0x00100000)
145#define OPERATION_TIMEOUT ((uint32_t)0x10000000)
158typedef enum
159{
160 FLASH_OPERATE_BUSY = 0x00,
161 FLASH_PROGRAM_ERROR = 0x01,
162 FLASH_EPP_ERROR = 0x02,
163 FLASH_OPERATE_DONE = 0x03,
164 FLASH_OPERATE_TIMEOUT = 0x04
165} flash_status_type;
166
170typedef enum
171{
172 FLASH_SPIM_MODEL1 = 0x01,
173 FLASH_SPIM_MODEL2 = 0x02,
174} flash_spim_model_type;
175
179typedef struct
180{
184 union
185 {
186 __IO uint32_t psr;
187 struct
188 {
189 __IO uint32_t reserved1 : 32; /* [31:0] */
190 } psr_bit;
191 };
192
196 union
197 {
198 __IO uint32_t unlock;
199 struct
200 {
201 __IO uint32_t ukval : 32;/* [31:0] */
202 } unlock_bit;
203 };
204
208 union
209 {
210 __IO uint32_t usd_unlock;
211 struct
212 {
213 __IO uint32_t usd_ukval : 32;/* [31:0] */
214 } usd_unlock_bit;
215 };
216
220 union
221 {
222 __IO uint32_t sts;
223 struct
224 {
225 __IO uint32_t obf : 1; /* [0] */
226 __IO uint32_t reserved1 : 1; /* [1] */
227 __IO uint32_t prgmerr : 1; /* [2] */
228 __IO uint32_t reserved2 : 1; /* [3] */
229 __IO uint32_t epperr : 1; /* [4] */
230 __IO uint32_t odf : 1; /* [5] */
231 __IO uint32_t reserved3 : 26;/* [31:6] */
232 } sts_bit;
233 };
234
238 union
239 {
240 __IO uint32_t ctrl;
241 struct
242 {
243 __IO uint32_t fprgm : 1; /* [0] */
244 __IO uint32_t secers : 1; /* [1] */
245 __IO uint32_t bankers : 1; /* [2] */
246 __IO uint32_t reserved1 : 1; /* [3] */
247 __IO uint32_t usdprgm : 1; /* [4] */
248 __IO uint32_t usders : 1; /* [5] */
249 __IO uint32_t erstr : 1; /* [6] */
250 __IO uint32_t oplk : 1; /* [7] */
251 __IO uint32_t reserved2 : 1; /* [8] */
252 __IO uint32_t usdulks : 1; /* [9] */
253 __IO uint32_t errie : 1; /* [10] */
254 __IO uint32_t reserved3 : 1; /* [11] */
255 __IO uint32_t odfie : 1; /* [12] */
256 __IO uint32_t reserved4 : 19;/* [31:13] */
257 } ctrl_bit;
258 };
259
263 union
264 {
265 __IO uint32_t addr;
266 struct
267 {
268 __IO uint32_t fa : 32;/* [31:0] */
269 } addr_bit;
270 };
271
275 __IO uint32_t reserved1;
276
280 union
281 {
282 __IO uint32_t usd;
283 struct
284 {
285 __IO uint32_t usderr : 1; /* [0] */
286 __IO uint32_t fap : 1; /* [1] */
287 __IO uint32_t wdt_ato_en : 1; /* [2] */
288 __IO uint32_t depslp_rst : 1; /* [3] */
289 __IO uint32_t stdby_rst : 1; /* [4] */
290 __IO uint32_t reserved1 : 5; /* [9:5] */
291 __IO uint32_t user_d0 : 8; /* [17:10] */
292 __IO uint32_t user_d1 : 8; /* [25:18] */
293 __IO uint32_t reserved2 : 6; /* [31:26] */
294 } usd_bit;
295 };
296
300 union
301 {
302 __IO uint32_t epps;
303 struct
304 {
305 __IO uint32_t epps : 32;/* [31:0] */
306 } epps_bit;
307 };
308
312 __IO uint32_t reserved2[24];
313
317 union
318 {
319 __IO uint32_t unlock3;
320 struct
321 {
322 __IO uint32_t ukval : 32;/* [31:0] */
323 } unlock3_bit;
324 };
325
329 union
330 {
331 __IO uint32_t select;
332 struct
333 {
334 __IO uint32_t select : 32;/* [31:0] */
335 } select_bit;
336 };
337
341 union
342 {
343 __IO uint32_t sts3;
344 struct
345 {
346 __IO uint32_t obf : 1; /* [0] */
347 __IO uint32_t reserved1 : 1; /* [1] */
348 __IO uint32_t prgmerr : 1; /* [2] */
349 __IO uint32_t reserved2 : 1; /* [3] */
350 __IO uint32_t epperr : 1; /* [4] */
351 __IO uint32_t odf : 1; /* [5] */
352 __IO uint32_t reserved3 : 26;/* [31:6] */
353 } sts3_bit;
354 };
355
359 union
360 {
361 __IO uint32_t ctrl3;
362 struct
363 {
364 __IO uint32_t fprgm : 1; /* [0] */
365 __IO uint32_t secers : 1; /* [1] */
366 __IO uint32_t chpers : 1; /* [2] */
367 __IO uint32_t reserved1 : 3; /* [5:3] */
368 __IO uint32_t erstr : 1; /* [6] */
369 __IO uint32_t oplk : 1; /* [7] */
370 __IO uint32_t reserved2 : 2; /* [9:8] */
371 __IO uint32_t errie : 1; /* [10] */
372 __IO uint32_t reserved3 : 1; /* [11] */
373 __IO uint32_t odfie : 1; /* [12] */
374 __IO uint32_t reserved4 : 19;/* [31:13] */
375 } ctrl3_bit;
376 };
377
381 union
382 {
383 __IO uint32_t addr3;
384 struct
385 {
386 __IO uint32_t fa : 32;/* [31:0] */
387 } addr3_bit;
388 };
389
393 union
394 {
395 __IO uint32_t da;
396 struct
397 {
398 __IO uint32_t fda : 32;/* [31:0] */
399 } da_bit;
400 };
401
405 __IO uint32_t reserved5[12];
406
410 union
411 {
412 __IO uint32_t slib_sts0;
413 struct
414 {
415 __IO uint32_t reserved1 : 3; /* [2:0] */
416 __IO uint32_t slib_enf : 1; /* [3] */
417 __IO uint32_t reserved2 : 28;/* [31:4] */
418 } slib_sts0_bit;
419 };
420
424 union
425 {
426 __IO uint32_t slib_sts1;
427 struct
428 {
429 __IO uint32_t slib_ss : 11;/* [10:0] */
430 __IO uint32_t slib_dat_ss : 11;/* [21:11] */
431 __IO uint32_t slib_es : 10;/* [31:22] */
432 } slib_sts1_bit;
433 };
434
438 union
439 {
440 __IO uint32_t slib_pwd_clr;
441 struct
442 {
443 __IO uint32_t slib_pclr_val : 32;/* [31:0] */
444 } slib_pwd_clr_bit;
445 };
446
450 union
451 {
452 __IO uint32_t slib_misc_sts;
453 struct
454 {
455 __IO uint32_t slib_pwd_err : 1; /* [0] */
456 __IO uint32_t slib_pwd_ok : 1; /* [1] */
457 __IO uint32_t slib_ulkf : 1; /* [2] */
458 __IO uint32_t reserved1 : 13;/* [15:3] */
459 __IO uint32_t slib_rcnt : 9; /* [24:16] */
460 __IO uint32_t reserved2 : 7; /* [31:25] */
461 } slib_misc_sts_bit;
462 };
463
467 union
468 {
469 __IO uint32_t slib_set_pwd;
470 struct
471 {
472 __IO uint32_t slib_pset_val : 32;/* [31:0] */
473 } slib_set_pwd_bit;
474 };
475
479 union
480 {
481 __IO uint32_t slib_set_range;
482 struct
483 {
484 __IO uint32_t slib_ss_set : 11;/* [10:0] */
485 __IO uint32_t slib_dss_set : 11;/* [21:11] */
486 __IO uint32_t slib_es_set : 10;/* [31:22] */
487 } slib_set_range_bit;
488 };
489
493 __IO uint32_t reserved6[3];
494
498 union
499 {
500 __IO uint32_t slib_unlock;
501 struct
502 {
503 __IO uint32_t slib_ukval : 32;/* [31:0] */
504 } slib_unlock_bit;
505 };
506
510 union
511 {
512 __IO uint32_t crc_ctrl;
513 struct
514 {
515 __IO uint32_t crc_ss : 12;/* [11:0] */
516 __IO uint32_t crc_sn : 12;/* [23:12] */
517 __IO uint32_t reserved1 : 7; /* [30:24] */
518 __IO uint32_t crc_strt : 1; /* [31] */
519 } crc_ctrl_bit;
520 };
521
525 union
526 {
527 __IO uint32_t crc_chkr;
528 struct
529 {
530 __IO uint32_t crc_chkr : 32;/* [31:0] */
531 } crc_chkr_bit;
532 };
533
534} flash_type;
535
539typedef struct
540{
541 __IO uint16_t fap;
542 __IO uint16_t ssb;
543 __IO uint16_t data0;
544 __IO uint16_t data1;
545 __IO uint16_t epp0;
546 __IO uint16_t epp1;
547 __IO uint16_t epp2;
548 __IO uint16_t epp3;
549 __IO uint16_t eopb0;
550 __IO uint16_t reserved;
551 __IO uint16_t data2;
552 __IO uint16_t data3;
553 __IO uint16_t data4;
554 __IO uint16_t data5;
555 __IO uint16_t data6;
556 __IO uint16_t data7;
557 __IO uint16_t ext_flash_key[8];
558} usd_type;
559
564#define FLASH ((flash_type *) FLASH_REG_BASE)
565#define USD ((usd_type *) USD_BASE)
566
571 flag_status flash_flag_get(uint32_t flash_flag);
572void flash_flag_clear(uint32_t flash_flag);
573 flash_status_type flash_operation_status_get(void);
574 flash_status_type flash_spim_operation_status_get(void);
575 flash_status_type flash_operation_wait_for(uint32_t time_out);
576 flash_status_type flash_spim_operation_wait_for(uint32_t time_out);
577void flash_unlock(void);
578void flash_spim_unlock(void);
579void flash_lock(void);
580void flash_spim_lock(void);
581 flash_status_type flash_sector_erase(uint32_t sector_address);
582 flash_status_type flash_internal_all_erase(void);
583 flash_status_type flash_spim_all_erase(void);
584 flash_status_type flash_user_system_data_erase(void);
585 flash_status_type flash_word_program(uint32_t address, uint32_t data);
586 flash_status_type flash_halfword_program(uint32_t address, uint16_t data);
587 flash_status_type flash_byte_program(uint32_t address, uint8_t data);
588 flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data);
589 flash_status_type flash_epp_set(uint32_t *sector_bits);
590void flash_epp_status_get(uint32_t *sector_bits);
591 flash_status_type flash_fap_enable(confirm_state new_state);
592 flag_status flash_fap_status_get(void);
593 flash_status_type flash_ssb_set(uint8_t usd_ssb);
594uint8_t flash_ssb_status_get(void);
595void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state);
596void flash_spim_model_select(flash_spim_model_type mode);
597void flash_spim_encryption_range_set(uint32_t decode_address);
598 flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector);
599 error_status flash_slib_disable(uint32_t pwd);
600uint32_t flash_slib_remaining_count_get(void);
601 flag_status flash_slib_state_get(void);
602uint16_t flash_slib_start_sector_get(void);
603uint16_t flash_slib_datstart_sector_get(void);
604uint16_t flash_slib_end_sector_get(void);
605uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt);
606
619#ifdef __cplusplus
620}
621#endif
622
623#endif
at32f413.h
at32f413 header file
error_status
error_status
error status
Definition: at32f413.h:264
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
flash_slib_state_get
flag_status flash_slib_state_get(void)
get the slib state.
Definition: at32f413_flash.c:891
flash_slib_enable
flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function.
Definition: at32f413_flash.c:824
flash_fap_status_get
flag_status flash_fap_status_get(void)
check the flash access protection status.
Definition: at32f413_flash.c:707
flash_slib_remaining_count_get
uint32_t flash_slib_remaining_count_get(void)
get remaining count of slib(range: 256~0).
Definition: at32f413_flash.c:881
flash_slib_disable
error_status flash_slib_disable(uint32_t pwd)
disable slib when slib enabled.
Definition: at32f413_flash.c:859
flash_slib_datstart_sector_get
uint16_t flash_slib_datstart_sector_get(void)
get the data start sector of slib.
Definition: at32f413_flash.c:914
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f413_flash.c:485
flash_user_system_data_program
flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
program a halfword at a specified user system data address.
Definition: at32f413_flash.c:560
flash_spim_lock
void flash_spim_lock(void)
lock the flash spim controller.
Definition: at32f413_flash.c:261
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:533
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_spim_unlock
void flash_spim_unlock(void)
unlock the flash spim controller.
Definition: at32f413_flash.c:240
flash_operation_status_get
flash_status_type flash_operation_status_get(void)
return the flash operation status.
Definition: at32f413_flash.c:122
flash_epp_set
flash_status_type flash_epp_set(uint32_t *sector_bits)
config erase/program protection for the desired sectors.
Definition: at32f413_flash.c:594
flash_spim_model_select
void flash_spim_model_select(flash_spim_model_type mode)
select spim supports extended spi flash chip model.
Definition: at32f413_flash.c:798
flash_ssb_set
flash_status_type flash_ssb_set(uint8_t usd_ssb)
program the flash system setting byte in usd: wdt_ato_en / depslp_rst / stdby_rst.
Definition: at32f413_flash.c:731
flash_crc_calibrate
uint32_t flash_crc_calibrate(uint32_t start_sector, uint32_t sector_cnt)
flash crc calibration in main block.
Definition: at32f413_flash.c:935
flash_spim_operation_wait_for
flash_status_type flash_spim_operation_wait_for(uint32_t time_out)
wait for flash spim operation complete or timeout.
Definition: at32f413_flash.c:205
flash_slib_start_sector_get
uint16_t flash_slib_start_sector_get(void)
get the start sector of slib.
Definition: at32f413_flash.c:904
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f413_flash.c:781
flash_fap_enable
flash_status_type flash_fap_enable(confirm_state new_state)
enable or disable the flash access protection.
Definition: at32f413_flash.c:663
flash_slib_end_sector_get
uint16_t flash_slib_end_sector_get(void)
get the end sector of slib.
Definition: at32f413_flash.c:924
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
flash_spim_encryption_range_set
void flash_spim_encryption_range_set(uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value,...
Definition: at32f413_flash.c:810
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:59
flash_spim_operation_status_get
flash_status_type flash_spim_operation_status_get(void)
return the flash spim operation status.
Definition: at32f413_flash.c:151
flash_user_system_data_erase
flash_status_type flash_user_system_data_erase(void)
erase the flash user system data.
Definition: at32f413_flash.c:382
flash_internal_all_erase
flash_status_type flash_internal_all_erase(void)
erase flash all internal sectors.
Definition: at32f413_flash.c:325
flash_operation_wait_for
flash_status_type flash_operation_wait_for(uint32_t time_out)
wait for flash operation complete or timeout.
Definition: at32f413_flash.c:180
flash_ssb_status_get
uint8_t flash_ssb_status_get(void)
return the flash system setting byte status.
Definition: at32f413_flash.c:763
flash_epp_status_get
void flash_epp_status_get(uint32_t *sector_bits)
return the flash erase/program protection status.
Definition: at32f413_flash.c:648
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:98
flash_spim_all_erase
flash_status_type flash_spim_all_erase(void)
erase flash spim sectors.
Definition: at32f413_flash.c:353
flash_spim_model_type
flash_spim_model_type
flash spim model type
Definition: at32f413_flash.h:171
flash_status_type
flash_status_type
flash status type
Definition: at32f413_flash.h:159
FLASH_SPIM_MODEL1
@ FLASH_SPIM_MODEL1
Definition: at32f413_flash.h:172
FLASH_SPIM_MODEL2
@ FLASH_SPIM_MODEL2
Definition: at32f413_flash.h:173
FLASH_OPERATE_BUSY
@ FLASH_OPERATE_BUSY
Definition: at32f413_flash.h:160
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f413_flash.h:163
FLASH_OPERATE_TIMEOUT
@ FLASH_OPERATE_TIMEOUT
Definition: at32f413_flash.h:164
FLASH_PROGRAM_ERROR
@ FLASH_PROGRAM_ERROR
Definition: at32f413_flash.h:161
FLASH_EPP_ERROR
@ FLASH_EPP_ERROR
Definition: at32f413_flash.h:162
flash_type
type define flash register all
Definition: at32f413_flash.h:180
flash_type::secers
__IO uint32_t secers
Definition: at32f413_flash.h:244
flash_type::unlock
__IO uint32_t unlock
Definition: at32f413_flash.h:198
flash_type::reserved2
__IO uint32_t reserved2
flash reserved2 register, offset:0x80~0x24
Definition: at32f413_flash.h:228
flash_type::crc_sn
__IO uint32_t crc_sn
Definition: at32f413_flash.h:516
flash_type::psr
__IO uint32_t psr
Definition: at32f413_flash.h:186
flash_type::user_d0
__IO uint32_t user_d0
Definition: at32f413_flash.h:291
flash_type::unlock3
__IO uint32_t unlock3
Definition: at32f413_flash.h:319
flash_type::slib_set_pwd
__IO uint32_t slib_set_pwd
Definition: at32f413_flash.h:469
flash_type::slib_pwd_err
__IO uint32_t slib_pwd_err
Definition: at32f413_flash.h:455
flash_type::ukval
__IO uint32_t ukval
Definition: at32f413_flash.h:201
flash_type::slib_ukval
__IO uint32_t slib_ukval
Definition: at32f413_flash.h:503
flash_type::bankers
__IO uint32_t bankers
Definition: at32f413_flash.h:245
flash_type::slib_set_range
__IO uint32_t slib_set_range
Definition: at32f413_flash.h:481
flash_type::usd_ukval
__IO uint32_t usd_ukval
Definition: at32f413_flash.h:213
flash_type::select
__IO uint32_t select
Definition: at32f413_flash.h:331
flash_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_flash.h:240
flash_type::slib_rcnt
__IO uint32_t slib_rcnt
Definition: at32f413_flash.h:459
flash_type::stdby_rst
__IO uint32_t stdby_rst
Definition: at32f413_flash.h:289
flash_type::crc_strt
__IO uint32_t crc_strt
Definition: at32f413_flash.h:518
flash_type::slib_dat_ss
__IO uint32_t slib_dat_ss
Definition: at32f413_flash.h:430
flash_type::epps
__IO uint32_t epps
Definition: at32f413_flash.h:302
flash_type::fprgm
__IO uint32_t fprgm
Definition: at32f413_flash.h:243
flash_type::reserved1
__IO uint32_t reserved1
flash reserved1 register, offset:0x18
Definition: at32f413_flash.h:189
flash_type::slib_sts1
__IO uint32_t slib_sts1
Definition: at32f413_flash.h:426
flash_type::erstr
__IO uint32_t erstr
Definition: at32f413_flash.h:249
flash_type::usderr
__IO uint32_t usderr
Definition: at32f413_flash.h:285
flash_type::crc_ss
__IO uint32_t crc_ss
Definition: at32f413_flash.h:515
flash_type::crc_chkr
__IO uint32_t crc_chkr
Definition: at32f413_flash.h:527
flash_type::slib_misc_sts
__IO uint32_t slib_misc_sts
Definition: at32f413_flash.h:452
flash_type::usdulks
__IO uint32_t usdulks
Definition: at32f413_flash.h:252
flash_type::slib_pclr_val
__IO uint32_t slib_pclr_val
Definition: at32f413_flash.h:443
flash_type::slib_ulkf
__IO uint32_t slib_ulkf
Definition: at32f413_flash.h:457
flash_type::epperr
__IO uint32_t epperr
Definition: at32f413_flash.h:229
flash_type::ctrl3
__IO uint32_t ctrl3
Definition: at32f413_flash.h:361
flash_type::odfie
__IO uint32_t odfie
Definition: at32f413_flash.h:255
flash_type::fda
__IO uint32_t fda
Definition: at32f413_flash.h:398
flash_type::slib_ss
__IO uint32_t slib_ss
Definition: at32f413_flash.h:429
flash_type::da
__IO uint32_t da
Definition: at32f413_flash.h:395
flash_type::fa
__IO uint32_t fa
Definition: at32f413_flash.h:268
flash_type::slib_es
__IO uint32_t slib_es
Definition: at32f413_flash.h:431
flash_type::slib_ss_set
__IO uint32_t slib_ss_set
Definition: at32f413_flash.h:484
flash_type::prgmerr
__IO uint32_t prgmerr
Definition: at32f413_flash.h:227
flash_type::slib_unlock
__IO uint32_t slib_unlock
Definition: at32f413_flash.h:500
flash_type::errie
__IO uint32_t errie
Definition: at32f413_flash.h:253
flash_type::user_d1
__IO uint32_t user_d1
Definition: at32f413_flash.h:292
flash_type::chpers
__IO uint32_t chpers
Definition: at32f413_flash.h:366
flash_type::usd
__IO uint32_t usd
Definition: at32f413_flash.h:282
flash_type::depslp_rst
__IO uint32_t depslp_rst
Definition: at32f413_flash.h:288
flash_type::slib_pwd_clr
__IO uint32_t slib_pwd_clr
Definition: at32f413_flash.h:440
flash_type::usd_unlock
__IO uint32_t usd_unlock
Definition: at32f413_flash.h:210
flash_type::wdt_ato_en
__IO uint32_t wdt_ato_en
Definition: at32f413_flash.h:287
flash_type::usdprgm
__IO uint32_t usdprgm
Definition: at32f413_flash.h:247
flash_type::slib_pwd_ok
__IO uint32_t slib_pwd_ok
Definition: at32f413_flash.h:456
flash_type::sts3
__IO uint32_t sts3
Definition: at32f413_flash.h:343
flash_type::slib_es_set
__IO uint32_t slib_es_set
Definition: at32f413_flash.h:486
flash_type::usders
__IO uint32_t usders
Definition: at32f413_flash.h:248
flash_type::oplk
__IO uint32_t oplk
Definition: at32f413_flash.h:250
flash_type::addr
__IO uint32_t addr
Definition: at32f413_flash.h:265
flash_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_flash.h:256
flash_type::slib_dss_set
__IO uint32_t slib_dss_set
Definition: at32f413_flash.h:485
flash_type::slib_sts0
__IO uint32_t slib_sts0
Definition: at32f413_flash.h:412
flash_type::odf
__IO uint32_t odf
Definition: at32f413_flash.h:230
flash_type::addr3
__IO uint32_t addr3
Definition: at32f413_flash.h:383
flash_type::fap
__IO uint32_t fap
Definition: at32f413_flash.h:286
flash_type::crc_ctrl
__IO uint32_t crc_ctrl
Definition: at32f413_flash.h:512
flash_type::sts
__IO uint32_t sts
Definition: at32f413_flash.h:222
flash_type::slib_pset_val
__IO uint32_t slib_pset_val
Definition: at32f413_flash.h:472
flash_type::slib_enf
__IO uint32_t slib_enf
Definition: at32f413_flash.h:416
flash_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_flash.h:231
flash_type::obf
__IO uint32_t obf
Definition: at32f413_flash.h:225
usd_type
user system data
Definition: at32f413_flash.h:540
usd_type::eopb0
__IO uint16_t eopb0
Definition: at32f413_flash.h:549
usd_type::epp2
__IO uint16_t epp2
Definition: at32f413_flash.h:547
usd_type::data7
__IO uint16_t data7
Definition: at32f413_flash.h:556
usd_type::reserved
__IO uint16_t reserved
Definition: at32f413_flash.h:550
usd_type::epp0
__IO uint16_t epp0
Definition: at32f413_flash.h:545
usd_type::data3
__IO uint16_t data3
Definition: at32f413_flash.h:552
usd_type::epp3
__IO uint16_t epp3
Definition: at32f413_flash.h:548
usd_type::data6
__IO uint16_t data6
Definition: at32f413_flash.h:555
usd_type::data2
__IO uint16_t data2
Definition: at32f413_flash.h:551
usd_type::data1
__IO uint16_t data1
Definition: at32f413_flash.h:544
usd_type::ssb
__IO uint16_t ssb
Definition: at32f413_flash.h:542
usd_type::fap
__IO uint16_t fap
Definition: at32f413_flash.h:541
usd_type::epp1
__IO uint16_t epp1
Definition: at32f413_flash.h:546
usd_type::data0
__IO uint16_t data0
Definition: at32f413_flash.h:543
usd_type::data4
__IO uint16_t data4
Definition: at32f413_flash.h:553
usd_type::data5
__IO uint16_t data5
Definition: at32f413_flash.h:554


AT32F413 Firmwary Library: at32f413_gpio.c Source File

  • libraries
  • drivers
  • src
at32f413_gpio.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef GPIO_MODULE_ENABLED
39
51void gpio_reset(gpio_type *gpio_x)
52{
53 if(gpio_x == GPIOA)
54 {
55 crm_periph_reset(CRM_GPIOA_PERIPH_RESET, TRUE);
56 crm_periph_reset(CRM_GPIOA_PERIPH_RESET, FALSE);
57 }
58 else if(gpio_x == GPIOB)
59 {
60 crm_periph_reset(CRM_GPIOB_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_GPIOB_PERIPH_RESET, FALSE);
62 }
63 else if(gpio_x == GPIOC)
64 {
65 crm_periph_reset(CRM_GPIOC_PERIPH_RESET, TRUE);
66 crm_periph_reset(CRM_GPIOC_PERIPH_RESET, FALSE);
67 }
68 else if(gpio_x == GPIOD)
69 {
70 crm_periph_reset(CRM_GPIOD_PERIPH_RESET, TRUE);
71 crm_periph_reset(CRM_GPIOD_PERIPH_RESET, FALSE);
72 }
73 else if(gpio_x == GPIOF)
74 {
75 crm_periph_reset(CRM_GPIOF_PERIPH_RESET, TRUE);
76 crm_periph_reset(CRM_GPIOF_PERIPH_RESET, FALSE);
77 }
78}
79
86void gpio_iomux_reset(void)
87{
88 crm_periph_reset(CRM_IOMUX_PERIPH_RESET, TRUE);
89 crm_periph_reset(CRM_IOMUX_PERIPH_RESET, FALSE);
90}
91
100void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
101{
102 uint32_t temp;
103 uint16_t pinx_value, pin_index;
104
105 pin_index = (uint16_t)gpio_init_struct->gpio_pins;
106
107 /* pinx_value indecate pin grounp bit[3:0] from modey[1:0] confy[1:0] */
108
109 /* pin input analog config */
110 if(gpio_init_struct->gpio_mode == GPIO_MODE_ANALOG)
111 {
112 pinx_value = 0x00;
113 }
114 /* pin input config */
115 else if(gpio_init_struct->gpio_mode == GPIO_MODE_INPUT)
116 {
117 pinx_value = gpio_init_struct->gpio_pull & 0x0F;
118
119 if(gpio_init_struct->gpio_pull == GPIO_PULL_UP)
120 {
121 gpio_x->scr = pin_index;
122 }
123 else if(gpio_init_struct->gpio_pull == GPIO_PULL_DOWN)
124 {
125 gpio_x->clr = pin_index;
126 }
127 }
128 else
129 {
130 pinx_value = (gpio_init_struct->gpio_mode & 0x08) | (gpio_init_struct->gpio_out_type & 0x04) | \
131 (gpio_init_struct->gpio_drive_strength & 0x03);
132 }
133
134 /* pin 0~7 config */
135 if(((uint32_t)pin_index & ((uint32_t)0x00FF)) != 0x00)
136 {
137 for(temp = 0; temp < 0x08; temp++)
138 {
139 if((1 << temp) & pin_index)
140 {
141 gpio_x->cfglr &= (uint32_t)~(0x0F << (temp * 4));
142 gpio_x->cfglr |= (uint32_t)(pinx_value << (temp * 4));
143 }
144 }
145 }
146
147 /* pin 8~15 config */
148 if(pin_index > 0x00ff)
149 {
150 pin_index = pin_index >> 8;
151
152 for(temp = 0; temp < 0x8; temp++)
153 {
154 if((1 << temp) & pin_index)
155 {
156 gpio_x->cfghr &= (uint32_t)~(0xf << (temp * 4));
157 gpio_x->cfghr |= (uint32_t)(pinx_value << (temp * 4));
158 }
159 }
160 }
161}
162
168void gpio_default_para_init(gpio_init_type *gpio_init_struct)
169{
170 /* reset gpio init structure parameters values */
171 gpio_init_struct->gpio_pins = GPIO_PINS_ALL;
172 gpio_init_struct->gpio_mode = GPIO_MODE_INPUT;
173 gpio_init_struct->gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
174 gpio_init_struct->gpio_pull = GPIO_PULL_NONE;
175 gpio_init_struct->gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
176}
177
203 flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
204{
205 flag_status status = RESET;
206
207 if(pins != (pins & gpio_x->idt))
208 {
209 status = RESET;
210 }
211 else
212 {
213 status = SET;
214 }
215
216 return status;
217}
218
226uint16_t gpio_input_data_read(gpio_type *gpio_x)
227{
228 return ((uint16_t)(gpio_x->idt));
229}
230
256 flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
257{
258 flag_status status = RESET;
259
260 if((gpio_x->odt & pins) != RESET)
261 {
262 status = SET;
263 }
264 else
265 {
266 status = RESET;
267 }
268
269 return status;
270}
271
279uint16_t gpio_output_data_read(gpio_type *gpio_x)
280{
281 return ((uint16_t)(gpio_x->odt));
282}
283
310void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
311{
312 gpio_x->scr = pins;
313}
314
341void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
342{
343 gpio_x->clr = pins;
344}
345
373void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
374{
375 if(bit_state != FALSE)
376 {
377 gpio_x->scr = pins;
378 }
379 else
380 {
381 gpio_x->clr = pins;
382 }
383}
384
393void gpio_port_wirte(gpio_type *gpio_x, uint16_t port_value)
394{
395 gpio_x->odt = port_value;
396}
397
424void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins)
425{
426 uint32_t temp = 0x00010000;
427
428 temp |= pins;
429 /* set wpen bit */
430 gpio_x->wpr = temp;
431 /* reset wpen bit */
432 gpio_x->wpr = pins;
433 /* set wpen bit */
434 gpio_x->wpr = temp;
435 /* read wpen bit*/
436 temp = gpio_x->wpr;
437 /* read wpen bit*/
438 temp = gpio_x->wpr;
439}
440
471void gpio_event_output_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
472{
473 uint32_t tmpreg = 0x00;
474
475 tmpreg = IOMUX->evtout;
476
477 /* clear the port[6:4] and pin[3:0] bits */
478 tmpreg &= 0x80;
479 tmpreg |= (uint32_t)gpio_port_source << 0x04;
480 tmpreg |= gpio_pin_source;
481 IOMUX->evtout = tmpreg;
482}
483
490void gpio_event_output_enable(confirm_state new_state)
491{
492 IOMUX->evtout_bit.evoen = new_state;
493}
494
517void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
518{
519 uint32_t reg_addr, remap_mask;
520 uint8_t bit_offset, bit_num, bit_val;
521
522 /* get register address, bit offset, bit number and remap value */
523 reg_addr = IOMUX_BASE + (gpio_remap >> 24);
524 bit_offset = (gpio_remap >> 16) & 0xFF;
525 bit_num = (gpio_remap >> 8) & 0xFF;
526 bit_val = gpio_remap & 0xFF;
527
528 /* get remap mask value */
529 remap_mask = 0xFFFFFFFF << (32 - bit_num - bit_offset);
530 remap_mask = remap_mask >> (32 - bit_num - bit_offset);
531 remap_mask = remap_mask >> bit_offset;
532 remap_mask = remap_mask << bit_offset;
533
534 /* clear remap value */
535 *(uint32_t*)reg_addr &= ~remap_mask;
536
537 if(new_state != FALSE)
538 {
539 /* set remap value */
540 *(uint32_t*)reg_addr |= (uint32_t)(bit_val << bit_offset);
541 }
542}
543
573void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
574{
575 uint32_t tmp = 0x00;
576 tmp = ((uint32_t)0x0F) << (0x04 * (gpio_pin_source & (uint8_t)0x03));
577
578 switch (gpio_pin_source >> 0x02)
579 {
580 case 0:
581 IOMUX->exintc1 &= ~tmp;
582 IOMUX->exintc1 |= (((uint32_t)gpio_port_source) << (0x04 * (gpio_pin_source & (uint8_t)0x03)));
583 break;
584 case 1:
585 IOMUX->exintc2 &= ~tmp;
586 IOMUX->exintc2 |= (((uint32_t)gpio_port_source) << (0x04 * (gpio_pin_source & (uint8_t)0x03)));
587 break;
588 case 2:
589 IOMUX->exintc3 &= ~tmp;
590 IOMUX->exintc3 |= (((uint32_t)gpio_port_source) << (0x04 * (gpio_pin_source & (uint8_t)0x03)));
591 break;
592 case 3:
593 IOMUX->exintc4 &= ~tmp;
594 IOMUX->exintc4 |= (((uint32_t)gpio_port_source) << (0x04 * (gpio_pin_source & (uint8_t)0x03)));
595 break;
596 default:
597 break;
598 }
599}
600
605#endif
606
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
CRM_IOMUX_PERIPH_RESET
@ CRM_IOMUX_PERIPH_RESET
Definition: at32f413_crm.h:152
CRM_GPIOF_PERIPH_RESET
@ CRM_GPIOF_PERIPH_RESET
Definition: at32f413_crm.h:158
CRM_GPIOD_PERIPH_RESET
@ CRM_GPIOD_PERIPH_RESET
Definition: at32f413_crm.h:157
CRM_GPIOC_PERIPH_RESET
@ CRM_GPIOC_PERIPH_RESET
Definition: at32f413_crm.h:156
CRM_GPIOA_PERIPH_RESET
@ CRM_GPIOA_PERIPH_RESET
Definition: at32f413_crm.h:154
CRM_GPIOB_PERIPH_RESET
@ CRM_GPIOB_PERIPH_RESET
Definition: at32f413_crm.h:155
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
gpio_pins_source_type
gpio_pins_source_type
gpio pins source type
Definition: at32f413_gpio.h:253
gpio_port_source_type
gpio_port_source_type
gpio port source type
Definition: at32f413_gpio.h:276
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:217
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_ALL
#define GPIO_PINS_ALL
Definition: at32f413_gpio.h:67
gpio_iomux_reset
void gpio_iomux_reset(void)
reset the mux functions (remap, event control and exint configuration) registers to their default val...
Definition: at32f413_gpio.c:86
gpio_output_data_read
uint16_t gpio_output_data_read(gpio_type *gpio_x)
read the specified gpio ouput data port.
Definition: at32f413_gpio.c:279
gpio_event_output_config
void gpio_event_output_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output.
Definition: at32f413_gpio.c:471
gpio_output_data_bit_read
flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified output port pin.
Definition: at32f413_gpio.c:256
gpio_bits_write
void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit.
Definition: at32f413_gpio.c:373
gpio_event_output_enable
void gpio_event_output_enable(confirm_state new_state)
enable or disable the event output.
Definition: at32f413_gpio.c:490
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:341
gpio_input_data_read
uint16_t gpio_input_data_read(gpio_type *gpio_x)
read the specified gpio input data port.
Definition: at32f413_gpio.c:226
gpio_pin_wp_config
void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers.
Definition: at32f413_gpio.c:424
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:203
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:310
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:573
gpio_reset
void gpio_reset(gpio_type *gpio_x)
reset the gpio register
Definition: at32f413_gpio.c:51
gpio_port_wirte
void gpio_port_wirte(gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port.
Definition: at32f413_gpio.c:393
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
GPIOF
#define GPIOF
Definition: at32f413_gpio.h:752
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOD
#define GPIOD
Definition: at32f413_gpio.h:751
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
IOMUX
#define IOMUX
Definition: at32f413_gpio.h:753
IOMUX_BASE
#define IOMUX_BASE
Definition: at32f413.h:324
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
gpio_type
type define gpio register all
Definition: at32f413_gpio.h:300
gpio_type::scr
__IO uint32_t scr
Definition: at32f413_gpio.h:416
gpio_type::odt
__IO uint32_t odt
Definition: at32f413_gpio.h:388
gpio_type::clr
__IO uint32_t clr
Definition: at32f413_gpio.h:459
gpio_type::cfghr
__IO uint32_t cfghr
Definition: at32f413_gpio.h:333
gpio_type::cfglr
__IO uint32_t cfglr
Definition: at32f413_gpio.h:306
gpio_type::idt
__IO uint32_t idt
Definition: at32f413_gpio.h:360
gpio_type::wpr
__IO uint32_t wpr
Definition: at32f413_gpio.h:487
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_gpio.h Source File

  • libraries
  • drivers
  • inc
at32f413_gpio.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_GPIO_H
29#define __AT32F413_GPIO_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
51#define GPIO_PINS_0 0x0001
52#define GPIO_PINS_1 0x0002
53#define GPIO_PINS_2 0x0004
54#define GPIO_PINS_3 0x0008
55#define GPIO_PINS_4 0x0010
56#define GPIO_PINS_5 0x0020
57#define GPIO_PINS_6 0x0040
58#define GPIO_PINS_7 0x0080
59#define GPIO_PINS_8 0x0100
60#define GPIO_PINS_9 0x0200
61#define GPIO_PINS_10 0x0400
62#define GPIO_PINS_11 0x0800
63#define GPIO_PINS_12 0x1000
64#define GPIO_PINS_13 0x2000
65#define GPIO_PINS_14 0x4000
66#define GPIO_PINS_15 0x8000
67#define GPIO_PINS_ALL 0xFFFF
73#define IOMUX_MAKE_VALUE(reg_offset, bit_addr ,bit_num, bit_val) \
74 (uint32_t)(((reg_offset) << 24) | ((bit_addr) << 16) | ((bit_num) << 8) | (bit_val))
75
81#define SPI1_MUX_01 SPI1_GMUX_0001
82#define I2C1_MUX I2C1_GMUX_0001
83#define USART1_MUX USART1_GMUX_0001
84#define USART3_MUX_01 USART3_GMUX_0001
85#define TMR1_MUX_01 TMR1_GMUX_0001
86#define TMR2_MUX_01 TMR2_GMUX_001
87#define TMR2_MUX_10 TMR2_GMUX_010
88#define TMR2_MUX_11 TMR2_GMUX_011
89#define TMR3_MUX_10 TMR3_GMUX_0010
90#define TMR3_MUX_11 TMR3_GMUX_0011
91#define CAN_MUX_10 CAN1_GMUX_0010
92#define PD01_MUX PD01_GMUX
93#define TMR5CH4_MUX TMR5CH4_GMUX
94#define ADC1_ETP_MUX ADC1_ETP_GMUX
95#define ADC1_ETO_MUX ADC1_ETO_GMUX
96#define ADC2_ETP_MUX ADC2_ETP_GMUX
97#define ADC2_ETO_MUX ADC2_ETO_GMUX
98#define SWJTAG_CONF_001 SWJTAG_GMUX_001
99#define SWJTAG_CONF_010 SWJTAG_GMUX_010
100#define SWJTAG_CONF_100 SWJTAG_GMUX_100
111#define EXT_SPIM_EN_MUX EXT_SPIM_GMUX_1000
122#define TMR9_GMUX IOMUX_MAKE_VALUE(0x20, 0, 4, 0x02)
123#define TMR10_GMUX IOMUX_MAKE_VALUE(0x20, 4, 4, 0x02)
124#define TMR11_GMUX IOMUX_MAKE_VALUE(0x20, 8, 4, 0x02)
135#define TMR1_GMUX_0001 IOMUX_MAKE_VALUE(0x24, 0, 4, 0x01)
136#define TMR2_GMUX_001 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x01)
137#define TMR2_GMUX_010 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x02)
138#define TMR2_GMUX_011 IOMUX_MAKE_VALUE(0x24, 4, 3, 0x03)
139#define TMR2ITR1_GMUX IOMUX_MAKE_VALUE(0x24, 7, 1, 0x01)
140#define TMR3_GMUX_0010 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x02)
141#define TMR3_GMUX_0011 IOMUX_MAKE_VALUE(0x24, 8, 4, 0x03)
142#define TMR5_GMUX_001 IOMUX_MAKE_VALUE(0x24, 16, 3, 0x01)
143#define TMR5CH4_GMUX IOMUX_MAKE_VALUE(0x24, 19, 1, 0x01)
154#define I2C1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x01)
155#define I2C1_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 4, 4, 0x03)
156#define I2C2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
157#define I2C2_GMUX_0010 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
158#define I2C2_GMUX_0011 IOMUX_MAKE_VALUE(0x28, 8, 4, 0x01)
159#define SPI1_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 16, 4, 0x01)
160#define SPI2_GMUX_0001 IOMUX_MAKE_VALUE(0x28, 20, 4, 0x01)
171#define CAN1_GMUX_0010 IOMUX_MAKE_VALUE(0x2C, 0, 4, 0x02)
172#define CAN2_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 4, 4, 0x01)
173#define SDIO1_GMUX_0100 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x04)
174#define SDIO1_GMUX_0101 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x05)
175#define SDIO1_GMUX_0110 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x06)
176#define SDIO1_GMUX_0111 IOMUX_MAKE_VALUE(0x2C, 8, 4, 0x07)
177#define USART1_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 16, 4, 0x01)
178#define USART3_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 24, 4, 0x01)
179#define UART4_GMUX_0001 IOMUX_MAKE_VALUE(0x2C, 28, 4, 0x01)
190#define EXT_SPIM_GMUX_1000 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x08)
191#define EXT_SPIM_GMUX_1001 IOMUX_MAKE_VALUE(0x30, 0, 4, 0x09)
192#define ADC1_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 4, 1, 0x01)
193#define ADC1_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 5, 1, 0x01)
194#define ADC2_ETP_GMUX IOMUX_MAKE_VALUE(0x30, 8, 1, 0x01)
195#define ADC2_ETO_GMUX IOMUX_MAKE_VALUE(0x30, 9, 1, 0x01)
196#define SWJTAG_GMUX_001 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x01)
197#define SWJTAG_GMUX_010 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x02)
198#define SWJTAG_GMUX_100 IOMUX_MAKE_VALUE(0x30, 16, 3, 0x04)
199#define PD01_GMUX IOMUX_MAKE_VALUE(0x30, 20, 1, 0x01)
212typedef enum
213{
214 GPIO_MODE_INPUT = 0x00,
215 GPIO_MODE_OUTPUT = 0x10,
216 GPIO_MODE_MUX = 0x08,
217 GPIO_MODE_ANALOG = 0x03
218} gpio_mode_type;
219
223typedef enum
224{
225 GPIO_DRIVE_STRENGTH_STRONGER = 0x01,
226 GPIO_DRIVE_STRENGTH_MODERATE = 0x02,
227 GPIO_DRIVE_STRENGTH_MAXIMUM = 0x03
228} gpio_drive_type;
229
233typedef enum
234{
235 GPIO_OUTPUT_PUSH_PULL = 0x00,
236 GPIO_OUTPUT_OPEN_DRAIN = 0x04
237} gpio_output_type;
238
242typedef enum
243{
244 GPIO_PULL_NONE = 0x0004,
245 GPIO_PULL_UP = 0x0018,
246 GPIO_PULL_DOWN = 0x0028
247} gpio_pull_type;
248
252typedef enum
253{
254 GPIO_PINS_SOURCE0 = 0x00,
255 GPIO_PINS_SOURCE1 = 0x01,
256 GPIO_PINS_SOURCE2 = 0x02,
257 GPIO_PINS_SOURCE3 = 0x03,
258 GPIO_PINS_SOURCE4 = 0x04,
259 GPIO_PINS_SOURCE5 = 0x05,
260 GPIO_PINS_SOURCE6 = 0x06,
261 GPIO_PINS_SOURCE7 = 0x07,
262 GPIO_PINS_SOURCE8 = 0x08,
263 GPIO_PINS_SOURCE9 = 0x09,
264 GPIO_PINS_SOURCE10 = 0x0A,
265 GPIO_PINS_SOURCE11 = 0x0B,
266 GPIO_PINS_SOURCE12 = 0x0C,
267 GPIO_PINS_SOURCE13 = 0x0D,
268 GPIO_PINS_SOURCE14 = 0x0E,
269 GPIO_PINS_SOURCE15 = 0x0F
270} gpio_pins_source_type;
271
275typedef enum
276{
277 GPIO_PORT_SOURCE_GPIOA = 0x00,
278 GPIO_PORT_SOURCE_GPIOB = 0x01,
279 GPIO_PORT_SOURCE_GPIOC = 0x02,
280 GPIO_PORT_SOURCE_GPIOD = 0x03,
281 GPIO_PORT_SOURCE_GPIOF = 0x05,
282} gpio_port_source_type;
283
287typedef struct
288{
289 uint32_t gpio_pins;
290 gpio_output_type gpio_out_type;
291 gpio_pull_type gpio_pull;
292 gpio_mode_type gpio_mode;
293 gpio_drive_type gpio_drive_strength;
294} gpio_init_type;
295
299typedef struct
300{
304 union
305 {
306 __IO uint32_t cfglr;
307 struct
308 {
309 __IO uint32_t iomc0 : 2; /* [1:0] */
310 __IO uint32_t iofc0 : 2; /* [3:2] */
311 __IO uint32_t iomc1 : 2; /* [5:4] */
312 __IO uint32_t iofc1 : 2; /* [7:6] */
313 __IO uint32_t iomc2 : 2; /* [9:8] */
314 __IO uint32_t iofc2 : 2; /* [11:10] */
315 __IO uint32_t iomc3 : 2; /* [13:12] */
316 __IO uint32_t iofc3 : 2; /* [15:14] */
317 __IO uint32_t iomc4 : 2; /* [17:16] */
318 __IO uint32_t iofc4 : 2; /* [19:18] */
319 __IO uint32_t iomc5 : 2; /* [21:20] */
320 __IO uint32_t iofc5 : 2; /* [23:22] */
321 __IO uint32_t iomc6 : 2; /* [25:24] */
322 __IO uint32_t iofc6 : 2; /* [27:26] */
323 __IO uint32_t iomc7 : 2; /* [29:28] */
324 __IO uint32_t iofc7 : 2; /* [31:30] */
325 } cfglr_bit;
326 };
327
331 union
332 {
333 __IO uint32_t cfghr;
334 struct
335 {
336 __IO uint32_t iomc8 : 2; /* [1:0] */
337 __IO uint32_t iofc8 : 2; /* [3:2] */
338 __IO uint32_t iomc9 : 2; /* [5:4] */
339 __IO uint32_t iofc9 : 2; /* [7:6] */
340 __IO uint32_t iomc10 : 2; /* [9:8] */
341 __IO uint32_t iofc10 : 2; /* [11:10] */
342 __IO uint32_t iomc11 : 2; /* [13:12] */
343 __IO uint32_t iofc11 : 2; /* [15:14] */
344 __IO uint32_t iomc12 : 2; /* [17:16] */
345 __IO uint32_t iofc12 : 2; /* [19:18] */
346 __IO uint32_t iomc13 : 2; /* [21:20] */
347 __IO uint32_t iofc13 : 2; /* [23:22] */
348 __IO uint32_t iomc14 : 2; /* [25:24] */
349 __IO uint32_t iofc14 : 2; /* [27:26] */
350 __IO uint32_t iomc15 : 2; /* [29:28] */
351 __IO uint32_t iofc15 : 2; /* [31:30] */
352 } cfghr_bit;
353 };
354
358 union
359 {
360 __IO uint32_t idt;
361 struct
362 {
363 __IO uint32_t idt0 : 1; /* [0] */
364 __IO uint32_t idt1 : 1; /* [1] */
365 __IO uint32_t idt2 : 1; /* [2] */
366 __IO uint32_t idt3 : 1; /* [3] */
367 __IO uint32_t idt4 : 1; /* [4] */
368 __IO uint32_t idt5 : 1; /* [5] */
369 __IO uint32_t idt6 : 1; /* [6] */
370 __IO uint32_t idt7 : 1; /* [7] */
371 __IO uint32_t idt8 : 1; /* [8] */
372 __IO uint32_t idt9 : 1; /* [9] */
373 __IO uint32_t idt10 : 1; /* [10] */
374 __IO uint32_t idt11 : 1; /* [11] */
375 __IO uint32_t idt12 : 1; /* [12] */
376 __IO uint32_t idt13 : 1; /* [13] */
377 __IO uint32_t idt14 : 1; /* [14] */
378 __IO uint32_t idt15 : 1; /* [15] */
379 __IO uint32_t reserved1 : 16;/* [31:16] */
380 } idt_bit;
381 };
382
386 union
387 {
388 __IO uint32_t odt;
389 struct
390 {
391 __IO uint32_t odt0 : 1; /* [0] */
392 __IO uint32_t odt1 : 1; /* [1] */
393 __IO uint32_t odt2 : 1; /* [2] */
394 __IO uint32_t odt3 : 1; /* [3] */
395 __IO uint32_t odt4 : 1; /* [4] */
396 __IO uint32_t odt5 : 1; /* [5] */
397 __IO uint32_t odt6 : 1; /* [6] */
398 __IO uint32_t odt7 : 1; /* [7] */
399 __IO uint32_t odt8 : 1; /* [8] */
400 __IO uint32_t odt9 : 1; /* [9] */
401 __IO uint32_t odt10 : 1; /* [10] */
402 __IO uint32_t odt11 : 1; /* [11] */
403 __IO uint32_t odt12 : 1; /* [12] */
404 __IO uint32_t odt13 : 1; /* [13] */
405 __IO uint32_t odt14 : 1; /* [14] */
406 __IO uint32_t odt15 : 1; /* [15] */
407 __IO uint32_t reserved1 : 16;/* [31:16] */
408 } odt_bit;
409 };
410
414 union
415 {
416 __IO uint32_t scr;
417 struct
418 {
419 __IO uint32_t iosb0 : 1; /* [0] */
420 __IO uint32_t iosb1 : 1; /* [1] */
421 __IO uint32_t iosb2 : 1; /* [2] */
422 __IO uint32_t iosb3 : 1; /* [3] */
423 __IO uint32_t iosb4 : 1; /* [4] */
424 __IO uint32_t iosb5 : 1; /* [5] */
425 __IO uint32_t iosb6 : 1; /* [6] */
426 __IO uint32_t iosb7 : 1; /* [7] */
427 __IO uint32_t iosb8 : 1; /* [8] */
428 __IO uint32_t iosb9 : 1; /* [9] */
429 __IO uint32_t iosb10 : 1; /* [10] */
430 __IO uint32_t iosb11 : 1; /* [11] */
431 __IO uint32_t iosb12 : 1; /* [12] */
432 __IO uint32_t iosb13 : 1; /* [13] */
433 __IO uint32_t iosb14 : 1; /* [14] */
434 __IO uint32_t iosb15 : 1; /* [15] */
435 __IO uint32_t iocb0 : 1; /* [16] */
436 __IO uint32_t iocb1 : 1; /* [17] */
437 __IO uint32_t iocb2 : 1; /* [18] */
438 __IO uint32_t iocb3 : 1; /* [19] */
439 __IO uint32_t iocb4 : 1; /* [20] */
440 __IO uint32_t iocb5 : 1; /* [21] */
441 __IO uint32_t iocb6 : 1; /* [22] */
442 __IO uint32_t iocb7 : 1; /* [23] */
443 __IO uint32_t iocb8 : 1; /* [24] */
444 __IO uint32_t iocb9 : 1; /* [25] */
445 __IO uint32_t iocb10 : 1; /* [26] */
446 __IO uint32_t iocb11 : 1; /* [27] */
447 __IO uint32_t iocb12 : 1; /* [28] */
448 __IO uint32_t iocb13 : 1; /* [29] */
449 __IO uint32_t iocb14 : 1; /* [30] */
450 __IO uint32_t iocb15 : 1; /* [31] */
451 } scr_bit;
452 };
453
457 union
458 {
459 __IO uint32_t clr;
460 struct
461 {
462 __IO uint32_t iocb0 : 1; /* [0] */
463 __IO uint32_t iocb1 : 1; /* [1] */
464 __IO uint32_t iocb2 : 1; /* [2] */
465 __IO uint32_t iocb3 : 1; /* [3] */
466 __IO uint32_t iocb4 : 1; /* [4] */
467 __IO uint32_t iocb5 : 1; /* [5] */
468 __IO uint32_t iocb6 : 1; /* [6] */
469 __IO uint32_t iocb7 : 1; /* [7] */
470 __IO uint32_t iocb8 : 1; /* [8] */
471 __IO uint32_t iocb9 : 1; /* [9] */
472 __IO uint32_t iocb10 : 1; /* [10] */
473 __IO uint32_t iocb11 : 1; /* [11] */
474 __IO uint32_t iocb12 : 1; /* [12] */
475 __IO uint32_t iocb13 : 1; /* [13] */
476 __IO uint32_t iocb14 : 1; /* [14] */
477 __IO uint32_t iocb15 : 1; /* [15] */
478 __IO uint32_t reserved1 : 16;/* [31:16] */
479 } clr_bit;
480 };
481
485 union
486 {
487 __IO uint32_t wpr;
488 struct
489 {
490 __IO uint32_t wpen0 : 1; /* [0] */
491 __IO uint32_t wpen1 : 1; /* [1] */
492 __IO uint32_t wpen2 : 1; /* [2] */
493 __IO uint32_t wpen3 : 1; /* [3] */
494 __IO uint32_t wpen4 : 1; /* [4] */
495 __IO uint32_t wpen5 : 1; /* [5] */
496 __IO uint32_t wpen6 : 1; /* [6] */
497 __IO uint32_t wpen7 : 1; /* [7] */
498 __IO uint32_t wpen8 : 1; /* [8] */
499 __IO uint32_t wpen9 : 1; /* [9] */
500 __IO uint32_t wpen10 : 1; /* [10] */
501 __IO uint32_t wpen11 : 1; /* [11] */
502 __IO uint32_t wpen12 : 1; /* [12] */
503 __IO uint32_t wpen13 : 1; /* [13] */
504 __IO uint32_t wpen14 : 1; /* [14] */
505 __IO uint32_t wpen15 : 1; /* [15] */
506 __IO uint32_t wpseq : 1; /* [16] */
507 __IO uint32_t reserved1 : 15;/* [31:17] */
508 } wpr_bit;
509 };
510
511} gpio_type;
512
516typedef struct
517{
521 union
522 {
523 __IO uint32_t evtout;
524 struct
525 {
526 __IO uint32_t selpin : 4; /* [3:0] */
527 __IO uint32_t selport : 3; /* [6:4] */
528 __IO uint32_t evoen : 1; /* [7] */
529 __IO uint32_t reserved1 : 24;/* [31:8] */
530 } evtout_bit;
531 };
532
536 union
537 {
538 __IO uint32_t remap;
539 struct
540 {
541 __IO uint32_t spi1_mux_l : 1; /* [0] */
542 __IO uint32_t i2c1_mux : 1; /* [1] */
543 __IO uint32_t usart1_mux : 1; /* [2] */
544 __IO uint32_t reserved1 : 1; /* [3] */
545 __IO uint32_t usart3_mux : 2; /* [5:4] */
546 __IO uint32_t tmr1_mux : 2; /* [7:6] */
547 __IO uint32_t tmr2_mux : 2; /* [9:8] */
548 __IO uint32_t tmr3_mux : 2; /* [11:10] */
549 __IO uint32_t reserved2 : 1; /* [12] */
550 __IO uint32_t can_mux : 2; /* [14:13] */
551 __IO uint32_t pd01_mux : 1; /* [15] */
552 __IO uint32_t tmr5ch4_mux : 1; /* [16] */
553 __IO uint32_t adc1_extrgpre_mux : 1; /* [17] */
554 __IO uint32_t adc1_extrgord_mux : 1; /* [18] */
555 __IO uint32_t adc2_extrgpre_mux : 1; /* [19] */
556 __IO uint32_t adc2_extrgord_mux : 1; /* [20] */
557 __IO uint32_t reserved3 : 3; /* [23:21] */
558 __IO uint32_t swjtag_conf : 3; /* [26:24] */
559 __IO uint32_t reserved4 : 4; /* [30:27] */
560 __IO uint32_t spi1_mux_h : 1; /* [31] */
561 } remap_bit;
562 };
563
567 union
568 {
569 __IO uint32_t exintc1;
570 struct
571 {
572 __IO uint32_t exint0 : 4; /* [3:0] */
573 __IO uint32_t exint1 : 4; /* [7:4] */
574 __IO uint32_t exint2 : 4; /* [11:8] */
575 __IO uint32_t exint3 : 4; /* [15:12] */
576 __IO uint32_t reserved1 : 16;/* [31:16] */
577 } exintc1_bit;
578 };
579
583 union
584 {
585 __IO uint32_t exintc2;
586 struct
587 {
588 __IO uint32_t exint4 : 4; /* [3:0] */
589 __IO uint32_t exint5 : 4; /* [7:4] */
590 __IO uint32_t exint6 : 4; /* [11:8] */
591 __IO uint32_t exint7 : 4; /* [15:12] */
592 __IO uint32_t reserved1 : 16;/* [31:16] */
593 } exintc2_bit;
594 };
595
599 union
600 {
601 __IO uint32_t exintc3;
602 struct
603 {
604 __IO uint32_t exint8 : 4; /* [3:0] */
605 __IO uint32_t exint9 : 4; /* [7:4] */
606 __IO uint32_t exint10 : 4; /* [11:8] */
607 __IO uint32_t exint11 : 4; /* [15:12] */
608 __IO uint32_t reserved1 : 16;/* [31:16] */
609 } exintc3_bit;
610 };
611
615 union
616 {
617 __IO uint32_t exintc4;
618 struct
619 {
620 __IO uint32_t exint12 : 4; /* [3:0] */
621 __IO uint32_t exint13 : 4; /* [7:4] */
622 __IO uint32_t exint14 : 4; /* [11:8] */
623 __IO uint32_t exint15 : 4; /* [15:12] */
624 __IO uint32_t reserved1 : 16;/* [31:16] */
625 } exintc4_bit;
626 };
627
631 __IO uint32_t reserved1;
632
636 union
637 {
638 __IO uint32_t remap2;
639 struct
640 {
641 __IO uint32_t reserved1 : 21;/* [20:0] */
642 __IO uint32_t ext_spim_en_mux : 1; /* [21] */
643 __IO uint32_t reserved2 : 10;/* [31:22] */
644 } remap2_bit;
645 };
646
650 union
651 {
652 __IO uint32_t remap3;
653 struct
654 {
655 __IO uint32_t tmr9_gmux : 4; /* [3:0] */
656 __IO uint32_t tmr10_gmux : 4; /* [7:4] */
657 __IO uint32_t tmr11_gmux : 4; /* [11:8] */
658 __IO uint32_t reserved1 : 20;/* [31:12] */
659 } remap3_bit;
660 };
661
665 union
666 {
667 __IO uint32_t remap4;
668 struct
669 {
670 __IO uint32_t tmr1_gmux : 4; /* [3:0] */
671 __IO uint32_t tmr2_gmux : 3; /* [6:4] */
672 __IO uint32_t tmr2itr1_gmux : 1; /* [7] */
673 __IO uint32_t tmr3_gmux : 4; /* [11:8] */
674 __IO uint32_t reserved1 : 4; /* [15:12] */
675 __IO uint32_t tmr5_gmux : 3; /* [18:16] */
676 __IO uint32_t tmr5ch4_gmux : 1; /* [19] */
677 __IO uint32_t reserved2 : 12;/* [31:20] */
678 } remap4_bit;
679 };
680
684 union
685 {
686 __IO uint32_t remap5;
687 struct
688 {
689 __IO uint32_t reserved1 : 4; /* [3:0] */
690 __IO uint32_t i2c1_gmux : 4; /* [7:4] */
691 __IO uint32_t i2c2_gmux : 4; /* [11:8] */
692 __IO uint32_t reserved2 : 4; /* [15:12] */
693 __IO uint32_t spi1_gmux : 4; /* [19:16] */
694 __IO uint32_t spi2_gmux : 4; /* [23:20] */
695 __IO uint32_t reserved3 : 8; /* [31:24] */
696 } remap5_bit;
697 };
698
702 union
703 {
704 __IO uint32_t remap6;
705 struct
706 {
707 __IO uint32_t can1_gmux : 4; /* [3:0] */
708 __IO uint32_t can2_gmux : 4; /* [7:4] */
709 __IO uint32_t sdio1_gmux : 4; /* [11:8] */
710 __IO uint32_t reserved1 : 4; /* [15:12] */
711 __IO uint32_t usart1_gmux : 4; /* [19:16] */
712 __IO uint32_t reserved2 : 4; /* [23:20] */
713 __IO uint32_t usart3_gmux : 4; /* [27:24] */
714 __IO uint32_t uart4_gmux : 4; /* [31:28] */
715 } remap6_bit;
716 };
717
721 union
722 {
723 __IO uint32_t remap7;
724 struct
725 {
726 __IO uint32_t ext_spim_gmux : 3; /* [2:0] */
727 __IO uint32_t ext_spim_gen : 1; /* [3] */
728 __IO uint32_t adc1_etp_gmux : 1; /* [4] */
729 __IO uint32_t adc1_eto_gmux : 1; /* [5] */
730 __IO uint32_t reserved1 : 2; /* [7:6] */
731 __IO uint32_t adc2_etp_gmux : 1; /* [8] */
732 __IO uint32_t adc2_eto_gmux : 1; /* [9] */
733 __IO uint32_t reserved2 : 6; /* [15:10] */
734 __IO uint32_t swjtag_gmux : 3; /* [18:16] */
735 __IO uint32_t reserved3 : 1; /* [19] */
736 __IO uint32_t pd01_gmux : 1; /* [20] */
737 __IO uint32_t reserved4 : 11;/* [31:21] */
738
739 } remap7_bit;
740 };
741
742} iomux_type;
743
748#define GPIOA ((gpio_type *) GPIOA_BASE)
749#define GPIOB ((gpio_type *) GPIOB_BASE)
750#define GPIOC ((gpio_type *) GPIOC_BASE)
751#define GPIOD ((gpio_type *) GPIOD_BASE)
752#define GPIOF ((gpio_type *) GPIOF_BASE)
753#define IOMUX ((iomux_type *) IOMUX_BASE)
754
759void gpio_reset(gpio_type *gpio_x);
760void gpio_iomux_reset(void);
761void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct);
762void gpio_default_para_init(gpio_init_type *gpio_init_struct);
763 flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins);
764uint16_t gpio_input_data_read(gpio_type *gpio_x);
765 flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins);
766uint16_t gpio_output_data_read(gpio_type *gpio_x);
767void gpio_bits_set(gpio_type *gpio_x, uint16_t pins);
768void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins);
769void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state);
770void gpio_port_wirte(gpio_type *gpio_x, uint16_t port_value);
771void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins);
772void gpio_event_output_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source);
773void gpio_event_output_enable(confirm_state new_state);
774void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state);
775void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source);
776
789#ifdef __cplusplus
790}
791#endif
792
793#endif
at32f413.h
at32f413 header file
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
gpio_iomux_reset
void gpio_iomux_reset(void)
reset the mux functions (remap, event control and exint configuration) registers to their default val...
Definition: at32f413_gpio.c:86
gpio_output_data_read
uint16_t gpio_output_data_read(gpio_type *gpio_x)
read the specified gpio ouput data port.
Definition: at32f413_gpio.c:279
gpio_event_output_config
void gpio_event_output_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as event output.
Definition: at32f413_gpio.c:471
gpio_output_data_bit_read
flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified output port pin.
Definition: at32f413_gpio.c:256
gpio_bits_write
void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit.
Definition: at32f413_gpio.c:373
gpio_event_output_enable
void gpio_event_output_enable(confirm_state new_state)
enable or disable the event output.
Definition: at32f413_gpio.c:490
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:341
gpio_input_data_read
uint16_t gpio_input_data_read(gpio_type *gpio_x)
read the specified gpio input data port.
Definition: at32f413_gpio.c:226
gpio_pin_wp_config
void gpio_pin_wp_config(gpio_type *gpio_x, uint16_t pins)
write protect gpio pins configuration registers.
Definition: at32f413_gpio.c:424
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:203
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:310
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:573
gpio_reset
void gpio_reset(gpio_type *gpio_x)
reset the gpio register
Definition: at32f413_gpio.c:51
gpio_port_wirte
void gpio_port_wirte(gpio_type *gpio_x, uint16_t port_value)
write data to the specified gpio data port.
Definition: at32f413_gpio.c:393
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
gpio_mode_type
gpio_mode_type
gpio mode select
Definition: at32f413_gpio.h:213
gpio_drive_type
gpio_drive_type
gpio output drive strength select
Definition: at32f413_gpio.h:224
gpio_pins_source_type
gpio_pins_source_type
gpio pins source type
Definition: at32f413_gpio.h:253
gpio_port_source_type
gpio_port_source_type
gpio port source type
Definition: at32f413_gpio.h:276
gpio_pull_type
gpio_pull_type
gpio pull type
Definition: at32f413_gpio.h:243
gpio_output_type
gpio_output_type
gpio output type
Definition: at32f413_gpio.h:234
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:217
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_MAXIMUM
@ GPIO_DRIVE_STRENGTH_MAXIMUM
Definition: at32f413_gpio.h:227
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:226
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PINS_SOURCE3
@ GPIO_PINS_SOURCE3
Definition: at32f413_gpio.h:257
GPIO_PINS_SOURCE1
@ GPIO_PINS_SOURCE1
Definition: at32f413_gpio.h:255
GPIO_PINS_SOURCE7
@ GPIO_PINS_SOURCE7
Definition: at32f413_gpio.h:261
GPIO_PINS_SOURCE12
@ GPIO_PINS_SOURCE12
Definition: at32f413_gpio.h:266
GPIO_PINS_SOURCE13
@ GPIO_PINS_SOURCE13
Definition: at32f413_gpio.h:267
GPIO_PINS_SOURCE6
@ GPIO_PINS_SOURCE6
Definition: at32f413_gpio.h:260
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:254
GPIO_PINS_SOURCE2
@ GPIO_PINS_SOURCE2
Definition: at32f413_gpio.h:256
GPIO_PINS_SOURCE10
@ GPIO_PINS_SOURCE10
Definition: at32f413_gpio.h:264
GPIO_PINS_SOURCE9
@ GPIO_PINS_SOURCE9
Definition: at32f413_gpio.h:263
GPIO_PINS_SOURCE4
@ GPIO_PINS_SOURCE4
Definition: at32f413_gpio.h:258
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f413_gpio.h:265
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f413_gpio.h:269
GPIO_PINS_SOURCE14
@ GPIO_PINS_SOURCE14
Definition: at32f413_gpio.h:268
GPIO_PINS_SOURCE5
@ GPIO_PINS_SOURCE5
Definition: at32f413_gpio.h:259
GPIO_PINS_SOURCE8
@ GPIO_PINS_SOURCE8
Definition: at32f413_gpio.h:262
GPIO_PORT_SOURCE_GPIOF
@ GPIO_PORT_SOURCE_GPIOF
Definition: at32f413_gpio.h:281
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:277
GPIO_PORT_SOURCE_GPIOB
@ GPIO_PORT_SOURCE_GPIOB
Definition: at32f413_gpio.h:278
GPIO_PORT_SOURCE_GPIOD
@ GPIO_PORT_SOURCE_GPIOD
Definition: at32f413_gpio.h:280
GPIO_PORT_SOURCE_GPIOC
@ GPIO_PORT_SOURCE_GPIOC
Definition: at32f413_gpio.h:279
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:236
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
gpio_type
type define gpio register all
Definition: at32f413_gpio.h:300
gpio_type::iocb9
__IO uint32_t iocb9
Definition: at32f413_gpio.h:444
gpio_type::idt4
__IO uint32_t idt4
Definition: at32f413_gpio.h:367
gpio_type::iocb4
__IO uint32_t iocb4
Definition: at32f413_gpio.h:439
gpio_type::iocb6
__IO uint32_t iocb6
Definition: at32f413_gpio.h:441
gpio_type::iomc13
__IO uint32_t iomc13
Definition: at32f413_gpio.h:346
gpio_type::odt11
__IO uint32_t odt11
Definition: at32f413_gpio.h:402
gpio_type::iocb7
__IO uint32_t iocb7
Definition: at32f413_gpio.h:442
gpio_type::idt3
__IO uint32_t idt3
Definition: at32f413_gpio.h:366
gpio_type::idt7
__IO uint32_t idt7
Definition: at32f413_gpio.h:370
gpio_type::iosb12
__IO uint32_t iosb12
Definition: at32f413_gpio.h:431
gpio_type::iomc5
__IO uint32_t iomc5
Definition: at32f413_gpio.h:319
gpio_type::iofc13
__IO uint32_t iofc13
Definition: at32f413_gpio.h:347
gpio_type::iosb4
__IO uint32_t iosb4
Definition: at32f413_gpio.h:423
gpio_type::idt1
__IO uint32_t idt1
Definition: at32f413_gpio.h:364
gpio_type::idt14
__IO uint32_t idt14
Definition: at32f413_gpio.h:377
gpio_type::idt6
__IO uint32_t idt6
Definition: at32f413_gpio.h:369
gpio_type::iofc2
__IO uint32_t iofc2
Definition: at32f413_gpio.h:314
gpio_type::scr
__IO uint32_t scr
Definition: at32f413_gpio.h:416
gpio_type::odt6
__IO uint32_t odt6
Definition: at32f413_gpio.h:397
gpio_type::odt
__IO uint32_t odt
Definition: at32f413_gpio.h:388
gpio_type::wpen0
__IO uint32_t wpen0
Definition: at32f413_gpio.h:490
gpio_type::wpen9
__IO uint32_t wpen9
Definition: at32f413_gpio.h:499
gpio_type::iomc0
__IO uint32_t iomc0
Definition: at32f413_gpio.h:309
gpio_type::odt5
__IO uint32_t odt5
Definition: at32f413_gpio.h:396
gpio_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_gpio.h:379
gpio_type::odt2
__IO uint32_t odt2
Definition: at32f413_gpio.h:393
gpio_type::iosb7
__IO uint32_t iosb7
Definition: at32f413_gpio.h:426
gpio_type::iocb15
__IO uint32_t iocb15
Definition: at32f413_gpio.h:450
gpio_type::idt12
__IO uint32_t idt12
Definition: at32f413_gpio.h:375
gpio_type::idt9
__IO uint32_t idt9
Definition: at32f413_gpio.h:372
gpio_type::iofc5
__IO uint32_t iofc5
Definition: at32f413_gpio.h:320
gpio_type::odt14
__IO uint32_t odt14
Definition: at32f413_gpio.h:405
gpio_type::iomc6
__IO uint32_t iomc6
Definition: at32f413_gpio.h:321
gpio_type::wpen14
__IO uint32_t wpen14
Definition: at32f413_gpio.h:504
gpio_type::idt8
__IO uint32_t idt8
Definition: at32f413_gpio.h:371
gpio_type::clr
__IO uint32_t clr
Definition: at32f413_gpio.h:459
gpio_type::iosb9
__IO uint32_t iosb9
Definition: at32f413_gpio.h:428
gpio_type::iomc2
__IO uint32_t iomc2
Definition: at32f413_gpio.h:313
gpio_type::iocb14
__IO uint32_t iocb14
Definition: at32f413_gpio.h:449
gpio_type::iofc3
__IO uint32_t iofc3
Definition: at32f413_gpio.h:316
gpio_type::iosb2
__IO uint32_t iosb2
Definition: at32f413_gpio.h:421
gpio_type::wpen8
__IO uint32_t wpen8
Definition: at32f413_gpio.h:498
gpio_type::wpen1
__IO uint32_t wpen1
Definition: at32f413_gpio.h:491
gpio_type::iocb13
__IO uint32_t iocb13
Definition: at32f413_gpio.h:448
gpio_type::wpen13
__IO uint32_t wpen13
Definition: at32f413_gpio.h:503
gpio_type::iofc14
__IO uint32_t iofc14
Definition: at32f413_gpio.h:349
gpio_type::odt15
__IO uint32_t odt15
Definition: at32f413_gpio.h:406
gpio_type::iocb12
__IO uint32_t iocb12
Definition: at32f413_gpio.h:447
gpio_type::iocb3
__IO uint32_t iocb3
Definition: at32f413_gpio.h:438
gpio_type::iosb13
__IO uint32_t iosb13
Definition: at32f413_gpio.h:432
gpio_type::odt3
__IO uint32_t odt3
Definition: at32f413_gpio.h:394
gpio_type::odt9
__IO uint32_t odt9
Definition: at32f413_gpio.h:400
gpio_type::iofc11
__IO uint32_t iofc11
Definition: at32f413_gpio.h:343
gpio_type::idt5
__IO uint32_t idt5
Definition: at32f413_gpio.h:368
gpio_type::iosb5
__IO uint32_t iosb5
Definition: at32f413_gpio.h:424
gpio_type::iosb14
__IO uint32_t iosb14
Definition: at32f413_gpio.h:433
gpio_type::iosb1
__IO uint32_t iosb1
Definition: at32f413_gpio.h:420
gpio_type::iofc6
__IO uint32_t iofc6
Definition: at32f413_gpio.h:322
gpio_type::odt12
__IO uint32_t odt12
Definition: at32f413_gpio.h:403
gpio_type::wpen15
__IO uint32_t wpen15
Definition: at32f413_gpio.h:505
gpio_type::iomc8
__IO uint32_t iomc8
Definition: at32f413_gpio.h:336
gpio_type::wpseq
__IO uint32_t wpseq
Definition: at32f413_gpio.h:506
gpio_type::idt10
__IO uint32_t idt10
Definition: at32f413_gpio.h:373
gpio_type::wpen12
__IO uint32_t wpen12
Definition: at32f413_gpio.h:502
gpio_type::iofc10
__IO uint32_t iofc10
Definition: at32f413_gpio.h:341
gpio_type::iomc9
__IO uint32_t iomc9
Definition: at32f413_gpio.h:338
gpio_type::iocb8
__IO uint32_t iocb8
Definition: at32f413_gpio.h:443
gpio_type::iosb6
__IO uint32_t iosb6
Definition: at32f413_gpio.h:425
gpio_type::iocb1
__IO uint32_t iocb1
Definition: at32f413_gpio.h:436
gpio_type::iocb2
__IO uint32_t iocb2
Definition: at32f413_gpio.h:437
gpio_type::wpen2
__IO uint32_t wpen2
Definition: at32f413_gpio.h:492
gpio_type::iofc12
__IO uint32_t iofc12
Definition: at32f413_gpio.h:345
gpio_type::iomc7
__IO uint32_t iomc7
Definition: at32f413_gpio.h:323
gpio_type::idt13
__IO uint32_t idt13
Definition: at32f413_gpio.h:376
gpio_type::odt13
__IO uint32_t odt13
Definition: at32f413_gpio.h:404
gpio_type::iocb5
__IO uint32_t iocb5
Definition: at32f413_gpio.h:440
gpio_type::odt7
__IO uint32_t odt7
Definition: at32f413_gpio.h:398
gpio_type::odt4
__IO uint32_t odt4
Definition: at32f413_gpio.h:395
gpio_type::iosb0
__IO uint32_t iosb0
Definition: at32f413_gpio.h:419
gpio_type::wpen6
__IO uint32_t wpen6
Definition: at32f413_gpio.h:496
gpio_type::cfghr
__IO uint32_t cfghr
Definition: at32f413_gpio.h:333
gpio_type::iofc0
__IO uint32_t iofc0
Definition: at32f413_gpio.h:310
gpio_type::wpen11
__IO uint32_t wpen11
Definition: at32f413_gpio.h:501
gpio_type::wpen4
__IO uint32_t wpen4
Definition: at32f413_gpio.h:494
gpio_type::wpen5
__IO uint32_t wpen5
Definition: at32f413_gpio.h:495
gpio_type::idt11
__IO uint32_t idt11
Definition: at32f413_gpio.h:374
gpio_type::idt2
__IO uint32_t idt2
Definition: at32f413_gpio.h:365
gpio_type::odt1
__IO uint32_t odt1
Definition: at32f413_gpio.h:392
gpio_type::cfglr
__IO uint32_t cfglr
Definition: at32f413_gpio.h:306
gpio_type::wpen7
__IO uint32_t wpen7
Definition: at32f413_gpio.h:497
gpio_type::iomc11
__IO uint32_t iomc11
Definition: at32f413_gpio.h:342
gpio_type::iocb10
__IO uint32_t iocb10
Definition: at32f413_gpio.h:445
gpio_type::iofc9
__IO uint32_t iofc9
Definition: at32f413_gpio.h:339
gpio_type::iomc15
__IO uint32_t iomc15
Definition: at32f413_gpio.h:350
gpio_type::iomc14
__IO uint32_t iomc14
Definition: at32f413_gpio.h:348
gpio_type::iofc8
__IO uint32_t iofc8
Definition: at32f413_gpio.h:337
gpio_type::iomc12
__IO uint32_t iomc12
Definition: at32f413_gpio.h:344
gpio_type::iosb15
__IO uint32_t iosb15
Definition: at32f413_gpio.h:434
gpio_type::odt10
__IO uint32_t odt10
Definition: at32f413_gpio.h:401
gpio_type::iofc7
__IO uint32_t iofc7
Definition: at32f413_gpio.h:324
gpio_type::iosb3
__IO uint32_t iosb3
Definition: at32f413_gpio.h:422
gpio_type::odt0
__IO uint32_t odt0
Definition: at32f413_gpio.h:391
gpio_type::wpen3
__IO uint32_t wpen3
Definition: at32f413_gpio.h:493
gpio_type::idt15
__IO uint32_t idt15
Definition: at32f413_gpio.h:378
gpio_type::idt
__IO uint32_t idt
Definition: at32f413_gpio.h:360
gpio_type::odt8
__IO uint32_t odt8
Definition: at32f413_gpio.h:399
gpio_type::iofc15
__IO uint32_t iofc15
Definition: at32f413_gpio.h:351
gpio_type::iofc1
__IO uint32_t iofc1
Definition: at32f413_gpio.h:312
gpio_type::idt0
__IO uint32_t idt0
Definition: at32f413_gpio.h:363
gpio_type::wpr
__IO uint32_t wpr
Definition: at32f413_gpio.h:487
gpio_type::iomc3
__IO uint32_t iomc3
Definition: at32f413_gpio.h:315
gpio_type::iocb0
__IO uint32_t iocb0
Definition: at32f413_gpio.h:435
gpio_type::iosb8
__IO uint32_t iosb8
Definition: at32f413_gpio.h:427
gpio_type::iosb11
__IO uint32_t iosb11
Definition: at32f413_gpio.h:430
gpio_type::iomc4
__IO uint32_t iomc4
Definition: at32f413_gpio.h:317
gpio_type::iomc10
__IO uint32_t iomc10
Definition: at32f413_gpio.h:340
gpio_type::iomc1
__IO uint32_t iomc1
Definition: at32f413_gpio.h:311
gpio_type::iofc4
__IO uint32_t iofc4
Definition: at32f413_gpio.h:318
gpio_type::wpen10
__IO uint32_t wpen10
Definition: at32f413_gpio.h:500
gpio_type::iosb10
__IO uint32_t iosb10
Definition: at32f413_gpio.h:429
gpio_type::iocb11
__IO uint32_t iocb11
Definition: at32f413_gpio.h:446
iomux_type
type define iomux register all
Definition: at32f413_gpio.h:517
iomux_type::adc1_etp_gmux
__IO uint32_t adc1_etp_gmux
Definition: at32f413_gpio.h:728
iomux_type::exint1
__IO uint32_t exint1
Definition: at32f413_gpio.h:573
iomux_type::remap
__IO uint32_t remap
Definition: at32f413_gpio.h:538
iomux_type::tmr3_gmux
__IO uint32_t tmr3_gmux
Definition: at32f413_gpio.h:673
iomux_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_gpio.h:557
iomux_type::exint9
__IO uint32_t exint9
Definition: at32f413_gpio.h:605
iomux_type::remap2
__IO uint32_t remap2
Definition: at32f413_gpio.h:638
iomux_type::tmr1_gmux
__IO uint32_t tmr1_gmux
Definition: at32f413_gpio.h:670
iomux_type::tmr2_gmux
__IO uint32_t tmr2_gmux
Definition: at32f413_gpio.h:671
iomux_type::adc2_eto_gmux
__IO uint32_t adc2_eto_gmux
Definition: at32f413_gpio.h:732
iomux_type::exint15
__IO uint32_t exint15
Definition: at32f413_gpio.h:623
iomux_type::can2_gmux
__IO uint32_t can2_gmux
Definition: at32f413_gpio.h:708
iomux_type::remap6
__IO uint32_t remap6
Definition: at32f413_gpio.h:704
iomux_type::exint13
__IO uint32_t exint13
Definition: at32f413_gpio.h:621
iomux_type::usart1_gmux
__IO uint32_t usart1_gmux
Definition: at32f413_gpio.h:711
iomux_type::remap5
__IO uint32_t remap5
Definition: at32f413_gpio.h:686
iomux_type::uart4_gmux
__IO uint32_t uart4_gmux
Definition: at32f413_gpio.h:714
iomux_type::ext_spim_en_mux
__IO uint32_t ext_spim_en_mux
Definition: at32f413_gpio.h:642
iomux_type::exint10
__IO uint32_t exint10
Definition: at32f413_gpio.h:606
iomux_type::tmr3_mux
__IO uint32_t tmr3_mux
Definition: at32f413_gpio.h:548
iomux_type::tmr10_gmux
__IO uint32_t tmr10_gmux
Definition: at32f413_gpio.h:656
iomux_type::adc2_extrgpre_mux
__IO uint32_t adc2_extrgpre_mux
Definition: at32f413_gpio.h:555
iomux_type::reserved1
__IO uint32_t reserved1
iomux reserved1 register, offset:0x18
Definition: at32f413_gpio.h:529
iomux_type::i2c1_mux
__IO uint32_t i2c1_mux
Definition: at32f413_gpio.h:542
iomux_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_gpio.h:549
iomux_type::adc2_etp_gmux
__IO uint32_t adc2_etp_gmux
Definition: at32f413_gpio.h:731
iomux_type::exint12
__IO uint32_t exint12
Definition: at32f413_gpio.h:620
iomux_type::pd01_mux
__IO uint32_t pd01_mux
Definition: at32f413_gpio.h:551
iomux_type::exint11
__IO uint32_t exint11
Definition: at32f413_gpio.h:607
iomux_type::adc1_extrgpre_mux
__IO uint32_t adc1_extrgpre_mux
Definition: at32f413_gpio.h:553
iomux_type::exint7
__IO uint32_t exint7
Definition: at32f413_gpio.h:591
iomux_type::exint6
__IO uint32_t exint6
Definition: at32f413_gpio.h:590
iomux_type::remap7
__IO uint32_t remap7
Definition: at32f413_gpio.h:723
iomux_type::remap4
__IO uint32_t remap4
Definition: at32f413_gpio.h:667
iomux_type::pd01_gmux
__IO uint32_t pd01_gmux
Definition: at32f413_gpio.h:736
iomux_type::evoen
__IO uint32_t evoen
Definition: at32f413_gpio.h:528
iomux_type::adc2_extrgord_mux
__IO uint32_t adc2_extrgord_mux
Definition: at32f413_gpio.h:556
iomux_type::i2c2_gmux
__IO uint32_t i2c2_gmux
Definition: at32f413_gpio.h:691
iomux_type::exint3
__IO uint32_t exint3
Definition: at32f413_gpio.h:575
iomux_type::swjtag_conf
__IO uint32_t swjtag_conf
Definition: at32f413_gpio.h:558
iomux_type::tmr1_mux
__IO uint32_t tmr1_mux
Definition: at32f413_gpio.h:546
iomux_type::usart3_gmux
__IO uint32_t usart3_gmux
Definition: at32f413_gpio.h:713
iomux_type::tmr11_gmux
__IO uint32_t tmr11_gmux
Definition: at32f413_gpio.h:657
iomux_type::tmr9_gmux
__IO uint32_t tmr9_gmux
Definition: at32f413_gpio.h:655
iomux_type::selpin
__IO uint32_t selpin
Definition: at32f413_gpio.h:526
iomux_type::spi1_gmux
__IO uint32_t spi1_gmux
Definition: at32f413_gpio.h:693
iomux_type::reserved4
__IO uint32_t reserved4
Definition: at32f413_gpio.h:559
iomux_type::tmr2_mux
__IO uint32_t tmr2_mux
Definition: at32f413_gpio.h:547
iomux_type::spi2_gmux
__IO uint32_t spi2_gmux
Definition: at32f413_gpio.h:694
iomux_type::exint4
__IO uint32_t exint4
Definition: at32f413_gpio.h:588
iomux_type::spi1_mux_h
__IO uint32_t spi1_mux_h
Definition: at32f413_gpio.h:560
iomux_type::exint8
__IO uint32_t exint8
Definition: at32f413_gpio.h:604
iomux_type::sdio1_gmux
__IO uint32_t sdio1_gmux
Definition: at32f413_gpio.h:709
iomux_type::can1_gmux
__IO uint32_t can1_gmux
Definition: at32f413_gpio.h:707
iomux_type::exintc4
__IO uint32_t exintc4
Definition: at32f413_gpio.h:617
iomux_type::exint2
__IO uint32_t exint2
Definition: at32f413_gpio.h:574
iomux_type::exint5
__IO uint32_t exint5
Definition: at32f413_gpio.h:589
iomux_type::selport
__IO uint32_t selport
Definition: at32f413_gpio.h:527
iomux_type::exint0
__IO uint32_t exint0
Definition: at32f413_gpio.h:572
iomux_type::exint14
__IO uint32_t exint14
Definition: at32f413_gpio.h:622
iomux_type::adc1_eto_gmux
__IO uint32_t adc1_eto_gmux
Definition: at32f413_gpio.h:729
iomux_type::remap3
__IO uint32_t remap3
Definition: at32f413_gpio.h:652
iomux_type::spi1_mux_l
__IO uint32_t spi1_mux_l
Definition: at32f413_gpio.h:541
iomux_type::usart1_mux
__IO uint32_t usart1_mux
Definition: at32f413_gpio.h:543
iomux_type::ext_spim_gen
__IO uint32_t ext_spim_gen
Definition: at32f413_gpio.h:727
iomux_type::exintc3
__IO uint32_t exintc3
Definition: at32f413_gpio.h:601
iomux_type::tmr5ch4_gmux
__IO uint32_t tmr5ch4_gmux
Definition: at32f413_gpio.h:676
iomux_type::can_mux
__IO uint32_t can_mux
Definition: at32f413_gpio.h:550
iomux_type::usart3_mux
__IO uint32_t usart3_mux
Definition: at32f413_gpio.h:545
iomux_type::tmr5ch4_mux
__IO uint32_t tmr5ch4_mux
Definition: at32f413_gpio.h:552
iomux_type::evtout
__IO uint32_t evtout
Definition: at32f413_gpio.h:523
iomux_type::adc1_extrgord_mux
__IO uint32_t adc1_extrgord_mux
Definition: at32f413_gpio.h:554
iomux_type::tmr5_gmux
__IO uint32_t tmr5_gmux
Definition: at32f413_gpio.h:675
iomux_type::exintc2
__IO uint32_t exintc2
Definition: at32f413_gpio.h:585
iomux_type::swjtag_gmux
__IO uint32_t swjtag_gmux
Definition: at32f413_gpio.h:734
iomux_type::ext_spim_gmux
__IO uint32_t ext_spim_gmux
Definition: at32f413_gpio.h:726
iomux_type::tmr2itr1_gmux
__IO uint32_t tmr2itr1_gmux
Definition: at32f413_gpio.h:672
iomux_type::exintc1
__IO uint32_t exintc1
Definition: at32f413_gpio.h:569
iomux_type::i2c1_gmux
__IO uint32_t i2c1_gmux
Definition: at32f413_gpio.h:690


AT32F413 Firmwary Library: at32f413_i2c.c Source File

  • libraries
  • drivers
  • src
at32f413_i2c.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef I2C_MODULE_ENABLED
39
51void i2c_reset(i2c_type *i2c_x)
52{
53 if(i2c_x == I2C1)
54 {
55 crm_periph_reset(CRM_I2C1_PERIPH_RESET, TRUE);
56 crm_periph_reset(CRM_I2C1_PERIPH_RESET, FALSE);
57 }
58 else if(i2c_x == I2C2)
59 {
60 crm_periph_reset(CRM_I2C2_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_I2C2_PERIPH_RESET, FALSE);
62 }
63}
64
73void i2c_software_reset(i2c_type *i2c_x, confirm_state new_state)
74{
75 i2c_x->ctrl1_bit.reset = new_state;
76}
77
90void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
91{
92 uint32_t apb_freq = 0;
93 uint16_t freq_mhz = 0, temp = 0;
94
95 crm_clocks_freq_type clocks;
96
97 /* disable i2c peripherals */
98 i2c_x->ctrl1_bit.i2cen = FALSE;
99
100 /* get system clock */
101 crm_clocks_freq_get(&clocks);
102
103 if((i2c_x == I2C1) || (i2c_x == I2C2))
104 {
105 apb_freq = clocks.apb1_freq;
106 }
107
108 freq_mhz = (apb_freq / 1000000);
109
110 /* set i2c input clock frequency */
111 i2c_x->ctrl2_bit.clkfreq = freq_mhz;
112
113 /* standard mode */
114 if(speed <= 100000)
115 {
116 temp = (uint16_t)(apb_freq / (speed << 1));
117
118 if (temp < 0x04)
119 {
120 temp = 0x04;
121 }
122
123 /* set scl clock */
124 i2c_x->clkctrl_bit.speed = temp;
125
126 /* disable fast mode */
127 i2c_x->clkctrl_bit.speedmode = FALSE;
128
129 /* set the maximum rise time */
130 if((freq_mhz + 1) > 0x3F)
131 {
132 i2c_x->tmrise_bit.risetime = 0x3F;
133 }
134 else
135 {
136 i2c_x->tmrise_bit.risetime = (freq_mhz + 1);
137 }
138 }
139 /* fast mode */
140 else
141 {
142 if (duty == I2C_FSMODE_DUTY_2_1)
143 {
144 temp = (uint16_t)(apb_freq / (speed * 3));
145
146 /* the ratio of high level to low level is 1:2 */
147 i2c_x->clkctrl_bit.dutymode = I2C_FSMODE_DUTY_2_1;
148 }
149 else
150 {
151 temp = (uint16_t)(apb_freq / (speed * 25));
152
153 /* the ratio of high level to low level is 9:16 */
154 i2c_x->clkctrl_bit.dutymode = I2C_FSMODE_DUTY_16_9;
155 }
156
157 if (temp == 0)
158 {
159 temp = 0x0001;
160 }
161
162 /* set scl clock*/
163 i2c_x->clkctrl_bit.speed = temp;
164
165 /* set the mode to fast mode */
166 i2c_x->clkctrl_bit.speedmode = TRUE;
167
168 /* set the maximum rise time */
169 i2c_x->tmrise_bit.risetime = (uint16_t)(((freq_mhz * (uint16_t)300) / (uint16_t)1000) + (uint16_t)1);
170 }
171}
172
185void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
186{
187 /* set address mode */
188 i2c_x->oaddr1_bit.addr1mode = mode;
189
190 /* set own address1 */
191 i2c_x->oaddr1_bit.addr1 = address;
192}
193
202void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address)
203{
204 i2c_x->oaddr2_bit.addr2 = (address >> 1);
205}
206
215void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state)
216{
217 i2c_x->oaddr2_bit.addr2en = new_state;
218}
219
228void i2c_smbus_enable(i2c_type *i2c_x, confirm_state new_state)
229{
230 i2c_x->ctrl1_bit.permode = new_state;
231}
232
241void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
242{
243 i2c_x->ctrl1_bit.i2cen = new_state;
244}
245
257void i2c_fast_mode_duty_set(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
258{
259 i2c_x->clkctrl_bit.dutymode = duty;
260}
261
270void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state)
271{
272 i2c_x->ctrl1_bit.stretch = !new_state;
273}
274
283void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
284{
285 i2c_x->ctrl1_bit.acken = new_state;
286}
287
299void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos)
300{
301 i2c_x->ctrl1_bit.mackctrl = pos;
302}
303
315void i2c_pec_position_set(i2c_type *i2c_x, i2c_pec_position_type pos)
316{
317 i2c_x->ctrl1_bit.mackctrl = pos;
318}
319
328void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state)
329{
330 i2c_x->ctrl1_bit.gcaen = new_state;
331}
332
341void i2c_arp_mode_enable(i2c_type *i2c_x, confirm_state new_state)
342{
343 i2c_x->ctrl1_bit.arpen = new_state;
344}
345
357void i2c_smbus_mode_set(i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
358{
359 i2c_x->ctrl1_bit.smbmode = mode;
360}
361
373void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level)
374{
375 i2c_x->ctrl1_bit.smbalert = level;
376}
377
386void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
387{
388 i2c_x->ctrl1_bit.pecten = new_state;
389}
390
399void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
400{
401 i2c_x->ctrl1_bit.pecen = new_state;
402}
403
411uint8_t i2c_pec_value_get(i2c_type *i2c_x)
412{
413 return i2c_x->sts2_bit.pecval;
414}
415
424void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state)
425{
426 i2c_x->ctrl2_bit.dmaend = new_state;
427}
428
437void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state)
438{
439 i2c_x->ctrl2_bit.dmaen = new_state;
440}
441
455void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state)
456{
457 if (new_state != FALSE)
458 {
459 i2c_x->ctrl2 |= source;
460 }
461 else
462 {
463 i2c_x->ctrl2 &= (uint16_t)~source;
464 }
465}
466
474void i2c_start_generate(i2c_type *i2c_x)
475{
476 i2c_x->ctrl1_bit.genstart = TRUE;
477}
478
486void i2c_stop_generate(i2c_type *i2c_x)
487{
488 i2c_x->ctrl1_bit.genstop = TRUE;
489}
490
503void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
504{
505 if(direction == I2C_DIRECTION_TRANSMIT)
506 {
507 i2c_x->dt = address & 0xFE;
508 }
509 else
510 {
511 i2c_x->dt = address | 0x01;
512 }
513}
514
523void i2c_data_send(i2c_type *i2c_x, uint8_t data)
524{
525 i2c_x->dt = data;
526}
527
535uint8_t i2c_data_receive(i2c_type *i2c_x)
536{
537 return (uint8_t)i2c_x->dt;
538}
539
570 flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
571{
572 __IO uint32_t reg = 0, value = 0;
573
574 reg = flag >> 28;
575
576 flag &= (uint32_t)0x00FFFFFF;
577
578 if(reg == 0)
579 {
580 value = i2c_x->sts1;
581 }
582 else
583 {
584 flag = (uint32_t)(flag >> 16);
585
586 value = i2c_x->sts2;
587 }
588
589 if((value & flag) != (uint32_t)RESET)
590 {
591 return SET;
592 }
593 else
594 {
595 return RESET;
596 }
597}
598
615void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
616{
617 i2c_x->sts1 = (uint16_t)~(flag & (uint32_t)0x00FFFFFF);
618}
619
624#endif
625
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_I2C2_PERIPH_RESET
@ CRM_I2C2_PERIPH_RESET
Definition: at32f413_crm.h:181
CRM_I2C1_PERIPH_RESET
@ CRM_I2C1_PERIPH_RESET
Definition: at32f413_crm.h:180
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
i2c_fsmode_duty_cycle_type
i2c_fsmode_duty_cycle_type
i2c fast mode duty cycle
Definition: at32f413_i2c.h:147
i2c_smbus_mode_set_type
i2c_smbus_mode_set_type
i2c smbus mode set
Definition: at32f413_i2c.h:137
i2c_direction_type
i2c_direction_type
i2c address direction
Definition: at32f413_i2c.h:165
i2c_master_ack_type
i2c_master_ack_type
i2c master receiving mode acknowledge control
Definition: at32f413_i2c.h:109
i2c_address_mode_type
i2c_address_mode_type
i2c address mode
Definition: at32f413_i2c.h:156
i2c_smbus_alert_set_type
i2c_smbus_alert_set_type
i2c smbus alert pin set
Definition: at32f413_i2c.h:128
i2c_pec_position_type
i2c_pec_position_type
i2c pec position set
Definition: at32f413_i2c.h:118
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:148
I2C_FSMODE_DUTY_16_9
@ I2C_FSMODE_DUTY_16_9
Definition: at32f413_i2c.h:149
I2C_DIRECTION_TRANSMIT
@ I2C_DIRECTION_TRANSMIT
Definition: at32f413_i2c.h:166
i2c_pec_position_set
void i2c_pec_position_set(i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set.
Definition: at32f413_i2c.c:315
i2c_pec_transmit_enable
void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer.
Definition: at32f413_i2c.c:386
i2c_arp_mode_enable
void i2c_arp_mode_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode.
Definition: at32f413_i2c.c:341
i2c_data_receive
uint8_t i2c_data_receive(i2c_type *i2c_x)
receive a byte through the i2c periph.
Definition: at32f413_i2c.c:535
i2c_reset
void i2c_reset(i2c_type *i2c_x)
reset the i2c register
Definition: at32f413_i2c.c:51
i2c_smbus_alert_set
void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low.
Definition: at32f413_i2c.c:373
i2c_smbus_enable
void i2c_smbus_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode
Definition: at32f413_i2c.c:228
i2c_pec_value_get
uint8_t i2c_pec_value_get(i2c_type *i2c_x)
get pec value.
Definition: at32f413_i2c.c:411
i2c_software_reset
void i2c_software_reset(i2c_type *i2c_x, confirm_state new_state)
software reset.
Definition: at32f413_i2c.c:73
i2c_general_call_enable
void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable general call.
Definition: at32f413_i2c.c:328
i2c_ack_enable
void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge.
Definition: at32f413_i2c.c:283
i2c_own_address2_set
void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address)
config own address2.
Definition: at32f413_i2c.c:202
i2c_7bit_address_send
void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address.
Definition: at32f413_i2c.c:503
i2c_dma_end_transfer_set
void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one.
Definition: at32f413_i2c.c:424
i2c_own_address2_enable
void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2.
Definition: at32f413_i2c.c:215
i2c_pec_calculate_enable
void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion.
Definition: at32f413_i2c.c:399
i2c_stop_generate
void i2c_stop_generate(i2c_type *i2c_x)
generate stop condition.
Definition: at32f413_i2c.c:486
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:185
i2c_enable
void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph
Definition: at32f413_i2c.c:241
i2c_fast_mode_duty_set
void i2c_fast_mode_duty_set(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle
Definition: at32f413_i2c.c:257
i2c_flag_get
flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
get flag status
Definition: at32f413_i2c.c:570
i2c_smbus_mode_set
void i2c_smbus_mode_set(i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device.
Definition: at32f413_i2c.c:357
i2c_interrupt_enable
void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt
Definition: at32f413_i2c.c:455
i2c_flag_clear
void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
clear flag status
Definition: at32f413_i2c.c:615
i2c_dma_enable
void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests.
Definition: at32f413_i2c.c:437
i2c_data_send
void i2c_data_send(i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph.
Definition: at32f413_i2c.c:523
i2c_clock_stretch_enable
void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch.
Definition: at32f413_i2c.c:270
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:90
i2c_master_receive_ack_set
void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control.
Definition: at32f413_i2c.c:299
i2c_start_generate
void i2c_start_generate(i2c_type *i2c_x)
generate start condition.
Definition: at32f413_i2c.c:474
I2C1
#define I2C1
Definition: at32f413_i2c.h:347
I2C2
#define I2C2
Definition: at32f413_i2c.h:348
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:475
i2c_type
type define i2c register all
Definition: at32f413_i2c.h:174
i2c_type::smbalert
__IO uint32_t smbalert
Definition: at32f413_i2c.h:196
i2c_type::dmaend
__IO uint32_t dmaend
Definition: at32f413_i2c.h:216
i2c_type::genstop
__IO uint32_t genstop
Definition: at32f413_i2c.h:192
i2c_type::addr2en
__IO uint32_t addr2en
Definition: at32f413_i2c.h:244
i2c_type::dmaen
__IO uint32_t dmaen
Definition: at32f413_i2c.h:215
i2c_type::oaddr2_bit
struct i2c_type::@510::@525 oaddr2_bit
i2c_type::gcaen
__IO uint32_t gcaen
Definition: at32f413_i2c.h:189
i2c_type::clkfreq
__IO uint32_t clkfreq
Definition: at32f413_i2c.h:211
i2c_type::addr2
__IO uint32_t addr2
Definition: at32f413_i2c.h:245
i2c_type::oaddr1_bit
struct i2c_type::@508::@524 oaddr1_bit
i2c_type::sts2_bit
struct i2c_type::@516::@528 sts2_bit
i2c_type::sts1
__IO uint32_t sts1
Definition: at32f413_i2c.h:268
i2c_type::risetime
__IO uint32_t risetime
Definition: at32f413_i2c.h:336
i2c_type::permode
__IO uint32_t permode
Definition: at32f413_i2c.h:184
i2c_type::genstart
__IO uint32_t genstart
Definition: at32f413_i2c.h:191
i2c_type::speedmode
__IO uint32_t speedmode
Definition: at32f413_i2c.h:323
i2c_type::pecten
__IO uint32_t pecten
Definition: at32f413_i2c.h:195
i2c_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_i2c.h:208
i2c_type::speed
__IO uint32_t speed
Definition: at32f413_i2c.h:320
i2c_type::ctrl1_bit
struct i2c_type::@504::@522 ctrl1_bit
i2c_type::stretch
__IO uint32_t stretch
Definition: at32f413_i2c.h:190
i2c_type::dutymode
__IO uint32_t dutymode
Definition: at32f413_i2c.h:322
i2c_type::arpen
__IO uint32_t arpen
Definition: at32f413_i2c.h:187
i2c_type::addr1mode
__IO uint32_t addr1mode
Definition: at32f413_i2c.h:231
i2c_type::tmrise_bit
struct i2c_type::@520::@530 tmrise_bit
i2c_type::reset
__IO uint32_t reset
Definition: at32f413_i2c.h:198
i2c_type::pecval
__IO uint32_t pecval
Definition: at32f413_i2c.h:307
i2c_type::clkctrl_bit
struct i2c_type::@518::@529 clkctrl_bit
i2c_type::dt
__IO uint32_t dt
Definition: at32f413_i2c.h:255
i2c_type::acken
__IO uint32_t acken
Definition: at32f413_i2c.h:193
i2c_type::i2cen
__IO uint32_t i2cen
Definition: at32f413_i2c.h:183
i2c_type::addr1
__IO uint32_t addr1
Definition: at32f413_i2c.h:229
i2c_type::sts2
__IO uint32_t sts2
Definition: at32f413_i2c.h:296
i2c_type::ctrl2_bit
struct i2c_type::@506::@523 ctrl2_bit
i2c_type::mackctrl
__IO uint32_t mackctrl
Definition: at32f413_i2c.h:194
i2c_type::pecen
__IO uint32_t pecen
Definition: at32f413_i2c.h:188
i2c_type::smbmode
__IO uint32_t smbmode
Definition: at32f413_i2c.h:186
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_i2c.h Source File

  • libraries
  • drivers
  • inc
at32f413_i2c.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_I2C_H
29#define __AT32F413_I2C_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define I2C_STARTF_FLAG ((uint32_t)0x00000001)
53#define I2C_ADDR7F_FLAG ((uint32_t)0x00000002)
54#define I2C_TDC_FLAG ((uint32_t)0x00000004)
55#define I2C_ADDRHF_FLAG ((uint32_t)0x00000008)
56#define I2C_STOPF_FLAG ((uint32_t)0x00000010)
57#define I2C_RDBF_FLAG ((uint32_t)0x00000040)
58#define I2C_TDBE_FLAG ((uint32_t)0x00000080)
59#define I2C_BUSERR_FLAG ((uint32_t)0x00000100)
60#define I2C_ARLOST_FLAG ((uint32_t)0x00000200)
61#define I2C_ACKFAIL_FLAG ((uint32_t)0x00000400)
62#define I2C_OUF_FLAG ((uint32_t)0x00000800)
63#define I2C_PECERR_FLAG ((uint32_t)0x00001000)
64#define I2C_TMOUT_FLAG ((uint32_t)0x00004000)
65#define I2C_ALERTF_FLAG ((uint32_t)0x00008000)
76#define I2C_TRMODE_FLAG ((uint32_t)0x10010000)
77#define I2C_BUSYF_FLAG ((uint32_t)0x10020000)
78#define I2C_DIRF_FLAG ((uint32_t)0x10040000)
79#define I2C_GCADDRF_FLAG ((uint32_t)0x10100000)
80#define I2C_DEVADDRF_FLAG ((uint32_t)0x10200000)
81#define I2C_HOSTADDRF_FLAG ((uint32_t)0x10400000)
82#define I2C_ADDR2_FLAG ((uint32_t)0x10800000)
93#define I2C_DATA_INT ((uint16_t)0x0400)
94#define I2C_EVT_INT ((uint16_t)0x0200)
95#define I2C_ERR_INT ((uint16_t)0x0100)
108typedef enum
109{
110 I2C_MASTER_ACK_CURRENT = 0x00,
111 I2C_MASTER_ACK_NEXT = 0x01
112} i2c_master_ack_type;
113
117typedef enum
118{
119 I2C_PEC_POSITION_CURRENT = 0x00,
120 I2C_PEC_POSITION_NEXT = 0x01
121} i2c_pec_position_type;
122
123
127typedef enum
128{
129 I2C_SMBUS_ALERT_HIGH = 0x00,
130 I2C_SMBUS_ALERT_LOW = 0x01
131} i2c_smbus_alert_set_type;
132
136typedef enum
137{
138 I2C_SMBUS_MODE_DEVICE = 0x00,
139 I2C_SMBUS_MODE_HOST = 0x01
140} i2c_smbus_mode_set_type;
141
142
146typedef enum
147{
148 I2C_FSMODE_DUTY_2_1 = 0x00,
149 I2C_FSMODE_DUTY_16_9 = 0x01
150} i2c_fsmode_duty_cycle_type;
151
155typedef enum
156{
157 I2C_ADDRESS_MODE_7BIT = 0x00,
158 I2C_ADDRESS_MODE_10BIT = 0x01
159} i2c_address_mode_type;
160
164typedef enum
165{
166 I2C_DIRECTION_TRANSMIT = 0x00,
167 I2C_DIRECTION_RECEIVE = 0x01
168} i2c_direction_type;
169
173typedef struct
174{
178 union
179 {
180 __IO uint32_t ctrl1;
181 struct
182 {
183 __IO uint32_t i2cen : 1; /* [0] */
184 __IO uint32_t permode : 1; /* [1] */
185 __IO uint32_t reserved1 : 1; /* [2] */
186 __IO uint32_t smbmode : 1; /* [3] */
187 __IO uint32_t arpen : 1; /* [4] */
188 __IO uint32_t pecen : 1; /* [5] */
189 __IO uint32_t gcaen : 1; /* [6] */
190 __IO uint32_t stretch : 1; /* [7] */
191 __IO uint32_t genstart : 1; /* [8] */
192 __IO uint32_t genstop : 1; /* [9] */
193 __IO uint32_t acken : 1; /* [10] */
194 __IO uint32_t mackctrl : 1; /* [11] */
195 __IO uint32_t pecten : 1; /* [12] */
196 __IO uint32_t smbalert : 1; /* [13] */
197 __IO uint32_t reserved2 : 1; /* [14] */
198 __IO uint32_t reset : 1; /* [15] */
199 __IO uint32_t reserved3 : 16;/* [31:16] */
200 } ctrl1_bit;
201 };
202
206 union
207 {
208 __IO uint32_t ctrl2;
209 struct
210 {
211 __IO uint32_t clkfreq : 8; /* [7:0] */
212 __IO uint32_t errien : 1; /* [8] */
213 __IO uint32_t evtien : 1; /* [9] */
214 __IO uint32_t dataien : 1; /* [10] */
215 __IO uint32_t dmaen : 1; /* [11] */
216 __IO uint32_t dmaend : 1; /* [12] */
217 __IO uint32_t reserved1 : 19;/* [31:13] */
218 } ctrl2_bit;
219 };
220
224 union
225 {
226 __IO uint32_t oaddr1;
227 struct
228 {
229 __IO uint32_t addr1 : 10;/* [9:0] */
230 __IO uint32_t reserved1 : 5; /* [14:10] */
231 __IO uint32_t addr1mode : 1; /* [15] */
232 __IO uint32_t reserved2 : 16;/* [31:16] */
233 } oaddr1_bit;
234 };
235
239 union
240 {
241 __IO uint32_t oaddr2;
242 struct
243 {
244 __IO uint32_t addr2en : 1; /* [0] */
245 __IO uint32_t addr2 : 7; /* [7:1] */
246 __IO uint32_t reserved1 : 24;/* [31:8] */
247 } oaddr2_bit;
248 };
249
253 union
254 {
255 __IO uint32_t dt;
256 struct
257 {
258 __IO uint32_t dt : 8; /* [7:0] */
259 __IO uint32_t reserved1 : 24;/* [31:8] */
260 } dt_bit;
261 };
262
266 union
267 {
268 __IO uint32_t sts1;
269 struct
270 {
271 __IO uint32_t startf : 1; /* [0] */
272 __IO uint32_t addr7f : 1; /* [1] */
273 __IO uint32_t tdc : 1; /* [2] */
274 __IO uint32_t addrhf : 1; /* [3] */
275 __IO uint32_t stopf : 1; /* [4] */
276 __IO uint32_t reserved1 : 1; /* [5] */
277 __IO uint32_t rdbf : 1; /* [6] */
278 __IO uint32_t tdbe : 1; /* [7] */
279 __IO uint32_t buserr : 1; /* [8] */
280 __IO uint32_t arlost : 1; /* [9] */
281 __IO uint32_t ackfail : 1; /* [10] */
282 __IO uint32_t ouf : 1; /* [11] */
283 __IO uint32_t pecerr : 1; /* [12] */
284 __IO uint32_t reserved2 : 1; /* [13] */
285 __IO uint32_t tmout : 1; /* [14] */
286 __IO uint32_t alertf : 1; /* [15] */
287 __IO uint32_t reserved3 : 16; /* [31:16] */
288 } sts1_bit;
289 };
290
294 union
295 {
296 __IO uint32_t sts2;
297 struct
298 {
299 __IO uint32_t trmode : 1; /* [0] */
300 __IO uint32_t busyf : 1; /* [1] */
301 __IO uint32_t dirf : 1; /* [2] */
302 __IO uint32_t reserved1 : 1; /* [3] */
303 __IO uint32_t gcaddrf : 1; /* [4] */
304 __IO uint32_t devaddrf : 1; /* [5] */
305 __IO uint32_t hostaddrf : 1; /* [6] */
306 __IO uint32_t addr2 : 1; /* [7] */
307 __IO uint32_t pecval : 8; /* [15:8] */
308 __IO uint32_t reserved2 : 16;/* [31:16] */
309 } sts2_bit;
310 };
311
315 union
316 {
317 __IO uint32_t clkctrl;
318 struct
319 {
320 __IO uint32_t speed : 12;/* [11:0] */
321 __IO uint32_t reserved1 : 2; /* [13:12] */
322 __IO uint32_t dutymode : 1; /* [14] */
323 __IO uint32_t speedmode : 1; /* [15] */
324 __IO uint32_t reserved2 : 16;/* [31:16] */
325 } clkctrl_bit;
326 };
327
331 union
332 {
333 __IO uint32_t tmrise;
334 struct
335 {
336 __IO uint32_t risetime : 6; /* [5:0] */
337 __IO uint32_t reserved1 : 26;/* [31:6] */
338 } tmrise_bit;
339 };
340
341} i2c_type;
342
347#define I2C1 ((i2c_type *) I2C1_BASE)
348#define I2C2 ((i2c_type *) I2C2_BASE)
349
354void i2c_reset(i2c_type *i2c_x);
355void i2c_software_reset(i2c_type *i2c_x, confirm_state new_state);
356void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed);
357void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address);
358void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address);
359void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state);
360void i2c_smbus_enable(i2c_type *i2c_x, confirm_state new_state);
361void i2c_enable(i2c_type *i2c_x, confirm_state new_state);
362void i2c_fast_mode_duty_set(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty);
363void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state);
364void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state);
365void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos);
366void i2c_pec_position_set(i2c_type *i2c_x, i2c_pec_position_type pos);
367void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state);
368void i2c_arp_mode_enable(i2c_type *i2c_x, confirm_state new_state);
369void i2c_smbus_mode_set(i2c_type *i2c_x, i2c_smbus_mode_set_type mode);
370void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level);
371void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state);
372void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state);
373uint8_t i2c_pec_value_get(i2c_type *i2c_x);
374void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state);
375void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state);
376void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state);
377void i2c_start_generate(i2c_type *i2c_x);
378void i2c_stop_generate(i2c_type *i2c_x);
379void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction);
380void i2c_data_send(i2c_type *i2c_x, uint8_t data);
381uint8_t i2c_data_receive(i2c_type *i2c_x);
382 flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag);
383void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag);
384
397#ifdef __cplusplus
398}
399#endif
400
401#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
i2c_pec_position_set
void i2c_pec_position_set(i2c_type *i2c_x, i2c_pec_position_type pos)
pec position set.
Definition: at32f413_i2c.c:315
i2c_pec_transmit_enable
void i2c_pec_transmit_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec transfer.
Definition: at32f413_i2c.c:386
i2c_arp_mode_enable
void i2c_arp_mode_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable arp mode.
Definition: at32f413_i2c.c:341
i2c_data_receive
uint8_t i2c_data_receive(i2c_type *i2c_x)
receive a byte through the i2c periph.
Definition: at32f413_i2c.c:535
i2c_reset
void i2c_reset(i2c_type *i2c_x)
reset the i2c register
Definition: at32f413_i2c.c:51
i2c_smbus_alert_set
void i2c_smbus_alert_set(i2c_type *i2c_x, i2c_smbus_alert_set_type level)
drive the smbus alert pin high or low.
Definition: at32f413_i2c.c:373
i2c_smbus_enable
void i2c_smbus_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable the smbus mode
Definition: at32f413_i2c.c:228
i2c_pec_value_get
uint8_t i2c_pec_value_get(i2c_type *i2c_x)
get pec value.
Definition: at32f413_i2c.c:411
i2c_software_reset
void i2c_software_reset(i2c_type *i2c_x, confirm_state new_state)
software reset.
Definition: at32f413_i2c.c:73
i2c_general_call_enable
void i2c_general_call_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable general call.
Definition: at32f413_i2c.c:328
i2c_ack_enable
void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge.
Definition: at32f413_i2c.c:283
i2c_own_address2_set
void i2c_own_address2_set(i2c_type *i2c_x, uint8_t address)
config own address2.
Definition: at32f413_i2c.c:202
i2c_7bit_address_send
void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address.
Definition: at32f413_i2c.c:503
i2c_dma_end_transfer_set
void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one.
Definition: at32f413_i2c.c:424
i2c_own_address2_enable
void i2c_own_address2_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable own address2.
Definition: at32f413_i2c.c:215
i2c_pec_calculate_enable
void i2c_pec_calculate_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable pec calcultetion.
Definition: at32f413_i2c.c:399
i2c_stop_generate
void i2c_stop_generate(i2c_type *i2c_x)
generate stop condition.
Definition: at32f413_i2c.c:486
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:185
i2c_enable
void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph
Definition: at32f413_i2c.c:241
i2c_fast_mode_duty_set
void i2c_fast_mode_duty_set(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty)
config fast mode duty cycle
Definition: at32f413_i2c.c:257
i2c_flag_get
flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
get flag status
Definition: at32f413_i2c.c:570
i2c_smbus_mode_set
void i2c_smbus_mode_set(i2c_type *i2c_x, i2c_smbus_mode_set_type mode)
config smbus host or device.
Definition: at32f413_i2c.c:357
i2c_interrupt_enable
void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt
Definition: at32f413_i2c.c:455
i2c_flag_clear
void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
clear flag status
Definition: at32f413_i2c.c:615
i2c_dma_enable
void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests.
Definition: at32f413_i2c.c:437
i2c_data_send
void i2c_data_send(i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph.
Definition: at32f413_i2c.c:523
i2c_clock_stretch_enable
void i2c_clock_stretch_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable clock stretch.
Definition: at32f413_i2c.c:270
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:90
i2c_master_receive_ack_set
void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control.
Definition: at32f413_i2c.c:299
i2c_start_generate
void i2c_start_generate(i2c_type *i2c_x)
generate start condition.
Definition: at32f413_i2c.c:474
i2c_fsmode_duty_cycle_type
i2c_fsmode_duty_cycle_type
i2c fast mode duty cycle
Definition: at32f413_i2c.h:147
i2c_smbus_mode_set_type
i2c_smbus_mode_set_type
i2c smbus mode set
Definition: at32f413_i2c.h:137
i2c_direction_type
i2c_direction_type
i2c address direction
Definition: at32f413_i2c.h:165
i2c_master_ack_type
i2c_master_ack_type
i2c master receiving mode acknowledge control
Definition: at32f413_i2c.h:109
i2c_address_mode_type
i2c_address_mode_type
i2c address mode
Definition: at32f413_i2c.h:156
i2c_smbus_alert_set_type
i2c_smbus_alert_set_type
i2c smbus alert pin set
Definition: at32f413_i2c.h:128
i2c_pec_position_type
i2c_pec_position_type
i2c pec position set
Definition: at32f413_i2c.h:118
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:148
I2C_FSMODE_DUTY_16_9
@ I2C_FSMODE_DUTY_16_9
Definition: at32f413_i2c.h:149
I2C_SMBUS_MODE_HOST
@ I2C_SMBUS_MODE_HOST
Definition: at32f413_i2c.h:139
I2C_SMBUS_MODE_DEVICE
@ I2C_SMBUS_MODE_DEVICE
Definition: at32f413_i2c.h:138
I2C_DIRECTION_RECEIVE
@ I2C_DIRECTION_RECEIVE
Definition: at32f413_i2c.h:167
I2C_DIRECTION_TRANSMIT
@ I2C_DIRECTION_TRANSMIT
Definition: at32f413_i2c.h:166
I2C_MASTER_ACK_CURRENT
@ I2C_MASTER_ACK_CURRENT
Definition: at32f413_i2c.h:110
I2C_MASTER_ACK_NEXT
@ I2C_MASTER_ACK_NEXT
Definition: at32f413_i2c.h:111
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:157
I2C_ADDRESS_MODE_10BIT
@ I2C_ADDRESS_MODE_10BIT
Definition: at32f413_i2c.h:158
I2C_SMBUS_ALERT_HIGH
@ I2C_SMBUS_ALERT_HIGH
Definition: at32f413_i2c.h:129
I2C_SMBUS_ALERT_LOW
@ I2C_SMBUS_ALERT_LOW
Definition: at32f413_i2c.h:130
I2C_PEC_POSITION_NEXT
@ I2C_PEC_POSITION_NEXT
Definition: at32f413_i2c.h:120
I2C_PEC_POSITION_CURRENT
@ I2C_PEC_POSITION_CURRENT
Definition: at32f413_i2c.h:119
i2c_type
type define i2c register all
Definition: at32f413_i2c.h:174
i2c_type::smbalert
__IO uint32_t smbalert
Definition: at32f413_i2c.h:196
i2c_type::dmaend
__IO uint32_t dmaend
Definition: at32f413_i2c.h:216
i2c_type::genstop
__IO uint32_t genstop
Definition: at32f413_i2c.h:192
i2c_type::tmrise
__IO uint32_t tmrise
Definition: at32f413_i2c.h:333
i2c_type::tdc
__IO uint32_t tdc
Definition: at32f413_i2c.h:273
i2c_type::addr2en
__IO uint32_t addr2en
Definition: at32f413_i2c.h:244
i2c_type::pecerr
__IO uint32_t pecerr
Definition: at32f413_i2c.h:283
i2c_type::dmaen
__IO uint32_t dmaen
Definition: at32f413_i2c.h:215
i2c_type::gcaen
__IO uint32_t gcaen
Definition: at32f413_i2c.h:189
i2c_type::clkfreq
__IO uint32_t clkfreq
Definition: at32f413_i2c.h:211
i2c_type::addr2
__IO uint32_t addr2
Definition: at32f413_i2c.h:245
i2c_type::buserr
__IO uint32_t buserr
Definition: at32f413_i2c.h:279
i2c_type::tmout
__IO uint32_t tmout
Definition: at32f413_i2c.h:285
i2c_type::stopf
__IO uint32_t stopf
Definition: at32f413_i2c.h:275
i2c_type::sts1
__IO uint32_t sts1
Definition: at32f413_i2c.h:268
i2c_type::risetime
__IO uint32_t risetime
Definition: at32f413_i2c.h:336
i2c_type::hostaddrf
__IO uint32_t hostaddrf
Definition: at32f413_i2c.h:305
i2c_type::dirf
__IO uint32_t dirf
Definition: at32f413_i2c.h:301
i2c_type::permode
__IO uint32_t permode
Definition: at32f413_i2c.h:184
i2c_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_i2c.h:185
i2c_type::genstart
__IO uint32_t genstart
Definition: at32f413_i2c.h:191
i2c_type::speedmode
__IO uint32_t speedmode
Definition: at32f413_i2c.h:323
i2c_type::pecten
__IO uint32_t pecten
Definition: at32f413_i2c.h:195
i2c_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_i2c.h:208
i2c_type::speed
__IO uint32_t speed
Definition: at32f413_i2c.h:320
i2c_type::trmode
__IO uint32_t trmode
Definition: at32f413_i2c.h:299
i2c_type::ouf
__IO uint32_t ouf
Definition: at32f413_i2c.h:282
i2c_type::arlost
__IO uint32_t arlost
Definition: at32f413_i2c.h:280
i2c_type::stretch
__IO uint32_t stretch
Definition: at32f413_i2c.h:190
i2c_type::dutymode
__IO uint32_t dutymode
Definition: at32f413_i2c.h:322
i2c_type::arpen
__IO uint32_t arpen
Definition: at32f413_i2c.h:187
i2c_type::dataien
__IO uint32_t dataien
Definition: at32f413_i2c.h:214
i2c_type::startf
__IO uint32_t startf
Definition: at32f413_i2c.h:271
i2c_type::addr1mode
__IO uint32_t addr1mode
Definition: at32f413_i2c.h:231
i2c_type::tdbe
__IO uint32_t tdbe
Definition: at32f413_i2c.h:278
i2c_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_i2c.h:197
i2c_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_i2c.h:199
i2c_type::reset
__IO uint32_t reset
Definition: at32f413_i2c.h:198
i2c_type::pecval
__IO uint32_t pecval
Definition: at32f413_i2c.h:307
i2c_type::addrhf
__IO uint32_t addrhf
Definition: at32f413_i2c.h:274
i2c_type::addr7f
__IO uint32_t addr7f
Definition: at32f413_i2c.h:272
i2c_type::dt
__IO uint32_t dt
Definition: at32f413_i2c.h:255
i2c_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_i2c.h:180
i2c_type::ackfail
__IO uint32_t ackfail
Definition: at32f413_i2c.h:281
i2c_type::acken
__IO uint32_t acken
Definition: at32f413_i2c.h:193
i2c_type::i2cen
__IO uint32_t i2cen
Definition: at32f413_i2c.h:183
i2c_type::rdbf
__IO uint32_t rdbf
Definition: at32f413_i2c.h:277
i2c_type::busyf
__IO uint32_t busyf
Definition: at32f413_i2c.h:300
i2c_type::oaddr1
__IO uint32_t oaddr1
Definition: at32f413_i2c.h:226
i2c_type::errien
__IO uint32_t errien
Definition: at32f413_i2c.h:212
i2c_type::addr1
__IO uint32_t addr1
Definition: at32f413_i2c.h:229
i2c_type::sts2
__IO uint32_t sts2
Definition: at32f413_i2c.h:296
i2c_type::evtien
__IO uint32_t evtien
Definition: at32f413_i2c.h:213
i2c_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f413_i2c.h:317
i2c_type::mackctrl
__IO uint32_t mackctrl
Definition: at32f413_i2c.h:194
i2c_type::oaddr2
__IO uint32_t oaddr2
Definition: at32f413_i2c.h:241
i2c_type::pecen
__IO uint32_t pecen
Definition: at32f413_i2c.h:188
i2c_type::gcaddrf
__IO uint32_t gcaddrf
Definition: at32f413_i2c.h:303
i2c_type::smbmode
__IO uint32_t smbmode
Definition: at32f413_i2c.h:186
i2c_type::devaddrf
__IO uint32_t devaddrf
Definition: at32f413_i2c.h:304
i2c_type::alertf
__IO uint32_t alertf
Definition: at32f413_i2c.h:286


AT32F413 Firmwary Library: at32f413_misc.c Source File

  • libraries
  • drivers
  • src
at32f413_misc.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_conf.h"
29
39#ifdef MISC_MODULE_ENABLED
40
45#define AIRCR_VECTKEY_MASK ((uint32_t)0x05FA0000)
46
52void nvic_system_reset(void)
53{
54 NVIC_SystemReset();
55}
56
64void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
65{
66 uint32_t temp_priority = 0;
67
68 /* encode priority */
69 temp_priority = NVIC_EncodePriority(NVIC_GetPriorityGrouping(), preempt_priority, sub_priority);
70 /* set priority */
71 NVIC_SetPriority(irqn, temp_priority);
72 /* enable irqn */
73 NVIC_EnableIRQ(irqn);
74}
75
81void nvic_irq_disable(IRQn_Type irqn)
82{
83 NVIC_DisableIRQ(irqn);
84}
85
97void nvic_priority_group_config(nvic_priority_group_type priority_group)
98{
99 /* set the prigroup[10:8] bits according to nvic_prioritygroup value */
100 NVIC_SetPriorityGrouping(priority_group);
101}
102
112void nvic_vector_table_set(uint32_t base, uint32_t offset)
113{
114 SCB->VTOR = base | (offset & (uint32_t)0x1FFFFF80);
115}
116
127void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state)
128{
129 if(new_state != FALSE)
130 {
131 SCB->SCR |= lp_mode;
132 }
133 else
134 {
135 SCB->SCR &= (uint32_t)(~(uint32_t)lp_mode);
136 }
137}
138
147void systick_clock_source_config(systick_clock_source_type source)
148{
149 if(source == SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV)
150 {
151 SysTick->CTRL |= SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV;
152 }
153 else
154 {
155 SysTick->CTRL &= ~(uint32_t)SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV;
156 }
157}
158
163#endif
164
IRQn_Type
enum IRQn IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_secti...
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
FALSE
@ FALSE
Definition: at32f413.h:259
nvic_lowpower_mode_type
nvic_lowpower_mode_type
nvic low power mode
Definition: at32f413_misc.h:78
nvic_priority_group_type
nvic_priority_group_type
nvic interrupt priority group
Definition: at32f413_misc.h:66
systick_clock_source_type
systick_clock_source_type
systick clock source
Definition: at32f413_misc.h:88
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f413_misc.h:90
nvic_lowpower_mode_config
void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode
Definition: at32f413_misc.c:127
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:52
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:112
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f413_misc.c:81
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f413_misc.c:147
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_misc.h Source File

  • libraries
  • drivers
  • inc
at32f413_misc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_MISC_H
29#define __AT32F413_MISC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
51#define NVIC_VECTTAB_RAM ((uint32_t)0x20000000)
52#define NVIC_VECTTAB_FLASH ((uint32_t)0x08000000)
65typedef enum
66{
67 NVIC_PRIORITY_GROUP_0 = ((uint32_t)0x7),
68 NVIC_PRIORITY_GROUP_1 = ((uint32_t)0x6),
69 NVIC_PRIORITY_GROUP_2 = ((uint32_t)0x5),
70 NVIC_PRIORITY_GROUP_3 = ((uint32_t)0x4),
71 NVIC_PRIORITY_GROUP_4 = ((uint32_t)0x3)
72} nvic_priority_group_type;
73
77typedef enum
78{
79 NVIC_LP_SLEEPONEXIT = 0x02,
80 NVIC_LP_SLEEPDEEP = 0x04,
81 NVIC_LP_SEVONPEND = 0x10
82} nvic_lowpower_mode_type;
83
87typedef enum
88{
89 SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8 = ((uint32_t)0x00000000),
90 SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV = ((uint32_t)0x00000004)
91} systick_clock_source_type;
92
101void nvic_system_reset(void);
102void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority);
103void nvic_irq_disable(IRQn_Type irqn);
104void nvic_priority_group_config(nvic_priority_group_type priority_group);
105void nvic_vector_table_set(uint32_t base, uint32_t offset);
106void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state);
107void systick_clock_source_config(systick_clock_source_type source);
108
121#ifdef __cplusplus
122}
123#endif
124
125#endif
at32f413.h
at32f413 header file
IRQn_Type
enum IRQn IRQn_Type
at32f413 interrupt number definition, according to the selected device in Library_configuration_secti...
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
nvic_lowpower_mode_config
void nvic_lowpower_mode_config(nvic_lowpower_mode_type lp_mode, confirm_state new_state)
config nvic lowpower mode
Definition: at32f413_misc.c:127
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:52
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:112
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f413_misc.c:81
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f413_misc.c:147
nvic_lowpower_mode_type
nvic_lowpower_mode_type
nvic low power mode
Definition: at32f413_misc.h:78
nvic_priority_group_type
nvic_priority_group_type
nvic interrupt priority group
Definition: at32f413_misc.h:66
systick_clock_source_type
systick_clock_source_type
systick clock source
Definition: at32f413_misc.h:88
NVIC_LP_SEVONPEND
@ NVIC_LP_SEVONPEND
Definition: at32f413_misc.h:81
NVIC_LP_SLEEPONEXIT
@ NVIC_LP_SLEEPONEXIT
Definition: at32f413_misc.h:79
NVIC_LP_SLEEPDEEP
@ NVIC_LP_SLEEPDEEP
Definition: at32f413_misc.h:80
NVIC_PRIORITY_GROUP_1
@ NVIC_PRIORITY_GROUP_1
Definition: at32f413_misc.h:68
NVIC_PRIORITY_GROUP_3
@ NVIC_PRIORITY_GROUP_3
Definition: at32f413_misc.h:70
NVIC_PRIORITY_GROUP_2
@ NVIC_PRIORITY_GROUP_2
Definition: at32f413_misc.h:69
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
NVIC_PRIORITY_GROUP_0
@ NVIC_PRIORITY_GROUP_0
Definition: at32f413_misc.h:67
SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
@ SYSTICK_CLOCK_SOURCE_AHBCLK_DIV8
Definition: at32f413_misc.h:89
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f413_misc.h:90


AT32F413 Firmwary Library: at32f413_pwc.c Source File

  • libraries
  • drivers
  • src
at32f413_pwc.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef PWC_MODULE_ENABLED
39
49void pwc_reset(void)
50{
51 crm_periph_reset(CRM_PWC_PERIPH_RESET, TRUE);
52 crm_periph_reset(CRM_PWC_PERIPH_RESET, FALSE);
53}
54
61void pwc_battery_powered_domain_access(confirm_state new_state)
62{
63 PWC->ctrl_bit.bpwen = new_state;
64}
65
79void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
80{
81 PWC->ctrl_bit.pvmsel = pvm_voltage;
82}
83
90void pwc_power_voltage_monitor_enable(confirm_state new_state)
91{
92 PWC->ctrl_bit.pvmen = new_state;
93}
94
106void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
107{
108 if(new_state == TRUE)
109 {
110 PWC->ctrlsts |= pin_num;
111 }
112 else
113 {
114 PWC->ctrlsts &= ~pin_num;
115 }
116}
117
127void pwc_flag_clear(uint32_t pwc_flag)
128{
129 if(pwc_flag & PWC_STANDBY_FLAG)
130 PWC->ctrl_bit.clsef = TRUE;
131 if(pwc_flag & PWC_WAKEUP_FLAG)
132 PWC->ctrl_bit.clswef = TRUE;
133}
134
144 flag_status pwc_flag_get(uint32_t pwc_flag)
145{
146 flag_status status = RESET;
147 if ((PWC->ctrlsts & pwc_flag) == RESET)
148 {
149 status = RESET;
150 }
151 else
152 {
153 status = SET;
154 }
155 return status;
156}
157
166void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
167{
168 SCB->SCR &= (uint32_t)~0x4;
169 if(pwc_sleep_enter == PWC_SLEEP_ENTER_WFE)
170 {
171 __SEV();
172 __WFE();
173 __WFE();
174 }
175 else if(pwc_sleep_enter == PWC_SLEEP_ENTER_WFI)
176 {
177 __WFI();
178 }
179}
180
189void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
190{
191 SCB->SCR |= 0x04;
192 if(pwc_deep_sleep_enter == PWC_DEEP_SLEEP_ENTER_WFE)
193 {
194 __SEV();
195 __WFE();
196 __WFE();
197 }
198 else if(pwc_deep_sleep_enter == PWC_DEEP_SLEEP_ENTER_WFI)
199 {
200 __WFI();
201 }
202 SCB->SCR &= (uint32_t)~0x4;
203}
204
213void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
214{
215 PWC->ctrl_bit.vrsel = pwc_regulator;
216}
217
223void pwc_standby_mode_enter(void)
224{
225 PWC->ctrl_bit.clswef = TRUE;
226 PWC->ctrl_bit.lpsel = TRUE;
227 SCB->SCR |= 0x04;
228#if defined (__CC_ARM)
229 __force_stores();
230#endif
231 __WFI();
232}
233
238#endif
239
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
CRM_PWC_PERIPH_RESET
@ CRM_PWC_PERIPH_RESET
Definition: at32f413_crm.h:185
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
pwc_pvm_voltage_type
pwc_pvm_voltage_type
pwc pvm voltage type
Definition: at32f413_pwc.h:73
pwc_regulator_type
pwc_regulator_type
pwc regulator type
Definition: at32f413_pwc.h:105
pwc_deep_sleep_enter_type
pwc_deep_sleep_enter_type
pwc deep sleep enter type
Definition: at32f413_pwc.h:96
pwc_sleep_enter_type
pwc_sleep_enter_type
pwc sleep enter type
Definition: at32f413_pwc.h:87
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:97
PWC_DEEP_SLEEP_ENTER_WFE
@ PWC_DEEP_SLEEP_ENTER_WFE
Definition: at32f413_pwc.h:98
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:88
PWC_SLEEP_ENTER_WFE
@ PWC_SLEEP_ENTER_WFE
Definition: at32f413_pwc.h:89
PWC_STANDBY_FLAG
#define PWC_STANDBY_FLAG
Definition: at32f413_pwc.h:53
PWC_WAKEUP_FLAG
#define PWC_WAKEUP_FLAG
Definition: at32f413_pwc.h:52
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:61
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f413_pwc.c:213
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:223
pwc_power_voltage_monitor_enable
void pwc_power_voltage_monitor_enable(confirm_state new_state)
enable or disable pwc power voltage monitor (pvm)
Definition: at32f413_pwc.c:90
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f413_pwc.c:166
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:189
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f413_pwc.c:144
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f413_pwc.c:127
pwc_pvm_level_select
void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector.
Definition: at32f413_pwc.c:79
pwc_reset
void pwc_reset(void)
deinitialize the pwc peripheral registers to their default reset values.
Definition: at32f413_pwc.c:49
pwc_wakeup_pin_enable
void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin
Definition: at32f413_pwc.c:106
PWC
#define PWC
Definition: at32f413_pwc.h:157
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_pwc.h Source File

  • libraries
  • drivers
  • inc
at32f413_pwc.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_PWC_H
29#define __AT32F413_PWC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define PWC_WAKEUP_FLAG ((uint32_t)0x00000001)
53#define PWC_STANDBY_FLAG ((uint32_t)0x00000002)
54#define PWC_PVM_OUTPUT_FLAG ((uint32_t)0x00000004)
63#define PWC_WAKEUP_PIN_1 ((uint32_t)0x00000100)
72typedef enum
73{
74 PWC_PVM_VOLTAGE_2V3 = 0x01,
75 PWC_PVM_VOLTAGE_2V4 = 0x02,
76 PWC_PVM_VOLTAGE_2V5 = 0x03,
77 PWC_PVM_VOLTAGE_2V6 = 0x04,
78 PWC_PVM_VOLTAGE_2V7 = 0x05,
79 PWC_PVM_VOLTAGE_2V8 = 0x06,
80 PWC_PVM_VOLTAGE_2V9 = 0x07
81} pwc_pvm_voltage_type;
82
86typedef enum
87{
88 PWC_SLEEP_ENTER_WFI = 0x00,
89 PWC_SLEEP_ENTER_WFE = 0x01
90} pwc_sleep_enter_type;
91
95typedef enum
96{
97 PWC_DEEP_SLEEP_ENTER_WFI = 0x00,
98 PWC_DEEP_SLEEP_ENTER_WFE = 0x01
99} pwc_deep_sleep_enter_type;
100
104typedef enum
105{
106 PWC_REGULATOR_ON = 0x00,
107 PWC_REGULATOR_LOW_POWER = 0x01
108} pwc_regulator_type;
109
113typedef struct
114{
118 union
119 {
120 __IO uint32_t ctrl;
121 struct
122 {
123 __IO uint32_t vrsel : 1; /* [0] */
124 __IO uint32_t lpsel : 1; /* [1] */
125 __IO uint32_t clswef : 1; /* [2] */
126 __IO uint32_t clsef : 1; /* [3] */
127 __IO uint32_t pvmen : 1; /* [4] */
128 __IO uint32_t pvmsel : 3; /* [7:5] */
129 __IO uint32_t bpwen : 1; /* [8] */
130 __IO uint32_t reserved1 : 23;/* [31:9] */
131 } ctrl_bit;
132 };
133
137 union
138 {
139 __IO uint32_t ctrlsts;
140 struct
141 {
142 __IO uint32_t swef : 1; /* [0] */
143 __IO uint32_t sef : 1; /* [1] */
144 __IO uint32_t pvmof : 1; /* [2] */
145 __IO uint32_t reserved1 : 5; /* [7:3] */
146 __IO uint32_t swpen : 1; /* [8] */
147 __IO uint32_t reserved2 : 23;/* [31:9] */
148 } ctrlsts_bit;
149 };
150
151} pwc_type;
152
157#define PWC ((pwc_type *) PWC_BASE)
158
163void pwc_reset(void);
164void pwc_battery_powered_domain_access(confirm_state new_state);
165void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage);
166void pwc_power_voltage_monitor_enable(confirm_state new_state);
167void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state);
168void pwc_flag_clear(uint32_t pwc_flag);
169 flag_status pwc_flag_get(uint32_t pwc_flag);
170void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter);
171void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter);
172void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator);
173void pwc_standby_mode_enter(void);
174
187#ifdef __cplusplus
188}
189#endif
190
191#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:61
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f413_pwc.c:213
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:223
pwc_power_voltage_monitor_enable
void pwc_power_voltage_monitor_enable(confirm_state new_state)
enable or disable pwc power voltage monitor (pvm)
Definition: at32f413_pwc.c:90
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f413_pwc.c:166
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:189
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f413_pwc.c:144
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f413_pwc.c:127
pwc_pvm_level_select
void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector.
Definition: at32f413_pwc.c:79
pwc_reset
void pwc_reset(void)
deinitialize the pwc peripheral registers to their default reset values.
Definition: at32f413_pwc.c:49
pwc_wakeup_pin_enable
void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin
Definition: at32f413_pwc.c:106
pwc_pvm_voltage_type
pwc_pvm_voltage_type
pwc pvm voltage type
Definition: at32f413_pwc.h:73
pwc_regulator_type
pwc_regulator_type
pwc regulator type
Definition: at32f413_pwc.h:105
pwc_deep_sleep_enter_type
pwc_deep_sleep_enter_type
pwc deep sleep enter type
Definition: at32f413_pwc.h:96
pwc_sleep_enter_type
pwc_sleep_enter_type
pwc sleep enter type
Definition: at32f413_pwc.h:87
PWC_PVM_VOLTAGE_2V7
@ PWC_PVM_VOLTAGE_2V7
Definition: at32f413_pwc.h:78
PWC_PVM_VOLTAGE_2V3
@ PWC_PVM_VOLTAGE_2V3
Definition: at32f413_pwc.h:74
PWC_PVM_VOLTAGE_2V8
@ PWC_PVM_VOLTAGE_2V8
Definition: at32f413_pwc.h:79
PWC_PVM_VOLTAGE_2V4
@ PWC_PVM_VOLTAGE_2V4
Definition: at32f413_pwc.h:75
PWC_PVM_VOLTAGE_2V5
@ PWC_PVM_VOLTAGE_2V5
Definition: at32f413_pwc.h:76
PWC_PVM_VOLTAGE_2V6
@ PWC_PVM_VOLTAGE_2V6
Definition: at32f413_pwc.h:77
PWC_PVM_VOLTAGE_2V9
@ PWC_PVM_VOLTAGE_2V9
Definition: at32f413_pwc.h:80
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f413_pwc.h:107
PWC_REGULATOR_ON
@ PWC_REGULATOR_ON
Definition: at32f413_pwc.h:106
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:97
PWC_DEEP_SLEEP_ENTER_WFE
@ PWC_DEEP_SLEEP_ENTER_WFE
Definition: at32f413_pwc.h:98
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:88
PWC_SLEEP_ENTER_WFE
@ PWC_SLEEP_ENTER_WFE
Definition: at32f413_pwc.h:89
pwc_type
type define pwc register all
Definition: at32f413_pwc.h:114
pwc_type::bpwen
__IO uint32_t bpwen
Definition: at32f413_pwc.h:129
pwc_type::clswef
__IO uint32_t clswef
Definition: at32f413_pwc.h:125
pwc_type::pvmof
__IO uint32_t pvmof
Definition: at32f413_pwc.h:144
pwc_type::lpsel
__IO uint32_t lpsel
Definition: at32f413_pwc.h:124
pwc_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_pwc.h:130
pwc_type::vrsel
__IO uint32_t vrsel
Definition: at32f413_pwc.h:123
pwc_type::pvmen
__IO uint32_t pvmen
Definition: at32f413_pwc.h:127
pwc_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_pwc.h:120
pwc_type::swef
__IO uint32_t swef
Definition: at32f413_pwc.h:142
pwc_type::clsef
__IO uint32_t clsef
Definition: at32f413_pwc.h:126
pwc_type::ctrlsts
__IO uint32_t ctrlsts
Definition: at32f413_pwc.h:139
pwc_type::sef
__IO uint32_t sef
Definition: at32f413_pwc.h:143
pwc_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_pwc.h:147
pwc_type::swpen
__IO uint32_t swpen
Definition: at32f413_pwc.h:146
pwc_type::pvmsel
__IO uint32_t pvmsel
Definition: at32f413_pwc.h:128


AT32F413 Firmwary Library: at32f413_rtc.c Source File

  • libraries
  • drivers
  • src
at32f413_rtc.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef RTC_MODULE_ENABLED
39
49void rtc_counter_set(uint32_t counter_value)
50{
51 /* enter rtc config mode */
52 RTC->ctrll = 0x003F;
53
54 /* set rtc counter */
55 RTC->cnth_bit.cnt = (uint16_t)(counter_value >> 16);
56 RTC->cntl_bit.cnt = (uint16_t)(counter_value & 0x0000FFFF);
57
58 /* exit rtc config mode */
59 RTC->ctrll = 0x000F;
60}
61
67uint32_t rtc_counter_get(void)
68{
69 uint32_t cnt = 0;
70
71 cnt = RTC->cnth;
72 cnt = (cnt << 16) | RTC->cntl;
73
74 return cnt;
75}
76
82void rtc_divider_set(uint32_t div_value)
83{
84 /* enter rtc config mode */
85 RTC->ctrll = 0x003F;
86
87 /* set rtc divider */
88 RTC->divh_bit.div = (uint16_t)(div_value >> 16);
89 RTC->divl_bit.div = (uint16_t)(div_value & 0x0000FFFF);
90
91 /* exit rtc config mode */
92 RTC->ctrll = 0x000F;
93}
94
100uint32_t rtc_divider_get(void)
101{
102 uint32_t div = 0;
103
104 div = RTC->divcnth;
105 div = (div << 16) | RTC->divcntl;
106
107 return div;
108}
109
115void rtc_alarm_set(uint32_t alarm_value)
116{
117 /* enter rtc config mode */
118 RTC->ctrll = 0x003F;
119
120 /* set rtc alarm value */
121 RTC->tah_bit.ta = (uint16_t)(alarm_value >> 16);
122 RTC->tal_bit.ta = (uint16_t)(alarm_value & 0x0000FFFF);
123
124 /* exit rtc config mode */
125 RTC->ctrll = 0x000F;
126}
127
138void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
139{
140 if(new_state == FALSE)
141 {
142 RTC->ctrlh &= ~source;
143 }
144 else
145 {
146 RTC->ctrlh |= source;
147 }
148}
149
161 flag_status rtc_flag_get(uint16_t flag)
162{
163 flag_status status = RESET;
164
165 if ((RTC->ctrll & flag) != (uint16_t)RESET)
166 {
167 status = SET;
168 }
169 else
170 {
171 status = RESET;
172 }
173
174 return status;
175}
176
187void rtc_flag_clear(uint16_t flag)
188{
189 RTC->ctrll = ~(flag | 0x10) | (RTC->ctrll_bit.cfgen << 4);
190}
191
197void rtc_wait_config_finish(void)
198{
199 while (RTC->ctrll_bit.cfgf == 0);
200}
201
207void rtc_wait_update_finish(void)
208{
209 while (RTC->ctrll_bit.updf == 0);
210}
211
216#endif
217
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:44
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:115
rtc_divider_get
uint32_t rtc_divider_get(void)
rtc divider get
Definition: at32f413_rtc.c:100
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:197
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:161
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:67
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:207
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:138
rtc_counter_set
void rtc_counter_set(uint32_t counter_value)
rtc counter set
Definition: at32f413_rtc.c:49
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:187
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:82
RTC
#define RTC
Definition: at32f413_rtc.h:228
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_rtc.h Source File

  • libraries
  • drivers
  • inc
at32f413_rtc.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_RTC_H
29#define __AT32F413_RTC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define RTC_TS_INT ((uint16_t)0x0001)
53#define RTC_TA_INT ((uint16_t)0x0002)
54#define RTC_OVF_INT ((uint16_t)0x0004)
65#define RTC_TS_FLAG ((uint16_t)0x0001)
66#define RTC_TA_FLAG ((uint16_t)0x0002)
67#define RTC_OVF_FLAG ((uint16_t)0x0004)
68#define RTC_UPDF_FLAG ((uint16_t)0x0008)
69#define RTC_CFGF_FLAG ((uint16_t)0x0020)
82typedef struct
83{
84
88 union
89 {
90 __IO uint32_t ctrlh;
91 struct
92 {
93 __IO uint32_t tsien : 1; /* [0] */
94 __IO uint32_t taien : 1; /* [1] */
95 __IO uint32_t ovfien : 1; /* [2] */
96 __IO uint32_t reserved1 : 29;/* [31:3] */
97 } ctrlh_bit;
98 };
99
103 union
104 {
105 __IO uint32_t ctrll;
106 struct
107 {
108 __IO uint32_t tsf : 1; /* [0] */
109 __IO uint32_t taf : 1; /* [1] */
110 __IO uint32_t ovff : 1; /* [2] */
111 __IO uint32_t updf : 1; /* [3] */
112 __IO uint32_t cfgen : 1; /* [4] */
113 __IO uint32_t cfgf : 1; /* [5] */
114 __IO uint32_t reserved1 : 26;/* [31:6] */
115 } ctrll_bit;
116 };
117
121 union
122 {
123 __IO uint32_t divh;
124 struct
125 {
126 __IO uint32_t div : 4; /* [3:0] */
127 __IO uint32_t reserved1 : 28;/* [31:4] */
128 } divh_bit;
129 };
130
134 union
135 {
136 __IO uint32_t divl;
137 struct
138 {
139 __IO uint32_t div : 16;/* [15:0] */
140 __IO uint32_t reserved1 : 16;/* [31:15] */
141 } divl_bit;
142 };
143
147 union
148 {
149 __IO uint32_t divcnth;
150 struct
151 {
152 __IO uint32_t divcnt : 4; /* [3:0] */
153 __IO uint32_t reserved1 : 28;/* [31:15] */
154 } divcnth_bit;
155 };
156
160 union
161 {
162 __IO uint32_t divcntl;
163 struct
164 {
165 __IO uint32_t divcnt : 16;/* [15:0] */
166 __IO uint32_t reserved1 : 16;/* [31:15] */
167 } divcntl_bit;
168 };
169
173 union
174 {
175 __IO uint32_t cnth;
176 struct
177 {
178 __IO uint32_t cnt : 16;/* [15:0] */
179 __IO uint32_t reserved1 : 16;/* [31:15] */
180 } cnth_bit;
181 };
182
186 union
187 {
188 __IO uint32_t cntl;
189 struct
190 {
191 __IO uint32_t cnt : 16;/* [15:0] */
192 __IO uint32_t reserved1 : 16;/* [31:15] */
193 } cntl_bit;
194 };
195
199 union
200 {
201 __IO uint32_t tah;
202 struct
203 {
204 __IO uint32_t ta : 16;/* [15:0] */
205 __IO uint32_t reserved1 : 16;/* [31:15] */
206 } tah_bit;
207 };
208
212 union
213 {
214 __IO uint32_t tal;
215 struct
216 {
217 __IO uint32_t ta : 16;/* [15:0] */
218 __IO uint32_t reserved1 : 16;/* [31:15] */
219 } tal_bit;
220 };
221
222} rtc_type;
223
228#define RTC ((rtc_type *) RTC_BASE)
229
234void rtc_counter_set(uint32_t counter_value);
235uint32_t rtc_counter_get(void);
236void rtc_divider_set(uint32_t div_value);
237uint32_t rtc_divider_get(void);
238void rtc_alarm_set(uint32_t alarm_value);
239void rtc_interrupt_enable(uint16_t source, confirm_state new_state);
240 flag_status rtc_flag_get(uint16_t flag);
241void rtc_flag_clear(uint16_t flag);
242void rtc_wait_config_finish(void);
243void rtc_wait_update_finish(void);
244
257#ifdef __cplusplus
258}
259#endif
260
261#endif
at32f413.h
at32f413 header file
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:44
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:115
rtc_divider_get
uint32_t rtc_divider_get(void)
rtc divider get
Definition: at32f413_rtc.c:100
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:197
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:161
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:67
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:207
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:138
rtc_counter_set
void rtc_counter_set(uint32_t counter_value)
rtc counter set
Definition: at32f413_rtc.c:49
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:187
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:82
rtc_type
type define rtc register all
Definition: at32f413_rtc.h:83
rtc_type::div
__IO uint32_t div
Definition: at32f413_rtc.h:126
rtc_type::cntl
__IO uint32_t cntl
Definition: at32f413_rtc.h:188
rtc_type::tsien
__IO uint32_t tsien
Definition: at32f413_rtc.h:93
rtc_type::ovff
__IO uint32_t ovff
Definition: at32f413_rtc.h:110
rtc_type::cfgf
__IO uint32_t cfgf
Definition: at32f413_rtc.h:113
rtc_type::ovfien
__IO uint32_t ovfien
Definition: at32f413_rtc.h:95
rtc_type::divl
__IO uint32_t divl
Definition: at32f413_rtc.h:136
rtc_type::cnt
__IO uint32_t cnt
Definition: at32f413_rtc.h:178
rtc_type::taf
__IO uint32_t taf
Definition: at32f413_rtc.h:109
rtc_type::divcnth
__IO uint32_t divcnth
Definition: at32f413_rtc.h:149
rtc_type::ta
__IO uint32_t ta
Definition: at32f413_rtc.h:204
rtc_type::cfgen
__IO uint32_t cfgen
Definition: at32f413_rtc.h:112
rtc_type::cnth
__IO uint32_t cnth
Definition: at32f413_rtc.h:175
rtc_type::ctrll
__IO uint32_t ctrll
Definition: at32f413_rtc.h:105
rtc_type::updf
__IO uint32_t updf
Definition: at32f413_rtc.h:111
rtc_type::tsf
__IO uint32_t tsf
Definition: at32f413_rtc.h:108
rtc_type::divh
__IO uint32_t divh
Definition: at32f413_rtc.h:123
rtc_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_rtc.h:96
rtc_type::tal
__IO uint32_t tal
Definition: at32f413_rtc.h:214
rtc_type::divcnt
__IO uint32_t divcnt
Definition: at32f413_rtc.h:152
rtc_type::divcntl
__IO uint32_t divcntl
Definition: at32f413_rtc.h:162
rtc_type::taien
__IO uint32_t taien
Definition: at32f413_rtc.h:94
rtc_type::tah
__IO uint32_t tah
Definition: at32f413_rtc.h:201
rtc_type::ctrlh
__IO uint32_t ctrlh
Definition: at32f413_rtc.h:90


AT32F413 Firmwary Library: at32f413_sdio.c Source File

  • libraries
  • drivers
  • src
at32f413_sdio.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef SDIO_MODULE_ENABLED
39
51void sdio_reset(sdio_type *sdio_x)
52{
53 sdio_x->pwrctrl = 0x0;
54 sdio_x->clkctrl = 0x0;
55 sdio_x->argu = 0x0;
56 sdio_x->cmdctrl = 0x0;
57 sdio_x->dttmr = 0x0;
58 sdio_x->dtlen = 0x0;
59 sdio_x->dtctrl = 0x0;
60 sdio_x->inten = 0x0;
61 sdio_x->intclr = 0x004007FF;
62}
63
75void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
76{
77 sdio_x->pwrctrl_bit.ps = power_state;
78}
79
87 flag_status sdio_power_status_get(sdio_type *sdio_x)
88{
89 flag_status flag = RESET;
90
91 if(sdio_x->pwrctrl_bit.ps == SDIO_POWER_ON)
92 {
93 flag = SET;
94 }
95 else if(sdio_x->pwrctrl_bit.ps == SDIO_POWER_OFF)
96 {
97 flag = RESET;
98 }
99
100 return flag;
101}
102
115void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
116{
117 /* config clock edge */
118 sdio_x->clkctrl_bit.clkegs = clk_edg;
119
120 /* config clock divide [7:0] */
121 sdio_x->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
122
123 /* config clock divide [9:8] */
124 sdio_x->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
125}
126
139void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
140{
141 sdio_x->clkctrl_bit.busws = width;
142}
143
152void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
153{
154 sdio_x->clkctrl_bit.bypsen = new_state;
155}
156
166void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
167{
168 sdio_x->clkctrl_bit.pwrsven = new_state;
169}
170
179void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
180{
181 sdio_x->clkctrl_bit.hfcen = new_state;
182}
183
192void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
193{
194 sdio_x->clkctrl_bit.clkoen = new_state;
195}
196
205void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
206{
207 sdio_x->dtctrl_bit.dmaen = new_state;
208}
209
243void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
244{
245 /* enable interrupt */
246 if(TRUE == new_state)
247 {
248 sdio_x->inten |= int_opt;
249 }
250 /* disable interrupt */
251 else
252 {
253 sdio_x->inten &= ~(int_opt);
254 }
255}
256
289 flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
290{
291 flag_status status = RESET;
292
293 if((sdio_x->sts & flag) == flag)
294 {
295 status = SET;
296 }
297 else
298 {
299 status = RESET;
300 }
301
302 return status;
303}
304
326void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
327{
328 sdio_x->intclr = flag;
329}
330
340void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
341{
342 /* disable command path state machine */
343 sdio_x->cmdctrl_bit.ccsmen = FALSE;
344
345 /* config command argument */
346 sdio_x->argu = command_struct->argument;
347
348 /* config command register */
349 sdio_x->cmdctrl_bit.cmdidx = command_struct->cmd_index;
350 sdio_x->cmdctrl_bit.rspwt = command_struct->rsp_type;
351 sdio_x->cmdctrl_bit.intwt = (command_struct->wait_type & 0x1); /* [1:0] -> [0] */
352 sdio_x->cmdctrl_bit.pndwt = (command_struct->wait_type & 0x2)>>1; /* [1:0] -> [1] */
353}
354
363void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
364{
365 sdio_x->cmdctrl_bit.ccsmen = new_state;
366}
367
376uint8_t sdio_command_response_get(sdio_type *sdio_x)
377{
378 return sdio_x->rspcmd_bit.rspcmd;
379}
380
394uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
395{
396 uint32_t response_value = 0;
397
398 switch(reg_index)
399 {
400 case SDIO_RSP1_INDEX:
401 response_value = sdio_x->rsp1;
402 break;
403 case SDIO_RSP2_INDEX:
404 response_value = sdio_x->rsp2;
405 break;
406 case SDIO_RSP3_INDEX:
407 response_value = sdio_x->rsp3;
408 break;
409 case SDIO_RSP4_INDEX:
410 response_value = sdio_x->rsp4;
411 break;
412 default: break;
413 }
414
415 return response_value;
416}
417
427void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
428{
429 /* disable data path state machine */
430 sdio_x->dtctrl_bit.tfren = FALSE;
431
432 /* config data block, transfer mode and transfer direction */
433 sdio_x->dtctrl_bit.blksize = data_struct->block_size;
434 sdio_x->dtctrl_bit.tfrdir = data_struct->transfer_direction;
435 sdio_x->dtctrl_bit.tfrmode = data_struct->transfer_mode;
436
437 /* config data length */
438 sdio_x->dtlen_bit.dtlen = data_struct->data_length;
439
440 /* config data transfer timeout */
441 sdio_x->dttmr_bit.timeout = data_struct->timeout;
442}
443
452void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
453{
454 sdio_x->dtctrl_bit.tfren = new_state;
455}
456
464uint32_t sdio_data_counter_get(sdio_type *sdio_x)
465{
466 return sdio_x->dtcnt;
467}
468
476uint32_t sdio_data_read(sdio_type *sdio_x)
477{
478 return sdio_x->buf;
479}
480
488uint32_t sdio_buffer_counter_get(sdio_type *sdio_x)
489{
490 return sdio_x->bufcnt;
491}
492
501void sdio_data_write(sdio_type *sdio_x, uint32_t data)
502{
503 sdio_x->buf = data;
504}
505
517void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode)
518{
519 sdio_x->dtctrl_bit.rdwtmode = mode;
520}
521
530void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state)
531{
532 sdio_x->dtctrl_bit.rdwtstart = new_state;
533}
534
543void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state)
544{
545 sdio_x->dtctrl_bit.rdwtstop = new_state;
546}
547
556void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state)
557{
558 sdio_x->dtctrl_bit.ioen = new_state;
559}
560
569void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state)
570{
571 sdio_x->cmdctrl_bit.iosusp = new_state;
572}
573
578#endif
579
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
sdio_read_wait_mode_type
sdio_read_wait_mode_type
sdio read wait mode
Definition: at32f413_sdio.h:220
sdio_edge_phase_type
sdio_edge_phase_type
sdio edge phase
Definition: at32f413_sdio.h:130
sdio_power_state_type
sdio_power_state_type
sdio power state
Definition: at32f413_sdio.h:121
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:139
sdio_rsp_index_type
sdio_rsp_index_type
sdio response register index
Definition: at32f413_sdio.h:169
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f413_sdio.h:122
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f413_sdio.h:123
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f413_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f413_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f413_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f413_sdio.h:170
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f413_sdio.c:340
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f413_sdio.c:501
sdio_io_suspend_command_set
void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending.
Definition: at32f413_sdio.c:569
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f413_sdio.c:427
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f413_sdio.c:476
sdio_power_status_get
flag_status sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f413_sdio.c:87
sdio_io_function_enable
void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function.
Definition: at32f413_sdio.c:556
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f413_sdio.c:363
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f413_sdio.c:152
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f413_sdio.c:179
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f413_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f413_sdio.c:115
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f413_sdio.c:139
sdio_read_wait_stop
void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation.
Definition: at32f413_sdio.c:543
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f413_sdio.c:243
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f413_sdio.c:326
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f413_sdio.c:394
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f413_sdio.c:452
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f413_sdio.c:166
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f413_sdio.c:289
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f413_sdio.c:205
sdio_data_counter_get
uint32_t sdio_data_counter_get(sdio_type *sdio_x)
get the number of remaining data bytes to be transferred.
Definition: at32f413_sdio.c:464
sdio_buffer_counter_get
uint32_t sdio_buffer_counter_get(sdio_type *sdio_x)
get the number of words left to be written to or read from fifo..
Definition: at32f413_sdio.c:488
sdio_read_wait_start
void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation.
Definition: at32f413_sdio.c:530
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f413_sdio.c:51
sdio_read_wait_mode_set
void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode.
Definition: at32f413_sdio.c:517
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f413_sdio.c:192
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f413_sdio.c:376
sdio_command_struct_type
sdio command structure
Definition: at32f413_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f413_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f413_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f413_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f413_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f413_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f413_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f413_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f413_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f413_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f413_sdio.h:242
sdio_type
type define sdio register all
Definition: at32f413_sdio.h:252
sdio_type::ps
__IO uint32_t ps
Definition: at32f413_sdio.h:261
sdio_type::dtlen
__IO uint32_t dtlen
Definition: at32f413_sdio.h:394
sdio_type::intclr
__IO uint32_t intclr
Definition: at32f413_sdio.h:476
sdio_type::rdwtstart
__IO uint32_t rdwtstart
Definition: at32f413_sdio.h:415
sdio_type::rdwtstop
__IO uint32_t rdwtstop
Definition: at32f413_sdio.h:416
sdio_type::rspwt
__IO uint32_t rspwt
Definition: at32f413_sdio.h:307
sdio_type::pwrctrl_bit
struct sdio_type::@567::@603 pwrctrl_bit
sdio_type::hfcen
__IO uint32_t hfcen
Definition: at32f413_sdio.h:280
sdio_type::tfrmode
__IO uint32_t tfrmode
Definition: at32f413_sdio.h:412
sdio_type::cmdctrl_bit
struct sdio_type::@573::@606 cmdctrl_bit
sdio_type::clkegs
__IO uint32_t clkegs
Definition: at32f413_sdio.h:279
sdio_type::tfrdir
__IO uint32_t tfrdir
Definition: at32f413_sdio.h:411
sdio_type::tfren
__IO uint32_t tfren
Definition: at32f413_sdio.h:410
sdio_type::dttmr
__IO uint32_t dttmr
Definition: at32f413_sdio.h:382
sdio_type::rspcmd_bit
struct sdio_type::@575::@607 rspcmd_bit
sdio_type::inten
__IO uint32_t inten
Definition: at32f413_sdio.h:501
sdio_type::pndwt
__IO uint32_t pndwt
Definition: at32f413_sdio.h:309
sdio_type::cmdctrl
__IO uint32_t cmdctrl
Definition: at32f413_sdio.h:303
sdio_type::clkoen
__IO uint32_t clkoen
Definition: at32f413_sdio.h:275
sdio_type::ioen
__IO uint32_t ioen
Definition: at32f413_sdio.h:418
sdio_type::bufcnt
__IO uint32_t bufcnt
Definition: at32f413_sdio.h:541
sdio_type::intwt
__IO uint32_t intwt
Definition: at32f413_sdio.h:308
sdio_type::rsp2
__IO uint32_t rsp2
Definition: at32f413_sdio.h:346
sdio_type::dtctrl
__IO uint32_t dtctrl
Definition: at32f413_sdio.h:407
sdio_type::dtctrl_bit
struct sdio_type::@589::@614 dtctrl_bit
sdio_type::ccsmen
__IO uint32_t ccsmen
Definition: at32f413_sdio.h:310
sdio_type::pwrsven
__IO uint32_t pwrsven
Definition: at32f413_sdio.h:276
sdio_type::cmdidx
__IO uint32_t cmdidx
Definition: at32f413_sdio.h:306
sdio_type::pwrctrl
__IO uint32_t pwrctrl
Definition: at32f413_sdio.h:258
sdio_type::dmaen
__IO uint32_t dmaen
Definition: at32f413_sdio.h:413
sdio_type::sts
__IO uint32_t sts
Definition: at32f413_sdio.h:441
sdio_type::blksize
__IO uint32_t blksize
Definition: at32f413_sdio.h:414
sdio_type::rdwtmode
__IO uint32_t rdwtmode
Definition: at32f413_sdio.h:417
sdio_type::clkctrl_bit
struct sdio_type::@569::@604 clkctrl_bit
sdio_type::rsp1
__IO uint32_t rsp1
Definition: at32f413_sdio.h:334
sdio_type::rsp4
__IO uint32_t rsp4
Definition: at32f413_sdio.h:370
sdio_type::bypsen
__IO uint32_t bypsen
Definition: at32f413_sdio.h:277
sdio_type::buf
__IO uint32_t buf
Definition: at32f413_sdio.h:559
sdio_type::clkdiv_l
__IO uint32_t clkdiv_l
Definition: at32f413_sdio.h:274
sdio_type::rspcmd
__IO uint32_t rspcmd
Definition: at32f413_sdio.h:321
sdio_type::argu
__IO uint32_t argu
Definition: at32f413_sdio.h:291
sdio_type::dtlen_bit
struct sdio_type::@587::@613 dtlen_bit
sdio_type::timeout
__IO uint32_t timeout
Definition: at32f413_sdio.h:385
sdio_type::busws
__IO uint32_t busws
Definition: at32f413_sdio.h:278
sdio_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f413_sdio.h:428
sdio_type::clkdiv_h
__IO uint32_t clkdiv_h
Definition: at32f413_sdio.h:281
sdio_type::iosusp
__IO uint32_t iosusp
Definition: at32f413_sdio.h:311
sdio_type::dttmr_bit
struct sdio_type::@585::@612 dttmr_bit
sdio_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f413_sdio.h:271
sdio_type::rsp3
__IO uint32_t rsp3
Definition: at32f413_sdio.h:358
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_sdio.h Source File

  • libraries
  • drivers
  • inc
at32f413_sdio.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_SDIO_H
29#define __AT32F413_SDIO_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define SDIO_CMDFAIL_INT ((uint32_t)0x00000001)
53#define SDIO_DTFAIL_INT ((uint32_t)0x00000002)
54#define SDIO_CMDTIMEOUT_INT ((uint32_t)0x00000004)
55#define SDIO_DTTIMEOUT_INT ((uint32_t)0x00000008)
56#define SDIO_TXERRU_INT ((uint32_t)0x00000010)
57#define SDIO_RXERRO_INT ((uint32_t)0x00000020)
58#define SDIO_CMDRSPCMPL_INT ((uint32_t)0x00000040)
59#define SDIO_CMDCMPL_INT ((uint32_t)0x00000080)
60#define SDIO_DTCMP_INT ((uint32_t)0x00000100)
61#define SDIO_SBITERR_INT ((uint32_t)0x00000200)
62#define SDIO_DTBLKCMPL_INT ((uint32_t)0x00000400)
63#define SDIO_DOCMD_INT ((uint32_t)0x00000800)
64#define SDIO_DOTX_INT ((uint32_t)0x00001000)
65#define SDIO_DORX_INT ((uint32_t)0x00002000)
66#define SDIO_TXBUFH_INT ((uint32_t)0x00004000)
67#define SDIO_RXBUFH_INT ((uint32_t)0x00008000)
68#define SDIO_TXBUFF_INT ((uint32_t)0x00010000)
69#define SDIO_RXBUFF_INT ((uint32_t)0x00020000)
70#define SDIO_TXBUFE_INT ((uint32_t)0x00040000)
71#define SDIO_RXBUFE_INT ((uint32_t)0x00080000)
72#define SDIO_TXBUF_INT ((uint32_t)0x00100000)
73#define SDIO_RXBUF_INT ((uint32_t)0x00200000)
74#define SDIO_SDIOIF_INT ((uint32_t)0x00400000)
85#define SDIO_CMDFAIL_FLAG ((uint32_t)0x00000001)
86#define SDIO_DTFAIL_FLAG ((uint32_t)0x00000002)
87#define SDIO_CMDTIMEOUT_FLAG ((uint32_t)0x00000004)
88#define SDIO_DTTIMEOUT_FLAG ((uint32_t)0x00000008)
89#define SDIO_TXERRU_FLAG ((uint32_t)0x00000010)
90#define SDIO_RXERRO_FLAG ((uint32_t)0x00000020)
91#define SDIO_CMDRSPCMPL_FLAG ((uint32_t)0x00000040)
92#define SDIO_CMDCMPL_FLAG ((uint32_t)0x00000080)
93#define SDIO_DTCMPL_FLAG ((uint32_t)0x00000100)
94#define SDIO_SBITERR_FLAG ((uint32_t)0x00000200)
95#define SDIO_DTBLKCMPL_FLAG ((uint32_t)0x00000400)
96#define SDIO_DOCMD_FLAG ((uint32_t)0x00000800)
97#define SDIO_DOTX_FLAG ((uint32_t)0x00001000)
98#define SDIO_DORX_FLAG ((uint32_t)0x00002000)
99#define SDIO_TXBUFH_FLAG ((uint32_t)0x00004000)
100#define SDIO_RXBUFH_FLAG ((uint32_t)0x00008000)
101#define SDIO_TXBUFF_FLAG ((uint32_t)0x00010000)
102#define SDIO_RXBUFF_FLAG ((uint32_t)0x00020000)
103#define SDIO_TXBUFE_FLAG ((uint32_t)0x00040000)
104#define SDIO_RXBUFE_FLAG ((uint32_t)0x00080000)
105#define SDIO_TXBUF_FLAG ((uint32_t)0x00100000)
106#define SDIO_RXBUF_FLAG ((uint32_t)0x00200000)
107#define SDIO_SDIOIF_FLAG ((uint32_t)0x00400000)
120typedef enum
121{
122 SDIO_POWER_OFF = 0x00,
123 SDIO_POWER_ON = 0x03
124} sdio_power_state_type;
125
129typedef enum
130{
131 SDIO_CLOCK_EDGE_RISING = 0x00,
132 SDIO_CLOCK_EDGE_FALLING = 0x01
133} sdio_edge_phase_type;
134
138typedef enum
139{
140 SDIO_BUS_WIDTH_D1 = 0x00,
141 SDIO_BUS_WIDTH_D4 = 0x01,
142 SDIO_BUS_WIDTH_D8 = 0x02
143} sdio_bus_width_type;
144
148typedef enum
149{
150 SDIO_RESPONSE_NO = 0x00,
151 SDIO_RESPONSE_SHORT = 0x01,
152 SDIO_RESPONSE_LONG = 0x03
153} sdio_reponse_type;
154
158typedef enum
159{
160 SDIO_WAIT_FOR_NO = 0x00,
161 SDIO_WAIT_FOR_INT = 0x01,
162 SDIO_WAIT_FOR_PEND = 0x02
163} sdio_wait_type;
164
168typedef enum
169{
170 SDIO_RSP1_INDEX = 0x00,
171 SDIO_RSP2_INDEX = 0x01,
172 SDIO_RSP3_INDEX = 0x02,
173 SDIO_RSP4_INDEX = 0x03
174} sdio_rsp_index_type;
175
179typedef enum
180{
181 SDIO_DATA_BLOCK_SIZE_1B = 0x00,
182 SDIO_DATA_BLOCK_SIZE_2B = 0x01,
183 SDIO_DATA_BLOCK_SIZE_4B = 0x02,
184 SDIO_DATA_BLOCK_SIZE_8B = 0x03,
185 SDIO_DATA_BLOCK_SIZE_16B = 0x04,
186 SDIO_DATA_BLOCK_SIZE_32B = 0x05,
187 SDIO_DATA_BLOCK_SIZE_64B = 0x06,
188 SDIO_DATA_BLOCK_SIZE_128B = 0x07,
189 SDIO_DATA_BLOCK_SIZE_256B = 0x08,
190 SDIO_DATA_BLOCK_SIZE_512B = 0x09,
191 SDIO_DATA_BLOCK_SIZE_1024B = 0x0A,
192 SDIO_DATA_BLOCK_SIZE_2048B = 0x0B,
193 SDIO_DATA_BLOCK_SIZE_4096B = 0x0C,
194 SDIO_DATA_BLOCK_SIZE_8192B = 0x0D,
195 SDIO_DATA_BLOCK_SIZE_16384B = 0x0E
196} sdio_block_size_type;
197
201typedef enum
202{
203 SDIO_DATA_BLOCK_TRANSFER = 0x00,
204 SDIO_DATA_STREAM_TRANSFER = 0x01
205} sdio_transfer_mode_type;
206
210typedef enum
211{
212 SDIO_DATA_TRANSFER_TO_CARD = 0x00,
213 SDIO_DATA_TRANSFER_TO_CONTROLLER = 0x01
214} sdio_transfer_direction_type;
215
219typedef enum
220{
221 SDIO_READ_WAIT_CONTROLLED_BY_D2 = 0x00,
222 SDIO_READ_WAIT_CONTROLLED_BY_CK = 0x01
223} sdio_read_wait_mode_type;
224
228typedef struct
229{
230 uint32_t argument;
231 uint8_t cmd_index;
232 sdio_reponse_type rsp_type;
233 sdio_wait_type wait_type;
234} sdio_command_struct_type;
235
239typedef struct
240{
241 uint32_t timeout;
242 uint32_t data_length;
243 sdio_block_size_type block_size;
244 sdio_transfer_mode_type transfer_mode;
245 sdio_transfer_direction_type transfer_direction;
246} sdio_data_struct_type;
247
251typedef struct
252{
256 union
257 {
258 __IO uint32_t pwrctrl;
259 struct
260 {
261 __IO uint32_t ps : 2; /* [1:0] */
262 __IO uint32_t reserved1 : 30;/* [31:2] */
263 } pwrctrl_bit;
264 };
265
269 union
270 {
271 __IO uint32_t clkctrl;
272 struct
273 {
274 __IO uint32_t clkdiv_l : 8; /* [7:0] */
275 __IO uint32_t clkoen : 1; /* [8] */
276 __IO uint32_t pwrsven : 1; /* [9] */
277 __IO uint32_t bypsen : 1; /* [10] */
278 __IO uint32_t busws : 2; /* [12:11] */
279 __IO uint32_t clkegs : 1; /* [13] */
280 __IO uint32_t hfcen : 1; /* [14] */
281 __IO uint32_t clkdiv_h : 2; /* [16:15] */
282 __IO uint32_t reserved1 : 15;/* [31:17] */
283 } clkctrl_bit;
284 };
285
289 union
290 {
291 __IO uint32_t argu;
292 struct
293 {
294 __IO uint32_t argu : 32;/* [31:0] */
295 } argu_bit;
296 };
297
301 union
302 {
303 __IO uint32_t cmdctrl;
304 struct
305 {
306 __IO uint32_t cmdidx : 6; /* [5:0] */
307 __IO uint32_t rspwt : 2; /* [7:6] */
308 __IO uint32_t intwt : 1; /* [8] */
309 __IO uint32_t pndwt : 1; /* [9] */
310 __IO uint32_t ccsmen : 1; /* [10] */
311 __IO uint32_t iosusp : 1; /* [11] */
312 __IO uint32_t reserved1 : 20;/* [31:12] */
313 } cmdctrl_bit;
314 };
315
319 union
320 {
321 __IO uint32_t rspcmd;
322 struct
323 {
324 __IO uint32_t rspcmd : 6; /* [5:0] */
325 __IO uint32_t reserved1 : 26;/* [31:6] */
326 } rspcmd_bit;
327 };
328
332 union
333 {
334 __IO uint32_t rsp1;
335 struct
336 {
337 __IO uint32_t cardsts1 : 32;/* [31:0] */
338 } rsp1_bit;
339 };
340
344 union
345 {
346 __IO uint32_t rsp2;
347 struct
348 {
349 __IO uint32_t cardsts2 : 32;/* [31:0] */
350 } rsp2_bit;
351 };
352
356 union
357 {
358 __IO uint32_t rsp3;
359 struct
360 {
361 __IO uint32_t cardsts3 : 32;/* [31:0] */
362 } rsp3_bit;
363 };
364
368 union
369 {
370 __IO uint32_t rsp4;
371 struct
372 {
373 __IO uint32_t cardsts4 : 32;/* [31:0] */
374 } rsp4_bit;
375 };
376
380 union
381 {
382 __IO uint32_t dttmr;
383 struct
384 {
385 __IO uint32_t timeout : 32;/* [31:0] */
386 } dttmr_bit;
387 };
388
392 union
393 {
394 __IO uint32_t dtlen;
395 struct
396 {
397 __IO uint32_t dtlen : 25;/* [24:0] */
398 __IO uint32_t reserved1 : 7; /* [31:25] */
399 } dtlen_bit;
400 };
401
405 union
406 {
407 __IO uint32_t dtctrl;
408 struct
409 {
410 __IO uint32_t tfren : 1; /* [0] */
411 __IO uint32_t tfrdir : 1; /* [1] */
412 __IO uint32_t tfrmode : 1; /* [2] */
413 __IO uint32_t dmaen : 1; /* [3] */
414 __IO uint32_t blksize : 4; /* [7:4] */
415 __IO uint32_t rdwtstart : 1; /* [8] */
416 __IO uint32_t rdwtstop : 1; /* [9] */
417 __IO uint32_t rdwtmode : 1; /* [10] */
418 __IO uint32_t ioen : 1; /* [11] */
419 __IO uint32_t reserved1 : 20;/* [31:12] */
420 } dtctrl_bit;
421 };
422
426 union
427 {
428 __IO uint32_t dtcnt;
429 struct
430 {
431 __IO uint32_t cnt : 25;/* [24:0] */
432 __IO uint32_t reserved1 : 7; /* [31:25] */
433 } dtcnt_bit;
434 };
435
439 union
440 {
441 __IO uint32_t sts;
442 struct
443 {
444 __IO uint32_t cmdfail : 1; /* [0] */
445 __IO uint32_t dtfail : 1; /* [1] */
446 __IO uint32_t cmdtimeout : 1; /* [2] */
447 __IO uint32_t dttimeout : 1; /* [3] */
448 __IO uint32_t txerru : 1; /* [4] */
449 __IO uint32_t rxerro : 1; /* [5] */
450 __IO uint32_t cmdrspcmpl : 1; /* [6] */
451 __IO uint32_t cmdcmpl : 1; /* [7] */
452 __IO uint32_t dtcmpl : 1; /* [8] */
453 __IO uint32_t sbiterr : 1; /* [9] */
454 __IO uint32_t dtblkcmpl : 1; /* [10] */
455 __IO uint32_t docmd : 1; /* [11] */
456 __IO uint32_t dotx : 1; /* [12] */
457 __IO uint32_t dorx : 1; /* [13] */
458 __IO uint32_t txbufh : 1; /* [14] */
459 __IO uint32_t rxbufh : 1; /* [15] */
460 __IO uint32_t txbuff : 1; /* [16] */
461 __IO uint32_t rxbuff : 1; /* [17] */
462 __IO uint32_t txbufe : 1; /* [18] */
463 __IO uint32_t rxbufe : 1; /* [19] */
464 __IO uint32_t txbuf : 1; /* [20] */
465 __IO uint32_t rxbuf : 1; /* [21] */
466 __IO uint32_t ioif : 1; /* [22] */
467 __IO uint32_t reserved1 : 9; /* [31:23] */
468 } sts_bit;
469 };
470
474 union
475 {
476 __IO uint32_t intclr;
477 struct
478 {
479 __IO uint32_t cmdfail : 1; /* [0] */
480 __IO uint32_t dtfail : 1; /* [1] */
481 __IO uint32_t cmdtimeout : 1; /* [2] */
482 __IO uint32_t dttimeout : 1; /* [3] */
483 __IO uint32_t txerru : 1; /* [4] */
484 __IO uint32_t rxerro : 1; /* [5] */
485 __IO uint32_t cmdrspcmpl : 1; /* [6] */
486 __IO uint32_t cmdcmpl : 1; /* [7] */
487 __IO uint32_t dtcmpl : 1; /* [8] */
488 __IO uint32_t sbiterr : 1; /* [9] */
489 __IO uint32_t dtblkcmpl : 1; /* [10] */
490 __IO uint32_t reserved1 : 11;/* [21:11] */
491 __IO uint32_t ioif : 1; /* [22] */
492 __IO uint32_t reserved2 : 9; /* [31:23] */
493 } intclr_bit;
494 };
495
499 union
500 {
501 __IO uint32_t inten;
502 struct
503 {
504 __IO uint32_t cmdfailien : 1; /* [0] */
505 __IO uint32_t dtfailien : 1; /* [1] */
506 __IO uint32_t cmdtimeoutien : 1; /* [2] */
507 __IO uint32_t dttimeoutien : 1; /* [3] */
508 __IO uint32_t txerruien : 1; /* [4] */
509 __IO uint32_t rxerroien : 1; /* [5] */
510 __IO uint32_t cmdrspcmplien : 1; /* [6] */
511 __IO uint32_t cmdcmplien : 1; /* [7] */
512 __IO uint32_t dtcmplien : 1; /* [8] */
513 __IO uint32_t sbiterrien : 1; /* [9] */
514 __IO uint32_t dtblkcmplien : 1; /* [10] */
515 __IO uint32_t docmdien : 1; /* [11] */
516 __IO uint32_t dotxien : 1; /* [12] */
517 __IO uint32_t dorxien : 1; /* [13] */
518 __IO uint32_t txbufhien : 1; /* [14] */
519 __IO uint32_t rxbufhien : 1; /* [15] */
520 __IO uint32_t txbuffien : 1; /* [16] */
521 __IO uint32_t rxbuffien : 1; /* [17] */
522 __IO uint32_t txbufeien : 1; /* [18] */
523 __IO uint32_t rxbufeien : 1; /* [19] */
524 __IO uint32_t txbufien : 1; /* [20] */
525 __IO uint32_t rxbufien : 1; /* [21] */
526 __IO uint32_t ioifien : 1; /* [22] */
527 __IO uint32_t reserved1 : 9; /* [31:23] */
528 } inten_bit;
529 };
530
534 __IO uint32_t reserved1[2];
535
539 union
540 {
541 __IO uint32_t bufcnt;
542 struct
543 {
544 __IO uint32_t cnt : 24;/* [23:0] */
545 __IO uint32_t reserved1 : 8; /* [31:24] */
546 } bufcnt_bit;
547 };
548
552 __IO uint32_t reserved2[13];
553
557 union
558 {
559 __IO uint32_t buf;
560 struct
561 {
562 __IO uint32_t dt : 32;/* [31:0] */
563 } buf_bit;
564 };
565
566} sdio_type;
567
572#define SDIO1 ((sdio_type *) SDIO1_BASE)
573
578void sdio_reset(sdio_type *sdio_x);
579void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state);
580 flag_status sdio_power_status_get(sdio_type *sdio_x);
581void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg);
582void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width);
583void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state);
584void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state);
585void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state);
586void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state);
587void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state);
588void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state);
589 flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag);
590void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag);
591void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct);
592void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state);
593uint8_t sdio_command_response_get(sdio_type *sdio_x);
594uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index);
595void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct);
596void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state);
597uint32_t sdio_data_counter_get(sdio_type *sdio_x);
598uint32_t sdio_data_read(sdio_type *sdio_x);
599uint32_t sdio_buffer_counter_get(sdio_type *sdio_x);
600void sdio_data_write(sdio_type *sdio_x, uint32_t data);
601void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode);
602void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state);
603void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state);
604void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state);
605void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state);
606
619#ifdef __cplusplus
620}
621#endif
622
623#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f413_sdio.c:340
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f413_sdio.c:501
sdio_io_suspend_command_set
void sdio_io_suspend_command_set(sdio_type *sdio_x, confirm_state new_state)
enable or disable sd i/o suspend command sending.
Definition: at32f413_sdio.c:569
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f413_sdio.c:427
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f413_sdio.c:476
sdio_power_status_get
flag_status sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f413_sdio.c:87
sdio_io_function_enable
void sdio_io_function_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable the sd i/o function.
Definition: at32f413_sdio.c:556
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f413_sdio.c:363
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f413_sdio.c:152
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f413_sdio.c:179
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f413_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f413_sdio.c:115
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f413_sdio.c:139
sdio_read_wait_stop
void sdio_read_wait_stop(sdio_type *sdio_x, confirm_state new_state)
enable or disable to stop sd i/o read wait operation.
Definition: at32f413_sdio.c:543
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f413_sdio.c:243
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f413_sdio.c:326
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f413_sdio.c:394
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f413_sdio.c:452
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f413_sdio.c:166
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f413_sdio.c:289
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f413_sdio.c:205
sdio_data_counter_get
uint32_t sdio_data_counter_get(sdio_type *sdio_x)
get the number of remaining data bytes to be transferred.
Definition: at32f413_sdio.c:464
sdio_buffer_counter_get
uint32_t sdio_buffer_counter_get(sdio_type *sdio_x)
get the number of words left to be written to or read from fifo..
Definition: at32f413_sdio.c:488
sdio_read_wait_start
void sdio_read_wait_start(sdio_type *sdio_x, confirm_state new_state)
enable or disable to start sd i/o read wait operation.
Definition: at32f413_sdio.c:530
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f413_sdio.c:51
sdio_read_wait_mode_set
void sdio_read_wait_mode_set(sdio_type *sdio_x, sdio_read_wait_mode_type mode)
set the read wait mode.
Definition: at32f413_sdio.c:517
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f413_sdio.c:192
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f413_sdio.c:376
sdio_wait_type
sdio_wait_type
sdio wait type
Definition: at32f413_sdio.h:159
sdio_reponse_type
sdio_reponse_type
sdio response type
Definition: at32f413_sdio.h:149
sdio_read_wait_mode_type
sdio_read_wait_mode_type
sdio read wait mode
Definition: at32f413_sdio.h:220
sdio_edge_phase_type
sdio_edge_phase_type
sdio edge phase
Definition: at32f413_sdio.h:130
sdio_transfer_direction_type
sdio_transfer_direction_type
sdio data transfer direction
Definition: at32f413_sdio.h:211
sdio_power_state_type
sdio_power_state_type
sdio power state
Definition: at32f413_sdio.h:121
sdio_transfer_mode_type
sdio_transfer_mode_type
sdio data transfer mode
Definition: at32f413_sdio.h:202
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:139
sdio_rsp_index_type
sdio_rsp_index_type
sdio response register index
Definition: at32f413_sdio.h:169
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f413_sdio.h:180
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f413_sdio.h:160
SDIO_WAIT_FOR_PEND
@ SDIO_WAIT_FOR_PEND
Definition: at32f413_sdio.h:162
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f413_sdio.h:161
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f413_sdio.h:152
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f413_sdio.h:151
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f413_sdio.h:150
SDIO_READ_WAIT_CONTROLLED_BY_CK
@ SDIO_READ_WAIT_CONTROLLED_BY_CK
Definition: at32f413_sdio.h:222
SDIO_READ_WAIT_CONTROLLED_BY_D2
@ SDIO_READ_WAIT_CONTROLLED_BY_D2
Definition: at32f413_sdio.h:221
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f413_sdio.h:132
SDIO_CLOCK_EDGE_RISING
@ SDIO_CLOCK_EDGE_RISING
Definition: at32f413_sdio.h:131
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f413_sdio.h:212
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f413_sdio.h:213
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f413_sdio.h:122
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f413_sdio.h:123
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f413_sdio.h:203
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f413_sdio.h:204
SDIO_BUS_WIDTH_D8
@ SDIO_BUS_WIDTH_D8
Definition: at32f413_sdio.h:142
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f413_sdio.h:140
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f413_sdio.h:141
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f413_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f413_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f413_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f413_sdio.h:170
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f413_sdio.h:184
SDIO_DATA_BLOCK_SIZE_128B
@ SDIO_DATA_BLOCK_SIZE_128B
Definition: at32f413_sdio.h:188
SDIO_DATA_BLOCK_SIZE_2048B
@ SDIO_DATA_BLOCK_SIZE_2048B
Definition: at32f413_sdio.h:192
SDIO_DATA_BLOCK_SIZE_4096B
@ SDIO_DATA_BLOCK_SIZE_4096B
Definition: at32f413_sdio.h:193
SDIO_DATA_BLOCK_SIZE_16B
@ SDIO_DATA_BLOCK_SIZE_16B
Definition: at32f413_sdio.h:185
SDIO_DATA_BLOCK_SIZE_1024B
@ SDIO_DATA_BLOCK_SIZE_1024B
Definition: at32f413_sdio.h:191
SDIO_DATA_BLOCK_SIZE_64B
@ SDIO_DATA_BLOCK_SIZE_64B
Definition: at32f413_sdio.h:187
SDIO_DATA_BLOCK_SIZE_32B
@ SDIO_DATA_BLOCK_SIZE_32B
Definition: at32f413_sdio.h:186
SDIO_DATA_BLOCK_SIZE_8192B
@ SDIO_DATA_BLOCK_SIZE_8192B
Definition: at32f413_sdio.h:194
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f413_sdio.h:181
SDIO_DATA_BLOCK_SIZE_512B
@ SDIO_DATA_BLOCK_SIZE_512B
Definition: at32f413_sdio.h:190
SDIO_DATA_BLOCK_SIZE_2B
@ SDIO_DATA_BLOCK_SIZE_2B
Definition: at32f413_sdio.h:182
SDIO_DATA_BLOCK_SIZE_256B
@ SDIO_DATA_BLOCK_SIZE_256B
Definition: at32f413_sdio.h:189
SDIO_DATA_BLOCK_SIZE_4B
@ SDIO_DATA_BLOCK_SIZE_4B
Definition: at32f413_sdio.h:183
SDIO_DATA_BLOCK_SIZE_16384B
@ SDIO_DATA_BLOCK_SIZE_16384B
Definition: at32f413_sdio.h:195
sdio_command_struct_type
sdio command structure
Definition: at32f413_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f413_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f413_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f413_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f413_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f413_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f413_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f413_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f413_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f413_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f413_sdio.h:242
sdio_type
type define sdio register all
Definition: at32f413_sdio.h:252
sdio_type::ps
__IO uint32_t ps
Definition: at32f413_sdio.h:261
sdio_type::dorx
__IO uint32_t dorx
Definition: at32f413_sdio.h:457
sdio_type::sbiterr
__IO uint32_t sbiterr
Definition: at32f413_sdio.h:453
sdio_type::dtlen
__IO uint32_t dtlen
Definition: at32f413_sdio.h:394
sdio_type::intclr
__IO uint32_t intclr
Definition: at32f413_sdio.h:476
sdio_type::rdwtstart
__IO uint32_t rdwtstart
Definition: at32f413_sdio.h:415
sdio_type::rdwtstop
__IO uint32_t rdwtstop
Definition: at32f413_sdio.h:416
sdio_type::rspwt
__IO uint32_t rspwt
Definition: at32f413_sdio.h:307
sdio_type::rxbuf
__IO uint32_t rxbuf
Definition: at32f413_sdio.h:465
sdio_type::hfcen
__IO uint32_t hfcen
Definition: at32f413_sdio.h:280
sdio_type::rxbufeien
__IO uint32_t rxbufeien
Definition: at32f413_sdio.h:523
sdio_type::tfrmode
__IO uint32_t tfrmode
Definition: at32f413_sdio.h:412
sdio_type::cmdtimeout
__IO uint32_t cmdtimeout
Definition: at32f413_sdio.h:446
sdio_type::clkegs
__IO uint32_t clkegs
Definition: at32f413_sdio.h:279
sdio_type::cmdcmplien
__IO uint32_t cmdcmplien
Definition: at32f413_sdio.h:511
sdio_type::cmdcmpl
__IO uint32_t cmdcmpl
Definition: at32f413_sdio.h:451
sdio_type::dtfailien
__IO uint32_t dtfailien
Definition: at32f413_sdio.h:505
sdio_type::rxbufhien
__IO uint32_t rxbufhien
Definition: at32f413_sdio.h:519
sdio_type::tfrdir
__IO uint32_t tfrdir
Definition: at32f413_sdio.h:411
sdio_type::tfren
__IO uint32_t tfren
Definition: at32f413_sdio.h:410
sdio_type::dttmr
__IO uint32_t dttmr
Definition: at32f413_sdio.h:382
sdio_type::reserved1
__IO uint32_t reserved1
sdio reserved1 register, offset:0x40~0x44
Definition: at32f413_sdio.h:262
sdio_type::cnt
__IO uint32_t cnt
Definition: at32f413_sdio.h:431
sdio_type::cardsts4
__IO uint32_t cardsts4
Definition: at32f413_sdio.h:373
sdio_type::cmdfail
__IO uint32_t cmdfail
Definition: at32f413_sdio.h:444
sdio_type::txbufhien
__IO uint32_t txbufhien
Definition: at32f413_sdio.h:518
sdio_type::txbuffien
__IO uint32_t txbuffien
Definition: at32f413_sdio.h:520
sdio_type::rxbufe
__IO uint32_t rxbufe
Definition: at32f413_sdio.h:463
sdio_type::dtblkcmpl
__IO uint32_t dtblkcmpl
Definition: at32f413_sdio.h:454
sdio_type::inten
__IO uint32_t inten
Definition: at32f413_sdio.h:501
sdio_type::dtcmpl
__IO uint32_t dtcmpl
Definition: at32f413_sdio.h:452
sdio_type::docmd
__IO uint32_t docmd
Definition: at32f413_sdio.h:455
sdio_type::pndwt
__IO uint32_t pndwt
Definition: at32f413_sdio.h:309
sdio_type::cmdctrl
__IO uint32_t cmdctrl
Definition: at32f413_sdio.h:303
sdio_type::dtcmplien
__IO uint32_t dtcmplien
Definition: at32f413_sdio.h:512
sdio_type::clkoen
__IO uint32_t clkoen
Definition: at32f413_sdio.h:275
sdio_type::ioen
__IO uint32_t ioen
Definition: at32f413_sdio.h:418
sdio_type::bufcnt
__IO uint32_t bufcnt
Definition: at32f413_sdio.h:541
sdio_type::intwt
__IO uint32_t intwt
Definition: at32f413_sdio.h:308
sdio_type::rsp2
__IO uint32_t rsp2
Definition: at32f413_sdio.h:346
sdio_type::dtctrl
__IO uint32_t dtctrl
Definition: at32f413_sdio.h:407
sdio_type::dtfail
__IO uint32_t dtfail
Definition: at32f413_sdio.h:445
sdio_type::docmdien
__IO uint32_t docmdien
Definition: at32f413_sdio.h:515
sdio_type::dotxien
__IO uint32_t dotxien
Definition: at32f413_sdio.h:516
sdio_type::dotx
__IO uint32_t dotx
Definition: at32f413_sdio.h:456
sdio_type::rxerroien
__IO uint32_t rxerroien
Definition: at32f413_sdio.h:509
sdio_type::ccsmen
__IO uint32_t ccsmen
Definition: at32f413_sdio.h:310
sdio_type::txerruien
__IO uint32_t txerruien
Definition: at32f413_sdio.h:508
sdio_type::dttimeoutien
__IO uint32_t dttimeoutien
Definition: at32f413_sdio.h:507
sdio_type::pwrsven
__IO uint32_t pwrsven
Definition: at32f413_sdio.h:276
sdio_type::cmdidx
__IO uint32_t cmdidx
Definition: at32f413_sdio.h:306
sdio_type::cardsts3
__IO uint32_t cardsts3
Definition: at32f413_sdio.h:361
sdio_type::cardsts1
__IO uint32_t cardsts1
Definition: at32f413_sdio.h:337
sdio_type::pwrctrl
__IO uint32_t pwrctrl
Definition: at32f413_sdio.h:258
sdio_type::ioifien
__IO uint32_t ioifien
Definition: at32f413_sdio.h:526
sdio_type::dmaen
__IO uint32_t dmaen
Definition: at32f413_sdio.h:413
sdio_type::reserved2
__IO uint32_t reserved2
sdio reserved2 register, offset:0x4C~0x7C
Definition: at32f413_sdio.h:492
sdio_type::dtblkcmplien
__IO uint32_t dtblkcmplien
Definition: at32f413_sdio.h:514
sdio_type::rxbuffien
__IO uint32_t rxbuffien
Definition: at32f413_sdio.h:521
sdio_type::txbufh
__IO uint32_t txbufh
Definition: at32f413_sdio.h:458
sdio_type::sts
__IO uint32_t sts
Definition: at32f413_sdio.h:441
sdio_type::blksize
__IO uint32_t blksize
Definition: at32f413_sdio.h:414
sdio_type::cardsts2
__IO uint32_t cardsts2
Definition: at32f413_sdio.h:349
sdio_type::rdwtmode
__IO uint32_t rdwtmode
Definition: at32f413_sdio.h:417
sdio_type::txbufeien
__IO uint32_t txbufeien
Definition: at32f413_sdio.h:522
sdio_type::ioif
__IO uint32_t ioif
Definition: at32f413_sdio.h:466
sdio_type::cmdrspcmplien
__IO uint32_t cmdrspcmplien
Definition: at32f413_sdio.h:510
sdio_type::rxbufien
__IO uint32_t rxbufien
Definition: at32f413_sdio.h:525
sdio_type::dttimeout
__IO uint32_t dttimeout
Definition: at32f413_sdio.h:447
sdio_type::rxbufh
__IO uint32_t rxbufh
Definition: at32f413_sdio.h:459
sdio_type::txbufien
__IO uint32_t txbufien
Definition: at32f413_sdio.h:524
sdio_type::rsp1
__IO uint32_t rsp1
Definition: at32f413_sdio.h:334
sdio_type::rxbuff
__IO uint32_t rxbuff
Definition: at32f413_sdio.h:461
sdio_type::rsp4
__IO uint32_t rsp4
Definition: at32f413_sdio.h:370
sdio_type::bypsen
__IO uint32_t bypsen
Definition: at32f413_sdio.h:277
sdio_type::txbufe
__IO uint32_t txbufe
Definition: at32f413_sdio.h:462
sdio_type::cmdfailien
__IO uint32_t cmdfailien
Definition: at32f413_sdio.h:504
sdio_type::buf
__IO uint32_t buf
Definition: at32f413_sdio.h:559
sdio_type::clkdiv_l
__IO uint32_t clkdiv_l
Definition: at32f413_sdio.h:274
sdio_type::txerru
__IO uint32_t txerru
Definition: at32f413_sdio.h:448
sdio_type::dorxien
__IO uint32_t dorxien
Definition: at32f413_sdio.h:517
sdio_type::dt
__IO uint32_t dt
Definition: at32f413_sdio.h:562
sdio_type::rspcmd
__IO uint32_t rspcmd
Definition: at32f413_sdio.h:321
sdio_type::argu
__IO uint32_t argu
Definition: at32f413_sdio.h:291
sdio_type::timeout
__IO uint32_t timeout
Definition: at32f413_sdio.h:385
sdio_type::cmdtimeoutien
__IO uint32_t cmdtimeoutien
Definition: at32f413_sdio.h:506
sdio_type::busws
__IO uint32_t busws
Definition: at32f413_sdio.h:278
sdio_type::dtcnt
__IO uint32_t dtcnt
Definition: at32f413_sdio.h:428
sdio_type::clkdiv_h
__IO uint32_t clkdiv_h
Definition: at32f413_sdio.h:281
sdio_type::iosusp
__IO uint32_t iosusp
Definition: at32f413_sdio.h:311
sdio_type::txbuff
__IO uint32_t txbuff
Definition: at32f413_sdio.h:460
sdio_type::cmdrspcmpl
__IO uint32_t cmdrspcmpl
Definition: at32f413_sdio.h:450
sdio_type::txbuf
__IO uint32_t txbuf
Definition: at32f413_sdio.h:464
sdio_type::clkctrl
__IO uint32_t clkctrl
Definition: at32f413_sdio.h:271
sdio_type::sbiterrien
__IO uint32_t sbiterrien
Definition: at32f413_sdio.h:513
sdio_type::rsp3
__IO uint32_t rsp3
Definition: at32f413_sdio.h:358
sdio_type::rxerro
__IO uint32_t rxerro
Definition: at32f413_sdio.h:449


AT32F413 Firmwary Library: at32f413_spi.c Source File

  • libraries
  • drivers
  • src
at32f413_spi.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef SPI_MODULE_ENABLED
39
51void spi_i2s_reset(spi_type *spi_x)
52{
53 if(spi_x == SPI1)
54 {
55 crm_periph_reset(CRM_SPI1_PERIPH_RESET, TRUE);
56 crm_periph_reset(CRM_SPI1_PERIPH_RESET, FALSE);
57 }
58 else if(spi_x == SPI2)
59 {
60 crm_periph_reset(CRM_SPI2_PERIPH_RESET, TRUE);
61 crm_periph_reset(CRM_SPI2_PERIPH_RESET, FALSE);
62 }
63}
64
71void spi_default_para_init(spi_init_type* spi_init_struct)
72{
73 spi_init_struct->transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
74 spi_init_struct->master_slave_mode = SPI_MODE_SLAVE;
75 spi_init_struct->mclk_freq_division = SPI_MCLK_DIV_2;
76 spi_init_struct->first_bit_transmission = SPI_FIRST_BIT_MSB;
77 spi_init_struct->frame_bit_num = SPI_FRAME_8BIT;
78 spi_init_struct->clock_polarity = SPI_CLOCK_POLARITY_LOW;
79 spi_init_struct->clock_phase = SPI_CLOCK_PHASE_1EDGE;
80 spi_init_struct->cs_mode_selection = SPI_CS_SOFTWARE_MODE;
81}
82
91void spi_init(spi_type* spi_x, spi_init_type* spi_init_struct)
92{
93 spi_x->i2sctrl_bit.i2smsel = FALSE;
94 if(spi_init_struct->transmission_mode == SPI_TRANSMIT_FULL_DUPLEX)
95 {
96 spi_x->ctrl1_bit.slben = FALSE;
97 spi_x->ctrl1_bit.slbtd = FALSE;
98 spi_x->ctrl1_bit.ora = FALSE;
99 }
100 else if(spi_init_struct->transmission_mode == SPI_TRANSMIT_SIMPLEX_RX)
101 {
102 spi_x->ctrl1_bit.slben = FALSE;
103 spi_x->ctrl1_bit.slbtd = FALSE;
104 spi_x->ctrl1_bit.ora = TRUE;
105 }
106 else if(spi_init_struct->transmission_mode == SPI_TRANSMIT_HALF_DUPLEX_RX)
107 {
108 spi_x->ctrl1_bit.slben = TRUE;
109 spi_x->ctrl1_bit.slbtd = FALSE;
110 spi_x->ctrl1_bit.ora = FALSE;
111 }
112 else if(spi_init_struct->transmission_mode == SPI_TRANSMIT_HALF_DUPLEX_TX)
113 {
114 spi_x->ctrl1_bit.slben = TRUE;
115 spi_x->ctrl1_bit.slbtd = TRUE;
116 spi_x->ctrl1_bit.ora = FALSE;
117 }
118
119 spi_x->ctrl1_bit.swcsen = spi_init_struct->cs_mode_selection;
120 if((spi_init_struct->master_slave_mode == SPI_MODE_MASTER) && (spi_init_struct->cs_mode_selection == SPI_CS_SOFTWARE_MODE))
121 {
122 spi_x->ctrl1_bit.swcsil = TRUE;
123 }
124 else
125 {
126 spi_x->ctrl1_bit.swcsil = FALSE;
127 }
128 spi_x->ctrl1_bit.msten = spi_init_struct->master_slave_mode;
129 if(spi_init_struct->mclk_freq_division > SPI_MCLK_DIV_256)
130 {
131 spi_x->ctrl2_bit.mdiv_h = 1;
132 spi_x->ctrl1_bit.mdiv_l = spi_init_struct->mclk_freq_division & 0x7;
133 }
134 else
135 {
136 spi_x->ctrl2_bit.mdiv_h = 0;
137 spi_x->ctrl1_bit.mdiv_l = spi_init_struct->mclk_freq_division;
138 }
139 spi_x->ctrl1_bit.ltf = spi_init_struct->first_bit_transmission;
140 spi_x->ctrl1_bit.fbn = spi_init_struct->frame_bit_num;
141 spi_x->ctrl1_bit.clkpol = spi_init_struct->clock_polarity;
142 spi_x->ctrl1_bit.clkpha = spi_init_struct->clock_phase;
143}
144
152void spi_crc_next_transmit(spi_type* spi_x)
153{
154 spi_x->ctrl1_bit.ntc = TRUE;
155}
156
165void spi_crc_polynomial_set(spi_type* spi_x, uint16_t crc_poly)
166{
167 spi_x->cpoly_bit.cpoly = crc_poly;
168}
169
177uint16_t spi_crc_polynomial_get(spi_type* spi_x)
178{
179 return spi_x->cpoly_bit.cpoly;
180}
181
191void spi_crc_enable(spi_type* spi_x, confirm_state new_state)
192{
193 spi_x->ctrl1_bit.ccen = new_state;
194}
195
206uint16_t spi_crc_value_get(spi_type* spi_x, spi_crc_direction_type crc_direction)
207{
208 if(crc_direction == SPI_CRC_RX)
209 return spi_x->rcrc_bit.rcrc;
210 else
211 return spi_x->tcrc_bit.tcrc;
212}
213
224void spi_hardware_cs_output_enable(spi_type* spi_x, confirm_state new_state)
225{
226 spi_x->ctrl2_bit.hwcsoe = new_state;
227}
228
242void spi_software_cs_internal_level_set(spi_type* spi_x, spi_software_cs_level_type level)
243{
244 spi_x->ctrl1_bit.swcsil = level;
245}
246
257void spi_frame_bit_num_set(spi_type* spi_x, spi_frame_bit_num_type bit_num)
258{
259 spi_x->ctrl1_bit.fbn = bit_num;
260}
261
273void spi_half_duplex_direction_set(spi_type* spi_x, spi_half_duplex_direction_type direction)
274{
275 spi_x->ctrl1_bit.slbtd = direction;
276}
277
287void spi_enable(spi_type* spi_x, confirm_state new_state)
288{
289 spi_x->ctrl1_bit.spien = new_state;
290}
291
298void i2s_default_para_init(i2s_init_type* i2s_init_struct)
299{
300 i2s_init_struct->operation_mode = I2S_MODE_SLAVE_TX;
301 i2s_init_struct->audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
302 i2s_init_struct->audio_sampling_freq = I2S_AUDIO_FREQUENCY_DEFAULT;
303 i2s_init_struct->data_channel_format = I2S_DATA_16BIT_CHANNEL_16BIT;
304 i2s_init_struct->clock_polarity = I2S_CLOCK_POLARITY_LOW;
305 i2s_init_struct->mclk_output_enable = FALSE;
306}
307
316void i2s_init(spi_type* spi_x, i2s_init_type* i2s_init_struct)
317{
318 crm_clocks_freq_type clocks_freq;
319 uint32_t i2s_sclk_index = 0;
320 uint32_t i2sdiv_index = 2, i2sodd_index = 0, frequency_index = 0;
321
322 /* i2s audio frequency config */
323 if(i2s_init_struct->audio_sampling_freq == I2S_AUDIO_FREQUENCY_DEFAULT)
324 {
325 i2sodd_index = 0;
326 i2sdiv_index = 2;
327 }
328 else
329 {
330 crm_clocks_freq_get(&clocks_freq);
331 i2s_sclk_index = clocks_freq.sclk_freq;
332 if((i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_SHORT) || (i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_LONG))
333 {
334 if(i2s_init_struct->mclk_output_enable == TRUE)
335 {
336 frequency_index = (((i2s_sclk_index / 128) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
337 }
338 else
339 {
340 if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_16BIT)
341 frequency_index = (((i2s_sclk_index / 16) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
342 else
343 frequency_index = (((i2s_sclk_index / 32) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
344 }
345 }
346 else
347 {
348 if(i2s_init_struct->mclk_output_enable == TRUE)
349 {
350 frequency_index = (((i2s_sclk_index / 256) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
351 }
352 else
353 {
354 if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_16BIT)
355 frequency_index = (((i2s_sclk_index / 32) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
356 else
357 frequency_index = (((i2s_sclk_index / 64) * 10) / i2s_init_struct->audio_sampling_freq) + 5;
358 }
359 }
360 }
361 frequency_index = frequency_index / 10;
362 i2sodd_index = frequency_index & (uint16_t)0x0001;
363 i2sdiv_index = (frequency_index - i2sodd_index) / 2;
364 if((i2sdiv_index < 2) || (i2sdiv_index > 0x03FF))
365 {
366 i2sodd_index = 0;
367 i2sdiv_index = 2;
368 }
369 spi_x->i2sclk_bit.i2sodd = i2sodd_index;
370 if(i2sdiv_index > 0x00FF)
371 {
372 spi_x->i2sclk_bit.i2sdiv_h = (i2sdiv_index >> 8) & 0x0003;
373 spi_x->i2sclk_bit.i2sdiv_l = i2sdiv_index & 0x00FF;
374 }
375 else
376 {
377 spi_x->i2sclk_bit.i2sdiv_h = 0;
378 spi_x->i2sclk_bit.i2sdiv_l = i2sdiv_index;
379 }
380
381 /* i2s audio_protocol set*/
382 if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_LONG)
383 {
384 spi_x->i2sctrl_bit.pcmfssel = 1;
385 spi_x->i2sctrl_bit.stdsel = 3;
386 }
387 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PCM_SHORT)
388 {
389 spi_x->i2sctrl_bit.pcmfssel = 0;
390 spi_x->i2sctrl_bit.stdsel = 3;
391 }
392 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_LSB)
393 {
394 spi_x->i2sctrl_bit.pcmfssel = 0;
395 spi_x->i2sctrl_bit.stdsel = 2;
396 }
397 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_MSB)
398 {
399 spi_x->i2sctrl_bit.pcmfssel = 0;
400 spi_x->i2sctrl_bit.stdsel = 1;
401 }
402 else if(i2s_init_struct->audio_protocol == I2S_AUDIO_PROTOCOL_PHILLIPS)
403 {
404 spi_x->i2sctrl_bit.pcmfssel = 0;
405 spi_x->i2sctrl_bit.stdsel = 0;
406 }
407
408 /* i2s data_channel_format set*/
409 if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_16BIT)
410 {
411 spi_x->i2sctrl_bit.i2scbn = 0;
412 spi_x->i2sctrl_bit.i2sdbn = 0;
413 }
414 else if(i2s_init_struct->data_channel_format == I2S_DATA_16BIT_CHANNEL_32BIT)
415 {
416 spi_x->i2sctrl_bit.i2scbn = 1;
417 spi_x->i2sctrl_bit.i2sdbn = 0;
418 }
419 else if(i2s_init_struct->data_channel_format == I2S_DATA_24BIT_CHANNEL_32BIT)
420 {
421 spi_x->i2sctrl_bit.i2scbn = 1;
422 spi_x->i2sctrl_bit.i2sdbn = 1;
423 }
424 else if(i2s_init_struct->data_channel_format == I2S_DATA_32BIT_CHANNEL_32BIT)
425 {
426 spi_x->i2sctrl_bit.i2scbn = 1;
427 spi_x->i2sctrl_bit.i2sdbn = 2;
428 }
429
430 spi_x->i2sctrl_bit.i2sclkpol = i2s_init_struct->clock_polarity;
431 spi_x->i2sclk_bit.i2smclkoe = i2s_init_struct->mclk_output_enable;
432 spi_x->i2sctrl_bit.opersel = i2s_init_struct->operation_mode;
433 spi_x->i2sctrl_bit.i2smsel = TRUE;
434}
435
445void i2s_enable(spi_type* spi_x, confirm_state new_state)
446{
447 spi_x->i2sctrl_bit.i2sen = new_state;
448}
449
464void spi_i2s_interrupt_enable(spi_type* spi_x, uint32_t spi_i2s_int, confirm_state new_state)
465{
466 if(new_state != FALSE)
467 {
468 spi_x->ctrl2 |= spi_i2s_int;
469 }
470 else
471 {
472 spi_x->ctrl2 &= ~spi_i2s_int;
473 }
474}
475
485void spi_i2s_dma_transmitter_enable(spi_type* spi_x, confirm_state new_state)
486{
487 spi_x->ctrl2_bit.dmaten = new_state;
488}
489
499void spi_i2s_dma_receiver_enable(spi_type* spi_x, confirm_state new_state)
500{
501 spi_x->ctrl2_bit.dmaren = new_state;
502}
503
514void spi_i2s_data_transmit(spi_type* spi_x, uint16_t tx_data)
515{
516 spi_x->dt = tx_data;
517}
518
526uint16_t spi_i2s_data_receive(spi_type* spi_x)
527{
528 return (uint16_t)spi_x->dt;
529}
530
548 flag_status spi_i2s_flag_get(spi_type* spi_x, uint32_t spi_i2s_flag)
549{
550 flag_status status = RESET;
551 if ((spi_x->sts & spi_i2s_flag) == RESET)
552 {
553 status = RESET;
554 }
555 else
556 {
557 status = SET;
558 }
559 return status;
560}
561
580void spi_i2s_flag_clear(spi_type* spi_x, uint32_t spi_i2s_flag)
581{
582 volatile uint32_t temp = 0;
583 temp = temp;
584 if(spi_i2s_flag == SPI_CCERR_FLAG)
585 spi_x->sts = ~SPI_CCERR_FLAG;
586 else if(spi_i2s_flag == SPI_I2S_RDBF_FLAG)
587 temp = REG32(&spi_x->dt);
588 else if(spi_i2s_flag == I2S_TUERR_FLAG)
589 temp = REG32(&spi_x->sts);
590 else if(spi_i2s_flag == SPI_MMERR_FLAG)
591 {
592 temp = REG32(&spi_x->sts);
593 spi_x->ctrl1 = spi_x->ctrl1;
594 }
595 else if(spi_i2s_flag == SPI_I2S_ROERR_FLAG)
596 {
597 temp = REG32(&spi_x->dt);
598 temp = REG32(&spi_x->sts);
599 }
600}
601
606#endif
607
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:41
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_SPI1_PERIPH_RESET
@ CRM_SPI1_PERIPH_RESET
Definition: at32f413_crm.h:162
CRM_SPI2_PERIPH_RESET
@ CRM_SPI2_PERIPH_RESET
Definition: at32f413_crm.h:175
REG32
#define REG32(addr)
Definition: at32f413.h:276
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
I2S_TUERR_FLAG
#define I2S_TUERR_FLAG
Definition: at32f413_spi.h:56
SPI_CCERR_FLAG
#define SPI_CCERR_FLAG
Definition: at32f413_spi.h:57
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
SPI_MMERR_FLAG
#define SPI_MMERR_FLAG
Definition: at32f413_spi.h:58
SPI_I2S_ROERR_FLAG
#define SPI_I2S_ROERR_FLAG
Definition: at32f413_spi.h:59
spi_software_cs_level_type
spi_software_cs_level_type
spi software cs internal level type
Definition: at32f413_spi.h:188
spi_half_duplex_direction_type
spi_half_duplex_direction_type
spi single line bidirectional direction type
Definition: at32f413_spi.h:179
spi_frame_bit_num_type
spi_frame_bit_num_type
spi frame bit num type
Definition: at32f413_spi.h:88
spi_crc_direction_type
spi_crc_direction_type
spi crc direction type
Definition: at32f413_spi.h:170
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:249
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f413_spi.h:227
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:229
I2S_DATA_32BIT_CHANNEL_32BIT
@ I2S_DATA_32BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:230
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:228
SPI_CLOCK_PHASE_1EDGE
@ SPI_CLOCK_PHASE_1EDGE
Definition: at32f413_spi.h:116
I2S_AUDIO_FREQUENCY_DEFAULT
@ I2S_AUDIO_FREQUENCY_DEFAULT
Definition: at32f413_spi.h:210
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:151
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:107
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:162
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:160
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:163
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f413_spi.h:161
I2S_AUDIO_PROTOCOL_PCM_LONG
@ I2S_AUDIO_PROTOCOL_PCM_LONG
Definition: at32f413_spi.h:202
I2S_AUDIO_PROTOCOL_LSB
@ I2S_AUDIO_PROTOCOL_LSB
Definition: at32f413_spi.h:200
I2S_AUDIO_PROTOCOL_MSB
@ I2S_AUDIO_PROTOCOL_MSB
Definition: at32f413_spi.h:199
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:198
I2S_AUDIO_PROTOCOL_PCM_SHORT
@ I2S_AUDIO_PROTOCOL_PCM_SHORT
Definition: at32f413_spi.h:201
SPI_MCLK_DIV_2
@ SPI_MCLK_DIV_2
Definition: at32f413_spi.h:134
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f413_spi.h:141
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:89
SPI_CRC_RX
@ SPI_CRC_RX
Definition: at32f413_spi.h:171
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:238
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:464
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:316
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_crc_enable
void spi_crc_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral.
Definition: at32f413_spi.c:191
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:499
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:445
spi_crc_polynomial_get
uint16_t spi_crc_polynomial_get(spi_type *spi_x)
return the crc polynomial register value for the spi peripheral.
Definition: at32f413_spi.c:177
spi_crc_next_transmit
void spi_crc_next_transmit(spi_type *spi_x)
spi next transmit crc for the spi peripheral.
Definition: at32f413_spi.c:152
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_crc_polynomial_set
void spi_crc_polynomial_set(spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral.
Definition: at32f413_spi.c:165
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
spi_crc_value_get
uint16_t spi_crc_value_get(spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral.
Definition: at32f413_spi.c:206
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:51
spi_half_duplex_direction_set
void spi_half_duplex_direction_set(spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi periphera...
Definition: at32f413_spi.c:273
spi_hardware_cs_output_enable
void spi_hardware_cs_output_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral.
Definition: at32f413_spi.c:224
spi_i2s_flag_clear
void spi_i2s_flag_clear(spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:580
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:298
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:485
spi_frame_bit_num_set
void spi_frame_bit_num_set(spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral.
Definition: at32f413_spi.c:257
spi_software_cs_internal_level_set
void spi_software_cs_internal_level_set(spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral.
Definition: at32f413_spi.c:242
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
i2s_init_type
i2s init type
Definition: at32f413_spi.h:272
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:275
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:276
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:278
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:274
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:273
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:277
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
spi_type
type define spi register all
Definition: at32f413_spi.h:285
spi_type::i2sctrl_bit
struct spi_type::@635::@646 i2sctrl_bit
spi_type::clkpha
__IO uint32_t clkpha
Definition: at32f413_spi.h:295
spi_type::hwcsoe
__IO uint32_t hwcsoe
Definition: at32f413_spi.h:323
spi_type::slben
__IO uint32_t slben
Definition: at32f413_spi.h:308
spi_type::ntc
__IO uint32_t ntc
Definition: at32f413_spi.h:305
spi_type::mdiv_h
__IO uint32_t mdiv_h
Definition: at32f413_spi.h:328
spi_type::dmaren
__IO uint32_t dmaren
Definition: at32f413_spi.h:321
spi_type::i2sclk_bit
struct spi_type::@637::@647 i2sclk_bit
spi_type::i2sdbn
__IO uint32_t i2sdbn
Definition: at32f413_spi.h:414
spi_type::rcrc
__IO uint32_t rcrc
Definition: at32f413_spi.h:384
spi_type::i2scbn
__IO uint32_t i2scbn
Definition: at32f413_spi.h:413
spi_type::i2sclkpol
__IO uint32_t i2sclkpol
Definition: at32f413_spi.h:415
spi_type::cpoly
__IO uint32_t cpoly
Definition: at32f413_spi.h:371
spi_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_spi.h:292
spi_type::i2sodd
__IO uint32_t i2sodd
Definition: at32f413_spi.h:435
spi_type::swcsil
__IO uint32_t swcsil
Definition: at32f413_spi.h:301
spi_type::tcrc
__IO uint32_t tcrc
Definition: at32f413_spi.h:397
spi_type::i2smclkoe
__IO uint32_t i2smclkoe
Definition: at32f413_spi.h:436
spi_type::ltf
__IO uint32_t ltf
Definition: at32f413_spi.h:300
spi_type::clkpol
__IO uint32_t clkpol
Definition: at32f413_spi.h:296
spi_type::ctrl1_bit
struct spi_type::@621::@639 ctrl1_bit
spi_type::slbtd
__IO uint32_t slbtd
Definition: at32f413_spi.h:307
spi_type::dmaten
__IO uint32_t dmaten
Definition: at32f413_spi.h:322
spi_type::ccen
__IO uint32_t ccen
Definition: at32f413_spi.h:306
spi_type::fbn
__IO uint32_t fbn
Definition: at32f413_spi.h:304
spi_type::dt
__IO uint32_t dt
Definition: at32f413_spi.h:358
spi_type::msten
__IO uint32_t msten
Definition: at32f413_spi.h:297
spi_type::sts
__IO uint32_t sts
Definition: at32f413_spi.h:338
spi_type::ctrl2_bit
struct spi_type::@623::@640 ctrl2_bit
spi_type::i2sdiv_h
__IO uint32_t i2sdiv_h
Definition: at32f413_spi.h:437
spi_type::opersel
__IO uint32_t opersel
Definition: at32f413_spi.h:419
spi_type::i2sdiv_l
__IO uint32_t i2sdiv_l
Definition: at32f413_spi.h:434
spi_type::cpoly_bit
struct spi_type::@629::@643 cpoly_bit
spi_type::i2smsel
__IO uint32_t i2smsel
Definition: at32f413_spi.h:421
spi_type::tcrc_bit
struct spi_type::@633::@645 tcrc_bit
spi_type::pcmfssel
__IO uint32_t pcmfssel
Definition: at32f413_spi.h:418
spi_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_spi.h:318
spi_type::stdsel
__IO uint32_t stdsel
Definition: at32f413_spi.h:416
spi_type::mdiv_l
__IO uint32_t mdiv_l
Definition: at32f413_spi.h:298
spi_type::spien
__IO uint32_t spien
Definition: at32f413_spi.h:299
spi_type::swcsen
__IO uint32_t swcsen
Definition: at32f413_spi.h:302
spi_type::ora
__IO uint32_t ora
Definition: at32f413_spi.h:303
spi_type::i2sen
__IO uint32_t i2sen
Definition: at32f413_spi.h:420
spi_type::rcrc_bit
struct spi_type::@631::@644 rcrc_bit
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_spi.h Source File

  • libraries
  • drivers
  • inc
at32f413_spi.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_SPI_H
29#define __AT32F413_SPI_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
53#define SPI_I2S_RDBF_FLAG 0x0001
54#define SPI_I2S_TDBE_FLAG 0x0002
55#define I2S_ACS_FLAG 0x0004
56#define I2S_TUERR_FLAG 0x0008
57#define SPI_CCERR_FLAG 0x0010
58#define SPI_MMERR_FLAG 0x0020
59#define SPI_I2S_ROERR_FLAG 0x0040
60#define SPI_I2S_BF_FLAG 0x0080
72#define SPI_I2S_ERROR_INT 0x0020
73#define SPI_I2S_RDBF_INT 0x0040
74#define SPI_I2S_TDBE_INT 0x0080
87typedef enum
88{
89 SPI_FRAME_8BIT = 0x00,
90 SPI_FRAME_16BIT = 0x01
91} spi_frame_bit_num_type;
92
96typedef enum
97{
98 SPI_MODE_SLAVE = 0x00,
99 SPI_MODE_MASTER = 0x01
100} spi_master_slave_mode_type;
101
105typedef enum
106{
107 SPI_CLOCK_POLARITY_LOW = 0x00,
108 SPI_CLOCK_POLARITY_HIGH = 0x01
109} spi_clock_polarity_type;
110
114typedef enum
115{
116 SPI_CLOCK_PHASE_1EDGE = 0x00,
117 SPI_CLOCK_PHASE_2EDGE = 0x01
118} spi_clock_phase_type;
119
123typedef enum
124{
125 SPI_CS_HARDWARE_MODE = 0x00,
126 SPI_CS_SOFTWARE_MODE = 0x01
127} spi_cs_mode_type;
128
132typedef enum
133{
134 SPI_MCLK_DIV_2 = 0x00,
135 SPI_MCLK_DIV_4 = 0x01,
136 SPI_MCLK_DIV_8 = 0x02,
137 SPI_MCLK_DIV_16 = 0x03,
138 SPI_MCLK_DIV_32 = 0x04,
139 SPI_MCLK_DIV_64 = 0x05,
140 SPI_MCLK_DIV_128 = 0x06,
141 SPI_MCLK_DIV_256 = 0x07,
142 SPI_MCLK_DIV_512 = 0x08,
143 SPI_MCLK_DIV_1024 = 0x09
144} spi_mclk_freq_div_type;
145
149typedef enum
150{
151 SPI_FIRST_BIT_MSB = 0x00,
152 SPI_FIRST_BIT_LSB = 0x01
153} spi_first_bit_type;
154
158typedef enum
159{
160 SPI_TRANSMIT_FULL_DUPLEX = 0x00,
161 SPI_TRANSMIT_SIMPLEX_RX = 0x01,
162 SPI_TRANSMIT_HALF_DUPLEX_RX = 0x02,
163 SPI_TRANSMIT_HALF_DUPLEX_TX = 0x03
164} spi_transmission_mode_type;
165
169typedef enum
170{
171 SPI_CRC_RX = 0x0014,
172 SPI_CRC_TX = 0x0018
173} spi_crc_direction_type;
174
178typedef enum
179{
180 SPI_HALF_DUPLEX_DIRECTION_RX = 0x00,
181 SPI_HALF_DUPLEX_DIRECTION_TX = 0x01
182} spi_half_duplex_direction_type;
183
187typedef enum
188{
189 SPI_SWCS_INTERNAL_LEVEL_LOW = 0x00,
190 SPI_SWCS_INTERNAL_LEVEL_HIGHT = 0x01
191} spi_software_cs_level_type;
192
196typedef enum
197{
198 I2S_AUDIO_PROTOCOL_PHILLIPS = 0x00,
199 I2S_AUDIO_PROTOCOL_MSB = 0x01,
200 I2S_AUDIO_PROTOCOL_LSB = 0x02,
201 I2S_AUDIO_PROTOCOL_PCM_SHORT = 0x03,
202 I2S_AUDIO_PROTOCOL_PCM_LONG = 0x04
203} i2s_audio_protocol_type;
204
208typedef enum
209{
210 I2S_AUDIO_FREQUENCY_DEFAULT = 2,
211 I2S_AUDIO_FREQUENCY_8K = 8000,
212 I2S_AUDIO_FREQUENCY_11_025K = 11025,
213 I2S_AUDIO_FREQUENCY_16K = 16000,
214 I2S_AUDIO_FREQUENCY_22_05K = 22050,
215 I2S_AUDIO_FREQUENCY_32K = 32000,
216 I2S_AUDIO_FREQUENCY_44_1K = 44100,
217 I2S_AUDIO_FREQUENCY_48K = 48000,
218 I2S_AUDIO_FREQUENCY_96K = 96000,
219 I2S_AUDIO_FREQUENCY_192K = 192000
220} i2s_audio_sampling_freq_type;
221
225typedef enum
226{
227 I2S_DATA_16BIT_CHANNEL_16BIT = 0x01,
228 I2S_DATA_16BIT_CHANNEL_32BIT = 0x02,
229 I2S_DATA_24BIT_CHANNEL_32BIT = 0x03,
230 I2S_DATA_32BIT_CHANNEL_32BIT = 0x04
231} i2s_data_channel_format_type;
232
236typedef enum
237{
238 I2S_MODE_SLAVE_TX = 0x00,
239 I2S_MODE_SLAVE_RX = 0x01,
240 I2S_MODE_MASTER_TX = 0x02,
241 I2S_MODE_MASTER_RX = 0x03
242} i2s_operation_mode_type;
243
247typedef enum
248{
249 I2S_CLOCK_POLARITY_LOW = 0x00,
250 I2S_CLOCK_POLARITY_HIGH = 0x01
251} i2s_clock_polarity_type;
252
256typedef struct
257{
258 spi_transmission_mode_type transmission_mode;
259 spi_master_slave_mode_type master_slave_mode;
260 spi_mclk_freq_div_type mclk_freq_division;
261 spi_first_bit_type first_bit_transmission;
262 spi_frame_bit_num_type frame_bit_num;
263 spi_clock_polarity_type clock_polarity;
264 spi_clock_phase_type clock_phase;
265 spi_cs_mode_type cs_mode_selection;
266} spi_init_type;
267
271typedef struct
272{
273 i2s_operation_mode_type operation_mode;
274 i2s_audio_protocol_type audio_protocol;
275 i2s_audio_sampling_freq_type audio_sampling_freq;
276 i2s_data_channel_format_type data_channel_format;
277 i2s_clock_polarity_type clock_polarity;
278 confirm_state mclk_output_enable;
279} i2s_init_type;
280
284typedef struct
285{
286
290 union
291 {
292 __IO uint32_t ctrl1;
293 struct
294 {
295 __IO uint32_t clkpha : 1; /* [0] */
296 __IO uint32_t clkpol : 1; /* [1] */
297 __IO uint32_t msten : 1; /* [2] */
298 __IO uint32_t mdiv_l : 3; /* [5:3] */
299 __IO uint32_t spien : 1; /* [6] */
300 __IO uint32_t ltf : 1; /* [7] */
301 __IO uint32_t swcsil : 1; /* [8] */
302 __IO uint32_t swcsen : 1; /* [9] */
303 __IO uint32_t ora : 1; /* [10] */
304 __IO uint32_t fbn : 1; /* [11] */
305 __IO uint32_t ntc : 1; /* [12] */
306 __IO uint32_t ccen : 1; /* [13] */
307 __IO uint32_t slbtd : 1; /* [14] */
308 __IO uint32_t slben : 1; /* [15] */
309 __IO uint32_t reserved1 : 16;/* [31:16] */
310 } ctrl1_bit;
311 };
312
316 union
317 {
318 __IO uint32_t ctrl2;
319 struct
320 {
321 __IO uint32_t dmaren : 1; /* [0] */
322 __IO uint32_t dmaten : 1; /* [1] */
323 __IO uint32_t hwcsoe : 1; /* [2] */
324 __IO uint32_t reserved1 : 2; /* [4:3] */
325 __IO uint32_t errie : 1; /* [5] */
326 __IO uint32_t rdbfie : 1; /* [6] */
327 __IO uint32_t tdbeie : 1; /* [7] */
328 __IO uint32_t mdiv_h : 1; /* [8] */
329 __IO uint32_t reserved2 : 23;/* [31:9] */
330 } ctrl2_bit;
331 };
332
336 union
337 {
338 __IO uint32_t sts;
339 struct
340 {
341 __IO uint32_t rdbf : 1; /* [0] */
342 __IO uint32_t tdbe : 1; /* [1] */
343 __IO uint32_t acs : 1; /* [2] */
344 __IO uint32_t tuerr : 1; /* [3] */
345 __IO uint32_t ccerr : 1; /* [4] */
346 __IO uint32_t mmerr : 1; /* [5] */
347 __IO uint32_t roerr : 1; /* [6] */
348 __IO uint32_t bf : 1; /* [7] */
349 __IO uint32_t reserved1 : 24;/* [31:8] */
350 } sts_bit;
351 };
352
356 union
357 {
358 __IO uint32_t dt;
359 struct
360 {
361 __IO uint32_t dt : 16;/* [15:0] */
362 __IO uint32_t reserved1 : 16;/* [31:16] */
363 } dt_bit;
364 };
365
369 union
370 {
371 __IO uint32_t cpoly;
372 struct
373 {
374 __IO uint32_t cpoly : 16;/* [15:0] */
375 __IO uint32_t reserved1 : 16;/* [31:16] */
376 } cpoly_bit;
377 };
378
382 union
383 {
384 __IO uint32_t rcrc;
385 struct
386 {
387 __IO uint32_t rcrc : 16;/* [15:0] */
388 __IO uint32_t reserved1 : 16;/* [31:16] */
389 } rcrc_bit;
390 };
391
395 union
396 {
397 __IO uint32_t tcrc;
398 struct
399 {
400 __IO uint32_t tcrc : 16;/* [15:0] */
401 __IO uint32_t reserved1 : 16;/* [31:16] */
402 } tcrc_bit;
403 };
404
408 union
409 {
410 __IO uint32_t i2sctrl;
411 struct
412 {
413 __IO uint32_t i2scbn : 1; /* [0] */
414 __IO uint32_t i2sdbn : 2; /* [2:1] */
415 __IO uint32_t i2sclkpol : 1; /* [3] */
416 __IO uint32_t stdsel : 2; /* [5:4] */
417 __IO uint32_t reserved1 : 1; /* [6] */
418 __IO uint32_t pcmfssel : 1; /* [7] */
419 __IO uint32_t opersel : 2; /* [9:8] */
420 __IO uint32_t i2sen : 1; /* [10] */
421 __IO uint32_t i2smsel : 1; /* [11] */
422 __IO uint32_t reserved2 : 20;/* [31:12] */
423 } i2sctrl_bit;
424 };
425
429 union
430 {
431 __IO uint32_t i2sclk;
432 struct
433 {
434 __IO uint32_t i2sdiv_l : 8; /* [7:0] */
435 __IO uint32_t i2sodd : 1; /* [8] */
436 __IO uint32_t i2smclkoe : 1; /* [9] */
437 __IO uint32_t i2sdiv_h : 2; /* [11:10] */
438 __IO uint32_t reserved1 : 20;/* [31:12] */
439 } i2sclk_bit;
440 };
441
442} spi_type;
443
448#define SPI1 ((spi_type *) SPI1_BASE)
449#define SPI2 ((spi_type *) SPI2_BASE)
450
451
456void spi_i2s_reset(spi_type *spi_x);
457void spi_default_para_init(spi_init_type* spi_init_struct);
458void spi_init(spi_type* spi_x, spi_init_type* spi_init_struct);
459void spi_crc_next_transmit(spi_type* spi_x);
460void spi_crc_polynomial_set(spi_type* spi_x, uint16_t crc_poly);
461uint16_t spi_crc_polynomial_get(spi_type* spi_x);
462void spi_crc_enable(spi_type* spi_x, confirm_state new_state);
463uint16_t spi_crc_value_get(spi_type* spi_x, spi_crc_direction_type crc_direction);
464void spi_hardware_cs_output_enable(spi_type* spi_x, confirm_state new_state);
465void spi_software_cs_internal_level_set(spi_type* spi_x, spi_software_cs_level_type level);
466void spi_frame_bit_num_set(spi_type* spi_x, spi_frame_bit_num_type bit_num);
467void spi_half_duplex_direction_set(spi_type* spi_x, spi_half_duplex_direction_type direction);
468void spi_enable(spi_type* spi_x, confirm_state new_state);
469void i2s_default_para_init(i2s_init_type* i2s_init_struct);
470void i2s_init(spi_type* spi_x, i2s_init_type* i2s_init_struct);
471void i2s_enable(spi_type* spi_x, confirm_state new_state);
472void spi_i2s_interrupt_enable(spi_type* spi_x, uint32_t spi_i2s_int, confirm_state new_state);
473void spi_i2s_dma_transmitter_enable(spi_type* spi_x, confirm_state new_state);
474void spi_i2s_dma_receiver_enable(spi_type* spi_x, confirm_state new_state);
475void spi_i2s_data_transmit(spi_type* spi_x, uint16_t tx_data);
476uint16_t spi_i2s_data_receive(spi_type* spi_x);
477 flag_status spi_i2s_flag_get(spi_type* spi_x, uint32_t spi_i2s_flag);
478void spi_i2s_flag_clear(spi_type* spi_x, uint32_t spi_i2s_flag);
479
492#ifdef __cplusplus
493}
494#endif
495
496#endif
at32f413.h
at32f413 header file
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:41
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:464
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:316
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_crc_enable
void spi_crc_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral.
Definition: at32f413_spi.c:191
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:499
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:445
spi_crc_polynomial_get
uint16_t spi_crc_polynomial_get(spi_type *spi_x)
return the crc polynomial register value for the spi peripheral.
Definition: at32f413_spi.c:177
spi_crc_next_transmit
void spi_crc_next_transmit(spi_type *spi_x)
spi next transmit crc for the spi peripheral.
Definition: at32f413_spi.c:152
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_crc_polynomial_set
void spi_crc_polynomial_set(spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral.
Definition: at32f413_spi.c:165
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
spi_crc_value_get
uint16_t spi_crc_value_get(spi_type *spi_x, spi_crc_direction_type crc_direction)
return the transmit or the receive crc value for the spi peripheral.
Definition: at32f413_spi.c:206
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:51
spi_half_duplex_direction_set
void spi_half_duplex_direction_set(spi_type *spi_x, spi_half_duplex_direction_type direction)
set the data transmission direction in single line bidirectiona half duplex mode of the spi periphera...
Definition: at32f413_spi.c:273
spi_hardware_cs_output_enable
void spi_hardware_cs_output_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral.
Definition: at32f413_spi.c:224
spi_i2s_flag_clear
void spi_i2s_flag_clear(spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:580
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:298
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:485
spi_frame_bit_num_set
void spi_frame_bit_num_set(spi_type *spi_x, spi_frame_bit_num_type bit_num)
set the data frame bit num for the spi peripheral.
Definition: at32f413_spi.c:257
spi_software_cs_internal_level_set
void spi_software_cs_internal_level_set(spi_type *spi_x, spi_software_cs_level_type level)
set the software cs internal level for the spi peripheral.
Definition: at32f413_spi.c:242
i2s_clock_polarity_type
i2s_clock_polarity_type
i2s clock polarity type
Definition: at32f413_spi.h:248
spi_master_slave_mode_type
spi_master_slave_mode_type
spi master/slave mode type
Definition: at32f413_spi.h:97
spi_software_cs_level_type
spi_software_cs_level_type
spi software cs internal level type
Definition: at32f413_spi.h:188
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f413_spi.h:226
spi_clock_phase_type
spi_clock_phase_type
spi clock phase (clkpha) type
Definition: at32f413_spi.h:115
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f413_spi.h:209
spi_cs_mode_type
spi_cs_mode_type
spi cs mode type
Definition: at32f413_spi.h:124
spi_first_bit_type
spi_first_bit_type
spi transmit first bit (lsb/msb) type
Definition: at32f413_spi.h:150
spi_clock_polarity_type
spi_clock_polarity_type
spi clock polarity (clkpol) type
Definition: at32f413_spi.h:106
spi_half_duplex_direction_type
spi_half_duplex_direction_type
spi single line bidirectional direction type
Definition: at32f413_spi.h:179
spi_transmission_mode_type
spi_transmission_mode_type
spi transmission mode type
Definition: at32f413_spi.h:159
i2s_audio_protocol_type
i2s_audio_protocol_type
i2s audio protocol type
Definition: at32f413_spi.h:197
spi_mclk_freq_div_type
spi_mclk_freq_div_type
spi master clock frequency division type
Definition: at32f413_spi.h:133
spi_frame_bit_num_type
spi_frame_bit_num_type
spi frame bit num type
Definition: at32f413_spi.h:88
spi_crc_direction_type
spi_crc_direction_type
spi crc direction type
Definition: at32f413_spi.h:170
i2s_operation_mode_type
i2s_operation_mode_type
i2s operation mode type
Definition: at32f413_spi.h:237
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:249
I2S_CLOCK_POLARITY_HIGH
@ I2S_CLOCK_POLARITY_HIGH
Definition: at32f413_spi.h:250
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
SPI_SWCS_INTERNAL_LEVEL_LOW
@ SPI_SWCS_INTERNAL_LEVEL_LOW
Definition: at32f413_spi.h:189
SPI_SWCS_INTERNAL_LEVEL_HIGHT
@ SPI_SWCS_INTERNAL_LEVEL_HIGHT
Definition: at32f413_spi.h:190
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f413_spi.h:227
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:229
I2S_DATA_32BIT_CHANNEL_32BIT
@ I2S_DATA_32BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:230
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:228
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
SPI_CLOCK_PHASE_1EDGE
@ SPI_CLOCK_PHASE_1EDGE
Definition: at32f413_spi.h:116
I2S_AUDIO_FREQUENCY_44_1K
@ I2S_AUDIO_FREQUENCY_44_1K
Definition: at32f413_spi.h:216
I2S_AUDIO_FREQUENCY_11_025K
@ I2S_AUDIO_FREQUENCY_11_025K
Definition: at32f413_spi.h:212
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f413_spi.h:217
I2S_AUDIO_FREQUENCY_DEFAULT
@ I2S_AUDIO_FREQUENCY_DEFAULT
Definition: at32f413_spi.h:210
I2S_AUDIO_FREQUENCY_8K
@ I2S_AUDIO_FREQUENCY_8K
Definition: at32f413_spi.h:211
I2S_AUDIO_FREQUENCY_32K
@ I2S_AUDIO_FREQUENCY_32K
Definition: at32f413_spi.h:215
I2S_AUDIO_FREQUENCY_192K
@ I2S_AUDIO_FREQUENCY_192K
Definition: at32f413_spi.h:219
I2S_AUDIO_FREQUENCY_96K
@ I2S_AUDIO_FREQUENCY_96K
Definition: at32f413_spi.h:218
I2S_AUDIO_FREQUENCY_22_05K
@ I2S_AUDIO_FREQUENCY_22_05K
Definition: at32f413_spi.h:214
I2S_AUDIO_FREQUENCY_16K
@ I2S_AUDIO_FREQUENCY_16K
Definition: at32f413_spi.h:213
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_CS_HARDWARE_MODE
@ SPI_CS_HARDWARE_MODE
Definition: at32f413_spi.h:125
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f413_spi.h:152
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:151
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f413_spi.h:108
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:107
SPI_HALF_DUPLEX_DIRECTION_TX
@ SPI_HALF_DUPLEX_DIRECTION_TX
Definition: at32f413_spi.h:181
SPI_HALF_DUPLEX_DIRECTION_RX
@ SPI_HALF_DUPLEX_DIRECTION_RX
Definition: at32f413_spi.h:180
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:162
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:160
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:163
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f413_spi.h:161
I2S_AUDIO_PROTOCOL_PCM_LONG
@ I2S_AUDIO_PROTOCOL_PCM_LONG
Definition: at32f413_spi.h:202
I2S_AUDIO_PROTOCOL_LSB
@ I2S_AUDIO_PROTOCOL_LSB
Definition: at32f413_spi.h:200
I2S_AUDIO_PROTOCOL_MSB
@ I2S_AUDIO_PROTOCOL_MSB
Definition: at32f413_spi.h:199
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:198
I2S_AUDIO_PROTOCOL_PCM_SHORT
@ I2S_AUDIO_PROTOCOL_PCM_SHORT
Definition: at32f413_spi.h:201
SPI_MCLK_DIV_16
@ SPI_MCLK_DIV_16
Definition: at32f413_spi.h:137
SPI_MCLK_DIV_64
@ SPI_MCLK_DIV_64
Definition: at32f413_spi.h:139
SPI_MCLK_DIV_128
@ SPI_MCLK_DIV_128
Definition: at32f413_spi.h:140
SPI_MCLK_DIV_4
@ SPI_MCLK_DIV_4
Definition: at32f413_spi.h:135
SPI_MCLK_DIV_512
@ SPI_MCLK_DIV_512
Definition: at32f413_spi.h:142
SPI_MCLK_DIV_32
@ SPI_MCLK_DIV_32
Definition: at32f413_spi.h:138
SPI_MCLK_DIV_2
@ SPI_MCLK_DIV_2
Definition: at32f413_spi.h:134
SPI_MCLK_DIV_1024
@ SPI_MCLK_DIV_1024
Definition: at32f413_spi.h:143
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f413_spi.h:141
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:136
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:89
SPI_FRAME_16BIT
@ SPI_FRAME_16BIT
Definition: at32f413_spi.h:90
SPI_CRC_RX
@ SPI_CRC_RX
Definition: at32f413_spi.h:171
SPI_CRC_TX
@ SPI_CRC_TX
Definition: at32f413_spi.h:172
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f413_spi.h:240
I2S_MODE_MASTER_RX
@ I2S_MODE_MASTER_RX
Definition: at32f413_spi.h:241
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:239
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:238
i2s_init_type
i2s init type
Definition: at32f413_spi.h:272
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:275
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:276
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:278
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:274
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:273
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:277
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
spi_type
type define spi register all
Definition: at32f413_spi.h:285
spi_type::tdbe
__IO uint32_t tdbe
Definition: at32f413_spi.h:342
spi_type::clkpha
__IO uint32_t clkpha
Definition: at32f413_spi.h:295
spi_type::hwcsoe
__IO uint32_t hwcsoe
Definition: at32f413_spi.h:323
spi_type::slben
__IO uint32_t slben
Definition: at32f413_spi.h:308
spi_type::ntc
__IO uint32_t ntc
Definition: at32f413_spi.h:305
spi_type::mdiv_h
__IO uint32_t mdiv_h
Definition: at32f413_spi.h:328
spi_type::rdbfie
__IO uint32_t rdbfie
Definition: at32f413_spi.h:326
spi_type::mmerr
__IO uint32_t mmerr
Definition: at32f413_spi.h:346
spi_type::dmaren
__IO uint32_t dmaren
Definition: at32f413_spi.h:321
spi_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_spi.h:329
spi_type::bf
__IO uint32_t bf
Definition: at32f413_spi.h:348
spi_type::i2sdbn
__IO uint32_t i2sdbn
Definition: at32f413_spi.h:414
spi_type::rcrc
__IO uint32_t rcrc
Definition: at32f413_spi.h:384
spi_type::errie
__IO uint32_t errie
Definition: at32f413_spi.h:325
spi_type::i2scbn
__IO uint32_t i2scbn
Definition: at32f413_spi.h:413
spi_type::i2sclkpol
__IO uint32_t i2sclkpol
Definition: at32f413_spi.h:415
spi_type::cpoly
__IO uint32_t cpoly
Definition: at32f413_spi.h:371
spi_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_spi.h:292
spi_type::i2sodd
__IO uint32_t i2sodd
Definition: at32f413_spi.h:435
spi_type::swcsil
__IO uint32_t swcsil
Definition: at32f413_spi.h:301
spi_type::i2sclk
__IO uint32_t i2sclk
Definition: at32f413_spi.h:431
spi_type::tcrc
__IO uint32_t tcrc
Definition: at32f413_spi.h:397
spi_type::acs
__IO uint32_t acs
Definition: at32f413_spi.h:343
spi_type::i2smclkoe
__IO uint32_t i2smclkoe
Definition: at32f413_spi.h:436
spi_type::ltf
__IO uint32_t ltf
Definition: at32f413_spi.h:300
spi_type::clkpol
__IO uint32_t clkpol
Definition: at32f413_spi.h:296
spi_type::slbtd
__IO uint32_t slbtd
Definition: at32f413_spi.h:307
spi_type::dmaten
__IO uint32_t dmaten
Definition: at32f413_spi.h:322
spi_type::ccen
__IO uint32_t ccen
Definition: at32f413_spi.h:306
spi_type::fbn
__IO uint32_t fbn
Definition: at32f413_spi.h:304
spi_type::dt
__IO uint32_t dt
Definition: at32f413_spi.h:358
spi_type::msten
__IO uint32_t msten
Definition: at32f413_spi.h:297
spi_type::ccerr
__IO uint32_t ccerr
Definition: at32f413_spi.h:345
spi_type::sts
__IO uint32_t sts
Definition: at32f413_spi.h:338
spi_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_spi.h:309
spi_type::i2sdiv_h
__IO uint32_t i2sdiv_h
Definition: at32f413_spi.h:437
spi_type::opersel
__IO uint32_t opersel
Definition: at32f413_spi.h:419
spi_type::i2sdiv_l
__IO uint32_t i2sdiv_l
Definition: at32f413_spi.h:434
spi_type::i2smsel
__IO uint32_t i2smsel
Definition: at32f413_spi.h:421
spi_type::pcmfssel
__IO uint32_t pcmfssel
Definition: at32f413_spi.h:418
spi_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_spi.h:318
spi_type::roerr
__IO uint32_t roerr
Definition: at32f413_spi.h:347
spi_type::i2sctrl
__IO uint32_t i2sctrl
Definition: at32f413_spi.h:410
spi_type::stdsel
__IO uint32_t stdsel
Definition: at32f413_spi.h:416
spi_type::rdbf
__IO uint32_t rdbf
Definition: at32f413_spi.h:341
spi_type::tuerr
__IO uint32_t tuerr
Definition: at32f413_spi.h:344
spi_type::mdiv_l
__IO uint32_t mdiv_l
Definition: at32f413_spi.h:298
spi_type::spien
__IO uint32_t spien
Definition: at32f413_spi.h:299
spi_type::swcsen
__IO uint32_t swcsen
Definition: at32f413_spi.h:302
spi_type::ora
__IO uint32_t ora
Definition: at32f413_spi.h:303
spi_type::i2sen
__IO uint32_t i2sen
Definition: at32f413_spi.h:420
spi_type::tdbeie
__IO uint32_t tdbeie
Definition: at32f413_spi.h:327


AT32F413 Firmwary Library: at32f413_tmr.c Source File

  • libraries
  • drivers
  • src
at32f413_tmr.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef TMR_MODULE_ENABLED
39
52void tmr_reset(tmr_type *tmr_x)
53{
54 if(tmr_x == TMR1)
55 {
56 crm_periph_reset(CRM_TMR1_PERIPH_RESET, TRUE);
57 crm_periph_reset(CRM_TMR1_PERIPH_RESET, FALSE);
58 }
59 else if(tmr_x == TMR2)
60 {
61 crm_periph_reset(CRM_TMR2_PERIPH_RESET, TRUE);
62 crm_periph_reset(CRM_TMR2_PERIPH_RESET, FALSE);
63 }
64 else if(tmr_x == TMR3)
65 {
66 crm_periph_reset(CRM_TMR3_PERIPH_RESET, TRUE);
67 crm_periph_reset(CRM_TMR3_PERIPH_RESET, FALSE);
68 }
69 else if(tmr_x == TMR4)
70 {
71 crm_periph_reset(CRM_TMR4_PERIPH_RESET, TRUE);
72 crm_periph_reset(CRM_TMR4_PERIPH_RESET, FALSE);
73 }
74 else if(tmr_x == TMR5)
75 {
76 crm_periph_reset(CRM_TMR5_PERIPH_RESET, TRUE);
77 crm_periph_reset(CRM_TMR5_PERIPH_RESET, FALSE);
78 }
79 else if(tmr_x == TMR8)
80 {
81 crm_periph_reset(CRM_TMR8_PERIPH_RESET, TRUE);
82 crm_periph_reset(CRM_TMR8_PERIPH_RESET, FALSE);
83 }
84 else if(tmr_x == TMR9)
85 {
86 crm_periph_reset(CRM_TMR9_PERIPH_RESET, TRUE);
87 crm_periph_reset(CRM_TMR9_PERIPH_RESET, FALSE);
88 }
89 else if(tmr_x == TMR10)
90 {
91 crm_periph_reset(CRM_TMR10_PERIPH_RESET, TRUE);
92 crm_periph_reset(CRM_TMR10_PERIPH_RESET, FALSE);
93 }
94 else if(tmr_x == TMR11)
95 {
96 crm_periph_reset(CRM_TMR11_PERIPH_RESET, TRUE);
97 crm_periph_reset(CRM_TMR11_PERIPH_RESET, FALSE);
98 }
99}
100
110void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
111{
112 /* tmr counter enable */
113 tmr_x->ctrl1_bit.tmren = new_state;
114}
115
122void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
123{
124 tmr_output_struct->oc_mode = TMR_OUTPUT_CONTROL_OFF;
125 tmr_output_struct->oc_idle_state = FALSE;
126 tmr_output_struct->occ_idle_state = FALSE;
127 tmr_output_struct->oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
128 tmr_output_struct->occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
129 tmr_output_struct->oc_output_state = FALSE;
130 tmr_output_struct->occ_output_state = FALSE;
131}
132
139void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
140{
141 tmr_input_struct->input_channel_select = TMR_SELECT_CHANNEL_1;
142 tmr_input_struct->input_polarity_select = TMR_INPUT_RISING_EDGE;
143 tmr_input_struct->input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
144 tmr_input_struct->input_filter_value = 0x0;
145}
146
153void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
154{
155 tmr_brkdt_struct->deadtime = 0x0;
156 tmr_brkdt_struct->brk_polarity = TMR_BRK_INPUT_ACTIVE_LOW;
157 tmr_brkdt_struct->wp_level = TMR_WP_OFF;
158 tmr_brkdt_struct->auto_output_enable = FALSE ;
159 tmr_brkdt_struct->fcsoen_state = FALSE ;
160 tmr_brkdt_struct->fcsodis_state = FALSE ;
161 tmr_brkdt_struct->brk_enable = FALSE ;
162}
163
175void tmr_base_init(tmr_type* tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
176{
177 /* set the pr value */
178 tmr_x->pr = tmr_pr;
179
180 /* set the div value */
181 tmr_x->div = tmr_div;
182
183 /* trigger the overflow event to immediately reload pr value and div value */
184 tmr_x->swevt_bit.ovfswtr = TRUE;
185}
186
200void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
201{
202 /* set tmr clock source division */
203 tmr_x->ctrl1_bit.clkdiv = tmr_clock_div;
204}
205
221void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
222{
223 /* set the cnt direct */
224 tmr_x->ctrl1_bit.cnt_dir = tmr_cnt_dir;
225}
226
235void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
236{
237 /* set the repetition counter value */
238 if((tmr_x == TMR1) || (tmr_x == TMR8))
239
240 {
241 tmr_x->rpr_bit.rpr = tmr_rpr_value;
242 }
243}
244
255void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value)
256{
257 /* set the tmr counter value */
258 tmr_x->cval = tmr_cnt_value;
259}
260
269uint32_t tmr_counter_value_get(tmr_type *tmr_x)
270{
271 return tmr_x->cval;
272}
273
284void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
285{
286 /* set the tmr div value */
287 tmr_x->div = tmr_div_value;
288}
289
298uint32_t tmr_div_value_get(tmr_type *tmr_x)
299{
300 return tmr_x->div;
301}
302
319void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
320 tmr_output_config_type *tmr_output_struct)
321{
322 uint16_t channel_index = 0, channel_c_index = 0, channel = 0;
323
324 /* get channel idle state bit position in ctrl2 register */
325 channel_index = (uint16_t)(tmr_output_struct->oc_idle_state << (8 + tmr_channel));
326
327 /* get channel complementary idle state bit position in ctrl2 register */
328 channel_c_index = (uint16_t)(tmr_output_struct->occ_idle_state << (9 + tmr_channel));
329
330 if((tmr_x == TMR1) || (tmr_x == TMR8))
331 {
332 /* set output channel complementary idle state */
333 tmr_x->ctrl2 &= ~channel_c_index;
334 tmr_x->ctrl2 |= channel_c_index;
335 }
336
337 /* set output channel idle state */
338 tmr_x->ctrl2 &= ~channel_index;
339 tmr_x->ctrl2 |= channel_index;
340
341 /* set channel output mode */
342 channel = tmr_channel;
343
344 switch(channel)
345 {
346 case TMR_SELECT_CHANNEL_1:
347 tmr_x->cm1_output_bit.c1octrl = tmr_output_struct->oc_mode;
348 break;
349
350 case TMR_SELECT_CHANNEL_2:
351 tmr_x->cm1_output_bit.c2octrl = tmr_output_struct->oc_mode;
352 break;
353
354 case TMR_SELECT_CHANNEL_3:
355 tmr_x->cm2_output_bit.c3octrl = tmr_output_struct->oc_mode;
356 break;
357
358 case TMR_SELECT_CHANNEL_4:
359 tmr_x->cm2_output_bit.c4octrl = tmr_output_struct->oc_mode;
360 break;
361
362 default:
363 break;
364 }
365
366 /* get channel polarity bit position in cctrl register */
367 channel_index = (uint16_t)(tmr_output_struct->oc_polarity << ((tmr_channel * 2) + 1));
368
369 /* get channel complementary polarity bit position in cctrl register */
370 channel_c_index = (uint16_t)(tmr_output_struct->occ_polarity << ((tmr_channel * 2) + 3));
371
372 if((tmr_x == TMR1) || (tmr_x == TMR8))
373 {
374 /* set output channel complementary polarity */
375 tmr_x->cctrl &= ~channel_c_index;
376 tmr_x->cctrl |= channel_c_index;
377 }
378
379 /* set output channel polarity */
380 tmr_x->cctrl &= ~channel_index;
381 tmr_x->cctrl |= channel_index;
382
383 /* get channel enable bit position in cctrl register */
384 channel_index = (uint16_t)(tmr_output_struct->oc_output_state << (tmr_channel * 2));
385
386 /* get channel complementary enable bit position in cctrl register */
387 channel_c_index = (uint16_t)(tmr_output_struct->occ_output_state << ((tmr_channel * 2) + 2));
388
389 if((tmr_x == TMR1) || (tmr_x == TMR8))
390 {
391 /* set output channel complementary enable bit */
392 tmr_x->cctrl &= ~channel_c_index;
393 tmr_x->cctrl |= channel_c_index;
394 }
395
396 /* set output channel enable bit */
397 tmr_x->cctrl &= ~channel_index;
398 tmr_x->cctrl |= channel_index;
399}
400
425void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
426 tmr_output_control_mode_type oc_mode)
427{
428 uint16_t channel;
429
430 channel = tmr_channel;
431
432 switch(channel)
433 {
434 case TMR_SELECT_CHANNEL_1:
435 tmr_x->cm1_output_bit.c1octrl = oc_mode;
436 break;
437
438 case TMR_SELECT_CHANNEL_2:
439 tmr_x->cm1_output_bit.c2octrl = oc_mode;
440 break;
441
442 case TMR_SELECT_CHANNEL_3:
443 tmr_x->cm2_output_bit.c3octrl = oc_mode;
444 break;
445
446 case TMR_SELECT_CHANNEL_4:
447 tmr_x->cm2_output_bit.c4octrl = oc_mode;
448 break;
449
450 default:
451 break;
452 }
453}
465void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value)
466{
467 /* set tmr period value */
468 tmr_x->pr = tmr_pr_value;
469}
470
481uint32_t tmr_period_value_get(tmr_type *tmr_x)
482{
483 return tmr_x->pr;
484}
485
502void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
503 uint32_t tmr_channel_value)
504{
505 uint16_t channel;
506
507 channel = tmr_channel;
508
509 /* set tmr channel value */
510 switch(channel)
511 {
512 case TMR_SELECT_CHANNEL_1:
513 tmr_x->c1dt = tmr_channel_value;
514 break;
515
516 case TMR_SELECT_CHANNEL_2:
517 tmr_x->c2dt = tmr_channel_value;
518 break;
519
520 case TMR_SELECT_CHANNEL_3:
521 tmr_x->c3dt = tmr_channel_value;
522 break;
523
524 case TMR_SELECT_CHANNEL_4:
525 tmr_x->c4dt = tmr_channel_value;
526 break;
527
528 default:
529 break;
530 }
531}
532
547uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
548{
549 uint32_t cc_value_get = 0;
550 uint16_t channel;
551
552 channel = tmr_channel;
553
554 /* get tmr channel value */
555 switch(channel)
556 {
557 case TMR_SELECT_CHANNEL_1:
558 cc_value_get = tmr_x->c1dt;
559 break;
560
561 case TMR_SELECT_CHANNEL_2:
562 cc_value_get = tmr_x->c2dt;
563 break;
564
565 case TMR_SELECT_CHANNEL_3:
566 cc_value_get = tmr_x->c3dt;
567 break;
568
569 case TMR_SELECT_CHANNEL_4:
570 cc_value_get = tmr_x->c4dt;
571 break;
572
573 default:
574 break;
575 }
576
577 return cc_value_get;
578}
588void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
589{
590 /* tmr period buffer set */
591 tmr_x->ctrl1_bit.prben = new_state;
592}
593
609void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
610 confirm_state new_state)
611{
612 uint16_t channel;
613
614 channel = tmr_channel;
615
616 /* get tmr channel value */
617 switch(channel)
618 {
619 case TMR_SELECT_CHANNEL_1:
620 tmr_x->cm1_output_bit.c1oben = new_state;
621 break;
622
623 case TMR_SELECT_CHANNEL_2:
624 tmr_x->cm1_output_bit.c2oben = new_state;
625 break;
626
627 case TMR_SELECT_CHANNEL_3:
628 tmr_x->cm2_output_bit.c3oben = new_state;
629 break;
630
631 case TMR_SELECT_CHANNEL_4:
632 tmr_x->cm2_output_bit.c4oben = new_state;
633 break;
634
635 default:
636 break;
637 }
638}
639
655void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
656 confirm_state new_state)
657{
658 uint16_t channel;
659
660 channel = tmr_channel;
661
662 /* get tmr channel value */
663 switch(channel)
664 {
665 case TMR_SELECT_CHANNEL_1:
666 tmr_x->cm1_output_bit.c1oien = new_state;
667 break;
668
669 case TMR_SELECT_CHANNEL_2:
670 tmr_x->cm1_output_bit.c2oien = new_state;
671 break;
672
673 case TMR_SELECT_CHANNEL_3:
674 tmr_x->cm2_output_bit.c3oien = new_state;
675 break;
676
677 case TMR_SELECT_CHANNEL_4:
678 tmr_x->cm2_output_bit.c4oien = new_state;
679 break;
680
681 default:
682 break;
683 }
684}
685
701void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
702 confirm_state new_state)
703{
704 uint16_t channel;
705
706 channel = tmr_channel;
707
708 /* get tmr channel value */
709 switch(channel)
710 {
711 case TMR_SELECT_CHANNEL_1:
712 tmr_x->cm1_output_bit.c1osen = new_state;
713 break;
714
715 case TMR_SELECT_CHANNEL_2:
716 tmr_x->cm1_output_bit.c2osen = new_state;
717 break;
718
719 case TMR_SELECT_CHANNEL_3:
720 tmr_x->cm2_output_bit.c3osen = new_state;
721 break;
722
723 case TMR_SELECT_CHANNEL_4:
724 tmr_x->cm2_output_bit.c4osen = new_state;
725 break;
726
727 default:
728 break;
729 }
730}
731
740void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
741{
742 /* tmr one cycle mode enable */
743 tmr_x->ctrl1_bit.ocmen = new_state;
744}
745
754void tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state)
755{
756 /* tmr 32 bit function(plus mode) enable,only for TMR2/TMR5 */
757 if((tmr_x == TMR2) || (tmr_x == TMR5))
758 {
759 tmr_x->ctrl1_bit.pmen = new_state;
760 }
761}
762
772void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state)
773{
774 tmr_x->ctrl1_bit.ovfs = new_state;
775}
776
786void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state)
787{
788 tmr_x->ctrl1_bit.ovfen = new_state;
789}
790
807void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct,
808 tmr_channel_input_divider_type divider_factor)
809{
810 uint16_t channel = 0;
811
812 /* get channel selected */
813 channel = input_struct->input_channel_select;
814
815 switch(channel)
816 {
817 case TMR_SELECT_CHANNEL_1:
818 tmr_x->cctrl_bit.c1p = (uint32_t)input_struct->input_polarity_select;
819 tmr_x->cctrl_bit.c1cp = (input_struct->input_polarity_select & 0x2) >> 1;
820 tmr_x->cm1_input_bit.c1c = input_struct->input_mapped_select;
821 tmr_x->cm1_input_bit.c1df = input_struct->input_filter_value;
822 tmr_x->cm1_input_bit.c1idiv = divider_factor;
823 tmr_x->cctrl_bit.c1en = TRUE;
824 break;
825
826 case TMR_SELECT_CHANNEL_2:
827 tmr_x->cctrl_bit.c2p = (uint32_t)input_struct->input_polarity_select;
828 tmr_x->cctrl_bit.c2cp = (input_struct->input_polarity_select & 0x2) >> 1;
829 tmr_x->cm1_input_bit.c2c = input_struct->input_mapped_select;
830 tmr_x->cm1_input_bit.c2df = input_struct->input_filter_value;
831 tmr_x->cm1_input_bit.c2idiv = divider_factor;
832 tmr_x->cctrl_bit.c2en = TRUE;
833 break;
834
835 case TMR_SELECT_CHANNEL_3:
836 tmr_x->cctrl_bit.c3p = (uint32_t)input_struct->input_polarity_select;
837 tmr_x->cctrl_bit.c3cp = (input_struct->input_polarity_select & 0x2) >> 1;
838 tmr_x->cm2_input_bit.c3c = input_struct->input_mapped_select;
839 tmr_x->cm2_input_bit.c3df = input_struct->input_filter_value;
840 tmr_x->cm2_input_bit.c3idiv = divider_factor;
841 tmr_x->cctrl_bit.c3en = TRUE;
842 break;
843
844 case TMR_SELECT_CHANNEL_4:
845 tmr_x->cctrl_bit.c4p = (uint32_t)input_struct->input_polarity_select;
846 tmr_x->cm2_input_bit.c4c = input_struct->input_mapped_select;
847 tmr_x->cm2_input_bit.c4df = input_struct->input_filter_value;
848 tmr_x->cm2_input_bit.c4idiv = divider_factor;
849 tmr_x->cctrl_bit.c4en = TRUE;
850 break;
851
852 default:
853 break;
854 }
855}
856
875void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
876{
877 uint16_t channel;
878
879 channel = tmr_channel;
880
881 switch(channel)
882 {
883 case TMR_SELECT_CHANNEL_1:
884 tmr_x->cctrl_bit.c1en = new_state;
885 break;
886
887 case TMR_SELECT_CHANNEL_1C:
888 tmr_x->cctrl_bit.c1cen = new_state;
889 break;
890
891 case TMR_SELECT_CHANNEL_2:
892 tmr_x->cctrl_bit.c2en = new_state;
893 break;
894
895 case TMR_SELECT_CHANNEL_2C:
896 tmr_x->cctrl_bit.c2cen = new_state;
897 break;
898
899 case TMR_SELECT_CHANNEL_3:
900 tmr_x->cctrl_bit.c3en = new_state;
901 break;
902
903 case TMR_SELECT_CHANNEL_3C:
904 tmr_x->cctrl_bit.c3cen = new_state;
905 break;
906
907 case TMR_SELECT_CHANNEL_4:
908 tmr_x->cctrl_bit.c4en = new_state;
909 break;
910
911 default:
912 break;
913 }
914}
915
931void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
932 uint16_t filter_value)
933{
934 uint16_t channel;
935
936 channel = tmr_channel;
937
938 switch(channel)
939 {
940 case TMR_SELECT_CHANNEL_1:
941 tmr_x->cm1_input_bit.c1df = filter_value;
942 break;
943
944 case TMR_SELECT_CHANNEL_2:
945 tmr_x->cm1_input_bit.c2df = filter_value;
946 break;
947
948 case TMR_SELECT_CHANNEL_3:
949 tmr_x->cm2_input_bit.c3df = filter_value;
950 break;
951
952 case TMR_SELECT_CHANNEL_4:
953 tmr_x->cm2_input_bit.c4df = filter_value;
954 break;
955
956 default:
957 break;
958 }
959}
960
977void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct,
978 tmr_channel_input_divider_type divider_factor)
979{
980 uint16_t channel = 0;
981
982 /* get channel selected */
983 channel = input_struct->input_channel_select;
984
985 switch(channel)
986 {
987 case TMR_SELECT_CHANNEL_1:
988 if(input_struct->input_polarity_select == TMR_INPUT_RISING_EDGE)
989 {
990 /* set channel polarity */
991 tmr_x->cctrl_bit.c1p = TMR_INPUT_RISING_EDGE;
992 tmr_x->cctrl_bit.c2p = TMR_INPUT_FALLING_EDGE;
993 }
994 else if(input_struct->input_polarity_select == TMR_INPUT_FALLING_EDGE)
995 {
996 /* set channel polarity */
997 tmr_x->cctrl_bit.c1p = TMR_INPUT_FALLING_EDGE;
998 tmr_x->cctrl_bit.c2p = TMR_INPUT_RISING_EDGE;
999 }
1000
1001 if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_DIRECT)
1002 {
1003 /* ic1 is mapped on ti1 */
1004 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1005
1006 /* ic1 is mapped on ti2 */
1007 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1008 }
1009 else if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_INDIRECT)
1010 {
1011 /* ic1 is mapped on ti1 */
1012 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1013
1014 /* ic1 is mapped on ti2 */
1015 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1016 }
1017
1018 /* set input ch1 and ch2 filter value*/
1019 tmr_x->cm1_input_bit.c1df = input_struct->input_filter_value;
1020 tmr_x->cm1_input_bit.c2df = input_struct->input_filter_value;
1021
1022 /*set input ch1 and ch2 divider value*/
1023 tmr_x->cm1_input_bit.c1idiv = divider_factor;
1024 tmr_x->cm1_input_bit.c2idiv = divider_factor;
1025
1026 tmr_x->cctrl_bit.c1en = TRUE;
1027 tmr_x->cctrl_bit.c2en = TRUE;
1028 break;
1029
1030 case TMR_SELECT_CHANNEL_2:
1031 if(input_struct->input_polarity_select == TMR_INPUT_RISING_EDGE)
1032 {
1033 /* set channel polarity */
1034 tmr_x->cctrl_bit.c2p = TMR_INPUT_RISING_EDGE;
1035 tmr_x->cctrl_bit.c1p = TMR_INPUT_FALLING_EDGE;
1036 }
1037 else if(input_struct->input_polarity_select == TMR_INPUT_FALLING_EDGE)
1038 {
1039 /* set channel polarity */
1040 tmr_x->cctrl_bit.c2p = TMR_INPUT_FALLING_EDGE;
1041 tmr_x->cctrl_bit.c1p = TMR_INPUT_RISING_EDGE;
1042 }
1043
1044 if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_DIRECT)
1045 {
1046 /* set mapped direct */
1047 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1048 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1049 }
1050 else if(input_struct->input_mapped_select == TMR_CC_CHANNEL_MAPPED_INDIRECT)
1051 {
1052 /* set mapped direct */
1053 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_INDIRECT;
1054 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1055 }
1056
1057 /* set input ch1 and ch2 filter value*/
1058 tmr_x->cm1_input_bit.c1df = input_struct->input_filter_value;
1059 tmr_x->cm1_input_bit.c2df = input_struct->input_filter_value;
1060
1061 /*set input ch1 and ch2 divider value*/
1062 tmr_x->cm1_input_bit.c1idiv = divider_factor;
1063 tmr_x->cm1_input_bit.c2idiv = divider_factor;
1064
1065 tmr_x->cctrl_bit.c1en = TRUE;
1066 tmr_x->cctrl_bit.c2en = TRUE;
1067 break;
1068
1069 default:
1070 break;
1071 }
1072}
1073
1085void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ti1_connect)
1086{
1087 tmr_x->ctrl2_bit.c1insel = ti1_connect;
1088}
1089
1110void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
1111 tmr_channel_input_divider_type divider_factor)
1112{
1113 uint16_t channel;
1114
1115 channel = tmr_channel;
1116
1117 switch(channel)
1118 {
1119 case TMR_SELECT_CHANNEL_1:
1120 tmr_x->cm1_input_bit.c1idiv = divider_factor;
1121 break;
1122
1123 case TMR_SELECT_CHANNEL_2:
1124 tmr_x->cm1_input_bit.c2idiv = divider_factor;
1125 break;
1126
1127 case TMR_SELECT_CHANNEL_3:
1128 tmr_x->cm2_input_bit.c3idiv = divider_factor;
1129 break;
1130
1131 case TMR_SELECT_CHANNEL_4:
1132 tmr_x->cm2_input_bit.c4idiv = divider_factor;
1133 break;
1134
1135 default:
1136 break;
1137 }
1138}
1139
1157void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
1158{
1159 tmr_x->ctrl2_bit.ptos = primary_mode;
1160}
1161
1179void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
1180{
1181 tmr_x->stctrl_bit.smsel = sub_mode;
1182}
1183
1195void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
1196{
1197 tmr_x->ctrl2_bit.drs = cc_dma_select;
1198}
1199
1208void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state)
1209{
1210 tmr_x->ctrl2_bit.ccfs = new_state;
1211}
1212
1221void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
1222{
1223 tmr_x->ctrl2_bit.cbctrl = new_state;
1224}
1225
1243void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
1244{
1245 tmr_x->stctrl_bit.stis = trigger_select;
1246}
1247
1256void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
1257{
1258 tmr_x->stctrl_bit.sts = new_state;
1259}
1260
1279void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
1280{
1281 if(new_state == TRUE)
1282 {
1283 tmr_x->iden |= dma_request;
1284 }
1285 else if(new_state == FALSE)
1286 {
1287 tmr_x->iden &= ~dma_request;
1288 }
1289}
1290
1310void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
1311{
1312 if(new_state == TRUE)
1313 {
1314 tmr_x->iden |= tmr_interrupt;
1315 }
1316 else if(new_state == FALSE)
1317 {
1318 tmr_x->iden &= ~tmr_interrupt;
1319 }
1320}
1321
1344 flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
1345{
1346 flag_status status = RESET;
1347
1348 if((tmr_x->ists & tmr_flag) != RESET)
1349 {
1350 status = SET;
1351 }
1352 else
1353 {
1354 status = RESET;
1355 }
1356
1357 return status;
1358}
1359
1382void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
1383{
1384 tmr_x->ists = ~tmr_flag;
1385}
1386
1405void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
1406{
1407 tmr_x->swevt |= tmr_event;
1408}
1409
1418void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
1419{
1420 tmr_x->brk_bit.oen = new_state;
1421}
1422
1430void tmr_internal_clock_set(tmr_type *tmr_x)
1431{
1432 tmr_x->stctrl_bit.smsel = TMR_SUB_MODE_DIABLE;
1433}
1434
1456void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
1457 tmr_polarity_active_type oc_polarity)
1458{
1459 uint16_t channel;
1460
1461 channel = tmr_channel;
1462
1463 switch(channel)
1464 {
1465 case TMR_SELECT_CHANNEL_1:
1466 tmr_x->cctrl_bit.c1p = (uint32_t)oc_polarity;
1467 break;
1468
1469 case TMR_SELECT_CHANNEL_2:
1470 tmr_x->cctrl_bit.c2p = (uint32_t)oc_polarity;
1471 break;
1472
1473 case TMR_SELECT_CHANNEL_3:
1474 tmr_x->cctrl_bit.c3p = (uint32_t)oc_polarity;
1475 break;
1476
1477 case TMR_SELECT_CHANNEL_4:
1478 tmr_x->cctrl_bit.c4p = (uint32_t)oc_polarity;
1479 break;
1480
1481 case TMR_SELECT_CHANNEL_1C:
1482 tmr_x->cctrl_bit.c1cp = (uint32_t)oc_polarity;
1483 break;
1484
1485 case TMR_SELECT_CHANNEL_2C:
1486 tmr_x->cctrl_bit.c2cp = (uint32_t)oc_polarity;
1487 break;
1488
1489 case TMR_SELECT_CHANNEL_3C:
1490 tmr_x->cctrl_bit.c3cp = (uint32_t)oc_polarity;
1491 break;
1492
1493 default:
1494 break;
1495 }
1496}
1497
1516void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide,
1517 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
1518{
1519 tmr_x->stctrl_bit.esdiv = es_divide;
1520 tmr_x->stctrl_bit.esp = es_polarity;
1521 tmr_x->stctrl_bit.esf = es_filter;
1522}
1523
1542void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide,
1543 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
1544{
1545 tmr_external_clock_config(tmr_x, es_divide, es_polarity, es_filter);
1546 tmr_x->stctrl_bit.smsel = TMR_SUB_EXTERNAL_CLOCK_MODE_A;
1547 tmr_x->stctrl_bit.stis = TMR_SUB_INPUT_SEL_EXTIN;
1548}
1549
1568void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide,
1569 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
1570{
1571 tmr_external_clock_config(tmr_x, es_divide, es_polarity, es_filter);
1572 tmr_x->stctrl_bit.ecmben = TRUE;
1573}
1574
1597void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type
1598 ic1_polarity, tmr_input_polarity_type ic2_polarity)
1599{
1600 tmr_x->stctrl_bit.smsel = encoder_mode;
1601
1602 /* set ic1 polarity */
1603 tmr_x->cctrl_bit.c1p = (ic1_polarity & 0x1);
1604 tmr_x->cctrl_bit.c1cp = (ic1_polarity >> 1);
1605 /* set ic1 as input channel */
1606 tmr_x->cm1_input_bit.c1c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1607
1608 /* set ic2 polarity */
1609 tmr_x->cctrl_bit.c2p = (ic2_polarity & 0x1);
1610 tmr_x->cctrl_bit.c2cp = (ic2_polarity >> 1);
1611 /* set ic2 as input channel */
1612 tmr_x->cm1_input_bit.c2c = TMR_CC_CHANNEL_MAPPED_DIRECT;
1613}
1614
1633void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel,
1634 tmr_force_output_type force_output)
1635{
1636 uint16_t channel;
1637
1638 channel = tmr_channel;
1639
1640 switch(channel)
1641 {
1642 case TMR_SELECT_CHANNEL_1:
1643 tmr_x->cm1_output_bit.c1octrl = force_output;
1644 break;
1645
1646 case TMR_SELECT_CHANNEL_2:
1647 tmr_x->cm1_output_bit.c2octrl = force_output;
1648 break;
1649
1650 case TMR_SELECT_CHANNEL_3:
1651 tmr_x->cm2_output_bit.c3octrl = force_output;
1652 break;
1653
1654 case TMR_SELECT_CHANNEL_4:
1655 tmr_x->cm2_output_bit.c4octrl = force_output;
1656 break;
1657
1658 default:
1659 break;
1660 }
1661}
1662
1699void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length,
1700 tmr_dma_address_type dma_base_address)
1701{
1702 tmr_x->dmactrl_bit.dtb = dma_length;
1703 tmr_x->dmactrl_bit.addr = dma_base_address;
1704}
1705
1715void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
1716{
1717 tmr_x->brk_bit.brken = brkdt_struct->brk_enable;
1718 tmr_x->brk_bit.dtc = brkdt_struct->deadtime;
1719 tmr_x->brk_bit.fcsodis = brkdt_struct->fcsodis_state;
1720 tmr_x->brk_bit.fcsoen = brkdt_struct->fcsoen_state;
1721 tmr_x->brk_bit.brkv = brkdt_struct->brk_polarity;
1722 tmr_x->brk_bit.aoen = brkdt_struct->auto_output_enable;
1723 tmr_x->brk_bit.wpc = brkdt_struct->wp_level;
1724}
1725
1730#endif
1731
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:39
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
CRM_TMR2_PERIPH_RESET
@ CRM_TMR2_PERIPH_RESET
Definition: at32f413_crm.h:170
CRM_TMR4_PERIPH_RESET
@ CRM_TMR4_PERIPH_RESET
Definition: at32f413_crm.h:172
CRM_TMR10_PERIPH_RESET
@ CRM_TMR10_PERIPH_RESET
Definition: at32f413_crm.h:166
CRM_TMR5_PERIPH_RESET
@ CRM_TMR5_PERIPH_RESET
Definition: at32f413_crm.h:173
CRM_TMR9_PERIPH_RESET
@ CRM_TMR9_PERIPH_RESET
Definition: at32f413_crm.h:165
CRM_TMR1_PERIPH_RESET
@ CRM_TMR1_PERIPH_RESET
Definition: at32f413_crm.h:161
CRM_TMR8_PERIPH_RESET
@ CRM_TMR8_PERIPH_RESET
Definition: at32f413_crm.h:163
CRM_TMR3_PERIPH_RESET
@ CRM_TMR3_PERIPH_RESET
Definition: at32f413_crm.h:171
CRM_TMR11_PERIPH_RESET
@ CRM_TMR11_PERIPH_RESET
Definition: at32f413_crm.h:167
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
tmr_dma_request_type
tmr_dma_request_type
tmr dma request type
Definition: at32f413_tmr.h:268
tmr_external_signal_divider_type
tmr_external_signal_divider_type
tmr external signal divider type
Definition: at32f413_tmr.h:307
tmr_polarity_active_type
tmr_polarity_active_type
tmr polarity active type
Definition: at32f413_tmr.h:297
tmr_count_mode_type
tmr_count_mode_type
tmr counter mode type
Definition: at32f413_tmr.h:105
tmr_input_polarity_type
tmr_input_polarity_type
tmr input channel polarity type
Definition: at32f413_tmr.h:205
tmr_dma_request_source_type
tmr_dma_request_source_type
tmr dma request source select type
Definition: at32f413_tmr.h:259
tmr_channel_select_type
tmr_channel_select_type
tmr channel select type
Definition: at32f413_tmr.h:215
tmr_external_signal_polarity_type
tmr_external_signal_polarity_type
tmr external signal polarity type
Definition: at32f413_tmr.h:318
tmr_dma_address_type
tmr_dma_address_type
tmr dma base address type
Definition: at32f413_tmr.h:352
tmr_channel1_input_connected_type
tmr_channel1_input_connected_type
tmr channel1 input connected type
Definition: at32f413_tmr.h:229
tmr_clock_division_type
tmr_clock_division_type
tmr clock division type
Definition: at32f413_tmr.h:95
tmr_event_trigger_type
tmr_event_trigger_type
tmr event triggered by software type
Definition: at32f413_tmr.h:282
tmr_output_control_mode_type
tmr_output_control_mode_type
tmr output control mode type
Definition: at32f413_tmr.h:172
tmr_dma_transfer_length_type
tmr_dma_transfer_length_type
tmr dma transfer length type
Definition: at32f413_tmr.h:327
sub_tmr_input_sel_type
sub_tmr_input_sel_type
tmr subordinate mode input select type
Definition: at32f413_tmr.h:132
tmr_force_output_type
tmr_force_output_type
tmr force output type
Definition: at32f413_tmr.h:187
tmr_sub_mode_select_type
tmr_sub_mode_select_type
tmr subordinate mode select type
Definition: at32f413_tmr.h:147
tmr_primary_select_type
tmr_primary_select_type
tmr primary mode select type
Definition: at32f413_tmr.h:117
tmr_encoder_mode_type
tmr_encoder_mode_type
tmr encoder mode type
Definition: at32f413_tmr.h:162
tmr_channel_input_divider_type
tmr_channel_input_divider_type
tmr input divider type
Definition: at32f413_tmr.h:248
TMR_INPUT_FALLING_EDGE
@ TMR_INPUT_FALLING_EDGE
Definition: at32f413_tmr.h:207
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_SELECT_CHANNEL_1C
@ TMR_SELECT_CHANNEL_1C
Definition: at32f413_tmr.h:217
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2C
@ TMR_SELECT_CHANNEL_2C
Definition: at32f413_tmr.h:219
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_3C
@ TMR_SELECT_CHANNEL_3C
Definition: at32f413_tmr.h:221
TMR_WP_OFF
@ TMR_WP_OFF
Definition: at32f413_tmr.h:388
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:239
TMR_CC_CHANNEL_MAPPED_INDIRECT
@ TMR_CC_CHANNEL_MAPPED_INDIRECT
Definition: at32f413_tmr.h:240
TMR_BRK_INPUT_ACTIVE_LOW
@ TMR_BRK_INPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:379
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f413_tmr.h:173
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_SUB_INPUT_SEL_EXTIN
@ TMR_SUB_INPUT_SEL_EXTIN
Definition: at32f413_tmr.h:140
TMR_SUB_EXTERNAL_CLOCK_MODE_A
@ TMR_SUB_EXTERNAL_CLOCK_MODE_A
Definition: at32f413_tmr.h:155
TMR_SUB_MODE_DIABLE
@ TMR_SUB_MODE_DIABLE
Definition: at32f413_tmr.h:148
tmr_dma_control_config
void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control
Definition: at32f413_tmr.c:1699
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:547
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_period_value_get
uint32_t tmr_period_value_get(tmr_type *tmr_x)
get tmr period value
Definition: at32f413_tmr.c:481
tmr_channel_buffer_enable
void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer
Definition: at32f413_tmr.c:1221
tmr_overflow_request_source_set
void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources
Definition: at32f413_tmr.c:772
tmr_output_channel_mode_select
void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode
Definition: at32f413_tmr.c:425
tmr_input_channel_divider_set
void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider
Definition: at32f413_tmr.c:1110
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1279
tmr_external_clock_config
void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock
Definition: at32f413_tmr.c:1516
tmr_repetition_counter_set
void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value
Definition: at32f413_tmr.c:235
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:588
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_internal_clock_set
void tmr_internal_clock_set(tmr_type *tmr_x)
set tmr select internal clock
Definition: at32f413_tmr.c:1430
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f413_tmr.c:153
tmr_force_output_set
void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output
Definition: at32f413_tmr.c:1633
tmr_counter_value_set
void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value
Definition: at32f413_tmr.c:255
tmr_div_value_get
uint32_t tmr_div_value_get(tmr_type *tmr_x)
get tmr div value
Definition: at32f413_tmr.c:298
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:807
tmr_input_channel_filter_set
void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter
Definition: at32f413_tmr.c:931
tmr_period_value_set
void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value
Definition: at32f413_tmr.c:465
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f413_tmr.c:269
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time
Definition: at32f413_tmr.c:1715
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_external_clock_mode2_config
void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2
Definition: at32f413_tmr.c:1568
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:139
tmr_div_value_set
void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value
Definition: at32f413_tmr.c:284
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_channel1_input_select
void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ti1_connect)
select tmr channel1 input
Definition: at32f413_tmr.c:1085
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1256
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_hall_select
void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state)
select tmr hall
Definition: at32f413_tmr.c:1208
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:754
tmr_external_clock_mode1_config
void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1
Definition: at32f413_tmr.c:1542
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f413_tmr.c:977
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:609
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1157
tmr_overflow_event_disable
void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation
Definition: at32f413_tmr.c:786
tmr_channel_dma_select
void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma
Definition: at32f413_tmr.c:1195
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_output_channel_immediately_set
void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately
Definition: at32f413_tmr.c:655
tmr_encoder_mode_config
void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode
Definition: at32f413_tmr.c:1597
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f413_tmr.c:875
tmr_output_channel_switch_set
void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch
Definition: at32f413_tmr.c:701
tmr_reset
void tmr_reset(tmr_type *tmr_x)
tmr reset by crm reset register
Definition: at32f413_tmr.c:52
tmr_output_channel_polarity_set
void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity
Definition: at32f413_tmr.c:1456
tmr_one_cycle_mode_enable
void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode
Definition: at32f413_tmr.c:740
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
TMR10
#define TMR10
Definition: at32f413_tmr.h:839
TMR11
#define TMR11
Definition: at32f413_tmr.h:840
TMR8
#define TMR8
Definition: at32f413_tmr.h:837
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
TMR4
#define TMR4
Definition: at32f413_tmr.h:835
TMR5
#define TMR5
Definition: at32f413_tmr.h:836
TMR9
#define TMR9
Definition: at32f413_tmr.h:838
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f413_tmr.h:423
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f413_tmr.h:430
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f413_tmr.h:424
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f413_tmr.h:427
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f413_tmr.h:426
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f413_tmr.h:428
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f413_tmr.h:429
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f413_tmr.h:425
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:416
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
tmr_type
type define tmr register all
Definition: at32f413_tmr.h:437
tmr_type::cm1_output_bit
struct tmr_type::@660::@694 cm1_output_bit
channel mode
tmr_type::cm2_output_bit
struct tmr_type::@662::@696 cm2_output_bit
channel mode
tmr_type::c1cen
__IO uint32_t c1cen
Definition: at32f413_tmr.h:665
tmr_type::pmen
__IO uint32_t pmen
Definition: at32f413_tmr.h:453
tmr_type::brken
__IO uint32_t brken
Definition: at32f413_tmr.h:791
tmr_type::c1idiv
__IO uint32_t c1idiv
Definition: at32f413_tmr.h:606
tmr_type::dtc
__IO uint32_t dtc
Definition: at32f413_tmr.h:787
tmr_type::c1en
__IO uint32_t c1en
Definition: at32f413_tmr.h:663
tmr_type::c4df
__IO uint32_t c4df
Definition: at32f413_tmr.h:650
tmr_type::c3octrl
__IO uint32_t c3octrl
Definition: at32f413_tmr.h:630
tmr_type::c2osen
__IO uint32_t c2osen
Definition: at32f413_tmr.h:596
tmr_type::swevt
__IO uint32_t swevt
Definition: at32f413_tmr.h:560
tmr_type::c2en
__IO uint32_t c2en
Definition: at32f413_tmr.h:667
tmr_type::c3df
__IO uint32_t c3df
Definition: at32f413_tmr.h:647
tmr_type::wpc
__IO uint32_t wpc
Definition: at32f413_tmr.h:788
tmr_type::c3oben
__IO uint32_t c3oben
Definition: at32f413_tmr.h:629
tmr_type::cnt_dir
__IO uint32_t cnt_dir
Definition: at32f413_tmr.h:450
tmr_type::c4octrl
__IO uint32_t c4octrl
Definition: at32f413_tmr.h:635
tmr_type::c1insel
__IO uint32_t c1insel
Definition: at32f413_tmr.h:471
tmr_type::div
__IO uint32_t div
Definition: at32f413_tmr.h:698
tmr_type::cm1_input_bit
struct tmr_type::@660::@695 cm1_input_bit
input capture mode
tmr_type::esf
__IO uint32_t esf
Definition: at32f413_tmr.h:495
tmr_type::c1osen
__IO uint32_t c1osen
Definition: at32f413_tmr.h:591
tmr_type::c2cen
__IO uint32_t c2cen
Definition: at32f413_tmr.h:669
tmr_type::drs
__IO uint32_t drs
Definition: at32f413_tmr.h:469
tmr_type::iden
__IO uint32_t iden
Definition: at32f413_tmr.h:508
tmr_type::c1oben
__IO uint32_t c1oben
Definition: at32f413_tmr.h:589
tmr_type::ists
__IO uint32_t ists
Definition: at32f413_tmr.h:535
tmr_type::c1c
__IO uint32_t c1c
Definition: at32f413_tmr.h:587
tmr_type::c3cen
__IO uint32_t c3cen
Definition: at32f413_tmr.h:673
tmr_type::c4p
__IO uint32_t c4p
Definition: at32f413_tmr.h:676
tmr_type::brkv
__IO uint32_t brkv
Definition: at32f413_tmr.h:792
tmr_type::dmactrl_bit
struct tmr_type::@684::@708 dmactrl_bit
tmr_type::stctrl_bit
struct tmr_type::@652::@690 stctrl_bit
tmr_type::stis
__IO uint32_t stis
Definition: at32f413_tmr.h:493
tmr_type::ovfswtr
__IO uint32_t ovfswtr
Definition: at32f413_tmr.h:563
tmr_type::c3idiv
__IO uint32_t c3idiv
Definition: at32f413_tmr.h:646
tmr_type::c4osen
__IO uint32_t c4osen
Definition: at32f413_tmr.h:636
tmr_type::cctrl_bit
struct tmr_type::@664::@698 cctrl_bit
tmr_type::c1octrl
__IO uint32_t c1octrl
Definition: at32f413_tmr.h:590
tmr_type::tmren
__IO uint32_t tmren
Definition: at32f413_tmr.h:446
tmr_type::oen
__IO uint32_t oen
Definition: at32f413_tmr.h:794
tmr_type::sts
__IO uint32_t sts
Definition: at32f413_tmr.h:494
tmr_type::c2idiv
__IO uint32_t c2idiv
Definition: at32f413_tmr.h:609
tmr_type::c1p
__IO uint32_t c1p
Definition: at32f413_tmr.h:664
tmr_type::c1oien
__IO uint32_t c1oien
Definition: at32f413_tmr.h:588
tmr_type::pr
__IO uint32_t pr
Definition: at32f413_tmr.h:711
tmr_type::c3oien
__IO uint32_t c3oien
Definition: at32f413_tmr.h:628
tmr_type::c1dt
uint32_t c1dt
Definition: at32f413_tmr.h:736
tmr_type::c2oben
__IO uint32_t c2oben
Definition: at32f413_tmr.h:594
tmr_type::c2octrl
__IO uint32_t c2octrl
Definition: at32f413_tmr.h:595
tmr_type::smsel
__IO uint32_t smsel
Definition: at32f413_tmr.h:491
tmr_type::c3p
__IO uint32_t c3p
Definition: at32f413_tmr.h:672
tmr_type::c1cp
__IO uint32_t c1cp
Definition: at32f413_tmr.h:666
tmr_type::c3c
__IO uint32_t c3c
Definition: at32f413_tmr.h:627
tmr_type::clkdiv
__IO uint32_t clkdiv
Definition: at32f413_tmr.h:452
tmr_type::ovfs
__IO uint32_t ovfs
Definition: at32f413_tmr.h:448
tmr_type::cbctrl
__IO uint32_t cbctrl
Definition: at32f413_tmr.h:466
tmr_type::dtb
__IO uint32_t dtb
Definition: at32f413_tmr.h:808
tmr_type::prben
__IO uint32_t prben
Definition: at32f413_tmr.h:451
tmr_type::ccfs
__IO uint32_t ccfs
Definition: at32f413_tmr.h:468
tmr_type::ecmben
__IO uint32_t ecmben
Definition: at32f413_tmr.h:497
tmr_type::rpr_bit
struct tmr_type::@672::@702 rpr_bit
tmr_type::ovfen
__IO uint32_t ovfen
Definition: at32f413_tmr.h:447
tmr_type::ctrl1_bit
struct tmr_type::@648::@688 ctrl1_bit
tmr_type::cm2_input_bit
struct tmr_type::@662::@697 cm2_input_bit
input capture mode
tmr_type::c4en
__IO uint32_t c4en
Definition: at32f413_tmr.h:675
tmr_type::fcsoen
__IO uint32_t fcsoen
Definition: at32f413_tmr.h:790
tmr_type::esdiv
__IO uint32_t esdiv
Definition: at32f413_tmr.h:496
tmr_type::c3en
__IO uint32_t c3en
Definition: at32f413_tmr.h:671
tmr_type::c2p
__IO uint32_t c2p
Definition: at32f413_tmr.h:668
tmr_type::ocmen
__IO uint32_t ocmen
Definition: at32f413_tmr.h:449
tmr_type::ctrl2_bit
struct tmr_type::@650::@689 ctrl2_bit
tmr_type::swevt_bit
struct tmr_type::@658::@693 swevt_bit
tmr_type::c4oien
__IO uint32_t c4oien
Definition: at32f413_tmr.h:633
tmr_type::c2dt
uint32_t c2dt
Definition: at32f413_tmr.h:748
tmr_type::addr
__IO uint32_t addr
Definition: at32f413_tmr.h:806
tmr_type::c3cp
__IO uint32_t c3cp
Definition: at32f413_tmr.h:674
tmr_type::c2df
__IO uint32_t c2df
Definition: at32f413_tmr.h:610
tmr_type::c4idiv
__IO uint32_t c4idiv
Definition: at32f413_tmr.h:649
tmr_type::c3osen
__IO uint32_t c3osen
Definition: at32f413_tmr.h:631
tmr_type::rpr
__IO uint32_t rpr
Definition: at32f413_tmr.h:723
tmr_type::c2c
__IO uint32_t c2c
Definition: at32f413_tmr.h:592
tmr_type::c1df
__IO uint32_t c1df
Definition: at32f413_tmr.h:607
tmr_type::c2oien
__IO uint32_t c2oien
Definition: at32f413_tmr.h:593
tmr_type::c4dt
__IO uint32_t c4dt
Definition: at32f413_tmr.h:772
tmr_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_tmr.h:463
tmr_type::c3dt
__IO uint32_t c3dt
Definition: at32f413_tmr.h:760
tmr_type::c2cp
__IO uint32_t c2cp
Definition: at32f413_tmr.h:670
tmr_type::cctrl
uint32_t cctrl
Definition: at32f413_tmr.h:660
tmr_type::c4c
__IO uint32_t c4c
Definition: at32f413_tmr.h:632
tmr_type::c4oben
__IO uint32_t c4oben
Definition: at32f413_tmr.h:634
tmr_type::fcsodis
__IO uint32_t fcsodis
Definition: at32f413_tmr.h:789
tmr_type::cval
__IO uint32_t cval
Definition: at32f413_tmr.h:686
tmr_type::esp
__IO uint32_t esp
Definition: at32f413_tmr.h:498
tmr_type::ptos
__IO uint32_t ptos
Definition: at32f413_tmr.h:470
tmr_type::brk_bit
struct tmr_type::@682::@707 brk_bit
tmr_type::aoen
__IO uint32_t aoen
Definition: at32f413_tmr.h:793
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_tmr.h Source File

  • libraries
  • drivers
  • inc
at32f413_tmr.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_TMR_H
29#define __AT32F413_TMR_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define TMR_OVF_FLAG ((uint32_t)0x000001)
53#define TMR_C1_FLAG ((uint32_t)0x000002)
54#define TMR_C2_FLAG ((uint32_t)0x000004)
55#define TMR_C3_FLAG ((uint32_t)0x000008)
56#define TMR_C4_FLAG ((uint32_t)0x000010)
57#define TMR_HALL_FLAG ((uint32_t)0x000020)
58#define TMR_TRIGGER_FLAG ((uint32_t)0x000040)
59#define TMR_BRK_FLAG ((uint32_t)0x000080)
60#define TMR_C1_RECAPTURE_FLAG ((uint32_t)0x000200)
61#define TMR_C2_RECAPTURE_FLAG ((uint32_t)0x000400)
62#define TMR_C3_RECAPTURE_FLAG ((uint32_t)0x000800)
63#define TMR_C4_RECAPTURE_FLAG ((uint32_t)0x001000)
74#define TMR_OVF_INT ((uint32_t)0x000001)
75#define TMR_C1_INT ((uint32_t)0x000002)
76#define TMR_C2_INT ((uint32_t)0x000004)
77#define TMR_C3_INT ((uint32_t)0x000008)
78#define TMR_C4_INT ((uint32_t)0x000010)
79#define TMR_HALL_INT ((uint32_t)0x000020)
80#define TMR_TRIGGER_INT ((uint32_t)0x000040)
81#define TMR_BRK_INT ((uint32_t)0x000080)
94typedef enum
95{
96 TMR_CLOCK_DIV1 = 0x00,
97 TMR_CLOCK_DIV2 = 0x01,
98 TMR_CLOCK_DIV4 = 0x02
99} tmr_clock_division_type;
100
104typedef enum
105{
106 TMR_COUNT_UP = 0x00,
107 TMR_COUNT_DOWN = 0x01,
108 TMR_COUNT_TWO_WAY_1 = 0x02,
109 TMR_COUNT_TWO_WAY_2 = 0x04,
110 TMR_COUNT_TWO_WAY_3 = 0x06
111} tmr_count_mode_type;
112
116typedef enum
117{
118 TMR_PRIMARY_SEL_RESET = 0x00,
119 TMR_PRIMARY_SEL_ENABLE = 0x01,
120 TMR_PRIMARY_SEL_OVERFLOW = 0x02,
121 TMR_PRIMARY_SEL_COMPARE = 0x03,
122 TMR_PRIMARY_SEL_C1ORAW = 0x04,
123 TMR_PRIMARY_SEL_C2ORAW = 0x05,
124 TMR_PRIMARY_SEL_C3ORAW = 0x06,
125 TMR_PRIMARY_SEL_C4ORAW = 0x07
126} tmr_primary_select_type;
127
131typedef enum
132{
133 TMR_SUB_INPUT_SEL_IS0 = 0x00,
134 TMR_SUB_INPUT_SEL_IS1 = 0x01,
135 TMR_SUB_INPUT_SEL_IS2 = 0x02,
136 TMR_SUB_INPUT_SEL_IS3 = 0x03,
137 TMR_SUB_INPUT_SEL_C1INC = 0x04,
138 TMR_SUB_INPUT_SEL_C1DF1 = 0x05,
139 TMR_SUB_INPUT_SEL_C2DF2 = 0x06,
140 TMR_SUB_INPUT_SEL_EXTIN = 0x07
141} sub_tmr_input_sel_type;
142
146typedef enum
147{
148 TMR_SUB_MODE_DIABLE = 0x00,
149 TMR_SUB_ENCODER_MODE_A = 0x01,
150 TMR_SUB_ENCODER_MODE_B = 0x02,
151 TMR_SUB_ENCODER_MODE_C = 0x03,
152 TMR_SUB_RESET_MODE = 0x04,
153 TMR_SUB_HANG_MODE = 0x05,
154 TMR_SUB_TRIGGER_MODE = 0x06,
155 TMR_SUB_EXTERNAL_CLOCK_MODE_A = 0x07
156} tmr_sub_mode_select_type;
157
161typedef enum
162{
163 TMR_ENCODER_MODE_A = TMR_SUB_ENCODER_MODE_A,
164 TMR_ENCODER_MODE_B = TMR_SUB_ENCODER_MODE_B,
165 TMR_ENCODER_MODE_C = TMR_SUB_ENCODER_MODE_C
166} tmr_encoder_mode_type;
167
171typedef enum
172{
173 TMR_OUTPUT_CONTROL_OFF = 0x00,
174 TMR_OUTPUT_CONTROL_HIGH = 0x01,
175 TMR_OUTPUT_CONTROL_LOW = 0x02,
176 TMR_OUTPUT_CONTROL_SWITCH = 0x03,
177 TMR_OUTPUT_CONTROL_FORCE_LOW = 0x04,
178 TMR_OUTPUT_CONTROL_FORCE_HIGH = 0x05,
179 TMR_OUTPUT_CONTROL_PWM_MODE_A = 0x06,
180 TMR_OUTPUT_CONTROL_PWM_MODE_B = 0x07
181} tmr_output_control_mode_type;
182
186typedef enum
187{
188 TMR_FORCE_OUTPUT_HIGH = TMR_OUTPUT_CONTROL_FORCE_HIGH,
189 TMR_FORCE_OUTPUT_LOW = TMR_OUTPUT_CONTROL_FORCE_LOW
190} tmr_force_output_type;
191
195typedef enum
196{
197 TMR_OUTPUT_ACTIVE_HIGH = 0x00,
198 TMR_OUTPUT_ACTIVE_LOW = 0x01
199} tmr_output_polarity_type;
200
204typedef enum
205{
206 TMR_INPUT_RISING_EDGE = 0x00,
207 TMR_INPUT_FALLING_EDGE = 0x01,
208 TMR_INPUT_BOTH_EDGE = 0x03
209} tmr_input_polarity_type;
210
214typedef enum
215{
216 TMR_SELECT_CHANNEL_1 = 0x00,
217 TMR_SELECT_CHANNEL_1C = 0x01,
218 TMR_SELECT_CHANNEL_2 = 0x02,
219 TMR_SELECT_CHANNEL_2C = 0x03,
220 TMR_SELECT_CHANNEL_3 = 0x04,
221 TMR_SELECT_CHANNEL_3C = 0x05,
222 TMR_SELECT_CHANNEL_4 = 0x06
223} tmr_channel_select_type;
224
228typedef enum
229{
230 TMR_CHANEL1_CONNECTED_C1IRAW = 0x00,
231 TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR = 0x01
232} tmr_channel1_input_connected_type;
233
237typedef enum
238{
239 TMR_CC_CHANNEL_MAPPED_DIRECT = 0x01,
240 TMR_CC_CHANNEL_MAPPED_INDIRECT = 0x02,
241 TMR_CC_CHANNEL_MAPPED_STI = 0x03
242} tmr_input_direction_mapped_type;
243
247typedef enum
248{
249 TMR_CHANNEL_INPUT_DIV_1 = 0x00,
250 TMR_CHANNEL_INPUT_DIV_2 = 0x01,
251 TMR_CHANNEL_INPUT_DIV_4 = 0x02,
252 TMR_CHANNEL_INPUT_DIV_8 = 0x03
253} tmr_channel_input_divider_type;
254
258typedef enum
259{
260 TMR_DMA_REQUEST_BY_CHANNEL = 0x00,
261 TMR_DMA_REQUEST_BY_OVERFLOW = 0x01
262} tmr_dma_request_source_type;
263
267typedef enum
268{
269 TMR_OVERFLOW_DMA_REQUEST = 0x00000100,
270 TMR_C1_DMA_REQUEST = 0x00000200,
271 TMR_C2_DMA_REQUEST = 0x00000400,
272 TMR_C3_DMA_REQUEST = 0x00000800,
273 TMR_C4_DMA_REQUEST = 0x00001000,
274 TMR_HALL_DMA_REQUEST = 0x00002000,
275 TMR_TRIGGER_DMA_REQUEST = 0x00004000
276} tmr_dma_request_type;
277
281typedef enum
282{
283 TMR_OVERFLOW_SWTRIG = 0x00000001,
284 TMR_C1_SWTRIG = 0x00000002,
285 TMR_C2_SWTRIG = 0x00000004,
286 TMR_C3_SWTRIG = 0x00000008,
287 TMR_C4_SWTRIG = 0x00000010,
288 TMR_HALL_SWTRIG = 0x00000020,
289 TMR_TRIGGER_SWTRIG = 0x00000040,
290 TMR_BRK_SWTRIG = 0x00000080
291}tmr_event_trigger_type;
292
296typedef enum
297{
298 TMR_POLARITY_ACTIVE_HIGH = 0x00,
299 TMR_POLARITY_ACTIVE_LOW = 0x01,
300 TMR_POLARITY_ACTIVE_BOTH = 0x02
301}tmr_polarity_active_type;
302
306typedef enum
307{
308 TMR_ES_FREQUENCY_DIV_1 = 0x00,
309 TMR_ES_FREQUENCY_DIV_2 = 0x01,
310 TMR_ES_FREQUENCY_DIV_4 = 0x02,
311 TMR_ES_FREQUENCY_DIV_8 = 0x03
312}tmr_external_signal_divider_type;
313
317typedef enum
318{
319 TMR_ES_POLARITY_NON_INVERTED = 0x00,
320 TMR_ES_POLARITY_INVERTED = 0x01
321}tmr_external_signal_polarity_type;
322
326typedef enum
327{
328 TMR_DMA_TRANSFER_1BYTE = 0x00,
329 TMR_DMA_TRANSFER_2BYTES = 0x01,
330 TMR_DMA_TRANSFER_3BYTES = 0x02,
331 TMR_DMA_TRANSFER_4BYTES = 0x03,
332 TMR_DMA_TRANSFER_5BYTES = 0x04,
333 TMR_DMA_TRANSFER_6BYTES = 0x05,
334 TMR_DMA_TRANSFER_7BYTES = 0x06,
335 TMR_DMA_TRANSFER_8BYTES = 0x07,
336 TMR_DMA_TRANSFER_9BYTES = 0x08,
337 TMR_DMA_TRANSFER_10BYTES = 0x09,
338 TMR_DMA_TRANSFER_11BYTES = 0x0A,
339 TMR_DMA_TRANSFER_12BYTES = 0x0B,
340 TMR_DMA_TRANSFER_13BYTES = 0x0C,
341 TMR_DMA_TRANSFER_14BYTES = 0x0D,
342 TMR_DMA_TRANSFER_15BYTES = 0x0E,
343 TMR_DMA_TRANSFER_16BYTES = 0x0F,
344 TMR_DMA_TRANSFER_17BYTES = 0x10,
345 TMR_DMA_TRANSFER_18BYTES = 0x11
346}tmr_dma_transfer_length_type;
347
351typedef enum
352{
353 TMR_CTRL1_ADDRESS = 0x0000,
354 TMR_CTRL2_ADDRESS = 0x0001,
355 TMR_STCTRL_ADDRESS = 0x0002,
356 TMR_IDEN_ADDRESS = 0x0003,
357 TMR_ISTS_ADDRESS = 0x0004,
358 TMR_SWEVT_ADDRESS = 0x0005,
359 TMR_CM1_ADDRESS = 0x0006,
360 TMR_CM2_ADDRESS = 0x0007,
361 TMR_CCTRL_ADDRESS = 0x0008,
362 TMR_CVAL_ADDRESS = 0x0009,
363 TMR_DIV_ADDRESS = 0x000A,
364 TMR_PR_ADDRESS = 0x000B,
365 TMR_RPR_ADDRESS = 0x000C,
366 TMR_C1DT_ADDRESS = 0x000D,
367 TMR_C2DT_ADDRESS = 0x000E,
368 TMR_C3DT_ADDRESS = 0x000F,
369 TMR_C4DT_ADDRESS = 0x0010,
370 TMR_BRK_ADDRESS = 0x0011,
371 TMR_DMACTRL_ADDRESS = 0x0012
372}tmr_dma_address_type;
373
377typedef enum
378{
379 TMR_BRK_INPUT_ACTIVE_LOW = 0x00,
380 TMR_BRK_INPUT_ACTIVE_HIGH = 0x01
381}tmr_brk_polarity_type;
382
386typedef enum
387{
388 TMR_WP_OFF = 0x00,
389 TMR_WP_LEVEL_3 = 0x01,
390 TMR_WP_LEVEL_2 = 0x02,
391 TMR_WP_LEVEL_1 = 0x03
392}tmr_wp_level_type;
393
397typedef struct
398{
399 tmr_output_control_mode_type oc_mode;
400 confirm_state oc_idle_state;
401 confirm_state occ_idle_state;
402 tmr_output_polarity_type oc_polarity;
403 tmr_output_polarity_type occ_polarity;
404 confirm_state oc_output_state;
405 confirm_state occ_output_state;
406} tmr_output_config_type;
407
411typedef struct
412{
413 tmr_channel_select_type input_channel_select;
414 tmr_input_polarity_type input_polarity_select;
415 tmr_input_direction_mapped_type input_mapped_select;
416 uint8_t input_filter_value;
417} tmr_input_config_type;
418
422typedef struct
423{
424 uint8_t deadtime;
425 tmr_brk_polarity_type brk_polarity;
426 tmr_wp_level_type wp_level;
427 confirm_state auto_output_enable;
428 confirm_state fcsoen_state;
429 confirm_state fcsodis_state;
430 confirm_state brk_enable;
431} tmr_brkdt_config_type;
432
436typedef struct
437{
441 union
442 {
443 __IO uint32_t ctrl1;
444 struct
445 {
446 __IO uint32_t tmren : 1; /* [0] */
447 __IO uint32_t ovfen : 1; /* [1] */
448 __IO uint32_t ovfs : 1; /* [2] */
449 __IO uint32_t ocmen : 1; /* [3] */
450 __IO uint32_t cnt_dir : 3; /* [6:4] */
451 __IO uint32_t prben : 1; /* [7] */
452 __IO uint32_t clkdiv : 2; /* [9:8] */
453 __IO uint32_t pmen : 1; /* [10] */
454 __IO uint32_t reserved1 : 21;/* [31:11] */
455 } ctrl1_bit;
456 };
457
461 union
462 {
463 __IO uint32_t ctrl2;
464 struct
465 {
466 __IO uint32_t cbctrl : 1; /* [0] */
467 __IO uint32_t reserved1 : 1; /* [1] */
468 __IO uint32_t ccfs : 1; /* [2] */
469 __IO uint32_t drs : 1; /* [3] */
470 __IO uint32_t ptos : 3; /* [6:4] */
471 __IO uint32_t c1insel : 1; /* [7] */
472 __IO uint32_t c1ios : 1; /* [8] */
473 __IO uint32_t c1cios : 1; /* [9] */
474 __IO uint32_t c2ios : 1; /* [10] */
475 __IO uint32_t c2cios : 1; /* [11] */
476 __IO uint32_t c3ios : 1; /* [12] */
477 __IO uint32_t c3cios : 1; /* [13] */
478 __IO uint32_t c4ios : 1; /* [14] */
479 __IO uint32_t reserved2 : 17;/* [31:15] */
480 } ctrl2_bit;
481 };
482
486 union
487 {
488 __IO uint32_t stctrl;
489 struct
490 {
491 __IO uint32_t smsel : 3; /* [2:0] */
492 __IO uint32_t reserved1 : 1; /* [3] */
493 __IO uint32_t stis : 3; /* [6:4] */
494 __IO uint32_t sts : 1; /* [7] */
495 __IO uint32_t esf : 4; /* [11:8] */
496 __IO uint32_t esdiv : 2; /* [13:12] */
497 __IO uint32_t ecmben : 1; /* [14] */
498 __IO uint32_t esp : 1; /* [15] */
499 __IO uint32_t reserved2 : 16;/* [31:16] */
500 } stctrl_bit;
501 };
502
506 union
507 {
508 __IO uint32_t iden;
509 struct
510 {
511 __IO uint32_t ovfien : 1; /* [0] */
512 __IO uint32_t c1ien : 1; /* [1] */
513 __IO uint32_t c2ien : 1; /* [2] */
514 __IO uint32_t c3ien : 1; /* [3] */
515 __IO uint32_t c4ien : 1; /* [4] */
516 __IO uint32_t hallien : 1; /* [5] */
517 __IO uint32_t tien : 1; /* [6] */
518 __IO uint32_t brkie : 1; /* [7] */
519 __IO uint32_t ovfden : 1; /* [8] */
520 __IO uint32_t c1den : 1; /* [9] */
521 __IO uint32_t c2den : 1; /* [10] */
522 __IO uint32_t c3den : 1; /* [11] */
523 __IO uint32_t c4den : 1; /* [12] */
524 __IO uint32_t hallde : 1; /* [13] */
525 __IO uint32_t tden : 1; /* [14] */
526 __IO uint32_t reserved1 : 17;/* [31:15] */
527 } iden_bit;
528 };
529
533 union
534 {
535 __IO uint32_t ists;
536 struct
537 {
538 __IO uint32_t ovfif : 1; /* [0] */
539 __IO uint32_t c1if : 1; /* [1] */
540 __IO uint32_t c2if : 1; /* [2] */
541 __IO uint32_t c3if : 1; /* [3] */
542 __IO uint32_t c4if : 1; /* [4] */
543 __IO uint32_t hallif : 1; /* [5] */
544 __IO uint32_t trgif : 1; /* [6] */
545 __IO uint32_t brkif : 1; /* [7] */
546 __IO uint32_t reserved1 : 1; /* [8] */
547 __IO uint32_t c1rf : 1; /* [9] */
548 __IO uint32_t c2rf : 1; /* [10] */
549 __IO uint32_t c3rf : 1; /* [11] */
550 __IO uint32_t c4rf : 1; /* [12] */
551 __IO uint32_t reserved2 : 19;/* [31:13] */
552 } ists_bit;
553 };
554
558 union
559 {
560 __IO uint32_t swevt;
561 struct
562 {
563 __IO uint32_t ovfswtr : 1; /* [0] */
564 __IO uint32_t c1swtr : 1; /* [1] */
565 __IO uint32_t c2swtr : 1; /* [2] */
566 __IO uint32_t c3swtr : 1; /* [3] */
567 __IO uint32_t c4swtr : 1; /* [4] */
568 __IO uint32_t hallswtr : 1; /* [5] */
569 __IO uint32_t trgswtr : 1; /* [6] */
570 __IO uint32_t brkswtr : 1; /* [7] */
571 __IO uint32_t reserved : 24;/* [31:8] */
572 } swevt_bit;
573 };
574
578 union
579 {
580 __IO uint32_t cm1;
581
585 struct
586 {
587 __IO uint32_t c1c : 2; /* [1:0] */
588 __IO uint32_t c1oien : 1; /* [2] */
589 __IO uint32_t c1oben : 1; /* [3] */
590 __IO uint32_t c1octrl : 3; /* [6:4] */
591 __IO uint32_t c1osen : 1; /* [7] */
592 __IO uint32_t c2c : 2; /* [9:8] */
593 __IO uint32_t c2oien : 1; /* [10] */
594 __IO uint32_t c2oben : 1; /* [11] */
595 __IO uint32_t c2octrl : 3; /* [14:12] */
596 __IO uint32_t c2osen : 1; /* [15] */
597 __IO uint32_t reserved1 : 16;/* [31:16] */
598 } cm1_output_bit;
599
603 struct
604 {
605 __IO uint32_t c1c : 2; /* [1:0] */
606 __IO uint32_t c1idiv : 2; /* [3:2] */
607 __IO uint32_t c1df : 4; /* [7:4] */
608 __IO uint32_t c2c : 2; /* [9:8] */
609 __IO uint32_t c2idiv : 2; /* [11:10] */
610 __IO uint32_t c2df : 4; /* [15:12] */
611 __IO uint32_t reserved1 : 16;/* [31:16] */
612 } cm1_input_bit;
613 };
614
618 union
619 {
620 __IO uint32_t cm2;
621
625 struct
626 {
627 __IO uint32_t c3c : 2; /* [1:0] */
628 __IO uint32_t c3oien : 1; /* [2] */
629 __IO uint32_t c3oben : 1; /* [3] */
630 __IO uint32_t c3octrl : 3; /* [6:4] */
631 __IO uint32_t c3osen : 1; /* [7] */
632 __IO uint32_t c4c : 2; /* [9:8] */
633 __IO uint32_t c4oien : 1; /* [10] */
634 __IO uint32_t c4oben : 1; /* [11] */
635 __IO uint32_t c4octrl : 3; /* [14:12] */
636 __IO uint32_t c4osen : 1; /* [15] */
637 __IO uint32_t reserved1 : 16;/* [31:16] */
638 } cm2_output_bit;
639
643 struct
644 {
645 __IO uint32_t c3c : 2; /* [1:0] */
646 __IO uint32_t c3idiv : 2; /* [3:2] */
647 __IO uint32_t c3df : 4; /* [7:4] */
648 __IO uint32_t c4c : 2; /* [9:8] */
649 __IO uint32_t c4idiv : 2; /* [11:10] */
650 __IO uint32_t c4df : 4; /* [15:12] */
651 __IO uint32_t reserved1 : 16;/* [31:16] */
652 } cm2_input_bit;
653 };
654
658 union
659 {
660 uint32_t cctrl;
661 struct
662 {
663 __IO uint32_t c1en : 1; /* [0] */
664 __IO uint32_t c1p : 1; /* [1] */
665 __IO uint32_t c1cen : 1; /* [2] */
666 __IO uint32_t c1cp : 1; /* [3] */
667 __IO uint32_t c2en : 1; /* [4] */
668 __IO uint32_t c2p : 1; /* [5] */
669 __IO uint32_t c2cen : 1; /* [6] */
670 __IO uint32_t c2cp : 1; /* [7] */
671 __IO uint32_t c3en : 1; /* [8] */
672 __IO uint32_t c3p : 1; /* [9] */
673 __IO uint32_t c3cen : 1; /* [10] */
674 __IO uint32_t c3cp : 1; /* [11] */
675 __IO uint32_t c4en : 1; /* [12] */
676 __IO uint32_t c4p : 1; /* [13] */
677 __IO uint32_t reserved1 : 18;/* [31:14] */
678 } cctrl_bit;
679 };
680
684 union
685 {
686 __IO uint32_t cval;
687 struct
688 {
689 __IO uint32_t cval : 32;/* [31:0] */
690 } cval_bit;
691 };
692
696 union
697 {
698 __IO uint32_t div;
699 struct
700 {
701 __IO uint32_t div : 16;/* [15:0] */
702 __IO uint32_t reserved1 : 16;/* [31:16] */
703 } div_bit;
704 };
705
709 union
710 {
711 __IO uint32_t pr;
712 struct
713 {
714 __IO uint32_t pr : 32;/* [31:0] */
715 } pr_bit;
716 };
717
721 union
722 {
723 __IO uint32_t rpr;
724 struct
725 {
726 __IO uint32_t rpr : 8; /* [7:0] */
727 __IO uint32_t reserved1 : 24;/* [31:8] */
728 } rpr_bit;
729 };
730
734 union
735 {
736 uint32_t c1dt;
737 struct
738 {
739 __IO uint32_t c1dt : 32;/* [31:0] */
740 } c1dt_bit;
741 };
742
746 union
747 {
748 uint32_t c2dt;
749 struct
750 {
751 __IO uint32_t c2dt : 32;/* [31:0] */
752 } c2dt_bit;
753 };
754
758 union
759 {
760 __IO uint32_t c3dt;
761 struct
762 {
763 __IO uint32_t c3dt : 32;/* [31:0] */
764 } c3dt_bit;
765 };
766
770 union
771 {
772 __IO uint32_t c4dt;
773 struct
774 {
775 __IO uint32_t c4dt : 32;/* [31:0] */
776 } c4dt_bit;
777 };
778
782 union
783 {
784 __IO uint32_t brk;
785 struct
786 {
787 __IO uint32_t dtc : 8; /* [7:0] */
788 __IO uint32_t wpc : 2; /* [9:8] */
789 __IO uint32_t fcsodis : 1; /* [10] */
790 __IO uint32_t fcsoen : 1; /* [11] */
791 __IO uint32_t brken : 1; /* [12] */
792 __IO uint32_t brkv : 1; /* [13] */
793 __IO uint32_t aoen : 1; /* [14] */
794 __IO uint32_t oen : 1; /* [15] */
795 __IO uint32_t reserved1 : 16; /* [31:16] */
796 } brk_bit;
797 };
801 union
802 {
803 __IO uint32_t dmactrl;
804 struct
805 {
806 __IO uint32_t addr : 5; /* [4:0] */
807 __IO uint32_t reserved1 : 3; /* [7:5] */
808 __IO uint32_t dtb : 5; /* [12:8] */
809 __IO uint32_t reserved2 : 19;/* [31:13] */
810 } dmactrl_bit;
811 };
812
816 union
817 {
818 __IO uint32_t dmadt;
819 struct
820 {
821 __IO uint32_t dmadt : 16;/* [15:0] */
822 __IO uint32_t reserved1 : 16;/* [31:16] */
823 } dmadt_bit;
824 };
825
826} tmr_type;
827
832#define TMR1 ((tmr_type *) TMR1_BASE)
833#define TMR2 ((tmr_type *) TMR2_BASE)
834#define TMR3 ((tmr_type *) TMR3_BASE)
835#define TMR4 ((tmr_type *) TMR4_BASE)
836#define TMR5 ((tmr_type *) TMR5_BASE)
837#define TMR8 ((tmr_type *) TMR8_BASE)
838#define TMR9 ((tmr_type *) TMR9_BASE)
839#define TMR10 ((tmr_type *) TMR10_BASE)
840#define TMR11 ((tmr_type *) TMR11_BASE)
841
846void tmr_reset(tmr_type *tmr_x);
847void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state);
848void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct);
849void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct);
850void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct);
851void tmr_base_init(tmr_type* tmr_x, uint32_t tmr_pr, uint32_t tmr_div);
852void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div);
853void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir);
854void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value);
855void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value);
856uint32_t tmr_counter_value_get(tmr_type *tmr_x);
857void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value);
858uint32_t tmr_div_value_get(tmr_type *tmr_x);
859void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
860 tmr_output_config_type *tmr_output_struct);
861void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
862 tmr_output_control_mode_type oc_mode);
863void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value);
864uint32_t tmr_period_value_get(tmr_type *tmr_x);
865void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
866 uint32_t tmr_channel_value);
867uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel);
868void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state);
869void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
870 confirm_state new_state);
871void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
872 confirm_state new_state);
873void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
874 confirm_state new_state);
875void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state);
876void tmr_32_bit_function_enable (tmr_type *tmr_x, confirm_state new_state);
877void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state);
878void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state);
879void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, \
880 tmr_channel_input_divider_type divider_factor);
881void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state);
882void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
883 uint16_t filter_value);
884void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, \
885 tmr_channel_input_divider_type divider_factor);
886void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ti1_connect);
887void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
888 tmr_channel_input_divider_type divider_factor);
889void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode);
890void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode);
891void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select);
892void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state);
893void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state);
894void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select);
895void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state);
896void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state);
897void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state);
898 flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag);
899void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag);
900void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event);
901void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state);
902void tmr_internal_clock_set(tmr_type *tmr_x);
903
904void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
905 tmr_polarity_active_type oc_polarity);
906void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
907 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter);
908void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
909 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter);
910void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, \
911 tmr_external_signal_polarity_type es_polarity, uint16_t es_filter);
912void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type \
913 ic1_polarity, tmr_input_polarity_type ic2_polarity);
914void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, \
915 tmr_force_output_type force_output);
916void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, \
917 tmr_dma_address_type dma_base_address);
918void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct);
919
932#ifdef __cplusplus
933}
934#endif
935
936#endif
at32f413.h
at32f413 header file
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:39
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
tmr_dma_control_config
void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control
Definition: at32f413_tmr.c:1699
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:547
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_period_value_get
uint32_t tmr_period_value_get(tmr_type *tmr_x)
get tmr period value
Definition: at32f413_tmr.c:481
tmr_channel_buffer_enable
void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer
Definition: at32f413_tmr.c:1221
tmr_overflow_request_source_set
void tmr_overflow_request_source_set(tmr_type *tmr_x, confirm_state new_state)
select tmr the overflow event sources
Definition: at32f413_tmr.c:772
tmr_output_channel_mode_select
void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode
Definition: at32f413_tmr.c:425
tmr_input_channel_divider_set
void tmr_input_channel_divider_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_channel_input_divider_type divider_factor)
set tmr input channel divider
Definition: at32f413_tmr.c:1110
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1279
tmr_external_clock_config
void tmr_external_clock_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock
Definition: at32f413_tmr.c:1516
tmr_repetition_counter_set
void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value
Definition: at32f413_tmr.c:235
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:588
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_internal_clock_set
void tmr_internal_clock_set(tmr_type *tmr_x)
set tmr select internal clock
Definition: at32f413_tmr.c:1430
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f413_tmr.c:153
tmr_force_output_set
void tmr_force_output_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_force_output_type force_output)
set tmr force output
Definition: at32f413_tmr.c:1633
tmr_counter_value_set
void tmr_counter_value_set(tmr_type *tmr_x, uint32_t tmr_cnt_value)
set tmr counter value
Definition: at32f413_tmr.c:255
tmr_div_value_get
uint32_t tmr_div_value_get(tmr_type *tmr_x)
get tmr div value
Definition: at32f413_tmr.c:298
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:807
tmr_input_channel_filter_set
void tmr_input_channel_filter_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint16_t filter_value)
set tmr input channel filter
Definition: at32f413_tmr.c:931
tmr_period_value_set
void tmr_period_value_set(tmr_type *tmr_x, uint32_t tmr_pr_value)
set tmr period value
Definition: at32f413_tmr.c:465
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f413_tmr.c:269
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time
Definition: at32f413_tmr.c:1715
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_external_clock_mode2_config
void tmr_external_clock_mode2_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode2
Definition: at32f413_tmr.c:1568
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:139
tmr_div_value_set
void tmr_div_value_set(tmr_type *tmr_x, uint32_t tmr_div_value)
set tmr div value
Definition: at32f413_tmr.c:284
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_channel1_input_select
void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ti1_connect)
select tmr channel1 input
Definition: at32f413_tmr.c:1085
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1256
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_hall_select
void tmr_hall_select(tmr_type *tmr_x, confirm_state new_state)
select tmr hall
Definition: at32f413_tmr.c:1208
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:754
tmr_external_clock_mode1_config
void tmr_external_clock_mode1_config(tmr_type *tmr_x, tmr_external_signal_divider_type es_divide, tmr_external_signal_polarity_type es_polarity, uint16_t es_filter)
config tmr external clock mode1
Definition: at32f413_tmr.c:1542
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f413_tmr.c:977
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:609
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1157
tmr_overflow_event_disable
void tmr_overflow_event_disable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr overflow event generation
Definition: at32f413_tmr.c:786
tmr_channel_dma_select
void tmr_channel_dma_select(tmr_type *tmr_x, tmr_dma_request_source_type cc_dma_select)
select tmr channel dma
Definition: at32f413_tmr.c:1195
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_output_channel_immediately_set
void tmr_output_channel_immediately_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel immediately
Definition: at32f413_tmr.c:655
tmr_encoder_mode_config
void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode
Definition: at32f413_tmr.c:1597
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f413_tmr.c:875
tmr_output_channel_switch_set
void tmr_output_channel_switch_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
set tmr output channel switch
Definition: at32f413_tmr.c:701
tmr_reset
void tmr_reset(tmr_type *tmr_x)
tmr reset by crm reset register
Definition: at32f413_tmr.c:52
tmr_output_channel_polarity_set
void tmr_output_channel_polarity_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_polarity_active_type oc_polarity)
set tmr output channel polarity
Definition: at32f413_tmr.c:1456
tmr_one_cycle_mode_enable
void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode
Definition: at32f413_tmr.c:740
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
tmr_dma_request_type
tmr_dma_request_type
tmr dma request type
Definition: at32f413_tmr.h:268
tmr_external_signal_divider_type
tmr_external_signal_divider_type
tmr external signal divider type
Definition: at32f413_tmr.h:307
tmr_polarity_active_type
tmr_polarity_active_type
tmr polarity active type
Definition: at32f413_tmr.h:297
tmr_count_mode_type
tmr_count_mode_type
tmr counter mode type
Definition: at32f413_tmr.h:105
tmr_input_polarity_type
tmr_input_polarity_type
tmr input channel polarity type
Definition: at32f413_tmr.h:205
tmr_dma_request_source_type
tmr_dma_request_source_type
tmr dma request source select type
Definition: at32f413_tmr.h:259
tmr_channel_select_type
tmr_channel_select_type
tmr channel select type
Definition: at32f413_tmr.h:215
tmr_external_signal_polarity_type
tmr_external_signal_polarity_type
tmr external signal polarity type
Definition: at32f413_tmr.h:318
tmr_dma_address_type
tmr_dma_address_type
tmr dma base address type
Definition: at32f413_tmr.h:352
tmr_wp_level_type
tmr_wp_level_type
tmr write protect level type
Definition: at32f413_tmr.h:387
tmr_channel1_input_connected_type
tmr_channel1_input_connected_type
tmr channel1 input connected type
Definition: at32f413_tmr.h:229
tmr_input_direction_mapped_type
tmr_input_direction_mapped_type
tmr input channel mapped type channel direction
Definition: at32f413_tmr.h:238
tmr_clock_division_type
tmr_clock_division_type
tmr clock division type
Definition: at32f413_tmr.h:95
tmr_event_trigger_type
tmr_event_trigger_type
tmr event triggered by software type
Definition: at32f413_tmr.h:282
tmr_brk_polarity_type
tmr_brk_polarity_type
tmr brk polarity type
Definition: at32f413_tmr.h:378
tmr_output_control_mode_type
tmr_output_control_mode_type
tmr output control mode type
Definition: at32f413_tmr.h:172
tmr_output_polarity_type
tmr_output_polarity_type
tmr output channel polarity type
Definition: at32f413_tmr.h:196
tmr_dma_transfer_length_type
tmr_dma_transfer_length_type
tmr dma transfer length type
Definition: at32f413_tmr.h:327
sub_tmr_input_sel_type
sub_tmr_input_sel_type
tmr subordinate mode input select type
Definition: at32f413_tmr.h:132
tmr_force_output_type
tmr_force_output_type
tmr force output type
Definition: at32f413_tmr.h:187
tmr_sub_mode_select_type
tmr_sub_mode_select_type
tmr subordinate mode select type
Definition: at32f413_tmr.h:147
tmr_primary_select_type
tmr_primary_select_type
tmr primary mode select type
Definition: at32f413_tmr.h:117
tmr_encoder_mode_type
tmr_encoder_mode_type
tmr encoder mode type
Definition: at32f413_tmr.h:162
tmr_channel_input_divider_type
tmr_channel_input_divider_type
tmr input divider type
Definition: at32f413_tmr.h:248
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f413_tmr.h:269
TMR_HALL_DMA_REQUEST
@ TMR_HALL_DMA_REQUEST
Definition: at32f413_tmr.h:274
TMR_C1_DMA_REQUEST
@ TMR_C1_DMA_REQUEST
Definition: at32f413_tmr.h:270
TMR_C2_DMA_REQUEST
@ TMR_C2_DMA_REQUEST
Definition: at32f413_tmr.h:271
TMR_C3_DMA_REQUEST
@ TMR_C3_DMA_REQUEST
Definition: at32f413_tmr.h:272
TMR_TRIGGER_DMA_REQUEST
@ TMR_TRIGGER_DMA_REQUEST
Definition: at32f413_tmr.h:275
TMR_C4_DMA_REQUEST
@ TMR_C4_DMA_REQUEST
Definition: at32f413_tmr.h:273
TMR_ES_FREQUENCY_DIV_1
@ TMR_ES_FREQUENCY_DIV_1
Definition: at32f413_tmr.h:308
TMR_ES_FREQUENCY_DIV_8
@ TMR_ES_FREQUENCY_DIV_8
Definition: at32f413_tmr.h:311
TMR_ES_FREQUENCY_DIV_4
@ TMR_ES_FREQUENCY_DIV_4
Definition: at32f413_tmr.h:310
TMR_ES_FREQUENCY_DIV_2
@ TMR_ES_FREQUENCY_DIV_2
Definition: at32f413_tmr.h:309
TMR_POLARITY_ACTIVE_HIGH
@ TMR_POLARITY_ACTIVE_HIGH
Definition: at32f413_tmr.h:298
TMR_POLARITY_ACTIVE_LOW
@ TMR_POLARITY_ACTIVE_LOW
Definition: at32f413_tmr.h:299
TMR_POLARITY_ACTIVE_BOTH
@ TMR_POLARITY_ACTIVE_BOTH
Definition: at32f413_tmr.h:300
TMR_COUNT_DOWN
@ TMR_COUNT_DOWN
Definition: at32f413_tmr.h:107
TMR_COUNT_TWO_WAY_2
@ TMR_COUNT_TWO_WAY_2
Definition: at32f413_tmr.h:109
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_COUNT_TWO_WAY_3
@ TMR_COUNT_TWO_WAY_3
Definition: at32f413_tmr.h:110
TMR_COUNT_TWO_WAY_1
@ TMR_COUNT_TWO_WAY_1
Definition: at32f413_tmr.h:108
TMR_INPUT_BOTH_EDGE
@ TMR_INPUT_BOTH_EDGE
Definition: at32f413_tmr.h:208
TMR_INPUT_FALLING_EDGE
@ TMR_INPUT_FALLING_EDGE
Definition: at32f413_tmr.h:207
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_DMA_REQUEST_BY_CHANNEL
@ TMR_DMA_REQUEST_BY_CHANNEL
Definition: at32f413_tmr.h:260
TMR_DMA_REQUEST_BY_OVERFLOW
@ TMR_DMA_REQUEST_BY_OVERFLOW
Definition: at32f413_tmr.h:261
TMR_SELECT_CHANNEL_1C
@ TMR_SELECT_CHANNEL_1C
Definition: at32f413_tmr.h:217
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2C
@ TMR_SELECT_CHANNEL_2C
Definition: at32f413_tmr.h:219
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_3C
@ TMR_SELECT_CHANNEL_3C
Definition: at32f413_tmr.h:221
TMR_ES_POLARITY_INVERTED
@ TMR_ES_POLARITY_INVERTED
Definition: at32f413_tmr.h:320
TMR_ES_POLARITY_NON_INVERTED
@ TMR_ES_POLARITY_NON_INVERTED
Definition: at32f413_tmr.h:319
TMR_C2DT_ADDRESS
@ TMR_C2DT_ADDRESS
Definition: at32f413_tmr.h:367
TMR_C1DT_ADDRESS
@ TMR_C1DT_ADDRESS
Definition: at32f413_tmr.h:366
TMR_STCTRL_ADDRESS
@ TMR_STCTRL_ADDRESS
Definition: at32f413_tmr.h:355
TMR_BRK_ADDRESS
@ TMR_BRK_ADDRESS
Definition: at32f413_tmr.h:370
TMR_CTRL2_ADDRESS
@ TMR_CTRL2_ADDRESS
Definition: at32f413_tmr.h:354
TMR_PR_ADDRESS
@ TMR_PR_ADDRESS
Definition: at32f413_tmr.h:364
TMR_CVAL_ADDRESS
@ TMR_CVAL_ADDRESS
Definition: at32f413_tmr.h:362
TMR_CM1_ADDRESS
@ TMR_CM1_ADDRESS
Definition: at32f413_tmr.h:359
TMR_IDEN_ADDRESS
@ TMR_IDEN_ADDRESS
Definition: at32f413_tmr.h:356
TMR_DMACTRL_ADDRESS
@ TMR_DMACTRL_ADDRESS
Definition: at32f413_tmr.h:371
TMR_CCTRL_ADDRESS
@ TMR_CCTRL_ADDRESS
Definition: at32f413_tmr.h:361
TMR_RPR_ADDRESS
@ TMR_RPR_ADDRESS
Definition: at32f413_tmr.h:365
TMR_ISTS_ADDRESS
@ TMR_ISTS_ADDRESS
Definition: at32f413_tmr.h:357
TMR_C4DT_ADDRESS
@ TMR_C4DT_ADDRESS
Definition: at32f413_tmr.h:369
TMR_DIV_ADDRESS
@ TMR_DIV_ADDRESS
Definition: at32f413_tmr.h:363
TMR_SWEVT_ADDRESS
@ TMR_SWEVT_ADDRESS
Definition: at32f413_tmr.h:358
TMR_CM2_ADDRESS
@ TMR_CM2_ADDRESS
Definition: at32f413_tmr.h:360
TMR_C3DT_ADDRESS
@ TMR_C3DT_ADDRESS
Definition: at32f413_tmr.h:368
TMR_CTRL1_ADDRESS
@ TMR_CTRL1_ADDRESS
Definition: at32f413_tmr.h:353
TMR_WP_LEVEL_3
@ TMR_WP_LEVEL_3
Definition: at32f413_tmr.h:389
TMR_WP_LEVEL_2
@ TMR_WP_LEVEL_2
Definition: at32f413_tmr.h:390
TMR_WP_OFF
@ TMR_WP_OFF
Definition: at32f413_tmr.h:388
TMR_WP_LEVEL_1
@ TMR_WP_LEVEL_1
Definition: at32f413_tmr.h:391
TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
@ TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Definition: at32f413_tmr.h:231
TMR_CHANEL1_CONNECTED_C1IRAW
@ TMR_CHANEL1_CONNECTED_C1IRAW
Definition: at32f413_tmr.h:230
TMR_CC_CHANNEL_MAPPED_STI
@ TMR_CC_CHANNEL_MAPPED_STI
Definition: at32f413_tmr.h:241
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:239
TMR_CC_CHANNEL_MAPPED_INDIRECT
@ TMR_CC_CHANNEL_MAPPED_INDIRECT
Definition: at32f413_tmr.h:240
TMR_CLOCK_DIV2
@ TMR_CLOCK_DIV2
Definition: at32f413_tmr.h:97
TMR_CLOCK_DIV4
@ TMR_CLOCK_DIV4
Definition: at32f413_tmr.h:98
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_C1_SWTRIG
@ TMR_C1_SWTRIG
Definition: at32f413_tmr.h:284
TMR_C3_SWTRIG
@ TMR_C3_SWTRIG
Definition: at32f413_tmr.h:286
TMR_C2_SWTRIG
@ TMR_C2_SWTRIG
Definition: at32f413_tmr.h:285
TMR_C4_SWTRIG
@ TMR_C4_SWTRIG
Definition: at32f413_tmr.h:287
TMR_BRK_SWTRIG
@ TMR_BRK_SWTRIG
Definition: at32f413_tmr.h:290
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR_TRIGGER_SWTRIG
@ TMR_TRIGGER_SWTRIG
Definition: at32f413_tmr.h:289
TMR_OVERFLOW_SWTRIG
@ TMR_OVERFLOW_SWTRIG
Definition: at32f413_tmr.h:283
TMR_BRK_INPUT_ACTIVE_HIGH
@ TMR_BRK_INPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:380
TMR_BRK_INPUT_ACTIVE_LOW
@ TMR_BRK_INPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:379
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:180
TMR_OUTPUT_CONTROL_FORCE_HIGH
@ TMR_OUTPUT_CONTROL_FORCE_HIGH
Definition: at32f413_tmr.h:178
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f413_tmr.h:176
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f413_tmr.h:173
TMR_OUTPUT_CONTROL_LOW
@ TMR_OUTPUT_CONTROL_LOW
Definition: at32f413_tmr.h:175
TMR_OUTPUT_CONTROL_FORCE_LOW
@ TMR_OUTPUT_CONTROL_FORCE_LOW
Definition: at32f413_tmr.h:177
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_CONTROL_HIGH
@ TMR_OUTPUT_CONTROL_HIGH
Definition: at32f413_tmr.h:174
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR_DMA_TRANSFER_15BYTES
@ TMR_DMA_TRANSFER_15BYTES
Definition: at32f413_tmr.h:342
TMR_DMA_TRANSFER_11BYTES
@ TMR_DMA_TRANSFER_11BYTES
Definition: at32f413_tmr.h:338
TMR_DMA_TRANSFER_13BYTES
@ TMR_DMA_TRANSFER_13BYTES
Definition: at32f413_tmr.h:340
TMR_DMA_TRANSFER_14BYTES
@ TMR_DMA_TRANSFER_14BYTES
Definition: at32f413_tmr.h:341
TMR_DMA_TRANSFER_2BYTES
@ TMR_DMA_TRANSFER_2BYTES
Definition: at32f413_tmr.h:329
TMR_DMA_TRANSFER_18BYTES
@ TMR_DMA_TRANSFER_18BYTES
Definition: at32f413_tmr.h:345
TMR_DMA_TRANSFER_9BYTES
@ TMR_DMA_TRANSFER_9BYTES
Definition: at32f413_tmr.h:336
TMR_DMA_TRANSFER_12BYTES
@ TMR_DMA_TRANSFER_12BYTES
Definition: at32f413_tmr.h:339
TMR_DMA_TRANSFER_7BYTES
@ TMR_DMA_TRANSFER_7BYTES
Definition: at32f413_tmr.h:334
TMR_DMA_TRANSFER_17BYTES
@ TMR_DMA_TRANSFER_17BYTES
Definition: at32f413_tmr.h:344
TMR_DMA_TRANSFER_16BYTES
@ TMR_DMA_TRANSFER_16BYTES
Definition: at32f413_tmr.h:343
TMR_DMA_TRANSFER_5BYTES
@ TMR_DMA_TRANSFER_5BYTES
Definition: at32f413_tmr.h:332
TMR_DMA_TRANSFER_10BYTES
@ TMR_DMA_TRANSFER_10BYTES
Definition: at32f413_tmr.h:337
TMR_DMA_TRANSFER_1BYTE
@ TMR_DMA_TRANSFER_1BYTE
Definition: at32f413_tmr.h:328
TMR_DMA_TRANSFER_6BYTES
@ TMR_DMA_TRANSFER_6BYTES
Definition: at32f413_tmr.h:333
TMR_DMA_TRANSFER_4BYTES
@ TMR_DMA_TRANSFER_4BYTES
Definition: at32f413_tmr.h:331
TMR_DMA_TRANSFER_8BYTES
@ TMR_DMA_TRANSFER_8BYTES
Definition: at32f413_tmr.h:335
TMR_DMA_TRANSFER_3BYTES
@ TMR_DMA_TRANSFER_3BYTES
Definition: at32f413_tmr.h:330
TMR_SUB_INPUT_SEL_IS2
@ TMR_SUB_INPUT_SEL_IS2
Definition: at32f413_tmr.h:135
TMR_SUB_INPUT_SEL_IS0
@ TMR_SUB_INPUT_SEL_IS0
Definition: at32f413_tmr.h:133
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:139
TMR_SUB_INPUT_SEL_EXTIN
@ TMR_SUB_INPUT_SEL_EXTIN
Definition: at32f413_tmr.h:140
TMR_SUB_INPUT_SEL_IS3
@ TMR_SUB_INPUT_SEL_IS3
Definition: at32f413_tmr.h:136
TMR_SUB_INPUT_SEL_C1DF1
@ TMR_SUB_INPUT_SEL_C1DF1
Definition: at32f413_tmr.h:138
TMR_SUB_INPUT_SEL_C1INC
@ TMR_SUB_INPUT_SEL_C1INC
Definition: at32f413_tmr.h:137
TMR_SUB_INPUT_SEL_IS1
@ TMR_SUB_INPUT_SEL_IS1
Definition: at32f413_tmr.h:134
TMR_FORCE_OUTPUT_HIGH
@ TMR_FORCE_OUTPUT_HIGH
Definition: at32f413_tmr.h:188
TMR_FORCE_OUTPUT_LOW
@ TMR_FORCE_OUTPUT_LOW
Definition: at32f413_tmr.h:189
TMR_SUB_ENCODER_MODE_A
@ TMR_SUB_ENCODER_MODE_A
Definition: at32f413_tmr.h:149
TMR_SUB_EXTERNAL_CLOCK_MODE_A
@ TMR_SUB_EXTERNAL_CLOCK_MODE_A
Definition: at32f413_tmr.h:155
TMR_SUB_ENCODER_MODE_C
@ TMR_SUB_ENCODER_MODE_C
Definition: at32f413_tmr.h:151
TMR_SUB_MODE_DIABLE
@ TMR_SUB_MODE_DIABLE
Definition: at32f413_tmr.h:148
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f413_tmr.h:152
TMR_SUB_ENCODER_MODE_B
@ TMR_SUB_ENCODER_MODE_B
Definition: at32f413_tmr.h:150
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:153
TMR_SUB_TRIGGER_MODE
@ TMR_SUB_TRIGGER_MODE
Definition: at32f413_tmr.h:154
TMR_PRIMARY_SEL_RESET
@ TMR_PRIMARY_SEL_RESET
Definition: at32f413_tmr.h:118
TMR_PRIMARY_SEL_C2ORAW
@ TMR_PRIMARY_SEL_C2ORAW
Definition: at32f413_tmr.h:123
TMR_PRIMARY_SEL_C1ORAW
@ TMR_PRIMARY_SEL_C1ORAW
Definition: at32f413_tmr.h:122
TMR_PRIMARY_SEL_C4ORAW
@ TMR_PRIMARY_SEL_C4ORAW
Definition: at32f413_tmr.h:125
TMR_PRIMARY_SEL_COMPARE
@ TMR_PRIMARY_SEL_COMPARE
Definition: at32f413_tmr.h:121
TMR_PRIMARY_SEL_ENABLE
@ TMR_PRIMARY_SEL_ENABLE
Definition: at32f413_tmr.h:119
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f413_tmr.h:120
TMR_PRIMARY_SEL_C3ORAW
@ TMR_PRIMARY_SEL_C3ORAW
Definition: at32f413_tmr.h:124
TMR_ENCODER_MODE_C
@ TMR_ENCODER_MODE_C
Definition: at32f413_tmr.h:165
TMR_ENCODER_MODE_A
@ TMR_ENCODER_MODE_A
Definition: at32f413_tmr.h:163
TMR_ENCODER_MODE_B
@ TMR_ENCODER_MODE_B
Definition: at32f413_tmr.h:164
TMR_CHANNEL_INPUT_DIV_4
@ TMR_CHANNEL_INPUT_DIV_4
Definition: at32f413_tmr.h:251
TMR_CHANNEL_INPUT_DIV_2
@ TMR_CHANNEL_INPUT_DIV_2
Definition: at32f413_tmr.h:250
TMR_CHANNEL_INPUT_DIV_8
@ TMR_CHANNEL_INPUT_DIV_8
Definition: at32f413_tmr.h:252
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:249
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f413_tmr.h:423
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f413_tmr.h:430
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f413_tmr.h:424
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f413_tmr.h:427
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f413_tmr.h:426
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f413_tmr.h:428
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f413_tmr.h:429
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f413_tmr.h:425
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:416
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
tmr_type
type define tmr register all
Definition: at32f413_tmr.h:437
tmr_type::ovfif
__IO uint32_t ovfif
Definition: at32f413_tmr.h:538
tmr_type::c1cen
__IO uint32_t c1cen
Definition: at32f413_tmr.h:665
tmr_type::pmen
__IO uint32_t pmen
Definition: at32f413_tmr.h:453
tmr_type::trgif
__IO uint32_t trgif
Definition: at32f413_tmr.h:544
tmr_type::brken
__IO uint32_t brken
Definition: at32f413_tmr.h:791
tmr_type::c1idiv
__IO uint32_t c1idiv
Definition: at32f413_tmr.h:606
tmr_type::dmactrl
__IO uint32_t dmactrl
Definition: at32f413_tmr.h:803
tmr_type::dtc
__IO uint32_t dtc
Definition: at32f413_tmr.h:787
tmr_type::c1en
__IO uint32_t c1en
Definition: at32f413_tmr.h:663
tmr_type::c4df
__IO uint32_t c4df
Definition: at32f413_tmr.h:650
tmr_type::c3octrl
__IO uint32_t c3octrl
Definition: at32f413_tmr.h:630
tmr_type::brkif
__IO uint32_t brkif
Definition: at32f413_tmr.h:545
tmr_type::c2osen
__IO uint32_t c2osen
Definition: at32f413_tmr.h:596
tmr_type::swevt
__IO uint32_t swevt
Definition: at32f413_tmr.h:560
tmr_type::ovfden
__IO uint32_t ovfden
Definition: at32f413_tmr.h:519
tmr_type::c2en
__IO uint32_t c2en
Definition: at32f413_tmr.h:667
tmr_type::stctrl
__IO uint32_t stctrl
Definition: at32f413_tmr.h:488
tmr_type::c3df
__IO uint32_t c3df
Definition: at32f413_tmr.h:647
tmr_type::wpc
__IO uint32_t wpc
Definition: at32f413_tmr.h:788
tmr_type::c3oben
__IO uint32_t c3oben
Definition: at32f413_tmr.h:629
tmr_type::cnt_dir
__IO uint32_t cnt_dir
Definition: at32f413_tmr.h:450
tmr_type::c2if
__IO uint32_t c2if
Definition: at32f413_tmr.h:540
tmr_type::c3if
__IO uint32_t c3if
Definition: at32f413_tmr.h:541
tmr_type::c4octrl
__IO uint32_t c4octrl
Definition: at32f413_tmr.h:635
tmr_type::hallif
__IO uint32_t hallif
Definition: at32f413_tmr.h:543
tmr_type::c1insel
__IO uint32_t c1insel
Definition: at32f413_tmr.h:471
tmr_type::c2cios
__IO uint32_t c2cios
Definition: at32f413_tmr.h:475
tmr_type::div
__IO uint32_t div
Definition: at32f413_tmr.h:698
tmr_type::hallswtr
__IO uint32_t hallswtr
Definition: at32f413_tmr.h:568
tmr_type::esf
__IO uint32_t esf
Definition: at32f413_tmr.h:495
tmr_type::c1osen
__IO uint32_t c1osen
Definition: at32f413_tmr.h:591
tmr_type::c2cen
__IO uint32_t c2cen
Definition: at32f413_tmr.h:669
tmr_type::c2ien
__IO uint32_t c2ien
Definition: at32f413_tmr.h:513
tmr_type::drs
__IO uint32_t drs
Definition: at32f413_tmr.h:469
tmr_type::iden
__IO uint32_t iden
Definition: at32f413_tmr.h:508
tmr_type::c1oben
__IO uint32_t c1oben
Definition: at32f413_tmr.h:589
tmr_type::ists
__IO uint32_t ists
Definition: at32f413_tmr.h:535
tmr_type::c1c
__IO uint32_t c1c
Definition: at32f413_tmr.h:587
tmr_type::c3cen
__IO uint32_t c3cen
Definition: at32f413_tmr.h:673
tmr_type::c4p
__IO uint32_t c4p
Definition: at32f413_tmr.h:676
tmr_type::brkv
__IO uint32_t brkv
Definition: at32f413_tmr.h:792
tmr_type::brk
__IO uint32_t brk
Definition: at32f413_tmr.h:784
tmr_type::stis
__IO uint32_t stis
Definition: at32f413_tmr.h:493
tmr_type::ovfswtr
__IO uint32_t ovfswtr
Definition: at32f413_tmr.h:563
tmr_type::c3idiv
__IO uint32_t c3idiv
Definition: at32f413_tmr.h:646
tmr_type::c4osen
__IO uint32_t c4osen
Definition: at32f413_tmr.h:636
tmr_type::c1ien
__IO uint32_t c1ien
Definition: at32f413_tmr.h:512
tmr_type::c1octrl
__IO uint32_t c1octrl
Definition: at32f413_tmr.h:590
tmr_type::hallien
__IO uint32_t hallien
Definition: at32f413_tmr.h:516
tmr_type::tmren
__IO uint32_t tmren
Definition: at32f413_tmr.h:446
tmr_type::oen
__IO uint32_t oen
Definition: at32f413_tmr.h:794
tmr_type::sts
__IO uint32_t sts
Definition: at32f413_tmr.h:494
tmr_type::brkie
__IO uint32_t brkie
Definition: at32f413_tmr.h:518
tmr_type::c2idiv
__IO uint32_t c2idiv
Definition: at32f413_tmr.h:609
tmr_type::c1p
__IO uint32_t c1p
Definition: at32f413_tmr.h:664
tmr_type::brkswtr
__IO uint32_t brkswtr
Definition: at32f413_tmr.h:570
tmr_type::c1rf
__IO uint32_t c1rf
Definition: at32f413_tmr.h:547
tmr_type::ovfien
__IO uint32_t ovfien
Definition: at32f413_tmr.h:511
tmr_type::c1oien
__IO uint32_t c1oien
Definition: at32f413_tmr.h:588
tmr_type::pr
__IO uint32_t pr
Definition: at32f413_tmr.h:711
tmr_type::c3oien
__IO uint32_t c3oien
Definition: at32f413_tmr.h:628
tmr_type::c2swtr
__IO uint32_t c2swtr
Definition: at32f413_tmr.h:565
tmr_type::c1dt
uint32_t c1dt
Definition: at32f413_tmr.h:736
tmr_type::c2oben
__IO uint32_t c2oben
Definition: at32f413_tmr.h:594
tmr_type::c1den
__IO uint32_t c1den
Definition: at32f413_tmr.h:520
tmr_type::cm2
__IO uint32_t cm2
Definition: at32f413_tmr.h:620
tmr_type::c2octrl
__IO uint32_t c2octrl
Definition: at32f413_tmr.h:595
tmr_type::smsel
__IO uint32_t smsel
Definition: at32f413_tmr.h:491
tmr_type::c3p
__IO uint32_t c3p
Definition: at32f413_tmr.h:672
tmr_type::c2dt
__IO uint32_t c2dt
Definition: at32f413_tmr.h:751
tmr_type::dmadt
__IO uint32_t dmadt
Definition: at32f413_tmr.h:818
tmr_type::c1if
__IO uint32_t c1if
Definition: at32f413_tmr.h:539
tmr_type::c1cp
__IO uint32_t c1cp
Definition: at32f413_tmr.h:666
tmr_type::c3c
__IO uint32_t c3c
Definition: at32f413_tmr.h:627
tmr_type::c4rf
__IO uint32_t c4rf
Definition: at32f413_tmr.h:550
tmr_type::c3cios
__IO uint32_t c3cios
Definition: at32f413_tmr.h:477
tmr_type::clkdiv
__IO uint32_t clkdiv
Definition: at32f413_tmr.h:452
tmr_type::tden
__IO uint32_t tden
Definition: at32f413_tmr.h:525
tmr_type::ovfs
__IO uint32_t ovfs
Definition: at32f413_tmr.h:448
tmr_type::c1dt
__IO uint32_t c1dt
Definition: at32f413_tmr.h:739
tmr_type::c3swtr
__IO uint32_t c3swtr
Definition: at32f413_tmr.h:566
tmr_type::cbctrl
__IO uint32_t cbctrl
Definition: at32f413_tmr.h:466
tmr_type::dtb
__IO uint32_t dtb
Definition: at32f413_tmr.h:808
tmr_type::c4ios
__IO uint32_t c4ios
Definition: at32f413_tmr.h:478
tmr_type::c4swtr
__IO uint32_t c4swtr
Definition: at32f413_tmr.h:567
tmr_type::prben
__IO uint32_t prben
Definition: at32f413_tmr.h:451
tmr_type::tien
__IO uint32_t tien
Definition: at32f413_tmr.h:517
tmr_type::ccfs
__IO uint32_t ccfs
Definition: at32f413_tmr.h:468
tmr_type::ecmben
__IO uint32_t ecmben
Definition: at32f413_tmr.h:497
tmr_type::ovfen
__IO uint32_t ovfen
Definition: at32f413_tmr.h:447
tmr_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_tmr.h:479
tmr_type::cm1
__IO uint32_t cm1
Definition: at32f413_tmr.h:580
tmr_type::c2den
__IO uint32_t c2den
Definition: at32f413_tmr.h:521
tmr_type::c4en
__IO uint32_t c4en
Definition: at32f413_tmr.h:675
tmr_type::reserved
__IO uint32_t reserved
Definition: at32f413_tmr.h:571
tmr_type::trgswtr
__IO uint32_t trgswtr
Definition: at32f413_tmr.h:569
tmr_type::fcsoen
__IO uint32_t fcsoen
Definition: at32f413_tmr.h:790
tmr_type::esdiv
__IO uint32_t esdiv
Definition: at32f413_tmr.h:496
tmr_type::c3en
__IO uint32_t c3en
Definition: at32f413_tmr.h:671
tmr_type::c2p
__IO uint32_t c2p
Definition: at32f413_tmr.h:668
tmr_type::c3ios
__IO uint32_t c3ios
Definition: at32f413_tmr.h:476
tmr_type::ocmen
__IO uint32_t ocmen
Definition: at32f413_tmr.h:449
tmr_type::hallde
__IO uint32_t hallde
Definition: at32f413_tmr.h:524
tmr_type::c1swtr
__IO uint32_t c1swtr
Definition: at32f413_tmr.h:564
tmr_type::c3rf
__IO uint32_t c3rf
Definition: at32f413_tmr.h:549
tmr_type::c3den
__IO uint32_t c3den
Definition: at32f413_tmr.h:522
tmr_type::c4oien
__IO uint32_t c4oien
Definition: at32f413_tmr.h:633
tmr_type::c2dt
uint32_t c2dt
Definition: at32f413_tmr.h:748
tmr_type::addr
__IO uint32_t addr
Definition: at32f413_tmr.h:806
tmr_type::c3cp
__IO uint32_t c3cp
Definition: at32f413_tmr.h:674
tmr_type::c2df
__IO uint32_t c2df
Definition: at32f413_tmr.h:610
tmr_type::c4idiv
__IO uint32_t c4idiv
Definition: at32f413_tmr.h:649
tmr_type::c2ios
__IO uint32_t c2ios
Definition: at32f413_tmr.h:474
tmr_type::c3osen
__IO uint32_t c3osen
Definition: at32f413_tmr.h:631
tmr_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_tmr.h:454
tmr_type::rpr
__IO uint32_t rpr
Definition: at32f413_tmr.h:723
tmr_type::c2c
__IO uint32_t c2c
Definition: at32f413_tmr.h:592
tmr_type::c1ios
__IO uint32_t c1ios
Definition: at32f413_tmr.h:472
tmr_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_tmr.h:443
tmr_type::c4den
__IO uint32_t c4den
Definition: at32f413_tmr.h:523
tmr_type::c1df
__IO uint32_t c1df
Definition: at32f413_tmr.h:607
tmr_type::c2oien
__IO uint32_t c2oien
Definition: at32f413_tmr.h:593
tmr_type::c4dt
__IO uint32_t c4dt
Definition: at32f413_tmr.h:772
tmr_type::c4if
__IO uint32_t c4if
Definition: at32f413_tmr.h:542
tmr_type::c3ien
__IO uint32_t c3ien
Definition: at32f413_tmr.h:514
tmr_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_tmr.h:463
tmr_type::c3dt
__IO uint32_t c3dt
Definition: at32f413_tmr.h:760
tmr_type::c2cp
__IO uint32_t c2cp
Definition: at32f413_tmr.h:670
tmr_type::cctrl
uint32_t cctrl
Definition: at32f413_tmr.h:660
tmr_type::c4c
__IO uint32_t c4c
Definition: at32f413_tmr.h:632
tmr_type::c4oben
__IO uint32_t c4oben
Definition: at32f413_tmr.h:634
tmr_type::fcsodis
__IO uint32_t fcsodis
Definition: at32f413_tmr.h:789
tmr_type::cval
__IO uint32_t cval
Definition: at32f413_tmr.h:686
tmr_type::c4ien
__IO uint32_t c4ien
Definition: at32f413_tmr.h:515
tmr_type::esp
__IO uint32_t esp
Definition: at32f413_tmr.h:498
tmr_type::ptos
__IO uint32_t ptos
Definition: at32f413_tmr.h:470
tmr_type::c1cios
__IO uint32_t c1cios
Definition: at32f413_tmr.h:473
tmr_type::aoen
__IO uint32_t aoen
Definition: at32f413_tmr.h:793
tmr_type::c2rf
__IO uint32_t c2rf
Definition: at32f413_tmr.h:548


AT32F413 Firmwary Library: at32f413_usart.c Source File

  • libraries
  • drivers
  • src
at32f413_usart.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_conf.h"
29
39#ifdef USART_MODULE_ENABLED
40
52void usart_reset(usart_type* usart_x)
53{
54 if(usart_x == USART1)
55 {
56 crm_periph_reset(CRM_USART1_PERIPH_RESET, TRUE);
57 crm_periph_reset(CRM_USART1_PERIPH_RESET, FALSE);
58 }
59 else if(usart_x == USART2)
60 {
61 crm_periph_reset(CRM_USART2_PERIPH_RESET, TRUE);
62 crm_periph_reset(CRM_USART2_PERIPH_RESET, FALSE);
63 }
64 else if(usart_x == USART3)
65 {
66 crm_periph_reset(CRM_USART3_PERIPH_RESET, TRUE);
67 crm_periph_reset(CRM_USART3_PERIPH_RESET, FALSE);
68 }
69 else if(usart_x == UART4)
70 {
71 crm_periph_reset(CRM_UART4_PERIPH_RESET, TRUE);
72 crm_periph_reset(CRM_UART4_PERIPH_RESET, FALSE);
73 }
74 else if(usart_x == UART5)
75 {
76 crm_periph_reset(CRM_UART5_PERIPH_RESET, TRUE);
77 crm_periph_reset(CRM_UART5_PERIPH_RESET, FALSE);
78 }
79}
80
99void usart_init(usart_type* usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
100{
101 crm_clocks_freq_type clocks_freq;
102 uint32_t apb_clock, temp_val;
103 crm_clocks_freq_get(&clocks_freq);
104 if(usart_x == USART1)
105 {
106 apb_clock = clocks_freq.apb2_freq;
107 }
108 else
109 {
110 apb_clock = clocks_freq.apb1_freq;
111 }
112 temp_val = (apb_clock * 10 / baud_rate);
113 if((temp_val % 10) < 5)
114 {
115 temp_val = (temp_val / 10);
116 }
117 else
118 {
119 temp_val = (temp_val / 10) + 1;
120 }
121 usart_x->baudr_bit.div = temp_val;
122 usart_x->ctrl1_bit.dbn = data_bit;
123 usart_x->ctrl2_bit.stopbn = stop_bit;
124}
125
138void usart_parity_selection_config(usart_type* usart_x, usart_parity_selection_type parity)
139{
140 if(parity == USART_PARITY_NONE)
141 {
142 usart_x->ctrl1_bit.psel = FALSE;
143 usart_x->ctrl1_bit.pen = FALSE;
144 }
145 else if(parity == USART_PARITY_EVEN)
146 {
147 usart_x->ctrl1_bit.psel = FALSE;
148 usart_x->ctrl1_bit.pen = TRUE;
149 }
150 else if(parity == USART_PARITY_ODD)
151 {
152 usart_x->ctrl1_bit.psel = TRUE;
153 usart_x->ctrl1_bit.pen = TRUE;
154 }
155}
156
166void usart_enable(usart_type* usart_x, confirm_state new_state)
167{
168 usart_x->ctrl1_bit.uen = new_state;
169}
170
179void usart_transmitter_enable(usart_type* usart_x, confirm_state new_state)
180{
181 usart_x->ctrl1_bit.ten = new_state;
182}
183
192void usart_receiver_enable(usart_type* usart_x, confirm_state new_state)
193{
194 usart_x->ctrl1_bit.ren = new_state;
195}
196
217void usart_clock_config(usart_type* usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
218{
219 usart_x->ctrl2_bit.clkpol = clk_pol;
220 usart_x->ctrl2_bit.clkpha = clk_pha;
221 usart_x->ctrl2_bit.lbcp = clk_lb;
222}
223
233void usart_clock_enable(usart_type* usart_x, confirm_state new_state)
234{
235 usart_x->ctrl2_bit.clken = new_state;
236}
237
257void usart_interrupt_enable(usart_type* usart_x, uint32_t usart_int, confirm_state new_state)
258{
259 if(new_state == TRUE)
260 PERIPH_REG((uint32_t)usart_x, usart_int) |= PERIPH_REG_BIT(usart_int);
261 else
262 PERIPH_REG((uint32_t)usart_x, usart_int) &= ~PERIPH_REG_BIT(usart_int);
263}
264
274void usart_dma_transmitter_enable(usart_type* usart_x, confirm_state new_state)
275{
276 usart_x->ctrl3_bit.dmaten = new_state;
277}
278
288void usart_dma_receiver_enable(usart_type* usart_x, confirm_state new_state)
289{
290 usart_x->ctrl3_bit.dmaren = new_state;
291}
292
301void usart_wakeup_id_set(usart_type* usart_x, uint8_t usart_id)
302{
303 usart_x->ctrl2_bit.id = usart_id;
304}
305
317void usart_wakeup_mode_set(usart_type* usart_x, usart_wakeup_mode_type wakeup_mode)
318{
319 usart_x->ctrl1_bit.wum = wakeup_mode;
320}
321
331void usart_receiver_mute_enable(usart_type* usart_x, confirm_state new_state)
332{
333 usart_x->ctrl1_bit.rm = new_state;
334}
335
347void usart_break_bit_num_set(usart_type* usart_x, usart_break_bit_num_type break_bit)
348{
349 usart_x->ctrl2_bit.bfbn = break_bit;
350}
351
361void usart_lin_mode_enable(usart_type* usart_x, confirm_state new_state)
362{
363 usart_x->ctrl2_bit.linen = new_state;
364}
365
374void usart_data_transmit(usart_type* usart_x, uint16_t data)
375{
376 usart_x->dt = (data & 0x01FF);
377}
378
386uint16_t usart_data_receive(usart_type* usart_x)
387{
388 return (uint16_t)(usart_x->dt);
389}
390
398void usart_break_send(usart_type* usart_x)
399{
400 usart_x->ctrl1_bit.sbf = TRUE;
401}
402
412void usart_smartcard_guard_time_set(usart_type* usart_x, uint8_t guard_time_val)
413{
414 usart_x->gdiv_bit.scgt = guard_time_val;
415}
416
426void usart_irda_smartcard_division_set(usart_type* usart_x, uint8_t div_val)
427{
428 usart_x->gdiv_bit.isdiv = div_val;
429}
430
441void usart_smartcard_mode_enable(usart_type* usart_x, confirm_state new_state)
442{
443 usart_x->ctrl3_bit.scmen = new_state;
444}
445
456void usart_smartcard_nack_set(usart_type* usart_x, confirm_state new_state)
457{
458 usart_x->ctrl3_bit.scnacken = new_state;
459}
460
470void usart_single_line_halfduplex_select(usart_type* usart_x, confirm_state new_state)
471{
472 usart_x->ctrl3_bit.slben = new_state;
473}
474
484void usart_irda_mode_enable(usart_type* usart_x, confirm_state new_state)
485{
486 usart_x->ctrl3_bit.irdaen = new_state;
487}
488
498void usart_irda_low_power_enable(usart_type* usart_x, confirm_state new_state)
499{
500 usart_x->ctrl3_bit.irdalp = new_state;
501}
502
516void usart_hardware_flow_control_set(usart_type* usart_x,usart_hardware_flow_control_type flow_state)
517{
518 if(flow_state == USART_HARDWARE_FLOW_NONE)
519 {
520 usart_x->ctrl3_bit.rtsen = FALSE;
521 usart_x->ctrl3_bit.ctsen = FALSE;
522 }
523 else if(flow_state == USART_HARDWARE_FLOW_RTS)
524 {
525 usart_x->ctrl3_bit.rtsen = TRUE;
526 usart_x->ctrl3_bit.ctsen = FALSE;
527 }
528 else if(flow_state == USART_HARDWARE_FLOW_CTS)
529 {
530 usart_x->ctrl3_bit.rtsen = FALSE;
531 usart_x->ctrl3_bit.ctsen = TRUE;
532 }
533 else if(flow_state == USART_HARDWARE_FLOW_RTS_CTS)
534 {
535 usart_x->ctrl3_bit.rtsen = TRUE;
536 usart_x->ctrl3_bit.ctsen = TRUE;
537 }
538}
539
559 flag_status usart_flag_get(usart_type* usart_x, uint32_t flag)
560{
561 if(usart_x->sts & flag)
562 {
563 return SET;
564 }
565 else
566 {
567 return RESET;
568 }
569}
570
592void usart_flag_clear(usart_type* usart_x, uint32_t flag)
593{
594 usart_x->sts = ~flag;
595}
596
601#endif
602
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_UART4_PERIPH_RESET
@ CRM_UART4_PERIPH_RESET
Definition: at32f413_crm.h:178
CRM_USART1_PERIPH_RESET
@ CRM_USART1_PERIPH_RESET
Definition: at32f413_crm.h:164
CRM_USART2_PERIPH_RESET
@ CRM_USART2_PERIPH_RESET
Definition: at32f413_crm.h:176
CRM_UART5_PERIPH_RESET
@ CRM_UART5_PERIPH_RESET
Definition: at32f413_crm.h:179
CRM_USART3_PERIPH_RESET
@ CRM_USART3_PERIPH_RESET
Definition: at32f413_crm.h:177
PERIPH_REG
#define PERIPH_REG(periph_base, value)
Definition: at32f413.h:280
PERIPH_REG_BIT
#define PERIPH_REG_BIT(value)
Definition: at32f413.h:281
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
usart_break_bit_num_type
usart_break_bit_num_type
usart break frame bit num type
Definition: at32f413_usart.h:121
usart_clock_polarity_type
usart_clock_polarity_type
usart polarity of the clock type
Definition: at32f413_usart.h:139
usart_hardware_flow_control_type
usart_hardware_flow_control_type
usart hardware flow control type
Definition: at32f413_usart.h:168
usart_stop_bit_num_type
usart_stop_bit_num_type
usart stop bit num type
Definition: at32f413_usart.h:157
usart_data_bit_num_type
usart_data_bit_num_type
usart data bit num type
Definition: at32f413_usart.h:112
usart_parity_selection_type
usart_parity_selection_type
usart parity selection type
Definition: at32f413_usart.h:93
usart_lbcp_type
usart_lbcp_type
usart last bit clock pulse type
Definition: at32f413_usart.h:148
usart_wakeup_mode_type
usart_wakeup_mode_type
usart wakeup mode type
Definition: at32f413_usart.h:103
usart_clock_phase_type
usart_clock_phase_type
usart phase of the clock type
Definition: at32f413_usart.h:130
USART_HARDWARE_FLOW_CTS
@ USART_HARDWARE_FLOW_CTS
Definition: at32f413_usart.h:171
USART_HARDWARE_FLOW_RTS
@ USART_HARDWARE_FLOW_RTS
Definition: at32f413_usart.h:170
USART_HARDWARE_FLOW_NONE
@ USART_HARDWARE_FLOW_NONE
Definition: at32f413_usart.h:169
USART_HARDWARE_FLOW_RTS_CTS
@ USART_HARDWARE_FLOW_RTS_CTS
Definition: at32f413_usart.h:172
USART_PARITY_ODD
@ USART_PARITY_ODD
Definition: at32f413_usart.h:96
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f413_usart.h:95
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:94
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f413_usart.c:233
usart_smartcard_nack_set
void usart_smartcard_nack_set(usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode.
Definition: at32f413_usart.c:456
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f413_usart.c:217
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:138
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_wakeup_id_set
void usart_wakeup_id_set(usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart.
Definition: at32f413_usart.c:301
usart_reset
void usart_reset(usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values.
Definition: at32f413_usart.c:52
usart_lin_mode_enable
void usart_lin_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode.
Definition: at32f413_usart.c:361
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f413_usart.c:288
usart_irda_low_power_enable
void usart_irda_low_power_enable(usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power.
Definition: at32f413_usart.c:498
usart_break_send
void usart_break_send(usart_type *usart_x)
transmit break characters.
Definition: at32f413_usart.c:398
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f413_usart.c:426
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_smartcard_guard_time_set
void usart_smartcard_guard_time_set(usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time.
Definition: at32f413_usart.c:412
usart_flag_clear
void usart_flag_clear(usart_type *usart_x, uint32_t flag)
clear the usart's pending flags.
Definition: at32f413_usart.c:592
usart_wakeup_mode_set
void usart_wakeup_mode_set(usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication.
Definition: at32f413_usart.c:317
usart_irda_mode_enable
void usart_irda_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface.
Definition: at32f413_usart.c:484
usart_break_bit_num_set
void usart_break_bit_num_set(usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num.
Definition: at32f413_usart.c:347
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f413_usart.c:516
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
usart_single_line_halfduplex_select
void usart_single_line_halfduplex_select(usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication.
Definition: at32f413_usart.c:470
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f413_usart.c:274
usart_smartcard_mode_enable
void usart_smartcard_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode.
Definition: at32f413_usart.c:441
usart_receiver_mute_enable
void usart_receiver_mute_enable(usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication.
Definition: at32f413_usart.c:331
USART3
#define USART3
Definition: at32f413_usart.h:321
UART4
#define UART4
Definition: at32f413_usart.h:322
UART5
#define UART5
Definition: at32f413_usart.h:323
USART1
#define USART1
Definition: at32f413_usart.h:319
USART2
#define USART2
Definition: at32f413_usart.h:320
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:475
crm_clocks_freq_type::apb2_freq
uint32_t apb2_freq
Definition: at32f413_crm.h:474
usart_type
type define usart register all
Definition: at32f413_usart.h:179
usart_type::scmen
__IO uint32_t scmen
Definition: at32f413_usart.h:290
usart_type::scgt
__IO uint32_t scgt
Definition: at32f413_usart.h:309
usart_type::clken
__IO uint32_t clken
Definition: at32f413_usart.h:270
usart_type::ctrl2_bit
struct usart_type::@718::@728 ctrl2_bit
usart_type::linen
__IO uint32_t linen
Definition: at32f413_usart.h:272
usart_type::psel
__IO uint32_t psel
Definition: at32f413_usart.h:245
usart_type::sbf
__IO uint32_t sbf
Definition: at32f413_usart.h:236
usart_type::slben
__IO uint32_t slben
Definition: at32f413_usart.h:288
usart_type::ctrl3_bit
struct usart_type::@720::@729 ctrl3_bit
usart_type::isdiv
__IO uint32_t isdiv
Definition: at32f413_usart.h:308
usart_type::id
__IO uint32_t id
Definition: at32f413_usart.h:262
usart_type::wum
__IO uint32_t wum
Definition: at32f413_usart.h:247
usart_type::pen
__IO uint32_t pen
Definition: at32f413_usart.h:246
usart_type::scnacken
__IO uint32_t scnacken
Definition: at32f413_usart.h:289
usart_type::ctsen
__IO uint32_t ctsen
Definition: at32f413_usart.h:294
usart_type::uen
__IO uint32_t uen
Definition: at32f413_usart.h:249
usart_type::dbn
__IO uint32_t dbn
Definition: at32f413_usart.h:248
usart_type::rm
__IO uint32_t rm
Definition: at32f413_usart.h:237
usart_type::clkpha
__IO uint32_t clkpha
Definition: at32f413_usart.h:268
usart_type::gdiv_bit
struct usart_type::@722::@730 gdiv_bit
usart_type::clkpol
__IO uint32_t clkpol
Definition: at32f413_usart.h:269
usart_type::rtsen
__IO uint32_t rtsen
Definition: at32f413_usart.h:293
usart_type::dmaren
__IO uint32_t dmaren
Definition: at32f413_usart.h:291
usart_type::lbcp
__IO uint32_t lbcp
Definition: at32f413_usart.h:267
usart_type::dmaten
__IO uint32_t dmaten
Definition: at32f413_usart.h:292
usart_type::sts
__IO uint32_t sts
Definition: at32f413_usart.h:185
usart_type::baudr_bit
struct usart_type::@714::@726 baudr_bit
usart_type::ren
__IO uint32_t ren
Definition: at32f413_usart.h:238
usart_type::irdaen
__IO uint32_t irdaen
Definition: at32f413_usart.h:286
usart_type::ten
__IO uint32_t ten
Definition: at32f413_usart.h:239
usart_type::div
__IO uint32_t div
Definition: at32f413_usart.h:223
usart_type::stopbn
__IO uint32_t stopbn
Definition: at32f413_usart.h:271
usart_type::irdalp
__IO uint32_t irdalp
Definition: at32f413_usart.h:287
usart_type::ctrl1_bit
struct usart_type::@716::@727 ctrl1_bit
usart_type::dt
__IO uint32_t dt
Definition: at32f413_usart.h:207
usart_type::bfbn
__IO uint32_t bfbn
Definition: at32f413_usart.h:264
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_usart.h Source File

  • libraries
  • drivers
  • inc
at32f413_usart.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_USART_H
29#define __AT32F413_USART_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define USART_PERR_FLAG ((uint32_t)0x00000001)
53#define USART_FERR_FLAG ((uint32_t)0x00000002)
54#define USART_NERR_FLAG ((uint32_t)0x00000004)
55#define USART_ROERR_FLAG ((uint32_t)0x00000008)
56#define USART_IDLEF_FLAG ((uint32_t)0x00000010)
57#define USART_RDBF_FLAG ((uint32_t)0x00000020)
58#define USART_TDC_FLAG ((uint32_t)0x00000040)
59#define USART_TDBE_FLAG ((uint32_t)0x00000080)
60#define USART_BFF_FLAG ((uint32_t)0x00000100)
61#define USART_CTSCF_FLAG ((uint32_t)0x00000200)
72#define USART_IDLE_INT MAKE_VALUE(0x0C,0x04)
73#define USART_RDBF_INT MAKE_VALUE(0x0C,0x05)
74#define USART_TDC_INT MAKE_VALUE(0x0C,0x06)
75#define USART_TDBE_INT MAKE_VALUE(0x0C,0x07)
76#define USART_PERR_INT MAKE_VALUE(0x0C,0x08)
77#define USART_BF_INT MAKE_VALUE(0x10,0x06)
78#define USART_ERR_INT MAKE_VALUE(0x14,0x00)
79#define USART_CTSCF_INT MAKE_VALUE(0x14,0x0A)
92typedef enum
93{
94 USART_PARITY_NONE = 0x00,
95 USART_PARITY_EVEN = 0x01,
96 USART_PARITY_ODD = 0x02
97} usart_parity_selection_type;
98
102typedef enum
103{
104 USART_WAKEUP_BY_IDLE_FRAME = 0x00,
105 USART_WAKEUP_BY_MATCHING_ID = 0x01
106} usart_wakeup_mode_type;
107
111typedef enum
112{
113 USART_DATA_8BITS = 0x00,
114 USART_DATA_9BITS = 0x01
115} usart_data_bit_num_type;
116
120typedef enum
121{
122 USART_BREAK_10BITS = 0x00,
123 USART_BREAK_11BITS = 0x01
124} usart_break_bit_num_type;
125
129typedef enum
130{
131 USART_CLOCK_PHASE_1EDGE = 0x00,
132 USART_CLOCK_PHASE_2EDGE = 0x01
133} usart_clock_phase_type;
134
138typedef enum
139{
140 USART_CLOCK_POLARITY_LOW = 0x00,
141 USART_CLOCK_POLARITY_HIGH = 0x01
142} usart_clock_polarity_type;
143
147typedef enum
148{
149 USART_CLOCK_LAST_BIT_NONE = 0x00,
150 USART_CLOCK_LAST_BIT_OUTPUT = 0x01
151} usart_lbcp_type;
152
156typedef enum
157{
158 USART_STOP_1_BIT = 0x00,
159 USART_STOP_0_5_BIT = 0x01,
160 USART_STOP_2_BIT = 0x02,
161 USART_STOP_1_5_BIT = 0x03
162} usart_stop_bit_num_type;
163
167typedef enum
168{
169 USART_HARDWARE_FLOW_NONE = 0x00,
170 USART_HARDWARE_FLOW_RTS = 0x01,
171 USART_HARDWARE_FLOW_CTS = 0x02,
172 USART_HARDWARE_FLOW_RTS_CTS = 0x03
173} usart_hardware_flow_control_type;
174
178typedef struct
179{
183 union
184 {
185 __IO uint32_t sts;
186 struct
187 {
188 __IO uint32_t perr : 1; /* [0] */
189 __IO uint32_t ferr : 1; /* [1] */
190 __IO uint32_t nerr : 1; /* [2] */
191 __IO uint32_t roerr : 1; /* [3] */
192 __IO uint32_t idlef : 1; /* [4] */
193 __IO uint32_t rdbf : 1; /* [5] */
194 __IO uint32_t tdc : 1; /* [6] */
195 __IO uint32_t tdbe : 1; /* [7] */
196 __IO uint32_t bff : 1; /* [8] */
197 __IO uint32_t ctscf : 1; /* [9] */
198 __IO uint32_t reserved1 : 22;/* [31:10] */
199 } sts_bit;
200 };
201
205 union
206 {
207 __IO uint32_t dt;
208 struct
209 {
210 __IO uint32_t dt : 9; /* [8:0] */
211 __IO uint32_t reserved1 : 23;/* [31:9] */
212 } dt_bit;
213 };
214
218 union
219 {
220 __IO uint32_t baudr;
221 struct
222 {
223 __IO uint32_t div : 16;/* [15:0] */
224 __IO uint32_t reserved1 : 16;/* [31:16] */
225 } baudr_bit;
226 };
227
231 union
232 {
233 __IO uint32_t ctrl1;
234 struct
235 {
236 __IO uint32_t sbf : 1; /* [0] */
237 __IO uint32_t rm : 1; /* [1] */
238 __IO uint32_t ren : 1; /* [2] */
239 __IO uint32_t ten : 1; /* [3] */
240 __IO uint32_t idleien : 1; /* [4] */
241 __IO uint32_t rdbfien : 1; /* [5] */
242 __IO uint32_t tdcien : 1; /* [6] */
243 __IO uint32_t tdbeien : 1; /* [7] */
244 __IO uint32_t perrien : 1; /* [8] */
245 __IO uint32_t psel : 1; /* [9] */
246 __IO uint32_t pen : 1; /* [10] */
247 __IO uint32_t wum : 1; /* [11] */
248 __IO uint32_t dbn : 1; /* [12] */
249 __IO uint32_t uen : 1; /* [13] */
250 __IO uint32_t reserved1 : 18;/* [31:14] */
251 } ctrl1_bit;
252 };
253
257 union
258 {
259 __IO uint32_t ctrl2;
260 struct
261 {
262 __IO uint32_t id : 4; /* [3:0] */
263 __IO uint32_t reserved1 : 1; /* [4] */
264 __IO uint32_t bfbn : 1; /* [5] */
265 __IO uint32_t bfien : 1; /* [6] */
266 __IO uint32_t reserved2 : 1; /* [7] */
267 __IO uint32_t lbcp : 1; /* [8] */
268 __IO uint32_t clkpha : 1; /* [9] */
269 __IO uint32_t clkpol : 1; /* [10] */
270 __IO uint32_t clken : 1; /* [11] */
271 __IO uint32_t stopbn : 2; /* [13:12] */
272 __IO uint32_t linen : 1; /* [14] */
273 __IO uint32_t reserved3 : 17;/* [31:15] */
274 } ctrl2_bit;
275 };
276
280 union
281 {
282 __IO uint32_t ctrl3;
283 struct
284 {
285 __IO uint32_t errien : 1; /* [0] */
286 __IO uint32_t irdaen : 1; /* [1] */
287 __IO uint32_t irdalp : 1; /* [2] */
288 __IO uint32_t slben : 1; /* [3] */
289 __IO uint32_t scnacken : 1; /* [4] */
290 __IO uint32_t scmen : 1; /* [5] */
291 __IO uint32_t dmaren : 1; /* [6] */
292 __IO uint32_t dmaten : 1; /* [7] */
293 __IO uint32_t rtsen : 1; /* [8] */
294 __IO uint32_t ctsen : 1; /* [9] */
295 __IO uint32_t ctscfien : 1; /* [10] */
296 __IO uint32_t reserved1 : 21;/* [31:11] */
297 } ctrl3_bit;
298 };
299
303 union
304 {
305 __IO uint32_t gdiv;
306 struct
307 {
308 __IO uint32_t isdiv : 8; /* [7:0] */
309 __IO uint32_t scgt : 8; /* [15:8] */
310 __IO uint32_t reserved1 : 16;/* [31:16] */
311 } gdiv_bit;
312 };
313} usart_type;
314
319#define USART1 ((usart_type *) USART1_BASE)
320#define USART2 ((usart_type *) USART2_BASE)
321#define USART3 ((usart_type *) USART3_BASE)
322#define UART4 ((usart_type *) UART4_BASE)
323#define UART5 ((usart_type *) UART5_BASE)
324
329void usart_reset(usart_type* usart_x);
330void usart_init(usart_type* usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit);
331void usart_parity_selection_config(usart_type* usart_x, usart_parity_selection_type parity);
332void usart_enable(usart_type* usart_x, confirm_state new_state);
333void usart_transmitter_enable(usart_type* usart_x, confirm_state new_state);
334void usart_receiver_enable(usart_type* usart_x, confirm_state new_state);
335void usart_clock_config(usart_type* usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb);
336void usart_clock_enable(usart_type* usart_x, confirm_state new_state);
337void usart_interrupt_enable(usart_type* usart_x, uint32_t usart_int, confirm_state new_state);
338void usart_dma_transmitter_enable(usart_type* usart_x, confirm_state new_state);
339void usart_dma_receiver_enable(usart_type* usart_x, confirm_state new_state);
340void usart_wakeup_id_set(usart_type* usart_x, uint8_t usart_id);
341void usart_wakeup_mode_set(usart_type* usart_x, usart_wakeup_mode_type wakeup_mode);
342void usart_receiver_mute_enable(usart_type* usart_x, confirm_state new_state);
343void usart_break_bit_num_set(usart_type* usart_x, usart_break_bit_num_type break_bit);
344void usart_lin_mode_enable(usart_type* usart_x, confirm_state new_state);
345void usart_data_transmit(usart_type* usart_x, uint16_t data);
346uint16_t usart_data_receive(usart_type* usart_x);
347void usart_break_send(usart_type* usart_x);
348void usart_smartcard_guard_time_set(usart_type* usart_x, uint8_t guard_time_val);
349void usart_irda_smartcard_division_set(usart_type* usart_x, uint8_t div_val);
350void usart_smartcard_mode_enable(usart_type* usart_x, confirm_state new_state);
351void usart_smartcard_nack_set(usart_type* usart_x, confirm_state new_state);
352void usart_single_line_halfduplex_select(usart_type* usart_x, confirm_state new_state);
353void usart_irda_mode_enable(usart_type* usart_x, confirm_state new_state);
354void usart_irda_low_power_enable(usart_type* usart_x, confirm_state new_state);
355void usart_hardware_flow_control_set(usart_type* usart_x,usart_hardware_flow_control_type flow_state);
356 flag_status usart_flag_get(usart_type* usart_x, uint32_t flag);
357void usart_flag_clear(usart_type* usart_x, uint32_t flag);
358
371#ifdef __cplusplus
372}
373#endif
374
375#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f413_usart.c:233
usart_smartcard_nack_set
void usart_smartcard_nack_set(usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode.
Definition: at32f413_usart.c:456
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f413_usart.c:217
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:138
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_wakeup_id_set
void usart_wakeup_id_set(usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart.
Definition: at32f413_usart.c:301
usart_reset
void usart_reset(usart_type *usart_x)
deinitialize the usart peripheral registers to their default reset values.
Definition: at32f413_usart.c:52
usart_lin_mode_enable
void usart_lin_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart lin mode.
Definition: at32f413_usart.c:361
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f413_usart.c:288
usart_irda_low_power_enable
void usart_irda_low_power_enable(usart_type *usart_x, confirm_state new_state)
configure the usart's irda low power.
Definition: at32f413_usart.c:498
usart_break_send
void usart_break_send(usart_type *usart_x)
transmit break characters.
Definition: at32f413_usart.c:398
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f413_usart.c:426
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_smartcard_guard_time_set
void usart_smartcard_guard_time_set(usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time.
Definition: at32f413_usart.c:412
usart_flag_clear
void usart_flag_clear(usart_type *usart_x, uint32_t flag)
clear the usart's pending flags.
Definition: at32f413_usart.c:592
usart_wakeup_mode_set
void usart_wakeup_mode_set(usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication.
Definition: at32f413_usart.c:317
usart_irda_mode_enable
void usart_irda_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface.
Definition: at32f413_usart.c:484
usart_break_bit_num_set
void usart_break_bit_num_set(usart_type *usart_x, usart_break_bit_num_type break_bit)
set the usart break frame bit num.
Definition: at32f413_usart.c:347
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f413_usart.c:516
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
usart_single_line_halfduplex_select
void usart_single_line_halfduplex_select(usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication.
Definition: at32f413_usart.c:470
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f413_usart.c:274
usart_smartcard_mode_enable
void usart_smartcard_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode.
Definition: at32f413_usart.c:441
usart_receiver_mute_enable
void usart_receiver_mute_enable(usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication.
Definition: at32f413_usart.c:331
usart_break_bit_num_type
usart_break_bit_num_type
usart break frame bit num type
Definition: at32f413_usart.h:121
usart_clock_polarity_type
usart_clock_polarity_type
usart polarity of the clock type
Definition: at32f413_usart.h:139
usart_hardware_flow_control_type
usart_hardware_flow_control_type
usart hardware flow control type
Definition: at32f413_usart.h:168
usart_stop_bit_num_type
usart_stop_bit_num_type
usart stop bit num type
Definition: at32f413_usart.h:157
usart_data_bit_num_type
usart_data_bit_num_type
usart data bit num type
Definition: at32f413_usart.h:112
usart_parity_selection_type
usart_parity_selection_type
usart parity selection type
Definition: at32f413_usart.h:93
usart_lbcp_type
usart_lbcp_type
usart last bit clock pulse type
Definition: at32f413_usart.h:148
usart_wakeup_mode_type
usart_wakeup_mode_type
usart wakeup mode type
Definition: at32f413_usart.h:103
usart_clock_phase_type
usart_clock_phase_type
usart phase of the clock type
Definition: at32f413_usart.h:130
USART_BREAK_11BITS
@ USART_BREAK_11BITS
Definition: at32f413_usart.h:123
USART_BREAK_10BITS
@ USART_BREAK_10BITS
Definition: at32f413_usart.h:122
USART_CLOCK_POLARITY_HIGH
@ USART_CLOCK_POLARITY_HIGH
Definition: at32f413_usart.h:141
USART_CLOCK_POLARITY_LOW
@ USART_CLOCK_POLARITY_LOW
Definition: at32f413_usart.h:140
USART_HARDWARE_FLOW_CTS
@ USART_HARDWARE_FLOW_CTS
Definition: at32f413_usart.h:171
USART_HARDWARE_FLOW_RTS
@ USART_HARDWARE_FLOW_RTS
Definition: at32f413_usart.h:170
USART_HARDWARE_FLOW_NONE
@ USART_HARDWARE_FLOW_NONE
Definition: at32f413_usart.h:169
USART_HARDWARE_FLOW_RTS_CTS
@ USART_HARDWARE_FLOW_RTS_CTS
Definition: at32f413_usart.h:172
USART_STOP_1_5_BIT
@ USART_STOP_1_5_BIT
Definition: at32f413_usart.h:161
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_STOP_0_5_BIT
@ USART_STOP_0_5_BIT
Definition: at32f413_usart.h:159
USART_STOP_2_BIT
@ USART_STOP_2_BIT
Definition: at32f413_usart.h:160
USART_DATA_9BITS
@ USART_DATA_9BITS
Definition: at32f413_usart.h:114
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_PARITY_ODD
@ USART_PARITY_ODD
Definition: at32f413_usart.h:96
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f413_usart.h:95
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:94
USART_CLOCK_LAST_BIT_OUTPUT
@ USART_CLOCK_LAST_BIT_OUTPUT
Definition: at32f413_usart.h:150
USART_CLOCK_LAST_BIT_NONE
@ USART_CLOCK_LAST_BIT_NONE
Definition: at32f413_usart.h:149
USART_WAKEUP_BY_MATCHING_ID
@ USART_WAKEUP_BY_MATCHING_ID
Definition: at32f413_usart.h:105
USART_WAKEUP_BY_IDLE_FRAME
@ USART_WAKEUP_BY_IDLE_FRAME
Definition: at32f413_usart.h:104
USART_CLOCK_PHASE_1EDGE
@ USART_CLOCK_PHASE_1EDGE
Definition: at32f413_usart.h:131
USART_CLOCK_PHASE_2EDGE
@ USART_CLOCK_PHASE_2EDGE
Definition: at32f413_usart.h:132
usart_type
type define usart register all
Definition: at32f413_usart.h:179
usart_type::scmen
__IO uint32_t scmen
Definition: at32f413_usart.h:290
usart_type::ctrl2
__IO uint32_t ctrl2
Definition: at32f413_usart.h:259
usart_type::tdcien
__IO uint32_t tdcien
Definition: at32f413_usart.h:242
usart_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_usart.h:198
usart_type::ctrl3
__IO uint32_t ctrl3
Definition: at32f413_usart.h:282
usart_type::scgt
__IO uint32_t scgt
Definition: at32f413_usart.h:309
usart_type::clken
__IO uint32_t clken
Definition: at32f413_usart.h:270
usart_type::linen
__IO uint32_t linen
Definition: at32f413_usart.h:272
usart_type::rdbf
__IO uint32_t rdbf
Definition: at32f413_usart.h:193
usart_type::psel
__IO uint32_t psel
Definition: at32f413_usart.h:245
usart_type::rdbfien
__IO uint32_t rdbfien
Definition: at32f413_usart.h:241
usart_type::sbf
__IO uint32_t sbf
Definition: at32f413_usart.h:236
usart_type::slben
__IO uint32_t slben
Definition: at32f413_usart.h:288
usart_type::tdbeien
__IO uint32_t tdbeien
Definition: at32f413_usart.h:243
usart_type::isdiv
__IO uint32_t isdiv
Definition: at32f413_usart.h:308
usart_type::baudr
__IO uint32_t baudr
Definition: at32f413_usart.h:220
usart_type::ferr
__IO uint32_t ferr
Definition: at32f413_usart.h:189
usart_type::id
__IO uint32_t id
Definition: at32f413_usart.h:262
usart_type::wum
__IO uint32_t wum
Definition: at32f413_usart.h:247
usart_type::pen
__IO uint32_t pen
Definition: at32f413_usart.h:246
usart_type::scnacken
__IO uint32_t scnacken
Definition: at32f413_usart.h:289
usart_type::roerr
__IO uint32_t roerr
Definition: at32f413_usart.h:191
usart_type::ctscfien
__IO uint32_t ctscfien
Definition: at32f413_usart.h:295
usart_type::gdiv
__IO uint32_t gdiv
Definition: at32f413_usart.h:305
usart_type::ctrl1
__IO uint32_t ctrl1
Definition: at32f413_usart.h:233
usart_type::ctsen
__IO uint32_t ctsen
Definition: at32f413_usart.h:294
usart_type::uen
__IO uint32_t uen
Definition: at32f413_usart.h:249
usart_type::idlef
__IO uint32_t idlef
Definition: at32f413_usart.h:192
usart_type::dbn
__IO uint32_t dbn
Definition: at32f413_usart.h:248
usart_type::rm
__IO uint32_t rm
Definition: at32f413_usart.h:237
usart_type::tdbe
__IO uint32_t tdbe
Definition: at32f413_usart.h:195
usart_type::clkpha
__IO uint32_t clkpha
Definition: at32f413_usart.h:268
usart_type::clkpol
__IO uint32_t clkpol
Definition: at32f413_usart.h:269
usart_type::perr
__IO uint32_t perr
Definition: at32f413_usart.h:188
usart_type::rtsen
__IO uint32_t rtsen
Definition: at32f413_usart.h:293
usart_type::reserved3
__IO uint32_t reserved3
Definition: at32f413_usart.h:273
usart_type::dmaren
__IO uint32_t dmaren
Definition: at32f413_usart.h:291
usart_type::tdc
__IO uint32_t tdc
Definition: at32f413_usart.h:194
usart_type::lbcp
__IO uint32_t lbcp
Definition: at32f413_usart.h:267
usart_type::dmaten
__IO uint32_t dmaten
Definition: at32f413_usart.h:292
usart_type::sts
__IO uint32_t sts
Definition: at32f413_usart.h:185
usart_type::ren
__IO uint32_t ren
Definition: at32f413_usart.h:238
usart_type::errien
__IO uint32_t errien
Definition: at32f413_usart.h:285
usart_type::bff
__IO uint32_t bff
Definition: at32f413_usart.h:196
usart_type::irdaen
__IO uint32_t irdaen
Definition: at32f413_usart.h:286
usart_type::ten
__IO uint32_t ten
Definition: at32f413_usart.h:239
usart_type::div
__IO uint32_t div
Definition: at32f413_usart.h:223
usart_type::ctscf
__IO uint32_t ctscf
Definition: at32f413_usart.h:197
usart_type::nerr
__IO uint32_t nerr
Definition: at32f413_usart.h:190
usart_type::stopbn
__IO uint32_t stopbn
Definition: at32f413_usart.h:271
usart_type::irdalp
__IO uint32_t irdalp
Definition: at32f413_usart.h:287
usart_type::dt
__IO uint32_t dt
Definition: at32f413_usart.h:207
usart_type::perrien
__IO uint32_t perrien
Definition: at32f413_usart.h:244
usart_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_usart.h:266
usart_type::bfien
__IO uint32_t bfien
Definition: at32f413_usart.h:265
usart_type::bfbn
__IO uint32_t bfbn
Definition: at32f413_usart.h:264
usart_type::idleien
__IO uint32_t idleien
Definition: at32f413_usart.h:240


AT32F413 Firmwary Library: at32f413_usb.c Source File

  • libraries
  • drivers
  • src
at32f413_usb.c
Go to the documentation of this file.
1
36#include "at32f413_conf.h"
37
38
39#ifdef USB_MODULE_ENABLED
40
48#define USB_ENDP_DESC_TABLE_OFFSET 0x40
49uint32_t g_usb_packet_address = USB_PACKET_BUFFER_ADDRESS;
50static uint16_t g_usb_offset_addr = USB_ENDP_DESC_TABLE_OFFSET;
51
58void usb_dev_init(usbd_type *usbx)
59{
60 /* clear usb core reset */
61 usbx->ctrl_bit.csrst = 0;
62
63 /* clear usb interrupt status */
64 usbx->intsts = 0;
65
66 /* set usb packet buffer descirption table address */
67 usbx->buftbl = USB_BUFFER_TABLE_ADDRESS;
68
69 /* enable usb core and set device address to 0 */
70 usbx->devaddr = 0x80;
71
72 usb_interrupt_enable(usbx, USB_SOF_INT | USB_RST_INT | USB_SP_INT | USB_WK_INT | USB_TC_INT, TRUE);
73}
74
81void usb_connect(usbd_type *usbx)
82{
83 /* enable usb phy */
84 usbx->ctrl_bit.disusb = 0;
85}
86
93void usb_disconnect(usbd_type *usbx)
94{
95 /* disable usb phy */
96 usbx->ctrl_bit.disusb = TRUE;
97}
98
99
116void usb_usbbufs_enable(usbd_type *usbx, confirm_state state)
117{
118 if(state == TRUE)
119 {
120 /* enable usbbufs */
121 g_usb_packet_address = USB_PACKET_BUFFER_ADDRESS_EX;
122 CRM->misc1_bit.usbbufs = TRUE;
123 }
124 else
125 {
126 /* disable usbbufs */
127 g_usb_packet_address = USB_PACKET_BUFFER_ADDRESS;
128 CRM->misc1_bit.usbbufs = FALSE;
129 }
130}
131
139void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info)
140{
141 uint16_t type = 0;
142
143 /* set endpoint address */
144 USB_SET_EPT_ADDRESS(ept_info->eptn, ept_info->ept_address);
145
146 /* select endpoint transfer type */
147 if(ept_info->trans_type == EPT_CONTROL_TYPE)
148 {
149 type = USB_EPT_CONTROL;
150 }
151 else if(ept_info->trans_type == EPT_BULK_TYPE)
152 {
153 type = USB_EPT_BULK;
154 }
155 else if(ept_info->trans_type == EPT_INT_TYPE)
156 {
157 type = USB_EPT_INT;
158 }
159 else if(ept_info->trans_type == EPT_ISO_TYPE)
160 {
161 type = USB_EPT_ISO;
162 ept_info->is_double_buffer = TRUE;
163 }
164
165 /* configure endpoint transfer type (control, bulk, interrupt, isochronous) */
166 USB_SET_TRANS_TYPE(ept_info->eptn, type);
167
168 /* endpoint is in transfer */
169 if(ept_info->inout == DATA_TRANS_IN)
170 {
171 if(ept_info->is_double_buffer == 0)
172 {
173 /* set in endpoint tx offset address */
174 USB_SET_TX_ADDRESS(ept_info->eptn, ept_info->tx_addr);
175
176 /* clear in endpoint data toggle */
177 USB_CLEAR_TXDTS(ept_info->eptn);
178
179 /* set endpoint transmission status: nak */
180 USB_SET_TXSTS(ept_info->eptn, USB_TX_NAK);
181 }
182 else
183 {
184 /* set double buffer endpoint*/
185 USB_SET_EPT_DOUBLE_BUFFER(ept_info->eptn);
186
187 /* set in endpoint offset address0 and address1 */
188 USB_SET_DOUBLE_BUFF0_ADDRESS(ept_info->eptn, ept_info->tx_addr);
189 USB_SET_DOUBLE_BUFF1_ADDRESS(ept_info->eptn, ept_info->rx_addr);
190
191 /* clear in and out data toggle */
192 USB_CLEAR_TXDTS(ept_info->eptn);
193 USB_CLEAR_RXDTS(ept_info->eptn);
194
195 /* toggle rx data toggle flag */
196 USB_TOGGLE_RXDTS(ept_info->eptn);
197
198 /* set endpoint reception status: disable */
199 USB_SET_RXSTS(ept_info->eptn, USB_RX_DISABLE);
200
201 /* set endpoint transmision status: nak */
202 USB_SET_TXSTS(ept_info->eptn, USB_TX_NAK);
203 }
204 }
205 else
206 {
207 if(ept_info->is_double_buffer == 0)
208 {
209 /* set out endpoint rx offset address */
210 USB_SET_RX_ADDRESS(ept_info->eptn, ept_info->rx_addr);
211
212 /* clear out endpoint data toggle */
213 USB_CLEAR_RXDTS(ept_info->eptn);
214
215 /* set out endpoint max reception buffer size */
216 USB_SET_RXLEN(ept_info->eptn, ept_info->maxpacket);
217
218 /* set endpoint reception status: valid */
219 USB_SET_RXSTS(ept_info->eptn, USB_RX_VALID);
220 }
221 else
222 {
223 /* set double buffer endpoint */
224 USB_SET_EPT_DOUBLE_BUFFER(ept_info->eptn);
225
226 /* set out endpoint offset address0 and address1 */
227 USB_SET_DOUBLE_BUFF0_ADDRESS(ept_info->eptn, ept_info->tx_addr);
228 USB_SET_DOUBLE_BUFF1_ADDRESS(ept_info->eptn, ept_info->rx_addr);
229
230 /* set out endpoint max reception buffer size */
231 USB_SET_EPT_DOUBLE_BUF0_LEN(ept_info->eptn, ept_info->maxpacket, DATA_TRANS_OUT);
232 USB_SET_EPT_DOUBLE_BUF1_LEN(ept_info->eptn, ept_info->maxpacket, DATA_TRANS_OUT);
233
234 /* clear in and out data toggle */
235 USB_CLEAR_TXDTS(ept_info->eptn);
236 USB_CLEAR_RXDTS(ept_info->eptn);
237
238 /* toggle tx data toggle flag */
239 USB_TOGGLE_TXDTS(ept_info->eptn);
240
241 /* set endpoint reception status: valid */
242 USB_SET_RXSTS(ept_info->eptn, USB_RX_VALID);
243
244 /* set endpoint transmision status: disable */
245 USB_SET_TXSTS(ept_info->eptn, USB_TX_DISABLE);
246 }
247 }
248}
249
250
258void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info)
259{
260 if(ept_info->is_double_buffer == 0)
261 {
262 if(ept_info->inout == DATA_TRANS_IN)
263 {
264 /*clear tx data toggle */
265 USB_CLEAR_TXDTS(ept_info->eptn);
266
267 /* set tx status: disable */
268 USB_SET_TXSTS(ept_info->eptn, USB_TX_DISABLE);
269 }
270 else
271 {
272 /*clear rx data toggle */
273 USB_CLEAR_RXDTS(ept_info->eptn);
274
275 /* set rx status: disable */
276 USB_SET_RXSTS(ept_info->eptn, USB_RX_DISABLE);
277
278 }
279 }
280 else
281 {
282 /* double buffer */
283
284 /*clear rx and tx data toggle */
285 USB_CLEAR_TXDTS(ept_info->eptn);
286 USB_CLEAR_RXDTS(ept_info->eptn);
287
288 if(ept_info->inout == DATA_TRANS_IN)
289 {
290 /* toggle tx */
291 USB_TOGGLE_TXDTS(ept_info->eptn);
292
293 /* set tx and rx status: disable */
294 USB_SET_TXSTS(ept_info->eptn, USB_TX_DISABLE);
295 USB_SET_RXSTS(ept_info->eptn, USB_RX_DISABLE);
296 }
297 else
298 {
299 /* toggle rx */
300 USB_TOGGLE_RXDTS(ept_info->eptn);
301
302 /* set tx and rx status: disable */
303 USB_SET_TXSTS(ept_info->eptn, USB_TX_DISABLE);
304 USB_SET_RXSTS(ept_info->eptn, USB_RX_DISABLE);
305 }
306 }
307}
308
316void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
317{
318 /* endpoint tx buffer address */
319 __IO uint16_t *d_addr = (__IO uint16_t *)(offset_addr * 2 + g_usb_packet_address);
320
321 uint32_t nhbytes = (nbytes + 1) >> 1;
322 uint32_t n_index;
323 uint16_t *pbuf = (uint16_t *)pusr_buf;
324 for(n_index = 0; n_index < nhbytes; n_index ++)
325 {
326#if defined (__ICCARM__) && (__VER__ < 7000000)
327 *d_addr++ = *(__packed uint16_t *)pbuf;
328#else
329 *d_addr++ = __UNALIGNED_UINT16_READ(pbuf);
330#endif
331 d_addr ++;
332 pbuf ++;
333 }
334}
335
343void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
344{
345 __IO uint16_t *s_addr = (__IO uint16_t *)(offset_addr * 2 + g_usb_packet_address);
346 uint32_t nhbytes = (nbytes + 1) >> 1;
347 uint32_t n_index;
348 uint16_t *pbuf = (uint16_t *)pusr_buf;
349 for(n_index = 0; n_index < nhbytes; n_index ++)
350 {
351#if defined (__ICCARM__) && (__VER__ < 7000000)
352 *(__packed uint16_t *)pbuf = *(__IO uint16_t *)s_addr ++;
353#else
354 __UNALIGNED_UINT16_WRITE(pbuf, *(__IO uint16_t *)s_addr ++);
355#endif
356 s_addr ++;
357 pbuf ++;
358 }
359}
360
361
379void usb_interrupt_enable(usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
380{
381 if(new_state == TRUE)
382 {
383 usbx->ctrl |= interrupt;
384 }
385 else
386 {
387 usbx->ctrl &= ~interrupt;
388 }
389}
390
398void usb_set_address(usbd_type *usbx, uint8_t address)
399{
400 usbx->devaddr_bit.addr = address;
401 usbx->devaddr_bit.cen = TRUE;
402}
403
411void usb_ept_stall(usbd_type *usbx, usb_ept_info *ept_info)
412{
413 if(ept_info->inout == DATA_TRANS_IN)
414 {
415 USB_SET_TXSTS(ept_info->eptn, USB_TX_STALL)
416 }
417 else
418 {
419 USB_SET_RXSTS(ept_info->eptn, USB_RX_STALL)
420 }
421}
422
429void usb_enter_suspend(usbd_type *usbx)
430{
431 usbx->ctrl_bit.ssp = TRUE;
432 usbx->ctrl_bit.lpm = TRUE;
433}
434
441void usb_exit_suspend(usbd_type *usbx)
442{
443 usbx->ctrl_bit.ssp = FALSE;
444 usbx->ctrl_bit.lpm = FALSE;
445}
446
453void usb_remote_wkup_set(usbd_type *usbx)
454{
455 usbx->ctrl_bit.gresume = TRUE;
456}
457
464void usb_remote_wkup_clear(usbd_type *usbx)
465{
466 usbx->ctrl_bit.gresume = FALSE;
467}
468
474uint16_t usb_buffer_malloc(uint16_t maxpacket)
475{
476 uint16_t offset = g_usb_offset_addr;
477 g_usb_offset_addr += maxpacket;
478 return offset;
479}
480
486void usb_buffer_free(void)
487{
488 g_usb_offset_addr = USB_ENDP_DESC_TABLE_OFFSET;
489}
490
507 flag_status usb_flag_get(usbd_type *usbx, uint16_t flag)
508{
509 flag_status status = RESET;
510
511 if((usbx->intsts & flag) == RESET)
512 {
513 status = RESET;
514 }
515 else
516 {
517 status = SET;
518 }
519 return status;
520}
521
538void usb_flag_clear(usbd_type *usbx, uint16_t flag)
539{
540 usbx->intsts = ~flag;
541}
542
547#endif
548
CRM
#define CRM
Definition: at32f413_crm.h:844
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
USB_BUFFER_TABLE_ADDRESS
#define USB_BUFFER_TABLE_ADDRESS
Definition: at32f413_usb.h:155
USB_EPT_CONTROL
#define USB_EPT_CONTROL
Definition: at32f413_usb.h:141
USB_EPT_INT
#define USB_EPT_INT
Definition: at32f413_usb.h:143
USB_EPT_BULK
#define USB_EPT_BULK
Definition: at32f413_usb.h:142
USB_EPT_ISO
#define USB_EPT_ISO
Definition: at32f413_usb.h:144
USB_RX_STALL
#define USB_RX_STALL
Definition: at32f413_usb.h:125
USB_RX_DISABLE
#define USB_RX_DISABLE
Definition: at32f413_usb.h:124
USB_TX_NAK
#define USB_TX_NAK
Definition: at32f413_usb.h:118
USB_TX_STALL
#define USB_TX_STALL
Definition: at32f413_usb.h:117
USB_TX_DISABLE
#define USB_TX_DISABLE
Definition: at32f413_usb.h:116
USB_RX_VALID
#define USB_RX_VALID
Definition: at32f413_usb.h:127
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:223
DATA_TRANS_IN
@ DATA_TRANS_IN
Definition: at32f413_usb.h:224
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f413_usb.h:206
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
EPT_CONTROL_TYPE
@ EPT_CONTROL_TYPE
Definition: at32f413_usb.h:203
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:204
USB_SP_INT
#define USB_SP_INT
Definition: at32f413_usb.h:57
USB_TC_INT
#define USB_TC_INT
Definition: at32f413_usb.h:61
USB_RST_INT
#define USB_RST_INT
Definition: at32f413_usb.h:56
USB_WK_INT
#define USB_WK_INT
Definition: at32f413_usb.h:58
USB_SOF_INT
#define USB_SOF_INT
Definition: at32f413_usb.h:55
USB_CLEAR_TXDTS
#define USB_CLEAR_TXDTS(eptn)
clear usb tx/rx toggle
Definition: at32f413_usb.h:419
USB_SET_EPT_DOUBLE_BUF1_LEN
#define USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir)
double buffer mode set endpoint buf1 length
Definition: at32f413_usb.h:377
USB_SET_RXLEN
#define USB_SET_RXLEN(eptn, len)
Definition: at32f413_usb.h:336
USB_SET_RXSTS
#define USB_SET_RXSTS(ept_num, new_sts)
set usb endpoint rx status
Definition: at32f413_usb.h:264
USB_SET_EPT_DOUBLE_BUFFER
#define USB_SET_EPT_DOUBLE_BUFFER(eptn)
set/clear endpoint double buffer mode
Definition: at32f413_usb.h:486
USB_CLEAR_RXDTS
#define USB_CLEAR_RXDTS(eptn)
Definition: at32f413_usb.h:423
USB_TOGGLE_RXDTS
#define USB_TOGGLE_RXDTS(eptn)
Definition: at32f413_usb.h:412
USB_SET_EPT_ADDRESS
#define USB_SET_EPT_ADDRESS(eptn, address)
set usb device address
Definition: at32f413_usb.h:454
USB_SET_TRANS_TYPE
#define USB_SET_TRANS_TYPE(eptn, type)
set usb endpoint type
Definition: at32f413_usb.h:438
USB_SET_DOUBLE_BUFF1_ADDRESS
#define USB_SET_DOUBLE_BUFF1_ADDRESS(eptn, address)
Definition: at32f413_usb.h:404
USB_SET_TXSTS
#define USB_SET_TXSTS(ept_num, new_sts)
set usb endpoint tx status
Definition: at32f413_usb.h:249
USB_SET_TX_ADDRESS
#define USB_SET_TX_ADDRESS(eptn, address)
set usb endpoint tx/rx fifo address
Definition: at32f413_usb.h:394
USB_TOGGLE_TXDTS
#define USB_TOGGLE_TXDTS(eptn)
set usb tx/rx toggle
Definition: at32f413_usb.h:411
USB_SET_EPT_DOUBLE_BUF0_LEN
#define USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir)
double buffer mode set endpoint buf0 length
Definition: at32f413_usb.h:359
USB_SET_RX_ADDRESS
#define USB_SET_RX_ADDRESS(eptn, address)
Definition: at32f413_usb.h:395
USB_SET_DOUBLE_BUFF0_ADDRESS
#define USB_SET_DOUBLE_BUFF0_ADDRESS(eptn, address)
set double buffer mode usb endpoint buf0/buf1 fifo address
Definition: at32f413_usb.h:403
USB_PACKET_BUFFER_ADDRESS
#define USB_PACKET_BUFFER_ADDRESS
Definition: at32f413_usb.h:166
USB_PACKET_BUFFER_ADDRESS_EX
#define USB_PACKET_BUFFER_ADDRESS_EX
Definition: at32f413_usb.h:167
usb_flag_get
flag_status usb_flag_get(usbd_type *usbx, uint16_t flag)
get flag of usb.
Definition: at32f413_usb.c:507
usb_exit_suspend
void usb_exit_suspend(usbd_type *usbx)
usb device exit suspend mode
Definition: at32f413_usb.c:441
usb_buffer_free
void usb_buffer_free(void)
free usb endpoint buffer
Definition: at32f413_usb.c:486
usb_flag_clear
void usb_flag_clear(usbd_type *usbx, uint16_t flag)
clear flag of usb.
Definition: at32f413_usb.c:538
usb_write_packet
void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer
Definition: at32f413_usb.c:316
usb_read_packet
void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer
Definition: at32f413_usb.c:343
g_usb_packet_address
uint32_t g_usb_packet_address
Definition: at32f413_usb.c:49
usb_disconnect
void usb_disconnect(usbd_type *usbx)
disconnect usb device
Definition: at32f413_usb.c:93
USB_ENDP_DESC_TABLE_OFFSET
#define USB_ENDP_DESC_TABLE_OFFSET
usb packet buffer start address
Definition: at32f413_usb.c:48
usb_enter_suspend
void usb_enter_suspend(usbd_type *usbx)
usb device enter suspend mode
Definition: at32f413_usb.c:429
usb_interrupt_enable
void usb_interrupt_enable(usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable
Definition: at32f413_usb.c:379
usb_remote_wkup_clear
void usb_remote_wkup_clear(usbd_type *usbx)
usb remote wakeup clear
Definition: at32f413_usb.c:464
usb_usbbufs_enable
void usb_usbbufs_enable(usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area,...
Definition: at32f413_usb.c:116
usb_ept_stall
void usb_ept_stall(usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall
Definition: at32f413_usb.c:411
usb_set_address
void usb_set_address(usbd_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f413_usb.c:398
g_usb_offset_addr
static uint16_t g_usb_offset_addr
Definition: at32f413_usb.c:50
usb_buffer_malloc
uint16_t usb_buffer_malloc(uint16_t maxpacket)
usb auto malloc endpoint buffer
Definition: at32f413_usb.c:474
usb_remote_wkup_set
void usb_remote_wkup_set(usbd_type *usbx)
usb remote wakeup set
Definition: at32f413_usb.c:453
usb_connect
void usb_connect(usbd_type *usbx)
connect usb device
Definition: at32f413_usb.c:81
usb_ept_open
void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint
Definition: at32f413_usb.c:139
usb_dev_init
void usb_dev_init(usbd_type *usbx)
initialize usb peripheral controller register
Definition: at32f413_usb.c:58
usb_ept_close
void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint
Definition: at32f413_usb.c:258
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:501
usb_ept_info::ept_address
uint8_t ept_address
Definition: at32f413_usb.h:503
usb_ept_info::inout
uint8_t inout
Definition: at32f413_usb.h:504
usb_ept_info::maxpacket
uint16_t maxpacket
Definition: at32f413_usb.h:509
usb_ept_info::rx_addr
uint16_t rx_addr
Definition: at32f413_usb.h:508
usb_ept_info::is_double_buffer
uint8_t is_double_buffer
Definition: at32f413_usb.h:510
usb_ept_info::tx_addr
uint16_t tx_addr
Definition: at32f413_usb.h:507
usb_ept_info::eptn
uint8_t eptn
Definition: at32f413_usb.h:502
usb_ept_info::trans_type
uint8_t trans_type
Definition: at32f413_usb.h:505
usbd_type
type define usb register all
Definition: at32f413_usb.h:528
usbd_type::devaddr
__IO uint32_t devaddr
Definition: at32f413_usb.h:624
usbd_type::intsts
__IO uint32_t intsts
Definition: at32f413_usb.h:584
usbd_type::cen
__IO uint32_t cen
Definition: at32f413_usb.h:628
usbd_type::ctrl_bit
struct usbd_type::@733::@746 ctrl_bit
usbd_type::buftbl
__IO uint32_t buftbl
Definition: at32f413_usb.h:638
usbd_type::ssp
__IO uint32_t ssp
Definition: at32f413_usb.h:564
usbd_type::csrst
__IO uint32_t csrst
Definition: at32f413_usb.h:561
usbd_type::lpm
__IO uint32_t lpm
Definition: at32f413_usb.h:563
usbd_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_usb.h:558
usbd_type::devaddr_bit
struct usbd_type::@739::@749 devaddr_bit
usbd_type::gresume
__IO uint32_t gresume
Definition: at32f413_usb.h:565
usbd_type::disusb
__IO uint32_t disusb
Definition: at32f413_usb.h:562
usbd_type::addr
__IO uint32_t addr
Definition: at32f413_usb.h:627
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_usb.h Source File

  • libraries
  • drivers
  • inc
at32f413_usb.h
Go to the documentation of this file.
1
35/* define to prevent recursive inclusion -------------------------------------*/
36#ifndef __AT32F413_USB_H
37#define __AT32F413_USB_H
38
39#ifdef __cplusplus
40extern "C" {
41#endif
42
43
44/* includes ------------------------------------------------------------------*/
45#include "at32f413.h"
46
47
48
54#define USB_LSOF_INT ((uint32_t)0x00000100)
55#define USB_SOF_INT ((uint32_t)0x00000200)
56#define USB_RST_INT ((uint32_t)0x00000400)
57#define USB_SP_INT ((uint32_t)0x00000800)
58#define USB_WK_INT ((uint32_t)0x00001000)
59#define USB_BE_INT ((uint32_t)0x00002000)
60#define USB_UCFOR_INT ((uint32_t)0x00004000)
61#define USB_TC_INT ((uint32_t)0x00008000)
72#define USB_EPT_NUM_FLAG ((uint32_t)0x0000000F)
73#define USB_INOUT_FLAG ((uint32_t)0x00000010)
74#define USB_LSOF_FLAG ((uint32_t)0x00000100)
75#define USB_SOF_FLAG ((uint32_t)0x00000200)
76#define USB_RST_FLAG ((uint32_t)0x00000400)
77#define USB_SP_FLAG ((uint32_t)0x00000800)
78#define USB_WK_FLAG ((uint32_t)0x00001000)
79#define USB_BE_FLAG ((uint32_t)0x00002000)
80#define USB_UCFOR_FLAG ((uint32_t)0x00004000)
81#define USB_TC_FLAG ((uint32_t)0x00008000)
92#define USB_EPTADDR ((uint32_t)0x0000000F)
93#define USB_TXSTS ((uint32_t)0x00000030)
94#define USB_TXDTS ((uint32_t)0x00000040)
95#define USB_TXTC ((uint32_t)0x00000080)
96#define USB_EXF ((uint32_t)0x00000100)
97#define USB_TRANS_TYPE ((uint32_t)0x00000600)
98#define USB_SETUPTC ((uint32_t)0x00000800)
99#define USB_RXSTS ((uint32_t)0x00003000)
100#define USB_RXDTS ((uint32_t)0x00004000)
101#define USB_RXTC ((uint32_t)0x00008000)
103#define USB_EPT_BIT_MASK (uint32_t)(USB_TXTC | USB_SETUPTC | USB_EPTADDR | USB_EXF | USB_RXTC | USB_TRANS_TYPE)
104#define USB_TX_MASK (USB_TXSTS | USB_EPT_BIT_MASK)
105#define USB_RX_MASK (USB_RXSTS | USB_EPT_BIT_MASK)
116#define USB_TX_DISABLE ((uint32_t)0x00000000)
117#define USB_TX_STALL ((uint32_t)0x00000010)
118#define USB_TX_NAK ((uint32_t)0x00000020)
119#define USB_TX_VALID ((uint32_t)0x00000030)
121#define USB_TXDTS0 ((uint32_t)0x00000010)
122#define USB_TXDTS1 ((uint32_t)0x00000020)
124#define USB_RX_DISABLE ((uint32_t)0x00000000)
125#define USB_RX_STALL ((uint32_t)0x00001000)
126#define USB_RX_NAK ((uint32_t)0x00002000)
127#define USB_RX_VALID ((uint32_t)0x00003000)
129#define USB_RXDTS0 ((uint32_t)0x00001000)
130#define USB_RXDTS1 ((uint32_t)0x00002000)
141#define USB_EPT_CONTROL ((uint32_t)0x00000200)
142#define USB_EPT_BULK ((uint32_t)0x00000000)
143#define USB_EPT_INT ((uint32_t)0x00000600)
144#define USB_EPT_ISO ((uint32_t)0x00000400)
155#define USB_BUFFER_TABLE_ADDRESS 0x0000
166#define USB_PACKET_BUFFER_ADDRESS 0x40006000
167#define USB_PACKET_BUFFER_ADDRESS_EX 0x40007800
180typedef enum
181{
182 USB_EPT0 = 0x00,
183 USB_EPT1 = 0x01,
184 USB_EPT2 = 0x02,
185 USB_EPT3 = 0x03,
186 USB_EPT4 = 0x04,
187 USB_EPT5 = 0x05,
188 USB_EPT6 = 0x06,
189 USB_EPT7 = 0x07
190} usb_ept_number_type;
191
195#ifndef USB_EPT_MAX_NUM
196#define USB_EPT_MAX_NUM 8
197#endif
201typedef enum
202{
203 EPT_CONTROL_TYPE = 0x00,
204 EPT_BULK_TYPE = 0x01,
205 EPT_INT_TYPE = 0x02,
206 EPT_ISO_TYPE = 0x03
207}ept_trans_type;
208
212typedef enum
213{
214 EPT_IN = 0x00,
215 EPT_OUT = 0x01
216}ept_inout_type;
217
221typedef enum
222{
223 DATA_TRANS_OUT = 0x00,
224 DATA_TRANS_IN = 0x01
225}data_trans_dir;
226
230typedef enum
231{
232 USB_CLK_HICK,
233 USB_CLK_HEXT
234}usb_clk48_s;
249#define USB_SET_TXSTS(ept_num, new_sts) { \
250 register uint16_t epsts = (USB->ept[ept_num]) & USB_TX_MASK; \
251 if((new_sts & USB_TXDTS0) != 0) \
252 epsts ^= USB_TXDTS0; \
253 if((new_sts & USB_TXDTS1) != 0) \
254 epsts ^= USB_TXDTS1; \
255 USB->ept[ept_num] = epsts | USB_RXTC | USB_TXTC; \
256}
257
264#define USB_SET_RXSTS(ept_num, new_sts) { \
265 register uint16_t epsts = (USB->ept[ept_num]) & USB_RX_MASK; \
266 if((new_sts & USB_RXDTS0) != 0) \
267 epsts ^= USB_RXDTS0; \
268 if((new_sts & USB_RXDTS1) != 0) \
269 epsts ^= USB_RXDTS1; \
270 USB->ept[ept_num] = epsts | USB_RXTC | USB_TXTC; \
271}
272
278#define GET_TX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 2) * 2 + g_usb_packet_address)
279#define GET_RX_LEN_ADDR(eptn) (uint32_t *)((USB->buftbl + eptn * 8 + 6) * 2 + g_usb_packet_address)
280
286#define USB_GET_TX_LEN(eptn) ((uint16_t)(*GET_TX_LEN_ADDR(eptn)) & 0x3ff)
287#define USB_GET_RX_LEN(eptn) ((uint16_t)(*GET_RX_LEN_ADDR(eptn)) & 0x3ff)
288
294#define USB_DBUF0_GET_LEN(eptn) USB_GET_TX_LEN(eptn)
295#define USB_DBUF1_GET_LEN(eptn) USB_GET_RX_LEN(eptn)
296
303#define BLK32(reg, len, blks) { \
304 blks = (len) >> 5; \
305 if(((len) & 0x1F) == 0) \
306 blks --; \
307 *reg = ((uint16_t)((blks) << 10) | 0x8000); \
308}
309
310#define BLK2(reg, len, blks) { \
311 blks = (len) >> 1; \
312 if(((len) & 0x1) == 0) \
313 blks ++; \
314 *reg = (uint16_t)((blks) << 10); \
315}
316
317#define USB_SET_RXLEN_REG(reg, len) { \
318 uint16_t blks; \
319 if(len > 62) \
320 { \
321 BLK32(reg, len, blks); \
322 } \
323 else \
324 { \
325 BLK2(reg, len, blks); \
326 } \
327}
328
335#define USB_SET_TXLEN(eptn, len) (*(GET_TX_LEN_ADDR(eptn)) = (len))
336#define USB_SET_RXLEN(eptn, len) { \
337 uint32_t *rx_reg = GET_RX_LEN_ADDR(eptn); \
338 USB_SET_RXLEN_REG(rx_reg, (len)); \
339}
340
347#define USB_OUT_EPT_DOUBLE_BUF0(eptn, len) { \
348 uint32_t *rx_reg = GET_TX_LEN_ADDR(eptn); \
349 USB_SET_RXLEN_REG(rx_reg, (len)); \
350}
351
359#define USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir) { \
360 if(dir == DATA_TRANS_OUT) \
361 { \
362 USB_OUT_EPT_DOUBLE_BUF0(eptn, len); \
363 } \
364 else \
365 { \
366 *(GET_TX_LEN_ADDR(eptn)) = (len); \
367 } \
368}
369
377#define USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir) { \
378 if(dir == DATA_TRANS_OUT) \
379 { \
380 USB_SET_RXLEN(eptn, len); \
381 } \
382 else \
383 { \
384 *(GET_RX_LEN_ADDR(eptn)) = (len); \
385 } \
386}
387
394#define USB_SET_TX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8) * 2 + g_usb_packet_address) = address)
395#define USB_SET_RX_ADDRESS(eptn, address) (*(uint32_t *)((USB->buftbl + eptn * 8 + 4) * 2 + g_usb_packet_address) = address)
396
403#define USB_SET_DOUBLE_BUFF0_ADDRESS(eptn, address) (USB_SET_TX_ADDRESS(eptn, address))
404#define USB_SET_DOUBLE_BUFF1_ADDRESS(eptn, address) (USB_SET_RX_ADDRESS(eptn, address))
405
411#define USB_TOGGLE_TXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_TXDTS | USB_RXTC | USB_TXTC))
412#define USB_TOGGLE_RXDTS(eptn) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK) | USB_RXDTS | USB_RXTC | USB_TXTC))
413
419#define USB_CLEAR_TXDTS(eptn) { \
420 if(USB->ept_bit[eptn].txdts != 0) \
421 USB_TOGGLE_TXDTS(eptn); \
422}
423#define USB_CLEAR_RXDTS(eptn) { \
424 if(USB->ept_bit[eptn].rxdts != 0) \
425 USB_TOGGLE_RXDTS(eptn); \
426}
427
438#define USB_SET_TRANS_TYPE(eptn, type) (USB->ept[eptn] = (USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_TRANS_TYPE)) | type)
439
445#define USB_SET_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | ((USB->ept[eptn] | USB_EXF) & USB_EPT_BIT_MASK))
446#define USB_CLEAR_EXF(eptn) (USB->ept[eptn] = USB_TXTC | USB_RXTC | (USB->ept[eptn] & ((~USB_EXF) & USB_EPT_BIT_MASK)))
447
454#define USB_SET_EPT_ADDRESS(eptn, address) (USB->ept[eptn] = ((USB->ept[eptn] & USB_EPT_BIT_MASK & (~USB_EPTADDR)) | address))
455
462#define USB_FREE_DB_USER_BUFFER(eptn, inout) { \
463 if(inout == DATA_TRANS_IN) \
464 { \
465 USB_TOGGLE_RXDTS(eptn); \
466 } \
467 else \
468 { \
469 USB_TOGGLE_TXDTS(eptn); \
470 } \
471}
472
478#define USB_CLEAR_TXTC(eptn) (USB->ept[eptn] &= 0xFF7F & USB_EPT_BIT_MASK)
479#define USB_CLEAR_RXTC(eptn) (USB->ept[eptn] &= 0x7FFF & USB_EPT_BIT_MASK)
480
486#define USB_SET_EPT_DOUBLE_BUFFER(eptn) USB_SET_EXF(eptn)
487#define USB_CLEAR_EPT_DOUBLE_BUFFER(eptn) USB_CLEAR_EXF(eptn)
488
500typedef struct
501{
502 uint8_t eptn;
503 uint8_t ept_address;
504 uint8_t inout;
505 uint8_t trans_type;
507 uint16_t tx_addr;
508 uint16_t rx_addr;
509 uint16_t maxpacket;
510 uint8_t is_double_buffer;
511 uint8_t stall;
512 uint16_t status;
514 /* transmission buffer and count */
515 uint16_t total_len;
516 uint16_t trans_len;
517 uint8_t *trans_buf;
519 uint16_t last_len;
520 uint16_t rem0_len;
521 uint16_t ept0_slen;
522}usb_ept_info;
523
527typedef struct
528{
532 union
533 {
534 __IO uint32_t ept[8];
535 struct
536 {
537 __IO uint32_t eptaddr : 4; /* [3:0] */
538 __IO uint32_t txsts : 2; /* [5:4] */
539 __IO uint32_t txdts : 1; /* [6] */
540 __IO uint32_t txtc : 1; /* [7] */
541 __IO uint32_t exf : 1; /* [8] */
542 __IO uint32_t trans_type : 2; /* [10:9] */
543 __IO uint32_t setuptc : 1; /* [11] */
544 __IO uint32_t rxsts : 2; /* [13:12] */
545 __IO uint32_t rxdts : 1; /* [14] */
546 __IO uint32_t rxtc : 1; /* [15] */
547 __IO uint32_t reserved1 : 16; /* [31:16] */
548 } ept_bit[8];
549 };
550
551 __IO uint32_t reserved1[8];
552
556 union
557 {
558 __IO uint32_t ctrl;
559 struct
560 {
561 __IO uint32_t csrst : 1; /* [0] */
562 __IO uint32_t disusb : 1; /* [1] */
563 __IO uint32_t lpm : 1; /* [2] */
564 __IO uint32_t ssp : 1; /* [3] */
565 __IO uint32_t gresume : 1; /* [4] */
566 __IO uint32_t reserved1 : 3; /* [7:5] */
567 __IO uint32_t lsofien : 1; /* [8] */
568 __IO uint32_t sofien : 1; /* [9] */
569 __IO uint32_t rstien : 1; /* [10] */
570 __IO uint32_t spien : 1; /* [11] */
571 __IO uint32_t wkien : 1; /* [12] */
572 __IO uint32_t beien : 1; /* [13] */
573 __IO uint32_t ucforien : 1; /* [14] */
574 __IO uint32_t tcien : 1; /* [15] */
575 __IO uint32_t reserved2 : 16; /* [31:16] */
576 } ctrl_bit;
577 };
578
582 union
583 {
584 __IO uint32_t intsts;
585 struct
586 {
587 __IO uint32_t ept_num : 4; /* [3:0] */
588 __IO uint32_t inout : 1; /* [4] */
589 __IO uint32_t reserved1 : 3; /* [7:5] */
590 __IO uint32_t lsof : 1; /* [8] */
591 __IO uint32_t sof : 1; /* [9] */
592 __IO uint32_t rst : 1; /* [10] */
593 __IO uint32_t sp : 1; /* [11] */
594 __IO uint32_t wk : 1; /* [12] */
595 __IO uint32_t be : 1; /* [13] */
596 __IO uint32_t ucfor : 1; /* [14] */
597 __IO uint32_t tc : 1; /* [15] */
598 __IO uint32_t reserved2 : 16; /* [31:16] */
599 } intsts_bit;
600 };
601
605 union
606 {
607 __IO uint32_t sofrnum;
608 struct
609 {
610 __IO uint32_t sofnum : 11; /* [10:0] */
611 __IO uint32_t lsofnum : 2; /* [12:11] */
612 __IO uint32_t clck : 1; /* [13] */
613 __IO uint32_t dmsts : 1; /* [14] */
614 __IO uint32_t dpsts : 1; /* [15] */
615 __IO uint32_t reserved1 : 16; /* [31:16] */
616 } sofrnum_bit;
617 };
618
622 union
623 {
624 __IO uint32_t devaddr;
625 struct
626 {
627 __IO uint32_t addr : 7; /* [6:0] */
628 __IO uint32_t cen : 1; /* [7] */
629 __IO uint32_t reserved1 : 24; /* [31:8] */
630 } devaddr_bit;
631 };
632
636 union
637 {
638 __IO uint32_t buftbl;
639 struct
640 {
641 __IO uint32_t reserved1 : 3; /* [2:0] */
642 __IO uint32_t btaddr : 13; /* [15:3] */
643 __IO uint32_t reserved2 : 16; /* [31:16] */
644 } buftbl_bit;
645 };
646 __IO uint32_t reserved2[3];
650 union
651 {
652 __IO uint32_t cfg;
653 struct
654 {
655 __IO uint32_t sofouten : 1; /* [0] */
656 __IO uint32_t reserved1 : 31; /* [31:1] */
657 } cfg_bit;
658 };
659
660} usbd_type;
661
666#define USB ((usbd_type *) USBFS_BASE)
667
668typedef usbd_type usb_reg_type;
669extern uint32_t g_usb_packet_address;
670
675void usb_dev_init(usbd_type *usbx);
676void usb_connect(usbd_type *usbx);
677void usb_disconnect(usbd_type *usbx);
678void usb_usbbufs_enable(usbd_type *usbx, confirm_state state);
679void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info);
680void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info);
681void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes);
682void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes);
683void usb_interrupt_enable(usbd_type *usbx, uint16_t interrupt, confirm_state new_state);
684void usb_set_address(usbd_type *usbx, uint8_t address);
685void usb_ept_stall(usbd_type *usbx, usb_ept_info *ept_info);
686void usb_enter_suspend(usbd_type *usbx);
687void usb_exit_suspend(usbd_type *usbx);
688void usb_remote_wkup_set(usbd_type *usbx);
689void usb_remote_wkup_clear(usbd_type *usbx);
690uint16_t usb_buffer_malloc(uint16_t maxpacket);
691void usb_buffer_free(void);
692 flag_status usb_flag_get(usbd_type *usbx, uint16_t flag);
693void usb_flag_clear(usbd_type *usbx, uint16_t flag);
694
695
696#ifdef __cplusplus
697}
698#endif
699
700#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
data_trans_dir
data_trans_dir
data transfer direction
Definition: at32f413_usb.h:222
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
ept_inout_type
ept_inout_type
endpoint endpoint direction define
Definition: at32f413_usb.h:213
usb_ept_number_type
usb_ept_number_type
usb endpoint number define
Definition: at32f413_usb.h:181
ept_trans_type
ept_trans_type
usb endpoint max num define
Definition: at32f413_usb.h:202
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:223
DATA_TRANS_IN
@ DATA_TRANS_IN
Definition: at32f413_usb.h:224
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
EPT_IN
@ EPT_IN
Definition: at32f413_usb.h:214
EPT_OUT
@ EPT_OUT
Definition: at32f413_usb.h:215
USB_EPT4
@ USB_EPT4
Definition: at32f413_usb.h:186
USB_EPT6
@ USB_EPT6
Definition: at32f413_usb.h:188
USB_EPT5
@ USB_EPT5
Definition: at32f413_usb.h:187
USB_EPT7
@ USB_EPT7
Definition: at32f413_usb.h:189
USB_EPT0
@ USB_EPT0
Definition: at32f413_usb.h:182
USB_EPT2
@ USB_EPT2
Definition: at32f413_usb.h:184
USB_EPT1
@ USB_EPT1
Definition: at32f413_usb.h:183
USB_EPT3
@ USB_EPT3
Definition: at32f413_usb.h:185
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f413_usb.h:206
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
EPT_CONTROL_TYPE
@ EPT_CONTROL_TYPE
Definition: at32f413_usb.h:203
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:204
usb_flag_get
flag_status usb_flag_get(usbd_type *usbx, uint16_t flag)
get flag of usb.
Definition: at32f413_usb.c:507
usb_exit_suspend
void usb_exit_suspend(usbd_type *usbx)
usb device exit suspend mode
Definition: at32f413_usb.c:441
usb_buffer_free
void usb_buffer_free(void)
free usb endpoint buffer
Definition: at32f413_usb.c:486
usb_flag_clear
void usb_flag_clear(usbd_type *usbx, uint16_t flag)
clear flag of usb.
Definition: at32f413_usb.c:538
usb_write_packet
void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer
Definition: at32f413_usb.c:316
usb_read_packet
void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer
Definition: at32f413_usb.c:343
usb_disconnect
void usb_disconnect(usbd_type *usbx)
disconnect usb device
Definition: at32f413_usb.c:93
usb_enter_suspend
void usb_enter_suspend(usbd_type *usbx)
usb device enter suspend mode
Definition: at32f413_usb.c:429
usb_interrupt_enable
void usb_interrupt_enable(usbd_type *usbx, uint16_t interrupt, confirm_state new_state)
usb interrupt enable
Definition: at32f413_usb.c:379
usb_remote_wkup_clear
void usb_remote_wkup_clear(usbd_type *usbx)
usb remote wakeup clear
Definition: at32f413_usb.c:464
usb_usbbufs_enable
void usb_usbbufs_enable(usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area,...
Definition: at32f413_usb.c:116
usb_ept_stall
void usb_ept_stall(usbd_type *usbx, usb_ept_info *ept_info)
set endpoint tx or rx status to stall
Definition: at32f413_usb.c:411
usb_set_address
void usb_set_address(usbd_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f413_usb.c:398
usb_buffer_malloc
uint16_t usb_buffer_malloc(uint16_t maxpacket)
usb auto malloc endpoint buffer
Definition: at32f413_usb.c:474
usb_remote_wkup_set
void usb_remote_wkup_set(usbd_type *usbx)
usb remote wakeup set
Definition: at32f413_usb.c:453
usb_connect
void usb_connect(usbd_type *usbx)
connect usb device
Definition: at32f413_usb.c:81
usb_ept_open
void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint
Definition: at32f413_usb.c:139
usb_dev_init
void usb_dev_init(usbd_type *usbx)
initialize usb peripheral controller register
Definition: at32f413_usb.c:58
usb_ept_close
void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint
Definition: at32f413_usb.c:258
usb_reg_type
usbd_type usb_reg_type
Definition: at32f413_usb.h:668
g_usb_packet_address
uint32_t g_usb_packet_address
Definition: at32f413_usb.c:49
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:501
usb_ept_info::total_len
uint16_t total_len
Definition: at32f413_usb.h:515
usb_ept_info::ept_address
uint8_t ept_address
Definition: at32f413_usb.h:503
usb_ept_info::trans_len
uint16_t trans_len
Definition: at32f413_usb.h:516
usb_ept_info::inout
uint8_t inout
Definition: at32f413_usb.h:504
usb_ept_info::maxpacket
uint16_t maxpacket
Definition: at32f413_usb.h:509
usb_ept_info::ept0_slen
uint16_t ept0_slen
Definition: at32f413_usb.h:521
usb_ept_info::rx_addr
uint16_t rx_addr
Definition: at32f413_usb.h:508
usb_ept_info::trans_buf
uint8_t * trans_buf
Definition: at32f413_usb.h:517
usb_ept_info::stall
uint8_t stall
Definition: at32f413_usb.h:511
usb_ept_info::is_double_buffer
uint8_t is_double_buffer
Definition: at32f413_usb.h:510
usb_ept_info::last_len
uint16_t last_len
Definition: at32f413_usb.h:519
usb_ept_info::status
uint16_t status
Definition: at32f413_usb.h:512
usb_ept_info::rem0_len
uint16_t rem0_len
Definition: at32f413_usb.h:520
usb_ept_info::tx_addr
uint16_t tx_addr
Definition: at32f413_usb.h:507
usb_ept_info::eptn
uint8_t eptn
Definition: at32f413_usb.h:502
usb_ept_info::trans_type
uint8_t trans_type
Definition: at32f413_usb.h:505
usbd_type
type define usb register all
Definition: at32f413_usb.h:528
usbd_type::rxtc
__IO uint32_t rxtc
Definition: at32f413_usb.h:546
usbd_type::sofien
__IO uint32_t sofien
Definition: at32f413_usb.h:568
usbd_type::devaddr
__IO uint32_t devaddr
Definition: at32f413_usb.h:624
usbd_type::intsts
__IO uint32_t intsts
Definition: at32f413_usb.h:584
usbd_type::txtc
__IO uint32_t txtc
Definition: at32f413_usb.h:540
usbd_type::lsofien
__IO uint32_t lsofien
Definition: at32f413_usb.h:567
usbd_type::cen
__IO uint32_t cen
Definition: at32f413_usb.h:628
usbd_type::rstien
__IO uint32_t rstien
Definition: at32f413_usb.h:569
usbd_type::sofnum
__IO uint32_t sofnum
Definition: at32f413_usb.h:610
usbd_type::dpsts
__IO uint32_t dpsts
Definition: at32f413_usb.h:614
usbd_type::btaddr
__IO uint32_t btaddr
Definition: at32f413_usb.h:642
usbd_type::be
__IO uint32_t be
Definition: at32f413_usb.h:595
usbd_type::exf
__IO uint32_t exf
Definition: at32f413_usb.h:541
usbd_type::dmsts
__IO uint32_t dmsts
Definition: at32f413_usb.h:613
usbd_type::lsofnum
__IO uint32_t lsofnum
Definition: at32f413_usb.h:611
usbd_type::sofouten
__IO uint32_t sofouten
Definition: at32f413_usb.h:655
usbd_type::inout
__IO uint32_t inout
Definition: at32f413_usb.h:588
usbd_type::rxdts
__IO uint32_t rxdts
Definition: at32f413_usb.h:545
usbd_type::rst
__IO uint32_t rst
Definition: at32f413_usb.h:592
usbd_type::txdts
__IO uint32_t txdts
Definition: at32f413_usb.h:539
usbd_type::setuptc
__IO uint32_t setuptc
Definition: at32f413_usb.h:543
usbd_type::buftbl
__IO uint32_t buftbl
Definition: at32f413_usb.h:638
usbd_type::wk
__IO uint32_t wk
Definition: at32f413_usb.h:594
usbd_type::ssp
__IO uint32_t ssp
Definition: at32f413_usb.h:564
usbd_type::wkien
__IO uint32_t wkien
Definition: at32f413_usb.h:571
usbd_type::txsts
__IO uint32_t txsts
Definition: at32f413_usb.h:538
usbd_type::clck
__IO uint32_t clck
Definition: at32f413_usb.h:612
usbd_type::sofrnum
__IO uint32_t sofrnum
Definition: at32f413_usb.h:607
usbd_type::ucfor
__IO uint32_t ucfor
Definition: at32f413_usb.h:596
usbd_type::spien
__IO uint32_t spien
Definition: at32f413_usb.h:570
usbd_type::csrst
__IO uint32_t csrst
Definition: at32f413_usb.h:561
usbd_type::lpm
__IO uint32_t lpm
Definition: at32f413_usb.h:563
usbd_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_usb.h:558
usbd_type::trans_type
__IO uint32_t trans_type
Definition: at32f413_usb.h:542
usbd_type::ucforien
__IO uint32_t ucforien
Definition: at32f413_usb.h:573
usbd_type::gresume
__IO uint32_t gresume
Definition: at32f413_usb.h:565
usbd_type::lsof
__IO uint32_t lsof
Definition: at32f413_usb.h:590
usbd_type::sof
__IO uint32_t sof
Definition: at32f413_usb.h:591
usbd_type::sp
__IO uint32_t sp
Definition: at32f413_usb.h:593
usbd_type::tcien
__IO uint32_t tcien
Definition: at32f413_usb.h:574
usbd_type::disusb
__IO uint32_t disusb
Definition: at32f413_usb.h:562
usbd_type::eptaddr
__IO uint32_t eptaddr
Definition: at32f413_usb.h:537
usbd_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_usb.h:547
usbd_type::tc
__IO uint32_t tc
Definition: at32f413_usb.h:597
usbd_type::addr
__IO uint32_t addr
Definition: at32f413_usb.h:627
usbd_type::cfg
__IO uint32_t cfg
Definition: at32f413_usb.h:652
usbd_type::reserved2
__IO uint32_t reserved2
Definition: at32f413_usb.h:575
usbd_type::ept_num
__IO uint32_t ept_num
Definition: at32f413_usb.h:587
usbd_type::rxsts
__IO uint32_t rxsts
Definition: at32f413_usb.h:544
usbd_type::beien
__IO uint32_t beien
Definition: at32f413_usb.h:572


AT32F413 Firmwary Library: at32f413_wdt.c Source File

  • libraries
  • drivers
  • src
at32f413_wdt.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef WDT_MODULE_ENABLED
39
49void wdt_enable(void)
50{
51 WDT->cmd = WDT_CMD_ENABLE;
52}
53
59void wdt_counter_reload(void)
60{
61 WDT->cmd = WDT_CMD_RELOAD;
62}
63
69void wdt_reload_value_set(uint16_t reload_value)
70{
71 WDT->rld = reload_value;
72}
73
87void wdt_divider_set(wdt_division_type division)
88{
89 WDT->div_bit.div = division;
90}
91
97void wdt_register_write_enable( confirm_state new_state)
98{
99 if(new_state == FALSE)
100 {
101 WDT->cmd = WDT_CMD_LOCK;
102 }
103 else
104 {
105 WDT->cmd = WDT_CMD_UNLOCK;
106 }
107}
108
117 flag_status wdt_flag_get(uint16_t wdt_flag)
118{
119 flag_status status = RESET;
120
121 if ((WDT->sts & wdt_flag) != (uint16_t)RESET)
122 {
123 status = SET;
124 }
125 else
126 {
127 status = RESET;
128 }
129
130 return status;
131}
132
137#endif
138
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
wdt_division_type
wdt_division_type
wdt division value type
Definition: at32f413_wdt.h:68
WDT_CMD_ENABLE
@ WDT_CMD_ENABLE
Definition: at32f413_wdt.h:85
WDT_CMD_UNLOCK
@ WDT_CMD_UNLOCK
Definition: at32f413_wdt.h:84
WDT_CMD_RELOAD
@ WDT_CMD_RELOAD
Definition: at32f413_wdt.h:86
WDT_CMD_LOCK
@ WDT_CMD_LOCK
Definition: at32f413_wdt.h:83
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f413_wdt.c:97
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f413_wdt.c:49
wdt_flag_get
flag_status wdt_flag_get(uint16_t wdt_flag)
get wdt flag
Definition: at32f413_wdt.c:117
wdt_counter_reload
void wdt_counter_reload(void)
reload wdt counter
Definition: at32f413_wdt.c:59
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f413_wdt.c:69
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f413_wdt.c:87
WDT
#define WDT
Definition: at32f413_wdt.h:154
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_wdt.h Source File

  • libraries
  • drivers
  • inc
at32f413_wdt.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_WDT_H
29#define __AT32F413_WDT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
53#define WDT_DIVF_UPDATE_FLAG ((uint16_t)0x0001)
54#define WDT_RLDF_UPDATE_FLAG ((uint16_t)0x0002)
67typedef enum
68{
69 WDT_CLK_DIV_4 = 0x00,
70 WDT_CLK_DIV_8 = 0x01,
71 WDT_CLK_DIV_16 = 0x02,
72 WDT_CLK_DIV_32 = 0x03,
73 WDT_CLK_DIV_64 = 0x04,
74 WDT_CLK_DIV_128 = 0x05,
75 WDT_CLK_DIV_256 = 0x06
76} wdt_division_type;
77
81typedef enum
82{
83 WDT_CMD_LOCK = 0x0000,
84 WDT_CMD_UNLOCK = 0x5555,
85 WDT_CMD_ENABLE = 0xCCCC,
86 WDT_CMD_RELOAD = 0xAAAA
87} wdt_cmd_value_type;
88
92typedef struct
93{
94
98 union
99 {
100 __IO uint32_t cmd;
101 struct
102 {
103 __IO uint32_t cmd : 16;/* [15:0] */
104 __IO uint32_t reserved1 : 16;/* [31:16] */
105 } cmd_bit;
106 };
107
111 union
112 {
113 __IO uint32_t div;
114 struct
115 {
116 __IO uint32_t div : 3; /* [2:0] */
117 __IO uint32_t reserved1 : 29;/* [31:3] */
118 } div_bit;
119 };
120
124 union
125 {
126 __IO uint32_t rld;
127 struct
128 {
129 __IO uint32_t rld : 12;/* [11:0] */
130 __IO uint32_t reserved1 : 20;/* [31:12] */
131 } rld_bit;
132 };
133
137 union
138 {
139 __IO uint32_t sts;
140 struct
141 {
142 __IO uint32_t divf : 1; /* [0] */
143 __IO uint32_t rldf : 1; /* [1] */
144 __IO uint32_t reserved1 : 30;/* [31:2] */
145 } sts_bit;
146 };
147
148} wdt_type;
149
154#define WDT ((wdt_type *) WDT_BASE)
155
160void wdt_enable(void);
161void wdt_counter_reload(void);
162void wdt_reload_value_set(uint16_t reload_value);
163void wdt_divider_set(wdt_division_type division);
164void wdt_register_write_enable( confirm_state new_state);
165 flag_status wdt_flag_get(uint16_t wdt_flag);
166
179#ifdef __cplusplus
180}
181#endif
182
183#endif
at32f413.h
at32f413 header file
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
flag_status
flag_status
flag status
Definition: at32f413.h:254
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f413_wdt.c:97
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f413_wdt.c:49
wdt_flag_get
flag_status wdt_flag_get(uint16_t wdt_flag)
get wdt flag
Definition: at32f413_wdt.c:117
wdt_counter_reload
void wdt_counter_reload(void)
reload wdt counter
Definition: at32f413_wdt.c:59
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f413_wdt.c:69
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f413_wdt.c:87
wdt_cmd_value_type
wdt_cmd_value_type
wdt cmd value type
Definition: at32f413_wdt.h:82
wdt_division_type
wdt_division_type
wdt division value type
Definition: at32f413_wdt.h:68
WDT_CMD_ENABLE
@ WDT_CMD_ENABLE
Definition: at32f413_wdt.h:85
WDT_CMD_UNLOCK
@ WDT_CMD_UNLOCK
Definition: at32f413_wdt.h:84
WDT_CMD_RELOAD
@ WDT_CMD_RELOAD
Definition: at32f413_wdt.h:86
WDT_CMD_LOCK
@ WDT_CMD_LOCK
Definition: at32f413_wdt.h:83
WDT_CLK_DIV_64
@ WDT_CLK_DIV_64
Definition: at32f413_wdt.h:73
WDT_CLK_DIV_8
@ WDT_CLK_DIV_8
Definition: at32f413_wdt.h:70
WDT_CLK_DIV_256
@ WDT_CLK_DIV_256
Definition: at32f413_wdt.h:75
WDT_CLK_DIV_4
@ WDT_CLK_DIV_4
Definition: at32f413_wdt.h:69
WDT_CLK_DIV_16
@ WDT_CLK_DIV_16
Definition: at32f413_wdt.h:71
WDT_CLK_DIV_32
@ WDT_CLK_DIV_32
Definition: at32f413_wdt.h:72
WDT_CLK_DIV_128
@ WDT_CLK_DIV_128
Definition: at32f413_wdt.h:74
wdt_type
type define wdt register all
Definition: at32f413_wdt.h:93
wdt_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_wdt.h:104
wdt_type::div
__IO uint32_t div
Definition: at32f413_wdt.h:113
wdt_type::divf
__IO uint32_t divf
Definition: at32f413_wdt.h:142
wdt_type::rld
__IO uint32_t rld
Definition: at32f413_wdt.h:126
wdt_type::rldf
__IO uint32_t rldf
Definition: at32f413_wdt.h:143
wdt_type::sts
__IO uint32_t sts
Definition: at32f413_wdt.h:139
wdt_type::cmd
__IO uint32_t cmd
Definition: at32f413_wdt.h:100


AT32F413 Firmwary Library: at32f413_wwdt.c Source File

  • libraries
  • drivers
  • src
at32f413_wwdt.c
Go to the documentation of this file.
1
27#include "at32f413_conf.h"
28
38#ifdef WWDT_MODULE_ENABLED
39
48void wwdt_reset(void)
49{
50 crm_periph_reset(CRM_WWDT_PERIPH_RESET, TRUE);
51 crm_periph_reset(CRM_WWDT_PERIPH_RESET, FALSE);
52}
53
64void wwdt_divider_set(wwdt_division_type division)
65{
66 WWDT->cfg_bit.div = division;
67}
68
74void wwdt_flag_clear(void)
75{
76 WWDT->sts = 0;
77}
78
84void wwdt_enable(uint8_t wwdt_cnt)
85{
86 WWDT->ctrl = wwdt_cnt | WWDT_EN_BIT;
87}
88
94void wwdt_interrupt_enable(void)
95{
96 WWDT->cfg_bit.rldien = TRUE;
97}
98
104 flag_status wwdt_flag_get(void)
105{
106 return (flag_status)WWDT->sts_bit.rldf;
107}
108
114void wwdt_counter_set(uint8_t wwdt_cnt)
115{
116 WWDT->ctrl_bit.cnt = wwdt_cnt;
117}
118
124void wwdt_window_counter_set(uint8_t window_cnt)
125{
126 WWDT->cfg_bit.win = window_cnt;
127}
128
133#endif
134
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
CRM_WWDT_PERIPH_RESET
@ CRM_WWDT_PERIPH_RESET
Definition: at32f413_crm.h:174
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
WWDT_EN_BIT
#define WWDT_EN_BIT
Definition: at32f413_wwdt.h:52
wwdt_division_type
wwdt_division_type
wwdt division type
Definition: at32f413_wwdt.h:66
wwdt_counter_set
void wwdt_counter_set(uint8_t wwdt_cnt)
wwdt counter value set
Definition: at32f413_wwdt.c:114
wwdt_flag_clear
void wwdt_flag_clear(void)
wwdt reload counter interrupt flag clear
Definition: at32f413_wwdt.c:74
wwdt_interrupt_enable
void wwdt_interrupt_enable(void)
wwdt reload counter interrupt enable
Definition: at32f413_wwdt.c:94
wwdt_divider_set
void wwdt_divider_set(wwdt_division_type division)
wwdt division set
Definition: at32f413_wwdt.c:64
wwdt_reset
void wwdt_reset(void)
wwdt reset by crm reset register
Definition: at32f413_wwdt.c:48
wwdt_window_counter_set
void wwdt_window_counter_set(uint8_t window_cnt)
wwdt window counter value set
Definition: at32f413_wwdt.c:124
wwdt_flag_get
flag_status wwdt_flag_get(void)
wwdt reload counter interrupt flag get
Definition: at32f413_wwdt.c:104
wwdt_enable
void wwdt_enable(uint8_t wwdt_cnt)
wwdt enable and the counter value load
Definition: at32f413_wwdt.c:84
WWDT
#define WWDT
Definition: at32f413_wwdt.h:127
at32f413_conf.h
at32f413 config header file


AT32F413 Firmwary Library: at32f413_wwdt.h Source File

  • libraries
  • drivers
  • inc
at32f413_wwdt.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_WWDT_H
29#define __AT32F413_WWDT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
52#define WWDT_EN_BIT ((uint32_t)0x00000080)
65typedef enum
66{
67 WWDT_PCLK1_DIV_4096 = 0x00,
68 WWDT_PCLK1_DIV_8192 = 0x01,
69 WWDT_PCLK1_DIV_16384 = 0x02,
70 WWDT_PCLK1_DIV_32768 = 0x03
71} wwdt_division_type;
72
76typedef struct
77{
78
82 union
83 {
84 __IO uint32_t ctrl;
85 struct
86 {
87 __IO uint32_t cnt : 7; /* [6:0] */
88 __IO uint32_t wwdten : 1; /* [7] */
89 __IO uint32_t reserved1 : 24;/* [31:8] */
90 } ctrl_bit;
91 };
92
96 union
97 {
98 __IO uint32_t cfg;
99 struct
100 {
101 __IO uint32_t win : 7; /* [6:0] */
102 __IO uint32_t div : 2; /* [8:7] */
103 __IO uint32_t rldien : 1; /* [9] */
104 __IO uint32_t reserved1 : 22;/* [31:10] */
105 } cfg_bit;
106 };
107
111 union
112 {
113 __IO uint32_t sts;
114 struct
115 {
116 __IO uint32_t rldf : 1; /* [0] */
117 __IO uint32_t reserved1 : 31;/* [31:1] */
118 } sts_bit;
119 };
120
121} wwdt_type;
122
127#define WWDT ((wwdt_type *) WWDT_BASE)
128
133void wwdt_reset(void);
134void wwdt_divider_set(wwdt_division_type division);
135void wwdt_flag_clear(void);
136void wwdt_enable(uint8_t wwdt_cnt);
137void wwdt_interrupt_enable(void);
138 flag_status wwdt_flag_get(void);
139void wwdt_counter_set(uint8_t wwdt_cnt);
140void wwdt_window_counter_set(uint8_t window_cnt);
141
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413.h
at32f413 header file
flag_status
flag_status
flag status
Definition: at32f413.h:254
wwdt_counter_set
void wwdt_counter_set(uint8_t wwdt_cnt)
wwdt counter value set
Definition: at32f413_wwdt.c:114
wwdt_flag_clear
void wwdt_flag_clear(void)
wwdt reload counter interrupt flag clear
Definition: at32f413_wwdt.c:74
wwdt_interrupt_enable
void wwdt_interrupt_enable(void)
wwdt reload counter interrupt enable
Definition: at32f413_wwdt.c:94
wwdt_divider_set
void wwdt_divider_set(wwdt_division_type division)
wwdt division set
Definition: at32f413_wwdt.c:64
wwdt_reset
void wwdt_reset(void)
wwdt reset by crm reset register
Definition: at32f413_wwdt.c:48
wwdt_window_counter_set
void wwdt_window_counter_set(uint8_t window_cnt)
wwdt window counter value set
Definition: at32f413_wwdt.c:124
wwdt_flag_get
flag_status wwdt_flag_get(void)
wwdt reload counter interrupt flag get
Definition: at32f413_wwdt.c:104
wwdt_enable
void wwdt_enable(uint8_t wwdt_cnt)
wwdt enable and the counter value load
Definition: at32f413_wwdt.c:84
wwdt_division_type
wwdt_division_type
wwdt division type
Definition: at32f413_wwdt.h:66
WWDT_PCLK1_DIV_16384
@ WWDT_PCLK1_DIV_16384
Definition: at32f413_wwdt.h:69
WWDT_PCLK1_DIV_8192
@ WWDT_PCLK1_DIV_8192
Definition: at32f413_wwdt.h:68
WWDT_PCLK1_DIV_32768
@ WWDT_PCLK1_DIV_32768
Definition: at32f413_wwdt.h:70
WWDT_PCLK1_DIV_4096
@ WWDT_PCLK1_DIV_4096
Definition: at32f413_wwdt.h:67
wwdt_type
type define wwdt register all
Definition: at32f413_wwdt.h:77
wwdt_type::div
__IO uint32_t div
Definition: at32f413_wwdt.h:102
wwdt_type::win
__IO uint32_t win
Definition: at32f413_wwdt.h:101
wwdt_type::cfg
__IO uint32_t cfg
Definition: at32f413_wwdt.h:98
wwdt_type::cnt
__IO uint32_t cnt
Definition: at32f413_wwdt.h:87
wwdt_type::wwdten
__IO uint32_t wwdten
Definition: at32f413_wwdt.h:88
wwdt_type::sts
__IO uint32_t sts
Definition: at32f413_wwdt.h:113
wwdt_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_wwdt.h:84
wwdt_type::reserved1
__IO uint32_t reserved1
Definition: at32f413_wwdt.h:89
wwdt_type::rldien
__IO uint32_t rldien
Definition: at32f413_wwdt.h:103
wwdt_type::rldf
__IO uint32_t rldf
Definition: at32f413_wwdt.h:116


AT32F413 Firmwary Library: audio_conf.h Source File

  • middlewares
  • usbd_class
  • audio
audio/audio_conf.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CONF_H
29#define __AUDIO_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
47#define AUDIO_SUPPORT_SPK 1
48#define AUDIO_SUPPORT_MIC 1
49#define AUDIO_SUPPORT_FEEDBACK 1
50
51#define AUDIO_SUPPORT_FREQ_16K 1
52#define AUDIO_SUPPORT_FREQ_48K 1
53
54
55#define AUDIO_SUPPORT_FREQ (AUDIO_SUPPORT_FREQ_16K + \
56 AUDIO_SUPPORT_FREQ_48K \
57 )
58
59#define AUDIO_FREQ_16K 16000
60#define AUDIO_FREQ_48K 48000
61#define AUDIO_BITW_16 16
62
63#define AUDIO_MIC_CHANEL_NUM 2
64#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
65
66#define AUDIO_SPK_CHANEL_NUM 2
67#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
68
69
70#define AUDIO_SUPPORT_MAX_FREQ 48
71#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
72#define AUDIO_DEFAULT_BITW AUDIO_BITW_16
73
85#ifdef __cplusplus
86}
87#endif
88
89#endif
90
91
92


AT32F413 Firmwary Library: audio_codec.h Source File

  • usb_device
  • audio
  • inc
audio/inc/audio_codec.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CODEC_H
29#define __AUDIO_CODEC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
44/* includes ------------------------------------------------------------------*/
45#include "at32f413.h"
46
50#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
51#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
52#define WM8988_R2_LOUT1_VOLUME 0x02
53#define WM8988_R3_ROUT1_VOLUME 0x03
54#define WM8988_R4_RESERVED 0x04
55#define WM8988_R5_ADC_DAC_CONTROL 0x05
56#define WM8988_R6_RESERVED 0x06
57#define WM8988_R7_AUDIO_INTERFACE 0x07
58#define WM8988_R8_SAMPLE_RATE 0x08
59#define WM8988_R9_RESERVED 0x09
60#define WM8988_R10_LEFT_DAC_VOLUME 0x0A
61#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B
62#define WM8988_R12_BASS_CONTROL 0x0C
63#define WM8988_R13_TREBLE_CONTROL 0x0D
64#define WM8988_R14_
65#define WM8988_R15_RESET 0x0F
66#define WM8988_R16_3D_CONTROL 0x10
67#define WM8988_R17_ALC1 0x11
68#define WM8988_R18_ALC2 0x12
69#define WM8988_R19_ALC3 0x13
70#define WM8988_R20_NOISE_GATE 0x14
71#define WM8988_R21_LEFT_ADC_VOLUME 0x15
72#define WM8988_R22_RIGHT_ADC_VOLUME 0x16
73#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17
74#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18
75#define WM8988_R25_PWR_1_MGMT 0x19
76#define WM8988_R26_PWR_2_MGMT 0x1A
77#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
78
79#define WM8988_R31_ADC_INPUT_MODE 0x1F
80#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20
81#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21
82#define WM8988_R34_LEFT_OUT_MIX_1 0x22
83#define WM8988_R35_LEFT_OUT_MIX_2 0x23
84#define WM8988_R36_RIGHT_OUT_MIX_1 0x24
85#define WM8988_R37_RIGHT_OUT_MIX_2 0x25
86#define WM8988_R38_RESERVED
87#define WM8988_R39_RESERVED
88#define WM8988_R40_LOUT2_VOLUME 0x28
89#define WM8988_R41_ROUT2_VOLUME 0x29
90#define WM8988_R42_RESERVED
91#define WM8988_R43_LOW_POWER_PALYBACK 0x43
92
93#define WM8988_I2C_ADDR_CSB_LOW 0x34
94#define WM8988_I2C_ADDR_CSB_HIGH 0x36
95
103#define I2S1_WS_PIN GPIO_PINS_4
104#define I2S1_CK_PIN GPIO_PINS_5
105#define I2S1_SD_PIN GPIO_PINS_7
106#define I2S1_GPIO GPIOA
107#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
108#define I2S1_DT_ADDRESS (&(SPI1->dt))
109
110/*I2S2 Pin*/
111#define I2S2_WS_PIN GPIO_PINS_12
112#define I2S2_CK_PIN GPIO_PINS_13
113#define I2S2_SD_PIN GPIO_PINS_15
114#define I2S2_GPIO GPIOB
115#define I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
116#define I2S2_DT_ADDRESS (&(SPI2->dt))
117
118#define SPK_TX_FIFO_SIZE (1024 * 4)
119
127#define MIC_BUFFER_SIZE 1024
128#define SPK_BUFFER_SIZE 4096
129#define DMA_BUFFER_SIZE 288
130
131typedef struct
132{
133 uint32_t audio_freq;
134 uint32_t audio_bitw;
135 //spk part
136 uint16_t spk_buffer[SPK_BUFFER_SIZE];
137 uint16_t *spk_roff;
138 uint16_t *spk_woff;
139 uint16_t *spk_rend;
140 uint32_t spk_freq;
141 uint32_t spk_wtotal;
142 uint32_t spk_rtotal;
143 uint16_t spk_threshold;
144 uint16_t spk_calc;
145 uint8_t spk_stage;
146
147 //mic part
148 uint16_t mic_buffer[MIC_BUFFER_SIZE];
149 uint16_t *mic_roff;
150 uint16_t *mic_woff;
151 uint16_t *mic_wend;
152 uint32_t mic_wtotal;
153 uint32_t mic_rtotal;
154 uint32_t mic_delta;
155 uint16_t mic_calc;
156 uint16_t mic_adj_count;
157 uint8_t mic_adj_stage;
158 uint8_t mic_stage;
159
160 uint8_t mic_mute;
161 uint8_t spk_mute;
162
163 uint16_t mic_volume;
164 uint16_t spk_volume;
165
166 uint32_t spk_tx_size;
167 uint32_t mic_rx_size;
168
169 uint32_t spk_enable;
170 uint32_t mic_enable;
171
172}audio_codec_type;
173
174 error_status audio_codec_init(void);
175 error_status audio_codec_loop(void);
176void audio_codec_modify_freq(uint32_t freq);
177
181void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len);
182uint32_t audio_codec_mic_get_data(uint8_t *buffer);
183uint8_t audio_codec_spk_feedback(uint8_t *feedback);
184void audio_codec_spk_alt_setting(uint32_t alt_seting);
185void audio_codec_mic_alt_setting(uint32_t alt_seting);
186void audio_codec_set_mic_mute(uint8_t mute);
187void audio_codec_set_spk_mute(uint8_t mute);
188void audio_codec_set_mic_volume(uint16_t volume);
189void audio_codec_set_spk_volume(uint16_t volume);
190void audio_codec_set_mic_freq(uint32_t freq);
191void audio_codec_set_spk_freq(uint32_t freq);
202#ifdef __cplusplus
203}
204#endif
205
206#endif
207
at32f413.h
at32f413 header file
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
error_status
error_status
error status
Definition: at32f413.h:264
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:169
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:217
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:195
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:127
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:121
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:282
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:853
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:128
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:184
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: audio/src/audio_codec.c:244
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:228
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: audio/src/audio_codec.c:342
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:206
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:154
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:794
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:137
audio_codec_type
Definition: audio/inc/audio_codec.h:132
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: audio/inc/audio_codec.h:161
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: audio/inc/audio_codec.h:143
audio_codec_type::mic_enable
uint32_t mic_enable
Definition: audio/inc/audio_codec.h:170
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: audio/inc/audio_codec.h:145
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: audio/inc/audio_codec.h:149
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: audio/inc/audio_codec.h:163
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: audio/inc/audio_codec.h:137
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: audio/inc/audio_codec.h:142
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: audio/inc/audio_codec.h:154
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: audio/inc/audio_codec.h:144
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: audio/inc/audio_codec.h:150
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: audio/inc/audio_codec.h:158
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: audio/inc/audio_codec.h:156
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: audio/inc/audio_codec.h:140
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: audio/inc/audio_codec.h:134
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: audio/inc/audio_codec.h:151
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: audio/inc/audio_codec.h:139
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: audio/inc/audio_codec.h:152
audio_codec_type::spk_enable
uint32_t spk_enable
Definition: audio/inc/audio_codec.h:169
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: audio/inc/audio_codec.h:153
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: audio/inc/audio_codec.h:133
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: audio/inc/audio_codec.h:160
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: audio/inc/audio_codec.h:164
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: audio/inc/audio_codec.h:155
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: audio/inc/audio_codec.h:141
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: audio/inc/audio_codec.h:157
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: audio/inc/audio_codec.h:166
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: audio/inc/audio_codec.h:167
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: audio/inc/audio_codec.h:138


AT32F413 Firmwary Library: audio_codec.c Source File

  • usb_device
  • audio
  • src
audio/src/audio_codec.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "audio_codec.h"
29#include "i2c_application.h"
30#include "audio_conf.h"
31#include <string.h>
32
41#define I2C_TIMEOUT 0xFFFFFFFF
42
43#define I2Cx_SPEED 100000
44#define I2Cx_ADDRESS 0x00
45
46#define I2Cx_PORT I2C1
47#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
48
49#define I2Cx_SCL_PIN GPIO_PINS_8
50#define I2Cx_SCL_GPIO_PORT GPIOB
51#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
52
53#define I2Cx_SDA_PIN GPIO_PINS_9
54#define I2Cx_SDA_GPIO_PORT GPIOB
55#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
56
60#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
61#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
62
66#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
67
71uint16_t reg_addr_data[] =
72{
73 (WM8988_R0_LEFT_INPUT_VOLUME << 9) | 0x012F, /*Left Input Channel Volume*/
74 (WM8988_R1_RIGHT_INPUT_VOLUME << 9) | 0x012F, /*Right Input Channel Volume*/
75 (WM8988_R2_LOUT1_VOLUME << 9) | 0x0179, /*Left Output Channel Volume*/
76 (WM8988_R3_ROUT1_VOLUME << 9) | 0x0179, /*Right Output Channel Volume*/
77 (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006, /*De-emphasis Control and Digital soft mute*/
78 (WM8988_REG_BITW16),
79 (WM8988_REG_FREQ16K),
80 (WM8988_R10_LEFT_DAC_VOLUME << 9) | 0x01FF, /*Left Digital DAC Volume Control*/
81 (WM8988_R11_RIGHT_DAC_VOLUME << 9) | 0x01FF, /*Right Digital DAC Volume Control*/
82 (WM8988_R12_BASS_CONTROL << 9) | 0x000F, /*Bass Control*/
83 (WM8988_R13_TREBLE_CONTROL << 9) | 0x000F, /*Treble Control*/
84 (WM8988_R16_3D_CONTROL << 9) | 0x0000, /*3D stereo Enhancment*/
85 (WM8988_R21_LEFT_ADC_VOLUME << 9) | 0x01C3, /*Left ADC Digital Volume*/
86 (WM8988_R22_RIGHT_ADC_VOLUME << 9) | 0x01C3, /*Right ADC Digital Volume*/
87 (WM8988_R23_ADDITIONAL_1_CONTROL << 9) | 0x00C2, /*Additional Control 1*/
88 (WM8988_R24_ADDITIONAL_2_CONTROL << 9) | 0x0000, /*Additional Control 2*/
89 (WM8988_R27_ADDITIONAL_3_CONTROL << 9) | 0x0000, /*Additional Control 3*/
90 (WM8988_R31_ADC_INPUT_MODE << 9) | 0x0000, /*ADC input mode*/
91 (WM8988_R32_ADC_L_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control left*/
92 (WM8988_R33_ADC_R_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control right*/
93 (WM8988_R34_LEFT_OUT_MIX_1 << 9) | 0x0152, /*Left DAC mixer Control*/
94 (WM8988_R35_LEFT_OUT_MIX_2 << 9) | 0x0050, /*Left DAC mixer Control*/
95 (WM8988_R36_RIGHT_OUT_MIX_1 << 9) | 0x0052, /*Right DAC mixer Control*/
96 (WM8988_R37_RIGHT_OUT_MIX_2 << 9) | 0x0150, /*Right DAC mixer Control*/
97 (WM8988_R40_LOUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
98 (WM8988_R41_ROUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
99 (WM8988_R43_LOW_POWER_PALYBACK << 9) | 0x0008, /*Output left channel volume*/
100 (WM8988_R25_PWR_1_MGMT << 9) | 0x017C, /*Power Management1*/
101 (WM8988_R26_PWR_2_MGMT << 9) | 0x01F8, /*Power Management2*/
102};
103
104 i2c_handle_type hi2cx;
105
106 audio_codec_type audio_codec;
107uint16_t spk_dma_buffer[DMA_BUFFER_SIZE];
108uint16_t mic_dma_buffer[DMA_BUFFER_SIZE];
109
110void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len);
111void codec_i2s_reset(void);
112void codec_i2s_init(audio_codec_type *param);
113void mclk_tmr1_init(void);
114void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len);
115
121void audio_codec_set_mic_freq(uint32_t freq)
122{
123 if(audio_codec.audio_freq != freq)
124 {
125 audio_codec.audio_freq = freq;
126 codec_i2s_reset();
127 audio_codec_modify_freq(freq);
128 codec_i2s_init(&audio_codec);
129 }
130}
131
137void audio_codec_set_spk_freq(uint32_t freq)
138{
139 if(audio_codec.audio_freq != freq)
140 {
141 audio_codec.audio_freq = freq;
142 codec_i2s_reset();
143 audio_codec_modify_freq(freq);
144 codec_i2s_init(&audio_codec);
145 }
146}
147
148
154void audio_codec_spk_alt_setting(uint32_t alt_seting)
155{
156 if(alt_seting == 0)
157 {
158 }
159 else
160 {
161 }
162}
163
169void audio_codec_mic_alt_setting(uint32_t alt_seting)
170{
171 if(alt_seting == 0)
172 {
173 }
174 else
175 {
176 }
177}
178
184void audio_codec_set_mic_mute(uint8_t mute)
185{
186 audio_codec.mic_mute = mute;
187}
188
189
195void audio_codec_set_spk_mute(uint8_t mute)
196{
197 audio_codec.spk_mute = mute;
198}
199
200
206void audio_codec_set_mic_volume(uint16_t volume)
207{
208 /* wm8988 adc have 256 steps */
209 audio_codec.mic_volume = volume;
210}
211
217void audio_codec_set_spk_volume(uint16_t volume)
218{
219 /* wm8988 dac have 80 steps */
220 audio_codec.spk_volume = (volume * 0x50) / 0x64 + 0x30 - 1;
221}
222
228uint8_t audio_codec_spk_feedback(uint8_t *feedback)
229{
230 uint32_t feedback_value = (audio_codec.spk_freq);
231 feedback_value = ((feedback_value/1000)<<14)|((feedback_value%1000)<<4);
232 feedback[0] = (uint8_t)(feedback_value);
233 feedback[1] = (uint8_t)(feedback_value >> 8);
234 feedback[2] = (uint8_t)(feedback_value >> 16);
235 return 3;
236}
237
244void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
245{
246 uint16_t ulen = len / 2, i;
247 uint16_t *u16data = (uint16_t *)data;
248
249 switch(audio_codec.spk_stage)
250 {
251 case 0:
252 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
253 audio_codec.spk_wtotal = audio_codec.spk_rtotal = 0;
254 audio_codec.spk_stage = 1;
255 audio_codec.spk_threshold = SPK_BUFFER_SIZE/2;
256 break;
257 case 1:
258 if( audio_codec.spk_wtotal >= SPK_BUFFER_SIZE/2 )
259 {
260 audio_codec.spk_stage = 2;
261 }
262 break;
263 case 2:
264 break;
265 }
266 for( i = 0; i < ulen; ++i )
267 {
268 *audio_codec.spk_woff++ = *u16data++;
269 if( audio_codec.spk_woff >= audio_codec.spk_rend )
270 {
271 audio_codec.spk_woff = audio_codec.spk_buffer;
272 }
273 }
274 audio_codec.spk_wtotal += ulen;
275}
276
282uint32_t audio_codec_mic_get_data(uint8_t *buffer)
283{
284 //copy_buff((uint16_t *)buffer, audio_codec.mic_buffer + audio_codec.mic_hf_status, audio_codec.mic_rx_size);
285 uint16_t len = audio_codec.mic_rx_size << 1;
286 uint16_t i;
287 uint16_t* u16buf = (uint16_t*)buffer;
288 switch(audio_codec.mic_stage)
289 {
290 case 0:
291 audio_codec.mic_stage = 1;
292 memset( buffer, 0, len );
293 return len;
294 case 1:
295 if( audio_codec.mic_wtotal - audio_codec.mic_rtotal >= MIC_BUFFER_SIZE/2 )
296 {
297 audio_codec.mic_stage = 2;
298 }
299 return len;
300 }
301 switch( audio_codec.mic_adj_stage )
302 {
303 case 0:
304 break;
305 case 1:
306 if( audio_codec.mic_adj_count >= 4 ){
307 len += 4;
308 audio_codec.mic_adj_count -= 4;
309 }
310 break;
311 case 2:
312 if( audio_codec.mic_adj_count >= 4 ){
313 len -= 4;
314 audio_codec.mic_adj_count -= 4;
315 }
316 break;
317 }
318
319 for( i = 0; i < len/2; ++i )
320 {
321 *u16buf++ = *audio_codec.mic_roff++;
322 if( audio_codec.mic_roff >= audio_codec.mic_wend )
323 {
324 audio_codec.mic_roff = audio_codec.mic_buffer;
325 }
326 }
327 if( audio_codec.mic_wtotal <= audio_codec.mic_rtotal )
328 { //should not happen
329 while(1);
330 }
331
332 audio_codec.mic_rtotal += len/2;
333 audio_codec.mic_delta += len/2;
334 return len;
335}
336
342void audio_codec_modify_freq(uint32_t freq)
343{
344 uint16_t codec_cmd;
345 uint8_t i2c_cmd[2];
346 if(freq == AUDIO_FREQ_16K)
347 {
348 codec_cmd = WM8988_REG_FREQ16K;
349 }
350 else if(freq == AUDIO_FREQ_48K)
351 {
352 codec_cmd = WM8988_REG_FREQ48K;
353 }
354 i2c_cmd[0] = (uint8_t)(codec_cmd >> 8);
355 i2c_cmd[1] = (uint8_t)codec_cmd & 0xFF;
356 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
357 {
358 while(1);
359 }
360}
361
369void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
370{
371 uint32_t i_index = 0;
372 for(i_index = 0; i_index < len; i_index ++)
373 {
374 buffer[i_index] = (uint16_t)set;
375 }
376}
377
385void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
386{
387 uint16_t i_index;
388 for(i_index = 0; i_index < len; i_index ++)
389 {
390 dest[i_index] = src[i_index];
391 }
392}
393
399void i2c_lowlevel_init(i2c_handle_type* hi2c)
400{
401 gpio_init_type gpio_initstructure;
402
403 if(hi2c->i2cx == I2Cx_PORT)
404 {
405 /* i2c periph clock enable */
406 crm_periph_clock_enable(I2Cx_CLK, TRUE);
407 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
408 gpio_pin_remap_config(I2C1_MUX, TRUE);
409 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
410 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
411
412 /* gpio configuration */
413 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
414 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
415 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
416 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
417
418 /* configure i2c pins: scl */
419 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
420 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
421
422 /* configure i2c pins: sda */
423 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
424 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
425
426 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
427
428 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
429 }
430}
431
437void mclk_tmr1_init(void)
438{
439 gpio_init_type gpio_init_struct;
440 tmr_output_config_type tmr_oc_init_structure;
441 uint16_t prescaler_value = (uint16_t)(system_core_clock / 24000000) - 1;
442
443 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
444 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
445 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
446
447 gpio_default_para_init(&gpio_init_struct);
448
449 gpio_init_struct.gpio_pins = GPIO_PINS_8;
450 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
451 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
452 gpio_init(GPIOA, &gpio_init_struct);
453
454 tmr_base_init(TMR1, 1, prescaler_value);
455 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
456 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
457
458 tmr_output_default_para_init(&tmr_oc_init_structure);
459 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
460 tmr_oc_init_structure.oc_idle_state = FALSE;
461 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
462 tmr_oc_init_structure.oc_output_state = TRUE;
463 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
464 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 1);
465 tmr_output_channel_buffer_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
466
467 /* tmr enable counter */
468 tmr_counter_enable(TMR1, TRUE);
469 tmr_output_enable(TMR1, TRUE);
470}
471
472
478void codec_i2s_reset(void)
479{
480 i2s_enable(SPI1, FALSE);
481 i2s_enable(SPI2, FALSE);
482 dma_channel_enable(DMA1_CHANNEL3, FALSE);
483 dma_channel_enable(DMA1_CHANNEL4, FALSE);
484}
485
492void codec_i2s_init(audio_codec_type *param)
493{
494 gpio_init_type gpio_init_struct;
495 dma_init_type dma_init_struct;
496 i2s_init_type i2s_init_struct;
497 i2s_data_channel_format_type format = I2S_DATA_16BIT_CHANNEL_16BIT;
498
499 crm_periph_clock_enable(I2S1_GPIO_CRM_CLK, TRUE);
500 crm_periph_clock_enable(I2S2_GPIO_CRM_CLK, TRUE);
501 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
502 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
503 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
504
505 param->spk_freq = param->audio_freq;
506
507 param->spk_tx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_SPK_CHANEL_NUM / 2;
508 param->mic_rx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_MIC_CHANEL_NUM / 2;
509
510 memset(param->spk_buffer, 0, SPK_BUFFER_SIZE*sizeof(uint16_t));
511 memset(param->mic_buffer, 0, MIC_BUFFER_SIZE*sizeof(uint16_t));
512
513 param->mic_wend = param->mic_woff = param->mic_roff = param->mic_buffer;
514 param->spk_rend = param->spk_woff = param->spk_roff = param->spk_buffer;
515
516 while(param->mic_wend < param->mic_buffer+MIC_BUFFER_SIZE)
517 {
518 param->mic_wend += param->mic_rx_size;
519 }
520 param->mic_wend -= param->mic_rx_size;
521 while(param->spk_rend < param->spk_buffer+SPK_BUFFER_SIZE)
522 {
523 param->spk_rend += param->spk_tx_size;
524 }
525 param->spk_rend -= param->spk_tx_size;
526 if(param->audio_bitw == 16)
527 {
528 format = I2S_DATA_16BIT_CHANNEL_16BIT;
529 }
530 else
531 {
532 format = I2S_DATA_24BIT_CHANNEL_32BIT;
533 }
534 gpio_default_para_init(&gpio_init_struct);
535
536 /* i2s1 ws pins */
537 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
538 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
539 gpio_init_struct.gpio_pins = I2S1_WS_PIN;
540 gpio_init(I2S1_GPIO, &gpio_init_struct);
541
542 /* i2s1 ck pins */
543 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
544 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
545 gpio_init_struct.gpio_pins = I2S1_CK_PIN;
546 gpio_init(I2S1_GPIO, &gpio_init_struct);
547
548 /* i2s1 sd pins slave tx */
549 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
550 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
551 gpio_init_struct.gpio_pins = I2S1_SD_PIN;
552 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
553 gpio_init(I2S1_GPIO, &gpio_init_struct);
554
555 /* i2s2 ws pins */
556 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
557 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
558 gpio_init_struct.gpio_pins = I2S2_WS_PIN;
559 gpio_init(I2S2_GPIO, &gpio_init_struct);
560
561 /* i2s2 ck pins */
562 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
563 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
564 gpio_init_struct.gpio_pins = I2S2_CK_PIN;
565 gpio_init(I2S2_GPIO, &gpio_init_struct);
566
567 /* i2s2 sd pins slave rx */
568 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
569 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
570 gpio_init_struct.gpio_pins = I2S2_SD_PIN;
571 gpio_init(I2S2_GPIO, &gpio_init_struct);
572
573 /* dma config */
574 dma_reset(DMA1_CHANNEL3);
575 dma_reset(DMA1_CHANNEL4);
576
577 /* dma1 channel3: speaker i2s1 tx */
578 dma_default_para_init(&dma_init_struct);
579 dma_init_struct.buffer_size = param->spk_tx_size << 1;
580 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
581 dma_init_struct.memory_base_addr = (uint32_t)spk_dma_buffer;
582 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
583 dma_init_struct.memory_inc_enable = TRUE;
584 dma_init_struct.peripheral_base_addr = (uint32_t)I2S1_DT_ADDRESS;
585 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
586 dma_init_struct.peripheral_inc_enable = FALSE;
587 dma_init_struct.priority = DMA_PRIORITY_HIGH;
588 dma_init_struct.loop_mode_enable = TRUE;
589 dma_init(DMA1_CHANNEL3, &dma_init_struct);
590 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
591 dma_interrupt_enable(DMA1_CHANNEL3, DMA_HDT_INT, TRUE);
592 nvic_irq_enable(DMA1_Channel3_IRQn, 1, 0);
593
594 /* dma1 channel4: microphone i2s2 rx */
595 dma_default_para_init(&dma_init_struct);
596 dma_init_struct.buffer_size = param->mic_rx_size << 1;
597 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
598 dma_init_struct.memory_base_addr = (uint32_t)mic_dma_buffer;
599 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
600 dma_init_struct.memory_inc_enable = TRUE;
601 dma_init_struct.peripheral_base_addr = (uint32_t)I2S2_DT_ADDRESS;
602 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
603 dma_init_struct.peripheral_inc_enable = FALSE;
604 dma_init_struct.priority = DMA_PRIORITY_HIGH;
605 dma_init_struct.loop_mode_enable = TRUE;
606 dma_init(DMA1_CHANNEL4, &dma_init_struct);
607 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
608 dma_interrupt_enable(DMA1_CHANNEL4, DMA_HDT_INT, TRUE);
609 nvic_irq_enable(DMA1_Channel4_IRQn, 2, 0);
610
611 /* i2s1 tx init */
612 spi_i2s_reset(SPI1);
613 i2s_default_para_init(&i2s_init_struct);
614 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
615 i2s_init_struct.data_channel_format = format;
616 i2s_init_struct.mclk_output_enable = FALSE;
617 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
618 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
619 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_TX;
620 i2s_init(SPI1, &i2s_init_struct);
621
622 /* i2s2 rx init */
623 spi_i2s_reset(SPI2);
624 i2s_default_para_init(&i2s_init_struct);
625 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
626 i2s_init_struct.data_channel_format = format;
627 i2s_init_struct.mclk_output_enable = FALSE;
628 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
629 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
630 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_RX;
631 i2s_init(SPI2, &i2s_init_struct);
632
633
634 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
635 spi_i2s_dma_receiver_enable(SPI2, TRUE);
636 i2s_enable(SPI1, TRUE);
637 i2s_enable(SPI2, TRUE);
638
639 dma_channel_enable(DMA1_CHANNEL3, TRUE);
640 dma_channel_enable(DMA1_CHANNEL4, TRUE);
641
642}
643
649void DMA1_Channel3_IRQHandler(void)
650{
651 uint16_t half_size = audio_codec.spk_tx_size;
652 uint16_t *pdst;
653
654 if(dma_flag_get(DMA1_HDT3_FLAG) == SET)
655 {
656 //copy_buff(audio_codec.spk_buffer, audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
657 pdst = spk_dma_buffer;
658 dma_flag_clear(DMA1_HDT3_FLAG);
659 }
660 else if(dma_flag_get(DMA1_FDT3_FLAG) == SET)
661 {
662 //copy_buff(&audio_codec.spk_buffer[half_size], audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
663 pdst = spk_dma_buffer + half_size;
664 dma_flag_clear(DMA1_FDT3_FLAG);
665 }
666
667 switch( audio_codec.spk_stage )
668 {
669 case 0:
670 case 1:
671 memset( pdst, 0, half_size << 1);
672 break;
673 case 2:
674 if( audio_codec.spk_wtotal >= audio_codec.spk_rtotal + SPK_BUFFER_SIZE )
675 {
676 while(1);//should not happen;
677 }
678 if( audio_codec.spk_rtotal >= audio_codec.spk_wtotal )
679 {
680 audio_codec.spk_stage = 0;
681 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
682 audio_codec.spk_rtotal = audio_codec.spk_wtotal = 0;
683 }
684 else
685 {
686 memcpy( pdst, audio_codec.spk_roff, half_size << 1 );
687 audio_codec.spk_roff += half_size;
688 audio_codec.spk_rtotal += half_size;
689 if( audio_codec.spk_roff >= audio_codec.spk_rend )
690 {
691 audio_codec.spk_roff = audio_codec.spk_buffer;
692 }
693 if( ++audio_codec.spk_calc == 256 )
694 {
695 uint16_t delta = audio_codec.spk_wtotal - audio_codec.spk_rtotal;
696 audio_codec.spk_calc = 0;
697 if( delta < audio_codec.spk_threshold - half_size )
698 {
699 audio_codec.spk_threshold -= half_size;
700 audio_codec.spk_freq += audio_codec.audio_freq/1024;
701 }
702 else if( delta > audio_codec.spk_threshold + half_size )
703 {
704 audio_codec.spk_threshold += half_size;
705 audio_codec.spk_freq -= audio_codec.audio_freq/1024;
706 }
707 if(audio_codec.spk_rtotal > 0x20000000)
708 {
709 audio_codec.spk_rtotal -= 0x10000000;
710 audio_codec.spk_wtotal -= 0x10000000;
711 }
712 }
713 }
714 break;
715 }
716
717}
718
724void DMA1_Channel4_IRQHandler(void)
725{
726 uint16_t *psrc;
727 uint16_t len = audio_codec.mic_rx_size << 1;
728
729 if(dma_flag_get(DMA1_HDT4_FLAG) == SET)
730 {
731 dma_flag_clear(DMA1_HDT4_FLAG);
732 psrc = mic_dma_buffer;
733 }
734 else if(dma_flag_get(DMA1_FDT4_FLAG) == SET)
735 {
736 psrc = mic_dma_buffer + audio_codec.mic_rx_size;
737 dma_flag_clear(DMA1_FDT4_FLAG);
738 }
739 if( audio_codec.mic_stage )
740 {
741 memcpy( audio_codec.mic_woff, psrc, len );
742 audio_codec.mic_woff += len/2;
743 audio_codec.mic_wtotal += len/2;
744 if( audio_codec.mic_woff >= audio_codec.mic_wend )
745 {
746 audio_codec.mic_woff = audio_codec.mic_buffer;
747 }
748 if( audio_codec.mic_stage == 2 )
749 {
750 if( 1024 == ++audio_codec.mic_calc )
751 {
752 uint32_t size_estimate = 1024*audio_codec.mic_rx_size;
753 audio_codec.mic_calc = 0;
754 if( audio_codec.mic_delta > size_estimate )
755 {
756 audio_codec.mic_adj_count = audio_codec.mic_delta - size_estimate;
757 audio_codec.mic_adj_stage = 2;
758 }
759 else if( audio_codec.mic_delta < size_estimate )
760 {
761 audio_codec.mic_adj_count = size_estimate - audio_codec.mic_delta;
762 audio_codec.mic_adj_stage = 1;
763 }
764 else
765 {
766 audio_codec.mic_adj_count = 0;
767 audio_codec.mic_adj_stage = 0;
768 }
769 audio_codec.mic_delta = 0;
770 if( audio_codec.mic_rtotal >= 0x80000000 )
771 {
772 audio_codec.mic_rtotal -= 0x80000000;
773 audio_codec.mic_wtotal -= 0x80000000;
774 }
775 }
776 if( audio_codec.mic_wtotal >= audio_codec.mic_rtotal + MIC_BUFFER_SIZE )
777 {
778 audio_codec.mic_delta = audio_codec.mic_wtotal = audio_codec.mic_rtotal = 0;
779 audio_codec.mic_woff = audio_codec.mic_roff = audio_codec.mic_buffer;
780 audio_codec.mic_stage = 0;
781 audio_codec.mic_adj_stage = 0;
782 audio_codec.mic_adj_count = 0;
783 audio_codec.mic_calc = 0;
784 }
785 }
786 }
787}
788
794 error_status audio_codec_init(void)
795{
796 uint32_t reg_len = sizeof(reg_addr_data) / sizeof(uint16_t);
797 uint32_t i_index = 0;
798 uint8_t i2c_cmd[2];
799
800 if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_16K)
801 {
802 reg_addr_data[6] = WM8988_REG_FREQ16K;
803 audio_codec.audio_freq = AUDIO_FREQ_16K;
804 }
805 else if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_48K)
806 {
807 reg_addr_data[6] = WM8988_REG_FREQ48K;
808 audio_codec.audio_freq = AUDIO_FREQ_48K;
809 }
810 else
811 {
812 return ERROR;
813 }
814
815 if(AUDIO_DEFAULT_BITW == AUDIO_BITW_16)
816 {
817 reg_addr_data[5] = WM8988_REG_BITW16;
818 audio_codec.audio_bitw = AUDIO_BITW_16;
819 }
820 else
821 {
822 return ERROR;
823 }
824
825 /* i2c init */
826 hi2cx.i2cx = I2Cx_PORT;
827
828 i2c_config(&hi2cx);
829
830 for(i_index = 0; i_index < reg_len; i_index ++)
831 {
832 i2c_cmd[0] = (uint8_t)(reg_addr_data[i_index] >> 8);
833 i2c_cmd[1] = (uint8_t)reg_addr_data[i_index] & 0xFF;
834 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
835 {
836 return ERROR;
837 }
838 }
839
840 /* timer init */
841 mclk_tmr1_init();
842
843 codec_i2s_init(&audio_codec);
844
845 return SUCCESS;
846}
847
853 error_status audio_codec_loop(void)
854{
855 static uint8_t mic_mute = 0;
856 static uint16_t mic_volume = 0;
857 static uint8_t spk_mute = 0;
858 static uint16_t spk_volume = 0;
859 uint16_t audio_ctrl_l;
860 uint16_t audio_ctrl_r;
861 uint8_t i2c_cmd[2];
862
863 if(mic_mute != audio_codec.mic_mute)
864 {
865 mic_mute = audio_codec.mic_mute;
866 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
867 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
868 if(audio_codec.mic_mute == 0)
869 {
870 audio_ctrl_l |= audio_codec.mic_volume;
871 audio_ctrl_r |= audio_codec.mic_volume;
872 }
873 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
874 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
875 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
876 {
877 return ERROR;
878 }
879 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
880 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
881 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
882 {
883 return ERROR;
884 }
885 }
886
887 if(mic_volume != audio_codec.mic_volume)
888 {
889 mic_volume = audio_codec.mic_volume;
890 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
891 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
892 audio_ctrl_l |= audio_codec.mic_volume;
893 audio_ctrl_r |= audio_codec.mic_volume;
894 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
895 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
896 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
897 {
898 return ERROR;
899 }
900 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
901 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
902 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
903 {
904 return ERROR;
905 }
906 }
907
908 if(spk_mute != audio_codec.spk_mute)
909 {
910 spk_mute = audio_codec.spk_mute;
911 audio_ctrl_l = (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006 | (audio_codec.spk_mute << 3);
912 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
913 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
914 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
915 {
916 return ERROR;
917 }
918 }
919
920 if(spk_volume != audio_codec.spk_volume)
921 {
922 spk_volume = audio_codec.spk_volume;
923 audio_ctrl_l = WM8988_R2_LOUT1_VOLUME << 9 | 0x100;
924 audio_ctrl_r = WM8988_R3_ROUT1_VOLUME << 9 | 0x100;
925 audio_ctrl_l |= audio_codec.spk_volume;
926 audio_ctrl_r |= audio_codec.spk_volume;
927
928 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
929 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
930
931 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
932 {
933 return ERROR;
934 }
935 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
936 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
937 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
938 {
939 return ERROR;
940 }
941 }
942 return SUCCESS;
943}
944
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:38
reg_addr_data
uint16_t reg_addr_data[]
wm8988 register default value
Definition: audio/src/audio_codec.c:71
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:169
codec_i2s_reset
void codec_i2s_reset(void)
audio codec i2s reset
Definition: audio/src/audio_codec.c:478
spk_dma_buffer
uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]
Definition: audio/src/audio_codec.c:107
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:217
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:195
WM8988_REG_FREQ48K
#define WM8988_REG_FREQ48K
wm8988 freq
Definition: audio/src/audio_codec.c:60
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:121
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: audio/src/audio_codec.c:44
I2Cx_CLK
#define I2Cx_CLK
Definition: audio/src/audio_codec.c:47
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:282
WM8988_REG_BITW16
#define WM8988_REG_BITW16
wm8988 bit width
Definition: audio/src/audio_codec.c:66
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:853
codec_i2s_init
void codec_i2s_init(audio_codec_type *param)
audio codec i2s init
Definition: audio/src/audio_codec.c:492
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:184
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
codec speaker write fifo
Definition: audio/src/audio_codec.c:244
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: audio/src/audio_codec.c:53
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: audio/src/audio_codec.c:49
mic_dma_buffer
uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]
Definition: audio/src/audio_codec.c:108
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:228
hi2cx
i2c_handle_type hi2cx
Definition: audio/src/audio_codec.c:104
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 interrupt.
Definition: audio/src/audio_codec.c:724
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: audio/src/audio_codec.c:342
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: audio/src/audio_codec.c:54
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:206
mclk_tmr1_init
void mclk_tmr1_init(void)
mclk clock conifg
Definition: audio/src/audio_codec.c:437
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 interrupt.
Definition: audio/src/audio_codec.c:649
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: audio/src/audio_codec.c:55
audio_codec
audio_codec_type audio_codec
Definition: audio/src/audio_codec.c:106
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:154
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: audio/src/audio_codec.c:399
I2Cx_SPEED
#define I2Cx_SPEED
Definition: audio/src/audio_codec.c:43
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:794
WM8988_REG_FREQ16K
#define WM8988_REG_FREQ16K
Definition: audio/src/audio_codec.c:61
copy_buff
void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer
Definition: audio/src/audio_codec.c:385
memset16_buffer
void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset
Definition: audio/src/audio_codec.c:369
I2Cx_PORT
#define I2Cx_PORT
Definition: audio/src/audio_codec.c:46
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:137
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: audio/src/audio_codec.c:51
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: audio/src/audio_codec.c:50
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:112
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:412
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f413.h:146
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f413.h:147
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f413_dma.h:95
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f413_dma.h:91
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:94
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:90
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA_HDT_INT
#define DMA_HDT_INT
Definition: at32f413_dma.h:53
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:482
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:483
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:226
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:236
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:185
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:90
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:148
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:157
I2C_OK
@ I2C_OK
Definition: i2c_application.h:82
I2C1_MUX
#define I2C1_MUX
Definition: at32f413_gpio.h:82
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:316
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:499
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:445
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:298
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:485
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f413_spi.h:226
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f413_spi.h:209
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:249
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f413_spi.h:227
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:229
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:198
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:239
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:238
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:609
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:127
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:128
DMA_BUFFER_SIZE
#define DMA_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:129
I2S2_DT_ADDRESS
#define I2S2_DT_ADDRESS
Definition: audio/inc/audio_codec.h:116
I2S1_SD_PIN
#define I2S1_SD_PIN
Definition: audio/inc/audio_codec.h:105
I2S1_CK_PIN
#define I2S1_CK_PIN
Definition: audio/inc/audio_codec.h:104
I2S2_GPIO
#define I2S2_GPIO
Definition: audio/inc/audio_codec.h:114
I2S2_SD_PIN
#define I2S2_SD_PIN
Definition: audio/inc/audio_codec.h:113
I2S2_WS_PIN
#define I2S2_WS_PIN
Definition: audio/inc/audio_codec.h:111
I2S2_GPIO_CRM_CLK
#define I2S2_GPIO_CRM_CLK
Definition: audio/inc/audio_codec.h:115
I2S1_DT_ADDRESS
#define I2S1_DT_ADDRESS
Definition: audio/inc/audio_codec.h:108
I2S1_GPIO_CRM_CLK
#define I2S1_GPIO_CRM_CLK
Definition: audio/inc/audio_codec.h:107
I2S1_WS_PIN
#define I2S1_WS_PIN
Definition: audio/inc/audio_codec.h:103
I2S1_GPIO
#define I2S1_GPIO
Definition: audio/inc/audio_codec.h:106
I2S2_CK_PIN
#define I2S2_CK_PIN
Definition: audio/inc/audio_codec.h:112
WM8988_R27_ADDITIONAL_3_CONTROL
#define WM8988_R27_ADDITIONAL_3_CONTROL
Definition: audio/inc/audio_codec.h:77
WM8988_I2C_ADDR_CSB_LOW
#define WM8988_I2C_ADDR_CSB_LOW
Definition: audio/inc/audio_codec.h:93
WM8988_R10_LEFT_DAC_VOLUME
#define WM8988_R10_LEFT_DAC_VOLUME
Definition: audio/inc/audio_codec.h:60
WM8988_R1_RIGHT_INPUT_VOLUME
#define WM8988_R1_RIGHT_INPUT_VOLUME
Definition: audio/inc/audio_codec.h:51
WM8988_R3_ROUT1_VOLUME
#define WM8988_R3_ROUT1_VOLUME
Definition: audio/inc/audio_codec.h:53
WM8988_R36_RIGHT_OUT_MIX_1
#define WM8988_R36_RIGHT_OUT_MIX_1
Definition: audio/inc/audio_codec.h:84
WM8988_R21_LEFT_ADC_VOLUME
#define WM8988_R21_LEFT_ADC_VOLUME
Definition: audio/inc/audio_codec.h:71
WM8988_R31_ADC_INPUT_MODE
#define WM8988_R31_ADC_INPUT_MODE
Definition: audio/inc/audio_codec.h:79
WM8988_R13_TREBLE_CONTROL
#define WM8988_R13_TREBLE_CONTROL
Definition: audio/inc/audio_codec.h:63
WM8988_R16_3D_CONTROL
#define WM8988_R16_3D_CONTROL
Definition: audio/inc/audio_codec.h:66
WM8988_R22_RIGHT_ADC_VOLUME
#define WM8988_R22_RIGHT_ADC_VOLUME
Definition: audio/inc/audio_codec.h:72
WM8988_R0_LEFT_INPUT_VOLUME
#define WM8988_R0_LEFT_INPUT_VOLUME
Definition: audio/inc/audio_codec.h:50
WM8988_R23_ADDITIONAL_1_CONTROL
#define WM8988_R23_ADDITIONAL_1_CONTROL
Definition: audio/inc/audio_codec.h:73
WM8988_R35_LEFT_OUT_MIX_2
#define WM8988_R35_LEFT_OUT_MIX_2
Definition: audio/inc/audio_codec.h:83
WM8988_R43_LOW_POWER_PALYBACK
#define WM8988_R43_LOW_POWER_PALYBACK
Definition: audio/inc/audio_codec.h:91
WM8988_R32_ADC_L_SIGNAL_PATH
#define WM8988_R32_ADC_L_SIGNAL_PATH
Definition: audio/inc/audio_codec.h:80
WM8988_R26_PWR_2_MGMT
#define WM8988_R26_PWR_2_MGMT
Definition: audio/inc/audio_codec.h:76
WM8988_R11_RIGHT_DAC_VOLUME
#define WM8988_R11_RIGHT_DAC_VOLUME
Definition: audio/inc/audio_codec.h:61
WM8988_R24_ADDITIONAL_2_CONTROL
#define WM8988_R24_ADDITIONAL_2_CONTROL
Definition: audio/inc/audio_codec.h:74
WM8988_R40_LOUT2_VOLUME
#define WM8988_R40_LOUT2_VOLUME
Definition: audio/inc/audio_codec.h:88
WM8988_R34_LEFT_OUT_MIX_1
#define WM8988_R34_LEFT_OUT_MIX_1
Definition: audio/inc/audio_codec.h:82
WM8988_R5_ADC_DAC_CONTROL
#define WM8988_R5_ADC_DAC_CONTROL
Definition: audio/inc/audio_codec.h:55
WM8988_R25_PWR_1_MGMT
#define WM8988_R25_PWR_1_MGMT
Definition: audio/inc/audio_codec.h:75
WM8988_R41_ROUT2_VOLUME
#define WM8988_R41_ROUT2_VOLUME
Definition: audio/inc/audio_codec.h:89
WM8988_R2_LOUT1_VOLUME
#define WM8988_R2_LOUT1_VOLUME
Definition: audio/inc/audio_codec.h:52
WM8988_R37_RIGHT_OUT_MIX_2
#define WM8988_R37_RIGHT_OUT_MIX_2
Definition: audio/inc/audio_codec.h:85
WM8988_R33_ADC_R_SIGNAL_PATH
#define WM8988_R33_ADC_R_SIGNAL_PATH
Definition: audio/inc/audio_codec.h:81
WM8988_R12_BASS_CONTROL
#define WM8988_R12_BASS_CONTROL
Definition: audio/inc/audio_codec.h:62
AUDIO_BITW_16
#define AUDIO_BITW_16
Definition: audio/audio_conf.h:61
AUDIO_MIC_CHANEL_NUM
#define AUDIO_MIC_CHANEL_NUM
Definition: audio/audio_conf.h:63
AUDIO_DEFAULT_FREQ
#define AUDIO_DEFAULT_FREQ
Definition: audio/audio_conf.h:71
AUDIO_FREQ_16K
#define AUDIO_FREQ_16K
Definition: audio/audio_conf.h:59
AUDIO_SPK_CHANEL_NUM
#define AUDIO_SPK_CHANEL_NUM
Definition: audio/audio_conf.h:66
AUDIO_DEFAULT_BITW
#define AUDIO_DEFAULT_BITW
Definition: audio/audio_conf.h:72
AUDIO_FREQ_48K
#define AUDIO_FREQ_48K
Definition: audio/audio_conf.h:60
i2c_application.h
i2c application libray header file
audio_codec_type
Definition: audio/inc/audio_codec.h:132
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: audio/inc/audio_codec.h:161
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: audio/inc/audio_codec.h:143
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: audio/inc/audio_codec.h:145
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: audio/inc/audio_codec.h:149
audio_codec_type::spk_buffer
uint16_t spk_buffer[4096]
Definition: audio/inc/audio_codec.h:136
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: audio/inc/audio_codec.h:163
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: audio/inc/audio_codec.h:137
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: audio/inc/audio_codec.h:142
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: audio/inc/audio_codec.h:154
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: audio/inc/audio_codec.h:144
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: audio/inc/audio_codec.h:150
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: audio/inc/audio_codec.h:158
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: audio/inc/audio_codec.h:156
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: audio/inc/audio_codec.h:140
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: audio/inc/audio_codec.h:134
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: audio/inc/audio_codec.h:151
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: audio/inc/audio_codec.h:139
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: audio/inc/audio_codec.h:152
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: audio/inc/audio_codec.h:153
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: audio/inc/audio_codec.h:133
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: audio/inc/audio_codec.h:160
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: audio/inc/audio_codec.h:164
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: audio/inc/audio_codec.h:155
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: audio/inc/audio_codec.h:141
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: audio/inc/audio_codec.h:157
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: audio/inc/audio_codec.h:166
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: audio/inc/audio_codec.h:167
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: audio/inc/audio_codec.h:138
audio_codec_type::mic_buffer
uint16_t mic_buffer[1024]
Definition: audio/inc/audio_codec.h:148
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
i2c_handle_type
Definition: i2c_application.h:114
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:115
i2s_init_type
i2s init type
Definition: at32f413_spi.h:272
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:275
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:276
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:278
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:274
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:273
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:277
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402


AT32F413 Firmwary Library: audio_class.c Source File

  • middlewares
  • usbd_class
  • audio
audio_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "audio_class.h"
28#include "audio_desc.h"
29#include "audio_codec.h"
30
44static usb_sts_type class_init_handler(void *udev);
45static usb_sts_type class_clear_handler(void *udev);
46static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
47static usb_sts_type class_ept0_tx_handler(void *udev);
48static usb_sts_type class_ept0_rx_handler(void *udev);
49static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
51static usb_sts_type class_sof_handler(void *udev);
52static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
53
54static void audio_req_get_cur(void *udev, usb_setup_type *setup);
55static void audio_req_set_cur(void *udev, usb_setup_type *setup);
56static void audio_req_get_min(void *udev, usb_setup_type *setup);
57static void audio_req_get_max(void *udev, usb_setup_type *setup);
58static void audio_req_get_res(void *udev, usb_setup_type *setup);
59static void audio_get_interface(void *udev, usb_setup_type *setup);
60static void audio_set_interface(void *udev, usb_setup_type *setup);
61
62 usb_audio_type audio_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0};
63
64/* usb device class handler */
65 usbd_class_handler audio_class_handler =
66{
67 class_init_handler,
68 class_clear_handler,
69 class_setup_handler,
70 class_ept0_tx_handler,
71 class_ept0_rx_handler,
72 class_in_handler,
73 class_out_handler,
74 class_sof_handler,
75 class_event_handler,
76 &audio_struct
77};
78
84static usb_sts_type class_init_handler(void *udev)
85{
86 usb_sts_type status = USB_OK;
87 usbd_core_type *pudev = (usbd_core_type *)udev;
88 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
89 /* enable microphone in endpoint double buffer mode */
90 usbd_ept_dbuffer_enable(pudev, USBD_AUDIO_MIC_IN_EPT);
91
92 /* open microphone in endpoint */
93 usbd_ept_open(pudev, USBD_AUDIO_MIC_IN_EPT, EPT_ISO_TYPE, AUDIO_MIC_IN_MAXPACKET_SIZE);
94
95 /* enable speaker out endpoint double buffer mode */
96 usbd_ept_dbuffer_enable(pudev, USBD_AUDIO_SPK_OUT_EPT);
97
98 /* open speaker out endpoint */
99 usbd_ept_open(pudev, USBD_AUDIO_SPK_OUT_EPT, EPT_ISO_TYPE, AUDIO_SPK_OUT_MAXPACKET_SIZE);
100
101 /* enable speaker feedback endpoint double buffer mode */
102 usbd_ept_dbuffer_enable(pudev, USBD_AUDIO_FEEDBACK_EPT);
103
104 /* open speaker feedback endpoint */
105 usbd_ept_open(pudev, USBD_AUDIO_FEEDBACK_EPT, EPT_ISO_TYPE, AUDIO_FEEDBACK_MAXPACKET_SIZE);
106
107 /* start receive speaker out data */
108 usbd_ept_recv(pudev, USBD_AUDIO_SPK_OUT_EPT, paudio->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
109
110 return status;
111}
112
118static usb_sts_type class_clear_handler(void *udev)
119{
120 usb_sts_type status = USB_OK;
121 usbd_core_type *pudev = (usbd_core_type *)udev;
122
123 /* close in endpoint */
124 usbd_ept_close(pudev, USBD_AUDIO_MIC_IN_EPT);
125
126 /* close in endpoint */
127 usbd_ept_close(pudev, USBD_AUDIO_FEEDBACK_EPT);
128
129 /* close out endpoint */
130 usbd_ept_close(pudev, USBD_AUDIO_SPK_OUT_EPT);
131
132 return status;
133}
134
141static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
142{
143 usb_sts_type status = USB_OK;
144 usbd_core_type *pudev = (usbd_core_type *)udev;
145 uint16_t len;
146
147 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
148 {
149 /* class request */
150 case USB_REQ_TYPE_CLASS:
151 switch(setup->bRequest)
152 {
153 case AUDIO_REQ_GET_CUR:
154 audio_req_get_cur(pudev, setup);
155 break;
156
157 case AUDIO_REQ_SET_CUR:
158 audio_req_set_cur(pudev, setup);
159 break;
160
161 case AUDIO_REQ_GET_MIN:
162 audio_req_get_min(pudev, setup);
163 break;
164
165 case AUDIO_REQ_GET_MAX:
166 audio_req_get_max(pudev, setup);
167 break;
168
169 case AUDIO_REQ_GET_RES:
170 audio_req_get_res(pudev, setup);
171 break;
172
173 default:
174 usbd_ctrl_unsupport(pudev);
175 break;
176 }
177 break;
178 /* standard request */
179 case USB_REQ_TYPE_STANDARD:
180 switch(setup->bRequest)
181 {
182 case USB_STD_REQ_GET_DESCRIPTOR:
183 if((setup->wValue >> 8) == AUDIO_DESCRIPTOR_TYPE)
184 {
185 usbd_desc_t *config = pudev->desc_handler->get_device_configuration();
186 len = MIN(AUDIO_DESCRIPTOR_SIZE, setup->wLength);
187 usbd_ctrl_send(pudev, config->descriptor + 18, len);
188 }
189 else
190 {
191 usbd_ctrl_unsupport(pudev);
192 }
193 break;
194 case USB_STD_REQ_GET_INTERFACE:
195 audio_get_interface(udev, setup);
196 break;
197
198 case USB_STD_REQ_SET_INTERFACE:
199 audio_set_interface(udev, setup);
200 usbd_ctrl_send_status(pudev);
201 break;
202
203 default:
204 break;
205 }
206 break;
207
208 default:
209 usbd_ctrl_unsupport(pudev);
210 break;
211 }
212 return status;
213}
214
220static usb_sts_type class_ept0_tx_handler(void *udev)
221{
222 usb_sts_type status = USB_OK;
223
224 /* ...user code... */
225
226 return status;
227}
228
234static usb_sts_type class_ept0_rx_handler(void *udev)
235{
236 usb_sts_type status = USB_OK;
237 usbd_core_type *pudev = (usbd_core_type *)udev;
238 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
239 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
240 /* ...user code... */
241 if( paudio->audio_cmd == AUDIO_REQ_SET_CUR)
242 {
243 /* class process */
244 switch( paudio->request_no)
245 {
246 case AUDIO_VOLUME_CONTROL:
247 if( paudio->interface == AUDIO_SPK_FEATURE_UNIT_ID)
248 {
249 paudio->spk_volume = (uint16_t)( paudio->g_audio_cur[0] |
250 ( paudio->g_audio_cur[1] << 8));
251 /* set volume */
252 audio_codec_set_spk_volume(paudio->spk_volume*100/paudio->spk_volume_limits[1]);
253 }
254 else
255 {
256 paudio->mic_volume = (uint16_t)(paudio->g_audio_cur[0] |
257 (paudio->g_audio_cur[1] << 8));
258
259 audio_codec_set_mic_volume(paudio->mic_volume*256/paudio->mic_volume_limits[1]);
260 }
261 break;
262 case AUDIO_MUTE_CONTROL:
263 if(paudio->interface == AUDIO_SPK_FEATURE_UNIT_ID)
264 {
265 paudio->spk_mute = paudio->g_audio_cur[0];
266 audio_codec_set_spk_mute(paudio->spk_mute);
267 }
268 else
269 {
270 paudio->mic_mute = paudio->g_audio_cur[0];
271 audio_codec_set_mic_mute(paudio->mic_mute);
272 }
273
274 break;
275 case AUDIO_FREQ_SET_CONTROL:
276 if(paudio->enpd == USBD_AUDIO_MIC_IN_EPT)
277 {
278 paudio->mic_freq = (paudio->g_audio_cur[0] |
279 (paudio->g_audio_cur[1] << 8) |
280 (paudio->g_audio_cur[2] << 16));
281 audio_codec_set_mic_freq(paudio->mic_freq);
282 }
283 else
284 {
285 paudio->spk_freq = (paudio->g_audio_cur[0] |
286 (paudio->g_audio_cur[1] << 8) |
287 (paudio->g_audio_cur[2] << 16));
288 audio_codec_set_spk_freq(paudio->spk_freq);
289 }
290 break;
291 default:
292 break;
293 }
294 }
295
296 return status;
297}
298
305static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
306{
307 usb_sts_type status = USB_OK;
308 usbd_core_type *pudev = (usbd_core_type *)udev;
309 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
310 uint32_t len = 0;
311
312 /* ...user code...
313 trans next packet data
314 */
315 if((ept_num & 0x7F) == (USBD_AUDIO_MIC_IN_EPT & 0x7F))
316 {
317 len = audio_codec_mic_get_data(paudio->audio_mic_data);
318 usbd_ept_send(udev, USBD_AUDIO_MIC_IN_EPT, paudio->audio_mic_data, len);
319 }
320
321 else if((ept_num & 0x7F) == (USBD_AUDIO_FEEDBACK_EPT & 0x7F))
322 {
323 len = audio_codec_spk_feedback(paudio->audio_feed_back);
324 usbd_ept_send(udev, USBD_AUDIO_FEEDBACK_EPT, paudio->audio_feed_back, len);
325 }
326
327 return status;
328}
329
336static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
337{
338 usb_sts_type status = USB_OK;
339 usbd_core_type *pudev = (usbd_core_type *)udev;
340 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
341 uint16_t g_rxlen;
342
343 /* get endpoint receive data length */
344 g_rxlen = usbd_get_recv_len(pudev, ept_num);
345
346 if((ept_num & 0x7F) == (USBD_AUDIO_SPK_OUT_EPT & 0x7F))
347 {
348 /* speaker data*/
349 audio_codec_spk_fifo_write(paudio->audio_spk_data, g_rxlen);
350
351 /* get next data */
352 usbd_ept_recv(pudev, USBD_AUDIO_SPK_OUT_EPT, paudio->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
353 }
354
355 return status;
356}
357
363static usb_sts_type class_sof_handler(void *udev)
364{
365 usb_sts_type status = USB_OK;
366
367 /* ...user code... */
368
369 return status;
370}
371
378 usb_sts_type class_event_handler(void *udev, usbd_event_type event)
379{
380 usb_sts_type status = USB_OK;
381 usbd_core_type *pudev = (usbd_core_type *)udev;
382 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
383 switch(event)
384 {
385 case USBD_RESET_EVENT:
386
387 /* ...user code... */
388
389 break;
390 case USBD_SUSPEND_EVENT:
391 paudio->spk_alt_setting = 0;
392 audio_codec_spk_alt_setting(paudio->spk_alt_setting);
393 paudio->mic_alt_setting = 0;
394 audio_codec_mic_alt_setting(paudio->spk_alt_setting);
395 /* ...user code... */
396
397 break;
398 case USBD_WAKEUP_EVENT:
399 /* ...user code... */
400
401 break;
402 default:
403 break;
404 }
405 return status;
406}
407
414static void audio_req_get_cur(void *udev, usb_setup_type *setup)
415{
416 usbd_core_type *pudev = (usbd_core_type *)udev;
417 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
418 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
419 {
420 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
421 {
422 paudio->g_audio_cur[0] = paudio->spk_mute;
423 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
424 }
425 else
426 {
427 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume;
428 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
429 }
430 }
431 else
432 {
433 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
434 {
435 paudio->g_audio_cur[0] = paudio->mic_mute;
436 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
437 }
438 else
439 {
440 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume;
441 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
442 }
443
444 }
445}
446
453static void audio_req_set_cur(void *udev, usb_setup_type *setup)
454{
455 usbd_core_type *pudev = (usbd_core_type *)udev;
456 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
457 if(setup->wLength > 0)
458 {
459 usbd_ctrl_recv(pudev, paudio->g_audio_cur, setup->wLength);
460
461 paudio->audio_cmd = AUDIO_REQ_SET_CUR;
462 paudio->audio_cmd_len = setup->wLength;
463
464 switch(setup->bmRequestType & AUDIO_REQ_CONTROL_MASK)
465 {
466 case AUDIO_REQ_CONTROL_INTERFACE:
467 paudio->interface = HBYTE(setup->wIndex);
468 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
469 {
470 paudio->request_no = AUDIO_MUTE_CONTROL;
471 }
472 else
473 {
474 paudio->request_no = AUDIO_VOLUME_CONTROL;
475 }
476 break;
477 case AUDIO_REQ_CONTROL_ENDPOINT:
478 paudio->enpd = setup->wIndex;
479 paudio->request_no = AUDIO_FREQ_SET_CONTROL;
480 break;
481 default:
482 break;
483 }
484 }
485}
486
493static void audio_req_get_min(void *udev, usb_setup_type *setup)
494{
495 usbd_core_type *pudev = (usbd_core_type *)udev;
496 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
497 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
498 {
499 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume_limits[0];
500 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
501 }
502 else
503 {
504 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume_limits[0];
505 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
506 }
507}
508
515static void audio_req_get_max(void *udev, usb_setup_type *setup)
516{
517 usbd_core_type *pudev = (usbd_core_type *)udev;
518 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
519 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
520 {
521 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume_limits[1];
522 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
523 }
524 else
525 {
526 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume_limits[1];
527 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
528 }
529}
530
537static void audio_req_get_res(void *udev, usb_setup_type *setup)
538{
539 usbd_core_type *pudev = (usbd_core_type *)udev;
540 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
541 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
542 {
543 *((uint16_t *)paudio->g_audio_cur) = paudio->spk_volume_limits[2];
544 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
545 }
546 else
547 {
548 *((uint16_t *)paudio->g_audio_cur) = paudio->mic_volume_limits[2];
549 usbd_ctrl_send(pudev, paudio->g_audio_cur, setup->wLength);
550 }
551}
552
559static void audio_set_interface(void *udev, usb_setup_type *setup)
560{
561 uint32_t len;
562 usbd_core_type *pudev = (usbd_core_type *)udev;
563 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
564 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
565 {
566 paudio->spk_alt_setting = setup->wValue;
567 audio_codec_spk_alt_setting(paudio->spk_alt_setting);
568 if(paudio->spk_alt_setting )
569 {
570 int len = audio_codec_spk_feedback(paudio->audio_feed_back);
571 usbd_ept_recv(pudev, USBD_AUDIO_SPK_OUT_EPT, paudio->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
572 usbd_ept_send(pudev, USBD_AUDIO_FEEDBACK_EPT, paudio->audio_feed_back, len);
573 }
574
575 }
576 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
577 {
578 paudio->mic_alt_setting = setup->wValue;
579 audio_codec_mic_alt_setting(paudio->mic_alt_setting);
580 if(paudio->mic_alt_setting)
581 {
582 len = audio_codec_mic_get_data(paudio->audio_mic_data);
583 usbd_ept_send(pudev, USBD_AUDIO_MIC_IN_EPT, paudio->audio_mic_data, len);
584 }
585 }
586
587}
588
589
596static void audio_get_interface(void *udev, usb_setup_type *setup)
597{
598 usbd_core_type *pudev = (usbd_core_type *)udev;
599 usb_audio_type *paudio = (usb_audio_type *)pudev->class_handler->pdata;
600 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
601 {
602 usbd_ctrl_send(pudev, (uint8_t *)&paudio->spk_alt_setting, 1);
603 }
604 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
605 {
606 usbd_ctrl_send(pudev, (uint8_t *)&paudio->mic_alt_setting, 1);
607 }
608
609}
610
611
audio_class.h
usb audio class file
audio_desc.h
usb audio descriptor header file
AUDIO_DESCRIPTOR_TYPE
#define AUDIO_DESCRIPTOR_TYPE
audio descriptor type
Definition: audio_class.h:83
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_MUTE_CONTROL
#define AUDIO_MUTE_CONTROL
audio set cur type define
Definition: audio_class.h:76
AUDIO_REQ_CONTROL_INTERFACE
#define AUDIO_REQ_CONTROL_INTERFACE
request type define
Definition: audio_class.h:69
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
AUDIO_VOLUME_CONTROL
#define AUDIO_VOLUME_CONTROL
Definition: audio_class.h:77
AUDIO_FREQ_SET_CONTROL
#define AUDIO_FREQ_SET_CONTROL
Definition: audio_class.h:78
AUDIO_REQ_CONTROL_ENDPOINT
#define AUDIO_REQ_CONTROL_ENDPOINT
Definition: audio_class.h:70
AUDIO_REQ_CONTROL_MASK
#define AUDIO_REQ_CONTROL_MASK
Definition: audio_class.h:71
USBD_AUDIO_SPK_OUT_EPT
#define USBD_AUDIO_SPK_OUT_EPT
Definition: audio_class.h:55
USBD_AUDIO_MIC_IN_EPT
#define USBD_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_class.h:54
AUDIO_DESCRIPTOR_SIZE
#define AUDIO_DESCRIPTOR_SIZE
Definition: audio_class.h:84
USBD_AUDIO_FEEDBACK_EPT
#define USBD_AUDIO_FEEDBACK_EPT
Definition: audio_class.h:56
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_class.c:363
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_class.c:305
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_class.c:118
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_class.c:141
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_class.c:220
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_class.c:378
audio_class_handler
usbd_class_handler audio_class_handler
Definition: audio_class.c:65
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_class.c:234
audio_req_get_res
static void audio_req_get_res(void *udev, usb_setup_type *setup)
usb audio request get res
Definition: audio_class.c:537
audio_get_interface
static void audio_get_interface(void *udev, usb_setup_type *setup)
usb audio get interface
Definition: audio_class.c:596
audio_req_set_cur
static void audio_req_set_cur(void *udev, usb_setup_type *setup)
usb audio request set cur
Definition: audio_class.c:453
audio_struct
usb_audio_type audio_struct
Definition: audio_class.c:62
audio_req_get_max
static void audio_req_get_max(void *udev, usb_setup_type *setup)
usb audio request get max
Definition: audio_class.c:515
audio_req_get_min
static void audio_req_get_min(void *udev, usb_setup_type *setup)
usb audio request get min
Definition: audio_class.c:493
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_class.c:84
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_class.c:336
audio_req_get_cur
static void audio_req_get_cur(void *udev, usb_setup_type *setup)
usb audio request get cur
Definition: audio_class.c:414
audio_set_interface
static void audio_set_interface(void *udev, usb_setup_type *setup)
usb audio set interface
Definition: audio_class.c:559
AUDIO_REQ_GET_CUR
#define AUDIO_REQ_GET_CUR
Definition: audio_desc.h:113
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:180
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:178
AUDIO_REQ_GET_MAX
#define AUDIO_REQ_GET_MAX
Definition: audio_desc.h:117
AUDIO_REQ_GET_MIN
#define AUDIO_REQ_GET_MIN
Definition: audio_desc.h:115
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:172
AUDIO_REQ_GET_RES
#define AUDIO_REQ_GET_RES
Definition: audio_desc.h:119
AUDIO_REQ_SET_CUR
#define AUDIO_REQ_SET_CUR
Definition: audio_desc.h:112
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:169
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:217
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:195
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:121
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:282
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:184
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: audio/src/audio_codec.c:244
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:228
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:206
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:154
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:137
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f413_usb.h:206
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_ept_dbuffer_enable
void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer.
Definition: usbd_core.c:406
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:211
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
usb_audio_type
usb audio control struct
Definition: audio_class.h:90
usb_audio_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_class.h:106
usb_audio_type::enpd
uint8_t enpd
Definition: audio_class.h:91
usb_audio_type::mic_freq
uint32_t mic_freq
Definition: audio_class.h:99
usb_audio_type::spk_volume_limits
uint16_t spk_volume_limits[3]
Definition: audio_class.h:100
usb_audio_type::audio_spk_data
uint8_t audio_spk_data[(48 *2 *(16/8)+40)]
Definition: audio_class.h:108
usb_audio_type::mic_volume_limits
uint16_t mic_volume_limits[3]
Definition: audio_class.h:101
usb_audio_type::interface
uint8_t interface
Definition: audio_class.h:92
usb_audio_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_class.h:104
usb_audio_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_class.h:105
usb_audio_type::spk_volume
uint16_t spk_volume
Definition: audio_class.h:96
usb_audio_type::mic_volume
uint16_t mic_volume
Definition: audio_class.h:97
usb_audio_type::spk_freq
uint32_t spk_freq
Definition: audio_class.h:98
usb_audio_type::audio_mic_data
uint8_t audio_mic_data[(48 *2 *(16/8)+40)]
Definition: audio_class.h:109
usb_audio_type::g_audio_cur
uint8_t g_audio_cur[64]
Definition: audio_class.h:107
usb_audio_type::spk_mute
uint8_t spk_mute
Definition: audio_class.h:94
usb_audio_type::request_no
uint8_t request_no
Definition: audio_class.h:93
usb_audio_type::audio_cmd
uint8_t audio_cmd
Definition: audio_class.h:103
usb_audio_type::audio_feed_back
uint8_t audio_feed_back[0x3+1]
Definition: audio_class.h:110
usb_audio_type::mic_mute
uint8_t mic_mute
Definition: audio_class.h:95
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:114
usbd_desc_handler::get_device_configuration
usbd_desc_t *(* get_device_configuration)(void)
Definition: usbd_core.h:79
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_class.h Source File

  • middlewares
  • usbd_class
  • audio
audio_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CLASS_H
29#define __AUDIO_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37#include "audio_conf.h"
38
54#define USBD_AUDIO_MIC_IN_EPT 0x81
55#define USBD_AUDIO_SPK_OUT_EPT 0x02
56#define USBD_AUDIO_FEEDBACK_EPT 0x83
57
61#define AUDIO_REMAIN_SIZE 40
62#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
63#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
64#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
65#define FEEDBACK_REFRESH_TIME 0x8
69#define AUDIO_REQ_CONTROL_INTERFACE 0x01
70#define AUDIO_REQ_CONTROL_ENDPOINT 0x02
71#define AUDIO_REQ_CONTROL_MASK 0x03
72
76#define AUDIO_MUTE_CONTROL 0x01
77#define AUDIO_VOLUME_CONTROL 0x02
78#define AUDIO_FREQ_SET_CONTROL 0x03
79
83#define AUDIO_DESCRIPTOR_TYPE 0x21
84#define AUDIO_DESCRIPTOR_SIZE 0x09
85
89typedef struct
90{
91 uint8_t enpd;
92 uint8_t interface;
93 uint8_t request_no;
94 uint8_t spk_mute;
95 uint8_t mic_mute;
96 uint16_t spk_volume;
97 uint16_t mic_volume;
98 uint32_t spk_freq;
99 uint32_t mic_freq;
100 uint16_t spk_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
101 uint16_t mic_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
102
103 uint8_t audio_cmd;
104 uint32_t audio_cmd_len;
105 uint32_t spk_alt_setting;
106 uint32_t mic_alt_setting;
107 uint8_t g_audio_cur[64];
108 uint8_t audio_spk_data[AUDIO_SPK_OUT_MAXPACKET_SIZE];
109 uint8_t audio_mic_data[AUDIO_MIC_IN_MAXPACKET_SIZE];
110 uint8_t audio_feed_back[AUDIO_FEEDBACK_MAXPACKET_SIZE+1];
111}usb_audio_type;
112
113extern usbd_class_handler audio_class_handler;
114
127#ifdef __cplusplus
128}
129#endif
130
131#endif
132
audio_conf.h
usb audio config
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
audio_class_handler
usbd_class_handler audio_class_handler
Definition: audio_class.c:65
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
usb_audio_type
usb audio control struct
Definition: audio_class.h:90
usb_audio_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_class.h:106
usb_audio_type::enpd
uint8_t enpd
Definition: audio_class.h:91
usb_audio_type::mic_freq
uint32_t mic_freq
Definition: audio_class.h:99
usb_audio_type::interface
uint8_t interface
Definition: audio_class.h:92
usb_audio_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_class.h:104
usb_audio_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_class.h:105
usb_audio_type::spk_volume
uint16_t spk_volume
Definition: audio_class.h:96
usb_audio_type::mic_volume
uint16_t mic_volume
Definition: audio_class.h:97
usb_audio_type::spk_freq
uint32_t spk_freq
Definition: audio_class.h:98
usb_audio_type::spk_mute
uint8_t spk_mute
Definition: audio_class.h:94
usb_audio_type::request_no
uint8_t request_no
Definition: audio_class.h:93
usb_audio_type::audio_cmd
uint8_t audio_cmd
Definition: audio_class.h:103
usb_audio_type::mic_mute
uint8_t mic_mute
Definition: audio_class.h:95
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_desc.c Source File

  • middlewares
  • usbd_class
  • audio
audio_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "audio_desc.h"
30
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57static uint8_t g_usbd_desc_buffer[256];
58
62 usbd_desc_handler audio_desc_handler =
63{
64 get_device_descriptor,
65 get_device_qualifier,
66 get_device_configuration,
67 get_device_other_speed,
68 get_device_lang_id,
69 get_device_manufacturer_string,
70 get_device_product_string,
71 get_device_serial_string,
72 get_device_interface_string,
73 get_device_config_string,
74};
75
79#if defined ( __ICCARM__ ) /* iar compiler */
80 #pragma data_alignment=4
81#endif
82ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
83{
84 USB_DEVICE_DESC_LEN, /* bLength */
85 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
86 0x00, /* bcdUSB */
87 0x02,
88 0x00, /* bDeviceClass */
89 0x00, /* bDeviceSubClass */
90 0x00, /* bDeviceProtocol */
91 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
92 LBYTE(USBD_AUDIO_VENDOR_ID), /* idVendor */
93 HBYTE(USBD_AUDIO_VENDOR_ID), /* idVendor */
94 LBYTE(USBD_AUDIO_PRODUCT_ID), /* idProduct */
95 HBYTE(USBD_AUDIO_PRODUCT_ID), /* idProduct */
96 0x00, /* bcdDevice rel. 2.00 */
97 0x02,
98 USB_MFC_STRING, /* Index of manufacturer string */
99 USB_PRODUCT_STRING, /* Index of product string */
100 USB_SERIAL_STRING, /* Index of serial number string */
101 0x01 /* bNumConfigurations */
102};
103
107#if defined ( __ICCARM__ ) /* iar compiler */
108 #pragma data_alignment=4
109#endif
110ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_AUDIO_CONFIG_DESC_SIZE] ALIGNED_TAIL =
111{
112 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
113 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
114 LBYTE(USBD_AUDIO_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
115 HBYTE(USBD_AUDIO_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 0x1 + AUDIO_INTERFACE_NUM, /* bNumInterfaces: n interface */
117 0x01, /* bConfigurationValue: configuration value */
118 0x00, /* iConfiguration: index of string descriptor describing
119 the configuration */
120 0xC0, /* bmAttributes: self powered */
121 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
122
123 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
124 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
125 0x00, /* bInterfaceNumber: number of interface */
126 0x00, /* bAlternateSetting: alternate set */
127 0x00, /* bNumEndpoints: number of endpoints */
128 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio class code */
129 AUDIO_SUBCLASS_AUDIOCONTROL, /* bInterfaceSubClass: audio control */
130 AUDIO_PROTOCOL_UNDEFINED, /* bInterfaceProtocol: undefined */
131 0x00, /* iInterface: index of string descriptor */
132
133 0x08+AUDIO_INTERFACE_NUM, /* bLength: size of this descriptor, in bytes 8+n */
134 AUDIO_CS_INTERFACE, /* bDescriptorType: cs interface descriptor type */
135 AUDIO_AC_HEADER, /* bDescriptorSubtype: Header function Descriptor*/
136 LBYTE(AUDIO_BCD_NUM),
137 HBYTE(AUDIO_BCD_NUM), /* bcdCDC: audio device class specification release number */
138 LBYTE(AUDIO_INTERFACE_LEN),
139 HBYTE(AUDIO_INTERFACE_LEN), /* wTotalLength: total number of bytes returned for the class-specific audio control interface */
140 AUDIO_INTERFACE_NUM, /* bInClollection: the number of audio streaming */
141#if (AUDIO_INTERFACE_NUM == 2) /* two interface */
142 0x02,
143 0x01,
144#else
145 0x01,
146#endif
147
148 /* usb microphone config */
149#if (AUDIO_SUPPORT_MIC == 1)
150 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
151 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
152 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
153 AUDIO_MIC_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
154 LBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),
155 HBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),/* wTerminalType: terminal is microphone */
156 0x00, /* bAssocTerminal: no association */
157 AUDIO_MIC_CHR, /* bNrChannels: two channel */
158#if (AUDIO_MIC_CHR == 2)
159 0x03, /* wChannelConfig: left front and right front */
160#endif
161#if (AUDIO_MIC_CHR == 1)
162 0x00, /* wChannelConfig */
163#endif
164 0x00, /* wChannelConfig */
165 0x00, /* iChannelNames: unused */
166 0x00, /* iTerminal: unused */
167
168 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
169 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
170 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
171 AUDIO_MIC_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
172 AUDIO_MIC_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
173 0x01, /* bControlSize: 1 byte */
174 0x01, /* bmaControls0: mute */
175 0x02, /* bmaControls1: volume */
176 0x00, /* iFeature: unused */
177
178 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
179 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
180 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
181 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
182 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING),
183 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
184 0x00, /* bAssocTerminal: unused */
185 AUDIO_MIC_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
186 0x00, /* iTerminal: unused */
187#endif
188
189#if (AUDIO_SUPPORT_SPK == 1)
190 /* speaker config */
191 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
192 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
193 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
194 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
195 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
196 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
197 0x00, /* bAssocTerminal: no association */
198 AUDIO_SPK_CHR, /* bNrChannels: two channel */
199#if (AUDIO_SPK_CHR == 2)
200 0x03, /* wChannelConfig: left front and right front */
201#endif
202#if (AUDIO_SPK_CHR == 1)
203 0x00, /* wChannelConfig */
204#endif
205 0x00, /* wChannelConfig */
206 0x00, /* iChannelNames: unused */
207 0x00, /* iTerminal: unused */
208
209 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
210 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
211 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
212 AUDIO_SPK_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
213 AUDIO_SPK_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
214 0x01, /* bControlSize: 1 byte */
215 0x01, /* bmaControls0: mute*/
216 0x02, /* bmaControls1: volume */
217 0x00, /* iFeature: unused */
218
219 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
220 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
221 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
222 AUDIO_SPK_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
223 LBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
224 HBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
225 0x00, /* bAssocTerminal: unused */
226 AUDIO_SPK_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
227 0x00, /* iTerminal: unused */
228#endif
229
230#if (AUDIO_SUPPORT_MIC == 1)
231 /* microphone interface */
232 0x09, /* bLength: descriptor size */
233 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
234 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
235 0x00, /* bAlternateSetting: index of this setting */
236 0x00, /* bNumEndpoints: 0 endpoints */
237 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
238 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
239 0x00, /* bInterfaceProtocol: unused */
240 0x00, /* iInterface: unused */
241
242 0x09, /* bLength: descriptor size */
243 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
244 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
245 0x01, /* bAlternateSetting: index of this setting */
246 0x01, /* bNumEndpoints: 1 endpoints */
247 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
248 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
249 0x00, /* bInterfaceProtocol: unused */
250 0x00, /* iInterface: unused */
251
252 0x07, /* bLength: configuration descriptor size */
253 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
254 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
255 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalLink: unit id of the output terminal */
256 0x01, /* bDelay: interface delay */
257 0x01, /* wFormatTag: pcm format*/
258 0x00, /* wFormatTag: pcm format*/
259
260 0x08 + AUDIO_MIC_FREQ_SIZE * 3, /* bLength: descriptor size */
261 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
262 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
263 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
264 AUDIO_MIC_CHR, /* bNrChannels: channel number */
265 AUDIO_MIC_BITW / 8, /* bSubFrameSize: per audio subframe */
266 AUDIO_MIC_BITW, /* bBitResolution: n bits per sample */
267 AUDIO_MIC_FREQ_SIZE, /* bSamFreqType: n frequency supported */
268#if (AUDIO_SUPPORT_FREQ_16K == 1)
269 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
270#endif
271#if (AUDIO_SUPPORT_FREQ_48K == 1)
272 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
273#endif
274
275 0x09, /* bLength: size of endpoint descriptor in bytes */
276 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
277 USBD_AUDIO_MIC_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
278 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
279 LBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE),
280 HBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
281 AUDIO_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
282 0x00, /* bRefresh: unused */
283 0x00, /* bSynchAddress: unused */
284
285 0x07, /* bLength: size of endpoint descriptor in bytes */
286 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
287 0x01, /* bDescriptorSubtype: general subtype */
288 0x01, /* bmAttributes */
289 0x00, /* bLockDelayUnits: unused */
290 0x00, /* wLockDelay: unused */
291 0x00, /* wLockDelay: unused */
292#endif
293
294#if (AUDIO_SUPPORT_SPK == 1)
295 /* speaker interface */
296 0x09, /* bLength: descriptor size */
297 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
298 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
299 0x00, /* bAlternateSetting: index of this setting */
300 0x00, /* bNumEndpoints: 0 endpoints */
301 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
302 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
303 0x00, /* bInterfaceProtocol: unused */
304 0x00, /* iInterface: unused */
305
306 0x09, /* bLength: descriptor size */
307 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
308 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
309 0x01, /* bAlternateSetting: index of this setting */
310 0x01 + AUDIO_SUPPORT_FEEDBACK, /* bNumEndpoints: endpoints */
311 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
312 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
313 0x00, /* bInterfaceProtocol: unused */
314 0x00, /* iInterface: unused */
315
316 0x07, /* bLength: configuration descriptor size */
317 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
318 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
319 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalLink: unit id of the input terminal */
320 0x01, /* bDelay: interface delay */
321 0x01, /* wFormatTag: pcm format*/
322 0x00, /* wFormatTag: pcm format*/
323
324 0x08 + AUDIO_SPK_FREQ_SIZE * 3, /* bLength: descriptor size */
325 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
326 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
327 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
328 AUDIO_SPK_CHR, /* bNrChannels: channel number */
329 AUDIO_SPK_BITW / 8, /* bSubFrameSize: per audio subframe */
330 AUDIO_SPK_BITW, /* bBitResolution: n bits per sample */
331 AUDIO_SPK_FREQ_SIZE, /* bSamFreqType: n frequency supported */
332#if (AUDIO_SUPPORT_FREQ_16K == 1)
333 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
334#endif
335#if (AUDIO_SUPPORT_FREQ_48K == 1)
336 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
337#endif
338
339 0x09, /* bLength: size of endpoint descriptor in bytes */
340 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
341 USBD_AUDIO_SPK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
342 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
343 LBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE),
344 HBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
345 AUDIO_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
346 0x00, /* bRefresh: unused */
347#if (AUDIO_SUPPORT_FEEDBACK == 1)
348 USBD_AUDIO_FEEDBACK_EPT, /* bSynchAddress: feedback endpoint */
349#else
350 0x00, /* bSynchAddress: unused */
351#endif
352
353 0x07, /* bLength: size of endpoint descriptor in bytes */
354 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
355 0x01, /* bDescriptorSubtype: general subtype */
356 0x01, /* bmAttributes */
357 0x00, /* bLockDelayUnits: unused */
358 0x00, /* wLockDelay: unused */
359 0x00, /* wLockDelay: unused */
360
361#if (AUDIO_SUPPORT_FEEDBACK == 1)
362 0x09, /* bLength: size of endpoint descriptor in bytes */
363 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
364 USBD_AUDIO_FEEDBACK_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
365 0x11, /* bmAttributes: endpoint attributes */
366 LBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
367 HBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
368 1, /* bInterval: interval for polling endpoint for data transfers */
369 FEEDBACK_REFRESH_TIME, /* bRefresh: this field indicates the rate at which an iso syncronization
370 pipe provides new syncronization feedback data. this rate must be a power of
371 2, therefore only the power is reported back and the range of this field is from
372 1(2ms) to 9(512ms) */
373 0x00 /* bSynchAddress: 0x00*/
374#endif
375
376#endif
377};
378
382#if defined ( __ICCARM__ ) /* iar compiler */
383 #pragma data_alignment=4
384#endif
385ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_AUDIO_SIZ_STRING_LANGID] ALIGNED_TAIL =
386{
387 USBD_AUDIO_SIZ_STRING_LANGID,
388 USB_DESCIPTOR_TYPE_STRING,
389 0x09,
390 0x04,
391};
392
396#if defined ( __ICCARM__ ) /* iar compiler */
397 #pragma data_alignment=4
398#endif
399ALIGNED_HEAD static uint8_t g_string_serial[USBD_AUDIO_SIZ_STRING_SERIAL] ALIGNED_TAIL =
400{
401 USBD_AUDIO_SIZ_STRING_SERIAL,
402 USB_DESCIPTOR_TYPE_STRING,
403};
404
405
406/* device descriptor */
407static usbd_desc_t device_descriptor =
408{
409 USB_DEVICE_DESC_LEN,
410 g_usbd_descriptor
411};
412
413/* config descriptor */
414static usbd_desc_t config_descriptor =
415{
416 USBD_AUDIO_CONFIG_DESC_SIZE,
417 g_usbd_configuration
418};
419
420/* langid descriptor */
421static usbd_desc_t langid_descriptor =
422{
423 USBD_AUDIO_SIZ_STRING_LANGID,
424 g_string_lang_id
425};
426
427/* serial descriptor */
428static usbd_desc_t serial_descriptor =
429{
430 USBD_AUDIO_SIZ_STRING_SERIAL,
431 g_string_serial
432};
433
434static usbd_desc_t vp_desc;
435
442static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
443{
444 uint16_t str_len = 0, id_pos = 2;
445 uint8_t *tmp_str = string;
446
447 while(*tmp_str != '\0')
448 {
449 str_len ++;
450 unicode_buf[id_pos ++] = *tmp_str ++;
451 unicode_buf[id_pos ++] = 0x00;
452 }
453
454 str_len = str_len * 2 + 2;
455 unicode_buf[0] = str_len;
456 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
457
458 return str_len;
459}
460
468static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
469{
470 uint8_t idx = 0;
471
472 for( idx = 0 ; idx < len ; idx ++)
473 {
474 if( ((value >> 28)) < 0xA )
475 {
476 pbuf[2 * idx] = (value >> 28) + '0';
477 }
478 else
479 {
480 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
481 }
482
483 value = value << 4;
484
485 pbuf[2 * idx + 1] = 0;
486 }
487}
488
494static void get_serial_num(void)
495{
496 uint32_t serial0, serial1, serial2;
497
498 serial0 = *(uint32_t*)MCU_ID1;
499 serial1 = *(uint32_t*)MCU_ID2;
500 serial2 = *(uint32_t*)MCU_ID3;
501
502 serial0 += serial2;
503
504 if (serial0 != 0)
505 {
506 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
507 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
508 }
509}
510
516static usbd_desc_t *get_device_descriptor(void)
517{
518 return &device_descriptor;
519}
520
526static usbd_desc_t * get_device_qualifier(void)
527{
528 return NULL;
529}
530
536static usbd_desc_t *get_device_configuration(void)
537{
538 return &config_descriptor;
539}
540
546static usbd_desc_t *get_device_other_speed(void)
547{
548 return NULL;
549}
550
556static usbd_desc_t *get_device_lang_id(void)
557{
558 return &langid_descriptor;
559}
560
561
567static usbd_desc_t *get_device_manufacturer_string(void)
568{
569 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
570 vp_desc.descriptor = g_usbd_desc_buffer;
571 return &vp_desc;
572}
573
579static usbd_desc_t *get_device_product_string(void)
580{
581 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
582 vp_desc.descriptor = g_usbd_desc_buffer;
583 return &vp_desc;
584}
585
591static usbd_desc_t *get_device_serial_string(void)
592{
593 get_serial_num();
594 return &serial_descriptor;
595}
596
602static usbd_desc_t *get_device_interface_string(void)
603{
604 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
605 vp_desc.descriptor = g_usbd_desc_buffer;
606 return &vp_desc;
607}
608
614static usbd_desc_t *get_device_config_string(void)
615{
616 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUDIO_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
617 vp_desc.descriptor = g_usbd_desc_buffer;
618 return &vp_desc;
619}
620
audio_desc.h
usb audio descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
FEEDBACK_REFRESH_TIME
#define FEEDBACK_REFRESH_TIME
Definition: audio_class.h:65
USBD_AUDIO_SPK_OUT_EPT
#define USBD_AUDIO_SPK_OUT_EPT
Definition: audio_class.h:55
USBD_AUDIO_MIC_IN_EPT
#define USBD_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_class.h:54
USBD_AUDIO_FEEDBACK_EPT
#define USBD_AUDIO_FEEDBACK_EPT
Definition: audio_class.h:56
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
AUDIO_MIC_FEATURE_UNIT_ID
#define AUDIO_MIC_FEATURE_UNIT_ID
Definition: audio_desc.h:169
AUDIO_CS_ENDPOINT
#define AUDIO_CS_ENDPOINT
Definition: audio_desc.h:76
AUDIO_AC_HEADER
#define AUDIO_AC_HEADER
Definition: audio_desc.h:91
AUDIO_SUBCLASS_AUDIOCONTROL
#define AUDIO_SUBCLASS_AUDIOCONTROL
Definition: audio_desc.h:68
AUDIO_INPUT_TERMINAL_SIZE
#define AUDIO_INPUT_TERMINAL_SIZE
audio interface descriptor size define
Definition: audio_desc.h:161
AUDIO_TERMINAL_TYPE_STREAMING
#define AUDIO_TERMINAL_TYPE_STREAMING
Definition: audio_desc.h:138
AUDIO_SPK_CHR
#define AUDIO_SPK_CHR
Definition: audio_desc.h:202
USBD_AUDIO_DESC_PRODUCT_STRING
#define USBD_AUDIO_DESC_PRODUCT_STRING
Definition: audio_desc.h:60
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:180
AUDIO_MIC_OUTPUT_TERMINAL_ID
#define AUDIO_MIC_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:170
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:178
USBD_AUDIO_PRODUCT_ID
#define USBD_AUDIO_PRODUCT_ID
Definition: audio_desc.h:54
USBD_AUDIO_CONFIG_DESC_SIZE
#define USBD_AUDIO_CONFIG_DESC_SIZE
Definition: audio_desc.h:208
AUDIO_BCD_NUM
#define AUDIO_BCD_NUM
Definition: audio_desc.h:51
SAMPLE_FREQ
#define SAMPLE_FREQ(frq)
Definition: audio_desc.h:213
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_desc.h:194
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_desc.h:201
AT32_AUDIO_FREQ_48K
#define AT32_AUDIO_FREQ_48K
Definition: audio_desc.h:189
AUDIO_FORMAT_TYPE_I
#define AUDIO_FORMAT_TYPE_I
audio format type 1
Definition: audio_desc.h:148
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
AUDIO_AS_GENERAL
#define AUDIO_AS_GENERAL
Definition: audio_desc.h:104
USBD_AUDIO_DESC_CONFIGURATION_STRING
#define USBD_AUDIO_DESC_CONFIGURATION_STRING
Definition: audio_desc.h:61
USBD_AUDIO_DESC_INTERFACE_STRING
#define USBD_AUDIO_DESC_INTERFACE_STRING
Definition: audio_desc.h:62
AUDIO_INTERFACE_NUM
#define AUDIO_INTERFACE_NUM
audio interface config
Definition: audio_desc.h:153
AUDIO_CS_INTERFACE
#define AUDIO_CS_INTERFACE
audio class-specific descriptor types
Definition: audio_desc.h:75
USBD_AUDIO_SIZ_STRING_SERIAL
#define USBD_AUDIO_SIZ_STRING_SERIAL
Definition: audio_desc.h:57
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:172
USBD_AUDIO_SIZ_STRING_LANGID
#define USBD_AUDIO_SIZ_STRING_LANGID
Definition: audio_desc.h:56
AUDIO_OUTPUT_TERMINAL_SIZE
#define AUDIO_OUTPUT_TERMINAL_SIZE
Definition: audio_desc.h:162
AUDIO_SPK_OUTPUT_TERMINAL_ID
#define AUDIO_SPK_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:173
AUDIO_AC_INPUT_TERMINAL
#define AUDIO_AC_INPUT_TERMINAL
Definition: audio_desc.h:92
AUDIO_MIC_CHR
#define AUDIO_MIC_CHR
Definition: audio_desc.h:195
AUDIO_OUTPUT_TERMINAL_SPEAKER
#define AUDIO_OUTPUT_TERMINAL_SPEAKER
Definition: audio_desc.h:143
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
AT32_AUDIO_FREQ_16K
#define AT32_AUDIO_FREQ_16K
audio support freq
Definition: audio_desc.h:188
AUDIO_AS_FORMAT_TYPE
#define AUDIO_AS_FORMAT_TYPE
Definition: audio_desc.h:105
AUDIO_MIC_INPUT_TERMINAL_ID
#define AUDIO_MIC_INPUT_TERMINAL_ID
audio terminal id define
Definition: audio_desc.h:168
AUDIO_SPK_BITW
#define AUDIO_SPK_BITW
Definition: audio_desc.h:203
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
AUDIO_FEATURE_UNIT_SIZE
#define AUDIO_FEATURE_UNIT_SIZE
Definition: audio_desc.h:163
AUDIO_PROTOCOL_UNDEFINED
#define AUDIO_PROTOCOL_UNDEFINED
audio interface protocol codes
Definition: audio_desc.h:85
AUDIO_MIC_BITW
#define AUDIO_MIC_BITW
Definition: audio_desc.h:196
USBD_AUDIO_VENDOR_ID
#define USBD_AUDIO_VENDOR_ID
Definition: audio_desc.h:53
AUDIO_AC_FEATURE_UNIT
#define AUDIO_AC_FEATURE_UNIT
Definition: audio_desc.h:96
AUDIO_SPK_INPUT_TERMINAL_ID
#define AUDIO_SPK_INPUT_TERMINAL_ID
Definition: audio_desc.h:171
AUDIO_BINTERVAL_TIME
#define AUDIO_BINTERVAL_TIME
Definition: audio_desc.h:205
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_desc.h:154
AUDIO_SUBCLASS_AUDIOSTREAMING
#define AUDIO_SUBCLASS_AUDIOSTREAMING
Definition: audio_desc.h:69
USBD_AUDIO_DESC_MANUFACTURER_STRING
#define USBD_AUDIO_DESC_MANUFACTURER_STRING
Definition: audio_desc.h:59
AUDIO_AC_OUTPUT_TERMINAL
#define AUDIO_AC_OUTPUT_TERMINAL
Definition: audio_desc.h:93
AUDIO_INPUT_TERMINAL_MICROPHONE
#define AUDIO_INPUT_TERMINAL_MICROPHONE
Definition: audio_desc.h:141
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: audio_desc.c:428
device_descriptor
static usbd_desc_t device_descriptor
Definition: audio_desc.c:407
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_desc.c:536
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: audio_desc.c:421
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_desc.c:516
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_desc.c:567
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_desc.c:526
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_desc.c:602
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: audio_desc.c:57
vp_desc
static usbd_desc_t vp_desc
Definition: audio_desc.c:434
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_desc.c:546
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: audio_desc.c:82
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_desc.c:579
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_desc.c:614
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: audio_desc.c:442
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_desc.c:556
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: audio_desc.c:494
config_descriptor
static usbd_desc_t config_descriptor
Definition: audio_desc.c:414
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_desc.c:591
audio_desc_handler
usbd_desc_handler audio_desc_handler
device descriptor handler structure
Definition: audio_desc.c:62
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: audio_desc.c:468
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_EPT_DESC_ISO
#define USB_EPT_DESC_ISO
Definition: usb_std.h:176
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_CLASS_CODE_AUDIO
#define USB_CLASS_CODE_AUDIO
usb class code
Definition: usb_std.h:161
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_ETP_DESC_ASYNC
#define USB_ETP_DESC_ASYNC
Definition: usb_std.h:181
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: audio_desc.h Source File

  • middlewares
  • usbd_class
  • audio
audio_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_DESC_H
29#define __AUDIO_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "audio_class.h"
36#include "usbd_core.h"
37#include "audio_conf.h"
38
51#define AUDIO_BCD_NUM 0x0100
52
53#define USBD_AUDIO_VENDOR_ID 0x2E3C
54#define USBD_AUDIO_PRODUCT_ID 0x5730
55
56#define USBD_AUDIO_SIZ_STRING_LANGID 4
57#define USBD_AUDIO_SIZ_STRING_SERIAL 0x1A
58
59#define USBD_AUDIO_DESC_MANUFACTURER_STRING "Artery"
60#define USBD_AUDIO_DESC_PRODUCT_STRING "AT32 Audio"
61#define USBD_AUDIO_DESC_CONFIGURATION_STRING "Audio Config"
62#define USBD_AUDIO_DESC_INTERFACE_STRING "Audio Interface"
63
67#define AUDIO_SUBCLASS_UNDEFINED 0x00
68#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01
69#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
70#define AUDIO_SUBCLASS_MIDISTREMING 0x03
71
75#define AUDIO_CS_INTERFACE 0x24
76#define AUDIO_CS_ENDPOINT 0x25
77#define AUDIO_CS_STRING 0x23
78#define AUDIO_CS_CONFIGURATION 0x22
79#define AUDIO_CS_DEVICE 0x21
80#define AUDIO_CS_UNDEFINED 0x20
81
85#define AUDIO_PROTOCOL_UNDEFINED 0x00
86
90#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
91#define AUDIO_AC_HEADER 0x01
92#define AUDIO_AC_INPUT_TERMINAL 0x02
93#define AUDIO_AC_OUTPUT_TERMINAL 0x03
94#define AUDIO_AC_MIXER_UNIT 0x04
95#define AUDIO_AC_SELECTOR_UNIT 0x05
96#define AUDIO_AC_FEATURE_UNIT 0x06
97#define AUDIO_AC_PROCESSING_UNIT 0x07
98#define AUDIO_AC_EXTENSION_UNIT 0x08
99
103#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
104#define AUDIO_AS_GENERAL 0x01
105#define AUDIO_AS_FORMAT_TYPE 0x02
106#define AUDIO_AS_FORMAT_SPECIFIC 0x03
107
111#define AUDIO_REQUEST_CODE_UNDEFINED 0x00
112#define AUDIO_REQ_SET_CUR 0x01
113#define AUDIO_REQ_GET_CUR 0x81
114#define AUDIO_REQ_SET_MIN 0x02
115#define AUDIO_REQ_GET_MIN 0x82
116#define AUDIO_REQ_SET_MAX 0x03
117#define AUDIO_REQ_GET_MAX 0x83
118#define AUDIO_REQ_SET_RES 0x04
119#define AUDIO_REQ_GET_RES 0x84
120#define AUDIO_REQ_SET_MEM 0x05
121#define AUDIO_REQ_GET_MEM 0x85
122#define AUDIO_REQ_GET_STAT 0xFF
123
127#define AUDIO_FU_CONTROL_UNDEFINED 0x00
128#define AUDIO_FU_MUTE_CONTROL 0x01
129#define AUDIO_FU_VOLUME_CONTROL 0x02
130#define AUDIO_FU_BASS_CONTROL 0x03
131#define AUDIO_FU_MID_CONTROL 0x04
132#define AUDIO_FU_TREBLE_CONTROL 0x05
133
137#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
138#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101
139#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
140#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
141#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
142#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
143#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
144
148#define AUDIO_FORMAT_TYPE_I 0x01
149
153#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
154#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
155#define AUDIO_MIC_INTERFACE 0x01
156#define AUDIO_SPK_INTERFACE 0x02
157
161#define AUDIO_INPUT_TERMINAL_SIZE 0x0C
162#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09
163#define AUDIO_FEATURE_UNIT_SIZE 0x09
164
168#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01
169#define AUDIO_MIC_FEATURE_UNIT_ID 0x02
170#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
171#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04
172#define AUDIO_SPK_FEATURE_UNIT_ID 0x05
173#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
174
178#define AUDIO_MIC_INTERFACE_NUMBER 0x01
179#if (AUDIO_SUPPORT_MIC == 1)
180#define AUDIO_SPK_INTERFACE_NUMBER 0x02
181#else
182#define AUDIO_SPK_INTERFACE_NUMBER 0x01
183#endif
184
188#define AT32_AUDIO_FREQ_16K 16000
189#define AT32_AUDIO_FREQ_48K 48000
190
194#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
195#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
196#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
197
201#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
202#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
203#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
204
205#define AUDIO_BINTERVAL_TIME 0x01
206
207
208#define USBD_AUDIO_CONFIG_DESC_SIZE ( 0x12 + AUDIO_INTERFACE_LEN + \
209 + (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
210 + (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
211 + (9 * AUDIO_SUPPORT_FEEDBACK) \
212 )
213#define SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
214
215#define MCU_ID1 (0x1FFFF7E8)
216#define MCU_ID2 (0x1FFFF7EC)
217#define MCU_ID3 (0x1FFFF7F0)
218
219extern usbd_desc_handler audio_desc_handler;
220
232#ifdef __cplusplus
233}
234#endif
235
236#endif
237
audio_class.h
usb audio class file
audio_conf.h
usb audio config
audio_desc_handler
usbd_desc_handler audio_desc_handler
device descriptor handler structure
Definition: audio_desc.c:62
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_conf.h Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid/audio_conf.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CONF_H
29#define __AUDIO_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
47#define AUDIO_SUPPORT_SPK 1
48#define AUDIO_SUPPORT_MIC 1
49#define AUDIO_SUPPORT_FEEDBACK 1
50
51#define AUDIO_SUPPORT_FREQ_16K 0
52#define AUDIO_SUPPORT_FREQ_48K 1
53
54
55#define AUDIO_SUPPORT_FREQ (AUDIO_SUPPORT_FREQ_16K + \
56 AUDIO_SUPPORT_FREQ_48K \
57 )
58
59#define AUDIO_FREQ_16K 16000
60#define AUDIO_FREQ_48K 48000
61#define AUDIO_BITW_16 16
62
63#define AUDIO_MIC_CHANEL_NUM 2
64#define AUDIO_MIC_DEFAULT_BITW AUDIO_BITW_16
65
66#define AUDIO_SPK_CHANEL_NUM 2
67#define AUDIO_SPK_DEFAULT_BITW AUDIO_BITW_16
68
69
70#define AUDIO_SUPPORT_MAX_FREQ 48
71#define AUDIO_DEFAULT_FREQ AUDIO_FREQ_48K
72#define AUDIO_DEFAULT_BITW AUDIO_BITW_16
73
85#ifdef __cplusplus
86}
87#endif
88
89#endif
90
91
92


AT32F413 Firmwary Library: audio_hid_class.c Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "audio_hid_class.h"
28#include "audio_hid_desc.h"
29#include "audio_codec.h"
30
44static usb_sts_type class_init_handler(void *udev);
45static usb_sts_type class_clear_handler(void *udev);
46static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
47static usb_sts_type class_ept0_tx_handler(void *udev);
48static usb_sts_type class_ept0_rx_handler(void *udev);
49static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
51static usb_sts_type class_sof_handler(void *udev);
52static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
53
54static void audio_req_get_cur(void *udev, usb_setup_type *setup);
55static void audio_req_set_cur(void *udev, usb_setup_type *setup);
56static void audio_req_get_min(void *udev, usb_setup_type *setup);
57static void audio_req_get_max(void *udev, usb_setup_type *setup);
58static void audio_req_get_res(void *udev, usb_setup_type *setup);
59static void audio_get_interface(void *udev, usb_setup_type *setup);
60static void audio_set_interface(void *udev, usb_setup_type *setup);
61static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len);
62 usb_audio_hid_type audio_hid_struct = {0, 0, 0, 0, 0, 0x1400, 0, 0, 0, {0x0000, 0x1400, 0x33}, {0x0000, 0x1400, 0x33}, 0, 0};
63
64 usbd_class_handler audio_hid_class_handler =
65{
66 class_init_handler,
67 class_clear_handler,
68 class_setup_handler,
69 class_ept0_tx_handler,
70 class_ept0_rx_handler,
71 class_in_handler,
72 class_out_handler,
73 class_sof_handler,
74 class_event_handler,
75 &audio_hid_struct
76};
77
83static usb_sts_type class_init_handler(void *udev)
84{
85 usb_sts_type status = USB_OK;
86 usbd_core_type *pudev = (usbd_core_type *)udev;
87 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
88 /* enable microphone in endpoint double buffer mode */
89 usbd_ept_dbuffer_enable(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT);
90
91 /* open microphone in endpoint */
92 usbd_ept_open(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT, EPT_ISO_TYPE, AUDIO_MIC_IN_MAXPACKET_SIZE);
93
94 /* enable speaker out endpoint double buffer mode */
95 usbd_ept_dbuffer_enable(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT);
96
97 /* open speaker out endpoint */
98 usbd_ept_open(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, EPT_ISO_TYPE, AUDIO_SPK_OUT_MAXPACKET_SIZE);
99#if AUDIO_SUPPORT_FEEDBACK
100 /* enable speaker feedback endpoint double buffer mode */
101 usbd_ept_dbuffer_enable(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT);
102
103 /* open speaker feedback endpoint */
104 usbd_ept_open(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT, EPT_ISO_TYPE, AUDIO_FEEDBACK_MAXPACKET_SIZE);
105#endif
106 /* start receive speaker out data */
107 usbd_ept_recv(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, paudio_hid->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
108
109 /*open hid endpoint */
110
111 /* open custom hid in endpoint */
112 usbd_ept_open(pudev, USBD_AUHID_HID_IN_EPT, EPT_INT_TYPE, USBD_AUHID_IN_MAXPACKET_SIZE);
113
114 /* open custom hid out endpoint */
115 usbd_ept_open(pudev, USBD_AUHID_HID_OUT_EPT, EPT_INT_TYPE, USBD_AUHID_OUT_MAXPACKET_SIZE);
116
117 /* set out endpoint to receive status */
118 usbd_ept_recv(pudev, USBD_AUHID_HID_OUT_EPT, paudio_hid->g_rxhid_buff, USBD_AUHID_OUT_MAXPACKET_SIZE);
119
120 return status;
121}
122
128static usb_sts_type class_clear_handler(void *udev)
129{
130 usb_sts_type status = USB_OK;
131 usbd_core_type *pudev = (usbd_core_type *)udev;
132
133 /* close in endpoint */
134 usbd_ept_close(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT);
135
136#if AUDIO_SUPPORT_FEEDBACK
137 /* close in endpoint */
138 usbd_ept_close(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT);
139#endif
140
141 /* close out endpoint */
142 usbd_ept_close(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT);
143
144 /* close custom hid in endpoint */
145 usbd_ept_close(pudev, USBD_AUHID_HID_IN_EPT);
146
147 /* close custom hid out endpoint */
148 usbd_ept_close(pudev, USBD_AUHID_HID_OUT_EPT);
149
150 return status;
151}
152
159 usb_sts_type class_audio_setup_handler(void *udev, usb_setup_type *setup)
160{
161 usb_sts_type status = USB_OK;
162 usbd_core_type *pudev = (usbd_core_type *)udev;
163 uint16_t len;
164
165 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
166 {
167 /* class request */
168 case USB_REQ_TYPE_CLASS:
169 switch(setup->bRequest)
170 {
171 case AUDIO_REQ_GET_CUR:
172 audio_req_get_cur(pudev, setup);
173 break;
174
175 case AUDIO_REQ_SET_CUR:
176 audio_req_set_cur(pudev, setup);
177 break;
178
179 case AUDIO_REQ_GET_MIN:
180 audio_req_get_min(pudev, setup);
181 break;
182
183 case AUDIO_REQ_GET_MAX:
184 audio_req_get_max(pudev, setup);
185 break;
186
187 case AUDIO_REQ_GET_RES:
188 audio_req_get_res(pudev, setup);
189 break;
190
191 default:
192 usbd_ctrl_unsupport(pudev);
193 break;
194 }
195 break;
196 /* standard request */
197 case USB_REQ_TYPE_STANDARD:
198 switch(setup->bRequest)
199 {
200 case USB_STD_REQ_GET_DESCRIPTOR:
201 if((setup->wValue >> 8) == AUDIO_DESCRIPTOR_TYPE)
202 {
203 usbd_desc_t *config = pudev->desc_handler->get_device_configuration();
204 len = MIN(AUDIO_DESCRIPTOR_SIZE, setup->wLength);
205 usbd_ctrl_send(pudev, config->descriptor + 18, len);
206 }
207 else
208 {
209 usbd_ctrl_unsupport(pudev);
210 }
211 break;
212 case USB_STD_REQ_GET_INTERFACE:
213 audio_get_interface(udev, setup);
214 break;
215
216 case USB_STD_REQ_SET_INTERFACE:
217 audio_set_interface(udev, setup);
218 usbd_ctrl_send_status(pudev);
219 break;
220
221 default:
222 break;
223 }
224 break;
225
226 default:
227 usbd_ctrl_unsupport(pudev);
228 break;
229 }
230 return status;
231
232}
233
240 usb_sts_type class_hid_setup_handler(void *udev, usb_setup_type *setup)
241{
242 usb_sts_type status = USB_OK;
243 usbd_core_type *pudev = (usbd_core_type *)udev;
244 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
245 uint16_t len;
246 uint8_t *buf;
247
248 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
249 {
250 /* class request */
251 case USB_REQ_TYPE_CLASS:
252 switch(setup->bRequest)
253 {
254 case HID_REQ_SET_PROTOCOL:
255 paudio_hid->hid_protocol = (uint8_t)setup->wValue;
256 break;
257 case HID_REQ_GET_PROTOCOL:
258 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->hid_protocol, 1);
259 break;
260 case HID_REQ_SET_IDLE:
261 paudio_hid->hid_set_idle = (uint8_t)(setup->wValue >> 8);
262 break;
263 case HID_REQ_GET_IDLE:
264 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->hid_set_idle, 1);
265 break;
266 case HID_REQ_SET_REPORT:
267 paudio_hid->hid_state = HID_REQ_SET_REPORT;
268 usbd_ctrl_recv(pudev, paudio_hid->hid_set_report, setup->wLength);
269 break;
270 default:
271 usbd_ctrl_unsupport(pudev);
272 break;
273 }
274 break;
275 /* standard request */
276 case USB_REQ_TYPE_STANDARD:
277 switch(setup->bRequest)
278 {
279 case USB_STD_REQ_GET_DESCRIPTOR:
280 if(setup->wValue >> 8 == HID_REPORT_DESC)
281 {
282 len = MIN(USBD_AUHID_HID_SIZ_REPORT_DESC, setup->wLength);
283 buf = (uint8_t *)g_usbd_audio_hid_report;
284 }
285 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
286 {
287 len = MIN(9, setup->wLength);
288 buf = (uint8_t *)g_audio_hid_usb_desc;
289 }
290 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
291 break;
292 case USB_STD_REQ_GET_INTERFACE:
293 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->alt_setting, 1);
294 break;
295 case USB_STD_REQ_SET_INTERFACE:
296 paudio_hid->alt_setting = setup->wValue;
297 break;
298 default:
299 break;
300 }
301 break;
302 default:
303 usbd_ctrl_unsupport(pudev);
304 break;
305 }
306 return status;
307}
314 usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
315{
316 usb_sts_type status = USB_OK;
317 usbd_core_type *pudev = (usbd_core_type *)udev;
318 switch(setup->bmRequestType & USB_REQ_RECIPIENT_MASK)
319 {
320 case USB_REQ_RECIPIENT_INTERFACE:
321 if(setup->wIndex == HID_INTERFACE_NUMBER)
322 {
323 class_hid_setup_handler(udev, setup);
324 }
325 else
326 {
327 class_audio_setup_handler(pudev, setup);
328 }
329 break;
330 case USB_REQ_RECIPIENT_ENDPOINT:
331 class_audio_setup_handler(pudev, setup);
332 break;
333
334 }
335 return status;
336
337
338}
339
345 usb_sts_type class_ept0_tx_handler(void *udev)
346{
347 usb_sts_type status = USB_OK;
348
349 /* ...user code... */
350
351 return status;
352}
353
359static usb_sts_type class_ept0_rx_handler(void *udev)
360{
361 usb_sts_type status = USB_OK;
362 usbd_core_type *pudev = (usbd_core_type *)udev;
363 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
364 usb_setup_type *setup = &pudev->setup;
365 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
366
367 /* ...user code... */
368 if(setup->wIndex == HID_INTERFACE_NUMBER)
369 {
370 if( paudio_hid->hid_state == HID_REQ_SET_REPORT)
371 {
372 /* hid buffer process */
373 usb_hid_buf_process(udev, paudio_hid->hid_set_report, recv_len);
374 paudio_hid->hid_state = 0;
375 }
376 }
377 else
378 {
379 /* ...user code... */
380 if( paudio_hid->audio_cmd == AUDIO_REQ_SET_CUR)
381 {
382 /* class process */
383 switch(paudio_hid->request_no)
384 {
385 case AUDIO_VOLUME_CONTROL:
386 if(paudio_hid->interface == AUDIO_SPK_FEATURE_UNIT_ID)
387 {
388 paudio_hid->spk_volume = (uint16_t)(paudio_hid->g_audio_cur[0] |
389 (paudio_hid->g_audio_cur[1] << 8));
390 /* set volume */
391 audio_codec_set_spk_volume(paudio_hid->spk_volume*100/paudio_hid->spk_volume_limits[1]);
392 }
393 else
394 {
395 paudio_hid->mic_volume = (uint16_t)(paudio_hid->g_audio_cur[0] |
396 (paudio_hid->g_audio_cur[1] << 8));
397
398 audio_codec_set_mic_volume(paudio_hid->mic_volume*256/paudio_hid->mic_volume_limits[1]);
399 }
400 break;
401 case AUDIO_MUTE_CONTROL:
402 if(paudio_hid->interface == AUDIO_SPK_FEATURE_UNIT_ID)
403 {
404 paudio_hid->spk_mute = paudio_hid->g_audio_cur[0];
405 audio_codec_set_spk_mute(paudio_hid->spk_mute);
406 }
407 else
408 {
409 paudio_hid->mic_mute = paudio_hid->g_audio_cur[0];
410 audio_codec_set_mic_mute(paudio_hid->mic_mute);
411 }
412
413 break;
414 case AUDIO_FREQ_SET_CONTROL:
415 if(paudio_hid->enpd == USBD_AUHID_AUDIO_MIC_IN_EPT)
416 {
417 paudio_hid->mic_freq = (paudio_hid->g_audio_cur[0] |
418 (paudio_hid->g_audio_cur[1] << 8) |
419 (paudio_hid->g_audio_cur[2] << 16));
420 audio_codec_set_mic_freq(paudio_hid->mic_freq);
421 }
422 else
423 {
424 paudio_hid->spk_freq = (paudio_hid->g_audio_cur[0] |
425 (paudio_hid->g_audio_cur[1] << 8) |
426 (paudio_hid->g_audio_cur[2] << 16));
427 audio_codec_set_spk_freq(paudio_hid->spk_freq);
428 }
429 break;
430 default:
431 break;
432 }
433 }
434 }
435
436 return status;
437}
438
445 usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
446{
447 usb_sts_type status = USB_OK;
448 usbd_core_type *pudev = (usbd_core_type *)udev;
449 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
450 uint32_t len = 0;
451
452 /* ...user code...
453 trans next packet data
454 */
455 if((ept_num & 0x7F) == (USBD_AUHID_AUDIO_MIC_IN_EPT & 0x7F))
456 {
457 len = audio_codec_mic_get_data(paudio_hid->audio_mic_data);
458 usbd_ept_send(udev, USBD_AUHID_AUDIO_MIC_IN_EPT, paudio_hid->audio_mic_data, len);
459 }
460#if AUDIO_SUPPORT_FEEDBACK
461 else if((ept_num & 0x7F) == (USBD_AUHID_AUDIO_FEEDBACK_EPT & 0x7F))
462 {
463 len = audio_codec_spk_feedback(paudio_hid->audio_feed_back);
464 usbd_ept_send(udev, USBD_AUHID_AUDIO_FEEDBACK_EPT, paudio_hid->audio_feed_back, len);
465 }
466#endif
467 else if((ept_num & 0x7F) == (USBD_AUHID_HID_IN_EPT & 0x7F))
468 {
469
470 }
471
472 return status;
473}
474
481static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
482{
483 usb_sts_type status = USB_OK;
484 usbd_core_type *pudev = (usbd_core_type *)udev;
485 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
486 uint16_t g_rxlen;
487
488 /* get endpoint receive data length */
489 g_rxlen = usbd_get_recv_len(pudev, ept_num);
490
491 if((ept_num & 0x7F) == (USBD_AUHID_AUDIO_SPK_OUT_EPT & 0x7F))
492 {
493 /* speaker data*/
494 audio_codec_spk_fifo_write(paudio_hid->audio_spk_data, g_rxlen);
495
496 /* get next data */
497 usbd_ept_recv(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, paudio_hid->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
498 }
499 else if((ept_num & 0x7F) == (USBD_AUHID_HID_OUT_EPT & 0x7F))
500 {
501 /* hid buffer process */
502 usb_hid_buf_process(udev, paudio_hid->g_rxhid_buff, g_rxlen);
503
504 /* start receive next packet */
505 usbd_ept_recv(pudev, USBD_AUHID_HID_OUT_EPT, paudio_hid->g_rxhid_buff, USBD_AUHID_OUT_MAXPACKET_SIZE);
506 }
507 return status;
508}
509
515static usb_sts_type class_sof_handler(void *udev)
516{
517 usb_sts_type status = USB_OK;
518
519 /* ...user code... */
520
521 return status;
522}
523
530static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
531{
532 usb_sts_type status = USB_OK;
533 usbd_core_type *pudev = (usbd_core_type *)udev;
534 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
535 switch(event)
536 {
537 case USBD_RESET_EVENT:
538
539 /* ...user code... */
540
541 break;
542 case USBD_SUSPEND_EVENT:
543 paudio_hid->spk_alt_setting = 0;
544 audio_codec_spk_alt_setting(paudio_hid->spk_alt_setting);
545 paudio_hid->mic_alt_setting = 0;
546 audio_codec_mic_alt_setting(paudio_hid->spk_alt_setting);
547 /* ...user code... */
548
549 break;
550 case USBD_WAKEUP_EVENT:
551 /* ...user code... */
552
553 break;
554 default:
555 break;
556 }
557 return status;
558}
559
566static void audio_req_get_cur(void *udev, usb_setup_type *setup)
567{
568 usbd_core_type *pudev = (usbd_core_type *)udev;
569 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
570 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
571 {
572 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
573 {
574 paudio_hid->g_audio_cur[0] = paudio_hid->spk_mute;
575 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
576 }
577 else
578 {
579 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume;
580 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
581 }
582 }
583 else
584 {
585 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
586 {
587 paudio_hid->g_audio_cur[0] = paudio_hid->mic_mute;
588 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
589 }
590 else
591 {
592 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume;
593 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
594 }
595
596 }
597}
598
605static void audio_req_set_cur(void *udev, usb_setup_type *setup)
606{
607 usbd_core_type *pudev = (usbd_core_type *)udev;
608 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
609 if(setup->wLength > 0)
610 {
611 usbd_ctrl_recv(pudev, paudio_hid->g_audio_cur, setup->wLength);
612
613 paudio_hid->audio_cmd = AUDIO_REQ_SET_CUR;
614 paudio_hid->audio_cmd_len = setup->wLength;
615
616 switch(setup->bmRequestType & AUDIO_REQ_CONTROL_MASK)
617 {
618 case AUDIO_REQ_CONTROL_INTERFACE:
619 paudio_hid->interface = HBYTE(setup->wIndex);
620 if(HBYTE(setup->wValue) == AUDIO_MUTE_CONTROL)
621 {
622 paudio_hid->request_no = AUDIO_MUTE_CONTROL;
623 }
624 else
625 {
626 paudio_hid->request_no = AUDIO_VOLUME_CONTROL;
627 }
628 break;
629 case AUDIO_REQ_CONTROL_ENDPOINT:
630 paudio_hid->enpd = setup->wIndex;
631 paudio_hid->request_no = AUDIO_FREQ_SET_CONTROL;
632 break;
633 default:
634 break;
635 }
636 }
637}
638
645static void audio_req_get_min(void *udev, usb_setup_type *setup)
646{
647 usbd_core_type *pudev = (usbd_core_type *)udev;
648 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
649 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
650 {
651 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume_limits[0];
652 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
653 }
654 else
655 {
656 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume_limits[0];
657 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
658 }
659}
660
667static void audio_req_get_max(void *udev, usb_setup_type *setup)
668{
669 usbd_core_type *pudev = (usbd_core_type *)udev;
670 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
671 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
672 {
673 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume_limits[1];
674 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
675 }
676 else
677 {
678 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume_limits[1];
679 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
680 }
681}
682
689static void audio_req_get_res(void *udev, usb_setup_type *setup)
690{
691 usbd_core_type *pudev = (usbd_core_type *)udev;
692 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
693 if(HBYTE(setup->wIndex) == AUDIO_SPK_FEATURE_UNIT_ID)
694 {
695 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->spk_volume_limits[2];
696 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
697 }
698 else
699 {
700 *((uint16_t *)paudio_hid->g_audio_cur) = paudio_hid->mic_volume_limits[2];
701 usbd_ctrl_send(pudev, paudio_hid->g_audio_cur, setup->wLength);
702 }
703}
704
711static void audio_set_interface(void *udev, usb_setup_type *setup)
712{
713 uint32_t len;
714 usbd_core_type *pudev = (usbd_core_type *)udev;
715 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
716 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
717 {
718 paudio_hid->spk_alt_setting = setup->wValue;
719 audio_codec_spk_alt_setting(paudio_hid->spk_alt_setting);
720 if(paudio_hid->spk_alt_setting )
721 {
722 int len = audio_codec_spk_feedback(paudio_hid->audio_feed_back);
723 usbd_ept_recv(pudev, USBD_AUHID_AUDIO_SPK_OUT_EPT, paudio_hid->audio_spk_data, AUDIO_SPK_OUT_MAXPACKET_SIZE);
724 usbd_ept_send(pudev, USBD_AUHID_AUDIO_FEEDBACK_EPT, paudio_hid->audio_feed_back, len);
725 }
726
727 }
728 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
729 {
730 paudio_hid->mic_alt_setting = setup->wValue;
731 audio_codec_mic_alt_setting(paudio_hid->mic_alt_setting);
732 if(paudio_hid->mic_alt_setting)
733 {
734 len = audio_codec_mic_get_data(paudio_hid->audio_mic_data);
735 usbd_ept_send(pudev, USBD_AUHID_AUDIO_MIC_IN_EPT, paudio_hid->audio_mic_data, len);
736 }
737 }
738
739}
740
741
748static void audio_get_interface(void *udev, usb_setup_type *setup)
749{
750 usbd_core_type *pudev = (usbd_core_type *)udev;
751 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
752 if(LBYTE(setup->wIndex) == AUDIO_SPK_INTERFACE_NUMBER)
753 {
754 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->spk_alt_setting, 1);
755 }
756 else if(LBYTE(setup->wIndex) == AUDIO_MIC_INTERFACE_NUMBER)
757 {
758 usbd_ctrl_send(pudev, (uint8_t *)&paudio_hid->mic_alt_setting, 1);
759 }
760
761}
762
770 usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
771{
772 usb_sts_type status = USB_OK;
773 usbd_core_type *pudev = (usbd_core_type *)udev;
774
775 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
776 usbd_ept_send(pudev, USBD_AUHID_HID_IN_EPT, report, len);
777
778 return status;
779}
780
781
789static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
790{
791 uint32_t i_index;
792 usbd_core_type *pudev = (usbd_core_type *)udev;
793 usb_audio_hid_type *paudio_hid = (usb_audio_hid_type *)pudev->class_handler->pdata;
794
795 switch(report[0])
796 {
797 case HID_REPORT_ID_2:
798 if(paudio_hid->g_rxhid_buff[1] == 0)
799 {
800 at32_led_off(LED2);
801 }
802 else
803 {
804 at32_led_on(LED2);
805 }
806 break;
807 case HID_REPORT_ID_3:
808 if(paudio_hid->g_rxhid_buff[1] == 0)
809 {
810 at32_led_off(LED3);
811 }
812 else
813 {
814 at32_led_on(LED3);
815 }
816 break;
817 case HID_REPORT_ID_4:
818 if(paudio_hid->g_rxhid_buff[1] == 0)
819 {
820 at32_led_off(LED4);
821 }
822 else
823 {
824 at32_led_on(LED4);
825 }
826 break;
827 case HID_REPORT_ID_6:
828 for(i_index = 0; i_index < len; i_index ++)
829 {
830 paudio_hid->g_txhid_buff[i_index] = report[i_index];
831 }
832 usbd_ept_send(pudev, USBD_AUHID_HID_IN_EPT, paudio_hid->g_txhid_buff, len);
833 break;
834 default:
835 break;
836 }
837
838}
839
840
audio_hid_class.h
audio_hid_desc.h
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
AUDIO_DESCRIPTOR_TYPE
#define AUDIO_DESCRIPTOR_TYPE
audio descriptor type
Definition: audio_class.h:83
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_MUTE_CONTROL
#define AUDIO_MUTE_CONTROL
audio set cur type define
Definition: audio_class.h:76
AUDIO_REQ_CONTROL_INTERFACE
#define AUDIO_REQ_CONTROL_INTERFACE
request type define
Definition: audio_class.h:69
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
AUDIO_VOLUME_CONTROL
#define AUDIO_VOLUME_CONTROL
Definition: audio_class.h:77
AUDIO_FREQ_SET_CONTROL
#define AUDIO_FREQ_SET_CONTROL
Definition: audio_class.h:78
AUDIO_REQ_CONTROL_ENDPOINT
#define AUDIO_REQ_CONTROL_ENDPOINT
Definition: audio_class.h:70
AUDIO_REQ_CONTROL_MASK
#define AUDIO_REQ_CONTROL_MASK
Definition: audio_class.h:71
AUDIO_DESCRIPTOR_SIZE
#define AUDIO_DESCRIPTOR_SIZE
Definition: audio_class.h:84
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
AUDIO_REQ_GET_CUR
#define AUDIO_REQ_GET_CUR
Definition: audio_desc.h:113
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:180
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:178
AUDIO_REQ_GET_MAX
#define AUDIO_REQ_GET_MAX
Definition: audio_desc.h:117
AUDIO_REQ_GET_MIN
#define AUDIO_REQ_GET_MIN
Definition: audio_desc.h:115
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:172
AUDIO_REQ_GET_RES
#define AUDIO_REQ_GET_RES
Definition: audio_desc.h:119
AUDIO_REQ_SET_CUR
#define AUDIO_REQ_SET_CUR
Definition: audio_desc.h:112
USBD_AUHID_AUDIO_MIC_IN_EPT
#define USBD_AUHID_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_hid_class.h:54
USBD_AUHID_HID_IN_EPT
#define USBD_AUHID_HID_IN_EPT
usb custom hid use endpoint define
Definition: audio_hid_class.h:61
USBD_AUHID_HID_OUT_EPT
#define USBD_AUHID_HID_OUT_EPT
Definition: audio_hid_class.h:62
USBD_AUHID_AUDIO_FEEDBACK_EPT
#define USBD_AUHID_AUDIO_FEEDBACK_EPT
Definition: audio_hid_class.h:56
USBD_AUHID_OUT_MAXPACKET_SIZE
#define USBD_AUHID_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:68
USBD_AUHID_AUDIO_SPK_OUT_EPT
#define USBD_AUHID_AUDIO_SPK_OUT_EPT
Definition: audio_hid_class.h:55
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:67
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: audio_hid_class.c:515
audio_hid_class_send_report
usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: audio_hid_class.c:770
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: audio_hid_class.c:128
audio_hid_class_handler
usbd_class_handler audio_hid_class_handler
Definition: audio_hid_class.c:64
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: audio_hid_class.c:359
audio_req_get_res
static void audio_req_get_res(void *udev, usb_setup_type *setup)
usb audio request get res
Definition: audio_hid_class.c:689
audio_get_interface
static void audio_get_interface(void *udev, usb_setup_type *setup)
usb audio get interface
Definition: audio_hid_class.c:748
class_hid_setup_handler
usb_sts_type class_hid_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:240
audio_req_set_cur
static void audio_req_set_cur(void *udev, usb_setup_type *setup)
usb audio request set cur
Definition: audio_hid_class.c:605
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: audio_hid_class.c:530
audio_req_get_max
static void audio_req_get_max(void *udev, usb_setup_type *setup)
usb audio request get max
Definition: audio_hid_class.c:667
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:314
usb_hid_buf_process
static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
usb device report function
Definition: audio_hid_class.c:789
audio_req_get_min
static void audio_req_get_min(void *udev, usb_setup_type *setup)
usb audio request get min
Definition: audio_hid_class.c:645
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: audio_hid_class.c:83
audio_hid_struct
usb_audio_hid_type audio_hid_struct
Definition: audio_hid_class.c:62
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: audio_hid_class.c:345
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: audio_hid_class.c:481
audio_req_get_cur
static void audio_req_get_cur(void *udev, usb_setup_type *setup)
usb audio request get cur
Definition: audio_hid_class.c:566
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: audio_hid_class.c:445
audio_set_interface
static void audio_set_interface(void *udev, usb_setup_type *setup)
usb audio set interface
Definition: audio_hid_class.c:711
class_audio_setup_handler
usb_sts_type class_audio_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: audio_hid_class.c:159
USBD_AUHID_HID_SIZ_REPORT_DESC
#define USBD_AUHID_HID_SIZ_REPORT_DESC
Definition: audio_hid_desc.h:236
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:223
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:225
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:227
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:224
g_audio_hid_usb_desc
uint8_t g_audio_hid_usb_desc[9]
usb hid descriptor
Definition: audio_hid_desc.c:521
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:423
HID_INTERFACE_NUMBER
#define HID_INTERFACE_NUMBER
Definition: audio_hid_desc.h:183
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:169
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:217
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:195
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:121
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:282
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:184
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: audio/src/audio_codec.c:244
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:228
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:206
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:154
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:137
EPT_ISO_TYPE
@ EPT_ISO_TYPE
Definition: at32f413_usb.h:206
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:58
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:56
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:55
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_ept_dbuffer_enable
void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer.
Definition: usbd_core.c:406
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:211
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
usb_audio_hid_type
usb audio control struct
Definition: audio_hid_class.h:113
usb_audio_hid_type::spk_volume_limits
uint16_t spk_volume_limits[3]
Definition: audio_hid_class.h:123
usb_audio_hid_type::audio_cmd
uint8_t audio_cmd
Definition: audio_hid_class.h:126
usb_audio_hid_type::request_no
uint8_t request_no
Definition: audio_hid_class.h:116
usb_audio_hid_type::g_txhid_buff
uint8_t g_txhid_buff[0x40]
Definition: audio_hid_class.h:143
usb_audio_hid_type::mic_freq
uint32_t mic_freq
Definition: audio_hid_class.h:122
usb_audio_hid_type::interface
uint8_t interface
Definition: audio_hid_class.h:115
usb_audio_hid_type::audio_spk_data
uint8_t audio_spk_data[(48 *2 *(16/8)+40)]
Definition: audio_hid_class.h:131
usb_audio_hid_type::spk_volume
uint16_t spk_volume
Definition: audio_hid_class.h:119
usb_audio_hid_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_hid_class.h:129
usb_audio_hid_type::mic_volume
uint16_t mic_volume
Definition: audio_hid_class.h:120
usb_audio_hid_type::alt_setting
uint32_t alt_setting
Definition: audio_hid_class.h:139
usb_audio_hid_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_hid_class.h:128
usb_audio_hid_type::enpd
uint8_t enpd
Definition: audio_hid_class.h:114
usb_audio_hid_type::hid_state
uint8_t hid_state
Definition: audio_hid_class.h:140
usb_audio_hid_type::mic_mute
uint8_t mic_mute
Definition: audio_hid_class.h:118
usb_audio_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: audio_hid_class.h:138
usb_audio_hid_type::mic_volume_limits
uint16_t mic_volume_limits[3]
Definition: audio_hid_class.h:124
usb_audio_hid_type::audio_feed_back
uint8_t audio_feed_back[0x3+1]
Definition: audio_hid_class.h:133
usb_audio_hid_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_hid_class.h:127
usb_audio_hid_type::g_rxhid_buff
uint8_t g_rxhid_buff[0x40]
Definition: audio_hid_class.h:142
usb_audio_hid_type::spk_freq
uint32_t spk_freq
Definition: audio_hid_class.h:121
usb_audio_hid_type::audio_mic_data
uint8_t audio_mic_data[(48 *2 *(16/8)+40)]
Definition: audio_hid_class.h:132
usb_audio_hid_type::hid_set_report
uint8_t hid_set_report[64]
Definition: audio_hid_class.h:141
usb_audio_hid_type::g_audio_cur
uint8_t g_audio_cur[64]
Definition: audio_hid_class.h:130
usb_audio_hid_type::hid_protocol
uint32_t hid_protocol
Definition: audio_hid_class.h:137
usb_audio_hid_type::spk_mute
uint8_t spk_mute
Definition: audio_hid_class.h:117
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core_type::setup
usb_setup_type setup
Definition: usbd_core.h:119
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:114
usbd_desc_handler::get_device_configuration
usbd_desc_t *(* get_device_configuration)(void)
Definition: usbd_core.h:79
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_hid_class.h Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_HID_CLASS_H
29#define __AUDIO_HID_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37#include "audio_conf.h"
38
54#define USBD_AUHID_AUDIO_MIC_IN_EPT 0x81
55#define USBD_AUHID_AUDIO_SPK_OUT_EPT 0x02
56#define USBD_AUHID_AUDIO_FEEDBACK_EPT 0x83
57
61#define USBD_AUHID_HID_IN_EPT 0x84
62#define USBD_AUHID_HID_OUT_EPT 0x05
63
67#define USBD_AUHID_IN_MAXPACKET_SIZE 0x40
68#define USBD_AUHID_OUT_MAXPACKET_SIZE 0x40
69
73#define AUDIO_REMAIN_SIZE 40
74#define AUDIO_MIC_IN_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_MIC_CHANEL_NUM * (AUDIO_MIC_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
75#define AUDIO_SPK_OUT_MAXPACKET_SIZE (AUDIO_SUPPORT_MAX_FREQ * AUDIO_SPK_CHANEL_NUM * (AUDIO_SPK_DEFAULT_BITW / 8) + AUDIO_REMAIN_SIZE)
76#define AUDIO_FEEDBACK_MAXPACKET_SIZE 0x3
77#define FEEDBACK_REFRESH_TIME 0x8
81#define AUDIO_REQ_CONTROL_INTERFACE 0x01
82#define AUDIO_REQ_CONTROL_ENDPOINT 0x02
83#define AUDIO_REQ_CONTROL_MASK 0x03
84
88#define AUDIO_MUTE_CONTROL 0x01
89#define AUDIO_VOLUME_CONTROL 0x02
90#define AUDIO_FREQ_SET_CONTROL 0x03
91
99#define AUDIO_MUTE_CONTROL 0x01
100#define AUDIO_VOLUME_CONTROL 0x02
101#define AUDIO_FREQ_SET_CONTROL 0x03
102
106#define AUDIO_DESCRIPTOR_TYPE 0x21
107#define AUDIO_DESCRIPTOR_SIZE 0x09
108
112typedef struct
113{
114 uint8_t enpd;
115 uint8_t interface;
116 uint8_t request_no;
117 uint8_t spk_mute;
118 uint8_t mic_mute;
119 uint16_t spk_volume;
120 uint16_t mic_volume;
121 uint32_t spk_freq;
122 uint32_t mic_freq;
123 uint16_t spk_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
124 uint16_t mic_volume_limits[3]; /*[0] is mininum value, [1] is maxnum value, [2] is volume resolution */
125
126 uint8_t audio_cmd;
127 uint32_t audio_cmd_len;
128 uint32_t spk_alt_setting;
129 uint32_t mic_alt_setting;
130 uint8_t g_audio_cur[64];
131 uint8_t audio_spk_data[AUDIO_SPK_OUT_MAXPACKET_SIZE];
132 uint8_t audio_mic_data[AUDIO_MIC_IN_MAXPACKET_SIZE];
133 uint8_t audio_feed_back[AUDIO_FEEDBACK_MAXPACKET_SIZE+1];
134
135
136 /* hid */
137 uint32_t hid_protocol;
138 uint32_t hid_set_idle;
139 uint32_t alt_setting;
140 uint8_t hid_state;
141 uint8_t hid_set_report[64];
142 uint8_t g_rxhid_buff[USBD_AUHID_OUT_MAXPACKET_SIZE];
143 uint8_t g_txhid_buff[USBD_AUHID_IN_MAXPACKET_SIZE];
144}usb_audio_hid_type;
145
146extern usbd_class_handler audio_hid_class_handler;
147
148 usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len);
149
162#ifdef __cplusplus
163}
164#endif
165
166#endif
167
audio_conf.h
usb audio config
audio_hid_class_send_report
usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: audio_hid_class.c:770
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_hid_class.h:74
audio_hid_class_handler
usbd_class_handler audio_hid_class_handler
Definition: audio_hid_class.c:64
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:75
USBD_AUHID_OUT_MAXPACKET_SIZE
#define USBD_AUHID_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:68
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:67
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_hid_class.h:76
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
usb_audio_hid_type
usb audio control struct
Definition: audio_hid_class.h:113
usb_audio_hid_type::audio_cmd
uint8_t audio_cmd
Definition: audio_hid_class.h:126
usb_audio_hid_type::request_no
uint8_t request_no
Definition: audio_hid_class.h:116
usb_audio_hid_type::mic_freq
uint32_t mic_freq
Definition: audio_hid_class.h:122
usb_audio_hid_type::interface
uint8_t interface
Definition: audio_hid_class.h:115
usb_audio_hid_type::spk_volume
uint16_t spk_volume
Definition: audio_hid_class.h:119
usb_audio_hid_type::mic_alt_setting
uint32_t mic_alt_setting
Definition: audio_hid_class.h:129
usb_audio_hid_type::mic_volume
uint16_t mic_volume
Definition: audio_hid_class.h:120
usb_audio_hid_type::alt_setting
uint32_t alt_setting
Definition: audio_hid_class.h:139
usb_audio_hid_type::spk_alt_setting
uint32_t spk_alt_setting
Definition: audio_hid_class.h:128
usb_audio_hid_type::enpd
uint8_t enpd
Definition: audio_hid_class.h:114
usb_audio_hid_type::hid_state
uint8_t hid_state
Definition: audio_hid_class.h:140
usb_audio_hid_type::mic_mute
uint8_t mic_mute
Definition: audio_hid_class.h:118
usb_audio_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: audio_hid_class.h:138
usb_audio_hid_type::audio_cmd_len
uint32_t audio_cmd_len
Definition: audio_hid_class.h:127
usb_audio_hid_type::spk_freq
uint32_t spk_freq
Definition: audio_hid_class.h:121
usb_audio_hid_type::hid_protocol
uint32_t hid_protocol
Definition: audio_hid_class.h:137
usb_audio_hid_type::spk_mute
uint8_t spk_mute
Definition: audio_hid_class.h:117
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_hid_desc.c Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "audio_hid_desc.h"
30
45static usbd_desc_t *get_device_descriptor(void);
46static usbd_desc_t *get_device_qualifier(void);
47static usbd_desc_t *get_device_configuration(void);
48static usbd_desc_t *get_device_other_speed(void);
49static usbd_desc_t *get_device_lang_id(void);
50static usbd_desc_t *get_device_manufacturer_string(void);
51static usbd_desc_t *get_device_product_string(void);
52static usbd_desc_t *get_device_serial_string(void);
53static usbd_desc_t *get_device_interface_string(void);
54static usbd_desc_t *get_device_config_string(void);
55
56static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
57static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
58static void get_serial_num(void);
59static uint8_t g_usbd_desc_buffer[256];
60
64 usbd_desc_handler audio_hid_desc_handler =
65{
66 get_device_descriptor,
67 get_device_qualifier,
68 get_device_configuration,
69 get_device_other_speed,
70 get_device_lang_id,
71 get_device_manufacturer_string,
72 get_device_product_string,
73 get_device_serial_string,
74 get_device_interface_string,
75 get_device_config_string,
76};
77
81#if defined ( __ICCARM__ ) /* iar compiler */
82 #pragma data_alignment=4
83#endif
84ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
85{
86 USB_DEVICE_DESC_LEN, /* bLength */
87 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
88 0x00, /* bcdUSB */
89 0x02,
90 0x00, /* bDeviceClass */
91 0x00, /* bDeviceSubClass */
92 0x00, /* bDeviceProtocol */
93 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
94 LBYTE(USBD_AUHID_VENDOR_ID), /* idVendor */
95 HBYTE(USBD_AUHID_VENDOR_ID), /* idVendor */
96 LBYTE(USBD_AUHID_PRODUCT_ID), /* idProduct */
97 HBYTE(USBD_AUHID_PRODUCT_ID), /* idProduct */
98 0x00, /* bcdDevice rel. 2.00 */
99 0x02,
100 USB_MFC_STRING, /* Index of manufacturer string */
101 USB_PRODUCT_STRING, /* Index of product string */
102 USB_SERIAL_STRING, /* Index of serial number string */
103 0x01 /* bNumConfigurations */
104};
105
109#if defined ( __ICCARM__ ) /* iar compiler */
110 #pragma data_alignment=4
111#endif
112ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_AUHID_CONFIG_DESC_SIZE] ALIGNED_TAIL =
113{
114 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
115 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
116 LBYTE(USBD_AUHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 HBYTE(USBD_AUHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 0x1 + AUDIO_INTERFACE_NUM + 0x1, /* bNumInterfaces: n interface */
119 0x01, /* bConfigurationValue: configuration value */
120 0x00, /* iConfiguration: index of string descriptor describing
121 the configuration */
122 0xC0, /* bmAttributes: self powered */
123 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
124
125 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
126 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
127 0x00, /* bInterfaceNumber: number of interface */
128 0x00, /* bAlternateSetting: alternate set */
129 0x00, /* bNumEndpoints: number of endpoints */
130 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio class code */
131 AUDIO_SUBCLASS_AUDIOCONTROL, /* bInterfaceSubClass: audio control */
132 AUDIO_PROTOCOL_UNDEFINED, /* bInterfaceProtocol: undefined */
133 0x00, /* iInterface: index of string descriptor */
134
135 0x08+AUDIO_INTERFACE_NUM, /* bLength: size of this descriptor, in bytes 8+n */
136 AUDIO_CS_INTERFACE, /* bDescriptorType: cs interface descriptor type */
137 AUDIO_AC_HEADER, /* bDescriptorSubtype: Header function Descriptor*/
138 LBYTE(AUHID_BCD_NUM),
139 HBYTE(AUHID_BCD_NUM), /* bcdCDC: audio device class specification release number */
140 LBYTE(AUDIO_INTERFACE_LEN),
141 HBYTE(AUDIO_INTERFACE_LEN), /* wTotalLength: total number of bytes returned for the class-specific audio control interface */
142 AUDIO_INTERFACE_NUM, /* bInClollection: the number of audio streaming */
143#if (AUDIO_INTERFACE_NUM == 2) /* two interface */
144 0x02,
145 0x01,
146#else
147 0x01,
148#endif
149
150 /* usb microphone config */
151#if (AUDIO_SUPPORT_MIC == 1)
152 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
153 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
154 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
155 AUDIO_MIC_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
156 LBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),
157 HBYTE(AUDIO_INPUT_TERMINAL_MICROPHONE),/* wTerminalType: terminal is microphone */
158 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bAssocTerminal: no association */
159 AUDIO_MIC_CHR, /* bNrChannels: two channel */
160#if (AUDIO_MIC_CHR == 2)
161 0x03, /* wChannelConfig: left front and right front */
162#endif
163#if (AUDIO_MIC_CHR == 1)
164 0x00, /* wChannelConfig */
165#endif
166 0x00, /* wChannelConfig */
167 0x00, /* iChannelNames: unused */
168 0x00, /* iTerminal: unused */
169
170 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
171 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
172 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
173 AUDIO_MIC_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
174 AUDIO_MIC_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
175 0x01, /* bControlSize: 1 byte */
176 0x01, /* bmaControls0: mute */
177 0x02, /* bmaControls1: volume */
178 0x00, /* iFeature: unused */
179
180 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
181 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
182 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
183 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
184 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING),
185 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
186 AUDIO_MIC_INPUT_TERMINAL_ID, /* bAssocTerminal: unused */
187 AUDIO_MIC_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
188 0x00, /* iTerminal: unused */
189#endif
190
191#if (AUDIO_SUPPORT_SPK == 1)
192 /* speaker config */
193 AUDIO_INPUT_TERMINAL_SIZE, /* bLength: descriptor size */
194 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
195 AUDIO_AC_INPUT_TERMINAL, /* bDescriptorSubtype: input_terminal type*/
196 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalID: id of this input terminal*/
197 LBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
198 HBYTE(AUDIO_TERMINAL_TYPE_STREAMING), /* wTerminalType: usb streaming */
199 AUDIO_SPK_OUTPUT_TERMINAL_ID, /* bAssocTerminal: no association */
200 AUDIO_SPK_CHR, /* bNrChannels: two channel */
201#if (AUDIO_SPK_CHR == 2)
202 0x03, /* wChannelConfig: left front and right front */
203#endif
204#if (AUDIO_SPK_CHR == 1)
205 0x00, /* wChannelConfig */
206#endif
207 0x00, /* wChannelConfig */
208 0x00, /* iChannelNames: unused */
209 0x00, /* iTerminal: unused */
210
211 AUDIO_FEATURE_UNIT_SIZE, /* bLength: descriptor size */
212 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
213 AUDIO_AC_FEATURE_UNIT, /* bDescriptorSubtype: feature unit type*/
214 AUDIO_SPK_FEATURE_UNIT_ID, /* bUnitID: id of this feature unit */
215 AUDIO_SPK_INPUT_TERMINAL_ID, /* bSourceID: from input terminal */
216 0x01, /* bControlSize: 1 byte */
217 0x01, /* bmaControls0: mute*/
218 0x02, /* bmaControls1: volume */
219 0x00, /* iFeature: unused */
220
221 AUDIO_OUTPUT_TERMINAL_SIZE, /* bLength: descriptor size */
222 AUDIO_CS_INTERFACE, /* bDescriptorType: configuration */
223 AUDIO_AC_OUTPUT_TERMINAL, /* bDescriptorSubtype: output_terminal type*/
224 AUDIO_SPK_OUTPUT_TERMINAL_ID, /* bTerminalID: id of this output terminal*/
225 LBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
226 HBYTE(AUDIO_OUTPUT_TERMINAL_SPEAKER), /* wTerminalType: usb speaker */
227 AUDIO_SPK_INPUT_TERMINAL_ID, /* bAssocTerminal: unused */
228 AUDIO_SPK_FEATURE_UNIT_ID, /* bSourceID: from feature unit terminal */
229 0x00, /* iTerminal: unused */
230#endif
231
232#if (AUDIO_SUPPORT_MIC == 1)
233 /* microphone interface */
234 0x09, /* bLength: descriptor size */
235 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
236 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
237 0x00, /* bAlternateSetting: index of this setting */
238 0x00, /* bNumEndpoints: 0 endpoints */
239 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
240 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
241 0x00, /* bInterfaceProtocol: unused */
242 0x00, /* iInterface: unused */
243
244 0x09, /* bLength: descriptor size */
245 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
246 AUDIO_MIC_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
247 0x01, /* bAlternateSetting: index of this setting */
248 0x01, /* bNumEndpoints: 1 endpoints */
249 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
250 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
251 0x00, /* bInterfaceProtocol: unused */
252 0x00, /* iInterface: unused */
253
254 0x07, /* bLength: configuration descriptor size */
255 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
256 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
257 AUDIO_MIC_OUTPUT_TERMINAL_ID, /* bTerminalLink: unit id of the output terminal */
258 0x01, /* bDelay: interface delay */
259 0x01, /* wFormatTag: pcm format*/
260 0x00, /* wFormatTag: pcm format*/
261
262 0x08 + AUDIO_MIC_FREQ_SIZE * 3, /* bLength: descriptor size */
263 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
264 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
265 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
266 AUDIO_MIC_CHR, /* bNrChannels: channel number */
267 AUDIO_MIC_BITW / 8, /* bSubFrameSize: per audio subframe */
268 AUDIO_MIC_BITW, /* bBitResolution: n bits per sample */
269 AUDIO_MIC_FREQ_SIZE, /* bSamFreqType: n frequency supported */
270#if (AUDIO_SUPPORT_FREQ_16K == 1)
271 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
272#endif
273#if (AUDIO_SUPPORT_FREQ_48K == 1)
274 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
275#endif
276
277 0x09, /* bLength: size of endpoint descriptor in bytes */
278 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
279 USBD_AUHID_AUDIO_MIC_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
280 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
281 LBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE),
282 HBYTE(AUDIO_MIC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
283 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
284 0x00, /* bRefresh: unused */
285 0x00, /* bSynchAddress: unused */
286
287 0x07, /* bLength: size of endpoint descriptor in bytes */
288 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
289 0x01, /* bDescriptorSubtype: general subtype */
290 0x01, /* bmAttributes */
291 0x00, /* bLockDelayUnits: unused */
292 0x00, /* wLockDelay: unused */
293 0x00, /* wLockDelay: unused */
294#endif
295
296#if (AUDIO_SUPPORT_SPK == 1)
297 /* speaker interface */
298 0x09, /* bLength: descriptor size */
299 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
300 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
301 0x00, /* bAlternateSetting: index of this setting */
302 0x00, /* bNumEndpoints: 0 endpoints */
303 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
304 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
305 0x00, /* bInterfaceProtocol: unused */
306 0x00, /* iInterface: unused */
307
308 0x09, /* bLength: descriptor size */
309 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
310 AUDIO_SPK_INTERFACE_NUMBER, /* bInterfaceNumber: index of this interface */
311 0x01, /* bAlternateSetting: index of this setting */
312 0x01 + AUDIO_SUPPORT_FEEDBACK, /* bNumEndpoints: endpoints */
313 USB_CLASS_CODE_AUDIO, /* bInterfaceClass: audio */
314 AUDIO_SUBCLASS_AUDIOSTREAMING, /* bInterfaceSubclass: audio streaming */
315 0x00, /* bInterfaceProtocol: unused */
316 0x00, /* iInterface: unused */
317
318 0x07, /* bLength: configuration descriptor size */
319 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
320 AUDIO_AS_GENERAL, /* bDescriptorSubtype: general sub type*/
321 AUDIO_SPK_INPUT_TERMINAL_ID, /* bTerminalLink: unit id of the input terminal */
322 0x01, /* bDelay: interface delay */
323 0x01, /* wFormatTag: pcm format*/
324 0x00, /* wFormatTag: pcm format*/
325
326 0x08 + AUDIO_SPK_FREQ_SIZE * 3, /* bLength: descriptor size */
327 AUDIO_CS_INTERFACE, /* bDescriptorType: interface descriptor type */
328 AUDIO_AS_FORMAT_TYPE, /* bDescriptorSubtype: format subtype */
329 AUDIO_FORMAT_TYPE_I, /* bFormatType: format type 1 */
330 AUDIO_SPK_CHR, /* bNrChannels: channel number */
331 AUDIO_SPK_BITW / 8, /* bSubFrameSize: per audio subframe */
332 AUDIO_SPK_BITW, /* bBitResolution: n bits per sample */
333 AUDIO_SPK_FREQ_SIZE, /* bSamFreqType: n frequency supported */
334#if (AUDIO_SUPPORT_FREQ_16K == 1)
335 SAMPLE_FREQ(AT32_AUDIO_FREQ_16K), /* tSamFreq: 16000hz */
336#endif
337#if (AUDIO_SUPPORT_FREQ_48K == 1)
338 SAMPLE_FREQ(AT32_AUDIO_FREQ_48K), /* tSamFreq: 48000hz */
339#endif
340
341 0x09, /* bLength: size of endpoint descriptor in bytes */
342 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
343 USBD_AUHID_AUDIO_SPK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
344 USB_EPT_DESC_ISO | USB_ETP_DESC_ASYNC, /* bmAttributes: endpoint attributes */
345 LBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE),
346 HBYTE(AUDIO_SPK_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
347 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
348 0x00, /* bRefresh: unused */
349#if (AUDIO_SUPPORT_FEEDBACK == 1)
350 USBD_AUHID_AUDIO_FEEDBACK_EPT, /* bSynchAddress: feedback endpoint */
351#else
352 0x00, /* bSynchAddress: unused */
353#endif
354
355 0x07, /* bLength: size of endpoint descriptor in bytes */
356 AUDIO_CS_ENDPOINT, /* bDescriptorType: cs endpoint descriptor type */
357 0x01, /* bDescriptorSubtype: general subtype */
358 0x01, /* bmAttributes */
359 0x00, /* bLockDelayUnits: unused */
360 0x00, /* wLockDelay: unused */
361 0x00, /* wLockDelay: unused */
362
363#if (AUDIO_SUPPORT_FEEDBACK == 1)
364 0x09, /* bLength: size of endpoint descriptor in bytes */
365 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
366 USBD_AUHID_AUDIO_FEEDBACK_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
367 0x11, /* bmAttributes: endpoint attributes */
368 LBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
369 HBYTE(AUDIO_FEEDBACK_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
370 1, /* bInterval: interval for polling endpoint for data transfers */
371 FEEDBACK_REFRESH_TIME, /* bRefresh: this field indicates the rate at which an iso syncronization
372 pipe provides new syncronization feedback data. this rate must be a power of
373 2, therefore only the power is reported back and the range of this field is from
374 1(2ms) to 9(512ms) */
375 0x00, /* bSynchAddress: 0x00*/
376#endif
377
378#endif
379
380 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
381 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
382 HID_INTERFACE_NUMBER, /* bInterfaceNumber: number of interface */
383 0x00, /* bAlternateSetting: alternate set */
384 0x02, /* bNumEndpoints: number of endpoints */
385 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
386 0x00, /* bInterfaceSubClass: subclass code */
387 0x00, /* bInterfaceProtocol: protocol code */
388 0x00, /* iInterface: index of string descriptor */
389
390 0x09, /* bLength: size of HID descriptor in bytes */
391 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
392 LBYTE(AUHID_HID_BCD_NUM),
393 HBYTE(AUHID_HID_BCD_NUM), /* bcdHID: HID class specification release number */
394 0x00, /* bCountryCode: hardware target conutry */
395 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
396 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
397 LBYTE(sizeof(g_usbd_audio_hid_report)),
398 HBYTE(sizeof(g_usbd_audio_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
399
400 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
401 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
402 USBD_AUHID_HID_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
403 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
404 LBYTE(USBD_AUHID_IN_MAXPACKET_SIZE),
405 HBYTE(USBD_AUHID_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
406 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
407
408 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
409 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
410 USBD_AUHID_HID_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
411 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
412 LBYTE(USBD_AUHID_OUT_MAXPACKET_SIZE),
413 HBYTE(USBD_AUHID_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
414 AUHID_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
415};
416
420#if defined ( __ICCARM__ ) /* iar compiler */
421 #pragma data_alignment=4
422#endif
423ALIGNED_HEAD uint8_t g_usbd_audio_hid_report[USBD_AUHID_HID_SIZ_REPORT_DESC] ALIGNED_TAIL =
424{
425 0x06, 0xFF, 0x00, /* USAGE_PAGE(Vendor Page:0xFF00) */
426 0x09, 0x01, /* USAGE (Demo Kit) */
427 0xa1, 0x01, /* COLLECTION (Application) */
428 /* 7 */
429
430 /* Led 2 */
431 0x85, HID_REPORT_ID_2, /* REPORT_ID 2 */
432 0x09, 0x02, /* USAGE (LED 2) */
433 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
434 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
435 0x75, 0x08, /* REPORT_SIZE (8) */
436 0x95, 0x3F, /* REPORT_COUNT (1) */
437 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
438
439 0x85, 0x02, /* REPORT_ID (2) */
440 0x09, 0x02, /* USAGE (LED 2) */
441 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
442 /* 27 */
443
444 /* Led 3 */
445 0x85, HID_REPORT_ID_3, /* REPORT_ID (3) */
446 0x09, 0x03, /* USAGE (LED 3) */
447 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
448 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
449 0x75, 0x08, /* REPORT_SIZE (8) */
450 0x95, 0x3F, /* REPORT_COUNT (1) */
451 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
452
453 0x85, 0x03, /* REPORT_ID (3) */
454 0x09, 0x03, /* USAGE (LED 3) */
455 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
456 /* 47 */
457
458 /* Led 4 */
459 0x85, HID_REPORT_ID_4, /* REPORT_ID 4) */
460 0x09, 0x04, /* USAGE (LED 4) */
461 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
462 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
463 0x75, 0x08, /* REPORT_SIZE (8) */
464 0x95, 0x3F, /* REPORT_COUNT (1) */
465 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
466
467 0x85, 0x04, /* REPORT_ID (4) */
468 0x09, 0x04, /* USAGE (LED 4) */
469 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
470 /* 67 */
471
472 /* key Push Button */
473 0x85, HID_REPORT_ID_5, /* REPORT_ID (5) */
474 0x09, 0x05, /* USAGE (Push Button) */
475 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
476 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
477 0x75, 0x01, /* REPORT_SIZE (1) */
478 0x81, 0x82, /* INPUT (Data,Var,Abs,Vol) */
479
480 0x09, 0x05, /* USAGE (Push Button) */
481 0x75, 0x01, /* REPORT_SIZE (1) */
482 0xb1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
483
484 0x75, 0x07, /* REPORT_SIZE (7) */
485 0x81, 0x83, /* INPUT (Cnst,Var,Abs,Vol) */
486 0x85, 0x05, /* REPORT_ID (5) */
487
488 0x75, 0x07, /* REPORT_SIZE (7) */
489 0xb1, 0x83, /* FEATURE (Cnst,Var,Abs,Vol) */
490 /* 95 */
491
492 /* Data OUT */
493 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
494 0x09, 0x06, /* USAGE */
495 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
496 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
497 0x75, 0x08, /* REPORT_SIZE (8) */
498 0x95, 0x3F, /* REPORT_COUNT (64) */
499 0x91, 0x02, /* OUTPUT(Data,Var,Abs,Vol) */
500 /* 110 */
501
502 /* Data IN */
503 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
504 0x09, 0x07, /* USAGE */
505 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
506 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
507 0x75, 0x08, /* REPORT_SIZE (8) */
508 0x95, 0x3F, /* REPORT_COUNT (64) */
509 0x81, 0x82, /* INPUT(Data,Var,Abs,Vol) */
510
511 /* 125 */
512 0xc0 /* END_COLLECTION */
513};
514
518#if defined ( __ICCARM__ ) /* iar compiler */
519 #pragma data_alignment=4
520#endif
521ALIGNED_HEAD uint8_t g_audio_hid_usb_desc[9] ALIGNED_TAIL =
522{
523 0x09, /* bLength: size of HID descriptor in bytes */
524 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
525 LBYTE(AUHID_HID_BCD_NUM),
526 HBYTE(AUHID_HID_BCD_NUM), /* bcdHID: HID class specification release number */
527 0x00, /* bCountryCode: hardware target conutry */
528 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
529 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
530 LBYTE(sizeof(g_usbd_audio_hid_report)),
531 HBYTE(sizeof(g_usbd_audio_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
532};
533
537#if defined ( __ICCARM__ ) /* iar compiler */
538 #pragma data_alignment=4
539#endif
540ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_AUHID_SIZ_STRING_LANGID] ALIGNED_TAIL =
541{
542 USBD_AUHID_SIZ_STRING_LANGID,
543 USB_DESCIPTOR_TYPE_STRING,
544 0x09,
545 0x04,
546};
547
551#if defined ( __ICCARM__ ) /* iar compiler */
552 #pragma data_alignment=4
553#endif
554ALIGNED_HEAD static uint8_t g_string_serial[USBD_AUHID_SIZ_STRING_SERIAL] ALIGNED_TAIL =
555{
556 USBD_AUHID_SIZ_STRING_SERIAL,
557 USB_DESCIPTOR_TYPE_STRING,
558};
559
560
561/* device descriptor */
562static usbd_desc_t device_descriptor =
563{
564 USB_DEVICE_DESC_LEN,
565 g_usbd_descriptor
566};
567
568/* config descriptor */
569static usbd_desc_t config_descriptor =
570{
571 USBD_AUHID_CONFIG_DESC_SIZE,
572 g_usbd_configuration
573};
574
575/* langid descriptor */
576static usbd_desc_t langid_descriptor =
577{
578 USBD_AUHID_SIZ_STRING_LANGID,
579 g_string_lang_id
580};
581
582/* serial descriptor */
583static usbd_desc_t serial_descriptor =
584{
585 USBD_AUHID_SIZ_STRING_SERIAL,
586 g_string_serial
587};
588
589static usbd_desc_t vp_desc;
590
597static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
598{
599 uint16_t str_len = 0, id_pos = 2;
600 uint8_t *tmp_str = string;
601
602 while(*tmp_str != '\0')
603 {
604 str_len ++;
605 unicode_buf[id_pos ++] = *tmp_str ++;
606 unicode_buf[id_pos ++] = 0x00;
607 }
608
609 str_len = str_len * 2 + 2;
610 unicode_buf[0] = str_len;
611 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
612
613 return str_len;
614}
615
623static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
624{
625 uint8_t idx = 0;
626
627 for( idx = 0 ; idx < len ; idx ++)
628 {
629 if( ((value >> 28)) < 0xA )
630 {
631 pbuf[2 * idx] = (value >> 28) + '0';
632 }
633 else
634 {
635 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
636 }
637
638 value = value << 4;
639
640 pbuf[2 * idx + 1] = 0;
641 }
642}
643
649static void get_serial_num(void)
650{
651 uint32_t serial0, serial1, serial2;
652
653 serial0 = *(uint32_t*)MCU_ID1;
654 serial1 = *(uint32_t*)MCU_ID2;
655 serial2 = *(uint32_t*)MCU_ID3;
656
657 serial0 += serial2;
658
659 if (serial0 != 0)
660 {
661 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
662 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
663 }
664}
665
671static usbd_desc_t *get_device_descriptor(void)
672{
673 return &device_descriptor;
674}
675
681static usbd_desc_t * get_device_qualifier(void)
682{
683 return NULL;
684}
685
691static usbd_desc_t *get_device_configuration(void)
692{
693 return &config_descriptor;
694}
695
701static usbd_desc_t *get_device_other_speed(void)
702{
703 return NULL;
704}
705
711static usbd_desc_t *get_device_lang_id(void)
712{
713 return &langid_descriptor;
714}
715
716
722static usbd_desc_t *get_device_manufacturer_string(void)
723{
724 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
725 vp_desc.descriptor = g_usbd_desc_buffer;
726 return &vp_desc;
727}
728
734static usbd_desc_t *get_device_product_string(void)
735{
736 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
737 vp_desc.descriptor = g_usbd_desc_buffer;
738 return &vp_desc;
739}
740
746static usbd_desc_t *get_device_serial_string(void)
747{
748 get_serial_num();
749 return &serial_descriptor;
750}
751
757static usbd_desc_t *get_device_interface_string(void)
758{
759 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
760 vp_desc.descriptor = g_usbd_desc_buffer;
761 return &vp_desc;
762}
763
769static usbd_desc_t *get_device_config_string(void)
770{
771 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_AUHID_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
772 vp_desc.descriptor = g_usbd_desc_buffer;
773 return &vp_desc;
774}
775
audio_hid_desc.h
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
AUDIO_MIC_IN_MAXPACKET_SIZE
#define AUDIO_MIC_IN_MAXPACKET_SIZE
Definition: audio_class.h:62
AUDIO_SPK_OUT_MAXPACKET_SIZE
#define AUDIO_SPK_OUT_MAXPACKET_SIZE
Definition: audio_class.h:63
FEEDBACK_REFRESH_TIME
#define FEEDBACK_REFRESH_TIME
Definition: audio_class.h:65
AUDIO_FEEDBACK_MAXPACKET_SIZE
#define AUDIO_FEEDBACK_MAXPACKET_SIZE
Definition: audio_class.h:64
AUDIO_MIC_FEATURE_UNIT_ID
#define AUDIO_MIC_FEATURE_UNIT_ID
Definition: audio_desc.h:169
AUDIO_CS_ENDPOINT
#define AUDIO_CS_ENDPOINT
Definition: audio_desc.h:76
AUDIO_AC_HEADER
#define AUDIO_AC_HEADER
Definition: audio_desc.h:91
AUDIO_SUBCLASS_AUDIOCONTROL
#define AUDIO_SUBCLASS_AUDIOCONTROL
Definition: audio_desc.h:68
AUDIO_INPUT_TERMINAL_SIZE
#define AUDIO_INPUT_TERMINAL_SIZE
audio interface descriptor size define
Definition: audio_desc.h:161
AUDIO_TERMINAL_TYPE_STREAMING
#define AUDIO_TERMINAL_TYPE_STREAMING
Definition: audio_desc.h:138
AUDIO_SPK_CHR
#define AUDIO_SPK_CHR
Definition: audio_desc.h:202
AUDIO_SPK_INTERFACE_NUMBER
#define AUDIO_SPK_INTERFACE_NUMBER
Definition: audio_desc.h:180
AUDIO_MIC_OUTPUT_TERMINAL_ID
#define AUDIO_MIC_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:170
AUDIO_MIC_INTERFACE_NUMBER
#define AUDIO_MIC_INTERFACE_NUMBER
audio interface number
Definition: audio_desc.h:178
SAMPLE_FREQ
#define SAMPLE_FREQ(frq)
Definition: audio_desc.h:213
AUDIO_MIC_FREQ_SIZE
#define AUDIO_MIC_FREQ_SIZE
audio microphone freq and channel config
Definition: audio_desc.h:194
AUDIO_SPK_FREQ_SIZE
#define AUDIO_SPK_FREQ_SIZE
audio speaker freq and channel config
Definition: audio_desc.h:201
AT32_AUDIO_FREQ_48K
#define AT32_AUDIO_FREQ_48K
Definition: audio_desc.h:189
AUDIO_FORMAT_TYPE_I
#define AUDIO_FORMAT_TYPE_I
audio format type 1
Definition: audio_desc.h:148
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
AUDIO_AS_GENERAL
#define AUDIO_AS_GENERAL
Definition: audio_desc.h:104
AUDIO_INTERFACE_NUM
#define AUDIO_INTERFACE_NUM
audio interface config
Definition: audio_desc.h:153
AUDIO_CS_INTERFACE
#define AUDIO_CS_INTERFACE
audio class-specific descriptor types
Definition: audio_desc.h:75
AUDIO_SPK_FEATURE_UNIT_ID
#define AUDIO_SPK_FEATURE_UNIT_ID
Definition: audio_desc.h:172
AUDIO_OUTPUT_TERMINAL_SIZE
#define AUDIO_OUTPUT_TERMINAL_SIZE
Definition: audio_desc.h:162
AUDIO_SPK_OUTPUT_TERMINAL_ID
#define AUDIO_SPK_OUTPUT_TERMINAL_ID
Definition: audio_desc.h:173
AUDIO_AC_INPUT_TERMINAL
#define AUDIO_AC_INPUT_TERMINAL
Definition: audio_desc.h:92
AUDIO_MIC_CHR
#define AUDIO_MIC_CHR
Definition: audio_desc.h:195
AUDIO_OUTPUT_TERMINAL_SPEAKER
#define AUDIO_OUTPUT_TERMINAL_SPEAKER
Definition: audio_desc.h:143
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
AT32_AUDIO_FREQ_16K
#define AT32_AUDIO_FREQ_16K
audio support freq
Definition: audio_desc.h:188
AUDIO_AS_FORMAT_TYPE
#define AUDIO_AS_FORMAT_TYPE
Definition: audio_desc.h:105
AUDIO_MIC_INPUT_TERMINAL_ID
#define AUDIO_MIC_INPUT_TERMINAL_ID
audio terminal id define
Definition: audio_desc.h:168
AUDIO_SPK_BITW
#define AUDIO_SPK_BITW
Definition: audio_desc.h:203
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
AUDIO_FEATURE_UNIT_SIZE
#define AUDIO_FEATURE_UNIT_SIZE
Definition: audio_desc.h:163
AUDIO_PROTOCOL_UNDEFINED
#define AUDIO_PROTOCOL_UNDEFINED
audio interface protocol codes
Definition: audio_desc.h:85
AUDIO_MIC_BITW
#define AUDIO_MIC_BITW
Definition: audio_desc.h:196
AUDIO_AC_FEATURE_UNIT
#define AUDIO_AC_FEATURE_UNIT
Definition: audio_desc.h:96
AUDIO_SPK_INPUT_TERMINAL_ID
#define AUDIO_SPK_INPUT_TERMINAL_ID
Definition: audio_desc.h:171
AUDIO_INTERFACE_LEN
#define AUDIO_INTERFACE_LEN
Definition: audio_desc.h:154
AUDIO_SUBCLASS_AUDIOSTREAMING
#define AUDIO_SUBCLASS_AUDIOSTREAMING
Definition: audio_desc.h:69
AUDIO_AC_OUTPUT_TERMINAL
#define AUDIO_AC_OUTPUT_TERMINAL
Definition: audio_desc.h:93
AUDIO_INPUT_TERMINAL_MICROPHONE
#define AUDIO_INPUT_TERMINAL_MICROPHONE
Definition: audio_desc.h:141
USBD_AUHID_AUDIO_MIC_IN_EPT
#define USBD_AUHID_AUDIO_MIC_IN_EPT
endpoint define
Definition: audio_hid_class.h:54
USBD_AUHID_HID_IN_EPT
#define USBD_AUHID_HID_IN_EPT
usb custom hid use endpoint define
Definition: audio_hid_class.h:61
USBD_AUHID_HID_OUT_EPT
#define USBD_AUHID_HID_OUT_EPT
Definition: audio_hid_class.h:62
USBD_AUHID_AUDIO_FEEDBACK_EPT
#define USBD_AUHID_AUDIO_FEEDBACK_EPT
Definition: audio_hid_class.h:56
USBD_AUHID_OUT_MAXPACKET_SIZE
#define USBD_AUHID_OUT_MAXPACKET_SIZE
Definition: audio_hid_class.h:68
USBD_AUHID_AUDIO_SPK_OUT_EPT
#define USBD_AUHID_AUDIO_SPK_OUT_EPT
Definition: audio_hid_class.h:55
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:67
USBD_AUHID_DESC_CONFIGURATION_STRING
#define USBD_AUHID_DESC_CONFIGURATION_STRING
Definition: audio_hid_desc.h:61
USBD_AUHID_DESC_MANUFACTURER_STRING
#define USBD_AUHID_DESC_MANUFACTURER_STRING
Definition: audio_hid_desc.h:59
USBD_AUHID_HID_SIZ_REPORT_DESC
#define USBD_AUHID_HID_SIZ_REPORT_DESC
Definition: audio_hid_desc.h:236
AUHID_BCD_NUM
#define AUHID_BCD_NUM
Definition: audio_hid_desc.h:51
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:223
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:225
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
AUHID_HID_BINTERVAL_TIME
#define AUHID_HID_BINTERVAL_TIME
Definition: audio_hid_desc.h:205
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:227
USBD_AUHID_SIZ_STRING_LANGID
#define USBD_AUHID_SIZ_STRING_LANGID
Definition: audio_hid_desc.h:56
AUHID_HID_BCD_NUM
#define AUHID_HID_BCD_NUM
usb bcd number define
Definition: audio_hid_desc.h:210
USBD_AUHID_PRODUCT_ID
#define USBD_AUHID_PRODUCT_ID
Definition: audio_hid_desc.h:54
USBD_AUHID_CONFIG_DESC_SIZE
#define USBD_AUHID_CONFIG_DESC_SIZE
Definition: audio_hid_desc.h:238
USBD_AUHID_DESC_INTERFACE_STRING
#define USBD_AUHID_DESC_INTERFACE_STRING
Definition: audio_hid_desc.h:62
USBD_AUHID_DESC_PRODUCT_STRING
#define USBD_AUHID_DESC_PRODUCT_STRING
Definition: audio_hid_desc.h:60
USBD_AUHID_SIZ_STRING_SERIAL
#define USBD_AUHID_SIZ_STRING_SERIAL
Definition: audio_hid_desc.h:57
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:224
g_audio_hid_usb_desc
uint8_t g_audio_hid_usb_desc[9]
usb hid descriptor
Definition: audio_hid_desc.c:521
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:423
USBD_AUHID_VENDOR_ID
#define USBD_AUHID_VENDOR_ID
Definition: audio_hid_desc.h:53
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:226
HID_INTERFACE_NUMBER
#define HID_INTERFACE_NUMBER
Definition: audio_hid_desc.h:183
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: audio_hid_desc.c:583
device_descriptor
static usbd_desc_t device_descriptor
Definition: audio_hid_desc.c:562
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: audio_hid_desc.c:691
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: audio_hid_desc.c:576
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: audio_hid_desc.c:671
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: audio_hid_desc.c:722
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: audio_hid_desc.c:681
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: audio_hid_desc.c:757
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: audio_hid_desc.c:59
vp_desc
static usbd_desc_t vp_desc
Definition: audio_hid_desc.c:589
audio_hid_desc_handler
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure
Definition: audio_hid_desc.c:64
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: audio_hid_desc.c:701
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: audio_hid_desc.c:84
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: audio_hid_desc.c:734
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: audio_hid_desc.c:769
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: audio_hid_desc.c:597
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: audio_hid_desc.c:711
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: audio_hid_desc.c:649
config_descriptor
static usbd_desc_t config_descriptor
Definition: audio_hid_desc.c:569
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: audio_hid_desc.c:746
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: audio_hid_desc.c:623
AUDIO_SUPPORT_FEEDBACK
#define AUDIO_SUPPORT_FEEDBACK
Definition: audio/audio_conf.h:49
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_EPT_DESC_ISO
#define USB_EPT_DESC_ISO
Definition: usb_std.h:176
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_CLASS_CODE_AUDIO
#define USB_CLASS_CODE_AUDIO
usb class code
Definition: usb_std.h:161
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_ETP_DESC_ASYNC
#define USB_ETP_DESC_ASYNC
Definition: usb_std.h:181
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: audio_hid_desc.h Source File

  • middlewares
  • usbd_class
  • audio_hid
audio_hid_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_HID_DESC_H
29#define __AUDIO_HID_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "audio_hid_class.h"
36#include "usbd_core.h"
37#include "audio_conf.h"
38
51#define AUHID_BCD_NUM 0x0100
52
53#define USBD_AUHID_VENDOR_ID 0x2E3C
54#define USBD_AUHID_PRODUCT_ID 0x5555
55
56#define USBD_AUHID_SIZ_STRING_LANGID 4
57#define USBD_AUHID_SIZ_STRING_SERIAL 0x1A
58
59#define USBD_AUHID_DESC_MANUFACTURER_STRING "Artery"
60#define USBD_AUHID_DESC_PRODUCT_STRING "AT32 Audio"
61#define USBD_AUHID_DESC_CONFIGURATION_STRING "Audio Config"
62#define USBD_AUHID_DESC_INTERFACE_STRING "Audio Interface"
66#define AUDIO_SUBCLASS_UNDEFINED 0x00
67#define AUDIO_SUBCLASS_AUDIOCONTROL 0x01
68#define AUDIO_SUBCLASS_AUDIOSTREAMING 0x02
69#define AUDIO_SUBCLASS_MIDISTREMING 0x03
70
74#define AUDIO_CS_INTERFACE 0x24
75#define AUDIO_CS_ENDPOINT 0x25
76#define AUDIO_CS_STRING 0x23
77#define AUDIO_CS_CONFIGURATION 0x22
78#define AUDIO_CS_DEVICE 0x21
79#define AUDIO_CS_UNDEFINED 0x20
80
84#define AUDIO_PROTOCOL_UNDEFINED 0x00
85
89#define AUDIO_AC_DESCRIPTOR_UNDEFINED 0x00
90#define AUDIO_AC_HEADER 0x01
91#define AUDIO_AC_INPUT_TERMINAL 0x02
92#define AUDIO_AC_OUTPUT_TERMINAL 0x03
93#define AUDIO_AC_MIXER_UNIT 0x04
94#define AUDIO_AC_SELECTOR_UNIT 0x05
95#define AUDIO_AC_FEATURE_UNIT 0x06
96#define AUDIO_AC_PROCESSING_UNIT 0x07
97#define AUDIO_AC_EXTENSION_UNIT 0x08
98
102#define AUDIO_AS_DESCRIPTOR_UNDEFINED 0x00
103#define AUDIO_AS_GENERAL 0x01
104#define AUDIO_AS_FORMAT_TYPE 0x02
105#define AUDIO_AS_FORMAT_SPECIFIC 0x03
106
110#define AUDIO_REQUEST_CODE_UNDEFINED 0x00
111#define AUDIO_REQ_SET_CUR 0x01
112#define AUDIO_REQ_GET_CUR 0x81
113#define AUDIO_REQ_SET_MIN 0x02
114#define AUDIO_REQ_GET_MIN 0x82
115#define AUDIO_REQ_SET_MAX 0x03
116#define AUDIO_REQ_GET_MAX 0x83
117#define AUDIO_REQ_SET_RES 0x04
118#define AUDIO_REQ_GET_RES 0x84
119#define AUDIO_REQ_SET_MEM 0x05
120#define AUDIO_REQ_GET_MEM 0x85
121#define AUDIO_REQ_GET_STAT 0xFF
122
126#define AUDIO_FU_CONTROL_UNDEFINED 0x00
127#define AUDIO_FU_MUTE_CONTROL 0x01
128#define AUDIO_FU_VOLUME_CONTROL 0x02
129#define AUDIO_FU_BASS_CONTROL 0x03
130#define AUDIO_FU_MID_CONTROL 0x04
131#define AUDIO_FU_TREBLE_CONTROL 0x05
132
136#define AUDIO_TERMINAL_TYPE_UNDEFINED 0x0100
137#define AUDIO_TERMINAL_TYPE_STREAMING 0x0101
138#define AUDIO_TERMINAL_TYPE_VENDOR 0x01FF
139#define AUDIO_INPUT_TERMINAL_UNDEFINED 0x0200
140#define AUDIO_INPUT_TERMINAL_MICROPHONE 0x0201
141#define AUDIO_OUTPUT_TERMINAL_UNDEFINED 0x0300
142#define AUDIO_OUTPUT_TERMINAL_SPEAKER 0x0301
143
147#define AUDIO_FORMAT_TYPE_I 0x01
148
152#define AUDIO_INTERFACE_NUM (AUDIO_SUPPORT_SPK + AUDIO_SUPPORT_MIC)
153#define AUDIO_INTERFACE_LEN ((0x08 + AUDIO_INTERFACE_NUM) + AUDIO_INTERFACE_NUM * 0x1E)
154#define AUDIO_MIC_INTERFACE 0x01
155#define AUDIO_SPK_INTERFACE 0x02
156
160#define AUDIO_INPUT_TERMINAL_SIZE 0x0C
161#define AUDIO_OUTPUT_TERMINAL_SIZE 0x09
162#define AUDIO_FEATURE_UNIT_SIZE 0x09
163
167#define AUDIO_MIC_INPUT_TERMINAL_ID 0x01
168#define AUDIO_MIC_FEATURE_UNIT_ID 0x02
169#define AUDIO_MIC_OUTPUT_TERMINAL_ID 0x03
170#define AUDIO_SPK_INPUT_TERMINAL_ID 0x04
171#define AUDIO_SPK_FEATURE_UNIT_ID 0x05
172#define AUDIO_SPK_OUTPUT_TERMINAL_ID 0x06
173
177#define AUDIO_MIC_INTERFACE_NUMBER 0x01
178#if (AUDIO_SUPPORT_MIC == 1)
179#define AUDIO_SPK_INTERFACE_NUMBER 0x02
180#else
181#define AUDIO_SPK_INTERFACE_NUMBER 0x01
182#endif
183#define HID_INTERFACE_NUMBER 0x03
184
188#define AT32_AUDIO_FREQ_16K 16000
189#define AT32_AUDIO_FREQ_48K 48000
190
194#define AUDIO_MIC_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
195#define AUDIO_MIC_CHR AUDIO_MIC_CHANEL_NUM
196#define AUDIO_MIC_BITW (AUDIO_MIC_DEFAULT_BITW)
197
201#define AUDIO_SPK_FREQ_SIZE (AUDIO_SUPPORT_FREQ)
202#define AUDIO_SPK_CHR AUDIO_SPK_CHANEL_NUM
203#define AUDIO_SPK_BITW (AUDIO_SPK_DEFAULT_BITW)
204
205#define AUHID_HID_BINTERVAL_TIME 0x01
206
210#define AUHID_HID_BCD_NUM 0x0110
211
215#define HID_CLASS_DESC_HID 0x21
216#define HID_CLASS_DESC_REPORT 0x22
217#define HID_CLASS_DESC_PHYSICAL 0x23
218
222#define HID_REPORT_ID_1 0x01
223#define HID_REPORT_ID_2 0x02
224#define HID_REPORT_ID_3 0x03
225#define HID_REPORT_ID_4 0x04
226#define HID_REPORT_ID_5 0x05
227#define HID_REPORT_ID_6 0xF0
228
229#define MCU_ID1 (0x1FFFF7E8)
230#define MCU_ID2 (0x1FFFF7EC)
231#define MCU_ID3 (0x1FFFF7F0)
232
233
234#define SAMPLE_FREQ(frq) (uint8_t)(frq), (uint8_t)((frq >> 8)), (uint8_t)((frq >> 16))
235
236#define USBD_AUHID_HID_SIZ_REPORT_DESC 126
237#define USBD_AUHID_HID_DESC_SIZE 32
238#define USBD_AUHID_CONFIG_DESC_SIZE ( 0x12 + AUDIO_INTERFACE_LEN + \
239 + (0x31 + AUDIO_SPK_FREQ_SIZE * 3) \
240 + (0x31 + AUDIO_MIC_FREQ_SIZE * 3) \
241 + (9 * AUDIO_SUPPORT_FEEDBACK) \
242 + USBD_AUHID_HID_DESC_SIZE)
243
244extern uint8_t g_usbd_audio_hid_report[USBD_AUHID_HID_SIZ_REPORT_DESC];
245extern uint8_t g_audio_hid_usb_desc[9];
246
247extern usbd_desc_handler audio_hid_desc_handler;
248
260#ifdef __cplusplus
261}
262#endif
263
264#endif
265
audio_conf.h
usb audio config
audio_hid_class.h
USBD_AUHID_HID_SIZ_REPORT_DESC
#define USBD_AUHID_HID_SIZ_REPORT_DESC
Definition: audio_hid_desc.h:236
audio_hid_desc_handler
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure
Definition: audio_hid_desc.c:64
g_audio_hid_usb_desc
uint8_t g_audio_hid_usb_desc[9]
usb hid descriptor
Definition: audio_hid_desc.c:521
g_usbd_audio_hid_report
uint8_t g_usbd_audio_hid_report[126]
usb hid report descriptor
Definition: audio_hid_desc.c:423
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: hid_iap_user.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/hid_iap_user.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_USER_H
29#define __HID_IAP_USER_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "hid_iap_class.h"
36
49#define FLASH_APP_ADDRESS 0x08004000
50
59void iap_init(void);
60 iap_result_type iap_get_upgrade_flag(void);
61void iap_loop(void);
62void jump_to_app(uint32_t address);
63
76#ifdef __cplusplus
77}
78#endif
79
80#endif
81
82
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
jump_to_app
void jump_to_app(uint32_t address)
jump to app
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:234
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:79
iap_loop
void iap_loop(void)
iap loop
Definition: bootloader/src/hid_iap_user.c:473
hid_iap_class.h
usb hid iap header file


AT32F413 Firmwary Library: iap.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/iap.h
Go to the documentation of this file.
1
27#ifndef __IAP_H__
28#define __IAP_H__
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
48/* app starting address */
49#define APP_START_ADDR 0x08004000
50
51/* the previous sector of app starting address is iap upgrade flag */
52#define IAP_UPGRADE_FLAG_ADDR (APP_START_ADDR - 0x800)
53
54/* when app received cmd 0x5aa5 from pc-tool, will set up the flag,
55indicates that an app upgrade will follow, see iap application note for more details */
56#define IAP_UPGRADE_FLAG 0x41544B38
57
69typedef struct
70{
71 uint8_t cmd_head;
72 uint8_t cmd_addr[4];
73 uint8_t cmd_buf[0x800];
74 uint8_t cmd_check;
75} cmd_data_group_type;
76
80typedef enum
81{
82 CMD_DATA_IDLE,
83 CMD_DATA_ADDR,
84 CMD_DATA_BUF,
85 CMD_DATA_CHACK,
86 CMD_DATA_DONE,
87 CMD_DATA_ERR,
88} cmd_data_step_type;
89
93typedef enum
94{
95 CMD_CTR_IDLE,
96 CMD_CTR_INIT,
97 CMD_CTR_DONE,
98 CMD_CTR_ERR,
99 CMD_CTR_APP,
100} cmd_ctr_step_type;
101
105typedef enum
106{
107 UPDATE_PRE,
108 UPDATE_CLEAR_FLAG,
109 UPDATE_ING,
110 UPDATE_DONE,
111} update_status_type;
112
113typedef void (*iapfun)(void);
114
119extern cmd_data_group_type cmd_data_group_type_struct;
120extern cmd_data_step_type cmd_data_step;
121extern cmd_ctr_step_type cmd_ctr_step;
122extern update_status_type update_status;
123
128void command_handle(void);
129void back_err(void);
130void back_ok(void);
131void iap_upgrade_app_handle(void);
132void app_load(uint32_t appxaddr);
133
146#ifdef __cplusplus
147}
148#endif
149
150#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
update_status
update_status_type update_status
Definition: bootloader/src/iap.c:43
cmd_data_group_type_struct
cmd_data_group_type cmd_data_group_type_struct
cmd_data_step
cmd_data_step_type cmd_data_step
Definition: bootloader/src/iap.c:40
cmd_ctr_step
cmd_ctr_step_type cmd_ctr_step
Definition: bootloader/src/iap.c:41
command_handle
void command_handle(void)
command analysis handle.
Definition: bootloader/src/iap.c:106
iap_upgrade_app_handle
void iap_upgrade_app_handle(void)
iap upgrade app handle.
Definition: bootloader/src/iap.c:344
app_load
void app_load(uint32_t appxaddr)
app load.
Definition: bootloader/src/iap.c:60
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:120
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:107
iapfun
void(* iapfun)(void)
Definition: bootloader/inc/iap.h:113
update_status_type
update_status_type
update status type
Definition: bootloader/inc/iap.h:106
cmd_ctr_step_type
cmd_ctr_step_type
cmd ctr step type
Definition: bootloader/inc/iap.h:94
cmd_data_step_type
cmd_data_step_type
cmd data step type
Definition: bootloader/inc/iap.h:81
UPDATE_PRE
@ UPDATE_PRE
Definition: bootloader/inc/iap.h:107
UPDATE_DONE
@ UPDATE_DONE
Definition: bootloader/inc/iap.h:110
UPDATE_ING
@ UPDATE_ING
Definition: bootloader/inc/iap.h:109
UPDATE_CLEAR_FLAG
@ UPDATE_CLEAR_FLAG
Definition: bootloader/inc/iap.h:108
CMD_CTR_ERR
@ CMD_CTR_ERR
Definition: bootloader/inc/iap.h:98
CMD_CTR_DONE
@ CMD_CTR_DONE
Definition: bootloader/inc/iap.h:97
CMD_CTR_INIT
@ CMD_CTR_INIT
Definition: bootloader/inc/iap.h:96
CMD_CTR_APP
@ CMD_CTR_APP
Definition: bootloader/inc/iap.h:99
CMD_CTR_IDLE
@ CMD_CTR_IDLE
Definition: bootloader/inc/iap.h:95
CMD_DATA_DONE
@ CMD_DATA_DONE
Definition: bootloader/inc/iap.h:86
CMD_DATA_ERR
@ CMD_DATA_ERR
Definition: bootloader/inc/iap.h:87
CMD_DATA_BUF
@ CMD_DATA_BUF
Definition: bootloader/inc/iap.h:84
CMD_DATA_IDLE
@ CMD_DATA_IDLE
Definition: bootloader/inc/iap.h:82
CMD_DATA_CHACK
@ CMD_DATA_CHACK
Definition: bootloader/inc/iap.h:85
CMD_DATA_ADDR
@ CMD_DATA_ADDR
Definition: bootloader/inc/iap.h:83
cmd_data_group_type
cmd data group type
Definition: bootloader/inc/iap.h:70
cmd_data_group_type::cmd_head
uint8_t cmd_head
Definition: bootloader/inc/iap.h:71
cmd_data_group_type::cmd_check
uint8_t cmd_check
Definition: bootloader/inc/iap.h:74


AT32F413 Firmwary Library: tmr.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/tmr.h
Go to the documentation of this file.
1
27#ifndef __TMR_H
28#define __TMR_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
36extern uint8_t time_ira_cnt;
37extern uint8_t get_data_from_usart_flag;
38
51void tmr_init(void);
52
65#ifdef __cplusplus
66}
67#endif
68
69#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
time_ira_cnt
uint8_t time_ira_cnt
Definition: bootloader/src/tmr.c:39
get_data_from_usart_flag
uint8_t get_data_from_usart_flag
Definition: bootloader/src/tmr.c:40
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:44


AT32F413 Firmwary Library: usart.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
bootloader/inc/usart.h
Go to the documentation of this file.
1
27#ifndef __USART_H
28#define __USART_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
48#define USART_REC_LEN 1024
49
61typedef struct
62{
63 uint16_t buf[USART_REC_LEN];
64 uint16_t head;
65 uint16_t tail;
66 uint16_t count;
67} usart_group_type;
68
73extern usart_group_type usart_group_struct;
74
79void uart_init(uint32_t baudrate);
80
93#ifdef __cplusplus
94}
95#endif
96
97#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usart_group_struct
usart_group_type usart_group_struct
Definition: bootloader/src/usart.c:38
USART_REC_LEN
#define USART_REC_LEN
Definition: bootloader/inc/usart.h:48
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
usart_group_type
usart group type
Definition: bootloader/inc/usart.h:62
usart_group_type::tail
uint16_t tail
Definition: bootloader/inc/usart.h:65
usart_group_type::count
uint16_t count
Definition: bootloader/inc/usart.h:66
usart_group_type::head
uint16_t head
Definition: bootloader/inc/usart.h:64


AT32F413 Firmwary Library: hid_iap_user.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/hid_iap_user.c
Go to the documentation of this file.
1
27#include "hid_iap_user.h"
28#include "hid_iap_class.h"
29#include "string.h"
30
39void (*pftarget)(void);
40void iap_clear_upgrade_flag(void);
41void iap_set_upgrade_flag(void);
42uint32_t crc_cal(uint32_t addr, uint16_t nk);
43
44void iap_idle(void);
45void iap_start(void);
46 iap_result_type iap_address(uint8_t *pdata, uint32_t len);
47void iap_finish(void);
48 iap_result_type iap_data_write(uint8_t *pdata, uint32_t len);
49void iap_jump(void);
50void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result);
51
57void jump_to_app(uint32_t address)
58{
59 uint32_t stkptr, jumpaddr;
60 stkptr = *(uint32_t *)address;
61 jumpaddr = *(uint32_t *)(address + sizeof(uint32_t));
62
63 /* disable nvic irq and periph clock, clear pending */
64 nvic_irq_disable(USBFS_L_CAN1_RX0_IRQn);
65 __NVIC_ClearPendingIRQ(USBFS_L_CAN1_RX0_IRQn);
66 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, FALSE);
67 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, FALSE);
68
69 crm_periph_reset(CRM_USB_PERIPH_RESET, TRUE);
70 crm_periph_reset(CRM_USB_PERIPH_RESET, FALSE);
71
72 __set_MSP(stkptr);
73 pftarget = (void (*) (void))jumpaddr;
74 pftarget();
75}
76
82void iap_clear_upgrade_flag(void)
83{
84 flash_unlock();
85 flash_sector_erase(iap_info.flag_address);
86 flash_lock();
87}
88
94void iap_set_upgrade_flag(void)
95{
96 flash_unlock();
97 flash_word_program(iap_info.flag_address, IAP_UPGRADE_COMPLETE_FLAG);
98 flash_lock();
99}
100
106 iap_result_type iap_get_upgrade_flag(void)
107{
108 uint32_t flag_address = iap_info.flag_address;
109 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
110 {
111 return IAP_SUCCESS;
112 }
113 else
114 {
115 return IAP_FAILED;
116 }
117}
118
124void iap_erase_sector(uint32_t address)
125{
126 flash_unlock();
127 if(iap_info.sector_size == SECTOR_SIZE_1K)
128 {
129 flash_sector_erase(address);
130 }
131 else if(iap_info.sector_size == SECTOR_SIZE_2K)
132 {
133 /* check the address is sector align */
134 if((address & (SECTOR_SIZE_2K-1)) == 0)
135 {
136 flash_sector_erase(address);
137 }
138 }
139 else if(iap_info.sector_size == SECTOR_SIZE_4K)
140 {
141 if((address & (SECTOR_SIZE_4K-1)) == 0)
142 {
143 flash_sector_erase(address);
144 }
145 }
146 flash_lock();
147}
148
155uint32_t crc_cal(uint32_t addr, uint16_t nk)
156{
157 uint32_t *paddr = (uint32_t *)addr;
158 uint32_t wlen = nk * 1024 / sizeof(uint32_t);
159 uint32_t value, i_index = 0;
160 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
161 crc_data_reset();
162
163 for(i_index = 0; i_index < wlen; i_index ++)
164 {
165 value = *paddr;
166 crc_one_word_calculate(CONVERT_ENDIAN(value));
167 paddr ++;
168 }
169 return crc_data_get();
170}
171
177void iap_init(void)
178{
179 iap_info.flash_size = KB_TO_B(FLASH_SIZE_REG());
180 if(iap_info.flash_size < KB_TO_B(256))
181 {
182 iap_info.sector_size = SECTOR_SIZE_1K;
183 }
184 else
185 {
186 iap_info.sector_size = SECTOR_SIZE_2K;
187 }
188
189 iap_info.flash_start_address = FLASH_BASE;
190 iap_info.flash_end_address = iap_info.flash_start_address + iap_info.flash_size;
191
192 iap_info.app_address = FLASH_APP_ADDRESS;
193 iap_info.flag_address = iap_info.app_address - iap_info.sector_size;
194
195 iap_info.fifo_length = 0;
196 iap_info.iap_address = 0;
197}
198
204void iap_idle(void)
205{
206 iap_info.state = IAP_STS_START;
207 iap_init();
208 iap_respond(iap_info.iap_tx, IAP_CMD_IDLE, IAP_ACK);
209}
210
216void iap_start(void)
217{
218 iap_info.state = IAP_STS_START;
219 iap_init();
220 iap_respond(iap_info.iap_tx, IAP_CMD_START, IAP_ACK);
221}
222
229 iap_result_type iap_address(uint8_t *pdata, uint32_t len)
230{
231 iap_result_type status = IAP_SUCCESS;
232 uint16_t result = IAP_ACK;
233 uint8_t *paddr = pdata + 2; /* skip iap cmd */
234 uint32_t address;
235
236 address = (paddr[0] << 24) |
237 (paddr[1] << 16) |
238 (paddr[2] << 8) |
239 paddr[3];
240
241 /* check the address is valid */
242 if(address < iap_info.app_address || address > iap_info.flash_end_address)
243 {
244 status = IAP_FAILED;
245 result = IAP_NACK;
246 }
247 else
248 {
249 iap_info.iap_address = address;
250
251 if(iap_info.state == IAP_STS_START)
252 {
253 iap_clear_upgrade_flag();
254 }
255 iap_erase_sector(iap_info.iap_address);
256 }
257
258 iap_info.state = IAP_STS_ADDR;
259
260 iap_respond(iap_info.iap_tx, IAP_CMD_ADDR, result);
261
262 return status;
263}
264/*
265 * @brief iap data write
266 * @param pdata: data buffer pointer.
267 * @param len: buffer length
268 * @retval the result of the address parse
269 */
270 iap_result_type iap_data_write(uint8_t *pdata, uint32_t len)
271{
272 uint32_t data_len = (pdata[2] << 8 | pdata[3]);
273 uint8_t *valid_data = pdata + 4;
274 uint32_t *pbuf;
275 uint32_t i_index = 0;
276
277 if(iap_info.state == IAP_STS_ADDR)
278 {
279 if(data_len + iap_info.fifo_length <= HID_IAP_BUFFER_LEN)
280 {
281 for(i_index = 0; i_index < data_len; i_index ++)
282 {
283 iap_info.iap_fifo[iap_info.fifo_length ++] = valid_data[i_index];
284 }
285 }
286 /* buffer full */
287 if(iap_info.fifo_length == HID_IAP_BUFFER_LEN)
288 {
289 flash_unlock();
290 pbuf = (uint32_t *)iap_info.iap_fifo;
291 for(i_index = 0; i_index < iap_info.fifo_length / sizeof(uint32_t); i_index ++)
292 {
293 flash_word_program(iap_info.iap_address, *pbuf ++);
294 iap_info.iap_address += 4;
295 }
296 flash_lock();
297
298 iap_info.fifo_length = 0;
299 iap_info.iap_address = 0;
300 iap_respond(iap_info.iap_tx, IAP_CMD_DATA, IAP_ACK);
301 }
302 }
303 else
304 {
305 iap_respond(iap_info.iap_tx, IAP_CMD_ADDR, IAP_NACK);
306 }
307 return IAP_SUCCESS;
308}
309
310/*
311 * @brief iap finish
312 * @param none
313 * @retval none
314 */
315void iap_finish()
316{
317 iap_info.state = IAP_STS_FINISH;
318 iap_set_upgrade_flag();
319 iap_respond(iap_info.iap_tx, IAP_CMD_FINISH, IAP_ACK);
320}
321
322/*
323 * @brief iap crc
324 * @param pdata: data buffer pointer.
325 * @param len: buffer length
326 * @retval the result of the address parse
327 */
328void iap_crc(uint8_t *pdata, uint32_t len)
329{
330 uint8_t *paddr = pdata + 2; /* skip iap cmd */
331 uint16_t crc_nk;
332 uint32_t crc_value;
333 uint32_t address = (paddr[0] << 24) |
334 (paddr[1] << 16) |
335 (paddr[2] << 8) |
336 paddr[3];
337 paddr = pdata + 6;
338
339 crc_nk = (paddr[0] << 16) | paddr[1];
340
341 crc_value = crc_cal(address, crc_nk);
342
343 iap_respond(iap_info.iap_tx, IAP_CMD_CRC, IAP_ACK);
344 iap_info.iap_tx[4] = (uint8_t)((crc_value >> 24) & 0xFF);
345 iap_info.iap_tx[5] = (uint8_t)((crc_value >> 16) & 0xFF);
346 iap_info.iap_tx[6] = (uint8_t)((crc_value >> 8) & 0xFF);
347 iap_info.iap_tx[7] = (uint8_t)((crc_value) & 0xFF);
348
349}
350
351/*
352 * @brief iap jump
353 * @param none
354 * @retval none
355 */
356void iap_jump()
357{
358 iap_info.state = IAP_STS_JMP_WAIT;
359 iap_respond(iap_info.iap_tx, IAP_CMD_JMP, IAP_ACK);
360}
361
362/*
363 * @brief iap get
364 * @param none
365 * @retval none
366 */
367void iap_get()
368{
369 iap_respond(iap_info.iap_tx, IAP_CMD_GET, IAP_ACK);
370 iap_info.iap_tx[4] = (uint8_t)((iap_info.app_address >> 24) & 0xFF);
371 iap_info.iap_tx[5] = (uint8_t)((iap_info.app_address >> 16) & 0xFF);
372 iap_info.iap_tx[6] = (uint8_t)((iap_info.app_address >> 8) & 0xFF);
373 iap_info.iap_tx[7] = (uint8_t)((iap_info.app_address) & 0xFF);
374}
375
376
377
378/*
379 * @brief iap respond
380 * @param res_buf: data buffer pointer.
381 * @param iap_cmd: iap command
382 * @param result: iap result
383 * @retval the result of the address parse
384 */
385void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
386{
387 res_buf[0] = (uint8_t)((iap_cmd >> 8) & 0xFF);
388 res_buf[1] = (uint8_t)((iap_cmd) & 0xFF);
389 res_buf[2] = (uint8_t)((result >> 8) & 0xFF);
390 res_buf[3] = (uint8_t)((result) & 0xFF);
391
392 iap_info.respond_flag = 1;
393}
394
402 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
403{
404 iap_result_type status = IAP_SUCCESS;
405 uint16_t iap_cmd;
406
407 if(len < 2)
408 {
409 return IAP_FAILED;
410 }
411
412 iap_info.respond_flag = 0;
413
414 iap_cmd = (pdata[0] << 8) | pdata[1];
415
416 switch(iap_cmd)
417 {
418 case IAP_CMD_IDLE:
419 iap_idle();
420 break;
421 case IAP_CMD_START:
422 iap_start();
423 break;
424 case IAP_CMD_ADDR:
425 iap_address(pdata, len);
426 break;
427 case IAP_CMD_DATA:
428 iap_data_write(pdata, len);
429 break;
430 case IAP_CMD_FINISH:
431 iap_finish();
432 break;
433 case IAP_CMD_CRC:
434 iap_crc(pdata, len);
435 break;
436 case IAP_CMD_JMP:
437 iap_jump();
438 break;
439 case IAP_CMD_GET:
440 iap_get();
441 break;
442 default:
443 status = IAP_FAILED;
444 break;
445 }
446
447 if(iap_info.respond_flag)
448 {
449 usb_iap_class_send_report(udev, iap_info.iap_tx, 64);
450 }
451
452 return status;
453}
454
460void usbd_hid_iap_in_complete(void *udev)
461{
462 if(iap_info.state == IAP_STS_JMP_WAIT)
463 {
464 iap_info.state = IAP_STS_JMP;
465 }
466}
467
473void iap_loop(void)
474{
475 if(iap_info.state == IAP_STS_JMP)
476 {
477 delay_ms(100);
478 jump_to_app(iap_info.app_address);
479 }
480}
481
crc_value
__IO uint32_t crc_value
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:64
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:49
crc_data_get
uint32_t crc_data_get(void)
return the current crc value.
Definition: at32f413_crc.c:89
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f413_crc.c:60
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f413_crm.h:106
CRM_USB_PERIPH_RESET
@ CRM_USB_PERIPH_RESET
Definition: at32f413_crm.h:182
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f413_misc.c:81
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:291
iap_set_upgrade_flag
void iap_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: bootloader/src/hid_iap_user.c:94
iap_idle
void iap_idle(void)
iap idle function
Definition: bootloader/src/hid_iap_user.c:204
iap_respond
void iap_respond(uint8_t *res_buf, uint16_t iap_cmd, uint16_t result)
Definition: bootloader/src/hid_iap_user.c:385
iap_data_write
iap_result_type iap_data_write(uint8_t *pdata, uint32_t len)
Definition: bootloader/src/hid_iap_user.c:270
iap_init
void iap_init(void)
iap init
Definition: bootloader/src/hid_iap_user.c:177
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *pdata, uint16_t len)
usb device iap function
Definition: bootloader/src/hid_iap_user.c:402
jump_to_app
void jump_to_app(uint32_t address)
jump to app
Definition: bootloader/src/hid_iap_user.c:57
crc_cal
uint32_t crc_cal(uint32_t addr, uint16_t nk)
crc cal
Definition: bootloader/src/hid_iap_user.c:155
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: bootloader/src/hid_iap_user.c:106
iap_address
iap_result_type iap_address(uint8_t *pdata, uint32_t len)
iap parse address
Definition: bootloader/src/hid_iap_user.c:229
iap_finish
void iap_finish(void)
Definition: bootloader/src/hid_iap_user.c:315
iap_loop
void iap_loop(void)
iap loop
Definition: bootloader/src/hid_iap_user.c:473
iap_start
void iap_start(void)
iap start function
Definition: bootloader/src/hid_iap_user.c:216
iap_crc
void iap_crc(uint8_t *pdata, uint32_t len)
Definition: bootloader/src/hid_iap_user.c:328
pftarget
void(* pftarget)(void)
Definition: bootloader/src/hid_iap_user.c:39
iap_erase_sector
void iap_erase_sector(uint32_t address)
set iap upgrade complete flag
Definition: bootloader/src/hid_iap_user.c:124
iap_clear_upgrade_flag
void iap_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: bootloader/src/hid_iap_user.c:82
iap_get
void iap_get()
Definition: bootloader/src/hid_iap_user.c:367
iap_jump
void iap_jump(void)
Definition: bootloader/src/hid_iap_user.c:356
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: bootloader/src/hid_iap_user.c:460
HID_IAP_BUFFER_LEN
#define HID_IAP_BUFFER_LEN
Definition: hid_iap_class.h:77
IAP_CMD_DATA
#define IAP_CMD_DATA
Definition: hid_iap_class.h:71
IAP_CMD_FINISH
#define IAP_CMD_FINISH
Definition: hid_iap_class.h:72
IAP_CMD_IDLE
#define IAP_CMD_IDLE
iap command
Definition: hid_iap_class.h:68
IAP_CMD_GET
#define IAP_CMD_GET
Definition: hid_iap_class.h:75
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
IAP_NACK
#define IAP_NACK
Definition: hid_iap_class.h:83
IAP_ACK
#define IAP_ACK
Definition: hid_iap_class.h:82
IAP_CMD_CRC
#define IAP_CMD_CRC
Definition: hid_iap_class.h:73
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
CONVERT_ENDIAN
#define CONVERT_ENDIAN(dwValue)
Definition: hid_iap_class.h:79
IAP_CMD_ADDR
#define IAP_CMD_ADDR
Definition: hid_iap_class.h:70
SECTOR_SIZE_4K
#define SECTOR_SIZE_4K
Definition: hid_iap_class.h:63
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:78
FLASH_SIZE_REG
#define FLASH_SIZE_REG()
Definition: hid_iap_class.h:58
IAP_CMD_START
#define IAP_CMD_START
Definition: hid_iap_class.h:69
IAP_CMD_JMP
#define IAP_CMD_JMP
Definition: hid_iap_class.h:74
KB_TO_B
#define KB_TO_B(kb)
Definition: hid_iap_class.h:59
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:95
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:101
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:100
IAP_STS_FINISH
@ IAP_STS_FINISH
Definition: hid_iap_class.h:98
IAP_STS_ADDR
@ IAP_STS_ADDR
Definition: hid_iap_class.h:96
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:49
hid_iap_class.h
usb hid iap header file
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:124
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:116
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:121
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:115
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:118
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:119
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:111
iap_info_type::iap_fifo
uint8_t iap_fifo[1024]
Definition: hid_iap_class.h:107
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:122
iap_info_type::iap_tx
uint8_t iap_tx[0x40]
Definition: hid_iap_class.h:109
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:114
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:133


AT32F413 Firmwary Library: iap.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/iap.c
Go to the documentation of this file.
1
27#include "iap.h"
28#include "usart.h"
29#include "flash.h"
30#include "tmr.h"
31
40 cmd_data_step_type cmd_data_step = CMD_DATA_IDLE;
41 cmd_ctr_step_type cmd_ctr_step = CMD_CTR_IDLE;
42 cmd_data_group_type cmd_data_group_struct;
43 update_status_type update_status = UPDATE_PRE;
44static uint8_t cmd_addr_cnt = 0;
45static uint32_t cmd_data_cnt = 0;
46 iapfun jump_to_app;
47
48/* app_load don't optimize */
49#if defined (__CC_ARM)
50 #pragma O0
51#elif defined (__ICCARM__)
52 #pragma optimize=s none
53#endif
60void app_load(uint32_t app_addr)
61{
62 /* check the address of stack */
63 if(((*(uint32_t*)app_addr) - 0x20000000) < (SRAM_SIZE * 1024))
64 {
65 /* disable periph clock */
66 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, FALSE);
67 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, FALSE);
68 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, FALSE);
69
70 /* disable nvic irq and clear pending */
71 nvic_irq_disable(USART1_IRQn);
72 nvic_irq_disable(TMR3_GLOBAL_IRQn);
73 __NVIC_ClearPendingIRQ(USART1_IRQn);
74 __NVIC_ClearPendingIRQ(TMR3_GLOBAL_IRQn);
75
76 jump_to_app = (iapfun)*(uint32_t*)(app_addr + 4); /* code second word is reset address */
77 __set_MSP(*(uint32_t*)app_addr); /* init app stack pointer(code first word is stack address) */
78 jump_to_app(); /* jump to user app */
79 }
80}
81
89uint8_t data_take(void)
90{
91 uint8_t val;
92 usart_interrupt_enable(USART1, USART_RDBF_INT, FALSE);
93 usart_group_struct.count--;
94 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
95 val = usart_group_struct.buf[usart_group_struct.tail++];
96 if(usart_group_struct.tail > (USART_REC_LEN-1))
97 usart_group_struct.tail = 0;
98 return val;
99}
100
106void command_handle(void)
107{
108 uint8_t val, checksum;
109 uint16_t index;
110 /* check whether received usart data */
111 if(usart_group_struct.count > 0)
112 val = data_take();
113 else
114 return;
115
116 if(update_status == UPDATE_PRE)
117 {
118 if(cmd_ctr_step == CMD_CTR_IDLE)
119 {
120 if(val == 0x5A)
121 cmd_ctr_step = CMD_CTR_INIT;
122 }
123 else if(cmd_ctr_step == CMD_CTR_INIT)
124 {
125 if(val == 0x01)
126 {
127 cmd_ctr_step = CMD_CTR_DONE;
128 }
129 else if(val == 0xA5)
130 {
131 cmd_ctr_step = CMD_CTR_APP;
132 }
133 else
134 {
135 cmd_ctr_step = CMD_CTR_ERR;
136 }
137 }
138 }
139 else if(update_status == UPDATE_ING)
140 {
141 switch(cmd_data_step)
142 {
143 case CMD_DATA_IDLE:
144 if(val == 0x31)
145 {
146 cmd_data_step = CMD_DATA_ADDR;
147 cmd_addr_cnt = 0;
148 cmd_data_cnt = 0;
149 }
150 if(val == 0x5A)
151 {
152 if(cmd_ctr_step == CMD_CTR_IDLE)
153 {
154 cmd_ctr_step = CMD_CTR_INIT;
155 update_status = UPDATE_DONE;
156 }
157 }
158 break;
159 case CMD_DATA_ADDR:
160 cmd_data_group_struct.cmd_addr[cmd_addr_cnt] = val;
161 cmd_addr_cnt++;
162 if(cmd_addr_cnt >= 4)
163 {
164 cmd_addr_cnt = 0;
165 cmd_data_step = CMD_DATA_BUF;
166 }
167 break;
168 case CMD_DATA_BUF:
169 cmd_data_group_struct.cmd_buf[cmd_data_cnt] = val;
170 cmd_data_cnt++;
171 if(cmd_data_cnt >= 2048)
172 {
173 cmd_data_cnt = 0;
174 cmd_data_step = CMD_DATA_CHACK;
175 }
176 break;
177 case CMD_DATA_CHACK:
178 checksum = 0;
179 for(index = 0;index < 4;index++)
180 {
181 checksum += cmd_data_group_struct.cmd_addr[index];
182 }
183 for(index = 0;index < 0x800; index++)
184 {
185 checksum += cmd_data_group_struct.cmd_buf[index];
186 }
187 if(checksum == val)
188 {
189 cmd_data_step = CMD_DATA_DONE;
190 }
191 else
192 {
193 cmd_data_step = CMD_DATA_ERR;
194 }
195 break;
196 default:
197 break;
198 }
199 }
200 else if(update_status == UPDATE_DONE)
201 {
202 if(cmd_ctr_step == CMD_CTR_IDLE)
203 {
204 if(val == 0x5A)
205 {
206 cmd_ctr_step = CMD_CTR_INIT;
207 }
208 }
209 else if(cmd_ctr_step == CMD_CTR_INIT)
210 {
211 if(val == 0x02)
212 {
213 cmd_ctr_step = CMD_CTR_DONE;
214 }
215 else
216 {
217 cmd_ctr_step = CMD_CTR_ERR;
218 }
219 }
220 }
221}
222
228void back_ok(void)
229{
230 usart_data_transmit(USART1, 0xCC);
231 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
232 usart_data_transmit(USART1, 0xDD);
233 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
234}
235
241void back_err(void)
242{
243 usart_data_transmit(USART1, 0xEE);
244 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
245 usart_data_transmit(USART1, 0xFF);
246 while(usart_flag_get(USART1, USART_TDC_FLAG) == RESET);
247 /* reset state machine of udgrade flow */
248 cmd_data_step = CMD_DATA_IDLE;
249 cmd_ctr_step = CMD_CTR_IDLE;
250 update_status = UPDATE_PRE;
251 cmd_addr_cnt = 0;
252 cmd_data_cnt = 0;
253 time_ira_cnt = 0;
254 get_data_from_usart_flag = 0;
255}
256
262void app_update_handle(void)
263{
264 uint32_t write_addr=0;
265 if(update_status == UPDATE_PRE)
266 {
267 if(cmd_ctr_step == CMD_CTR_DONE)
268 {
269 cmd_ctr_step = CMD_CTR_IDLE;
270 update_status = UPDATE_CLEAR_FLAG;
271 }
272 else if(cmd_ctr_step == CMD_CTR_APP)
273 {
274 cmd_ctr_step = CMD_CTR_IDLE;
275 back_ok();
276 }
277 else if(cmd_ctr_step == CMD_CTR_ERR)
278 {
279 cmd_ctr_step = CMD_CTR_IDLE;
280 back_err();
281 }
282 }
283 else if(update_status == UPDATE_CLEAR_FLAG)
284 {
285 get_data_from_usart_flag = 1;
286 update_status = UPDATE_ING;
287 back_ok();
288 }
289 else if(update_status == UPDATE_ING)
290 {
291 if(cmd_data_step == CMD_DATA_DONE)
292 {
293 write_addr = (cmd_data_group_struct.cmd_addr[0] << 24) + (cmd_data_group_struct.cmd_addr[1] << 16) + \
294 (cmd_data_group_struct.cmd_addr[2] << 8) + cmd_data_group_struct.cmd_addr[3];
295 if((write_addr >= APP_START_ADDR) && (write_addr < FLASH_BASE + 1024 * FLASH_SIZE))
296 {
297 flash_2kb_write(write_addr, cmd_data_group_struct.cmd_buf);
298 cmd_data_step = CMD_DATA_IDLE;
299 back_ok();
300 }
301 else
302 {
303 cmd_data_step = CMD_DATA_IDLE;
304 back_err();
305 }
306 }
307 else if(cmd_data_step == CMD_DATA_ERR)
308 {
309 cmd_data_step = CMD_DATA_IDLE;
310 back_err();
311 }
312 }
313 else if(update_status == UPDATE_DONE)
314 {
315 if(cmd_ctr_step == CMD_CTR_DONE)
316 {
317 cmd_ctr_step = CMD_CTR_IDLE;
318 back_ok();
319 /* check app starting address whether 0x08xxxxxx */
320 if(((*(uint32_t*)(APP_START_ADDR + 4)) & 0xFF000000) == 0x08000000)
321 {
322 crm_reset();
323 /* jump and run in app */
324 app_load(APP_START_ADDR);
325 }
326 else
327 {
328 cmd_ctr_step = CMD_CTR_ERR;
329 }
330 }
331 else if(cmd_ctr_step == CMD_CTR_ERR)
332 {
333 cmd_ctr_step = CMD_CTR_IDLE;
334 back_err();
335 }
336 }
337}
338
344void iap_upgrade_app_handle(void)
345{
346 command_handle();
347 app_update_handle();
348}
349
jump_to_app
iapfun jump_to_app
jump to app
Definition: bootloader/src/iap.c:46
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:120
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:163
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:171
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_irq_disable
void nvic_irq_disable(IRQn_Type irqn)
disable nvic irq number
Definition: at32f413_misc.c:81
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:291
cmd_addr_cnt
static uint8_t cmd_addr_cnt
Definition: bootloader/src/iap.c:44
app_update_handle
void app_update_handle(void)
app update flow handle.
Definition: bootloader/src/iap.c:262
data_take
uint8_t data_take(void)
take data from usart buf.
Definition: bootloader/src/iap.c:89
command_handle
void command_handle(void)
command analysis handle.
Definition: bootloader/src/iap.c:106
update_status
update_status_type update_status
Definition: bootloader/src/iap.c:43
iap_upgrade_app_handle
void iap_upgrade_app_handle(void)
iap upgrade app handle.
Definition: bootloader/src/iap.c:344
cmd_data_group_struct
cmd_data_group_type cmd_data_group_struct
Definition: bootloader/src/iap.c:42
time_ira_cnt
uint8_t time_ira_cnt
Definition: bootloader/src/tmr.c:39
cmd_data_cnt
static uint32_t cmd_data_cnt
Definition: bootloader/src/iap.c:45
get_data_from_usart_flag
uint8_t get_data_from_usart_flag
Definition: bootloader/src/tmr.c:40
cmd_data_step
cmd_data_step_type cmd_data_step
Definition: bootloader/src/iap.c:40
app_load
void app_load(uint32_t app_addr)
app load.
Definition: bootloader/src/iap.c:60
cmd_ctr_step
cmd_ctr_step_type cmd_ctr_step
Definition: bootloader/src/iap.c:41
back_err
void back_err(void)
command response error.
Definition: bootloader/src/iap.c:241
usart_group_struct
usart_group_type usart_group_struct
Definition: bootloader/src/usart.c:38
back_ok
void back_ok(void)
command response ok.
Definition: bootloader/src/iap.c:228
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:58
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART1
#define USART1
Definition: at32f413_usart.h:319
APP_START_ADDR
#define APP_START_ADDR
Definition: app_led3_toggle/inc/iap.h:49
SRAM_SIZE
#define SRAM_SIZE
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h:49
USART_REC_LEN
#define USART_REC_LEN
Definition: bootloader/inc/usart.h:48
FLASH_SIZE
#define FLASH_SIZE
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h:48
flash_2kb_write
void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:45
iapfun
void(* iapfun)(void)
Definition: bootloader/inc/iap.h:113
update_status_type
update_status_type
update status type
Definition: bootloader/inc/iap.h:106
cmd_ctr_step_type
cmd_ctr_step_type
cmd ctr step type
Definition: bootloader/inc/iap.h:94
cmd_data_step_type
cmd_data_step_type
cmd data step type
Definition: bootloader/inc/iap.h:81
UPDATE_PRE
@ UPDATE_PRE
Definition: bootloader/inc/iap.h:107
UPDATE_DONE
@ UPDATE_DONE
Definition: bootloader/inc/iap.h:110
UPDATE_ING
@ UPDATE_ING
Definition: bootloader/inc/iap.h:109
UPDATE_CLEAR_FLAG
@ UPDATE_CLEAR_FLAG
Definition: bootloader/inc/iap.h:108
CMD_CTR_ERR
@ CMD_CTR_ERR
Definition: bootloader/inc/iap.h:98
CMD_CTR_DONE
@ CMD_CTR_DONE
Definition: bootloader/inc/iap.h:97
CMD_CTR_INIT
@ CMD_CTR_INIT
Definition: bootloader/inc/iap.h:96
CMD_CTR_APP
@ CMD_CTR_APP
Definition: bootloader/inc/iap.h:99
CMD_CTR_IDLE
@ CMD_CTR_IDLE
Definition: bootloader/inc/iap.h:95
CMD_DATA_DONE
@ CMD_DATA_DONE
Definition: bootloader/inc/iap.h:86
CMD_DATA_ERR
@ CMD_DATA_ERR
Definition: bootloader/inc/iap.h:87
CMD_DATA_BUF
@ CMD_DATA_BUF
Definition: bootloader/inc/iap.h:84
CMD_DATA_IDLE
@ CMD_DATA_IDLE
Definition: bootloader/inc/iap.h:82
CMD_DATA_CHACK
@ CMD_DATA_CHACK
Definition: bootloader/inc/iap.h:85
CMD_DATA_ADDR
@ CMD_DATA_ADDR
Definition: bootloader/inc/iap.h:83
cmd_data_group_type
cmd data group type
Definition: bootloader/inc/iap.h:70
cmd_data_group_type::cmd_addr
uint8_t cmd_addr[4]
Definition: bootloader/inc/iap.h:72
cmd_data_group_type::cmd_buf
uint8_t cmd_buf[0x800]
Definition: bootloader/inc/iap.h:73
usart_group_type::tail
uint16_t tail
Definition: bootloader/inc/usart.h:65
usart_group_type::buf
uint16_t buf[1024]
Definition: bootloader/inc/usart.h:63
usart_group_type::count
uint16_t count
Definition: bootloader/inc/usart.h:66


AT32F413 Firmwary Library: tmr.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/tmr.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "tmr.h"
29#include "iap.h"
30
39uint8_t time_ira_cnt=0;
40uint8_t get_data_from_usart_flag = 0; /* flag for timer out in upgrade flow */
41
47void tmr_init(void)
48{
49 crm_clocks_freq_type crm_clocks_freq_struct = {0};
50
51 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
52
53 /* enable the tmr3 global interrupt */
54 nvic_irq_enable(TMR3_GLOBAL_IRQn, 1, 0);
55
56 /* get system clock */
57 crm_clocks_freq_get(&crm_clocks_freq_struct);
58
59 /* time base configuration */
60 tmr_base_init(TMR3, 10000, crm_clocks_freq_struct.ahb_freq / 10000);
61 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
62
63 /* overflow interrupt enable */
64 tmr_interrupt_enable(TMR3, TMR_OVF_INT, TRUE);
65
66 /* enable tmr */
67 tmr_counter_enable(TMR3, TRUE);
68}
69
75void TMR3_GLOBAL_IRQHandler(void)
76{
77 if(tmr_flag_get(TMR3, TMR_OVF_FLAG) == SET)
78 {
79 tmr_flag_clear(TMR3, TMR_OVF_FLAG);
80 at32_led_toggle(LED2);
81 if(get_data_from_usart_flag)
82 {
83 if((++time_ira_cnt) == 0x00)
84 time_ira_cnt = 0xFF;
85 if(time_ira_cnt > 2)
86 back_err();
87 if(time_ira_cnt > 5)
88 crm_periph_clock_enable(LED2_GPIO_CRM_CLK, FALSE);
89 }
90 }
91}
92
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:39
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:163
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:74
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
time_ira_cnt
uint8_t time_ira_cnt
Definition: bootloader/src/tmr.c:39
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
tmr3 global interrupt handler.
Definition: bootloader/src/tmr.c:75
tmr_init
void tmr_init(void)
init tmr.
Definition: bootloader/src/tmr.c:47
get_data_from_usart_flag
uint8_t get_data_from_usart_flag
Definition: bootloader/src/tmr.c:40
back_err
void back_err(void)
command response error.
Definition: app_led3_toggle/src/usart.c:120
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:473


AT32F413 Firmwary Library: usart.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
bootloader/src/usart.c
Go to the documentation of this file.
1
27#include "usart.h"
28#include "tmr.h"
29
38 usart_group_type usart_group_struct;
39
45void uart_init(uint32_t baudrate)
46{
47 gpio_init_type gpio_init_struct;
48 /* enable the usart and it's io clock */
49 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
50 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
51
52 /* set default parameter */
53 gpio_default_para_init(&gpio_init_struct);
54
55 /* configure the usart1_tx pa9 */
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
58 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
59 gpio_init_struct.gpio_pins = GPIO_PINS_9;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init(GPIOA, &gpio_init_struct);
62
63 /* configure the usart1_rx pa10 */
64 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
65 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
66 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
67 gpio_init_struct.gpio_pins = GPIO_PINS_10;
68 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
69 gpio_init(GPIOA, &gpio_init_struct);
70
71 /*configure usart nvic interrupt */
72 nvic_irq_enable(USART1_IRQn, 0, 0);
73
74 /*configure usart param*/
75 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
76 usart_transmitter_enable(USART1, TRUE);
77 usart_receiver_enable(USART1, TRUE);
78 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
79 usart_enable(USART1, TRUE);
80}
81
87void USART1_IRQHandler(void)
88{
89 uint16_t reval;
90 time_ira_cnt = 0; /* clear upgrade time out flag */
91 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
92 {
93 reval = usart_data_receive(USART1);
94 if(usart_group_struct.count > (USART_REC_LEN - 1))
95 {
96 usart_group_struct.count = 0;
97 usart_group_struct.head = 0;
98 usart_group_struct.tail = 0;
99 }
100 else
101 {
102 usart_group_struct.count++;
103 usart_group_struct.buf[usart_group_struct.head++] = reval;
104 if(usart_group_struct.head > (USART_REC_LEN - 1))
105 {
106 usart_group_struct.head = 0;
107 }
108 }
109 }
110}
111
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:120
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:171
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
time_ira_cnt
uint8_t time_ira_cnt
Definition: bootloader/src/tmr.c:39
USART1_IRQHandler
void USART1_IRQHandler(void)
usart1 interrupt handler.
Definition: bootloader/src/usart.c:87
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: bootloader/src/usart.c:45
usart_group_struct
usart_group_type usart_group_struct
Definition: bootloader/src/usart.c:38
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART1
#define USART1
Definition: at32f413_usart.h:319
USART_REC_LEN
#define USART_REC_LEN
Definition: bootloader/inc/usart.h:48
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
usart_group_type
usart group type
Definition: bootloader/inc/usart.h:62
usart_group_type::tail
uint16_t tail
Definition: bootloader/inc/usart.h:65
usart_group_type::buf
uint16_t buf[1024]
Definition: bootloader/inc/usart.h:63
usart_group_type::count
uint16_t count
Definition: bootloader/inc/usart.h:66
usart_group_type::head
uint16_t head
Definition: bootloader/inc/usart.h:64


AT32F413 Firmwary Library: cdc_class.c Source File

  • middlewares
  • usbd_class
  • cdc
cdc_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "cdc_class.h"
28#include "cdc_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53static usb_sts_type cdc_struct_init(cdc_struct_type *pcdc);
54extern void usb_usart_config( linecoding_type linecoding);
55static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len);
56
57 linecoding_type linecoding =
58{
59 115200,
60 0,
61 0,
62 8
63};
64
65/* cdc data struct */
66 cdc_struct_type cdc_struct;
67
68/* usb device class handler */
69 usbd_class_handler cdc_class_handler =
70{
71 class_init_handler,
72 class_clear_handler,
73 class_setup_handler,
74 class_ept0_tx_handler,
75 class_ept0_rx_handler,
76 class_in_handler,
77 class_out_handler,
78 class_sof_handler,
79 class_event_handler,
80 &cdc_struct
81};
82
88static usb_sts_type class_init_handler(void *udev)
89{
90 usb_sts_type status = USB_OK;
91 usbd_core_type *pudev = (usbd_core_type *)udev;
92 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
93
94#ifndef USB_EPT_AUTO_MALLOC_BUFFER
95 /* use user define buffer address */
96 usbd_ept_buf_custom_define(pudev, USBD_CDC_INT_EPT, EPT2_TX_ADDR);
97 usbd_ept_buf_custom_define(pudev, USBD_CDC_BULK_IN_EPT, EPT1_TX_ADDR);
98 usbd_ept_buf_custom_define(pudev, USBD_CDC_BULK_OUT_EPT, EPT1_RX_ADDR);
99#endif
100
101 /* open in endpoint */
102 usbd_ept_open(pudev, USBD_CDC_INT_EPT, EPT_INT_TYPE, USBD_CDC_CMD_MAXPACKET_SIZE);
103
104 /* open in endpoint */
105 usbd_ept_open(pudev, USBD_CDC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_CDC_IN_MAXPACKET_SIZE);
106
107 /* open out endpoint */
108 usbd_ept_open(pudev, USBD_CDC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_CDC_OUT_MAXPACKET_SIZE);
109
110 /* set out endpoint to receive status */
111 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdc->g_rx_buff, USBD_CDC_OUT_MAXPACKET_SIZE);
112
113 cdc_struct_init(pcdc);
114
115 return status;
116}
117
123static usb_sts_type class_clear_handler(void *udev)
124{
125 usb_sts_type status = USB_OK;
126 usbd_core_type *pudev = (usbd_core_type *)udev;
127
128 /* close in endpoint */
129 usbd_ept_close(pudev, USBD_CDC_INT_EPT);
130
131 /* close in endpoint */
132 usbd_ept_close(pudev, USBD_CDC_BULK_IN_EPT);
133
134 /* close out endpoint */
135 usbd_ept_close(pudev, USBD_CDC_BULK_OUT_EPT);
136
137 return status;
138}
139
146static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
147{
148 usb_sts_type status = USB_OK;
149 usbd_core_type *pudev = (usbd_core_type *)udev;
150 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
151
152 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
153 {
154 /* class request */
155 case USB_REQ_TYPE_CLASS:
156 if(setup->wLength)
157 {
158 if(setup->bmRequestType & USB_REQ_DIR_DTH)
159 {
160 usb_vcp_cmd_process(udev, setup->bRequest, pcdc->g_cmd, setup->wLength);
161 usbd_ctrl_send(pudev, pcdc->g_cmd, setup->wLength);
162 }
163 else
164 {
165 pcdc->g_req = setup->bRequest;
166 pcdc->g_len = setup->wLength;
167 usbd_ctrl_recv(pudev, pcdc->g_cmd, pcdc->g_len);
168
169 }
170 }
171 break;
172 /* standard request */
173 case USB_REQ_TYPE_STANDARD:
174 switch(setup->bRequest)
175 {
176 case USB_STD_REQ_GET_DESCRIPTOR:
177 usbd_ctrl_unsupport(pudev);
178 break;
179 case USB_STD_REQ_GET_INTERFACE:
180 usbd_ctrl_send(pudev, (uint8_t *)&pcdc->alt_setting, 1);
181 break;
182 case USB_STD_REQ_SET_INTERFACE:
183 pcdc->alt_setting = setup->wValue;
184 break;
185 default:
186 break;
187 }
188 break;
189 default:
190 usbd_ctrl_unsupport(pudev);
191 break;
192 }
193 return status;
194}
195
201static usb_sts_type class_ept0_tx_handler(void *udev)
202{
203 usb_sts_type status = USB_OK;
204
205 /* ...user code... */
206
207 return status;
208}
209
215static usb_sts_type class_ept0_rx_handler(void *udev)
216{
217 usb_sts_type status = USB_OK;
218 usbd_core_type *pudev = (usbd_core_type *)udev;
219 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
220 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
221 /* ...user code... */
222 if( pcdc->g_req == SET_LINE_CODING)
223 {
224 /* class process */
225 usb_vcp_cmd_process(udev, pcdc->g_req, pcdc->g_cmd, recv_len);
226 }
227
228 return status;
229}
230
237static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
238{
239 usbd_core_type *pudev = (usbd_core_type *)udev;
240 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
241 usb_sts_type status = USB_OK;
242
243 /* ...user code...
244 trans next packet data
245 */
246 pcdc->g_tx_completed = 1;
247
248 return status;
249}
250
257static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
258{
259 usb_sts_type status = USB_OK;
260 usbd_core_type *pudev = (usbd_core_type *)udev;
261 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
262
263 /* get endpoint receive data length */
264 pcdc->g_rxlen = usbd_get_recv_len(pudev, ept_num);
265
266 /*set recv flag*/
267 pcdc->g_rx_completed = 1;
268
269 return status;
270}
271
277static usb_sts_type class_sof_handler(void *udev)
278{
279 usb_sts_type status = USB_OK;
280
281 /* ...user code... */
282
283 return status;
284}
285
292static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
293{
294 usb_sts_type status = USB_OK;
295 switch(event)
296 {
297 case USBD_RESET_EVENT:
298
299 /* ...user code... */
300
301 break;
302 case USBD_SUSPEND_EVENT:
303
304 /* ...user code... */
305
306 break;
307 case USBD_WAKEUP_EVENT:
308 /* ...user code... */
309
310 break;
311 default:
312 break;
313 }
314 return status;
315}
316
322static usb_sts_type cdc_struct_init(cdc_struct_type *pcdc)
323{
324 pcdc->g_tx_completed = 1;
325 pcdc->g_rx_completed = 0;
326 pcdc->alt_setting = 0;
327 pcdc->linecoding.bitrate = linecoding.bitrate;
328 pcdc->linecoding.data = linecoding.data;
329 pcdc->linecoding.format = linecoding.format;
330 pcdc->linecoding.parity = linecoding.parity;
331 return USB_OK;
332}
333
340uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
341{
342 uint16_t i_index = 0;
343 uint16_t tmp_len = 0;
344 usbd_core_type *pudev = (usbd_core_type *)udev;
345 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
346
347 if(pcdc->g_rx_completed == 0)
348 {
349 return 0;
350 }
351 pcdc->g_rx_completed = 0;
352 tmp_len = pcdc->g_rxlen;
353 for(i_index = 0; i_index < pcdc->g_rxlen; i_index ++)
354 {
355 recv_data[i_index] = pcdc->g_rx_buff[i_index];
356 }
357
358 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdc->g_rx_buff, USBD_CDC_OUT_MAXPACKET_SIZE);
359
360 return tmp_len;
361}
362
370 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
371{
372 error_status status = SUCCESS;
373 usbd_core_type *pudev = (usbd_core_type *)udev;
374 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
375 if(pcdc->g_tx_completed)
376 {
377 pcdc->g_tx_completed = 0;
378 usbd_ept_send(pudev, USBD_CDC_BULK_IN_EPT, send_data, len);
379 }
380 else
381 {
382 status = ERROR;
383 }
384 return status;
385}
386
387
396static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
397{
398 usbd_core_type *pudev = (usbd_core_type *)udev;
399 cdc_struct_type *pcdc = (cdc_struct_type *)pudev->class_handler->pdata;
400 switch(cmd)
401 {
402 case SET_LINE_CODING:
403 pcdc->linecoding.bitrate = (uint32_t)(buff[0] | (buff[1] << 8) | (buff[2] << 16) | (buff[3] <<24));
404 pcdc->linecoding.format = buff[4];
405 pcdc->linecoding.parity = buff[5];
406 pcdc->linecoding.data = buff[6];
407#ifdef USB_VIRTUAL_COMPORT
408 /* set hardware usart */
409 usb_usart_config(pcdc->linecoding);
410#endif
411 break;
412
413 case GET_LINE_CODING:
414 buff[0] = (uint8_t)pcdc->linecoding.bitrate;
415 buff[1] = (uint8_t)(pcdc->linecoding.bitrate >> 8);
416 buff[2] = (uint8_t)(pcdc->linecoding.bitrate >> 16);
417 buff[3] = (uint8_t)(pcdc->linecoding.bitrate >> 24);
418 buff[4] = (uint8_t)(pcdc->linecoding.format);
419 buff[5] = (uint8_t)(pcdc->linecoding.parity);
420 buff[6] = (uint8_t)(pcdc->linecoding.data);
421 break;
422
423 default:
424 break;
425 }
426}
427
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
EPT1_RX_ADDR
#define EPT1_RX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:78
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:77
EPT2_TX_ADDR
#define EPT2_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:80
USB_EPT_AUTO_MALLOC_BUFFER
#define USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer
Definition: project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h:63
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:55
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:53
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:54
USBD_CDC_OUT_MAXPACKET_SIZE
#define USBD_CDC_OUT_MAXPACKET_SIZE
Definition: cdc_class.h:61
USBD_CDC_IN_MAXPACKET_SIZE
#define USBD_CDC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_class.h:60
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_class.c:277
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_class.c:237
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_class.c:123
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_class.c:146
usb_usart_config
void usb_usart_config(linecoding_type linecoding)
this function handles usart2 and linecoding config.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:299
linecoding
linecoding_type linecoding
Definition: cdc_class.c:57
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_class.c:201
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:340
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_class.c:215
cdc_struct_init
static usb_sts_type cdc_struct_init(cdc_struct_type *pcdc)
usb device cdc init
Definition: cdc_class.c:322
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_class.c:292
usb_vcp_cmd_process
static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function
Definition: cdc_class.c:396
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:370
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_class.c:88
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_class.c:257
cdc_struct
cdc_struct_type cdc_struct
Definition: cdc_class.c:66
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:69
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:204
GET_LINE_CODING
#define GET_LINE_CODING
Definition: cdc_msc_class.h:107
SET_LINE_CODING
#define SET_LINE_CODING
Definition: cdc_msc_class.h:106
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
USB_REQ_DIR_DTH
#define USB_REQ_DIR_DTH
Definition: usb_std.h:72
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:461
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
cdc_struct_type
usb cdc class struct
Definition: cdc_class.h:76
cdc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_class.h:77
cdc_struct_type::g_req
uint8_t g_req
Definition: cdc_class.h:80
cdc_struct_type::g_rxlen
uint16_t g_rxlen
Definition: cdc_class.h:81
cdc_struct_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_class.h:82
cdc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_class.h:83
cdc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_class.h:82
cdc_struct_type::g_cmd
uint8_t g_cmd[0x08]
Definition: cdc_class.h:79
cdc_struct_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: cdc_class.h:78
cdc_struct_type::g_len
uint16_t g_len
Definition: cdc_class.h:81
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:214
linecoding_type::data
uint8_t data
Definition: usb_std.h:217
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:216
linecoding_type::format
uint8_t format
Definition: usb_std.h:215
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_class.h Source File

  • middlewares
  • usbd_class
  • cdc
cdc_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_CLASS_H
29#define __CDC_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_CDC_INT_EPT 0x82
54#define USBD_CDC_BULK_IN_EPT 0x81
55#define USBD_CDC_BULK_OUT_EPT 0x01
56
60#define USBD_CDC_IN_MAXPACKET_SIZE 0x40
61#define USBD_CDC_OUT_MAXPACKET_SIZE 0x40
62#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08
63
75typedef struct
76{
77 uint32_t alt_setting;
78 uint8_t g_rx_buff[USBD_CDC_OUT_MAXPACKET_SIZE];
79 uint8_t g_cmd[USBD_CDC_CMD_MAXPACKET_SIZE];
80 uint8_t g_req;
81 uint16_t g_len, g_rxlen;
82 __IO uint8_t g_tx_completed, g_rx_completed;
83 linecoding_type linecoding;
84}cdc_struct_type;
85
86
94extern usbd_class_handler cdc_class_handler;
95uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data);
96 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len);
97
110#ifdef __cplusplus
111}
112#endif
113
114#endif
115
116
117
error_status
error_status
error status
Definition: at32f413.h:264
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_OUT_MAXPACKET_SIZE
#define USBD_CDC_OUT_MAXPACKET_SIZE
Definition: cdc_class.h:61
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:340
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:370
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:69
cdc_struct_type
usb cdc class struct
Definition: cdc_class.h:76
cdc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_class.h:77
cdc_struct_type::g_req
uint8_t g_req
Definition: cdc_class.h:80
cdc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_class.h:83
cdc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_class.h:82
cdc_struct_type::g_len
uint16_t g_len
Definition: cdc_class.h:81
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_desc.c Source File

  • middlewares
  • usbd_class
  • cdc
cdc_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "cdc_desc.h"
30
44static usbd_desc_t *get_device_descriptor(void);
45static usbd_desc_t *get_device_qualifier(void);
46static usbd_desc_t *get_device_configuration(void);
47static usbd_desc_t *get_device_other_speed(void);
48static usbd_desc_t *get_device_lang_id(void);
49static usbd_desc_t *get_device_manufacturer_string(void);
50static usbd_desc_t *get_device_product_string(void);
51static usbd_desc_t *get_device_serial_string(void);
52static usbd_desc_t *get_device_interface_string(void);
53static usbd_desc_t *get_device_config_string(void);
54
55static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
56static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
57static void get_serial_num(void);
58static uint8_t g_usbd_desc_buffer[256];
59
63 usbd_desc_handler cdc_desc_handler =
64{
65 get_device_descriptor,
66 get_device_qualifier,
67 get_device_configuration,
68 get_device_other_speed,
69 get_device_lang_id,
70 get_device_manufacturer_string,
71 get_device_product_string,
72 get_device_serial_string,
73 get_device_interface_string,
74 get_device_config_string,
75};
76
80#if defined ( __ICCARM__ ) /* iar compiler */
81 #pragma data_alignment=4
82#endif
83ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
84{
85 USB_DEVICE_DESC_LEN, /* bLength */
86 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
87 0x00, /* bcdUSB */
88 0x02,
89 0x02, /* bDeviceClass */
90 0x00, /* bDeviceSubClass */
91 0x00, /* bDeviceProtocol */
92 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
93 LBYTE(USBD_CDC_VENDOR_ID), /* idVendor */
94 HBYTE(USBD_CDC_VENDOR_ID), /* idVendor */
95 LBYTE(USBD_CDC_PRODUCT_ID), /* idProduct */
96 HBYTE(USBD_CDC_PRODUCT_ID), /* idProduct */
97 0x00, /* bcdDevice rel. 2.00 */
98 0x02,
99 USB_MFC_STRING, /* Index of manufacturer string */
100 USB_PRODUCT_STRING, /* Index of product string */
101 USB_SERIAL_STRING, /* Index of serial number string */
102 1 /* bNumConfigurations */
103};
104
108#if defined ( __ICCARM__ ) /* iar compiler */
109 #pragma data_alignment=4
110#endif
111ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_CDC_CONFIG_DESC_SIZE] ALIGNED_TAIL =
112{
113 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
114 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
115 LBYTE(USBD_CDC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 HBYTE(USBD_CDC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 0x02, /* bNumInterfaces: 2 interface */
118 0x01, /* bConfigurationValue: configuration value */
119 0x00, /* iConfiguration: index of string descriptor describing
120 the configuration */
121 0xC0, /* bmAttributes: self powered */
122 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
123
124 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
125 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
126 0x00, /* bInterfaceNumber: number of interface */
127 0x00, /* bAlternateSetting: alternate set */
128 0x01, /* bNumEndpoints: number of endpoints */
129 USB_CLASS_CODE_CDC, /* bInterfaceClass: CDC class code */
130 0x02, /* bInterfaceSubClass: subclass code, Abstract Control Model*/
131 0x01, /* bInterfaceProtocol: protocol code, AT Command */
132 0x00, /* iInterface: index of string descriptor */
133
134 0x05, /* bFunctionLength: size of this descriptor in bytes */
135 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
136 USBD_CDC_SUBTYPE_HEADER, /* bDescriptorSubtype: Header function Descriptor 0x00*/
137 LBYTE(CDC_BCD_NUM),
138 HBYTE(CDC_BCD_NUM), /* bcdCDC: USB class definitions for communications */
139
140 0x05, /* bFunctionLength: size of this descriptor in bytes */
141 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
142 USBD_CDC_SUBTYPE_CMF, /* bDescriptorSubtype: Call Management function descriptor subtype 0x01 */
143 0x00, /* bmCapabilities: 0x00*/
144 0x01, /* bDataInterface: interface number of data class interface optionally used for call management */
145
146 0x04, /* bFunctionLength: size of this descriptor in bytes */
147 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
148 USBD_CDC_SUBTYPE_ACM, /* bDescriptorSubtype: Abstract Control Management functional descriptor subtype 0x02 */
149 0x02, /* bmCapabilities: Support Set_Line_Coding and Get_Line_Coding 0x02 */
150
151 0x05, /* bFunctionLength: size of this descriptor in bytes */
152 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
153 USBD_CDC_SUBTYPE_UFD, /* bDescriptorSubtype: Union Function Descriptor subtype 0x06 */
154 0x00, /* bControlInterface: The interface number of the communications or data class interface 0x00 */
155 0x01, /* bSubordinateInterface0: interface number of first subordinate interface in the union */
156
157 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
158 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
159 USBD_CDC_INT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
160 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
161 LBYTE(USBD_CDC_CMD_MAXPACKET_SIZE),
162 HBYTE(USBD_CDC_CMD_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
163 CDC_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
164
165
166 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
167 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
168 0x01, /* bInterfaceNumber: number of interface */
169 0x00, /* bAlternateSetting: alternate set */
170 0x02, /* bNumEndpoints: number of endpoints */
171 USB_CLASS_CODE_CDCDATA, /* bInterfaceClass: CDC-data class code */
172 0x00, /* bInterfaceSubClass: Data interface subclass code 0x00*/
173 0x00, /* bInterfaceProtocol: data class protocol code 0x00 */
174 0x00, /* iInterface: index of string descriptor */
175
176 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
177 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
178 USBD_CDC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
179 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
180 LBYTE(USBD_CDC_IN_MAXPACKET_SIZE),
181 HBYTE(USBD_CDC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
182 0x00, /* bInterval: interval for polling endpoint for data transfers */
183
184 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
185 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
186 USBD_CDC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
187 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
188 LBYTE(USBD_CDC_OUT_MAXPACKET_SIZE),
189 HBYTE(USBD_CDC_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
190 0x00, /* bInterval: interval for polling endpoint for data transfers */
191};
192
196#if defined ( __ICCARM__ ) /* iar compiler */
197 #pragma data_alignment=4
198#endif
199ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_CDC_SIZ_STRING_LANGID] ALIGNED_TAIL =
200{
201 USBD_CDC_SIZ_STRING_LANGID,
202 USB_DESCIPTOR_TYPE_STRING,
203 0x09,
204 0x04,
205};
206
210#if defined ( __ICCARM__ ) /* iar compiler */
211 #pragma data_alignment=4
212#endif
213ALIGNED_HEAD static uint8_t g_string_serial[USBD_CDC_SIZ_STRING_SERIAL] ALIGNED_TAIL =
214{
215 USBD_CDC_SIZ_STRING_SERIAL,
216 USB_DESCIPTOR_TYPE_STRING,
217};
218
219
220/* device descriptor */
221static usbd_desc_t device_descriptor =
222{
223 USB_DEVICE_DESC_LEN,
224 g_usbd_descriptor
225};
226
227/* config descriptor */
228static usbd_desc_t config_descriptor =
229{
230 USBD_CDC_CONFIG_DESC_SIZE,
231 g_usbd_configuration
232};
233
234/* langid descriptor */
235static usbd_desc_t langid_descriptor =
236{
237 USBD_CDC_SIZ_STRING_LANGID,
238 g_string_lang_id
239};
240
241/* serial descriptor */
242static usbd_desc_t serial_descriptor =
243{
244 USBD_CDC_SIZ_STRING_SERIAL,
245 g_string_serial
246};
247
248static usbd_desc_t vp_desc;
249
256static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
257{
258 uint16_t str_len = 0, id_pos = 2;
259 uint8_t *tmp_str = string;
260
261 while(*tmp_str != '\0')
262 {
263 str_len ++;
264 unicode_buf[id_pos ++] = *tmp_str ++;
265 unicode_buf[id_pos ++] = 0x00;
266 }
267
268 str_len = str_len * 2 + 2;
269 unicode_buf[0] = (uint8_t)str_len;
270 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
271
272 return str_len;
273}
274
282static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
283{
284 uint8_t idx = 0;
285
286 for( idx = 0 ; idx < len ; idx ++)
287 {
288 if( ((value >> 28)) < 0xA )
289 {
290 pbuf[ 2 * idx] = (value >> 28) + '0';
291 }
292 else
293 {
294 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
295 }
296
297 value = value << 4;
298
299 pbuf[2 * idx + 1] = 0;
300 }
301}
302
308static void get_serial_num(void)
309{
310 uint32_t serial0, serial1, serial2;
311
312 serial0 = *(uint32_t*)MCU_ID1;
313 serial1 = *(uint32_t*)MCU_ID2;
314 serial2 = *(uint32_t*)MCU_ID3;
315
316 serial0 += serial2;
317
318 if (serial0 != 0)
319 {
320 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
321 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
322 }
323}
324
330static usbd_desc_t *get_device_descriptor(void)
331{
332 return &device_descriptor;
333}
334
340static usbd_desc_t * get_device_qualifier(void)
341{
342 return NULL;
343}
344
350static usbd_desc_t *get_device_configuration(void)
351{
352 return &config_descriptor;
353}
354
360static usbd_desc_t *get_device_other_speed(void)
361{
362 return NULL;
363}
364
370static usbd_desc_t *get_device_lang_id(void)
371{
372 return &langid_descriptor;
373}
374
375
381static usbd_desc_t *get_device_manufacturer_string(void)
382{
383 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
384 vp_desc.descriptor = g_usbd_desc_buffer;
385 return &vp_desc;
386}
387
393static usbd_desc_t *get_device_product_string(void)
394{
395 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
396 vp_desc.descriptor = g_usbd_desc_buffer;
397 return &vp_desc;
398}
399
405static usbd_desc_t *get_device_serial_string(void)
406{
407 get_serial_num();
408 return &serial_descriptor;
409}
410
416static usbd_desc_t *get_device_interface_string(void)
417{
418 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
419 vp_desc.descriptor = g_usbd_desc_buffer;
420 return &vp_desc;
421}
422
428static usbd_desc_t *get_device_config_string(void)
429{
430 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
431 vp_desc.descriptor = g_usbd_desc_buffer;
432 return &vp_desc;
433}
434
cdc_desc.h
usb cdc descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:55
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:53
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:54
USBD_CDC_OUT_MAXPACKET_SIZE
#define USBD_CDC_OUT_MAXPACKET_SIZE
Definition: cdc_class.h:61
USBD_CDC_IN_MAXPACKET_SIZE
#define USBD_CDC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_class.h:60
CDC_BCD_NUM
#define CDC_BCD_NUM
usb bcd number define
Definition: cdc_desc.h:52
USBD_CDC_DESC_MANUFACTURER_STRING
#define USBD_CDC_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: cdc_desc.h:70
USBD_CDC_DESC_CONFIGURATION_STRING
#define USBD_CDC_DESC_CONFIGURATION_STRING
Definition: cdc_desc.h:72
USBD_CDC_SIZ_STRING_LANGID
#define USBD_CDC_SIZ_STRING_LANGID
Definition: cdc_desc.h:64
USBD_CDC_PRODUCT_ID
#define USBD_CDC_PRODUCT_ID
Definition: cdc_desc.h:58
USBD_CDC_DESC_PRODUCT_STRING
#define USBD_CDC_DESC_PRODUCT_STRING
Definition: cdc_desc.h:71
USBD_CDC_VENDOR_ID
#define USBD_CDC_VENDOR_ID
usb vendor id and product id define
Definition: cdc_desc.h:57
CDC_HID_BINTERVAL_TIME
#define CDC_HID_BINTERVAL_TIME
usb endpoint interval define
Definition: cdc_desc.h:78
USBD_CDC_CONFIG_DESC_SIZE
#define USBD_CDC_CONFIG_DESC_SIZE
usb descriptor size define
Definition: cdc_desc.h:63
USBD_CDC_SIZ_STRING_SERIAL
#define USBD_CDC_SIZ_STRING_SERIAL
Definition: cdc_desc.h:65
USBD_CDC_DESC_INTERFACE_STRING
#define USBD_CDC_DESC_INTERFACE_STRING
Definition: cdc_desc.h:73
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: cdc_desc.c:242
device_descriptor
static usbd_desc_t device_descriptor
Definition: cdc_desc.c:221
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_desc.c:350
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: cdc_desc.c:235
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_desc.c:330
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_desc.c:381
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_desc.c:340
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_desc.c:416
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: cdc_desc.c:58
vp_desc
static usbd_desc_t vp_desc
Definition: cdc_desc.c:248
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_desc.c:360
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: cdc_desc.c:83
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_desc.c:393
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:63
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_desc.c:428
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: cdc_desc.c:256
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_desc.c:370
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: cdc_desc.c:308
config_descriptor
static usbd_desc_t config_descriptor
Definition: cdc_desc.c:228
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_desc.c:405
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: cdc_desc.c:282
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USBD_CDC_SUBTYPE_CMF
#define USBD_CDC_SUBTYPE_CMF
Definition: usb_std.h:199
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USBD_CDC_SUBTYPE_HEADER
#define USBD_CDC_SUBTYPE_HEADER
usb cdc class sub-type define
Definition: usb_std.h:198
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USBD_CDC_CS_INTERFACE
#define USBD_CDC_CS_INTERFACE
usb cdc class descriptor define
Definition: usb_std.h:192
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_CLASS_CODE_CDCDATA
#define USB_CLASS_CODE_CDCDATA
Definition: usb_std.h:167
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_CDC
#define USB_CLASS_CODE_CDC
Definition: usb_std.h:162
USBD_CDC_SUBTYPE_UFD
#define USBD_CDC_SUBTYPE_UFD
Definition: usb_std.h:201
USBD_CDC_SUBTYPE_ACM
#define USBD_CDC_SUBTYPE_ACM
Definition: usb_std.h:200
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: cdc_desc.h Source File

  • middlewares
  • usbd_class
  • cdc
cdc_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_DESC_H
29#define __CDC_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "cdc_class.h"
36#include "usbd_core.h"
37
52#define CDC_BCD_NUM 0x0110
53
57#define USBD_CDC_VENDOR_ID 0x2E3C
58#define USBD_CDC_PRODUCT_ID 0x5740
59
63#define USBD_CDC_CONFIG_DESC_SIZE 67
64#define USBD_CDC_SIZ_STRING_LANGID 4
65#define USBD_CDC_SIZ_STRING_SERIAL 0x1A
66
70#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
71#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Virtual Com Port "
72#define USBD_CDC_DESC_CONFIGURATION_STRING "Virtual ComPort Config"
73#define USBD_CDC_DESC_INTERFACE_STRING "Virtual ComPort Interface"
74
78#define CDC_HID_BINTERVAL_TIME 0xFF
79
83#define MCU_ID1 (0x1FFFF7E8)
84#define MCU_ID2 (0x1FFFF7EC)
85#define MCU_ID3 (0x1FFFF7F0)
90extern usbd_desc_handler cdc_desc_handler;
91
92
100#ifdef __cplusplus
101}
102#endif
103
104#endif
cdc_class.h
usb cdc class file
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:63
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_keyboard_class.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "cdc_keyboard_class.h"
28#include "cdc_keyboard_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup);
53static usb_sts_type keyboard_class_setup_handler(void *udev, usb_setup_type *setup);
54
55static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len);
56
57 vcp_keyboard_type vcp_keyboard_struct;
58
59#define SHIFT 0x80
60const static unsigned char _asciimap[128] =
61{
62 0x00,// NUL
63 0x00,// SOH
64 0x00,// STX
65 0x00,// ETX
66 0x00,// EOT
67 0x00,// ENQ
68 0x00,// ACK
69 0x00,// BEL
70 0x2A,// BS Backspace
71 0x2B,// TAB Tab
72 0x28,// LF Enter
73 0x00,// VT
74 0x00,// FF
75 0x00,// CR
76 0x00,// SO
77 0x00,// SI
78 0x00,// DEL
79 0x00,// DC1
80 0x00,// DC2
81 0x00,// DC3
82 0x00,// DC4
83 0x00,// NAK
84 0x00,// SYN
85 0x00,// ETB
86 0x00,// CAN
87 0x00,// EM
88 0x00,// SUB
89 0x00,// ESC
90 0x00,// FS
91 0x00,// GS
92 0x00,// RS
93 0x00,// US
94
95 0x2C,// ' '
96 0x1E|SHIFT,// !
97 0x34|SHIFT,// "
98 0x20|SHIFT,// #
99 0x21|SHIFT,// $
100 0x22|SHIFT,// %
101 0x24|SHIFT,// &
102 0x34, // '
103 0x26|SHIFT,// (
104 0x27|SHIFT,// )
105 0x25|SHIFT,// *
106 0x2E|SHIFT,// +
107 0x36,// ,
108 0x2D,// -
109 0x37,// .
110 0x38,// /
111 0x27,// 0
112 0x1E,// 1
113 0x1F,// 2
114 0x20,// 3
115 0x21,// 4
116 0x22,// 5
117 0x23,// 6
118 0x24,// 7
119 0x25,// 8
120 0x26,// 9
121 0x33|SHIFT,// :
122 0x33, // ;
123 0x36|SHIFT,// <
124 0x2E, // =
125 0x37|SHIFT,// >
126 0x38|SHIFT,// ?
127 0x1F|SHIFT,// @
128 0x04|SHIFT,// A
129 0x05|SHIFT,// B
130 0x06|SHIFT,// C
131 0x07|SHIFT,// D
132 0x08|SHIFT,// E
133 0x09|SHIFT,// F
134 0x0A|SHIFT,// G
135 0x0B|SHIFT,// H
136 0x0C|SHIFT,// I
137 0x0D|SHIFT,// J
138 0x0E|SHIFT,// K
139 0x0F|SHIFT,// L
140 0x10|SHIFT,// M
141 0x11|SHIFT,// N
142 0x12|SHIFT,// O
143 0x13|SHIFT,// P
144 0x14|SHIFT,// Q
145 0x15|SHIFT,// R
146 0x16|SHIFT,// S
147 0x17|SHIFT,// T
148 0x18|SHIFT,// U
149 0x19|SHIFT,// V
150 0x1A|SHIFT,// W
151 0x1B|SHIFT,// X
152 0x1C|SHIFT,// Y
153 0x1D|SHIFT,// Z
154 0x2F, // [
155 0x31, // bslash
156 0x30, // ]
157 0x23|SHIFT,// ^
158 0x2D|SHIFT,// _
159 0x35, // `
160 0x04, // a
161 0x05, // b
162 0x06, // c
163 0x07, // d
164 0x08, // e
165 0x09, // f
166 0x0A, // g
167 0x0B, // h
168 0x0C, // i
169 0x0D, // j
170 0x0E, // k
171 0x0F, // l
172 0x10, // m
173 0x11, // n
174 0x12, // o
175 0x13, // p
176 0x14, // q
177 0x15, // r
178 0x16, // s
179 0x17, // t
180 0x18, // u
181 0x19, // v
182 0x1A, // w
183 0x1B, // x
184 0x1C, // y
185 0x1D, // z
186 0x2f|SHIFT,//
187 0x31|SHIFT,// |
188 0x30|SHIFT,// }
189 0x35|SHIFT,// ~
190 0 // DEL
191};
192
193 linecoding_type linecoding_vcpkybrd =
194{
195 115200,
196 0x00,
197 0x00,
198 0x08
199};
200
201/* static variable */
202
203
204/* usb device class handler */
205 usbd_class_handler cdc_keyboard_class_handler =
206{
207 class_init_handler,
208 class_clear_handler,
209 class_setup_handler,
210 class_ept0_tx_handler,
211 class_ept0_rx_handler,
212 class_in_handler,
213 class_out_handler,
214 class_sof_handler,
215 class_event_handler,
216 &vcp_keyboard_struct
217};
218
224static usb_sts_type class_init_handler(void *udev)
225{
226 usb_sts_type status = USB_OK;
227 usbd_core_type *pudev = (usbd_core_type *)udev;
228 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
229#ifndef USB_EPT_AUTO_MALLOC_BUFFER
230 /* use user define buffer address */
231 usbd_ept_buf_custom_define(pudev, USBD_VCPKYBRD_CDC_INT_EPT, EPT2_TX_ADDR);
232 usbd_ept_buf_custom_define(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT, EPT1_TX_ADDR);
233 usbd_ept_buf_custom_define(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, EPT1_RX_ADDR);
234 usbd_ept_buf_custom_define(pudev, USBD_VCPKYBRD_HID_IN_EPT, EPT3_TX_ADDR);
235#endif
236
237 /* open in endpoint */
238 usbd_ept_open(pudev, USBD_VCPKYBRD_CDC_INT_EPT, EPT_INT_TYPE, USBD_VCPKYBRD_CMD_MAXPACKET_SIZE);
239
240 /* open in endpoint */
241 usbd_ept_open(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_VCPKYBRD_IN_MAXPACKET_SIZE);
242
243 /* open out endpoint */
244 usbd_ept_open(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_VCPKYBRD_OUT_MAXPACKET_SIZE);
245
246 /* open hid in endpoint */
247 usbd_ept_open(pudev, USBD_VCPKYBRD_HID_IN_EPT, EPT_INT_TYPE, USBD_VCPKYBRD_IN_MAXPACKET_SIZE);
248
249 /* set out endpoint to receive status */
250 usbd_ept_recv(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, vcpkybrd->g_rx_buff, USBD_VCPKYBRD_OUT_MAXPACKET_SIZE);
251
252 vcpkybrd->g_tx_completed = 1;
253 vcpkybrd->g_keyboard_tx_completed = 1;
254
255 vcpkybrd->linecoding.bitrate = linecoding_vcpkybrd.bitrate;
256 vcpkybrd->linecoding.data = linecoding_vcpkybrd.data;
257 vcpkybrd->linecoding.format = linecoding_vcpkybrd.format;
258 vcpkybrd->linecoding.parity = linecoding_vcpkybrd.parity;
259 return status;
260}
261
267static usb_sts_type class_clear_handler(void *udev)
268{
269 usb_sts_type status = USB_OK;
270 usbd_core_type *pudev = (usbd_core_type *)udev;
271
272 /* close in endpoint */
273 usbd_ept_close(pudev, USBD_VCPKYBRD_CDC_INT_EPT);
274
275 /* close in endpoint */
276 usbd_ept_close(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT);
277
278 /* close out endpoint */
279 usbd_ept_close(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT);
280
281 /* close in endpoint */
282 usbd_ept_close(pudev, USBD_VCPKYBRD_HID_IN_EPT);
283
284 return status;
285}
286
293static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
294{
295 usb_sts_type status = USB_OK;
296 usbd_core_type *pudev = (usbd_core_type *)udev;
297 switch(setup->bmRequestType & USB_REQ_RECIPIENT_MASK)
298 {
299 case USB_REQ_RECIPIENT_INTERFACE:
300 if(setup->wIndex == VCPKYBRD_KEYBOARD_INTERFACE)
301 {
302 keyboard_class_setup_handler(pudev, setup);
303 }
304 else
305 {
306 cdc_class_setup_handler(pudev, setup);
307 }
308 break;
309 case USB_REQ_RECIPIENT_ENDPOINT:
310 break;
311
312 }
313 return status;
314}
315
322static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
323{
324 usb_sts_type status = USB_OK;
325 usbd_core_type *pudev = (usbd_core_type *)udev;
326 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
327
328 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
329 {
330 /* class request */
331 case USB_REQ_TYPE_CLASS:
332 if(setup->wLength)
333 {
334 if(setup->bmRequestType & USB_REQ_DIR_DTH)
335 {
336 usb_vcp_cmd_process(udev, setup->bRequest, vcpkybrd->g_cmd, setup->wLength);
337 usbd_ctrl_send(pudev, vcpkybrd->g_cmd, setup->wLength);
338 }
339 else
340 {
341 vcpkybrd->g_req = setup->bRequest;
342 vcpkybrd->g_len = setup->wLength;
343 usbd_ctrl_recv(pudev, vcpkybrd->g_cmd, vcpkybrd->g_len);
344
345 }
346 }
347 break;
348 /* standard request */
349 case USB_REQ_TYPE_STANDARD:
350 switch(setup->bRequest)
351 {
352 case USB_STD_REQ_GET_DESCRIPTOR:
353 usbd_ctrl_unsupport(pudev);
354 break;
355 case USB_STD_REQ_GET_INTERFACE:
356 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->alt_setting, 1);
357 break;
358 case USB_STD_REQ_SET_INTERFACE:
359 vcpkybrd->alt_setting = setup->wValue;
360 break;
361 default:
362 break;
363 }
364 break;
365 default:
366 usbd_ctrl_unsupport(pudev);
367 break;
368 }
369 return status;
370}
371
378static usb_sts_type keyboard_class_setup_handler(void *udev, usb_setup_type *setup)
379{
380 usb_sts_type status = USB_OK;
381 usbd_core_type *pudev = (usbd_core_type *)udev;
382 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
383 uint16_t len;
384 uint8_t *buf;
385
386 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
387 {
388 /* class request */
389 case USB_REQ_TYPE_CLASS:
390 switch(setup->bRequest)
391 {
392 case HID_REQ_SET_PROTOCOL:
393 vcpkybrd->hid_protocol = (uint8_t)setup->wValue;
394 break;
395 case HID_REQ_GET_PROTOCOL:
396 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->hid_protocol, 1);
397 break;
398 case HID_REQ_SET_IDLE:
399 vcpkybrd->hid_set_idle = (uint8_t)(setup->wValue >> 8);
400 break;
401 case HID_REQ_GET_IDLE:
402 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->hid_set_idle, 1);
403 break;
404 case HID_REQ_SET_REPORT:
405 vcpkybrd->hid_state = HID_REQ_SET_REPORT;
406 usbd_ctrl_recv(pudev, vcpkybrd->hid_set_report, setup->wLength);
407 break;
408 default:
409 usbd_ctrl_unsupport(pudev);
410 break;
411 }
412 break;
413 /* standard request */
414 case USB_REQ_TYPE_STANDARD:
415 switch(setup->bRequest)
416 {
417 case USB_STD_REQ_GET_DESCRIPTOR:
418 if(setup->wValue >> 8 == HID_REPORT_DESC)
419 {
420 len = MIN(USBD_VCPKYBRD_HID_SIZ_REPORT_DESC, setup->wLength);
421 buf = (uint8_t *)g_usbd_vcpkybrd_hid_report;
422 }
423 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
424 {
425 len = MIN(9, setup->wLength);
426 buf = (uint8_t *)g_vcpkybrd_hid_usb_desc;
427 }
428 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
429 break;
430 case USB_STD_REQ_GET_INTERFACE:
431 usbd_ctrl_send(pudev, (uint8_t *)&vcpkybrd->alt_setting, 1);
432 break;
433 case USB_STD_REQ_SET_INTERFACE:
434 vcpkybrd->alt_setting = setup->wValue;
435 break;
436 default:
437 break;
438 }
439 break;
440 default:
441 usbd_ctrl_unsupport(pudev);
442 break;
443 }
444 return status;
445}
446
452static usb_sts_type class_ept0_tx_handler(void *udev)
453{
454 usb_sts_type status = USB_OK;
455
456 /* ...user code... */
457
458 return status;
459}
460
466static usb_sts_type class_ept0_rx_handler(void *udev)
467{
468 usb_sts_type status = USB_OK;
469 usbd_core_type *pudev = (usbd_core_type *)udev;
470 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
471 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
472 /* ...user code... */
473 if( vcpkybrd->g_req == SET_LINE_CODING)
474 {
475 /* class process */
476 usb_vcp_cmd_process(udev, vcpkybrd->g_req, vcpkybrd->g_cmd, recv_len);
477 }
478
479 if( vcpkybrd->hid_state == HID_REQ_SET_REPORT)
480 {
481 /* hid buffer process */
482 vcpkybrd->hid_state = 0;
483 }
484 return status;
485}
486
493static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
494{
495 usb_sts_type status = USB_OK;
496 usbd_core_type *pudev = (usbd_core_type *)udev;
497 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
498
499 /* ...user code...
500 trans next packet data
501 */
502 if((ept_num & 0x7F) == (USBD_VCPKYBRD_CDC_BULK_IN_EPT & 0x7F))
503 {
504 vcpkybrd->g_tx_completed = 1;
505 }
506 if((ept_num & 0x7F) == (USBD_VCPKYBRD_HID_IN_EPT & 0x7F))
507 {
508 vcpkybrd->g_keyboard_tx_completed = 1;
509 }
510
511
512 return status;
513}
514
521static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
522{
523 usb_sts_type status = USB_OK;
524 usbd_core_type *pudev = (usbd_core_type *)udev;
525 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
526
527 /* get endpoint receive data length */
528 vcpkybrd->g_rxlen = usbd_get_recv_len(pudev, ept_num);
529
530 /*set recv flag*/
531 vcpkybrd->g_rx_completed = 1;
532
533 return status;
534}
535
541static usb_sts_type class_sof_handler(void *udev)
542{
543 usb_sts_type status = USB_OK;
544
545 /* ...user code... */
546
547 return status;
548}
549
556static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
557{
558 usb_sts_type status = USB_OK;
559 switch(event)
560 {
561 case USBD_RESET_EVENT:
562
563 /* ...user code... */
564
565 break;
566 case USBD_SUSPEND_EVENT:
567
568 /* ...user code... */
569
570 break;
571 case USBD_WAKEUP_EVENT:
572 /* ...user code... */
573
574 break;
575 default:
576 break;
577 }
578 return status;
579}
580
587uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
588{
589 uint16_t i_index = 0;
590 usbd_core_type *pudev = (usbd_core_type *)udev;
591 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
592 uint16_t tmp_len = 0;
593
594 if(vcpkybrd->g_rx_completed == 0)
595 {
596 return 0;
597 }
598 vcpkybrd->g_rx_completed = 0;
599
600 tmp_len = vcpkybrd->g_rxlen;
601 for(i_index = 0; i_index < vcpkybrd->g_rxlen; i_index ++)
602 {
603 recv_data[i_index] = vcpkybrd->g_rx_buff[i_index];
604 }
605
606 usbd_ept_recv(pudev, USBD_VCPKYBRD_CDC_BULK_OUT_EPT, vcpkybrd->g_rx_buff, USBD_VCPKYBRD_OUT_MAXPACKET_SIZE);
607
608 return tmp_len;
609}
610
618 error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
619{
620 error_status status = SUCCESS;
621 usbd_core_type *pudev = (usbd_core_type *)udev;
622 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
623 if(vcpkybrd->g_tx_completed)
624 {
625 vcpkybrd->g_tx_completed = 0;
626 usbd_ept_send(pudev, USBD_VCPKYBRD_CDC_BULK_IN_EPT, send_data, len);
627 }
628 else
629 {
630 status = ERROR;
631 }
632 return status;
633}
634
635
644static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
645{
646 usbd_core_type *pudev = (usbd_core_type *)udev;
647 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
648 switch(cmd)
649 {
650 case SET_LINE_CODING:
651 vcpkybrd->linecoding.bitrate = (uint32_t)(buff[0] | (buff[1] << 8) | (buff[2] << 16) | (buff[3] <<24));
652 vcpkybrd->linecoding.format = buff[4];
653 vcpkybrd->linecoding.parity = buff[5];
654 vcpkybrd->linecoding.data = buff[6];
655 break;
656
657 case GET_LINE_CODING:
658 buff[0] = (uint8_t)vcpkybrd->linecoding.bitrate;
659 buff[1] = (uint8_t)(vcpkybrd->linecoding.bitrate >> 8);
660 buff[2] = (uint8_t)(vcpkybrd->linecoding.bitrate >> 16);
661 buff[3] = (uint8_t)(vcpkybrd->linecoding.bitrate >> 24);
662 buff[4] = (uint8_t)(vcpkybrd->linecoding.format);
663 buff[5] = (uint8_t)(vcpkybrd->linecoding.parity);
664 buff[6] = (uint8_t)(vcpkybrd->linecoding.data);
665 break;
666
667 default:
668 break;
669 }
670}
671
679 usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len)
680{
681 usb_sts_type status = USB_OK;
682 usbd_core_type *pudev = (usbd_core_type *)udev;
683
684 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
685 usbd_ept_send(pudev, USBD_VCPKYBRD_HID_IN_EPT, report, len);
686
687 return status;
688}
689
690
697void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
698{
699 uint8_t key_data = 0;
700 static uint8_t temp = 0;
701 static uint8_t keyboard_buf[8] = {0, 0, 6, 0, 0, 0, 0, 0};
702
703 if(ascii_code > 128)
704 {
705 ascii_code = 0;
706 }
707 else
708 {
709 ascii_code = _asciimap[ascii_code];
710 if(!ascii_code)
711 {
712 ascii_code = 0;
713 }
714
715 if(ascii_code & SHIFT)
716 {
717 key_data = 0x2;
718 ascii_code &= 0x7F;
719 }
720 }
721
722 if((temp == ascii_code) && (ascii_code != 0))
723 {
724 keyboard_buf[0] = 0;
725 keyboard_buf[2] = 0;
726 usb_vcpkybrd_class_send_report(udev, keyboard_buf, 8);
727 }
728 else
729 {
730 keyboard_buf[0] = key_data;
731 keyboard_buf[2] = ascii_code;
732 usb_vcpkybrd_class_send_report(udev, keyboard_buf, 8);
733 }
734}
735
cdc_keyboard_class.h
usb cdc and keyboard class file
cdc_keyboard_desc.h
usb cdc and keyboard descriptor header file
EPT3_TX_ADDR
#define EPT3_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:83
EPT1_RX_ADDR
#define EPT1_RX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:78
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:77
EPT2_TX_ADDR
#define EPT2_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:80
USB_EPT_AUTO_MALLOC_BUFFER
#define USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer
Definition: project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h:63
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:63
USBD_VCPKYBRD_HID_IN_EPT
#define USBD_VCPKYBRD_HID_IN_EPT
Definition: cdc_keyboard_class.h:56
USBD_VCPKYBRD_IN_MAXPACKET_SIZE
#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE
usb in and out max packet size define
Definition: cdc_keyboard_class.h:61
USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:62
USBD_VCPKYBRD_CDC_INT_EPT
#define USBD_VCPKYBRD_CDC_INT_EPT
usb use endpoint define
Definition: cdc_keyboard_class.h:53
USBD_VCPKYBRD_CDC_BULK_IN_EPT
#define USBD_VCPKYBRD_CDC_BULK_IN_EPT
Definition: cdc_keyboard_class.h:54
USBD_VCPKYBRD_CDC_BULK_OUT_EPT
#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT
Definition: cdc_keyboard_class.h:55
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: cdc_keyboard_class.c:541
usb_vcpkybrd_vcp_send_data
error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_keyboard_class.c:618
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: cdc_keyboard_class.c:493
usb_vcpkybrd_keyboard_send_char
void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
usb keyoard send char
Definition: cdc_keyboard_class.c:697
usb_vcpkybrd_class_send_report
usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: cdc_keyboard_class.c:679
_asciimap
static const unsigned char _asciimap[128]
Definition: cdc_keyboard_class.c:60
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_keyboard_class.c:267
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:293
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: cdc_keyboard_class.c:452
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: cdc_keyboard_class.c:466
cdc_keyboard_class_handler
usbd_class_handler cdc_keyboard_class_handler
Definition: cdc_keyboard_class.c:205
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: cdc_keyboard_class.c:556
usb_vcp_cmd_process
static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device class request function
Definition: cdc_keyboard_class.c:644
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: cdc_keyboard_class.c:224
cdc_class_setup_handler
static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:322
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: cdc_keyboard_class.c:521
SHIFT
#define SHIFT
Definition: cdc_keyboard_class.c:59
usb_vcpkybrd_vcp_get_rxdata
uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_keyboard_class.c:587
vcp_keyboard_struct
vcp_keyboard_type vcp_keyboard_struct
Definition: cdc_keyboard_class.c:57
keyboard_class_setup_handler
static usb_sts_type keyboard_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_keyboard_class.c:378
linecoding_vcpkybrd
linecoding_type linecoding_vcpkybrd
Definition: cdc_keyboard_class.c:193
VCPKYBRD_KEYBOARD_INTERFACE
#define VCPKYBRD_KEYBOARD_INTERFACE
Definition: cdc_keyboard_desc.h:88
USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
Definition: cdc_keyboard_desc.h:66
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:263
g_vcpkybrd_hid_usb_desc
uint8_t g_vcpkybrd_hid_usb_desc[9]
usb hid descriptor
Definition: cdc_keyboard_desc.c:244
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:204
GET_LINE_CODING
#define GET_LINE_CODING
Definition: cdc_msc_class.h:107
SET_LINE_CODING
#define SET_LINE_CODING
Definition: cdc_msc_class.h:106
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
USB_REQ_DIR_DTH
#define USB_REQ_DIR_DTH
Definition: usb_std.h:72
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:58
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:56
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:55
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:461
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:214
linecoding_type::data
uint8_t data
Definition: usb_std.h:217
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:216
linecoding_type::format
uint8_t format
Definition: usb_std.h:215
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
vcp_keyboard_type
Definition: cdc_keyboard_class.h:75
vcp_keyboard_type::g_cmd
uint8_t g_cmd[0x08]
Definition: cdc_keyboard_class.h:82
vcp_keyboard_type::g_len
uint16_t g_len
Definition: cdc_keyboard_class.h:85
vcp_keyboard_type::hid_state
uint8_t hid_state
Definition: cdc_keyboard_class.h:84
vcp_keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: cdc_keyboard_class.h:78
vcp_keyboard_type::alt_setting
uint32_t alt_setting
Definition: cdc_keyboard_class.h:76
vcp_keyboard_type::g_keyboard_tx_completed
__IO uint8_t g_keyboard_tx_completed
Definition: cdc_keyboard_class.h:88
vcp_keyboard_type::g_rxlen
uint16_t g_rxlen
Definition: cdc_keyboard_class.h:85
vcp_keyboard_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_keyboard_class.h:86
vcp_keyboard_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: cdc_keyboard_class.h:81
vcp_keyboard_type::g_req
uint8_t g_req
Definition: cdc_keyboard_class.h:83
vcp_keyboard_type::hid_set_report
uint8_t hid_set_report[64]
Definition: cdc_keyboard_class.h:80
vcp_keyboard_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_keyboard_class.h:87
vcp_keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: cdc_keyboard_class.h:77
vcp_keyboard_type::linecoding
linecoding_type linecoding
Definition: cdc_keyboard_class.h:90
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_keyboard_class.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_KEYBOARD_CLASS_H
29#define __CDC_KEYBOARD_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_VCPKYBRD_CDC_INT_EPT 0x82
54#define USBD_VCPKYBRD_CDC_BULK_IN_EPT 0x81
55#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT 0x01
56#define USBD_VCPKYBRD_HID_IN_EPT 0x83
57
61#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE 0x40
62#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE 0x40
63#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE 0x08
64
65
74typedef struct
75{
76 uint32_t alt_setting;
77 uint32_t hid_protocol;
78 uint32_t hid_set_idle;
79
80 uint8_t hid_set_report[64];
81 uint8_t g_rx_buff[USBD_VCPKYBRD_OUT_MAXPACKET_SIZE];
82 uint8_t g_cmd[USBD_VCPKYBRD_CMD_MAXPACKET_SIZE];
83 uint8_t g_req;
84 uint8_t hid_state;
85 uint16_t g_len, g_rxlen;
86 __IO uint8_t g_tx_completed;
87 __IO uint8_t g_rx_completed;
88 __IO uint8_t g_keyboard_tx_completed;
89
90 linecoding_type linecoding;
91}vcp_keyboard_type;
92
100extern usbd_class_handler cdc_keyboard_class_handler;
101uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data);
102 error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len);
103 usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len);
104void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code);
105
117#ifdef __cplusplus
118}
119#endif
120
121#endif
122
123
124
125
error_status
error_status
error status
Definition: at32f413.h:264
usb_vcpkybrd_vcp_send_data
error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_keyboard_class.c:618
usb_vcpkybrd_keyboard_send_char
void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
usb keyoard send char
Definition: cdc_keyboard_class.c:697
usb_vcpkybrd_class_send_report
usb_sts_type usb_vcpkybrd_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: cdc_keyboard_class.c:679
cdc_keyboard_class_handler
usbd_class_handler cdc_keyboard_class_handler
Definition: cdc_keyboard_class.c:205
usb_vcpkybrd_vcp_get_rxdata
uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_keyboard_class.c:587
USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:63
USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:62
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
vcp_keyboard_type
Definition: cdc_keyboard_class.h:75
vcp_keyboard_type::g_len
uint16_t g_len
Definition: cdc_keyboard_class.h:85
vcp_keyboard_type::hid_state
uint8_t hid_state
Definition: cdc_keyboard_class.h:84
vcp_keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: cdc_keyboard_class.h:78
vcp_keyboard_type::alt_setting
uint32_t alt_setting
Definition: cdc_keyboard_class.h:76
vcp_keyboard_type::g_keyboard_tx_completed
__IO uint8_t g_keyboard_tx_completed
Definition: cdc_keyboard_class.h:88
vcp_keyboard_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_keyboard_class.h:86
vcp_keyboard_type::g_req
uint8_t g_req
Definition: cdc_keyboard_class.h:83
vcp_keyboard_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_keyboard_class.h:87
vcp_keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: cdc_keyboard_class.h:77
vcp_keyboard_type::linecoding
linecoding_type linecoding
Definition: cdc_keyboard_class.h:90
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_keyboard_desc.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "cdc_keyboard_desc.h"
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57static uint8_t g_usbd_desc_buffer[256];
58
62 usbd_desc_handler cdc_keyboard_desc_handler =
63{
64 get_device_descriptor,
65 get_device_qualifier,
66 get_device_configuration,
67 get_device_other_speed,
68 get_device_lang_id,
69 get_device_manufacturer_string,
70 get_device_product_string,
71 get_device_serial_string,
72 get_device_interface_string,
73 get_device_config_string,
74};
75
79#if defined ( __ICCARM__ ) /* iar compiler */
80 #pragma data_alignment=4
81#endif
82ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
83{
84 USB_DEVICE_DESC_LEN, /* bLength */
85 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
86 0x00, /* bcdUSB */
87 0x02,
88 0xEF, /* bDeviceClass */
89 0x02, /* bDeviceSubClass */
90 0x01, /* bDeviceProtocol */
91 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
92 LBYTE(USBD_VCPKYBRD_VENDOR_ID), /* idVendor */
93 HBYTE(USBD_VCPKYBRD_VENDOR_ID), /* idVendor */
94 LBYTE(USBD_VCPKYBRD_PRODUCT_ID), /* idProduct */
95 HBYTE(USBD_VCPKYBRD_PRODUCT_ID), /* idProduct */
96 0x00, /* bcdDevice rel. 2.00 */
97 0x02,
98 USB_MFC_STRING, /* Index of manufacturer string */
99 USB_PRODUCT_STRING, /* Index of product string */
100 USB_SERIAL_STRING, /* Index of serial number string */
101 1 /* bNumConfigurations */
102};
103
107#if defined ( __ICCARM__ ) /* iar compiler */
108 #pragma data_alignment=4
109#endif
110ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_VCPKYBRD_CONFIG_DESC_SIZE] ALIGNED_TAIL =
111{
112 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
113 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
114 LBYTE(USBD_VCPKYBRD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
115 HBYTE(USBD_VCPKYBRD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 0x03, /* bNumInterfaces: 2 interface */
117 0x01, /* bConfigurationValue: configuration value */
118 0x00, /* iConfiguration: index of string descriptor describing
119 the configuration */
120 0xC0, /* bmAttributes: self powered */
121 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
122
123 0x08, /* bLength */
124 0x0B, /* bDescriptorType */
125 0x00, /* bFirstInterface */
126 0x02, /* bInterfaceCount */
127 0x02, /* bFunctionClass */
128 0x02, /* bFunctionSubClass */
129 0x01, /* bFunctionProtocol */
130 0x00, /* iFunction (Index of string descriptor describing this function) */
131
132 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
133 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
134 VCPKYBRD_CDC_INTERFACE, /* bInterfaceNumber: number of interface */
135 0x00, /* bAlternateSetting: alternate set */
136 0x01, /* bNumEndpoints: number of endpoints */
137 USB_CLASS_CODE_CDC, /* bInterfaceClass: CDC class code */
138 0x02, /* bInterfaceSubClass: subclass code, Abstract Control Model*/
139 0x01, /* bInterfaceProtocol: protocol code, AT Command */
140 0x00, /* iInterface: index of string descriptor */
141
142 0x05, /* bFunctionLength: size of this descriptor in bytes */
143 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
144 USBD_CDC_SUBTYPE_HEADER, /* bDescriptorSubtype: Header function Descriptor 0x00*/
145 LBYTE(VCPKYBRD_BCD_NUM),
146 HBYTE(VCPKYBRD_BCD_NUM), /* bcdCDC: USB class definitions for communications */
147
148 0x05, /* bFunctionLength: size of this descriptor in bytes */
149 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
150 USBD_CDC_SUBTYPE_CMF, /* bDescriptorSubtype: Call Management function descriptor subtype 0x01 */
151 0x00, /* bmCapabilities: 0x00*/
152 0x01, /* bDataInterface: interface number of data class interface optionally used for call management */
153
154 0x04, /* bFunctionLength: size of this descriptor in bytes */
155 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
156 USBD_CDC_SUBTYPE_ACM, /* bDescriptorSubtype: Abstract Control Management functional descriptor subtype 0x02 */
157 0x02, /* bmCapabilities: Support Set_Line_Coding and Get_Line_Coding 0x02 */
158
159 0x05, /* bFunctionLength: size of this descriptor in bytes */
160 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
161 USBD_CDC_SUBTYPE_UFD, /* bDescriptorSubtype: Union Function Descriptor subtype 0x06 */
162 0x00, /* bControlInterface: The interface number of the communications or data class interface 0x00 */
163 0x01, /* bSubordinateInterface0: interface number of first subordinate interface in the union */
164
165 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
166 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
167 USBD_VCPKYBRD_CDC_INT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
168 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
169 LBYTE(USBD_VCPKYBRD_CMD_MAXPACKET_SIZE),
170 HBYTE(USBD_VCPKYBRD_CMD_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
171 VCPKYBRD_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
172
173
174 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
175 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
176 VCPKYBRD_CDC_DATA_INTERFACE, /* bInterfaceNumber: number of interface */
177 0x00, /* bAlternateSetting: alternate set */
178 0x02, /* bNumEndpoints: number of endpoints */
179 USB_CLASS_CODE_CDCDATA, /* bInterfaceClass: CDC-data class code */
180 0x00, /* bInterfaceSubClass: Data interface subclass code 0x00*/
181 0x00, /* bInterfaceProtocol: data class protocol code 0x00 */
182 0x00, /* iInterface: index of string descriptor */
183
184 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
185 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
186 USBD_VCPKYBRD_CDC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
187 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
188 LBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE),
189 HBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
190 0x00, /* bInterval: interval for polling endpoint for data transfers */
191
192 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
193 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
194 USBD_VCPKYBRD_CDC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
195 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
196 LBYTE(USBD_VCPKYBRD_OUT_MAXPACKET_SIZE),
197 HBYTE(USBD_VCPKYBRD_OUT_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
198 0x00, /* bInterval: interval for polling endpoint for data transfers */
199
200 0x08, /* bLength */
201 0x0B, /* bDescriptorType */
202 0x02, /* bFirstInterface */
203 0x01, /* bInterfaceCount */
204 0x03, /* bFunctionClass */
205 0x00, /* bFunctionSubClass */
206 0x01, /* bFunctionProtocol */
207 0x00, /* iFunction (Index of string descriptor describing this function) */
208
209 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
210 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
211 VCPKYBRD_KEYBOARD_INTERFACE, /* bInterfaceNumber: number of interface */
212 0x00, /* bAlternateSetting: alternate set */
213 0x01, /* bNumEndpoints: number of endpoints */
214 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
215 0x01, /* bInterfaceSubClass: subclass code */
216 0x01, /* bInterfaceProtocol: protocol code */
217 0x00, /* iInterface: index of string descriptor */
218
219 0x09, /* bLength: size of HID descriptor in bytes */
220 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
221 LBYTE(VCPKYBRD_BCD_NUM),
222 HBYTE(VCPKYBRD_BCD_NUM), /* bcdHID: HID class specification release number */
223 0x00, /* bCountryCode: hardware target conutry */
224 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
225 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
226 LBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
227 HBYTE(sizeof(g_usbd_vcpkybrd_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
228
229 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
230 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
231 USBD_VCPKYBRD_HID_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
232 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
233 LBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE),
234 HBYTE(USBD_VCPKYBRD_IN_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
235 VCPKYBRD_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
236};
237
241#if defined ( __ICCARM__ ) /* iar compiler */
242 #pragma data_alignment=4
243#endif
244ALIGNED_HEAD uint8_t g_vcpkybrd_hid_usb_desc[9] ALIGNED_TAIL =
245{
246 0x09, /* bLength: size of HID descriptor in bytes */
247 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
248 LBYTE(VCPKYBRD_BCD_NUM),
249 HBYTE(VCPKYBRD_BCD_NUM), /* bcdHID: HID class specification release number */
250 0x00, /* bCountryCode: hardware target conutry */
251 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
252 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
253 LBYTE(sizeof(g_usbd_vcpkybrd_hid_report)),
254 HBYTE(sizeof(g_usbd_vcpkybrd_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
255};
256
260#if defined ( __ICCARM__ ) /* iar compiler */
261 #pragma data_alignment=4
262#endif
263ALIGNED_HEAD uint8_t g_usbd_vcpkybrd_hid_report[USBD_VCPKYBRD_HID_SIZ_REPORT_DESC] ALIGNED_TAIL =
264{
265 0x05, 0x01, // USAGE_PAGE (Generic Desktop)
266 0x09, 0x06, // USAGE (Keyboard)
267 0xa1, 0x01, // COLLECTION (Application)
268 0x05, 0x07, // USAGE_PAGE (Keyboard)
269 0x19, 0xe0, // USAGE_MINIMUM (Keyboard LeftControl)
270 0x29, 0xe7, // USAGE_MAXIMUM (Keyboard Right GUI)
271 0x15, 0x00, // LOGICAL_MINIMUM (0)
272 0x25, 0x01, // LOGICAL_MAXIMUM (1)
273 0x75, 0x01, // REPORT_SIZE (1)
274 0x95, 0x08, // REPORT_COUNT (8)
275 0x81, 0x02, // INPUT (Data,Var,Abs)
276 0x95, 0x01, // REPORT_COUNT (1)
277 0x75, 0x08, // REPORT_SIZE (8)
278 0x81, 0x03, // INPUT (Cnst,Var,Abs)
279 0x95, 0x05, // REPORT_COUNT (5)
280 0x75, 0x01, // REPORT_SIZE (1)
281 0x05, 0x08, // USAGE_PAGE (LEDs)
282 0x19, 0x01, // USAGE_MINIMUM (Num Lock)
283 0x29, 0x05, // USAGE_MAXIMUM (Kana)
284 0x91, 0x02, // OUTPUT (Data,Var,Abs)
285 0x95, 0x01, // REPORT_COUNT (1)
286 0x75, 0x03, // REPORT_SIZE (3)
287 0x91, 0x03, // OUTPUT (Cnst,Var,Abs)
288 0x95, 0x06, // REPORT_COUNT (6)
289 0x75, 0x08, // REPORT_SIZE (8)
290 0x15, 0x00, // LOGICAL_MINIMUM (0)
291 0x25, 0xFF, // LOGICAL_MAXIMUM (255)
292 0x05, 0x07, // USAGE_PAGE (Keyboard)
293 0x19, 0x00, // USAGE_MINIMUM (Reserved (no event indicated))
294 0x29, 0x65, // USAGE_MAXIMUM (Keyboard Application)
295 0x81, 0x00, // INPUT (Data,Ary,Abs)
296 0xc0 // END_COLLECTION
297};
301#if defined ( __ICCARM__ ) /* iar compiler */
302 #pragma data_alignment=4
303#endif
304ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_VCPKYBRD_SIZ_STRING_LANGID] ALIGNED_TAIL =
305{
306 USBD_VCPKYBRD_SIZ_STRING_LANGID,
307 USB_DESCIPTOR_TYPE_STRING,
308 0x09,
309 0x04,
310};
311
315#if defined ( __ICCARM__ ) /* iar compiler */
316 #pragma data_alignment=4
317#endif
318ALIGNED_HEAD static uint8_t g_string_serial[USBD_VCPKYBRD_SIZ_STRING_SERIAL] ALIGNED_TAIL =
319{
320 USBD_VCPKYBRD_SIZ_STRING_SERIAL,
321 USB_DESCIPTOR_TYPE_STRING,
322};
323
324
325/* device descriptor */
326static usbd_desc_t device_descriptor =
327{
328 USB_DEVICE_DESC_LEN,
329 g_usbd_descriptor
330};
331
332/* config descriptor */
333static usbd_desc_t config_descriptor =
334{
335 USBD_VCPKYBRD_CONFIG_DESC_SIZE,
336 g_usbd_configuration
337};
338
339/* langid descriptor */
340static usbd_desc_t langid_descriptor =
341{
342 USBD_VCPKYBRD_SIZ_STRING_LANGID,
343 g_string_lang_id
344};
345
346/* serial descriptor */
347static usbd_desc_t serial_descriptor =
348{
349 USBD_VCPKYBRD_SIZ_STRING_SERIAL,
350 g_string_serial
351};
352
353static usbd_desc_t vp_desc;
354
361static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
362{
363 uint16_t str_len = 0, id_pos = 2;
364 uint8_t *tmp_str = string;
365
366 while(*tmp_str != '\0')
367 {
368 str_len ++;
369 unicode_buf[id_pos ++] = *tmp_str ++;
370 unicode_buf[id_pos ++] = 0x00;
371 }
372
373 str_len = str_len * 2 + 2;
374 unicode_buf[0] = str_len;
375 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
376
377 return str_len;
378}
379
387static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
388{
389 uint8_t idx = 0;
390
391 for( idx = 0 ; idx < len ; idx ++)
392 {
393 if( ((value >> 28)) < 0xA )
394 {
395 pbuf[ 2 * idx] = (value >> 28) + '0';
396 }
397 else
398 {
399 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
400 }
401
402 value = value << 4;
403
404 pbuf[2 * idx + 1] = 0;
405 }
406}
407
413static void get_serial_num(void)
414{
415 uint32_t serial0, serial1, serial2;
416
417 serial0 = *(uint32_t*)MCU_ID1;
418 serial1 = *(uint32_t*)MCU_ID2;
419 serial2 = *(uint32_t*)MCU_ID3;
420
421 serial0 += serial2;
422
423 if (serial0 != 0)
424 {
425 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
426 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
427 }
428}
429
435static usbd_desc_t *get_device_descriptor(void)
436{
437 return &device_descriptor;
438}
439
445static usbd_desc_t * get_device_qualifier(void)
446{
447 return NULL;
448}
449
455static usbd_desc_t *get_device_configuration(void)
456{
457 return &config_descriptor;
458}
459
465static usbd_desc_t *get_device_other_speed(void)
466{
467 return NULL;
468}
469
475static usbd_desc_t *get_device_lang_id(void)
476{
477 return &langid_descriptor;
478}
479
480
486static usbd_desc_t *get_device_manufacturer_string(void)
487{
488 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
489 vp_desc.descriptor = g_usbd_desc_buffer;
490 return &vp_desc;
491}
492
498static usbd_desc_t *get_device_product_string(void)
499{
500 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
501 vp_desc.descriptor = g_usbd_desc_buffer;
502 return &vp_desc;
503}
504
510static usbd_desc_t *get_device_serial_string(void)
511{
512 get_serial_num();
513 return &serial_descriptor;
514}
515
521static usbd_desc_t *get_device_interface_string(void)
522{
523 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
524 vp_desc.descriptor = g_usbd_desc_buffer;
525 return &vp_desc;
526}
527
533static usbd_desc_t *get_device_config_string(void)
534{
535 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_VCPKYBRD_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
536 vp_desc.descriptor = g_usbd_desc_buffer;
537 return &vp_desc;
538}
539
cdc_keyboard_desc.h
usb cdc and keyboard descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
#define USBD_VCPKYBRD_CMD_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:63
USBD_VCPKYBRD_HID_IN_EPT
#define USBD_VCPKYBRD_HID_IN_EPT
Definition: cdc_keyboard_class.h:56
USBD_VCPKYBRD_IN_MAXPACKET_SIZE
#define USBD_VCPKYBRD_IN_MAXPACKET_SIZE
usb in and out max packet size define
Definition: cdc_keyboard_class.h:61
USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
#define USBD_VCPKYBRD_OUT_MAXPACKET_SIZE
Definition: cdc_keyboard_class.h:62
USBD_VCPKYBRD_CDC_INT_EPT
#define USBD_VCPKYBRD_CDC_INT_EPT
usb use endpoint define
Definition: cdc_keyboard_class.h:53
USBD_VCPKYBRD_CDC_BULK_IN_EPT
#define USBD_VCPKYBRD_CDC_BULK_IN_EPT
Definition: cdc_keyboard_class.h:54
USBD_VCPKYBRD_CDC_BULK_OUT_EPT
#define USBD_VCPKYBRD_CDC_BULK_OUT_EPT
Definition: cdc_keyboard_class.h:55
USBD_VCPKYBRD_DESC_INTERFACE_STRING
#define USBD_VCPKYBRD_DESC_INTERFACE_STRING
Definition: cdc_keyboard_desc.h:76
VCPKYBRD_CDC_INTERFACE
#define VCPKYBRD_CDC_INTERFACE
usb interface define
Definition: cdc_keyboard_desc.h:86
VCPKYBRD_KEYBOARD_INTERFACE
#define VCPKYBRD_KEYBOARD_INTERFACE
Definition: cdc_keyboard_desc.h:88
USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
Definition: cdc_keyboard_desc.h:66
USBD_VCPKYBRD_DESC_MANUFACTURER_STRING
#define USBD_VCPKYBRD_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: cdc_keyboard_desc.h:73
USBD_VCPKYBRD_PRODUCT_ID
#define USBD_VCPKYBRD_PRODUCT_ID
Definition: cdc_keyboard_desc.h:59
VCPKYBRD_BCD_NUM
#define VCPKYBRD_BCD_NUM
usb bcd number define
Definition: cdc_keyboard_desc.h:53
VCPKYBRD_CDC_DATA_INTERFACE
#define VCPKYBRD_CDC_DATA_INTERFACE
Definition: cdc_keyboard_desc.h:87
USBD_VCPKYBRD_DESC_CONFIGURATION_STRING
#define USBD_VCPKYBRD_DESC_CONFIGURATION_STRING
Definition: cdc_keyboard_desc.h:75
USBD_VCPKYBRD_CONFIG_DESC_SIZE
#define USBD_VCPKYBRD_CONFIG_DESC_SIZE
usb descriptor size define
Definition: cdc_keyboard_desc.h:65
VCPKYBRD_HID_BINTERVAL_TIME
#define VCPKYBRD_HID_BINTERVAL_TIME
usb endpoint interval define
Definition: cdc_keyboard_desc.h:81
USBD_VCPKYBRD_SIZ_STRING_SERIAL
#define USBD_VCPKYBRD_SIZ_STRING_SERIAL
Definition: cdc_keyboard_desc.h:68
USBD_VCPKYBRD_VENDOR_ID
#define USBD_VCPKYBRD_VENDOR_ID
usb vendor id and product id define
Definition: cdc_keyboard_desc.h:58
USBD_VCPKYBRD_SIZ_STRING_LANGID
#define USBD_VCPKYBRD_SIZ_STRING_LANGID
Definition: cdc_keyboard_desc.h:67
USBD_VCPKYBRD_DESC_PRODUCT_STRING
#define USBD_VCPKYBRD_DESC_PRODUCT_STRING
Definition: cdc_keyboard_desc.h:74
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: cdc_keyboard_desc.c:347
device_descriptor
static usbd_desc_t device_descriptor
Definition: cdc_keyboard_desc.c:326
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_keyboard_desc.c:455
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: cdc_keyboard_desc.c:340
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_keyboard_desc.c:435
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_keyboard_desc.c:486
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_keyboard_desc.c:445
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_keyboard_desc.c:521
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: cdc_keyboard_desc.c:57
vp_desc
static usbd_desc_t vp_desc
Definition: cdc_keyboard_desc.c:353
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:263
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_keyboard_desc.c:465
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: cdc_keyboard_desc.c:82
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_keyboard_desc.c:498
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_keyboard_desc.c:533
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: cdc_keyboard_desc.c:361
cdc_keyboard_desc_handler
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure
Definition: cdc_keyboard_desc.c:62
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_keyboard_desc.c:475
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: cdc_keyboard_desc.c:413
g_vcpkybrd_hid_usb_desc
uint8_t g_vcpkybrd_hid_usb_desc[9]
usb hid descriptor
Definition: cdc_keyboard_desc.c:244
config_descriptor
static usbd_desc_t config_descriptor
Definition: cdc_keyboard_desc.c:333
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_keyboard_desc.c:510
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: cdc_keyboard_desc.c:387
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USBD_CDC_SUBTYPE_CMF
#define USBD_CDC_SUBTYPE_CMF
Definition: usb_std.h:199
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USBD_CDC_SUBTYPE_HEADER
#define USBD_CDC_SUBTYPE_HEADER
usb cdc class sub-type define
Definition: usb_std.h:198
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USBD_CDC_CS_INTERFACE
#define USBD_CDC_CS_INTERFACE
usb cdc class descriptor define
Definition: usb_std.h:192
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_CLASS_CODE_CDCDATA
#define USB_CLASS_CODE_CDCDATA
Definition: usb_std.h:167
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_CDC
#define USB_CLASS_CODE_CDC
Definition: usb_std.h:162
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
USBD_CDC_SUBTYPE_UFD
#define USBD_CDC_SUBTYPE_UFD
Definition: usb_std.h:201
USBD_CDC_SUBTYPE_ACM
#define USBD_CDC_SUBTYPE_ACM
Definition: usb_std.h:200
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: cdc_keyboard_desc.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
cdc_keyboard_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_KEYBOARD_DESC_H
29#define __CDC_KEYBOARD_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "cdc_keyboard_class.h"
36#include "usbd_core.h"
37
53#define VCPKYBRD_BCD_NUM 0x0110
54
58#define USBD_VCPKYBRD_VENDOR_ID 0x2E3C
59#define USBD_VCPKYBRD_PRODUCT_ID 0x5750
60
61
65#define USBD_VCPKYBRD_CONFIG_DESC_SIZE 108
66#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC 63
67#define USBD_VCPKYBRD_SIZ_STRING_LANGID 4
68#define USBD_VCPKYBRD_SIZ_STRING_SERIAL 0x1A
69
73#define USBD_VCPKYBRD_DESC_MANUFACTURER_STRING "Artery"
74#define USBD_VCPKYBRD_DESC_PRODUCT_STRING "AT32 Composite VCP and Keyboard"
75#define USBD_VCPKYBRD_DESC_CONFIGURATION_STRING "Composite VCP and Keyboard Config"
76#define USBD_VCPKYBRD_DESC_INTERFACE_STRING "Composite VCP and Keyboard Interface"
77
81#define VCPKYBRD_HID_BINTERVAL_TIME 0x0A
82
86#define VCPKYBRD_CDC_INTERFACE 0x00
87#define VCPKYBRD_CDC_DATA_INTERFACE 0x01
88#define VCPKYBRD_KEYBOARD_INTERFACE 0x02
89
93#define MCU_ID1 (0x1FFFF7E8)
94#define MCU_ID2 (0x1FFFF7EC)
95#define MCU_ID3 (0x1FFFF7F0)
96
100extern uint8_t g_usbd_vcpkybrd_hid_report[USBD_VCPKYBRD_HID_SIZ_REPORT_DESC];
101extern uint8_t g_vcpkybrd_hid_usb_desc[9];
102extern usbd_desc_handler cdc_keyboard_desc_handler;
103
104
112#ifdef __cplusplus
113}
114#endif
115
116#endif
cdc_keyboard_class.h
usb cdc and keyboard class file
USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
#define USBD_VCPKYBRD_HID_SIZ_REPORT_DESC
Definition: cdc_keyboard_desc.h:66
g_usbd_vcpkybrd_hid_report
uint8_t g_usbd_vcpkybrd_hid_report[63]
usb hid keyboard report descriptor
Definition: cdc_keyboard_desc.c:263
g_vcpkybrd_hid_usb_desc
uint8_t g_vcpkybrd_hid_usb_desc[9]
usb hid descriptor
Definition: cdc_keyboard_desc.c:244
cdc_keyboard_desc_handler
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure
Definition: cdc_keyboard_desc.c:62
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_msc_class.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "cdc_msc_class.h"
28#include "cdc_msc_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53static usb_sts_type cdc_struct_init(cdc_msc_struct_type *pcdc);
54extern void usb_usart_config( linecoding_type linecoding);
55static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len);
56
57static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup);
58static usb_sts_type msc_class_setup_handler(void *udev, usb_setup_type *setup);
59
60 linecoding_type linecoding =
61{
62 115200,
63 0,
64 0,
65 8
66};
67
68/* cdc data struct */
69 cdc_msc_struct_type cdc_msc_struct;
70
71/* usb device class handler */
72 usbd_class_handler cdc_msc_class_handler =
73{
74 class_init_handler,
75 class_clear_handler,
76 class_setup_handler,
77 class_ept0_tx_handler,
78 class_ept0_rx_handler,
79 class_in_handler,
80 class_out_handler,
81 class_sof_handler,
82 class_event_handler,
83 &cdc_msc_struct //cdc_struct
84};
90static usb_sts_type class_init_handler(void *udev)
91{
92 usb_sts_type status = USB_OK;
93 usbd_core_type *pudev = (usbd_core_type *)udev;
94 cdc_msc_struct_type *pcdcmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
95
96 /* init cdc struct */
97 cdc_struct_init(pcdcmsc);
98
99 /* open in endpoint */
100 usbd_ept_open(pudev, USBD_CDC_INT_EPT, EPT_INT_TYPE, USBD_CDC_CMD_MAXPACKET_SIZE);
101
102 /* open in endpoint */
103 usbd_ept_open(pudev, USBD_CDC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_IN_MAXPACKET_SIZE);
104
105 /* open out endpoint */
106 usbd_ept_open(pudev, USBD_CDC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
107
108 /* set out endpoint to receive status */
109 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdcmsc->g_rx_buff, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
110
111 /* open in endpoint */
112 usbd_ept_open(pudev, USBD_MSC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_IN_MAXPACKET_SIZE);
113
114 /* open out endpoint */
115 usbd_ept_open(pudev, USBD_MSC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
116
117 bot_scsi_init(udev);
118
119 return status;
120}
121
127static usb_sts_type class_clear_handler(void *udev)
128{
129 usb_sts_type status = USB_OK;
130 usbd_core_type *pudev = (usbd_core_type *)udev;
131
132 /* close in endpoint */
133 usbd_ept_close(pudev, USBD_CDC_INT_EPT);
134
135 /* close in endpoint */
136 usbd_ept_close(pudev, USBD_CDC_BULK_IN_EPT);
137
138 /* close out endpoint */
139 usbd_ept_close(pudev, USBD_CDC_BULK_OUT_EPT);
140
141 /* close in endpoint */
142 usbd_ept_close(pudev, USBD_MSC_BULK_IN_EPT);
143
144 /* close out endpoint */
145 usbd_ept_close(pudev, USBD_MSC_BULK_OUT_EPT);
146
147 return status;
148}
149
156static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
157{
158 usb_sts_type status = USB_OK;
159 usbd_core_type *pudev = (usbd_core_type *)udev;
160 switch(setup->bmRequestType & USB_REQ_RECIPIENT_MASK)
161 {
162 case USB_REQ_RECIPIENT_INTERFACE:
163 if(setup->wIndex == VCPMSC_MSC_INTERFACE)
164 {
165 msc_class_setup_handler(udev, setup);
166 }
167 else
168 {
169 cdc_class_setup_handler(pudev, setup);
170 }
171 break;
172 case USB_REQ_RECIPIENT_ENDPOINT:
173 if(setup->wIndex == (USBD_MSC_BULK_IN_EPT | USBD_MSC_BULK_OUT_EPT))
174 {
175 msc_class_setup_handler(udev, setup);
176 }
177 else
178 {
179 cdc_class_setup_handler(pudev, setup);
180 }
181 break;
182
183 }
184 return status;
185}
186
193static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
194{
195 usb_sts_type status = USB_OK;
196 usbd_core_type *pudev = (usbd_core_type *)udev;
197 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
198
199 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
200 {
201 /* class request */
202 case USB_REQ_TYPE_CLASS:
203 if(setup->wLength)
204 {
205 if(setup->bmRequestType & USB_REQ_DIR_DTH)
206 {
207 usb_vcp_cmd_process(udev, setup->bRequest, pcdc->g_cmd, setup->wLength);
208 usbd_ctrl_send(pudev, pcdc->g_cmd, setup->wLength);
209 }
210 else
211 {
212 pcdc->g_req = setup->bRequest;
213 pcdc->g_len = setup->wLength;
214 usbd_ctrl_recv(pudev, pcdc->g_cmd, pcdc->g_len);
215
216 }
217 }
218 break;
219 /* standard request */
220 case USB_REQ_TYPE_STANDARD:
221 switch(setup->bRequest)
222 {
223 case USB_STD_REQ_GET_DESCRIPTOR:
224 usbd_ctrl_unsupport(pudev);
225 break;
226 case USB_STD_REQ_GET_INTERFACE:
227 usbd_ctrl_send(pudev, (uint8_t *)&pcdc->alt_setting, 1);
228 break;
229 case USB_STD_REQ_SET_INTERFACE:
230 pcdc->alt_setting = setup->wValue;
231 break;
232 default:
233 break;
234 }
235 break;
236 default:
237 usbd_ctrl_unsupport(pudev);
238 break;
239 }
240 return status;
241}
242
249static usb_sts_type msc_class_setup_handler(void *udev, usb_setup_type *setup)
250{
251 usb_sts_type status = USB_OK;
252 usbd_core_type *pudev = (usbd_core_type *)udev;
253 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
254 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
255 {
256 /* class request */
257 case USB_REQ_TYPE_CLASS:
258
259 switch(setup->bRequest)
260 {
261 case MSC_REQ_GET_MAX_LUN:
262 usbd_ctrl_send(pudev, (uint8_t *)&cdc_msc_struct.max_lun, 1);
263 break;
264 case MSC_REQ_BO_RESET:
265 bot_scsi_reset(udev);
266 usbd_ctrl_send_status(pudev);
267 break;
268 default:
269 usbd_ctrl_unsupport(pudev);
270 break;
271
272 }
273 break;
274 /* standard request */
275 case USB_REQ_TYPE_STANDARD:
276
277 switch(setup->bRequest)
278 {
279 case USB_STD_REQ_GET_DESCRIPTOR:
280 usbd_ctrl_unsupport(pudev);
281 break;
282 case USB_STD_REQ_GET_INTERFACE:
283 usbd_ctrl_send(pudev, (uint8_t *)&pmsc->alt_setting, 1);
284 break;
285 case USB_STD_REQ_SET_INTERFACE:
286 pmsc->alt_setting = setup->wValue;
287 break;
288 case USB_STD_REQ_CLEAR_FEATURE:
289 usbd_ept_close(pudev, (uint8_t)setup->wIndex);
290
291 if((setup->wIndex & 0x80) == 0x80)
292 {
293 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_CDC_MSC_IN_MAXPACKET_SIZE);
294 }
295 else
296 {
297 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
298 }
299 bot_scsi_clear_feature(udev, setup->wIndex);
300 break;
301 default:
302 break;
303 }
304 break;
305 default:
306 usbd_ctrl_unsupport(pudev);
307 break;
308 }
309 return status;
310}
311
317static usb_sts_type class_ept0_tx_handler(void *udev)
318{
319 usb_sts_type status = USB_OK;
320
321 /* ...user code... */
322
323 return status;
324}
325
331static usb_sts_type class_ept0_rx_handler(void *udev)
332{
333 usb_sts_type status = USB_OK;
334 usbd_core_type *pudev = (usbd_core_type *)udev;
335 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
336 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
337 /* ...user code... */
338 if( pcdc->g_req == SET_LINE_CODING)
339 {
340 /* class process */
341 usb_vcp_cmd_process(udev, pcdc->g_req, pcdc->g_cmd, recv_len);
342 }
343
344 return status;
345}
346
353static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
354{
355 usbd_core_type *pudev = (usbd_core_type *)udev;
356 cdc_msc_struct_type *pcdcmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
357 usb_sts_type status = USB_OK;
358
359 /* ...user code...
360 trans next packet data
361 */
362
363 if((ept_num & 0x7F) == (USBD_CDC_BULK_IN_EPT & 0x7F))
364 {
365 pcdcmsc->g_tx_completed = 1;
366 }
367 if((ept_num & 0x7F) == (USBD_MSC_BULK_IN_EPT & 0x7F))
368 {
369 bot_scsi_datain_handler(udev, ept_num);
370 }
371
372 return status;
373}
374
381static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
382{
383 usb_sts_type status = USB_OK;
384 usbd_core_type *pudev = (usbd_core_type *)udev;
385 cdc_msc_struct_type *pcdcmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
386
387
388
389 if((ept_num & 0x7F) == (USBD_CDC_BULK_OUT_EPT & 0x7F))
390 {
391 /* get endpoint receive data length */
392 pcdcmsc->g_rxlen = usbd_get_recv_len(pudev, ept_num);
393
394 /*set recv flag*/
395 pcdcmsc->g_rx_completed = 1;
396 }
397 if((ept_num & 0x7F) == (USBD_MSC_BULK_OUT_EPT & 0x7F))
398 {
399 bot_scsi_dataout_handler(udev, ept_num);
400 }
401
402 return status;
403}
404
410static usb_sts_type class_sof_handler(void *udev)
411{
412 usb_sts_type status = USB_OK;
413
414 /* ...user code... */
415
416 return status;
417}
418
425static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
426{
427 usb_sts_type status = USB_OK;
428 switch(event)
429 {
430 case USBD_RESET_EVENT:
431
432 /* ...user code... */
433
434 break;
435 case USBD_SUSPEND_EVENT:
436
437 /* ...user code... */
438
439 break;
440 case USBD_WAKEUP_EVENT:
441 /* ...user code... */
442
443 break;
444 default:
445 break;
446 }
447 return status;
448}
449
455static usb_sts_type cdc_struct_init(cdc_msc_struct_type *pcdc)
456{
457 pcdc->g_tx_completed = 1;
458 pcdc->g_rx_completed = 0;
459 pcdc->alt_setting = 0;
460 pcdc->linecoding.bitrate = linecoding.bitrate;
461 pcdc->linecoding.data = linecoding.data;
462 pcdc->linecoding.format = linecoding.format;
463 pcdc->linecoding.parity = linecoding.parity;
464 return USB_OK;
465}
466
473uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
474{
475 uint16_t i_index = 0;
476 uint16_t tmp_len = 0;
477 usbd_core_type *pudev = (usbd_core_type *)udev;
478 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
479
480 if(pcdc->g_rx_completed == 0)
481 {
482 return 0;
483 }
484 pcdc->g_rx_completed = 0;
485 tmp_len = pcdc->g_rxlen;
486 for(i_index = 0; i_index < pcdc->g_rxlen; i_index ++)
487 {
488 recv_data[i_index] = pcdc->g_rx_buff[i_index];
489 }
490
491 usbd_ept_recv(pudev, USBD_CDC_BULK_OUT_EPT, pcdc->g_rx_buff, USBD_CDC_MSC_OUT_MAXPACKET_SIZE);
492
493 return tmp_len;
494}
495
503 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
504{
505 error_status status = SUCCESS;
506 usbd_core_type *pudev = (usbd_core_type *)udev;
507 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
508 if(pcdc->g_tx_completed)
509 {
510 pcdc->g_tx_completed = 0;
511 usbd_ept_send(pudev, USBD_CDC_BULK_IN_EPT, send_data, len);
512 }
513 else
514 {
515 status = ERROR;
516 }
517 return status;
518}
519
528static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
529{
530 usbd_core_type *pudev = (usbd_core_type *)udev;
531 cdc_msc_struct_type *pcdc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
532 switch(cmd)
533 {
534 case SET_LINE_CODING:
535 pcdc->linecoding.bitrate = (uint32_t)(buff[0] | (buff[1] << 8) | (buff[2] << 16) | (buff[3] <<24));
536 pcdc->linecoding.format = buff[4];
537 pcdc->linecoding.parity = buff[5];
538 pcdc->linecoding.data = buff[6];
539#ifdef USB_VIRTUAL_COMPORT
540 /* set hardware usart */
541 usb_usart_config(pcdc->linecoding);
542#endif
543 break;
544
545 case GET_LINE_CODING:
546 buff[0] = (uint8_t)pcdc->linecoding.bitrate;
547 buff[1] = (uint8_t)(pcdc->linecoding.bitrate >> 8);
548 buff[2] = (uint8_t)(pcdc->linecoding.bitrate >> 16);
549 buff[3] = (uint8_t)(pcdc->linecoding.bitrate >> 24);
550 buff[4] = (uint8_t)(pcdc->linecoding.format);
551 buff[5] = (uint8_t)(pcdc->linecoding.parity);
552 buff[6] = (uint8_t)(pcdc->linecoding.data);
553 break;
554
555 default:
556 break;
557 }
558}
559
cdc_msc_class.h
usb cdc class file
cdc_msc_desc.h
usb cdc descriptor header file
cdc_msc_struct_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: cdc_msc_class.h:260
cdc_msc_struct_type::g_req
uint8_t g_req
Definition: cdc_msc_class.h:258
cdc_msc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:255
cdc_msc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_msc_class.h:261
cdc_msc_struct_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: cdc_msc_class.h:256
cdc_msc_struct_type::g_len
uint16_t g_len
Definition: cdc_msc_class.h:259
cdc_msc_struct_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:266
cdc_msc_struct_type::g_cmd
uint8_t g_cmd[0x08]
Definition: cdc_msc_class.h:257
cdc_msc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_msc_class.h:260
cdc_msc_struct_type::g_rxlen
uint16_t g_rxlen
Definition: cdc_msc_class.h:259
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_MSC_OUT_MAXPACKET_SIZE
#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE
Definition: cdc_msc_class.h:65
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:55
USBD_CDC_MSC_IN_MAXPACKET_SIZE
#define USBD_CDC_MSC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_msc_class.h:63
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:53
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:54
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
VCPMSC_MSC_INTERFACE
#define VCPMSC_MSC_INTERFACE
usb interface define
Definition: cdc_msc_desc.h:84
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:145
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:127
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:104
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:174
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:731
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: cdc_msc_class.c:410
cdc_msc_struct
cdc_msc_struct_type cdc_msc_struct
Definition: cdc_msc_class.c:69
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: cdc_msc_class.c:353
cdc_struct_init
static usb_sts_type cdc_struct_init(cdc_msc_struct_type *pcdc)
usb device cdc init
Definition: cdc_msc_class.c:455
msc_class_setup_handler
static usb_sts_type msc_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:249
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: cdc_msc_class.c:127
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:156
usb_usart_config
void usb_usart_config(linecoding_type linecoding)
this function handles usart2 and linecoding config.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:299
linecoding
linecoding_type linecoding
Definition: cdc_msc_class.c:60
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: cdc_msc_class.c:317
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_msc_class.c:473
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: cdc_msc_class.c:331
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: cdc_msc_class.c:425
usb_vcp_cmd_process
static void usb_vcp_cmd_process(void *udev, uint8_t cmd, uint8_t *buff, uint16_t len)
usb device function
Definition: cdc_msc_class.c:528
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_msc_class.c:503
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: cdc_msc_class.c:90
cdc_class_setup_handler
static usb_sts_type cdc_class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: cdc_msc_class.c:193
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: cdc_msc_class.c:381
cdc_msc_class_handler
usbd_class_handler cdc_msc_class_handler
Definition: cdc_msc_class.c:72
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:204
MSC_REQ_BO_RESET
#define MSC_REQ_BO_RESET
Definition: cdc_msc_class.h:104
GET_LINE_CODING
#define GET_LINE_CODING
Definition: cdc_msc_class.h:107
SET_LINE_CODING
#define SET_LINE_CODING
Definition: cdc_msc_class.h:106
MSC_REQ_GET_MAX_LUN
#define MSC_REQ_GET_MAX_LUN
Definition: cdc_msc_class.h:103
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:78
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
USB_REQ_DIR_DTH
#define USB_REQ_DIR_DTH
Definition: usb_std.h:72
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:58
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:56
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:55
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:211
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
cdc_msc_struct_type
usb cdc class struct
Definition: cdc_msc_class.h:253
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:214
linecoding_type::data
uint8_t data
Definition: usb_std.h:217
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:216
linecoding_type::format
uint8_t format
Definition: usb_std.h:215
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_msc_class.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_MSC_CLASS_H
29#define __CDC_MSC_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_CDC_INT_EPT 0x82
54#define USBD_CDC_BULK_IN_EPT 0x83
55#define USBD_CDC_BULK_OUT_EPT 0x02
56
57#define USBD_MSC_BULK_IN_EPT 0x81
58#define USBD_MSC_BULK_OUT_EPT 0x01
59
63#define USBD_CDC_MSC_IN_MAXPACKET_SIZE 0x40
64
65#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE 0x40
66#define USBD_CDC_CMD_MAXPACKET_SIZE 0x08
67
68
69
70
83#define MSC_SUPPORT_MAX_LUN 1
84#define MSC_MAX_DATA_BUF_LEN 4096
85
86#define MSC_CMD_FORMAT_UNIT 0x04
87#define MSC_CMD_INQUIRY 0x12
88#define MSC_CMD_START_STOP 0x1B
89#define MSC_CMD_MODE_SENSE6 0x1A
90#define MSC_CMD_MODE_SENSE10 0x5A
91#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
92#define MSC_CMD_READ_10 0x28
93#define MSC_CMD_READ_12 0xA8
94#define MSC_CMD_READ_CAPACITY 0x25
95#define MSC_CMD_READ_FORMAT_CAPACITY 0x23
96#define MSC_CMD_REQUEST_SENSE 0x03
97#define MSC_CMD_TEST_UNIT 0x00
98#define MSC_CMD_VERIFY 0x2F
99#define MSC_CMD_WRITE_10 0x2A
100#define MSC_CMD_WRITE_12 0xAA
101#define MSC_CMD_WRITE_VERIFY 0x2E
102
103#define MSC_REQ_GET_MAX_LUN 0xFE
104#define MSC_REQ_BO_RESET 0xFF
106#define SET_LINE_CODING 0x20
107#define GET_LINE_CODING 0x21
108
109#define CBW_CMD_LENGTH 31
110#define CBW_DCBWSIGNATURE 0x43425355
111#define CBW_BMCBWFLAGS_DIR_OUT 0x00
112#define CBW_BMCBWFLAGS_DIR_IN 0x80
113
114#define CSW_CMD_LENGTH 13
115#define CSW_DCSWSIGNATURE 0x53425355
116#define CSW_BCSWSTATUS_PASS 0x00
117#define CSW_BCSWSTATUS_FAILED 0x01
118#define CSW_BCSWSTATUS_PHASE_ERR 0x02
119
120#define MSC_STATE_MACHINE_CMD 0x00
121#define MSC_STATE_MACHINE_DATA_IN 0x01
122#define MSC_STATE_MACHINE_DATA_OUT 0x02
123#define MSC_STATE_MACHINE_SEND_DATA 0x03
124#define MSC_STATE_MACHINE_LAST_DATA 0x04
125#define MSC_STATE_MACHINE_STATUS 0x05
126#define MSC_STATE_MACHINE_FAILED 0x06
127#define MSC_STATE_MACHINE_IDLE 0x07
128
129#define MSC_BOT_STATE_IDLE 0x00
130#define MSC_BOT_STATE_RECOVERY 0x01
131#define MSC_BOT_STATE_ERROR 0x02
132
133#define REQ_SENSE_STANDARD_DATA_LEN 0x12
134#define SENSE_KEY_NO_SENSE 0x00
135#define SENSE_KEY_RECOVERED_ERROR 0x01
136#define SENSE_KEY_NOT_READY 0x02
137#define SENSE_KEY_MEDIUM_ERROR 0x03
138#define SENSE_KEY_HARDWARE_ERROR 0x04
139#define SENSE_KEY_ILLEGAL_REQUEST 0x05
140#define SENSE_KEY_UNIT_ATTENTION 0x06
141#define SENSE_KEY_DATA_PROTECT 0x07
142#define SENSE_KEY_BLANK_CHECK 0x08
143#define SENSE_KEY_VENDERO_SPECIFIC 0x09
144#define SENSE_KEY_ABORTED_COMMAND 0x0B
145#define SENSE_KEY_VOLUME_OVERFLOW 0x0D
146#define SENSE_KEY_MISCOMPARE 0x0E
147
148
149#define INVALID_COMMAND 0x20
150#define INVALID_FIELED_IN_COMMAND 0x24
151#define PARAMETER_LIST_LENGTH_ERROR 0x1A
152#define INVALID_FIELD_IN_PARAMETER_LIST 0x26
153#define ADDRESS_OUT_OF_RANGE 0x21
154#define MEDIUM_NOT_PRESENT 0x3A
155#define MEDIUM_HAVE_CHANGED 0x28
156
157#define SCSI_INQUIRY_DATA_LENGTH 36
158
162typedef struct
163{
164 uint8_t opcode;
165 uint8_t lun;
166 uint32_t address;
167 uint8_t reserved1;
168 uint32_t alloc_length;
169 uint16_t reserved2;
170}cbd_typical_type;
171
175typedef struct
176{
177 uint8_t opcode;
178 uint8_t lun;
179 uint32_t address;
180 uint8_t reserved1;
181 uint32_t alloc_length;
182 uint16_t reserved2;
183}cbd_extended_type;
184
188typedef struct
189{
190 uint32_t dCBWSignature;
191 uint32_t dCBWTage;
192 uint32_t dCBWDataTransferLength;
193 uint8_t bmCBWFlags;
194 uint8_t bCBWLUN;
195 uint8_t bCBWCBLength;
196 uint8_t CBWCB[16];
197}cbw_type;
198
202typedef struct
203{
204 uint32_t dCSWSignature;
205 uint32_t dCSWTag;
206 uint32_t dCSWDataResidue;
207 uint32_t bCSWStatus;
208}csw_type;
209
213typedef struct
214{
215 uint8_t err_code;
216 uint8_t reserved1;
217 uint8_t sense_key;
218 uint32_t information;
219 uint8_t as_length;
220 uint32_t reserved2;
221 uint8_t asc;
222 uint8_t ascq;
223 uint32_t reserved3;
224}sense_type;
225
226
227typedef struct
228{
229 uint8_t msc_state;
230 uint8_t bot_status;
231 uint32_t max_lun;
232
233 uint32_t blk_nbr[MSC_SUPPORT_MAX_LUN];
234 uint32_t blk_size[MSC_SUPPORT_MAX_LUN];
235
236 uint32_t blk_addr;
237 uint32_t blk_len;
238
239 uint32_t data_len;
240 uint8_t data[MSC_MAX_DATA_BUF_LEN];
241
242 uint32_t alt_setting;
243
244 cbw_type cbw_struct;
245 csw_type csw_struct;
246
247}msc_type;
248
252typedef struct
253{
254 //used for CDC
255 uint32_t alt_setting;
256 uint8_t g_rx_buff[USBD_CDC_MSC_OUT_MAXPACKET_SIZE];
257 uint8_t g_cmd[USBD_CDC_CMD_MAXPACKET_SIZE];
258 uint8_t g_req;
259 uint16_t g_len, g_rxlen;
260 __IO uint8_t g_tx_completed, g_rx_completed;
261 linecoding_type linecoding;
262
263 //used for MSC
264 uint8_t msc_state;
265 uint8_t bot_status;
266 uint32_t max_lun;
267
268 uint32_t blk_nbr[MSC_SUPPORT_MAX_LUN];
269 uint32_t blk_size[MSC_SUPPORT_MAX_LUN];
270
271 uint32_t blk_addr;
272 uint32_t blk_len;
273
274 uint32_t data_len;
275 uint8_t data[MSC_MAX_DATA_BUF_LEN];
276
277 cbw_type cbw_struct;
278 csw_type csw_struct;
279}cdc_msc_struct_type; //cdc_struct_type;
280
281
289extern usbd_class_handler cdc_msc_class_handler; //cdc_class_handler;
290uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data);
291 error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len);
292
293void bot_scsi_init(void *udev);
294void bot_scsi_reset(void *udev);
295void bot_scsi_datain_handler(void *pudev, uint8_t ept_num);
296void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num);
297void bot_cbw_decode(void *udev);
298void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len);
299void bot_scsi_send_csw(void *udev, uint8_t status);
300void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc);
301 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count);
302void bot_scsi_stall(void *udev);
303 usb_sts_type bot_scsi_cmd_process(void *udev);
304
305 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun);
306 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun);
307 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun);
308 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun);
309 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun);
310 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun);
311 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun);
312 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun);
313 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun);
314 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun);
315 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun);
316 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun);
317void bot_scsi_clear_feature(void *udev, uint8_t ept_num);
318
330#ifdef __cplusplus
331}
332#endif
333
334#endif
335
336
337
338
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
cdc_msc_struct_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:277
cbd_typical_type::opcode
uint8_t opcode
Definition: cdc_msc_class.h:164
cbd_typical_type::address
uint32_t address
Definition: cdc_msc_class.h:166
cbd_typical_type::alloc_length
uint32_t alloc_length
Definition: cdc_msc_class.h:168
cbw_type::bCBWLUN
uint8_t bCBWLUN
Definition: cdc_msc_class.h:194
msc_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:244
sense_type::err_code
uint8_t err_code
Definition: cdc_msc_class.h:215
cdc_msc_struct_type::g_req
uint8_t g_req
Definition: cdc_msc_class.h:258
sense_type::ascq
uint8_t ascq
Definition: cdc_msc_class.h:222
cbw_type::bCBWCBLength
uint8_t bCBWCBLength
Definition: cdc_msc_class.h:195
cdc_msc_struct_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:255
cdc_msc_struct_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:264
csw_type::dCSWSignature
uint32_t dCSWSignature
Definition: cdc_msc_class.h:204
cbd_typical_type::reserved1
uint8_t reserved1
Definition: cdc_msc_class.h:167
sense_type::reserved3
uint32_t reserved3
Definition: cdc_msc_class.h:223
cbd_extended_type::alloc_length
uint32_t alloc_length
Definition: cdc_msc_class.h:181
csw_type::bCSWStatus
uint32_t bCSWStatus
Definition: cdc_msc_class.h:207
cdc_msc_struct_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:272
sense_type::asc
uint8_t asc
Definition: cdc_msc_class.h:221
csw_type::dCSWTag
uint32_t dCSWTag
Definition: cdc_msc_class.h:205
cbd_extended_type::opcode
uint8_t opcode
Definition: cdc_msc_class.h:177
csw_type::dCSWDataResidue
uint32_t dCSWDataResidue
Definition: cdc_msc_class.h:206
cbd_extended_type::address
uint32_t address
Definition: cdc_msc_class.h:179
cdc_msc_struct_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:278
msc_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:245
msc_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:237
sense_type::as_length
uint8_t as_length
Definition: cdc_msc_class.h:219
sense_type::reserved2
uint32_t reserved2
Definition: cdc_msc_class.h:220
msc_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:236
cbd_extended_type::reserved1
uint8_t reserved1
Definition: cdc_msc_class.h:180
cbd_extended_type::reserved2
uint16_t reserved2
Definition: cdc_msc_class.h:182
cdc_msc_struct_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:274
cdc_msc_struct_type::linecoding
linecoding_type linecoding
Definition: cdc_msc_class.h:261
sense_type::sense_key
uint8_t sense_key
Definition: cdc_msc_class.h:217
cbd_typical_type::lun
uint8_t lun
Definition: cdc_msc_class.h:165
cbd_typical_type::reserved2
uint16_t reserved2
Definition: cdc_msc_class.h:169
msc_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:231
msc_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:230
cbd_extended_type::lun
uint8_t lun
Definition: cdc_msc_class.h:178
msc_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:229
sense_type::reserved1
uint8_t reserved1
Definition: cdc_msc_class.h:216
msc_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:242
cdc_msc_struct_type::g_len
uint16_t g_len
Definition: cdc_msc_class.h:259
cbw_type::dCBWDataTransferLength
uint32_t dCBWDataTransferLength
Definition: cdc_msc_class.h:192
sense_type::information
uint32_t information
Definition: cdc_msc_class.h:218
msc_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:239
cdc_msc_struct_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:266
cdc_msc_struct_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:271
cbw_type::dCBWTage
uint32_t dCBWTage
Definition: cdc_msc_class.h:191
cbw_type::dCBWSignature
uint32_t dCBWSignature
Definition: cdc_msc_class.h:190
cdc_msc_struct_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:265
cdc_msc_struct_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: cdc_msc_class.h:260
cbw_type::bmCBWFlags
uint8_t bmCBWFlags
Definition: cdc_msc_class.h:193
error_status
error_status
error status
Definition: at32f413.h:264
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_msc_class.h:66
USBD_CDC_MSC_OUT_MAXPACKET_SIZE
#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE
Definition: cdc_msc_class.h:65
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: msc/msc_bot_scsi.c:506
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:145
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: msc/msc_bot_scsi.c:411
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: msc/msc_bot_scsi.c:541
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:340
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: msc/msc_bot_scsi.c:600
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: msc/msc_bot_scsi.c:305
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: msc/msc_bot_scsi.c:661
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:127
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: msc/msc_bot_scsi.c:459
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: msc/msc_bot_scsi.c:290
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: msc/msc_bot_scsi.c:198
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: msc/msc_bot_scsi.c:572
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: msc/msc_bot_scsi.c:425
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:370
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:104
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: msc/msc_bot_scsi.c:751
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:174
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: msc/msc_bot_scsi.c:439
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: msc/msc_bot_scsi.c:322
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: msc/msc_bot_scsi.c:245
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: msc/msc_bot_scsi.c:348
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: msc/msc_bot_scsi.c:370
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: msc/msc_bot_scsi.c:479
cdc_msc_class_handler
usbd_class_handler cdc_msc_class_handler
Definition: cdc_msc_class.c:72
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:731
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: msc/msc_bot_scsi.c:266
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: cdc_msc_class.h:84
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
cbd_extended_type
extended command block description
Definition: cdc_msc_class.h:176
cbd_typical_type
typical command block description
Definition: cdc_msc_class.h:163
cbw_type
command block wrapper
Definition: cdc_msc_class.h:189
cdc_msc_struct_type
usb cdc class struct
Definition: cdc_msc_class.h:253
csw_type
command block wrapper
Definition: cdc_msc_class.h:203
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
msc_type
Definition: cdc_msc_class.h:228
sense_type
request sense standard data
Definition: cdc_msc_class.h:214
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: cdc_msc_desc.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_desc.c
Go to the documentation of this file.
1
26#include "stdio.h"
27#include "usb_std.h"
28#include "usbd_sdr.h"
29#include "usbd_core.h"
30#include "cdc_msc_desc.h"
31
45#define USB_INTERFACE_ASSOCIATION_TYPE 0x0B
46
47static usbd_desc_t *get_device_descriptor(void);
48static usbd_desc_t *get_device_qualifier(void);
49static usbd_desc_t *get_device_configuration(void);
50static usbd_desc_t *get_device_other_speed(void);
51static usbd_desc_t *get_device_lang_id(void);
52static usbd_desc_t *get_device_manufacturer_string(void);
53static usbd_desc_t *get_device_product_string(void);
54static usbd_desc_t *get_device_serial_string(void);
55static usbd_desc_t *get_device_interface_string(void);
56static usbd_desc_t *get_device_config_string(void);
57
58static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
59static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
60static void get_serial_num(void);
61static uint8_t g_usbd_desc_buffer[256];
62
66 usbd_desc_handler cdc_msc_desc_handler =
67{
68 get_device_descriptor,
69 get_device_qualifier,
70 get_device_configuration,
71 get_device_other_speed,
72 get_device_lang_id,
73 get_device_manufacturer_string,
74 get_device_product_string,
75 get_device_serial_string,
76 get_device_interface_string,
77 get_device_config_string,
78};
79
83#if defined ( __ICCARM__ ) /* iar compiler */
84 #pragma data_alignment=4
85#endif
86ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
87{
88 USB_DEVICE_DESC_LEN, /* bLength */
89 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
90 0x00, /* bcdUSB */
91 0x02,
92 0xEF, /* bDeviceClass */
93 0x02, /* bDeviceSubClass */
94 0x01, /* bDeviceProtocol */
95 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
96 LBYTE(USBD_CDC_MSC_VENDOR_ID), /* idVendor */
97 HBYTE(USBD_CDC_MSC_VENDOR_ID), /* idVendor */
98 LBYTE(USBD_CDC_MSC_PRODUCT_ID), /* idProduct */
99 HBYTE(USBD_CDC_MSC_PRODUCT_ID), /* idProduct */
100 0x00, /* bcdDevice rel. 2.00 */
101 0x02,
102 USB_MFC_STRING, /* Index of manufacturer string */
103 USB_PRODUCT_STRING, /* Index of product string */
104 USB_SERIAL_STRING, /* Index of serial number string */
105 1 /* bNumConfigurations */
106};
107
111#if defined ( __ICCARM__ ) /* iar compiler */
112 #pragma data_alignment=4
113#endif
114ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_CDC_MSC_CONFIG_DESC_SIZE] ALIGNED_TAIL =
115{
116 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
117 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
118 LBYTE(USBD_CDC_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
119 HBYTE(USBD_CDC_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
120 0x03, /* bNumInterfaces: 3 interface */
121 0x01, /* bConfigurationValue: configuration value */
122 0x00, /* iConfiguration: index of string descriptor describing
123 the configuration */
124 0xC0, /* bmAttributes: self powered */
125 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
126
127 // IAD (Interface Association Descriptor) for MSC
128 0x08, /* bLength */
129 USB_INTERFACE_ASSOCIATION_TYPE, /* bDescriptorType */
130 0x00, /* bFirstInterface */
131 0x01, /* bInterfaceCount */
132 0x08, /* bFunctionClass */
133 0x06, /* bFunctionSubClass */
134 0x50, /* bFunctionProtocol */
135 0x00, /* iFunction (Index of string descriptor describing this function) */
136
137 // Configuration Descriptor for MSC
138 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
139 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
140 VCPMSC_MSC_INTERFACE, /* bInterfaceNumber: number of interface */
141 0x00, /* bAlternateSetting: alternate set */
142 0x02, /* bNumEndpoints: number of endpoints */
143 USB_CLASS_CODE_MSC, /* bInterfaceClass: msc class code */
144 0x06, /* bInterfaceSubClass: subclass code scsi */
145 0x50, /* bInterfaceProtocol: protocol code BBB */
146 0x00, /* iInterface: index of string descriptor */
147
148 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
149 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
150 USBD_MSC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
151 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
152 LBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE),
153 HBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
154 0x00, /* bInterval: interval for polling endpoint for data transfers */
155
156 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
157 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
158 USBD_MSC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
159 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
160 LBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE),
161 HBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
162 0x00, /* bInterval: interval for polling endpoint for data transfers */
163
164 // IAD (Interface Association Descriptor) for CDC
165 0x08, /* bLength */
166 USB_INTERFACE_ASSOCIATION_TYPE, /* bDescriptorType */
167 0x01, /* bFirstInterface */
168 0x02, /* bInterfaceCount */
169 USB_CLASS_CODE_CDC, /* bFunctionClass */
170 0x02, /* bFunctionSubClass */
171 0x01, /* bFunctionProtocol */
172 0x00, /* iFunction (Index of string descriptor describing this function) */
173
174 // Configuration Descriptor for CDC
175 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
176 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
177 VCPMSC_CDC_INTERFACE, /* bInterfaceNumber: number of interface */
178 0x00, /* bAlternateSetting: alternate set */
179 0x01, /* bNumEndpoints: number of endpoints */
180 USB_CLASS_CODE_CDC, /* bInterfaceClass: CDC class code */
181 0x02, /* bInterfaceSubClass: subclass code, Abstract Control Model*/
182 0x01, /* bInterfaceProtocol: protocol code, AT Command */
183 0x00, /* iInterface: index of string descriptor */
184
185 0x05, /* bFunctionLength: size of this descriptor in bytes */
186 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
187 USBD_CDC_SUBTYPE_HEADER, /* bDescriptorSubtype: Header function Descriptor 0x00*/
188 LBYTE(CDC_BCD_NUM),
189 HBYTE(CDC_BCD_NUM), /* bcdCDC: USB class definitions for communications */
190
191 0x05, /* bFunctionLength: size of this descriptor in bytes */
192 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
193 USBD_CDC_SUBTYPE_CMF, /* bDescriptorSubtype: Call Management function descriptor subtype 0x01 */
194 0x00, /* bmCapabilities: 0x00*/
195 0x01, /* bDataInterface: interface number of data class interface optionally used for call management */
196
197 0x04, /* bFunctionLength: size of this descriptor in bytes */
198 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
199 USBD_CDC_SUBTYPE_ACM, /* bDescriptorSubtype: Abstract Control Management functional descriptor subtype 0x02 */
200 0x02, /* bmCapabilities: Support Set_Line_Coding and Get_Line_Coding 0x02 */
201
202 0x05, /* bFunctionLength: size of this descriptor in bytes */
203 USBD_CDC_CS_INTERFACE, /* bDescriptorType: CDC interface descriptor type */
204 USBD_CDC_SUBTYPE_UFD, /* bDescriptorSubtype: Union Function Descriptor subtype 0x06 */
205 0x00, /* bControlInterface: The interface number of the communications or data class interface 0x00 */
206 0x01, /* bSubordinateInterface0: interface number of first subordinate interface in the union */
207
208 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
209 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
210 USBD_CDC_INT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
211 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
212 LBYTE(USBD_CDC_CMD_MAXPACKET_SIZE),
213 HBYTE(USBD_CDC_CMD_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
214 CDC_HID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
215
216
217 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
218 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
219 VCPMSC_CDC_DATA_INTERFACE, /* bInterfaceNumber: number of interface */
220 0x00, /* bAlternateSetting: alternate set */
221 0x02, /* bNumEndpoints: number of endpoints */
222 USB_CLASS_CODE_CDCDATA, /* bInterfaceClass: CDC-data class code */
223 0x00, /* bInterfaceSubClass: Data interface subclass code 0x00*/
224 0x00, /* bInterfaceProtocol: data class protocol code 0x00 */
225 0x00, /* iInterface: index of string descriptor */
226
227 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
228 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
229 USBD_CDC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
230 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
231 LBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE),
232 HBYTE(USBD_CDC_MSC_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
233 0x00, /* bInterval: interval for polling endpoint for data transfers */
234
235 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
236 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
237 USBD_CDC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
238 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
239 LBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE),
240 HBYTE(USBD_CDC_MSC_OUT_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
241 0x00, /* bInterval: interval for polling endpoint for data transfers */
242
243
244};
245
249#if defined ( __ICCARM__ ) /* iar compiler */
250 #pragma data_alignment=4
251#endif
252ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_CDC_SIZ_STRING_LANGID] ALIGNED_TAIL =
253{
254 USBD_CDC_SIZ_STRING_LANGID,
255 USB_DESCIPTOR_TYPE_STRING,
256 0x09,
257 0x04,
258};
259
263#if defined ( __ICCARM__ ) /* iar compiler */
264 #pragma data_alignment=4
265#endif
266ALIGNED_HEAD static uint8_t g_string_serial[USBD_CDC_SIZ_STRING_SERIAL] ALIGNED_TAIL =
267{
268 USBD_CDC_SIZ_STRING_SERIAL,
269 USB_DESCIPTOR_TYPE_STRING,
270};
271
272
273/* device descriptor */
274static usbd_desc_t device_descriptor =
275{
276 USB_DEVICE_DESC_LEN,
277 g_usbd_descriptor
278};
279
280/* config descriptor */
281static usbd_desc_t config_descriptor =
282{
283 USBD_CDC_MSC_CONFIG_DESC_SIZE,
284 g_usbd_configuration
285};
286
287/* langid descriptor */
288static usbd_desc_t langid_descriptor =
289{
290 USBD_CDC_SIZ_STRING_LANGID,
291 g_string_lang_id
292};
293
294/* serial descriptor */
295static usbd_desc_t serial_descriptor =
296{
297 USBD_CDC_SIZ_STRING_SERIAL,
298 g_string_serial
299};
300
301static usbd_desc_t vp_desc;
302
309static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
310{
311 uint16_t str_len = 0, id_pos = 2;
312 uint8_t *tmp_str = string;
313
314 while(*tmp_str != '\0')
315 {
316 str_len ++;
317 unicode_buf[id_pos ++] = *tmp_str ++;
318 unicode_buf[id_pos ++] = 0x00;
319 }
320
321 str_len = str_len * 2 + 2;
322 unicode_buf[0] = (uint8_t)str_len;
323 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
324
325 return str_len;
326}
327
335static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
336{
337 uint8_t idx = 0;
338
339 for( idx = 0 ; idx < len ; idx ++)
340 {
341 if( ((value >> 28)) < 0xA )
342 {
343 pbuf[ 2 * idx] = (value >> 28) + '0';
344 }
345 else
346 {
347 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
348 }
349
350 value = value << 4;
351
352 pbuf[2 * idx + 1] = 0;
353 }
354}
355
361static void get_serial_num(void)
362{
363 uint32_t serial0, serial1, serial2;
364
365 serial0 = *(uint32_t*)MCU_ID1;
366 serial1 = *(uint32_t*)MCU_ID2;
367 serial2 = *(uint32_t*)MCU_ID3;
368
369 serial0 += serial2;
370
371 if (serial0 != 0)
372 {
373 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
374 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
375 }
376}
377
383static usbd_desc_t *get_device_descriptor(void)
384{
385 return &device_descriptor;
386}
387
393static usbd_desc_t * get_device_qualifier(void)
394{
395 return NULL;
396}
397
403static usbd_desc_t *get_device_configuration(void)
404{
405 return &config_descriptor;
406}
407
413static usbd_desc_t *get_device_other_speed(void)
414{
415 return NULL;
416}
417
423static usbd_desc_t *get_device_lang_id(void)
424{
425 return &langid_descriptor;
426}
427
428
434static usbd_desc_t *get_device_manufacturer_string(void)
435{
436 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
437 vp_desc.descriptor = g_usbd_desc_buffer;
438 return &vp_desc;
439}
440
446static usbd_desc_t *get_device_product_string(void)
447{
448 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
449 vp_desc.descriptor = g_usbd_desc_buffer;
450 return &vp_desc;
451}
452
458static usbd_desc_t *get_device_serial_string(void)
459{
460 get_serial_num();
461 return &serial_descriptor;
462}
463
469static usbd_desc_t *get_device_interface_string(void)
470{
471 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
472 vp_desc.descriptor = g_usbd_desc_buffer;
473 return &vp_desc;
474}
475
481static usbd_desc_t *get_device_config_string(void)
482{
483 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CDC_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
484 vp_desc.descriptor = g_usbd_desc_buffer;
485 return &vp_desc;
486}
487
cdc_msc_desc.h
usb cdc descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_CDC_CMD_MAXPACKET_SIZE
#define USBD_CDC_CMD_MAXPACKET_SIZE
Definition: cdc_class.h:62
USBD_CDC_MSC_OUT_MAXPACKET_SIZE
#define USBD_CDC_MSC_OUT_MAXPACKET_SIZE
Definition: cdc_msc_class.h:65
USBD_CDC_BULK_OUT_EPT
#define USBD_CDC_BULK_OUT_EPT
Definition: cdc_class.h:55
USBD_CDC_MSC_IN_MAXPACKET_SIZE
#define USBD_CDC_MSC_IN_MAXPACKET_SIZE
usb cdc in and out max packet size define
Definition: cdc_msc_class.h:63
USBD_CDC_INT_EPT
#define USBD_CDC_INT_EPT
usb cdc use endpoint define
Definition: cdc_class.h:53
USBD_CDC_BULK_IN_EPT
#define USBD_CDC_BULK_IN_EPT
Definition: cdc_class.h:54
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
CDC_BCD_NUM
#define CDC_BCD_NUM
usb bcd number define
Definition: cdc_desc.h:52
USBD_CDC_DESC_MANUFACTURER_STRING
#define USBD_CDC_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: cdc_desc.h:70
USBD_CDC_DESC_CONFIGURATION_STRING
#define USBD_CDC_DESC_CONFIGURATION_STRING
Definition: cdc_desc.h:72
USBD_CDC_SIZ_STRING_LANGID
#define USBD_CDC_SIZ_STRING_LANGID
Definition: cdc_desc.h:64
USBD_CDC_DESC_PRODUCT_STRING
#define USBD_CDC_DESC_PRODUCT_STRING
Definition: cdc_desc.h:71
VCPMSC_MSC_INTERFACE
#define VCPMSC_MSC_INTERFACE
usb interface define
Definition: cdc_msc_desc.h:84
USBD_CDC_MSC_CONFIG_DESC_SIZE
#define USBD_CDC_MSC_CONFIG_DESC_SIZE
usb descriptor size define
Definition: cdc_msc_desc.h:64
CDC_HID_BINTERVAL_TIME
#define CDC_HID_BINTERVAL_TIME
usb endpoint interval define
Definition: cdc_desc.h:78
VCPMSC_CDC_INTERFACE
#define VCPMSC_CDC_INTERFACE
Definition: cdc_msc_desc.h:85
USBD_CDC_SIZ_STRING_SERIAL
#define USBD_CDC_SIZ_STRING_SERIAL
Definition: cdc_desc.h:65
USBD_CDC_DESC_INTERFACE_STRING
#define USBD_CDC_DESC_INTERFACE_STRING
Definition: cdc_desc.h:73
USBD_CDC_MSC_PRODUCT_ID
#define USBD_CDC_MSC_PRODUCT_ID
Definition: cdc_msc_desc.h:58
VCPMSC_CDC_DATA_INTERFACE
#define VCPMSC_CDC_DATA_INTERFACE
Definition: cdc_msc_desc.h:86
USBD_CDC_MSC_VENDOR_ID
#define USBD_CDC_MSC_VENDOR_ID
usb vendor id and product id define
Definition: cdc_msc_desc.h:57
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: cdc_msc_desc.c:295
cdc_msc_desc_handler
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure
Definition: cdc_msc_desc.c:66
USB_INTERFACE_ASSOCIATION_TYPE
#define USB_INTERFACE_ASSOCIATION_TYPE
Definition: cdc_msc_desc.c:45
device_descriptor
static usbd_desc_t device_descriptor
Definition: cdc_msc_desc.c:274
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: cdc_msc_desc.c:403
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: cdc_msc_desc.c:288
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: cdc_msc_desc.c:383
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: cdc_msc_desc.c:434
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: cdc_msc_desc.c:393
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: cdc_msc_desc.c:469
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: cdc_msc_desc.c:61
vp_desc
static usbd_desc_t vp_desc
Definition: cdc_msc_desc.c:301
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: cdc_msc_desc.c:413
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: cdc_msc_desc.c:86
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: cdc_msc_desc.c:446
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: cdc_msc_desc.c:481
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: cdc_msc_desc.c:309
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: cdc_msc_desc.c:423
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: cdc_msc_desc.c:361
config_descriptor
static usbd_desc_t config_descriptor
Definition: cdc_msc_desc.c:281
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: cdc_msc_desc.c:458
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: cdc_msc_desc.c:335
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
USB_CLASS_CODE_MSC
#define USB_CLASS_CODE_MSC
Definition: usb_std.h:165
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USBD_CDC_SUBTYPE_CMF
#define USBD_CDC_SUBTYPE_CMF
Definition: usb_std.h:199
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USBD_CDC_SUBTYPE_HEADER
#define USBD_CDC_SUBTYPE_HEADER
usb cdc class sub-type define
Definition: usb_std.h:198
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USBD_CDC_CS_INTERFACE
#define USBD_CDC_CS_INTERFACE
usb cdc class descriptor define
Definition: usb_std.h:192
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_CLASS_CODE_CDCDATA
#define USB_CLASS_CODE_CDCDATA
Definition: usb_std.h:167
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_CDC
#define USB_CLASS_CODE_CDC
Definition: usb_std.h:162
USBD_CDC_SUBTYPE_UFD
#define USBD_CDC_SUBTYPE_UFD
Definition: usb_std.h:201
USBD_CDC_SUBTYPE_ACM
#define USBD_CDC_SUBTYPE_ACM
Definition: usb_std.h:200
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: cdc_msc_desc.h Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
cdc_msc_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CDC_MSC_DESC_H
29#define __CDC_MSC_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "cdc_msc_class.h"
36#include "usbd_core.h"
37
52#define CDC_BCD_NUM 0x0110
53
57#define USBD_CDC_MSC_VENDOR_ID 0x2E3C
58#define USBD_CDC_MSC_PRODUCT_ID 0x5760
59
64#define USBD_CDC_MSC_CONFIG_DESC_SIZE 106
65#define USBD_CDC_SIZ_STRING_LANGID 4
66#define USBD_CDC_SIZ_STRING_SERIAL 0x1A
67
71#define USBD_CDC_DESC_MANUFACTURER_STRING "Artery"
72#define USBD_CDC_DESC_PRODUCT_STRING "AT32 Composite VCP and MSC "
73#define USBD_CDC_DESC_CONFIGURATION_STRING "Composite VCP and MSC Config"
74#define USBD_CDC_DESC_INTERFACE_STRING "Composite VCP and MSC Interface"
75
79#define CDC_HID_BINTERVAL_TIME 0xFF
80
84#define VCPMSC_MSC_INTERFACE 0x00
85#define VCPMSC_CDC_INTERFACE 0x01
86#define VCPMSC_CDC_DATA_INTERFACE 0x02
87
88
92#define MCU_ID1 (0x1FFFF7E8)
93#define MCU_ID2 (0x1FFFF7EC)
94#define MCU_ID3 (0x1FFFF7F0)
99extern usbd_desc_handler cdc_msc_desc_handler;
100
101
109#ifdef __cplusplus
110}
111#endif
112
113#endif
cdc_msc_class.h
usb cdc class file
cdc_msc_desc_handler
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure
Definition: cdc_msc_desc.c:66
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: audio_codec.h Source File

  • usb_device
  • composite_audio_hid
  • inc
composite_audio_hid/inc/audio_codec.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AUDIO_CODEC_H
29#define __AUDIO_CODEC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
44/* includes ------------------------------------------------------------------*/
45#include "at32f413.h"
46
50#define WM8988_R0_LEFT_INPUT_VOLUME 0x00 /*Left channel PGA control*/
51#define WM8988_R1_RIGHT_INPUT_VOLUME 0x01 /*Right channel PGA control*/
52#define WM8988_R2_LOUT1_VOLUME 0x02
53#define WM8988_R3_ROUT1_VOLUME 0x03
54#define WM8988_R4_RESERVED 0x04
55#define WM8988_R5_ADC_DAC_CONTROL 0x05
56#define WM8988_R6_RESERVED 0x06
57#define WM8988_R7_AUDIO_INTERFACE 0x07
58#define WM8988_R8_SAMPLE_RATE 0x08
59#define WM8988_R9_RESERVED 0x09
60#define WM8988_R10_LEFT_DAC_VOLUME 0x0A
61#define WM8988_R11_RIGHT_DAC_VOLUME 0x0B
62#define WM8988_R12_BASS_CONTROL 0x0C
63#define WM8988_R13_TREBLE_CONTROL 0x0D
64#define WM8988_R14_
65#define WM8988_R15_RESET 0x0F
66#define WM8988_R16_3D_CONTROL 0x10
67#define WM8988_R17_ALC1 0x11
68#define WM8988_R18_ALC2 0x12
69#define WM8988_R19_ALC3 0x13
70#define WM8988_R20_NOISE_GATE 0x14
71#define WM8988_R21_LEFT_ADC_VOLUME 0x15
72#define WM8988_R22_RIGHT_ADC_VOLUME 0x16
73#define WM8988_R23_ADDITIONAL_1_CONTROL 0x17
74#define WM8988_R24_ADDITIONAL_2_CONTROL 0x18
75#define WM8988_R25_PWR_1_MGMT 0x19
76#define WM8988_R26_PWR_2_MGMT 0x1A
77#define WM8988_R27_ADDITIONAL_3_CONTROL 0x1B
78
79#define WM8988_R31_ADC_INPUT_MODE 0x1F
80#define WM8988_R32_ADC_L_SIGNAL_PATH 0x20
81#define WM8988_R33_ADC_R_SIGNAL_PATH 0x21
82#define WM8988_R34_LEFT_OUT_MIX_1 0x22
83#define WM8988_R35_LEFT_OUT_MIX_2 0x23
84#define WM8988_R36_RIGHT_OUT_MIX_1 0x24
85#define WM8988_R37_RIGHT_OUT_MIX_2 0x25
86#define WM8988_R38_RESERVED
87#define WM8988_R39_RESERVED
88#define WM8988_R40_LOUT2_VOLUME 0x28
89#define WM8988_R41_ROUT2_VOLUME 0x29
90#define WM8988_R42_RESERVED
91#define WM8988_R43_LOW_POWER_PALYBACK 0x43
92
93#define WM8988_I2C_ADDR_CSB_LOW 0x34
94#define WM8988_I2C_ADDR_CSB_HIGH 0x36
95
103#define I2S1_WS_PIN GPIO_PINS_4
104#define I2S1_CK_PIN GPIO_PINS_5
105#define I2S1_SD_PIN GPIO_PINS_7
106
107#define I2S1_GPIO GPIOA
108#define I2S1_GPIO_CRM_CLK CRM_GPIOA_PERIPH_CLOCK
109#define I2S1_DT_ADDRESS (&(SPI1->dt))
110
111/*I2S2 Pin*/
112#define I2S2_WS_PIN GPIO_PINS_12
113#define I2S2_CK_PIN GPIO_PINS_13
114#define I2S2_SD_PIN GPIO_PINS_15
115
116
117#define I2S2_GPIO GPIOB
118#define I2S2_GPIO_CRM_CLK CRM_GPIOB_PERIPH_CLOCK
119#define I2S2_DT_ADDRESS (&(SPI2->dt))
120
121#define SPK_TX_FIFO_SIZE (1024 * 4)
122
130#define MIC_BUFFER_SIZE 1024
131#define SPK_BUFFER_SIZE 4096
132#define DMA_BUFFER_SIZE 288
133
134typedef struct
135{
136 uint32_t audio_freq;
137 uint32_t audio_bitw;
138 //spk part
139 uint16_t spk_buffer[SPK_BUFFER_SIZE];
140 uint16_t *spk_roff;
141 uint16_t *spk_woff;
142 uint16_t *spk_rend;
143 uint32_t spk_freq;
144 uint32_t spk_wtotal;
145 uint32_t spk_rtotal;
146 uint16_t spk_threshold;
147 uint16_t spk_calc;
148 uint8_t spk_stage;
149
150 //mic part
151 uint16_t mic_buffer[MIC_BUFFER_SIZE];
152 uint16_t *mic_roff;
153 uint16_t *mic_woff;
154 uint16_t *mic_wend;
155 uint32_t mic_wtotal;
156 uint32_t mic_rtotal;
157 uint32_t mic_delta;
158 uint16_t mic_calc;
159 uint16_t mic_adj_count;
160 uint8_t mic_adj_stage;
161 uint8_t mic_stage;
162
163 uint8_t mic_mute;
164 uint8_t spk_mute;
165
166 uint16_t mic_volume;
167 uint16_t spk_volume;
168
169 uint32_t spk_tx_size;
170 uint32_t mic_rx_size;
171
172 uint32_t spk_enable;
173 uint32_t mic_enable;
174
175}audio_codec_type;
176
177 error_status audio_codec_init(void);
178 error_status audio_codec_loop(void);
179void audio_codec_modify_freq(uint32_t freq);
180
184void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len);
185uint32_t audio_codec_mic_get_data(uint8_t *buffer);
186uint8_t audio_codec_spk_feedback(uint8_t *feedback);
187void audio_codec_spk_alt_setting(uint32_t alt_seting);
188void audio_codec_mic_alt_setting(uint32_t alt_seting);
189void audio_codec_set_mic_mute(uint8_t mute);
190void audio_codec_set_spk_mute(uint8_t mute);
191void audio_codec_set_mic_volume(uint16_t volume);
192void audio_codec_set_spk_volume(uint16_t volume);
193void audio_codec_set_mic_freq(uint32_t freq);
194void audio_codec_set_spk_freq(uint32_t freq);
195
207#ifdef __cplusplus
208}
209#endif
210
211#endif
212
at32f413.h
at32f413 header file
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
error_status
error_status
error status
Definition: at32f413.h:264
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: audio/src/audio_codec.c:169
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: audio/src/audio_codec.c:217
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: audio/src/audio_codec.c:195
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: composite_audio_hid/inc/audio_codec.h:130
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: audio/src/audio_codec.c:121
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: audio/src/audio_codec.c:282
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:853
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: composite_audio_hid/inc/audio_codec.h:131
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: audio/src/audio_codec.c:184
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
audio codec interface
Definition: audio/src/audio_codec.c:244
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: audio/src/audio_codec.c:228
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: audio/src/audio_codec.c:342
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: audio/src/audio_codec.c:206
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: audio/src/audio_codec.c:154
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:794
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: audio/src/audio_codec.c:137
audio_codec_type
Definition: audio/inc/audio_codec.h:132


AT32F413 Firmwary Library: audio_codec.c Source File

  • usb_device
  • composite_audio_hid
  • src
composite_audio_hid/src/audio_codec.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "audio_codec.h"
29#include "i2c_application.h"
30#include "audio_conf.h"
31#include <string.h>
32
41#define I2C_TIMEOUT 0xFFFFFFFF
42
43#define I2Cx_SPEED 200000
44#define I2Cx_ADDRESS 0x00
45
46#define I2Cx_PORT I2C1
47#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
48
49#define I2Cx_SCL_PIN GPIO_PINS_8
50#define I2Cx_SCL_GPIO_PORT GPIOB
51#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
52
53#define I2Cx_SDA_PIN GPIO_PINS_9
54#define I2Cx_SDA_GPIO_PORT GPIOB
55#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
56
60#define WM8988_REG_FREQ48K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0081)
61#define WM8988_REG_FREQ16K ((WM8988_R8_SAMPLE_RATE << 9) | 0x0095)
62
66#define WM8988_REG_BITW16 ((WM8988_R7_AUDIO_INTERFACE << 9) | 0x0042)
67
71uint16_t reg_addr_data[] =
72{
73 (WM8988_R0_LEFT_INPUT_VOLUME << 9) | 0x012F, /*Left Input Channel Volume*/
74 (WM8988_R1_RIGHT_INPUT_VOLUME << 9) | 0x012F, /*Right Input Channel Volume*/
75 (WM8988_R2_LOUT1_VOLUME << 9) | 0x0179, /*Left Output Channel Volume*/
76 (WM8988_R3_ROUT1_VOLUME << 9) | 0x0179, /*Right Output Channel Volume*/
77 (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006, /*De-emphasis Control and Digital soft mute*/
78 (WM8988_REG_BITW16),
79 (WM8988_REG_FREQ16K),
80 (WM8988_R10_LEFT_DAC_VOLUME << 9) | 0x01FF, /*Left Digital DAC Volume Control*/
81 (WM8988_R11_RIGHT_DAC_VOLUME << 9) | 0x01FF, /*Right Digital DAC Volume Control*/
82 (WM8988_R12_BASS_CONTROL << 9) | 0x000F, /*Bass Control*/
83 (WM8988_R13_TREBLE_CONTROL << 9) | 0x000F, /*Treble Control*/
84 (WM8988_R16_3D_CONTROL << 9) | 0x0000, /*3D stereo Enhancment*/
85 (WM8988_R21_LEFT_ADC_VOLUME << 9) | 0x01C3, /*Left ADC Digital Volume*/
86 (WM8988_R22_RIGHT_ADC_VOLUME << 9) | 0x01C3, /*Right ADC Digital Volume*/
87 (WM8988_R23_ADDITIONAL_1_CONTROL << 9) | 0x00C2, /*Additional Control 1*/
88 (WM8988_R24_ADDITIONAL_2_CONTROL << 9) | 0x0000, /*Additional Control 2*/
89 (WM8988_R27_ADDITIONAL_3_CONTROL << 9) | 0x0000, /*Additional Control 3*/
90 (WM8988_R31_ADC_INPUT_MODE << 9) | 0x0000, /*ADC input mode*/
91 (WM8988_R32_ADC_L_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control left*/
92 (WM8988_R33_ADC_R_SIGNAL_PATH << 9) | 0x0000, /*ADC Signal Path Control right*/
93 (WM8988_R34_LEFT_OUT_MIX_1 << 9) | 0x0152, /*Left DAC mixer Control*/
94 (WM8988_R35_LEFT_OUT_MIX_2 << 9) | 0x0050, /*Left DAC mixer Control*/
95 (WM8988_R36_RIGHT_OUT_MIX_1 << 9) | 0x0052, /*Right DAC mixer Control*/
96 (WM8988_R37_RIGHT_OUT_MIX_2 << 9) | 0x0150, /*Right DAC mixer Control*/
97 (WM8988_R40_LOUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
98 (WM8988_R41_ROUT2_VOLUME << 9) | 0x01FF, /*Output left channel volume*/
99 (WM8988_R43_LOW_POWER_PALYBACK << 9) | 0x0008, /*Output left channel volume*/
100 (WM8988_R25_PWR_1_MGMT << 9) | 0x017C, /*Power Management1*/
101 (WM8988_R26_PWR_2_MGMT << 9) | 0x01F8, /*Power Management2*/
102};
103
104 i2c_handle_type hi2cx;
105
106 audio_codec_type audio_codec;
107uint16_t spk_dma_buffer[DMA_BUFFER_SIZE];
108uint16_t mic_dma_buffer[DMA_BUFFER_SIZE];
109
110void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len);
111void codec_i2s_reset(void);
112void codec_i2s_init(audio_codec_type *param);
113void mclk_tmr1_init(void);
114void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len);
115
121void audio_codec_set_mic_freq(uint32_t freq)
122{
123 if(audio_codec.audio_freq != freq)
124 {
125 audio_codec.audio_freq = freq;
126 codec_i2s_reset();
127 audio_codec_modify_freq(freq);
128 codec_i2s_init(&audio_codec);
129 }
130}
131
137void audio_codec_set_spk_freq(uint32_t freq)
138{
139 if(audio_codec.audio_freq != freq)
140 {
141 audio_codec.audio_freq = freq;
142 codec_i2s_reset();
143 audio_codec_modify_freq(freq);
144 codec_i2s_init(&audio_codec);
145 }
146}
147
148
154void audio_codec_spk_alt_setting(uint32_t alt_seting)
155{
156 if(alt_seting == 0)
157 {
158 }
159 else
160 {
161 }
162}
163
169void audio_codec_mic_alt_setting(uint32_t alt_seting)
170{
171 if(alt_seting == 0)
172 {
173 }
174 else
175 {
176 }
177}
178
184void audio_codec_set_mic_mute(uint8_t mute)
185{
186 audio_codec.mic_mute = mute;
187}
188
189
195void audio_codec_set_spk_mute(uint8_t mute)
196{
197 audio_codec.spk_mute = mute;
198}
199
200
206void audio_codec_set_mic_volume(uint16_t volume)
207{
208 /* wm8988 adc have 256 steps */
209 audio_codec.mic_volume = volume;
210}
211
217void audio_codec_set_spk_volume(uint16_t volume)
218{
219 /* wm8988 dac have 80 steps */
220 audio_codec.spk_volume = (volume * 0x50) / 0x64 + 0x30 - 1;
221}
222
228uint8_t audio_codec_spk_feedback(uint8_t *feedback)
229{
230 uint32_t feedback_value = (audio_codec.spk_freq);
231 feedback_value = ((feedback_value/1000)<<14)|((feedback_value%1000)<<4);
232 feedback[0] = (uint8_t)(feedback_value);
233 feedback[1] = (uint8_t)(feedback_value >> 8);
234 feedback[2] = (uint8_t)(feedback_value >> 16);
235 return 3;
236}
237
244void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
245{
246 uint16_t ulen = len / 2, i;
247 uint16_t *u16data = (uint16_t *)data;
248
249 switch(audio_codec.spk_stage)
250 {
251 case 0:
252 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
253 audio_codec.spk_wtotal = audio_codec.spk_rtotal = 0;
254 audio_codec.spk_stage = 1;
255 audio_codec.spk_threshold = SPK_BUFFER_SIZE/2;
256 break;
257 case 1:
258 if( audio_codec.spk_wtotal >= SPK_BUFFER_SIZE/2 )
259 {
260 audio_codec.spk_stage = 2;
261 }
262 break;
263 case 2:
264 break;
265 }
266 for( i = 0; i < ulen; ++i )
267 {
268 *audio_codec.spk_woff++ = *u16data++;
269 if( audio_codec.spk_woff >= audio_codec.spk_rend )
270 {
271 audio_codec.spk_woff = audio_codec.spk_buffer;
272 }
273 }
274 audio_codec.spk_wtotal += ulen;
275}
276
282uint32_t audio_codec_mic_get_data(uint8_t *buffer)
283{
284 //copy_buff((uint16_t *)buffer, audio_codec.mic_buffer + audio_codec.mic_hf_status, audio_codec.mic_rx_size);
285 uint16_t len = audio_codec.mic_rx_size << 1;
286 uint16_t i;
287 uint16_t* u16buf = (uint16_t*)buffer;
288 switch(audio_codec.mic_stage)
289 {
290 case 0:
291 audio_codec.mic_stage = 1;
292 memset( buffer, 0, len );
293 return len;
294 case 1:
295 if( audio_codec.mic_wtotal - audio_codec.mic_rtotal >= MIC_BUFFER_SIZE/2 )
296 {
297 audio_codec.mic_stage = 2;
298 }
299 return len;
300 }
301 switch( audio_codec.mic_adj_stage )
302 {
303 case 0:
304 break;
305 case 1:
306 if( audio_codec.mic_adj_count >= 4 ){
307 len += 4;
308 audio_codec.mic_adj_count -= 4;
309 }
310 break;
311 case 2:
312 if( audio_codec.mic_adj_count >= 4 ){
313 len -= 4;
314 audio_codec.mic_adj_count -= 4;
315 }
316 break;
317 }
318
319 for( i = 0; i < len/2; ++i )
320 {
321 *u16buf++ = *audio_codec.mic_roff++;
322 if( audio_codec.mic_roff >= audio_codec.mic_wend )
323 {
324 audio_codec.mic_roff = audio_codec.mic_buffer;
325 }
326 }
327 if( audio_codec.mic_wtotal <= audio_codec.mic_rtotal )
328 { //should not happen
329 while(1);
330 }
331
332 audio_codec.mic_rtotal += len/2;
333 audio_codec.mic_delta += len/2;
334 return len;
335}
336
342void audio_codec_modify_freq(uint32_t freq)
343{
344 uint16_t codec_cmd;
345 uint8_t i2c_cmd[2];
346 if(freq == AUDIO_FREQ_16K)
347 {
348 codec_cmd = WM8988_REG_FREQ16K;
349 }
350 else if(freq == AUDIO_FREQ_48K)
351 {
352 codec_cmd = WM8988_REG_FREQ48K;
353 }
354 i2c_cmd[0] = (uint8_t)(codec_cmd >> 8);
355 i2c_cmd[1] = (uint8_t)codec_cmd & 0xFF;
356 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
357 {
358 while(1);
359 }
360}
361
369void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
370{
371 uint32_t i_index = 0;
372 for(i_index = 0; i_index < len; i_index ++)
373 {
374 buffer[i_index] = (uint16_t)set;
375 }
376}
377
385void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
386{
387 uint16_t i_index;
388 for(i_index = 0; i_index < len; i_index ++)
389 {
390 dest[i_index] = src[i_index];
391 }
392}
393
399void i2c_lowlevel_init(i2c_handle_type* hi2c)
400{
401 gpio_init_type gpio_initstructure;
402
403 if(hi2c->i2cx == I2Cx_PORT)
404 {
405 /* i2c periph clock enable */
406 crm_periph_clock_enable(I2Cx_CLK, TRUE);
407 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
408 gpio_pin_remap_config(I2C1_MUX, TRUE);
409 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
410 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
411
412 /* gpio configuration */
413 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
414 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
415 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
416 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
417
418 /* configure i2c pins: scl */
419 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
420 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
421
422 /* configure i2c pins: sda */
423 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
424 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
425
426 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
427
428 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
429 }
430}
431
437void mclk_tmr1_init(void)
438{
439 gpio_init_type gpio_init_struct;
440 tmr_output_config_type tmr_oc_init_structure;
441 uint16_t prescaler_value = (uint16_t)(system_core_clock / 24000000) - 1;
442
443 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
444 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
445 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
446
447 gpio_default_para_init(&gpio_init_struct);
448
449
450 gpio_init_struct.gpio_pins = GPIO_PINS_8;
451 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
452 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
453 gpio_init(GPIOA, &gpio_init_struct);
454
455 tmr_base_init(TMR1, 1, prescaler_value);
456 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
457 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
458
459 tmr_output_default_para_init(&tmr_oc_init_structure);
460 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
461 tmr_oc_init_structure.oc_idle_state = FALSE;
462 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
463 tmr_oc_init_structure.oc_output_state = TRUE;
464 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
465 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 1);
466 tmr_output_channel_buffer_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
467
468 /* tmr enable counter */
469 tmr_counter_enable(TMR1, TRUE);
470 tmr_output_enable(TMR1, TRUE);
471}
472
473
479void codec_i2s_reset(void)
480{
481 i2s_enable(SPI1, FALSE);
482 i2s_enable(SPI2, FALSE);
483 dma_channel_enable(DMA1_CHANNEL3, FALSE);
484 dma_channel_enable(DMA1_CHANNEL4, FALSE);
485}
486
493void codec_i2s_init(audio_codec_type *param)
494{
495 gpio_init_type gpio_init_struct;
496 dma_init_type dma_init_struct;
497 i2s_init_type i2s_init_struct;
498 i2s_data_channel_format_type format = I2S_DATA_16BIT_CHANNEL_16BIT;
499
500 crm_periph_clock_enable(I2S1_GPIO_CRM_CLK, TRUE);
501 crm_periph_clock_enable(I2S2_GPIO_CRM_CLK, TRUE);
502 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
503 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
504 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
505
506 param->spk_freq = param->audio_freq;
507
508 param->spk_tx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_SPK_CHANEL_NUM / 2;
509 param->mic_rx_size = (param->audio_freq / 1000) * (param->audio_bitw / 8) * AUDIO_MIC_CHANEL_NUM / 2;
510
511 memset(param->spk_buffer, 0, SPK_BUFFER_SIZE*sizeof(uint16_t));
512 memset(param->mic_buffer, 0, MIC_BUFFER_SIZE*sizeof(uint16_t));
513
514 param->mic_wend = param->mic_woff = param->mic_roff = param->mic_buffer;
515 param->spk_rend = param->spk_woff = param->spk_roff = param->spk_buffer;
516
517 while(param->mic_wend < param->mic_buffer+MIC_BUFFER_SIZE)
518 {
519 param->mic_wend += param->mic_rx_size;
520 }
521 param->mic_wend -= param->mic_rx_size;
522 while(param->spk_rend < param->spk_buffer+SPK_BUFFER_SIZE)
523 {
524 param->spk_rend += param->spk_tx_size;
525 }
526 param->spk_rend -= param->spk_tx_size;
527 if(param->audio_bitw == 16)
528 {
529 format = I2S_DATA_16BIT_CHANNEL_16BIT;
530 }
531 else
532 {
533 format = I2S_DATA_24BIT_CHANNEL_32BIT;
534 }
535
536 gpio_default_para_init(&gpio_init_struct);
537
538 /* i2s1 ws pins */
539 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
540 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
541 gpio_init_struct.gpio_pins = I2S1_WS_PIN;
542 gpio_init(I2S1_GPIO, &gpio_init_struct);
543
544 /* i2s1 ck pins */
545 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
546 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
547 gpio_init_struct.gpio_pins = I2S1_CK_PIN;
548 gpio_init(I2S1_GPIO, &gpio_init_struct);
549
550 /* i2s1 sd pins slave tx */
551 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
552 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
553 gpio_init_struct.gpio_pins = I2S1_SD_PIN;
554 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
555 gpio_init(I2S1_GPIO, &gpio_init_struct);
556
557 /* i2s2 ws pins */
558 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
559 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
560 gpio_init_struct.gpio_pins = I2S2_WS_PIN;
561 gpio_init(I2S2_GPIO, &gpio_init_struct);
562
563 /* i2s2 ck pins */
564 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
565 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
566 gpio_init_struct.gpio_pins = I2S2_CK_PIN;
567 gpio_init(I2S2_GPIO, &gpio_init_struct);
568
569 /* i2s2 sd pins slave rx */
570 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
571 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
572 gpio_init_struct.gpio_pins = I2S2_SD_PIN;
573 gpio_init(I2S2_GPIO, &gpio_init_struct);
574
575 /* dma config */
576 dma_reset(DMA1_CHANNEL3);
577 dma_reset(DMA1_CHANNEL4);
578
579 /* dma1 channel3: speaker i2s1 tx */
580 dma_default_para_init(&dma_init_struct);
581 dma_init_struct.buffer_size = param->spk_tx_size << 1;
582 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
583 dma_init_struct.memory_base_addr = (uint32_t)spk_dma_buffer;
584 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
585 dma_init_struct.memory_inc_enable = TRUE;
586 dma_init_struct.peripheral_base_addr = (uint32_t)I2S1_DT_ADDRESS;
587 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
588 dma_init_struct.peripheral_inc_enable = FALSE;
589 dma_init_struct.priority = DMA_PRIORITY_HIGH;
590 dma_init_struct.loop_mode_enable = TRUE;
591 dma_init(DMA1_CHANNEL3, &dma_init_struct);
592 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
593 dma_interrupt_enable(DMA1_CHANNEL3, DMA_HDT_INT, TRUE);
594 nvic_irq_enable(DMA1_Channel3_IRQn, 1, 0);
595
596 /* dma1 channel4: microphone i2s2 rx */
597 dma_default_para_init(&dma_init_struct);
598 dma_init_struct.buffer_size = param->mic_rx_size << 1;
599 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
600 dma_init_struct.memory_base_addr = (uint32_t)mic_dma_buffer;
601 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
602 dma_init_struct.memory_inc_enable = TRUE;
603 dma_init_struct.peripheral_base_addr = (uint32_t)I2S2_DT_ADDRESS;
604 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
605 dma_init_struct.peripheral_inc_enable = FALSE;
606 dma_init_struct.priority = DMA_PRIORITY_HIGH;
607 dma_init_struct.loop_mode_enable = TRUE;
608 dma_init(DMA1_CHANNEL4, &dma_init_struct);
609 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
610 dma_interrupt_enable(DMA1_CHANNEL4, DMA_HDT_INT, TRUE);
611 nvic_irq_enable(DMA1_Channel4_IRQn, 2, 0);
612
613 /* i2s1 tx init */
614 spi_i2s_reset(SPI1);
615 i2s_default_para_init(&i2s_init_struct);
616 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
617 i2s_init_struct.data_channel_format = format;
618 i2s_init_struct.mclk_output_enable = FALSE;
619 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
620 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
621 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_TX;
622 i2s_init(SPI1, &i2s_init_struct);
623
624 /* i2s2 rx init */
625 spi_i2s_reset(SPI2);
626 i2s_default_para_init(&i2s_init_struct);
627 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
628 i2s_init_struct.data_channel_format = format;
629 i2s_init_struct.mclk_output_enable = FALSE;
630 i2s_init_struct.audio_sampling_freq = (i2s_audio_sampling_freq_type)param->audio_freq;
631 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
632 i2s_init_struct.operation_mode = I2S_MODE_SLAVE_RX;
633 i2s_init(SPI2, &i2s_init_struct);
634
635
636 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
637 spi_i2s_dma_receiver_enable(SPI2, TRUE);
638 i2s_enable(SPI1, TRUE);
639 i2s_enable(SPI2, TRUE);
640
641 dma_channel_enable(DMA1_CHANNEL3, TRUE);
642 dma_channel_enable(DMA1_CHANNEL4, TRUE);
643
644}
645
651void DMA1_Channel3_IRQHandler(void)
652{
653 uint16_t half_size = audio_codec.spk_tx_size;
654 uint16_t *pdst;
655
656 if(dma_flag_get(DMA1_HDT3_FLAG) == SET)
657 {
658 //copy_buff(audio_codec.spk_buffer, audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
659 pdst = spk_dma_buffer;
660 dma_flag_clear(DMA1_HDT3_FLAG);
661 }
662 else if(dma_flag_get(DMA1_FDT3_FLAG) == SET)
663 {
664 //copy_buff(&audio_codec.spk_buffer[half_size], audio_codec.spk_tx_fifo + audio_codec.r_pos, half_size);
665 pdst = spk_dma_buffer + half_size;
666 dma_flag_clear(DMA1_FDT3_FLAG);
667 }
668
669 switch( audio_codec.spk_stage )
670 {
671 case 0:
672 case 1:
673 memset( pdst, 0, half_size << 1);
674 break;
675 case 2:
676 if( audio_codec.spk_wtotal >= audio_codec.spk_rtotal + SPK_BUFFER_SIZE )
677 {
678 while(1);//should not happen;
679 }
680 if( audio_codec.spk_rtotal >= audio_codec.spk_wtotal )
681 {
682 audio_codec.spk_stage = 0;
683 audio_codec.spk_woff = audio_codec.spk_roff = audio_codec.spk_buffer;
684 audio_codec.spk_rtotal = audio_codec.spk_wtotal = 0;
685 }
686 else
687 {
688 memcpy( pdst, audio_codec.spk_roff, half_size << 1 );
689 audio_codec.spk_roff += half_size;
690 audio_codec.spk_rtotal += half_size;
691 if( audio_codec.spk_roff >= audio_codec.spk_rend )
692 {
693 audio_codec.spk_roff = audio_codec.spk_buffer;
694 }
695 if( ++audio_codec.spk_calc == 256 )
696 {
697 uint16_t delta = audio_codec.spk_wtotal - audio_codec.spk_rtotal;
698 audio_codec.spk_calc = 0;
699 if( delta < audio_codec.spk_threshold - half_size )
700 {
701 audio_codec.spk_threshold -= half_size;
702 audio_codec.spk_freq += audio_codec.audio_freq/1024;
703 }
704 else if( delta > audio_codec.spk_threshold + half_size )
705 {
706 audio_codec.spk_threshold += half_size;
707 audio_codec.spk_freq -= audio_codec.audio_freq/1024;
708 }
709 if(audio_codec.spk_rtotal > 0x20000000)
710 {
711 audio_codec.spk_rtotal -= 0x10000000;
712 audio_codec.spk_wtotal -= 0x10000000;
713 }
714 }
715 }
716 break;
717 }
718
719}
720
726void DMA1_Channel4_IRQHandler(void)
727{
728 uint16_t *psrc;
729 uint16_t len = audio_codec.mic_rx_size << 1;
730
731 if(dma_flag_get(DMA1_HDT4_FLAG) == SET)
732 {
733 dma_flag_clear(DMA1_HDT4_FLAG);
734 psrc = mic_dma_buffer;
735 }
736 else if(dma_flag_get(DMA1_FDT4_FLAG) == SET)
737 {
738 psrc = mic_dma_buffer + audio_codec.mic_rx_size;
739 dma_flag_clear(DMA1_FDT4_FLAG);
740 }
741 if( audio_codec.mic_stage )
742 {
743 memcpy( audio_codec.mic_woff, psrc, len );
744 audio_codec.mic_woff += len/2;
745 audio_codec.mic_wtotal += len/2;
746 if( audio_codec.mic_woff >= audio_codec.mic_wend )
747 {
748 audio_codec.mic_woff = audio_codec.mic_buffer;
749 }
750 if( audio_codec.mic_stage == 2 )
751 {
752 if( 1024 == ++audio_codec.mic_calc )
753 {
754 uint32_t size_estimate = 1024*audio_codec.mic_rx_size;
755 audio_codec.mic_calc = 0;
756 if( audio_codec.mic_delta > size_estimate )
757 {
758 audio_codec.mic_adj_count = audio_codec.mic_delta - size_estimate;
759 audio_codec.mic_adj_stage = 2;
760 }
761 else if( audio_codec.mic_delta < size_estimate )
762 {
763 audio_codec.mic_adj_count = size_estimate - audio_codec.mic_delta;
764 audio_codec.mic_adj_stage = 1;
765 }
766 else
767 {
768 audio_codec.mic_adj_count = 0;
769 audio_codec.mic_adj_stage = 0;
770 }
771 audio_codec.mic_delta = 0;
772 if( audio_codec.mic_rtotal >= 0x80000000 )
773 {
774 audio_codec.mic_rtotal -= 0x80000000;
775 audio_codec.mic_wtotal -= 0x80000000;
776 }
777 }
778 if( audio_codec.mic_wtotal >= audio_codec.mic_rtotal + MIC_BUFFER_SIZE )
779 {
780 audio_codec.mic_delta = audio_codec.mic_wtotal = audio_codec.mic_rtotal = 0;
781 audio_codec.mic_woff = audio_codec.mic_roff = audio_codec.mic_buffer;
782 audio_codec.mic_stage = 0;
783 audio_codec.mic_adj_stage = 0;
784 audio_codec.mic_adj_count = 0;
785 audio_codec.mic_calc = 0;
786 }
787 }
788 }
789}
790
796 error_status audio_codec_init(void)
797{
798 uint32_t reg_len = sizeof(reg_addr_data) / sizeof(uint16_t);
799 uint32_t i_index = 0;
800 uint8_t i2c_cmd[2];
801
802 if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_16K)
803 {
804 reg_addr_data[6] = WM8988_REG_FREQ16K;
805 audio_codec.audio_freq = AUDIO_FREQ_16K;
806 }
807 else if(AUDIO_DEFAULT_FREQ == AUDIO_FREQ_48K)
808 {
809 reg_addr_data[6] = WM8988_REG_FREQ48K;
810 audio_codec.audio_freq = AUDIO_FREQ_48K;
811 }
812 else
813 {
814 return ERROR;
815 }
816
817 if(AUDIO_DEFAULT_BITW == AUDIO_BITW_16)
818 {
819 reg_addr_data[5] = WM8988_REG_BITW16;
820 audio_codec.audio_bitw = AUDIO_BITW_16;
821 }
822 else
823 {
824 return ERROR;
825 }
826
827 /* i2c init */
828 hi2cx.i2cx = I2Cx_PORT;
829
830 i2c_config(&hi2cx);
831
832 for(i_index = 0; i_index < reg_len; i_index ++)
833 {
834 i2c_cmd[0] = (uint8_t)(reg_addr_data[i_index] >> 8);
835 i2c_cmd[1] = (uint8_t)reg_addr_data[i_index] & 0xFF;
836 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
837 {
838 return ERROR;
839 }
840 }
841
842 /* timer init */
843 mclk_tmr1_init();
844
845 codec_i2s_init(&audio_codec);
846
847 return SUCCESS;
848}
849
855 error_status audio_codec_loop(void)
856{
857 static uint8_t mic_mute = 0;
858 static uint16_t mic_volume = 0;
859 static uint8_t spk_mute = 0;
860 static uint16_t spk_volume = 0;
861 uint16_t audio_ctrl_l;
862 uint16_t audio_ctrl_r;
863 uint8_t i2c_cmd[2];
864
865 if(mic_mute != audio_codec.mic_mute)
866 {
867 mic_mute = audio_codec.mic_mute;
868 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
869 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
870 if(audio_codec.mic_mute == 0)
871 {
872 audio_ctrl_l |= audio_codec.mic_volume;
873 audio_ctrl_r |= audio_codec.mic_volume;
874 }
875 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
876 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
877 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
878 {
879 return ERROR;
880 }
881 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
882 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
883 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
884 {
885 return ERROR;
886 }
887 }
888
889 if(mic_volume != audio_codec.mic_volume)
890 {
891 mic_volume = audio_codec.mic_volume;
892 audio_ctrl_l = WM8988_R21_LEFT_ADC_VOLUME << 9 | 0x100;
893 audio_ctrl_r = WM8988_R22_RIGHT_ADC_VOLUME << 9 | 0x100;
894 audio_ctrl_l |= audio_codec.mic_volume;
895 audio_ctrl_r |= audio_codec.mic_volume;
896 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
897 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
898 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
899 {
900 return ERROR;
901 }
902 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
903 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
904 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
905 {
906 return ERROR;
907 }
908 }
909
910 if(spk_mute != audio_codec.spk_mute)
911 {
912 spk_mute = audio_codec.spk_mute;
913 audio_ctrl_l = (WM8988_R5_ADC_DAC_CONTROL << 9) | 0x0006 | (audio_codec.spk_mute << 3);
914 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
915 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
916 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
917 {
918 return ERROR;
919 }
920 }
921
922 if(spk_volume != audio_codec.spk_volume)
923 {
924 spk_volume = audio_codec.spk_volume;
925 audio_ctrl_l = WM8988_R2_LOUT1_VOLUME << 9 | 0x100;
926 audio_ctrl_r = WM8988_R3_ROUT1_VOLUME << 9 | 0x100;
927 audio_ctrl_l |= audio_codec.spk_volume;
928 audio_ctrl_r |= audio_codec.spk_volume;
929
930 i2c_cmd[0] = (uint8_t)(audio_ctrl_l >> 8);
931 i2c_cmd[1] = (uint8_t)audio_ctrl_l & 0xFF;
932
933 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
934 {
935 return ERROR;
936 }
937 i2c_cmd[0] = (uint8_t)(audio_ctrl_r >> 8);
938 i2c_cmd[1] = (uint8_t)audio_ctrl_r & 0xFF;
939 if(i2c_master_transmit(&hi2cx, WM8988_I2C_ADDR_CSB_LOW, (uint8_t *)i2c_cmd, 2, 0xFFFF) != I2C_OK)
940 {
941 return ERROR;
942 }
943 }
944 return SUCCESS;
945}
946
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:38
reg_addr_data
uint16_t reg_addr_data[]
wm8988 register default value
Definition: composite_audio_hid/src/audio_codec.c:71
audio_codec_mic_alt_setting
void audio_codec_mic_alt_setting(uint32_t alt_seting)
audio codec microphone alt setting config
Definition: composite_audio_hid/src/audio_codec.c:169
codec_i2s_reset
void codec_i2s_reset(void)
audio codec i2s reset
Definition: composite_audio_hid/src/audio_codec.c:479
spk_dma_buffer
uint16_t spk_dma_buffer[DMA_BUFFER_SIZE]
Definition: composite_audio_hid/src/audio_codec.c:107
audio_codec_set_spk_volume
void audio_codec_set_spk_volume(uint16_t volume)
audio codec set speaker volume
Definition: composite_audio_hid/src/audio_codec.c:217
audio_codec_set_spk_mute
void audio_codec_set_spk_mute(uint8_t mute)
audio codec set speaker mute
Definition: composite_audio_hid/src/audio_codec.c:195
WM8988_REG_FREQ48K
#define WM8988_REG_FREQ48K
wm8988 freq
Definition: composite_audio_hid/src/audio_codec.c:60
audio_codec_set_mic_freq
void audio_codec_set_mic_freq(uint32_t freq)
audio codec set microphone freq
Definition: composite_audio_hid/src/audio_codec.c:121
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: composite_audio_hid/src/audio_codec.c:44
I2Cx_CLK
#define I2Cx_CLK
Definition: composite_audio_hid/src/audio_codec.c:47
audio_codec_mic_get_data
uint32_t audio_codec_mic_get_data(uint8_t *buffer)
codec microphone get data
Definition: composite_audio_hid/src/audio_codec.c:282
WM8988_REG_BITW16
#define WM8988_REG_BITW16
wm8988 bit width
Definition: composite_audio_hid/src/audio_codec.c:66
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: composite_audio_hid/src/audio_codec.c:855
codec_i2s_init
void codec_i2s_init(audio_codec_type *param)
audio codec i2s init
Definition: composite_audio_hid/src/audio_codec.c:493
audio_codec_set_mic_mute
void audio_codec_set_mic_mute(uint8_t mute)
audio codec set microphone mute
Definition: composite_audio_hid/src/audio_codec.c:184
audio_codec_spk_fifo_write
void audio_codec_spk_fifo_write(uint8_t *data, uint32_t len)
codec speaker write fifo
Definition: composite_audio_hid/src/audio_codec.c:244
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: composite_audio_hid/src/audio_codec.c:53
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: composite_audio_hid/src/audio_codec.c:49
mic_dma_buffer
uint16_t mic_dma_buffer[DMA_BUFFER_SIZE]
Definition: composite_audio_hid/src/audio_codec.c:108
audio_codec_spk_feedback
uint8_t audio_codec_spk_feedback(uint8_t *feedback)
codec speaker feedback
Definition: composite_audio_hid/src/audio_codec.c:228
hi2cx
i2c_handle_type hi2cx
Definition: composite_audio_hid/src/audio_codec.c:104
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 interrupt.
Definition: composite_audio_hid/src/audio_codec.c:726
audio_codec_modify_freq
void audio_codec_modify_freq(uint32_t freq)
audio codec modify freq
Definition: composite_audio_hid/src/audio_codec.c:342
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: composite_audio_hid/src/audio_codec.c:54
audio_codec_set_mic_volume
void audio_codec_set_mic_volume(uint16_t volume)
audio codec set microphone volume
Definition: composite_audio_hid/src/audio_codec.c:206
mclk_tmr1_init
void mclk_tmr1_init(void)
mclk clock conifg
Definition: composite_audio_hid/src/audio_codec.c:437
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 interrupt.
Definition: composite_audio_hid/src/audio_codec.c:651
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: composite_audio_hid/src/audio_codec.c:55
audio_codec
audio_codec_type audio_codec
Definition: composite_audio_hid/src/audio_codec.c:106
audio_codec_spk_alt_setting
void audio_codec_spk_alt_setting(uint32_t alt_seting)
audio codec speaker alt setting config
Definition: composite_audio_hid/src/audio_codec.c:154
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: composite_audio_hid/src/audio_codec.c:399
I2Cx_SPEED
#define I2Cx_SPEED
Definition: composite_audio_hid/src/audio_codec.c:43
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: composite_audio_hid/src/audio_codec.c:796
WM8988_REG_FREQ16K
#define WM8988_REG_FREQ16K
Definition: composite_audio_hid/src/audio_codec.c:61
copy_buff
void copy_buff(uint16_t *dest, uint16_t *src, uint32_t len)
copy buffer
Definition: composite_audio_hid/src/audio_codec.c:385
memset16_buffer
void memset16_buffer(uint16_t *buffer, uint32_t set, uint32_t len)
buffer memset
Definition: composite_audio_hid/src/audio_codec.c:369
I2Cx_PORT
#define I2Cx_PORT
Definition: composite_audio_hid/src/audio_codec.c:46
audio_codec_set_spk_freq
void audio_codec_set_spk_freq(uint32_t freq)
audio codec set speaker freq
Definition: composite_audio_hid/src/audio_codec.c:137
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: composite_audio_hid/src/audio_codec.c:51
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: composite_audio_hid/src/audio_codec.c:50
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:112
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:412
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f413.h:146
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f413.h:147
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA1_HDT4_FLAG
#define DMA1_HDT4_FLAG
Definition: at32f413_dma.h:95
DMA1_HDT3_FLAG
#define DMA1_HDT3_FLAG
Definition: at32f413_dma.h:91
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:94
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:90
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA_HDT_INT
#define DMA_HDT_INT
Definition: at32f413_dma.h:53
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:482
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:483
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:226
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:236
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:185
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:90
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:148
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:157
I2C_OK
@ I2C_OK
Definition: i2c_application.h:82
I2C1_MUX
#define I2C1_MUX
Definition: at32f413_gpio.h:82
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:316
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:499
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:445
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:298
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:485
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f413_spi.h:226
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f413_spi.h:209
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:249
I2S_DATA_16BIT_CHANNEL_16BIT
@ I2S_DATA_16BIT_CHANNEL_16BIT
Definition: at32f413_spi.h:227
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:229
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:198
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:239
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:238
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:609
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
MIC_BUFFER_SIZE
#define MIC_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:127
SPK_BUFFER_SIZE
#define SPK_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:128
DMA_BUFFER_SIZE
#define DMA_BUFFER_SIZE
Definition: audio/inc/audio_codec.h:129
I2S2_DT_ADDRESS
#define I2S2_DT_ADDRESS
Definition: audio/inc/audio_codec.h:116
I2S1_SD_PIN
#define I2S1_SD_PIN
Definition: audio/inc/audio_codec.h:105
I2S1_CK_PIN
#define I2S1_CK_PIN
Definition: audio/inc/audio_codec.h:104
I2S2_GPIO
#define I2S2_GPIO
Definition: audio/inc/audio_codec.h:114
I2S2_SD_PIN
#define I2S2_SD_PIN
Definition: audio/inc/audio_codec.h:113
I2S2_WS_PIN
#define I2S2_WS_PIN
Definition: audio/inc/audio_codec.h:111
I2S2_GPIO_CRM_CLK
#define I2S2_GPIO_CRM_CLK
Definition: audio/inc/audio_codec.h:115
I2S1_DT_ADDRESS
#define I2S1_DT_ADDRESS
Definition: audio/inc/audio_codec.h:108
I2S1_GPIO_CRM_CLK
#define I2S1_GPIO_CRM_CLK
Definition: audio/inc/audio_codec.h:107
I2S1_WS_PIN
#define I2S1_WS_PIN
Definition: audio/inc/audio_codec.h:103
I2S1_GPIO
#define I2S1_GPIO
Definition: audio/inc/audio_codec.h:106
I2S2_CK_PIN
#define I2S2_CK_PIN
Definition: audio/inc/audio_codec.h:112
WM8988_R27_ADDITIONAL_3_CONTROL
#define WM8988_R27_ADDITIONAL_3_CONTROL
Definition: audio/inc/audio_codec.h:77
WM8988_I2C_ADDR_CSB_LOW
#define WM8988_I2C_ADDR_CSB_LOW
Definition: audio/inc/audio_codec.h:93
WM8988_R10_LEFT_DAC_VOLUME
#define WM8988_R10_LEFT_DAC_VOLUME
Definition: audio/inc/audio_codec.h:60
WM8988_R1_RIGHT_INPUT_VOLUME
#define WM8988_R1_RIGHT_INPUT_VOLUME
Definition: audio/inc/audio_codec.h:51
WM8988_R3_ROUT1_VOLUME
#define WM8988_R3_ROUT1_VOLUME
Definition: audio/inc/audio_codec.h:53
WM8988_R36_RIGHT_OUT_MIX_1
#define WM8988_R36_RIGHT_OUT_MIX_1
Definition: audio/inc/audio_codec.h:84
WM8988_R21_LEFT_ADC_VOLUME
#define WM8988_R21_LEFT_ADC_VOLUME
Definition: audio/inc/audio_codec.h:71
WM8988_R31_ADC_INPUT_MODE
#define WM8988_R31_ADC_INPUT_MODE
Definition: audio/inc/audio_codec.h:79
WM8988_R13_TREBLE_CONTROL
#define WM8988_R13_TREBLE_CONTROL
Definition: audio/inc/audio_codec.h:63
WM8988_R16_3D_CONTROL
#define WM8988_R16_3D_CONTROL
Definition: audio/inc/audio_codec.h:66
WM8988_R22_RIGHT_ADC_VOLUME
#define WM8988_R22_RIGHT_ADC_VOLUME
Definition: audio/inc/audio_codec.h:72
WM8988_R0_LEFT_INPUT_VOLUME
#define WM8988_R0_LEFT_INPUT_VOLUME
Definition: audio/inc/audio_codec.h:50
WM8988_R23_ADDITIONAL_1_CONTROL
#define WM8988_R23_ADDITIONAL_1_CONTROL
Definition: audio/inc/audio_codec.h:73
WM8988_R35_LEFT_OUT_MIX_2
#define WM8988_R35_LEFT_OUT_MIX_2
Definition: audio/inc/audio_codec.h:83
WM8988_R43_LOW_POWER_PALYBACK
#define WM8988_R43_LOW_POWER_PALYBACK
Definition: audio/inc/audio_codec.h:91
WM8988_R32_ADC_L_SIGNAL_PATH
#define WM8988_R32_ADC_L_SIGNAL_PATH
Definition: audio/inc/audio_codec.h:80
WM8988_R26_PWR_2_MGMT
#define WM8988_R26_PWR_2_MGMT
Definition: audio/inc/audio_codec.h:76
WM8988_R11_RIGHT_DAC_VOLUME
#define WM8988_R11_RIGHT_DAC_VOLUME
Definition: audio/inc/audio_codec.h:61
WM8988_R24_ADDITIONAL_2_CONTROL
#define WM8988_R24_ADDITIONAL_2_CONTROL
Definition: audio/inc/audio_codec.h:74
WM8988_R40_LOUT2_VOLUME
#define WM8988_R40_LOUT2_VOLUME
Definition: audio/inc/audio_codec.h:88
WM8988_R34_LEFT_OUT_MIX_1
#define WM8988_R34_LEFT_OUT_MIX_1
Definition: audio/inc/audio_codec.h:82
WM8988_R5_ADC_DAC_CONTROL
#define WM8988_R5_ADC_DAC_CONTROL
Definition: audio/inc/audio_codec.h:55
WM8988_R25_PWR_1_MGMT
#define WM8988_R25_PWR_1_MGMT
Definition: audio/inc/audio_codec.h:75
WM8988_R41_ROUT2_VOLUME
#define WM8988_R41_ROUT2_VOLUME
Definition: audio/inc/audio_codec.h:89
WM8988_R2_LOUT1_VOLUME
#define WM8988_R2_LOUT1_VOLUME
Definition: audio/inc/audio_codec.h:52
WM8988_R37_RIGHT_OUT_MIX_2
#define WM8988_R37_RIGHT_OUT_MIX_2
Definition: audio/inc/audio_codec.h:85
WM8988_R33_ADC_R_SIGNAL_PATH
#define WM8988_R33_ADC_R_SIGNAL_PATH
Definition: audio/inc/audio_codec.h:81
WM8988_R12_BASS_CONTROL
#define WM8988_R12_BASS_CONTROL
Definition: audio/inc/audio_codec.h:62
AUDIO_BITW_16
#define AUDIO_BITW_16
Definition: audio/audio_conf.h:61
AUDIO_MIC_CHANEL_NUM
#define AUDIO_MIC_CHANEL_NUM
Definition: audio/audio_conf.h:63
AUDIO_DEFAULT_FREQ
#define AUDIO_DEFAULT_FREQ
Definition: audio/audio_conf.h:71
AUDIO_FREQ_16K
#define AUDIO_FREQ_16K
Definition: audio/audio_conf.h:59
AUDIO_SPK_CHANEL_NUM
#define AUDIO_SPK_CHANEL_NUM
Definition: audio/audio_conf.h:66
AUDIO_DEFAULT_BITW
#define AUDIO_DEFAULT_BITW
Definition: audio/audio_conf.h:72
AUDIO_FREQ_48K
#define AUDIO_FREQ_48K
Definition: audio/audio_conf.h:60
i2c_application.h
i2c application libray header file
audio_codec_type
Definition: audio/inc/audio_codec.h:132
audio_codec_type::spk_mute
uint8_t spk_mute
Definition: audio/inc/audio_codec.h:161
audio_codec_type::spk_threshold
uint16_t spk_threshold
Definition: audio/inc/audio_codec.h:143
audio_codec_type::spk_stage
uint8_t spk_stage
Definition: audio/inc/audio_codec.h:145
audio_codec_type::mic_roff
uint16_t * mic_roff
Definition: audio/inc/audio_codec.h:149
audio_codec_type::spk_buffer
uint16_t spk_buffer[4096]
Definition: audio/inc/audio_codec.h:136
audio_codec_type::mic_volume
uint16_t mic_volume
Definition: audio/inc/audio_codec.h:163
audio_codec_type::spk_roff
uint16_t * spk_roff
Definition: audio/inc/audio_codec.h:137
audio_codec_type::spk_rtotal
uint32_t spk_rtotal
Definition: audio/inc/audio_codec.h:142
audio_codec_type::mic_delta
uint32_t mic_delta
Definition: audio/inc/audio_codec.h:154
audio_codec_type::spk_calc
uint16_t spk_calc
Definition: audio/inc/audio_codec.h:144
audio_codec_type::mic_woff
uint16_t * mic_woff
Definition: audio/inc/audio_codec.h:150
audio_codec_type::mic_stage
uint8_t mic_stage
Definition: audio/inc/audio_codec.h:158
audio_codec_type::mic_adj_count
uint16_t mic_adj_count
Definition: audio/inc/audio_codec.h:156
audio_codec_type::spk_freq
uint32_t spk_freq
Definition: audio/inc/audio_codec.h:140
audio_codec_type::audio_bitw
uint32_t audio_bitw
Definition: audio/inc/audio_codec.h:134
audio_codec_type::mic_wend
uint16_t * mic_wend
Definition: audio/inc/audio_codec.h:151
audio_codec_type::spk_rend
uint16_t * spk_rend
Definition: audio/inc/audio_codec.h:139
audio_codec_type::mic_wtotal
uint32_t mic_wtotal
Definition: audio/inc/audio_codec.h:152
audio_codec_type::mic_rtotal
uint32_t mic_rtotal
Definition: audio/inc/audio_codec.h:153
audio_codec_type::audio_freq
uint32_t audio_freq
Definition: audio/inc/audio_codec.h:133
audio_codec_type::mic_mute
uint8_t mic_mute
Definition: audio/inc/audio_codec.h:160
audio_codec_type::spk_volume
uint16_t spk_volume
Definition: audio/inc/audio_codec.h:164
audio_codec_type::mic_calc
uint16_t mic_calc
Definition: audio/inc/audio_codec.h:155
audio_codec_type::spk_wtotal
uint32_t spk_wtotal
Definition: audio/inc/audio_codec.h:141
audio_codec_type::mic_adj_stage
uint8_t mic_adj_stage
Definition: audio/inc/audio_codec.h:157
audio_codec_type::spk_tx_size
uint32_t spk_tx_size
Definition: audio/inc/audio_codec.h:166
audio_codec_type::mic_rx_size
uint32_t mic_rx_size
Definition: audio/inc/audio_codec.h:167
audio_codec_type::spk_woff
uint16_t * spk_woff
Definition: audio/inc/audio_codec.h:138
audio_codec_type::mic_buffer
uint16_t mic_buffer[1024]
Definition: audio/inc/audio_codec.h:148
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
i2c_handle_type
Definition: i2c_application.h:114
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:115
i2s_init_type
i2s init type
Definition: at32f413_spi.h:272
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:275
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:276
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:278
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:274
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:273
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:277
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402


AT32F413 Firmwary Library: msc_bot_scsi.c Source File

  • middlewares
  • usbd_class
  • composite_cdc_msc
composite_cdc_msc/msc_bot_scsi.c
Go to the documentation of this file.
1
26#include "cdc_msc_class.h"
27#include "msc_diskio.h"
28
43#if defined ( __ICCARM__ ) /* iar compiler */
44 #pragma data_alignment=4
45#endif
46ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL = {
47 0x00,
48 0x00,
49 0x00,
50 0x00,
51 0x00,
52
53};
54#if defined ( __ICCARM__ ) /* iar compiler */
55 #pragma data_alignment=4
56#endif
57ALIGNED_HEAD sense_type sense_data ALIGNED_TAIL =
58{
59 0x70,
60 0x00,
61 SENSE_KEY_ILLEGAL_REQUEST,
62 0x00000000,
63 0x0A,
64 0x00000000,
65 0x20,
66 0x00,
67 0x00000000
68};
69
70#if defined ( __ICCARM__ ) /* iar compiler */
71 #pragma data_alignment=4
72#endif
73ALIGNED_HEAD uint8_t mode_sense6_data[8] ALIGNED_TAIL =
74{
75 0x00,
76 0x00,
77 0x00,
78 0x00,
79 0x00,
80 0x00,
81 0x00,
82 0x00
83};
84
85#if defined ( __ICCARM__ ) /* iar compiler */
86 #pragma data_alignment=4
87#endif
88ALIGNED_HEAD uint8_t mode_sense10_data[8] ALIGNED_TAIL =
89{
90 0x00,
91 0x06,
92 0x00,
93 0x00,
94 0x00,
95 0x00,
96 0x00,
97 0x00
98};
104void bot_scsi_init(void *udev)
105{
106 usbd_core_type *pudev = (usbd_core_type *)udev;
107 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
108 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
109 pmsc->bot_status = MSC_BOT_STATE_IDLE;
110 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
111
112 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
113 pmsc->csw_struct.dCSWDataResidue = 0;
114 pmsc->csw_struct.dCSWSignature = 0;
115 pmsc->csw_struct.dCSWTag = CSW_BCSWSTATUS_PASS;
116
117 /* set out endpoint to receive status */
118 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
119}
120
126void bot_scsi_reset(void *udev)
127{
128 usbd_core_type *pudev = (usbd_core_type *)udev;
129 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
130 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
131 pmsc->bot_status = MSC_BOT_STATE_RECOVERY;
132 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
133
134 /* set out endpoint to receive status */
135 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
136}
137
144void bot_scsi_datain_handler(void *udev, uint8_t ept_num)
145{
146 usbd_core_type *pudev = (usbd_core_type *)udev;
147 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
148 switch(pmsc->msc_state)
149 {
150 case MSC_STATE_MACHINE_DATA_IN:
151 if(bot_scsi_cmd_process(udev) != USB_OK)
152 {
153 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
154 }
155 break;
156
157 case MSC_STATE_MACHINE_LAST_DATA:
158 case MSC_STATE_MACHINE_SEND_DATA:
159 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
160 break;
161
162 default:
163 break;
164 }
165}
166
173void bot_scsi_dataout_handler(void *udev, uint8_t ept_num)
174{
175 usbd_core_type *pudev = (usbd_core_type *)udev;
176 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
177 switch(pmsc->msc_state)
178 {
179 case MSC_STATE_MACHINE_IDLE:
180 bot_cbw_decode(udev);
181 break;
182
183 case MSC_STATE_MACHINE_DATA_OUT:
184 if(bot_scsi_cmd_process(udev) != USB_OK)
185 {
186 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
187 }
188 break;
189 }
190}
191
197void bot_cbw_decode(void *udev)
198{
199 usbd_core_type *pudev = (usbd_core_type *)udev;
200 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
201
202 pmsc->csw_struct.dCSWTag = pmsc->cbw_struct.dCBWTage;
203 pmsc->csw_struct.dCSWDataResidue = pmsc->cbw_struct.dCBWDataTransferLength;
204
205 /* check param */
206 if((pmsc->cbw_struct.dCBWSignature != CBW_DCBWSIGNATURE) ||
207 (usbd_get_recv_len(pudev, USBD_MSC_BULK_OUT_EPT) != CBW_CMD_LENGTH)
208 || (pmsc->cbw_struct.bCBWLUN > MSC_SUPPORT_MAX_LUN) ||
209 (pmsc->cbw_struct.bCBWCBLength < 1) || (pmsc->cbw_struct.bCBWCBLength > 16))
210 {
211 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
212 pmsc->bot_status = MSC_BOT_STATE_ERROR;
213 bot_scsi_stall(udev);
214 }
215 else
216 {
217 if(bot_scsi_cmd_process(udev) != USB_OK)
218 {
219 bot_scsi_stall(udev);
220 }
221 else if((pmsc->msc_state != MSC_STATE_MACHINE_DATA_IN) &&
222 (pmsc->msc_state != MSC_STATE_MACHINE_DATA_OUT) &&
223 (pmsc->msc_state != MSC_STATE_MACHINE_LAST_DATA))
224 {
225 if(pmsc->data_len == 0)
226 {
227 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
228 }
229 else if(pmsc->data_len > 0)
230 {
231 bot_scsi_send_data(udev, pmsc->data, pmsc->data_len);
232 }
233 }
234 }
235}
236
244void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
245{
246 usbd_core_type *pudev = (usbd_core_type *)udev;
247 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
248 uint32_t data_len = MIN(len, pmsc->cbw_struct.dCBWDataTransferLength);
249
250 pmsc->csw_struct.dCSWDataResidue -= data_len;
251 pmsc->csw_struct.bCSWStatus = CSW_BCSWSTATUS_PASS;
252
253 pmsc->msc_state = MSC_STATE_MACHINE_SEND_DATA;
254
255 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
256 buffer, data_len);
257}
258
265void bot_scsi_send_csw(void *udev, uint8_t status)
266{
267 usbd_core_type *pudev = (usbd_core_type *)udev;
268 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
269
270 pmsc->csw_struct.bCSWStatus = status;
271 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
272 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
273
274 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
275 (uint8_t *)&pmsc->csw_struct, CSW_CMD_LENGTH);
276
277 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
278 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
279}
280
281
289void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
290{
291 sense_data.sense_key = sense_key;
292 sense_data.asc = asc;
293}
294
295
304 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
305{
306 usbd_core_type *pudev = (usbd_core_type *)udev;
307 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
308 if((blk_offset + blk_count) > pmsc->blk_nbr[lun])
309 {
310 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, ADDRESS_OUT_OF_RANGE);
311 return USB_FAIL;
312 }
313 return USB_OK;
314}
315
321void bot_scsi_stall(void *udev)
322{
323 usbd_core_type *pudev = (usbd_core_type *)udev;
324 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
325
326 if((pmsc->cbw_struct.dCBWDataTransferLength != 0) &&
327 (pmsc->cbw_struct.bmCBWFlags == 0) &&
328 pmsc->bot_status == MSC_BOT_STATE_IDLE)
329 {
330 usbd_set_stall(pudev, USBD_MSC_BULK_OUT_EPT);
331 }
332 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
333
334 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
335 {
336 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
337 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
338 }
339}
340
347 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
348{
349 usb_sts_type status = USB_OK;
350 usbd_core_type *pudev = (usbd_core_type *)udev;
351 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
352
353 if(pmsc->cbw_struct.dCBWDataTransferLength != 0)
354 {
355 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
356 return USB_FAIL;
357 }
358
359 pmsc->data_len = 0;
360 return status;
361}
362
369 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
370{
371 uint8_t *pdata;
372 uint32_t trans_len = 0;
373 usb_sts_type status = USB_OK;
374 usbd_core_type *pudev = (usbd_core_type *)udev;
375 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
376
377 if(pmsc->cbw_struct.CBWCB[1] & 0x01)
378 {
379 pdata = page00_inquiry_data;
380 trans_len = 5;
381 }
382 else
383 {
384 pdata = get_inquiry(lun);
385 if(pmsc->cbw_struct.dCBWDataTransferLength < SCSI_INQUIRY_DATA_LENGTH)
386 {
387 trans_len = pmsc->cbw_struct.dCBWDataTransferLength;
388 }
389 else
390 {
391 trans_len = SCSI_INQUIRY_DATA_LENGTH;
392 }
393 }
394
395 pmsc->data_len = trans_len;
396 while(trans_len)
397 {
398 trans_len --;
399 pmsc->data[trans_len] = pdata[trans_len];
400 }
401 return status;
402}
403
410 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
411{
412 usbd_core_type *pudev = (usbd_core_type *)udev;
413 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
414 pmsc->data_len = 0;
415 return USB_OK;
416}
417
424 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
425{
426 usbd_core_type *pudev = (usbd_core_type *)udev;
427 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
428 pmsc->data_len = 0;
429 return USB_OK;
430}
431
438 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
439{
440 uint8_t data_len = 8;
441 usbd_core_type *pudev = (usbd_core_type *)udev;
442 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
443 pmsc->data_len = 8;
444 while(data_len)
445 {
446 data_len --;
447 pmsc->data[data_len] = mode_sense6_data[data_len];
448 };
449 return USB_OK;
450}
451
458 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
459{
460 uint8_t data_len = 8;
461 usbd_core_type *pudev = (usbd_core_type *)udev;
462 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
463 pmsc->data_len = 8;
464 while(data_len)
465 {
466 data_len --;
467 pmsc->data[data_len] = mode_sense10_data[data_len];
468 };
469 return USB_OK;
470}
471
478 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
479{
480 usbd_core_type *pudev = (usbd_core_type *)udev;
481 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
482 uint8_t *pdata = pmsc->data;
483 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
484
485 pdata[0] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
486 pdata[1] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
487 pdata[2] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
488 pdata[3] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
489
490 pdata[4] = (uint8_t)((pmsc->blk_size[lun]) >> 24);
491 pdata[5] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
492 pdata[6] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
493 pdata[7] = (uint8_t)((pmsc->blk_size[lun]));
494
495 pmsc->data_len = 8;
496 return USB_OK;
497}
498
505 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
506{
507 usbd_core_type *pudev = (usbd_core_type *)udev;
508 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
509 uint8_t *pdata = pmsc->data;
510
511 pdata[0] = 0;
512 pdata[1] = 0;
513 pdata[2] = 0;
514 pdata[3] = 0x08;
515
516 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
517
518 pdata[4] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
519 pdata[5] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
520 pdata[6] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
521 pdata[7] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
522
523 pdata[8] = 0x02;
524
525 pdata[9] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
526 pdata[10] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
527 pdata[11] = (uint8_t)((pmsc->blk_size[lun]));
528
529 pmsc->data_len = 12;
530
531 return USB_OK;
532}
533
540 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
541{
542 uint32_t trans_len = 0x12;
543 usbd_core_type *pudev = (usbd_core_type *)udev;
544 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
545 uint8_t *pdata = pmsc->data;
546 uint8_t *sdata = (uint8_t *)&sense_data;
547
548 while(trans_len)
549 {
550 trans_len --;
551 pdata[trans_len] = sdata[trans_len];
552 }
553
554 if(pmsc->cbw_struct.dCBWDataTransferLength < REQ_SENSE_STANDARD_DATA_LEN)
555 {
556 pmsc->data_len = pmsc->cbw_struct.dCBWDataTransferLength;
557 }
558 else
559 {
560 pmsc->data_len = REQ_SENSE_STANDARD_DATA_LEN;
561 }
562 return USB_OK;
563}
564
571 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
572{
573 usbd_core_type *pudev = (usbd_core_type *)udev;
574 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
575 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
576 if((pmsc->cbw_struct.CBWCB[1] & 0x02) == 0x02)
577 {
578 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_FIELED_IN_COMMAND);
579 return USB_FAIL;
580 }
581
582 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
583 pmsc->blk_len = cmd[7] << 8 | cmd[8];
584
585 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
586 {
587 return USB_FAIL;
588 }
589 pmsc->data_len = 0;
590 return USB_OK;
591}
592
599 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
600{
601 usbd_core_type *pudev = (usbd_core_type *)udev;
602 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
603 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
604 uint32_t len;
605
606 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
607 {
608 if((pmsc->cbw_struct.bmCBWFlags & 0x80) != 0x80)
609 {
610 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
611 return USB_FAIL;
612 }
613
614 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
615 pmsc->blk_len = cmd[7] << 8 | cmd[8];
616
617 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
618 {
619 return USB_FAIL;
620 }
621
622 pmsc->blk_addr *= pmsc->blk_size[lun];
623 pmsc->blk_len *= pmsc->blk_size[lun];
624
625 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
626 {
627 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
628 return USB_FAIL;
629 }
630 pmsc->msc_state = MSC_STATE_MACHINE_DATA_IN;
631 }
632 pmsc->data_len = MSC_MAX_DATA_BUF_LEN;
633
634 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
635 if( msc_disk_read(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
636 {
637 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
638 return USB_FAIL;
639 }
640 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT, pmsc->data, len);
641 pmsc->blk_addr += len;
642 pmsc->blk_len -= len;
643
644 pmsc->csw_struct.dCSWDataResidue -= len;
645 if(pmsc->blk_len == 0)
646 {
647 pmsc->msc_state = MSC_STATE_MACHINE_LAST_DATA;
648 }
649
650 return USB_OK;
651}
652
653
660 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
661{
662 usbd_core_type *pudev = (usbd_core_type *)udev;
663 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
664 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
665 uint32_t len;
666
667 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
668 {
669 if((pmsc->cbw_struct.bmCBWFlags & 0x80) == 0x80)
670 {
671 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
672 return USB_FAIL;
673 }
674
675 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
676 pmsc->blk_len = cmd[7] << 8 | cmd[8];
677
678 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
679 {
680 return USB_FAIL;
681 }
682
683 pmsc->blk_addr *= pmsc->blk_size[lun];
684 pmsc->blk_len *= pmsc->blk_size[lun];
685
686 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
687 {
688 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
689 return USB_FAIL;
690 }
691
692 pmsc->msc_state = MSC_STATE_MACHINE_DATA_OUT;
693 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
694 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
695
696 }
697 else
698 {
699 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
700 if(msc_disk_write(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
701 {
702 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
703 return USB_FAIL;
704 }
705
706 pmsc->blk_addr += len;
707 pmsc->blk_len -= len;
708
709 pmsc->csw_struct.dCSWDataResidue -= len;
710
711 if(pmsc->blk_len == 0)
712 {
713 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
714 }
715 else
716 {
717 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
718 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
719 }
720 }
721 return USB_OK;
722}
723
730void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
731{
732 usbd_core_type *pudev = (usbd_core_type *)udev;
733 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
734 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
735 {
736 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
737 pmsc->bot_status = MSC_BOT_STATE_IDLE;
738 }
739 else if(((ept_num & 0x80) == 0x80) && (pmsc->bot_status != MSC_BOT_STATE_RECOVERY))
740 {
741 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
742 }
743}
744
750 usb_sts_type bot_scsi_cmd_process(void *udev)
751{
752 usb_sts_type status = USB_FAIL;
753 usbd_core_type *pudev = (usbd_core_type *)udev;
754 cdc_msc_struct_type *pmsc = (cdc_msc_struct_type *)pudev->class_handler->pdata;
755 switch(pmsc->cbw_struct.CBWCB[0])
756 {
757 case MSC_CMD_INQUIRY:
758 status = bot_scsi_inquiry(udev, pmsc->cbw_struct.bCBWLUN);
759 break;
760
761 case MSC_CMD_START_STOP:
762 status = bot_scsi_start_stop(udev, pmsc->cbw_struct.bCBWLUN);
763 break;
764
765 case MSC_CMD_MODE_SENSE6:
766 status = bot_scsi_mode_sense6(udev, pmsc->cbw_struct.bCBWLUN);
767 break;
768
769 case MSC_CMD_MODE_SENSE10:
770 status = bot_scsi_mode_sense10(udev, pmsc->cbw_struct.bCBWLUN);
771 break;
772
773 case MSC_CMD_ALLOW_MEDIUM_REMOVAL:
774 status = bot_scsi_allow_medium_removal(udev, pmsc->cbw_struct.bCBWLUN);
775 break;
776
777 case MSC_CMD_READ_10:
778 status = bot_scsi_read10(udev, pmsc->cbw_struct.bCBWLUN);
779 break;
780
781 case MSC_CMD_READ_CAPACITY:
782 status = bot_scsi_capacity(udev, pmsc->cbw_struct.bCBWLUN);
783 break;
784
785 case MSC_CMD_REQUEST_SENSE:
786 status = bot_scsi_request_sense(udev, pmsc->cbw_struct.bCBWLUN);
787 break;
788
789 case MSC_CMD_TEST_UNIT:
790 status = bot_scsi_test_unit(udev, pmsc->cbw_struct.bCBWLUN);
791 break;
792
793 case MSC_CMD_VERIFY:
794 status = bot_scsi_verify(udev, pmsc->cbw_struct.bCBWLUN);
795 break;
796
797 case MSC_CMD_WRITE_10:
798 status = bot_scsi_write10(udev, pmsc->cbw_struct.bCBWLUN);
799 break;
800
801 case MSC_CMD_READ_FORMAT_CAPACITY:
802 status = bot_scsi_format_capacity(udev, pmsc->cbw_struct.bCBWLUN);
803 break;
804
805 default:
806 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
807 status = USB_FAIL;
808 break;
809 }
810 return status;
811}
812
cdc_msc_class.h
usb cdc class file
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:102
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:136
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:59
cdc_msc_struct_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:277
cdc_msc_struct_type::data
uint8_t data[4096]
Definition: cdc_msc_class.h:275
cbw_type::bCBWLUN
uint8_t bCBWLUN
Definition: cdc_msc_class.h:194
cbw_type::bCBWCBLength
uint8_t bCBWCBLength
Definition: cdc_msc_class.h:195
cdc_msc_struct_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:264
csw_type::dCSWSignature
uint32_t dCSWSignature
Definition: cdc_msc_class.h:204
cbw_type::CBWCB
uint8_t CBWCB[16]
Definition: cdc_msc_class.h:196
csw_type::bCSWStatus
uint32_t bCSWStatus
Definition: cdc_msc_class.h:207
cdc_msc_struct_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:272
csw_type::dCSWTag
uint32_t dCSWTag
Definition: cdc_msc_class.h:205
csw_type::dCSWDataResidue
uint32_t dCSWDataResidue
Definition: cdc_msc_class.h:206
cdc_msc_struct_type::blk_size
uint32_t blk_size[1]
Definition: cdc_msc_class.h:269
cdc_msc_struct_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:278
cdc_msc_struct_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:274
cdc_msc_struct_type::blk_nbr
uint32_t blk_nbr[1]
Definition: cdc_msc_class.h:268
cbw_type::dCBWDataTransferLength
uint32_t dCBWDataTransferLength
Definition: cdc_msc_class.h:192
cdc_msc_struct_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:266
cdc_msc_struct_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:271
cbw_type::dCBWTage
uint32_t dCBWTage
Definition: cdc_msc_class.h:191
cbw_type::dCBWSignature
uint32_t dCBWSignature
Definition: cdc_msc_class.h:190
cdc_msc_struct_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:265
cbw_type::bmCBWFlags
uint8_t bmCBWFlags
Definition: cdc_msc_class.h:193
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:505
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *udev, uint8_t ept_num)
bulk-only transport data in handler
Definition: composite_cdc_msc/msc_bot_scsi.c:144
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: composite_cdc_msc/msc_bot_scsi.c:410
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: composite_cdc_msc/msc_bot_scsi.c:540
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: composite_cdc_msc/msc_bot_scsi.c:599
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: composite_cdc_msc/msc_bot_scsi.c:304
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: composite_cdc_msc/msc_bot_scsi.c:660
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:126
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: composite_cdc_msc/msc_bot_scsi.c:458
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: composite_cdc_msc/msc_bot_scsi.c:289
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: composite_cdc_msc/msc_bot_scsi.c:197
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: composite_cdc_msc/msc_bot_scsi.c:571
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: composite_cdc_msc/msc_bot_scsi.c:424
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:104
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: composite_cdc_msc/msc_bot_scsi.c:750
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *udev, uint8_t ept_num)
bulk-only transport data out handler
Definition: composite_cdc_msc/msc_bot_scsi.c:173
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: composite_cdc_msc/msc_bot_scsi.c:438
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: composite_cdc_msc/msc_bot_scsi.c:321
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: composite_cdc_msc/msc_bot_scsi.c:244
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: composite_cdc_msc/msc_bot_scsi.c:347
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: composite_cdc_msc/msc_bot_scsi.c:369
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:478
ALIGNED_TAIL
ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL
Definition: composite_cdc_msc/msc_bot_scsi.c:46
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: composite_cdc_msc/msc_bot_scsi.c:730
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: composite_cdc_msc/msc_bot_scsi.c:265
MSC_STATE_MACHINE_DATA_IN
#define MSC_STATE_MACHINE_DATA_IN
Definition: cdc_msc_class.h:121
MSC_CMD_START_STOP
#define MSC_CMD_START_STOP
Definition: cdc_msc_class.h:88
MSC_CMD_VERIFY
#define MSC_CMD_VERIFY
Definition: cdc_msc_class.h:98
ADDRESS_OUT_OF_RANGE
#define ADDRESS_OUT_OF_RANGE
Definition: cdc_msc_class.h:153
SENSE_KEY_HARDWARE_ERROR
#define SENSE_KEY_HARDWARE_ERROR
Definition: cdc_msc_class.h:138
MEDIUM_NOT_PRESENT
#define MEDIUM_NOT_PRESENT
Definition: cdc_msc_class.h:154
MSC_CMD_MODE_SENSE6
#define MSC_CMD_MODE_SENSE6
Definition: cdc_msc_class.h:89
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_CMD_ALLOW_MEDIUM_REMOVAL
#define MSC_CMD_ALLOW_MEDIUM_REMOVAL
Definition: cdc_msc_class.h:91
CSW_CMD_LENGTH
#define CSW_CMD_LENGTH
Definition: cdc_msc_class.h:114
MSC_BOT_STATE_IDLE
#define MSC_BOT_STATE_IDLE
Definition: cdc_msc_class.h:129
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: cdc_msc_class.h:84
CSW_DCSWSIGNATURE
#define CSW_DCSWSIGNATURE
Definition: cdc_msc_class.h:115
MSC_CMD_INQUIRY
#define MSC_CMD_INQUIRY
Definition: cdc_msc_class.h:87
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
INVALID_COMMAND
#define INVALID_COMMAND
Definition: cdc_msc_class.h:149
MSC_CMD_WRITE_10
#define MSC_CMD_WRITE_10
Definition: cdc_msc_class.h:99
MSC_STATE_MACHINE_IDLE
#define MSC_STATE_MACHINE_IDLE
Definition: cdc_msc_class.h:127
MSC_CMD_READ_FORMAT_CAPACITY
#define MSC_CMD_READ_FORMAT_CAPACITY
Definition: cdc_msc_class.h:95
MSC_CMD_MODE_SENSE10
#define MSC_CMD_MODE_SENSE10
Definition: cdc_msc_class.h:90
SENSE_KEY_ILLEGAL_REQUEST
#define SENSE_KEY_ILLEGAL_REQUEST
Definition: cdc_msc_class.h:139
MSC_STATE_MACHINE_DATA_OUT
#define MSC_STATE_MACHINE_DATA_OUT
Definition: cdc_msc_class.h:122
CSW_BCSWSTATUS_PASS
#define CSW_BCSWSTATUS_PASS
Definition: cdc_msc_class.h:116
INVALID_FIELED_IN_COMMAND
#define INVALID_FIELED_IN_COMMAND
Definition: cdc_msc_class.h:150
REQ_SENSE_STANDARD_DATA_LEN
#define REQ_SENSE_STANDARD_DATA_LEN
Definition: cdc_msc_class.h:133
MSC_STATE_MACHINE_SEND_DATA
#define MSC_STATE_MACHINE_SEND_DATA
Definition: cdc_msc_class.h:123
CBW_DCBWSIGNATURE
#define CBW_DCBWSIGNATURE
Definition: cdc_msc_class.h:110
MSC_CMD_READ_10
#define MSC_CMD_READ_10
Definition: cdc_msc_class.h:92
MSC_BOT_STATE_RECOVERY
#define MSC_BOT_STATE_RECOVERY
Definition: cdc_msc_class.h:130
CBW_CMD_LENGTH
#define CBW_CMD_LENGTH
Definition: cdc_msc_class.h:109
MSC_STATE_MACHINE_LAST_DATA
#define MSC_STATE_MACHINE_LAST_DATA
Definition: cdc_msc_class.h:124
MSC_CMD_TEST_UNIT
#define MSC_CMD_TEST_UNIT
Definition: cdc_msc_class.h:97
CSW_BCSWSTATUS_FAILED
#define CSW_BCSWSTATUS_FAILED
Definition: cdc_msc_class.h:117
MSC_CMD_READ_CAPACITY
#define MSC_CMD_READ_CAPACITY
Definition: cdc_msc_class.h:94
MSC_BOT_STATE_ERROR
#define MSC_BOT_STATE_ERROR
Definition: cdc_msc_class.h:131
MSC_CMD_REQUEST_SENSE
#define MSC_CMD_REQUEST_SENSE
Definition: cdc_msc_class.h:96
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
USB_FAIL
@ USB_FAIL
Definition: usb_std.h:277
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:261
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
cdc_msc_struct_type
usb cdc class struct
Definition: cdc_msc_class.h:253
sense_type
request sense standard data
Definition: cdc_msc_class.h:214
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113


AT32F413 Firmwary Library: msc_diskio.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
composite_vcp_msc/inc/msc_diskio.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_DISKIO_H
28#define __MSC_DISKIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36#include "usb_std.h"
37
45#define INTERNAL_FLASH_LUN 0
46#define SPI_FLASH_LUN 1
47#define SD_LUN 2
48
49#define USB_FLASH_ADDR_OFFSET 0x08005000
50
51#define SECTOR_SIZE_1K 1024
52#define SECTOR_SIZE_2K 2048
53#define SECTOR_SIZE_4K 4096
54
55uint8_t *get_inquiry(uint8_t lun);
56 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len);
57 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len);
58 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
59
68#ifdef __cplusplus
69}
70#endif
71
72#endif
73
74
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:102
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:136
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:59
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F413 Firmwary Library: msc_diskio.c Source File

  • usb_device
  • composite_vcp_msc
  • src
composite_vcp_msc/src/msc_diskio.c
Go to the documentation of this file.
1
26#include "msc_diskio.h"
27#include "cdc_msc_class.h"
28
36uint32_t sector_size = 2048;
37uint32_t msc_flash_size;
38uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
39{
40 /* lun = 0 */
41 {
42 0x00, /* peripheral device type (direct-access device) */
43 0x80, /* removable media bit */
44 0x00, /* ansi version, ecma version, iso version */
45 0x01, /* respond data format */
46 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
47 0x00, 0x00, 0x00, /* reserved */
48 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
49 'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
50 '2', '.', '0', '0' /* product revision level */
51 }
52};
53
59uint8_t *get_inquiry(uint8_t lun)
60{
61 if(lun < MSC_SUPPORT_MAX_LUN)
62 return (uint8_t *)scsi_inquiry[lun];
63 else
64 return NULL;
65}
66
75 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
76{
77 uint32_t i = 0;
78 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
79 switch(lun)
80 {
81 case 0:
82 for(i = 0; i < len; i ++)
83 {
84 read_buf[i] = *((uint8_t *)flash_addr);
85 flash_addr += 1;
86 }
87 break;
88 case 1:
89 break;
90 }
91 return USB_OK;
92}
93
102 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
103{
104 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
105 uint32_t i = 0, page_len = 2048, tolen = len;
106 uint32_t erase_addr = flash_addr;
107 switch(lun)
108 {
109 case 0:
110 flash_unlock();
111 while(tolen >= page_len)
112 {
113 flash_sector_erase(erase_addr);
114 tolen -= page_len;
115 erase_addr += page_len;
116 }
117 for(i = 0; i < len; i ++)
118 {
119 flash_byte_program(flash_addr+i, buf[i]);
120 }
121 flash_lock();
122 break;
123 case 1:
124 break;
125 }
126 return USB_OK;
127}
128
136 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
137{
138 uint32_t flash_s = *((uint32_t *)0x1FFFF7E0);
139 msc_flash_size = (flash_s << 10) - (USB_FLASH_ADDR_OFFSET - FLASH_BASE);
140
141 if(flash_s < 256)
142 {
143 sector_size = SECTOR_SIZE_1K;
144 }
145 else
146 {
147 sector_size = SECTOR_SIZE_2K;
148 }
149
150 switch(lun)
151 {
152 case INTERNAL_FLASH_LUN:
153 *blk_nbr = msc_flash_size / sector_size;
154 *blk_size = sector_size;
155 break;
156 case SPI_FLASH_LUN:
157 break;
158 case SD_LUN:
159 break;
160 default:
161 break;
162 }
163 return USB_OK;
164}
165
cdc_msc_class.h
usb cdc class file
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:102
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:75
USB_FLASH_ADDR_OFFSET
#define USB_FLASH_ADDR_OFFSET
Definition: composite_vcp_msc/inc/msc_diskio.h:49
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:45
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:136
msc_flash_size
uint32_t msc_flash_size
Definition: composite_vcp_msc/src/msc_diskio.c:37
sector_size
uint32_t sector_size
Definition: composite_vcp_msc/src/msc_diskio.c:36
SD_LUN
#define SD_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:47
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: composite_vcp_msc/src/msc_diskio.c:38
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:46
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:59
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:533
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:291
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276


AT32F413 Firmwary Library: custom_hid_class.c Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "custom_hid_class.h"
28#include "custom_hid_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len);
54 custom_hid_type custom_hid_struct;
55
56/* usb device class handler */
57 usbd_class_handler custom_hid_class_handler =
58{
59 class_init_handler,
60 class_clear_handler,
61 class_setup_handler,
62 class_ept0_tx_handler,
63 class_ept0_rx_handler,
64 class_in_handler,
65 class_out_handler,
66 class_sof_handler,
67 class_event_handler,
68 &custom_hid_struct
69};
70
76 usb_sts_type class_init_handler(void *udev)
77{
78 usb_sts_type status = USB_OK;
79 usbd_core_type *pudev = (usbd_core_type *)udev;
80 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
81#ifndef USB_EPT_AUTO_MALLOC_BUFFER
82 /* use user define buffer address */
83 usbd_ept_buf_custom_define(pudev, USBD_CUSTOM_HID_IN_EPT, EPT1_TX_ADDR);
84 usbd_ept_buf_custom_define(pudev, USBD_CUSTOM_HID_OUT_EPT, EPT1_RX_ADDR);
85#endif
86
87 /* open custom hid in endpoint */
88 usbd_ept_open(pudev, USBD_CUSTOM_HID_IN_EPT, EPT_INT_TYPE, USBD_CUSTOM_IN_MAXPACKET_SIZE);
89
90 /* open custom hid out endpoint */
91 usbd_ept_open(pudev, USBD_CUSTOM_HID_OUT_EPT, EPT_INT_TYPE, USBD_CUSTOM_OUT_MAXPACKET_SIZE);
92
93 /* set out endpoint to receive status */
94 usbd_ept_recv(pudev, USBD_CUSTOM_HID_OUT_EPT, pcshid->g_rxhid_buff, USBD_CUSTOM_OUT_MAXPACKET_SIZE);
95
96 return status;
97}
98
104static usb_sts_type class_clear_handler(void *udev)
105{
106 usb_sts_type status = USB_OK;
107 usbd_core_type *pudev = (usbd_core_type *)udev;
108
109 /* close custom hid in endpoint */
110 usbd_ept_close(pudev, USBD_CUSTOM_HID_IN_EPT);
111
112 /* close custom hid out endpoint */
113 usbd_ept_close(pudev, USBD_CUSTOM_HID_OUT_EPT);
114
115 return status;
116}
117
124static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
125{
126 usb_sts_type status = USB_OK;
127 usbd_core_type *pudev = (usbd_core_type *)udev;
128 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
129 uint16_t len;
130 uint8_t *buf;
131
132 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
133 {
134 /* class request */
135 case USB_REQ_TYPE_CLASS:
136 switch(setup->bRequest)
137 {
138 case HID_REQ_SET_PROTOCOL:
139 pcshid->hid_protocol = (uint8_t)setup->wValue;
140 break;
141 case HID_REQ_GET_PROTOCOL:
142 usbd_ctrl_send(pudev, (uint8_t *)&pcshid->hid_protocol, 1);
143 break;
144 case HID_REQ_SET_IDLE:
145 pcshid->hid_set_idle = (uint8_t)(setup->wValue >> 8);
146 break;
147 case HID_REQ_GET_IDLE:
148 usbd_ctrl_send(pudev, (uint8_t *)&pcshid->hid_set_idle, 1);
149 break;
150 case HID_REQ_SET_REPORT:
151 pcshid->hid_state = HID_REQ_SET_REPORT;
152 usbd_ctrl_recv(pudev, pcshid->hid_set_report, setup->wLength);
153 break;
154 default:
155 usbd_ctrl_unsupport(pudev);
156 break;
157 }
158 break;
159 /* standard request */
160 case USB_REQ_TYPE_STANDARD:
161 switch(setup->bRequest)
162 {
163 case USB_STD_REQ_GET_DESCRIPTOR:
164 if(setup->wValue >> 8 == HID_REPORT_DESC)
165 {
166 len = MIN(USBD_CUSHID_SIZ_REPORT_DESC, setup->wLength);
167 buf = (uint8_t *)g_usbd_custom_hid_report;
168 }
169 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
170 {
171 len = MIN(9, setup->wLength);
172 buf = (uint8_t *)g_custom_hid_usb_desc;
173 }
174 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
175 break;
176 case USB_STD_REQ_GET_INTERFACE:
177 usbd_ctrl_send(pudev, (uint8_t *)&pcshid->alt_setting, 1);
178 break;
179 case USB_STD_REQ_SET_INTERFACE:
180 pcshid->alt_setting = setup->wValue;
181 break;
182 default:
183 break;
184 }
185 break;
186 default:
187 usbd_ctrl_unsupport(pudev);
188 break;
189 }
190 return status;
191}
192
198static usb_sts_type class_ept0_tx_handler(void *udev)
199{
200 usb_sts_type status = USB_OK;
201
202 /* ...user code... */
203
204 return status;
205}
206
212static usb_sts_type class_ept0_rx_handler(void *udev)
213{
214 usb_sts_type status = USB_OK;
215 usbd_core_type *pudev = (usbd_core_type *)udev;
216 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
217 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
218 /* ...user code... */
219 if( pcshid->hid_state == HID_REQ_SET_REPORT)
220 {
221 /* hid buffer process */
222 usb_hid_buf_process(udev, pcshid->hid_set_report, recv_len);
223 pcshid->hid_state = 0;
224 }
225
226 return status;
227}
228
235static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
236{
237 usb_sts_type status = USB_OK;
238
239 /* ...user code...
240 trans next packet data
241 */
242
243 return status;
244}
245
252static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
253{
254 usb_sts_type status = USB_OK;
255 usbd_core_type *pudev = (usbd_core_type *)udev;
256 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
257
258 /* get endpoint receive data length */
259 uint32_t recv_len = usbd_get_recv_len(pudev, ept_num);
260
261 /* hid buffer process */
262 usb_hid_buf_process(udev, pcshid->g_rxhid_buff, recv_len);
263
264 /* start receive next packet */
265 usbd_ept_recv(pudev, USBD_CUSTOM_HID_OUT_EPT, pcshid->g_rxhid_buff, recv_len);
266
267 return status;
268}
269
275static usb_sts_type class_sof_handler(void *udev)
276{
277 usb_sts_type status = USB_OK;
278
279 /* ...user code... */
280
281 return status;
282}
283
290static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
291{
292 usb_sts_type status = USB_OK;
293 switch(event)
294 {
295 case USBD_RESET_EVENT:
296
297 /* ...user code... */
298
299 break;
300 case USBD_SUSPEND_EVENT:
301
302 /* ...user code... */
303
304 break;
305 case USBD_WAKEUP_EVENT:
306 /* ...user code... */
307
308 break;
309 default:
310 break;
311 }
312 return status;
313}
314
322 usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
323{
324 usb_sts_type status = USB_OK;
325 usbd_core_type *pudev = (usbd_core_type *)udev;
326
327 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
328 usbd_ept_send(pudev, USBD_CUSTOM_HID_IN_EPT, report, len);
329
330 return status;
331}
332
340static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
341{
342 uint32_t i_index;
343 usbd_core_type *pudev = (usbd_core_type *)udev;
344 custom_hid_type *pcshid = (custom_hid_type *)pudev->class_handler->pdata;
345
346 switch(report[0])
347 {
348 case HID_REPORT_ID_2:
349 if(pcshid->g_rxhid_buff[1] == 0)
350 {
351 at32_led_off(LED2);
352 }
353 else
354 {
355 at32_led_on(LED2);
356 }
357 break;
358 case HID_REPORT_ID_3:
359 if(pcshid->g_rxhid_buff[1] == 0)
360 {
361 at32_led_off(LED3);
362 }
363 else
364 {
365 at32_led_on(LED3);
366 }
367 break;
368 case HID_REPORT_ID_4:
369 if(pcshid->g_rxhid_buff[1] == 0)
370 {
371 at32_led_off(LED4);
372 }
373 else
374 {
375 at32_led_on(LED4);
376 }
377 break;
378 case HID_REPORT_ID_6:
379 for(i_index = 0; i_index < len; i_index ++)
380 {
381 pcshid->g_txhid_buff[i_index] = report[i_index];
382 }
383 usbd_ept_send(pudev, USBD_CUSTOM_HID_IN_EPT, pcshid->g_txhid_buff, len);
384 break;
385 default:
386 break;
387 }
388
389}
390
custom_hid_class.h
usb custom hid header file
custom_hid_desc.h
usb custom hid descriptor header file
EPT1_RX_ADDR
#define EPT1_RX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:78
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:77
USB_EPT_AUTO_MALLOC_BUFFER
#define USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer
Definition: project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h:63
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:223
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:225
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:227
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:224
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:59
USBD_CUSTOM_HID_IN_EPT
#define USBD_CUSTOM_HID_IN_EPT
usb custom hid use endpoint define
Definition: custom_hid_class.h:53
USBD_CUSTOM_OUT_MAXPACKET_SIZE
#define USBD_CUSTOM_OUT_MAXPACKET_SIZE
Definition: custom_hid_class.h:60
USBD_CUSTOM_HID_OUT_EPT
#define USBD_CUSTOM_HID_OUT_EPT
Definition: custom_hid_class.h:54
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: custom_hid_class.c:275
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: custom_hid_class.c:235
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: custom_hid_class.c:104
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: custom_hid_class.c:124
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: custom_hid_class.c:198
custom_hid_class_send_report
usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: custom_hid_class.c:322
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: custom_hid_class.c:212
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: custom_hid_class.c:290
usb_hid_buf_process
static void usb_hid_buf_process(void *udev, uint8_t *report, uint16_t len)
usb device class report function
Definition: custom_hid_class.c:340
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: custom_hid_class.c:252
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: custom_hid_class.c:76
custom_hid_class_handler
usbd_class_handler custom_hid_class_handler
Definition: custom_hid_class.c:57
custom_hid_struct
custom_hid_type custom_hid_struct
Definition: custom_hid_class.c:54
USBD_CUSHID_SIZ_REPORT_DESC
#define USBD_CUSHID_SIZ_REPORT_DESC
Definition: custom_hid_desc.h:66
g_custom_hid_usb_desc
uint8_t g_custom_hid_usb_desc[9]
usb hid descriptor
Definition: custom_hid_desc.c:264
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:166
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:461
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
custom_hid_type
Definition: custom_hid_class.h:71
custom_hid_type::g_txhid_buff
uint8_t g_txhid_buff[0x40]
Definition: custom_hid_class.h:73
custom_hid_type::alt_setting
uint32_t alt_setting
Definition: custom_hid_class.h:77
custom_hid_type::hid_set_report
uint8_t hid_set_report[64]
Definition: custom_hid_class.h:79
custom_hid_type::g_rxhid_buff
uint8_t g_rxhid_buff[0x40]
Definition: custom_hid_class.h:72
custom_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: custom_hid_class.h:76
custom_hid_type::hid_protocol
uint32_t hid_protocol
Definition: custom_hid_class.h:75
custom_hid_type::hid_state
uint8_t hid_state
Definition: custom_hid_class.h:78
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: custom_hid_class.h Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CUSTOM_HID_CLASS_H
29#define __CUSTOM_HID_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_CUSTOM_HID_IN_EPT 0x81
54#define USBD_CUSTOM_HID_OUT_EPT 0x01
55
59#define USBD_CUSTOM_IN_MAXPACKET_SIZE 0x40
60#define USBD_CUSTOM_OUT_MAXPACKET_SIZE 0x40
61
70typedef struct
71{
72 uint8_t g_rxhid_buff[USBD_CUSTOM_OUT_MAXPACKET_SIZE];
73 uint8_t g_txhid_buff[USBD_CUSTOM_IN_MAXPACKET_SIZE];
74
75 uint32_t hid_protocol;
76 uint32_t hid_set_idle;
77 uint32_t alt_setting;
78 uint8_t hid_state;
79 uint8_t hid_set_report[64];
80}custom_hid_type;
81
89extern usbd_class_handler custom_hid_class_handler;
90 usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len);
102#ifdef __cplusplus
103}
104#endif
105
106#endif
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:59
USBD_CUSTOM_OUT_MAXPACKET_SIZE
#define USBD_CUSTOM_OUT_MAXPACKET_SIZE
Definition: custom_hid_class.h:60
custom_hid_class_send_report
usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: custom_hid_class.c:322
custom_hid_class_handler
usbd_class_handler custom_hid_class_handler
Definition: custom_hid_class.c:57
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
custom_hid_type
Definition: custom_hid_class.h:71
custom_hid_type::alt_setting
uint32_t alt_setting
Definition: custom_hid_class.h:77
custom_hid_type::hid_set_idle
uint32_t hid_set_idle
Definition: custom_hid_class.h:76
custom_hid_type::hid_protocol
uint32_t hid_protocol
Definition: custom_hid_class.h:75
custom_hid_type::hid_state
uint8_t hid_state
Definition: custom_hid_class.h:78
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: custom_hid_desc.c Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "custom_hid_desc.h"
30
43static usbd_desc_t *get_device_descriptor(void);
44static usbd_desc_t *get_device_qualifier(void);
45static usbd_desc_t *get_device_configuration(void);
46static usbd_desc_t *get_device_other_speed(void);
47static usbd_desc_t *get_device_lang_id(void);
48static usbd_desc_t *get_device_manufacturer_string(void);
49static usbd_desc_t *get_device_product_string(void);
50static usbd_desc_t *get_device_serial_string(void);
51static usbd_desc_t *get_device_interface_string(void);
52static usbd_desc_t *get_device_config_string(void);
53
54static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
55static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
56static void get_serial_num(void);
57static uint8_t g_usbd_desc_buffer[256];
58
62 usbd_desc_handler custom_hid_desc_handler =
63{
64 get_device_descriptor,
65 get_device_qualifier,
66 get_device_configuration,
67 get_device_other_speed,
68 get_device_lang_id,
69 get_device_manufacturer_string,
70 get_device_product_string,
71 get_device_serial_string,
72 get_device_interface_string,
73 get_device_config_string,
74};
75
79#if defined ( __ICCARM__ ) /* iar compiler */
80 #pragma data_alignment=4
81#endif
82ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
83{
84 USB_DEVICE_DESC_LEN, /* bLength */
85 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
86 0x00, /* bcdUSB */
87 0x02,
88 0x00, /* bDeviceClass */
89 0x00, /* bDeviceSubClass */
90 0x00, /* bDeviceProtocol */
91 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
92 LBYTE(USBD_CUSHID_VENDOR_ID), /* idVendor */
93 HBYTE(USBD_CUSHID_VENDOR_ID), /* idVendor */
94 LBYTE(USBD_CUSHID_PRODUCT_ID), /* idProduct */
95 HBYTE(USBD_CUSHID_PRODUCT_ID), /* idProduct */
96 0x00, /* bcdDevice rel. 2.00 */
97 0x02,
98 USB_MFC_STRING, /* Index of manufacturer string */
99 USB_PRODUCT_STRING, /* Index of product string */
100 USB_SERIAL_STRING, /* Index of serial number string */
101 1 /* bNumConfigurations */
102};
103
107#if defined ( __ICCARM__ ) /* iar compiler */
108 #pragma data_alignment=4
109#endif
110ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_CUSHID_CONFIG_DESC_SIZE] ALIGNED_TAIL =
111{
112 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
113 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
114 LBYTE(USBD_CUSHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
115 HBYTE(USBD_CUSHID_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 0x01, /* bNumInterfaces: 1 interface */
117 0x01, /* bConfigurationValue: configuration value */
118 0x00, /* iConfiguration: index of string descriptor describing
119 the configuration */
120 0xC0, /* bmAttributes: self powered */
121 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
122
123 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
124 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
125 0x00, /* bInterfaceNumber: number of interface */
126 0x00, /* bAlternateSetting: alternate set */
127 0x02, /* bNumEndpoints: number of endpoints */
128 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
129 0x00, /* bInterfaceSubClass: subclass code */
130 0x00, /* bInterfaceProtocol: protocol code */
131 0x00, /* iInterface: index of string descriptor */
132
133 0x09, /* bLength: size of HID descriptor in bytes */
134 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
135 LBYTE(CUSHID_BCD_NUM),
136 HBYTE(CUSHID_BCD_NUM), /* bcdHID: HID class specification release number */
137 0x00, /* bCountryCode: hardware target conutry */
138 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
139 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
140 LBYTE(sizeof(g_usbd_custom_hid_report)),
141 HBYTE(sizeof(g_usbd_custom_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
142
143 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
144 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
145 USBD_CUSTOM_HID_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
146 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
147 LBYTE(USBD_CUSTOM_IN_MAXPACKET_SIZE),
148 HBYTE(USBD_CUSTOM_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
149 CUSHID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
150
151 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
152 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
153 USBD_CUSTOM_HID_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
154 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
155 LBYTE(USBD_CUSTOM_OUT_MAXPACKET_SIZE),
156 HBYTE(USBD_CUSTOM_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
157 CUSHID_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
158};
159
163#if defined ( __ICCARM__ ) /* iar compiler */
164 #pragma data_alignment=4
165#endif
166ALIGNED_HEAD uint8_t g_usbd_custom_hid_report[USBD_CUSHID_SIZ_REPORT_DESC] ALIGNED_TAIL =
167{
168 0x06, 0xFF, 0x00, /* USAGE_PAGE(Vendor Page:0xFF00) */
169 0x09, 0x01, /* USAGE (Demo Kit) */
170 0xa1, 0x01, /* COLLECTION (Application) */
171 /* 7 */
172
173 /* Led 2 */
174 0x85, HID_REPORT_ID_2, /* REPORT_ID 2 */
175 0x09, 0x02, /* USAGE (LED 2) */
176 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
177 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
178 0x75, 0x08, /* REPORT_SIZE (8) */
179 0x95, 0x3F, /* REPORT_COUNT (1) */
180 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
181
182 0x85, 0x02, /* REPORT_ID (2) */
183 0x09, 0x02, /* USAGE (LED 2) */
184 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
185 /* 27 */
186
187 /* Led 3 */
188 0x85, HID_REPORT_ID_3, /* REPORT_ID (3) */
189 0x09, 0x03, /* USAGE (LED 3) */
190 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
191 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
192 0x75, 0x08, /* REPORT_SIZE (8) */
193 0x95, 0x3F, /* REPORT_COUNT (1) */
194 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
195
196 0x85, 0x03, /* REPORT_ID (3) */
197 0x09, 0x03, /* USAGE (LED 3) */
198 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
199 /* 47 */
200
201 /* Led 4 */
202 0x85, HID_REPORT_ID_4, /* REPORT_ID 4) */
203 0x09, 0x04, /* USAGE (LED 4) */
204 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
205 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
206 0x75, 0x08, /* REPORT_SIZE (8) */
207 0x95, 0x3F, /* REPORT_COUNT (1) */
208 0xB1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
209
210 0x85, 0x04, /* REPORT_ID (4) */
211 0x09, 0x04, /* USAGE (LED 4) */
212 0x91, 0x82, /* OUTPUT (Data,Var,Abs,Vol) */
213 /* 67 */
214
215 /* key Push Button */
216 0x85, HID_REPORT_ID_5, /* REPORT_ID (5) */
217 0x09, 0x05, /* USAGE (Push Button) */
218 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
219 0x25, 0x01, /* LOGICAL_MAXIMUM (1) */
220 0x75, 0x01, /* REPORT_SIZE (1) */
221 0x81, 0x82, /* INPUT (Data,Var,Abs,Vol) */
222
223 0x09, 0x05, /* USAGE (Push Button) */
224 0x75, 0x01, /* REPORT_SIZE (1) */
225 0xb1, 0x82, /* FEATURE (Data,Var,Abs,Vol) */
226
227 0x75, 0x07, /* REPORT_SIZE (7) */
228 0x81, 0x83, /* INPUT (Cnst,Var,Abs,Vol) */
229 0x85, 0x05, /* REPORT_ID (5) */
230
231 0x75, 0x07, /* REPORT_SIZE (7) */
232 0xb1, 0x83, /* FEATURE (Cnst,Var,Abs,Vol) */
233 /* 95 */
234
235 /* Data OUT */
236 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
237 0x09, 0x06, /* USAGE */
238 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
239 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
240 0x75, 0x08, /* REPORT_SIZE (8) */
241 0x95, 0x3F, /* REPORT_COUNT (64) */
242 0x91, 0x02, /* OUTPUT(Data,Var,Abs,Vol) */
243 /* 110 */
244
245 /* Data IN */
246 0x85, HID_REPORT_ID_6, /* REPORT_ID (0xF0) */
247 0x09, 0x07, /* USAGE */
248 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
249 0x26, 0x00,0xff, /* LOGICAL_MAXIMUM (255) */
250 0x75, 0x08, /* REPORT_SIZE (8) */
251 0x95, 0x3F, /* REPORT_COUNT (64) */
252 0x81, 0x82, /* INPUT(Data,Var,Abs,Vol) */
253
254 /* 125 */
255 0xc0 /* END_COLLECTION */
256};
257
261#if defined ( __ICCARM__ ) /* iar compiler */
262 #pragma data_alignment=4
263#endif
264ALIGNED_HEAD uint8_t g_custom_hid_usb_desc[9] ALIGNED_TAIL =
265{
266 0x09, /* bLength: size of HID descriptor in bytes */
267 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
268 LBYTE(CUSHID_BCD_NUM),
269 HBYTE(CUSHID_BCD_NUM), /* bcdHID: HID class specification release number */
270 0x00, /* bCountryCode: hardware target conutry */
271 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
272 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
273 LBYTE(sizeof(g_usbd_custom_hid_report)),
274 HBYTE(sizeof(g_usbd_custom_hid_report)), /* wDescriptorLength: total length of reprot descriptor */
275};
276
277
281#if defined ( __ICCARM__ ) /* iar compiler */
282 #pragma data_alignment=4
283#endif
284ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_CUSHID_SIZ_STRING_LANGID] ALIGNED_TAIL =
285{
286 USBD_CUSHID_SIZ_STRING_LANGID,
287 USB_DESCIPTOR_TYPE_STRING,
288 0x09,
289 0x04,
290};
291
295#if defined ( __ICCARM__ ) /* iar compiler */
296 #pragma data_alignment=4
297#endif
298ALIGNED_HEAD static uint8_t g_string_serial[USBD_CUSHID_SIZ_STRING_SERIAL] ALIGNED_TAIL =
299{
300 USBD_CUSHID_SIZ_STRING_SERIAL,
301 USB_DESCIPTOR_TYPE_STRING,
302};
303
304
305/* device descriptor */
306static usbd_desc_t device_descriptor =
307{
308 USB_DEVICE_DESC_LEN,
309 g_usbd_descriptor
310};
311
312/* config descriptor */
313static usbd_desc_t config_descriptor =
314{
315 USBD_CUSHID_CONFIG_DESC_SIZE,
316 g_usbd_configuration
317};
318
319/* langid descriptor */
320static usbd_desc_t langid_descriptor =
321{
322 USBD_CUSHID_SIZ_STRING_LANGID,
323 g_string_lang_id
324};
325
326/* serial descriptor */
327static usbd_desc_t serial_descriptor =
328{
329 USBD_CUSHID_SIZ_STRING_SERIAL,
330 g_string_serial
331};
332
333static usbd_desc_t vp_desc;
334
341static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
342{
343 uint16_t str_len = 0, id_pos = 2;
344 uint8_t *tmp_str = string;
345
346 while(*tmp_str != '\0')
347 {
348 str_len ++;
349 unicode_buf[id_pos ++] = *tmp_str ++;
350 unicode_buf[id_pos ++] = 0x00;
351 }
352
353 str_len = str_len * 2 + 2;
354 unicode_buf[0] = str_len;
355 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
356
357 return str_len;
358}
359
367static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
368{
369 uint8_t idx = 0;
370
371 for( idx = 0 ; idx < len ; idx ++)
372 {
373 if( ((value >> 28)) < 0xA )
374 {
375 pbuf[ 2 * idx] = (value >> 28) + '0';
376 }
377 else
378 {
379 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
380 }
381
382 value = value << 4;
383
384 pbuf[2 * idx + 1] = 0;
385 }
386}
387
393static void get_serial_num(void)
394{
395 uint32_t serial0, serial1, serial2;
396
397 serial0 = *(uint32_t*)MCU_ID1;
398 serial1 = *(uint32_t*)MCU_ID2;
399 serial2 = *(uint32_t*)MCU_ID3;
400
401 serial0 += serial2;
402
403 if (serial0 != 0)
404 {
405 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
406 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
407 }
408}
409
415static usbd_desc_t *get_device_descriptor(void)
416{
417 return &device_descriptor;
418}
419
425static usbd_desc_t * get_device_qualifier(void)
426{
427 return NULL;
428}
429
435static usbd_desc_t *get_device_configuration(void)
436{
437 return &config_descriptor;
438}
439
445static usbd_desc_t *get_device_other_speed(void)
446{
447 return NULL;
448}
449
455static usbd_desc_t *get_device_lang_id(void)
456{
457 return &langid_descriptor;
458}
459
460
466static usbd_desc_t *get_device_manufacturer_string(void)
467{
468 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
469 vp_desc.descriptor = g_usbd_desc_buffer;
470 return &vp_desc;
471}
472
478static usbd_desc_t *get_device_product_string(void)
479{
480 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
481 vp_desc.descriptor = g_usbd_desc_buffer;
482 return &vp_desc;
483}
484
490static usbd_desc_t *get_device_serial_string(void)
491{
492 get_serial_num();
493 return &serial_descriptor;
494}
495
501static usbd_desc_t *get_device_interface_string(void)
502{
503 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
504 vp_desc.descriptor = g_usbd_desc_buffer;
505 return &vp_desc;
506}
507
513static usbd_desc_t *get_device_config_string(void)
514{
515 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_CUSHID_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
516 vp_desc.descriptor = g_usbd_desc_buffer;
517 return &vp_desc;
518}
519
custom_hid_desc.h
usb custom hid descriptor header file
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
HID_REPORT_ID_2
#define HID_REPORT_ID_2
Definition: audio_hid_desc.h:223
HID_REPORT_ID_4
#define HID_REPORT_ID_4
Definition: audio_hid_desc.h:225
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
HID_REPORT_ID_6
#define HID_REPORT_ID_6
Definition: audio_hid_desc.h:227
HID_REPORT_ID_3
#define HID_REPORT_ID_3
Definition: audio_hid_desc.h:224
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:226
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:59
USBD_CUSTOM_HID_IN_EPT
#define USBD_CUSTOM_HID_IN_EPT
usb custom hid use endpoint define
Definition: custom_hid_class.h:53
USBD_CUSTOM_OUT_MAXPACKET_SIZE
#define USBD_CUSTOM_OUT_MAXPACKET_SIZE
Definition: custom_hid_class.h:60
USBD_CUSTOM_HID_OUT_EPT
#define USBD_CUSTOM_HID_OUT_EPT
Definition: custom_hid_class.h:54
USBD_CUSHID_SIZ_STRING_SERIAL
#define USBD_CUSHID_SIZ_STRING_SERIAL
Definition: custom_hid_desc.h:68
USBD_CUSHID_VENDOR_ID
#define USBD_CUSHID_VENDOR_ID
usb vendor id and product id define
Definition: custom_hid_desc.h:59
USBD_CUSHID_DESC_CONFIGURATION_STRING
#define USBD_CUSHID_DESC_CONFIGURATION_STRING
Definition: custom_hid_desc.h:75
USBD_CUSHID_SIZ_REPORT_DESC
#define USBD_CUSHID_SIZ_REPORT_DESC
Definition: custom_hid_desc.h:66
CUSHID_BINTERVAL_TIME
#define CUSHID_BINTERVAL_TIME
Definition: custom_hid_desc.h:78
USBD_CUSHID_DESC_MANUFACTURER_STRING
#define USBD_CUSHID_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: custom_hid_desc.h:73
USBD_CUSHID_CONFIG_DESC_SIZE
#define USBD_CUSHID_CONFIG_DESC_SIZE
usb descriptor size define
Definition: custom_hid_desc.h:65
USBD_CUSHID_DESC_INTERFACE_STRING
#define USBD_CUSHID_DESC_INTERFACE_STRING
Definition: custom_hid_desc.h:76
USBD_CUSHID_PRODUCT_ID
#define USBD_CUSHID_PRODUCT_ID
Definition: custom_hid_desc.h:60
USBD_CUSHID_SIZ_STRING_LANGID
#define USBD_CUSHID_SIZ_STRING_LANGID
Definition: custom_hid_desc.h:67
USBD_CUSHID_DESC_PRODUCT_STRING
#define USBD_CUSHID_DESC_PRODUCT_STRING
Definition: custom_hid_desc.h:74
CUSHID_BCD_NUM
#define CUSHID_BCD_NUM
usb bcd number define
Definition: custom_hid_desc.h:54
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: custom_hid_desc.c:327
device_descriptor
static usbd_desc_t device_descriptor
Definition: custom_hid_desc.c:306
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: custom_hid_desc.c:435
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: custom_hid_desc.c:320
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: custom_hid_desc.c:415
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: custom_hid_desc.c:466
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: custom_hid_desc.c:425
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: custom_hid_desc.c:501
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: custom_hid_desc.c:57
vp_desc
static usbd_desc_t vp_desc
Definition: custom_hid_desc.c:333
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: custom_hid_desc.c:445
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: custom_hid_desc.c:82
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: custom_hid_desc.c:478
custom_hid_desc_handler
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure
Definition: custom_hid_desc.c:62
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: custom_hid_desc.c:513
g_custom_hid_usb_desc
uint8_t g_custom_hid_usb_desc[9]
usb hid descriptor
Definition: custom_hid_desc.c:264
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: custom_hid_desc.c:341
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:166
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: custom_hid_desc.c:455
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: custom_hid_desc.c:393
config_descriptor
static usbd_desc_t config_descriptor
Definition: custom_hid_desc.c:313
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: custom_hid_desc.c:490
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: custom_hid_desc.c:367
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: custom_hid_desc.h Source File

  • middlewares
  • usbd_class
  • custom_hid
custom_hid_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __CUSTOM_HID_DESC_H
29#define __CUSTOM_HID_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "custom_hid_class.h"
36#include "usbd_core.h"
37
54#define CUSHID_BCD_NUM 0x0110
55
59#define USBD_CUSHID_VENDOR_ID 0x2E3C
60#define USBD_CUSHID_PRODUCT_ID 0x5745
61
65#define USBD_CUSHID_CONFIG_DESC_SIZE 41
66#define USBD_CUSHID_SIZ_REPORT_DESC 126
67#define USBD_CUSHID_SIZ_STRING_LANGID 4
68#define USBD_CUSHID_SIZ_STRING_SERIAL 0x1A
69
73#define USBD_CUSHID_DESC_MANUFACTURER_STRING "Artery"
74#define USBD_CUSHID_DESC_PRODUCT_STRING "Custom HID"
75#define USBD_CUSHID_DESC_CONFIGURATION_STRING "Custom HID Config"
76#define USBD_CUSHID_DESC_INTERFACE_STRING "Custom HID Interface"
77
78#define CUSHID_BINTERVAL_TIME 0x0A
79
86#define HID_REPORT_ID_1 0x01
87#define HID_REPORT_ID_2 0x02
88#define HID_REPORT_ID_3 0x03
89#define HID_REPORT_ID_4 0x04
90#define HID_REPORT_ID_5 0x05
91#define HID_REPORT_ID_6 0xF0
92
96#define MCU_ID1 (0x1FFFF7E8)
97#define MCU_ID2 (0x1FFFF7EC)
98#define MCU_ID3 (0x1FFFF7F0)
99
103extern uint8_t g_usbd_custom_hid_report[USBD_CUSHID_SIZ_REPORT_DESC];
104extern uint8_t g_custom_hid_usb_desc[9];
105extern usbd_desc_handler custom_hid_desc_handler;
106
114#ifdef __cplusplus
115}
116#endif
117
118#endif
119
120
custom_hid_class.h
usb custom hid header file
USBD_CUSHID_SIZ_REPORT_DESC
#define USBD_CUSHID_SIZ_REPORT_DESC
Definition: custom_hid_desc.h:66
g_custom_hid_usb_desc
uint8_t g_custom_hid_usb_desc[9]
usb hid descriptor
Definition: custom_hid_desc.c:264
g_usbd_custom_hid_report
uint8_t g_usbd_custom_hid_report[126]
usb hid report descriptor
Definition: custom_hid_desc.c:166
custom_hid_desc_handler
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure
Definition: custom_hid_desc.c:62
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • oc_toggle_tmr9
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: receiver_mute Directory Reference

  • usart
  • receiver_mute
receiver_mute Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_input_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: led_toggle Directory Reference

  • gpio
  • led_toggle
led_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • composite_vcp_msc
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c [code]
main program
file | composite_vcp_msc/src/msc_diskio.c [code]
usb mass storage disk function


AT32F413 Firmwary Library: oc_toggle_tmr9 Directory Reference

  • tmr
  • oc_toggle_tmr9
oc_toggle_tmr9 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • sram
  • extend_sram
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/sram/extend_sram/src/main.c [code]
main program


AT32F413 Firmwary Library: rtc Directory Reference

  • rtc
rtc Directory Reference

Directories

directory | calendar
directory | lick_calibration


AT32F413 Firmwary Library: power_voltage_monitor Directory Reference

  • pwc
  • power_voltage_monitor
power_voltage_monitor Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • encoder_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: dma Directory Reference

  • tmr
  • dma
dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: composite_cdc_keyboard Directory Reference

  • middlewares
  • usbd_class
  • composite_cdc_keyboard
composite_cdc_keyboard Directory Reference

Files

file | cdc_keyboard_class.c [code]
usb cdc and keyboard class type
file | cdc_keyboard_class.h [code]
usb cdc and keyboard class file
file | cdc_keyboard_desc.c [code]
usb cdc and keyboard device descriptor
file | cdc_keyboard_desc.h [code]
usb cdc and keyboard descriptor header file


AT32F413 Firmwary Library: inc Directory Reference

  • rtc
  • lick_calibration
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • synchronous
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • sdio
  • sd_mmc_card
  • inc
inc Directory Reference

Files

file | sd_mmc_card/inc/at32_sdio.h [code]
this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.
file | project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • exint
  • exint_software_trigger
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/exint/exint_software_trigger/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • mouse
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/mouse/src/main.c [code]
main program


AT32F413 Firmwary Library: composite_vcp_keyboard Directory Reference

  • usb_device
  • composite_vcp_keyboard
composite_vcp_keyboard Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • tmr2_32bit
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: middlewares Directory Reference

  • middlewares
middlewares Directory Reference

Directories

directory | i2c_application_library
directory | usbd_class
directory | usbd_drivers


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • internal_temperature_sensor
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: parallel_synchro Directory Reference

  • tmr
  • parallel_synchro
parallel_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: project_l1 Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
project_l1 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: usart Directory Reference

  • usart
usart Directory Reference

Directories

directory | half_duplex
directory | hw_flow_control
directory | idle_detection
directory | interrupt
directory | irda
directory | polling
directory | printf
directory | receiver_mute
directory | rs485
directory | smartcard
directory | synchronous
directory | transfer_by_dma_interrupt
directory | transfer_by_dma_polling


AT32F413 Firmwary Library: src Directory Reference

  • middlewares
  • usbd_drivers
  • src
src Directory Reference

Files

file | usbd_core.c [code]
usb driver
file | usbd_int.c [code]
usb interrupt request
file | usbd_sdr.c [code]
usb standard device request


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/dma/src/main.c [code]
main program


AT32F413 Firmwary Library: mouse Directory Reference

  • usb_device
  • mouse
mouse Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • standby_wakeup_pin
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • oc_toggle_tmr3
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • flash
  • run_in_spim
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/flash/run_in_spim/src/main.c [code]
main program
file | run_in_spim.c [code]
run in spim program


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
src Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | app_led4_toggle/src/iap.c [code]
iap program
file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c [code]
main program
file | app_led4_toggle/src/tmr.c [code]
tmr program
file | app_led4_toggle/src/usart.c [code]
usart program


AT32F413 Firmwary Library: wdt_reset Directory Reference

  • wdt
  • wdt_reset
wdt_reset Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • flash
  • operate_spim
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/flash/operate_spim/src/main.c [code]
main program
file | operate_spim.c [code]
operate spim program


AT32F413 Firmwary Library: inc Directory Reference

  • dma
  • data_to_gpio_flexible
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: mouse Directory Reference

  • middlewares
  • usbd_class
  • mouse
mouse Directory Reference

Files

file | mouse_class.c [code]
usb hid mouse class type
file | mouse_class.h [code]
usb hid mouse header file
file | mouse_desc.c [code]
usb hid mouse device descriptor
file | mouse_desc.h [code]
usb mouse descriptor header file


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • voltage_monitoring
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/voltage_monitoring/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_freertos_demo
  • src
src Directory Reference

Files

file | utilities/at32f413_freertos_demo/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_freertos_demo/src/at32f413_int.c [code]
main interrupt service routines.
file | utilities/at32f413_freertos_demo/src/main.c [code]
main program


AT32F413 Firmwary Library: eeprom Directory Reference

  • i2c
  • eeprom
eeprom Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • receiver_mute
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • deepsleep_rtc
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: sdio Directory Reference

  • sdio
sdio Directory Reference

Directories

directory | sd_mmc_card
directory | sdio_fatfs


AT32F413 Firmwary Library: inc Directory Reference

  • cortex_m4
  • cmsis_dsp
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • 6_steps
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/6_steps/src/main.c [code]
main program


AT32F413 Firmwary Library: bpr Directory Reference

  • bpr
bpr Directory Reference

Directories

directory | bpr_data
directory | tamper


AT32F413 Firmwary Library: run_in_spim Directory Reference

  • flash
  • run_in_spim
run_in_spim Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: hall_xor_tmr2 Directory Reference

  • tmr
  • hall_xor_tmr2
hall_xor_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • combine_mode_ordinary_simult
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • halfduplex_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • custom_hid
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/custom_hid/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • wwdt
  • wwdt_reset
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • half_duplex
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_gen_random_number_demo
  • src
src Directory Reference

Files

file | utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_gen_random_number_demo/src/at32f413_int.c [code]
main interrupt service routines.
file | utilities/at32f413_gen_random_number_demo/src/main.c [code]
main program
file | random.c [code]
set of firmware functions to random function


AT32F413 Firmwary Library: inc Directory Reference

  • cortex_m4
  • fpu
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | julia_fpu.h [code]
julia_fpu header file


AT32F413 Firmwary Library: composite_audio_hid Directory Reference

  • usb_device
  • composite_audio_hid
composite_audio_hid Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: communication_dma Directory Reference

  • i2c
  • communication_dma
communication_dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • dma
  • data_to_gpio_flexible
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • bpr
  • bpr_data
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/bpr/bpr_data/src/main.c [code]
main program


AT32F413 Firmwary Library: source_code Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
source_code Directory Reference

Directories

directory | app_led3_toggle
directory | app_led4_toggle
directory | bootloader


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • oc_high
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/oc_high/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • virtual_comport
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
src Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c [code]
main interrupt service routines.
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c [code]
flash program
file | bootloader/src/iap.c [code]
iap program
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c [code]
main program
file | bootloader/src/tmr.c [code]
tmr program
file | bootloader/src/usart.c [code]
usart program


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • composite_audio_hid
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | composite_audio_hid/inc/audio_codec.h [code]
audio codec header file
file | project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • cascade_synchro
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/cascade_synchro/src/main.c [code]
main program


AT32F413 Firmwary Library: sysclk_switch Directory Reference

  • crm
  • sysclk_switch
sysclk_switch Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: 6_steps Directory Reference

  • tmr
  • 6_steps
6_steps Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • tmr2_32bit
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • oc_high
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: one_cycle Directory Reference

  • tmr
  • one_cycle
one_cycle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: half_duplex Directory Reference

  • usart
  • half_duplex
half_duplex Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: wdt Directory Reference

  • wdt
wdt Directory Reference

Directories

directory | wdt_reset
directory | wdt_standby


AT32F413 Firmwary Library: fpu Directory Reference

  • cortex_m4
  • fpu
fpu Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: flash_to_sram Directory Reference

  • dma
  • flash_to_sram
flash_to_sram Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • w25q_flash
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/w25q_flash/src/main.c [code]
main program
file | spi_flash.c [code]
spi_flash source code


AT32F413 Firmwary Library: inc Directory Reference

  • cortex_m4
  • systick_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • wdt
  • wdt_standby
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • cortex_m4
  • fpu
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c [code]
main interrupt service routines.
file | julia_fpu.c [code]
julia_fpu source file
file | project/at_start_f413/examples/cortex_m4/fpu/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: operate_spim Directory Reference

  • flash
  • operate_spim
operate_spim Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • printer
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • composite_vcp_msc
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | composite_vcp_msc/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • tmr1_synchro
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • crm
  • sysclk_switch
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • transfer_by_dma_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • gpio
  • swjtag_remap
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • voltage_monitoring
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: tmr1 Directory Reference

  • debug
  • tmr1
tmr1 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: virtual_comport Directory Reference

  • usb_device
  • virtual_comport
virtual_comport Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • sram
  • extend_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • crc
  • calculation
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/crc/calculation/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/crc/calculation/src/main.c [code]
main program


AT32F413 Firmwary Library: pwm_input_dma Directory Reference

  • tmr
  • pwm_input_dma
pwm_input_dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: spii2s_switch_halfduplex_polling Directory Reference

  • i2s
  • spii2s_switch_halfduplex_polling
spii2s_switch_halfduplex_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: clock_failure_detection Directory Reference

  • crm
  • clock_failure_detection
clock_failure_detection Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • fullduplex_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/fullduplex_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • keyboard
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/keyboard/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • cortex_m4
  • bit_band
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • mouse
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • receiver_mute
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/receiver_mute/src/main.c [code]
main program


AT32F413 Firmwary Library: systick_interrupt Directory Reference

  • cortex_m4
  • systick_interrupt
systick_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • gpio
  • led_toggle
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • idle_detection
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
src Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | app_led4_toggle/src/hid_iap_user.c [code]
usb hid iap user file
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • i2c
  • eeprom
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_input
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: current_vref_value_check Directory Reference

  • adc
  • current_vref_value_check
current_vref_value_check Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • bpr
  • tamper
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/bpr/tamper/src/main.c [code]
main program


AT32F413 Firmwary Library: tmr2_32bit Directory Reference

  • tmr
  • tmr2_32bit
tmr2_32bit Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • flash
  • run_in_spim
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | run_in_spim.h [code]
run_in_spim header file


AT32F413 Firmwary Library: inc Directory Reference

  • rtc
  • calendar
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | rtc.h [code]
this file provides template for calendar api.


AT32F413 Firmwary Library: custom_hid Directory Reference

  • middlewares
  • usbd_class
  • custom_hid
custom_hid Directory Reference

Files

file | custom_hid_class.c [code]
usb custom hid class type
file | custom_hid_class.h [code]
usb custom hid header file
file | custom_hid_desc.c [code]
usb hid device descriptor
file | custom_hid_desc.h [code]
usb custom hid descriptor header file


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
src Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | app_led3_toggle/src/hid_iap_user.c [code]
usb hid iap user file
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • power_voltage_monitor
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c [code]
main program


AT32F413 Firmwary Library: cm4 Directory Reference

  • libraries
  • cmsis
  • cm4
cm4 Directory Reference

Directories

directory device_support


AT32F413 Firmwary Library: inc Directory Reference

  • exint
  • exint_config
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: oc_low Directory Reference

  • tmr
  • oc_low
oc_low Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • tmr1_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: keyboard Directory Reference

  • usb_device
  • keyboard
keyboard Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: templates Directory Reference

  • templates
templates Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: halfduplex_transceiver_switch Directory Reference

  • spi
  • halfduplex_transceiver_switch
halfduplex_transceiver_switch Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • composite_vcp_keyboard
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • tmr_trigger_automatic_preempted
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • transfer_by_dma_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: at32f413_slib_demo Directory Reference

  • utilities
  • at32f413_slib_demo
at32f413_slib_demo Directory Reference

Directories

directory | project_l0
directory | project_l1


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • encoder_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • vcp_loopback
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c [code]
main program


AT32F413 Firmwary Library: at32f413_usart_iap_demo Directory Reference

  • utilities
  • at32f413_usart_iap_demo
at32f413_usart_iap_demo Directory Reference

Directories

directory source_code


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • only_receive_mode_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: exint_config Directory Reference

  • exint
  • exint_config
exint_config Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • gpio
  • swjtag_remap
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/gpio/swjtag_remap/src/main.c [code]
main program


AT32F413 Firmwary Library: cortex_m4 Directory Reference

  • cortex_m4
cortex_m4 Directory Reference

Directories

directory | bit_band
directory | cmsis_dsp
directory | fpu
directory | systick_interrupt


AT32F413 Firmwary Library: spi Directory Reference

  • spi
spi Directory Reference

Directories

directory | crc_transfer_polling
directory | fullduplex_polling
directory | halfduplex_interrupt
directory | halfduplex_transceiver_switch
directory | only_receive_mode_polling
directory | use_jtagpin_hardwarecs_dma
directory | w25q_flash


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • oc_toggle_tmr9
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • can
  • filter
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/can/filter/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/can/filter/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/can/filter/src/main.c [code]
main program


AT32F413 Firmwary Library: rs485 Directory Reference

  • usart
  • rs485
rs485 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: tamper Directory Reference

  • bpr
  • tamper
tamper Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • i2c
  • communication_int
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • exint_trigger_partitioned
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c [code]
main program


AT32F413 Firmwary Library: complementary_signals Directory Reference

  • tmr
  • complementary_signals
complementary_signals Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • cortex_m4
  • bit_band
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/cortex_m4/bit_band/src/main.c [code]
main program


AT32F413 Firmwary Library: transfer_by_dma_interrupt Directory Reference

  • usart
  • transfer_by_dma_interrupt
transfer_by_dma_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: halfduplex_dma Directory Reference

  • i2s
  • halfduplex_dma
halfduplex_dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • i2c
  • eeprom
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2c/eeprom/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • virtual_comport
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/virtual_comport/src/main.c [code]
main program


AT32F413 Firmwary Library: bootloader Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
bootloader Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: crm Directory Reference

  • crm
crm Directory Reference

Directories

directory | clock_failure_detection
directory | sysclk_switch


AT32F413 Firmwary Library: src Directory Reference

  • sdio
  • sdio_fatfs
  • src
src Directory Reference

Files

file | sdio_fatfs/src/at32_sdio.c [code]
this file provides a set of functions needed to manage the sdio/mmc card memory.
file | project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c [code]
main interrupt service routines.
file | diskio.c [code]
file | project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c [code]
main program


AT32F413 Firmwary Library: bootloader Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
bootloader Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: polling Directory Reference

  • usart
  • polling
polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • wwdt
  • wwdt_reset
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • can
  • loopback_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: sleep_usart1 Directory Reference

  • pwc
  • sleep_usart1
sleep_usart1 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: wwdt_reset Directory Reference

  • wwdt
  • wwdt_reset
wwdt_reset Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: printer Directory Reference

  • usb_device
  • printer
printer Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • synchronous
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/synchronous/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • power_voltage_monitor
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: swjtag_remap Directory Reference

  • gpio
  • swjtag_remap
swjtag_remap Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: 7_pwm_output Directory Reference

  • tmr
  • 7_pwm_output
7_pwm_output Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: wdt_standby Directory Reference

  • wdt
  • wdt_standby
wdt_standby Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • i2s
  • halfduplex_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • rs485
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/rs485/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/rs485/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | bootloader/inc/hid_iap_user.h [code]
usb config header file
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • parallel_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_output_tmr3
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_output_tmr10
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c [code]
main program


AT32F413 Firmwary Library: at32f413_board Directory Reference

  • at32f413_board
at32f413_board Directory Reference

Files

file | at32f413_board.c [code]
set of firmware functions to manage leds and push-button. initialize delay function.
file | at32f413_board.h [code]
header file for at-start board. set of firmware functions to manage leds and push-button. initialize delay function.


AT32F413 Firmwary Library: src Directory Reference

  • exint
  • exint_config
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/exint/exint_config/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • can
  • communication_mode
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/can/communication_mode/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
inc Directory Reference

Files

file | utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project_l0/inc/fir_filter.h [code]
file | project_l0/inc/math_helper.h [code]


AT32F413 Firmwary Library: transfer_by_dma_polling Directory Reference

  • usart
  • transfer_by_dma_polling
transfer_by_dma_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: irda Directory Reference

  • usart
  • irda
irda Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • dma
  • flash_to_sram
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/dma/flash_to_sram/src/main.c [code]
main program


AT32F413 Firmwary Library: extend_sram Directory Reference

  • sram
  • extend_sram
extend_sram Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: at_start_f413 Directory Reference

at_start_f413 Directory Reference

Directories

directory | examples
directory | templates


AT32F413 Firmwary Library: w25q_flash Directory Reference

  • spi
  • w25q_flash
w25q_flash Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: printer Directory Reference

  • middlewares
  • usbd_class
  • printer
printer Directory Reference

Files

file | printer_class.c [code]
usb printer class type
file | printer_class.h [code]
usb printer class file
file | printer_desc.c [code]
usb printer device descriptor
file | printer_desc.h [code]
usb printer descriptor header file


AT32F413 Firmwary Library: crc_transfer_polling Directory Reference

  • spi
  • crc_transfer_polling
crc_transfer_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • hang_mode
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/hang_mode/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • hw_flow_control
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • exint_trigger_partitioned
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: external_clock Directory Reference

  • tmr
  • external_clock
external_clock Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • composite_vcp_keyboard
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: libraries Directory Reference

  • libraries
libraries Directory Reference

Directories

directory | cmsis
directory | drivers


AT32F413 Firmwary Library: project_l0 Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
project_l0 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • keyboard
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • cortex_m4
  • systick_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • debug
  • tmr1
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | app_led4_toggle/inc/iap.h [code]
iap header file
file | app_led4_toggle/inc/tmr.h [code]
tmr header file
file | app_led4_toggle/inc/usart.h [code]
usart header file


AT32F413 Firmwary Library: encoder_tmr2 Directory Reference

  • tmr
  • encoder_tmr2
encoder_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/polling/src/main.c [code]
main program


AT32F413 Firmwary Library: data_to_gpio_flexible Directory Reference

  • dma
  • data_to_gpio_flexible
data_to_gpio_flexible Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • i2c
  • communication_int
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2c/communication_int/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • current_vref_value_check
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: printf Directory Reference

  • usart
  • printf
printf Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_input
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_input/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • dma_burst
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: calibration Directory Reference

  • acc
  • calibration
calibration Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • input_capture
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/input_capture/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • deepsleep_rtc
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • cortex_m4
  • cmsis_dsp
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c [code]
main program


AT32F413 Firmwary Library: crc Directory Reference

  • crc
crc Directory Reference

Directories

directory calculation


AT32F413 Firmwary Library: inc Directory Reference

  • crc
  • calculation
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: at32f413_gen_random_number_demo Directory Reference

  • utilities
  • at32f413_gen_random_number_demo
at32f413_gen_random_number_demo Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: cdc Directory Reference

  • middlewares
  • usbd_class
  • cdc
cdc Directory Reference

Files

file | cdc_class.c [code]
usb cdc class type
file | cdc_class.h [code]
usb cdc class file
file | cdc_desc.c [code]
usb cdc device descriptor
file | cdc_desc.h [code]
usb cdc descriptor header file


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • sleep_usart1
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/sleep_usart1/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • libraries
  • drivers
  • inc
inc Directory Reference

Files

file | at32f413_acc.h [code]
at32f413 acc header file
file | at32f413_adc.h [code]
at32f413 adc header file
file | at32f413_bpr.h [code]
at32f413 bpr header file
file | at32f413_can.h [code]
at32f413 can header file
file | at32f413_crc.h [code]
at32f413 crc header file
file | at32f413_crm.h [code]
at32f413 crm header file
file | at32f413_debug.h [code]
at32f413 debug header file
file | at32f413_def.h [code]
at32f413 macros header file
file | at32f413_dma.h [code]
at32f413 dma header file
file | at32f413_exint.h [code]
at32f413 exint header file
file | at32f413_flash.h [code]
at32f413 flash header file
file | at32f413_gpio.h [code]
at32f413 gpio header file
file | at32f413_i2c.h [code]
at32f413 i2c header file
file | at32f413_misc.h [code]
at32f413 misc header file
file | at32f413_pwc.h [code]
at32f413 pwc header file
file | at32f413_rtc.h [code]
at32f413 rtc header file
file | at32f413_sdio.h [code]
at32f413 sdio header file
file | at32f413_spi.h [code]
at32f413 spi header file
file | at32f413_tmr.h [code]
at32f413 tmr header file
file | at32f413_usart.h [code]
at32f413 usart header file
file | at32f413_usb.h [code]
at32f413 usb header file
file | at32f413_wdt.h [code]
at32f413 wdt header file
file | at32f413_wwdt.h [code]
at32f413 wwdt header file


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
src Directory Reference

Files

file | project_l0/src/arm_fir_data.c [code]
file | arm_fir_init_f32.c [code]
file | utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c [code]
main interrupt service routines.
file | fir_coefficient.c [code]
file | fir_filter.c [code]
file | utilities/at32f413_slib_demo/project_l0/src/main.c [code]
main program
file | project_l0/src/math_helper.c [code]


AT32F413 Firmwary Library: flash Directory Reference

  • flash
flash Directory Reference

Directories

directory | flash_write_read
directory | operate_spim
directory | run_in_spim


AT32F413 Firmwary Library: inc Directory Reference

  • flash
  • flash_write_read
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/flash/flash_write_read/inc/flash.h [code]
flash header file


AT32F413 Firmwary Library: utilities Directory Reference

  • utilities
utilities Directory Reference

Directories

directory | at32f413_freertos_demo
directory | at32f413_gen_random_number_demo
directory | at32f413_slib_demo
directory | at32f413_usart_iap_demo
directory | at32f413_usb_iap_demo


AT32F413 Firmwary Library: usbd_drivers Directory Reference

  • middlewares
  • usbd_drivers
usbd_drivers Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • oc_low
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/oc_low/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • templates
  • src
src Directory Reference

Files

file | project/at_start_f413/templates/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/templates/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/templates/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • printf
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/printf/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: AT32F413_Firmware_Library_V2.0.5 Directory Reference

AT32F413_Firmware_Library_V2.0.5 Directory Reference

Directories

directory | libraries
directory | main_page
directory | middlewares
directory | project
directory | utilities


AT32F413 Firmwary Library: cmsis_dsp Directory Reference

  • cortex_m4
  • cmsis_dsp
cmsis_dsp Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: exint_software_trigger Directory Reference

  • exint
  • exint_software_trigger
exint_software_trigger Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: pwm_output_tmr10 Directory Reference

  • tmr
  • pwm_output_tmr10
pwm_output_tmr10 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: audio Directory Reference

  • usb_device
  • audio
audio Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | app_led3_toggle/inc/hid_iap_user.h [code]
usb config header file
file | utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: combine_mode_ordinary_simult Directory Reference

  • adc
  • combine_mode_ordinary_simult
combine_mode_ordinary_simult Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: communication_poll Directory Reference

  • i2c
  • communication_poll
communication_poll Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: bit_band Directory Reference

  • cortex_m4
  • bit_band
bit_band Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: pwc Directory Reference

  • pwc
pwc Directory Reference

Directories

directory | deepsleep_rtc
directory | power_voltage_monitor
directory | sleep_tmr2
directory | sleep_usart1
directory | standby_rtc
directory | standby_wakeup_pin


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • smartcard
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/smartcard/src/main.c [code]
main program


AT32F413 Firmwary Library: exint Directory Reference

  • exint
exint Directory Reference

Directories

directory | exint_config
directory | exint_software_trigger


AT32F413 Firmwary Library: tmr Directory Reference

  • tmr
tmr Directory Reference

Directories

directory | 6_steps
directory | 7_pwm_output
directory | cascade_synchro
directory | complementary_signals
directory | dma
directory | dma_burst
directory | encoder_tmr2
directory | external_clock
directory | hall_xor_tmr2
directory | hang_mode
directory | input_capture
directory | oc_high
directory | oc_low
directory | oc_toggle_tmr3
directory | oc_toggle_tmr9
directory | one_cycle
directory | parallel_synchro
directory | pwm_input
directory | pwm_input_dma
directory | pwm_output_simulate
directory | pwm_output_tmr10
directory | pwm_output_tmr3
directory | timer_base
directory | tmr1_synchro
directory | tmr2_32bit


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • 7_pwm_output
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/7_pwm_output/src/main.c [code]
main program


AT32F413 Firmwary Library: i2c Directory Reference

  • i2c
i2c Directory Reference

Directories

directory | communication_dma
directory | communication_int
directory | communication_poll
directory | eeprom


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • hall_xor_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • audio
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c [code]
main interrupt service routines.
file | audio/src/audio_codec.c [code]
audio codec function
file | project/at_start_f413/examples/usb_device/audio/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • w25q_flash
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | spi_flash.h [code]
header file of spi_flash


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | app_led4_toggle/inc/hid_iap_user.h [code]
usb config header file
file | utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • acc
  • calibration
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/acc/calibration/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/acc/calibration/src/main.c [code]
main program


AT32F413 Firmwary Library: tmr_trigger_automatic_preempted Directory Reference

  • adc
  • tmr_trigger_automatic_preempted
tmr_trigger_automatic_preempted Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • oc_low
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • middlewares
  • usbd_drivers
  • inc
inc Directory Reference

Files

file | usb_std.h [code]
usb standard header file
file | usbd_core.h [code]
usb device core header file
file | usbd_int.h [code]
file | usbd_sdr.h [code]
usb standard request header file


AT32F413 Firmwary Library: oc_toggle_tmr3 Directory Reference

  • tmr
  • oc_toggle_tmr3
oc_toggle_tmr3 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: dma_burst Directory Reference

  • tmr
  • dma_burst
dma_burst Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • hall_xor_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: composite_cdc_msc Directory Reference

  • middlewares
  • usbd_class
  • composite_cdc_msc
composite_cdc_msc Directory Reference

Files

file | cdc_msc_class.c [code]
usb cdc class type
file | cdc_msc_class.h [code]
usb cdc class file
file | cdc_msc_desc.c [code]
usb cdc device descriptor
file | cdc_msc_desc.h [code]
usb cdc descriptor header file
file | composite_cdc_msc/msc_bot_scsi.c [code]
usb mass storage bulk-only transport and scsi command


AT32F413 Firmwary Library: fullduplex_polling Directory Reference

  • spi
  • fullduplex_polling
fullduplex_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • rtc
  • calendar
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/rtc/calendar/src/main.c [code]
main program
file | rtc.c [code]
this file provides template for calendar api.


AT32F413 Firmwary Library: project Directory Reference

  • project
project Directory Reference

Directories

directory | at32f413_board
directory | at_start_f413


AT32F413 Firmwary Library: standby_rtc Directory Reference

  • pwc
  • standby_rtc
standby_rtc Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: oc_high Directory Reference

  • tmr
  • oc_high
oc_high Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: idle_detection Directory Reference

  • usart
  • idle_detection
idle_detection Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: communication_int Directory Reference

  • i2c
  • communication_int
communication_int Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: source_code Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
source_code Directory Reference

Directories

directory | app_led3_toggle
directory | app_led4_toggle
directory | bootloader


AT32F413 Firmwary Library: synchronous Directory Reference

  • usart
  • synchronous
synchronous Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • halfduplex_transceiver_switch
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • msc
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/msc/src/main.c [code]
main program
file | msc/src/msc_diskio.c [code]
usb mass storage disk function


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_output_tmr10
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • sleep_tmr2
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • fullduplex_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • standby_rtc
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: device_support Directory Reference

  • libraries
  • cmsis
  • cm4
  • device_support
device_support Directory Reference

Files

file | at32f413.h [code]
at32f413 header file
file | system_at32f413.c [code]
contains all the functions for cmsis cortex-m4 system source file
file | system_at32f413.h [code]
cmsis cortex-m4 system header file.


AT32F413 Firmwary Library: pwm_input Directory Reference

  • tmr
  • pwm_input
pwm_input Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: tmr1_synchro Directory Reference

  • tmr
  • tmr1_synchro
tmr1_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: can Directory Reference

  • can
can Directory Reference

Directories

directory | communication_mode
directory | filter
directory | loopback_mode


AT32F413 Firmwary Library: virtual_msc_iap Directory Reference

  • usb_device
  • virtual_msc_iap
virtual_msc_iap Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: halfduplex_interrupt Directory Reference

  • spi
  • halfduplex_interrupt
halfduplex_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: internal_temperature_sensor Directory Reference

  • adc
  • internal_temperature_sensor
internal_temperature_sensor Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • i2c
  • communication_poll
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: gpio Directory Reference

  • gpio
gpio Directory Reference

Directories

directory | led_toggle
directory | swjtag_remap


AT32F413 Firmwary Library: inc Directory Reference

  • can
  • communication_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: sleep_tmr2 Directory Reference

  • pwc
  • sleep_tmr2
sleep_tmr2 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • external_clock
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: bpr_data Directory Reference

  • bpr
  • bpr_data
bpr_data Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • only_receive_mode_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • printf
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/printf/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/printf/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/printf/src/main.c [code]
main program


AT32F413 Firmwary Library: exint_trigger_partitioned Directory Reference

  • adc
  • exint_trigger_partitioned
exint_trigger_partitioned Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: timer_base Directory Reference

  • tmr
  • timer_base
timer_base Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: standby_wakeup_pin Directory Reference

  • pwc
  • standby_wakeup_pin
standby_wakeup_pin Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: debug Directory Reference

  • debug
debug Directory Reference

Directories

directory tmr1


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • tmr_trigger_automatic_preempted
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • virtual_msc_iap
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c [code]
main interrupt service routines.
file | flash_fat16.c [code]
fat16 file system
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c [code]
main program
file | virtual_msc_iap/src/msc_diskio.c [code]
usb mass storage disk function


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • cascade_synchro
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: calendar Directory Reference

  • rtc
  • calendar
calendar Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • complementary_signals
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/complementary_signals/src/main.c [code]
main program


AT32F413 Firmwary Library: input_capture Directory Reference

  • tmr
  • input_capture
input_capture Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | app_led3_toggle/inc/iap.h [code]
iap header file
file | app_led3_toggle/inc/tmr.h [code]
tmr header file
file | app_led3_toggle/inc/usart.h [code]
usart header file


AT32F413 Firmwary Library: app_led3_toggle Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
app_led3_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
src Directory Reference

Files

file | utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c [code]
main interrupt service routines.
file | bootloader/src/hid_iap_user.c [code]
usb hid iap user file
file | utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • smartcard
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | smartcard_config.h [code]
header file of clock program


AT32F413 Firmwary Library: pwm_output_simulate Directory Reference

  • tmr
  • pwm_output_simulate
pwm_output_simulate Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • i2s
  • halfduplex_dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c [code]
main program


AT32F413 Firmwary Library: msc Directory Reference

  • usb_device
  • msc
msc Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
src Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | app_led3_toggle/src/iap.c [code]
iap program
file | utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c [code]
main program
file | app_led3_toggle/src/tmr.c [code]
tmr program
file | app_led3_toggle/src/usart.c [code]
usart program


AT32F413 Firmwary Library: adc Directory Reference

  • adc
adc Directory Reference

Directories

directory | combine_mode_ordinary_simult
directory | current_vref_value_check
directory | exint_trigger_partitioned
directory | internal_temperature_sensor
directory | software_trigger_repeat
directory | tmr_trigger_automatic_preempted
directory | voltage_monitoring


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • 6_steps
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • rtc
  • lick_calibration
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/rtc/lick_calibration/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • sleep_tmr2
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: use_jtagpin_hardwarecs_dma Directory Reference

  • spi
  • use_jtagpin_hardwarecs_dma
use_jtagpin_hardwarecs_dma Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: acc Directory Reference

  • acc
acc Directory Reference

Directories

directory calibration


AT32F413 Firmwary Library: examples Directory Reference

examples Directory Reference

Directories

directory | acc
directory | adc
directory | bpr
directory | can
directory | cortex_m4
directory | crc
directory | crm
directory | debug
directory | dma
directory | exint
directory | flash
directory | gpio
directory | i2c
directory | i2s
directory | pwc
directory | rtc
directory | sdio
directory | spi
directory | sram
directory | tmr
directory | usart
directory | usb_device
directory | wdt
directory | wwdt


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_output_simulate
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • i2s
  • halfduplex_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: at32f413_usb_iap_demo Directory Reference

  • utilities
  • at32f413_usb_iap_demo
at32f413_usb_iap_demo Directory Reference

Directories

directory source_code


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • current_vref_value_check
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/current_vref_value_check/src/main.c [code]
main program


AT32F413 Firmwary Library: usbd_class Directory Reference

  • middlewares
  • usbd_class
usbd_class Directory Reference

Directories

directory | audio
directory | audio_hid
directory | cdc
directory | composite_cdc_keyboard
directory | composite_cdc_msc
directory | custom_hid
directory | hid_iap
directory | keyboard
directory | mouse
directory | msc
directory | printer


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • 7_pwm_output
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • audio
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | audio/inc/audio_codec.h [code]
audio codec header file
file | project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • transfer_by_dma_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: sd_mmc_card Directory Reference

  • sdio
  • sd_mmc_card
sd_mmc_card Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • crm
  • clock_failure_detection
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • flash
  • flash_write_read
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/flash/flash_write_read/src/flash.c [code]
flash program
file | project/at_start_f413/examples/flash/flash_write_read/src/main.c [code]
main program


AT32F413 Firmwary Library: i2s Directory Reference

  • i2s
i2s Directory Reference

Directories

directory | halfduplex_dma
directory | halfduplex_interrupt
directory | spii2s_switch_halfduplex_polling


AT32F413 Firmwary Library: msc Directory Reference

  • middlewares
  • usbd_class
  • msc
msc Directory Reference

Files

file | msc/msc_bot_scsi.c [code]
usb mass storage bulk-only transport and scsi command
file | msc_bot_scsi.h [code]
usb mass storage bulk-only transport and scsi command header file
file | msc_class.c [code]
usb msc class type
file | msc_class.h [code]
usb msc class file
file | msc_desc.c [code]
usb msc device descriptor
file | msc_desc.h [code]
usb msc descriptor header file


AT32F413 Firmwary Library: only_receive_mode_polling Directory Reference

  • spi
  • only_receive_mode_polling
only_receive_mode_polling Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • halfduplex_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • wdt
  • wdt_reset
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/wdt/wdt_reset/src/main.c [code]
main program


AT32F413 Firmwary Library: hang_mode Directory Reference

  • tmr
  • hang_mode
hang_mode Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • i2s
  • halfduplex_interrupt
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • input_capture
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • external_clock
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/external_clock/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_output_tmr3
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • dma_burst
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/dma_burst/src/main.c [code]
main program


AT32F413 Firmwary Library: smartcard Directory Reference

  • usart
  • smartcard
smartcard Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: usb_device Directory Reference

  • usb_device
usb_device Directory Reference

Directories

directory | audio
directory | composite_audio_hid
directory | composite_vcp_keyboard
directory | composite_vcp_msc
directory | custom_hid
directory | keyboard
directory | mouse
directory | msc
directory | printer
directory | vcp_loopback
directory | virtual_comport
directory | virtual_msc_iap


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • composite_audio_hid
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c [code]
main interrupt service routines.
file | composite_audio_hid/src/audio_codec.c [code]
audio codec function
file | project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • pwc
  • sleep_usart1
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • crc_transfer_polling
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: vcp_loopback Directory Reference

  • usb_device
  • vcp_loopback
vcp_loopback Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • bpr
  • bpr_data
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • wdt
  • wdt_reset
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • sdio
  • sd_mmc_card
  • src
src Directory Reference

Files

file | sd_mmc_card/src/at32_sdio.c [code]
this file provides a set of functions needed to manage the sdio/mmc card memory.
file | project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_gen_random_number_demo
  • inc
inc Directory Reference

Files

file | utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | random.h [code]
at32f413 random header file


AT32F413 Firmwary Library: custom_hid Directory Reference

  • usb_device
  • custom_hid
custom_hid Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • templates
  • inc
inc Directory Reference

Files

file | project/at_start_f413/templates/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/templates/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/templates/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • sdio
  • sdio_fatfs
  • inc
inc Directory Reference

Files

file | sdio_fatfs/inc/at32_sdio.h [code]
this file contains all the functions prototypes for the sd/mmc card at32_sdio driver firmware library.
file | project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | ffconf.h [code]


AT32F413 Firmwary Library: composite_vcp_msc Directory Reference

  • usb_device
  • composite_vcp_msc
composite_vcp_msc Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • rs485
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: main_page Directory Reference

  • main_page
main_page Directory Reference

Files

file main_page.h [code]


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • complementary_signals
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • i2c
  • communication_dma
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: dma Directory Reference

  • dma
dma Directory Reference

Directories

directory | data_to_gpio_flexible
directory | flash_to_sram


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • vcp_loopback
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • usb_device
  • printer
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usb_device/printer/src/main.c [code]
main program


AT32F413 Firmwary Library: hw_flow_control Directory Reference

  • usart
  • hw_flow_control
hw_flow_control Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • spi
  • halfduplex_transceiver_switch
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • standby_rtc
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/standby_rtc/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • acc
  • calibration
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/acc/calibration/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • crc_transfer_polling
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • wdt
  • wdt_standby
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/wdt/wdt_standby/src/main.c [code]
main program


AT32F413 Firmwary Library: sram Directory Reference

  • sram
sram Directory Reference

Directories

directory extend_sram


AT32F413 Firmwary Library: sdio_fatfs Directory Reference

  • sdio
  • sdio_fatfs
sdio_fatfs Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • exint
  • exint_software_trigger
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: filter Directory Reference

  • can
  • filter
filter Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • dma
  • flash_to_sram
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: voltage_monitoring Directory Reference

  • adc
  • voltage_monitoring
voltage_monitoring Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: keyboard Directory Reference

  • middlewares
  • usbd_class
  • keyboard
keyboard Directory Reference

Files

file | keyboard_class.c [code]
usb hid keyboard class type
file | keyboard_class.h [code]
usb hid keyboard header file
file | keyboard_desc.c [code]
usb hid keyboard device descriptor
file | keyboard_desc.h [code]
usb keyboard descriptor header file


AT32F413 Firmwary Library: deepsleep_rtc Directory Reference

  • pwc
  • deepsleep_rtc
deepsleep_rtc Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • can
  • loopback_mode
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/can/loopback_mode/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • virtual_msc_iap
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | flash_fat16.h [code]
fat16 file system header file
file | virtual_msc_iap/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: inc Directory Reference

  • can
  • filter
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/can/filter/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/can/filter/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/can/filter/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usart
  • irda
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usart/irda/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: software_trigger_repeat Directory Reference

  • adc
  • software_trigger_repeat
software_trigger_repeat Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
inc Directory Reference

Files

file | utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project_l1/inc/fir_filter.h [code]
file | project_l1/inc/math_helper.h [code]


AT32F413 Firmwary Library: audio Directory Reference

  • middlewares
  • usbd_class
  • audio
audio Directory Reference

Files

file | audio_class.c [code]
usb audio class type
file | audio_class.h [code]
usb audio class file
file | audio/audio_conf.h [code]
usb audio config
file | audio_desc.c [code]
usb audio device descriptor
file | audio_desc.h [code]
usb audio descriptor header file


AT32F413 Firmwary Library: src Directory Reference

  • gpio
  • led_toggle
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/gpio/led_toggle/src/main.c [code]
main program


AT32F413 Firmwary Library: halfduplex_interrupt Directory Reference

  • i2s
  • halfduplex_interrupt
halfduplex_interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: loopback_mode Directory Reference

  • can
  • loopback_mode
loopback_mode Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • irda
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/irda/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/irda/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/irda/src/main.c [code]
main program


AT32F413 Firmwary Library: lick_calibration Directory Reference

  • rtc
  • lick_calibration
lick_calibration Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
src Directory Reference

Files

file | project_l1/src/arm_fir_data.c [code]
file | utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c [code]
system clock config program
file | utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c [code]
main interrupt service routines.
file | utilities/at32f413_slib_demo/project_l1/src/main.c [code]
main program
file | project_l1/src/math_helper.c [code]


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • one_cycle
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/one_cycle/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • libraries
  • drivers
  • src
src Directory Reference

Files

file | at32f413_acc.c [code]
contains all the functions for the acc firmware library
file | at32f413_adc.c [code]
contains all the functions for the adc firmware library
file | at32f413_bpr.c [code]
contains all the functions for the bpr firmware library
file | at32f413_can.c [code]
contains all the functions for the can firmware library
file | at32f413_crc.c [code]
contains all the functions for the crc firmware library
file | at32f413_crm.c [code]
contains all the functions for the crm firmware library
file | at32f413_debug.c [code]
contains all the functions for the debug firmware library
file | at32f413_dma.c [code]
contains all the functions for the dma firmware library
file | at32f413_exint.c [code]
contains all the functions for the exint firmware library
file | at32f413_flash.c [code]
contains all the functions for the flash firmware library
file | at32f413_gpio.c [code]
contains all the functions for the gpio firmware library
file | at32f413_i2c.c [code]
contains all the functions for the i2c firmware library
file | at32f413_misc.c [code]
contains all the functions for the misc firmware library
file | at32f413_pwc.c [code]
contains all the functions for the pwc firmware library
file | at32f413_rtc.c [code]
contains all the functions for the rtc firmware library
file | at32f413_sdio.c [code]
contains all the functions for the sdio firmware library
file | at32f413_spi.c [code]
contains all the functions for the spi firmware library
file | at32f413_tmr.c [code]
contains all the functions for the tmr firmware library
file | at32f413_usart.c [code]
contains all the functions for the usart firmware library
file | at32f413_usb.c [code]
contains the functions for the usb firmware library
file | at32f413_wdt.c [code]
contains all the functions for the wdt firmware library
file | at32f413_wwdt.c [code]
contains all the functions for the wwdt firmware library


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • one_cycle
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: wwdt Directory Reference

  • wwdt
wwdt Directory Reference

Directories

directory wwdt_reset


AT32F413 Firmwary Library: src Directory Reference

  • pwc
  • standby_wakeup_pin
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c [code]
main program


AT32F413 Firmwary Library: communication_mode Directory Reference

  • can
  • communication_mode
communication_mode Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • oc_toggle_tmr3
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_freertos_demo
  • inc
inc Directory Reference

Files

file | utilities/at32f413_freertos_demo/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_freertos_demo/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_freertos_demo/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | FreeRTOSConfig.h [code]


AT32F413 Firmwary Library: hid_iap Directory Reference

  • middlewares
  • usbd_class
  • hid_iap
hid_iap Directory Reference

Files

file | hid_iap_class.c [code]
usb hid iap class type
file | hid_iap_class.h [code]
usb hid iap header file
file | hid_iap_desc.c [code]
usb hid device descriptor
file | hid_iap_desc.h [code]
usb hid descriptor header file


AT32F413 Firmwary Library: pwm_output_tmr3 Directory Reference

  • tmr
  • pwm_output_tmr3
pwm_output_tmr3 Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • pwm_output_simulate
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • i2c
  • communication_dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2c/communication_dma/src/main.c [code]
main program


AT32F413 Firmwary Library: app_led4_toggle Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
app_led4_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • combine_mode_ordinary_simult
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: app_led3_toggle Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
app_led3_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • timer_base
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • adc
  • software_trigger_repeat
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • msc
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | msc/inc/msc_diskio.h [code]
usb mass storage disk interface header file
file | project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: drivers Directory Reference

  • libraries
  • drivers
drivers Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: src Directory Reference

  • crm
  • clock_failure_detection
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/crm/clock_failure_detection/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • i2c
  • communication_poll
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/i2c/communication_poll/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • half_duplex
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/half_duplex/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • flash
  • operate_spim
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | operate_spim.h [code]
operate_spim header file


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • transfer_by_dma_interrupt
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • timer_base
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/timer_base/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • parallel_synchro
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/parallel_synchro/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • idle_detection
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/idle_detection/src/main.c [code]
main program


AT32F413 Firmwary Library: interrupt Directory Reference

  • usart
  • interrupt
interrupt Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: app_led4_toggle Directory Reference

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
app_led4_toggle Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: at32f413_freertos_demo Directory Reference

  • utilities
  • at32f413_freertos_demo
at32f413_freertos_demo Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: i2c_application_library Directory Reference

  • middlewares
  • i2c_application_library
i2c_application_library Directory Reference

Files

file | i2c_application.c [code]
the driver library of the i2c peripheral
file | i2c_application.h [code]
i2c application libray header file


AT32F413 Firmwary Library: src Directory Reference

  • tmr
  • pwm_input_dma
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c [code]
main program


AT32F413 Firmwary Library: src Directory Reference

  • usart
  • hw_flow_control
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/usart/hw_flow_control/src/main.c [code]
main program


AT32F413 Firmwary Library: cascade_synchro Directory Reference

  • tmr
  • cascade_synchro
cascade_synchro Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: calculation Directory Reference

  • crc
  • calculation
calculation Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: audio_hid Directory Reference

  • middlewares
  • usbd_class
  • audio_hid
audio_hid Directory Reference

Files

file | audio_hid/audio_conf.h [code]
usb audio config
file | audio_hid_class.c [code]
file | audio_hid_class.h [code]
file | audio_hid_desc.c [code]
file | audio_hid_desc.h [code]


AT32F413 Firmwary Library: inc Directory Reference

  • bpr
  • tamper
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: inc Directory Reference

  • usb_device
  • custom_hid
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h [code]
usb config header file


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • software_trigger_repeat
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c [code]
main program


AT32F413 Firmwary Library: flash_write_read Directory Reference

  • flash
  • flash_write_read
flash_write_read Directory Reference

Directories

directory | inc
directory | src


AT32F413 Firmwary Library: inc Directory Reference

  • tmr
  • hang_mode
  • inc
inc Directory Reference

Files

file | project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h [code]
header file of clock program
file | project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h [code]
at32f413 config header file
file | project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h [code]
header file of main interrupt service routines.


AT32F413 Firmwary Library: src Directory Reference

  • crm
  • sysclk_switch
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/crm/sysclk_switch/src/main.c [code]
main program


AT32F413 Firmwary Library: inc Directory Reference

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
inc Directory Reference

Files

file | utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h [code]
header file of clock program
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h [code]
at32f413 config header file
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h [code]
header file of main interrupt service routines.
file | utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h [code]
flash header file
file | bootloader/inc/iap.h [code]
iap header file
file | bootloader/inc/tmr.h [code]
tmr header file
file | bootloader/inc/usart.h [code]
usart header file


AT32F413 Firmwary Library: src Directory Reference

  • debug
  • tmr1
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/debug/tmr1/src/main.c [code]
main program


AT32F413 Firmwary Library: cmsis Directory Reference

  • libraries
  • cmsis
cmsis Directory Reference

Directories

directory cm4


AT32F413 Firmwary Library: src Directory Reference

  • adc
  • internal_temperature_sensor
  • src
src Directory Reference

Files

file | project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c [code]
system clock config program
file | project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c [code]
main interrupt service routines.
file | project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c [code]
main program


AT32F413 Firmwary Library: diskio.c Source File

  • sdio
  • sdio_fatfs
  • src
diskio.c
Go to the documentation of this file.
1/*-----------------------------------------------------------------------*/
2/* Low level disk I/O module SKELETON for FatFs (C)ChaN, 2019 */
3/*-----------------------------------------------------------------------*/
4/* If a working storage control module is available, it should be */
5/* attached to the FatFs via a glue function rather than modifying it. */
6/* This is an example of glue functions to attach various exsisting */
7/* storage control modules to the FatFs module with a defined API. */
8/*-----------------------------------------------------------------------*/
9
10
11#include "ff.h" /* Obtains integer types */
12#include "diskio.h" /* Declarations of disk functions */
13
14#include <string.h>
15#include "at32_sdio.h" /* Example: Header file of existing MMC/SDC contorl module */
16
17/* Definitions of physical drive number for each drive */
18#define DEV_RAM 0 /* Example: Map Ramdisk to physical drive 0 */
19#define DEV_MMC 1 /* Example: Map MMC/SD card to physical drive 1 */
20#define DEV_USB 2 /* Example: Map USB MSD to physical drive 2 */
21
22 __align(4) uint8_t sdio_data_buffer[512]; /* buf for sd_read_disk/sd_write_disk function used. */
23
24 sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt);
25 sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt);
26
34 sd_error_status_type sd_read_disk(uint8_t *buf, uint32_t sector, uint8_t cnt)
35{
36 sd_error_status_type sta = SD_OK;
37 long long lsector = sector;
38 uint8_t n;
39
40 /* data address is in block (512 byte) units. */
41 lsector <<= 9;
42
43 if((uint32_t)buf % 4 != 0)
44 {
45 for(n = 0; n < cnt; n++)
46 {
47 sta = sd_block_read(sdio_data_buffer, lsector + 512 * n, 512);
48 memcpy(buf, sdio_data_buffer, 512);
49 buf += 512;
50 }
51 }
52 else
53 {
54 if(cnt == 1)
55 {
56 sta = sd_block_read(buf, lsector, 512);
57 }
58 else
59 {
60 sta = sd_mult_blocks_read(buf, lsector, 512, cnt);
61 }
62 }
63
64 return sta;
65}
66
74 sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt)
75{
76 sd_error_status_type sta = SD_OK;
77 uint8_t n;
78 long long lsector = sector;
79
80 /* data address is in block (512 byte) units. */
81 lsector <<= 9;
82
83 if((uint32_t)buf % 4 != 0)
84 {
85 for(n = 0; n < cnt; n++)
86 {
87 memcpy(sdio_data_buffer, buf, 512);
88 sta = sd_block_write(sdio_data_buffer, lsector + 512*n, 512);
89 buf += 512;
90 }
91 }
92 else
93 {
94 if(cnt == 1)
95 {
96 sta = sd_block_write(buf, lsector, 512);
97 }
98 else
99 {
100 sta = sd_mult_blocks_write(buf, lsector, 512, cnt);
101 }
102 }
103
104 return sta;
105}
106
107/*-----------------------------------------------------------------------*/
108/* Get Drive Status */
109/*-----------------------------------------------------------------------*/
110DSTATUS disk_status (
111 BYTE pdrv /* Physical drive nmuber to identify the drive */
112)
113{
114 DSTATUS stat;
115 int result;
116
117 switch (pdrv) {
118 case DEV_RAM :
119 result = 1;
120 stat = (DSTATUS)result;
121 return stat;
122
123 case DEV_MMC :
124 result = 0;
125 stat = (DSTATUS)result;
126 return stat;
127
128 case DEV_USB :
129 result = 1;
130 stat = (DSTATUS)result;
131 return stat;
132 }
133 return STA_NOINIT;
134}
135
136
137
138/*-----------------------------------------------------------------------*/
139/* Inidialize a Drive */
140/*-----------------------------------------------------------------------*/
141DSTATUS disk_initialize (
142 BYTE pdrv /* Physical drive nmuber to identify the drive */
143)
144{
145 DSTATUS stat;
146 int result;
147
148 switch (pdrv) {
149 case DEV_RAM :
150 result = 1;
151 stat = (DSTATUS)result;
152 return stat;
153
154 case DEV_MMC :
155 result = sd_init();
156 stat = (DSTATUS)result;
157 return stat;
158
159 case DEV_USB :
160 result = 1;
161 stat = (DSTATUS)result;
162 return stat;
163 }
164 return STA_NOINIT;
165}
166
167
168
169/*-----------------------------------------------------------------------*/
170/* Read Sector(s) */
171/*-----------------------------------------------------------------------*/
172DRESULT disk_read (
173 BYTE pdrv, /* Physical drive nmuber to identify the drive */
174 BYTE *buff, /* Data buffer to store read data */
175 LBA_t sector, /* Start sector in LBA */
176 UINT count /* Number of sectors to read */
177)
178{
179 DRESULT res;
180 int result;
181
182 switch (pdrv) {
183 case DEV_RAM :
184 result = 1;
185 res = (DRESULT)result;
186 return res;
187
188 case DEV_MMC :
189 result = sd_read_disk(buff, sector, count);
190 res = (DRESULT)result;
191 return res;
192
193 case DEV_USB :
194 result = 1;
195 res = (DRESULT)result;
196 return res;
197 }
198
199 return RES_PARERR;
200}
201
202
203
204/*-----------------------------------------------------------------------*/
205/* Write Sector(s) */
206/*-----------------------------------------------------------------------*/
207#if FF_FS_READONLY == 0
208
209DRESULT disk_write (
210 BYTE pdrv, /* Physical drive nmuber to identify the drive */
211 const BYTE *buff, /* Data to be written */
212 LBA_t sector, /* Start sector in LBA */
213 UINT count /* Number of sectors to write */
214)
215{
216 DRESULT res;
217 int result;
218
219 switch (pdrv) {
220 case DEV_RAM :
221 result = 1;
222 res = (DRESULT)result;
223 return res;
224
225 case DEV_MMC :
226 result = sd_write_disk(buff, sector, count);
227 res = (DRESULT)result;
228 return res;
229
230 case DEV_USB :
231 result = 1;
232 res = (DRESULT)result;
233 return res;
234 }
235
236 return RES_PARERR;
237}
238
239#endif
240
241
242/*-----------------------------------------------------------------------*/
243/* Miscellaneous Functions */
244/*-----------------------------------------------------------------------*/
245DRESULT disk_ioctl (
246 BYTE pdrv, /* Physical drive nmuber (0..) */
247 BYTE cmd, /* Control code */
248 void *buff /* Buffer to send/receive control data */
249)
250{
251 DRESULT res;
252 int result;
253
254 switch (pdrv) {
255 case DEV_RAM :
256 result = 1;
257 res = (DRESULT)result;
258 return res;
259
260 case DEV_MMC :
261 switch(cmd){
262 case CTRL_SYNC:
263 result = RES_OK;
264 break;
265 case GET_SECTOR_SIZE:
266 *(DWORD*)buff = 512;
267 result = RES_OK;
268 break;
269 case GET_SECTOR_COUNT:
270 *(DWORD*)buff = sd_card_info.card_capacity/512;
271 result = RES_OK;
272 break;
273 case GET_BLOCK_SIZE:
274 *(DWORD*)buff = sd_card_info.card_blk_size;
275 result = RES_OK;
276 break;
277 default:
278 result = RES_PARERR;
279 break;
280 }
281 res = (DRESULT)result;
282 return res;
283
284 case DEV_USB :
285 result = 1;
286 res = (DRESULT)result;
287 return res;
288 }
289
290 return RES_PARERR;
291}
disk_read
DRESULT disk_read(BYTE pdrv, BYTE *buff, LBA_t sector, UINT count)
Definition: diskio.c:172
disk_initialize
DSTATUS disk_initialize(BYTE pdrv)
Definition: diskio.c:141
__align
__align(4)
Definition: diskio.c:22
DEV_USB
#define DEV_USB
Definition: diskio.c:20
DEV_RAM
#define DEV_RAM
Definition: diskio.c:18
disk_status
DSTATUS disk_status(BYTE pdrv)
Definition: diskio.c:110
disk_ioctl
DRESULT disk_ioctl(BYTE pdrv, BYTE cmd, void *buff)
Definition: diskio.c:245
disk_write
DRESULT disk_write(BYTE pdrv, const BYTE *buff, LBA_t sector, UINT count)
Definition: diskio.c:209
DEV_MMC
#define DEV_MMC
Definition: diskio.c:19
sd_write_disk
sd_error_status_type sd_write_disk(const uint8_t *buf, uint32_t sector, uint8_t cnt)
write sd card sector
Definition: diskio.c:74
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:48
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1181
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1482
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1360
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:72
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1270
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:74
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:119
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:242


AT32F413 Firmwary Library: ffconf.h Source File

  • sdio
  • sdio_fatfs
  • inc
ffconf.h
Go to the documentation of this file.
1/*---------------------------------------------------------------------------/
2/ FatFs Functional Configurations
3/---------------------------------------------------------------------------*/
4
5#define FFCONF_DEF 86631 /* Revision ID */
6
7/*---------------------------------------------------------------------------/
8/ Function Configurations
9/---------------------------------------------------------------------------*/
10
11#define FF_FS_READONLY 0
12/* This option switches read-only configuration. (0:Read/Write or 1:Read-only)
13/ Read-only configuration removes writing API functions, f_write(), f_sync(),
14/ f_unlink(), f_mkdir(), f_chmod(), f_rename(), f_truncate(), f_getfree()
15/ and optional writing functions as well. */
16
17
18#define FF_FS_MINIMIZE 0
19/* This option defines minimization level to remove some basic API functions.
20/
21/ 0: Basic functions are fully enabled.
22/ 1: f_stat(), f_getfree(), f_unlink(), f_mkdir(), f_truncate() and f_rename()
23/ are removed.
24/ 2: f_opendir(), f_readdir() and f_closedir() are removed in addition to 1.
25/ 3: f_lseek() function is removed in addition to 2. */
26
27
28#define FF_USE_FIND 0
29/* This option switches filtered directory read functions, f_findfirst() and
30/ f_findnext(). (0:Disable, 1:Enable 2:Enable with matching altname[] too) */
31
32
33#define FF_USE_MKFS 1//0
34/* This option switches f_mkfs() function. (0:Disable or 1:Enable) */
35
36
37#define FF_USE_FASTSEEK 1//0
38/* This option switches fast seek function. (0:Disable or 1:Enable) */
39
40
41#define FF_USE_EXPAND 0
42/* This option switches f_expand function. (0:Disable or 1:Enable) */
43
44
45#define FF_USE_CHMOD 0
46/* This option switches attribute manipulation functions, f_chmod() and f_utime().
47/ (0:Disable or 1:Enable) Also FF_FS_READONLY needs to be 0 to enable this option. */
48
49
50#define FF_USE_LABEL 0
51/* This option switches volume label functions, f_getlabel() and f_setlabel().
52/ (0:Disable or 1:Enable) */
53
54
55#define FF_USE_FORWARD 0
56/* This option switches f_forward() function. (0:Disable or 1:Enable) */
57
58
59#define FF_USE_STRFUNC 0
60#define FF_PRINT_LLI 0
61#define FF_PRINT_FLOAT 0
62#define FF_STRF_ENCODE 0
63/* FF_USE_STRFUNC switches string functions, f_gets(), f_putc(), f_puts() and
64/ f_printf().
65/
66/ 0: Disable. FF_PRINT_LLI, FF_PRINT_FLOAT and FF_STRF_ENCODE have no effect.
67/ 1: Enable without LF-CRLF conversion.
68/ 2: Enable with LF-CRLF conversion.
69/
70/ FF_PRINT_LLI = 1 makes f_printf() support long long argument and FF_PRINT_FLOAT = 1/2
71 makes f_printf() support floating point argument. These features want C99 or later.
72/ When FF_LFN_UNICODE >= 1 with LFN enabled, string functions convert the character
73/ encoding in it. FF_STRF_ENCODE selects assumption of character encoding ON THE FILE
74/ to be read/written via those functions.
75/
76/ 0: ANSI/OEM in current CP
77/ 1: Unicode in UTF-16LE
78/ 2: Unicode in UTF-16BE
79/ 3: Unicode in UTF-8
80*/
81
82
83/*---------------------------------------------------------------------------/
84/ Locale and Namespace Configurations
85/---------------------------------------------------------------------------*/
86
87#define FF_CODE_PAGE 932
88/* This option specifies the OEM code page to be used on the target system.
89/ Incorrect code page setting can cause a file open failure.
90/
91/ 437 - U.S.
92/ 720 - Arabic
93/ 737 - Greek
94/ 771 - KBL
95/ 775 - Baltic
96/ 850 - Latin 1
97/ 852 - Latin 2
98/ 855 - Cyrillic
99/ 857 - Turkish
100/ 860 - Portuguese
101/ 861 - Icelandic
102/ 862 - Hebrew
103/ 863 - Canadian French
104/ 864 - Arabic
105/ 865 - Nordic
106/ 866 - Russian
107/ 869 - Greek 2
108/ 932 - Japanese (DBCS)
109/ 936 - Simplified Chinese (DBCS)
110/ 949 - Korean (DBCS)
111/ 950 - Traditional Chinese (DBCS)
112/ 0 - Include all code pages above and configured by f_setcp()
113*/
114
115
116#define FF_USE_LFN 0
117#define FF_MAX_LFN 255
118/* The FF_USE_LFN switches the support for LFN (long file name).
119/
120/ 0: Disable LFN. FF_MAX_LFN has no effect.
121/ 1: Enable LFN with static working buffer on the BSS. Always NOT thread-safe.
122/ 2: Enable LFN with dynamic working buffer on the STACK.
123/ 3: Enable LFN with dynamic working buffer on the HEAP.
124/
125/ To enable the LFN, ffunicode.c needs to be added to the project. The LFN function
126/ requiers certain internal working buffer occupies (FF_MAX_LFN + 1) * 2 bytes and
127/ additional (FF_MAX_LFN + 44) / 15 * 32 bytes when exFAT is enabled.
128/ The FF_MAX_LFN defines size of the working buffer in UTF-16 code unit and it can
129/ be in range of 12 to 255. It is recommended to be set it 255 to fully support LFN
130/ specification.
131/ When use stack for the working buffer, take care on stack overflow. When use heap
132/ memory for the working buffer, memory management functions, ff_memalloc() and
133/ ff_memfree() exemplified in ffsystem.c, need to be added to the project. */
134
135
136#define FF_LFN_UNICODE 0
137/* This option switches the character encoding on the API when LFN is enabled.
138/
139/ 0: ANSI/OEM in current CP (TCHAR = char)
140/ 1: Unicode in UTF-16 (TCHAR = WCHAR)
141/ 2: Unicode in UTF-8 (TCHAR = char)
142/ 3: Unicode in UTF-32 (TCHAR = DWORD)
143/
144/ Also behavior of string I/O functions will be affected by this option.
145/ When LFN is not enabled, this option has no effect. */
146
147
148#define FF_LFN_BUF 255
149#define FF_SFN_BUF 12
150/* This set of options defines size of file name members in the FILINFO structure
151/ which is used to read out directory items. These values should be suffcient for
152/ the file names to read. The maximum possible length of the read file name depends
153/ on character encoding. When LFN is not enabled, these options have no effect. */
154
155
156#define FF_FS_RPATH 0
157/* This option configures support for relative path.
158/
159/ 0: Disable relative path and remove related functions.
160/ 1: Enable relative path. f_chdir() and f_chdrive() are available.
161/ 2: f_getcwd() function is available in addition to 1.
162*/
163
164
165/*---------------------------------------------------------------------------/
166/ Drive/Volume Configurations
167/---------------------------------------------------------------------------*/
168
169#define FF_VOLUMES 3//1
170/* Number of volumes (logical drives) to be used. (1-10) */
171
172
173#define FF_STR_VOLUME_ID 0
174#define FF_VOLUME_STRS "RAM","NAND","CF","SD","SD2","USB","USB2","USB3"
175/* FF_STR_VOLUME_ID switches support for volume ID in arbitrary strings.
176/ When FF_STR_VOLUME_ID is set to 1 or 2, arbitrary strings can be used as drive
177/ number in the path name. FF_VOLUME_STRS defines the volume ID strings for each
178/ logical drives. Number of items must not be less than FF_VOLUMES. Valid
179/ characters for the volume ID strings are A-Z, a-z and 0-9, however, they are
180/ compared in case-insensitive. If FF_STR_VOLUME_ID >= 1 and FF_VOLUME_STRS is
181/ not defined, a user defined volume string table needs to be defined as:
182/
183/ const char* VolumeStr[FF_VOLUMES] = {"ram","flash","sd","usb",...
184*/
185
186
187#define FF_MULTI_PARTITION 0
188/* This option switches support for multiple volumes on the physical drive.
189/ By default (0), each logical drive number is bound to the same physical drive
190/ number and only an FAT volume found on the physical drive will be mounted.
191/ When this function is enabled (1), each logical drive number can be bound to
192/ arbitrary physical drive and partition listed in the VolToPart[]. Also f_fdisk()
193/ funciton will be available. */
194
195
196#define FF_MIN_SS 512
197#define FF_MAX_SS 512
198/* This set of options configures the range of sector size to be supported. (512,
199/ 1024, 2048 or 4096) Always set both 512 for most systems, generic memory card and
200/ harddisk, but a larger value may be required for on-board flash memory and some
201/ type of optical media. When FF_MAX_SS is larger than FF_MIN_SS, FatFs is configured
202/ for variable sector size mode and disk_ioctl() function needs to implement
203/ GET_SECTOR_SIZE command. */
204
205
206#define FF_LBA64 0
207/* This option switches support for 64-bit LBA. (0:Disable or 1:Enable)
208/ To enable the 64-bit LBA, also exFAT needs to be enabled. (FF_FS_EXFAT == 1) */
209
210
211#define FF_MIN_GPT 0x10000000
212/* Minimum number of sectors to switch GPT as partitioning format in f_mkfs and
213/ f_fdisk function. 0x100000000 max. This option has no effect when FF_LBA64 == 0. */
214
215
216#define FF_USE_TRIM 0
217/* This option switches support for ATA-TRIM. (0:Disable or 1:Enable)
218/ To enable Trim function, also CTRL_TRIM command should be implemented to the
219/ disk_ioctl() function. */
220
221
222
223/*---------------------------------------------------------------------------/
224/ System Configurations
225/---------------------------------------------------------------------------*/
226
227#define FF_FS_TINY 0
228/* This option switches tiny buffer configuration. (0:Normal or 1:Tiny)
229/ At the tiny configuration, size of file object (FIL) is shrinked FF_MAX_SS bytes.
230/ Instead of private sector buffer eliminated from the file object, common sector
231/ buffer in the filesystem object (FATFS) is used for the file data transfer. */
232
233
234#define FF_FS_EXFAT 0
235/* This option switches support for exFAT filesystem. (0:Disable or 1:Enable)
236/ To enable exFAT, also LFN needs to be enabled. (FF_USE_LFN >= 1)
237/ Note that enabling exFAT discards ANSI C (C89) compatibility. */
238
239
240#define FF_FS_NORTC 1//0
241#define FF_NORTC_MON 1
242#define FF_NORTC_MDAY 1
243#define FF_NORTC_YEAR 2020
244/* The option FF_FS_NORTC switches timestamp functiton. If the system does not have
245/ any RTC function or valid timestamp is not needed, set FF_FS_NORTC = 1 to disable
246/ the timestamp function. Every object modified by FatFs will have a fixed timestamp
247/ defined by FF_NORTC_MON, FF_NORTC_MDAY and FF_NORTC_YEAR in local time.
248/ To enable timestamp function (FF_FS_NORTC = 0), get_fattime() function need to be
249/ added to the project to read current time form real-time clock. FF_NORTC_MON,
250/ FF_NORTC_MDAY and FF_NORTC_YEAR have no effect.
251/ These options have no effect in read-only configuration (FF_FS_READONLY = 1). */
252
253
254#define FF_FS_NOFSINFO 0
255/* If you need to know correct free space on the FAT32 volume, set bit 0 of this
256/ option, and f_getfree() function at first time after volume mount will force
257/ a full FAT scan. Bit 1 controls the use of last allocated cluster number.
258/
259/ bit0=0: Use free cluster count in the FSINFO if available.
260/ bit0=1: Do not trust free cluster count in the FSINFO.
261/ bit1=0: Use last allocated cluster number in the FSINFO if available.
262/ bit1=1: Do not trust last allocated cluster number in the FSINFO.
263*/
264
265
266#define FF_FS_LOCK 0
267/* The option FF_FS_LOCK switches file lock function to control duplicated file open
268/ and illegal operation to open objects. This option must be 0 when FF_FS_READONLY
269/ is 1.
270/
271/ 0: Disable file lock function. To avoid volume corruption, application program
272/ should avoid illegal open, remove and rename to the open objects.
273/ >0: Enable file lock function. The value defines how many files/sub-directories
274/ can be opened simultaneously under file lock control. Note that the file
275/ lock control is independent of re-entrancy. */
276
277
278/* #include <somertos.h> // O/S definitions */
279#define FF_FS_REENTRANT 0
280#define FF_FS_TIMEOUT 1000
281#define FF_SYNC_t HANDLE
282/* The option FF_FS_REENTRANT switches the re-entrancy (thread safe) of the FatFs
283/ module itself. Note that regardless of this option, file access to different
284/ volume is always re-entrant and volume control functions, f_mount(), f_mkfs()
285/ and f_fdisk() function, are always not re-entrant. Only file/directory access
286/ to the same volume is under control of this function.
287/
288/ 0: Disable re-entrancy. FF_FS_TIMEOUT and FF_SYNC_t have no effect.
289/ 1: Enable re-entrancy. Also user provided synchronization handlers,
290/ ff_req_grant(), ff_rel_grant(), ff_del_syncobj() and ff_cre_syncobj()
291/ function, must be added to the project. Samples are available in
292/ option/syscall.c.
293/
294/ The FF_FS_TIMEOUT defines timeout period in unit of time tick.
295/ The FF_SYNC_t defines O/S dependent sync object type. e.g. HANDLE, ID, OS_EVENT*,
296/ SemaphoreHandle_t and etc. A header file for O/S definitions needs to be
297/ included somewhere in the scope of ff.h. */
298
299
300
301/*--- End of configuration options ---*/


AT32F413 Firmwary Library: fir_coefficient.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
fir_coefficient.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2 * Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3 *
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8 * Title: arm_fir_example_f32.c
9 *
10 * Description: Example code demonstrating how an FIR filter can be used
11 * as a low pass filter.
12 *
13 * Target Processor: Cortex-M4/Cortex-M3
14 *
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42** Include Files
43** ------------------------------------------------------------------- */
44#include "at32f413.h"
45#include "arm_math.h"
46#include "fir_filter.h"
47/* ----------------------------------------------------------------------
48** Macro Defines
49** ------------------------------------------------------------------- */
50
51#define NUM_TAPS 29
52
53/* ----------------------------------------------------------------------
54** FIR Coefficients buffer generated using fir1() MATLAB function.
55** fir1(28, 6/24)
56** ------------------------------------------------------------------- */
57//#if defined ( __ICCARM__ )
58//const float32_t firCoeffs32[NUM_TAPS] @ 0x08002000 ={
59//#elif defined ( __CC_ARM )
60//const float32_t firCoeffs32[NUM_TAPS] __attribute__((at(0x08002000))) = {
61//#endif
62const float32_t firCoeffs32[NUM_TAPS] = {
63 -0.0018225230f, -0.0015879294f, +0.0000000000f, +0.0036977508f, +0.0080754303f, +0.0085302217f, -0.0000000000f, -0.0173976984f,
64 -0.0341458607f, -0.0333591565f, +0.0000000000f, +0.0676308395f, +0.1522061835f, +0.2229246956f, +0.2504960933f, +0.2229246956f,
65 +0.1522061835f, +0.0676308395f, +0.0000000000f, -0.0333591565f, -0.0341458607f, -0.0173976984f, -0.0000000000f, +0.0085302217f,
66 +0.0080754303f, +0.0036977508f, +0.0000000000f, -0.0015879294f, -0.0018225230f
67};
68
at32f413.h
at32f413 header file
firCoeffs32
const float32_t firCoeffs32[29]
Definition: fir_coefficient.c:62
NUM_TAPS
#define NUM_TAPS
Definition: fir_coefficient.c:51


AT32F413 Firmwary Library: fir_filter.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
fir_filter.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2 * Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3 *
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8 * Title: arm_fir_example_f32.c
9 *
10 * Description: Example code demonstrating how an FIR filter can be used
11 * as a low pass filter.
12 *
13 * Target Processor: Cortex-M4/Cortex-M3
14 *
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42** Include Files
43** ------------------------------------------------------------------- */
44#include "at32f413.h"
45#include "arm_math.h"
46#include "fir_filter.h"
47
48extern const float32_t firCoeffs32[];
49
50/* ----------------------------------------------------------------------
51** Macro Defines
52** ------------------------------------------------------------------- */
53#define BLOCK_SIZE 32
54#define NUM_TAPS 29
55
56/* -------------------------------------------------------------------
57 * Declare State buffer of size (numTaps + blockSize - 1)
58 * ------------------------------------------------------------------- */
59
60
61//#if defined ( __ICCARM__ )
62//static float32_t firStateF32[BLOCK_SIZE + NUM_TAPS - 1] @ 0x20017000 ;
63//#elif defined ( __CC_ARM )
64//static float32_t firStateF32[BLOCK_SIZE + NUM_TAPS - 1] __attribute__((at(0x20017000)));
65//#endif
66static float32_t firStateF32[BLOCK_SIZE + NUM_TAPS - 1] ;
67
68/* ----------------------------------------------------------------------
69** FIR Coefficients buffer generated using fir1() MATLAB function.
70** fir1(28, 6/24)
71** ------------------------------------------------------------------- */
72
73/* ----------------------------------------------------------------------
74 * FIR LPF Example
75 * ------------------------------------------------------------------- */
76void FIR_lowpass_filter(float32_t * pSrc, float32_t * pDst, uint32_t testlengthsamples)
77{
78 uint32_t i;
79 uint32_t blockSize = BLOCK_SIZE;
80 uint32_t numBlocks = testlengthsamples/BLOCK_SIZE;
81 arm_fir_instance_f32 S;
82
83
84 /* Call FIR init function to initialize the instance structure. */
85 arm_fir_init_f32(&S, NUM_TAPS, (float32_t *)&firCoeffs32[0], &firStateF32[0], blockSize);
86 /* ----------------------------------------------------------------------
87 ** Call the FIR process function for every blockSize samples
88 ** ------------------------------------------------------------------- */
89 for(i=0; i < numBlocks; i++)
90 {
91 arm_fir_f32(&S, pSrc + (i * blockSize), pDst + (i * blockSize), blockSize);
92 }
93
94}
at32f413.h
at32f413 header file
firCoeffs32
const float32_t firCoeffs32[]
Definition: fir_coefficient.c:62
firStateF32
static float32_t firStateF32[32+29 - 1]
Definition: fir_filter.c:66
NUM_TAPS
#define NUM_TAPS
Definition: fir_filter.c:54
BLOCK_SIZE
#define BLOCK_SIZE
Definition: fir_filter.c:53
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76
arm_fir_f32
void arm_fir_f32(const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59


AT32F413 Firmwary Library: flash_fat16.c Source File

  • usb_device
  • virtual_msc_iap
  • src
flash_fat16.c
Go to the documentation of this file.
1
26#include "flash_fat16.h"
27#include "usb_conf.h"
28
36#define FAT16_SECTOR_SIZE 62
37static uint8_t fat16_sector[FAT16_SECTOR_SIZE] =
38{
39 0xEB, /*0*/
40 0x3C, /*1*/
41 0x90, /*2*/
42 0x4D, /*3*/
43 0x53, /*4*/
44 0x44, /*5*/
45 0x4F, /*6*/
46 0x53, /*7*/
47 0x35, /*8*/
48 0x2E, /*9*/
49 0x30, /*10*/
50 0x00, /*11*/
51 0x08, /*12*/ //2K
52 0x04, /*13*/
53 0x06, /*14*/
54 0x00, /*15*/
55
56 0x02, /*16*/
57 0x00, /*17*/
58 0x02, /*18*/
59 0xFF, /*19*/
60 0x0F, /*20*/
61 0xF8, /*21*/
62 0x01, /*22*/
63 0x00, /*23*/
64 0x01, /*24*/
65 0x00, /*25*/
66 0x01, /*26*/
67 0x00, /*27*/
68 0x00, /*28*/
69 0x00, /*29*/
70 0x00, /*30*/
71 0x00, /*31*/
72
73 0x00, /*32*/
74 0x00, /*33*/
75 0x00, /*34*/
76 0x00, /*35*/
77 0x00, /*36*/
78 0x00, /*37*/
79 0x29, /*38*/
80 0x96, /*39*/
81 0x16, /*40*/
82 0x66, /*41*/
83 0xD3, /*42*/
84 0x20, /*43*/
85 0x20, /*44*/
86 0x20, /*45*/
87 0x20, /*46*/
88 0x20, /*47*/
89
90 0x20, /*48*/
91 0x20, /*49*/
92 0x20, /*50*/
93 0x20, /*51*/
94 0x20, /*52*/
95 0x20, /*53*/
96 0x46, /*54*/
97 0x41, /*55*/
98 0x54, /*56*/
99 0x31, /*57*/
100 0x36, /*58*/
101 0x20, /*59*/
102 0x20, /*60*/
103 0x20 /*61*/
104};
105
106
107
108const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]=
109{
110 0x20, /*11 - Archive Attribute set */
111 0x00, /*12 - Reserved */
112 0x4B, /*13 - Create Time Tenth */
113 0x9C, /*14 - Create Time */
114 0x42, /*15 - Create Time */
115 0x92, /*16 - Create Date */
116 0x38, /*17 - Create Date */
117 0x92, /*18 - Last Access Date */
118 0x38, /*19 - Last Access Date */
119 0x00, /*20 - Not used in FAT16 */
120 0x00, /*21 - Not used in FAT16 */
121 0x9D, /*22 - Write Time */
122 0x42, /*23 - Write Time */
123 0x92, /*24 - Write Date */
124 0x38, /*25 - Write Date */
125 0x00, /*26 - First Cluster (none, because file is empty) */
126 0x00, /*27 - First Cluster (none, because file is empty) */
127 0x00, /*28 - File Size */
128 0x00, /*29 - File Size */
129 0x00, /*30 - File Size */
130 0x00, /*31 - File Size */
131 'A','T','3','2',' ','I','A','P',' ',' ',' ', /*32-42 - Volume label */
132 0x08, /*43 - File attribute = Volume label */
133 0x00, /*44 - Reserved */
134 0x00, /*45 - Create Time Tenth */
135 0x00, /*46 - Create Time */
136 0x00, /*47 - Create Time */
137 0x00, /*48 - Create Date */
138 0x00, /*49 - Create Date */
139 0x00, /*50 - Last Access Date */
140 0x00, /*51 - Last Access Date */
141 0x00, /*52 - Not used in FAT16 */
142 0x00, /*53 - Not used in FAT16 */
143 0x9D, /*54 - Write Time */
144 0x42, /*55 - Write Time */
145 0x92, /*56 - Write Date */
146 0x38, /*57 - Write Date */
147};
148
149const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE] =
150{
151 0xF8,
152 0xFF,
153 0xFF,
154 0xFF
155};
156
157uint8_t fat16_file_name[FAT16_FILENAME_SIZE] =
158{
159 'R',
160 'e',
161 'a',
162 'd',
163 'y',
164 ' ',
165 ' ',
166 ' ',
167 'T',
168 'X',
169 'T'
170};
171
172 fat_dir_type g_file_attr;
173 flash_iap_type flash_iap;
174uint32_t file_write_nr = 0;
175uint8_t file_match = 0;
176
177uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
178uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
179uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len);
180uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len);
181uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len);
182uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len);
183uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len);
184uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len);
185void flash_fat16_clear_upgrade_flag(void);
186void flash_fat16_set_upgrade_flag(void);
187
195uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len)
196{
197 uint32_t i_index;
198 for(i_index = 0; i_index < len; i_index ++)
199 {
200 dst[i_index] = src[i_index];
201 }
202 return i_index;
203}
204
212uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len)
213{
214 uint32_t i_index;
215 for(i_index = 0; i_index < len; i_index ++)
216 {
217 dst[i_index] = (uint8_t)set;
218 }
219 return i_index;
220}
221
229uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len)
230{
231 uint32_t i_index;
232 for(i_index = 0; i_index < len; i_index ++)
233 {
234 if(dst[i_index] != src[i_index])
235 return 1;
236 }
237 return 0;
238}
239
245void flash_fat16_clear_upgrade_flag(void)
246{
247 flash_unlock();
248 flash_sector_erase(flash_iap.flash_app_addr - flash_iap.sector_size);
249 flash_lock();
250}
251
257void flash_fat16_set_upgrade_flag(void)
258{
259 flash_unlock();
260 flash_word_program(flash_iap.flash_app_addr - flash_iap.sector_size,
261 IAP_UPGRADE_COMPLETE_FLAG);
262 flash_lock();
263}
264
270uint8_t flash_fat16_get_upgrade_flag(void)
271{
272 uint32_t flag_address = flash_iap.flash_app_addr - flash_iap.sector_size;
273 if(*((uint32_t *)flag_address) == IAP_UPGRADE_COMPLETE_FLAG)
274 {
275 return IAP_SUCCESS;
276 }
277 else
278 {
279 return IAP_FAILED;
280 }
281}
282
290uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
291{
292 uint32_t i_index = 0;
293 switch(fat_lbk)
294 {
295 case FLASH_FAT16_BOOT_SECTOR_ADDR:
296 i_index += fat16_memory_copy(data, fat16_sector, FAT16_SECTOR_SIZE);
297 i_index += 2;
298
299 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
300 data[510] = 0x55;
301 data[511] = 0xAA;
302
303 break;
304 case FLASH_FAT16_1_ADDR:
305 case FLASH_FAT16_2_ADDR:
306 i_index += fat16_memory_copy(data, fat16_table_sector0, FAT16_TABLE_SIZE);
307
308 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
309 break;
310 case FLASH_FAT16_ROOT_ADDR:
311 i_index += fat16_memory_copy(data, fat16_file_name, FAT16_FILENAME_SIZE);
312 i_index += fat16_memory_copy(data + i_index, fat16_root_dir_sector, FAT16_DIR_SIZE);
313
314 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
315 break;
316 default:
317 i_index = 0;
318 fat16_memory_memset(data+i_index, 0, FAT16_BYTE_PER_SIZE-i_index);
319 break;
320 }
321 return FAT16_BYTE_PER_SIZE;
322}
323
331uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
332{
333 switch(fat_lbk)
334 {
335 case FLASH_FAT16_BOOT_SECTOR_ADDR:
336 case FLASH_FAT16_1_ADDR:
337 case FLASH_FAT16_2_ADDR:
338 break;
339 case FLASH_FAT16_ROOT_ADDR:
340 flash_fat16_boot_dir_write(fat_lbk, data, len);
341 break;
342 default:
343 if(fat_lbk >= FLASH_FAT16_FILE_START_ADDR)
344 {
345 flash_fat16_sector_write(fat_lbk, data, len);
346 }
347 break;
348
349 }
350 return len;
351}
352
359uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
360{
361 uint8_t i_index = 0;
362 for(i_index = 0; i_index < len && i_index < 8; i_index ++)
363 {
364 fat16_file_name[i_index] = file_name[i_index];
365 }
366
367 for(; i_index < 8; i_index ++)
368 {
369 fat16_file_name[i_index] = ' ';
370 }
371 return i_index;
372}
373
381uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
382{
383 fat_dir_type *pdir = (fat_dir_type *)data;
384 uint32_t i_index = 2, loop_len = 0;
385
386 pdir ++;
387 pdir ++;
388 loop_len += 64;
389
390 while(i_index ++ < 512 && loop_len < len)
391 {
392 if((pdir->attr == 0x20) && ((pdir + 1)->attr == 0x00))
393 {
394 break;
395 }
396 else
397 {
398 pdir ++;
399 }
400 loop_len += 32;
401 }
402
403 if(i_index <= 512 && loop_len < len)
404 {
405 fat16_memory_copy((uint8_t *)&g_file_attr, (const uint8_t *)pdir, 32);
406
407 if(file_match == 1)
408 {
409 file_match = 0;
410 if(g_file_attr.file_size > 0)
411 {
412 if(flash_iap.file_write_nr >= g_file_attr.file_size)
413 {
414 /* upgrade finish */
415 flash_iap.file_write_nr = 0;
416 flash_iap.msc_up_status = UPGRADE_SUCCESS;
417
418 /* set the upgrade done flag to flash */
419 flash_fat16_set_upgrade_flag();
420 }
421 }
422 }
423 g_file_attr.write_data = 0;
424 g_file_attr.write_time = 0;
425 flash_iap.file_write_nr = 0;
426 }
427 else
428 {
429 fat16_memory_memset((uint8_t *)&g_file_attr, 0, 32);
430 }
431 return len;
432}
433
439uint32_t flash_fat16_addr_offset(uint8_t *file_name)
440{
441 uint8_t i_index = 0, offset_shift = 20;
442 uint32_t offset = 0;
443 uint8_t *pfile = file_name;
444
445 if(*pfile != 'A')
446 {
447 return INVAILD_OFFSET_ADDR;
448 }
449 pfile += 1;
450
451 for(i_index = 0; i_index < 6; i_index ++)
452 {
453 if(*pfile >= '0' && *pfile <= '9')
454 {
455 offset |= (*pfile - '0') << offset_shift;
456 }
457 else if(*pfile >= 'A' && *pfile <= 'F')
458 {
459 offset |= (*pfile - 'A' + 0xA) << offset_shift;
460 }
461 else if(*pfile >= 'a' && *pfile <= 'f')
462 {
463 offset |= (*pfile - 'a' + 0xA) << offset_shift;
464 }
465 else
466 {
467 return INVAILD_OFFSET_ADDR;
468 }
469 pfile ++;
470 offset_shift -= 4;
471 }
472
473 if((offset < (flash_iap.flash_app_addr - flash_iap.flash_base_addr)) ||
474 (offset > flash_iap.flash_size ))
475 {
476 return INVAILD_OFFSET_ADDR;
477 }
478 return offset;
479}
480
488uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
489{
490 uint32_t file_size = g_file_attr.file_size;
491 uint32_t flash_offset = 0;
492 uint32_t status;
493
494 /* check the suffix is .bin or .BIN*/
495 if((fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[8],
496 (uint8_t *)FILE_SUFFIX1_NAME, FILE_SUFFIX1_LEN) == 0) ||
497 (fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[8],
498 (uint8_t *)FILE_SUFFIX2_NAME, FILE_SUFFIX2_LEN) == 0))
499 {
500 /* check the upgrade status */
501 if(flash_iap.msc_up_status == UPGRADE_DONE || flash_iap.msc_up_status == UPGRADE_SUCCESS)
502 {
503 return 0;
504 }
505
506 if(g_file_attr.file_size == 0)
507 {
508 g_file_attr.file_size = flash_iap.flash_app_size;
509 file_match = 1;
510 }
511
512 file_size = g_file_attr.file_size;
513
514 if(flash_iap.msc_up_status == UPGRADE_READY)
515 {
516 /* get offset address from filename */
517 flash_offset = flash_fat16_addr_offset(g_file_attr.file_name);
518
519 if(flash_offset == INVAILD_OFFSET_ADDR)
520 {
521 /* use default app address */
522 flash_iap.write_addr = FLASH_APP_START_ADDR;
523 }
524 else
525 {
526 flash_iap.write_addr = flash_offset + flash_iap.flash_base_addr;
527 }
528 /* clear upgrade flag */
529 flash_fat16_clear_upgrade_flag();
530
531 flash_iap.msc_up_status = UPGRAGE_ONGOING;
532 }
533
534 if(flash_iap.flash_app_size >= g_file_attr.file_size)
535 {
536 if((flash_iap.file_write_nr + len) >= file_size)
537 {
538 len = file_size - flash_iap.file_write_nr;
539 }
540 /* write data to flash and check crc */
541 status = flash_write_data(flash_iap.write_addr + flash_iap.file_write_nr, data, len);
542
543 flash_iap.file_write_nr += len;
544
545 if(status == 0)
546 {
547 if(flash_iap.file_write_nr >= file_size)
548 {
549 /* upgrade finish */
550 flash_iap.file_write_nr = 0;
551 flash_iap.msc_up_status = UPGRADE_SUCCESS;
552
553 /* set the upgrade done flag to flash */
554 flash_fat16_set_upgrade_flag();
555 }
556 }
557 else
558 {
559 /* upgrade failed */
560 flash_iap.file_write_nr = 0;
561 flash_iap.msc_up_status = UPGRADE_FAILED;
562 }
563 }
564 else
565 {
566 /* upgrade file is large than flash size */
567 flash_iap.msc_up_status = UPGRADE_LARGE;
568 }
569
570 }
571 else if((fat16_memory_cmp((uint8_t *)&g_file_attr.file_name[0],
572 (uint8_t *)"JUMP", 4) == 0))
573 {
574 /* receive jump command file */
575 flash_iap.msc_up_status = UPGRADE_JUMP;
576 }
577 else
578 {
579 /* unkonw upgrade status */
580 }
581
582 return len;
583}
584
592uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len)
593{
594 uint32_t flash_crc = 0;
595 uint32_t data_crc = 0;
596 uint32_t i_index = 0;
597 uint32_t wlen = len / sizeof(uint32_t);
598 uint32_t remain_len = len % sizeof(uint32_t);
599 uint32_t *u32data = (uint32_t *)data;
600 uint32_t *flash_addr = (uint32_t *)address;
601
602 /* enable crc clock */
603 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
604
605 if(remain_len)
606 {
607 wlen += 1;
608 for(i_index = 0; i_index < (4 - remain_len); i_index ++)
609 {
610 data[len+i_index] = 0xFF;
611 }
612 }
613
614 /* calculate write buffer */
615 crc_data_reset();
616 for(i_index = 0; i_index < wlen; i_index ++)
617 {
618 data_crc = crc_one_word_calculate(u32data[i_index]);
619 }
620
621 /* calculate flash data */
622 crc_data_reset();
623 for(i_index = 0; i_index < wlen; i_index ++)
624 {
625 flash_crc = crc_one_word_calculate(*flash_addr++);
626 }
627 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, FALSE);
628
629 if(data_crc != flash_crc)
630 return 1;
631
632 return 0;
633
634}
635
643uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len)
644{
645 uint32_t i_index;
646 for(i_index = 0; i_index < len; i_index ++)
647 {
648 data[i_index] = *(uint8_t *)address;
649 address += 1;
650 }
651 return i_index;
652}
653
654
662uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len)
663{
664 uint32_t waddr = address;
665 uint32_t wlength = len;
666 uint32_t i_index = 0;
667 if((address + len) > flash_iap.flash_base_addr + flash_iap.flash_size)
668 {
669 return 1;
670 }
671
672 if((waddr & flash_iap.sector_mask) == 0)
673 {
674 flash_unlock();
675 if(len > flash_iap.sector_size)
676 {
677 for(; wlength >= flash_iap.sector_size; wlength -= flash_iap.sector_size)
678 {
679 flash_sector_erase(waddr);
680 waddr += flash_iap.sector_size;
681 }
682 if(wlength > 0)
683 {
684 flash_sector_erase(waddr);
685 }
686 }
687 else
688 {
689 flash_sector_erase(waddr);
690 }
691
692 flash_lock();
693 }
694
695 waddr = address;
696 flash_unlock();
697 for(i_index = 0; i_index < len; i_index ++)
698 {
699 flash_byte_program(waddr+i_index, data[i_index]);
700 }
701 flash_lock();
702
703 return flash_crc_check(address, data, len);
704}
705
711void flash_fat16_init(void)
712{
713 uint32_t flash_size = *(uint32_t *)0x1FFFF7E0;
714 flash_iap.flash_base_addr = FLASH_BASE;
715 flash_iap.flash_app_addr = FLASH_APP_START_ADDR;
716 flash_iap.write_addr = FLASH_APP_START_ADDR;
717 flash_iap.flash_size = flash_size << 10;
718
719 flash_iap.flash_app_size = flash_iap.flash_size -
720 (flash_iap.flash_app_addr -
721 flash_iap.flash_base_addr);
722
723 if(flash_size < 0x100)
724 {
725 flash_iap.sector_size = FLASH_SECTOR_1K_SIZE;
726 flash_iap.sector_mask = FLASH_SECTOR_1K_ALLGNED;
727 }
728 else
729 {
730 flash_iap.sector_size = FLASH_SECTOR_2K_SIZE;
731 flash_iap.sector_mask = FLASH_SECTOR_2K_ALLGNED;
732 }
733
734}
735
736
737
flash_fat16.h
fat16 file system header file
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: flash_fat16.c:359
FAT16_SECTOR_SIZE
#define FAT16_SECTOR_SIZE
Definition: flash_fat16.c:36
g_file_attr
fat_dir_type g_file_attr
Definition: flash_fat16.c:172
fat16_sector
static uint8_t fat16_sector[62]
Definition: flash_fat16.c:37
flash_read_data
uint32_t flash_read_data(uint32_t address, uint8_t *data, uint32_t len)
read data from flash
Definition: flash_fat16.c:643
file_match
uint8_t file_match
Definition: flash_fat16.c:175
fat16_root_dir_sector
const uint8_t fat16_root_dir_sector[FAT16_DIR_SIZE]
Definition: flash_fat16.c:108
file_write_nr
uint32_t file_write_nr
Definition: flash_fat16.c:174
flash_fat16_addr_offset
uint32_t flash_fat16_addr_offset(uint8_t *file_name)
get offset address
Definition: flash_fat16.c:439
fat16_table_sector0
const uint8_t fat16_table_sector0[FAT16_TABLE_SIZE]
Definition: flash_fat16.c:149
flash_fat16_clear_upgrade_flag
void flash_fat16_clear_upgrade_flag(void)
clear iap upgrade flag
Definition: flash_fat16.c:245
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: flash_fat16.c:270
fat16_memory_memset
uint32_t fat16_memory_memset(uint8_t *dst, uint32_t set, uint32_t len)
memset function
Definition: flash_fat16.c:212
flash_iap
flash_iap_type flash_iap
Definition: flash_fat16.c:173
flash_crc_check
uint32_t flash_crc_check(uint32_t address, uint8_t *data, uint32_t len)
crc check
Definition: flash_fat16.c:592
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: flash_fat16.c:331
fat16_memory_cmp
uint32_t fat16_memory_cmp(uint8_t *dst, uint8_t *src, uint32_t len)
memory compare function
Definition: flash_fat16.c:229
flash_fat16_sector_write
uint32_t flash_fat16_sector_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write sector
Definition: flash_fat16.c:488
flash_fat16_set_upgrade_flag
void flash_fat16_set_upgrade_flag(void)
set iap upgrade complete flag
Definition: flash_fat16.c:257
flash_write_data
uint32_t flash_write_data(uint32_t address, uint8_t *data, uint32_t len)
write data to flash
Definition: flash_fat16.c:662
fat16_memory_copy
uint32_t fat16_memory_copy(uint8_t *dst, const uint8_t *src, uint32_t len)
memory copy function
Definition: flash_fat16.c:195
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: flash_fat16.c:711
flash_fat16_boot_dir_write
uint32_t flash_fat16_boot_dir_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
boot dir write
Definition: flash_fat16.c:381
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: flash_fat16.c:290
fat16_file_name
uint8_t fat16_file_name[FAT16_FILENAME_SIZE]
Definition: flash_fat16.c:157
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:49
crc_one_word_calculate
uint32_t crc_one_word_calculate(uint32_t data)
compute the 32-bit crc of a given data word(32-bit).
Definition: at32f413_crc.c:60
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f413_crm.h:106
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:533
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:291
FLASH_APP_START_ADDR
#define FLASH_APP_START_ADDR
Definition: flash_fat16.h:60
FLASH_SECTOR_1K_ALLGNED
#define FLASH_SECTOR_1K_ALLGNED
Definition: flash_fat16.h:66
FAT16_TABLE_SIZE
#define FAT16_TABLE_SIZE
Definition: flash_fat16.h:49
INVAILD_OFFSET_ADDR
#define INVAILD_OFFSET_ADDR
Definition: flash_fat16.h:75
FLASH_FAT16_2_ADDR
#define FLASH_FAT16_2_ADDR
Definition: flash_fat16.h:56
FLASH_FAT16_1_ADDR
#define FLASH_FAT16_1_ADDR
Definition: flash_fat16.h:55
FLASH_FAT16_ROOT_ADDR
#define FLASH_FAT16_ROOT_ADDR
Definition: flash_fat16.h:57
FAT16_DIR_SIZE
#define FAT16_DIR_SIZE
Definition: flash_fat16.h:52
FLASH_SECTOR_2K_SIZE
#define FLASH_SECTOR_2K_SIZE
Definition: flash_fat16.h:63
FILE_SUFFIX1_NAME
#define FILE_SUFFIX1_NAME
Definition: flash_fat16.h:72
FLASH_FAT16_FILE_START_ADDR
#define FLASH_FAT16_FILE_START_ADDR
Definition: flash_fat16.h:58
FILE_SUFFIX2_LEN
#define FILE_SUFFIX2_LEN
Definition: flash_fat16.h:71
FLASH_SECTOR_2K_ALLGNED
#define FLASH_SECTOR_2K_ALLGNED
Definition: flash_fat16.h:67
FLASH_FAT16_BOOT_SECTOR_ADDR
#define FLASH_FAT16_BOOT_SECTOR_ADDR
Definition: flash_fat16.h:54
FILE_SUFFIX1_LEN
#define FILE_SUFFIX1_LEN
Definition: flash_fat16.h:70
FAT16_BYTE_PER_SIZE
#define FAT16_BYTE_PER_SIZE
Definition: flash_fat16.h:50
FILE_SUFFIX2_NAME
#define FILE_SUFFIX2_NAME
Definition: flash_fat16.h:73
FAT16_FILENAME_SIZE
#define FAT16_FILENAME_SIZE
Definition: flash_fat16.h:51
FLASH_SECTOR_1K_SIZE
#define FLASH_SECTOR_1K_SIZE
Definition: flash_fat16.h:62
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: flash_fat16.h:86
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: flash_fat16.h:89
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: flash_fat16.h:85
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: flash_fat16.h:84
UPGRADE_READY
@ UPGRADE_READY
Definition: flash_fat16.h:82
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: flash_fat16.h:83
UPGRADE_DONE
@ UPGRADE_DONE
Definition: flash_fat16.h:88
IAP_UPGRADE_COMPLETE_FLAG
#define IAP_UPGRADE_COMPLETE_FLAG
Definition: hid_iap_class.h:78
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
fat_dir_type
Definition: flash_fat16.h:93
fat_dir_type::write_data
uint16_t write_data
Definition: flash_fat16.h:103
fat_dir_type::file_size
uint32_t file_size
Definition: flash_fat16.h:105
fat_dir_type::write_time
uint16_t write_time
Definition: flash_fat16.h:102
fat_dir_type::file_name
uint8_t file_name[11]
Definition: flash_fat16.h:94
fat_dir_type::attr
uint8_t attr
Definition: flash_fat16.h:95
flash_iap_type
Definition: flash_fat16.h:109
flash_iap_type::flash_size
uint32_t flash_size
Definition: flash_fat16.h:112
flash_iap_type::msc_up_status
upgrade_status_type msc_up_status
Definition: flash_fat16.h:122
flash_iap_type::flash_base_addr
uint32_t flash_base_addr
Definition: flash_fat16.h:110
flash_iap_type::sector_size
uint32_t sector_size
Definition: flash_fat16.h:114
flash_iap_type::sector_mask
uint32_t sector_mask
Definition: flash_fat16.h:115
flash_iap_type::file_write_nr
uint32_t file_write_nr
Definition: flash_fat16.h:121
flash_iap_type::flash_app_size
uint32_t flash_app_size
Definition: flash_fat16.h:113
flash_iap_type::write_addr
uint32_t write_addr
Definition: flash_fat16.h:120
flash_iap_type::flash_app_addr
uint32_t flash_app_addr
Definition: flash_fat16.h:111


AT32F413 Firmwary Library: flash_fat16.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
flash_fat16.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __FLASH_FAT16_H
28#define __FLASH_FAT16_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36
48#define FAT16_SECTOR_SIZE 62
49#define FAT16_TABLE_SIZE 4
50#define FAT16_BYTE_PER_SIZE 2048
51#define FAT16_FILENAME_SIZE 11
52#define FAT16_DIR_SIZE 47
53
54#define FLASH_FAT16_BOOT_SECTOR_ADDR 0x00
55#define FLASH_FAT16_1_ADDR 0x3000
56#define FLASH_FAT16_2_ADDR 0x3800
57#define FLASH_FAT16_ROOT_ADDR 0x4000
58#define FLASH_FAT16_FILE_START_ADDR 0x8800
59
60#define FLASH_APP_START_ADDR 0x08005000
61
62#define FLASH_SECTOR_1K_SIZE 0x400
63#define FLASH_SECTOR_2K_SIZE 0x800
64#define FLASH_SECTOR_4K_SIZE 0x1000
65
66#define FLASH_SECTOR_1K_ALLGNED 0x3FF
67#define FLASH_SECTOR_2K_ALLGNED 0x7FF
68#define FLASH_SECTOR_4K_ALLGNED 0xFFF
69
70#define FILE_SUFFIX1_LEN 3
71#define FILE_SUFFIX2_LEN 3
72#define FILE_SUFFIX1_NAME "BIN"
73#define FILE_SUFFIX2_NAME "bin"
74
75#define INVAILD_OFFSET_ADDR 0xFFFFFFFF
76#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
77#define IAP_SUCCESS 0
78#define IAP_FAILED 1
79
80typedef enum
81{
82 UPGRADE_READY = 0,
83 UPGRAGE_ONGOING,
84 UPGRADE_SUCCESS,
85 UPGRADE_FAILED,
86 UPGRADE_LARGE,
87 UPGRADE_UNKNOWN,
88 UPGRADE_DONE,
89 UPGRADE_JUMP
90}upgrade_status_type;
91
92typedef struct
93{
94 uint8_t file_name[11];
95 uint8_t attr;
96 uint8_t res;
97 uint8_t create_time_tenth;
98 uint16_t create_time;
99 uint16_t create_data;
100 uint16_t last_access_data;
101 uint16_t clus_high;
102 uint16_t write_time;
103 uint16_t write_data;
104 uint16_t clus_low;
105 uint32_t file_size;
106}fat_dir_type;
107
108typedef struct
109{
110 uint32_t flash_base_addr;
111 uint32_t flash_app_addr;
112 uint32_t flash_size;
113 uint32_t flash_app_size;
114 uint32_t sector_size;
115 uint32_t sector_mask;
116 uint32_t firmware_length;
117 uint32_t write_crc;
118 uint32_t read_crc;
119
120 uint32_t write_addr;
121 uint32_t file_write_nr;
122 upgrade_status_type msc_up_status;
123}flash_iap_type;
124
125extern flash_iap_type flash_iap;
126
127uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len);
128uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len);
129
130void flash_fat16_init(void);
131void flash_fat16_loop_status(void);
132uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len);
133uint8_t flash_fat16_get_upgrade_flag(void);
134
147#ifdef __cplusplus
148}
149#endif
150
151#endif
152
upgrade_status_type
upgrade_status_type
Definition: flash_fat16.h:81
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: flash_fat16.c:359
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: flash_fat16.c:270
flash_fat16_loop_status
void flash_fat16_loop_status(void)
loop status
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:179
flash_iap
flash_iap_type flash_iap
Definition: flash_fat16.c:173
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: flash_fat16.c:331
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: flash_fat16.c:711
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: flash_fat16.c:290
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: flash_fat16.h:86
UPGRADE_UNKNOWN
@ UPGRADE_UNKNOWN
Definition: flash_fat16.h:87
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: flash_fat16.h:89
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: flash_fat16.h:85
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: flash_fat16.h:84
UPGRADE_READY
@ UPGRADE_READY
Definition: flash_fat16.h:82
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: flash_fat16.h:83
UPGRADE_DONE
@ UPGRADE_DONE
Definition: flash_fat16.h:88
fat_dir_type
Definition: flash_fat16.h:93
fat_dir_type::clus_low
uint16_t clus_low
Definition: flash_fat16.h:104
fat_dir_type::write_data
uint16_t write_data
Definition: flash_fat16.h:103
fat_dir_type::file_size
uint32_t file_size
Definition: flash_fat16.h:105
fat_dir_type::last_access_data
uint16_t last_access_data
Definition: flash_fat16.h:100
fat_dir_type::write_time
uint16_t write_time
Definition: flash_fat16.h:102
fat_dir_type::create_time
uint16_t create_time
Definition: flash_fat16.h:98
fat_dir_type::create_time_tenth
uint8_t create_time_tenth
Definition: flash_fat16.h:97
fat_dir_type::create_data
uint16_t create_data
Definition: flash_fat16.h:99
fat_dir_type::clus_high
uint16_t clus_high
Definition: flash_fat16.h:101
fat_dir_type::res
uint8_t res
Definition: flash_fat16.h:96
fat_dir_type::attr
uint8_t attr
Definition: flash_fat16.h:95
flash_iap_type
Definition: flash_fat16.h:109
flash_iap_type::flash_size
uint32_t flash_size
Definition: flash_fat16.h:112
flash_iap_type::read_crc
uint32_t read_crc
Definition: flash_fat16.h:118
flash_iap_type::msc_up_status
upgrade_status_type msc_up_status
Definition: flash_fat16.h:122
flash_iap_type::flash_base_addr
uint32_t flash_base_addr
Definition: flash_fat16.h:110
flash_iap_type::write_crc
uint32_t write_crc
Definition: flash_fat16.h:117
flash_iap_type::sector_size
uint32_t sector_size
Definition: flash_fat16.h:114
flash_iap_type::firmware_length
uint32_t firmware_length
Definition: flash_fat16.h:116
flash_iap_type::sector_mask
uint32_t sector_mask
Definition: flash_fat16.h:115
flash_iap_type::file_write_nr
uint32_t file_write_nr
Definition: flash_fat16.h:121
flash_iap_type::flash_app_size
uint32_t flash_app_size
Definition: flash_fat16.h:113
flash_iap_type::write_addr
uint32_t write_addr
Definition: flash_fat16.h:120
flash_iap_type::flash_app_addr
uint32_t flash_app_addr
Definition: flash_fat16.h:111
usb_conf.h
usb config header file


AT32F413 Firmwary Library: hid_iap_class.c Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "hid_iap_class.h"
28#include "hid_iap_desc.h"
29
44static usb_sts_type class_init_handler(void *udev);
45static usb_sts_type class_clear_handler(void *udev);
46static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
47static usb_sts_type class_ept0_tx_handler(void *udev);
48static usb_sts_type class_ept0_rx_handler(void *udev);
49static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
51static usb_sts_type class_sof_handler(void *udev);
52static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
53
54 iap_info_type iap_info;
55
56/* usb device class handler */
57 usbd_class_handler hid_iap_class_handler =
58{
59 class_init_handler,
60 class_clear_handler,
61 class_setup_handler,
62 class_ept0_tx_handler,
63 class_ept0_rx_handler,
64 class_in_handler,
65 class_out_handler,
66 class_sof_handler,
67 class_event_handler,
68 &iap_info
69};
70
76static usb_sts_type class_init_handler(void *udev)
77{
78 usb_sts_type status = USB_OK;
79 usbd_core_type *pudev = (usbd_core_type *)udev;
80 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
81 /* open hid iap in endpoint */
82 usbd_ept_open(pudev, USBD_HIDIAP_IN_EPT, EPT_INT_TYPE, USBD_HIDIAP_IN_MAXPACKET_SIZE);
83
84 /* open hid iap out endpoint */
85 usbd_ept_open(pudev, USBD_HIDIAP_OUT_EPT, EPT_INT_TYPE, USBD_HIDIAP_OUT_MAXPACKET_SIZE);
86
87 /* set out endpoint to receive status */
88 usbd_ept_recv(pudev, USBD_HIDIAP_OUT_EPT, piap->g_rxhid_buff, USBD_HIDIAP_OUT_MAXPACKET_SIZE);
89
90 return status;
91}
92
98static usb_sts_type class_clear_handler(void *udev)
99{
100 usb_sts_type status = USB_OK;
101 usbd_core_type *pudev = (usbd_core_type *)udev;
102
103 /* close hid iap in endpoint */
104 usbd_ept_close(pudev, USBD_HIDIAP_IN_EPT);
105
106 /* close hid iap out endpoint */
107 usbd_ept_close(pudev, USBD_HIDIAP_OUT_EPT);
108
109 return status;
110}
111
118static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
119{
120 usb_sts_type status = USB_OK;
121 usbd_core_type *pudev = (usbd_core_type *)udev;
122 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
123 uint16_t len;
124 uint8_t *buf;
125
126 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
127 {
128 /* class request */
129 case USB_REQ_TYPE_CLASS:
130 switch(setup->bRequest)
131 {
132 case HID_REQ_SET_PROTOCOL:
133 piap->hid_protocol = (uint8_t)setup->wValue;
134 break;
135 case HID_REQ_GET_PROTOCOL:
136 usbd_ctrl_send(pudev, (uint8_t *)&piap->hid_protocol, 1);
137 break;
138 case HID_REQ_SET_IDLE:
139 piap->hid_set_idle = (uint8_t)(setup->wValue >> 8);
140 break;
141 case HID_REQ_GET_IDLE:
142 usbd_ctrl_send(pudev, (uint8_t *)&piap->hid_set_idle, 1);
143 break;
144 case HID_REQ_SET_REPORT:
145 piap->hid_state = HID_REQ_SET_REPORT;
146 usbd_ctrl_recv(pudev, piap->hid_set_report, setup->wLength);
147 break;
148 default:
149 usbd_ctrl_unsupport(pudev);
150 break;
151 }
152 break;
153 /* standard request */
154 case USB_REQ_TYPE_STANDARD:
155 switch(setup->bRequest)
156 {
157 case USB_STD_REQ_GET_DESCRIPTOR:
158 if(setup->wValue >> 8 == HID_REPORT_DESC)
159 {
160 len = MIN(USBD_HIDIAP_SIZ_REPORT_DESC, setup->wLength);
161 buf = (uint8_t *)g_usbd_hidiap_report;
162 }
163 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
164 {
165 len = MIN(9, setup->wLength);
166 buf = (uint8_t *)g_hidiap_usb_desc;
167 }
168 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
169 break;
170 case USB_STD_REQ_GET_INTERFACE:
171 usbd_ctrl_send(pudev, (uint8_t *)&piap->alt_setting, 1);
172 break;
173 case USB_STD_REQ_SET_INTERFACE:
174 piap->alt_setting = setup->wValue;
175 break;
176 default:
177 break;
178 }
179 break;
180 default:
181 usbd_ctrl_unsupport(pudev);
182 break;
183 }
184 return status;
185}
186
192static usb_sts_type class_ept0_tx_handler(void *udev)
193{
194 usb_sts_type status = USB_OK;
195
196 /* ...user code... */
197
198 return status;
199}
200
206static usb_sts_type class_ept0_rx_handler(void *udev)
207{
208 usb_sts_type status = USB_OK;
209 usbd_core_type *pudev = (usbd_core_type *)udev;
210 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
211 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
212 /* ...user code... */
213 if( piap->hid_state == HID_REQ_SET_REPORT)
214 {
215 /* hid buffer process */
216 piap->hid_state = 0;
217 }
218
219 return status;
220}
221
228static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
229{
230 usb_sts_type status = USB_OK;
231
232 /* ...user code...
233 trans next packet data
234 */
235 usbd_hid_iap_in_complete(udev);
236
237 return status;
238}
239
246static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
247{
248 usb_sts_type status = USB_OK;
249 usbd_core_type *pudev = (usbd_core_type *)udev;
250 iap_info_type *piap = (iap_info_type *)pudev->class_handler->pdata;
251
252 /* get endpoint receive data length */
253 uint32_t recv_len = usbd_get_recv_len(pudev, ept_num);
254
255 /* hid iap process */
256 usbd_hid_iap_process(udev, piap->g_rxhid_buff, recv_len);
257
258 /* start receive next packet */
259 usbd_ept_recv(pudev, USBD_HIDIAP_OUT_EPT, piap->g_rxhid_buff, USBD_HIDIAP_OUT_MAXPACKET_SIZE);
260
261 return status;
262}
263
269static usb_sts_type class_sof_handler(void *udev)
270{
271 usb_sts_type status = USB_OK;
272
273 /* ...user code... */
274
275 return status;
276}
277
284static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
285{
286 usb_sts_type status = USB_OK;
287 switch(event)
288 {
289 case USBD_RESET_EVENT:
290
291 /* ...user code... */
292
293 break;
294 case USBD_SUSPEND_EVENT:
295
296 /* ...user code... */
297
298 break;
299 case USBD_WAKEUP_EVENT:
300 /* ...user code... */
301
302 break;
303 default:
304 break;
305 }
306 return status;
307}
308
316 usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
317{
318 usb_sts_type status = USB_OK;
319 usbd_core_type *pudev = (usbd_core_type *)udev;
320
321 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
322 usbd_ept_send(pudev, USBD_HIDIAP_IN_EPT, report, len);
323
324 return status;
325}
326
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
USBD_HIDIAP_OUT_MAXPACKET_SIZE
#define USBD_HIDIAP_OUT_MAXPACKET_SIZE
Definition: hid_iap_class.h:56
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *report, uint16_t len)
usb device iap function
Definition: app_led3_toggle/src/hid_iap_user.c:194
USBD_HIDIAP_IN_EPT
#define USBD_HIDIAP_IN_EPT
Definition: hid_iap_class.h:52
USBD_HIDIAP_OUT_EPT
#define USBD_HIDIAP_OUT_EPT
Definition: hid_iap_class.h:53
USBD_HIDIAP_IN_MAXPACKET_SIZE
#define USBD_HIDIAP_IN_MAXPACKET_SIZE
Definition: hid_iap_class.h:55
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led3_toggle/src/hid_iap_user.c:240
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: hid_iap_class.c:269
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: hid_iap_class.c:228
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: hid_iap_class.c:98
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: hid_iap_class.c:118
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: hid_iap_class.c:192
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: hid_iap_class.c:206
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: hid_iap_class.c:284
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:57
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: hid_iap_class.c:76
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: hid_iap_class.c:246
g_hidiap_usb_desc
uint8_t g_hidiap_usb_desc[9]
usb hid descriptor
Definition: hid_iap_desc.c:200
USBD_HIDIAP_SIZ_REPORT_DESC
#define USBD_HIDIAP_SIZ_REPORT_DESC
Definition: hid_iap_desc.h:57
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:169
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
hid_iap_class.h
usb hid iap header file
hid_iap_desc.h
usb hid descriptor header file
iap_info_type
Definition: hid_iap_class.h:105
iap_info_type::hid_state
uint32_t hid_state
Definition: hid_iap_class.h:130
iap_info_type::hid_set_idle
uint32_t hid_set_idle
Definition: hid_iap_class.h:128
iap_info_type::hid_protocol
uint32_t hid_protocol
Definition: hid_iap_class.h:127
iap_info_type::hid_set_report
uint8_t hid_set_report[64]
Definition: hid_iap_class.h:131
iap_info_type::alt_setting
uint32_t alt_setting
Definition: hid_iap_class.h:129
iap_info_type::g_rxhid_buff
uint8_t g_rxhid_buff[0x40]
Definition: hid_iap_class.h:126
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: hid_iap_class.h Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_CLASS_H
29#define __HID_IAP_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
38
52#define USBD_HIDIAP_IN_EPT 0x81
53#define USBD_HIDIAP_OUT_EPT 0x01
54
55#define USBD_HIDIAP_IN_MAXPACKET_SIZE 0x40
56#define USBD_HIDIAP_OUT_MAXPACKET_SIZE 0x40
57
58#define FLASH_SIZE_REG() ((*(uint32_t *)0x1FFFF7E0) & 0xFFFF) /*Get Flash size*/
59#define KB_TO_B(kb) ((kb) << 10)
60
61#define SECTOR_SIZE_1K 0x400
62#define SECTOR_SIZE_2K 0x800
63#define SECTOR_SIZE_4K 0x1000
64
68#define IAP_CMD_IDLE 0x5AA0
69#define IAP_CMD_START 0x5AA1
70#define IAP_CMD_ADDR 0x5AA2
71#define IAP_CMD_DATA 0x5AA3
72#define IAP_CMD_FINISH 0x5AA4
73#define IAP_CMD_CRC 0x5AA5
74#define IAP_CMD_JMP 0x5AA6
75#define IAP_CMD_GET 0x5AA7
76
77#define HID_IAP_BUFFER_LEN 1024
78#define IAP_UPGRADE_COMPLETE_FLAG 0x41544B38
79#define CONVERT_ENDIAN(dwValue) ((dwValue >> 24) | ((dwValue >> 8) & 0xFF00) | \
80 ((dwValue << 8) & 0xFF0000) | (dwValue << 24) )
81
82#define IAP_ACK 0xFF00
83#define IAP_NACK 0x00FF
84
85typedef enum
86{
87 IAP_SUCCESS,
88 IAP_WAIT,
89 IAP_FAILED
90}iap_result_type;
91
92typedef enum
93{
94 IAP_STS_IDLE,
95 IAP_STS_START,
96 IAP_STS_ADDR,
97 IAP_STS_DATA,
98 IAP_STS_FINISH,
99 IAP_STS_CRC,
100 IAP_STS_JMP_WAIT,
101 IAP_STS_JMP,
102}iap_machine_state_type;
103
104typedef struct
105{
106
107 uint8_t iap_fifo[HID_IAP_BUFFER_LEN];
108 uint8_t iap_rx[USBD_HIDIAP_OUT_MAXPACKET_SIZE];
109 uint8_t iap_tx[USBD_HIDIAP_IN_MAXPACKET_SIZE];
110
111 uint32_t fifo_length;
112 uint32_t tx_length;
113
114 uint32_t app_address;
115 uint32_t iap_address;
116 uint32_t flag_address;
117
118 uint32_t flash_start_address;
119 uint32_t flash_end_address;
120
121 uint32_t sector_size;
122 uint32_t flash_size;
123
124 uint32_t respond_flag;
125
126 uint8_t g_rxhid_buff[USBD_HIDIAP_OUT_MAXPACKET_SIZE];
127 uint32_t hid_protocol;
128 uint32_t hid_set_idle;
129 uint32_t alt_setting;
130 uint32_t hid_state;
131 uint8_t hid_set_report[64];
132
133 iap_machine_state_type state;
134}iap_info_type;
135
136extern usbd_class_handler hid_iap_class_handler;
137extern iap_info_type iap_info;
138 usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len);
139 iap_result_type usbd_hid_iap_process(void *udev, uint8_t *report, uint16_t len);
140void usbd_hid_iap_in_complete(void *udev);
141
153#ifdef __cplusplus
154}
155#endif
156
157#endif
158
159
iap_info
iap_info_type iap_info
Definition: hid_iap_class.c:54
HID_IAP_BUFFER_LEN
#define HID_IAP_BUFFER_LEN
Definition: hid_iap_class.h:77
USBD_HIDIAP_OUT_MAXPACKET_SIZE
#define USBD_HIDIAP_OUT_MAXPACKET_SIZE
Definition: hid_iap_class.h:56
usb_iap_class_send_report
usb_sts_type usb_iap_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: hid_iap_class.c:316
iap_result_type
iap_result_type
Definition: hid_iap_class.h:86
usbd_hid_iap_process
iap_result_type usbd_hid_iap_process(void *udev, uint8_t *report, uint16_t len)
usb device iap function
Definition: app_led3_toggle/src/hid_iap_user.c:194
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:57
iap_machine_state_type
iap_machine_state_type
Definition: hid_iap_class.h:93
USBD_HIDIAP_IN_MAXPACKET_SIZE
#define USBD_HIDIAP_IN_MAXPACKET_SIZE
Definition: hid_iap_class.h:55
usbd_hid_iap_in_complete
void usbd_hid_iap_in_complete(void *udev)
usb device in transfer complete function
Definition: app_led3_toggle/src/hid_iap_user.c:240
IAP_WAIT
@ IAP_WAIT
Definition: hid_iap_class.h:88
IAP_FAILED
@ IAP_FAILED
Definition: hid_iap_class.h:89
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
IAP_STS_START
@ IAP_STS_START
Definition: hid_iap_class.h:95
IAP_STS_JMP
@ IAP_STS_JMP
Definition: hid_iap_class.h:101
IAP_STS_DATA
@ IAP_STS_DATA
Definition: hid_iap_class.h:97
IAP_STS_JMP_WAIT
@ IAP_STS_JMP_WAIT
Definition: hid_iap_class.h:100
IAP_STS_IDLE
@ IAP_STS_IDLE
Definition: hid_iap_class.h:94
IAP_STS_FINISH
@ IAP_STS_FINISH
Definition: hid_iap_class.h:98
IAP_STS_ADDR
@ IAP_STS_ADDR
Definition: hid_iap_class.h:96
IAP_STS_CRC
@ IAP_STS_CRC
Definition: hid_iap_class.h:99
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
iap_info_type
Definition: hid_iap_class.h:105
iap_info_type::respond_flag
uint32_t respond_flag
Definition: hid_iap_class.h:124
iap_info_type::hid_state
uint32_t hid_state
Definition: hid_iap_class.h:130
iap_info_type::flag_address
uint32_t flag_address
Definition: hid_iap_class.h:116
iap_info_type::sector_size
uint32_t sector_size
Definition: hid_iap_class.h:121
iap_info_type::iap_address
uint32_t iap_address
Definition: hid_iap_class.h:115
iap_info_type::flash_start_address
uint32_t flash_start_address
Definition: hid_iap_class.h:118
iap_info_type::flash_end_address
uint32_t flash_end_address
Definition: hid_iap_class.h:119
iap_info_type::fifo_length
uint32_t fifo_length
Definition: hid_iap_class.h:111
iap_info_type::hid_set_idle
uint32_t hid_set_idle
Definition: hid_iap_class.h:128
iap_info_type::hid_protocol
uint32_t hid_protocol
Definition: hid_iap_class.h:127
iap_info_type::tx_length
uint32_t tx_length
Definition: hid_iap_class.h:112
iap_info_type::flash_size
uint32_t flash_size
Definition: hid_iap_class.h:122
iap_info_type::app_address
uint32_t app_address
Definition: hid_iap_class.h:114
iap_info_type::alt_setting
uint32_t alt_setting
Definition: hid_iap_class.h:129
iap_info_type::state
iap_machine_state_type state
Definition: hid_iap_class.h:133
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: hid_iap_desc.c Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "hid_iap_desc.h"
30
31
46static usbd_desc_t *get_device_descriptor(void);
47static usbd_desc_t *get_device_qualifier(void);
48static usbd_desc_t *get_device_configuration(void);
49static usbd_desc_t *get_device_other_speed(void);
50static usbd_desc_t *get_device_lang_id(void);
51static usbd_desc_t *get_device_manufacturer_string(void);
52static usbd_desc_t *get_device_product_string(void);
53static usbd_desc_t *get_device_serial_string(void);
54static usbd_desc_t *get_device_interface_string(void);
55static usbd_desc_t *get_device_config_string(void);
56
57static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
58static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
59static void get_serial_num(void);
60static uint8_t g_usbd_desc_buffer[256];
61
65 usbd_desc_handler hid_iap_desc_handler =
66{
67 get_device_descriptor,
68 get_device_qualifier,
69 get_device_configuration,
70 get_device_other_speed,
71 get_device_lang_id,
72 get_device_manufacturer_string,
73 get_device_product_string,
74 get_device_serial_string,
75 get_device_interface_string,
76 get_device_config_string,
77};
78
82#if defined ( __ICCARM__ ) /* iar compiler */
83 #pragma data_alignment=4
84#endif
85ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
86{
87 USB_DEVICE_DESC_LEN, /* bLength */
88 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
89 0x00, /* bcdUSB */
90 0x02,
91 0x00, /* bDeviceClass */
92 0x00, /* bDeviceSubClass */
93 0x00, /* bDeviceProtocol */
94 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
95 LBYTE(USBD_HIDIAP_VENDOR_ID), /* idVendor */
96 HBYTE(USBD_HIDIAP_VENDOR_ID), /* idVendor */
97 LBYTE(USBD_HIDIAP_PRODUCT_ID), /* idProduct */
98 HBYTE(USBD_HIDIAP_PRODUCT_ID), /* idProduct */
99 0x00, /* bcdDevice rel. 2.00 */
100 0x02,
101 USB_MFC_STRING, /* Index of manufacturer string */
102 USB_PRODUCT_STRING, /* Index of product string */
103 USB_SERIAL_STRING, /* Index of serial number string */
104 1 /* bNumConfigurations */
105};
106
110#if defined ( __ICCARM__ ) /* iar compiler */
111 #pragma data_alignment=4
112#endif
113ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_HIDIAP_CONFIG_DESC_SIZE] ALIGNED_TAIL =
114{
115 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
116 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
117 LBYTE(USBD_HIDIAP_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 HBYTE(USBD_HIDIAP_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
119 0x01, /* bNumInterfaces: 1 interface */
120 0x01, /* bConfigurationValue: configuration value */
121 0x00, /* iConfiguration: index of string descriptor describing
122 the configuration */
123 0xC0, /* bmAttributes: self powered */
124 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
125
126 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
127 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
128 0x00, /* bInterfaceNumber: number of interface */
129 0x00, /* bAlternateSetting: alternate set */
130 0x02, /* bNumEndpoints: number of endpoints */
131 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
132 0x00, /* bInterfaceSubClass: subclass code */
133 0x00, /* bInterfaceProtocol: protocol code */
134 0x00, /* iInterface: index of string descriptor */
135
136 0x09, /* bLength: size of HID descriptor in bytes */
137 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
138 LBYTE(HIDIAP_BCD_NUM),
139 HBYTE(HIDIAP_BCD_NUM), /* bcdHID: HID class specification release number */
140 0x00, /* bCountryCode: hardware target conutry */
141 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
142 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
143 LBYTE(sizeof(g_usbd_hidiap_report)),
144 HBYTE(sizeof(g_usbd_hidiap_report)), /* wDescriptorLength: total length of reprot descriptor */
145
146 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
147 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
148 USBD_HIDIAP_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
149 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
150 LBYTE(USBD_HIDIAP_IN_MAXPACKET_SIZE),
151 HBYTE(USBD_HIDIAP_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
152 HIDIAP_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
153
154 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
155 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
156 USBD_HIDIAP_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
157 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
158 LBYTE(USBD_HIDIAP_OUT_MAXPACKET_SIZE),
159 HBYTE(USBD_HIDIAP_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
160 HIDIAP_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
161};
162
166#if defined ( __ICCARM__ ) /* iar compiler */
167 #pragma data_alignment=4
168#endif
169ALIGNED_HEAD uint8_t g_usbd_hidiap_report[USBD_HIDIAP_SIZ_REPORT_DESC] ALIGNED_TAIL =
170{
171 0x06, 0xFF, 0x00, /* USAGE_PAGE(Vendor Page:0xFF00) */
172 0x09, 0x01, /* USAGE (Demo Kit) */
173 0xa1, 0x01, /* COLLECTION (Application) */
174
175 /* 6 */
176 0x15, 0x00, /* LOGICAL_MINIMUM (0) */
177 0x25, 0xFF, /* LOGICAL_MAXIMUM (255) */
178 0x75, 0x08, /* REPORT_SIZE (8) */
179 0x95, 0x40, /* REPORT_COUNT (64) */
180
181 0x09, 0x01,
182 0x81, 0x02,
183 0x95, 0x40,
184
185 0x09, 0x01,
186 0x91, 0x02,
187 0x95, 0x01,
188
189 0x09, 0x01,
190 0xB1, 0x02,
191 0xC0
192};
193
197#if defined ( __ICCARM__ ) /* iar compiler */
198 #pragma data_alignment=4
199#endif
200ALIGNED_HEAD uint8_t g_hidiap_usb_desc[9] ALIGNED_TAIL =
201{
202 0x09, /* bLength: size of HID descriptor in bytes */
203 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
204 LBYTE(HIDIAP_BCD_NUM),
205 HBYTE(HIDIAP_BCD_NUM), /* bcdHID: HID class specification release number */
206 0x00, /* bCountryCode: hardware target conutry */
207 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
208 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
209 LBYTE(sizeof(g_usbd_hidiap_report)),
210 HBYTE(sizeof(g_usbd_hidiap_report)), /* wDescriptorLength: total length of reprot descriptor */
211};
212
213
217#if defined ( __ICCARM__ ) /* iar compiler */
218 #pragma data_alignment=4
219#endif
220ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_HIDIAP_SIZ_STRING_LANGID] ALIGNED_TAIL =
221{
222 USBD_HIDIAP_SIZ_STRING_LANGID,
223 USB_DESCIPTOR_TYPE_STRING,
224 0x09,
225 0x04,
226};
227
231#if defined ( __ICCARM__ ) /* iar compiler */
232 #pragma data_alignment=4
233#endif
234ALIGNED_HEAD static uint8_t g_string_serial[USBD_HIDIAP_SIZ_STRING_SERIAL] ALIGNED_TAIL =
235{
236 USBD_HIDIAP_SIZ_STRING_SERIAL,
237 USB_DESCIPTOR_TYPE_STRING,
238};
239
240
241/* device descriptor */
242static usbd_desc_t device_descriptor =
243{
244 USB_DEVICE_DESC_LEN,
245 g_usbd_descriptor
246};
247
248/* config descriptor */
249static usbd_desc_t config_descriptor =
250{
251 USBD_HIDIAP_CONFIG_DESC_SIZE,
252 g_usbd_configuration
253};
254
255/* langid descriptor */
256static usbd_desc_t langid_descriptor =
257{
258 USBD_HIDIAP_SIZ_STRING_LANGID,
259 g_string_lang_id
260};
261
262/* serial descriptor */
263static usbd_desc_t serial_descriptor =
264{
265 USBD_HIDIAP_SIZ_STRING_SERIAL,
266 g_string_serial
267};
268
269static usbd_desc_t vp_desc;
270
277static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
278{
279 uint16_t str_len = 0, id_pos = 2;
280 uint8_t *tmp_str = string;
281
282 while(*tmp_str != '\0')
283 {
284 str_len ++;
285 unicode_buf[id_pos ++] = *tmp_str ++;
286 unicode_buf[id_pos ++] = 0x00;
287 }
288
289 str_len = str_len * 2 + 2;
290 unicode_buf[0] = str_len;
291 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
292
293 return str_len;
294}
295
303static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
304{
305 uint8_t idx = 0;
306
307 for( idx = 0 ; idx < len ; idx ++)
308 {
309 if( ((value >> 28)) < 0xA )
310 {
311 pbuf[ 2 * idx] = (value >> 28) + '0';
312 }
313 else
314 {
315 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
316 }
317
318 value = value << 4;
319
320 pbuf[2 * idx + 1] = 0;
321 }
322}
323
329static void get_serial_num(void)
330{
331 uint32_t serial0, serial1, serial2;
332
333 serial0 = *(uint32_t*)MCU_ID1;
334 serial1 = *(uint32_t*)MCU_ID2;
335 serial2 = *(uint32_t*)MCU_ID3;
336
337 serial0 += serial2;
338
339 if (serial0 != 0)
340 {
341 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
342 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
343 }
344}
345
351static usbd_desc_t *get_device_descriptor(void)
352{
353 return &device_descriptor;
354}
355
361static usbd_desc_t * get_device_qualifier(void)
362{
363 return NULL;
364}
365
371static usbd_desc_t *get_device_configuration(void)
372{
373 return &config_descriptor;
374}
375
381static usbd_desc_t *get_device_other_speed(void)
382{
383 return NULL;
384}
385
391static usbd_desc_t *get_device_lang_id(void)
392{
393 return &langid_descriptor;
394}
395
396
402static usbd_desc_t *get_device_manufacturer_string(void)
403{
404 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
405 vp_desc.descriptor = g_usbd_desc_buffer;
406 return &vp_desc;
407}
408
414static usbd_desc_t *get_device_product_string(void)
415{
416 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
417 vp_desc.descriptor = g_usbd_desc_buffer;
418 return &vp_desc;
419}
420
426static usbd_desc_t *get_device_serial_string(void)
427{
428 get_serial_num();
429 return &serial_descriptor;
430}
431
437static usbd_desc_t *get_device_interface_string(void)
438{
439 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
440 vp_desc.descriptor = g_usbd_desc_buffer;
441 return &vp_desc;
442}
443
449static usbd_desc_t *get_device_config_string(void)
450{
451 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_HIDIAP_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
452 vp_desc.descriptor = g_usbd_desc_buffer;
453 return &vp_desc;
454}
455
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
USBD_HIDIAP_OUT_MAXPACKET_SIZE
#define USBD_HIDIAP_OUT_MAXPACKET_SIZE
Definition: hid_iap_class.h:56
USBD_HIDIAP_IN_EPT
#define USBD_HIDIAP_IN_EPT
Definition: hid_iap_class.h:52
USBD_HIDIAP_OUT_EPT
#define USBD_HIDIAP_OUT_EPT
Definition: hid_iap_class.h:53
USBD_HIDIAP_IN_MAXPACKET_SIZE
#define USBD_HIDIAP_IN_MAXPACKET_SIZE
Definition: hid_iap_class.h:55
USBD_HIDIAP_SIZ_STRING_LANGID
#define USBD_HIDIAP_SIZ_STRING_LANGID
Definition: hid_iap_desc.h:58
USBD_HIDIAP_SIZ_STRING_SERIAL
#define USBD_HIDIAP_SIZ_STRING_SERIAL
Definition: hid_iap_desc.h:59
USBD_HIDIAP_VENDOR_ID
#define USBD_HIDIAP_VENDOR_ID
Definition: hid_iap_desc.h:53
HIDIAP_BCD_NUM
#define HIDIAP_BCD_NUM
Definition: hid_iap_desc.h:51
g_hidiap_usb_desc
uint8_t g_hidiap_usb_desc[9]
usb hid descriptor
Definition: hid_iap_desc.c:200
USBD_HIDIAP_SIZ_REPORT_DESC
#define USBD_HIDIAP_SIZ_REPORT_DESC
Definition: hid_iap_desc.h:57
USBD_HIDIAP_DESC_INTERFACE_STRING
#define USBD_HIDIAP_DESC_INTERFACE_STRING
Definition: hid_iap_desc.h:64
HIDIAP_BINTERVAL_TIME
#define HIDIAP_BINTERVAL_TIME
Definition: hid_iap_desc.h:66
USBD_HIDIAP_DESC_CONFIGURATION_STRING
#define USBD_HIDIAP_DESC_CONFIGURATION_STRING
Definition: hid_iap_desc.h:63
USBD_HIDIAP_DESC_MANUFACTURER_STRING
#define USBD_HIDIAP_DESC_MANUFACTURER_STRING
Definition: hid_iap_desc.h:61
USBD_HIDIAP_DESC_PRODUCT_STRING
#define USBD_HIDIAP_DESC_PRODUCT_STRING
Definition: hid_iap_desc.h:62
USBD_HIDIAP_CONFIG_DESC_SIZE
#define USBD_HIDIAP_CONFIG_DESC_SIZE
Definition: hid_iap_desc.h:56
USBD_HIDIAP_PRODUCT_ID
#define USBD_HIDIAP_PRODUCT_ID
Definition: hid_iap_desc.h:54
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:169
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: hid_iap_desc.c:263
device_descriptor
static usbd_desc_t device_descriptor
Definition: hid_iap_desc.c:242
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: hid_iap_desc.c:371
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: hid_iap_desc.c:256
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: hid_iap_desc.c:351
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: hid_iap_desc.c:402
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: hid_iap_desc.c:361
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: hid_iap_desc.c:437
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: hid_iap_desc.c:60
vp_desc
static usbd_desc_t vp_desc
Definition: hid_iap_desc.c:269
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: hid_iap_desc.c:381
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: hid_iap_desc.c:85
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: hid_iap_desc.c:414
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: hid_iap_desc.c:449
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:65
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: hid_iap_desc.c:277
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: hid_iap_desc.c:391
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: hid_iap_desc.c:329
config_descriptor
static usbd_desc_t config_descriptor
Definition: hid_iap_desc.c:249
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: hid_iap_desc.c:426
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: hid_iap_desc.c:303
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
hid_iap_desc.h
usb hid descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: hid_iap_desc.h Source File

  • middlewares
  • usbd_class
  • hid_iap
hid_iap_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __HID_IAP_DESC_H
29#define __HID_IAP_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "hid_iap_class.h"
36#include "usbd_core.h"
37
51#define HIDIAP_BCD_NUM 0x0110
52
53#define USBD_HIDIAP_VENDOR_ID 0x2E3C
54#define USBD_HIDIAP_PRODUCT_ID 0xAF01
55
56#define USBD_HIDIAP_CONFIG_DESC_SIZE 41
57#define USBD_HIDIAP_SIZ_REPORT_DESC 32
58#define USBD_HIDIAP_SIZ_STRING_LANGID 4
59#define USBD_HIDIAP_SIZ_STRING_SERIAL 0x1A
60
61#define USBD_HIDIAP_DESC_MANUFACTURER_STRING "Artery"
62#define USBD_HIDIAP_DESC_PRODUCT_STRING "HID IAP"
63#define USBD_HIDIAP_DESC_CONFIGURATION_STRING "HID IAP Config"
64#define USBD_HIDIAP_DESC_INTERFACE_STRING "HID IAP Interface"
65
66#define HIDIAP_BINTERVAL_TIME 0x01
67
68#define MCU_ID1 (0x1FFFF7E8)
69#define MCU_ID2 (0x1FFFF7EC)
70#define MCU_ID3 (0x1FFFF7F0)
71extern uint8_t g_usbd_hidiap_report[USBD_HIDIAP_SIZ_REPORT_DESC];
72extern uint8_t g_hidiap_usb_desc[9];
73
74extern usbd_desc_handler hid_iap_desc_handler;
75
76
89#ifdef __cplusplus
90}
91#endif
92
93#endif
94
g_hidiap_usb_desc
uint8_t g_hidiap_usb_desc[9]
usb hid descriptor
Definition: hid_iap_desc.c:200
USBD_HIDIAP_SIZ_REPORT_DESC
#define USBD_HIDIAP_SIZ_REPORT_DESC
Definition: hid_iap_desc.h:57
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:65
g_usbd_hidiap_report
uint8_t g_usbd_hidiap_report[32]
usb hid report descriptor
Definition: hid_iap_desc.c:169
hid_iap_class.h
usb hid iap header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: i2c_application.c Source File

  • middlewares
  • i2c_application_library
i2c_application.c
Go to the documentation of this file.
1
27#include "i2c_application.h"
28
37#define DMA_GET_TC_FLAG(DMA_CHANNEL) \
38(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_FDT1_FLAG : \
39 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_FDT2_FLAG : \
40 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_FDT3_FLAG : \
41 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_FDT4_FLAG : \
42 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_FDT5_FLAG : \
43 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_FDT6_FLAG : \
44 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_FDT7_FLAG : \
45 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_FDT1_FLAG : \
46 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_FDT2_FLAG : \
47 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_FDT3_FLAG : \
48 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_FDT4_FLAG : \
49 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_FDT5_FLAG : \
50 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_FDT6_FLAG : \
51 DMA2_FDT7_FLAG)
52
56#define DMA_GET_HT_FLAG(DMA_CHANNEL) \
57(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_HDT1_FLAG : \
58 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_HDT2_FLAG : \
59 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_HDT3_FLAG : \
60 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_HDT4_FLAG : \
61 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_HDT5_FLAG : \
62 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_HDT6_FLAG : \
63 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_HDT7_FLAG : \
64 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_HDT1_FLAG : \
65 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_HDT2_FLAG : \
66 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_HDT3_FLAG : \
67 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_HDT4_FLAG : \
68 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_HDT5_FLAG : \
69 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_HDT6_FLAG : \
70 DMA2_HDT7_FLAG)
71
75#define DMA_GET_TERR_FLAG(DMA_CHANNEL) \
76(((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL1))? DMA1_DTERR1_FLAG : \
77 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL2))? DMA1_DTERR2_FLAG : \
78 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL3))? DMA1_DTERR3_FLAG : \
79 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL4))? DMA1_DTERR4_FLAG : \
80 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL5))? DMA1_DTERR5_FLAG : \
81 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL6))? DMA1_DTERR6_FLAG : \
82 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA1_CHANNEL7))? DMA1_DTERR7_FLAG : \
83 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL1))? DMA2_DTERR1_FLAG : \
84 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL2))? DMA2_DTERR2_FLAG : \
85 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL3))? DMA2_DTERR3_FLAG : \
86 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL4))? DMA2_DTERR4_FLAG : \
87 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL5))? DMA2_DTERR5_FLAG : \
88 ((uint32_t)(DMA_CHANNEL) == ((uint32_t)DMA2_CHANNEL6))? DMA2_DTERR6_FLAG : \
89 DMA2_DTERR7_FLAG)
90
94#define I2C_START 0
95#define I2C_END 1
96
102__WEAK void i2c_lowlevel_init(i2c_handle_type* hi2c)
103{
104
105}
106
112void i2c_config(i2c_handle_type* hi2c)
113{
114 /* reset i2c peripheral */
115 i2c_reset(hi2c->i2cx);
116
117 /* i2c peripheral initialization */
118 i2c_lowlevel_init(hi2c);
119
120 /* i2c peripheral enable */
121 i2c_enable(hi2c->i2cx, TRUE);
122}
123
129void i2c_addr_flag_clear(i2c_handle_type* hi2c)
130{
131 __IO uint32_t tmpreg;
132
133 tmpreg = hi2c->i2cx->sts1;
134
135 tmpreg = hi2c->i2cx->sts2;
136}
137
143void i2c_stop_flag_clear(i2c_handle_type* hi2c)
144{
145 __IO uint32_t tmpreg;
146
147 tmpreg = hi2c->i2cx->sts1;
148
149 tmpreg = hi2c->i2cx->ctrl1_bit.i2cen = TRUE;
150}
151
158 i2c_status_type i2c_wait_end(i2c_handle_type* hi2c, uint32_t timeout)
159{
160 while(hi2c->status != I2C_END)
161 {
162 /* check timeout */
163 if((timeout--) == 0)
164 {
165 return I2C_ERR_TIMEOUT;
166 }
167 }
168
169 if(hi2c->error_code != I2C_OK)
170 {
171 return hi2c->error_code;
172 }
173 else
174 {
175 return I2C_OK;
176 }
177}
178
192 i2c_status_type i2c_wait_flag(i2c_handle_type* hi2c, uint32_t flag, flag_status status, uint32_t event_check, uint32_t timeout)
193{
194 while(i2c_flag_get(hi2c->i2cx, flag) == status)
195 {
196 /* check the ack fail flag */
197 if(event_check & I2C_EVENT_CHECK_ACKFAIL)
198 {
199 if(i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
200 {
201 /* generate stop condtion */
202 i2c_stop_generate(hi2c->i2cx);
203
204 /* clear ack fail flag */
205 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
206
207 hi2c->error_code = I2C_ERR_ACKFAIL;
208
209 return I2C_ERR_ACKFAIL;
210 }
211 }
212
213 /* check the stop flag */
214 if(event_check & I2C_EVENT_CHECK_STOP)
215 {
216 if(i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
217 {
218 /* clear stop flag */
219 i2c_stop_flag_clear(hi2c);
220
221 hi2c->error_code = I2C_ERR_STOP;
222
223 return I2C_ERR_STOP;
224 }
225 }
226
227 /* check timeout */
228 if((timeout--) == 0)
229 {
230 hi2c->error_code = I2C_ERR_TIMEOUT;
231
232 return I2C_ERR_TIMEOUT;
233 }
234 }
235
236 return I2C_OK;
237}
238
247void i2c_dma_config(i2c_handle_type* hi2c, dma_channel_type* dma_channelx, uint8_t* pdata, uint16_t size)
248{
249 /* disable the dma channel */
250 dma_channel_enable(dma_channelx, FALSE);
251
252 /* disable the transfer complete interrupt */
253 dma_interrupt_enable(dma_channelx, DMA_FDT_INT , FALSE);
254
255 /* configure buffer address and buffer size */
256 hi2c->dma_init_struct.memory_base_addr = (uint32_t)pdata;
257 hi2c->dma_init_struct.direction = (dma_channelx == hi2c->dma_tx_channel) ? DMA_DIR_MEMORY_TO_PERIPHERAL : DMA_DIR_PERIPHERAL_TO_MEMORY;
258 hi2c->dma_init_struct.peripheral_base_addr = (uint32_t)&hi2c->i2cx->dt;
259 hi2c->dma_init_struct.buffer_size = (uint32_t)size;
260 dma_init(dma_channelx, &hi2c->dma_init_struct);
261
262 /* enable the transfer complete interrupt */
263 dma_interrupt_enable(dma_channelx, DMA_FDT_INT , TRUE);
264
265 /* enable the dma channel */
266 dma_channel_enable(dma_channelx, TRUE);
267}
268
276 i2c_status_type i2c_master_write_addr(i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
277{
278 /* generate start condtion */
279 i2c_start_generate(hi2c->i2cx);
280
281 /* wait for the start flag to be set */
282 if(i2c_wait_flag(hi2c, I2C_STARTF_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
283 {
284 hi2c->error_code = I2C_ERR_START;
285
286 return I2C_ERR_START;
287 }
288
289 if(hi2c->i2cx->oaddr1_bit.addr1mode == I2C_ADDRESS_MODE_7BIT)
290 {
291 /* send slave address */
292 i2c_7bit_address_send(hi2c->i2cx, address, I2C_DIRECTION_TRANSMIT);
293 }
294 else
295 {
296 /* send slave 10-bit address header */
297 i2c_data_send(hi2c->i2cx, (uint8_t)((address & 0x0300) >> 7) | 0xF0);
298
299 /* wait for the addrh flag to be set */
300 if(i2c_wait_flag(hi2c, I2C_ADDRHF_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
301 {
302 hi2c->error_code = I2C_ERR_ADDR10;
303
304 return I2C_ERR_ADDR10;
305 }
306
307 /* send slave address */
308 i2c_data_send(hi2c->i2cx, (uint8_t)(address & 0x00FF));
309 }
310
311 /* wait for the addr7 flag to be set */
312 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
313 {
314 hi2c->error_code = I2C_ERR_ADDR;
315
316 return I2C_ERR_ADDR;
317 }
318
319 return I2C_OK;
320}
321
329 i2c_status_type i2c_master_read_addr(i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
330{
331 /* enable ack */
332 i2c_ack_enable(hi2c->i2cx, TRUE);
333
334 /* generate start condtion */
335 i2c_start_generate(hi2c->i2cx);
336
337 /* wait for the start flag to be set */
338 if(i2c_wait_flag(hi2c, I2C_STARTF_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
339 {
340 hi2c->error_code = I2C_ERR_START;
341
342 return I2C_ERR_START;
343 }
344
345 if(hi2c->i2cx->oaddr1_bit.addr1mode == I2C_ADDRESS_MODE_7BIT)
346 {
347 /* send slave address */
348 i2c_7bit_address_send(hi2c->i2cx, address, I2C_DIRECTION_RECEIVE);
349 }
350 else
351 {
352 /* send slave 10-bit address header */
353 i2c_data_send(hi2c->i2cx, (uint8_t)((address & 0x0300) >> 7) | 0xF0);
354
355 /* wait for the addrh flag to be set */
356 if(i2c_wait_flag(hi2c, I2C_ADDRHF_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
357 {
358 hi2c->error_code = I2C_ERR_ADDR10;
359
360 return I2C_ERR_ADDR10;
361 }
362
363 /* send slave address */
364 i2c_data_send(hi2c->i2cx, (uint8_t)(address & 0x00FF));
365
366 /* wait for the addr7 flag to be set */
367 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
368 {
369 hi2c->error_code = I2C_ERR_ADDR;
370
371 return I2C_ERR_ADDR;
372 }
373
374 /* clear addr flag */
375 i2c_addr_flag_clear(hi2c);
376
377 /* generate restart condtion */
378 i2c_start_generate(hi2c->i2cx);
379
380 /* wait for the start flag to be set */
381 if(i2c_wait_flag(hi2c, I2C_STARTF_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
382 {
383 hi2c->error_code = I2C_ERR_START;
384
385 return I2C_ERR_START;
386 }
387
388 /* send slave 10-bit address header */
389 i2c_data_send(hi2c->i2cx, (uint8_t)((address & 0x0300) >> 7) | 0xF1);
390 }
391
392 /* wait for the addr7 flag to be set */
393 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
394 {
395 hi2c->error_code = I2C_ERR_ADDR;
396
397 return I2C_ERR_ADDR;
398 }
399
400 return I2C_OK;
401}
402
412 i2c_status_type i2c_master_transmit(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
413{
414 /* initialization parameters */
415 hi2c->pbuff = pdata;
416 hi2c->pcount = size;
417
418 hi2c->error_code = I2C_OK;
419
420 /* wait for the busy flag to be reset */
421 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
422 {
423 return I2C_ERR_STEP_1;
424 }
425
426 /* ack acts on the current byte */
427 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
428
429 /* send slave address */
430 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
431 {
432 /* generate stop condtion */
433 i2c_stop_generate(hi2c->i2cx);
434
435 return I2C_ERR_STEP_2;
436 }
437
438 /* clear addr flag */
439 i2c_addr_flag_clear(hi2c);
440
441 while(size > 0)
442 {
443 /* wait for the tdbe flag to be set */
444 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
445 {
446 /* generate stop condtion */
447 i2c_stop_generate(hi2c->i2cx);
448
449 return I2C_ERR_STEP_3;
450 }
451
452 /* write data */
453 i2c_data_send(hi2c->i2cx, (*pdata++));
454 size--;
455 }
456
457 /* wait for the tdc flag to be set */
458 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
459 {
460 /* generate stop condtion */
461 i2c_stop_generate(hi2c->i2cx);
462
463 return I2C_ERR_STEP_4;
464 }
465
466 /* generate stop condtion */
467 i2c_stop_generate(hi2c->i2cx);
468
469 return I2C_OK;
470}
471
480 i2c_status_type i2c_slave_receive(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
481{
482 /* initialization parameters */
483 hi2c->pbuff = pdata;
484 hi2c->pcount = size;
485
486 hi2c->error_code = I2C_OK;
487
488 /* wait for the busy flag to be reset */
489 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
490 {
491 return I2C_ERR_STEP_1;
492 }
493
494 /* ack acts on the current byte */
495 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
496
497 /* enable ack */
498 i2c_ack_enable(hi2c->i2cx, TRUE);
499
500 /* wait for the addr7 flag to be set */
501 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
502 {
503 /* disable ack */
504 i2c_ack_enable(hi2c->i2cx, FALSE);
505
506 return I2C_ERR_STEP_2;
507 }
508
509 /* clear addr flag */
510 i2c_addr_flag_clear(hi2c);
511
512 while(size > 0)
513 {
514 /* wait for the rdbf flag to be set */
515 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, RESET, I2C_EVENT_CHECK_STOP, timeout) != I2C_OK)
516 {
517 /* disable ack */
518 i2c_ack_enable(hi2c->i2cx, FALSE);
519
520 return I2C_ERR_STEP_3;
521 }
522
523 /* read data */
524 (*pdata++) = i2c_data_receive(hi2c->i2cx);
525 size--;
526 }
527
528 /* wait for the stop flag to be set */
529 if(i2c_wait_flag(hi2c, I2C_STOPF_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
530 {
531 /* disable ack */
532 i2c_ack_enable(hi2c->i2cx, FALSE);
533
534 return I2C_ERR_STEP_4;
535 }
536
537 /* clear stop flag */
538 i2c_stop_flag_clear(hi2c);
539
540 /* disable ack */
541 i2c_ack_enable(hi2c->i2cx, FALSE);
542
543 return I2C_OK;
544}
545
555 i2c_status_type i2c_master_receive(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
556{
557 /* initialization parameters */
558 hi2c->pbuff = pdata;
559 hi2c->pcount = size;
560
561 hi2c->error_code = I2C_OK;
562
563 /* wait for the busy flag to be reset */
564 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
565 {
566 return I2C_ERR_STEP_1;
567 }
568
569 /* ack acts on the current byte */
570 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
571
572 /* enable ack */
573 i2c_ack_enable(hi2c->i2cx, TRUE);
574
575 /* send slave address */
576 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
577 {
578 /* generate stop condtion */
579 i2c_stop_generate(hi2c->i2cx);
580
581 return I2C_ERR_STEP_2;
582 }
583
584 if(size == 1)
585 {
586 /* disable ack */
587 i2c_ack_enable(hi2c->i2cx, FALSE);
588
589 /* clear addr flag */
590 i2c_addr_flag_clear(hi2c);
591
592 /* generate stop condtion */
593 i2c_stop_generate(hi2c->i2cx);
594 }
595 else if(size == 2)
596 {
597 /* ack acts on the next byte */
598 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_NEXT);
599
600 /* disable ack */
601 i2c_ack_enable(hi2c->i2cx, FALSE);
602
603 /* clear addr flag */
604 i2c_addr_flag_clear(hi2c);
605 }
606 else
607 {
608 /* enable ack */
609 i2c_ack_enable(hi2c->i2cx, TRUE);
610
611 /* clear addr flag */
612 i2c_addr_flag_clear(hi2c);
613 }
614
615 while(size > 0)
616 {
617 if(size <= 3)
618 {
619 /* 1 byte */
620 if(size == 1)
621 {
622 /* wait for the rdbf flag to be set */
623 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
624 {
625 /* generate stop condtion */
626 i2c_stop_generate(hi2c->i2cx);
627
628 return I2C_ERR_STEP_3;
629 }
630
631 /* read data */
632 (*pdata++) = i2c_data_receive(hi2c->i2cx);
633 size--;
634 }
635 /* 2 bytes */
636 else if(size == 2)
637 {
638 /* wait for the tdc flag to be set */
639 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
640 {
641 /* generate stop condtion */
642 i2c_stop_generate(hi2c->i2cx);
643
644 return I2C_ERR_STEP_4;
645 }
646
647 /* generate stop condtion */
648 i2c_stop_generate(hi2c->i2cx);
649
650 /* read data */
651 (*pdata++) = i2c_data_receive(hi2c->i2cx);
652 size--;
653
654 /* read data */
655 (*pdata++) = i2c_data_receive(hi2c->i2cx);
656 size--;
657 }
658 /* 3 last bytes */
659 else
660 {
661 /* wait for the tdc flag to be set */
662 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
663 {
664 /* generate stop condtion */
665 i2c_stop_generate(hi2c->i2cx);
666
667 return I2C_ERR_STEP_5;
668 }
669
670 /* disable ack */
671 i2c_ack_enable(hi2c->i2cx, FALSE);
672
673 /* read data */
674 (*pdata++) = i2c_data_receive(hi2c->i2cx);
675 size--;
676
677 /* wait for the tdc flag to be set */
678 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
679 {
680 /* generate stop condtion */
681 i2c_stop_generate(hi2c->i2cx);
682
683 return I2C_ERR_STEP_6;
684 }
685
686 /* generate stop condtion */
687 i2c_stop_generate(hi2c->i2cx);
688
689 /* read data */
690 (*pdata++) = i2c_data_receive(hi2c->i2cx);
691 size--;
692
693 /* read data */
694 (*pdata++) = i2c_data_receive(hi2c->i2cx);
695 size--;
696 }
697 }
698 else
699 {
700 /* wait for the rdbf flag to be set */
701 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
702 {
703 /* generate stop condtion */
704 i2c_stop_generate(hi2c->i2cx);
705
706 return I2C_ERR_STEP_7;
707 }
708
709 /* read data */
710 (*pdata++) = i2c_data_receive(hi2c->i2cx);
711 size--;
712 }
713 }
714
715 return I2C_OK;
716}
717
726 i2c_status_type i2c_slave_transmit(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
727{
728 /* initialization parameters */
729 hi2c->pbuff = pdata;
730 hi2c->pcount = size;
731
732 hi2c->error_code = I2C_OK;
733
734 /* wait for the busy flag to be reset */
735 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
736 {
737 return I2C_ERR_STEP_1;
738 }
739
740 /* ack acts on the current byte */
741 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
742
743 /* enable ack */
744 i2c_ack_enable(hi2c->i2cx, TRUE);
745
746 /* wait for the addr7 flag to be set */
747 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
748 {
749 /* disable ack */
750 i2c_ack_enable(hi2c->i2cx, FALSE);
751
752 return I2C_ERR_STEP_2;
753 }
754
755 /* clear addr flag */
756 i2c_addr_flag_clear(hi2c);
757
758 if(hi2c->i2cx->oaddr1_bit.addr1mode == I2C_ADDRESS_MODE_10BIT)
759 {
760 /* wait for the addr7 flag to be set */
761 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
762 {
763 /* disable ack */
764 i2c_ack_enable(hi2c->i2cx, FALSE);
765
766 return I2C_ERR_STEP_3;
767 }
768
769 /* clear addr flag */
770 i2c_addr_flag_clear(hi2c);
771 }
772
773 while(size > 0)
774 {
775 /* wait for the tdbe flag to be set */
776 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
777 {
778 /* disable ack */
779 i2c_ack_enable(hi2c->i2cx, FALSE);
780
781 return I2C_ERR_STEP_4;
782 }
783
784 /* write data */
785 i2c_data_send(hi2c->i2cx, *pdata++);
786 size--;
787 }
788
789 /* wait for the ackfail flag to be set */
790 if(i2c_wait_flag(hi2c, I2C_ACKFAIL_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
791 {
792 return I2C_ERR_STEP_5;
793 }
794
795 /* clear ackfail flag */
796 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
797
798 /* disable ack */
799 i2c_ack_enable(hi2c->i2cx, FALSE);
800
801 return I2C_OK;
802}
803
813 i2c_status_type i2c_master_transmit_int(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
814{
815 /* initialization parameters */
816 hi2c->mode = I2C_INT_MA_TX;
817 hi2c->status = I2C_START;
818
819 hi2c->pbuff = pdata;
820 hi2c->pcount = size;
821
822 hi2c->timeout = timeout;
823 hi2c->error_code = I2C_OK;
824
825 /* wait for the busy flag to be reset */
826 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
827 {
828 return I2C_ERR_STEP_1;
829 }
830
831 /* ack acts on the current byte */
832 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
833
834 /* send slave address */
835 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
836 {
837 /* generate stop condtion */
838 i2c_stop_generate(hi2c->i2cx);
839
840 return I2C_ERR_STEP_2;
841 }
842
843 /* clear addr flag */
844 i2c_addr_flag_clear(hi2c);
845
846 /* enable interrupt */
847 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
848
849 return I2C_OK;
850}
851
860 i2c_status_type i2c_slave_receive_int(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
861{
862 /* initialization parameters */
863 hi2c->mode = I2C_INT_SLA_RX;
864 hi2c->status = I2C_START;
865
866 hi2c->pbuff = pdata;
867 hi2c->pcount = size;
868
869 hi2c->timeout = timeout;
870 hi2c->error_code = I2C_OK;
871
872 /* wait for the busy flag to be reset */
873 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
874 {
875 return I2C_ERR_STEP_1;
876 }
877
878 /* ack acts on the current byte */
879 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
880
881 /* enable ack */
882 i2c_ack_enable(hi2c->i2cx, TRUE);
883
884 /* wait for the addr7 flag to be set */
885 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
886 {
887 return I2C_ERR_STEP_2;
888 }
889
890 /* clear addr flag */
891 i2c_addr_flag_clear(hi2c);
892
893 /* enable interrupt */
894 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
895
896 return I2C_OK;
897}
898
908 i2c_status_type i2c_master_receive_int(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
909{
910 /* initialization parameters */
911 hi2c->mode = I2C_INT_MA_RX;
912 hi2c->status = I2C_START;
913
914 hi2c->pbuff = pdata;
915 hi2c->pcount = size;
916
917 hi2c->timeout = timeout;
918 hi2c->error_code = I2C_OK;
919
920 /* wait for the busy flag to be reset */
921 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
922 {
923 return I2C_ERR_STEP_1;
924 }
925
926 /* ack acts on the current byte */
927 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
928
929 /* enable ack */
930 i2c_ack_enable(hi2c->i2cx, TRUE);
931
932 /* send slave address */
933 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
934 {
935 /* generate stop condtion */
936 i2c_stop_generate(hi2c->i2cx);
937
938 return I2C_ERR_STEP_2;
939 }
940
941 if(hi2c->pcount == 1)
942 {
943 /* disable ack */
944 i2c_ack_enable(hi2c->i2cx, FALSE);
945
946 /* clear addr flag */
947 i2c_addr_flag_clear(hi2c);
948
949 /* generate stop condtion */
950 i2c_stop_generate(hi2c->i2cx);
951 }
952 else if(hi2c->pcount == 2)
953 {
954 /* ack acts on the next byte */
955 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_NEXT);
956
957 /* clear addr flag */
958 i2c_addr_flag_clear(hi2c);
959
960 /* disable ack */
961 i2c_ack_enable(hi2c->i2cx, FALSE);
962 }
963 else
964 {
965 /* enable ack */
966 i2c_ack_enable(hi2c->i2cx, TRUE);
967
968 /* clear addr flag */
969 i2c_addr_flag_clear(hi2c);
970 }
971
972 /* enable interrupt */
973 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
974
975 return I2C_OK;
976}
977
986 i2c_status_type i2c_slave_transmit_int(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
987{
988 /* initialization parameters */
989 hi2c->mode = I2C_INT_SLA_TX;
990 hi2c->status = I2C_START;
991
992 hi2c->pbuff = pdata;
993 hi2c->pcount = size;
994
995 hi2c->timeout = timeout;
996 hi2c->error_code = I2C_OK;
997
998 /* wait for the busy flag to be reset */
999 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1000 {
1001 return I2C_ERR_STEP_1;
1002 }
1003
1004 /* ack acts on the current byte */
1005 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1006
1007 /* enable ack */
1008 i2c_ack_enable(hi2c->i2cx, TRUE);
1009
1010 /* wait for the addr7 flag to be set */
1011 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1012 {
1013 return I2C_ERR_STEP_2;
1014 }
1015
1016 /* clear addr flag */
1017 i2c_addr_flag_clear(hi2c);
1018
1019 if(hi2c->i2cx->oaddr1_bit.addr1mode == I2C_ADDRESS_MODE_10BIT)
1020 {
1021 /* wait for the addr7 flag to be set */
1022 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1023 {
1024 /* disable ack */
1025 i2c_ack_enable(hi2c->i2cx, FALSE);
1026
1027 return I2C_ERR_STEP_3;
1028 }
1029
1030 /* clear addr flag */
1031 i2c_addr_flag_clear(hi2c);
1032 }
1033
1034 /* enable interrupt */
1035 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
1036
1037 return I2C_OK;
1038}
1039
1049 i2c_status_type i2c_master_transmit_dma(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1050{
1051 /* initialization parameters */
1052 hi2c->mode = I2C_DMA_MA_TX;
1053 hi2c->status = I2C_START;
1054
1055 hi2c->pbuff = pdata;
1056 hi2c->pcount = size;
1057
1058 hi2c->timeout = timeout;
1059 hi2c->error_code = I2C_OK;
1060
1061 /* wait for the busy flag to be reset */
1062 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1063 {
1064 return I2C_ERR_STEP_1;
1065 }
1066
1067 /* ack acts on the current byte */
1068 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1069
1070 /* disable dma request */
1071 i2c_dma_enable(hi2c->i2cx, FALSE);
1072
1073 /* configure the dma channel */
1074 i2c_dma_config(hi2c, hi2c->dma_tx_channel, pdata, size);
1075
1076 /* send slave address */
1077 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1078 {
1079 /* generate stop condtion */
1080 i2c_stop_generate(hi2c->i2cx);
1081
1082 return I2C_ERR_STEP_2;
1083 }
1084
1085 /* clear addr flag */
1086 i2c_addr_flag_clear(hi2c);
1087
1088 /* enable dma request */
1089 i2c_dma_enable(hi2c->i2cx, TRUE);
1090
1091 return I2C_OK;
1092}
1093
1102 i2c_status_type i2c_slave_receive_dma(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
1103{
1104 /* initialization parameters */
1105 hi2c->mode = I2C_DMA_SLA_RX;
1106 hi2c->status = I2C_START;
1107
1108 hi2c->pbuff = pdata;
1109 hi2c->pcount = size;
1110
1111 hi2c->timeout = timeout;
1112 hi2c->error_code = I2C_OK;
1113
1114 /* wait for the busy flag to be reset */
1115 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1116 {
1117 return I2C_ERR_STEP_1;
1118 }
1119
1120 /* ack acts on the current byte */
1121 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1122
1123 /* enable ack */
1124 i2c_ack_enable(hi2c->i2cx, TRUE);
1125
1126 /* disable dma request */
1127 i2c_dma_enable(hi2c->i2cx, FALSE);
1128
1129 /* configure the dma channel */
1130 i2c_dma_config(hi2c, hi2c->dma_rx_channel, pdata, size);
1131
1132 /* wait for the addr7 flag to be set */
1133 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1134 {
1135 /* disable ack */
1136 i2c_ack_enable(hi2c->i2cx, FALSE);
1137
1138 return I2C_ERR_STEP_2;
1139 }
1140
1141 /* enable dma request */
1142 i2c_dma_enable(hi2c->i2cx, TRUE);
1143
1144 /* clear addr flag */
1145 i2c_addr_flag_clear(hi2c);
1146
1147 return I2C_OK;
1148}
1149
1159 i2c_status_type i2c_master_receive_dma(i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1160{
1161 /* initialization parameters */
1162 hi2c->mode = I2C_DMA_MA_RX;
1163 hi2c->status = I2C_START;
1164
1165 hi2c->pbuff = pdata;
1166 hi2c->pcount = size;
1167
1168 hi2c->timeout = timeout;
1169 hi2c->error_code = I2C_OK;
1170
1171 /* wait for the busy flag to be reset */
1172 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1173 {
1174 return I2C_ERR_STEP_1;
1175 }
1176
1177 /* ack acts on the current byte */
1178 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1179
1180 /* enable ack */
1181 i2c_ack_enable(hi2c->i2cx, TRUE);
1182
1183 /* disable dma request */
1184 i2c_dma_enable(hi2c->i2cx, FALSE);
1185
1186 /* configure the dma channel */
1187 i2c_dma_config(hi2c, hi2c->dma_rx_channel, pdata, size);
1188
1189 /* send slave address */
1190 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
1191 {
1192 /* generate stop condtion */
1193 i2c_stop_generate(hi2c->i2cx);
1194
1195 return I2C_ERR_STEP_2;
1196 }
1197
1198 if(size == 1)
1199 {
1200 /* clear addr flag */
1201 i2c_addr_flag_clear(hi2c);
1202
1203 /* disable ack */
1204 i2c_ack_enable(hi2c->i2cx, FALSE);
1205
1206 /* generate stop condtion */
1207 i2c_stop_generate(hi2c->i2cx);
1208
1209 /* enable dma request */
1210 i2c_dma_enable(hi2c->i2cx, TRUE);
1211 }
1212 else
1213 {
1214 /* enable dma end transfer */
1215 i2c_dma_end_transfer_set(hi2c->i2cx, TRUE);
1216
1217 /* enable dma request */
1218 i2c_dma_enable(hi2c->i2cx, TRUE);
1219
1220 /* clear addr flag */
1221 i2c_addr_flag_clear(hi2c);
1222 }
1223
1224 return I2C_OK;
1225}
1226
1235 i2c_status_type i2c_slave_transmit_dma(i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout)
1236{
1237 /* initialization parameters */
1238 hi2c->mode = I2C_DMA_SLA_TX;
1239 hi2c->status = I2C_START;
1240
1241 hi2c->pbuff = pdata;
1242 hi2c->pcount = size;
1243
1244 hi2c->timeout = timeout;
1245 hi2c->error_code = I2C_OK;
1246
1247 /* wait for the busy flag to be reset */
1248 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1249 {
1250 return I2C_ERR_STEP_1;
1251 }
1252
1253 /* ack acts on the current byte */
1254 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1255
1256 /* enable ack */
1257 i2c_ack_enable(hi2c->i2cx, TRUE);
1258
1259 /* disable dma request */
1260 i2c_dma_enable(hi2c->i2cx, FALSE);
1261
1262 /* configure the dma channel */
1263 i2c_dma_config(hi2c, hi2c->dma_tx_channel, pdata, size);
1264
1265
1266 /* wait for the addr7 flag to be set */
1267 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1268 {
1269 /* disable ack */
1270 i2c_ack_enable(hi2c->i2cx, FALSE);
1271
1272 return I2C_ERR_STEP_2;
1273 }
1274
1275 if(hi2c->i2cx->oaddr1_bit.addr1mode == I2C_ADDRESS_MODE_10BIT)
1276 {
1277 /* clear addr flag */
1278 i2c_addr_flag_clear(hi2c);
1279
1280 /* wait for the addr7 flag to be set */
1281 if(i2c_wait_flag(hi2c, I2C_ADDR7F_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1282 {
1283 /* disable ack */
1284 i2c_ack_enable(hi2c->i2cx, FALSE);
1285
1286 return I2C_ERR_STEP_3;
1287 }
1288 }
1289
1290 /* clear addr flag */
1291 i2c_addr_flag_clear(hi2c);
1292
1293 /* enable dma request */
1294 i2c_dma_enable(hi2c->i2cx, TRUE);
1295
1296 return I2C_OK;
1297}
1298
1309 i2c_status_type i2c_memory_write(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1310{
1311 /* initialization parameters */
1312 hi2c->pbuff = pdata;
1313 hi2c->pcount = size;
1314
1315 hi2c->error_code = I2C_OK;
1316
1317 /* wait for the busy flag to be reset */
1318 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1319 {
1320 return I2C_ERR_STEP_1;
1321 }
1322
1323 /* ack acts on the current byte */
1324 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1325
1326 /* send slave address */
1327 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1328 {
1329 /* generate stop condtion */
1330 i2c_stop_generate(hi2c->i2cx);
1331
1332 return I2C_ERR_STEP_2;
1333 }
1334
1335 /* clear addr flag */
1336 i2c_addr_flag_clear(hi2c);
1337
1338 /* wait for the tdbe flag to be set */
1339 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1340 {
1341 /* generate stop condtion */
1342 i2c_stop_generate(hi2c->i2cx);
1343
1344 return I2C_ERR_STEP_3;
1345 }
1346
1347 /* send memory address */
1348 i2c_data_send(hi2c->i2cx, mem_address);
1349
1350 while(size > 0)
1351 {
1352 /* wait for the tdbe flag to be set */
1353 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1354 {
1355 /* generate stop condtion */
1356 i2c_stop_generate(hi2c->i2cx);
1357
1358 return I2C_ERR_STEP_4;
1359 }
1360
1361 /* write data */
1362 i2c_data_send(hi2c->i2cx, (*pdata++));
1363 size--;
1364 }
1365
1366 /* wait for the tdc flag to be set */
1367 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1368 {
1369 /* generate stop condtion */
1370 i2c_stop_generate(hi2c->i2cx);
1371
1372 return I2C_ERR_STEP_5;
1373 }
1374
1375 /* generate stop condtion */
1376 i2c_stop_generate(hi2c->i2cx);
1377
1378 return I2C_OK;
1379}
1380
1391 i2c_status_type i2c_memory_read(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1392{
1393 /* initialization parameters */
1394 hi2c->pbuff = pdata;
1395 hi2c->pcount = size;
1396
1397 hi2c->error_code = I2C_OK;
1398
1399 /* wait for the busy flag to be reset */
1400 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1401 {
1402 return I2C_ERR_STEP_1;
1403 }
1404
1405 /* ack acts on the current byte */
1406 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1407
1408 /* enable ack */
1409 i2c_ack_enable(hi2c->i2cx, TRUE);
1410
1411 /* send slave address */
1412 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1413 {
1414 /* generate stop condtion */
1415 i2c_stop_generate(hi2c->i2cx);
1416
1417 return I2C_ERR_STEP_2;
1418 }
1419
1420 /* clear addr flag */
1421 i2c_addr_flag_clear(hi2c);
1422
1423 /* wait for the tdbe flag to be set */
1424 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1425 {
1426 /* generate stop condtion */
1427 i2c_stop_generate(hi2c->i2cx);
1428
1429 return I2C_ERR_STEP_3;
1430 }
1431
1432 /* send memory address */
1433 i2c_data_send(hi2c->i2cx, mem_address);
1434
1435 /* wait for the tdbe flag to be set */
1436 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1437 {
1438 /* generate stop condtion */
1439 i2c_stop_generate(hi2c->i2cx);
1440
1441 return I2C_ERR_STEP_4;
1442 }
1443
1444 /* send slave address */
1445 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
1446 {
1447 /* generate stop condtion */
1448 i2c_stop_generate(hi2c->i2cx);
1449
1450 return I2C_ERR_STEP_5;
1451 }
1452
1453 if(size == 1)
1454 {
1455 /* disable ack */
1456 i2c_ack_enable(hi2c->i2cx, FALSE);
1457
1458 /* clear addr flag */
1459 i2c_addr_flag_clear(hi2c);
1460
1461 /* generate stop condtion */
1462 i2c_stop_generate(hi2c->i2cx);
1463 }
1464 else if(size == 2)
1465 {
1466 /* ack acts on the next byte */
1467 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_NEXT);
1468
1469 /* clear addr flag */
1470 i2c_addr_flag_clear(hi2c);
1471
1472 /* disable ack */
1473 i2c_ack_enable(hi2c->i2cx, FALSE);
1474 }
1475 else
1476 {
1477 /* enable ack */
1478 i2c_ack_enable(hi2c->i2cx, TRUE);
1479
1480 /* clear addr flag */
1481 i2c_addr_flag_clear(hi2c);
1482 }
1483
1484 while(size > 0)
1485 {
1486 if(size <= 3)
1487 {
1488 /* 1 byte */
1489 if(size == 1)
1490 {
1491 /* wait for the rdbf flag to be set */
1492 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1493 {
1494 /* generate stop condtion */
1495 i2c_stop_generate(hi2c->i2cx);
1496
1497 return I2C_ERR_STEP_6;
1498 }
1499
1500 /* read data */
1501 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1502 size--;
1503 }
1504 /* 2 bytes */
1505 else if(size == 2)
1506 {
1507 /* wait for the tdc flag to be set */
1508 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1509 {
1510 /* generate stop condtion */
1511 i2c_stop_generate(hi2c->i2cx);
1512
1513 return I2C_ERR_STEP_7;
1514 }
1515
1516 /* generate stop condtion */
1517 i2c_stop_generate(hi2c->i2cx);
1518
1519 /* read data */
1520 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1521 size--;
1522
1523 /* read data */
1524 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1525 size--;
1526 }
1527 /* 3 last bytes */
1528 else
1529 {
1530 /* wait for the tdc flag to be set */
1531 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1532 {
1533 /* generate stop condtion */
1534 i2c_stop_generate(hi2c->i2cx);
1535
1536 return I2C_ERR_STEP_8;
1537 }
1538
1539 /* disable ack */
1540 i2c_ack_enable(hi2c->i2cx, FALSE);
1541
1542 /* read data */
1543 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1544 size--;
1545
1546 /* wait for the tdc flag to be set */
1547 if(i2c_wait_flag(hi2c, I2C_TDC_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1548 {
1549 /* generate stop condtion */
1550 i2c_stop_generate(hi2c->i2cx);
1551
1552 return I2C_ERR_STEP_9;
1553 }
1554
1555 /* generate stop condtion */
1556 i2c_stop_generate(hi2c->i2cx);
1557
1558 /* read data */
1559 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1560 size--;
1561
1562 /* read data */
1563 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1564 size--;
1565 }
1566 }
1567 else
1568 {
1569 /* wait for the rdbf flag to be set */
1570 if(i2c_wait_flag(hi2c, I2C_RDBF_FLAG, RESET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1571 {
1572 /* generate stop condtion */
1573 i2c_stop_generate(hi2c->i2cx);
1574
1575 return I2C_ERR_STEP_10;
1576 }
1577
1578 /* read data */
1579 (*pdata++) = i2c_data_receive(hi2c->i2cx);
1580 size--;
1581 }
1582 }
1583
1584 return I2C_OK;
1585}
1586
1597 i2c_status_type i2c_memory_write_int(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1598{
1599 /* initialization parameters */
1600 hi2c->mode = I2C_INT_MA_TX;
1601 hi2c->status = I2C_START;
1602
1603 hi2c->pbuff = pdata;
1604 hi2c->pcount = size;
1605
1606 hi2c->timeout = timeout;
1607 hi2c->error_code = I2C_OK;
1608
1609 /* wait for the busy flag to be reset */
1610 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1611 {
1612 return I2C_ERR_STEP_1;
1613 }
1614
1615 /* ack acts on the current byte */
1616 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1617
1618 /* send slave address */
1619 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1620 {
1621 /* generate stop condtion */
1622 i2c_stop_generate(hi2c->i2cx);
1623
1624 return I2C_ERR_STEP_2;
1625 }
1626
1627 /* clear addr flag */
1628 i2c_addr_flag_clear(hi2c);
1629
1630 /* wait for the tdbe flag to be set */
1631 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1632 {
1633 /* generate stop condtion */
1634 i2c_stop_generate(hi2c->i2cx);
1635
1636 return I2C_ERR_STEP_3;
1637 }
1638
1639 /* send memory address */
1640 i2c_data_send(hi2c->i2cx, mem_address);
1641
1642 /* wait for the tdbe flag to be set */
1643 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1644 {
1645 /* generate stop condtion */
1646 i2c_stop_generate(hi2c->i2cx);
1647
1648 return I2C_ERR_STEP_4;
1649 }
1650
1651 /* enable interrupt */
1652 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
1653
1654 return I2C_OK;
1655}
1656
1667 i2c_status_type i2c_memory_read_int(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1668{
1669 /* initialization parameters */
1670 hi2c->mode = I2C_INT_MA_RX;
1671 hi2c->status = I2C_START;
1672
1673 hi2c->pbuff = pdata;
1674 hi2c->pcount = size;
1675
1676 hi2c->timeout = timeout;
1677 hi2c->error_code = I2C_OK;
1678
1679 /* wait for the busy flag to be reset */
1680 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1681 {
1682 return I2C_ERR_STEP_1;
1683 }
1684
1685 /* ack acts on the current byte */
1686 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1687
1688 /* send slave address */
1689 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1690 {
1691 /* generate stop condtion */
1692 i2c_stop_generate(hi2c->i2cx);
1693
1694 return I2C_ERR_STEP_2;
1695 }
1696
1697 /* clear addr flag */
1698 i2c_addr_flag_clear(hi2c);
1699
1700 /* wait for the tdbe flag to be set */
1701 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1702 {
1703 /* generate stop condtion */
1704 i2c_stop_generate(hi2c->i2cx);
1705
1706 return I2C_ERR_STEP_3;
1707 }
1708
1709 /* send memory address */
1710 i2c_data_send(hi2c->i2cx, mem_address);
1711
1712 /* wait for the tdbe flag to be set */
1713 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1714 {
1715 /* generate stop condtion */
1716 i2c_stop_generate(hi2c->i2cx);
1717
1718 return I2C_ERR_STEP_4;
1719 }
1720
1721 /* send slave address */
1722 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
1723 {
1724 /* generate stop condtion */
1725 i2c_stop_generate(hi2c->i2cx);
1726
1727 return I2C_ERR_STEP_5;
1728 }
1729
1730 if(hi2c->pcount == 1)
1731 {
1732 /* disable ack */
1733 i2c_ack_enable(hi2c->i2cx, FALSE);
1734
1735 /* clear addr flag */
1736 i2c_addr_flag_clear(hi2c);
1737
1738 /* generate stop condtion */
1739 i2c_stop_generate(hi2c->i2cx);
1740 }
1741 else if(hi2c->pcount == 2)
1742 {
1743 /* ack acts on the next byte */
1744 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_NEXT);
1745
1746 /* clear addr flag */
1747 i2c_addr_flag_clear(hi2c);
1748
1749 /* disable ack */
1750 i2c_ack_enable(hi2c->i2cx, FALSE);
1751 }
1752 else
1753 {
1754 /* enable ack */
1755 i2c_ack_enable(hi2c->i2cx, TRUE);
1756
1757 /* clear addr flag */
1758 i2c_addr_flag_clear(hi2c);
1759 }
1760
1761 /* enable interrupt */
1762 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, TRUE);
1763
1764 return I2C_OK;
1765}
1766
1777 i2c_status_type i2c_memory_write_dma(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1778{
1779 /* initialization parameters */
1780 hi2c->mode = I2C_DMA_MA_TX;
1781 hi2c->status = I2C_START;
1782
1783 hi2c->pbuff = pdata;
1784 hi2c->pcount = size;
1785
1786 hi2c->timeout = timeout;
1787 hi2c->error_code = I2C_OK;
1788
1789 /* wait for the busy flag to be reset */
1790 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1791 {
1792 return I2C_ERR_STEP_1;
1793 }
1794
1795 /* ack acts on the current byte */
1796 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1797
1798 /* disable dma request */
1799 i2c_dma_enable(hi2c->i2cx, FALSE);
1800
1801 /* configure the dma channel */
1802 i2c_dma_config(hi2c, hi2c->dma_tx_channel, pdata, size);
1803
1804 /* send slave address */
1805 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1806 {
1807 /* generate stop condtion */
1808 i2c_stop_generate(hi2c->i2cx);
1809
1810 return I2C_ERR_STEP_2;
1811 }
1812
1813 /* clear addr flag */
1814 i2c_addr_flag_clear(hi2c);
1815
1816 /* wait for the tdbe flag to be set */
1817 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1818 {
1819 /* generate stop condtion */
1820 i2c_stop_generate(hi2c->i2cx);
1821
1822 return I2C_ERR_STEP_3;
1823 }
1824
1825 /* send memory address */
1826 i2c_data_send(hi2c->i2cx, mem_address);
1827
1828 /* wait for the tdbe flag to be set */
1829 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1830 {
1831 /* generate stop condtion */
1832 i2c_stop_generate(hi2c->i2cx);
1833
1834 return I2C_ERR_STEP_4;
1835 }
1836
1837 /* enable dma request */
1838 i2c_dma_enable(hi2c->i2cx, TRUE);
1839
1840 return I2C_OK;
1841}
1842
1853 i2c_status_type i2c_memory_read_dma(i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout)
1854{
1855 /* initialization parameters */
1856 hi2c->mode = I2C_DMA_MA_RX;
1857 hi2c->status = I2C_START;
1858
1859 hi2c->pbuff = pdata;
1860 hi2c->pcount = size;
1861
1862 hi2c->timeout = timeout;
1863 hi2c->error_code = I2C_OK;
1864
1865 /* wait for the busy flag to be reset */
1866 if(i2c_wait_flag(hi2c, I2C_BUSYF_FLAG, SET, I2C_EVENT_CHECK_NONE, timeout) != I2C_OK)
1867 {
1868 return I2C_ERR_STEP_1;
1869 }
1870
1871 /* ack acts on the current byte */
1872 i2c_master_receive_ack_set(hi2c->i2cx, I2C_MASTER_ACK_CURRENT);
1873
1874 /* enable ack */
1875 i2c_ack_enable(hi2c->i2cx, TRUE);
1876
1877 /* disable dma request */
1878 i2c_dma_enable(hi2c->i2cx, FALSE);
1879
1880 /* configure the dma channel */
1881 i2c_dma_config(hi2c, hi2c->dma_rx_channel, pdata, size);
1882
1883 /* send slave address */
1884 if(i2c_master_write_addr(hi2c, address, timeout) != I2C_OK)
1885 {
1886 /* generate stop condtion */
1887 i2c_stop_generate(hi2c->i2cx);
1888
1889 return I2C_ERR_STEP_2;
1890 }
1891
1892 /* clear addr flag */
1893 i2c_addr_flag_clear(hi2c);
1894
1895 /* wait for the tdbe flag to be set */
1896 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1897 {
1898 /* generate stop condtion */
1899 i2c_stop_generate(hi2c->i2cx);
1900
1901 return I2C_ERR_STEP_3;
1902 }
1903
1904 /* send memory address */
1905 i2c_data_send(hi2c->i2cx, mem_address);
1906
1907 /* wait for the tdbe flag to be set */
1908 if(i2c_wait_flag(hi2c, I2C_TDBE_FLAG, RESET, I2C_EVENT_CHECK_ACKFAIL, timeout) != I2C_OK)
1909 {
1910 /* generate stop condtion */
1911 i2c_stop_generate(hi2c->i2cx);
1912
1913 return I2C_ERR_STEP_4;
1914 }
1915
1916 /* send slave address */
1917 if(i2c_master_read_addr(hi2c, address, timeout) != I2C_OK)
1918 {
1919 /* generate stop condtion */
1920 i2c_stop_generate(hi2c->i2cx);
1921
1922 return I2C_ERR_STEP_5;
1923 }
1924
1925 if(size == 1)
1926 {
1927 /* clear addr flag */
1928 i2c_addr_flag_clear(hi2c);
1929
1930 /* disable ack */
1931 i2c_ack_enable(hi2c->i2cx, FALSE);
1932
1933 /* generate stop condtion */
1934 i2c_stop_generate(hi2c->i2cx);
1935
1936 /* enable dma request */
1937 i2c_dma_enable(hi2c->i2cx, TRUE);
1938 }
1939 else
1940 {
1941 /* enable dma end transfer */
1942 i2c_dma_end_transfer_set(hi2c->i2cx, TRUE);
1943
1944 /* enable dma request */
1945 i2c_dma_enable(hi2c->i2cx, TRUE);
1946
1947 /* clear addr flag */
1948 i2c_addr_flag_clear(hi2c);
1949 }
1950
1951 return I2C_OK;
1952}
1953
1959void i2c_master_tx_isr_int(i2c_handle_type* hi2c)
1960{
1961 /* step 1: transfer data */
1962 if(i2c_flag_get(hi2c->i2cx, I2C_TDBE_FLAG) != RESET)
1963 {
1964 if(hi2c->pcount == 0)
1965 {
1966 /* transfer complete */
1967 hi2c->status = I2C_END;
1968
1969 /* disable interrupt */
1970 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, FALSE);
1971
1972 /* generate stop condtion */
1973 i2c_stop_generate(hi2c->i2cx);
1974 }
1975 else
1976 {
1977 /* write data */
1978 i2c_data_send(hi2c->i2cx, *hi2c->pbuff++);
1979 hi2c->pcount--;
1980 }
1981 }
1982}
1983
1989void i2c_master_rx_isr_int(i2c_handle_type* hi2c)
1990{
1991 if(i2c_flag_get(hi2c->i2cx, I2C_TDC_FLAG) != RESET)
1992 {
1993 if(hi2c->pcount == 3)
1994 {
1995 /* disable ack */
1996 i2c_ack_enable(hi2c->i2cx, FALSE);
1997
1998 /* read data */
1999 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2000 hi2c->pcount--;
2001 }
2002 else if(hi2c->pcount == 2)
2003 {
2004 /* generate stop condtion */
2005 i2c_stop_generate(hi2c->i2cx);
2006
2007 /* read data */
2008 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2009 hi2c->pcount--;
2010
2011 /* read data */
2012 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2013 hi2c->pcount--;
2014
2015 /* transfer complete */
2016 hi2c->status = I2C_END;
2017
2018 /* disable interrupt */
2019 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, FALSE);
2020 }
2021 else
2022 {
2023 /* read data */
2024 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2025 hi2c->pcount--;
2026 }
2027 }
2028
2029 else if(i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) != RESET)
2030 {
2031 if(hi2c->pcount > 3)
2032 {
2033 /* read data */
2034 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2035 hi2c->pcount--;
2036 }
2037 else if((hi2c->pcount == 3) || (hi2c->pcount == 2))
2038 {
2039 /* disable rdbf interrupt */
2040 i2c_interrupt_enable(hi2c->i2cx, I2C_DATA_INT, FALSE);
2041 }
2042 else
2043 {
2044 /* read data */
2045 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2046 hi2c->pcount--;
2047
2048 /* transfer complete */
2049 hi2c->status = I2C_END;
2050
2051 /* disable interrupt */
2052 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, FALSE);
2053 }
2054 }
2055}
2056
2062void i2c_slave_tx_isr_int(i2c_handle_type* hi2c)
2063{
2064 /* transfer data */
2065 if(i2c_flag_get(hi2c->i2cx, I2C_TDBE_FLAG) != RESET)
2066 {
2067 if(hi2c->pcount)
2068 {
2069 /* send data */
2070 i2c_data_send(hi2c->i2cx, (*hi2c->pbuff++));
2071 hi2c->pcount--;
2072
2073 if(hi2c->pcount == 0)
2074 {
2075 /* disable interrupt */
2076 i2c_interrupt_enable(hi2c->i2cx, I2C_DATA_INT | I2C_EVT_INT | I2C_ERR_INT, FALSE);
2077
2078 /* wait for the ackfail flag to be set */
2079 hi2c->status = i2c_wait_flag(hi2c, I2C_ACKFAIL_FLAG, RESET, I2C_EVENT_CHECK_NONE, hi2c->timeout);
2080
2081 /* clear ackfail flag */
2082 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
2083
2084 /* transfer complete */
2085 hi2c->status = I2C_END;
2086 }
2087 }
2088 }
2089}
2090
2096void i2c_slave_rx_isr_int(i2c_handle_type* hi2c)
2097{
2098 /* receive data */
2099 if(i2c_flag_get(hi2c->i2cx, I2C_RDBF_FLAG) != RESET)
2100 {
2101 if(hi2c->pcount)
2102 {
2103 /* read data */
2104 (*hi2c->pbuff++) = i2c_data_receive(hi2c->i2cx);
2105
2106 hi2c->pcount--;
2107 }
2108 }
2109
2110 /* step 2: received stop conditon */
2111 else if(i2c_flag_get(hi2c->i2cx, I2C_STOPF_FLAG) != RESET)
2112 {
2113 /* clear stop flag */
2114 i2c_stop_flag_clear(hi2c);
2115
2116 /* transfer complete */
2117 hi2c->status = I2C_END;
2118
2119 /* disable interrupt */
2120 i2c_interrupt_enable(hi2c->i2cx, I2C_EVT_INT | I2C_DATA_INT | I2C_ERR_INT, FALSE);
2121 }
2122}
2123
2129void i2c_evt_irq_handler(i2c_handle_type* hi2c)
2130{
2131 switch(hi2c->mode)
2132 {
2133 case I2C_INT_MA_TX:
2134 i2c_master_tx_isr_int(hi2c);
2135 break;
2136 case I2C_INT_MA_RX:
2137 i2c_master_rx_isr_int(hi2c);
2138 break;
2139 case I2C_INT_SLA_TX:
2140 i2c_slave_tx_isr_int(hi2c);
2141 break;
2142 case I2C_INT_SLA_RX:
2143 i2c_slave_rx_isr_int(hi2c);
2144 break;
2145 default:
2146 break;
2147 }
2148}
2149
2155void i2c_dma_tx_irq_handler(i2c_handle_type* hi2c)
2156{
2157 /* transfer complete */
2158 if(dma_flag_get(DMA_GET_TC_FLAG(hi2c->dma_tx_channel)) != RESET)
2159 {
2160 /* disable the transfer complete interrupt */
2161 dma_interrupt_enable(hi2c->dma_tx_channel, DMA_FDT_INT, FALSE);
2162
2163 /* clear the transfer complete flag */
2164 dma_flag_clear(DMA_GET_TC_FLAG(hi2c->dma_tx_channel));
2165
2166 switch(hi2c->mode)
2167 {
2168 case I2C_DMA_MA_TX:
2169 /* wait for the tdc flag to be set */
2170 hi2c->status = i2c_wait_flag(hi2c, I2C_TDC_FLAG, RESET, I2C_EVENT_CHECK_NONE, hi2c->timeout);
2171
2172 /* generate stop condtion */
2173 i2c_stop_generate(hi2c->i2cx);
2174 break;
2175 case I2C_DMA_SLA_TX:
2176 /* wait for the ackfail flag to be set */
2177 hi2c->status = i2c_wait_flag(hi2c, I2C_ACKFAIL_FLAG, RESET, I2C_EVENT_CHECK_NONE, hi2c->timeout);
2178
2179 /* clear ackfail flag */
2180 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
2181
2182 /* disable ack */
2183 i2c_ack_enable(hi2c->i2cx, FALSE);
2184 break;
2185 default:
2186 break;
2187 }
2188
2189 hi2c->pcount = 0;
2190
2191 /* disable dma request */
2192 i2c_dma_enable(hi2c->i2cx, FALSE);
2193
2194 /* transfer complete */
2195 hi2c->status = I2C_END;
2196 }
2197}
2198
2204void i2c_dma_rx_irq_handler(i2c_handle_type* hi2c)
2205{
2206 /* transfer complete */
2207 if(dma_flag_get(DMA_GET_TC_FLAG(hi2c->dma_rx_channel)) != RESET)
2208 {
2209 /* disable the transfer complete interrupt */
2210 dma_interrupt_enable(hi2c->dma_rx_channel, DMA_FDT_INT, FALSE);
2211
2212 /* clear the transfer complete flag */
2213 dma_flag_clear(DMA_GET_TC_FLAG(hi2c->dma_rx_channel));
2214
2215 switch(hi2c->mode)
2216 {
2217 case I2C_DMA_MA_RX:
2218 /* clear ackfail flag */
2219 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
2220
2221 if(hi2c->pcount != 1)
2222 {
2223 /* generate stop condtion */
2224 i2c_stop_generate(hi2c->i2cx);
2225 }
2226 break;
2227 case I2C_DMA_SLA_RX:
2228 /* wait for the stop flag to be set */
2229 hi2c->status = i2c_wait_flag(hi2c, I2C_STOPF_FLAG, RESET, I2C_EVENT_CHECK_NONE, hi2c->timeout);
2230
2231 /* clear stop flag */
2232 i2c_stop_flag_clear(hi2c);
2233 break;
2234 default:
2235 break;
2236 }
2237
2238 hi2c->pcount = 0;
2239
2240 /* disable dma request */
2241 i2c_dma_enable(hi2c->i2cx, FALSE);
2242
2243 /* transfer complete */
2244 hi2c->status = I2C_END;
2245 }
2246}
2247
2253void i2c_err_irq_handler(i2c_handle_type* hi2c)
2254{
2255 hi2c->error_code = I2C_ERR_INTERRUPT;
2256
2257 /* buserr */
2258 if(i2c_flag_get(hi2c->i2cx, I2C_BUSERR_FLAG) != RESET)
2259 {
2260 i2c_flag_clear(hi2c->i2cx, I2C_BUSERR_FLAG);
2261 }
2262
2263 /* arlost */
2264 if(i2c_flag_get(hi2c->i2cx, I2C_ARLOST_FLAG) != RESET)
2265 {
2266 i2c_flag_clear(hi2c->i2cx, I2C_ARLOST_FLAG);
2267 }
2268
2269 /* ackfail */
2270 if(i2c_flag_get(hi2c->i2cx, I2C_ACKFAIL_FLAG) != RESET)
2271 {
2272 i2c_flag_clear(hi2c->i2cx, I2C_ACKFAIL_FLAG);
2273 }
2274
2275 /* ouf */
2276 if(i2c_flag_get(hi2c->i2cx, I2C_OUF_FLAG) != RESET)
2277 {
2278 i2c_flag_clear(hi2c->i2cx, I2C_OUF_FLAG);
2279 }
2280
2281 /* pecerr */
2282 if(i2c_flag_get(hi2c->i2cx, I2C_PECERR_FLAG) != RESET)
2283 {
2284 i2c_flag_clear(hi2c->i2cx, I2C_PECERR_FLAG);
2285 }
2286
2287 /* tmout */
2288 if(i2c_flag_get(hi2c->i2cx, I2C_TMOUT_FLAG) != RESET)
2289 {
2290 i2c_flag_clear(hi2c->i2cx, I2C_TMOUT_FLAG);
2291 }
2292
2293 /* alertf */
2294 if(i2c_flag_get(hi2c->i2cx, I2C_ALERTF_FLAG) != RESET)
2295 {
2296 i2c_flag_clear(hi2c->i2cx, I2C_ALERTF_FLAG);
2297 }
2298
2299 /* disable all interrupts */
2300 i2c_interrupt_enable(hi2c->i2cx, I2C_ERR_INT, FALSE);
2301}
2302
i2c_master_rx_isr_int
void i2c_master_rx_isr_int(i2c_handle_type *hi2c)
master receive mode interrupt procession function
Definition: i2c_application.c:1989
i2c_slave_rx_isr_int
void i2c_slave_rx_isr_int(i2c_handle_type *hi2c)
slave receive mode interrupt procession function
Definition: i2c_application.c:2096
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:158
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2129
i2c_master_tx_isr_int
void i2c_master_tx_isr_int(i2c_handle_type *hi2c)
master transfer mode interrupt procession function
Definition: i2c_application.c:1959
i2c_slave_transmit_int
i2c_status_type i2c_slave_transmit_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode.
Definition: i2c_application.c:986
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
i2c error interrupt function.
Definition: i2c_application.c:2253
i2c_wait_flag
i2c_status_type i2c_wait_flag(i2c_handle_type *hi2c, uint32_t flag, flag_status status, uint32_t event_check, uint32_t timeout)
wait for the flag.
Definition: i2c_application.c:192
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2204
i2c_master_write_addr
i2c_status_type i2c_master_write_addr(i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master transmits mode.
Definition: i2c_application.c:276
I2C_START
#define I2C_START
i2c transmission status
Definition: i2c_application.c:94
i2c_slave_receive
i2c_status_type i2c_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode.
Definition: i2c_application.c:480
i2c_slave_transmit_dma
i2c_status_type i2c_slave_transmit_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode.
Definition: i2c_application.c:1235
i2c_memory_read
i2c_status_type i2c_memory_read(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1391
i2c_memory_write_int
i2c_status_type i2c_memory_write_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode.
Definition: i2c_application.c:1597
i2c_memory_write
i2c_status_type i2c_memory_write(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode.
Definition: i2c_application.c:1309
i2c_master_receive_int
i2c_status_type i2c_master_receive_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode.
Definition: i2c_application.c:908
i2c_addr_flag_clear
void i2c_addr_flag_clear(i2c_handle_type *hi2c)
clear the addr flag.
Definition: i2c_application.c:129
i2c_slave_tx_isr_int
void i2c_slave_tx_isr_int(i2c_handle_type *hi2c)
slave transfer mode interrupt procession function
Definition: i2c_application.c:2062
i2c_memory_write_dma
i2c_status_type i2c_memory_write_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode.
Definition: i2c_application.c:1777
i2c_master_read_addr
i2c_status_type i2c_master_read_addr(i2c_handle_type *hi2c, uint16_t address, uint32_t timeout)
send address in master receive mode.
Definition: i2c_application.c:329
I2C_END
#define I2C_END
Definition: i2c_application.c:95
i2c_stop_flag_clear
void i2c_stop_flag_clear(i2c_handle_type *hi2c)
clear the stop flag.
Definition: i2c_application.c:143
i2c_master_transmit_dma
i2c_status_type i2c_master_transmit_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode.
Definition: i2c_application.c:1049
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:112
DMA_GET_TC_FLAG
#define DMA_GET_TC_FLAG(DMA_CHANNEL)
get the dma transfer complete flag through the channel
Definition: i2c_application.c:37
i2c_dma_config
void i2c_dma_config(i2c_handle_type *hi2c, dma_channel_type *dma_channelx, uint8_t *pdata, uint16_t size)
dma transfer cofiguration.
Definition: i2c_application.c:247
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2155
i2c_lowlevel_init
__WEAK void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:102
i2c_slave_receive_dma
i2c_status_type i2c_slave_receive_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode.
Definition: i2c_application.c:1102
i2c_master_transmit_int
i2c_status_type i2c_master_transmit_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode.
Definition: i2c_application.c:813
i2c_memory_read_int
i2c_status_type i2c_memory_read_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode.
Definition: i2c_application.c:1667
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:555
i2c_master_receive_dma
i2c_status_type i2c_master_receive_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode.
Definition: i2c_application.c:1159
i2c_slave_receive_int
i2c_status_type i2c_slave_receive_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode.
Definition: i2c_application.c:860
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:412
i2c_slave_transmit
i2c_status_type i2c_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode.
Definition: i2c_application.c:726
i2c_memory_read_dma
i2c_status_type i2c_memory_read_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1853
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
flag_status
flag_status
flag status
Definition: at32f413.h:254
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
i2c_data_receive
uint8_t i2c_data_receive(i2c_type *i2c_x)
receive a byte through the i2c periph.
Definition: at32f413_i2c.c:535
i2c_reset
void i2c_reset(i2c_type *i2c_x)
reset the i2c register
Definition: at32f413_i2c.c:51
i2c_ack_enable
void i2c_ack_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable acknowledge.
Definition: at32f413_i2c.c:283
i2c_7bit_address_send
void i2c_7bit_address_send(i2c_type *i2c_x, uint8_t address, i2c_direction_type direction)
transmit the slave address.
Definition: at32f413_i2c.c:503
i2c_dma_end_transfer_set
void i2c_dma_end_transfer_set(i2c_type *i2c_x, confirm_state new_state)
enable or disable if the next dma transfer will be the last one.
Definition: at32f413_i2c.c:424
i2c_stop_generate
void i2c_stop_generate(i2c_type *i2c_x)
generate stop condition.
Definition: at32f413_i2c.c:486
i2c_enable
void i2c_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable i2c periph
Definition: at32f413_i2c.c:241
i2c_flag_get
flag_status i2c_flag_get(i2c_type *i2c_x, uint32_t flag)
get flag status
Definition: at32f413_i2c.c:570
i2c_interrupt_enable
void i2c_interrupt_enable(i2c_type *i2c_x, uint16_t source, confirm_state new_state)
enable or disable interrupt
Definition: at32f413_i2c.c:455
i2c_flag_clear
void i2c_flag_clear(i2c_type *i2c_x, uint32_t flag)
clear flag status
Definition: at32f413_i2c.c:615
i2c_dma_enable
void i2c_dma_enable(i2c_type *i2c_x, confirm_state new_state)
enable or disable dma requests.
Definition: at32f413_i2c.c:437
i2c_data_send
void i2c_data_send(i2c_type *i2c_x, uint8_t data)
send a byte through the i2c periph.
Definition: at32f413_i2c.c:523
i2c_master_receive_ack_set
void i2c_master_receive_ack_set(i2c_type *i2c_x, i2c_master_ack_type pos)
master receiving mode acknowledge control.
Definition: at32f413_i2c.c:299
i2c_start_generate
void i2c_start_generate(i2c_type *i2c_x)
generate start condition.
Definition: at32f413_i2c.c:474
I2C_DIRECTION_RECEIVE
@ I2C_DIRECTION_RECEIVE
Definition: at32f413_i2c.h:167
I2C_DIRECTION_TRANSMIT
@ I2C_DIRECTION_TRANSMIT
Definition: at32f413_i2c.h:166
I2C_MASTER_ACK_CURRENT
@ I2C_MASTER_ACK_CURRENT
Definition: at32f413_i2c.h:110
I2C_MASTER_ACK_NEXT
@ I2C_MASTER_ACK_NEXT
Definition: at32f413_i2c.h:111
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:157
I2C_ADDRESS_MODE_10BIT
@ I2C_ADDRESS_MODE_10BIT
Definition: at32f413_i2c.h:158
I2C_EVT_INT
#define I2C_EVT_INT
Definition: at32f413_i2c.h:94
I2C_ERR_INT
#define I2C_ERR_INT
Definition: at32f413_i2c.h:95
I2C_DATA_INT
#define I2C_DATA_INT
Definition: at32f413_i2c.h:93
I2C_EVENT_CHECK_STOP
#define I2C_EVENT_CHECK_STOP
Definition: i2c_application.h:49
I2C_EVENT_CHECK_NONE
#define I2C_EVENT_CHECK_NONE
Definition: i2c_application.h:47
I2C_EVENT_CHECK_ACKFAIL
#define I2C_EVENT_CHECK_ACKFAIL
Definition: i2c_application.h:48
i2c_status_type
i2c_status_type
Definition: i2c_application.h:81
I2C_ERR_STEP_1
@ I2C_ERR_STEP_1
Definition: i2c_application.h:83
I2C_ERR_TIMEOUT
@ I2C_ERR_TIMEOUT
Definition: i2c_application.h:100
I2C_ERR_ADDR10
@ I2C_ERR_ADDR10
Definition: i2c_application.h:96
I2C_ERR_START
@ I2C_ERR_START
Definition: i2c_application.h:95
I2C_ERR_INTERRUPT
@ I2C_ERR_INTERRUPT
Definition: i2c_application.h:101
I2C_ERR_STEP_3
@ I2C_ERR_STEP_3
Definition: i2c_application.h:85
I2C_ERR_STEP_6
@ I2C_ERR_STEP_6
Definition: i2c_application.h:88
I2C_ERR_STEP_5
@ I2C_ERR_STEP_5
Definition: i2c_application.h:87
I2C_ERR_STEP_9
@ I2C_ERR_STEP_9
Definition: i2c_application.h:91
I2C_ERR_STEP_7
@ I2C_ERR_STEP_7
Definition: i2c_application.h:89
I2C_ERR_STOP
@ I2C_ERR_STOP
Definition: i2c_application.h:98
I2C_ERR_STEP_8
@ I2C_ERR_STEP_8
Definition: i2c_application.h:90
I2C_ERR_ACKFAIL
@ I2C_ERR_ACKFAIL
Definition: i2c_application.h:99
I2C_ERR_ADDR
@ I2C_ERR_ADDR
Definition: i2c_application.h:97
I2C_ERR_STEP_2
@ I2C_ERR_STEP_2
Definition: i2c_application.h:84
I2C_OK
@ I2C_OK
Definition: i2c_application.h:82
I2C_ERR_STEP_10
@ I2C_ERR_STEP_10
Definition: i2c_application.h:92
I2C_ERR_STEP_4
@ I2C_ERR_STEP_4
Definition: i2c_application.h:86
I2C_DMA_MA_RX
@ I2C_DMA_MA_RX
Definition: i2c_application.h:66
I2C_DMA_SLA_RX
@ I2C_DMA_SLA_RX
Definition: i2c_application.h:68
I2C_INT_SLA_RX
@ I2C_INT_SLA_RX
Definition: i2c_application.h:64
I2C_DMA_MA_TX
@ I2C_DMA_MA_TX
Definition: i2c_application.h:65
I2C_INT_MA_RX
@ I2C_INT_MA_RX
Definition: i2c_application.h:62
I2C_INT_SLA_TX
@ I2C_INT_SLA_TX
Definition: i2c_application.h:63
I2C_INT_MA_TX
@ I2C_INT_MA_TX
Definition: i2c_application.h:61
I2C_DMA_SLA_TX
@ I2C_DMA_SLA_TX
Definition: i2c_application.h:67
I2C_STARTF_FLAG
#define I2C_STARTF_FLAG
Definition: at32f413_i2c.h:52
I2C_TMOUT_FLAG
#define I2C_TMOUT_FLAG
Definition: at32f413_i2c.h:64
I2C_ADDR7F_FLAG
#define I2C_ADDR7F_FLAG
Definition: at32f413_i2c.h:53
I2C_ALERTF_FLAG
#define I2C_ALERTF_FLAG
Definition: at32f413_i2c.h:65
I2C_BUSERR_FLAG
#define I2C_BUSERR_FLAG
Definition: at32f413_i2c.h:59
I2C_ACKFAIL_FLAG
#define I2C_ACKFAIL_FLAG
Definition: at32f413_i2c.h:61
I2C_OUF_FLAG
#define I2C_OUF_FLAG
Definition: at32f413_i2c.h:62
I2C_ARLOST_FLAG
#define I2C_ARLOST_FLAG
Definition: at32f413_i2c.h:60
I2C_STOPF_FLAG
#define I2C_STOPF_FLAG
Definition: at32f413_i2c.h:56
I2C_TDC_FLAG
#define I2C_TDC_FLAG
Definition: at32f413_i2c.h:54
I2C_ADDRHF_FLAG
#define I2C_ADDRHF_FLAG
Definition: at32f413_i2c.h:55
I2C_TDBE_FLAG
#define I2C_TDBE_FLAG
Definition: at32f413_i2c.h:58
I2C_RDBF_FLAG
#define I2C_RDBF_FLAG
Definition: at32f413_i2c.h:57
I2C_PECERR_FLAG
#define I2C_PECERR_FLAG
Definition: at32f413_i2c.h:63
I2C_BUSYF_FLAG
#define I2C_BUSYF_FLAG
Definition: at32f413_i2c.h:77
i2c_application.h
i2c application libray header file
dma_channel_type
type define dma channel register all
Definition: at32f413_dma.h:412
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
i2c_handle_type
Definition: i2c_application.h:114
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:124
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:115
i2c_handle_type::status
__IO uint32_t status
Definition: i2c_application.h:121
i2c_handle_type::pbuff
uint8_t * pbuff
Definition: i2c_application.h:116
i2c_handle_type::mode
__IO uint32_t mode
Definition: i2c_application.h:119
i2c_handle_type::timeout
__IO uint32_t timeout
Definition: i2c_application.h:120
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:125
i2c_handle_type::error_code
__IO i2c_status_type error_code
Definition: i2c_application.h:122
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:123
i2c_handle_type::pcount
__IO uint16_t pcount
Definition: i2c_application.h:118
i2c_type::oaddr1_bit
struct i2c_type::@508::@524 oaddr1_bit
i2c_type::sts1
__IO uint32_t sts1
Definition: at32f413_i2c.h:268
i2c_type::ctrl1_bit
struct i2c_type::@504::@522 ctrl1_bit
i2c_type::addr1mode
__IO uint32_t addr1mode
Definition: at32f413_i2c.h:231
i2c_type::dt
__IO uint32_t dt
Definition: at32f413_i2c.h:255
i2c_type::i2cen
__IO uint32_t i2cen
Definition: at32f413_i2c.h:183
i2c_type::sts2
__IO uint32_t sts2
Definition: at32f413_i2c.h:296


AT32F413 Firmwary Library: i2c_application.h Source File

  • middlewares
  • i2c_application_library
i2c_application.h
Go to the documentation of this file.
1
28#ifndef __I2C_APPLICATION_H
29#define __I2C_APPLICATION_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
47#define I2C_EVENT_CHECK_NONE ((uint32_t)0x00000000)
48#define I2C_EVENT_CHECK_ACKFAIL ((uint32_t)0x00000001)
49#define I2C_EVENT_CHECK_STOP ((uint32_t)0x00000002)
59typedef enum
60{
61 I2C_INT_MA_TX = 0,
62 I2C_INT_MA_RX,
63 I2C_INT_SLA_TX,
64 I2C_INT_SLA_RX,
65 I2C_DMA_MA_TX,
66 I2C_DMA_MA_RX,
67 I2C_DMA_SLA_TX,
68 I2C_DMA_SLA_RX,
69} i2c_mode_type;
70
71
80typedef enum
81{
82 I2C_OK = 0,
83 I2C_ERR_STEP_1,
84 I2C_ERR_STEP_2,
85 I2C_ERR_STEP_3,
86 I2C_ERR_STEP_4,
87 I2C_ERR_STEP_5,
88 I2C_ERR_STEP_6,
89 I2C_ERR_STEP_7,
90 I2C_ERR_STEP_8,
91 I2C_ERR_STEP_9,
92 I2C_ERR_STEP_10,
93 I2C_ERR_STEP_11,
94 I2C_ERR_STEP_12,
95 I2C_ERR_START,
96 I2C_ERR_ADDR10,
97 I2C_ERR_ADDR,
98 I2C_ERR_STOP,
99 I2C_ERR_ACKFAIL,
100 I2C_ERR_TIMEOUT,
101 I2C_ERR_INTERRUPT,
103} i2c_status_type;
104
113typedef struct
114{
115 i2c_type *i2cx;
116 uint8_t *pbuff;
117 __IO uint16_t psize;
118 __IO uint16_t pcount;
119 __IO uint32_t mode;
120 __IO uint32_t timeout;
121 __IO uint32_t status;
122 __IO i2c_status_type error_code;
123 dma_channel_type *dma_tx_channel;
124 dma_channel_type *dma_rx_channel;
125 dma_init_type dma_init_struct;
126} i2c_handle_type;
127
136void i2c_config (i2c_handle_type* hi2c);
137void i2c_lowlevel_init (i2c_handle_type* hi2c);
138void i2c_reset_ctrl2_register (i2c_handle_type* hi2c);
139 i2c_status_type i2c_wait_end (i2c_handle_type* hi2c, uint32_t timeout);
140 i2c_status_type i2c_wait_flag (i2c_handle_type* hi2c, uint32_t flag, flag_status status, uint32_t event_check, uint32_t timeout);
141
142 i2c_status_type i2c_master_transmit (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
143 i2c_status_type i2c_master_receive (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
144 i2c_status_type i2c_slave_transmit (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
145 i2c_status_type i2c_slave_receive (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
146
147 i2c_status_type i2c_master_transmit_int (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
148 i2c_status_type i2c_master_receive_int (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
149 i2c_status_type i2c_slave_transmit_int (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
150 i2c_status_type i2c_slave_receive_int (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
151
152 i2c_status_type i2c_master_transmit_dma (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
153 i2c_status_type i2c_master_receive_dma (i2c_handle_type* hi2c, uint16_t address, uint8_t* pdata, uint16_t size, uint32_t timeout);
154 i2c_status_type i2c_slave_transmit_dma (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
155 i2c_status_type i2c_slave_receive_dma (i2c_handle_type* hi2c, uint8_t* pdata, uint16_t size, uint32_t timeout);
156
157 i2c_status_type i2c_memory_write (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
158 i2c_status_type i2c_memory_write_int (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
159 i2c_status_type i2c_memory_write_dma (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
160 i2c_status_type i2c_memory_read (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
161 i2c_status_type i2c_memory_read_int (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
162 i2c_status_type i2c_memory_read_dma (i2c_handle_type* hi2c, uint16_t address, uint16_t mem_address, uint8_t* pdata, uint16_t size, uint32_t timeout);
163
164void i2c_evt_irq_handler (i2c_handle_type* hi2c);
165void i2c_err_irq_handler (i2c_handle_type* hi2c);
166void i2c_dma_tx_irq_handler (i2c_handle_type* hi2c);
167void i2c_dma_rx_irq_handler (i2c_handle_type* hi2c);
168
177#ifdef __cplusplus
178}
179#endif
180
181#endif
at32f413.h
at32f413 header file
flag_status
flag_status
flag status
Definition: at32f413.h:254
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:158
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2129
i2c_slave_transmit_int
i2c_status_type i2c_slave_transmit_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode.
Definition: i2c_application.c:986
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
i2c error interrupt function.
Definition: i2c_application.c:2253
i2c_wait_flag
i2c_status_type i2c_wait_flag(i2c_handle_type *hi2c, uint32_t flag, flag_status status, uint32_t event_check, uint32_t timeout)
wait for the flag.
Definition: i2c_application.c:192
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2204
i2c_slave_receive
i2c_status_type i2c_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode.
Definition: i2c_application.c:480
i2c_slave_transmit_dma
i2c_status_type i2c_slave_transmit_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode.
Definition: i2c_application.c:1235
i2c_memory_read
i2c_status_type i2c_memory_read(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1391
i2c_memory_write_int
i2c_status_type i2c_memory_write_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode.
Definition: i2c_application.c:1597
i2c_memory_write
i2c_status_type i2c_memory_write(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode.
Definition: i2c_application.c:1309
i2c_master_receive_int
i2c_status_type i2c_master_receive_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode.
Definition: i2c_application.c:908
i2c_memory_write_dma
i2c_status_type i2c_memory_write_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode.
Definition: i2c_application.c:1777
i2c_reset_ctrl2_register
void i2c_reset_ctrl2_register(i2c_handle_type *hi2c)
i2c_master_transmit_dma
i2c_status_type i2c_master_transmit_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode.
Definition: i2c_application.c:1049
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:112
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2155
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: i2c_application.c:102
i2c_slave_receive_dma
i2c_status_type i2c_slave_receive_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode.
Definition: i2c_application.c:1102
i2c_master_transmit_int
i2c_status_type i2c_master_transmit_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode.
Definition: i2c_application.c:813
i2c_memory_read_int
i2c_status_type i2c_memory_read_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode.
Definition: i2c_application.c:1667
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:555
i2c_master_receive_dma
i2c_status_type i2c_master_receive_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode.
Definition: i2c_application.c:1159
i2c_slave_receive_int
i2c_status_type i2c_slave_receive_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode.
Definition: i2c_application.c:860
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:412
i2c_slave_transmit
i2c_status_type i2c_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode.
Definition: i2c_application.c:726
i2c_memory_read_dma
i2c_status_type i2c_memory_read_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1853
i2c_status_type
i2c_status_type
Definition: i2c_application.h:81
I2C_ERR_STEP_1
@ I2C_ERR_STEP_1
Definition: i2c_application.h:83
I2C_ERR_TIMEOUT
@ I2C_ERR_TIMEOUT
Definition: i2c_application.h:100
I2C_ERR_ADDR10
@ I2C_ERR_ADDR10
Definition: i2c_application.h:96
I2C_ERR_START
@ I2C_ERR_START
Definition: i2c_application.h:95
I2C_ERR_STEP_11
@ I2C_ERR_STEP_11
Definition: i2c_application.h:93
I2C_ERR_INTERRUPT
@ I2C_ERR_INTERRUPT
Definition: i2c_application.h:101
I2C_ERR_STEP_3
@ I2C_ERR_STEP_3
Definition: i2c_application.h:85
I2C_ERR_STEP_6
@ I2C_ERR_STEP_6
Definition: i2c_application.h:88
I2C_ERR_STEP_5
@ I2C_ERR_STEP_5
Definition: i2c_application.h:87
I2C_ERR_STEP_9
@ I2C_ERR_STEP_9
Definition: i2c_application.h:91
I2C_ERR_STEP_7
@ I2C_ERR_STEP_7
Definition: i2c_application.h:89
I2C_ERR_STOP
@ I2C_ERR_STOP
Definition: i2c_application.h:98
I2C_ERR_STEP_8
@ I2C_ERR_STEP_8
Definition: i2c_application.h:90
I2C_ERR_ACKFAIL
@ I2C_ERR_ACKFAIL
Definition: i2c_application.h:99
I2C_ERR_ADDR
@ I2C_ERR_ADDR
Definition: i2c_application.h:97
I2C_ERR_STEP_12
@ I2C_ERR_STEP_12
Definition: i2c_application.h:94
I2C_ERR_STEP_2
@ I2C_ERR_STEP_2
Definition: i2c_application.h:84
I2C_OK
@ I2C_OK
Definition: i2c_application.h:82
I2C_ERR_STEP_10
@ I2C_ERR_STEP_10
Definition: i2c_application.h:92
I2C_ERR_STEP_4
@ I2C_ERR_STEP_4
Definition: i2c_application.h:86
i2c_mode_type
i2c_mode_type
Definition: i2c_application.h:60
I2C_DMA_MA_RX
@ I2C_DMA_MA_RX
Definition: i2c_application.h:66
I2C_DMA_SLA_RX
@ I2C_DMA_SLA_RX
Definition: i2c_application.h:68
I2C_INT_SLA_RX
@ I2C_INT_SLA_RX
Definition: i2c_application.h:64
I2C_DMA_MA_TX
@ I2C_DMA_MA_TX
Definition: i2c_application.h:65
I2C_INT_MA_RX
@ I2C_INT_MA_RX
Definition: i2c_application.h:62
I2C_INT_SLA_TX
@ I2C_INT_SLA_TX
Definition: i2c_application.h:63
I2C_INT_MA_TX
@ I2C_INT_MA_TX
Definition: i2c_application.h:61
I2C_DMA_SLA_TX
@ I2C_DMA_SLA_TX
Definition: i2c_application.h:67
dma_channel_type
type define dma channel register all
Definition: at32f413_dma.h:412
dma_init_type
dma init type
Definition: at32f413_dma.h:275
i2c_handle_type
Definition: i2c_application.h:114
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:124
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:115
i2c_handle_type::status
__IO uint32_t status
Definition: i2c_application.h:121
i2c_handle_type::psize
__IO uint16_t psize
Definition: i2c_application.h:117
i2c_handle_type::pbuff
uint8_t * pbuff
Definition: i2c_application.h:116
i2c_handle_type::mode
__IO uint32_t mode
Definition: i2c_application.h:119
i2c_handle_type::timeout
__IO uint32_t timeout
Definition: i2c_application.h:120
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:125
i2c_handle_type::error_code
__IO i2c_status_type error_code
Definition: i2c_application.h:122
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:123
i2c_handle_type::pcount
__IO uint16_t pcount
Definition: i2c_application.h:118
i2c_type
type define i2c register all
Definition: at32f413_i2c.h:174


AT32F413 Firmwary Library: julia_fpu.c Source File

  • cortex_m4
  • fpu
  • src
julia_fpu.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "julia_fpu.h"
29
48void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t * buffer)
49{
50 float tmp1, tmp2;
51 float num_real, num_img;
52 float rayon;
53 uint16_t i;
54 uint16_t x, y;
55 for (y = 0; y < size_y; y++)
56 {
57 for (x = 0; x < size_x; x++)
58 {
59 num_real = y - offset_y;
60 num_real = num_real / zoom;
61 num_img = x - offset_x;
62 num_img = num_img / zoom;
63 i = 0;
64 rayon = 0;
65 while((i < ITERATION - 1) && (rayon < 4))
66 {
67 tmp1 = num_real * num_real;
68 tmp2 = num_img * num_img;
69 num_img = 2 * num_real * num_img + IMG_CONSTANT;
70 num_real = tmp1 - tmp2 + REAL_CONSTANT;
71 rayon = tmp1 + tmp2;
72 i++;
73 }
74 /* store the value in the buffer */
75 buffer[x + y * size_x] = i;
76 }
77 }
78}
79
IMG_CONSTANT
#define IMG_CONSTANT
Definition: julia_fpu.h:47
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: julia_fpu.c:48
REAL_CONSTANT
#define REAL_CONSTANT
Definition: julia_fpu.h:46
ITERATION
#define ITERATION
Definition: julia_fpu.h:45
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
julia_fpu.h
julia_fpu header file


AT32F413 Firmwary Library: julia_fpu.h Source File

  • cortex_m4
  • fpu
  • inc
julia_fpu.h
Go to the documentation of this file.
1
27#ifndef __JULIA_FPU_H
28#define __JULIA_FPU_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34/* includes ------------------------------------------------------------------*/
35#include "at32f413.h"
36
45#define ITERATION 200
46#define REAL_CONSTANT (0.285f)
47#define IMG_CONSTANT (0.01f)
48
53void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t * buffer);
54
67#ifdef __cplusplus
68}
69#endif
70
71#endif
72
at32f413.h
at32f413 header file
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: julia_fpu.c:48


AT32F413 Firmwary Library: keyboard_class.c Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "keyboard_class.h"
28#include "keyboard_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53 keyboard_type keyboard_struct;
54#define SHIFT 0x80
55const static unsigned char _asciimap[128] =
56{
57 0x00,// NUL
58 0x00,// SOH
59 0x00,// STX
60 0x00,// ETX
61 0x00,// EOT
62 0x00,// ENQ
63 0x00,// ACK
64 0x00,// BEL
65 0x2A,// BS Backspace
66 0x2B,// TAB Tab
67 0x28,// LF Enter
68 0x00,// VT
69 0x00,// FF
70 0x00,// CR
71 0x00,// SO
72 0x00,// SI
73 0x00,// DEL
74 0x00,// DC1
75 0x00,// DC2
76 0x00,// DC3
77 0x00,// DC4
78 0x00,// NAK
79 0x00,// SYN
80 0x00,// ETB
81 0x00,// CAN
82 0x00,// EM
83 0x00,// SUB
84 0x00,// ESC
85 0x00,// FS
86 0x00,// GS
87 0x00,// RS
88 0x00,// US
89
90 0x2C,// ' '
91 0x1E|SHIFT,// !
92 0x34|SHIFT,// "
93 0x20|SHIFT,// #
94 0x21|SHIFT,// $
95 0x22|SHIFT,// %
96 0x24|SHIFT,// &
97 0x34, // '
98 0x26|SHIFT,// (
99 0x27|SHIFT,// )
100 0x25|SHIFT,// *
101 0x2E|SHIFT,// +
102 0x36,// ,
103 0x2D,// -
104 0x37,// .
105 0x38,// /
106 0x27,// 0
107 0x1E,// 1
108 0x1F,// 2
109 0x20,// 3
110 0x21,// 4
111 0x22,// 5
112 0x23,// 6
113 0x24,// 7
114 0x25,// 8
115 0x26,// 9
116 0x33|SHIFT,// :
117 0x33, // ;
118 0x36|SHIFT,// <
119 0x2E, // =
120 0x37|SHIFT,// >
121 0x38|SHIFT,// ?
122 0x1F|SHIFT,// @
123 0x04|SHIFT,// A
124 0x05|SHIFT,// B
125 0x06|SHIFT,// C
126 0x07|SHIFT,// D
127 0x08|SHIFT,// E
128 0x09|SHIFT,// F
129 0x0A|SHIFT,// G
130 0x0B|SHIFT,// H
131 0x0C|SHIFT,// I
132 0x0D|SHIFT,// J
133 0x0E|SHIFT,// K
134 0x0F|SHIFT,// L
135 0x10|SHIFT,// M
136 0x11|SHIFT,// N
137 0x12|SHIFT,// O
138 0x13|SHIFT,// P
139 0x14|SHIFT,// Q
140 0x15|SHIFT,// R
141 0x16|SHIFT,// S
142 0x17|SHIFT,// T
143 0x18|SHIFT,// U
144 0x19|SHIFT,// V
145 0x1A|SHIFT,// W
146 0x1B|SHIFT,// X
147 0x1C|SHIFT,// Y
148 0x1D|SHIFT,// Z
149 0x2F, // [
150 0x31, // bslash
151 0x30, // ]
152 0x23|SHIFT,// ^
153 0x2D|SHIFT,// _
154 0x35, // `
155 0x04, // a
156 0x05, // b
157 0x06, // c
158 0x07, // d
159 0x08, // e
160 0x09, // f
161 0x0A, // g
162 0x0B, // h
163 0x0C, // i
164 0x0D, // j
165 0x0E, // k
166 0x0F, // l
167 0x10, // m
168 0x11, // n
169 0x12, // o
170 0x13, // p
171 0x14, // q
172 0x15, // r
173 0x16, // s
174 0x17, // t
175 0x18, // u
176 0x19, // v
177 0x1A, // w
178 0x1B, // x
179 0x1C, // y
180 0x1D, // z
181 0x2f|SHIFT,//
182 0x31|SHIFT,// |
183 0x30|SHIFT,// }
184 0x35|SHIFT,// ~
185 0 // DEL
186};
187
188/* usb device class handler */
189 usbd_class_handler keyboard_class_handler =
190{
191 class_init_handler,
192 class_clear_handler,
193 class_setup_handler,
194 class_ept0_tx_handler,
195 class_ept0_rx_handler,
196 class_in_handler,
197 class_out_handler,
198 class_sof_handler,
199 class_event_handler,
200 &keyboard_struct
201};
202
208static usb_sts_type class_init_handler(void *udev)
209{
210 usb_sts_type status = USB_OK;
211 usbd_core_type *pudev = (usbd_core_type *)udev;
212 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
213#ifndef USB_EPT_AUTO_MALLOC_BUFFER
214 /* use user define buffer address */
215 usbd_ept_buf_custom_define(pudev, USBD_KEYBOARD_IN_EPT, EPT1_TX_ADDR);
216#endif
217
218 /* open hid in endpoint */
219 usbd_ept_open(pudev, USBD_KEYBOARD_IN_EPT, EPT_INT_TYPE, USBD_KEYBOARD_IN_MAXPACKET_SIZE);
220
221 pkeyboard->g_u8tx_completed = 1;
222
223 return status;
224}
225
231static usb_sts_type class_clear_handler(void *udev)
232{
233 usb_sts_type status = USB_OK;
234 usbd_core_type *pudev = (usbd_core_type *)udev;
235
236 /* close hid in endpoint */
237 usbd_ept_close(pudev, USBD_KEYBOARD_IN_EPT);
238
239 return status;
240}
241
248static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
249{
250 usb_sts_type status = USB_OK;
251 usbd_core_type *pudev = (usbd_core_type *)udev;
252 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
253 uint16_t len;
254 uint8_t *buf;
255
256 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
257 {
258 /* class request */
259 case USB_REQ_TYPE_CLASS:
260 switch(setup->bRequest)
261 {
262 case HID_REQ_SET_PROTOCOL:
263 pkeyboard->hid_protocol = (uint8_t)setup->wValue;
264 break;
265 case HID_REQ_GET_PROTOCOL:
266 usbd_ctrl_send(pudev, (uint8_t *)&pkeyboard->hid_protocol, 1);
267 break;
268 case HID_REQ_SET_IDLE:
269 pkeyboard->hid_set_idle = (uint8_t)(setup->wValue >> 8);
270 break;
271 case HID_REQ_GET_IDLE:
272 usbd_ctrl_send(pudev, (uint8_t *)&pkeyboard->hid_set_idle, 1);
273 break;
274 case HID_REQ_SET_REPORT:
275 pkeyboard->hid_state = HID_REQ_SET_REPORT;
276 usbd_ctrl_recv(pudev, pkeyboard->hid_set_report, setup->wLength);
277 break;
278 default:
279 usbd_ctrl_unsupport(pudev);
280 break;
281 }
282 break;
283 /* standard request */
284 case USB_REQ_TYPE_STANDARD:
285 switch(setup->bRequest)
286 {
287 case USB_STD_REQ_GET_DESCRIPTOR:
288 if(setup->wValue >> 8 == HID_REPORT_DESC)
289 {
290 len = MIN(USBD_KEYBOARD_SIZ_REPORT_DESC, setup->wLength);
291 buf = (uint8_t *)g_usbd_keyboard_report;
292 }
293 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
294 {
295 len = MIN(9, setup->wLength);
296 buf = (uint8_t *)g_keyboard_usb_desc;
297 }
298 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
299 break;
300 case USB_STD_REQ_GET_INTERFACE:
301 usbd_ctrl_send(pudev, (uint8_t *)&pkeyboard->alt_setting, 1);
302 break;
303 case USB_STD_REQ_SET_INTERFACE:
304 pkeyboard->alt_setting = setup->wValue;
305 break;
306 default:
307 break;
308 }
309 break;
310 default:
311 usbd_ctrl_unsupport(pudev);
312 break;
313 }
314 return status;
315}
316
322static usb_sts_type class_ept0_tx_handler(void *udev)
323{
324 usb_sts_type status = USB_OK;
325
326 /* ...user code... */
327
328 return status;
329}
330
336static usb_sts_type class_ept0_rx_handler(void *udev)
337{
338 usb_sts_type status = USB_OK;
339 usbd_core_type *pudev = (usbd_core_type *)udev;
340 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
341 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
342 /* ...user code... */
343 if( pkeyboard->hid_state == HID_REQ_SET_REPORT)
344 {
345 /* hid buffer process */
346 pkeyboard->hid_state = 0;
347 }
348
349 return status;
350}
351
358static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
359{
360 usb_sts_type status = USB_OK;
361 usbd_core_type *pudev = (usbd_core_type *)udev;
362 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
363
364 /* ...user code...
365 trans next packet data
366 */
367 pkeyboard->g_u8tx_completed = 1;
368
369 return status;
370}
371
378static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
379{
380 usb_sts_type status = USB_OK;
381
382 return status;
383}
384
390static usb_sts_type class_sof_handler(void *udev)
391{
392 usb_sts_type status = USB_OK;
393
394 /* ...user code... */
395
396 return status;
397}
398
405static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
406{
407 usb_sts_type status = USB_OK;
408 usbd_core_type *pudev = (usbd_core_type *)udev;
409 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
410 switch(event)
411 {
412 case USBD_RESET_EVENT:
413
414 /* ...user code... */
415
416 break;
417 case USBD_SUSPEND_EVENT:
418 pkeyboard->hid_suspend_flag = 1;
419 /* ...user code... */
420
421 break;
422 case USBD_WAKEUP_EVENT:
423 /* ...user code... */
424
425 break;
426 default:
427 break;
428 }
429 return status;
430}
431
439 usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len)
440{
441 usb_sts_type status = USB_OK;
442 usbd_core_type *pudev = (usbd_core_type *)udev;
443
444 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
445 usbd_ept_send(pudev, USBD_KEYBOARD_IN_EPT, report, len);
446
447 return status;
448}
449
450
457void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
458{
459 uint8_t key_data = 0;
460 usbd_core_type *pudev = (usbd_core_type *)udev;
461 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
462
463 if(ascii_code > 128)
464 {
465 ascii_code = 0;
466 }
467 else
468 {
469 ascii_code = _asciimap[ascii_code];
470 if(!ascii_code)
471 {
472 ascii_code = 0;
473 }
474
475 if(ascii_code & SHIFT)
476 {
477 key_data = 0x2;
478 ascii_code &= 0x7F;
479 }
480 }
481
482 if((pkeyboard->temp == ascii_code) && (ascii_code != 0))
483 {
484 pkeyboard->keyboard_buf[0] = 0;
485 pkeyboard->keyboard_buf[2] = 0;
486 usb_keyboard_class_send_report(udev, pkeyboard->keyboard_buf, 8);
487 }
488 else
489 {
490 pkeyboard->keyboard_buf[0] = key_data;
491 pkeyboard->keyboard_buf[2] = ascii_code;
492 usb_keyboard_class_send_report(udev, pkeyboard->keyboard_buf, 8);
493 }
494}
495
496
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:77
USB_EPT_AUTO_MALLOC_BUFFER
#define USB_EPT_AUTO_MALLOC_BUFFER
auto malloc usb endpoint buffer
Definition: project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h:63
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
USBD_KEYBOARD_IN_MAXPACKET_SIZE
#define USBD_KEYBOARD_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: keyboard_class.h:58
USBD_KEYBOARD_IN_EPT
#define USBD_KEYBOARD_IN_EPT
usb hid use endpoint define
Definition: keyboard_class.h:53
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: keyboard_class.c:390
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: keyboard_class.c:358
keyboard_struct
keyboard_type keyboard_struct
Definition: keyboard_class.c:53
_asciimap
static const unsigned char _asciimap[128]
Definition: keyboard_class.c:55
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: keyboard_class.c:231
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: keyboard_class.c:248
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: keyboard_class.c:322
usb_hid_keyboard_send_char
void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
usb device class report function
Definition: keyboard_class.c:457
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: keyboard_class.c:336
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: keyboard_class.c:405
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: keyboard_class.c:208
usb_keyboard_class_send_report
usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: keyboard_class.c:439
keyboard_class_handler
usbd_class_handler keyboard_class_handler
Definition: keyboard_class.c:189
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: keyboard_class.c:378
SHIFT
#define SHIFT
Definition: keyboard_class.c:54
USBD_KEYBOARD_SIZ_REPORT_DESC
#define USBD_KEYBOARD_SIZ_REPORT_DESC
Definition: keyboard_desc.h:65
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:159
g_keyboard_usb_desc
uint8_t g_keyboard_usb_desc[9]
usb hid descriptor
Definition: keyboard_desc.c:201
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:461
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
keyboard_class.h
usb hid keyboard header file
keyboard_desc.h
usb keyboard descriptor header file
keyboard_type
Definition: keyboard_class.h:67
keyboard_type::keyboard_buf
uint8_t keyboard_buf[8]
Definition: keyboard_class.h:72
keyboard_type::hid_set_report
uint8_t hid_set_report[64]
Definition: keyboard_class.h:71
keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: keyboard_class.h:69
keyboard_type::alt_setting
uint32_t alt_setting
Definition: keyboard_class.h:70
keyboard_type::temp
uint8_t temp
Definition: keyboard_class.h:77
keyboard_type::hid_state
uint8_t hid_state
Definition: keyboard_class.h:76
keyboard_type::g_u8tx_completed
__IO uint8_t g_u8tx_completed
Definition: keyboard_class.h:75
keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: keyboard_class.h:68
keyboard_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: keyboard_class.h:74
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: keyboard_class.h Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __KEYBOARD_CLASS_H
29#define __KEYBOARD_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_KEYBOARD_IN_EPT 0x81
54
58#define USBD_KEYBOARD_IN_MAXPACKET_SIZE 0x40
59#define USBD_KEYBOARD_OUT_MAXPACKET_SIZE 0x40
60
66typedef struct
67{
68 uint32_t hid_protocol;
69 uint32_t hid_set_idle;
70 uint32_t alt_setting;
71 uint8_t hid_set_report[64];
72 uint8_t keyboard_buf[8];
73
74 __IO uint8_t hid_suspend_flag;
75 __IO uint8_t g_u8tx_completed;
76 uint8_t hid_state;
77 uint8_t temp;
78
79}keyboard_type;
80
84extern usbd_class_handler keyboard_class_handler;
85
86 usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len);
87void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code);
99#ifdef __cplusplus
100}
101#endif
102
103#endif
usb_hid_keyboard_send_char
void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
usb device class report function
Definition: keyboard_class.c:457
usb_keyboard_class_send_report
usb_sts_type usb_keyboard_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: keyboard_class.c:439
keyboard_class_handler
usbd_class_handler keyboard_class_handler
Definition: keyboard_class.c:189
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
keyboard_type
Definition: keyboard_class.h:67
keyboard_type::hid_set_idle
uint32_t hid_set_idle
Definition: keyboard_class.h:69
keyboard_type::alt_setting
uint32_t alt_setting
Definition: keyboard_class.h:70
keyboard_type::temp
uint8_t temp
Definition: keyboard_class.h:77
keyboard_type::hid_state
uint8_t hid_state
Definition: keyboard_class.h:76
keyboard_type::g_u8tx_completed
__IO uint8_t g_u8tx_completed
Definition: keyboard_class.h:75
keyboard_type::hid_protocol
uint32_t hid_protocol
Definition: keyboard_class.h:68
keyboard_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: keyboard_class.h:74
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: keyboard_desc.c Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "keyboard_desc.h"
30
44static usbd_desc_t *get_device_descriptor(void);
45static usbd_desc_t *get_device_qualifier(void);
46static usbd_desc_t *get_device_configuration(void);
47static usbd_desc_t *get_device_other_speed(void);
48static usbd_desc_t *get_device_lang_id(void);
49static usbd_desc_t *get_device_manufacturer_string(void);
50static usbd_desc_t *get_device_product_string(void);
51static usbd_desc_t *get_device_serial_string(void);
52static usbd_desc_t *get_device_interface_string(void);
53static usbd_desc_t *get_device_config_string(void);
54
55static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
56static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
57static void get_serial_num(void);
58static uint8_t g_usbd_desc_buffer[256];
59
63 usbd_desc_handler keyboard_desc_handler =
64{
65 get_device_descriptor,
66 get_device_qualifier,
67 get_device_configuration,
68 get_device_other_speed,
69 get_device_lang_id,
70 get_device_manufacturer_string,
71 get_device_product_string,
72 get_device_serial_string,
73 get_device_interface_string,
74 get_device_config_string,
75};
76
80#if defined ( __ICCARM__ ) /* iar compiler */
81 #pragma data_alignment=4
82#endif
83ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
84{
85 USB_DEVICE_DESC_LEN, /* bLength */
86 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
87 0x00, /* bcdUSB */
88 0x02,
89 0x00, /* bDeviceClass */
90 0x00, /* bDeviceSubClass */
91 0x00, /* bDeviceProtocol */
92 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
93 LBYTE(USBD_KEYBOARD_VENDOR_ID), /* idVendor */
94 HBYTE(USBD_KEYBOARD_VENDOR_ID), /* idVendor */
95 LBYTE(USBD_KEYBOARD_PRODUCT_ID), /* idProduct */
96 HBYTE(USBD_KEYBOARD_PRODUCT_ID), /* idProduct */
97 0x00, /* bcdDevice rel. 2.00 */
98 0x02,
99 USB_MFC_STRING, /* Index of manufacturer string */
100 USB_PRODUCT_STRING, /* Index of product string */
101 USB_SERIAL_STRING, /* Index of serial number string */
102 1 /* bNumConfigurations */
103};
104
108#if defined ( __ICCARM__ ) /* iar compiler */
109 #pragma data_alignment=4
110#endif
111ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_KEYBOARD_CONFIG_DESC_SIZE] ALIGNED_TAIL =
112{
113 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
114 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
115 LBYTE(USBD_KEYBOARD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 HBYTE(USBD_KEYBOARD_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 0x01, /* bNumInterfaces: 1 interface */
118 0x01, /* bConfigurationValue: configuration value */
119 0x00, /* iConfiguration: index of string descriptor describing
120 the configuration */
121 0xE0, /* bmAttributes: self powered and support remote wakeup*/
122 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
123
124 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
125 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
126 0x00, /* bInterfaceNumber: number of interface */
127 0x00, /* bAlternateSetting: alternate set */
128 0x01, /* bNumEndpoints: number of endpoints */
129 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
130 0x01, /* bInterfaceSubClass: subclass code */
131 0x01, /* bInterfaceProtocol: protocol code */
132 0x00, /* iInterface: index of string descriptor */
133
134 0x09, /* bLength: size of HID descriptor in bytes */
135 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
136 LBYTE(KEYBOARD_BCD_NUM),
137 HBYTE(KEYBOARD_BCD_NUM), /* bcdHID: HID class specification release number */
138 0x00, /* bCountryCode: hardware target conutry */
139 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
140 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
141 LBYTE(sizeof(g_usbd_keyboard_report)),
142 HBYTE(sizeof(g_usbd_keyboard_report)), /* wDescriptorLength: total length of reprot descriptor */
143
144 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
145 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
146 USBD_KEYBOARD_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
147 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
148 LBYTE(USBD_KEYBOARD_IN_MAXPACKET_SIZE),
149 HBYTE(USBD_KEYBOARD_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
150 KEYBOARD_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
151};
152
156#if defined ( __ICCARM__ ) /* iar compiler */
157 #pragma data_alignment=4
158#endif
159ALIGNED_HEAD uint8_t g_usbd_keyboard_report[USBD_KEYBOARD_SIZ_REPORT_DESC] ALIGNED_TAIL =
160{
161 0x05, 0x01, // USAGE_PAGE (Generic Desktop)
162 0x09, 0x06, // USAGE (Keyboard)
163 0xa1, 0x01, // COLLECTION (Application)
164 0x05, 0x07, // USAGE_PAGE (Keyboard)
165 0x19, 0xe0, // USAGE_MINIMUM (Keyboard LeftControl)
166 0x29, 0xe7, // USAGE_MAXIMUM (Keyboard Right GUI)
167 0x15, 0x00, // LOGICAL_MINIMUM (0)
168 0x25, 0x01, // LOGICAL_MAXIMUM (1)
169 0x75, 0x01, // REPORT_SIZE (1)
170 0x95, 0x08, // REPORT_COUNT (8)
171 0x81, 0x02, // INPUT (Data,Var,Abs)
172 0x95, 0x01, // REPORT_COUNT (1)
173 0x75, 0x08, // REPORT_SIZE (8)
174 0x81, 0x03, // INPUT (Cnst,Var,Abs)
175 0x95, 0x05, // REPORT_COUNT (5)
176 0x75, 0x01, // REPORT_SIZE (1)
177 0x05, 0x08, // USAGE_PAGE (LEDs)
178 0x19, 0x01, // USAGE_MINIMUM (Num Lock)
179 0x29, 0x05, // USAGE_MAXIMUM (Kana)
180 0x91, 0x02, // OUTPUT (Data,Var,Abs)
181 0x95, 0x01, // REPORT_COUNT (1)
182 0x75, 0x03, // REPORT_SIZE (3)
183 0x91, 0x03, // OUTPUT (Cnst,Var,Abs)
184 0x95, 0x06, // REPORT_COUNT (6)
185 0x75, 0x08, // REPORT_SIZE (8)
186 0x15, 0x00, // LOGICAL_MINIMUM (0)
187 0x25, 0xFF, // LOGICAL_MAXIMUM (255)
188 0x05, 0x07, // USAGE_PAGE (Keyboard)
189 0x19, 0x00, // USAGE_MINIMUM (Reserved (no event indicated))
190 0x29, 0x65, // USAGE_MAXIMUM (Keyboard Application)
191 0x81, 0x00, // INPUT (Data,Ary,Abs)
192 0xc0 // END_COLLECTION
193};
194
198#if defined ( __ICCARM__ ) /* iar compiler */
199 #pragma data_alignment=4
200#endif
201ALIGNED_HEAD uint8_t g_keyboard_usb_desc[9] ALIGNED_TAIL =
202{
203 0x09, /* bLength: size of HID descriptor in bytes */
204 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
205 LBYTE(KEYBOARD_BCD_NUM),
206 HBYTE(KEYBOARD_BCD_NUM), /* bcdHID: HID class specification release number */
207 0x00, /* bCountryCode: hardware target conutry */
208 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
209 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
210 LBYTE(sizeof(g_usbd_keyboard_report)),
211 HBYTE(sizeof(g_usbd_keyboard_report)), /* wDescriptorLength: total length of reprot descriptor */
212};
213
214
218#if defined ( __ICCARM__ ) /* iar compiler */
219 #pragma data_alignment=4
220#endif
221ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_KEYBOARD_SIZ_STRING_LANGID] ALIGNED_TAIL =
222{
223 USBD_KEYBOARD_SIZ_STRING_LANGID,
224 USB_DESCIPTOR_TYPE_STRING,
225 0x09,
226 0x04,
227};
228
232#if defined ( __ICCARM__ ) /* iar compiler */
233 #pragma data_alignment=4
234#endif
235ALIGNED_HEAD static uint8_t g_string_serial[USBD_KEYBOARD_SIZ_STRING_SERIAL] ALIGNED_TAIL =
236{
237 USBD_KEYBOARD_SIZ_STRING_SERIAL,
238 USB_DESCIPTOR_TYPE_STRING,
239};
240
241
242/* device descriptor */
243static usbd_desc_t device_descriptor =
244{
245 USB_DEVICE_DESC_LEN,
246 g_usbd_descriptor
247};
248
249/* config descriptor */
250static usbd_desc_t config_descriptor =
251{
252 USBD_KEYBOARD_CONFIG_DESC_SIZE,
253 g_usbd_configuration
254};
255
256/* langid descriptor */
257static usbd_desc_t langid_descriptor =
258{
259 USBD_KEYBOARD_SIZ_STRING_LANGID,
260 g_string_lang_id
261};
262
263/* serial descriptor */
264static usbd_desc_t serial_descriptor =
265{
266 USBD_KEYBOARD_SIZ_STRING_SERIAL,
267 g_string_serial
268};
269
270static usbd_desc_t vp_desc;
271
278static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
279{
280 uint16_t str_len = 0, id_pos = 2;
281 uint8_t *tmp_str = string;
282
283 while(*tmp_str != '\0')
284 {
285 str_len ++;
286 unicode_buf[id_pos ++] = *tmp_str ++;
287 unicode_buf[id_pos ++] = 0x00;
288 }
289
290 str_len = str_len * 2 + 2;
291 unicode_buf[0] = str_len;
292 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
293
294 return str_len;
295}
296
304static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
305{
306 uint8_t idx = 0;
307
308 for( idx = 0 ; idx < len ; idx ++)
309 {
310 if( ((value >> 28)) < 0xA )
311 {
312 pbuf[ 2 * idx] = (value >> 28) + '0';
313 }
314 else
315 {
316 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
317 }
318
319 value = value << 4;
320
321 pbuf[2 * idx + 1] = 0;
322 }
323}
324
330static void get_serial_num(void)
331{
332 uint32_t serial0, serial1, serial2;
333
334 serial0 = *(uint32_t*)MCU_ID1;
335 serial1 = *(uint32_t*)MCU_ID2;
336 serial2 = *(uint32_t*)MCU_ID3;
337
338 serial0 += serial2;
339
340 if (serial0 != 0)
341 {
342 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
343 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
344 }
345}
346
352static usbd_desc_t *get_device_descriptor(void)
353{
354 return &device_descriptor;
355}
356
362static usbd_desc_t * get_device_qualifier(void)
363{
364 return NULL;
365}
366
372static usbd_desc_t *get_device_configuration(void)
373{
374 return &config_descriptor;
375}
376
382static usbd_desc_t *get_device_other_speed(void)
383{
384 return NULL;
385}
386
392static usbd_desc_t *get_device_lang_id(void)
393{
394 return &langid_descriptor;
395}
396
397
403static usbd_desc_t *get_device_manufacturer_string(void)
404{
405 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
406 vp_desc.descriptor = g_usbd_desc_buffer;
407 return &vp_desc;
408}
409
415static usbd_desc_t *get_device_product_string(void)
416{
417 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
418 vp_desc.descriptor = g_usbd_desc_buffer;
419 return &vp_desc;
420}
421
427static usbd_desc_t *get_device_serial_string(void)
428{
429 get_serial_num();
430 return &serial_descriptor;
431}
432
438static usbd_desc_t *get_device_interface_string(void)
439{
440 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
441 vp_desc.descriptor = g_usbd_desc_buffer;
442 return &vp_desc;
443}
444
450static usbd_desc_t *get_device_config_string(void)
451{
452 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_KEYBOARD_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
453 vp_desc.descriptor = g_usbd_desc_buffer;
454 return &vp_desc;
455}
456
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
USBD_KEYBOARD_IN_MAXPACKET_SIZE
#define USBD_KEYBOARD_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: keyboard_class.h:58
USBD_KEYBOARD_IN_EPT
#define USBD_KEYBOARD_IN_EPT
usb hid use endpoint define
Definition: keyboard_class.h:53
USBD_KEYBOARD_VENDOR_ID
#define USBD_KEYBOARD_VENDOR_ID
usb vendor id and product id define
Definition: keyboard_desc.h:58
USBD_KEYBOARD_DESC_CONFIGURATION_STRING
#define USBD_KEYBOARD_DESC_CONFIGURATION_STRING
Definition: keyboard_desc.h:74
USBD_KEYBOARD_CONFIG_DESC_SIZE
#define USBD_KEYBOARD_CONFIG_DESC_SIZE
usb descriptor size define
Definition: keyboard_desc.h:64
USBD_KEYBOARD_SIZ_STRING_LANGID
#define USBD_KEYBOARD_SIZ_STRING_LANGID
Definition: keyboard_desc.h:66
USBD_KEYBOARD_DESC_MANUFACTURER_STRING
#define USBD_KEYBOARD_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: keyboard_desc.h:72
USBD_KEYBOARD_SIZ_REPORT_DESC
#define USBD_KEYBOARD_SIZ_REPORT_DESC
Definition: keyboard_desc.h:65
KEYBOARD_BCD_NUM
#define KEYBOARD_BCD_NUM
usb bcd number define
Definition: keyboard_desc.h:53
KEYBOARD_BINTERVAL_TIME
#define KEYBOARD_BINTERVAL_TIME
usb hid endpoint interval define
Definition: keyboard_desc.h:80
USBD_KEYBOARD_DESC_PRODUCT_STRING
#define USBD_KEYBOARD_DESC_PRODUCT_STRING
Definition: keyboard_desc.h:73
USBD_KEYBOARD_SIZ_STRING_SERIAL
#define USBD_KEYBOARD_SIZ_STRING_SERIAL
Definition: keyboard_desc.h:67
USBD_KEYBOARD_PRODUCT_ID
#define USBD_KEYBOARD_PRODUCT_ID
Definition: keyboard_desc.h:59
USBD_KEYBOARD_DESC_INTERFACE_STRING
#define USBD_KEYBOARD_DESC_INTERFACE_STRING
Definition: keyboard_desc.h:75
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: keyboard_desc.c:264
device_descriptor
static usbd_desc_t device_descriptor
Definition: keyboard_desc.c:243
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: keyboard_desc.c:372
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: keyboard_desc.c:257
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: keyboard_desc.c:352
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: keyboard_desc.c:403
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: keyboard_desc.c:362
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: keyboard_desc.c:438
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:159
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: keyboard_desc.c:58
vp_desc
static usbd_desc_t vp_desc
Definition: keyboard_desc.c:270
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: keyboard_desc.c:382
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: keyboard_desc.c:83
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: keyboard_desc.c:415
keyboard_desc_handler
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure
Definition: keyboard_desc.c:63
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: keyboard_desc.c:450
g_keyboard_usb_desc
uint8_t g_keyboard_usb_desc[9]
usb hid descriptor
Definition: keyboard_desc.c:201
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: keyboard_desc.c:278
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: keyboard_desc.c:392
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: keyboard_desc.c:330
config_descriptor
static usbd_desc_t config_descriptor
Definition: keyboard_desc.c:250
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: keyboard_desc.c:427
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: keyboard_desc.c:304
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
keyboard_desc.h
usb keyboard descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: keyboard_desc.h Source File

  • middlewares
  • usbd_class
  • keyboard
keyboard_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __KEYBOARD_DESC_H
29#define __KEYBOARD_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "keyboard_class.h"
36#include "usbd_core.h"
37
53#define KEYBOARD_BCD_NUM 0x0110
54
58#define USBD_KEYBOARD_VENDOR_ID 0x2E3C
59#define USBD_KEYBOARD_PRODUCT_ID 0x6040
60
64#define USBD_KEYBOARD_CONFIG_DESC_SIZE 34
65#define USBD_KEYBOARD_SIZ_REPORT_DESC 63
66#define USBD_KEYBOARD_SIZ_STRING_LANGID 4
67#define USBD_KEYBOARD_SIZ_STRING_SERIAL 0x1A
68
72#define USBD_KEYBOARD_DESC_MANUFACTURER_STRING "Artery"
73#define USBD_KEYBOARD_DESC_PRODUCT_STRING "Keyboard"
74#define USBD_KEYBOARD_DESC_CONFIGURATION_STRING "Keyboard Config"
75#define USBD_KEYBOARD_DESC_INTERFACE_STRING "Keyboard Interface"
76
80#define KEYBOARD_BINTERVAL_TIME 0x0A
81
85#define MCU_ID1 (0x1FFFF7E8)
86#define MCU_ID2 (0x1FFFF7EC)
87#define MCU_ID3 (0x1FFFF7F0)
88
92extern uint8_t g_usbd_keyboard_report[USBD_KEYBOARD_SIZ_REPORT_DESC];
93extern uint8_t g_keyboard_usb_desc[9];
94extern usbd_desc_handler keyboard_desc_handler;
95
103#ifdef __cplusplus
104}
105#endif
106
107#endif
108
109
USBD_KEYBOARD_SIZ_REPORT_DESC
#define USBD_KEYBOARD_SIZ_REPORT_DESC
Definition: keyboard_desc.h:65
g_usbd_keyboard_report
uint8_t g_usbd_keyboard_report[63]
usb mouse report descriptor
Definition: keyboard_desc.c:159
g_keyboard_usb_desc
uint8_t g_keyboard_usb_desc[9]
usb hid descriptor
Definition: keyboard_desc.c:201
keyboard_desc_handler
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure
Definition: keyboard_desc.c:63
keyboard_class.h
usb hid keyboard header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: main_page.h Source File

  • main_page
main_page.h
Go to the documentation of this file.
1


AT32F413 Firmwary Library: mouse_class.c Source File

  • middlewares
  • usbd_class
  • mouse
mouse_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "mouse_class.h"
28#include "mouse_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53 mouse_type mouse_struct;
54
55/* usb device class handler */
56 usbd_class_handler mouse_class_handler =
57{
58 class_init_handler,
59 class_clear_handler,
60 class_setup_handler,
61 class_ept0_tx_handler,
62 class_ept0_rx_handler,
63 class_in_handler,
64 class_out_handler,
65 class_sof_handler,
66 class_event_handler,
67 &mouse_struct
68};
69
75static usb_sts_type class_init_handler(void *udev)
76{
77 usb_sts_type status = USB_OK;
78 usbd_core_type *pudev = (usbd_core_type *)udev;
79
80#ifndef USB_EPT_AUTO_MALLOC_BUFFER
81 /* use user define buffer address */
82 usbd_ept_buf_custom_define(pudev, USBD_MOUSE_IN_EPT, EPT1_TX_ADDR);
83#endif
84
85 /* open hid in endpoint */
86 usbd_ept_open(pudev, USBD_MOUSE_IN_EPT, EPT_INT_TYPE, USBD_MOUSE_IN_MAXPACKET_SIZE);
87
88 return status;
89}
90
96static usb_sts_type class_clear_handler(void *udev)
97{
98 usb_sts_type status = USB_OK;
99 usbd_core_type *pudev = (usbd_core_type *)udev;
100
101 /* close hid in endpoint */
102 usbd_ept_close(pudev, USBD_MOUSE_IN_EPT);
103
104 return status;
105}
106
113static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
114{
115 usb_sts_type status = USB_OK;
116 usbd_core_type *pudev = (usbd_core_type *)udev;
117 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
118 uint16_t len;
119 uint8_t *buf;
120
121 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
122 {
123 /* class request */
124 case USB_REQ_TYPE_CLASS:
125 switch(setup->bRequest)
126 {
127 case HID_REQ_SET_PROTOCOL:
128 pmouse->hid_protocol = (uint8_t)setup->wValue;
129 break;
130 case HID_REQ_GET_PROTOCOL:
131 usbd_ctrl_send(pudev, (uint8_t *)&pmouse->hid_protocol, 1);
132 break;
133 case HID_REQ_SET_IDLE:
134 pmouse->hid_set_idle = (uint8_t)(setup->wValue >> 8);
135 break;
136 case HID_REQ_GET_IDLE:
137 usbd_ctrl_send(pudev, (uint8_t *)&pmouse->hid_set_idle, 1);
138 break;
139 case HID_REQ_SET_REPORT:
140 pmouse->hid_state = HID_REQ_SET_REPORT;
141 usbd_ctrl_recv(pudev, pmouse->hid_set_report, setup->wLength);
142 break;
143 default:
144 usbd_ctrl_unsupport(pudev);
145 break;
146 }
147 break;
148 /* standard request */
149 case USB_REQ_TYPE_STANDARD:
150 switch(setup->bRequest)
151 {
152 case USB_STD_REQ_GET_DESCRIPTOR:
153 if(setup->wValue >> 8 == HID_REPORT_DESC)
154 {
155 len = MIN(USBD_MOUSE_SIZ_REPORT_DESC, setup->wLength);
156 buf = (uint8_t *)g_usbd_mouse_report;
157 }
158 else if(setup->wValue >> 8 == HID_DESCRIPTOR_TYPE)
159 {
160 len = MIN(9, setup->wLength);
161 buf = (uint8_t *)g_mouse_usb_desc;
162 }
163 usbd_ctrl_send(pudev, (uint8_t *)buf, len);
164 break;
165 case USB_STD_REQ_GET_INTERFACE:
166 usbd_ctrl_send(pudev, (uint8_t *)&pmouse->alt_setting, 1);
167 break;
168 case USB_STD_REQ_SET_INTERFACE:
169 pmouse->alt_setting = setup->wValue;
170 break;
171 default:
172 usbd_ctrl_unsupport(pudev);
173 break;
174 }
175 break;
176 default:
177 usbd_ctrl_unsupport(pudev);
178 break;
179 }
180 return status;
181}
182
188static usb_sts_type class_ept0_tx_handler(void *udev)
189{
190 usb_sts_type status = USB_OK;
191
192 /* ...user code... */
193
194 return status;
195}
196
202static usb_sts_type class_ept0_rx_handler(void *udev)
203{
204 usb_sts_type status = USB_OK;
205 usbd_core_type *pudev = (usbd_core_type *)udev;
206 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
207 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
208 /* ...user code... */
209 if( pmouse->hid_state == HID_REQ_SET_REPORT)
210 {
211 /* hid buffer process */
212 pmouse->hid_state = 0;
213 }
214
215 return status;
216}
217
224static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
225{
226 usb_sts_type status = USB_OK;
227
228 /* ...user code...
229 trans next packet data
230 */
231
232 return status;
233}
234
241static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
242{
243 usb_sts_type status = USB_OK;
244
245 return status;
246}
247
253static usb_sts_type class_sof_handler(void *udev)
254{
255 usb_sts_type status = USB_OK;
256
257 /* ...user code... */
258
259 return status;
260}
261
268static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
269{
270 usb_sts_type status = USB_OK;
271 usbd_core_type *pudev = (usbd_core_type *)udev;
272 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
273 switch(event)
274 {
275 case USBD_RESET_EVENT:
276
277 /* ...user code... */
278
279 break;
280 case USBD_SUSPEND_EVENT:
281 pmouse->hid_suspend_flag = 1;
282 /* ...user code... */
283
284 break;
285 case USBD_WAKEUP_EVENT:
286 /* ...user code... */
287
288 break;
289 default:
290 break;
291 }
292 return status;
293}
294
302 usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len)
303{
304 usb_sts_type status = USB_OK;
305 usbd_core_type *pudev = (usbd_core_type *)udev;
306
307 if(usbd_connect_state_get(pudev) == USB_CONN_STATE_CONFIGURED)
308 usbd_ept_send(pudev, USBD_MOUSE_IN_EPT, report, len);
309
310 return status;
311}
312
319void usb_hid_mouse_send(void *udev, uint8_t op)
320{
321 usbd_core_type *pudev = (usbd_core_type *)udev;
322 mouse_type *pmouse = (mouse_type *)pudev->class_handler->pdata;
323 int8_t posx = 0, posy = 0, button = 0;
324 switch(op)
325 {
326 case LEFT_BUTTON:
327 button = 0x01;
328 break;
329
330 case RIGHT_BUTTON:
331 button = 0x2;
332 break;
333
334 case UP_MOVE:
335 posy -= MOVE_STEP;
336 break;
337
338 case DOWN_MOVE:
339 posy += MOVE_STEP;
340 break;
341
342 case LEFT_MOVE:
343 posx -= MOVE_STEP;
344 break;
345
346 case RIGHT_MOVE:
347 posx += MOVE_STEP;
348 break;
349
350 default:
351 break;
352 }
353 pmouse->mouse_buffer[0] = button;
354 pmouse->mouse_buffer[1] = posx;
355 pmouse->mouse_buffer[2] = posy;
356
357 usb_mouse_class_send_report(udev, pmouse->mouse_buffer, 4);
358}
359
EPT1_TX_ADDR
#define EPT1_TX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:77
EPT_INT_TYPE
@ EPT_INT_TYPE
Definition: at32f413_usb.h:205
USBD_MOUSE_IN_EPT
#define USBD_MOUSE_IN_EPT
usb hid use endpoint define
Definition: mouse_class.h:53
USBD_MOUSE_IN_MAXPACKET_SIZE
#define USBD_MOUSE_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: mouse_class.h:58
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device class sof handler
Definition: mouse_class.c:253
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device class transmision complete handler
Definition: mouse_class.c:224
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: mouse_class.c:96
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: mouse_class.c:113
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device class endpoint 0 in status stage complete
Definition: mouse_class.c:188
usb_mouse_class_send_report
usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: mouse_class.c:302
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device class endpoint 0 out status stage complete
Definition: mouse_class.c:202
mouse_struct
mouse_type mouse_struct
Definition: mouse_class.c:53
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device class event handler
Definition: mouse_class.c:268
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: mouse_class.c:75
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device class endpoint receive data
Definition: mouse_class.c:241
mouse_class_handler
usbd_class_handler mouse_class_handler
Definition: mouse_class.c:56
usb_hid_mouse_send
void usb_hid_mouse_send(void *udev, uint8_t op)
usb device class report function
Definition: mouse_class.c:319
MOVE_STEP
#define MOVE_STEP
usb hid mouse operation
Definition: mouse_class.h:72
LEFT_MOVE
#define LEFT_MOVE
Definition: mouse_class.h:77
DOWN_MOVE
#define DOWN_MOVE
Definition: mouse_class.h:80
RIGHT_MOVE
#define RIGHT_MOVE
Definition: mouse_class.h:78
LEFT_BUTTON
#define LEFT_BUTTON
Definition: mouse_class.h:75
RIGHT_BUTTON
#define RIGHT_BUTTON
Definition: mouse_class.h:76
UP_MOVE
#define UP_MOVE
Definition: mouse_class.h:79
USBD_MOUSE_SIZ_REPORT_DESC
#define USBD_MOUSE_SIZ_REPORT_DESC
Definition: mouse_desc.h:65
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:159
g_mouse_usb_desc
uint8_t g_mouse_usb_desc[9]
usb hid descriptor
Definition: mouse_desc.c:215
HID_DESCRIPTOR_TYPE
#define HID_DESCRIPTOR_TYPE
Definition: usb_std.h:236
HID_REQ_GET_PROTOCOL
#define HID_REQ_GET_PROTOCOL
Definition: usb_std.h:231
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
HID_REQ_SET_PROTOCOL
#define HID_REQ_SET_PROTOCOL
usb hid class request code define
Definition: usb_std.h:230
HID_REPORT_DESC
#define HID_REPORT_DESC
Definition: usb_std.h:237
HID_REQ_SET_IDLE
#define HID_REQ_SET_IDLE
Definition: usb_std.h:232
HID_REQ_GET_IDLE
#define HID_REQ_GET_IDLE
Definition: usb_std.h:233
HID_REQ_SET_REPORT
#define HID_REQ_SET_REPORT
Definition: usb_std.h:234
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:461
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
mouse_class.h
usb hid mouse header file
mouse_desc.h
usb mouse descriptor header file
mouse_type
Definition: mouse_class.h:83
mouse_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: mouse_class.h:91
mouse_type::hid_protocol
uint32_t hid_protocol
Definition: mouse_class.h:84
mouse_type::hid_set_idle
uint32_t hid_set_idle
Definition: mouse_class.h:85
mouse_type::mouse_buffer
uint8_t mouse_buffer[4]
Definition: mouse_class.h:89
mouse_type::hid_set_report
uint8_t hid_set_report[64]
Definition: mouse_class.h:88
mouse_type::alt_setting
uint32_t alt_setting
Definition: mouse_class.h:86
mouse_type::hid_state
uint8_t hid_state
Definition: mouse_class.h:90
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: mouse_class.h Source File

  • middlewares
  • usbd_class
  • mouse
mouse_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __MOUSE_CLASS_H
29#define __MOUSE_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
53#define USBD_MOUSE_IN_EPT 0x81
54
58#define USBD_MOUSE_IN_MAXPACKET_SIZE 0x40
59
72#define MOVE_STEP 20
73
74#define BUTTON_RELEASE 0
75#define LEFT_BUTTON 1
76#define RIGHT_BUTTON 2
77#define LEFT_MOVE 3
78#define RIGHT_MOVE 4
79#define UP_MOVE 5
80#define DOWN_MOVE 6
81
82typedef struct
83{
84 uint32_t hid_protocol;
85 uint32_t hid_set_idle;
86 uint32_t alt_setting;
87
88 uint8_t hid_set_report[64];
89 uint8_t mouse_buffer[4];
90 uint8_t hid_state;
91 __IO uint8_t hid_suspend_flag;
92}mouse_type;
93
101extern usbd_class_handler mouse_class_handler;
102 usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len);
103void usb_hid_mouse_send(void *udev, uint8_t op);
115#ifdef __cplusplus
116}
117#endif
118
119#endif
usb_mouse_class_send_report
usb_sts_type usb_mouse_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: mouse_class.c:302
mouse_class_handler
usbd_class_handler mouse_class_handler
Definition: mouse_class.c:56
usb_hid_mouse_send
void usb_hid_mouse_send(void *udev, uint8_t op)
usb device class report function
Definition: mouse_class.c:319
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
mouse_type
Definition: mouse_class.h:83
mouse_type::hid_suspend_flag
__IO uint8_t hid_suspend_flag
Definition: mouse_class.h:91
mouse_type::hid_protocol
uint32_t hid_protocol
Definition: mouse_class.h:84
mouse_type::hid_set_idle
uint32_t hid_set_idle
Definition: mouse_class.h:85
mouse_type::alt_setting
uint32_t alt_setting
Definition: mouse_class.h:86
mouse_type::hid_state
uint8_t hid_state
Definition: mouse_class.h:90
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: mouse_desc.c Source File

  • middlewares
  • usbd_class
  • mouse
mouse_desc.c
Go to the documentation of this file.
1
26#include "usb_std.h"
27#include "usbd_sdr.h"
28#include "usbd_core.h"
29#include "mouse_desc.h"
30
44static usbd_desc_t *get_device_descriptor(void);
45static usbd_desc_t *get_device_qualifier(void);
46static usbd_desc_t *get_device_configuration(void);
47static usbd_desc_t *get_device_other_speed(void);
48static usbd_desc_t *get_device_lang_id(void);
49static usbd_desc_t *get_device_manufacturer_string(void);
50static usbd_desc_t *get_device_product_string(void);
51static usbd_desc_t *get_device_serial_string(void);
52static usbd_desc_t *get_device_interface_string(void);
53static usbd_desc_t *get_device_config_string(void);
54
55static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
56static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
57static void get_serial_num(void);
58static uint8_t g_usbd_desc_buffer[256];
59
63 usbd_desc_handler mouse_desc_handler =
64{
65 get_device_descriptor,
66 get_device_qualifier,
67 get_device_configuration,
68 get_device_other_speed,
69 get_device_lang_id,
70 get_device_manufacturer_string,
71 get_device_product_string,
72 get_device_serial_string,
73 get_device_interface_string,
74 get_device_config_string,
75};
76
80#if defined ( __ICCARM__ ) /* iar compiler */
81 #pragma data_alignment=4
82#endif
83ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
84{
85 USB_DEVICE_DESC_LEN, /* bLength */
86 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
87 0x00, /* bcdUSB */
88 0x02,
89 0x00, /* bDeviceClass */
90 0x00, /* bDeviceSubClass */
91 0x00, /* bDeviceProtocol */
92 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
93 LBYTE(USBD_MOUSE_VENDOR_ID), /* idVendor */
94 HBYTE(USBD_MOUSE_VENDOR_ID), /* idVendor */
95 LBYTE(USBD_MOUSE_PRODUCT_ID), /* idProduct */
96 HBYTE(USBD_MOUSE_PRODUCT_ID), /* idProduct */
97 0x00, /* bcdDevice rel. 2.00 */
98 0x02,
99 USB_MFC_STRING, /* Index of manufacturer string */
100 USB_PRODUCT_STRING, /* Index of product string */
101 USB_SERIAL_STRING, /* Index of serial number string */
102 1 /* bNumConfigurations */
103};
104
108#if defined ( __ICCARM__ ) /* iar compiler */
109 #pragma data_alignment=4
110#endif
111ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_MOUSE_CONFIG_DESC_SIZE] ALIGNED_TAIL =
112{
113 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
114 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
115 LBYTE(USBD_MOUSE_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
116 HBYTE(USBD_MOUSE_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 0x01, /* bNumInterfaces: 1 interface */
118 0x01, /* bConfigurationValue: configuration value */
119 0x00, /* iConfiguration: index of string descriptor describing
120 the configuration */
121 0xE0, /* bmAttributes: self powered and support remote wakeup*/
122 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
123
124 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
125 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
126 0x00, /* bInterfaceNumber: number of interface */
127 0x00, /* bAlternateSetting: alternate set */
128 0x01, /* bNumEndpoints: number of endpoints */
129 USB_CLASS_CODE_HID, /* bInterfaceClass: class code hid */
130 0x01, /* bInterfaceSubClass: subclass code */
131 0x02, /* bInterfaceProtocol: protocol code */
132 0x00, /* iInterface: index of string descriptor */
133
134 0x09, /* bLength: size of HID descriptor in bytes */
135 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
136 LBYTE(MOUSE_BCD_NUM),
137 HBYTE(MOUSE_BCD_NUM), /* bcdHID: HID class specification release number */
138 0x00, /* bCountryCode: hardware target conutry */
139 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
140 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
141 LBYTE(sizeof(g_usbd_mouse_report)),
142 HBYTE(sizeof(g_usbd_mouse_report)), /* wDescriptorLength: total length of reprot descriptor */
143
144 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
145 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
146 USBD_MOUSE_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
147 USB_EPT_DESC_INTERRUPT, /* bmAttributes: endpoint attributes */
148 LBYTE(USBD_MOUSE_IN_MAXPACKET_SIZE),
149 HBYTE(USBD_MOUSE_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
150 MOUSE_BINTERVAL_TIME, /* bInterval: interval for polling endpoint for data transfers */
151};
152
156#if defined ( __ICCARM__ ) /* iar compiler */
157 #pragma data_alignment=4
158#endif
159ALIGNED_HEAD uint8_t g_usbd_mouse_report[USBD_MOUSE_SIZ_REPORT_DESC] ALIGNED_TAIL =
160{
161 0x05,0x01,
162 0x09,0x02,
163 0xA1,0x01,
164 0x09,0x01,
165
166 0xA1,0x00,
167 0x05,0x09,
168 0x19,0x01,
169 0x29,0x03,
170
171 0x15,0x00,
172 0x25,0x01,
173 0x95,0x03,
174 0x75,0x01,
175
176 0x81,0x02,
177 0x95,0x01,
178 0x75,0x05,
179 0x81,0x01,
180
181 0x05,0x01,
182 0x09,0x30,
183 0x09,0x31,
184 0x09,0x38,
185
186 0x15,0x81,
187 0x25,0x7F,
188 0x75,0x08,
189 0x95,0x03,
190
191 0x81,0x06,
192 0xC0,0x09,
193 0x3c,0x05,
194 0xff,0x09,
195
196 0x01,0x15,
197 0x00,0x25,
198 0x01,0x75,
199 0x01,0x95,
200
201 0x02,0xb1,
202 0x22,0x75,
203 0x06,0x95,
204 0x01,0xb1,
205
206 0x01,0xc0
207};
208
212#if defined ( __ICCARM__ ) /* iar compiler */
213 #pragma data_alignment=4
214#endif
215ALIGNED_HEAD uint8_t g_mouse_usb_desc[9] ALIGNED_TAIL =
216{
217 0x09, /* bLength: size of HID descriptor in bytes */
218 HID_CLASS_DESC_HID, /* bDescriptorType: HID descriptor type */
219 LBYTE(MOUSE_BCD_NUM),
220 HBYTE(MOUSE_BCD_NUM), /* bcdHID: HID class specification release number */
221 0x00, /* bCountryCode: hardware target conutry */
222 0x01, /* bNumDescriptors: number of HID class descriptor to follow */
223 HID_CLASS_DESC_REPORT, /* bDescriptorType: report descriptor type */
224 LBYTE(sizeof(g_usbd_mouse_report)),
225 HBYTE(sizeof(g_usbd_mouse_report)), /* wDescriptorLength: total length of reprot descriptor */
226};
227
228
232#if defined ( __ICCARM__ ) /* iar compiler */
233 #pragma data_alignment=4
234#endif
235ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_MOUSE_SIZ_STRING_LANGID] ALIGNED_TAIL =
236{
237 USBD_MOUSE_SIZ_STRING_LANGID,
238 USB_DESCIPTOR_TYPE_STRING,
239 0x09,
240 0x04,
241};
242
246#if defined ( __ICCARM__ ) /* iar compiler */
247 #pragma data_alignment=4
248#endif
249ALIGNED_HEAD static uint8_t g_string_serial[USBD_MOUSE_SIZ_STRING_SERIAL] ALIGNED_TAIL =
250{
251 USBD_MOUSE_SIZ_STRING_SERIAL,
252 USB_DESCIPTOR_TYPE_STRING,
253};
254
255
256/* device descriptor */
257static usbd_desc_t device_descriptor =
258{
259 USB_DEVICE_DESC_LEN,
260 g_usbd_descriptor
261};
262
263/* config descriptor */
264static usbd_desc_t config_descriptor =
265{
266 USBD_MOUSE_CONFIG_DESC_SIZE,
267 g_usbd_configuration
268};
269
270/* langid descriptor */
271static usbd_desc_t langid_descriptor =
272{
273 USBD_MOUSE_SIZ_STRING_LANGID,
274 g_string_lang_id
275};
276
277/* serial descriptor */
278static usbd_desc_t serial_descriptor =
279{
280 USBD_MOUSE_SIZ_STRING_SERIAL,
281 g_string_serial
282};
283
284static usbd_desc_t vp_desc;
285
292static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
293{
294 uint16_t str_len = 0, id_pos = 2;
295 uint8_t *tmp_str = string;
296
297 while(*tmp_str != '\0')
298 {
299 str_len ++;
300 unicode_buf[id_pos ++] = *tmp_str ++;
301 unicode_buf[id_pos ++] = 0x00;
302 }
303
304 str_len = str_len * 2 + 2;
305 unicode_buf[0] = str_len;
306 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
307
308 return str_len;
309}
310
318static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
319{
320 uint8_t idx = 0;
321
322 for( idx = 0 ; idx < len ; idx ++)
323 {
324 if( ((value >> 28)) < 0xA )
325 {
326 pbuf[ 2 * idx] = (value >> 28) + '0';
327 }
328 else
329 {
330 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
331 }
332
333 value = value << 4;
334
335 pbuf[2 * idx + 1] = 0;
336 }
337}
338
344static void get_serial_num(void)
345{
346 uint32_t serial0, serial1, serial2;
347
348 serial0 = *(uint32_t*)MCU_ID1;
349 serial1 = *(uint32_t*)MCU_ID2;
350 serial2 = *(uint32_t*)MCU_ID3;
351
352 serial0 += serial2;
353
354 if (serial0 != 0)
355 {
356 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
357 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
358 }
359}
360
366static usbd_desc_t *get_device_descriptor(void)
367{
368 return &device_descriptor;
369}
370
376static usbd_desc_t * get_device_qualifier(void)
377{
378 return NULL;
379}
380
386static usbd_desc_t *get_device_configuration(void)
387{
388 return &config_descriptor;
389}
390
396static usbd_desc_t *get_device_other_speed(void)
397{
398 return NULL;
399}
400
406static usbd_desc_t *get_device_lang_id(void)
407{
408 return &langid_descriptor;
409}
410
411
417static usbd_desc_t *get_device_manufacturer_string(void)
418{
419 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
420 vp_desc.descriptor = g_usbd_desc_buffer;
421 return &vp_desc;
422}
423
429static usbd_desc_t *get_device_product_string(void)
430{
431 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
432 vp_desc.descriptor = g_usbd_desc_buffer;
433 return &vp_desc;
434}
435
441static usbd_desc_t *get_device_serial_string(void)
442{
443 get_serial_num();
444 return &serial_descriptor;
445}
446
452static usbd_desc_t *get_device_interface_string(void)
453{
454 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
455 vp_desc.descriptor = g_usbd_desc_buffer;
456 return &vp_desc;
457}
458
464static usbd_desc_t *get_device_config_string(void)
465{
466 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MOUSE_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
467 vp_desc.descriptor = g_usbd_desc_buffer;
468 return &vp_desc;
469}
470
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
HID_CLASS_DESC_HID
#define HID_CLASS_DESC_HID
usb hid class descriptor define
Definition: audio_hid_desc.h:215
HID_CLASS_DESC_REPORT
#define HID_CLASS_DESC_REPORT
Definition: audio_hid_desc.h:216
USBD_MOUSE_IN_EPT
#define USBD_MOUSE_IN_EPT
usb hid use endpoint define
Definition: mouse_class.h:53
USBD_MOUSE_IN_MAXPACKET_SIZE
#define USBD_MOUSE_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: mouse_class.h:58
USBD_MOUSE_DESC_INTERFACE_STRING
#define USBD_MOUSE_DESC_INTERFACE_STRING
Definition: mouse_desc.h:75
USBD_MOUSE_SIZ_REPORT_DESC
#define USBD_MOUSE_SIZ_REPORT_DESC
Definition: mouse_desc.h:65
USBD_MOUSE_DESC_CONFIGURATION_STRING
#define USBD_MOUSE_DESC_CONFIGURATION_STRING
Definition: mouse_desc.h:74
USBD_MOUSE_SIZ_STRING_LANGID
#define USBD_MOUSE_SIZ_STRING_LANGID
Definition: mouse_desc.h:66
USBD_MOUSE_VENDOR_ID
#define USBD_MOUSE_VENDOR_ID
usb vendor id and product id define
Definition: mouse_desc.h:58
USBD_MOUSE_CONFIG_DESC_SIZE
#define USBD_MOUSE_CONFIG_DESC_SIZE
usb descriptor size define
Definition: mouse_desc.h:64
MOUSE_BINTERVAL_TIME
#define MOUSE_BINTERVAL_TIME
usb hid endpoint interval define
Definition: mouse_desc.h:80
USBD_MOUSE_PRODUCT_ID
#define USBD_MOUSE_PRODUCT_ID
Definition: mouse_desc.h:59
USBD_MOUSE_DESC_PRODUCT_STRING
#define USBD_MOUSE_DESC_PRODUCT_STRING
Definition: mouse_desc.h:73
USBD_MOUSE_SIZ_STRING_SERIAL
#define USBD_MOUSE_SIZ_STRING_SERIAL
Definition: mouse_desc.h:67
USBD_MOUSE_DESC_MANUFACTURER_STRING
#define USBD_MOUSE_DESC_MANUFACTURER_STRING
usb string define(vendor, product configuration, interface)
Definition: mouse_desc.h:72
MOUSE_BCD_NUM
#define MOUSE_BCD_NUM
usb bcd number define
Definition: mouse_desc.h:53
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: mouse_desc.c:278
device_descriptor
static usbd_desc_t device_descriptor
Definition: mouse_desc.c:257
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: mouse_desc.c:386
mouse_desc_handler
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure
Definition: mouse_desc.c:63
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: mouse_desc.c:271
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: mouse_desc.c:366
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: mouse_desc.c:417
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: mouse_desc.c:376
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: mouse_desc.c:452
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: mouse_desc.c:58
vp_desc
static usbd_desc_t vp_desc
Definition: mouse_desc.c:284
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: mouse_desc.c:396
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: mouse_desc.c:83
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: mouse_desc.c:429
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:159
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: mouse_desc.c:464
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: mouse_desc.c:292
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: mouse_desc.c:406
g_mouse_usb_desc
uint8_t g_mouse_usb_desc[9]
usb hid descriptor
Definition: mouse_desc.c:215
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: mouse_desc.c:344
config_descriptor
static usbd_desc_t config_descriptor
Definition: mouse_desc.c:264
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: mouse_desc.c:441
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: mouse_desc.c:318
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_EPT_DESC_INTERRUPT
#define USB_EPT_DESC_INTERRUPT
Definition: usb_std.h:178
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
USB_CLASS_CODE_HID
#define USB_CLASS_CODE_HID
Definition: usb_std.h:163
mouse_desc.h
usb mouse descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: mouse_desc.h Source File

  • middlewares
  • usbd_class
  • mouse
mouse_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __MOUSE_DESC_H
29#define __MOUSE_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "mouse_class.h"
36#include "usbd_core.h"
37
53#define MOUSE_BCD_NUM 0x0110
54
58#define USBD_MOUSE_VENDOR_ID 0x2E3C
59#define USBD_MOUSE_PRODUCT_ID 0x5710
60
64#define USBD_MOUSE_CONFIG_DESC_SIZE 34
65#define USBD_MOUSE_SIZ_REPORT_DESC 74
66#define USBD_MOUSE_SIZ_STRING_LANGID 4
67#define USBD_MOUSE_SIZ_STRING_SERIAL 0x1A
68
72#define USBD_MOUSE_DESC_MANUFACTURER_STRING "Artery"
73#define USBD_MOUSE_DESC_PRODUCT_STRING "Mouse"
74#define USBD_MOUSE_DESC_CONFIGURATION_STRING "Mouse Config"
75#define USBD_MOUSE_DESC_INTERFACE_STRING "Mouse Interface"
76
80#define MOUSE_BINTERVAL_TIME 0x0A
81
85#define MCU_ID1 (0x1FFFF7E8)
86#define MCU_ID2 (0x1FFFF7EC)
87#define MCU_ID3 (0x1FFFF7F0)
88
92extern uint8_t g_usbd_mouse_report[USBD_MOUSE_SIZ_REPORT_DESC];
93extern uint8_t g_mouse_usb_desc[9];
94extern usbd_desc_handler mouse_desc_handler;
95
103#ifdef __cplusplus
104}
105#endif
106
107#endif
108
109
USBD_MOUSE_SIZ_REPORT_DESC
#define USBD_MOUSE_SIZ_REPORT_DESC
Definition: mouse_desc.h:65
g_usbd_mouse_report
uint8_t g_usbd_mouse_report[74]
usb mouse report descriptor
Definition: mouse_desc.c:159
g_mouse_usb_desc
uint8_t g_mouse_usb_desc[9]
usb hid descriptor
Definition: mouse_desc.c:215
mouse_desc_handler
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure
Definition: mouse_desc.c:63
mouse_class.h
usb hid mouse header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: msc_diskio.h Source File

  • usb_device
  • msc
  • inc
msc/inc/msc_diskio.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_DISKIO_H
28#define __MSC_DISKIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36#include "usb_std.h"
37
45#define INTERNAL_FLASH_LUN 0
46#define SPI_FLASH_LUN 1
47#define SD_LUN 2
48
49#define USB_FLASH_ADDR_OFFSET 0x08005000
50
51#define SECTOR_SIZE_1K 1024
52#define SECTOR_SIZE_2K 2048
53#define SECTOR_SIZE_4K 4096
54
55uint8_t *get_inquiry(uint8_t lun);
56 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len);
57 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len);
58 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
59
68#ifdef __cplusplus
69}
70#endif
71
72#endif
73
74
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:102
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:136
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:59
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F413 Firmwary Library: msc_bot_scsi.c Source File

  • middlewares
  • usbd_class
  • msc
msc/msc_bot_scsi.c
Go to the documentation of this file.
1
26#include "msc_bot_scsi.h"
27#include "msc_diskio.h"
28
43#if defined ( __ICCARM__ ) /* iar compiler */
44 #pragma data_alignment=4
45#endif
46ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL = {
47 0x00,
48 0x00,
49 0x00,
50 0x00,
51 0x00,
52
53};
54#if defined ( __ICCARM__ ) /* iar compiler */
55 #pragma data_alignment=4
56#endif
57ALIGNED_HEAD sense_type sense_data ALIGNED_TAIL =
58{
59 0x70,
60 0x00,
61 SENSE_KEY_ILLEGAL_REQUEST,
62 0x00000000,
63 0x0A,
64 0x00000000,
65 0x20,
66 0x00,
67 0x00000000
68};
69
70#if defined ( __ICCARM__ ) /* iar compiler */
71 #pragma data_alignment=4
72#endif
73ALIGNED_HEAD uint8_t mode_sense6_data[8] ALIGNED_TAIL =
74{
75 0x00,
76 0x00,
77 0x00,
78 0x00,
79 0x00,
80 0x00,
81 0x00,
82 0x00
83};
84
85#if defined ( __ICCARM__ ) /* iar compiler */
86 #pragma data_alignment=4
87#endif
88ALIGNED_HEAD uint8_t mode_sense10_data[8] ALIGNED_TAIL =
89{
90 0x00,
91 0x06,
92 0x00,
93 0x00,
94 0x00,
95 0x00,
96 0x00,
97 0x00
98};
104void bot_scsi_init(void *udev)
105{
106 usbd_core_type *pudev = (usbd_core_type *)udev;
107 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
108 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
109 pmsc->bot_status = MSC_BOT_STATE_IDLE;
110 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
111
112 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
113 pmsc->csw_struct.dCSWDataResidue = 0;
114 pmsc->csw_struct.dCSWSignature = 0;
115 pmsc->csw_struct.dCSWTag = CSW_BCSWSTATUS_PASS;
116
117
118 /* set out endpoint to receive status */
119 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
120}
121
127void bot_scsi_reset(void *udev)
128{
129 usbd_core_type *pudev = (usbd_core_type *)udev;
130 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
131 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
132 pmsc->bot_status = MSC_BOT_STATE_RECOVERY;
133 pmsc->max_lun = MSC_SUPPORT_MAX_LUN - 1;
134
135 /* set out endpoint to receive status */
136 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
137}
138
145void bot_scsi_datain_handler(void *udev, uint8_t ept_num)
146{
147 usbd_core_type *pudev = (usbd_core_type *)udev;
148 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
149 switch(pmsc->msc_state)
150 {
151 case MSC_STATE_MACHINE_DATA_IN:
152 if(bot_scsi_cmd_process(udev) != USB_OK)
153 {
154 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
155 }
156 break;
157
158 case MSC_STATE_MACHINE_LAST_DATA:
159 case MSC_STATE_MACHINE_SEND_DATA:
160 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
161 break;
162
163 default:
164 break;
165 }
166}
167
174void bot_scsi_dataout_handler(void *udev, uint8_t ept_num)
175{
176 usbd_core_type *pudev = (usbd_core_type *)udev;
177 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
178 switch(pmsc->msc_state)
179 {
180 case MSC_STATE_MACHINE_IDLE:
181 bot_cbw_decode(udev);
182 break;
183
184 case MSC_STATE_MACHINE_DATA_OUT:
185 if(bot_scsi_cmd_process(udev) != USB_OK)
186 {
187 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
188 }
189 break;
190 }
191}
192
198void bot_cbw_decode(void *udev)
199{
200 usbd_core_type *pudev = (usbd_core_type *)udev;
201 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
202
203 pmsc->csw_struct.dCSWTag = pmsc->cbw_struct.dCBWTage;
204 pmsc->csw_struct.dCSWDataResidue = pmsc->cbw_struct.dCBWDataTransferLength;
205
206 /* check param */
207 if((pmsc->cbw_struct.dCBWSignature != CBW_DCBWSIGNATURE) ||
208 (usbd_get_recv_len(pudev, USBD_MSC_BULK_OUT_EPT) != CBW_CMD_LENGTH)
209 || (pmsc->cbw_struct.bCBWLUN > MSC_SUPPORT_MAX_LUN) ||
210 (pmsc->cbw_struct.bCBWCBLength < 1) || (pmsc->cbw_struct.bCBWCBLength > 16))
211 {
212 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
213 pmsc->bot_status = MSC_BOT_STATE_ERROR;
214 bot_scsi_stall(udev);
215 }
216 else
217 {
218 if(bot_scsi_cmd_process(udev) != USB_OK)
219 {
220 bot_scsi_stall(udev);
221 }
222 else if((pmsc->msc_state != MSC_STATE_MACHINE_DATA_IN) &&
223 (pmsc->msc_state != MSC_STATE_MACHINE_DATA_OUT) &&
224 (pmsc->msc_state != MSC_STATE_MACHINE_LAST_DATA))
225 {
226 if(pmsc->data_len == 0)
227 {
228 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
229 }
230 else if(pmsc->data_len > 0)
231 {
232 bot_scsi_send_data(udev, pmsc->data, pmsc->data_len);
233 }
234 }
235 }
236}
237
245void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
246{
247 usbd_core_type *pudev = (usbd_core_type *)udev;
248 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
249 uint32_t data_len = MIN(len, pmsc->cbw_struct.dCBWDataTransferLength);
250
251 pmsc->csw_struct.dCSWDataResidue -= data_len;
252 pmsc->csw_struct.bCSWStatus = CSW_BCSWSTATUS_PASS;
253
254 pmsc->msc_state = MSC_STATE_MACHINE_SEND_DATA;
255
256 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
257 buffer, data_len);
258}
259
266void bot_scsi_send_csw(void *udev, uint8_t status)
267{
268 usbd_core_type *pudev = (usbd_core_type *)udev;
269 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
270
271 pmsc->csw_struct.bCSWStatus = status;
272 pmsc->csw_struct.dCSWSignature = CSW_DCSWSIGNATURE;
273 pmsc->msc_state = MSC_STATE_MACHINE_IDLE;
274
275 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT,
276 (uint8_t *)&pmsc->csw_struct, CSW_CMD_LENGTH);
277
278 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
279 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
280}
281
282
290void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
291{
292 sense_data.sense_key = sense_key;
293 sense_data.asc = asc;
294}
295
296
305 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
306{
307 usbd_core_type *pudev = (usbd_core_type *)udev;
308 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
309 if((blk_offset + blk_count) > pmsc->blk_nbr[lun])
310 {
311 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, ADDRESS_OUT_OF_RANGE);
312 return USB_FAIL;
313 }
314 return USB_OK;
315}
316
322void bot_scsi_stall(void *udev)
323{
324 usbd_core_type *pudev = (usbd_core_type *)udev;
325 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
326
327 if((pmsc->cbw_struct.dCBWDataTransferLength != 0) &&
328 (pmsc->cbw_struct.bmCBWFlags == 0) &&
329 pmsc->bot_status == MSC_BOT_STATE_IDLE)
330 {
331 usbd_set_stall(pudev, USBD_MSC_BULK_OUT_EPT);
332 }
333 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
334
335 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
336 {
337 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT,
338 (uint8_t *)&pmsc->cbw_struct, CBW_CMD_LENGTH);
339 }
340}
341
348 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
349{
350 usb_sts_type status = USB_OK;
351 usbd_core_type *pudev = (usbd_core_type *)udev;
352 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
353
354 if(pmsc->cbw_struct.dCBWDataTransferLength != 0)
355 {
356 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
357 return USB_FAIL;
358 }
359
360 pmsc->data_len = 0;
361 return status;
362}
363
370 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
371{
372 uint8_t *pdata;
373 uint32_t trans_len = 0;
374 usb_sts_type status = USB_OK;
375 usbd_core_type *pudev = (usbd_core_type *)udev;
376 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
377
378 if(pmsc->cbw_struct.CBWCB[1] & 0x01)
379 {
380 pdata = page00_inquiry_data;
381 trans_len = 5;
382 }
383 else
384 {
385 pdata = get_inquiry(lun);
386 if(pmsc->cbw_struct.dCBWDataTransferLength < SCSI_INQUIRY_DATA_LENGTH)
387 {
388 trans_len = pmsc->cbw_struct.dCBWDataTransferLength;
389 }
390 else
391 {
392 trans_len = SCSI_INQUIRY_DATA_LENGTH;
393 }
394 }
395
396 pmsc->data_len = trans_len;
397 while(trans_len)
398 {
399 trans_len --;
400 pmsc->data[trans_len] = pdata[trans_len];
401 }
402 return status;
403}
404
411 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
412{
413 usbd_core_type *pudev = (usbd_core_type *)udev;
414 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
415 pmsc->data_len = 0;
416 return USB_OK;
417}
418
425 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
426{
427 usbd_core_type *pudev = (usbd_core_type *)udev;
428 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
429 pmsc->data_len = 0;
430 return USB_OK;
431}
432
439 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
440{
441 uint8_t data_len = 8;
442 usbd_core_type *pudev = (usbd_core_type *)udev;
443 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
444 pmsc->data_len = 8;
445 while(data_len)
446 {
447 data_len --;
448 pmsc->data[data_len] = mode_sense6_data[data_len];
449 };
450 return USB_OK;
451}
452
459 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
460{
461 uint8_t data_len = 8;
462 usbd_core_type *pudev = (usbd_core_type *)udev;
463 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
464 pmsc->data_len = 8;
465 while(data_len)
466 {
467 data_len --;
468 pmsc->data[data_len] = mode_sense10_data[data_len];
469 };
470 return USB_OK;
471}
472
479 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
480{
481 usbd_core_type *pudev = (usbd_core_type *)udev;
482 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
483 uint8_t *pdata = pmsc->data;
484 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
485
486 pdata[0] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
487 pdata[1] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
488 pdata[2] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
489 pdata[3] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
490
491 pdata[4] = (uint8_t)((pmsc->blk_size[lun]) >> 24);
492 pdata[5] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
493 pdata[6] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
494 pdata[7] = (uint8_t)((pmsc->blk_size[lun]));
495
496 pmsc->data_len = 8;
497 return USB_OK;
498}
499
506 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
507{
508 usbd_core_type *pudev = (usbd_core_type *)udev;
509 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
510 uint8_t *pdata = pmsc->data;
511
512 pdata[0] = 0;
513 pdata[1] = 0;
514 pdata[2] = 0;
515 pdata[3] = 0x08;
516
517 msc_disk_capacity(lun, &pmsc->blk_nbr[lun], &pmsc->blk_size[lun]);
518
519 pdata[4] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 24);
520 pdata[5] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 16);
521 pdata[6] = (uint8_t)((pmsc->blk_nbr[lun] - 1) >> 8);
522 pdata[7] = (uint8_t)((pmsc->blk_nbr[lun] - 1));
523
524 pdata[8] = 0x02;
525
526 pdata[9] = (uint8_t)((pmsc->blk_size[lun]) >> 16);
527 pdata[10] = (uint8_t)((pmsc->blk_size[lun]) >> 8);
528 pdata[11] = (uint8_t)((pmsc->blk_size[lun]));
529
530 pmsc->data_len = 12;
531
532 return USB_OK;
533}
534
541 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
542{
543 uint32_t trans_len = 0x12;
544 usbd_core_type *pudev = (usbd_core_type *)udev;
545 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
546 uint8_t *pdata = pmsc->data;
547 uint8_t *sdata = (uint8_t *)&sense_data;
548
549 while(trans_len)
550 {
551 trans_len --;
552 pdata[trans_len] = sdata[trans_len];
553 }
554
555 if(pmsc->cbw_struct.dCBWDataTransferLength < REQ_SENSE_STANDARD_DATA_LEN)
556 {
557 pmsc->data_len = pmsc->cbw_struct.dCBWDataTransferLength;
558 }
559 else
560 {
561 pmsc->data_len = REQ_SENSE_STANDARD_DATA_LEN;
562 }
563 return USB_OK;
564}
565
572 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
573{
574 usbd_core_type *pudev = (usbd_core_type *)udev;
575 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
576 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
577 if((pmsc->cbw_struct.CBWCB[1] & 0x02) == 0x02)
578 {
579 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_FIELED_IN_COMMAND);
580 return USB_FAIL;
581 }
582
583 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
584 pmsc->blk_len = cmd[7] << 8 | cmd[8];
585
586 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
587 {
588 return USB_FAIL;
589 }
590 pmsc->data_len = 0;
591 return USB_OK;
592}
593
600 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
601{
602 usbd_core_type *pudev = (usbd_core_type *)udev;
603 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
604 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
605 uint32_t len;
606
607 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
608 {
609 if((pmsc->cbw_struct.bmCBWFlags & 0x80) != 0x80)
610 {
611 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
612 return USB_FAIL;
613 }
614
615 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
616 pmsc->blk_len = cmd[7] << 8 | cmd[8];
617
618 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
619 {
620 return USB_FAIL;
621 }
622
623 pmsc->blk_addr *= pmsc->blk_size[lun];
624 pmsc->blk_len *= pmsc->blk_size[lun];
625
626 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
627 {
628 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
629 return USB_FAIL;
630 }
631 pmsc->msc_state = MSC_STATE_MACHINE_DATA_IN;
632 }
633 pmsc->data_len = MSC_MAX_DATA_BUF_LEN;
634
635 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
636 if( msc_disk_read(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
637 {
638 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
639 return USB_FAIL;
640 }
641 usbd_ept_send(pudev, USBD_MSC_BULK_IN_EPT, pmsc->data, len);
642 pmsc->blk_addr += len;
643 pmsc->blk_len -= len;
644
645 pmsc->csw_struct.dCSWDataResidue -= len;
646 if(pmsc->blk_len == 0)
647 {
648 pmsc->msc_state = MSC_STATE_MACHINE_LAST_DATA;
649 }
650
651 return USB_OK;
652}
653
654
661 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
662{
663 usbd_core_type *pudev = (usbd_core_type *)udev;
664 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
665 uint8_t *cmd = pmsc->cbw_struct.CBWCB;
666 uint32_t len;
667
668 if(pmsc->msc_state == MSC_STATE_MACHINE_IDLE)
669 {
670 if((pmsc->cbw_struct.bmCBWFlags & 0x80) == 0x80)
671 {
672 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
673 return USB_FAIL;
674 }
675
676 pmsc->blk_addr = cmd[2] << 24 | cmd[3] << 16 | cmd[4] << 8 | cmd[5];
677 pmsc->blk_len = cmd[7] << 8 | cmd[8];
678
679 if(bot_scsi_check_address(udev, lun, pmsc->blk_addr, pmsc->blk_len) != USB_OK)
680 {
681 return USB_FAIL;
682 }
683
684 pmsc->blk_addr *= pmsc->blk_size[lun];
685 pmsc->blk_len *= pmsc->blk_size[lun];
686
687 if(pmsc->cbw_struct.dCBWDataTransferLength != pmsc->blk_len)
688 {
689 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
690 return USB_FAIL;
691 }
692
693 pmsc->msc_state = MSC_STATE_MACHINE_DATA_OUT;
694 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
695 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
696
697 }
698 else
699 {
700 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
701 if(msc_disk_write(lun, pmsc->blk_addr, pmsc->data, len) != USB_OK)
702 {
703 bot_scsi_sense_code(udev, SENSE_KEY_HARDWARE_ERROR, MEDIUM_NOT_PRESENT);
704 return USB_FAIL;
705 }
706
707 pmsc->blk_addr += len;
708 pmsc->blk_len -= len;
709
710 pmsc->csw_struct.dCSWDataResidue -= len;
711
712 if(pmsc->blk_len == 0)
713 {
714 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_PASS);
715 }
716 else
717 {
718 len = MIN(pmsc->blk_len, MSC_MAX_DATA_BUF_LEN);
719 usbd_ept_recv(pudev, USBD_MSC_BULK_OUT_EPT, (uint8_t *)pmsc->data, len);
720 }
721 }
722 return USB_OK;
723}
724
731void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
732{
733 usbd_core_type *pudev = (usbd_core_type *)udev;
734 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
735 if(pmsc->bot_status == MSC_BOT_STATE_ERROR)
736 {
737 usbd_set_stall(pudev, USBD_MSC_BULK_IN_EPT);
738 pmsc->bot_status = MSC_BOT_STATE_IDLE;
739 }
740 else if(((ept_num & 0x80) == 0x80) && (pmsc->bot_status != MSC_BOT_STATE_RECOVERY))
741 {
742 bot_scsi_send_csw(udev, CSW_BCSWSTATUS_FAILED);
743 }
744}
745
751 usb_sts_type bot_scsi_cmd_process(void *udev)
752{
753 usb_sts_type status = USB_FAIL;
754 usbd_core_type *pudev = (usbd_core_type *)udev;
755 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
756 switch(pmsc->cbw_struct.CBWCB[0])
757 {
758 case MSC_CMD_INQUIRY:
759 status = bot_scsi_inquiry(udev, pmsc->cbw_struct.bCBWLUN);
760 break;
761
762 case MSC_CMD_START_STOP:
763 status = bot_scsi_start_stop(udev, pmsc->cbw_struct.bCBWLUN);
764 break;
765
766 case MSC_CMD_MODE_SENSE6:
767 status = bot_scsi_mode_sense6(udev, pmsc->cbw_struct.bCBWLUN);
768 break;
769
770 case MSC_CMD_MODE_SENSE10:
771 status = bot_scsi_mode_sense10(udev, pmsc->cbw_struct.bCBWLUN);
772 break;
773
774 case MSC_CMD_ALLOW_MEDIUM_REMOVAL:
775 status = bot_scsi_allow_medium_removal(udev, pmsc->cbw_struct.bCBWLUN);
776 break;
777
778 case MSC_CMD_READ_10:
779 status = bot_scsi_read10(udev, pmsc->cbw_struct.bCBWLUN);
780 break;
781
782 case MSC_CMD_READ_CAPACITY:
783 status = bot_scsi_capacity(udev, pmsc->cbw_struct.bCBWLUN);
784 break;
785
786 case MSC_CMD_REQUEST_SENSE:
787 status = bot_scsi_request_sense(udev, pmsc->cbw_struct.bCBWLUN);
788 break;
789
790 case MSC_CMD_TEST_UNIT:
791 status = bot_scsi_test_unit(udev, pmsc->cbw_struct.bCBWLUN);
792 break;
793
794 case MSC_CMD_VERIFY:
795 status = bot_scsi_verify(udev, pmsc->cbw_struct.bCBWLUN);
796 break;
797
798 case MSC_CMD_WRITE_10:
799 status = bot_scsi_write10(udev, pmsc->cbw_struct.bCBWLUN);
800 break;
801
802 case MSC_CMD_READ_FORMAT_CAPACITY:
803 status = bot_scsi_format_capacity(udev, pmsc->cbw_struct.bCBWLUN);
804 break;
805
806 default:
807 bot_scsi_sense_code(udev, SENSE_KEY_ILLEGAL_REQUEST, INVALID_COMMAND);
808 status = USB_FAIL;
809 break;
810 }
811 return status;
812}
813
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:102
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:136
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:59
cbw_type::bCBWLUN
uint8_t bCBWLUN
Definition: cdc_msc_class.h:194
msc_type::cbw_struct
cbw_type cbw_struct
Definition: cdc_msc_class.h:244
cbw_type::bCBWCBLength
uint8_t bCBWCBLength
Definition: cdc_msc_class.h:195
csw_type::dCSWSignature
uint32_t dCSWSignature
Definition: cdc_msc_class.h:204
cbw_type::CBWCB
uint8_t CBWCB[16]
Definition: cdc_msc_class.h:196
msc_type::blk_size
uint32_t blk_size[1]
Definition: cdc_msc_class.h:234
csw_type::bCSWStatus
uint32_t bCSWStatus
Definition: cdc_msc_class.h:207
csw_type::dCSWTag
uint32_t dCSWTag
Definition: cdc_msc_class.h:205
csw_type::dCSWDataResidue
uint32_t dCSWDataResidue
Definition: cdc_msc_class.h:206
msc_type::csw_struct
csw_type csw_struct
Definition: cdc_msc_class.h:245
msc_type::blk_len
uint32_t blk_len
Definition: cdc_msc_class.h:237
msc_type::data
uint8_t data[4096]
Definition: cdc_msc_class.h:240
msc_type::blk_addr
uint32_t blk_addr
Definition: cdc_msc_class.h:236
msc_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:231
msc_type::bot_status
uint8_t bot_status
Definition: cdc_msc_class.h:230
msc_type::msc_state
uint8_t msc_state
Definition: cdc_msc_class.h:229
cbw_type::dCBWDataTransferLength
uint32_t dCBWDataTransferLength
Definition: cdc_msc_class.h:192
msc_type::data_len
uint32_t data_len
Definition: cdc_msc_class.h:239
cbw_type::dCBWTage
uint32_t dCBWTage
Definition: cdc_msc_class.h:191
cbw_type::dCBWSignature
uint32_t dCBWSignature
Definition: cdc_msc_class.h:190
msc_type::blk_nbr
uint32_t blk_nbr[1]
Definition: cdc_msc_class.h:233
cbw_type::bmCBWFlags
uint8_t bmCBWFlags
Definition: cdc_msc_class.h:193
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: msc/msc_bot_scsi.c:506
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:145
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: msc/msc_bot_scsi.c:411
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: msc/msc_bot_scsi.c:541
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: msc/msc_bot_scsi.c:600
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: msc/msc_bot_scsi.c:305
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: msc/msc_bot_scsi.c:661
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:127
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: msc/msc_bot_scsi.c:459
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: msc/msc_bot_scsi.c:290
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: msc/msc_bot_scsi.c:198
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: msc/msc_bot_scsi.c:572
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: msc/msc_bot_scsi.c:425
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:104
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: msc/msc_bot_scsi.c:751
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:174
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: msc/msc_bot_scsi.c:439
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: msc/msc_bot_scsi.c:322
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: msc/msc_bot_scsi.c:245
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: msc/msc_bot_scsi.c:348
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: msc/msc_bot_scsi.c:370
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: msc/msc_bot_scsi.c:479
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:731
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: msc/msc_bot_scsi.c:266
ALIGNED_TAIL
ALIGNED_HEAD uint8_t page00_inquiry_data[] ALIGNED_TAIL
Definition: msc/msc_bot_scsi.c:46
MSC_STATE_MACHINE_DATA_IN
#define MSC_STATE_MACHINE_DATA_IN
Definition: cdc_msc_class.h:121
MSC_CMD_START_STOP
#define MSC_CMD_START_STOP
Definition: cdc_msc_class.h:88
MSC_CMD_VERIFY
#define MSC_CMD_VERIFY
Definition: cdc_msc_class.h:98
ADDRESS_OUT_OF_RANGE
#define ADDRESS_OUT_OF_RANGE
Definition: cdc_msc_class.h:153
SENSE_KEY_HARDWARE_ERROR
#define SENSE_KEY_HARDWARE_ERROR
Definition: cdc_msc_class.h:138
MEDIUM_NOT_PRESENT
#define MEDIUM_NOT_PRESENT
Definition: cdc_msc_class.h:154
MSC_CMD_MODE_SENSE6
#define MSC_CMD_MODE_SENSE6
Definition: cdc_msc_class.h:89
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_CMD_ALLOW_MEDIUM_REMOVAL
#define MSC_CMD_ALLOW_MEDIUM_REMOVAL
Definition: cdc_msc_class.h:91
CSW_CMD_LENGTH
#define CSW_CMD_LENGTH
Definition: cdc_msc_class.h:114
MSC_BOT_STATE_IDLE
#define MSC_BOT_STATE_IDLE
Definition: cdc_msc_class.h:129
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: cdc_msc_class.h:84
CSW_DCSWSIGNATURE
#define CSW_DCSWSIGNATURE
Definition: cdc_msc_class.h:115
MSC_CMD_INQUIRY
#define MSC_CMD_INQUIRY
Definition: cdc_msc_class.h:87
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
INVALID_COMMAND
#define INVALID_COMMAND
Definition: cdc_msc_class.h:149
MSC_CMD_WRITE_10
#define MSC_CMD_WRITE_10
Definition: cdc_msc_class.h:99
MSC_STATE_MACHINE_IDLE
#define MSC_STATE_MACHINE_IDLE
Definition: cdc_msc_class.h:127
MSC_CMD_READ_FORMAT_CAPACITY
#define MSC_CMD_READ_FORMAT_CAPACITY
Definition: cdc_msc_class.h:95
MSC_CMD_MODE_SENSE10
#define MSC_CMD_MODE_SENSE10
Definition: cdc_msc_class.h:90
SENSE_KEY_ILLEGAL_REQUEST
#define SENSE_KEY_ILLEGAL_REQUEST
Definition: cdc_msc_class.h:139
MSC_STATE_MACHINE_DATA_OUT
#define MSC_STATE_MACHINE_DATA_OUT
Definition: cdc_msc_class.h:122
CSW_BCSWSTATUS_PASS
#define CSW_BCSWSTATUS_PASS
Definition: cdc_msc_class.h:116
INVALID_FIELED_IN_COMMAND
#define INVALID_FIELED_IN_COMMAND
Definition: cdc_msc_class.h:150
REQ_SENSE_STANDARD_DATA_LEN
#define REQ_SENSE_STANDARD_DATA_LEN
Definition: cdc_msc_class.h:133
MSC_STATE_MACHINE_SEND_DATA
#define MSC_STATE_MACHINE_SEND_DATA
Definition: cdc_msc_class.h:123
CBW_DCBWSIGNATURE
#define CBW_DCBWSIGNATURE
Definition: cdc_msc_class.h:110
MSC_CMD_READ_10
#define MSC_CMD_READ_10
Definition: cdc_msc_class.h:92
MSC_BOT_STATE_RECOVERY
#define MSC_BOT_STATE_RECOVERY
Definition: cdc_msc_class.h:130
CBW_CMD_LENGTH
#define CBW_CMD_LENGTH
Definition: cdc_msc_class.h:109
MSC_STATE_MACHINE_LAST_DATA
#define MSC_STATE_MACHINE_LAST_DATA
Definition: cdc_msc_class.h:124
MSC_CMD_TEST_UNIT
#define MSC_CMD_TEST_UNIT
Definition: cdc_msc_class.h:97
CSW_BCSWSTATUS_FAILED
#define CSW_BCSWSTATUS_FAILED
Definition: cdc_msc_class.h:117
MSC_CMD_READ_CAPACITY
#define MSC_CMD_READ_CAPACITY
Definition: cdc_msc_class.h:94
MSC_BOT_STATE_ERROR
#define MSC_BOT_STATE_ERROR
Definition: cdc_msc_class.h:131
MSC_CMD_REQUEST_SENSE
#define MSC_CMD_REQUEST_SENSE
Definition: cdc_msc_class.h:96
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
USB_FAIL
@ USB_FAIL
Definition: usb_std.h:277
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:261
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file
msc_type
Definition: cdc_msc_class.h:228
sense_type
request sense standard data
Definition: cdc_msc_class.h:214
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113


AT32F413 Firmwary Library: msc_diskio.c Source File

  • usb_device
  • msc
  • src
msc/src/msc_diskio.c
Go to the documentation of this file.
1
26#include "msc_diskio.h"
27#include "msc_bot_scsi.h"
28
36uint32_t sector_size = 2048;
37uint32_t msc_flash_size;
38uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
39{
40 /* lun = 0 */
41 {
42 0x00, /* peripheral device type (direct-access device) */
43 0x80, /* removable media bit */
44 0x00, /* ansi version, ecma version, iso version */
45 0x01, /* respond data format */
46 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
47 0x00, 0x00, 0x00, /* reserved */
48 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
49 'D', 'i', 's', 'k', '0', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
50 '2', '.', '0', '0' /* product revision level */
51 }
52};
53
59uint8_t *get_inquiry(uint8_t lun)
60{
61 if(lun < MSC_SUPPORT_MAX_LUN)
62 return (uint8_t *)scsi_inquiry[lun];
63 else
64 return NULL;
65}
66
75 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
76{
77 uint32_t i = 0;
78 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
79 switch(lun)
80 {
81 case 0:
82 for(i = 0; i < len; i ++)
83 {
84 read_buf[i] = *((uint8_t *)flash_addr);
85 flash_addr += 1;
86 }
87 break;
88 case 1:
89 break;
90 }
91 return USB_OK;
92}
93
102 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
103{
104 uint32_t flash_addr = addr + USB_FLASH_ADDR_OFFSET;
105 uint32_t i = 0, page_len = 2048, tolen = len;
106 uint32_t erase_addr = flash_addr;
107 switch(lun)
108 {
109 case 0:
110 flash_unlock();
111 while(tolen >= page_len)
112 {
113 flash_sector_erase(erase_addr);
114 tolen -= page_len;
115 erase_addr += page_len;
116 }
117 for(i = 0; i < len; i ++)
118 {
119 flash_byte_program(flash_addr+i, buf[i]);
120 }
121 flash_lock();
122 break;
123 case 1:
124 break;
125 }
126 return USB_OK;
127}
128
136 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
137{
138 uint32_t flash_s = *((uint32_t *)0x1FFFF7E0);
139 msc_flash_size = (flash_s << 10) - (USB_FLASH_ADDR_OFFSET - FLASH_BASE);
140
141 if(flash_s < 256)
142 {
143 sector_size = SECTOR_SIZE_1K;
144 }
145 else
146 {
147 sector_size = SECTOR_SIZE_2K;
148 }
149
150 switch(lun)
151 {
152 case INTERNAL_FLASH_LUN:
153 *blk_nbr = msc_flash_size / sector_size;
154 *blk_size = sector_size;
155 break;
156 case SPI_FLASH_LUN:
157 break;
158 case SD_LUN:
159 break;
160 default:
161 break;
162 }
163 return USB_OK;
164}
165
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:102
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:75
USB_FLASH_ADDR_OFFSET
#define USB_FLASH_ADDR_OFFSET
Definition: composite_vcp_msc/inc/msc_diskio.h:49
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:45
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:136
msc_flash_size
uint32_t msc_flash_size
Definition: msc/src/msc_diskio.c:37
sector_size
uint32_t sector_size
Definition: msc/src/msc_diskio.c:36
SD_LUN
#define SD_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:47
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: msc/src/msc_diskio.c:38
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:46
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:59
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_byte_program
flash_status_type flash_byte_program(uint32_t address, uint8_t data)
program a byte at a specified address.
Definition: at32f413_flash.c:533
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:291
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
SECTOR_SIZE_1K
#define SECTOR_SIZE_1K
Definition: hid_iap_class.h:61
SECTOR_SIZE_2K
#define SECTOR_SIZE_2K
Definition: hid_iap_class.h:62
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file


AT32F413 Firmwary Library: msc_bot_scsi.h Source File

  • middlewares
  • usbd_class
  • msc
msc_bot_scsi.h
Go to the documentation of this file.
1
26/* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_BOT_SCSI_H
28#define __MSC_BOT_SCSI_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "msc_class.h"
35#include "usbd_core.h"
36
49#define MSC_SUPPORT_MAX_LUN 1
50#define MSC_MAX_DATA_BUF_LEN 4096
51
52#define MSC_CMD_FORMAT_UNIT 0x04
53#define MSC_CMD_INQUIRY 0x12
54#define MSC_CMD_START_STOP 0x1B
55#define MSC_CMD_MODE_SENSE6 0x1A
56#define MSC_CMD_MODE_SENSE10 0x5A
57#define MSC_CMD_ALLOW_MEDIUM_REMOVAL 0x1E
58#define MSC_CMD_READ_10 0x28
59#define MSC_CMD_READ_12 0xA8
60#define MSC_CMD_READ_CAPACITY 0x25
61#define MSC_CMD_READ_FORMAT_CAPACITY 0x23
62#define MSC_CMD_REQUEST_SENSE 0x03
63#define MSC_CMD_TEST_UNIT 0x00
64#define MSC_CMD_VERIFY 0x2F
65#define MSC_CMD_WRITE_10 0x2A
66#define MSC_CMD_WRITE_12 0xAA
67#define MSC_CMD_WRITE_VERIFY 0x2E
68
69#define MSC_REQ_GET_MAX_LUN 0xFE
70#define MSC_REQ_BO_RESET 0xFF
72#define SET_LINE_CODING 0x20
73#define GET_LINE_CODING 0x21
74
75#define CBW_CMD_LENGTH 31
76#define CBW_DCBWSIGNATURE 0x43425355
77#define CBW_BMCBWFLAGS_DIR_OUT 0x00
78#define CBW_BMCBWFLAGS_DIR_IN 0x80
79
80#define CSW_CMD_LENGTH 13
81#define CSW_DCSWSIGNATURE 0x53425355
82#define CSW_BCSWSTATUS_PASS 0x00
83#define CSW_BCSWSTATUS_FAILED 0x01
84#define CSW_BCSWSTATUS_PHASE_ERR 0x02
85
86#define MSC_STATE_MACHINE_CMD 0x00
87#define MSC_STATE_MACHINE_DATA_IN 0x01
88#define MSC_STATE_MACHINE_DATA_OUT 0x02
89#define MSC_STATE_MACHINE_SEND_DATA 0x03
90#define MSC_STATE_MACHINE_LAST_DATA 0x04
91#define MSC_STATE_MACHINE_STATUS 0x05
92#define MSC_STATE_MACHINE_FAILED 0x06
93#define MSC_STATE_MACHINE_IDLE 0x07
94
95#define MSC_BOT_STATE_IDLE 0x00
96#define MSC_BOT_STATE_RECOVERY 0x01
97#define MSC_BOT_STATE_ERROR 0x02
98
99#define REQ_SENSE_STANDARD_DATA_LEN 0x12
100#define SENSE_KEY_NO_SENSE 0x00
101#define SENSE_KEY_RECOVERED_ERROR 0x01
102#define SENSE_KEY_NOT_READY 0x02
103#define SENSE_KEY_MEDIUM_ERROR 0x03
104#define SENSE_KEY_HARDWARE_ERROR 0x04
105#define SENSE_KEY_ILLEGAL_REQUEST 0x05
106#define SENSE_KEY_UNIT_ATTENTION 0x06
107#define SENSE_KEY_DATA_PROTECT 0x07
108#define SENSE_KEY_BLANK_CHECK 0x08
109#define SENSE_KEY_VENDERO_SPECIFIC 0x09
110#define SENSE_KEY_ABORTED_COMMAND 0x0B
111#define SENSE_KEY_VOLUME_OVERFLOW 0x0D
112#define SENSE_KEY_MISCOMPARE 0x0E
113
114
115#define INVALID_COMMAND 0x20
116#define INVALID_FIELED_IN_COMMAND 0x24
117#define PARAMETER_LIST_LENGTH_ERROR 0x1A
118#define INVALID_FIELD_IN_PARAMETER_LIST 0x26
119#define ADDRESS_OUT_OF_RANGE 0x21
120#define MEDIUM_NOT_PRESENT 0x3A
121#define MEDIUM_HAVE_CHANGED 0x28
122
123#define SCSI_INQUIRY_DATA_LENGTH 36
124
128typedef struct
129{
130 uint8_t opcode;
131 uint8_t lun;
132 uint32_t address;
133 uint8_t reserved1;
134 uint32_t alloc_length;
135 uint16_t reserved2;
136}cbd_typical_type;
137
141typedef struct
142{
143 uint8_t opcode;
144 uint8_t lun;
145 uint32_t address;
146 uint8_t reserved1;
147 uint32_t alloc_length;
148 uint16_t reserved2;
149}cbd_extended_type;
150
154typedef struct
155{
156 uint32_t dCBWSignature;
157 uint32_t dCBWTage;
158 uint32_t dCBWDataTransferLength;
159 uint8_t bmCBWFlags;
160 uint8_t bCBWLUN;
161 uint8_t bCBWCBLength;
162 uint8_t CBWCB[16];
163}cbw_type;
164
168typedef struct
169{
170 uint32_t dCSWSignature;
171 uint32_t dCSWTag;
172 uint32_t dCSWDataResidue;
173 uint32_t bCSWStatus;
174}csw_type;
175
179typedef struct
180{
181 uint8_t err_code;
182 uint8_t reserved1;
183 uint8_t sense_key;
184 uint32_t information;
185 uint8_t as_length;
186 uint32_t reserved2;
187 uint8_t asc;
188 uint8_t ascq;
189 uint32_t reserved3;
190}sense_type;
191
192
193typedef struct
194{
195 uint8_t msc_state;
196 uint8_t bot_status;
197 uint32_t max_lun;
198
199 uint32_t blk_nbr[MSC_SUPPORT_MAX_LUN];
200 uint32_t blk_size[MSC_SUPPORT_MAX_LUN];
201
202 uint32_t blk_addr;
203 uint32_t blk_len;
204
205 uint32_t data_len;
206 uint8_t data[MSC_MAX_DATA_BUF_LEN];
207
208 uint32_t alt_setting;
209
210 cbw_type cbw_struct;
211 csw_type csw_struct;
212
213}msc_type;
214
215void bot_scsi_init(void *udev);
216void bot_scsi_reset(void *udev);
217void bot_scsi_datain_handler(void *pudev, uint8_t ept_num);
218void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num);
219void bot_cbw_decode(void *udev);
220void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len);
221void bot_scsi_send_csw(void *udev, uint8_t status);
222void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc);
223 usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count);
224void bot_scsi_stall(void *udev);
225 usb_sts_type bot_scsi_cmd_process(void *udev);
226
227 usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun);
228 usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun);
229 usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun);
230 usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun);
231 usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun);
232 usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun);
233 usb_sts_type bot_scsi_read10(void *udev, uint8_t lun);
234 usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun);
235 usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun);
236 usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun);
237 usb_sts_type bot_scsi_verify(void *udev, uint8_t lun);
238 usb_sts_type bot_scsi_write10(void *udev, uint8_t lun);
239void bot_scsi_clear_feature(void *udev, uint8_t ept_num);
240
252#ifdef __cplusplus
253}
254#endif
255
256#endif
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
bot_scsi_format_capacity
usb_sts_type bot_scsi_format_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command format capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:505
bot_scsi_start_stop
usb_sts_type bot_scsi_start_stop(void *udev, uint8_t lun)
bulk-only transport scsi command start stop
Definition: composite_cdc_msc/msc_bot_scsi.c:410
bot_scsi_request_sense
usb_sts_type bot_scsi_request_sense(void *udev, uint8_t lun)
bulk-only transport scsi command request sense
Definition: composite_cdc_msc/msc_bot_scsi.c:540
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: composite_cdc_msc/msc_bot_scsi.c:173
MSC_MAX_DATA_BUF_LEN
#define MSC_MAX_DATA_BUF_LEN
Definition: msc_bot_scsi.h:50
bot_scsi_read10
usb_sts_type bot_scsi_read10(void *udev, uint8_t lun)
bulk-only transport scsi command read10
Definition: composite_cdc_msc/msc_bot_scsi.c:599
bot_scsi_check_address
usb_sts_type bot_scsi_check_address(void *udev, uint8_t lun, uint32_t blk_offset, uint32_t blk_count)
check address
Definition: composite_cdc_msc/msc_bot_scsi.c:304
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: msc_bot_scsi.h:49
bot_scsi_write10
usb_sts_type bot_scsi_write10(void *udev, uint8_t lun)
bulk-only transport scsi command write10
Definition: composite_cdc_msc/msc_bot_scsi.c:660
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:126
bot_scsi_mode_sense10
usb_sts_type bot_scsi_mode_sense10(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense10
Definition: composite_cdc_msc/msc_bot_scsi.c:458
bot_scsi_sense_code
void bot_scsi_sense_code(void *udev, uint8_t sense_key, uint8_t asc)
send scsi sense code
Definition: composite_cdc_msc/msc_bot_scsi.c:289
bot_cbw_decode
void bot_cbw_decode(void *udev)
bulk-only cbw decode
Definition: composite_cdc_msc/msc_bot_scsi.c:197
bot_scsi_verify
usb_sts_type bot_scsi_verify(void *udev, uint8_t lun)
bulk-only transport scsi command verify
Definition: composite_cdc_msc/msc_bot_scsi.c:571
bot_scsi_allow_medium_removal
usb_sts_type bot_scsi_allow_medium_removal(void *udev, uint8_t lun)
bulk-only transport scsi command meidum removal
Definition: composite_cdc_msc/msc_bot_scsi.c:424
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: composite_cdc_msc/msc_bot_scsi.c:104
bot_scsi_cmd_process
usb_sts_type bot_scsi_cmd_process(void *udev)
bulk-only transport scsi command process
Definition: composite_cdc_msc/msc_bot_scsi.c:750
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: composite_cdc_msc/msc_bot_scsi.c:144
bot_scsi_mode_sense6
usb_sts_type bot_scsi_mode_sense6(void *udev, uint8_t lun)
bulk-only transport scsi command mode sense6
Definition: composite_cdc_msc/msc_bot_scsi.c:438
bot_scsi_stall
void bot_scsi_stall(void *udev)
bot endpoint stall
Definition: composite_cdc_msc/msc_bot_scsi.c:321
bot_scsi_send_data
void bot_scsi_send_data(void *udev, uint8_t *buffer, uint32_t len)
send bot data
Definition: composite_cdc_msc/msc_bot_scsi.c:244
bot_scsi_test_unit
usb_sts_type bot_scsi_test_unit(void *udev, uint8_t lun)
bulk-only transport scsi command test unit
Definition: composite_cdc_msc/msc_bot_scsi.c:347
bot_scsi_inquiry
usb_sts_type bot_scsi_inquiry(void *udev, uint8_t lun)
bulk-only transport scsi command inquiry
Definition: composite_cdc_msc/msc_bot_scsi.c:369
bot_scsi_capacity
usb_sts_type bot_scsi_capacity(void *udev, uint8_t lun)
bulk-only transport scsi command capacity
Definition: composite_cdc_msc/msc_bot_scsi.c:478
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: composite_cdc_msc/msc_bot_scsi.c:730
bot_scsi_send_csw
void bot_scsi_send_csw(void *udev, uint8_t status)
send command status
Definition: composite_cdc_msc/msc_bot_scsi.c:265
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
msc_class.h
usb msc class file
cbd_extended_type
extended command block description
Definition: cdc_msc_class.h:176
cbd_typical_type
typical command block description
Definition: cdc_msc_class.h:163
cbw_type
command block wrapper
Definition: cdc_msc_class.h:189
csw_type
command block wrapper
Definition: cdc_msc_class.h:203
msc_type
Definition: cdc_msc_class.h:228
sense_type
request sense standard data
Definition: cdc_msc_class.h:214
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: msc_class.c Source File

  • middlewares
  • usbd_class
  • msc
msc_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "msc_class.h"
28#include "msc_desc.h"
29#include "msc_bot_scsi.h"
30
44static usb_sts_type class_init_handler(void *udev);
45static usb_sts_type class_clear_handler(void *udev);
46static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
47static usb_sts_type class_ept0_tx_handler(void *udev);
48static usb_sts_type class_ept0_rx_handler(void *udev);
49static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
51static usb_sts_type class_sof_handler(void *udev);
52static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
53
54 msc_type msc_struct;
55
56/* usb device class handler */
57 usbd_class_handler msc_class_handler =
58{
59 class_init_handler,
60 class_clear_handler,
61 class_setup_handler,
62 class_ept0_tx_handler,
63 class_ept0_rx_handler,
64 class_in_handler,
65 class_out_handler,
66 class_sof_handler,
67 class_event_handler,
68 &msc_struct
69};
70
76static usb_sts_type class_init_handler(void *udev)
77{
78 usb_sts_type status = USB_OK;
79 usbd_core_type *pudev = (usbd_core_type *)udev;
80
81 /* open in endpoint */
82 usbd_ept_open(pudev, USBD_MSC_BULK_IN_EPT, EPT_BULK_TYPE, USBD_OUT_MAXPACKET_SIZE);
83
84 /* open out endpoint */
85 usbd_ept_open(pudev, USBD_MSC_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_OUT_MAXPACKET_SIZE);
86
87 bot_scsi_init(udev);
88
89 return status;
90}
91
97static usb_sts_type class_clear_handler(void *udev)
98{
99 usb_sts_type status = USB_OK;
100 usbd_core_type *pudev = (usbd_core_type *)udev;
101
102 /* close in endpoint */
103 usbd_ept_close(pudev, USBD_MSC_BULK_IN_EPT);
104
105 /* close out endpoint */
106 usbd_ept_close(pudev, USBD_MSC_BULK_OUT_EPT);
107
108 return status;
109}
110
117static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
118{
119 usb_sts_type status = USB_OK;
120 usbd_core_type *pudev = (usbd_core_type *)udev;
121 msc_type *pmsc = (msc_type *)pudev->class_handler->pdata;
122 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
123 {
124 /* class request */
125 case USB_REQ_TYPE_CLASS:
126
127 switch(setup->bRequest)
128 {
129 case MSC_REQ_GET_MAX_LUN:
130 usbd_ctrl_send(pudev, (uint8_t *)&pmsc->max_lun, 1);
131 break;
132 case MSC_REQ_BO_RESET:
133 bot_scsi_reset(udev);
134 usbd_ctrl_send_status(pudev);
135 break;
136 default:
137 usbd_ctrl_unsupport(pudev);
138 break;
139
140 }
141 break;
142 /* standard request */
143 case USB_REQ_TYPE_STANDARD:
144
145 switch(setup->bRequest)
146 {
147 case USB_STD_REQ_GET_DESCRIPTOR:
148 usbd_ctrl_unsupport(pudev);
149 break;
150 case USB_STD_REQ_GET_INTERFACE:
151 usbd_ctrl_send(pudev, (uint8_t *)&pmsc->alt_setting, 1);
152 break;
153 case USB_STD_REQ_SET_INTERFACE:
154 pmsc->alt_setting = setup->wValue;
155 break;
156 case USB_STD_REQ_CLEAR_FEATURE:
157 usbd_ept_close(pudev, (uint8_t)setup->wIndex);
158
159 if((setup->wIndex & 0x80) == 0x80)
160 {
161 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_IN_MAXPACKET_SIZE);
162 }
163 else
164 {
165 usbd_ept_open(pudev, (uint8_t)setup->wIndex, EPT_BULK_TYPE, USBD_OUT_MAXPACKET_SIZE);
166 }
167 bot_scsi_clear_feature(udev, setup->wIndex);
168 break;
169 default:
170 break;
171 }
172 break;
173 default:
174 usbd_ctrl_unsupport(pudev);
175 break;
176 }
177 return status;
178}
179
185static usb_sts_type class_ept0_tx_handler(void *udev)
186{
187 usb_sts_type status = USB_OK;
188
189 /* ...user code... */
190
191 return status;
192}
193
199static usb_sts_type class_ept0_rx_handler(void *udev)
200{
201 usb_sts_type status = USB_OK;
202 usbd_core_type *pudev = (usbd_core_type *)udev;
203 uint32_t recv_len = usbd_get_recv_len(pudev, 0);
204 /* ...user code... */
205 return status;
206}
207
214static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
215{
216 usb_sts_type status = USB_OK;
217
218 bot_scsi_datain_handler(udev, ept_num);
219 return status;
220}
221
228static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
229{
230 usb_sts_type status = USB_OK;
231 bot_scsi_dataout_handler(udev, ept_num);
232 return status;
233}
234
240static usb_sts_type class_sof_handler(void *udev)
241{
242 usb_sts_type status = USB_OK;
243
244 /* ...user code... */
245
246 return status;
247}
248
255static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
256{
257 usb_sts_type status = USB_OK;
258 switch(event)
259 {
260 case USBD_RESET_EVENT:
261
262 /* ...user code... */
263
264 break;
265 case USBD_SUSPEND_EVENT:
266
267 /* ...user code... */
268
269 break;
270 case USBD_WAKEUP_EVENT:
271 /* ...user code... */
272
273 break;
274
275 default:
276 break;
277 }
278 return status;
279}
msc_type::max_lun
uint32_t max_lun
Definition: cdc_msc_class.h:231
msc_type::alt_setting
uint32_t alt_setting
Definition: cdc_msc_class.h:242
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
bot_scsi_datain_handler
void bot_scsi_datain_handler(void *pudev, uint8_t ept_num)
bulk-only transport data in handler
Definition: msc/msc_bot_scsi.c:145
bot_scsi_reset
void bot_scsi_reset(void *udev)
reset bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:127
bot_scsi_init
void bot_scsi_init(void *udev)
initialize bulk-only transport and scsi
Definition: msc/msc_bot_scsi.c:104
bot_scsi_dataout_handler
void bot_scsi_dataout_handler(void *pudev, uint8_t ept_num)
bulk-only transport data out handler
Definition: msc/msc_bot_scsi.c:174
bot_scsi_clear_feature
void bot_scsi_clear_feature(void *udev, uint8_t ept_num)
clear feature
Definition: msc/msc_bot_scsi.c:731
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:204
MSC_REQ_BO_RESET
#define MSC_REQ_BO_RESET
Definition: cdc_msc_class.h:104
MSC_REQ_GET_MAX_LUN
#define MSC_REQ_GET_MAX_LUN
Definition: cdc_msc_class.h:103
USBD_OUT_MAXPACKET_SIZE
#define USBD_OUT_MAXPACKET_SIZE
Definition: msc_class.h:53
USBD_IN_MAXPACKET_SIZE
#define USBD_IN_MAXPACKET_SIZE
Definition: msc_class.h:52
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: msc_class.c:240
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: msc_class.c:214
msc_struct
msc_type msc_struct
Definition: msc_class.c:54
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: msc_class.c:97
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: msc_class.c:117
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: msc_class.c:185
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: msc_class.c:199
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: msc_class.c:255
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb endpoint
Definition: msc_class.c:76
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:57
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: msc_class.c:228
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:78
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:211
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file
msc_class.h
usb msc class file
msc_desc.h
usb msc descriptor header file
msc_type
Definition: cdc_msc_class.h:228
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: msc_class.h Source File

  • middlewares
  • usbd_class
  • msc
msc_class.h
Go to the documentation of this file.
1
26 /* define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_CLASS_H
28#define __MSC_CLASS_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "usb_std.h"
35#include "usbd_core.h"
36
49#define USBD_MSC_BULK_IN_EPT 0x81
50#define USBD_MSC_BULK_OUT_EPT 0x01
51
52#define USBD_IN_MAXPACKET_SIZE 0x40
53#define USBD_OUT_MAXPACKET_SIZE 0x40
54
55
56extern usbd_class_handler msc_class_handler;
68#ifdef __cplusplus
69}
70#endif
71
72#endif
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:57
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: msc_desc.c Source File

  • middlewares
  • usbd_class
  • msc
msc_desc.c
Go to the documentation of this file.
1
26#include "stdio.h"
27#include "usb_std.h"
28#include "usbd_sdr.h"
29#include "usbd_core.h"
30#include "msc_desc.h"
31
45static usbd_desc_t *get_device_descriptor(void);
46static usbd_desc_t *get_device_qualifier(void);
47static usbd_desc_t *get_device_configuration(void);
48static usbd_desc_t *get_device_other_speed(void);
49static usbd_desc_t *get_device_lang_id(void);
50static usbd_desc_t *get_device_manufacturer_string(void);
51static usbd_desc_t *get_device_product_string(void);
52static usbd_desc_t *get_device_serial_string(void);
53static usbd_desc_t *get_device_interface_string(void);
54static usbd_desc_t *get_device_config_string(void);
55
56static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
57static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
58static void get_serial_num(void);
59static uint8_t g_usbd_desc_buffer[256];
60
64 usbd_desc_handler msc_desc_handler =
65{
66 get_device_descriptor,
67 get_device_qualifier,
68 get_device_configuration,
69 get_device_other_speed,
70 get_device_lang_id,
71 get_device_manufacturer_string,
72 get_device_product_string,
73 get_device_serial_string,
74 get_device_interface_string,
75 get_device_config_string,
76};
77
81#if defined ( __ICCARM__ ) /* iar compiler */
82 #pragma data_alignment=4
83#endif
84ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
85{
86 USB_DEVICE_DESC_LEN, /* bLength */
87 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
88 0x00, /* bcdUSB */
89 0x02,
90 0x00, /* bDeviceClass */
91 0x00, /* bDeviceSubClass */
92 0x00, /* bDeviceProtocol */
93 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
94 LBYTE(USBD_MSC_VENDOR_ID), /* idVendor */
95 HBYTE(USBD_MSC_VENDOR_ID), /* idVendor */
96 LBYTE(USBD_MSC_PRODUCT_ID), /* idProduct */
97 HBYTE(USBD_MSC_PRODUCT_ID), /* idProduct */
98 0x00, /* bcdDevice rel. 2.00 */
99 0x02,
100 USB_MFC_STRING, /* Index of manufacturer string */
101 USB_PRODUCT_STRING, /* Index of product string */
102 USB_SERIAL_STRING, /* Index of serial number string */
103 1 /* bNumConfigurations */
104};
105
109#if defined ( __ICCARM__ ) /* iar compiler */
110 #pragma data_alignment=4
111#endif
112ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_MSC_CONFIG_DESC_SIZE] ALIGNED_TAIL =
113{
114 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
115 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
116 LBYTE(USBD_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 HBYTE(USBD_MSC_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 0x01, /* bNumInterfaces: 2 interface */
119 0x01, /* bConfigurationValue: configuration value */
120 0x04, /* iConfiguration: index of string descriptor describing
121 the configuration */
122 0xC0, /* bmAttributes: self powered */
123 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
124
125 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
126 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
127 0x00, /* bInterfaceNumber: number of interface */
128 0x00, /* bAlternateSetting: alternate set */
129 0x02, /* bNumEndpoints: number of endpoints */
130 USB_CLASS_CODE_MSC, /* bInterfaceClass: msc class code */
131 0x06, /* bInterfaceSubClass: subclass code scsi */
132 0x50, /* bInterfaceProtocol: protocol code BBB */
133 0x05, /* iInterface: index of string descriptor */
134
135 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
136 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
137 USBD_MSC_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
138 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
139 LBYTE(USBD_IN_MAXPACKET_SIZE),
140 HBYTE(USBD_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
141 0x00, /* bInterval: interval for polling endpoint for data transfers */
142
143 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
144 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
145 USBD_MSC_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
146 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
147 LBYTE(USBD_OUT_MAXPACKET_SIZE),
148 HBYTE(USBD_OUT_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
149 0x00, /* bInterval: interval for polling endpoint for data transfers */
150};
151
155#if defined ( __ICCARM__ ) /* iar compiler */
156 #pragma data_alignment=4
157#endif
158ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_MSC_SIZ_STRING_LANGID] ALIGNED_TAIL =
159{
160 USBD_MSC_SIZ_STRING_LANGID,
161 USB_DESCIPTOR_TYPE_STRING,
162 0x09,
163 0x04,
164};
165
169#if defined ( __ICCARM__ ) /* iar compiler */
170 #pragma data_alignment=4
171#endif
172ALIGNED_HEAD static uint8_t g_string_serial[USBD_MSC_SIZ_STRING_SERIAL] ALIGNED_TAIL =
173{
174 USBD_MSC_SIZ_STRING_SERIAL,
175 USB_DESCIPTOR_TYPE_STRING,
176};
177
178
179/* device descriptor */
180static usbd_desc_t device_descriptor =
181{
182 USB_DEVICE_DESC_LEN,
183 g_usbd_descriptor
184};
185
186/* config descriptor */
187static usbd_desc_t config_descriptor =
188{
189 USBD_MSC_CONFIG_DESC_SIZE,
190 g_usbd_configuration
191};
192
193/* langid descriptor */
194static usbd_desc_t langid_descriptor =
195{
196 USBD_MSC_SIZ_STRING_LANGID,
197 g_string_lang_id
198};
199
200/* serial descriptor */
201static usbd_desc_t serial_descriptor =
202{
203 USBD_MSC_SIZ_STRING_SERIAL,
204 g_string_serial
205};
206
207static usbd_desc_t vp_desc;
208
215static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
216{
217 uint16_t str_len = 0, id_pos = 2;
218 uint8_t *tmp_str = string;
219
220 while(*tmp_str != '\0')
221 {
222 str_len ++;
223 unicode_buf[id_pos ++] = *tmp_str ++;
224 unicode_buf[id_pos ++] = 0x00;
225 }
226
227 str_len = str_len * 2 + 2;
228 unicode_buf[0] = (uint8_t)str_len;
229 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
230
231 return str_len;
232}
233
241static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
242{
243 uint8_t idx = 0;
244
245 for( idx = 0 ; idx < len ; idx ++)
246 {
247 if( ((value >> 28)) < 0xA )
248 {
249 pbuf[ 2 * idx] = (value >> 28) + '0';
250 }
251 else
252 {
253 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
254 }
255
256 value = value << 4;
257
258 pbuf[2 * idx + 1] = 0;
259 }
260}
261
267static void get_serial_num(void)
268{
269 uint32_t serial0, serial1, serial2;
270
271 serial0 = *(uint32_t*)MCU_ID1;
272 serial1 = *(uint32_t*)MCU_ID2;
273 serial2 = *(uint32_t*)MCU_ID3;
274
275 serial0 += serial2;
276
277 if (serial0 != 0)
278 {
279 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
280 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
281 }
282}
283
289static usbd_desc_t *get_device_descriptor(void)
290{
291 return &device_descriptor;
292}
293
299static usbd_desc_t * get_device_qualifier(void)
300{
301 return NULL;
302}
303
309static usbd_desc_t *get_device_configuration(void)
310{
311 return &config_descriptor;
312}
313
319static usbd_desc_t *get_device_other_speed(void)
320{
321 return NULL;
322}
323
329static usbd_desc_t *get_device_lang_id(void)
330{
331 return &langid_descriptor;
332}
333
334
340static usbd_desc_t *get_device_manufacturer_string(void)
341{
342 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
343 vp_desc.descriptor = g_usbd_desc_buffer;
344 return &vp_desc;
345}
346
352static usbd_desc_t *get_device_product_string(void)
353{
354 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
355 vp_desc.descriptor = g_usbd_desc_buffer;
356 return &vp_desc;
357}
358
364static usbd_desc_t *get_device_serial_string(void)
365{
366 get_serial_num();
367 return &serial_descriptor;
368}
369
375static usbd_desc_t *get_device_interface_string(void)
376{
377 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
378 vp_desc.descriptor = g_usbd_desc_buffer;
379 return &vp_desc;
380}
381
387static usbd_desc_t *get_device_config_string(void)
388{
389 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_MSC_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
390 vp_desc.descriptor = g_usbd_desc_buffer;
391 return &vp_desc;
392}
393
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_MSC_BULK_IN_EPT
#define USBD_MSC_BULK_IN_EPT
Definition: cdc_msc_class.h:57
USBD_MSC_BULK_OUT_EPT
#define USBD_MSC_BULK_OUT_EPT
Definition: cdc_msc_class.h:58
USBD_OUT_MAXPACKET_SIZE
#define USBD_OUT_MAXPACKET_SIZE
Definition: msc_class.h:53
USBD_IN_MAXPACKET_SIZE
#define USBD_IN_MAXPACKET_SIZE
Definition: msc_class.h:52
USBD_MSC_SIZ_STRING_SERIAL
#define USBD_MSC_SIZ_STRING_SERIAL
Definition: msc_desc.h:57
USBD_MSC_DESC_PRODUCT_STRING
#define USBD_MSC_DESC_PRODUCT_STRING
Definition: msc_desc.h:60
USBD_MSC_DESC_CONFIGURATION_STRING
#define USBD_MSC_DESC_CONFIGURATION_STRING
Definition: msc_desc.h:61
USBD_MSC_DESC_INTERFACE_STRING
#define USBD_MSC_DESC_INTERFACE_STRING
Definition: msc_desc.h:62
USBD_MSC_CONFIG_DESC_SIZE
#define USBD_MSC_CONFIG_DESC_SIZE
Definition: msc_desc.h:55
USBD_MSC_PRODUCT_ID
#define USBD_MSC_PRODUCT_ID
Definition: msc_desc.h:53
USBD_MSC_SIZ_STRING_LANGID
#define USBD_MSC_SIZ_STRING_LANGID
Definition: msc_desc.h:56
USBD_MSC_VENDOR_ID
#define USBD_MSC_VENDOR_ID
Definition: msc_desc.h:52
USBD_MSC_DESC_MANUFACTURER_STRING
#define USBD_MSC_DESC_MANUFACTURER_STRING
Definition: msc_desc.h:59
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: msc_desc.c:201
device_descriptor
static usbd_desc_t device_descriptor
Definition: msc_desc.c:180
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: msc_desc.c:309
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: msc_desc.c:194
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: msc_desc.c:289
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: msc_desc.c:340
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: msc_desc.c:299
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: msc_desc.c:375
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: msc_desc.c:59
vp_desc
static usbd_desc_t vp_desc
Definition: msc_desc.c:207
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: msc_desc.c:319
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: msc_desc.c:84
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: msc_desc.c:352
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: msc_desc.c:387
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: msc_desc.c:215
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: msc_desc.c:329
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: msc_desc.c:267
config_descriptor
static usbd_desc_t config_descriptor
Definition: msc_desc.c:187
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:64
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: msc_desc.c:364
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: msc_desc.c:241
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
USB_CLASS_CODE_MSC
#define USB_CLASS_CODE_MSC
Definition: usb_std.h:165
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
msc_desc.h
usb msc descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: msc_desc.h Source File

  • middlewares
  • usbd_class
  • msc
msc_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __MSC_DESC_H
29#define __MSC_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "msc_class.h"
36#include "usbd_core.h"
37
50#define MSC_BCD_NUM 0x0110
51
52#define USBD_MSC_VENDOR_ID 0x2E3C
53#define USBD_MSC_PRODUCT_ID 0x5720
54
55#define USBD_MSC_CONFIG_DESC_SIZE 32
56#define USBD_MSC_SIZ_STRING_LANGID 4
57#define USBD_MSC_SIZ_STRING_SERIAL 0x1A
58
59#define USBD_MSC_DESC_MANUFACTURER_STRING "Artery"
60#define USBD_MSC_DESC_PRODUCT_STRING "AT32 Mass Storage"
61#define USBD_MSC_DESC_CONFIGURATION_STRING "Mass Storage Config"
62#define USBD_MSC_DESC_INTERFACE_STRING "Mass Storage Interface"
63
64#define MCU_ID1 (0x1FFFF7E8)
65#define MCU_ID2 (0x1FFFF7EC)
66#define MCU_ID3 (0x1FFFF7F0)
67
68extern usbd_desc_handler msc_desc_handler;
69
81#ifdef __cplusplus
82}
83#endif
84
85#endif
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:64
msc_class.h
usb msc class file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: operate_spim.c Source File

  • flash
  • operate_spim
  • src
operate_spim.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "operate_spim.h"
29#include <string.h>
30
31
41uint8_t write_buffer[4096]; /* the content writed to spim flash */
42uint8_t read_buffer[4096]; /* the content read from spim flash */
43
49void spim_init(void)
50{
51 gpio_init_type gpio_init_struct;
52
53 /* enable the clock */
54 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
56 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
57
58 /* init spim io */
59 gpio_default_para_init(&gpio_init_struct);
60 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
61 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
62 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
63 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
64 gpio_init_struct.gpio_pins = GPIO_PINS_8;
65 gpio_init(GPIOA, &gpio_init_struct);
66 gpio_init_struct.gpio_pins = GPIO_PINS_1 | GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_10 | GPIO_PINS_11;
67 gpio_init(GPIOB, &gpio_init_struct);
68
69 /* enable spim, and select pb10, pb11 as spim io */
70 gpio_pin_remap_config(EXT_SPIM_GMUX_1001, TRUE);
71
72 /* in this example, use on-board en25qh128a as spim flash */
73 flash_spim_model_select(FLASH_SPIM_MODEL2);
74
75 /* unlock the spim flash program erase controller */
76 while(flash_flag_get(FLASH_SPIM_OBF_FLAG));
77 flash_spim_unlock();
78 while(FLASH->ctrl3_bit.oplk);
79
80 /* if the data written to spim flash need to be scrambled, please specify the scrambled range */
81 flash_spim_encryption_range_set(0);
82
83 return;
84}
85
93void sector_read(uint32_t address, uint32_t sector_size, uint8_t *buf)
94{
95 while(sector_size)
96 {
97 *(uint32_t *)buf = *(uint32_t *)address;
98 sector_size -= sizeof(uint32_t);
99 address += sizeof(uint32_t);
100 buf += sizeof(uint32_t);
101 }
102}
103
109void spim_operate(void)
110{
111 uint16_t i = 0;
112
113 /* configures the spim flash */
114 spim_init();
115
116 /* fill the content to be writed to spim flash */
117 for(i = 0; i < SPIM_SECTOR_SIZE; i++)
118 {
119 write_buffer[i] = i % 256;
120 }
121
122 /* erase an spim flash sector */
123 flash_sector_erase(SPIM_TEST_ADDR);
124
125 /* read an spim flash sector */
126 memset(read_buffer, 0, SPIM_SECTOR_SIZE);
127 sector_read(SPIM_TEST_ADDR, SPIM_SECTOR_SIZE, read_buffer);
128
129 /* check if the desired sector are erased */
130 for(i = 0; i < SPIM_SECTOR_SIZE; i++)
131 {
132 if(read_buffer[i] != 0xff)
133 {
134 /* test spim fail */
135 return;
136 }
137 }
138
139 /* program an spim flash sector */
140 i = 0;
141 while(i < SPIM_SECTOR_SIZE)
142 {
143 flash_word_program(SPIM_TEST_ADDR + i, *(uint32_t *)(write_buffer + i));
144 i = i + 4;
145 }
146
147 /* read an spim flash sector */
148 memset(read_buffer, 0, SPIM_SECTOR_SIZE);
149 sector_read(SPIM_TEST_ADDR, SPIM_SECTOR_SIZE, read_buffer);
150
151 /* check if reading result and writing content are the same */
152 for(i = 0; i < SPIM_SECTOR_SIZE; i++)
153 {
154 if(read_buffer[i] != write_buffer[i])
155 {
156 /* test spim fail */
157 return;
158 }
159 }
160
161 while(1)
162 {
163 /* toggle led */
164 at32_led_toggle(LED2);
165 delay_ms(100);
166 at32_led_toggle(LED3);
167 delay_ms(100);
168 at32_led_toggle(LED4);
169 delay_ms(100);
170 }
171}
172
173
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
write_buffer
uint8_t write_buffer[4096]
Definition: operate_spim.c:41
SPIM_SECTOR_SIZE
#define SPIM_SECTOR_SIZE
Definition: operate_spim.h:43
sector_read
void sector_read(uint32_t address, uint32_t sector_size, uint8_t *buf)
read one sector from a specified address in spim flash
Definition: operate_spim.c:93
spim_init
void spim_init(void)
init the spim flash
Definition: operate_spim.c:49
read_buffer
uint8_t read_buffer[4096]
Definition: operate_spim.c:42
SPIM_TEST_ADDR
#define SPIM_TEST_ADDR
Definition: operate_spim.h:44
spim_operate
void spim_operate(void)
operate spim flash
Definition: operate_spim.c:109
sector_size
uint32_t sector_size
Definition: composite_vcp_msc/src/msc_diskio.c:36
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
TRUE
@ TRUE
Definition: at32f413.h:259
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_spim_unlock
void flash_spim_unlock(void)
unlock the flash spim controller.
Definition: at32f413_flash.c:240
flash_spim_model_select
void flash_spim_model_select(flash_spim_model_type mode)
select spim supports extended spi flash chip model.
Definition: at32f413_flash.c:798
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_spim_encryption_range_set
void flash_spim_encryption_range_set(uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value,...
Definition: at32f413_flash.c:810
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:59
FLASH_SPIM_MODEL2
@ FLASH_SPIM_MODEL2
Definition: at32f413_flash.h:173
FLASH_SPIM_OBF_FLAG
#define FLASH_SPIM_OBF_FLAG
Definition: at32f413_flash.h:81
FLASH
#define FLASH
Definition: at32f413_flash.h:564
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
EXT_SPIM_GMUX_1001
#define EXT_SPIM_GMUX_1001
Definition: at32f413_gpio.h:191
operate_spim.h
operate_spim header file
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289


AT32F413 Firmwary Library: operate_spim.h Source File

  • flash
  • operate_spim
  • inc
operate_spim.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __OPERATE_SPIM_H
29#define __OPERATE_SPIM_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#define SPIM_SECTOR_SIZE 4096
44#define SPIM_TEST_ADDR 0x08400000
45
50void spim_operate(void);
51
65#ifdef __cplusplus
66}
67#endif
68
69#endif /* __OPERATE_SPIM_H */
spim_operate
void spim_operate(void)
operate spim flash
Definition: operate_spim.c:109


AT32F413 Firmwary Library: printer_class.c Source File

  • middlewares
  • usbd_class
  • printer
printer_class.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "printer_class.h"
28#include "printer_desc.h"
29
43static usb_sts_type class_init_handler(void *udev);
44static usb_sts_type class_clear_handler(void *udev);
45static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup);
46static usb_sts_type class_ept0_tx_handler(void *udev);
47static usb_sts_type class_ept0_rx_handler(void *udev);
48static usb_sts_type class_in_handler(void *udev, uint8_t ept_num);
49static usb_sts_type class_out_handler(void *udev, uint8_t ept_num);
50static usb_sts_type class_sof_handler(void *udev);
51static usb_sts_type class_event_handler(void *udev, usbd_event_type event);
52
53ALIGNED_HEAD static uint8_t printer_device_id[PRINTER_DEVICE_ID_LEN] ALIGNED_TAIL=
54{
55 0x00, 0x16,
56 'M', 'F', 'G',':','A','r','t','e', 'r', 'y' ,' ',
57 'C','M', 'D', ':', 'E', 'S', 'C', 'P', 'O', 'S',' ',
58};
59
60/* static variable */
61 printer_type printer_struct;
62
63/* usb device class handler */
64 usbd_class_handler printer_class_handler =
65{
66 class_init_handler,
67 class_clear_handler,
68 class_setup_handler,
69 class_ept0_tx_handler,
70 class_ept0_rx_handler,
71 class_in_handler,
72 class_out_handler,
73 class_sof_handler,
74 class_event_handler,
75 &printer_struct
76};
77
83static usb_sts_type class_init_handler(void *udev)
84{
85 usb_sts_type status = USB_OK;
86 usbd_core_type *pudev = (usbd_core_type *)udev;
87 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
88
89 /* open in endpoint */
90 usbd_ept_open(pudev, USBD_PRINTER_BULK_IN_EPT, EPT_BULK_TYPE, USBD_PRINTER_IN_MAXPACKET_SIZE);
91
92 /* open out endpoint */
93 usbd_ept_open(pudev, USBD_PRINTER_BULK_OUT_EPT, EPT_BULK_TYPE, USBD_PRINTER_OUT_MAXPACKET_SIZE);
94
95 /* set out endpoint to receive status */
96 usbd_ept_recv(pudev, USBD_PRINTER_BULK_OUT_EPT, pprter->g_rx_buff, USBD_PRINTER_OUT_MAXPACKET_SIZE);
97
98 pprter->g_tx_completed = 1;
99 pprter->g_printer_port_status = 0x18;
100
101 return status;
102}
103
109static usb_sts_type class_clear_handler(void *udev)
110{
111 usb_sts_type status = USB_OK;
112 usbd_core_type *pudev = (usbd_core_type *)udev;
113
114 /* close in endpoint */
115 usbd_ept_close(pudev, USBD_PRINTER_BULK_IN_EPT);
116
117 /* close out endpoint */
118 usbd_ept_close(pudev, USBD_PRINTER_BULK_OUT_EPT);
119
120 return status;
121}
122
129static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
130{
131 usb_sts_type status = USB_OK;
132 usbd_core_type *pudev = (usbd_core_type *)udev;
133 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
134
135 switch(setup->bmRequestType & USB_REQ_TYPE_RESERVED)
136 {
137 /* class request */
138 case USB_REQ_TYPE_CLASS:
139 switch(setup->bRequest)
140 {
141 case PRINTER_REQ_GET_DEVICE_ID:
142 usbd_ctrl_send(pudev, printer_device_id, PRINTER_DEVICE_ID_LEN);
143 break;
144 case PRINTER_REQ_GET_PORT_STATUS:
145 usbd_ctrl_send(pudev, (uint8_t *)&pprter->g_printer_port_status, 1);
146 break;
147 case PRINTER_REQ_GET_SOFT_RESET:
148 usbd_ctrl_recv(pudev, pprter->g_printer_data, USBD_PRINTER_OUT_MAXPACKET_SIZE);
149 break;
150 default:
151 usbd_ctrl_unsupport(pudev);
152 break;
153 }
154 break;
155 /* standard request */
156 case USB_REQ_TYPE_STANDARD:
157 switch(setup->bRequest)
158 {
159 case USB_STD_REQ_GET_DESCRIPTOR:
160 usbd_ctrl_unsupport(pudev);
161 break;
162 case USB_STD_REQ_GET_INTERFACE:
163 usbd_ctrl_send(pudev, (uint8_t *)&pprter->alt_setting, 1);
164 break;
165 case USB_STD_REQ_SET_INTERFACE:
166 pprter->alt_setting = setup->wValue;
167 break;
168 default:
169 break;
170 }
171 break;
172 default:
173 usbd_ctrl_unsupport(pudev);
174 break;
175 }
176 return status;
177}
178
184static usb_sts_type class_ept0_tx_handler(void *udev)
185{
186 usb_sts_type status = USB_OK;
187
188 /* ...user code... */
189
190 return status;
191}
192
198static usb_sts_type class_ept0_rx_handler(void *udev)
199{
200 usb_sts_type status = USB_OK;
201
202 /* ...user code... */
203
204 return status;
205}
206
213static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
214{
215 usbd_core_type *pudev = (usbd_core_type *)udev;
216 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
217 usb_sts_type status = USB_OK;
218
219 /* ...user code...
220 trans next packet data
221 */
222 pprter->g_tx_completed = 1;
223
224 return status;
225}
226
233static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
234{
235 usb_sts_type status = USB_OK;
236 usbd_core_type *pudev = (usbd_core_type *)udev;
237 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
238 /* get endpoint receive data length */
239 pprter->g_rxlen = usbd_get_recv_len(pudev, ept_num);
240
241 /*set recv flag*/
242 pprter->g_rx_completed = 1;
243
244 return status;
245}
246
252static usb_sts_type class_sof_handler(void *udev)
253{
254 usb_sts_type status = USB_OK;
255
256 /* ...user code... */
257
258 return status;
259}
260
267static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
268{
269 usb_sts_type status = USB_OK;
270 switch(event)
271 {
272 case USBD_RESET_EVENT:
273
274 /* ...user code... */
275
276 break;
277 case USBD_SUSPEND_EVENT:
278
279 /* ...user code... */
280
281 break;
282 case USBD_WAKEUP_EVENT:
283 /* ...user code... */
284
285 break;
286
287 default:
288 break;
289 }
290 return status;
291}
292
299uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data)
300{
301 uint16_t i_index = 0;
302 usbd_core_type *pudev = (usbd_core_type *)udev;
303 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
304 uint16_t tmp_len = 0;
305
306 if(pprter->g_rx_completed == 0)
307 {
308 return 0;
309 }
310 pprter->g_rx_completed = 0;
311 tmp_len = pprter->g_rxlen;
312 for(i_index = 0; i_index < pprter->g_rxlen; i_index ++)
313 {
314 recv_data[i_index] = pprter->g_rx_buff[i_index];
315 }
316
317 usbd_ept_recv(pudev, USBD_PRINTER_BULK_OUT_EPT, pprter->g_rx_buff, USBD_PRINTER_OUT_MAXPACKET_SIZE);
318
319 return tmp_len;
320}
321
329 error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len)
330{
331 error_status status = SUCCESS;
332 usbd_core_type *pudev = (usbd_core_type *)udev;
333 printer_type *pprter = (printer_type *)pudev->class_handler->pdata;
334 if(pprter->g_tx_completed)
335 {
336 pprter->g_tx_completed = 0;
337 usbd_ept_send(pudev, USBD_PRINTER_BULK_IN_EPT, send_data, len);
338 }
339 else
340 {
341 status = ERROR;
342 }
343 return status;
344}
345
346
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
EPT_BULK_TYPE
@ EPT_BULK_TYPE
Definition: at32f413_usb.h:204
USBD_PRINTER_OUT_MAXPACKET_SIZE
#define USBD_PRINTER_OUT_MAXPACKET_SIZE
Definition: printer_class.h:55
USBD_PRINTER_IN_MAXPACKET_SIZE
#define USBD_PRINTER_IN_MAXPACKET_SIZE
Definition: printer_class.h:54
PRINTER_DEVICE_ID_LEN
#define PRINTER_DEVICE_ID_LEN
Definition: printer_class.h:57
USBD_PRINTER_BULK_OUT_EPT
#define USBD_PRINTER_BULK_OUT_EPT
Definition: printer_class.h:51
USBD_PRINTER_BULK_IN_EPT
#define USBD_PRINTER_BULK_IN_EPT
Definition: printer_class.h:50
PRINTER_REQ_GET_SOFT_RESET
@ PRINTER_REQ_GET_SOFT_RESET
Definition: printer_class.h:63
PRINTER_REQ_GET_PORT_STATUS
@ PRINTER_REQ_GET_PORT_STATUS
Definition: printer_class.h:62
PRINTER_REQ_GET_DEVICE_ID
@ PRINTER_REQ_GET_DEVICE_ID
Definition: printer_class.h:61
class_sof_handler
static usb_sts_type class_sof_handler(void *udev)
usb device sof handler
Definition: printer_class.c:252
class_in_handler
static usb_sts_type class_in_handler(void *udev, uint8_t ept_num)
usb device transmision complete handler
Definition: printer_class.c:213
class_clear_handler
static usb_sts_type class_clear_handler(void *udev)
clear endpoint or other state
Definition: printer_class.c:109
class_setup_handler
static usb_sts_type class_setup_handler(void *udev, usb_setup_type *setup)
usb device class setup request handler
Definition: printer_class.c:129
usb_printer_get_rxdata
uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: printer_class.c:299
class_ept0_tx_handler
static usb_sts_type class_ept0_tx_handler(void *udev)
usb device endpoint 0 in status stage complete
Definition: printer_class.c:184
printer_class_handler
usbd_class_handler printer_class_handler
Definition: printer_class.c:64
class_ept0_rx_handler
static usb_sts_type class_ept0_rx_handler(void *udev)
usb device endpoint 0 out status stage complete
Definition: printer_class.c:198
class_event_handler
static usb_sts_type class_event_handler(void *udev, usbd_event_type event)
usb device event handler
Definition: printer_class.c:267
usb_printer_send_data
error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: printer_class.c:329
class_init_handler
static usb_sts_type class_init_handler(void *udev)
initialize usb custom hid endpoint
Definition: printer_class.c:83
class_out_handler
static usb_sts_type class_out_handler(void *udev, uint8_t ept_num)
usb device endpoint receive data
Definition: printer_class.c:233
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t printer_device_id[24] ALIGNED_TAIL
Definition: printer_class.c:53
printer_struct
printer_type printer_struct
Definition: printer_class.c:61
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
USB_STD_REQ_SET_INTERFACE
#define USB_STD_REQ_SET_INTERFACE
Definition: usb_std.h:86
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_STD_REQ_GET_INTERFACE
#define USB_STD_REQ_GET_INTERFACE
Definition: usb_std.h:85
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
printer_class.h
usb printer class file
printer_desc.h
usb printer descriptor header file
printer_type
Definition: printer_class.h:68
printer_type::g_printer_data
uint8_t g_printer_data[0x40]
Definition: printer_class.h:72
printer_type::g_rxlen
uint32_t g_rxlen
Definition: printer_class.h:75
printer_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: printer_class.h:74
printer_type::g_printer_port_status
uint32_t g_printer_port_status
Definition: printer_class.h:70
printer_type::g_rx_buff
uint8_t g_rx_buff[0x40]
Definition: printer_class.h:71
printer_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: printer_class.h:73
printer_type::alt_setting
uint32_t alt_setting
Definition: printer_class.h:69
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: printer_class.h Source File

  • middlewares
  • usbd_class
  • printer
printer_class.h
Go to the documentation of this file.
1
27 /* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __PRINTER_CLASS_H
29#define __PRINTER_CLASS_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "usb_std.h"
36#include "usbd_core.h"
37
50#define USBD_PRINTER_BULK_IN_EPT 0x81
51#define USBD_PRINTER_BULK_OUT_EPT 0x01
52
53
54#define USBD_PRINTER_IN_MAXPACKET_SIZE 0x40
55#define USBD_PRINTER_OUT_MAXPACKET_SIZE 0x40
56
57#define PRINTER_DEVICE_ID_LEN 24
58
59typedef enum
60{
61 PRINTER_REQ_GET_DEVICE_ID = 0x00,
62 PRINTER_REQ_GET_PORT_STATUS = 0x01,
63 PRINTER_REQ_GET_SOFT_RESET = 0x02
64}printer_req_type;
65
66
67typedef struct
68{
69 uint32_t alt_setting;
70 uint32_t g_printer_port_status;
71 uint8_t g_rx_buff[USBD_PRINTER_OUT_MAXPACKET_SIZE];
72 uint8_t g_printer_data[USBD_PRINTER_OUT_MAXPACKET_SIZE];
73 __IO uint8_t g_tx_completed;
74 __IO uint8_t g_rx_completed;
75 uint32_t g_rxlen;
76}printer_type;
77
78extern usbd_class_handler printer_class_handler;
79uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data);
80 error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len);
92#ifdef __cplusplus
93}
94#endif
95
96#endif
97
error_status
error_status
error status
Definition: at32f413.h:264
printer_req_type
printer_req_type
Definition: printer_class.h:60
USBD_PRINTER_OUT_MAXPACKET_SIZE
#define USBD_PRINTER_OUT_MAXPACKET_SIZE
Definition: printer_class.h:55
usb_printer_get_rxdata
uint16_t usb_printer_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: printer_class.c:299
printer_class_handler
usbd_class_handler printer_class_handler
Definition: printer_class.c:64
usb_printer_send_data
error_status usb_printer_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: printer_class.c:329
PRINTER_REQ_GET_SOFT_RESET
@ PRINTER_REQ_GET_SOFT_RESET
Definition: printer_class.h:63
PRINTER_REQ_GET_PORT_STATUS
@ PRINTER_REQ_GET_PORT_STATUS
Definition: printer_class.h:62
PRINTER_REQ_GET_DEVICE_ID
@ PRINTER_REQ_GET_DEVICE_ID
Definition: printer_class.h:61
printer_type
Definition: printer_class.h:68
printer_type::g_rxlen
uint32_t g_rxlen
Definition: printer_class.h:75
printer_type::g_rx_completed
__IO uint8_t g_rx_completed
Definition: printer_class.h:74
printer_type::g_printer_port_status
uint32_t g_printer_port_status
Definition: printer_class.h:70
printer_type::g_tx_completed
__IO uint8_t g_tx_completed
Definition: printer_class.h:73
printer_type::alt_setting
uint32_t alt_setting
Definition: printer_class.h:69
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usb_std.h
usb standard header file
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: printer_desc.c Source File

  • middlewares
  • usbd_class
  • printer
printer_desc.c
Go to the documentation of this file.
1
26#include "stdio.h"
27#include "usb_std.h"
28#include "usbd_sdr.h"
29#include "usbd_core.h"
30#include "printer_desc.h"
31
45static usbd_desc_t *get_device_descriptor(void);
46static usbd_desc_t *get_device_qualifier(void);
47static usbd_desc_t *get_device_configuration(void);
48static usbd_desc_t *get_device_other_speed(void);
49static usbd_desc_t *get_device_lang_id(void);
50static usbd_desc_t *get_device_manufacturer_string(void);
51static usbd_desc_t *get_device_product_string(void);
52static usbd_desc_t *get_device_serial_string(void);
53static usbd_desc_t *get_device_interface_string(void);
54static usbd_desc_t *get_device_config_string(void);
55
56static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf);
57static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len);
58static void get_serial_num(void);
59static uint8_t g_usbd_desc_buffer[256];
60
64 usbd_desc_handler printer_desc_handler =
65{
66 get_device_descriptor,
67 get_device_qualifier,
68 get_device_configuration,
69 get_device_other_speed,
70 get_device_lang_id,
71 get_device_manufacturer_string,
72 get_device_product_string,
73 get_device_serial_string,
74 get_device_interface_string,
75 get_device_config_string,
76};
77
81#if defined ( __ICCARM__ ) /* iar compiler */
82 #pragma data_alignment=4
83#endif
84ALIGNED_HEAD static uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL =
85{
86 USB_DEVICE_DESC_LEN, /* bLength */
87 USB_DESCIPTOR_TYPE_DEVICE, /* bDescriptorType */
88 0x00, /* bcdUSB */
89 0x02,
90 0x00, /* bDeviceClass */
91 0x00, /* bDeviceSubClass */
92 0x00, /* bDeviceProtocol */
93 USB_MAX_EP0_SIZE, /* bMaxPacketSize */
94 LBYTE(USBD_PRINTER_VENDOR_ID), /* idVendor */
95 HBYTE(USBD_PRINTER_VENDOR_ID), /* idVendor */
96 LBYTE(USBD_PRINTER_PRODUCT_ID), /* idProduct */
97 HBYTE(USBD_PRINTER_PRODUCT_ID), /* idProduct */
98 0x00, /* bcdDevice rel. 2.00 */
99 0x02,
100 USB_MFC_STRING, /* Index of manufacturer string */
101 USB_PRODUCT_STRING, /* Index of product string */
102 USB_SERIAL_STRING, /* Index of serial number string */
103 1 /* bNumConfigurations */
104};
105
109#if defined ( __ICCARM__ ) /* iar compiler */
110 #pragma data_alignment=4
111#endif
112ALIGNED_HEAD static uint8_t g_usbd_configuration[USBD_PRINTER_CONFIG_DESC_SIZE] ALIGNED_TAIL =
113{
114 USB_DEVICE_CFG_DESC_LEN, /* bLength: configuration descriptor size */
115 USB_DESCIPTOR_TYPE_CONFIGURATION, /* bDescriptorType: configuration */
116 LBYTE(USBD_PRINTER_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
117 HBYTE(USBD_PRINTER_CONFIG_DESC_SIZE), /* wTotalLength: bytes returned */
118 0x01, /* bNumInterfaces: 1 interface */
119 0x01, /* bConfigurationValue: configuration value */
120 0x00, /* iConfiguration: index of string descriptor describing
121 the configuration */
122 0xC0, /* bmAttributes: self powered */
123 0x32, /* MaxPower 100 mA: this current is used for detecting vbus */
124
125 USB_DEVICE_IF_DESC_LEN, /* bLength: interface descriptor size */
126 USB_DESCIPTOR_TYPE_INTERFACE, /* bDescriptorType: interface descriptor type */
127 0x00, /* bInterfaceNumber: number of interface */
128 0x00, /* bAlternateSetting: alternate set */
129 0x02, /* bNumEndpoints: number of endpoints */
130 USB_CLASS_CODE_PRINTER, /* bInterfaceClass: printer class code */
131 0x01, /* bInterfaceSubClass: subclass code*/
132 PRINTER_PROTOCOL_BI_DIRECTIONAL, /* bInterfaceProtocol: printer interface type */
133 0x00, /* iInterface: index of string descriptor */
134
135 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
136 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
137 USBD_PRINTER_BULK_IN_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
138 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
139 LBYTE(USBD_PRINTER_IN_MAXPACKET_SIZE),
140 HBYTE(USBD_PRINTER_IN_MAXPACKET_SIZE), /* wMaxPacketSize: maximum packe size this endpoint */
141 0x00, /* bInterval: interval for polling endpoint for data transfers */
142
143 USB_DEVICE_EPT_LEN, /* bLength: size of endpoint descriptor in bytes */
144 USB_DESCIPTOR_TYPE_ENDPOINT, /* bDescriptorType: endpoint descriptor type */
145 USBD_PRINTER_BULK_OUT_EPT, /* bEndpointAddress: the address of endpoint on usb device described by this descriptor */
146 USB_EPT_DESC_BULK, /* bmAttributes: endpoint attributes */
147 LBYTE(USBD_PRINTER_OUT_MAXPACKET_SIZE),
148 HBYTE(USBD_PRINTER_OUT_MAXPACKET_SIZE),/* wMaxPacketSize: maximum packe size this endpoint */
149 0x00, /* bInterval: interval for polling endpoint for data transfers */
150};
151
155#if defined ( __ICCARM__ ) /* iar compiler */
156 #pragma data_alignment=4
157#endif
158ALIGNED_HEAD static uint8_t g_string_lang_id[USBD_PRINTER_SIZ_STRING_LANGID] ALIGNED_TAIL =
159{
160 USBD_PRINTER_SIZ_STRING_LANGID,
161 USB_DESCIPTOR_TYPE_STRING,
162 0x09,
163 0x04,
164};
165
169#if defined ( __ICCARM__ ) /* iar compiler */
170 #pragma data_alignment=4
171#endif
172ALIGNED_HEAD static uint8_t g_string_serial[USBD_PRINTER_SIZ_STRING_SERIAL] ALIGNED_TAIL =
173{
174 USBD_PRINTER_SIZ_STRING_SERIAL,
175 USB_DESCIPTOR_TYPE_STRING,
176};
177
178
179/* device descriptor */
180static usbd_desc_t device_descriptor =
181{
182 USB_DEVICE_DESC_LEN,
183 g_usbd_descriptor
184};
185
186/* config descriptor */
187static usbd_desc_t config_descriptor =
188{
189 USBD_PRINTER_CONFIG_DESC_SIZE,
190 g_usbd_configuration
191};
192
193/* langid descriptor */
194static usbd_desc_t langid_descriptor =
195{
196 USBD_PRINTER_SIZ_STRING_LANGID,
197 g_string_lang_id
198};
199
200/* serial descriptor */
201static usbd_desc_t serial_descriptor =
202{
203 USBD_PRINTER_SIZ_STRING_SERIAL,
204 g_string_serial
205};
206
207static usbd_desc_t vp_desc;
208
215static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
216{
217 uint16_t str_len = 0, id_pos = 2;
218 uint8_t *tmp_str = string;
219
220 while(*tmp_str != '\0')
221 {
222 str_len ++;
223 unicode_buf[id_pos ++] = *tmp_str ++;
224 unicode_buf[id_pos ++] = 0x00;
225 }
226
227 str_len = str_len * 2 + 2;
228 unicode_buf[0] = (uint8_t)str_len;
229 unicode_buf[1] = USB_DESCIPTOR_TYPE_STRING;
230
231 return str_len;
232}
233
241static void usbd_int_to_unicode (uint32_t value , uint8_t *pbuf , uint8_t len)
242{
243 uint8_t idx = 0;
244
245 for( idx = 0 ; idx < len ; idx ++)
246 {
247 if( ((value >> 28)) < 0xA )
248 {
249 pbuf[ 2 * idx] = (value >> 28) + '0';
250 }
251 else
252 {
253 pbuf[2 * idx] = (value >> 28) + 'A' - 10;
254 }
255
256 value = value << 4;
257
258 pbuf[2 * idx + 1] = 0;
259 }
260}
261
267static void get_serial_num(void)
268{
269 uint32_t serial0, serial1, serial2;
270
271 serial0 = *(uint32_t*)MCU_ID1;
272 serial1 = *(uint32_t*)MCU_ID2;
273 serial2 = *(uint32_t*)MCU_ID3;
274
275 serial0 += serial2;
276
277 if (serial0 != 0)
278 {
279 usbd_int_to_unicode (serial0, &g_string_serial[2] ,8);
280 usbd_int_to_unicode (serial1, &g_string_serial[18] ,4);
281 }
282}
283
289static usbd_desc_t *get_device_descriptor(void)
290{
291 return &device_descriptor;
292}
293
299static usbd_desc_t * get_device_qualifier(void)
300{
301 return NULL;
302}
303
309static usbd_desc_t *get_device_configuration(void)
310{
311 return &config_descriptor;
312}
313
319static usbd_desc_t *get_device_other_speed(void)
320{
321 return NULL;
322}
323
329static usbd_desc_t *get_device_lang_id(void)
330{
331 return &langid_descriptor;
332}
333
334
340static usbd_desc_t *get_device_manufacturer_string(void)
341{
342 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_MANUFACTURER_STRING, g_usbd_desc_buffer);
343 vp_desc.descriptor = g_usbd_desc_buffer;
344 return &vp_desc;
345}
346
352static usbd_desc_t *get_device_product_string(void)
353{
354 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_PRODUCT_STRING, g_usbd_desc_buffer);
355 vp_desc.descriptor = g_usbd_desc_buffer;
356 return &vp_desc;
357}
358
364static usbd_desc_t *get_device_serial_string(void)
365{
366 get_serial_num();
367 return &serial_descriptor;
368}
369
375static usbd_desc_t *get_device_interface_string(void)
376{
377 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_INTERFACE_STRING, g_usbd_desc_buffer);
378 vp_desc.descriptor = g_usbd_desc_buffer;
379 return &vp_desc;
380}
381
387static usbd_desc_t *get_device_config_string(void)
388{
389 vp_desc.length = usbd_unicode_convert((uint8_t *)USBD_PRINTER_DESC_CONFIGURATION_STRING, g_usbd_desc_buffer);
390 vp_desc.descriptor = g_usbd_desc_buffer;
391 return &vp_desc;
392}
393
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
MCU_ID1
#define MCU_ID1
Definition: audio_desc.h:215
MCU_ID2
#define MCU_ID2
Definition: audio_desc.h:216
MCU_ID3
#define MCU_ID3
Definition: audio_desc.h:217
USBD_PRINTER_OUT_MAXPACKET_SIZE
#define USBD_PRINTER_OUT_MAXPACKET_SIZE
Definition: printer_class.h:55
USBD_PRINTER_IN_MAXPACKET_SIZE
#define USBD_PRINTER_IN_MAXPACKET_SIZE
Definition: printer_class.h:54
USBD_PRINTER_BULK_OUT_EPT
#define USBD_PRINTER_BULK_OUT_EPT
Definition: printer_class.h:51
USBD_PRINTER_BULK_IN_EPT
#define USBD_PRINTER_BULK_IN_EPT
Definition: printer_class.h:50
USBD_PRINTER_DESC_PRODUCT_STRING
#define USBD_PRINTER_DESC_PRODUCT_STRING
Definition: printer_desc.h:60
USBD_PRINTER_CONFIG_DESC_SIZE
#define USBD_PRINTER_CONFIG_DESC_SIZE
Definition: printer_desc.h:55
USBD_PRINTER_DESC_CONFIGURATION_STRING
#define USBD_PRINTER_DESC_CONFIGURATION_STRING
Definition: printer_desc.h:61
PRINTER_PROTOCOL_BI_DIRECTIONAL
#define PRINTER_PROTOCOL_BI_DIRECTIONAL
Definition: printer_desc.h:65
USBD_PRINTER_DESC_INTERFACE_STRING
#define USBD_PRINTER_DESC_INTERFACE_STRING
Definition: printer_desc.h:62
USBD_PRINTER_DESC_MANUFACTURER_STRING
#define USBD_PRINTER_DESC_MANUFACTURER_STRING
Definition: printer_desc.h:59
USBD_PRINTER_PRODUCT_ID
#define USBD_PRINTER_PRODUCT_ID
Definition: printer_desc.h:53
USBD_PRINTER_SIZ_STRING_SERIAL
#define USBD_PRINTER_SIZ_STRING_SERIAL
Definition: printer_desc.h:57
USBD_PRINTER_SIZ_STRING_LANGID
#define USBD_PRINTER_SIZ_STRING_LANGID
Definition: printer_desc.h:56
USBD_PRINTER_VENDOR_ID
#define USBD_PRINTER_VENDOR_ID
Definition: printer_desc.h:52
serial_descriptor
static usbd_desc_t serial_descriptor
Definition: printer_desc.c:201
device_descriptor
static usbd_desc_t device_descriptor
Definition: printer_desc.c:180
get_device_configuration
static usbd_desc_t * get_device_configuration(void)
get config descriptor
Definition: printer_desc.c:309
langid_descriptor
static usbd_desc_t langid_descriptor
Definition: printer_desc.c:194
get_device_descriptor
static usbd_desc_t * get_device_descriptor(void)
get device descriptor
Definition: printer_desc.c:289
get_device_manufacturer_string
static usbd_desc_t * get_device_manufacturer_string(void)
get manufacturer descriptor
Definition: printer_desc.c:340
get_device_qualifier
static usbd_desc_t * get_device_qualifier(void)
get device qualifier
Definition: printer_desc.c:299
get_device_interface_string
static usbd_desc_t * get_device_interface_string(void)
get interface descriptor
Definition: printer_desc.c:375
g_usbd_desc_buffer
static uint8_t g_usbd_desc_buffer[256]
Definition: printer_desc.c:59
vp_desc
static usbd_desc_t vp_desc
Definition: printer_desc.c:207
get_device_other_speed
static usbd_desc_t * get_device_other_speed(void)
get other speed descriptor
Definition: printer_desc.c:319
ALIGNED_TAIL
static ALIGNED_HEAD uint8_t g_usbd_descriptor[USB_DEVICE_DESC_LEN] ALIGNED_TAIL
usb device standard descriptor
Definition: printer_desc.c:84
get_device_product_string
static usbd_desc_t * get_device_product_string(void)
get product descriptor
Definition: printer_desc.c:352
get_device_config_string
static usbd_desc_t * get_device_config_string(void)
get device config descriptor
Definition: printer_desc.c:387
usbd_unicode_convert
static uint16_t usbd_unicode_convert(uint8_t *string, uint8_t *unicode_buf)
standard usb unicode convert
Definition: printer_desc.c:215
printer_desc_handler
usbd_desc_handler printer_desc_handler
device descriptor handler structure
Definition: printer_desc.c:64
get_device_lang_id
static usbd_desc_t * get_device_lang_id(void)
get lang id descriptor
Definition: printer_desc.c:329
get_serial_num
static void get_serial_num(void)
usb get serial number
Definition: printer_desc.c:267
config_descriptor
static usbd_desc_t config_descriptor
Definition: printer_desc.c:187
get_device_serial_string
static usbd_desc_t * get_device_serial_string(void)
get serial descriptor
Definition: printer_desc.c:364
usbd_int_to_unicode
static void usbd_int_to_unicode(uint32_t value, uint8_t *pbuf, uint8_t len)
usb int convert to unicode
Definition: printer_desc.c:241
USB_CLASS_CODE_PRINTER
#define USB_CLASS_CODE_PRINTER
Definition: usb_std.h:164
HBYTE
#define HBYTE(x)
Definition: usb_std.h:261
USB_DEVICE_EPT_LEN
#define USB_DEVICE_EPT_LEN
Definition: usb_std.h:153
USB_MAX_EP0_SIZE
#define USB_MAX_EP0_SIZE
endpoint 0 max size
Definition: usb_std.h:242
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_DESCIPTOR_TYPE_ENDPOINT
#define USB_DESCIPTOR_TYPE_ENDPOINT
Definition: usb_std.h:96
USB_DEVICE_DESC_LEN
#define USB_DEVICE_DESC_LEN
Definition: usb_std.h:150
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_EPT_DESC_BULK
#define USB_EPT_DESC_BULK
Definition: usb_std.h:177
USB_DEVICE_IF_DESC_LEN
#define USB_DEVICE_IF_DESC_LEN
Definition: usb_std.h:152
USB_DEVICE_CFG_DESC_LEN
#define USB_DEVICE_CFG_DESC_LEN
Definition: usb_std.h:151
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_DESCIPTOR_TYPE_INTERFACE
#define USB_DESCIPTOR_TYPE_INTERFACE
Definition: usb_std.h:95
printer_desc.h
usb printer descriptor header file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usb_std.h
usb standard header file
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: printer_desc.h Source File

  • middlewares
  • usbd_class
  • printer
printer_desc.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __PRINTER_DESC_H
29#define __PRINTER_DESC_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "printer_class.h"
36#include "usbd_core.h"
37
50#define PRINTER_BCD_NUM 0x0110
51
52#define USBD_PRINTER_VENDOR_ID 0x2E3C
53#define USBD_PRINTER_PRODUCT_ID 0x57FF
54
55#define USBD_PRINTER_CONFIG_DESC_SIZE 32
56#define USBD_PRINTER_SIZ_STRING_LANGID 4
57#define USBD_PRINTER_SIZ_STRING_SERIAL 0x1A
58
59#define USBD_PRINTER_DESC_MANUFACTURER_STRING "Artery"
60#define USBD_PRINTER_DESC_PRODUCT_STRING "AT32 Printer"
61#define USBD_PRINTER_DESC_CONFIGURATION_STRING "Printer Config"
62#define USBD_PRINTER_DESC_INTERFACE_STRING "Printer Interface"
63
64#define PRINTER_PROTOCOL_UNIDIRECTIONAL 0x01
65#define PRINTER_PROTOCOL_BI_DIRECTIONAL 0x02
66#define PRINTER_PROTOCOL_1284_4 0x03
67#define PRINTER_PROTOCOL_VENDOR_SPECIFIC 0xFF
68
69
70#define MCU_ID1 (0x1FFFF7E8)
71#define MCU_ID2 (0x1FFFF7EC)
72#define MCU_ID3 (0x1FFFF7F0)
73
74
75extern usbd_desc_handler printer_desc_handler;
76
88#ifdef __cplusplus
89}
90#endif
91
92#endif
printer_desc_handler
usbd_desc_handler printer_desc_handler
device descriptor handler structure
Definition: printer_desc.c:64
printer_class.h
usb printer class file
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • acc
  • calibration
  • inc
project/at_start_f413/examples/acc/calibration/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • acc
  • calibration
  • inc
project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • acc
  • calibration
  • inc
project/at_start_f413/examples/acc/calibration/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:113


AT32F413 Firmwary Library: usb_conf.h Source File

  • acc
  • calibration
  • inc
project/at_start_f413/examples/acc/calibration/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX
58
59
63//#define USB_EPT_AUTO_MALLOC_BUFFER
64
65
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
76
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
79
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
82
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
85
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
88
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
91
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
94
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
97
98#endif
99void usb_delay_ms(uint32_t ms);
100void usb_delay_us(uint32_t us);
101
109#ifdef __cplusplus
110}
111#endif
112
113#endif
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • acc
  • calibration
  • src
project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • acc
  • calibration
  • src
project/at_start_f413/examples/acc/calibration/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • acc
  • calibration
  • src
project/at_start_f413/examples/acc/calibration/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "cdc_class.h"
31#include "cdc_desc.h"
32#include "usbd_int.h"
33
34
35
44 usbd_core_type usb_core_dev;
45uint8_t usb_buffer[256];
46
47/* select system clock source from hext or hick */
48//#define SCLK_FROM_HEXT
49#define SCLK_FROM_HICK
50
51/* select acc calibration mode */
52//#define ACC_CAL
53#define ACC_TRIM
54
55void system_clock_config_for_acc(void);
56void clkout_config(void);
57
58uint32_t acc_c2_value = 0;
59
60
66void usb_clock48m_select(usb_clk48_s clk_s)
67{
68 if(clk_s == USB_CLK_HICK)
69 {
70 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
71 }
72 else
73 {
74 switch(system_core_clock)
75 {
76 /* 48MHz */
77 case 48000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1);
79 break;
80
81 /* 72MHz */
82 case 72000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
84 break;
85
86 /* 96MHz */
87 case 96000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2);
89 break;
90
91 /* 120MHz */
92 case 120000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
94 break;
95
96 /* 144MHz */
97 case 144000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3);
99 break;
100
101 /* 168MHz */
102 case 168000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
104 break;
105
106 /* 192MHz */
107 case 192000000:
108 crm_usb_clock_div_set(CRM_USB_DIV_4);
109 break;
110
111 default:
112 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
113 break;
114 }
115 }
116}
117
123void USBFS_L_CAN1_RX0_IRQHandler(void)
124{
125 usbd_irq_handler(&usb_core_dev);
126}
127
133void ACC_IRQHandler(void)
134{
135 if(acc_flag_get(ACC_CALRDY_FLAG) != RESET)
136 {
137 at32_led_toggle(LED2);
138
139 /* clear acc calibration ready flag */
140 acc_flag_clear(ACC_CALRDY_FLAG);
141 }
142 if(acc_flag_get(ACC_RSLOST_FLAG) != RESET)
143 {
144 at32_led_toggle(LED3);
145
146 /* clear acc reference signal lost flag */
147 acc_flag_clear(ACC_RSLOST_FLAG);
148 }
149}
150
156void system_clock_config_for_acc(void)
157{
158 /* reset crm */
159 crm_reset();
160
161 #ifdef SCLK_FROM_HICK
162 crm_clock_source_enable(CRM_CLOCK_SOURCE_HICK, TRUE);
163 #elif defined SCLK_FROM_HEXT
164 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
165 #endif
166
167 /* wait till hick is ready */
168 while(SET != crm_flag_get(CRM_HICK_STABLE_FLAG))
169 {
170 }
171
172 /* config pll clock resource */
173 crm_pll_config(CRM_PLL_SOURCE_HICK, CRM_PLL_MULT_60, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
174
175 /* enable pll */
176 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
177
178 /* wait till pll is ready */
179 while(SET != crm_flag_get(CRM_PLL_STABLE_FLAG))
180 {
181 }
182
183 /* config ahbclk */
184 crm_ahb_div_set(CRM_AHB_DIV_1);
185
186 /* config apb2clk */
187 crm_apb2_div_set(CRM_APB2_DIV_2);
188
189 /* config apb1clk */
190 crm_apb1_div_set(CRM_APB1_DIV_2);
191
192 /* enable auto step mode */
193 crm_auto_step_mode_enable(TRUE);
194
195 /* select pll as system clock source */
196 crm_sysclk_switch(CRM_SCLK_PLL);
197
198 /* wait till pll is used as system clock source */
199 while(CRM_SCLK_PLL != crm_sysclk_switch_status_get())
200 {
201 }
202
203 /* disable auto step mode */
204 crm_auto_step_mode_enable(FALSE);
205
206 /* update system_core_clock global variable */
207 system_core_clock_update();
208
209 /* pa8 output usb clk */
210 clkout_config();
211}
212
218void clkout_config(void)
219{
220 gpio_init_type gpio_init_struct;
221
222 /* enable gpio port clock */
223 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
224
225 /* set default parameter */
226 gpio_default_para_init(&gpio_init_struct);
227
228 /* clkout gpio init */
229 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
230 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
231 gpio_init_struct.gpio_pins = GPIO_PINS_8;
232 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
233 gpio_init(GPIOA, &gpio_init_struct);
234
235 /* config clkout division */
236 crm_clkout_div_set(CRM_CLKOUT_DIV_1);
237
238 /* config clkout clock */
239 crm_clock_out_set(CRM_CLKOUT_USB);
240}
241
247void usb_delay_ms(uint32_t ms)
248{
249 /* user can define self delay function */
250 delay_ms(ms);
251}
252
258void usb_delay_us(uint32_t us)
259{
260 delay_us(us);
261}
262
268int main(void)
269{
270 uint16_t data_len;
271
272 uint32_t timeout;
273
274 uint8_t send_zero_packet = 0;
275
276 /* config nvic priority group */
277 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
278
279 /* sclk = 240mhz from hick */
280 system_clock_config_for_acc();
281
282 at32_board_init();
283
284 usb_clock48m_select(USB_CLK_HICK);
285
286 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
287
288 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 1, 0);
289
290 usbd_core_init(&usb_core_dev, USB, &cdc_class_handler, &cdc_desc_handler, 0);
291
292 usbd_connect(&usb_core_dev);
293
294 /* acc config */
295 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
296
297 /* enable the acc calibration ready interrupt */
298 acc_interrupt_enable(ACC_CALRDYIEN_INT, TRUE);
299
300 /* enable the acc reference signal lost interrupt */
301 acc_interrupt_enable(ACC_EIEN_INT, TRUE);
302
303 /* config nvic for acc int */
304 nvic_irq_enable(ACC_IRQn, 2, 0);
305
306 /* update the c1\c2\c3 value */
307 acc_c2_value = 8000;
308 #ifdef ACC_CAL
309 acc_write_c1(acc_c2_value - 20);
310 acc_write_c2(acc_c2_value);
311 acc_write_c3(acc_c2_value + 20);
312 #else
313 acc_write_c1(acc_c2_value - 10);
314 acc_write_c2(acc_c2_value);
315 acc_write_c3(acc_c2_value + 10);
316 #endif
317
318 /* open acc calibration */
319 #if defined(ACC_CAL)
320 acc_calibration_mode_enable(ACC_CAL_HICKCAL, TRUE);
321 #elif defined(ACC_TRIM)
322 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
323 #endif
324
325 while(1)
326 {
327 /* get usb vcp receive data */
328 data_len = usb_vcp_get_rxdata(&usb_core_dev, usb_buffer);
329
330 if(data_len > 0 || send_zero_packet == 1)
331 {
332
333 /* bulk transfer is complete when the endpoint does one of the following
334 1 has transferred exactly the amount of data expected
335 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
336 */
337 if(data_len > 0)
338 send_zero_packet = 1;
339
340 if(data_len == 0)
341 send_zero_packet = 0;
342
343 timeout = 5000000;
344 do
345 {
346 /* send data to host */
347 if(usb_vcp_send_data(&usb_core_dev, usb_buffer, data_len) == SUCCESS)
348 {
349 break;
350 }
351 }while(timeout --);
352 }
353 }
354}
355
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
clkout_config
void clkout_config(void)
clkout configuration
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:218
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:66
system_clock_config_for_acc
void system_clock_config_for_acc(void)
system clock config for acc
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:156
ACC_IRQHandler
void ACC_IRQHandler(void)
acc interrupt handler
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:133
main
int main(void)
main function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:268
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
usbfs_l_can1_rx0 interrupt handler
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:123
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:45
acc_c2_value
uint32_t acc_c2_value
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:58
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:44
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
ACC_CAL_HICKCAL
#define ACC_CAL_HICKCAL
Definition: at32f413_acc.h:52
ACC_RSLOST_FLAG
#define ACC_RSLOST_FLAG
Definition: at32f413_acc.h:55
ACC_EIEN_INT
#define ACC_EIEN_INT
Definition: at32f413_acc.h:59
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
ACC_CALRDYIEN_INT
#define ACC_CALRDYIEN_INT
Definition: at32f413_acc.h:58
ACC_CALRDY_FLAG
#define ACC_CALRDY_FLAG
Definition: at32f413_acc.h:56
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_interrupt_enable
void acc_interrupt_enable(uint16_t acc_int, confirm_state new_state)
enable or disable the specified acc interrupts.
Definition: at32f413_acc.c:85
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_flag_get
flag_status acc_flag_get(uint16_t acc_flag)
check whether the specified acc flag is set or not.
Definition: at32f413_acc.c:185
acc_flag_clear
void acc_flag_clear(uint16_t acc_flag)
clear the specified acc flag is set or not.
Definition: at32f413_acc.c:201
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:804
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:683
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:420
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:275
CRM_PLL_MULT_60
@ CRM_PLL_MULT_60
Definition: at32f413_crm.h:263
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_CLKOUT_USB
@ CRM_CLKOUT_USB
Definition: at32f413_crm.h:411
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
CRM_HICK_STABLE_FLAG
#define CRM_HICK_STABLE_FLAG
Definition: at32f413_crm.h:55
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
ACC_IRQn
@ ACC_IRQn
Definition: at32f413.h:193
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:340
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:370
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:69
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:63
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • combine_mode_ordinary_simult
  • inc
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • combine_mode_ordinary_simult
  • inc
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • combine_mode_ordinary_simult
  • inc
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • combine_mode_ordinary_simult
  • src
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • combine_mode_ordinary_simult
  • src
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31extern __IO uint32_t adc1_ordinary_valuetab[5][3];
32extern __IO uint32_t dma1_trans_complete_flag;
33
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void DMA1_Channel1_IRQHandler(void)
145{
146 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
147 {
148 dma_flag_clear(DMA1_FDT1_FLAG);
149 dma1_trans_complete_flag = 1;
150 }
151}
152
153
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:108
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:126
adc1_ordinary_valuetab
__IO uint32_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:39
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:47
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:40
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:144
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:82
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:135
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/at32f413_int.c:117
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
RESET
@ RESET
Definition: at32f413.h:254
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • combine_mode_ordinary_simult
  • src
project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
39__IO uint32_t adc1_ordinary_valuetab[5][3];
40__IO uint32_t dma1_trans_complete_flag = 0;
41
42static void gpio_config(void);
43static void dma_config(void);
44static void adc_config(void);
45
51static void gpio_config(void)
52{
53 gpio_init_type gpio_initstructure;
54 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
56
57 gpio_default_para_init(&gpio_initstructure);
58 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
59 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
60 gpio_init(GPIOA, &gpio_initstructure);
61
62 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
63 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
64 gpio_init(GPIOB, &gpio_initstructure);
65}
66
72static void dma_config(void)
73{
74 dma_init_type dma_init_struct;
75 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
76 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
77 dma_reset(DMA1_CHANNEL1);
78 dma_default_para_init(&dma_init_struct);
79 dma_init_struct.buffer_size = 15;
80 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
81 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
82 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
83 dma_init_struct.memory_inc_enable = TRUE;
84 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
85 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
86 dma_init_struct.peripheral_inc_enable = FALSE;
87 dma_init_struct.priority = DMA_PRIORITY_HIGH;
88 dma_init_struct.loop_mode_enable = FALSE;
89 dma_init(DMA1_CHANNEL1, &dma_init_struct);
90
91 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
92 dma_channel_enable(DMA1_CHANNEL1, TRUE);
93}
94
100static void adc_config(void)
101{
102 adc_base_config_type adc_base_struct;
103 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
104 crm_periph_clock_enable(CRM_ADC2_PERIPH_CLOCK, TRUE);
105 crm_adc_clock_div_set(CRM_ADC_DIV_6);
106
107 /* select combine mode */
108 adc_combine_mode_select(ADC_ORDINARY_SMLT_ONLY_MODE);
109 adc_base_default_para_init(&adc_base_struct);
110 adc_base_struct.sequence_mode = TRUE;
111 adc_base_struct.repeat_mode = FALSE;
112 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
113 adc_base_struct.ordinary_channel_length = 3;
114 adc_base_config(ADC1, &adc_base_struct);
115 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
116 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
117 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
118 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
119 adc_dma_mode_enable(ADC1, TRUE);
120
121 adc_base_config(ADC2, &adc_base_struct);
122 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_239_5);
123 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_239_5);
124 adc_ordinary_channel_set(ADC2, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_239_5);
125 adc_ordinary_conversion_trigger_set(ADC2, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
126
127 adc_enable(ADC1, TRUE);
128 adc_enable(ADC2, TRUE);
129 adc_calibration_init(ADC1);
130 while(adc_calibration_init_status_get(ADC1));
131 adc_calibration_start(ADC1);
132 while(adc_calibration_status_get(ADC1));
133 adc_calibration_init(ADC2);
134 while(adc_calibration_init_status_get(ADC2));
135 adc_calibration_start(ADC2);
136 while(adc_calibration_status_get(ADC2));
137}
138
144int main(void)
145{
146 __IO uint32_t index = 0;
147 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
148 system_clock_config();
149 at32_board_init();
150 at32_led_off(LED2);
151 at32_led_off(LED3);
152 at32_led_off(LED4);
153 uart_print_init(115200);
154 gpio_config();
155 dma_config();
156 adc_config();
157 printf("combine_mode_ordinary_simult \r\n");
158 while(dma1_trans_complete_flag == 0)
159 {
160 delay_ms(100);
161 adc_ordinary_software_trigger_enable(ADC1, TRUE);
162 }
163 for(index = 0; index < 5; index++)
164 {
165 printf("adc1_ordinary_channel4[%d] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][0] & 0xFFFF);
166 printf("adc1_ordinary_channel5[%d] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][1] & 0xFFFF);
167 printf("adc1_ordinary_channel6[%d] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][2] & 0xFFFF);
168 printf("adc2_ordinary_channel7[%d] = 0x%x\r\n",index, (adc1_ordinary_valuetab[index][0] >> 16) & 0xFFFF);
169 printf("adc2_ordinary_channel8[%d] = 0x%x\r\n",index, (adc1_ordinary_valuetab[index][1] >> 16) & 0xFFFF);
170 printf("adc2_ordinary_channel9[%d] = 0x%x\r\n",index, (adc1_ordinary_valuetab[index][2] >> 16) & 0xFFFF);
171 printf("\r\n");
172 }
173 at32_led_on(LED2);
174 while(1)
175 {
176 }
177}
178
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:72
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:100
adc1_ordinary_valuetab
__IO uint32_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:39
dma1_trans_complete_flag
__IO uint32_t dma1_trans_complete_flag
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:144
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:51
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:762
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:143
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:75
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:117
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:230
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:242
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:599
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:199
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:211
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:161
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:97
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:343
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:101
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f413_adc.h:119
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f413_adc.h:118
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:114
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:116
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f413_adc.h:117
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:115
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:142
ADC_ORDINARY_SMLT_ONLY_MODE
@ ADC_ORDINARY_SMLT_ONLY_MODE
Definition: at32f413_adc.h:90
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:158
ADC1
#define ADC1
Definition: at32f413_adc.h:559
ADC2
#define ADC2
Definition: at32f413_adc.h:560
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_ADC2_PERIPH_CLOCK
@ CRM_ADC2_PERIPH_CLOCK
Definition: at32f413_crm.h:116
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:348
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:144
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:247
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:257
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:217
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:212
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:215
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:214
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:213
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:216
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • current_vref_value_check
  • inc
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • current_vref_value_check
  • inc
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • current_vref_value_check
  • inc
project/at_start_f413/examples/adc/current_vref_value_check/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • current_vref_value_check
  • src
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • current_vref_value_check
  • src
project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135}
136
137
138
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:106
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:124
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:45
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:80
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/at32f413_int.c:115
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • current_vref_value_check
  • src
project/at_start_f413/examples/adc/current_vref_value_check/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38__IO uint16_t adc1_ordinary_value = 0;
39
40static void dma_config(void);
41static void adc_config(void);
42
48static void dma_config(void)
49{
50 dma_init_type dma_init_struct;
51 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
52 dma_reset(DMA1_CHANNEL1);
53 dma_default_para_init(&dma_init_struct);
54 dma_init_struct.buffer_size = 1;
55 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
56 dma_init_struct.memory_base_addr = (uint32_t)&adc1_ordinary_value;
57 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
58 dma_init_struct.memory_inc_enable = FALSE;
59 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
60 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
61 dma_init_struct.peripheral_inc_enable = FALSE;
62 dma_init_struct.priority = DMA_PRIORITY_HIGH;
63 dma_init_struct.loop_mode_enable = TRUE;
64 dma_init(DMA1_CHANNEL1, &dma_init_struct);
65
66 dma_channel_enable(DMA1_CHANNEL1, TRUE);
67}
68
74static void adc_config(void)
75{
76 adc_base_config_type adc_base_struct;
77 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
78 crm_adc_clock_div_set(CRM_ADC_DIV_6);
79
80 /* select combine mode */
81 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
82 adc_base_default_para_init(&adc_base_struct);
83 adc_base_struct.sequence_mode = FALSE;
84 adc_base_struct.repeat_mode = FALSE;
85 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
86 adc_base_struct.ordinary_channel_length = 1;
87 adc_base_config(ADC1, &adc_base_struct);
88 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_17, 1, ADC_SAMPLETIME_239_5);
89 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
90 adc_dma_mode_enable(ADC1, TRUE);
91 adc_tempersensor_vintrv_enable(TRUE);
92
93 adc_enable(ADC1, TRUE);
94 adc_calibration_init(ADC1);
95 while(adc_calibration_init_status_get(ADC1));
96 adc_calibration_start(ADC1);
97 while(adc_calibration_status_get(ADC1));
98}
99
105int main(void)
106{
107 __IO uint32_t index = 0;
108 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
109 system_clock_config();
110 at32_board_init();
111 at32_led_off(LED2);
112 at32_led_off(LED3);
113 at32_led_off(LED4);
114 uart_print_init(115200);
115 dma_config();
116 adc_config();
117 printf("adc1_vref_check \r\n");
118 while(1)
119 {
120 at32_led_on(LED2);
121 delay_sec(1);
122 adc_ordinary_software_trigger_enable(ADC1, TRUE);
123 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET);
124 dma_flag_clear(DMA1_FDT1_FLAG);
125 printf("vref_value = %f V\r\n", ((double)1.2 * 4095) / adc1_ordinary_value);
126 }
127}
128
129
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/main.c:48
adc1_ordinary_value
__IO uint16_t adc1_ordinary_value
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/main.c:38
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/main.c:74
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/current_vref_value_check/src/main.c:105
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:762
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:143
adc_tempersensor_vintrv_enable
void adc_tempersensor_vintrv_enable(confirm_state new_state)
enable or disable the temperature sensor and vintrv channel.
Definition: at32f413_adc.c:748
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:75
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:117
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:230
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:242
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:599
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:199
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:211
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:161
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:97
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:343
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:101
ADC_CHANNEL_17
@ ADC_CHANNEL_17
Definition: at32f413_adc.h:127
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:142
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:84
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:158
ADC1
#define ADC1
Definition: at32f413_adc.h:559
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:348
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:212
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:215
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:214
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:213
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:216
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • exint_trigger_partitioned
  • inc
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • exint_trigger_partitioned
  • inc
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • exint_trigger_partitioned
  • inc
project/at_start_f413/examples/adc/exint_trigger_partitioned/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • exint_trigger_partitioned
  • src
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • exint_trigger_partitioned
  • src
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31extern __IO uint16_t adc1_preempt_valuetab[3][3];
32extern __IO uint16_t dma_trans_complete_flag;
33extern __IO uint16_t preempt_trigger_count;
34
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void DMA1_Channel1_IRQHandler(void)
146{
147 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
148 {
149 dma_flag_clear(DMA1_FDT1_FLAG);
150 dma_trans_complete_flag = 1;
151 }
152}
153
159void ADC1_2_IRQHandler(void)
160{
161 if(adc_flag_get(ADC1, ADC_PCCE_FLAG) != RESET)
162 {
163 adc_flag_clear(ADC1, ADC_PCCE_FLAG);
164 if(preempt_trigger_count < 3)
165 {
166 adc1_preempt_valuetab[preempt_trigger_count][0] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_1);
167 adc1_preempt_valuetab[preempt_trigger_count][1] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_2);
168 adc1_preempt_valuetab[preempt_trigger_count][2] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_3);
169 preempt_trigger_count++;
170 }
171 }
172}
173
174
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[3][3]
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:40
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:41
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:70
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:109
ADC1_2_IRQHandler
void ADC1_2_IRQHandler(void)
this function handles adc1_2 handler.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:159
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:48
preempt_trigger_count
__IO uint16_t preempt_trigger_count
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:42
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:145
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:83
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:136
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/at32f413_int.c:118
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:853
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:919
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:890
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f413_adc.h:190
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f413_adc.h:189
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f413_adc.h:188
ADC_PCCE_FLAG
#define ADC_PCCE_FLAG
Definition: at32f413_adc.h:67
ADC1
#define ADC1
Definition: at32f413_adc.h:559
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
RESET
@ RESET
Definition: at32f413.h:254
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • exint_trigger_partitioned
  • src
project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
39__IO uint16_t adc1_ordinary_valuetab[3][3] = {0};
40__IO uint16_t adc1_preempt_valuetab[3][3] = {0};
41__IO uint16_t dma_trans_complete_flag = 0;
42__IO uint16_t preempt_trigger_count = 0;
43
44static void gpio_config(void);
45static void exint_config(void);
46static void dma_config(void);
47static void adc_config(void);
48
54static void gpio_config(void)
55{
56 gpio_init_type gpio_initstructure;
57 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
59
60 gpio_default_para_init(&gpio_initstructure);
61 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
62 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
63 gpio_init(GPIOA, &gpio_initstructure);
64
65 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
66 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
67 gpio_init(GPIOB, &gpio_initstructure);
68}
69
75static void exint_config(void)
76{
77 gpio_init_type gpio_initstructure;
78 exint_init_type exint_init_struct;
79
80 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
81 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
82 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
83
84 gpio_default_para_init(&gpio_initstructure);
85 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
86 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
87 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
88 gpio_initstructure.gpio_pins = GPIO_PINS_11;
89 gpio_init(GPIOC, &gpio_initstructure);
90 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
91 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
92 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
93 gpio_initstructure.gpio_pins = GPIO_PINS_15;
94 gpio_init(GPIOA, &gpio_initstructure);
95
96 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOC, GPIO_PINS_SOURCE11);
97 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE15);
98
99 exint_default_para_init(&exint_init_struct);
100 exint_init_struct.line_enable = TRUE;
101 exint_init_struct.line_mode = EXINT_LINE_EVENT;
102 exint_init_struct.line_select = EXINT_LINE_11;
103 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
104 exint_init(&exint_init_struct);
105
106 exint_init_struct.line_select = EXINT_LINE_15;
107 exint_init(&exint_init_struct);
108}
109
115static void dma_config(void)
116{
117 dma_init_type dma_init_struct;
118 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
119 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
120 dma_reset(DMA1_CHANNEL1);
121 dma_default_para_init(&dma_init_struct);
122 dma_init_struct.buffer_size = 9;
123 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
124 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
125 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
126 dma_init_struct.memory_inc_enable = TRUE;
127 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
128 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
129 dma_init_struct.peripheral_inc_enable = FALSE;
130 dma_init_struct.priority = DMA_PRIORITY_HIGH;
131 dma_init_struct.loop_mode_enable = FALSE;
132 dma_init(DMA1_CHANNEL1, &dma_init_struct);
133
134 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
135 dma_channel_enable(DMA1_CHANNEL1, TRUE);
136}
137
143static void adc_config(void)
144{
145 adc_base_config_type adc_base_struct;
146 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
147 crm_adc_clock_div_set(CRM_ADC_DIV_6);
148 nvic_irq_enable(ADC1_2_IRQn, 0, 0);
149
150 /* select combine mode */
151 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
152 adc_base_default_para_init(&adc_base_struct);
153 adc_base_struct.sequence_mode = TRUE;
154 adc_base_struct.repeat_mode = FALSE;
155 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
156 adc_base_struct.ordinary_channel_length = 3;
157 adc_base_config(ADC1, &adc_base_struct);
158 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
159 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
160 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
161 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT, TRUE);
162 adc_dma_mode_enable(ADC1, TRUE);
163 adc_ordinary_part_count_set(ADC1, 1);
164 adc_ordinary_part_mode_enable(ADC1, TRUE);
165
166 adc_preempt_channel_length_set(ADC1, 3);
167 adc_preempt_channel_set(ADC1, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_239_5);
168 adc_preempt_channel_set(ADC1, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_239_5);
169 adc_preempt_channel_set(ADC1, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_239_5);
170 adc_preempt_conversion_trigger_set(ADC1, ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4, TRUE);
171 adc_interrupt_enable(ADC1, ADC_PCCE_INT, TRUE);
172
173 adc_enable(ADC1, TRUE);
174 adc_calibration_init(ADC1);
175 while(adc_calibration_init_status_get(ADC1));
176 adc_calibration_start(ADC1);
177 while(adc_calibration_status_get(ADC1));
178}
179
185int main(void)
186{
187 __IO uint32_t index = 0;
188 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
189 system_clock_config();
190 at32_board_init();
191 at32_led_off(LED2);
192 at32_led_off(LED3);
193 at32_led_off(LED4);
194 uart_print_init(115200);
195 gpio_config();
196 exint_config();
197 dma_config();
198 adc_config();
199 printf("exint_trigger_partitioned \r\n");
200 while(dma_trans_complete_flag == 0);
201 while(preempt_trigger_count != 3);
202 for(index = 0; index < 3; index++)
203 {
204 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][0]);
205 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][1]);
206 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n",index, adc1_ordinary_valuetab[index][2]);
207 printf("adc1_preempt_valuetab[%d][0] = 0x%x\r\n",index, adc1_preempt_valuetab[index][0]);
208 printf("adc1_preempt_valuetab[%d][1] = 0x%x\r\n",index, adc1_preempt_valuetab[index][1]);
209 printf("adc1_preempt_valuetab[%d][2] = 0x%x\r\n",index, adc1_preempt_valuetab[index][2]);
210 printf("\r\n");
211 }
212 at32_led_on(LED2);
213 while(1)
214 {
215 }
216}
217
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[3][3]
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:40
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:41
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:115
exint_config
static void exint_config(void)
exint configuration.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:75
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:143
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3][3]
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:39
preempt_trigger_count
__IO uint16_t preempt_trigger_count
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:185
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:54
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:143
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:75
adc_ordinary_part_count_set
void adc_ordinary_part_count_set(adc_type *adc_x, uint8_t adc_channel_count)
set partitioned mode channel count of the specified adc peripheral.
Definition: at32f413_adc.c:693
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:180
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:117
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:230
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:242
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:599
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f413_adc.c:630
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:199
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f413_adc.c:501
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:211
adc_ordinary_part_mode_enable
void adc_ordinary_part_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the partitioned mode on ordinary channel of the specified adc peripheral.
Definition: at32f413_adc.c:708
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:161
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:97
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f413_adc.c:469
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:343
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:101
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f413_adc.h:119
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f413_adc.h:118
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:114
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:116
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f413_adc.h:117
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:115
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:142
ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4
@ ADC12_PREEMPT_TRIG_EXINT15_TMR8CH4
Definition: at32f413_adc.h:176
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:84
ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT
@ ADC12_ORDINARY_TRIG_EXINT11_TMR8TRGOUT
Definition: at32f413_adc.h:157
ADC_PCCE_INT
#define ADC_PCCE_INT
Definition: at32f413_adc.h:54
ADC1
#define ADC1
Definition: at32f413_adc.h:559
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:112
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:348
ADC1_2_IRQn
@ ADC1_2_IRQn
Definition: at32f413.h:152
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:144
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT_LINE_EVENT
@ EXINT_LINE_EVENT
Definition: at32f413_exint.h:85
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:93
EXINT_LINE_15
#define EXINT_LINE_15
Definition: at32f413_exint.h:67
EXINT_LINE_11
#define EXINT_LINE_11
Definition: at32f413_exint.h:63
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:573
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:217
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PINS_SOURCE11
@ GPIO_PINS_SOURCE11
Definition: at32f413_gpio.h:265
GPIO_PINS_SOURCE15
@ GPIO_PINS_SOURCE15
Definition: at32f413_gpio.h:269
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:277
GPIO_PORT_SOURCE_GPIOC
@ GPIO_PORT_SOURCE_GPIOC
Definition: at32f413_gpio.h:279
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:212
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:215
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:214
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:213
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:216
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • internal_temperature_sensor
  • inc
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • internal_temperature_sensor
  • inc
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • internal_temperature_sensor
  • inc
project/at_start_f413/examples/adc/internal_temperature_sensor/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • internal_temperature_sensor
  • src
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • internal_temperature_sensor
  • src
project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
138
139
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/at32f413_int.c:116
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • internal_temperature_sensor
  • src
project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
39#define ADC_VREF (3.3)
40#define ADC_TEMP_BASE (1.26)
41#define ADC_TEMP_SLOPE (-0.00423)
42
43__IO uint16_t adc1_ordinary_value = 0;
44
45static void dma_config(void);
46static void adc_config(void);
47
53static void dma_config(void)
54{
55 dma_init_type dma_init_struct;
56 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
57 dma_reset(DMA1_CHANNEL1);
58 dma_default_para_init(&dma_init_struct);
59 dma_init_struct.buffer_size = 1;
60 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
61 dma_init_struct.memory_base_addr = (uint32_t)&adc1_ordinary_value;
62 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
63 dma_init_struct.memory_inc_enable = FALSE;
64 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
65 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
66 dma_init_struct.peripheral_inc_enable = FALSE;
67 dma_init_struct.priority = DMA_PRIORITY_HIGH;
68 dma_init_struct.loop_mode_enable = TRUE;
69 dma_init(DMA1_CHANNEL1, &dma_init_struct);
70
71 dma_channel_enable(DMA1_CHANNEL1, TRUE);
72}
73
79static void adc_config(void)
80{
81 adc_base_config_type adc_base_struct;
82 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
83 crm_adc_clock_div_set(CRM_ADC_DIV_6);
84
85 /* select combine mode */
86 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
87 adc_base_default_para_init(&adc_base_struct);
88 adc_base_struct.sequence_mode = FALSE;
89 adc_base_struct.repeat_mode = TRUE;
90 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
91 adc_base_struct.ordinary_channel_length = 1;
92 adc_base_config(ADC1, &adc_base_struct);
93 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_16, 1, ADC_SAMPLETIME_239_5);
94 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
95 adc_dma_mode_enable(ADC1, TRUE);
96 adc_tempersensor_vintrv_enable(TRUE);
97
98 adc_enable(ADC1, TRUE);
99 adc_calibration_init(ADC1);
100 while(adc_calibration_init_status_get(ADC1));
101 adc_calibration_start(ADC1);
102 while(adc_calibration_status_get(ADC1));
103}
104
110int main(void)
111{
112 __IO uint32_t index = 0;
113 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
114 system_clock_config();
115 at32_board_init();
116 at32_led_off(LED2);
117 at32_led_off(LED3);
118 at32_led_off(LED4);
119 uart_print_init(115200);
120 dma_config();
121 adc_config();
122 printf("internal_temperature_sensor \r\n");
123 adc_ordinary_software_trigger_enable(ADC1, TRUE);
124 while(1)
125 {
126 at32_led_on(LED2);
127 delay_sec(1);
128 while(dma_flag_get(DMA1_FDT1_FLAG) == RESET);
129 dma_flag_clear(DMA1_FDT1_FLAG);
130 printf("internal_temperature = %f deg C\r\n",(ADC_TEMP_BASE - (double)adc1_ordinary_value * ADC_VREF / 4096) / ADC_TEMP_SLOPE + 25);
131 }
132}
133
134
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:53
adc1_ordinary_value
__IO uint16_t adc1_ordinary_value
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:43
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:79
ADC_VREF
#define ADC_VREF
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:110
ADC_TEMP_SLOPE
#define ADC_TEMP_SLOPE
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:41
ADC_TEMP_BASE
#define ADC_TEMP_BASE
Definition: project/at_start_f413/examples/adc/internal_temperature_sensor/src/main.c:40
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:762
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:143
adc_tempersensor_vintrv_enable
void adc_tempersensor_vintrv_enable(confirm_state new_state)
enable or disable the temperature sensor and vintrv channel.
Definition: at32f413_adc.c:748
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:75
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:117
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:230
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:242
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:599
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:199
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:211
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:161
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:97
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:343
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:101
ADC_CHANNEL_16
@ ADC_CHANNEL_16
Definition: at32f413_adc.h:126
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:142
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:84
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:158
ADC1
#define ADC1
Definition: at32f413_adc.h:559
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:348
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:212
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:215
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:214
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:213
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:216
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • software_trigger_repeat
  • inc
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • software_trigger_repeat
  • inc
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • software_trigger_repeat
  • inc
project/at_start_f413/examples/adc/software_trigger_repeat/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • software_trigger_repeat
  • src
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • software_trigger_repeat
  • src
project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31extern __IO uint16_t dma_trans_complete_flag;
32
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void DMA1_Channel1_IRQHandler(void)
144{
145 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
146 {
147 dma_flag_clear(DMA1_FDT1_FLAG);
148 dma_trans_complete_flag = 1;
149 }
150}
151
152
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:41
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:46
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:143
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/at32f413_int.c:116
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
RESET
@ RESET
Definition: at32f413.h:254
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • software_trigger_repeat
  • src
project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[10][3] = {0};
39__IO uint16_t dma_trans_complete_flag = 0;
40
41static void gpio_config(void);
42static void dma_config(void);
43static void adc_config(void);
44
50static void gpio_config(void)
51{
52 gpio_init_type gpio_initstructure;
53 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
54
55 gpio_default_para_init(&gpio_initstructure);
56 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
57 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
58 gpio_init(GPIOA, &gpio_initstructure);
59}
60
66static void dma_config(void)
67{
68 dma_init_type dma_init_struct;
69 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
70 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
71 dma_reset(DMA1_CHANNEL1);
72 dma_default_para_init(&dma_init_struct);
73 dma_init_struct.buffer_size = 30;
74 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
75 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
76 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
77 dma_init_struct.memory_inc_enable = TRUE;
78 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
79 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
80 dma_init_struct.peripheral_inc_enable = FALSE;
81 dma_init_struct.priority = DMA_PRIORITY_HIGH;
82 dma_init_struct.loop_mode_enable = FALSE;
83 dma_init(DMA1_CHANNEL1, &dma_init_struct);
84
85 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
86 dma_channel_enable(DMA1_CHANNEL1, TRUE);
87}
88
94static void adc_config(void)
95{
96 adc_base_config_type adc_base_struct;
97 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
98 crm_adc_clock_div_set(CRM_ADC_DIV_6);
99
100 /* select combine mode */
101 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
102 adc_base_default_para_init(&adc_base_struct);
103 adc_base_struct.sequence_mode = TRUE;
104 adc_base_struct.repeat_mode = TRUE;
105 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
106 adc_base_struct.ordinary_channel_length = 3;
107 adc_base_config(ADC1, &adc_base_struct);
108 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
109 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
110 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
111 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
112 adc_dma_mode_enable(ADC1, TRUE);
113
114 adc_enable(ADC1, TRUE);
115 adc_calibration_init(ADC1);
116 while(adc_calibration_init_status_get(ADC1));
117 adc_calibration_start(ADC1);
118 while(adc_calibration_status_get(ADC1));
119}
120
126int main(void)
127{
128 __IO uint32_t index = 0;
129 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
130 system_clock_config();
131 at32_board_init();
132 at32_led_off(LED2);
133 at32_led_off(LED3);
134 at32_led_off(LED4);
135 uart_print_init(115200);
136 gpio_config();
137 dma_config();
138 adc_config();
139 printf("software_trigger_repeat \r\n");
140 adc_ordinary_software_trigger_enable(ADC1, TRUE);
141 while(dma_trans_complete_flag == 0);
142 for(index = 0; index < 10; index++)
143 {
144 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][0]);
145 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][1]);
146 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][2]);
147 }
148 at32_led_on(LED2);
149 while(1)
150 {
151 }
152}
153
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:39
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:66
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:94
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:126
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[10][3]
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:38
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/software_trigger_repeat/src/main.c:50
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:762
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:143
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:75
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:117
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:230
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:242
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:599
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:199
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:211
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:161
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:97
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:343
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:101
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:114
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:116
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:115
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:142
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:84
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:158
ADC1
#define ADC1
Definition: at32f413_adc.h:559
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:348
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:144
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:217
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:212
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:215
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:214
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:213
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:216
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • tmr_trigger_automatic_preempted
  • inc
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • tmr_trigger_automatic_preempted
  • inc
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • tmr_trigger_automatic_preempted
  • inc
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • tmr_trigger_automatic_preempted
  • src
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • tmr_trigger_automatic_preempted
  • src
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31extern __IO uint16_t adc1_ordinary_valuetab[5][3];
32extern __IO uint16_t adc1_preempt_valuetab[5][3];
33extern __IO uint16_t dma_trans_complete_flag;
34extern __IO uint16_t preempt_conversion_count;
35
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
146void DMA1_Channel1_IRQHandler(void)
147{
148 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
149 {
150 dma_flag_clear(DMA1_FDT1_FLAG);
151 dma_trans_complete_flag = 1;
152 }
153}
154
160void ADC1_2_IRQHandler(void)
161{
162 if(adc_flag_get(ADC1, ADC_PCCE_FLAG) != RESET)
163 {
164 adc_flag_clear(ADC1, ADC_PCCE_FLAG);
165 if(preempt_conversion_count < 5)
166 {
167 adc1_preempt_valuetab[preempt_conversion_count][0] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_1);
168 adc1_preempt_valuetab[preempt_conversion_count][1] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_2);
169 adc1_preempt_valuetab[preempt_conversion_count][2] = adc_preempt_conversion_data_get(ADC1, ADC_PREEMPT_CHANNEL_3);
170 preempt_conversion_count++;
171 }
172 at32_led_toggle(LED3);
173 }
174}
175
176
177
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:39
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:40
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/exint_trigger_partitioned/src/main.c:41
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:97
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:58
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:71
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:110
ADC1_2_IRQHandler
void ADC1_2_IRQHandler(void)
this function handles adc1_2 handler.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:160
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:128
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:49
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1_channel1 handler.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:146
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:84
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:137
preempt_conversion_count
__IO uint16_t preempt_conversion_count
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:41
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/at32f413_int.c:119
adc_preempt_conversion_data_get
uint16_t adc_preempt_conversion_data_get(adc_type *adc_x, adc_preempt_channel_type adc_preempt_channel)
return the conversion data for selection preempt channel of the specified adc peripheral.
Definition: at32f413_adc.c:853
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:919
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:890
ADC_PREEMPT_CHANNEL_3
@ ADC_PREEMPT_CHANNEL_3
Definition: at32f413_adc.h:190
ADC_PREEMPT_CHANNEL_2
@ ADC_PREEMPT_CHANNEL_2
Definition: at32f413_adc.h:189
ADC_PREEMPT_CHANNEL_1
@ ADC_PREEMPT_CHANNEL_1
Definition: at32f413_adc.h:188
ADC_PCCE_FLAG
#define ADC_PCCE_FLAG
Definition: at32f413_adc.h:67
ADC1
#define ADC1
Definition: at32f413_adc.h:559
LED3
@ LED3
Definition: at32f413_board.h:64
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
RESET
@ RESET
Definition: at32f413.h:254
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • tmr_trigger_automatic_preempted
  • src
project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[5][3] = {0};
39__IO uint16_t adc1_preempt_valuetab[5][3] = {0};
40__IO uint16_t dma_trans_complete_flag = 0;
41__IO uint16_t preempt_conversion_count = 0;
42
43static void gpio_config(void);
44static void dma_config(void);
45static void tmr1_config(void);
46static void adc_config(void);
47
53static void gpio_config(void)
54{
55 gpio_init_type gpio_initstructure;
56 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
57 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
58
59 gpio_default_para_init(&gpio_initstructure);
60 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
61 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6 | GPIO_PINS_7;
62 gpio_init(GPIOA, &gpio_initstructure);
63
64 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
65 gpio_initstructure.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
66 gpio_init(GPIOB, &gpio_initstructure);
67}
68
74static void dma_config(void)
75{
76 dma_init_type dma_init_struct;
77 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
78 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
79 dma_reset(DMA1_CHANNEL1);
80 dma_default_para_init(&dma_init_struct);
81 dma_init_struct.buffer_size = 15;
82 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
83 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
84 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
85 dma_init_struct.memory_inc_enable = TRUE;
86 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
87 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
88 dma_init_struct.peripheral_inc_enable = FALSE;
89 dma_init_struct.priority = DMA_PRIORITY_HIGH;
90 dma_init_struct.loop_mode_enable = FALSE;
91 dma_init(DMA1_CHANNEL1, &dma_init_struct);
92
93 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
94 dma_channel_enable(DMA1_CHANNEL1, TRUE);
95}
96
102static void tmr1_config(void)
103{
104 gpio_init_type gpio_initstructure;
105 tmr_output_config_type tmr_oc_init_structure;
106 crm_clocks_freq_type crm_clocks_freq_struct = {0};
107 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
108
109 gpio_default_para_init(&gpio_initstructure);
110 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
111 gpio_initstructure.gpio_pins = GPIO_PINS_8;
112 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
113 gpio_initstructure.gpio_pull = GPIO_PULL_NONE;
114 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
115 gpio_init(GPIOA, &gpio_initstructure);
116
117 /* get system clock */
118 crm_clocks_freq_get(&crm_clocks_freq_struct);
119
120 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
121
122 /* (systemclock/(systemclock/10000))/1000 = 10Hz(100ms) */
123 tmr_base_init(TMR1, 999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
124 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
125 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
126
127 tmr_output_default_para_init(&tmr_oc_init_structure);
128 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
129 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
130 tmr_oc_init_structure.oc_output_state = TRUE;
131 tmr_oc_init_structure.oc_idle_state = FALSE;
132 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
133 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 500);
134}
135
141static void adc_config(void)
142{
143 adc_base_config_type adc_base_struct;
144 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
145 crm_adc_clock_div_set(CRM_ADC_DIV_6);
146 nvic_irq_enable(ADC1_2_IRQn, 0, 0);
147
148 /* select combine mode */
149 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
150 adc_base_default_para_init(&adc_base_struct);
151 adc_base_struct.sequence_mode = TRUE;
152 adc_base_struct.repeat_mode = FALSE;
153 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
154 adc_base_struct.ordinary_channel_length = 3;
155 adc_base_config(ADC1, &adc_base_struct);
156 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
157 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
158 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
159 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_TMR1CH1, TRUE);
160 adc_dma_mode_enable(ADC1, TRUE);
161
162 adc_preempt_channel_length_set(ADC1, 3);
163 adc_preempt_channel_set(ADC1, ADC_CHANNEL_7, 1, ADC_SAMPLETIME_239_5);
164 adc_preempt_channel_set(ADC1, ADC_CHANNEL_8, 2, ADC_SAMPLETIME_239_5);
165 adc_preempt_channel_set(ADC1, ADC_CHANNEL_9, 3, ADC_SAMPLETIME_239_5);
166 adc_preempt_conversion_trigger_set(ADC1, ADC12_PREEMPT_TRIG_SOFTWARE, TRUE);
167 adc_preempt_auto_mode_enable(ADC1, TRUE);
168 adc_interrupt_enable(ADC1, ADC_PCCE_INT, TRUE);
169
170 adc_enable(ADC1, TRUE);
171 adc_calibration_init(ADC1);
172 while(adc_calibration_init_status_get(ADC1));
173 adc_calibration_start(ADC1);
174 while(adc_calibration_status_get(ADC1));
175}
176
177
178
179
185int main(void)
186{
187 __IO uint32_t index = 0;
188 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
189 system_clock_config();
190 at32_board_init();
191 at32_led_off(LED2);
192 at32_led_off(LED3);
193 at32_led_off(LED4);
194 uart_print_init(115200);
195 gpio_config();
196 tmr1_config();
197 dma_config();
198 adc_config();
199 printf("tmr_trigger_automatic_preempted \r\n");
200 tmr_counter_enable(TMR1, TRUE);
201 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
202 tmr_output_enable(TMR1, TRUE);
203 while(preempt_conversion_count < 5);
204 while(dma_trans_complete_flag == 0);
205 tmr_counter_enable(TMR1, FALSE);
206 for(index = 0; index < 5; index++)
207 {
208 printf("adc1_ordinary_valuetab[%d][0] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][0]);
209 printf("adc1_ordinary_valuetab[%d][1] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][1]);
210 printf("adc1_ordinary_valuetab[%d][2] = 0x%x\r\n", index, adc1_ordinary_valuetab[index][2]);
211 printf("adc1_preempted_valuetab[%d][0] = 0x%x\r\n", index, adc1_preempt_valuetab[index][0]);
212 printf("adc1_preempted_valuetab[%d][1] = 0x%x\r\n", index, adc1_preempt_valuetab[index][1]);
213 printf("adc1_preempted_valuetab[%d][2] = 0x%x\r\n", index, adc1_preempt_valuetab[index][2]);
214 printf("\r\n");
215 }
216 at32_led_on(LED2);
217 while(1)
218 {
219 }
220}
221
222
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_trans_complete_flag
__IO uint16_t dma_trans_complete_flag
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:40
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:74
adc1_preempt_valuetab
__IO uint16_t adc1_preempt_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:39
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[5][3]
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:38
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:141
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:185
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:102
preempt_conversion_count
__IO uint16_t preempt_conversion_count
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:41
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/tmr_trigger_automatic_preempted/src/main.c:53
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:39
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:38
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:143
adc_preempt_auto_mode_enable
void adc_preempt_auto_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable automatic preempt group conversion of the specified adc peripheral.
Definition: at32f413_adc.c:736
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:75
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:180
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:117
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:230
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:242
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:599
adc_preempt_conversion_trigger_set
void adc_preempt_conversion_trigger_set(adc_type *adc_x, adc_preempt_trig_select_type adc_preempt_trig, confirm_state new_state)
enable or disable the preempt channel's external trigger and set external trigger event of the specif...
Definition: at32f413_adc.c:630
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:199
adc_preempt_channel_set
void adc_preempt_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
configure preempt channel's corresponding rank in the sequencer and sample time of the specified adc ...
Definition: at32f413_adc.c:501
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:211
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:161
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:97
adc_preempt_channel_length_set
void adc_preempt_channel_length_set(adc_type *adc_x, uint8_t adc_channel_lenght)
set preempt channel lenghth of the specified adc peripheral.
Definition: at32f413_adc.c:469
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:343
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:101
ADC_CHANNEL_9
@ ADC_CHANNEL_9
Definition: at32f413_adc.h:119
ADC_CHANNEL_8
@ ADC_CHANNEL_8
Definition: at32f413_adc.h:118
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:114
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:116
ADC_CHANNEL_7
@ ADC_CHANNEL_7
Definition: at32f413_adc.h:117
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:115
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:142
ADC12_PREEMPT_TRIG_SOFTWARE
@ ADC12_PREEMPT_TRIG_SOFTWARE
Definition: at32f413_adc.h:177
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:84
ADC12_ORDINARY_TRIG_TMR1CH1
@ ADC12_ORDINARY_TRIG_TMR1CH1
Definition: at32f413_adc.h:151
ADC_PCCE_INT
#define ADC_PCCE_INT
Definition: at32f413_adc.h:54
ADC1
#define ADC1
Definition: at32f413_adc.h:559
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:348
ADC1_2_IRQn
@ ADC1_2_IRQn
Definition: at32f413.h:152
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:144
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:217
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f413_tmr.c:875
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:212
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:215
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:214
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:213
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:216
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • adc
  • voltage_monitoring
  • inc
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • adc
  • voltage_monitoring
  • inc
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • adc
  • voltage_monitoring
  • inc
project/at_start_f413/examples/adc/voltage_monitoring/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • adc
  • voltage_monitoring
  • src
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • adc
  • voltage_monitoring
  • src
project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31extern __IO uint16_t adc1_ordinary_valuetab[3];
32extern __IO uint16_t vmor_flag_index;
33
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void ADC1_2_IRQHandler(void)
146{
147 if(adc_flag_get(ADC1, ADC_VMOR_FLAG) != RESET)
148 {
149 at32_led_toggle(LED3);
150 adc_flag_clear(ADC1, ADC_VMOR_FLAG);
151 vmor_flag_index = 1;
152 }
153}
154
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3]
Definition: project/at_start_f413/examples/adc/combine_mode_ordinary_simult/src/main.c:39
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:70
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:109
ADC1_2_IRQHandler
void ADC1_2_IRQHandler(void)
this function handles adc1_2 handler.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:145
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:48
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:83
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:136
vmor_flag_index
__IO uint16_t vmor_flag_index
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:39
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/at32f413_int.c:118
adc_flag_clear
void adc_flag_clear(adc_type *adc_x, uint32_t adc_flag)
clear flag of the specified adc peripheral.
Definition: at32f413_adc.c:919
adc_flag_get
flag_status adc_flag_get(adc_type *adc_x, uint8_t adc_flag)
get flag of the specified adc peripheral.
Definition: at32f413_adc.c:890
ADC_VMOR_FLAG
#define ADC_VMOR_FLAG
Definition: at32f413_adc.h:65
ADC1
#define ADC1
Definition: at32f413_adc.h:559
LED3
@ LED3
Definition: at32f413_board.h:64
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
RESET
@ RESET
Definition: at32f413.h:254
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • adc
  • voltage_monitoring
  • src
project/at_start_f413/examples/adc/voltage_monitoring/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38__IO uint16_t adc1_ordinary_valuetab[3] = {0};
39__IO uint16_t vmor_flag_index = 0;
40
41static void gpio_config(void);
42static void dma_config(void);
43static void adc_config(void);
44
50static void gpio_config(void)
51{
52 gpio_init_type gpio_initstructure;
53 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
54
55 gpio_default_para_init(&gpio_initstructure);
56 gpio_initstructure.gpio_mode = GPIO_MODE_ANALOG;
57 gpio_initstructure.gpio_pins = GPIO_PINS_4 | GPIO_PINS_5 | GPIO_PINS_6;
58 gpio_init(GPIOA, &gpio_initstructure);
59}
60
66static void dma_config(void)
67{
68 dma_init_type dma_init_struct;
69 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
70 dma_reset(DMA1_CHANNEL1);
71 dma_default_para_init(&dma_init_struct);
72 dma_init_struct.buffer_size = 3;
73 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
74 dma_init_struct.memory_base_addr = (uint32_t)adc1_ordinary_valuetab;
75 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
76 dma_init_struct.memory_inc_enable = TRUE;
77 dma_init_struct.peripheral_base_addr = (uint32_t)&(ADC1->odt);
78 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
79 dma_init_struct.peripheral_inc_enable = FALSE;
80 dma_init_struct.priority = DMA_PRIORITY_HIGH;
81 dma_init_struct.loop_mode_enable = TRUE;
82 dma_init(DMA1_CHANNEL1, &dma_init_struct);
83
84 dma_channel_enable(DMA1_CHANNEL1, TRUE);
85}
86
92static void adc_config(void)
93{
94 adc_base_config_type adc_base_struct;
95 crm_periph_clock_enable(CRM_ADC1_PERIPH_CLOCK, TRUE);
96 crm_adc_clock_div_set(CRM_ADC_DIV_6);
97 nvic_irq_enable(ADC1_2_IRQn, 0, 0);
98
99 /* select combine mode */
100 adc_combine_mode_select(ADC_INDEPENDENT_MODE);
101 adc_base_default_para_init(&adc_base_struct);
102 adc_base_struct.sequence_mode = TRUE;
103 adc_base_struct.repeat_mode = FALSE;
104 adc_base_struct.data_align = ADC_RIGHT_ALIGNMENT;
105 adc_base_struct.ordinary_channel_length = 3;
106 adc_base_config(ADC1, &adc_base_struct);
107 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_4, 1, ADC_SAMPLETIME_239_5);
108 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_5, 2, ADC_SAMPLETIME_239_5);
109 adc_ordinary_channel_set(ADC1, ADC_CHANNEL_6, 3, ADC_SAMPLETIME_239_5);
110 adc_ordinary_conversion_trigger_set(ADC1, ADC12_ORDINARY_TRIG_SOFTWARE, TRUE);
111 adc_dma_mode_enable(ADC1, TRUE);
112 adc_voltage_monitor_enable(ADC1, ADC_VMONITOR_SINGLE_ORDINARY);
113 adc_voltage_monitor_threshold_value_set(ADC1, 0xBBB, 0xAAA);
114 adc_voltage_monitor_single_channel_select(ADC1, ADC_CHANNEL_5);
115 adc_interrupt_enable(ADC1, ADC_VMOR_INT, TRUE);
116
117 adc_enable(ADC1, TRUE);
118 adc_calibration_init(ADC1);
119 while(adc_calibration_init_status_get(ADC1));
120 adc_calibration_start(ADC1);
121 while(adc_calibration_status_get(ADC1));
122}
123
129int main(void)
130{
131 __IO uint32_t index = 0;
132 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
133 system_clock_config();
134 at32_board_init();
135 at32_led_off(LED2);
136 at32_led_off(LED3);
137 at32_led_off(LED4);
138 uart_print_init(115200);
139 gpio_config();
140 dma_config();
141 adc_config();
142 printf("voltage_monitoring \r\n");
143 while(1)
144 {
145 at32_led_toggle(LED2);
146 delay_sec(1);
147 if(vmor_flag_index == 1)
148 {
149 vmor_flag_index = 0;
150 printf("out of range:adc1_channel_5 value is = %x!\r\n", adc1_ordinary_valuetab[1]);
151 }
152 adc_ordinary_software_trigger_enable(ADC1, TRUE);
153 }
154}
155
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_config
static void dma_config(void)
dma configuration.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:66
adc_config
static void adc_config(void)
adc configuration.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:92
main
int main(void)
main function.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:129
adc1_ordinary_valuetab
__IO uint16_t adc1_ordinary_valuetab[3]
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:38
vmor_flag_index
__IO uint16_t vmor_flag_index
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:39
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/adc/voltage_monitoring/src/main.c:50
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
adc_ordinary_software_trigger_enable
void adc_ordinary_software_trigger_enable(adc_type *adc_x, confirm_state new_state)
enable or disable ordinary software start conversion of the specified adc peripheral.
Definition: at32f413_adc.c:762
adc_voltage_monitor_enable
void adc_voltage_monitor_enable(adc_type *adc_x, adc_voltage_monitoring_type adc_voltage_monitoring)
enable or disable the voltage monitoring on single/all ordinary or preempt channels of the specified ...
Definition: at32f413_adc.c:270
adc_voltage_monitor_single_channel_select
void adc_voltage_monitor_single_channel_select(adc_type *adc_x, adc_channel_select_type adc_channel)
select the voltage monitoring's channel of the specified adc peripheral.
Definition: at32f413_adc.c:311
adc_base_config
void adc_base_config(adc_type *adc_x, adc_base_config_type *adc_base_struct)
initialize the adc peripheral according to the specified parameters.
Definition: at32f413_adc.c:143
adc_enable
void adc_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the specified adc peripheral.
Definition: at32f413_adc.c:75
adc_interrupt_enable
void adc_interrupt_enable(adc_type *adc_x, uint32_t adc_int, confirm_state new_state)
enable or disable the specified adc interrupts.
Definition: at32f413_adc.c:180
adc_base_default_para_init
void adc_base_default_para_init(adc_base_config_type *adc_base_struct)
adc base default para init.
Definition: at32f413_adc.c:117
adc_calibration_start
void adc_calibration_start(adc_type *adc_x)
start calibration process of the specified adc peripheral.
Definition: at32f413_adc.c:230
adc_calibration_status_get
flag_status adc_calibration_status_get(adc_type *adc_x)
get calibration status of the specified adc peripheral.
Definition: at32f413_adc.c:242
adc_voltage_monitor_threshold_value_set
void adc_voltage_monitor_threshold_value_set(adc_type *adc_x, uint16_t adc_high_threshold, uint16_t adc_low_threshold)
set voltage monitoring's high and low thresholds value of the specified adc peripheral.
Definition: at32f413_adc.c:291
adc_ordinary_conversion_trigger_set
void adc_ordinary_conversion_trigger_set(adc_type *adc_x, adc_ordinary_trig_select_type adc_ordinary_trig, confirm_state new_state)
enable or disable the ordinary channel's external trigger and set external trigger event of the speci...
Definition: at32f413_adc.c:599
adc_calibration_init
void adc_calibration_init(adc_type *adc_x)
initialize calibration register of the specified adc peripheral.
Definition: at32f413_adc.c:199
adc_calibration_init_status_get
flag_status adc_calibration_init_status_get(adc_type *adc_x)
get calibration register's initialize status of the specified adc peripheral.
Definition: at32f413_adc.c:211
adc_dma_mode_enable
void adc_dma_mode_enable(adc_type *adc_x, confirm_state new_state)
enable or disable the adc dma transfer.
Definition: at32f413_adc.c:161
adc_combine_mode_select
void adc_combine_mode_select(adc_combine_mode_type combine_mode)
select combine mode of the specified adc peripheral.
Definition: at32f413_adc.c:97
adc_ordinary_channel_set
void adc_ordinary_channel_set(adc_type *adc_x, adc_channel_select_type adc_channel, uint8_t adc_sequence, adc_sampletime_select_type adc_sampletime)
set ordinary channel's corresponding rank in the sequencer and sample time of the specified adc perip...
Definition: at32f413_adc.c:343
ADC_VMONITOR_SINGLE_ORDINARY
@ ADC_VMONITOR_SINGLE_ORDINARY
Definition: at32f413_adc.h:199
ADC_RIGHT_ALIGNMENT
@ ADC_RIGHT_ALIGNMENT
Definition: at32f413_adc.h:101
ADC_CHANNEL_4
@ ADC_CHANNEL_4
Definition: at32f413_adc.h:114
ADC_CHANNEL_6
@ ADC_CHANNEL_6
Definition: at32f413_adc.h:116
ADC_CHANNEL_5
@ ADC_CHANNEL_5
Definition: at32f413_adc.h:115
ADC_SAMPLETIME_239_5
@ ADC_SAMPLETIME_239_5
Definition: at32f413_adc.h:142
ADC_INDEPENDENT_MODE
@ ADC_INDEPENDENT_MODE
Definition: at32f413_adc.h:84
ADC12_ORDINARY_TRIG_SOFTWARE
@ ADC12_ORDINARY_TRIG_SOFTWARE
Definition: at32f413_adc.h:158
ADC_VMOR_INT
#define ADC_VMOR_INT
Definition: at32f413_adc.h:53
ADC1
#define ADC1
Definition: at32f413_adc.h:559
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_adc_clock_div_set
void crm_adc_clock_div_set(crm_adc_div_type div_value)
set crm adc division
Definition: at32f413_crm.c:455
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_ADC1_PERIPH_CLOCK
@ CRM_ADC1_PERIPH_CLOCK
Definition: at32f413_crm.h:115
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_ADC_DIV_6
@ CRM_ADC_DIV_6
Definition: at32f413_crm.h:348
ADC1_2_IRQn
@ ADC1_2_IRQn
Definition: at32f413.h:152
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_ANALOG
@ GPIO_MODE_ANALOG
Definition: at32f413_gpio.h:217
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
adc_base_config_type
adc base config type
Definition: at32f413_adc.h:212
adc_base_config_type::data_align
adc_data_align_type data_align
Definition: at32f413_adc.h:215
adc_base_config_type::repeat_mode
confirm_state repeat_mode
Definition: at32f413_adc.h:214
adc_base_config_type::sequence_mode
confirm_state sequence_mode
Definition: at32f413_adc.h:213
adc_base_config_type::ordinary_channel_length
uint8_t ordinary_channel_length
Definition: at32f413_adc.h:216
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • bpr
  • bpr_data
  • inc
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • bpr
  • bpr_data
  • inc
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • bpr
  • bpr_data
  • inc
project/at_start_f413/examples/bpr/bpr_data/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • bpr
  • bpr_data
  • src
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • bpr
  • bpr_data
  • src
project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • bpr
  • bpr_data
  • src
project/at_start_f413/examples/bpr/bpr_data/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define BPR_DR_NUMBER 42
39
40 bpr_data_type bpr_addr_tab[BPR_DR_NUMBER] =
41{
42 BPR_DATA1, BPR_DATA2, BPR_DATA3, BPR_DATA4, BPR_DATA5,
43 BPR_DATA6, BPR_DATA7, BPR_DATA8, BPR_DATA9, BPR_DATA10,
44 BPR_DATA11, BPR_DATA12, BPR_DATA13, BPR_DATA14, BPR_DATA15,
45 BPR_DATA16, BPR_DATA17, BPR_DATA18, BPR_DATA19, BPR_DATA20,
46 BPR_DATA21, BPR_DATA22, BPR_DATA23, BPR_DATA24, BPR_DATA25,
47 BPR_DATA26, BPR_DATA27, BPR_DATA28, BPR_DATA29, BPR_DATA30,
48 BPR_DATA31, BPR_DATA32, BPR_DATA33, BPR_DATA34, BPR_DATA35,
49 BPR_DATA36, BPR_DATA37, BPR_DATA38, BPR_DATA39, BPR_DATA40,
50 BPR_DATA41, BPR_DATA42
51};
52
53void bpr_reg_write(void);
54uint8_t bpr_reg_check(void);
55void uart_init(uint32_t baudrate);
56
62void bpr_reg_write(void)
63{
64 uint32_t index = 0;
65
66 for(index = 0; index < BPR_DR_NUMBER; index++)
67 {
68 bpr_data_write(bpr_addr_tab[index], 0x5A00 | bpr_addr_tab[index]);
69 }
70}
71
80uint8_t bpr_reg_check(void)
81{
82 uint32_t index = 0;
83
84 for(index = 0; index < BPR_DR_NUMBER; index++)
85 {
86 if(bpr_data_read(bpr_addr_tab[index]) != (0x5A00 | bpr_addr_tab[index]))
87 {
88 return FALSE;
89 }
90 }
91
92 return TRUE;
93}
94
100int main(void)
101{
102 system_clock_config();
103
104 uart_print_init(115200);
105
106 /* enable pwc and bpr clock */
107 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
108 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
109
110 /* enable write access to bpr domain */
111 pwc_battery_powered_domain_access(TRUE);
112
113 /* clear tamper pin event pending flag */
114 bpr_flag_clear(BPR_TAMPER_EVENT_FLAG);
115
116 /* check data from bpr dt register */
117 if(bpr_reg_check() == TRUE)
118 {
119 printf("bpr reg => none reset\r\n");
120 }
121 else
122 {
123 printf("bpr reg => reset\r\n");
124 }
125
126 /* reset bpr domain */
127 bpr_reset();
128
129 /* write data to bpr dt register */
130 bpr_reg_write();
131
132 /* check if the written data are correct */
133 if(bpr_reg_check() == TRUE)
134 {
135 printf("write bpr reg ok\r\n");
136 }
137 else
138 {
139 printf("write bpr reg fail\r\n");
140 }
141
142 /* disable pwc and bpr clock for power saving */
143 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, FALSE);
144 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, FALSE);
145
146 while(1)
147 {
148 }
149}
150
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
bpr_addr_tab
bpr_data_type bpr_addr_tab[42]
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:40
BPR_DR_NUMBER
#define BPR_DR_NUMBER
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:38
bpr_reg_write
void bpr_reg_write(void)
write data to bpr dt register.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:62
main
int main(void)
main function.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:100
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
bpr_reg_check
uint8_t bpr_reg_check(void)
checks if the bpr dt register values are correct or not.
Definition: project/at_start_f413/examples/bpr/bpr_data/src/main.c:80
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:49
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:116
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:83
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:133
bpr_data_type
bpr_data_type
battery powered register data type
Definition: at32f413_bpr.h:67
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:93
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:95
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:98
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:75
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:92
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:106
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:74
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:79
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:96
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:86
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:68
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:103
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:76
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:77
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:94
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:87
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:105
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:104
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:108
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:80
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:71
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:99
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:83
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:78
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:91
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:90
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:72
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:85
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:84
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:109
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:88
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:100
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:107
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:97
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:69
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:81
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:82
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:70
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:89
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:101
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:102
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:73
BPR_TAMPER_EVENT_FLAG
#define BPR_TAMPER_EVENT_FLAG
Definition: at32f413_bpr.h:53
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:140
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:61
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • bpr
  • tamper
  • inc
project/at_start_f413/examples/bpr/tamper/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • bpr
  • tamper
  • inc
project/at_start_f413/examples/bpr/tamper/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • bpr
  • tamper
  • inc
project/at_start_f413/examples/bpr/tamper/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • bpr
  • tamper
  • src
project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • bpr
  • tamper
  • src
project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31extern uint32_t bpr_reg_judge(void);
32
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void TAMPER_IRQHandler(void)
144{
145 if(bpr_flag_get(BPR_TAMPER_INTERRUPT_FLAG) != RESET)
146 {
147 /* check if bpr registers are cleared */
148 if(bpr_reg_judge() == 0)
149 {
150 /* ok, bpr registers are reset as expected */
151 at32_led_on(LED3);
152 }
153 else
154 {
155 /* bpr registers are not reset */
156 at32_led_off(LED3);
157 }
158
159 /* clear tamper pin interrupt pending bit */
160 bpr_flag_clear(BPR_TAMPER_INTERRUPT_FLAG);
161
162 /* clear tamper pin event(te) pending flag */
163 bpr_flag_clear(BPR_TAMPER_EVENT_FLAG);
164
165 /* disable tamper pin */
166 bpr_tamper_pin_enable(FALSE);
167
168 /* enable tamper pin */
169 bpr_tamper_pin_enable(TRUE);
170 }
171}
172
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:107
bpr_reg_judge
uint32_t bpr_reg_judge(void)
checks if the bpr dt registers are reset or not.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:103
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:46
TAMPER_IRQHandler
void TAMPER_IRQHandler(void)
this function handles tamper interrupt request.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:143
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/bpr/tamper/src/at32f413_int.c:116
LED3
@ LED3
Definition: at32f413_board.h:64
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:176
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:83
bpr_flag_get
flag_status bpr_flag_get(uint32_t flag)
bpr event flag get, for tamper event flag
Definition: at32f413_bpr.c:63
BPR_TAMPER_EVENT_FLAG
#define BPR_TAMPER_EVENT_FLAG
Definition: at32f413_bpr.h:53
BPR_TAMPER_INTERRUPT_FLAG
#define BPR_TAMPER_INTERRUPT_FLAG
Definition: at32f413_bpr.h:52
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • bpr
  • tamper
  • src
project/at_start_f413/examples/bpr/tamper/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define BPR_DR_NUMBER 42
39
40 bpr_data_type bpr_addr_tab[BPR_DR_NUMBER] =
41{
42 BPR_DATA1, BPR_DATA2, BPR_DATA3, BPR_DATA4, BPR_DATA5,
43 BPR_DATA6, BPR_DATA7, BPR_DATA8, BPR_DATA9, BPR_DATA10,
44 BPR_DATA11, BPR_DATA12, BPR_DATA13, BPR_DATA14, BPR_DATA15,
45 BPR_DATA16, BPR_DATA17, BPR_DATA18, BPR_DATA19, BPR_DATA20,
46 BPR_DATA21, BPR_DATA22, BPR_DATA23, BPR_DATA24, BPR_DATA25,
47 BPR_DATA26, BPR_DATA27, BPR_DATA28, BPR_DATA29, BPR_DATA30,
48 BPR_DATA31, BPR_DATA32, BPR_DATA33, BPR_DATA34, BPR_DATA35,
49 BPR_DATA36, BPR_DATA37, BPR_DATA38, BPR_DATA39, BPR_DATA40,
50 BPR_DATA41, BPR_DATA42
51};
52
53void bpr_reg_write(void);
54uint8_t bpr_reg_check(void);
55uint32_t bpr_reg_judge(void);
56
62void bpr_reg_write(void)
63{
64 uint32_t index = 0;
65
66 for(index = 0; index < BPR_DR_NUMBER; index++)
67 {
68 bpr_data_write(bpr_addr_tab[index], 0x5A00 | bpr_addr_tab[index]);
69 }
70}
71
80uint8_t bpr_reg_check(void)
81{
82 uint32_t index = 0;
83
84 for(index = 0; index < BPR_DR_NUMBER; index++)
85 {
86 if(bpr_data_read(bpr_addr_tab[index]) != (0x5A00 | bpr_addr_tab[index]))
87 {
88 return FALSE;
89 }
90 }
91
92 return TRUE;
93}
94
103uint32_t bpr_reg_judge(void)
104{
105 uint32_t index = 0;
106
107 for(index = 0; index < BPR_DR_NUMBER; index++)
108 {
109 if(bpr_data_read(bpr_addr_tab[index]) != 0x0000)
110 {
111 return (index + 1);
112 }
113 }
114
115 return 0;
116}
117
123int main(void)
124{
125 /* config nvic priority group */
126 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
127
128 system_clock_config();
129
130 at32_board_init();
131
132 /* nvic configuration */
133 nvic_irq_enable(TAMPER_IRQn, 0, 0);
134
135 /* enable pwc and bpr clock */
136 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
137 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
138
139 /* enable write access to bpr domain */
140 pwc_battery_powered_domain_access(TRUE);
141
142 /* disable tamper pin */
143 bpr_tamper_pin_enable(FALSE);
144
145 /* disable tamper interrupt */
146 bpr_interrupt_enable(FALSE);
147
148 /* tamper pin active on low level */
149 bpr_tamper_pin_active_level_set(BPR_TAMPER_PIN_ACTIVE_LOW);
150
151 /* clear tamper pin event pending flag */
152 bpr_flag_clear(BPR_TAMPER_EVENT_FLAG);
153
154 /* write data to bpr dt registers */
155 bpr_reg_write();
156
157 /* enable tamper interrupt */
158 bpr_interrupt_enable(TRUE);
159
160 /* enable tamper pin */
161 bpr_tamper_pin_enable(TRUE);
162
163 /* check if the written data are correct */
164 if(bpr_reg_check() == TRUE)
165 {
166 at32_led_on(LED2);
167 }
168 else
169 {
170 at32_led_off(LED2);
171 }
172
173 while(1)
174 {
175 }
176}
177
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
bpr_addr_tab
bpr_data_type bpr_addr_tab[42]
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:40
BPR_DR_NUMBER
#define BPR_DR_NUMBER
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:38
bpr_reg_judge
uint32_t bpr_reg_judge(void)
checks if the bpr dt registers are reset or not.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:103
bpr_reg_write
void bpr_reg_write(void)
write data to bpr dt registers.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:62
main
int main(void)
main function.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:123
bpr_reg_check
uint8_t bpr_reg_check(void)
checks if the bpr dt registers values are correct or not.
Definition: project/at_start_f413/examples/bpr/tamper/src/main.c:80
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:176
bpr_interrupt_enable
void bpr_interrupt_enable(confirm_state new_state)
enable or disable bpr tamper interrupt
Definition: at32f413_bpr.c:100
bpr_tamper_pin_active_level_set
void bpr_tamper_pin_active_level_set(bpr_tamper_pin_active_level_type active_level)
set bpr tamper pin active level
Definition: at32f413_bpr.c:189
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:116
bpr_flag_clear
void bpr_flag_clear(uint32_t flag)
clear bpr tamper flag
Definition: at32f413_bpr.c:83
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:133
bpr_data_type
bpr_data_type
battery powered register data type
Definition: at32f413_bpr.h:67
BPR_DATA26
@ BPR_DATA26
Definition: at32f413_bpr.h:93
BPR_DATA28
@ BPR_DATA28
Definition: at32f413_bpr.h:95
BPR_DATA31
@ BPR_DATA31
Definition: at32f413_bpr.h:98
BPR_DATA8
@ BPR_DATA8
Definition: at32f413_bpr.h:75
BPR_DATA25
@ BPR_DATA25
Definition: at32f413_bpr.h:92
BPR_DATA39
@ BPR_DATA39
Definition: at32f413_bpr.h:106
BPR_DATA7
@ BPR_DATA7
Definition: at32f413_bpr.h:74
BPR_DATA12
@ BPR_DATA12
Definition: at32f413_bpr.h:79
BPR_DATA29
@ BPR_DATA29
Definition: at32f413_bpr.h:96
BPR_DATA19
@ BPR_DATA19
Definition: at32f413_bpr.h:86
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:68
BPR_DATA36
@ BPR_DATA36
Definition: at32f413_bpr.h:103
BPR_DATA9
@ BPR_DATA9
Definition: at32f413_bpr.h:76
BPR_DATA10
@ BPR_DATA10
Definition: at32f413_bpr.h:77
BPR_DATA27
@ BPR_DATA27
Definition: at32f413_bpr.h:94
BPR_DATA20
@ BPR_DATA20
Definition: at32f413_bpr.h:87
BPR_DATA38
@ BPR_DATA38
Definition: at32f413_bpr.h:105
BPR_DATA37
@ BPR_DATA37
Definition: at32f413_bpr.h:104
BPR_DATA41
@ BPR_DATA41
Definition: at32f413_bpr.h:108
BPR_DATA13
@ BPR_DATA13
Definition: at32f413_bpr.h:80
BPR_DATA4
@ BPR_DATA4
Definition: at32f413_bpr.h:71
BPR_DATA32
@ BPR_DATA32
Definition: at32f413_bpr.h:99
BPR_DATA16
@ BPR_DATA16
Definition: at32f413_bpr.h:83
BPR_DATA11
@ BPR_DATA11
Definition: at32f413_bpr.h:78
BPR_DATA24
@ BPR_DATA24
Definition: at32f413_bpr.h:91
BPR_DATA23
@ BPR_DATA23
Definition: at32f413_bpr.h:90
BPR_DATA5
@ BPR_DATA5
Definition: at32f413_bpr.h:72
BPR_DATA18
@ BPR_DATA18
Definition: at32f413_bpr.h:85
BPR_DATA17
@ BPR_DATA17
Definition: at32f413_bpr.h:84
BPR_DATA42
@ BPR_DATA42
Definition: at32f413_bpr.h:109
BPR_DATA21
@ BPR_DATA21
Definition: at32f413_bpr.h:88
BPR_DATA33
@ BPR_DATA33
Definition: at32f413_bpr.h:100
BPR_DATA40
@ BPR_DATA40
Definition: at32f413_bpr.h:107
BPR_DATA30
@ BPR_DATA30
Definition: at32f413_bpr.h:97
BPR_DATA2
@ BPR_DATA2
Definition: at32f413_bpr.h:69
BPR_DATA14
@ BPR_DATA14
Definition: at32f413_bpr.h:81
BPR_DATA15
@ BPR_DATA15
Definition: at32f413_bpr.h:82
BPR_DATA3
@ BPR_DATA3
Definition: at32f413_bpr.h:70
BPR_DATA22
@ BPR_DATA22
Definition: at32f413_bpr.h:89
BPR_DATA34
@ BPR_DATA34
Definition: at32f413_bpr.h:101
BPR_DATA35
@ BPR_DATA35
Definition: at32f413_bpr.h:102
BPR_DATA6
@ BPR_DATA6
Definition: at32f413_bpr.h:73
BPR_TAMPER_PIN_ACTIVE_LOW
@ BPR_TAMPER_PIN_ACTIVE_LOW
Definition: at32f413_bpr.h:132
BPR_TAMPER_EVENT_FLAG
#define BPR_TAMPER_EVENT_FLAG
Definition: at32f413_bpr.h:53
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:140
TAMPER_IRQn
@ TAMPER_IRQn
Definition: at32f413.h:135
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:61
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • can
  • communication_mode
  • inc
project/at_start_f413/examples/can/communication_mode/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • can
  • communication_mode
  • inc
project/at_start_f413/examples/can/communication_mode/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • can
  • communication_mode
  • inc
project/at_start_f413/examples/can/communication_mode/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • can
  • communication_mode
  • src
project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • can
  • communication_mode
  • src
project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/can/communication_mode/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • can
  • communication_mode
  • src
project/at_start_f413/examples/can/communication_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
43static void can_gpio_config(void)
44{
45 gpio_init_type gpio_init_struct;
46
47 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
48 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
49 gpio_pin_remap_config(CAN1_GMUX_0010,TRUE);
50
51 gpio_default_para_init(&gpio_init_struct);
52 /* can tx pin */
53 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
54 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
55 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
56 gpio_init_struct.gpio_pins = GPIO_PINS_9;
57 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
58 gpio_init(GPIOB, &gpio_init_struct);
59 /* can rx pin */
60 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
61 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
62 gpio_init_struct.gpio_pins = GPIO_PINS_8;
63 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
64 gpio_init(GPIOB, &gpio_init_struct);
65}
66
72static void can_configuration(void)
73{
74 can_base_type can_base_struct;
75 can_baudrate_type can_baudrate_struct;
76 can_filter_init_type can_filter_init_struct;
77
78 crm_periph_clock_enable(CRM_CAN1_PERIPH_CLOCK, TRUE);
79 /* can base init */
80 can_default_para_init(&can_base_struct);
81 can_base_struct.mode_selection = CAN_MODE_COMMUNICATE;
82 can_base_struct.ttc_enable = FALSE;
83 can_base_struct.aebo_enable = TRUE;
84 can_base_struct.aed_enable = TRUE;
85 can_base_struct.prsf_enable = FALSE;
86 can_base_struct.mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
87 can_base_struct.mmssr_selection = CAN_SENDING_BY_ID;
88 can_base_init(CAN1, &can_base_struct);
89
90 /* can baudrate, set baudrate = pclk/(baudrate_div *(1 + bts1_size + bts2_size)) */
91 can_baudrate_struct.baudrate_div = 8;
92 can_baudrate_struct.rsaw_size = CAN_RSAW_3TQ;
93 can_baudrate_struct.bts1_size = CAN_BTS1_8TQ;
94 can_baudrate_struct.bts2_size = CAN_BTS2_3TQ;
95 can_baudrate_set(CAN1, &can_baudrate_struct);
96
97 /* can filter init */
98 can_filter_init_struct.filter_activate_enable = TRUE;
99 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_MASK;
100 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
101 can_filter_init_struct.filter_number = 0;
102 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
103 can_filter_init_struct.filter_id_high = 0;
104 can_filter_init_struct.filter_id_low = 0;
105 can_filter_init_struct.filter_mask_high = 0;
106 can_filter_init_struct.filter_mask_low = 0;
107 can_filter_init(CAN1, &can_filter_init_struct);
108
109 /* can interrupt config */
110 nvic_irq_enable(CAN1_SE_IRQn, 0x00, 0x00);
111 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0x00, 0x00);
112 can_interrupt_enable(CAN1, CAN_RF0MIEN_INT, TRUE);
113
114 /* error interrupt enable */
115 can_interrupt_enable(CAN1, CAN_ETRIEN_INT, TRUE);
116 can_interrupt_enable(CAN1, CAN_EOIEN_INT, TRUE);
117}
118
124static void can_transmit_data(void)
125{
126 uint8_t transmit_mailbox;
127 can_tx_message_type tx_message_struct;
128 tx_message_struct.standard_id = 0x400;
129 tx_message_struct.extended_id = 0;
130 tx_message_struct.id_type = CAN_ID_STANDARD;
131 tx_message_struct.frame_type = CAN_TFT_DATA;
132 tx_message_struct.dlc = 8;
133 tx_message_struct.data[0] = 0x11;
134 tx_message_struct.data[1] = 0x22;
135 tx_message_struct.data[2] = 0x33;
136 tx_message_struct.data[3] = 0x44;
137 tx_message_struct.data[4] = 0x55;
138 tx_message_struct.data[5] = 0x66;
139 tx_message_struct.data[6] = 0x77;
140 tx_message_struct.data[7] = 0x88;
141 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
142 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
143}
144
150void USBFS_L_CAN1_RX0_IRQHandler (void)
151{
152 can_rx_message_type rx_message_struct;
153 if(can_flag_get(CAN1,CAN_RF0MN_FLAG) != RESET)
154 {
155 can_message_receive(CAN1, CAN_RX_FIFO0, &rx_message_struct);
156 if(rx_message_struct.standard_id == 0x400)
157 at32_led_toggle(LED2);
158 else
159 at32_led_toggle(LED3);
160 }
161}
162
168void CAN1_SE_IRQHandler(void)
169{
170 __IO uint32_t err_index = 0;
171 if(can_flag_get(CAN1,CAN_ETR_FLAG) != RESET)
172 {
173 err_index = CAN1->ests & 0x70;
174 can_flag_clear(CAN1, CAN_ETR_FLAG);
175 /* error type is stuff error */
176 if(err_index == 0x00000010)
177 {
178 /* when stuff error occur: in order to ensure communication normally,
179 user must restart can or send a frame of highest priority message here */
180 }
181 }
182}
183
189int main(void)
190{
191 system_clock_config();
192 at32_board_init();
193 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
194 can_gpio_config();
195 can_configuration();
196 while(1)
197 {
198 can_transmit_data();
199 at32_led_toggle(LED4);
200 delay_sec(1);
201 }
202}
203
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
CAN1_SE_IRQHandler
void CAN1_SE_IRQHandler(void)
can1 interrupt function se
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:168
can_transmit_data
static void can_transmit_data(void)
can transmit data
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:124
main
int main(void)
main function.
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:189
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
can1 interrupt function rx0
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:150
can_gpio_config
static void can_gpio_config(void)
can gpio config
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:43
can_configuration
static void can_configuration(void)
can configiguration.
Definition: project/at_start_f413/examples/can/communication_mode/src/main.c:72
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:194
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:514
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1088
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:99
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:157
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:252
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:138
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:273
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:301
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:222
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f413_can.h:244
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f413_can.h:204
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f413_can.h:147
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:310
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:157
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:263
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:235
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f413_can.h:165
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f413_can.h:188
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f413_can.h:72
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f413_can.h:67
CAN_RF0MIEN_INT
#define CAN_RF0MIEN_INT
Definition: at32f413_can.h:92
CAN_EOIEN_INT
#define CAN_EOIEN_INT
Definition: at32f413_can.h:102
CAN_ETRIEN_INT
#define CAN_ETRIEN_INT
Definition: at32f413_can.h:101
CAN1
#define CAN1
Definition: at32f413_can.h:938
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f413.h:156
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
CAN1_GMUX_0010
#define CAN1_GMUX_0010
Definition: at32f413_gpio.h:171
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
can_base_type
can init structure definition
Definition: at32f413_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:359
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:383
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:420
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:406
can_tx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:411
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:398
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • can
  • filter
  • inc
project/at_start_f413/examples/can/filter/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • can
  • filter
  • inc
project/at_start_f413/examples/can/filter/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • can
  • filter
  • inc
project/at_start_f413/examples/can/filter/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • can
  • filter
  • src
project/at_start_f413/examples/can/filter/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/can/filter/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • can
  • filter
  • src
project/at_start_f413/examples/can/filter/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/can/filter/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • can
  • filter
  • src
project/at_start_f413/examples/can/filter/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38/* extended identifier */
39#define FILTER_EXT_ID1 ((uint32_t)0x18F5F100)
40#define FILTER_EXT_ID2 ((uint32_t)0x18F5F200)
41#define FILTER_EXT_ID3 ((uint32_t)0x18F5F300)
42
43/* standard identifier */
44#define FILTER_STD_ID1 ((uint16_t)0x04F6)
45#define FILTER_STD_ID2 ((uint16_t)0x04F7)
46#define FILTER_STD_ID3 ((uint16_t)0x04F8)
47
48uint8_t test_result = 0;
54static void can_gpio_config(void)
55{
56 gpio_init_type gpio_init_struct;
57
58 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
60 gpio_pin_remap_config(CAN1_GMUX_0010,TRUE);
61
62 gpio_default_para_init(&gpio_init_struct);
63
64 /* can tx pin */
65 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
66 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
67 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
68 gpio_init_struct.gpio_pins = GPIO_PINS_9;
69 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
70 gpio_init(GPIOB, &gpio_init_struct);
71
72 /* can rx pin */
73 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
74 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
75 gpio_init_struct.gpio_pins = GPIO_PINS_8;
76 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
77 gpio_init(GPIOB, &gpio_init_struct);
78}
79
85static void can_configuration(void)
86{
87 can_base_type can_base_struct;
88 can_baudrate_type can_baudrate_struct;
89 can_filter_init_type can_filter_init_struct;
90
91 crm_periph_clock_enable(CRM_CAN1_PERIPH_CLOCK, TRUE);
92 /* can base init */
93 can_default_para_init(&can_base_struct);
94 can_base_struct.mode_selection = CAN_MODE_COMMUNICATE;
95 can_base_struct.ttc_enable = FALSE;
96 can_base_struct.aebo_enable = TRUE;
97 can_base_struct.aed_enable = TRUE;
98 can_base_struct.prsf_enable = FALSE;
99 can_base_struct.mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
100 can_base_struct.mmssr_selection = CAN_SENDING_BY_ID;
101 can_base_init(CAN1, &can_base_struct);
102
103 /* can baudrate, set baudrate = pclk/(baudrate_div *(1 + bts1_size + bts2_size)) */
104 can_baudrate_struct.baudrate_div = 8;
105 can_baudrate_struct.rsaw_size = CAN_RSAW_3TQ;
106 can_baudrate_struct.bts1_size = CAN_BTS1_8TQ;
107 can_baudrate_struct.bts2_size = CAN_BTS2_3TQ;
108 can_baudrate_set(CAN1, &can_baudrate_struct);
109
110 /* can filter 0 config */
111 can_filter_init_struct.filter_activate_enable = TRUE;
112 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_LIST;
113 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
114 can_filter_init_struct.filter_number = 0;
115 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
116 can_filter_init_struct.filter_id_high = (((FILTER_EXT_ID1 << 3) >> 16) & 0xFFFF); /* extended identifier is 29 bit */
117 can_filter_init_struct.filter_id_low = ((FILTER_EXT_ID1 << 3) & 0xFFFF) | 0x04;
118 can_filter_init_struct.filter_mask_high = ((FILTER_EXT_ID2 << 3) >> 16) & 0xFFFF; /* extended identifier is 29 bit */
119 can_filter_init_struct.filter_mask_low = ((FILTER_EXT_ID2 << 3) & 0xFFFF) | 0x04;
120 can_filter_init(CAN1, &can_filter_init_struct);
121
122 /* can filter 1 config */
123 can_filter_init_struct.filter_activate_enable = TRUE;
124 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_LIST;
125 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
126 can_filter_init_struct.filter_number = 1;
127 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
128 can_filter_init_struct.filter_id_high = FILTER_STD_ID1 << 5; /* standard identifier is 11 bit */
129 can_filter_init_struct.filter_id_low = 0;
130 can_filter_init_struct.filter_mask_high = FILTER_STD_ID2 << 5;/* standard identifier is 11 bit */
131 can_filter_init_struct.filter_mask_low = 0;
132 can_filter_init(CAN1, &can_filter_init_struct);
133
134 /* can interrupt config */
135 nvic_irq_enable(CAN1_SE_IRQn, 0x00, 0x00);
136 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0x00, 0x00);
137 can_interrupt_enable(CAN1, CAN_RF0MIEN_INT, TRUE);
138
139 /* error interrupt enable */
140 can_interrupt_enable(CAN1, CAN_ETRIEN_INT, TRUE);
141 can_interrupt_enable(CAN1, CAN_EOIEN_INT, TRUE);
142}
143
149static void can_transmit_data(void)
150{
151 uint8_t transmit_mailbox;
152 can_tx_message_type tx_message_struct;
153
154 /* transmit FILTER_STD_ID1 */
155 tx_message_struct.standard_id = FILTER_STD_ID1;
156 tx_message_struct.extended_id = 0;
157 tx_message_struct.id_type = CAN_ID_STANDARD;
158 tx_message_struct.frame_type = CAN_TFT_DATA;
159 tx_message_struct.dlc = 8;
160 tx_message_struct.data[0] = 0x11;
161 tx_message_struct.data[1] = 0x22;
162 tx_message_struct.data[2] = 0x33;
163 tx_message_struct.data[3] = 0x44;
164 tx_message_struct.data[4] = 0x55;
165 tx_message_struct.data[5] = 0x66;
166 tx_message_struct.data[6] = 0x77;
167 tx_message_struct.data[7] = 0x88;
168 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
169 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
170
171 /* transmit FILTER_STD_ID2 */
172 tx_message_struct.standard_id = FILTER_STD_ID2;
173 tx_message_struct.extended_id = 0;
174 tx_message_struct.id_type = CAN_ID_STANDARD;
175 tx_message_struct.frame_type = CAN_TFT_DATA;
176 tx_message_struct.dlc = 8;
177 tx_message_struct.data[0] = 0x11;
178 tx_message_struct.data[1] = 0x22;
179 tx_message_struct.data[2] = 0x33;
180 tx_message_struct.data[3] = 0x44;
181 tx_message_struct.data[4] = 0x55;
182 tx_message_struct.data[5] = 0x66;
183 tx_message_struct.data[6] = 0x77;
184 tx_message_struct.data[7] = 0x88;
185 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
186 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
187
188 /* transmit FILTER_STD_ID3 */
189 tx_message_struct.standard_id = FILTER_STD_ID3;
190 tx_message_struct.extended_id = 0;
191 tx_message_struct.id_type = CAN_ID_STANDARD;
192 tx_message_struct.frame_type = CAN_TFT_DATA;
193 tx_message_struct.dlc = 8;
194 tx_message_struct.data[0] = 0x11;
195 tx_message_struct.data[1] = 0x22;
196 tx_message_struct.data[2] = 0x33;
197 tx_message_struct.data[3] = 0x44;
198 tx_message_struct.data[4] = 0x55;
199 tx_message_struct.data[5] = 0x66;
200 tx_message_struct.data[6] = 0x77;
201 tx_message_struct.data[7] = 0x88;
202 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
203 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
204
205 /* transmit FILTER_EXT_ID1 */
206 tx_message_struct.standard_id = 0;
207 tx_message_struct.extended_id = FILTER_EXT_ID1;
208 tx_message_struct.id_type = CAN_ID_EXTENDED;
209 tx_message_struct.frame_type = CAN_TFT_DATA;
210 tx_message_struct.dlc = 8;
211 tx_message_struct.data[0] = 0x11;
212 tx_message_struct.data[1] = 0x22;
213 tx_message_struct.data[2] = 0x33;
214 tx_message_struct.data[3] = 0x44;
215 tx_message_struct.data[4] = 0x55;
216 tx_message_struct.data[5] = 0x66;
217 tx_message_struct.data[6] = 0x77;
218 tx_message_struct.data[7] = 0x88;
219 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
220 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
221
222 /* transmit FILTER_EXT_ID2 */
223 tx_message_struct.standard_id = 0;
224 tx_message_struct.extended_id = FILTER_EXT_ID2;
225 tx_message_struct.id_type = CAN_ID_EXTENDED;
226 tx_message_struct.frame_type = CAN_TFT_DATA;
227 tx_message_struct.dlc = 8;
228 tx_message_struct.data[0] = 0x11;
229 tx_message_struct.data[1] = 0x22;
230 tx_message_struct.data[2] = 0x33;
231 tx_message_struct.data[3] = 0x44;
232 tx_message_struct.data[4] = 0x55;
233 tx_message_struct.data[5] = 0x66;
234 tx_message_struct.data[6] = 0x77;
235 tx_message_struct.data[7] = 0x88;
236 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
237 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
238
239 /* transmit FILTER_EXT_ID3 */
240 tx_message_struct.standard_id = 0;
241 tx_message_struct.extended_id = FILTER_EXT_ID3;
242 tx_message_struct.id_type = CAN_ID_EXTENDED;
243 tx_message_struct.frame_type = CAN_TFT_DATA;
244 tx_message_struct.dlc = 8;
245 tx_message_struct.data[0] = 0x11;
246 tx_message_struct.data[1] = 0x22;
247 tx_message_struct.data[2] = 0x33;
248 tx_message_struct.data[3] = 0x44;
249 tx_message_struct.data[4] = 0x55;
250 tx_message_struct.data[5] = 0x66;
251 tx_message_struct.data[6] = 0x77;
252 tx_message_struct.data[7] = 0x88;
253 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
254 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
255}
256
262void USBFS_L_CAN1_RX0_IRQHandler (void)
263{
264 can_rx_message_type rx_message_struct;
265 if(can_flag_get(CAN1,CAN_RF0MN_FLAG) != RESET)
266 {
267 if(test_result == 4)
268 {
269 test_result = 0;
270 }
271
272 can_message_receive(CAN1, CAN_RX_FIFO0, &rx_message_struct);
273
274 if((rx_message_struct.id_type == CAN_ID_STANDARD) && (rx_message_struct.standard_id == FILTER_STD_ID1))
275 test_result++;
276 else if((rx_message_struct.id_type == CAN_ID_STANDARD) && (rx_message_struct.standard_id == FILTER_STD_ID2))
277 test_result++;
278 else if((rx_message_struct.id_type == CAN_ID_EXTENDED) && (rx_message_struct.extended_id == FILTER_EXT_ID1))
279 test_result++;
280 else if((rx_message_struct.id_type == CAN_ID_EXTENDED) && (rx_message_struct.extended_id == FILTER_EXT_ID2))
281 test_result++;
282 }
283}
284
290void CAN1_SE_IRQHandler(void)
291{
292 __IO uint32_t err_index = 0;
293 if(can_flag_get(CAN1,CAN_ETR_FLAG) != RESET)
294 {
295 err_index = CAN1->ests & 0x70;
296 can_flag_clear(CAN1, CAN_ETR_FLAG);
297 /* error type is stuff error */
298 if(err_index == 0x00000010)
299 {
300 /* when stuff error occur: in order to ensure communication normally,
301 user must restart can or send a frame of highest priority message here */
302 }
303 }
304}
305
311int main(void)
312{
313 system_clock_config();
314 at32_board_init();
315 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
316 can_gpio_config();
317 can_configuration();
318 can_transmit_data();
319 while(1)
320 {
321 if(test_result == 4)
322 {
323 at32_led_toggle(LED2);
324 at32_led_toggle(LED3);
325 at32_led_toggle(LED4);
326 delay_sec(1);
327 }
328 }
329}
330
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
CAN1_SE_IRQHandler
void CAN1_SE_IRQHandler(void)
can1 interrupt function se
Definition: project/at_start_f413/examples/can/filter/src/main.c:290
FILTER_EXT_ID3
#define FILTER_EXT_ID3
Definition: project/at_start_f413/examples/can/filter/src/main.c:41
FILTER_EXT_ID1
#define FILTER_EXT_ID1
Definition: project/at_start_f413/examples/can/filter/src/main.c:39
FILTER_STD_ID2
#define FILTER_STD_ID2
Definition: project/at_start_f413/examples/can/filter/src/main.c:45
can_transmit_data
static void can_transmit_data(void)
can transmit data
Definition: project/at_start_f413/examples/can/filter/src/main.c:149
main
int main(void)
main function.
Definition: project/at_start_f413/examples/can/filter/src/main.c:311
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
can1 interrupt function rx0
Definition: project/at_start_f413/examples/can/filter/src/main.c:262
FILTER_EXT_ID2
#define FILTER_EXT_ID2
Definition: project/at_start_f413/examples/can/filter/src/main.c:40
FILTER_STD_ID3
#define FILTER_STD_ID3
Definition: project/at_start_f413/examples/can/filter/src/main.c:46
FILTER_STD_ID1
#define FILTER_STD_ID1
Definition: project/at_start_f413/examples/can/filter/src/main.c:44
can_gpio_config
static void can_gpio_config(void)
can gpio config
Definition: project/at_start_f413/examples/can/filter/src/main.c:54
can_configuration
static void can_configuration(void)
can configiguration.
Definition: project/at_start_f413/examples/can/filter/src/main.c:85
test_result
uint8_t test_result
Definition: project/at_start_f413/examples/can/filter/src/main.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:194
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:514
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1088
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:99
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:157
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:252
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:138
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:273
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:301
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:222
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f413_can.h:244
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f413_can.h:204
CAN_FILTER_MODE_ID_LIST
@ CAN_FILTER_MODE_ID_LIST
Definition: at32f413_can.h:148
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:310
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:157
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:263
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:235
CAN_ID_EXTENDED
@ CAN_ID_EXTENDED
Definition: at32f413_can.h:236
CAN_MODE_COMMUNICATE
@ CAN_MODE_COMMUNICATE
Definition: at32f413_can.h:165
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f413_can.h:188
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f413_can.h:72
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f413_can.h:67
CAN_RF0MIEN_INT
#define CAN_RF0MIEN_INT
Definition: at32f413_can.h:92
CAN_EOIEN_INT
#define CAN_EOIEN_INT
Definition: at32f413_can.h:102
CAN_ETRIEN_INT
#define CAN_ETRIEN_INT
Definition: at32f413_can.h:101
CAN1
#define CAN1
Definition: at32f413_can.h:938
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f413.h:156
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
CAN1_GMUX_0010
#define CAN1_GMUX_0010
Definition: at32f413_gpio.h:171
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
can_base_type
can init structure definition
Definition: at32f413_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:359
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:383
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:420
can_rx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:426
can_rx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:423
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:406
can_tx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:411
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:398
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • can
  • loopback_mode
  • inc
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • can
  • loopback_mode
  • inc
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • can
  • loopback_mode
  • inc
project/at_start_f413/examples/can/loopback_mode/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • can
  • loopback_mode
  • src
project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • can
  • loopback_mode
  • src
project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/can/loopback_mode/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • can
  • loopback_mode
  • src
project/at_start_f413/examples/can/loopback_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
43static void can_gpio_config(void)
44{
45 gpio_init_type gpio_init_struct;
46
47 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
48 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
49 gpio_pin_remap_config(CAN1_GMUX_0010,TRUE);
50
51 gpio_default_para_init(&gpio_init_struct);
52 /* can tx pin */
53 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
54 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
55 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
56 gpio_init_struct.gpio_pins = GPIO_PINS_9;
57 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
58 gpio_init(GPIOB, &gpio_init_struct);
59 /* can rx pin */
60 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
61 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
62 gpio_init_struct.gpio_pins = GPIO_PINS_8;
63 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
64 gpio_init(GPIOB, &gpio_init_struct);
65}
66
72static void can_configuration(void)
73{
74 can_base_type can_base_struct;
75 can_baudrate_type can_baudrate_struct;
76 can_filter_init_type can_filter_init_struct;
77
78 crm_periph_clock_enable(CRM_CAN1_PERIPH_CLOCK, TRUE);
79 /* can base init */
80 can_default_para_init(&can_base_struct);
81 can_base_struct.mode_selection = CAN_MODE_LOOPBACK;
82 can_base_struct.ttc_enable = FALSE;
83 can_base_struct.aebo_enable = TRUE;
84 can_base_struct.aed_enable = TRUE;
85 can_base_struct.prsf_enable = FALSE;
86 can_base_struct.mdrsel_selection = CAN_DISCARDING_FIRST_RECEIVED;
87 can_base_struct.mmssr_selection = CAN_SENDING_BY_ID;
88 can_base_init(CAN1, &can_base_struct);
89
90 /* can baudrate, set baudrate = pclk/(baudrate_div *(1 + bts1_size + bts2_size)) */
91 can_baudrate_struct.baudrate_div = 8;
92 can_baudrate_struct.rsaw_size = CAN_RSAW_3TQ;
93 can_baudrate_struct.bts1_size = CAN_BTS1_8TQ;
94 can_baudrate_struct.bts2_size = CAN_BTS2_3TQ;
95 can_baudrate_set(CAN1, &can_baudrate_struct);
96
97 /* can filter init */
98 can_filter_init_struct.filter_activate_enable = TRUE;
99 can_filter_init_struct.filter_mode = CAN_FILTER_MODE_ID_MASK;
100 can_filter_init_struct.filter_fifo = CAN_FILTER_FIFO0;
101 can_filter_init_struct.filter_number = 0;
102 can_filter_init_struct.filter_bit = CAN_FILTER_32BIT;
103 can_filter_init_struct.filter_id_high = 0;
104 can_filter_init_struct.filter_id_low = 0;
105 can_filter_init_struct.filter_mask_high = 0;
106 can_filter_init_struct.filter_mask_low = 0;
107 can_filter_init(CAN1, &can_filter_init_struct);
108
109 /* can interrupt config */
110 nvic_irq_enable(CAN1_SE_IRQn, 0x00, 0x00);
111 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0x00, 0x00);
112 can_interrupt_enable(CAN1, CAN_RF0MIEN_INT, TRUE);
113
114 /* error interrupt enable */
115 can_interrupt_enable(CAN1, CAN_ETRIEN_INT, TRUE);
116 can_interrupt_enable(CAN1, CAN_EOIEN_INT, TRUE);
117}
118
124static void can_transmit_data(void)
125{
126 uint8_t transmit_mailbox;
127 can_tx_message_type tx_message_struct;
128 tx_message_struct.standard_id = 0x400;
129 tx_message_struct.extended_id = 0;
130 tx_message_struct.id_type = CAN_ID_STANDARD;
131 tx_message_struct.frame_type = CAN_TFT_DATA;
132 tx_message_struct.dlc = 8;
133 tx_message_struct.data[0] = 0x11;
134 tx_message_struct.data[1] = 0x22;
135 tx_message_struct.data[2] = 0x33;
136 tx_message_struct.data[3] = 0x44;
137 tx_message_struct.data[4] = 0x55;
138 tx_message_struct.data[5] = 0x66;
139 tx_message_struct.data[6] = 0x77;
140 tx_message_struct.data[7] = 0x88;
141 transmit_mailbox = can_message_transmit(CAN1, &tx_message_struct);
142 while(can_transmit_status_get(CAN1, (can_tx_mailbox_num_type)transmit_mailbox) != CAN_TX_STATUS_SUCCESSFUL);
143}
144
150void USBFS_L_CAN1_RX0_IRQHandler (void)
151{
152 can_rx_message_type rx_message_struct;
153 if(can_flag_get(CAN1,CAN_RF0MN_FLAG) != RESET)
154 {
155 can_message_receive(CAN1, CAN_RX_FIFO0, &rx_message_struct);
156 if(rx_message_struct.standard_id == 0x400)
157 at32_led_toggle(LED2);
158 }
159}
160
166void CAN1_SE_IRQHandler(void)
167{
168 __IO uint32_t err_index = 0;
169 if(can_flag_get(CAN1,CAN_ETR_FLAG) != RESET)
170 {
171 err_index = CAN1->ests & 0x70;
172 can_flag_clear(CAN1, CAN_ETR_FLAG);
173 /* error type is stuff error */
174 if(err_index == 0x00000010)
175 {
176 /* when stuff error occur: in order to ensure communication normally,
177 user must restart can or send a frame of highest priority message here */
178 }
179 }
180}
181
187int main(void)
188{
189 system_clock_config();
190 at32_board_init();
191 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
192 can_gpio_config();
193 can_configuration();
194 while(1)
195 {
196 can_transmit_data();
197 at32_led_toggle(LED4);
198 delay_sec(1);
199 }
200}
201
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
CAN1_SE_IRQHandler
void CAN1_SE_IRQHandler(void)
can1 interrupt function se
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:166
can_transmit_data
static void can_transmit_data(void)
can transmit data
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:124
main
int main(void)
main function.
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:187
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
can1 interrupt function rx0
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:150
can_gpio_config
static void can_gpio_config(void)
can gpio config
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:43
can_configuration
static void can_configuration(void)
can configiguration.
Definition: project/at_start_f413/examples/can/loopback_mode/src/main.c:72
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
can_base_init
error_status can_base_init(can_type *can_x, can_base_type *can_base_struct)
initialize the can peripheral according to the specified parameters in the can_init_struct.
Definition: at32f413_can.c:194
can_transmit_status_get
can_transmit_status_type can_transmit_status_get(can_type *can_x, can_tx_mailbox_num_type transmit_mailbox)
check the transmission state of the specified can peripheral.
Definition: at32f413_can.c:514
can_message_transmit
uint8_t can_message_transmit(can_type *can_x, can_tx_message_type *tx_message_struct)
fill the transmission message and transmit of the specified can peripheral.
Definition: at32f413_can.c:440
can_message_receive
void can_message_receive(can_type *can_x, can_rx_fifo_num_type fifo_number, can_rx_message_type *rx_message_struct)
receive message of the specified can peripheral.
Definition: at32f413_can.c:619
can_interrupt_enable
void can_interrupt_enable(can_type *can_x, uint32_t can_int, confirm_state new_state)
enable or disable the interrupt of the specified can peripheral.
Definition: at32f413_can.c:924
can_flag_get
flag_status can_flag_get(can_type *can_x, uint32_t can_flag)
get flag of the specified can peripheral.
Definition: at32f413_can.c:964
can_flag_clear
void can_flag_clear(can_type *can_x, uint32_t can_flag)
clear flag of the specified can peripheral.
Definition: at32f413_can.c:1088
can_baudrate_set
error_status can_baudrate_set(can_type *can_x, can_baudrate_type *can_baudrate_struct)
set the baudrate of the can peripheral
Definition: at32f413_can.c:99
can_filter_init
void can_filter_init(can_type *can_x, can_filter_init_type *can_filter_init_struct)
initialize the can peripheral according to the specified parameters in the can_filter_init_struct.
Definition: at32f413_can.c:304
can_default_para_init
void can_default_para_init(can_base_type *can_base_struct)
fill each can_init_struct member with its default value.
Definition: at32f413_can.c:157
can_tx_mailbox_num_type
can_tx_mailbox_num_type
can tx mailboxes
Definition: at32f413_can.h:252
CAN_FILTER_FIFO0
@ CAN_FILTER_FIFO0
Definition: at32f413_can.h:138
CAN_TX_STATUS_SUCCESSFUL
@ CAN_TX_STATUS_SUCCESSFUL
Definition: at32f413_can.h:273
CAN_DISCARDING_FIRST_RECEIVED
@ CAN_DISCARDING_FIRST_RECEIVED
Definition: at32f413_can.h:301
CAN_BTS2_3TQ
@ CAN_BTS2_3TQ
Definition: at32f413_can.h:222
CAN_TFT_DATA
@ CAN_TFT_DATA
Definition: at32f413_can.h:244
CAN_BTS1_8TQ
@ CAN_BTS1_8TQ
Definition: at32f413_can.h:204
CAN_FILTER_MODE_ID_MASK
@ CAN_FILTER_MODE_ID_MASK
Definition: at32f413_can.h:147
CAN_SENDING_BY_ID
@ CAN_SENDING_BY_ID
Definition: at32f413_can.h:310
CAN_FILTER_32BIT
@ CAN_FILTER_32BIT
Definition: at32f413_can.h:157
CAN_RX_FIFO0
@ CAN_RX_FIFO0
Definition: at32f413_can.h:263
CAN_ID_STANDARD
@ CAN_ID_STANDARD
Definition: at32f413_can.h:235
CAN_MODE_LOOPBACK
@ CAN_MODE_LOOPBACK
Definition: at32f413_can.h:166
CAN_RSAW_3TQ
@ CAN_RSAW_3TQ
Definition: at32f413_can.h:188
CAN_RF0MN_FLAG
#define CAN_RF0MN_FLAG
Definition: at32f413_can.h:72
CAN_ETR_FLAG
#define CAN_ETR_FLAG
Definition: at32f413_can.h:67
CAN_RF0MIEN_INT
#define CAN_RF0MIEN_INT
Definition: at32f413_can.h:92
CAN_EOIEN_INT
#define CAN_EOIEN_INT
Definition: at32f413_can.h:102
CAN_ETRIEN_INT
#define CAN_ETRIEN_INT
Definition: at32f413_can.h:101
CAN1
#define CAN1
Definition: at32f413_can.h:938
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_CAN1_PERIPH_CLOCK
@ CRM_CAN1_PERIPH_CLOCK
Definition: at32f413_crm.h:139
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
CAN1_SE_IRQn
@ CAN1_SE_IRQn
Definition: at32f413.h:156
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
CAN1_GMUX_0010
#define CAN1_GMUX_0010
Definition: at32f413_gpio.h:171
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
can_base_type
can init structure definition
Definition: at32f413_can.h:333
can_base_type::prsf_enable
confirm_state prsf_enable
Definition: at32f413_can.h:342
can_base_type::mdrsel_selection
can_msg_discarding_rule_type mdrsel_selection
Definition: at32f413_can.h:344
can_base_type::aed_enable
confirm_state aed_enable
Definition: at32f413_can.h:340
can_base_type::mmssr_selection
can_msg_sending_rule_type mmssr_selection
Definition: at32f413_can.h:346
can_base_type::ttc_enable
confirm_state ttc_enable
Definition: at32f413_can.h:336
can_base_type::mode_selection
can_mode_type mode_selection
Definition: at32f413_can.h:334
can_base_type::aebo_enable
confirm_state aebo_enable
Definition: at32f413_can.h:338
can_baudrate_type
can baudrate structure definition
Definition: at32f413_can.h:354
can_baudrate_type::baudrate_div
uint16_t baudrate_div
Definition: at32f413_can.h:355
can_baudrate_type::rsaw_size
can_rsaw_type rsaw_size
Definition: at32f413_can.h:357
can_baudrate_type::bts2_size
can_bts2_type bts2_size
Definition: at32f413_can.h:361
can_baudrate_type::bts1_size
can_bts1_type bts1_size
Definition: at32f413_can.h:359
can_filter_init_type
can filter init structure definition
Definition: at32f413_can.h:369
can_filter_init_type::filter_mask_low
uint16_t filter_mask_low
Definition: at32f413_can.h:389
can_filter_init_type::filter_number
uint8_t filter_number
Definition: at32f413_can.h:376
can_filter_init_type::filter_fifo
can_filter_fifo_type filter_fifo
Definition: at32f413_can.h:374
can_filter_init_type::filter_bit
can_filter_bit_width_type filter_bit
Definition: at32f413_can.h:378
can_filter_init_type::filter_mode
can_filter_mode_type filter_mode
Definition: at32f413_can.h:372
can_filter_init_type::filter_activate_enable
confirm_state filter_activate_enable
Definition: at32f413_can.h:370
can_filter_init_type::filter_mask_high
uint16_t filter_mask_high
Definition: at32f413_can.h:386
can_filter_init_type::filter_id_high
uint16_t filter_id_high
Definition: at32f413_can.h:380
can_filter_init_type::filter_id_low
uint16_t filter_id_low
Definition: at32f413_can.h:383
can_rx_message_type
can rx message structure definition
Definition: at32f413_can.h:419
can_rx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:420
can_tx_message_type
can tx message structure definition
Definition: at32f413_can.h:397
can_tx_message_type::extended_id
uint32_t extended_id
Definition: at32f413_can.h:401
can_tx_message_type::frame_type
can_trans_frame_type frame_type
Definition: at32f413_can.h:406
can_tx_message_type::data
uint8_t data[8]
Definition: at32f413_can.h:411
can_tx_message_type::dlc
uint8_t dlc
Definition: at32f413_can.h:408
can_tx_message_type::id_type
can_identifier_type id_type
Definition: at32f413_can.h:404
can_tx_message_type::standard_id
uint32_t standard_id
Definition: at32f413_can.h:398
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • cortex_m4
  • bit_band
  • inc
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • cortex_m4
  • bit_band
  • inc
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • cortex_m4
  • bit_band
  • inc
project/at_start_f413/examples/cortex_m4/bit_band/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • cortex_m4
  • bit_band
  • src
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • cortex_m4
  • bit_band
  • src
project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • cortex_m4
  • bit_band
  • src
project/at_start_f413/examples/cortex_m4/bit_band/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
39/* bit band for sram */
40#define RAM_BASE 0x20000000
41#define RAM_BITBAND_BASE 0x22000000
42
43#define VARIABLES_RESET_BIT(variables_addr, bit_number) \
44 (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 0)
45
46#define VARIABLES_SET_BIT(variables_addr, bit_number) \
47 (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)) = 1)
48
49#define VARIABLES_GET_BIT(variables_addr, bit_number) \
50 (*(uint32_t *)(RAM_BITBAND_BASE + ((variables_addr - RAM_BASE) * 32) + ((bit_number) * 4)))
51
52/* bit band for peripheral */
53#define PERIPHERAL_BASE 0x40000000
54#define PERIPHERAL_BITBAND_BASE 0x42000000
55
56#define PERIPHERAL_RESET_BIT(peripheral_addr, bit_number) \
57 (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 0)
58
59#define PERIPHERAL_SET_BIT(peripheral_addr, bit_number) \
60 (*(uint32_t *)(PERIPHERAL_BITBAND_BASE + ((peripheral_addr - PERIPHERAL_BASE) * 32) + ((bit_number) * 4)) = 1)
61
62__IO uint32_t variables, variables_addr = 0, variables_bit_val = 0;
63
69void result_error(void)
70{
71 while(1)
72 {
73 at32_led_toggle(LED4);
74 delay_sec(1);
75 }
76}
77
83int main(void)
84{
85 system_clock_config();
86 at32_board_init();
87 variables = 0xA5A5A5A5;
88
89 /* get the variables address */
90 variables_addr = (uint32_t)&variables;
91
92 /* modify variables bit0 and check result */
93 VARIABLES_RESET_BIT(variables_addr, 0);
94 if((variables != 0xA5A5A5A4) || (VARIABLES_GET_BIT(variables_addr, 0) != 0))
95 {
96 result_error();
97 }
98
99 /* modify variables bit0 and check result */
100 VARIABLES_SET_BIT(variables_addr, 0);
101 if((variables != 0xA5A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 0) != 1))
102 {
103 result_error();
104 }
105
106 /* modify variables bit16 and check result */
107 VARIABLES_RESET_BIT(variables_addr, 16);
108 if((variables != 0xA5A4A5A5) || (VARIABLES_GET_BIT(variables_addr, 16) != 0))
109 {
110 result_error();
111 }
112
113 /* modify variables bit16 and check result */
114 VARIABLES_SET_BIT(variables_addr, 16);
115 if((variables != 0xA5A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 16) != 1))
116 {
117 result_error();
118 }
119
120 /* modify variables bit31 and check result */
121 VARIABLES_RESET_BIT(variables_addr, 31);
122 if((variables != 0x25A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 31) != 0))
123 {
124 result_error();
125 }
126
127 /* modify variables bit31 and check result */
128 VARIABLES_SET_BIT(variables_addr, 31);
129 if((variables != 0xA5A5A5A5) || (VARIABLES_GET_BIT(variables_addr, 31) != 1))
130 {
131 result_error();
132 }
133
134 while(1)
135 {
136 /* led2 toggle */
137 PERIPHERAL_RESET_BIT((uint32_t)&LED2_GPIO->odt, 2);
138 delay_ms(500);
139 PERIPHERAL_SET_BIT((uint32_t)&LED2_GPIO->odt, 2);
140 delay_ms(500);
141 }
142}
143
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
variables
__IO uint32_t variables
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:62
variables_addr
__IO uint32_t variables_addr
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:62
variables_bit_val
__IO uint32_t variables_bit_val
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:62
PERIPHERAL_SET_BIT
#define PERIPHERAL_SET_BIT(peripheral_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:59
main
int main(void)
main function.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:83
result_error
void result_error(void)
led4 flick for error.
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:69
VARIABLES_SET_BIT
#define VARIABLES_SET_BIT(variables_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:46
PERIPHERAL_RESET_BIT
#define PERIPHERAL_RESET_BIT(peripheral_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:56
VARIABLES_RESET_BIT
#define VARIABLES_RESET_BIT(variables_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:43
VARIABLES_GET_BIT
#define VARIABLES_GET_BIT(variables_addr, bit_number)
Definition: project/at_start_f413/examples/cortex_m4/bit_band/src/main.c:49
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED4
@ LED4
Definition: at32f413_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • cortex_m4
  • cmsis_dsp
  • inc
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • cortex_m4
  • cmsis_dsp
  • inc
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • cortex_m4
  • cmsis_dsp
  • inc
project/at_start_f413/examples/cortex_m4/cmsis_dsp/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • cortex_m4
  • cmsis_dsp
  • src
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • cortex_m4
  • cmsis_dsp
  • src
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • cortex_m4
  • cmsis_dsp
  • src
project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "arm_math.h"
30
39#define USE_STATIC_INIT
40
41 /* Global defines */
42
43#define TEST_LENGTH_SAMPLES (20*4)
44
45/* List of Marks scored by 20 students for 4 subjects */
46const float32_t testMarks_f32[TEST_LENGTH_SAMPLES] =
47{
48 42.000000, 37.000000, 81.000000, 28.000000,
49 83.000000, 72.000000, 36.000000, 38.000000,
50 32.000000, 51.000000, 63.000000, 64.000000,
51 97.000000, 82.000000, 95.000000, 90.000000,
52 66.000000, 51.000000, 54.000000, 42.000000,
53 67.000000, 56.000000, 45.000000, 57.000000,
54 67.000000, 69.000000, 35.000000, 52.000000,
55 29.000000, 81.000000, 58.000000, 47.000000,
56 38.000000, 76.000000, 100.000000, 29.000000,
57 33.000000, 47.000000, 29.000000, 50.000000,
58 34.000000, 41.000000, 61.000000, 46.000000,
59 52.000000, 50.000000, 48.000000, 36.000000,
60 47.000000, 55.000000, 44.000000, 40.000000,
61 100.000000, 94.000000, 84.000000, 37.000000,
62 32.000000, 71.000000, 47.000000, 77.000000,
63 31.000000, 50.000000, 49.000000, 35.000000,
64 63.000000, 67.000000, 40.000000, 31.000000,
65 29.000000, 68.000000, 61.000000, 38.000000,
66 31.000000, 28.000000, 28.000000, 76.000000,
67 55.000000, 33.000000, 29.000000, 39.000000
68};
69
70
71/* Number of subjects X 1 */
72const float32_t testUnity_f32[4] =
73{
74 1.000, 1.000, 1.000, 1.000
75};
76
77
78/* f32 Output buffer */
79static float32_t testOutput[TEST_LENGTH_SAMPLES];
80
81
82/* Global defines */
83#define NUMSTUDENTS 20
84#define NUMSUBJECTS 4
85
86/* Global variables */
87
88uint32_t numStudents = 20;
89uint32_t numSubjects = 4;
90float32_t max_marks, min_marks, mean, std, var;
91uint32_t student_num;
92
98int32_t main()
99{
100 system_clock_config();
101
102 uart_print_init(115200);
103
104#ifndef USE_STATIC_INIT
105
106 arm_matrix_instance_f32 srcA;
107 arm_matrix_instance_f32 srcB;
108 arm_matrix_instance_f32 dstC;
109
110 /* Input and output matrices initializations */
111 arm_mat_init_f32(&srcA, numStudents, numSubjects, (float32_t *)testMarks_f32);
112 arm_mat_init_f32(&srcB, numSubjects, 1, (float32_t *)testUnity_f32);
113 arm_mat_init_f32(&dstC, numStudents, 1, testOutput);
114
115#else
116
117 /* Static Initializations of Input and output matrix sizes and array */
118 arm_matrix_instance_f32 srcA = {NUMSTUDENTS, NUMSUBJECTS, (float32_t *)testMarks_f32};
119 arm_matrix_instance_f32 srcB = {NUMSUBJECTS, 1, (float32_t *)testUnity_f32};
120 arm_matrix_instance_f32 dstC = {NUMSTUDENTS, 1, testOutput};
121
122#endif
123
124 /* Call the Matrix multiplication process function */
125 arm_mat_mult_f32(&srcA, &srcB, &dstC);
126
127 /* Call the Max function to calculate max marks among numStudents */
128 arm_max_f32(testOutput, numStudents, &max_marks, &student_num);
129
130 /* Call the Min function to calculate min marks among numStudents */
131 arm_min_f32(testOutput, numStudents, &min_marks, &student_num);
132
133 /* Call the Mean function to calculate mean */
134 arm_mean_f32(testOutput, numStudents, &mean);
135
136 /* Call the std function to calculate standard deviation */
137 arm_std_f32(testOutput, numStudents, &std);
138
139 /* Call the var function to calculate variance */
140 arm_var_f32(testOutput, numStudents, &var);
141
142 printf("max_marks = %f, min_marks = %f, mean = %f, std = %f, var = %f\n", max_marks, min_marks, mean, std, var);
143
144 while (1);
145}
146
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
testMarks_f32
const float32_t testMarks_f32[(20 *4)]
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:46
std
float32_t std
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:90
main
int32_t main()
main function.
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:98
var
float32_t var
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:90
numSubjects
uint32_t numSubjects
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:89
student_num
uint32_t student_num
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:91
NUMSUBJECTS
#define NUMSUBJECTS
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:84
testUnity_f32
const float32_t testUnity_f32[4]
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:72
NUMSTUDENTS
#define NUMSTUDENTS
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:83
max_marks
float32_t max_marks
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:90
numStudents
uint32_t numStudents
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:88
min_marks
float32_t min_marks
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:90
TEST_LENGTH_SAMPLES
#define TEST_LENGTH_SAMPLES
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:43
mean
float32_t mean
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:90
testOutput
static float32_t testOutput[(20 *4)]
Definition: project/at_start_f413/examples/cortex_m4/cmsis_dsp/src/main.c:79
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • cortex_m4
  • fpu
  • inc
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • cortex_m4
  • fpu
  • inc
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • cortex_m4
  • fpu
  • inc
project/at_start_f413/examples/cortex_m4/fpu/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • cortex_m4
  • fpu
  • src
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • cortex_m4
  • fpu
  • src
project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:106
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:124
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:45
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:80
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/at32f413_int.c:115
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • cortex_m4
  • fpu
  • src
project/at_start_f413/examples/cortex_m4/fpu/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "julia_fpu.h"
30
39#define SCREEN_X_SIZE ((uint16_t)160)
40#define SCREEN_Y_SIZE ((uint16_t)120)
41#define ZOOM ((uint16_t)100)
42
43uint8_t buffer[SCREEN_X_SIZE * SCREEN_Y_SIZE];
44
50int main(void)
51{
52 system_clock_config();
53
54 at32_board_init();
55
56 while(1)
57 {
58 at32_led_toggle(LED4);
59
60 generate_julia_fpu(SCREEN_X_SIZE, SCREEN_Y_SIZE, SCREEN_X_SIZE / 2, SCREEN_Y_SIZE / 2, ZOOM, buffer);
61 }
62}
63
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
SCREEN_X_SIZE
#define SCREEN_X_SIZE
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:50
ZOOM
#define ZOOM
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:41
SCREEN_Y_SIZE
#define SCREEN_Y_SIZE
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:40
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
generate_julia_fpu
void generate_julia_fpu(uint16_t size_x, uint16_t size_y, uint16_t offset_x, uint16_t offset_y, uint16_t zoom, uint8_t *buffer)
julia calculation test with fpu option enable or disable
Definition: julia_fpu.c:48
julia_fpu.h
julia_fpu header file
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • cortex_m4
  • systick_interrupt
  • inc
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • cortex_m4
  • systick_interrupt
  • inc
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • cortex_m4
  • systick_interrupt
  • inc
project/at_start_f413/examples/cortex_m4/systick_interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • cortex_m4
  • systick_interrupt
  • src
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • cortex_m4
  • systick_interrupt
  • src
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30extern void systick_handler(void);
31
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135 systick_handler();
136}
137
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:106
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:124
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:45
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:80
systick_handler
void systick_handler(void)
systick interrupt handler.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:46
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/at32f413_int.c:115
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • cortex_m4
  • systick_interrupt
  • src
project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define MS_TICK (system_core_clock / 1000U)
39#define DELAY 200 /* 200 ms ticks */
40
46void systick_handler(void)
47{
48 static uint32_t ticks = 0;
49
50 ticks ++;
51
52 /* toggle led */
53 if(ticks > DELAY)
54 {
55 at32_led_toggle(LED2);
56 ticks = 0;
57 }
58}
59
65int main(void)
66{
67 system_clock_config();
68
69 /* config systick clock source */
70 systick_clock_source_config(SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV);
71
72 /* config systick reload value and enable interrupt */
73 SysTick_Config(MS_TICK);
74
75 /* configure led */
76 at32_led_init(LED2);
77
78 while(1)
79 {
80 }
81}
82
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
MS_TICK
#define MS_TICK
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:38
DELAY
#define DELAY
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:65
systick_handler
void systick_handler(void)
systick interrupt handler.
Definition: project/at_start_f413/examples/cortex_m4/systick_interrupt/src/main.c:46
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f413_board.c:216
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
systick_clock_source_config
void systick_clock_source_config(systick_clock_source_type source)
config systick clock source
Definition: at32f413_misc.c:147
SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
@ SYSTICK_CLOCK_SOURCE_AHBCLK_NODIV
Definition: at32f413_misc.h:90
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • crc
  • calculation
  • inc
project/at_start_f413/examples/crc/calculation/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • crc
  • calculation
  • inc
project/at_start_f413/examples/crc/calculation/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • crc
  • calculation
  • inc
project/at_start_f413/examples/crc/calculation/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • crc
  • calculation
  • src
project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • crc
  • calculation
  • src
project/at_start_f413/examples/crc/calculation/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/crc/calculation/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • crc
  • calculation
  • src
project/at_start_f413/examples/crc/calculation/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define BUFFER_SIZE 120
39
40static const uint32_t data_buffer[BUFFER_SIZE] =
41{
42 0xc33dd31c, 0xe37ff35e, 0x129022f3, 0x32d24235, 0x52146277, 0x7256b5ea,
43 0x4a755a54, 0x6a377a16, 0x0af11ad0, 0x2ab33a92, 0xed0fdd6c, 0xcd4dbdaa,
44 0xbb3bab1a, 0x6ca67c87, 0x5cc52c22, 0x3c030c60, 0x1c41edae, 0xfd8fcdec,
45 0xad8b9de8, 0x8dc97c26, 0x5c644c45, 0x3ca22c83, 0x1ce00cc1, 0xef1fff3e,
46 0x95a88589, 0xf56ee54f, 0xd52cc50d, 0x34e224c3, 0x04817466, 0x64475424,
47 0x78066827, 0x18c008e1, 0x28a3cb7d, 0xdb5ceb3f, 0xfb1e8bf9, 0x9bd8abbb,
48 0xdf7caf9b, 0xbfba8fd9, 0x9ff86e17, 0x7e364e55, 0x2e933eb2, 0x0ed11ef0,
49 0xa35ad3bd, 0xc39cf3ff, 0xe3de2462, 0x34430420, 0x64e674c7, 0x44a45485,
50 0xad2abd0b, 0x8d689d49, 0x7e976eb6, 0x5ed54ef4, 0x2e321e51, 0x0e70ff9f,
51 0xefbedfdd, 0xcffcbf1b, 0x9f598f78, 0x918881a9, 0xb1caa1eb, 0xd10cc12d,
52 0xe16f1080, 0x00a130c2, 0x20e35004, 0x40257046, 0x83b99398, 0xa3fbb3da,
53 0x00001021, 0x20423063, 0x408450a5, 0x60c670e7, 0x9129a14a, 0xb16bc18c,
54 0x569546b4, 0xb75ba77a, 0x97198738, 0xf7dfe7fe, 0xc7bc48c4, 0x58e56886,
55 0x4405a7db, 0xb7fa8799, 0xe75ff77e, 0xc71dd73c, 0x26d336f2, 0x069116b0,
56 0x76764615, 0x5634d94c, 0xc96df90e, 0xe92f99c8, 0xb98aa9ab, 0x58444865,
57 0x78a70840, 0x18612802, 0xc9ccd9ed, 0xe98ef9af, 0x89489969, 0xa90ab92b,
58 0xd1ade1ce, 0xf1ef1231, 0x32732252, 0x52b54294, 0x72f762d6, 0x93398318,
59 0xa56ab54b, 0x85289509, 0xf5cfc5ac, 0xd58d3653, 0x26721611, 0x063076d7,
60 0x8d689d49, 0xf7dfe7fe, 0xe98ef9af, 0x063076d7, 0x93398318, 0xb98aa9ab,
61 0x4ad47ab7, 0x6a961a71, 0x0a503a33, 0x2a12dbfd, 0xfbbfeb9e, 0x9b798b58
62};
63
64__IO uint32_t crc_value = 0;
65
71int main(void)
72{
73 system_clock_config();
74
75 at32_board_init();
76
77 /* enable crc clock */
78 crm_periph_clock_enable(CRM_CRC_PERIPH_CLOCK, TRUE);
79
80 crc_data_reset();
81
82 /* compute the crc of "data_buffer" */
83 crc_value = crc_block_calculate((uint32_t *)data_buffer, BUFFER_SIZE);
84
85 if(crc_value == 0xE5DFCF6D)
86 {
87 /* turn on led3 */
88 at32_led_on(LED3);
89 }
90 else
91 {
92 /* turn on led4 */
93 at32_led_on(LED4);
94 }
95
96 while(1)
97 {
98 }
99}
100
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:38
data_buffer
static const uint32_t data_buffer[120]
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:71
crc_value
__IO uint32_t crc_value
Definition: project/at_start_f413/examples/crc/calculation/src/main.c:64
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crc_block_calculate
uint32_t crc_block_calculate(uint32_t *pbuffer, uint32_t length)
compute the 32-bit crc of a given buffer of data word(32-bit).
Definition: at32f413_crc.c:72
crc_data_reset
void crc_data_reset(void)
reset the crc data register.
Definition: at32f413_crc.c:49
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_CRC_PERIPH_CLOCK
@ CRM_CRC_PERIPH_CLOCK
Definition: at32f413_crm.h:106
TRUE
@ TRUE
Definition: at32f413.h:259
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • crm
  • clock_failure_detection
  • inc
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • crm
  • clock_failure_detection
  • inc
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • crm
  • clock_failure_detection
  • inc
project/at_start_f413/examples/crm/clock_failure_detection/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • crm
  • clock_failure_detection
  • src
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • crm
  • clock_failure_detection
  • src
project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30extern void clock_failure_detection_handler(void);
31
45void NMI_Handler(void)
46{
47 clock_failure_detection_handler();
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:107
clock_failure_detection_handler
void clock_failure_detection_handler(void)
clock failure detection handler.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:76
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:45
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/at32f413_int.c:116
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • crm
  • clock_failure_detection
  • src
project/at_start_f413/examples/crm/clock_failure_detection/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38static void clkout_config(void);
39static void sclk_192m_hick_config(void);
40void clock_failure_detection_handler(void);
41
47static void clkout_config(void)
48{
49 gpio_init_type gpio_init_struct;
50
51 /* enable gpio port clock */
52 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
53
54 /* set default parameter */
55 gpio_default_para_init(&gpio_init_struct);
56
57 /* clkout gpio init */
58 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
59 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
60 gpio_init_struct.gpio_pins = GPIO_PINS_8;
61 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
62 gpio_init(GPIOA, &gpio_init_struct);
63
64 /* config clkout division */
65 crm_clkout_div_set(CRM_CLKOUT_DIV_1);
66
67 /* config clkout clock */
68 crm_clock_out_set(CRM_CLKOUT_PLL_DIV_4);
69}
70
76void clock_failure_detection_handler(void)
77{
78 /* check clock failure detection flag */
79 if(crm_flag_get(CRM_CLOCK_FAILURE_INT_FLAG) != RESET)
80 {
81 /* disable clock failure detection */
82 crm_clock_failure_detection_enable(FALSE);
83
84 /* config system clock */
85 sclk_192m_hick_config();
86
87 /* clear clock failure detection flag */
88 crm_flag_clear(CRM_CLOCK_FAILURE_INT_FLAG);
89 }
90}
91
110static void sclk_192m_hick_config(void)
111{
112 /* reset crm */
113 crm_reset();
114
115 crm_clock_source_enable(CRM_CLOCK_SOURCE_HICK, TRUE);
116
117 /* wait till hick is ready */
118 while(crm_flag_get(CRM_HICK_STABLE_FLAG) != SET)
119 {
120 }
121
122 /* config pll clock resource */
123 crm_pll_config(CRM_PLL_SOURCE_HICK, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
124
125 /* enable pll */
126 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
127
128 /* wait till pll is ready */
129 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
130 {
131 }
132
133 /* config ahbclk */
134 crm_ahb_div_set(CRM_AHB_DIV_1);
135
136 /* config apb2clk */
137 crm_apb2_div_set(CRM_APB2_DIV_2);
138
139 /* config apb1clk */
140 crm_apb1_div_set(CRM_APB1_DIV_2);
141
142 /* enable auto step mode */
143 crm_auto_step_mode_enable(TRUE);
144
145 /* select pll as system clock source */
146 crm_sysclk_switch(CRM_SCLK_PLL);
147
148 /* wait till pll is used as system clock source */
149 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
150 {
151 }
152
153 /* disable auto step mode */
154 crm_auto_step_mode_enable(FALSE);
155
156 /* update system_core_clock global variable */
157 system_core_clock_update();
158
159 /* config systick delay */
160 delay_init();
161
162 /* config clkout */
163 clkout_config();
164}
165
171int main(void)
172{
173 system_clock_config();
174
175 at32_board_init();
176
177 /* clkout config */
178 clkout_config();
179
180 /* enable clock failure detection */
181 crm_clock_failure_detection_enable(TRUE);
182
183 while(1)
184 {
185 at32_led_toggle(LED2);
186 delay_ms(200);
187 }
188}
189
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
clkout_config
static void clkout_config(void)
clkout configuration.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:47
clock_failure_detection_handler
void clock_failure_detection_handler(void)
clock failure detection handler.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:76
main
int main(void)
main function.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:171
sclk_192m_hick_config
static void sclk_192m_hick_config(void)
config sclk 192 mhz with hick clock source.
Definition: project/at_start_f413/examples/crm/clock_failure_detection/src/main.c:110
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
LED2
@ LED2
Definition: at32f413_board.h:63
delay_init
void delay_init()
initialize delay function
Definition: at32f413_board.c:291
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:804
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:330
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:683
crm_clock_failure_detection_enable
void crm_clock_failure_detection_enable(confirm_state new_state)
enable or disable clock failure detection
Definition: at32f413_crm.c:485
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:420
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:275
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_CLKOUT_PLL_DIV_4
@ CRM_CLKOUT_PLL_DIV_4
Definition: at32f413_crm.h:410
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
CRM_CLOCK_FAILURE_INT_FLAG
#define CRM_CLOCK_FAILURE_INT_FLAG
Definition: at32f413_crm.h:72
CRM_HICK_STABLE_FLAG
#define CRM_HICK_STABLE_FLAG
Definition: at32f413_crm.h:55
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • crm
  • sysclk_switch
  • inc
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • crm
  • sysclk_switch
  • inc
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • crm
  • sysclk_switch
  • inc
project/at_start_f413/examples/crm/sysclk_switch/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • crm
  • sysclk_switch
  • src
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • crm
  • sysclk_switch
  • src
project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • crm
  • sysclk_switch
  • src
project/at_start_f413/examples/crm/sysclk_switch/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38static void clkout_config(void);
39static void sclk_64m_hick_config(void);
40static void sclk_96m_hext_config(void);
41static void switch_system_clock(void);
42
48void clkout_config(void)
49{
50 gpio_init_type gpio_init_struct;
51
52 /* enable gpio port clock */
53 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
54
55 /* set default parameter */
56 gpio_default_para_init(&gpio_init_struct);
57
58 /* clkout gpio init */
59 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
60 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
61 gpio_init_struct.gpio_pins = GPIO_PINS_8;
62 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
63 gpio_init(GPIOA, &gpio_init_struct);
64
65 /* config clkout division */
66 crm_clkout_div_set(CRM_CLKOUT_DIV_1);
67
68 /* config clkout clock */
69 crm_clock_out_set(CRM_CLKOUT_PLL_DIV_4);
70}
71
77static void switch_system_clock(void)
78{
79 if(CRM->cfg_bit.pllrcs == RESET)
80 {
81 sclk_96m_hext_config();
82 }
83 else
84 {
85 sclk_64m_hick_config();
86 }
87}
88
107static void sclk_64m_hick_config(void)
108{
109 /* reset crm */
110 crm_reset();
111
112 crm_clock_source_enable(CRM_CLOCK_SOURCE_HICK, TRUE);
113
114 /* wait till hick is ready */
115 while(crm_flag_get(CRM_HICK_STABLE_FLAG) != SET)
116 {
117 }
118
119 /* config pll clock resource */
120 crm_pll_config(CRM_PLL_SOURCE_HICK, CRM_PLL_MULT_16, CRM_PLL_OUTPUT_RANGE_LE72MHZ);
121
122 /* enable pll */
123 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
124
125 /* wait till pll is ready */
126 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
127 {
128 }
129
130 /* config ahbclk */
131 crm_ahb_div_set(CRM_AHB_DIV_1);
132
133 /* config apb2clk */
134 crm_apb2_div_set(CRM_APB2_DIV_2);
135
136 /* config apb1clk */
137 crm_apb1_div_set(CRM_APB1_DIV_2);
138
139 /* enable auto step mode */
140 crm_auto_step_mode_enable(TRUE);
141
142 /* select pll as system clock source */
143 crm_sysclk_switch(CRM_SCLK_PLL);
144
145 /* wait till pll is used as system clock source */
146 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
147 {
148 }
149
150 /* disable auto step mode */
151 crm_auto_step_mode_enable(FALSE);
152
153 /* update system_core_clock global variable */
154 system_core_clock_update();
155
156 /* config systick delay */
157 delay_init();
158
159 /* config clkout */
160 clkout_config();
161}
162
181static void sclk_96m_hext_config(void)
182{
183 /* reset crm */
184 crm_reset();
185
186 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
187
188 /* wait till hext is ready */
189 while(crm_hext_stable_wait() == ERROR)
190 {
191 }
192
193 /* config pll clock resource */
194 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_24, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
195
196 /* enable pll */
197 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
198
199 /* wait till pll is ready */
200 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
201 {
202 }
203
204 /* config ahbclk */
205 crm_ahb_div_set(CRM_AHB_DIV_1);
206
207 /* config apb2clk */
208 crm_apb2_div_set(CRM_APB2_DIV_2);
209
210 /* config apb1clk */
211 crm_apb1_div_set(CRM_APB1_DIV_2);
212
213 /* enable auto step mode */
214 crm_auto_step_mode_enable(TRUE);
215
216 /* select pll as system clock source */
217 crm_sysclk_switch(CRM_SCLK_PLL);
218
219 /* wait till pll is used as system clock source */
220 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
221 {
222 }
223
224 /* disable auto step mode */
225 crm_auto_step_mode_enable(FALSE);
226
227 /* update system_core_clock global variable */
228 system_core_clock_update();
229
230 /* config systick delay */
231 delay_init();
232
233 /* config clkout */
234 clkout_config();
235}
236
242int main(void)
243{
244 system_clock_config();
245
246 at32_board_init();
247
248 clkout_config();
249
250 while(1)
251 {
252 if(at32_button_press() == USER_BUTTON)
253 {
254 switch_system_clock();
255 at32_led_toggle(LED4);
256 }
257 at32_led_toggle(LED2);
258 delay_ms(100);
259 }
260}
261
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
clkout_config
static void clkout_config(void)
clkout configuration.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:48
sclk_96m_hext_config
static void sclk_96m_hext_config(void)
config sclk 96 mhz with hext clock source.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:181
main
int main(void)
main function.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:242
sclk_64m_hick_config
static void sclk_64m_hick_config(void)
config sclk 64 mhz with hick clock source.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:107
switch_system_clock
static void switch_system_clock(void)
sclk switch function.
Definition: project/at_start_f413/examples/crm/sysclk_switch/src/main.c:77
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
delay_init
void delay_init()
initialize delay function
Definition: at32f413_board.c:291
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:804
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:683
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_HICK
@ CRM_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:294
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:420
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_SOURCE_HICK
@ CRM_PLL_SOURCE_HICK
Definition: at32f413_crm.h:275
CRM_PLL_MULT_24
@ CRM_PLL_MULT_24
Definition: at32f413_crm.h:227
CRM_PLL_MULT_16
@ CRM_PLL_MULT_16
Definition: at32f413_crm.h:219
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_CLKOUT_PLL_DIV_4
@ CRM_CLKOUT_PLL_DIV_4
Definition: at32f413_crm.h:410
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_LE72MHZ
@ CRM_PLL_OUTPUT_RANGE_LE72MHZ
Definition: at32f413_crm.h:285
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
CRM_HICK_STABLE_FLAG
#define CRM_HICK_STABLE_FLAG
Definition: at32f413_crm.h:55
CRM
#define CRM
Definition: at32f413_crm.h:844
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • debug
  • tmr1
  • inc
project/at_start_f413/examples/debug/tmr1/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • debug
  • tmr1
  • inc
project/at_start_f413/examples/debug/tmr1/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • debug
  • tmr1
  • inc
project/at_start_f413/examples/debug/tmr1/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • debug
  • tmr1
  • src
project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • debug
  • tmr1
  • src
project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/debug/tmr1/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • debug
  • tmr1
  • src
project/at_start_f413/examples/debug/tmr1/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
30
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40uint16_t counter = 0;
41
47void TMR1_OVF_TMR10_IRQHandler(void)
48{
49 if(tmr_flag_get(TMR1, TMR_OVF_FLAG) != RESET)
50 {
51 /* add user code... */
52 at32_led_toggle(LED3);
53 tmr_flag_clear(TMR1, TMR_OVF_FLAG);
54 }
55}
56
62int main(void)
63{
64 system_clock_config();
65
66 at32_board_init();
67
68 /* get system clock */
69 crm_clocks_freq_get(&crm_clocks_freq_struct);
70
71 /* turn led2/led3/led4 on */
72 at32_led_on(LED2);
73 at32_led_on(LED3);
74 at32_led_on(LED4);
75
76 /* enable tmr1 clock */
77 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
78
79 /* enable tmr1 debug mode */
80 debug_periph_mode_set(DEBUG_TMR1_PAUSE, TRUE);
81
82 /* tmr1 configuration */
83 tmr_base_init(TMR1, 10000, 0);
84 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
85
86 /* overflow interrupt enable */
87 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
88
89 /* tmr1 interrupt nvic init */
90 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
91 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 1, 0);
92
93 /* enable tmr1 */
94 tmr_counter_enable(TMR1, TRUE);
95
96 while(1)
97 {
98 /* in debug mode,tmr1 counter will pause */
99 counter = tmr_counter_value_get(TMR1);
100 counter = tmr_counter_value_get(TMR1);
101 counter = tmr_counter_value_get(TMR1);
102 counter = tmr_counter_value_get(TMR1);
103 counter = tmr_counter_value_get(TMR1);
104 }
105}
106
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:62
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:39
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
this function handles tmr1 overflow handler.
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:47
counter
uint16_t counter
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f413.h:159
debug_periph_mode_set
void debug_periph_mode_set(uint32_t periph_debug_mode, confirm_state new_state)
set periph debug mode
Definition: at32f413_debug.c:79
DEBUG_TMR1_PAUSE
#define DEBUG_TMR1_PAUSE
Definition: at32f413_debug.h:56
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f413_tmr.c:269
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:74
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • dma
  • data_to_gpio_flexible
  • inc
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • dma
  • data_to_gpio_flexible
  • inc
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • dma
  • data_to_gpio_flexible
  • inc
project/at_start_f413/examples/dma/data_to_gpio_flexible/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • dma
  • data_to_gpio_flexible
  • src
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • dma
  • data_to_gpio_flexible
  • src
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • dma
  • data_to_gpio_flexible
  • src
project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 dma_init_type dma_init_struct = {0};
40
41#define BUFFER_SIZE 16
42uint16_t src_buffer[BUFFER_SIZE] = {0x0001, 0x0002, 0x0003, 0x0004, 0x0005, 0x0006, 0x0007, 0x0008,
43 0x0009, 0x000A, 0x000B, 0x000C, 0x000D, 0x000E, 0x000F, 0x0010};
44
50void DMA2_Channel1_IRQHandler(void)
51{
52 if(dma_flag_get(DMA2_FDT1_FLAG) != RESET)
53 {
54 /* turn led2/led3/led4 on */
55 at32_led_on(LED2);
56 at32_led_on(LED3);
57 at32_led_on(LED4);
58 dma_flag_clear(DMA2_FDT1_FLAG);
59 }
60}
61
67int main(void)
68{
69 system_clock_config();
70
71 at32_board_init();
72
73 /* enable dma2/gpiob/tmr2 clock */
74 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
75 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
76 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
77 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
78 gpio_pin_remap_config(SWJTAG_CONF_010, TRUE);
79 /* config gpioc pin for output mode */
80 gpio_init_struct.gpio_pins = GPIO_PINS_ALL;
81 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
82 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
83 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
84 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
85 gpio_init(GPIOB, &gpio_init_struct);
86
87 tmr_base_init(TMR2, 0xFF, 0);
88 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
89
90 /* enable tmr2 overflow dma request */
91 tmr_dma_request_enable(TMR2, TMR_OVERFLOW_DMA_REQUEST, TRUE);
92
93 /* dma2 channel1 configuration */
94 dma_reset(DMA2_CHANNEL1);
95 dma_init_struct.buffer_size = BUFFER_SIZE;
96 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
97 dma_init_struct.memory_base_addr = (uint32_t)src_buffer;
98 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
99 dma_init_struct.memory_inc_enable = TRUE;
100 dma_init_struct.peripheral_base_addr = (uint32_t)&GPIOB->odt;
101 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
102 dma_init_struct.peripheral_inc_enable = FALSE;
103 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
104 dma_init_struct.loop_mode_enable = FALSE;
105 dma_init(DMA2_CHANNEL1, &dma_init_struct);
106
107 /* enable transfer full data intterrupt */
108 dma_interrupt_enable(DMA2_CHANNEL1, DMA_FDT_INT, TRUE);
109
110 /* dma2 channel1 interrupt nvic init */
111 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
112 nvic_irq_enable(DMA2_Channel1_IRQn, 1, 0);
113
114 /* tmr2 flexible function enable */
115 dma_flexible_config(DMA2, FLEX_CHANNEL1, DMA_FLEXIBLE_TMR2_OVERFLOW);
116
117 /* enable dma channel */
118 dma_channel_enable(DMA2_CHANNEL1, TRUE);
119
120 /* enable tmr2 */
121 tmr_counter_enable(TMR2, TRUE);
122
123 while(1)
124 {
125 }
126}
127
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
DMA2_Channel1_IRQHandler
void DMA2_Channel1_IRQHandler(void)
this function handles DMA2 channel1 handler.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:50
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:41
main
int main(void)
main function.
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:67
src_buffer
uint16_t src_buffer[16]
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f413_crm.h:105
DMA2_Channel1_IRQn
@ DMA2_Channel1_IRQn
Definition: at32f413.h:185
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:238
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_FLEXIBLE_TMR2_OVERFLOW
@ DMA_FLEXIBLE_TMR2_OVERFLOW
Definition: at32f413_dma.h:180
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:266
DMA2_FDT1_FLAG
#define DMA2_FDT1_FLAG
Definition: at32f413_dma.h:111
FLEX_CHANNEL1
#define FLEX_CHANNEL1
Definition: at32f413_dma.h:64
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA2
#define DMA2
Definition: at32f413_dma.h:488
DMA2_CHANNEL1
#define DMA2_CHANNEL1
Definition: at32f413_dma.h:489
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_ALL
#define GPIO_PINS_ALL
Definition: at32f413_gpio.h:67
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
SWJTAG_CONF_010
#define SWJTAG_CONF_010
Definition: at32f413_gpio.h:99
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1279
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f413_tmr.h:269
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • dma
  • flash_to_sram
  • inc
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • dma
  • flash_to_sram
  • inc
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • dma
  • flash_to_sram
  • inc
project/at_start_f413/examples/dma/flash_to_sram/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • dma
  • flash_to_sram
  • src
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • dma
  • flash_to_sram
  • src
project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135}
136
137
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:106
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:124
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:45
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:80
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/at32f413_int.c:115
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • dma
  • flash_to_sram
  • src
project/at_start_f413/examples/dma/flash_to_sram/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
39#define BUFFER_SIZE 32
40
41const uint32_t src_const_buffer[BUFFER_SIZE]= {0x01020304, 0x05060708, 0x090A0B0C, 0x0D0E0F10,
42 0x11121314, 0x15161718, 0x191A1B1C, 0x1D1E1F20,
43 0x21222324, 0x25262728, 0x292A2B2C, 0x2D2E2F30,
44 0x31323334, 0x35363738, 0x393A3B3C, 0x3D3E3F40,
45 0x41424344, 0x45464748, 0x494A4B4C, 0x4D4E4F50,
46 0x51525354, 0x55565758, 0x595A5B5C, 0x5D5E5F60,
47 0x61626364, 0x65666768, 0x696A6B6C, 0x6D6E6F70,
48 0x71727374, 0x75767778, 0x797A7B7C, 0x7D7E7F80};
49uint32_t dst_buffer[BUFFER_SIZE];
50 gpio_init_type gpio_init_struct = {0};
51 dma_init_type dma_init_struct = {0};
52__IO uint32_t data_counter_end = 0x01; /* this variable should not be initialized to 0 */
53 error_status transfer_status = ERROR;
54
55 error_status buffer_compare(const uint32_t* pbuffer, uint32_t* pbuffer1, uint16_t buffer_length);
56
62void DMA1_Channel1_IRQHandler(void)
63{
64 if(dma_flag_get(DMA1_FDT1_FLAG) != RESET)
65 {
66 data_counter_end = 0;
67 dma_flag_clear(DMA1_FDT1_FLAG);
68 }
69}
70
78 error_status buffer_compare(const uint32_t* pbuffer, uint32_t* pbuffer1, uint16_t buffer_length)
79{
80 while(buffer_length--)
81 {
82 if(*pbuffer != *pbuffer1)
83 {
84 return ERROR;
85 }
86
87 pbuffer++;
88 pbuffer1++;
89 }
90
91 return SUCCESS;
92}
93
99int main(void)
100{
101 system_clock_config();
102
103 at32_board_init();
104
105 /* enable dma1 clock */
106 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
107
108 /* dma1 channel1 configuration */
109 dma_reset(DMA1_CHANNEL1);
110 dma_init_struct.buffer_size = BUFFER_SIZE;
111 dma_init_struct.direction = DMA_DIR_MEMORY_TO_MEMORY;
112 dma_init_struct.memory_base_addr = (uint32_t)dst_buffer;
113 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
114 dma_init_struct.memory_inc_enable = TRUE;
115 dma_init_struct.peripheral_base_addr = (uint32_t)src_const_buffer;
116 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
117 dma_init_struct.peripheral_inc_enable = TRUE;
118 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
119 dma_init_struct.loop_mode_enable = FALSE;
120 dma_init(DMA1_CHANNEL1, &dma_init_struct);
121
122 /* enable transfer full data intterrupt */
123 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
124
125 /* dma1 channel1 interrupt nvic init */
126 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
127 nvic_irq_enable(DMA1_Channel1_IRQn, 1, 0);
128
129 dma_channel_enable(DMA1_CHANNEL1, TRUE);
130
131 /* wait the end of transmission */
132 while(data_counter_end != 0)
133 {
134 }
135
136 /* check if the transmitted and received data are equal */
137 transfer_status = buffer_compare(src_const_buffer, dst_buffer, BUFFER_SIZE);
138
139 /* transfer_status = passed, if the transmitted and received data are the same
140 transfer_status = failed, if the transmitted and received data are different */
141 if(transfer_status == SUCCESS)
142 {
143 /* turn led2/led3/led4 on */
144 at32_led_on(LED2);
145 at32_led_on(LED3);
146 at32_led_on(LED4);
147 }
148
149 while(1)
150 {
151 }
152}
153
154
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:50
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:51
src_const_buffer
const uint32_t src_const_buffer[32]
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:41
data_counter_end
__IO uint32_t data_counter_end
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:52
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:39
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1 channel1 handler.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:62
main
int main(void)
main function.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:99
dst_buffer
uint32_t dst_buffer[32]
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:49
buffer_compare
error_status buffer_compare(const uint32_t *pbuffer, uint32_t *pbuffer1, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:78
transfer_status
error_status transfer_status
Definition: project/at_start_f413/examples/dma/flash_to_sram/src/main.c:53
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:144
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:247
DMA_DIR_MEMORY_TO_MEMORY
@ DMA_DIR_MEMORY_TO_MEMORY
Definition: at32f413_dma.h:219
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:257
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:266
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • exint
  • exint_config
  • inc
project/at_start_f413/examples/exint/exint_config/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • exint
  • exint_config
  • inc
project/at_start_f413/examples/exint/exint_config/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • exint
  • exint_config
  • inc
project/at_start_f413/examples/exint/exint_config/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • exint
  • exint_config
  • src
project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • exint
  • exint_config
  • src
project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/exint/exint_config/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • exint
  • exint_config
  • src
project/at_start_f413/examples/exint/exint_config/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
30
40void exint_line0_config(void);
41
47int main(void)
48{
49 system_clock_config();
50
51 at32_board_init();
52
53 /* turn led2/led3/led4 on */
54 at32_led_on(LED2);
55 at32_led_on(LED3);
56 at32_led_on(LED4);
57
58 /* configure pa0 in interrupt mode */
59 exint_line0_config();
60
61 while(1)
62 {
63 }
64}
65
71void exint_line0_config(void)
72{
73 exint_init_type exint_init_struct;
74
75 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
76 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
77
78 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE0);
79
80 exint_default_para_init(&exint_init_struct);
81 exint_init_struct.line_enable = TRUE;
82 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
83 exint_init_struct.line_select = EXINT_LINE_0;
84 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
85 exint_init(&exint_init_struct);
86
87 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
88 nvic_irq_enable(EXINT0_IRQn, 1, 0);
89}
90
96void EXINT0_IRQHandler(void)
97{
98 if(exint_flag_get(EXINT_LINE_0) != RESET)
99 {
100 at32_led_toggle(LED2);
101 at32_led_toggle(LED3);
102 at32_led_toggle(LED4);
103 exint_flag_clear(EXINT_LINE_0);
104 }
105}
106
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:47
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:96
exint_line0_config
void exint_line0_config(void)
exint line0 config. configure pa0 in interrupt mode
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:71
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:139
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:93
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f413_exint.h:52
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:573
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:254
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:277
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • exint
  • exint_software_trigger
  • inc
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • exint
  • exint_software_trigger
  • inc
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • exint
  • exint_software_trigger
  • inc
project/at_start_f413/examples/exint/exint_software_trigger/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • exint
  • exint_software_trigger
  • src
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • exint
  • exint_software_trigger
  • src
project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • exint
  • exint_software_trigger
  • src
project/at_start_f413/examples/exint/exint_software_trigger/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
30
40void exint_line4_config(void);
41static void tmr1_config(void);
42
48void exint_line4_config(void)
49{
50 exint_init_type exint_init_struct;
51
52 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
53
54 exint_default_para_init(&exint_init_struct);
55 exint_init_struct.line_enable = TRUE;
56 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
57 exint_init_struct.line_select = EXINT_LINE_4;
58 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
59 exint_init(&exint_init_struct);
60
61 nvic_irq_enable(EXINT4_IRQn, 1, 0);
62}
63
69static void tmr1_config(void)
70{
71 crm_clocks_freq_type crm_clocks_freq_struct = {0};
72
73 /* get system clock */
74 crm_clocks_freq_get(&crm_clocks_freq_struct);
75
76 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
77
78 /* (systemclock / (system_core_clock/10000)) / 10000 = 1Hz(1s) */
79 tmr_base_init(TMR1, 10000-1, system_core_clock/10000-1);
80 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
81 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
82 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
83 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 0, 0);
84}
85
91void TMR1_OVF_TMR10_IRQHandler(void)
92{
93 if(tmr_flag_get(TMR1,TMR_OVF_FLAG) != RESET)
94 {
95 at32_led_toggle(LED2);
96 exint_software_interrupt_event_generate(EXINT_LINE_4);
97 tmr_flag_clear(TMR1,TMR_OVF_FLAG);
98 }
99}
100
106void EXINT4_IRQHandler(void)
107{
108 if(exint_flag_get(EXINT_LINE_4) != RESET)
109 {
110 at32_led_toggle(LED3);
111 at32_led_toggle(LED4);
112 exint_flag_clear(EXINT_LINE_4);
113 }
114}
115
121int main(void)
122{
123 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
124 system_clock_config();
125
126 at32_board_init();
127
128 /* turn led2/led3/led4 on */
129 at32_led_on(LED2);
130 at32_led_on(LED3);
131 at32_led_on(LED4);
132 tmr1_config();
133 exint_line4_config();
134 tmr_counter_enable(TMR1, TRUE);
135 while(1)
136 {
137 }
138}
139
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:39
exint_line4_config
void exint_line4_config(void)
exint line4 config. configure pa0 in interrupt mode
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:121
tmr1_config
static void tmr1_config(void)
tmr1 configuration.
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:69
EXINT4_IRQHandler
void EXINT4_IRQHandler(void)
exint4 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:106
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
tmr1 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_software_trigger/src/main.c:91
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f413.h:159
EXINT4_IRQn
@ EXINT4_IRQn
Definition: at32f413.h:143
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:64
exint_software_interrupt_event_generate
void exint_software_interrupt_event_generate(uint32_t exint_line)
generate exint software interrupt event
Definition: at32f413_exint.c:169
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:93
EXINT_LINE_4
#define EXINT_LINE_4
Definition: at32f413_exint.h:56
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:74
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • flash
  • flash_write_read
  • inc
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • flash
  • flash_write_read
  • inc
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • flash
  • flash_write_read
  • inc
project/at_start_f413/examples/flash/flash_write_read/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: flash.h Source File

  • flash
  • flash_write_read
  • inc
project/at_start_f413/examples/flash/flash_write_read/inc/flash.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __FLASH_H__
29#define __FLASH_H__
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413_board.h"
36
50void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read);
51void flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write);
52void flash_write(uint32_t write_addr,uint16_t *p_Buffer, uint16_t num_write);
53
66#ifdef __cplusplus
67}
68#endif
69
70#endif
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
flash_write
void flash_write(uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:83
flash_write_nocheck
void flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:66
flash_read
void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:49


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • flash
  • flash_write_read
  • src
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • flash
  • flash_write_read
  • src
project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: flash.c Source File

  • flash
  • flash_write_read
  • src
project/at_start_f413/examples/flash/flash_write_read/src/flash.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "flash.h"
29
38#define SECTOR_SIZE 2048 /* this parameter depends on the specific model of the chip */
39
40uint16_t flash_buf[SECTOR_SIZE / 2];
41
49void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
50{
51 uint16_t i;
52 for(i = 0; i < num_read; i++)
53 {
54 p_buffer[i] = *(uint16_t*)(read_addr);
55 read_addr += 2;
56 }
57}
58
66void flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
67{
68 uint16_t i;
69 for(i = 0; i < num_write; i++)
70 {
71 flash_halfword_program(write_addr, p_buffer[i]);
72 write_addr += 2;
73 }
74}
75
83void flash_write(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
84{
85 uint32_t offset_addr;
86 uint32_t sector_position;
87 uint16_t sector_offset;
88 uint16_t sector_remain;
89 uint16_t i;
90
91 flash_unlock();
92 offset_addr = write_addr - FLASH_BASE;
93 sector_position = offset_addr / SECTOR_SIZE;
94 sector_offset = (offset_addr % SECTOR_SIZE) / 2;
95 sector_remain = SECTOR_SIZE / 2 - sector_offset;
96 if(num_write <= sector_remain)
97 sector_remain = num_write;
98 while(1)
99 {
100 flash_read(sector_position * SECTOR_SIZE + FLASH_BASE, flash_buf, SECTOR_SIZE / 2);
101 for(i = 0; i < sector_remain; i++)
102 {
103 if(flash_buf[sector_offset + i] != 0xFFFF)
104 break;
105 }
106 if(i < sector_remain)
107 {
108 flash_sector_erase(sector_position * SECTOR_SIZE + FLASH_BASE);
109 for(i = 0; i < sector_remain; i++)
110 {
111 flash_buf[i + sector_offset] = p_buffer[i];
112 }
113 flash_write_nocheck(sector_position * SECTOR_SIZE + FLASH_BASE, flash_buf, SECTOR_SIZE / 2);
114 }
115 else
116 {
117 flash_write_nocheck(write_addr, p_buffer, sector_remain);
118 }
119 if(num_write == sector_remain)
120 break;
121 else
122 {
123 sector_position++;
124 sector_offset = 0;
125 p_buffer += sector_remain;
126 write_addr += (sector_remain * 2);
127 num_write -= sector_remain;
128 if(num_write > (SECTOR_SIZE / 2))
129 sector_remain = SECTOR_SIZE / 2;
130 else
131 sector_remain = num_write;
132 }
133 }
134 flash_lock();
135}
136
137
138
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
flash_buf
uint16_t flash_buf[2048/2]
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:40
flash_write_nocheck
void flash_write_nocheck(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode without checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:66
SECTOR_SIZE
#define SECTOR_SIZE
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:38
flash_read
void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:49
flash_write
void flash_write(uint32_t write_addr, uint16_t *p_buffer, uint16_t num_write)
write data using halfword mode with checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:83
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f413_flash.c:485
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:291


AT32F413 Firmwary Library: main.c Source File

  • flash
  • flash_write_read
  • src
project/at_start_f413/examples/flash/flash_write_read/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "flash.h"
30
39#define TEST_BUFEER_SIZE 3000
40#define TEST_FLASH_ADDRESS_START (0x08000000 + 1024 * 16)
41
42uint16_t buffer_write[TEST_BUFEER_SIZE];
43uint16_t buffer_read[TEST_BUFEER_SIZE];
44
45 error_status buffer_compare(uint16_t* p_buffer1, uint16_t* p_buffer2, uint16_t buffer_length);
46
54 error_status buffer_compare(uint16_t* p_buffer1, uint16_t* p_buffer2, uint16_t buffer_length)
55{
56 while(buffer_length--)
57 {
58 if(*p_buffer1 != *p_buffer2)
59 {
60 return ERROR;
61 }
62 p_buffer1++;
63 p_buffer2++;
64 }
65 return SUCCESS;
66}
67
73int main(void)
74{
75 uint32_t index=0;
76 system_clock_config();
77 at32_board_init();
78 /* fill buffer_write data to test */
79 for(index = 0; index < TEST_BUFEER_SIZE; index++)
80 {
81 buffer_write[index] = index;
82 }
83
84 /* write data to flash */
85 flash_write(TEST_FLASH_ADDRESS_START, buffer_write, TEST_BUFEER_SIZE);
86
87 /* read data from flash */
88 flash_read(TEST_FLASH_ADDRESS_START, buffer_read, TEST_BUFEER_SIZE);
89
90 /* compare the buffer */
91 if(buffer_compare(buffer_write, buffer_read, TEST_BUFEER_SIZE) == SUCCESS)
92 {
93 at32_led_on(LED2);
94 at32_led_on(LED3);
95 at32_led_on(LED4);
96 }
97
98 while(1)
99 {
100 }
101}
102
103
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
TEST_BUFEER_SIZE
#define TEST_BUFEER_SIZE
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:39
buffer_compare
error_status buffer_compare(uint16_t *p_buffer1, uint16_t *p_buffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:54
buffer_read
uint16_t buffer_read[3000]
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:43
TEST_FLASH_ADDRESS_START
#define TEST_FLASH_ADDRESS_START
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:73
buffer_write
uint16_t buffer_write[3000]
Definition: project/at_start_f413/examples/flash/flash_write_read/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
flash_write
void flash_write(uint32_t write_addr, uint16_t *p_Buffer, uint16_t num_write)
write data using halfword mode with checking
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:83
flash_read
void flash_read(uint32_t read_addr, uint16_t *p_buffer, uint16_t num_read)
read data using halfword mode
Definition: project/at_start_f413/examples/flash/flash_write_read/src/flash.c:49
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • flash
  • operate_spim
  • inc
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • flash
  • operate_spim
  • inc
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • flash
  • operate_spim
  • inc
project/at_start_f413/examples/flash/operate_spim/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • flash
  • operate_spim
  • src
project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • flash
  • operate_spim
  • src
project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
136
137
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/flash/operate_spim/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • flash
  • operate_spim
  • src
project/at_start_f413/examples/flash/operate_spim/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "operate_spim.h"
30
31
45int main(void)
46{
47 system_clock_config();
48
49 at32_board_init();
50
51 /* operate spim flash */
52 spim_operate();
53
54 while(1)
55 {
56
57 }
58}
59
60
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/flash/operate_spim/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
spim_operate
void spim_operate(void)
operate spim flash
Definition: operate_spim.c:109
operate_spim.h
operate_spim header file
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • flash
  • run_in_spim
  • inc
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • flash
  • run_in_spim
  • inc
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • flash
  • run_in_spim
  • inc
project/at_start_f413/examples/flash/run_in_spim/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • flash
  • run_in_spim
  • src
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • flash
  • run_in_spim
  • src
project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:106
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:124
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:45
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:80
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/at32f413_int.c:115
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • flash
  • run_in_spim
  • src
project/at_start_f413/examples/flash/run_in_spim/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "run_in_spim.h"
30
31
45void spim_init(void)
46{
47 gpio_init_type gpio_init_struct;
48
49 /* enable the clock */
50 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
51 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
52 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
53
54 /* init spim io */
55 gpio_default_para_init(&gpio_init_struct);
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
58 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
59 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
60 gpio_init_struct.gpio_pins = GPIO_PINS_8;
61 gpio_init(GPIOA, &gpio_init_struct);
62 gpio_init_struct.gpio_pins = GPIO_PINS_1 | GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_10 | GPIO_PINS_11;
63 gpio_init(GPIOB, &gpio_init_struct);
64
65 /* enable spim, and select pb10, pb11 as spim io */
66 gpio_pin_remap_config(EXT_SPIM_GMUX_1001, TRUE);
67
68 /* in this example, use on-board en25qh128a as spim flash */
69 flash_spim_model_select(FLASH_SPIM_MODEL2);
70
71 /* unlock the spim flash program erase controller */
72 while(flash_flag_get(FLASH_SPIM_OBF_FLAG));
73 flash_spim_unlock();
74 while(FLASH->ctrl3_bit.oplk);
75
76 /* if the data written to spim flash need to be scrambled, please specify the scrambled range */
77 flash_spim_encryption_range_set(0);
78
79 return;
80}
81
87int main(void)
88{
89 system_clock_config();
90 at32_board_init();
91
92 /* configures the spim flash */
93 spim_init();
94
95 /* check the led toggle in spim */
96 spim_run();
97
98 while(1)
99 {
100 }
101}
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
spim_run
void spim_run(void)
check the led toggle in spim
Definition: run_in_spim.c:45
main
int main(void)
main function.
Definition: project/at_start_f413/examples/flash/run_in_spim/src/main.c:87
spim_init
void spim_init(void)
init the spim flash
Definition: project/at_start_f413/examples/flash/run_in_spim/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
TRUE
@ TRUE
Definition: at32f413.h:259
flash_spim_unlock
void flash_spim_unlock(void)
unlock the flash spim controller.
Definition: at32f413_flash.c:240
flash_spim_model_select
void flash_spim_model_select(flash_spim_model_type mode)
select spim supports extended spi flash chip model.
Definition: at32f413_flash.c:798
flash_spim_encryption_range_set
void flash_spim_encryption_range_set(uint32_t decode_address)
set the range of encryption in spim flash. when the address is larger than this value,...
Definition: at32f413_flash.c:810
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:59
FLASH_SPIM_MODEL2
@ FLASH_SPIM_MODEL2
Definition: at32f413_flash.h:173
FLASH_SPIM_OBF_FLAG
#define FLASH_SPIM_OBF_FLAG
Definition: at32f413_flash.h:81
FLASH
#define FLASH
Definition: at32f413_flash.h:564
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
EXT_SPIM_GMUX_1001
#define EXT_SPIM_GMUX_1001
Definition: at32f413_gpio.h:191
run_in_spim.h
run_in_spim header file
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • gpio
  • led_toggle
  • inc
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • gpio
  • led_toggle
  • inc
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • gpio
  • led_toggle
  • inc
project/at_start_f413/examples/gpio/led_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • gpio
  • led_toggle
  • src
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • gpio
  • led_toggle
  • src
project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • gpio
  • led_toggle
  • src
project/at_start_f413/examples/gpio/led_toggle/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
30
44int main(void)
45{
46 system_clock_config();
47
48 at32_board_init();
49
50 while(1)
51 {
52 at32_led_toggle(LED2);
53 delay_ms(200);
54 at32_led_toggle(LED3);
55 delay_ms(200);
56 at32_led_toggle(LED4);
57 delay_ms(200);
58 }
59}
60
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/gpio/led_toggle/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • gpio
  • swjtag_remap
  • inc
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • gpio
  • swjtag_remap
  • inc
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • gpio
  • swjtag_remap
  • inc
project/at_start_f413/examples/gpio/swjtag_remap/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • gpio
  • swjtag_remap
  • src
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • gpio
  • swjtag_remap
  • src
project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • gpio
  • swjtag_remap
  • src
project/at_start_f413/examples/gpio/swjtag_remap/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
30
39void swj_dp_config(void);
40void gpio_pins_toggle(gpio_type* gpio_x, uint16_t gpio_pin);
41
47void swj_dp_config(void)
48{
49 gpio_init_type gpio_init_struct;
50
51 /* configure pa13 (jtms/swdat), pa14 (jtck/swclk) and pa15 (jtdi) as output push-pull */
52 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
53 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
54 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
57 gpio_init(GPIOA, &gpio_init_struct);
58
59 /* configure pb3 (jtdo) and pb4 (jtrst) as output push-pull */
60 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_4;
61 gpio_init(GPIOB, &gpio_init_struct);
62}
63
70void gpio_pins_toggle(gpio_type* gpio_x, uint16_t gpio_pin)
71{
72 gpio_x->odt ^= gpio_pin;
73}
74
80int main(void)
81{
82 system_clock_config();
83
84 at32_board_init();
85
86 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
87 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
88 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
89
90 swj_dp_config();
91
92 while(1)
93 {
94 if(USER_BUTTON == at32_button_press())
95 {
96 /* disable the serial wire jtag debug port swj-dp */
97 gpio_pin_remap_config(SWJTAG_CONF_100, TRUE);
98
99 /* turn on led3 */
100 at32_led_on(LED3);
101 }
102
103 /* toggle jtms/swdat pin */
104 gpio_pins_toggle(GPIOA, GPIO_PINS_13);
105 delay_us(200);
106
107 /* toggle jtck/swclk pin */
108 gpio_pins_toggle(GPIOA, GPIO_PINS_14);
109 delay_us(200);
110
111 /* toggle jtdi pin */
112 gpio_pins_toggle(GPIOA, GPIO_PINS_15);
113 delay_us(200);
114
115 /* toggle jtdo pin */
116 gpio_pins_toggle(GPIOB, GPIO_PINS_3);
117 delay_us(200);
118
119 /* toggle jtrst pin */
120 gpio_pins_toggle(GPIOB, GPIO_PINS_4);
121 delay_us(200);
122 }
123}
124
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
gpio_pins_toggle
void gpio_pins_toggle(gpio_type *gpio_x, uint16_t gpio_pin)
toggles the specified gpio pin
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/main.c:70
main
int main(void)
main function.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/main.c:80
swj_dp_config
void swj_dp_config(void)
configure the gpio of swj-dp.
Definition: project/at_start_f413/examples/gpio/swjtag_remap/src/main.c:47
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
SWJTAG_CONF_100
#define SWJTAG_CONF_100
Definition: at32f413_gpio.h:100
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
gpio_type
type define gpio register all
Definition: at32f413_gpio.h:300
gpio_type::odt
__IO uint32_t odt
Definition: at32f413_gpio.h:388
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2c
  • communication_dma
  • inc
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2c
  • communication_dma
  • inc
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2c
  • communication_dma
  • inc
project/at_start_f413/examples/i2c/communication_dma/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2c
  • communication_dma
  • src
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2c
  • communication_dma
  • src
project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "i2c_application.h"
30
31extern i2c_handle_type hi2cx;
32
33#define I2Cx_DMA_TX_IRQHandler DMA1_Channel6_IRQHandler
34#define I2Cx_DMA_RX_IRQHandler DMA1_Channel7_IRQHandler
35#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
36#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
37
51void NMI_Handler(void)
52{
53}
54
60void HardFault_Handler(void)
61{
62 /* go to infinite loop when hard fault exception occurs */
63 while(1)
64 {
65 }
66}
67
73void MemManage_Handler(void)
74{
75 /* go to infinite loop when memory manage exception occurs */
76 while(1)
77 {
78 }
79}
80
86void BusFault_Handler(void)
87{
88 /* go to infinite loop when bus fault exception occurs */
89 while(1)
90 {
91 }
92}
93
99void UsageFault_Handler(void)
100{
101 /* go to infinite loop when usage fault exception occurs */
102 while(1)
103 {
104 }
105}
106
112void SVC_Handler(void)
113{
114}
115
121void DebugMon_Handler(void)
122{
123}
124
130void PendSV_Handler(void)
131{
132}
133
139void SysTick_Handler(void)
140{
141}
142
148void I2Cx_DMA_RX_IRQHandler(void)
149{
150 i2c_dma_rx_irq_handler(&hi2cx);
151}
152
158void I2Cx_DMA_TX_IRQHandler(void)
159{
160 i2c_dma_tx_irq_handler(&hi2cx);
161}
162
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:99
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:60
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:73
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:112
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:130
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:51
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:86
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:71
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:139
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:121
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2204
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2155
i2c_application.h
i2c application libray header file
I2Cx_DMA_TX_IRQHandler
#define I2Cx_DMA_TX_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:33
I2Cx_DMA_RX_IRQHandler
#define I2Cx_DMA_RX_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_dma/src/at32f413_int.c:34
i2c_handle_type
Definition: i2c_application.h:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2c
  • communication_dma
  • src
project/at_start_f413/examples/i2c/communication_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "i2c_application.h"
30
39#define I2C_TIMEOUT 0xFFFFFFFF
40
41#define I2Cx_SPEED 100000
42#define I2Cx_ADDRESS 0xA0
43
44#define I2Cx_PORT I2C1
45#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
46
47#define I2Cx_SCL_PIN GPIO_PINS_6
48#define I2Cx_SCL_GPIO_PORT GPIOB
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50
51#define I2Cx_SDA_PIN GPIO_PINS_7
52#define I2Cx_SDA_GPIO_PORT GPIOB
53#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54
55#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
56#define I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL6
57#define I2Cx_DMA_TX_IRQn DMA1_Channel6_IRQn
58
59#define I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL7
60#define I2Cx_DMA_RX_IRQn DMA1_Channel7_IRQn
61
62#define I2Cx_EVT_IRQn I2C1_EVT_IRQn
63#define I2Cx_ERR_IRQn I2C1_ERR_IRQn
64
65#define BUF_SIZE 8
66#define MASTER_BOARD
67
68uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
69uint8_t rx_buf[BUF_SIZE] = {0};
70
71 i2c_handle_type hi2cx;
72
73uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len);
74void i2c_lowlevel_init(i2c_handle_type* hi2c);
75
81void error_handler(uint32_t error_code)
82{
83 while(1)
84 {
85 at32_led_toggle(LED2);
86 delay_ms(500);
87 }
88}
89
97uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
98{
99 uint32_t i;
100
101 for(i = 0; i < len; i++)
102 {
103 if(buffer1[i] != buffer2[i])
104 {
105 return 1;
106 }
107 }
108
109 return 0;
110}
111
117void i2c_lowlevel_init(i2c_handle_type* hi2c)
118{
119 gpio_init_type gpio_initstructure;
120
121 if(hi2c->i2cx == I2Cx_PORT)
122 {
123 /* i2c periph clock enable */
124 crm_periph_clock_enable(I2Cx_CLK, TRUE);
125 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
126 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
127
128 /* gpio configuration */
129 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
130 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
131 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
132 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
133
134 /* configure i2c pins: scl */
135 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
136 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
137
138 /* configure i2c pins: sda */
139 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
140 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
141
142 /* configure and enable i2c dma channel interrupt */
143 nvic_irq_enable(I2Cx_DMA_TX_IRQn, 0, 0);
144 nvic_irq_enable(I2Cx_DMA_RX_IRQn, 0, 0);
145
146 /* i2c dma tx and rx channels configuration */
147 /* enable the dma clock */
148 crm_periph_clock_enable(I2Cx_DMA_CLK, TRUE);
149
150 /* i2c dma channel configuration */
151 dma_reset(hi2c->dma_tx_channel);
152 dma_reset(hi2c->dma_rx_channel);
153
154 hi2c->dma_tx_channel = I2Cx_DMA_TX_CHANNEL;
155 hi2c->dma_rx_channel = I2Cx_DMA_RX_CHANNEL;
156
157 dma_default_para_init(&hi2c->dma_init_struct);
158 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
159 hi2c->dma_init_struct.memory_inc_enable = TRUE;
160 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
161 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
162 hi2c->dma_init_struct.loop_mode_enable = FALSE;
163 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
164 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
165
166 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
167 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
168
169 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
170
171 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
172 }
173}
174
180int main(void)
181{
182 i2c_status_type i2c_status;
183
184 /* config nvic priority group */
185 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
186
187 system_clock_config();
188
189 at32_board_init();
190
191 hi2cx.i2cx = I2Cx_PORT;
192
193 i2c_config(&hi2cx);
194
195 while(1)
196 {
197
198#if defined (MASTER_BOARD)
199
200 /* wait for key USER_BUTTON press before starting the communication */
201 while(at32_button_press() != USER_BUTTON)
202 {
203 }
204
205 /* start the request reception process */
206 if((i2c_status = i2c_master_transmit_dma(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
207 {
208 error_handler(i2c_status);
209 }
210
211 /* wait for the communication to end */
212 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
213 {
214 error_handler(i2c_status);
215 }
216
217 delay_ms(10);
218
219 /* start the request reception process */
220 if((i2c_status = i2c_master_receive_dma(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
221 {
222 error_handler(i2c_status);
223 }
224
225 /* wait for the communication to end */
226 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
227 {
228 error_handler(i2c_status);
229 }
230
231 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
232 {
233 at32_led_on(LED3);
234 }
235 else
236 {
237 error_handler(i2c_status);
238 }
239
240#else
241
242 /* wait for key USER_BUTTON press before starting the communication */
243 while(at32_button_press() != USER_BUTTON)
244 {
245 }
246
247 /* start the transmission process */
248 if((i2c_status = i2c_slave_receive_dma(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
249 {
250 error_handler(i2c_status);
251 }
252
253 /* wait for the communication to end */
254 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
255 {
256 error_handler(i2c_status);
257 }
258
259 if((i2c_status = i2c_slave_transmit_dma(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
260 {
261 error_handler(i2c_status);
262 }
263
264 /* wait for the communication to end */
265 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
266 {
267 error_handler(i2c_status);
268 }
269
270 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
271 {
272 at32_led_on(LED3);
273 }
274 else
275 {
276 error_handler(i2c_status);
277 }
278
279#endif
280
281 }
282}
283
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rx_buf
uint8_t rx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:69
tx_buf
uint8_t tx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:68
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:42
I2Cx_DMA_RX_IRQn
#define I2Cx_DMA_RX_IRQn
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:60
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:45
I2Cx_DMA_TX_CHANNEL
#define I2Cx_DMA_TX_CHANNEL
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:56
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:65
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:180
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:47
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:71
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:52
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:97
I2Cx_DMA_CLK
#define I2Cx_DMA_CLK
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:55
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:53
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:81
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:117
I2Cx_SPEED
#define I2Cx_SPEED
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:41
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:44
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:49
I2Cx_DMA_RX_CHANNEL
#define I2Cx_DMA_RX_CHANNEL
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:59
I2Cx_DMA_TX_IRQn
#define I2Cx_DMA_TX_IRQn
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:57
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:48
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:158
i2c_slave_transmit_dma
i2c_status_type i2c_slave_transmit_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through dma mode.
Definition: i2c_application.c:1235
i2c_master_transmit_dma
i2c_status_type i2c_master_transmit_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through dma mode.
Definition: i2c_application.c:1049
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:112
i2c_slave_receive_dma
i2c_status_type i2c_slave_receive_dma(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through dma mode.
Definition: i2c_application.c:1102
i2c_master_receive_dma
i2c_status_type i2c_master_receive_dma(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through dma mode.
Definition: i2c_application.c:1159
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:245
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:255
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f413_dma.h:265
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:226
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:236
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:185
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:90
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:148
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:157
i2c_status_type
i2c_status_type
Definition: i2c_application.h:81
I2C_OK
@ I2C_OK
Definition: i2c_application.h:82
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
i2c_handle_type
Definition: i2c_application.h:114
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:124
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:115
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:125
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:123
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2c
  • communication_int
  • inc
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2c
  • communication_int
  • inc
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2c
  • communication_int
  • inc
project/at_start_f413/examples/i2c/communication_int/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2c
  • communication_int
  • src
project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2c
  • communication_int
  • src
project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "i2c_application.h"
30
31extern i2c_handle_type hi2cx;
32
33#define I2Cx_EVT_IRQHandler I2C1_EVT_IRQHandler
34#define I2Cx_ERR_IRQHandler I2C1_ERR_IRQHandler
35
49void NMI_Handler(void)
50{
51}
52
58void HardFault_Handler(void)
59{
60 /* go to infinite loop when hard fault exception occurs */
61 while(1)
62 {
63 }
64}
65
71void MemManage_Handler(void)
72{
73 /* go to infinite loop when memory manage exception occurs */
74 while(1)
75 {
76 }
77}
78
84void BusFault_Handler(void)
85{
86 /* go to infinite loop when bus fault exception occurs */
87 while(1)
88 {
89 }
90}
91
97void UsageFault_Handler(void)
98{
99 /* go to infinite loop when usage fault exception occurs */
100 while(1)
101 {
102 }
103}
104
110void SVC_Handler(void)
111{
112}
113
119void DebugMon_Handler(void)
120{
121}
122
128void PendSV_Handler(void)
129{
130}
131
137void SysTick_Handler(void)
138{
139}
140
146void I2Cx_EVT_IRQHandler(void)
147{
148 i2c_evt_irq_handler(&hi2cx);
149}
150
156void I2Cx_ERR_IRQHandler(void)
157{
158 i2c_err_irq_handler(&hi2cx);
159}
160
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:71
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:97
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:58
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:71
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:110
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:128
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:49
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:84
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:137
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:119
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2129
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
i2c error interrupt function.
Definition: i2c_application.c:2253
i2c_application.h
i2c application libray header file
I2Cx_EVT_IRQHandler
#define I2Cx_EVT_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:33
I2Cx_ERR_IRQHandler
#define I2Cx_ERR_IRQHandler
Definition: project/at_start_f413/examples/i2c/communication_int/src/at32f413_int.c:34
i2c_handle_type
Definition: i2c_application.h:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2c
  • communication_int
  • src
project/at_start_f413/examples/i2c/communication_int/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "i2c_application.h"
30
39#define I2C_TIMEOUT 0xFFFFFFFF
40
41#define I2Cx_SPEED 100000
42#define I2Cx_ADDRESS 0xA0
43
44#define I2Cx_PORT I2C1
45#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
46
47#define I2Cx_SCL_PIN GPIO_PINS_6
48#define I2Cx_SCL_GPIO_PORT GPIOB
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50
51#define I2Cx_SDA_PIN GPIO_PINS_7
52#define I2Cx_SDA_GPIO_PORT GPIOB
53#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54
55#define I2Cx_EVT_IRQn I2C1_EVT_IRQn
56#define I2Cx_ERR_IRQn I2C1_ERR_IRQn
57
58#define BUF_SIZE 8
59#define MASTER_BOARD
60
61uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
62uint8_t rx_buf[BUF_SIZE] = {0};
63
64 i2c_handle_type hi2cx;
65
66uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len);
67void error_handler(uint32_t error_code);
68void i2c_lowlevel_init(i2c_handle_type* hi2c);
69
75void error_handler(uint32_t error_code)
76{
77 while(1)
78 {
79 at32_led_toggle(LED2);
80 delay_ms(500);
81 }
82}
83
91uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
92{
93 uint32_t i;
94
95 for(i = 0; i < len; i++)
96 {
97 if(buffer1[i] != buffer2[i])
98 {
99 return 1;
100 }
101 }
102
103 return 0;
104}
105
111void i2c_lowlevel_init(i2c_handle_type* hi2c)
112{
113 gpio_init_type gpio_initstructure;
114
115 if(hi2c->i2cx == I2Cx_PORT)
116 {
117 /* i2c periph clock enable */
118 crm_periph_clock_enable(I2Cx_CLK, TRUE);
119 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
120 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
121
122 /* gpio configuration */
123 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
124 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
125 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
126 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
127
128 /* configure i2c pins: scl */
129 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
130 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
131
132 /* configure i2c pins: sda */
133 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
134 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
135
136 /* configure and enable i2c interrupt */
137 nvic_irq_enable(I2Cx_EVT_IRQn, 0, 0);
138 nvic_irq_enable(I2Cx_ERR_IRQn, 0, 0);
139
140 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
141
142 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
143 }
144}
145
151int main(void)
152{
153 i2c_status_type i2c_status;
154
155 /* config nvic priority group */
156 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
157
158 system_clock_config();
159
160 at32_board_init();
161
162 hi2cx.i2cx = I2Cx_PORT;
163
164 i2c_config(&hi2cx);
165
166 while(1)
167 {
168
169#if defined (MASTER_BOARD)
170
171 /* wait for key USER_BUTTON press before starting the communication */
172 while(at32_button_press() != USER_BUTTON)
173 {
174 }
175
176 /* start the request reception process */
177 if((i2c_status = i2c_master_transmit_int(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
178 {
179 error_handler(i2c_status);
180 }
181
182 /* wait for the communication to end */
183 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
184 {
185 error_handler(i2c_status);
186 }
187
188 delay_ms(10);
189
190 /* start the request reception process */
191 if((i2c_status = i2c_master_receive_int(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
192 {
193 error_handler(i2c_status);
194 }
195
196 /* wait for the communication to end */
197 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
198 {
199 error_handler(i2c_status);
200 }
201
202 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
203 {
204 at32_led_on(LED3);
205 }
206 else
207 {
208 error_handler(i2c_status);
209 }
210
211#else
212
213 /* wait for key USER_BUTTON press before starting the communication */
214 while(at32_button_press() != USER_BUTTON)
215 {
216 }
217
218 /* start the transmission process */
219 if((i2c_status = i2c_slave_receive_int(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
220 {
221 error_handler(i2c_status);
222 }
223
224 /* wait for the communication to end */
225 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
226 {
227 error_handler(i2c_status);
228 }
229
230 if((i2c_status = i2c_slave_transmit_int(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
231 {
232 error_handler(i2c_status);
233 }
234
235 /* wait for the communication to end */
236 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
237 {
238 error_handler(i2c_status);
239 }
240
241 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
242 {
243 at32_led_on(LED3);
244 }
245 else
246 {
247 error_handler(i2c_status);
248 }
249#endif
250
251 }
252}
253
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rx_buf
uint8_t rx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:62
tx_buf
uint8_t tx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:61
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:42
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:45
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:58
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:151
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:47
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:64
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:52
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:91
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:53
I2Cx_ERR_IRQn
#define I2Cx_ERR_IRQn
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:56
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:75
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:111
I2Cx_SPEED
#define I2Cx_SPEED
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:41
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:44
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:49
I2Cx_EVT_IRQn
#define I2Cx_EVT_IRQn
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:55
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:48
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f413/examples/i2c/communication_int/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:158
i2c_slave_transmit_int
i2c_status_type i2c_slave_transmit_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through interrupt mode.
Definition: i2c_application.c:986
i2c_master_receive_int
i2c_status_type i2c_master_receive_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through interrupt mode.
Definition: i2c_application.c:908
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:112
i2c_master_transmit_int
i2c_status_type i2c_master_transmit_int(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through interrupt mode.
Definition: i2c_application.c:813
i2c_slave_receive_int
i2c_status_type i2c_slave_receive_int(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through interrupt mode.
Definition: i2c_application.c:860
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:226
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:236
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:185
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:90
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:148
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:157
i2c_status_type
i2c_status_type
Definition: i2c_application.h:81
I2C_OK
@ I2C_OK
Definition: i2c_application.h:82
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
i2c_application.h
i2c application libray header file
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
i2c_handle_type
Definition: i2c_application.h:114
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:115
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2c
  • communication_poll
  • inc
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2c
  • communication_poll
  • inc
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2c
  • communication_poll
  • inc
project/at_start_f413/examples/i2c/communication_poll/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2c
  • communication_poll
  • src
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2c
  • communication_poll
  • src
project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2c
  • communication_poll
  • src
project/at_start_f413/examples/i2c/communication_poll/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "i2c_application.h"
30
39#define I2C_TIMEOUT 0xFFFFFFFF
40
41#define I2Cx_SPEED 100000
42#define I2Cx_ADDRESS 0xA0
43
44#define I2Cx_PORT I2C1
45#define I2Cx_CLK CRM_I2C1_PERIPH_CLOCK
46
47#define I2Cx_SCL_PIN GPIO_PINS_6
48#define I2Cx_SCL_GPIO_PORT GPIOB
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50
51#define I2Cx_SDA_PIN GPIO_PINS_7
52#define I2Cx_SDA_GPIO_PORT GPIOB
53#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54
55#define BUF_SIZE 8
56#define MASTER_BOARD
57
58uint8_t tx_buf[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
59uint8_t rx_buf[BUF_SIZE] = {0};
60
61 i2c_handle_type hi2cx;
62
63void error_handler(uint32_t error_code);
64uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len);
65void i2c_lowlevel_init(i2c_handle_type* hi2c);
66
72void error_handler(uint32_t error_code)
73{
74 while(1)
75 {
76 at32_led_toggle(LED2);
77 delay_ms(500);
78 }
79}
80
88uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
89{
90 uint32_t i;
91
92 for(i = 0; i < len; i++)
93 {
94 if(buffer1[i] != buffer2[i])
95 {
96 return 1;
97 }
98 }
99
100 return 0;
101}
102
108void i2c_lowlevel_init(i2c_handle_type* hi2c)
109{
110 gpio_init_type gpio_initstructure;
111
112 if(hi2c->i2cx == I2Cx_PORT)
113 {
114 /* i2c periph clock enable */
115 crm_periph_clock_enable(I2Cx_CLK, TRUE);
116 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
117 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
118
119 /* gpio configuration */
120 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
121 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
122 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
123 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
124
125 /* configure i2c pins: scl */
126 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
127 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
128
129 /* configure i2c pins: sda */
130 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
131 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
132
133 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
134
135 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
136 }
137}
138
144int main(void)
145{
146 i2c_status_type i2c_status;
147
148 system_clock_config();
149
150 at32_board_init();
151
152 hi2cx.i2cx = I2Cx_PORT;
153
154 i2c_config(&hi2cx);
155
156 while(1)
157 {
158
159#if defined (MASTER_BOARD)
160
161 /* wait for key USER_BUTTON press before starting the communication */
162 while(at32_button_press() != USER_BUTTON)
163 {
164 }
165
166 /* start the request reception process */
167 if((i2c_status = i2c_master_transmit(&hi2cx, I2Cx_ADDRESS, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
168 {
169 error_handler(i2c_status);
170 }
171
172 delay_ms(10);
173
174 /* start the request reception process */
175 if((i2c_status = i2c_master_receive(&hi2cx, I2Cx_ADDRESS, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
176 {
177 error_handler(i2c_status);
178 }
179
180 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
181 {
182 at32_led_on(LED3);
183 }
184 else
185 {
186 error_handler(i2c_status);
187 }
188#else
189
190 /* wait for key USER_BUTTON press before starting the communication */
191 while(at32_button_press() != USER_BUTTON)
192 {
193 }
194
195 /* start the transmission process */
196 if((i2c_status = i2c_slave_receive(&hi2cx, rx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
197 {
198 error_handler(i2c_status);
199 }
200
201 if((i2c_status = i2c_slave_transmit(&hi2cx, tx_buf, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
202 {
203 error_handler(i2c_status);
204 }
205
206 if(buffer_compare(tx_buf, rx_buf, BUF_SIZE) == 0)
207 {
208 at32_led_on(LED3);
209 }
210 else
211 {
212 error_handler(i2c_status);
213 }
214#endif
215
216 }
217}
218
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rx_buf
uint8_t rx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:59
tx_buf
uint8_t tx_buf[8]
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:58
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:42
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:45
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:55
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:144
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:47
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:61
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:52
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:88
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:53
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:72
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:108
I2Cx_SPEED
#define I2Cx_SPEED
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:41
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:44
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:49
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:48
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f413/examples/i2c/communication_poll/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
i2c_slave_receive
i2c_status_type i2c_slave_receive(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave receive data through polling mode.
Definition: i2c_application.c:480
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:112
i2c_master_receive
i2c_status_type i2c_master_receive(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master receive data through polling mode.
Definition: i2c_application.c:555
i2c_master_transmit
i2c_status_type i2c_master_transmit(i2c_handle_type *hi2c, uint16_t address, uint8_t *pdata, uint16_t size, uint32_t timeout)
the master transmits data through polling mode.
Definition: i2c_application.c:412
i2c_slave_transmit
i2c_status_type i2c_slave_transmit(i2c_handle_type *hi2c, uint8_t *pdata, uint16_t size, uint32_t timeout)
the slave transmits data through polling mode.
Definition: i2c_application.c:726
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:226
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:236
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:185
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:90
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:148
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:157
i2c_status_type
i2c_status_type
Definition: i2c_application.h:81
I2C_OK
@ I2C_OK
Definition: i2c_application.h:82
i2c_application.h
i2c application libray header file
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
i2c_handle_type
Definition: i2c_application.h:114
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:115
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2c
  • eeprom
  • inc
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2c
  • eeprom
  • inc
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2c
  • eeprom
  • inc
project/at_start_f413/examples/i2c/eeprom/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2c
  • eeprom
  • src
project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2c
  • eeprom
  • src
project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "i2c_application.h"
30
31extern i2c_handle_type hi2cx;
32
33#define I2Cx_DMA_TX_IRQHandler DMA1_Channel4_IRQHandler
34#define I2Cx_DMA_RX_IRQHandler DMA1_Channel5_IRQHandler
35#define I2Cx_EVT_IRQHandler I2C2_EVT_IRQHandler
36#define I2Cx_ERR_IRQHandler I2C2_ERR_IRQHandler
37
51void NMI_Handler(void)
52{
53}
54
60void HardFault_Handler(void)
61{
62 /* go to infinite loop when hard fault exception occurs */
63 while(1)
64 {
65 }
66}
67
73void MemManage_Handler(void)
74{
75 /* go to infinite loop when memory manage exception occurs */
76 while(1)
77 {
78 }
79}
80
86void BusFault_Handler(void)
87{
88 /* go to infinite loop when bus fault exception occurs */
89 while(1)
90 {
91 }
92}
93
99void UsageFault_Handler(void)
100{
101 /* go to infinite loop when usage fault exception occurs */
102 while(1)
103 {
104 }
105}
106
112void SVC_Handler(void)
113{
114}
115
121void DebugMon_Handler(void)
122{
123}
124
130void PendSV_Handler(void)
131{
132}
133
139void SysTick_Handler(void)
140{
141}
142
148void I2Cx_DMA_RX_IRQHandler(void)
149{
150 i2c_dma_rx_irq_handler(&hi2cx);
151}
152
158void I2Cx_DMA_TX_IRQHandler(void)
159{
160 i2c_dma_tx_irq_handler(&hi2cx);
161}
162
168void I2Cx_EVT_IRQHandler(void)
169{
170 i2c_evt_irq_handler(&hi2cx);
171}
172
178void I2Cx_ERR_IRQHandler(void)
179{
180 i2c_err_irq_handler(&hi2cx);
181}
182
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/communication_dma/src/main.c:71
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:99
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:60
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:73
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:112
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:130
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:51
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:86
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:139
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:121
i2c_evt_irq_handler
void i2c_evt_irq_handler(i2c_handle_type *hi2c)
interrupt procession function.
Definition: i2c_application.c:2129
i2c_err_irq_handler
void i2c_err_irq_handler(i2c_handle_type *hi2c)
i2c error interrupt function.
Definition: i2c_application.c:2253
i2c_dma_rx_irq_handler
void i2c_dma_rx_irq_handler(i2c_handle_type *hi2c)
dma reveive complete interrupt function.
Definition: i2c_application.c:2204
i2c_dma_tx_irq_handler
void i2c_dma_tx_irq_handler(i2c_handle_type *hi2c)
dma transmission complete interrupt function.
Definition: i2c_application.c:2155
i2c_application.h
i2c application libray header file
I2Cx_EVT_IRQHandler
#define I2Cx_EVT_IRQHandler
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:35
I2Cx_ERR_IRQHandler
#define I2Cx_ERR_IRQHandler
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:36
I2Cx_DMA_TX_IRQHandler
#define I2Cx_DMA_TX_IRQHandler
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:33
I2Cx_DMA_RX_IRQHandler
#define I2Cx_DMA_RX_IRQHandler
Definition: project/at_start_f413/examples/i2c/eeprom/src/at32f413_int.c:34
i2c_handle_type
Definition: i2c_application.h:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2c
  • eeprom
  • src
project/at_start_f413/examples/i2c/eeprom/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "i2c_application.h"
30
39#define I2C_TIMEOUT 0xFFFFFFFF
40
41#define I2Cx_SPEED 100000
42#define I2Cx_ADDRESS 0xA0
43
44#define I2Cx_PORT I2C2
45#define I2Cx_CLK CRM_I2C2_PERIPH_CLOCK
46
47#define I2Cx_SCL_PIN GPIO_PINS_10
48#define I2Cx_SCL_GPIO_PORT GPIOB
49#define I2Cx_SCL_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
50
51#define I2Cx_SDA_PIN GPIO_PINS_11
52#define I2Cx_SDA_GPIO_PORT GPIOB
53#define I2Cx_SDA_GPIO_CLK CRM_GPIOB_PERIPH_CLOCK
54
55#define I2Cx_DMA_CLK CRM_DMA1_PERIPH_CLOCK
56#define I2Cx_DMA_TX_CHANNEL DMA1_CHANNEL4
57#define I2Cx_DMA_TX_IRQn DMA1_Channel4_IRQn
58
59#define I2Cx_DMA_RX_CHANNEL DMA1_CHANNEL5
60#define I2Cx_DMA_RX_IRQn DMA1_Channel5_IRQn
61
62#define I2Cx_EVT_IRQn I2C2_EVT_IRQn
63#define I2Cx_ERR_IRQn I2C2_ERR_IRQn
64
65#define BUF_SIZE 8
66
67uint8_t tx_buf1[BUF_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08};
68uint8_t tx_buf2[BUF_SIZE] = {0x10, 0x20, 0x30, 0x40, 0x50, 0x60, 0x70, 0x80};
69uint8_t tx_buf3[BUF_SIZE] = {0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88};
70uint8_t rx_buf1[BUF_SIZE] = {0};
71uint8_t rx_buf2[BUF_SIZE] = {0};
72uint8_t rx_buf3[BUF_SIZE] = {0};
73
74 i2c_handle_type hi2cx;
75
76void error_handler(uint32_t error_code);
77uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len);
78void i2c_lowlevel_init(i2c_handle_type* hi2c);
79
85void error_handler(uint32_t error_code)
86{
87 while(1)
88 {
89 at32_led_toggle(LED2);
90 delay_ms(500);
91 }
92}
93
101uint32_t buffer_compare(uint8_t* buffer1, uint8_t* buffer2, uint32_t len)
102{
103 uint32_t i;
104
105 for(i = 0; i < len; i++)
106 {
107 if(buffer1[i] != buffer2[i])
108 {
109 return 1;
110 }
111 }
112
113 return 0;
114}
115
121void i2c_lowlevel_init(i2c_handle_type* hi2c)
122{
123 gpio_init_type gpio_initstructure;
124
125 if(hi2c->i2cx == I2Cx_PORT)
126 {
127 /* i2c periph clock enable */
128 crm_periph_clock_enable(I2Cx_CLK, TRUE);
129 crm_periph_clock_enable(I2Cx_SCL_GPIO_CLK, TRUE);
130 crm_periph_clock_enable(I2Cx_SDA_GPIO_CLK, TRUE);
131
132 /* gpio configuration */
133 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
134 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
135 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
136 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_MODERATE;
137
138 /* configure i2c pins: scl */
139 gpio_initstructure.gpio_pins = I2Cx_SCL_PIN;
140 gpio_init(I2Cx_SCL_GPIO_PORT, &gpio_initstructure);
141
142 /* configure i2c pins: sda */
143 gpio_initstructure.gpio_pins = I2Cx_SDA_PIN;
144 gpio_init(I2Cx_SDA_GPIO_PORT, &gpio_initstructure);
145
146 /* configure and enable i2c dma channel interrupt */
147 nvic_irq_enable(I2Cx_DMA_TX_IRQn, 0, 0);
148 nvic_irq_enable(I2Cx_DMA_RX_IRQn, 0, 0);
149
150 /* configure and enable i2c interrupt */
151 nvic_irq_enable(I2Cx_EVT_IRQn, 0, 0);
152 nvic_irq_enable(I2Cx_ERR_IRQn, 0, 0);
153
154 /* i2c dma tx and rx channels configuration */
155 /* enable the dma clock */
156 crm_periph_clock_enable(I2Cx_DMA_CLK, TRUE);
157
158 /* i2c dma channel configuration */
159 dma_reset(hi2c->dma_tx_channel);
160 dma_reset(hi2c->dma_rx_channel);
161
162 hi2c->dma_tx_channel = I2Cx_DMA_TX_CHANNEL;
163 hi2c->dma_rx_channel = I2Cx_DMA_RX_CHANNEL;
164
165 dma_default_para_init(&hi2c->dma_init_struct);
166 hi2c->dma_init_struct.peripheral_inc_enable = FALSE;
167 hi2c->dma_init_struct.memory_inc_enable = TRUE;
168 hi2c->dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
169 hi2c->dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
170 hi2c->dma_init_struct.loop_mode_enable = FALSE;
171 hi2c->dma_init_struct.priority = DMA_PRIORITY_LOW;
172 hi2c->dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
173
174 dma_init(hi2c->dma_tx_channel, &hi2c->dma_init_struct);
175 dma_init(hi2c->dma_rx_channel, &hi2c->dma_init_struct);
176
177 i2c_init(hi2c->i2cx, I2C_FSMODE_DUTY_2_1, I2Cx_SPEED);
178
179 i2c_own_address1_set(hi2c->i2cx, I2C_ADDRESS_MODE_7BIT, I2Cx_ADDRESS);
180 }
181}
182
188int main(void)
189{
190 i2c_status_type i2c_status;
191
192 /* config nvic priority group */
193 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
194
195 system_clock_config();
196
197 at32_board_init();
198
199 hi2cx.i2cx = I2Cx_PORT;
200
201 i2c_config(&hi2cx);
202
203 while(1)
204 {
205 /* wait for key USER_BUTTON press before starting the communication */
206 while(at32_button_press() != USER_BUTTON)
207 {
208 }
209
210 /* write data to memory device */
211 if((i2c_status = i2c_memory_write(&hi2cx, I2Cx_ADDRESS, 0, tx_buf1, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
212 {
213 error_handler(i2c_status);
214 }
215
216 delay_ms(5);
217
218 /* read data from memory device */
219 if((i2c_status = i2c_memory_read(&hi2cx, I2Cx_ADDRESS, 0, rx_buf1, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
220 {
221 error_handler(i2c_status);
222 }
223
224 /* write data to memory device */
225 if((i2c_status = i2c_memory_write_int(&hi2cx, I2Cx_ADDRESS, 0, tx_buf2, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
226 {
227 error_handler(i2c_status);
228 }
229
230 /* wait for the communication to end */
231 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
232 {
233 error_handler(i2c_status);
234 }
235
236 delay_ms(5);
237
238 /* read data from memory device */
239 if((i2c_status = i2c_memory_read_int(&hi2cx, I2Cx_ADDRESS, 0, rx_buf2, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
240 {
241 error_handler(i2c_status);
242 }
243
244 /* wait for the communication to end */
245 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
246 {
247 error_handler(i2c_status);
248 }
249
250 /* write data to memory device */
251 if((i2c_status = i2c_memory_write_dma(&hi2cx, I2Cx_ADDRESS, 0, tx_buf3, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
252 {
253 error_handler(i2c_status);
254 }
255
256 /* wait for the communication to end */
257 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
258 {
259 error_handler(i2c_status);
260 }
261
262 delay_ms(5);
263
264 /* read data from memory device */
265 if((i2c_status = i2c_memory_read_dma(&hi2cx, I2Cx_ADDRESS, 0, rx_buf3, BUF_SIZE, I2C_TIMEOUT)) != I2C_OK)
266 {
267 error_handler(i2c_status);
268 }
269
270 /* wait for the communication to end */
271 if(i2c_wait_end(&hi2cx, I2C_TIMEOUT) != I2C_OK)
272 {
273 error_handler(i2c_status);
274 }
275
276 if((buffer_compare(tx_buf1, rx_buf1, BUF_SIZE) == 0) &&
277 (buffer_compare(tx_buf2, rx_buf2, BUF_SIZE) == 0) &&
278 (buffer_compare(tx_buf3, rx_buf3, BUF_SIZE) == 0))
279 {
280 at32_led_on(LED3);
281 }
282 else
283 {
284 error_handler(i2c_status);
285 }
286
287 }
288}
289
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
I2Cx_ADDRESS
#define I2Cx_ADDRESS
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:42
I2Cx_DMA_RX_IRQn
#define I2Cx_DMA_RX_IRQn
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:60
I2Cx_CLK
#define I2Cx_CLK
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:45
tx_buf3
uint8_t tx_buf3[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:69
I2Cx_DMA_TX_CHANNEL
#define I2Cx_DMA_TX_CHANNEL
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:56
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:65
rx_buf1
uint8_t rx_buf1[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:70
I2Cx_SDA_PIN
#define I2Cx_SDA_PIN
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:188
I2Cx_SCL_PIN
#define I2Cx_SCL_PIN
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:47
hi2cx
i2c_handle_type hi2cx
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:74
I2Cx_SDA_GPIO_PORT
#define I2Cx_SDA_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:52
buffer_compare
uint32_t buffer_compare(uint8_t *buffer1, uint8_t *buffer2, uint32_t len)
compare whether the valus of buffer 1 and buffer 2 are equal.
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:101
I2Cx_DMA_CLK
#define I2Cx_DMA_CLK
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:55
I2Cx_SDA_GPIO_CLK
#define I2Cx_SDA_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:53
rx_buf2
uint8_t rx_buf2[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:71
I2Cx_ERR_IRQn
#define I2Cx_ERR_IRQn
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:63
error_handler
void error_handler(uint32_t error_code)
error handler program
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:85
i2c_lowlevel_init
void i2c_lowlevel_init(i2c_handle_type *hi2c)
initializes peripherals used by the i2c.
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:121
I2Cx_SPEED
#define I2Cx_SPEED
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:41
I2Cx_PORT
#define I2Cx_PORT
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:44
rx_buf3
uint8_t rx_buf3[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:72
tx_buf2
uint8_t tx_buf2[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:68
I2Cx_SCL_GPIO_CLK
#define I2Cx_SCL_GPIO_CLK
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:49
I2Cx_DMA_RX_CHANNEL
#define I2Cx_DMA_RX_CHANNEL
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:59
I2Cx_DMA_TX_IRQn
#define I2Cx_DMA_TX_IRQn
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:57
tx_buf1
uint8_t tx_buf1[8]
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:67
I2Cx_EVT_IRQn
#define I2Cx_EVT_IRQn
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:62
I2Cx_SCL_GPIO_PORT
#define I2Cx_SCL_GPIO_PORT
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:48
I2C_TIMEOUT
#define I2C_TIMEOUT
Definition: project/at_start_f413/examples/i2c/eeprom/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
i2c_wait_end
i2c_status_type i2c_wait_end(i2c_handle_type *hi2c, uint32_t timeout)
wait for the transfer to end.
Definition: i2c_application.c:158
i2c_memory_read
i2c_status_type i2c_memory_read(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1391
i2c_memory_write_int
i2c_status_type i2c_memory_write_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through interrupt mode.
Definition: i2c_application.c:1597
i2c_memory_write
i2c_status_type i2c_memory_write(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through polling mode.
Definition: i2c_application.c:1309
i2c_memory_write_dma
i2c_status_type i2c_memory_write_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
write data to the memory device through dma mode.
Definition: i2c_application.c:1777
i2c_config
void i2c_config(i2c_handle_type *hi2c)
i2c peripheral initialization.
Definition: i2c_application.c:112
i2c_memory_read_int
i2c_status_type i2c_memory_read_int(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through interrupt mode.
Definition: i2c_application.c:1667
i2c_memory_read_dma
i2c_status_type i2c_memory_read_dma(i2c_handle_type *hi2c, uint16_t address, uint16_t mem_address, uint8_t *pdata, uint16_t size, uint32_t timeout)
read data from memory device through polling mode.
Definition: i2c_application.c:1853
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:245
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:255
DMA_PRIORITY_LOW
@ DMA_PRIORITY_LOW
Definition: at32f413_dma.h:265
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_MODERATE
@ GPIO_DRIVE_STRENGTH_MODERATE
Definition: at32f413_gpio.h:226
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:236
i2c_own_address1_set
void i2c_own_address1_set(i2c_type *i2c_x, i2c_address_mode_type mode, uint16_t address)
config own address1.
Definition: at32f413_i2c.c:185
i2c_init
void i2c_init(i2c_type *i2c_x, i2c_fsmode_duty_cycle_type duty, uint32_t speed)
init i2c speed and duty cycle.
Definition: at32f413_i2c.c:90
I2C_FSMODE_DUTY_2_1
@ I2C_FSMODE_DUTY_2_1
Definition: at32f413_i2c.h:148
I2C_ADDRESS_MODE_7BIT
@ I2C_ADDRESS_MODE_7BIT
Definition: at32f413_i2c.h:157
i2c_status_type
i2c_status_type
Definition: i2c_application.h:81
I2C_OK
@ I2C_OK
Definition: i2c_application.h:82
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
i2c_application.h
i2c application libray header file
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
i2c_handle_type
Definition: i2c_application.h:114
i2c_handle_type::dma_rx_channel
dma_channel_type * dma_rx_channel
Definition: i2c_application.h:124
i2c_handle_type::i2cx
i2c_type * i2cx
Definition: i2c_application.h:115
i2c_handle_type::dma_init_struct
dma_init_type dma_init_struct
Definition: i2c_application.h:125
i2c_handle_type::dma_tx_channel
dma_channel_type * dma_tx_channel
Definition: i2c_application.h:123
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2s
  • halfduplex_dma
  • inc
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2s
  • halfduplex_dma
  • inc
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2s
  • halfduplex_dma
  • inc
project/at_start_f413/examples/i2s/halfduplex_dma/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2s
  • halfduplex_dma
  • src
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2s
  • halfduplex_dma
  • src
project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2s
  • halfduplex_dma
  • src
project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30
31
40uint16_t i2s1_buffer_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
41 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
42 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
43 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
44 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
45 0x3D3E, 0x3F40};
46uint16_t i2s2_buffer_rx[32];
47volatile error_status transfer_status = ERROR;
48
49static void gpio_config(void);
50static void i2s_config(void);
51 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
52
58 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
59{
60 while(buffer_length--)
61 {
62 if(*pbuffer1 != *pbuffer2)
63 {
64 return ERROR;
65 }
66
67 pbuffer1++;
68 pbuffer2++;
69 }
70 return SUCCESS;
71}
72
78static void i2s_config(void)
79{
80 dma_init_type dma_init_struct;
81 i2s_init_type i2s_init_struct;
82
83 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
84 dma_reset(DMA1_CHANNEL4);
85 dma_reset(DMA1_CHANNEL3);
86 dma_default_para_init(&dma_init_struct);
87 dma_init_struct.buffer_size = 32;
88 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
89 dma_init_struct.memory_base_addr = (uint32_t)i2s1_buffer_tx;
90 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
91 dma_init_struct.memory_inc_enable = TRUE;
92 dma_init_struct.peripheral_base_addr = (uint32_t)0x4001300C;
93 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
94 dma_init_struct.peripheral_inc_enable = FALSE;
95 dma_init_struct.priority = DMA_PRIORITY_HIGH;
96 dma_init_struct.loop_mode_enable = FALSE;
97 dma_init(DMA1_CHANNEL3, &dma_init_struct);
98
99 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
100 dma_init_struct.memory_base_addr = (uint32_t)i2s2_buffer_rx;
101 dma_init_struct.peripheral_base_addr = (uint32_t)0x4000380C;
102 dma_init(DMA1_CHANNEL4, &dma_init_struct);
103
104 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
105 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
106 i2s_default_para_init(&i2s_init_struct);
107 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
108 i2s_init_struct.data_channel_format = I2S_DATA_16BIT_CHANNEL_32BIT;
109 i2s_init_struct.mclk_output_enable = TRUE;
110 i2s_init_struct.audio_sampling_freq = I2S_AUDIO_FREQUENCY_48K;
111 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
112 i2s_init_struct.operation_mode = I2S_MODE_MASTER_TX;
113 i2s_init(SPI1, &i2s_init_struct);
114
115 i2s_init_struct.operation_mode =I2S_MODE_SLAVE_RX;
116 i2s_init(SPI2, &i2s_init_struct);
117
118 dma_channel_enable(DMA1_CHANNEL3, TRUE);
119 dma_channel_enable(DMA1_CHANNEL4, TRUE);
120 spi_i2s_dma_receiver_enable(SPI2, TRUE);
121 i2s_enable(SPI1, TRUE);
122 i2s_enable(SPI2, TRUE);
123}
124
130static void gpio_config(void)
131{
132 gpio_init_type gpio_initstructure;
133 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
134 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
135
136 /* master ws pin */
137 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
138 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
139 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
140 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
141 gpio_initstructure.gpio_pins = GPIO_PINS_4;
142 gpio_init(GPIOA, &gpio_initstructure);
143
144 /* master ck pin */
145 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
146 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
147 gpio_initstructure.gpio_pins = GPIO_PINS_5;
148 gpio_init(GPIOA, &gpio_initstructure);
149
150 /* master sd pin */
151 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
152 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
153 gpio_initstructure.gpio_pins = GPIO_PINS_7;
154 gpio_init(GPIOA, &gpio_initstructure);
155
156 /* master mck pin */
157 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
158 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
159 gpio_initstructure.gpio_pins = GPIO_PINS_0;
160 gpio_init(GPIOB, &gpio_initstructure);
161
162 /* slave ws pin */
163 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
164 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
165 gpio_initstructure.gpio_pins = GPIO_PINS_12;
166 gpio_init(GPIOB, &gpio_initstructure);
167
168 /* slave ck pin */
169 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
170 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
171 gpio_initstructure.gpio_pins = GPIO_PINS_13;
172 gpio_init(GPIOB, &gpio_initstructure);
173
174 /* slave sd pin */
175 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
176 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
177 gpio_initstructure.gpio_pins = GPIO_PINS_15;
178 gpio_init(GPIOB, &gpio_initstructure);
179}
180
186int main(void)
187{
188 system_clock_config();
189 at32_board_init();
190 at32_led_off(LED2);
191 at32_led_off(LED3);
192 at32_led_off(LED4);
193 gpio_config();
194 i2s_config();
195 spi_i2s_dma_transmitter_enable(SPI1, TRUE);
196
197 while(dma_flag_get(DMA1_FDT4_FLAG) == RESET);
198
199 /* test result:the data check */
200 transfer_status = buffer_compare(i2s2_buffer_rx, i2s1_buffer_tx, 32);
201
202 /* test result indicate:if passed ,led2 lights */
203 if(transfer_status==SUCCESS)
204 {
205 at32_led_on(LED2);
206 }
207 else
208 {
209 at32_led_off(LED2);
210 }
211 while(1)
212 {
213 }
214}
215
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:58
i2s_config
static void i2s_config(void)
i2s configuration.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:78
i2s1_buffer_tx
uint16_t i2s1_buffer_tx[32]
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:186
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:130
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:47
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:46
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:94
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:482
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:483
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:316
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:499
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:445
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:298
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:485
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:249
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:228
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f413_spi.h:217
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:198
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f413_spi.h:240
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:239
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
i2s_init_type
i2s init type
Definition: at32f413_spi.h:272
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:275
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:276
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:278
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:274
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:273
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:277
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2s
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2s
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2s
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/i2s/halfduplex_interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2s
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2s
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31extern uint16_t i2s1_buffer_tx[];
32extern uint16_t i2s2_buffer_rx[];
33extern __IO uint32_t tx_index, rx_index;
34
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
140
146 void SPI2_IRQHandler(void)
147{
148 if(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) != RESET)
149 {
150 i2s2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
151 }
152}
153
159void SPI1_IRQHandler(void)
160{
161 if(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) != RESET)
162 {
163 spi_i2s_data_transmit(SPI1, i2s1_buffer_tx[tx_index++]);
164 if(tx_index == 32)
165 {
166 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, FALSE);
167 }
168 }
169}
170
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
i2s1_buffer_tx
uint16_t i2s1_buffer_tx[]
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:40
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[]
Definition: project/at_start_f413/examples/i2s/halfduplex_dma/src/main.c:46
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:70
tx_index
__IO uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:46
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:109
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:127
SPI2_IRQHandler
void SPI2_IRQHandler(void)
This function handles the spi2 interrupt request.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:146
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:48
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:83
SPI1_IRQHandler
void SPI1_IRQHandler(void)
This function handles the spi1 interrupt request.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:159
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:136
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:118
FALSE
@ FALSE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:74
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:464
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
rx_index
__IO uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:33
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2s
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30
39uint16_t i2s1_buffer_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
40 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
41 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
42 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
43 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
44 0x3D3E, 0x3F40};
45uint16_t i2s2_buffer_rx[32];
46__IO uint32_t tx_index = 0, rx_index = 0;
47volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
48
49static void gpio_config(void);
50static void i2s_config(i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq);
51 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
52 error_status buffer_compare_24bits(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
53
59 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
60{
61 while(buffer_length--)
62 {
63 if(*pbuffer1 != *pbuffer2)
64 {
65 return ERROR;
66 }
67
68 pbuffer1++;
69 pbuffer2++;
70 }
71 return SUCCESS;
72}
73
79 error_status buffer_compare_24bits(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
80{
81 while(buffer_length--)
82 {
83 if(*pbuffer1 != *pbuffer2)
84 {
85 if(*pbuffer1 != (*pbuffer2 & 0xFF00))
86 {
87 return ERROR;
88 }
89 }
90
91 pbuffer1++;
92 pbuffer2++;
93 }
94 return SUCCESS;
95}
96
102static void i2s_config(i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
103{
104 i2s_init_type i2s_init_struct;
105
106 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
107 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
108
109 nvic_irq_enable(SPI1_IRQn, 0, 0);
110 nvic_irq_enable(SPI2_IRQn, 0, 0);
111 spi_i2s_reset(SPI2);
112 spi_i2s_reset(SPI1);
113 i2s_default_para_init(&i2s_init_struct);
114 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
115 i2s_init_struct.data_channel_format = format;
116 i2s_init_struct.mclk_output_enable = TRUE;
117 i2s_init_struct.audio_sampling_freq = freq;
118 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
119 i2s_init_struct.operation_mode = I2S_MODE_MASTER_TX;
120 i2s_init(SPI1, &i2s_init_struct);
121
122 i2s_init_struct.operation_mode =I2S_MODE_SLAVE_RX;
123 i2s_init(SPI2, &i2s_init_struct);
124
125 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, TRUE);
126 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, TRUE);
127 i2s_enable(SPI2, TRUE);
128 i2s_enable(SPI1, TRUE);
129}
130
136static void gpio_config(void)
137{
138 gpio_init_type gpio_initstructure;
139 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
140 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
141
142 /* master ws pin */
143 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
144 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
145 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
146 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
147 gpio_initstructure.gpio_pins = GPIO_PINS_4;
148 gpio_init(GPIOA, &gpio_initstructure);
149
150 /* master ck pin */
151 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
152 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
153 gpio_initstructure.gpio_pins = GPIO_PINS_5;
154 gpio_init(GPIOA, &gpio_initstructure);
155
156 /* master sd pin */
157 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
158 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
159 gpio_initstructure.gpio_pins = GPIO_PINS_7;
160 gpio_init(GPIOA, &gpio_initstructure);
161
162 /* master mck pin */
163 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
164 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
165 gpio_initstructure.gpio_pins = GPIO_PINS_0;
166 gpio_init(GPIOB, &gpio_initstructure);
167
168 /* slave ws pin */
169 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
170 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
171 gpio_initstructure.gpio_pins = GPIO_PINS_12;
172 gpio_init(GPIOB, &gpio_initstructure);
173
174 /* slave ck pin */
175 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
176 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
177 gpio_initstructure.gpio_pins = GPIO_PINS_13;
178 gpio_init(GPIOB, &gpio_initstructure);
179
180 /* slave sd pin */
181 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
182 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
183 gpio_initstructure.gpio_pins = GPIO_PINS_15;
184 gpio_init(GPIOB, &gpio_initstructure);
185}
186
192int main(void)
193{
194 __IO uint32_t index = 0;
195 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
196 system_clock_config();
197 at32_board_init();
198 at32_led_off(LED2);
199 at32_led_off(LED3);
200 at32_led_off(LED4);
201 gpio_config();
202 i2s_config(I2S_DATA_16BIT_CHANNEL_32BIT, I2S_AUDIO_FREQUENCY_48K);
203 while(rx_index < 32);
204
205 /* test result:the data check */
206 transfer_status1 = buffer_compare(i2s2_buffer_rx, i2s1_buffer_tx, 32);
207
208 for(index = 0; index < 32; index++) i2s2_buffer_rx[index] = 0;
209 tx_index = 0;
210 rx_index = 0;
211
212 i2s_config(I2S_DATA_24BIT_CHANNEL_32BIT, I2S_AUDIO_FREQUENCY_16K);
213 while(rx_index < 32);
214
215 /* test result:the data check */
216 transfer_status2 = buffer_compare_24bits(i2s2_buffer_rx, i2s1_buffer_tx, 32);
217
218 /* test result indicate:if passed ,led2 lights */
219 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
220 {
221 at32_led_on(LED2);
222 }
223 else
224 {
225 at32_led_off(LED2);
226 }
227
228 while(1)
229 {
230 }
231}
232
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:59
tx_index
__IO uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:46
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:47
i2s1_buffer_tx
uint16_t i2s1_buffer_tx[32]
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:39
i2s_config
static void i2s_config(i2s_data_channel_format_type format, i2s_audio_sampling_freq_type freq)
i2s configuration.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:102
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:47
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:192
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:136
buffer_compare_24bits
error_status buffer_compare_24bits(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare_24bits function.
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:79
rx_index
__IO uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:46
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
SPI2_IRQn
@ SPI2_IRQn
Definition: at32f413.h:170
SPI1_IRQn
@ SPI1_IRQn
Definition: at32f413.h:169
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:74
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f413_spi.h:73
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:464
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:316
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:445
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:298
i2s_data_channel_format_type
i2s_data_channel_format_type
i2s data bit num and channel bit num type
Definition: at32f413_spi.h:226
i2s_audio_sampling_freq_type
i2s_audio_sampling_freq_type
i2s audio frequency type
Definition: at32f413_spi.h:209
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:249
I2S_DATA_24BIT_CHANNEL_32BIT
@ I2S_DATA_24BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:229
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:228
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f413_spi.h:217
I2S_AUDIO_FREQUENCY_16K
@ I2S_AUDIO_FREQUENCY_16K
Definition: at32f413_spi.h:213
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:198
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f413_spi.h:240
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:239
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
i2s_init_type
i2s init type
Definition: at32f413_spi.h:272
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:275
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:276
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:278
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:274
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:273
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:277
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • inc
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • i2s
  • spii2s_switch_halfduplex_polling
  • src
project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30
39uint16_t i2s1_buffer_tx[32] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C,
40 0x0D0E, 0x0F10, 0x1112, 0x1314, 0x1516, 0x1718,
41 0x191A, 0x1B1C, 0x1D1E, 0x1F20, 0x2122, 0x2324,
42 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
43 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C,
44 0x3D3E, 0x3F40
45 };
46uint16_t spi1_buffer_tx[32] = {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C,
47 0x5D5E, 0x5F60, 0x6162, 0x6364, 0x6566, 0x6768,
48 0x696A, 0x6B6C, 0x6D6E, 0x6F70, 0x7172, 0x7374,
49 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
50 0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C,
51 0x8D8E, 0x8F90
52 };
53uint16_t i2s2_buffer_rx[32];
54uint16_t spi2_buffer_rx[32];
55__IO uint32_t tx_index = 0, rx_index = 0;
56volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR, transfer_status3 = ERROR;
57
58static void gpio_config(void);
59static void spi_config(void);
60static void i2s_config(i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode);
61 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
62
68 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
69{
70 while(buffer_length--)
71 {
72 if(*pbuffer1 != *pbuffer2)
73 {
74 return ERROR;
75 }
76
77 pbuffer1++;
78 pbuffer2++;
79 }
80 return SUCCESS;
81}
82
88static void i2s_config(i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode)
89{
90 i2s_init_type i2s_init_struct;
91
92 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
93 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
94
95 spi_i2s_reset(SPI2);
96 spi_i2s_reset(SPI1);
97 i2s_default_para_init(&i2s_init_struct);
98 i2s_init_struct.audio_protocol = I2S_AUDIO_PROTOCOL_PHILLIPS;
99 i2s_init_struct.data_channel_format = I2S_DATA_16BIT_CHANNEL_32BIT;
100 i2s_init_struct.mclk_output_enable = FALSE;
101 i2s_init_struct.audio_sampling_freq = I2S_AUDIO_FREQUENCY_48K;
102 i2s_init_struct.clock_polarity = I2S_CLOCK_POLARITY_LOW;
103 i2s_init_struct.operation_mode = i2s1_mode;
104 i2s_init(SPI1, &i2s_init_struct);
105
106 i2s_init_struct.operation_mode =i2s2_mode;
107 i2s_init(SPI2, &i2s_init_struct);
108}
109
115static void spi_config(void)
116{
117 spi_init_type spi_init_struct;
118 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
119 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
120
121 spi_i2s_reset(SPI2);
122 spi_i2s_reset(SPI1);
123 spi_default_para_init(&spi_init_struct);
124 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
125 spi_init_struct.master_slave_mode =SPI_MODE_MASTER;
126 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
127 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
128 spi_init_struct.frame_bit_num = SPI_FRAME_16BIT;
129 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
130 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
131 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
132 spi_init(SPI1, &spi_init_struct);
133
134 spi_init_struct.transmission_mode = SPI_TRANSMIT_SIMPLEX_RX;
135 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
136 spi_init(SPI2, &spi_init_struct);
137
138 spi_enable(SPI2, TRUE);
139 spi_enable(SPI1, TRUE);
140}
141
147static void gpio_config(void)
148{
149 gpio_init_type gpio_initstructure;
150 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
151 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
152
153 /* master ws pin */
154 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
155 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
156 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
157 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
158 gpio_initstructure.gpio_pins = GPIO_PINS_4;
159 gpio_init(GPIOA, &gpio_initstructure);
160
161 /* master ck pin */
162 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
163 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
164 gpio_initstructure.gpio_pins = GPIO_PINS_5;
165 gpio_init(GPIOA, &gpio_initstructure);
166
167 /* master sd pin */
168 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
169 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
170 gpio_initstructure.gpio_pins = GPIO_PINS_7;
171 gpio_init(GPIOA, &gpio_initstructure);
172
173 /* master mck pin */
174 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
175 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
176 gpio_initstructure.gpio_pins = GPIO_PINS_0;
177 gpio_init(GPIOB, &gpio_initstructure);
178
179 /* slave ws pin */
180 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
181 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
182 gpio_initstructure.gpio_pins = GPIO_PINS_12;
183 gpio_init(GPIOB, &gpio_initstructure);
184
185 /* slave ck pin */
186 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
187 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
188 gpio_initstructure.gpio_pins = GPIO_PINS_13;
189 gpio_init(GPIOB, &gpio_initstructure);
190
191 /* slave sd pin */
192 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
193 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
194 gpio_initstructure.gpio_pins = GPIO_PINS_15;
195 gpio_init(GPIOB, &gpio_initstructure);
196}
197
203int main(void)
204{
205 __IO uint32_t index = 0;
206 system_clock_config();
207 at32_board_init();
208 at32_led_off(LED2);
209 at32_led_off(LED3);
210 at32_led_off(LED4);
211 gpio_config();
212 i2s_config(I2S_MODE_MASTER_TX, I2S_MODE_SLAVE_RX);
213 i2s_enable(SPI2, TRUE);
214 i2s_enable(SPI1, TRUE);
215 while(rx_index < 32)
216 {
217 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
218 spi_i2s_data_transmit(SPI1, i2s1_buffer_tx[tx_index++]);
219 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
220 i2s2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
221 }
222
223 /* test result:the data check */
224 transfer_status1 = buffer_compare(i2s2_buffer_rx, i2s1_buffer_tx, 32);
225
226 tx_index = 0;
227 rx_index = 0;
228 spi_config();
229 while(rx_index < 32)
230 {
231 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
232 spi_i2s_data_transmit(SPI1, spi1_buffer_tx[tx_index++]);
233 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
234 spi2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
235 }
236
237 /* test result:the data check */
238 transfer_status2 = buffer_compare(spi2_buffer_rx, spi1_buffer_tx, 32);
239
240 for(index = 0; index < 32; index++) i2s2_buffer_rx[index] = 0;
241 tx_index = 0;
242 rx_index = 0;
243 i2s_config(I2S_MODE_SLAVE_TX, I2S_MODE_MASTER_RX);
244 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
245 spi_i2s_data_transmit(SPI1, i2s1_buffer_tx[tx_index++]);
246 i2s_enable(SPI1, TRUE);
247 i2s_enable(SPI2, TRUE);
248 while(rx_index < 32)
249 {
250 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
251 i2s2_buffer_rx[rx_index++] = spi_i2s_data_receive(SPI2);
252 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
253 spi_i2s_data_transmit(SPI1, i2s1_buffer_tx[tx_index++]);
254 }
255
256 /* test result:the data check */
257 transfer_status3 = buffer_compare(i2s2_buffer_rx, i2s1_buffer_tx, 32);
258
259 /* test result indicate:if passed ,led2 lights */
260 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS) && (transfer_status3 == SUCCESS))
261 {
262 at32_led_on(LED2);
263 }
264 else
265 {
266 at32_led_off(LED2);
267 }
268 while(1)
269 {
270 }
271}
272
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer_compare function.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:68
tx_index
__IO uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:55
transfer_status3
volatile error_status transfer_status3
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:56
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:115
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:56
i2s1_buffer_tx
uint16_t i2s1_buffer_tx[32]
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:39
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:56
main
int main(void)
main function.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:203
i2s_config
static void i2s_config(i2s_operation_mode_type i2s1_mode, i2s_operation_mode_type i2s2_mode)
i2s configuration.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:88
spi2_buffer_rx
uint16_t spi2_buffer_rx[32]
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:54
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:147
spi1_buffer_tx
uint16_t spi1_buffer_tx[32]
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:46
rx_index
__IO uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:55
i2s2_buffer_rx
uint16_t i2s2_buffer_rx[32]
Definition: project/at_start_f413/examples/i2s/spii2s_switch_halfduplex_polling/src/main.c:53
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
i2s_init
void i2s_init(spi_type *spi_x, i2s_init_type *i2s_init_struct)
i2s init config with its setting value.
Definition: at32f413_spi.c:316
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
i2s_enable
void i2s_enable(spi_type *spi_x, confirm_state new_state)
enable or disable i2s.
Definition: at32f413_spi.c:445
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
spi_i2s_reset
void spi_i2s_reset(spi_type *spi_x)
spi reset by crm reset register
Definition: at32f413_spi.c:51
i2s_default_para_init
void i2s_default_para_init(i2s_init_type *i2s_init_struct)
i2s init config with its default value.
Definition: at32f413_spi.c:298
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
i2s_operation_mode_type
i2s_operation_mode_type
i2s operation mode type
Definition: at32f413_spi.h:237
I2S_CLOCK_POLARITY_LOW
@ I2S_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:249
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
I2S_DATA_16BIT_CHANNEL_32BIT
@ I2S_DATA_16BIT_CHANNEL_32BIT
Definition: at32f413_spi.h:228
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
I2S_AUDIO_FREQUENCY_48K
@ I2S_AUDIO_FREQUENCY_48K
Definition: at32f413_spi.h:217
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:151
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:107
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:163
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f413_spi.h:161
I2S_AUDIO_PROTOCOL_PHILLIPS
@ I2S_AUDIO_PROTOCOL_PHILLIPS
Definition: at32f413_spi.h:198
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:136
SPI_FRAME_16BIT
@ SPI_FRAME_16BIT
Definition: at32f413_spi.h:90
I2S_MODE_MASTER_TX
@ I2S_MODE_MASTER_TX
Definition: at32f413_spi.h:240
I2S_MODE_MASTER_RX
@ I2S_MODE_MASTER_RX
Definition: at32f413_spi.h:241
I2S_MODE_SLAVE_RX
@ I2S_MODE_SLAVE_RX
Definition: at32f413_spi.h:239
I2S_MODE_SLAVE_TX
@ I2S_MODE_SLAVE_TX
Definition: at32f413_spi.h:238
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
i2s_init_type
i2s init type
Definition: at32f413_spi.h:272
i2s_init_type::audio_sampling_freq
i2s_audio_sampling_freq_type audio_sampling_freq
Definition: at32f413_spi.h:275
i2s_init_type::data_channel_format
i2s_data_channel_format_type data_channel_format
Definition: at32f413_spi.h:276
i2s_init_type::mclk_output_enable
confirm_state mclk_output_enable
Definition: at32f413_spi.h:278
i2s_init_type::audio_protocol
i2s_audio_protocol_type audio_protocol
Definition: at32f413_spi.h:274
i2s_init_type::operation_mode
i2s_operation_mode_type operation_mode
Definition: at32f413_spi.h:273
i2s_init_type::clock_polarity
i2s_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:277
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • deepsleep_rtc
  • inc
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • deepsleep_rtc
  • inc
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • deepsleep_rtc
  • inc
project/at_start_f413/examples/pwc/deepsleep_rtc/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • deepsleep_rtc
  • src
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • deepsleep_rtc
  • src
project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void RTCAlarm_IRQHandler(void)
144{
145 if(rtc_flag_get(RTC_TA_FLAG) != RESET)
146 {
147 /* clear exint line flag */
148 exint_flag_clear(EXINT_LINE_17);
149
150 /* toggle led */
151 at32_led_toggle(LED4);
152
153 /* wait for the register write to complete */
154 rtc_wait_config_finish();
155
156 /* clear alarm flag */
157 rtc_flag_clear(RTC_TA_FLAG);
158
159 /* wait for the register write to complete */
160 rtc_wait_config_finish();
161 }
162}
163
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:116
RTCAlarm_IRQHandler
void RTCAlarm_IRQHandler(void)
this function handles the rtc alarm through exint line interrupt request.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/at32f413_int.c:143
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
EXINT_LINE_17
#define EXINT_LINE_17
Definition: at32f413_exint.h:69
RESET
@ RESET
Definition: at32f413.h:254
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:197
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:161
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:187
RTC_TA_FLAG
#define RTC_TA_FLAG
Definition: at32f413_rtc.h:66
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • deepsleep_rtc
  • src
project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30
31
45void rtc_config(void)
46{
47 exint_init_type exint_init_struct;
48
49 /* config the exint line of the rtc alarm */
50 exint_init_struct.line_select = EXINT_LINE_17;
51 exint_init_struct.line_enable = TRUE;
52 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
53 exint_init_struct.line_polarity = EXINT_TRIGGER_BOTH_EDGE;
54 exint_init(&exint_init_struct);
55
56 /* enable the battery-powered domain write operations */
57 pwc_battery_powered_domain_access(TRUE);
58
59 /* reset battery-powered domain register */
60 bpr_reset();
61
62 /* enable the lick */
63 crm_clock_source_enable(CRM_CLOCK_SOURCE_LICK, TRUE);
64
65 /* wait lick is ready */
66 while(crm_flag_get(CRM_LICK_STABLE_FLAG) == RESET);
67
68 /* select the rtc clock source */
69 crm_rtc_clock_select(CRM_RTC_CLOCK_LICK);
70
71 /* enable rtc clock */
72 crm_rtc_clock_enable(TRUE);
73
74 /* wait for rtc registers update */
75 rtc_wait_update_finish();
76
77 /* set rtc divider: set rtc period to 1sec */
78 rtc_divider_set(32767);
79
80 /* wait for the register write to complete */
81 rtc_wait_config_finish();
82
83 /* enable alarm interrupt */
84 rtc_interrupt_enable(RTC_TA_INT, TRUE);
85
86 /* wait for the register write to complete */
87 rtc_wait_config_finish();
88
89 /* configure and enable rtc alarm interrupt */
90 nvic_irq_enable(RTCAlarm_IRQn, 0, 0);
91}
92
98void system_clock_recover(void)
99{
100 /* enable external high-speed crystal oscillator - hext */
101 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
102
103 /* wait till hext is ready */
104 while(crm_hext_stable_wait() == ERROR);
105
106 /* enable pll */
107 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
108
109 /* wait till pll is ready */
110 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
111
112 /* enable auto step mode */
113 crm_auto_step_mode_enable(TRUE);
114
115 /* select pll as system clock source */
116 crm_sysclk_switch(CRM_SCLK_PLL);
117
118 /* wait till pll is used as system clock source */
119 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
120}
121
127int main(void)
128{
129 __IO uint32_t index = 0;
130 __IO uint32_t systick_index = 0;
131
132 /* congfig the system clock */
133 system_clock_config();
134
135 /* init at start board */
136 at32_board_init();
137
138 /* config priority group */
139 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
140
141 /* turn on the led light */
142 at32_led_on(LED2);
143 at32_led_on(LED3);
144 at32_led_on(LED4);
145
146 /* enable pwc and bpr clock */
147 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
148 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
149
150 /* config rtc */
151 rtc_config();
152
153 while(1)
154 {
155 /* clear second flag */
156 rtc_flag_clear(RTC_TS_FLAG);
157
158 /* wait for the second flag to be set */
159 while(rtc_flag_get(RTC_TS_FLAG) == RESET);
160
161 /* set the wakeup time to 3 seconds */
162 rtc_alarm_set(rtc_counter_get() + 3);
163
164 /* wait for the register write to complete */
165 rtc_wait_config_finish();
166
167 at32_led_off(LED2);
168
169 /* save systick register configuration */
170 systick_index = SysTick->CTRL;
171 systick_index &= ~((uint32_t)0xFFFFFFFE);
172
173 /* disable systick */
174 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
175
176 /* congfig the voltage regulator mode */
177 pwc_voltage_regulate_set(PWC_REGULATOR_LOW_POWER);
178
179 /* enter deep sleep mode */
180 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
181
182 /* restore systick register configuration */
183 SysTick->CTRL |= systick_index;
184
185 at32_led_on(LED2);
186
187 /* wait clock stable */
188 for(index = 0; index < 600; index++)
189 {
190 __NOP();
191 }
192
193 /* wake up from deep sleep mode, congfig the system clock */
194 system_clock_recover();
195
196 delay_ms(500);
197 }
198}
199
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rtc_config
void rtc_config(void)
rtc configuration.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:45
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:127
system_clock_recover
void system_clock_recover(void)
systemclock recover.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:98
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:49
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:376
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:386
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:140
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:298
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_RTC_CLOCK_LICK
@ CRM_RTC_CLOCK_LICK
Definition: at32f413_crm.h:375
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_LICK_STABLE_FLAG
#define CRM_LICK_STABLE_FLAG
Definition: at32f413_crm.h:59
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
RTCAlarm_IRQn
@ RTCAlarm_IRQn
Definition: at32f413.h:175
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_BOTH_EDGE
@ EXINT_TRIGGER_BOTH_EDGE
Definition: at32f413_exint.h:95
EXINT_LINE_17
#define EXINT_LINE_17
Definition: at32f413_exint.h:69
ERROR
@ ERROR
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:61
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f413_pwc.c:213
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:189
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f413_pwc.h:107
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:97
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:115
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:197
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:161
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:67
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:207
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:138
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:187
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:82
RTC_TS_FLAG
#define RTC_TS_FLAG
Definition: at32f413_rtc.h:65
RTC_TA_INT
#define RTC_TA_INT
Definition: at32f413_rtc.h:53
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • power_voltage_monitor
  • inc
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • power_voltage_monitor
  • inc
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • power_voltage_monitor
  • inc
project/at_start_f413/examples/pwc/power_voltage_monitor/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • power_voltage_monitor
  • src
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • power_voltage_monitor
  • src
project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void PVM_IRQHandler(void)
144{
145 if(exint_flag_get(EXINT_LINE_16) != RESET)
146 {
147 /* clear exint line flag */
148 exint_flag_clear(EXINT_LINE_16);
149
150 /* toggle led */
151 at32_led_toggle(LED2);
152 at32_led_toggle(LED3);
153 at32_led_toggle(LED4);
154 }
155}
156
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:134
PVM_IRQHandler
void PVM_IRQHandler(void)
this function handles the power voltage monitoring output interrupt request.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:143
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/at32f413_int.c:116
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
EXINT_LINE_16
#define EXINT_LINE_16
Definition: at32f413_exint.h:68
RESET
@ RESET
Definition: at32f413.h:254
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • power_voltage_monitor
  • src
project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
30
45void pvm_exint_config(void)
46{
47 exint_init_type exint_init_struct;
48
49 /* config the exint line of the power voltage monitor */
50 exint_init_struct.line_select = EXINT_LINE_16;
51 exint_init_struct.line_enable = TRUE;
52 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
53 exint_init_struct.line_polarity = EXINT_TRIGGER_BOTH_EDGE;
54 exint_init(&exint_init_struct);
55}
56
62int main(void)
63{
64 __IO uint32_t index = 0;
65
66 /* congfig the system clock */
67 system_clock_config();
68
69 /* init at start board */
70 at32_board_init();
71
72 /* config priority group */
73 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
74
75 /* turn on the led light */
76 at32_led_on(LED2);
77 at32_led_on(LED3);
78 at32_led_on(LED4);
79
80 /* enable pwc clock */
81 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
82
83 /* set the threshold voltage to 2.9v */
84 pwc_pvm_level_select(PWC_PVM_VOLTAGE_2V9);
85
86 /* enable power voltage monitor */
87 pwc_power_voltage_monitor_enable(TRUE);
88
89 /* config the exint line of the power voltage monitor */
90 pvm_exint_config();
91
92 /* when power voltage monitor enable,exint line16 flag will be set */
93 while(exint_flag_get(EXINT_LINE_16) == RESET);
94
95 /* clear the unexpected exint line flag */
96 exint_flag_clear(EXINT_LINE_16);
97
98 /* clear the unexpected nvic pending flag */
99 NVIC_ClearPendingIRQ(PVM_IRQn);
100
101 /* enable power voltage monitor interrupt */
102 nvic_irq_enable(PVM_IRQn, 0, 0);
103
104 while(1)
105 {
106 }
107}
108
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
pvm_exint_config
void pvm_exint_config(void)
power voltage monitor exint configuration.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c:45
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/power_voltage_monitor/src/main.c:62
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
PVM_IRQn
@ PVM_IRQn
Definition: at32f413.h:134
exint_flag_get
flag_status exint_flag_get(uint32_t exint_line)
get exint flag
Definition: at32f413_exint.c:142
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_BOTH_EDGE
@ EXINT_TRIGGER_BOTH_EDGE
Definition: at32f413_exint.h:95
EXINT_LINE_16
#define EXINT_LINE_16
Definition: at32f413_exint.h:68
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_power_voltage_monitor_enable
void pwc_power_voltage_monitor_enable(confirm_state new_state)
enable or disable pwc power voltage monitor (pvm)
Definition: at32f413_pwc.c:90
pwc_pvm_level_select
void pwc_pvm_level_select(pwc_pvm_voltage_type pvm_voltage)
select the voltage threshold detected by the power voltage detector.
Definition: at32f413_pwc.c:79
PWC_PVM_VOLTAGE_2V9
@ PWC_PVM_VOLTAGE_2V9
Definition: at32f413_pwc.h:80
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • sleep_tmr2
  • inc
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • sleep_tmr2
  • inc
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • sleep_tmr2
  • inc
project/at_start_f413/examples/pwc/sleep_tmr2/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • sleep_tmr2
  • src
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • sleep_tmr2
  • src
project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
45void NMI_Handler(void)
46{
47}
48
54void HardFault_Handler(void)
55{
56 /* go to infinite loop when hard fault exception occurs */
57 while(1)
58 {
59 }
60}
61
67void MemManage_Handler(void)
68{
69 /* go to infinite loop when memory manage exception occurs */
70 while(1)
71 {
72 }
73}
74
80void BusFault_Handler(void)
81{
82 /* go to infinite loop when bus fault exception occurs */
83 while(1)
84 {
85 }
86}
87
93void UsageFault_Handler(void)
94{
95 /* go to infinite loop when usage fault exception occurs */
96 while(1)
97 {
98 }
99}
100
106void SVC_Handler(void)
107{
108}
109
115void DebugMon_Handler(void)
116{
117}
118
124void PendSV_Handler(void)
125{
126}
127
133void SysTick_Handler(void)
134{
135}
136
142void TMR2_GLOBAL_IRQHandler(void)
143{
144 if(tmr_flag_get(TMR2, TMR_OVF_FLAG) != RESET)
145 {
146 /* clear timer 2 ovf flag */
147 tmr_flag_clear(TMR2, TMR_OVF_FLAG);
148
149 /* toggle led */
150 at32_led_toggle(LED4);
151 }
152}
153
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:93
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:54
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:67
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:106
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles the timer interrupt request.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:142
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:124
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:45
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:80
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:133
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/at32f413_int.c:115
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
RESET
@ RESET
Definition: at32f413.h:254
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:52
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • sleep_tmr2
  • src
project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
30
45void tmr2_config(void)
46{
47 crm_clocks_freq_type crm_clocks_freq_struct = {0};
48
49 /* enable tmr 2 clock */
50 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
51
52 /* get system clock */
53 crm_clocks_freq_get(&crm_clocks_freq_struct);
54
55 /* (systemclock/(systemclock/10000))/10000 = 1Hz(1s) */
56 tmr_base_init(TMR2, 9999, (crm_clocks_freq_struct.sclk_freq/10000 - 1));
57
58 /* config the counting direction */
59 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
60
61 /* config the clock divider value */
62 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
63
64 /* enable tmr 2 interrupt */
65 tmr_interrupt_enable(TMR2, TMR_OVF_INT, TRUE);
66
67 /* config tmr 2 nvic */
68 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
69
70 /* enable tmr 2 */
71 tmr_counter_enable(TMR2, TRUE);
72}
73
79int main(void)
80{
81 __IO uint32_t index = 0;
82 __IO uint32_t systick_index = 0;
83
84 /* congfig the system clock */
85 system_clock_config();
86
87 /* init at start board */
88 at32_board_init();
89
90 /* config priority group */
91 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
92
93 /* turn on the led light */
94 at32_led_on(LED2);
95 at32_led_on(LED3);
96 at32_led_on(LED4);
97
98 /* enable pwc clock */
99 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
100
101 /* config tmr 2 */
102 tmr2_config();
103
104 while(1)
105 {
106 at32_led_off(LED2);
107
108 /* save systick register configuration */
109 systick_index = SysTick->CTRL;
110 systick_index &= ~((uint32_t)0xFFFFFFFE);
111
112 /* disable systick */
113 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
114
115 /* enter sleep mode */
116 pwc_sleep_mode_enter(PWC_SLEEP_ENTER_WFI);
117
118 /* restore systick register configuration */
119 SysTick->CTRL |= systick_index;
120
121 /* wake up from sleep mode */
122 at32_led_on(LED2);
123 for(index = 0; index < 500000; index++);
124 }
125}
126
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/debug/tmr1/src/main.c:39
tmr2_config
void tmr2_config(void)
tmr2 configuration.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c:45
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/sleep_tmr2/src/main.c:79
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:162
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f413_pwc.c:166
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:88
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:74
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • sleep_usart1
  • inc
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • sleep_usart1
  • inc
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • sleep_usart1
  • inc
project/at_start_f413/examples/pwc/sleep_usart1/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • sleep_usart1
  • src
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • sleep_usart1
  • src
project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31
41uint16_t usart1_index = 0;
47void NMI_Handler(void)
48{
49}
50
56void HardFault_Handler(void)
57{
58 /* go to infinite loop when hard fault exception occurs */
59 while(1)
60 {
61 }
62}
63
69void MemManage_Handler(void)
70{
71 /* go to infinite loop when memory manage exception occurs */
72 while(1)
73 {
74 }
75}
76
82void BusFault_Handler(void)
83{
84 /* go to infinite loop when bus fault exception occurs */
85 while(1)
86 {
87 }
88}
89
95void UsageFault_Handler(void)
96{
97 /* go to infinite loop when usage fault exception occurs */
98 while(1)
99 {
100 }
101}
102
108void SVC_Handler(void)
109{
110}
111
117void DebugMon_Handler(void)
118{
119}
120
126void PendSV_Handler(void)
127{
128}
129
135void SysTick_Handler(void)
136{
137}
138
144void USART1_IRQHandler(void)
145{
146 if(usart_flag_get(USART1, USART_RDBF_FLAG) != RESET)
147 {
148 /* clear rdbf flag */
149 usart1_index = usart_data_receive(USART1);
150
151 /* toggle led */
152 at32_led_toggle(LED4);
153 }
154}
155
156
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:95
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:56
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:69
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:108
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:126
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:47
USART1_IRQHandler
void USART1_IRQHandler(void)
this function handles the usatt interrupt request.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:144
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:82
usart1_index
uint16_t usart1_index
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:41
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:135
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/at32f413_int.c:117
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
RESET
@ RESET
Definition: at32f413.h:254
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART1
#define USART1
Definition: at32f413_usart.h:319
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • sleep_usart1
  • src
project/at_start_f413/examples/pwc/sleep_usart1/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
43void usart1_config(uint32_t baudrate)
44{
45 gpio_init_type gpio_init_struct;
46
47 /* enable the uart1 and gpio clock */
48 crm_periph_clock_enable(CRM_USART1_PERIPH_CLOCK, TRUE);
49 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
50
51 gpio_default_para_init(&gpio_init_struct);
52
53 /* configure the uart1 tx pin */
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
58 gpio_init_struct.gpio_pins = GPIO_PINS_9;
59 gpio_init(GPIOA, &gpio_init_struct);
60
61 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
62 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
63 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
64 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
65 gpio_init_struct.gpio_pins = GPIO_PINS_10;
66 gpio_init(GPIOA, &gpio_init_struct);
67
68 /* configure uart param */
69 nvic_irq_enable(USART1_IRQn, 0, 0);
70
71 usart_init(USART1, baudrate, USART_DATA_8BITS, USART_STOP_1_BIT);
72 usart_parity_selection_config(USART1, USART_PARITY_NONE);
73 usart_transmitter_enable(USART1, TRUE);
74 usart_receiver_enable(USART1, TRUE);
75 usart_hardware_flow_control_set(USART1,USART_HARDWARE_FLOW_NONE);
76 usart_interrupt_enable(USART1, USART_RDBF_INT, TRUE);
77 usart_enable(USART1, TRUE);
78}
79
85int main(void)
86{
87 __IO uint32_t index = 0;
88 __IO uint32_t systick_index = 0;
89
90 /* congfig the system clock */
91 system_clock_config();
92
93 /* init at start board */
94 at32_board_init();
95
96 /* config priority group */
97 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
98
99 /* turn on the led light */
100 at32_led_on(LED2);
101 at32_led_on(LED3);
102 at32_led_on(LED4);
103
104 /* enable pwc clock */
105 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
106
107 /* config usart1 */
108 usart1_config(115200);
109
110 printf("exit sleep mode by usart1 rdbf interrupt \r\n");
111
112 while(1)
113 {
114 at32_led_off(LED2);
115 at32_led_off(LED3);
116 printf("now enter sleep mode \r\n");
117
118 /* save systick register configuration */
119 systick_index = SysTick->CTRL;
120 systick_index &= ~((uint32_t)0xFFFFFFFE);
121
122 /* disable systick */
123 SysTick->CTRL &= (uint32_t)0xFFFFFFFE;
124
125 /* enter sleep mode */
126 pwc_sleep_mode_enter(PWC_SLEEP_ENTER_WFI);
127
128 /* restore systick register configuration */
129 SysTick->CTRL |= systick_index;
130
131 /* wake up from sleep mode */
132 printf("now exit sleep mode by usart1 rdbf interrupt \r\n");
133
134 at32_led_on(LED2);
135 for(index = 0; index < 500000; index++);
136 }
137}
138
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/main.c:85
usart1_config
void usart1_config(uint32_t baudrate)
usart1 configuration.
Definition: project/at_start_f413/examples/pwc/sleep_usart1/src/main.c:43
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART1_PERIPH_CLOCK
@ CRM_USART1_PERIPH_CLOCK
Definition: at32f413_crm.h:120
USART1_IRQn
@ USART1_IRQn
Definition: at32f413.h:171
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_sleep_mode_enter
void pwc_sleep_mode_enter(pwc_sleep_enter_type pwc_sleep_enter)
enter pwc sleep mode
Definition: at32f413_pwc.c:166
PWC_SLEEP_ENTER_WFI
@ PWC_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:88
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:138
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f413_usart.c:516
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
USART_HARDWARE_FLOW_NONE
@ USART_HARDWARE_FLOW_NONE
Definition: at32f413_usart.h:169
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:94
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART1
#define USART1
Definition: at32f413_usart.h:319
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • standby_rtc
  • inc
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • standby_rtc
  • inc
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • standby_rtc
  • inc
project/at_start_f413/examples/pwc/standby_rtc/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • standby_rtc
  • src
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • standby_rtc
  • src
project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/at32f413_int.c:116
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • standby_rtc
  • src
project/at_start_f413/examples/pwc/standby_rtc/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30
31
46void rtc_config(void)
47{
48 /* enable the battery-powered domain write operations */
49 pwc_battery_powered_domain_access(TRUE);
50
51 /* reset battery-powered domain register */
52 bpr_reset();
53
54 /* enable the lick */
55 crm_clock_source_enable(CRM_CLOCK_SOURCE_LICK, TRUE);
56
57 /* wait lick is ready */
58 while(crm_flag_get(CRM_LICK_STABLE_FLAG) == RESET);
59
60 /* select the rtc clock source */
61 crm_rtc_clock_select(CRM_RTC_CLOCK_LICK);
62
63 /* enable rtc clock */
64 crm_rtc_clock_enable(TRUE);
65
66 /* wait for rtc registers update */
67 rtc_wait_update_finish();
68
69 /* set rtc divider: set rtc period to 1sec */
70 rtc_divider_set(32767);
71
72 /* wait for the register write to complete */
73 rtc_wait_config_finish();
74}
75
81void rtc_alarm_config(uint8_t alarm_time)
82{
83 /* clear second flag */
84 rtc_flag_clear(RTC_TS_FLAG);
85
86 /* wait for the second flag to be set */
87 while(rtc_flag_get(RTC_TS_FLAG) == RESET);
88
89 /* config the wakeup time */
90 rtc_alarm_set(rtc_counter_get() + alarm_time);
91
92 /* wait for the register write to complete */
93 rtc_wait_config_finish();
94}
95
101int main(void)
102{
103 __IO uint32_t index = 0;
104
105 /* congfig the system clock */
106 system_clock_config();
107
108 /* init at start board */
109 at32_board_init();
110
111 /* config priority group */
112 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
113
114 /* turn on the led light */
115 at32_led_off(LED2);
116 at32_led_off(LED3);
117 at32_led_off(LED4);
118
119 /* enable pwc and bpr clock */
120 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
121 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
122
123 if(pwc_flag_get(PWC_STANDBY_FLAG) != RESET)
124 {
125 /* wakeup from standby */
126 pwc_flag_clear(PWC_STANDBY_FLAG);
127 at32_led_on(LED2);
128 }
129
130 if(pwc_flag_get(PWC_WAKEUP_FLAG) != RESET)
131 {
132 /* wakeup event occurs */
133 pwc_flag_clear(PWC_WAKEUP_FLAG);
134 at32_led_on(LED3);
135 }
136
137 /* config rtc */
138 rtc_config();
139
140 at32_led_on(LED4);
141
142 for(index = 0; index < 500000; index++);
143
144 /* set the wakeup time to 10 seconds */
145 rtc_alarm_config(10);
146
147 /* enter standby mode */
148 pwc_standby_mode_enter();
149
150 while(1)
151 {
152 }
153}
154
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
rtc_config
void rtc_config(void)
rtc configuration.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/main.c:46
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/main.c:101
rtc_alarm_config
void rtc_alarm_config(uint8_t alarm_time)
rtc alarm set.
Definition: project/at_start_f413/examples/pwc/standby_rtc/src/main.c:81
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:49
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:376
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:386
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:140
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:298
CRM_RTC_CLOCK_LICK
@ CRM_RTC_CLOCK_LICK
Definition: at32f413_crm.h:375
CRM_LICK_STABLE_FLAG
#define CRM_LICK_STABLE_FLAG
Definition: at32f413_crm.h:59
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:61
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:223
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f413_pwc.c:144
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f413_pwc.c:127
PWC_STANDBY_FLAG
#define PWC_STANDBY_FLAG
Definition: at32f413_pwc.h:53
PWC_WAKEUP_FLAG
#define PWC_WAKEUP_FLAG
Definition: at32f413_pwc.h:52
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:115
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:197
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:161
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:67
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:207
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:187
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:82
RTC_TS_FLAG
#define RTC_TS_FLAG
Definition: at32f413_rtc.h:65
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • pwc
  • standby_wakeup_pin
  • inc
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • pwc
  • standby_wakeup_pin
  • inc
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • pwc
  • standby_wakeup_pin
  • inc
project/at_start_f413/examples/pwc/standby_wakeup_pin/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • pwc
  • standby_wakeup_pin
  • src
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • pwc
  • standby_wakeup_pin
  • src
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • pwc
  • standby_wakeup_pin
  • src
project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30
44int main(void)
45{
46 __IO uint32_t index = 0;
47
48 /* congfig the system clock */
49 system_clock_config();
50
51 /* init at start board */
52 at32_board_init();
53
54 /* config priority group */
55 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
56
57 /* turn on the led light */
58 at32_led_off(LED2);
59 at32_led_off(LED3);
60 at32_led_off(LED4);
61
62 /* enable pwc clock */
63 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
64
65 if(pwc_flag_get(PWC_STANDBY_FLAG) != RESET)
66 {
67 /* wakeup from standby */
68 pwc_flag_clear(PWC_STANDBY_FLAG);
69 at32_led_on(LED2);
70 }
71
72 if(pwc_flag_get(PWC_WAKEUP_FLAG) != RESET)
73 {
74 /* wakeup event occurs */
75 pwc_flag_clear(PWC_WAKEUP_FLAG);
76 at32_led_on(LED3);
77 }
78
79 at32_led_on(LED4);
80 for(index = 0; index < 0xFFFFFF; index++);
81
82 /* enable wakeup pin - pa0 */
83 pwc_wakeup_pin_enable(PWC_WAKEUP_PIN_1, TRUE);
84
85 /* enter standby mode */
86 pwc_standby_mode_enter();
87 while(1)
88 {
89 }
90}
91
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/pwc/standby_wakeup_pin/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:223
pwc_flag_get
flag_status pwc_flag_get(uint32_t pwc_flag)
get flag of pwc
Definition: at32f413_pwc.c:144
pwc_flag_clear
void pwc_flag_clear(uint32_t pwc_flag)
clear flag of pwc
Definition: at32f413_pwc.c:127
pwc_wakeup_pin_enable
void pwc_wakeup_pin_enable(uint32_t pin_num, confirm_state new_state)
enable or disable pwc standby wakeup pin
Definition: at32f413_pwc.c:106
PWC_STANDBY_FLAG
#define PWC_STANDBY_FLAG
Definition: at32f413_pwc.h:53
PWC_WAKEUP_FLAG
#define PWC_WAKEUP_FLAG
Definition: at32f413_pwc.h:52
PWC_WAKEUP_PIN_1
#define PWC_WAKEUP_PIN_1
pwc wakeup pin num definition
Definition: at32f413_pwc.h:63
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • rtc
  • calendar
  • inc
project/at_start_f413/examples/rtc/calendar/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • rtc
  • calendar
  • inc
project/at_start_f413/examples/rtc/calendar/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • rtc
  • calendar
  • inc
project/at_start_f413/examples/rtc/calendar/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • rtc
  • calendar
  • src
project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • rtc
  • calendar
  • src
project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
136
142void RTC_IRQHandler(void)
143{
144 if(rtc_flag_get(RTC_TA_FLAG) != RESET)
145 {
146 at32_led_toggle(LED4);
147
148 /* clear the rtc second flag */
149 rtc_flag_clear(RTC_TA_FLAG);
150 }
151}
152
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:132
RTC_IRQHandler
void RTC_IRQHandler(void)
this function handles rtc handler.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:142
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/rtc/calendar/src/at32f413_int.c:114
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
RESET
@ RESET
Definition: at32f413.h:254
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:161
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:187
RTC_TA_FLAG
#define RTC_TA_FLAG
Definition: at32f413_rtc.h:66
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • rtc
  • calendar
  • src
project/at_start_f413/examples/rtc/calendar/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "rtc.h"
30
39char const weekday_table[7][10] = { "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"};
40
46void alarm_init(void)
47{
48 calendar_type alarm_struct;
49
50 /* clear alarm flag */
51 rtc_flag_clear(RTC_TA_FLAG);
52
53 /* wait for the register write to complete */
54 rtc_wait_config_finish();
55
56 /* configure and enable rtc interrupt */
57 nvic_irq_enable(RTC_IRQn, 0, 0);
58
59 /* enable alarm interrupt */
60 rtc_interrupt_enable(RTC_TA_INT, TRUE);
61
62 /* wait for the register write to complete */
63 rtc_wait_config_finish();
64
65 /* config alarm */
66
67 alarm_struct.year = 2021;
68 alarm_struct.month = 5;
69 alarm_struct.date = 1;
70 alarm_struct.hour = 12;
71 alarm_struct.min = 0;
72 alarm_struct.sec = 5;
73
74 rtc_alarm_clock_set(&alarm_struct);
75}
76
82int main(void)
83{
84 calendar_type time_struct;
85
86 /* config nvic priority group */
87 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
88
89 system_clock_config();
90
91 at32_board_init();
92
93 uart_print_init(115200);
94
95 /* config calendar */
96 time_struct.year = 2021;
97 time_struct.month = 5;
98 time_struct.date = 1;
99 time_struct.hour = 12;
100 time_struct.min = 0;
101 time_struct.sec = 0;
102 rtc_init(&time_struct);
103
104 /* config alarm */
105 alarm_init();
106
107 printf("initial ok\r\n");
108
109 while(1)
110 {
111 if(rtc_flag_get(RTC_TS_FLAG) != RESET)
112 {
113 at32_led_toggle(LED3);
114
115 /* get time */
116 rtc_time_get();
117
118 /* print time */
119 printf("%d/%d/%d ", calendar.year, calendar.month, calendar.date);
120 printf("%02d:%02d:%02d %s\r\n", calendar.hour, calendar.min, calendar.sec, weekday_table[calendar.week]);
121
122 /* wait for the register write to complete */
123 rtc_wait_config_finish();
124
125 /* clear the rtc second flag */
126 rtc_flag_clear(RTC_TS_FLAG);
127
128 /* wait for the register write to complete */
129 rtc_wait_config_finish();
130 }
131 }
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
calendar
calendar_type calendar
Definition: rtc.c:37
main
int main(void)
main function.
Definition: project/at_start_f413/examples/rtc/calendar/src/main.c:82
weekday_table
char const weekday_table[7][10]
Definition: project/at_start_f413/examples/rtc/calendar/src/main.c:39
alarm_init
void alarm_init(void)
init alarm.
Definition: project/at_start_f413/examples/rtc/calendar/src/main.c:46
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
RTC_IRQn
@ RTC_IRQn
Definition: at32f413.h:136
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
rtc_time_get
void rtc_time_get(void)
get current time.
Definition: rtc.c:309
rtc_init
uint8_t rtc_init(calendar_type *calendar)
rtc peripheral initialization.
Definition: rtc.c:51
rtc_alarm_clock_set
uint8_t rtc_alarm_clock_set(calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:217
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:197
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:161
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:138
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:187
RTC_TA_FLAG
#define RTC_TA_FLAG
Definition: at32f413_rtc.h:66
RTC_TS_FLAG
#define RTC_TS_FLAG
Definition: at32f413_rtc.h:65
RTC_TA_INT
#define RTC_TA_INT
Definition: at32f413_rtc.h:53
rtc.h
this file provides template for calendar api.
calendar_type
Definition: rtc.h:49
calendar_type::hour
__IO uint8_t hour
Definition: rtc.h:53
calendar_type::month
__IO uint8_t month
Definition: rtc.h:51
calendar_type::sec
__IO uint8_t sec
Definition: rtc.h:55
calendar_type::week
__IO uint8_t week
Definition: rtc.h:56
calendar_type::year
__IO uint16_t year
Definition: rtc.h:50
calendar_type::min
__IO uint8_t min
Definition: rtc.h:54
calendar_type::date
__IO uint8_t date
Definition: rtc.h:52
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • rtc
  • lick_calibration
  • inc
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • rtc
  • lick_calibration
  • inc
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • rtc
  • lick_calibration
  • inc
project/at_start_f413/examples/rtc/lick_calibration/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • rtc
  • lick_calibration
  • src
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • rtc
  • lick_calibration
  • src
project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30#include "stdio.h"
31
32extern uint32_t incrementvar_operationcomplete(void);
33extern uint32_t getvar_operationcomplete(void);
34extern void setvar_periodvalue(uint32_t Value);
35
36extern __IO uint32_t periodvalue;
37extern __IO uint32_t operationcomplete;
38
47uint16_t tmpCC4[2] = {0, 0};
48
54void NMI_Handler(void)
55{
56}
57
63void HardFault_Handler(void)
64{
65 /* go to infinite loop when hard fault exception occurs */
66 while(1)
67 {
68 }
69}
70
76void MemManage_Handler(void)
77{
78 /* go to infinite loop when memory manage exception occurs */
79 while(1)
80 {
81 }
82}
83
89void BusFault_Handler(void)
90{
91 /* go to infinite loop when bus fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void UsageFault_Handler(void)
103{
104 /* go to infinite loop when usage fault exception occurs */
105 while(1)
106 {
107 }
108}
109
115void SVC_Handler(void)
116{
117}
118
124void DebugMon_Handler(void)
125{
126}
127
133void PendSV_Handler(void)
134{
135}
136
142void SysTick_Handler(void)
143{
144}
145
151void RTC_IRQHandler(void)
152{
153 if(rtc_flag_get(RTC_TS_FLAG) != RESET)
154 {
155 /* toggle led3 */
156 at32_led_toggle(LED3);
157
158 /* clear interrupt pending bit */
159 rtc_flag_clear(RTC_TS_FLAG);
160
161 printf("%d\r\n", rtc_counter_get());
162 }
163}
164
170void TMR5_GLOBAL_IRQHandler(void)
171{
172 uint32_t tmp = 0;
173
174 if(tmr_flag_get(TMR5, TMR_C4_FLAG) == SET)
175 {
176 tmpCC4[incrementvar_operationcomplete()] = (uint16_t)(TMR5->c4dt);
177
178 tmr_flag_get(TMR5, TMR_C4_FLAG);
179
180 if(getvar_operationcomplete() >= 2)
181 {
182 /* compute the period length */
183 tmp = (uint16_t)(tmpCC4[1] - tmpCC4[0] + 1);
184 setvar_periodvalue(tmp);
185
186 /* disable the interrupt */
187 tmr_interrupt_enable(TMR5, TMR_C4_INT, FALSE);
188 tmr_counter_enable(TMR5, FALSE);
189 }
190 }
191}
192
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
operationcomplete
__IO uint32_t operationcomplete
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:41
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:102
setvar_periodvalue
void setvar_periodvalue(uint32_t Value)
sets the periodvalue variable with input parameter.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:140
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:63
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:76
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:115
incrementvar_operationcomplete
uint32_t incrementvar_operationcomplete(void)
increments operationcomplete variable and return its value before increment operation.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:118
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:133
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:54
periodvalue
__IO uint32_t periodvalue
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:39
tmpCC4
uint16_t tmpCC4[2]
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:47
getvar_operationcomplete
uint32_t getvar_operationcomplete(void)
returns operationcomplete value.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:130
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:89
TMR5_GLOBAL_IRQHandler
void TMR5_GLOBAL_IRQHandler(void)
this function handles tmr5 global interrupt request.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:170
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:142
RTC_IRQHandler
void RTC_IRQHandler(void)
this function handles rtc global interrupt request.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:151
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/at32f413_int.c:124
LED3
@ LED3
Definition: at32f413_board.h:64
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
FALSE
@ FALSE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
rtc_flag_get
flag_status rtc_flag_get(uint16_t flag)
rtc flag get
Definition: at32f413_rtc.c:161
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:67
rtc_flag_clear
void rtc_flag_clear(uint16_t flag)
rtc flag clear
Definition: at32f413_rtc.c:187
RTC_TS_FLAG
#define RTC_TS_FLAG
Definition: at32f413_rtc.h:65
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:56
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:78
TMR5
#define TMR5
Definition: at32f413_tmr.h:836
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • rtc
  • lick_calibration
  • src
project/at_start_f413/examples/rtc/lick_calibration/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 crm_clocks_freq_type crm_clocks;
39__IO uint32_t periodvalue = 0;
40__IO uint32_t lickfreq = 0;
41__IO uint32_t operationcomplete = 0;
42
48void nvic_configuration(void)
49{
50 /* configure one bit for preemption priority */
51 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
52
53 /* enable the rtc interrupt */
54 nvic_irq_enable(RTC_IRQn, 0, 0);
55
56 /* enable the tmr5 interrupt */
57 nvic_irq_enable(TMR5_GLOBAL_IRQn, 0, 0);
58}
59
65void rtc_configuration(void)
66{
67 /* enable pwc and bpr clocks */
68 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
69 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
70
71 /* allow access to bpr domain */
72 pwc_battery_powered_domain_access(TRUE);
73
74 /* reset backup domain */
75 bpr_reset();
76
77 /* enable the lick osc */
78 crm_clock_source_enable(CRM_CLOCK_SOURCE_LICK, TRUE);
79 /* wait till lick is ready */
80 while(crm_flag_get(CRM_LICK_STABLE_FLAG) == RESET);
81 /* select the rtc clock source */
82 crm_rtc_clock_select(CRM_RTC_CLOCK_LICK);
83
84 /* enable rtc clock */
85 crm_rtc_clock_enable(TRUE);
86
87 /* wait for rtc registers update */
88 rtc_wait_update_finish();
89
90 /* wait for the register write to complete */
91 rtc_wait_config_finish();
92
93 /* enable the rtc second */
94 rtc_interrupt_enable(RTC_TS_INT, TRUE);
95
96 /* wait for the register write to complete */
97 rtc_wait_config_finish();
98
99 /* set rtc divider: set rtc period to 1sec */
100 rtc_divider_set(40000);
101
102 /* wait for the register write to complete */
103 rtc_wait_config_finish();
104
105 /* tamper pin disabled */
106 bpr_tamper_pin_enable(FALSE);
107
108 /* enable the rtc second output on tamper pin */
109 bpr_rtc_output_select(BPR_RTC_OUTPUT_SECOND);
110}
111
118uint32_t incrementvar_operationcomplete(void)
119{
120 operationcomplete++;
121
122 return (uint32_t)(operationcomplete - 1);
123}
124
130uint32_t getvar_operationcomplete(void)
131{
132 return (uint32_t)operationcomplete;
133}
134
140void setvar_periodvalue(uint32_t value)
141{
142 periodvalue = (uint32_t)(value);
143}
144
150int main(void)
151{
152 tmr_input_config_type tmr_ic_init_structure;
153
154 system_clock_config();
155
156 at32_board_init();
157
158 uart_print_init(115200);
159
160 /* rtc configuration */
161 rtc_configuration();
162
163 printf("\r\n\nstart calib\r\n\r\n");
164
165 /* get the frequency value */
166 crm_clocks_freq_get(&crm_clocks);
167
168 /* enable tmr5 apb1 clocks */
169 crm_periph_clock_enable(CRM_TMR5_PERIPH_CLOCK, TRUE);
170 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
171
172 /* connect internally the tm5_ch4 input capture to the lick clock output */
173 gpio_pin_remap_config(TMR5CH4_MUX, TRUE);
174
175 /* tmr5 time base configuration */
176 tmr_base_init(TMR5, 0xFFFF, 0);
177 tmr_cnt_dir_set(TMR5, TMR_COUNT_UP);
178 tmr_clock_source_div_set(TMR5, TMR_CLOCK_DIV1);
179
180 /* tmr5 channel4 input capture mode configuration */
181 tmr_input_default_para_init(&tmr_ic_init_structure);
182 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_4;
183 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
184 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
185 tmr_ic_init_structure.input_filter_value = 0;
186 tmr_input_channel_init(TMR5, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
187
188 /* reinitialize the index for the interrupt */
189 operationcomplete = 0;
190
191 /* enable the tmr5 input capture counter */
192 tmr_counter_enable(TMR5, TRUE);
193
194 /* Reset all tmr5 flags */
195 tmr_flag_get(TMR5, TMR_C4_FLAG);
196
197 /* enable the tmr5 channel 4 */
198 tmr_interrupt_enable(TMR5, TMR_C4_INT, TRUE);
199
200 /* nvic configuration */
201 nvic_configuration();
202
203 /* wait the tmr5 measuring operation to be completed */
204 while(operationcomplete != 2);
205
206 /* compute the actual frequency of the lick. (tim5_clk = 1 * pclk1) */
207 if(periodvalue != 0)
208 {
209 lickfreq = (uint32_t)((uint32_t)(crm_clocks.apb1_freq * 2) / (uint32_t)periodvalue);
210 }
211
212 printf("apb1_freq = %d\r\n", crm_clocks.apb1_freq);
213 printf("period_value = %d\r\n", periodvalue);
214 printf("lick_freq = %d\r\n", lickfreq);
215
216 /* adjust the rtc prescaler value */
217 rtc_divider_set((lickfreq - 1));
218
219 /* wait for the register write to complete */
220 rtc_wait_config_finish();
221
222 /* turn on led2 */
223 at32_led_on(LED2);
224
225 while(1)
226 {
227 }
228}
229
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
operationcomplete
__IO uint32_t operationcomplete
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:41
setvar_periodvalue
void setvar_periodvalue(uint32_t value)
sets the periodvalue variable with input parameter.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:140
incrementvar_operationcomplete
uint32_t incrementvar_operationcomplete(void)
increments operationcomplete variable and return its value before increment operation.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:118
lickfreq
__IO uint32_t lickfreq
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:40
periodvalue
__IO uint32_t periodvalue
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:39
nvic_configuration
void nvic_configuration(void)
configures the nested vectored interrupt controller.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:48
getvar_operationcomplete
uint32_t getvar_operationcomplete(void)
returns operationcomplete value.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:130
main
int main(void)
main function.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:150
crm_clocks
crm_clocks_freq_type crm_clocks
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:38
rtc_configuration
void rtc_configuration(void)
configures the rtc.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:65
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:39
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:49
bpr_tamper_pin_enable
void bpr_tamper_pin_enable(confirm_state new_state)
enable or disable bpr tamper pin
Definition: at32f413_bpr.c:176
bpr_rtc_output_select
void bpr_rtc_output_select(bpr_rtc_output_type output_source)
select bpr rtc output
Definition: at32f413_bpr.c:151
BPR_RTC_OUTPUT_SECOND
@ BPR_RTC_OUTPUT_SECOND
Definition: at32f413_bpr.h:120
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:376
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:386
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:140
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_TMR5_PERIPH_CLOCK
@ CRM_TMR5_PERIPH_CLOCK
Definition: at32f413_crm.h:129
CRM_CLOCK_SOURCE_LICK
@ CRM_CLOCK_SOURCE_LICK
Definition: at32f413_crm.h:298
CRM_RTC_CLOCK_LICK
@ CRM_RTC_CLOCK_LICK
Definition: at32f413_crm.h:375
CRM_LICK_STABLE_FLAG
#define CRM_LICK_STABLE_FLAG
Definition: at32f413_crm.h:59
TMR5_GLOBAL_IRQn
@ TMR5_GLOBAL_IRQn
Definition: at32f413.h:182
RTC_IRQn
@ RTC_IRQn
Definition: at32f413.h:136
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
TMR5CH4_MUX
#define TMR5CH4_MUX
Definition: at32f413_gpio.h:93
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:61
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:197
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:207
rtc_interrupt_enable
void rtc_interrupt_enable(uint16_t source, confirm_state new_state)
rtc interrupt enable
Definition: at32f413_rtc.c:138
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:82
RTC_TS_INT
#define RTC_TS_INT
Definition: at32f413_rtc.h:52
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:807
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:139
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:239
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:249
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:56
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:78
TMR5
#define TMR5
Definition: at32f413_tmr.h:836
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:475
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:416
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • sdio
  • sd_mmc_card
  • inc
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • sdio
  • sd_mmc_card
  • inc
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • sdio
  • sd_mmc_card
  • inc
project/at_start_f413/examples/sdio/sd_mmc_card/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • sdio
  • sd_mmc_card
  • src
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • sdio
  • sd_mmc_card
  • src
project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • sdio
  • sd_mmc_card
  • src
project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c
Go to the documentation of this file.
1
27#include <stdbool.h>
28#include <string.h>
29#include "at32_sdio.h"
30#include "at32f413_board.h"
31#include "at32f413_clock.h"
32
41#define BLOCK_SIZE (512)
42#define BLOCKS_NUMBER (8)
43#define MULTI_BUFFER_SIZE (BLOCK_SIZE * BLOCKS_NUMBER)
44#define STREAM_BUFFER_SIZE (1024)
45
46static uint8_t sblock_tbuffer[BLOCK_SIZE], sblock_rbuffer[BLOCK_SIZE];
47static uint8_t mblock_tbuffer[MULTI_BUFFER_SIZE], mblock_rbuffer[MULTI_BUFFER_SIZE];
48static uint8_t stream_tbuffer[STREAM_BUFFER_SIZE], stream_rbuffer[STREAM_BUFFER_SIZE];
49
50static error_status sd_single_block_test(void);
51static error_status sd_multiple_blocks_test(void);
52uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
53static void sd_test_error(void);
54static void nvic_configuration(void);
55
62static error_status sd_single_block_test(void)
63{
64 sd_error_status_type status = SD_OK;
65 uint8_t bus_width;
66
67 /* test 1-bit and 4-bit width */
68 for(bus_width = 0; bus_width < 2; bus_width++)
69 {
70 memset(sblock_tbuffer, bus_width + 0xAB, BLOCK_SIZE);
71 memset(sblock_rbuffer, 0, BLOCK_SIZE);
72
73 /* set data width */
74 status = sd_wide_bus_operation_config((sdio_bus_width_type)bus_width);
75 if(status != SD_OK)
76 {
77 return ERROR;
78 }
79
80 /* write block of 512 bytes on address 0 */
81 status = sd_block_write(sblock_tbuffer, 0x00, BLOCK_SIZE);
82 if(status != SD_OK)
83 {
84 return ERROR;
85 }
86
87 /* read block of 512 bytes from address 0 */
88 status = sd_block_read(sblock_rbuffer, 0x00, BLOCK_SIZE);
89 if(status != SD_OK)
90 {
91 return ERROR;
92 }
93
94 if(!buffer_compare(sblock_tbuffer, sblock_rbuffer, BLOCK_SIZE))
95 {
96 return ERROR;
97 }
98 }
99
100 return SUCCESS;
101}
102
109static error_status sd_multiple_blocks_test(void)
110{
111 sd_error_status_type status = SD_OK;
112 uint8_t bus_width;
113
114 /* test 1-bit and 4-bit width */
115 for(bus_width = 0; bus_width < 2; bus_width++)
116 {
117 memset(mblock_tbuffer, bus_width + 0x3C, MULTI_BUFFER_SIZE);
118 memset(mblock_rbuffer, 0, MULTI_BUFFER_SIZE);
119
120 /* set data width */
121 status = sd_wide_bus_operation_config((sdio_bus_width_type)bus_width);
122 if(status != SD_OK)
123 {
124 return ERROR;
125 }
126
127 /* write multiple block of many bytes on address 0 */
128 status = sd_mult_blocks_write(mblock_tbuffer, 0x00, BLOCK_SIZE, BLOCKS_NUMBER);
129 if(status != SD_OK)
130 {
131 return ERROR;
132 }
133
134 /* read block of many bytes from address 0 */
135 status = sd_mult_blocks_read(mblock_rbuffer, 0x00, BLOCK_SIZE, BLOCKS_NUMBER);
136 if(status != SD_OK)
137 {
138 return ERROR;
139 }
140
141 /* check the correctness of written data */
142 if(!buffer_compare(mblock_tbuffer, mblock_rbuffer, MULTI_BUFFER_SIZE))
143 {
144 return ERROR;
145 }
146 }
147
148 return SUCCESS;
149}
150
157static error_status mmc_stream_test(void)
158{
159 sd_error_status_type status = SD_OK;
160 uint8_t bus_width;
161
162 /* only test 1-bit width */
163 for(bus_width = 0; bus_width < 1; bus_width++)
164 {
165 memset(stream_tbuffer, bus_width+0x5A, STREAM_BUFFER_SIZE);
166 memset(stream_rbuffer, 0, STREAM_BUFFER_SIZE);
167
168 /* set data width */
169 status = sd_wide_bus_operation_config((sdio_bus_width_type)bus_width);
170 if(status != SD_OK)
171 {
172 return ERROR;
173 }
174
175 /* write stream of many bytes on address 0 */
176 status = mmc_stream_write(stream_tbuffer, 0x00, STREAM_BUFFER_SIZE);
177 if (status != SD_OK)
178 {
179 return ERROR;
180 }
181
182 /* read stream of many bytes from address 0 */
183 status = mmc_stream_read(stream_rbuffer, 0x00, STREAM_BUFFER_SIZE);
184 if (status != SD_OK)
185 {
186 return ERROR;
187 }
188
189 /* check the correctness of written data */
190 if(!buffer_compare(stream_tbuffer, stream_rbuffer, STREAM_BUFFER_SIZE))
191 {
192 return ERROR;
193 }
194 }
195
196 return SUCCESS;
197}
198
206uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
207{
208 while(buffer_length--)
209 {
210 if(*pbuffer1 != *pbuffer2)
211 {
212 return 0;
213 }
214 pbuffer1++;
215 pbuffer2++;
216 }
217 return 1;
218}
219
225static void sd_test_error(void)
226{
227 at32_led_on(LED2);
228 delay_ms(300);
229 at32_led_off(LED2);
230 delay_ms(300);
231}
232
238static void nvic_configuration(void)
239{
240 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
241 nvic_irq_enable(SDIO1_IRQn, 0, 0);
242}
243
249void show_card_info(void)
250{
251 printf("---------------------\r\n");
252 switch(sd_card_info.card_type)
253 {
254 case SDIO_STD_CAPACITY_SD_CARD_V1_1: printf("card type: SDSC V1.1\r\n");break;
255 case SDIO_STD_CAPACITY_SD_CARD_V2_0: printf("card type: SDSC V2.0\r\n");break;
256 case SDIO_HIGH_CAPACITY_SD_CARD: printf("card type: SDHC V2.0\r\n");break;
257 case SDIO_MULTIMEDIA_CARD: printf("card type: MMC Card\r\n");break;
258 }
259 printf("card manufacturer_id: %d\r\n", sd_card_info.sd_cid_reg.manufacturer_id);
260 printf("card rca: 0x%X\r\n", sd_card_info.rca);
261 printf("card c_size = %u\r\n", sd_card_info.sd_csd_reg.device_size);
262 printf("card capacity: %uMB %uKB\r\n", (uint32_t)(sd_card_info.card_capacity>>20), (uint32_t)(sd_card_info.card_capacity>>10));
263 printf("card block_size: %d\r\n", sd_card_info.card_blk_size);
264 printf("---------------------\r\n");
265}
266
267/* gloable functions ---------------------------------------------------------*/
273int main(void)
274{
275 system_clock_config();
276
277 at32_board_init();
278
279 nvic_configuration();
280
281 uart_print_init(115200);
282 printf("start test..\r\n");
283
284 /* sdio init */
285 if(SD_OK != sd_init())
286 {
287 printf("sdio init fail\r\n");
288 while(1)
289 {
290 sd_test_error();
291 }
292 }
293 printf("sdio init ok\r\n");
294 show_card_info();
295
296 /* sd card single block test */
297 if(SUCCESS != sd_single_block_test())
298 {
299 printf("sd card single block test fail\r\n");
300 /* single block test fail, led2 fresh */
301 while(1)
302 {
303 sd_test_error();
304 }
305 }
306 printf("sd card single block test ok\r\n");
307
308 /* sd card multiple blocks test */
309 if(SUCCESS != sd_multiple_blocks_test())
310 {
311 printf("sd card multiple blocks test fail\r\n");
312 /* multiple blocks test fail, led2 fresh */
313 while(1)
314 {
315 sd_test_error();
316 }
317 }
318 printf("sd card multiple blocks test ok\r\n");
319
320 /* mmc card stream data transfer test */
321 if(sd_card_info.card_type == SDIO_MULTIMEDIA_CARD)
322 {
323 if(SUCCESS != mmc_stream_test())
324 {
325 printf("mmc card stream data test fail\r\n");
326 /* mmc card stream data test fail, led2 fresh */
327 while(1)
328 {
329 sd_test_error();
330 }
331 }
332 printf("mmc card stream data test ok\r\n");
333 }
334
335 /* all tests pass, led3 and led4 fresh */
336 while(1)
337 {
338 at32_led_toggle(LED3);
339 at32_led_toggle(LED4);
340 delay_ms(300);
341 }
342}
343
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:48
STREAM_BUFFER_SIZE
#define STREAM_BUFFER_SIZE
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:44
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:206
stream_tbuffer
static uint8_t stream_tbuffer[(1024)]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:48
sd_test_error
static void sd_test_error(void)
LED2 on off every 300ms for sd test failed.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:225
mmc_stream_test
static error_status mmc_stream_test(void)
mmc card data stream read/write test.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:157
BLOCKS_NUMBER
#define BLOCKS_NUMBER
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:42
sd_single_block_test
static error_status sd_single_block_test(void)
sd card single block read/write test.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:62
stream_rbuffer
static uint8_t stream_rbuffer[(1024)]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:48
sblock_rbuffer
static uint8_t sblock_rbuffer[(512)]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:46
sd_multiple_blocks_test
static error_status sd_multiple_blocks_test(void)
sd card multiple blocks read/write test.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:109
show_card_info
void show_card_info(void)
show sd/mmc card info.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:249
mblock_tbuffer
static uint8_t mblock_tbuffer[((512) *(8))]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:47
sblock_tbuffer
static uint8_t sblock_tbuffer[(512)]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:46
MULTI_BUFFER_SIZE
#define MULTI_BUFFER_SIZE
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:43
nvic_configuration
static void nvic_configuration(void)
configures sdio1 irq channel.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:238
main
int main(void)
main function.
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:273
BLOCK_SIZE
#define BLOCK_SIZE
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:41
mblock_rbuffer
static uint8_t mblock_rbuffer[((512) *(8))]
Definition: project/at_start_f413/examples/sdio/sd_mmc_card/src/main.c:47
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
SDIO1_IRQn
@ SDIO1_IRQn
Definition: at32f413.h:181
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:139
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1693
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1181
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1482
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1360
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1646
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1270
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sd_mmc_card/src/at32_sdio.c:736
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:74
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:119
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:206
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sd_mmc_card/inc/at32_sdio.h:204
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sd_mmc_card/inc/at32_sdio.h:205
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:207
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::rca
uint16_t rca
Definition: sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: sd_mmc_card/inc/at32_sdio.h:244
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: sd_mmc_card/inc/at32_sdio.h:171
sd_csd_struct_type::device_size
uint32_t device_size
Definition: sd_mmc_card/inc/at32_sdio.h:140
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • sdio
  • sdio_fatfs
  • inc
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • sdio
  • sdio_fatfs
  • inc
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • sdio
  • sdio_fatfs
  • inc
project/at_start_f413/examples/sdio/sdio_fatfs/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • sdio
  • sdio_fatfs
  • src
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • sdio
  • sdio_fatfs
  • src
project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • sdio
  • sdio_fatfs
  • src
project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c
Go to the documentation of this file.
1
27#include <stdbool.h>
28#include <string.h>
29#include "at32_sdio.h"
30#include "at32f413_board.h"
31#include "at32f413_clock.h"
32#include "ff.h"
33
42FATFS fs;
43FIL file;
44BYTE work[FF_MAX_SS];
45
46uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
47static void sd_test_error(void);
48static void nvic_configuration(void);
49
57uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
58{
59 while(buffer_length--)
60 {
61 if(*pbuffer1 != *pbuffer2)
62 {
63 return 0;
64 }
65 pbuffer1++;
66 pbuffer2++;
67 }
68 return 1;
69}
70
76static void sd_test_error(void)
77{
78 at32_led_on(LED2);
79 delay_ms(300);
80 at32_led_off(LED2);
81 delay_ms(300);
82}
83
89static void nvic_configuration(void)
90{
91 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
92 nvic_irq_enable(SDIO1_IRQn, 0, 0);
93}
94
101static error_status fatfs_test(void)
102{
103 FRESULT ret;
104 char filename[] = "1:/test1.txt";
105 const char wbuf[] = "this is my file for test fatfs!\r\n";
106 char rbuf[50];
107 UINT bytes_written = 0;
108 UINT bytes_read = 0;
109 DWORD fre_clust, fre_sect, tot_sect;
110 FATFS* pt_fs;
111
112 ret = f_mount(&fs, "1:", 1);
113 if(ret){
114 printf("fs mount err:%d.\r\n", ret);
115 if(ret == FR_NO_FILESYSTEM){
116 printf("create fatfs..\r\n");
117 ret = f_mkfs("1:", 0, work, sizeof(work));
118 if(ret){
119 printf("creates fatfs err:%d.\r\n", ret);
120 return ERROR;
121 }
122 else{
123 printf("creates fatfs ok.\r\n");
124 }
125 ret = f_mount(NULL, "1:", 1);
126 ret = f_mount(&fs, "1:", 1);
127 if(ret){
128 printf("fs mount err:%d.\r\n", ret);
129 return ERROR;
130 }
131 else{
132 printf("fs mount ok.\r\n");
133 }
134 }
135 else{
136 return ERROR;
137 }
138 }
139 else{
140 printf("fs mount ok.\r\n");
141 }
142
143 ret = f_open(&file, filename, FA_READ | FA_WRITE | FA_CREATE_ALWAYS);
144 if(ret){
145 printf("open file err:%d.\r\n", ret);
146 }
147 else{
148 printf("open file ok.\r\n");
149 }
150 ret = f_write(&file, wbuf, sizeof(wbuf), &bytes_written);
151 if(ret){
152 printf("write file err:%d.\r\n", ret);
153 }
154 else{
155 printf("write file ok, byte:%u.\r\n", bytes_written);
156 }
157 f_lseek(&file, 0);
158 ret = f_read(&file, rbuf, sizeof(rbuf), &bytes_read);
159 if(ret){
160 printf("read file err:%d.\r\n", ret);
161 }
162 else{
163 printf("read file ok, byte:%u.\r\n", bytes_read);
164 }
165 ret = f_close(&file);
166 if(ret){
167 printf("close file err:%d.\r\n", ret);
168 }
169 else{
170 printf("close file ok.\r\n");
171 }
172
173 pt_fs = &fs;
174 /* get volume information and free clusters of drive 1 */
175 ret = f_getfree("1:", &fre_clust, &pt_fs);
176 if(ret == FR_OK)
177 {
178 /* get total sectors and free sectors */
179 tot_sect = (pt_fs->n_fatent - 2) * pt_fs->csize;
180 fre_sect = fre_clust * pt_fs->csize;
181
182 /* print the free space (assuming 512 bytes/sector) */
183 printf("%10u KiB total drive space.\r\n%10u KiB available.\r\n", tot_sect / 2, fre_sect / 2);
184 }
185
186 ret = f_mount(NULL, "1:", 1);
187
188 if(1 == buffer_compare((uint8_t*)rbuf, (uint8_t*)wbuf, sizeof(wbuf))){
189 printf("r/w file data test ok.\r\n");
190 }
191 else{
192 printf("r/w file data test fail.\r\n");
193 return ERROR;
194 }
195
196 return SUCCESS;
197}
198
199/* gloable functions ---------------------------------------------------------*/
205int main(void)
206{
207 system_clock_config();
208
209 at32_board_init();
210
211 nvic_configuration();
212
213 uart_print_init(115200);
214 printf("start test fatfs r0.14b..\r\n");
215
216 if(SUCCESS != fatfs_test())
217 {
218 while(1)
219 {
220 sd_test_error();
221 }
222 }
223
224 /* all tests pass, led3 and led4 fresh */
225 while(1)
226 {
227 at32_led_toggle(LED3);
228 at32_led_toggle(LED4);
229 delay_ms(300);
230 }
231}
232
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
FF_MAX_SS
#define FF_MAX_SS
Definition: ffconf.h:197
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:57
file
FIL file
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:43
sd_test_error
static void sd_test_error(void)
led2 on off every 300ms for sd test failed.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:76
work
BYTE work[FF_MAX_SS]
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:44
nvic_configuration
static void nvic_configuration(void)
configures sdio1 irq channel.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:89
main
int main(void)
main function.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:205
fatfs_test
static error_status fatfs_test(void)
fatfs file read/write test.
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:101
fs
FATFS fs
Definition: project/at_start_f413/examples/sdio/sdio_fatfs/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
SDIO1_IRQn
@ SDIO1_IRQn
Definition: at32f413.h:181
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • crc_transfer_polling
  • inc
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • crc_transfer_polling
  • inc
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • crc_transfer_polling
  • inc
project/at_start_f413/examples/spi/crc_transfer_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • crc_transfer_polling
  • src
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • crc_transfer_polling
  • src
project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • crc_transfer_polling
  • src
project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30
39#define BUFFER_SIZE 32
40
41uint16_t spi1_tx_buffer[BUFFER_SIZE] = {0x0102, 0x0304, 0x0506, 0x0708, 0x090A, 0x0B0C, 0x0D0E, 0x0F10,
42 0x1112, 0x1314, 0x1516, 0x1718, 0x191A, 0x1B1C, 0x1D1E, 0x1F20,
43 0x2122, 0x2324, 0x2526, 0x2728, 0x292A, 0x2B2C, 0x2D2E, 0x2F30,
44 0x3132, 0x3334, 0x3536, 0x3738, 0x393A, 0x3B3C, 0x3D3E, 0x3F40};
45uint16_t spi2_tx_buffer[BUFFER_SIZE] = {0x5152, 0x5354, 0x5556, 0x5758, 0x595A, 0x5B5C, 0x5D5E, 0x5F60,
46 0x6162, 0x6364, 0x6566, 0x6768, 0x696A, 0x6B6C, 0x6D6E, 0x6F70,
47 0x7172, 0x7374, 0x7576, 0x7778, 0x797A, 0x7B7C, 0x7D7E, 0x7F80,
48 0x8182, 0x8384, 0x8586, 0x8788, 0x898A, 0x8B8C, 0x8D8E, 0x8F90};
49uint16_t spi1_rx_buffer[BUFFER_SIZE], spi2_rx_buffer[BUFFER_SIZE];
50uint32_t tx_index = 0, rx_index = 0;
51__IO uint16_t crc1_value = 0, crc2_value = 0;
52volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
53
54static void gpio_config(void);
55static void spi_config(void);
56 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length);
57
64 error_status buffer_compare(uint16_t* pbuffer1, uint16_t* pbuffer2, uint16_t buffer_length)
65{
66 while(buffer_length--)
67 {
68 if(*pbuffer1 != *pbuffer2)
69 {
70 return ERROR;
71 }
72 pbuffer1++;
73 pbuffer2++;
74 }
75 return SUCCESS;
76}
77
83static void spi_config(void)
84{
85 spi_init_type spi_init_struct;
86 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
87 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
88 spi_default_para_init(&spi_init_struct);
89 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
90 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
91 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
92 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
93 spi_init_struct.frame_bit_num = SPI_FRAME_16BIT;
94 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
95 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
96 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
97 spi_init(SPI1, &spi_init_struct);
98
99 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
100 spi_init(SPI2, &spi_init_struct);
101
102 spi_crc_polynomial_set(SPI1, 7);
103 spi_crc_polynomial_set(SPI2, 7);
104 spi_crc_enable(SPI1, TRUE);
105 spi_crc_enable(SPI2, TRUE);
106 spi_enable(SPI1, TRUE);
107 spi_enable(SPI2, TRUE);
108}
109
115static void gpio_config(void)
116{
117 gpio_init_type gpio_initstructure;
118 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
119 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
120
121 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
122 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
123 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
124 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
125 gpio_initstructure.gpio_pins = GPIO_PINS_5;
126 gpio_init(GPIOA, &gpio_initstructure);
127
128 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
129 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
130 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
131 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
132 gpio_initstructure.gpio_pins = GPIO_PINS_6;
133 gpio_init(GPIOA, &gpio_initstructure);
134
135 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
136 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
137 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
138 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
139 gpio_initstructure.gpio_pins = GPIO_PINS_7;
140 gpio_init(GPIOA, &gpio_initstructure);
141
142 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
143 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
144 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
145 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
146 gpio_initstructure.gpio_pins = GPIO_PINS_13;
147 gpio_init(GPIOB, &gpio_initstructure);
148
149 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
150 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
151 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
152 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
153 gpio_initstructure.gpio_pins = GPIO_PINS_14;
154 gpio_init(GPIOB, &gpio_initstructure);
155
156 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
157 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
158 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
159 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
160 gpio_initstructure.gpio_pins = GPIO_PINS_15;
161 gpio_init(GPIOB, &gpio_initstructure);
162}
163
169int main(void)
170{
171 system_clock_config();
172 at32_board_init();
173 gpio_config();
174 spi_config();
175
176 /* transfer procedure:the "BUFFER_SIZE-1" data transfer */
177 while(tx_index < BUFFER_SIZE - 1)
178 {
179 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
180 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index]);
181 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
182 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
183 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
184 spi2_rx_buffer[rx_index] = spi_i2s_data_receive(SPI2);
185 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
186 spi1_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI1);
187 }
188 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
189 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
190
191 /* transfer procedure:the last data and crc transfer */
192 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index]);
193 spi_crc_next_transmit(SPI2);
194 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index]);
195 spi_crc_next_transmit(SPI1);
196 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
197 spi1_rx_buffer[rx_index] = spi_i2s_data_receive(SPI1);
198 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
199 spi2_rx_buffer[rx_index] = spi_i2s_data_receive(SPI2);
200 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
201 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
202
203 /* test result:the data and crc check */
204 transfer_status1 = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
205 transfer_status2 = buffer_compare(spi1_rx_buffer, spi2_tx_buffer, BUFFER_SIZE);
206 if((spi_i2s_flag_get(SPI1, SPI_CCERR_FLAG)) != RESET)
207 {
208 spi_i2s_flag_clear(SPI1, SPI_CCERR_FLAG);
209 transfer_status2 = ERROR;
210 }
211 if((spi_i2s_flag_get(SPI2, SPI_CCERR_FLAG)) != RESET)
212 {
213 spi_i2s_flag_clear(SPI2, SPI_CCERR_FLAG);
214 transfer_status1 = ERROR;
215 }
216 crc1_value = spi_i2s_data_receive(SPI1);
217 crc2_value = spi_i2s_data_receive(SPI2);
218
219 /* test result indicate:if success,led2 lights */
220 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
221 {
222 at32_led_on(LED2);
223 }
224 else
225 {
226 at32_led_off(LED2);
227 }
228 while(1)
229 {
230 }
231}
232
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
spi1_tx_buffer
uint16_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:41
buffer_compare
error_status buffer_compare(uint16_t *pbuffer1, uint16_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:64
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:83
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:52
spi2_tx_buffer
uint16_t spi2_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:45
spi1_rx_buffer
uint16_t spi1_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:49
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:39
crc2_value
__IO uint16_t crc2_value
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:51
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:52
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:169
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:50
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:50
spi2_rx_buffer
uint16_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:49
crc1_value
__IO uint16_t crc1_value
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:51
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:115
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
SPI_CCERR_FLAG
#define SPI_CCERR_FLAG
Definition: at32f413_spi.h:57
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_crc_enable
void spi_crc_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware crc calculation for the spi peripheral.
Definition: at32f413_spi.c:191
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
spi_crc_next_transmit
void spi_crc_next_transmit(spi_type *spi_x)
spi next transmit crc for the spi peripheral.
Definition: at32f413_spi.c:152
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_crc_polynomial_set
void spi_crc_polynomial_set(spi_type *spi_x, uint16_t crc_poly)
set the crc polynomial value for the spi peripheral.
Definition: at32f413_spi.c:165
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
spi_i2s_flag_clear
void spi_i2s_flag_clear(spi_type *spi_x, uint32_t spi_i2s_flag)
clear flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:580
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:151
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:107
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:160
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:136
SPI_FRAME_16BIT
@ SPI_FRAME_16BIT
Definition: at32f413_spi.h:90
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • fullduplex_polling
  • inc
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • fullduplex_polling
  • inc
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • fullduplex_polling
  • inc
project/at_start_f413/examples/spi/fullduplex_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • fullduplex_polling
  • src
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • fullduplex_polling
  • src
project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • fullduplex_polling
  • src
project/at_start_f413/examples/spi/fullduplex_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30
39#define BUFFER_SIZE 32
40
41 spi_init_type spi_init_struct;
42uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
43 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
44 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
45 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
46uint8_t spi2_tx_buffer[BUFFER_SIZE] = {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
47 0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
48 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
49 0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70};
50uint8_t spi1_rx_buffer[BUFFER_SIZE], spi2_rx_buffer[BUFFER_SIZE];
51uint32_t tx_index = 0, rx_index = 0;
52volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
53volatile error_status transfer_status3 = ERROR, transfer_status4 = ERROR;
54
55static void gpio_config(uint16_t spi1_mode, uint16_t spi2_mode);
56static void spi_config(void);
57 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength);
58
65 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t bufferlength)
66{
67 while(bufferlength--)
68 {
69 if(*pbuffer1 != *pbuffer2)
70 {
71 return ERROR;
72 }
73
74 pbuffer1++;
75 pbuffer2++;
76 }
77 return SUCCESS;
78}
79
85static void spi_config(void)
86{
87 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
88 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
89 spi_default_para_init(&spi_init_struct);
90 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
91 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
92 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
93 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_LSB;
94 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
95 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
96 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
97 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
98 spi_init(SPI1, &spi_init_struct);
99
100 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
101 spi_init(SPI2, &spi_init_struct);
102
103 spi_enable(SPI1, TRUE);
104 spi_enable(SPI2, TRUE);
105}
106
112static void gpio_config(uint16_t spi1_mode, uint16_t spi2_mode)
113{
114 gpio_init_type gpio_initstructure;
115 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
116 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
117 gpio_default_para_init(&gpio_initstructure);
118 /* spi1 sck pin */
119 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
120 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
121 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
122 if(spi1_mode == SPI_MODE_MASTER)
123 {
124 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
125 }
126 else
127 {
128 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
129 }
130 gpio_initstructure.gpio_pins = GPIO_PINS_5;
131 gpio_init(GPIOA, &gpio_initstructure);
132
133 /* spi1 miso pin */
134 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
135 if(spi1_mode == SPI_MODE_MASTER)
136 {
137 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
138 }
139 else
140 {
141 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
142 }
143 gpio_initstructure.gpio_pins = GPIO_PINS_6;
144 gpio_init(GPIOA, &gpio_initstructure);
145
146 /* spi1 mosi pin */
147 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
148 if(spi1_mode == SPI_MODE_MASTER)
149 {
150 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
151 }
152 else
153 {
154 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
155 }
156 gpio_initstructure.gpio_pins = GPIO_PINS_7;
157 gpio_init(GPIOA, &gpio_initstructure);
158
159 /* spi2 sck pin */
160 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
161 if(spi2_mode == SPI_MODE_SLAVE)
162 {
163 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
164 }
165 else
166 {
167 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
168 }
169 gpio_initstructure.gpio_pins = GPIO_PINS_13;
170 gpio_init(GPIOB, &gpio_initstructure);
171
172 /* spi2 miso pin */
173 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
174 if(spi2_mode == SPI_MODE_SLAVE)
175 {
176 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
177 }
178 else
179 {
180 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
181 }
182 gpio_initstructure.gpio_pins = GPIO_PINS_14;
183 gpio_init(GPIOB, &gpio_initstructure);
184
185 /* spi2 mosi pin */
186 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
187 if(spi2_mode == SPI_MODE_SLAVE)
188 {
189 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
190 }
191 else
192 {
193 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
194 }
195 gpio_initstructure.gpio_pins = GPIO_PINS_15;
196 gpio_init(GPIOB, &gpio_initstructure);
197}
198
204int main(void)
205{
206 __IO uint32_t index = 0;
207 system_clock_config();
208 at32_board_init();
209 gpio_config(SPI_MODE_MASTER, SPI_MODE_SLAVE);
210 spi_config();
211
212 /* transfer procedure:the "BUFFER_SIZE" data transfer */
213 while(tx_index < BUFFER_SIZE)
214 {
215 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
216 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index]);
217 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
218 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
219 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
220 spi2_rx_buffer[rx_index] = spi_i2s_data_receive(SPI2);
221 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
222 spi1_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI1);
223 }
224
225 /* test result:the data check */
226 transfer_status1 = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
227 transfer_status2 = buffer_compare(spi1_rx_buffer, spi2_tx_buffer, BUFFER_SIZE);
228
229 /* master &slave mode switch */
230 spi_enable(SPI1, FALSE);
231 spi_enable(SPI2, FALSE);
232 gpio_config(SPI_MODE_SLAVE, SPI_MODE_MASTER);
233 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
234 spi_init(SPI1, &spi_init_struct);
235
236 spi_init_struct.master_slave_mode =SPI_MODE_MASTER;
237 spi_init(SPI2, &spi_init_struct);
238
239 tx_index = 0;
240 rx_index = 0;
241 for(index = 0; index < BUFFER_SIZE; index++)
242 spi1_rx_buffer[index] = 0;
243 for(index = 0; index < BUFFER_SIZE; index++)
244 spi2_rx_buffer[index] = 0;
245
246 spi_enable(SPI2, TRUE);
247 spi_enable(SPI1, TRUE);
248
249 /* transfer procedure:the "BUFFER_SIZE" data transfer */
250 while(tx_index < BUFFER_SIZE)
251 {
252 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
253 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index]);
254 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
255 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index++]);
256 while(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) == RESET);
257 spi1_rx_buffer[rx_index] = spi_i2s_data_receive(SPI1);
258 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
259 spi2_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI2);
260 }
261
262 /* test result:the data check */
263 transfer_status3 = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
264 transfer_status4 = buffer_compare(spi1_rx_buffer, spi2_tx_buffer, BUFFER_SIZE);
265
266 /* test result indicate:if success ,led2 lights */
267 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS) && \
268 (transfer_status3 == SUCCESS) && (transfer_status4 == SUCCESS))
269 {
270 at32_led_on(LED2);
271 }
272 else
273 {
274 at32_led_off(LED2);
275 }
276 while(1)
277 {
278 }
279}
280
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t bufferlength)
buffer compare function.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:65
transfer_status3
volatile error_status transfer_status3
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:53
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:85
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:52
transfer_status4
volatile error_status transfer_status4
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:53
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:39
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:52
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:204
gpio_config
static void gpio_config(uint16_t spi1_mode, uint16_t spi2_mode)
gpio configuration.
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:112
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:50
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:41
spi1_rx_buffer
uint8_t spi1_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:50
spi2_tx_buffer
uint8_t spi2_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:46
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:51
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:51
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f413_spi.h:152
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:107
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:160
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:136
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:89
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • halfduplex_interrupt
  • inc
project/at_start_f413/examples/spi/halfduplex_interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31extern uint8_t spi1_tx_buffer[];
32extern uint8_t spi2_rx_buffer[];
33extern uint32_t tx_index;
34extern uint32_t rx_index;
35
44#define BUFFERSIZE 32
45
51void NMI_Handler(void)
52{
53}
54
60void HardFault_Handler(void)
61{
62 /* go to infinite loop when hard fault exception occurs */
63 while(1)
64 {
65 }
66}
67
73void MemManage_Handler(void)
74{
75 /* go to infinite loop when memory manage exception occurs */
76 while(1)
77 {
78 }
79}
80
86void BusFault_Handler(void)
87{
88 /* go to infinite loop when bus fault exception occurs */
89 while(1)
90 {
91 }
92}
93
99void UsageFault_Handler(void)
100{
101 /* go to infinite loop when usage fault exception occurs */
102 while(1)
103 {
104 }
105}
106
112void SVC_Handler(void)
113{
114}
115
121void DebugMon_Handler(void)
122{
123}
124
130void PendSV_Handler(void)
131{
132}
133
139void SysTick_Handler(void)
140{
141}
142
148 void SPI1_IRQHandler(void)
149{
150 if(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) != RESET)
151 {
152 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
153 if(tx_index == BUFFERSIZE)
154 {
155 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, FALSE);
156 }
157 }
158}
159
165 void SPI2_IRQHandler(void)
166{
167 if(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) != RESET)
168 {
169 spi2_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI2);
170 }
171}
172
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:46
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:33
spi1_tx_buffer
uint8_t spi1_tx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:41
spi2_rx_buffer
uint8_t spi2_rx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:49
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:99
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:60
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:73
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:112
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:130
SPI2_IRQHandler
void SPI2_IRQHandler(void)
This function handles the spi2 interrupt request.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:165
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:51
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:86
SPI1_IRQHandler
void SPI1_IRQHandler(void)
This function handles the spi1 interrupt request.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:148
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:139
BUFFERSIZE
#define BUFFERSIZE
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:44
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/at32f413_int.c:121
FALSE
@ FALSE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:74
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:464
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • halfduplex_interrupt
  • src
project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define BUFFER_SIZE 32
39
40 spi_init_type spi_init_struct;
41
42uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
43 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
44 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
45 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
46uint8_t spi2_rx_buffer[BUFFER_SIZE];
47volatile uint32_t tx_index = 0, rx_index = 0;
48volatile error_status transfer_status = ERROR;
49
50static void gpio_config(void);
51static void spi_config(void);
52 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
53
60 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
61{
62 while(buffer_length--)
63 {
64 if(*pbuffer1 != *pbuffer2)
65 {
66 return ERROR;
67 }
68
69 pbuffer1++;
70 pbuffer2++;
71 }
72 return SUCCESS;
73}
74
80static void spi_config(void)
81{
82 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
83 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
84 spi_default_para_init(&spi_init_struct);
85 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
86 spi_init_struct.master_slave_mode =SPI_MODE_MASTER;
87 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
88 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
89 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
90 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
91 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
92 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
93 spi_init(SPI1, &spi_init_struct);
94
95 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
96 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
97 spi_init(SPI2, &spi_init_struct);
98
99 nvic_irq_enable(SPI1_IRQn, 0, 0);
100 nvic_irq_enable(SPI2_IRQn, 0, 0);
101 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, TRUE);
102 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, TRUE);
103
104 spi_enable(SPI2, TRUE);
105 spi_enable(SPI1, TRUE);
106}
107
113static void gpio_config(void)
114{
115 gpio_init_type gpio_initstructure;
116 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
117 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
118 gpio_default_para_init(&gpio_initstructure);
119
120 /* spi1 sck pin */
121 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
122 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
123 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
124 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
125 gpio_initstructure.gpio_pins = GPIO_PINS_5;
126 gpio_init(GPIOA, &gpio_initstructure);
127
128 /* spi1 mosi pin */
129 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
130 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
131 gpio_initstructure.gpio_pins = GPIO_PINS_7;
132 gpio_init(GPIOA, &gpio_initstructure);
133
134 /* spi2 sck pin */
135 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
136 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
137 gpio_initstructure.gpio_pins = GPIO_PINS_13;
138 gpio_init(GPIOB, &gpio_initstructure);
139
140 /* spi2 miso pin */
141 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
142 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
143 gpio_initstructure.gpio_pins = GPIO_PINS_14;
144 gpio_init(GPIOB, &gpio_initstructure);
145
146 while(gpio_input_data_bit_read(GPIOB, GPIO_PINS_13)!=RESET);
147}
148
154int main(void)
155{
156 system_clock_config();
157 at32_board_init();
158 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
159 gpio_config();
160 /* config spi1 send spi2 receive */
161 spi_config();
162 while(rx_index < BUFFER_SIZE);
163
164 /* test result:the data check */
165 transfer_status = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
166
167 /* test result indicate:if success ,led2 lights */
168 if(transfer_status==SUCCESS)
169 {
170 at32_led_on(LED2);
171 }
172 else
173 {
174 at32_led_off(LED2);
175 }
176 while(1)
177 {
178 }
179}
180
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:60
tx_index
volatile uint32_t tx_index
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:47
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:80
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:154
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:46
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:40
rx_index
volatile uint32_t rx_index
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:47
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:113
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:48
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_interrupt/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
SPI2_IRQn
@ SPI2_IRQn
Definition: at32f413.h:170
SPI1_IRQn
@ SPI1_IRQn
Definition: at32f413.h:169
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:203
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:74
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f413_spi.h:73
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:464
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:151
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:107
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:162
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:163
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:136
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:89
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • halfduplex_transceiver_switch
  • inc
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • halfduplex_transceiver_switch
  • inc
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • halfduplex_transceiver_switch
  • inc
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • halfduplex_transceiver_switch
  • src
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • halfduplex_transceiver_switch
  • src
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
31extern uint8_t spi1_tx_buffer[];
32extern uint8_t spi2_tx_buffer[];
33extern uint8_t spi1_rx_buffer[];
34extern uint8_t spi2_rx_buffer[];
35extern uint32_t tx_index;
36extern uint32_t rx_index;
37
46#define BUFFERSIZE 32
47
53void NMI_Handler(void)
54{
55}
56
62void HardFault_Handler(void)
63{
64 /* go to infinite loop when hard fault exception occurs */
65 while(1)
66 {
67 }
68}
69
75void MemManage_Handler(void)
76{
77 /* go to infinite loop when memory manage exception occurs */
78 while(1)
79 {
80 }
81}
82
88void BusFault_Handler(void)
89{
90 /* go to infinite loop when bus fault exception occurs */
91 while(1)
92 {
93 }
94}
95
101void UsageFault_Handler(void)
102{
103 /* go to infinite loop when usage fault exception occurs */
104 while(1)
105 {
106 }
107}
108
114void SVC_Handler(void)
115{
116}
117
123void DebugMon_Handler(void)
124{
125}
126
132void PendSV_Handler(void)
133{
134}
135
141void SysTick_Handler(void)
142{
143}
144
150 void SPI1_IRQHandler(void)
151{
152 if(SPI1->ctrl2_bit.tdbeie != RESET)
153 {
154 if(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) != RESET)
155 {
156 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
157 if(tx_index == BUFFERSIZE)
158 {
159 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, FALSE);
160 }
161 }
162 }
163 if(SPI1->ctrl2_bit.rdbfie != RESET)
164 {
165 if(spi_i2s_flag_get(SPI1, SPI_I2S_RDBF_FLAG) != RESET)
166 {
167 spi_enable(SPI1, FALSE);
168 spi1_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI1);
169 spi_enable(SPI1, TRUE);
170 if(rx_index == BUFFERSIZE)
171 {
172 spi_i2s_interrupt_enable(SPI1, SPI_I2S_RDBF_FLAG, FALSE);
173 }
174 }
175 }
176}
177
183 void SPI2_IRQHandler(void)
184{
185 if(SPI2->ctrl2_bit.tdbeie != RESET)
186 {
187 if(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) != RESET)
188 {
189 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[tx_index++]);
190 if(tx_index == BUFFERSIZE)
191 {
192 spi_i2s_interrupt_enable(SPI2, SPI_I2S_TDBE_INT, FALSE);
193 }
194 }
195 }
196 if(SPI2->ctrl2_bit.rdbfie != RESET)
197 {
198 if(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) != RESET)
199 {
200 spi2_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI2);
201 }
202 }
203}
204
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/main.c:46
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/i2s/halfduplex_interrupt/src/at32f413_int.c:33
spi1_tx_buffer
uint8_t spi1_tx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:41
spi2_tx_buffer
uint8_t spi2_tx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:45
spi1_rx_buffer
uint8_t spi1_rx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:49
spi2_rx_buffer
uint8_t spi2_rx_buffer[]
Definition: project/at_start_f413/examples/spi/crc_transfer_polling/src/main.c:49
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:101
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:62
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:75
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:114
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:132
SPI2_IRQHandler
void SPI2_IRQHandler(void)
This function handles the spi2 interrupt request.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:183
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:53
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:88
SPI1_IRQHandler
void SPI1_IRQHandler(void)
This function handles the spi1 interrupt request.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:150
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:141
BUFFERSIZE
#define BUFFERSIZE
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:46
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/at32f413_int.c:123
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:74
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:464
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • halfduplex_transceiver_switch
  • src
project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define BUFFER_SIZE 32
39
40
41 spi_init_type spi_init_struct;
42uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
43 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
44 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
45 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
46uint8_t spi2_tx_buffer[BUFFER_SIZE] = {0x51, 0x52, 0x53, 0x54, 0x55, 0x56, 0x57, 0x58,
47 0x59, 0x5A, 0x5B, 0x5C, 0x5D, 0x5E, 0x5F, 0x60,
48 0x61, 0x62, 0x63, 0x64, 0x65, 0x66, 0x67, 0x68,
49 0x69, 0x6A, 0x6B, 0x6C, 0x6D, 0x6E, 0x6F, 0x70};
50uint8_t spi1_rx_buffer[BUFFER_SIZE], spi2_rx_buffer[BUFFER_SIZE];
51volatile uint32_t tx_index = 0, rx_index = 0;
52volatile error_status transfer_status1 = ERROR, transfer_status2 = ERROR;
53
54static void gpio_config(void);
55static void spi_config(void);
56 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
57
64 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
65{
66 while(buffer_length--)
67 {
68 if(*pbuffer1 != *pbuffer2)
69 {
70 return ERROR;
71 }
72
73 pbuffer1++;
74 pbuffer2++;
75 }
76 return SUCCESS;
77}
78
84static void spi_config(void)
85{
86 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
87 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
88 spi_default_para_init(&spi_init_struct);
89 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
90 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
91 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_256;
92 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
93 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
94 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
95 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
96 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
97 spi_init(SPI1, &spi_init_struct);
98
99 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
100 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
101 spi_init(SPI2, &spi_init_struct);
102
103 nvic_irq_enable(SPI1_IRQn, 0, 0);
104 nvic_irq_enable(SPI2_IRQn, 0, 0);
105 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, TRUE);
106 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, TRUE);
107
108 spi_enable(SPI1, TRUE);
109 spi_enable(SPI2, TRUE);
110}
111
117static void gpio_config(void)
118{
119 gpio_init_type gpio_initstructure;
120 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
121 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
122 gpio_default_para_init(&gpio_initstructure);
123
124 /* spi1 sck pin */
125 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
126 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
127 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
128 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
129 gpio_initstructure.gpio_pins = GPIO_PINS_5;
130 gpio_init(GPIOA, &gpio_initstructure);
131
132 /* spi1 mosi pin */
133 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
134 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
135 gpio_initstructure.gpio_pins = GPIO_PINS_7;
136 gpio_init(GPIOA, &gpio_initstructure);
137
138 /* spi2 sck pin */
139 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
140 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
141 gpio_initstructure.gpio_pins = GPIO_PINS_13;
142 gpio_init(GPIOB, &gpio_initstructure);
143
144 /* spi2 miso pin */
145 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
146 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
147 gpio_initstructure.gpio_pins = GPIO_PINS_14;
148 gpio_init(GPIOB, &gpio_initstructure);
149
150 while(gpio_input_data_bit_read(GPIOB, GPIO_PINS_13)!=RESET);
151}
152
158int main(void)
159{
160 system_clock_config();
161 at32_board_init();
162 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
163 gpio_config();
164 /* config spi1 send spi2 receive */
165 spi_config();
166 while(rx_index < BUFFER_SIZE);
167
168 /* test result:the data check */
169 transfer_status1 = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
170
171 /* config spi2 send spi1 receive */
172 spi_enable(SPI1, FALSE);
173 spi_enable(SPI2, FALSE);
174 rx_index = 0;
175 tx_index = 0;
176 spi_i2s_interrupt_enable(SPI1, SPI_I2S_TDBE_INT, FALSE);
177 spi_i2s_interrupt_enable(SPI2, SPI_I2S_RDBF_INT, FALSE);
178
179 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
180 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
181 spi_init(SPI1, &spi_init_struct);
182
183 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
184 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
185 spi_init(SPI2, &spi_init_struct);
186
187 spi_i2s_interrupt_enable(SPI1, SPI_I2S_RDBF_INT, TRUE);
188 spi_i2s_interrupt_enable(SPI2, SPI_I2S_TDBE_INT, TRUE);
189 spi_enable(SPI2, TRUE);
190 spi_enable(SPI1, TRUE);
191 while(rx_index < BUFFER_SIZE);
192
193 /* test result:the data check */
194 transfer_status2 = buffer_compare(spi1_rx_buffer, spi2_tx_buffer, BUFFER_SIZE);
195
196 /* test result indicate:if passed ,led2 lights */
197 if((transfer_status1 == SUCCESS) && (transfer_status2 == SUCCESS))
198 {
199 at32_led_on(LED2);
200 }
201 else
202 {
203 at32_led_off(LED2);
204 }
205 while(1)
206 {
207 }
208}
209
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:64
tx_index
volatile uint32_t tx_index
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:51
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:84
transfer_status1
volatile error_status transfer_status1
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:52
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:38
transfer_status2
volatile error_status transfer_status2
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:52
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:158
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:50
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:41
spi1_rx_buffer
uint8_t spi1_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:50
spi2_tx_buffer
uint8_t spi2_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:46
rx_index
volatile uint32_t rx_index
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:51
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:117
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/halfduplex_transceiver_switch/src/main.c:42
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
SPI2_IRQn
@ SPI2_IRQn
Definition: at32f413.h:170
SPI1_IRQn
@ SPI1_IRQn
Definition: at32f413.h:169
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:203
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
SPI_I2S_TDBE_INT
#define SPI_I2S_TDBE_INT
Definition: at32f413_spi.h:74
SPI_I2S_RDBF_INT
#define SPI_I2S_RDBF_INT
Definition: at32f413_spi.h:73
spi_i2s_interrupt_enable
void spi_i2s_interrupt_enable(spi_type *spi_x, uint32_t spi_i2s_int, confirm_state new_state)
enable or disable the specified spi/i2s interrupts.
Definition: at32f413_spi.c:464
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:151
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:107
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:162
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:163
SPI_MCLK_DIV_256
@ SPI_MCLK_DIV_256
Definition: at32f413_spi.h:141
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:89
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • only_receive_mode_polling
  • inc
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • only_receive_mode_polling
  • inc
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • only_receive_mode_polling
  • inc
project/at_start_f413/examples/spi/only_receive_mode_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • only_receive_mode_polling
  • src
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • only_receive_mode_polling
  • src
project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • only_receive_mode_polling
  • src
project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define BUFFER_SIZE 32
39
40 spi_init_type spi_init_struct;
41uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
42 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
43 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
44 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
45uint8_t spi2_rx_buffer[BUFFER_SIZE];
46uint32_t tx_index = 0, rx_index = 0;
47volatile error_status transfer_status = ERROR;
48
49static void gpio_config(void);
50static void spi_config(void);
51 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
52
59 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
60{
61 while(buffer_length--)
62 {
63 if(*pbuffer1 != *pbuffer2)
64 {
65 return ERROR;
66 }
67
68 pbuffer1++;
69 pbuffer2++;
70 }
71 return SUCCESS;
72}
73
79static void spi_config(void)
80{
81 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
82 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
83 spi_default_para_init(&spi_init_struct);
84 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
85 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
86 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
87 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_LSB;
88 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
89 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
90 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
91 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
92 spi_init(SPI1, &spi_init_struct);
93
94 spi_init_struct.transmission_mode = SPI_TRANSMIT_SIMPLEX_RX;
95 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
96 spi_init(SPI2, &spi_init_struct);
97
98 spi_enable(SPI1, TRUE);
99 spi_enable(SPI2, TRUE);
100}
101
107static void gpio_config(void)
108{
109 gpio_init_type gpio_initstructure;
110 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
111 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
112 gpio_default_para_init(&gpio_initstructure);
113
114 /* spi1 sck pin */
115 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
116 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
117 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
118 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
119 gpio_initstructure.gpio_pins = GPIO_PINS_5;
120 gpio_init(GPIOA, &gpio_initstructure);
121
122 /* spi1 mosi pin */
123 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
124 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
125 gpio_initstructure.gpio_pins = GPIO_PINS_7;
126 gpio_init(GPIOA, &gpio_initstructure);
127
128 /* spi2 sck pin */
129 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
130 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
131 gpio_initstructure.gpio_pins = GPIO_PINS_13;
132 gpio_init(GPIOB, &gpio_initstructure);
133
134 /* spi2 mosi pin */
135 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
136 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
137 gpio_initstructure.gpio_pins = GPIO_PINS_15;
138 gpio_init(GPIOB, &gpio_initstructure);
139
140 while(gpio_input_data_bit_read(GPIOB, GPIO_PINS_13) != RESET);
141}
142
148int main(void)
149{
150 system_clock_config();
151 at32_board_init();
152 gpio_config();
153 spi_config();
154
155 /* transfer procedure:the "BUFFER_SIZE" data transfer */
156 while(tx_index < BUFFER_SIZE)
157 {
158 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
159 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
160 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
161 spi2_rx_buffer[rx_index++] = spi_i2s_data_receive(SPI2);
162 }
163
164 /* test result:the data check */
165 transfer_status = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
166
167 /* test result indicate:if SUCCESS ,led2 lights */
168 if(transfer_status == SUCCESS)
169 {
170 at32_led_on(LED2);
171 }
172 else
173 {
174 at32_led_off(LED2);
175 }
176 while(1)
177 {
178 }
179}
180
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:59
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:79
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:148
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:45
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:40
rx_index
uint32_t rx_index
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:46
tx_index
uint32_t tx_index
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:46
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:107
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:47
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/only_receive_mode_polling/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:203
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f413_spi.h:152
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:107
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:160
SPI_TRANSMIT_SIMPLEX_RX
@ SPI_TRANSMIT_SIMPLEX_RX
Definition: at32f413_spi.h:161
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:136
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:89
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • inc
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • use_jtagpin_hardwarecs_dma
  • src
project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define BUFFER_SIZE 32
39
40uint8_t spi1_tx_buffer[BUFFER_SIZE] = {0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08,
41 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10,
42 0x11, 0x12, 0x13, 0x14, 0x15, 0x16, 0x17, 0x18,
43 0x19, 0x1A, 0x1B, 0x1C, 0x1D, 0x1E, 0x1F, 0x20};
44uint8_t spi2_rx_buffer[BUFFER_SIZE];
45__IO uint8_t tx_index = 0;
46volatile error_status transfer_status = ERROR;
47
48static void gpio_config(void);
49static void spi_config(void);
50 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
51
58 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
59{
60 while(buffer_length--)
61 {
62 if(*pbuffer1 != *pbuffer2)
63 {
64 return ERROR;
65 }
66
67 pbuffer1++;
68 pbuffer2++;
69 }
70 return SUCCESS;
71}
72
78static void spi_config(void)
79{
80 dma_init_type dma_init_struct;
81 spi_init_type spi_init_struct;
82
83 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
84 dma_reset(DMA1_CHANNEL4);
85 dma_default_para_init(&dma_init_struct);
86 dma_init_struct.buffer_size = BUFFER_SIZE;
87 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
88 dma_init_struct.memory_base_addr = (uint32_t)spi2_rx_buffer;
89 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
90 dma_init_struct.memory_inc_enable = TRUE;
91 dma_init_struct.peripheral_base_addr = (uint32_t)0x4000380C;
92 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
93 dma_init_struct.peripheral_inc_enable = FALSE;
94 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
95 dma_init_struct.loop_mode_enable = FALSE;
96 dma_init(DMA1_CHANNEL4, &dma_init_struct);
97
98 crm_periph_clock_enable(CRM_SPI1_PERIPH_CLOCK, TRUE);
99 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
100 spi_default_para_init(&spi_init_struct);
101 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_TX;
102 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
103 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
104 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
105 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
106 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_LOW;
107 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
108 spi_init_struct.cs_mode_selection = SPI_CS_HARDWARE_MODE;
109 spi_init(SPI1, &spi_init_struct);
110
111 spi_init_struct.master_slave_mode = SPI_MODE_SLAVE;
112 spi_init_struct.transmission_mode = SPI_TRANSMIT_HALF_DUPLEX_RX;
113 spi_init(SPI2, &spi_init_struct);
114
115 spi_hardware_cs_output_enable(SPI1, TRUE);
116 spi_i2s_dma_receiver_enable(SPI2, TRUE);
117 spi_enable(SPI1, TRUE);
118 spi_enable(SPI2, TRUE);
119}
120
126static void gpio_config(void)
127{
128 gpio_init_type gpio_initstructure;
129 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
130 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
131 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
132 gpio_pin_remap_config(SWJTAG_GMUX_010, TRUE);
133 gpio_pin_remap_config(SPI1_MUX_01, TRUE);
134
135 /* master sck pin */
136 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
137 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
138 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
139 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
140 gpio_initstructure.gpio_pins = GPIO_PINS_3;
141 gpio_init(GPIOB, &gpio_initstructure);
142
143 /* master miso pin */
144 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
145 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
146 gpio_initstructure.gpio_pins = GPIO_PINS_4;
147 gpio_init(GPIOB, &gpio_initstructure);
148
149 /* master mosi pin */
150 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
151 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
152 gpio_initstructure.gpio_pins = GPIO_PINS_5;
153 gpio_init(GPIOB, &gpio_initstructure);
154
155 /* master cs pin */
156 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
157 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
158 gpio_initstructure.gpio_pins = GPIO_PINS_15;
159 gpio_init(GPIOA, &gpio_initstructure);
160
161 /* slave sck pin */
162 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
163 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
164 gpio_initstructure.gpio_pins = GPIO_PINS_13;
165 gpio_init(GPIOB, &gpio_initstructure);
166
167 /* slave miso pin */
168 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
169 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
170 gpio_initstructure.gpio_pins = GPIO_PINS_14;
171 gpio_init(GPIOB, &gpio_initstructure);
172
173 /* slave mosi pin */
174 gpio_initstructure.gpio_pull = GPIO_PULL_DOWN;
175 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
176 gpio_initstructure.gpio_pins = GPIO_PINS_15;
177 gpio_init(GPIOB, &gpio_initstructure);
178
179 /* slave cs pin */
180 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
181 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
182 gpio_initstructure.gpio_pins = GPIO_PINS_12;
183 gpio_init(GPIOB, &gpio_initstructure);
184}
185
191int main(void)
192{
193 system_clock_config();
194 at32_board_init();
195
196 /* button press:ensure code canbe download normally */
197 while(at32_button_press() == NO_BUTTON);
198
199 gpio_config();
200 spi_config();
201 dma_channel_enable(DMA1_CHANNEL4, TRUE);
202
203 /* transfer procedure:the "BUFFER_SIZE" data transfer */
204 while(tx_index < BUFFER_SIZE)
205 {
206 while(spi_i2s_flag_get(SPI1, SPI_I2S_TDBE_FLAG) == RESET);
207 spi_i2s_data_transmit(SPI1, spi1_tx_buffer[tx_index++]);
208 }
209 while(!dma_flag_get(DMA1_FDT4_FLAG));
210
211 /* test result:the data check */
212 transfer_status = buffer_compare(spi2_rx_buffer, spi1_tx_buffer, BUFFER_SIZE);
213
214 /* test result indicate:if success ,led2 lights */
215 if(transfer_status == SUCCESS)
216 {
217 at32_led_on(LED2);
218 }
219 else
220 {
221 at32_led_off(LED2);
222 }
223 while(1)
224 {
225 }
226}
227
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:41
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:58
spi_config
static void spi_config(void)
spi configuration.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:78
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:38
tx_index
__IO uint8_t tx_index
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:45
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:191
spi2_rx_buffer
uint8_t spi2_rx_buffer[32]
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:44
gpio_config
static void gpio_config(void)
gpio configuration.
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:126
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:46
spi1_tx_buffer
uint8_t spi1_tx_buffer[32]
Definition: project/at_start_f413/examples/spi/use_jtagpin_hardwarecs_dma/src/main.c:40
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED2
@ LED2
Definition: at32f413_board.h:63
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:95
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_SPI1_PERIPH_CLOCK
@ CRM_SPI1_PERIPH_CLOCK
Definition: at32f413_crm.h:118
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:245
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:255
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:266
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:94
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:483
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_pin_remap_config
void gpio_pin_remap_config(uint32_t gpio_remap, confirm_state new_state)
iomux remap and debug i/o configuration.
Definition: at32f413_gpio.c:517
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIO_PINS_5
#define GPIO_PINS_5
Definition: at32f413_gpio.h:56
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
SWJTAG_GMUX_010
#define SWJTAG_GMUX_010
Definition: at32f413_gpio.h:197
SPI1_MUX_01
#define SPI1_MUX_01
Definition: at32f413_gpio.h:81
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:499
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_hardware_cs_output_enable
void spi_hardware_cs_output_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the hardware cs output for the spi peripheral.
Definition: at32f413_spi.c:224
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
SPI_CS_HARDWARE_MODE
@ SPI_CS_HARDWARE_MODE
Definition: at32f413_spi.h:125
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:151
SPI_CLOCK_POLARITY_LOW
@ SPI_CLOCK_POLARITY_LOW
Definition: at32f413_spi.h:107
SPI_TRANSMIT_HALF_DUPLEX_RX
@ SPI_TRANSMIT_HALF_DUPLEX_RX
Definition: at32f413_spi.h:162
SPI_TRANSMIT_HALF_DUPLEX_TX
@ SPI_TRANSMIT_HALF_DUPLEX_TX
Definition: at32f413_spi.h:163
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:136
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:89
SPI1
#define SPI1
Definition: at32f413_spi.h:448
SPI2
#define SPI2
Definition: at32f413_spi.h:449
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • spi
  • w25q_flash
  • inc
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • spi
  • w25q_flash
  • inc
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • spi
  • w25q_flash
  • inc
project/at_start_f413/examples/spi/w25q_flash/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • spi
  • w25q_flash
  • src
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • spi
  • w25q_flash
  • src
project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • spi
  • w25q_flash
  • src
project/at_start_f413/examples/spi/w25q_flash/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "spi_flash.h"
30
39#define FLASH_TEST_ADDR 0x1000
40#define BUF_SIZE 0x256
41
42uint8_t tx_buffer[BUF_SIZE];
43uint8_t rx_buffer[BUF_SIZE];
44volatile error_status transfer_status = ERROR;
45
46void tx_data_fill(void);
47 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length);
48
54void tx_data_fill(void)
55{
56 uint32_t data_index = 0;
57 for(data_index = 0; data_index < BUF_SIZE; data_index++)
58 {
59 tx_buffer[data_index] = data_index;
60 }
61}
62
69 error_status buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
70{
71 while(buffer_length--)
72 {
73 if(*pbuffer1 != *pbuffer2)
74 {
75 return ERROR;
76 }
77
78 pbuffer1++;
79 pbuffer2++;
80 }
81 return SUCCESS;
82}
83
89int main(void)
90{
91 __IO uint32_t index = 0;
92 __IO uint32_t flash_id_index = 0;
93 system_clock_config();
94 at32_board_init();
95 tx_data_fill();
96 uart_print_init(115200);
97 spiflash_init();
98 flash_id_index = spiflash_read_id();
99if((flash_id_index != W25Q128)&&(flash_id_index != W25Q80)&&(flash_id_index != W25Q16)&&(flash_id_index != W25Q32)&&(flash_id_index != W25Q64)) {
100 printf("flash id check error!\r\n");
101 for(index = 0; index < 50; index++)
102 {
103 at32_led_toggle(LED2);
104 at32_led_toggle(LED3);
105 delay_ms(200);
106 }
107 return 1;
108 }
109 else
110 {
111 printf("flash id check success! id: %x\r\n", flash_id_index);
112 }
113
114 /* erase sector */
115 spiflash_sector_erase(FLASH_TEST_ADDR / SPIF_SECTOR_SIZE);
116
117 /* write data */
118 spiflash_write(tx_buffer, FLASH_TEST_ADDR, BUF_SIZE);
119
120 /* read data */
121 spiflash_read(rx_buffer, FLASH_TEST_ADDR, BUF_SIZE);
122
123 /* printf read data */
124 printf("Read Data: ");
125 for(index = 0; index < BUF_SIZE; index++)
126 {
127 printf("%x ", rx_buffer[index]);
128 }
129
130 /* test result:the data check */
131 transfer_status = buffer_compare(rx_buffer, tx_buffer, BUF_SIZE);
132
133 /* test result indicate:if SUCCESS ,led2 lights */
134 if(transfer_status == SUCCESS)
135 {
136 printf("\r\nflash data read write success!\r\n");
137 at32_led_on(LED2);
138 }
139 else
140 {
141 printf("\r\nflash data read write ERROR!\r\n");
142 at32_led_off(LED2);
143 }
144
145 while(1)
146 {
147 }
148}
149
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
buffer_compare
error_status buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
buffer compare function.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:69
FLASH_TEST_ADDR
#define FLASH_TEST_ADDR
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:39
BUF_SIZE
#define BUF_SIZE
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:89
rx_buffer
uint8_t rx_buffer[0x256]
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:43
tx_data_fill
void tx_data_fill(void)
transfer data fill.
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:54
tx_buffer
uint8_t tx_buffer[0x256]
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:42
transfer_status
volatile error_status transfer_status
Definition: project/at_start_f413/examples/spi/w25q_flash/src/main.c:44
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: spi_flash.c:44
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: spi_flash.c:99
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: spi_flash.c:203
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: spi_flash.c:187
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: spi_flash.c:468
W25Q128
#define W25Q128
Definition: spi_flash.h:71
W25Q16
#define W25Q16
Definition: spi_flash.h:67
W25Q32
#define W25Q32
Definition: spi_flash.h:68
W25Q80
#define W25Q80
Definition: spi_flash.h:66
W25Q64
#define W25Q64
Definition: spi_flash.h:69
SPIF_SECTOR_SIZE
#define SPIF_SECTOR_SIZE
Definition: spi_flash.h:82
spi_flash.h
header file of spi_flash
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • sram
  • extend_sram
  • inc
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • sram
  • extend_sram
  • inc
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • sram
  • extend_sram
  • inc
project/at_start_f413/examples/sram/extend_sram/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • sram
  • extend_sram
  • src
project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • sram
  • extend_sram
  • src
project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/sram/extend_sram/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • sram
  • extend_sram
  • src
project/at_start_f413/examples/sram/extend_sram/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34void extend_sram(void);
35
36#ifdef __cplusplus
37}
38#endif
39
53void extend_sram(void)
54{
55 /* check if ram has been set to expectant size, if not, change eopb0 */
56 if(((USD->eopb0) & 0xFF) != EXTEND_SRAM)
57 {
58 flash_unlock();
59 /* erase user system data bytes */
60 flash_user_system_data_erase();
61
62 /* change sram size */
63 flash_user_system_data_program((uint32_t)&USD->eopb0, EXTEND_SRAM);
64
65 /* system reset */
66 nvic_system_reset();
67 }
68}
69
75int main(void)
76{
77 system_clock_config();
78 at32_board_init();
79
80 /* check eopb0 */
81 if(((USD->eopb0) & 0xFF) == EXTEND_SRAM)
82 {
83 at32_led_on(LED4);
84 }
85
86 while(1)
87 {
88 }
89}
90
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
main
int main(void)
main function.
Definition: project/at_start_f413/examples/sram/extend_sram/src/main.c:75
extend_sram
void extend_sram(void)
to extend sram size
Definition: project/at_start_f413/examples/sram/extend_sram/src/main.c:53
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
flash_user_system_data_program
flash_status_type flash_user_system_data_program(uint32_t address, uint8_t data)
program a halfword at a specified user system data address.
Definition: at32f413_flash.c:560
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_user_system_data_erase
flash_status_type flash_user_system_data_erase(void)
erase the flash user system data.
Definition: at32f413_flash.c:382
USD
#define USD
Definition: at32f413_flash.h:565
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:52
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • cascade_synchro
  • inc
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • cascade_synchro
  • inc
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • cascade_synchro
  • inc
project/at_start_f413/examples/tmr/cascade_synchro/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • cascade_synchro
  • src
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • cascade_synchro
  • src
project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/at32f413_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • cascade_synchro
  • src
project/at_start_f413/examples/tmr/cascade_synchro/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40
46int main(void)
47{
48 system_clock_config();
49
50 at32_board_init();
51
52 /* turn led2/led3/led4 on */
53 at32_led_on(LED2);
54 at32_led_on(LED3);
55 at32_led_on(LED4);
56
57 /* enable tmr2/tmr3/tmr4/gpioa/gpiob clock */
58 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
60 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
61 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
63
64 /* timer1 output pin Configuration */
65 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_0;
66 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
67 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
68 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
69 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
70 gpio_init(GPIOA, &gpio_init_struct);
71
72 gpio_init_struct.gpio_pins = GPIO_PINS_6;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
77 gpio_init(GPIOB, &gpio_init_struct);
78
79
80 /* timers synchronisation in cascade mode
81 1/tmr2 is configured as primary timer:
82 - pwm mode is used
83 - the tmr2 update event is used as trigger output
84
85 2/tmr3 is sub for tmr2 and primary for tmr4,
86 - pwm mode is used
87 - the itr1(tmr2) is used as input trigger
88 - gated mode is used, so start and stop of sub counter
89 are controlled by the master trigger output signal(tmr2 update event).
90 - the tmr3 update event is used as trigger output.
91
92 3/tmr4 is slave for tmr3,
93 - pwm mode is used
94 - the itr2(tmr3) is used as input trigger
95 - gated mode is used, so start and stop of sub counter
96 are controlled by the master trigger output signal(tmr3 overflow event).
97
98 the primary timer tmr2 is running at tmr2 frequency :
99 tim2 frequency = (tmr2 counter clock)/ (tmr2 period + 1) = 1 mhz
100 and the duty cycle = tmr2_c1dt/(tmr2_pr + 1) = 50%.
101
102 the tmr3 is running at:
103 (tmr2 frequency)/ (tmr3 period + 1) = 100 khz and a duty cycle equal
104 to tmr3_c1dt/(tmr3_pr + 1) = 50%
105
106 the tmr4 is running at:
107 (tmr3 frequency)/ (tmr4 period + 1) = 100 khz and a duty cycle equal
108 to tmr4_c1dt/(tmr4_pr + 1) = 50%
109
110 tmr2 pwm frequency = 1mhz, tmr3 pwm frequency = 100 khz,
111 and tmr4 pwm frequency = 10 khz */
112
113 tmr_base_init(TMR2, 191, 0);
114 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
115
116 tmr_base_init(TMR3, 9, 0);
117 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
118
119 tmr_base_init(TMR4, 9, 0);
120 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
121
122 /* channelx Configuration in output mode */
123 tmr_output_default_para_init(&tmr_output_struct);
124 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
125 tmr_output_struct.oc_output_state = TRUE;
126 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
127 tmr_output_struct.oc_idle_state = TRUE;
128 tmr_output_struct.occ_output_state = FALSE;
129 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
130 tmr_output_struct.occ_idle_state = FALSE;
131
132 /* timer2 channel 1 */
133 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
134 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, 96);
135
136 /* timer2 select enable signal to sub timer */
137 tmr_primary_mode_select(TMR2, TMR_PRIMARY_SEL_OVERFLOW);
138 tmr_sub_sync_mode_set(TMR2, TRUE);
139
140 /* timer3 channel 1 */
141 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
142 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, 5);
143
144 /* sub mode selection: tmr3 */
145 tmr_sub_mode_select(TMR3, TMR_SUB_HANG_MODE);
146 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_IS1);
147
148 /* timer3 select enable signal to sub timer */
149 tmr_primary_mode_select(TMR3, TMR_PRIMARY_SEL_OVERFLOW);
150 tmr_sub_sync_mode_set(TMR3, TRUE);
151
152 /* timer4 channel 1 */
153 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
154 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 5);
155
156 /* sub mode selection: tmr4 */
157 tmr_sub_mode_select(TMR4, TMR_SUB_HANG_MODE);
158 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_IS2);
159
160 /* enable tmr2/tmr3/tmr4 */
161 tmr_counter_enable(TMR2, TRUE);
162 tmr_counter_enable(TMR3, TRUE);
163 tmr_counter_enable(TMR4, TRUE);
164
165 while(1)
166 {
167 }
168}
169
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/cascade_synchro/src/main.c:46
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:128
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1256
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1157
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR_SUB_INPUT_SEL_IS2
@ TMR_SUB_INPUT_SEL_IS2
Definition: at32f413_tmr.h:135
TMR_SUB_INPUT_SEL_IS1
@ TMR_SUB_INPUT_SEL_IS1
Definition: at32f413_tmr.h:134
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:153
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f413_tmr.h:120
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
TMR4
#define TMR4
Definition: at32f413_tmr.h:835
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • complementary_signals
  • inc
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • complementary_signals
  • inc
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • complementary_signals
  • inc
project/at_start_f413/examples/tmr/complementary_signals/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • complementary_signals
  • src
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • complementary_signals
  • src
project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/at32f413_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • complementary_signals
  • src
project/at_start_f413/examples/tmr/complementary_signals/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 crm_clocks_freq_type crm_clocks_freq_struct = {0};
41 tmr_brkdt_config_type tmr_brkdt_config_struct = {0};
42
43uint16_t timer_period = 0;
44uint16_t channel1_pulse = 0, channel2_pulse = 0, channel3_pulse = 0;
45
51int main(void)
52{
53 system_clock_config();
54
55 at32_board_init();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 /* turn led2/led3/led4 on */
61 at32_led_on(LED2);
62 at32_led_on(LED3);
63 at32_led_on(LED4);
64
65 /* enable tmr1/gpioa/gpiob clock */
66 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
69
70 /* timer1 output pin configuration */
71 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
72 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
73 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
74 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
75 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
76 gpio_init(GPIOA, &gpio_init_struct);
77
78 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
79 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
80 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
81 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
82 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
83 gpio_init(GPIOB, &gpio_init_struct);
84
85 gpio_init_struct.gpio_pins = GPIO_PINS_12;
86 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
87 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
88 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
89 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
90 gpio_init(GPIOB, &gpio_init_struct);
91
92 /* tmr1 configuration to:
93
94 1/ generate 3 complementary pwm signals with 3 different duty cycles:
95 tmr1clk is fixed to system_core_clock, the tmr1 prescaler is equal to 0 so the
96 tmr1 counter clock used is system_core_clock.
97
98 the objective is to generate pwm signal at 17.57 khz:
99 - tmr1_period = (system_core_clock / 17570) - 1
100
101 the three duty cycles are computed as the following description:
102
103 the channel 1 duty cycle is set to 50% so channel 1c is set to 50%.
104 the channel 2 duty cycle is set to 25% so channel 2c is set to 75%.
105 the channel 3 duty cycle is set to 12.5% so channel 3c is set to 87.5%.
106 the timer pulse is calculated as follows:
107 - channelxpulse = duty_cycle * (tmr1_period - 1) / 100
108
109 2/ insert a dead time equal to 11/system_core_clock ns
110 3/ configure the break feature, active at high level, and using the automatic
111 output enable feature
112 4/ use the locking parameters level1. */
113
114 /* compute the value to be set in arr regiter to generate signal frequency at 17.57 khz */
115 timer_period = (crm_clocks_freq_struct.sclk_freq / 17570 ) - 1;
116
117 /* compute c1dt value to generate a duty cycle at 50% for channel 1 and 1c */
118 channel1_pulse = (uint16_t) (((uint32_t) 5 * (timer_period - 1)) / 10);
119
120 /* compute c2dt value to generate a duty cycle at 25% for channel 2 and 2c */
121 channel2_pulse = (uint16_t) (((uint32_t) 25 * (timer_period - 1)) / 100);
122
123 /* compute c3dt value to generate a duty cycle at 12.5% for channel 3 and 3c */
124 channel3_pulse = (uint16_t) (((uint32_t) 125 * (timer_period - 1)) / 1000);
125
126 tmr_base_init(TMR1, timer_period, 0);
127 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
128
129 /* channel 1, 2, 3 and 4 Configuration in output mode */
130 tmr_output_default_para_init(&tmr_output_struct);
131 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
132 tmr_output_struct.oc_output_state = TRUE;
133 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
134 tmr_output_struct.oc_idle_state = TRUE;
135 tmr_output_struct.occ_output_state = TRUE;
136 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
137 tmr_output_struct.occ_idle_state = FALSE;
138
139 /* channel 1 */
140 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
141 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, channel1_pulse);
142
143 /* channel 2 */
144 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
145 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, channel2_pulse);
146
147 /* channel 3 */
148 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
149 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, channel3_pulse);
150
151 /* automatic output enable, stop, dead time and lock configuration */
152 tmr_brkdt_default_para_init(&tmr_brkdt_config_struct);
153 tmr_brkdt_config_struct.brk_enable = TRUE;
154 tmr_brkdt_config_struct.auto_output_enable = TRUE;
155 tmr_brkdt_config_struct.deadtime = 11;
156 tmr_brkdt_config_struct.fcsodis_state = TRUE;
157 tmr_brkdt_config_struct.fcsoen_state = TRUE;
158 tmr_brkdt_config_struct.brk_polarity = TMR_BRK_INPUT_ACTIVE_HIGH;
159 tmr_brkdt_config_struct.wp_level = TMR_WP_LEVEL_3;
160 tmr_brkdt_config(TMR1, &tmr_brkdt_config_struct);
161
162 /* output enable */
163 tmr_output_enable(TMR1, TRUE);
164
165 /* enable tmr1 */
166 tmr_counter_enable(TMR1, TRUE);
167
168 while(1)
169 {
170 }
171}
172
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:38
channel1_pulse
uint16_t channel1_pulse
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:44
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:39
timer_period
uint16_t timer_period
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:43
channel2_pulse
uint16_t channel2_pulse
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:44
channel3_pulse
uint16_t channel3_pulse
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:44
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:51
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:40
tmr_brkdt_config_struct
tmr_brkdt_config_type tmr_brkdt_config_struct
Definition: project/at_start_f413/examples/tmr/complementary_signals/src/main.c:41
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f413_tmr.c:153
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time
Definition: at32f413_tmr.c:1715
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_WP_LEVEL_3
@ TMR_WP_LEVEL_3
Definition: at32f413_tmr.h:389
TMR_BRK_INPUT_ACTIVE_HIGH
@ TMR_BRK_INPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:380
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:180
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f413_tmr.h:423
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f413_tmr.h:430
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f413_tmr.h:424
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f413_tmr.h:427
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f413_tmr.h:426
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f413_tmr.h:428
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f413_tmr.h:429
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f413_tmr.h:425
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • dma
  • inc
project/at_start_f413/examples/tmr/dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • dma
  • inc
project/at_start_f413/examples/tmr/dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • dma
  • inc
project/at_start_f413/examples/tmr/dma/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • dma
  • src
project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • dma
  • src
project/at_start_f413/examples/tmr/dma/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/dma/src/at32f413_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • dma
  • src
project/at_start_f413/examples/tmr/dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 dma_init_type dma_init_struct = {0};
41 crm_clocks_freq_type crm_clocks_freq_struct = {0};
42
43uint16_t timer_period = 0;
44uint16_t src_buffer[3] = {0, 0, 0};
45
51int main(void)
52{
53 system_clock_config();
54
55 at32_board_init();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 /* turn led2/led3/led4 on */
61 at32_led_on(LED2);
62 at32_led_on(LED3);
63 at32_led_on(LED4);
64
65 /* enable tmr1/gpioa/gpiob/dma clock */
66 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
69 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
70
71 /* timer1 output pin Configuration */
72 gpio_init_struct.gpio_pins = GPIO_PINS_10;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
77 gpio_init(GPIOA, &gpio_init_struct);
78
79 gpio_init_struct.gpio_pins = GPIO_PINS_15;
80 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
81 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
82 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
83 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
84 gpio_init(GPIOB, &gpio_init_struct);
85
86 /* tmr1 dma transfer example
87 tmr1clk = system_core_clock, prescaler = 0, tmr1 counter clock = system_core_clock
88
89 the objective is to configure tmr1 channel 3 to generate complementary pwm
90 signal with a frequency equal to 17.57 khz:
91 - tmr1_period = (system_core_clock / 17570) - 1
92 and a variable duty cycle that is changed by the dma after a specific number of
93 update dma request.
94
95 the number of this repetitive requests is defined by the tmr1 repetition counter,
96 each 3 update requests, the tmr1 channel 3 duty cycle changes to the next new
97 value defined by the src_buffer. */
98 /* compute the value to be set in arr regiter to generate signal frequency at 17.57 khz */
99 timer_period = (crm_clocks_freq_struct.sclk_freq / 17570 ) - 1;
100 /* compute c1dt value to generate a duty cycle at 50% */
101 src_buffer[0] = (uint16_t) (((uint32_t) 5 * (timer_period - 1)) / 10);
102 /* compute c1dt value to generate a duty cycle at 37.5% */
103 src_buffer[1] = (uint16_t) (((uint32_t) 375 * (timer_period - 1)) / 1000);
104 /* compute c1dt value to generate a duty cycle at 25% */
105 src_buffer[2] = (uint16_t) (((uint32_t) 25 * (timer_period - 1)) / 100);
106
107 tmr_base_init(TMR1, timer_period, 0);
108 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
109
110 /* channel 3 configuration in output mode */
111 tmr_output_default_para_init(&tmr_output_struct);
112 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
113 tmr_output_struct.oc_output_state = TRUE;
114 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
115 tmr_output_struct.oc_idle_state = TRUE;
116 tmr_output_struct.occ_output_state = TRUE;
117 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
118 tmr_output_struct.occ_idle_state = FALSE;
119 /* channel 3 */
120 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
121 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, src_buffer[0]);
122
123 /* enable tmr1 overflow dma request */
124 tmr_dma_request_enable(TMR1, TMR_OVERFLOW_DMA_REQUEST, TRUE);
125
126 /* dma config for tmr1 overflow dma request */
127 /* dma1 channel5 configuration */
128 dma_reset(DMA1_CHANNEL5);
129 dma_init_struct.buffer_size = 3;
130 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
131 dma_init_struct.memory_base_addr = (uint32_t)src_buffer;
132 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
133 dma_init_struct.memory_inc_enable = TRUE;
134 dma_init_struct.peripheral_base_addr = (uint32_t)0x40012C3C;
135 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
136 dma_init_struct.peripheral_inc_enable = FALSE;
137 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
138 dma_init_struct.loop_mode_enable = TRUE;
139 dma_init(DMA1_CHANNEL5, &dma_init_struct);
140
141 dma_channel_enable(DMA1_CHANNEL5, TRUE);
142
143 /* output enable */
144 tmr_output_enable(TMR1, TRUE);
145 /* enable tmr1 */
146 tmr_counter_enable(TMR1, TRUE);
147
148 while(1)
149 {
150 }
151}
152
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:40
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:39
src_buffer
uint16_t src_buffer[3]
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:44
timer_period
uint16_t timer_period
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:51
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/dma/src/main.c:41
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:266
DMA1_CHANNEL5
#define DMA1_CHANNEL5
Definition: at32f413_dma.h:484
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1279
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f413_tmr.h:269
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:180
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • dma_burst
  • inc
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • dma_burst
  • inc
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • dma_burst
  • inc
project/at_start_f413/examples/tmr/dma_burst/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • dma_burst
  • src
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • dma_burst
  • src
project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/at32f413_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • dma_burst
  • src
project/at_start_f413/examples/tmr/dma_burst/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 dma_init_type dma_init_struct = {0};
41 crm_clocks_freq_type crm_clocks_freq_struct = {0};
42
43uint16_t timer_period = 0;
44uint16_t src_buffer[3] = {0x0FFF, 0x0000, 0x0555};
45
51int main(void)
52{
53 system_clock_config();
54
55 at32_board_init();
56
57 /* get system clock */
58 crm_clocks_freq_get(&crm_clocks_freq_struct);
59
60 /* turn led2/led3/led4 on */
61 at32_led_on(LED2);
62 at32_led_on(LED3);
63 at32_led_on(LED4);
64
65 /* enable tmr1/gpioa/gpiob/dma clock */
66 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
69 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
70
71 /* timer1 output pin Configuration */
72 gpio_init_struct.gpio_pins = GPIO_PINS_8;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
77 gpio_init(GPIOA, &gpio_init_struct);
78
79 /* tmr1 configuration: generate 1 pwm signal using the dma burst mode:
80 the tmr1clk frequency is set to system_core_clock (hz), to get tmr1 counter
81 clock at 24 mhz the prescaler is computed as following:
82 - div = (tim1clk / tmr1 counter clock) - 1
83 the tmr1 period is 5.86 khz: tmr1 frequency = tmr1 counter clock/(pr + 1)
84 = 24 mhz / 4096 = 5.86khz
85 tmr1 channel1 duty cycle = (tim1_c1dt/ tmr1_pr)* 100 = 33.33% */
86
87 tmr_base_init(TMR1, 0xFFFF, (crm_clocks_freq_struct.sclk_freq/24000000)-1);
88 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
89
90 /* channel 3 configuration in output mode */
91 tmr_output_default_para_init(&tmr_output_struct);
92 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
93 tmr_output_struct.oc_output_state = TRUE;
94 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
95 tmr_output_struct.oc_idle_state = TRUE;
96 tmr_output_struct.occ_output_state = FALSE;
97 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
98 tmr_output_struct.occ_idle_state = FALSE;
99 /* channel 3 */
100 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
101 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 0xFFF);
102
103 /* enable tmr1 overflow dma request */
104 tmr_dma_request_enable(TMR1, TMR_OVERFLOW_DMA_REQUEST, TRUE);
105 tmr_dma_control_config(TMR1, TMR_DMA_TRANSFER_3BYTES, TMR_PR_ADDRESS);
106
107 /* dma config for tmr1 overflow dma request */
108 /* dma1 channel5 configuration */
109 dma_reset(DMA1_CHANNEL5);
110 dma_init_struct.buffer_size = 3;
111 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
112 dma_init_struct.memory_base_addr = (uint32_t)src_buffer;
113 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
114 dma_init_struct.memory_inc_enable = TRUE;
115 dma_init_struct.peripheral_base_addr = (uint32_t)0x40012C4C;
116 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
117 dma_init_struct.peripheral_inc_enable = FALSE;
118 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
119 dma_init_struct.loop_mode_enable = TRUE;
120 dma_init(DMA1_CHANNEL5, &dma_init_struct);
121
122 dma_channel_enable(DMA1_CHANNEL5, TRUE);
123
124 /* output enable */
125 tmr_output_enable(TMR1, TRUE);
126 /* enable tmr1 */
127 tmr_counter_enable(TMR1, TRUE);
128
129 while(1)
130 {
131 }
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:40
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:39
src_buffer
uint16_t src_buffer[3]
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:44
timer_period
uint16_t timer_period
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:51
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/dma_burst/src/main.c:41
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:266
DMA1_CHANNEL5
#define DMA1_CHANNEL5
Definition: at32f413_dma.h:484
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_dma_control_config
void tmr_dma_control_config(tmr_type *tmr_x, tmr_dma_transfer_length_type dma_length, tmr_dma_address_type dma_base_address)
config tmr dma control
Definition: at32f413_tmr.c:1699
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1279
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_OVERFLOW_DMA_REQUEST
@ TMR_OVERFLOW_DMA_REQUEST
Definition: at32f413_tmr.h:269
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_PR_ADDRESS
@ TMR_PR_ADDRESS
Definition: at32f413_tmr.h:364
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:180
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR_DMA_TRANSFER_3BYTES
@ TMR_DMA_TRANSFER_3BYTES
Definition: at32f413_tmr.h:330
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • encoder_tmr2
  • inc
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • encoder_tmr2
  • inc
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • encoder_tmr2
  • inc
project/at_start_f413/examples/tmr/encoder_tmr2/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • encoder_tmr2
  • src
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • encoder_tmr2
  • src
project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/at32f413_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • encoder_tmr2
  • src
project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40
41void delay(uint32_t time);
42uint32_t counter;
43
49int main(void)
50{
51 system_clock_config();
52
53 at32_board_init();
54
55 /* get system clock */
56 crm_clocks_freq_get(&crm_clocks_freq_struct);
57
58 /* turn led2/led3/led4 on */
59 at32_led_on(LED2);
60 at32_led_on(LED3);
61 at32_led_on(LED4);
62
63 /* enable tmr2/gpioa clock */
64 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
66
67 /* timer1 output pin Configuration */
68 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
69 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
70 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
71 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
72 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
73 gpio_init(GPIOA, &gpio_init_struct);
74
75 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
76 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
77 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
78 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
79 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
80 gpio_init(GPIOA, &gpio_init_struct);
81
82 /* tmr2 encoder mode configuration
83 tmr2 c1ifp1 ,c2ifp2 as encoder input pin, tmr2 counter
84 changed each signal edge. */
85
86 /* enable tmr2 32bit function */
87 tmr_32_bit_function_enable(TMR2, TRUE);
88
89 tmr_base_init(TMR2, 0xFFFFFFFF, 0);
90 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
91
92 /* config encoder mode */
93 tmr_encoder_mode_config(TMR2, TMR_ENCODER_MODE_C, TMR_INPUT_RISING_EDGE, TMR_INPUT_RISING_EDGE);
94
95 /* enable tmr2 */
96 tmr_counter_enable(TMR2, TRUE);
97
98 while(1)
99 {
100 /* generate encoder signal */
101 gpio_bits_set(GPIOA, GPIO_PINS_2);
102 delay(150);
103 gpio_bits_set(GPIOA, GPIO_PINS_3);
104 delay(150);
105 gpio_bits_reset(GPIOA, GPIO_PINS_2);
106 delay(150);
107 gpio_bits_reset(GPIOA, GPIO_PINS_3);
108 delay(150);
109
110 /* get current counter value */
111 counter = tmr_counter_value_get(TMR2);
112 }
113}
114
120void delay(uint32_t time)
121{
122 uint32_t i;
123
124 for(i = 0; i < time; i++);
125}
126
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:38
delay
void delay(uint32_t time)
delay function
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:120
counter
uint32_t counter
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:42
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:49
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/encoder_tmr2/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:341
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:310
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_counter_value_get
uint32_t tmr_counter_value_get(tmr_type *tmr_x)
get tmr counter value
Definition: at32f413_tmr.c:269
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:754
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_encoder_mode_config
void tmr_encoder_mode_config(tmr_type *tmr_x, tmr_encoder_mode_type encoder_mode, tmr_input_polarity_type ic1_polarity, tmr_input_polarity_type ic2_polarity)
config tmr encoder mode
Definition: at32f413_tmr.c:1597
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_ENCODER_MODE_C
@ TMR_ENCODER_MODE_C
Definition: at32f413_tmr.h:165
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • external_clock
  • inc
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • external_clock
  • inc
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • external_clock
  • inc
project/at_start_f413/examples/tmr/external_clock/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • external_clock
  • src
project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • external_clock
  • src
project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/external_clock/src/at32f413_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • external_clock
  • src
project/at_start_f413/examples/tmr/external_clock/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40 tmr_output_config_type tmr_output_struct;
41 tmr_input_config_type tmr_input_config_struct;
42
48int main(void)
49{
50 system_clock_config();
51
52 at32_board_init();
53
54 /* get system clock */
55 crm_clocks_freq_get(&crm_clocks_freq_struct);
56
57 /* turn led2/led3/led4 on */
58 at32_led_on(LED2);
59 at32_led_on(LED3);
60 at32_led_on(LED4);
61
62 /* enable tmr2/tmr3/gpioa/gpiob clock */
63 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
65 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
67
68 /* timer2 and timer3 output pin Configuration */
69 gpio_init_struct.gpio_pins = GPIO_PINS_0;
70 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
71 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
72 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
73 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
74 gpio_init(GPIOA, &gpio_init_struct);
75 gpio_init(GPIOB, &gpio_init_struct);
76
77 gpio_init_struct.gpio_pins = GPIO_PINS_7;
78 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
81 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
82 gpio_init(GPIOA, &gpio_init_struct);
83
84 /* use tmr2 generate clock to drive tmr3
85 tmr2 pwm frequency = 192000000(systemclock)/192(period+1)/1000(div+1) = 1 khz
86 tmr3 pwm frequency = 1000(tmr2 pwm frequency)/10(period+1)/1(div+1) = 100 hz */
87
88 /* tmr2 and tmr3 counter mode configuration */
89 tmr_base_init(TMR2, 191, 999);
90 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
91
92 tmr_base_init(TMR3, 9, 0);
93 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
94
95 /* tmr2 and tmr3 output mode configuration */
96 tmr_output_default_para_init(&tmr_output_struct);
97 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
98 tmr_output_struct.oc_output_state = TRUE;
99 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
100 tmr_output_struct.oc_idle_state = TRUE;
101 tmr_output_struct.occ_output_state = FALSE;
102 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
103 tmr_output_struct.occ_idle_state = FALSE;
104 /* tmr2 channel 1 */
105 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
106 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, 96);
107 /* tmr3 channel 3 */
108 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
109 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, 5);
110
111 /* configure tmr3 channel2 to get clock signal */
112 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_2;
113 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
114 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
115 tmr_input_channel_init(TMR3, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
116
117 /* select the tmr3 input trigger: C2IF2 */
118 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_C2DF2);
119
120 /* select the slave mode: external mode a */
121 tmr_sub_mode_select(TMR3, TMR_SUB_EXTERNAL_CLOCK_MODE_A);
122
123 /* enable tmr2 */
124 tmr_counter_enable(TMR2, TRUE);
125
126 /* enable tmr3 */
127 tmr_counter_enable(TMR3, TRUE);
128
129 while(1)
130 {
131 }
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:48
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:41
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/external_clock/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:807
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:239
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:139
TMR_SUB_EXTERNAL_CLOCK_MODE_A
@ TMR_SUB_EXTERNAL_CLOCK_MODE_A
Definition: at32f413_tmr.h:155
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:249
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • hall_xor_tmr2
  • inc
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • hall_xor_tmr2
  • inc
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • hall_xor_tmr2
  • inc
project/at_start_f413/examples/tmr/hall_xor_tmr2/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • hall_xor_tmr2
  • src
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • hall_xor_tmr2
  • src
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • hall_xor_tmr2
  • src
project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40 tmr_output_config_type tmr_output_struct;
41 tmr_input_config_type tmr_input_config_struct;
42
48int main(void)
49{
50 system_clock_config();
51
52 at32_board_init();
53
54 /* get system clock */
55 crm_clocks_freq_get(&crm_clocks_freq_struct);
56
57 /* turn led2/led3/led4 on */
58 at32_led_on(LED2);
59 at32_led_on(LED3);
60 at32_led_on(LED4);
61
62 /* enable tmr2/tmr3/gpioa/gpiob clock */
63 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* tmr2 channel1 ,channel2 and channel3 configuration */
67 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2;
68 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
69 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
70 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init(GPIOA, &gpio_init_struct);
73
74 /* hall signal (pa3 ,pa6 ,pa7) and trigger flag signal(pa8) configuration */
75 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8;
76 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
77 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
78 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
79 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
80 gpio_init(GPIOA, &gpio_init_struct);
81
82 /* tmr2 xor mode configuration
83 tmr2 channel1 ,channel2 and channel3 as hall signal input channel, trigger
84 generated each signal edge. */
85
86 /* tmr2 and tmr3 counter mode configuration */
87 tmr_32_bit_function_enable(TMR2, TRUE);
88
89 tmr_base_init(TMR2, 0xFFFFFFFF, 0);
90 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
91
92 /* config ti1 trc as input source */
93 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_1;
94 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_STI;
95 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
96 tmr_input_channel_init(TMR2, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
97
98 /* xor funtion enable */
99 tmr_channel1_input_select(TMR2, TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR);
100
101 /* select the tmr2 input trigger: C1INC */
102 tmr_trigger_input_select(TMR2, TMR_SUB_INPUT_SEL_C1INC);
103
104 /* select the slave mode: reset mode */
105 tmr_sub_mode_select(TMR2, TMR_SUB_RESET_MODE);
106
107 tmr_interrupt_enable(TMR2, TMR_TRIGGER_INT, TRUE);
108
109 /* tmr2 trigger interrupt nvic init */
110 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
111 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
112
113 /* enable tmr2 */
114 tmr_counter_enable(TMR2, TRUE);
115
116 while(1)
117 {
118 /* generate hall signal */
119 gpio_bits_set(GPIOA, GPIO_PINS_3);
120 delay_us(10);
121 gpio_bits_set(GPIOA, GPIO_PINS_6);
122 delay_us(10);
123 gpio_bits_set(GPIOA, GPIO_PINS_7);
124 delay_us(10);
125 gpio_bits_reset(GPIOA, GPIO_PINS_3);
126 delay_us(10);
127 gpio_bits_reset(GPIOA, GPIO_PINS_6);
128 delay_us(10);
129 gpio_bits_reset(GPIOA, GPIO_PINS_7);
130 delay_us(10);
131 }
132}
133
139void TMR2_GLOBAL_IRQHandler(void)
140{
141 if(tmr_flag_get(TMR2, TMR_TRIGGER_FLAG) != RESET)
142 {
143 GPIOA->odt ^= GPIO_PINS_8;
144 tmr_flag_clear(TMR2, TMR_TRIGGER_FLAG);
145 }
146}
147
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:40
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles TMR2 trigger exception.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:139
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:48
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:41
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/hall_xor_tmr2/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:162
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:341
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:310
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:807
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_channel1_input_select
void tmr_channel1_input_select(tmr_type *tmr_x, tmr_channel1_input_connected_type ti1_connect)
select tmr channel1 input
Definition: at32f413_tmr.c:1085
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:754
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
@ TMR_CHANEL1_2_3_CONNECTED_C1IRAW_XOR
Definition: at32f413_tmr.h:231
TMR_CC_CHANNEL_MAPPED_STI
@ TMR_CC_CHANNEL_MAPPED_STI
Definition: at32f413_tmr.h:241
TMR_SUB_INPUT_SEL_C1INC
@ TMR_SUB_INPUT_SEL_C1INC
Definition: at32f413_tmr.h:137
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f413_tmr.h:152
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:249
TMR_TRIGGER_FLAG
#define TMR_TRIGGER_FLAG
Definition: at32f413_tmr.h:58
TMR_TRIGGER_INT
#define TMR_TRIGGER_INT
Definition: at32f413_tmr.h:80
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • hang_mode
  • inc
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • hang_mode
  • inc
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • hang_mode
  • inc
project/at_start_f413/examples/tmr/hang_mode/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • hang_mode
  • src
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • hang_mode
  • src
project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/at32f413_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • hang_mode
  • src
project/at_start_f413/examples/tmr/hang_mode/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40 tmr_output_config_type tmr_output_struct;
41 tmr_input_config_type tmr_input_config_struct;
42
48int main(void)
49{
50 system_clock_config();
51
52 at32_board_init();
53
54 /* get system clock */
55 crm_clocks_freq_get(&crm_clocks_freq_struct);
56
57 /* turn led2/led3/led4 on */
58 at32_led_on(LED2);
59 at32_led_on(LED3);
60 at32_led_on(LED4);
61
62 /* enable tmr1/gpioa clock */
63 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* timer1 output pin configuration */
67 gpio_init_struct.gpio_pins = GPIO_PINS_8;
68 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
69 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
70 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init(GPIOA, &gpio_init_struct);
73
74 gpio_init_struct.gpio_pins = GPIO_PINS_9;
75 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
76 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
77 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
78 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
79 gpio_init(GPIOA, &gpio_init_struct);
80
81 /* hang mode test
82 1/tmr1 is configured as master timer:
83 - toggle mode is used
84
85 2/tmr1 is configured as slave timer for an external trigger connected
86 to tmr1 ti2 pin (tmr1 ch2 configured as input pin):
87 - the tmr1 ti2fp2 is used as trigger input
88 - rising edge is used to start and stop the tmr1: hang mode.
89
90 the tmr1 are running at:
91 tmrx frequency = tmrx clock counter/ 2*(timx_period + 1) = 500 khz.
92 */
93
94 tmr_base_init(TMR1, 191, 0);
95 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
96
97 /* tmr1 output mode configuration */
98 tmr_output_default_para_init(&tmr_output_struct);
99 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_SWITCH;
100 tmr_output_struct.oc_output_state = TRUE;
101 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
102 tmr_output_struct.oc_idle_state = TRUE;
103 tmr_output_struct.occ_output_state = FALSE;
104 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
105 tmr_output_struct.occ_idle_state = FALSE;
106 /* tmr1 channel 1 */
107 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
108 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 50);
109
110 /* configure tmr1 channel2 to get hang signal */
111 tmr_input_default_para_init(&tmr_input_config_struct);
112 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_2;
113 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
114 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
115 tmr_input_channel_init(TMR1, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
116
117 /* select the tmr1 input trigger: c2df2 */
118 tmr_trigger_input_select(TMR1, TMR_SUB_INPUT_SEL_C2DF2);
119
120 /* select the slave mode: hang mode */
121 tmr_sub_mode_select(TMR1, TMR_SUB_HANG_MODE);
122
123 /* output enable */
124 tmr_output_enable(TMR1, TRUE);
125
126 /* enable tmr1 */
127 tmr_counter_enable(TMR1, TRUE);
128
129 while(1)
130 {
131 }
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:48
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:41
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/hang_mode/src/main.c:39
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:807
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:139
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:239
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f413_tmr.h:176
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:139
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:153
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:249
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • input_capture
  • inc
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • input_capture
  • inc
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • input_capture
  • inc
project/at_start_f413/examples/tmr/input_capture/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • input_capture
  • src
project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • input_capture
  • src
project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • input_capture
  • src
project/at_start_f413/examples/tmr/input_capture/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40 tmr_input_config_type tmr_input_config_struct;
41void uart_init(uint32_t baudrate);
42__IO uint32_t tmr3freq = 0;
43__IO uint32_t sys_counter = 0;
44__IO uint16_t capturenumber = 0;
45__IO uint16_t ch3readvalue1 = 0, ch3readvalue2 = 0;
46__IO uint32_t capture = 0;
47
53void TMR3_GLOBAL_IRQHandler(void)
54{
55 if(tmr_flag_get(TMR3, TMR_C2_FLAG) != RESET)
56 {
57 tmr_flag_clear(TMR3, TMR_C2_FLAG);
58 if(capturenumber == 0)
59 {
60 /* get the Input Capture value */
61 ch3readvalue1 = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
62 capturenumber = 1;
63 }
64 else if(capturenumber == 1)
65 {
66 /* get the Input Capture value */
67 ch3readvalue2 = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
68
69 /* capture computation */
70 if(ch3readvalue2 > ch3readvalue1)
71 {
72 capture = (ch3readvalue2 - ch3readvalue1);
73 }
74 else
75 {
76 capture = ((0xFFFF - ch3readvalue1) + ch3readvalue2);
77 }
78
79 /* frequency computation */
80 tmr3freq = (uint32_t) crm_clocks_freq_struct.sclk_freq / capture;
81 capturenumber = 0;
82 }
83 }
84}
85
91int main(void)
92{
93 system_clock_config();
94
95 at32_board_init();
96
97 uart_print_init(115200);
98
99 /* get system clock */
100 crm_clocks_freq_get(&crm_clocks_freq_struct);
101
102 /* turn led2/led3/led4 on */
103 at32_led_on(LED2);
104 at32_led_on(LED3);
105 at32_led_on(LED4);
106
107 /* enable tmr3/gpioa clock */
108 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
109 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
110
111 /* timer3 input pin Configuration */
112 gpio_init_struct.gpio_pins = GPIO_PINS_7;
113 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
114 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
115 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
116 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
117 gpio_init(GPIOA, &gpio_init_struct);
118
119 /* tmr3 configuration: input capture mode
120 the external signal is connected to tmr3 ch2 pin (pa.07)
121 the rising edge is used as active edge,
122 the tmr3 c2dt is used to compute the frequency value */
123
124 /* tmr3 counter mode configuration */
125 tmr_base_init(TMR3, 0xFFFF, 0);
126 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
127
128 /* configure tmr3 channel2 to get clock signal */
129 tmr_input_config_struct.input_channel_select = TMR_SELECT_CHANNEL_2;
130 tmr_input_config_struct.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
131 tmr_input_config_struct.input_polarity_select = TMR_INPUT_RISING_EDGE;
132 tmr_input_channel_init(TMR3, &tmr_input_config_struct, TMR_CHANNEL_INPUT_DIV_1);
133
134 tmr_interrupt_enable(TMR3, TMR_C2_INT, TRUE);
135
136 /* tmr2 trigger interrupt nvic init */
137 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
138 nvic_irq_enable(TMR3_GLOBAL_IRQn, 0, 0);
139
140 /* enable tmr3 */
141 tmr_counter_enable(TMR3, TRUE);
142
143 while(1)
144 {
145 delay_ms(100);
146 printf("The external signal frequece is : %d\r\n",tmr3freq);
147 tmr3freq = 0;
148 }
149}
150
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:38
ch3readvalue2
__IO uint16_t ch3readvalue2
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:45
ch3readvalue1
__IO uint16_t ch3readvalue1
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:45
tmr3freq
__IO uint32_t tmr3freq
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:42
capturenumber
__IO uint16_t capturenumber
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:44
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
this function handles tmr3 trigger exception.
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:53
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:91
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
tmr_input_config_struct
tmr_input_config_type tmr_input_config_struct
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:40
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:39
sys_counter
__IO uint32_t sys_counter
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:43
capture
__IO uint32_t capture
Definition: project/at_start_f413/examples/tmr/input_capture/src/main.c:46
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:163
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:547
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:807
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:239
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:249
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:54
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:76
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • oc_high
  • inc
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • oc_high
  • inc
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • oc_high
  • inc
project/at_start_f413/examples/tmr/oc_high/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • oc_high
  • src
project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • oc_high
  • src
project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
140void TMR2_GLOBAL_IRQHandler(void)
141{
142 if(tmr_flag_get(TMR2, TMR_C1_FLAG) != RESET)
143 {
144 /* clear tmr2 channel1 interrupt pending bit */
145 tmr_flag_clear(TMR2, TMR_C1_FLAG);
146
147 /* pc.06 turnoff after 1000 ms */
148 gpio_bits_reset(GPIOC, GPIO_PINS_6);
149 }
150 else if(tmr_flag_get(TMR2, TMR_C2_FLAG) != RESET)
151 {
152 /* clear tmr2 channel2 interrupt pending bit */
153 tmr_flag_clear(TMR2, TMR_C2_FLAG);
154
155 /* pc.07 turnoff after 500 ms */
156 gpio_bits_reset(GPIOC, GPIO_PINS_7);
157 }
158 else if(tmr_flag_get(TMR2, TMR_C3_FLAG) != RESET)
159 {
160 /* clear tmr2 channel3 interrupt pending bit */
161 tmr_flag_clear(TMR2, TMR_C3_FLAG);
162
163 /* pc.08 turnoff after 250 ms */
164 gpio_bits_reset(GPIOC, GPIO_PINS_8);
165 }
166 else
167 {
168 /* clear tmr2 channel4 interrupt pending bit */
169 tmr_flag_clear(TMR2, TMR_C4_FLAG);
170
171 /* pc.09 turnoff after 125 ms */
172 gpio_bits_reset(GPIOC, GPIO_PINS_9);
173 }
174}
175
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:104
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles tmr2 global interrupt request.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:140
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/oc_high/src/at32f413_int.c:113
RESET
@ RESET
Definition: at32f413.h:254
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:341
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:54
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f413_tmr.h:55
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:56
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • oc_high
  • src
project/at_start_f413/examples/tmr/oc_high/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 crm_clocks_freq_type crm_clocks_freq_struct = {0};
40uint16_t ch1_val = 1000;
41uint16_t ch2_val = 500;
42uint16_t ch3_val = 250;
43uint16_t ch4_val = 125;
44uint16_t div_value = 0;
45
46void gpio_configuration(void);
47
53void gpio_configuration(void)
54{
55 gpio_init_type gpio_init_struct;
56
57 gpio_default_para_init(&gpio_init_struct);
58
59 /* gpioc configuration: pin6, 7, 8 and 9 as output push-pull */
60 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9;
61 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
62 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
63 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
64 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
65
66 gpio_init(GPIOC, &gpio_init_struct);
67}
68
74int main(void)
75{
76 /* config nvic priority group */
77 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
78
79 system_clock_config();
80
81 at32_board_init();
82
83 /* get system clock */
84 crm_clocks_freq_get(&crm_clocks_freq_struct);
85
86 crm_apb1_div_set(CRM_APB1_DIV_8);
87 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
88 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
89
90 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
91
92 gpio_configuration();
93
94 /* compute the div value */
95 div_value = (uint16_t)(crm_clocks_freq_struct.sclk_freq / 4000) - 1;
96
97 /* tmr2 time base configuration */
98 tmr_base_init(TMR2, 0xFFFF, div_value);
99 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
100 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
101
102 tmr_output_default_para_init(&tmr_oc_init_structure);
103 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_HIGH;
104 tmr_oc_init_structure.oc_idle_state = FALSE;
105 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
106 tmr_oc_init_structure.oc_output_state = TRUE;
107 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
108 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ch1_val);
109
110 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
111 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ch2_val);
112
113 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
114 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ch3_val);
115
116 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
117 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ch4_val);
118
119 tmr_period_buffer_enable(TMR2, TRUE);
120
121 /* tmr2 int enable */
122 tmr_interrupt_enable(TMR2, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
123
124 /* set pc.06, pc.07, pc.08 and pc.09 pins */
125 gpio_bits_set(GPIOC, GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9);
126
127 /* tmr2 enable counter */
128 tmr_counter_enable(TMR2, TRUE);
129
130 while(1)
131 {
132 }
133}
134
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ch4_val
uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:43
ch3_val
uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:42
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:74
ch2_val
uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:41
gpio_configuration
void gpio_configuration(void)
configure the gpioc pins.
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:53
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:38
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:39
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:44
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:112
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_APB1_DIV_8
@ CRM_APB1_DIV_8
Definition: at32f413_crm.h:325
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:162
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:310
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:588
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_HIGH
@ TMR_OUTPUT_CONTROL_HIGH
Definition: at32f413_tmr.h:174
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f413_tmr.h:77
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:78
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:75
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:76
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • oc_low
  • inc
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • oc_low
  • inc
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • oc_low
  • inc
project/at_start_f413/examples/tmr/oc_low/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • oc_low
  • src
project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • oc_low
  • src
project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
140void TMR2_GLOBAL_IRQHandler(void)
141{
142 if(tmr_flag_get(TMR2, TMR_C1_FLAG) != RESET)
143 {
144 /* clear tmr2 channel1 interrupt pending bit */
145 tmr_flag_clear(TMR2, TMR_C1_FLAG);
146
147 /* pc.06 turnoff after 1000 ms */
148 gpio_bits_reset(GPIOC, GPIO_PINS_6);
149 }
150 else if(tmr_flag_get(TMR2, TMR_C2_FLAG) != RESET)
151 {
152 /* clear tmr2 channel2 interrupt pending bit */
153 tmr_flag_clear(TMR2, TMR_C2_FLAG);
154
155 /* pc.07 turnoff after 500 ms */
156 gpio_bits_reset(GPIOC, GPIO_PINS_7);
157 }
158 else if(tmr_flag_get(TMR2, TMR_C3_FLAG) != RESET)
159 {
160 /* clear tmr2 channel3 interrupt pending bit */
161 tmr_flag_clear(TMR2, TMR_C3_FLAG);
162
163 /* pc.08 turnoff after 250 ms */
164 gpio_bits_reset(GPIOC, GPIO_PINS_8);
165 }
166 else
167 {
168 /* clear tmr2 channel4 interrupt pending bit */
169 tmr_flag_clear(TMR2, TMR_C4_FLAG);
170
171 /* pc.09 turnoff after 125 ms */
172 gpio_bits_reset(GPIOC, GPIO_PINS_9);
173 }
174}
175
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:104
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
this function handles tmr2 global interrupt request.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:140
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/oc_low/src/at32f413_int.c:113
RESET
@ RESET
Definition: at32f413.h:254
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:341
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:54
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f413_tmr.h:55
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:56
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • oc_low
  • src
project/at_start_f413/examples/tmr/oc_low/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39uint16_t ch1_val = 1000;
40uint16_t ch2_val = 500;
41uint16_t ch3_val = 250;
42uint16_t ch4_val = 125;
43uint16_t div_value = 0;
44
45void gpio_configuration(void);
46
52void gpio_configuration(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 /* gpioc configuration: pin6, 7, 8 and 9 as output push-pull */
57 gpio_default_para_init(&gpio_init_struct);
58 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9;
59 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63
64 gpio_init(GPIOC, &gpio_init_struct);
65}
66
72int main(void)
73{
74 /* config nvic priority group */
75 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
76
77 system_clock_config();
78
79 at32_board_init();
80
81 crm_apb1_div_set(CRM_APB1_DIV_8);
82 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
83 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
84
85 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
86
87 gpio_configuration();
88
89 /* compute the div value */
90 div_value = (uint16_t)(system_core_clock / 4000) - 1;
91
92 /* tmr2 time base configuration */
93 tmr_base_init(TMR2, 65535, div_value);
94 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
95 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
96
97 tmr_output_default_para_init(&tmr_oc_init_structure);
98 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_LOW;
99 tmr_oc_init_structure.oc_idle_state = FALSE;
100 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
101 tmr_oc_init_structure.oc_output_state = TRUE;
102 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
103 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ch1_val);
104
105 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
106 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ch2_val);
107
108 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
109 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ch3_val);
110
111 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
112 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ch4_val);
113
114 tmr_period_buffer_enable(TMR2, TRUE);
115
116 /* tmr2 int enable */
117 tmr_interrupt_enable(TMR2, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
118
119 /* set pc.06, pc.07, pc.08 and pc.09 pins */
120 gpio_bits_set(GPIOC, GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9);
121
122 /* tmr2 enable counter */
123 tmr_counter_enable(TMR2, TRUE);
124
125 while(1)
126 {
127 }
128}
129
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ch4_val
uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:42
ch3_val
uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:41
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:72
ch2_val
uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:40
gpio_configuration
void gpio_configuration(void)
configure the gpioc pins.
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:52
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:38
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_low/src/main.c:43
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:112
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_APB1_DIV_8
@ CRM_APB1_DIV_8
Definition: at32f413_crm.h:325
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:162
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:310
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:588
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_LOW
@ TMR_OUTPUT_CONTROL_LOW
Definition: at32f413_tmr.h:175
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f413_tmr.h:77
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:78
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:75
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:76
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • oc_toggle_tmr3
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • oc_toggle_tmr3
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • oc_toggle_tmr3
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr3/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • oc_toggle_tmr3
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • oc_toggle_tmr3
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30extern __IO uint16_t ch1_val;
31extern __IO uint16_t ch2_val;
32extern __IO uint16_t ch3_val;
33extern __IO uint16_t ch4_val;
34
43uint32_t capture = 0;
44
50void NMI_Handler(void)
51{
52}
53
59void HardFault_Handler(void)
60{
61 /* go to infinite loop when hard fault exception occurs */
62 while(1)
63 {
64 }
65}
66
72void MemManage_Handler(void)
73{
74 /* go to infinite loop when memory manage exception occurs */
75 while(1)
76 {
77 }
78}
79
85void BusFault_Handler(void)
86{
87 /* go to infinite loop when bus fault exception occurs */
88 while(1)
89 {
90 }
91}
92
98void UsageFault_Handler(void)
99{
100 /* go to infinite loop when usage fault exception occurs */
101 while(1)
102 {
103 }
104}
105
111void SVC_Handler(void)
112{
113}
114
120void DebugMon_Handler(void)
121{
122}
123
129void PendSV_Handler(void)
130{
131}
132
138void SysTick_Handler(void)
139{
140}
141
147void TMR3_GLOBAL_IRQHandler(void)
148{
149 /* TMR3_CH1 toggling with frequency = 183.1 Hz */
150 if(tmr_flag_get(TMR3, TMR_C1_FLAG) != RESET)
151 {
152 tmr_flag_clear(TMR3, TMR_C1_FLAG );
153 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_1);
154 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, capture + ch1_val);
155 }
156
157 /* TMR3_CH2 toggling with frequency = 366.2 Hz */
158 if(tmr_flag_get(TMR3, TMR_C2_FLAG) != RESET)
159 {
160 tmr_flag_clear(TMR3, TMR_C2_FLAG);
161 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
162 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_2, capture + ch2_val);
163 }
164
165 /* TMR3_CH3 toggling with frequency = 732.4 Hz */
166 if(tmr_flag_get(TMR3, TMR_C3_FLAG) != RESET)
167 {
168 tmr_flag_clear(TMR3, TMR_C3_FLAG);
169 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_3);
170 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, capture + ch3_val);
171 }
172
173 /* TMR3_CH4 toggling with frequency = 1464.8 Hz */
174 if(tmr_flag_get(TMR3, TMR_C4_FLAG) != RESET)
175 {
176 tmr_flag_clear(TMR3, TMR_C4_FLAG);
177 capture = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_4);
178 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_4, capture + ch4_val);
179 }
180}
181
ch4_val
__IO uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:43
ch3_val
__IO uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:42
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:40
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:41
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:98
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:59
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:72
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:111
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:129
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:50
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
this function handles tmr3 global interrupt request.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:147
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:85
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:138
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:120
capture
uint32_t capture
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/at32f413_int.c:43
RESET
@ RESET
Definition: at32f413.h:254
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:547
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:54
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f413_tmr.h:55
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:56
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • oc_toggle_tmr3
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39__IO uint16_t ch1_val = 32768;
40__IO uint16_t ch2_val = 16384;
41__IO uint16_t ch3_val = 8192;
42__IO uint16_t ch4_val = 4096;
43uint16_t div_value = 0;
44
45void crm_configuration(void);
46void gpio_configuration(void);
47void nvic_configuration(void);
48
54void gpio_configuration(void)
55{
56 gpio_init_type gpio_init_struct;
57
58 /* gpioa configuration:tmr3 channel1, 2, 3 and 4 as alternate function push-pull */
59 gpio_default_para_init(&gpio_init_struct);
60 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7;
61 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
62 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
63 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
64 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
65
66 gpio_init(GPIOA, &gpio_init_struct);
67
68 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
69 gpio_init(GPIOB, &gpio_init_struct);
70
71}
72
78void crm_configuration(void)
79{
80 /* tmr3 clock enable */
81 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
82
83 /* gpioa clock enable */
84 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
85 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
86}
87
93int main(void)
94{
95 system_clock_config();
96
97 /* peripheral clocks configuration */
98 crm_configuration();
99
100 /* nvic configuration */
101 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
102 nvic_irq_enable(TMR3_GLOBAL_IRQn, 0, 0);
103
104 /* gpio configuration */
105 gpio_configuration();
106
107 /* tmr3 configuration: output compare toggle mode:
108 tmr3clk = system_core_clock,
109 the objective is to get tmr3 counter clock at 24 mhz:
110 - div = (tmr3clk / tmr3 counter clock) - 1
111 cc1 update rate = tmr3 counter clock / ch1_val / 2 = 366.2 hz
112 cc2 update rate = tmr3 counter clock / ch2_val / 2 = 732.4 hz
113 cc3 update rate = tmr3 counter clock / ch3_val / 2 = 1464.8 hz
114 cc4 update rate = tmr3 counter clock / ch4_val / 2 = 2929.6 hz */
115
116 /* compute the div value */
117 div_value = (uint16_t)(system_core_clock / 24000000) - 1;
118
119 /* tmre base configuration */
120 tmr_base_init(TMR3, 65535, div_value);
121 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
122 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
123
124 /* output compare toggle mode configuration: channel1 */
125 tmr_output_default_para_init(&tmr_oc_init_structure);
126 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_SWITCH;
127 tmr_oc_init_structure.oc_idle_state = FALSE;
128 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
129 tmr_oc_init_structure.oc_output_state = TRUE;
130 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
131 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, ch1_val);
132
133 /* output compare toggle mode configuration: channel2 */
134 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
135 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_2, ch2_val);
136
137 /* output compare toggle mode configuration: channel3 */
138 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
139 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, ch3_val);
140
141 /* output compare toggle mode configuration: channel4 */
142 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
143 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_4, ch4_val);
144
145 /* tmr enable counter */
146 tmr_counter_enable(TMR3, TRUE);
147
148 /* tmr it enable */
149 tmr_interrupt_enable(TMR3, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
150
151 while(1)
152 {
153 }
154}
155
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:93
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:54
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:38
ch3_val
__IO uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:41
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:78
ch4_val
__IO uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:42
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:43
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr3/src/main.c:40
nvic_configuration
void nvic_configuration(void)
configures the nested vectored interrupt controller.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:48
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:163
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f413_tmr.h:176
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f413_tmr.h:77
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:78
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:75
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:76
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • oc_toggle_tmr9
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • oc_toggle_tmr9
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • oc_toggle_tmr9
  • inc
project/at_start_f413/examples/tmr/oc_toggle_tmr9/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • oc_toggle_tmr9
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • oc_toggle_tmr9
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30extern __IO uint16_t ch1_val;
31extern __IO uint16_t ch2_val;
32
41uint16_t capture = 0;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void TMR1_BRK_TMR9_IRQHandler(void)
146{
147 /* TMR9_CH1 toggling with frequency = 366.2 Hz */
148 if(tmr_flag_get(TMR9, TMR_C1_FLAG) != RESET)
149 {
150 tmr_flag_clear(TMR9, TMR_C1_FLAG );
151 capture = tmr_channel_value_get(TMR9, TMR_SELECT_CHANNEL_1);
152 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_1, capture + ch1_val);
153 }
154
155 /* TMR9_CH2 toggling with frequency = 732.4 Hz */
156 if(tmr_flag_get(TMR9, TMR_C2_FLAG) != RESET)
157 {
158 tmr_flag_clear(TMR9, TMR_C2_FLAG);
159 capture = tmr_channel_value_get(TMR9, TMR_SELECT_CHANNEL_2);
160 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_2, capture + ch2_val);
161 }
162}
163
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:40
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:41
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:70
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:109
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:48
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:83
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:136
TMR1_BRK_TMR9_IRQHandler
void TMR1_BRK_TMR9_IRQHandler(void)
this function handles TMR9 global interrupt request.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:145
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:118
capture
uint16_t capture
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/at32f413_int.c:41
RESET
@ RESET
Definition: at32f413.h:254
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:547
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:54
TMR9
#define TMR9
Definition: at32f413_tmr.h:838
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • oc_toggle_tmr9
  • src
project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39__IO uint16_t ch1_val = 32768;
40__IO uint16_t ch2_val = 16384;
41uint16_t div_value = 0;
42
43void crm_configuration(void);
44void gpio_configuration(void);
45void nvic_configuration(void);
46
52void gpio_configuration(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 /* gpioa configuration:tmr9 channel1 and 2 as alternate function push-pull */
57 gpio_default_para_init(&gpio_init_struct);
58 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_3;
59 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
60 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
61 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63
64 gpio_init(GPIOA, &gpio_init_struct);
65}
66
72void crm_configuration(void)
73{
74 /* tmr9 clock enable */
75 crm_periph_clock_enable(CRM_TMR9_PERIPH_CLOCK, TRUE);
76
77 /* gpioa clock enable */
78 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
79}
80
86int main(void)
87{
88 system_clock_config();
89
90 /* peripheral clocks configuration */
91 crm_configuration();
92
93 /* nvic configuration */
94 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
95 nvic_irq_enable(TMR1_BRK_TMR9_IRQn, 0, 0);
96
97 /* gpio configuration */
98 gpio_configuration();
99
100 /* tmr9 configuration: output compare toggle mode:
101 tmr9clk = system_core_clock,
102 the objective is to get tmr9 counter clock at 24 mhz:
103 - div_value = (tmr9clk / tmr9 counter clock) - 1
104 cc1 update rate = tmr9 counter clock / ch1val / 2 = 366.2 hz
105 cc2 update rate = tmr9 counter clock / ch2val / 2 = 732.4 hz */
106
107 /* compute the div value */
108 div_value = (uint16_t) (system_core_clock / 24000000) - 1;
109
110 /* tmr base configuration */
111 tmr_base_init(TMR9, 65535, div_value);
112 tmr_cnt_dir_set(TMR9, TMR_COUNT_UP);
113 tmr_clock_source_div_set(TMR9, TMR_CLOCK_DIV1);
114
115 /* output compare toggle mode configuration: channel1 */
116 tmr_output_default_para_init(&tmr_oc_init_structure);
117 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_SWITCH;
118 tmr_oc_init_structure.oc_idle_state = FALSE;
119 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
120 tmr_oc_init_structure.oc_output_state = TRUE;
121 tmr_output_channel_config(TMR9, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
122 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_1, ch1_val);
123
124 /* output toggle mode configuration: channel2 */
125 tmr_output_channel_config(TMR9, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
126 tmr_channel_value_set(TMR9, TMR_SELECT_CHANNEL_2, ch2_val);
127
128 /* tmr enable counter */
129 tmr_counter_enable(TMR9, TRUE);
130
131 /* tmr interrupt enable */
132 tmr_interrupt_enable(TMR9, TMR_C1_INT | TMR_C2_INT, TRUE);
133
134 while(1)
135 {
136 }
137}
138
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:86
gpio_configuration
void gpio_configuration(void)
configure the tmr9 pins.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:52
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:72
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:41
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_toggle_tmr9/src/main.c:40
nvic_configuration
void nvic_configuration(void)
configures the nested vectored interrupt controller.
Definition: project/at_start_f413/examples/rtc/lick_calibration/src/main.c:48
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR9_PERIPH_CLOCK
@ CRM_TMR9_PERIPH_CLOCK
Definition: at32f413_crm.h:121
TMR1_BRK_TMR9_IRQn
@ TMR1_BRK_TMR9_IRQn
Definition: at32f413.h:158
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_SWITCH
@ TMR_OUTPUT_CONTROL_SWITCH
Definition: at32f413_tmr.h:176
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:75
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:76
TMR9
#define TMR9
Definition: at32f413_tmr.h:838
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • one_cycle
  • inc
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • one_cycle
  • inc
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • one_cycle
  • inc
project/at_start_f413/examples/tmr/one_cycle/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • one_cycle
  • src
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • one_cycle
  • src
project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • one_cycle
  • src
project/at_start_f413/examples/tmr/one_cycle/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39 tmr_input_config_type tmr_ic_init_structure;
40uint16_t div_value = 0;
41
42void crm_configuration(void);
43void gpio_configuration(void);
44
50void gpio_configuration(void)
51{
52 gpio_init_type gpio_init_struct;
53
54 gpio_default_para_init(&gpio_init_struct);
55
56 /* tmr4_ch2 pin (pb.07) configuration */
57 gpio_init_struct.gpio_pins = GPIO_PINS_7;
58 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
59 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
60 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
61 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
62 gpio_init(GPIOB, &gpio_init_struct);
63
64 /* tmr4_ch1 pin (pb.06) configuration */
65 gpio_init_struct.gpio_pins = GPIO_PINS_6;
66 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
67 gpio_init(GPIOB, &gpio_init_struct);
68}
69
75void crm_configuration(void)
76{
77 /* tmr3 clock enable */
78 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
79
80 /* gpioa clock enable */
81 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
82}
83
89int main(void)
90{
91 system_clock_config();
92
93 /* peripheral clocks configuration */
94 crm_configuration();
95
96 /* gpio configuration */
97 gpio_configuration();
98
99 /* compute the div value */
100 div_value = (uint16_t)(system_core_clock / 24000000) - 1;
101
102 /* tmr base configuration */
103 tmr_base_init(TMR4, 65535, div_value);
104 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
105 tmr_clock_source_div_set(TMR4, TMR_CLOCK_DIV1);
106
107 /* output compare toggle mode configuration: channel1 */
108 tmr_output_default_para_init(&tmr_oc_init_structure);
109 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
110 tmr_oc_init_structure.oc_idle_state = FALSE;
111 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
112 tmr_oc_init_structure.oc_output_state = TRUE;
113 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
114 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 16383);
115
116 tmr_input_default_para_init(&tmr_ic_init_structure);
117 tmr_ic_init_structure.input_filter_value = 0;
118 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_2;
119 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
120 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
121 tmr_input_channel_init(TMR4, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
122
123 /* one cycle mode selection */
124 tmr_one_cycle_mode_enable(TMR4, TRUE);
125
126 /* input trigger selection */
127 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_C2DF2);
128
129 /* slave mode selection: trigger mode */
130 tmr_sub_mode_select(TMR4, TMR_SUB_TRIGGER_MODE);
131
132 while(1)
133 {
134 }
135}
136
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:89
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:50
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:39
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:75
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/one_cycle/src/main.c:40
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:128
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_input_channel_init
void tmr_input_channel_init(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
init tmr input channel
Definition: at32f413_tmr.c:807
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:139
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_one_cycle_mode_enable
void tmr_one_cycle_mode_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr one cycle mode
Definition: at32f413_tmr.c:740
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:239
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:139
TMR_SUB_TRIGGER_MODE
@ TMR_SUB_TRIGGER_MODE
Definition: at32f413_tmr.h:154
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:249
TMR4
#define TMR4
Definition: at32f413_tmr.h:835
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:416
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • parallel_synchro
  • inc
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • parallel_synchro
  • inc
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • parallel_synchro
  • inc
project/at_start_f413/examples/tmr/parallel_synchro/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • parallel_synchro
  • src
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • parallel_synchro
  • src
project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • parallel_synchro
  • src
project/at_start_f413/examples/tmr/parallel_synchro/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39
40void crm_configuration(void);
41void gpio_configuration(void);
42
48void gpio_configuration(void)
49{
50 gpio_init_type gpio_init_struct;
51
52 gpio_default_para_init(&gpio_init_struct);
53
54 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_0;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
57 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
58 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
59 gpio_init(GPIOA, &gpio_init_struct);
60
61 gpio_init_struct.gpio_pins = GPIO_PINS_6;
62 gpio_init(GPIOB, &gpio_init_struct);
63
64}
65
71void crm_configuration(void)
72{
73 /* tmr3 clock enable */
74 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
75 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
76 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
77
78 /* gpios clock enable */
79 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
80 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
81 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
82 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
83}
84
90int main(void)
91{
92 system_clock_config();
93
94 /* peripheral clocks configuration */
95 crm_configuration();
96
97 /* gpio configuration */
98 gpio_configuration();
99
100 /* tmr base configuration */
101 tmr_base_init(TMR2, 191, 0);
102 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
103 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
104 tmr_base_init(TMR3, 9, 0);
105 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
106 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
107 tmr_base_init(TMR4, 4, 0);
108 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
109 tmr_clock_source_div_set(TMR4, TMR_CLOCK_DIV1);
110
111 /* output compare toggle mode configuration: channel1 */
112 tmr_output_default_para_init(&tmr_oc_init_structure);
113 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
114 tmr_oc_init_structure.oc_idle_state = FALSE;
115 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
116 tmr_oc_init_structure.oc_output_state = TRUE;
117 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
118 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, 96);
119
120 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
121 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, 3);
122
123 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
124 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 3);
125
126 /* primary mode selection: TMR2 */
127 tmr_sub_sync_mode_set(TMR2, TRUE);
128 tmr_primary_mode_select(TMR2, TMR_PRIMARY_SEL_OVERFLOW);
129
130 /* subordinate mode selection: TMR3 */
131 tmr_sub_mode_select(TMR3, TMR_SUB_HANG_MODE);
132 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_IS1);
133
134 /* subordinate mode selection: TMR4 */
135 tmr_sub_mode_select(TMR4, TMR_SUB_HANG_MODE);
136 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_IS1);
137
138 /* tmr enable counter */
139 tmr_counter_enable(TMR2, TRUE);
140 tmr_counter_enable(TMR3, TRUE);
141 tmr_counter_enable(TMR4, TRUE);
142
143 while(1)
144 {
145 }
146}
147
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/main.c:90
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/main.c:48
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/parallel_synchro/src/main.c:71
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:112
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:128
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1256
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1157
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_SUB_INPUT_SEL_IS1
@ TMR_SUB_INPUT_SEL_IS1
Definition: at32f413_tmr.h:134
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:153
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f413_tmr.h:120
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
TMR4
#define TMR4
Definition: at32f413_tmr.h:835
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_input
  • inc
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_input
  • inc
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_input
  • inc
project/at_start_f413/examples/tmr/pwm_input/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_input
  • src
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_input
  • src
project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30extern uint16_t duty_cycle;
31extern uint32_t frequency;
32
41__IO uint16_t ic2value = 0;
42
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void TMR3_GLOBAL_IRQHandler(void)
146{
147 /* clear tmr3 channel interrupt pending bit */
148 tmr_flag_clear(TMR3, TMR_C2_FLAG);
149
150 /* get the input channel data value */
151 ic2value = tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_2);
152
153 if(ic2value != 0)
154 {
155 /* duty cycle computation */
156 duty_cycle = (tmr_channel_value_get(TMR3, TMR_SELECT_CHANNEL_1) * 100) / ic2value;
157
158 /* frequency computation */
159 frequency = system_core_clock / ic2value;
160 }
161 else
162 {
163 duty_cycle = 0;
164 frequency = 0;
165 }
166}
167
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:96
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:70
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:109
ic2value
__IO uint16_t ic2value
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:41
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:48
TMR3_GLOBAL_IRQHandler
void TMR3_GLOBAL_IRQHandler(void)
this function handles tmr3 global interrupt request.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:145
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:83
frequency
uint32_t frequency
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:41
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:136
duty_cycle
uint16_t duty_cycle
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:40
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/at32f413_int.c:118
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:547
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:54
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_input
  • src
project/at_start_f413/examples/tmr/pwm_input/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_input_config_type tmr_ic_init_structure;
39
40__IO uint16_t duty_cycle = 0;
41__IO uint32_t frequency = 0;
42
43void crm_configuration(void);
44void gpio_configuration(void);
45
51void gpio_configuration(void)
52{
53 gpio_init_type gpio_init_struct;
54
55 gpio_default_para_init(&gpio_init_struct);
56
57 gpio_init_struct.gpio_pins = GPIO_PINS_7;
58 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
59 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
60 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
61 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
62 gpio_init(GPIOA, &gpio_init_struct);
63}
64
70void crm_configuration(void)
71{
72 /* tmr3 clock enable */
73 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
74
75 /* gpioa clock enable */
76 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
77}
78
84int main(void)
85{
86 system_clock_config();
87
88 /* peripheral clocks configuration */
89 crm_configuration();
90
91 /* nvic configuration */
92 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
93 nvic_irq_enable(TMR3_GLOBAL_IRQn, 0, 0);
94
95 /* gpio configuration */
96 gpio_configuration();
97
98 uart_print_init(115200);
99
100 tmr_input_default_para_init(&tmr_ic_init_structure);
101 tmr_ic_init_structure.input_filter_value = 0;
102 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_2;
103 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
104 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
105
106 tmr_pwm_input_config(TMR3, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
107
108 /* select the tmr3 input trigger: c2df2 */
109 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_C2DF2);
110
111 /* select the sub mode: reset mode */
112 tmr_sub_mode_select(TMR3, TMR_SUB_RESET_MODE);
113
114 /* enable the sub sync mode */
115 tmr_sub_sync_mode_set(TMR3, TRUE);
116
117 /* tmr enable counter */
118 tmr_counter_enable(TMR3, TRUE);
119
120 /* enable the c2 interrupt request */
121 tmr_interrupt_enable(TMR3, TMR_C2_INT, TRUE);
122
123 while(1)
124 {
125 printf("Frequency = %dHZ,Dutycycle = %d%%\r\n", frequency, duty_cycle);
126 }
127}
128
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:84
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:51
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:70
frequency
__IO uint32_t frequency
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:41
duty_cycle
__IO uint16_t duty_cycle
Definition: project/at_start_f413/examples/tmr/pwm_input/src/main.c:40
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
TMR3_GLOBAL_IRQn
@ TMR3_GLOBAL_IRQn
Definition: at32f413.h:163
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:139
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1256
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f413_tmr.c:977
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:239
TMR_SUB_INPUT_SEL_C2DF2
@ TMR_SUB_INPUT_SEL_C2DF2
Definition: at32f413_tmr.h:139
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f413_tmr.h:152
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:249
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:76
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:416
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_input_dma
  • inc
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_input_dma
  • inc
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_input_dma
  • inc
project/at_start_f413/examples/tmr/pwm_input_dma/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_input_dma
  • src
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_input_dma
  • src
project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_input_dma
  • src
project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "stdio.h"
30
39#define TMR1_C1DT_ADDRESS 0x40012C34
40#define TMR1_C2DT_ADDRESS 0x40012C38
41
42#define SAMPLING_NUM 1000
43
44 tmr_input_config_type tmr_ic_init_structure;
45 dma_init_type dma_init_structure;
46
47__IO uint16_t buffer_ch1[1000];
48__IO uint16_t buffer_ch2[1000];
49
50__IO uint32_t frequency = 0;
51__IO float duty_cycle = 0;
52
53uint32_t freq_result;
54float duty_result;
55
56void crm_configuration(void);
57void gpio_configuration(void);
58
59void DMA1_Channel2_IRQHandler(void)
60{
61 uint16_t i;
62
63 dma_flag_clear(DMA1_FDT2_FLAG);
64
65 duty_result = 0;
66 freq_result = 0.0;
67
68 for(i = 0; i < SAMPLING_NUM; i++)
69 {
70 duty_result += ((buffer_ch2[i] * 100.0) / buffer_ch1[i]);
71 freq_result += (system_core_clock / buffer_ch1[i]);
72 }
73
74 duty_cycle = duty_result / SAMPLING_NUM;
75 frequency = freq_result / SAMPLING_NUM;
76 printf("\r\nFreq=%dHZ, Duty=%.2f%%\r\n", frequency, duty_cycle);
77}
78
84void gpio_configuration(void)
85{
86 gpio_init_type gpio_init_struct;
87
88 gpio_default_para_init(&gpio_init_struct);
89
90 gpio_init_struct.gpio_pins = GPIO_PINS_8;
91 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
92 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
93 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
94 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
95 gpio_init(GPIOA, &gpio_init_struct);
96}
97
103void crm_configuration(void)
104{
105 /* tmr1 clock enable */
106 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
107
108 /* gpioa clock enable */
109 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
110
111 /* dma clock enable */
112 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
113}
114
120int main(void)
121{
122 system_clock_config();
123
124 /* peripheral clocks configuration */
125 crm_configuration();
126
127 /* nvic configuration */
128 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
129 nvic_irq_enable(DMA1_Channel2_IRQn, 0, 0);
130
131 /* gpio configuration */
132 gpio_configuration();
133
134 uart_print_init(115200);
135
136 dma_reset(DMA1_CHANNEL2);
137 dma_default_para_init(&dma_init_structure);
138 dma_init_structure.peripheral_base_addr = (uint32_t)TMR1_C1DT_ADDRESS;
139 dma_init_structure.memory_base_addr = (uint32_t)buffer_ch1;
140 dma_init_structure.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
141 dma_init_structure.buffer_size = SAMPLING_NUM;
142 dma_init_structure.peripheral_inc_enable = FALSE;
143 dma_init_structure.memory_inc_enable = TRUE;
144 dma_init_structure.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_HALFWORD;
145 dma_init_structure.memory_data_width = DMA_MEMORY_DATA_WIDTH_HALFWORD;
146 dma_init_structure.loop_mode_enable = TRUE;
147 dma_init_structure.priority = DMA_PRIORITY_HIGH;
148 dma_init(DMA1_CHANNEL2, &dma_init_structure);
149
150 dma_reset(DMA1_CHANNEL3);
151 dma_init_structure.peripheral_base_addr = (uint32_t)TMR1_C2DT_ADDRESS;
152 dma_init_structure.memory_base_addr = (uint32_t)buffer_ch2;
153 dma_init(DMA1_CHANNEL3, &dma_init_structure);
154
155 dma_interrupt_enable(DMA1_CHANNEL2, DMA_FDT_INT, TRUE);
156
157 dma_channel_enable(DMA1_CHANNEL2, TRUE);
158 dma_channel_enable(DMA1_CHANNEL3, TRUE);
159
160 tmr_input_default_para_init(&tmr_ic_init_structure);
161 tmr_ic_init_structure.input_filter_value = 0;
162 tmr_ic_init_structure.input_channel_select = TMR_SELECT_CHANNEL_1;
163 tmr_ic_init_structure.input_mapped_select = TMR_CC_CHANNEL_MAPPED_DIRECT;
164 tmr_ic_init_structure.input_polarity_select = TMR_INPUT_RISING_EDGE;
165
166 tmr_pwm_input_config(TMR1, &tmr_ic_init_structure, TMR_CHANNEL_INPUT_DIV_1);
167
168 /* select the TMR1 input trigger: C2IF2 */
169 tmr_trigger_input_select(TMR1, TMR_SUB_INPUT_SEL_C1DF1);
170
171 /* select the sub mode: reset mode */
172 tmr_sub_mode_select(TMR1, TMR_SUB_RESET_MODE);
173
174 /* enable the sub sync mode */
175 tmr_sub_sync_mode_set(TMR1, TRUE);
176
177 /* enable the c1/c2 dma */
178 tmr_dma_request_enable(TMR1, TMR_C1_DMA_REQUEST, TRUE);
179 tmr_dma_request_enable(TMR1, TMR_C2_DMA_REQUEST, TRUE);
180
181 /* tmr enable counter */
182 tmr_counter_enable(TMR1, TRUE);
183
184 while(1)
185 {
186 }
187}
188
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
duty_cycle
__IO float duty_cycle
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:51
DMA1_Channel2_IRQHandler
void DMA1_Channel2_IRQHandler(void)
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:59
dma_init_structure
dma_init_type dma_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:45
freq_result
uint32_t freq_result
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:53
duty_result
float duty_result
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:54
TMR1_C1DT_ADDRESS
#define TMR1_C1DT_ADDRESS
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:39
buffer_ch2
__IO uint16_t buffer_ch2[1000]
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:120
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:84
SAMPLING_NUM
#define SAMPLING_NUM
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:42
tmr_ic_init_structure
tmr_input_config_type tmr_ic_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:44
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:103
frequency
__IO uint32_t frequency
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:50
buffer_ch1
__IO uint16_t buffer_ch1[1000]
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:47
TMR1_C2DT_ADDRESS
#define TMR1_C2DT_ADDRESS
Definition: project/at_start_f413/examples/tmr/pwm_input_dma/src/main.c:40
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f413.h:145
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
@ DMA_PERIPHERAL_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:246
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_HALFWORD
@ DMA_MEMORY_DATA_WIDTH_HALFWORD
Definition: at32f413_dma.h:256
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f413_dma.h:86
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:482
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:481
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_dma_request_enable
void tmr_dma_request_enable(tmr_type *tmr_x, tmr_dma_request_type dma_request, confirm_state new_state)
enable or disable tmr dma request
Definition: at32f413_tmr.c:1279
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_input_default_para_init
void tmr_input_default_para_init(tmr_input_config_type *tmr_input_struct)
init tmr input default para
Definition: at32f413_tmr.c:139
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1256
tmr_pwm_input_config
void tmr_pwm_input_config(tmr_type *tmr_x, tmr_input_config_type *input_struct, tmr_channel_input_divider_type divider_factor)
config tmr pwm input
Definition: at32f413_tmr.c:977
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
TMR_C1_DMA_REQUEST
@ TMR_C1_DMA_REQUEST
Definition: at32f413_tmr.h:270
TMR_C2_DMA_REQUEST
@ TMR_C2_DMA_REQUEST
Definition: at32f413_tmr.h:271
TMR_INPUT_RISING_EDGE
@ TMR_INPUT_RISING_EDGE
Definition: at32f413_tmr.h:206
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_CC_CHANNEL_MAPPED_DIRECT
@ TMR_CC_CHANNEL_MAPPED_DIRECT
Definition: at32f413_tmr.h:239
TMR_SUB_INPUT_SEL_C1DF1
@ TMR_SUB_INPUT_SEL_C1DF1
Definition: at32f413_tmr.h:138
TMR_SUB_RESET_MODE
@ TMR_SUB_RESET_MODE
Definition: at32f413_tmr.h:152
TMR_CHANNEL_INPUT_DIV_1
@ TMR_CHANNEL_INPUT_DIV_1
Definition: at32f413_tmr.h:249
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_input_config_type
tmr input capture config type
Definition: at32f413_tmr.h:412
tmr_input_config_type::input_mapped_select
tmr_input_direction_mapped_type input_mapped_select
Definition: at32f413_tmr.h:415
tmr_input_config_type::input_filter_value
uint8_t input_filter_value
Definition: at32f413_tmr.h:416
tmr_input_config_type::input_polarity_select
tmr_input_polarity_type input_polarity_select
Definition: at32f413_tmr.h:414
tmr_input_config_type::input_channel_select
tmr_channel_select_type input_channel_select
Definition: at32f413_tmr.h:413
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_output_simulate
  • inc
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_output_simulate
  • inc
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_output_simulate
  • inc
project/at_start_f413/examples/tmr/pwm_output_simulate/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_output_simulate
  • src
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_output_simulate
  • src
project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30extern __IO uint16_t ch1_val;
31extern __IO uint16_t ch2_val;
32extern __IO uint16_t ch3_val;
33extern __IO uint16_t ch4_val;
34
43uint16_t capture = 0;
44
50void NMI_Handler(void)
51{
52}
53
59void HardFault_Handler(void)
60{
61 /* go to infinite loop when hard fault exception occurs */
62 while(1)
63 {
64 }
65}
66
72void MemManage_Handler(void)
73{
74 /* go to infinite loop when memory manage exception occurs */
75 while(1)
76 {
77 }
78}
79
85void BusFault_Handler(void)
86{
87 /* go to infinite loop when bus fault exception occurs */
88 while(1)
89 {
90 }
91}
92
98void UsageFault_Handler(void)
99{
100 /* go to infinite loop when usage fault exception occurs */
101 while(1)
102 {
103 }
104}
105
111void SVC_Handler(void)
112{
113}
114
120void DebugMon_Handler(void)
121{
122}
123
129void PendSV_Handler(void)
130{
131}
132
138void SysTick_Handler(void)
139{
140}
141
142void TMR2_GLOBAL_IRQHandler(void)
143{
144 if(tmr_flag_get(TMR2, TMR_C1_FLAG) != RESET)
145 {
146 tmr_flag_clear(TMR2, TMR_C1_FLAG );
147
148 /* Pin PC.06 toggling with frequency = 73.24 Hz */
149 gpio_bits_write(GPIOC, GPIO_PINS_6, (confirm_state)(1 - gpio_output_data_bit_read(GPIOC, GPIO_PINS_6)));
150 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_1);
151 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, capture + ch1_val);
152 }
153 else if(tmr_flag_get(TMR2, TMR_C2_FLAG) != RESET)
154 {
155 tmr_flag_clear(TMR2, TMR_C2_FLAG);
156
157 /* Pin PC.06 toggling with frequency = 73.24 Hz */
158 gpio_bits_write(GPIOC, GPIO_PINS_7, (confirm_state)(1 - gpio_output_data_bit_read(GPIOC, GPIO_PINS_7)));
159 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_2);
160 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, capture + ch2_val);
161 }
162 else if(tmr_flag_get(TMR2, TMR_C3_FLAG) != RESET)
163 {
164 tmr_flag_clear(TMR2, TMR_C3_FLAG);
165
166 /* Pin PC.06 toggling with frequency = 73.24 Hz */
167 gpio_bits_write(GPIOC, GPIO_PINS_8, (confirm_state)(1 - gpio_output_data_bit_read(GPIOC, GPIO_PINS_8)));
168 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_3);
169 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, capture + ch3_val);
170 }
171 else
172 {
173 tmr_flag_clear(TMR2, TMR_C4_FLAG);
174
175 /* Pin PC.06 toggling with frequency = 73.24 Hz */
176 gpio_bits_write(GPIOC, GPIO_PINS_9, (confirm_state)(1 - gpio_output_data_bit_read(GPIOC, GPIO_PINS_9)));
177 capture = tmr_channel_value_get(TMR2, TMR_SELECT_CHANNEL_4);
178 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, capture + ch4_val);
179 }
180}
181
ch4_val
__IO uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:43
ch3_val
__IO uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:42
ch1_val
__IO uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:40
ch2_val
__IO uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:41
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:98
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:59
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:72
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:111
TMR2_GLOBAL_IRQHandler
void TMR2_GLOBAL_IRQHandler(void)
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:142
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:129
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:50
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:85
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:138
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:120
capture
uint16_t capture
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/at32f413_int.c:43
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_output_data_bit_read
flag_status gpio_output_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified output port pin.
Definition: at32f413_gpio.c:256
gpio_bits_write
void gpio_bits_write(gpio_type *gpio_x, uint16_t pins, confirm_state bit_state)
set or clear the selected data port bit.
Definition: at32f413_gpio.c:373
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
tmr_channel_value_get
uint32_t tmr_channel_value_get(tmr_type *tmr_x, tmr_channel_select_type tmr_channel)
get tmr channel value
Definition: at32f413_tmr.c:547
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_C1_FLAG
#define TMR_C1_FLAG
Definition: at32f413_tmr.h:53
TMR_C2_FLAG
#define TMR_C2_FLAG
Definition: at32f413_tmr.h:54
TMR_C3_FLAG
#define TMR_C3_FLAG
Definition: at32f413_tmr.h:55
TMR_C4_FLAG
#define TMR_C4_FLAG
Definition: at32f413_tmr.h:56
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_output_simulate
  • src
project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39
40uint16_t ch1_val = 40961;
41uint16_t ch2_val = 27309;
42uint16_t ch3_val = 13654;
43uint16_t ch4_val = 6826;
44uint16_t div_value = 0;
45
46void crm_configuration(void);
47void gpio_configuration(void);
48
54void gpio_configuration(void)
55{
56 gpio_init_type gpio_init_struct;
57
58 gpio_default_para_init(&gpio_init_struct);
59
60 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7 | GPIO_PINS_8 | GPIO_PINS_9;
61 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
62 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
63 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
64 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
65 gpio_init(GPIOC, &gpio_init_struct);
66}
67
73void crm_configuration(void)
74{
75 /* tmr2 clock enable */
76 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
77
78 /* gpioa gpiob clock enable */
79 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
80}
81
87int main(void)
88{
89 /* config nvic priority group */
90 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
91
92 system_clock_config();
93
94 /* peripheral clocks configuration */
95 crm_configuration();
96
97 /* nvic Configuration */
98 nvic_irq_enable(TMR2_GLOBAL_IRQn, 0, 0);
99
100 /* gpio configuration */
101 gpio_configuration();
102
103 /* compute the div value */
104 div_value = (uint16_t)(system_core_clock / 12000000) - 1;
105
106 /* tmr2 time base configuration */
107 tmr_base_init(TMR2, 65535, div_value);
108 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
109 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
110
111 tmr_output_default_para_init(&tmr_oc_init_structure);
112 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_OFF;
113 tmr_oc_init_structure.oc_idle_state = FALSE;
114 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
115 tmr_oc_init_structure.oc_output_state = TRUE;
116 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
117 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ch1_val);
118
119 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
120 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ch2_val);
121
122 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
123 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ch3_val);
124
125 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
126 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ch4_val);
127
128 /* tmr2 int enable */
129 tmr_interrupt_enable(TMR2, TMR_C1_INT | TMR_C2_INT | TMR_C3_INT | TMR_C4_INT, TRUE);
130
131 /* tmr enable counter */
132 tmr_counter_enable(TMR2, TRUE);
133
134 while(1)
135 {
136 }
137}
138
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ch4_val
uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:43
ch3_val
uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:42
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:87
ch2_val
uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:41
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:54
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:73
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/pwm_output_simulate/src/main.c:44
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:112
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
TMR2_GLOBAL_IRQn
@ TMR2_GLOBAL_IRQn
Definition: at32f413.h:162
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f413_tmr.h:173
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_C3_INT
#define TMR_C3_INT
Definition: at32f413_tmr.h:77
TMR_C4_INT
#define TMR_C4_INT
Definition: at32f413_tmr.h:78
TMR_C1_INT
#define TMR_C1_INT
Definition: at32f413_tmr.h:75
TMR_C2_INT
#define TMR_C2_INT
Definition: at32f413_tmr.h:76
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_output_tmr3
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_output_tmr3
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_output_tmr3
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr3/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_output_tmr3
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_output_tmr3
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_output_tmr3
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39
40uint16_t ch1_val = 333;
41uint16_t ch2_val = 249;
42uint16_t ch3_val = 166;
43uint16_t ch4_val = 83;
44uint16_t div_value = 0;
45
46void crm_configuration(void);
47void gpio_configuration(void);
48
54void gpio_configuration(void)
55{
56 gpio_init_type gpio_init_struct;
57
58 gpio_default_para_init(&gpio_init_struct);
59
60 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_7;
61 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
62 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
63 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
64 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
65 gpio_init(GPIOA, &gpio_init_struct);
66
67 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1;
68 gpio_init(GPIOB, &gpio_init_struct);
69}
70
76void crm_configuration(void)
77{
78 /* tmr3 clock enable */
79 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
80
81 /* gpioa gpiob clock enable */
82 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
83 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
84}
85
91int main(void)
92{
93 system_clock_config();
94
95 /* peripheral clocks configuration */
96 crm_configuration();
97
98 /* gpio configuration */
99 gpio_configuration();
100
101 /* compute the div value */
102 div_value = (uint16_t)(system_core_clock / 24000000) - 1;
103
104 /* tmr3 time base configuration */
105 tmr_base_init(TMR3, 665, div_value);
106 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
107 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
108
109 tmr_output_default_para_init(&tmr_oc_init_structure);
110 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
111 tmr_oc_init_structure.oc_idle_state = FALSE;
112 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
113 tmr_oc_init_structure.oc_output_state = TRUE;
114 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
115 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, ch1_val);
116 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_1, TRUE);
117
118 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
119 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_2, ch2_val);
120 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_2, TRUE);
121
122 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
123 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_3, ch3_val);
124 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_3, TRUE);
125
126 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
127 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_4, ch4_val);
128 tmr_output_channel_buffer_enable(TMR3, TMR_SELECT_CHANNEL_4, TRUE);
129
130 tmr_period_buffer_enable(TMR3, TRUE);
131
132 /* tmr enable counter */
133 tmr_counter_enable(TMR3, TRUE);
134
135 while(1)
136 {
137 }
138}
139
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ch4_val
uint16_t ch4_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:43
ch3_val
uint16_t ch3_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:42
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:91
ch2_val
uint16_t ch2_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:41
gpio_configuration
void gpio_configuration(void)
configure the tmr3 pins.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:54
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:76
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr3/src/main.c:44
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_7
#define GPIO_PINS_7
Definition: at32f413_gpio.h:58
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:588
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:609
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • pwm_output_tmr10
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • pwm_output_tmr10
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • pwm_output_tmr10
  • inc
project/at_start_f413/examples/tmr/pwm_output_tmr10/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • pwm_output_tmr10
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • pwm_output_tmr10
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • pwm_output_tmr10
  • src
project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39
40uint16_t ch1_val = 250;
41uint16_t div_value = 0;
42
43void crm_configuration(void);
44void gpio_configuration(void);
45
51void gpio_configuration(void)
52{
53 gpio_init_type gpio_init_struct;
54
55 gpio_default_para_init(&gpio_init_struct);
56
57 gpio_init_struct.gpio_pins = GPIO_PINS_8;
58 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
59 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
60 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
61 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
62 gpio_init(GPIOB, &gpio_init_struct);
63}
64
70void crm_configuration(void)
71{
72 /* tmr10 clock enable */
73 crm_periph_clock_enable(CRM_TMR10_PERIPH_CLOCK, TRUE);
74
75 /* gpioa gpiob clock enable */
76 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
77}
78
84int main(void)
85{
86 system_clock_config();
87
88 /* peripheral clocks configuration */
89 crm_configuration();
90
91 /* gpio configuration */
92 gpio_configuration();
93
94 /* compute the div value */
95 div_value = (uint16_t)(system_core_clock / 10000000) - 1;
96
97 /* tmr10 time base configuration */
98 tmr_base_init(TMR10, 499, div_value);
99 tmr_cnt_dir_set(TMR10, TMR_COUNT_UP);
100 tmr_clock_source_div_set(TMR10, TMR_CLOCK_DIV1);
101
102 tmr_output_default_para_init(&tmr_oc_init_structure);
103 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
104 tmr_oc_init_structure.oc_idle_state = FALSE;
105 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
106 tmr_oc_init_structure.oc_output_state = TRUE;
107 tmr_output_channel_config(TMR10, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
108 tmr_channel_value_set(TMR10, TMR_SELECT_CHANNEL_1, ch1_val);
109 tmr_output_channel_buffer_enable(TMR10, TMR_SELECT_CHANNEL_1, TRUE);
110
111 tmr_period_buffer_enable(TMR10, TRUE);
112
113 /* tmr enable counter */
114 tmr_counter_enable(TMR10, TRUE);
115
116 while(1)
117 {
118 }
119}
120
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ch1_val
uint16_t ch1_val
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:84
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:51
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:70
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/pwm_output_tmr10/src/main.c:41
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_TMR10_PERIPH_CLOCK
@ CRM_TMR10_PERIPH_CLOCK
Definition: at32f413_crm.h:122
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:588
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:609
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR10
#define TMR10
Definition: at32f413_tmr.h:839
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • timer_base
  • inc
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • timer_base
  • inc
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • timer_base
  • inc
project/at_start_f413/examples/tmr/timer_base/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • timer_base
  • src
project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • timer_base
  • src
project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/timer_base/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • timer_base
  • src
project/at_start_f413/examples/tmr/timer_base/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 crm_clocks_freq_type crm_clocks_freq_struct = {0};
39
40void clkout_config(void)
41{
42 gpio_init_type gpio_init_struct;
43
44 /* enable gpio port clock */
45 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
46
47 /* set default parameter */
48 gpio_default_para_init(&gpio_init_struct);
49
50 /* clkout gpio init */
51 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
52 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
53 gpio_init_struct.gpio_pins = GPIO_PINS_8;
54 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
55 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
56 gpio_init(GPIOA, &gpio_init_struct);
57
58 /* config clkout division */
59 crm_clkout_div_set(CRM_CLKOUT_DIV_1);
60
61 /* config clkout clock */
62 crm_clock_out_set(CRM_CLKOUT_PLL_DIV_4);
63}
64
70void TMR1_OVF_TMR10_IRQHandler(void)
71{
72 if(tmr_flag_get(TMR1, TMR_OVF_FLAG) != RESET)
73 {
74 /* add user code... */
75 at32_led_toggle(LED3);
76 tmr_flag_clear(TMR1, TMR_OVF_FLAG);
77 }
78}
79
85int main(void)
86{
87 system_clock_config();
88
89 at32_board_init();
90
91 /* get system clock */
92 crm_clocks_freq_get(&crm_clocks_freq_struct);
93
94 /* turn led2/led3/led4 on */
95 at32_led_on(LED2);
96 at32_led_on(LED3);
97 at32_led_on(LED4);
98
99 /* enable tmr1 clock */
100 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
101
102 /* tmr1 configuration */
103 /* time base configuration */
104 /* systemclock/19200/10000 = 1hz */
105 tmr_base_init(TMR1, 9999, (crm_clocks_freq_struct.ahb_freq / 10000) - 1);
106 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
107
108 /* overflow interrupt enable */
109 tmr_interrupt_enable(TMR1, TMR_OVF_INT, TRUE);
110
111 /* tmr1 overflow interrupt nvic init */
112 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
113 nvic_irq_enable(TMR1_OVF_TMR10_IRQn, 0, 0);
114
115 /* enable tmr1 */
116 tmr_counter_enable(TMR1, TRUE);
117 clkout_config();
118
119 while(1)
120 {
121 }
122}
123
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
clkout_config
void clkout_config(void)
Definition: project/at_start_f413/examples/tmr/timer_base/src/main.c:40
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/timer_base/src/main.c:85
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/timer_base/src/main.c:38
TMR1_OVF_TMR10_IRQHandler
void TMR1_OVF_TMR10_IRQHandler(void)
this function handles timer1 overflow handler.
Definition: project/at_start_f413/examples/tmr/timer_base/src/main.c:70
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_clkout_div_set
void crm_clkout_div_set(crm_clkout_div_type clkout_div)
set crm clkout division
Definition: at32f413_crm.c:804
crm_clock_out_set
void crm_clock_out_set(crm_clkout_select_type clkout)
set crm clkout
Definition: at32f413_crm.c:683
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
CRM_CLKOUT_DIV_1
@ CRM_CLKOUT_DIV_1
Definition: at32f413_crm.h:420
CRM_CLKOUT_PLL_DIV_4
@ CRM_CLKOUT_PLL_DIV_4
Definition: at32f413_crm.h:410
TMR1_OVF_TMR10_IRQn
@ TMR1_OVF_TMR10_IRQn
Definition: at32f413.h:159
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_flag_get
flag_status tmr_flag_get(tmr_type *tmr_x, uint32_t tmr_flag)
get tmr flag
Definition: at32f413_tmr.c:1344
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_OVF_FLAG
#define TMR_OVF_FLAG
Definition: at32f413_tmr.h:52
TMR_OVF_INT
#define TMR_OVF_INT
Definition: at32f413_tmr.h:74
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::ahb_freq
uint32_t ahb_freq
Definition: at32f413_crm.h:473
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • tmr1_synchro
  • inc
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • tmr1_synchro
  • inc
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • tmr1_synchro
  • inc
project/at_start_f413/examples/tmr/tmr1_synchro/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • tmr1_synchro
  • src
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • tmr1_synchro
  • src
project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • tmr1_synchro
  • src
project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39
40void crm_configuration(void);
41void gpio_configuration(void);
42
48void gpio_configuration(void)
49{
50 gpio_init_type gpio_init_struct;
51
52 gpio_default_para_init(&gpio_init_struct);
53
54 gpio_init_struct.gpio_pins = GPIO_PINS_6 | GPIO_PINS_8;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
57 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
58 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
59 gpio_init(GPIOA, &gpio_init_struct);
60
61 gpio_init_struct.gpio_pins = GPIO_PINS_6;
62 gpio_init(GPIOB, &gpio_init_struct);
63}
64
70void crm_configuration(void)
71{
72 /* tmr clock enable */
73 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
74 crm_periph_clock_enable(CRM_TMR3_PERIPH_CLOCK, TRUE);
75 crm_periph_clock_enable(CRM_TMR4_PERIPH_CLOCK, TRUE);
76
77 /* gpio clock enable */
78 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
79 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
80}
81
87int main(void)
88{
89 system_clock_config();
90
91 /* peripheral clocks configuration */
92 crm_configuration();
93
94 /* gpio configuration */
95 gpio_configuration();
96
97 /* tmr3 time base configuration */
98 tmr_base_init(TMR3, 2, 0);
99 tmr_cnt_dir_set(TMR3, TMR_COUNT_UP);
100 tmr_clock_source_div_set(TMR3, TMR_CLOCK_DIV1);
101
102 tmr_output_default_para_init(&tmr_oc_init_structure);
103 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
104 tmr_oc_init_structure.oc_idle_state = FALSE;
105 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
106 tmr_oc_init_structure.oc_output_state = TRUE;
107 tmr_output_channel_config(TMR3, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
108 tmr_channel_value_set(TMR3, TMR_SELECT_CHANNEL_1, 1);
109
110 /* input trigger selection */
111 tmr_trigger_input_select(TMR3, TMR_SUB_INPUT_SEL_IS0);
112
113 /* slave mode selection: hang mode */
114 tmr_sub_mode_select(TMR3, TMR_SUB_HANG_MODE);
115
116 /* tmr4 time base configuration */
117 tmr_base_init(TMR4, 1, 0);
118 tmr_cnt_dir_set(TMR4, TMR_COUNT_UP);
119 tmr_clock_source_div_set(TMR4, TMR_CLOCK_DIV1);
120
121 tmr_output_default_para_init(&tmr_oc_init_structure);
122 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
123 tmr_oc_init_structure.oc_idle_state = FALSE;
124 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
125 tmr_oc_init_structure.oc_output_state = TRUE;
126 tmr_output_channel_config(TMR4, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
127 tmr_channel_value_set(TMR4, TMR_SELECT_CHANNEL_1, 1);
128
129 /* input trigger selection */
130 tmr_trigger_input_select(TMR4, TMR_SUB_INPUT_SEL_IS0);
131
132 /* slave mode selection: hang mode */
133 tmr_sub_mode_select(TMR4, TMR_SUB_HANG_MODE);
134
135 /* tmr1 time base configuration */
136 tmr_base_init(TMR1, 191, 0);
137 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
138 tmr_clock_source_div_set(TMR1, TMR_CLOCK_DIV1);
139 tmr_repetition_counter_set(TMR1, 4);
140
141 tmr_output_default_para_init(&tmr_oc_init_structure);
142 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
143 tmr_oc_init_structure.oc_idle_state = TRUE;
144 tmr_oc_init_structure.occ_idle_state = FALSE;
145 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
146 tmr_oc_init_structure.occ_polarity = TMR_OUTPUT_ACTIVE_LOW;
147 tmr_oc_init_structure.oc_output_state = TRUE;
148 tmr_oc_init_structure.occ_output_state = TRUE;
149 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
150 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 96);
151
152 tmr_primary_mode_select(TMR1, TMR_PRIMARY_SEL_OVERFLOW);
153 tmr_sub_sync_mode_set(TMR1, TRUE);
154
155 tmr_output_enable(TMR1, TRUE);
156
157 /* tmr enable counter */
158 tmr_counter_enable(TMR1, TRUE);
159 tmr_counter_enable(TMR3, TRUE);
160 tmr_counter_enable(TMR4, TRUE);
161
162 while(1)
163 {
164 }
165}
166
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c:87
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c:48
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/tmr1_synchro/src/main.c:70
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR4_PERIPH_CLOCK
@ CRM_TMR4_PERIPH_CLOCK
Definition: at32f413_crm.h:128
CRM_TMR3_PERIPH_CLOCK
@ CRM_TMR3_PERIPH_CLOCK
Definition: at32f413_crm.h:127
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_6
#define GPIO_PINS_6
Definition: at32f413_gpio.h:57
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_repetition_counter_set
void tmr_repetition_counter_set(tmr_type *tmr_x, uint8_t tmr_rpr_value)
set the repetition counter register(rpr) value
Definition: at32f413_tmr.c:235
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_sub_mode_select
void tmr_sub_mode_select(tmr_type *tmr_x, tmr_sub_mode_select_type sub_mode)
select tmr subordinate mode
Definition: at32f413_tmr.c:1179
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_sub_sync_mode_set
void tmr_sub_sync_mode_set(tmr_type *tmr_x, confirm_state new_state)
set tmr subordinate synchronization mode
Definition: at32f413_tmr.c:1256
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_trigger_input_select
void tmr_trigger_input_select(tmr_type *tmr_x, sub_tmr_input_sel_type trigger_select)
select tmr sub-trigger
Definition: at32f413_tmr.c:1243
tmr_primary_mode_select
void tmr_primary_mode_select(tmr_type *tmr_x, tmr_primary_select_type primary_mode)
select tmr primary mode
Definition: at32f413_tmr.c:1157
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:180
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR_SUB_INPUT_SEL_IS0
@ TMR_SUB_INPUT_SEL_IS0
Definition: at32f413_tmr.h:133
TMR_SUB_HANG_MODE
@ TMR_SUB_HANG_MODE
Definition: at32f413_tmr.h:153
TMR_PRIMARY_SEL_OVERFLOW
@ TMR_PRIMARY_SEL_OVERFLOW
Definition: at32f413_tmr.h:120
TMR3
#define TMR3
Definition: at32f413_tmr.h:834
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
TMR4
#define TMR4
Definition: at32f413_tmr.h:835
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • tmr2_32bit
  • inc
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • tmr2_32bit
  • inc
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • tmr2_32bit
  • inc
project/at_start_f413/examples/tmr/tmr2_32bit/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • tmr2_32bit
  • src
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • tmr2_32bit
  • src
project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • tmr2_32bit
  • src
project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 tmr_output_config_type tmr_oc_init_structure;
39
40uint32_t ch1_val = 0x7FFFF;
41uint32_t ch2_val = 0x3FFFF;
42uint32_t ch3_val = 0x1FFFF;
43uint32_t ch4_val = 0xFFFF;
44
45void crm_configuration(void);
46void gpio_configuration(void);
47
53void gpio_configuration(void)
54{
55 gpio_init_type gpio_init_struct;
56
57 gpio_default_para_init(&gpio_init_struct);
58
59 gpio_init_struct.gpio_pins = GPIO_PINS_0 | GPIO_PINS_1 | GPIO_PINS_2 | GPIO_PINS_3;
60 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
61 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
62 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
63 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
64 gpio_init(GPIOA, &gpio_init_struct);
65}
66
72void crm_configuration(void)
73{
74 /* tmr clock enable */
75 crm_periph_clock_enable(CRM_TMR2_PERIPH_CLOCK, TRUE);
76
77 /* gpio clock enable */
78 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
79}
80
86int main(void)
87{
88 system_clock_config();
89
90 /* peripheral clocks configuration */
91 crm_configuration();
92
93 /* gpio configuration */
94 gpio_configuration();
95
96 tmr_32_bit_function_enable(TMR2, TRUE);
97
98 /* tmr2 time base configuration */
99 tmr_base_init(TMR2, 0xFFFFF, 0);
100 tmr_cnt_dir_set(TMR2, TMR_COUNT_UP);
101 tmr_clock_source_div_set(TMR2, TMR_CLOCK_DIV1);
102
103 tmr_output_default_para_init(&tmr_oc_init_structure);
104 tmr_oc_init_structure.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_A;
105 tmr_oc_init_structure.oc_idle_state = FALSE;
106 tmr_oc_init_structure.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
107 tmr_oc_init_structure.oc_output_state = TRUE;
108 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_1, &tmr_oc_init_structure);
109 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_1, ch1_val);
110 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_1, TRUE);
111
112 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_2, &tmr_oc_init_structure);
113 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_2, ch2_val);
114 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_2, TRUE);
115
116 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_3, &tmr_oc_init_structure);
117 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_3, ch3_val);
118 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_3, TRUE);
119
120 tmr_output_channel_config(TMR2, TMR_SELECT_CHANNEL_4, &tmr_oc_init_structure);
121 tmr_channel_value_set(TMR2, TMR_SELECT_CHANNEL_4, ch4_val);
122 tmr_output_channel_buffer_enable(TMR2, TMR_SELECT_CHANNEL_4, TRUE);
123
124 tmr_period_buffer_enable(TMR2, TRUE);
125
126 /* tmr2 enable counter */
127 tmr_counter_enable(TMR2, TRUE);
128
129 while(1)
130 {
131 }
132}
133
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ch1_val
uint32_t ch1_val
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:40
ch2_val
uint32_t ch2_val
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:41
ch4_val
uint32_t ch4_val
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:86
gpio_configuration
void gpio_configuration(void)
configure the tmr1 pins.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:53
tmr_oc_init_structure
tmr_output_config_type tmr_oc_init_structure
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:38
crm_configuration
void crm_configuration(void)
configures the different peripheral clocks.
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:72
ch3_val
uint32_t ch3_val
Definition: project/at_start_f413/examples/tmr/tmr2_32bit/src/main.c:42
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_TMR2_PERIPH_CLOCK
@ CRM_TMR2_PERIPH_CLOCK
Definition: at32f413_crm.h:126
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_period_buffer_enable
void tmr_period_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr period buffer
Definition: at32f413_tmr.c:588
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_clock_source_div_set
void tmr_clock_source_div_set(tmr_type *tmr_x, tmr_clock_division_type tmr_clock_div)
set tmr clock source division
Definition: at32f413_tmr.c:200
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_32_bit_function_enable
void tmr_32_bit_function_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr 32 bit function(plus mode)
Definition: at32f413_tmr.c:754
tmr_output_channel_buffer_enable
void tmr_output_channel_buffer_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
enable tmr output channel buffer
Definition: at32f413_tmr.c:609
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_CLOCK_DIV1
@ TMR_CLOCK_DIV1
Definition: at32f413_tmr.h:96
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR2
#define TMR2
Definition: at32f413_tmr.h:833
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • 6_steps
  • inc
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • 6_steps
  • inc
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • 6_steps
  • inc
project/at_start_f413/examples/tmr/6_steps/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • 6_steps
  • src
project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • 6_steps
  • src
project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/6_steps/src/at32f413_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • 6_steps
  • src
project/at_start_f413/examples/tmr/6_steps/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 tmr_brkdt_config_type tmr_brkdt_config_struct = {0};
41 crm_clocks_freq_type crm_clocks_freq_struct = {0};
42
43__IO uint32_t step = 1;
44
45/* systick configuration */
46void systick_configuration(void);
47
53int main(void)
54{
55 system_clock_config();
56
57 at32_board_init();
58
59 /* get system clock */
60 crm_clocks_freq_get(&crm_clocks_freq_struct);
61
62 systick_configuration();
63
64 /* turn led2/led3/led4 on */
65 at32_led_on(LED2);
66 at32_led_on(LED3);
67 at32_led_on(LED4);
68
69 /* enable tmr1/gpioa/gpiob clock */
70 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
71 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
72 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
73
74 /* timer2 output pin Configuration */
75 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10;
76 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
77 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
78 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
79 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
80 gpio_init(GPIOA, &gpio_init_struct);
81
82 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
83 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
84 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
85 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
86 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
87 gpio_init(GPIOB, &gpio_init_struct);
88
89 gpio_init_struct.gpio_pins = GPIO_PINS_12;
90 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
91 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
92 gpio_init_struct.gpio_pull = GPIO_PULL_DOWN;
93 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
94 gpio_init(GPIOB, &gpio_init_struct);
95
96 /*
97 the tmr1 peripheral offers the possibility to program in advance the
98 configuration for the next tmr1 outputs behaviour (step) and change the configuration
99 of all the channels at the same time. this operation is possible when the hall
100 event is used.
101 the hall event can be generated by software by setting the hall bit in the tmr1_swevt
102 register or by hardware (on trc rising edge).
103 in this example, a software hall event is generated each 100 ms: using the systick
104 interrupt.
105 the tmr1 is configured in timing mode, each time a hall event occurs,
106 a new tmr1 configuration will be set in advance.
107 the following table describes the tmr1 channels states:
108 -----------------------------------------------
109 | step1 | step2 | step3 | step4 | step5 | step6 |
110 ----------------------------------------------------------
111 |channel1 | 1 | 0 | 0 | 0 | 0 | 1 |
112 ----------------------------------------------------------
113 |channel1n | 0 | 0 | 1 | 1 | 0 | 0 |
114 ----------------------------------------------------------
115 |channel2 | 0 | 0 | 0 | 1 | 1 | 0 |
116 ----------------------------------------------------------
117 |channel2n | 1 | 1 | 0 | 0 | 0 | 0 |
118 ----------------------------------------------------------
119 |channel3 | 0 | 1 | 1 | 0 | 0 | 0 |
120 ----------------------------------------------------------
121 |channel3n | 0 | 0 | 0 | 0 | 1 | 1 |
122 ----------------------------------------------------------
123 */
124 /* tmr1 configuration */
125 /* time base configuration */
126 tmr_base_init(TMR1, 4095, 0);
127 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
128
129 /* channel 1, 2 and 3 configuration in output mode */
130 tmr_output_default_para_init(&tmr_output_struct);
131 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_OFF;
132 tmr_output_struct.oc_output_state = TRUE;
133 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_HIGH;
134 tmr_output_struct.oc_idle_state = TRUE;
135 tmr_output_struct.occ_output_state = TRUE;
136 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
137 tmr_output_struct.occ_idle_state = TRUE;
138
139 /* channel 1 */
140 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
141 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, 2047);
142
143 /* channel 2 */
144 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
145 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, 1023);
146
147 /* channel 3 */
148 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
149 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, 511);
150
151 /* automatic output enable, break, dead time and lock configuration */
152 tmr_brkdt_default_para_init(&tmr_brkdt_config_struct);
153 tmr_brkdt_config_struct.brk_enable = TRUE;
154 tmr_brkdt_config_struct.auto_output_enable = TRUE;
155 tmr_brkdt_config_struct.deadtime = 0;
156 tmr_brkdt_config_struct.fcsodis_state = TRUE;
157 tmr_brkdt_config_struct.fcsoen_state = TRUE;
158 tmr_brkdt_config_struct.brk_polarity = TMR_BRK_INPUT_ACTIVE_HIGH;
159 tmr_brkdt_config_struct.wp_level = TMR_WP_OFF;
160 tmr_brkdt_config(TMR1, &tmr_brkdt_config_struct);
161 tmr_channel_buffer_enable(TMR1, TRUE);
162
163 /* hall interrupt enable */
164 tmr_interrupt_enable(TMR1, TMR_HALL_INT, TRUE);
165
166 /* tmr1 hall interrupt nvic init */
167 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
168 nvic_irq_enable(TMR1_TRG_HALL_TMR11_IRQn, 0, 0);
169
170 /* tmr1 output enable */
171 tmr_output_enable(TMR1, TRUE);
172
173 /* enable tmr1 */
174 tmr_counter_enable(TMR1, TRUE);
175
176 while(1)
177 {
178 }
179}
185void systick_configuration(void)
186{
187 /* setup systick timer for 20 msec interrupts */
188 if(SysTick_Config((crm_clocks_freq_struct.sclk_freq) / 50))
189 {
190 /* capture error */
191 while(1);
192 }
193 NVIC_SetPriority(SysTick_IRQn, 0x0);
194}
195
202void TMR1_TRG_HALL_TMR11_IRQHandler(void)
203{
204 /* clear tmr1 com pending bit */
205 tmr_flag_clear(TMR1, TMR_HALL_FLAG);
206 if(step == 1)
207 {
208 /* next step: step 2 configuration ---------------------------- */
209 /* channel3 configuration */
210 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
211 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
212
213 /* channel1 configuration */
214 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
215 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
216 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
217
218 /* channel2 configuration */
219 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
220 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
221 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, TRUE);
222 step++;
223 }
224 else if(step == 2)
225 {
226 /* next step: step 3 configuration ---------------------------- */
227 /* channel2 configuration */
228 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
229 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
230 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, TRUE);
231
232 /* channel3 configuration */
233 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
234 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, TRUE);
235 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
236
237 /* channel1 configuration */
238 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
239 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
240 step++;
241 }
242 else if(step == 3)
243 {
244 /* next step: step 4 configuration ---------------------------- */
245 /* channel3 configuration */
246 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
247 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, TRUE);
248 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
249
250 /* channel2 configuration */
251 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
252 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
253
254 /* channel1 configuration */
255 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
256 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
257 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, TRUE);
258 step++;
259 }
260 else if(step == 4)
261 {
262 /* next step: step 5 configuration ---------------------------- */
263 /* channel3 configuration */
264 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
265 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, FALSE);
266
267 /* channel1 configuration */
268 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
269 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
270 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, TRUE);
271
272 /* channel2 configuration */
273 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
274 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, TRUE);
275 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
276 step++;
277 }
278 else if(step == 5)
279 {
280 /* next step: step 6 configuration ---------------------------- */
281 /* channel3 configuration */
282 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
283 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
284 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, TRUE);
285
286 /* channel1 configuration */
287 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, FALSE);
288 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
289
290 /* channel2 configuration */
291 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_2, TMR_OUTPUT_CONTROL_PWM_MODE_A);
292 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, TRUE);
293 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
294 step++;
295 }
296 else
297 {
298 /* next step: step 1 configuration ---------------------------- */
299 /* channel1 configuration */
300 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_1, TMR_OUTPUT_CONTROL_PWM_MODE_A);
301 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1, TRUE);
302 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_1C, FALSE);
303
304 /* channel3 configuration */
305 tmr_output_channel_mode_select(TMR1, TMR_SELECT_CHANNEL_3, TMR_OUTPUT_CONTROL_PWM_MODE_A);
306 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3, FALSE);
307 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_3C, TRUE);
308
309 /* channel2 configuration */
310 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2, FALSE);
311 tmr_channel_enable(TMR1, TMR_SELECT_CHANNEL_2C, FALSE);
312 step = 1;
313 }
314}
315
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:38
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:39
systick_configuration
void systick_configuration(void)
configures the systick.
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:185
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:53
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:41
step
__IO uint32_t step
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:43
TMR1_TRG_HALL_TMR11_IRQHandler
void TMR1_TRG_HALL_TMR11_IRQHandler(void)
this function handles tmr1 trigger and hall interrupts requests.
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:202
tmr_brkdt_config_struct
tmr_brkdt_config_type tmr_brkdt_config_struct
Definition: project/at_start_f413/examples/tmr/6_steps/src/main.c:40
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
SysTick_IRQn
@ SysTick_IRQn
Definition: at32f413.h:130
TMR1_TRG_HALL_TMR11_IRQn
@ TMR1_TRG_HALL_TMR11_IRQn
Definition: at32f413.h:160
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_DOWN
@ GPIO_PULL_DOWN
Definition: at32f413_gpio.h:246
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
tmr_flag_clear
void tmr_flag_clear(tmr_type *tmr_x, uint32_t tmr_flag)
clear tmr flag
Definition: at32f413_tmr.c:1382
tmr_channel_buffer_enable
void tmr_channel_buffer_enable(tmr_type *tmr_x, confirm_state new_state)
enable tmr channel buffer
Definition: at32f413_tmr.c:1221
tmr_output_channel_mode_select
void tmr_output_channel_mode_select(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_control_mode_type oc_mode)
select tmr output channel mode
Definition: at32f413_tmr.c:425
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_brkdt_default_para_init
void tmr_brkdt_default_para_init(tmr_brkdt_config_type *tmr_brkdt_struct)
init tmr brkdt default para
Definition: at32f413_tmr.c:153
tmr_brkdt_config
void tmr_brkdt_config(tmr_type *tmr_x, tmr_brkdt_config_type *brkdt_struct)
config tmr break mode and dead-time
Definition: at32f413_tmr.c:1715
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_interrupt_enable
void tmr_interrupt_enable(tmr_type *tmr_x, uint32_t tmr_interrupt, confirm_state new_state)
enable or disable tmr interrupt
Definition: at32f413_tmr.c:1310
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_enable
void tmr_channel_enable(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, confirm_state new_state)
tmr channel enable
Definition: at32f413_tmr.c:875
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_1C
@ TMR_SELECT_CHANNEL_1C
Definition: at32f413_tmr.h:217
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_2C
@ TMR_SELECT_CHANNEL_2C
Definition: at32f413_tmr.h:219
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_SELECT_CHANNEL_3C
@ TMR_SELECT_CHANNEL_3C
Definition: at32f413_tmr.h:221
TMR_WP_OFF
@ TMR_WP_OFF
Definition: at32f413_tmr.h:388
TMR_BRK_INPUT_ACTIVE_HIGH
@ TMR_BRK_INPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:380
TMR_OUTPUT_CONTROL_OFF
@ TMR_OUTPUT_CONTROL_OFF
Definition: at32f413_tmr.h:173
TMR_OUTPUT_CONTROL_PWM_MODE_A
@ TMR_OUTPUT_CONTROL_PWM_MODE_A
Definition: at32f413_tmr.h:179
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_HALL_FLAG
#define TMR_HALL_FLAG
Definition: at32f413_tmr.h:57
TMR_HALL_INT
#define TMR_HALL_INT
Definition: at32f413_tmr.h:79
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_brkdt_config_type
tmr brkdt config type
Definition: at32f413_tmr.h:423
tmr_brkdt_config_type::brk_enable
confirm_state brk_enable
Definition: at32f413_tmr.h:430
tmr_brkdt_config_type::deadtime
uint8_t deadtime
Definition: at32f413_tmr.h:424
tmr_brkdt_config_type::auto_output_enable
confirm_state auto_output_enable
Definition: at32f413_tmr.h:427
tmr_brkdt_config_type::wp_level
tmr_wp_level_type wp_level
Definition: at32f413_tmr.h:426
tmr_brkdt_config_type::fcsoen_state
confirm_state fcsoen_state
Definition: at32f413_tmr.h:428
tmr_brkdt_config_type::fcsodis_state
confirm_state fcsodis_state
Definition: at32f413_tmr.h:429
tmr_brkdt_config_type::brk_polarity
tmr_brk_polarity_type brk_polarity
Definition: at32f413_tmr.h:425
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • tmr
  • 7_pwm_output
  • inc
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • tmr
  • 7_pwm_output
  • inc
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • tmr
  • 7_pwm_output
  • inc
project/at_start_f413/examples/tmr/7_pwm_output/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • tmr
  • 7_pwm_output
  • src
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • tmr
  • 7_pwm_output
  • src
project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133 /* trigger TMR1 hall event */
134 tmr_event_sw_trigger(TMR1, TMR_HALL_SWTRIG);
135}
136
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/at32f413_int.c:113
tmr_event_sw_trigger
void tmr_event_sw_trigger(tmr_type *tmr_x, tmr_event_trigger_type tmr_event)
generate tmr event
Definition: at32f413_tmr.c:1405
TMR_HALL_SWTRIG
@ TMR_HALL_SWTRIG
Definition: at32f413_tmr.h:288
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • tmr
  • 7_pwm_output
  • src
project/at_start_f413/examples/tmr/7_pwm_output/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38 gpio_init_type gpio_init_struct = {0};
39 tmr_output_config_type tmr_output_struct;
40 crm_clocks_freq_type crm_clocks_freq_struct = {0};
41
42uint16_t timer_period = 0;
43uint16_t channel1_pulse = 0, channel2_pulse = 0, channel3_pulse = 0, channel4_pulse = 0;
44
50int main(void)
51{
52 system_clock_config();
53
54 at32_board_init();
55
56 /* get system clock */
57 crm_clocks_freq_get(&crm_clocks_freq_struct);
58
59 /* turn led2/led3/led4 on */
60 at32_led_on(LED2);
61 at32_led_on(LED3);
62 at32_led_on(LED4);
63
64 /* enable tmr1/gpioa/gpiob clock */
65 crm_periph_clock_enable(CRM_TMR1_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
67 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
68
69 /* timer1 output pin Configuration */
70 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11;
71 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
74 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
75 gpio_init(GPIOA, &gpio_init_struct);
76
77 gpio_init_struct.gpio_pins = GPIO_PINS_13 | GPIO_PINS_14 | GPIO_PINS_15;
78 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
81 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
82 gpio_init(GPIOB, &gpio_init_struct);
83
84 gpio_init_struct.gpio_pins = GPIO_PINS_12;
85 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
86 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
87 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
88 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
89 gpio_init(GPIOB, &gpio_init_struct);
90
91
92 /* tmr1 configuration generate 7 pwm signals with 4 different duty cycles:
93 prescaler = 0, tmr1 counter clock = system_core_clock
94
95 the objective is to generate 7 pwm signal at 17.57 khz:
96 - tim1_period = (system_core_clock / 17570) - 1
97 the channel 1 and channel 1n duty cycle is set to 50%
98 the channel 2 and channel 2n duty cycle is set to 37.5%
99 the channel 3 and channel 3n duty cycle is set to 25%
100 the channel 4 duty cycle is set to 12.5%
101 the timer pulse is calculated as follows:
102 - channelxpulse = duty_cycle * (tim1_period - 1) / 100 */
103
104 /* compute the value to be set in arr regiter to generate signal frequency at 17.57 khz */
105 timer_period = (crm_clocks_freq_struct.sclk_freq / 17570 ) - 1;
106
107 /* compute ccr1 value to generate a duty cycle at 50% for channel 1 and 1n */
108 channel1_pulse = (uint16_t)(((uint32_t) 5 * (timer_period - 1)) / 10);
109
110 /* compute ccr2 value to generate a duty cycle at 37.5% for channel 2 and 2n */
111 channel2_pulse = (uint16_t)(((uint32_t) 375 * (timer_period - 1)) / 1000);
112
113 /* compute ccr3 value to generate a duty cycle at 25% for channel 3 and 3n */
114 channel3_pulse = (uint16_t)(((uint32_t) 25 * (timer_period - 1)) / 100);
115
116 /* compute ccr4 value to generate a duty cycle at 12.5% for channel 4 */
117 channel4_pulse = (uint16_t)(((uint32_t) 125 * (timer_period- 1)) / 1000);
118
119 tmr_base_init(TMR1, timer_period, 0);
120 tmr_cnt_dir_set(TMR1, TMR_COUNT_UP);
121
122 /* channel 1, 2, 3 and 4 configuration in output mode */
123 tmr_output_default_para_init(&tmr_output_struct);
124 tmr_output_struct.oc_mode = TMR_OUTPUT_CONTROL_PWM_MODE_B;
125 tmr_output_struct.oc_output_state = TRUE;
126 tmr_output_struct.oc_polarity = TMR_OUTPUT_ACTIVE_LOW;
127 tmr_output_struct.oc_idle_state = TRUE;
128 tmr_output_struct.occ_output_state = TRUE;
129 tmr_output_struct.occ_polarity = TMR_OUTPUT_ACTIVE_HIGH;
130 tmr_output_struct.occ_idle_state = FALSE;
131
132 /* channel 1 */
133 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_1, &tmr_output_struct);
134 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_1, channel1_pulse);
135
136 /* channel 2 */
137 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_2, &tmr_output_struct);
138 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_2, channel2_pulse);
139
140 /* channel 3 */
141 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_3, &tmr_output_struct);
142 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_3, channel3_pulse);
143
144 /* channel 4 */
145 tmr_output_channel_config(TMR1, TMR_SELECT_CHANNEL_4, &tmr_output_struct);
146 tmr_channel_value_set(TMR1, TMR_SELECT_CHANNEL_4, channel4_pulse);
147
148 /* output enable */
149 tmr_output_enable(TMR1, TRUE);
150
151 /* enable tmr1 */
152 tmr_counter_enable(TMR1, TRUE);
153
154 while(1)
155 {
156 }
157}
158
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:38
channel1_pulse
uint16_t channel1_pulse
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:43
tmr_output_struct
tmr_output_config_type tmr_output_struct
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:39
timer_period
uint16_t timer_period
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:42
channel2_pulse
uint16_t channel2_pulse
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:43
channel3_pulse
uint16_t channel3_pulse
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:50
crm_clocks_freq_struct
crm_clocks_freq_type crm_clocks_freq_struct
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:40
channel4_pulse
uint16_t channel4_pulse
Definition: project/at_start_f413/examples/tmr/7_pwm_output/src/main.c:43
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_TMR1_PERIPH_CLOCK
@ CRM_TMR1_PERIPH_CLOCK
Definition: at32f413_crm.h:117
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
tmr_counter_enable
void tmr_counter_enable(tmr_type *tmr_x, confirm_state new_state)
enable or disable tmr counter
Definition: at32f413_tmr.c:110
tmr_output_channel_config
void tmr_output_channel_config(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, tmr_output_config_type *tmr_output_struct)
config tmr output channel
Definition: at32f413_tmr.c:319
tmr_output_default_para_init
void tmr_output_default_para_init(tmr_output_config_type *tmr_output_struct)
init tmr output default para
Definition: at32f413_tmr.c:122
tmr_output_enable
void tmr_output_enable(tmr_type *tmr_x, confirm_state new_state)
tmr output enable(oen),this function is important for advtm output enable
Definition: at32f413_tmr.c:1418
tmr_base_init
void tmr_base_init(tmr_type *tmr_x, uint32_t tmr_pr, uint32_t tmr_div)
init tmr base
Definition: at32f413_tmr.c:175
tmr_cnt_dir_set
void tmr_cnt_dir_set(tmr_type *tmr_x, tmr_count_mode_type tmr_cnt_dir)
set tmr counter count direction
Definition: at32f413_tmr.c:221
tmr_channel_value_set
void tmr_channel_value_set(tmr_type *tmr_x, tmr_channel_select_type tmr_channel, uint32_t tmr_channel_value)
set tmr channel value
Definition: at32f413_tmr.c:502
TMR_COUNT_UP
@ TMR_COUNT_UP
Definition: at32f413_tmr.h:106
TMR_SELECT_CHANNEL_3
@ TMR_SELECT_CHANNEL_3
Definition: at32f413_tmr.h:220
TMR_SELECT_CHANNEL_1
@ TMR_SELECT_CHANNEL_1
Definition: at32f413_tmr.h:216
TMR_SELECT_CHANNEL_4
@ TMR_SELECT_CHANNEL_4
Definition: at32f413_tmr.h:222
TMR_SELECT_CHANNEL_2
@ TMR_SELECT_CHANNEL_2
Definition: at32f413_tmr.h:218
TMR_OUTPUT_CONTROL_PWM_MODE_B
@ TMR_OUTPUT_CONTROL_PWM_MODE_B
Definition: at32f413_tmr.h:180
TMR_OUTPUT_ACTIVE_HIGH
@ TMR_OUTPUT_ACTIVE_HIGH
Definition: at32f413_tmr.h:197
TMR_OUTPUT_ACTIVE_LOW
@ TMR_OUTPUT_ACTIVE_LOW
Definition: at32f413_tmr.h:198
TMR1
#define TMR1
Definition: at32f413_tmr.h:832
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::sclk_freq
uint32_t sclk_freq
Definition: at32f413_crm.h:472
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
tmr_output_config_type
tmr output config type
Definition: at32f413_tmr.h:398
tmr_output_config_type::occ_output_state
confirm_state occ_output_state
Definition: at32f413_tmr.h:405
tmr_output_config_type::oc_idle_state
confirm_state oc_idle_state
Definition: at32f413_tmr.h:400
tmr_output_config_type::oc_output_state
confirm_state oc_output_state
Definition: at32f413_tmr.h:404
tmr_output_config_type::oc_mode
tmr_output_control_mode_type oc_mode
Definition: at32f413_tmr.h:399
tmr_output_config_type::occ_polarity
tmr_output_polarity_type occ_polarity
Definition: at32f413_tmr.h:403
tmr_output_config_type::occ_idle_state
confirm_state occ_idle_state
Definition: at32f413_tmr.h:401
tmr_output_config_type::oc_polarity
tmr_output_polarity_type oc_polarity
Definition: at32f413_tmr.h:402
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • half_duplex
  • inc
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • half_duplex
  • inc
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • half_duplex
  • inc
project/at_start_f413/examples/usart/half_duplex/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • half_duplex
  • src
project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • half_duplex
  • src
project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/half_duplex/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • half_duplex
  • src
project/at_start_f413/examples/usart/half_duplex/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart half-duplex transfer: usart2 -> usart3";
43uint8_t usart3_tx_buffer[] = "usart half-duplex transfer: usart3 -> usart2";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46uint8_t data_count;
47
53void usart_configuration(void)
54{
55 gpio_init_type gpio_init_struct;
56
57 /* enable the usart2 and gpio clock */
58 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
59 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
60
61 /* enable the usart3 and gpio clock */
62 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
63 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
64
65 gpio_default_para_init(&gpio_init_struct);
66
67 /* configure the usart2 tx pin */
68 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
69 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
70 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
71 gpio_init_struct.gpio_pins = GPIO_PINS_2;
72 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
73 gpio_init(GPIOA, &gpio_init_struct);
74
75 /* configure the usart3 tx pin */
76 gpio_init_struct.gpio_pins = GPIO_PINS_10;
77 gpio_init(GPIOB, &gpio_init_struct);
78
79 /* configure usart2 param */
80 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
81 usart_transmitter_enable(USART2, TRUE);
82 usart_receiver_enable(USART2, TRUE);
83 usart_single_line_halfduplex_select(USART2, TRUE);
84 usart_enable(USART2, TRUE);
85
86 /* configure usart3 param */
87 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
88 usart_transmitter_enable(USART3, TRUE);
89 usart_receiver_enable(USART3, TRUE);
90 usart_single_line_halfduplex_select(USART3, TRUE);
91 usart_enable(USART3, TRUE);
92}
93
101uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
102{
103 while(buffer_length--)
104 {
105 if(*pbuffer1 != *pbuffer2)
106 {
107 return 0;
108 }
109 pbuffer1++;
110 pbuffer2++;
111 }
112 return 1;
113}
114
120int main(void)
121{
122 system_clock_config();
123 at32_board_init();
124 usart_configuration();
125
126 /* usart2 transmit and usart3 receive */
127 data_count = USART2_TX_BUFFER_SIZE;
128 while(data_count)
129 {
130 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
131 usart_data_transmit(USART2, usart2_tx_buffer[USART2_TX_BUFFER_SIZE-data_count]);
132 while(usart_flag_get(USART3, USART_RDBF_FLAG) == RESET);
133 usart3_rx_buffer[USART2_TX_BUFFER_SIZE-data_count] = usart_data_receive(USART3);
134 data_count--;
135 }
136
137 /* usart3 transmit and usart2 receive */
138 data_count = USART3_TX_BUFFER_SIZE;
139 while(data_count)
140 {
141 while(usart_flag_get(USART3, USART_TDBE_FLAG) == RESET);
142 usart_data_transmit(USART3, usart3_tx_buffer[USART3_TX_BUFFER_SIZE-data_count]);
143 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
144 usart2_rx_buffer[USART3_TX_BUFFER_SIZE-data_count] = usart_data_receive(USART2);
145 data_count--;
146 }
147
148 while(1)
149 {
150 /* compare data buffer */
151 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
152 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
153 {
154 at32_led_toggle(LED2);
155 at32_led_toggle(LED3);
156 at32_led_toggle(LED4);
157 delay_sec(1);
158 }
159 }
160}
161
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:53
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:101
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:45
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:120
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:40
data_count
uint8_t data_count
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:46
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:43
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:44
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:133
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:236
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
usart_single_line_halfduplex_select
void usart_single_line_halfduplex_select(usart_type *usart_x, confirm_state new_state)
enable or disable the usart single line bidirectional half-duplex communication.
Definition: at32f413_usart.c:470
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART3
#define USART3
Definition: at32f413_usart.h:321
USART2
#define USART2
Definition: at32f413_usart.h:320
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • hw_flow_control
  • inc
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • hw_flow_control
  • inc
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • hw_flow_control
  • inc
project/at_start_f413/examples/usart/hw_flow_control/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • hw_flow_control
  • src
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • hw_flow_control
  • src
project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • hw_flow_control
  • src
project/at_start_f413/examples/usart/hw_flow_control/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define BUFFER_SIZE 16
39
40uint8_t rx_buffer[BUFFER_SIZE];
41uint8_t data_count;
42
48void usart_configuration(void)
49{
50 gpio_init_type gpio_init_struct;
51
52 /* enable the usart2 and gpio clock */
53 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
54 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
55
56 gpio_default_para_init(&gpio_init_struct);
57
58 /* configure the usart2 tx and rts pin */
59 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
60 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
61 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
62 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_1;
63 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
64 gpio_init(GPIOA, &gpio_init_struct);
65
66 /* configure the usart2 rx and cts pin */
67 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
68 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
69 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
70 gpio_init_struct.gpio_pins = GPIO_PINS_3 | GPIO_PINS_0;
71 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
72 gpio_init(GPIOA, &gpio_init_struct);
73
74 /* configure usart2 param */
75 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
76 usart_hardware_flow_control_set(USART2, USART_HARDWARE_FLOW_RTS_CTS);
77 usart_transmitter_enable(USART2, TRUE);
78 usart_receiver_enable(USART2, TRUE);
79 usart_enable(USART2, TRUE);
80}
81
87int main(void)
88{
89 system_clock_config();
90 at32_board_init();
91 usart_configuration();
92
93 /* receive a string (BUFFER_SIZE bytes) from the hyperterminal */
94 data_count = BUFFER_SIZE;
95 while(data_count)
96 {
97 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
98 rx_buffer[BUFFER_SIZE-data_count] = usart_data_receive(USART2);
99 data_count--;
100 }
101
102 /* send a buffer from usart to hyperterminal */
103 data_count = BUFFER_SIZE;
104 while(data_count)
105 {
106 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
107 usart_data_transmit(USART2, rx_buffer[BUFFER_SIZE-data_count]);
108 data_count--;
109 }
110
111 while(1)
112 {
113 at32_led_toggle(LED2);
114 at32_led_toggle(LED3);
115 at32_led_toggle(LED4);
116 delay_sec(1);
117 }
118}
119
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
rx_buffer
uint8_t rx_buffer[16]
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:40
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:48
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:38
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:87
data_count
uint8_t data_count
Definition: project/at_start_f413/examples/usart/hw_flow_control/src/main.c:41
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_0
#define GPIO_PINS_0
Definition: at32f413_gpio.h:51
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_hardware_flow_control_set
void usart_hardware_flow_control_set(usart_type *usart_x, usart_hardware_flow_control_type flow_state)
configure the usart's hardware flow control.
Definition: at32f413_usart.c:516
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_HARDWARE_FLOW_RTS_CTS
@ USART_HARDWARE_FLOW_RTS_CTS
Definition: at32f413_usart.h:172
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART2
#define USART2
Definition: at32f413_usart.h:320
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • idle_detection
  • inc
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • idle_detection
  • inc
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • idle_detection
  • inc
project/at_start_f413/examples/usart/idle_detection/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • idle_detection
  • src
project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • idle_detection
  • src
project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void USART2_IRQHandler(void)
142{
143 if(usart_flag_get(USART2, USART_IDLEF_FLAG))
144 {
145 usart_data_receive(USART2);
146 at32_led_on(LED2);
147 at32_led_on(LED3);
148 at32_led_on(LED4);
149 }
150}
151
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
USART2_IRQHandler
void USART2_IRQHandler(void)
this function handles usart2 handler.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:141
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/idle_detection/src/at32f413_int.c:114
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_IDLEF_FLAG
#define USART_IDLEF_FLAG
Definition: at32f413_usart.h:56
USART2
#define USART2
Definition: at32f413_usart.h:320
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • idle_detection
  • src
project/at_start_f413/examples/usart/idle_detection/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
43void usart_configuration(void)
44{
45 gpio_init_type gpio_init_struct;
46
47 /* enable the usart2 and gpio clock */
48 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
49 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
50
51 gpio_default_para_init(&gpio_init_struct);
52
53 /* configure the usart2 tx pin */
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pins = GPIO_PINS_2;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init(GPIOA, &gpio_init_struct);
60
61 /* configure the usart2 rx pin */
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
64 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
65 gpio_init_struct.gpio_pins = GPIO_PINS_3;
66 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
67 gpio_init(GPIOA, &gpio_init_struct);
68
69 /* config usart nvic interrupt */
70 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
71 nvic_irq_enable(USART2_IRQn, 0, 0);
72
73 /* configure usart2 param */
74 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
75 usart_transmitter_enable(USART2, TRUE);
76 usart_receiver_enable(USART2, TRUE);
77 usart_interrupt_enable(USART2, USART_IDLE_INT, TRUE);
78 usart_enable(USART2, TRUE);
79}
80
86int main(void)
87{
88 system_clock_config();
89 at32_board_init();
90 at32_led_off(LED2);
91 at32_led_off(LED3);
92 at32_led_off(LED4);
93 usart_configuration();
94
95 /* transmit a data */
96 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
97 usart_data_transmit(USART2, 0x55);
98
99 /* receive a data from the tx pin */
100 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
101 usart_data_receive(USART2);
102
103 while(1)
104 {
105 }
106}
107
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/idle_detection/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/idle_detection/src/main.c:86
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:172
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART_IDLE_INT
#define USART_IDLE_INT
Definition: at32f413_usart.h:72
USART2
#define USART2
Definition: at32f413_usart.h:320
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • interrupt
  • inc
project/at_start_f413/examples/usart/interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • interrupt
  • inc
project/at_start_f413/examples/usart/interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • interrupt
  • inc
project/at_start_f413/examples/usart/interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • interrupt
  • src
project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • interrupt
  • src
project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30extern uint8_t usart2_tx_buffer[];
31extern uint8_t usart3_tx_buffer[];
32extern uint8_t usart2_rx_buffer[];
33extern uint8_t usart3_rx_buffer[];
34extern uint8_t usart2_tx_counter;
35extern uint8_t usart3_tx_counter;
36extern uint8_t usart2_rx_counter;
37extern uint8_t usart3_rx_counter;
38extern uint8_t usart2_tx_buffer_size;
39extern uint8_t usart3_tx_buffer_size;
40
54void NMI_Handler(void)
55{
56}
57
63void HardFault_Handler(void)
64{
65 /* go to infinite loop when hard fault exception occurs */
66 while(1)
67 {
68 }
69}
70
76void MemManage_Handler(void)
77{
78 /* go to infinite loop when memory manage exception occurs */
79 while(1)
80 {
81 }
82}
83
89void BusFault_Handler(void)
90{
91 /* go to infinite loop when bus fault exception occurs */
92 while(1)
93 {
94 }
95}
96
102void UsageFault_Handler(void)
103{
104 /* go to infinite loop when usage fault exception occurs */
105 while(1)
106 {
107 }
108}
109
115void SVC_Handler(void)
116{
117}
118
124void DebugMon_Handler(void)
125{
126}
127
133void PendSV_Handler(void)
134{
135}
136
142void SysTick_Handler(void)
143{
144}
145
151void USART2_IRQHandler(void)
152{
153 if(usart_flag_get(USART2, USART_RDBF_FLAG) != RESET)
154 {
155 /* read one byte from the receive data register */
156 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
157
158 if(usart2_rx_counter == usart3_tx_buffer_size)
159 {
160 /* disable the usart2 receive interrupt */
161 usart_interrupt_enable(USART2, USART_RDBF_INT, FALSE);
162 }
163 }
164
165 if(usart_flag_get(USART2, USART_TDBE_FLAG) != RESET)
166 {
167 /* write one byte to the transmit data register */
168 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
169
170 if(usart2_tx_counter == usart2_tx_buffer_size)
171 {
172 /* disable the usart2 transmit interrupt */
173 usart_interrupt_enable(USART2, USART_TDBE_INT, FALSE);
174 }
175 }
176}
177
183void USART3_IRQHandler(void)
184{
185 if(usart_flag_get(USART3, USART_RDBF_FLAG) != RESET)
186 {
187 /* read one byte from the receive data register */
188 usart3_rx_buffer[usart3_rx_counter++] = usart_data_receive(USART3);
189
190 if(usart3_rx_counter == usart2_tx_buffer_size)
191 {
192 /* disable the usart3 receive interrupt */
193 usart_interrupt_enable(USART3, USART_RDBF_INT, FALSE);
194 }
195 }
196
197 if(usart_flag_get(USART3, USART_TDBE_FLAG) != RESET)
198 {
199 /* write one byte to the transmit data register */
200 usart_data_transmit(USART3, usart3_tx_buffer[usart3_tx_counter++]);
201
202 if(usart3_tx_counter == usart3_tx_buffer_size)
203 {
204 /* disable the usart3 transmit interrupt */
205 usart_interrupt_enable(USART3, USART_TDBE_INT, FALSE);
206 }
207 }
208}
209
usart3_rx_buffer
uint8_t usart3_rx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:45
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:42
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:43
usart2_rx_buffer
uint8_t usart2_rx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:44
USART2_IRQHandler
void USART2_IRQHandler(void)
this function handles usart2 handler.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:151
USART3_IRQHandler
void USART3_IRQHandler(void)
this function handles usart3 handler.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:183
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:102
usart3_rx_counter
uint8_t usart3_rx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:49
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:48
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:63
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:76
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:115
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:46
usart3_tx_counter
uint8_t usart3_tx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:47
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:50
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:133
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:54
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:89
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:51
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:142
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/interrupt/src/at32f413_int.c:124
FALSE
@ FALSE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART_TDBE_INT
#define USART_TDBE_INT
Definition: at32f413_usart.h:75
USART3
#define USART3
Definition: at32f413_usart.h:321
USART2
#define USART2
Definition: at32f413_usart.h:320
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • interrupt
  • src
project/at_start_f413/examples/usart/interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt";
43uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46volatile uint8_t usart2_tx_counter = 0x00;
47volatile uint8_t usart3_tx_counter = 0x00;
48volatile uint8_t usart2_rx_counter = 0x00;
49volatile uint8_t usart3_rx_counter = 0x00;
50uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
51uint8_t usart3_tx_buffer_size = USART3_TX_BUFFER_SIZE;
52
58void usart_configuration(void)
59{
60 gpio_init_type gpio_init_struct;
61
62 /* enable the usart2 and gpio clock */
63 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* enable the usart3 and gpio clock */
67 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
69
70 gpio_default_para_init(&gpio_init_struct);
71
72 /* configure the usart2 tx pin */
73 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
76 gpio_init_struct.gpio_pins = GPIO_PINS_2;
77 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
78 gpio_init(GPIOA, &gpio_init_struct);
79
80 /* configure the usart3 tx pin */
81 gpio_init_struct.gpio_pins = GPIO_PINS_10;
82 gpio_init(GPIOB, &gpio_init_struct);
83
84 /* configure the usart2 rx pin */
85 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
86 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
87 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
88 gpio_init_struct.gpio_pins = GPIO_PINS_3;
89 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
90 gpio_init(GPIOA, &gpio_init_struct);
91
92 /* configure the usart3 rx pin */
93 gpio_init_struct.gpio_pins = GPIO_PINS_11;
94 gpio_init(GPIOB, &gpio_init_struct);
95
96 /* config usart nvic interrupt */
97 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
98 nvic_irq_enable(USART2_IRQn, 0, 0);
99 nvic_irq_enable(USART3_IRQn, 0, 0);
100
101 /* configure usart2 param */
102 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
103 usart_transmitter_enable(USART2, TRUE);
104 usart_receiver_enable(USART2, TRUE);
105
106 /* configure usart3 param */
107 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
108 usart_transmitter_enable(USART3, TRUE);
109 usart_receiver_enable(USART3, TRUE);
110
111 /* enable usart2 and usart3 interrupt */
112 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
113 usart_enable(USART2, TRUE);
114
115 usart_interrupt_enable(USART3, USART_RDBF_INT, TRUE);
116 usart_enable(USART3, TRUE);
117
118 usart_interrupt_enable(USART2, USART_TDBE_INT, TRUE);
119 usart_interrupt_enable(USART3, USART_TDBE_INT, TRUE);
120}
121
129uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
130{
131 while(buffer_length--)
132 {
133 if(*pbuffer1 != *pbuffer2)
134 {
135 return 0;
136 }
137 pbuffer1++;
138 pbuffer2++;
139 }
140 return 1;
141}
142
148int main(void)
149{
150 system_clock_config();
151 at32_board_init();
152 usart_configuration();
153
154 /* wait until end of transmission from usart2 to usart3 */
155 while(usart3_rx_counter < usart2_tx_buffer_size);
156
157 /* wait until end of transmission from usart3 to usart2 */
158 while(usart2_rx_counter < usart3_tx_buffer_size);
159
160 while(1)
161 {
162 /* compare data buffer */
163 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
164 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
165 {
166 at32_led_toggle(LED2);
167 at32_led_toggle(LED3);
168 at32_led_toggle(LED4);
169 delay_sec(1);
170 }
171 }
172}
173
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:58
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:129
usart3_rx_counter
volatile uint8_t usart3_rx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:49
usart2_rx_counter
volatile uint8_t usart2_rx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:48
usart2_tx_counter
volatile uint8_t usart2_tx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:46
usart3_tx_counter
volatile uint8_t usart3_tx_counter
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:47
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:50
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:45
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:148
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:51
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:43
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/interrupt/src/main.c:44
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:133
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:172
USART3_IRQn
@ USART3_IRQn
Definition: at32f413.h:173
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART_TDBE_INT
#define USART_TDBE_INT
Definition: at32f413_usart.h:75
USART3
#define USART3
Definition: at32f413_usart.h:321
USART2
#define USART2
Definition: at32f413_usart.h:320
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • irda
  • inc
project/at_start_f413/examples/usart/irda/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • irda
  • inc
project/at_start_f413/examples/usart/irda/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • irda
  • inc
project/at_start_f413/examples/usart/irda/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • irda
  • src
project/at_start_f413/examples/usart/irda/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • irda
  • src
project/at_start_f413/examples/usart/irda/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/irda/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • irda
  • src
project/at_start_f413/examples/usart/irda/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
43void usart_configuration(void)
44{
45 gpio_init_type gpio_init_struct;
46
47 /* enable the usart2 and gpio clock */
48 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
49 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
50
51 gpio_default_para_init(&gpio_init_struct);
52
53 /* configure the usart2 tx pin */
54 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
55 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
56 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
57 gpio_init_struct.gpio_pins = GPIO_PINS_2;
58 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
59 gpio_init(GPIOA, &gpio_init_struct);
60
61 /* configure the usart2 rx pin */
62 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
63 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
64 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
65 gpio_init_struct.gpio_pins = GPIO_PINS_3;
66 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
67 gpio_init(GPIOA, &gpio_init_struct);
68
69 /* configure usart2 param */
70 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
71 usart_transmitter_enable(USART2, TRUE);
72 usart_receiver_enable(USART2, TRUE);
73 usart_irda_smartcard_division_set(USART2, 0x01);
74 usart_irda_mode_enable(USART2, TRUE);
75 usart_enable(USART2, TRUE);
76}
77
83int main(void)
84{
85 system_clock_config();
86 at32_board_init();
87 at32_led_off(LED2);
88 at32_led_off(LED3);
89 at32_led_off(LED4);
90 usart_configuration();
91
92#if defined(TRANSMIT)
93 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
94 usart_data_transmit(USART2, 0x55);
95 at32_led_on(LED4);
96#endif
97
98#if defined(RECEIVE)
99 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
100 if(usart_data_receive(USART2) == 0x55)
101 {
102 at32_led_on(LED4);
103 }
104#endif
105
106 while(1)
107 {
108 }
109}
110
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/irda/src/main.c:43
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/irda/src/main.c:83
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f413_usart.c:426
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_irda_mode_enable
void usart_irda_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's irda interface.
Definition: at32f413_usart.c:484
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART2
#define USART2
Definition: at32f413_usart.h:320
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • polling
  • inc
project/at_start_f413/examples/usart/polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • polling
  • inc
project/at_start_f413/examples/usart/polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • polling
  • inc
project/at_start_f413/examples/usart/polling/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • polling
  • src
project/at_start_f413/examples/usart/polling/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • polling
  • src
project/at_start_f413/examples/usart/polling/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/polling/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • polling
  • src
project/at_start_f413/examples/usart/polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart transfer by interrupt: usart2 -> usart3 using interrupt";
43uint8_t usart3_tx_buffer[] = "usart transfer by interrupt: usart3 -> usart2 using interrupt";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46uint8_t usart2_tx_counter = 0x00;
47uint8_t usart3_tx_counter = 0x00;
48uint8_t usart2_rx_counter = 0x00;
49uint8_t usart3_rx_counter = 0x00;
50uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
51uint8_t usart3_tx_buffer_size = USART3_TX_BUFFER_SIZE;
52
58void usart_configuration(void)
59{
60 gpio_init_type gpio_init_struct;
61
62 /* enable the usart2 and gpio clock */
63 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
64 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
65
66 /* enable the usart3 and gpio clock */
67 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
68 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
69
70 gpio_default_para_init(&gpio_init_struct);
71
72 /* configure the usart2 tx pin */
73 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
76 gpio_init_struct.gpio_pins = GPIO_PINS_2;
77 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
78 gpio_init(GPIOA, &gpio_init_struct);
79
80 /* configure the usart3 tx pin */
81 gpio_init_struct.gpio_pins = GPIO_PINS_10;
82 gpio_init(GPIOB, &gpio_init_struct);
83
84 /* configure the usart2 rx pin */
85 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
86 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
87 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
88 gpio_init_struct.gpio_pins = GPIO_PINS_3;
89 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
90 gpio_init(GPIOA, &gpio_init_struct);
91
92 /* configure the usart3 rx pin */
93 gpio_init_struct.gpio_pins = GPIO_PINS_11;
94 gpio_init(GPIOB, &gpio_init_struct);
95
96 /* configure usart2 param */
97 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
98 usart_parity_selection_config(USART2, USART_PARITY_NONE);
99 usart_transmitter_enable(USART2, TRUE);
100 usart_receiver_enable(USART2, TRUE);
101 usart_enable(USART2, TRUE);
102
103 /* configure usart3 param */
104 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
105 usart_parity_selection_config(USART3, USART_PARITY_NONE);
106 usart_transmitter_enable(USART3, TRUE);
107 usart_receiver_enable(USART3, TRUE);
108 usart_enable(USART3, TRUE);
109}
110
118uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
119{
120 while(buffer_length--)
121 {
122 if(*pbuffer1 != *pbuffer2)
123 {
124 return 0;
125 }
126 pbuffer1++;
127 pbuffer2++;
128 }
129 return 1;
130}
131
137int main(void)
138{
139 system_clock_config();
140 at32_board_init();
141 usart_configuration();
142
143 /* wait until end of transmission from usart2 to usart3 */
144 while(usart3_rx_counter < usart2_tx_buffer_size)
145 {
146 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
147 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
148
149 while(usart_flag_get(USART3, USART_RDBF_FLAG) == RESET);
150 usart3_rx_buffer[usart3_rx_counter++] = usart_data_receive(USART3);
151 }
152
153 /* wait until end of transmission from usart3 to usart2 */
154 while(usart2_rx_counter < usart3_tx_buffer_size)
155 {
156 while(usart_flag_get(USART3, USART_TDBE_FLAG) == RESET);
157 usart_data_transmit(USART3, usart3_tx_buffer[usart3_tx_counter++]);
158
159 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
160 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
161 }
162
163 while(1)
164 {
165 /* compare data buffer */
166 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
167 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
168 {
169 at32_led_toggle(LED2);
170 at32_led_toggle(LED3);
171 at32_led_toggle(LED4);
172 delay_sec(1);
173 }
174 }
175}
176
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/polling/src/main.c:58
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/polling/src/main.c:118
usart3_tx_counter
uint8_t usart3_tx_counter
Definition: project/at_start_f413/examples/usart/polling/src/main.c:47
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f413/examples/usart/polling/src/main.c:46
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/polling/src/main.c:50
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/polling/src/main.c:45
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f413/examples/usart/polling/src/main.c:48
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/polling/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/polling/src/main.c:137
usart3_tx_buffer_size
uint8_t usart3_tx_buffer_size
Definition: project/at_start_f413/examples/usart/polling/src/main.c:51
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/polling/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/polling/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/polling/src/main.c:43
usart3_rx_counter
uint8_t usart3_rx_counter
Definition: project/at_start_f413/examples/usart/polling/src/main.c:49
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/polling/src/main.c:44
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:133
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:138
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:94
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART3
#define USART3
Definition: at32f413_usart.h:321
USART2
#define USART2
Definition: at32f413_usart.h:320
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • printf
  • inc
project/at_start_f413/examples/usart/printf/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • printf
  • inc
project/at_start_f413/examples/usart/printf/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • printf
  • inc
project/at_start_f413/examples/usart/printf/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • printf
  • src
project/at_start_f413/examples/usart/printf/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • printf
  • src
project/at_start_f413/examples/usart/printf/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/printf/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • printf
  • src
project/at_start_f413/examples/usart/printf/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38__IO uint32_t time_cnt = 0;
39
45int main(void)
46{
47 system_clock_config();
48 at32_board_init();
49 uart_print_init(115200);
50
51 /* output a message on hyperterminal using printf function */
52 printf("usart printf example: retarget the c library printf function to the usart\r\n");
53
54 while(1)
55 {
56 printf("usart printf counter: %u\r\n",time_cnt++);
57 delay_sec(1);
58 }
59}
60
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/printf/src/main.c:45
time_cnt
__IO uint32_t time_cnt
Definition: project/at_start_f413/examples/usart/printf/src/main.c:38
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • receiver_mute
  • inc
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • receiver_mute
  • inc
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • receiver_mute
  • inc
project/at_start_f413/examples/usart/receiver_mute/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • receiver_mute
  • src
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • receiver_mute
  • src
project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30extern uint8_t usart3_rx_buffer[];
31extern uint8_t rx_counter;
32
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void USART3_IRQHandler(void)
144{
145 if(usart_flag_get(USART3, USART_RDBF_FLAG) != RESET)
146 {
147 usart3_rx_buffer[rx_counter++] = usart_data_receive(USART3);
148 }
149}
150
usart3_rx_buffer
uint8_t usart3_rx_buffer[]
Definition: project/at_start_f413/examples/usart/half_duplex/src/main.c:45
USART3_IRQHandler
void USART3_IRQHandler(void)
this function handles usart3 handler.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:143
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:107
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:46
rx_counter
uint8_t rx_counter
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:49
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:81
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/at32f413_int.c:116
RESET
@ RESET
Definition: at32f413.h:254
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART3
#define USART3
Definition: at32f413_usart.h:321
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • receiver_mute
  • src
project/at_start_f413/examples/usart/receiver_mute/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define BUFFER_SIZE 7
39#define MATCH_ID_VAL 0x81
40#define ERROR_ID_VAL 0x82
41#define DATA1_VAL 0x7F
42#define DATA2_VAL 0x7A
43#define DATA3_VAL 0x7B
44#define DATA4_VAL 0x7C
45
46uint8_t usart2_tx_buffer[BUFFER_SIZE] = {DATA1_VAL, MATCH_ID_VAL, DATA2_VAL, ERROR_ID_VAL, DATA3_VAL, MATCH_ID_VAL, DATA4_VAL};
47uint8_t usart3_rx_buffer[BUFFER_SIZE];
48uint8_t tx_counter = 0;
49uint8_t rx_counter = 0;
50
56void usart_configuration(void)
57{
58 gpio_init_type gpio_init_struct;
59
60 /* enable the usart2 and gpio clock */
61 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* enable the usart3 and gpio clock */
65 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
67
68 gpio_default_para_init(&gpio_init_struct);
69
70 /* configure the usart2 tx pin */
71 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
72 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
73 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
74 gpio_init_struct.gpio_pins = GPIO_PINS_2;
75 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
76 gpio_init(GPIOA, &gpio_init_struct);
77
78 /* configure the usart3 rx pin */
79 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
80 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
81 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
82 gpio_init_struct.gpio_pins = GPIO_PINS_11;
83 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
84 gpio_init(GPIOB, &gpio_init_struct);
85
86 /* configure usart2 param */
87 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
88 usart_transmitter_enable(USART2, TRUE);
89 usart_enable(USART2, TRUE);
90
91 /* config usart3 nvic interrupt */
92 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
93 nvic_irq_enable(USART3_IRQn, 0 ,0);
94
95 /* configure usart3 param */
96 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
97 usart_receiver_enable(USART3, TRUE);
98 usart_interrupt_enable(USART3, USART_RDBF_INT, TRUE);
99 usart_wakeup_id_set(USART3, 0x01);
100 usart_wakeup_mode_set(USART3, USART_WAKEUP_BY_MATCHING_ID);
101 usart_receiver_mute_enable(USART3, TRUE);
102 usart_enable(USART3, TRUE);
103}
104
110int main(void)
111{
112 system_clock_config();
113 at32_board_init();
114 usart_configuration();
115
116 /* usart2 transmit data */
117 while(tx_counter < BUFFER_SIZE)
118 {
119 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
120 usart_data_transmit(USART2, usart2_tx_buffer[tx_counter++]);
121 }
122
123 /* wait usart2 data transmission complete */
124 while(usart_flag_get(USART2, USART_TDC_FLAG) == RESET);
125
126 while(1)
127 {
128 if((usart3_rx_buffer[0] == MATCH_ID_VAL) && (usart3_rx_buffer[1] == DATA2_VAL) && \
129 (usart3_rx_buffer[2] == MATCH_ID_VAL) && (usart3_rx_buffer[3] == DATA4_VAL))
130 {
131 at32_led_toggle(LED2);
132 at32_led_toggle(LED3);
133 at32_led_toggle(LED4);
134 delay_sec(1);
135 }
136 }
137}
138
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
DATA4_VAL
#define DATA4_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:44
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:56
usart2_tx_buffer
uint8_t usart2_tx_buffer[7]
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:46
ERROR_ID_VAL
#define ERROR_ID_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:40
tx_counter
uint8_t tx_counter
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:48
BUFFER_SIZE
#define BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:38
rx_counter
uint8_t rx_counter
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:110
DATA2_VAL
#define DATA2_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:42
DATA3_VAL
#define DATA3_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:43
MATCH_ID_VAL
#define MATCH_ID_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:39
usart3_rx_buffer
uint8_t usart3_rx_buffer[7]
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:47
DATA1_VAL
#define DATA1_VAL
Definition: project/at_start_f413/examples/usart/receiver_mute/src/main.c:41
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:133
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
USART3_IRQn
@ USART3_IRQn
Definition: at32f413.h:173
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_wakeup_id_set
void usart_wakeup_id_set(usart_type *usart_x, uint8_t usart_id)
set the wakeup id of the usart.
Definition: at32f413_usart.c:301
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_wakeup_mode_set
void usart_wakeup_mode_set(usart_type *usart_x, usart_wakeup_mode_type wakeup_mode)
select the usart wakeup method in multi-processor communication.
Definition: at32f413_usart.c:317
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_receiver_mute_enable
void usart_receiver_mute_enable(usart_type *usart_x, confirm_state new_state)
config the usart in mute mode in multi-processor communication.
Definition: at32f413_usart.c:331
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_WAKEUP_BY_MATCHING_ID
@ USART_WAKEUP_BY_MATCHING_ID
Definition: at32f413_usart.h:105
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:58
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART3
#define USART3
Definition: at32f413_usart.h:321
USART2
#define USART2
Definition: at32f413_usart.h:320
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • rs485
  • inc
project/at_start_f413/examples/usart/rs485/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • rs485
  • inc
project/at_start_f413/examples/usart/rs485/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • rs485
  • inc
project/at_start_f413/examples/usart/rs485/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • rs485
  • src
project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • rs485
  • src
project/at_start_f413/examples/usart/rs485/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/rs485/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • rs485
  • src
project/at_start_f413/examples/usart/rs485/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define RS485_BAUDRATE 9600
39#define RS485_BUFFER_SIZE 128
40
41uint8_t rs485_buffer_rx[RS485_BUFFER_SIZE];
42uint8_t rs485_buffer_rx_cnt = 0;
43
49static void rs485_config(void)
50{
51 gpio_init_type gpio_init_struct;
52
53 /* enable the uart2 and gpio clock */
54 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
56
57 gpio_default_para_init(&gpio_init_struct);
58
59 /* configure the uart2 tx,rx,de pin */
60 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
61 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
62 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
63 gpio_init_struct.gpio_pins = GPIO_PINS_2;
64 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
65 gpio_init(GPIOA, &gpio_init_struct);
66
67 gpio_init_struct.gpio_pins = GPIO_PINS_3;
68 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
69 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
70 gpio_init(GPIOA, &gpio_init_struct);
71
72 gpio_init_struct.gpio_pins = GPIO_PINS_1;
73 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
74 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
75 gpio_init(GPIOA, &gpio_init_struct);
76
77 gpio_bits_reset(GPIOA, GPIO_PINS_1);
78
79 /* configure uart2 param */
80 usart_init(USART2, RS485_BAUDRATE, USART_DATA_8BITS, USART_STOP_1_BIT);
81
82 usart_flag_clear(USART2, USART_RDBF_FLAG);
83 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
84
85 usart_receiver_enable(USART2, TRUE);
86 usart_transmitter_enable(USART2, TRUE);
87 usart_enable(USART2, TRUE);
88
89 nvic_irq_enable(USART2_IRQn, 1, 0);
90}
91
98static void rs485_send_data(u8* buf, u8 cnt)
99{
100 gpio_bits_set(GPIOA, GPIO_PINS_1);
101 while(cnt--){
102 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
103 usart_data_transmit(USART2, *buf++);
104 }
105 while(usart_flag_get(USART2, USART_TDC_FLAG) == RESET);
106 gpio_bits_reset(GPIOA, GPIO_PINS_1);
107}
108
114int main(void)
115{
116 char str[]="start test..\r\n";
117 u8 len = 0;
118
119 system_clock_config();
120 at32_board_init();
121 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
122
123 rs485_config();
124
125 len = sizeof(str);
126 rs485_send_data((u8*)str, len);
127 while(1)
128 {
129 if(usart_flag_get(USART2, USART_IDLEF_FLAG) != RESET)
130 {
131 usart_data_receive(USART2);
132 usart_interrupt_enable(USART2, USART_RDBF_INT, FALSE);
133 rs485_send_data(rs485_buffer_rx, rs485_buffer_rx_cnt);
134 rs485_buffer_rx_cnt = 0;
135 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
136 }
137 }
138}
139
145void USART2_IRQHandler(void)
146{
147 uint16_t tmp;
148
149 if(usart_flag_get(USART2, USART_RDBF_FLAG) != RESET)
150 {
151 tmp = usart_data_receive(USART2);
152 if(rs485_buffer_rx_cnt < RS485_BUFFER_SIZE)
153 {
154 rs485_buffer_rx[rs485_buffer_rx_cnt++] = tmp;
155 }
156 }
157}
158
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:172
u8
uint8_t u8
Definition: at32f413.h:237
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
USART2_IRQHandler
void USART2_IRQHandler(void)
usart2 interrupt handler
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:145
rs485_send_data
static void rs485_send_data(u8 *buf, u8 cnt)
rs485 send data
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:98
RS485_BAUDRATE
#define RS485_BAUDRATE
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:38
rs485_config
static void rs485_config(void)
rs485 configiguration.
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:114
rs485_buffer_rx
uint8_t rs485_buffer_rx[128]
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:41
RS485_BUFFER_SIZE
#define RS485_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:39
rs485_buffer_rx_cnt
uint8_t rs485_buffer_rx_cnt
Definition: project/at_start_f413/examples/usart/rs485/src/main.c:42
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:341
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:310
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIO_PINS_1
#define GPIO_PINS_1
Definition: at32f413_gpio.h:52
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_flag_clear
void usart_flag_clear(usart_type *usart_x, uint32_t flag)
clear the usart's pending flags.
Definition: at32f413_usart.c:592
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_IDLEF_FLAG
#define USART_IDLEF_FLAG
Definition: at32f413_usart.h:56
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_TDC_FLAG
#define USART_TDC_FLAG
Definition: at32f413_usart.h:58
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART2
#define USART2
Definition: at32f413_usart.h:320
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • smartcard
  • inc
project/at_start_f413/examples/usart/smartcard/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • smartcard
  • inc
project/at_start_f413/examples/usart/smartcard/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • smartcard
  • inc
project/at_start_f413/examples/usart/smartcard/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • smartcard
  • src
project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • smartcard
  • src
project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "smartcard_config.h"
30
31extern uint32_t card_inserted;
32
46void NMI_Handler(void)
47{
48}
49
55void HardFault_Handler(void)
56{
57 /* go to infinite loop when hard fault exception occurs */
58 while(1)
59 {
60 }
61}
62
68void MemManage_Handler(void)
69{
70 /* go to infinite loop when memory manage exception occurs */
71 while(1)
72 {
73 }
74}
75
81void BusFault_Handler(void)
82{
83 /* go to infinite loop when bus fault exception occurs */
84 while(1)
85 {
86 }
87}
88
94void UsageFault_Handler(void)
95{
96 /* go to infinite loop when usage fault exception occurs */
97 while(1)
98 {
99 }
100}
101
107void SVC_Handler(void)
108{
109}
110
116void DebugMon_Handler(void)
117{
118}
119
125void PendSV_Handler(void)
126{
127}
128
134void SysTick_Handler(void)
135{
136}
137
143void EXINT9_5_IRQHandler(void)
144{
145 /* reset smart card cmdvcc */
146 gpio_bits_reset(SC_CMDVCC_PORT, SC_CMDVCC_PIN);
147
148 /* rst low */
149 gpio_bits_reset(SC_RESET_PORT, SC_RESET_PIN);
150
151 /* rst high */
152 gpio_bits_set(SC_RESET_PORT, SC_RESET_PIN);
153
154 /* clear sc exint line pending bit */
155 exint_flag_clear(SC_OFF_EXINT);
156
157 /* smart card detected */
158 card_inserted = 1;
159}
160
166void SC_USART_IRQHandler(void)
167{
168 /* if the sc_usart detects a parity error */
169 if(usart_flag_get(SC_USART, USART_PERR_FLAG) != RESET)
170 {
171 /* enable sc_usart rdbf interrupt (until receiving the corrupted byte) */
172 usart_interrupt_enable(SC_USART, USART_RDBF_INT, TRUE);
173 /* flush the sc_usart dr register */
174 usart_data_receive(SC_USART);
175 }
176
177 if(usart_flag_get(SC_USART, USART_RDBF_FLAG) != RESET)
178 {
179 /* disable sc_usart rdbf interrupt */
180 usart_interrupt_enable(SC_USART, USART_RDBF_INT, FALSE);
181 usart_data_receive(SC_USART);
182 }
183}
184
EXINT9_5_IRQHandler
void EXINT9_5_IRQHandler(void)
this function handles external lines 9 to 5 interrupt request.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:143
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:94
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:55
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:68
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:107
SC_USART_IRQHandler
void SC_USART_IRQHandler(void)
this function handles sc_usart global interrupt request.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:166
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:125
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:46
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:81
card_inserted
uint32_t card_inserted
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:63
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:134
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/smartcard/src/at32f413_int.c:116
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_bits_reset
void gpio_bits_reset(gpio_type *gpio_x, uint16_t pins)
clear the selected data port bits.
Definition: at32f413_gpio.c:341
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:310
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_PERR_FLAG
#define USART_PERR_FLAG
Definition: at32f413_usart.h:52
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
smartcard_config.h
header file of clock program
SC_RESET_PIN
#define SC_RESET_PIN
Definition: smartcard_config.h:48
SC_RESET_PORT
#define SC_RESET_PORT
Definition: smartcard_config.h:52
SC_OFF_EXINT
#define SC_OFF_EXINT
Definition: smartcard_config.h:59
SC_USART
#define SC_USART
Definition: smartcard_config.h:36
SC_CMDVCC_PORT
#define SC_CMDVCC_PORT
Definition: smartcard_config.h:53
SC_CMDVCC_PIN
#define SC_CMDVCC_PIN
Definition: smartcard_config.h:49
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • smartcard
  • src
project/at_start_f413/examples/usart/smartcard/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "smartcard_config.h"
30
39#define T0_PROTOCOL 0x00 /* t0 protocol */
40#define SETUP_LENGTH 20
41#define HIST_LENGTH 20
42#define SC_RECEIVE_TIMEOUT 0xA000 /* direction to reader */
43
44#define SC_USART_DIV_VAL 20 /* ISO 7816-3 protocol: SC_CLOCK_FREQ(PCLK/(2*USART_DIV_VAL)) is between 1 and 5 MHz */
45#define SC_F_DIV_D 372 /* ISO 7816-3 protocol: F/D = 372 */
46
47/* atr structure - answer to reset */
48typedef struct
49{
50 uint8_t ts; /* bit convention */
51 uint8_t t0; /* high nibble = n. of setup byte; low nibble = n. of historical byte */
52 uint8_t t[SETUP_LENGTH]; /* setup array */
53 uint8_t h[HIST_LENGTH]; /* historical array */
54 uint8_t tlength; /* setup array dimension */
55 uint8_t hlength; /* historical array dimension */
56} sc_atr_type;
57
58 sc_atr_type sc_a2r_struct;
59uint32_t sc_baud_rate = 0;
60uint32_t sc_clock_freq = 0;
61uint32_t counter = 0;
62 error_status atr_decode_status = ERROR;
63uint32_t card_inserted = 0, card_protocol = 1;
64uint8_t dst_buffer[50]= {
65 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
66 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1,
67 1, 1, 1, 1, 1, 1, 1, 1, 1, 1
68 };
69
75void usart_configuration(void)
76{
77 gpio_init_type gpio_init_struct;
78 exint_init_type exint_init_struct;
79 crm_clocks_freq_type crm_clocks_struct;
80
81 /* enable gpio_3_5v, sc_usart_gpio_clk, gpio_reset, gpio_cmdvcc, gpio_off and iomux clocks */
82 crm_periph_clock_enable(SC_3_5V_CLK, TRUE);
83 crm_periph_clock_enable(SC_USART_GPIO_CLK, TRUE);
84 crm_periph_clock_enable(SC_RESET_CLK, TRUE);
85 crm_periph_clock_enable(SC_CMDVCC_CLK, TRUE);
86 crm_periph_clock_enable(SC_OFF_CLK, TRUE);
87 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
88
89 /* enable sc_usart clocks */
90 crm_periph_clock_enable(SC_USART_CLK, TRUE);
91
92 gpio_default_para_init(&gpio_init_struct);
93 /* configure sc_usart ck pin */
94 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
95 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
96 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
97 gpio_init_struct.gpio_pins = SC_USART_CLK_PIN;
98 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
99 gpio_init(SC_USART_CLK_PORT, &gpio_init_struct);
100
101 /* configure sc_usart tx pin */
102 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
103 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_OPEN_DRAIN;
104 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
105 gpio_init_struct.gpio_pins = SC_USART_TX_PIN;
106 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
107 gpio_init(SC_USART_TX_PORT, &gpio_init_struct);
108
109 /* configure smartcard reset pin */
110 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
111 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
112 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
113 gpio_init_struct.gpio_pins = SC_RESET_PIN;
114 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
115 gpio_init(SC_RESET_PORT, &gpio_init_struct);
116
117 /* set reset pin high */
118 gpio_bits_set(SC_RESET_PORT, SC_RESET_PIN);
119
120 /* configure smartcard 3/5v pin */
121 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
122 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
123 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
124 gpio_init_struct.gpio_pins = SC_3_5V_PIN;
125 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
126 gpio_init(SC_3_5V_PORT, &gpio_init_struct);
127
128 /* select 5 v */
129 gpio_bits_set(SC_3_5V_PORT, SC_3_5V_PIN);
130
131 /* configure smartcard cmdvcc pin */
132 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
133 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
134 gpio_init_struct.gpio_mode = GPIO_MODE_OUTPUT;
135 gpio_init_struct.gpio_pins = SC_CMDVCC_PIN;
136 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
137 gpio_init(SC_CMDVCC_PORT, &gpio_init_struct);
138
139 /* set smartcard cmdvcc */
140 gpio_bits_set(SC_CMDVCC_PORT, SC_CMDVCC_PIN);
141
142 /* configure smartcard off pin */
143 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
144 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
145 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
146 gpio_init_struct.gpio_pins = SC_OFF_PIN;
147 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
148 gpio_init(SC_OFF_PORT, &gpio_init_struct);
149
150 /* nvic interrupt init */
151 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
152 NVIC_ClearPendingIRQ(SC_OFF_EXINT_IRQ);
153 nvic_irq_enable(SC_OFF_EXINT_IRQ, 0, 0);
154 nvic_irq_enable(SC_USART_IRQn, 1, 0);
155
156 /* configure smartcard off exint */
157 gpio_exint_line_config(SC_OFF_PORTSOURCE, SC_OFF_PINSOURCE);
158
159 exint_default_para_init(&exint_init_struct);
160 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
161 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
162 exint_init_struct.line_select = SC_OFF_EXINT;
163 exint_init_struct.line_enable = TRUE;
164 exint_init(&exint_init_struct);
165
166 /* clear sc exint line pending bit */
167 exint_flag_clear(SC_OFF_EXINT);
168
169 /* sc_usart clock set to (apbclk / (2 * SC_USART_DIV_VAL)) */
170 usart_irda_smartcard_division_set(SC_USART, SC_USART_DIV_VAL);
171 /* sc_usart guard time set to 2 bit */
172 usart_smartcard_guard_time_set(SC_USART, 0x2);
173
174 /* configure sc usart clk */
175 usart_clock_config(SC_USART, USART_CLOCK_POLARITY_LOW, USART_CLOCK_PHASE_1EDGE, USART_CLOCK_LAST_BIT_OUTPUT);
176 usart_clock_enable(SC_USART, TRUE);
177
178 crm_clocks_freq_get(&crm_clocks_struct);
179 sc_clock_freq = crm_clocks_struct.apb1_freq / (2 * SC_USART_DIV_VAL); /* ISO 7816-3 protocol: the CLK frequency is between 1 and 5 MHz */
180 sc_baud_rate = sc_clock_freq / SC_F_DIV_D;
181 /* configure sc usart param */
182 usart_init(SC_USART, sc_baud_rate, USART_DATA_9BITS, USART_STOP_1_5_BIT);
183 usart_parity_selection_config(SC_USART, USART_PARITY_EVEN);
184 usart_transmitter_enable(SC_USART, TRUE);
185 usart_receiver_enable(SC_USART, TRUE);
186
187 /* enable the sc_usart parity error interrupt */
188 usart_interrupt_enable(SC_USART, USART_PERR_INT, TRUE);
189 usart_enable(SC_USART, TRUE);
190
191 /* enable the nack transmission */
192 usart_smartcard_nack_set(SC_USART, TRUE);
193
194 /* enable the smartcard mode */
195 usart_smartcard_mode_enable(SC_USART, TRUE);
196}
197
203uint8_t sc_response_decode(__IO uint8_t *card)
204{
205 uint32_t i = 0, flag = 0, buf = 0, protocol = 0;
206
207 sc_a2r_struct.ts = 0;
208 sc_a2r_struct.t0 = 0;
209 for(i = 0; i < SETUP_LENGTH; i++)
210 {
211 sc_a2r_struct.t[i] = 0;
212 }
213 for(i = 0;i < HIST_LENGTH; i++)
214 {
215 sc_a2r_struct.h[i] = 0;
216 }
217 sc_a2r_struct.tlength = 0;
218 sc_a2r_struct.hlength = 0;
219
220 /* initial character */
221 sc_a2r_struct.ts = card[0];
222
223 /* format character */
224 sc_a2r_struct.t0 = card[1];
225
226 sc_a2r_struct.hlength = sc_a2r_struct.t0 & 0x0F;
227
228 if((sc_a2r_struct.t0 & 0x80) == 0x80) flag = 1;
229
230 for(i = 0; i < 4; i++)
231 {
232 sc_a2r_struct.tlength = sc_a2r_struct.tlength + (((sc_a2r_struct.t0 & 0xF0) >> (4 + i)) & 0x1);
233 }
234
235 for(i = 0; i < sc_a2r_struct.tlength; i++)
236 {
237 sc_a2r_struct.t[i] = card[i + 2];
238 }
239
240 protocol = sc_a2r_struct.t[sc_a2r_struct.tlength - 1] & 0x0F;
241
242 while(flag)
243 {
244 if((sc_a2r_struct.t[sc_a2r_struct.tlength - 1] & 0x80)== 0x80)
245 {
246 flag = 1;
247 }
248 else
249 {
250 flag = 0;
251 }
252 buf = sc_a2r_struct.tlength;
253 sc_a2r_struct.tlength = 0;
254
255 for(i = 0; i < 4; i++)
256 {
257 sc_a2r_struct.tlength = sc_a2r_struct.tlength + (((sc_a2r_struct.t[buf - 1] & 0xF0) >> (4 + i)) & 0x1);
258 }
259 for(i = 0; i < sc_a2r_struct.tlength; i++)
260 {
261 sc_a2r_struct.t[buf + i] = card[i + 2 + buf];
262 }
263 sc_a2r_struct.tlength += buf;
264 }
265
266 for(i = 0;i < sc_a2r_struct.hlength; i++)
267 {
268 sc_a2r_struct.h[i] = card[i + 2 + sc_a2r_struct.tlength];
269 }
270
271 return ((uint8_t)protocol);
272}
273
279int main(void)
280{
281 uint32_t index = 0;
282 system_clock_config();
283 at32_board_init();
284 usart_configuration();
285
286 /* loop while no smartcard is detected */
287 while(card_inserted == 0)
288 {
289 }
290
291 /* read smartcard atr response */
292 for(index = 0; index < 40; index++, counter = 0)
293 {
294 while((usart_flag_get(SC_USART, USART_RDBF_FLAG) == RESET) && (counter != SC_RECEIVE_TIMEOUT))
295 {
296 counter++;
297 }
298
299 if(counter != SC_RECEIVE_TIMEOUT)
300 {
301 dst_buffer[index] = usart_data_receive(SC_USART);
302 }
303 }
304
305 /* decode atr */
306 card_protocol = sc_response_decode(dst_buffer);
307
308 /* test if the inserted card is iso7816-3 t=0 compatible */
309 if(card_protocol == 0)
310 {
311 /* inserted card is iso7816-3 t=0 compatible */
312 atr_decode_status = SUCCESS;
313 }
314 else
315 {
316 /* inserted smartcard is not iso7816-3 t=0 compatible */
317 atr_decode_status = ERROR;
318 }
319
320 /* judge whether the result is correct */
321 if(atr_decode_status == SUCCESS)
322 {
323 /* trun on the led */
324 at32_led_on(LED2);
325 at32_led_on(LED3);
326 at32_led_on(LED4);
327 }
328
329 while(1)
330 {
331 }
332}
333
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
sc_baud_rate
uint32_t sc_baud_rate
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:59
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:75
sc_response_decode
uint8_t sc_response_decode(__IO uint8_t *card)
decode the card atr response.
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:203
card_protocol
uint32_t card_protocol
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:63
counter
uint32_t counter
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:61
SETUP_LENGTH
#define SETUP_LENGTH
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:40
SC_USART_DIV_VAL
#define SC_USART_DIV_VAL
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:44
sc_a2r_struct
sc_atr_type sc_a2r_struct
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:58
SC_F_DIV_D
#define SC_F_DIV_D
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:45
atr_decode_status
error_status atr_decode_status
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:62
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:279
card_inserted
uint32_t card_inserted
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:63
dst_buffer
uint8_t dst_buffer[50]
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:64
SC_RECEIVE_TIMEOUT
#define SC_RECEIVE_TIMEOUT
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:42
sc_clock_freq
uint32_t sc_clock_freq
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:60
HIST_LENGTH
#define HIST_LENGTH
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:41
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_clocks_freq_get
void crm_clocks_freq_get(crm_clocks_freq_type *clocks_struct)
get crm clocks freqency
Definition: at32f413_crm.c:576
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:93
error_status
error_status
error status
Definition: at32f413.h:264
ERROR
@ ERROR
Definition: at32f413.h:264
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_bits_set
void gpio_bits_set(gpio_type *gpio_x, uint16_t pins)
set the selected data port bits.
Definition: at32f413_gpio.c:310
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:573
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_OPEN_DRAIN
@ GPIO_OUTPUT_OPEN_DRAIN
Definition: at32f413_gpio.h:236
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f413_usart.c:233
usart_smartcard_nack_set
void usart_smartcard_nack_set(usart_type *usart_x, confirm_state new_state)
enable or disable nack transmission in smartcard mode.
Definition: at32f413_usart.c:456
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f413_usart.c:217
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:138
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_irda_smartcard_division_set
void usart_irda_smartcard_division_set(usart_type *usart_x, uint8_t div_val)
config the irda/smartcard division.
Definition: at32f413_usart.c:426
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_smartcard_guard_time_set
void usart_smartcard_guard_time_set(usart_type *usart_x, uint8_t guard_time_val)
config the specified usart smartcard guard time.
Definition: at32f413_usart.c:412
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
usart_smartcard_mode_enable
void usart_smartcard_mode_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart smart card mode.
Definition: at32f413_usart.c:441
USART_CLOCK_POLARITY_LOW
@ USART_CLOCK_POLARITY_LOW
Definition: at32f413_usart.h:140
USART_STOP_1_5_BIT
@ USART_STOP_1_5_BIT
Definition: at32f413_usart.h:161
USART_DATA_9BITS
@ USART_DATA_9BITS
Definition: at32f413_usart.h:114
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f413_usart.h:95
USART_CLOCK_LAST_BIT_OUTPUT
@ USART_CLOCK_LAST_BIT_OUTPUT
Definition: at32f413_usart.h:150
USART_CLOCK_PHASE_1EDGE
@ USART_CLOCK_PHASE_1EDGE
Definition: at32f413_usart.h:131
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART_PERR_INT
#define USART_PERR_INT
Definition: at32f413_usart.h:76
smartcard_config.h
header file of clock program
SC_RESET_PIN
#define SC_RESET_PIN
Definition: smartcard_config.h:48
SC_USART_TX_PIN
#define SC_USART_TX_PIN
Definition: smartcard_config.h:39
SC_RESET_PORT
#define SC_RESET_PORT
Definition: smartcard_config.h:52
SC_3_5V_PORT
#define SC_3_5V_PORT
Definition: smartcard_config.h:51
SC_RESET_CLK
#define SC_RESET_CLK
Definition: smartcard_config.h:56
SC_USART_CLK_PIN
#define SC_USART_CLK_PIN
Definition: smartcard_config.h:41
SC_OFF_EXINT
#define SC_OFF_EXINT
Definition: smartcard_config.h:59
SC_USART
#define SC_USART
Definition: smartcard_config.h:36
SC_OFF_CLK
#define SC_OFF_CLK
Definition: smartcard_config.h:58
SC_CMDVCC_CLK
#define SC_CMDVCC_CLK
Definition: smartcard_config.h:57
SC_USART_GPIO_CLK
#define SC_USART_GPIO_CLK
Definition: smartcard_config.h:38
SC_3_5V_PIN
#define SC_3_5V_PIN
Definition: smartcard_config.h:47
SC_OFF_PIN
#define SC_OFF_PIN
Definition: smartcard_config.h:50
SC_CMDVCC_PORT
#define SC_CMDVCC_PORT
Definition: smartcard_config.h:53
SC_USART_IRQn
#define SC_USART_IRQn
Definition: smartcard_config.h:43
SC_USART_CLK_PORT
#define SC_USART_CLK_PORT
Definition: smartcard_config.h:42
SC_3_5V_CLK
#define SC_3_5V_CLK
Definition: smartcard_config.h:55
SC_USART_TX_PORT
#define SC_USART_TX_PORT
Definition: smartcard_config.h:40
SC_OFF_PORTSOURCE
#define SC_OFF_PORTSOURCE
Definition: smartcard_config.h:60
SC_OFF_EXINT_IRQ
#define SC_OFF_EXINT_IRQ
Definition: smartcard_config.h:62
SC_USART_CLK
#define SC_USART_CLK
Definition: smartcard_config.h:37
SC_CMDVCC_PIN
#define SC_CMDVCC_PIN
Definition: smartcard_config.h:49
SC_OFF_PORT
#define SC_OFF_PORT
Definition: smartcard_config.h:54
SC_OFF_PINSOURCE
#define SC_OFF_PINSOURCE
Definition: smartcard_config.h:61
crm_clocks_freq_type
crm clocks freqency structure
Definition: at32f413_crm.h:471
crm_clocks_freq_type::apb1_freq
uint32_t apb1_freq
Definition: at32f413_crm.h:475
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
sc_atr_type
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:49
sc_atr_type::t
uint8_t t[20]
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:52
sc_atr_type::h
uint8_t h[20]
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:53
sc_atr_type::ts
uint8_t ts
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:50
sc_atr_type::tlength
uint8_t tlength
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:54
sc_atr_type::hlength
uint8_t hlength
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:55
sc_atr_type::t0
uint8_t t0
Definition: project/at_start_f413/examples/usart/smartcard/src/main.c:51
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • synchronous
  • inc
project/at_start_f413/examples/usart/synchronous/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • synchronous
  • inc
project/at_start_f413/examples/usart/synchronous/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • synchronous
  • inc
project/at_start_f413/examples/usart/synchronous/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • synchronous
  • src
project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • synchronous
  • src
project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/synchronous/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • synchronous
  • src
project/at_start_f413/examples/usart/synchronous/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define SPI2_TX_BUFFER_SIZE (COUNTOF(spi2_tx_buffer) - 1)
41#define DYMMY_BYTE 0x00
42
43uint8_t usart2_tx_buffer[] = "usart synchronous example: usart2 -> spi2";
44uint8_t spi2_tx_buffer[] = "usart synchronous example: spi2 -> usart2";
45uint8_t usart2_rx_buffer[SPI2_TX_BUFFER_SIZE];
46uint8_t spi2_rx_buffer[USART2_TX_BUFFER_SIZE];
47uint8_t usart2_tx_counter = 0x00;
48uint8_t spi2_tx_counter = 0x00;
49uint8_t usart2_rx_counter = 0x00;
50uint8_t spi2_rx_counter = 0x00;
51uint8_t usart2_tx_buffer_size = USART2_TX_BUFFER_SIZE;
52uint8_t spi2_tx_buffer_size = SPI2_TX_BUFFER_SIZE;
53
59void usart_spi_configuration(void)
60{
61 gpio_init_type gpio_init_struct;
62 spi_init_type spi_init_struct;
63
64 /* enable the usart2 and gpio clock */
65 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
67
68 /* enable the spi2 and gpio clock */
69 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
70 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
71
72 gpio_default_para_init(&gpio_init_struct);
73
74 /* configure the usart2 tx and ck pin */
75 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
76 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
77 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
78 gpio_init_struct.gpio_pins = GPIO_PINS_2 | GPIO_PINS_4;
79 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
80 gpio_init(GPIOA, &gpio_init_struct);
81
82 /* configure the usart2 rx pin */
83 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
84 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
85 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
86 gpio_init_struct.gpio_pins = GPIO_PINS_3;
87 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
88 gpio_init(GPIOA, &gpio_init_struct);
89
90 /* configure the spi2 mosi and ck pin */
91 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
92 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
93 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
94 gpio_init_struct.gpio_pins = GPIO_PINS_15 | GPIO_PINS_13;
95 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
96 gpio_init(GPIOB, &gpio_init_struct);
97
98 /* configure the spi2 miso pin */
99 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
100 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
101 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
102 gpio_init_struct.gpio_pins = GPIO_PINS_14;
103 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
104 gpio_init(GPIOB, &gpio_init_struct);
105
106 /* configure usart2 param */
107 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
108 usart_clock_config(USART2, USART_CLOCK_POLARITY_HIGH, USART_CLOCK_PHASE_2EDGE, USART_CLOCK_LAST_BIT_OUTPUT);
109 usart_clock_enable(USART2, TRUE);
110 usart_transmitter_enable(USART2, TRUE);
111 usart_receiver_enable(USART2, TRUE);
112 usart_enable(USART2, TRUE);
113
114 /* configure spi2 param */
115 spi_default_para_init(&spi_init_struct);
116 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
117 spi_init_struct.master_slave_mode =SPI_MODE_SLAVE;
118 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_LSB;
119 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
120 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_HIGH;
121 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
122 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
123 spi_init(SPI2, &spi_init_struct);
124 spi_enable(SPI2, TRUE);
125}
126
134uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
135{
136 while(buffer_length--)
137 {
138 if(*pbuffer1 != *pbuffer2)
139 {
140 return 0;
141 }
142 pbuffer1++;
143 pbuffer2++;
144 }
145 return 1;
146}
147
153int main(void)
154{
155 system_clock_config();
156 at32_board_init();
157 usart_spi_configuration();
158
159 /* wait until end of transmission from usart2 to spi2 */
160 while(spi2_rx_counter < usart2_tx_buffer_size)
161 {
162 /* usart transmit data */
163 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
164 usart_data_transmit(USART2, usart2_tx_buffer[usart2_tx_counter++]);
165
166 /* wait until spi receive data */
167 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
168 spi2_rx_buffer[spi2_rx_counter++] = spi_i2s_data_receive(SPI2);
169
170 /* wait until usart receive data, and clear dummy byte in data register */
171 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
172 usart_data_receive(USART2);
173 }
174
175 /* wait until end of transmission from spi2 to usart2 */
176 while(usart2_rx_counter < spi2_tx_buffer_size)
177 {
178 /* spi put transmit data in data register */
179 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
180 spi_i2s_data_transmit(SPI2, spi2_tx_buffer[spi2_tx_counter++]);
181
182 /* usart transmit a dummy byte to generate clock to slave */
183 while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
184 usart_data_transmit(USART2, DYMMY_BYTE);
185
186 /* wait until usart receive data */
187 while(usart_flag_get(USART2, USART_RDBF_FLAG) == RESET);
188 usart2_rx_buffer[usart2_rx_counter++] = usart_data_receive(USART2);
189 }
190
191 while(1)
192 {
193 /* compare data buffer */
194 if(buffer_compare(usart2_tx_buffer, spi2_rx_buffer, USART2_TX_BUFFER_SIZE) && \
195 buffer_compare(spi2_tx_buffer, usart2_rx_buffer, SPI2_TX_BUFFER_SIZE))
196 {
197 at32_led_toggle(LED2);
198 at32_led_toggle(LED3);
199 at32_led_toggle(LED4);
200 delay_sec(1);
201 }
202 }
203}
204
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:41
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
spi2_tx_buffer
uint8_t spi2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:44
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:134
usart2_tx_counter
uint8_t usart2_tx_counter
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:47
usart_spi_configuration
void usart_spi_configuration(void)
config usart and spi
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:59
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(spi2_tx_buffer)/sizeof(*(spi2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:45
spi2_rx_counter
uint8_t spi2_rx_counter
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:50
SPI2_TX_BUFFER_SIZE
#define SPI2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:40
DYMMY_BYTE
#define DYMMY_BYTE
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:41
usart2_tx_buffer_size
uint8_t usart2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:51
usart2_rx_counter
uint8_t usart2_rx_counter
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:49
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:153
spi2_tx_buffer_size
uint8_t spi2_tx_buffer_size
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:52
spi2_rx_buffer
uint8_t spi2_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:46
spi2_tx_counter
uint8_t spi2_tx_counter
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:48
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/synchronous/src/main.c:43
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_4
#define GPIO_PINS_4
Definition: at32f413_gpio.h:55
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
SPI_MODE_SLAVE
@ SPI_MODE_SLAVE
Definition: at32f413_spi.h:98
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_FIRST_BIT_LSB
@ SPI_FIRST_BIT_LSB
Definition: at32f413_spi.h:152
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f413_spi.h:108
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:160
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:89
SPI2
#define SPI2
Definition: at32f413_spi.h:449
usart_clock_enable
void usart_clock_enable(usart_type *usart_x, confirm_state new_state)
usart enable the ck pin.
Definition: at32f413_usart.c:233
usart_clock_config
void usart_clock_config(usart_type *usart_x, usart_clock_polarity_type clk_pol, usart_clock_phase_type clk_pha, usart_lbcp_type clk_lb)
usart clock config.
Definition: at32f413_usart.c:217
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
USART_CLOCK_POLARITY_HIGH
@ USART_CLOCK_POLARITY_HIGH
Definition: at32f413_usart.h:141
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_CLOCK_LAST_BIT_OUTPUT
@ USART_CLOCK_LAST_BIT_OUTPUT
Definition: at32f413_usart.h:150
USART_CLOCK_PHASE_2EDGE
@ USART_CLOCK_PHASE_2EDGE
Definition: at32f413_usart.h:132
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART2
#define USART2
Definition: at32f413_usart.h:320
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • transfer_by_dma_interrupt
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • transfer_by_dma_interrupt
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • transfer_by_dma_interrupt
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • transfer_by_dma_interrupt
  • src
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • transfer_by_dma_interrupt
  • src
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30extern uint8_t usart2_tx_dma_status;
31extern uint8_t usart2_rx_dma_status;
32extern uint8_t usart3_tx_dma_status;
33extern uint8_t usart3_rx_dma_status;
34
48void NMI_Handler(void)
49{
50}
51
57void HardFault_Handler(void)
58{
59 /* go to infinite loop when hard fault exception occurs */
60 while(1)
61 {
62 }
63}
64
70void MemManage_Handler(void)
71{
72 /* go to infinite loop when memory manage exception occurs */
73 while(1)
74 {
75 }
76}
77
83void BusFault_Handler(void)
84{
85 /* go to infinite loop when bus fault exception occurs */
86 while(1)
87 {
88 }
89}
90
96void UsageFault_Handler(void)
97{
98 /* go to infinite loop when usage fault exception occurs */
99 while(1)
100 {
101 }
102}
103
109void SVC_Handler(void)
110{
111}
112
118void DebugMon_Handler(void)
119{
120}
121
127void PendSV_Handler(void)
128{
129}
130
136void SysTick_Handler(void)
137{
138}
139
145void DMA1_Channel1_IRQHandler(void)
146{
147 if(dma_flag_get(DMA1_FDT1_FLAG))
148 {
149 usart2_tx_dma_status = 1;
150 dma_flag_clear(DMA1_FDT1_FLAG);
151 dma_channel_enable(DMA1_CHANNEL1, FALSE);
152 }
153}
154
160void DMA1_Channel2_IRQHandler(void)
161{
162 if(dma_flag_get(DMA1_FDT2_FLAG))
163 {
164 usart2_rx_dma_status = 1;
165 dma_flag_clear(DMA1_FDT2_FLAG);
166 dma_channel_enable(DMA1_CHANNEL2, FALSE);
167 }
168}
169
175void DMA1_Channel3_IRQHandler(void)
176{
177 if(dma_flag_get(DMA1_FDT3_FLAG))
178 {
179 usart3_tx_dma_status = 1;
180 dma_flag_clear(DMA1_FDT3_FLAG);
181 dma_channel_enable(DMA1_CHANNEL3, FALSE);
182 }
183}
184
190void DMA1_Channel4_IRQHandler(void)
191{
192 if(dma_flag_get(DMA1_FDT4_FLAG))
193 {
194 usart3_rx_dma_status = 1;
195 dma_flag_clear(DMA1_FDT4_FLAG);
196 dma_channel_enable(DMA1_CHANNEL4, FALSE);
197 }
198}
199
DMA1_Channel2_IRQHandler
void DMA1_Channel2_IRQHandler(void)
this function handles dma1 channel2 handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:160
usart3_tx_dma_status
uint8_t usart3_tx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:48
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:96
usart2_tx_dma_status
uint8_t usart2_tx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:46
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:57
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:70
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:109
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:127
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:48
DMA1_Channel1_IRQHandler
void DMA1_Channel1_IRQHandler(void)
this function handles dma1 channel1 handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:145
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:83
usart2_rx_dma_status
uint8_t usart2_rx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:47
DMA1_Channel4_IRQHandler
void DMA1_Channel4_IRQHandler(void)
this function handles dma1 channel4 handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:190
usart3_rx_dma_status
uint8_t usart3_rx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:49
DMA1_Channel3_IRQHandler
void DMA1_Channel3_IRQHandler(void)
this function handles dma1 channel3 handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:175
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:136
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/at32f413_int.c:118
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:94
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f413_dma.h:86
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:90
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:482
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:483
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:481
FALSE
@ FALSE
Definition: at32f413.h:259
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • transfer_by_dma_interrupt
  • src
project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma";
43uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46volatile uint8_t usart2_tx_dma_status = 0;
47volatile uint8_t usart2_rx_dma_status = 0;
48volatile uint8_t usart3_tx_dma_status = 0;
49volatile uint8_t usart3_rx_dma_status = 0;
50
56void usart_configuration(void)
57{
58 gpio_init_type gpio_init_struct;
59
60 /* enable the usart2 and gpio clock */
61 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
63
64 /* enable the usart3 and gpio clock */
65 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
66 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
67
68 gpio_default_para_init(&gpio_init_struct);
69 /* configure the usart2 tx pin */
70 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
71 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
72 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
73 gpio_init_struct.gpio_pins = GPIO_PINS_2;
74 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
75 gpio_init(GPIOA, &gpio_init_struct);
76
77 /* configure the usart3 tx pin */
78 gpio_init_struct.gpio_pins = GPIO_PINS_10;
79 gpio_init(GPIOB, &gpio_init_struct);
80
81 /* configure the usart2 rx pin */
82 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
83 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
84 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
85 gpio_init_struct.gpio_pins = GPIO_PINS_3;
86 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
87 gpio_init(GPIOA, &gpio_init_struct);
88
89 /* configure the usart3 rx pin */
90 gpio_init_struct.gpio_pins = GPIO_PINS_11;
91 gpio_init(GPIOB, &gpio_init_struct);
92
93 /* configure usart2 param */
94 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
95 usart_transmitter_enable(USART2, TRUE);
96 usart_receiver_enable(USART2, TRUE);
97 usart_dma_transmitter_enable(USART2, TRUE);
98 usart_dma_receiver_enable(USART2, TRUE);
99 usart_enable(USART2, TRUE);
100
101 /* configure usart3 param */
102 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
103 usart_transmitter_enable(USART3, TRUE);
104 usart_receiver_enable(USART3, TRUE);
105 usart_dma_transmitter_enable(USART3, TRUE);
106 usart_dma_receiver_enable(USART3, TRUE);
107 usart_enable(USART3, TRUE);
108}
109
115void dma_configuration(void)
116{
117 dma_init_type dma_init_struct;
118
119 /* enable dma1 clock */
120 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
121
122 /* dma1 channel1 for usart2 tx configuration */
123 dma_reset(DMA1_CHANNEL1);
124 dma_default_para_init(&dma_init_struct);
125 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
126 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
127 dma_init_struct.memory_base_addr = (uint32_t)usart2_tx_buffer;
128 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
129 dma_init_struct.memory_inc_enable = TRUE;
130 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
131 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
132 dma_init_struct.peripheral_inc_enable = FALSE;
133 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
134 dma_init_struct.loop_mode_enable = FALSE;
135 dma_init(DMA1_CHANNEL1, &dma_init_struct);
136
137 /* enable transfer full data intterrupt */
138 dma_interrupt_enable(DMA1_CHANNEL1, DMA_FDT_INT, TRUE);
139
140 /* dma1 channel1 interrupt nvic init */
141 nvic_irq_enable(DMA1_Channel1_IRQn, 0, 0);
142
143 /* config flexible dma for usart2 tx */
144 dma_flexible_config(DMA1, FLEX_CHANNEL1, DMA_FLEXIBLE_UART2_TX);
145
146 /* dma1 channel2 for usart2 rx configuration */
147 dma_reset(DMA1_CHANNEL2);
148 dma_default_para_init(&dma_init_struct);
149 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
150 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
151 dma_init_struct.memory_base_addr = (uint32_t)usart2_rx_buffer;
152 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
153 dma_init_struct.memory_inc_enable = TRUE;
154 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
155 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
156 dma_init_struct.peripheral_inc_enable = FALSE;
157 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
158 dma_init_struct.loop_mode_enable = FALSE;
159 dma_init(DMA1_CHANNEL2, &dma_init_struct);
160
161 /* enable transfer full data intterrupt */
162 dma_interrupt_enable(DMA1_CHANNEL2, DMA_FDT_INT, TRUE);
163
164 /* dma1 channel2 interrupt nvic init */
165 nvic_irq_enable(DMA1_Channel2_IRQn, 0, 0);
166
167 /* config flexible dma for usart2 rx */
168 dma_flexible_config(DMA1, FLEX_CHANNEL2, DMA_FLEXIBLE_UART2_RX);
169
170 /* dma1 channel3 for usart3 tx configuration */
171 dma_reset(DMA1_CHANNEL3);
172 dma_default_para_init(&dma_init_struct);
173 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
174 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
175 dma_init_struct.memory_base_addr = (uint32_t)usart3_tx_buffer;
176 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
177 dma_init_struct.memory_inc_enable = TRUE;
178 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
179 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
180 dma_init_struct.peripheral_inc_enable = FALSE;
181 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
182 dma_init_struct.loop_mode_enable = FALSE;
183 dma_init(DMA1_CHANNEL3, &dma_init_struct);
184
185 /* enable transfer full data intterrupt */
186 dma_interrupt_enable(DMA1_CHANNEL3, DMA_FDT_INT, TRUE);
187
188 /* dma1 channel3 interrupt nvic init */
189 nvic_irq_enable(DMA1_Channel3_IRQn, 0, 0);
190
191 /* config flexible dma for usart3 tx */
192 dma_flexible_config(DMA1, FLEX_CHANNEL3, DMA_FLEXIBLE_UART3_TX);
193
194 /* dma1 channel4 for usart3 rx configuration */
195 dma_reset(DMA1_CHANNEL4);
196 dma_default_para_init(&dma_init_struct);
197 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
198 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
199 dma_init_struct.memory_base_addr = (uint32_t)usart3_rx_buffer;
200 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
201 dma_init_struct.memory_inc_enable = TRUE;
202 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
203 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
204 dma_init_struct.peripheral_inc_enable = FALSE;
205 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
206 dma_init_struct.loop_mode_enable = FALSE;
207 dma_init(DMA1_CHANNEL4, &dma_init_struct);
208
209 /* enable transfer full data intterrupt */
210 dma_interrupt_enable(DMA1_CHANNEL4, DMA_FDT_INT, TRUE);
211
212 /* dma1 channel4 interrupt nvic init */
213 nvic_irq_enable(DMA1_Channel4_IRQn, 0, 0);
214
215 /* config flexible dma for usart3 rx */
216 dma_flexible_config(DMA1, FLEX_CHANNEL4, DMA_FLEXIBLE_UART3_RX);
217
218 dma_channel_enable(DMA1_CHANNEL2, TRUE); /* usart2 rx begin dma receiving */
219 dma_channel_enable(DMA1_CHANNEL4, TRUE); /* usart3 rx begin dma receiving */
220 dma_channel_enable(DMA1_CHANNEL1, TRUE); /* usart2 tx begin dma transmitting */
221 dma_channel_enable(DMA1_CHANNEL3, TRUE); /* usart3 tx begin dma transmitting */
222}
223
231uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
232{
233 while(buffer_length--)
234 {
235 if(*pbuffer1 != *pbuffer2)
236 {
237 return 0;
238 }
239 pbuffer1++;
240 pbuffer2++;
241 }
242 return 1;
243}
244
250int main(void)
251{
252 system_clock_config();
253 at32_board_init();
254 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
255 usart_configuration();
256 dma_configuration();
257
258 /* wait dma transmission complete */
259 while((usart2_tx_dma_status == 0) || (usart2_rx_dma_status == 0) || (usart3_tx_dma_status == 0) || (usart3_rx_dma_status == 0));
260
261 while(1)
262 {
263 /* compare data buffer */
264 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
265 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
266 {
267 at32_led_toggle(LED2);
268 at32_led_toggle(LED3);
269 at32_led_toggle(LED4);
270 delay_sec(1);
271 }
272 }
273}
274
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:56
usart3_tx_dma_status
volatile uint8_t usart3_tx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:48
usart2_tx_dma_status
volatile uint8_t usart2_tx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:46
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:231
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:45
dma_configuration
void dma_configuration(void)
config dma for usart2 and usart3
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:115
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:250
usart2_rx_dma_status
volatile uint8_t usart2_rx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:47
usart3_rx_dma_status
volatile uint8_t usart3_rx_dma_status
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:49
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:43
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_interrupt/src/main.c:44
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:133
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
DMA1_Channel2_IRQn
@ DMA1_Channel2_IRQn
Definition: at32f413.h:145
DMA1_Channel1_IRQn
@ DMA1_Channel1_IRQn
Definition: at32f413.h:144
DMA1_Channel3_IRQn
@ DMA1_Channel3_IRQn
Definition: at32f413.h:146
DMA1_Channel4_IRQn
@ DMA1_Channel4_IRQn
Definition: at32f413.h:147
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:238
dma_interrupt_enable
void dma_interrupt_enable(dma_channel_type *dmax_channely, uint32_t dma_int, confirm_state new_state)
enable or disable dma interrupt
Definition: at32f413_dma.c:165
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:245
DMA_FLEXIBLE_UART3_TX
@ DMA_FLEXIBLE_UART3_TX
Definition: at32f413_dma.h:162
DMA_FLEXIBLE_UART2_RX
@ DMA_FLEXIBLE_UART2_RX
Definition: at32f413_dma.h:159
DMA_FLEXIBLE_UART2_TX
@ DMA_FLEXIBLE_UART2_TX
Definition: at32f413_dma.h:160
DMA_FLEXIBLE_UART3_RX
@ DMA_FLEXIBLE_UART3_RX
Definition: at32f413_dma.h:161
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:255
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:266
FLEX_CHANNEL3
#define FLEX_CHANNEL3
Definition: at32f413_dma.h:66
FLEX_CHANNEL1
#define FLEX_CHANNEL1
Definition: at32f413_dma.h:64
FLEX_CHANNEL4
#define FLEX_CHANNEL4
Definition: at32f413_dma.h:67
FLEX_CHANNEL2
#define FLEX_CHANNEL2
Definition: at32f413_dma.h:65
DMA_FDT_INT
#define DMA_FDT_INT
Definition: at32f413_dma.h:52
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:482
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:483
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:481
DMA1
#define DMA1
Definition: at32f413_dma.h:479
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f413_usart.c:288
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f413_usart.c:274
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART3
#define USART3
Definition: at32f413_usart.h:321
USART2
#define USART2
Definition: at32f413_usart.h:320
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usart
  • transfer_by_dma_polling
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usart
  • transfer_by_dma_polling
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usart
  • transfer_by_dma_polling
  • inc
project/at_start_f413/examples/usart/transfer_by_dma_polling/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usart
  • transfer_by_dma_polling
  • src
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usart
  • transfer_by_dma_polling
  • src
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usart
  • transfer_by_dma_polling
  • src
project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define COUNTOF(a) (sizeof(a) / sizeof(*(a)))
39#define USART2_TX_BUFFER_SIZE (COUNTOF(usart2_tx_buffer) - 1)
40#define USART3_TX_BUFFER_SIZE (COUNTOF(usart3_tx_buffer) - 1)
41
42uint8_t usart2_tx_buffer[] = "usart transfer by dma interrupt: usart2 -> usart3 using dma";
43uint8_t usart3_tx_buffer[] = "usart transfer by dma interrupt: usart3 -> usart2 using dma";
44uint8_t usart2_rx_buffer[USART3_TX_BUFFER_SIZE];
45uint8_t usart3_rx_buffer[USART2_TX_BUFFER_SIZE];
46
52void usart_configuration(void)
53{
54 gpio_init_type gpio_init_struct;
55
56 /* enable the usart2 and gpio clock */
57 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
58 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
59
60 /* enable the usart3 and gpio clock */
61 crm_periph_clock_enable(CRM_USART3_PERIPH_CLOCK, TRUE);
62 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
63
64 gpio_default_para_init(&gpio_init_struct);
65 /* configure the usart2 tx pin */
66 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
67 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
68 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
69 gpio_init_struct.gpio_pins = GPIO_PINS_2;
70 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
71 gpio_init(GPIOA, &gpio_init_struct);
72
73 /* configure the usart3 tx pin */
74 gpio_init_struct.gpio_pins = GPIO_PINS_10;
75 gpio_init(GPIOB, &gpio_init_struct);
76
77 /* configure the usart2 rx pin */
78 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
79 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
80 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
81 gpio_init_struct.gpio_pins = GPIO_PINS_3;
82 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
83 gpio_init(GPIOA, &gpio_init_struct);
84
85 /* configure the usart3 rx pin */
86 gpio_init_struct.gpio_pins = GPIO_PINS_11;
87 gpio_init(GPIOB, &gpio_init_struct);
88
89 /* configure usart2 param */
90 usart_init(USART2, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
91 usart_transmitter_enable(USART2, TRUE);
92 usart_receiver_enable(USART2, TRUE);
93 usart_dma_transmitter_enable(USART2, TRUE);
94 usart_dma_receiver_enable(USART2, TRUE);
95 usart_enable(USART2, TRUE);
96
97 /* configure usart3 param */
98 usart_init(USART3, 115200, USART_DATA_8BITS, USART_STOP_1_BIT);
99 usart_transmitter_enable(USART3, TRUE);
100 usart_receiver_enable(USART3, TRUE);
101 usart_dma_transmitter_enable(USART3, TRUE);
102 usart_dma_receiver_enable(USART3, TRUE);
103 usart_enable(USART3, TRUE);
104}
105
111void dma_configuration(void)
112{
113 dma_init_type dma_init_struct;
114
115 /* enable dma1 clock */
116 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
117
118 /* dma1 channel1 for usart2 tx configuration */
119 dma_reset(DMA1_CHANNEL1);
120 dma_default_para_init(&dma_init_struct);
121 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
122 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
123 dma_init_struct.memory_base_addr = (uint32_t)usart2_tx_buffer;
124 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
125 dma_init_struct.memory_inc_enable = TRUE;
126 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
127 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
128 dma_init_struct.peripheral_inc_enable = FALSE;
129 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
130 dma_init_struct.loop_mode_enable = FALSE;
131 dma_init(DMA1_CHANNEL1, &dma_init_struct);
132
133 /* config flexible dma for usart2 tx */
134 dma_flexible_config(DMA1, FLEX_CHANNEL1, DMA_FLEXIBLE_UART2_TX);
135
136 /* dma1 channel2 for usart2 rx configuration */
137 dma_reset(DMA1_CHANNEL2);
138 dma_default_para_init(&dma_init_struct);
139 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
140 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
141 dma_init_struct.memory_base_addr = (uint32_t)usart2_rx_buffer;
142 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
143 dma_init_struct.memory_inc_enable = TRUE;
144 dma_init_struct.peripheral_base_addr = (uint32_t)&USART2->dt;
145 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
146 dma_init_struct.peripheral_inc_enable = FALSE;
147 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
148 dma_init_struct.loop_mode_enable = FALSE;
149 dma_init(DMA1_CHANNEL2, &dma_init_struct);
150
151 /* config flexible dma for usart2 rx */
152 dma_flexible_config(DMA1, FLEX_CHANNEL2, DMA_FLEXIBLE_UART2_RX);
153
154 /* dma1 channel3 for usart3 tx configuration */
155 dma_reset(DMA1_CHANNEL3);
156 dma_default_para_init(&dma_init_struct);
157 dma_init_struct.buffer_size = USART3_TX_BUFFER_SIZE;
158 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
159 dma_init_struct.memory_base_addr = (uint32_t)usart3_tx_buffer;
160 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
161 dma_init_struct.memory_inc_enable = TRUE;
162 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
163 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
164 dma_init_struct.peripheral_inc_enable = FALSE;
165 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
166 dma_init_struct.loop_mode_enable = FALSE;
167 dma_init(DMA1_CHANNEL3, &dma_init_struct);
168
169 /* config flexible dma for usart3 tx */
170 dma_flexible_config(DMA1, FLEX_CHANNEL3, DMA_FLEXIBLE_UART3_TX);
171
172 /* dma1 channel4 for usart3 rx configuration */
173 dma_reset(DMA1_CHANNEL4);
174 dma_default_para_init(&dma_init_struct);
175 dma_init_struct.buffer_size = USART2_TX_BUFFER_SIZE;
176 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
177 dma_init_struct.memory_base_addr = (uint32_t)usart3_rx_buffer;
178 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
179 dma_init_struct.memory_inc_enable = TRUE;
180 dma_init_struct.peripheral_base_addr = (uint32_t)&USART3->dt;
181 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
182 dma_init_struct.peripheral_inc_enable = FALSE;
183 dma_init_struct.priority = DMA_PRIORITY_MEDIUM;
184 dma_init_struct.loop_mode_enable = FALSE;
185 dma_init(DMA1_CHANNEL4, &dma_init_struct);
186
187 /* config flexible dma for usart3 rx */
188 dma_flexible_config(DMA1, FLEX_CHANNEL4, DMA_FLEXIBLE_UART3_RX);
189
190 dma_channel_enable(DMA1_CHANNEL2, TRUE); /* usart2 rx begin dma receiving */
191 dma_channel_enable(DMA1_CHANNEL4, TRUE); /* usart3 rx begin dma receiving */
192 dma_channel_enable(DMA1_CHANNEL1, TRUE); /* usart2 tx begin dma transmitting */
193 dma_channel_enable(DMA1_CHANNEL3, TRUE); /* usart3 tx begin dma transmitting */
194}
195
203uint8_t buffer_compare(uint8_t* pbuffer1, uint8_t* pbuffer2, uint16_t buffer_length)
204{
205 while(buffer_length--)
206 {
207 if(*pbuffer1 != *pbuffer2)
208 {
209 return 0;
210 }
211 pbuffer1++;
212 pbuffer2++;
213 }
214 return 1;
215}
216
222int main(void)
223{
224 system_clock_config();
225 at32_board_init();
226 usart_configuration();
227 dma_configuration();
228
229 /* wait dma transmission complete */
230 while((dma_flag_get(DMA1_FDT1_FLAG) == RESET) || (dma_flag_get(DMA1_FDT2_FLAG) == RESET) || \
231 (dma_flag_get(DMA1_FDT3_FLAG) == RESET) || (dma_flag_get(DMA1_FDT4_FLAG) == RESET));
232
233 while(1)
234 {
235 /* compare data buffer */
236 if(buffer_compare(usart2_tx_buffer, usart3_rx_buffer, USART2_TX_BUFFER_SIZE) && \
237 buffer_compare(usart3_tx_buffer, usart2_rx_buffer, USART3_TX_BUFFER_SIZE))
238 {
239 at32_led_toggle(LED2);
240 at32_led_toggle(LED3);
241 at32_led_toggle(LED4);
242 delay_sec(1);
243 }
244 }
245}
246
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usart_configuration
void usart_configuration(void)
config usart
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:52
buffer_compare
uint8_t buffer_compare(uint8_t *pbuffer1, uint8_t *pbuffer2, uint16_t buffer_length)
compares two buffers.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:203
usart3_rx_buffer
uint8_t usart3_rx_buffer[((sizeof(usart2_tx_buffer)/sizeof(*(usart2_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:45
dma_configuration
void dma_configuration(void)
config dma for usart2 and usart3
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:111
USART2_TX_BUFFER_SIZE
#define USART2_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:222
usart2_tx_buffer
uint8_t usart2_tx_buffer[]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:42
USART3_TX_BUFFER_SIZE
#define USART3_TX_BUFFER_SIZE
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:40
usart3_tx_buffer
uint8_t usart3_tx_buffer[]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:43
usart2_rx_buffer
uint8_t usart2_rx_buffer[((sizeof(usart3_tx_buffer)/sizeof(*(usart3_tx_buffer))) - 1)]
Definition: project/at_start_f413/examples/usart/transfer_by_dma_polling/src/main.c:44
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_USART3_PERIPH_CLOCK
@ CRM_USART3_PERIPH_CLOCK
Definition: at32f413_crm.h:133
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_flexible_config
void dma_flexible_config(dma_type *dma_x, uint8_t flex_channelx, dma_flexible_request_type flexible_request)
initialize the dma_x flexible function according to the specified parameters.
Definition: at32f413_dma.c:238
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:245
DMA_FLEXIBLE_UART3_TX
@ DMA_FLEXIBLE_UART3_TX
Definition: at32f413_dma.h:162
DMA_FLEXIBLE_UART2_RX
@ DMA_FLEXIBLE_UART2_RX
Definition: at32f413_dma.h:159
DMA_FLEXIBLE_UART2_TX
@ DMA_FLEXIBLE_UART2_TX
Definition: at32f413_dma.h:160
DMA_FLEXIBLE_UART3_RX
@ DMA_FLEXIBLE_UART3_RX
Definition: at32f413_dma.h:161
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:255
DMA_PRIORITY_MEDIUM
@ DMA_PRIORITY_MEDIUM
Definition: at32f413_dma.h:266
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:94
DMA1_FDT1_FLAG
#define DMA1_FDT1_FLAG
Definition: at32f413_dma.h:82
DMA1_FDT2_FLAG
#define DMA1_FDT2_FLAG
Definition: at32f413_dma.h:86
DMA1_FDT3_FLAG
#define DMA1_FDT3_FLAG
Definition: at32f413_dma.h:90
FLEX_CHANNEL3
#define FLEX_CHANNEL3
Definition: at32f413_dma.h:66
FLEX_CHANNEL1
#define FLEX_CHANNEL1
Definition: at32f413_dma.h:64
FLEX_CHANNEL4
#define FLEX_CHANNEL4
Definition: at32f413_dma.h:67
FLEX_CHANNEL2
#define FLEX_CHANNEL2
Definition: at32f413_dma.h:65
DMA1_CHANNEL3
#define DMA1_CHANNEL3
Definition: at32f413_dma.h:482
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:483
DMA1_CHANNEL1
#define DMA1_CHANNEL1
Definition: at32f413_dma.h:480
DMA1_CHANNEL2
#define DMA1_CHANNEL2
Definition: at32f413_dma.h:481
DMA1
#define DMA1
Definition: at32f413_dma.h:479
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
gpio_default_para_init
void gpio_default_para_init(gpio_init_type *gpio_init_struct)
fill each gpio_init_type member with its default value.
Definition: at32f413_gpio.c:168
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_dma_receiver_enable
void usart_dma_receiver_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma receiver interface.
Definition: at32f413_usart.c:288
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_dma_transmitter_enable
void usart_dma_transmitter_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the usart's dma transmitter interface.
Definition: at32f413_usart.c:274
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART3
#define USART3
Definition: at32f413_usart.h:321
USART2
#define USART2
Definition: at32f413_usart.h:320
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • audio
  • inc
project/at_start_f413/examples/usb_device/audio/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • audio
  • inc
project/at_start_f413/examples/usb_device/audio/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • audio
  • inc
project/at_start_f413/examples/usb_device/audio/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • audio
  • inc
project/at_start_f413/examples/usb_device/audio/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57#define USB_BUFFER_SIZE_EX
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99
100void usb_delay_ms(uint32_t ms);
101void usb_delay_us(uint32_t us);
102
111#ifdef __cplusplus
112}
113#endif
114
115#endif
116
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:169
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:180


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • audio
  • src
project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • audio
  • src
project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/audio/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • audio
  • src
project/at_start_f413/examples/usb_device/audio/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "audio_class.h"
31#include "audio_desc.h"
32#include "usbd_int.h"
33#include "audio_codec.h"
34
43 usbd_core_type usb_core_dev;
44
50void usb_clock48m_select(usb_clk48_s clk_s)
51{
52 if(clk_s == USB_CLK_HICK)
53 {
54 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
55
56 /* enable the acc calibration ready interrupt */
57 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
58
59 /* update the c1\c2\c3 value */
60 acc_write_c1(7980);
61 acc_write_c2(8000);
62 acc_write_c3(8020);
63
64 /* open acc calibration */
65 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
66 }
67 else
68 {
69 switch(system_core_clock)
70 {
71 /* 48MHz */
72 case 48000000:
73 crm_usb_clock_div_set(CRM_USB_DIV_1);
74 break;
75
76 /* 72MHz */
77 case 72000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
79 break;
80
81 /* 96MHz */
82 case 96000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_2);
84 break;
85
86 /* 120MHz */
87 case 120000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
89 break;
90
91 /* 144MHz */
92 case 144000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_3);
94 break;
95
96 /* 168MHz */
97 case 168000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
99 break;
100
101 /* 192MHz */
102 case 192000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_4);
104 break;
105
106 default:
107 break;
108
109 }
110 }
111}
112
118int main(void)
119{
120 /* config nvic priority group */
121 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
122
123 /* system clock config */
124 system_clock_config();
125
126 /* audio codec init */
127 audio_codec_init();
128
129 /* at32 board init */
130 at32_board_init();
131
132 /* select usb 48m clcok source */
133 usb_clock48m_select(USB_CLK_HEXT);
134
135 /* enable usb clock */
136 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
137
138 /* enable usb interrupt */
139 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
140
141 /* usb core init */
142 usbd_core_init(&usb_core_dev, USB, &audio_class_handler, &audio_desc_handler, 0);
143
144 /* enable usb pull-up */
145 usbd_connect(&usb_core_dev);
146
147 while(1)
148 {
149 audio_codec_loop();
150 delay_ms(100);
151 }
152}
153
159void USBFS_L_CAN1_RX0_IRQHandler(void)
160{
161 usbd_irq_handler(&usb_core_dev);
162}
163
169void usb_delay_ms(uint32_t ms)
170{
171 /* user can define self delay function */
172 delay_ms(ms);
173}
174
180void usb_delay_us(uint32_t us)
181{
182 delay_us(us);
183}
184
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
audio_class.h
usb audio class file
audio_desc.h
usb audio descriptor header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:50
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:118
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:159
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/audio/src/main.c:43
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
audio_class_handler
usbd_class_handler audio_class_handler
Definition: audio_class.c:65
audio_desc_handler
usbd_desc_handler audio_desc_handler
device descriptor handler structure
Definition: audio_desc.c:62
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:853
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:794
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • composite_audio_hid
  • inc
project/at_start_f413/examples/usb_device/composite_audio_hid/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57#define USB_BUFFER_SIZE_EX
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99
100void usb_delay_ms(uint32_t ms);
101void usb_delay_us(uint32_t us);
102
110#ifdef __cplusplus
111}
112#endif
113
114#endif
115
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:178
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:189


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • composite_audio_hid
  • src
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • composite_audio_hid
  • src
project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • composite_audio_hid
  • src
project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "usbd_int.h"
31#include "audio_hid_class.h"
32#include "audio_hid_desc.h"
33#include "audio_codec.h"
34
43/* usb global struct define */
44 usbd_core_type usb_core_dev;
45
46uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE];
47
53void usb_clock48m_select(usb_clk48_s clk_s)
54{
55 if(clk_s == USB_CLK_HICK)
56 {
57 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
58
59 /* enable the acc calibration ready interrupt */
60 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
61
62 /* update the c1\c2\c3 value */
63 acc_write_c1(7980);
64 acc_write_c2(8000);
65 acc_write_c3(8020);
66
67 /* open acc calibration */
68 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
69 }
70 else
71 {
72 switch(system_core_clock)
73 {
74 /* 48MHz */
75 case 48000000:
76 crm_usb_clock_div_set(CRM_USB_DIV_1);
77 break;
78
79 /* 72MHz */
80 case 72000000:
81 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
82 break;
83
84 /* 96MHz */
85 case 96000000:
86 crm_usb_clock_div_set(CRM_USB_DIV_2);
87 break;
88
89 /* 120MHz */
90 case 120000000:
91 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
92 break;
93
94 /* 144MHz */
95 case 144000000:
96 crm_usb_clock_div_set(CRM_USB_DIV_3);
97 break;
98
99 /* 168MHz */
100 case 168000000:
101 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
102 break;
103
104 /* 192MHz */
105 case 192000000:
106 crm_usb_clock_div_set(CRM_USB_DIV_4);
107 break;
108
109 default:
110 break;
111
112 }
113 }
114}
115
121int main(void)
122{
123 /* config nvic priority group */
124 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
125
126 /* system clock config */
127 system_clock_config();
128
129 /* audio codec init */
130 audio_codec_init();
131
132 /* at32 board init */
133 at32_board_init();
134
135 /* select usb 48m clcok source */
136 usb_clock48m_select(USB_CLK_HEXT);
137
138 /* enable usb clock */
139 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
140
141 /* enable usb interrupt */
142 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
143
144 /* usb core init */
145 usbd_core_init(&usb_core_dev, USB, &audio_hid_class_handler, &audio_hid_desc_handler, 0);
146
147 /* enable usb pull-up */
148 usbd_connect(&usb_core_dev);
149
150 while(1)
151 {
152 audio_codec_loop();
153 if(at32_button_press() == USER_BUTTON)
154 {
155 report_buf[0] = HID_REPORT_ID_5;
156 report_buf[1] = (~report_buf[1]) & 0x1;
157 audio_hid_class_send_report(&usb_core_dev, report_buf, USBD_AUHID_IN_MAXPACKET_SIZE);
158 }
159 delay_ms(100);
160 }
161}
162
168void USBFS_L_CAN1_RX0_IRQHandler(void)
169{
170 usbd_irq_handler(&usb_core_dev);
171}
172
178void usb_delay_ms(uint32_t ms)
179{
180 /* user can define self delay function */
181 delay_ms(ms);
182}
183
189void usb_delay_us(uint32_t us)
190{
191 delay_us(us);
192}
193
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
audio_hid_class.h
audio_hid_desc.h
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
report_buf
uint8_t report_buf[USBD_AUHID_IN_MAXPACKET_SIZE]
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:46
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:53
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:121
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:168
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/composite_audio_hid/src/main.c:44
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
USBD_AUHID_IN_MAXPACKET_SIZE
#define USBD_AUHID_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: audio_hid_class.h:67
audio_hid_class_send_report
usb_sts_type audio_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: audio_hid_class.c:770
audio_hid_class_handler
usbd_class_handler audio_hid_class_handler
Definition: audio_hid_class.c:64
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:226
audio_hid_desc_handler
usbd_desc_handler audio_hid_desc_handler
device descriptor handler structure
Definition: audio_hid_desc.c:64
audio_codec_loop
error_status audio_codec_loop(void)
audio codec loop
Definition: audio/src/audio_codec.c:853
audio_codec_init
error_status audio_codec_init(void)
audio codec init
Definition: audio/src/audio_codec.c:794
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • composite_vcp_keyboard
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99void usb_delay_ms(uint32_t ms);
100void usb_delay_us(uint32_t us);
101
110#ifdef __cplusplus
111}
112#endif
113
114#endif
115
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:235
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:246


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • composite_vcp_keyboard
  • src
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • composite_vcp_keyboard
  • src
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • composite_vcp_keyboard
  • src
project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "cdc_keyboard_class.h"
31#include "cdc_keyboard_desc.h"
32#include "usbd_int.h"
33
42 usbd_core_type usb_core_dev;
43uint8_t usb_buffer[256];
44void keyboard_send_string(void *udev, uint8_t *string, uint8_t len);
45
51void usb_clock48m_select(usb_clk48_s clk_s)
52{
53 if(clk_s == USB_CLK_HICK)
54 {
55 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
56
57 /* enable the acc calibration ready interrupt */
58 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
59
60 /* update the c1\c2\c3 value */
61 acc_write_c1(7980);
62 acc_write_c2(8000);
63 acc_write_c3(8020);
64
65 /* open acc calibration */
66 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
67 }
68 else
69 {
70 switch(system_core_clock)
71 {
72 /* 48MHz */
73 case 48000000:
74 crm_usb_clock_div_set(CRM_USB_DIV_1);
75 break;
76
77 /* 72MHz */
78 case 72000000:
79 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
80 break;
81
82 /* 96MHz */
83 case 96000000:
84 crm_usb_clock_div_set(CRM_USB_DIV_2);
85 break;
86
87 /* 120MHz */
88 case 120000000:
89 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
90 break;
91
92 /* 144MHz */
93 case 144000000:
94 crm_usb_clock_div_set(CRM_USB_DIV_3);
95 break;
96
97 /* 168MHz */
98 case 168000000:
99 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
100 break;
101
102 /* 192MHz */
103 case 192000000:
104 crm_usb_clock_div_set(CRM_USB_DIV_4);
105 break;
106
107 default:
108 break;
109
110 }
111 }
112}
113
120void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
121{
122 uint8_t index = 0;
123 usbd_core_type *pudev = (usbd_core_type *)udev;
124 vcp_keyboard_type *vcpkybrd = (vcp_keyboard_type *)pudev->class_handler->pdata;
125 for(index = 0; index < len; index ++)
126 {
127 while(1)
128 {
129 if(vcpkybrd->g_keyboard_tx_completed == 1)
130 {
131 vcpkybrd->g_keyboard_tx_completed = 0;
132 usb_vcpkybrd_keyboard_send_char(&usb_core_dev, string[index]);
133 break;
134 }
135 }
136 /* send 0x00 */
137 while(1)
138 {
139 if(vcpkybrd->g_keyboard_tx_completed == 1)
140 {
141 vcpkybrd->g_keyboard_tx_completed = 0;
142 usb_vcpkybrd_keyboard_send_char(&usb_core_dev, 0x00);
143 break;
144 }
145 }
146 }
147
148}
149
155int main(void)
156{
157 uint16_t data_len;
158
159 uint32_t timeout;
160
161 uint8_t send_zero_packet = 0;
162
163 /* config nvic priority group */
164 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
165
166 system_clock_config();
167
168 at32_board_init();
169
170 /* select usb 48m clcok source */
171 usb_clock48m_select(USB_CLK_HEXT);
172
173 /* enable usb clock */
174 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
175
176 /* enable usb interrupt */
177 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
178
179 /* usb core init */
180 usbd_core_init(&usb_core_dev, USB, &cdc_keyboard_class_handler, &cdc_keyboard_desc_handler, 0);
181
182 /* enable usb pull-up */
183 usbd_connect(&usb_core_dev);
184
185 while(1)
186 {
187 /* get usb vcp receive data */
188 data_len = usb_vcpkybrd_vcp_get_rxdata(&usb_core_dev, usb_buffer);
189
190 if(data_len > 0 || send_zero_packet == 1)
191 {
192 /* bulk transfer is complete when the endpoint does one of the following
193 1 has transferred exactly the amount of data expected
194 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
195 */
196 if(data_len > 0)
197 send_zero_packet = 1;
198
199 if(data_len == 0)
200 send_zero_packet = 0;
201
202 timeout = 5000000;
203 do
204 {
205 /* send data to host */
206 if(usb_vcpkybrd_vcp_send_data(&usb_core_dev, usb_buffer, data_len) == SUCCESS)
207 {
208 break;
209 }
210 }while(timeout --);
211 }
212
213 if(at32_button_press() == USER_BUTTON)
214 {
215 keyboard_send_string(&usb_core_dev, (uint8_t *)" Keyboard Demo\r\n", 16);
216 }
217 }
218}
219
225void USBFS_L_CAN1_RX0_IRQHandler(void)
226{
227 usbd_irq_handler(&usb_core_dev);
228}
229
235void usb_delay_ms(uint32_t ms)
236{
237 /* user can define self delay function */
238 delay_ms(ms);
239}
240
246void usb_delay_us(uint32_t us)
247{
248 delay_us(us);
249}
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_keyboard_class.h
usb cdc and keyboard class file
cdc_keyboard_desc.h
usb cdc and keyboard descriptor header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:155
keyboard_send_string
void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
keyboard send string
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:120
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:225
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:43
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/composite_vcp_keyboard/src/main.c:42
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usb_vcpkybrd_vcp_send_data
error_status usb_vcpkybrd_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_keyboard_class.c:618
usb_vcpkybrd_keyboard_send_char
void usb_vcpkybrd_keyboard_send_char(void *udev, uint8_t ascii_code)
usb keyoard send char
Definition: cdc_keyboard_class.c:697
cdc_keyboard_class_handler
usbd_class_handler cdc_keyboard_class_handler
Definition: cdc_keyboard_class.c:205
usb_vcpkybrd_vcp_get_rxdata
uint16_t usb_vcpkybrd_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_keyboard_class.c:587
cdc_keyboard_desc_handler
usbd_desc_handler cdc_keyboard_desc_handler
device descriptor handler structure
Definition: cdc_keyboard_desc.c:62
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
vcp_keyboard_type
Definition: cdc_keyboard_class.h:75
vcp_keyboard_type::g_keyboard_tx_completed
__IO uint8_t g_keyboard_tx_completed
Definition: cdc_keyboard_class.h:88
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • composite_vcp_msc
  • inc
project/at_start_f413/examples/usb_device/composite_vcp_msc/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99void usb_delay_ms(uint32_t ms);
100void usb_delay_us(uint32_t us);
101
110#ifdef __cplusplus
111}
112#endif
113
114#endif
115
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • composite_vcp_msc
  • src
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • composite_vcp_msc
  • src
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • composite_vcp_msc
  • src
project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "cdc_msc_class.h"
31#include "cdc_msc_desc.h"
32#include "usbd_int.h"
33
42 usbd_core_type usb_core_dev;
43uint8_t usb_buffer[256];
44
50void usb_clock48m_select(usb_clk48_s clk_s)
51{
52 if(clk_s == USB_CLK_HICK)
53 {
54 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
55
56 /* enable the acc calibration ready interrupt */
57 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
58
59 /* update the c1\c2\c3 value */
60 acc_write_c1(7980);
61 acc_write_c2(8000);
62 acc_write_c3(8020);
63
64 /* open acc calibration */
65 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
66 }
67 else
68 {
69 switch(system_core_clock)
70 {
71 /* 48MHz */
72 case 48000000:
73 crm_usb_clock_div_set(CRM_USB_DIV_1);
74 break;
75
76 /* 72MHz */
77 case 72000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
79 break;
80
81 /* 96MHz */
82 case 96000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_2);
84 break;
85
86 /* 120MHz */
87 case 120000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
89 break;
90
91 /* 144MHz */
92 case 144000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_3);
94 break;
95
96 /* 168MHz */
97 case 168000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
99 break;
100
101 /* 192MHz */
102 case 192000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_4);
104 break;
105
106 default:
107 break;
108
109 }
110 }
111}
112
118int main(void)
119{
120 uint16_t data_len;
121
122 uint32_t timeout;
123
124 uint8_t send_zero_packet = 0;
125
126 /* config nvic priority group */
127 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
128
129 system_clock_config();
130
131 at32_board_init();
132
133 /* select usb 48m clcok source */
134 usb_clock48m_select(USB_CLK_HEXT);
135
136 /* enable usb clock */
137 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
138
139 /* enable usb interrupt */
140 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
141
142 /* usb core init */
143 usbd_core_init(&usb_core_dev, USB, &cdc_msc_class_handler, &cdc_msc_desc_handler, 0);
144
145 /* enable usb pull-up */
146 usbd_connect(&usb_core_dev);
147
148 while(1)
149 {
150 /* get usb vcp receive data */
151 data_len = usb_vcp_get_rxdata(&usb_core_dev, usb_buffer);
152
153 if(data_len > 0 || send_zero_packet == 1)
154 {
155 /* bulk transfer is complete when the endpoint does one of the following
156 1 has transferred exactly the amount of data expected
157 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
158 */
159 if(data_len > 0)
160 send_zero_packet = 1;
161
162 if(data_len == 0)
163 send_zero_packet = 0;
164
165 timeout = 5000000;
166 do
167 {
168 /* send data to host */
169 if(usb_vcp_send_data(&usb_core_dev, usb_buffer, data_len) == SUCCESS)
170 {
171 break;
172 }
173 }while(timeout --);
174 }
175 }
176}
177
183void USBFS_L_CAN1_RX0_IRQHandler(void)
184{
185 usbd_irq_handler(&usb_core_dev);
186}
187
193void usb_delay_ms(uint32_t ms)
194{
195 /* user can define self delay function */
196 delay_ms(ms);
197}
198
204void usb_delay_us(uint32_t us)
205{
206 delay_us(us);
207}
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_msc_class.h
usb cdc class file
cdc_msc_desc.h
usb cdc descriptor header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:50
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:118
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:183
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:193
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:204
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:43
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/composite_vcp_msc/src/main.c:42
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:340
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:370
cdc_msc_class_handler
usbd_class_handler cdc_msc_class_handler
Definition: cdc_msc_class.c:72
cdc_msc_desc_handler
usbd_desc_handler cdc_msc_desc_handler
device descriptor handler structure
Definition: cdc_msc_desc.c:66
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • custom_hid
  • inc
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • custom_hid
  • inc
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • custom_hid
  • inc
project/at_start_f413/examples/usb_device/custom_hid/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • custom_hid
  • inc
project/at_start_f413/examples/usb_device/custom_hid/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99
100void usb_delay_ms(uint32_t ms);
101void usb_delay_us(uint32_t us);
102
111#ifdef __cplusplus
112}
113#endif
114
115#endif
116
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:170
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:181


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • custom_hid
  • src
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • custom_hid
  • src
project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • custom_hid
  • src
project/at_start_f413/examples/usb_device/custom_hid/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "custom_hid_class.h"
31#include "custom_hid_desc.h"
32#include "usbd_int.h"
33
42 usbd_core_type usb_core_dev;
43uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE];
44
50void usb_clock48m_select(usb_clk48_s clk_s)
51{
52 if(clk_s == USB_CLK_HICK)
53 {
54 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
55
56 /* enable the acc calibration ready interrupt */
57 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
58
59 /* update the c1\c2\c3 value */
60 acc_write_c1(7980);
61 acc_write_c2(8000);
62 acc_write_c3(8020);
63
64 /* open acc calibration */
65 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
66 }
67 else
68 {
69 switch(system_core_clock)
70 {
71 /* 48MHz */
72 case 48000000:
73 crm_usb_clock_div_set(CRM_USB_DIV_1);
74 break;
75
76 /* 72MHz */
77 case 72000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
79 break;
80
81 /* 96MHz */
82 case 96000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_2);
84 break;
85
86 /* 120MHz */
87 case 120000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
89 break;
90
91 /* 144MHz */
92 case 144000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_3);
94 break;
95
96 /* 168MHz */
97 case 168000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
99 break;
100
101 /* 192MHz */
102 case 192000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_4);
104 break;
105
106 default:
107 break;
108
109 }
110 }
111}
112
118int main(void)
119{
120 /* config nvic priority group */
121 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
122
123 system_clock_config();
124
125 at32_board_init();
126
127 /* select usb 48m clcok source */
128 usb_clock48m_select(USB_CLK_HEXT);
129
130 /* enable usb clock */
131 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
132
133 /* enable usb interrupt */
134 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
135
136 /* usb core init */
137 usbd_core_init(&usb_core_dev, USB, &custom_hid_class_handler, &custom_hid_desc_handler, 0);
138
139 /* enable usb pull-up */
140 usbd_connect(&usb_core_dev);
141
142 while(1)
143 {
144 if(at32_button_press() == USER_BUTTON)
145 {
146 report_buf[1] = (~report_buf[1]) & 0x1;
147 report_buf[0] = HID_REPORT_ID_5;
148 custom_hid_class_send_report(&usb_core_dev, report_buf, USBD_CUSTOM_IN_MAXPACKET_SIZE);
149
150 }
151 }
152}
153
154
160void USBFS_L_CAN1_RX0_IRQHandler(void)
161{
162 usbd_irq_handler(&usb_core_dev);
163}
164
170void usb_delay_ms(uint32_t ms)
171{
172 /* user can define self delay function */
173 delay_ms(ms);
174}
175
181void usb_delay_us(uint32_t us)
182{
183 delay_us(us);
184}
185
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
custom_hid_class.h
usb custom hid header file
custom_hid_desc.h
usb custom hid descriptor header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
report_buf
uint8_t report_buf[USBD_CUSTOM_IN_MAXPACKET_SIZE]
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:43
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:50
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:118
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:160
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/custom_hid/src/main.c:42
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
HID_REPORT_ID_5
#define HID_REPORT_ID_5
Definition: audio_hid_desc.h:226
USBD_CUSTOM_IN_MAXPACKET_SIZE
#define USBD_CUSTOM_IN_MAXPACKET_SIZE
usb custom hid in and out max packet size define
Definition: custom_hid_class.h:59
custom_hid_class_send_report
usb_sts_type custom_hid_class_send_report(void *udev, uint8_t *report, uint16_t len)
usb device class send report
Definition: custom_hid_class.c:322
custom_hid_class_handler
usbd_class_handler custom_hid_class_handler
Definition: custom_hid_class.c:57
custom_hid_desc_handler
usbd_desc_handler custom_hid_desc_handler
custom hid device descriptor handler structure
Definition: custom_hid_desc.c:62
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • keyboard
  • inc
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • keyboard
  • inc
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • keyboard
  • inc
project/at_start_f413/examples/usb_device/keyboard/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • keyboard
  • inc
project/at_start_f413/examples/usb_device/keyboard/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99
103#define USB_LOW_POWER_WAKUP
104
105void usb_delay_ms(uint32_t ms);
106void usb_delay_us(uint32_t us);
107
116#ifdef __cplusplus
117}
118#endif
119
120#endif
121
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:337
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:348


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • keyboard
  • src
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • keyboard
  • src
project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • keyboard
  • src
project/at_start_f413/examples/usb_device/keyboard/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "keyboard_class.h"
31#include "keyboard_desc.h"
32#include "usbd_int.h"
33
42 usbd_core_type usb_core_dev;
43extern __IO uint8_t hid_suspend_flag;
44void keyboard_send_string(void *udev, uint8_t *string, uint8_t len);
45void system_clock_recover(void);
46void button_exint_init(void);
47void usb_low_power_wakeup_config(void);
48
55void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
56{
57 uint8_t index = 0;
58 usbd_core_type *pudev = (usbd_core_type *)udev;
59 keyboard_type *pkeyboard = (keyboard_type *)pudev->class_handler->pdata;
60 for(index = 0; index < len; index ++)
61 {
62 while(1)
63 {
64 if(pkeyboard->g_u8tx_completed == 1)
65 {
66 pkeyboard->g_u8tx_completed = 0;
67 usb_hid_keyboard_send_char(udev, string[index]);
68 break;
69 }
70 }
71 /* send 0x00 */
72 while(1)
73 {
74 if(pkeyboard->g_u8tx_completed == 1)
75 {
76 pkeyboard->g_u8tx_completed = 0;
77 usb_hid_keyboard_send_char(udev, 0x00);
78 break;
79 }
80 }
81 }
82}
83
89void usb_clock48m_select(usb_clk48_s clk_s)
90{
91 if(clk_s == USB_CLK_HICK)
92 {
93 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
94
95 /* enable the acc calibration ready interrupt */
96 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
97
98 /* update the c1\c2\c3 value */
99 acc_write_c1(7980);
100 acc_write_c2(8000);
101 acc_write_c3(8020);
102
103 /* open acc calibration */
104 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
105 }
106 else
107 {
108 switch(system_core_clock)
109 {
110 /* 48MHz */
111 case 48000000:
112 crm_usb_clock_div_set(CRM_USB_DIV_1);
113 break;
114
115 /* 72MHz */
116 case 72000000:
117 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
118 break;
119
120 /* 96MHz */
121 case 96000000:
122 crm_usb_clock_div_set(CRM_USB_DIV_2);
123 break;
124
125 /* 120MHz */
126 case 120000000:
127 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
128 break;
129
130 /* 144MHz */
131 case 144000000:
132 crm_usb_clock_div_set(CRM_USB_DIV_3);
133 break;
134
135 /* 168MHz */
136 case 168000000:
137 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
138 break;
139
140 /* 192MHz */
141 case 192000000:
142 crm_usb_clock_div_set(CRM_USB_DIV_4);
143 break;
144
145 default:
146 break;
147
148 }
149 }
150}
151
157int main(void)
158{
159 /* config nvic priority group */
160 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
161
162 system_clock_config();
163
164 at32_board_init();
165
166 /* select usb 48m clcok source */
167 usb_clock48m_select(USB_CLK_HEXT);
168
169#ifdef USB_LOW_POWER_WAKUP
170 /* enable pwc and bpr clock */
171 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
172 button_exint_init();
173 usb_low_power_wakeup_config();
174#endif
175
176 /* enable usb clock */
177 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
178
179 /* enable usb interrupt */
180 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
181
182 /* usb core init */
183 usbd_core_init(&usb_core_dev, USB, &keyboard_class_handler, &keyboard_desc_handler, 0);
184
185 /* enable usb pull-up */
186 usbd_connect(&usb_core_dev);
187
188 while(1)
189 {
190 if(at32_button_press() == USER_BUTTON)
191 {
192 if(usbd_connect_state_get(&usb_core_dev) == USB_CONN_STATE_CONFIGURED)
193 {
194 keyboard_send_string(&usb_core_dev, (uint8_t *)" Keyboard Demo\r\n", 16);
195 }
196 /* remote wakeup */
197 if(usbd_connect_state_get(&usb_core_dev) == USB_CONN_STATE_SUSPENDED
198 &&(usb_core_dev.remote_wakup == 1))
199 {
200 usbd_remote_wakeup(&usb_core_dev);
201 }
202 }
203#ifdef USB_LOW_POWER_WAKUP
204 /* enter deep sleep */
205 if(((keyboard_type *)(usb_core_dev.class_handler->pdata))->hid_suspend_flag == 1)
206 {
207 at32_led_off(LED2);
208 at32_led_off(LED3);
209 at32_led_off(LED4);
210 /* congfig the voltage regulator mode */
211 pwc_voltage_regulate_set(PWC_REGULATOR_LOW_POWER);
212
213 /* enter deep sleep mode */
214 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
215 /* wait clock stable */
216
217 system_clock_recover();
218 ((keyboard_type *)(usb_core_dev.class_handler->pdata))->hid_suspend_flag = 0;
219 at32_led_on(LED2);
220 at32_led_on(LED3);
221 at32_led_on(LED4);
222 }
223#endif
224 }
225}
226
227#ifdef USB_LOW_POWER_WAKUP
233void button_exint_init(void)
234{
235 exint_init_type exint_init_struct;
236
237 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
238 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE0);
239
240 exint_default_para_init(&exint_init_struct);
241 exint_init_struct.line_enable = TRUE;
242 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
243 exint_init_struct.line_select = EXINT_LINE_0;
244 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
245 exint_init(&exint_init_struct);
246
247 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
248 nvic_irq_enable(EXINT0_IRQn, 0, 0);
249}
250
256void EXINT0_IRQHandler(void)
257{
258 /* clear interrupt pending bit */
259 exint_flag_clear(EXINT_LINE_0);
260}
261
267void usb_low_power_wakeup_config(void)
268{
269 exint_init_type exint_init_struct;
270
271 exint_default_para_init(&exint_init_struct);
272
273 exint_init_struct.line_enable = TRUE;
274 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
275 exint_init_struct.line_select = EXINT_LINE_18;
276 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
277 exint_init(&exint_init_struct);
278
279 nvic_irq_enable(USBFSWakeUp_IRQn, 0, 0);
280}
281
287void USBFSWakeUp_IRQHandler(void)
288{
289 exint_flag_clear(EXINT_LINE_18);
290}
291
297void system_clock_recover(void)
298{
299 /* enable external high-speed crystal oscillator - hext */
300 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
301
302 /* wait till hext is ready */
303 while(crm_hext_stable_wait() == ERROR);
304
305 /* enable pll */
306 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
307
308 /* wait till pll is ready */
309 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
310
311 /* enable auto step mode */
312 crm_auto_step_mode_enable(TRUE);
313
314 /* select pll as system clock source */
315 crm_sysclk_switch(CRM_SCLK_PLL);
316
317 /* wait till pll is used as system clock source */
318 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
319}
320
321#endif
327void USBFS_L_CAN1_RX0_IRQHandler(void)
328{
329 usbd_irq_handler(&usb_core_dev);
330}
331
337void usb_delay_ms(uint32_t ms)
338{
339 /* user can define self delay function */
340 delay_ms(ms);
341}
342
348void usb_delay_us(uint32_t us)
349{
350 delay_us(us);
351}
352
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:96
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
hid_suspend_flag
__IO uint8_t hid_suspend_flag
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f413/templates/src/main.c:52
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:89
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:157
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
keyboard_send_string
void keyboard_send_string(void *udev, uint8_t *string, uint8_t len)
keyboard send string
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:55
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:327
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/keyboard/src/main.c:42
system_clock_recover
void system_clock_recover(void)
systemclock recover.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:98
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
USBFSWakeUp_IRQn
@ USBFSWakeUp_IRQn
Definition: at32f413.h:176
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:139
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:93
EXINT_LINE_18
#define EXINT_LINE_18
Definition: at32f413_exint.h:70
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f413_exint.h:52
ERROR
@ ERROR
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:573
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:254
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:277
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f413_pwc.c:213
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:189
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f413_pwc.h:107
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:97
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
usb_hid_keyboard_send_char
void usb_hid_keyboard_send_char(void *udev, uint8_t ascii_code)
usb device class report function
Definition: keyboard_class.c:457
keyboard_class_handler
usbd_class_handler keyboard_class_handler
Definition: keyboard_class.c:189
keyboard_desc_handler
usbd_desc_handler keyboard_desc_handler
keyboard device descriptor handler structure
Definition: keyboard_desc.c:63
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:132
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:602
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
keyboard_class.h
usb hid keyboard header file
keyboard_desc.h
usb keyboard descriptor header file
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
keyboard_type
Definition: keyboard_class.h:67
keyboard_type::g_u8tx_completed
__IO uint8_t g_u8tx_completed
Definition: keyboard_class.h:75
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::remote_wakup
uint8_t remote_wakup
Definition: usbd_core.h:130
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • mouse
  • inc
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • mouse
  • inc
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • mouse
  • inc
project/at_start_f413/examples/usb_device/mouse/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • mouse
  • inc
project/at_start_f413/examples/usb_device/mouse/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99
103#define USB_LOW_POWER_WAKUP
104
105void usb_delay_ms(uint32_t ms);
106void usb_delay_us(uint32_t us);
115#ifdef __cplusplus
116}
117#endif
118
119#endif
120
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:313
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:324


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • mouse
  • src
project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • mouse
  • src
project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/mouse/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • mouse
  • src
project/at_start_f413/examples/usb_device/mouse/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "mouse_class.h"
31#include "mouse_desc.h"
32#include "usbd_int.h"
33
42 usbd_core_type usb_core_dev;
43__IO uint8_t press_mouse = 0;
44extern __IO uint8_t hid_suspend_flag;
45uint8_t report_buf[USBD_MOUSE_IN_MAXPACKET_SIZE];
46void system_clock_recover(void);
47void button_exint_init(void);
48void usb_low_power_wakeup_config(void);
54void usb_clock48m_select(usb_clk48_s clk_s)
55{
56 if(clk_s == USB_CLK_HICK)
57 {
58 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
59
60 /* enable the acc calibration ready interrupt */
61 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
62
63 /* update the c1\c2\c3 value */
64 acc_write_c1(7980);
65 acc_write_c2(8000);
66 acc_write_c3(8020);
67
68 /* open acc calibration */
69 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
70 }
71 else
72 {
73 switch(system_core_clock)
74 {
75 /* 48MHz */
76 case 48000000:
77 crm_usb_clock_div_set(CRM_USB_DIV_1);
78 break;
79
80 /* 72MHz */
81 case 72000000:
82 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
83 break;
84
85 /* 96MHz */
86 case 96000000:
87 crm_usb_clock_div_set(CRM_USB_DIV_2);
88 break;
89
90 /* 120MHz */
91 case 120000000:
92 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
93 break;
94
95 /* 144MHz */
96 case 144000000:
97 crm_usb_clock_div_set(CRM_USB_DIV_3);
98 break;
99
100 /* 168MHz */
101 case 168000000:
102 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
103 break;
104
105 /* 192MHz */
106 case 192000000:
107 crm_usb_clock_div_set(CRM_USB_DIV_4);
108 break;
109
110 default:
111 break;
112
113 }
114 }
115}
116
122int main(void)
123{
124 __IO uint32_t delay_index = 0;
125 /* config nvic priority group */
126 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
127
128 system_clock_config();
129
130 at32_board_init();
131
132 /* select usb 48m clcok source */
133 usb_clock48m_select(USB_CLK_HEXT);
134
135#ifdef USB_LOW_POWER_WAKUP
136 /* enable pwc and bpr clock */
137 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
138 button_exint_init();
139 usb_low_power_wakeup_config();
140#endif
141
142 /* enable usb clock */
143 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
144
145 /* enable usb interrupt */
146 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
147
148 /* usb core init */
149 usbd_core_init(&usb_core_dev, USB, &mouse_class_handler, &mouse_desc_handler, 0);
150
151 /* enable usb pull-up */
152 usbd_connect(&usb_core_dev);
153
154 while(1)
155 {
156 if(at32_button_press() == USER_BUTTON)
157 {
158 if(usbd_connect_state_get(&usb_core_dev) == USB_CONN_STATE_CONFIGURED)
159 {
160 usb_hid_mouse_send(&usb_core_dev, RIGHT_BUTTON);
161 press_mouse = 1;
162 }
163 /* remote wakeup */
164 if(usbd_connect_state_get(&usb_core_dev) == USB_CONN_STATE_SUSPENDED
165 &&(usb_core_dev.remote_wakup == 1))
166 {
167 usbd_remote_wakeup(&usb_core_dev);
168 }
169 }
170 else if(press_mouse == 1)
171 {
172 delay_ms(10);
173 usb_hid_mouse_send(&usb_core_dev, BUTTON_RELEASE);
174 press_mouse = 0;
175 }
176 #ifdef USB_LOW_POWER_WAKUP
177 /* enter deep sleep */
178 if(((mouse_type *)(usb_core_dev.class_handler->pdata))->hid_suspend_flag == 1)
179 {
180 at32_led_off(LED2);
181 at32_led_off(LED3);
182 at32_led_off(LED4);
183 /* congfig the voltage regulator mode */
184 pwc_voltage_regulate_set(PWC_REGULATOR_LOW_POWER);
185
186 /* enter deep sleep mode */
187 pwc_deep_sleep_mode_enter(PWC_DEEP_SLEEP_ENTER_WFI);
188 /* wait clock stable */
189
190 system_clock_recover();
191 ((mouse_type *)(usb_core_dev.class_handler->pdata))->hid_suspend_flag = 0;
192 at32_led_on(LED2);
193 at32_led_on(LED3);
194 at32_led_on(LED4);
195 }
196#endif
197
198 }
199}
200
201#ifdef USB_LOW_POWER_WAKUP
207void button_exint_init(void)
208{
209 exint_init_type exint_init_struct;
210
211 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
212 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE0);
213
214 exint_default_para_init(&exint_init_struct);
215 exint_init_struct.line_enable = TRUE;
216 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
217 exint_init_struct.line_select = EXINT_LINE_0;
218 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
219 exint_init(&exint_init_struct);
220
221 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
222 nvic_irq_enable(EXINT0_IRQn, 0, 0);
223}
224
230void EXINT0_IRQHandler(void)
231{
232 /* clear interrupt pending bit */
233 exint_flag_clear(EXINT_LINE_0);
234}
235
241void usb_low_power_wakeup_config(void)
242{
243 exint_init_type exint_init_struct;
244
245 exint_default_para_init(&exint_init_struct);
246
247 exint_init_struct.line_enable = TRUE;
248 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
249 exint_init_struct.line_select = EXINT_LINE_18;
250 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
251 exint_init(&exint_init_struct);
252
253 nvic_irq_enable(USBFSWakeUp_IRQn, 0, 0);
254}
255
261void USBFSWakeUp_IRQHandler(void)
262{
263 exint_flag_clear(EXINT_LINE_18);
264}
265
271void system_clock_recover(void)
272{
273 /* enable external high-speed crystal oscillator - hext */
274 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
275
276 /* wait till hext is ready */
277 while(crm_hext_stable_wait() == ERROR);
278
279 /* enable pll */
280 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
281
282 /* wait till pll is ready */
283 while(crm_flag_get(CRM_PLL_STABLE_FLAG) == RESET);
284
285 /* enable auto step mode */
286 crm_auto_step_mode_enable(TRUE);
287
288 /* select pll as system clock source */
289 crm_sysclk_switch(CRM_SCLK_PLL);
290
291 /* wait till pll is used as system clock source */
292 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL);
293}
294
295#endif
296
302void USBFS_L_CAN1_RX0_IRQHandler(void)
303{
304 usbd_irq_handler(&usb_core_dev);
305}
306
307
313void usb_delay_ms(uint32_t ms)
314{
315 /* user can define self delay function */
316 delay_ms(ms);
317}
318
324void usb_delay_us(uint32_t us)
325{
326 delay_us(us);
327}
328
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f413/examples/exint/exint_config/src/main.c:96
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
hid_suspend_flag
__IO uint8_t hid_suspend_flag
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f413/templates/src/main.c:52
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:54
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:122
usb_low_power_wakeup_config
void usb_low_power_wakeup_config(void)
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:302
report_buf
uint8_t report_buf[USBD_MOUSE_IN_MAXPACKET_SIZE]
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:45
press_mouse
__IO uint8_t press_mouse
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:43
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/mouse/src/main.c:42
system_clock_recover
void system_clock_recover(void)
systemclock recover.
Definition: project/at_start_f413/examples/pwc/deepsleep_rtc/src/main.c:98
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
USBFSWakeUp_IRQn
@ USBFSWakeUp_IRQn
Definition: at32f413.h:176
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:139
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:93
EXINT_LINE_18
#define EXINT_LINE_18
Definition: at32f413_exint.h:70
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f413_exint.h:52
ERROR
@ ERROR
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:573
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:254
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:277
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
pwc_voltage_regulate_set
void pwc_voltage_regulate_set(pwc_regulator_type pwc_regulator)
regulate low power consumption in the deep sleep mode
Definition: at32f413_pwc.c:213
pwc_deep_sleep_mode_enter
void pwc_deep_sleep_mode_enter(pwc_deep_sleep_enter_type pwc_deep_sleep_enter)
enter pwc deep-sleep mode
Definition: at32f413_pwc.c:189
PWC_REGULATOR_LOW_POWER
@ PWC_REGULATOR_LOW_POWER
Definition: at32f413_pwc.h:107
PWC_DEEP_SLEEP_ENTER_WFI
@ PWC_DEEP_SLEEP_ENTER_WFI
Definition: at32f413_pwc.h:97
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
USBD_MOUSE_IN_MAXPACKET_SIZE
#define USBD_MOUSE_IN_MAXPACKET_SIZE
usb hid in and out max packet size define
Definition: mouse_class.h:58
mouse_class_handler
usbd_class_handler mouse_class_handler
Definition: mouse_class.c:56
usb_hid_mouse_send
void usb_hid_mouse_send(void *udev, uint8_t op)
usb device class report function
Definition: mouse_class.c:319
BUTTON_RELEASE
#define BUTTON_RELEASE
Definition: mouse_class.h:74
RIGHT_BUTTON
#define RIGHT_BUTTON
Definition: mouse_class.h:76
mouse_desc_handler
usbd_desc_handler mouse_desc_handler
mouse device descriptor handler structure
Definition: mouse_desc.c:63
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:132
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:602
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
mouse_class.h
usb hid mouse header file
mouse_desc.h
usb mouse descriptor header file
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
mouse_type
Definition: mouse_class.h:83
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::remote_wakup
uint8_t remote_wakup
Definition: usbd_core.h:130
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • msc
  • inc
project/at_start_f413/examples/usb_device/msc/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • msc
  • inc
project/at_start_f413/examples/usb_device/msc/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • msc
  • inc
project/at_start_f413/examples/usb_device/msc/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • msc
  • inc
project/at_start_f413/examples/usb_device/msc/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99
100void usb_delay_ms(uint32_t ms);
101void usb_delay_us(uint32_t us);
102
111#ifdef __cplusplus
112}
113#endif
114
115#endif
116
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:163
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:174


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • msc
  • src
project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • msc
  • src
project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/msc/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • msc
  • src
project/at_start_f413/examples/usb_device/msc/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "msc_class.h"
31#include "msc_desc.h"
32#include "usbd_int.h"
33
34
43 usbd_core_type usb_core_dev;
44
45
51void usb_clock48m_select(usb_clk48_s clk_s)
52{
53 if(clk_s == USB_CLK_HICK)
54 {
55 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
56
57 /* enable the acc calibration ready interrupt */
58 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
59
60 /* update the c1\c2\c3 value */
61 acc_write_c1(7980);
62 acc_write_c2(8000);
63 acc_write_c3(8020);
64
65 /* open acc calibration */
66 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
67 }
68 else
69 {
70 switch(system_core_clock)
71 {
72 /* 48MHz */
73 case 48000000:
74 crm_usb_clock_div_set(CRM_USB_DIV_1);
75 break;
76
77 /* 72MHz */
78 case 72000000:
79 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
80 break;
81
82 /* 96MHz */
83 case 96000000:
84 crm_usb_clock_div_set(CRM_USB_DIV_2);
85 break;
86
87 /* 120MHz */
88 case 120000000:
89 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
90 break;
91
92 /* 144MHz */
93 case 144000000:
94 crm_usb_clock_div_set(CRM_USB_DIV_3);
95 break;
96
97 /* 168MHz */
98 case 168000000:
99 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
100 break;
101
102 /* 192MHz */
103 case 192000000:
104 crm_usb_clock_div_set(CRM_USB_DIV_4);
105 break;
106
107 default:
108 break;
109
110 }
111 }
112}
113
119int main(void)
120{
121 /* config nvic priority group */
122 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
123
124 system_clock_config();
125
126 at32_board_init();
127
128 /* select usb 48m clcok source */
129 usb_clock48m_select(USB_CLK_HEXT);
130
131 /* enable usb clock */
132 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
133
134 /* enable usb interrupt */
135 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
136
137 /* usb core init */
138 usbd_core_init(&usb_core_dev, USB, &msc_class_handler, &msc_desc_handler, 0);
139
140 /* enable usb pull-up */
141 usbd_connect(&usb_core_dev);
142
143 while(1)
144 {
145 }
146}
147
153void USBFS_L_CAN1_RX0_IRQHandler(void)
154{
155 usbd_irq_handler(&usb_core_dev);
156}
157
163void usb_delay_ms(uint32_t ms)
164{
165 /* user can define self delay function */
166 delay_ms(ms);
167}
168
174void usb_delay_us(uint32_t us)
175{
176 delay_us(us);
177}
178
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:51
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:119
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:153
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/msc/src/main.c:43
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:57
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:64
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
msc_class.h
usb msc class file
msc_desc.h
usb msc descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • printer
  • inc
project/at_start_f413/examples/usb_device/printer/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • printer
  • inc
project/at_start_f413/examples/usb_device/printer/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • printer
  • inc
project/at_start_f413/examples/usb_device/printer/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • printer
  • inc
project/at_start_f413/examples/usb_device/printer/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99
100void usb_delay_ms(uint32_t ms);
101void usb_delay_us(uint32_t us);
102
111#ifdef __cplusplus
112}
113#endif
114
115#endif
116
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:161
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:172


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • printer
  • src
project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • printer
  • src
project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/printer/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • printer
  • src
project/at_start_f413/examples/usb_device/printer/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "printer_class.h"
31#include "printer_desc.h"
32#include "usbd_int.h"
33
42 usbd_core_type usb_core_dev;
43
49void usb_clock48m_select(usb_clk48_s clk_s)
50{
51 if(clk_s == USB_CLK_HICK)
52 {
53 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
54
55 /* enable the acc calibration ready interrupt */
56 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
57
58 /* update the c1\c2\c3 value */
59 acc_write_c1(7980);
60 acc_write_c2(8000);
61 acc_write_c3(8020);
62
63 /* open acc calibration */
64 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
65 }
66 else
67 {
68 switch(system_core_clock)
69 {
70 /* 48MHz */
71 case 48000000:
72 crm_usb_clock_div_set(CRM_USB_DIV_1);
73 break;
74
75 /* 72MHz */
76 case 72000000:
77 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
78 break;
79
80 /* 96MHz */
81 case 96000000:
82 crm_usb_clock_div_set(CRM_USB_DIV_2);
83 break;
84
85 /* 120MHz */
86 case 120000000:
87 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
88 break;
89
90 /* 144MHz */
91 case 144000000:
92 crm_usb_clock_div_set(CRM_USB_DIV_3);
93 break;
94
95 /* 168MHz */
96 case 168000000:
97 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
98 break;
99
100 /* 192MHz */
101 case 192000000:
102 crm_usb_clock_div_set(CRM_USB_DIV_4);
103 break;
104
105 default:
106 break;
107
108 }
109 }
110}
111
117int main(void)
118{
119 /* config nvic priority group */
120 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
121
122 system_clock_config();
123
124 at32_board_init();
125
126 /* select usb 48m clcok source */
127 usb_clock48m_select(USB_CLK_HEXT);
128
129 /* enable usb clock */
130 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
131
132 /* enable usb interrupt */
133 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
134
135 /* usb core init */
136 usbd_core_init(&usb_core_dev, USB, &printer_class_handler, &printer_desc_handler, 0);
137
138 /* enable usb pull-up */
139 usbd_connect(&usb_core_dev);
140
141 while(1)
142 {
143 }
144}
145
151void USBFS_L_CAN1_RX0_IRQHandler(void)
152{
153 usbd_irq_handler(&usb_core_dev);
154}
155
161void usb_delay_ms(uint32_t ms)
162{
163 /* user can define self delay function */
164 delay_ms(ms);
165}
166
172void usb_delay_us(uint32_t us)
173{
174 delay_us(us);
175}
176
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:49
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:117
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:151
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/printer/src/main.c:42
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
printer_class_handler
usbd_class_handler printer_class_handler
Definition: printer_class.c:64
printer_desc_handler
usbd_desc_handler printer_desc_handler
device descriptor handler structure
Definition: printer_desc.c:64
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
printer_class.h
usb printer class file
printer_desc.h
usb printer descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • vcp_loopback
  • inc
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • vcp_loopback
  • inc
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • vcp_loopback
  • inc
project/at_start_f413/examples/usb_device/vcp_loopback/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • vcp_loopback
  • inc
project/at_start_f413/examples/usb_device/vcp_loopback/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63//#define USB_EPT_AUTO_MALLOC_BUFFER /*!< usb auto malloc endpoint tx and rx buffer */
64
65
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99
100void usb_delay_ms(uint32_t ms);
101void usb_delay_us(uint32_t us);
102
111#ifdef __cplusplus
112}
113#endif
114
115#endif
116
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:195
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:206


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • vcp_loopback
  • src
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • vcp_loopback
  • src
project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • vcp_loopback
  • src
project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "cdc_class.h"
31#include "cdc_desc.h"
32#include "usbd_int.h"
33
42 usbd_core_type usb_core_dev;
43uint8_t usb_buffer[256];
44
50void usb_clock48m_select(usb_clk48_s clk_s)
51{
52 if(clk_s == USB_CLK_HICK)
53 {
54 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
55
56 /* enable the acc calibration ready interrupt */
57 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
58
59 /* update the c1\c2\c3 value */
60 acc_write_c1(7980);
61 acc_write_c2(8000);
62 acc_write_c3(8020);
63
64 /* open acc calibration */
65 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
66 }
67 else
68 {
69 switch(system_core_clock)
70 {
71 /* 48MHz */
72 case 48000000:
73 crm_usb_clock_div_set(CRM_USB_DIV_1);
74 break;
75
76 /* 72MHz */
77 case 72000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
79 break;
80
81 /* 96MHz */
82 case 96000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_2);
84 break;
85
86 /* 120MHz */
87 case 120000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
89 break;
90
91 /* 144MHz */
92 case 144000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_3);
94 break;
95
96 /* 168MHz */
97 case 168000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
99 break;
100
101 /* 192MHz */
102 case 192000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_4);
104 break;
105
106 default:
107 break;
108
109 }
110 }
111}
112
118int main(void)
119{
120 uint16_t data_len;
121
122 uint32_t timeout;
123
124 uint8_t send_zero_packet = 0;
125
126 /* config nvic priority group */
127 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
128
129 system_clock_config();
130
131 at32_board_init();
132
133 /* select usb 48m clcok source */
134 usb_clock48m_select(USB_CLK_HEXT);
135
136 /* enable usb clock */
137 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
138
139 /* enable usb interrupt */
140 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
141
142 /* usb core init */
143 usbd_core_init(&usb_core_dev, USB, &cdc_class_handler, &cdc_desc_handler, 0);
144
145 /* enable usb pull-up */
146 usbd_connect(&usb_core_dev);
147
148 while(1)
149 {
150 /* get usb vcp receive data */
151 data_len = usb_vcp_get_rxdata(&usb_core_dev, usb_buffer);
152
153 if(data_len > 0 || send_zero_packet == 1)
154 {
155
156 /* bulk transfer is complete when the endpoint does one of the following
157 1 has transferred exactly the amount of data expected
158 2 transfers a packet with a payload size less than wMaxPacketSize or transfers a zero-length packet
159 */
160 if(data_len > 0)
161 send_zero_packet = 1;
162
163 if(data_len == 0)
164 send_zero_packet = 0;
165
166 timeout = 5000000;
167 do
168 {
169 /* send data to host */
170 if(usb_vcp_send_data(&usb_core_dev, usb_buffer, data_len) == SUCCESS)
171 {
172 break;
173 }
174 }while(timeout --);
175 }
176 }
177}
178
179
185void USBFS_L_CAN1_RX0_IRQHandler(void)
186{
187 usbd_irq_handler(&usb_core_dev);
188}
189
195void usb_delay_ms(uint32_t ms)
196{
197 /* user can define self delay function */
198 delay_ms(ms);
199}
200
206void usb_delay_us(uint32_t us)
207{
208 delay_us(us);
209}
210
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:50
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:118
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:185
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:43
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/vcp_loopback/src/main.c:42
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:340
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:370
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:69
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:63
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • virtual_comport
  • inc
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • virtual_comport
  • inc
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • virtual_comport
  • inc
project/at_start_f413/examples/usb_device/virtual_comport/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • virtual_comport
  • inc
project/at_start_f413/examples/usb_device/virtual_comport/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63//#define USB_EPT_AUTO_MALLOC_BUFFER /*!< usb auto malloc endpoint tx and rx buffer */
64
68#define USB_VIRTUAL_COMPORT
69
70#ifndef USB_EPT_AUTO_MALLOC_BUFFER
76/* ept0 tx start address 0x40, size 0x40,
77 so rx start address is 0x40 + 0x40 = 0x80 */
78#define EPT0_TX_ADDR 0x40
79#define EPT0_RX_ADDR 0x80
81#define EPT1_TX_ADDR 0xC0
82#define EPT1_RX_ADDR 0x100
84#define EPT2_TX_ADDR 0x140
85#define EPT2_RX_ADDR 0x180
87#define EPT3_TX_ADDR 0x00
88#define EPT3_RX_ADDR 0x00
90#define EPT4_TX_ADDR 0x00
91#define EPT4_RX_ADDR 0x00
93#define EPT5_TX_ADDR 0x00
94#define EPT5_RX_ADDR 0x00
96#define EPT6_TX_ADDR 0x00
97#define EPT6_RX_ADDR 0x00
99#define EPT7_TX_ADDR 0x00
100#define EPT7_RX_ADDR 0x00
102#endif
103
104void usb_delay_ms(uint32_t ms);
105void usb_delay_us(uint32_t us);
106
115#ifdef __cplusplus
116}
117#endif
118
119#endif
120
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • virtual_comport
  • src
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • virtual_comport
  • src
project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • virtual_comport
  • src
project/at_start_f413/examples/usb_device/virtual_comport/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "cdc_class.h"
31#include "cdc_desc.h"
32#include "usbd_int.h"
33
42 usbd_core_type usb_core_dev;
43uint8_t usb_buffer[256];
44
45/* usart global struct define */
46extern linecoding_type linecoding;
47void usb_usart_config(linecoding_type linecoding);
48void usart_gpio_config(void);
49#define usart_buffer_size 2048
50uint8_t usart_rx_buffer[usart_buffer_size];
51uint16_t hw_usart_rx_index = 0;
52uint16_t hw_usart_read_index = 0;
53uint16_t usart_rx_data_len = 0;
54uint16_t ov_cnt = 0;
55void usart_send_data(uint8_t *send_data, uint16_t len);
56uint16_t usart_receive_data(void);
57
63void usb_clock48m_select(usb_clk48_s clk_s)
64{
65 if(clk_s == USB_CLK_HICK)
66 {
67 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
68
69 /* enable the acc calibration ready interrupt */
70 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
71
72 /* update the c1\c2\c3 value */
73 acc_write_c1(7980);
74 acc_write_c2(8000);
75 acc_write_c3(8020);
76
77 /* open acc calibration */
78 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
79 }
80 else
81 {
82 switch(system_core_clock)
83 {
84 /* 48MHz */
85 case 48000000:
86 crm_usb_clock_div_set(CRM_USB_DIV_1);
87 break;
88
89 /* 72MHz */
90 case 72000000:
91 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
92 break;
93
94 /* 96MHz */
95 case 96000000:
96 crm_usb_clock_div_set(CRM_USB_DIV_2);
97 break;
98
99 /* 120MHz */
100 case 120000000:
101 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
102 break;
103
104 /* 144MHz */
105 case 144000000:
106 crm_usb_clock_div_set(CRM_USB_DIV_3);
107 break;
108
109 /* 168MHz */
110 case 168000000:
111 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
112 break;
113
114 /* 192MHz */
115 case 192000000:
116 crm_usb_clock_div_set(CRM_USB_DIV_4);
117 break;
118
119 default:
120 break;
121
122 }
123 }
124}
125
131int main(void)
132{
133 uint16_t data_len;
134
135 uint32_t timeout;
136
137 uint8_t send_zero_packet = 0;
138
139 /* config nvic priority group */
140 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
141
142 system_clock_config();
143
144 at32_board_init();
145
146 /* usart gpio config */
147 usart_gpio_config();
148
149 /* hardware usart config: usart2 */
150 usb_usart_config(linecoding);
151
152 /* select usb 48m clcok source */
153 usb_clock48m_select(USB_CLK_HEXT);
154
155 /* enable usb clock */
156 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
157
158 /* enable usb interrupt */
159 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
160
161 /* usb core init */
162 usbd_core_init(&usb_core_dev, USB, &cdc_class_handler, &cdc_desc_handler, 0);
163
164 /* enable usb pull-up */
165 usbd_connect(&usb_core_dev);
166
167 while(1)
168 {
169 /* get usb vcp receive data */
170 data_len = usb_vcp_get_rxdata(&usb_core_dev, usb_buffer);
171
172 /* send data to hardware usart */
173 if(data_len > 0)
174 {
175 usart_send_data(usb_buffer, data_len);
176 }
177
178 /* if hardware usart received data,usb send data to host */
179 usart_rx_data_len = usart_receive_data();
180 if(usart_rx_data_len || send_zero_packet == 1)
181 {
182 if(usart_rx_data_len > 0)
183 send_zero_packet = 1;
184
185 if(usart_rx_data_len == 0)
186 send_zero_packet = 0;
187
188 timeout = 50000;
189
190 if((hw_usart_read_index + usart_rx_data_len) < usart_buffer_size)
191 {
192 do
193 {
194 /* send data to host */
195 if(usb_vcp_send_data(&usb_core_dev, &usart_rx_buffer[hw_usart_read_index], usart_rx_data_len) == SUCCESS)
196 {
197 hw_usart_read_index = hw_usart_read_index + usart_rx_data_len;
198
199 break;
200 }
201 }while(timeout --);
202
203 }
204 /* process the fifo overflow */
205 else
206 {
207 do
208 {
209 /* send data to host */
210 if(usb_vcp_send_data(&usb_core_dev, &usart_rx_buffer[hw_usart_read_index], usart_buffer_size - hw_usart_read_index) == SUCCESS)
211 {
212 /* get fifo overflow data count */
213 ov_cnt = usart_rx_data_len - (usart_buffer_size - hw_usart_read_index);
214 hw_usart_read_index = 0;
215 break;
216 }
217 }while(timeout --);
218 timeout = 50000;
219 do
220 {
221 /* send data to host */
222 if(usb_vcp_send_data(&usb_core_dev, &usart_rx_buffer[hw_usart_read_index], ov_cnt) == SUCCESS)
223 {
224 hw_usart_read_index = ov_cnt;
225 break;
226 }
227 }while(timeout --);
228 }
229 }
230 }
231}
232
239void usart_send_data(uint8_t *send_data, uint16_t len)
240{
241 uint16_t index = 0;
242 for(index = 0; index < len; index++ )
243 {
244 do
245 {
246 ;
247 }while(usart_flag_get(USART2, USART_TDBE_FLAG) == RESET);
248
249 usart_data_transmit(USART2, send_data[index]);
250 }
251}
252
258uint16_t usart_receive_data(void)
259{
260 uint16_t usart_data_len;
261 if(hw_usart_read_index == hw_usart_rx_index)
262 {
263 usart_data_len = 0;
264 }
265 else
266 {
267 /* whether to process the fifo overflow or not */
268 if(hw_usart_rx_index > hw_usart_read_index)
269 usart_data_len = hw_usart_rx_index - hw_usart_read_index;
270 else if(hw_usart_rx_index == 0 && hw_usart_rx_index != hw_usart_read_index)
271 usart_data_len = usart_buffer_size - hw_usart_read_index;
272 else
273 usart_data_len = (usart_buffer_size-1) + hw_usart_rx_index - hw_usart_read_index;
274 }
275
276 return usart_data_len;
277}
278
284void USART2_IRQHandler(void)
285{
286 if(usart_flag_get(USART2, USART_RDBF_FLAG) != RESET)
287 {
288 /* read one byte from the receive data register */
289 usart_rx_buffer[hw_usart_rx_index] = usart_data_receive(USART2);
290 hw_usart_rx_index = ( (hw_usart_rx_index+1) & (usart_buffer_size-1) );
291 }
292}
293
299void usb_usart_config( linecoding_type linecoding)
300{
301 usart_stop_bit_num_type usart_stop_bit;
302 usart_data_bit_num_type usart_data_bit;
303 usart_parity_selection_type usart_parity_select;
304
305 /* enable the usart2 and gpio clock */
306 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, FALSE);
307 crm_periph_clock_enable(CRM_USART2_PERIPH_CLOCK, TRUE);
308
309 /* stop bit */
310 switch(linecoding.format)
311 {
312 case 0x0:
313 usart_stop_bit = USART_STOP_1_BIT;
314 break;
315 /* to be used when transmitting and receiving data in smartcard mode */
316 case 0x1:
317 usart_stop_bit = USART_STOP_1_5_BIT;
318 break;
319 case 0x2:
320 usart_stop_bit = USART_STOP_2_BIT;
321 break;
322 default :
323 break;
324 }
325 /* data bits */
326 switch(linecoding.data)
327 {
328 /* hardware usart not support data bits for 5/6/7 */
329 case 0x5:
330 case 0x6:
331 case 0x7:
332 break;
333 case 0x8:
334 usart_data_bit = USART_DATA_8BITS;
335 break;
336 /* hardware usart not support data bits for 16 */
337 case 0x10:
338 break;
339 default :
340 break;
341 }
342 /* parity */
343 switch(linecoding.parity)
344 {
345 case 0x0:
346 usart_parity_select = USART_PARITY_NONE;
347 break;
348 case 0x1:
349 usart_parity_select = USART_PARITY_ODD;
350 break;
351 case 0x2:
352 usart_parity_select = USART_PARITY_EVEN;
353 break;
354 /* hardware usart not support parity for mark and space */
355 case 0x3:
356 case 0x4:
357 break;
358 default :
359 break;
360 }
361
362 nvic_irq_enable(USART2_IRQn, 0, 0);
363
364 /* configure usart2 param */
365 usart_init(USART2, linecoding.bitrate, usart_data_bit, usart_stop_bit);
366 usart_parity_selection_config(USART2, usart_parity_select);
367 usart_transmitter_enable(USART2, TRUE);
368 usart_receiver_enable(USART2, TRUE);
369
370 /* enable usart2 interrupt */
371 usart_interrupt_enable(USART2, USART_RDBF_INT, TRUE);
372 usart_enable(USART2, TRUE);
373}
374
380void usart_gpio_config(void)
381{
382 gpio_init_type gpio_init_struct;
383 crm_periph_clock_enable(CRM_GPIOA_PERIPH_CLOCK, TRUE);
384
385 /* configure the usart2 tx pin */
386 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
387 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
388 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
389 gpio_init_struct.gpio_pins = GPIO_PINS_2;
390 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
391 gpio_init(GPIOA, &gpio_init_struct);
392
393 /* configure the usart2 rx pin */
394 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
395 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
396 gpio_init_struct.gpio_mode = GPIO_MODE_INPUT;
397 gpio_init_struct.gpio_pins = GPIO_PINS_3;
398 gpio_init_struct.gpio_pull = GPIO_PULL_UP;
399 gpio_init(GPIOA, &gpio_init_struct);
400}
401
407void USBFS_L_CAN1_RX0_IRQHandler(void)
408{
409 usbd_irq_handler(&usb_core_dev);
410}
411
417void usb_delay_ms(uint32_t ms)
418{
419 /* user can define self delay function */
420 delay_ms(ms);
421}
422
428void usb_delay_us(uint32_t us)
429{
430 delay_us(us);
431}
432
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
cdc_class.h
usb cdc class file
cdc_desc.h
usb cdc descriptor header file
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:66
main
int main(void)
main function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:268
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
usbfs_l_can1_rx0 interrupt handler
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:123
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usart_buffer_size
#define usart_buffer_size
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:49
USART2_IRQHandler
void USART2_IRQHandler(void)
this function handles usart2 handler.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:284
hw_usart_read_index
uint16_t hw_usart_read_index
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:52
usb_usart_config
void usb_usart_config(linecoding_type linecoding)
this function handles usart2 and linecoding config.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:299
usart_rx_data_len
uint16_t usart_rx_data_len
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:53
linecoding
linecoding_type linecoding
Definition: cdc_class.c:57
ov_cnt
uint16_t ov_cnt
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:54
usart_gpio_config
void usart_gpio_config(void)
this function handles usart2 gpio config.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:380
usart_rx_buffer
uint8_t usart_rx_buffer[2048]
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:50
usart_send_data
void usart_send_data(uint8_t *send_data, uint16_t len)
this function handles usart2 send data.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:239
usb_buffer
uint8_t usb_buffer[256]
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:43
usart_receive_data
uint16_t usart_receive_data(void)
this function handles usart2 receive data.
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:258
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:42
hw_usart_rx_index
uint16_t hw_usart_rx_index
Definition: project/at_start_f413/examples/usb_device/virtual_comport/src/main.c:51
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_GPIOA_PERIPH_CLOCK
@ CRM_GPIOA_PERIPH_CLOCK
Definition: at32f413_crm.h:110
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USART2_PERIPH_CLOCK
@ CRM_USART2_PERIPH_CLOCK
Definition: at32f413_crm.h:132
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USART2_IRQn
@ USART2_IRQn
Definition: at32f413.h:172
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
SUCCESS
@ SUCCESS
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_3
#define GPIO_PINS_3
Definition: at32f413_gpio.h:54
GPIOA
#define GPIOA
Definition: at32f413_gpio.h:748
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usart_data_transmit
void usart_data_transmit(usart_type *usart_x, uint16_t data)
transmit single data through the usart peripheral.
Definition: at32f413_usart.c:374
usart_parity_selection_config
void usart_parity_selection_config(usart_type *usart_x, usart_parity_selection_type parity)
usart parity selection config.
Definition: at32f413_usart.c:138
usart_flag_get
flag_status usart_flag_get(usart_type *usart_x, uint32_t flag)
check whether the specified usart flag is set or not.
Definition: at32f413_usart.c:559
usart_transmitter_enable
void usart_transmitter_enable(usart_type *usart_x, confirm_state new_state)
usart transmitter enable.
Definition: at32f413_usart.c:179
usart_init
void usart_init(usart_type *usart_x, uint32_t baud_rate, usart_data_bit_num_type data_bit, usart_stop_bit_num_type stop_bit)
initialize the usart peripheral according to the specified parameters.
Definition: at32f413_usart.c:99
usart_enable
void usart_enable(usart_type *usart_x, confirm_state new_state)
enable or disable the specified usart peripheral.
Definition: at32f413_usart.c:166
usart_receiver_enable
void usart_receiver_enable(usart_type *usart_x, confirm_state new_state)
usart receiver enable.
Definition: at32f413_usart.c:192
usart_interrupt_enable
void usart_interrupt_enable(usart_type *usart_x, uint32_t usart_int, confirm_state new_state)
enable or disable the specified usart interrupts.
Definition: at32f413_usart.c:257
usart_data_receive
uint16_t usart_data_receive(usart_type *usart_x)
return the most recent received data by the usart peripheral.
Definition: at32f413_usart.c:386
usart_stop_bit_num_type
usart_stop_bit_num_type
usart stop bit num type
Definition: at32f413_usart.h:157
usart_data_bit_num_type
usart_data_bit_num_type
usart data bit num type
Definition: at32f413_usart.h:112
usart_parity_selection_type
usart_parity_selection_type
usart parity selection type
Definition: at32f413_usart.h:93
USART_STOP_1_5_BIT
@ USART_STOP_1_5_BIT
Definition: at32f413_usart.h:161
USART_STOP_1_BIT
@ USART_STOP_1_BIT
Definition: at32f413_usart.h:158
USART_STOP_2_BIT
@ USART_STOP_2_BIT
Definition: at32f413_usart.h:160
USART_DATA_8BITS
@ USART_DATA_8BITS
Definition: at32f413_usart.h:113
USART_PARITY_ODD
@ USART_PARITY_ODD
Definition: at32f413_usart.h:96
USART_PARITY_EVEN
@ USART_PARITY_EVEN
Definition: at32f413_usart.h:95
USART_PARITY_NONE
@ USART_PARITY_NONE
Definition: at32f413_usart.h:94
USART_TDBE_FLAG
#define USART_TDBE_FLAG
Definition: at32f413_usart.h:59
USART_RDBF_FLAG
#define USART_RDBF_FLAG
Definition: at32f413_usart.h:57
USART_RDBF_INT
#define USART_RDBF_INT
Definition: at32f413_usart.h:73
USART2
#define USART2
Definition: at32f413_usart.h:320
usb_vcp_get_rxdata
uint16_t usb_vcp_get_rxdata(void *udev, uint8_t *recv_data)
usb device class rx data process
Definition: cdc_class.c:340
usb_vcp_send_data
error_status usb_vcp_send_data(void *udev, uint8_t *send_data, uint16_t len)
usb device class send data
Definition: cdc_class.c:370
cdc_class_handler
usbd_class_handler cdc_class_handler
Definition: cdc_class.c:69
cdc_desc_handler
usbd_desc_handler cdc_desc_handler
device descriptor handler structure
Definition: cdc_desc.c:63
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:214
linecoding_type::data
uint8_t data
Definition: usb_std.h:217
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:216
linecoding_type::format
uint8_t format
Definition: usb_std.h:215
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
project/at_start_f413/examples/usb_device/virtual_msc_iap/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99
100void usb_delay_ms(uint32_t ms);
101void usb_delay_us(uint32_t us);
102
111#ifdef __cplusplus
112}
113#endif
114
115#endif
116
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:267
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:278


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • usb_device
  • virtual_msc_iap
  • src
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • usb_device
  • virtual_msc_iap
  • src
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • usb_device
  • virtual_msc_iap
  • src
project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "msc_class.h"
31#include "msc_desc.h"
32#include "usbd_int.h"
33#include "flash_fat16.h"
34
43 usbd_core_type usb_core_dev;
44
45void (*pftarget)(void);
46
47void jump_to_app(uint32_t address);
48
49
55void usb_clock48m_select(usb_clk48_s clk_s)
56{
57 if(clk_s == USB_CLK_HICK)
58 {
59 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
60
61 /* enable the acc calibration ready interrupt */
62 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
63
64 /* update the c1\c2\c3 value */
65 acc_write_c1(7980);
66 acc_write_c2(8000);
67 acc_write_c3(8020);
68
69 /* open acc calibration */
70 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
71 }
72 else
73 {
74 switch(system_core_clock)
75 {
76 /* 48MHz */
77 case 48000000:
78 crm_usb_clock_div_set(CRM_USB_DIV_1);
79 break;
80
81 /* 72MHz */
82 case 72000000:
83 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
84 break;
85
86 /* 96MHz */
87 case 96000000:
88 crm_usb_clock_div_set(CRM_USB_DIV_2);
89 break;
90
91 /* 120MHz */
92 case 120000000:
93 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
94 break;
95
96 /* 144MHz */
97 case 144000000:
98 crm_usb_clock_div_set(CRM_USB_DIV_3);
99 break;
100
101 /* 168MHz */
102 case 168000000:
103 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
104 break;
105
106 /* 192MHz */
107 case 192000000:
108 crm_usb_clock_div_set(CRM_USB_DIV_4);
109 break;
110
111 default:
112 break;
113
114 }
115 }
116}
117
123int main(void)
124{
125 /* config nvic priority group */
126 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
127
128 system_clock_config();
129
130 flash_fat16_init();
131
132 at32_board_init();
133
134 if(flash_fat16_get_upgrade_flag() == IAP_SUCCESS &&
135 (at32_button_press() == NO_BUTTON))
136 {
137 jump_to_app(flash_iap.flash_app_addr);
138 }
139
140 /* select usb 48m clcok source */
141 usb_clock48m_select(USB_CLK_HEXT);
142
143 /* enable usb clock */
144 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
145
146 /* enable usb interrupt */
147 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
148
149 /* usb core init */
150 usbd_core_init(&usb_core_dev, USB, &msc_class_handler, &msc_desc_handler, 0);
151
152 /* enable usb pull-up */
153 usbd_connect(&usb_core_dev);
154
155 while(1)
156 {
157 flash_fat16_loop_status();
158 }
159}
160
166void usb_reset()
167{
168 delay_ms(1000);
169 usbd_disconnect(&usb_core_dev);
170 delay_ms(1000);
171 usbd_connect(&usb_core_dev);
172}
173
179void flash_fat16_loop_status(void)
180{
181 static uint8_t status = UPGRADE_READY;
182 if(status == flash_iap.msc_up_status)
183 {
184 return;
185 }
186 else
187 {
188 status = flash_iap.msc_up_status;
189 }
190
191 switch(flash_iap.msc_up_status)
192 {
193 case UPGRADE_READY:
194 flash_fat16_set_name((const uint8_t *)"Ready", 5);
195 break;
196 case UPGRAGE_ONGOING:
197 break;
198 case UPGRADE_SUCCESS:
199 flash_fat16_set_name((const uint8_t *)"Success", 7);
200 flash_iap.msc_up_status = UPGRADE_DONE;
201 usb_reset();
202 break;
203 case UPGRADE_FAILED:
204 flash_fat16_set_name((const uint8_t *)"Failed", 6);
205 flash_iap.msc_up_status = UPGRADE_DONE;
206 usb_reset();
207 break;
208 case UPGRADE_LARGE:
209 flash_fat16_set_name((const uint8_t *)"Large", 5);
210 flash_iap.msc_up_status = UPGRADE_DONE;
211 usb_reset();
212 break;
213 case UPGRADE_UNKNOWN:
214 flash_fat16_set_name((const uint8_t *)"Unkown", 6);
215 break;
216 case UPGRADE_DONE:
217 break;
218 case UPGRADE_JUMP:
219 flash_fat16_set_name((const uint8_t *)"Jump", 6);
220 delay_ms(1000);
221 jump_to_app(flash_iap.write_addr);
222 break;
223 default:
224 break;
225 }
226
227}
228
234void jump_to_app(uint32_t address)
235{
236 uint32_t stkptr, jumpaddr;
237 stkptr = *(uint32_t *)address;
238 jumpaddr = *(uint32_t *)(address + sizeof(uint32_t));
239
240 /* clear usb crm */
241 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, FALSE);
242 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, FALSE);
243
244 crm_periph_reset(CRM_USB_PERIPH_RESET, TRUE);
245 crm_periph_reset(CRM_USB_PERIPH_RESET, FALSE);
246
247 __set_MSP(stkptr);
248 pftarget = (void (*) (void))jumpaddr;
249 pftarget();
250}
251
257void USBFS_L_CAN1_RX0_IRQHandler(void)
258{
259 usbd_irq_handler(&usb_core_dev);
260}
261
267void usb_delay_ms(uint32_t ms)
268{
269 /* user can define self delay function */
270 delay_ms(ms);
271}
272
278void usb_delay_us(uint32_t us)
279{
280 delay_us(us);
281}
282
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
flash_fat16.h
fat16 file system header file
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
usb_reset
void usb_reset()
usb re-connect
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:166
jump_to_app
void jump_to_app(uint32_t address)
jump to app
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:234
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:55
main
int main(void)
main function.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:123
flash_fat16_loop_status
void flash_fat16_loop_status(void)
loop status
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:179
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:257
pftarget
void(* pftarget)(void)
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:45
usb_core_dev
usbd_core_type usb_core_dev
Definition: project/at_start_f413/examples/usb_device/virtual_msc_iap/src/main.c:43
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:95
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_periph_reset
void crm_periph_reset(crm_periph_reset_type value, confirm_state new_state)
enable or disable the peripheral reset
Definition: at32f413_crm.c:236
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
CRM_USB_PERIPH_RESET
@ CRM_USB_PERIPH_RESET
Definition: at32f413_crm.h:182
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
flash_fat16_set_name
uint32_t flash_fat16_set_name(const uint8_t *file_name, uint8_t len)
set file name
Definition: flash_fat16.c:359
flash_fat16_get_upgrade_flag
uint8_t flash_fat16_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: flash_fat16.c:270
flash_iap
flash_iap_type flash_iap
Definition: flash_fat16.c:173
flash_fat16_init
void flash_fat16_init(void)
flash fat16 iap init
Definition: flash_fat16.c:711
UPGRADE_LARGE
@ UPGRADE_LARGE
Definition: flash_fat16.h:86
UPGRADE_UNKNOWN
@ UPGRADE_UNKNOWN
Definition: flash_fat16.h:87
UPGRADE_JUMP
@ UPGRADE_JUMP
Definition: flash_fat16.h:89
UPGRADE_FAILED
@ UPGRADE_FAILED
Definition: flash_fat16.h:85
UPGRADE_SUCCESS
@ UPGRADE_SUCCESS
Definition: flash_fat16.h:84
UPGRADE_READY
@ UPGRADE_READY
Definition: flash_fat16.h:82
UPGRAGE_ONGOING
@ UPGRAGE_ONGOING
Definition: flash_fat16.h:83
UPGRADE_DONE
@ UPGRADE_DONE
Definition: flash_fat16.h:88
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
msc_class_handler
usbd_class_handler msc_class_handler
Definition: msc_class.c:57
msc_desc_handler
usbd_desc_handler msc_desc_handler
device descriptor handler structure
Definition: msc_desc.c:64
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_disconnect
void usbd_disconnect(usbd_core_type *udev)
usb device disconnect to host
Definition: usbd_core.c:571
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
msc_class.h
usb msc class file
msc_desc.h
usb msc descriptor header file
flash_iap_type::msc_up_status
upgrade_status_type msc_up_status
Definition: flash_fat16.h:122
flash_iap_type::write_addr
uint32_t write_addr
Definition: flash_fat16.h:120
flash_iap_type::flash_app_addr
uint32_t flash_app_addr
Definition: flash_fat16.h:111
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • wdt
  • wdt_reset
  • inc
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • wdt
  • wdt_reset
  • inc
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • wdt
  • wdt_reset
  • inc
project/at_start_f413/examples/wdt/wdt_reset/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • wdt
  • wdt_reset
  • src
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • wdt
  • wdt_reset
  • src
project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • wdt
  • wdt_reset
  • src
project/at_start_f413/examples/wdt/wdt_reset/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
44int main(void)
45{
46 system_clock_config();
47
48 at32_board_init();
49
50 if(crm_flag_get(CRM_WDT_RESET_FLAG) != RESET)
51 {
52 /* reset from wdt */
53 crm_flag_clear(CRM_WDT_RESET_FLAG);
54
55 at32_led_on(LED4);
56 }
57 else
58 {
59 /* reset from other mode */
60 at32_led_off(LED4);
61 }
62
63 /* disable register write protection */
64 wdt_register_write_enable(TRUE);
65
66 /* set the wdt divider value */
67 wdt_divider_set(WDT_CLK_DIV_4);
68
69 /* set reload value
70
71 timeout = reload_value * (divider / lick_freq ) (s)
72
73 lick_freq = 40000 Hz
74 divider = 4
75 reload_value = 3000
76
77 timeout = 3000 * (4 / 40000 ) = 0.3s = 300ms
78 */
79 wdt_reload_value_set(3000 - 1);
80
81 /* enable wdt */
82 wdt_enable();
83
84 while(1)
85 {
86 /* reload wdt counter */
87 wdt_counter_reload();
88
89 at32_led_toggle(LED3);
90
91 delay_ms(200);
92
93 if(at32_button_press() == USER_BUTTON)
94 {
95 while(1);
96 }
97 }
98}
99
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/wdt/wdt_reset/src/main.c:44
LED3
@ LED3
Definition: at32f413_board.h:64
LED4
@ LED4
Definition: at32f413_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:330
CRM_WDT_RESET_FLAG
#define CRM_WDT_RESET_FLAG
Definition: at32f413_crm.h:64
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f413_wdt.c:97
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f413_wdt.c:49
wdt_counter_reload
void wdt_counter_reload(void)
reload wdt counter
Definition: at32f413_wdt.c:59
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f413_wdt.c:69
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f413_wdt.c:87
WDT_CLK_DIV_4
@ WDT_CLK_DIV_4
Definition: at32f413_wdt.h:69
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • wdt
  • wdt_standby
  • inc
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • wdt
  • wdt_standby
  • inc
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • wdt
  • wdt_standby
  • inc
project/at_start_f413/examples/wdt/wdt_standby/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • wdt
  • wdt_standby
  • src
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • wdt
  • wdt_standby
  • src
project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • wdt
  • wdt_standby
  • src
project/at_start_f413/examples/wdt/wdt_standby/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
44int main(void)
45{
46 system_clock_config();
47
48 at32_board_init();
49
50 /* enable the pwc clock */
51 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
52
53 if(crm_flag_get(CRM_WDT_RESET_FLAG) != RESET)
54 {
55 /* reset from wdt */
56 crm_flag_clear(CRM_WDT_RESET_FLAG);
57
58 at32_led_on(LED4);
59 }
60 else
61 {
62 /* reset from other mode */
63 at32_led_off(LED4);
64 }
65
66 delay_ms(100);
67
68 /* disable register write protection */
69 wdt_register_write_enable(TRUE);
70
71 /* set the wdt divider value */
72 wdt_divider_set(WDT_CLK_DIV_4);
73
74 /* set reload value
75
76 timeout = reload_value * (divider / lick_freq ) (s)
77
78 lick_freq = 40000 Hz
79 divider = 4
80 reload_value = 3000
81
82 timeout = 3000 * (4 / 40000 ) = 0.3s = 300ms
83 */
84 wdt_reload_value_set(3000 - 1);
85
86 /* enable wdt */
87 wdt_enable();
88
89 /* delay 100us wait for iwdg enable successfully */
90 delay_us(100);
91
92 /* enter standby mode */
93 pwc_standby_mode_enter();
94
95 while(1)
96 {
97
98 }
99}
100
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/wdt/wdt_standby/src/main.c:44
LED4
@ LED4
Definition: at32f413_board.h:65
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:330
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_WDT_RESET_FLAG
#define CRM_WDT_RESET_FLAG
Definition: at32f413_crm.h:64
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
pwc_standby_mode_enter
void pwc_standby_mode_enter(void)
enter pwc standby mode
Definition: at32f413_pwc.c:223
wdt_register_write_enable
void wdt_register_write_enable(confirm_state new_state)
enable or disable wdt cmd register write
Definition: at32f413_wdt.c:97
wdt_enable
void wdt_enable(void)
wdt enable ,the reload value will be sent to the counter
Definition: at32f413_wdt.c:49
wdt_reload_value_set
void wdt_reload_value_set(uint16_t reload_value)
set wdt counter reload value
Definition: at32f413_wdt.c:69
wdt_divider_set
void wdt_divider_set(wdt_division_type division)
set wdt division divider
Definition: at32f413_wdt.c:87
WDT_CLK_DIV_4
@ WDT_CLK_DIV_4
Definition: at32f413_wdt.h:69
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • wwdt
  • wwdt_reset
  • inc
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • wwdt
  • wwdt_reset
  • inc
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • wwdt
  • wwdt_reset
  • inc
project/at_start_f413/examples/wwdt/wwdt_reset/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • wwdt
  • wwdt_reset
  • src
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_clock.c:48
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • wwdt
  • wwdt_reset
  • src
project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while(1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while(1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while(1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while(1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/at32f413_int.c:114
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • wwdt
  • wwdt_reset
  • src
project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
43int main(void)
44{
45 system_clock_config();
46
47 at32_board_init();
48
49 if(crm_flag_get(CRM_WWDT_RESET_FLAG) != RESET)
50 {
51 /* reset from wwdt */
52 crm_flag_clear(CRM_WWDT_RESET_FLAG);
53
54 at32_led_on(LED4);
55 }
56 else
57 {
58 /* reset from other mode */
59 at32_led_off(LED4);
60 }
61
62 /* enable the wwdt clock */
63 crm_periph_clock_enable(CRM_WWDT_PERIPH_CLOCK, TRUE);
64
65 /* set the wwdt divider value */
66 wwdt_divider_set(WWDT_PCLK1_DIV_32768);
67
68 /* set the wwdt window counter value */
69 wwdt_window_counter_set(0x6F);
70
71 /* enable wwdt
72
73 window_value: (0x7F - 0x6F)
74 timeout_value: (0x7F - 0x40) + 1
75
76 timeout = timeout_value * (divider / pclk1_freq ) (s)
77 window = window_value * (divider / pclk1_freq ) (s)
78
79 pclk1_freq = 120 MHz
80 divider = 32768
81 reload_value = 0x40 = 64
82 window_value = 0x10 = 16
83
84 timeout = 64 * (32768 / 96000000 ) = 0.0218s = 21.8ms
85 window = 16 * (32768 / 96000000 ) = 0.0055s = 5.5ms
86
87 */
88 wwdt_enable(0x7F);
89
90 while(1)
91 {
92 at32_led_toggle(LED3);
93
94 /* the reload time must within the window (8ms > 5.5ms) */
95 delay_ms(8);
96
97 /* update the wwdt window counter */
98 wwdt_counter_set(0x7F);
99
100 if(at32_button_press() == USER_BUTTON)
101 {
102 while(1);
103 }
104 }
105}
106
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
main
int main(void)
main function.
Definition: project/at_start_f413/examples/wwdt/wwdt_reset/src/main.c:43
LED3
@ LED3
Definition: at32f413_board.h:64
LED4
@ LED4
Definition: at32f413_board.h:65
USER_BUTTON
@ USER_BUTTON
Definition: at32f413_board.h:94
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_flag_clear
void crm_flag_clear(uint32_t flag)
clear the crm reset flags
Definition: at32f413_crm.c:330
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_WWDT_PERIPH_CLOCK
@ CRM_WWDT_PERIPH_CLOCK
Definition: at32f413_crm.h:130
CRM_WWDT_RESET_FLAG
#define CRM_WWDT_RESET_FLAG
Definition: at32f413_crm.h:65
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
wwdt_counter_set
void wwdt_counter_set(uint8_t wwdt_cnt)
wwdt counter value set
Definition: at32f413_wwdt.c:114
wwdt_divider_set
void wwdt_divider_set(wwdt_division_type division)
wwdt division set
Definition: at32f413_wwdt.c:64
wwdt_window_counter_set
void wwdt_window_counter_set(uint8_t window_cnt)
wwdt window counter value set
Definition: at32f413_wwdt.c:124
wwdt_enable
void wwdt_enable(uint8_t wwdt_cnt)
wwdt enable and the counter value load
Definition: at32f413_wwdt.c:84
WWDT_PCLK1_DIV_32768
@ WWDT_PCLK1_DIV_32768
Definition: at32f413_wwdt.h:70
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • templates
  • inc
project/at_start_f413/templates/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • templates
  • inc
project/at_start_f413/templates/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
52#if !defined HEXT_VALUE
53#define HEXT_VALUE ((uint32_t)8000000)
54#endif
55
60#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
61#define HICK_VALUE ((uint32_t)8000000)
63/* module define -------------------------------------------------------------*/
64#define CRM_MODULE_ENABLED
65#define TMR_MODULE_ENABLED
66#define RTC_MODULE_ENABLED
67#define BPR_MODULE_ENABLED
68#define GPIO_MODULE_ENABLED
69#define I2C_MODULE_ENABLED
70#define USART_MODULE_ENABLED
71#define PWC_MODULE_ENABLED
72#define CAN_MODULE_ENABLED
73#define ADC_MODULE_ENABLED
74#define SPI_MODULE_ENABLED
75#define DMA_MODULE_ENABLED
76#define DEBUG_MODULE_ENABLED
77#define FLASH_MODULE_ENABLED
78#define CRC_MODULE_ENABLED
79#define WWDT_MODULE_ENABLED
80#define WDT_MODULE_ENABLED
81#define EXINT_MODULE_ENABLED
82#define SDIO_MODULE_ENABLED
83#define USB_MODULE_ENABLED
84#define ACC_MODULE_ENABLED
85#define MISC_MODULE_ENABLED
86
87/* includes ------------------------------------------------------------------*/
88#ifdef CRM_MODULE_ENABLED
89#include "at32f413_crm.h"
90#endif
91#ifdef TMR_MODULE_ENABLED
92#include "at32f413_tmr.h"
93#endif
94#ifdef RTC_MODULE_ENABLED
95#include "at32f413_rtc.h"
96#endif
97#ifdef BPR_MODULE_ENABLED
98#include "at32f413_bpr.h"
99#endif
100#ifdef GPIO_MODULE_ENABLED
101#include "at32f413_gpio.h"
102#endif
103#ifdef I2C_MODULE_ENABLED
104#include "at32f413_i2c.h"
105#endif
106#ifdef USART_MODULE_ENABLED
107#include "at32f413_usart.h"
108#endif
109#ifdef PWC_MODULE_ENABLED
110#include "at32f413_pwc.h"
111#endif
112#ifdef CAN_MODULE_ENABLED
113#include "at32f413_can.h"
114#endif
115#ifdef ADC_MODULE_ENABLED
116#include "at32f413_adc.h"
117#endif
118#ifdef SPI_MODULE_ENABLED
119#include "at32f413_spi.h"
120#endif
121#ifdef DMA_MODULE_ENABLED
122#include "at32f413_dma.h"
123#endif
124#ifdef DEBUG_MODULE_ENABLED
125#include "at32f413_debug.h"
126#endif
127#ifdef FLASH_MODULE_ENABLED
128#include "at32f413_flash.h"
129#endif
130#ifdef CRC_MODULE_ENABLED
131#include "at32f413_crc.h"
132#endif
133#ifdef WWDT_MODULE_ENABLED
134#include "at32f413_wwdt.h"
135#endif
136#ifdef WDT_MODULE_ENABLED
137#include "at32f413_wdt.h"
138#endif
139#ifdef EXINT_MODULE_ENABLED
140#include "at32f413_exint.h"
141#endif
142#ifdef SDIO_MODULE_ENABLED
143#include "at32f413_sdio.h"
144#endif
145#ifdef ACC_MODULE_ENABLED
146#include "at32f413_acc.h"
147#endif
148#ifdef MISC_MODULE_ENABLED
149#include "at32f413_misc.h"
150#endif
151#ifdef USB_MODULE_ENABLED
152#include "at32f413_usb.h"
153#endif
154
163#ifdef __cplusplus
164}
165#endif
166
167#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • templates
  • inc
project/at_start_f413/templates/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • templates
  • src
project/at_start_f413/templates/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
56void system_clock_config(void)
57{
58 /* reset crm */
59 crm_reset();
60
61 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
62
63 /* wait till hext is ready */
64 while(crm_hext_stable_wait() == ERROR)
65 {
66 }
67
68 /* config pll clock resource */
69 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
70
71 /* enable pll */
72 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
73
74 /* wait till pll is ready */
75 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
76 {
77 }
78
79 /* config ahbclk */
80 crm_ahb_div_set(CRM_AHB_DIV_1);
81
82 /* config apb2clk */
83 crm_apb2_div_set(CRM_APB2_DIV_2);
84
85 /* config apb1clk */
86 crm_apb1_div_set(CRM_APB1_DIV_2);
87
88 /* enable auto step mode */
89 crm_auto_step_mode_enable(TRUE);
90
91 /* select pll as system clock source */
92 crm_sysclk_switch(CRM_SCLK_PLL);
93
94 /* wait till pll is used as system clock source */
95 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
96 {
97 }
98
99 /* disable auto step mode */
100 crm_auto_step_mode_enable(FALSE);
101
102 /* update system_core_clock global variable */
103 system_core_clock_update();
104}
105
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/templates/src/at32f413_clock.c:56
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • templates
  • src
project/at_start_f413/templates/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/templates/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/templates/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • templates
  • src
project/at_start_f413/templates/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29
38#define DELAY 100
39#define FAST 1
40#define SLOW 4
41
42uint8_t g_speed = FAST;
43
44void button_exint_init(void);
45void button_isr(void);
46
52void button_exint_init(void)
53{
54 exint_init_type exint_init_struct;
55
56 crm_periph_clock_enable(CRM_IOMUX_PERIPH_CLOCK, TRUE);
57 gpio_exint_line_config(GPIO_PORT_SOURCE_GPIOA, GPIO_PINS_SOURCE0);
58
59 exint_default_para_init(&exint_init_struct);
60 exint_init_struct.line_enable = TRUE;
61 exint_init_struct.line_mode = EXINT_LINE_INTERRUPUT;
62 exint_init_struct.line_select = EXINT_LINE_0;
63 exint_init_struct.line_polarity = EXINT_TRIGGER_RISING_EDGE;
64 exint_init(&exint_init_struct);
65
66 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
67 nvic_irq_enable(EXINT0_IRQn, 0, 0);
68}
69
75void button_isr(void)
76{
77 /* delay 5ms */
78 delay_ms(5);
79
80 /* clear interrupt pending bit */
81 exint_flag_clear(EXINT_LINE_0);
82
83 /* check input pin state */
84 if(SET == gpio_input_data_bit_read(USER_BUTTON_PORT, USER_BUTTON_PIN))
85 {
86 if(g_speed == SLOW)
87 g_speed = FAST;
88 else
89 g_speed = SLOW;
90 }
91}
92
98void EXINT0_IRQHandler(void)
99{
100 button_isr();
101}
102
108int main(void)
109{
110 system_clock_config();
111
112 at32_board_init();
113
114 button_exint_init();
115
116 while(1)
117 {
118 at32_led_toggle(LED2);
119 delay_ms(g_speed * DELAY);
120 at32_led_toggle(LED3);
121 delay_ms(g_speed * DELAY);
122 at32_led_toggle(LED4);
123 delay_ms(g_speed * DELAY);
124 }
125}
126
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
SLOW
#define SLOW
Definition: project/at_start_f413/templates/src/main.c:40
button_exint_init
void button_exint_init(void)
configure button exint
Definition: project/at_start_f413/templates/src/main.c:52
DELAY
#define DELAY
Definition: project/at_start_f413/templates/src/main.c:38
FAST
#define FAST
Definition: project/at_start_f413/templates/src/main.c:39
main
int main(void)
main function.
Definition: project/at_start_f413/templates/src/main.c:108
EXINT0_IRQHandler
void EXINT0_IRQHandler(void)
exint0 interrupt handler
Definition: project/at_start_f413/templates/src/main.c:98
g_speed
uint8_t g_speed
Definition: project/at_start_f413/templates/src/main.c:42
button_isr
void button_isr(void)
button handler function
Definition: project/at_start_f413/templates/src/main.c:75
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
USER_BUTTON_PORT
#define USER_BUTTON_PORT
Definition: at32f413_board.h:99
USER_BUTTON_PIN
#define USER_BUTTON_PIN
Definition: at32f413_board.h:98
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_IOMUX_PERIPH_CLOCK
@ CRM_IOMUX_PERIPH_CLOCK
Definition: at32f413_crm.h:109
EXINT0_IRQn
@ EXINT0_IRQn
Definition: at32f413.h:139
exint_flag_clear
void exint_flag_clear(uint32_t exint_line)
clear exint flag
Definition: at32f413_exint.c:126
exint_default_para_init
void exint_default_para_init(exint_init_type *exint_struct)
exint default para init
Definition: at32f413_exint.c:64
exint_init
void exint_init(exint_init_type *exint_struct)
exint init
Definition: at32f413_exint.c:78
EXINT_LINE_INTERRUPUT
@ EXINT_LINE_INTERRUPUT
Definition: at32f413_exint.h:84
EXINT_TRIGGER_RISING_EDGE
@ EXINT_TRIGGER_RISING_EDGE
Definition: at32f413_exint.h:93
EXINT_LINE_0
#define EXINT_LINE_0
Definition: at32f413_exint.h:52
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
gpio_input_data_bit_read
flag_status gpio_input_data_bit_read(gpio_type *gpio_x, uint16_t pins)
read the specified input port pin.
Definition: at32f413_gpio.c:203
gpio_exint_line_config
void gpio_exint_line_config(gpio_port_source_type gpio_port_source, gpio_pins_source_type gpio_pin_source)
select the gpio pin used as exint line.
Definition: at32f413_gpio.c:573
GPIO_PINS_SOURCE0
@ GPIO_PINS_SOURCE0
Definition: at32f413_gpio.h:254
GPIO_PORT_SOURCE_GPIOA
@ GPIO_PORT_SOURCE_GPIOA
Definition: at32f413_gpio.h:277
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
exint_init_type
exint init type
Definition: at32f413_exint.h:102
exint_init_type::line_select
uint32_t line_select
Definition: at32f413_exint.h:104
exint_init_type::line_enable
confirm_state line_enable
Definition: at32f413_exint.h:106
exint_init_type::line_mode
exint_line_mode_type line_mode
Definition: at32f413_exint.h:103
exint_init_type::line_polarity
exint_polarity_config_type line_polarity
Definition: at32f413_exint.h:105
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: fir_filter.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
project_l0/inc/fir_filter.h
Go to the documentation of this file.
1
30/* Define to prevent recursive inclusion -------------------------------------*/
31#ifndef __FIR_FILTER_H
32#define __FIR_FILTER_H
33
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "arm_math.h"
38
39/* Exported types ------------------------------------------------------------*/
40/* Exported constants --------------------------------------------------------*/
41/* Exported macro ------------------------------------------------------------*/
42/* Exported functions ------------------------------------------------------- */
43void arm_fir_init_f32(
44 arm_fir_instance_f32 * S,
45 uint16_t numTaps,
46 const float32_t * pCoeffs,
47 float32_t * pState,
48 uint32_t blockSize);
49
50void arm_fir_f32(
51const arm_fir_instance_f32 * S,
52const float32_t * pSrc,
53float32_t * pDst,
54uint32_t blockSize);
55
56void FIR_lowpass_filter(float32_t * pSrc, float32_t * pDst, uint32_t testlengthsamples);
57
58#endif /* __FIR_FILTER_H */
59
arm_fir_f32
void arm_fir_f32(const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76


AT32F413 Firmwary Library: math_helper.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
project_l0/inc/math_helper.h
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2013 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8*
9* Title: math_helper.h
10*
11* Description: Prototypes of all helper functions required.
12*
13* Target Processor: Cortex-M4/Cortex-M3
14*
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41
42
43#include "arm_math.h"
44
45#ifndef MATH_HELPER_H
46#define MATH_HELPER_H
47
48float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize);
49void arm_float_to_q12_20(float *pIn, q31_t * pOut, uint32_t numSamples);
50void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits);
51void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits);
52void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples);
53void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples);
54void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples);
55void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples);
56void arm_clip_f32(float *pIn, uint32_t numSamples);
57uint32_t arm_calc_guard_bits(uint32_t num_adds);
58void arm_apply_guard_bits (float32_t * pIn, uint32_t numSamples, uint32_t guard_bits);
59uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t * pOut, uint32_t numSamples);
60uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples);
61uint32_t arm_calc_2pow(uint32_t guard_bits);
62#endif
63
arm_float_to_q29
void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:391
arm_apply_guard_bits
void arm_apply_guard_bits(float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer.
Definition: project_l0/src/math_helper.c:293
arm_float_to_q30
void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:364
arm_float_to_q14
void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14.
Definition: project_l0/src/math_helper.c:334
arm_float_to_q12_20
void arm_float_to_q12_20(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format.
Definition: project_l0/src/math_helper.c:139
arm_compare_fixed_q31
uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:193
arm_calc_guard_bits
uint32_t arm_calc_guard_bits(uint32_t num_adds)
Caluclates number of guard bits.
Definition: project_l0/src/math_helper.c:267
arm_compare_fixed_q15
uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:165
arm_calc_2pow
uint32_t arm_calc_2pow(uint32_t guard_bits)
Calculates pow(2, numShifts)
Definition: project_l0/src/math_helper.c:310
arm_float_to_q28
void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format.
Definition: project_l0/src/math_helper.c:419
arm_clip_f32
void arm_clip_f32(float *pIn, uint32_t numSamples)
Clip the float values to +/- 1.
Definition: project_l0/src/math_helper.c:445
arm_provide_guard_bits_q15
void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:119
arm_provide_guard_bits_q31
void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:223
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61


AT32F413 Firmwary Library: arm_fir_data.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
project_l0/src/arm_fir_data.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8* Title: arm_fir_data.c
9*
10* Description: Data file used for example code
11*
12* Target Processor: Cortex-M4/Cortex-M3/Cortex-M0
13*
14* Redistribution and use in source and binary forms, with or without
15* modification, are permitted provided that the following conditions
16* are met:
17* - Redistributions of source code must retain the above copyright
18* notice, this list of conditions and the following disclaimer.
19* - Redistributions in binary form must reproduce the above copyright
20* notice, this list of conditions and the following disclaimer in
21* the documentation and/or other materials provided with the
22* distribution.
23* - Neither the name of ARM LIMITED nor the names of its contributors
24* may be used to endorse or promote products derived from this
25* software without specific prior written permission.
26*
27* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
28* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
29* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
30* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
31* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
32* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
33* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
34* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
35* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
36* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
37* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
38* POSSIBILITY OF SUCH DAMAGE.
39* -------------------------------------------------------------------- */
40
41#include "at32f413.h"
42#include "arm_math.h"
43
44/* ----------------------------------------------------------------------
45** Test input signal contains 1000Hz + 15000 Hz
46** ------------------------------------------------------------------- */
47
48float32_t testInput_f32_1kHz_15kHz[320] =
49{
50+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
51+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
52+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
53-0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
54-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
55-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
56+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
57+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
58+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
59+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
60-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
61-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
62+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
63+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
64+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
65+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
66-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
67-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
68-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
69+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
70+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
71-0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
72-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
73-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
74+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
75+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
76+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
77+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
78-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
79-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
80-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
81+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
82+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
83+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
84-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
85-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
86-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
87+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
88+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
89+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
90};
91
92/* ----------------------------------------------------------------------
93** Reference output signal computed with MATLAB
94** ------------------------------------------------------------------- */
95
96float32_t refOutput[320] =
97{
98+0.0000000000f, -0.0010797829f, -0.0007681386f, -0.0001982932f, +0.0000644313f, +0.0020854271f, +0.0036891871f, +0.0015855941f,
99-0.0026280805f, -0.0075907658f, -0.0119390538f, -0.0086665968f, +0.0088981202f, +0.0430539279f, +0.0974468742f, +0.1740405600f,
100+0.2681416601f, +0.3747720089f, +0.4893362230f, +0.6024154672f, +0.7058740791f, +0.7968348987f, +0.8715901940f, +0.9277881093f,
101+0.9682182661f, +0.9934674267f, +1.0012052245f, +0.9925859371f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
102+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
103-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
104-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
105-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
106+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
107+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
108+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
109-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
110-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
111-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
112+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
113+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
114+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
115-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
116-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
117-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
118+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
119+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
120+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
121-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
122-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
123-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
124+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
125+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
126+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
127-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
128-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
129-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, -0.0000000000f, +0.1309866321f,
130+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
131+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
132+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
133-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
134-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
135-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
136+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
137+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f
138};
139
at32f413.h
at32f413 header file
testInput_f32_1kHz_15kHz
float32_t testInput_f32_1kHz_15kHz[320]
Definition: project_l0/src/arm_fir_data.c:48
refOutput
float32_t refOutput[320]
Definition: project_l0/src/arm_fir_data.c:96


AT32F413 Firmwary Library: math_helper.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
project_l0/src/math_helper.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0 b
6*
7* Project: CMSIS DSP Library
8*
9* Title: math_helper.c
10*
11* Description: Definition of all helper functions required.
12*
13* Target Processor: Cortex-M4/Cortex-M3
14*
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42* Include standard header files
43* -------------------------------------------------------------------- */
44#include<math.h>
45
46/* ----------------------------------------------------------------------
47* Include project header files
48* -------------------------------------------------------------------- */
49#include "math_helper.h"
50
61float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
62{
63 float EnergySignal = 0.0, EnergyError = 0.0;
64 uint32_t i;
65 float SNR;
66 int temp;
67 int *test;
68
69 for (i = 0; i < buffSize; i++)
70 {
71 /* Checking for a NAN value in pRef array */
72 test = (int *)(&pRef[i]);
73 temp = *test;
74
75 if (temp == 0x7FC00000)
76 {
77 return(0);
78 }
79
80 /* Checking for a NAN value in pTest array */
81 test = (int *)(&pTest[i]);
82 temp = *test;
83
84 if (temp == 0x7FC00000)
85 {
86 return(0);
87 }
88 EnergySignal += pRef[i] * pRef[i];
89 EnergyError += (pRef[i] - pTest[i]) * (pRef[i] - pTest[i]);
90 }
91
92 /* Checking for a NAN value in EnergyError */
93 test = (int *)(&EnergyError);
94 temp = *test;
95
96 if (temp == 0x7FC00000)
97 {
98 return(0);
99 }
100
101
102 SNR = 10 * log10 (EnergySignal / EnergyError);
103
104 return (SNR);
105
106}
107
108
119void arm_provide_guard_bits_q15 (q15_t * input_buf, uint32_t blockSize,
120 uint32_t guard_bits)
121{
122 uint32_t i;
123
124 for (i = 0; i < blockSize; i++)
125 {
126 input_buf[i] = input_buf[i] >> guard_bits;
127 }
128}
129
139void arm_float_to_q12_20(float *pIn, q31_t * pOut, uint32_t numSamples)
140{
141 uint32_t i;
142
143 for (i = 0; i < numSamples; i++)
144 {
145 /* 1048576.0f corresponds to pow(2, 20) */
146 pOut[i] = (q31_t) (pIn[i] * 1048576.0f);
147
148 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
149
150 if (pIn[i] == (float) 1.0)
151 {
152 pOut[i] = 0x000FFFFF;
153 }
154 }
155}
156
165uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
166{
167 uint32_t i;
168 int32_t diff, diffCrnt = 0;
169 uint32_t maxDiff = 0;
170
171 for (i = 0; i < numSamples; i++)
172 {
173 diff = pIn[i] - pOut[i];
174 diffCrnt = (diff > 0) ? diff : -diff;
175
176 if (diffCrnt > maxDiff)
177 {
178 maxDiff = diffCrnt;
179 }
180 }
181
182 return(maxDiff);
183}
184
193uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t * pOut, uint32_t numSamples)
194{
195 uint32_t i;
196 int32_t diff, diffCrnt = 0;
197 uint32_t maxDiff = 0;
198
199 for (i = 0; i < numSamples; i++)
200 {
201 diff = pIn[i] - pOut[i];
202 diffCrnt = (diff > 0) ? diff : -diff;
203
204 if (diffCrnt > maxDiff)
205 {
206 maxDiff = diffCrnt;
207 }
208 }
209
210 return(maxDiff);
211}
212
223void arm_provide_guard_bits_q31 (q31_t * input_buf,
224 uint32_t blockSize,
225 uint32_t guard_bits)
226{
227 uint32_t i;
228
229 for (i = 0; i < blockSize; i++)
230 {
231 input_buf[i] = input_buf[i] >> guard_bits;
232 }
233}
234
245void arm_provide_guard_bits_q7 (q7_t * input_buf,
246 uint32_t blockSize,
247 uint32_t guard_bits)
248{
249 uint32_t i;
250
251 for (i = 0; i < blockSize; i++)
252 {
253 input_buf[i] = input_buf[i] >> guard_bits;
254 }
255}
256
257
258
267uint32_t arm_calc_guard_bits (uint32_t num_adds)
268{
269 uint32_t i = 1, j = 0;
270
271 if (num_adds == 1)
272 {
273 return (0);
274 }
275
276 while (i < num_adds)
277 {
278 i = i * 2;
279 j++;
280 }
281
282 return (j);
283}
284
293void arm_apply_guard_bits (float32_t *pIn,
294 uint32_t numSamples,
295 uint32_t guard_bits)
296{
297 uint32_t i;
298
299 for (i = 0; i < numSamples; i++)
300 {
301 pIn[i] = pIn[i] * arm_calc_2pow(guard_bits);
302 }
303}
304
310uint32_t arm_calc_2pow(uint32_t numShifts)
311{
312
313 uint32_t i, val = 1;
314
315 for (i = 0; i < numShifts; i++)
316 {
317 val = val * 2;
318 }
319
320 return(val);
321}
322
323
324
334void arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
335{
336 uint32_t i;
337
338 for (i = 0; i < numSamples; i++)
339 {
340 /* 16384.0f corresponds to pow(2, 14) */
341 pOut[i] = (q15_t) (pIn[i] * 16384.0f);
342
343 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
344
345 if (pIn[i] == (float) 2.0)
346 {
347 pOut[i] = 0x7FFF;
348 }
349
350 }
351
352}
353
354
364void arm_float_to_q30 (float *pIn, q31_t * pOut, uint32_t numSamples)
365{
366 uint32_t i;
367
368 for (i = 0; i < numSamples; i++)
369 {
370 /* 1073741824.0f corresponds to pow(2, 30) */
371 pOut[i] = (q31_t) (pIn[i] * 1073741824.0f);
372
373 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
374
375 if (pIn[i] == (float) 2.0)
376 {
377 pOut[i] = 0x7FFFFFFF;
378 }
379 }
380}
381
391void arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
392{
393 uint32_t i;
394
395 for (i = 0; i < numSamples; i++)
396 {
397 /* 1073741824.0f corresponds to pow(2, 30) */
398 pOut[i] = (q31_t) (pIn[i] * 536870912.0f);
399
400 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
401
402 if (pIn[i] == (float) 4.0)
403 {
404 pOut[i] = 0x7FFFFFFF;
405 }
406 }
407}
408
409
419void arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
420{
421 uint32_t i;
422
423 for (i = 0; i < numSamples; i++)
424 {
425 /* 268435456.0f corresponds to pow(2, 28) */
426 pOut[i] = (q31_t) (pIn[i] * 268435456.0f);
427
428 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
429
430 if (pIn[i] == (float) 8.0)
431 {
432 pOut[i] = 0x7FFFFFFF;
433 }
434 }
435}
436
445void arm_clip_f32 (float *pIn, uint32_t numSamples)
446{
447 uint32_t i;
448
449 for (i = 0; i < numSamples; i++)
450 {
451 if (pIn[i] > 1.0f)
452 {
453 pIn[i] = 1.0;
454 }
455 else if ( pIn[i] < -1.0f)
456 {
457 pIn[i] = -1.0;
458 }
459
460 }
461}
462
463
464
465
arm_float_to_q29
void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:391
arm_apply_guard_bits
void arm_apply_guard_bits(float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer.
Definition: project_l0/src/math_helper.c:293
arm_float_to_q30
void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:364
arm_float_to_q14
void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14.
Definition: project_l0/src/math_helper.c:334
arm_float_to_q12_20
void arm_float_to_q12_20(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format.
Definition: project_l0/src/math_helper.c:139
arm_compare_fixed_q31
uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:193
arm_provide_guard_bits_q7
void arm_provide_guard_bits_q7(q7_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:245
arm_calc_guard_bits
uint32_t arm_calc_guard_bits(uint32_t num_adds)
Caluclates number of guard bits.
Definition: project_l0/src/math_helper.c:267
arm_compare_fixed_q15
uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:165
arm_float_to_q28
void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format.
Definition: project_l0/src/math_helper.c:419
arm_clip_f32
void arm_clip_f32(float *pIn, uint32_t numSamples)
Clip the float values to +/- 1.
Definition: project_l0/src/math_helper.c:445
arm_provide_guard_bits_q15
void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:119
arm_calc_2pow
uint32_t arm_calc_2pow(uint32_t numShifts)
Calculates pow(2, numShifts)
Definition: project_l0/src/math_helper.c:310
arm_provide_guard_bits_q31
void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:223
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61


AT32F413 Firmwary Library: fir_filter.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
project_l1/inc/fir_filter.h
Go to the documentation of this file.
1
30/* Define to prevent recursive inclusion -------------------------------------*/
31#ifndef __FIR_FILTER_H
32#define __FIR_FILTER_H
33
34
35
36/* Includes ------------------------------------------------------------------*/
37#include "arm_math.h"
38
39/* Exported types ------------------------------------------------------------*/
40/* Exported constants --------------------------------------------------------*/
41/* Exported macro ------------------------------------------------------------*/
42/* Exported functions ------------------------------------------------------- */
43void arm_fir_init_f32(
44 arm_fir_instance_f32 * S,
45 uint16_t numTaps,
46 const float32_t * pCoeffs,
47 float32_t * pState,
48 uint32_t blockSize);
49
50void arm_fir_f32(
51const arm_fir_instance_f32 * S,
52const float32_t * pSrc,
53float32_t * pDst,
54uint32_t blockSize);
55
56void FIR_lowpass_filter(float32_t * pSrc, float32_t * pDst, uint32_t testlengthsamples);
57
58#endif /* __FIR_FILTER_H */
59
arm_fir_f32
void arm_fir_f32(const arm_fir_instance_f32 *S, const float32_t *pSrc, float32_t *pDst, uint32_t blockSize)
arm_fir_init_f32
void arm_fir_init_f32(arm_fir_instance_f32 *S, uint16_t numTaps, const float32_t *pCoeffs, float32_t *pState, uint32_t blockSize)
Initialization function for the floating-point FIR filter.
Definition: arm_fir_init_f32.c:59
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76


AT32F413 Firmwary Library: math_helper.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
project_l1/inc/math_helper.h
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2013 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8*
9* Title: math_helper.h
10*
11* Description: Prototypes of all helper functions required.
12*
13* Target Processor: Cortex-M4/Cortex-M3
14*
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41
42
43#include "arm_math.h"
44
45#ifndef MATH_HELPER_H
46#define MATH_HELPER_H
47
48float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize);
49void arm_float_to_q12_20(float *pIn, q31_t * pOut, uint32_t numSamples);
50void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits);
51void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits);
52void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples);
53void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples);
54void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples);
55void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples);
56void arm_clip_f32(float *pIn, uint32_t numSamples);
57uint32_t arm_calc_guard_bits(uint32_t num_adds);
58void arm_apply_guard_bits (float32_t * pIn, uint32_t numSamples, uint32_t guard_bits);
59uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t * pOut, uint32_t numSamples);
60uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples);
61uint32_t arm_calc_2pow(uint32_t guard_bits);
62#endif
63
arm_float_to_q29
void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:391
arm_apply_guard_bits
void arm_apply_guard_bits(float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer.
Definition: project_l0/src/math_helper.c:293
arm_float_to_q30
void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l0/src/math_helper.c:364
arm_float_to_q14
void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14.
Definition: project_l0/src/math_helper.c:334
arm_float_to_q12_20
void arm_float_to_q12_20(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format.
Definition: project_l0/src/math_helper.c:139
arm_compare_fixed_q31
uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:193
arm_calc_guard_bits
uint32_t arm_calc_guard_bits(uint32_t num_adds)
Caluclates number of guard bits.
Definition: project_l0/src/math_helper.c:267
arm_compare_fixed_q15
uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l0/src/math_helper.c:165
arm_calc_2pow
uint32_t arm_calc_2pow(uint32_t guard_bits)
Calculates pow(2, numShifts)
Definition: project_l0/src/math_helper.c:310
arm_float_to_q28
void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format.
Definition: project_l0/src/math_helper.c:419
arm_clip_f32
void arm_clip_f32(float *pIn, uint32_t numSamples)
Clip the float values to +/- 1.
Definition: project_l0/src/math_helper.c:445
arm_provide_guard_bits_q15
void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:119
arm_provide_guard_bits_q31
void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l0/src/math_helper.c:223
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61


AT32F413 Firmwary Library: arm_fir_data.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
project_l1/src/arm_fir_data.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0
6*
7* Project: CMSIS DSP Library
8* Title: arm_fir_data.c
9*
10* Description: Data file used for example code
11*
12* Target Processor: Cortex-M4/Cortex-M3/Cortex-M0
13*
14* Redistribution and use in source and binary forms, with or without
15* modification, are permitted provided that the following conditions
16* are met:
17* - Redistributions of source code must retain the above copyright
18* notice, this list of conditions and the following disclaimer.
19* - Redistributions in binary form must reproduce the above copyright
20* notice, this list of conditions and the following disclaimer in
21* the documentation and/or other materials provided with the
22* distribution.
23* - Neither the name of ARM LIMITED nor the names of its contributors
24* may be used to endorse or promote products derived from this
25* software without specific prior written permission.
26*
27* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
28* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
29* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
30* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
31* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
32* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
33* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
34* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
35* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
36* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
37* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
38* POSSIBILITY OF SUCH DAMAGE.
39* -------------------------------------------------------------------- */
40
41#include "at32f413.h"
42#include "arm_math.h"
43
44/* ----------------------------------------------------------------------
45** Test input signal contains 1000Hz + 15000 Hz
46** ------------------------------------------------------------------- */
47
48float32_t testInput_f32_1kHz_15kHz[320] =
49{
50+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
51+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
52+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
53-0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
54-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
55-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
56+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
57+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
58+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
59+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
60-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
61-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
62+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
63+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
64+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
65+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
66-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
67-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
68-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
69+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
70+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
71-0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
72-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
73-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
74+0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
75+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
76+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
77+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
78-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
79-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
80-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
81+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
82+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
83+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
84-0.8660254038f, -0.4619397663f, -1.3194792169f, -1.1827865776f, -0.5000000000f, -1.1827865776f, -1.3194792169f, -0.4619397663f,
85-0.8660254038f, -1.2552931065f, -0.3535533906f, -0.4174197128f, -1.0000000000f, -0.1913417162f, +0.0947343455f, -0.5924659585f,
86-0.0000000000f, +0.5924659585f, -0.0947343455f, +0.1913417162f, +1.0000000000f, +0.4174197128f, +0.3535533906f, +1.2552931065f,
87+0.8660254038f, +0.4619397663f, +1.3194792169f, +1.1827865776f, +0.5000000000f, +1.1827865776f, +1.3194792169f, +0.4619397663f,
88+0.8660254038f, +1.2552931065f, +0.3535533906f, +0.4174197128f, +1.0000000000f, +0.1913417162f, -0.0947343455f, +0.5924659585f,
89+0.0000000000f, -0.5924659585f, +0.0947343455f, -0.1913417162f, -1.0000000000f, -0.4174197128f, -0.3535533906f, -1.2552931065f,
90};
91
92/* ----------------------------------------------------------------------
93** Reference output signal computed with MATLAB
94** ------------------------------------------------------------------- */
95
96float32_t refOutput[320] =
97{
98+0.0000000000f, -0.0010797829f, -0.0007681386f, -0.0001982932f, +0.0000644313f, +0.0020854271f, +0.0036891871f, +0.0015855941f,
99-0.0026280805f, -0.0075907658f, -0.0119390538f, -0.0086665968f, +0.0088981202f, +0.0430539279f, +0.0974468742f, +0.1740405600f,
100+0.2681416601f, +0.3747720089f, +0.4893362230f, +0.6024154672f, +0.7058740791f, +0.7968348987f, +0.8715901940f, +0.9277881093f,
101+0.9682182661f, +0.9934674267f, +1.0012052245f, +0.9925859371f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
102+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
103-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
104-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
105-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
106+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
107+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
108+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
109-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
110-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
111-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
112+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
113+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
114+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, -0.0000000000f, -0.1309866321f,
115-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
116-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
117-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
118+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
119+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
120+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
121-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
122-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
123-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
124+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
125+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
126+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
127-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
128-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
129-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, -0.0000000000f, +0.1309866321f,
130+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
131+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f,
132+0.7085021596f, +0.6100062330f, +0.5012752767f, +0.3834386057f, +0.2592435399f, +0.1309866321f, +0.0000000000f, -0.1309866321f,
133-0.2592435399f, -0.3834386057f, -0.5012752767f, -0.6100062330f, -0.7085021596f, -0.7952493046f, -0.8679010068f, -0.9257026822f,
134-0.9681538347f, -0.9936657199f, -1.0019733630f, -0.9936657199f, -0.9681538347f, -0.9257026822f, -0.8679010068f, -0.7952493046f,
135-0.7085021596f, -0.6100062330f, -0.5012752767f, -0.3834386057f, -0.2592435399f, -0.1309866321f, +0.0000000000f, +0.1309866321f,
136+0.2592435399f, +0.3834386057f, +0.5012752767f, +0.6100062330f, +0.7085021596f, +0.7952493046f, +0.8679010068f, +0.9257026822f,
137+0.9681538347f, +0.9936657199f, +1.0019733630f, +0.9936657199f, +0.9681538347f, +0.9257026822f, +0.8679010068f, +0.7952493046f
138};
139
at32f413.h
at32f413 header file
testInput_f32_1kHz_15kHz
float32_t testInput_f32_1kHz_15kHz[320]
Definition: project_l1/src/arm_fir_data.c:48
refOutput
float32_t refOutput[320]
Definition: project_l1/src/arm_fir_data.c:96


AT32F413 Firmwary Library: math_helper.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
project_l1/src/math_helper.c
Go to the documentation of this file.
1/* ----------------------------------------------------------------------
2* Copyright (C) 2010-2012 ARM Limited. All rights reserved.
3*
4* $Date: 17. January 2013
5* $Revision: V1.4.0 b
6*
7* Project: CMSIS DSP Library
8*
9* Title: math_helper.c
10*
11* Description: Definition of all helper functions required.
12*
13* Target Processor: Cortex-M4/Cortex-M3
14*
15* Redistribution and use in source and binary forms, with or without
16* modification, are permitted provided that the following conditions
17* are met:
18* - Redistributions of source code must retain the above copyright
19* notice, this list of conditions and the following disclaimer.
20* - Redistributions in binary form must reproduce the above copyright
21* notice, this list of conditions and the following disclaimer in
22* the documentation and/or other materials provided with the
23* distribution.
24* - Neither the name of ARM LIMITED nor the names of its contributors
25* may be used to endorse or promote products derived from this
26* software without specific prior written permission.
27*
28* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
29* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
30* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
31* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
32* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
33* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
34* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
35* LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
36* CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
37* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
38* ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
39* POSSIBILITY OF SUCH DAMAGE.
40* -------------------------------------------------------------------- */
41/* ----------------------------------------------------------------------
42* Include standard header files
43* -------------------------------------------------------------------- */
44#include<math.h>
45
46/* ----------------------------------------------------------------------
47* Include project header files
48* -------------------------------------------------------------------- */
49#include "math_helper.h"
50
61float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
62{
63 float EnergySignal = 0.0, EnergyError = 0.0;
64 uint32_t i;
65 float SNR;
66 int temp;
67 int *test;
68
69 for (i = 0; i < buffSize; i++)
70 {
71 /* Checking for a NAN value in pRef array */
72 test = (int *)(&pRef[i]);
73 temp = *test;
74
75 if (temp == 0x7FC00000)
76 {
77 return(0);
78 }
79
80 /* Checking for a NAN value in pTest array */
81 test = (int *)(&pTest[i]);
82 temp = *test;
83
84 if (temp == 0x7FC00000)
85 {
86 return(0);
87 }
88 EnergySignal += pRef[i] * pRef[i];
89 EnergyError += (pRef[i] - pTest[i]) * (pRef[i] - pTest[i]);
90 }
91
92 /* Checking for a NAN value in EnergyError */
93 test = (int *)(&EnergyError);
94 temp = *test;
95
96 if (temp == 0x7FC00000)
97 {
98 return(0);
99 }
100
101
102 SNR = 10 * log10 (EnergySignal / EnergyError);
103
104 return (SNR);
105
106}
107
108
119void arm_provide_guard_bits_q15 (q15_t * input_buf, uint32_t blockSize,
120 uint32_t guard_bits)
121{
122 uint32_t i;
123
124 for (i = 0; i < blockSize; i++)
125 {
126 input_buf[i] = input_buf[i] >> guard_bits;
127 }
128}
129
139void arm_float_to_q12_20(float *pIn, q31_t * pOut, uint32_t numSamples)
140{
141 uint32_t i;
142
143 for (i = 0; i < numSamples; i++)
144 {
145 /* 1048576.0f corresponds to pow(2, 20) */
146 pOut[i] = (q31_t) (pIn[i] * 1048576.0f);
147
148 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
149
150 if (pIn[i] == (float) 1.0)
151 {
152 pOut[i] = 0x000FFFFF;
153 }
154 }
155}
156
165uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
166{
167 uint32_t i;
168 int32_t diff, diffCrnt = 0;
169 uint32_t maxDiff = 0;
170
171 for (i = 0; i < numSamples; i++)
172 {
173 diff = pIn[i] - pOut[i];
174 diffCrnt = (diff > 0) ? diff : -diff;
175
176 if (diffCrnt > maxDiff)
177 {
178 maxDiff = diffCrnt;
179 }
180 }
181
182 return(maxDiff);
183}
184
193uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t * pOut, uint32_t numSamples)
194{
195 uint32_t i;
196 int32_t diff, diffCrnt = 0;
197 uint32_t maxDiff = 0;
198
199 for (i = 0; i < numSamples; i++)
200 {
201 diff = pIn[i] - pOut[i];
202 diffCrnt = (diff > 0) ? diff : -diff;
203
204 if (diffCrnt > maxDiff)
205 {
206 maxDiff = diffCrnt;
207 }
208 }
209
210 return(maxDiff);
211}
212
223void arm_provide_guard_bits_q31 (q31_t * input_buf,
224 uint32_t blockSize,
225 uint32_t guard_bits)
226{
227 uint32_t i;
228
229 for (i = 0; i < blockSize; i++)
230 {
231 input_buf[i] = input_buf[i] >> guard_bits;
232 }
233}
234
245void arm_provide_guard_bits_q7 (q7_t * input_buf,
246 uint32_t blockSize,
247 uint32_t guard_bits)
248{
249 uint32_t i;
250
251 for (i = 0; i < blockSize; i++)
252 {
253 input_buf[i] = input_buf[i] >> guard_bits;
254 }
255}
256
257
258
267uint32_t arm_calc_guard_bits (uint32_t num_adds)
268{
269 uint32_t i = 1, j = 0;
270
271 if (num_adds == 1)
272 {
273 return (0);
274 }
275
276 while (i < num_adds)
277 {
278 i = i * 2;
279 j++;
280 }
281
282 return (j);
283}
284
293void arm_apply_guard_bits (float32_t *pIn,
294 uint32_t numSamples,
295 uint32_t guard_bits)
296{
297 uint32_t i;
298
299 for (i = 0; i < numSamples; i++)
300 {
301 pIn[i] = pIn[i] * arm_calc_2pow(guard_bits);
302 }
303}
304
310uint32_t arm_calc_2pow(uint32_t numShifts)
311{
312
313 uint32_t i, val = 1;
314
315 for (i = 0; i < numShifts; i++)
316 {
317 val = val * 2;
318 }
319
320 return(val);
321}
322
323
324
334void arm_float_to_q14 (float *pIn, q15_t *pOut, uint32_t numSamples)
335{
336 uint32_t i;
337
338 for (i = 0; i < numSamples; i++)
339 {
340 /* 16384.0f corresponds to pow(2, 14) */
341 pOut[i] = (q15_t) (pIn[i] * 16384.0f);
342
343 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
344
345 if (pIn[i] == (float) 2.0)
346 {
347 pOut[i] = 0x7FFF;
348 }
349
350 }
351
352}
353
354
364void arm_float_to_q30 (float *pIn, q31_t * pOut, uint32_t numSamples)
365{
366 uint32_t i;
367
368 for (i = 0; i < numSamples; i++)
369 {
370 /* 1073741824.0f corresponds to pow(2, 30) */
371 pOut[i] = (q31_t) (pIn[i] * 1073741824.0f);
372
373 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
374
375 if (pIn[i] == (float) 2.0)
376 {
377 pOut[i] = 0x7FFFFFFF;
378 }
379 }
380}
381
391void arm_float_to_q29 (float *pIn, q31_t *pOut, uint32_t numSamples)
392{
393 uint32_t i;
394
395 for (i = 0; i < numSamples; i++)
396 {
397 /* 1073741824.0f corresponds to pow(2, 30) */
398 pOut[i] = (q31_t) (pIn[i] * 536870912.0f);
399
400 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
401
402 if (pIn[i] == (float) 4.0)
403 {
404 pOut[i] = 0x7FFFFFFF;
405 }
406 }
407}
408
409
419void arm_float_to_q28 (float *pIn, q31_t *pOut, uint32_t numSamples)
420{
421 uint32_t i;
422
423 for (i = 0; i < numSamples; i++)
424 {
425 /* 268435456.0f corresponds to pow(2, 28) */
426 pOut[i] = (q31_t) (pIn[i] * 268435456.0f);
427
428 pOut[i] += pIn[i] > 0 ? 0.5 : -0.5;
429
430 if (pIn[i] == (float) 8.0)
431 {
432 pOut[i] = 0x7FFFFFFF;
433 }
434 }
435}
436
445void arm_clip_f32 (float *pIn, uint32_t numSamples)
446{
447 uint32_t i;
448
449 for (i = 0; i < numSamples; i++)
450 {
451 if (pIn[i] > 1.0f)
452 {
453 pIn[i] = 1.0;
454 }
455 else if ( pIn[i] < -1.0f)
456 {
457 pIn[i] = -1.0;
458 }
459
460 }
461}
462
463
464
465
arm_float_to_q29
void arm_float_to_q29(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l1/src/math_helper.c:391
arm_apply_guard_bits
void arm_apply_guard_bits(float32_t *pIn, uint32_t numSamples, uint32_t guard_bits)
Apply guard bits to buffer.
Definition: project_l1/src/math_helper.c:293
arm_float_to_q30
void arm_float_to_q30(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q30 format.
Definition: project_l1/src/math_helper.c:364
arm_float_to_q14
void arm_float_to_q14(float *pIn, q15_t *pOut, uint32_t numSamples)
Converts float to fixed q14.
Definition: project_l1/src/math_helper.c:334
arm_float_to_q12_20
void arm_float_to_q12_20(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed in q12.20 format.
Definition: project_l1/src/math_helper.c:139
arm_compare_fixed_q31
uint32_t arm_compare_fixed_q31(q31_t *pIn, q31_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l1/src/math_helper.c:193
arm_provide_guard_bits_q7
void arm_provide_guard_bits_q7(q7_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l1/src/math_helper.c:245
arm_calc_guard_bits
uint32_t arm_calc_guard_bits(uint32_t num_adds)
Caluclates number of guard bits.
Definition: project_l1/src/math_helper.c:267
arm_compare_fixed_q15
uint32_t arm_compare_fixed_q15(q15_t *pIn, q15_t *pOut, uint32_t numSamples)
Compare MATLAB Reference Output and ARM Test output.
Definition: project_l1/src/math_helper.c:165
arm_float_to_q28
void arm_float_to_q28(float *pIn, q31_t *pOut, uint32_t numSamples)
Converts float to fixed q28 format.
Definition: project_l1/src/math_helper.c:419
arm_clip_f32
void arm_clip_f32(float *pIn, uint32_t numSamples)
Clip the float values to +/- 1.
Definition: project_l1/src/math_helper.c:445
arm_provide_guard_bits_q15
void arm_provide_guard_bits_q15(q15_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l1/src/math_helper.c:119
arm_calc_2pow
uint32_t arm_calc_2pow(uint32_t numShifts)
Calculates pow(2, numShifts)
Definition: project_l1/src/math_helper.c:310
arm_provide_guard_bits_q31
void arm_provide_guard_bits_q31(q31_t *input_buf, uint32_t blockSize, uint32_t guard_bits)
Provide guard bits for Input buffer.
Definition: project_l1/src/math_helper.c:223
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l1/src/math_helper.c:61


AT32F413 Firmwary Library: random.c Source File

  • utilities
  • at32f413_gen_random_number_demo
  • src
random.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "random.h"
29#include "stdio.h"
30#include <stdlib.h>
31
40/* define at32 mcu uid address */
41#define DEVICE_ID_ADDR1 0x1FFFF7E8
42
48int get_uid_for_seed (void)
49{
50 uint32_t id[3] = {0};
51 uint32_t uid_one_word;
52
53 /* get uid */
54 id[0] = *(int*)DEVICE_ID_ADDR1;
55 id[2] = *(int*)(DEVICE_ID_ADDR1+8);
56 uid_one_word=id[0]&0x7fffffff+((id[2]&(~0x7fffffff))<<16);
57 return uid_one_word;
58}
59
65#if ENABLE_RTC_ASSEED
66void rtc_init_for_seed (void)
67{
68 /* enable pwc and bpr clocks */
69 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
70 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
71
72 /* allow access to bpr domain */
73 pwc_battery_powered_domain_access(TRUE);
74
75 if (bpr_data_read(BPR_DATA1) != 0x5051)
76 {
77 /* reset bpr domain */
78 bpr_reset();
79
80 /* enable the lext osc */
81 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
82 /* wait lext is ready */
83 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET);
84 /* select the rtc clock source */
85 crm_rtc_clock_select(CRM_RTC_CLOCK_LEXT);
86
87 /* enable rtc clock */
88 crm_rtc_clock_enable(TRUE);
89
90 /* wait for rtc registers update */
91 rtc_wait_update_finish();
92
93 /* wait for the register write to complete */
94 rtc_wait_config_finish();
95
96 /* set rtc divider: set rtc period to 1sec */
97 rtc_divider_set(32767);
98
99 /* wait for the register write to complete */
100 rtc_wait_config_finish();
101
102 /* writes data to bpr register */
103 bpr_data_write(BPR_DATA1, 0x5051);
104 }
105 else
106 {
107 /* wait for rtc registers update */
108 rtc_wait_update_finish();
109
110 /* wait for the register write to complete */
111 rtc_wait_config_finish();
112 }
113}
114
115#endif
116
122void randnum_test( void)
123{
124#if ENABLE_RTC_ASSEED
125 rtc_init_for_seed();
126
127 /* set uid and rtc as seed for random */
128 srand(rtc_counter_get()+get_uid_for_seed());
129#else
130 /* set only uid as seed for random */
131 srand(get_uid_for_seed());
132#endif
133
134 while(1)
135 {
136 delay_ms(500);
137 printf("%d\r\n",rand());
138 }
139}
140
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:49
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:116
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:133
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:68
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:376
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:386
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:140
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f413_crm.h:297
CRM_RTC_CLOCK_LEXT
@ CRM_RTC_CLOCK_LEXT
Definition: at32f413_crm.h:374
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f413_crm.h:58
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
get_uid_for_seed
int get_uid_for_seed(void)
get uid value as seed
Definition: random.c:48
DEVICE_ID_ADDR1
#define DEVICE_ID_ADDR1
Definition: random.c:41
randnum_test
void randnum_test(void)
enable rtc as seed
Definition: random.c:122
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:61
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:197
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:67
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:207
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:82
random.h
at32f413 random header file


AT32F413 Firmwary Library: random.h Source File

  • utilities
  • at32f413_gen_random_number_demo
  • inc
random.h
Go to the documentation of this file.
1
27#ifndef __RANDOM_H
28#define __RANDOM_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413.h"
35
48/* this define rtc seed for random number gen,*/
49#define ENABLE_RTC_ASSEED (1)
50
59void randnum_test( void);
60
73#ifdef __cplusplus
74}
75#endif
76
77#endif
at32f413.h
at32f413 header file
randnum_test
void randnum_test(void)
enable rtc as seed
Definition: random.c:122


AT32F413 Firmwary Library: rtc.c Source File

  • rtc
  • calendar
  • src
rtc.c
Go to the documentation of this file.
1
27#include "rtc.h"
28
37 calendar_type calendar;
38
39/* monthly correction data sheet */
40const uint8_t table_week[12] = {0, 3, 3, 6, 1, 4, 6, 2, 5, 0, 3, 5};
41
42/* monmonth data table of common year */
43const uint8_t mon_table[12] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
44
51uint8_t rtc_init(calendar_type *calendar)
52{
53 /* enable pwc and bpr clocks */
54 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
55 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
56
57 /* enable the battery-powered domain write operations */
58 pwc_battery_powered_domain_access(TRUE);
59
60 /* check if rtc is initialized */
61 if(bpr_data_read(BPR_DATA1) != 0x1234)
62 {
63 /* reset battery-powered domain register */
64 bpr_reset();
65
66 /* enable the lext osc */
67 crm_clock_source_enable(CRM_CLOCK_SOURCE_LEXT, TRUE);
68 /* wait lext is ready */
69 while(crm_flag_get(CRM_LEXT_STABLE_FLAG) == RESET);
70 /* select the rtc clock source */
71 crm_rtc_clock_select(CRM_RTC_CLOCK_LEXT);
72
73 /* enable rtc clock */
74 crm_rtc_clock_enable(TRUE);
75
76 /* wait for rtc registers update */
77 rtc_wait_update_finish();
78
79 /* wait for the register write to complete */
80 rtc_wait_config_finish();
81
82 /* set rtc divider: set rtc period to 1sec */
83 rtc_divider_set(32767);
84
85 /* wait for the register write to complete */
86 rtc_wait_config_finish();
87
88 /* set time */
89 rtc_time_set(calendar);
90
91 /* writes data to bpr register */
92 bpr_data_write(BPR_DATA1, 0x1234);
93
94 return 1;
95 }
96 else
97 {
98 /* wait for rtc registers update */
99 rtc_wait_update_finish();
100
101 /* wait for the register write to complete */
102 rtc_wait_config_finish();
103
104 return 0;
105 }
106}
107
117uint8_t is_leap_year(uint16_t year)
118{
119 if(year % 4 == 0)
120 {
121 if(year % 100 == 0)
122 {
123 if(year % 400 == 0)
124 {
125 return 1;
126 }
127 else
128 {
129 return 0;
130 }
131 }
132 else
133 {
134 return 1;
135 }
136 }
137 else
138 {
139 return 0;
140 }
141}
142
151uint8_t rtc_time_set(calendar_type *calendar)
152{
153 uint32_t t;
154 uint32_t seccount = 0;
155
156 if(calendar->year < 1970 || calendar->year > 2099)
157 {
158 return 1;
159 }
160
161 for(t = 1970; t < calendar->year; t++)
162 {
163 if(is_leap_year(t))
164 {
165 seccount += 31622400;
166 }
167 else
168 {
169 seccount += 31536000;
170 }
171 }
172
173 calendar->month -= 1;
174
175 for(t = 0; t < calendar->month; t++)
176 {
177 seccount += (uint8_t)mon_table[t] * 86400;
178
179 if(is_leap_year(calendar->year) && t == 1)
180 {
181 seccount += 86400;
182 }
183 }
184
185 seccount += (uint8_t)(calendar->date - 1) * 86400;
186
187 seccount += (uint8_t)calendar->hour * 3600;
188
189 seccount += (uint8_t)calendar->min * 60;
190
191 seccount += calendar->sec;
192
193 /* enable pwc and bpr clocks */
194 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
195 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
196
197 /* enable write access to bpr domain */
198 pwc_battery_powered_domain_access(TRUE);
199
200 /* set the rtc counter value */
201 rtc_counter_set(seccount);
202
203 /* wait for the register write to complete */
204 rtc_wait_config_finish();
205
206 return 0;
207}
208
217uint8_t rtc_alarm_clock_set(calendar_type *calendar)
218{
219 uint16_t t;
220 uint32_t seccount = 0;
221
222 if(calendar->year < 1970 || calendar->year > 2099)
223 {
224 return 1;
225 }
226
227 for(t = 1970; t < calendar->year; t++)
228 {
229 if(is_leap_year(t))
230 {
231 seccount += 31622400;
232 }
233 else
234 {
235 seccount += 31536000;
236 }
237 }
238
239 calendar->month -= 1;
240
241 for(t = 0; t < calendar->month; t++)
242 {
243 seccount += (uint8_t)mon_table[t] * 86400;
244
245 if(is_leap_year(calendar->year) && t == 1)
246 {
247 seccount += 86400;
248 }
249 }
250
251 seccount += (uint8_t)(calendar->date - 1) * 86400;
252 seccount += (uint8_t)calendar->hour * 3600;
253 seccount += (uint8_t)calendar->min * 60;
254 seccount += calendar->sec;
255
256 /* enable pwc and bpr clocks */
257 crm_periph_clock_enable(CRM_PWC_PERIPH_CLOCK, TRUE);
258 crm_periph_clock_enable(CRM_BPR_PERIPH_CLOCK, TRUE);
259
260 /* enable write access to bpr domain */
261 pwc_battery_powered_domain_access(TRUE);
262
263 /* set the rtc counter value */
264 rtc_alarm_set(seccount);
265
266 /* wait for the register write to complete */
267 rtc_wait_config_finish();
268
269 return 0;
270}
271
279uint8_t rtc_week_get(uint16_t year, uint8_t month, uint8_t day)
280{
281 uint16_t temp2;
282 uint8_t yearh, yearl;
283
284 yearh = year / 100;
285 yearl = year % 100;
286
287 if(yearh > 19)
288 {
289 yearl += 100;
290 }
291
292 temp2 = yearl + yearl / 4;
293 temp2 = temp2 % 7;
294 temp2 = temp2 + day + table_week[month - 1];
295
296 if(yearl % 4 == 0 && month < 3)
297 {
298 temp2--;
299 }
300
301 return(temp2 % 7);
302}
303
309void rtc_time_get(void)
310{
311 static uint16_t daycnt = 0;
312 uint32_t timecount = 0;
313 uint32_t temp = 0;
314 uint32_t temp1 = 0;
315
316 timecount = rtc_counter_get();
317 temp = timecount / 86400;
318
319 if(daycnt != temp)
320 {
321 daycnt = temp;
322 temp1 = 1970;
323
324 while(temp >= 365)
325 {
326 if(is_leap_year(temp1))
327 {
328 if(temp >= 366)
329 {
330 temp -= 366;
331 }
332 else
333 {
334 temp1++;
335 break;
336 }
337 }
338 else
339 {
340 temp -= 365;
341 }
342
343 temp1++;
344 }
345
346 calendar.year = temp1;
347 temp1 = 0;
348
349 while(temp >= 28)
350 {
351 if(is_leap_year(calendar.year) && temp1 == 1)
352 {
353 if(temp >= 29)
354 {
355 temp -= 29;
356 }
357 else
358 {
359 break;
360 }
361 }
362 else
363 {
364 if(temp >= mon_table[temp1])
365 {
366 temp -= mon_table[temp1];
367 }
368 else
369 {
370 break;
371 }
372 }
373
374 temp1++;
375 }
376
377 calendar.month = temp1 + 1;
378 calendar.date = temp + 1;
379 }
380
381 temp = timecount % 86400;
382 calendar.hour = temp / 3600;
383 calendar.min = (temp % 3600) / 60;
384 calendar.sec = (temp % 3600) % 60;
385 calendar.week = rtc_week_get(calendar.year, calendar.month, calendar.date);
386}
387
rtc_time_get
void rtc_time_get(void)
get current time.
Definition: rtc.c:309
rtc_init
uint8_t rtc_init(calendar_type *calendar)
rtc peripheral initialization.
Definition: rtc.c:51
calendar
calendar_type calendar
Definition: rtc.c:37
mon_table
const uint8_t mon_table[12]
Definition: rtc.c:43
rtc_week_get
uint8_t rtc_week_get(uint16_t year, uint8_t month, uint8_t day)
get current week by input leap year\mouth\day.
Definition: rtc.c:279
rtc_time_set
uint8_t rtc_time_set(calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:151
rtc_alarm_clock_set
uint8_t rtc_alarm_clock_set(calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:217
table_week
const uint8_t table_week[12]
Definition: rtc.c:40
is_leap_year
uint8_t is_leap_year(uint16_t year)
judeg the leap year or common year.
Definition: rtc.c:117
bpr_reset
void bpr_reset(void)
bpr reset by crm reset register
Definition: at32f413_bpr.c:49
bpr_data_read
uint16_t bpr_data_read(bpr_data_type bpr_data)
read bpr bpr data
Definition: at32f413_bpr.c:116
bpr_data_write
void bpr_data_write(bpr_data_type bpr_data, uint16_t data_value)
write bpr data
Definition: at32f413_bpr.c:133
BPR_DATA1
@ BPR_DATA1
Definition: at32f413_bpr.h:68
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_rtc_clock_select
void crm_rtc_clock_select(crm_rtc_clock_type value)
select rtc clock
Definition: at32f413_crm.c:376
crm_rtc_clock_enable
void crm_rtc_clock_enable(confirm_state new_state)
enable or disable rtc
Definition: at32f413_crm.c:386
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_PWC_PERIPH_CLOCK
@ CRM_PWC_PERIPH_CLOCK
Definition: at32f413_crm.h:141
CRM_BPR_PERIPH_CLOCK
@ CRM_BPR_PERIPH_CLOCK
Definition: at32f413_crm.h:140
CRM_CLOCK_SOURCE_LEXT
@ CRM_CLOCK_SOURCE_LEXT
Definition: at32f413_crm.h:297
CRM_RTC_CLOCK_LEXT
@ CRM_RTC_CLOCK_LEXT
Definition: at32f413_crm.h:374
CRM_LEXT_STABLE_FLAG
#define CRM_LEXT_STABLE_FLAG
Definition: at32f413_crm.h:58
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
pwc_battery_powered_domain_access
void pwc_battery_powered_domain_access(confirm_state new_state)
enable or disable access to the battery powered domain.
Definition: at32f413_pwc.c:61
rtc_alarm_set
void rtc_alarm_set(uint32_t alarm_value)
rtc alarm value set
Definition: at32f413_rtc.c:115
rtc_wait_config_finish
void rtc_wait_config_finish(void)
rtc wait configuration finish
Definition: at32f413_rtc.c:197
rtc_counter_get
uint32_t rtc_counter_get(void)
rtc counter get
Definition: at32f413_rtc.c:67
rtc_wait_update_finish
void rtc_wait_update_finish(void)
rtc wait update finish
Definition: at32f413_rtc.c:207
rtc_counter_set
void rtc_counter_set(uint32_t counter_value)
rtc counter set
Definition: at32f413_rtc.c:49
rtc_divider_set
void rtc_divider_set(uint32_t div_value)
rtc divider set
Definition: at32f413_rtc.c:82
rtc.h
this file provides template for calendar api.
calendar_type
Definition: rtc.h:49
calendar_type::hour
__IO uint8_t hour
Definition: rtc.h:53
calendar_type::month
__IO uint8_t month
Definition: rtc.h:51
calendar_type::sec
__IO uint8_t sec
Definition: rtc.h:55
calendar_type::week
__IO uint8_t week
Definition: rtc.h:56
calendar_type::year
__IO uint16_t year
Definition: rtc.h:50
calendar_type::min
__IO uint8_t min
Definition: rtc.h:54
calendar_type::date
__IO uint8_t date
Definition: rtc.h:52


AT32F413 Firmwary Library: rtc.h Source File

  • rtc
  • calendar
  • inc
rtc.h
Go to the documentation of this file.
1
27#ifndef __RTC_H
28#define __RTC_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413.h"
35
48typedef struct
49{
50 __IO uint16_t year;
51 __IO uint8_t month;
52 __IO uint8_t date;
53 __IO uint8_t hour;
54 __IO uint8_t min;
55 __IO uint8_t sec;
56 __IO uint8_t week;
57} calendar_type;
58
63extern calendar_type calendar;
64
69uint8_t rtc_init (calendar_type *calendar);
70uint8_t rtc_time_set (calendar_type *calendar);
71uint8_t rtc_alarm_clock_set (calendar_type *calendar);
72void rtc_time_get (void);
73
86#ifdef __cplusplus
87}
88#endif
89
90#endif
at32f413.h
at32f413 header file
calendar
calendar_type calendar
Definition: rtc.c:37
rtc_time_get
void rtc_time_get(void)
get current time.
Definition: rtc.c:309
rtc_init
uint8_t rtc_init(calendar_type *calendar)
rtc peripheral initialization.
Definition: rtc.c:51
rtc_time_set
uint8_t rtc_time_set(calendar_type *calendar)
set time. convert the input clock to a second. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:151
rtc_alarm_clock_set
uint8_t rtc_alarm_clock_set(calendar_type *calendar)
set rtc alarm clock. the time basic : 1970.1.1 legitimate year: 1970 ~ 2099
Definition: rtc.c:217
calendar_type
Definition: rtc.h:49
calendar_type::hour
__IO uint8_t hour
Definition: rtc.h:53
calendar_type::month
__IO uint8_t month
Definition: rtc.h:51
calendar_type::sec
__IO uint8_t sec
Definition: rtc.h:55
calendar_type::week
__IO uint8_t week
Definition: rtc.h:56
calendar_type::year
__IO uint16_t year
Definition: rtc.h:50
calendar_type::min
__IO uint8_t min
Definition: rtc.h:54
calendar_type::date
__IO uint8_t date
Definition: rtc.h:52


AT32F413 Firmwary Library: run_in_spim.c Source File

  • flash
  • run_in_spim
  • src
run_in_spim.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "run_in_spim.h"
29
30
45void spim_run(void)
46{
47 while(1)
48 {
49 /* toggle led */
50 at32_led_toggle(LED2);
51 delay_ms(100);
52 at32_led_toggle(LED3);
53 delay_ms(100);
54 at32_led_toggle(LED4);
55 delay_ms(100);
56 }
57}
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
spim_run
void spim_run(void)
check the led toggle in spim
Definition: run_in_spim.c:45
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
run_in_spim.h
run_in_spim header file


AT32F413 Firmwary Library: run_in_spim.h Source File

  • flash
  • run_in_spim
  • inc
run_in_spim.h
Go to the documentation of this file.
1
27/* Define to prevent recursive inclusion -------------------------------------*/
28#ifndef __RUN_IN_SPIM_H
29#define __RUN_IN_SPIM_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
44void spim_run(void);
45
58#ifdef __cplusplus
59}
60#endif
61
62#endif /* __RUN_IN_SPIM_H */
63
spim_run
void spim_run(void)
check the led toggle in spim
Definition: run_in_spim.c:45


AT32F413 Firmwary Library: at32_sdio.h Source File

  • sdio
  • sd_mmc_card
  • inc
sd_mmc_card/inc/at32_sdio.h
Go to the documentation of this file.
1
28/* define to prevent recursive inclusion -------------------------------------*/
29#ifndef __AT32_SDIO_H
30#define __AT32_SDIO_H
31
32#ifdef __cplusplus
33extern "C" {
34#endif
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
51#define SDIOx SDIO1
52
64typedef enum
65{
66 SD_TRANSFER_POLLING_MODE = 0,
67 SD_TRANSFER_DMA_MODE = 1
68} sd_data_transfer_mode_type;
69
73typedef enum
74{
75 /* sdio specific error defines ------------------------------------------*/
76 SD_CMD_FAIL = 1,
77 SD_DATA_FAIL = 2,
78 SD_CMD_RSP_TIMEOUT = 3,
79 SD_DATA_TIMEOUT = 4,
80 SD_TX_UNDERRUN = 5,
81 SD_RX_OVERRUN = 6,
82 SD_START_BIT_ERR = 7,
83 SD_CMD_OUT_OF_RANGE = 8,
84 SD_ADDR_MISALIGNED = 9,
85 SD_BLK_LEN_ERR = 10,
86 SD_ERASE_SEQ_ERR = 11,
87 SD_INVALID_ERASE_PARAM = 12,
88 SD_WR_PROTECT_VIOLATION = 13,
89 SD_LOCK_UNLOCK_ERROR = 14,
90 SD_CMD_CRC_ERROR = 15,
91 SD_ILLEGAL_CMD = 16,
92 SD_CARD_ECC_ERROR = 17,
93 SD_CARD_CONTROLLER_ERR = 18,
94 SD_GENERAL_UNKNOWN_ERROR = 19,
95 SD_STREAM_RD_UNDERRUN = 20,
96 SD_STREAM_WR_OVERRUN = 21,
97 SD_CID_CSD_OVERWRITE = 22,
98 SD_WP_ERASE_SKIP = 23,
99 SD_CARD_ECC_DISABLED = 24,
100 SD_ERASE_RESET = 25,
101 SD_AKE_SEQ_ERROR = 26,
102 SD_INVALID_VOLTRANGE = 27,
103 SD_ADDR_OUT_OF_RANGE = 28,
104 SD_SWITCH_ERROR = 29,
105 SD_SDIO_DISABLED = 30,
106 SD_SDIO_FUNC_BUSY = 31,
107 SD_SDIO_FUNC_ERROR = 32,
108 SD_SDIO_UNKNOWN_FUNC = 33,
110 /* standard error defines --------------------------------------------*/
111 SD_INTERNAL_ERROR,
112 SD_NOT_CONFIGURED,
113 SD_REQ_PENDING,
114 SD_REQ_NOT_APPLICABLE,
115 SD_INVALID_PARAMETER,
116 SD_UNSUPPORTED_FEATURE,
117 SD_UNSUPPORTED_HW,
118 SD_ERROR,
119 SD_OK = 0
120} sd_error_status_type;
121
125typedef struct
126{
127 uint8_t csd_struct;
128 uint8_t spec_version;
129 uint8_t reserved1;
130 uint8_t taac;
131 uint8_t nsac;
132 uint8_t max_bus_clk_freq;
133 uint16_t card_cmd_classes;
134 uint8_t max_read_blk_length;
135 uint8_t part_blk_read;
136 uint8_t write_blk_misalign;
137 uint8_t read_blk_misalign;
138 uint8_t dsr_implemented;
139 uint8_t reserved2;
140 uint32_t device_size;
141 uint8_t max_read_current_vdd_min;
142 uint8_t max_read_current_vdd_max;
143 uint8_t max_write_current_vdd_min;
144 uint8_t max_write_current_vdd_max;
145 uint8_t device_size_mult;
146 uint8_t erase_group_size;
147 uint8_t erase_group_size_mult;
148 uint8_t write_protect_group_size;
149 uint8_t write_protect_group_enable;
150 uint8_t manufacturer_default_ecc;
151 uint8_t write_speed_factor;
152 uint8_t max_write_blk_length;
153 uint8_t part_blk_write;
154 uint8_t reserved3;
155 uint8_t content_protect_app;
156 uint8_t file_format_group;
157 uint8_t copy_flag;
158 uint8_t permanent_write_protect;
159 uint8_t temp_write_protect;
160 uint8_t file_formart;
161 uint8_t ecc_code;
162 uint8_t csd_crc;
163 uint8_t reserved4;
164} sd_csd_struct_type;
165
169typedef struct
170{
171 uint8_t manufacturer_id;
172 uint16_t oem_app_id;
173 uint32_t product_name1;
174 uint8_t product_name2;
175 uint8_t product_reversion;
176 uint32_t product_sn;
177 uint8_t reserved1;
178 uint16_t manufact_date;
179 uint8_t cid_crc;
180 uint8_t reserved2;
181} sd_cid_struct_type;
182
186typedef enum
187{
188 SD_CARD_READY = ((uint32_t)0x00000001),
189 SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002),
190 SD_CARD_STANDBY = ((uint32_t)0x00000003),
191 SD_CARD_TRANSFER = ((uint32_t)0x00000004),
192 SD_CARD_SENDING = ((uint32_t)0x00000005),
193 SD_CARD_RECEIVING = ((uint32_t)0x00000006),
194 SD_CARD_PROGRAMMING = ((uint32_t)0x00000007),
195 SD_CARD_DISCONNECTED = ((uint32_t)0x00000008),
196 SD_CARD_ERROR = ((uint32_t)0x000000FF)
197} sd_card_state_type;
198
202typedef enum
203{
204 SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0,
205 SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1,
206 SDIO_HIGH_CAPACITY_SD_CARD = 2,
207 SDIO_MULTIMEDIA_CARD = 3,
208 SDIO_SECURE_DIGITAL_IO_CARD = 4,
209 SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5,
210 SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6,
211 SDIO_HIGH_CAPACITY_MMC_CARD = 7,
212 SDIO_SDIO_CARD = 8
213} sd_memory_card_type;
214
218typedef struct
219{
220 uint32_t sd_spec :4; /* [59:56] */
221 uint32_t scr_structure :4; /* [60:63] */
222 uint32_t sd_bus_width :4; /* [51:48] */
223 uint32_t sd_security :3; /* [52:54] */
224 uint32_t data_stat_after_erase :1; /* [55:55] */
225 uint32_t reserved1 :7; /* [46:40] */
226 uint32_t sd_spec3 :1; /* [47:47] */
227 uint32_t cmd20_support :1; /* [32:32] */
228 uint32_t cmd23_support :1; /* [33:33] */
229 uint32_t reserverd2 :6; /* [34:39] */
230 uint32_t reserverd3; /* [31:0] */
231} sd_scr_struct_type;
232
236typedef struct
237{
238 sd_csd_struct_type sd_csd_reg;
239 sd_cid_struct_type sd_cid_reg;
240 sd_scr_struct_type sd_scr_reg;
241 long long card_capacity;
242 uint32_t card_blk_size;
243 uint16_t rca;
244 uint8_t card_type;
245} sd_card_info_struct_type;
246
258#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)
259#define SD_CMD_SEND_OP_COND ((uint8_t)1)
260#define SD_CMD_ALL_SEND_CID ((uint8_t)2)
261#define SD_CMD_SET_REL_ADDR ((uint8_t)3)
262#define SD_CMD_SET_DSR ((uint8_t)4)
263#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
264#define SD_CMD_HS_SWITCH ((uint8_t)6)
265#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
266#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
267#define SD_CMD_SEND_CSD ((uint8_t)9)
268#define SD_CMD_SEND_CID ((uint8_t)10)
269#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
270#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
271#define SD_CMD_SEND_STATUS ((uint8_t)13)
272#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
273#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
274#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)
275#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
276#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
277#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
278#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
279#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
280#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
281#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
282#define SD_CMD_PROG_CID ((uint8_t)26)
283#define SD_CMD_PROG_CSD ((uint8_t)27)
284#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)
285#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
286#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
287#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
288#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
289#define SD_CMD_ERASE_GRP_START ((uint8_t)35)
290#define SD_CMD_ERASE_GRP_END ((uint8_t)36)
291#define SD_CMD_ERASE ((uint8_t)38)
292#define SD_CMD_FAST_IO ((uint8_t)39)
293#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)
294#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)
295#define SD_CMD_APP_CMD ((uint8_t)55)
296#define SD_CMD_GEN_CMD ((uint8_t)56)
297#define SD_CMD_NO_CMD ((uint8_t)64)
298
303#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
304#define SD_CMD_SD_APP_STAUS ((uint8_t)13)
305#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
306#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)
307#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
308#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
309#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
310#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
311
316#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
317#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)
318#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
319#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
320#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
321#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
322#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
323#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
324#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
325#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
326#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
327
339#define NULL 0
340#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
341#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
342#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
343#define SDIO_FIFO_Address ((uint32_t)0x40018080)
344
356#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
357#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
358#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
359#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
360#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
361#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
362#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
363#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
364#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
365#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
366#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
367#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
368#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
369#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
370#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
371#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
372#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
373#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
374#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)
375#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
376#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
377
381#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
382#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
383#define SD_R5_ERROR ((uint32_t)0x00000800)
384
388#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
389#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
390#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
391#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
392#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)
393#define SD_STD_CAPACITY ((uint32_t)0x00000000)
394#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)
395#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
396#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
397#define SD_ALLZERO ((uint32_t)0x00000000)
398#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
399#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
400#define SD_CARD_LOCKED ((uint32_t)0x02000000)
401#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
402#define SD_CARD_RECEIVING ((uint32_t)0x00000006)
403#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
404#define SD_0TO7BITS ((uint32_t)0x000000FF)
405#define SD_8TO15BITS ((uint32_t)0x0000FF00)
406#define SD_16TO23BITS ((uint32_t)0x00FF0000)
407#define SD_24TO31BITS ((uint32_t)0xFF000000)
408#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
409#define SD_HALFFIFO ((uint32_t)0x00000008)
410#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)
411
423#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
424#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
425#define SD_CCCC_ERASE ((uint32_t)0x00000020)
426
438#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)
439
451#define EXT_CSD_Command_set 0x0
452#define EXT_CSD_Set_bit 0x1
453#define EXT_CSD_Clear_byte 0x2
454#define EXT_CSD_Write_byte 0x3
455
456#define EXT_CSD_CMD_SET_NORMAL (1<<0)
457#define EXT_CSD_CMD_SET_SECURE (1<<1)
458#define EXT_CSD_CMD_SET_CPSECURE (1<<2)
459
463#define EXT_CSD_BUS_WIDTH 183
464#define EXT_CSD_HS_TIMING 185
465
474#define SDIO_INTR_STS_WRITE_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
475 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
476#define SDIO_INTR_STS_READ_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
477 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
482extern sd_card_info_struct_type sd_card_info;
483
488/* sd exported functions ----------------------------------------*/
489 sd_error_status_type sd_init(void);
490void sdio_clock_set(uint32_t clkdiv);
491 sd_error_status_type sd_power_on(void);
492 sd_error_status_type sd_power_off(void);
493 sd_error_status_type sd_card_init(void);
494 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info);
495 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode);
496 sd_error_status_type sd_device_mode_set(uint32_t mode);
497 sd_error_status_type sd_deselect_select(uint32_t addr);
498 sd_error_status_type sd_status_send(uint32_t *p_card_status);
499 sd_card_state_type sd_state_get(void);
500 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks);
501 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size);
502 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
503 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size);
504 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
505 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len);
506 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len);
507 sd_error_status_type sd_irq_service(void);
508void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir);
509
522#ifdef __cplusplus
523}
524#endif
525
526#endif /* __AT32_SDIO_H */
at32f413.h
at32f413 header file
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:48
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:216
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:139
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: sd_mmc_card/src/at32_sdio.c:396
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: sd_mmc_card/src/at32_sdio.c:1782
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: sd_mmc_card/src/at32_sdio.c:779
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: sd_mmc_card/src/at32_sdio.c:525
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1693
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: sd_mmc_card/src/at32_sdio.c:410
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1181
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: sd_mmc_card/src/at32_sdio.c:800
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: sd_mmc_card/src/at32_sdio.c:181
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: sd_mmc_card/src/at32_sdio.c:1023
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1482
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: sd_mmc_card/src/at32_sdio.c:2482
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: sd_mmc_card/src/at32_sdio.c:2699
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1360
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: sd_mmc_card/src/at32_sdio.c:2445
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1646
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: sd_mmc_card/src/at32_sdio.c:196
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1270
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sd_mmc_card/src/at32_sdio.c:736
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: sd_mmc_card/inc/at32_sdio.h:65
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:74
sd_card_state_type
sd_card_state_type
Definition: sd_mmc_card/inc/at32_sdio.h:187
sd_memory_card_type
sd_memory_card_type
Definition: sd_mmc_card/inc/at32_sdio.h:203
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: sd_mmc_card/inc/at32_sdio.h:402
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: sd_mmc_card/inc/at32_sdio.h:401
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:67
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:66
SD_ERROR
@ SD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:118
SD_WP_ERASE_SKIP
@ SD_WP_ERASE_SKIP
Definition: sd_mmc_card/inc/at32_sdio.h:98
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: sd_mmc_card/inc/at32_sdio.h:108
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:77
SD_STREAM_WR_OVERRUN
@ SD_STREAM_WR_OVERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:96
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: sd_mmc_card/inc/at32_sdio.h:115
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:76
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:83
SD_UNSUPPORTED_HW
@ SD_UNSUPPORTED_HW
Definition: sd_mmc_card/inc/at32_sdio.h:117
SD_SDIO_FUNC_ERROR
@ SD_SDIO_FUNC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:107
SD_INTERNAL_ERROR
@ SD_INTERNAL_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:111
SD_INVALID_ERASE_PARAM
@ SD_INVALID_ERASE_PARAM
Definition: sd_mmc_card/inc/at32_sdio.h:87
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:94
SD_CARD_ECC_DISABLED
@ SD_CARD_ECC_DISABLED
Definition: sd_mmc_card/inc/at32_sdio.h:99
SD_CARD_CONTROLLER_ERR
@ SD_CARD_CONTROLLER_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:93
SD_ERASE_RESET
@ SD_ERASE_RESET
Definition: sd_mmc_card/inc/at32_sdio.h:100
SD_CARD_ECC_ERROR
@ SD_CARD_ECC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:92
SD_STREAM_RD_UNDERRUN
@ SD_STREAM_RD_UNDERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:95
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: sd_mmc_card/inc/at32_sdio.h:116
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:80
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:91
SD_SDIO_FUNC_BUSY
@ SD_SDIO_FUNC_BUSY
Definition: sd_mmc_card/inc/at32_sdio.h:106
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:90
SD_ADDR_OUT_OF_RANGE
@ SD_ADDR_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:103
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:81
SD_REQ_PENDING
@ SD_REQ_PENDING
Definition: sd_mmc_card/inc/at32_sdio.h:113
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: sd_mmc_card/inc/at32_sdio.h:114
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:104
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: sd_mmc_card/inc/at32_sdio.h:102
SD_SDIO_DISABLED
@ SD_SDIO_DISABLED
Definition: sd_mmc_card/inc/at32_sdio.h:105
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:79
SD_ADDR_MISALIGNED
@ SD_ADDR_MISALIGNED
Definition: sd_mmc_card/inc/at32_sdio.h:84
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:82
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:89
SD_NOT_CONFIGURED
@ SD_NOT_CONFIGURED
Definition: sd_mmc_card/inc/at32_sdio.h:112
SD_CID_CSD_OVERWRITE
@ SD_CID_CSD_OVERWRITE
Definition: sd_mmc_card/inc/at32_sdio.h:97
SD_WR_PROTECT_VIOLATION
@ SD_WR_PROTECT_VIOLATION
Definition: sd_mmc_card/inc/at32_sdio.h:88
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:78
SD_BLK_LEN_ERR
@ SD_BLK_LEN_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:85
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:119
SD_ERASE_SEQ_ERR
@ SD_ERASE_SEQ_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:86
SD_AKE_SEQ_ERROR
@ SD_AKE_SEQ_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:101
SD_CARD_TRANSFER
@ SD_CARD_TRANSFER
Definition: sd_mmc_card/inc/at32_sdio.h:191
SD_CARD_IDENTIFICATION
@ SD_CARD_IDENTIFICATION
Definition: sd_mmc_card/inc/at32_sdio.h:189
SD_CARD_SENDING
@ SD_CARD_SENDING
Definition: sd_mmc_card/inc/at32_sdio.h:192
SD_CARD_STANDBY
@ SD_CARD_STANDBY
Definition: sd_mmc_card/inc/at32_sdio.h:190
SD_CARD_READY
@ SD_CARD_READY
Definition: sd_mmc_card/inc/at32_sdio.h:188
SD_CARD_DISCONNECTED
@ SD_CARD_DISCONNECTED
Definition: sd_mmc_card/inc/at32_sdio.h:195
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:196
SDIO_SDIO_CARD
@ SDIO_SDIO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:212
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:206
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:210
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sd_mmc_card/inc/at32_sdio.h:204
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:208
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sd_mmc_card/inc/at32_sdio.h:205
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:207
SDIO_HIGH_CAPACITY_MMC_CARD
@ SDIO_HIGH_CAPACITY_MMC_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:211
sd_card_info_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:237
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::rca
uint16_t rca
Definition: sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: sd_mmc_card/inc/at32_sdio.h:244
sd_cid_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:170
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: sd_mmc_card/inc/at32_sdio.h:179
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: sd_mmc_card/inc/at32_sdio.h:171
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: sd_mmc_card/inc/at32_sdio.h:173
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:180
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: sd_mmc_card/inc/at32_sdio.h:172
sd_csd_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:126
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::nsac
uint8_t nsac
Definition: sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: sd_mmc_card/inc/at32_sdio.h:163
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::device_size
uint32_t device_size
Definition: sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: sd_mmc_card/inc/at32_sdio.h:127
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:143
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: sd_mmc_card/inc/at32_sdio.h:162
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::taac
uint8_t taac
Definition: sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:146
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:145
sd_scr_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:219
sd_scr_struct_type::cmd20_support
uint32_t cmd20_support
Definition: sd_mmc_card/inc/at32_sdio.h:227
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: sd_mmc_card/inc/at32_sdio.h:222
sd_scr_struct_type::reserverd3
uint32_t reserverd3
Definition: sd_mmc_card/inc/at32_sdio.h:230
sd_scr_struct_type::cmd23_support
uint32_t cmd23_support
Definition: sd_mmc_card/inc/at32_sdio.h:228
sd_scr_struct_type::sd_spec3
uint32_t sd_spec3
Definition: sd_mmc_card/inc/at32_sdio.h:226
sd_scr_struct_type::data_stat_after_erase
uint32_t data_stat_after_erase
Definition: sd_mmc_card/inc/at32_sdio.h:224
sd_scr_struct_type::reserved1
uint32_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:225
sd_scr_struct_type::scr_structure
uint32_t scr_structure
Definition: sd_mmc_card/inc/at32_sdio.h:221
sd_scr_struct_type::sd_security
uint32_t sd_security
Definition: sd_mmc_card/inc/at32_sdio.h:223
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: sd_mmc_card/inc/at32_sdio.h:220
sd_scr_struct_type::reserverd2
uint32_t reserverd2
Definition: sd_mmc_card/inc/at32_sdio.h:229


AT32F413 Firmwary Library: at32_sdio.c Source File

  • sdio
  • sd_mmc_card
  • src
sd_mmc_card/src/at32_sdio.c
Go to the documentation of this file.
1
28#include "at32_sdio.h"
29#include "at32f413_board.h"
30
39 sdio_command_struct_type sdio_command_init_struct;
40 sdio_data_struct_type sdio_data_init_struct;
41
42static sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1; /* sd card type */
43static uint32_t csd_table[4], cid_table[4], rca = 0; /* csd, sid, rca */
44static sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE; /* working mode */
45static uint8_t stop_flag = 0; /* transmit stop flag */
46volatile sd_error_status_type transfer_error = SD_OK; /* transmit error flag */
47volatile uint8_t transfer_end = 0; /* transmit end flag */
48 sd_card_info_struct_type sd_card_info; /* sd card information */
49
50 sd_error_status_type command_error(void);
51 sd_error_status_type command_rsp1_error(uint8_t cmd);
52 sd_error_status_type command_rsp2_error(void);
53 sd_error_status_type command_rsp3_error(void);
54 sd_error_status_type command_rsp4_error(uint8_t cmd);
55 sd_error_status_type command_rsp5_error(uint8_t cmd);
56 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca);
57 sd_error_status_type command_rsp7_error(void);
58 sd_error_status_type sd_bus_wide_enable(confirm_state new_state);
59 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value);
60 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp);
61 sd_error_status_type check_card_programming(uint8_t *p_status);
62 sd_error_status_type speed_change(uint8_t speed);
63 sd_error_status_type scr_find(void);
64uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes);
65
72 sd_error_status_type sd_init(void)
73{
74 uint16_t clkdiv = 0;
75 sd_error_status_type status = SD_OK;
76 gpio_init_type gpio_init_struct = {0};
77 uint8_t retry = 0;
78
79 /* gpioc and gpiod periph clock enable */
80 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
81 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
82
83 /* sdio periph clock enable */
84 crm_periph_clock_enable(CRM_SDIO1_PERIPH_CLOCK, TRUE);
85
86 /* configure pc.08, pc.09, pc.10, pc.11, pc.12 pin: d0, d1, d2, d3, clk pin */
87 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
88 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
89 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
90 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
91 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
92 gpio_init(GPIOC, &gpio_init_struct);
93
94 /* configure pd.02 cmd line */
95 gpio_init_struct.gpio_pins = GPIO_PINS_2;
96 gpio_init(GPIOD, &gpio_init_struct);
97
98 retry = 3;
99 while(retry--){
100 /* reset sdio */
101 sdio_reset(SDIOx);
102 /* power on */
103 status = sd_power_on();
104
105 if(status == SD_OK)
106 break;
107 }
108
109 if(status == SD_OK)
110 {
111 /* sdio card initialize */
112 status = sd_card_init();
113 }
114
115 if(status == SD_OK)
116 {
117 /* get card information*/
118 status = sd_card_info_get(&sd_card_info);
119 }
120
121 if((SDIO_MULTIMEDIA_CARD == card_type) && (sd_card_info.sd_csd_reg.spec_version >= 4))
122 {
123 card_type = SDIO_HIGH_SPEED_MULTIMEDIA_CARD;
124 }
125
126 if(status == SD_OK)
127 {
128 /* select card */
129 status = sd_deselect_select((uint32_t)(sd_card_info.rca << 16));
130 }
131
132 if(status == SD_OK && ((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
133 (SDIO_SECURE_DIGITAL_IO_COMBO_CARD == card_type) || (SDIO_HIGH_CAPACITY_SD_CARD == card_type)))
134 {
135 status = scr_find();
136 }
137
138 if(status == SD_OK)
139 {
140 /* set normal speed */
141 status = speed_change(0);
142 }
143
144 if((status == SD_OK) || (card_type == SDIO_MULTIMEDIA_CARD))
145 {
146 if(sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1 || sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0)
147 {
148 /* set sdio_ck to 12mhz */
149 clkdiv = system_core_clock / 12000000;
150
151 if(clkdiv >= 2)
152 {
153 clkdiv -= 2;
154 }
155 }
156 else
157 {
158 /* set sdio_ck to 48mhz */
159 clkdiv = system_core_clock / 48000000;
160
161 if(clkdiv >= 2)
162 {
163 clkdiv -= 2;
164 }
165 }
166 /* set sdio clock divider */
167 sdio_clock_set(clkdiv);
168
169 /* set transfer mode */
170 status = sd_device_mode_set(SD_TRANSFER_DMA_MODE);
171 }
172
173 return status;
174}
175
181void sdio_clock_set(uint32_t clk_div)
182{
183 /* config clock divide [7:0] */
184 SDIOx->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
185
186 /* config clock divide [9:8] */
187 SDIOx->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
188}
189
196 sd_error_status_type sd_power_on(void)
197{
198 uint8_t retry = 0;
199 sd_error_status_type status = SD_OK;
200 uint32_t response = 0, count = 0, valid_voltage = 0, clk_psc;
201 uint32_t sd_type = SD_STD_CAPACITY;
202
203 /* sdio_ck is less than 400KHz in initialization stage, set to 200KHz */
204 clk_psc = (system_core_clock / 200000) - 2;
205
206 if(clk_psc > 0x3FF)
207 {
208 clk_psc = 0x3FF;
209 }
210
211 /* config sdio clock divide and edge phase */
212 sdio_clock_config(SDIOx, clk_psc, SDIO_CLOCK_EDGE_FALLING);
213 /* config sdio bus width */
214 sdio_bus_width_config(SDIOx, SDIO_BUS_WIDTH_D1);
215 /* disable flow control */
216 sdio_flow_control_enable(SDIOx, FALSE);
217 /* disable clock bypass */
218 sdio_clock_bypass(SDIOx, FALSE);
219 /* disable power saving mode */
220 sdio_power_saving_mode_enable(SDIOx, FALSE);
221
222 /* sdio power on */
223 sdio_power_set(SDIOx, SDIO_POWER_ON);
224 /* enable to output sdio_ck */
225 sdio_clock_enable(SDIOx, TRUE);
226
227 for(retry = 0; retry < 5; retry++)
228 {
229 /* send cmd0, get in idle stage */
230 sdio_command_init_struct.argument = 0x0;
231 sdio_command_init_struct.cmd_index = SD_CMD_GO_IDLE_STATE;
232 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_NO;
233 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
234
235 /* sdio command config */
236 sdio_command_config(SDIOx, &sdio_command_init_struct);
237 /* enable ccsm */
238 sdio_command_state_machine_enable(SDIOx, TRUE);
239
240 /* get command status */
241 status = command_error();
242 }
243
244 /* send cmd8, check card interface feature */
245 sdio_command_init_struct.argument = SD_CHECK_PATTERN;
246 sdio_command_init_struct.cmd_index = SDIO_SEND_IF_COND;
247 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
248 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
249
250 /* sdio command config */
251 sdio_command_config(SDIOx, &sdio_command_init_struct);
252 /* enable ccsm */
253 sdio_command_state_machine_enable(SDIOx, TRUE);
254
255 /* waiting R7 */
256 status = command_rsp7_error();
257
258 if(status == SD_OK)
259 {
260 /* set card type and sd type */
261 card_type = SDIO_STD_CAPACITY_SD_CARD_V2_0;
262 sd_type = SD_HIGH_CAPACITY;
263 }
264
265 /* send cmd55, check sd version */
266 sdio_command_init_struct.argument = 0x00;
267 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
268 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
269 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
270
271 /* sdio command config */
272 sdio_command_config(SDIOx, &sdio_command_init_struct);
273 /* enable ccsm */
274 sdio_command_state_machine_enable(SDIOx, TRUE);
275
276 /* waiting R1 */
277 status = command_rsp1_error(SD_CMD_APP_CMD);
278
279 /* check sd card or mmc card */
280 if(SD_OK == status)
281 {
282 /* send acmd41, check voltage operation range */
283 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
284 {
285 delay_ms(10);
286
287 /* send cmd55 before acmd41 */
288 sdio_command_init_struct.argument = 0x00;
289 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
290 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
291 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
292
293 /* sdio command config */
294 sdio_command_config(SDIOx, &sdio_command_init_struct);
295 /* enable ccsm */
296 sdio_command_state_machine_enable(SDIOx, TRUE);
297
298 /* waiting R1 */
299 status = command_rsp1_error(SD_CMD_APP_CMD);
300
301 /* if any errors occured, return status */
302 if(status != SD_OK)
303 {
304 return status;
305 }
306
307 /* send acmd41 */
308 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_SD | sd_type;
309 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_OP_COND;
310 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
311 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
312
313 /* sdio command config */
314 sdio_command_config(SDIOx, &sdio_command_init_struct);
315 /* enable ccsm */
316 sdio_command_state_machine_enable(SDIOx, TRUE);
317
318 /* waiting R3 */
319 status = command_rsp3_error();
320
321 /* if any errors occured, return status */
322 if(status != SD_OK)
323 {
324 return status;
325 }
326
327 /* get response1 */
328 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
329
330 /* check sd card power on stage is success or not */
331 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
332 count++;
333 }
334
335 if(count >= SD_MAX_VOLT_TRIAL)
336 {
337 status = SD_INVALID_VOLTRANGE;
338 return status;
339 }
340
341 if(response &= SD_HIGH_CAPACITY)
342 {
343 card_type = SDIO_HIGH_CAPACITY_SD_CARD;
344 }
345 }
346 /* mmc card */
347 else
348 {
349 /* send cmd1 */
350 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
351 {
352 delay_ms(10);
353
354 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_MMC;
355 sdio_command_init_struct.cmd_index = SD_CMD_SEND_OP_COND;
356 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
357 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
358
359 /* sdio command config */
360 sdio_command_config(SDIOx, &sdio_command_init_struct);
361 /* enable ccsm */
362 sdio_command_state_machine_enable(SDIOx, TRUE);
363
364 /* waiting R3 */
365 status = command_rsp3_error();
366
367 if(status != SD_OK)
368 {
369 return status;
370 }
371
372 /* get response1 */
373 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
374
375 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
376 count++;
377 }
378
379 if(count >= SD_MAX_VOLT_TRIAL)
380 {
381 status = SD_INVALID_VOLTRANGE;
382 return status;
383 }
384
385 card_type = SDIO_MULTIMEDIA_CARD;
386 }
387
388 return(status);
389}
390
396 sd_error_status_type sd_power_off(void)
397{
398 /* sdio power off */
399 sdio_power_set(SDIOx, SDIO_POWER_OFF);
400
401 return SD_OK;
402}
403
410 sd_error_status_type sd_card_init(void)
411{
412 sd_error_status_type status = SD_OK;
413 uint16_t rca_temp = 0x01;
414
415 /* check power status */
416 if(SDIO_POWER_OFF == sdio_power_status_get(SDIOx))
417 {
418 return SD_REQ_NOT_APPLICABLE;
419 }
420
421 /* check is secure_digital_io_card or not */
422 if(SDIO_SECURE_DIGITAL_IO_CARD != card_type)
423 {
424 /* send cmd2, get cid register */
425 sdio_command_init_struct.argument = 0x0;
426 sdio_command_init_struct.cmd_index = SD_CMD_ALL_SEND_CID;
427 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
428 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
429
430 /* sdio command config */
431 sdio_command_config(SDIOx, &sdio_command_init_struct);
432 /* enable ccsm */
433 sdio_command_state_machine_enable(SDIOx, TRUE);
434
435 status = command_rsp2_error();
436 if(status != SD_OK)
437 {
438 return status;
439 }
440
441 cid_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
442 cid_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
443 cid_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
444 cid_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
445 }
446
447 /* check card type */
448 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
449 (card_type == SDIO_SECURE_DIGITAL_IO_COMBO_CARD) || (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
450 {
451 /* send cmd3, get rca */
452 sdio_command_init_struct.argument = 0x00;
453 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
454 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
455 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
456
457 /* sdio command config */
458 sdio_command_config(SDIOx, &sdio_command_init_struct);
459 /* enable ccsm */
460 sdio_command_state_machine_enable(SDIOx, TRUE);
461
462 status = command_rsp6_error(SD_CMD_SET_REL_ADDR, &rca_temp);
463 if(status != SD_OK)
464 {
465 return status;
466 }
467 }
468
469 /* mmc card */
470 if(card_type == SDIO_MULTIMEDIA_CARD)
471 {
472 /* send cmd3 */
473 sdio_command_init_struct.argument = (uint32_t)(rca_temp << 16);
474 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
475 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
476 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
477
478 /* sdio command config */
479 sdio_command_config(SDIOx, &sdio_command_init_struct);
480 /* enable ccsm */
481 sdio_command_state_machine_enable(SDIOx, TRUE);
482
483 status = command_rsp2_error();
484 if(status != SD_OK)
485 {
486 return status;
487 }
488 }
489
490 /* check is secure_digital_io_card or not */
491 if(card_type != SDIO_SECURE_DIGITAL_IO_CARD)
492 {
493 rca = rca_temp;
494 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
495 sdio_command_init_struct.cmd_index = SD_CMD_SEND_CSD;
496 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
497 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
498
499 /* sdio command config */
500 sdio_command_config(SDIOx, &sdio_command_init_struct);
501 /* enable ccsm */
502 sdio_command_state_machine_enable(SDIOx, TRUE);
503
504 status = command_rsp2_error();
505 if(status != SD_OK)
506 {
507 return status;
508 }
509
510 csd_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
511 csd_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
512 csd_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
513 csd_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
514 }
515
516 return SD_OK;
517}
518
525 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
526{
527 sd_error_status_type status = SD_OK;
528 uint8_t tmp = 0;
529
530 card_info->card_type = (uint8_t)card_type;
531 card_info->rca = (uint16_t)rca;
532
533 /* byte 0 */
534 tmp = (uint8_t)((csd_table[0] & 0xFF000000) >> 24);
535 card_info->sd_csd_reg.csd_struct = (tmp & 0xC0) >> 6;
536 card_info->sd_csd_reg.spec_version = (tmp & 0x3C) >> 2;
537 card_info->sd_csd_reg.reserved1 = tmp & 0x03;
538
539 /* byte 1 */
540 tmp = (uint8_t)((csd_table[0] & 0x00FF0000) >> 16);
541 card_info->sd_csd_reg.taac = tmp;
542
543 /* byte 2 */
544 tmp = (uint8_t)((csd_table[0] & 0x0000FF00) >> 8);
545 card_info->sd_csd_reg.nsac = tmp;
546
547 /* byte 3 */
548 tmp = (uint8_t)(csd_table[0] & 0x000000FF);
549 card_info->sd_csd_reg.max_bus_clk_freq = tmp;
550
551 /* byte 4 */
552 tmp = (uint8_t)((csd_table[1] & 0xFF000000) >> 24);
553 card_info->sd_csd_reg.card_cmd_classes = tmp << 4;
554
555 /* byte 5 */
556 tmp = (uint8_t)((csd_table[1] & 0x00FF0000) >> 16);
557 card_info->sd_csd_reg.card_cmd_classes |= (tmp & 0xF0) >> 4;
558 card_info->sd_csd_reg.max_read_blk_length = tmp & 0x0F;
559
560 /* byte 6 */
561 tmp = (uint8_t)((csd_table[1] & 0x0000FF00) >> 8);
562 card_info->sd_csd_reg.part_blk_read = (tmp & 0x80) >> 7;
563 card_info->sd_csd_reg.write_blk_misalign = (tmp & 0x40) >> 6;
564 card_info->sd_csd_reg.read_blk_misalign = (tmp & 0x20) >> 5;
565 card_info->sd_csd_reg.dsr_implemented = (tmp & 0x10) >> 4;
566 card_info->sd_csd_reg.reserved2 = 0; /* reserved */
567
568 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || (card_type == SDIO_MULTIMEDIA_CARD))
569 {
570 card_info->sd_csd_reg.device_size = (tmp & 0x03) << 10;
571
572 /* byte 7 */
573 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
574 card_info->sd_csd_reg.device_size |= (tmp) << 2;
575
576 /* byte 8 */
577 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
578 card_info->sd_csd_reg.device_size |= (tmp & 0xC0) >> 6;
579
580 card_info->sd_csd_reg.max_read_current_vdd_min = (tmp & 0x38) >> 3;
581 card_info->sd_csd_reg.max_read_current_vdd_max = (tmp & 0x07);
582
583 /* byte 9 */
584 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
585 card_info->sd_csd_reg.max_write_current_vdd_min = (tmp & 0xE0) >> 5;
586 card_info->sd_csd_reg.max_write_current_vdd_max = (tmp & 0x1C) >> 2;
587 card_info->sd_csd_reg.device_size_mult = (tmp & 0x03) << 1;
588 /* byte 10 */
589 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
590 card_info->sd_csd_reg.device_size_mult |= (tmp & 0x80) >> 7;
591
592 card_info->card_capacity = (card_info->sd_csd_reg.device_size + 1) ;
593 card_info->card_capacity *= (1 << (card_info->sd_csd_reg.device_size_mult + 2));
594 card_info->card_blk_size = 1 << (card_info->sd_csd_reg.max_read_blk_length);
595 card_info->card_capacity *= card_info->card_blk_size;
596 }
597 else if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
598 {
599 /* byte 7 */
600 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
601 card_info->sd_csd_reg.device_size = (tmp & 0x3F) << 16;
602
603 /* byte 8 */
604 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
605
606 card_info->sd_csd_reg.device_size |= (tmp << 8);
607
608 /* byte 9 */
609 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
610
611 card_info->sd_csd_reg.device_size |= (tmp);
612
613 /* byte 10 */
614 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
615
616 card_info->card_capacity = (uint64_t)(card_info->sd_csd_reg.device_size + 1) * 512 * 1024;
617 card_info->card_blk_size = 512;
618 }
619
620
621 card_info->sd_csd_reg.erase_group_size = (tmp & 0x40) >> 6;
622 card_info->sd_csd_reg.erase_group_size_mult = (tmp & 0x3F) << 1;
623
624 /* byte 11 */
625 tmp = (uint8_t)(csd_table[2] & 0x000000FF);
626 card_info->sd_csd_reg.erase_group_size_mult |= (tmp & 0x80) >> 7;
627 card_info->sd_csd_reg.write_protect_group_size = (tmp & 0x7F);
628
629 /* byte 12 */
630 tmp = (uint8_t)((csd_table[3] & 0xFF000000) >> 24);
631 card_info->sd_csd_reg.write_protect_group_enable = (tmp & 0x80) >> 7;
632 card_info->sd_csd_reg.manufacturer_default_ecc = (tmp & 0x60) >> 5;
633 card_info->sd_csd_reg.write_speed_factor = (tmp & 0x1C) >> 2;
634 card_info->sd_csd_reg.max_write_blk_length = (tmp & 0x03) << 2;
635
636 /* byte 13 */
637 tmp = (uint8_t)((csd_table[3] & 0x00FF0000) >> 16);
638 card_info->sd_csd_reg.max_write_blk_length |= (tmp & 0xC0) >> 6;
639 card_info->sd_csd_reg.part_blk_write = (tmp & 0x20) >> 5;
640 card_info->sd_csd_reg.reserved3 = 0;
641 card_info->sd_csd_reg.content_protect_app = (tmp & 0x01);
642
643 /* byte 14 */
644 tmp = (uint8_t)((csd_table[3] & 0x0000FF00) >> 8);
645 card_info->sd_csd_reg.file_format_group = (tmp & 0x80) >> 7;
646 card_info->sd_csd_reg.copy_flag = (tmp & 0x40) >> 6;
647 card_info->sd_csd_reg.permanent_write_protect = (tmp & 0x20) >> 5;
648 card_info->sd_csd_reg.temp_write_protect = (tmp & 0x10) >> 4;
649 card_info->sd_csd_reg.file_formart = (tmp & 0x0C) >> 2;
650 card_info->sd_csd_reg.ecc_code = (tmp & 0x03);
651
652 /* byte 15 */
653 tmp = (uint8_t)(csd_table[3] & 0x000000FF);
654 card_info->sd_csd_reg.csd_crc = (tmp & 0xFE) >> 1;
655 card_info->sd_csd_reg.reserved4 = 1;
656
657 /* byte 0 */
658 tmp = (uint8_t)((cid_table[0] & 0xFF000000) >> 24);
659 card_info->sd_cid_reg.manufacturer_id = tmp;
660
661 /* byte 1 */
662 tmp = (uint8_t)((cid_table[0] & 0x00FF0000) >> 16);
663 card_info->sd_cid_reg.oem_app_id = tmp << 8;
664
665 /* byte 2 */
666 tmp = (uint8_t)((cid_table[0] & 0x000000FF00) >> 8);
667 card_info->sd_cid_reg.oem_app_id |= tmp;
668
669 /* byte 3 */
670 tmp = (uint8_t)(cid_table[0] & 0x000000FF);
671 card_info->sd_cid_reg.product_name1 = tmp << 24;
672
673 /* byte 4 */
674 tmp = (uint8_t)((cid_table[1] & 0xFF000000) >> 24);
675 card_info->sd_cid_reg.product_name1 |= tmp << 16;
676
677 /* byte 5 */
678 tmp = (uint8_t)((cid_table[1] & 0x00FF0000) >> 16);
679 card_info->sd_cid_reg.product_name1 |= tmp << 8;
680
681 /* byte 6 */
682 tmp = (uint8_t)((cid_table[1] & 0x0000FF00) >> 8);
683 card_info->sd_cid_reg.product_name1 |= tmp;
684
685 /* byte 7 */
686 tmp = (uint8_t)(cid_table[1] & 0x000000FF);
687 card_info->sd_cid_reg.product_name2 = tmp;
688
689 /* byte 8 */
690 tmp = (uint8_t)((cid_table[2] & 0xFF000000) >> 24);
691 card_info->sd_cid_reg.product_reversion = tmp;
692
693 /* byte 9 */
694 tmp = (uint8_t)((cid_table[2] & 0x00FF0000) >> 16);
695 card_info->sd_cid_reg.product_sn = tmp << 24;
696
697 /* byte 10 */
698 tmp = (uint8_t)((cid_table[2] & 0x0000FF00) >> 8);
699 card_info->sd_cid_reg.product_sn |= tmp << 16;
700
701 /* byte 11 */
702 tmp = (uint8_t)(cid_table[2] & 0x000000FF);
703 card_info->sd_cid_reg.product_sn |= tmp << 8;
704
705 /* byte 12 */
706 tmp = (uint8_t)((cid_table[3] & 0xFF000000) >> 24);
707 card_info->sd_cid_reg.product_sn |= tmp;
708
709 /* byte 13 */
710 tmp = (uint8_t)((cid_table[3] & 0x00FF0000) >> 16);
711 card_info->sd_cid_reg.reserved1 |= (tmp & 0xF0) >> 4;
712 card_info->sd_cid_reg.manufact_date = (tmp & 0x0F) << 8;
713
714 /* byte 14 */
715 tmp = (uint8_t)((cid_table[3] & 0x0000FF00) >> 8);
716 card_info->sd_cid_reg.manufact_date |= tmp;
717
718 /* byte 15 */
719 tmp = (uint8_t)(cid_table[3] & 0x000000FF);
720 card_info->sd_cid_reg.cid_crc = (tmp & 0xFE) >> 1;
721 card_info->sd_cid_reg.reserved2 = 1;
722
723 return(status);
724}
725
736 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
737{
738 sd_error_status_type status = SD_OK;
739
740 if((card_type == SDIO_MULTIMEDIA_CARD) || (card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD))
741 {
742 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)mode);
743 }
744 else if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
745 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
746 {
747 if(mode >= 2)
748 {
749 /* not support D8 mode */
750 return SD_UNSUPPORTED_FEATURE;
751 }
752
753 if(SDIO_BUS_WIDTH_D4 == mode)
754 {
755 status = sd_bus_wide_enable(TRUE);
756 }
757 else
758 {
759 status = sd_bus_wide_enable(FALSE);
760 }
761 }
762
763 if(status == SD_OK)
764 {
765 sdio_bus_width_config(SDIOx, mode);
766 }
767
768 return status;
769}
770
779 sd_error_status_type sd_device_mode_set(uint32_t mode)
780{
781 sd_error_status_type status = SD_OK;
782
783 if((mode == SD_TRANSFER_DMA_MODE) || (mode == SD_TRANSFER_POLLING_MODE))
784 {
785 device_mode = (sd_data_transfer_mode_type)mode;
786 }
787 else
788 {
789 status = SD_INVALID_PARAMETER;
790 }
791
792 return status;
793}
794
800 sd_error_status_type sd_deselect_select(uint32_t addr)
801{
802 /* send cmd7, select card */
803 sdio_command_init_struct.argument = addr;
804 sdio_command_init_struct.cmd_index = SD_CMD_SEL_DESEL_CARD;
805 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
806 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_INT;
807
808 /* sdio command config */
809 sdio_command_config(SDIOx, &sdio_command_init_struct);
810 /* enable ccsm */
811 sdio_command_state_machine_enable(SDIOx, TRUE);
812
813 return command_rsp1_error(SD_CMD_SEL_DESEL_CARD);
814}
815
823 sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, \
824 sdio_data_struct_type* sdio_data_init_t, uint32_t *buf)
825{
826 sd_error_status_type status = SD_OK;
827 uint32_t count = 0;
828 uint32_t timeout = SDIO_DATATIMEOUT;
829 uint32_t length = 0;
830
831 if(buf == NULL)
832 {
833 return SD_INVALID_PARAMETER;
834 }
835 /* clear dtctrl register */
836 SDIOx->dtcnt = 0x0;
837
838 /* sdio command config */
839 sdio_data_config(SDIOx, sdio_data_init_t);
840 /* enable dcsm */
841 sdio_data_state_machine_enable(SDIOx, TRUE);
842
843 length = sdio_data_init_t->data_length;
844
845 if(device_mode == SD_TRANSFER_DMA_MODE)
846 {
847 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CONTROLLER)
848 {
849 sd_dma_config(buf, length, DMA_DIR_PERIPHERAL_TO_MEMORY);
850 SDIOx->inten |= SDIO_INTR_STS_READ_MASK;
851 transfer_error = SD_OK;
852 transfer_end = 0;
853 sdio_dma_enable(SDIOx, TRUE);
854 }
855 }
856
857 /* sdio command config */
858 sdio_command_config(SDIOx, sdio_cmd_init_t);
859 /* enable ccsm */
860 sdio_command_state_machine_enable(SDIOx, TRUE);
861
862 status = command_rsp1_error(sdio_cmd_init_t->cmd_index);
863 if(status != SD_OK)
864 {
865 return status;
866 }
867
868 /* polling mode */
869 if(device_mode == SD_TRANSFER_POLLING_MODE)
870 {
871 if(SDIO_DATA_TRANSFER_TO_CONTROLLER == sdio_data_init_t->transfer_direction)
872 {
873 while(!(SDIOx->sts & (SDIO_INTR_STS_READ_MASK)))
874 {
875 if(sdio_flag_get(SDIOx, SDIO_RXBUFH_FLAG) != RESET)
876 {
877 for(count = 0; count < 8; count++, buf++)
878 {
879 *buf = sdio_data_read(SDIOx);
880 }
881
882 timeout = 0x7FFFFF;
883 }
884 else
885 {
886 if(0 == timeout)
887 {
888 sd_init();
889 return SD_DATA_TIMEOUT;
890 }
891
892 timeout--;
893 }
894 }
895
896 while(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
897 {
898 *buf = sdio_data_read(SDIOx);
899 buf++;
900 }
901 }
902 else
903 {
904 while(!(SDIOx->sts & SDIO_INTR_STS_WRITE_MASK))
905 {
906 if(sdio_flag_get(SDIOx, SDIO_TXBUFH_FLAG) != RESET)
907 {
908 for(count = 0; count < 8 && length > 0; count++, buf++, length -= 4)
909 {
910 sdio_data_write(SDIOx, *buf);
911 }
912
913 timeout = 0x3FFFFFFF;
914 }
915 else
916 {
917 if(timeout == 0)
918 {
919 sd_init();
920 return SD_DATA_TIMEOUT;
921 }
922
923 timeout--;
924 }
925 }
926 }
927 /* data timeout */
928 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
929 {
930 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
931 return SD_DATA_TIMEOUT;
932 }
933 /* crc error */
934 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
935 {
936 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
937 return SD_DATA_FAIL;
938 }
939 /* over run error */
940 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
941 {
942 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
943 return SD_RX_OVERRUN;
944 }
945 /* under run error */
946 else if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
947 {
948 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
949 return SD_TX_UNDERRUN;
950 }
951 /* start bit error */
952 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
953 {
954 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
955 return SD_START_BIT_ERR;
956 }
957 /* data transfer complete */
958 if((stop_flag == 1) && (sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET))
959 {
960 /* send cmd12, stop transmission */
961 sdio_cmd_init_t->argument = 0;
962 sdio_cmd_init_t->cmd_index = SD_CMD_STOP_TRANSMISSION;
963 sdio_cmd_init_t->rsp_type = SDIO_RESPONSE_SHORT;
964 sdio_cmd_init_t->wait_type = SDIO_WAIT_FOR_NO;
965
966 /* sdio command config */
967 sdio_command_config(SDIOx, sdio_cmd_init_t);
968 /* enable ccsm */
969 sdio_command_state_machine_enable(SDIOx, TRUE);
970
971 status = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
972
973 if(status != SD_OK)
974 {
975 return status;
976 }
977 }
978
979 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
980 }
981 else if(device_mode == SD_TRANSFER_DMA_MODE)
982 {
983 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CARD)
984 {
985 sd_dma_config(buf, length, DMA_DIR_MEMORY_TO_PERIPHERAL);
986 SDIOx->inten |= SDIO_INTR_STS_WRITE_MASK;
987 transfer_error = SD_OK;
988 transfer_end = 0;
989 sdio_dma_enable(SDIOx, TRUE);
990 }
991
992 while(!(SDIOx->sts & SDIOx->inten) && timeout)
993 {
994 timeout--;
995
996 if(transfer_end)
997 {
998 break;
999 }
1000 }
1001
1002 if(timeout == 0)
1003 {
1004 sd_init();
1005 return SD_DATA_TIMEOUT;
1006 }
1007
1008 if(transfer_error != SD_OK)
1009 {
1010 status = transfer_error;
1011 }
1012 }
1013
1014 return status;
1015}
1016
1023 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
1024{
1025 sd_error_status_type status = SD_OK;
1026 uint32_t start_addr = 0, end_addr = 0, response = 0;
1027 uint8_t card_state;
1028
1029 /* high capacity sd card */
1030 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1031 {
1032 start_addr = addr >> 9;
1033 end_addr = start_addr + nblks - 1;
1034 }
1035 else
1036 {
1037 start_addr = addr;
1038 end_addr = start_addr + (nblks - 1) * 512;
1039 }
1040
1041 /* clear dcsm configuration */
1042 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1043 sdio_data_init_struct.data_length = 0 ;
1044 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1045 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1046 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1047
1048 sdio_data_config(SDIOx, &sdio_data_init_struct);
1049 sdio_data_state_machine_enable(SDIOx, FALSE);
1050
1051 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1052
1053 /* check card locked */
1054 if(response & SD_CARD_LOCKED)
1055 {
1056 return SD_LOCK_UNLOCK_ERROR;
1057 }
1058
1059 if(card_type == SDIO_MULTIMEDIA_CARD || card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
1060 {
1061 /* send cmd35, set erase group start */
1062 sdio_command_init_struct.argument = start_addr;
1063 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_START;
1064 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1065 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1066
1067 /* sdio command config */
1068 sdio_command_config(SDIOx, &sdio_command_init_struct);
1069 /* enable ccsm */
1070 sdio_command_state_machine_enable(SDIOx, TRUE);
1071
1072 status = command_rsp1_error(SD_CMD_ERASE_GRP_START);
1073
1074 if(status != SD_OK)
1075 {
1076 return status;
1077 }
1078
1079 /* send cmd36, set erase group end */
1080 sdio_command_init_struct.argument = end_addr;
1081 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_END;
1082
1083 /* sdio command config */
1084 sdio_command_config(SDIOx, &sdio_command_init_struct);
1085 /* enable ccsm */
1086 sdio_command_state_machine_enable(SDIOx, TRUE);
1087
1088 status = command_rsp1_error(SD_CMD_ERASE_GRP_END);
1089
1090 if(status != SD_OK)
1091 {
1092 return status;
1093 }
1094
1095 /* send cmd38, start erase gourp */
1096 sdio_command_init_struct.argument = 0;
1097 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1098
1099 /* sdio command config */
1100 sdio_command_config(SDIOx, &sdio_command_init_struct);
1101 /* enable ccsm */
1102 sdio_command_state_machine_enable(SDIOx, TRUE);
1103
1104 status = command_rsp1_error(SD_CMD_ERASE);
1105
1106 if(status != SD_OK)
1107 {
1108 return status;
1109 }
1110 }
1111 else
1112 {
1113 /* send cmd32, set erase block start */
1114 sdio_command_init_struct.argument = start_addr;
1115 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_START;
1116 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1117 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1118
1119 /* sdio command config */
1120 sdio_command_config(SDIOx, &sdio_command_init_struct);
1121 /* enable ccsm */
1122 sdio_command_state_machine_enable(SDIOx, TRUE);
1123
1124 status = command_rsp1_error(SD_CMD_SD_ERASE_GRP_START);
1125
1126 if(status != SD_OK)
1127 {
1128 return status;
1129 }
1130
1131 /* send cmd33, set erase block end */
1132 sdio_command_init_struct.argument = end_addr;
1133 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_END;
1134
1135 /* sdio command config */
1136 sdio_command_config(SDIOx, &sdio_command_init_struct);
1137 /* enable ccsm */
1138 sdio_command_state_machine_enable(SDIOx, TRUE);
1139
1140 if(status != SD_OK)
1141 {
1142 return status;
1143 }
1144
1145 /* send cmd38, start erase block */
1146 sdio_command_init_struct.argument = 0;
1147 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1148
1149 /* sdio command config */
1150 sdio_command_config(SDIOx, &sdio_command_init_struct);
1151 /* enable ccsm */
1152 sdio_command_state_machine_enable(SDIOx, TRUE);
1153
1154 status = command_rsp1_error(SD_CMD_ERASE);
1155
1156 if(status != SD_OK)
1157 {
1158 return status;
1159 }
1160 }
1161
1162 status = check_card_programming(&card_state);
1163
1164 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || \
1165 (card_state == SD_CARD_RECEIVING)))
1166 {
1167 status = check_card_programming(&card_state);
1168 }
1169
1170 return status;
1171}
1172
1181 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
1182{
1183 sd_error_status_type status = SD_OK;
1184 uint32_t response = 0;
1185 uint8_t power;
1186
1187 if(NULL == buf)
1188 {
1189 return SD_INVALID_PARAMETER;
1190 }
1191
1192 SDIOx->dtctrl = 0x0;
1193
1194 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1195 {
1196 blk_size = 512;
1197 addr >>= 9;
1198 }
1199
1200 /* clear dcsm configuration */
1201 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1202 sdio_data_init_struct.data_length = 0;
1203 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1204 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1205 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1206
1207 sdio_data_config(SDIOx, &sdio_data_init_struct);
1208 sdio_data_state_machine_enable(SDIOx, FALSE);
1209
1210 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1211
1212 /* check card locked */
1213 if(response & SD_CARD_LOCKED)
1214 {
1215 return SD_LOCK_UNLOCK_ERROR;
1216 }
1217
1218 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1219 {
1220 power = convert_from_bytes_to_power_of_two(blk_size);
1221
1222 /* send cmd16, set block size */
1223 sdio_command_init_struct.argument = blk_size;
1224 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1225 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1226 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1227
1228 /* sdio command config */
1229 sdio_command_config(SDIOx, &sdio_command_init_struct);
1230 /* enable ccsm */
1231 sdio_command_state_machine_enable(SDIOx, TRUE);
1232
1233 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1234
1235 if(status != SD_OK)
1236 {
1237 return status;
1238 }
1239 }
1240 else
1241 {
1242 return SD_INVALID_PARAMETER;
1243 }
1244
1245 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1246 sdio_data_init_struct.data_length = blk_size ;
1247 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1248 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1249 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1250
1251 sdio_command_init_struct.argument = addr;
1252 sdio_command_init_struct.cmd_index = SD_CMD_READ_SINGLE_BLOCK;
1253 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1254 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1255
1256 stop_flag = 0;
1257
1258 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1259}
1260
1270 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1271{
1272 sd_error_status_type status = SD_OK;
1273 uint32_t response = 0;
1274 uint8_t power;
1275
1276 SDIOx->dtctrl = 0x0;
1277
1278 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1279 {
1280 blk_size = 512;
1281 addr >>= 9;
1282 }
1283
1284 /* clear dcsm configuration */
1285 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1286 sdio_data_init_struct.data_length = 0;
1287 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1288 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1289 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1290
1291 sdio_data_config(SDIOx, &sdio_data_init_struct);
1292 sdio_data_state_machine_enable(SDIOx, FALSE);
1293
1294 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1295
1296 /* check card locked */
1297 if(response & SD_CARD_LOCKED)
1298 {
1299 return SD_LOCK_UNLOCK_ERROR;
1300 }
1301
1302 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1303 {
1304 power = convert_from_bytes_to_power_of_two(blk_size);
1305
1306 /* send cmd16, set block size */
1307 sdio_command_init_struct.argument = blk_size;
1308 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1309 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1310 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1311
1312 /* sdio command config */
1313 sdio_command_config(SDIOx, &sdio_command_init_struct);
1314 /* enable ccsm */
1315 sdio_command_state_machine_enable(SDIOx, TRUE);
1316
1317 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1318
1319 if(status != SD_OK)
1320 {
1321 return status;
1322 }
1323 }
1324 else
1325 {
1326 return SD_INVALID_PARAMETER;
1327 }
1328
1329 /* check max receive length */
1330 if(nblks * blk_size > SD_MAX_DATA_LENGTH)
1331 {
1332 return SD_INVALID_PARAMETER;
1333 }
1334
1335 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1336 sdio_data_init_struct.data_length = nblks * blk_size ;
1337 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1338 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1339 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1340
1341 /* send cmd18, read block data */
1342 sdio_command_init_struct.argument = addr;
1343 sdio_command_init_struct.cmd_index = SD_CMD_READ_MULT_BLOCK;
1344 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1345 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1346
1347 stop_flag = 1;
1348
1349 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1350}
1351
1360 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
1361{
1362 sd_error_status_type status = SD_OK;
1363 uint8_t power = 0, card_state = 0;
1364 uint32_t timeout = 0, card_status = 0, response = 0;
1365
1366 if(buf == NULL)
1367 {
1368 return SD_INVALID_PARAMETER;
1369 }
1370
1371 SDIOx->dtctrl = 0x0;
1372
1373 /* clear dcsm configuration */
1374 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1375 sdio_data_init_struct.data_length = 0;
1376 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1377 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1378 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1379
1380 sdio_data_config(SDIOx, &sdio_data_init_struct);
1381 sdio_data_state_machine_enable(SDIOx, FALSE);
1382
1383 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1384
1385 /* check card locked */
1386 if(response & SD_CARD_LOCKED)
1387 {
1388 return SD_LOCK_UNLOCK_ERROR;
1389 }
1390
1391 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1392 {
1393 blk_size = 512;
1394 addr >>= 9;
1395 }
1396
1397 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1398 {
1399 power = convert_from_bytes_to_power_of_two(blk_size);
1400
1401 /* send cmd16, set block size */
1402 sdio_command_init_struct.argument = blk_size;
1403 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1404 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1405 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1406
1407 /* sdio command config */
1408 sdio_command_config(SDIOx, &sdio_command_init_struct);
1409 /* enable ccsm */
1410 sdio_command_state_machine_enable(SDIOx, TRUE);
1411
1412 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1413
1414 if(status != SD_OK)
1415 {
1416 return status;
1417 }
1418 }
1419 else
1420 {
1421 return SD_INVALID_PARAMETER;
1422 }
1423
1424 timeout = SD_DATATIMEOUT;
1425
1426 do
1427 {
1428 timeout--;
1429 status = sd_status_send(&card_status);
1430 }
1431 /* check ready_for_data flag */
1432 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1433
1434 if(timeout == 0)
1435 {
1436 return SD_ERROR;
1437 }
1438
1439 /* send cmd24, write single block */
1440 sdio_command_init_struct.argument = addr;
1441 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_SINGLE_BLOCK;
1442 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1443 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1444
1445 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1446 sdio_data_init_struct.data_length = blk_size;
1447 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1448 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1449 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1450
1451 stop_flag = 0;
1452
1453 /* single block, stop command is unnecessary */
1454 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1455
1456 if(status != SD_OK)
1457 {
1458 return status;
1459 }
1460
1461 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1462
1463 status = check_card_programming(&card_state);
1464
1465 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1466 {
1467 status = check_card_programming(&card_state);
1468 }
1469
1470 return status;
1471}
1472
1482 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1483{
1484 sd_error_status_type status = SD_OK;
1485 uint8_t power = 0, card_state = 0;
1486 uint32_t timeout = 0, card_status = 0, response = 0;;
1487
1488 if(buf == NULL)
1489 {
1490 return SD_INVALID_PARAMETER;
1491 }
1492
1493 SDIOx->dtctrl = 0x0;
1494
1495 /* clear dcsm configuration */
1496 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1497 sdio_data_init_struct.data_length = 0;
1498 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1499 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1500 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1501
1502 sdio_data_config(SDIOx, &sdio_data_init_struct);
1503 sdio_data_state_machine_enable(SDIOx, FALSE);
1504
1505 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1506
1507 /* check card locked */
1508 if(response & SD_CARD_LOCKED)
1509 {
1510 return SD_LOCK_UNLOCK_ERROR;
1511 }
1512
1513 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1514 {
1515 blk_size = 512;
1516 addr >>= 9;
1517 }
1518
1519 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1520 {
1521 power = convert_from_bytes_to_power_of_two(blk_size);
1522
1523 /* send cmd16, set block size */
1524 sdio_command_init_struct.argument = blk_size;
1525 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1526 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1527 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1528
1529 /* sdio command config */
1530 sdio_command_config(SDIOx, &sdio_command_init_struct);
1531 /* enable ccsm */
1532 sdio_command_state_machine_enable(SDIOx, TRUE);
1533
1534 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1535
1536 if(status != SD_OK)
1537 {
1538 return status;
1539 }
1540 }
1541 else
1542 {
1543 return SD_INVALID_PARAMETER;
1544 }
1545
1546 if((nblks * blk_size) > SD_MAX_DATA_LENGTH)
1547 {
1548 return SD_INVALID_PARAMETER;
1549 }
1550
1551 timeout = SD_DATATIMEOUT;
1552
1553 do
1554 {
1555 timeout--;
1556 status = sd_status_send(&card_status);
1557 }
1558 /* check ready_for_data flag */
1559 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1560
1561 if(timeout == 0)
1562 {
1563 return SD_ERROR;
1564 }
1565
1566 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
1567 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
1568 {
1569 /* send cmd55 */
1570 sdio_command_init_struct.argument = (uint32_t)rca << 16;
1571 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
1572 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1573 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1574
1575 /* sdio command config */
1576 sdio_command_config(SDIOx, &sdio_command_init_struct);
1577 /* enable ccsm */
1578 sdio_command_state_machine_enable(SDIOx, TRUE);
1579
1580 status = command_rsp1_error(SD_CMD_APP_CMD);
1581
1582 if(status != SD_OK)
1583 {
1584 return status;
1585 }
1586
1587 /* send cmd23, set block count */
1588 sdio_command_init_struct.argument = blk_size;
1589 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCK_COUNT;
1590 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1591 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1592
1593 /* sdio command config */
1594 sdio_command_config(SDIOx, &sdio_command_init_struct);
1595 /* enable ccsm */
1596 sdio_command_state_machine_enable(SDIOx, TRUE);
1597
1598 status = command_rsp1_error(SD_CMD_SET_BLOCK_COUNT);
1599
1600 if(status != SD_OK)
1601 {
1602 return status;
1603 }
1604 }
1605
1606 /* send cmd25, write mult blocks */
1607 sdio_command_init_struct.argument = addr;
1608 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_MULT_BLOCK;
1609 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1610 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1611
1612 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1613 sdio_data_init_struct.data_length = nblks * blk_size ;
1614 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1615 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1616 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1617
1618 stop_flag = 1;
1619 /* cmd12 is needed */
1620 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1621
1622 if(status != SD_OK)
1623 {
1624 return status;
1625 }
1626
1627 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1628
1629 status = check_card_programming(&card_state);
1630
1631 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1632 {
1633 status = check_card_programming(&card_state);
1634 }
1635
1636 return status;
1637}
1638
1646 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
1647{
1648 uint32_t response = 0;
1649
1650 SDIOx->dtctrl = 0x0;
1651
1652 /* clear dcsm configuration */
1653 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1654 sdio_data_init_struct.data_length = 0 ;
1655 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1656 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1657 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1658
1659 sdio_data_config(SDIOx, &sdio_data_init_struct);
1660 sdio_data_state_machine_enable(SDIOx, FALSE);
1661
1662 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1663
1664 /* check card locked */
1665 if(response & SD_CARD_LOCKED)
1666 {
1667 return SD_LOCK_UNLOCK_ERROR;
1668 }
1669 /* send cmd11, read data */
1670 sdio_command_init_struct.argument = addr;
1671 sdio_command_init_struct.cmd_index = SD_CMD_READ_DAT_UNTIL_STOP;
1672 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1673 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1674
1675 sdio_data_init_struct.block_size = (sdio_block_size_type)(5 << 4);
1676 sdio_data_init_struct.data_length = len;
1677 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1678 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1679 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1680
1681 stop_flag = 1;
1682 /* cmd12 is needed */
1683 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1684}
1685
1693 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
1694{
1695 sd_error_status_type status = SD_OK;
1696 uint32_t response = 0;
1697 uint8_t card_state = 0;
1698
1699 if(buf == NULL)
1700 {
1701 return SD_INVALID_PARAMETER;
1702 }
1703
1704 SDIOx->dtctrl = 0x0;
1705
1706 /* clear dcsm configuration */
1707 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1708 sdio_data_init_struct.data_length = 0;
1709 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1710 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1711 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1712
1713 sdio_data_config(SDIOx, &sdio_data_init_struct);
1714 sdio_data_state_machine_enable(SDIOx, FALSE);
1715
1716 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1717
1718 /* check card locked */
1719 if(response & SD_CARD_LOCKED)
1720 {
1721 return SD_LOCK_UNLOCK_ERROR;
1722 }
1723 /* send cmd20, write data */
1724 sdio_command_init_struct.argument = addr;
1725 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_DAT_UNTIL_STOP;
1726 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1727 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1728
1729
1730 sdio_data_init_struct.block_size = (sdio_block_size_type)(15 << 4);
1731 sdio_data_init_struct.data_length = len;
1732 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1733 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1734 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1735
1736 stop_flag = 1;
1737 /* cmd12 is needed */
1738 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1739
1740 if(status != SD_OK)
1741 {
1742 return status;
1743 }
1744
1745 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1746
1747 status = check_card_programming(&card_state);
1748
1749 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1750 {
1751 status = check_card_programming(&card_state);
1752 }
1753
1754 return status;
1755}
1756
1762void SDIO1_IRQHandler(void)
1763{
1764 sd_irq_service();
1765}
1766
1772void SDIO2_IRQHandler(void)
1773{
1774 sd_irq_service();
1775}
1776
1782 sd_error_status_type sd_irq_service(void)
1783{
1784 if(sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET)
1785 {
1786 if(stop_flag == 1)
1787 {
1788 /* send cmd12, stop transmission */
1789 sdio_command_init_struct.argument = 0;
1790 sdio_command_init_struct.cmd_index = SD_CMD_STOP_TRANSMISSION;
1791 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1792 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1793 /* sdio command config */
1794 sdio_command_config(SDIOx, &sdio_command_init_struct);
1795 /* enable ccsm */
1796 sdio_command_state_machine_enable(SDIOx, TRUE);
1797 transfer_error = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
1798 }
1799 else
1800 {
1801 transfer_error = SD_OK;
1802 }
1803 /* clear flag */
1804 sdio_flag_clear(SDIOx, SDIO_DTCMPL_FLAG);
1805 transfer_end = 1;
1806 return transfer_error;
1807 }
1808
1809 if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
1810 {
1811 /* clear flag */
1812 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
1813 transfer_error = SD_DATA_FAIL;
1814 transfer_end = 1;
1815 return transfer_error;
1816 }
1817
1818 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
1819 {
1820 /* clear flag */
1821 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
1822 transfer_error = SD_DATA_TIMEOUT;
1823 transfer_end = 1;
1824 return transfer_error;
1825 }
1826
1827 if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
1828 {
1829 /* clear flag */
1830 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
1831 transfer_error = SD_RX_OVERRUN;
1832 transfer_end = 1;
1833 return(SD_RX_OVERRUN);
1834 }
1835
1836 if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
1837 {
1838 /* clear flag */
1839 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
1840 transfer_error = SD_TX_UNDERRUN;
1841 transfer_end = 1;
1842 return(SD_TX_UNDERRUN);
1843 }
1844
1845 if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
1846 {
1847 /* clear flag */
1848 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
1849 transfer_error = SD_START_BIT_ERR;
1850 transfer_end = 1;
1851 return(SD_START_BIT_ERR);
1852 }
1853
1854 /* disable interrupt */
1855 sdio_interrupt_enable(SDIOx, (SDIO_DTFAIL_INT | SDIO_DTTIMEOUT_INT | \
1856 SDIO_DTCMP_INT | SDIO_TXBUFH_INT | SDIO_RXBUFH_INT | \
1857 SDIO_TXERRU_INT| SDIO_RXERRO_INT | SDIO_SBITERR_INT), FALSE);
1858 return(SD_OK);
1859}
1860
1866 sd_error_status_type command_error(void)
1867{
1868 sd_error_status_type status = SD_OK;
1869 uint32_t timeout = SDIO_CMD0TIMEOUT;
1870
1871 while(timeout--)
1872 {
1873 if(sdio_flag_get(SDIOx, SDIO_CMDCMPL_FLAG) != RESET)
1874 {
1875 break;
1876 }
1877 }
1878
1879 if(timeout == 0)
1880 {
1881 return SD_CMD_RSP_TIMEOUT;
1882 }
1883
1884 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1885 return status;
1886}
1887
1893 sd_error_status_type command_rsp7_error(void)
1894{
1895 sd_error_status_type status = SD_OK;
1896 uint32_t sts_reg = 0;
1897 uint32_t timeout = SDIO_CMD0TIMEOUT;
1898
1899 while(timeout--)
1900 {
1901 sts_reg = SDIOx->sts;
1902
1903 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1904 {
1905 break;
1906 }
1907 }
1908
1909 if((timeout == 0) || (sts_reg & SDIO_CMDTIMEOUT_FLAG))
1910 {
1911 status = SD_CMD_RSP_TIMEOUT;
1912 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1913 return status;
1914 }
1915
1916 if(sts_reg & SDIO_CMDRSPCMPL_FLAG)
1917 {
1918 status = SD_OK;
1919 sdio_flag_clear(SDIOx, SDIO_CMDRSPCMPL_FLAG);
1920 }
1921
1922 return status;
1923}
1924
1930 sd_error_status_type command_rsp1_error(uint8_t cmd)
1931{
1932 uint32_t sts_reg = 0;
1933 uint32_t rsp_cmd = 0;
1934
1935 while(1)
1936 {
1937 sts_reg = SDIOx->sts;
1938
1939 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1940 {
1941 break;
1942 }
1943 }
1944
1945 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1946 {
1947 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1948 return SD_CMD_RSP_TIMEOUT;
1949 }
1950
1951 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
1952 {
1953 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
1954 return SD_CMD_FAIL;
1955 }
1956
1957 rsp_cmd = sdio_command_response_get(SDIOx);
1958 if(rsp_cmd != cmd)
1959 {
1960 return SD_ILLEGAL_CMD;
1961 }
1962
1963 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1964
1965 return (sd_error_status_type)(sdio_response_get(SDIOx, SDIO_RSP1_INDEX) & SD_OCR_ERRORBITS);
1966}
1967
1973 sd_error_status_type command_rsp3_error(void)
1974{
1975 uint32_t sts_reg = 0;;
1976
1977 while(1)
1978 {
1979 sts_reg = SDIOx->sts;
1980
1981 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1982 {
1983 break;
1984 }
1985 }
1986
1987 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1988 {
1989 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1990 return SD_CMD_RSP_TIMEOUT;
1991 }
1992
1993 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1994
1995 return SD_OK;
1996}
1997
2003 sd_error_status_type command_rsp2_error(void)
2004{
2005 sd_error_status_type status = SD_OK;
2006 uint32_t sts_reg;
2007 uint32_t timeout = SDIO_CMD0TIMEOUT;
2008
2009 while(timeout--)
2010 {
2011 sts_reg = SDIOx->sts;
2012
2013 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2014 {
2015 break;
2016 }
2017 }
2018
2019 if((timeout == 0) || sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2020 {
2021 status = SD_CMD_RSP_TIMEOUT;
2022 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2023
2024 return status;
2025 }
2026
2027 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2028 {
2029 status = SD_CMD_FAIL;
2030 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2031 }
2032
2033 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2034
2035 return status;
2036}
2037
2043 sd_error_status_type command_rsp4_error(uint8_t cmd)
2044{
2045 uint32_t sts_reg = 0, rsp_cmd = 0;
2046
2047 while(1)
2048 {
2049 sts_reg = SDIOx->sts;
2050
2051 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2052 {
2053 break;
2054 }
2055 }
2056
2057 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2058 {
2059 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2060 return SD_CMD_RSP_TIMEOUT;
2061 }
2062
2063 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2064 {
2065 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2066
2067 return SD_CMD_FAIL;
2068 }
2069
2070 rsp_cmd = sdio_command_response_get(SDIOx);
2071 if(rsp_cmd != cmd)
2072 {
2073 return SD_ILLEGAL_CMD;
2074 }
2075
2076 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2077
2078 return SD_OK;
2079}
2080
2086 sd_error_status_type command_rsp5_error(uint8_t cmd)
2087{
2088 uint32_t sts_reg = 0, rsp_cmd = 0, response = 0;
2089
2090 while(1)
2091 {
2092 sts_reg = SDIOx->sts;
2093
2094 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2095 {
2096 break;
2097 }
2098 }
2099
2100 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2101 {
2102 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2103
2104 return SD_CMD_RSP_TIMEOUT;
2105 }
2106
2107 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2108 {
2109 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2110
2111 return SD_CMD_FAIL;
2112 }
2113
2114 rsp_cmd = sdio_command_response_get(SDIOx);
2115 if(rsp_cmd != cmd)
2116 {
2117 return SD_ILLEGAL_CMD;
2118 }
2119
2120 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2121
2122 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2123
2124 if(response & SD_R5_OUT_OF_RANGE)
2125 {
2126 return SD_CMD_OUT_OF_RANGE;
2127 }
2128
2129 if(response & SD_R5_FUNCTION_NUMBER)
2130 {
2131 return SD_SDIO_UNKNOWN_FUNC;
2132 }
2133
2134 if(response & SD_R5_ERROR)
2135 {
2136 return SD_GENERAL_UNKNOWN_ERROR;
2137 }
2138
2139 return SD_OK;
2140}
2141
2149 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *prca)
2150{
2151 sd_error_status_type status = SD_OK;
2152 uint32_t sts_reg, rsp_cmd = 0, response = 0;
2153
2154 while(1)
2155 {
2156 sts_reg = SDIOx->sts;
2157
2158 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2159 {
2160 break;
2161 }
2162 }
2163
2164 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2165 {
2166 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2167 return SD_CMD_RSP_TIMEOUT;
2168 }
2169
2170 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2171 {
2172 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2173 return SD_CMD_FAIL;
2174 }
2175
2176 rsp_cmd = sdio_command_response_get(SDIOx);
2177 if(rsp_cmd != cmd)
2178 {
2179 return SD_ILLEGAL_CMD;
2180 }
2181
2182 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2183
2184 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2185
2186 if(SD_ALLZERO == (response & (SD_R6_GENERAL_UNKNOWN_ERROR | SD_R6_ILLEGAL_CMD | SD_R6_CMD_CRC_ERROR)))
2187 {
2188 *prca = (uint16_t)(response >> 16);
2189 return status;
2190 }
2191
2192 if(response & SD_R6_GENERAL_UNKNOWN_ERROR)
2193 {
2194 return SD_GENERAL_UNKNOWN_ERROR;
2195 }
2196
2197 if(response & SD_R6_ILLEGAL_CMD)
2198 {
2199 return SD_ILLEGAL_CMD;
2200 }
2201
2202 if(response & SD_R6_CMD_CRC_ERROR)
2203 {
2204 return SD_CMD_CRC_ERROR;
2205 }
2206
2207 return status;
2208}
2209
2215 sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
2216{
2217 sd_error_status_type status = SD_OK;
2218 uint32_t response = 0;
2219 uint8_t arg = 0x00;
2220
2221 if(new_state == TRUE)
2222 {
2223 arg = 0x02;
2224 }
2225 else
2226 {
2227 arg = 0x00;
2228 }
2229
2230 /* get response1 */
2231 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2232
2233 /* check card locked or not */
2234 if(response & SD_CARD_LOCKED)
2235 {
2236 return SD_LOCK_UNLOCK_ERROR;
2237 }
2238
2239 if(sd_card_info.sd_scr_reg.sd_bus_width)
2240 {
2241 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2242 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2243 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2244 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2245
2246 /* sdio command config */
2247 sdio_command_config(SDIOx, &sdio_command_init_struct);
2248 /* enable ccsm */
2249 sdio_command_state_machine_enable(SDIOx, TRUE);
2250
2251 status = command_rsp1_error(SD_CMD_APP_CMD);
2252
2253 if(status != SD_OK)
2254 {
2255 return status;
2256 }
2257
2258 sdio_command_init_struct.argument = arg;
2259 sdio_command_init_struct.cmd_index = SD_CMD_APP_SD_SET_BUSWIDTH;
2260 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2261 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2262
2263 /* sdio command config */
2264 sdio_command_config(SDIOx, &sdio_command_init_struct);
2265 /* enable ccsm */
2266 sdio_command_state_machine_enable(SDIOx, TRUE);
2267
2268 status = command_rsp1_error(SD_CMD_APP_SD_SET_BUSWIDTH);
2269 return status;
2270 }
2271 else
2272 {
2273 return SD_REQ_NOT_APPLICABLE;
2274 }
2275}
2276
2284 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
2285{
2286 sd_error_status_type status = SD_OK;
2287 uint32_t card_status = 0, timeout = 0;
2288
2289 sdio_command_init_struct.argument = (EXT_CSD_Write_byte << 24) | (index << 16) | (value << 8) | set;
2290 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2291 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2292 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2293
2294 /* sdio command config */
2295 sdio_command_config(SDIOx, &sdio_command_init_struct);
2296 /* enable ccsm */
2297 sdio_command_state_machine_enable(SDIOx, TRUE);
2298
2299 status = command_rsp1_error(SD_CMD_HS_SWITCH);
2300 if(status != SD_OK)
2301 {
2302 return status;
2303 }
2304
2305 card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2306 if(card_status & MMC_SWITCH_ERROR)
2307 {
2308 return SD_SWITCH_ERROR;
2309 }
2310
2311 timeout = SD_DATATIMEOUT;
2312 do
2313 {
2314 timeout--;
2315 status = sd_status_send(&card_status);
2316 } /* check ready_for_data flag */
2317 while(((card_status & 0x00000100) == 0) && (timeout > 0));
2318
2319 if(timeout == 0)
2320 {
2321 return SD_ERROR;
2322 }
2323
2324 return status;
2325}
2326
2335 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
2336{
2337 sd_error_status_type status = SD_OK;
2338 uint8_t power;
2339 uint16_t blk_size;
2340
2341 if(rsp == NULL)
2342 {
2343 return SD_INVALID_PARAMETER;
2344 }
2345
2346 SDIOx->dtctrl = 0x0;
2347
2348 blk_size = 64;
2349 power = convert_from_bytes_to_power_of_two(blk_size);
2350
2351 sdio_command_init_struct.argument = blk_size;
2352 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2353 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2354 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2355
2356 /* sdio command config */
2357 sdio_command_config(SDIOx, &sdio_command_init_struct);
2358 /* enable ccsm */
2359 sdio_command_state_machine_enable(SDIOx, TRUE);
2360
2361 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2362
2363 if(status != SD_OK)
2364 {
2365 return status;
2366 }
2367
2368 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
2369 sdio_data_init_struct.data_length = blk_size ;
2370 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
2371 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2372 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2373
2374 sdio_command_init_struct.argument = (mode << 31) | 0x00FFFFFF;
2375 sdio_command_init_struct.argument &= ~(0xF << (group * 4));
2376 sdio_command_init_struct.argument |= value << (group * 4);
2377 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2378 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2379 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2380
2381 stop_flag = 0;
2382
2383 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)rsp);
2384}
2385
2391 sd_error_status_type check_card_programming(uint8_t *p_status)
2392{
2393 volatile uint32_t response = 0, sts_reg = 0, rsp_cmd = 0;
2394
2395 /* send cmd13 */
2396 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2397 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2398 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2399 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2400
2401 /* sdio command config */
2402 sdio_command_config(SDIOx, &sdio_command_init_struct);
2403 /* enable ccsm */
2404 sdio_command_state_machine_enable(SDIOx, TRUE);
2405
2406 sts_reg = SDIOx->sts;
2407
2408 while(!(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG)))
2409 {
2410 sts_reg = SDIOx->sts;
2411 }
2412
2413 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2414 {
2415 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2416 return SD_CMD_FAIL;
2417 }
2418
2419 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2420 {
2421 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2422 return SD_CMD_RSP_TIMEOUT;
2423 }
2424
2425 rsp_cmd = sdio_command_response_get(SDIOx);
2426 if(rsp_cmd!= SD_CMD_SEND_STATUS)
2427 {
2428 return SD_ILLEGAL_CMD;
2429 }
2430
2431 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2432
2433 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2434
2435 *p_status = (uint8_t)((response >> 9) & 0x0000000F);
2436
2437 return SD_OK;
2438}
2439
2445 sd_error_status_type sd_status_send(uint32_t *p_card_status)
2446{
2447 sd_error_status_type status = SD_OK;
2448
2449 if(p_card_status == NULL)
2450 {
2451 status = SD_INVALID_PARAMETER;
2452 return status;
2453 }
2454
2455 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2456 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2457 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2458 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2459
2460 /* sdio command config */
2461 sdio_command_config(SDIOx, &sdio_command_init_struct);
2462 /* enable ccsm */
2463 sdio_command_state_machine_enable(SDIOx, TRUE);
2464
2465 status = command_rsp1_error(SD_CMD_SEND_STATUS);
2466
2467 if(status != SD_OK)
2468 {
2469 return status;
2470 }
2471
2472 *p_card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2473
2474 return status;
2475}
2476
2482 sd_card_state_type sd_state_get(void)
2483{
2484 uint32_t response = 0;
2485
2486 if(sd_status_send(&response) != SD_OK)
2487 {
2488 return SD_CARD_ERROR;
2489 }
2490 else
2491 {
2492 return (sd_card_state_type)((response >> 9) & 0x0F);
2493 }
2494}
2495
2500 sd_error_status_type scr_find(void)
2501{
2502 uint32_t index = 0, sts_reg = 0;
2503 sd_error_status_type status = SD_OK;
2504 uint32_t *tempscr;
2505
2506 tempscr = (uint32_t *) &(sd_card_info.sd_scr_reg);
2507
2508 /* send cmd16, set block length */
2509 sdio_command_init_struct.argument = (uint32_t)8;
2510 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2511 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2512 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2513
2514 /* sdio command config */
2515 sdio_command_config(SDIOx, &sdio_command_init_struct);
2516 /* enable ccsm */
2517 sdio_command_state_machine_enable(SDIOx, TRUE);
2518
2519 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2520
2521 if(status != SD_OK)
2522 {
2523 return status;
2524 }
2525
2526 /* send cmd55 */
2527 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2528 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2529 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2530 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2531
2532 /* sdio command config */
2533 sdio_command_config(SDIOx, &sdio_command_init_struct);
2534 /* enable ccsm */
2535 sdio_command_state_machine_enable(SDIOx, TRUE);
2536
2537 status = command_rsp1_error(SD_CMD_APP_CMD);
2538
2539 if(status != SD_OK)
2540 {
2541 return status;
2542 }
2543
2544 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_8B;
2545 sdio_data_init_struct.data_length = 8;
2546 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
2547 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2548 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2549
2550 sdio_data_config(SDIOx, &sdio_data_init_struct);
2551 sdio_data_state_machine_enable(SDIOx, TRUE);
2552
2553 /* send cmd51 */
2554 sdio_command_init_struct.argument = 0x0;
2555 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_SEND_SCR;
2556 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2557 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2558
2559 /* sdio command config */
2560 sdio_command_config(SDIOx, &sdio_command_init_struct);
2561 /* enable ccsm */
2562 sdio_command_state_machine_enable(SDIOx, TRUE);
2563
2564 status = command_rsp1_error(SD_CMD_SD_APP_SEND_SCR);
2565
2566 if(status != SD_OK)
2567 {
2568 return status;
2569 }
2570
2571 sts_reg = SDIOx->sts;
2572
2573 while(!(sts_reg & (SDIO_RXERRO_FLAG | SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_DTBLKCMPL_FLAG | SDIO_SBITERR_FLAG)))
2574 {
2575 if(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
2576 {
2577 *(tempscr + index) = sdio_data_read(SDIOx);
2578 index++;
2579 }
2580 sts_reg = SDIOx->sts;
2581 }
2582
2583 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
2584 {
2585 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
2586 return SD_DATA_TIMEOUT;
2587 }
2588 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
2589 {
2590 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
2591 return SD_DATA_FAIL;
2592 }
2593 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
2594 {
2595 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
2596 return SD_RX_OVERRUN;
2597 }
2598 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
2599 {
2600 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
2601 return SD_START_BIT_ERR;
2602 }
2603
2604 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2605
2606 return status;
2607}
2608
2614 sd_error_status_type speed_change(uint8_t speed)
2615{
2616 sd_error_status_type status = SD_OK;
2617 uint8_t switch_sts[64];
2618
2619 if(speed > 1)
2620 {
2621 return SD_ERROR;
2622 }
2623
2624 /* check card type */
2625 if((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
2626 (SDIO_HIGH_CAPACITY_SD_CARD == card_type))
2627 {
2628 /* version 1.01 card does not support cmd6 */
2629 if(sd_card_info.sd_scr_reg.sd_spec == 0)
2630 {
2631 return SD_ERROR;
2632 }
2633
2634 /* check group 1 function support speed */
2635 status = sd_switch(0, 0, speed, switch_sts);
2636
2637 if(status != 0)
2638 {
2639 return status;
2640 }
2641
2642 if((switch_sts[13] & (1 << speed)) == 0)
2643 {
2644 return SD_ERROR;
2645 }
2646
2647 status = sd_switch(1, 0, speed, switch_sts);
2648
2649 if(status != 0)
2650 {
2651 return status;
2652 }
2653
2654 /* read it back for confirmation */
2655 if((switch_sts[16] & 0xF) != speed)
2656 {
2657 return SD_ERROR;
2658 }
2659 }
2660 else if(card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
2661 {
2662 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)speed);
2663
2664 if(status != 0)
2665 {
2666 return status;
2667 }
2668 }
2669
2670 return status;
2671}
2672
2678uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
2679{
2680 uint8_t count = 0;
2681
2682 while(number_of_bytes != 1)
2683 {
2684 number_of_bytes >>= 1;
2685 count++;
2686 }
2687
2688 return count;
2689}
2690
2699void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
2700{
2701 dma_init_type dma_init_struct;
2702 dma_default_para_init(&dma_init_struct);
2703
2704 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
2705
2706 dma_reset(DMA2_CHANNEL4);
2707 dma_channel_enable(DMA2_CHANNEL4, FALSE);
2708
2709 dma_init_struct.peripheral_base_addr = (uint32_t)&SDIOx->buf;
2710 dma_init_struct.memory_base_addr = (uint32_t)mbuf;
2711 dma_init_struct.direction = dir;
2712 dma_init_struct.buffer_size = buf_size / 4;
2713 dma_init_struct.peripheral_inc_enable = FALSE;
2714 dma_init_struct.memory_inc_enable = TRUE;
2715 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
2716 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
2717 dma_init_struct.loop_mode_enable = FALSE;
2718 dma_init_struct.priority = DMA_PRIORITY_HIGH;
2719 dma_init(DMA2_CHANNEL4, &dma_init_struct);
2720
2721 dma_channel_enable(DMA2_CHANNEL4, TRUE);
2722}
2723
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:48
sd_switch
sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed
Definition: sd_mmc_card/src/at32_sdio.c:2335
command_rsp5_error
sd_error_status_type command_rsp5_error(uint8_t cmd)
checks for error conditions for r5 response.
Definition: sd_mmc_card/src/at32_sdio.c:2086
speed_change
sd_error_status_type speed_change(uint8_t speed)
set bus speed
Definition: sd_mmc_card/src/at32_sdio.c:2614
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: sd_mmc_card/src/at32_sdio.c:396
sdio_data_init_struct
sdio_data_struct_type sdio_data_init_struct
Definition: sd_mmc_card/src/at32_sdio.c:40
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: sd_mmc_card/src/at32_sdio.c:1782
transfer_end
volatile uint8_t transfer_end
Definition: sd_mmc_card/src/at32_sdio.c:47
command_rsp7_error
sd_error_status_type command_rsp7_error(void)
checks for error conditions for R7 response.
Definition: sd_mmc_card/src/at32_sdio.c:1893
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: sd_mmc_card/src/at32_sdio.c:779
card_type
static sd_memory_card_type card_type
Definition: sd_mmc_card/src/at32_sdio.c:42
convert_from_bytes_to_power_of_two
uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power.
Definition: sd_mmc_card/src/at32_sdio.c:2678
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: sd_mmc_card/src/at32_sdio.c:525
sdio_command_init_struct
sdio_command_struct_type sdio_command_init_struct
Definition: sd_mmc_card/src/at32_sdio.c:39
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1693
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: sd_mmc_card/src/at32_sdio.c:410
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1181
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: sd_mmc_card/src/at32_sdio.c:800
command_rsp6_error
sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca)
checks for error conditions for r6 (rca) response.
Definition: sd_mmc_card/src/at32_sdio.c:2149
SDIO1_IRQHandler
void SDIO1_IRQHandler(void)
sdio1 isr.
Definition: sd_mmc_card/src/at32_sdio.c:1762
stop_flag
static uint8_t stop_flag
Definition: sd_mmc_card/src/at32_sdio.c:45
mmc_switch
sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed
Definition: sd_mmc_card/src/at32_sdio.c:2284
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: sd_mmc_card/src/at32_sdio.c:1023
check_card_programming
sd_error_status_type check_card_programming(uint8_t *p_status)
checks if the sd card is in programming state.
Definition: sd_mmc_card/src/at32_sdio.c:2391
transfer_error
volatile sd_error_status_type transfer_error
Definition: sd_mmc_card/src/at32_sdio.c:46
sd_bus_wide_enable
sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
enable or disable the sdio wide bus mode.
Definition: sd_mmc_card/src/at32_sdio.c:2215
command_rsp1_error
sd_error_status_type command_rsp1_error(uint8_t cmd)
checks for error conditions for R1 response.
Definition: sd_mmc_card/src/at32_sdio.c:1930
SDIO2_IRQHandler
void SDIO2_IRQHandler(void)
sdio2 isr.
Definition: sd_mmc_card/src/at32_sdio.c:1772
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1482
csd_table
static uint32_t csd_table[4]
Definition: sd_mmc_card/src/at32_sdio.c:43
sdio_clock_set
void sdio_clock_set(uint32_t clk_div)
set sdio clock devision factor.
Definition: sd_mmc_card/src/at32_sdio.c:181
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: sd_mmc_card/src/at32_sdio.c:2482
cid_table
static uint32_t cid_table[4]
Definition: sd_mmc_card/src/at32_sdio.c:43
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: sd_mmc_card/src/at32_sdio.c:2699
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1360
device_mode
static sd_data_transfer_mode_type device_mode
Definition: sd_mmc_card/src/at32_sdio.c:44
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: sd_mmc_card/src/at32_sdio.c:2445
sdio_command_data_send
sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card.
Definition: sd_mmc_card/src/at32_sdio.c:823
command_rsp2_error
sd_error_status_type command_rsp2_error(void)
checks for error conditions for R2 (cid or csd) response.
Definition: sd_mmc_card/src/at32_sdio.c:2003
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1646
scr_find
sd_error_status_type scr_find(void)
find the sd card scr register value.
Definition: sd_mmc_card/src/at32_sdio.c:2500
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: sd_mmc_card/src/at32_sdio.c:196
command_rsp4_error
sd_error_status_type command_rsp4_error(uint8_t cmd)
checks for error conditions for r4 response.
Definition: sd_mmc_card/src/at32_sdio.c:2043
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1270
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sd_mmc_card/src/at32_sdio.c:736
rca
static uint32_t rca
Definition: sd_mmc_card/src/at32_sdio.c:43
command_rsp3_error
sd_error_status_type command_rsp3_error(void)
checks for error conditions for R3 (ocr) response.
Definition: sd_mmc_card/src/at32_sdio.c:1973
command_error
sd_error_status_type command_error(void)
checks for error conditions for cmd0.
Definition: sd_mmc_card/src/at32_sdio.c:1866
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:112
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f413_crm.h:105
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:216
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:247
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:257
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f413_dma.h:492
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
GPIOD
#define GPIOD
Definition: at32f413_gpio.h:751
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f413_sdio.c:340
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f413_sdio.c:501
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f413_sdio.c:427
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f413_sdio.c:476
sdio_power_status_get
flag_status sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f413_sdio.c:87
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f413_sdio.c:363
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f413_sdio.c:152
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f413_sdio.c:179
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f413_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f413_sdio.c:115
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f413_sdio.c:139
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f413_sdio.c:243
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f413_sdio.c:326
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f413_sdio.c:394
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f413_sdio.c:452
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f413_sdio.c:166
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f413_sdio.c:289
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f413_sdio.c:205
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f413_sdio.c:51
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f413_sdio.c:192
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f413_sdio.c:376
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:139
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f413_sdio.h:180
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f413_sdio.h:160
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f413_sdio.h:161
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f413_sdio.h:152
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f413_sdio.h:151
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f413_sdio.h:150
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f413_sdio.h:132
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f413_sdio.h:212
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f413_sdio.h:213
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f413_sdio.h:122
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f413_sdio.h:123
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f413_sdio.h:203
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f413_sdio.h:204
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f413_sdio.h:140
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f413_sdio.h:141
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f413_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f413_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f413_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f413_sdio.h:170
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f413_sdio.h:184
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f413_sdio.h:181
SDIO_CMDTIMEOUT_FLAG
#define SDIO_CMDTIMEOUT_FLAG
Definition: at32f413_sdio.h:87
SDIO_TXBUFH_FLAG
#define SDIO_TXBUFH_FLAG
Definition: at32f413_sdio.h:99
SDIO_CMDCMPL_FLAG
#define SDIO_CMDCMPL_FLAG
Definition: at32f413_sdio.h:92
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f413_sdio.h:86
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f413_sdio.h:90
SDIO_RXBUFH_FLAG
#define SDIO_RXBUFH_FLAG
Definition: at32f413_sdio.h:100
SDIO_RXBUF_FLAG
#define SDIO_RXBUF_FLAG
Definition: at32f413_sdio.h:106
SDIO_CMDFAIL_FLAG
#define SDIO_CMDFAIL_FLAG
Definition: at32f413_sdio.h:85
SDIO_CMDRSPCMPL_FLAG
#define SDIO_CMDRSPCMPL_FLAG
Definition: at32f413_sdio.h:91
SDIO_DTBLKCMPL_FLAG
#define SDIO_DTBLKCMPL_FLAG
Definition: at32f413_sdio.h:95
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f413_sdio.h:88
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f413_sdio.h:94
SDIO_DTCMPL_FLAG
#define SDIO_DTCMPL_FLAG
Definition: at32f413_sdio.h:93
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f413_sdio.h:89
SDIO_SBITERR_INT
#define SDIO_SBITERR_INT
Definition: at32f413_sdio.h:61
SDIO_RXBUFH_INT
#define SDIO_RXBUFH_INT
Definition: at32f413_sdio.h:67
SDIO_DTTIMEOUT_INT
#define SDIO_DTTIMEOUT_INT
Definition: at32f413_sdio.h:55
SDIO_TXERRU_INT
#define SDIO_TXERRU_INT
Definition: at32f413_sdio.h:56
SDIO_RXERRO_INT
#define SDIO_RXERRO_INT
Definition: at32f413_sdio.h:57
SDIO_DTFAIL_INT
#define SDIO_DTFAIL_INT
Definition: at32f413_sdio.h:53
SDIO_TXBUFH_INT
#define SDIO_TXBUFH_INT
Definition: at32f413_sdio.h:66
SDIO_DTCMP_INT
#define SDIO_DTCMP_INT
Definition: at32f413_sdio.h:60
SDIO_SEND_IF_COND
#define SDIO_SEND_IF_COND
Definition: sd_mmc_card/inc/at32_sdio.h:438
SD_CMD_SD_APP_SEND_SCR
#define SD_CMD_SD_APP_SEND_SCR
Definition: sd_mmc_card/inc/at32_sdio.h:308
SD_CMD_ERASE
#define SD_CMD_ERASE
Definition: sd_mmc_card/inc/at32_sdio.h:291
SD_CMD_APP_SD_SET_BUSWIDTH
#define SD_CMD_APP_SD_SET_BUSWIDTH
Definition: sd_mmc_card/inc/at32_sdio.h:303
SD_CMD_WRITE_SINGLE_BLOCK
#define SD_CMD_WRITE_SINGLE_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:280
SD_CMD_SD_ERASE_GRP_START
#define SD_CMD_SD_ERASE_GRP_START
Definition: sd_mmc_card/inc/at32_sdio.h:287
SD_CMD_APP_CMD
#define SD_CMD_APP_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:295
SD_CMD_ALL_SEND_CID
#define SD_CMD_ALL_SEND_CID
Definition: sd_mmc_card/inc/at32_sdio.h:260
SD_CMD_STOP_TRANSMISSION
#define SD_CMD_STOP_TRANSMISSION
Definition: sd_mmc_card/inc/at32_sdio.h:270
SD_CMD_SEND_STATUS
#define SD_CMD_SEND_STATUS
Definition: sd_mmc_card/inc/at32_sdio.h:271
SD_CMD_SET_BLOCK_COUNT
#define SD_CMD_SET_BLOCK_COUNT
Definition: sd_mmc_card/inc/at32_sdio.h:279
SD_CMD_WRITE_DAT_UNTIL_STOP
#define SD_CMD_WRITE_DAT_UNTIL_STOP
Definition: sd_mmc_card/inc/at32_sdio.h:278
SD_CMD_SEND_OP_COND
#define SD_CMD_SEND_OP_COND
Definition: sd_mmc_card/inc/at32_sdio.h:259
SD_CMD_SET_BLOCKLEN
#define SD_CMD_SET_BLOCKLEN
Definition: sd_mmc_card/inc/at32_sdio.h:274
SD_CMD_HS_SWITCH
#define SD_CMD_HS_SWITCH
Definition: sd_mmc_card/inc/at32_sdio.h:264
SD_CMD_READ_SINGLE_BLOCK
#define SD_CMD_READ_SINGLE_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:275
SD_CMD_SD_APP_OP_COND
#define SD_CMD_SD_APP_OP_COND
Definition: sd_mmc_card/inc/at32_sdio.h:306
SD_CMD_GO_IDLE_STATE
#define SD_CMD_GO_IDLE_STATE
Definition: sd_mmc_card/inc/at32_sdio.h:258
SD_CMD_SET_REL_ADDR
#define SD_CMD_SET_REL_ADDR
Definition: sd_mmc_card/inc/at32_sdio.h:261
SD_CMD_ERASE_GRP_END
#define SD_CMD_ERASE_GRP_END
Definition: sd_mmc_card/inc/at32_sdio.h:290
SD_CMD_READ_DAT_UNTIL_STOP
#define SD_CMD_READ_DAT_UNTIL_STOP
Definition: sd_mmc_card/inc/at32_sdio.h:269
SD_CMD_SD_ERASE_GRP_END
#define SD_CMD_SD_ERASE_GRP_END
Definition: sd_mmc_card/inc/at32_sdio.h:288
SD_CMD_ERASE_GRP_START
#define SD_CMD_ERASE_GRP_START
Definition: sd_mmc_card/inc/at32_sdio.h:289
SD_CMD_SEL_DESEL_CARD
#define SD_CMD_SEL_DESEL_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:265
SD_CMD_WRITE_MULT_BLOCK
#define SD_CMD_WRITE_MULT_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:281
SD_CMD_READ_MULT_BLOCK
#define SD_CMD_READ_MULT_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:276
SD_CMD_SEND_CSD
#define SD_CMD_SEND_CSD
Definition: sd_mmc_card/inc/at32_sdio.h:267
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: sd_mmc_card/inc/at32_sdio.h:65
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:74
sd_card_state_type
sd_card_state_type
Definition: sd_mmc_card/inc/at32_sdio.h:187
sd_memory_card_type
sd_memory_card_type
Definition: sd_mmc_card/inc/at32_sdio.h:203
SDIOx
#define SDIOx
Definition: sd_mmc_card/inc/at32_sdio.h:51
SDIO_INTR_STS_WRITE_MASK
#define SDIO_INTR_STS_WRITE_MASK
Definition: sd_mmc_card/inc/at32_sdio.h:474
SDIO_INTR_STS_READ_MASK
#define SDIO_INTR_STS_READ_MASK
Definition: sd_mmc_card/inc/at32_sdio.h:476
EXT_CSD_BUS_WIDTH
#define EXT_CSD_BUS_WIDTH
Definition: sd_mmc_card/inc/at32_sdio.h:463
EXT_CSD_CMD_SET_NORMAL
#define EXT_CSD_CMD_SET_NORMAL
Definition: sd_mmc_card/inc/at32_sdio.h:456
EXT_CSD_Write_byte
#define EXT_CSD_Write_byte
Definition: sd_mmc_card/inc/at32_sdio.h:454
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
SDIO_DATATIMEOUT
#define SDIO_DATATIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:342
SDIO_CMD0TIMEOUT
#define SDIO_CMD0TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:341
SDIO_STATIC_FLAGS
#define SDIO_STATIC_FLAGS
Definition: sd_mmc_card/inc/at32_sdio.h:340
SD_CARD_LOCKED
#define SD_CARD_LOCKED
Definition: sd_mmc_card/inc/at32_sdio.h:400
SD_VOLTAGE_WINDOW_SD
#define SD_VOLTAGE_WINDOW_SD
Definition: sd_mmc_card/inc/at32_sdio.h:391
SD_R5_ERROR
#define SD_R5_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:383
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: sd_mmc_card/inc/at32_sdio.h:402
SD_R5_OUT_OF_RANGE
#define SD_R5_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:381
SD_MAX_DATA_LENGTH
#define SD_MAX_DATA_LENGTH
Definition: sd_mmc_card/inc/at32_sdio.h:408
SD_STD_CAPACITY
#define SD_STD_CAPACITY
Definition: sd_mmc_card/inc/at32_sdio.h:393
SD_R5_FUNCTION_NUMBER
#define SD_R5_FUNCTION_NUMBER
Definition: sd_mmc_card/inc/at32_sdio.h:382
SD_R6_ILLEGAL_CMD
#define SD_R6_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:389
SD_R6_GENERAL_UNKNOWN_ERROR
#define SD_R6_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:388
SD_MAX_VOLT_TRIAL
#define SD_MAX_VOLT_TRIAL
Definition: sd_mmc_card/inc/at32_sdio.h:396
SD_DATATIMEOUT
#define SD_DATATIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:403
SD_ALLZERO
#define SD_ALLZERO
Definition: sd_mmc_card/inc/at32_sdio.h:397
SD_R6_CMD_CRC_ERROR
#define SD_R6_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:390
MMC_SWITCH_ERROR
#define MMC_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:374
SD_VOLTAGE_WINDOW_MMC
#define SD_VOLTAGE_WINDOW_MMC
Definition: sd_mmc_card/inc/at32_sdio.h:395
SD_CHECK_PATTERN
#define SD_CHECK_PATTERN
Definition: sd_mmc_card/inc/at32_sdio.h:394
SD_OCR_ERRORBITS
#define SD_OCR_ERRORBITS
Definition: sd_mmc_card/inc/at32_sdio.h:376
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: sd_mmc_card/inc/at32_sdio.h:401
SD_HIGH_CAPACITY
#define SD_HIGH_CAPACITY
Definition: sd_mmc_card/inc/at32_sdio.h:392
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:67
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:66
SD_ERROR
@ SD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:118
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: sd_mmc_card/inc/at32_sdio.h:108
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:77
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: sd_mmc_card/inc/at32_sdio.h:115
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:76
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:83
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:94
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: sd_mmc_card/inc/at32_sdio.h:116
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:80
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:91
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:90
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:81
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: sd_mmc_card/inc/at32_sdio.h:114
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:104
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: sd_mmc_card/inc/at32_sdio.h:102
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:79
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:82
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:89
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:78
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:119
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:196
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:206
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:210
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sd_mmc_card/inc/at32_sdio.h:204
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:208
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sd_mmc_card/inc/at32_sdio.h:205
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:207
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
sd_card_info_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:237
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::rca
uint16_t rca
Definition: sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: sd_mmc_card/inc/at32_sdio.h:244
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: sd_mmc_card/inc/at32_sdio.h:179
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: sd_mmc_card/inc/at32_sdio.h:171
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: sd_mmc_card/inc/at32_sdio.h:173
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:180
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: sd_mmc_card/inc/at32_sdio.h:172
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::nsac
uint8_t nsac
Definition: sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: sd_mmc_card/inc/at32_sdio.h:163
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::device_size
uint32_t device_size
Definition: sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: sd_mmc_card/inc/at32_sdio.h:127
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:143
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: sd_mmc_card/inc/at32_sdio.h:162
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::taac
uint8_t taac
Definition: sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:146
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:145
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: sd_mmc_card/inc/at32_sdio.h:222
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: sd_mmc_card/inc/at32_sdio.h:220
sdio_command_struct_type
sdio command structure
Definition: at32f413_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f413_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f413_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f413_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f413_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f413_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f413_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f413_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f413_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f413_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f413_sdio.h:242


AT32F413 Firmwary Library: at32_sdio.h Source File

  • sdio
  • sdio_fatfs
  • inc
sdio_fatfs/inc/at32_sdio.h
Go to the documentation of this file.
1
28/* define to prevent recursive inclusion -------------------------------------*/
29#ifndef __AT32_SDIO_H
30#define __AT32_SDIO_H
31
32#ifdef __cplusplus
33extern "C" {
34#endif
35
36/* includes ------------------------------------------------------------------*/
37#include "at32f413.h"
38
51#define SDIOx SDIO1
52
64typedef enum
65{
66 SD_TRANSFER_POLLING_MODE = 0,
67 SD_TRANSFER_DMA_MODE = 1
68} sd_data_transfer_mode_type;
69
73typedef enum
74{
75 /* sdio specific error defines ------------------------------------------*/
76 SD_CMD_FAIL = 1,
77 SD_DATA_FAIL = 2,
78 SD_CMD_RSP_TIMEOUT = 3,
79 SD_DATA_TIMEOUT = 4,
80 SD_TX_UNDERRUN = 5,
81 SD_RX_OVERRUN = 6,
82 SD_START_BIT_ERR = 7,
83 SD_CMD_OUT_OF_RANGE = 8,
84 SD_ADDR_MISALIGNED = 9,
85 SD_BLK_LEN_ERR = 10,
86 SD_ERASE_SEQ_ERR = 11,
87 SD_INVALID_ERASE_PARAM = 12,
88 SD_WR_PROTECT_VIOLATION = 13,
89 SD_LOCK_UNLOCK_ERROR = 14,
90 SD_CMD_CRC_ERROR = 15,
91 SD_ILLEGAL_CMD = 16,
92 SD_CARD_ECC_ERROR = 17,
93 SD_CARD_CONTROLLER_ERR = 18,
94 SD_GENERAL_UNKNOWN_ERROR = 19,
95 SD_STREAM_RD_UNDERRUN = 20,
96 SD_STREAM_WR_OVERRUN = 21,
97 SD_CID_CSD_OVERWRITE = 22,
98 SD_WP_ERASE_SKIP = 23,
99 SD_CARD_ECC_DISABLED = 24,
100 SD_ERASE_RESET = 25,
101 SD_AKE_SEQ_ERROR = 26,
102 SD_INVALID_VOLTRANGE = 27,
103 SD_ADDR_OUT_OF_RANGE = 28,
104 SD_SWITCH_ERROR = 29,
105 SD_SDIO_DISABLED = 30,
106 SD_SDIO_FUNC_BUSY = 31,
107 SD_SDIO_FUNC_ERROR = 32,
108 SD_SDIO_UNKNOWN_FUNC = 33,
110 /* standard error defines --------------------------------------------*/
111 SD_INTERNAL_ERROR,
112 SD_NOT_CONFIGURED,
113 SD_REQ_PENDING,
114 SD_REQ_NOT_APPLICABLE,
115 SD_INVALID_PARAMETER,
116 SD_UNSUPPORTED_FEATURE,
117 SD_UNSUPPORTED_HW,
118 SD_ERROR,
119 SD_OK = 0
120} sd_error_status_type;
121
125typedef struct
126{
127 uint8_t csd_struct;
128 uint8_t spec_version;
129 uint8_t reserved1;
130 uint8_t taac;
131 uint8_t nsac;
132 uint8_t max_bus_clk_freq;
133 uint16_t card_cmd_classes;
134 uint8_t max_read_blk_length;
135 uint8_t part_blk_read;
136 uint8_t write_blk_misalign;
137 uint8_t read_blk_misalign;
138 uint8_t dsr_implemented;
139 uint8_t reserved2;
140 uint32_t device_size;
141 uint8_t max_read_current_vdd_min;
142 uint8_t max_read_current_vdd_max;
143 uint8_t max_write_current_vdd_min;
144 uint8_t max_write_current_vdd_max;
145 uint8_t device_size_mult;
146 uint8_t erase_group_size;
147 uint8_t erase_group_size_mult;
148 uint8_t write_protect_group_size;
149 uint8_t write_protect_group_enable;
150 uint8_t manufacturer_default_ecc;
151 uint8_t write_speed_factor;
152 uint8_t max_write_blk_length;
153 uint8_t part_blk_write;
154 uint8_t reserved3;
155 uint8_t content_protect_app;
156 uint8_t file_format_group;
157 uint8_t copy_flag;
158 uint8_t permanent_write_protect;
159 uint8_t temp_write_protect;
160 uint8_t file_formart;
161 uint8_t ecc_code;
162 uint8_t csd_crc;
163 uint8_t reserved4;
164} sd_csd_struct_type;
165
169typedef struct
170{
171 uint8_t manufacturer_id;
172 uint16_t oem_app_id;
173 uint32_t product_name1;
174 uint8_t product_name2;
175 uint8_t product_reversion;
176 uint32_t product_sn;
177 uint8_t reserved1;
178 uint16_t manufact_date;
179 uint8_t cid_crc;
180 uint8_t reserved2;
181} sd_cid_struct_type;
182
186typedef enum
187{
188 SD_CARD_READY = ((uint32_t)0x00000001),
189 SD_CARD_IDENTIFICATION = ((uint32_t)0x00000002),
190 SD_CARD_STANDBY = ((uint32_t)0x00000003),
191 SD_CARD_TRANSFER = ((uint32_t)0x00000004),
192 SD_CARD_SENDING = ((uint32_t)0x00000005),
193 SD_CARD_RECEIVING = ((uint32_t)0x00000006),
194 SD_CARD_PROGRAMMING = ((uint32_t)0x00000007),
195 SD_CARD_DISCONNECTED = ((uint32_t)0x00000008),
196 SD_CARD_ERROR = ((uint32_t)0x000000FF)
197} sd_card_state_type;
198
202typedef enum
203{
204 SDIO_STD_CAPACITY_SD_CARD_V1_1 = 0,
205 SDIO_STD_CAPACITY_SD_CARD_V2_0 = 1,
206 SDIO_HIGH_CAPACITY_SD_CARD = 2,
207 SDIO_MULTIMEDIA_CARD = 3,
208 SDIO_SECURE_DIGITAL_IO_CARD = 4,
209 SDIO_HIGH_SPEED_MULTIMEDIA_CARD = 5,
210 SDIO_SECURE_DIGITAL_IO_COMBO_CARD = 6,
211 SDIO_HIGH_CAPACITY_MMC_CARD = 7,
212 SDIO_SDIO_CARD = 8
213} sd_memory_card_type;
214
218typedef struct
219{
220 uint32_t sd_spec :4; /* [59:56] */
221 uint32_t scr_structure :4; /* [60:63] */
222 uint32_t sd_bus_width :4; /* [51:48] */
223 uint32_t sd_security :3; /* [52:54] */
224 uint32_t data_stat_after_erase :1; /* [55:55] */
225 uint32_t reserved1 :7; /* [46:40] */
226 uint32_t sd_spec3 :1; /* [47:47] */
227 uint32_t cmd20_support :1; /* [32:32] */
228 uint32_t cmd23_support :1; /* [33:33] */
229 uint32_t reserverd2 :6; /* [34:39] */
230 uint32_t reserverd3; /* [31:0] */
231} sd_scr_struct_type;
232
236typedef struct
237{
238 sd_csd_struct_type sd_csd_reg;
239 sd_cid_struct_type sd_cid_reg;
240 sd_scr_struct_type sd_scr_reg;
241 long long card_capacity;
242 uint32_t card_blk_size;
243 uint16_t rca;
244 uint8_t card_type;
245} sd_card_info_struct_type;
246
258#define SD_CMD_GO_IDLE_STATE ((uint8_t)0)
259#define SD_CMD_SEND_OP_COND ((uint8_t)1)
260#define SD_CMD_ALL_SEND_CID ((uint8_t)2)
261#define SD_CMD_SET_REL_ADDR ((uint8_t)3)
262#define SD_CMD_SET_DSR ((uint8_t)4)
263#define SD_CMD_SDIO_SEN_OP_COND ((uint8_t)5)
264#define SD_CMD_HS_SWITCH ((uint8_t)6)
265#define SD_CMD_SEL_DESEL_CARD ((uint8_t)7)
266#define SD_CMD_HS_SEND_EXT_CSD ((uint8_t)8)
267#define SD_CMD_SEND_CSD ((uint8_t)9)
268#define SD_CMD_SEND_CID ((uint8_t)10)
269#define SD_CMD_READ_DAT_UNTIL_STOP ((uint8_t)11)
270#define SD_CMD_STOP_TRANSMISSION ((uint8_t)12)
271#define SD_CMD_SEND_STATUS ((uint8_t)13)
272#define SD_CMD_HS_BUSTEST_READ ((uint8_t)14)
273#define SD_CMD_GO_INACTIVE_STATE ((uint8_t)15)
274#define SD_CMD_SET_BLOCKLEN ((uint8_t)16)
275#define SD_CMD_READ_SINGLE_BLOCK ((uint8_t)17)
276#define SD_CMD_READ_MULT_BLOCK ((uint8_t)18)
277#define SD_CMD_HS_BUSTEST_WRITE ((uint8_t)19)
278#define SD_CMD_WRITE_DAT_UNTIL_STOP ((uint8_t)20)
279#define SD_CMD_SET_BLOCK_COUNT ((uint8_t)23)
280#define SD_CMD_WRITE_SINGLE_BLOCK ((uint8_t)24)
281#define SD_CMD_WRITE_MULT_BLOCK ((uint8_t)25)
282#define SD_CMD_PROG_CID ((uint8_t)26)
283#define SD_CMD_PROG_CSD ((uint8_t)27)
284#define SD_CMD_SET_WRITE_PROT ((uint8_t)28)
285#define SD_CMD_CLR_WRITE_PROT ((uint8_t)29)
286#define SD_CMD_SEND_WRITE_PROT ((uint8_t)30)
287#define SD_CMD_SD_ERASE_GRP_START ((uint8_t)32)
288#define SD_CMD_SD_ERASE_GRP_END ((uint8_t)33)
289#define SD_CMD_ERASE_GRP_START ((uint8_t)35)
290#define SD_CMD_ERASE_GRP_END ((uint8_t)36)
291#define SD_CMD_ERASE ((uint8_t)38)
292#define SD_CMD_FAST_IO ((uint8_t)39)
293#define SD_CMD_GO_IRQ_STATE ((uint8_t)40)
294#define SD_CMD_LOCK_UNLOCK ((uint8_t)42)
295#define SD_CMD_APP_CMD ((uint8_t)55)
296#define SD_CMD_GEN_CMD ((uint8_t)56)
297#define SD_CMD_NO_CMD ((uint8_t)64)
298
303#define SD_CMD_APP_SD_SET_BUSWIDTH ((uint8_t)6)
304#define SD_CMD_SD_APP_STAUS ((uint8_t)13)
305#define SD_CMD_SD_APP_SEND_NUM_WRITE_BLOCKS ((uint8_t)22)
306#define SD_CMD_SD_APP_OP_COND ((uint8_t)41)
307#define SD_CMD_SD_APP_SET_CLR_CARD_DETECT ((uint8_t)42)
308#define SD_CMD_SD_APP_SEND_SCR ((uint8_t)51)
309#define SD_CMD_SDIO_RW_DIRECT ((uint8_t)52)
310#define SD_CMD_SDIO_RW_EXTENDED ((uint8_t)53)
311
316#define SD_CMD_SD_APP_GET_MKB ((uint8_t)43)
317#define SD_CMD_SD_APP_GET_MID ((uint8_t)44)
318#define SD_CMD_SD_APP_SET_CER_RN1 ((uint8_t)45)
319#define SD_CMD_SD_APP_GET_CER_RN2 ((uint8_t)46)
320#define SD_CMD_SD_APP_SET_CER_RES2 ((uint8_t)47)
321#define SD_CMD_SD_APP_GET_CER_RES1 ((uint8_t)48)
322#define SD_CMD_SD_APP_SECURE_READ_MULTIPLE_BLOCK ((uint8_t)18)
323#define SD_CMD_SD_APP_SECURE_WRITE_MULTIPLE_BLOCK ((uint8_t)25)
324#define SD_CMD_SD_APP_SECURE_ERASE ((uint8_t)38)
325#define SD_CMD_SD_APP_CHANGE_SECURE_AREA ((uint8_t)49)
326#define SD_CMD_SD_APP_SECURE_WRITE_MKB ((uint8_t)48)
327
339#define NULL 0
340#define SDIO_STATIC_FLAGS ((uint32_t)0x000005FF)
341#define SDIO_CMD0TIMEOUT ((uint32_t)0x00010000)
342#define SDIO_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
343#define SDIO_FIFO_Address ((uint32_t)0x40018080)
344
356#define SD_OCR_ADDR_OUT_OF_RANGE ((uint32_t)0x80000000)
357#define SD_OCR_ADDR_MISALIGNED ((uint32_t)0x40000000)
358#define SD_OCR_BLK_LEN_ERR ((uint32_t)0x20000000)
359#define SD_OCR_ERASE_SEQ_ERR ((uint32_t)0x10000000)
360#define SD_OCR_INVALID_ERASE_PARAM ((uint32_t)0x08000000)
361#define SD_OCR_WR_PROTECT_VIOLATION ((uint32_t)0x04000000)
362#define SD_OCR_LOCK_UNLOCK_ERROR ((uint32_t)0x01000000)
363#define SD_OCR_CMD_CRC_ERROR ((uint32_t)0x00800000)
364#define SD_OCR_ILLEGAL_CMD ((uint32_t)0x00400000)
365#define SD_OCR_CARD_ECC_ERROR ((uint32_t)0x00200000)
366#define SD_OCR_CARD_CONTROLLER_ERR ((uint32_t)0x00100000)
367#define SD_OCR_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00080000)
368#define SD_OCR_STREAM_RD_UNDERRUN ((uint32_t)0x00040000)
369#define SD_OCR_STREAM_WR_OVERRUN ((uint32_t)0x00020000)
370#define SD_OCR_CID_CSD_OVERWRIETE ((uint32_t)0x00010000)
371#define SD_OCR_WP_ERASE_SKIP ((uint32_t)0x00008000)
372#define SD_OCR_CARD_ECC_DISABLED ((uint32_t)0x00004000)
373#define SD_OCR_ERASE_RESET ((uint32_t)0x00002000)
374#define MMC_SWITCH_ERROR ((uint32_t)0x00000080)
375#define SD_OCR_AKE_SEQ_ERROR ((uint32_t)0x00000008)
376#define SD_OCR_ERRORBITS ((uint32_t)0xFDFFE008)
377
381#define SD_R5_OUT_OF_RANGE ((uint32_t)0x00000100)
382#define SD_R5_FUNCTION_NUMBER ((uint32_t)0x00000200)
383#define SD_R5_ERROR ((uint32_t)0x00000800)
384
388#define SD_R6_GENERAL_UNKNOWN_ERROR ((uint32_t)0x00002000)
389#define SD_R6_ILLEGAL_CMD ((uint32_t)0x00004000)
390#define SD_R6_CMD_CRC_ERROR ((uint32_t)0x00008000)
391#define SD_VOLTAGE_WINDOW_SD ((uint32_t)0x80100000)
392#define SD_HIGH_CAPACITY ((uint32_t)0x40000000)
393#define SD_STD_CAPACITY ((uint32_t)0x00000000)
394#define SD_CHECK_PATTERN ((uint32_t)0x000001AA)
395#define SD_VOLTAGE_WINDOW_MMC ((uint32_t)0x80FF8000)
396#define SD_MAX_VOLT_TRIAL ((uint32_t)0x000000FF)
397#define SD_ALLZERO ((uint32_t)0x00000000)
398#define SD_WIDE_BUS_SUPPORT ((uint32_t)0x00040000)
399#define SD_SINGLE_BUS_SUPPORT ((uint32_t)0x00010000)
400#define SD_CARD_LOCKED ((uint32_t)0x02000000)
401#define SD_CARD_PROGRAMMING ((uint32_t)0x00000007)
402#define SD_CARD_RECEIVING ((uint32_t)0x00000006)
403#define SD_DATATIMEOUT ((uint32_t)0xFFFFFFFF)
404#define SD_0TO7BITS ((uint32_t)0x000000FF)
405#define SD_8TO15BITS ((uint32_t)0x0000FF00)
406#define SD_16TO23BITS ((uint32_t)0x00FF0000)
407#define SD_24TO31BITS ((uint32_t)0xFF000000)
408#define SD_MAX_DATA_LENGTH ((uint32_t)0x01FFFFFF)
409#define SD_HALFFIFO ((uint32_t)0x00000008)
410#define SD_HALFFIFOBYTES ((uint32_t)0x00000020)
411
423#define SD_CCCC_LOCK_UNLOCK ((uint32_t)0x00000080)
424#define SD_CCCC_WRITE_PROT ((uint32_t)0x00000040)
425#define SD_CCCC_ERASE ((uint32_t)0x00000020)
426
438#define SDIO_SEND_IF_COND ((uint32_t)0x00000008)
439
451#define EXT_CSD_Command_set 0x0
452#define EXT_CSD_Set_bit 0x1
453#define EXT_CSD_Clear_byte 0x2
454#define EXT_CSD_Write_byte 0x3
455
456#define EXT_CSD_CMD_SET_NORMAL (1<<0)
457#define EXT_CSD_CMD_SET_SECURE (1<<1)
458#define EXT_CSD_CMD_SET_CPSECURE (1<<2)
459
463#define EXT_CSD_BUS_WIDTH 183
464#define EXT_CSD_HS_TIMING 185
465
474#define SDIO_INTR_STS_WRITE_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_TXERRU_FLAG | \
475 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
476#define SDIO_INTR_STS_READ_MASK (SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_RXERRO_FLAG | \
477 SDIO_DTCMPL_FLAG | SDIO_SBITERR_FLAG)
482extern sd_card_info_struct_type sd_card_info;
483
488/* sd exported functions ----------------------------------------*/
489 sd_error_status_type sd_init(void);
490void sdio_clock_set(uint32_t clkdiv);
491 sd_error_status_type sd_power_on(void);
492 sd_error_status_type sd_power_off(void);
493 sd_error_status_type sd_card_init(void);
494 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info);
495 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode);
496 sd_error_status_type sd_device_mode_set(uint32_t mode);
497 sd_error_status_type sd_deselect_select(uint32_t addr);
498 sd_error_status_type sd_status_send(uint32_t *p_card_status);
499 sd_card_state_type sd_state_get(void);
500 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks);
501 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size);
502 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
503 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size);
504 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks);
505 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len);
506 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len);
507 sd_error_status_type sd_irq_service(void);
508void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir);
509
522#ifdef __cplusplus
523}
524#endif
525
526#endif /* __AT32_SDIO_H */
at32f413.h
at32f413 header file
card_type
static sd_memory_card_type card_type
Definition: sd_mmc_card/src/at32_sdio.c:42
rca
static uint32_t rca
Definition: sd_mmc_card/src/at32_sdio.c:43
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sd_mmc_card/src/at32_sdio.c:48
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:216
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:139
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:74
sd_card_state_type
sd_card_state_type
Definition: sd_mmc_card/inc/at32_sdio.h:187
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: sd_mmc_card/src/at32_sdio.c:396
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: sd_mmc_card/src/at32_sdio.c:1782
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: sd_mmc_card/src/at32_sdio.c:779
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: sd_mmc_card/src/at32_sdio.c:525
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1693
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: sd_mmc_card/src/at32_sdio.c:410
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sd_mmc_card/src/at32_sdio.c:1181
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: sd_mmc_card/src/at32_sdio.c:800
sdio_clock_set
void sdio_clock_set(uint32_t clkdiv)
set sdio clock devision factor.
Definition: sd_mmc_card/src/at32_sdio.c:181
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: sd_mmc_card/src/at32_sdio.c:1023
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sd_mmc_card/src/at32_sdio.c:1482
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: sd_mmc_card/src/at32_sdio.c:2482
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: sd_mmc_card/src/at32_sdio.c:2699
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sd_mmc_card/src/at32_sdio.c:1360
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: sd_mmc_card/src/at32_sdio.c:2445
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sd_mmc_card/src/at32_sdio.c:72
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sd_mmc_card/src/at32_sdio.c:1646
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: sd_mmc_card/src/at32_sdio.c:196
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sd_mmc_card/src/at32_sdio.c:1270
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sd_mmc_card/src/at32_sdio.c:736
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: sdio_fatfs/inc/at32_sdio.h:65
sd_error_status_type
sd_error_status_type
Definition: sdio_fatfs/inc/at32_sdio.h:74
sd_card_state_type
sd_card_state_type
Definition: sdio_fatfs/inc/at32_sdio.h:187
sd_memory_card_type
sd_memory_card_type
Definition: sdio_fatfs/inc/at32_sdio.h:203
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: sdio_fatfs/inc/at32_sdio.h:67
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: sdio_fatfs/inc/at32_sdio.h:66
SD_ERROR
@ SD_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:118
SD_WP_ERASE_SKIP
@ SD_WP_ERASE_SKIP
Definition: sdio_fatfs/inc/at32_sdio.h:98
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: sdio_fatfs/inc/at32_sdio.h:108
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: sdio_fatfs/inc/at32_sdio.h:77
SD_STREAM_WR_OVERRUN
@ SD_STREAM_WR_OVERRUN
Definition: sdio_fatfs/inc/at32_sdio.h:96
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: sdio_fatfs/inc/at32_sdio.h:115
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: sdio_fatfs/inc/at32_sdio.h:76
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: sdio_fatfs/inc/at32_sdio.h:83
SD_UNSUPPORTED_HW
@ SD_UNSUPPORTED_HW
Definition: sdio_fatfs/inc/at32_sdio.h:117
SD_SDIO_FUNC_ERROR
@ SD_SDIO_FUNC_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:107
SD_INTERNAL_ERROR
@ SD_INTERNAL_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:111
SD_INVALID_ERASE_PARAM
@ SD_INVALID_ERASE_PARAM
Definition: sdio_fatfs/inc/at32_sdio.h:87
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:94
SD_CARD_ECC_DISABLED
@ SD_CARD_ECC_DISABLED
Definition: sdio_fatfs/inc/at32_sdio.h:99
SD_CARD_CONTROLLER_ERR
@ SD_CARD_CONTROLLER_ERR
Definition: sdio_fatfs/inc/at32_sdio.h:93
SD_ERASE_RESET
@ SD_ERASE_RESET
Definition: sdio_fatfs/inc/at32_sdio.h:100
SD_CARD_ECC_ERROR
@ SD_CARD_ECC_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:92
SD_STREAM_RD_UNDERRUN
@ SD_STREAM_RD_UNDERRUN
Definition: sdio_fatfs/inc/at32_sdio.h:95
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: sdio_fatfs/inc/at32_sdio.h:116
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: sdio_fatfs/inc/at32_sdio.h:80
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: sdio_fatfs/inc/at32_sdio.h:91
SD_SDIO_FUNC_BUSY
@ SD_SDIO_FUNC_BUSY
Definition: sdio_fatfs/inc/at32_sdio.h:106
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:90
SD_ADDR_OUT_OF_RANGE
@ SD_ADDR_OUT_OF_RANGE
Definition: sdio_fatfs/inc/at32_sdio.h:103
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: sdio_fatfs/inc/at32_sdio.h:81
SD_REQ_PENDING
@ SD_REQ_PENDING
Definition: sdio_fatfs/inc/at32_sdio.h:113
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: sdio_fatfs/inc/at32_sdio.h:114
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:104
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: sdio_fatfs/inc/at32_sdio.h:102
SD_SDIO_DISABLED
@ SD_SDIO_DISABLED
Definition: sdio_fatfs/inc/at32_sdio.h:105
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: sdio_fatfs/inc/at32_sdio.h:79
SD_ADDR_MISALIGNED
@ SD_ADDR_MISALIGNED
Definition: sdio_fatfs/inc/at32_sdio.h:84
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: sdio_fatfs/inc/at32_sdio.h:82
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:89
SD_NOT_CONFIGURED
@ SD_NOT_CONFIGURED
Definition: sdio_fatfs/inc/at32_sdio.h:112
SD_CID_CSD_OVERWRITE
@ SD_CID_CSD_OVERWRITE
Definition: sdio_fatfs/inc/at32_sdio.h:97
SD_WR_PROTECT_VIOLATION
@ SD_WR_PROTECT_VIOLATION
Definition: sdio_fatfs/inc/at32_sdio.h:88
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: sdio_fatfs/inc/at32_sdio.h:78
SD_BLK_LEN_ERR
@ SD_BLK_LEN_ERR
Definition: sdio_fatfs/inc/at32_sdio.h:85
SD_OK
@ SD_OK
Definition: sdio_fatfs/inc/at32_sdio.h:119
SD_ERASE_SEQ_ERR
@ SD_ERASE_SEQ_ERR
Definition: sdio_fatfs/inc/at32_sdio.h:86
SD_AKE_SEQ_ERROR
@ SD_AKE_SEQ_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:101
SD_CARD_TRANSFER
@ SD_CARD_TRANSFER
Definition: sdio_fatfs/inc/at32_sdio.h:191
SD_CARD_IDENTIFICATION
@ SD_CARD_IDENTIFICATION
Definition: sdio_fatfs/inc/at32_sdio.h:189
SD_CARD_SENDING
@ SD_CARD_SENDING
Definition: sdio_fatfs/inc/at32_sdio.h:192
SD_CARD_STANDBY
@ SD_CARD_STANDBY
Definition: sdio_fatfs/inc/at32_sdio.h:190
SD_CARD_READY
@ SD_CARD_READY
Definition: sdio_fatfs/inc/at32_sdio.h:188
SD_CARD_DISCONNECTED
@ SD_CARD_DISCONNECTED
Definition: sdio_fatfs/inc/at32_sdio.h:195
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: sdio_fatfs/inc/at32_sdio.h:196
SDIO_SDIO_CARD
@ SDIO_SDIO_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:212
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:206
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:210
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sdio_fatfs/inc/at32_sdio.h:204
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:208
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sdio_fatfs/inc/at32_sdio.h:205
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:207
SDIO_HIGH_CAPACITY_MMC_CARD
@ SDIO_HIGH_CAPACITY_MMC_CARD
Definition: sdio_fatfs/inc/at32_sdio.h:211
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: sdio_fatfs/inc/at32_sdio.h:402
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: sdio_fatfs/inc/at32_sdio.h:401
sd_card_info_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:237
sd_cid_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:170
sd_csd_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:126
sd_scr_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:219


AT32F413 Firmwary Library: at32_sdio.c Source File

  • sdio
  • sdio_fatfs
  • src
sdio_fatfs/src/at32_sdio.c
Go to the documentation of this file.
1
28#include <string.h>
29#include "at32_sdio.h"
30#include "at32f413_board.h"
31
40 sdio_command_struct_type sdio_command_init_struct;
41 sdio_data_struct_type sdio_data_init_struct;
42
43static sd_memory_card_type card_type = SDIO_STD_CAPACITY_SD_CARD_V1_1; /* sd card type */
44static uint32_t csd_table[4], cid_table[4], rca = 0; /* csd, sid, rca */
45static sd_data_transfer_mode_type device_mode = SD_TRANSFER_POLLING_MODE; /* working mode */
46static uint8_t stop_flag = 0; /* transmit stop flag */
47volatile sd_error_status_type transfer_error = SD_OK; /* transmit error flag */
48volatile uint8_t transfer_end = 0; /* transmit end flag */
49 sd_card_info_struct_type sd_card_info; /* sd card information */
50
51 sd_error_status_type command_error(void);
52 sd_error_status_type command_rsp1_error(uint8_t cmd);
53 sd_error_status_type command_rsp2_error(void);
54 sd_error_status_type command_rsp3_error(void);
55 sd_error_status_type command_rsp4_error(uint8_t cmd);
56 sd_error_status_type command_rsp5_error(uint8_t cmd);
57 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca);
58 sd_error_status_type command_rsp7_error(void);
59 sd_error_status_type sd_bus_wide_enable(confirm_state new_state);
60 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value);
61 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp);
62 sd_error_status_type check_card_programming(uint8_t *p_status);
63 sd_error_status_type speed_change(uint8_t speed);
64 sd_error_status_type scr_find(void);
65uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes);
66
73 sd_error_status_type sd_init(void)
74{
75 uint16_t clkdiv = 0;
76 sd_error_status_type status = SD_OK;
77 gpio_init_type gpio_init_struct = {0};
78 uint8_t retry = 0;
79
80 /* gpioc and gpiod periph clock enable */
81 crm_periph_clock_enable(CRM_GPIOC_PERIPH_CLOCK, TRUE);
82 crm_periph_clock_enable(CRM_GPIOD_PERIPH_CLOCK, TRUE);
83
84 /* sdio periph clock enable */
85 crm_periph_clock_enable(CRM_SDIO1_PERIPH_CLOCK, TRUE);
86
87 /* configure pc.08, pc.09, pc.10, pc.11, pc.12 pin: d0, d1, d2, d3, clk pin */
88 gpio_init_struct.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
89 gpio_init_struct.gpio_mode = GPIO_MODE_MUX;
90 gpio_init_struct.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
91 gpio_init_struct.gpio_pins = GPIO_PINS_8 | GPIO_PINS_9 | GPIO_PINS_10 | GPIO_PINS_11 | GPIO_PINS_12;
92 gpio_init_struct.gpio_pull = GPIO_PULL_NONE;
93 gpio_init(GPIOC, &gpio_init_struct);
94
95 /* configure pd.02 cmd line */
96 gpio_init_struct.gpio_pins = GPIO_PINS_2;
97 gpio_init(GPIOD, &gpio_init_struct);
98
99 retry = 3;
100 while(retry--){
101 /* reset sdio */
102 sdio_reset(SDIOx);
103 /* power on */
104 status = sd_power_on();
105
106 if(status == SD_OK)
107 break;
108 }
109
110 if(status == SD_OK)
111 {
112 /* sdio card initialize */
113 status = sd_card_init();
114 }
115
116 if(status == SD_OK)
117 {
118 /* get card information*/
119 status = sd_card_info_get(&sd_card_info);
120 }
121
122 if((SDIO_MULTIMEDIA_CARD == card_type) && (sd_card_info.sd_csd_reg.spec_version >= 4))
123 {
124 card_type = SDIO_HIGH_SPEED_MULTIMEDIA_CARD;
125 }
126
127 if(status == SD_OK)
128 {
129 /* select card */
130 status = sd_deselect_select((uint32_t)(sd_card_info.rca << 16));
131 }
132
133 if(status == SD_OK && ((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
134 (SDIO_SECURE_DIGITAL_IO_COMBO_CARD == card_type) || (SDIO_HIGH_CAPACITY_SD_CARD == card_type)))
135 {
136 status = scr_find();
137 }
138
139 if(status == SD_OK)
140 {
141 /* set normal speed */
142 status = speed_change(0);
143 }
144
145 if((status == SD_OK) || (card_type == SDIO_MULTIMEDIA_CARD))
146 {
147 if(sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1 || sd_card_info.card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0)
148 {
149 /* set sdio_ck to 12mhz */
150 clkdiv = system_core_clock / 12000000;
151
152 if(clkdiv >= 2)
153 {
154 clkdiv -= 2;
155 }
156 }
157 else
158 {
159 /* set sdio_ck to 48mhz */
160 clkdiv = system_core_clock / 48000000;
161
162 if(clkdiv >= 2)
163 {
164 clkdiv -= 2;
165 }
166 }
167 /* set sdio clock divider */
168 sdio_clock_set(clkdiv);
169
170 /* set transfer mode */
171 status = sd_device_mode_set(SD_TRANSFER_DMA_MODE);
172 }
173
174 if(status == SD_OK)
175 {
176 /* Set data width */
177 status = sd_wide_bus_operation_config(SDIO_BUS_WIDTH_D4);
178 }
179
180 return status;
181}
182
188void sdio_clock_set(uint32_t clk_div)
189{
190 /* config clock divide [7:0] */
191 SDIOx->clkctrl_bit.clkdiv_l = (clk_div & 0xFF);
192
193 /* config clock divide [9:8] */
194 SDIOx->clkctrl_bit.clkdiv_h = ((clk_div & 0x300) >> 8);
195}
196
203 sd_error_status_type sd_power_on(void)
204{
205 uint8_t retry = 0;
206 sd_error_status_type status = SD_OK;
207 uint32_t response = 0, count = 0, valid_voltage = 0, clk_psc;
208 uint32_t sd_type = SD_STD_CAPACITY;
209
210 /* sdio_ck is less than 400KHz in initialization stage, set to 200KHz */
211 clk_psc = (system_core_clock / 200000) - 2;
212
213 if(clk_psc > 0x3FF)
214 {
215 clk_psc = 0x3FF;
216 }
217
218 /* config sdio clock divide and edge phase */
219 sdio_clock_config(SDIOx, clk_psc, SDIO_CLOCK_EDGE_FALLING);
220 /* config sdio bus width */
221 sdio_bus_width_config(SDIOx, SDIO_BUS_WIDTH_D1);
222 /* disable flow control */
223 sdio_flow_control_enable(SDIOx, FALSE);
224 /* disable clock bypass */
225 sdio_clock_bypass(SDIOx, FALSE);
226 /* disable power saving mode */
227 sdio_power_saving_mode_enable(SDIOx, FALSE);
228
229 /* sdio power on */
230 sdio_power_set(SDIOx, SDIO_POWER_ON);
231 /* enable to output sdio_ck */
232 sdio_clock_enable(SDIOx, TRUE);
233
234 for(retry = 0; retry < 5; retry++)
235 {
236 /* send cmd0, get in idle stage */
237 sdio_command_init_struct.argument = 0x0;
238 sdio_command_init_struct.cmd_index = SD_CMD_GO_IDLE_STATE;
239 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_NO;
240 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
241
242 /* sdio command config */
243 sdio_command_config(SDIOx, &sdio_command_init_struct);
244 /* enable ccsm */
245 sdio_command_state_machine_enable(SDIOx, TRUE);
246
247 /* get command status */
248 status = command_error();
249 }
250
251 /* send cmd8, check card interface feature */
252 sdio_command_init_struct.argument = SD_CHECK_PATTERN;
253 sdio_command_init_struct.cmd_index = SDIO_SEND_IF_COND;
254 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
255 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
256
257 /* sdio command config */
258 sdio_command_config(SDIOx, &sdio_command_init_struct);
259 /* enable ccsm */
260 sdio_command_state_machine_enable(SDIOx, TRUE);
261
262 /* waiting R7 */
263 status = command_rsp7_error();
264
265 if(status == SD_OK)
266 {
267 /* set card type and sd type */
268 card_type = SDIO_STD_CAPACITY_SD_CARD_V2_0;
269 sd_type = SD_HIGH_CAPACITY;
270 }
271
272 /* send cmd55, check sd version */
273 sdio_command_init_struct.argument = 0x00;
274 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
275 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
276 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
277
278 /* sdio command config */
279 sdio_command_config(SDIOx, &sdio_command_init_struct);
280 /* enable ccsm */
281 sdio_command_state_machine_enable(SDIOx, TRUE);
282
283 /* waiting R1 */
284 status = command_rsp1_error(SD_CMD_APP_CMD);
285
286 /* check sd card or mmc card */
287 if(SD_OK == status)
288 {
289 /* send acmd41, check voltage operation range */
290 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
291 {
292 delay_ms(10);
293
294 /* send cmd55 before acmd41 */
295 sdio_command_init_struct.argument = 0x00;
296 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
297 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
298 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
299
300 /* sdio command config */
301 sdio_command_config(SDIOx, &sdio_command_init_struct);
302 /* enable ccsm */
303 sdio_command_state_machine_enable(SDIOx, TRUE);
304
305 /* waiting R1 */
306 status = command_rsp1_error(SD_CMD_APP_CMD);
307
308 /* if any errors occured, return status */
309 if(status != SD_OK)
310 {
311 return status;
312 }
313
314 /* send acmd41 */
315 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_SD | sd_type;
316 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_OP_COND;
317 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
318 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
319
320 /* sdio command config */
321 sdio_command_config(SDIOx, &sdio_command_init_struct);
322 /* enable ccsm */
323 sdio_command_state_machine_enable(SDIOx, TRUE);
324
325 /* waiting R3 */
326 status = command_rsp3_error();
327
328 /* if any errors occured, return status */
329 if(status != SD_OK)
330 {
331 return status;
332 }
333
334 /* get response1 */
335 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
336
337 /* check sd card power on stage is success or not */
338 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
339 count++;
340 }
341
342 if(count >= SD_MAX_VOLT_TRIAL)
343 {
344 status = SD_INVALID_VOLTRANGE;
345 return status;
346 }
347
348 if(response &= SD_HIGH_CAPACITY)
349 {
350 card_type = SDIO_HIGH_CAPACITY_SD_CARD;
351 }
352 }
353 /* mmc card */
354 else
355 {
356 /* send cmd1 */
357 while((!valid_voltage) && (count < SD_MAX_VOLT_TRIAL))
358 {
359 delay_ms(10);
360
361 sdio_command_init_struct.argument = SD_VOLTAGE_WINDOW_MMC;
362 sdio_command_init_struct.cmd_index = SD_CMD_SEND_OP_COND;
363 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
364 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
365
366 /* sdio command config */
367 sdio_command_config(SDIOx, &sdio_command_init_struct);
368 /* enable ccsm */
369 sdio_command_state_machine_enable(SDIOx, TRUE);
370
371 /* waiting R3 */
372 status = command_rsp3_error();
373
374 if(status != SD_OK)
375 {
376 return status;
377 }
378
379 /* get response1 */
380 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
381
382 valid_voltage = (((response >> 31) == 1) ? 1 : 0);
383 count++;
384 }
385
386 if(count >= SD_MAX_VOLT_TRIAL)
387 {
388 status = SD_INVALID_VOLTRANGE;
389 return status;
390 }
391
392 card_type = SDIO_MULTIMEDIA_CARD;
393 }
394
395 return(status);
396}
397
403 sd_error_status_type sd_power_off(void)
404{
405 /* sdio power off */
406 sdio_power_set(SDIOx, SDIO_POWER_OFF);
407
408 return SD_OK;
409}
410
417 sd_error_status_type sd_card_init(void)
418{
419 sd_error_status_type status = SD_OK;
420 uint16_t rca_temp = 0x01;
421
422 /* check power status */
423 if(SDIO_POWER_OFF == sdio_power_status_get(SDIOx))
424 {
425 return SD_REQ_NOT_APPLICABLE;
426 }
427
428 /* check is secure_digital_io_card or not */
429 if(SDIO_SECURE_DIGITAL_IO_CARD != card_type)
430 {
431 /* send cmd2, get cid register */
432 sdio_command_init_struct.argument = 0x0;
433 sdio_command_init_struct.cmd_index = SD_CMD_ALL_SEND_CID;
434 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
435 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
436
437 /* sdio command config */
438 sdio_command_config(SDIOx, &sdio_command_init_struct);
439 /* enable ccsm */
440 sdio_command_state_machine_enable(SDIOx, TRUE);
441
442 status = command_rsp2_error();
443 if(status != SD_OK)
444 {
445 return status;
446 }
447
448 cid_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
449 cid_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
450 cid_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
451 cid_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
452 }
453
454 /* check card type */
455 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
456 (card_type == SDIO_SECURE_DIGITAL_IO_COMBO_CARD) || (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
457 {
458 /* send cmd3, get rca */
459 sdio_command_init_struct.argument = 0x00;
460 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
461 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
462 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
463
464 /* sdio command config */
465 sdio_command_config(SDIOx, &sdio_command_init_struct);
466 /* enable ccsm */
467 sdio_command_state_machine_enable(SDIOx, TRUE);
468
469 status = command_rsp6_error(SD_CMD_SET_REL_ADDR, &rca_temp);
470 if(status != SD_OK)
471 {
472 return status;
473 }
474 }
475
476 /* mmc card */
477 if(card_type == SDIO_MULTIMEDIA_CARD)
478 {
479 /* send cmd3 */
480 sdio_command_init_struct.argument = (uint32_t)(rca_temp << 16);
481 sdio_command_init_struct.cmd_index = SD_CMD_SET_REL_ADDR;
482 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
483 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
484
485 /* sdio command config */
486 sdio_command_config(SDIOx, &sdio_command_init_struct);
487 /* enable ccsm */
488 sdio_command_state_machine_enable(SDIOx, TRUE);
489
490 status = command_rsp2_error();
491 if(status != SD_OK)
492 {
493 return status;
494 }
495 }
496
497 /* check is secure_digital_io_card or not */
498 if(card_type != SDIO_SECURE_DIGITAL_IO_CARD)
499 {
500 rca = rca_temp;
501 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
502 sdio_command_init_struct.cmd_index = SD_CMD_SEND_CSD;
503 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_LONG;
504 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
505
506 /* sdio command config */
507 sdio_command_config(SDIOx, &sdio_command_init_struct);
508 /* enable ccsm */
509 sdio_command_state_machine_enable(SDIOx, TRUE);
510
511 status = command_rsp2_error();
512 if(status != SD_OK)
513 {
514 return status;
515 }
516
517 csd_table[0] = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
518 csd_table[1] = sdio_response_get(SDIOx, SDIO_RSP2_INDEX);
519 csd_table[2] = sdio_response_get(SDIOx, SDIO_RSP3_INDEX);
520 csd_table[3] = sdio_response_get(SDIOx, SDIO_RSP4_INDEX);
521 }
522
523 return SD_OK;
524}
525
532 sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
533{
534 sd_error_status_type status = SD_OK;
535 uint8_t tmp = 0;
536
537 card_info->card_type = (uint8_t)card_type;
538 card_info->rca = (uint16_t)rca;
539
540 /* byte 0 */
541 tmp = (uint8_t)((csd_table[0] & 0xFF000000) >> 24);
542 card_info->sd_csd_reg.csd_struct = (tmp & 0xC0) >> 6;
543 card_info->sd_csd_reg.spec_version = (tmp & 0x3C) >> 2;
544 card_info->sd_csd_reg.reserved1 = tmp & 0x03;
545
546 /* byte 1 */
547 tmp = (uint8_t)((csd_table[0] & 0x00FF0000) >> 16);
548 card_info->sd_csd_reg.taac = tmp;
549
550 /* byte 2 */
551 tmp = (uint8_t)((csd_table[0] & 0x0000FF00) >> 8);
552 card_info->sd_csd_reg.nsac = tmp;
553
554 /* byte 3 */
555 tmp = (uint8_t)(csd_table[0] & 0x000000FF);
556 card_info->sd_csd_reg.max_bus_clk_freq = tmp;
557
558 /* byte 4 */
559 tmp = (uint8_t)((csd_table[1] & 0xFF000000) >> 24);
560 card_info->sd_csd_reg.card_cmd_classes = tmp << 4;
561
562 /* byte 5 */
563 tmp = (uint8_t)((csd_table[1] & 0x00FF0000) >> 16);
564 card_info->sd_csd_reg.card_cmd_classes |= (tmp & 0xF0) >> 4;
565 card_info->sd_csd_reg.max_read_blk_length = tmp & 0x0F;
566
567 /* byte 6 */
568 tmp = (uint8_t)((csd_table[1] & 0x0000FF00) >> 8);
569 card_info->sd_csd_reg.part_blk_read = (tmp & 0x80) >> 7;
570 card_info->sd_csd_reg.write_blk_misalign = (tmp & 0x40) >> 6;
571 card_info->sd_csd_reg.read_blk_misalign = (tmp & 0x20) >> 5;
572 card_info->sd_csd_reg.dsr_implemented = (tmp & 0x10) >> 4;
573 card_info->sd_csd_reg.reserved2 = 0; /* reserved */
574
575 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || (card_type == SDIO_MULTIMEDIA_CARD))
576 {
577 card_info->sd_csd_reg.device_size = (tmp & 0x03) << 10;
578
579 /* byte 7 */
580 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
581 card_info->sd_csd_reg.device_size |= (tmp) << 2;
582
583 /* byte 8 */
584 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
585 card_info->sd_csd_reg.device_size |= (tmp & 0xC0) >> 6;
586
587 card_info->sd_csd_reg.max_read_current_vdd_min = (tmp & 0x38) >> 3;
588 card_info->sd_csd_reg.max_read_current_vdd_max = (tmp & 0x07);
589
590 /* byte 9 */
591 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
592 card_info->sd_csd_reg.max_write_current_vdd_min = (tmp & 0xE0) >> 5;
593 card_info->sd_csd_reg.max_write_current_vdd_max = (tmp & 0x1C) >> 2;
594 card_info->sd_csd_reg.device_size_mult = (tmp & 0x03) << 1;
595 /* byte 10 */
596 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
597 card_info->sd_csd_reg.device_size_mult |= (tmp & 0x80) >> 7;
598
599 card_info->card_capacity = (card_info->sd_csd_reg.device_size + 1) ;
600 card_info->card_capacity *= (1 << (card_info->sd_csd_reg.device_size_mult + 2));
601 card_info->card_blk_size = 1 << (card_info->sd_csd_reg.max_read_blk_length);
602 card_info->card_capacity *= card_info->card_blk_size;
603 }
604 else if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
605 {
606 /* byte 7 */
607 tmp = (uint8_t)(csd_table[1] & 0x000000FF);
608 card_info->sd_csd_reg.device_size = (tmp & 0x3F) << 16;
609
610 /* byte 8 */
611 tmp = (uint8_t)((csd_table[2] & 0xFF000000) >> 24);
612
613 card_info->sd_csd_reg.device_size |= (tmp << 8);
614
615 /* byte 9 */
616 tmp = (uint8_t)((csd_table[2] & 0x00FF0000) >> 16);
617
618 card_info->sd_csd_reg.device_size |= (tmp);
619
620 /* byte 10 */
621 tmp = (uint8_t)((csd_table[2] & 0x0000FF00) >> 8);
622
623 card_info->card_capacity = (uint64_t)(card_info->sd_csd_reg.device_size + 1) * 512 * 1024;
624 card_info->card_blk_size = 512;
625 }
626
627
628 card_info->sd_csd_reg.erase_group_size = (tmp & 0x40) >> 6;
629 card_info->sd_csd_reg.erase_group_size_mult = (tmp & 0x3F) << 1;
630
631 /* byte 11 */
632 tmp = (uint8_t)(csd_table[2] & 0x000000FF);
633 card_info->sd_csd_reg.erase_group_size_mult |= (tmp & 0x80) >> 7;
634 card_info->sd_csd_reg.write_protect_group_size = (tmp & 0x7F);
635
636 /* byte 12 */
637 tmp = (uint8_t)((csd_table[3] & 0xFF000000) >> 24);
638 card_info->sd_csd_reg.write_protect_group_enable = (tmp & 0x80) >> 7;
639 card_info->sd_csd_reg.manufacturer_default_ecc = (tmp & 0x60) >> 5;
640 card_info->sd_csd_reg.write_speed_factor = (tmp & 0x1C) >> 2;
641 card_info->sd_csd_reg.max_write_blk_length = (tmp & 0x03) << 2;
642
643 /* byte 13 */
644 tmp = (uint8_t)((csd_table[3] & 0x00FF0000) >> 16);
645 card_info->sd_csd_reg.max_write_blk_length |= (tmp & 0xC0) >> 6;
646 card_info->sd_csd_reg.part_blk_write = (tmp & 0x20) >> 5;
647 card_info->sd_csd_reg.reserved3 = 0;
648 card_info->sd_csd_reg.content_protect_app = (tmp & 0x01);
649
650 /* byte 14 */
651 tmp = (uint8_t)((csd_table[3] & 0x0000FF00) >> 8);
652 card_info->sd_csd_reg.file_format_group = (tmp & 0x80) >> 7;
653 card_info->sd_csd_reg.copy_flag = (tmp & 0x40) >> 6;
654 card_info->sd_csd_reg.permanent_write_protect = (tmp & 0x20) >> 5;
655 card_info->sd_csd_reg.temp_write_protect = (tmp & 0x10) >> 4;
656 card_info->sd_csd_reg.file_formart = (tmp & 0x0C) >> 2;
657 card_info->sd_csd_reg.ecc_code = (tmp & 0x03);
658
659 /* byte 15 */
660 tmp = (uint8_t)(csd_table[3] & 0x000000FF);
661 card_info->sd_csd_reg.csd_crc = (tmp & 0xFE) >> 1;
662 card_info->sd_csd_reg.reserved4 = 1;
663
664 /* byte 0 */
665 tmp = (uint8_t)((cid_table[0] & 0xFF000000) >> 24);
666 card_info->sd_cid_reg.manufacturer_id = tmp;
667
668 /* byte 1 */
669 tmp = (uint8_t)((cid_table[0] & 0x00FF0000) >> 16);
670 card_info->sd_cid_reg.oem_app_id = tmp << 8;
671
672 /* byte 2 */
673 tmp = (uint8_t)((cid_table[0] & 0x000000FF00) >> 8);
674 card_info->sd_cid_reg.oem_app_id |= tmp;
675
676 /* byte 3 */
677 tmp = (uint8_t)(cid_table[0] & 0x000000FF);
678 card_info->sd_cid_reg.product_name1 = tmp << 24;
679
680 /* byte 4 */
681 tmp = (uint8_t)((cid_table[1] & 0xFF000000) >> 24);
682 card_info->sd_cid_reg.product_name1 |= tmp << 16;
683
684 /* byte 5 */
685 tmp = (uint8_t)((cid_table[1] & 0x00FF0000) >> 16);
686 card_info->sd_cid_reg.product_name1 |= tmp << 8;
687
688 /* byte 6 */
689 tmp = (uint8_t)((cid_table[1] & 0x0000FF00) >> 8);
690 card_info->sd_cid_reg.product_name1 |= tmp;
691
692 /* byte 7 */
693 tmp = (uint8_t)(cid_table[1] & 0x000000FF);
694 card_info->sd_cid_reg.product_name2 = tmp;
695
696 /* byte 8 */
697 tmp = (uint8_t)((cid_table[2] & 0xFF000000) >> 24);
698 card_info->sd_cid_reg.product_reversion = tmp;
699
700 /* byte 9 */
701 tmp = (uint8_t)((cid_table[2] & 0x00FF0000) >> 16);
702 card_info->sd_cid_reg.product_sn = tmp << 24;
703
704 /* byte 10 */
705 tmp = (uint8_t)((cid_table[2] & 0x0000FF00) >> 8);
706 card_info->sd_cid_reg.product_sn |= tmp << 16;
707
708 /* byte 11 */
709 tmp = (uint8_t)(cid_table[2] & 0x000000FF);
710 card_info->sd_cid_reg.product_sn |= tmp << 8;
711
712 /* byte 12 */
713 tmp = (uint8_t)((cid_table[3] & 0xFF000000) >> 24);
714 card_info->sd_cid_reg.product_sn |= tmp;
715
716 /* byte 13 */
717 tmp = (uint8_t)((cid_table[3] & 0x00FF0000) >> 16);
718 card_info->sd_cid_reg.reserved1 |= (tmp & 0xF0) >> 4;
719 card_info->sd_cid_reg.manufact_date = (tmp & 0x0F) << 8;
720
721 /* byte 14 */
722 tmp = (uint8_t)((cid_table[3] & 0x0000FF00) >> 8);
723 card_info->sd_cid_reg.manufact_date |= tmp;
724
725 /* byte 15 */
726 tmp = (uint8_t)(cid_table[3] & 0x000000FF);
727 card_info->sd_cid_reg.cid_crc = (tmp & 0xFE) >> 1;
728 card_info->sd_cid_reg.reserved2 = 1;
729
730 return(status);
731}
732
743 sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
744{
745 sd_error_status_type status = SD_OK;
746
747 if((card_type == SDIO_MULTIMEDIA_CARD) || (card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD))
748 {
749 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)mode);
750 }
751 else if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
752 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
753 {
754 if(mode >= 2)
755 {
756 /* not support D8 mode */
757 return SD_UNSUPPORTED_FEATURE;
758 }
759
760 if(SDIO_BUS_WIDTH_D4 == mode)
761 {
762 status = sd_bus_wide_enable(TRUE);
763 }
764 else
765 {
766 status = sd_bus_wide_enable(FALSE);
767 }
768 }
769
770 if(status == SD_OK)
771 {
772 sdio_bus_width_config(SDIOx, mode);
773 }
774
775 return status;
776}
777
786 sd_error_status_type sd_device_mode_set(uint32_t mode)
787{
788 sd_error_status_type status = SD_OK;
789
790 if((mode == SD_TRANSFER_DMA_MODE) || (mode == SD_TRANSFER_POLLING_MODE))
791 {
792 device_mode = (sd_data_transfer_mode_type)mode;
793 }
794 else
795 {
796 status = SD_INVALID_PARAMETER;
797 }
798
799 return status;
800}
801
807 sd_error_status_type sd_deselect_select(uint32_t addr)
808{
809 /* send cmd7, select card */
810 sdio_command_init_struct.argument = addr;
811 sdio_command_init_struct.cmd_index = SD_CMD_SEL_DESEL_CARD;
812 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
813 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_INT;
814
815 /* sdio command config */
816 sdio_command_config(SDIOx, &sdio_command_init_struct);
817 /* enable ccsm */
818 sdio_command_state_machine_enable(SDIOx, TRUE);
819
820 return command_rsp1_error(SD_CMD_SEL_DESEL_CARD);
821}
822
830 sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, \
831 sdio_data_struct_type* sdio_data_init_t, uint32_t *buf)
832{
833 sd_error_status_type status = SD_OK;
834 uint32_t count = 0;
835 uint32_t timeout = SDIO_DATATIMEOUT;
836 uint32_t length = 0;
837
838 if(buf == NULL)
839 {
840 return SD_INVALID_PARAMETER;
841 }
842 /* clear dtctrl register */
843 SDIOx->dtcnt = 0x0;
844
845 /* sdio command config */
846 sdio_data_config(SDIOx, sdio_data_init_t);
847 /* enable dcsm */
848 sdio_data_state_machine_enable(SDIOx, TRUE);
849
850 length = sdio_data_init_t->data_length;
851
852 if(device_mode == SD_TRANSFER_DMA_MODE)
853 {
854 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CONTROLLER)
855 {
856 sd_dma_config(buf, length, DMA_DIR_PERIPHERAL_TO_MEMORY);
857 SDIOx->inten |= SDIO_INTR_STS_READ_MASK;
858 transfer_error = SD_OK;
859 transfer_end = 0;
860 sdio_dma_enable(SDIOx, TRUE);
861 }
862 }
863
864 /* sdio command config */
865 sdio_command_config(SDIOx, sdio_cmd_init_t);
866 /* enable ccsm */
867 sdio_command_state_machine_enable(SDIOx, TRUE);
868
869 status = command_rsp1_error(sdio_cmd_init_t->cmd_index);
870 if(status != SD_OK)
871 {
872 return status;
873 }
874
875 /* polling mode */
876 if(device_mode == SD_TRANSFER_POLLING_MODE)
877 {
878 if(SDIO_DATA_TRANSFER_TO_CONTROLLER == sdio_data_init_t->transfer_direction)
879 {
880 while(!(SDIOx->sts & (SDIO_INTR_STS_READ_MASK)))
881 {
882 if(sdio_flag_get(SDIOx, SDIO_RXBUFH_FLAG) != RESET)
883 {
884 for(count = 0; count < 8; count++, buf++)
885 {
886 *buf = sdio_data_read(SDIOx);
887 }
888
889 timeout = 0x7FFFFF;
890 }
891 else
892 {
893 if(0 == timeout)
894 {
895 sd_init();
896 return SD_DATA_TIMEOUT;
897 }
898
899 timeout--;
900 }
901 }
902
903 while(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
904 {
905 *buf = sdio_data_read(SDIOx);
906 buf++;
907 }
908 }
909 else
910 {
911 while(!(SDIOx->sts & SDIO_INTR_STS_WRITE_MASK))
912 {
913 if(sdio_flag_get(SDIOx, SDIO_TXBUFH_FLAG) != RESET)
914 {
915 for(count = 0; count < 8 && length > 0; count++, buf++, length -= 4)
916 {
917 sdio_data_write(SDIOx, *buf);
918 }
919
920 timeout = 0x3FFFFFFF;
921 }
922 else
923 {
924 if(timeout == 0)
925 {
926 sd_init();
927 return SD_DATA_TIMEOUT;
928 }
929
930 timeout--;
931 }
932 }
933 }
934 /* data timeout */
935 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
936 {
937 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
938 return SD_DATA_TIMEOUT;
939 }
940 /* crc error */
941 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
942 {
943 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
944 return SD_DATA_FAIL;
945 }
946 /* over run error */
947 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
948 {
949 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
950 return SD_RX_OVERRUN;
951 }
952 /* under run error */
953 else if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
954 {
955 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
956 return SD_TX_UNDERRUN;
957 }
958 /* start bit error */
959 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
960 {
961 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
962 return SD_START_BIT_ERR;
963 }
964 /* data transfer complete */
965 if((stop_flag == 1) && (sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET))
966 {
967 /* send cmd12, stop transmission */
968 sdio_cmd_init_t->argument = 0;
969 sdio_cmd_init_t->cmd_index = SD_CMD_STOP_TRANSMISSION;
970 sdio_cmd_init_t->rsp_type = SDIO_RESPONSE_SHORT;
971 sdio_cmd_init_t->wait_type = SDIO_WAIT_FOR_NO;
972
973 /* sdio command config */
974 sdio_command_config(SDIOx, sdio_cmd_init_t);
975 /* enable ccsm */
976 sdio_command_state_machine_enable(SDIOx, TRUE);
977
978 status = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
979
980 if(status != SD_OK)
981 {
982 return status;
983 }
984 }
985
986 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
987 }
988 else if(device_mode == SD_TRANSFER_DMA_MODE)
989 {
990 if(sdio_data_init_t->transfer_direction == SDIO_DATA_TRANSFER_TO_CARD)
991 {
992 sd_dma_config(buf, length, DMA_DIR_MEMORY_TO_PERIPHERAL);
993 SDIOx->inten |= SDIO_INTR_STS_WRITE_MASK;
994 transfer_error = SD_OK;
995 transfer_end = 0;
996 sdio_dma_enable(SDIOx, TRUE);
997 }
998
999 while(!(SDIOx->sts & SDIOx->inten) && timeout)
1000 {
1001 timeout--;
1002
1003 if(transfer_end)
1004 {
1005 break;
1006 }
1007 }
1008
1009 if(timeout == 0)
1010 {
1011 sd_init();
1012 return SD_DATA_TIMEOUT;
1013 }
1014
1015 if(transfer_error != SD_OK)
1016 {
1017 status = transfer_error;
1018 }
1019 }
1020
1021 return status;
1022}
1023
1030 sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
1031{
1032 sd_error_status_type status = SD_OK;
1033 uint32_t start_addr = 0, end_addr = 0, response = 0;
1034 uint8_t card_state;
1035
1036 /* high capacity sd card */
1037 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1038 {
1039 start_addr = addr >> 9;
1040 end_addr = start_addr + nblks - 1;
1041 }
1042 else
1043 {
1044 start_addr = addr;
1045 end_addr = start_addr + (nblks - 1) * 512;
1046 }
1047
1048 /* clear dcsm configuration */
1049 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1050 sdio_data_init_struct.data_length = 0 ;
1051 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1052 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1053 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1054
1055 sdio_data_config(SDIOx, &sdio_data_init_struct);
1056 sdio_data_state_machine_enable(SDIOx, FALSE);
1057
1058 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1059
1060 /* check card locked */
1061 if(response & SD_CARD_LOCKED)
1062 {
1063 return SD_LOCK_UNLOCK_ERROR;
1064 }
1065
1066 if(card_type == SDIO_MULTIMEDIA_CARD || card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
1067 {
1068 /* send cmd35, set erase group start */
1069 sdio_command_init_struct.argument = start_addr;
1070 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_START;
1071 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1072 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1073
1074 /* sdio command config */
1075 sdio_command_config(SDIOx, &sdio_command_init_struct);
1076 /* enable ccsm */
1077 sdio_command_state_machine_enable(SDIOx, TRUE);
1078
1079 status = command_rsp1_error(SD_CMD_ERASE_GRP_START);
1080
1081 if(status != SD_OK)
1082 {
1083 return status;
1084 }
1085
1086 /* send cmd36, set erase group end */
1087 sdio_command_init_struct.argument = end_addr;
1088 sdio_command_init_struct.cmd_index = SD_CMD_ERASE_GRP_END;
1089
1090 /* sdio command config */
1091 sdio_command_config(SDIOx, &sdio_command_init_struct);
1092 /* enable ccsm */
1093 sdio_command_state_machine_enable(SDIOx, TRUE);
1094
1095 status = command_rsp1_error(SD_CMD_ERASE_GRP_END);
1096
1097 if(status != SD_OK)
1098 {
1099 return status;
1100 }
1101
1102 /* send cmd38, start erase gourp */
1103 sdio_command_init_struct.argument = 0;
1104 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1105
1106 /* sdio command config */
1107 sdio_command_config(SDIOx, &sdio_command_init_struct);
1108 /* enable ccsm */
1109 sdio_command_state_machine_enable(SDIOx, TRUE);
1110
1111 status = command_rsp1_error(SD_CMD_ERASE);
1112
1113 if(status != SD_OK)
1114 {
1115 return status;
1116 }
1117 }
1118 else
1119 {
1120 /* send cmd32, set erase block start */
1121 sdio_command_init_struct.argument = start_addr;
1122 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_START;
1123 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1124 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1125
1126 /* sdio command config */
1127 sdio_command_config(SDIOx, &sdio_command_init_struct);
1128 /* enable ccsm */
1129 sdio_command_state_machine_enable(SDIOx, TRUE);
1130
1131 status = command_rsp1_error(SD_CMD_SD_ERASE_GRP_START);
1132
1133 if(status != SD_OK)
1134 {
1135 return status;
1136 }
1137
1138 /* send cmd33, set erase block end */
1139 sdio_command_init_struct.argument = end_addr;
1140 sdio_command_init_struct.cmd_index = SD_CMD_SD_ERASE_GRP_END;
1141
1142 /* sdio command config */
1143 sdio_command_config(SDIOx, &sdio_command_init_struct);
1144 /* enable ccsm */
1145 sdio_command_state_machine_enable(SDIOx, TRUE);
1146
1147 if(status != SD_OK)
1148 {
1149 return status;
1150 }
1151
1152 /* send cmd38, start erase block */
1153 sdio_command_init_struct.argument = 0;
1154 sdio_command_init_struct.cmd_index = SD_CMD_ERASE;
1155
1156 /* sdio command config */
1157 sdio_command_config(SDIOx, &sdio_command_init_struct);
1158 /* enable ccsm */
1159 sdio_command_state_machine_enable(SDIOx, TRUE);
1160
1161 status = command_rsp1_error(SD_CMD_ERASE);
1162
1163 if(status != SD_OK)
1164 {
1165 return status;
1166 }
1167 }
1168
1169 status = check_card_programming(&card_state);
1170
1171 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || \
1172 (card_state == SD_CARD_RECEIVING)))
1173 {
1174 status = check_card_programming(&card_state);
1175 }
1176
1177 return status;
1178}
1179
1188 sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
1189{
1190 sd_error_status_type status = SD_OK;
1191 uint32_t response = 0;
1192 uint8_t power;
1193
1194 if(NULL == buf)
1195 {
1196 return SD_INVALID_PARAMETER;
1197 }
1198
1199 SDIOx->dtctrl = 0x0;
1200
1201 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1202 {
1203 blk_size = 512;
1204 addr >>= 9;
1205 }
1206
1207 /* clear dcsm configuration */
1208 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1209 sdio_data_init_struct.data_length = 0;
1210 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1211 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1212 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1213
1214 sdio_data_config(SDIOx, &sdio_data_init_struct);
1215 sdio_data_state_machine_enable(SDIOx, FALSE);
1216
1217 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1218
1219 /* check card locked */
1220 if(response & SD_CARD_LOCKED)
1221 {
1222 return SD_LOCK_UNLOCK_ERROR;
1223 }
1224
1225 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1226 {
1227 power = convert_from_bytes_to_power_of_two(blk_size);
1228
1229 /* send cmd16, set block size */
1230 sdio_command_init_struct.argument = blk_size;
1231 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1232 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1233 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1234
1235 /* sdio command config */
1236 sdio_command_config(SDIOx, &sdio_command_init_struct);
1237 /* enable ccsm */
1238 sdio_command_state_machine_enable(SDIOx, TRUE);
1239
1240 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1241
1242 if(status != SD_OK)
1243 {
1244 return status;
1245 }
1246 }
1247 else
1248 {
1249 return SD_INVALID_PARAMETER;
1250 }
1251
1252 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1253 sdio_data_init_struct.data_length = blk_size ;
1254 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1255 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1256 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1257
1258 sdio_command_init_struct.argument = addr;
1259 sdio_command_init_struct.cmd_index = SD_CMD_READ_SINGLE_BLOCK;
1260 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1261 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1262
1263 stop_flag = 0;
1264
1265 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1266}
1267
1277 sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1278{
1279 sd_error_status_type status = SD_OK;
1280 uint32_t response = 0;
1281 uint8_t power;
1282
1283 SDIOx->dtctrl = 0x0;
1284
1285 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1286 {
1287 blk_size = 512;
1288 addr >>= 9;
1289 }
1290
1291 /* clear dcsm configuration */
1292 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1293 sdio_data_init_struct.data_length = 0;
1294 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1295 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1296 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1297
1298 sdio_data_config(SDIOx, &sdio_data_init_struct);
1299 sdio_data_state_machine_enable(SDIOx, FALSE);
1300
1301 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1302
1303 /* check card locked */
1304 if(response & SD_CARD_LOCKED)
1305 {
1306 return SD_LOCK_UNLOCK_ERROR;
1307 }
1308
1309 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1310 {
1311 power = convert_from_bytes_to_power_of_two(blk_size);
1312
1313 /* send cmd16, set block size */
1314 sdio_command_init_struct.argument = blk_size;
1315 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1316 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1317 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1318
1319 /* sdio command config */
1320 sdio_command_config(SDIOx, &sdio_command_init_struct);
1321 /* enable ccsm */
1322 sdio_command_state_machine_enable(SDIOx, TRUE);
1323
1324 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1325
1326 if(status != SD_OK)
1327 {
1328 return status;
1329 }
1330 }
1331 else
1332 {
1333 return SD_INVALID_PARAMETER;
1334 }
1335
1336 /* check max receive length */
1337 if(nblks * blk_size > SD_MAX_DATA_LENGTH)
1338 {
1339 return SD_INVALID_PARAMETER;
1340 }
1341
1342 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1343 sdio_data_init_struct.data_length = nblks * blk_size ;
1344 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1345 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1346 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1347
1348 /* send cmd18, read block data */
1349 sdio_command_init_struct.argument = addr;
1350 sdio_command_init_struct.cmd_index = SD_CMD_READ_MULT_BLOCK;
1351 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1352 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1353
1354 stop_flag = 1;
1355
1356 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1357}
1358
1367 sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
1368{
1369 sd_error_status_type status = SD_OK;
1370 uint8_t power = 0, card_state = 0;
1371 uint32_t timeout = 0, card_status = 0, response = 0;
1372
1373 if(buf == NULL)
1374 {
1375 return SD_INVALID_PARAMETER;
1376 }
1377
1378 SDIOx->dtctrl = 0x0;
1379
1380 /* clear dcsm configuration */
1381 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1382 sdio_data_init_struct.data_length = 0;
1383 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1384 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1385 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1386
1387 sdio_data_config(SDIOx, &sdio_data_init_struct);
1388 sdio_data_state_machine_enable(SDIOx, FALSE);
1389
1390 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1391
1392 /* check card locked */
1393 if(response & SD_CARD_LOCKED)
1394 {
1395 return SD_LOCK_UNLOCK_ERROR;
1396 }
1397
1398 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1399 {
1400 blk_size = 512;
1401 addr >>= 9;
1402 }
1403
1404 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1405 {
1406 power = convert_from_bytes_to_power_of_two(blk_size);
1407
1408 /* send cmd16, set block size */
1409 sdio_command_init_struct.argument = blk_size;
1410 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1411 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1412 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1413
1414 /* sdio command config */
1415 sdio_command_config(SDIOx, &sdio_command_init_struct);
1416 /* enable ccsm */
1417 sdio_command_state_machine_enable(SDIOx, TRUE);
1418
1419 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1420
1421 if(status != SD_OK)
1422 {
1423 return status;
1424 }
1425 }
1426 else
1427 {
1428 return SD_INVALID_PARAMETER;
1429 }
1430
1431 timeout = SD_DATATIMEOUT;
1432
1433 do
1434 {
1435 timeout--;
1436 status = sd_status_send(&card_status);
1437 }
1438 /* check ready_for_data flag */
1439 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1440
1441 if(timeout == 0)
1442 {
1443 return SD_ERROR;
1444 }
1445
1446 /* send cmd24, write single block */
1447 sdio_command_init_struct.argument = addr;
1448 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_SINGLE_BLOCK;
1449 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1450 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1451
1452 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1453 sdio_data_init_struct.data_length = blk_size;
1454 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1455 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1456 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1457
1458 stop_flag = 0;
1459
1460 /* single block, stop command is unnecessary */
1461 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1462
1463 if(status != SD_OK)
1464 {
1465 return status;
1466 }
1467
1468 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1469
1470 status = check_card_programming(&card_state);
1471
1472 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1473 {
1474 status = check_card_programming(&card_state);
1475 }
1476
1477 return status;
1478}
1479
1489 sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
1490{
1491 sd_error_status_type status = SD_OK;
1492 uint8_t power = 0, card_state = 0;
1493 uint32_t timeout = 0, card_status = 0, response = 0;;
1494
1495 if(buf == NULL)
1496 {
1497 return SD_INVALID_PARAMETER;
1498 }
1499
1500 SDIOx->dtctrl = 0x0;
1501
1502 /* clear dcsm configuration */
1503 sdio_data_init_struct.block_size = (sdio_block_size_type)0;
1504 sdio_data_init_struct.data_length = 0;
1505 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1506 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1507 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1508
1509 sdio_data_config(SDIOx, &sdio_data_init_struct);
1510 sdio_data_state_machine_enable(SDIOx, FALSE);
1511
1512 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1513
1514 /* check card locked */
1515 if(response & SD_CARD_LOCKED)
1516 {
1517 return SD_LOCK_UNLOCK_ERROR;
1518 }
1519
1520 if(card_type == SDIO_HIGH_CAPACITY_SD_CARD)
1521 {
1522 blk_size = 512;
1523 addr >>= 9;
1524 }
1525
1526 if((blk_size > 0) && (blk_size <= 2048) && ((blk_size & (blk_size - 1)) == 0))
1527 {
1528 power = convert_from_bytes_to_power_of_two(blk_size);
1529
1530 /* send cmd16, set block size */
1531 sdio_command_init_struct.argument = blk_size;
1532 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
1533 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1534 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1535
1536 /* sdio command config */
1537 sdio_command_config(SDIOx, &sdio_command_init_struct);
1538 /* enable ccsm */
1539 sdio_command_state_machine_enable(SDIOx, TRUE);
1540
1541 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
1542
1543 if(status != SD_OK)
1544 {
1545 return status;
1546 }
1547 }
1548 else
1549 {
1550 return SD_INVALID_PARAMETER;
1551 }
1552
1553 if((nblks * blk_size) > SD_MAX_DATA_LENGTH)
1554 {
1555 return SD_INVALID_PARAMETER;
1556 }
1557
1558 timeout = SD_DATATIMEOUT;
1559
1560 do
1561 {
1562 timeout--;
1563 status = sd_status_send(&card_status);
1564 }
1565 /* check ready_for_data flag */
1566 while(((card_status & 0x00000100) == 0) && (timeout > 0));
1567
1568 if(timeout == 0)
1569 {
1570 return SD_ERROR;
1571 }
1572
1573 if((card_type == SDIO_STD_CAPACITY_SD_CARD_V1_1) || (card_type == SDIO_STD_CAPACITY_SD_CARD_V2_0) || \
1574 (card_type == SDIO_HIGH_CAPACITY_SD_CARD))
1575 {
1576 /* send cmd55 */
1577 sdio_command_init_struct.argument = (uint32_t)rca << 16;
1578 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
1579 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1580 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1581
1582 /* sdio command config */
1583 sdio_command_config(SDIOx, &sdio_command_init_struct);
1584 /* enable ccsm */
1585 sdio_command_state_machine_enable(SDIOx, TRUE);
1586
1587 status = command_rsp1_error(SD_CMD_APP_CMD);
1588
1589 if(status != SD_OK)
1590 {
1591 return status;
1592 }
1593
1594 /* send cmd23, set block count */
1595 sdio_command_init_struct.argument = blk_size;
1596 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCK_COUNT;
1597 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1598 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1599
1600 /* sdio command config */
1601 sdio_command_config(SDIOx, &sdio_command_init_struct);
1602 /* enable ccsm */
1603 sdio_command_state_machine_enable(SDIOx, TRUE);
1604
1605 status = command_rsp1_error(SD_CMD_SET_BLOCK_COUNT);
1606
1607 if(status != SD_OK)
1608 {
1609 return status;
1610 }
1611 }
1612
1613 /* send cmd25, write mult blocks */
1614 sdio_command_init_struct.argument = addr;
1615 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_MULT_BLOCK;
1616 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1617 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1618
1619 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
1620 sdio_data_init_struct.data_length = nblks * blk_size ;
1621 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1622 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1623 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
1624
1625 stop_flag = 1;
1626 /* cmd12 is needed */
1627 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1628
1629 if(status != SD_OK)
1630 {
1631 return status;
1632 }
1633
1634 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1635
1636 status = check_card_programming(&card_state);
1637
1638 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1639 {
1640 status = check_card_programming(&card_state);
1641 }
1642
1643 return status;
1644}
1645
1653 sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
1654{
1655 uint32_t response = 0;
1656
1657 SDIOx->dtctrl = 0x0;
1658
1659 /* clear dcsm configuration */
1660 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1661 sdio_data_init_struct.data_length = 0 ;
1662 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1663 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1664 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1665
1666 sdio_data_config(SDIOx, &sdio_data_init_struct);
1667 sdio_data_state_machine_enable(SDIOx, FALSE);
1668
1669 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1670
1671 /* check card locked */
1672 if(response & SD_CARD_LOCKED)
1673 {
1674 return SD_LOCK_UNLOCK_ERROR;
1675 }
1676 /* send cmd11, read data */
1677 sdio_command_init_struct.argument = addr;
1678 sdio_command_init_struct.cmd_index = SD_CMD_READ_DAT_UNTIL_STOP;
1679 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1680 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1681
1682 sdio_data_init_struct.block_size = (sdio_block_size_type)(5 << 4);
1683 sdio_data_init_struct.data_length = len;
1684 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1685 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
1686 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1687
1688 stop_flag = 1;
1689 /* cmd12 is needed */
1690 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1691}
1692
1700 sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
1701{
1702 sd_error_status_type status = SD_OK;
1703 uint32_t response = 0;
1704 uint8_t card_state = 0;
1705
1706 if(buf == NULL)
1707 {
1708 return SD_INVALID_PARAMETER;
1709 }
1710
1711 SDIOx->dtctrl = 0x0;
1712
1713 /* clear dcsm configuration */
1714 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_1B;
1715 sdio_data_init_struct.data_length = 0;
1716 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
1717 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1718 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1719
1720 sdio_data_config(SDIOx, &sdio_data_init_struct);
1721 sdio_data_state_machine_enable(SDIOx, FALSE);
1722
1723 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
1724
1725 /* check card locked */
1726 if(response & SD_CARD_LOCKED)
1727 {
1728 return SD_LOCK_UNLOCK_ERROR;
1729 }
1730 /* send cmd20, write data */
1731 sdio_command_init_struct.argument = addr;
1732 sdio_command_init_struct.cmd_index = SD_CMD_WRITE_DAT_UNTIL_STOP;
1733 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1734 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1735
1736
1737 sdio_data_init_struct.block_size = (sdio_block_size_type)(15 << 4);
1738 sdio_data_init_struct.data_length = len;
1739 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
1740 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CARD;
1741 sdio_data_init_struct.transfer_mode = SDIO_DATA_STREAM_TRANSFER;
1742
1743 stop_flag = 1;
1744 /* cmd12 is needed */
1745 status = sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)buf);
1746
1747 if(status != SD_OK)
1748 {
1749 return status;
1750 }
1751
1752 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1753
1754 status = check_card_programming(&card_state);
1755
1756 while((status == SD_OK) && ((card_state == SD_CARD_PROGRAMMING) || (card_state == SD_CARD_RECEIVING)))
1757 {
1758 status = check_card_programming(&card_state);
1759 }
1760
1761 return status;
1762}
1763
1769void SDIO1_IRQHandler(void)
1770{
1771 sd_irq_service();
1772}
1773
1779void SDIO2_IRQHandler(void)
1780{
1781 sd_irq_service();
1782}
1783
1789 sd_error_status_type sd_irq_service(void)
1790{
1791 if(sdio_flag_get(SDIOx, SDIO_DTCMPL_FLAG) != RESET)
1792 {
1793 if(stop_flag == 1)
1794 {
1795 /* send cmd12, stop transmission */
1796 sdio_command_init_struct.argument = 0;
1797 sdio_command_init_struct.cmd_index = SD_CMD_STOP_TRANSMISSION;
1798 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
1799 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
1800 /* sdio command config */
1801 sdio_command_config(SDIOx, &sdio_command_init_struct);
1802 /* enable ccsm */
1803 sdio_command_state_machine_enable(SDIOx, TRUE);
1804 transfer_error = command_rsp1_error(SD_CMD_STOP_TRANSMISSION);
1805 }
1806 else
1807 {
1808 transfer_error = SD_OK;
1809 }
1810 /* clear flag */
1811 sdio_flag_clear(SDIOx, SDIO_DTCMPL_FLAG);
1812 transfer_end = 1;
1813 return transfer_error;
1814 }
1815
1816 if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
1817 {
1818 /* clear flag */
1819 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
1820 transfer_error = SD_DATA_FAIL;
1821 transfer_end = 1;
1822 return transfer_error;
1823 }
1824
1825 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
1826 {
1827 /* clear flag */
1828 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
1829 transfer_error = SD_DATA_TIMEOUT;
1830 transfer_end = 1;
1831 return transfer_error;
1832 }
1833
1834 if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
1835 {
1836 /* clear flag */
1837 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
1838 transfer_error = SD_RX_OVERRUN;
1839 transfer_end = 1;
1840 return(SD_RX_OVERRUN);
1841 }
1842
1843 if(sdio_flag_get(SDIOx, SDIO_TXERRU_FLAG) != RESET)
1844 {
1845 /* clear flag */
1846 sdio_flag_clear(SDIOx, SDIO_TXERRU_FLAG);
1847 transfer_error = SD_TX_UNDERRUN;
1848 transfer_end = 1;
1849 return(SD_TX_UNDERRUN);
1850 }
1851
1852 if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
1853 {
1854 /* clear flag */
1855 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
1856 transfer_error = SD_START_BIT_ERR;
1857 transfer_end = 1;
1858 return(SD_START_BIT_ERR);
1859 }
1860
1861 /* disable interrupt */
1862 sdio_interrupt_enable(SDIOx, (SDIO_DTFAIL_INT | SDIO_DTTIMEOUT_INT | \
1863 SDIO_DTCMP_INT | SDIO_TXBUFH_INT | SDIO_RXBUFH_INT | \
1864 SDIO_TXERRU_INT| SDIO_RXERRO_INT | SDIO_SBITERR_INT), FALSE);
1865 return(SD_OK);
1866}
1867
1873 sd_error_status_type command_error(void)
1874{
1875 sd_error_status_type status = SD_OK;
1876 uint32_t timeout = SDIO_CMD0TIMEOUT;
1877
1878 while(timeout--)
1879 {
1880 if(sdio_flag_get(SDIOx, SDIO_CMDCMPL_FLAG) != RESET)
1881 {
1882 break;
1883 }
1884 }
1885
1886 if(timeout == 0)
1887 {
1888 return SD_CMD_RSP_TIMEOUT;
1889 }
1890
1891 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1892 return status;
1893}
1894
1900 sd_error_status_type command_rsp7_error(void)
1901{
1902 sd_error_status_type status = SD_OK;
1903 uint32_t sts_reg = 0;
1904 uint32_t timeout = SDIO_CMD0TIMEOUT;
1905
1906 while(timeout--)
1907 {
1908 sts_reg = SDIOx->sts;
1909
1910 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1911 {
1912 break;
1913 }
1914 }
1915
1916 if((timeout == 0) || (sts_reg & SDIO_CMDTIMEOUT_FLAG))
1917 {
1918 status = SD_CMD_RSP_TIMEOUT;
1919 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1920 return status;
1921 }
1922
1923 if(sts_reg & SDIO_CMDRSPCMPL_FLAG)
1924 {
1925 status = SD_OK;
1926 sdio_flag_clear(SDIOx, SDIO_CMDRSPCMPL_FLAG);
1927 }
1928
1929 return status;
1930}
1931
1937 sd_error_status_type command_rsp1_error(uint8_t cmd)
1938{
1939 uint32_t sts_reg = 0;
1940 uint32_t rsp_cmd = 0;
1941
1942 while(1)
1943 {
1944 sts_reg = SDIOx->sts;
1945
1946 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1947 {
1948 break;
1949 }
1950 }
1951
1952 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1953 {
1954 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1955 return SD_CMD_RSP_TIMEOUT;
1956 }
1957
1958 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
1959 {
1960 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
1961 return SD_CMD_FAIL;
1962 }
1963
1964 rsp_cmd = sdio_command_response_get(SDIOx);
1965 if(rsp_cmd != cmd)
1966 {
1967 return SD_ILLEGAL_CMD;
1968 }
1969
1970 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
1971
1972 return (sd_error_status_type)(sdio_response_get(SDIOx, SDIO_RSP1_INDEX) & SD_OCR_ERRORBITS);
1973}
1974
1980 sd_error_status_type command_rsp3_error(void)
1981{
1982 uint32_t sts_reg = 0;;
1983
1984 while(1)
1985 {
1986 sts_reg = SDIOx->sts;
1987
1988 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
1989 {
1990 break;
1991 }
1992 }
1993
1994 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
1995 {
1996 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
1997 return SD_CMD_RSP_TIMEOUT;
1998 }
1999
2000 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2001
2002 return SD_OK;
2003}
2004
2010 sd_error_status_type command_rsp2_error(void)
2011{
2012 sd_error_status_type status = SD_OK;
2013 uint32_t sts_reg;
2014 uint32_t timeout = SDIO_CMD0TIMEOUT;
2015
2016 while(timeout--)
2017 {
2018 sts_reg = SDIOx->sts;
2019
2020 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2021 {
2022 break;
2023 }
2024 }
2025
2026 if((timeout == 0) || sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2027 {
2028 status = SD_CMD_RSP_TIMEOUT;
2029 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2030
2031 return status;
2032 }
2033
2034 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2035 {
2036 status = SD_CMD_FAIL;
2037 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2038 }
2039
2040 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2041
2042 return status;
2043}
2044
2050 sd_error_status_type command_rsp4_error(uint8_t cmd)
2051{
2052 uint32_t sts_reg = 0, rsp_cmd = 0;
2053
2054 while(1)
2055 {
2056 sts_reg = SDIOx->sts;
2057
2058 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2059 {
2060 break;
2061 }
2062 }
2063
2064 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2065 {
2066 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2067 return SD_CMD_RSP_TIMEOUT;
2068 }
2069
2070 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2071 {
2072 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2073
2074 return SD_CMD_FAIL;
2075 }
2076
2077 rsp_cmd = sdio_command_response_get(SDIOx);
2078 if(rsp_cmd != cmd)
2079 {
2080 return SD_ILLEGAL_CMD;
2081 }
2082
2083 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2084
2085 return SD_OK;
2086}
2087
2093 sd_error_status_type command_rsp5_error(uint8_t cmd)
2094{
2095 uint32_t sts_reg = 0, rsp_cmd = 0, response = 0;
2096
2097 while(1)
2098 {
2099 sts_reg = SDIOx->sts;
2100
2101 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2102 {
2103 break;
2104 }
2105 }
2106
2107 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2108 {
2109 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2110
2111 return SD_CMD_RSP_TIMEOUT;
2112 }
2113
2114 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2115 {
2116 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2117
2118 return SD_CMD_FAIL;
2119 }
2120
2121 rsp_cmd = sdio_command_response_get(SDIOx);
2122 if(rsp_cmd != cmd)
2123 {
2124 return SD_ILLEGAL_CMD;
2125 }
2126
2127 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2128
2129 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2130
2131 if(response & SD_R5_OUT_OF_RANGE)
2132 {
2133 return SD_CMD_OUT_OF_RANGE;
2134 }
2135
2136 if(response & SD_R5_FUNCTION_NUMBER)
2137 {
2138 return SD_SDIO_UNKNOWN_FUNC;
2139 }
2140
2141 if(response & SD_R5_ERROR)
2142 {
2143 return SD_GENERAL_UNKNOWN_ERROR;
2144 }
2145
2146 return SD_OK;
2147}
2148
2156 sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *prca)
2157{
2158 sd_error_status_type status = SD_OK;
2159 uint32_t sts_reg, rsp_cmd = 0, response = 0;
2160
2161 while(1)
2162 {
2163 sts_reg = SDIOx->sts;
2164
2165 if(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG))
2166 {
2167 break;
2168 }
2169 }
2170
2171 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2172 {
2173 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2174 return SD_CMD_RSP_TIMEOUT;
2175 }
2176
2177 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2178 {
2179 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2180 return SD_CMD_FAIL;
2181 }
2182
2183 rsp_cmd = sdio_command_response_get(SDIOx);
2184 if(rsp_cmd != cmd)
2185 {
2186 return SD_ILLEGAL_CMD;
2187 }
2188
2189 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2190
2191 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2192
2193 if(SD_ALLZERO == (response & (SD_R6_GENERAL_UNKNOWN_ERROR | SD_R6_ILLEGAL_CMD | SD_R6_CMD_CRC_ERROR)))
2194 {
2195 *prca = (uint16_t)(response >> 16);
2196 return status;
2197 }
2198
2199 if(response & SD_R6_GENERAL_UNKNOWN_ERROR)
2200 {
2201 return SD_GENERAL_UNKNOWN_ERROR;
2202 }
2203
2204 if(response & SD_R6_ILLEGAL_CMD)
2205 {
2206 return SD_ILLEGAL_CMD;
2207 }
2208
2209 if(response & SD_R6_CMD_CRC_ERROR)
2210 {
2211 return SD_CMD_CRC_ERROR;
2212 }
2213
2214 return status;
2215}
2216
2222 sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
2223{
2224 sd_error_status_type status = SD_OK;
2225 uint32_t response = 0;
2226 uint8_t arg = 0x00;
2227
2228 if(new_state == TRUE)
2229 {
2230 arg = 0x02;
2231 }
2232 else
2233 {
2234 arg = 0x00;
2235 }
2236
2237 /* get response1 */
2238 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2239
2240 /* check card locked or not */
2241 if(response & SD_CARD_LOCKED)
2242 {
2243 return SD_LOCK_UNLOCK_ERROR;
2244 }
2245
2246 if(sd_card_info.sd_scr_reg.sd_bus_width)
2247 {
2248 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2249 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2250 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2251 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2252
2253 /* sdio command config */
2254 sdio_command_config(SDIOx, &sdio_command_init_struct);
2255 /* enable ccsm */
2256 sdio_command_state_machine_enable(SDIOx, TRUE);
2257
2258 status = command_rsp1_error(SD_CMD_APP_CMD);
2259
2260 if(status != SD_OK)
2261 {
2262 return status;
2263 }
2264
2265 sdio_command_init_struct.argument = arg;
2266 sdio_command_init_struct.cmd_index = SD_CMD_APP_SD_SET_BUSWIDTH;
2267 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2268 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2269
2270 /* sdio command config */
2271 sdio_command_config(SDIOx, &sdio_command_init_struct);
2272 /* enable ccsm */
2273 sdio_command_state_machine_enable(SDIOx, TRUE);
2274
2275 status = command_rsp1_error(SD_CMD_APP_SD_SET_BUSWIDTH);
2276 return status;
2277 }
2278 else
2279 {
2280 return SD_REQ_NOT_APPLICABLE;
2281 }
2282}
2283
2291 sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
2292{
2293 sd_error_status_type status = SD_OK;
2294 uint32_t card_status = 0, timeout = 0;
2295
2296 sdio_command_init_struct.argument = (EXT_CSD_Write_byte << 24) | (index << 16) | (value << 8) | set;
2297 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2298 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2299 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2300
2301 /* sdio command config */
2302 sdio_command_config(SDIOx, &sdio_command_init_struct);
2303 /* enable ccsm */
2304 sdio_command_state_machine_enable(SDIOx, TRUE);
2305
2306 status = command_rsp1_error(SD_CMD_HS_SWITCH);
2307 if(status != SD_OK)
2308 {
2309 return status;
2310 }
2311
2312 card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2313 if(card_status & MMC_SWITCH_ERROR)
2314 {
2315 return SD_SWITCH_ERROR;
2316 }
2317
2318 timeout = SD_DATATIMEOUT;
2319 do
2320 {
2321 timeout--;
2322 status = sd_status_send(&card_status);
2323 } /* check ready_for_data flag */
2324 while(((card_status & 0x00000100) == 0) && (timeout > 0));
2325
2326 if(timeout == 0)
2327 {
2328 return SD_ERROR;
2329 }
2330
2331 return status;
2332}
2333
2342 sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
2343{
2344 sd_error_status_type status = SD_OK;
2345 uint8_t power;
2346 uint16_t blk_size;
2347
2348 if(rsp == NULL)
2349 {
2350 return SD_INVALID_PARAMETER;
2351 }
2352
2353 SDIOx->dtctrl = 0x0;
2354
2355 blk_size = 64;
2356 power = convert_from_bytes_to_power_of_two(blk_size);
2357
2358 sdio_command_init_struct.argument = blk_size;
2359 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2360 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2361 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2362
2363 /* sdio command config */
2364 sdio_command_config(SDIOx, &sdio_command_init_struct);
2365 /* enable ccsm */
2366 sdio_command_state_machine_enable(SDIOx, TRUE);
2367
2368 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2369
2370 if(status != SD_OK)
2371 {
2372 return status;
2373 }
2374
2375 sdio_data_init_struct.block_size = (sdio_block_size_type)(power);
2376 sdio_data_init_struct.data_length = blk_size ;
2377 sdio_data_init_struct.timeout = SD_DATATIMEOUT ;
2378 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2379 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2380
2381 sdio_command_init_struct.argument = (mode << 31) | 0x00FFFFFF;
2382 sdio_command_init_struct.argument &= ~(0xF << (group * 4));
2383 sdio_command_init_struct.argument |= value << (group * 4);
2384 sdio_command_init_struct.cmd_index = SD_CMD_HS_SWITCH;
2385 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2386 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2387
2388 stop_flag = 0;
2389
2390 return sdio_command_data_send(&sdio_command_init_struct, &sdio_data_init_struct, (uint32_t *)rsp);
2391}
2392
2398 sd_error_status_type check_card_programming(uint8_t *p_status)
2399{
2400 volatile uint32_t response = 0, sts_reg = 0, rsp_cmd = 0;
2401
2402 /* send cmd13 */
2403 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2404 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2405 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2406 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2407
2408 /* sdio command config */
2409 sdio_command_config(SDIOx, &sdio_command_init_struct);
2410 /* enable ccsm */
2411 sdio_command_state_machine_enable(SDIOx, TRUE);
2412
2413 sts_reg = SDIOx->sts;
2414
2415 while(!(sts_reg & (SDIO_CMDFAIL_FLAG | SDIO_CMDTIMEOUT_FLAG | SDIO_CMDRSPCMPL_FLAG)))
2416 {
2417 sts_reg = SDIOx->sts;
2418 }
2419
2420 if(sdio_flag_get(SDIOx, SDIO_CMDFAIL_FLAG) != RESET)
2421 {
2422 sdio_flag_clear(SDIOx, SDIO_CMDFAIL_FLAG);
2423 return SD_CMD_FAIL;
2424 }
2425
2426 if(sdio_flag_get(SDIOx, SDIO_CMDTIMEOUT_FLAG) != RESET)
2427 {
2428 sdio_flag_clear(SDIOx, SDIO_CMDTIMEOUT_FLAG);
2429 return SD_CMD_RSP_TIMEOUT;
2430 }
2431
2432 rsp_cmd = sdio_command_response_get(SDIOx);
2433 if(rsp_cmd!= SD_CMD_SEND_STATUS)
2434 {
2435 return SD_ILLEGAL_CMD;
2436 }
2437
2438 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2439
2440 response = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2441
2442 *p_status = (uint8_t)((response >> 9) & 0x0000000F);
2443
2444 return SD_OK;
2445}
2446
2452 sd_error_status_type sd_status_send(uint32_t *p_card_status)
2453{
2454 sd_error_status_type status = SD_OK;
2455
2456 if(p_card_status == NULL)
2457 {
2458 status = SD_INVALID_PARAMETER;
2459 return status;
2460 }
2461
2462 sdio_command_init_struct.argument = (uint32_t)(rca << 16);
2463 sdio_command_init_struct.cmd_index = SD_CMD_SEND_STATUS;
2464 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2465 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2466
2467 /* sdio command config */
2468 sdio_command_config(SDIOx, &sdio_command_init_struct);
2469 /* enable ccsm */
2470 sdio_command_state_machine_enable(SDIOx, TRUE);
2471
2472 status = command_rsp1_error(SD_CMD_SEND_STATUS);
2473
2474 if(status != SD_OK)
2475 {
2476 return status;
2477 }
2478
2479 *p_card_status = sdio_response_get(SDIOx, SDIO_RSP1_INDEX);
2480
2481 return status;
2482}
2483
2489 sd_card_state_type sd_state_get(void)
2490{
2491 uint32_t response = 0;
2492
2493 if(sd_status_send(&response) != SD_OK)
2494 {
2495 return SD_CARD_ERROR;
2496 }
2497 else
2498 {
2499 return (sd_card_state_type)((response >> 9) & 0x0F);
2500 }
2501}
2502
2507 sd_error_status_type scr_find(void)
2508{
2509 uint32_t index = 0, sts_reg = 0;
2510 sd_error_status_type status = SD_OK;
2511 uint32_t *tempscr;
2512
2513 tempscr = (uint32_t *) &(sd_card_info.sd_scr_reg);
2514
2515 /* send cmd16, set block length */
2516 sdio_command_init_struct.argument = (uint32_t)8;
2517 sdio_command_init_struct.cmd_index = SD_CMD_SET_BLOCKLEN;
2518 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2519 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2520
2521 /* sdio command config */
2522 sdio_command_config(SDIOx, &sdio_command_init_struct);
2523 /* enable ccsm */
2524 sdio_command_state_machine_enable(SDIOx, TRUE);
2525
2526 status = command_rsp1_error(SD_CMD_SET_BLOCKLEN);
2527
2528 if(status != SD_OK)
2529 {
2530 return status;
2531 }
2532
2533 /* send cmd55 */
2534 sdio_command_init_struct.argument = (uint32_t)(sd_card_info.rca << 16);
2535 sdio_command_init_struct.cmd_index = SD_CMD_APP_CMD;
2536 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2537 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2538
2539 /* sdio command config */
2540 sdio_command_config(SDIOx, &sdio_command_init_struct);
2541 /* enable ccsm */
2542 sdio_command_state_machine_enable(SDIOx, TRUE);
2543
2544 status = command_rsp1_error(SD_CMD_APP_CMD);
2545
2546 if(status != SD_OK)
2547 {
2548 return status;
2549 }
2550
2551 sdio_data_init_struct.block_size = SDIO_DATA_BLOCK_SIZE_8B;
2552 sdio_data_init_struct.data_length = 8;
2553 sdio_data_init_struct.timeout = SD_DATATIMEOUT;
2554 sdio_data_init_struct.transfer_direction = SDIO_DATA_TRANSFER_TO_CONTROLLER;
2555 sdio_data_init_struct.transfer_mode = SDIO_DATA_BLOCK_TRANSFER;
2556
2557 sdio_data_config(SDIOx, &sdio_data_init_struct);
2558 sdio_data_state_machine_enable(SDIOx, TRUE);
2559
2560 /* send cmd51 */
2561 sdio_command_init_struct.argument = 0x0;
2562 sdio_command_init_struct.cmd_index = SD_CMD_SD_APP_SEND_SCR;
2563 sdio_command_init_struct.rsp_type = SDIO_RESPONSE_SHORT;
2564 sdio_command_init_struct.wait_type = SDIO_WAIT_FOR_NO;
2565
2566 /* sdio command config */
2567 sdio_command_config(SDIOx, &sdio_command_init_struct);
2568 /* enable ccsm */
2569 sdio_command_state_machine_enable(SDIOx, TRUE);
2570
2571 status = command_rsp1_error(SD_CMD_SD_APP_SEND_SCR);
2572
2573 if(status != SD_OK)
2574 {
2575 return status;
2576 }
2577
2578 sts_reg = SDIOx->sts;
2579
2580 while(!(sts_reg & (SDIO_RXERRO_FLAG | SDIO_DTFAIL_FLAG | SDIO_DTTIMEOUT_FLAG | SDIO_DTBLKCMPL_FLAG | SDIO_SBITERR_FLAG)))
2581 {
2582 if(sdio_flag_get(SDIOx, SDIO_RXBUF_FLAG) != RESET)
2583 {
2584 *(tempscr + index) = sdio_data_read(SDIOx);
2585 index++;
2586 }
2587 sts_reg = SDIOx->sts;
2588 }
2589
2590 if(sdio_flag_get(SDIOx, SDIO_DTTIMEOUT_FLAG) != RESET)
2591 {
2592 sdio_flag_clear(SDIOx, SDIO_DTTIMEOUT_FLAG);
2593 return SD_DATA_TIMEOUT;
2594 }
2595 else if(sdio_flag_get(SDIOx, SDIO_DTFAIL_FLAG) != RESET)
2596 {
2597 sdio_flag_clear(SDIOx, SDIO_DTFAIL_FLAG);
2598 return SD_DATA_FAIL;
2599 }
2600 else if(sdio_flag_get(SDIOx, SDIO_RXERRO_FLAG) != RESET)
2601 {
2602 sdio_flag_clear(SDIOx, SDIO_RXERRO_FLAG);
2603 return SD_RX_OVERRUN;
2604 }
2605 else if(sdio_flag_get(SDIOx, SDIO_SBITERR_FLAG) != RESET)
2606 {
2607 sdio_flag_clear(SDIOx, SDIO_SBITERR_FLAG);
2608 return SD_START_BIT_ERR;
2609 }
2610
2611 sdio_flag_clear(SDIOx, SDIO_STATIC_FLAGS);
2612
2613 return status;
2614}
2615
2621 sd_error_status_type speed_change(uint8_t speed)
2622{
2623 sd_error_status_type status = SD_OK;
2624 uint8_t switch_sts[64];
2625
2626 if(speed > 1)
2627 {
2628 return SD_ERROR;
2629 }
2630
2631 /* check card type */
2632 if((SDIO_STD_CAPACITY_SD_CARD_V1_1 == card_type) || (SDIO_STD_CAPACITY_SD_CARD_V2_0 == card_type) || \
2633 (SDIO_HIGH_CAPACITY_SD_CARD == card_type))
2634 {
2635 /* version 1.01 card does not support cmd6 */
2636 if(sd_card_info.sd_scr_reg.sd_spec == 0)
2637 {
2638 return SD_ERROR;
2639 }
2640
2641 /* check group 1 function support speed */
2642 status = sd_switch(0, 0, speed, switch_sts);
2643
2644 if(status != 0)
2645 {
2646 return status;
2647 }
2648
2649 if((switch_sts[13] & (1 << speed)) == 0)
2650 {
2651 return SD_ERROR;
2652 }
2653
2654 status = sd_switch(1, 0, speed, switch_sts);
2655
2656 if(status != 0)
2657 {
2658 return status;
2659 }
2660
2661 /* read it back for confirmation */
2662 if((switch_sts[16] & 0xF) != speed)
2663 {
2664 return SD_ERROR;
2665 }
2666 }
2667 else if(card_type == SDIO_HIGH_SPEED_MULTIMEDIA_CARD)
2668 {
2669 status = mmc_switch(EXT_CSD_CMD_SET_NORMAL, EXT_CSD_BUS_WIDTH, (uint8_t)speed);
2670
2671 if(status != 0)
2672 {
2673 return status;
2674 }
2675 }
2676
2677 return status;
2678}
2679
2685uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
2686{
2687 uint8_t count = 0;
2688
2689 while(number_of_bytes != 1)
2690 {
2691 number_of_bytes >>= 1;
2692 count++;
2693 }
2694
2695 return count;
2696}
2697
2706void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
2707{
2708 dma_init_type dma_init_struct;
2709 dma_default_para_init(&dma_init_struct);
2710
2711 crm_periph_clock_enable(CRM_DMA2_PERIPH_CLOCK, TRUE);
2712
2713 dma_reset(DMA2_CHANNEL4);
2714 dma_channel_enable(DMA2_CHANNEL4, FALSE);
2715
2716 dma_init_struct.peripheral_base_addr = (uint32_t)&SDIOx->buf;
2717 dma_init_struct.memory_base_addr = (uint32_t)mbuf;
2718 dma_init_struct.direction = dir;
2719 dma_init_struct.buffer_size = buf_size / 4;
2720 dma_init_struct.peripheral_inc_enable = FALSE;
2721 dma_init_struct.memory_inc_enable = TRUE;
2722 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_WORD;
2723 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_WORD;
2724 dma_init_struct.loop_mode_enable = FALSE;
2725 dma_init_struct.priority = DMA_PRIORITY_HIGH;
2726 dma_init(DMA2_CHANNEL4, &dma_init_struct);
2727
2728 dma_channel_enable(DMA2_CHANNEL4, TRUE);
2729}
2730
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
gpio_init_struct
gpio_init_type gpio_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:38
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
sd_card_info
sd_card_info_struct_type sd_card_info
Definition: sdio_fatfs/src/at32_sdio.c:49
sd_switch
sd_error_status_type sd_switch(uint32_t mode, uint32_t group, uint8_t value, uint8_t *rsp)
switch sd card speed to high speed
Definition: sdio_fatfs/src/at32_sdio.c:2342
command_rsp5_error
sd_error_status_type command_rsp5_error(uint8_t cmd)
checks for error conditions for r5 response.
Definition: sdio_fatfs/src/at32_sdio.c:2093
speed_change
sd_error_status_type speed_change(uint8_t speed)
set bus speed
Definition: sdio_fatfs/src/at32_sdio.c:2621
sd_power_off
sd_error_status_type sd_power_off(void)
turns the sdio output signals off.
Definition: sdio_fatfs/src/at32_sdio.c:403
sdio_data_init_struct
sdio_data_struct_type sdio_data_init_struct
Definition: sdio_fatfs/src/at32_sdio.c:41
sd_irq_service
sd_error_status_type sd_irq_service(void)
allows to process all the interrupts that are high.
Definition: sdio_fatfs/src/at32_sdio.c:1789
transfer_end
volatile uint8_t transfer_end
Definition: sdio_fatfs/src/at32_sdio.c:48
command_rsp7_error
sd_error_status_type command_rsp7_error(void)
checks for error conditions for R7 response.
Definition: sdio_fatfs/src/at32_sdio.c:1900
sd_device_mode_set
sd_error_status_type sd_device_mode_set(uint32_t mode)
set sdio work mode.
Definition: sdio_fatfs/src/at32_sdio.c:786
card_type
static sd_memory_card_type card_type
Definition: sdio_fatfs/src/at32_sdio.c:43
convert_from_bytes_to_power_of_two
uint8_t convert_from_bytes_to_power_of_two(uint16_t number_of_bytes)
converts the number of bytes in power of two and returns the power.
Definition: sdio_fatfs/src/at32_sdio.c:2685
sd_card_info_get
sd_error_status_type sd_card_info_get(sd_card_info_struct_type *card_info)
returns information about specific card.
Definition: sdio_fatfs/src/at32_sdio.c:532
sdio_command_init_struct
sdio_command_struct_type sdio_command_init_struct
Definition: sdio_fatfs/src/at32_sdio.c:40
mmc_stream_write
sd_error_status_type mmc_stream_write(uint8_t *buf, long long addr, uint32_t len)
write mmc card data stream.
Definition: sdio_fatfs/src/at32_sdio.c:1700
sd_card_init
sd_error_status_type sd_card_init(void)
intialises all cards or single card as the case may be card(s) come into standby state.
Definition: sdio_fatfs/src/at32_sdio.c:417
sd_block_read
sd_error_status_type sd_block_read(uint8_t *buf, long long addr, uint16_t blk_size)
allows to read one block from a specified address in a card. the data transfer can be managed by dma ...
Definition: sdio_fatfs/src/at32_sdio.c:1188
sd_deselect_select
sd_error_status_type sd_deselect_select(uint32_t addr)
selects od deselects the corresponding card.
Definition: sdio_fatfs/src/at32_sdio.c:807
command_rsp6_error
sd_error_status_type command_rsp6_error(uint8_t cmd, uint16_t *p_rca)
checks for error conditions for r6 (rca) response.
Definition: sdio_fatfs/src/at32_sdio.c:2156
SDIO1_IRQHandler
void SDIO1_IRQHandler(void)
sdio1 isr.
Definition: sdio_fatfs/src/at32_sdio.c:1769
stop_flag
static uint8_t stop_flag
Definition: sdio_fatfs/src/at32_sdio.c:46
mmc_switch
sd_error_status_type mmc_switch(uint8_t set, uint8_t index, uint8_t value)
switch mmc card speed to high speed
Definition: sdio_fatfs/src/at32_sdio.c:2291
sd_blocks_erase
sd_error_status_type sd_blocks_erase(long long addr, uint32_t nblks)
erase continuous data block
Definition: sdio_fatfs/src/at32_sdio.c:1030
check_card_programming
sd_error_status_type check_card_programming(uint8_t *p_status)
checks if the sd card is in programming state.
Definition: sdio_fatfs/src/at32_sdio.c:2398
transfer_error
volatile sd_error_status_type transfer_error
Definition: sdio_fatfs/src/at32_sdio.c:47
sd_bus_wide_enable
sd_error_status_type sd_bus_wide_enable(confirm_state new_state)
enable or disable the sdio wide bus mode.
Definition: sdio_fatfs/src/at32_sdio.c:2222
command_rsp1_error
sd_error_status_type command_rsp1_error(uint8_t cmd)
checks for error conditions for R1 response.
Definition: sdio_fatfs/src/at32_sdio.c:1937
SDIO2_IRQHandler
void SDIO2_IRQHandler(void)
sdio2 isr.
Definition: sdio_fatfs/src/at32_sdio.c:1779
sd_mult_blocks_write
sd_error_status_type sd_mult_blocks_write(const uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to write blocks starting from a specified address in a card. the data transfer can be managed ...
Definition: sdio_fatfs/src/at32_sdio.c:1489
csd_table
static uint32_t csd_table[4]
Definition: sdio_fatfs/src/at32_sdio.c:44
sdio_clock_set
void sdio_clock_set(uint32_t clk_div)
set sdio clock devision factor.
Definition: sdio_fatfs/src/at32_sdio.c:188
sd_state_get
sd_card_state_type sd_state_get(void)
returns information about sd card.
Definition: sdio_fatfs/src/at32_sdio.c:2489
cid_table
static uint32_t cid_table[4]
Definition: sdio_fatfs/src/at32_sdio.c:44
sd_dma_config
void sd_dma_config(uint32_t *mbuf, uint32_t buf_size, dma_dir_type dir)
set dma configuation for sdio
Definition: sdio_fatfs/src/at32_sdio.c:2706
sd_block_write
sd_error_status_type sd_block_write(const uint8_t *buf, long long addr, uint16_t blk_size)
allows to write one block starting from a specified address in a card. the data transfer can be manag...
Definition: sdio_fatfs/src/at32_sdio.c:1367
device_mode
static sd_data_transfer_mode_type device_mode
Definition: sdio_fatfs/src/at32_sdio.c:45
sd_status_send
sd_error_status_type sd_status_send(uint32_t *p_card_status)
read current card status.
Definition: sdio_fatfs/src/at32_sdio.c:2452
sdio_command_data_send
sd_error_status_type sdio_command_data_send(sdio_command_struct_type *sdio_cmd_init_t, sdio_data_struct_type *sdio_data_init_t, uint32_t *buf)
read data from or write data to sd card.
Definition: sdio_fatfs/src/at32_sdio.c:830
command_rsp2_error
sd_error_status_type command_rsp2_error(void)
checks for error conditions for R2 (cid or csd) response.
Definition: sdio_fatfs/src/at32_sdio.c:2010
sd_init
sd_error_status_type sd_init(void)
initializes the sd card and put it into standby state (ready for data transfer).
Definition: sdio_fatfs/src/at32_sdio.c:73
mmc_stream_read
sd_error_status_type mmc_stream_read(uint8_t *buf, long long addr, uint32_t len)
read mmc card data stream.
Definition: sdio_fatfs/src/at32_sdio.c:1653
scr_find
sd_error_status_type scr_find(void)
find the sd card scr register value.
Definition: sdio_fatfs/src/at32_sdio.c:2507
sd_power_on
sd_error_status_type sd_power_on(void)
enquires cards about their operating voltage and configures clock controls.
Definition: sdio_fatfs/src/at32_sdio.c:203
command_rsp4_error
sd_error_status_type command_rsp4_error(uint8_t cmd)
checks for error conditions for r4 response.
Definition: sdio_fatfs/src/at32_sdio.c:2050
sd_mult_blocks_read
sd_error_status_type sd_mult_blocks_read(uint8_t *buf, long long addr, uint16_t blk_size, uint32_t nblks)
allows to read blocks from a specified address in a card. the data transfer can be managed by dma mod...
Definition: sdio_fatfs/src/at32_sdio.c:1277
sd_wide_bus_operation_config
sd_error_status_type sd_wide_bus_operation_config(sdio_bus_width_type mode)
enable wide bus opeartion for the requeseted card if supported by card.
Definition: sdio_fatfs/src/at32_sdio.c:743
rca
static uint32_t rca
Definition: sdio_fatfs/src/at32_sdio.c:44
command_rsp3_error
sd_error_status_type command_rsp3_error(void)
checks for error conditions for R3 (ocr) response.
Definition: sdio_fatfs/src/at32_sdio.c:1980
command_error
sd_error_status_type command_error(void)
checks for error conditions for cmd0.
Definition: sdio_fatfs/src/at32_sdio.c:1873
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_SDIO1_PERIPH_CLOCK
@ CRM_SDIO1_PERIPH_CLOCK
Definition: at32f413_crm.h:107
CRM_GPIOC_PERIPH_CLOCK
@ CRM_GPIOC_PERIPH_CLOCK
Definition: at32f413_crm.h:112
CRM_GPIOD_PERIPH_CLOCK
@ CRM_GPIOD_PERIPH_CLOCK
Definition: at32f413_crm.h:113
CRM_DMA2_PERIPH_CLOCK
@ CRM_DMA2_PERIPH_CLOCK
Definition: at32f413_crm.h:105
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
dma_dir_type
dma_dir_type
dma direction type
Definition: at32f413_dma.h:216
DMA_PERIPHERAL_DATA_WIDTH_WORD
@ DMA_PERIPHERAL_DATA_WIDTH_WORD
Definition: at32f413_dma.h:247
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_WORD
@ DMA_MEMORY_DATA_WIDTH_WORD
Definition: at32f413_dma.h:257
DMA_PRIORITY_HIGH
@ DMA_PRIORITY_HIGH
Definition: at32f413_dma.h:267
DMA2_CHANNEL4
#define DMA2_CHANNEL4
Definition: at32f413_dma.h:492
confirm_state
confirm_state
confirm state
Definition: at32f413.h:259
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_NONE
@ GPIO_PULL_NONE
Definition: at32f413_gpio.h:244
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_10
#define GPIO_PINS_10
Definition: at32f413_gpio.h:61
GPIO_PINS_11
#define GPIO_PINS_11
Definition: at32f413_gpio.h:62
GPIO_PINS_2
#define GPIO_PINS_2
Definition: at32f413_gpio.h:53
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_9
#define GPIO_PINS_9
Definition: at32f413_gpio.h:60
GPIO_PINS_8
#define GPIO_PINS_8
Definition: at32f413_gpio.h:59
GPIOC
#define GPIOC
Definition: at32f413_gpio.h:750
GPIOD
#define GPIOD
Definition: at32f413_gpio.h:751
sdio_command_config
void sdio_command_config(sdio_type *sdio_x, sdio_command_struct_type *command_struct)
config sdio command.
Definition: at32f413_sdio.c:340
sdio_data_write
void sdio_data_write(sdio_type *sdio_x, uint32_t data)
write one word data to fifo.
Definition: at32f413_sdio.c:501
sdio_data_config
void sdio_data_config(sdio_type *sdio_x, sdio_data_struct_type *data_struct)
config sdio data.
Definition: at32f413_sdio.c:427
sdio_data_read
uint32_t sdio_data_read(sdio_type *sdio_x)
read a word data from sdio fifo.
Definition: at32f413_sdio.c:476
sdio_power_status_get
flag_status sdio_power_status_get(sdio_type *sdio_x)
get power status.
Definition: at32f413_sdio.c:87
sdio_command_state_machine_enable
void sdio_command_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable command path state machine(CPSM).
Definition: at32f413_sdio.c:363
sdio_clock_bypass
void sdio_clock_bypass(sdio_type *sdio_x, confirm_state new_state)
enable or disable clock divider bypss
Definition: at32f413_sdio.c:152
sdio_flow_control_enable
void sdio_flow_control_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable hardware flow control.
Definition: at32f413_sdio.c:179
sdio_power_set
void sdio_power_set(sdio_type *sdio_x, sdio_power_state_type power_state)
set the power status of the controller
Definition: at32f413_sdio.c:75
sdio_clock_config
void sdio_clock_config(sdio_type *sdio_x, uint16_t clk_div, sdio_edge_phase_type clk_edg)
config sdio clock
Definition: at32f413_sdio.c:115
sdio_bus_width_config
void sdio_bus_width_config(sdio_type *sdio_x, sdio_bus_width_type width)
config sdio bus width
Definition: at32f413_sdio.c:139
sdio_interrupt_enable
void sdio_interrupt_enable(sdio_type *sdio_x, uint32_t int_opt, confirm_state new_state)
config corresponding interrupt.
Definition: at32f413_sdio.c:243
sdio_flag_clear
void sdio_flag_clear(sdio_type *sdio_x, uint32_t flag)
clear sdio flag.
Definition: at32f413_sdio.c:326
sdio_response_get
uint32_t sdio_response_get(sdio_type *sdio_x, sdio_rsp_index_type reg_index)
get response received from the card for the last command.
Definition: at32f413_sdio.c:394
sdio_data_state_machine_enable
void sdio_data_state_machine_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable data path state machine(DPSM).
Definition: at32f413_sdio.c:452
sdio_power_saving_mode_enable
void sdio_power_saving_mode_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable power saving mode, config sdio_ck clock output when the bus is idle.
Definition: at32f413_sdio.c:166
sdio_flag_get
flag_status sdio_flag_get(sdio_type *sdio_x, uint32_t flag)
get sdio flag.
Definition: at32f413_sdio.c:289
sdio_dma_enable
void sdio_dma_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable dma.
Definition: at32f413_sdio.c:205
sdio_reset
void sdio_reset(sdio_type *sdio_x)
reset the sdio register
Definition: at32f413_sdio.c:51
sdio_clock_enable
void sdio_clock_enable(sdio_type *sdio_x, confirm_state new_state)
enable or disable sdio_ck output.
Definition: at32f413_sdio.c:192
sdio_command_response_get
uint8_t sdio_command_response_get(sdio_type *sdio_x)
get command index of last command for which response received.
Definition: at32f413_sdio.c:376
sdio_bus_width_type
sdio_bus_width_type
sdio bus width
Definition: at32f413_sdio.h:139
sdio_block_size_type
sdio_block_size_type
sdio data block size
Definition: at32f413_sdio.h:180
SDIO_WAIT_FOR_NO
@ SDIO_WAIT_FOR_NO
Definition: at32f413_sdio.h:160
SDIO_WAIT_FOR_INT
@ SDIO_WAIT_FOR_INT
Definition: at32f413_sdio.h:161
SDIO_RESPONSE_LONG
@ SDIO_RESPONSE_LONG
Definition: at32f413_sdio.h:152
SDIO_RESPONSE_SHORT
@ SDIO_RESPONSE_SHORT
Definition: at32f413_sdio.h:151
SDIO_RESPONSE_NO
@ SDIO_RESPONSE_NO
Definition: at32f413_sdio.h:150
SDIO_CLOCK_EDGE_FALLING
@ SDIO_CLOCK_EDGE_FALLING
Definition: at32f413_sdio.h:132
SDIO_DATA_TRANSFER_TO_CARD
@ SDIO_DATA_TRANSFER_TO_CARD
Definition: at32f413_sdio.h:212
SDIO_DATA_TRANSFER_TO_CONTROLLER
@ SDIO_DATA_TRANSFER_TO_CONTROLLER
Definition: at32f413_sdio.h:213
SDIO_POWER_OFF
@ SDIO_POWER_OFF
Definition: at32f413_sdio.h:122
SDIO_POWER_ON
@ SDIO_POWER_ON
Definition: at32f413_sdio.h:123
SDIO_DATA_BLOCK_TRANSFER
@ SDIO_DATA_BLOCK_TRANSFER
Definition: at32f413_sdio.h:203
SDIO_DATA_STREAM_TRANSFER
@ SDIO_DATA_STREAM_TRANSFER
Definition: at32f413_sdio.h:204
SDIO_BUS_WIDTH_D1
@ SDIO_BUS_WIDTH_D1
Definition: at32f413_sdio.h:140
SDIO_BUS_WIDTH_D4
@ SDIO_BUS_WIDTH_D4
Definition: at32f413_sdio.h:141
SDIO_RSP3_INDEX
@ SDIO_RSP3_INDEX
Definition: at32f413_sdio.h:172
SDIO_RSP2_INDEX
@ SDIO_RSP2_INDEX
Definition: at32f413_sdio.h:171
SDIO_RSP4_INDEX
@ SDIO_RSP4_INDEX
Definition: at32f413_sdio.h:173
SDIO_RSP1_INDEX
@ SDIO_RSP1_INDEX
Definition: at32f413_sdio.h:170
SDIO_DATA_BLOCK_SIZE_8B
@ SDIO_DATA_BLOCK_SIZE_8B
Definition: at32f413_sdio.h:184
SDIO_DATA_BLOCK_SIZE_1B
@ SDIO_DATA_BLOCK_SIZE_1B
Definition: at32f413_sdio.h:181
SDIO_CMDTIMEOUT_FLAG
#define SDIO_CMDTIMEOUT_FLAG
Definition: at32f413_sdio.h:87
SDIO_TXBUFH_FLAG
#define SDIO_TXBUFH_FLAG
Definition: at32f413_sdio.h:99
SDIO_CMDCMPL_FLAG
#define SDIO_CMDCMPL_FLAG
Definition: at32f413_sdio.h:92
SDIO_DTFAIL_FLAG
#define SDIO_DTFAIL_FLAG
Definition: at32f413_sdio.h:86
SDIO_RXERRO_FLAG
#define SDIO_RXERRO_FLAG
Definition: at32f413_sdio.h:90
SDIO_RXBUFH_FLAG
#define SDIO_RXBUFH_FLAG
Definition: at32f413_sdio.h:100
SDIO_RXBUF_FLAG
#define SDIO_RXBUF_FLAG
Definition: at32f413_sdio.h:106
SDIO_CMDFAIL_FLAG
#define SDIO_CMDFAIL_FLAG
Definition: at32f413_sdio.h:85
SDIO_CMDRSPCMPL_FLAG
#define SDIO_CMDRSPCMPL_FLAG
Definition: at32f413_sdio.h:91
SDIO_DTBLKCMPL_FLAG
#define SDIO_DTBLKCMPL_FLAG
Definition: at32f413_sdio.h:95
SDIO_DTTIMEOUT_FLAG
#define SDIO_DTTIMEOUT_FLAG
Definition: at32f413_sdio.h:88
SDIO_SBITERR_FLAG
#define SDIO_SBITERR_FLAG
Definition: at32f413_sdio.h:94
SDIO_DTCMPL_FLAG
#define SDIO_DTCMPL_FLAG
Definition: at32f413_sdio.h:93
SDIO_TXERRU_FLAG
#define SDIO_TXERRU_FLAG
Definition: at32f413_sdio.h:89
SDIO_SBITERR_INT
#define SDIO_SBITERR_INT
Definition: at32f413_sdio.h:61
SDIO_RXBUFH_INT
#define SDIO_RXBUFH_INT
Definition: at32f413_sdio.h:67
SDIO_DTTIMEOUT_INT
#define SDIO_DTTIMEOUT_INT
Definition: at32f413_sdio.h:55
SDIO_TXERRU_INT
#define SDIO_TXERRU_INT
Definition: at32f413_sdio.h:56
SDIO_RXERRO_INT
#define SDIO_RXERRO_INT
Definition: at32f413_sdio.h:57
SDIO_DTFAIL_INT
#define SDIO_DTFAIL_INT
Definition: at32f413_sdio.h:53
SDIO_TXBUFH_INT
#define SDIO_TXBUFH_INT
Definition: at32f413_sdio.h:66
SDIO_DTCMP_INT
#define SDIO_DTCMP_INT
Definition: at32f413_sdio.h:60
SDIO_SEND_IF_COND
#define SDIO_SEND_IF_COND
Definition: sd_mmc_card/inc/at32_sdio.h:438
SD_CMD_SD_APP_SEND_SCR
#define SD_CMD_SD_APP_SEND_SCR
Definition: sd_mmc_card/inc/at32_sdio.h:308
SD_CMD_ERASE
#define SD_CMD_ERASE
Definition: sd_mmc_card/inc/at32_sdio.h:291
SD_CMD_APP_SD_SET_BUSWIDTH
#define SD_CMD_APP_SD_SET_BUSWIDTH
Definition: sd_mmc_card/inc/at32_sdio.h:303
SD_CMD_WRITE_SINGLE_BLOCK
#define SD_CMD_WRITE_SINGLE_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:280
SD_CMD_SD_ERASE_GRP_START
#define SD_CMD_SD_ERASE_GRP_START
Definition: sd_mmc_card/inc/at32_sdio.h:287
SD_CMD_APP_CMD
#define SD_CMD_APP_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:295
SD_CMD_ALL_SEND_CID
#define SD_CMD_ALL_SEND_CID
Definition: sd_mmc_card/inc/at32_sdio.h:260
SD_CMD_STOP_TRANSMISSION
#define SD_CMD_STOP_TRANSMISSION
Definition: sd_mmc_card/inc/at32_sdio.h:270
SD_CMD_SEND_STATUS
#define SD_CMD_SEND_STATUS
Definition: sd_mmc_card/inc/at32_sdio.h:271
SD_CMD_SET_BLOCK_COUNT
#define SD_CMD_SET_BLOCK_COUNT
Definition: sd_mmc_card/inc/at32_sdio.h:279
SD_CMD_WRITE_DAT_UNTIL_STOP
#define SD_CMD_WRITE_DAT_UNTIL_STOP
Definition: sd_mmc_card/inc/at32_sdio.h:278
SD_CMD_SEND_OP_COND
#define SD_CMD_SEND_OP_COND
Definition: sd_mmc_card/inc/at32_sdio.h:259
SD_CMD_SET_BLOCKLEN
#define SD_CMD_SET_BLOCKLEN
Definition: sd_mmc_card/inc/at32_sdio.h:274
SD_CMD_HS_SWITCH
#define SD_CMD_HS_SWITCH
Definition: sd_mmc_card/inc/at32_sdio.h:264
SD_CMD_READ_SINGLE_BLOCK
#define SD_CMD_READ_SINGLE_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:275
SD_CMD_SD_APP_OP_COND
#define SD_CMD_SD_APP_OP_COND
Definition: sd_mmc_card/inc/at32_sdio.h:306
SD_CMD_GO_IDLE_STATE
#define SD_CMD_GO_IDLE_STATE
Definition: sd_mmc_card/inc/at32_sdio.h:258
SD_CMD_SET_REL_ADDR
#define SD_CMD_SET_REL_ADDR
Definition: sd_mmc_card/inc/at32_sdio.h:261
SD_CMD_ERASE_GRP_END
#define SD_CMD_ERASE_GRP_END
Definition: sd_mmc_card/inc/at32_sdio.h:290
SD_CMD_READ_DAT_UNTIL_STOP
#define SD_CMD_READ_DAT_UNTIL_STOP
Definition: sd_mmc_card/inc/at32_sdio.h:269
SD_CMD_SD_ERASE_GRP_END
#define SD_CMD_SD_ERASE_GRP_END
Definition: sd_mmc_card/inc/at32_sdio.h:288
SD_CMD_ERASE_GRP_START
#define SD_CMD_ERASE_GRP_START
Definition: sd_mmc_card/inc/at32_sdio.h:289
SD_CMD_SEL_DESEL_CARD
#define SD_CMD_SEL_DESEL_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:265
SD_CMD_WRITE_MULT_BLOCK
#define SD_CMD_WRITE_MULT_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:281
SD_CMD_READ_MULT_BLOCK
#define SD_CMD_READ_MULT_BLOCK
Definition: sd_mmc_card/inc/at32_sdio.h:276
SD_CMD_SEND_CSD
#define SD_CMD_SEND_CSD
Definition: sd_mmc_card/inc/at32_sdio.h:267
sd_data_transfer_mode_type
sd_data_transfer_mode_type
Definition: sd_mmc_card/inc/at32_sdio.h:65
sd_error_status_type
sd_error_status_type
Definition: sd_mmc_card/inc/at32_sdio.h:74
sd_card_state_type
sd_card_state_type
Definition: sd_mmc_card/inc/at32_sdio.h:187
sd_memory_card_type
sd_memory_card_type
Definition: sd_mmc_card/inc/at32_sdio.h:203
SDIOx
#define SDIOx
Definition: sd_mmc_card/inc/at32_sdio.h:51
SDIO_INTR_STS_WRITE_MASK
#define SDIO_INTR_STS_WRITE_MASK
Definition: sd_mmc_card/inc/at32_sdio.h:474
SDIO_INTR_STS_READ_MASK
#define SDIO_INTR_STS_READ_MASK
Definition: sd_mmc_card/inc/at32_sdio.h:476
EXT_CSD_BUS_WIDTH
#define EXT_CSD_BUS_WIDTH
Definition: sd_mmc_card/inc/at32_sdio.h:463
EXT_CSD_CMD_SET_NORMAL
#define EXT_CSD_CMD_SET_NORMAL
Definition: sd_mmc_card/inc/at32_sdio.h:456
EXT_CSD_Write_byte
#define EXT_CSD_Write_byte
Definition: sd_mmc_card/inc/at32_sdio.h:454
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
SDIO_DATATIMEOUT
#define SDIO_DATATIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:342
SDIO_CMD0TIMEOUT
#define SDIO_CMD0TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:341
SDIO_STATIC_FLAGS
#define SDIO_STATIC_FLAGS
Definition: sd_mmc_card/inc/at32_sdio.h:340
SD_CARD_LOCKED
#define SD_CARD_LOCKED
Definition: sd_mmc_card/inc/at32_sdio.h:400
SD_VOLTAGE_WINDOW_SD
#define SD_VOLTAGE_WINDOW_SD
Definition: sd_mmc_card/inc/at32_sdio.h:391
SD_R5_ERROR
#define SD_R5_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:383
SD_CARD_RECEIVING
#define SD_CARD_RECEIVING
Definition: sd_mmc_card/inc/at32_sdio.h:402
SD_R5_OUT_OF_RANGE
#define SD_R5_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:381
SD_MAX_DATA_LENGTH
#define SD_MAX_DATA_LENGTH
Definition: sd_mmc_card/inc/at32_sdio.h:408
SD_STD_CAPACITY
#define SD_STD_CAPACITY
Definition: sd_mmc_card/inc/at32_sdio.h:393
SD_R5_FUNCTION_NUMBER
#define SD_R5_FUNCTION_NUMBER
Definition: sd_mmc_card/inc/at32_sdio.h:382
SD_R6_ILLEGAL_CMD
#define SD_R6_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:389
SD_R6_GENERAL_UNKNOWN_ERROR
#define SD_R6_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:388
SD_MAX_VOLT_TRIAL
#define SD_MAX_VOLT_TRIAL
Definition: sd_mmc_card/inc/at32_sdio.h:396
SD_DATATIMEOUT
#define SD_DATATIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:403
SD_ALLZERO
#define SD_ALLZERO
Definition: sd_mmc_card/inc/at32_sdio.h:397
SD_R6_CMD_CRC_ERROR
#define SD_R6_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:390
MMC_SWITCH_ERROR
#define MMC_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:374
SD_VOLTAGE_WINDOW_MMC
#define SD_VOLTAGE_WINDOW_MMC
Definition: sd_mmc_card/inc/at32_sdio.h:395
SD_CHECK_PATTERN
#define SD_CHECK_PATTERN
Definition: sd_mmc_card/inc/at32_sdio.h:394
SD_OCR_ERRORBITS
#define SD_OCR_ERRORBITS
Definition: sd_mmc_card/inc/at32_sdio.h:376
SD_CARD_PROGRAMMING
#define SD_CARD_PROGRAMMING
Definition: sd_mmc_card/inc/at32_sdio.h:401
SD_HIGH_CAPACITY
#define SD_HIGH_CAPACITY
Definition: sd_mmc_card/inc/at32_sdio.h:392
SD_TRANSFER_DMA_MODE
@ SD_TRANSFER_DMA_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:67
SD_TRANSFER_POLLING_MODE
@ SD_TRANSFER_POLLING_MODE
Definition: sd_mmc_card/inc/at32_sdio.h:66
SD_ERROR
@ SD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:118
SD_SDIO_UNKNOWN_FUNC
@ SD_SDIO_UNKNOWN_FUNC
Definition: sd_mmc_card/inc/at32_sdio.h:108
SD_DATA_FAIL
@ SD_DATA_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:77
SD_INVALID_PARAMETER
@ SD_INVALID_PARAMETER
Definition: sd_mmc_card/inc/at32_sdio.h:115
SD_CMD_FAIL
@ SD_CMD_FAIL
Definition: sd_mmc_card/inc/at32_sdio.h:76
SD_CMD_OUT_OF_RANGE
@ SD_CMD_OUT_OF_RANGE
Definition: sd_mmc_card/inc/at32_sdio.h:83
SD_GENERAL_UNKNOWN_ERROR
@ SD_GENERAL_UNKNOWN_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:94
SD_UNSUPPORTED_FEATURE
@ SD_UNSUPPORTED_FEATURE
Definition: sd_mmc_card/inc/at32_sdio.h:116
SD_TX_UNDERRUN
@ SD_TX_UNDERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:80
SD_ILLEGAL_CMD
@ SD_ILLEGAL_CMD
Definition: sd_mmc_card/inc/at32_sdio.h:91
SD_CMD_CRC_ERROR
@ SD_CMD_CRC_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:90
SD_RX_OVERRUN
@ SD_RX_OVERRUN
Definition: sd_mmc_card/inc/at32_sdio.h:81
SD_REQ_NOT_APPLICABLE
@ SD_REQ_NOT_APPLICABLE
Definition: sd_mmc_card/inc/at32_sdio.h:114
SD_SWITCH_ERROR
@ SD_SWITCH_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:104
SD_INVALID_VOLTRANGE
@ SD_INVALID_VOLTRANGE
Definition: sd_mmc_card/inc/at32_sdio.h:102
SD_DATA_TIMEOUT
@ SD_DATA_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:79
SD_START_BIT_ERR
@ SD_START_BIT_ERR
Definition: sd_mmc_card/inc/at32_sdio.h:82
SD_LOCK_UNLOCK_ERROR
@ SD_LOCK_UNLOCK_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:89
SD_CMD_RSP_TIMEOUT
@ SD_CMD_RSP_TIMEOUT
Definition: sd_mmc_card/inc/at32_sdio.h:78
SD_OK
@ SD_OK
Definition: sd_mmc_card/inc/at32_sdio.h:119
SD_CARD_ERROR
@ SD_CARD_ERROR
Definition: sd_mmc_card/inc/at32_sdio.h:196
SDIO_HIGH_CAPACITY_SD_CARD
@ SDIO_HIGH_CAPACITY_SD_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:206
SDIO_SECURE_DIGITAL_IO_COMBO_CARD
@ SDIO_SECURE_DIGITAL_IO_COMBO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:210
SDIO_HIGH_SPEED_MULTIMEDIA_CARD
@ SDIO_HIGH_SPEED_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:209
SDIO_STD_CAPACITY_SD_CARD_V1_1
@ SDIO_STD_CAPACITY_SD_CARD_V1_1
Definition: sd_mmc_card/inc/at32_sdio.h:204
SDIO_SECURE_DIGITAL_IO_CARD
@ SDIO_SECURE_DIGITAL_IO_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:208
SDIO_STD_CAPACITY_SD_CARD_V2_0
@ SDIO_STD_CAPACITY_SD_CARD_V2_0
Definition: sd_mmc_card/inc/at32_sdio.h:205
SDIO_MULTIMEDIA_CARD
@ SDIO_MULTIMEDIA_CARD
Definition: sd_mmc_card/inc/at32_sdio.h:207
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
sd_card_info_struct_type
Definition: sd_mmc_card/inc/at32_sdio.h:237
sd_card_info_struct_type::sd_scr_reg
sd_scr_struct_type sd_scr_reg
Definition: sd_mmc_card/inc/at32_sdio.h:240
sd_card_info_struct_type::card_capacity
long long card_capacity
Definition: sd_mmc_card/inc/at32_sdio.h:241
sd_card_info_struct_type::sd_cid_reg
sd_cid_struct_type sd_cid_reg
Definition: sd_mmc_card/inc/at32_sdio.h:239
sd_card_info_struct_type::sd_csd_reg
sd_csd_struct_type sd_csd_reg
Definition: sd_mmc_card/inc/at32_sdio.h:238
sd_card_info_struct_type::card_blk_size
uint32_t card_blk_size
Definition: sd_mmc_card/inc/at32_sdio.h:242
sd_card_info_struct_type::rca
uint16_t rca
Definition: sd_mmc_card/inc/at32_sdio.h:243
sd_card_info_struct_type::card_type
uint8_t card_type
Definition: sd_mmc_card/inc/at32_sdio.h:244
sd_cid_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:177
sd_cid_struct_type::product_name2
uint8_t product_name2
Definition: sd_mmc_card/inc/at32_sdio.h:174
sd_cid_struct_type::manufact_date
uint16_t manufact_date
Definition: sd_mmc_card/inc/at32_sdio.h:178
sd_cid_struct_type::cid_crc
uint8_t cid_crc
Definition: sd_mmc_card/inc/at32_sdio.h:179
sd_cid_struct_type::product_reversion
uint8_t product_reversion
Definition: sd_mmc_card/inc/at32_sdio.h:175
sd_cid_struct_type::manufacturer_id
uint8_t manufacturer_id
Definition: sd_mmc_card/inc/at32_sdio.h:171
sd_cid_struct_type::product_sn
uint32_t product_sn
Definition: sd_mmc_card/inc/at32_sdio.h:176
sd_cid_struct_type::product_name1
uint32_t product_name1
Definition: sd_mmc_card/inc/at32_sdio.h:173
sd_cid_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:180
sd_cid_struct_type::oem_app_id
uint16_t oem_app_id
Definition: sd_mmc_card/inc/at32_sdio.h:172
sd_csd_struct_type::spec_version
uint8_t spec_version
Definition: sd_mmc_card/inc/at32_sdio.h:128
sd_csd_struct_type::max_write_current_vdd_max
uint8_t max_write_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:144
sd_csd_struct_type::nsac
uint8_t nsac
Definition: sd_mmc_card/inc/at32_sdio.h:131
sd_csd_struct_type::card_cmd_classes
uint16_t card_cmd_classes
Definition: sd_mmc_card/inc/at32_sdio.h:133
sd_csd_struct_type::part_blk_read
uint8_t part_blk_read
Definition: sd_mmc_card/inc/at32_sdio.h:135
sd_csd_struct_type::read_blk_misalign
uint8_t read_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:137
sd_csd_struct_type::content_protect_app
uint8_t content_protect_app
Definition: sd_mmc_card/inc/at32_sdio.h:155
sd_csd_struct_type::write_speed_factor
uint8_t write_speed_factor
Definition: sd_mmc_card/inc/at32_sdio.h:151
sd_csd_struct_type::max_read_blk_length
uint8_t max_read_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:134
sd_csd_struct_type::max_bus_clk_freq
uint8_t max_bus_clk_freq
Definition: sd_mmc_card/inc/at32_sdio.h:132
sd_csd_struct_type::ecc_code
uint8_t ecc_code
Definition: sd_mmc_card/inc/at32_sdio.h:161
sd_csd_struct_type::reserved4
uint8_t reserved4
Definition: sd_mmc_card/inc/at32_sdio.h:163
sd_csd_struct_type::dsr_implemented
uint8_t dsr_implemented
Definition: sd_mmc_card/inc/at32_sdio.h:138
sd_csd_struct_type::max_read_current_vdd_min
uint8_t max_read_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:141
sd_csd_struct_type::reserved2
uint8_t reserved2
Definition: sd_mmc_card/inc/at32_sdio.h:139
sd_csd_struct_type::erase_group_size_mult
uint8_t erase_group_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:147
sd_csd_struct_type::file_formart
uint8_t file_formart
Definition: sd_mmc_card/inc/at32_sdio.h:160
sd_csd_struct_type::temp_write_protect
uint8_t temp_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:159
sd_csd_struct_type::permanent_write_protect
uint8_t permanent_write_protect
Definition: sd_mmc_card/inc/at32_sdio.h:158
sd_csd_struct_type::max_read_current_vdd_max
uint8_t max_read_current_vdd_max
Definition: sd_mmc_card/inc/at32_sdio.h:142
sd_csd_struct_type::file_format_group
uint8_t file_format_group
Definition: sd_mmc_card/inc/at32_sdio.h:156
sd_csd_struct_type::device_size
uint32_t device_size
Definition: sd_mmc_card/inc/at32_sdio.h:140
sd_csd_struct_type::write_blk_misalign
uint8_t write_blk_misalign
Definition: sd_mmc_card/inc/at32_sdio.h:136
sd_csd_struct_type::csd_struct
uint8_t csd_struct
Definition: sd_mmc_card/inc/at32_sdio.h:127
sd_csd_struct_type::write_protect_group_enable
uint8_t write_protect_group_enable
Definition: sd_mmc_card/inc/at32_sdio.h:149
sd_csd_struct_type::max_write_current_vdd_min
uint8_t max_write_current_vdd_min
Definition: sd_mmc_card/inc/at32_sdio.h:143
sd_csd_struct_type::reserved1
uint8_t reserved1
Definition: sd_mmc_card/inc/at32_sdio.h:129
sd_csd_struct_type::max_write_blk_length
uint8_t max_write_blk_length
Definition: sd_mmc_card/inc/at32_sdio.h:152
sd_csd_struct_type::csd_crc
uint8_t csd_crc
Definition: sd_mmc_card/inc/at32_sdio.h:162
sd_csd_struct_type::write_protect_group_size
uint8_t write_protect_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:148
sd_csd_struct_type::reserved3
uint8_t reserved3
Definition: sd_mmc_card/inc/at32_sdio.h:154
sd_csd_struct_type::taac
uint8_t taac
Definition: sd_mmc_card/inc/at32_sdio.h:130
sd_csd_struct_type::manufacturer_default_ecc
uint8_t manufacturer_default_ecc
Definition: sd_mmc_card/inc/at32_sdio.h:150
sd_csd_struct_type::part_blk_write
uint8_t part_blk_write
Definition: sd_mmc_card/inc/at32_sdio.h:153
sd_csd_struct_type::copy_flag
uint8_t copy_flag
Definition: sd_mmc_card/inc/at32_sdio.h:157
sd_csd_struct_type::erase_group_size
uint8_t erase_group_size
Definition: sd_mmc_card/inc/at32_sdio.h:146
sd_csd_struct_type::device_size_mult
uint8_t device_size_mult
Definition: sd_mmc_card/inc/at32_sdio.h:145
sd_scr_struct_type::sd_bus_width
uint32_t sd_bus_width
Definition: sd_mmc_card/inc/at32_sdio.h:222
sd_scr_struct_type::sd_spec
uint32_t sd_spec
Definition: sd_mmc_card/inc/at32_sdio.h:220
sdio_command_struct_type
sdio command structure
Definition: at32f413_sdio.h:229
sdio_command_struct_type::cmd_index
uint8_t cmd_index
Definition: at32f413_sdio.h:231
sdio_command_struct_type::argument
uint32_t argument
Definition: at32f413_sdio.h:230
sdio_command_struct_type::wait_type
sdio_wait_type wait_type
Definition: at32f413_sdio.h:233
sdio_command_struct_type::rsp_type
sdio_reponse_type rsp_type
Definition: at32f413_sdio.h:232
sdio_data_struct_type
sdio data structure
Definition: at32f413_sdio.h:240
sdio_data_struct_type::block_size
sdio_block_size_type block_size
Definition: at32f413_sdio.h:243
sdio_data_struct_type::transfer_direction
sdio_transfer_direction_type transfer_direction
Definition: at32f413_sdio.h:245
sdio_data_struct_type::timeout
uint32_t timeout
Definition: at32f413_sdio.h:241
sdio_data_struct_type::transfer_mode
sdio_transfer_mode_type transfer_mode
Definition: at32f413_sdio.h:244
sdio_data_struct_type::data_length
uint32_t data_length
Definition: at32f413_sdio.h:242


AT32F413 Firmwary Library: smartcard_config.h Source File

  • usart
  • smartcard
  • inc
smartcard_config.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __SMARTCARD_CONFIG_H
29#define __SMARTCARD_CONFIG_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* smartcard inteface usart pins */
36#define SC_USART USART2
37#define SC_USART_CLK CRM_USART2_PERIPH_CLOCK
38#define SC_USART_GPIO_CLK CRM_GPIOA_PERIPH_CLOCK
39#define SC_USART_TX_PIN GPIO_PINS_2
40#define SC_USART_TX_PORT GPIOA
41#define SC_USART_CLK_PIN GPIO_PINS_4
42#define SC_USART_CLK_PORT GPIOA
43#define SC_USART_IRQn USART2_IRQn
44#define SC_USART_IRQHandler USART2_IRQHandler
45
46/* smartcard inteface gpio pins */
47#define SC_3_5V_PIN GPIO_PINS_5
48#define SC_RESET_PIN GPIO_PINS_6
49#define SC_CMDVCC_PIN GPIO_PINS_7
50#define SC_OFF_PIN GPIO_PINS_8
51#define SC_3_5V_PORT GPIOA
52#define SC_RESET_PORT GPIOA
53#define SC_CMDVCC_PORT GPIOA
54#define SC_OFF_PORT GPIOA
55#define SC_3_5V_CLK CRM_GPIOA_PERIPH_CLOCK
56#define SC_RESET_CLK CRM_GPIOA_PERIPH_CLOCK
57#define SC_CMDVCC_CLK CRM_GPIOA_PERIPH_CLOCK
58#define SC_OFF_CLK CRM_GPIOA_PERIPH_CLOCK
59#define SC_OFF_EXINT EXINT_LINE_8
60#define SC_OFF_PORTSOURCE GPIO_PORT_SOURCE_GPIOA
61#define SC_OFF_PINSOURCE GPIO_PINS_SOURCE8
62#define SC_OFF_EXINT_IRQ EXINT9_5_IRQn
63
64#ifdef __cplusplus
65}
66#endif
67
68#endif /* __SMARTCARD_CONFIG_H */
69


AT32F413 Firmwary Library: spi_flash.c Source File

  • spi
  • w25q_flash
  • src
spi_flash.c
Go to the documentation of this file.
1
27#include "spi_flash.h"
28
37uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE];
38
44void spiflash_init(void)
45{
46 gpio_init_type gpio_initstructure;
47 spi_init_type spi_init_struct;
48
49 crm_periph_clock_enable(CRM_GPIOB_PERIPH_CLOCK, TRUE);
50 crm_periph_clock_enable(CRM_DMA1_PERIPH_CLOCK, TRUE);
51 /* software cs, pb12 as a general io to control flash cs */
52 gpio_initstructure.gpio_out_type = GPIO_OUTPUT_PUSH_PULL;
53 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
54 gpio_initstructure.gpio_mode = GPIO_MODE_OUTPUT;
55 gpio_initstructure.gpio_drive_strength = GPIO_DRIVE_STRENGTH_STRONGER;
56 gpio_initstructure.gpio_pins = GPIO_PINS_12;
57 gpio_init(GPIOB, &gpio_initstructure);
58
59 /* sck */
60 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
61 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
62 gpio_initstructure.gpio_pins = GPIO_PINS_13;
63 gpio_init(GPIOB, &gpio_initstructure);
64
65 /* miso */
66 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
67 gpio_initstructure.gpio_mode = GPIO_MODE_INPUT;
68 gpio_initstructure.gpio_pins = GPIO_PINS_14;
69 gpio_init(GPIOB, &gpio_initstructure);
70
71 /* mosi */
72 gpio_initstructure.gpio_pull = GPIO_PULL_UP;
73 gpio_initstructure.gpio_mode = GPIO_MODE_MUX;
74 gpio_initstructure.gpio_pins = GPIO_PINS_15;
75 gpio_init(GPIOB, &gpio_initstructure);
76
77 FLASH_CS_HIGH();
78 crm_periph_clock_enable(CRM_SPI2_PERIPH_CLOCK, TRUE);
79 spi_default_para_init(&spi_init_struct);
80 spi_init_struct.transmission_mode = SPI_TRANSMIT_FULL_DUPLEX;
81 spi_init_struct.master_slave_mode = SPI_MODE_MASTER;
82 spi_init_struct.mclk_freq_division = SPI_MCLK_DIV_8;
83 spi_init_struct.first_bit_transmission = SPI_FIRST_BIT_MSB;
84 spi_init_struct.frame_bit_num = SPI_FRAME_8BIT;
85 spi_init_struct.clock_polarity = SPI_CLOCK_POLARITY_HIGH;
86 spi_init_struct.clock_phase = SPI_CLOCK_PHASE_2EDGE;
87 spi_init_struct.cs_mode_selection = SPI_CS_SOFTWARE_MODE;
88 spi_init(SPI2, &spi_init_struct);
89 spi_enable(SPI2, TRUE);
90}
91
99void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
100{
101 uint32_t sector_pos;
102 uint16_t sector_offset;
103 uint16_t sector_remain;
104 uint16_t index;
105 uint8_t *spiflash_buf;
106 spiflash_buf = spiflash_sector_buf;
107
108 /* sector address */
109 sector_pos = write_addr / SPIF_SECTOR_SIZE;
110
111 /* address offset in a sector */
112 sector_offset = write_addr % SPIF_SECTOR_SIZE;
113
114 /* the remain in a sector */
115 sector_remain = SPIF_SECTOR_SIZE - sector_offset;
116 if(length <= sector_remain)
117 {
118 /* smaller than a sector size */
119 sector_remain = length;
120 }
121 while(1)
122 {
123 /* read a sector */
124 spiflash_read(spiflash_buf, sector_pos * SPIF_SECTOR_SIZE, SPIF_SECTOR_SIZE);
125
126 /* validate the read erea */
127 for(index = 0; index < sector_remain; index++)
128 {
129 if(spiflash_buf[sector_offset + index] != 0xFF)
130 {
131 /* there are some data not equal 0xff, so this secotr needs erased */
132 break;
133 }
134 }
135 if(index < sector_remain)
136 {
137 /* erase the sector */
138 spiflash_sector_erase(sector_pos);
139
140 /* copy the write data */
141 for(index = 0; index < sector_remain; index++)
142 {
143 spiflash_buf[index + sector_offset] = pbuffer[index];
144 }
145 spiflash_write_nocheck(spiflash_buf, sector_pos * SPIF_SECTOR_SIZE, SPIF_SECTOR_SIZE); /* program the sector */
146 }
147 else
148 {
149 /* write directly in the erased area */
150 spiflash_write_nocheck(pbuffer, write_addr, sector_remain);
151 }
152 if(length == sector_remain)
153 {
154 /* write end */
155 break;
156 }
157 else
158 {
159 /* go on writing */
160 sector_pos++;
161 sector_offset = 0;
162
163 pbuffer += sector_remain;
164 write_addr += sector_remain;
165 length -= sector_remain;
166 if(length > SPIF_SECTOR_SIZE)
167 {
168 /* could not write the remain data in the next sector */
169 sector_remain = SPIF_SECTOR_SIZE;
170 }
171 else
172 {
173 /* could write the remain data in the next sector */
174 sector_remain = length;
175 }
176 }
177 }
178}
179
187void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
188{
189 FLASH_CS_LOW();
190 spi_byte_write(SPIF_READDATA); /* send instruction */
191 spi_byte_write((uint8_t)((read_addr) >> 16)); /* send 24-bit address */
192 spi_byte_write((uint8_t)((read_addr) >> 8));
193 spi_byte_write((uint8_t)read_addr);
194 spi_bytes_read(pbuffer, length);
195 FLASH_CS_HIGH();
196}
197
203void spiflash_sector_erase(uint32_t erase_addr)
204{
205 erase_addr *= SPIF_SECTOR_SIZE; /* translate sector address to byte address */
206 spiflash_write_enable();
207 spiflash_wait_busy();
208 FLASH_CS_LOW();
209 spi_byte_write(SPIF_SECTORERASE);
210 spi_byte_write((uint8_t)((erase_addr) >> 16));
211 spi_byte_write((uint8_t)((erase_addr) >> 8));
212 spi_byte_write((uint8_t)erase_addr);
213 FLASH_CS_HIGH();
214 spiflash_wait_busy();
215}
216
224void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
225{
226 uint16_t page_remain;
227
228 /* remain bytes in a page */
229 page_remain = SPIF_PAGE_SIZE - write_addr % SPIF_PAGE_SIZE;
230 if(length <= page_remain)
231 {
232 /* smaller than a page size */
233 page_remain = length;
234 }
235 while(1)
236 {
237 spiflash_page_write(pbuffer, write_addr, page_remain);
238 if(length == page_remain)
239 {
240 /* all data are programmed */
241 break;
242 }
243 else
244 {
245 /* length > page_remain */
246 pbuffer += page_remain;
247 write_addr += page_remain;
248
249 /* the remain bytes to be prorammed */
250 length -= page_remain;
251 if(length > SPIF_PAGE_SIZE)
252 {
253 /* can be progrmmed a page at a time */
254 page_remain = SPIF_PAGE_SIZE;
255 }
256 else
257 {
258 /* smaller than a page size */
259 page_remain = length;
260 }
261 }
262 }
263}
264
272void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
273{
274 if((0 < length) && (length <= SPIF_PAGE_SIZE))
275 {
276 /* set write enable */
277 spiflash_write_enable();
278
279 FLASH_CS_LOW();
280
281 /* send instruction */
282 spi_byte_write(SPIF_PAGEPROGRAM);
283
284 /* send 24-bit address */
285 spi_byte_write((uint8_t)((write_addr) >> 16));
286 spi_byte_write((uint8_t)((write_addr) >> 8));
287 spi_byte_write((uint8_t)write_addr);
288 spi_bytes_write(pbuffer,length);
289
290 FLASH_CS_HIGH();
291
292 /* wait for program end */
293 spiflash_wait_busy();
294 }
295}
296
303void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
304{
305 volatile uint8_t dummy_data;
306
307#if defined(SPI_TRANS_DMA)
308 dma_init_type dma_init_struct;
309 dma_reset(DMA1_CHANNEL4);
310 dma_reset(DMA1_CHANNEL5);
311 dma_default_para_init(&dma_init_struct);
312 dma_init_struct.buffer_size = length;
313 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
314 dma_init_struct.memory_base_addr = (uint32_t)&dummy_data;
315 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
316 dma_init_struct.memory_inc_enable = FALSE;
317 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
318 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
319 dma_init_struct.peripheral_inc_enable = FALSE;
320 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
321 dma_init_struct.loop_mode_enable = FALSE;
322 dma_init(DMA1_CHANNEL4, &dma_init_struct);
323
324 dma_init_struct.buffer_size = length;
325 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
326 dma_init_struct.memory_base_addr = (uint32_t)pbuffer;
327 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
328 dma_init_struct.memory_inc_enable = TRUE;
329 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
330 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
331 dma_init_struct.peripheral_inc_enable = FALSE;
332 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
333 dma_init_struct.loop_mode_enable = FALSE;
334 dma_init(DMA1_CHANNEL5, &dma_init_struct);
335
336 spi_i2s_dma_transmitter_enable(SPI2, TRUE);
337 spi_i2s_dma_receiver_enable(SPI2, TRUE);
338
339 dma_channel_enable(DMA1_CHANNEL4, TRUE);
340 dma_channel_enable(DMA1_CHANNEL5, TRUE);
341
342 while(dma_flag_get(DMA1_FDT4_FLAG) == RESET);
343 dma_flag_clear(DMA1_FDT4_FLAG);
344
345 dma_channel_enable(DMA1_CHANNEL4, FALSE);
346 dma_channel_enable(DMA1_CHANNEL5, FALSE);
347
348 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
349 spi_i2s_dma_receiver_enable(SPI2, FALSE);
350#else
351 while(length--)
352 {
353 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
354 spi_i2s_data_transmit(SPI2, *pbuffer);
355 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
356 dummy_data = spi_i2s_data_receive(SPI2);
357 pbuffer++;
358 }
359#endif
360}
361
368void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
369{
370 uint8_t write_value = FLASH_SPI_DUMMY_BYTE;
371
372#if defined(SPI_TRANS_DMA)
373 dma_init_type dma_init_struct;
374 dma_reset(DMA1_CHANNEL4);
375 dma_reset(DMA1_CHANNEL5);
376 dma_default_para_init(&dma_init_struct);
377 dma_init_struct.buffer_size = length;
378 dma_init_struct.direction = DMA_DIR_MEMORY_TO_PERIPHERAL;
379 dma_init_struct.memory_base_addr = (uint32_t)&write_value;
380 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
381 dma_init_struct.memory_inc_enable = FALSE;
382 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
383 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
384 dma_init_struct.peripheral_inc_enable = FALSE;
385 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
386 dma_init_struct.loop_mode_enable = FALSE;
387 dma_init(DMA1_CHANNEL5, &dma_init_struct);
388
389 dma_init_struct.buffer_size = length;
390 dma_init_struct.direction = DMA_DIR_PERIPHERAL_TO_MEMORY;
391 dma_init_struct.memory_base_addr = (uint32_t)pbuffer;
392 dma_init_struct.memory_data_width = DMA_MEMORY_DATA_WIDTH_BYTE;
393 dma_init_struct.memory_inc_enable = TRUE;
394 dma_init_struct.peripheral_base_addr = (uint32_t)(&SPI2->dt);
395 dma_init_struct.peripheral_data_width = DMA_PERIPHERAL_DATA_WIDTH_BYTE;
396 dma_init_struct.peripheral_inc_enable = FALSE;
397 dma_init_struct.priority = DMA_PRIORITY_VERY_HIGH;
398 dma_init_struct.loop_mode_enable = FALSE;
399 dma_init(DMA1_CHANNEL4, &dma_init_struct);
400
401 spi_i2s_dma_transmitter_enable(SPI2, TRUE);
402 spi_i2s_dma_receiver_enable(SPI2, TRUE);
403 dma_channel_enable(DMA1_CHANNEL4, TRUE);
404 dma_channel_enable(DMA1_CHANNEL5, TRUE);
405
406 while(dma_flag_get(DMA1_FDT4_FLAG) == RESET);
407 dma_flag_clear(DMA1_FDT4_FLAG);
408
409 dma_channel_enable(DMA1_CHANNEL4, FALSE);
410 dma_channel_enable(DMA1_CHANNEL5, FALSE);
411
412 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
413 spi_i2s_dma_receiver_enable(SPI2, FALSE);
414#else
415 while(length--)
416 {
417 while(spi_i2s_flag_get(SPI2, SPI_I2S_TDBE_FLAG) == RESET);
418 spi_i2s_data_transmit(SPI2, write_value);
419 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
420 *pbuffer = spi_i2s_data_receive(SPI2);
421 pbuffer++;
422 }
423#endif
424}
425
431void spiflash_wait_busy(void)
432{
433 while((spiflash_read_sr1() & 0x01) == 0x01);
434}
435
441uint8_t spiflash_read_sr1(void)
442{
443 uint8_t breadbyte = 0;
444 FLASH_CS_LOW();
445 spi_byte_write(SPIF_READSTATUSREG1);
446 breadbyte = (uint8_t)spi_byte_read();
447 FLASH_CS_HIGH();
448 return (breadbyte);
449}
450
456void spiflash_write_enable(void)
457{
458 FLASH_CS_LOW();
459 spi_byte_write(SPIF_WRITEENABLE);
460 FLASH_CS_HIGH();
461}
462
468uint16_t spiflash_read_id(void)
469{
470 uint16_t wreceivedata = 0;
471 FLASH_CS_LOW();
472 spi_byte_write(SPIF_MANUFACTDEVICEID);
473 spi_byte_write(0x00);
474 spi_byte_write(0x00);
475 spi_byte_write(0x00);
476 wreceivedata |= spi_byte_read() << 8;
477 wreceivedata |= spi_byte_read();
478 FLASH_CS_HIGH();
479 return wreceivedata;
480}
481
487uint8_t spi_byte_write(uint8_t data)
488{
489 uint8_t brxbuff;
490 spi_i2s_dma_transmitter_enable(SPI2, FALSE);
491 spi_i2s_dma_receiver_enable(SPI2, FALSE);
492 spi_i2s_data_transmit(SPI2, data);
493 while(spi_i2s_flag_get(SPI2, SPI_I2S_RDBF_FLAG) == RESET);
494 brxbuff = spi_i2s_data_receive(SPI2);
495 while(spi_i2s_flag_get(SPI2, SPI_I2S_BF_FLAG) != RESET);
496 return brxbuff;
497}
498
504uint8_t spi_byte_read(void)
505{
506 return (spi_byte_write(FLASH_SPI_DUMMY_BYTE));
507}
508
dma_init_struct
dma_init_type dma_init_struct
Definition: project/at_start_f413/examples/dma/data_to_gpio_flexible/src/main.c:39
spi_init_struct
spi_init_type spi_init_struct
Definition: project/at_start_f413/examples/spi/fullduplex_polling/src/main.c:41
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: spi_flash.c:44
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: spi_flash.c:99
spiflash_wait_busy
void spiflash_wait_busy(void)
wait program done
Definition: spi_flash.c:431
spiflash_write_enable
void spiflash_write_enable(void)
enable write operation
Definition: spi_flash.c:456
spiflash_read_sr1
uint8_t spiflash_read_sr1(void)
read sr1 register
Definition: spi_flash.c:441
spiflash_write_nocheck
void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check
Definition: spi_flash.c:224
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: spi_flash.c:203
spi_byte_write
uint8_t spi_byte_write(uint8_t data)
write a byte to flash
Definition: spi_flash.c:487
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: spi_flash.c:187
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: spi_flash.c:468
spi_bytes_read
void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
read data continuously
Definition: spi_flash.c:368
spi_bytes_write
void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
write data continuously
Definition: spi_flash.c:303
spiflash_sector_buf
uint8_t spiflash_sector_buf[SPIF_SECTOR_SIZE]
Definition: spi_flash.c:37
spiflash_page_write
void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data
Definition: spi_flash.c:272
spi_byte_read
uint8_t spi_byte_read(void)
read a byte to flash
Definition: spi_flash.c:504
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
CRM_SPI2_PERIPH_CLOCK
@ CRM_SPI2_PERIPH_CLOCK
Definition: at32f413_crm.h:131
CRM_GPIOB_PERIPH_CLOCK
@ CRM_GPIOB_PERIPH_CLOCK
Definition: at32f413_crm.h:111
CRM_DMA1_PERIPH_CLOCK
@ CRM_DMA1_PERIPH_CLOCK
Definition: at32f413_crm.h:104
dma_channel_enable
void dma_channel_enable(dma_channel_type *dmax_channely, confirm_state new_state)
enable or disable dma channely
Definition: at32f413_dma.c:198
dma_default_para_init
void dma_default_para_init(dma_init_type *dma_init_struct)
dma init config with its default value.
Definition: at32f413_dma.c:362
dma_flag_get
flag_status dma_flag_get(uint32_t dmax_flag)
get dma flag
Definition: at32f413_dma.c:298
dma_flag_clear
void dma_flag_clear(uint32_t dmax_flag)
clear dma flag
Definition: at32f413_dma.c:344
dma_reset
void dma_reset(dma_channel_type *dmax_channely)
reset the dmax channely registers.
Definition: at32f413_dma.c:64
dma_init
void dma_init(dma_channel_type *dmax_channely, dma_init_type *dma_init_struct)
dma init
Definition: at32f413_dma.c:397
DMA_PERIPHERAL_DATA_WIDTH_BYTE
@ DMA_PERIPHERAL_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:245
DMA_DIR_MEMORY_TO_PERIPHERAL
@ DMA_DIR_MEMORY_TO_PERIPHERAL
Definition: at32f413_dma.h:218
DMA_DIR_PERIPHERAL_TO_MEMORY
@ DMA_DIR_PERIPHERAL_TO_MEMORY
Definition: at32f413_dma.h:217
DMA_MEMORY_DATA_WIDTH_BYTE
@ DMA_MEMORY_DATA_WIDTH_BYTE
Definition: at32f413_dma.h:255
DMA_PRIORITY_VERY_HIGH
@ DMA_PRIORITY_VERY_HIGH
Definition: at32f413_dma.h:268
DMA1_FDT4_FLAG
#define DMA1_FDT4_FLAG
Definition: at32f413_dma.h:94
DMA1_CHANNEL5
#define DMA1_CHANNEL5
Definition: at32f413_dma.h:484
DMA1_CHANNEL4
#define DMA1_CHANNEL4
Definition: at32f413_dma.h:483
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
gpio_init
void gpio_init(gpio_type *gpio_x, gpio_init_type *gpio_init_struct)
initialize the gpio peripheral.
Definition: at32f413_gpio.c:100
GPIO_MODE_MUX
@ GPIO_MODE_MUX
Definition: at32f413_gpio.h:216
GPIO_MODE_INPUT
@ GPIO_MODE_INPUT
Definition: at32f413_gpio.h:214
GPIO_MODE_OUTPUT
@ GPIO_MODE_OUTPUT
Definition: at32f413_gpio.h:215
GPIO_DRIVE_STRENGTH_STRONGER
@ GPIO_DRIVE_STRENGTH_STRONGER
Definition: at32f413_gpio.h:225
GPIO_PULL_UP
@ GPIO_PULL_UP
Definition: at32f413_gpio.h:245
GPIO_OUTPUT_PUSH_PULL
@ GPIO_OUTPUT_PUSH_PULL
Definition: at32f413_gpio.h:235
GPIO_PINS_13
#define GPIO_PINS_13
Definition: at32f413_gpio.h:64
GPIO_PINS_12
#define GPIO_PINS_12
Definition: at32f413_gpio.h:63
GPIO_PINS_14
#define GPIO_PINS_14
Definition: at32f413_gpio.h:65
GPIO_PINS_15
#define GPIO_PINS_15
Definition: at32f413_gpio.h:66
GPIOB
#define GPIOB
Definition: at32f413_gpio.h:749
SPI_I2S_TDBE_FLAG
#define SPI_I2S_TDBE_FLAG
Definition: at32f413_spi.h:54
SPI_I2S_RDBF_FLAG
#define SPI_I2S_RDBF_FLAG
Definition: at32f413_spi.h:53
SPI_I2S_BF_FLAG
#define SPI_I2S_BF_FLAG
Definition: at32f413_spi.h:60
spi_i2s_data_transmit
void spi_i2s_data_transmit(spi_type *spi_x, uint16_t tx_data)
spi/i2s data transmit
Definition: at32f413_spi.c:514
spi_i2s_dma_receiver_enable
void spi_i2s_dma_receiver_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma receiver mode.
Definition: at32f413_spi.c:499
spi_i2s_flag_get
flag_status spi_i2s_flag_get(spi_type *spi_x, uint32_t spi_i2s_flag)
get flag of the specified spi/i2s peripheral.
Definition: at32f413_spi.c:548
spi_init
void spi_init(spi_type *spi_x, spi_init_type *spi_init_struct)
spi init config with its setting value.
Definition: at32f413_spi.c:91
spi_default_para_init
void spi_default_para_init(spi_init_type *spi_init_struct)
spi init config with its default value.
Definition: at32f413_spi.c:71
spi_i2s_data_receive
uint16_t spi_i2s_data_receive(spi_type *spi_x)
spi/i2s data receive
Definition: at32f413_spi.c:526
spi_enable
void spi_enable(spi_type *spi_x, confirm_state new_state)
enable or disable spi.
Definition: at32f413_spi.c:287
spi_i2s_dma_transmitter_enable
void spi_i2s_dma_transmitter_enable(spi_type *spi_x, confirm_state new_state)
enable or disable the spi/i2s dma transmitter mode.
Definition: at32f413_spi.c:485
SPI_MODE_MASTER
@ SPI_MODE_MASTER
Definition: at32f413_spi.h:99
SPI_CLOCK_PHASE_2EDGE
@ SPI_CLOCK_PHASE_2EDGE
Definition: at32f413_spi.h:117
SPI_CS_SOFTWARE_MODE
@ SPI_CS_SOFTWARE_MODE
Definition: at32f413_spi.h:126
SPI_FIRST_BIT_MSB
@ SPI_FIRST_BIT_MSB
Definition: at32f413_spi.h:151
SPI_CLOCK_POLARITY_HIGH
@ SPI_CLOCK_POLARITY_HIGH
Definition: at32f413_spi.h:108
SPI_TRANSMIT_FULL_DUPLEX
@ SPI_TRANSMIT_FULL_DUPLEX
Definition: at32f413_spi.h:160
SPI_MCLK_DIV_8
@ SPI_MCLK_DIV_8
Definition: at32f413_spi.h:136
SPI_FRAME_8BIT
@ SPI_FRAME_8BIT
Definition: at32f413_spi.h:89
FLASH_CS_LOW
#define FLASH_CS_LOW()
Definition: spi_flash.h:53
FLASH_CS_HIGH
#define FLASH_CS_HIGH()
Definition: spi_flash.h:52
SPIF_READDATA
#define SPIF_READDATA
Definition: spi_flash.h:96
SPIF_PAGE_SIZE
#define SPIF_PAGE_SIZE
Definition: spi_flash.h:83
SPIF_SECTORERASE
#define SPIF_SECTORERASE
Definition: spi_flash.h:102
SPIF_MANUFACTDEVICEID
#define SPIF_MANUFACTDEVICEID
Definition: spi_flash.h:107
FLASH_SPI_DUMMY_BYTE
#define FLASH_SPI_DUMMY_BYTE
Definition: spi_flash.h:109
SPIF_SECTOR_SIZE
#define SPIF_SECTOR_SIZE
Definition: spi_flash.h:82
SPIF_READSTATUSREG1
#define SPIF_READSTATUSREG1
Definition: spi_flash.h:88
SPIF_PAGEPROGRAM
#define SPIF_PAGEPROGRAM
Definition: spi_flash.h:99
SPIF_WRITEENABLE
#define SPIF_WRITEENABLE
Definition: spi_flash.h:85
SPI2
#define SPI2
Definition: at32f413_spi.h:449
spi_flash.h
header file of spi_flash
dma_init_type
dma init type
Definition: at32f413_dma.h:275
dma_init_type::loop_mode_enable
confirm_state loop_mode_enable
Definition: at32f413_dma.h:284
dma_init_type::buffer_size
uint16_t buffer_size
Definition: at32f413_dma.h:279
dma_init_type::memory_data_width
dma_memory_data_size_type memory_data_width
Definition: at32f413_dma.h:283
dma_init_type::priority
dma_priority_level_type priority
Definition: at32f413_dma.h:285
dma_init_type::peripheral_inc_enable
confirm_state peripheral_inc_enable
Definition: at32f413_dma.h:280
dma_init_type::memory_inc_enable
confirm_state memory_inc_enable
Definition: at32f413_dma.h:281
dma_init_type::direction
dma_dir_type direction
Definition: at32f413_dma.h:278
dma_init_type::peripheral_base_addr
uint32_t peripheral_base_addr
Definition: at32f413_dma.h:276
dma_init_type::memory_base_addr
uint32_t memory_base_addr
Definition: at32f413_dma.h:277
dma_init_type::peripheral_data_width
dma_peripheral_data_size_type peripheral_data_width
Definition: at32f413_dma.h:282
gpio_init_type
gpio init type
Definition: at32f413_gpio.h:288
gpio_init_type::gpio_out_type
gpio_output_type gpio_out_type
Definition: at32f413_gpio.h:290
gpio_init_type::gpio_pull
gpio_pull_type gpio_pull
Definition: at32f413_gpio.h:291
gpio_init_type::gpio_drive_strength
gpio_drive_type gpio_drive_strength
Definition: at32f413_gpio.h:293
gpio_init_type::gpio_mode
gpio_mode_type gpio_mode
Definition: at32f413_gpio.h:292
gpio_init_type::gpio_pins
uint32_t gpio_pins
Definition: at32f413_gpio.h:289
spi_init_type
spi init type
Definition: at32f413_spi.h:257
spi_init_type::master_slave_mode
spi_master_slave_mode_type master_slave_mode
Definition: at32f413_spi.h:259
spi_init_type::first_bit_transmission
spi_first_bit_type first_bit_transmission
Definition: at32f413_spi.h:261
spi_init_type::frame_bit_num
spi_frame_bit_num_type frame_bit_num
Definition: at32f413_spi.h:262
spi_init_type::clock_polarity
spi_clock_polarity_type clock_polarity
Definition: at32f413_spi.h:263
spi_init_type::cs_mode_selection
spi_cs_mode_type cs_mode_selection
Definition: at32f413_spi.h:265
spi_init_type::mclk_freq_division
spi_mclk_freq_div_type mclk_freq_division
Definition: at32f413_spi.h:260
spi_init_type::transmission_mode
spi_transmission_mode_type transmission_mode
Definition: at32f413_spi.h:258
spi_init_type::clock_phase
spi_clock_phase_type clock_phase
Definition: at32f413_spi.h:264


AT32F413 Firmwary Library: spi_flash.h Source File

  • spi
  • w25q_flash
  • inc
spi_flash.h
Go to the documentation of this file.
1
27#ifndef __SPI_FLASH_H
28#define __SPI_FLASH_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413.h"
35
45 /* use dma transfer spi data */
46#define SPI_TRANS_DMA
47
52#define FLASH_CS_HIGH() gpio_bits_set(GPIOB, GPIO_PINS_12)
53#define FLASH_CS_LOW() gpio_bits_reset(GPIOB, GPIO_PINS_12)
54
63/*
64 * flash define
65 */
66#define W25Q80 0xEF13
67#define W25Q16 0xEF14
68#define W25Q32 0xEF15
69#define W25Q64 0xEF16
70/* 16mb, the range of address:0~0xFFFFFF */
71#define W25Q128 0xEF17
72
81#define SPIF_CHIP_SIZE 0x1000000
82#define SPIF_SECTOR_SIZE 4096
83#define SPIF_PAGE_SIZE 256
84
85#define SPIF_WRITEENABLE 0x06
86#define SPIF_WRITEDISABLE 0x04
87/* s7-s0 */
88#define SPIF_READSTATUSREG1 0x05
89#define SPIF_WRITESTATUSREG1 0x01
90/* s15-s8 */
91#define SPIF_READSTATUSREG2 0x35
92#define SPIF_WRITESTATUSREG2 0x31
93/* s23-s16 */
94#define SPIF_READSTATUSREG3 0x15
95#define SPIF_WRITESTATUSREG3 0x11
96#define SPIF_READDATA 0x03
97#define SPIF_FASTREADDATA 0x0B
98#define SPIF_FASTREADDUAL 0x3B
99#define SPIF_PAGEPROGRAM 0x02
100/* block size:64kb */
101#define SPIF_BLOCKERASE 0xD8
102#define SPIF_SECTORERASE 0x20
103#define SPIF_CHIPERASE 0xC7
104#define SPIF_POWERDOWN 0xB9
105#define SPIF_RELEASEPOWERDOWN 0xAB
106#define SPIF_DEVICEID 0xAB
107#define SPIF_MANUFACTDEVICEID 0x90
108#define SPIF_JEDECDEVICEID 0x9F
109#define FLASH_SPI_DUMMY_BYTE 0xA5
110
119void spiflash_init(void);
120void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
121void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length);
122void spiflash_sector_erase(uint32_t erase_addr);
123void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
124void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length);
125void spi_bytes_write(uint8_t *pbuffer, uint32_t length);
126void spi_bytes_read(uint8_t *pbuffer, uint32_t length);
127void spiflash_wait_busy(void);
128uint8_t spiflash_read_sr1(void);
129void spiflash_write_enable(void);
130uint16_t spiflash_read_id(void);
131uint8_t spi_byte_write(uint8_t data);
132uint8_t spi_byte_read(void);
133
146#ifdef __cplusplus
147}
148#endif
149
150#endif
151
at32f413.h
at32f413 header file
spiflash_init
void spiflash_init(void)
spi configuration.
Definition: spi_flash.c:44
spiflash_write
void spiflash_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data to flash
Definition: spi_flash.c:99
spiflash_wait_busy
void spiflash_wait_busy(void)
wait program done
Definition: spi_flash.c:431
spiflash_write_enable
void spiflash_write_enable(void)
enable write operation
Definition: spi_flash.c:456
spiflash_read_sr1
uint8_t spiflash_read_sr1(void)
read sr1 register
Definition: spi_flash.c:441
spiflash_write_nocheck
void spiflash_write_nocheck(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write data without check
Definition: spi_flash.c:224
spiflash_sector_erase
void spiflash_sector_erase(uint32_t erase_addr)
erase a sector data
Definition: spi_flash.c:203
spi_byte_write
uint8_t spi_byte_write(uint8_t data)
write a byte to flash
Definition: spi_flash.c:487
spiflash_read
void spiflash_read(uint8_t *pbuffer, uint32_t read_addr, uint32_t length)
read data from flash
Definition: spi_flash.c:187
spiflash_read_id
uint16_t spiflash_read_id(void)
read device id
Definition: spi_flash.c:468
spi_bytes_read
void spi_bytes_read(uint8_t *pbuffer, uint32_t length)
read data continuously
Definition: spi_flash.c:368
spi_bytes_write
void spi_bytes_write(uint8_t *pbuffer, uint32_t length)
write data continuously
Definition: spi_flash.c:303
spiflash_page_write
void spiflash_page_write(uint8_t *pbuffer, uint32_t write_addr, uint32_t length)
write a page data
Definition: spi_flash.c:272
spi_byte_read
uint8_t spi_byte_read(void)
read a byte to flash
Definition: spi_flash.c:504


AT32F413 Firmwary Library: system_at32f413.c Source File

  • libraries
  • cmsis
  • cm4
  • device_support
system_at32f413.c
Go to the documentation of this file.
1
35#include "at32f413.h"
36
40#define VECT_TAB_OFFSET 0x0
48unsigned int system_core_clock = HICK_VALUE;
64void SystemInit (void)
65{
66#if defined (__FPU_USED) && (__FPU_USED == 1U)
67 SCB->CPACR |= ((3U << 10U * 2U) | /* set cp10 full access */
68 (3U << 11U * 2U) ); /* set cp11 full access */
69#endif
70
71 /* reset the crm clock configuration to the default reset state(for debug purpose) */
72 /* set hicken bit */
73 CRM->ctrl_bit.hicken = TRUE;
74
75 /* wait hick stable */
76 while(CRM->ctrl_bit.hickstbl != SET);
77
78 /* hick used as system clock */
79 CRM->cfg_bit.sclksel = CRM_SCLK_HICK;
80
81 /* wait sclk switch status */
82 while(CRM->cfg_bit.sclksts != CRM_SCLK_HICK);
83
84 /* reset hexten, hextbyps, cfden and pllen bits */
85 CRM->ctrl &= ~(0x010D0000U);
86
87 /* reset cfg register, include sclk switch, ahbdiv, apb1div, apb2div, adcdiv,
88 clkout pllrcs, pllhextdiv, pllmult, usbdiv and pllrange bits */
89 CRM->cfg = 0;
90
91 /* reset clkout[3], usbbufs, hickdiv, clkoutdiv */
92 CRM->misc1 = 0;
93
94 /* disable all interrupts enable and clear pending bits */
95 CRM->clkint = 0x009F0000;
96
97#ifdef VECT_TAB_SRAM
98 SCB->VTOR = SRAM_BASE | VECT_TAB_OFFSET; /* vector table relocation in internal sram. */
99#else
100 SCB->VTOR = FLASH_BASE | VECT_TAB_OFFSET; /* vector table relocation in internal flash. */
101#endif
102}
103
112void system_core_clock_update(void)
113{
114 uint32_t pll_mult = 0, pll_mult_h = 0, pll_clock_source = 0, temp = 0, div_value = 0;
115 crm_sclk_type sclk_source;
116
117 static const uint8_t sys_ahb_div_table[16] = {0, 0, 0, 0, 0, 0, 0, 0, 1, 2, 3, 4, 6, 7, 8, 9};
118
119 /* get sclk source */
120 sclk_source = crm_sysclk_switch_status_get();
121
122 switch(sclk_source)
123 {
124 case CRM_SCLK_HICK:
125 if(((CRM->misc3_bit.hick_to_sclk) != RESET) && ((CRM->misc1_bit.hickdiv) != RESET))
126 system_core_clock = HICK_VALUE * 6;
127 else
128 system_core_clock = HICK_VALUE;
129 break;
130 case CRM_SCLK_HEXT:
131 system_core_clock = HEXT_VALUE;
132 break;
133 case CRM_SCLK_PLL:
134 pll_clock_source = CRM->cfg_bit.pllrcs;
135 {
136 /* get multiplication factor */
137 pll_mult = CRM->cfg_bit.pllmult_l;
138 pll_mult_h = CRM->cfg_bit.pllmult_h;
139 /* process high bits */
140 if((pll_mult_h != 0U) || (pll_mult == 15U)){
141 pll_mult += ((16U * pll_mult_h) + 1U);
142 }
143 else
144 {
145 pll_mult += 2U;
146 }
147
148 if (pll_clock_source == 0x00)
149 {
150 /* hick divided by 2 selected as pll clock entry */
151 system_core_clock = (HICK_VALUE >> 1) * pll_mult;
152 }
153 else
154 {
155 /* hext selected as pll clock entry */
156 if (CRM->cfg_bit.pllhextdiv != RESET)
157 {
158 /* hext clock divided by 2 */
159 system_core_clock = (HEXT_VALUE / 2) * pll_mult;
160 }
161 else
162 {
163 system_core_clock = HEXT_VALUE * pll_mult;
164 }
165 }
166 }
167 break;
168 default:
169 system_core_clock = HICK_VALUE;
170 break;
171 }
172
173 /* compute sclk, ahbclk frequency */
174 /* get ahb division */
175 temp = CRM->cfg_bit.ahbdiv;
176 div_value = sys_ahb_div_table[temp];
177 /* ahbclk frequency */
178 system_core_clock = system_core_clock >> div_value;
179}
at32f413.h
at32f413 header file
div_value
uint16_t div_value
Definition: project/at_start_f413/examples/tmr/oc_high/src/main.c:44
VECT_TAB_OFFSET
#define VECT_TAB_OFFSET
Definition: system_at32f413.c:40
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
SystemInit
void SystemInit(void)
setup the microcontroller system initialize the flash interface.
Definition: system_at32f413.c:64
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_sclk_type
crm_sclk_type
crm sclk select
Definition: at32f413_crm.h:392
CRM_SCLK_HICK
@ CRM_SCLK_HICK
Definition: at32f413_crm.h:393
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_SCLK_HEXT
@ CRM_SCLK_HEXT
Definition: at32f413_crm.h:394
CRM
#define CRM
Definition: at32f413_crm.h:844
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
SRAM_BASE
#define SRAM_BASE
Definition: at32f413.h:294
FLASH_BASE
#define FLASH_BASE
Definition: at32f413.h:291
HEXT_VALUE
#define HEXT_VALUE
in the following line adjust the value of high speed exernal crystal (hext) used in your application
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:44
HICK_VALUE
#define HICK_VALUE
Definition: project/at_start_f413/examples/acc/calibration/inc/at32f413_conf.h:52


AT32F413 Firmwary Library: system_at32f413.h Source File

  • libraries
  • cmsis
  • cm4
  • device_support
system_at32f413.h
Go to the documentation of this file.
1
27#ifndef __SYSTEM_AT32F413_H
28#define __SYSTEM_AT32F413_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
46#define HEXT_STABLE_DELAY (5000u)
47#define PLL_STABLE_DELAY (500u)
48
57extern unsigned int system_core_clock;
67extern void SystemInit(void);
68extern void system_core_clock_update(void);
69
82#ifdef __cplusplus
83}
84#endif
85
86#endif
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
SystemInit
void SystemInit(void)
setup the microcontroller system initialize the flash interface.
Definition: system_at32f413.c:64
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48


AT32F413 Firmwary Library: usb_std.h Source File

  • middlewares
  • usbd_drivers
  • inc
usb_std.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_STD_H
29#define __USB_STD_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "usb_conf.h"
38
54#define USB_REQ_RECIPIENT_DEVICE 0x00
55#define USB_REQ_RECIPIENT_INTERFACE 0x01
56#define USB_REQ_RECIPIENT_ENDPOINT 0x02
57#define USB_REQ_RECIPIENT_OTHER 0x03
58#define USB_REQ_RECIPIENT_MASK 0x1F
63#define USB_REQ_TYPE_STANDARD 0x00
64#define USB_REQ_TYPE_CLASS 0x20
65#define USB_REQ_TYPE_VENDOR 0x40
66#define USB_REQ_TYPE_RESERVED 0x60
71#define USB_REQ_DIR_HTD 0x00
72#define USB_REQ_DIR_DTH 0x80
77#define USB_STD_REQ_GET_STATUS 0
78#define USB_STD_REQ_CLEAR_FEATURE 1
79#define USB_STD_REQ_SET_FEATURE 3
80#define USB_STD_REQ_SET_ADDRESS 5
81#define USB_STD_REQ_GET_DESCRIPTOR 6
82#define USB_STD_REQ_SET_DESCRIPTOR 7
83#define USB_STD_REQ_GET_CONFIGURATION 8
84#define USB_STD_REQ_SET_CONFIGURATION 9
85#define USB_STD_REQ_GET_INTERFACE 10
86#define USB_STD_REQ_SET_INTERFACE 11
87#define USB_STD_REQ_SYNCH_FRAME 12
92#define USB_DESCIPTOR_TYPE_DEVICE 1
93#define USB_DESCIPTOR_TYPE_CONFIGURATION 2
94#define USB_DESCIPTOR_TYPE_STRING 3
95#define USB_DESCIPTOR_TYPE_INTERFACE 4
96#define USB_DESCIPTOR_TYPE_ENDPOINT 5
97#define USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER 6
98#define USB_DESCIPTOR_TYPE_OTHER_SPEED 7
99#define USB_DESCIPTOR_TYPE_INTERFACE_POWER 8
104#define USB_LANGID_STRING 0
105#define USB_MFC_STRING 1
106#define USB_PRODUCT_STRING 2
107#define USB_SERIAL_STRING 3
108#define USB_CONFIG_STRING 4
109#define USB_INTERFACE_STRING 5
114#define USB_CONF_REMOTE_WAKEUP 2
115#define USB_CONF_SELF_POWERED 1
120#define USB_FEATURE_EPT_HALT 0
121#define USB_FEATURE_REMOTE_WAKEUP 1
122#define USB_FEATURE_TEST_MODE 2
127typedef enum
128{
129 USB_CONN_STATE_DEFAULT =1,
130 USB_CONN_STATE_ADDRESSED,
131 USB_CONN_STATE_CONFIGURED,
132 USB_CONN_STATE_SUSPENDED
133}usbd_conn_state;
134
138#define USB_EPT0_IDLE 0
139#define USB_EPT0_SETUP 1
140#define USB_EPT0_DATA_IN 2
141#define USB_EPT0_DATA_OUT 3
142#define USB_EPT0_STATUS_IN 4
143#define USB_EPT0_STATUS_OUT 5
144#define USB_EPT0_STALL 6
149#define USB_DEVICE_QUALIFIER_DESC_LEN 0x0A
150#define USB_DEVICE_DESC_LEN 0x12
151#define USB_DEVICE_CFG_DESC_LEN 0x09
152#define USB_DEVICE_IF_DESC_LEN 0x09
153#define USB_DEVICE_EPT_LEN 0x07
154#define USB_DEVICE_OTG_DESC_LEN 0x03
155#define USB_DEVICE_LANGID_STR_DESC_LEN 0x04
156#define USB_DEVICE_OTHER_SPEED_DESC_SIZ_LEN 0x09
161#define USB_CLASS_CODE_AUDIO 0x01
162#define USB_CLASS_CODE_CDC 0x02
163#define USB_CLASS_CODE_HID 0x03
164#define USB_CLASS_CODE_PRINTER 0x07
165#define USB_CLASS_CODE_MSC 0x08
166#define USB_CLASS_CODE_HUB 0x09
167#define USB_CLASS_CODE_CDCDATA 0x0A
168#define USB_CLASS_CODE_CCID 0x0B
169#define USB_CLASS_CODE_VIDEO 0x0E
170#define USB_CLASS_CODE_VENDOR 0xFF
175#define USB_EPT_DESC_CONTROL 0x00
176#define USB_EPT_DESC_ISO 0x01
177#define USB_EPT_DESC_BULK 0x02
178#define USB_EPT_DESC_INTERRUPT 0x03
180#define USB_EPT_DESC_NSYNC 0x00
181#define USB_ETP_DESC_ASYNC 0x04
182#define USB_ETP_DESC_ADAPTIVE 0x08
183#define USB_ETP_DESC_SYNC 0x0C
185#define USB_EPT_DESC_DATA_EPT 0x00
186#define USB_EPT_DESC_FD_EPT 0x10
187#define USB_EPT_DESC_FDDATA_EPT 0x20
192#define USBD_CDC_CS_INTERFACE 0x24
193#define USBD_CDC_CS_ENDPOINT 0x25
194
198#define USBD_CDC_SUBTYPE_HEADER 0x00
199#define USBD_CDC_SUBTYPE_CMF 0x01
200#define USBD_CDC_SUBTYPE_ACM 0x02
201#define USBD_CDC_SUBTYPE_UFD 0x06
202
206#define SET_LINE_CODING 0x20
207#define GET_LINE_CODING 0x21
208
212typedef struct
213{
214 uint32_t bitrate; /* line coding baud rate */
215 uint8_t format; /* line coding foramt */
216 uint8_t parity; /* line coding parity */
217 uint8_t data; /* line coding data bit */
218}linecoding_type;
219
223#define HID_CLASS_DESC_HID 0x21
224#define HID_CLASS_DESC_REPORT 0x22
225#define HID_CLASS_DESC_PHYSICAL 0x23
226
230#define HID_REQ_SET_PROTOCOL 0x0B
231#define HID_REQ_GET_PROTOCOL 0x03
232#define HID_REQ_SET_IDLE 0x0A
233#define HID_REQ_GET_IDLE 0x02
234#define HID_REQ_SET_REPORT 0x09
235#define HID_REQ_GET_REPORT 0x01
236#define HID_DESCRIPTOR_TYPE 0x21
237#define HID_REPORT_DESC 0x22
238
242#define USB_MAX_EP0_SIZE 64
247#define SWAPBYTE(addr) (uint16_t)(((uint16_t)(*((uint8_t *)(addr)))) + \
248 (((uint16_t)(*(((uint8_t *)(addr)) + 1))) << 8))
253#define MIN(a, b) (uint16_t)(((a) < (b)) ? (a) : (b))
254#define MAX(a, b) (uint16_t)(((a) > (b)) ? (a) : (b))
259#define LBYTE(x) ((uint8_t)(x & 0x00FF))
260#define HBYTE(x) ((uint8_t)((x & 0xFF00) >>8))
273typedef enum
274{
275 USB_OK,
276 USB_FAIL,
277 USB_WAIT,
278 USB_NOT_SUPPORT,
279 USB_ERROR,
280}usb_sts_type;
281
285typedef struct
286{
287 uint8_t bmRequestType;
288 uint8_t bRequest;
289 uint16_t wValue;
290 uint16_t wIndex;
292 uint16_t wLength;
293}usb_setup_type;
294
298typedef struct
299{
300 uint8_t bLength;
301 uint8_t bDescriptorType;
302 uint16_t bcdUSB;
303 uint8_t bDeviceClass;
304 uint8_t bDeviceSubClass;
305 uint8_t bDeviceProtocol;
306 uint8_t bMaxPacketSize0;
307 uint16_t idVendor;
308 uint16_t idProduct;
309 uint16_t bcdDevice;
310 uint8_t iManufacturer;
311 uint8_t iProduct;
312 uint8_t iSerialNumber;
313 uint8_t bNumConfigurations;
314}usb_device_desc_type;
315
319typedef struct
320{
321 uint8_t bLength;
322 uint8_t bDescriptorType;
323 uint16_t wTotalLength;
324 uint8_t bNumInterfaces;
325 uint8_t bConfigurationValue;
326 uint8_t iConfiguration;
327 uint8_t bmAttributes;
332 uint8_t bMaxPower;
335}usb_configuration_desc_type;
336
340typedef struct
341{
342 uint8_t bLength;
343 uint8_t bDescriptorType;
344 uint8_t bInterfaceNumber;
345 uint8_t bAlternateSetting;
346 uint8_t bNumEndpoints;
347 uint8_t bInterfaceClass;
348 uint8_t bInterfaceSubClass;
349 uint8_t bInterfaceProtocol;
350 uint8_t iInterface;
351}usb_interface_desc_type;
352
356typedef struct
357{
358 uint8_t bLength;
359 uint8_t bDescriptorType;
360 uint8_t bEndpointAddress;
361 uint8_t bmAttributes;
362 uint16_t wMaxPacketSize;
363 uint8_t bInterval;
364}usb_endpoint_desc_type;
365
369typedef struct
370{
371 uint8_t bLength;
372 uint8_t bDescriptorType;
373}usb_header_desc_type;
374
375
387#ifdef __cplusplus
388}
389#endif
390
391#endif
392
usbd_conn_state
usbd_conn_state
usb device connect state
Definition: usb_std.h:128
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:132
USB_CONN_STATE_DEFAULT
@ USB_CONN_STATE_DEFAULT
Definition: usb_std.h:129
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
USB_CONN_STATE_ADDRESSED
@ USB_CONN_STATE_ADDRESSED
Definition: usb_std.h:130
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
USB_WAIT
@ USB_WAIT
Definition: usb_std.h:278
USB_ERROR
@ USB_ERROR
Definition: usb_std.h:280
USB_NOT_SUPPORT
@ USB_NOT_SUPPORT
Definition: usb_std.h:279
USB_FAIL
@ USB_FAIL
Definition: usb_std.h:277
linecoding_type
usb cdc class set line coding struct
Definition: usb_std.h:213
linecoding_type::bitrate
uint32_t bitrate
Definition: usb_std.h:214
linecoding_type::data
uint8_t data
Definition: usb_std.h:217
linecoding_type::parity
uint8_t parity
Definition: usb_std.h:216
linecoding_type::format
uint8_t format
Definition: usb_std.h:215
usb_configuration_desc_type
format of standard configuration descriptor
Definition: usb_std.h:321
usb_device_desc_type
format of standard device descriptor
Definition: usb_std.h:300
usb_endpoint_desc_type
format of standard endpoint descriptor
Definition: usb_std.h:358
usb_header_desc_type
format of header
Definition: usb_std.h:371
usb_interface_desc_type
format of standard interface descriptor
Definition: usb_std.h:342
usb_setup_type
format of usb setup data
Definition: usb_std.h:287


AT32F413 Firmwary Library: usbd_core.c Source File

  • middlewares
  • usbd_drivers
  • src
usbd_core.c
Go to the documentation of this file.
1
26#include "usbd_core.h"
27#include "usbd_sdr.h"
28
48void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_addr)
49{
50 /* get endpoint info*/
51 usb_ept_info *ept_info = &udev->ept_in[ept_addr & 0x7F];
52
53 if(ept_addr == 0)
54 {
55 /* endpoint 0 */
56 if(udev->ept0_sts == USB_EPT0_DATA_IN)
57 {
58 if(ept_info->rem0_len > ept_info->maxpacket)
59 {
60 ept_info->rem0_len -= ept_info->maxpacket;
61 usbd_ept_send(udev, 0, ept_info->trans_buf,
62 MIN(ept_info->rem0_len, ept_info->maxpacket));
63 }
64 /* endpoint 0 */
65 else if(ept_info->last_len == ept_info->maxpacket
66 && ept_info->ept0_slen >= ept_info->maxpacket
67 && ept_info->ept0_slen < udev->ept0_wlength)
68 {
69 ept_info->last_len = 0;
70 usbd_ept_send(udev, 0, 0, 0);
71 usbd_ept_recv(udev, ept_addr, 0, 0);
72 }
73 else
74 {
75
76 if(udev->class_handler->ept0_tx_handler != 0 &&
77 udev->conn_state == USB_CONN_STATE_CONFIGURED)
78 {
79 udev->class_handler->ept0_tx_handler(udev);
80 }
81 usbd_ctrl_recv_status(udev);
82
83 }
84 }
85 }
86 else if(udev->class_handler->in_handler != 0 &&
87 udev->conn_state == USB_CONN_STATE_CONFIGURED)
88 {
89 /* other user define endpoint */
90 udev->class_handler->in_handler(udev, ept_addr);
91 }
92}
93
100void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_addr)
101{
102 /* get endpoint info*/
103 usb_ept_info *ept_info = &udev->ept_out[ept_addr & 0x7F];
104
105 if(ept_addr == 0)
106 {
107 /* endpoint 0 */
108 if(udev->ept0_sts == USB_EPT0_DATA_OUT)
109 {
110 if(ept_info->rem0_len > ept_info->maxpacket)
111 {
112 ept_info->rem0_len -= ept_info->maxpacket;
113 usbd_ept_recv(udev, ept_addr, ept_info->trans_buf,
114 MIN(ept_info->rem0_len, ept_info->maxpacket));
115 }
116 else
117 {
118 if(udev->class_handler->ept0_rx_handler != 0)
119 {
120 udev->class_handler->ept0_rx_handler(udev);
121 }
122 usbd_ctrl_send_status(udev);
123 }
124 }
125 }
126 else if(udev->class_handler->out_handler != 0 &&
127 udev->conn_state == USB_CONN_STATE_CONFIGURED)
128 {
129 /* other user define endpoint */
130 udev->class_handler->out_handler(udev, ept_addr);
131 }
132}
133
140void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num)
141{
142 /* setup parse */
143 usbd_setup_request_parse(&udev->setup, udev->setup_buffer);
144
145 /* set ept0 status */
146 udev->ept0_sts = USB_EPT0_SETUP;
147 udev->ept0_wlength = udev->setup.wLength;
148
149 switch(udev->setup.bmRequestType & USB_REQ_RECIPIENT_MASK)
150 {
151 case USB_REQ_RECIPIENT_DEVICE:
152 /* recipient device request */
153 usbd_device_request(udev);
154 break;
155 case USB_REQ_RECIPIENT_INTERFACE:
156 /* recipient interface request */
157 usbd_interface_request(udev);
158 break;
159 case USB_REQ_RECIPIENT_ENDPOINT:
160 /* recipient endpoint request */
161 usbd_endpoint_request(udev);
162 break;
163 default:
164 break;
165 }
166}
167
176void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
177{
178 usb_ept_info *ept_info = &udev->ept_in[0];
179
180 ept_info->ept0_slen = len;
181 ept_info->rem0_len = len;
182 udev->ept0_sts = USB_EPT0_DATA_IN;
183
184 usbd_ept_send(udev, 0, buffer, len);
185}
186
195void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
196{
197 usb_ept_info *ept_info = &udev->ept_out[0];
198
199 ept_info->ept0_slen = len;
200 ept_info->rem0_len = len;
201 udev->ept0_sts = USB_EPT0_DATA_OUT;
202
203 usbd_ept_recv(udev, 0, buffer, len);
204}
205
211void usbd_ctrl_send_status(usbd_core_type *udev)
212{
213 udev->ept0_sts = USB_EPT0_STATUS_IN;
214
215 usbd_ept_send(udev, 0, 0, 0);
216}
217
223void usbd_ctrl_recv_status(usbd_core_type *udev)
224{
225 udev->ept0_sts = USB_EPT0_STATUS_OUT;
226
227 usbd_ept_recv(udev, 0, 0, 0);
228}
229
236void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr)
237{
238 usb_ept_info *ept_info;
239
240 if(ept_addr & 0x80)
241 {
242 /* in endpoint */
243 ept_info = &udev->ept_in[ept_addr & 0x7F];
244 USB_SET_TXSTS(ept_info->eptn, USB_TX_VALID);
245 }
246 else
247 {
248 /* out endpoint */
249 ept_info = &udev->ept_out[ept_addr & 0x7F];
250 USB_SET_RXSTS(ept_info->eptn, USB_RX_VALID);
251 }
252 ept_info->stall = 0;
253}
254
261void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
262{
263 usb_ept_info *ept_info;
264
265 if(ept_addr & 0x80)
266 {
267 /* in endpoint */
268 ept_info = &udev->ept_in[ept_addr & 0x7F];
269 USB_SET_TXSTS(ept_info->eptn, USB_TX_STALL);
270 }
271 else
272 {
273 /* out endpoint */
274 ept_info = &udev->ept_out[ept_addr & 0x7F];
275 USB_SET_RXSTS(ept_info->eptn, USB_RX_STALL)
276 }
277
278 ept_info->stall = 1;
279}
280
286void usbd_ctrl_unsupport(usbd_core_type *udev)
287{
288 /* return stall status */
289 usbd_set_stall(udev, 0x00);
290 usbd_set_stall(udev, 0x80);
291}
292
301void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
302{
303 /* get endpoint info struct and register */
304 usb_ept_info *ept_info = &udev->ept_in[ept_addr & 0x7F];
305 uint16_t trs_len = 0;
306 usbd_type *usbx = udev->usb_reg;
307
308 /* set send data buffer and length */
309 ept_info->trans_buf = buffer;
310 ept_info->total_len = len;
311 ept_info->trans_len = 0;
312
313 if(ept_info->total_len > ept_info->maxpacket)
314 {
315 trs_len = ept_info->maxpacket;
316 ept_info->total_len -= trs_len;
317 }
318 else
319 {
320 trs_len = len;
321 ept_info->total_len = 0;
322 }
323
324 ept_info->last_len = trs_len;
325
326 if(ept_info->is_double_buffer == 0)
327 {
328 /* write data to endpoint buffer */
329 usb_write_packet(ept_info->trans_buf, ept_info->tx_addr, trs_len);
330
331 /* set send data length */
332 USB_SET_TXLEN((ept_addr & 0x7F), trs_len);
333 }
334 else
335 {
336 if(usbx->ept_bit[ept_addr & 0x7F].txdts)
337 {
338 USB_SET_EPT_DOUBLE_BUF1_LEN((ept_addr & 0x7F), trs_len, DATA_TRANS_IN);
339 usb_write_packet(ept_info->trans_buf, ept_info->rx_addr, trs_len);
340 }
341 else
342 {
343 USB_SET_EPT_DOUBLE_BUF0_LEN((ept_addr & 0x7F), trs_len, DATA_TRANS_IN);
344 usb_write_packet(ept_info->trans_buf, ept_info->tx_addr, trs_len);
345 }
346 USB_FREE_DB_USER_BUFFER((ept_addr & 0x7F), DATA_TRANS_IN);
347 }
348
349 /* set tx status valid */
350 USB_SET_TXSTS((ept_addr & 0x7F), USB_TX_VALID);
351}
352
361void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
362{
363 /* get endpoint info struct and register */
364 usb_ept_info *ept_info = &udev->ept_out[ept_addr & 0x7F];
365 uint32_t trs_len = 0;
366
367 /* set receive data buffer and length */
368 ept_info->trans_buf = buffer;
369 ept_info->total_len = len;
370 ept_info->trans_len = 0;
371
372 if(ept_info->total_len > ept_info->maxpacket)
373 {
374 trs_len = ept_info->maxpacket;
375 ept_info->total_len -= trs_len;
376 }
377 else
378 {
379 trs_len = len;
380 ept_info->total_len = 0;
381 }
382
383 /* set rx status valid */
384 USB_SET_RXSTS((ept_addr & 0x7F), USB_RX_VALID);
385}
386
387
394uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
395{
396 usb_ept_info *ept = &udev->ept_out[ept_addr & 0x7F];
397 return ept->trans_len;
398}
399
406void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
407{
408 usb_ept_info *ept_info;
409 if((ept_addr & 0x80) == 0)
410 {
411 /* out endpoint info */
412 ept_info = &udev->ept_out[ept_addr & 0x7F];
413 }
414 else
415 {
416 /* in endpoint info */
417 ept_info = &udev->ept_in[ept_addr & 0x7F];
418 }
419 ept_info->is_double_buffer = TRUE;
420}
421
427void usbd_ept_buf_auto_define(usb_ept_info *ept_info)
428{
429 if(ept_info->is_double_buffer == 0)
430 {
431 if( ept_info->inout == DATA_TRANS_IN )
432 {
433 if(ept_info->tx_addr == 0)
434 ept_info->tx_addr = usb_buffer_malloc(ept_info->maxpacket);
435 }
436 else
437 {
438 if(ept_info->rx_addr == 0)
439 ept_info->rx_addr = usb_buffer_malloc(ept_info->maxpacket);
440 }
441 }
442 else
443 {
444 /* double buffer auto define */
445 if(ept_info->tx_addr == 0)
446 ept_info->tx_addr = usb_buffer_malloc(ept_info->maxpacket);
447 if(ept_info->rx_addr == 0)
448 ept_info->rx_addr = usb_buffer_malloc(ept_info->maxpacket);
449 }
450}
451
452
453
461void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr,
462 uint32_t addr)
463{
464 usb_ept_info *ept_info;
465 if((ept_addr & 0x80) == 0)
466 {
467 /* out endpoint info */
468 ept_info = &udev->ept_out[ept_addr & 0x7F];
469 }
470 else
471 {
472 /* in endpoint info */
473 ept_info = &udev->ept_in[ept_addr & 0x7F];
474 }
475
476 if(ept_info->is_double_buffer == 0)
477 {
478 if( ept_info->inout == DATA_TRANS_IN )
479 {
480 ept_info->tx_addr = addr;
481 }
482 else
483 {
484 ept_info->rx_addr = addr;
485 }
486 }
487 else
488 {
489 /* double buffer malloc */
490 ept_info->tx_addr = addr & 0xFFFF;
491 ept_info->rx_addr = (addr >> 16) & 0xFFFF;
492 }
493}
494
503void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
504{
505 usbd_type *usbx = udev->usb_reg;
506 usb_ept_info *ept_info;
507
508 if((ept_addr & 0x80) == 0)
509 {
510 /* out endpoint info */
511 ept_info = &udev->ept_out[ept_addr & 0x7F];
512 ept_info->inout = DATA_TRANS_OUT;
513 }
514 else
515 {
516 /* in endpoint info */
517 ept_info = &udev->ept_in[ept_addr & 0x7F];
518 ept_info->inout = DATA_TRANS_IN;
519 }
520
521 /* set endpoint maxpacket and type */
522 ept_info->maxpacket = (maxpacket + 1) & 0xFFFE;
523 ept_info->trans_type = ept_type;
524
525#ifdef USB_EPT_AUTO_MALLOC_BUFFER
526 usbd_ept_buf_auto_define(ept_info);
527#endif
528 /* open endpoint */
529 usb_ept_open(usbx, ept_info);
530}
531
538void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
539{
540 usb_ept_info *ept_info;
541 if(ept_addr & 0x80)
542 {
543 /* in endpoint */
544 ept_info = &udev->ept_in[ept_addr & 0x7F];
545 }
546 else
547 {
548 /* out endpoint */
549 ept_info = &udev->ept_out[ept_addr & 0x7F];
550 }
551
552 /* close endpoint */
553 usb_ept_close(udev->usb_reg, ept_info);
554}
555
561void usbd_connect(usbd_core_type *udev)
562{
563 usb_connect(udev->usb_reg);
564}
565
571void usbd_disconnect(usbd_core_type *udev)
572{
573 usb_disconnect(udev->usb_reg);
574}
575
582void usbd_set_device_addr(usbd_core_type *udev, uint8_t address)
583{
584 usb_set_address(udev->usb_reg, address);
585}
586
592 usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
593{
594 return udev->conn_state;
595}
596
602void usbd_remote_wakeup(usbd_core_type *udev)
603{
604 /* set connect state */
605 udev->conn_state = udev->old_conn_state;
606
607 usb_exit_suspend(udev->usb_reg);
608
609 usb_remote_wkup_set(udev->usb_reg);
610
611 usb_delay_ms(10);
612
613 usb_remote_wkup_clear(udev->usb_reg);
614
615}
616
622void usbd_enter_suspend(usbd_core_type *udev)
623{
624 usb_enter_suspend(udev->usb_reg);
625}
626
632void usbd_ept_defaut_init(usbd_core_type *udev)
633{
634 uint8_t i_index = 0;
635 /* init in endpoint info structure */
636 for(i_index = 0; i_index < USB_EPT_MAX_NUM; i_index ++)
637 {
638 udev->ept_in[i_index].eptn = i_index;
639 udev->ept_in[i_index].ept_address = i_index;
640 udev->ept_in[i_index].inout = DATA_TRANS_IN;
641 udev->ept_in[i_index].maxpacket = 0;
642 udev->ept_in[i_index].trans_buf = 0;
643 udev->ept_in[i_index].total_len = 0;
644 udev->ept_in[i_index].tx_addr = 0;
645 udev->ept_in[i_index].rx_addr = 0;
646 }
647
648 /* init out endpoint info structure */
649 for(i_index = 0; i_index < USB_EPT_MAX_NUM; i_index ++)
650 {
651 udev->ept_out[i_index].eptn = i_index;
652 udev->ept_out[i_index].ept_address = i_index;
653 udev->ept_out[i_index].inout = DATA_TRANS_OUT;
654 udev->ept_out[i_index].maxpacket = 0;
655 udev->ept_out[i_index].trans_buf = 0;
656 udev->ept_out[i_index].total_len = 0;
657 udev->ept_out[i_index].rx_addr = 0;
658 udev->ept_out[i_index].tx_addr = 0;
659 }
660 return;
661}
662
672void usbd_core_init(usbd_core_type *udev,
673 usb_reg_type *usb_reg,
674 usbd_class_handler *class_handler,
675 usbd_desc_handler *desc_handler,
676 uint8_t core_id)
677{
678 /* usb class handler */
679 udev->class_handler = class_handler;
680
681 /* usb description handler */
682 udev->desc_handler = desc_handler;
683
684 /* set usb register type */
685 udev->usb_reg = usb_reg;
686
687 /* set usb connect state to default */
688 udev->conn_state = USB_CONN_STATE_DEFAULT;
689
690 /* init in endpoint info structure */
691 usbd_ept_defaut_init(udev);
692
693#ifdef USB_BUFFER_SIZE_EX
694 /* usb buffer size extend 768-1280 byte */
695 usb_usbbufs_enable(usb_reg, TRUE);
696#endif
697
698 /*usb register config */
699 usb_dev_init(udev->usb_reg);
700}
701
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
TRUE
@ TRUE
Definition: at32f413.h:259
USB_RX_STALL
#define USB_RX_STALL
Definition: at32f413_usb.h:125
USB_TX_VALID
#define USB_TX_VALID
Definition: at32f413_usb.h:119
USB_TX_STALL
#define USB_TX_STALL
Definition: at32f413_usb.h:117
USB_RX_VALID
#define USB_RX_VALID
Definition: at32f413_usb.h:127
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:223
DATA_TRANS_IN
@ DATA_TRANS_IN
Definition: at32f413_usb.h:224
usb_exit_suspend
void usb_exit_suspend(usbd_type *usbx)
usb device exit suspend mode
Definition: at32f413_usb.c:441
usb_write_packet
void usb_write_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
write data from user memory to usb buffer
Definition: at32f413_usb.c:316
usb_disconnect
void usb_disconnect(usbd_type *usbx)
disconnect usb device
Definition: at32f413_usb.c:93
usb_enter_suspend
void usb_enter_suspend(usbd_type *usbx)
usb device enter suspend mode
Definition: at32f413_usb.c:429
usb_remote_wkup_clear
void usb_remote_wkup_clear(usbd_type *usbx)
usb remote wakeup clear
Definition: at32f413_usb.c:464
usb_usbbufs_enable
void usb_usbbufs_enable(usbd_type *usbx, confirm_state state)
mapping usb packet buffer area two mapping intervals are available for packet buffer area,...
Definition: at32f413_usb.c:116
usb_set_address
void usb_set_address(usbd_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f413_usb.c:398
usb_buffer_malloc
uint16_t usb_buffer_malloc(uint16_t maxpacket)
usb auto malloc endpoint buffer
Definition: at32f413_usb.c:474
usb_remote_wkup_set
void usb_remote_wkup_set(usbd_type *usbx)
usb remote wakeup set
Definition: at32f413_usb.c:453
usb_connect
void usb_connect(usbd_type *usbx)
connect usb device
Definition: at32f413_usb.c:81
usb_ept_open
void usb_ept_open(usbd_type *usbx, usb_ept_info *ept_info)
open usb endpoint
Definition: at32f413_usb.c:139
usb_dev_init
void usb_dev_init(usbd_type *usbx)
initialize usb peripheral controller register
Definition: at32f413_usb.c:58
usb_ept_close
void usb_ept_close(usbd_type *usbx, usb_ept_info *ept_info)
close usb endpoint
Definition: at32f413_usb.c:258
USB_SET_EPT_DOUBLE_BUF1_LEN
#define USB_SET_EPT_DOUBLE_BUF1_LEN(eptn, len, dir)
double buffer mode set endpoint buf1 length
Definition: at32f413_usb.h:377
USB_SET_RXSTS
#define USB_SET_RXSTS(ept_num, new_sts)
set usb endpoint rx status
Definition: at32f413_usb.h:264
USB_FREE_DB_USER_BUFFER
#define USB_FREE_DB_USER_BUFFER(eptn, inout)
free buffer used by application
Definition: at32f413_usb.h:462
USB_SET_TXLEN
#define USB_SET_TXLEN(eptn, len)
set endpoint tx/rx transfer length
Definition: at32f413_usb.h:335
USB_SET_TXSTS
#define USB_SET_TXSTS(ept_num, new_sts)
set usb endpoint tx status
Definition: at32f413_usb.h:249
USB_SET_EPT_DOUBLE_BUF0_LEN
#define USB_SET_EPT_DOUBLE_BUF0_LEN(eptn, len, dir)
double buffer mode set endpoint buf0 length
Definition: at32f413_usb.h:359
USB_EPT0_STATUS_OUT
#define USB_EPT0_STATUS_OUT
Definition: usb_std.h:143
usbd_conn_state
usbd_conn_state
usb device connect state
Definition: usb_std.h:128
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_EPT0_DATA_IN
#define USB_EPT0_DATA_IN
Definition: usb_std.h:140
USB_REQ_RECIPIENT_DEVICE
#define USB_REQ_RECIPIENT_DEVICE
usb request recipient
Definition: usb_std.h:54
USB_REQ_RECIPIENT_MASK
#define USB_REQ_RECIPIENT_MASK
Definition: usb_std.h:58
USB_EPT0_DATA_OUT
#define USB_EPT0_DATA_OUT
Definition: usb_std.h:141
USB_EPT0_SETUP
#define USB_EPT0_SETUP
Definition: usb_std.h:139
USB_REQ_RECIPIENT_ENDPOINT
#define USB_REQ_RECIPIENT_ENDPOINT
Definition: usb_std.h:56
USB_EPT0_STATUS_IN
#define USB_EPT0_STATUS_IN
Definition: usb_std.h:142
USB_REQ_RECIPIENT_INTERFACE
#define USB_REQ_RECIPIENT_INTERFACE
Definition: usb_std.h:55
USB_CONN_STATE_DEFAULT
@ USB_CONN_STATE_DEFAULT
Definition: usb_std.h:129
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:261
usbd_ept_dbuffer_enable
void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer.
Definition: usbd_core.c:406
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:211
usbd_set_device_addr
void usbd_set_device_addr(usbd_core_type *udev, uint8_t address)
usb device set device address.
Definition: usbd_core.c:582
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_core_out_handler
void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_addr)
usb core out transfer complete handler
Definition: usbd_core.c:100
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:461
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_ctrl_recv_status
void usbd_ctrl_recv_status(usbd_core_type *udev)
usb control endpoint send out status
Definition: usbd_core.c:223
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_core_in_handler
void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_addr)
usb core in transfer complete handler
Definition: usbd_core.c:48
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_addr, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_clear_stall
void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall
Definition: usbd_core.c:236
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:602
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_ept_defaut_init
void usbd_ept_defaut_init(usbd_core_type *udev)
usb endpoint structure initialization
Definition: usbd_core.c:632
usbd_ept_buf_auto_define
void usbd_ept_buf_auto_define(usb_ept_info *ept_info)
usb auto define endpoint buffer
Definition: usbd_core.c:427
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *class_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_enter_suspend
void usbd_enter_suspend(usbd_core_type *udev)
usb device enter suspend mode
Definition: usbd_core.c:622
usbd_disconnect
void usbd_disconnect(usbd_core_type *udev)
usb device disconnect to host
Definition: usbd_core.c:571
usbd_core_setup_handler
void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler
Definition: usbd_core.c:140
usbd_endpoint_request
usb_sts_type usbd_endpoint_request(usbd_core_type *udev)
standard usb endpoint requests
Definition: usbd_sdr.c:419
usbd_setup_request_parse
void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request
Definition: usbd_sdr.c:55
usbd_device_request
usb_sts_type usbd_device_request(usbd_core_type *udev)
standard usb device requests
Definition: usbd_sdr.c:350
usbd_interface_request
usb_sts_type usbd_interface_request(usbd_core_type *udev)
standard usb interface requests
Definition: usbd_sdr.c:394
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:501
usb_ept_info::total_len
uint16_t total_len
Definition: at32f413_usb.h:515
usb_ept_info::ept_address
uint8_t ept_address
Definition: at32f413_usb.h:503
usb_ept_info::trans_len
uint16_t trans_len
Definition: at32f413_usb.h:516
usb_ept_info::inout
uint8_t inout
Definition: at32f413_usb.h:504
usb_ept_info::maxpacket
uint16_t maxpacket
Definition: at32f413_usb.h:509
usb_ept_info::ept0_slen
uint16_t ept0_slen
Definition: at32f413_usb.h:521
usb_ept_info::rx_addr
uint16_t rx_addr
Definition: at32f413_usb.h:508
usb_ept_info::trans_buf
uint8_t * trans_buf
Definition: at32f413_usb.h:517
usb_ept_info::stall
uint8_t stall
Definition: at32f413_usb.h:511
usb_ept_info::is_double_buffer
uint8_t is_double_buffer
Definition: at32f413_usb.h:510
usb_ept_info::last_len
uint16_t last_len
Definition: at32f413_usb.h:519
usb_ept_info::rem0_len
uint16_t rem0_len
Definition: at32f413_usb.h:520
usb_ept_info::tx_addr
uint16_t tx_addr
Definition: at32f413_usb.h:507
usb_ept_info::eptn
uint8_t eptn
Definition: at32f413_usb.h:502
usb_ept_info::trans_type
uint8_t trans_type
Definition: at32f413_usb.h:505
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::out_handler
usb_sts_type(* out_handler)(void *udev, uint8_t ept_num)
Definition: usbd_core.h:100
usbd_class_handler::ept0_tx_handler
usb_sts_type(* ept0_tx_handler)(void *udev)
Definition: usbd_core.h:97
usbd_class_handler::ept0_rx_handler
usb_sts_type(* ept0_rx_handler)(void *udev)
Definition: usbd_core.h:98
usbd_class_handler::in_handler
usb_sts_type(* in_handler)(void *udev, uint8_t ept_num)
Definition: usbd_core.h:99
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::conn_state
usbd_conn_state conn_state
Definition: usbd_core.h:126
usbd_core_type::setup_buffer
uint8_t setup_buffer[12]
Definition: usbd_core.h:120
usbd_core_type::ept0_wlength
uint16_t ept0_wlength
Definition: usbd_core.h:124
usbd_core_type::ept0_sts
uint8_t ept0_sts
Definition: usbd_core.h:122
usbd_core_type::old_conn_state
usbd_conn_state old_conn_state
Definition: usbd_core.h:127
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core_type::ept_in
usb_ept_info ept_in[USB_EPT_MAX_NUM]
Definition: usbd_core.h:116
usbd_core_type::ept_out
usb_ept_info ept_out[USB_EPT_MAX_NUM]
Definition: usbd_core.h:117
usbd_core_type::setup
usb_setup_type setup
Definition: usbd_core.h:119
usbd_core_type::usb_reg
usb_reg_type * usb_reg
Definition: usbd_core.h:111
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:114
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_type
type define usb register all
Definition: at32f413_usb.h:528
usbd_type::txdts
__IO uint32_t txdts
Definition: at32f413_usb.h:539
usbd_type::ept_bit
struct usbd_type::@731::@745 ept_bit[8]
usbd_core.h
usb device core header file
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: usbd_core.h Source File

  • middlewares
  • usbd_drivers
  • inc
usbd_core.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USBD_CORE_H
29#define __USBD_CORE_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36#include "usb_conf.h"
37#include "usb_std.h"
38
54typedef enum
55{
56 USBD_NOP_EVENT,
57 USBD_RESET_EVENT,
58 USBD_SUSPEND_EVENT,
59 USBD_WAKEUP_EVENT,
60 USBD_ERR_EVENT
61}usbd_event_type;
62
66typedef struct
67{
68 uint16_t length;
69 uint8_t *descriptor;
70}usbd_desc_t;
71
75typedef struct
76{
77 usbd_desc_t *(*get_device_descriptor)(void);
78 usbd_desc_t *(*get_device_qualifier)(void);
79 usbd_desc_t *(*get_device_configuration)(void);
80 usbd_desc_t *(*get_device_other_speed)(void);
81 usbd_desc_t *(*get_device_lang_id)(void);
82 usbd_desc_t *(*get_device_manufacturer_string)(void);
83 usbd_desc_t *(*get_device_product_string)(void);
84 usbd_desc_t *(*get_device_serial_string)(void);
85 usbd_desc_t *(*get_device_interface_string)(void);
86 usbd_desc_t *(*get_device_config_string)(void);
87}usbd_desc_handler;
88
92typedef struct
93{
94 usb_sts_type (*init_handler)(void *udev);
95 usb_sts_type (*clear_handler)(void *udev);
96 usb_sts_type (*setup_handler)(void *udev, usb_setup_type *setup);
97 usb_sts_type (*ept0_tx_handler)(void *udev);
98 usb_sts_type (*ept0_rx_handler)(void *udev);
99 usb_sts_type (*in_handler)(void *udev, uint8_t ept_num);
100 usb_sts_type (*out_handler)(void *udev, uint8_t ept_num);
101 usb_sts_type (*sof_handler)(void *udev);
102 usb_sts_type (*event_handler)(void *udev, usbd_event_type event);
103 void *pdata;
104}usbd_class_handler;
105
109typedef struct
110{
111 usb_reg_type *usb_reg;
113 usbd_class_handler *class_handler;
114 usbd_desc_handler *desc_handler;
116 usb_ept_info ept_in[USB_EPT_MAX_NUM];
117 usb_ept_info ept_out[USB_EPT_MAX_NUM];
119 usb_setup_type setup;
120 uint8_t setup_buffer[12];
122 uint8_t ept0_sts;
123 uint8_t speed;
124 uint16_t ept0_wlength;
126 usbd_conn_state conn_state;
127 usbd_conn_state old_conn_state;
129 uint8_t device_addr;
130 uint8_t remote_wakup;
131 uint8_t default_config;
132 uint8_t dev_config;
133 uint16_t config_status;
134}usbd_core_type;
135
143void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_num);
144void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_num);
145void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num);
146void usbd_ctrl_unsupport(usbd_core_type *udev);
147void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len);
148void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len);
149void usbd_ctrl_send_status(usbd_core_type *udev);
150void usbd_ctrl_recv_status(usbd_core_type *udev);
151void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr);
152void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr);
153void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket);
154void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr);
155void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len);
156void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len);
157void usbd_connect(usbd_core_type *udev);
158void usbd_disconnect(usbd_core_type *udev);
159void usbd_set_device_addr(usbd_core_type *udev, uint8_t address);
160uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr);
161 usbd_conn_state usbd_connect_state_get(usbd_core_type *udev);
162void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr);
163void usbd_ept_buf_auto_define(usb_ept_info *ept_info);
164void usbd_ept_buf_custom_define( usbd_core_type *udev, uint8_t ept_addr,
165 uint32_t addr);
166void usbd_ept_defaut_init(usbd_core_type *udev);
167void usbd_remote_wakeup(usbd_core_type *udev);
168void usbd_enter_suspend(usbd_core_type *udev);
169void usbd_core_init(usbd_core_type *udev,
170 usb_reg_type *usb_reg,
171 usbd_class_handler *dev_handler,
172 usbd_desc_handler *desc_handler,
173 uint8_t core_id);
174
175
188#ifdef __cplusplus
189}
190#endif
191
192#endif
193
buffer
uint8_t buffer[((uint16_t) 160) *((uint16_t) 120)]
Definition: project/at_start_f413/examples/cortex_m4/fpu/src/main.c:43
usbd_conn_state
usbd_conn_state
usb device connect state
Definition: usb_std.h:128
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
usbd_connect_state_get
usbd_conn_state usbd_connect_state_get(usbd_core_type *udev)
get usb connect state
Definition: usbd_core.c:592
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:261
usbd_ept_dbuffer_enable
void usbd_ept_dbuffer_enable(usbd_core_type *udev, uint8_t ept_addr)
enable endpoint double buffer.
Definition: usbd_core.c:406
usbd_ept_close
void usbd_ept_close(usbd_core_type *udev, uint8_t ept_addr)
usb close endpoint
Definition: usbd_core.c:538
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:211
usbd_set_device_addr
void usbd_set_device_addr(usbd_core_type *udev, uint8_t address)
usb device set device address.
Definition: usbd_core.c:582
usbd_core_in_handler
void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_num)
usb core in transfer complete handler
Definition: usbd_core.c:48
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:461
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_ctrl_recv_status
void usbd_ctrl_recv_status(usbd_core_type *udev)
usb control endpoint send out status
Definition: usbd_core.c:223
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_core_out_handler
void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_num)
usb core out transfer complete handler
Definition: usbd_core.c:100
usbd_clear_stall
void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall
Definition: usbd_core.c:236
usbd_get_recv_len
uint32_t usbd_get_recv_len(usbd_core_type *udev, uint8_t ept_addr)
usb endpoint get receive data length
Definition: usbd_core.c:394
usbd_remote_wakeup
void usbd_remote_wakeup(usbd_core_type *udev)
usb device remote wakeup
Definition: usbd_core.c:602
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_ept_defaut_init
void usbd_ept_defaut_init(usbd_core_type *udev)
usb endpoint structure initialization
Definition: usbd_core.c:632
usbd_ept_buf_auto_define
void usbd_ept_buf_auto_define(usb_ept_info *ept_info)
usb auto define endpoint buffer
Definition: usbd_core.c:427
usbd_ctrl_recv
void usbd_ctrl_recv(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint receive data
Definition: usbd_core.c:195
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_enter_suspend
void usbd_enter_suspend(usbd_core_type *udev)
usb device enter suspend mode
Definition: usbd_core.c:622
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_disconnect
void usbd_disconnect(usbd_core_type *udev)
usb device disconnect to host
Definition: usbd_core.c:571
usbd_core_setup_handler
void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler
Definition: usbd_core.c:140
usbd_event_type
usbd_event_type
usb device event
Definition: usbd_core.h:55
USBD_ERR_EVENT
@ USBD_ERR_EVENT
Definition: usbd_core.h:60
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
USBD_NOP_EVENT
@ USBD_NOP_EVENT
Definition: usbd_core.h:56
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:501
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usbd_class_handler
usb device class handler
Definition: usbd_core.h:93
usbd_class_handler::pdata
void * pdata
Definition: usbd_core.h:103
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::conn_state
usbd_conn_state conn_state
Definition: usbd_core.h:126
usbd_core_type::default_config
uint8_t default_config
Definition: usbd_core.h:131
usbd_core_type::remote_wakup
uint8_t remote_wakup
Definition: usbd_core.h:130
usbd_core_type::ept0_wlength
uint16_t ept0_wlength
Definition: usbd_core.h:124
usbd_core_type::ept0_sts
uint8_t ept0_sts
Definition: usbd_core.h:122
usbd_core_type::old_conn_state
usbd_conn_state old_conn_state
Definition: usbd_core.h:127
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core_type::config_status
uint16_t config_status
Definition: usbd_core.h:133
usbd_core_type::speed
uint8_t speed
Definition: usbd_core.h:123
usbd_core_type::dev_config
uint8_t dev_config
Definition: usbd_core.h:132
usbd_core_type::device_addr
uint8_t device_addr
Definition: usbd_core.h:129
usbd_core_type::setup
usb_setup_type setup
Definition: usbd_core.h:119
usbd_core_type::usb_reg
usb_reg_type * usb_reg
Definition: usbd_core.h:111
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:114
usbd_desc_handler
usb device descriptor handler
Definition: usbd_core.h:76
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usbd_type
type define usb register all
Definition: at32f413_usb.h:528
usb_std.h
usb standard header file


AT32F413 Firmwary Library: usbd_int.c Source File

  • middlewares
  • usbd_drivers
  • src
usbd_int.c
Go to the documentation of this file.
1
26#include "usbd_int.h"
27
46void usbd_irq_handler(usbd_core_type *udev)
47{
48 usbd_type *usbx = udev->usb_reg;
49 uint32_t sts_val = usbx->intsts;
50 uint32_t sts_ien = usbx->ctrl;
51
52 if(sts_val & USB_TC_FLAG)
53 {
54 /* endpoint tc interrupt handler */
55 usbd_ept_loop_handler(udev);
56 }
57
58 if(sts_val & USB_RST_FLAG)
59 {
60 /* clear reset flag */
61 usb_flag_clear(usbx, USB_RST_FLAG);
62
63 /* reset interrupt handler */
64 usbd_reset_handler(udev);
65 }
66
67 if((sts_val & USB_SOF_FLAG) &&
68 (sts_ien & USB_SOF_INT))
69 {
70 /* clear sof flag */
71 usb_flag_clear(usbx, USB_SOF_FLAG);
72
73 /* sof interrupt handler */
74 usbd_sof_handler(udev);
75 }
76
77 if((sts_val & USB_LSOF_FLAG) &&
78 (sts_ien & USB_LSOF_INT))
79 {
80 /* clear lsof flag */
81 usb_flag_clear(usbx, USB_LSOF_FLAG);
82 }
83
84 if((sts_val & USB_SP_FLAG) &&
85 (sts_ien & USB_SP_INT))
86 {
87 /* clear suspend flag */
88 usb_flag_clear(usbx, USB_SP_FLAG);
89
90 /* usb suspend interrupt handler */
91 usbd_suspend_handler(udev);
92 }
93
94 if((sts_val & USB_WK_FLAG) &&
95 (sts_ien & USB_WK_INT))
96 {
97 /* usb wakeup interrupt handler */
98 usbd_wakeup_handler(udev);
99
100 /* clear wakeup flag */
101 usb_flag_clear(usbx, USB_WK_FLAG);
102 }
103}
104
111void usbd_eptn_handler(usbd_core_type *udev, usb_ept_number_type ept_num)
112{
113 usbd_type *usbx = udev->usb_reg;
114 usb_ept_info *ept_info;
115 uint32_t ept_val = usbx->ept[ept_num];
116 uint16_t length;
117
118 /* in interrupt request */
119 if(ept_val & USB_TXTC)
120 {
121 /* get endpoint register and in transfer info struct */
122 ept_info = &udev->ept_in[ept_num];
123
124 /* clear endpoint tc flag */
125 USB_CLEAR_TXTC(ept_num);
126
127 /* get endpoint tx length */
128 ept_info->trans_len = USB_GET_TX_LEN(ept_num);
129
130 /* offset the trans buffer */
131 ept_info->trans_buf += ept_info->trans_len;
132
133 if(ept_info->total_len == 0 || ept_num == USB_EPT0)
134 {
135 /* in transfer complete */
136 usbd_core_in_handler(udev, ept_num);
137 }
138 else
139 {
140 /* endpoint continue send data */
141 usbd_ept_send(udev, ept_num, ept_info->trans_buf, ept_info->total_len);
142 }
143 /* set the host assignment address */
144 if(udev->conn_state == USB_CONN_STATE_ADDRESSED && udev->device_addr > 0)
145 {
146 usb_set_address(udev->usb_reg, udev->device_addr);
147 udev->device_addr = 0;
148 }
149 }
150 else
151 {
152 /* setup and out interrupt request */
153
154 /* get endpoint register and out transfer info struct */
155 ept_info = &udev->ept_out[ept_num];
156
157 if((ept_val & USB_SETUPTC) != 0)
158 {
159 /* endpoint setup interrupt request */
160
161 /* get endpoint received data length */
162 ept_info->trans_len = USB_GET_RX_LEN(ept_num);
163
164 /* read endpoint received data */
165 usb_read_packet(udev->setup_buffer, ept_info->rx_addr, ept_info->trans_len);
166
167 /* clear endpoint rx tc flag */
168 USB_CLEAR_RXTC(USB_EPT0);
169
170 /* endpoint setup complete handler */
171 usbd_core_setup_handler(udev, ept_num);
172 }
173 else if(ept_val & USB_RXTC )
174 {
175 /* endpoint out interrupt request */
176 USB_CLEAR_RXTC(ept_num);
177
178 if(ept_info->is_double_buffer == 0)
179 {
180 /* get endpoint received data length */
181 length = USB_GET_RX_LEN(ept_num);
182
183 /* read endpoint received data */
184 usb_read_packet(ept_info->trans_buf, ept_info->rx_addr, length);
185 }
186 else
187 {
188 if( ept_val & USB_RXDTS)
189 {
190 length = USB_DBUF0_GET_LEN(ept_num);
191 usb_read_packet(ept_info->trans_buf, ept_info->tx_addr, length);
192 }
193 else
194 {
195 length = USB_DBUF1_GET_LEN(ept_num);
196 usb_read_packet(ept_info->trans_buf, ept_info->rx_addr, length);
197 }
198 USB_FREE_DB_USER_BUFFER(ept_num, DATA_TRANS_OUT);
199 }
200
201 /* set received data length */
202 ept_info->trans_len += length;
203 ept_info->trans_buf += length;
204
205 if(ept_info->total_len == 0 || length < ept_info->maxpacket || ept_num == USB_EPT0)
206 {
207 /* out transfer complete */
208 usbd_core_out_handler(udev, ept_num);
209 }
210 else
211 {
212 /* endpoint continue receive data */
213 usbd_ept_recv(udev, ept_num, ept_info->trans_buf, ept_info->total_len);
214 }
215 }
216 }
217}
218
224void usbd_ept_loop_handler(usbd_core_type *udev)
225{
226 usbd_type *usbx = udev->usb_reg;
227 usb_ept_number_type ept_num = USB_EPT0;
228 uint32_t sts_val;
229
230 while((sts_val = usbx->intsts) & USB_TC_FLAG)
231 {
232 /* get the interrupt endpoint number */
233 ept_num = (usb_ept_number_type)(sts_val & USB_EPT_NUM_FLAG);
234
235 usbd_eptn_handler(udev, ept_num);
236 }
237}
238
244void usbd_reset_handler(usbd_core_type *udev)
245{
246 /* free usb buffer */
247 usb_buffer_free();
248
249 usbd_ept_defaut_init(udev);
250#ifndef USB_EPT_AUTO_MALLOC_BUFFER
251 usbd_ept_buf_custom_define(udev, 0x80, EPT0_TX_ADDR);
252 usbd_ept_buf_custom_define(udev, 0x00, EPT0_RX_ADDR);
253#endif
254
255 /* open endpoint 0 out */
256 usbd_ept_open(udev, 0x00, EPT_CONTROL_TYPE, 0x40);
257
258 /* open endpoint 0 in */
259 usbd_ept_open(udev, 0x80, EPT_CONTROL_TYPE, 0x40);
260
261 /* set device address to 0 */
262 usb_set_address(udev->usb_reg, 0);
263
264 /* usb connect state set to default */
265 udev->conn_state = USB_CONN_STATE_DEFAULT;
266
267 /* user define reset event */
268 if(udev->class_handler->event_handler)
269 udev->class_handler->event_handler(udev, USBD_RESET_EVENT);
270}
271
277void usbd_sof_handler(usbd_core_type *udev)
278{
279 /* user sof handler in class define*/
280 if(udev->class_handler->sof_handler)
281 udev->class_handler->sof_handler(udev);
282}
283
289void usbd_suspend_handler(usbd_core_type *udev)
290{
291 /* save connect state */
292 udev->old_conn_state = udev->conn_state;
293
294 /* set current state to suspend */
295 udev->conn_state = USB_CONN_STATE_SUSPENDED;
296
297 /* enter suspend mode */
298 usbd_enter_suspend(udev);
299
300 /* user define suspend event */
301 if(udev->class_handler->event_handler)
302 udev->class_handler->event_handler(udev, USBD_SUSPEND_EVENT);
303}
304
310void usbd_wakeup_handler(usbd_core_type *udev)
311{
312 /* exit suspend mode */
313 usb_exit_suspend(udev->usb_reg);
314
315 /* restore connect state */
316 udev->conn_state = udev->old_conn_state;
317
318 /* user define wakeup event */
319 if(udev->class_handler->event_handler)
320 udev->class_handler->event_handler(udev, USBD_WAKEUP_EVENT);
321}
322
EPT0_TX_ADDR
#define EPT0_TX_ADDR
usb endpoint max num define
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:74
EPT0_RX_ADDR
#define EPT0_RX_ADDR
Definition: project/at_start_f413/examples/acc/calibration/inc/usb_conf.h:75
USB_RXTC
#define USB_RXTC
Definition: at32f413_usb.h:101
USB_SETUPTC
#define USB_SETUPTC
Definition: at32f413_usb.h:98
USB_RXDTS
#define USB_RXDTS
Definition: at32f413_usb.h:100
USB_TXTC
#define USB_TXTC
Definition: at32f413_usb.h:95
usb_ept_number_type
usb_ept_number_type
usb endpoint number define
Definition: at32f413_usb.h:181
DATA_TRANS_OUT
@ DATA_TRANS_OUT
Definition: at32f413_usb.h:223
USB_EPT0
@ USB_EPT0
Definition: at32f413_usb.h:182
EPT_CONTROL_TYPE
@ EPT_CONTROL_TYPE
Definition: at32f413_usb.h:203
usb_exit_suspend
void usb_exit_suspend(usbd_type *usbx)
usb device exit suspend mode
Definition: at32f413_usb.c:441
usb_buffer_free
void usb_buffer_free(void)
free usb endpoint buffer
Definition: at32f413_usb.c:486
usb_flag_clear
void usb_flag_clear(usbd_type *usbx, uint16_t flag)
clear flag of usb.
Definition: at32f413_usb.c:538
usb_read_packet
void usb_read_packet(uint8_t *pusr_buf, uint16_t offset_addr, uint16_t nbytes)
read data from usb buffer to user buffer
Definition: at32f413_usb.c:343
usb_set_address
void usb_set_address(usbd_type *usbx, uint8_t address)
set the host assignment address
Definition: at32f413_usb.c:398
USB_EPT_NUM_FLAG
#define USB_EPT_NUM_FLAG
Definition: at32f413_usb.h:72
USB_SOF_FLAG
#define USB_SOF_FLAG
Definition: at32f413_usb.h:75
USB_WK_FLAG
#define USB_WK_FLAG
Definition: at32f413_usb.h:78
USB_TC_FLAG
#define USB_TC_FLAG
Definition: at32f413_usb.h:81
USB_SP_FLAG
#define USB_SP_FLAG
Definition: at32f413_usb.h:77
USB_RST_FLAG
#define USB_RST_FLAG
Definition: at32f413_usb.h:76
USB_LSOF_FLAG
#define USB_LSOF_FLAG
Definition: at32f413_usb.h:74
USB_SP_INT
#define USB_SP_INT
Definition: at32f413_usb.h:57
USB_WK_INT
#define USB_WK_INT
Definition: at32f413_usb.h:58
USB_LSOF_INT
#define USB_LSOF_INT
Definition: at32f413_usb.h:54
USB_SOF_INT
#define USB_SOF_INT
Definition: at32f413_usb.h:55
USB_GET_TX_LEN
#define USB_GET_TX_LEN(eptn)
get usb endpoint tx/rx data length
Definition: at32f413_usb.h:286
USB_FREE_DB_USER_BUFFER
#define USB_FREE_DB_USER_BUFFER(eptn, inout)
free buffer used by application
Definition: at32f413_usb.h:462
USB_DBUF0_GET_LEN
#define USB_DBUF0_GET_LEN(eptn)
double buffer mode get endpoint buf0/buf1 data length
Definition: at32f413_usb.h:294
USB_CLEAR_TXTC
#define USB_CLEAR_TXTC(eptn)
clear tx/rx transfer completed flag
Definition: at32f413_usb.h:478
USB_DBUF1_GET_LEN
#define USB_DBUF1_GET_LEN(eptn)
Definition: at32f413_usb.h:295
USB_CLEAR_RXTC
#define USB_CLEAR_RXTC(eptn)
Definition: at32f413_usb.h:479
USB_GET_RX_LEN
#define USB_GET_RX_LEN(eptn)
Definition: at32f413_usb.h:287
USB_CONN_STATE_SUSPENDED
@ USB_CONN_STATE_SUSPENDED
Definition: usb_std.h:132
USB_CONN_STATE_DEFAULT
@ USB_CONN_STATE_DEFAULT
Definition: usb_std.h:129
USB_CONN_STATE_ADDRESSED
@ USB_CONN_STATE_ADDRESSED
Definition: usb_std.h:130
usbd_ept_recv
void usbd_ept_recv(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint receive data
Definition: usbd_core.c:361
usbd_core_in_handler
void usbd_core_in_handler(usbd_core_type *udev, uint8_t ept_num)
usb core in transfer complete handler
Definition: usbd_core.c:48
usbd_ept_buf_custom_define
void usbd_ept_buf_custom_define(usbd_core_type *udev, uint8_t ept_addr, uint32_t addr)
usb custom define endpoint buffer
Definition: usbd_core.c:461
usbd_ept_open
void usbd_ept_open(usbd_core_type *udev, uint8_t ept_addr, uint8_t ept_type, uint16_t maxpacket)
usb open endpoint
Definition: usbd_core.c:503
usbd_core_out_handler
void usbd_core_out_handler(usbd_core_type *udev, uint8_t ept_num)
usb core out transfer complete handler
Definition: usbd_core.c:100
usbd_ept_defaut_init
void usbd_ept_defaut_init(usbd_core_type *udev)
usb endpoint structure initialization
Definition: usbd_core.c:632
usbd_enter_suspend
void usbd_enter_suspend(usbd_core_type *udev)
usb device enter suspend mode
Definition: usbd_core.c:622
usbd_ept_send
void usbd_ept_send(usbd_core_type *udev, uint8_t ept_num, uint8_t *buffer, uint16_t len)
usb endpoint send data
Definition: usbd_core.c:301
usbd_core_setup_handler
void usbd_core_setup_handler(usbd_core_type *udev, uint8_t ept_num)
usb core setup transfer complete handler
Definition: usbd_core.c:140
USBD_SUSPEND_EVENT
@ USBD_SUSPEND_EVENT
Definition: usbd_core.h:58
USBD_RESET_EVENT
@ USBD_RESET_EVENT
Definition: usbd_core.h:57
USBD_WAKEUP_EVENT
@ USBD_WAKEUP_EVENT
Definition: usbd_core.h:59
usbd_sof_handler
void usbd_sof_handler(usbd_core_type *udev)
usb device sof interrupt request handler.
Definition: usbd_int.c:277
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
usbd_eptn_handler
void usbd_eptn_handler(usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler.
Definition: usbd_int.c:111
usbd_reset_handler
void usbd_reset_handler(usbd_core_type *udev)
usb device reset interrupt request handler.
Definition: usbd_int.c:244
usbd_wakeup_handler
void usbd_wakeup_handler(usbd_core_type *udev)
usb device wakup interrupt request handler.
Definition: usbd_int.c:310
usbd_ept_loop_handler
void usbd_ept_loop_handler(usbd_core_type *udev)
usb device endpoint loop handler.
Definition: usbd_int.c:224
usbd_suspend_handler
void usbd_suspend_handler(usbd_core_type *udev)
usb device suspend interrupt request handler.
Definition: usbd_int.c:289
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:501
usb_ept_info::total_len
uint16_t total_len
Definition: at32f413_usb.h:515
usb_ept_info::trans_len
uint16_t trans_len
Definition: at32f413_usb.h:516
usb_ept_info::rx_addr
uint16_t rx_addr
Definition: at32f413_usb.h:508
usb_ept_info::trans_buf
uint8_t * trans_buf
Definition: at32f413_usb.h:517
usb_ept_info::is_double_buffer
uint8_t is_double_buffer
Definition: at32f413_usb.h:510
usb_ept_info::tx_addr
uint16_t tx_addr
Definition: at32f413_usb.h:507
usbd_class_handler::event_handler
usb_sts_type(* event_handler)(void *udev, usbd_event_type event)
Definition: usbd_core.h:102
usbd_class_handler::sof_handler
usb_sts_type(* sof_handler)(void *udev)
Definition: usbd_core.h:101
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::conn_state
usbd_conn_state conn_state
Definition: usbd_core.h:126
usbd_core_type::setup_buffer
uint8_t setup_buffer[12]
Definition: usbd_core.h:120
usbd_core_type::old_conn_state
usbd_conn_state old_conn_state
Definition: usbd_core.h:127
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core_type::ept_in
usb_ept_info ept_in[USB_EPT_MAX_NUM]
Definition: usbd_core.h:116
usbd_core_type::device_addr
uint8_t device_addr
Definition: usbd_core.h:129
usbd_core_type::ept_out
usb_ept_info ept_out[USB_EPT_MAX_NUM]
Definition: usbd_core.h:117
usbd_core_type::usb_reg
usb_reg_type * usb_reg
Definition: usbd_core.h:111
usbd_type
type define usb register all
Definition: at32f413_usb.h:528
usbd_type::intsts
__IO uint32_t intsts
Definition: at32f413_usb.h:584
usbd_type::ept
__IO uint32_t ept[8]
Definition: at32f413_usb.h:534
usbd_type::ctrl
__IO uint32_t ctrl
Definition: at32f413_usb.h:558
usbd_int.h


AT32F413 Firmwary Library: usbd_int.h Source File

  • middlewares
  • usbd_drivers
  • inc
usbd_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_INT_H
29#define __USB_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "usbd_core.h"
38
50void usbd_irq_handler(usbd_core_type *udev);
51void usbd_ept_loop_handler(usbd_core_type *udev);
52void usbd_eptn_handler(usbd_core_type *udev, usb_ept_number_type ept_num);
53void usbd_reset_handler(usbd_core_type *udev);
54void usbd_sof_handler(usbd_core_type *udev);
55void usbd_suspend_handler(usbd_core_type *udev);
56void usbd_wakeup_handler(usbd_core_type *udev);
57
70#ifdef __cplusplus
71}
72#endif
73#endif
74
usb_ept_number_type
usb_ept_number_type
usb endpoint number define
Definition: at32f413_usb.h:181
usbd_sof_handler
void usbd_sof_handler(usbd_core_type *udev)
usb device sof interrupt request handler.
Definition: usbd_int.c:277
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
usbd_eptn_handler
void usbd_eptn_handler(usbd_core_type *udev, usb_ept_number_type ept_num)
usb device endpoint request handler.
Definition: usbd_int.c:111
usbd_reset_handler
void usbd_reset_handler(usbd_core_type *udev)
usb device reset interrupt request handler.
Definition: usbd_int.c:244
usbd_wakeup_handler
void usbd_wakeup_handler(usbd_core_type *udev)
usb device wakup interrupt request handler.
Definition: usbd_int.c:310
usbd_ept_loop_handler
void usbd_ept_loop_handler(usbd_core_type *udev)
usb device endpoint loop handler.
Definition: usbd_int.c:224
usbd_suspend_handler
void usbd_suspend_handler(usbd_core_type *udev)
usb device suspend interrupt request handler.
Definition: usbd_int.c:289
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: usbd_sdr.c Source File

  • middlewares
  • usbd_drivers
  • src
usbd_sdr.c
Go to the documentation of this file.
1
26#include "usbd_sdr.h"
27
41static usb_sts_type usbd_get_descriptor(usbd_core_type *udev);
42static usb_sts_type usbd_set_address(usbd_core_type *udev);
43static usb_sts_type usbd_get_status(usbd_core_type *udev);
44static usb_sts_type usbd_clear_feature(usbd_core_type *udev);
45static usb_sts_type usbd_set_feature(usbd_core_type *udev);
46static usb_sts_type usbd_get_configuration(usbd_core_type *udev);
47static usb_sts_type usbd_set_configuration(usbd_core_type *udev);
48
55void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf)
56{
57 setup->bmRequestType = *(uint8_t *) buf;
58 setup->bRequest = *(uint8_t *) (buf + 1);
59 setup->wValue = SWAPBYTE(buf + 2);
60 setup->wIndex = SWAPBYTE(buf + 4);
61 setup->wLength = SWAPBYTE(buf + 6);
62}
63
69static usb_sts_type usbd_get_descriptor(usbd_core_type *udev)
70{
71 usb_sts_type ret = USB_OK;
72 uint16_t len = 0;
73 usbd_desc_t *desc = NULL;
74 uint8_t desc_type = udev->setup.wValue >> 8;
75 switch(desc_type)
76 {
77 case USB_DESCIPTOR_TYPE_DEVICE:
78 desc = udev->desc_handler->get_device_descriptor();
79 break;
80 case USB_DESCIPTOR_TYPE_CONFIGURATION:
81 desc = udev->desc_handler->get_device_configuration();
82 break;
83 case USB_DESCIPTOR_TYPE_STRING:
84 {
85 uint8_t str_desc = (uint8_t)udev->setup.wValue;
86 switch(str_desc)
87 {
88 case USB_LANGID_STRING:
89 desc = udev->desc_handler->get_device_lang_id();
90 break;
91 case USB_MFC_STRING:
92 desc = udev->desc_handler->get_device_manufacturer_string();
93 break;
94 case USB_PRODUCT_STRING:
95 desc = udev->desc_handler->get_device_product_string();
96 break;
97 case USB_SERIAL_STRING:
98 desc = udev->desc_handler->get_device_serial_string();
99 break;
100 case USB_CONFIG_STRING:
101 desc = udev->desc_handler->get_device_config_string();
102 break;
103 case USB_INTERFACE_STRING:
104 desc = udev->desc_handler->get_device_interface_string();
105 break;
106 default:
107 udev->class_handler->setup_handler(udev, &udev->setup);
108 return ret;
109 }
110 break;
111 }
112 case USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER:
113 usbd_ctrl_unsupport(udev);
114 break;
115 case USB_DESCIPTOR_TYPE_OTHER_SPEED:
116 usbd_ctrl_unsupport(udev);
117 return ret;
118 default:
119 usbd_ctrl_unsupport(udev);
120 return ret;
121 }
122
123 if(desc != NULL)
124 {
125 if((desc->length != 0) && (udev->setup.wLength != 0))
126 {
127 len = MIN(desc->length , udev->setup.wLength);
128 usbd_ctrl_send(udev, desc->descriptor, len);
129 }
130 }
131 return ret;
132}
133
139static usb_sts_type usbd_set_address(usbd_core_type *udev)
140{
141 usb_sts_type ret = USB_OK;
142 usb_setup_type *setup = &udev->setup;
143 uint8_t dev_addr;
144
145 /* if wIndex or wLength are non-zero, then the behavior of
146 the device is not specified
147 */
148 if(setup->wIndex == 0 && setup->wLength == 0)
149 {
150 dev_addr = (uint8_t)(setup->wValue) & 0x7f;
151
152 /* device behavior when this request is received
153 while the device is in the configured state is not specified.*/
154 if(udev->conn_state == USB_CONN_STATE_CONFIGURED )
155 {
156 usbd_ctrl_unsupport(udev);
157 }
158 else
159 {
160 udev->device_addr = dev_addr;
161
162 if(dev_addr != 0)
163 {
164 udev->conn_state = USB_CONN_STATE_ADDRESSED;
165 }
166 else
167 {
168 udev->conn_state = USB_CONN_STATE_DEFAULT;
169 }
170 usbd_ctrl_send_status(udev);
171 }
172 }
173 else
174 {
175 usbd_ctrl_unsupport(udev);
176 }
177 return ret;
178}
179
185static usb_sts_type usbd_get_status(usbd_core_type *udev)
186{
187 usb_sts_type ret = USB_OK;
188 switch(udev->conn_state)
189 {
190 case USB_CONN_STATE_ADDRESSED:
191 case USB_CONN_STATE_CONFIGURED:
192 if(udev->remote_wakup)
193 {
194 udev->config_status |= USB_CONF_REMOTE_WAKEUP;
195 }
196 usbd_ctrl_send(udev, (uint8_t *)(&udev->config_status), 2);
197 break;
198 default:
199 usbd_ctrl_unsupport(udev);
200 break;
201 }
202 return ret;
203}
204
210static usb_sts_type usbd_clear_feature(usbd_core_type *udev)
211{
212 usb_sts_type ret = USB_OK;
213 usb_setup_type *setup = &udev->setup;
214 switch(udev->conn_state)
215 {
216 case USB_CONN_STATE_ADDRESSED:
217 case USB_CONN_STATE_CONFIGURED:
218 if(setup->wValue == USB_FEATURE_REMOTE_WAKEUP)
219 {
220 udev->remote_wakup = 0;
221 udev->config_status &= ~USB_CONF_REMOTE_WAKEUP;
222 udev->class_handler->setup_handler(udev, &udev->setup);
223 usbd_ctrl_send_status(udev);
224 }
225 break;
226 default:
227 usbd_ctrl_unsupport(udev);
228 break;
229 }
230 return ret;
231}
232
238static usb_sts_type usbd_set_feature(usbd_core_type *udev)
239{
240 usb_sts_type ret = USB_OK;
241 usb_setup_type *setup = &udev->setup;
242 if(setup->wValue == USB_FEATURE_REMOTE_WAKEUP)
243 {
244 udev->remote_wakup = 1;
245 udev->class_handler->setup_handler(udev, &udev->setup);
246 usbd_ctrl_send_status(udev);
247 }
248 return ret;
249}
250
256static usb_sts_type usbd_get_configuration(usbd_core_type *udev)
257{
258 usb_sts_type ret = USB_OK;
259 usb_setup_type *setup = &udev->setup;
260 if(setup->wLength != 1)
261 {
262 usbd_ctrl_unsupport(udev);
263 }
264 else
265 {
266 switch(udev->conn_state)
267 {
268 case USB_CONN_STATE_ADDRESSED:
269 udev->default_config = 0;
270 usbd_ctrl_send(udev, (uint8_t *)(&udev->default_config), 1);
271 break;
272 case USB_CONN_STATE_CONFIGURED:
273 usbd_ctrl_send(udev, (uint8_t *)(&udev->dev_config), 1);
274 break;
275 default:
276 usbd_ctrl_unsupport(udev);
277 break;
278 }
279 }
280 return ret;
281}
282
288static usb_sts_type usbd_set_configuration(usbd_core_type *udev)
289{
290 usb_sts_type ret = USB_OK;
291 static uint8_t config_value;
292 usb_setup_type *setup = &udev->setup;
293 config_value = (uint8_t)setup->wValue;
294
295 if(setup->wIndex == 0 && setup->wLength == 0)
296 {
297 switch(udev->conn_state)
298 {
299 case USB_CONN_STATE_ADDRESSED:
300 if(config_value)
301 {
302 udev->dev_config = config_value;
303 udev->conn_state = USB_CONN_STATE_CONFIGURED;
304 udev->class_handler->init_handler(udev);
305 usbd_ctrl_send_status(udev);
306 }
307 else
308 {
309 usbd_ctrl_send_status(udev);
310 }
311
312 break;
313 case USB_CONN_STATE_CONFIGURED:
314 if(config_value == 0)
315 {
316 udev->conn_state = USB_CONN_STATE_ADDRESSED;
317 udev->dev_config = config_value;
318 udev->class_handler->clear_handler(udev);
319 usbd_ctrl_send_status(udev);
320 }
321 else if(config_value == udev->dev_config)
322 {
323 udev->class_handler->clear_handler(udev);
324 udev->dev_config = config_value;
325 udev->class_handler->init_handler(udev);
326 usbd_ctrl_send_status(udev);
327 }
328 else
329 {
330 usbd_ctrl_send_status(udev);
331 }
332 break;
333 default:
334 usbd_ctrl_unsupport(udev);
335 break;
336 }
337 }
338 else
339 {
340 usbd_ctrl_unsupport(udev);
341 }
342 return ret;
343}
344
350 usb_sts_type usbd_device_request(usbd_core_type *udev)
351{
352 usb_sts_type ret = USB_OK;
353 usb_setup_type *setup = &udev->setup;
354 if((setup->bmRequestType & USB_REQ_TYPE_RESERVED) != USB_REQ_TYPE_STANDARD)
355 {
356 udev->class_handler->setup_handler(udev, &udev->setup);
357 return ret;
358 }
359 switch(udev->setup.bRequest)
360 {
361 case USB_STD_REQ_GET_STATUS:
362 usbd_get_status(udev);
363 break;
364 case USB_STD_REQ_CLEAR_FEATURE:
365 usbd_clear_feature(udev);
366 break;
367 case USB_STD_REQ_SET_FEATURE:
368 usbd_set_feature(udev);
369 break;
370 case USB_STD_REQ_SET_ADDRESS:
371 usbd_set_address(udev);
372 break;
373 case USB_STD_REQ_GET_DESCRIPTOR:
374 usbd_get_descriptor(udev);
375 break;
376 case USB_STD_REQ_GET_CONFIGURATION:
377 usbd_get_configuration(udev);
378 break;
379 case USB_STD_REQ_SET_CONFIGURATION:
380 usbd_set_configuration(udev);
381 break;
382 default:
383 usbd_ctrl_unsupport(udev);
384 break;
385 }
386 return ret;
387}
388
394 usb_sts_type usbd_interface_request(usbd_core_type *udev)
395{
396 usb_sts_type ret = USB_OK;
397 usb_setup_type *setup = &udev->setup;
398 switch(udev->conn_state)
399 {
400 case USB_CONN_STATE_CONFIGURED:
401 udev->class_handler->setup_handler(udev, &udev->setup);
402 if(setup->wLength == 0)
403 {
404 usbd_ctrl_send_status(udev);
405 }
406 break;
407 default:
408 usbd_ctrl_unsupport(udev);
409 break;
410 }
411 return ret;
412}
413
419 usb_sts_type usbd_endpoint_request(usbd_core_type *udev)
420{
421 usb_sts_type ret = USB_OK;
422 usb_setup_type *setup = &udev->setup;
423 uint8_t ept_addr = LBYTE(setup->wIndex);
424 usb_ept_info *ept_info;
425
426 if((setup->bmRequestType & USB_REQ_TYPE_RESERVED) == USB_REQ_TYPE_CLASS)
427 {
428 udev->class_handler->setup_handler(udev, &udev->setup);
429 }
430 switch(setup->bRequest)
431 {
432 case USB_STD_REQ_GET_STATUS:
433 switch(udev->conn_state)
434 {
435 case USB_CONN_STATE_ADDRESSED:
436 if((ept_addr & 0x7F) != 0)
437 {
438 usbd_set_stall(udev, ept_addr);
439 }
440 break;
441 case USB_CONN_STATE_CONFIGURED:
442 {
443 if((ept_addr & 0x80) != 0)
444 {
445 ept_info = &udev->ept_in[ept_addr & 0x7F];
446 }
447 else
448 {
449 ept_info = &udev->ept_out[ept_addr & 0x7F];
450 }
451 if(ept_info->stall == 1)
452 {
453 ept_info->status = 0x0001;
454 }
455 else
456 {
457 ept_info->status = 0x0000;
458 }
459 usbd_ctrl_send(udev, (uint8_t *)(&ept_info->status), 2);
460 }
461 break;
462 default:
463 usbd_ctrl_unsupport(udev);
464 break;
465 }
466 break;
467 case USB_STD_REQ_CLEAR_FEATURE:
468 switch(udev->conn_state)
469 {
470 case USB_CONN_STATE_ADDRESSED:
471 if((ept_addr != 0x00) && (ept_addr != 0x80))
472 {
473 usbd_set_stall(udev, ept_addr);
474 }
475 break;
476 case USB_CONN_STATE_CONFIGURED:
477 if(setup->wValue == USB_FEATURE_EPT_HALT)
478 {
479 if((ept_addr & 0x7F) != 0x00 )
480 {
481 usbd_clear_stall(udev, ept_addr);
482 udev->class_handler->setup_handler(udev, &udev->setup);
483 }
484 usbd_ctrl_send_status(udev);
485 }
486 break;
487 default:
488 usbd_ctrl_unsupport(udev);
489 break;
490 }
491 break;
492 case USB_STD_REQ_SET_FEATURE:
493 switch(udev->conn_state)
494 {
495 case USB_CONN_STATE_ADDRESSED:
496 if((ept_addr != 0x00) && (ept_addr != 0x80))
497 {
498 usbd_set_stall(udev, ept_addr);
499 }
500 break;
501 case USB_CONN_STATE_CONFIGURED:
502 if(setup->wValue == USB_FEATURE_EPT_HALT)
503 {
504 if((ept_addr != 0x00) && (ept_addr != 0x80))
505 {
506 usbd_set_stall(udev, ept_addr);
507 }
508 }
509 udev->class_handler->setup_handler(udev, &udev->setup);
510 usbd_ctrl_send_status(udev);
511 break;
512 default:
513 usbd_ctrl_unsupport(udev);
514 break;
515 }
516 break;
517 default:
518 usbd_ctrl_unsupport(udev);
519 break;
520 }
521 return ret;
522}
523
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
USB_STD_REQ_CLEAR_FEATURE
#define USB_STD_REQ_CLEAR_FEATURE
Definition: usb_std.h:78
USB_DESCIPTOR_TYPE_OTHER_SPEED
#define USB_DESCIPTOR_TYPE_OTHER_SPEED
Definition: usb_std.h:98
USB_INTERFACE_STRING
#define USB_INTERFACE_STRING
Definition: usb_std.h:109
USB_STD_REQ_SET_CONFIGURATION
#define USB_STD_REQ_SET_CONFIGURATION
Definition: usb_std.h:84
USB_FEATURE_REMOTE_WAKEUP
#define USB_FEATURE_REMOTE_WAKEUP
Definition: usb_std.h:121
USB_PRODUCT_STRING
#define USB_PRODUCT_STRING
Definition: usb_std.h:106
MIN
#define MIN(a, b)
min and max define
Definition: usb_std.h:254
USB_REQ_TYPE_STANDARD
#define USB_REQ_TYPE_STANDARD
usb request type
Definition: usb_std.h:63
USB_DESCIPTOR_TYPE_CONFIGURATION
#define USB_DESCIPTOR_TYPE_CONFIGURATION
Definition: usb_std.h:93
USB_STD_REQ_GET_DESCRIPTOR
#define USB_STD_REQ_GET_DESCRIPTOR
Definition: usb_std.h:81
USB_STD_REQ_SET_ADDRESS
#define USB_STD_REQ_SET_ADDRESS
Definition: usb_std.h:80
LBYTE
#define LBYTE(x)
low byte and high byte define
Definition: usb_std.h:260
USB_STD_REQ_SET_FEATURE
#define USB_STD_REQ_SET_FEATURE
Definition: usb_std.h:79
USB_CONF_REMOTE_WAKEUP
#define USB_CONF_REMOTE_WAKEUP
usb configuration attributes
Definition: usb_std.h:114
SWAPBYTE
#define SWAPBYTE(addr)
usb swap address
Definition: usb_std.h:247
USB_MFC_STRING
#define USB_MFC_STRING
Definition: usb_std.h:105
USB_STD_REQ_GET_STATUS
#define USB_STD_REQ_GET_STATUS
usb standard device requests codes
Definition: usb_std.h:77
USB_SERIAL_STRING
#define USB_SERIAL_STRING
Definition: usb_std.h:107
USB_DESCIPTOR_TYPE_DEVICE
#define USB_DESCIPTOR_TYPE_DEVICE
usb standard device type
Definition: usb_std.h:92
USB_FEATURE_EPT_HALT
#define USB_FEATURE_EPT_HALT
usb standard feature selectors
Definition: usb_std.h:120
USB_STD_REQ_GET_CONFIGURATION
#define USB_STD_REQ_GET_CONFIGURATION
Definition: usb_std.h:83
USB_DESCIPTOR_TYPE_STRING
#define USB_DESCIPTOR_TYPE_STRING
Definition: usb_std.h:94
USB_REQ_TYPE_RESERVED
#define USB_REQ_TYPE_RESERVED
Definition: usb_std.h:66
USB_LANGID_STRING
#define USB_LANGID_STRING
usb standard string type
Definition: usb_std.h:104
USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER
#define USB_DESCIPTOR_TYPE_DEVICE_QUALIFIER
Definition: usb_std.h:97
USB_CONFIG_STRING
#define USB_CONFIG_STRING
Definition: usb_std.h:108
USB_REQ_TYPE_CLASS
#define USB_REQ_TYPE_CLASS
Definition: usb_std.h:64
USB_CONN_STATE_DEFAULT
@ USB_CONN_STATE_DEFAULT
Definition: usb_std.h:129
USB_CONN_STATE_CONFIGURED
@ USB_CONN_STATE_CONFIGURED
Definition: usb_std.h:131
USB_CONN_STATE_ADDRESSED
@ USB_CONN_STATE_ADDRESSED
Definition: usb_std.h:130
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
usbd_set_stall
void usbd_set_stall(usbd_core_type *udev, uint8_t ept_addr)
usb set endpoint to stall.
Definition: usbd_core.c:261
usbd_ctrl_send_status
void usbd_ctrl_send_status(usbd_core_type *udev)
usb control endpoint send in status
Definition: usbd_core.c:211
usbd_ctrl_send
void usbd_ctrl_send(usbd_core_type *udev, uint8_t *buffer, uint16_t len)
usb control endpoint send data
Definition: usbd_core.c:176
usbd_clear_stall
void usbd_clear_stall(usbd_core_type *udev, uint8_t ept_addr)
clear endpoint stall
Definition: usbd_core.c:236
usbd_ctrl_unsupport
void usbd_ctrl_unsupport(usbd_core_type *udev)
un-support device request
Definition: usbd_core.c:286
usbd_set_feature
static usb_sts_type usbd_set_feature(usbd_core_type *udev)
set usb feature request
Definition: usbd_sdr.c:238
usbd_endpoint_request
usb_sts_type usbd_endpoint_request(usbd_core_type *udev)
standard usb endpoint requests
Definition: usbd_sdr.c:419
usbd_get_status
static usb_sts_type usbd_get_status(usbd_core_type *udev)
get usb status request
Definition: usbd_sdr.c:185
usbd_get_configuration
static usb_sts_type usbd_get_configuration(usbd_core_type *udev)
get usb configuration request
Definition: usbd_sdr.c:256
usbd_get_descriptor
static usb_sts_type usbd_get_descriptor(usbd_core_type *udev)
get usb standard device description request
Definition: usbd_sdr.c:69
usbd_setup_request_parse
void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request
Definition: usbd_sdr.c:55
usbd_device_request
usb_sts_type usbd_device_request(usbd_core_type *udev)
standard usb device requests
Definition: usbd_sdr.c:350
usbd_set_address
static usb_sts_type usbd_set_address(usbd_core_type *udev)
this request sets the device address
Definition: usbd_sdr.c:139
usbd_interface_request
usb_sts_type usbd_interface_request(usbd_core_type *udev)
standard usb interface requests
Definition: usbd_sdr.c:394
usbd_set_configuration
static usb_sts_type usbd_set_configuration(usbd_core_type *udev)
sets the usb device configuration request
Definition: usbd_sdr.c:288
usbd_clear_feature
static usb_sts_type usbd_clear_feature(usbd_core_type *udev)
clear usb feature request
Definition: usbd_sdr.c:210
usb_ept_info
usb endpoint infomation structure definition
Definition: at32f413_usb.h:501
usb_ept_info::stall
uint8_t stall
Definition: at32f413_usb.h:511
usb_ept_info::status
uint16_t status
Definition: at32f413_usb.h:512
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usb_setup_type::wValue
uint16_t wValue
Definition: usb_std.h:290
usb_setup_type::wLength
uint16_t wLength
Definition: usb_std.h:293
usb_setup_type::bmRequestType
uint8_t bmRequestType
Definition: usb_std.h:288
usb_setup_type::wIndex
uint16_t wIndex
Definition: usb_std.h:291
usb_setup_type::bRequest
uint8_t bRequest
Definition: usb_std.h:289
usbd_class_handler::init_handler
usb_sts_type(* init_handler)(void *udev)
Definition: usbd_core.h:94
usbd_class_handler::clear_handler
usb_sts_type(* clear_handler)(void *udev)
Definition: usbd_core.h:95
usbd_class_handler::setup_handler
usb_sts_type(* setup_handler)(void *udev, usb_setup_type *setup)
Definition: usbd_core.h:96
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core_type::conn_state
usbd_conn_state conn_state
Definition: usbd_core.h:126
usbd_core_type::default_config
uint8_t default_config
Definition: usbd_core.h:131
usbd_core_type::remote_wakup
uint8_t remote_wakup
Definition: usbd_core.h:130
usbd_core_type::class_handler
usbd_class_handler * class_handler
Definition: usbd_core.h:113
usbd_core_type::ept_in
usb_ept_info ept_in[USB_EPT_MAX_NUM]
Definition: usbd_core.h:116
usbd_core_type::config_status
uint16_t config_status
Definition: usbd_core.h:133
usbd_core_type::dev_config
uint8_t dev_config
Definition: usbd_core.h:132
usbd_core_type::device_addr
uint8_t device_addr
Definition: usbd_core.h:129
usbd_core_type::ept_out
usb_ept_info ept_out[USB_EPT_MAX_NUM]
Definition: usbd_core.h:117
usbd_core_type::setup
usb_setup_type setup
Definition: usbd_core.h:119
usbd_core_type::desc_handler
usbd_desc_handler * desc_handler
Definition: usbd_core.h:114
usbd_desc_handler::get_device_config_string
usbd_desc_t *(* get_device_config_string)(void)
Definition: usbd_core.h:86
usbd_desc_handler::get_device_descriptor
usbd_desc_t *(* get_device_descriptor)(void)
Definition: usbd_core.h:77
usbd_desc_handler::get_device_configuration
usbd_desc_t *(* get_device_configuration)(void)
Definition: usbd_core.h:79
usbd_desc_handler::get_device_interface_string
usbd_desc_t *(* get_device_interface_string)(void)
Definition: usbd_core.h:85
usbd_desc_handler::get_device_lang_id
usbd_desc_t *(* get_device_lang_id)(void)
Definition: usbd_core.h:81
usbd_desc_handler::get_device_manufacturer_string
usbd_desc_t *(* get_device_manufacturer_string)(void)
Definition: usbd_core.h:82
usbd_desc_handler::get_device_product_string
usbd_desc_t *(* get_device_product_string)(void)
Definition: usbd_core.h:83
usbd_desc_handler::get_device_serial_string
usbd_desc_t *(* get_device_serial_string)(void)
Definition: usbd_core.h:84
usbd_desc_t
usb device descriptor struct
Definition: usbd_core.h:67
usbd_desc_t::length
uint16_t length
Definition: usbd_core.h:68
usbd_desc_t::descriptor
uint8_t * descriptor
Definition: usbd_core.h:69
usbd_sdr.h
usb standard request header file


AT32F413 Firmwary Library: usbd_sdr.h Source File

  • middlewares
  • usbd_drivers
  • inc
usbd_sdr.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USBD_SDR_H
29#define __USBD_SDR_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35
36/* includes ------------------------------------------------------------------*/
37#include "usbd_core.h"
38
51void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf);
52 usb_sts_type usbd_device_request(usbd_core_type *udev);
53 usb_sts_type usbd_interface_request(usbd_core_type *udev);
54 usb_sts_type usbd_endpoint_request(usbd_core_type *udev);
55
56
69#ifdef __cplusplus
70}
71#endif
72
73#endif
74
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
usbd_endpoint_request
usb_sts_type usbd_endpoint_request(usbd_core_type *udev)
standard usb endpoint requests
Definition: usbd_sdr.c:419
usbd_setup_request_parse
void usbd_setup_request_parse(usb_setup_type *setup, uint8_t *buf)
usb parse standard setup request
Definition: usbd_sdr.c:55
usbd_device_request
usb_sts_type usbd_device_request(usbd_core_type *udev)
standard usb device requests
Definition: usbd_sdr.c:350
usbd_interface_request
usb_sts_type usbd_interface_request(usbd_core_type *udev)
standard usb interface requests
Definition: usbd_sdr.c:394
usb_setup_type
format of usb setup data
Definition: usb_std.h:287
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_freertos_demo
  • inc
utilities/at32f413_freertos_demo/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_freertos_demo
  • inc
utilities/at32f413_freertos_demo/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_freertos_demo
  • inc
utilities/at32f413_freertos_demo/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_freertos_demo
  • src
utilities/at32f413_freertos_demo/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_freertos_demo/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_freertos_demo
  • src
utilities/at32f413_freertos_demo/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104//void SVC_Handler(void)
105//{
106//}
107
113void DebugMon_Handler(void)
114{
115}
116
122//void PendSV_Handler(void)
123//{
124//}
125
131//void SysTick_Handler(void)
132//{
133//}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:65
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:78
DebugMon_Handler
void DebugMon_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_freertos_demo/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_freertos_demo
  • src
utilities/at32f413_freertos_demo/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "FreeRTOS.h"
30#include "task.h"
31
39TaskHandle_t led2_handler;
40TaskHandle_t led3_handler;
41
42/* led2 task */
43void led2_task_function(void *pvParameters);
44/* led3 task */
45void led3_task_function(void *pvParameters);
46
52int main(void)
53{
54 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
55
56 system_clock_config();
57
58 /* init led2 and led3 */
59 at32_led_init(LED2);
60 at32_led_init(LED3);
61
62 /* init usart1 */
63 uart_print_init(115200);
64
65 /* enter critical */
66 taskENTER_CRITICAL();
67
68 /* create led2 task */
69 if(xTaskCreate((TaskFunction_t )led2_task_function,
70 (const char* )"LED2_task",
71 (uint16_t )512,
72 (void* )NULL,
73 (UBaseType_t )2,
74 (TaskHandle_t* )&led2_handler) != pdPASS)
75 {
76 printf("LED2 task could not be created as there was insufficient heap memory remaining.\r\n");
77 }
78 else
79 {
80 printf("LED2 task was created successfully.\r\n");
81 }
82 /* create led3 task */
83 if(xTaskCreate((TaskFunction_t )led3_task_function,
84 (const char* )"LED3_task",
85 (uint16_t )512,
86 (void* )NULL,
87 (UBaseType_t )2,
88 (TaskHandle_t* )&led3_handler) != pdPASS)
89 {
90 printf("LED3 task could not be created as there was insufficient heap memory remaining.\r\n");
91 }
92 else
93 {
94 printf("LED3 task was created successfully.\r\n");
95 }
96
97 /* exit critical */
98 taskEXIT_CRITICAL();
99
100 /* start scheduler */
101 vTaskStartScheduler();
102}
103
104/* led2 task function */
105void led2_task_function(void *pvParameters)
106{
107 while(1)
108 {
109 at32_led_toggle(LED2);
110 vTaskDelay(1000);
111 }
112}
113
114/* led3 task function */
115void led3_task_function(void *pvParameters)
116{
117 while(1)
118 {
119 at32_led_toggle(LED3);
120 vTaskDelay(500);
121 }
122}
123
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
at32_led_init
void at32_led_init(led_type led)
configure led gpio
Definition: at32f413_board.c:216
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
led2_task_function
void led2_task_function(void *pvParameters)
Definition: utilities/at32f413_freertos_demo/src/main.c:105
main
int main(void)
main function.
Definition: utilities/at32f413_freertos_demo/src/main.c:52
led3_task_function
void led3_task_function(void *pvParameters)
Definition: utilities/at32f413_freertos_demo/src/main.c:115
led3_handler
TaskHandle_t led3_handler
Definition: utilities/at32f413_freertos_demo/src/main.c:40
led2_handler
TaskHandle_t led2_handler
Definition: utilities/at32f413_freertos_demo/src/main.c:39
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_gen_random_number_demo
  • inc
utilities/at32f413_gen_random_number_demo/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_gen_random_number_demo
  • inc
utilities/at32f413_gen_random_number_demo/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_gen_random_number_demo
  • inc
utilities/at32f413_gen_random_number_demo/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_gen_random_number_demo
  • src
utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_gen_random_number_demo
  • src
utilities/at32f413_gen_random_number_demo/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_gen_random_number_demo/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_gen_random_number_demo
  • src
utilities/at32f413_gen_random_number_demo/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "stdio.h"
30#include "random.h"
31
45int main(void)
46{
47 system_clock_config();
48
49 at32_board_init();
50 uart_print_init(115200);
51 printf("gen random number test\r\n");
52 randnum_test();
53 while(1)
54 {
55 }
56}
57
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
uart_print_init
void uart_print_init(uint32_t baudrate)
initialize uart
Definition: at32f413_board.c:107
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
randnum_test
void randnum_test(void)
enable rtc as seed
Definition: random.c:122
main
int main(void)
main function.
Definition: utilities/at32f413_gen_random_number_demo/src/main.c:45
random.h
at32f413 random header file
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
utilities/at32f413_slib_demo/project_l0/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
utilities/at32f413_slib_demo/project_l0/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • inc
utilities/at32f413_slib_demo/project_l0/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while (1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while (1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while (1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while (1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void FLASH_IRQHandler(void)
142{
143 if(flash_flag_get(FLASH_EPPERR_FLAG))
144 {
145 flash_flag_clear(FLASH_EPPERR_FLAG);
146 delay_ms(500);
147 }
148}
149
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:59
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:98
FLASH_EPPERR_FLAG
#define FLASH_EPPERR_FLAG
Definition: at32f413_flash.h:80
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:114
FLASH_IRQHandler
void FLASH_IRQHandler(void)
flash handler.
Definition: utilities/at32f413_slib_demo/project_l0/src/at32f413_int.c:141
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l0
  • src
utilities/at32f413_slib_demo/project_l0/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30#include "math_helper.h"
31#include "fir_filter.h"
32
33extern float32_t testInput_f32_1kHz_15kHz[];
34extern float32_t refOutput[];
35
44#define USE_SLIB_FUNCTION /* define it when user want to activate slib in this project */
45
46#if defined (USE_SLIB_FUNCTION)
47#define FLASH_START_ADDR 0x08000000
48#define TEST_SLIB_PSW 0x55665566
49#define SLIB_START_ADDR 0x08001000
50#define SLIB_DATA_ADDR 0x08002000
51#define SLIB_END_ADDR 0x08002800
52#define FLASH_SECTOR_SIZE 0x800
53#define SECTOR_NUM(dwAddr) ((dwAddr & (FLASH_START_ADDR - 1)) / FLASH_SECTOR_SIZE)
54#define SECTOR_WORD_CNT (FLASH_SECTOR_SIZE >> 2) /* words per sector */
55#endif
56#define SNR_THRESHOLD_F32 140.0f
57#define TEST_LENGTH_SAMPLES 320
58
59#if defined (USE_SLIB_FUNCTION)
60uint32_t dw_start_sector, dw_data_start_sector, dw_end_sector;
61uint32_t temp_buf[512]; /* 2kb buffer */
62#endif
63
64static float32_t testOutput[TEST_LENGTH_SAMPLES];
65
66#if defined (USE_SLIB_FUNCTION)
67 flash_status_type slib_enable(void);
68#endif
69void config_flash_interrupt(void);
70
76void config_flash_interrupt(void)
77{
78 flash_unlock();
79 flash_interrupt_enable(FLASH_ERR_INT, TRUE);
80 flash_lock();
81 /* config nvic priority group */
82 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
83
84 nvic_irq_enable(FLASH_IRQn, 0, 0);
85}
86
87#if defined (USE_SLIB_FUNCTION)
93 flash_status_type slib_enable(void)
94{
95 uint32_t *ptr;
96 uint32_t i, j;
97 flash_status_type status = FLASH_OPERATE_DONE;
98 ptr = (uint32_t *)SLIB_START_ADDR;
99 dw_start_sector = SECTOR_NUM(SLIB_START_ADDR); /* slib start sector */
100 dw_data_start_sector = SECTOR_NUM(SLIB_DATA_ADDR); /* slib data sector */
101 dw_end_sector = SECTOR_NUM(SLIB_END_ADDR); /* slib end sector */
102 flash_unlock();
103 status = flash_slib_enable(TEST_SLIB_PSW, dw_start_sector, dw_data_start_sector, dw_end_sector);
104 if(status != FLASH_OPERATE_DONE)
105 return status;
106 for(i = 0; i <= (dw_end_sector - dw_start_sector); i++)
107 {
108 memcpy(temp_buf, ptr, FLASH_SECTOR_SIZE);
109 status = flash_sector_erase(SLIB_START_ADDR + i * FLASH_SECTOR_SIZE);
110 if(status != FLASH_OPERATE_DONE)
111 return status;
112 for(j = 0; j < (FLASH_SECTOR_SIZE >> 2); j++)
113 {
114 status = flash_word_program(SLIB_START_ADDR + i * FLASH_SECTOR_SIZE + (j << 2), temp_buf[j]);
115 if(status != FLASH_OPERATE_DONE)
116 return status;
117 }
118 ptr += SECTOR_WORD_CNT;
119 }
120 return status;
121}
122#endif
123
129int main(void)
130{
131 arm_status status;
132 float32_t *inputf32, *outputf32, snr;
133
134 system_clock_config();
135 at32_board_init();
136
137 /* initialize input and output buffer pointers */
138 inputf32 = &testInput_f32_1kHz_15kHz[0];
139 outputf32 = &testOutput[0];
140
141 /* configure flash to generate an interrupt when a write protect error occur */
142 config_flash_interrupt();
143
144 /* wait for key button to be pushed, then turn off led3 */
145 while(at32_button_press() == NO_BUTTON)
146 {
147 at32_led_toggle(LED3);
148 delay_ms(100);
149 }
150 at32_led_off(LED3);
151
152 /* call the fir low pass filter function */
153 FIR_lowpass_filter(inputf32, outputf32, TEST_LENGTH_SAMPLES);
154
155 /* compare the generated output against the reference output computed in matlab. */
156 snr = arm_snr_f32(&refOutput[0], &testOutput[0], TEST_LENGTH_SAMPLES);
157 if(snr < SNR_THRESHOLD_F32)
158 {
159 status = ARM_MATH_TEST_FAILURE;
160 }
161 else
162 {
163 status = ARM_MATH_SUCCESS;
164#if defined (USE_SLIB_FUNCTION)
165 /* enable slib protection from sector 2 to sector 5 when fir filter ip-code is tested ok */
166 if(flash_slib_state_get() == RESET)
167 {
168 /* if slib has not been enabled, set slib configuration */
169 if(slib_enable() == FLASH_OPERATE_DONE)
170 {
171 /* if slib configuration is correctly set, tuen on green led4 */
172 at32_led_on(LED4);
173 delay_sec(3);
174
175 /* execute system reset to activate slib protection */
176 nvic_system_reset();
177 }
178 else
179 {
180 /* turn on red led2 if slib activation failed */
181 at32_led_on(LED2);
182 while(1);
183 }
184 }
185#endif
186 }
187
188 /* infinite loop */
189 while(1)
190 {
191 if(status == ARM_MATH_TEST_FAILURE)
192 {
193 /* toggle red led2 if fir function failed */
194 at32_led_toggle(LED2);
195 delay_ms(500);
196 }
197 else
198 {
199 /* toggle green led4 if fir function success */
200 at32_led_toggle(LED4);
201 delay_ms(500);
202 }
203 }
204}
205
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:95
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
at32_led_on
void at32_led_on(led_type led)
turns selected led on.
Definition: at32f413_board.c:244
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_sec
void delay_sec(uint16_t sec)
inserts a delay time.
Definition: at32f413_board.c:356
FLASH_IRQn
@ FLASH_IRQn
Definition: at32f413.h:137
TRUE
@ TRUE
Definition: at32f413.h:259
RESET
@ RESET
Definition: at32f413.h:254
flash_slib_state_get
flag_status flash_slib_state_get(void)
get the slib state.
Definition: at32f413_flash.c:891
flash_slib_enable
flash_status_type flash_slib_enable(uint32_t pwd, uint16_t start_sector, uint16_t data_start_sector, uint16_t end_sector)
enable security library function.
Definition: at32f413_flash.c:824
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f413_flash.c:781
flash_word_program
flash_status_type flash_word_program(uint32_t address, uint32_t data)
program a word at a specified address.
Definition: at32f413_flash.c:438
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
flash_status_type
flash_status_type
flash status type
Definition: at32f413_flash.h:159
FLASH_OPERATE_DONE
@ FLASH_OPERATE_DONE
Definition: at32f413_flash.h:163
FLASH_ERR_INT
#define FLASH_ERR_INT
Definition: at32f413_flash.h:96
nvic_system_reset
void nvic_system_reset(void)
system reset
Definition: at32f413_misc.c:52
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
SECTOR_NUM
#define SECTOR_NUM(dwAddr)
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:53
testOutput
static float32_t testOutput[320]
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:64
SECTOR_WORD_CNT
#define SECTOR_WORD_CNT
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:54
config_flash_interrupt
void config_flash_interrupt(void)
config flash error interrupt.
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:76
SLIB_DATA_ADDR
#define SLIB_DATA_ADDR
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:50
dw_end_sector
uint32_t dw_end_sector
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:60
SLIB_END_ADDR
#define SLIB_END_ADDR
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:51
dw_start_sector
uint32_t dw_start_sector
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:60
main
int main(void)
main function.
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:129
TEST_LENGTH_SAMPLES
#define TEST_LENGTH_SAMPLES
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:57
temp_buf
uint32_t temp_buf[512]
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:61
SLIB_START_ADDR
#define SLIB_START_ADDR
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:49
dw_data_start_sector
uint32_t dw_data_start_sector
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:60
slib_enable
flash_status_type slib_enable(void)
config slib enable and program slib area.
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:93
FLASH_SECTOR_SIZE
#define FLASH_SECTOR_SIZE
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:52
TEST_SLIB_PSW
#define TEST_SLIB_PSW
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:48
SNR_THRESHOLD_F32
#define SNR_THRESHOLD_F32
Definition: utilities/at32f413_slib_demo/project_l0/src/main.c:56
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61
testInput_f32_1kHz_15kHz
float32_t testInput_f32_1kHz_15kHz[]
Definition: project_l0/src/arm_fir_data.c:48
refOutput
float32_t refOutput[]
Definition: project_l0/src/arm_fir_data.c:96
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
utilities/at32f413_slib_demo/project_l1/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
utilities/at32f413_slib_demo/project_l1/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • inc
utilities/at32f413_slib_demo/project_l1/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29#include "at32f413_board.h"
30
44void NMI_Handler(void)
45{
46}
47
53void HardFault_Handler(void)
54{
55 /* go to infinite loop when hard fault exception occurs */
56 while (1)
57 {
58 }
59}
60
66void MemManage_Handler(void)
67{
68 /* go to infinite loop when memory manage exception occurs */
69 while (1)
70 {
71 }
72}
73
79void BusFault_Handler(void)
80{
81 /* go to infinite loop when bus fault exception occurs */
82 while (1)
83 {
84 }
85}
86
92void UsageFault_Handler(void)
93{
94 /* go to infinite loop when usage fault exception occurs */
95 while (1)
96 {
97 }
98}
99
105void SVC_Handler(void)
106{
107}
108
114void DebugMon_Handler(void)
115{
116}
117
123void PendSV_Handler(void)
124{
125}
126
132void SysTick_Handler(void)
133{
134}
135
141void FLASH_IRQHandler(void)
142{
143 if(flash_flag_get(FLASH_EPPERR_FLAG))
144 {
145 flash_flag_clear(FLASH_EPPERR_FLAG);
146 delay_ms(500);
147 }
148}
149
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
flash_flag_get
flag_status flash_flag_get(uint32_t flash_flag)
check whether the specified flash flag is set or not.
Definition: at32f413_flash.c:59
flash_flag_clear
void flash_flag_clear(uint32_t flash_flag)
clear the flash flag.
Definition: at32f413_flash.c:98
FLASH_EPPERR_FLAG
#define FLASH_EPPERR_FLAG
Definition: at32f413_flash.h:80
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:114
FLASH_IRQHandler
void FLASH_IRQHandler(void)
flash handler.
Definition: utilities/at32f413_slib_demo/project_l1/src/at32f413_int.c:141
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_slib_demo
  • project_l1
  • src
utilities/at32f413_slib_demo/project_l1/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include <stdio.h>
30#include "math_helper.h"
31#include "fir_filter.h"
32
33extern float32_t testInput_f32_1kHz_15kHz[];
34extern float32_t refOutput[];
35
44#define SNR_THRESHOLD_F32 140.0f
45#define TEST_LENGTH_SAMPLES 320
46
47static float32_t testOutput[TEST_LENGTH_SAMPLES];
48
49void config_flash_interrupt(void);
50
56void config_flash_interrupt(void)
57{
58 flash_unlock();
59 flash_interrupt_enable(FLASH_ERR_INT, TRUE);
60 flash_lock();
61 /* config nvic priority group */
62 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
63
64 nvic_irq_enable(FLASH_IRQn, 0, 0);
65}
66
72int main(void)
73{
74 arm_status status;
75 float32_t *inputf32, *outputf32, snr;
76
77 system_clock_config();
78 at32_board_init();
79
80 /* initialize input and output buffer pointers */
81 inputf32 = &testInput_f32_1kHz_15kHz[0];
82 outputf32 = &testOutput[0];
83
84 /* configure flash to generate an interrupt when a write protect error occur */
85 config_flash_interrupt();
86
87 /* wait for key button to be pushed, then turn off led3 */
88 while(at32_button_press() == NO_BUTTON)
89 {
90 at32_led_toggle(LED3);
91 delay_ms(100);
92 }
93 at32_led_off(LED3);
94
95 /* call the fir low pass filter function */
96 FIR_lowpass_filter(inputf32, outputf32, TEST_LENGTH_SAMPLES);
97
98 /* compare the generated output against the reference output computed in matlab. */
99 snr = arm_snr_f32(&refOutput[0], &testOutput[0], TEST_LENGTH_SAMPLES);
100 if(snr < SNR_THRESHOLD_F32)
101 {
102 status = ARM_MATH_TEST_FAILURE;
103 }
104 else
105 {
106 status = ARM_MATH_SUCCESS;
107 }
108
109 /* infinite loop */
110 while(1)
111 {
112 if(status == ARM_MATH_TEST_FAILURE)
113 {
114 /* toggle red led2 if fir function failed */
115 at32_led_toggle(LED2);
116 delay_ms(500);
117 }
118 else
119 {
120 /* toggle green led4 if fir function success */
121 at32_led_toggle(LED4);
122 delay_ms(500);
123 }
124 }
125}
126
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
LED2
@ LED2
Definition: at32f413_board.h:63
LED4
@ LED4
Definition: at32f413_board.h:65
NO_BUTTON
@ NO_BUTTON
Definition: at32f413_board.h:95
at32_button_press
button_type at32_button_press()
returns which button have press down
Definition: at32f413_board.c:192
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_led_off
void at32_led_off(led_type led)
turns selected led off.
Definition: at32f413_board.c:261
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
FLASH_IRQn
@ FLASH_IRQn
Definition: at32f413.h:137
TRUE
@ TRUE
Definition: at32f413.h:259
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_interrupt_enable
void flash_interrupt_enable(uint32_t flash_int, confirm_state new_state)
enable or disable the specified flash interrupts.
Definition: at32f413_flash.c:781
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
FLASH_ERR_INT
#define FLASH_ERR_INT
Definition: at32f413_flash.h:96
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
testOutput
static float32_t testOutput[320]
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:47
config_flash_interrupt
void config_flash_interrupt(void)
config flash error interrupt.
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:56
main
int main(void)
main function.
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:72
TEST_LENGTH_SAMPLES
#define TEST_LENGTH_SAMPLES
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:45
SNR_THRESHOLD_F32
#define SNR_THRESHOLD_F32
Definition: utilities/at32f413_slib_demo/project_l1/src/main.c:44
FIR_lowpass_filter
void FIR_lowpass_filter(float32_t *pSrc, float32_t *pDst, uint32_t testlengthsamples)
Definition: fir_filter.c:76
arm_snr_f32
float arm_snr_f32(float *pRef, float *pTest, uint32_t buffSize)
Caluclation of SNR.
Definition: project_l0/src/math_helper.c:61
testInput_f32_1kHz_15kHz
float32_t testInput_f32_1kHz_15kHz[]
Definition: project_l0/src/arm_fir_data.c:48
refOutput
float32_t refOutput[]
Definition: project_l0/src/arm_fir_data.c:96
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "tmr.h"
30#include "usart.h"
31#include "iap.h"
32
46int main(void)
47{
48 /* config vector table offset */
49 nvic_vector_table_set(NVIC_VECTTAB_FLASH, 0x4000);
50
51 /* config nvic priority group */
52 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
53
54 system_clock_config();
55 at32_board_init();
56
57 /* check and clear iap_upgrade_flag flag */
58 iap_init();
59
60 /* init usart used for app update */
61 uart_init(115200);
62
63 /* init tmr used for show code running state(led cycle toggle) */
64 tmr_init();
65
66 while(1)
67 {
68 iap_command_handle();
69 }
70}
71
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:112
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
NVIC_VECTTAB_FLASH
#define NVIC_VECTTAB_FLASH
Definition: at32f413_misc.h:52
main
int main(void)
main function.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led3_toggle/src/main.c:46
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:44
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:44
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "tmr.h"
30#include "usart.h"
31#include "iap.h"
32
46int main(void)
47{
48 /* config vector table offset */
49 nvic_vector_table_set(NVIC_VECTTAB_FLASH, 0x4000);
50
51 /* config nvic priority group */
52 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
53
54 system_clock_config();
55 at32_board_init();
56
57 /* check and clear iap_upgrade_flag flag */
58 iap_init();
59
60 /* init usart used for app update */
61 uart_init(115200);
62
63 /* init tmr used for show code running state(led cycle toggle) */
64 tmr_init();
65
66 while(1)
67 {
68 iap_command_handle();
69 }
70}
71
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:112
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
NVIC_VECTTAB_FLASH
#define NVIC_VECTTAB_FLASH
Definition: at32f413_misc.h:52
main
int main(void)
main function.
Definition: utilities/at32f413_usart_iap_demo/source_code/app_led4_toggle/src/main.c:46
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
iap_command_handle
void iap_command_handle(void)
iap command handle handle.
Definition: app_led3_toggle/src/iap.c:44
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:44
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: flash.h Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h
Go to the documentation of this file.
1
27#ifndef __FLASH_H__
28#define __FLASH_H__
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34#include "at32f413_board.h"
35
48#define FLASH_SIZE (*((uint32_t*)0x1FFFF7E0)) /* read from at32 flash capacity register(unit:kbyte) */
49#define SRAM_SIZE 224 /* sram size, unit:kbyte */
50
59void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer);
60 flag_status flash_upgrade_flag_read(void);
61
74#ifdef __cplusplus
75}
76#endif
77
78#endif
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
flag_status
flag_status
flag status
Definition: at32f413.h:254
flash_2kb_write
void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:45
flash_upgrade_flag_read
flag_status flash_upgrade_flag_read(void)
check flash upgrade flag.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:66


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while (1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while (1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while (1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while (1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: flash.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c
Go to the documentation of this file.
1
27#include "flash.h"
28#include "usart.h"
29#include "iap.h"
30
45void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer)
46{
47 uint16_t index, write_data;
48 flash_unlock();
49 flash_sector_erase(write_addr);
50 if(FLASH_SIZE < 0x100) /* less than 256kb, 1kb/sector */
51 flash_sector_erase(write_addr + 0x400);
52 for(index = 0; index < 2048; index += 2)
53 {
54 write_data = (pbuffer[index+1] << 8) + pbuffer[index];
55 flash_halfword_program(write_addr, write_data);
56 write_addr += sizeof(uint16_t);
57 }
58 flash_lock();
59}
60
66 flag_status flash_upgrade_flag_read(void)
67{
68 if((*(uint32_t*)IAP_UPGRADE_FLAG_ADDR) == IAP_UPGRADE_FLAG)
69 return SET;
70 else
71 return RESET;
72}
73
flag_status
flag_status
flag status
Definition: at32f413.h:254
RESET
@ RESET
Definition: at32f413.h:254
SET
@ SET
Definition: at32f413.h:254
flash_sector_erase
flash_status_type flash_sector_erase(uint32_t sector_address)
erase a specified flash sector.
Definition: at32f413_flash.c:272
flash_halfword_program
flash_status_type flash_halfword_program(uint32_t address, uint16_t data)
program a halfword at a specified address.
Definition: at32f413_flash.c:485
flash_unlock
void flash_unlock(void)
unlock the flash controller.
Definition: at32f413_flash.c:229
flash_lock
void flash_lock(void)
lock the flash controller.
Definition: at32f413_flash.c:251
flash_2kb_write
void flash_2kb_write(uint32_t write_addr, uint8_t *pbuffer)
flash erase/program operation.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:45
flash_upgrade_flag_read
flag_status flash_upgrade_flag_read(void)
check flash upgrade flag.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:66
IAP_UPGRADE_FLAG_ADDR
#define IAP_UPGRADE_FLAG_ADDR
Definition: app_led3_toggle/inc/iap.h:52
IAP_UPGRADE_FLAG
#define IAP_UPGRADE_FLAG
Definition: app_led3_toggle/inc/iap.h:56
FLASH_SIZE
#define FLASH_SIZE
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/inc/flash.h:48


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usart_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "tmr.h"
30#include "usart.h"
31#include "flash.h"
32#include "iap.h"
33
47int main(void)
48{
49 system_clock_config();
50 at32_board_init();
51
52 /* config nvic priority group */
53 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
54
55 /* check iap_upgrade_flag flag */
56 if(flash_upgrade_flag_read() == RESET)
57 {
58 /* check app starting address whether 0x08xxxxxx */
59 if(((*(uint32_t*)(APP_START_ADDR + 4)) & 0xFF000000) == 0x08000000)
60 app_load(APP_START_ADDR);
61 }
62
63 /* init usart used for app update */
64 uart_init(115200);
65
66 /* check whether need to upgrade, if yes, response ok to pc-tool */
67 if(flash_upgrade_flag_read() != RESET)
68 back_ok();
69
70 /* init tmr used for show code running state(led cycle toggle) */
71 tmr_init();
72
73 while(1)
74 {
75 /* upgrade handle */
76 iap_upgrade_app_handle();
77 }
78}
79
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
uart_init
void uart_init(uint32_t baudrate)
init usart.
Definition: app_led3_toggle/src/usart.c:45
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
RESET
@ RESET
Definition: at32f413.h:254
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
main
int main(void)
main function.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/main.c:47
APP_START_ADDR
#define APP_START_ADDR
Definition: app_led3_toggle/inc/iap.h:49
tmr_init
void tmr_init(void)
init tmr.
Definition: app_led3_toggle/src/tmr.c:44
back_ok
void back_ok(void)
command response ok.
Definition: app_led3_toggle/src/usart.c:107
iap_upgrade_app_handle
void iap_upgrade_app_handle(void)
iap upgrade app handle.
Definition: bootloader/src/iap.c:344
app_load
void app_load(uint32_t appxaddr)
app load.
Definition: bootloader/src/iap.c:60
flash_upgrade_flag_read
flag_status flash_upgrade_flag_read(void)
check flash upgrade flag.
Definition: utilities/at32f413_usart_iap_demo/source_code/bootloader/src/flash.c:66
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99void usb_delay_ms(uint32_t ms);
100void usb_delay_us(uint32_t us);
101
110#ifdef __cplusplus
111}
112#endif
113
114#endif
115
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led3_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "hid_iap_class.h"
31#include "hid_iap_desc.h"
32#include "hid_iap_user.h"
33#include "usbd_int.h"
34
43 usbd_core_type usb_core_dev;
44
45void usb_clock48m_select(usb_clk48_s clk_s);
46
52void usb_clock48m_select(usb_clk48_s clk_s)
53{
54 if(clk_s == USB_CLK_HICK)
55 {
56 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
57
58 /* enable the acc calibration ready interrupt */
59 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
60
61 /* update the c1\c2\c3 value */
62 acc_write_c1(7980);
63 acc_write_c2(8000);
64 acc_write_c3(8020);
65
66 /* open acc calibration */
67 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
68 }
69 else
70 {
71 switch(system_core_clock)
72 {
73 /* 48MHz */
74 case 48000000:
75 crm_usb_clock_div_set(CRM_USB_DIV_1);
76 break;
77
78 /* 72MHz */
79 case 72000000:
80 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
81 break;
82
83 /* 96MHz */
84 case 96000000:
85 crm_usb_clock_div_set(CRM_USB_DIV_2);
86 break;
87
88 /* 120MHz */
89 case 120000000:
90 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
91 break;
92
93 /* 144MHz */
94 case 144000000:
95 crm_usb_clock_div_set(CRM_USB_DIV_3);
96 break;
97
98 /* 168MHz */
99 case 168000000:
100 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
101 break;
102
103 /* 192MHz */
104 case 192000000:
105 crm_usb_clock_div_set(CRM_USB_DIV_4);
106 break;
107
108 default:
109 break;
110
111 }
112 }
113}
114
120void USBFS_L_CAN1_RX0_IRQHandler(void)
121{
122 usbd_irq_handler(&usb_core_dev);
123}
124
130void usb_delay_ms(uint32_t ms)
131{
132 /* user can define self delay function */
133 delay_ms(ms);
134}
135
141void usb_delay_us(uint32_t us)
142{
143 delay_us(us);
144}
145
151int main(void)
152{
153 /* config vector table offset */
154 nvic_vector_table_set(NVIC_VECTTAB_FLASH, 0x4000);
155
156 system_clock_config();
157
158 /* config nvic priority group */
159 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
160
161 /* iap init */
162 iap_init();
163
164 at32_board_init();
165
166 /* select usb 48m clcok source */
167 usb_clock48m_select(USB_CLK_HEXT);
168
169 /* enable usb clock */
170 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
171
172 /* enable usb interrupt */
173 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
174
175 /* usb core init */
176 usbd_core_init(&usb_core_dev, USB, &hid_iap_class_handler, &hid_iap_desc_handler, 0);
177
178 /* enable usb pull-up */
179 usbd_connect(&usb_core_dev);
180
181 while(1)
182 {
183 app_loop();
184 at32_led_toggle(LED3);
185 delay_ms(200);
186 }
187}
188
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
LED3
@ LED3
Definition: at32f413_board.h:64
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:112
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
NVIC_VECTTAB_FLASH
#define NVIC_VECTTAB_FLASH
Definition: at32f413_misc.h:52
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:52
main
int main(void)
main function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:151
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:120
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:130
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:141
usb_core_dev
usbd_core_type usb_core_dev
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led3_toggle/src/main.c:43
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:57
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:65
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:253
hid_iap_class.h
usb hid iap header file
hid_iap_desc.h
usb hid descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • inc
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99void usb_delay_ms(uint32_t ms);
100void usb_delay_us(uint32_t us);
101
110#ifdef __cplusplus
111}
112#endif
113
114#endif
115
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • app_led4_toggle
  • src
utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "hid_iap_class.h"
31#include "hid_iap_desc.h"
32#include "hid_iap_user.h"
33#include "usbd_int.h"
34
43 usbd_core_type usb_core_dev;
44
45void usb_clock48m_select(usb_clk48_s clk_s);
46
52void usb_clock48m_select(usb_clk48_s clk_s)
53{
54 if(clk_s == USB_CLK_HICK)
55 {
56 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
57
58 /* enable the acc calibration ready interrupt */
59 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
60
61 /* update the c1\c2\c3 value */
62 acc_write_c1(7980);
63 acc_write_c2(8000);
64 acc_write_c3(8020);
65
66 /* open acc calibration */
67 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
68 }
69 else
70 {
71 switch(system_core_clock)
72 {
73 /* 48MHz */
74 case 48000000:
75 crm_usb_clock_div_set(CRM_USB_DIV_1);
76 break;
77
78 /* 72MHz */
79 case 72000000:
80 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
81 break;
82
83 /* 96MHz */
84 case 96000000:
85 crm_usb_clock_div_set(CRM_USB_DIV_2);
86 break;
87
88 /* 120MHz */
89 case 120000000:
90 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
91 break;
92
93 /* 144MHz */
94 case 144000000:
95 crm_usb_clock_div_set(CRM_USB_DIV_3);
96 break;
97
98 /* 168MHz */
99 case 168000000:
100 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
101 break;
102
103 /* 192MHz */
104 case 192000000:
105 crm_usb_clock_div_set(CRM_USB_DIV_4);
106 break;
107
108 default:
109 break;
110
111 }
112 }
113}
114
120void USBFS_L_CAN1_RX0_IRQHandler(void)
121{
122 usbd_irq_handler(&usb_core_dev);
123}
124
130void usb_delay_ms(uint32_t ms)
131{
132 /* user can define self delay function */
133 delay_ms(ms);
134}
135
141void usb_delay_us(uint32_t us)
142{
143 delay_us(us);
144}
145
151int main(void)
152{
153 /* config vector table offset */
154 nvic_vector_table_set(NVIC_VECTTAB_FLASH, 0x4000);
155
156 system_clock_config();
157
158 /* config nvic priority group */
159 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
160
161 /* iap init */
162 iap_init();
163
164 at32_board_init();
165
166 /* select usb 48m clcok source */
167 usb_clock48m_select(USB_CLK_HEXT);
168
169 /* enable usb clock */
170 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
171
172 /* enable usb interrupt */
173 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
174
175 /* usb core init */
176 usbd_core_init(&usb_core_dev, USB, &hid_iap_class_handler, &hid_iap_desc_handler, 0);
177
178 /* enable usb pull-up */
179 usbd_connect(&usb_core_dev);
180
181 while(1)
182 {
183 app_loop();
184 at32_led_toggle(LED4);
185 delay_ms(200);
186 }
187}
188
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
LED4
@ LED4
Definition: at32f413_board.h:65
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_led_toggle
void at32_led_toggle(led_type led)
turns selected led toggle.
Definition: at32f413_board.c:278
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_vector_table_set
void nvic_vector_table_set(uint32_t base, uint32_t offset)
set the vector table location and offset.
Definition: at32f413_misc.c:112
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
NVIC_VECTTAB_FLASH
#define NVIC_VECTTAB_FLASH
Definition: at32f413_misc.h:52
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:52
main
int main(void)
main function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:151
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:120
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:130
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:141
usb_core_dev
usbd_core_type usb_core_dev
Definition: utilities/at32f413_usb_iap_demo/source_code/app_led4_toggle/src/main.c:43
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:57
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:65
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
app_loop
void app_loop(void)
iap loop
Definition: app_led3_toggle/src/hid_iap_user.c:253
hid_iap_class.h
usb hid iap header file
hid_iap_desc.h
usb hid descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_clock.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_clock.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CLOCK_H
29#define __AT32F413_CLOCK_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported functions ------------------------------------------------------- */
39void system_clock_config(void);
40
41#ifdef __cplusplus
42}
43#endif
44
45#endif /* __AT32F413_CLOCK_H */
46
at32f413.h
at32f413 header file
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48


AT32F413 Firmwary Library: at32f413_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_CONF_H
29#define __AT32F413_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
43#if !defined HEXT_VALUE
44#define HEXT_VALUE ((uint32_t)8000000)
45#endif
46
51#define HEXT_STARTUP_TIMEOUT ((uint16_t)0x3000)
52#define HICK_VALUE ((uint32_t)8000000)
54/* module define -------------------------------------------------------------*/
55#define CRM_MODULE_ENABLED
56#define TMR_MODULE_ENABLED
57#define RTC_MODULE_ENABLED
58#define BPR_MODULE_ENABLED
59#define GPIO_MODULE_ENABLED
60#define I2C_MODULE_ENABLED
61#define USART_MODULE_ENABLED
62#define PWC_MODULE_ENABLED
63#define CAN_MODULE_ENABLED
64#define ADC_MODULE_ENABLED
65#define SPI_MODULE_ENABLED
66#define DMA_MODULE_ENABLED
67#define DEBUG_MODULE_ENABLED
68#define FLASH_MODULE_ENABLED
69#define CRC_MODULE_ENABLED
70#define WWDT_MODULE_ENABLED
71#define WDT_MODULE_ENABLED
72#define EXINT_MODULE_ENABLED
73#define SDIO_MODULE_ENABLED
74#define USB_MODULE_ENABLED
75#define ACC_MODULE_ENABLED
76#define MISC_MODULE_ENABLED
77
78/* includes ------------------------------------------------------------------*/
79#ifdef CRM_MODULE_ENABLED
80#include "at32f413_crm.h"
81#endif
82#ifdef TMR_MODULE_ENABLED
83#include "at32f413_tmr.h"
84#endif
85#ifdef RTC_MODULE_ENABLED
86#include "at32f413_rtc.h"
87#endif
88#ifdef BPR_MODULE_ENABLED
89#include "at32f413_bpr.h"
90#endif
91#ifdef GPIO_MODULE_ENABLED
92#include "at32f413_gpio.h"
93#endif
94#ifdef I2C_MODULE_ENABLED
95#include "at32f413_i2c.h"
96#endif
97#ifdef USART_MODULE_ENABLED
98#include "at32f413_usart.h"
99#endif
100#ifdef PWC_MODULE_ENABLED
101#include "at32f413_pwc.h"
102#endif
103#ifdef CAN_MODULE_ENABLED
104#include "at32f413_can.h"
105#endif
106#ifdef ADC_MODULE_ENABLED
107#include "at32f413_adc.h"
108#endif
109#ifdef SPI_MODULE_ENABLED
110#include "at32f413_spi.h"
111#endif
112#ifdef DMA_MODULE_ENABLED
113#include "at32f413_dma.h"
114#endif
115#ifdef DEBUG_MODULE_ENABLED
116#include "at32f413_debug.h"
117#endif
118#ifdef FLASH_MODULE_ENABLED
119#include "at32f413_flash.h"
120#endif
121#ifdef CRC_MODULE_ENABLED
122#include "at32f413_crc.h"
123#endif
124#ifdef WWDT_MODULE_ENABLED
125#include "at32f413_wwdt.h"
126#endif
127#ifdef WDT_MODULE_ENABLED
128#include "at32f413_wdt.h"
129#endif
130#ifdef EXINT_MODULE_ENABLED
131#include "at32f413_exint.h"
132#endif
133#ifdef SDIO_MODULE_ENABLED
134#include "at32f413_sdio.h"
135#endif
136#ifdef ACC_MODULE_ENABLED
137#include "at32f413_acc.h"
138#endif
139#ifdef MISC_MODULE_ENABLED
140#include "at32f413_misc.h"
141#endif
142#ifdef USB_MODULE_ENABLED
143#include "at32f413_usb.h"
144#endif
145
154#ifdef __cplusplus
155}
156#endif
157
158#endif
at32f413_acc.h
at32f413 acc header file
at32f413_adc.h
at32f413 adc header file
at32f413_bpr.h
at32f413 bpr header file
at32f413_can.h
at32f413 can header file
at32f413_crc.h
at32f413 crc header file
at32f413_crm.h
at32f413 crm header file
at32f413_debug.h
at32f413 debug header file
at32f413_dma.h
at32f413 dma header file
at32f413_exint.h
at32f413 exint header file
at32f413_flash.h
at32f413 flash header file
at32f413_gpio.h
at32f413 gpio header file
at32f413_i2c.h
at32f413 i2c header file
at32f413_misc.h
at32f413 misc header file
at32f413_pwc.h
at32f413 pwc header file
at32f413_rtc.h
at32f413 rtc header file
at32f413_sdio.h
at32f413 sdio header file
at32f413_spi.h
at32f413 spi header file
at32f413_tmr.h
at32f413 tmr header file
at32f413_usart.h
at32f413 usart header file
at32f413_usb.h
at32f413 usb header file
at32f413_wdt.h
at32f413 wdt header file
at32f413_wwdt.h
at32f413 wwdt header file


AT32F413 Firmwary Library: at32f413_int.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/at32f413_int.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __AT32F413_INT_H
29#define __AT32F413_INT_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35/* includes ------------------------------------------------------------------*/
36#include "at32f413.h"
37
38/* exported types ------------------------------------------------------------*/
39/* exported constants --------------------------------------------------------*/
40/* exported macro ------------------------------------------------------------*/
41/* exported functions ------------------------------------------------------- */
42
43void NMI_Handler(void);
44void HardFault_Handler(void);
45void MemManage_Handler(void);
46void BusFault_Handler(void);
47void UsageFault_Handler(void);
48void SVC_Handler(void);
49void DebugMon_Handler(void);
50void PendSV_Handler(void);
51void SysTick_Handler(void);
52
53#ifdef __cplusplus
54}
55#endif
56
57#endif
58
at32f413.h
at32f413 header file
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:92
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:53
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:66
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:105
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:123
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:44
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:79
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:132
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_int.c:114


AT32F413 Firmwary Library: usb_conf.h Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • inc
utilities/at32f413_usb_iap_demo/source_code/bootloader/inc/usb_conf.h
Go to the documentation of this file.
1
27/* define to prevent recursive inclusion -------------------------------------*/
28#ifndef __USB_CONF_H
29#define __USB_CONF_H
30
31#ifdef __cplusplus
32extern "C" {
33#endif
34
35#include "at32f413.h"
36#include "at32f413_board.h"
37#include "stdio.h"
38
50#ifndef USB_EPT_MAX_NUM
51#define USB_EPT_MAX_NUM 8
52#endif
53
57//#define USB_BUFFER_SIZE_EX /*!< usb enable extend buffer */
58
59
63#define USB_EPT_AUTO_MALLOC_BUFFER
66#ifndef USB_EPT_AUTO_MALLOC_BUFFER
72/* ept0 tx start address 0x40, size 0x40,
73 so rx start address is 0x40 + 0x40 = 0x80 */
74#define EPT0_TX_ADDR 0x40
75#define EPT0_RX_ADDR 0x80
77#define EPT1_TX_ADDR 0xC0
78#define EPT1_RX_ADDR 0x100
80#define EPT2_TX_ADDR 0x140
81#define EPT2_RX_ADDR 0x180
83#define EPT3_TX_ADDR 0x00
84#define EPT3_RX_ADDR 0x00
86#define EPT4_TX_ADDR 0x00
87#define EPT4_RX_ADDR 0x00
89#define EPT5_TX_ADDR 0x00
90#define EPT5_RX_ADDR 0x00
92#define EPT6_TX_ADDR 0x00
93#define EPT6_RX_ADDR 0x00
95#define EPT7_TX_ADDR 0x00
96#define EPT7_RX_ADDR 0x00
98#endif
99void usb_delay_ms(uint32_t ms);
100void usb_delay_us(uint32_t us);
101
110#ifdef __cplusplus
111}
112#endif
113
114#endif
115
116
at32f413.h
at32f413 header file
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:247
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: project/at_start_f413/examples/acc/calibration/src/main.c:258


AT32F413 Firmwary Library: at32f413_clock.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_clock.h"
29
48void system_clock_config(void)
49{
50 /* reset crm */
51 crm_reset();
52
53 crm_clock_source_enable(CRM_CLOCK_SOURCE_HEXT, TRUE);
54
55 /* wait till hext is ready */
56 while(crm_hext_stable_wait() == ERROR)
57 {
58 }
59
60 /* config pll clock resource */
61 crm_pll_config(CRM_PLL_SOURCE_HEXT_DIV, CRM_PLL_MULT_48, CRM_PLL_OUTPUT_RANGE_GT72MHZ);
62
63 /* enable pll */
64 crm_clock_source_enable(CRM_CLOCK_SOURCE_PLL, TRUE);
65
66 /* wait till pll is ready */
67 while(crm_flag_get(CRM_PLL_STABLE_FLAG) != SET)
68 {
69 }
70
71 /* config ahbclk */
72 crm_ahb_div_set(CRM_AHB_DIV_1);
73
74 /* config apb2clk */
75 crm_apb2_div_set(CRM_APB2_DIV_2);
76
77 /* config apb1clk */
78 crm_apb1_div_set(CRM_APB1_DIV_2);
79
80 /* enable auto step mode */
81 crm_auto_step_mode_enable(TRUE);
82
83 /* select pll as system clock source */
84 crm_sysclk_switch(CRM_SCLK_PLL);
85
86 /* wait till pll is used as system clock source */
87 while(crm_sysclk_switch_status_get() != CRM_SCLK_PLL)
88 {
89 }
90
91 /* disable auto step mode */
92 crm_auto_step_mode_enable(FALSE);
93
94 /* update system_core_clock global variable */
95 system_core_clock_update();
96}
system_clock_config
void system_clock_config(void)
system clock config program
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_clock.c:48
system_core_clock_update
void system_core_clock_update(void)
update system_core_clock variable according to clock register values. the system_core_clock variable ...
Definition: system_at32f413.c:112
crm_flag_get
flag_status crm_flag_get(uint32_t flag)
get crm flag status
Definition: at32f413_crm.c:122
crm_hext_stable_wait
error_status crm_hext_stable_wait(void)
wait for hext stable
Definition: at32f413_crm.c:141
crm_ahb_div_set
void crm_ahb_div_set(crm_ahb_div_type value)
set crm ahb division
Definition: at32f413_crm.c:406
crm_sysclk_switch_status_get
crm_sclk_type crm_sysclk_switch_status_get(void)
indicate which clock source is used as system clock
Definition: at32f413_crm.c:565
crm_clock_source_enable
void crm_clock_source_enable(crm_clock_source_type source, confirm_state new_state)
enable or disable the crm clock source
Definition: at32f413_crm.c:285
crm_apb2_div_set
void crm_apb2_div_set(crm_apb2_div_type value)
set crm apb2 division
Definition: at32f413_crm.c:438
crm_apb1_div_set
void crm_apb1_div_set(crm_apb1_div_type value)
set crm apb1 division
Definition: at32f413_crm.c:422
crm_pll_config
void crm_pll_config(crm_pll_clock_source_type clock_source, crm_pll_mult_type mult_value, crm_pll_output_range_type pll_range)
config crm pll
Definition: at32f413_crm.c:514
crm_auto_step_mode_enable
void crm_auto_step_mode_enable(confirm_state new_state)
auto step clock switch enable
Definition: at32f413_crm.c:714
crm_reset
void crm_reset(void)
reset the crm register
Definition: at32f413_crm.c:49
crm_sysclk_switch
void crm_sysclk_switch(crm_sclk_type value)
select system clock source
Definition: at32f413_crm.c:551
CRM_APB1_DIV_2
@ CRM_APB1_DIV_2
Definition: at32f413_crm.h:323
CRM_CLOCK_SOURCE_PLL
@ CRM_CLOCK_SOURCE_PLL
Definition: at32f413_crm.h:296
CRM_CLOCK_SOURCE_HEXT
@ CRM_CLOCK_SOURCE_HEXT
Definition: at32f413_crm.h:295
CRM_PLL_SOURCE_HEXT_DIV
@ CRM_PLL_SOURCE_HEXT_DIV
Definition: at32f413_crm.h:277
CRM_PLL_MULT_48
@ CRM_PLL_MULT_48
Definition: at32f413_crm.h:251
CRM_AHB_DIV_1
@ CRM_AHB_DIV_1
Definition: at32f413_crm.h:306
CRM_SCLK_PLL
@ CRM_SCLK_PLL
Definition: at32f413_crm.h:395
CRM_APB2_DIV_2
@ CRM_APB2_DIV_2
Definition: at32f413_crm.h:335
CRM_PLL_OUTPUT_RANGE_GT72MHZ
@ CRM_PLL_OUTPUT_RANGE_GT72MHZ
Definition: at32f413_crm.h:286
CRM_PLL_STABLE_FLAG
#define CRM_PLL_STABLE_FLAG
Definition: at32f413_crm.h:57
ERROR
@ ERROR
Definition: at32f413.h:264
FALSE
@ FALSE
Definition: at32f413.h:259
TRUE
@ TRUE
Definition: at32f413.h:259
SET
@ SET
Definition: at32f413.h:254
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: at32f413_int.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c
Go to the documentation of this file.
1
27/* includes ------------------------------------------------------------------*/
28#include "at32f413_int.h"
29
43void NMI_Handler(void)
44{
45}
46
52void HardFault_Handler(void)
53{
54 /* go to infinite loop when hard fault exception occurs */
55 while(1)
56 {
57 }
58}
59
65void MemManage_Handler(void)
66{
67 /* go to infinite loop when memory manage exception occurs */
68 while(1)
69 {
70 }
71}
72
78void BusFault_Handler(void)
79{
80 /* go to infinite loop when bus fault exception occurs */
81 while(1)
82 {
83 }
84}
85
91void UsageFault_Handler(void)
92{
93 /* go to infinite loop when usage fault exception occurs */
94 while(1)
95 {
96 }
97}
98
104void SVC_Handler(void)
105{
106}
107
113void DebugMon_Handler(void)
114{
115}
116
122void PendSV_Handler(void)
123{
124}
125
131void SysTick_Handler(void)
132{
133}
134
UsageFault_Handler
void UsageFault_Handler(void)
this function handles usage fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:91
HardFault_Handler
void HardFault_Handler(void)
this function handles hard fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:52
MemManage_Handler
void MemManage_Handler(void)
this function handles memory manage exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:65
SVC_Handler
void SVC_Handler(void)
this function handles svcall exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:104
PendSV_Handler
void PendSV_Handler(void)
this function handles pendsv_handler exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:122
NMI_Handler
void NMI_Handler(void)
this function handles nmi exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:43
BusFault_Handler
void BusFault_Handler(void)
this function handles bus fault exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:78
SysTick_Handler
void SysTick_Handler(void)
this function handles systick handler.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:131
DebugMon_Handler
void DebugMon_Handler(void)
this function handles debug monitor exception.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/at32f413_int.c:113
at32f413_int.h
header file of main interrupt service routines.


AT32F413 Firmwary Library: main.c Source File

  • utilities
  • at32f413_usb_iap_demo
  • source_code
  • bootloader
  • src
utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c
Go to the documentation of this file.
1
27#include "at32f413_board.h"
28#include "at32f413_clock.h"
29#include "usbd_core.h"
30#include "hid_iap_class.h"
31#include "hid_iap_desc.h"
32#include "hid_iap_user.h"
33#include "usbd_int.h"
34
43 usbd_core_type usb_core_dev;
44
45void usb_clock48m_select(usb_clk48_s clk_s);
46
52void usb_clock48m_select(usb_clk48_s clk_s)
53{
54 if(clk_s == USB_CLK_HICK)
55 {
56 crm_usb_clock_source_select(CRM_USB_CLOCK_SOURCE_HICK);
57
58 /* enable the acc calibration ready interrupt */
59 crm_periph_clock_enable(CRM_ACC_PERIPH_CLOCK, TRUE);
60
61 /* update the c1\c2\c3 value */
62 acc_write_c1(7980);
63 acc_write_c2(8000);
64 acc_write_c3(8020);
65
66 /* open acc calibration */
67 acc_calibration_mode_enable(ACC_CAL_HICKTRIM, TRUE);
68 }
69 else
70 {
71 switch(system_core_clock)
72 {
73 /* 48MHz */
74 case 48000000:
75 crm_usb_clock_div_set(CRM_USB_DIV_1);
76 break;
77
78 /* 72MHz */
79 case 72000000:
80 crm_usb_clock_div_set(CRM_USB_DIV_1_5);
81 break;
82
83 /* 96MHz */
84 case 96000000:
85 crm_usb_clock_div_set(CRM_USB_DIV_2);
86 break;
87
88 /* 120MHz */
89 case 120000000:
90 crm_usb_clock_div_set(CRM_USB_DIV_2_5);
91 break;
92
93 /* 144MHz */
94 case 144000000:
95 crm_usb_clock_div_set(CRM_USB_DIV_3);
96 break;
97
98 /* 168MHz */
99 case 168000000:
100 crm_usb_clock_div_set(CRM_USB_DIV_3_5);
101 break;
102
103 /* 192MHz */
104 case 192000000:
105 crm_usb_clock_div_set(CRM_USB_DIV_4);
106 break;
107
108 default:
109 break;
110
111 }
112 }
113}
114
115
121void USBFS_L_CAN1_RX0_IRQHandler(void)
122{
123 usbd_irq_handler(&usb_core_dev);
124}
125
131void usb_delay_ms(uint32_t ms)
132{
133 /* user can define self delay function */
134 delay_ms(ms);
135}
136
142void usb_delay_us(uint32_t us)
143{
144 delay_us(us);
145}
146
152int main(void)
153{
154 system_clock_config();
155
156 /* config nvic priority group */
157 nvic_priority_group_config(NVIC_PRIORITY_GROUP_4);
158
159 /* iap init */
160 iap_init();
161
162 if(iap_get_upgrade_flag() == IAP_SUCCESS)
163 {
164 jump_to_app(FLASH_APP_ADDRESS);
165 }
166
167 at32_board_init();
168
169 /* select usb 48m clcok source */
170 usb_clock48m_select(USB_CLK_HEXT);
171
172 /* enable usb clock */
173 crm_periph_clock_enable(CRM_USB_PERIPH_CLOCK, TRUE);
174
175 /* enable usb interrupt */
176 nvic_irq_enable(USBFS_L_CAN1_RX0_IRQn, 0, 0);
177
178 /* usb core init */
179 usbd_core_init(&usb_core_dev, USB, &hid_iap_class_handler, &hid_iap_desc_handler, 0);
180
181 /* enable usb pull-up */
182 usbd_connect(&usb_core_dev);
183
184 while(1)
185 {
186 iap_loop();
187 }
188}
189
at32f413_board.h
header file for at-start board. set of firmware functions to manage leds and push-button....
system_clock_config
void system_clock_config(void)
system clock config program
Definition: project/at_start_f413/examples/acc/calibration/src/at32f413_clock.c:48
jump_to_app
iapfun jump_to_app
jump to app
Definition: bootloader/src/iap.c:46
ACC_CAL_HICKTRIM
#define ACC_CAL_HICKTRIM
Definition: at32f413_acc.h:53
acc_write_c2
void acc_write_c2(uint16_t acc_c2_value)
wtire the value to acc c2 register.
Definition: at32f413_acc.c:132
acc_write_c3
void acc_write_c3(uint16_t acc_c3_value)
wtire the value to acc c3 register.
Definition: at32f413_acc.c:142
acc_write_c1
void acc_write_c1(uint16_t acc_c1_value)
wtire the value to acc c1 register.
Definition: at32f413_acc.c:122
acc_calibration_mode_enable
void acc_calibration_mode_enable(uint16_t acc_trim, confirm_state new_state)
enable or disable the acc calibration mode.
Definition: at32f413_acc.c:53
system_core_clock
unsigned int system_core_clock
Definition: system_at32f413.c:48
delay_ms
void delay_ms(uint16_t nms)
inserts a delay time.
Definition: at32f413_board.c:324
at32_board_init
void at32_board_init()
board initialize interface init led and button
Definition: at32f413_board.c:136
delay_us
void delay_us(uint32_t nus)
inserts a delay time.
Definition: at32f413_board.c:304
crm_usb_clock_div_set
void crm_usb_clock_div_set(crm_usb_div_type div_value)
set crm usb division
Definition: at32f413_crm.c:474
crm_periph_clock_enable
void crm_periph_clock_enable(crm_periph_clock_type value, confirm_state new_state)
enable or disable the peripheral clock
Definition: at32f413_crm.c:206
crm_usb_clock_source_select
void crm_usb_clock_source_select(crm_usb_clock_source_type value)
usb 48 mhz clock source select
Definition: at32f413_crm.c:770
CRM_USB_PERIPH_CLOCK
@ CRM_USB_PERIPH_CLOCK
Definition: at32f413_crm.h:138
CRM_ACC_PERIPH_CLOCK
@ CRM_ACC_PERIPH_CLOCK
Definition: at32f413_crm.h:124
CRM_USB_DIV_3
@ CRM_USB_DIV_3
Definition: at32f413_crm.h:364
CRM_USB_DIV_1_5
@ CRM_USB_DIV_1_5
Definition: at32f413_crm.h:359
CRM_USB_DIV_4
@ CRM_USB_DIV_4
Definition: at32f413_crm.h:365
CRM_USB_DIV_3_5
@ CRM_USB_DIV_3_5
Definition: at32f413_crm.h:363
CRM_USB_DIV_2
@ CRM_USB_DIV_2
Definition: at32f413_crm.h:362
CRM_USB_DIV_1
@ CRM_USB_DIV_1
Definition: at32f413_crm.h:360
CRM_USB_DIV_2_5
@ CRM_USB_DIV_2_5
Definition: at32f413_crm.h:361
CRM_USB_CLOCK_SOURCE_HICK
@ CRM_USB_CLOCK_SOURCE_HICK
Definition: at32f413_crm.h:455
USBFS_L_CAN1_RX0_IRQn
@ USBFS_L_CAN1_RX0_IRQn
Definition: at32f413.h:154
TRUE
@ TRUE
Definition: at32f413.h:259
nvic_irq_enable
void nvic_irq_enable(IRQn_Type irqn, uint32_t preempt_priority, uint32_t sub_priority)
enable nvic irq
Definition: at32f413_misc.c:64
nvic_priority_group_config
void nvic_priority_group_config(nvic_priority_group_type priority_group)
config nvic priority group
Definition: at32f413_misc.c:97
NVIC_PRIORITY_GROUP_4
@ NVIC_PRIORITY_GROUP_4
Definition: at32f413_misc.h:71
usb_clock48m_select
void usb_clock48m_select(usb_clk48_s clk_s)
usb 48M clock select
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:52
main
int main(void)
main function.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:152
USBFS_L_CAN1_RX0_IRQHandler
void USBFS_L_CAN1_RX0_IRQHandler(void)
this function handles usb interrupt.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:121
usb_delay_ms
void usb_delay_ms(uint32_t ms)
usb delay millisecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:131
usb_delay_us
void usb_delay_us(uint32_t us)
usb delay microsecond function.
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:142
usb_core_dev
usbd_core_type usb_core_dev
Definition: utilities/at32f413_usb_iap_demo/source_code/bootloader/src/main.c:43
usb_clk48_s
usb_clk48_s
usb clock select
Definition: at32f413_usb.h:231
USB_CLK_HEXT
@ USB_CLK_HEXT
Definition: at32f413_usb.h:233
USB_CLK_HICK
@ USB_CLK_HICK
Definition: at32f413_usb.h:232
IAP_SUCCESS
@ IAP_SUCCESS
Definition: hid_iap_class.h:87
hid_iap_class_handler
usbd_class_handler hid_iap_class_handler
Definition: hid_iap_class.c:57
hid_iap_desc_handler
usbd_desc_handler hid_iap_desc_handler
hid device descriptor handler structure
Definition: hid_iap_desc.c:65
usbd_core_init
void usbd_core_init(usbd_core_type *udev, usb_reg_type *usb_reg, usbd_class_handler *dev_handler, usbd_desc_handler *desc_handler, uint8_t core_id)
initializes the usb core
Definition: usbd_core.c:672
usbd_connect
void usbd_connect(usbd_core_type *udev)
usb device connect to host
Definition: usbd_core.c:561
usbd_irq_handler
void usbd_irq_handler(usbd_core_type *udev)
usb device interrput request handler.
Definition: usbd_int.c:46
USB
#define USB
Definition: at32f413_usb.h:666
iap_init
void iap_init(void)
iap init.
Definition: app_led3_toggle/src/iap.c:61
FLASH_APP_ADDRESS
#define FLASH_APP_ADDRESS
Definition: app_led3_toggle/inc/hid_iap_user.h:49
iap_get_upgrade_flag
iap_result_type iap_get_upgrade_flag(void)
get iap upgrade complete flag
Definition: app_led3_toggle/src/hid_iap_user.c:79
iap_loop
void iap_loop(void)
iap loop
Definition: bootloader/src/hid_iap_user.c:473
hid_iap_class.h
usb hid iap header file
hid_iap_desc.h
usb hid descriptor header file
usbd_core_type
usb device core struct type
Definition: usbd_core.h:110
usbd_core.h
usb device core header file
usbd_int.h
at32f413_clock.h
header file of clock program


AT32F413 Firmwary Library: msc_diskio.h Source File

  • usb_device
  • virtual_msc_iap
  • inc
virtual_msc_iap/inc/msc_diskio.h
Go to the documentation of this file.
1
26/* Define to prevent recursive inclusion -------------------------------------*/
27#ifndef __MSC_DISKIO_H
28#define __MSC_DISKIO_H
29
30#ifdef __cplusplus
31extern "C" {
32#endif
33
34
35#include "usb_conf.h"
36#include "usb_std.h"
37
45#define INTERNAL_FLASH_LUN 0
46#define SPI_FLASH_LUN 1
47#define SD_LUN 2
48
49#define USB_FLASH_ADDR_OFFSET 0x08004000
50
51uint8_t *get_inquiry(uint8_t lun);
52 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len);
53 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len);
54 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size);
55
64#ifdef __cplusplus
65}
66#endif
67
68#endif
69
70
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: virtual_msc_iap/src/msc_diskio.c:97
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: virtual_msc_iap/src/msc_diskio.c:75
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: virtual_msc_iap/src/msc_diskio.c:117
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: virtual_msc_iap/src/msc_diskio.c:59
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
usb_std.h
usb standard header file
usb_conf.h
usb config header file


AT32F413 Firmwary Library: msc_diskio.c Source File

  • usb_device
  • virtual_msc_iap
  • src
virtual_msc_iap/src/msc_diskio.c
Go to the documentation of this file.
1
26#include "msc_diskio.h"
27#include "msc_bot_scsi.h"
28#include "flash_fat16.h"
29
38uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH] =
39{
40 /* lun = 0 */
41 {
42 0x00, /* peripheral device type (direct-access device) */
43 0x80, /* removable media bit */
44 0x00, /* ansi version, ecma version, iso version */
45 0x01, /* respond data format */
46 SCSI_INQUIRY_DATA_LENGTH - 5, /* additional length */
47 0x00, 0x00, 0x00, /* reserved */
48 'A', 'T', '3', '2', ' ', ' ', ' ', ' ', /* vendor information "AT32" */
49 'M', 's', 'c', ' ', 'i', 'a', 'p', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', ' ', /* Product identification "Disk" */
50 '2', '.', '0', '0' /* product revision level */
51 },
52};
53
59uint8_t *get_inquiry(uint8_t lun)
60{
61 if(lun < MSC_SUPPORT_MAX_LUN)
62 return (uint8_t *)scsi_inquiry[lun];
63 else
64 return NULL;
65}
66
75 usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
76{
77
78 switch(lun)
79 {
80 case 0:
81 flash_fat16_read(addr, read_buf, len);
82 break;
83 case 1:
84 break;
85 }
86 return USB_OK;
87}
88
97 usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
98{
99 switch(lun)
100 {
101 case 0:
102 flash_fat16_write(addr, buf, len);
103 break;
104 case 1:
105 break;
106 }
107 return USB_OK;
108}
109
117 usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
118{
119 switch(lun)
120 {
121 case INTERNAL_FLASH_LUN:
122 *blk_nbr = 0x0FFF;
123 *blk_size = FLASH_SECTOR_2K_SIZE;
124 break;
125 case SPI_FLASH_LUN:
126 break;
127 case SD_LUN:
128 break;
129 default:
130 break;
131 }
132 return USB_OK;
133}
134
flash_fat16.h
fat16 file system header file
msc_disk_write
usb_sts_type msc_disk_write(uint8_t lun, uint32_t addr, uint8_t *buf, uint32_t len)
disk write
Definition: composite_vcp_msc/src/msc_diskio.c:102
msc_disk_read
usb_sts_type msc_disk_read(uint8_t lun, uint32_t addr, uint8_t *read_buf, uint32_t len)
disk read
Definition: composite_vcp_msc/src/msc_diskio.c:75
INTERNAL_FLASH_LUN
#define INTERNAL_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:45
msc_disk_capacity
usb_sts_type msc_disk_capacity(uint8_t lun, uint32_t *blk_nbr, uint32_t *blk_size)
disk capacity
Definition: composite_vcp_msc/src/msc_diskio.c:136
SD_LUN
#define SD_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:47
SPI_FLASH_LUN
#define SPI_FLASH_LUN
Definition: composite_vcp_msc/inc/msc_diskio.h:46
get_inquiry
uint8_t * get_inquiry(uint8_t lun)
get disk inquiry
Definition: composite_vcp_msc/src/msc_diskio.c:59
scsi_inquiry
uint8_t scsi_inquiry[MSC_SUPPORT_MAX_LUN][SCSI_INQUIRY_DATA_LENGTH]
Definition: virtual_msc_iap/src/msc_diskio.c:38
NULL
#define NULL
Definition: sd_mmc_card/inc/at32_sdio.h:339
FLASH_SECTOR_2K_SIZE
#define FLASH_SECTOR_2K_SIZE
Definition: flash_fat16.h:63
flash_fat16_write
uint32_t flash_fat16_write(uint32_t fat_lbk, uint8_t *data, uint32_t len)
write a logical block address
Definition: flash_fat16.c:331
flash_fat16_read
uint32_t flash_fat16_read(uint32_t fat_lbk, uint8_t *data, uint32_t len)
read a logical block address
Definition: flash_fat16.c:290
SCSI_INQUIRY_DATA_LENGTH
#define SCSI_INQUIRY_DATA_LENGTH
Definition: cdc_msc_class.h:157
MSC_SUPPORT_MAX_LUN
#define MSC_SUPPORT_MAX_LUN
Definition: cdc_msc_class.h:83
usb_sts_type
usb_sts_type
usb return status
Definition: usb_std.h:275
USB_OK
@ USB_OK
Definition: usb_std.h:276
msc_bot_scsi.h
usb mass storage bulk-only transport and scsi command header file